Intersoft WebTreeView

Intersoft WebTreeView Documentation
Intersoft WebTreeView
Send Feedback

Glossary Item Box

This section contains information about WebTreeView.

In This Section

Getting Started

Walkthrough Topics

FAQ and How-to Topics

Overview

Features and Concepts

Server-side References

Client-side References

Product Support

Licensing


Getting Started

Getting Started
See Also Send Feedback
Intersoft WebTreeView > Getting Started

Glossary Item Box

This section is designated to help you quickly getting started with WebTreeView.NET. You can use all links below to become familiar with WebTreeView.

Installation

The following topics will guide you how to install WebTreeView.NET and what the system requirements you need to have in order to run WebTreeView.NET in your PC.

  • Installation Guide
  • Manually installing WebTreeView to Visual Studio 2005 ToolBox
  • Use Toolbox Utility Tool to add Intersoft Products to Visual Studio toolbox
  • System Requirements

Deployment

This section will help you to configure and set the application in deploying the project to server. It also provides a Deployment Checklist which contains the essential things you need to manage before proceeding to deployment.

  • Deployment Guide
  • Application Wide Configurations

Samples and Walkthroughs

This sections will provide you information to locate the sample and tutorial files of WebTreeView.NET.

  • Locating Sample Files
  • Locating Tutorial Files
  • More Walkthrough Topics

See Also

Tasks
{Walkthrough Topics}
{FAQ and How-to Topics}

Concepts
{Features and Concepts}


Installation

Installation
See Also Send Feedback
Intersoft WebTreeView > Getting Started > Installation

Glossary Item Box

This section contains information on installing WebTreeView.NET and specifying the system requirements needed by the component.

In This Section

Installation Guide
Information about installing WebTreeView.NET on your PC.

Manually installing WebTreeView to Visual Studio 2005 ToolBox
Information about installing WebTreeView control to Visual Studio 2005 ToolBox manually.

Use Toolbox Utility Tool to add Intersoft Products to Visual Studio toolbox
Information about installing WebTreeView control to Visual Studio ToolBox using Toolbox Utility tool.

System Requirements
Read about the Windows version, Visual Studio application, WebUI.NET Framework and other software requirements for installing WebTreeView.NET.

See Also

Other Resources
{Deployment}
{Samples and Walkthroughs}


Installation Guide

Installation Guide
See Also Send Feedback
Intersoft WebTreeView > Getting Started > Installation > Installation Guide

Glossary Item Box

Installation Requirement

For system requirement, please see the System Requirements section.

Installing WebTreeView

Intersoft has released the new setup installer which includes WebUI Framework 3, WebGrid Enterprise 7, WebCombo 4, WebInput 4, WebDesktop 3, WebTreeView, ISDataSource, WebScheduler 3, WebAqua 2, WebTextEditor, WebEssentials and ClientUI components.

Here are the step-by-step instructions to install WebTreeView:

  1. Double click on the "intersoft webui studio 2010 r1.exe" icon to start the installation process. Read the instructions, and click next.

  2. Please read the license agreement. You must accept the terms in the license agreement in order to install WebTreeView.

  3. Fill in your details such as User Name and Organization. Click Next to proceed.

  4. You can select the product edition and setup type that you would like to install and perform.

    The product contains three editions such as WebUI Studio for ASP.NET, WebUI Studio for Silverlight and WebUI Studio for WPF.

  5. You can select the target environment for the samples, either Microsoft Visual Studio 2008 or Microsoft Visual Studio 2010.

  6. You can also customize the Start Menu group and choose to create shortcuts for all users or just for yourself.

  7. Click Next to proceed with the installation process.

  8. The wizard is installing WebUI Studio 2010 R1.

  9. A window showing the installation progress appears. It will list the status of components that are being installed.

  10. After the installation process has been finished, you will see a confirmation window. Click Finish to close the window. At this rate, you have successfully installed the Intersoft WebUI Studio 2010 R1.

  11. To install the full version of WebTreeView, proceed by using License Manager that can be triggered from Start menu >> All Programs >> Intersoft WebUI Studio 2010 R1 >> License Manager.

  12. Intersoft License Manager window will appear. Click "Add License" to proceed to the next step.

  13. Now, Select a product from the combo box. In this case, select WebTreeView Version 1.0.1500 and enter the license according to the component.

  14. Click Add and it will automatically check the license with the server through internet connection. If it is correct, then you have successfully installed the full version of WebTreeView.

See Also

Other Resources
Manually installing WebTreeView to Visual Studio 2005 ToolBox
Use Toolbox Utility Tool to add Intersoft Products to Visual Studio toolbox
{System Requirements}


Manually installing WebTreeView to Visual Studio 2005 ToolBox

Manually installing WebTreeView to Visual Studio 2005 ToolBox
See Also Send Feedback
Intersoft WebTreeView > Getting Started > Installation > Manually installing WebTreeView to Visual Studio 2005 ToolBox

Glossary Item Box

This document provides a step-by-step guidance on how to manually install WebTreeView to Visual Studio 2005 ToolBox.

Step-By Step Instructions

To manually install WebGrid to Visual Studio 2005 ToolBox

  1. Open Visual Studio 2005 application.
  2. Create a new WebSite application.
  3. In the Designer view, refer to the ToolBox on the left side.
  4. Right-click on the ToolBox and choose Add Tab.
  5. Named the Tab as "WebUI Studio.NET".
  6. Right-click on the created Tab and select Choose Items.
  7. Browse and Add ISNet.WebUI.WebTreeView.dll from C:\Program Files\Intersoft Solutions\WebTreeView.NET 1.0\Bin.
  8. Finally, your ToolBox will look like the following:

    ToolBox

See Also

Other Resources
{Installation Guide}
{System Requirements}
Use Toolbox Utility Tool to add Intersoft Products to Visual Studio toolbox


Use Toolbox Utility Tool to add Intersoft Products to Visual Studio toolbox

Use Toolbox Utility Tool to add Intersoft Products to Visual Studio toolbox
See Also Send Feedback
Intersoft WebTreeView > Getting Started > Installation > Use Toolbox Utility Tool to add Intersoft Products to Visual Studio toolbox

Glossary Item Box

This topic provides a step-by-step instruction on how to manually add Intersoft products to Visual Studio Toolbox using Toolbox Utility tool.

To add Intersoft products to Visual Studio Toolbox

  1. Run Intersoft ToolBox Utility for Visual Studio from Start Menu >> All Programs >> Intersoft WebUI Studio 2010 R1 >> Intersoft ToolBox Utility for Visual Studio or you can access ToolBoxUtility.exe from [Installation Folder]\Intersoft Solutions\Intersoft WebUI Studio 2010 R1\ToolBoxUtility
  2. Select on the Visual Studio platform you want Intersoft products to be installed. By default, it will automatically select all Visual Studio versions installed on your PC.

  3. Click Register to run the tool and wait until the process is finished.

  4. Finally, open your project and you will notice that Intersoft products has been installed successfully into Visual Studio Toolbox.

See Also

Other Resources
{Installation Guide}
{System Requirements}
{Manually installing WebTreeView to Visual Studio 2005 ToolBox}


System Requirements

System Requirements
See Also Send Feedback
Intersoft WebTreeView > Getting Started > Installation > System Requirements

Glossary Item Box

Development Machine Requirements

  • Microsoft Windows Vista
  • Microsoft Windows 2000/2003/2008 Server family
  • Microsoft Windows XP Professional or Home Edition
  • Microsoft .NET Framework v2.0 or higher
  • Microsoft Visual Studio 2005 Professional/Team Studio/Express Edition
  • Microsoft Visual Studio 2008
  • Intersoft WebUI.NET Framework v3.0 or higher

Server Machine Requirements

  • Windows Server 2003 Enterprise
  • Windows Server 2003 Web Edition
  • Windows Server 2008
  • Internet Information Services 6.0 or later
  • Microsoft .NET Framework Version 2.0 or later
  • Intersoft WebUI.NET Framework v3.0 or higher

Client Machine Requirements

  • Microsoft Internet Explorer 5.5 or higher
  • Mozilla V1.7 +for Windows/Mac/Linux/Solaris
  • Firefox V1.0+ for Windows/Mac/Linux/Solaris
  • Netscape V7.0+ for Windows/Mac/Linux/Solaris
  • Opera 9.5+ for Windows/Mac/Linux/Solaris/FreeBSD/BeOS/QNX
  • Apple Safari 3+ for Windows/Mac

See Also

Other Resources
{Installation Guide}
{Manually installing WebGrid to Visual Studio 2005 ToolBox}
Use Toolbox Utility Tool to add Intersoft Products to Visual Studio toolbox


Deployment

Deployment
See Also Send Feedback
Intersoft WebTreeView > Getting Started > Deployment

Glossary Item Box

This section contains information on configuring the application and guiding user with a step-by-step Checklist instructions for deployment purposes.

In This Section

Deployment Guide
Information about Deployment Checklist that will list all the important tasks you need to do before deploying the project.

Application Wide Configurations
Read about the WebGrid's ability to configure deployment-related properties via web.config, such as ScriptDirectory and many others.

See Also

Other Resources
{Installation}
{Samples and Walkthroughs}


Deployment Guide

Deployment Guide
Send Feedback
Intersoft WebTreeView > Getting Started > Deployment > Deployment Guide

Glossary Item Box

This section continues to guide you on how to deploy the project by using Deployment Manager and SmartWebResources™.

In This Section

Using Deployment Manager
Learn how to use deployment manager to set the web.config.

Deploying project that uses SmartWebResources™
Information about deploying project using SmartWebResources™.

Deploying project that does not use SmartWebResources™
Information about deploying project without using SmartWebResources™. In other words, you need to copy CommonLibrary, project's directory and assemblies.


Using Deployment Manager
See Also Send Feedback
Intersoft WebTreeView > Getting Started > Deployment > Deployment Guide > Using Deployment Manager

Glossary Item Box

Intersoft comes up with a new hassle-free Deployment Manager that is designated to help developers to easily manage configurations during deployment phase.

Now, you can quickly configure the common settings required in deployment such as entering runtime license keys, view state configurations and others through user-friendly Windows GUI application.

Using Deployment Manager

Here are the step-by-step instructions to use Deployment Manager:

  1. Open Deployment Manager from Start menu >> All Programs >> Intersoft WebUI Studio.NET 2007 R2 >> WebUI.NET Framework 3.0 >> Deployment Manager.
  2. Click Browse and select the project's directory of your web application to be configured. Click Next afterwards.

  3. Tick WebTreeView.NET 1.0.1500 and put the Runtime License key according to the component. Click Next to proceed to the next step.

  4. In this step, there are many settings you can configure such as View State Storage, Optimization, Client Resources and Advanced sections.

    View State Storage Section

    View State Storage section lets you configure how ViewState is stored, specify how ViewState items are going to be saved in ViewState and determine the priority and duration of items stored in Cache object.

    Optimization Section

    Optimization section lets you choose whether to enable CSS Optimization and XML compression.

    Client Resources Section

    This section contains information on how to enable WebResources and set its mode.

    If you have applied SmartWebResources™ in your project, this option will be automatically selected with its default mode set to Auto.

  5. Click Next or Apply to save the configuration. Finally, the web.config has been updated successfully. Click Close to apply the settings.

See Also

Other Resources
{Deploying project that uses SmartWebResources™}
{Deploying project that does not use SmartWebResources™}
{Application Wide Configurations}

WebUI.NET Framework Reference
New SmartWebResources Framework


Deploying project that uses SmartWebResources™
See Also Send Feedback
Intersoft WebTreeView > Getting Started > Deployment > Deployment Guide > Deploying project that uses SmartWebResources™

Glossary Item Box

Intersoft Solutions constantly conduct extensive research and development to deliver new innovations that help developers become more productive by reducing the efforts and overwhelming complexity in both development and deployment stage.

SmartWebResources™ Framework is one of the great technology offered by Intersoft, which is used to eliminate the external physical resources such as scripts, images, etc.

WebTreeView.NET Deployment Checklist

  1. RuntimeLicenseKey
    This is a key required in order to license the components for deployment purpose in production environment.

    Runtime license key is different with design-time license key that you get during purchase. Please obtain each licensed component's RuntimeLicenseKey from Intersoft Developer Network under My Component section. You only need to obtain once and reuse it in multiple projects. The login detail is provided in your purchase receipt. If you purchased from our resellers, it may take 24-48 hours for the verification and account creation process.

  2. Resources Assembly
    Ensure that you have copied the resources assemblies to your project's bin folder. The resources assembly can be found in C:\Program Files\Intersoft Solutions\WebTreeView.NET 1.0\Bin. The resources assemblies are:
    * ISNet.WebUI.WebTreeView.Resources.dll
  3. Framework Assemblies
    You are required to copy framework assemblies to your project's bin folder. The framework assemblies can be found in C:\Program Files\Intersoft Solutions\WebUI.NET Framework 3.0\Bin (Default installation directory). The framework assemblies are:
    * ISNet.dll
    * ISNet.WebUI.dll
  4. Component Assembly
    Component assembly is required to be copied to your project's bin folder. The component assembly can be found in C:\Program Files\Intersoft Solutions\WebTreeView.NET 1.0\Bin. The component assembly is:
    * ISNet.WebUI.WebTreeView.dll

Deploying project that uses SmartWebResources™

Here are step-by-step instructions to deploy the project using SmartWebResources™:

  1. Before deploying the project, you have to configure SmartWebResources after you created a new web application. Click here for guidance.
  2. Next, you need to use Deployment Manager in order to set the web.config of your web application, such as defining Runtime License key. Please read Using Deployment Manager for more information.
  3. Finally, you simply need to XCopy all required web application files along with the bin folder (i.e. your project's directory) to a destination folder in your web server.

See Also

Other Resources
{Deploying project that does not use SmartWebResources™}
{Application Wide Configurations}

WebUI.NET Framework Reference
New SmartWebResources Framework


Deploying project that does not use SmartWebResources™

Deploying project that does not use SmartWebResources™
See Also Send Feedback
Intersoft WebTreeView > Getting Started > Deployment > Deployment Guide > Deploying project that does not use SmartWebResources™

Glossary Item Box

General

WebTreeView.NET is built on the top of WebUI.NET Framework. It includes the common concept, functionalities and features implemented in the framework level.

WebTreeView.NET Deployment Checklist

  1. RuntimeLicenseKey.
    This is a key required in order to license the components for deployment purpose in production environment.

    Runtime license key is different with design-time license key that you get during purchase.

    Use Deployment Manager to set the project's Web.config. There are 2 important things you need to notice:

    - If you set CommonLibrary folder as IIS Virtual Directory in development machine, you may refer to Using Deployment Manager topic for guidance.

    - If you copy the CommonLibrary folder to the project's directory in development machine, you may refer to Using Deployment Manager topic under Advanced section for guidance.

    Please obtain each licensed component's RuntimeLicenseKey from Intersoft Developer Network under My Component section. You only need to obtain once and reuse it in multiple projects. The login detail is provided in your purchase receipt. If you purchased from our resellers, it may take 24-48 hours for the verification and account creation process.
  2. CommonLibrary
    All subfolders and files inside CommonLibrary folder is required.
  3. Framework Assemblies.
    You are required to copy framework assemblies to your project's bin folder. The framework assemblies can be found in C:\Program Files\Intersoft Solutions\WebUI.NET Framework 3.0\Bin (Default installation directory). The framework assemblies are as following:
    * ISNet.dll
    * ISNet.WebUI.dll
  4. Component Assembly
    Component assembly is required to be copied to your project's bin folder. The component assembly can be found in C:\Program Files\Intersoft Solutions\WebTreeView.NET 1.0\Bin. The component assembly is:
    * ISNet.WebUI.WebTreeView.dll

WebTreeView.NET Deployment Guide

  1. If you set CommonLibrary folder as IIS Virtual Directory in development machine
    - XCopy all your required web application files along with the bin folder (i.e. your project's directory) to a destination folder in your web server.
    - XCopy the CommonLibrary folder to your web server. It is recommended to place it under wwwroot folder (usually c:\inetpub\wwwroot). You need to map the destination folder to IIS Virtual Directory with name "CommonLibrary".
  2. If you copy the CommonLibrary folder to the project's directory in development machine
    - XCopy all your required web application files along with the bin and CommonLibrary folders (i.e. your project's directory) to a destination folder in your web server.

    Creating CommonLibrary as IIS Virtual Directory is not required in this case.

See Also

Other Resources
{Deploying project that uses SmartWebResources™}
{Application Wide Configurations}

WebUI.NET Framework Reference
New SmartWebResources Framework


Application Wide Configurations

Application Wide Configurations
See Also Send Feedback
Intersoft WebTreeView > Getting Started > Deployment > Application Wide Configurations

Glossary Item Box

One of the unique features introduced since the initial products is the ability to configure specific deployment-related properties via web.config. WebUI.NET Framework further enhanced this capability by adding more properties which are configurable through web.config. Now, it also supports relative application path by using ~ character. The application-wide configurations feature allows centralized configuration for common deployment properties such as ScriptDirectory etc, which dramatically increase effectiveness and efficiency particularly for maintenance purpose.

Following is the list of properties that are configurable through web.config:

  • SharedScriptDirectory
  • ScriptDirectory
  • ImagesDirectory

The settings specified in web.config will only be applied to instances' properties that have Default value (unchanged).
The format of the key used for the configuration is AssemblyFullName.vProductVersion.Properties.

Examples:

The sample configuration in web.config below will change the property value of ScriptDirectory, ImagesDirectory, SharedScriptDirectory and LocalizationDirectory to all WebTreeView V1.0.1500 instances in the application.

<configuration>

<appSettings>

<add key="ISNet.WebUI.WebTreeView.v1_0_1500.ScriptDirectory" value="~/CommonLibrary/WebTreeView/V1_0_1500/" />

<add key="ISNet.WebUI.WebTreeView.v1_0_1500.ImagesDirectory" value="~/CommonLibrary/Images/" />

<add key="ISNet.WebUI.WebTreeView.v1_0_1500.SharedScriptDirectory" value="/CommonLibrary/Shared/" />

</appSettings>

... other settings

</configuration>

Additional application-wide configurations may be available specifically per product. Please refer to the Application-wide Configurations topic in the product's help file.

See Also

Other Resources
{Deployment Guide}

WebUI.NET Framework Reference
How-to: Use file server for an instance of control


Samples and Walkthroughs

Samples and Walkthroughs
See Also Send Feedback
Intersoft WebTreeView > Getting Started > Samples and Walkthroughs

Glossary Item Box

This section contains information about location of sample and tutorial files, example codes and how to use WebTreeView in Visual Studio 2005.

In This Section

Locating Sample Files
Discover the locations where sample files are stored on your computer or the installation source.

Locating Tutorial Files
Discover the locations where tutorial files are stored on your computer or the installation source.

More Walkthrough Topics
Lists complete walkthrough topics available in WebTreeView.

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Other Resources
{Features and Concepts}


Locating Sample Files

Locating Sample Files
See Also Send Feedback
Intersoft WebTreeView > Getting Started > Samples and Walkthroughs > Locating Sample Files

Glossary Item Box

The default locations for Sample files in this release are listed below. %install% represents the location where Intersoft's components are installed, such as \Program Files\Intersoft Solutions\.

Product | Sample Location
WebGrid.NET Enterprise C# Samples (Visual Studio 2005 Solution) | C:\%install%\Intersoft WebUI Studio.NET 2007 R2\ISNet.WebUI.Samples\cs
WebGrid.NET Enterprise VB Samples (Visual Studio 2005 Solution) | C:\%install%\Intersoft WebUI Studio.NET 2007 R2\ISNet.WebUI.Samples\vb

See Also

Tasks
{Walkthrough Topics}
{FAQ and How-to Topics}

Other Resources
{Locating Tutorial Files}


Locating Tutorial Files

Locating Tutorial Files
See Also Send Feedback
Intersoft WebTreeView > Getting Started > Samples and Walkthroughs > Locating Tutorial Files

Glossary Item Box

The default locations for Tutorial files in this release are listed below. %install% represents the location where Intersoft's components are installed, such as \Program Files\Intersoft Solutions\.

Product | Sample Location
WebGrid.NET Enterprise C# Tutorials (Visual Studio 2005 Solution) | C:\%install%\WebGrid.NET 6.0\Tutorials
WebGrid.NET Enterprise VB Tutorials (Visual Studio 2005 Solution) | C:\%install%\WebGrid.NET 6.0\Tutorials

See Also

Tasks
Walkthrough Topics
FAQ and How-to Topics

Other Resources
{Locating Sample Files}


WebTreeView Walkthroughs

WebTreeView Walkthroughs
Send Feedback
Intersoft WebTreeView > Getting Started > Samples and Walkthroughs > WebTreeView Walkthroughs

Glossary Item Box

The walkthrough introduces the important basic area of WebTreeView component. It discusses the development of binding WebTreeView for the first time, how to set up xml data and the animation using a series of step-by-step instructions.

In This Section

Walkthrough: Getting started with WebTreeView
Demonstrates how to create a WebTreeView control from the beginning.

More Walkthrough Topics
Lists complete walkthrough topics available in WebAqua.


Walkthrough: Getting started with WebTreeView

Walkthrough: Getting started with WebTreeView
See Also Send Feedback
Intersoft WebTreeView > Getting Started > Samples and Walkthroughs > WebTreeView Walkthroughs > Walkthrough: Getting started with WebTreeView

Glossary Item Box

This walkthrough shows you how to create and display WebTreeView control.

During this walkthrough, you will learn how to do the following:

  • Use SmartTag to register SmartWebResources™.
  • Use WebTreeView.NET Designer to set all settings, such as node animation.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Visual Studio 2005 Application.

Step-By-Step Instructions

To create new web application and display WebFishEye control

  1. Launch Visual Studio.NET 2005.
  2. Click on File menu, then select New and click Web Site.
  3. Select ASP.NET Web Site in the Template box and set Location to HTTP.
  4. Named the Web Site and click OK.
  5. Right-click on Project's name and select Add New Item.
  6. Select Intersoft AppForm in the My Templates box and named it as Walkthrough.aspx.
  7. Drag WebTreeView instance from ToolBar to WebForm.
  8. Open SmartTag and select Register SmartWebResources™ to register all images and scripts needed for the WebTreeView control.
  9. Right click on App_Data and choose Add New Item. Create an XML File and named it as Desktop.xml.
  10. In Desktop.xml, put the following code:

    Xml Copy Image Copy Code
    <?xml version="1.0" encoding="utf-8" ?>
<Root name="Desktop">
  <Group name="My Documents">
    <Group name="Music">
    </Group>
    <Group name="Pictures">
    </Group>
    <Group name="My Received Files">
    </Group>
  </Group>
  <Group name="My Computer">
    <Group name="3½ Floppy (A:)">
    </Group>
    <Group name="Local Disk (C:)">
    </Group>
    <Group name="Local Disk (D:)">
    </Group>
    <Group name="Local Disk (E:)">
    </Group>
  </Group>
  <Group name="My Network Places">
  </Group>
</Root>

  11. Open SmartTag and select <New data source..> in Choose Data Source field. The Data Source Configuration Wizard will appear.
  12. Choose XML File and click OK afterwards. In Data File section, click Browse to get the Desktop.xml from App_Data folder.
  13. In SmartTag, choose Edit TreeNode Databindings and the Databindings Editor will appear.
  14. Add the Root and Groups, and set the TextField to name respectively. Do not forget to select Auto-generate data binding in order to bind the data. Click OK to apply the settings.

  15. Right click on WebTreeView control and choose Properties.
  16. Set ExpandedDepth to -1 in order to display the expanded data in WebTreeView.

  17. Finally, save and run the project. It will look like following:

See Also

Tasks
{Walkthrough: Enabling WebTreeView to accept data items from WebGrid control}
{Walkthrough: Binding TreeView to XmlDataSource}
{Walkthrough: Binding TreeView to SiteMapDataSource}
{Walkthrough Topics}
{FAQ and How-to Topics}


More Walkthrough Topics

More Walkthrough Topics
See Also Send Feedback
Intersoft WebTreeView > Getting Started > Samples and Walkthroughs > WebTreeView Walkthroughs > More Walkthrough Topics

Glossary Item Box

To learn more about WebTreeView's advanced features, please see Complete Walkthrough Topics.

See Also

Tasks
{FAQ and How-to Topics}


What's New in WebTreeView

What's New in WebTreeView
Send Feedback
Intersoft WebTreeView > What's New in WebTreeView

Glossary Item Box

This section describes the new features and technologies added in WebTreeView. Here are the following list of new features supported by WebTreeView:

Support HTML5 and CSS3

WebTreeView has been refined to fully support the latest web standards. This allows you to use many of the WebTreeView features in your next-generation web applications and at the same time leveraging cutting-edge technologies such as HTML5 and CSS3.

  • To learn how to enable HTML5 rendering mode in WebTreeView, see How to: Enable HTML5 Rendering Mode.

New style variety

New variety of WebTreeView’s style, Metro Style


How to: Enable HTML5 Rendering Mode

How to: Enable HTML5 Rendering Mode
Send Feedback
Intersoft WebTreeView > What's New in WebTreeView > How to: Enable HTML5 Rendering Mode

Glossary Item Box

This topic explains how to configure WebTreeView to emit HTML5 compliance output.

Configure Doc Type

Each doctype declaration in HTML specification produces different results and behaviors, mostly in the layout and rendering aspects. WebTreeView supports most commonly used doctype and automatically adjust the behaviors and rendering results by detecting the doctype declaration of the HTML page.

WebTreeView has been significantly enhanced to deliver consistent behaviors and layout in HTML5 pages. All features should work exactly as in other doctype.

To enable HTML5 support in WebTreeView, make sure you have configured the HTML pages to use the proper doctype. The standard doctype for HTML5 is <!DOCTYPE html>.

The following code example shows how to use WebTreeView in a simple WebForm using HTML5 doctype.

ASPX Copy Code
<%@ Page Language="C#" AutoEventWireup="true" CodeFile="Default.aspx.cs" Inherits="Default" %>
<%@ Register Assembly="ISNet.WebUI.WebTreeView" Namespace="ISNet.WebUI.WebTreeView" TagPrefix="ISWebTreeView" %>

<!DOCTYPE html>
<html>
<head runat="server">
    <title></title>
</head>
<body>
    <form id="form1" runat="server">
    <div>
         <ISWebTreeView:WebTreeView ID="WebTreeView1" runat="server">
         </ISWebTreeView:WebTreeView>
    </div>
    </form>
</body>
</html>

Note that the xmlns attribute is no longer necessary to be defined in the <html> tag. If you upgraded your existing pages, make sure the xmlns attribute is removed from the <html> tag.

Also, to enable percentage height in HTML5, you must define its height in body and html element. Here's the example

ASPX Copy Code
<head runat="server">
    <title></title>
    <style type="text/css">
    html, body
    {
        height: 100%;
        width: 100%;
        margin: 0;
        padding: 0;
    }
    </style>
</head>

In HTML5, height of an element is refer to its parent's height so this is necessary to define its parent element.

Configure Rendering Mode

To provide the best HTML5 support, WebInput needs to adjust several features that are commonly processed in the server-side such as markup rendering and AJAX callback response. Unfortunately, the HTML5 doctype cannot be automatically detected by the server-side browser capability. As such, WebTreeView introduces a new property called RenderingMode which you must set explicitly in order to activate HTML5 compliance output.

You can set the rendering mode in a WebTreeView instance individually by setting the RenderingMode property to HTML5 value, which is shown in the example below.

ASPX Copy Code
<ISWebTreeView:WebTreeView ID="WebTreeView1" runat="server" RenderingMode="HTML5">
</ISWebTreeView:WebTreeView>

Alternatively, you can also apply the rendering mode globally through the application-wide configuration, see the following example.

Web.config Copy Code
<add key="ISNet.WebUI.WebTreeView.v1_0_1500.RenderingMode" value="HTML5"/>
If your project is exclusively targeting HTML5, it's recommended to use application-wide configuration to apply the rendering mode to all WebTreeView instances in the project.

For more information about application-wide settings in WebTextEditor, see Application Wide Configurations.


Walkthrough Topics

Walkthrough Topics
See Also Send Feedback
Intersoft WebTreeView > Walkthrough Topics

Glossary Item Box

The following list of walkthrough topics demonstrates how to use all features in WebTreeView and how to manipulate WebTreeView into some complex structures.

Getting Started with WebTreeView

The topic in this category provides information about creating a simple application using WebTreeView.NET.

  • Walkthrough: Getting started with WebTreeView

Drag and Drop - Integration with WebDragDropExtender component

The topic in this category provides information about enabling WebTreeView to accept data from WebGrid control.

  • Walkthrough: Enabling WebTreeView to accept data items from WebGrid control

Data Binding

The topics in this category provide information about binding TreeView to XmlDataSource and SiteMapDataSource.

  • Walkthrough: Binding TreeView to XmlDataSource
  • Walkthrough: Binding TreeView to SiteMapDataSource

See Also

Tasks
{How-to Topics}

Other Resources
{Features and Concepts}


FAQ and How-to Topics

FAQ and How-to Topics
See Also Send Feedback
Intersoft WebTreeView > FAQ and How-to Topics

Glossary Item Box

The following list of How-to topics describes how to implement various features and enhancements in WebTreeView.

General Features

The topics in this category provide direct instructions on how to apply some general features in WebTreeView.NET.

  • How-to: Apply Multiple Nodes Selection
  • How-to: Select Nodes on First Load
  • How-to: Check and uncheck selected node
  • How-to: Check and uncheck selected node with its children
  • How-to: Check and uncheck all nodes in WebTreeView
  • How-to: Get selected nodes
  • How-to: Change the currently selected node's text and tooltip
  • How-to: Enable and disable a WebTreeViewNode
  • How-to: Integrate WebTreeView with WebContextMenu

Data Binding

The topics in this category provide direct instructions on how to bind TreeView with Xml and SiteMap DataSource controls and create unbound TreeView.

  • How-to: Create unbound TreeView using both editor and server side code

Hassle-free deployment through SmartWebResources™ technology

The topics in this category provide direct instructions on how to use SmartWebResources™ in a new web application.

  • How-to: Configure SmartWebResources in a new web application
  • FAQ: Does SmartWebResources feature automatically enabled in WebTreeView.NET?

Drag Drop

The topics in this category provide direct instructions on how to drag and drop with Multiple Selection and between TreeView.

  • How-to: Drag and drop with Multiple Selection
  • How-to: Drag and drop between TreeView

Drag and Drop - Auto Postback on DragDrop

The topics in this category provide direct instructions on how to set auto postback and handle server side on drag drop operation.

  • How-to: Set auto postback on drag drop operation
  • How-to: Handle server side OnDragDrop event

Drag and Drop - Integration with WebDragDropExtender component

The topic in this category provides a direct instruction on how to enable drag behavior in WebTreeView using WebDragDropExtender.

  • How-to: Enable drag behavior in WebTreeView with ability to drop into Panel control using WebDragDropExtender

TriState CheckBox and Normal CheckBox

The topics in this category provide direct instructions on how to configure Tristate CheckBox in WebTreeView.NET.

  • How-to: Create a simple WebTreeView with TriState CheckBox
  • How-to: Get checked Nodes in TriState CheckBox

Load on Demand

The topics in this category provide direct instructions on how to use Load on Demand in WebTreeView.NET.

  • How-to: Enable Load on Demand

Advanced Load on Demand

The topic in this category provides a direct instruction on how to add TreeViewNodes based on retrieved data

  • How-to: Add TreeViewNodes based on retrieved data (Load On Demand)

Keyboard Navigation

The topic in this category provides a direct instruction on how to use keyboard navigation in WebTreeView.NET.

  • How-to: Enable keyboard nagivation

Path

The topic in this category provides a direct instruction on how to find node by path using client side API.

  • How-to: Find node by path

Automatically select a node on expand or collapse

The topics in this category provide direct instructions on how to perform various expand and collapse features in WebTreeView.NET.

  • How-to: Expand and collapse by selecting the nodes
  • How-to: Automatically select node on expand and collapse
  • How-to: Expand and collapse the selected node
  • How-to: Toggle expand collapse of the selected node
  • How-to: Expand and collapse the selected node with its children
  • How-to: Expand and collapse all nodes in WebTreeView

Customizing styles, appearance and images

The topics in this category provide direct instructions on how to customize WebTreeView's styles, appearances and images.

  • How-to: Customize loading style and text
  • How-to: Specify +/- (plus/minus) sign
  • How-to: Specify text image
  • How-to: Show/hide TreeView lines

Node Editing

The topics in this category provide direct instructions on how to add, edit and remove node in WebTreeView.NET

  • How-to: Add node in WebTreeView
  • How-to: Edit node in WebTreeView
  • How-to: Remove node in WebTreeView

Using NavigateURL and Target

The topic in this category provides a direct instruction on how to configure NavigateURL and Target properties.

  • How-to: Configure NavigateURL and Target properties

Advanced Data Binding

The topic in this category provides a direct instruction on how to apply advanced databinding in WebTreeView.NET.

  • How-to: Use Advanced WebTreeView.NET® 1.0 DataBinding

PostBack Settings

The topics in this category provide direct instructions on how to enable Auto Postback on nodes's select and update all client-side modification to xml file.

  • How-to: Enable AutoPostBack on node's select action
  • How-to: Update all client-side modification to physical Xml file (Batch Update)

See Also

Tasks
{Walkthrough Topics}

Other Resources
WebTreeView Overview
Features and Concepts


Overview

Overview
See Also Send Feedback
Intersoft WebTreeView > Overview

Glossary Item Box

WebTreeView.NET® 1.0 is Intersoft's latest ASP.NET server control which enables you to easily create a hierarchical data presentation. This powerful control incorporates numerous unique features which makes WebTreeView.NET® 1.0 flexible and highly customizable to meet your design needs.

WebTreeView.NET® 1.0 is loaded with many features which make it the best tree view control in the industry. These features are as followed:

  • Rock-solid client side architecture enables high-performance OOP-based TreeView control.
  • Supports databinding to Hierarchical DataSourceControl (such as XmlDataSource and SiteMapDataSource) in both design and runtime.
  • The unique Tristate checkbox and of course support the two-state checkbox
  • The ability to load the child nodes on demand. This technique, called Load on Demand will give you performance boost while working with large hierarchical data presentation.
  • The ability to drag and drop a node to a root node, child node, or sibling node.
  • Keyboard navigation provides your end users with the ability to control the node selection by using keyboard
  • Find a node based on its path.
  • Built-in animation during expanding or collapsing the node.

Web-based Vista Explorer's tree view is just a simple sample of our WebTreeView.NET ® 1.0

This fully-featured control will benefit the developers in creating a powerful data hierarchical presentation, window-to-window navigation and also structural navigation. This, of course, will help the developers deliver simple, yet powerful tree view control to the customer.

In This Section

How-to: Apply Multiple Nodes Selection

How-to: Select Nodes on First Load

How-to: Check and uncheck selected node

How-to: Check and uncheck selected node with its children

How-to: Check and uncheck all nodes in WebTreeView

How-to: Get selected nodes

How-to: Change the currently selected node's text and tooltip

How-to: Enable and disable a WebTreeViewNode

See Also

Tasks
{Walkthrough Topics}
{FAQ and How-to Topics}

Other Resources
{Getting Started}
{Features and Concepts}


How-to: Apply Multiple Nodes Selection

How-to: Apply Multiple Nodes Selection
See Also Send Feedback
Intersoft WebTreeView > Overview > How-to: Apply Multiple Nodes Selection

Glossary Item Box

You can set WebTreeView to apply multiple nodes selection.

This topic will show you how to apply multiple nodes selection on WebTreeView.

To apply multiple nodes selection

  1. Click WebTreeView instance and press F4 to open its properties window.
  2. Set the AllowMultipleSelect property to True.
  3. Run the project. Press and hold the SHIFT button to select the nodes in a row and press and hold the CTRL button to select the nodes individually.

See Also

Tasks
{How-to: Select Nodes on First Load}
{How-to: Get selected nodes}
{How-to: Check and uncheck nodes in WebTreeView}
{How-to: Check and uncheck selected node with its children}
{How-to: Enable and disable a WebTreeViewNode}
{How-to: Check and uncheck selected node}
{How-to: Change the currently selected node's text and tooltip}

Concepts
WebTreeView Overview


How-to: Select Nodes on First Load

How-to: Select Nodes on First Load
See Also Send Feedback
Intersoft WebTreeView > Overview > How-to: Select Nodes on First Load

Glossary Item Box

You can set WebTreeView to select nodes on first load.

This topic will show you how to select WebTreeView's nodes on first load.

To select nodes on first load

  1. Right click on WebTreeView instance and choose Properties to show Properties Window.
  2. Click the Collection button in DataBindings property to show WebTreeView DataBindings Editor.
  3. In Selected data bindings section, select on one of the nodes.
  4. For bound WebTreeView you can fill the SelectedField and for Unbound WebTreeView, you can only fill the Selected properties.
  5. Run the project.

See Also

Tasks
{How-to: Apply Multiple Nodes Selection}
{How-to: Get selected nodes}
{How-to: Change the currently selected node's text and tooltip}
{How-to: Enable and disable a WebTreeViewNode}
{How-to: Check and uncheck selected node with its children}
{How-to: Check and uncheck selected node}
{How-to: Check and uncheck nodes in WebTreeView}

Concepts
WebTreeView Overview


How-to: Check and uncheck selected node

How-to: Check and uncheck selected node
See Also Send Feedback
Intersoft WebTreeView > Overview > How-to: Check and uncheck selected node

Glossary Item Box

WebTreeView provides a feature to check and uncheck selected node in WebTreeView via client side.

In this topic, you will learn how to implement the above scenario.

To check and uncheck selected node

  1. Bind WebTreeView to XMLDataSource. Please use Sports.xml (You can get the xml from LiveSamples's AppData folder).
  2. Drag and drop 4 HTML buttons to the page.
  3. Button1 and Button2 will perform checking and unchecking selected node with Check() and UnCheck() methods.
  4. Button3 and Button4 will perform checking and unchecking specific node's item with SetChecked() method.
  5. Implement onclick client side event for each button like following:

    JavaScript Copy Image Copy Code
    // Add this code to Check selected node's button
function Button1_onclick()
{
   var tv = ISGetObject("WebTreeView1");

   if (tv.GetSelectedNode()!=null)
      tv.GetSelectedNode().Check();
   else
      alert("Please select a node");
}

// Add this code to Uncheck selected node's button
function Button2_onclick()
{
   var tv = ISGetObject("WebTreeView1");

   if (tv.GetSelectedNode()!=null)
      tv.GetSelectedNode().UnCheck();
   else
      alert("Please select a node");
}

// Add this code to Check 'Outdoor Sports' node's button
function Button3_onclick()
{
   var tv = ISGetObject("WebTreeView1");
   tv.GetNodes().GetNamedItem("Sports").GetNodes().GetNamedItem("Outdoor Sports").SetChecked(true);
}

// Add this code to Uncheck 'Outdoor Sports' node's button
function Button4_onclick()
{
   var tv = ISGetObject("WebTreeView1");
   tv.GetNodes().GetNamedItem("Sports").GetNodes().GetNamedItem("Outdoor Sports").SetChecked(false);
}

  6. Run the application and try to click each button to see the result. For more information, please refer to Checked Nodes samples in LiveSamples >> WebTreeView >> Client Programmability.

See Also

Tasks
{How-to: Apply Multiple Nodes Selection}
{How-to: Select Nodes on First Load}
{How-to: Check and uncheck selected node with its children}
{How-to: Check and uncheck all nodes in WebTreeView}
{How-to: Get selected nodes}
{How-to: Change the currently selected node's text and tooltip}
{How-to: Enable and disable a WebTreeViewNode}

Concepts
WebTreeView Overview


How-to: Check and uncheck selected node with its children

How-to: Check and uncheck selected node with its children
See Also Send Feedback
Intersoft WebTreeView > Overview > How-to: Check and uncheck selected node with its children

Glossary Item Box

WebTreeView provides a feature to check and uncheck selected node with its children in WebTreeView via client side.

In this topic, you will learn how to implement the above scenario.

To check and uncheck selected node with its children

  1. Bind WebTreeView to XMLDataSource. Please use Sports.xml (You can get the xml from LiveSamples's AppData folder).
  2. Drag and drop 2 HTML buttons to the page.
  3. Button1 and Button2 will perform checking and unchecking selected node and its children with GetSelectedNode() along CheckAll() and UnCheckAll() methods.
  4. Implement onclick client side event for each button like following:

    Javascript Copy Image Copy Code
    // Add this code to Check selected node and its children
function Button1_onclick()
{
   var tv = ISGetObject("WebTreeView1");
   if (tv.GetSelectedNode()!=null)
      tv.GetSelectedNode().CheckAll();
   else
      alert("Please select a node");
}

// Add this code to Uncheck selected node and its children
function Button2_onclick()
{
   var tv = ISGetObject("WebTreeView1");
   if (tv.GetSelectedNode()!=null)
      tv.GetSelectedNode().UnCheckAll();
   else
      alert("Please select a node");
}

  5. Run the application and try to click each button to see the result. For more information, please refer to Checked Nodes samples in LiveSamples >> WebTreeView >> Client Programmability.

See Also

Tasks
{How-to: Apply Multiple Nodes Selection}
{How-to: Select Nodes on First Load}
{How-to: Check and uncheck selected node}
{How-to: Check and uncheck all nodes in WebTreeView}
{How-to: Get selected nodes}
{How-to: Change the currently selected node's text and tooltip}
{How-to: Enable and disable a WebTreeViewNode}

Concepts
WebTreeView Overview


How-to: Check and uncheck all nodes in WebTreeView

How-to: Check and uncheck all nodes in WebTreeView
See Also Send Feedback
Intersoft WebTreeView > Overview > How-to: Check and uncheck all nodes in WebTreeView

Glossary Item Box

WebTreeView provides a feature to check and uncheck all nodes in WebTreeView via client side.

In this topic, you will learn how to implement the above scenario.

To check and uncheck all nodes in WebTreeView

  1. Bind WebTreeView to XMLDataSource. Please use Sports.xml (You can get the xml from LiveSamples's AppData folder).
  2. Drag and drop 2 HTML buttons to the page.
  3. Button1 and Button2 will perform checking and unchecking all nodes with CheckAll() and UnCheckAll() methods.
  4. Implement onclick client side event for each button like following:

    Javascript Copy Image Copy Code
    // Add this code to Check all's button
function Button1_onclick()
{
   var tv = ISGetObject("WebTreeView1");
   tv.CheckAll();
}

// Add this code to Uncheck all's button
function Button2_onclick()
{
   var tv = ISGetObject("WebTreeView1");
   tv.UnCheckAll();
}

  5. Run the application and try to click each button to see the result. For more information, please refer to Checked Nodes samples in LiveSamples >> WebTreeView >> Client Programmability.

See Also

Tasks
{How-to: Apply Multiple Nodes Selection}
{How-to: Select Nodes on First Load}
{How-to: Get selected nodes}
{How-to: Change the currently selected node's text and tooltip}
{How-to: Enable and disable a WebTreeViewNode}
{How-to: Apply Multiple Nodes Selection}
{How-to: Check and uncheck selected node}
{How-to: Check and uncheck selected node with its children}

Concepts
WebTreeView Overview


How-to: Configure Node for Navigation

How-to: Configure Node for Navigation
Send Feedback
Intersoft WebTreeView > Overview > How-to: Configure Node for Navigation

Glossary Item Box

You can either use keyboard or NavigateURL to configure node for navigation.

This topic will show you how to use keyboard and NavigateURL.

To allow keyboard navigation in WebTreeView

  1. Right click on WebTreeView instance and choose Properties to open its Properties window.
  2. Set the AllowKeyboardNavigation property to True.
  3. Run the project.

To configure NavigateURL and Target properties

  1. Click WebTreeView instance and press F4.
  2. Click the Collection button in DataBindings property to show WebTreeView DataBindings Editor.
  3. Click the nodes inside Selected data bindings section.
  4. Set the NavigateURL to the defined URL and Target property to describe where the URL will be shown.

  5. Run the project.


How-to: Get selected nodes

How-to: Get selected nodes
See Also Send Feedback
Intersoft WebTreeView > Overview > How-to: Get selected nodes

Glossary Item Box

WebTreeView provides a way for developer to get the selected nodes via client side.

In this topic, you will learn how to perform get selected nodes from client side.

To get selected nodes

  1. Bind WebTreeView to XMLDataSource.
  2. Drag and drop div controls to the page and named it divWebTreeView1SelectNodes and divWebTreeView2SelectNodes respectively.
  3. You can get the selected nodes using GetSelectedNodes or GetSelectedNode methods.

    GetSelectedNotes method is used for multiple nodes selection TreeView, whereas GetSelectedNode method is used for normal TreeView.
  4. Implement WebTreeView's OnNodeSelect client side event to get selected nodes on multiple selection TreeView:

    JavaScript Copy Image Copy Code
    function doWebTreeView1NodeSelect(ctrlId, node)
{
   var divStatus = document.getElementById("divWebTreeView1SelectNodes");
   var tv = ISGetObject(ctrlId);
   var selectedNodes = tv.GetSelectedNodes();
   divStatus.innerHTML = "";

   if (selectedNodes!=null && selectedNodes.length&gt0)
   {
      for(var i=0;i<selectedNodes.length;i++)
      {
         divStatus.innerHTML +="- " + selectedNodes[i].Name + " node <br>"
      }
   }
}

  5. Implement WebTreeView's OnNodeSelect client side event to get selected node on normal TreeView:

    JavaScript Copy Image Copy Code
    function doWebTreeView2NodeSelect(ctrlId, node)
{
   var divStatus = document.getElementById("divWebTreeView2SelectNode");
   var tv = ISGetObject(ctrlId);
   if(tv != null)
   {
      var selectedNode = tv.GetSelectedNode();
      divStatus.innerHTML = "";
      if (selectedNode!=null)
         divStatus.innerHTML = selectedNode.Name;
   }
}

  6. For more information, please refer to Get Selected Nodes sample in LiveSample >> WebTreeView >> Client Programmability.

See Also

Tasks
{How-to: Apply Multiple Nodes Selection}
{How-to: Select Nodes on First Load}
{How-to: Check and uncheck nodes in WebTreeView}
{How-to: Change the currently selected node's text and tooltip}
{How-to: Enable and disable a WebTreeViewNode}
{How-to: Check and uncheck selected node}
{How-to: Check and uncheck selected node with its children}
{How-to: Check and uncheck all nodes in WebTreeView}

Concepts
WebTreeView Overview


How-to: Assign Tooltip

How-to: Assign Tooltip
Send Feedback
Intersoft WebTreeView > Overview > How-to: Assign Tooltip

Glossary Item Box

There are three objects that can have tooltip: the node's text, the node's image and node's text image.

This topic will show how to customize tooltip using several ways.

To assign Tooltip using WebTreeView DataBindings Editor

  1. Bind WebTreeView to XMLDataSource. (Use Sample.xml)
  2. Open WebTreeView DataBindings Editor.
  3. To configure the node's text tooltip, set the ToolTipField property.
  4. To configure the node image's tooltip, set the ImageToolTipField property.
  5. To configure the text image's tooltip, set the TextImageToolTipField property.
  6. Run the project.

To assign Tooltip using predefineds Tooltip's fields

  1. Bind WebTreeView to XMLDataSource. (Use Sample.xml)
  2. Open WebTreeView DataBindings Editor.
  3. To configure the node's text tooltip, set the ToolTip property.
  4. To configure the node image's tooltip, set the ImageToolTip property.
  5. To configure the text image's tooltip, set the TextImageToolTip property.
  6. Run the project.

To assign Tooltip using InitializeNode server-side event

  1. Bind WebTreeView to XMLDataSource. (Use Sample.xml)
  2. Put the following code in InitializeNode server-side event to assign tooltip.
    C# Copy Image Copy Code
    protected void WebTreeView3_InitializeNode(object sender, ISNet.WebUI.WebTreeView.WebTreeViewNodeEventArgs e)
{
   e.Node.ToolTip = "ToolTip [Assigned from server side during InitializeNode]";
   e.Node.ImageToolTip = "Image ToolTip [Assigned from server side during InitializeNode]";
   e.Node.TextImageToolTip = "TextImage ToolTip [Assigned from server side during InitializeNode]";
}

  3. Run the project.


How-to: Change the currently selected node's text and tooltip

How-to: Change the currently selected node's text and tooltip
See Also Send Feedback
Intersoft WebTreeView > Overview > How-to: Change the currently selected node's text and tooltip

Glossary Item Box

WebTreeView provides a way for you to change the currently selected node's text and tooltip.

In this topic, you will learn how to implement the above scenario.

To change the current selected node's text and tooltip

  1. Bind WebTreeView to XMLDataSource.
  2. Drag 2 HTML TextBox and 1 HTML button controls to the WebForm.
  3. Set the button's caption to Update, TextBoxt ID to txtText and txtToolTip respectively.
  4. Use Set("Text", [text]) to change selected node's text and Set("Tooltip", [text]) to change selected node's tooltip.
  5. Implement onclick client side event for the button like following:

    JavaScript Copy Image Copy Code
    function Update()
{
   var tv = ISGetObject("WebTreeView1");
   var txtText = document.getElementById("txtText");
   var txtToolTip = document.getElementById("txtToolTip");
   var node = tv.GetSelectedNode();

   if (node!=null)
   {
      if(txtText.value != "")
         node.Set("Text", txtText.value);
      if(txtToolTip.value != "")
         node.Set("ToolTip", txtToolTip.value);
   }
   else
      alert("Please select a node first !");
}

See Also

Tasks
{How-to: Apply Multiple Nodes Selection}
{How-to: Select Nodes on First Load}
{How-to: Check and uncheck nodes in WebTreeView}
{How-to: Get selected nodes}
{How-to: Enable and disable a WebTreeViewNode}
{How-to: Check and uncheck selected node}
{How-to: Check and uncheck selected node with its children}

Concepts
WebTreeView Overview


How-to: Enable and disable a WebTreeViewNode

How-to: Enable and disable a WebTreeViewNode
See Also Send Feedback
Intersoft WebTreeView > Overview > How-to: Enable and disable a WebTreeViewNode

Glossary Item Box

WebTreeView provides a way for you to enable and disable a WebTreeViewNode.

In this topic, you will learn how to enable and disable a WebTreeViewNode.

To enable and disable a WebTreeViewNode

  1. Bind WebTreeView to XMLDataSource.
  2. Drag 2 HTML Buttons to the WebForm.
  3. Button1 will perform disabling WebTreeViewNode whereas Button2 will perform enabling WebTreeViewMode with Set"Enabled", [enabled value]) method.
  4. Implement onclick client side event for each button like following"

    JavaScript Copy Image Copy Code
    // Add this code to Button1 [Disable WebTreeViewNode]
function Button1_onclick()
{
   var treeView = ISGetObject("WebTreeView1");
   var node = treeView.GetSelectedNode();

   if(node!=null)
      node.Set("Enabled", false);}

// Add this code to Button2 [Enable WebTreeViewNode]
function Button2_onclick()
{
   var treeView = ISGetObject("WebTreeView1");
   var node = treeView.GetSelectedNode();

   if(node!=null)
      node.Set("Enabled", true);
}

See Also

Tasks
{How-to: Apply Multiple Nodes Selection}
{How-to: Select Nodes on First Load}
{How-to: Check and uncheck nodes in WebTreeView}
{How-to: Get selected nodes}
{How-to: Change the currently selected node's text and tooltip}
{How-to: Check and uncheck selected node}
{How-to: Check and uncheck selected node with its children}
{How-to: Check and uncheck all nodes in WebTreeView}

Concepts
WebTreeView Overview


How-to: Integrate WebTreeView with WebContextMenu

How-to: Integrate WebTreeView with WebContextMenu
See Also Send Feedback
Intersoft WebTreeView > Overview > How-to: Integrate WebTreeView with WebContextMenu

Glossary Item Box

You can integrate WebTreeView with WebContextMenu.

This topic will show you how to implement the above scenario.

To integrate WebTreeView with WebContextMenu

  1. Bind WebTreeView to XmlDataSource.
  2. Drag WebContextMenu from ToolBar to the page.
  3. Right click on WebTreeView instance and choose Properties to show its Properties Window.
  4. Fill the ClientSideEvent >> OnNodeContextMenu property with WebTreeView1_OnNodeContextMenu.
  5. Switch to HTML view and add the following code:

    JavaScript Copy Image Copy Code
    function WebTreeView1_OnNodeContextMenu(controlId, node)
{
    var menu = ISGetObject("WebContextMenu1");
    menu.Show(this.screenLeft + event.clientX, this.screenTop + event.clientY );

    window.event.returnValue = false;
    return false;
}

  6. Run the project.

See Also

Tasks
{How-to: Apply Multiple Nodes Selection}
{How-to: Select Nodes on First Load}
{How-to: Check and uncheck all nodes in WebTreeView}
{How-to: Check and uncheck selected node}
{How-to: Check and uncheck selected node with its children}
{How-to: Get selected nodes}
{How-to: Change the currently selected node's text and tooltip}
{How-to: Enable and disable a WebTreeViewNode}

Concepts
WebTreeView Overview


Features and Concepts

Features and Concepts
See Also Send Feedback
Intersoft WebTreeView > Features and Concepts

Glossary Item Box

This section summarizes key features owned by the latest version of WebTreeView.NET.

In This Section

Drag and Drop
Read about pixel-perfect sensitivity of drag-and-drop in WebTreeView control.

TriState CheckBox and Normal CheckBox
Information about TriState checkbox which allows you to have a better control over the state of checkbox in hierarchical presentation.

Load on Demand
Read about the Load on Demand's capability to deliver high performance hierarchical tree view presentation with large data without any performance loss.

Advanced Load on Demand
Read about the concept behind advanced load on demand in WebTreeView.NET.

Keyboard Navigation
Information about both mouse and keyboard navigations supported in WebTreeView.NET.

Path
Read about three built-in powerful features related to path, such as Find node by path, Identify a node as a unique node and Show the hierarchy of a node.

Automatically select a node on expand or collapse
Read about selecting a node on expand or collapse with WebTreeView.NET.

Animation during expanding or collapsing a node
Information about enabling animation when expand or collapse a node.

Customizing styles, appearance and images
Information about WebTreeView which is highly customizable in terms of style, appearance, and images of the node and frame.

Node Editing
Read about WebTreeView's ability to add, delete and edit a node.

Using NavigateURL and Target
Read about NavigateURL and TargetWindow properties.

Data Binding
Read about data binding capability available in WebTreeView.NET.

Advanced Data Binding
Read about advanced data binding with its available properties.

Client-side Events
Read about all client side events available in WebTreeView.NET.

See Also

Tasks
{Walkthrough Topics}
{How-to Topics}

Other Resources
{Getting Started}
WebTreeView Overview


Data Binding

Data Binding
See Also Send Feedback
Intersoft WebTreeView > Features and Concepts > Data Binding

Glossary Item Box

WebTreeView.NET® 1.0 is equipped with data binding capability. You can bind to XMLDataSource and SiteMapDataSource.. This basic feature will help you create a powerful Treeview presentation in the matter of seconds.

Following is the tutorial on how to bind WebTreeView.NET® 1.0 to XMLDataSource.

  1. You need to create an XMLDataSource. Please set the DataSourceID to the XMLDataSource you have created before.

  2. Then, click on the DataBindings property and the WebTreeView DataBindings Editor will appear.

  3. To bind the whole xml, just check the Auto-generate data binding and click ok. The whole XML structure will be bind to the WebTreeView.NET® 1.0.

In This Section

Walkthrough: Binding TreeView to XmlDataSource

Walkthrough: Binding TreeView to SiteMapDataSource

How-to: Create unbound TreeView using both editor and server side code

See Also

Tasks
{Walkthrough Topics}
{FAQ and How-to Topics}

Other Resources
WebTreeView Overview
{Features and Concepts}


Walkthrough: Binding TreeView to XmlDataSource

Walkthrough: Binding TreeView to XmlDataSource
See Also Send Feedback
Intersoft WebTreeView > Features and Concepts > Data Binding > Walkthrough: Binding TreeView to XmlDataSource

Glossary Item Box

This walkthrough shows you how to bind WebTreeView to XmlDataSource control.

During this walkthrough, you will learn how to do the following:

  • Use XmlDataSource.
  • Bind WebTreeView.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Xml file to be used as datasource for XmlDataSource.
  • Visual Studio 2005/2008/2010 Application.

Step-By-Step Instructions

To create new web application and bind WebTreeView to XmlDataSource

  1. Launch Visual Studio.NET 2008.
  2. Click on File menu, then select New and click Web Site.
  3. Select ASP.NET Web Site in the Template box and set Location to HTTP.
  4. Named the Web Site and click OK.
  5. Right-click on Project's name and select Add New Item.
  6. Select Intersoft AppForm in the My Templates box and named it as Walkthrough.aspx.
  7. Drag WebTreeView instance from ToolBar to WebForm.
  8. Right click on WebTreeView instance and choose Properties to show Properties Window.

  9. In DataSourceID property, set which the XmlDataSource that you want to use (e.g XmlDataSource1).

  10. Click the Collection button in DataBindings property to show WebTreeView DataBindings Editor.
  11. Check the Auto-generate data binding checkbox.

  12. After that, add the data bindings where you want to set the TextField and ImageField properties.

  13. Press Apply and OK Buttons.
  14. Run the project.

See Also

Tasks
{How-to: Create unbound TreeView using both designer and server side code}
{How-to: Bind TreeView to SiteMapDataSource}
{Walkthrough Topics}
{FAQ and How-to Topics}

Concepts
{Data Binding}


Walkthrough: Binding TreeView to SiteMapDataSource

Walkthrough: Binding TreeView to SiteMapDataSource
See Also Send Feedback
Intersoft WebTreeView > Features and Concepts > Data Binding > Walkthrough: Binding TreeView to SiteMapDataSource

Glossary Item Box

This walkthrough shows you how to bind WebTreeView to SiteMapDataSource control.

During this walkthrough, you will learn how to do the following:

  • Use SiteMapDataSource.
  • Bind WebTreeView.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • SiteMap file to be use as datasource for SiteMapDataSource.
  • Visual Studio 2005/2008/2010 Application.

Step-By-Step Instructions

To create new web application and bind WebTreeView to SiteMapDataSource

  1. Launch Visual Studio.NET 2008.
  2. Click on File menu, then select New and click Web Site.
  3. Select ASP.NET Web Site in the Template box and set Location to HTTP.
  4. Named the Web Site and click OK.
  5. Right-click on Project's name and select Add New Item.
  6. Select Intersoft AppForm in the My Templates box and named it as Walkthrough.aspx.
  7. Drag WebTreeView instance from ToolBar to WebForm.
  8. Right click on WebTreeView instance and choose Properties to show Properties Window.

  9. In DataSourceID property set the SiteMapDataSource that you want to use (e.g SiteMapDataSource1).

  10. Click the Collection button in DataBindings property to show WebTreeView DataBindings Editor.
  11. Check the Auto-generate data binding checkbox.

  12. After that, add the data bindings where you want to set the TextField.

  13. Press Apply and OK Buttons.
  14. Run the project.

See Also

Tasks
{How-to: Create unbound TreeView using both designer and server side code}
{How-to: Bind TreeView to XmlDataSource}
{Walkthrough Topics}
{FAQ and How-to Topics}

Concepts
{Data Binding}


How-to: Create unbound TreeView using both editor and server side code

How-to: Create unbound TreeView using both editor and server side code
See Also Send Feedback
Intersoft WebTreeView > Features and Concepts > Data Binding > How-to: Create unbound TreeView using both editor and server side code

Glossary Item Box

You can create unbound WebTreeView using editor or server side code.

This topic will show you how to implement the above scenario.

To create unbound WebTreeView using designer

  1. Right click on WebTreeView instance and choose WebTreeView.NET Designer.
  2. Click the Tree Editor tab.
  3. Click the "Add a root node" icon to add root nodes, select the new added node to set its properties.

  4. You can also add child nodes for the newly added nodes by clicking the "Add a child node" icon, select the new added node to set its properties.
  5. Press Apply >> OK Button and run the project.

To create unbound WebTreeView using server side code

  1. Drag WebTreeView instance from ToolBar to WebForm.
  2. On Page_Load event handler, add the following code:

    C# Copy Image Copy Code
    protected void Page_Load(object sender, EventArgs e)
{
    WebTreeViewNode nodeRoot = new WebTreeViewNode();
    nodeRoot.Text = "Personal Folders";
    nodeRoot.Image = "./Images/PersonalFolders.gif";
    nodeRoot.Expanded = true;

    WebTreeViewNode nodeParent = new WebTreeViewNode();
    nodeParent.Text = "Deleted Items";
    nodeParent.Image = "./Images/DeletedItems.gif";
    nodeRoot.Nodes.Add(nodeParent);

    WebTreeViewNode nodeParent2 = new WebTreeViewNode();
    nodeParent2.Text = "Drafts";
    nodeParent2.Image = "./Images/Drafts.gif";
    nodeRoot.Nodes.Add(nodeParent2);

    WebTreeViewNode nodeParent3 = new WebTreeViewNode();
    nodeParent3.Text = "Inbox";
    nodeParent3.Image = "./Images/Inbox.gif";
    nodeRoot.Nodes.Add(nodeParent3);

    WebTreeViewNode nodeParent4 = new WebTreeViewNode();
    nodeParent4.Text = "Junk E-mail";
    nodeParent4.Image = "./Images/JunkEmail.gif";
    nodeRoot.Nodes.Add(nodeParent4);

    WebTreeViewNode nodeParent5 = new WebTreeViewNode();
    nodeParent5.Text = "Outbox";
    nodeParent5.Image = "./Images/Outbox.gif";
    nodeRoot.Nodes.Add(nodeParent5);

    WebTreeViewNode nodeParent6 = new WebTreeViewNode();
    nodeParent6.Text = "RSS Feeds";
    nodeParent6.Image = "./Images/RSSFeeds.gif";
    nodeRoot.Nodes.Add(nodeParent6);

    WebTreeViewNode nodeParent7 = new WebTreeViewNode();
    nodeParent7.Text = "Sent Items";
    nodeParent7.Image = "./Images/SentItem.gif";
    nodeRoot.Nodes.Add(nodeParent7);

    WebTreeViewNode nodeParent8 = new WebTreeViewNode();
    nodeParent8.Text = "Search Folders";
    nodeParent8.Image = "./Images/SearchFolders.gif";

    WebTreeViewNode nodeLeaf = new WebTreeViewNode();
    nodeLeaf.Text = "Categorized Mail";
    nodeLeaf.Image = "./Images/SearchFolders.gif";
    nodeParent8.Nodes.Add(nodeLeaf);

    WebTreeViewNode nodeLeaf2 = new WebTreeViewNode();
    nodeLeaf2.Text = "For Follow Up";
    nodeLeaf2.Image = "./Images/SearchFolders.gif";
    nodeParent8.Nodes.Add(nodeLeaf2);

    WebTreeViewNode nodeLeaf3 = new WebTreeViewNode();
    nodeLeaf3.Text = "Large Mail";
    nodeLeaf3.Image = "./Images/SearchFolders-copy.gif";
    nodeParent8.Nodes.Add(nodeLeaf3);

    WebTreeViewNode nodeLeaf4 = new WebTreeViewNode();
    nodeLeaf4.Text = "Unread Mail";
    nodeLeaf4.Image = "./Images/SearchFolders-copy.gif";
    nodeParent8.Nodes.Add(nodeLeaf4);

    nodeRoot.Nodes.Add(nodeParent8);
    WebTreeView2.Nodes.Add(nodeRoot);

    WebTreeViewNode nodeRoot2 = new WebTreeViewNode();
    nodeRoot2.Text = "Archieve Folders";
    nodeRoot2.Image = "./Images/ArchiveFolders.gif";

    WebTreeViewNode nodeParent9 = new WebTreeViewNode();
    nodeParent9.Text = "Deleted Items";
    nodeParent9.Image = "./Images/DeletedItems.gif";
    nodeRoot2.Nodes.Add(nodeParent9);

    WebTreeViewNode nodeParent10 = new WebTreeViewNode();
    nodeParent10.Text = "Sent Items";
    nodeParent10.Image = "./Images/SentItem.gif";
    nodeRoot2.Nodes.Add(nodeParent10);

    WebTreeViewNode nodeParent11 = new WebTreeViewNode();
    nodeParent11.Text = "Search Folders";
    nodeParent11.Image = "./Images/SearchFolders.gif";
    nodeRoot2.Nodes.Add(nodeParent11);

    WebTreeView2.Nodes.Add(nodeRoot2);
}

  3. Run the project.

See Also

Tasks
{How-to: Bind TreeView to XmlDataSource}
{How-to: Bind TreeView to SiteMapDataSource}
{Walkthrough Topics}
{FAQ and How-to Topics}

Concepts
{Data Binding}


Hassle-free deployment through SmartWebResources™ technology

Hassle-free deployment through SmartWebResources™ technology
See Also Send Feedback
Intersoft WebTreeView > Features and Concepts > Hassle-free deployment through SmartWebResources™ technology

Glossary Item Box

Oftentimes, developers found it too complex in order to deploy their web application that used third party components. There are too much things that need to be recalled before a web application can be successfully deployed. For an instance, the javascript files, images and other runtime client files need to be copied in order for the component to run properly.

One of the goal in Intersoft's 2007 product platforms is to simplify the deployment process required in Intersoft's controls. Our approach is by developing a new infrastructure that handles the storage and retrieval system of these client resources, so that the physical files can be totally eliminated. This new infrastructure is called SmartWebResources™.

WebTreeView.NET fully supports SmartWebResources infrastructure. This enables WebTreeView.NET to function right out-of-the-box after the simply XCOPY deployment.

Both developers and site administrators can now deploy Intersoft's components by simply copying the assemblies in the Bin folder of the project - and totally eliminates the need to copy javascript files, component-specific images and runtime files.

To learn how SmartWebResources works, please read How does SmartWebResources™ work.

To learn more about the benefits introduced by SmartWebResources, read Features and benefits introduced by SmartWebResources™.

In This Section

How-to: Configure SmartWebResources in a new web application

FAQ: Does SmartWebResources feature automatically enabled in WebTreeView.NET?

See Also

Tasks
{Walkthrough Topics}
{FAQ and How-to Topics}


How-to: Configure SmartWebResources in a new web application

How-to: Configure SmartWebResources in a new web application
See Also Send Feedback
Intersoft WebTreeView > Features and Concepts > Hassle-free deployment through SmartWebResources™ technology > How-to: Configure SmartWebResources in a new web application

Glossary Item Box

As the best practice in using Intersoft 2007's product lines, you are recommended to perform the following steps after you have created a new web application or migrated an existing web application.

  1. Right click on one of the Intersoft's control instance. For instance, WebTreeView1.
  2. Click Register SmartWebResources™ command in the context menu.

  3. In short time after you clicked the command, you should receive a message prompt similar to the following:
    "SmartWebResources has been successfully configured for this web application."

If you are receiving an error message, it is likely that you have not installed the product properly. Please note that you can't enable this feature in older products (non 2007-platform products).

To learn more about SmartWebResources, please read Introducing SmartWebResources™.

See Also

Tasks
{FAQ: Does SmartWebResources feature automatically enabled in WebTreeView.NET?}

Concepts
{Hassle-free deployment through SmartWebResources™ technology}


FAQ: Does SmartWebResources feature automatically enabled in WebTreeView.NET?

FAQ: Does SmartWebResources feature automatically enabled in WebTreeView.NET?
See Also Send Feedback
Intersoft WebTreeView > Features and Concepts > Hassle-free deployment through SmartWebResources™ technology > FAQ: Does SmartWebResources feature automatically enabled in WebTreeView.NET?

Glossary Item Box

By default, Intersoft 2007 product platform has the SmartWebResources set to Automatic mode. This automatic mode ensures compatibility with existing web application when developers migrated to 2007 platform, while at the same time attempting to utilize SmartWebResources in new web application whenever possible.

When you created a new web application and started to use WebTreeView.NET, the SmartWebResources is not configured initially. With the automatic mode as default behavior, WebTreeView.NET will use physical resources since the SmartWebResources has not been configured.

See Also

Tasks
{How-to: Configure SmartWebResources in a new web application}

Concepts
{Hassle-free deployment through SmartWebResources™ technology}


Drag and Drop

Drag and Drop
See Also Send Feedback
Intersoft WebTreeView > Features and Concepts > Drag and Drop

Glossary Item Box

Powered by Intersoft's unique DragDrop Framework 2007 architecture, you can enjoy pixel-perfect sensitivity of drag-and-drop in WebTreeView control. This can be done easily by setting the AllowDragDrop property to True.

There are four properties that you can set in the DragDropSettings to customize the node drag drop behaviors:

  • AllowChildDrop
    This property allows you to control a node's drop ability, set it to True and a node can be dropped on a child node. The default value is False.

  • AllowRootDrop
    Setting this property to True to allow nodes to be dropped on root node. The default value is False.

  • AllowSiblingDrop
    Setting this property to True to allow nodes to be dropped on target's sibling node. The default value is False.

  • AllowLeafDrop
    Setting this property to True to allow nodes to be dropped into node which type is Leaf. Leaf type is the node without children. The default value of this property is False.

WebTreeView.NET includes comprehensive drag and drop support with ability to combine four behaviors at once. For instance, you can enable both AllowLeafDrop and AllowSiblingDrop to enable child move and item reposition. You can also enable AllowChildDrop, AllowSiblingDrop and AllowLeafDrop at once to create more powerful drag and drop behavior.

While you can easily enable the drag and drop feature at global level by setting the AllowDragDrop property to True, you also have the flexibility to control the drag and drop ability at node level. For instance, you can specify individual node to disallow the drag behavior by setting the AllowDrag property of the WebTreeViewNode to False. The same goes true for AllowDrop property.

The drag and drop feature also works perfectly in conjunction with multiple selection feature. You can select multiple nodes by using Ctrl+Click approach, or Ctrl+Shift for batch selection. You can then initiate drag operation by dragging one of the selected node.

See Also

Tasks
{How-to: Drag and drop with Multiple Selection}
{How-to: Drag and drop between TreeView}
{Walkthrough Topics}
{FAQ and How-to Topics}

Other Resources
{Drag Drop Visual Hints}
{Automatic Drag Drop Behaviors }
{Drag Drop Client Side Events }
{Auto Postback on DragDrop }
{Integration with WebDragDropExtender component }


Drag Drop Visual Hints

Drag Drop Visual Hints
See Also Send Feedback
Intersoft WebTreeView > Features and Concepts > Drag and Drop > Drag Drop Visual Hints

Glossary Item Box

By default, all drag and drop operations in WebTreeView will initiate a �??Move�?� operation. There are several visual hints that allow you to understand the status of the drag drop behavior:

  • Move into Parent
    This action is marked with a changing background style of the target node. This behavior is enabled when AllowChildDrop is enabled. See following image:

  • Move into Leaf
    This action is marked with a changing background style of the target node. This behavior is enabled when AllowLeafDrop is enabled. See following image:

  • Move Before Node
    This action is marked with a line indicator above the desired target node. The drop result will move the dragged node to the position before target node. This behavior is enabled when AllowSiblingDrop is enabled. See following image:

  • Move After Node
    This action is marked with a line indicator below the desired target node. The drop result will move the dragged node to the position after target node. This behavior is enabled when AllowSiblingDrop is enabled. See following image:

See Also

Other Resources
Drag and Drop Overview
{Automatic Drag Drop Behaviors }
{Drag Drop Client Side Events }
{Auto Postback on DragDrop }
{Integration with WebDragDropExtender component }


Automatic Drag Drop Behaviors

Automatic Drag Drop Behaviors
See Also Send Feedback
Intersoft WebTreeView > Features and Concepts > Drag and Drop > Automatic Drag Drop Behaviors

Glossary Item Box

The behaviors and drag drop implementation in WebTreeView.NET are mostly automatic, so you can create powerful TreeView presentation with drag and drop ability in shorter time and less efforts.

The automatic behaviors are:

  • When a parent node is dragged-and-dropped to another node, the child node will always follow its parent node. This is the default behavior of WebTreeView.NET.
  • When a node is dropped to another node�??s sibling, the dragged node will be moved to the target node�??s position.
  • When a node is dropped to a leaf node, the dragged node will be moved into the leaf node, and the leaf node will be converted to parent node.
  • When the drag selection contains multiple nodes, the selected nodes will be moved including its children if any.
  • When the dragged mouse cursor is moved near to the most bottom boundary of the control�??s dimension, the TreeView will be automatically scrolled down. The same goes true for automatic scrolling up. This feature is also called Auto Scroll on Drag.

The drag drop constraints are:

  • You cannot perform drag and drop when the dragged selection contains nodes from different level/depth.
  • You cannot move a source node into destination node which is under the source node.
  • When custom objects are dropped into WebTreeView, the built-in WebTreeView�??s drag drop behavior will not be processed. You can handle custom drop implementation in OnDragDrop client side event.

See Also

Other Resources
Drag and Drop Overview
{Drag Drop Visual Hints}
{Drag Drop Client Side Events }
{Auto Postback on DragDrop }
{Integration with WebDragDropExtender component }


Drag Drop Client Side Events

Drag Drop Client Side Events
See Also Send Feedback
Intersoft WebTreeView > Features and Concepts > Drag and Drop > Drag Drop Client Side Events

Glossary Item Box

The drag drop feature in WebTreeView.NET exposes complete client side events which developers can implement to extend and customize the drag drop behaviors.

The client side events related to drag drop feature:

  • OnDragStart
    This event is invoked when a drag session is initiated by holding the left mouse button and moves the mouse. The parameters available to this event are controlId, dragObject.

  • OnDragEnd
    This event is invoked when a drag session has ended regardless of the drop status. This means the event will be invoked in any condition of the drop status (either in valid or invalid). The parameters available to this event are controlId, dragObject.

  • OnDragQuery
    This event is invoked when a target node is being queried for its status and information during drag operation. This event is very suitable to be consumed for customizing the Effect or EffectText of the drag session when it queries for a specific target node. The parameters available to this event are controlId, dragEventArgs, dropContext.

  • OnDragDrop
    This event is invoked when a drag session has ended with valid drop status. This means the event will only be invoked when the dragged node is dropped to a valid target node. This is a perfect event for developer to perform additional logic upon a successful drag drop session. For instance, you can perform some AJAX callbacks to save a certain state of data when a node is moved successfully to another node. The parameters available to this event are controlId, dragData, dropContext.

See Also

Other Resources
Drag and Drop Overview
{Drag Drop Visual Hints}
{Automatic Drag Drop Behaviors }
{Auto Postback on DragDrop }
{Integration with WebDragDropExtender component }


Auto Postback on DragDrop

Auto Postback on DragDrop
See Also Send Feedback
Intersoft WebTreeView > Features and Concepts > Drag and Drop > Auto Postback on DragDrop

Glossary Item Box

By default all drag and drop actions are performed in client side. The hierarchy structure changes are stored in client side for best performance rather than post back on each drag drop operation. The node hierarchy changes will be submitted to the server side on the next Webform postback. In response, the OnDragDrop server side event will be raised followed by OnNodeMove for each moved nodes.

Despite the default behavior, in certain scenarios you may require complex server side operation to be executed upon successful drag drop operation. WebTreeView provides the feature that allows you to automatically perform full page postback upon each successful drag drop operation. This can be easily achieved by setting AutoPostBackSettings.OnDragDrop property to True.
Using this feature, you can also perform AJAX callback instead of full page postback during the drag drop operation. This feature is compatible with other AJAX Manager such as ASP.NET AJAX and WebFlyPostbackManager.

In This Section

How-to: Set auto postback on drag drop operation

How-to: Handle server side OnDragDrop event

See Also

Other Resources
Drag and Drop Overview
{Drag Drop Visual Hints}
{Automatic Drag Drop Behaviors }
{Drag Drop Client Side Events }
{Integration with WebDragDropExtender component }


How-to: Set auto postback on drag drop operation

How-to: Set auto postback on drag drop operation
See Also Send Feedback
Intersoft WebTreeView > Features and Concepts > Drag and Drop > Auto Postback on DragDrop > How-to: Set auto postback on drag drop operation

Glossary Item Box

You can set auto postback for WebTreeView on drag drop operation.

This topic will show you how to implement the above scenario.

To set auto postback on drag drop operation

  1. Right click on WebTreeView instance and choose Properties to open Properties Window.
  2. Set the AutoPostBackSettings >> OnDragDrop property to True.
  3. Run the project.

See Also

Tasks
{How-to: Handle server side OnDragDrop event}
{Walkthrough Topics}
{FAQ and How-to Topics}

Concepts
{Auto Postback on DragDrop }


How-to: Handle server side OnDragDrop event

How-to: Handle server side OnDragDrop event
See Also Send Feedback
Intersoft WebTreeView > Features and Concepts > Drag and Drop > Auto Postback on DragDrop > How-to: Handle server side OnDragDrop event

Glossary Item Box

When you set auto postback for WebTreeView, you also trigger OnDragDrop server side event.

This topic will show you how to handle OnDragDrop event.

To handle OnDragDrop event

  1. Right click on WebTreeView instance and choose Properties to open Properties Window.
  2. Set the AutoPostBackSettings >> OnDragDrop property to True.
  3. Add the following code under OnDragDrop server side event:
    Javascript Copy Image Copy Code
    protected void WebTreeView1_DragDrop(object sender, ISNet.WebUI.WebTreeView.WebTreeViewDragDropEventArgs e)
{
    e.Node.Text = "Changed";
}
  4. Run the project.

See Also

Tasks
{How-to: Set auto postback on drag drop operation}
{Walkthrough Topics}
{FAQ and How-to Topics}

Concepts
{Auto Postback on DragDrop }


Integration with WebDragDropExtender component

Integration with WebDragDropExtender component
See Also Send Feedback
Intersoft WebTreeView > Features and Concepts > Drag and Drop > Integration with WebDragDropExtender component

Glossary Item Box

Thanks to the powerful Intersoft DragDrop Framework 2007 architecture, it enables the drag and drop feature in WebTreeView to be interoperable with other controls that implement the framework such as WebDragDropExtender control (a new family in WebDesktop.NET 2.5).

Since WebTreeView contains full implementation of drag drop at its product level, it does not require WebDragDropExtender component. In other words, the drag drop feature in WebTreeView can be used in standalone mode without the need of WebDragDropExtender.
In order to allow WebTreeView to accept drag from other controls, you simply need to set the AllowDropFromOtherControls property to True. The other drop behaviors will be determined by the DragDropSettings in the WebTreeView control itself.

In This Section

Walkthrough: Enabling WebTreeView to accept data items from WebGrid control

How-to: Enable drag behavior in WebTreeView with ability to drop into Panel control suing WebDragDropExtender

See Also

Other Resources
Drag and Drop Overview
{Drag Drop Visual Hints}
{Automatic Drag Drop Behaviors }
{Drag Drop Client Side Events }
{Auto Postback on DragDrop }


Walkthrough: Enabling WebTreeView to accept data items from WebGrid control

Walkthrough: Enabling WebTreeView to accept data items from WebGrid control
See Also Send Feedback
Intersoft WebTreeView > Features and Concepts > Drag and Drop > Integration with WebDragDropExtender component > Walkthrough: Enabling WebTreeView to accept data items from WebGrid control

Glossary Item Box

This walkthrough shows you how to enable WebTreeView to accept data items from WebGrid control.

During this walkthrough, you will learn how to do the following:

  • Use AccessDataSource.
  • Bind WebTreeView.
  • Use DragDropExtender to set the Drag control and Drop control.
  • Set the TreeView to accept data from other control

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Microsoft Access Northwind database.
  • Visual Studio 2005/2008/2010 Application.

Step-By-Step Instructions

To enable WebTreeView to accept data items from WebGrid control

  1. Launch Visual Studio.NET 2008.
  2. Click on File menu, then select New and click Web Site.
  3. Select ASP.NET Web Site in the Template box and set Location to HTTP.
  4. Named the Web Site and click OK.
  5. Right-click on Project's name and select Add New Item.
  6. Select Intersoft AppForm in the My Templates box and named it as Walkthrough.aspx.
  7. Drag WebGrid instance from ToolBar to WebForm.
  8. Bind the WebGrid to AccessDataSource control.
  9. Drag WebTreeView instance from ToolBar to WebForm.
  10. Bind WebTreeView to XmlDataSource.
  11. Click the WebTreeView instance and press F4 to open its Properties window.
  12. Set AllowDragDrop to True and AllowDropFromOtherControls to True.
  13. Expand DragDropSettings and set the following properties.
    Property | Value
    AllowChildDrop | True
    AllowLeafDrop | True
    AllowRootDrop | True
    AllowSiblingDrop | True

  14. Drag WebDragDropExtender from ToolBar to WebForm.
  15. Right click on WebDragDropExtender control and choose Properties.
  16. On DragControls property, click the (collection) button to open WebDragControl Collection Editor.

  17. Set ControlID to WebGrid1 and Effect to Copy.
  18. Click the (collection) button on AdvancedProperties and a dialog box will appear afterwards.
  19. Select Enable special integration with Intersoft control and Allow dragging on checked rows. Click OK to apply the settings.

  20. On DropControls property, click the (collection) button to open WebDropControl Collection Editor. Set ControlID to WebTreeView1.

  21. Run the project.

See Also

Tasks
{How-to: Enable drag behavior in WebTreeView with ability to drop into Panel control using WebDragDropExtender}
{Walkthrough Topics}
{FAQ and How-to Topics}

Concepts
Integration with WebDragDropExtender component


How-to: Enable drag behavior in WebTreeView with ability to drop into Panel control using WebDragDropExtender

How-to: Enable drag behavior in WebTreeView with ability to drop into Panel control using WebDragDropExtender
See Also Send Feedback
Intersoft WebTreeView > Features and Concepts > Drag and Drop > Integration with WebDragDropExtender component > How-to: Enable drag behavior in WebTreeView with ability to drop into Panel control using WebDragDropExtender

Glossary Item Box

You can enable drag behavior in WebTreeView with ability to drop into Panel control using WebDragDropExtender.

This topic will show you how to enable drag behavior in WebTreeView with ability to drop into Panel control using WebDragDropExtender.

To enable drag behavior in WebTreeView with ability to drop into Panel control using WebDragDropExtender

  1. Drag an aspnet Panel from ToolBar to WebForm.
  2. Drag WebTreeView instance from ToolBar to WebForm.
  3. Bind TreeView to XmlDataSource.
  4. Click the WebTreeView instance and press F4 to open its Properties window. Set the below property:

  5. Drag WebDragDropExtender from ToolBar to WebForm.
  6. On DragControls property, click the (collection) button to open WebDragControl Collection Editor

  7. On DropControls property, click the (collection) button to open WebDropControl Collection Editor.

  8. Run the project.

See Also

Tasks
{Walkthrough: Enabling WebTreeView to accept data items from WebGrid control}
{Walkthrough Topics}
{FAQ and How-to Topics}

Concepts
{Integration with WebDragDropExtender component }


How-to: Enable basic Drag-and-Drop

How-to: Enable basic Drag-and-Drop
Send Feedback
Intersoft WebTreeView > Features and Concepts > Drag and Drop > How-to: Enable basic Drag-and-Drop

Glossary Item Box

WebTreeView provides feature to allow user performing Drag-and-Drop.

This topic will show you how to enable basic Drag-and-Drop.

To enable basic Drag-and-Drop

  1. Right click on WebTreeView instance and choose WebTreeView.NET Designer.
  2. Go to WebTreeView's Properties and set AllowDragDrop to True.
  3. Expand DragDropSettings. There are 4 properties you can set.
    • AllowChildDrop : This property allows you to control a node�??s drop ability, set it to True and a node can be dropped on a child node. The default value is False.
    • AllowRootDrop : Setting this property to True to allow nodes to be dropped on root node. The default value is False.
    • AllowSiblingDrop : Setting this property to True to allow nodes to be dropped on target�??s sibling node. The default value is False.
    • AllowLeafDrop : Setting this property to True to allow nodes to be dropped into node which type is Leaf. Leaf type is the node without children. The default value of this property is False.
  4. Run the project.


How-to: Drag-and-drop with Multiple Selection

How-to: Drag-and-drop with Multiple Selection
See Also Send Feedback
Intersoft WebTreeView > Features and Concepts > Drag and Drop > How-to: Drag-and-drop with Multiple Selection

Glossary Item Box

You can set drag drop and multiple selection features at the same time.

This topic will show you how to implement the above scenario.

To set drag and drop with multiple selection

  1. Right click on WebTreeView instance and choose Properties to open Properties Window.
  2. Set the AllowDragDrop property to True.
  3. Set the AllowMultipleSelect property to True.
  4. Run the project.

See Also

Tasks
{How-to: Drag and drop between TreeView}
{Walkthrough Topics}
{FAQ and How-to Topics}

Concepts
{Drag and Drop}


How-to: Drag-and-drop between TreeView

How-to: Drag-and-drop between TreeView
See Also Send Feedback
Intersoft WebTreeView > Features and Concepts > Drag and Drop > How-to: Drag-and-drop between TreeView

Glossary Item Box

You can set drag drop feature between two or more WebTreeView.

This topic will show you how to implement the above scenario.

To set drag and drop between TreeView

  1. Right click on each WebTreeView instance and choose Properties to open Properties Window.
  2. Set the AllowDragDrop property to True for each WebTreeView.
  3. It is recommended to set all the properties inside DragDropSettings to True for each WebTreeView, so you can drop into all nodes without restriction.
  4. Run the project.

See Also

Tasks
{How-to: Drag and drop with Multiple Selection}
{Walkthrough Topics}
{FAQ and How-to Topics}

Concepts
{Drag and Drop}


TriState CheckBox and Normal CheckBox

TriState CheckBox and Normal CheckBox
See Also Send Feedback
Intersoft WebTreeView > Features and Concepts > TriState CheckBox and Normal CheckBox

Glossary Item Box

WebTreeView.NET® 1.0 introduces you innovative TriState checkbox which allows you to have a better control over the state of checkbox in hierarchical presentation. These three states are: checked, indeterminate, and unchecked.

WebTreeView.NET ® 1.0 Tristate Checkbox

When to use Tristate checkbox? As an ASP.NET developer, you should have installed Microsoft Visual Studio before and familiar with the setup wizard in Microsoft Visual Studio 2005. In the option page, users are given an option to choose which components they want to install by checking the check box. Notice when you check the root check box, all the child check boxes will be checked. If you check some child check boxes, the root check box will be checked.

This Tristate checkbox concept is adopted by WebTreeView.NET® 1.0, implementing the exact behavior of the three-state checkbox concept of Windows-based tree view.

There is no code needed to take advantage of the Tristate checkbox feature, you only need to set the EnableTriStateCheckbox property to True. Another related property is the AutoCheckChildNodes. Set it to True and it will automatically check all child nodes when the parent node is checked.

Besides the advanced TriState checkbox, WebTreeView is also equipped with traditional checkbox, the two-state checkbox (checked or unchecked). Set the ShowCheckBoxes property to All and you will see a checkbox in every nodes.

The value of ShowCheckBoxes property

Please note that the AutoCheckChildNodes property also applies to normal checkbox, two state-state checkbox (checked and unchecked).

Microsoft Visual Studio Setup Wizard Replica by WebTreeView.NET® 1.0

In This Section

How-to: Create a simple WebTreeView with TriState CheckBox

How-to: Get checked Nodes in TriState CheckBox

See Also

Tasks
{Walkthrough Topics}
{FAQ and How-to Topics}

Other Resources
WebTreeView Overview
{Features and Concepts}


How-to: Create a simple WebTreeView with Tristate CheckBox

How-to: Create a simple WebTreeView with Tristate CheckBox
See Also Send Feedback
Intersoft WebTreeView > Features and Concepts > TriState CheckBox and Normal CheckBox > How-to: Create a simple WebTreeView with Tristate CheckBox

Glossary Item Box

WebTreeView gives flexibility to create a simple WebTreeView along with TriState CheckBox.

In this topic, you will learn how to perform the above scenario.

To create a simple WebTreeView with TriState CheckBox

  1. Bind WebTreeView to XMLDataSource.
  2. Set the ShowCheckBox to Yes and EnableTriStateCheckBox to True.
  3. If you want all the child nodes to be checked when the parent node is checked, set AutoCheckChildNodes to True.
  4. Click OK and run your sample. You should see something like following:

See Also

Tasks
{How-to: Get checked nodes in TriState CheckBox}
{Walkthrough Topics}
{FAQ and How-to Topics}

Concepts
TriState CheckBox and Normal CheckBox


How-to: Get checked nodes in TriState CheckBox

How-to: Get checked nodes in TriState CheckBox
See Also Send Feedback
Intersoft WebTreeView > Features and Concepts > TriState CheckBox and Normal CheckBox > How-to: Get checked nodes in TriState CheckBox

Glossary Item Box

WebTreeView provides a way to get the checked nodes from client side.

In this topic, you will learn how to get checked nodes in TriState CheckBox.

To get checked nodes in TriState CheckBox

  1. Follow Create a simple WebTreeView with Tristate CheckBox steps.
  2. Drag a HTML div control into the WebForm and named it div1.
  3. Implement WebTreeView's OnNodeCheckedChanged client side event.

    Javascript Copy Image Copy Code
    function WebTreeView1_OnNodeCheckedChanged(controlId, node)
{
   var WebTreeView1 = ISGetObject(controlId);
   var checkedNodes = WebTreeView1.GetCheckedNodes();
   var txt = document.getElementById("div1");
   txt.innerHTML = "";

   for(var i=0; i<checkedNodes.length; i++)
   {
      txt.innerHTML += "- " + checkedNodes[i].Name + " node <br>";
   }
    return true;
}

  4. For more information, please refer to Get Checked Nodes samples in LiveSamples >> WebTreeView >> TriState CheckBox.

See Also

Tasks
{How-to: Create a simple WebTreeView with Tristate CheckBox}
{Walkthrough Topics}
{FAQ and How-to Topics}

Concepts
{TriState CheckBox and Normal CheckBox}


Load on Demand

Load on Demand
See Also Send Feedback
Intersoft WebTreeView > Features and Concepts > Load on Demand

Glossary Item Box

One important aspect when building a Web-based application using ASP.NET control is that the user interaction should be performed in real time. Real time here means that the information should be available when needed without having to wait for a minute. This will be an issue if a control contains lots of data. This is where the Load on Demand plays important part in WebTreeView.NET. This technique will deliver the content faster with the build-in AJAX capability.

Can you imagine loading one hundred nodes and each node consists of another one hundred child nodes. This will, of course, decrease the performance significantly when the large nodes are delivered at once in first page load. This is the time when the Load on Demand plays important role. It will boost the performance by rendering the parent node first and when you expand a node, it will then render the child node.

With the advanced Load on Demand capability, you can now deliver high performance hierarchical tree view presentation with large data without any performance loss.

The Load on Demand technique comes in handy when you have complex data presentation structure. The concept behind this technique is rendering the child node when needed, which is when the node is expanded. This process will definitely decrease the WebTreeView.NET's workload, thus delivering faster response and better user interaction.
You only need to set the EnableLoadOnDemand property to True and you are all set. It is just that simple.

In This Section

How-to: Enable Load on Demand

See Also

Tasks
{Walkthrough Topics}
{FAQ and How-to Topics}

Other Resources
{Advanced Load on Demand}
WebTreeView Overview
{Features and Concepts}


How-to: Enable Load on Demand

How-to: Enable Load on Demand
See Also Send Feedback
Intersoft WebTreeView > Features and Concepts > Load on Demand > How-to: Enable Load on Demand

Glossary Item Box

You can set load on demand feature in WebTreeView for better performance.

This topic will show you how to implement the above scenario.

To set load on demand in WebTreeView (Basic)

  1. Right click on WebTreeView instance and choose Properties to open its Properties window.
  2. Set the EnableLoadOnDemand property to True.
  3. Run the project.

You can add TreeViewNodes based on retrieved data. This scenario can only be done in unbound TreeView mode.

This topic will show you how to implement the above scenario.

To add TreeViewNodes based on retrieved data (Advanced Load On Demand scenario)

  1. Right click on WebTreeView and choose Properties to open its Properties window.
  2. Set EnableLoadOnDemand to True.
  3. Create a dataset and named it dsNorthwind. This dataset will be used to get data from database and the data will be added to WebTreeView.

  4. Right click on WebTreeView control and choose WebTreeView.NET Designer. Switch to Tree Editor tab and create a parent node in the WebTreeView.

  5. Implement WebTreeView's InitializeChildNodes server side event.

    C# Copy Image Copy Code
    protected void WebTreeView1_InitializeChildNodes(object sender, ISNet.WebUI.WebTreeView.WebTreeViewNodeEventArgs e)
{
   PopulateNode(e.Node);
}

private void PopulateNode(WebTreeViewNode node)
{
   // Call the appropriate method to populate a node at a particular level.
   switch (node.Depth)
   {
      case 0:
         // Populate the first-level nodes.
         PopulateCategories(node);
         break;
      case 1:
         // Populate the second-level nodes.
         PopulateProducts(node);
         break;
      default:
         // Do nothing.
         break;
   }
}

private void PopulateCategories(WebTreeViewNode node)
{
   // Query for the product categories. These are the values
   // for the second-level nodes.
   dsNorthwindTableAdapters.CategoriesTableAdapter adapter = new dsNorthwindTableAdapters.CategoriesTableAdapter();
   dsNorthwind.CategoriesDataTable table = adapter.GetData();

   // Create the second-level nodes.
   if (table.Count > 0)
   {
      // Iterate through and create a new node for each row in the query results.
      // Notice that the query results are stored in the table of the DataSet.
      foreach (dsNorthwind.CategoriesRow row in table.Rows)
      {
         WebTreeViewNode newNode = new WebTreeViewNode();
         newNode.Name = "Category" + row.CategoryID.ToString();
         newNode.Text = row.CategoryName;
         newNode.Value = row.CategoryID;

         node.Nodes.Add(newNode);
      }
   }
}

private void PopulateProducts(WebTreeViewNode node)
{
   // Query for the products of the current category. These are the values
   // for the third-level nodes.
   dsNorthwindTableAdapters.ProductsTableAdapter adapter = new dsNorthwindTableAdapters.ProductsTableAdapter();
   dsNorthwind.ProductsDataTable table = adapter.GetDataByCategoryID((int)node.Value);

   // Create the second-level nodes.
   if (table.Count > 0)
   {
      // Iterate through and create a new node for each row in the query results.
      // Notice that the query results are stored in the table of the DataSet.
      foreach (dsNorthwind.ProductsRow row in table.Rows)
      {
         WebTreeViewNode newNode = new WebTreeViewNode();
         newNode.Name = "Product" + row.ProductID.ToString();
         newNode.Text = row.ProductName;
         newNode.Value = row.ProductID;

         node.Nodes.Add(newNode);
      }
   }
}

protected void WebTreeView1_InitializeNode(object sender, WebTreeViewNodeEventArgs e)
{
   if (e.Node.Depth == 2)
      e.Node.ChildNodeExpandable = false;
}

  6. Run the sample and you will get a result like screenshot below.

See Also

Tasks
{How-to: Enable drag and drop in Load on Demand TreeView}
{Walkthrough Topics}
{FAQ and How-to Topics}

Features and Concepts
{Load on Demand}


Advanced Load on Demand

Advanced Load on Demand
See Also Send Feedback
Intersoft WebTreeView > Features and Concepts > Advanced Load on Demand

Glossary Item Box

The concept behind the advanced Load on Demand is that all physical child nodes are initialized in InitializeChildNodes event. This will give you more control on how the child nodes are initialized.

The following code demonstrates you on how to initialize a child node in InitializeChildNodes event:

C# Copy Code
protected void WebTreeView2_InitializeChildNodes(object sender, ISNet.WebUI.WebTreeView.WebTreeViewNodeEventArgs e)
{
    ISNet.WebUI.WebTreeView.WebTreeViewNode a = new ISNet.WebUI.WebTreeView.WebTreeViewNode();
    a.Name = "NewNode" + WebTreeView2.NodeIndex.ToString();
    a.Text = "New Node " + WebTreeView2.NodeIndex.ToString();

    e.Node.Nodes.Add(a);

    ISNet.WebUI.WebTreeView.WebTreeViewNode b = new ISNet.WebUI.WebTreeView.WebTreeViewNode();
    b.Name = "NewNode" + WebTreeView2.NodeIndex.ToString();
    b.Text = "New Node " + WebTreeView2.NodeIndex.ToString();

    e.Node.Nodes.Add(b);
}

In This Section

How-to: Add TreeViewNodes based on retrieved data (Load on Demand scenario)

See Also

Tasks
{Walkthrough Topics}
{FAQ and How-to Topics}

Other Resources
{Load on Demand}
WebTreeView Overview
{Features and Concepts}


How-to: Add TreeViewNodes based on retrieved data (Load On Demand scenario)

How-to: Add TreeViewNodes based on retrieved data (Load On Demand scenario)
See Also Send Feedback
Intersoft WebTreeView > Features and Concepts > Advanced Load on Demand > How-to: Add TreeViewNodes based on retrieved data (Load On Demand scenario)

Glossary Item Box

You can add TreeViewNodes based on retrieved data. This scenario can only be done in unbound TreeView mode.

This topic will show you how to implement the above scenario.

To add TreeViewNodes based on retrieved data (Load On Demand scenario)

  1. Right click on WebTreeView and choose Properties to open its Properties window.
  2. Set EnableLoadOnDemand to True.
  3. Create a dataset and named it dsNorthwind. This dataset will be used to get data from database and the data will be added to WebTreeView.

  4. Right click on WebTreeView control and choose WebTreeView.NET Designer. Switch to Tree Editor tab and create a parent node in the WebTreeView.

  5. Implement WebTreeView's InitializeChildNodes server side event.

    C# Copy Image Copy Code
    protected void WebTreeView1_InitializeChildNodes(object sender, ISNet.WebUI.WebTreeView.WebTreeViewNodeEventArgs e)
{
   PopulateNode(e.Node);
}

private void PopulateNode(WebTreeViewNode node)
{
   // Call the appropriate method to populate a node at a particular level.
   switch (node.Depth)
   {
      case 0:
         // Populate the first-level nodes.
         PopulateCategories(node);
         break;
      case 1:
         // Populate the second-level nodes.
         PopulateProducts(node);
         break;
      default:
         // Do nothing.
         break;
   }
}

private void PopulateCategories(WebTreeViewNode node)
{
   // Query for the product categories. These are the values
   // for the second-level nodes.
   dsNorthwindTableAdapters.CategoriesTableAdapter adapter = new dsNorthwindTableAdapters.CategoriesTableAdapter();
   dsNorthwind.CategoriesDataTable table = adapter.GetData();

   // Create the second-level nodes.
   if (table.Count > 0)
   {
      // Iterate through and create a new node for each row in the query results.
      // Notice that the query results are stored in the table of the DataSet.
      foreach (dsNorthwind.CategoriesRow row in table.Rows)
      {
         WebTreeViewNode newNode = new WebTreeViewNode();
         newNode.Name = "Category" + row.CategoryID.ToString();
         newNode.Text = row.CategoryName;
         newNode.Value = row.CategoryID;

         node.Nodes.Add(newNode);
      }
   }
}

private void PopulateProducts(WebTreeViewNode node)
{
   // Query for the products of the current category. These are the values
   // for the third-level nodes.
   dsNorthwindTableAdapters.ProductsTableAdapter adapter = new dsNorthwindTableAdapters.ProductsTableAdapter();
   dsNorthwind.ProductsDataTable table = adapter.GetDataByCategoryID((int)node.Value);

   // Create the second-level nodes.
   if (table.Count > 0)
   {
      // Iterate through and create a new node for each row in the query results.
      // Notice that the query results are stored in the table of the DataSet.
      foreach (dsNorthwind.ProductsRow row in table.Rows)
      {
         WebTreeViewNode newNode = new WebTreeViewNode();
         newNode.Name = "Product" + row.ProductID.ToString();
         newNode.Text = row.ProductName;
         newNode.Value = row.ProductID;

         node.Nodes.Add(newNode);
      }
   }
}

protected void WebTreeView1_InitializeNode(object sender, WebTreeViewNodeEventArgs e)
{
   if (e.Node.Depth == 2)
      e.Node.ChildNodeExpandable = false;
}

  6. Run the sample and you will get a result like screen shot below.

See Also

Tasks
{Walkthrough Topics}
{FAQ and How-to Topics}

Concepts
{Advanced Load on Demand}


Keyboard Navigation

Keyboard Navigation
See Also Send Feedback
Intersoft WebTreeView > Features and Concepts > Keyboard Navigation

Glossary Item Box

WebTreeView.NET® 1.0 supports both mouse navigation and keyboard navigation which will enhance your end-user's interactivity when using WebTreeView.NET.

WebTreeView.NET® 1.0 supports basic desktop-based keyboard navigation such as:

  • You can also use the arrow navigation (left, right, up, down, home, delete) to navigate our WebTreeView.NET® 1.0.
  • Press F2 to perform inline-node editing.
  • CTRL + Z to undo any inline-node editing.
  • Press Delete to delete node(s).

WebTreeView.NET® 1.0 is also equipped with multiple node selection using the CTRL and SHIFT key. You only need to set the AllowMultipleSelect to True.

In This Section

How-to: Enable keyboard navigation

See Also

Tasks
{Walkthrough Topics}
{FAQ and How-to Topics}

Other Resources
WebTreeView Overview
{Features and Concepts}


How-to: Enable keyboard navigation

How-to: Enable keyboard navigation
See Also Send Feedback
Intersoft WebTreeView > Features and Concepts > Keyboard Navigation > How-to: Enable keyboard navigation

Glossary Item Box

You can allow keyboard navigation feature in WebTreeView.

This topic will show you how to implement the above scenario.

To allow keyboard navigation in WebTreeView

  1. Right click on WebTreeView instance and choose Properties to open its Properties window.
  2. Set the AllowKeyboardNavigation property to True.
  3. Run the project.

See Also

Tasks
{Walkthrough Topics}
{FAQ and How-to Topics}

Concepts
{Keyboard Navigation}


Path

Path
See Also Send Feedback
Intersoft WebTreeView > Features and Concepts > Path

Glossary Item Box

Path in WebTreeView.NET® 1.0 can be defined as a line which connects a node from the root node to the node itself. WebTreeView.NET has three built-in powerful feature related to path such as listed in the following:

  • Find node by path
    WebTreeView.NET has a built-in FindNodeByPath() method which allows you to find a node by the given path. This means that you can perform any action you desired to the node just by providing the path of a node.

    JavaScript Copy Code
    function Button1_onclick()
{
   var tv = ISGetObject("WebTreeView1");
   var value = document.getElementById("txtPath").value;
   var node =  tv.FindNodeByPath(value);
   var divStatus = document.getElementById("divWebTreeView1Node");
   divStatus.innerHTML = "";
   if (node!=null)
   {
      node.Select();
      divStatus.innerHTML = "Node name :" + node.Name;
   }
   else
   {
      divStatus.innerHTML = "node is not found";
   }
}

    When executed, the code above will select a node based on the path typed in the textbox. Please refer to our WebTreeView.NET® 1.0 Sample. The following sample scenario can be done easily by using our WebTreeView.NET. Please refer to the java script below on how to get the selected node�??s path.

    JavaScript Copy Image Copy Code
    function doWebTreeView1NodeSelect(ctrlId, node)

    {
       var divStatus = document.getElementById("divWebTreeViewNodeDepth");
       document.getElementById(    "tdNode").innerHTML = node.Name;
       document.getElementById("tdPath").innerHTML = node.GetPath();
    }
  • Identify a node as a unique node
    Path is unique. Every node has its own unique path. This is what differ a node from the others. There is certain scenario that two nodes have the same name. This is possible if both nodes are on the different level or when two nodes are located in two different parents. Path is an important feature when it comes to this kind of scenario.

    The sample below clearly demonstrating this feature. There are two �??My Folder�?� nodes, but both have different path.

  • Show the hierarchy of a node
    A tree view is a collection of nodes which present a hierarchical data presentation. This node can have items or child nodes and the child nodes can also have child nodes. This is what we call the hierarchy of a node. A node always has a parent node. If it is a single level node, then the single node is the parent node.

    WebTreeView.NET incorporates powerful built-in API which can be used to get the hierarchy of a node. This can be achieved by using GetParentNode(). Please refer to the sample below.

    JavaScript Copy Code
    function doWebTreeView1NodeSelect(ctrlId, node)
{
   var parentNode = node.GetParentNode();
   var parentNodeName = "";
   document.getElementById("tdNode").innerHTML = node.Name;

   if(parentNode!=null)
   {
      parentNodeName = parentNode.Name;
   }
   else
   {
      parentNodeName = "-";
   }
   document.getElementById("tdParent").innerHTML = (parentNodeName);
}

    When you select a node, it will show you the node information and its parent node name.

In This Section

How-to: Find node by path

See Also

Tasks
{Walkthrough Topics}
{FAQ and How-to Topics}

Other Resources
WebTreeView Overview
{Features and Concepts}


How-to: Find node by path

How-to: Find node by path
See Also Send Feedback
Intersoft WebTreeView > Features and Concepts > Path > How-to: Find node by path

Glossary Item Box

WebTreeView gives you a way to find the node by path.

In this topic, you will learn how to find node by path.

To find node by path

  1. Bind WebGrid to XMLDataSource. Please use Desktop.xml as the XMLDataSource's file. You can find Desktop.xml in LiveSample's AppData folder.
  2. Drag HTML TextBox, Button and div controls to the WebForm.
  3. TextBox is used to specify the path, Button is used to find the node in WebTreeView and select the node, and div is used to specify the finding information whether the node is found or not.
  4. Set TextBox's ID to txtPath and the div's ID to divWebTreeViewNode.
  5. Implement onclick client side event for the HTML Button like following:

    JavaScript Copy Image Copy Code
    function Button1_onclick()
{
   var tv = ISGetObject("WebTreeView1");
   var node = tv.FindNodeByPath(document.getElementById("txtPath").value);
   var divStatus = document.getElementById("divWebTreeView1Node");
   divStatus.innerHTML = "";
   if (node!=null)
   {
      node.Select();
      divStatus.innerHTML = "Node is found
    Node name : " + node.Name;
   }
   else
   {
      divStatus.innerHTML = "Node is not found";
   }
}

  6. Try to specify the TextBox with "Desktop/My Documents" and click the button. For more information, please refer to Find Node by Path sample in LiveSamples >> WebTreeView >> Client Programmability.

See Also

Tasks
{Walkthrough Topics}
{FAQ and How-to Topics}

Concepts
{Path}


Automatically select a node on expand or collapse

Automatically select a node on expand or collapse
See Also Send Feedback
Intersoft WebTreeView > Features and Concepts > Automatically select a node on expand or collapse

Glossary Item Box

WebTreeView.NET allows you to automatically select a node on expand or collapse. You only need to set AutoSelectNodeOnExpandCollapse to True. Please refer to the following code.

Component's Tags Copy Image Copy Code
<ISWebTreeView:WebTreeView ID="WebTreeView1" runat="server"
AutoCheckChildNodes="True" AutoGenerateDataBindings="True" DataSourceID="XmlDataSource1"
Height="300px" Width="300px" AutoSelectOnNodeExpandCollapse="True">
<FrameStyle BorderStyle="Solid" BorderWidth="1px" BorderColor="Gray">
</FrameStyle>
<DataBindings>
   <ISWebTreeView:WebTreeViewNodeBinding DataMember="Root" TextField="name"/>
   <ISWebTreeView:WebTreeViewNodeBinding DataMember="Group" TextField="name"/>
</DataBindings>
<NodeStyle>
   <Active ForeColor="White" BaseStyle="Normal" BackColor="Navy">
   </Active>
   <Over BaseStyle="Normal" Font-Underline="True">
   </Over>
   <Normal Font-Size="9pt" Font-Names="Segoe UI" Overflow="Hidden" Cursor="Default" OverflowX="Hidden" OverflowY="Hidden">
      <Padding Left="1px" Right="3px">
      </Padding>
   </Normal>
</NodeStyle>
</ISWebTreeView:WebTreeView>
<asp:XmlDataSource ID="XmlDataSource1" runat="server" DataFile="~/Products.xml">
</asp:XmlDataSource>

In This Section

How-to: Expand and collapse by selecting the nodes

How-to: Automatically select node on expand and collapse

How-to: Expand and collapse the selected node

How-to: Toggle expand collapse of the selected node

How-to: Expand and collapse the selected node with its children

How-to: Expand and collapse all nodes in WebTreeView

See Also

Tasks
{Walkthrough Topics}
{FAQ and How-to Topics}

Other Resources
WebTreeView Overview
{Features and Concepts}


How-to: Expand and collapse by selecting the nodes

How-to: Expand and collapse by selecting the nodes
See Also Send Feedback
Intersoft WebTreeView > Features and Concepts > Automatically select a node on expand or collapse > How-to: Expand and collapse by selecting the nodes

Glossary Item Box

By default, when you select a node in WebTreeView, the node will be expanded. However, you can also set WebTreeView to collapse when the expanded node is selected.

The default value of AllowExpandNodeOnSelect is True and AllowCollapseNodeOnSelect is False.

In this topic, you will learn how to expand and collapse by selecting the nodes.

To expand and collapse by selecting the nodes.

  1. Bind WebTreeView to XMLDataSource.
  2. Set WebTreeView's properties >> AllowCollapseNodeOnSelect to True.

See Also

Tasks
{How-to: Automatically select node on expand and collapse}
{How-to: Perform various expand and collapse node in WebTreeView}
{How-to: Expand and collapse the selected node}
{How-to: Toggle expand collapse of the selected node}
{How-to: Expand and collapse the selected node with its children}

Concepts
{Automatically select a node on expand or collapse}


How-to: Customize Expand and Collapse

How-to: Customize Expand and Collapse
Send Feedback
Intersoft WebTreeView > Features and Concepts > Automatically select a node on expand or collapse > How-to: Customize Expand and Collapse

Glossary Item Box

By default, when you select a node in WebTreeView, the node will be expanded. However, you can also set WebTreeView to collapse when the expanded node is selected.

The default value of AllowExpandNodeOnSelect is True and AllowCollapseNodeOnSelect is False.

In this topic, you will learn how to customize expand and collapse.

To expand and collapse by selecting the nodes.

  1. Bind WebTreeView to XMLDataSource.
  2. Set WebTreeView's properties >> AllowCollapseNodeOnSelect to True.
  3. If both properties are set to False, simply double clicking the node to expand and collapse.

To expand and collapse the selected node

  1. Bind WebTreeView to XMLDataSource.
  2. Drag 2 HTML buttons to the WebForm.
  3. Button1 will perform expanding selected node with Expand() method.
  4. Button2 will perform collapsing selected node with Collapse() method.

    JavaScript Copy Image Copy Code
    // Add this code to Expand selected node's button
function Button1_onclick()
{
   var tv = ISGetObject("WebTreeView1");
   if (tv.GetSelectedNode()!=null)
   {
      tv.GetSelectedNode().Expand();
   }
   else
      alert("Please select a node first !");}

// Add this code to Collapse selected node's button
function Button2_onclick()
{
   var tv = ISGetObject("WebTreeView1");
   if (tv.GetSelectedNode()!=null)
   {
      tv.GetSelectedNode().Collapse();
   }
   else
      alert("Please select a node first !");
}

  5. Run the application and try to click each button to see the result. For more information, please refer to Expand and Collapse Node sample in LiveSamples >> WebTreeView >> Expand Collapse Behaviors.

To toggle expand collapse of the selected node

  1. Bind WebTreeView to XMLDataSource.
  2. Drag a HTML button to the WebForm.
  3. The button will perform toggle expand collapse of the selected node with ToggleExpandCollapse() method.

    JavaScript Copy Image Copy Code
    // Add this code to Toggle expand collapse selected node's button
function Button1_onclick()
{
   var tv = ISGetObject("WebTreeView1");
   if (tv.GetSelectedNode()!=null)
   {
      tv.GetSelectedNode().ToggleExpandCollapse();
   }
   else
      alert("Please select a node first !");
}

  4. Run the application and try to click each button to see the result. For more information, please refer to Expand and Collapse Node sample in LiveSamples >> WebTreeView >> Expand Collapse Behaviors.

To expand and collapse all nodes

  1. Bind WebTreeView to XMLDataSource.
  2. Drag 2 HTML buttons to the WebForm.
  3. Button1 will perform expanding all nodes with ExpandAll() method.
  4. Button2 will perform collapsing nodes with CollapseAll() method.

    JavaScript Copy Image Copy Code
    // Add this code to Expand all nodes's button
function Button1_onclick()
{
   var tv = ISGetObject("WebTreeView1");
   tv.ExpandAll();
}

// Add this code to Collapse all nodes's button
function Button2_onclick()
{
   var tv = ISGetObject("WebTreeView1");
   tv.CollapseAll();
}

  5. Run the application and try to click each button to see the result. For more information, please refer to Expand and Collapse Node sample in LiveSamples >> WebTreeView >> Expand Collapse Behaviors.


How-to: Automatically select node on expand and collapse

How-to: Automatically select node on expand and collapse
See Also Send Feedback
Intersoft WebTreeView > Features and Concepts > Automatically select a node on expand or collapse > How-to: Automatically select node on expand and collapse

Glossary Item Box

By default, when user clicks the +/- (plus/minus) icon of WebTreeView, the node will not be selected. However, WebTreeView provides a way to implement that scenario.

In this topic, you will learn how to automatically select node on expand and collapse.

To automatically select node on expand and collapse.

  1. Bind WebTreeView to XMLDataSource.
  2. Set WebTreeView's properties >> AutoSelectOnNodeExpandCollapse to True.
  3. Run the sample and try to expand and collapse a node by clicking on the +/- (plus/minus) icon.

See Also

Tasks
{How-to: Expand and collapse by selecting the nodes}
{How-to: Perform various expand and collapse node in WebTreeView}
{How-to: Expand and collapse the selected node}
{How-to: Expand and collapse the selected node with its children}
{How-to: Toggle expand collapse of the selected node}

Concepts
{Automatically select a node on expand or collapse}


How-to: Expand and collapse the selected node

How-to: Expand and collapse the selected node
See Also Send Feedback
Intersoft WebTreeView > Features and Concepts > Automatically select a node on expand or collapse > How-to: Expand and collapse the selected node

Glossary Item Box

WebTreeView provides a way to expand and collapse the selected node in WebTreeView from client side.

In this topic, you will learn how to implement the above scenario.

To expand and collapse the selected node

  1. Bind WebTreeView to XMLDataSource.
  2. Drag 2 HTML buttons to the WebForm.
  3. Button1 will perform expanding selected node with Expand() method.
  4. Button2 will perform collapsing selected node with Collapse() method.

    Javascript Copy Image Copy Code
    // Add this code to Expand selected node's button
function Button1_onclick()
{
   var tv = ISGetObject("WebTreeView1");
   if (tv.GetSelectedNode()!=null)
   {
      tv.GetSelectedNode().Expand();
   }
   else
      alert("Please select a node first !");}

// Add this code to Collapse selected node's button
function Button2_onclick()
{
   var tv = ISGetObject("WebTreeView1");
   if (tv.GetSelectedNode()!=null)
   {
      tv.GetSelectedNode().Collapse();
   }
   else
      alert("Please select a node first !");
}

  5. Run the application and try to click each button to see the result. For more information, please refer to Expand and Collapse Node sample in LiveSamples >> WebTreeView >> Expand Collapse.

See Also

Tasks
{How-to: Expand and collapse by selecting the nodes}
{How-to: Automatically select node on expand and collapse}
{How-to: Toggle expand collapse of the selected node}
{How-to: Expand and collapse the selected node with its children}
{How-to: Expand and collapse all nodes in WebTreeView}

Concepts
{Automatically select a node on expand or collapse}


How-to: Toggle expand collapse of the selected node

How-to: Toggle expand collapse of the selected node
See Also Send Feedback
Intersoft WebTreeView > Features and Concepts > Automatically select a node on expand or collapse > How-to: Toggle expand collapse of the selected node

Glossary Item Box

WebTreeView provides a way to toggle expand collapse of the selected node in WebTreeView from client side.

In this topic, you will learn how to implement the above scenario.

To toggle expand collapse of the selected node

  1. Bind WebTreeView to XMLDataSource.
  2. Drag a HTML button to the WebForm.
  3. The button will perform toggle expand collapse of the selected node with ToggleExpandCollapse() method.

    Javascript Copy Image Copy Code
    // Add this code to Toggle expand collapse selected node's button
function Button1_onclick()
{
   var tv = ISGetObject("WebTreeView1");
   if (tv.GetSelectedNode()!=null)
   {
      tv.GetSelectedNode().ToggleExpandCollapse();
   }
   else
      alert("Please select a node first !");
}

  4. Run the application and try to click each button to see the result. For more information, please refer to Expand and Collapse Node sample in LiveSamples >> WebTreeView >> Expand Collapse.

See Also

Tasks
{How-to: Expand and collapse by selecting the nodes}
{How-to: Automatically select node on expand and collapse}
{How-to: Expand and collapse the selected node}
{How-to: Expand and collapse the selected node with its children}
{How-to: Expand and collapse all nodes in WebTreeView}

Concepts
{Automatically select a node on expand or collapse}


How-to: Expand and collapse the selected node with its children

How-to: Expand and collapse the selected node with its children
See Also Send Feedback
Intersoft WebTreeView > Features and Concepts > Automatically select a node on expand or collapse > How-to: Expand and collapse the selected node with its children

Glossary Item Box

WebTreeView provides a way to toggle expand collapse of the selected node in WebTreeView from client side.

In this topic, you will learn how to implement the above scenario.

To expand and collapse of the selected node with its children

  1. Bind WebTreeView to XMLDataSource.
  2. Drag 2 HTML buttons to the WebForm.
  3. Button1 will perform expanding selected node and its children's with ExpandAll() method.
  4. Button2 will perform collapsing selected node and its children's with CollapseAll() method.

    Javascript Copy Image Copy Code
    // Add this code to Expand selected node and its children's button
function Button1_onclick()
{
   var tv = ISGetObject("WebTreeView1");
   if (tv.GetSelectedNode()!=null)
   {
      tv.GetSelectedNode().ExpandAll();
   }
   else
      alert("Please select a node first !");
}

// Add this code to Collapse selected node and its children's button
function Button2_onclick()
{
   var tv = ISGetObject("WebTreeView1");
   if (tv.GetSelectedNode()!=null)
   {
      tv.GetSelectedNode().CollapseAll();
   }
   else
      alert("Please select a node first !");
}

  5. Run the application and try to click each button to see the result. For more information, please see Expand and Collapse Node sample in LiveSamples >> WebTreeView >> Expand Collapse.

See Also

Tasks
{How-to: Expand and collapse by selecting the nodes}
{How-to: Automatically select node on expand and collapse}
{How-to: Expand and collapse the selected node}
{How-to: Toggle expand collapse of the selected node}
{How-to: Expand and collapse all nodes in WebTreeView}

Concepts
{Automatically select a node on expand or collapse}


How-to: Expand and collapse all nodes in WebTreeView

How-to: Expand and collapse all nodes in WebTreeView
See Also Send Feedback
Intersoft WebTreeView > Features and Concepts > Automatically select a node on expand or collapse > How-to: Expand and collapse all nodes in WebTreeView

Glossary Item Box

WebTreeView provides a way to expand and collapse all nodes in WebTreeView from client side.

In this topic, you will learn how to implement the above scenario.

To expand and collapse all nodes

  1. Bind WebTreeView to XMLDataSource.
  2. Drag 2 HTML buttons to the WebForm.
  3. Button1 will perform expanding all nodes with ExpandAll() method.
  4. Button2 will perform collapsing nodes with CollapseAll() method.

    Javascript Copy Image Copy Code
    // Add this code to Expand all nodes's button
function Button1_onclick()
{
   var tv = ISGetObject("WebTreeView1");
   tv.ExpandAll();
}

// Add this code to Collapse all nodes's button
function Button2_onclick()
{
   var tv = ISGetObject("WebTreeView1");
   tv.CollapseAll();
}

  5. Run the application and try to click each button to see the result. For more information, please refer to Expand and Collapse Node sample in LiveSamples >> WebTreeView >> Expand Collapse.

See Also

Tasks
{How-to: Expand and collapse by selecting the nodes}
{How-to: Automatically select node on expand and collapse}
{How-to: Expand and collapse the selected node}
{How-to: Toggle expand collapse of the selected node}
{How-to: Expand and collapse the selected node with its children}

Concepts
{Automatically select a node on expand or collapse}


Animation during expanding or collapsing a node

Animation during expanding or collapsing a node
See Also Send Feedback
Intersoft WebTreeView > Features and Concepts > Animation during expanding or collapsing a node

Glossary Item Box

This eye candy feature embedded in our WebTreeView.NET® 1.0 will feast your customer�??s eyes for animated and interactive user interface when expand or collapse a node. If you set the EnableAnimation property to True, you will be able to enjoy the sliding animation during expanding or collapsing. This proves that our WebTreeView.NET® 1.0 is made to fulfill your customer�??s need.

To enable the collapse and expand animation, open the properties window, expand the NodeSettings and set the EnableAnimation to True.

See Also

Tasks
{Walkthrough Topics}
{FAQ and How-to Topics}

Other Resources
WebTreeView Overview
{Features and Concepts}


Customizing styles, appearance and images

Customizing styles, appearance and images
See Also Send Feedback
Intersoft WebTreeView > Features and Concepts > Customizing styles, appearance and images

Glossary Item Box

Besides incorporating numerous features, WebTreeView is also highly customizable in terms of style, appearance, and images of the node and frame.

You can easily customize WebTreeView to any style and appearance. The Web-based Vista Explorer replica is a perfect sample describing this scenario. Please take a look at the code below.

Notice the above example and you�??ll see that these following properties are set:

Property | Description
BorderColor | Sets the color of the WebTreeView's border.
BorderStyle | Sets the border's style of the WebTreeView.
BroderWidth | Sets the border's width of the WebTreeView.
BackgroundImage | Sets each node's background image.
Font-Names | Sets the font style to be applied to WebTreeView. This can be set under the Font property.
Font-Size | Sets the size of the font to be applied to WebTreeView. This can also be set under the Font property.
Padding left | Determines the amounts of space on the left of WebTreeView.
Padding right | Determines the amounts of space on the right of WebTreeView.
Font-Underline | Sets underline style to each node in WebTreeView.
Overflow | Shows or hides the WebTreeView's scrollbar.
Overflow-X | Shows or hides the WebTreeView's horizontal scrollbar.
Overflow-Y | Shows or hides the WebTreeView's vertical scrollbar

  • Frames Appearance
    Frame appearance is an ASP.NET inherited style. This enables you to customize the basic appearance of WebTreeView. You can easily set the background color, font and its color, border color, width, and style.
  • Appearance
    Appearance is WebTreeView�??s own style. It provides you numerous properties to set which will help you create and customize your WebTreeView easily. Under the appearance property, you can set the Frame Style, Node Style (Active state, Normal state, and Over state), the loading image and the text. Please see our documentation for the complete list.
  • Images
    Another style you can customize is the images. The images can be set in the ImageSettings property.

    Property | Description
    CheckBoxFalseImage | Gets or sets the images used to render false checkbox.
    CheckBoxPartialImage | Gets or sets the image used to render partial checkbox.
    CheckBoxTrueImage | Gets or sets the images used to render false checkbox.
    CollapseImage | Gets or sets the image used to render node when node is collapsed.
    ExpandedParentNodeImage | Gets or sets the image used to render expanded parent level node.
    ExpandedRootNodeImage | Gets or sets the image used to render expanded root level mode.
    ExpandedSelectedParentNode | Gets or sets the image used to render expanded parent level node when node is selected.
    ExpandImage | Gets or sets the image used to render node when node is expanded.
    LeafNodeImage | Gets or sets the images used to render leaf level node.
    ParentNodeImage | Gets or sets the image used to render parent level node.
    RootNodeImage | Gets or sets the image used to render root level node.
    SelectedLeafNodeImage | Gets or sets the image used to render selected leaf level node.
    SelectedParentNodeImage | Gets or sets the image used to render selected parent level node.
    SelectedRootNode | Gets or sets the image used to render selected root level node.

In This Section

How-to: Customize loading style and text

How-to: Specify +/- (plus/minus) sign

How-to: Specify text image

How-to: Show/hide TreeView lines

See Also

Tasks
{Walkthrough Topics}
{FAQ and How-to Topics}

Other Resources
WebTreeView Overview
{Features and Concepts}


How-to: Customize loading style and text

How-to: Customize loading style and text
See Also Send Feedback
Intersoft WebTreeView > Features and Concepts > Customizing styles, appearance and images > How-to: Customize loading style and text

Glossary Item Box

You can set loading style and text feature in WebTreeView.

This topic will show you how to implement the above scenario.

To customize Loading style and text in WebTreeView

  1. Right click on WebTreeView instance and choose Properties to open it.
  2. Set the LoadingText property to "loading more data".
  3. In LoadingStyle property, set BackColor to Red and FontName to Segoe UI.
  4. Run the project.

See Also

Tasks
{How-to: Specify +/- (plus/minus) sign}
{How to: Specify node image}
{How to: Specify text image}
{How-to: Show/hide TreeView lines}

Concepts
{Customizing styles, appearance and images}


How-to: Specify +/- (plus/minus) sign

How-to: Specify +/- (plus/minus) sign
See Also Send Feedback
Intersoft WebTreeView > Features and Concepts > Customizing styles, appearance and images > How-to: Specify +/- (plus/minus) sign

Glossary Item Box

You can specify +/- (plus/minus) sign for WebTreeView.

This topic will show you how to implement the above scenario.

To specify +/- (plus/minus) sign

  1. Right click on WebTreeView instance and choose Properties to open Properties Window.
  2. Set the ShowExpandCollapse property to True.

    - At ImagesSettings, if you change the PlusImage and MinusImage properties than the ShowLines property will change automatically to False, which will make the TreeView line disappeared and all settings inside ImageSettings will be ignored.

    - If you want to change the +/- (plus/minus) sign and show the line, then you need to set all properties inside ImageSettings except for PlusImage and MinusImage (Both properties value need to be set to the default value).
  3. Run the project.

See Also

Tasks
{How-to: Customize loading style and text}
{How to: Specify node image}
{How to: Specify text image}
{How-to: Show/hide TreeView lines}

Concepts
{Customizing styles, appearance and images}


How to: Specify text image

How to: Specify text image
See Also Send Feedback
Intersoft WebTreeView > Features and Concepts > Customizing styles, appearance and images > How to: Specify text image

Glossary Item Box

You can specify text image in WebTreeView beside text for a clearer view.

This topic will show you how to specify text image in WebTreeView.

To specify text image in WebTreeView

  1. Right click on WebTreeView instance and choose Properties to open its Properties window.
  2. Open DataBindings property collection
  3. Set the TextImageField property for name field in selected data binding.
  4. Run the project.

See Also

Tasks
{How-to: Customize loading style and text}
{How-to: Specify +/- (plus/minus) sign}
{How to: Specify node image}
{How-to: Show/hide TreeView lines}

Concepts
{Customizing styles, appearance and images}


How-to: Show/hide TreeView lines

How-to: Show/hide TreeView lines
See Also Send Feedback
Intersoft WebTreeView > Features and Concepts > Customizing styles, appearance and images > How-to: Show/hide TreeView lines

Glossary Item Box

You can show or hide TreeView lines from WebTreeView properties.

This topic will show you how to implement the above scenario.

To show/hide lines in WebTreeView

  1. Right click on WebTreeView instance and choose Properties to open its Properties window.
  2. Set the ShowLines property to True if you want to show TreeView lines, and vice versa.
  3. Run the project.

See Also

Tasks
{How-to: Customize loading style and text}
{How-to: Specify +/- (plus/minus) sign}
{How to: Specify node image}
{How to: Specify text image}

Concepts
{Customizing styles, appearance and images}


How-to: Customize Visual Styles

How-to: Customize Visual Styles
Send Feedback
Intersoft WebTreeView > Features and Concepts > Customizing styles, appearance and images > How-to: Customize Visual Styles

Glossary Item Box

WebTreeView provides predefined visual styles that you can use to customize WebTreeView styles.

In this topic, you will learn how to customize visual styles from designer.

To customize visual styles

  1. Open WebTreeView.NET Designer.
  2. Go to Layout Manager and expand Predefined Layout.
  3. Select any available styles such as Contact, Outlook, Visa and etc.
  4. Click OK to apply the changes.
  5. Run the project.


Node Editing

Node Editing
See Also Send Feedback
Intersoft WebTreeView > Features and Concepts > Node Editing

Glossary Item Box

WebTreeView.NET also comes with the node editing ability. Node editing means that you can add a node, delete a node, and edit a node. These three client-side actions provide you full control over a node. In order to take advantage of this feature, you need to set AllowAddNode, AllowDeleteNode, AllowNodeEditing to Yes.

JavaScript Copy Code
function Button1_onclick()

{
  var name = document.getElementById("txtNode");
  var text = document.getElementById("txtText");

  if (name.value==null || name.value=="")
  {
     alert("node name cannot be empty");
     name.focus();
  }
  else
  {
     var tv = ISGetObject("WebTreeView1");
     var selectedNode = tv.GetSelectedNode();
     if (selectedNode==null)
        tv.AddNode(name.value);
     else
        selectedNode.AddNode(name.value);

       name.value = "node" + (tv.NodeIndex + 1);
  }
}

The above code is a sample on how to implement AllowAddNode feature easily. The AddNode(nodeObject) method will add a new node which is passed as a parameters to your WebTreeView when called. If the method is called from WebTreeView object, the node will be created as a root node, but if the method is called from an existing WebTreeViewNode, the new node will be treated as a child node.

The DeleteNode(nodeObject) method will delete a node when called.

JavaScript Copy Image Copy Code
var tv = ISGetObject("WebTreeView1")
tv.DeleteNode(node1); //node1 is a node object

The DeleteNode() method works for all node level, root node, child, grand child node. If you delete a parent node, the parent's child node will also be deleted. This is the default behavior.

If you set the AllowNodeEditing to Yes, your end-users will be able to edit the node's name by using your keyboard and mouse.

In This Section

How-to: Add node in WebTreeView

How-to: Edit node in WebTreeView

How-to: Remove node in WebTreeView

See Also

Tasks
{Walkthrough Topics}
{FAQ and How-to Topics}

Other Resources
WebTreeView Overview
{Features and Concepts}


How-to: Enable Node Editing

How-to: Enable Node Editing
Send Feedback
Intersoft WebTreeView > Features and Concepts > Node Editing > How-to: Enable Node Editing

Glossary Item Box

In WebTreeView, you can perform add, edit and remove the WebTreeViewNode.

This topic will show you how to enable node editing using client-side events.

To add node in WebTreeView

  1. Go to WebTreeView's properties and set AllowAddNode to True.
  2. You can add WebTreeViewNode in client side using AddNode("Node's Name", "Node's Text) method.
  3. Implement onclick (button) client side event and add the following code:

    JavaScript Copy Image Copy Code
    function Button1_onclick()
{
    var treeView = ISGetObject("WebTreeView1");
    treeView.AddNode("Node1", "BasketBall");
}

  4. To add a new node, select WebTreeViewNode (the path where the new node will be placed) and then click the button.

To edit node in WebTreeView

  1. Go to WebTreeView's properties and set AllowNodeEditing to Yes.
  2. You can edit the WebTreeViewNode by clicking twice to the WebTreeViewNode or press F2.

To remove node in WebTreeView

  1. Go to WebTreeView's properties and set AllowDeleteNode to True.
  2. You can delete the WebTreeViewNode by selecting the node that you want to delete and press Delete button.
  3. You can also delete the WebTreeView node from client side using DeleteNode(WebTreeViewNode) method.
  4. Implement onclick (button) client side event and add the following code:

    JavaScript Copy Image Copy Code
    function Button1_onclick()
{
   var treeView = ISGetObject("WebTreeView1");
   //Get selected WebTreeViewNode
   var node = treeView.GetSelectedNode();
   treeView.DeleteNode(node);
}

  5. Run the project.


How-to: Add node in WebTreeView

How-to: Add node in WebTreeView
See Also Send Feedback
Intersoft WebTreeView > Features and Concepts > Node Editing > How-to: Add node in WebTreeView

Glossary Item Box

In WebTreeView, you can perform add, edit and remove the WebTreeViewNode.

This topic will show you how to add node in WebTreeView client side event.

To add node in WebTreeView

  1. Go to WebTreeView's properties and set AllowAddNode to True.
  2. You can add WebTreeViewNode in client side using AddNode("Node's Name", "Node's Text) method.
  3. Implement onclick (button) client side event and add the following code:

    Javascript Copy Image Copy Code
    function Button1_onclick()
{
    var treeView = ISGetObject("WebTreeView1");
    treeView.AddNode("Node1", "BasketBall");
}

  4. To add a new node, select WebTreeViewNode (the path where the new node will be placed) and then click the button.

See Also

Tasks
{How-to: Edit node in WebTreeView}
{How-to: Remove node in WebTreeView}
{Walkthrough Topics}
{FAQ and How-to Topics}

Concepts
{Node Editing}


How-to: Edit node in WebTreeView

How-to: Edit node in WebTreeView
See Also Send Feedback
Intersoft WebTreeView > Features and Concepts > Node Editing > How-to: Edit node in WebTreeView

Glossary Item Box

In WebTreeView, you can perform add, edit and remove the WebTreeViewNode.

This topic will show you how to edit node in WebTreeView.

To edit node in WebTreeView

  1. Go to WebTreeView's properties and set AllowNodeEditing to Yes.
  2. You can edit the WebTreeViewNode by clicking twice to the WebTreeViewNode or press F2.

See Also

Tasks
{How-to: Add node in WebTreeView}
{How-to: Remove node in WebTreeView}
{Walkthrough Topics}
{FAQ and How-to Topics}

Concepts
{Node Editing}


How-to: Remove node in WebTreeView

How-to: Remove node in WebTreeView
See Also Send Feedback
Intersoft WebTreeView > Features and Concepts > Node Editing > How-to: Remove node in WebTreeView

Glossary Item Box

In WebTreeView, you can perform add, edit and remove the WebTreeViewNode.

This topic will show you how to remove node in WebTreeView.

To remove node in WebTreeView

  1. Go to WebTreeView's properties and set AllowDeleteNode to True.
  2. You can delete the WebTreeViewNode by selecting the node that you want to delete and press Delete button.
  3. You can also delete the WebTreeView node from client side using DeleteNode(WebTreeViewNode) method.
  4. Implement onclick (button) client side event and add the following code:

    Javascript Copy Image Copy Code
    function Button1_onclick()
{
   var treeView = ISGetObject("WebTreeView1");
   //Get selected WebTreeViewNode
   var node = treeView.GetSelectedNode();
   treeView.DeleteNode(node);
}

  5. Run the project.

See Also

Tasks
{How-to: Add node in WebTreeView}
{How-to: Edit node in WebTreeView}
{Walkthrough Topics}
{FAQ and How-to Topics}

Concepts
{Node Editing}


Using NavigateURL and Target

Using NavigateURL and Target
See Also Send Feedback
Intersoft WebTreeView > Features and Concepts > Using NavigateURL and Target

Glossary Item Box

NavigateURL is a property which will allow you to set the URL when a node is clicked, while the TargetWindow property allows you to set in which window the URL will be displayed. You can direct it to an iFrame or even a new window.

The screenshot below demonstrates the NavigateURL and Target property:

This is the ASPX code for the above sample. This is a data bound WebTreeView. You can see that NavigateURLField value and TargetField value are taken from the XML file.

Component's Tags Copy Code
<table width="100%">
   <tr>
      <td width="250px">
         <ISWebTreeView:WebTreeView ID="WebTreeView1" runat="server" Height="280px" Width="250px" AutoGenerateDataBindings="True" DataSourceID="XmlDataSource1">          <DataBindings>
            <ISWebTreeView:WebTreeViewNodeBinding DataMember="Root" TextField="name" />
            <ISWebTreeView:WebTreeViewNodeBinding DataMember="Group" NavigateURLField="NavigationURL" TextField="name" TargetField="Target" />                   </DataBindings>
         </ISWebTreeView:WebTreeView>

         <asp:XmlDataSource ID="XmlDataSource1" runat="server" DataFile="~/Sample.xml"></asp:XmlDataSource>
      </td>
      <td valign="top">
         <iframe name="iFrame" id="iFrame" src="about:blank" style="width: 100%; height: 280px;"></iframe>
      </td>
   </tr>
</table>

In This Section

How-to: Configure NavigateURL and Target properties

See Also

Tasks
{Walkthrough Topics}
{FAQ and How-to Topics}

Other Resources
WebTreeView Overview
{Features and Concepts}


How-to: Configure NavigateURL and Target properties

How-to: Configure NavigateURL and Target properties
See Also Send Feedback
Intersoft WebTreeView > Features and Concepts > Using NavigateURL and Target > How-to: Configure NavigateURL and Target properties

Glossary Item Box

You can NavigateURL and Target for WebTreeView.

This topic will show you how to configure NavigateURL and Target properties.

To configure NavigateURL and Target properties

  1. Click WebTreeView instance and press F4.
  2. Click the Collection button in DataBindings property to show WebTreeView DataBindings Editor.
  3. Click the nodes inside Selected data bindings section.
  4. Set the NavigateURL to the defined URL and Target property to describe where the URL will be shown.

  5. Run the project.

See Also

Tasks
{Walkthrough Topics}
{FAQ and How-to Topics}

Concepts
{Using NavigateURL and Target}


Advanced Data Binding

Advanced Data Binding
See Also Send Feedback
Intersoft WebTreeView > Features and Concepts > Advanced Data Binding

Glossary Item Box

Besides the simple, easy binding, WebTreeView.NET® 1.0 is also equipped with a lot of properties you can set. This can be accessible if you add a node to the Selected data bindings box and select it. Please see the screenshot below:

Following is the list of available properties you can set:

Data | Description
DataMember | Get or set the Data Member.
Depth | Gets or set the Depth of the databinding.

DataBindings | Description
AllowEditingField | Sets a node edit ability based on the XML.
CheckedField | Initially check or uncheck node when ShowCheckBox property is set to true.
CheckedStateField | Initially sets the checked state of a node when ShowCheckBox property is set to true.
EnabledField | Enables or disables node based on the XML.
ExpandedField | Expands or collapses node based on the XML.
ExpandedImageField | Sets the expanded node image icon based on the XML.
ImageField | Sets the collapsed node image icon based on the XML.
ImageToolTipField | Sets the tooltip image icon based on the XML.
MaxBindingDepthField | Sets the node level you want to bind based on the XML.
NavigateURLField | Sets the URL when a node is selected based on the XML.
SelectableField | Specifies if a node is selected or not based on the XML.
SelectedImageField | Sets the collapse icon image of the selected node based on the XML.
ShowCheckBoxField | Shows or hides check box based on the XML.
TagField | Gets or sets a string which contains data about the WebTreeViewNode.
TargetField | Specifies the target window when the node is clicked based on the XML.
TextField | Sets the text of a node that you want to display based on the XML.
ToolTipField | Sets the tooltip of a node based on the XML.
VisibleField | Sets the visibility of a node based on the XML.

Default Properties | Description
AllowEditiing | Sets a node edit ability.
Checked | Check or uncheck a node.
CheckedState | Sets the checked state of a node.
Enabled | Enables or disables node.
Expanded | Expands or collapses node.
ExpandedImage | Sets the image icon of expanded node.
Image | Sets the image icon of collapsed node.
ImageToolTip | Sets the tooltip image icon of a node.
MaxBindingDepth | Sets the node level you want to bind.
NavigateURL | Sets the URL when a node is selected.
Selectable | Sets a node's selected ability.
Selected | Specifies if a node is selected or not.
SelectedExpandedImage | Sets the expand icon image of the selected node.
SelectedImage | Sets the collapse icon image of the selected node.
ShowCheckBox | Shows or hides check box.
Tag | Gets or sets a string which contains data about the WebTreeViewNode.
Target | Sets the target window when a node is clicked.
Text | Sets the text of a node.
ToolTip | Sets the tooltip of a node.
Value | Sets the value of a node.
Visible | Sets the visibility of a node.

Notice that both Databindings properties and Default properties are identical. The difference between them is, you can set each property value under the Databindings based on the value specified on your XML. This approach is designed to provide you with a hassle-free data binding process. You only need to set the structure of your Treeview and its properties in your XML file.

A sample of XML file which can be bound to WebTreeView.NET® 1.0

The Depth property allows you to controls which node level you want the properties to be applied. One thing you should note is that this only applicable to the same XML name. The default value for this property is -1 which means all properties will be applied to the same XML name. If you set the value to 0 (the index of a node), the properties will only be applied to all index 0 nodes.

There are some scenarios when you have two different node levels, but both nodes have the same DataMember and you need to set the different properties for each node level. This is the case when you need to change the Depth's value based on the node's index that you want to set to. Have a look at the image below and you will see that there are two different node levels, but same DataMember.

Products.xml

If you leave Depth to its default value, the Selectable properties will be applied to all nodes. You need to set the Depth to 1, if you want to apply the Selectable to "WebCombo.NET" node only. Set it to 2 if you want to apply the Selectable to "WebCombo.NET 2.0" node, "WebCombo.NET 3.0" node, and "WebCombo.NET 4.0" node.

MaxBindingDepth is a property which allows you to select how many child nodes you want to bind. This feature will be a great help when you have deep-structured XML and for example, you want to bind a parent node and the first level child node. WebTreeView provides you MaxBindingDepth property to achieve your scenario.

You only need to add a node to the Selected databindings box and set the MaxBindingDepth value to the desired child node level. Please note that the value of the MaxBindingDepth property is based on how many child node level you want to bind, so this is a relative value, not absolute value. For example, you have a deep-structured XML and you want to bind a parent node and level three child nodes only.

Notice that the grayed part will be the child nodes of Parent 2 node

Select the Parent node and add it to the Selected data bindigs box.
Set the MaxBindingDepth to 3

Run your project and it will look like the following screenshot.

In This Section

How-to: Use Advanced WebTreeView.NET® 1.0 DataBinding

See Also

Tasks
{Walkthrough Topics}
{FAQ and How-to Topics}

Other Resources
WebTreeView Overview
{Features and Concepts}


How-to: Use Advanced WebTreeView.NET® 1.0 DataBinding

How-to: Use Advanced WebTreeView.NET® 1.0 DataBinding
See Also Send Feedback
Intersoft WebTreeView > Features and Concepts > Advanced Data Binding > How-to: Use Advanced WebTreeView.NET® 1.0 DataBinding

Glossary Item Box

WebTreeView provides a feature that is able to perform advanced databinding.

In this topic, you will learn how to use advanced databinding.

To use advanced DataBinding

  1. Create a WebTreeView.NET® 1.0 instance in your design window.
  2. Drag an XMLDataSource and bind it to an XML file
  3. Use Products.xml.

  4. Click on DataBindings property
  5. Select the Root and click Add. The Root node will be added to Selected DataBindings.
  6. Next, set the SelectableField and TextField as shown in the screenshot below.

See Also

Tasks
{Walkthrough Topics}
{FAQ and How-to Topics}

Concepts
{Advanced Data Binding}


PostBack Settings

PostBack Settings
See Also Send Feedback
Intersoft WebTreeView > Features and Concepts > PostBack Settings

Glossary Item Box

By default, all WebTreeView actions, such as expand/collapse node, add/edit/remove node, etc are performed in client side. If the properties in AutoPostBackSettings are not set to True, all the changes will be stored in client side and will be submitted to the server side on the next WebForm postback. In response, the related server side events will be raised according to every node's action in client side. For example: if user adds 3 nodes and edit a node, when the next postback is performed, the NodeAdd server side events will be raised 3 times, and NodeEdit server side events will be raised one time.

Despite the default behavior, in certain scenarios you may require complex server side operation to be executed upon every successful WebTreeView operation. This can be easily achieved by setting the related properties in AutoPostBackSettings property to True. When the related properties in AutoPostBackSettings property is set to True, the related server side event will be raised on every node action. For example: when AutoPostBackSettings - OnNodeSelectChanged is set to True, postback will be performed everytime a node is selected and NodeSelectChanged server side event will be raised.
Using this feature, you can also perform AJAX callback instead of full page postback during the WebTreeView operation simply by changing PostbackModeType between to 'FlyPostBack'. This feature is compatible with other AJAX Manager such as ASP.NET AJAX and WebFlyPostbackManager.

In This Section

How-to: Enable AutoPostBack on node's select action

How-to: Update all client-side modification to physical Xml file (Batch Update)

See Also

Tasks
{Walkthrough Topics}
{FAQ and How-to Topics}

Other Resources
{Getting Started}
{Features and Concepts}


How-to: Enable AutoPostBack on node's select action

How-to: Enable AutoPostBack on node's select action
See Also Send Feedback
Intersoft WebTreeView > Features and Concepts > PostBack Settings > How-to: Enable AutoPostBack on node's select action

Glossary Item Box

You can enable AutoPostBack on node's select action.

This topic will show you how to implement the above scenario.

To enable AutoPostBack on node's select action

  1. Right click on WebTreeView instance and choose Properties to open Properties Window.
  2. Set the AutoPostBackSettings >> OnNodeSelectChanged property to True.
  3. You can also arrange the PostBack type by setting the PostBackModeTypes property to FlyPostBack or FullPostBack.
  4. For more information about this feature, you can refer to our WebTreeView sample >> PostBackSettings.aspx.

See Also

Tasks
{How-to: Update all client-side modification to physical xml file (Batch Update)}
{Walkthrough Topics}
{FAQ and How-to Topics}

Concepts
{PostBack Settings}


How-to: Update all client-side modification to physical Xml file (Batch Update)

How-to: Update all client-side modification to physical Xml file (Batch Update)
See Also Send Feedback
Intersoft WebTreeView > Features and Concepts > PostBack Settings > How-to: Update all client-side modification to physical Xml file (Batch Update)

Glossary Item Box

WebTreeView provides you a way to perform batch update.

This topic will show you how to implement the above scenario.

To update all client-side modification to physical Xml file (Batch Update)

  1. Drag WebTreeView controls to the WebForm.
  2. Drag HTML's TextBox and Button to the page (These HTML controls will be used to add WebTreeView via client side).
  3. Set the TextBox's ID to txtNewNode.
  4. Drag ASP.NET button to the page (This button will be used to perform the batch update).
  5. Drag XMLDataSource to the page and bind it to WebTreeView. In this sample, Sports_Updatable.xml is used as the XMLDataSource's DataFile.

  6. Go to WebTreeView's properties and set AllowAddNode to True, AllowNodeEditing to Yes and AllowDeleteNode to True.
  7. Implement onclick (Add New Node's button) client side event and add the following code:

    Javascript Copy Image Copy Code
    function btnAdd_Click()
{
   var treeView = ISGetObject("WebTreeView1");
   var node = treeView.GetSelectedNode();
   var txt = document.getElementById("txtNewNode").value;
   if(txt == "")
      alert("Please type a text");
   else
   {
      if(node != null)
         node.AddNode(txt, txt);
      else
         treeView.AddNode(txt, txt);
   }
}

  8. Implement OnNodeAdd, OnNodeEdit and OnNodeDelete server side event:

    C# Copy Image Copy Code
    XmlDocument xml;
protected void WebTreeView1_NodeAdd(object sender, ISNet.WebUI.WebTreeView.WebTreeViewNodeEventArgs e)
{
   if (e.Node.ParentNode != null)
   {
      XmlNode parentNode = (XmlNode)e.Node.ParentNode.DataItem;
      XmlNode node = parentNode.CloneNode(false);
      node.Attributes["name"].Value = e.Node.Text;
      parentNode.AppendChild(node);
      xml = parentNode.OwnerDocument;
   }
   else
   {
      XmlNode parentNode = (XmlNode)WebTreeView1.Nodes[0].DataItem;
      XmlNode node = parentNode.CloneNode(false);
      node.Attributes["name"].Value = e.Node.Text;
      parentNode.OwnerDocument.DocumentElement.AppendChild(node);
      xml = parentNode.OwnerDocument;
   }
}

protected void WebTreeView1_NodeEdit(object sender, ISNet.WebUI.WebTreeView.WebTreeViewNodeEditEventArgs e)
{
   XmlNode node = (XmlNode)e.Node.DataItem;
   node.Attributes["name"].Value = e.Node.Text;
   xml = node.OwnerDocument;
}

protected void WebTreeView1_NodeDelete(object sender, ISNet.WebUI.WebTreeView.WebTreeViewNodeEventArgs e)
{
   XmlNode node = (XmlNode)e.Node.DataItem;
   node.ParentNode.RemoveChild(node);
   xml = node.OwnerDocument;
}

  9. Implement Button_Click server side event to perform batch update.

    C# Copy Image Copy Code
    protected void Button1_Click(object sender, EventArgs e)
{
   xml.Save(Server.MapPath("App_Data/Sports_Updatable.xml"));
}

  10. Run the application. Add WebTreeViewNode via client side and press the server side button to apply the changes to Xml file.

See Also

Tasks
{How-to: Enable AutoPostBack on node's select action}
{Walkthrough Topics}
{FAQ and How-to Topics}

Concepts
{PostBack Settings}


Client-side Events

Client-side Events
See Also Send Feedback
Intersoft WebTreeView > Features and Concepts > Client-side Events

Glossary Item Box

WebTreeView.NET is a highly customizable ASP.NET Treeview control as one of its objective. The following list describes all client-side events in order:

  • OnInitialized
    When the WebTreeView is initialized, this event will be invoked. The parameter for this event is controlId.

  • OnNodeCheckedChanged
    This event will be invoked when you check or uncheck a node. The parameters for this event are controlId and node.

  • OnNodeCollapse
    This event will be invoked when a node is collapsed. The parameters for this event are controlId and node.

  • OnNodeCopy
    This event will be invoked when a node is copied. The parameters for this event are controlId and node.

  • OnNodeExpand
    This event will be invoked when a node is expanded. The parameters for this event are controlId and node.

  • OnNodeMove
    This event will be invoked when a node is moved. The parameters for this event are controlId and node.

  • OnNodeRename
    This event will be invoked when a node is renamed. The parameters for this event are controlId, node, oldName, and newName.

  • OnNodeSelect
    This event will be invoked when a node is selected. The parameters for this event are controlId and node.

  • OnUnload
    This event will be invoked when WebTreeView is unloaded. The parameters for this event are controlId.

See Also

Tasks
{Walkthrough Topics}
{FAQ and How-to Topics}

Other Resources
WebTreeView Overview
{Features and Concepts}


Server-side References

Server-side References
Send Feedback
Intersoft WebTreeView > Server-side References

Glossary Item Box

This section is designated to help user working with server-side references in WebTreeView.


ISNet.WebUI.WebTreeView Namespace

ISNet.WebUI.WebTreeView Namespace
See Also Inheritance Hierarchy Send Feedback

Glossary Item Box

Classes

 | Class | Description
Class | WebTreeView | WebTreeView.NET® 1.0 is Intersoft’s latest ASP.NET server control which enables you to easily create a hierarchical data presentation. WebTreeView.NET® 1.0 is Intersoft’s latest ASP.NET server control which enables you to easily create a hierarchical data presentation.
Class | WebTreeViewAutoPostBackSettings | A collection of WebTreeView's AutoPostBack settings.
Class | WebTreeViewClientSideEvents | A collection of WebTreeView's client-side event.
Class | WebTreeViewDragDropEventArgs |
Class | WebTreeViewDragDropSettings | A collection of WebTreeView drag and drop behavior settings.
Class | WebTreeViewImagesSettings | A collection of WebTreeView's image settings.
Class | WebTreeViewNode | Represents a unbound node which belongs to WebTreeView object. WebTreeViewNode contains many properties for you to customize a node.
Class | WebTreeViewNodeBinding | Represents a bound node which belongs to WebTreeView object. WebTreeViewNodeBinding provides you numerous properties which you can set to meet your need.
Class | WebTreeViewNodeBindingCollection | Summary description for WebTreeViewNodeBindingCollection. A collection of WebTreeViewNodeBinding.
Class | WebTreeViewNodeCollection | Summary description for WebTreeViewNodeCollection. A collection of WebTreeViewNode.
Class | WebTreeViewNodeEditEventArgs | Provides data for WebTreeView's node editing event.
Class | WebTreeViewNodeEventArgs | Provides data for WebTreeView's node related event.
Class | WebTreeViewNodeMoveEventArgs | Provides data for WebTreeView's node moving event.
Class | WebTreeViewNodeRenameEventArgs | Provides data for WebTreeView's node renaming event.
Class | WebTreeViewNodeSettings | A collection of WebTreeView's node properties.
Class | WebTreeViewNodeUpdatedEventArgs |

Delegates

 | Delegate | Description
Delegate | InitializeChildNodesEventHandler | Represents the method that handles InitializeChildNode event.
Delegate | InitializeNodeEventHandler | Represents the method that handles InitializeNode event.
Delegate | NodeAddEventHandler | Represents the method that handles NodeAdd event.
Delegate | NodeCheckChangedEventHandler | Represents the method that handles NodeCheckChanged event.
Delegate | NodeCollapseEventHandler | Represents the method that handles NodeCollapse event.
Delegate | NodeCopyEventHandler | Represents the method that handles NodeCopy event.
Delegate | NodeDeleteEventHandler | Represents the method that handles NodeDelete event.
Delegate | NodeEditEventHandler | Represents the method that handles NodeEdit event.
Delegate | NodeExpandEventHandler | Represents the method that handles NodeExpand event.
Delegate | NodeMoveEventHandler | Represents the method that handles NodeMove event.
Delegate | NodeRenameEventHandler | Represents the method that handles NodeRename event.
Delegate | NodeSelectChangedEventHandler | Represents the method that handles NodeSelectChanged event.
Delegate | NodeUpdatedEventHandler |

Enumerations

 | Enumeration | Description
Enumeration | AllowEditing | Enumerations for Allow Editing Specifies whether to allow node editting or not.
Enumeration | CheckBoxLocation | Values indicating the location of checkbox.
Enumeration | CheckBoxType | Values indicating which checkbox is used, normal two-state checkbox or TriState checkbox.
Enumeration | CheckState | Values representing checkbox's state.
Enumeration | NodeMoveInsertionMode |
Enumeration | NodeMoveType |
Enumeration | NodeType | Values representing the type of a node.
Enumeration | PostBackMode | Specifies which postback mode is set.
Enumeration | ShowCheckBox | Enumerations for Show CheckBox Values indicating on which node level a checkbox will be shown.

See Also

Reference

ISNet.WebUI.WebTreeView Assembly

© 2013 Intersoft Solutions Corp. All Rights Reserved.


WebTreeView Class

[image]
Intersoft WebTreeView Documentation
WebTreeView Class
Members See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace : WebTreeView Class

Glossary Item Box

WebTreeView.NET® 1.0 is Intersoft’s latest ASP.NET server control which enables you to easily create a hierarchical data presentation. WebTreeView.NET® 1.0 is Intersoft’s latest ASP.NET server control which enables you to easily create a hierarchical data presentation.

Object Model

WebTreeView Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.ParseChildrenAttribute(True)>
<System.Web.UI.PersistChildrenAttribute(Persist=False, UsesCustomPersistence=False)>
<System.ComponentModel.DescriptionAttribute("WebTreeView.NET® 1.0 is Intersoft’s latest ASP.NET server control which enables you to easily create a hierarchical data presentation. ")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(JSFileNames="WebAnimation.js;WebTreeView.js", Type=XmlSerializationType.ClientAndLayout)>
<System.Web.UI.ToolboxDataAttribute("<{0}:WebTreeView runat="server" Width="250px" Height="500px"></{0}:WebTreeView>")>
<System.ComponentModel.DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="Ӓ.ӓ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")>
<System.SerializableAttribute()>
<System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand Or  _
    SecurityAction.Deny Or  _
    SecurityAction.LinkDemand,
   Unrestricted=False)>
<System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand Or  _
    SecurityAction.Assert Or  _
    SecurityAction.Deny Or  _
    SecurityAction.PermitOnly Or  _
    SecurityAction.LinkDemand Or  _
    SecurityAction.InheritanceDemand,
   Unrestricted=False)>
Public Class WebTreeView
   Inherits ISNet.WebUI.ISNetControl
   Implements ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.ICustomXmlSerializer, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IDataSourceControlSupport, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings, ISNet.WebUI.ISDataSource, ISNet.WebUI.ITemplateSync
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
C#
[System.Web.UI.ParseChildrenAttribute(true)]
[System.Web.UI.PersistChildrenAttribute(Persist=false, UsesCustomPersistence=false)]
[System.ComponentModel.DescriptionAttribute("WebTreeView.NET® 1.0 is Intersoft’s latest ASP.NET server control which enables you to easily create a hierarchical data presentation. ")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(JSFileNames="WebAnimation.js;WebTreeView.js", Type=XmlSerializationType.ClientAndLayout)]
[System.Web.UI.ToolboxDataAttribute("<{0}:WebTreeView runat="server" Width="250px" Height="500px"></{0}:WebTreeView>")]
[System.ComponentModel.DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="Ӓ.ӓ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
[System.SerializableAttribute()]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public class WebTreeView : ISNet.WebUI.ISNetControl, ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.ICustomXmlSerializer, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IDataSourceControlSupport, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings, ISNet.WebUI.ISDataSource, ISNet.WebUI.ITemplateSync
Delphi
public class WebTreeView = class(ISNet.WebUI.ISNetControl, ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.ICustomXmlSerializer, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IDataSourceControlSupport, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings, ISNet.WebUI.ISDataSource, ISNet.WebUI.ITemplateSync)
JScript
System.Web.UI.ParseChildrenAttribute()
System.Web.UI.PersistChildrenAttribute(Persist=, UsesCustomPersistence=)
System.ComponentModel.DescriptionAttribute("WebTreeView.NET® 1.0 is Intersoft’s latest ASP.NET server control which enables you to easily create a hierarchical data presentation. ")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute(JSFileNames="WebAnimation.js;WebTreeView.js", Type=XmlSerializationType.ClientAndLayout)
System.Web.UI.ToolboxDataAttribute("<{0}:WebTreeView runat="server" Width="250px" Height="500px"></{0}:WebTreeView>")
System.ComponentModel.DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="Ӓ.ӓ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")
System.SerializableAttribute()
System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=)
System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=)
public class WebTreeView extends ISNet.WebUI.ISNetControl implements ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.ICustomXmlSerializer, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IDataSourceControlSupport, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings, ISNet.WebUI.ISDataSource, ISNet.WebUI.ITemplateSync
Managed Extensions for C++
[System.Web.UI.ParseChildrenAttribute(true)]
[System.Web.UI.PersistChildrenAttribute(Persist=false, UsesCustomPersistence=false)]
[System.ComponentModel.DescriptionAttribute("WebTreeView.NET® 1.0 is Intersoft’s latest ASP.NET server control which enables you to easily create a hierarchical data presentation. ")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(JSFileNames="WebAnimation.js;WebTreeView.js", Type=XmlSerializationType.ClientAndLayout)]
[System.Web.UI.ToolboxDataAttribute("<{0}:WebTreeView runat="server" Width="250px" Height="500px"></{0}:WebTreeView>")]
[System.ComponentModel.DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="Ӓ.ӓ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
[System.SerializableAttribute()]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public __gc class WebTreeView : public ISNet.WebUI.ISNetControl, ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.ICustomXmlSerializer, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IDataSourceControlSupport, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings, ISNet.WebUI.ISDataSource, ISNet.WebUI.ITemplateSync
C++/CLI
[System.Web.UI.ParseChildrenAttribute(true)]
[System.Web.UI.PersistChildrenAttribute(Persist=false, UsesCustomPersistence=false)]
[System.ComponentModel.DescriptionAttribute("WebTreeView.NET® 1.0 is Intersoft’s latest ASP.NET server control which enables you to easily create a hierarchical data presentation. ")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(JSFileNames="WebAnimation.js;WebTreeView.js", Type=XmlSerializationType.ClientAndLayout)]
[System.Web.UI.ToolboxDataAttribute("<{0}:WebTreeView runat="server" Width="250px" Height="500px"></{0}:WebTreeView>")]
[System.ComponentModel.DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="Ӓ.ӓ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
[System.SerializableAttribute()]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public ref class WebTreeView : public ISNet.WebUI.ISNetControl, ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.ICustomXmlSerializer, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IDataSourceControlSupport, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings, ISNet.WebUI.ISDataSource, ISNet.WebUI.ITemplateSync

Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
ISNet.WebUI.ISNetControl
ISNet.WebUI.WebTreeView.WebTreeView

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Members
ISNet.WebUI.WebTreeView Namespace

Concepts

Overview


WebTreeView Class Members

[image]
Intersoft WebTreeView Documentation
WebTreeView Class Members
See Also Fields Properties Methods Events Send Feedback
ISNet.WebUI.WebTreeView Namespace : WebTreeView Class

Glossary Item Box

The following tables list the members exposed by WebTreeView.

Public Constructors

 | Name | Description
Public Constructor | WebTreeView Constructor | Overloaded. Initializes a new instance of WebTreeView class with no parameter.
Top

Protected Fields

 | Name | Description
Protected Field | isPagePreRender | (Inherited from ISNet.WebUI.ISNetControl)
Protected Field | renderDHTML | (Inherited from ISNet.WebUI.ISNetControl)
Protected Field | renderNS | (Inherited from ISNet.WebUI.ISNetControl)
Protected Field | viewStateLoaded | (Inherited from ISNet.WebUI.ISNetControl)
Top

Public Properties

 | Name | Description
Public Property | AccessKey | Keyboard shortcut used by the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | AllowAddNode | Indicates whether to allow node adding or not.
Public Property | AllowCollapseNodeOnSelect | Indicates whether to collapse a parent node when it is selected.Indicates whether to collapse a parent node when it is selected.
Public Property | AllowDeleteNode | Indicates whether to allow node deleting or not.
Public Property | AllowDragDrop | Specifies whether to allow drag and drop of the tree nodes.Specifies whether to allow drag and drop of the tree nodes.
Public Property | AllowDropFromOtherControls | Indicates whether to allow drop from other Intersoft controls.Indicates whether to allow dropping from other Intersoft's controls.
Public Property | AllowExpandNodeOnSelect | Indicates whether to expand a parent node when it is selected.Indicates whether to expand a parent node when it is selected.
Public Property | AllowExpandSinglePath | Indicates whether to collapse all other paths when expanding a node, ensuring that only one path is expanded.Indicates whether to collapse the other paths when expanding a node, ensuring that only one path is expanded.
Public Property | AllowKeyboardNavigation | Indicates whether to allow keyboard navigation.Indicates whether to allow keyboard navigation or not.
Public Property | AllowMultipleSelect | Specifies whether to allow multiple select on the tree nodes.Specifies whether to allow multiple select on TreeView nodes.
Public Property | AllowNodeEditing | Indicates whether to allow node editing.Indicates whether to allow node editing.
Public Property | AppRelativeTemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | AspNetAjaxSettings | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Attributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | AutoCheckChildNodes | Indicates whether to automatically check child nodes.
Public Property | AutoGenerateDataBindings | Gets or sets the auto generate data bindings.Specifies whether WebTreeView retrieves data from a datasource and bind it automatically.
Public Property | AutoPostBackSettings | Contains auto postback settings such as OnNodeMove, OnNodeExpand, OnNodeCollapse, etc.Contains auto postback settings such as OnNodeMove, OnNodeExpand, OnNodeCollapse, etc.
Public Property | AutoSelectOnNodeExpandCollapse | Indicates whether to automatically select node when a node is expanded/collapsed.
Public Property | BackColor | Color of the background of the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | BorderColor | Color of the border around the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | BorderStyle | Style of the border around the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | BorderWidth | Width of the border around the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | CheckBoxType | Gets or sets the type of node checkbox, whether to use image or standard checkbox.Gets or sets the type of node's checkbox, whether to use image or standard checkbox.
Public Property | CheckedNodes | The collection of checkable nodes which are currently checked.Determines the collection of checked nodes.
Public Property | ClientAction | Returns ClientSideAction class Returns ClientSideAction class.
Public Property | ClientID | (Inherited from System.Web.UI.Control)
Public Property | ClientIDMode | (Inherited from System.Web.UI.Control)
Public Property | ClientSideEvents | Contains Javascript ClientSide events.Contains WebTreeView's JavaScript client-side event.
Public Property | ControlDataTransferFormat | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Controls | (Inherited from System.Web.UI.Control)
Public Property | ControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ControlStyleCreated | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | CssClass | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | DataBindings | A collection of properties available for data bound node.
Public Property | DataMember | Gets or sets the datamember of the treeview.Gets or sets the data member.
Public Property | DataSource | Gets or sets the datasource of the treeview.Specifies the type of WebTreeView's datasource.
Public Property | DataSourceID | Gets or sets the ID of the control from which the treeview control retrieves its list.Gets or sets the ID of the control which TreeView control retrieves its list.
Public Property | DefaultImageHeight | Gets or sets the default height(in pixels) to use for icon images.Gets or sets the default image height (in pixel) which will be used as an icon images.
Public Property | DefaultImageWidth | Gets or sets the default width(in pixels) to use for icon images.Gets or sets the default image width (in pixel) which will be used as an icon images.
Public Property | DefaultPathSeparator | Gets or sets the default path separator symbol.
Public Property | DragDropSettings | Contains drag and drop settings such as AllowRootDrop, AllowChildDrop, and AllowSiblingDrop.Contains drag and drop settings such as AllowRootDrop, AllowChildDrop, and AllowSiblingDrop.
Public Property | Enabled | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableLoadOnDemand | Indicates whether to enable load on demand.Indicates whether to allow LoadOnDemand or not.
Public Property | EnableManagedTheming | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableTriStateCheckBox | Specifies whether to enable tristate checkbox.Specifies whether to allow TriState checkbox or not.
Public Property | EnableTriStateCheckBoxParentInIndeterminateState |
Public Property | EnableViewState | Specifies whether the control automatically saves its state for use in round-trips. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableWebResources | Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ExpandCollapseImageHeight | Gets or sets the default height(in pixels) to use for expand/collapse images.Gets or sets the default image height (in pixel) which will be used as an expand/collapse image.
Public Property | ExpandCollapseImageWidth | Gets or sets the default width(in pixels) to use for expand/collapse images.Gets or sets the default image width (in pixel) which will be used as an expand/collapse image.
Public Property | ExpandedDepth | Gets or sets the expanded depth.Determines whether all specified nodes (based on their depth) are expanded (initially and on postback) or not
Public Property | FlyPostBackSettings | Configures the settings used by the control when performing OnTheFly postback. Configures the settings used by the control when performing OnTheFly postback.
Public Property | Font | Overridden. Gets or sets the font of node's text.
Public Property | ForeColor | Color of the text within the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | FrameStyle | The style applied to frame of the control.Style applied to the frame of the control.
Public Property | HasAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Height | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | ImagesDirectory | Gets or sets the location of images used to render the control.Gets or sets the location of the images used for rendering the control.
Public Property | ImagesSettings | Contains images settings for WebTreeView.Contains image settings for WebTreeView.
Public Property | IsControlThemed | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | IsDataBindingPerformed |
Public Property | IsDesign | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | IsDynamicCreated | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | IsFlyPostBack | Returns whether this instance invokes OnTheFly postback. Returns whether the specified WebTreeView instance invokes OnTheFly postback.
Public Property | IsInternalCreated | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | IsUnloaded | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | LineImageHeight | Gets or sets the height(in pixels) to apply on line images.Gets or sets the height (in pixel) of the line images.
Public Property | LineImageWidth | Gets or sets the width(in pixels) to apply on line images.Gets or sets the width (in pixel) of the line images.
Public Property | LoadingStyle | Gets or sets the style of the loading.Gets or sets the style used when loading LoadOnDemand content.
Public Property | LoadingText | Gets or sets the text to use while loading load-on-demand content.Gets or sets the text used when loading LoadOnDemand content.
Public Property | MaxDataBindDepth | Gets or sets the depth to which the TreeView will databind.Gets or sets the depth to which TreeView will be bound.
Public Property | NamingContainer | (Inherited from System.Web.UI.Control)
Public Property | NodeIndent | Gets or sets the width(in pixels) to indent each level of the node.Gets or sets the width (in pixel) of indentation on each level of the node.
Public Property | Nodes | The collection of nodes for WebTreeView.Specifies a collection of WebTreeView's nodes.
Public Property | NodeSettings | Contains node settings such as TargetWindow, and EnableAnimation.Contains node settings such as TargetWindow and EnableAnimation.
Public Property | NodeStyle | Gets or sets the style of the node.Gets or sets the style of a node.
Public Property | Page | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Parent | (Inherited from System.Web.UI.Control)
Public Property | ParentStyleId | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | PathSeparator | Specifies the character used to separate parts of the path.Specifies the character used to separate parts of the path.
Public Property | PersistInfoDuringLoadOnDemand | Indicates whether to persist nodes info during load on demand.
Public Property | PostBackModeType | Gets or sets the type of postback mode, whether to use flypostback or fullpostback.Gets or sets the type of postback mode, whether to use flypostback or fullpostback.
Public Property | RenderingCompatibility | (Inherited from System.Web.UI.Control)
Public Property | RenderingMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RequiresUIRefresh | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RuntimeLicenseKey | The runtime license key that is used for xcopy development. For Registered customers, please obtain the key through Intersoft Developer Network. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | SaveViewStateOnFlyPostback | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ScriptDirectory | Overridden. Gets or sets the location of the required scripts used by WebTreeView.
Public Property | SelectedNode | Specifies a selected node.
Public Property | SelectedNodes | The collection of selected nodes.Specifies a collection of the selected nodes.
Public Property | SerializedJSFiles | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | SerializedStyles | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | SharedScriptDirectory | Overridden.
Public Property | ShowCheckBoxes | Gets or sets the node type next to which checkboxes should be shown.Gets or sets which node level will have checkbox shown on it.
Public Property | ShowExpandCollapse | Specifies whether to show the expand/collapse icon next to the tree nodes.Specifies whether to show the expand/collapse icon next to the nodes.
Public Property | ShowLines | Specifies whether to show lines connecting the tree nodes.Specifies whether to show lines connecting the tree nodes.
Public Property | Site | (Inherited from System.Web.UI.Control)
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Style | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | SupportsDisabledAttribute | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | SupportXMLCultureInfo | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | TabIndex | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | TemplateControl | (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | ToolTip | The tooltip displayed when the mouse is over the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | UniqueID | (Inherited from System.Web.UI.Control)
Public Property | ValidateRequestMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateItems | Gets or sets the item to be stored in view state storage. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateServerConnection | Gets or sets the server connection string for file server-based viewstate storage. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateStorage | Gets or sets the location to store the viewstate of this control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Visible | Indicates whether the control is visible and rendered. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Width | The width of the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | XmlCompressionEnabled | Specifies whether the Xml used for clientside state storage should be compressed. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | XPath | Specifies an intial XPath that is applied to the XML data.Specifies an initial XPath that is applied to the XML data.
Top

Protected Properties

 | Name | Description
Protected Property | Adapter | (Inherited from System.Web.UI.Control)
Protected Property | ChildControlsCreated | (Inherited from System.Web.UI.Control)
Protected Property | ClientIDSeparator | (Inherited from System.Web.UI.Control)
Protected Property | DefaultImagesFolder | Overridden.
Protected Property | Events | (Inherited from System.Web.UI.Control)
Protected Property | HasChildViewState | (Inherited from System.Web.UI.Control)
Protected Property | IdSeparator | (Inherited from System.Web.UI.Control)
Protected Property | IsMvc | (Inherited from ISNet.WebUI.ISNetControl)
Protected Property | IsTrackingViewState | (Inherited from System.Web.UI.Control)
Protected Property | LicenseType | Overridden.
Protected Property | LoadViewStateByID | (Inherited from System.Web.UI.Control)
Protected Property | MaxJsonLength | (Inherited from ISNet.WebUI.ISNetControl)
Protected Property | Product | Overridden.
Protected Property | ProductIcon | Overridden.
Protected Property | ProductImage | Overridden.
Protected Property | SupportDataSourceControl | Overridden.
Protected Property | TagKey | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Property | TagName | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Property | ViewState | (Inherited from System.Web.UI.Control)
Protected Property | ViewStateIgnoresCase | (Inherited from System.Web.UI.Control)
Top

Public Methods

 | Name | Description
Public Method | AddNode | Overloaded. Adds a new node to a WebTreeView instance with no parameter.
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CanUseWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CheckAll | Method used for checking all nodes level.
Public Method | Clone | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CollapseAll | Method used for collapsing all parent nodes.
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
static (Shared in Visual Basic) | CreateNode | Method used for creating a new XML node.
Public Method | DataBind | Overloaded. Overridden. Binds the control to a data source specified by the DataSource property.
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | ExpandAll | Method used for expanding all parent nodes.
Public Method | FindControl | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | FindNodeByPath | Find a node based on the path parameter given.
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | ForceDisableXmlCompression | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetClientAction | Gets the client function directly from server code during OnTheFly postback.
Public Method | GetCurrentControlLifeCycle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkDataFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkVersion | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetIntersoftFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetLayoutFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetPostedXMLData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductInfoKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductSimpleName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetPropertyValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetResourceStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetRouteUrl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | GetUniqueIDRelativeTo | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | IsAtlasCallback | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsBetaRelease | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsChromeBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackRequest | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoBasedBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoVersion18 | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInDesignMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorer8Browser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorerBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsOperaBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsSafariBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsW3CStandardBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromPredefinedName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadNodesFromXml | Overloaded. Loads WebTreeView's node structure from an XML file based on the XML value.
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | OnInfoChanged | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | OnPreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RaiseDragDropEvent |
Public Method | RaiseInitializeChildNodesEvent | Method used for triggering InitializeChildNodes event.
Public Method | RaiseInitializeNodeEvent | Method used for triggering InitializeNode event.
Public Method | RaiseNodeAddEvent | Method used for triggering NodeAdd event.
Public Method | RaiseNodeCheckChangedEvent | Method used for triggering NodeCheckChanged event.
Public Method | RaiseNodeCollapseEvent | Method used for triggering NodeCollapse event.
Public Method | RaiseNodeDeleteEvent | Method used for triggering NodeDelete event.
Public Method | RaiseNodeEditEvent | Method used for triggering NodeEdit event.
Public Method | RaiseNodeExpandEvent | Method used for triggering NodeExpand event.
Public Method | RaiseNodeMoveEvent | Method used for triggering NodeMove event.
Public Method | RaiseNodeRenameEvent | Method used for triggering NodeRename event.
Public Method | RaiseNodeSelectChangedEvent | Method used for triggering NodeSelectedChanged event.
Public Method | RaiseNodeUpdatedEvent |
Public Method | RaisePostDataChangedEvent | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ReadWebConfigValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterBoxSizing | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterGlobalStyle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterLink | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterOptimizedCssClasses | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterPreloadImage | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterScript | Overridden.
Public Method | RegisterSharePointHandler | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderBeginTag | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderControl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | Overridden.
Public Method | Reset | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveImagePath | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveRelativeURL | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveResourceUrl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SaveLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveNodesToXml | Overloaded. Saves WebTreeView's structure to an XML file with String parameter as the filename of XML.
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Public Method | SetSessionTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ShouldReturnJson | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | UnCheckAll | Method used for unchecking all node level.
Top

Protected Methods

 | Name | Description
Protected Method | AddAttributesToRender | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | AddParsedSubObject | (Inherited from System.Web.UI.Control)
Protected Method | ApplyControlTheme | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | AssignXmlInputHiddenUniqueID | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | BuildProfileTree | (Inherited from System.Web.UI.Control)
Protected Method | ClearCachedClientID | (Inherited from System.Web.UI.Control)
Protected Method | ClearChildControlState | (Inherited from System.Web.UI.Control)
Protected Method | ClearChildState | (Inherited from System.Web.UI.Control)
Protected Method | ClearChildViewState | (Inherited from System.Web.UI.Control)
Protected Method | ClearEffectiveClientIDMode | (Inherited from System.Web.UI.Control)
Protected Method | ControlRequestHandler | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | CreateChildControls | Overridden.
Protected Method | CreateControlCollection | (Inherited from System.Web.UI.Control)
Protected Method | CreateControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | CreateThemeInfo | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | DataBindChildren | (Inherited from System.Web.UI.Control)
Protected Method | DecodeRequest | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | EnsureChildControls | (Inherited from System.Web.UI.Control)
Protected Method | EnsureID | (Inherited from System.Web.UI.Control)
Protected Method | GetApplicationState | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | GetCachedAppTheme | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | GetDesignModeState | (Inherited from System.Web.UI.Control)
Protected Method | GetDHTMLRenderer | Overridden.
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | GetSessionLevelTheme | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | HasEvents | (Inherited from System.Web.UI.Control)
Protected Method | InitializeDefaultStyles | Overridden.
Protected Method | InitializeLayoutBehaviors | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | InitializeManagedTheming | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | IsApplicationAvailable | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | IsAppThemeEnabled | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | IsLiteralContent | (Inherited from System.Web.UI.Control)
Protected Method | IsSessionAvailable | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | LoadControlState | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | LoadViewState | Overridden.
Protected Method | OnBubbleEvent | (Inherited from System.Web.UI.Control)
Protected Method | OnDataBinding | (Inherited from System.Web.UI.Control)
Protected Method | OnInit | Overridden.
Protected Method | OnLoad | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | OnPreRender | Overridden.
Protected Method | RaiseBubbleEvent | (Inherited from System.Web.UI.Control)
Protected Method | RenderContents | Overridden.
Protected Method | ResetFilteredStyle | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | ResolveAdapter | (Inherited from System.Web.UI.Control)
Protected Method | SaveControlState | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | SaveViewState | Overridden.
Protected Method | SetDesignModeState | (Inherited from System.Web.UI.Control)
Protected Method | SetTheme | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | ShowAboutBox | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | TrackViewState | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | UseDeepCloneForViewStateStorage | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | UseMemoryStreamStateType | (Inherited from ISNet.WebUI.ISNetControl)
Top

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | DragDrop |
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | InitializeChildNodes | Fires when child nodes need to be initialized during databinding.
Public Event | InitializeNode | Fires when node is initialized and about to be rendered.
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | NodeAdd | Fires after a treeview node is added. Fires when node is added successfully.
Public Event | NodeCheckChanged | Fires after a treeview node is checked or unchecked. Fires after a TreeView node is checked or unchecked.
Public Event | NodeCollapse | Fires after a treeview node is collapsed. Fires after a TreeView node is collapsed.
Public Event | NodeDelete | Fires after a treeview node is edited. Fires when node is deleted successfully.
Public Event | NodeEdit | Fires after a treeview node is edited. Fires when node is edited successfully.
Public Event | NodeExpand | Fires after a treeview node is expanded. Fires after a TreeView node is expanded.
Public Event | NodeMove | Fires after a treeview node is moved. Fires after a TreeView node is moved.
Public Event | NodeRename | Fires after a treeview node is renamed. Fires after a TreeView node is renamed.
Public Event | NodeSelectChanged | Fires after the selected treeview nodes are changed. Fires after the selected TreeView node has changed.
Public Event | NodeUpdated |
Public Event | PreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

WebTreeView Class
ISNet.WebUI.WebTreeView Namespace

Concepts

Overview


WebTreeView Constructor

[image]
Intersoft WebTreeView Documentation
WebTreeView Constructor
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : WebTreeView Constructor

Glossary Item Box

Initializes a new instance of WebTreeView class with no parameter.

Overload List

Overload | Description
WebTreeView Constructor() |
WebTreeView Constructor(SerializationInfo,StreamingContext) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


WebTreeView Constructor()

[image]
Intersoft WebTreeView Documentation
WebTreeView Constructor()
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class > WebTreeView Constructor : WebTreeView Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebTreeView class with no parameter. ")>
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebTreeView()
C#
[System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebTreeView class with no parameter. ")]
public WebTreeView()
Delphi
public WebTreeView();
JScript
System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebTreeView class with no parameter. ")
public function WebTreeView();
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebTreeView class with no parameter. ")]
public: WebTreeView();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebTreeView class with no parameter. ")]
public:
WebTreeView();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members
Overload List


WebTreeView Constructor(SerializationInfo,StreamingContext)

[image]
Intersoft WebTreeView Documentation
WebTreeView Constructor(SerializationInfo,StreamingContext)
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class > WebTreeView Constructor : WebTreeView Constructor(SerializationInfo,StreamingContext)

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

Dim instance As New WebTreeView(info, context)
C#
protected WebTreeView(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
protected WebTreeView(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
protected function WebTreeView(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
protected: WebTreeView(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
protected:
WebTreeView(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members
Overload List


WebTreeView Class Methods

[image]
Intersoft WebTreeView Documentation
WebTreeView Class Methods
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace : WebTreeView Class

Glossary Item Box

For a list of all members of this type, see WebTreeView members.

Public Methods

 | Name | Description
Public Method | AddNode | Overloaded. Adds a new node to a WebTreeView instance with no parameter.
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CanUseWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CheckAll | Method used for checking all nodes level.
Public Method | Clone | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CollapseAll | Method used for collapsing all parent nodes.
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
static (Shared in Visual Basic) | CreateNode | Method used for creating a new XML node.
Public Method | DataBind | Overloaded. Overridden. Binds the control to a data source specified by the DataSource property.
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | ExpandAll | Method used for expanding all parent nodes.
Public Method | FindControl | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | FindNodeByPath | Find a node based on the path parameter given.
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | ForceDisableXmlCompression | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetClientAction | Gets the client function directly from server code during OnTheFly postback.
Public Method | GetCurrentControlLifeCycle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkDataFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkVersion | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetIntersoftFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetLayoutFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetPostedXMLData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductInfoKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductSimpleName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetPropertyValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetResourceStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetRouteUrl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | GetUniqueIDRelativeTo | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | IsAtlasCallback | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsBetaRelease | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsChromeBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackRequest | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoBasedBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoVersion18 | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInDesignMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorer8Browser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorerBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsOperaBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsSafariBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsW3CStandardBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromPredefinedName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadNodesFromXml | Overloaded. Loads WebTreeView's node structure from an XML file based on the XML value.
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | OnInfoChanged | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | OnPreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RaiseDragDropEvent |
Public Method | RaiseInitializeChildNodesEvent | Method used for triggering InitializeChildNodes event.
Public Method | RaiseInitializeNodeEvent | Method used for triggering InitializeNode event.
Public Method | RaiseNodeAddEvent | Method used for triggering NodeAdd event.
Public Method | RaiseNodeCheckChangedEvent | Method used for triggering NodeCheckChanged event.
Public Method | RaiseNodeCollapseEvent | Method used for triggering NodeCollapse event.
Public Method | RaiseNodeDeleteEvent | Method used for triggering NodeDelete event.
Public Method | RaiseNodeEditEvent | Method used for triggering NodeEdit event.
Public Method | RaiseNodeExpandEvent | Method used for triggering NodeExpand event.
Public Method | RaiseNodeMoveEvent | Method used for triggering NodeMove event.
Public Method | RaiseNodeRenameEvent | Method used for triggering NodeRename event.
Public Method | RaiseNodeSelectChangedEvent | Method used for triggering NodeSelectedChanged event.
Public Method | RaiseNodeUpdatedEvent |
Public Method | RaisePostDataChangedEvent | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ReadWebConfigValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterBoxSizing | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterGlobalStyle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterLink | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterOptimizedCssClasses | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterPreloadImage | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterScript | Overridden.
Public Method | RegisterSharePointHandler | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderBeginTag | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderControl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | Overridden.
Public Method | Reset | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveImagePath | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveRelativeURL | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveResourceUrl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SaveLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveNodesToXml | Overloaded. Saves WebTreeView's structure to an XML file with String parameter as the filename of XML.
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Public Method | SetSessionTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ShouldReturnJson | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | UnCheckAll | Method used for unchecking all node level.
Top

Protected Methods

 | Name | Description
Protected Method | AddAttributesToRender | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | AddParsedSubObject | (Inherited from System.Web.UI.Control)
Protected Method | ApplyControlTheme | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | AssignXmlInputHiddenUniqueID | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | BuildProfileTree | (Inherited from System.Web.UI.Control)
Protected Method | ClearCachedClientID | (Inherited from System.Web.UI.Control)
Protected Method | ClearChildControlState | (Inherited from System.Web.UI.Control)
Protected Method | ClearChildState | (Inherited from System.Web.UI.Control)
Protected Method | ClearChildViewState | (Inherited from System.Web.UI.Control)
Protected Method | ClearEffectiveClientIDMode | (Inherited from System.Web.UI.Control)
Protected Method | ControlRequestHandler | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | CreateChildControls | Overridden.
Protected Method | CreateControlCollection | (Inherited from System.Web.UI.Control)
Protected Method | CreateControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | CreateThemeInfo | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | DataBindChildren | (Inherited from System.Web.UI.Control)
Protected Method | DecodeRequest | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | EnsureChildControls | (Inherited from System.Web.UI.Control)
Protected Method | EnsureID | (Inherited from System.Web.UI.Control)
Protected Method | GetApplicationState | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | GetCachedAppTheme | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | GetDesignModeState | (Inherited from System.Web.UI.Control)
Protected Method | GetDHTMLRenderer | Overridden.
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | GetSessionLevelTheme | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | HasEvents | (Inherited from System.Web.UI.Control)
Protected Method | InitializeDefaultStyles | Overridden.
Protected Method | InitializeLayoutBehaviors | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | InitializeManagedTheming | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | IsApplicationAvailable | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | IsAppThemeEnabled | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | IsLiteralContent | (Inherited from System.Web.UI.Control)
Protected Method | IsSessionAvailable | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | LoadControlState | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | LoadViewState | Overridden.
Protected Method | OnBubbleEvent | (Inherited from System.Web.UI.Control)
Protected Method | OnDataBinding | (Inherited from System.Web.UI.Control)
Protected Method | OnInit | Overridden.
Protected Method | OnLoad | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | OnPreRender | Overridden.
Protected Method | RaiseBubbleEvent | (Inherited from System.Web.UI.Control)
Protected Method | RenderContents | Overridden.
Protected Method | ResetFilteredStyle | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | ResolveAdapter | (Inherited from System.Web.UI.Control)
Protected Method | SaveControlState | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | SaveViewState | Overridden.
Protected Method | SetDesignModeState | (Inherited from System.Web.UI.Control)
Protected Method | SetTheme | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | ShowAboutBox | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | TrackViewState | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | UseDeepCloneForViewStateStorage | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | UseMemoryStreamStateType | (Inherited from ISNet.WebUI.ISNetControl)
Top

See Also

Reference

WebTreeView Class
ISNet.WebUI.WebTreeView Namespace

Concepts

Overview


AddNode Method

[image]
Intersoft WebTreeView Documentation
AddNode Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : AddNode Method

Glossary Item Box

Adds a new node to a WebTreeView instance with no parameter. Adds a new node to a WebTreeView instance.

Overload List

Overload | Description
AddNode() | Adds a new node to a WebTreeView instance with no parameter.
AddNode(String) | Adds a new node to a WebTreeView instance (the new node will be a root node) with String parameter as its name.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


AddNode() Method

[image]
Intersoft WebTreeView Documentation
AddNode() Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class > AddNode Method : AddNode() Method

Glossary Item Box

Adds a new node to a WebTreeView instance with no parameter.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Adds a new node to a WebTreeView instance. ")>
Public Overloads Function AddNode() As WebTreeViewNode
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As WebTreeViewNode

value = instance.AddNode()
C#
[System.ComponentModel.DescriptionAttribute("Adds a new node to a WebTreeView instance. ")]
public WebTreeViewNode AddNode()
Delphi
public function AddNode(): WebTreeViewNode;
JScript
System.ComponentModel.DescriptionAttribute("Adds a new node to a WebTreeView instance. ")
public function AddNode() : WebTreeViewNode;
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Adds a new node to a WebTreeView instance. ")]
public: WebTreeViewNode* AddNode();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Adds a new node to a WebTreeView instance. ")]
public:
WebTreeViewNode^ AddNode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members
Overload List


AddNode(String) Method

[image]
Intersoft WebTreeView Documentation
AddNode(String) Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class > AddNode Method : AddNode(String) Method

name
Name of the new WebTreeView instance.

Glossary Item Box

Adds a new node to a WebTreeView instance (the new node will be a root node) with String parameter as its name.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Adds a new node to a WebTreeView instance (the new node will be a root node) with String parameter as its name. ")>
Public Overloads Function AddNode( _
   ByVal name As System.String _
) As WebTreeViewNode
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim name As System.String
Dim value As WebTreeViewNode

value = instance.AddNode(name)
C#
[System.ComponentModel.DescriptionAttribute("Adds a new node to a WebTreeView instance (the new node will be a root node) with String parameter as its name. ")]
public WebTreeViewNode AddNode(
   System.string name
)
Delphi
public function AddNode(
    name: System.String
): WebTreeViewNode;
JScript
System.ComponentModel.DescriptionAttribute("Adds a new node to a WebTreeView instance (the new node will be a root node) with String parameter as its name. ")
public function AddNode(
   name : System.String
) : WebTreeViewNode;
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Adds a new node to a WebTreeView instance (the new node will be a root node) with String parameter as its name. ")]
public: WebTreeViewNode* AddNode(
   System.string* name
)
C++/CLI
[System.ComponentModel.DescriptionAttribute("Adds a new node to a WebTreeView instance (the new node will be a root node) with String parameter as its name. ")]
public:
WebTreeViewNode^ AddNode(
   System.String^ name
)

Parameters

name
Name of the new WebTreeView instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members
Overload List


CheckAll Method

[image]
Intersoft WebTreeView Documentation
CheckAll Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : CheckAll Method

Glossary Item Box

Method used for checking all nodes level.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Method use for checking all nodes level. ")>
Public Sub CheckAll()
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView

instance.CheckAll()
C#
[System.ComponentModel.DescriptionAttribute("Method use for checking all nodes level. ")]
public void CheckAll()
Delphi
public procedure CheckAll();
JScript
System.ComponentModel.DescriptionAttribute("Method use for checking all nodes level. ")
public function CheckAll();
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Method use for checking all nodes level. ")]
public: void CheckAll();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Method use for checking all nodes level. ")]
public:
void CheckAll();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


CollapseAll Method

[image]
Intersoft WebTreeView Documentation
CollapseAll Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : CollapseAll Method

Glossary Item Box

Method used for collapsing all parent nodes.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Method use for collapsing all parent nodes. ")>
Public Sub CollapseAll()
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView

instance.CollapseAll()
C#
[System.ComponentModel.DescriptionAttribute("Method use for collapsing all parent nodes. ")]
public void CollapseAll()
Delphi
public procedure CollapseAll();
JScript
System.ComponentModel.DescriptionAttribute("Method use for collapsing all parent nodes. ")
public function CollapseAll();
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Method use for collapsing all parent nodes. ")]
public: void CollapseAll();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Method use for collapsing all parent nodes. ")]
public:
void CollapseAll();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


CreateChildControls Method

[image]
Intersoft WebTreeView Documentation
CreateChildControls Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : CreateChildControls Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overrides Sub CreateChildControls()
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView

instance.CreateChildControls()
C#
protected override void CreateChildControls()
Delphi
protected procedure CreateChildControls(); override;
JScript
protected override function CreateChildControls();
Managed Extensions for C++
protected: void CreateChildControls(); override
C++/CLI
protected:
void CreateChildControls(); override

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


CreateNode Method

[image]
Intersoft WebTreeView Documentation
CreateNode Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : CreateNode Method

x
The specified XML node.
tagName
The tagnew of the specified XML node.
sValue
The content of the specified XML node.

Glossary Item Box

Method used for creating a new XML node.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Create a new node. ")>
Public Shared Function CreateNode( _
   ByVal x As System.Xml.XmlDocument, _
   ByVal tagName As System.String, _
   ByVal sValue As System.String _
) As System.Xml.XmlNode
Visual Basic (Usage) Copy Code
Dim x As System.Xml.XmlDocument
Dim tagName As System.String
Dim sValue As System.String
Dim value As System.Xml.XmlNode

value = WebTreeView.CreateNode(x, tagName, sValue)
C#
[System.ComponentModel.DescriptionAttribute("Create a new node. ")]
public static System.Xml.XmlNode CreateNode(
   System.Xml.XmlDocument x,
   System.string tagName,
   System.string sValue
)
Delphi
public function CreateNode(
    x: System.Xml.XmlDocument;
    tagName: System.String;
    sValue: System.String
): System.Xml.XmlNode; static;
JScript
System.ComponentModel.DescriptionAttribute("Create a new node. ")
public static function CreateNode(
   x : System.Xml.XmlDocument,
   tagName : System.String,
   sValue : System.String
) : System.Xml.XmlNode;
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Create a new node. ")]
public: static System.Xml.XmlNode* CreateNode(
   System.Xml.XmlDocument* x,
   System.string* tagName,
   System.string* sValue
)
C++/CLI
[System.ComponentModel.DescriptionAttribute("Create a new node. ")]
public:
static System.Xml.XmlNode^ CreateNode(
   System.Xml.XmlDocument^ x,
   System.String^ tagName,
   System.String^ sValue
)

Parameters

x
The specified XML node.
tagName
The tagnew of the specified XML node.
sValue
The content of the specified XML node.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


DataBind Method

[image]
Intersoft WebTreeView Documentation
DataBind Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : DataBind Method

Glossary Item Box

Binds the control to a data source specified by the DataSource property. Binds the control to a data source specified by the DataSource property.

Overload List

Overload | Description
DataBind() |
DataBind(Boolean) | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


DataBind() Method

[image]
Intersoft WebTreeView Documentation
DataBind() Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class > DataBind Method : DataBind() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Sub DataBind()
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView

instance.DataBind()
C#
public override void DataBind()
Delphi
public procedure DataBind(); override;
JScript
public override function DataBind();
Managed Extensions for C++
public: void DataBind(); override
C++/CLI
public:
void DataBind(); override

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members
Overload List


ExpandAll Method

[image]
Intersoft WebTreeView Documentation
ExpandAll Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : ExpandAll Method

Glossary Item Box

Method used for expanding all parent nodes.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Method use for expanding all parent nodes.")>
Public Sub ExpandAll()
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView

instance.ExpandAll()
C#
[System.ComponentModel.DescriptionAttribute("Method use for expanding all parent nodes.")]
public void ExpandAll()
Delphi
public procedure ExpandAll();
JScript
System.ComponentModel.DescriptionAttribute("Method use for expanding all parent nodes.")
public function ExpandAll();
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Method use for expanding all parent nodes.")]
public: void ExpandAll();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Method use for expanding all parent nodes.")]
public:
void ExpandAll();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


FindNodeByPath Method

[image]
Intersoft WebTreeView Documentation
FindNodeByPath Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : FindNodeByPath Method

path
The path parameter.

Glossary Item Box

Find a node based on the path parameter given.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Find a node based on the path parameter given. ")>
Public Function FindNodeByPath( _
   ByVal path As System.String _
) As WebTreeViewNode
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim path As System.String
Dim value As WebTreeViewNode

value = instance.FindNodeByPath(path)
C#
[System.ComponentModel.DescriptionAttribute("Find a node based on the path parameter given. ")]
public WebTreeViewNode FindNodeByPath(
   System.string path
)
Delphi
public function FindNodeByPath(
    path: System.String
): WebTreeViewNode;
JScript
System.ComponentModel.DescriptionAttribute("Find a node based on the path parameter given. ")
public function FindNodeByPath(
   path : System.String
) : WebTreeViewNode;
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Find a node based on the path parameter given. ")]
public: WebTreeViewNode* FindNodeByPath(
   System.string* path
)
C++/CLI
[System.ComponentModel.DescriptionAttribute("Find a node based on the path parameter given. ")]
public:
WebTreeViewNode^ FindNodeByPath(
   System.String^ path
)

Parameters

path
The path parameter.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


GetClientAction Method

[image]
Intersoft WebTreeView Documentation
GetClientAction Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : GetClientAction Method

Glossary Item Box

Gets the client function directly from server code during OnTheFly postback.

Syntax

Visual Basic (Declaration)
Public Function GetClientAction() As ISNet.WebUI.BaseClientSideAction
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As ISNet.WebUI.BaseClientSideAction

value = instance.GetClientAction()
C#
public ISNet.WebUI.BaseClientSideAction GetClientAction()
Delphi
public function GetClientAction(): ISNet.WebUI.BaseClientSideAction;
JScript
public function GetClientAction() : ISNet.WebUI.BaseClientSideAction;
Managed Extensions for C++
public: ISNet.WebUI.BaseClientSideAction* GetClientAction();
C++/CLI
public:
ISNet.WebUI.BaseClientSideAction^ GetClientAction();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


GetDHTMLRenderer Method

[image]
Intersoft WebTreeView Documentation
GetDHTMLRenderer Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : GetDHTMLRenderer Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetDHTMLRenderer() As ISNet.WebUI.RenderDHTML
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As ISNet.WebUI.RenderDHTML

value = instance.GetDHTMLRenderer()
C#
protected override ISNet.WebUI.RenderDHTML GetDHTMLRenderer()
Delphi
protected function GetDHTMLRenderer(): ISNet.WebUI.RenderDHTML; override;
JScript
protected override function GetDHTMLRenderer() : ISNet.WebUI.RenderDHTML;
Managed Extensions for C++
protected: ISNet.WebUI.RenderDHTML* GetDHTMLRenderer(); override
C++/CLI
protected:
ISNet.WebUI.RenderDHTML^ GetDHTMLRenderer(); override

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


InitializeDefaultStyles Method

[image]
Intersoft WebTreeView Documentation
InitializeDefaultStyles Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : InitializeDefaultStyles Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overrides Sub InitializeDefaultStyles()
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView

instance.InitializeDefaultStyles()
C#
protected override void InitializeDefaultStyles()
Delphi
protected procedure InitializeDefaultStyles(); override;
JScript
protected override function InitializeDefaultStyles();
Managed Extensions for C++
protected: void InitializeDefaultStyles(); override
C++/CLI
protected:
void InitializeDefaultStyles(); override

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


LoadNodesFromXml Method

[image]
Intersoft WebTreeView Documentation
LoadNodesFromXml Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : LoadNodesFromXml Method

Glossary Item Box

Loads WebTreeView's node structure from an XML file based on the XML value. Loads WebTreeView's structure from an XML file.

Overload List

Overload | Description
LoadNodesFromXml(String) | Loads WebTreeView's node structure from an XML file based on the XML value.
LoadNodesFromXml(XmlDocument) | Loads WebTreeView's node structure from an XML document with XMLDocument parameter.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


LoadNodesFromXml(String) Method

[image]
Intersoft WebTreeView Documentation
LoadNodesFromXml(String) Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class > LoadNodesFromXml Method : LoadNodesFromXml(String) Method

fileName
The specified XML filename.

Glossary Item Box

Loads WebTreeView's node structure from an XML file based on the XML value.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Load nodes from xml file.")>
Public Overloads Sub LoadNodesFromXml( _
   ByVal fileName As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim fileName As System.String

instance.LoadNodesFromXml(fileName)
C#
[System.ComponentModel.DescriptionAttribute("Load nodes from xml file.")]
public void LoadNodesFromXml(
   System.string fileName
)
Delphi
public procedure LoadNodesFromXml(
    fileName: System.String
);
JScript
System.ComponentModel.DescriptionAttribute("Load nodes from xml file.")
public function LoadNodesFromXml(
   fileName : System.String
);
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Load nodes from xml file.")]
public: void LoadNodesFromXml(
   System.string* fileName
)
C++/CLI
[System.ComponentModel.DescriptionAttribute("Load nodes from xml file.")]
public:
void LoadNodesFromXml(
   System.String^ fileName
)

Parameters

fileName
The specified XML filename.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members
Overload List


LoadNodesFromXml(XmlDocument) Method

[image]
Intersoft WebTreeView Documentation
LoadNodesFromXml(XmlDocument) Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class > LoadNodesFromXml Method : LoadNodesFromXml(XmlDocument) Method

doc
The specified XML document.

Glossary Item Box

Loads WebTreeView's node structure from an XML document with XMLDocument parameter.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Load nodes from xml document.")>
Public Overloads Sub LoadNodesFromXml( _
   ByVal doc As System.Xml.XmlDocument _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim doc As System.Xml.XmlDocument

instance.LoadNodesFromXml(doc)
C#
[System.ComponentModel.DescriptionAttribute("Load nodes from xml document.")]
public void LoadNodesFromXml(
   System.Xml.XmlDocument doc
)
Delphi
public procedure LoadNodesFromXml(
    doc: System.Xml.XmlDocument
);
JScript
System.ComponentModel.DescriptionAttribute("Load nodes from xml document.")
public function LoadNodesFromXml(
   doc : System.Xml.XmlDocument
);
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Load nodes from xml document.")]
public: void LoadNodesFromXml(
   System.Xml.XmlDocument* doc
)
C++/CLI
[System.ComponentModel.DescriptionAttribute("Load nodes from xml document.")]
public:
void LoadNodesFromXml(
   System.Xml.XmlDocument^ doc
)

Parameters

doc
The specified XML document.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members
Overload List


LoadViewState Method

[image]
Intersoft WebTreeView Documentation
LoadViewState Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : LoadViewState Method

savedState

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overrides Sub LoadViewState( _
   ByVal savedState As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim savedState As System.Object

instance.LoadViewState(savedState)
C#
protected override void LoadViewState(
   System.object savedState
)
Delphi
protected procedure LoadViewState(
    savedState: System.TObject
); override;
JScript
protected override function LoadViewState(
   savedState : System.Object
);
Managed Extensions for C++
protected: void LoadViewState(
   System.Object* savedState
) override
C++/CLI
protected:
void LoadViewState(
   System.Object^ savedState
) override

Parameters

savedState

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


OnInit Method

[image]
Intersoft WebTreeView Documentation
OnInit Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : OnInit Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnInit( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim e As System.EventArgs

instance.OnInit(e)
C#
protected override void OnInit(
   System.EventArgs e
)
Delphi
protected procedure OnInit(
    e: System.EventArgs
); override;
JScript
protected override function OnInit(
   e : System.EventArgs
);
Managed Extensions for C++
protected: void OnInit(
   System.EventArgs* e
) override
C++/CLI
protected:
void OnInit(
   System.EventArgs^ e
) override

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


OnPreRender Method

[image]
Intersoft WebTreeView Documentation
OnPreRender Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : OnPreRender Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnPreRender( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim e As System.EventArgs

instance.OnPreRender(e)
C#
protected override void OnPreRender(
   System.EventArgs e
)
Delphi
protected procedure OnPreRender(
    e: System.EventArgs
); override;
JScript
protected override function OnPreRender(
   e : System.EventArgs
);
Managed Extensions for C++
protected: void OnPreRender(
   System.EventArgs* e
) override
C++/CLI
protected:
void OnPreRender(
   System.EventArgs^ e
) override

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


RaiseDragDropEvent Method

[image]
Intersoft WebTreeView Documentation
RaiseDragDropEvent Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : RaiseDragDropEvent Method

node
draggedNodesCol
moveType
insertionMode

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Method use for triggering drag drop event.")>
Public Sub RaiseDragDropEvent( _
   ByVal node As WebTreeViewNode, _
   ByVal draggedNodesCol As System.Collections.Generic.List(Of WebTreeViewNode), _
   ByVal moveType As NodeMoveType, _
   ByVal insertionMode As NodeMoveInsertionMode _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim node As WebTreeViewNode
Dim draggedNodesCol As System.Collections.Generic.List(Of WebTreeViewNode)
Dim moveType As NodeMoveType
Dim insertionMode As NodeMoveInsertionMode

instance.RaiseDragDropEvent(node, draggedNodesCol, moveType, insertionMode)
C#
[System.ComponentModel.DescriptionAttribute("Method use for triggering drag drop event.")]
public void RaiseDragDropEvent(
   WebTreeViewNode node,
   System.Collections.Generic.List<WebTreeViewNode> draggedNodesCol,
   NodeMoveType moveType,
   NodeMoveInsertionMode insertionMode
)
Delphi
public procedure RaiseDragDropEvent(
    node: WebTreeViewNode;
    draggedNodesCol: System.Collections.Generic.List;
    moveType: NodeMoveType;
    insertionMode: NodeMoveInsertionMode
);
JScript
System.ComponentModel.DescriptionAttribute("Method use for triggering drag drop event.")
public function RaiseDragDropEvent(
   node : WebTreeViewNode,
   draggedNodesCol : System.Collections.Generic.List,
   moveType : NodeMoveType,
   insertionMode : NodeMoveInsertionMode
);
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Method use for triggering drag drop event.")]
public: void RaiseDragDropEvent(
   WebTreeViewNode* node,
   System.Collections.Generic.List<WebTreeViewNode*>* draggedNodesCol,
   NodeMoveType moveType,
   NodeMoveInsertionMode insertionMode
)
C++/CLI
[System.ComponentModel.DescriptionAttribute("Method use for triggering drag drop event.")]
public:
void RaiseDragDropEvent(
   WebTreeViewNode^ node,
   System.Collections.Generic.List<WebTreeViewNode^>^ draggedNodesCol,
   NodeMoveType moveType,
   NodeMoveInsertionMode insertionMode
)

Parameters

node
draggedNodesCol
moveType
insertionMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


RaiseInitializeChildNodesEvent Method

[image]
Intersoft WebTreeView Documentation
RaiseInitializeChildNodesEvent Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : RaiseInitializeChildNodesEvent Method

node
The specified node.

Glossary Item Box

Method used for triggering InitializeChildNodes event.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Method use for triggering InitializeChildNodes event.")>
Public Sub RaiseInitializeChildNodesEvent( _
   ByVal node As WebTreeViewNode _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim node As WebTreeViewNode

instance.RaiseInitializeChildNodesEvent(node)
C#
[System.ComponentModel.DescriptionAttribute("Method use for triggering InitializeChildNodes event.")]
public void RaiseInitializeChildNodesEvent(
   WebTreeViewNode node
)
Delphi
public procedure RaiseInitializeChildNodesEvent(
    node: WebTreeViewNode
);
JScript
System.ComponentModel.DescriptionAttribute("Method use for triggering InitializeChildNodes event.")
public function RaiseInitializeChildNodesEvent(
   node : WebTreeViewNode
);
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Method use for triggering InitializeChildNodes event.")]
public: void RaiseInitializeChildNodesEvent(
   WebTreeViewNode* node
)
C++/CLI
[System.ComponentModel.DescriptionAttribute("Method use for triggering InitializeChildNodes event.")]
public:
void RaiseInitializeChildNodesEvent(
   WebTreeViewNode^ node
)

Parameters

node
The specified node.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


RaiseInitializeNodeEvent Method

[image]
Intersoft WebTreeView Documentation
RaiseInitializeNodeEvent Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : RaiseInitializeNodeEvent Method

node
The specified node.

Glossary Item Box

Method used for triggering InitializeNode event.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Method use for triggering InitializeNode event.")>
Public Sub RaiseInitializeNodeEvent( _
   ByVal node As WebTreeViewNode _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim node As WebTreeViewNode

instance.RaiseInitializeNodeEvent(node)
C#
[System.ComponentModel.DescriptionAttribute("Method use for triggering InitializeNode event.")]
public void RaiseInitializeNodeEvent(
   WebTreeViewNode node
)
Delphi
public procedure RaiseInitializeNodeEvent(
    node: WebTreeViewNode
);
JScript
System.ComponentModel.DescriptionAttribute("Method use for triggering InitializeNode event.")
public function RaiseInitializeNodeEvent(
   node : WebTreeViewNode
);
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Method use for triggering InitializeNode event.")]
public: void RaiseInitializeNodeEvent(
   WebTreeViewNode* node
)
C++/CLI
[System.ComponentModel.DescriptionAttribute("Method use for triggering InitializeNode event.")]
public:
void RaiseInitializeNodeEvent(
   WebTreeViewNode^ node
)

Parameters

node
The specified node.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


RaiseNodeAddEvent Method

[image]
Intersoft WebTreeView Documentation
RaiseNodeAddEvent Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : RaiseNodeAddEvent Method

node
The specified node.

Glossary Item Box

Method used for triggering NodeAdd event.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Method use for triggering add node event. ")>
Public Sub RaiseNodeAddEvent( _
   ByVal node As WebTreeViewNode _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim node As WebTreeViewNode

instance.RaiseNodeAddEvent(node)
C#
[System.ComponentModel.DescriptionAttribute("Method use for triggering add node event. ")]
public void RaiseNodeAddEvent(
   WebTreeViewNode node
)
Delphi
public procedure RaiseNodeAddEvent(
    node: WebTreeViewNode
);
JScript
System.ComponentModel.DescriptionAttribute("Method use for triggering add node event. ")
public function RaiseNodeAddEvent(
   node : WebTreeViewNode
);
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Method use for triggering add node event. ")]
public: void RaiseNodeAddEvent(
   WebTreeViewNode* node
)
C++/CLI
[System.ComponentModel.DescriptionAttribute("Method use for triggering add node event. ")]
public:
void RaiseNodeAddEvent(
   WebTreeViewNode^ node
)

Parameters

node
The specified node.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


RaiseNodeCheckChangedEvent Method

[image]
Intersoft WebTreeView Documentation
RaiseNodeCheckChangedEvent Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : RaiseNodeCheckChangedEvent Method

node
The specified node.

Glossary Item Box

Method used for triggering NodeCheckChanged event.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Method use for triggering NodeCheckChanged event. ")>
Public Sub RaiseNodeCheckChangedEvent( _
   ByVal node As WebTreeViewNode _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim node As WebTreeViewNode

instance.RaiseNodeCheckChangedEvent(node)
C#
[System.ComponentModel.DescriptionAttribute("Method use for triggering NodeCheckChanged event. ")]
public void RaiseNodeCheckChangedEvent(
   WebTreeViewNode node
)
Delphi
public procedure RaiseNodeCheckChangedEvent(
    node: WebTreeViewNode
);
JScript
System.ComponentModel.DescriptionAttribute("Method use for triggering NodeCheckChanged event. ")
public function RaiseNodeCheckChangedEvent(
   node : WebTreeViewNode
);
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Method use for triggering NodeCheckChanged event. ")]
public: void RaiseNodeCheckChangedEvent(
   WebTreeViewNode* node
)
C++/CLI
[System.ComponentModel.DescriptionAttribute("Method use for triggering NodeCheckChanged event. ")]
public:
void RaiseNodeCheckChangedEvent(
   WebTreeViewNode^ node
)

Parameters

node
The specified node.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


RaiseNodeCollapseEvent Method

[image]
Intersoft WebTreeView Documentation
RaiseNodeCollapseEvent Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : RaiseNodeCollapseEvent Method

node
The specified node.

Glossary Item Box

Method used for triggering NodeCollapse event.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Method use for triggering NodeCollapse event. ")>
Public Sub RaiseNodeCollapseEvent( _
   ByVal node As WebTreeViewNode _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim node As WebTreeViewNode

instance.RaiseNodeCollapseEvent(node)
C#
[System.ComponentModel.DescriptionAttribute("Method use for triggering NodeCollapse event. ")]
public void RaiseNodeCollapseEvent(
   WebTreeViewNode node
)
Delphi
public procedure RaiseNodeCollapseEvent(
    node: WebTreeViewNode
);
JScript
System.ComponentModel.DescriptionAttribute("Method use for triggering NodeCollapse event. ")
public function RaiseNodeCollapseEvent(
   node : WebTreeViewNode
);
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Method use for triggering NodeCollapse event. ")]
public: void RaiseNodeCollapseEvent(
   WebTreeViewNode* node
)
C++/CLI
[System.ComponentModel.DescriptionAttribute("Method use for triggering NodeCollapse event. ")]
public:
void RaiseNodeCollapseEvent(
   WebTreeViewNode^ node
)

Parameters

node
The specified node.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


RaiseNodeDeleteEvent Method

[image]
Intersoft WebTreeView Documentation
RaiseNodeDeleteEvent Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : RaiseNodeDeleteEvent Method

node
The specified node.

Glossary Item Box

Method used for triggering NodeDelete event.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Method use for triggering node delete event. ")>
Public Sub RaiseNodeDeleteEvent( _
   ByVal node As WebTreeViewNode _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim node As WebTreeViewNode

instance.RaiseNodeDeleteEvent(node)
C#
[System.ComponentModel.DescriptionAttribute("Method use for triggering node delete event. ")]
public void RaiseNodeDeleteEvent(
   WebTreeViewNode node
)
Delphi
public procedure RaiseNodeDeleteEvent(
    node: WebTreeViewNode
);
JScript
System.ComponentModel.DescriptionAttribute("Method use for triggering node delete event. ")
public function RaiseNodeDeleteEvent(
   node : WebTreeViewNode
);
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Method use for triggering node delete event. ")]
public: void RaiseNodeDeleteEvent(
   WebTreeViewNode* node
)
C++/CLI
[System.ComponentModel.DescriptionAttribute("Method use for triggering node delete event. ")]
public:
void RaiseNodeDeleteEvent(
   WebTreeViewNode^ node
)

Parameters

node
The specified node.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


RaiseNodeEditEvent Method

[image]
Intersoft WebTreeView Documentation
RaiseNodeEditEvent Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : RaiseNodeEditEvent Method

node
The specified node.
oldText
The specified node's old text that wants to be edited.

Glossary Item Box

Method used for triggering NodeEdit event.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Method use for triggering node edit event. ")>
Public Sub RaiseNodeEditEvent( _
   ByVal node As WebTreeViewNode, _
   ByVal oldText As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim node As WebTreeViewNode
Dim oldText As System.String

instance.RaiseNodeEditEvent(node, oldText)
C#
[System.ComponentModel.DescriptionAttribute("Method use for triggering node edit event. ")]
public void RaiseNodeEditEvent(
   WebTreeViewNode node,
   System.string oldText
)
Delphi
public procedure RaiseNodeEditEvent(
    node: WebTreeViewNode;
    oldText: System.String
);
JScript
System.ComponentModel.DescriptionAttribute("Method use for triggering node edit event. ")
public function RaiseNodeEditEvent(
   node : WebTreeViewNode,
   oldText : System.String
);
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Method use for triggering node edit event. ")]
public: void RaiseNodeEditEvent(
   WebTreeViewNode* node,
   System.string* oldText
)
C++/CLI
[System.ComponentModel.DescriptionAttribute("Method use for triggering node edit event. ")]
public:
void RaiseNodeEditEvent(
   WebTreeViewNode^ node,
   System.String^ oldText
)

Parameters

node
The specified node.
oldText
The specified node's old text that wants to be edited.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


RaiseNodeExpandEvent Method

[image]
Intersoft WebTreeView Documentation
RaiseNodeExpandEvent Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : RaiseNodeExpandEvent Method

node
The specified node.

Glossary Item Box

Method used for triggering NodeExpand event.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Method use for triggering NodeExpand event. ")>
Public Sub RaiseNodeExpandEvent( _
   ByVal node As WebTreeViewNode _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim node As WebTreeViewNode

instance.RaiseNodeExpandEvent(node)
C#
[System.ComponentModel.DescriptionAttribute("Method use for triggering NodeExpand event. ")]
public void RaiseNodeExpandEvent(
   WebTreeViewNode node
)
Delphi
public procedure RaiseNodeExpandEvent(
    node: WebTreeViewNode
);
JScript
System.ComponentModel.DescriptionAttribute("Method use for triggering NodeExpand event. ")
public function RaiseNodeExpandEvent(
   node : WebTreeViewNode
);
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Method use for triggering NodeExpand event. ")]
public: void RaiseNodeExpandEvent(
   WebTreeViewNode* node
)
C++/CLI
[System.ComponentModel.DescriptionAttribute("Method use for triggering NodeExpand event. ")]
public:
void RaiseNodeExpandEvent(
   WebTreeViewNode^ node
)

Parameters

node
The specified node.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


RaiseNodeMoveEvent Method

[image]
Intersoft WebTreeView Documentation
RaiseNodeMoveEvent Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : RaiseNodeMoveEvent Method

sourceNode
targetNode
moveType
insertionMode

Glossary Item Box

Method used for triggering NodeMove event.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Method use for triggering node move event.")>
Public Sub RaiseNodeMoveEvent( _
   ByVal sourceNode As WebTreeViewNode, _
   ByVal targetNode As WebTreeViewNode, _
   ByVal moveType As NodeMoveType, _
   ByVal insertionMode As NodeMoveInsertionMode _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim sourceNode As WebTreeViewNode
Dim targetNode As WebTreeViewNode
Dim moveType As NodeMoveType
Dim insertionMode As NodeMoveInsertionMode

instance.RaiseNodeMoveEvent(sourceNode, targetNode, moveType, insertionMode)
C#
[System.ComponentModel.DescriptionAttribute("Method use for triggering node move event.")]
public void RaiseNodeMoveEvent(
   WebTreeViewNode sourceNode,
   WebTreeViewNode targetNode,
   NodeMoveType moveType,
   NodeMoveInsertionMode insertionMode
)
Delphi
public procedure RaiseNodeMoveEvent(
    sourceNode: WebTreeViewNode;
    targetNode: WebTreeViewNode;
    moveType: NodeMoveType;
    insertionMode: NodeMoveInsertionMode
);
JScript
System.ComponentModel.DescriptionAttribute("Method use for triggering node move event.")
public function RaiseNodeMoveEvent(
   sourceNode : WebTreeViewNode,
   targetNode : WebTreeViewNode,
   moveType : NodeMoveType,
   insertionMode : NodeMoveInsertionMode
);
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Method use for triggering node move event.")]
public: void RaiseNodeMoveEvent(
   WebTreeViewNode* sourceNode,
   WebTreeViewNode* targetNode,
   NodeMoveType moveType,
   NodeMoveInsertionMode insertionMode
)
C++/CLI
[System.ComponentModel.DescriptionAttribute("Method use for triggering node move event.")]
public:
void RaiseNodeMoveEvent(
   WebTreeViewNode^ sourceNode,
   WebTreeViewNode^ targetNode,
   NodeMoveType moveType,
   NodeMoveInsertionMode insertionMode
)

Parameters

sourceNode
targetNode
moveType
insertionMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


RaiseNodeRenameEvent Method

[image]
Intersoft WebTreeView Documentation
RaiseNodeRenameEvent Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : RaiseNodeRenameEvent Method

oldText
The specified node's old text that wants to be replaced.
node
The specified node.

Glossary Item Box

Method used for triggering NodeRename event.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Method use for triggering NodeRename event.")>
Public Sub RaiseNodeRenameEvent( _
   ByVal oldText As System.String, _
   ByVal node As WebTreeViewNode _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim oldText As System.String
Dim node As WebTreeViewNode

instance.RaiseNodeRenameEvent(oldText, node)
C#
[System.ComponentModel.DescriptionAttribute("Method use for triggering NodeRename event.")]
public void RaiseNodeRenameEvent(
   System.string oldText,
   WebTreeViewNode node
)
Delphi
public procedure RaiseNodeRenameEvent(
    oldText: System.String;
    node: WebTreeViewNode
);
JScript
System.ComponentModel.DescriptionAttribute("Method use for triggering NodeRename event.")
public function RaiseNodeRenameEvent(
   oldText : System.String,
   node : WebTreeViewNode
);
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Method use for triggering NodeRename event.")]
public: void RaiseNodeRenameEvent(
   System.string* oldText,
   WebTreeViewNode* node
)
C++/CLI
[System.ComponentModel.DescriptionAttribute("Method use for triggering NodeRename event.")]
public:
void RaiseNodeRenameEvent(
   System.String^ oldText,
   WebTreeViewNode^ node
)

Parameters

oldText
The specified node's old text that wants to be replaced.
node
The specified node.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


RaiseNodeSelectChangedEvent Method

[image]
Intersoft WebTreeView Documentation
RaiseNodeSelectChangedEvent Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : RaiseNodeSelectChangedEvent Method

node
The specified node.

Glossary Item Box

Method used for triggering NodeSelectedChanged event.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Method use for triggering NodeSelectedChanged event. ")>
Public Sub RaiseNodeSelectChangedEvent( _
   ByVal node As WebTreeViewNode _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim node As WebTreeViewNode

instance.RaiseNodeSelectChangedEvent(node)
C#
[System.ComponentModel.DescriptionAttribute("Method use for triggering NodeSelectedChanged event. ")]
public void RaiseNodeSelectChangedEvent(
   WebTreeViewNode node
)
Delphi
public procedure RaiseNodeSelectChangedEvent(
    node: WebTreeViewNode
);
JScript
System.ComponentModel.DescriptionAttribute("Method use for triggering NodeSelectedChanged event. ")
public function RaiseNodeSelectChangedEvent(
   node : WebTreeViewNode
);
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Method use for triggering NodeSelectedChanged event. ")]
public: void RaiseNodeSelectChangedEvent(
   WebTreeViewNode* node
)
C++/CLI
[System.ComponentModel.DescriptionAttribute("Method use for triggering NodeSelectedChanged event. ")]
public:
void RaiseNodeSelectChangedEvent(
   WebTreeViewNode^ node
)

Parameters

node
The specified node.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


RaiseNodeUpdatedEvent Method

[image]
Intersoft WebTreeView Documentation
RaiseNodeUpdatedEvent Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : RaiseNodeUpdatedEvent Method

node
propertyName
value
oldValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Method use for triggering node updated event. ")>
Public Sub RaiseNodeUpdatedEvent( _
   ByVal node As WebTreeViewNode, _
   ByVal propertyName As System.String, _
   ByVal value As System.Object, _
   ByVal oldValue As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim node As WebTreeViewNode
Dim propertyName As System.String
Dim value As System.Object
Dim oldValue As System.Object

instance.RaiseNodeUpdatedEvent(node, propertyName, value, oldValue)
C#
[System.ComponentModel.DescriptionAttribute("Method use for triggering node updated event. ")]
public void RaiseNodeUpdatedEvent(
   WebTreeViewNode node,
   System.string propertyName,
   System.object value,
   System.object oldValue
)
Delphi
public procedure RaiseNodeUpdatedEvent(
    node: WebTreeViewNode;
    propertyName: System.String;
    value: System.TObject;
    oldValue: System.TObject
);
JScript
System.ComponentModel.DescriptionAttribute("Method use for triggering node updated event. ")
public function RaiseNodeUpdatedEvent(
   node : WebTreeViewNode,
   propertyName : System.String,
   value : System.Object,
   oldValue : System.Object
);
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Method use for triggering node updated event. ")]
public: void RaiseNodeUpdatedEvent(
   WebTreeViewNode* node,
   System.string* propertyName,
   System.Object* value,
   System.Object* oldValue
)
C++/CLI
[System.ComponentModel.DescriptionAttribute("Method use for triggering node updated event. ")]
public:
void RaiseNodeUpdatedEvent(
   WebTreeViewNode^ node,
   System.String^ propertyName,
   System.Object^ value,
   System.Object^ oldValue
)

Parameters

node
propertyName
value
oldValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


RenderContents Method

[image]
Intersoft WebTreeView Documentation
RenderContents Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : RenderContents Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overrides Sub RenderContents( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderContents(writer)
C#
protected override void RenderContents(
   System.Web.UI.HtmlTextWriter writer
)
Delphi
protected procedure RenderContents(
    writer: System.Web.UI.HtmlTextWriter
); override;
JScript
protected override function RenderContents(
   writer : System.Web.UI.HtmlTextWriter
);
Managed Extensions for C++
protected: void RenderContents(
   System.Web.UI.HtmlTextWriter* writer
) override
C++/CLI
protected:
void RenderContents(
   System.Web.UI.HtmlTextWriter^ writer
) override

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


SaveNodesToXml Method

[image]
Intersoft WebTreeView Documentation
SaveNodesToXml Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : SaveNodesToXml Method

Glossary Item Box

Saves WebTreeView's structure to an XML file with String parameter as the filename of XML. Saves WebTreeView's structure to an XML file.

Overload List

Overload | Description
SaveNodesToXml(String) | Saves WebTreeView's structure to an XML file with String parameter as the filename of XML.
SaveNodesToXml() | Saves WebTreeView's structure to an XML file with no parameter.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


SaveNodesToXml(String) Method

[image]
Intersoft WebTreeView Documentation
SaveNodesToXml(String) Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class > SaveNodesToXml Method : SaveNodesToXml(String) Method

fileName
The filename of the XML.

Glossary Item Box

Saves WebTreeView's structure to an XML file with String parameter as the filename of XML.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Save nodes to xml file.")>
Public Overloads Sub SaveNodesToXml( _
   ByVal fileName As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim fileName As System.String

instance.SaveNodesToXml(fileName)
C#
[System.ComponentModel.DescriptionAttribute("Save nodes to xml file.")]
public void SaveNodesToXml(
   System.string fileName
)
Delphi
public procedure SaveNodesToXml(
    fileName: System.String
);
JScript
System.ComponentModel.DescriptionAttribute("Save nodes to xml file.")
public function SaveNodesToXml(
   fileName : System.String
);
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Save nodes to xml file.")]
public: void SaveNodesToXml(
   System.string* fileName
)
C++/CLI
[System.ComponentModel.DescriptionAttribute("Save nodes to xml file.")]
public:
void SaveNodesToXml(
   System.String^ fileName
)

Parameters

fileName
The filename of the XML.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members
Overload List


SaveNodesToXml() Method

[image]
Intersoft WebTreeView Documentation
SaveNodesToXml() Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class > SaveNodesToXml Method : SaveNodesToXml() Method

Glossary Item Box

Saves WebTreeView's structure to an XML file with no parameter.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Save nodes to xml document.")>
Public Overloads Function SaveNodesToXml() As System.Xml.XmlDocument
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Xml.XmlDocument

value = instance.SaveNodesToXml()
C#
[System.ComponentModel.DescriptionAttribute("Save nodes to xml document.")]
public System.Xml.XmlDocument SaveNodesToXml()
Delphi
public function SaveNodesToXml(): System.Xml.XmlDocument;
JScript
System.ComponentModel.DescriptionAttribute("Save nodes to xml document.")
public function SaveNodesToXml() : System.Xml.XmlDocument;
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Save nodes to xml document.")]
public: System.Xml.XmlDocument* SaveNodesToXml();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Save nodes to xml document.")]
public:
System.Xml.XmlDocument^ SaveNodesToXml();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members
Overload List


SaveViewState Method

[image]
Intersoft WebTreeView Documentation
SaveViewState Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : SaveViewState Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overrides Function SaveViewState() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Object

value = instance.SaveViewState()
C#
protected override System.object SaveViewState()
Delphi
protected function SaveViewState(): System.TObject; override;
JScript
protected override function SaveViewState() : System.Object;
Managed Extensions for C++
protected: System.Object* SaveViewState(); override
C++/CLI
protected:
System.Object^ SaveViewState(); override

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


UnCheckAll Method

[image]
Intersoft WebTreeView Documentation
UnCheckAll Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : UnCheckAll Method

Glossary Item Box

Method used for unchecking all node level.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Method use for unchecking all node level. ")>
Public Sub UnCheckAll()
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView

instance.UnCheckAll()
C#
[System.ComponentModel.DescriptionAttribute("Method use for unchecking all node level. ")]
public void UnCheckAll()
Delphi
public procedure UnCheckAll();
JScript
System.ComponentModel.DescriptionAttribute("Method use for unchecking all node level. ")
public function UnCheckAll();
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Method use for unchecking all node level. ")]
public: void UnCheckAll();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Method use for unchecking all node level. ")]
public:
void UnCheckAll();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


WebTreeView Class Properties

[image]
Intersoft WebTreeView Documentation
WebTreeView Class Properties
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace : WebTreeView Class

Glossary Item Box

For a list of all members of this type, see WebTreeView members.

Public Properties

 | Name | Description
Public Property | AccessKey | Keyboard shortcut used by the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | AllowAddNode | Indicates whether to allow node adding or not.
Public Property | AllowCollapseNodeOnSelect | Indicates whether to collapse a parent node when it is selected.Indicates whether to collapse a parent node when it is selected.
Public Property | AllowDeleteNode | Indicates whether to allow node deleting or not.
Public Property | AllowDragDrop | Specifies whether to allow drag and drop of the tree nodes.Specifies whether to allow drag and drop of the tree nodes.
Public Property | AllowDropFromOtherControls | Indicates whether to allow drop from other Intersoft controls.Indicates whether to allow dropping from other Intersoft's controls.
Public Property | AllowExpandNodeOnSelect | Indicates whether to expand a parent node when it is selected.Indicates whether to expand a parent node when it is selected.
Public Property | AllowExpandSinglePath | Indicates whether to collapse all other paths when expanding a node, ensuring that only one path is expanded.Indicates whether to collapse the other paths when expanding a node, ensuring that only one path is expanded.
Public Property | AllowKeyboardNavigation | Indicates whether to allow keyboard navigation.Indicates whether to allow keyboard navigation or not.
Public Property | AllowMultipleSelect | Specifies whether to allow multiple select on the tree nodes.Specifies whether to allow multiple select on TreeView nodes.
Public Property | AllowNodeEditing | Indicates whether to allow node editing.Indicates whether to allow node editing.
Public Property | AppRelativeTemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | AspNetAjaxSettings | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Attributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | AutoCheckChildNodes | Indicates whether to automatically check child nodes.
Public Property | AutoGenerateDataBindings | Gets or sets the auto generate data bindings.Specifies whether WebTreeView retrieves data from a datasource and bind it automatically.
Public Property | AutoPostBackSettings | Contains auto postback settings such as OnNodeMove, OnNodeExpand, OnNodeCollapse, etc.Contains auto postback settings such as OnNodeMove, OnNodeExpand, OnNodeCollapse, etc.
Public Property | AutoSelectOnNodeExpandCollapse | Indicates whether to automatically select node when a node is expanded/collapsed.
Public Property | BackColor | Color of the background of the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | BorderColor | Color of the border around the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | BorderStyle | Style of the border around the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | BorderWidth | Width of the border around the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | CheckBoxType | Gets or sets the type of node checkbox, whether to use image or standard checkbox.Gets or sets the type of node's checkbox, whether to use image or standard checkbox.
Public Property | CheckedNodes | The collection of checkable nodes which are currently checked.Determines the collection of checked nodes.
Public Property | ClientAction | Returns ClientSideAction class Returns ClientSideAction class.
Public Property | ClientID | (Inherited from System.Web.UI.Control)
Public Property | ClientIDMode | (Inherited from System.Web.UI.Control)
Public Property | ClientSideEvents | Contains Javascript ClientSide events.Contains WebTreeView's JavaScript client-side event.
Public Property | ControlDataTransferFormat | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Controls | (Inherited from System.Web.UI.Control)
Public Property | ControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ControlStyleCreated | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | CssClass | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | DataBindings | A collection of properties available for data bound node.
Public Property | DataMember | Gets or sets the datamember of the treeview.Gets or sets the data member.
Public Property | DataSource | Gets or sets the datasource of the treeview.Specifies the type of WebTreeView's datasource.
Public Property | DataSourceID | Gets or sets the ID of the control from which the treeview control retrieves its list.Gets or sets the ID of the control which TreeView control retrieves its list.
Public Property | DefaultImageHeight | Gets or sets the default height(in pixels) to use for icon images.Gets or sets the default image height (in pixel) which will be used as an icon images.
Public Property | DefaultImageWidth | Gets or sets the default width(in pixels) to use for icon images.Gets or sets the default image width (in pixel) which will be used as an icon images.
Public Property | DefaultPathSeparator | Gets or sets the default path separator symbol.
Public Property | DragDropSettings | Contains drag and drop settings such as AllowRootDrop, AllowChildDrop, and AllowSiblingDrop.Contains drag and drop settings such as AllowRootDrop, AllowChildDrop, and AllowSiblingDrop.
Public Property | Enabled | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableLoadOnDemand | Indicates whether to enable load on demand.Indicates whether to allow LoadOnDemand or not.
Public Property | EnableManagedTheming | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableTriStateCheckBox | Specifies whether to enable tristate checkbox.Specifies whether to allow TriState checkbox or not.
Public Property | EnableTriStateCheckBoxParentInIndeterminateState |
Public Property | EnableViewState | Specifies whether the control automatically saves its state for use in round-trips. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableWebResources | Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ExpandCollapseImageHeight | Gets or sets the default height(in pixels) to use for expand/collapse images.Gets or sets the default image height (in pixel) which will be used as an expand/collapse image.
Public Property | ExpandCollapseImageWidth | Gets or sets the default width(in pixels) to use for expand/collapse images.Gets or sets the default image width (in pixel) which will be used as an expand/collapse image.
Public Property | ExpandedDepth | Gets or sets the expanded depth.Determines whether all specified nodes (based on their depth) are expanded (initially and on postback) or not
Public Property | FlyPostBackSettings | Configures the settings used by the control when performing OnTheFly postback. Configures the settings used by the control when performing OnTheFly postback.
Public Property | Font | Overridden. Gets or sets the font of node's text.
Public Property | ForeColor | Color of the text within the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | FrameStyle | The style applied to frame of the control.Style applied to the frame of the control.
Public Property | HasAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Height | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | ImagesDirectory | Gets or sets the location of images used to render the control.Gets or sets the location of the images used for rendering the control.
Public Property | ImagesSettings | Contains images settings for WebTreeView.Contains image settings for WebTreeView.
Public Property | IsControlThemed | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | IsDataBindingPerformed |
Public Property | IsDesign | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | IsDynamicCreated | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | IsFlyPostBack | Returns whether this instance invokes OnTheFly postback. Returns whether the specified WebTreeView instance invokes OnTheFly postback.
Public Property | IsInternalCreated | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | IsUnloaded | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | LineImageHeight | Gets or sets the height(in pixels) to apply on line images.Gets or sets the height (in pixel) of the line images.
Public Property | LineImageWidth | Gets or sets the width(in pixels) to apply on line images.Gets or sets the width (in pixel) of the line images.
Public Property | LoadingStyle | Gets or sets the style of the loading.Gets or sets the style used when loading LoadOnDemand content.
Public Property | LoadingText | Gets or sets the text to use while loading load-on-demand content.Gets or sets the text used when loading LoadOnDemand content.
Public Property | MaxDataBindDepth | Gets or sets the depth to which the TreeView will databind.Gets or sets the depth to which TreeView will be bound.
Public Property | NamingContainer | (Inherited from System.Web.UI.Control)
Public Property | NodeIndent | Gets or sets the width(in pixels) to indent each level of the node.Gets or sets the width (in pixel) of indentation on each level of the node.
Public Property | Nodes | The collection of nodes for WebTreeView.Specifies a collection of WebTreeView's nodes.
Public Property | NodeSettings | Contains node settings such as TargetWindow, and EnableAnimation.Contains node settings such as TargetWindow and EnableAnimation.
Public Property | NodeStyle | Gets or sets the style of the node.Gets or sets the style of a node.
Public Property | Page | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Parent | (Inherited from System.Web.UI.Control)
Public Property | ParentStyleId | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | PathSeparator | Specifies the character used to separate parts of the path.Specifies the character used to separate parts of the path.
Public Property | PersistInfoDuringLoadOnDemand | Indicates whether to persist nodes info during load on demand.
Public Property | PostBackModeType | Gets or sets the type of postback mode, whether to use flypostback or fullpostback.Gets or sets the type of postback mode, whether to use flypostback or fullpostback.
Public Property | RenderingCompatibility | (Inherited from System.Web.UI.Control)
Public Property | RenderingMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RequiresUIRefresh | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RuntimeLicenseKey | The runtime license key that is used for xcopy development. For Registered customers, please obtain the key through Intersoft Developer Network. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | SaveViewStateOnFlyPostback | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ScriptDirectory | Overridden. Gets or sets the location of the required scripts used by WebTreeView.
Public Property | SelectedNode | Specifies a selected node.
Public Property | SelectedNodes | The collection of selected nodes.Specifies a collection of the selected nodes.
Public Property | SerializedJSFiles | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | SerializedStyles | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | SharedScriptDirectory | Overridden.
Public Property | ShowCheckBoxes | Gets or sets the node type next to which checkboxes should be shown.Gets or sets which node level will have checkbox shown on it.
Public Property | ShowExpandCollapse | Specifies whether to show the expand/collapse icon next to the tree nodes.Specifies whether to show the expand/collapse icon next to the nodes.
Public Property | ShowLines | Specifies whether to show lines connecting the tree nodes.Specifies whether to show lines connecting the tree nodes.
Public Property | Site | (Inherited from System.Web.UI.Control)
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Style | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | SupportsDisabledAttribute | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | SupportXMLCultureInfo | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | TabIndex | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | TemplateControl | (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | ToolTip | The tooltip displayed when the mouse is over the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | UniqueID | (Inherited from System.Web.UI.Control)
Public Property | ValidateRequestMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateItems | Gets or sets the item to be stored in view state storage. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateServerConnection | Gets or sets the server connection string for file server-based viewstate storage. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateStorage | Gets or sets the location to store the viewstate of this control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Visible | Indicates whether the control is visible and rendered. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Width | The width of the control. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | XmlCompressionEnabled | Specifies whether the Xml used for clientside state storage should be compressed. (Inherited from ISNet.WebUI.ISNetControl)
Public Property | XPath | Specifies an intial XPath that is applied to the XML data.Specifies an initial XPath that is applied to the XML data.
Top

Protected Properties

 | Name | Description
Protected Property | Adapter | (Inherited from System.Web.UI.Control)
Protected Property | ChildControlsCreated | (Inherited from System.Web.UI.Control)
Protected Property | ClientIDSeparator | (Inherited from System.Web.UI.Control)
Protected Property | DefaultImagesFolder | Overridden.
Protected Property | Events | (Inherited from System.Web.UI.Control)
Protected Property | HasChildViewState | (Inherited from System.Web.UI.Control)
Protected Property | IdSeparator | (Inherited from System.Web.UI.Control)
Protected Property | IsMvc | (Inherited from ISNet.WebUI.ISNetControl)
Protected Property | IsTrackingViewState | (Inherited from System.Web.UI.Control)
Protected Property | LicenseType | Overridden.
Protected Property | LoadViewStateByID | (Inherited from System.Web.UI.Control)
Protected Property | MaxJsonLength | (Inherited from ISNet.WebUI.ISNetControl)
Protected Property | Product | Overridden.
Protected Property | ProductIcon | Overridden.
Protected Property | ProductImage | Overridden.
Protected Property | SupportDataSourceControl | Overridden.
Protected Property | TagKey | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Property | TagName | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Property | ViewState | (Inherited from System.Web.UI.Control)
Protected Property | ViewStateIgnoresCase | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

WebTreeView Class
ISNet.WebUI.WebTreeView Namespace

Concepts

Overview


AllowAddNode Property

[image]
Intersoft WebTreeView Documentation
AllowAddNode Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : AllowAddNode Property

Glossary Item Box

Indicates whether to allow node adding or not.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Indicates whether to allow keyboard navigation.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property AllowAddNode As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Boolean

instance.AllowAddNode = value

value = instance.AllowAddNode
C#
[System.ComponentModel.DescriptionAttribute("Indicates whether to allow keyboard navigation.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.bool AllowAddNode {get; set;}
Delphi
public read-write property AllowAddNode: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Indicates whether to allow keyboard navigation.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set AllowAddNode : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Indicates whether to allow keyboard navigation.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.bool get_AllowAddNode();
public: __property void set_AllowAddNode(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Indicates whether to allow keyboard navigation.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.bool AllowAddNode {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


AllowCollapseNodeOnSelect Property

[image]
Intersoft WebTreeView Documentation
AllowCollapseNodeOnSelect Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : AllowCollapseNodeOnSelect Property

Glossary Item Box

Indicates whether to collapse a parent node when it is selected.Indicates whether to collapse a parent node when it is selected.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Indicates whether to collapse a parent node when it is selected.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property AllowCollapseNodeOnSelect As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Boolean

instance.AllowCollapseNodeOnSelect = value

value = instance.AllowCollapseNodeOnSelect
C#
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Indicates whether to collapse a parent node when it is selected.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool AllowCollapseNodeOnSelect {get; set;}
Delphi
public read-write property AllowCollapseNodeOnSelect: System.Boolean;
JScript
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Indicates whether to collapse a parent node when it is selected.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set AllowCollapseNodeOnSelect : System.boolean
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Indicates whether to collapse a parent node when it is selected.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_AllowCollapseNodeOnSelect();
public: __property void set_AllowCollapseNodeOnSelect(
   System.bool value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Indicates whether to collapse a parent node when it is selected.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool AllowCollapseNodeOnSelect {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


AllowDeleteNode Property

[image]
Intersoft WebTreeView Documentation
AllowDeleteNode Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : AllowDeleteNode Property

Glossary Item Box

Indicates whether to allow node deleting or not.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Indicates whether to allow keyboard navigation.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Property AllowDeleteNode As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Boolean

instance.AllowDeleteNode = value

value = instance.AllowDeleteNode
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Indicates whether to allow keyboard navigation.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public System.bool AllowDeleteNode {get; set;}
Delphi
public read-write property AllowDeleteNode: System.Boolean;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Indicates whether to allow keyboard navigation.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set AllowDeleteNode : System.boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Indicates whether to allow keyboard navigation.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property System.bool get_AllowDeleteNode();
public: __property void set_AllowDeleteNode(
   System.bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Indicates whether to allow keyboard navigation.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
property System.bool AllowDeleteNode {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


AllowDragDrop Property

[image]
Intersoft WebTreeView Documentation
AllowDragDrop Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : AllowDragDrop Property

Glossary Item Box

Specifies whether to allow drag and drop of the tree nodes.Specifies whether to allow drag and drop of the tree nodes.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.DescriptionAttribute("Specifies whether to allow drag and drop of the tree nodes.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property AllowDragDrop As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Boolean

instance.AllowDragDrop = value

value = instance.AllowDragDrop
C#
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute("Specifies whether to allow drag and drop of the tree nodes.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.bool AllowDragDrop {get; set;}
Delphi
public read-write property AllowDragDrop: System.Boolean;
JScript
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.DescriptionAttribute("Specifies whether to allow drag and drop of the tree nodes.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set AllowDragDrop : System.boolean
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute("Specifies whether to allow drag and drop of the tree nodes.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.bool get_AllowDragDrop();
public: __property void set_AllowDragDrop(
   System.bool value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute("Specifies whether to allow drag and drop of the tree nodes.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.bool AllowDragDrop {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


AllowDropFromOtherControls Property

[image]
Intersoft WebTreeView Documentation
AllowDropFromOtherControls Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : AllowDropFromOtherControls Property

Glossary Item Box

Indicates whether to allow drop from other Intersoft controls.Indicates whether to allow dropping from other Intersoft's controls.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.DescriptionAttribute("Indicates whether to allow drop from other Intersoft controls.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property AllowDropFromOtherControls As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Boolean

instance.AllowDropFromOtherControls = value

value = instance.AllowDropFromOtherControls
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute("Indicates whether to allow drop from other Intersoft controls.")]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool AllowDropFromOtherControls {get; set;}
Delphi
public read-write property AllowDropFromOtherControls: System.Boolean;
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.DescriptionAttribute("Indicates whether to allow drop from other Intersoft controls.")
System.ComponentModel.DefaultValueAttribute()
public function get,set AllowDropFromOtherControls : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute("Indicates whether to allow drop from other Intersoft controls.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_AllowDropFromOtherControls();
public: __property void set_AllowDropFromOtherControls(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute("Indicates whether to allow drop from other Intersoft controls.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool AllowDropFromOtherControls {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


AllowExpandNodeOnSelect Property

[image]
Intersoft WebTreeView Documentation
AllowExpandNodeOnSelect Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : AllowExpandNodeOnSelect Property

Glossary Item Box

Indicates whether to expand a parent node when it is selected.Indicates whether to expand a parent node when it is selected.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Indicates whether to expand a parent node when it is selected.")>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Property AllowExpandNodeOnSelect As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Boolean

instance.AllowExpandNodeOnSelect = value

value = instance.AllowExpandNodeOnSelect
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Indicates whether to expand a parent node when it is selected.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
public System.bool AllowExpandNodeOnSelect {get; set;}
Delphi
public read-write property AllowExpandNodeOnSelect: System.Boolean;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Indicates whether to expand a parent node when it is selected.")
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set AllowExpandNodeOnSelect : System.boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Indicates whether to expand a parent node when it is selected.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property System.bool get_AllowExpandNodeOnSelect();
public: __property void set_AllowExpandNodeOnSelect(
   System.bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Indicates whether to expand a parent node when it is selected.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
property System.bool AllowExpandNodeOnSelect {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


AllowExpandSinglePath Property

[image]
Intersoft WebTreeView Documentation
AllowExpandSinglePath Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : AllowExpandSinglePath Property

Glossary Item Box

Indicates whether to collapse all other paths when expanding a node, ensuring that only one path is expanded.Indicates whether to collapse the other paths when expanding a node, ensuring that only one path is expanded.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Indicates whether to collapse all other paths when expanding a node, ensuring that only one path is expanded.")>
Public Property AllowExpandSinglePath As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Boolean

instance.AllowExpandSinglePath = value

value = instance.AllowExpandSinglePath
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Indicates whether to collapse all other paths when expanding a node, ensuring that only one path is expanded.")]
public System.bool AllowExpandSinglePath {get; set;}
Delphi
public read-write property AllowExpandSinglePath: System.Boolean;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Indicates whether to collapse all other paths when expanding a node, ensuring that only one path is expanded.")
public function get,set AllowExpandSinglePath : System.boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Indicates whether to collapse all other paths when expanding a node, ensuring that only one path is expanded.")]
public: __property System.bool get_AllowExpandSinglePath();
public: __property void set_AllowExpandSinglePath(
   System.bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Indicates whether to collapse all other paths when expanding a node, ensuring that only one path is expanded.")]
public:
property System.bool AllowExpandSinglePath {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


AllowKeyboardNavigation Property

[image]
Intersoft WebTreeView Documentation
AllowKeyboardNavigation Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : AllowKeyboardNavigation Property

Glossary Item Box

Indicates whether to allow keyboard navigation.Indicates whether to allow keyboard navigation or not.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Indicates whether to allow keyboard navigation.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Property AllowKeyboardNavigation As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Boolean

instance.AllowKeyboardNavigation = value

value = instance.AllowKeyboardNavigation
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Indicates whether to allow keyboard navigation.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public System.bool AllowKeyboardNavigation {get; set;}
Delphi
public read-write property AllowKeyboardNavigation: System.Boolean;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Indicates whether to allow keyboard navigation.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set AllowKeyboardNavigation : System.boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Indicates whether to allow keyboard navigation.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property System.bool get_AllowKeyboardNavigation();
public: __property void set_AllowKeyboardNavigation(
   System.bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Indicates whether to allow keyboard navigation.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
property System.bool AllowKeyboardNavigation {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


AllowMultipleSelect Property

[image]
Intersoft WebTreeView Documentation
AllowMultipleSelect Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : AllowMultipleSelect Property

Glossary Item Box

Specifies whether to allow multiple select on the tree nodes.Specifies whether to allow multiple select on TreeView nodes.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether to allow multiple select on the tree nodes.")>
Public Property AllowMultipleSelect As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Boolean

instance.AllowMultipleSelect = value

value = instance.AllowMultipleSelect
C#
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether to allow multiple select on the tree nodes.")]
public System.bool AllowMultipleSelect {get; set;}
Delphi
public read-write property AllowMultipleSelect: System.Boolean;
JScript
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether to allow multiple select on the tree nodes.")
public function get,set AllowMultipleSelect : System.boolean
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether to allow multiple select on the tree nodes.")]
public: __property System.bool get_AllowMultipleSelect();
public: __property void set_AllowMultipleSelect(
   System.bool value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether to allow multiple select on the tree nodes.")]
public:
property System.bool AllowMultipleSelect {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


AllowNodeEditing Property

[image]
Intersoft WebTreeView Documentation
AllowNodeEditing Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : AllowNodeEditing Property

Glossary Item Box

Indicates whether to allow node editing.Indicates whether to allow node editing.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Indicates whether to allow node editing.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property AllowNodeEditing As AllowEditing
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As AllowEditing

instance.AllowNodeEditing = value

value = instance.AllowNodeEditing
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Indicates whether to allow node editing.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.XmlSerializableAttribute()]
public AllowEditing AllowNodeEditing {get; set;}
Delphi
public read-write property AllowNodeEditing: AllowEditing;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Indicates whether to allow node editing.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set AllowNodeEditing : AllowEditing
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Indicates whether to allow node editing.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property AllowEditing get_AllowNodeEditing();
public: __property void set_AllowNodeEditing(
   AllowEditing value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Indicates whether to allow node editing.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property AllowEditing AllowNodeEditing {
   AllowEditing get();
   void set (    AllowEditing value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


AutoCheckChildNodes Property

[image]
Intersoft WebTreeView Documentation
AutoCheckChildNodes Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : AutoCheckChildNodes Property

Glossary Item Box

Indicates whether to automatically check child nodes.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Indicates whether to automatic check child nodes.")>
Public Property AutoCheckChildNodes As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Boolean

instance.AutoCheckChildNodes = value

value = instance.AutoCheckChildNodes
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Indicates whether to automatic check child nodes.")]
public System.bool AutoCheckChildNodes {get; set;}
Delphi
public read-write property AutoCheckChildNodes: System.Boolean;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Indicates whether to automatic check child nodes.")
public function get,set AutoCheckChildNodes : System.boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Indicates whether to automatic check child nodes.")]
public: __property System.bool get_AutoCheckChildNodes();
public: __property void set_AutoCheckChildNodes(
   System.bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Indicates whether to automatic check child nodes.")]
public:
property System.bool AutoCheckChildNodes {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


AutoGenerateDataBindings Property

[image]
Intersoft WebTreeView Documentation
AutoGenerateDataBindings Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : AutoGenerateDataBindings Property

Glossary Item Box

Gets or sets the auto generate data bindings.Specifies whether WebTreeView retrieves data from a datasource and bind it automatically.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the auto generate data bindings.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Data")>
<System.ComponentModel.BrowsableAttribute(False)>
Public Property AutoGenerateDataBindings As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Boolean

instance.AutoGenerateDataBindings = value

value = instance.AutoGenerateDataBindings
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the auto generate data bindings.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.BrowsableAttribute(false)]
public System.bool AutoGenerateDataBindings {get; set;}
Delphi
public read-write property AutoGenerateDataBindings: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the auto generate data bindings.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Data")
System.ComponentModel.BrowsableAttribute()
public function get,set AutoGenerateDataBindings : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the auto generate data bindings.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.BrowsableAttribute(false)]
public: __property System.bool get_AutoGenerateDataBindings();
public: __property void set_AutoGenerateDataBindings(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the auto generate data bindings.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.BrowsableAttribute(false)]
public:
property System.bool AutoGenerateDataBindings {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


AutoPostBackSettings Property

[image]
Intersoft WebTreeView Documentation
AutoPostBackSettings Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : AutoPostBackSettings Property

Glossary Item Box

Contains auto postback settings such as OnNodeMove, OnNodeExpand, OnNodeCollapse, etc.Contains auto postback settings such as OnNodeMove, OnNodeExpand, OnNodeCollapse, etc.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Contains auto postback settings such as OnNodeMove, OnNodeExpand, OnNodeCollapse, etc.")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
Public Property AutoPostBackSettings As WebTreeViewAutoPostBackSettings
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As WebTreeViewAutoPostBackSettings

instance.AutoPostBackSettings = value

value = instance.AutoPostBackSettings
C#
[System.ComponentModel.DescriptionAttribute("Contains auto postback settings such as OnNodeMove, OnNodeExpand, OnNodeCollapse, etc.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public WebTreeViewAutoPostBackSettings AutoPostBackSettings {get; set;}
Delphi
public read-write property AutoPostBackSettings: WebTreeViewAutoPostBackSettings;
JScript
System.ComponentModel.DescriptionAttribute("Contains auto postback settings such as OnNodeMove, OnNodeExpand, OnNodeCollapse, etc.")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
public function get,set AutoPostBackSettings : WebTreeViewAutoPostBackSettings
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Contains auto postback settings such as OnNodeMove, OnNodeExpand, OnNodeCollapse, etc.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public: __property WebTreeViewAutoPostBackSettings* get_AutoPostBackSettings();
public: __property void set_AutoPostBackSettings(
   WebTreeViewAutoPostBackSettings* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Contains auto postback settings such as OnNodeMove, OnNodeExpand, OnNodeCollapse, etc.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public:
property WebTreeViewAutoPostBackSettings^ AutoPostBackSettings {
   WebTreeViewAutoPostBackSettings^ get();
   void set (    WebTreeViewAutoPostBackSettings^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


AutoSelectOnNodeExpandCollapse Property

[image]
Intersoft WebTreeView Documentation
AutoSelectOnNodeExpandCollapse Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : AutoSelectOnNodeExpandCollapse Property

Glossary Item Box

Indicates whether to automatically select node when a node is expanded/collapsed.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Indicates whether to automatic select node when node is expanded/collapsed.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Property AutoSelectOnNodeExpandCollapse As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Boolean

instance.AutoSelectOnNodeExpandCollapse = value

value = instance.AutoSelectOnNodeExpandCollapse
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Indicates whether to automatic select node when node is expanded/collapsed.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public System.bool AutoSelectOnNodeExpandCollapse {get; set;}
Delphi
public read-write property AutoSelectOnNodeExpandCollapse: System.Boolean;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Indicates whether to automatic select node when node is expanded/collapsed.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set AutoSelectOnNodeExpandCollapse : System.boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Indicates whether to automatic select node when node is expanded/collapsed.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property System.bool get_AutoSelectOnNodeExpandCollapse();
public: __property void set_AutoSelectOnNodeExpandCollapse(
   System.bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Indicates whether to automatic select node when node is expanded/collapsed.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
property System.bool AutoSelectOnNodeExpandCollapse {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


CheckBoxType Property

[image]
Intersoft WebTreeView Documentation
CheckBoxType Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : CheckBoxType Property

Glossary Item Box

Gets or sets the type of node checkbox, whether to use image or standard checkbox.Gets or sets the type of node's checkbox, whether to use image or standard checkbox.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the type of node checkbox, whether to use image or standard checkbox.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property CheckBoxType As CheckBoxType
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As CheckBoxType

instance.CheckBoxType = value

value = instance.CheckBoxType
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the type of node checkbox, whether to use image or standard checkbox.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public CheckBoxType CheckBoxType {get; set;}
Delphi
public read-write property CheckBoxType: CheckBoxType;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.DescriptionAttribute("Gets or sets the type of node checkbox, whether to use image or standard checkbox.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set CheckBoxType : CheckBoxType
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the type of node checkbox, whether to use image or standard checkbox.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property CheckBoxType get_CheckBoxType();
public: __property void set_CheckBoxType(
   CheckBoxType value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the type of node checkbox, whether to use image or standard checkbox.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property CheckBoxType CheckBoxType {
   CheckBoxType get();
   void set (    CheckBoxType value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


CheckedNodes Property

[image]
Intersoft WebTreeView Documentation
CheckedNodes Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : CheckedNodes Property

Glossary Item Box

The collection of checkable nodes which are currently checked.Determines the collection of checked nodes.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DescriptionAttribute("The collection of checkable nodes which are currently checked.")>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public ReadOnly Property CheckedNodes As System.Collections.ArrayList
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Collections.ArrayList

value = instance.CheckedNodes
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DescriptionAttribute("The collection of checkable nodes which are currently checked.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
public System.Collections.ArrayList CheckedNodes {get;}
Delphi
public read-only property CheckedNodes: System.Collections.ArrayList;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DescriptionAttribute("The collection of checkable nodes which are currently checked.")
System.ComponentModel.CategoryAttribute("Behavior")
public function get CheckedNodes : System.Collections.ArrayList
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DescriptionAttribute("The collection of checkable nodes which are currently checked.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property System.Collections.ArrayList* get_CheckedNodes();
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DescriptionAttribute("The collection of checkable nodes which are currently checked.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
property System.Collections.ArrayList^ CheckedNodes {
   System.Collections.ArrayList^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


ClientAction Property

[image]
Intersoft WebTreeView Documentation
ClientAction Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : ClientAction Property

Glossary Item Box

Returns ClientSideAction class Returns ClientSideAction class.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Returns ClientSideAction class.")>
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public ReadOnly Property ClientAction As ISNet.WebUI.BaseClientSideAction
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As ISNet.WebUI.BaseClientSideAction

value = instance.ClientAction
C#
[System.ComponentModel.DescriptionAttribute("Returns ClientSideAction class.")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public ISNet.WebUI.BaseClientSideAction ClientAction {get;}
Delphi
public read-only property ClientAction: ISNet.WebUI.BaseClientSideAction;
JScript
System.ComponentModel.DescriptionAttribute("Returns ClientSideAction class.")
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get ClientAction : ISNet.WebUI.BaseClientSideAction
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Returns ClientSideAction class.")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property ISNet.WebUI.BaseClientSideAction* get_ClientAction();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Returns ClientSideAction class.")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property ISNet.WebUI.BaseClientSideAction^ ClientAction {
   ISNet.WebUI.BaseClientSideAction^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


ClientSideEvents Property

[image]
Intersoft WebTreeView Documentation
ClientSideEvents Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : ClientSideEvents Property

Glossary Item Box

Contains Javascript ClientSide events.Contains WebTreeView's JavaScript client-side event.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DescriptionAttribute("Contains Javascript ClientSide events.")>
Public Property ClientSideEvents As WebTreeViewClientSideEvents
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As WebTreeViewClientSideEvents

instance.ClientSideEvents = value

value = instance.ClientSideEvents
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Contains Javascript ClientSide events.")]
public WebTreeViewClientSideEvents ClientSideEvents {get; set;}
Delphi
public read-write property ClientSideEvents: WebTreeViewClientSideEvents;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DescriptionAttribute("Contains Javascript ClientSide events.")
public function get,set ClientSideEvents : WebTreeViewClientSideEvents
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Contains Javascript ClientSide events.")]
public: __property WebTreeViewClientSideEvents* get_ClientSideEvents();
public: __property void set_ClientSideEvents(
   WebTreeViewClientSideEvents* value
);
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Contains Javascript ClientSide events.")]
public:
property WebTreeViewClientSideEvents^ ClientSideEvents {
   WebTreeViewClientSideEvents^ get();
   void set (    WebTreeViewClientSideEvents^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


DataBindings Property

[image]
Intersoft WebTreeView Documentation
DataBindings Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : DataBindings Property

Glossary Item Box

A collection of properties available for data bound node.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Data")>
<System.ComponentModel.DefaultValueAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebTreeView.WebTreeViewBindingsEditor, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")>
<System.ComponentModel.MergablePropertyAttribute(False)>
Public ReadOnly Property DataBindings As WebTreeViewNodeBindingCollection
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As WebTreeViewNodeBindingCollection

value = instance.DataBindings
C#
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebTreeView.WebTreeViewBindingsEditor, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
[System.ComponentModel.MergablePropertyAttribute(false)]
public WebTreeViewNodeBindingCollection DataBindings {get;}
Delphi
public read-only property DataBindings: WebTreeViewNodeBindingCollection;
JScript
System.ComponentModel.CategoryAttribute("Data")
System.ComponentModel.DefaultValueAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebTreeView.WebTreeViewBindingsEditor, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")
System.ComponentModel.MergablePropertyAttribute()
public function get DataBindings : WebTreeViewNodeBindingCollection
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebTreeView.WebTreeViewBindingsEditor, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
[System.ComponentModel.MergablePropertyAttribute(false)]
public: __property WebTreeViewNodeBindingCollection* get_DataBindings();
C++/CLI
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebTreeView.WebTreeViewBindingsEditor, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
[System.ComponentModel.MergablePropertyAttribute(false)]
public:
property WebTreeViewNodeBindingCollection^ DataBindings {
   WebTreeViewNodeBindingCollection^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


DataMember Property

[image]
Intersoft WebTreeView Documentation
DataMember Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : DataMember Property

Glossary Item Box

Gets or sets the datamember of the treeview.Gets or sets the data member.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the datamember of the treeview.")>
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.CategoryAttribute("Data")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property DataMember As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.String

instance.DataMember = value

value = instance.DataMember
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the datamember of the treeview.")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string DataMember {get; set;}
Delphi
public read-write property DataMember: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the datamember of the treeview.")
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.CategoryAttribute("Data")
System.ComponentModel.DefaultValueAttribute()
public function get,set DataMember : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the datamember of the treeview.")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_DataMember();
public: __property void set_DataMember(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the datamember of the treeview.")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ DataMember {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


DataSource Property

[image]
Intersoft WebTreeView Documentation
DataSource Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : DataSource Property

Glossary Item Box

Gets or sets the datasource of the treeview.Specifies the type of WebTreeView's datasource.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.CategoryAttribute("Data")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the datasource of the treeview.")>
Public Property DataSource As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Object

instance.DataSource = value

value = instance.DataSource
C#
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the datasource of the treeview.")]
public System.object DataSource {get; set;}
Delphi
public read-write property DataSource: System.TObject;
JScript
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.CategoryAttribute("Data")
System.ComponentModel.DescriptionAttribute("Gets or sets the datasource of the treeview.")
public function get,set DataSource : System.Object
Managed Extensions for C++
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the datasource of the treeview.")]
public: __property System.Object* get_DataSource();
public: __property void set_DataSource(
   System.Object* value
);
C++/CLI
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the datasource of the treeview.")]
public:
property System.Object^ DataSource {
   System.Object^ get();
   void set (    System.Object^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


DataSourceID Property

[image]
Intersoft WebTreeView Documentation
DataSourceID Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : DataSourceID Property

Glossary Item Box

Gets or sets the ID of the control from which the treeview control retrieves its list.Gets or sets the ID of the control which TreeView control retrieves its list.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the ID of the control from which the treeview control retrieves its list.")>
<System.Web.UI.IDReferencePropertyAttribute(System.Web.UI.HierarchicalDataSourceControl)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Data")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property DataSourceID As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.String

instance.DataSourceID = value

value = instance.DataSourceID
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the ID of the control from which the treeview control retrieves its list.")]
[System.Web.UI.IDReferencePropertyAttribute(System.Web.UI.HierarchicalDataSourceControl)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string DataSourceID {get; set;}
Delphi
public read-write property DataSourceID: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the ID of the control from which the treeview control retrieves its list.")
System.Web.UI.IDReferencePropertyAttribute(System.Web.UI.HierarchicalDataSourceControl)
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Data")
System.ComponentModel.DefaultValueAttribute()
public function get,set DataSourceID : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the ID of the control from which the treeview control retrieves its list.")]
[System.Web.UI.IDReferencePropertyAttribute(System.Web.UI.HierarchicalDataSourceControl)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_DataSourceID();
public: __property void set_DataSourceID(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the ID of the control from which the treeview control retrieves its list.")]
[System.Web.UI.IDReferencePropertyAttribute(System.Web.UI.HierarchicalDataSourceControl)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ DataSourceID {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


DefaultImageHeight Property

[image]
Intersoft WebTreeView Documentation
DefaultImageHeight Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : DefaultImageHeight Property

Glossary Item Box

Gets or sets the default height(in pixels) to use for icon images.Gets or sets the default image height (in pixel) which will be used as an icon images.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the default height(in pixels) to use for icon images.")>
<System.ComponentModel.CategoryAttribute("Appearance")>
Public Property DefaultImageHeight As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Integer

instance.DefaultImageHeight = value

value = instance.DefaultImageHeight
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default height(in pixels) to use for icon images.")]
[System.ComponentModel.CategoryAttribute("Appearance")]
public System.int DefaultImageHeight {get; set;}
Delphi
public read-write property DefaultImageHeight: System.Integer;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the default height(in pixels) to use for icon images.")
System.ComponentModel.CategoryAttribute("Appearance")
public function get,set DefaultImageHeight : System.int
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default height(in pixels) to use for icon images.")]
[System.ComponentModel.CategoryAttribute("Appearance")]
public: __property System.int get_DefaultImageHeight();
public: __property void set_DefaultImageHeight(
   System.int value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default height(in pixels) to use for icon images.")]
[System.ComponentModel.CategoryAttribute("Appearance")]
public:
property System.int DefaultImageHeight {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


DefaultImagesFolder Property

[image]
Intersoft WebTreeView Documentation
DefaultImagesFolder Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : DefaultImagesFolder Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property DefaultImagesFolder As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.String

value = instance.DefaultImagesFolder
C#
protected override System.string DefaultImagesFolder {get;}
Delphi
protected read-only property DefaultImagesFolder: System.String; override;
JScript
protected override function get DefaultImagesFolder : System.String
Managed Extensions for C++
protected: __property System.string* get_DefaultImagesFolder() override;
C++/CLI
protected:
property System.String^ DefaultImagesFolder {
   System.String^ get() override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


DefaultImageWidth Property

[image]
Intersoft WebTreeView Documentation
DefaultImageWidth Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : DefaultImageWidth Property

Glossary Item Box

Gets or sets the default width(in pixels) to use for icon images.Gets or sets the default image width (in pixel) which will be used as an icon images.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Appearance")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the default width(in pixels) to use for icon images.")>
Public Property DefaultImageWidth As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Integer

instance.DefaultImageWidth = value

value = instance.DefaultImageWidth
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default width(in pixels) to use for icon images.")]
public System.int DefaultImageWidth {get; set;}
Delphi
public read-write property DefaultImageWidth: System.Integer;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Appearance")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the default width(in pixels) to use for icon images.")
public function get,set DefaultImageWidth : System.int
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default width(in pixels) to use for icon images.")]
public: __property System.int get_DefaultImageWidth();
public: __property void set_DefaultImageWidth(
   System.int value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default width(in pixels) to use for icon images.")]
public:
property System.int DefaultImageWidth {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


DefaultPathSeparator Property

[image]
Intersoft WebTreeView Documentation
DefaultPathSeparator Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : DefaultPathSeparator Property

Glossary Item Box

Gets or sets the default path separator symbol.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
Public ReadOnly Property DefaultPathSeparator As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.String

value = instance.DefaultPathSeparator
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public System.string DefaultPathSeparator {get;}
Delphi
public read-only property DefaultPathSeparator: System.String;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
public function get DefaultPathSeparator : System.String
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public: __property System.string* get_DefaultPathSeparator();
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public:
property System.String^ DefaultPathSeparator {
   System.String^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


DragDropSettings Property

[image]
Intersoft WebTreeView Documentation
DragDropSettings Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : DragDropSettings Property

Glossary Item Box

Contains drag and drop settings such as AllowRootDrop, AllowChildDrop, and AllowSiblingDrop.Contains drag and drop settings such as AllowRootDrop, AllowChildDrop, and AllowSiblingDrop.

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DescriptionAttribute("Contains drag and drop settings such as AllowRootDrop, AllowChildDrop, and AllowSiblingDrop.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Property DragDropSettings As WebTreeViewDragDropSettings
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As WebTreeViewDragDropSettings

instance.DragDropSettings = value

value = instance.DragDropSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DescriptionAttribute("Contains drag and drop settings such as AllowRootDrop, AllowChildDrop, and AllowSiblingDrop.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public WebTreeViewDragDropSettings DragDropSettings {get; set;}
Delphi
public read-write property DragDropSettings: WebTreeViewDragDropSettings;
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DescriptionAttribute("Contains drag and drop settings such as AllowRootDrop, AllowChildDrop, and AllowSiblingDrop.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set DragDropSettings : WebTreeViewDragDropSettings
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DescriptionAttribute("Contains drag and drop settings such as AllowRootDrop, AllowChildDrop, and AllowSiblingDrop.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property WebTreeViewDragDropSettings* get_DragDropSettings();
public: __property void set_DragDropSettings(
   WebTreeViewDragDropSettings* value
);
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DescriptionAttribute("Contains drag and drop settings such as AllowRootDrop, AllowChildDrop, and AllowSiblingDrop.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
property WebTreeViewDragDropSettings^ DragDropSettings {
   WebTreeViewDragDropSettings^ get();
   void set (    WebTreeViewDragDropSettings^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


EnableLoadOnDemand Property

[image]
Intersoft WebTreeView Documentation
EnableLoadOnDemand Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : EnableLoadOnDemand Property

Glossary Item Box

Indicates whether to enable load on demand.Indicates whether to allow LoadOnDemand or not.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.DescriptionAttribute("Indicates whether to enable load on demand.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property EnableLoadOnDemand As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Boolean

instance.EnableLoadOnDemand = value

value = instance.EnableLoadOnDemand
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute("Indicates whether to enable load on demand.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.bool EnableLoadOnDemand {get; set;}
Delphi
public read-write property EnableLoadOnDemand: System.Boolean;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.DescriptionAttribute("Indicates whether to enable load on demand.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set EnableLoadOnDemand : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute("Indicates whether to enable load on demand.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.bool get_EnableLoadOnDemand();
public: __property void set_EnableLoadOnDemand(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute("Indicates whether to enable load on demand.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.bool EnableLoadOnDemand {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


EnableTriStateCheckBox Property

[image]
Intersoft WebTreeView Documentation
EnableTriStateCheckBox Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : EnableTriStateCheckBox Property

Glossary Item Box

Specifies whether to enable tristate checkbox.Specifies whether to allow TriState checkbox or not.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether to enable tristate checkbox.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property EnableTriStateCheckBox As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Boolean

instance.EnableTriStateCheckBox = value

value = instance.EnableTriStateCheckBox
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether to enable tristate checkbox.")]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool EnableTriStateCheckBox {get; set;}
Delphi
public read-write property EnableTriStateCheckBox: System.Boolean;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether to enable tristate checkbox.")
System.ComponentModel.DefaultValueAttribute()
public function get,set EnableTriStateCheckBox : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether to enable tristate checkbox.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_EnableTriStateCheckBox();
public: __property void set_EnableTriStateCheckBox(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether to enable tristate checkbox.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool EnableTriStateCheckBox {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


EnableTriStateCheckBoxParentInIndeterminateState Property

[image]
Intersoft WebTreeView Documentation
EnableTriStateCheckBoxParentInIndeterminateState Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : EnableTriStateCheckBoxParentInIndeterminateState Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether to enable tristate checkbox parent in indeterminate state.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Property EnableTriStateCheckBoxParentInIndeterminateState As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Boolean

instance.EnableTriStateCheckBoxParentInIndeterminateState = value

value = instance.EnableTriStateCheckBoxParentInIndeterminateState
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether to enable tristate checkbox parent in indeterminate state.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public System.bool EnableTriStateCheckBoxParentInIndeterminateState {get; set;}
Delphi
public read-write property EnableTriStateCheckBoxParentInIndeterminateState: System.Boolean;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether to enable tristate checkbox parent in indeterminate state.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set EnableTriStateCheckBoxParentInIndeterminateState : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether to enable tristate checkbox parent in indeterminate state.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property System.bool get_EnableTriStateCheckBoxParentInIndeterminateState();
public: __property void set_EnableTriStateCheckBoxParentInIndeterminateState(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether to enable tristate checkbox parent in indeterminate state.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
property System.bool EnableTriStateCheckBoxParentInIndeterminateState {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


ExpandCollapseImageHeight Property

[image]
Intersoft WebTreeView Documentation
ExpandCollapseImageHeight Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : ExpandCollapseImageHeight Property

Glossary Item Box

Gets or sets the default height(in pixels) to use for expand/collapse images.Gets or sets the default image height (in pixel) which will be used as an expand/collapse image.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the default height(in pixels) to use for expand/collapse images.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property ExpandCollapseImageHeight As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Integer

instance.ExpandCollapseImageHeight = value

value = instance.ExpandCollapseImageHeight
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default height(in pixels) to use for expand/collapse images.")]
[System.ComponentModel.DefaultValueAttribute()]
public System.int ExpandCollapseImageHeight {get; set;}
Delphi
public read-write property ExpandCollapseImageHeight: System.Integer;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.DescriptionAttribute("Gets or sets the default height(in pixels) to use for expand/collapse images.")
System.ComponentModel.DefaultValueAttribute()
public function get,set ExpandCollapseImageHeight : System.int
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default height(in pixels) to use for expand/collapse images.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.int get_ExpandCollapseImageHeight();
public: __property void set_ExpandCollapseImageHeight(
   System.int value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default height(in pixels) to use for expand/collapse images.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.int ExpandCollapseImageHeight {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


ExpandCollapseImageWidth Property

[image]
Intersoft WebTreeView Documentation
ExpandCollapseImageWidth Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : ExpandCollapseImageWidth Property

Glossary Item Box

Gets or sets the default width(in pixels) to use for expand/collapse images.Gets or sets the default image width (in pixel) which will be used as an expand/collapse image.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the default width(in pixels) to use for expand/collapse images.")>
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property ExpandCollapseImageWidth As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Integer

instance.ExpandCollapseImageWidth = value

value = instance.ExpandCollapseImageWidth
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the default width(in pixels) to use for expand/collapse images.")]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.int ExpandCollapseImageWidth {get; set;}
Delphi
public read-write property ExpandCollapseImageWidth: System.Integer;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the default width(in pixels) to use for expand/collapse images.")
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set ExpandCollapseImageWidth : System.int
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the default width(in pixels) to use for expand/collapse images.")]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.int get_ExpandCollapseImageWidth();
public: __property void set_ExpandCollapseImageWidth(
   System.int value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the default width(in pixels) to use for expand/collapse images.")]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.int ExpandCollapseImageWidth {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


ExpandedDepth Property

[image]
Intersoft WebTreeView Documentation
ExpandedDepth Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : ExpandedDepth Property

Glossary Item Box

Gets or sets the expanded depth.Determines whether all specified nodes (based on their depth) are expanded (initially and on postback) or not

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the expanded depth.")>
Public Property ExpandedDepth As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Integer

instance.ExpandedDepth = value

value = instance.ExpandedDepth
C#
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the expanded depth.")]
public System.int ExpandedDepth {get; set;}
Delphi
public read-write property ExpandedDepth: System.Integer;
JScript
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the expanded depth.")
public function get,set ExpandedDepth : System.int
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the expanded depth.")]
public: __property System.int get_ExpandedDepth();
public: __property void set_ExpandedDepth(
   System.int value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the expanded depth.")]
public:
property System.int ExpandedDepth {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


FlyPostBackSettings Property

[image]
Intersoft WebTreeView Documentation
FlyPostBackSettings Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : FlyPostBackSettings Property

Glossary Item Box

Configures the settings used by the control when performing OnTheFly postback. Configures the settings used by the control when performing OnTheFly postback.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Configures the settings used by the control when performing OnTheFly postback.")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute("SetFlyPostBackSettings")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public ReadOnly Property FlyPostBackSettings As ISNet.WebUI.FlyPostBackSettings
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As ISNet.WebUI.FlyPostBackSettings

value = instance.FlyPostBackSettings
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Configures the settings used by the control when performing OnTheFly postback.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("SetFlyPostBackSettings")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public ISNet.WebUI.FlyPostBackSettings FlyPostBackSettings {get;}
Delphi
public read-only property FlyPostBackSettings: ISNet.WebUI.FlyPostBackSettings;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Configures the settings used by the control when performing OnTheFly postback.")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute("SetFlyPostBackSettings")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.CategoryAttribute("Behavior")
public function get FlyPostBackSettings : ISNet.WebUI.FlyPostBackSettings
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Configures the settings used by the control when performing OnTheFly postback.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("SetFlyPostBackSettings")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property ISNet.WebUI.FlyPostBackSettings* get_FlyPostBackSettings();
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Configures the settings used by the control when performing OnTheFly postback.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("SetFlyPostBackSettings")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
property ISNet.WebUI.FlyPostBackSettings^ FlyPostBackSettings {
   ISNet.WebUI.FlyPostBackSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


Font Property

[image]
Intersoft WebTreeView Documentation
Font Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : Font Property

Glossary Item Box

Gets or sets the font of node's text.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Overrides ReadOnly Property Font As System.Web.UI.WebControls.FontInfo
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Web.UI.WebControls.FontInfo

value = instance.Font
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public override System.Web.UI.WebControls.FontInfo Font {get;}
Delphi
public read-only property Font: System.Web.UI.WebControls.FontInfo; override;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.NotifyParentPropertyAttribute()
public override function get Font : System.Web.UI.WebControls.FontInfo
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.Web.UI.WebControls.FontInfo* get_Font() override;
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.Web.UI.WebControls.FontInfo^ Font {
   System.Web.UI.WebControls.FontInfo^ get() override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


FrameStyle Property

[image]
Intersoft WebTreeView Documentation
FrameStyle Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : FrameStyle Property

Glossary Item Box

The style applied to frame of the control.Style applied to the frame of the control.

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("The style applied to frame of the control.")>
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
Public Property FrameStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As ISNet.WebUI.WebStyle

instance.FrameStyle = value

value = instance.FrameStyle
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("The style applied to frame of the control.")]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public ISNet.WebUI.WebStyle FrameStyle {get; set;}
Delphi
public read-write property FrameStyle: ISNet.WebUI.WebStyle;
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("The style applied to frame of the control.")
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
public function get,set FrameStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("The style applied to frame of the control.")]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public: __property ISNet.WebUI.WebStyle* get_FrameStyle();
public: __property void set_FrameStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("The style applied to frame of the control.")]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public:
property ISNet.WebUI.WebStyle^ FrameStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


ImagesDirectory Property

[image]
Intersoft WebTreeView Documentation
ImagesDirectory Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : ImagesDirectory Property

Glossary Item Box

Gets or sets the location of images used to render the control.Gets or sets the location of the images used for rendering the control.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the location of images used to render the control.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property ImagesDirectory As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.String

instance.ImagesDirectory = value

value = instance.ImagesDirectory
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the location of images used to render the control.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string ImagesDirectory {get; set;}
Delphi
public read-write property ImagesDirectory: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the location of images used to render the control.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.DefaultValueAttribute()
public function get,set ImagesDirectory : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the location of images used to render the control.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_ImagesDirectory();
public: __property void set_ImagesDirectory(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the location of images used to render the control.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ ImagesDirectory {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


ImagesSettings Property

[image]
Intersoft WebTreeView Documentation
ImagesSettings Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : ImagesSettings Property

Glossary Item Box

Contains images settings for WebTreeView.Contains image settings for WebTreeView.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Contains images settings for WebTreeView.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public Property ImagesSettings As WebTreeViewImagesSettings
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As WebTreeViewImagesSettings

instance.ImagesSettings = value

value = instance.ImagesSettings
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains images settings for WebTreeView.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public WebTreeViewImagesSettings ImagesSettings {get; set;}
Delphi
public read-write property ImagesSettings: WebTreeViewImagesSettings;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Contains images settings for WebTreeView.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
public function get,set ImagesSettings : WebTreeViewImagesSettings
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains images settings for WebTreeView.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public: __property WebTreeViewImagesSettings* get_ImagesSettings();
public: __property void set_ImagesSettings(
   WebTreeViewImagesSettings* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains images settings for WebTreeView.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public:
property WebTreeViewImagesSettings^ ImagesSettings {
   WebTreeViewImagesSettings^ get();
   void set (    WebTreeViewImagesSettings^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


IsDataBindingPerformed Property

[image]
Intersoft WebTreeView Documentation
IsDataBindingPerformed Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : IsDataBindingPerformed Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
Public Property IsDataBindingPerformed As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Boolean

instance.IsDataBindingPerformed = value

value = instance.IsDataBindingPerformed
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public System.bool IsDataBindingPerformed {get; set;}
Delphi
public read-write property IsDataBindingPerformed: System.Boolean;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
public function get,set IsDataBindingPerformed : System.boolean
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public: __property System.bool get_IsDataBindingPerformed();
public: __property void set_IsDataBindingPerformed(
   System.bool value
);
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public:
property System.bool IsDataBindingPerformed {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


IsFlyPostBack Property

[image]
Intersoft WebTreeView Documentation
IsFlyPostBack Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : IsFlyPostBack Property

Glossary Item Box

Returns whether this instance invokes OnTheFly postback. Returns whether the specified WebTreeView instance invokes OnTheFly postback.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Returns whether this instance invokes OnTheFly postback.")>
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property IsFlyPostBack As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Boolean

instance.IsFlyPostBack = value

value = instance.IsFlyPostBack
C#
[System.ComponentModel.DescriptionAttribute("Returns whether this instance invokes OnTheFly postback.")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public System.bool IsFlyPostBack {get; set;}
Delphi
public read-write property IsFlyPostBack: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Returns whether this instance invokes OnTheFly postback.")
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get,set IsFlyPostBack : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Returns whether this instance invokes OnTheFly postback.")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property System.bool get_IsFlyPostBack();
public: __property void set_IsFlyPostBack(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Returns whether this instance invokes OnTheFly postback.")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property System.bool IsFlyPostBack {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


LicenseType Property

[image]
Intersoft WebTreeView Documentation
LicenseType Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : LicenseType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overrides Property LicenseType As ISNet.WebUI.LicType
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As ISNet.WebUI.LicType

instance.LicenseType = value

value = instance.LicenseType
C#
protected override ISNet.WebUI.LicType LicenseType {get; set;}
Delphi
protected read-write property LicenseType: ISNet.WebUI.LicType; override;
JScript
protected override function get,set LicenseType : ISNet.WebUI.LicType
Managed Extensions for C++
protected: __property ISNet.WebUI.LicType get_LicenseType() override;
protected: __property void set_LicenseType(
   ISNet.WebUI.LicType value
) override;
C++/CLI
protected:
property ISNet.WebUI.LicType LicenseType {
   ISNet.WebUI.LicType get() override;
   void set (    ISNet.WebUI.LicType value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


LineImageHeight Property

[image]
Intersoft WebTreeView Documentation
LineImageHeight Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : LineImageHeight Property

Glossary Item Box

Gets or sets the height(in pixels) to apply on line images.Gets or sets the height (in pixel) of the line images.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the height(in pixels) to apply on line images.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Appearance")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property LineImageHeight As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Integer

instance.LineImageHeight = value

value = instance.LineImageHeight
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the height(in pixels) to apply on line images.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.int LineImageHeight {get; set;}
Delphi
public read-write property LineImageHeight: System.Integer;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the height(in pixels) to apply on line images.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Appearance")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set LineImageHeight : System.int
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the height(in pixels) to apply on line images.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.int get_LineImageHeight();
public: __property void set_LineImageHeight(
   System.int value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the height(in pixels) to apply on line images.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.int LineImageHeight {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


LineImageWidth Property

[image]
Intersoft WebTreeView Documentation
LineImageWidth Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : LineImageWidth Property

Glossary Item Box

Gets or sets the width(in pixels) to apply on line images.Gets or sets the width (in pixel) of the line images.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the width(in pixels) to apply on line images.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property LineImageWidth As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Integer

instance.LineImageWidth = value

value = instance.LineImageWidth
C#
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the width(in pixels) to apply on line images.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.int LineImageWidth {get; set;}
Delphi
public read-write property LineImageWidth: System.Integer;
JScript
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the width(in pixels) to apply on line images.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set LineImageWidth : System.int
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the width(in pixels) to apply on line images.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.int get_LineImageWidth();
public: __property void set_LineImageWidth(
   System.int value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the width(in pixels) to apply on line images.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.int LineImageWidth {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


LoadingStyle Property

[image]
Intersoft WebTreeView Documentation
LoadingStyle Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : LoadingStyle Property

Glossary Item Box

Gets or sets the style of the loading.Gets or sets the style used when loading LoadOnDemand content.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the style of the loading.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
Public Property LoadingStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As ISNet.WebUI.WebStyle

instance.LoadingStyle = value

value = instance.LoadingStyle
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the style of the loading.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
public ISNet.WebUI.WebStyle LoadingStyle {get; set;}
Delphi
public read-write property LoadingStyle: ISNet.WebUI.WebStyle;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the style of the loading.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.ComponentModel.CategoryAttribute("Appearance")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
public function get,set LoadingStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the style of the loading.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
public: __property ISNet.WebUI.WebStyle* get_LoadingStyle();
public: __property void set_LoadingStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the style of the loading.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
public:
property ISNet.WebUI.WebStyle^ LoadingStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


LoadingText Property

[image]
Intersoft WebTreeView Documentation
LoadingText Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : LoadingText Property

Glossary Item Box

Gets or sets the text to use while loading load-on-demand content.Gets or sets the text used when loading LoadOnDemand content.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the text to use while loading load-on-demand content.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property LoadingText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.String

instance.LoadingText = value

value = instance.LoadingText
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the text to use while loading load-on-demand content.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string LoadingText {get; set;}
Delphi
public read-write property LoadingText: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the text to use while loading load-on-demand content.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set LoadingText : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the text to use while loading load-on-demand content.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_LoadingText();
public: __property void set_LoadingText(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the text to use while loading load-on-demand content.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ LoadingText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


MaxDataBindDepth Property

[image]
Intersoft WebTreeView Documentation
MaxDataBindDepth Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : MaxDataBindDepth Property

Glossary Item Box

Gets or sets the depth to which the TreeView will databind.Gets or sets the depth to which TreeView will be bound.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the depth to which the TreeView will databind.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Property MaxDataBindDepth As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Integer

instance.MaxDataBindDepth = value

value = instance.MaxDataBindDepth
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the depth to which the TreeView will databind.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public System.int MaxDataBindDepth {get; set;}
Delphi
public read-write property MaxDataBindDepth: System.Integer;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the depth to which the TreeView will databind.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set MaxDataBindDepth : System.int
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the depth to which the TreeView will databind.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property System.int get_MaxDataBindDepth();
public: __property void set_MaxDataBindDepth(
   System.int value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the depth to which the TreeView will databind.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
property System.int MaxDataBindDepth {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


NodeIndent Property

[image]
Intersoft WebTreeView Documentation
NodeIndent Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : NodeIndent Property

Glossary Item Box

Gets or sets the width(in pixels) to indent each level of the node.Gets or sets the width (in pixel) of indentation on each level of the node.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the width(in pixels) to indent each level of the node.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property NodeIndent As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Integer

instance.NodeIndent = value

value = instance.NodeIndent
C#
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the width(in pixels) to indent each level of the node.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.int NodeIndent {get; set;}
Delphi
public read-write property NodeIndent: System.Integer;
JScript
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the width(in pixels) to indent each level of the node.")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set NodeIndent : System.int
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the width(in pixels) to indent each level of the node.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.int get_NodeIndent();
public: __property void set_NodeIndent(
   System.int value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the width(in pixels) to indent each level of the node.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.int NodeIndent {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


Nodes Property

[image]
Intersoft WebTreeView Documentation
Nodes Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : Nodes Property

Glossary Item Box

The collection of nodes for WebTreeView.Specifies a collection of WebTreeView's nodes.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("The collection of nodes for WebTreeView.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute("SetNodes")>
Public ReadOnly Property Nodes As WebTreeViewNodeCollection
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As WebTreeViewNodeCollection

value = instance.Nodes
C#
[System.ComponentModel.DescriptionAttribute("The collection of nodes for WebTreeView.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("SetNodes")]
public WebTreeViewNodeCollection Nodes {get;}
Delphi
public read-only property Nodes: WebTreeViewNodeCollection;
JScript
System.ComponentModel.DescriptionAttribute("The collection of nodes for WebTreeView.")
ISNet.Serialization.XmlSerializableAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute("SetNodes")
public function get Nodes : WebTreeViewNodeCollection
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("The collection of nodes for WebTreeView.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("SetNodes")]
public: __property WebTreeViewNodeCollection* get_Nodes();
C++/CLI
[System.ComponentModel.DescriptionAttribute("The collection of nodes for WebTreeView.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("SetNodes")]
public:
property WebTreeViewNodeCollection^ Nodes {
   WebTreeViewNodeCollection^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


NodeSettings Property

[image]
Intersoft WebTreeView Documentation
NodeSettings Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : NodeSettings Property

Glossary Item Box

Contains node settings such as TargetWindow, and EnableAnimation.Contains node settings such as TargetWindow and EnableAnimation.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Contains node settings such as TargetWindow, and EnableAnimation.")>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
Public Property NodeSettings As WebTreeViewNodeSettings
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As WebTreeViewNodeSettings

instance.NodeSettings = value

value = instance.NodeSettings
C#
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains node settings such as TargetWindow, and EnableAnimation.")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public WebTreeViewNodeSettings NodeSettings {get; set;}
Delphi
public read-write property NodeSettings: WebTreeViewNodeSettings;
JScript
System.ComponentModel.CategoryAttribute("Behavior")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Contains node settings such as TargetWindow, and EnableAnimation.")
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
public function get,set NodeSettings : WebTreeViewNodeSettings
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains node settings such as TargetWindow, and EnableAnimation.")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public: __property WebTreeViewNodeSettings* get_NodeSettings();
public: __property void set_NodeSettings(
   WebTreeViewNodeSettings* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains node settings such as TargetWindow, and EnableAnimation.")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public:
property WebTreeViewNodeSettings^ NodeSettings {
   WebTreeViewNodeSettings^ get();
   void set (    WebTreeViewNodeSettings^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


NodeStyle Property

[image]
Intersoft WebTreeView Documentation
NodeStyle Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : NodeStyle Property

Glossary Item Box

Gets or sets the style of the node.Gets or sets the style of a node.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the style of the node.")>
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
Public Property NodeStyle As ISNet.WebUI.DynamicStyle
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As ISNet.WebUI.DynamicStyle

instance.NodeStyle = value

value = instance.NodeStyle
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the style of the node.")]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
public ISNet.WebUI.DynamicStyle NodeStyle {get; set;}
Delphi
public read-write property NodeStyle: ISNet.WebUI.DynamicStyle;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the style of the node.")
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
public function get,set NodeStyle : ISNet.WebUI.DynamicStyle
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the style of the node.")]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
public: __property ISNet.WebUI.DynamicStyle* get_NodeStyle();
public: __property void set_NodeStyle(
   ISNet.WebUI.DynamicStyle* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the style of the node.")]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
public:
property ISNet.WebUI.DynamicStyle^ NodeStyle {
   ISNet.WebUI.DynamicStyle^ get();
   void set (    ISNet.WebUI.DynamicStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


PathSeparator Property

[image]
Intersoft WebTreeView Documentation
PathSeparator Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : PathSeparator Property

Glossary Item Box

Specifies the character used to separate parts of the path.Specifies the character used to separate parts of the path.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the character used to separate parts of the path.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property PathSeparator As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.String

instance.PathSeparator = value

value = instance.PathSeparator
C#
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the character used to separate parts of the path.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string PathSeparator {get; set;}
Delphi
public read-write property PathSeparator: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the character used to separate parts of the path.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set PathSeparator : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the character used to separate parts of the path.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_PathSeparator();
public: __property void set_PathSeparator(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the character used to separate parts of the path.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ PathSeparator {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


PersistInfoDuringLoadOnDemand Property

[image]
Intersoft WebTreeView Documentation
PersistInfoDuringLoadOnDemand Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : PersistInfoDuringLoadOnDemand Property

Glossary Item Box

Indicates whether to persist nodes info during load on demand.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Indicates whether to persist nodes info during load on demand.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Data")>
Public Property PersistInfoDuringLoadOnDemand As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Boolean

instance.PersistInfoDuringLoadOnDemand = value

value = instance.PersistInfoDuringLoadOnDemand
C#
[System.ComponentModel.DescriptionAttribute("Indicates whether to persist nodes info during load on demand.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Data")]
public System.bool PersistInfoDuringLoadOnDemand {get; set;}
Delphi
public read-write property PersistInfoDuringLoadOnDemand: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Indicates whether to persist nodes info during load on demand.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Data")
public function get,set PersistInfoDuringLoadOnDemand : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Indicates whether to persist nodes info during load on demand.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Data")]
public: __property System.bool get_PersistInfoDuringLoadOnDemand();
public: __property void set_PersistInfoDuringLoadOnDemand(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Indicates whether to persist nodes info during load on demand.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Data")]
public:
property System.bool PersistInfoDuringLoadOnDemand {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


PostBackModeType Property

[image]
Intersoft WebTreeView Documentation
PostBackModeType Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : PostBackModeType Property

Glossary Item Box

Gets or sets the type of postback mode, whether to use flypostback or fullpostback.Gets or sets the type of postback mode, whether to use flypostback or fullpostback.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the type of postback mode, whether to use flypostback or fullpostback.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property PostBackModeType As PostBackMode
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As PostBackMode

instance.PostBackModeType = value

value = instance.PostBackModeType
C#
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the type of postback mode, whether to use flypostback or fullpostback.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public PostBackMode PostBackModeType {get; set;}
Delphi
public read-write property PostBackModeType: PostBackMode;
JScript
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.DescriptionAttribute("Gets or sets the type of postback mode, whether to use flypostback or fullpostback.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set PostBackModeType : PostBackMode
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the type of postback mode, whether to use flypostback or fullpostback.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property PostBackMode get_PostBackModeType();
public: __property void set_PostBackModeType(
   PostBackMode value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the type of postback mode, whether to use flypostback or fullpostback.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property PostBackMode PostBackModeType {
   PostBackMode get();
   void set (    PostBackMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


Product Property

[image]
Intersoft WebTreeView Documentation
Product Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : Product Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property Product As ISNet.WebUI.ProductInfo
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As ISNet.WebUI.ProductInfo

value = instance.Product
C#
protected override ISNet.WebUI.ProductInfo Product {get;}
Delphi
protected read-only property Product: ISNet.WebUI.ProductInfo; override;
JScript
protected override function get Product : ISNet.WebUI.ProductInfo
Managed Extensions for C++
protected: __property ISNet.WebUI.ProductInfo* get_Product() override;
C++/CLI
protected:
property ISNet.WebUI.ProductInfo^ Product {
   ISNet.WebUI.ProductInfo^ get() override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


ProductIcon Property

[image]
Intersoft WebTreeView Documentation
ProductIcon Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : ProductIcon Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property ProductIcon As System.Drawing.Icon
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Drawing.Icon

value = instance.ProductIcon
C#
protected override System.Drawing.Icon ProductIcon {get;}
Delphi
protected read-only property ProductIcon: System.Drawing.Icon; override;
JScript
protected override function get ProductIcon : System.Drawing.Icon
Managed Extensions for C++
protected: __property System.Drawing.Icon* get_ProductIcon() override;
C++/CLI
protected:
property System.Drawing.Icon^ ProductIcon {
   System.Drawing.Icon^ get() override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


ProductImage Property

[image]
Intersoft WebTreeView Documentation
ProductImage Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : ProductImage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property ProductImage As System.Drawing.Image
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Drawing.Image

value = instance.ProductImage
C#
protected override System.Drawing.Image ProductImage {get;}
Delphi
protected read-only property ProductImage: System.Drawing.Image; override;
JScript
protected override function get ProductImage : System.Drawing.Image
Managed Extensions for C++
protected: __property System.Drawing.Image* get_ProductImage() override;
C++/CLI
protected:
property System.Drawing.Image^ ProductImage {
   System.Drawing.Image^ get() override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


ScriptDirectory Property

[image]
Intersoft WebTreeView Documentation
ScriptDirectory Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : ScriptDirectory Property

Glossary Item Box

Gets or sets the location of the required scripts used by WebTreeView.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Client Script Directory")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required scripts for the control are stored.")>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overrides Property ScriptDirectory As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.String

instance.ScriptDirectory = value

value = instance.ScriptDirectory
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required scripts for the control are stored.")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public override System.string ScriptDirectory {get; set;}
Delphi
public read-write property ScriptDirectory: System.String; override;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Client Script Directory")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required scripts for the control are stored.")
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public override function get,set ScriptDirectory : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required scripts for the control are stored.")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property System.string* get_ScriptDirectory() override;
public: __property void set_ScriptDirectory(
   System.string* value
) override;
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required scripts for the control are stored.")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
property System.String^ ScriptDirectory {
   System.String^ get() override;
   void set (    System.String^ value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


SelectedNode Property

[image]
Intersoft WebTreeView Documentation
SelectedNode Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : SelectedNode Property

Glossary Item Box

Specifies a selected node.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public ReadOnly Property SelectedNode As WebTreeViewNode
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As WebTreeViewNode

value = instance.SelectedNode
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public WebTreeViewNode SelectedNode {get;}
Delphi
public read-only property SelectedNode: WebTreeViewNode;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get SelectedNode : WebTreeViewNode
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property WebTreeViewNode* get_SelectedNode();
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property WebTreeViewNode^ SelectedNode {
   WebTreeViewNode^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


SelectedNodes Property

[image]
Intersoft WebTreeView Documentation
SelectedNodes Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : SelectedNodes Property

Glossary Item Box

The collection of selected nodes.Specifies a collection of the selected nodes.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.DescriptionAttribute("The collection of selected nodes.")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
Public ReadOnly Property SelectedNodes As System.Collections.ArrayList
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Collections.ArrayList

value = instance.SelectedNodes
C#
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute("The collection of selected nodes.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public System.Collections.ArrayList SelectedNodes {get;}
Delphi
public read-only property SelectedNodes: System.Collections.ArrayList;
JScript
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.DescriptionAttribute("The collection of selected nodes.")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
public function get SelectedNodes : System.Collections.ArrayList
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute("The collection of selected nodes.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public: __property System.Collections.ArrayList* get_SelectedNodes();
C++/CLI
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute("The collection of selected nodes.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public:
property System.Collections.ArrayList^ SelectedNodes {
   System.Collections.ArrayList^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


SharedScriptDirectory Property

[image]
Intersoft WebTreeView Documentation
SharedScriptDirectory Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : SharedScriptDirectory Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Client Script Directory")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required framework scripts for the control are stored.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overrides Property SharedScriptDirectory As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.String

instance.SharedScriptDirectory = value

value = instance.SharedScriptDirectory
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required framework scripts for the control are stored.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public override System.string SharedScriptDirectory {get; set;}
Delphi
public read-write property SharedScriptDirectory: System.String; override;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Client Script Directory")
System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required framework scripts for the control are stored.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public override function get,set SharedScriptDirectory : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required framework scripts for the control are stored.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property System.string* get_SharedScriptDirectory() override;
public: __property void set_SharedScriptDirectory(
   System.string* value
) override;
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required framework scripts for the control are stored.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
property System.String^ SharedScriptDirectory {
   System.String^ get() override;
   void set (    System.String^ value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


ShowCheckBoxes Property

[image]
Intersoft WebTreeView Documentation
ShowCheckBoxes Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : ShowCheckBoxes Property

Glossary Item Box

Gets or sets the node type next to which checkboxes should be shown.Gets or sets which node level will have checkbox shown on it.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the node type next to which checkboxes should be shown.")>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property ShowCheckBoxes As CheckBoxLocation
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As CheckBoxLocation

instance.ShowCheckBoxes = value

value = instance.ShowCheckBoxes
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the node type next to which checkboxes should be shown.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public CheckBoxLocation ShowCheckBoxes {get; set;}
Delphi
public read-write property ShowCheckBoxes: CheckBoxLocation;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the node type next to which checkboxes should be shown.")
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set ShowCheckBoxes : CheckBoxLocation
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the node type next to which checkboxes should be shown.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property CheckBoxLocation get_ShowCheckBoxes();
public: __property void set_ShowCheckBoxes(
   CheckBoxLocation value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the node type next to which checkboxes should be shown.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property CheckBoxLocation ShowCheckBoxes {
   CheckBoxLocation get();
   void set (    CheckBoxLocation value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


ShowExpandCollapse Property

[image]
Intersoft WebTreeView Documentation
ShowExpandCollapse Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : ShowExpandCollapse Property

Glossary Item Box

Specifies whether to show the expand/collapse icon next to the tree nodes.Specifies whether to show the expand/collapse icon next to the nodes.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether to show the expand/collapse icon next to the tree nodes.")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property ShowExpandCollapse As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Boolean

instance.ShowExpandCollapse = value

value = instance.ShowExpandCollapse
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether to show the expand/collapse icon next to the tree nodes.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.bool ShowExpandCollapse {get; set;}
Delphi
public read-write property ShowExpandCollapse: System.Boolean;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether to show the expand/collapse icon next to the tree nodes.")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set ShowExpandCollapse : System.boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether to show the expand/collapse icon next to the tree nodes.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.bool get_ShowExpandCollapse();
public: __property void set_ShowExpandCollapse(
   System.bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether to show the expand/collapse icon next to the tree nodes.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.bool ShowExpandCollapse {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


ShowLines Property

[image]
Intersoft WebTreeView Documentation
ShowLines Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : ShowLines Property

Glossary Item Box

Specifies whether to show lines connecting the tree nodes.Specifies whether to show lines connecting the tree nodes.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies whether to show lines connecting the tree nodes.")>
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property ShowLines As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Boolean

instance.ShowLines = value

value = instance.ShowLines
C#
[System.ComponentModel.DescriptionAttribute("Specifies whether to show lines connecting the tree nodes.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool ShowLines {get; set;}
Delphi
public read-write property ShowLines: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Specifies whether to show lines connecting the tree nodes.")
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set ShowLines : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies whether to show lines connecting the tree nodes.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_ShowLines();
public: __property void set_ShowLines(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies whether to show lines connecting the tree nodes.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool ShowLines {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


SupportDataSourceControl Property

[image]
Intersoft WebTreeView Documentation
SupportDataSourceControl Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : SupportDataSourceControl Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property SupportDataSourceControl As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Boolean

value = instance.SupportDataSourceControl
C#
protected override System.bool SupportDataSourceControl {get;}
Delphi
protected read-only property SupportDataSourceControl: System.Boolean; override;
JScript
protected override function get SupportDataSourceControl : System.boolean
Managed Extensions for C++
protected: __property System.bool get_SupportDataSourceControl() override;
C++/CLI
protected:
property System.bool SupportDataSourceControl {
   System.bool get() override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


XPath Property

[image]
Intersoft WebTreeView Documentation
XPath Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : XPath Property

Glossary Item Box

Specifies an intial XPath that is applied to the XML data.Specifies an initial XPath that is applied to the XML data.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies an intial XPath that is applied to the XML data.")>
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property XPath As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.String

instance.XPath = value

value = instance.XPath
C#
[System.ComponentModel.DescriptionAttribute("Specifies an intial XPath that is applied to the XML data.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.string XPath {get; set;}
Delphi
public read-write property XPath: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies an intial XPath that is applied to the XML data.")
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set XPath : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies an intial XPath that is applied to the XML data.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_XPath();
public: __property void set_XPath(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies an intial XPath that is applied to the XML data.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ XPath {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


WebTreeView Class Events

[image]
Intersoft WebTreeView Documentation
WebTreeView Class Events
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace : WebTreeView Class

Glossary Item Box

For a list of all members of this type, see WebTreeView members.

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | DragDrop |
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | InitializeChildNodes | Fires when child nodes need to be initialized during databinding.
Public Event | InitializeNode | Fires when node is initialized and about to be rendered.
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | NodeAdd | Fires after a treeview node is added. Fires when node is added successfully.
Public Event | NodeCheckChanged | Fires after a treeview node is checked or unchecked. Fires after a TreeView node is checked or unchecked.
Public Event | NodeCollapse | Fires after a treeview node is collapsed. Fires after a TreeView node is collapsed.
Public Event | NodeDelete | Fires after a treeview node is edited. Fires when node is deleted successfully.
Public Event | NodeEdit | Fires after a treeview node is edited. Fires when node is edited successfully.
Public Event | NodeExpand | Fires after a treeview node is expanded. Fires after a TreeView node is expanded.
Public Event | NodeMove | Fires after a treeview node is moved. Fires after a TreeView node is moved.
Public Event | NodeRename | Fires after a treeview node is renamed. Fires after a TreeView node is renamed.
Public Event | NodeSelectChanged | Fires after the selected treeview nodes are changed. Fires after the selected TreeView node has changed.
Public Event | NodeUpdated |
Public Event | PreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

WebTreeView Class
ISNet.WebUI.WebTreeView Namespace

Concepts

Overview


DragDrop Event

[image]
Intersoft WebTreeView Documentation
DragDrop Event
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : DragDrop Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Fires after a successful drag and drop operation.")>
<System.ComponentModel.CategoryAttribute("TreeView Events")>
Public Event DragDrop As System.EventHandler(Of WebTreeViewDragDropEventArgs)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim handler As System.EventHandler(Of WebTreeViewDragDropEventArgs)

AddHandler instance.DragDrop, handler
C#
[System.ComponentModel.DescriptionAttribute("Fires after a successful drag and drop operation.")]
[System.ComponentModel.CategoryAttribute("TreeView Events")]
public event System.EventHandler<WebTreeViewDragDropEventArgs> DragDrop
Delphi
public event DragDrop: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Fires after a successful drag and drop operation.")]
[System.ComponentModel.CategoryAttribute("TreeView Events")]
public: __event System.EventHandler<WebTreeViewDragDropEventArgs*>* DragDrop
C++/CLI
[System.ComponentModel.DescriptionAttribute("Fires after a successful drag and drop operation.")]
[System.ComponentModel.CategoryAttribute("TreeView Events")]
public:
event System.EventHandler<WebTreeViewDragDropEventArgs^>^ DragDrop

Event Data

The event handler receives an argument of type WebTreeViewDragDropEventArgs containing data related to this event. The following WebTreeViewDragDropEventArgs properties provide information specific to this event.

Property | Description
Command (Inherited from ISNet.WebUI.WebTreeView.WebTreeViewNodeEventArgs) | Gets command of WebTreeViewNode event arguments.Determines the type of operation, such as "NodeCopy", "NodeCollapse", "Initialize", etc.
DraggedNodes | Gets dragged nodes.
InsertionMode | Get insertion mode.
MoveType | Gets move type.
Node (Inherited from ISNet.WebUI.WebTreeView.WebTreeViewNodeEventArgs) | Gets operated node.The specified node.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


InitializeChildNodes Event

[image]
Intersoft WebTreeView Documentation
InitializeChildNodes Event
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : InitializeChildNodes Event

Glossary Item Box

Fires when child nodes need to be initialized during databinding.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Fires when childnodes need to be initialized during databinding.")>
<System.ComponentModel.CategoryAttribute("TreeView Events")>
Public Event InitializeChildNodes As InitializeChildNodesEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim handler As InitializeChildNodesEventHandler

AddHandler instance.InitializeChildNodes, handler
C#
[System.ComponentModel.DescriptionAttribute("Fires when childnodes need to be initialized during databinding.")]
[System.ComponentModel.CategoryAttribute("TreeView Events")]
public event InitializeChildNodesEventHandler InitializeChildNodes
Delphi
public event InitializeChildNodes: InitializeChildNodesEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Fires when childnodes need to be initialized during databinding.")]
[System.ComponentModel.CategoryAttribute("TreeView Events")]
public: __event InitializeChildNodesEventHandler* InitializeChildNodes
C++/CLI
[System.ComponentModel.DescriptionAttribute("Fires when childnodes need to be initialized during databinding.")]
[System.ComponentModel.CategoryAttribute("TreeView Events")]
public:
event InitializeChildNodesEventHandler^ InitializeChildNodes

Event Data

The event handler receives an argument of type WebTreeViewNodeEventArgs containing data related to this event. The following WebTreeViewNodeEventArgs properties provide information specific to this event.

Property | Description
Command | Gets command of WebTreeViewNode event arguments.Determines the type of operation, such as "NodeCopy", "NodeCollapse", "Initialize", etc.
Node | Gets operated node.The specified node.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


InitializeNode Event

[image]
Intersoft WebTreeView Documentation
InitializeNode Event
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : InitializeNode Event

Glossary Item Box

Fires when node is initialized and about to be rendered.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Fires when node is being initialized and about to be rendered.")>
<System.ComponentModel.CategoryAttribute("TreeView Events")>
Public Event InitializeNode As InitializeNodeEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim handler As InitializeNodeEventHandler

AddHandler instance.InitializeNode, handler
C#
[System.ComponentModel.DescriptionAttribute("Fires when node is being initialized and about to be rendered.")]
[System.ComponentModel.CategoryAttribute("TreeView Events")]
public event InitializeNodeEventHandler InitializeNode
Delphi
public event InitializeNode: InitializeNodeEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Fires when node is being initialized and about to be rendered.")]
[System.ComponentModel.CategoryAttribute("TreeView Events")]
public: __event InitializeNodeEventHandler* InitializeNode
C++/CLI
[System.ComponentModel.DescriptionAttribute("Fires when node is being initialized and about to be rendered.")]
[System.ComponentModel.CategoryAttribute("TreeView Events")]
public:
event InitializeNodeEventHandler^ InitializeNode

Event Data

The event handler receives an argument of type WebTreeViewNodeEventArgs containing data related to this event. The following WebTreeViewNodeEventArgs properties provide information specific to this event.

Property | Description
Command | Gets command of WebTreeViewNode event arguments.Determines the type of operation, such as "NodeCopy", "NodeCollapse", "Initialize", etc.
Node | Gets operated node.The specified node.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


NodeAdd Event

[image]
Intersoft WebTreeView Documentation
NodeAdd Event
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : NodeAdd Event

Glossary Item Box

Fires after a treeview node is added. Fires when node is added successfully.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("TreeView Events")>
<System.ComponentModel.DescriptionAttribute("Fires after a treeview node is added.")>
Public Event NodeAdd As NodeAddEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim handler As NodeAddEventHandler

AddHandler instance.NodeAdd, handler
C#
[System.ComponentModel.CategoryAttribute("TreeView Events")]
[System.ComponentModel.DescriptionAttribute("Fires after a treeview node is added.")]
public event NodeAddEventHandler NodeAdd
Delphi
public event NodeAdd: NodeAddEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("TreeView Events")]
[System.ComponentModel.DescriptionAttribute("Fires after a treeview node is added.")]
public: __event NodeAddEventHandler* NodeAdd
C++/CLI
[System.ComponentModel.CategoryAttribute("TreeView Events")]
[System.ComponentModel.DescriptionAttribute("Fires after a treeview node is added.")]
public:
event NodeAddEventHandler^ NodeAdd

Event Data

The event handler receives an argument of type WebTreeViewNodeEventArgs containing data related to this event. The following WebTreeViewNodeEventArgs properties provide information specific to this event.

Property | Description
Command | Gets command of WebTreeViewNode event arguments.Determines the type of operation, such as "NodeCopy", "NodeCollapse", "Initialize", etc.
Node | Gets operated node.The specified node.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


NodeCheckChanged Event

[image]
Intersoft WebTreeView Documentation
NodeCheckChanged Event
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : NodeCheckChanged Event

Glossary Item Box

Fires after a treeview node is checked or unchecked. Fires after a TreeView node is checked or unchecked.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("TreeView Events")>
<System.ComponentModel.DescriptionAttribute("Fires after a treeview node is checked or unchecked.")>
Public Event NodeCheckChanged As NodeCheckChangedEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim handler As NodeCheckChangedEventHandler

AddHandler instance.NodeCheckChanged, handler
C#
[System.ComponentModel.CategoryAttribute("TreeView Events")]
[System.ComponentModel.DescriptionAttribute("Fires after a treeview node is checked or unchecked.")]
public event NodeCheckChangedEventHandler NodeCheckChanged
Delphi
public event NodeCheckChanged: NodeCheckChangedEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("TreeView Events")]
[System.ComponentModel.DescriptionAttribute("Fires after a treeview node is checked or unchecked.")]
public: __event NodeCheckChangedEventHandler* NodeCheckChanged
C++/CLI
[System.ComponentModel.CategoryAttribute("TreeView Events")]
[System.ComponentModel.DescriptionAttribute("Fires after a treeview node is checked or unchecked.")]
public:
event NodeCheckChangedEventHandler^ NodeCheckChanged

Event Data

The event handler receives an argument of type WebTreeViewNodeEventArgs containing data related to this event. The following WebTreeViewNodeEventArgs properties provide information specific to this event.

Property | Description
Command | Gets command of WebTreeViewNode event arguments.Determines the type of operation, such as "NodeCopy", "NodeCollapse", "Initialize", etc.
Node | Gets operated node.The specified node.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


NodeCollapse Event

[image]
Intersoft WebTreeView Documentation
NodeCollapse Event
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : NodeCollapse Event

Glossary Item Box

Fires after a treeview node is collapsed. Fires after a TreeView node is collapsed.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Fires after a treeview node is collapsed.")>
<System.ComponentModel.CategoryAttribute("TreeView Events")>
Public Event NodeCollapse As NodeCollapseEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim handler As NodeCollapseEventHandler

AddHandler instance.NodeCollapse, handler
C#
[System.ComponentModel.DescriptionAttribute("Fires after a treeview node is collapsed.")]
[System.ComponentModel.CategoryAttribute("TreeView Events")]
public event NodeCollapseEventHandler NodeCollapse
Delphi
public event NodeCollapse: NodeCollapseEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Fires after a treeview node is collapsed.")]
[System.ComponentModel.CategoryAttribute("TreeView Events")]
public: __event NodeCollapseEventHandler* NodeCollapse
C++/CLI
[System.ComponentModel.DescriptionAttribute("Fires after a treeview node is collapsed.")]
[System.ComponentModel.CategoryAttribute("TreeView Events")]
public:
event NodeCollapseEventHandler^ NodeCollapse

Event Data

The event handler receives an argument of type WebTreeViewNodeEventArgs containing data related to this event. The following WebTreeViewNodeEventArgs properties provide information specific to this event.

Property | Description
Command | Gets command of WebTreeViewNode event arguments.Determines the type of operation, such as "NodeCopy", "NodeCollapse", "Initialize", etc.
Node | Gets operated node.The specified node.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


NodeDelete Event

[image]
Intersoft WebTreeView Documentation
NodeDelete Event
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : NodeDelete Event

Glossary Item Box

Fires after a treeview node is edited. Fires when node is deleted successfully.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("TreeView Events")>
<System.ComponentModel.DescriptionAttribute("Fires after a treeview node is edited.")>
Public Event NodeDelete As NodeDeleteEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim handler As NodeDeleteEventHandler

AddHandler instance.NodeDelete, handler
C#
[System.ComponentModel.CategoryAttribute("TreeView Events")]
[System.ComponentModel.DescriptionAttribute("Fires after a treeview node is edited.")]
public event NodeDeleteEventHandler NodeDelete
Delphi
public event NodeDelete: NodeDeleteEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("TreeView Events")]
[System.ComponentModel.DescriptionAttribute("Fires after a treeview node is edited.")]
public: __event NodeDeleteEventHandler* NodeDelete
C++/CLI
[System.ComponentModel.CategoryAttribute("TreeView Events")]
[System.ComponentModel.DescriptionAttribute("Fires after a treeview node is edited.")]
public:
event NodeDeleteEventHandler^ NodeDelete

Event Data

The event handler receives an argument of type WebTreeViewNodeEventArgs containing data related to this event. The following WebTreeViewNodeEventArgs properties provide information specific to this event.

Property | Description
Command | Gets command of WebTreeViewNode event arguments.Determines the type of operation, such as "NodeCopy", "NodeCollapse", "Initialize", etc.
Node | Gets operated node.The specified node.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


NodeEdit Event

[image]
Intersoft WebTreeView Documentation
NodeEdit Event
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : NodeEdit Event

Glossary Item Box

Fires after a treeview node is edited. Fires when node is edited successfully.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("TreeView Events")>
<System.ComponentModel.DescriptionAttribute("Fires after a treeview node is edited.")>
Public Event NodeEdit As NodeEditEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim handler As NodeEditEventHandler

AddHandler instance.NodeEdit, handler
C#
[System.ComponentModel.CategoryAttribute("TreeView Events")]
[System.ComponentModel.DescriptionAttribute("Fires after a treeview node is edited.")]
public event NodeEditEventHandler NodeEdit
Delphi
public event NodeEdit: NodeEditEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("TreeView Events")]
[System.ComponentModel.DescriptionAttribute("Fires after a treeview node is edited.")]
public: __event NodeEditEventHandler* NodeEdit
C++/CLI
[System.ComponentModel.CategoryAttribute("TreeView Events")]
[System.ComponentModel.DescriptionAttribute("Fires after a treeview node is edited.")]
public:
event NodeEditEventHandler^ NodeEdit

Event Data

The event handler receives an argument of type WebTreeViewNodeEditEventArgs containing data related to this event. The following WebTreeViewNodeEditEventArgs properties provide information specific to this event.

Property | Description
Command | Gets command type.Determines the type of operation, such as "NodeCopy", "NodeCollapse", "Initialize", etc.
Node | Gets operated node.The specified node.
OldText | Gets old text.The specified node's old text that wants to be edited.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


NodeExpand Event

[image]
Intersoft WebTreeView Documentation
NodeExpand Event
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : NodeExpand Event

Glossary Item Box

Fires after a treeview node is expanded. Fires after a TreeView node is expanded.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Fires after a treeview node is expanded.")>
<System.ComponentModel.CategoryAttribute("TreeView Events")>
Public Event NodeExpand As NodeExpandEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim handler As NodeExpandEventHandler

AddHandler instance.NodeExpand, handler
C#
[System.ComponentModel.DescriptionAttribute("Fires after a treeview node is expanded.")]
[System.ComponentModel.CategoryAttribute("TreeView Events")]
public event NodeExpandEventHandler NodeExpand
Delphi
public event NodeExpand: NodeExpandEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Fires after a treeview node is expanded.")]
[System.ComponentModel.CategoryAttribute("TreeView Events")]
public: __event NodeExpandEventHandler* NodeExpand
C++/CLI
[System.ComponentModel.DescriptionAttribute("Fires after a treeview node is expanded.")]
[System.ComponentModel.CategoryAttribute("TreeView Events")]
public:
event NodeExpandEventHandler^ NodeExpand

Event Data

The event handler receives an argument of type WebTreeViewNodeEventArgs containing data related to this event. The following WebTreeViewNodeEventArgs properties provide information specific to this event.

Property | Description
Command | Gets command of WebTreeViewNode event arguments.Determines the type of operation, such as "NodeCopy", "NodeCollapse", "Initialize", etc.
Node | Gets operated node.The specified node.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


NodeMove Event

[image]
Intersoft WebTreeView Documentation
NodeMove Event
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : NodeMove Event

Glossary Item Box

Fires after a treeview node is moved. Fires after a TreeView node is moved.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Fires after a treeview node is moved.")>
<System.ComponentModel.CategoryAttribute("TreeView Events")>
Public Event NodeMove As NodeMoveEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim handler As NodeMoveEventHandler

AddHandler instance.NodeMove, handler
C#
[System.ComponentModel.DescriptionAttribute("Fires after a treeview node is moved.")]
[System.ComponentModel.CategoryAttribute("TreeView Events")]
public event NodeMoveEventHandler NodeMove
Delphi
public event NodeMove: NodeMoveEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Fires after a treeview node is moved.")]
[System.ComponentModel.CategoryAttribute("TreeView Events")]
public: __event NodeMoveEventHandler* NodeMove
C++/CLI
[System.ComponentModel.DescriptionAttribute("Fires after a treeview node is moved.")]
[System.ComponentModel.CategoryAttribute("TreeView Events")]
public:
event NodeMoveEventHandler^ NodeMove

Event Data

The event handler receives an argument of type WebTreeViewNodeMoveEventArgs containing data related to this event. The following WebTreeViewNodeMoveEventArgs properties provide information specific to this event.

Property | Description
Command (Inherited from ISNet.WebUI.WebTreeView.WebTreeViewNodeEventArgs) | Gets command of WebTreeViewNode event arguments.Determines the type of operation, such as "NodeCopy", "NodeCollapse", "Initialize", etc.
DestinationNode | Gets destination node of node move operation.
InsertionMode | Gets insertion mode of node move operation.
MoveType | Gets move type of node move operation.
Node (Inherited from ISNet.WebUI.WebTreeView.WebTreeViewNodeEventArgs) | Gets operated node.The specified node.
SourceNode | Gets source node of node move operation.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


NodeRename Event

[image]
Intersoft WebTreeView Documentation
NodeRename Event
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : NodeRename Event

Glossary Item Box

Fires after a treeview node is renamed. Fires after a TreeView node is renamed.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("TreeView Events")>
<System.ComponentModel.DescriptionAttribute("Fires after a treeview node is renamed.")>
Public Event NodeRename As NodeRenameEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim handler As NodeRenameEventHandler

AddHandler instance.NodeRename, handler
C#
[System.ComponentModel.CategoryAttribute("TreeView Events")]
[System.ComponentModel.DescriptionAttribute("Fires after a treeview node is renamed.")]
public event NodeRenameEventHandler NodeRename
Delphi
public event NodeRename: NodeRenameEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("TreeView Events")]
[System.ComponentModel.DescriptionAttribute("Fires after a treeview node is renamed.")]
public: __event NodeRenameEventHandler* NodeRename
C++/CLI
[System.ComponentModel.CategoryAttribute("TreeView Events")]
[System.ComponentModel.DescriptionAttribute("Fires after a treeview node is renamed.")]
public:
event NodeRenameEventHandler^ NodeRename

Event Data

The event handler receives an argument of type WebTreeViewNodeRenameEventArgs containing data related to this event. The following WebTreeViewNodeRenameEventArgs properties provide information specific to this event.

Property | Description
Command (Inherited from ISNet.WebUI.WebTreeView.WebTreeViewNodeEventArgs) | Gets command of WebTreeViewNode event arguments.Determines the type of operation, such as "NodeCopy", "NodeCollapse", "Initialize", etc.
Node (Inherited from ISNet.WebUI.WebTreeView.WebTreeViewNodeEventArgs) | Gets operated node.The specified node.
OldText | Gets old text of node.The specified node's old text that wants to be replaced.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


NodeSelectChanged Event

[image]
Intersoft WebTreeView Documentation
NodeSelectChanged Event
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : NodeSelectChanged Event

Glossary Item Box

Fires after the selected treeview nodes are changed. Fires after the selected TreeView node has changed.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("TreeView Events")>
<System.ComponentModel.DescriptionAttribute("Fires after the selected treeview nodes are changed.")>
Public Event NodeSelectChanged As NodeSelectChangedEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim handler As NodeSelectChangedEventHandler

AddHandler instance.NodeSelectChanged, handler
C#
[System.ComponentModel.CategoryAttribute("TreeView Events")]
[System.ComponentModel.DescriptionAttribute("Fires after the selected treeview nodes are changed.")]
public event NodeSelectChangedEventHandler NodeSelectChanged
Delphi
public event NodeSelectChanged: NodeSelectChangedEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("TreeView Events")]
[System.ComponentModel.DescriptionAttribute("Fires after the selected treeview nodes are changed.")]
public: __event NodeSelectChangedEventHandler* NodeSelectChanged
C++/CLI
[System.ComponentModel.CategoryAttribute("TreeView Events")]
[System.ComponentModel.DescriptionAttribute("Fires after the selected treeview nodes are changed.")]
public:
event NodeSelectChangedEventHandler^ NodeSelectChanged

Event Data

The event handler receives an argument of type WebTreeViewNodeEventArgs containing data related to this event. The following WebTreeViewNodeEventArgs properties provide information specific to this event.

Property | Description
Command | Gets command of WebTreeViewNode event arguments.Determines the type of operation, such as "NodeCopy", "NodeCollapse", "Initialize", etc.
Node | Gets operated node.The specified node.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


NodeUpdated Event

[image]
Intersoft WebTreeView Documentation
NodeUpdated Event
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : NodeUpdated Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("TreeView Events")>
<System.ComponentModel.DescriptionAttribute("Fires after the node property is updated.")>
Public Event NodeUpdated As NodeUpdatedEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim handler As NodeUpdatedEventHandler

AddHandler instance.NodeUpdated, handler
C#
[System.ComponentModel.CategoryAttribute("TreeView Events")]
[System.ComponentModel.DescriptionAttribute("Fires after the node property is updated.")]
public event NodeUpdatedEventHandler NodeUpdated
Delphi
public event NodeUpdated: NodeUpdatedEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("TreeView Events")]
[System.ComponentModel.DescriptionAttribute("Fires after the node property is updated.")]
public: __event NodeUpdatedEventHandler* NodeUpdated
C++/CLI
[System.ComponentModel.CategoryAttribute("TreeView Events")]
[System.ComponentModel.DescriptionAttribute("Fires after the node property is updated.")]
public:
event NodeUpdatedEventHandler^ NodeUpdated

Event Data

The event handler receives an argument of type WebTreeViewNodeUpdatedEventArgs containing data related to this event. The following WebTreeViewNodeUpdatedEventArgs properties provide information specific to this event.

Property | Description
Node | Gets operated node.
OldValue | Gets old value.
PropertyName | Gets Property Name.
Value | Gets Value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


WebTreeViewAutoPostBackSettings Class

[image]
Intersoft WebTreeView Documentation
WebTreeViewAutoPostBackSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace : WebTreeViewAutoPostBackSettings Class

Glossary Item Box

A collection of WebTreeView's AutoPostBack settings.

Object Model

WebTreeViewAutoPostBackSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DescriptionAttribute("A collection of WebTreeView's AutoPostBack settings. ")>
<System.SerializableAttribute()>
Public Class WebTreeViewAutoPostBackSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewAutoPostBackSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("A collection of WebTreeView's AutoPostBack settings. ")]
[System.SerializableAttribute()]
public class WebTreeViewAutoPostBackSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebTreeViewAutoPostBackSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DescriptionAttribute("A collection of WebTreeView's AutoPostBack settings. ")
System.SerializableAttribute()
public class WebTreeViewAutoPostBackSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("A collection of WebTreeView's AutoPostBack settings. ")]
[System.SerializableAttribute()]
public __gc class WebTreeViewAutoPostBackSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("A collection of WebTreeView's AutoPostBack settings. ")]
[System.SerializableAttribute()]
public ref class WebTreeViewAutoPostBackSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebTreeView.WebTreeViewAutoPostBackSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewAutoPostBackSettings Members
ISNet.WebUI.WebTreeView Namespace


WebTreeViewAutoPostBackSettings Class Members

[image]
Intersoft WebTreeView Documentation
WebTreeViewAutoPostBackSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebTreeView Namespace : WebTreeViewAutoPostBackSettings Class

Glossary Item Box

The following tables list the members exposed by WebTreeViewAutoPostBackSettings.

Public Constructors

 | Name | Description
Public Constructor | WebTreeViewAutoPostBackSettings Constructor | Overloaded. Initializes a new instance of WebTreeViewAutoPostBackSettings class.
Top

Public Properties

 | Name | Description
Public Property | OnDragDrop | Specifies whether WebTreeView will performed postback automatically when OnDragDrop is executed successfully.
Public Property | OnNodeAdd | Specifies whether WebTreeView will performed postback automatically when OnNodeAdd is executed successfully.
Public Property | OnNodeCheckChanged | Specifies whether WebTreeView will performed postback automatically when OnNodeCheckChanged is executed successfully.
Public Property | OnNodeCollapse | Specifies whether WebTreeView will performed postback automatically when OnNodeCollapse is executed successfully.
Public Property | OnNodeDelete | Specifies whether WebTreeView will performed postback automatically when OnNodeDelete is executed successfully.
Public Property | OnNodeEdit | Specifies whether WebTreeView will performed postback automatically when OnNodeEdit is executed successfully.
Public Property | OnNodeExpand | Specifies whether WebTreeView will performed postback automatically when OnNodeExpand is executed successfully.
Public Property | OnNodeMove | Specifies whether WebTreeView will performed postback automatically when OnNodeMove is executed successfully.
Public Property | OnNodeRename | Specifies whether WebTreeView will performed postback automatically when OnNodeRename is executed successfully.
Public Property | OnNodeSelectChanged | Specifies whether WebTreeView will performed postback automatically when SelectChanged is executed successfully.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

Protected Methods

 | Name | Description
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | IsInSerializationContext | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebTreeViewAutoPostBackSettings Class
ISNet.WebUI.WebTreeView Namespace


WebTreeViewAutoPostBackSettings Constructor

[image]
Intersoft WebTreeView Documentation
WebTreeViewAutoPostBackSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewAutoPostBackSettings Class : WebTreeViewAutoPostBackSettings Constructor

Glossary Item Box

Initializes a new instance of WebTreeViewAutoPostBackSettings class.

Overload List

Overload | Description
WebTreeViewAutoPostBackSettings Constructor() |
WebTreeViewAutoPostBackSettings Constructor(SerializationInfo,StreamingContext) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewAutoPostBackSettings Class
WebTreeViewAutoPostBackSettings Members


WebTreeViewAutoPostBackSettings Constructor()

[image]
Intersoft WebTreeView Documentation
WebTreeViewAutoPostBackSettings Constructor()
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewAutoPostBackSettings Class > WebTreeViewAutoPostBackSettings Constructor : WebTreeViewAutoPostBackSettings Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebTreeViewAutoPostBackSettings class.")>
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebTreeViewAutoPostBackSettings()
C#
[System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebTreeViewAutoPostBackSettings class.")]
public WebTreeViewAutoPostBackSettings()
Delphi
public WebTreeViewAutoPostBackSettings();
JScript
System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebTreeViewAutoPostBackSettings class.")
public function WebTreeViewAutoPostBackSettings();
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebTreeViewAutoPostBackSettings class.")]
public: WebTreeViewAutoPostBackSettings();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebTreeViewAutoPostBackSettings class.")]
public:
WebTreeViewAutoPostBackSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewAutoPostBackSettings Class
WebTreeViewAutoPostBackSettings Members
Overload List


WebTreeViewAutoPostBackSettings Constructor(SerializationInfo,StreamingContext)

[image]
Intersoft WebTreeView Documentation
WebTreeViewAutoPostBackSettings Constructor(SerializationInfo,StreamingContext)
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewAutoPostBackSettings Class > WebTreeViewAutoPostBackSettings Constructor : WebTreeViewAutoPostBackSettings Constructor(SerializationInfo,StreamingContext)

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

Dim instance As New WebTreeViewAutoPostBackSettings(info, context)
C#
protected WebTreeViewAutoPostBackSettings(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
protected WebTreeViewAutoPostBackSettings(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
protected function WebTreeViewAutoPostBackSettings(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
protected: WebTreeViewAutoPostBackSettings(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
protected:
WebTreeViewAutoPostBackSettings(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewAutoPostBackSettings Class
WebTreeViewAutoPostBackSettings Members
Overload List


WebTreeViewAutoPostBackSettings Class Properties

[image]
Intersoft WebTreeView Documentation
WebTreeViewAutoPostBackSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace : WebTreeViewAutoPostBackSettings Class

Glossary Item Box

For a list of all members of this type, see WebTreeViewAutoPostBackSettings members.

Public Properties

 | Name | Description
Public Property | OnDragDrop | Specifies whether WebTreeView will performed postback automatically when OnDragDrop is executed successfully.
Public Property | OnNodeAdd | Specifies whether WebTreeView will performed postback automatically when OnNodeAdd is executed successfully.
Public Property | OnNodeCheckChanged | Specifies whether WebTreeView will performed postback automatically when OnNodeCheckChanged is executed successfully.
Public Property | OnNodeCollapse | Specifies whether WebTreeView will performed postback automatically when OnNodeCollapse is executed successfully.
Public Property | OnNodeDelete | Specifies whether WebTreeView will performed postback automatically when OnNodeDelete is executed successfully.
Public Property | OnNodeEdit | Specifies whether WebTreeView will performed postback automatically when OnNodeEdit is executed successfully.
Public Property | OnNodeExpand | Specifies whether WebTreeView will performed postback automatically when OnNodeExpand is executed successfully.
Public Property | OnNodeMove | Specifies whether WebTreeView will performed postback automatically when OnNodeMove is executed successfully.
Public Property | OnNodeRename | Specifies whether WebTreeView will performed postback automatically when OnNodeRename is executed successfully.
Public Property | OnNodeSelectChanged | Specifies whether WebTreeView will performed postback automatically when SelectChanged is executed successfully.
Top

See Also

Reference

WebTreeViewAutoPostBackSettings Class
ISNet.WebUI.WebTreeView Namespace


OnDragDrop Property

[image]
Intersoft WebTreeView Documentation
OnDragDrop Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewAutoPostBackSettings Class : OnDragDrop Property

Glossary Item Box

Specifies whether WebTreeView will performed postback automatically when OnDragDrop is executed successfully.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies WebTreeView to perform auto postback OnDragDrop.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property OnDragDrop As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewAutoPostBackSettings
Dim value As System.Boolean

instance.OnDragDrop = value

value = instance.OnDragDrop
C#
[System.ComponentModel.DescriptionAttribute("Specifies WebTreeView to perform auto postback OnDragDrop.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool OnDragDrop {get; set;}
Delphi
public read-write property OnDragDrop: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Specifies WebTreeView to perform auto postback OnDragDrop.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set OnDragDrop : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies WebTreeView to perform auto postback OnDragDrop.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_OnDragDrop();
public: __property void set_OnDragDrop(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies WebTreeView to perform auto postback OnDragDrop.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool OnDragDrop {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewAutoPostBackSettings Class
WebTreeViewAutoPostBackSettings Members


OnNodeAdd Property

[image]
Intersoft WebTreeView Documentation
OnNodeAdd Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewAutoPostBackSettings Class : OnNodeAdd Property

Glossary Item Box

Specifies whether WebTreeView will performed postback automatically when OnNodeAdd is executed successfully.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies WebTreeView to perform auto postback OnNodeAdd.")>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Property OnNodeAdd As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewAutoPostBackSettings
Dim value As System.Boolean

instance.OnNodeAdd = value

value = instance.OnNodeAdd
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies WebTreeView to perform auto postback OnNodeAdd.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
public System.bool OnNodeAdd {get; set;}
Delphi
public read-write property OnNodeAdd: System.Boolean;
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies WebTreeView to perform auto postback OnNodeAdd.")
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set OnNodeAdd : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies WebTreeView to perform auto postback OnNodeAdd.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property System.bool get_OnNodeAdd();
public: __property void set_OnNodeAdd(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies WebTreeView to perform auto postback OnNodeAdd.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
property System.bool OnNodeAdd {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewAutoPostBackSettings Class
WebTreeViewAutoPostBackSettings Members


OnNodeCheckChanged Property

[image]
Intersoft WebTreeView Documentation
OnNodeCheckChanged Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewAutoPostBackSettings Class : OnNodeCheckChanged Property

Glossary Item Box

Specifies whether WebTreeView will performed postback automatically when OnNodeCheckChanged is executed successfully.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies WebTreeView to perform auto postback OnNodeCheckChanged.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property OnNodeCheckChanged As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewAutoPostBackSettings
Dim value As System.Boolean

instance.OnNodeCheckChanged = value

value = instance.OnNodeCheckChanged
C#
[System.ComponentModel.DescriptionAttribute("Specifies WebTreeView to perform auto postback OnNodeCheckChanged.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.bool OnNodeCheckChanged {get; set;}
Delphi
public read-write property OnNodeCheckChanged: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Specifies WebTreeView to perform auto postback OnNodeCheckChanged.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set OnNodeCheckChanged : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies WebTreeView to perform auto postback OnNodeCheckChanged.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.bool get_OnNodeCheckChanged();
public: __property void set_OnNodeCheckChanged(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies WebTreeView to perform auto postback OnNodeCheckChanged.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.bool OnNodeCheckChanged {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewAutoPostBackSettings Class
WebTreeViewAutoPostBackSettings Members


OnNodeCollapse Property

[image]
Intersoft WebTreeView Documentation
OnNodeCollapse Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewAutoPostBackSettings Class : OnNodeCollapse Property

Glossary Item Box

Specifies whether WebTreeView will performed postback automatically when OnNodeCollapse is executed successfully.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.DescriptionAttribute("Specifies WebTreeView to perform auto postback OnNodeCollapse.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property OnNodeCollapse As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewAutoPostBackSettings
Dim value As System.Boolean

instance.OnNodeCollapse = value

value = instance.OnNodeCollapse
C#
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute("Specifies WebTreeView to perform auto postback OnNodeCollapse.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.bool OnNodeCollapse {get; set;}
Delphi
public read-write property OnNodeCollapse: System.Boolean;
JScript
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.DescriptionAttribute("Specifies WebTreeView to perform auto postback OnNodeCollapse.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set OnNodeCollapse : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute("Specifies WebTreeView to perform auto postback OnNodeCollapse.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.bool get_OnNodeCollapse();
public: __property void set_OnNodeCollapse(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute("Specifies WebTreeView to perform auto postback OnNodeCollapse.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.bool OnNodeCollapse {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewAutoPostBackSettings Class
WebTreeViewAutoPostBackSettings Members


OnNodeDelete Property

[image]
Intersoft WebTreeView Documentation
OnNodeDelete Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewAutoPostBackSettings Class : OnNodeDelete Property

Glossary Item Box

Specifies whether WebTreeView will performed postback automatically when OnNodeDelete is executed successfully.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies WebTreeView to perform auto postback OnNodeDelete.")>
Public Property OnNodeDelete As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewAutoPostBackSettings
Dim value As System.Boolean

instance.OnNodeDelete = value

value = instance.OnNodeDelete
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies WebTreeView to perform auto postback OnNodeDelete.")]
public System.bool OnNodeDelete {get; set;}
Delphi
public read-write property OnNodeDelete: System.Boolean;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies WebTreeView to perform auto postback OnNodeDelete.")
public function get,set OnNodeDelete : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies WebTreeView to perform auto postback OnNodeDelete.")]
public: __property System.bool get_OnNodeDelete();
public: __property void set_OnNodeDelete(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies WebTreeView to perform auto postback OnNodeDelete.")]
public:
property System.bool OnNodeDelete {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewAutoPostBackSettings Class
WebTreeViewAutoPostBackSettings Members


OnNodeEdit Property

[image]
Intersoft WebTreeView Documentation
OnNodeEdit Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewAutoPostBackSettings Class : OnNodeEdit Property

Glossary Item Box

Specifies whether WebTreeView will performed postback automatically when OnNodeEdit is executed successfully.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.DescriptionAttribute("Specifies WebTreeView to perform auto postback OnNodeEdit.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property OnNodeEdit As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewAutoPostBackSettings
Dim value As System.Boolean

instance.OnNodeEdit = value

value = instance.OnNodeEdit
C#
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute("Specifies WebTreeView to perform auto postback OnNodeEdit.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.bool OnNodeEdit {get; set;}
Delphi
public read-write property OnNodeEdit: System.Boolean;
JScript
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.DescriptionAttribute("Specifies WebTreeView to perform auto postback OnNodeEdit.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set OnNodeEdit : System.boolean
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute("Specifies WebTreeView to perform auto postback OnNodeEdit.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.bool get_OnNodeEdit();
public: __property void set_OnNodeEdit(
   System.bool value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute("Specifies WebTreeView to perform auto postback OnNodeEdit.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.bool OnNodeEdit {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewAutoPostBackSettings Class
WebTreeViewAutoPostBackSettings Members


OnNodeExpand Property

[image]
Intersoft WebTreeView Documentation
OnNodeExpand Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewAutoPostBackSettings Class : OnNodeExpand Property

Glossary Item Box

Specifies whether WebTreeView will performed postback automatically when OnNodeExpand is executed successfully.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.DescriptionAttribute("Specifies WebTreeView to perform auto postback OnNodeExpand.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property OnNodeExpand As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewAutoPostBackSettings
Dim value As System.Boolean

instance.OnNodeExpand = value

value = instance.OnNodeExpand
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute("Specifies WebTreeView to perform auto postback OnNodeExpand.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.bool OnNodeExpand {get; set;}
Delphi
public read-write property OnNodeExpand: System.Boolean;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.DescriptionAttribute("Specifies WebTreeView to perform auto postback OnNodeExpand.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set OnNodeExpand : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute("Specifies WebTreeView to perform auto postback OnNodeExpand.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.bool get_OnNodeExpand();
public: __property void set_OnNodeExpand(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute("Specifies WebTreeView to perform auto postback OnNodeExpand.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.bool OnNodeExpand {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewAutoPostBackSettings Class
WebTreeViewAutoPostBackSettings Members


OnNodeMove Property

[image]
Intersoft WebTreeView Documentation
OnNodeMove Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewAutoPostBackSettings Class : OnNodeMove Property

Glossary Item Box

Specifies whether WebTreeView will performed postback automatically when OnNodeMove is executed successfully.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies WebTreeView to perform auto postback OnNodeMove. ")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property OnNodeMove As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewAutoPostBackSettings
Dim value As System.Boolean

instance.OnNodeMove = value

value = instance.OnNodeMove
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies WebTreeView to perform auto postback OnNodeMove. ")]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool OnNodeMove {get; set;}
Delphi
public read-write property OnNodeMove: System.Boolean;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies WebTreeView to perform auto postback OnNodeMove. ")
System.ComponentModel.DefaultValueAttribute()
public function get,set OnNodeMove : System.boolean
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies WebTreeView to perform auto postback OnNodeMove. ")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_OnNodeMove();
public: __property void set_OnNodeMove(
   System.bool value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies WebTreeView to perform auto postback OnNodeMove. ")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool OnNodeMove {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewAutoPostBackSettings Class
WebTreeViewAutoPostBackSettings Members


OnNodeRename Property

[image]
Intersoft WebTreeView Documentation
OnNodeRename Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewAutoPostBackSettings Class : OnNodeRename Property

Glossary Item Box

Specifies whether WebTreeView will performed postback automatically when OnNodeRename is executed successfully.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies WebTreeView to perform auto postback OnNodeRename. ")>
Public Property OnNodeRename As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewAutoPostBackSettings
Dim value As System.Boolean

instance.OnNodeRename = value

value = instance.OnNodeRename
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies WebTreeView to perform auto postback OnNodeRename. ")]
public System.bool OnNodeRename {get; set;}
Delphi
public read-write property OnNodeRename: System.Boolean;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies WebTreeView to perform auto postback OnNodeRename. ")
public function get,set OnNodeRename : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies WebTreeView to perform auto postback OnNodeRename. ")]
public: __property System.bool get_OnNodeRename();
public: __property void set_OnNodeRename(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies WebTreeView to perform auto postback OnNodeRename. ")]
public:
property System.bool OnNodeRename {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewAutoPostBackSettings Class
WebTreeViewAutoPostBackSettings Members


OnNodeSelectChanged Property

[image]
Intersoft WebTreeView Documentation
OnNodeSelectChanged Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewAutoPostBackSettings Class : OnNodeSelectChanged Property

Glossary Item Box

Specifies whether WebTreeView will performed postback automatically when SelectChanged is executed successfully.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies WebTreeView to perform auto postback OnNodeSelectedChanged. ")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property OnNodeSelectChanged As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewAutoPostBackSettings
Dim value As System.Boolean

instance.OnNodeSelectChanged = value

value = instance.OnNodeSelectChanged
C#
[System.ComponentModel.DescriptionAttribute("Specifies WebTreeView to perform auto postback OnNodeSelectedChanged. ")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.bool OnNodeSelectChanged {get; set;}
Delphi
public read-write property OnNodeSelectChanged: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Specifies WebTreeView to perform auto postback OnNodeSelectedChanged. ")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set OnNodeSelectChanged : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies WebTreeView to perform auto postback OnNodeSelectedChanged. ")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.bool get_OnNodeSelectChanged();
public: __property void set_OnNodeSelectChanged(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies WebTreeView to perform auto postback OnNodeSelectedChanged. ")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.bool OnNodeSelectChanged {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewAutoPostBackSettings Class
WebTreeViewAutoPostBackSettings Members


WebTreeViewClientSideEvents Class

[image]
Intersoft WebTreeView Documentation
WebTreeViewClientSideEvents Class
Members See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace : WebTreeViewClientSideEvents Class

Glossary Item Box

A collection of WebTreeView's client-side event.

Object Model

WebTreeViewClientSideEvents Class

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("A collection of WebTreeView's client-side event.")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebTreeViewClientSideEvents
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewClientSideEvents
C#
[System.ComponentModel.DescriptionAttribute("A collection of WebTreeView's client-side event.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebTreeViewClientSideEvents : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebTreeViewClientSideEvents = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.ComponentModel.DescriptionAttribute("A collection of WebTreeView's client-side event.")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebTreeViewClientSideEvents extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("A collection of WebTreeView's client-side event.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebTreeViewClientSideEvents : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.ComponentModel.DescriptionAttribute("A collection of WebTreeView's client-side event.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebTreeViewClientSideEvents : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebTreeView.WebTreeViewClientSideEvents

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewClientSideEvents Members
ISNet.WebUI.WebTreeView Namespace


WebTreeViewClientSideEvents Class Members

[image]
Intersoft WebTreeView Documentation
WebTreeViewClientSideEvents Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebTreeView Namespace : WebTreeViewClientSideEvents Class

Glossary Item Box

The following tables list the members exposed by WebTreeViewClientSideEvents.

Public Constructors

 | Name | Description
Public Constructor | WebTreeViewClientSideEvents Constructor | Overloaded. Initializes a new instance of WebTreeViewClientSideEvents class.
Top

Public Properties

 | Name | Description
Public Property | OnDragDrop | Specifies the client side (JavaScript) function name that will be invoked when selected nodes are successfully dropped into valid target node. Specifies the client side (JavaScript) function name that will be invoked when selected nodes are successfully dropped into valid target node. Parameters (controlId, dragData, dropContext).
Public Property | OnDragEnd | Specifies the client side (JavaScript) function name that will be invoked when drag operation is ended regardless of the drop status. Specifies the client side (JavaScript) function name that will be invoked when drag operation is ended regardless of the drop status. Parameters (controlId, dragObject).
Public Property | OnDragQuery | Specifies the client side (JavaScript) function name that will be invoked when the drag operation requires to query the state and information about the target node. Specifies the client side (JavaScript) function name that will be invoked when the drag operation requires to query the state and information about the target node. Parameters (controlId, dragEventArgs, dropContext).
Public Property | OnDragStart | Specifies the client side (JavaScript) function name that will be invoked when node is dragged using left mouse button. Specifies the client side (JavaScript) function name that will be invoked when the drag operation requires to query the state and information about the target node. Parameters (controlId, dragEventArgs, dropContext)
Public Property | OnInitialize | Specifies the client side (JavaScript) function name that will be invoked when control is initialized. Specifies the client-side (Javascript) function that will be invoked when the control is initialized. Parameters (controlId).
Public Property | OnNodeAdd | Specifies the client side (JavaScript) function name that will be invoked when node checked is changed. Specifies the client-side (Javascript) function that will be invoked when a node is added.
Public Property | OnNodeCheckedChanged | Specifies the client side (JavaScript) function name that will be invoked when node checked is changed. Specifies the client-side (JavaScript) function that will be invoked when the state of a node's checkbox is changed. Parameters (controlId, object).
Public Property | OnNodeCollapse | Specifies the client side (JavaScript) function name that will be invoked when node is collapsed. Specifies the client-side (JavaScript) function that will be invoked when node is collapsed. Parameters (controlId, node).
Public Property | OnNodeContextMenu | Specifies the client side (JavaScript) function name that will be invoked when node is right clicked. Specifies the client-side (JavaScript) function that will be invoked when node is right clicked. Parameters (controlId, object).
Public Property | OnNodeDelete |
Public Property | OnNodeDoubleClick |
Public Property | OnNodeEdit | Specifies the client side (JavaScript) function name that will be invoked when node checked is changed. Specifies the client-side (Javascript) function that will be invoked when a node is edited. Parameters (node, oldText)
Public Property | OnNodeExpand | Specifies the client side (JavaScript) function name that will be invoked when node is expanded. Specifies the client-side (JavaScript) function that will be invoked when node is expanded. Parameters (controlId, node).
Public Property | OnNodeMove | Specifies the client side (JavaScript) function name that will be invoked when node is moved. Specifies the client-side (JavaScript) function that will be invoked when node is moved. Parameters (controlId, node).
Public Property | OnNodeRename | Specifies the client side (JavaScript) function name that will be invoked when node name is renamed. Specifies the client-side (JavaScript) function that will be invoked when node is renamed. Parameters (controlId, node, oldName, newName).
Public Property | OnNodeSelect | Specifies the client side (JavaScript) function name that will be invoked when node is selected. Specifies the client-side (JavaScript) function that will be invoked when node is selected. Parameters (controlId, node).
Public Property | OnUnload | Specifies the client side (JavaScript) function name that will be invoked when control is unload. Specifies the client-side (JavaScript) function that will be invoked when control is unloaded. Parameters (controlId).
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

Protected Methods

 | Name | Description
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | IsInSerializationContext | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebTreeViewClientSideEvents Class
ISNet.WebUI.WebTreeView Namespace


WebTreeViewClientSideEvents Constructor

[image]
Intersoft WebTreeView Documentation
WebTreeViewClientSideEvents Constructor
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewClientSideEvents Class : WebTreeViewClientSideEvents Constructor

Glossary Item Box

Initializes a new instance of WebTreeViewClientSideEvents class.

Overload List

Overload | Description
WebTreeViewClientSideEvents Constructor() |
WebTreeViewClientSideEvents Constructor(SerializationInfo,StreamingContext) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewClientSideEvents Class
WebTreeViewClientSideEvents Members


WebTreeViewClientSideEvents Constructor()

[image]
Intersoft WebTreeView Documentation
WebTreeViewClientSideEvents Constructor()
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewClientSideEvents Class > WebTreeViewClientSideEvents Constructor : WebTreeViewClientSideEvents Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("tializes a new instance of WebTreeViewClientSideEvents class. ")>
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebTreeViewClientSideEvents()
C#
[System.ComponentModel.DescriptionAttribute("tializes a new instance of WebTreeViewClientSideEvents class. ")]
public WebTreeViewClientSideEvents()
Delphi
public WebTreeViewClientSideEvents();
JScript
System.ComponentModel.DescriptionAttribute("tializes a new instance of WebTreeViewClientSideEvents class. ")
public function WebTreeViewClientSideEvents();
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("tializes a new instance of WebTreeViewClientSideEvents class. ")]
public: WebTreeViewClientSideEvents();
C++/CLI
[System.ComponentModel.DescriptionAttribute("tializes a new instance of WebTreeViewClientSideEvents class. ")]
public:
WebTreeViewClientSideEvents();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewClientSideEvents Class
WebTreeViewClientSideEvents Members
Overload List


WebTreeViewClientSideEvents Constructor(SerializationInfo,StreamingContext)

[image]
Intersoft WebTreeView Documentation
WebTreeViewClientSideEvents Constructor(SerializationInfo,StreamingContext)
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewClientSideEvents Class > WebTreeViewClientSideEvents Constructor : WebTreeViewClientSideEvents Constructor(SerializationInfo,StreamingContext)

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

Dim instance As New WebTreeViewClientSideEvents(info, context)
C#
protected WebTreeViewClientSideEvents(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
protected WebTreeViewClientSideEvents(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
protected function WebTreeViewClientSideEvents(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
protected: WebTreeViewClientSideEvents(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
protected:
WebTreeViewClientSideEvents(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewClientSideEvents Class
WebTreeViewClientSideEvents Members
Overload List


WebTreeViewClientSideEvents Class Properties

[image]
Intersoft WebTreeView Documentation
WebTreeViewClientSideEvents Class Properties
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace : WebTreeViewClientSideEvents Class

Glossary Item Box

For a list of all members of this type, see WebTreeViewClientSideEvents members.

Public Properties

 | Name | Description
Public Property | OnDragDrop | Specifies the client side (JavaScript) function name that will be invoked when selected nodes are successfully dropped into valid target node. Specifies the client side (JavaScript) function name that will be invoked when selected nodes are successfully dropped into valid target node. Parameters (controlId, dragData, dropContext).
Public Property | OnDragEnd | Specifies the client side (JavaScript) function name that will be invoked when drag operation is ended regardless of the drop status. Specifies the client side (JavaScript) function name that will be invoked when drag operation is ended regardless of the drop status. Parameters (controlId, dragObject).
Public Property | OnDragQuery | Specifies the client side (JavaScript) function name that will be invoked when the drag operation requires to query the state and information about the target node. Specifies the client side (JavaScript) function name that will be invoked when the drag operation requires to query the state and information about the target node. Parameters (controlId, dragEventArgs, dropContext).
Public Property | OnDragStart | Specifies the client side (JavaScript) function name that will be invoked when node is dragged using left mouse button. Specifies the client side (JavaScript) function name that will be invoked when the drag operation requires to query the state and information about the target node. Parameters (controlId, dragEventArgs, dropContext)
Public Property | OnInitialize | Specifies the client side (JavaScript) function name that will be invoked when control is initialized. Specifies the client-side (Javascript) function that will be invoked when the control is initialized. Parameters (controlId).
Public Property | OnNodeAdd | Specifies the client side (JavaScript) function name that will be invoked when node checked is changed. Specifies the client-side (Javascript) function that will be invoked when a node is added.
Public Property | OnNodeCheckedChanged | Specifies the client side (JavaScript) function name that will be invoked when node checked is changed. Specifies the client-side (JavaScript) function that will be invoked when the state of a node's checkbox is changed. Parameters (controlId, object).
Public Property | OnNodeCollapse | Specifies the client side (JavaScript) function name that will be invoked when node is collapsed. Specifies the client-side (JavaScript) function that will be invoked when node is collapsed. Parameters (controlId, node).
Public Property | OnNodeContextMenu | Specifies the client side (JavaScript) function name that will be invoked when node is right clicked. Specifies the client-side (JavaScript) function that will be invoked when node is right clicked. Parameters (controlId, object).
Public Property | OnNodeDelete |
Public Property | OnNodeDoubleClick |
Public Property | OnNodeEdit | Specifies the client side (JavaScript) function name that will be invoked when node checked is changed. Specifies the client-side (Javascript) function that will be invoked when a node is edited. Parameters (node, oldText)
Public Property | OnNodeExpand | Specifies the client side (JavaScript) function name that will be invoked when node is expanded. Specifies the client-side (JavaScript) function that will be invoked when node is expanded. Parameters (controlId, node).
Public Property | OnNodeMove | Specifies the client side (JavaScript) function name that will be invoked when node is moved. Specifies the client-side (JavaScript) function that will be invoked when node is moved. Parameters (controlId, node).
Public Property | OnNodeRename | Specifies the client side (JavaScript) function name that will be invoked when node name is renamed. Specifies the client-side (JavaScript) function that will be invoked when node is renamed. Parameters (controlId, node, oldName, newName).
Public Property | OnNodeSelect | Specifies the client side (JavaScript) function name that will be invoked when node is selected. Specifies the client-side (JavaScript) function that will be invoked when node is selected. Parameters (controlId, node).
Public Property | OnUnload | Specifies the client side (JavaScript) function name that will be invoked when control is unload. Specifies the client-side (JavaScript) function that will be invoked when control is unloaded. Parameters (controlId).
Top

See Also

Reference

WebTreeViewClientSideEvents Class
ISNet.WebUI.WebTreeView Namespace


OnDragDrop Property

[image]
Intersoft WebTreeView Documentation
OnDragDrop Property
See Also Example Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewClientSideEvents Class : OnDragDrop Property

Glossary Item Box

Specifies the client side (JavaScript) function name that will be invoked when selected nodes are successfully dropped into valid target node. Specifies the client side (JavaScript) function name that will be invoked when selected nodes are successfully dropped into valid target node. Parameters (controlId, dragData, dropContext).

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.EventParameterAttribute("controlId, dragData, dropContext")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when selected nodes are successfully dropped into valid target node. Parameters (controlId, dragData, dropContext)")>
Public Property OnDragDrop As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewClientSideEvents
Dim value As System.String

instance.OnDragDrop = value

value = instance.OnDragDrop
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId, dragData, dropContext")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when selected nodes are successfully dropped into valid target node. Parameters (controlId, dragData, dropContext)")]
public System.string OnDragDrop {get; set;}
Delphi
public read-write property OnDragDrop: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.EventParameterAttribute("controlId, dragData, dropContext")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when selected nodes are successfully dropped into valid target node. Parameters (controlId, dragData, dropContext)")
public function get,set OnDragDrop : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId, dragData, dropContext")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when selected nodes are successfully dropped into valid target node. Parameters (controlId, dragData, dropContext)")]
public: __property System.string* get_OnDragDrop();
public: __property void set_OnDragDrop(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId, dragData, dropContext")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when selected nodes are successfully dropped into valid target node. Parameters (controlId, dragData, dropContext)")]
public:
property System.String^ OnDragDrop {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default is null.

Remarks

Parameters :
  • controlId - string

Example

C# Copy Code
function OnDragDrop(controlId, dragData, dropContext)
{
    // do some action here
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewClientSideEvents Class
WebTreeViewClientSideEvents Members


OnDragEnd Property

[image]
Intersoft WebTreeView Documentation
OnDragEnd Property
See Also Example Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewClientSideEvents Class : OnDragEnd Property

Glossary Item Box

Specifies the client side (JavaScript) function name that will be invoked when drag operation is ended regardless of the drop status. Specifies the client side (JavaScript) function name that will be invoked when drag operation is ended regardless of the drop status. Parameters (controlId, dragObject).

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when drag operation is ended regardless of the drop status. Parameters (controlId, dragObject)")>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.EventParameterAttribute("controlId, dragObject")>
Public Property OnDragEnd As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewClientSideEvents
Dim value As System.String

instance.OnDragEnd = value

value = instance.OnDragEnd
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when drag operation is ended regardless of the drop status. Parameters (controlId, dragObject)")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId, dragObject")]
public System.string OnDragEnd {get; set;}
Delphi
public read-write property OnDragEnd: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when drag operation is ended regardless of the drop status. Parameters (controlId, dragObject)")
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.EventParameterAttribute("controlId, dragObject")
public function get,set OnDragEnd : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when drag operation is ended regardless of the drop status. Parameters (controlId, dragObject)")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId, dragObject")]
public: __property System.string* get_OnDragEnd();
public: __property void set_OnDragEnd(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when drag operation is ended regardless of the drop status. Parameters (controlId, dragObject)")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId, dragObject")]
public:
property System.String^ OnDragEnd {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default is null.

Remarks

Parameters :
  • controlId - string

Example

C# Copy Code
function OnDragEnd(controlId, dragObject)
{
    // do some action here
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewClientSideEvents Class
WebTreeViewClientSideEvents Members


OnDragQuery Property

[image]
Intersoft WebTreeView Documentation
OnDragQuery Property
See Also Example Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewClientSideEvents Class : OnDragQuery Property

Glossary Item Box

Specifies the client side (JavaScript) function name that will be invoked when the drag operation requires to query the state and information about the target node. Specifies the client side (JavaScript) function name that will be invoked when the drag operation requires to query the state and information about the target node. Parameters (controlId, dragEventArgs, dropContext).

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.EventParameterAttribute("controlId, dragEventArgs, dropContext")>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when the drag operation requires to query the state and information about the target node. Parameters (controlId, dragEventArgs, dropContext)")>
Public Property OnDragQuery As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewClientSideEvents
Dim value As System.String

instance.OnDragQuery = value

value = instance.OnDragQuery
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId, dragEventArgs, dropContext")]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when the drag operation requires to query the state and information about the target node. Parameters (controlId, dragEventArgs, dropContext)")]
public System.string OnDragQuery {get; set;}
Delphi
public read-write property OnDragQuery: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.EventParameterAttribute("controlId, dragEventArgs, dropContext")
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when the drag operation requires to query the state and information about the target node. Parameters (controlId, dragEventArgs, dropContext)")
public function get,set OnDragQuery : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId, dragEventArgs, dropContext")]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when the drag operation requires to query the state and information about the target node. Parameters (controlId, dragEventArgs, dropContext)")]
public: __property System.string* get_OnDragQuery();
public: __property void set_OnDragQuery(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId, dragEventArgs, dropContext")]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when the drag operation requires to query the state and information about the target node. Parameters (controlId, dragEventArgs, dropContext)")]
public:
property System.String^ OnDragQuery {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default is null.

Remarks

Parameters :
  • controlId - string

Example

C# Copy Code
function OnDragQuery(controlId, dragEventArgs, dropContext)
{
    // do some action here
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewClientSideEvents Class
WebTreeViewClientSideEvents Members


OnDragStart Property

[image]
Intersoft WebTreeView Documentation
OnDragStart Property
See Also Example Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewClientSideEvents Class : OnDragStart Property

Glossary Item Box

Specifies the client side (JavaScript) function name that will be invoked when node is dragged using left mouse button.

Specifies the client side (JavaScript) function name that will be invoked when the drag operation requires to query the state and information about the target node. Parameters (controlId, dragEventArgs, dropContext)

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when node is dragged using left mouse button. Parameters (controlId, dragObject)")>
<ISNet.EventParameterAttribute("controlId, dragObject")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property OnDragStart As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewClientSideEvents
Dim value As System.String

instance.OnDragStart = value

value = instance.OnDragStart
C#
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when node is dragged using left mouse button. Parameters (controlId, dragObject)")]
[ISNet.EventParameterAttribute("controlId, dragObject")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string OnDragStart {get; set;}
Delphi
public read-write property OnDragStart: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when node is dragged using left mouse button. Parameters (controlId, dragObject)")
ISNet.EventParameterAttribute("controlId, dragObject")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set OnDragStart : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when node is dragged using left mouse button. Parameters (controlId, dragObject)")]
[ISNet.EventParameterAttribute("controlId, dragObject")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_OnDragStart();
public: __property void set_OnDragStart(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when node is dragged using left mouse button. Parameters (controlId, dragObject)")]
[ISNet.EventParameterAttribute("controlId, dragObject")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ OnDragStart {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default is null.

Remarks

Parameters :
  • controlId - string

Example

C# Copy Code
function OnDragStart(controlId, dragObject)
{
    // do some action here
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewClientSideEvents Class
WebTreeViewClientSideEvents Members


OnInitialize Property

[image]
Intersoft WebTreeView Documentation
OnInitialize Property
See Also Example Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewClientSideEvents Class : OnInitialize Property

Glossary Item Box

Specifies the client side (JavaScript) function name that will be invoked when control is initialized. Specifies the client-side (Javascript) function that will be invoked when the control is initialized. Parameters (controlId).

Syntax

Visual Basic (Declaration)
<ISNet.EventParameterAttribute("controlId")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when control is initialized. Parameters (controlId)")>
Public Property OnInitialize As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewClientSideEvents
Dim value As System.String

instance.OnInitialize = value

value = instance.OnInitialize
C#
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when control is initialized. Parameters (controlId)")]
public System.string OnInitialize {get; set;}
Delphi
public read-write property OnInitialize: System.String;
JScript
ISNet.EventParameterAttribute("controlId")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when control is initialized. Parameters (controlId)")
public function get,set OnInitialize : System.String
Managed Extensions for C++
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when control is initialized. Parameters (controlId)")]
public: __property System.string* get_OnInitialize();
public: __property void set_OnInitialize(
   System.string* value
);
C++/CLI
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when control is initialized. Parameters (controlId)")]
public:
property System.String^ OnInitialize {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default is null.

Remarks

Parameters :
  • controlId - string

Example

C# Copy Code
function doInitialize(controlId)
{
    // do some action here
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewClientSideEvents Class
WebTreeViewClientSideEvents Members


OnNodeAdd Property

[image]
Intersoft WebTreeView Documentation
OnNodeAdd Property
See Also Example Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewClientSideEvents Class : OnNodeAdd Property

Glossary Item Box

Specifies the client side (JavaScript) function name that will be invoked when node checked is changed. Specifies the client-side (Javascript) function that will be invoked when a node is added.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when node checked is changed. Parameters (controlId, object)")>
<ISNet.EventParameterAttribute("controlId, node")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
Public Property OnNodeAdd As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewClientSideEvents
Dim value As System.String

instance.OnNodeAdd = value

value = instance.OnNodeAdd
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when node checked is changed. Parameters (controlId, object)")]
[ISNet.EventParameterAttribute("controlId, node")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public System.string OnNodeAdd {get; set;}
Delphi
public read-write property OnNodeAdd: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when node checked is changed. Parameters (controlId, object)")
ISNet.EventParameterAttribute("controlId, node")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
public function get,set OnNodeAdd : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when node checked is changed. Parameters (controlId, object)")]
[ISNet.EventParameterAttribute("controlId, node")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public: __property System.string* get_OnNodeAdd();
public: __property void set_OnNodeAdd(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when node checked is changed. Parameters (controlId, object)")]
[ISNet.EventParameterAttribute("controlId, node")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public:
property System.String^ OnNodeAdd {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default is null.

Remarks

Parameters :
  • controlId - string

Example

C# Copy Code
function doNodeAdd(controlId, node)
{
    // do some action here
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewClientSideEvents Class
WebTreeViewClientSideEvents Members


OnNodeCheckedChanged Property

[image]
Intersoft WebTreeView Documentation
OnNodeCheckedChanged Property
See Also Example Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewClientSideEvents Class : OnNodeCheckedChanged Property

Glossary Item Box

Specifies the client side (JavaScript) function name that will be invoked when node checked is changed. Specifies the client-side (JavaScript) function that will be invoked when the state of a node's checkbox is changed. Parameters (controlId, object).

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when node checked is changed. Parameters (controlId, object)")>
<ISNet.EventParameterAttribute("controlId, node")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property OnNodeCheckedChanged As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewClientSideEvents
Dim value As System.String

instance.OnNodeCheckedChanged = value

value = instance.OnNodeCheckedChanged
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when node checked is changed. Parameters (controlId, object)")]
[ISNet.EventParameterAttribute("controlId, node")]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string OnNodeCheckedChanged {get; set;}
Delphi
public read-write property OnNodeCheckedChanged: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when node checked is changed. Parameters (controlId, object)")
ISNet.EventParameterAttribute("controlId, node")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set OnNodeCheckedChanged : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when node checked is changed. Parameters (controlId, object)")]
[ISNet.EventParameterAttribute("controlId, node")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_OnNodeCheckedChanged();
public: __property void set_OnNodeCheckedChanged(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when node checked is changed. Parameters (controlId, object)")]
[ISNet.EventParameterAttribute("controlId, node")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ OnNodeCheckedChanged {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default is null.

Remarks

Parameters :
  • controlId - string

Example

C# Copy Code
function doNodeCheckedChanged(controlId, node)
{
    // do some action here
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewClientSideEvents Class
WebTreeViewClientSideEvents Members


OnNodeCollapse Property

[image]
Intersoft WebTreeView Documentation
OnNodeCollapse Property
See Also Example Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewClientSideEvents Class : OnNodeCollapse Property

Glossary Item Box

Specifies the client side (JavaScript) function name that will be invoked when node is collapsed. Specifies the client-side (JavaScript) function that will be invoked when node is collapsed. Parameters (controlId, node).

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.EventParameterAttribute("controlId, node")>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when node is collapsed. Parameters (controlId, node)")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property OnNodeCollapse As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewClientSideEvents
Dim value As System.String

instance.OnNodeCollapse = value

value = instance.OnNodeCollapse
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, node")]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when node is collapsed. Parameters (controlId, node)")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string OnNodeCollapse {get; set;}
Delphi
public read-write property OnNodeCollapse: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.EventParameterAttribute("controlId, node")
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when node is collapsed. Parameters (controlId, node)")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set OnNodeCollapse : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, node")]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when node is collapsed. Parameters (controlId, node)")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_OnNodeCollapse();
public: __property void set_OnNodeCollapse(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, node")]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when node is collapsed. Parameters (controlId, node)")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ OnNodeCollapse {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default is null.

Remarks

Parameters :
  • controlId - string

Example

C# Copy Code
function doNodeCollapse(controlId, node)
{
    // do some action here
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewClientSideEvents Class
WebTreeViewClientSideEvents Members


OnNodeContextMenu Property

[image]
Intersoft WebTreeView Documentation
OnNodeContextMenu Property
See Also Example Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewClientSideEvents Class : OnNodeContextMenu Property

Glossary Item Box

Specifies the client side (JavaScript) function name that will be invoked when node is right clicked. Specifies the client-side (JavaScript) function that will be invoked when node is right clicked. Parameters (controlId, object).

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when node is right clicked. Parameters (controlId, object)")>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.EventParameterAttribute("controlId, node")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property OnNodeContextMenu As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewClientSideEvents
Dim value As System.String

instance.OnNodeContextMenu = value

value = instance.OnNodeContextMenu
C#
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when node is right clicked. Parameters (controlId, object)")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, node")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string OnNodeContextMenu {get; set;}
Delphi
public read-write property OnNodeContextMenu: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when node is right clicked. Parameters (controlId, object)")
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.EventParameterAttribute("controlId, node")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set OnNodeContextMenu : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when node is right clicked. Parameters (controlId, object)")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, node")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_OnNodeContextMenu();
public: __property void set_OnNodeContextMenu(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when node is right clicked. Parameters (controlId, object)")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, node")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ OnNodeContextMenu {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default is null.

Remarks

Parameters :
  • controlId - string

Example

C# Copy Code
function doNodeCheckedChanged(controlId, node)
{
    // do some action here
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewClientSideEvents Class
WebTreeViewClientSideEvents Members


OnNodeDelete Property

[image]
Intersoft WebTreeView Documentation
OnNodeDelete Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewClientSideEvents Class : OnNodeDelete Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when node is deleted. Parameters (controlId, node)")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.EventParameterAttribute("controlId, node")>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
Public Property OnNodeDelete As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewClientSideEvents
Dim value As System.String

instance.OnNodeDelete = value

value = instance.OnNodeDelete
C#
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when node is deleted. Parameters (controlId, node)")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, node")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public System.string OnNodeDelete {get; set;}
Delphi
public read-write property OnNodeDelete: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when node is deleted. Parameters (controlId, node)")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.EventParameterAttribute("controlId, node")
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
public function get,set OnNodeDelete : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when node is deleted. Parameters (controlId, node)")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, node")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public: __property System.string* get_OnNodeDelete();
public: __property void set_OnNodeDelete(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when node is deleted. Parameters (controlId, node)")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, node")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public:
property System.String^ OnNodeDelete {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewClientSideEvents Class
WebTreeViewClientSideEvents Members


OnNodeDoubleClick Property

[image]
Intersoft WebTreeView Documentation
OnNodeDoubleClick Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewClientSideEvents Class : OnNodeDoubleClick Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.EventParameterAttribute("controlId, node")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when node is double clicked. Parameters (controlId, object)")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
Public Property OnNodeDoubleClick As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewClientSideEvents
Dim value As System.String

instance.OnNodeDoubleClick = value

value = instance.OnNodeDoubleClick
C#
[ISNet.EventParameterAttribute("controlId, node")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when node is double clicked. Parameters (controlId, object)")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public System.string OnNodeDoubleClick {get; set;}
Delphi
public read-write property OnNodeDoubleClick: System.String;
JScript
ISNet.EventParameterAttribute("controlId, node")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when node is double clicked. Parameters (controlId, object)")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
public function get,set OnNodeDoubleClick : System.String
Managed Extensions for C++
[ISNet.EventParameterAttribute("controlId, node")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when node is double clicked. Parameters (controlId, object)")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public: __property System.string* get_OnNodeDoubleClick();
public: __property void set_OnNodeDoubleClick(
   System.string* value
);
C++/CLI
[ISNet.EventParameterAttribute("controlId, node")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when node is double clicked. Parameters (controlId, object)")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public:
property System.String^ OnNodeDoubleClick {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewClientSideEvents Class
WebTreeViewClientSideEvents Members


OnNodeEdit Property

[image]
Intersoft WebTreeView Documentation
OnNodeEdit Property
See Also Example Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewClientSideEvents Class : OnNodeEdit Property

Glossary Item Box

Specifies the client side (JavaScript) function name that will be invoked when node checked is changed. Specifies the client-side (Javascript) function that will be invoked when a node is edited. Parameters (node, oldText)

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.EventParameterAttribute("controlId, node")>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when node checked is changed. Parameters (controlId, object)")>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property OnNodeEdit As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewClientSideEvents
Dim value As System.String

instance.OnNodeEdit = value

value = instance.OnNodeEdit
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, node")]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when node checked is changed. Parameters (controlId, object)")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string OnNodeEdit {get; set;}
Delphi
public read-write property OnNodeEdit: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.EventParameterAttribute("controlId, node")
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when node checked is changed. Parameters (controlId, object)")
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set OnNodeEdit : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, node")]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when node checked is changed. Parameters (controlId, object)")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_OnNodeEdit();
public: __property void set_OnNodeEdit(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, node")]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when node checked is changed. Parameters (controlId, object)")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ OnNodeEdit {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default is null.

Remarks

Parameters :
  • controlId - string

Example

C# Copy Code
function doNodeAdd(controlId, node)
{
    // do some action here
}
C# Copy Code
function doNodeEdit(node, oldText)
        {
            // do some action here
        }

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewClientSideEvents Class
WebTreeViewClientSideEvents Members


OnNodeExpand Property

[image]
Intersoft WebTreeView Documentation
OnNodeExpand Property
See Also Example Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewClientSideEvents Class : OnNodeExpand Property

Glossary Item Box

Specifies the client side (JavaScript) function name that will be invoked when node is expanded. Specifies the client-side (JavaScript) function that will be invoked when node is expanded. Parameters (controlId, node).

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.EventParameterAttribute("controlId, node")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when control is clicked. Parameters (controlId, node)")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
Public Property OnNodeExpand As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewClientSideEvents
Dim value As System.String

instance.OnNodeExpand = value

value = instance.OnNodeExpand
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId, node")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when control is clicked. Parameters (controlId, node)")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public System.string OnNodeExpand {get; set;}
Delphi
public read-write property OnNodeExpand: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.EventParameterAttribute("controlId, node")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when control is clicked. Parameters (controlId, node)")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
public function get,set OnNodeExpand : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId, node")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when control is clicked. Parameters (controlId, node)")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public: __property System.string* get_OnNodeExpand();
public: __property void set_OnNodeExpand(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId, node")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when control is clicked. Parameters (controlId, node)")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public:
property System.String^ OnNodeExpand {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default is null.

Remarks

Parameters :
  • controlId - string

Example

C# Copy Code
function doNodeExpand(controlId, node)
{
    // do some action here
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewClientSideEvents Class
WebTreeViewClientSideEvents Members


OnNodeMove Property

[image]
Intersoft WebTreeView Documentation
OnNodeMove Property
See Also Example Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewClientSideEvents Class : OnNodeMove Property

Glossary Item Box

Specifies the client side (JavaScript) function name that will be invoked when node is moved. Specifies the client-side (JavaScript) function that will be invoked when node is moved. Parameters (controlId, node).

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when control is clicked. Parameters (controlId, node)")>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.EventParameterAttribute("controlId, node")>
Public Property OnNodeMove As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewClientSideEvents
Dim value As System.String

instance.OnNodeMove = value

value = instance.OnNodeMove
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when control is clicked. Parameters (controlId, node)")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, node")]
public System.string OnNodeMove {get; set;}
Delphi
public read-write property OnNodeMove: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when control is clicked. Parameters (controlId, node)")
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.EventParameterAttribute("controlId, node")
public function get,set OnNodeMove : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when control is clicked. Parameters (controlId, node)")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, node")]
public: __property System.string* get_OnNodeMove();
public: __property void set_OnNodeMove(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when control is clicked. Parameters (controlId, node)")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, node")]
public:
property System.String^ OnNodeMove {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default is null.

Remarks

Parameters :
  • controlId - string

Example

C# Copy Code
function doNodeMove(controlId, node)
{
    // do some action here
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewClientSideEvents Class
WebTreeViewClientSideEvents Members


OnNodeRename Property

[image]
Intersoft WebTreeView Documentation
OnNodeRename Property
See Also Example Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewClientSideEvents Class : OnNodeRename Property

Glossary Item Box

Specifies the client side (JavaScript) function name that will be invoked when node name is renamed. Specifies the client-side (JavaScript) function that will be invoked when node is renamed. Parameters (controlId, node, oldName, newName).

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.EventParameterAttribute("controlId, node, oldName, newName")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when node name is renamed. Parameters (controlId, node, oldName, newName)")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property OnNodeRename As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewClientSideEvents
Dim value As System.String

instance.OnNodeRename = value

value = instance.OnNodeRename
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, node, oldName, newName")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when node name is renamed. Parameters (controlId, node, oldName, newName)")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string OnNodeRename {get; set;}
Delphi
public read-write property OnNodeRename: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.EventParameterAttribute("controlId, node, oldName, newName")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when node name is renamed. Parameters (controlId, node, oldName, newName)")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set OnNodeRename : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, node, oldName, newName")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when node name is renamed. Parameters (controlId, node, oldName, newName)")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_OnNodeRename();
public: __property void set_OnNodeRename(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, node, oldName, newName")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when node name is renamed. Parameters (controlId, node, oldName, newName)")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ OnNodeRename {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default is null.

Remarks

Parameters :
  • controlId - string

Example

C# Copy Code
function doNodeRename(controlId, node, oldName, newName)
{
    // do some action here
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewClientSideEvents Class
WebTreeViewClientSideEvents Members


OnNodeSelect Property

[image]
Intersoft WebTreeView Documentation
OnNodeSelect Property
See Also Example Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewClientSideEvents Class : OnNodeSelect Property

Glossary Item Box

Specifies the client side (JavaScript) function name that will be invoked when node is selected. Specifies the client-side (JavaScript) function that will be invoked when node is selected. Parameters (controlId, node).

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when node is selected. Parameters (controlId, node)")>
<ISNet.EventParameterAttribute("controlId, node")>
Public Property OnNodeSelect As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewClientSideEvents
Dim value As System.String

instance.OnNodeSelect = value

value = instance.OnNodeSelect
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when node is selected. Parameters (controlId, node)")]
[ISNet.EventParameterAttribute("controlId, node")]
public System.string OnNodeSelect {get; set;}
Delphi
public read-write property OnNodeSelect: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when node is selected. Parameters (controlId, node)")
ISNet.EventParameterAttribute("controlId, node")
public function get,set OnNodeSelect : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when node is selected. Parameters (controlId, node)")]
[ISNet.EventParameterAttribute("controlId, node")]
public: __property System.string* get_OnNodeSelect();
public: __property void set_OnNodeSelect(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when node is selected. Parameters (controlId, node)")]
[ISNet.EventParameterAttribute("controlId, node")]
public:
property System.String^ OnNodeSelect {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default is null.

Remarks

Parameters :
  • controlId - string

Example

C# Copy Code
function doNodeSelect(controlId, node)
{
    // do some action here
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewClientSideEvents Class
WebTreeViewClientSideEvents Members


OnUnload Property

[image]
Intersoft WebTreeView Documentation
OnUnload Property
See Also Example Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewClientSideEvents Class : OnUnload Property

Glossary Item Box

Specifies the client side (JavaScript) function name that will be invoked when control is unload. Specifies the client-side (JavaScript) function that will be invoked when control is unloaded. Parameters (controlId).

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when control is unload. Parameters (controlId)")>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.EventParameterAttribute("controlId")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property OnUnload As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewClientSideEvents
Dim value As System.String

instance.OnUnload = value

value = instance.OnUnload
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when control is unload. Parameters (controlId)")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string OnUnload {get; set;}
Delphi
public read-write property OnUnload: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when control is unload. Parameters (controlId)")
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.EventParameterAttribute("controlId")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set OnUnload : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when control is unload. Parameters (controlId)")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_OnUnload();
public: __property void set_OnUnload(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when control is unload. Parameters (controlId)")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ OnUnload {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default is null.

Remarks

Parameters :
  • controlId - string

Example

C# Copy Code
function doUnload(controlId)
{
    // do some action here
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewClientSideEvents Class
WebTreeViewClientSideEvents Members


WebTreeViewDragDropEventArgs Class

[image]
Intersoft WebTreeView Documentation
WebTreeViewDragDropEventArgs Class
Members See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace : WebTreeViewDragDropEventArgs Class

Glossary Item Box

Object Model

WebTreeViewDragDropEventArgs Class

Syntax

Visual Basic (Declaration)
<System.ComponentModel.ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")>
<System.ComponentModel.DescriptionAttribute("Provides data for WebTreeView's node drag drop event.")>
Public Class WebTreeViewDragDropEventArgs
   Inherits WebTreeViewNodeEventArgs
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewDragDropEventArgs
C#
[System.ComponentModel.ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
[System.ComponentModel.DescriptionAttribute("Provides data for WebTreeView's node drag drop event.")]
public class WebTreeViewDragDropEventArgs : WebTreeViewNodeEventArgs
Delphi
public class WebTreeViewDragDropEventArgs = class(WebTreeViewNodeEventArgs)
JScript
System.ComponentModel.ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")
System.ComponentModel.DescriptionAttribute("Provides data for WebTreeView's node drag drop event.")
public class WebTreeViewDragDropEventArgs extends WebTreeViewNodeEventArgs
Managed Extensions for C++
[System.ComponentModel.ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
[System.ComponentModel.DescriptionAttribute("Provides data for WebTreeView's node drag drop event.")]
public __gc class WebTreeViewDragDropEventArgs : public WebTreeViewNodeEventArgs
C++/CLI
[System.ComponentModel.ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
[System.ComponentModel.DescriptionAttribute("Provides data for WebTreeView's node drag drop event.")]
public ref class WebTreeViewDragDropEventArgs : public WebTreeViewNodeEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
ISNet.WebUI.WebTreeView.WebTreeViewNodeEventArgs
ISNet.WebUI.WebTreeView.WebTreeViewDragDropEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewDragDropEventArgs Members
ISNet.WebUI.WebTreeView Namespace


WebTreeViewDragDropEventArgs Class Members

[image]
Intersoft WebTreeView Documentation
WebTreeViewDragDropEventArgs Class Members
See Also Properties Send Feedback
ISNet.WebUI.WebTreeView Namespace : WebTreeViewDragDropEventArgs Class

Glossary Item Box

The following tables list the members exposed by WebTreeViewDragDropEventArgs.

Public Constructors

 | Name | Description
Public Constructor | WebTreeViewDragDropEventArgs Constructor |
Top

Public Properties

 | Name | Description
Public Property | Command | Gets command of WebTreeViewNode event arguments.Determines the type of operation, such as "NodeCopy", "NodeCollapse", "Initialize", etc. (Inherited from ISNet.WebUI.WebTreeView.WebTreeViewNodeEventArgs)
Public Property | DraggedNodes | Gets dragged nodes.
Public Property | InsertionMode | Get insertion mode.
Public Property | MoveType | Gets move type.
Public Property | Node | Gets operated node.The specified node. (Inherited from ISNet.WebUI.WebTreeView.WebTreeViewNodeEventArgs)
Top

See Also

Reference

WebTreeViewDragDropEventArgs Class
ISNet.WebUI.WebTreeView Namespace


WebTreeViewDragDropEventArgs Constructor

[image]
Intersoft WebTreeView Documentation
WebTreeViewDragDropEventArgs Constructor
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewDragDropEventArgs Class : WebTreeViewDragDropEventArgs Constructor

targetNode
draggedNodes
moveType
insertionMode

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebTreeViewDragDropEventArgs class.")>
Public Function New( _
   ByVal targetNode As WebTreeViewNode, _
   ByVal draggedNodes As System.Collections.Generic.List(Of WebTreeViewNode), _
   ByVal moveType As NodeMoveType, _
   ByVal insertionMode As NodeMoveInsertionMode _
)
Visual Basic (Usage) Copy Code
Dim targetNode As WebTreeViewNode
Dim draggedNodes As System.Collections.Generic.List(Of WebTreeViewNode)
Dim moveType As NodeMoveType
Dim insertionMode As NodeMoveInsertionMode

Dim instance As New WebTreeViewDragDropEventArgs(targetNode, draggedNodes, moveType, insertionMode)
C#
[System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebTreeViewDragDropEventArgs class.")]
public WebTreeViewDragDropEventArgs(
   WebTreeViewNode targetNode,
   System.Collections.Generic.List<WebTreeViewNode> draggedNodes,
   NodeMoveType moveType,
   NodeMoveInsertionMode insertionMode
)
Delphi
public WebTreeViewDragDropEventArgs(
    targetNode: WebTreeViewNode;
    draggedNodes: System.Collections.Generic.List;
    moveType: NodeMoveType;
    insertionMode: NodeMoveInsertionMode
);
JScript
System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebTreeViewDragDropEventArgs class.")
public function WebTreeViewDragDropEventArgs(
   targetNode : WebTreeViewNode,
   draggedNodes : System.Collections.Generic.List,
   moveType : NodeMoveType,
   insertionMode : NodeMoveInsertionMode
);
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebTreeViewDragDropEventArgs class.")]
public: WebTreeViewDragDropEventArgs(
   WebTreeViewNode* targetNode,
   System.Collections.Generic.List<WebTreeViewNode*>* draggedNodes,
   NodeMoveType moveType,
   NodeMoveInsertionMode insertionMode
)
C++/CLI
[System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebTreeViewDragDropEventArgs class.")]
public:
WebTreeViewDragDropEventArgs(
   WebTreeViewNode^ targetNode,
   System.Collections.Generic.List<WebTreeViewNode^>^ draggedNodes,
   NodeMoveType moveType,
   NodeMoveInsertionMode insertionMode
)

Parameters

targetNode
draggedNodes
moveType
insertionMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewDragDropEventArgs Class
WebTreeViewDragDropEventArgs Members


WebTreeViewDragDropEventArgs Class Properties

[image]
Intersoft WebTreeView Documentation
WebTreeViewDragDropEventArgs Class Properties
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace : WebTreeViewDragDropEventArgs Class

Glossary Item Box

For a list of all members of this type, see WebTreeViewDragDropEventArgs members.

Public Properties

 | Name | Description
Public Property | Command | Gets command of WebTreeViewNode event arguments.Determines the type of operation, such as "NodeCopy", "NodeCollapse", "Initialize", etc. (Inherited from ISNet.WebUI.WebTreeView.WebTreeViewNodeEventArgs)
Public Property | DraggedNodes | Gets dragged nodes.
Public Property | InsertionMode | Get insertion mode.
Public Property | MoveType | Gets move type.
Public Property | Node | Gets operated node.The specified node. (Inherited from ISNet.WebUI.WebTreeView.WebTreeViewNodeEventArgs)
Top

See Also

Reference

WebTreeViewDragDropEventArgs Class
ISNet.WebUI.WebTreeView Namespace


DraggedNodes Property

[image]
Intersoft WebTreeView Documentation
DraggedNodes Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewDragDropEventArgs Class : DraggedNodes Property

Glossary Item Box

Gets dragged nodes.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets dragged nodes.")>
Public ReadOnly Property DraggedNodes As System.Collections.Generic.List(Of WebTreeViewNode)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewDragDropEventArgs
Dim value As System.Collections.Generic.List(Of WebTreeViewNode)

value = instance.DraggedNodes
C#
[System.ComponentModel.DescriptionAttribute("Gets dragged nodes.")]
public System.Collections.Generic.List<WebTreeViewNode> DraggedNodes {get;}
Delphi
public read-only property DraggedNodes: System.Collections.Generic.List;
JScript
System.ComponentModel.DescriptionAttribute("Gets dragged nodes.")
public function get DraggedNodes : System.Collections.Generic.List
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets dragged nodes.")]
public: __property System.Collections.Generic.List<WebTreeViewNode*>* get_DraggedNodes();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets dragged nodes.")]
public:
property System.Collections.Generic.List<WebTreeViewNode^>^ DraggedNodes {
   System.Collections.Generic.List<WebTreeViewNode^>^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewDragDropEventArgs Class
WebTreeViewDragDropEventArgs Members


InsertionMode Property

[image]
Intersoft WebTreeView Documentation
InsertionMode Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewDragDropEventArgs Class : InsertionMode Property

Glossary Item Box

Get insertion mode.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Get insertion mode.")>
Public ReadOnly Property InsertionMode As NodeMoveInsertionMode
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewDragDropEventArgs
Dim value As NodeMoveInsertionMode

value = instance.InsertionMode
C#
[System.ComponentModel.DescriptionAttribute("Get insertion mode.")]
public NodeMoveInsertionMode InsertionMode {get;}
Delphi
public read-only property InsertionMode: NodeMoveInsertionMode;
JScript
System.ComponentModel.DescriptionAttribute("Get insertion mode.")
public function get InsertionMode : NodeMoveInsertionMode
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Get insertion mode.")]
public: __property NodeMoveInsertionMode get_InsertionMode();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Get insertion mode.")]
public:
property NodeMoveInsertionMode InsertionMode {
   NodeMoveInsertionMode get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewDragDropEventArgs Class
WebTreeViewDragDropEventArgs Members


MoveType Property

[image]
Intersoft WebTreeView Documentation
MoveType Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewDragDropEventArgs Class : MoveType Property

Glossary Item Box

Gets move type.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets move type.")>
Public ReadOnly Property MoveType As NodeMoveType
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewDragDropEventArgs
Dim value As NodeMoveType

value = instance.MoveType
C#
[System.ComponentModel.DescriptionAttribute("Gets move type.")]
public NodeMoveType MoveType {get;}
Delphi
public read-only property MoveType: NodeMoveType;
JScript
System.ComponentModel.DescriptionAttribute("Gets move type.")
public function get MoveType : NodeMoveType
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets move type.")]
public: __property NodeMoveType get_MoveType();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets move type.")]
public:
property NodeMoveType MoveType {
   NodeMoveType get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewDragDropEventArgs Class
WebTreeViewDragDropEventArgs Members


WebTreeViewDragDropSettings Class

[image]
Intersoft WebTreeView Documentation
WebTreeViewDragDropSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace : WebTreeViewDragDropSettings Class

Glossary Item Box

A collection of WebTreeView drag and drop behavior settings.

Object Model

WebTreeViewDragDropSettings Class

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("A collection of WebTreeView drag and drop behavior settings. ")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebTreeViewDragDropSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewDragDropSettings
C#
[System.ComponentModel.DescriptionAttribute("A collection of WebTreeView drag and drop behavior settings. ")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebTreeViewDragDropSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebTreeViewDragDropSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.ComponentModel.DescriptionAttribute("A collection of WebTreeView drag and drop behavior settings. ")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebTreeViewDragDropSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("A collection of WebTreeView drag and drop behavior settings. ")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebTreeViewDragDropSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.ComponentModel.DescriptionAttribute("A collection of WebTreeView drag and drop behavior settings. ")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebTreeViewDragDropSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebTreeView.WebTreeViewDragDropSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewDragDropSettings Members
ISNet.WebUI.WebTreeView Namespace

Concepts

Drag and Drop


WebTreeViewDragDropSettings Class Members

[image]
Intersoft WebTreeView Documentation
WebTreeViewDragDropSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebTreeView Namespace : WebTreeViewDragDropSettings Class

Glossary Item Box

The following tables list the members exposed by WebTreeViewDragDropSettings.

Public Constructors

 | Name | Description
Public Constructor | WebTreeViewDragDropSettings Constructor | Overloaded. Initializes a new instance of WebTreeViewDragDropSettings class.
Top

Public Properties

 | Name | Description
Public Property | AllowChildDrop | Determines that only child nodes are allowed to be dropped.
Public Property | AllowLeafDrop | Determines whether a leaf type node can be set as a node dropping target.
Public Property | AllowRootDrop | Determines whether a node can be dropped as a root.
Public Property | AllowSiblingDrop | Determines whether a node can be dropped as sibling node (node on the same level).
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

Protected Methods

 | Name | Description
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | IsInSerializationContext | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebTreeViewDragDropSettings Class
ISNet.WebUI.WebTreeView Namespace

Concepts

Drag and Drop


WebTreeViewDragDropSettings Constructor

[image]
Intersoft WebTreeView Documentation
WebTreeViewDragDropSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewDragDropSettings Class : WebTreeViewDragDropSettings Constructor

Glossary Item Box

Initializes a new instance of WebTreeViewDragDropSettings class.

Overload List

Overload | Description
WebTreeViewDragDropSettings Constructor() |
WebTreeViewDragDropSettings Constructor(SerializationInfo,StreamingContext) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewDragDropSettings Class
WebTreeViewDragDropSettings Members


WebTreeViewDragDropSettings Constructor()

[image]
Intersoft WebTreeView Documentation
WebTreeViewDragDropSettings Constructor()
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewDragDropSettings Class > WebTreeViewDragDropSettings Constructor : WebTreeViewDragDropSettings Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("A collection of WebTreeView drag and drop behavior settings. ")>
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebTreeViewDragDropSettings()
C#
[System.ComponentModel.DescriptionAttribute("A collection of WebTreeView drag and drop behavior settings. ")]
public WebTreeViewDragDropSettings()
Delphi
public WebTreeViewDragDropSettings();
JScript
System.ComponentModel.DescriptionAttribute("A collection of WebTreeView drag and drop behavior settings. ")
public function WebTreeViewDragDropSettings();
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("A collection of WebTreeView drag and drop behavior settings. ")]
public: WebTreeViewDragDropSettings();
C++/CLI
[System.ComponentModel.DescriptionAttribute("A collection of WebTreeView drag and drop behavior settings. ")]
public:
WebTreeViewDragDropSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewDragDropSettings Class
WebTreeViewDragDropSettings Members
Overload List


WebTreeViewDragDropSettings Constructor(SerializationInfo,StreamingContext)

[image]
Intersoft WebTreeView Documentation
WebTreeViewDragDropSettings Constructor(SerializationInfo,StreamingContext)
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewDragDropSettings Class > WebTreeViewDragDropSettings Constructor : WebTreeViewDragDropSettings Constructor(SerializationInfo,StreamingContext)

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

Dim instance As New WebTreeViewDragDropSettings(info, context)
C#
protected WebTreeViewDragDropSettings(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
protected WebTreeViewDragDropSettings(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
protected function WebTreeViewDragDropSettings(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
protected: WebTreeViewDragDropSettings(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
protected:
WebTreeViewDragDropSettings(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewDragDropSettings Class
WebTreeViewDragDropSettings Members
Overload List


WebTreeViewDragDropSettings Class Properties

[image]
Intersoft WebTreeView Documentation
WebTreeViewDragDropSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace : WebTreeViewDragDropSettings Class

Glossary Item Box

For a list of all members of this type, see WebTreeViewDragDropSettings members.

Public Properties

 | Name | Description
Public Property | AllowChildDrop | Determines that only child nodes are allowed to be dropped.
Public Property | AllowLeafDrop | Determines whether a leaf type node can be set as a node dropping target.
Public Property | AllowRootDrop | Determines whether a node can be dropped as a root.
Public Property | AllowSiblingDrop | Determines whether a node can be dropped as sibling node (node on the same level).
Top

See Also

Reference

WebTreeViewDragDropSettings Class
ISNet.WebUI.WebTreeView Namespace

Concepts

Drag and Drop


AllowChildDrop Property

[image]
Intersoft WebTreeView Documentation
AllowChildDrop Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewDragDropSettings Class : AllowChildDrop Property

Glossary Item Box

Determines that only child nodes are allowed to be dropped.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Determines that only child nodes are allowed to be dropped.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property AllowChildDrop As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewDragDropSettings
Dim value As System.Boolean

instance.AllowChildDrop = value

value = instance.AllowChildDrop
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines that only child nodes are allowed to be dropped.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.bool AllowChildDrop {get; set;}
Delphi
public read-write property AllowChildDrop: System.Boolean;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Determines that only child nodes are allowed to be dropped.")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set AllowChildDrop : System.boolean
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines that only child nodes are allowed to be dropped.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.bool get_AllowChildDrop();
public: __property void set_AllowChildDrop(
   System.bool value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines that only child nodes are allowed to be dropped.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.bool AllowChildDrop {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewDragDropSettings Class
WebTreeViewDragDropSettings Members


AllowLeafDrop Property

[image]
Intersoft WebTreeView Documentation
AllowLeafDrop Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewDragDropSettings Class : AllowLeafDrop Property

Glossary Item Box

Determines whether a leaf type node can be set as a node dropping target.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Determines whether a leaf type node can be set as a node dropping target.")>
Public Property AllowLeafDrop As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewDragDropSettings
Dim value As System.Boolean

instance.AllowLeafDrop = value

value = instance.AllowLeafDrop
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Determines whether a leaf type node can be set as a node dropping target.")]
public System.bool AllowLeafDrop {get; set;}
Delphi
public read-write property AllowLeafDrop: System.Boolean;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Determines whether a leaf type node can be set as a node dropping target.")
public function get,set AllowLeafDrop : System.boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Determines whether a leaf type node can be set as a node dropping target.")]
public: __property System.bool get_AllowLeafDrop();
public: __property void set_AllowLeafDrop(
   System.bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Determines whether a leaf type node can be set as a node dropping target.")]
public:
property System.bool AllowLeafDrop {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewDragDropSettings Class
WebTreeViewDragDropSettings Members


AllowRootDrop Property

[image]
Intersoft WebTreeView Documentation
AllowRootDrop Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewDragDropSettings Class : AllowRootDrop Property

Glossary Item Box

Determines whether a node can be dropped as a root.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Determines whether a node can be dropped as a root.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property AllowRootDrop As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewDragDropSettings
Dim value As System.Boolean

instance.AllowRootDrop = value

value = instance.AllowRootDrop
C#
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether a node can be dropped as a root.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.bool AllowRootDrop {get; set;}
Delphi
public read-write property AllowRootDrop: System.Boolean;
JScript
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Determines whether a node can be dropped as a root.")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set AllowRootDrop : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether a node can be dropped as a root.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.bool get_AllowRootDrop();
public: __property void set_AllowRootDrop(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether a node can be dropped as a root.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.bool AllowRootDrop {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewDragDropSettings Class
WebTreeViewDragDropSettings Members


AllowSiblingDrop Property

[image]
Intersoft WebTreeView Documentation
AllowSiblingDrop Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewDragDropSettings Class : AllowSiblingDrop Property

Glossary Item Box

Determines whether a node can be dropped as sibling node (node on the same level).

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Determines whether a node can be dropped as sibling node (node on the same level).")>
Public Property AllowSiblingDrop As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewDragDropSettings
Dim value As System.Boolean

instance.AllowSiblingDrop = value

value = instance.AllowSiblingDrop
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether a node can be dropped as sibling node (node on the same level).")]
public System.bool AllowSiblingDrop {get; set;}
Delphi
public read-write property AllowSiblingDrop: System.Boolean;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Determines whether a node can be dropped as sibling node (node on the same level).")
public function get,set AllowSiblingDrop : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether a node can be dropped as sibling node (node on the same level).")]
public: __property System.bool get_AllowSiblingDrop();
public: __property void set_AllowSiblingDrop(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether a node can be dropped as sibling node (node on the same level).")]
public:
property System.bool AllowSiblingDrop {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewDragDropSettings Class
WebTreeViewDragDropSettings Members


WebTreeViewImagesSettings Class

[image]
Intersoft WebTreeView Documentation
WebTreeViewImagesSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace : WebTreeViewImagesSettings Class

Glossary Item Box

A collection of WebTreeView's image settings.

Object Model

WebTreeViewImagesSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DescriptionAttribute("A collection of WebTreeView's image settings.")>
<System.SerializableAttribute()>
Public Class WebTreeViewImagesSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewImagesSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("A collection of WebTreeView's image settings.")]
[System.SerializableAttribute()]
public class WebTreeViewImagesSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebTreeViewImagesSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DescriptionAttribute("A collection of WebTreeView's image settings.")
System.SerializableAttribute()
public class WebTreeViewImagesSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("A collection of WebTreeView's image settings.")]
[System.SerializableAttribute()]
public __gc class WebTreeViewImagesSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("A collection of WebTreeView's image settings.")]
[System.SerializableAttribute()]
public ref class WebTreeViewImagesSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebTreeView.WebTreeViewImagesSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewImagesSettings Members
ISNet.WebUI.WebTreeView Namespace


WebTreeViewImagesSettings Class Members

[image]
Intersoft WebTreeView Documentation
WebTreeViewImagesSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebTreeView Namespace : WebTreeViewImagesSettings Class

Glossary Item Box

The following tables list the members exposed by WebTreeViewImagesSettings.

Public Constructors

 | Name | Description
Public Constructor | WebTreeViewImagesSettings Constructor | Overloaded. Initializes a new instance of WebTreeViewImagesSettings class.
Top

Public Properties

 | Name | Description
Public Property | CheckBoxFalseImage | Gets or sets the image which will be used as checkbox falseimage.
Public Property | CheckBoxPartialImage | Gets or sets the image which will be used as checkbox partial image.
Public Property | CheckBoxTrueImage | Gets or sets the image which will be used as checkbox true image.
Public Property | CollapseImage | The image (often a 'minus') indicating the collapsibility of parent nodes Gets or sets the image which will be used as collapse image.
Public Property | DashImage | Gets or sets the image which will be used as dash image.
Public Property | DashminusImage | Gets or sets the image which will be used as dash minus image.
Public Property | DashplusImage | The Image (often a 'plus') to use to indicate expandability of parent nodes Gets or sets the image which will be used as dash plus image.
Public Property | ExpandedParentNodeImage | Default icon to use for expanded parent nodes Gets or sets the image which will be used as expanded parent node image.
Public Property | ExpandedRootNodeImage | Default icon to use for root nodes Gets or sets the image which will be used as expanded root node image.
Public Property | ExpandedSelectedParentNodeImage | Default icon to use for the expanded selected node if it is a parent Gets or sets the image which will be used as expanded selected parent node image.
Public Property | ExpandedSelectedRootNodeImage | Default icon to use for the selected node if it is a root Gets or sets the image which will be used as expanded selected root node image.
Public Property | ExpandImage | The Image (often a 'plus') to use to indicate expandability of parent nodes Gets or sets the image which will be used as expand image.
Public Property | IImage | Gets or sets the image which will be used as vertical node connector's image.
Public Property | LeafNodeImage | Default icon to use for leaf nodes Gets or sets the image which will be used as leaf node image.
Public Property | LImage | Gets or sets the image which will be used as L image.
Public Property | LminusImage | Gets or sets the image which will be used as L minus image.
Public Property | LplusImage | Gets or sets the image which will be used as L plus image.
Public Property | MinusImage | Gets or sets the image which will be used as minus image.
Public Property | NoexpandImage | The Image (often a 'plus') to use to indicate expandability of parent nodes Gets or sets the image which will be used as no expand image.
Public Property | ParentNodeImage | Default icon to use for parent nodes Gets or sets the image which will be used as parent node image.
Public Property | PlusImage | Gets or sets the image which will be used as plus image.
Public Property | RImage | The Image (often a 'plus') to use to indicate expandability of parent nodes Gets or sets the image which will be used as R image.
Public Property | RminusImage | The Image (often a 'plus') to use to indicate expandability of parent nodes Gets or sets the image which will be used as R minus image.
Public Property | RootNodeImage | Default icon to use for root nodes Gets or sets the image which will be used as root node image.
Public Property | RplusImage | The Image (often a 'plus') to use to indicate expandability of parent nodes Gets or sets the image which will be used as R plus image.
Public Property | SelectedLeafNodeImage | Default icon to use on the selected node if it is a leaf Gets or sets the image which will be used as selected leaf node image.
Public Property | SelectedParentNodeImage | Default icon to use for the selected node if it is a parent Gets or sets the image which will be used as selected parent node image.
Public Property | SelectedRootNodeImage | Default icon to use for the selected node if it is a root Gets or sets the image which will be used as selected root node image.
Public Property | TImage | Gets or sets the image which will be used as T image.
Public Property | TminusImage | Gets or sets the image which will be used as T minus image.
Public Property | TplusImage | Gets or sets the image which will be used as T plus image.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

Protected Methods

 | Name | Description
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | IsInSerializationContext | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebTreeViewImagesSettings Class
ISNet.WebUI.WebTreeView Namespace


WebTreeViewImagesSettings Constructor

[image]
Intersoft WebTreeView Documentation
WebTreeViewImagesSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewImagesSettings Class : WebTreeViewImagesSettings Constructor

Glossary Item Box

Initializes a new instance of WebTreeViewImagesSettings class.

Overload List

Overload | Description
WebTreeViewImagesSettings Constructor() |
WebTreeViewImagesSettings Constructor(SerializationInfo,StreamingContext) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewImagesSettings Class
WebTreeViewImagesSettings Members


WebTreeViewImagesSettings Constructor()

[image]
Intersoft WebTreeView Documentation
WebTreeViewImagesSettings Constructor()
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewImagesSettings Class > WebTreeViewImagesSettings Constructor : WebTreeViewImagesSettings Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebTreeViewImagesSettings class.")>
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebTreeViewImagesSettings()
C#
[System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebTreeViewImagesSettings class.")]
public WebTreeViewImagesSettings()
Delphi
public WebTreeViewImagesSettings();
JScript
System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebTreeViewImagesSettings class.")
public function WebTreeViewImagesSettings();
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebTreeViewImagesSettings class.")]
public: WebTreeViewImagesSettings();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebTreeViewImagesSettings class.")]
public:
WebTreeViewImagesSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewImagesSettings Class
WebTreeViewImagesSettings Members
Overload List


WebTreeViewImagesSettings Constructor(SerializationInfo,StreamingContext)

[image]
Intersoft WebTreeView Documentation
WebTreeViewImagesSettings Constructor(SerializationInfo,StreamingContext)
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewImagesSettings Class > WebTreeViewImagesSettings Constructor : WebTreeViewImagesSettings Constructor(SerializationInfo,StreamingContext)

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

Dim instance As New WebTreeViewImagesSettings(info, context)
C#
protected WebTreeViewImagesSettings(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
protected WebTreeViewImagesSettings(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
protected function WebTreeViewImagesSettings(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
protected: WebTreeViewImagesSettings(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
protected:
WebTreeViewImagesSettings(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewImagesSettings Class
WebTreeViewImagesSettings Members
Overload List


WebTreeViewImagesSettings Class Properties

[image]
Intersoft WebTreeView Documentation
WebTreeViewImagesSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace : WebTreeViewImagesSettings Class

Glossary Item Box

For a list of all members of this type, see WebTreeViewImagesSettings members.

Public Properties

 | Name | Description
Public Property | CheckBoxFalseImage | Gets or sets the image which will be used as checkbox falseimage.
Public Property | CheckBoxPartialImage | Gets or sets the image which will be used as checkbox partial image.
Public Property | CheckBoxTrueImage | Gets or sets the image which will be used as checkbox true image.
Public Property | CollapseImage | The image (often a 'minus') indicating the collapsibility of parent nodes Gets or sets the image which will be used as collapse image.
Public Property | DashImage | Gets or sets the image which will be used as dash image.
Public Property | DashminusImage | Gets or sets the image which will be used as dash minus image.
Public Property | DashplusImage | The Image (often a 'plus') to use to indicate expandability of parent nodes Gets or sets the image which will be used as dash plus image.
Public Property | ExpandedParentNodeImage | Default icon to use for expanded parent nodes Gets or sets the image which will be used as expanded parent node image.
Public Property | ExpandedRootNodeImage | Default icon to use for root nodes Gets or sets the image which will be used as expanded root node image.
Public Property | ExpandedSelectedParentNodeImage | Default icon to use for the expanded selected node if it is a parent Gets or sets the image which will be used as expanded selected parent node image.
Public Property | ExpandedSelectedRootNodeImage | Default icon to use for the selected node if it is a root Gets or sets the image which will be used as expanded selected root node image.
Public Property | ExpandImage | The Image (often a 'plus') to use to indicate expandability of parent nodes Gets or sets the image which will be used as expand image.
Public Property | IImage | Gets or sets the image which will be used as vertical node connector's image.
Public Property | LeafNodeImage | Default icon to use for leaf nodes Gets or sets the image which will be used as leaf node image.
Public Property | LImage | Gets or sets the image which will be used as L image.
Public Property | LminusImage | Gets or sets the image which will be used as L minus image.
Public Property | LplusImage | Gets or sets the image which will be used as L plus image.
Public Property | MinusImage | Gets or sets the image which will be used as minus image.
Public Property | NoexpandImage | The Image (often a 'plus') to use to indicate expandability of parent nodes Gets or sets the image which will be used as no expand image.
Public Property | ParentNodeImage | Default icon to use for parent nodes Gets or sets the image which will be used as parent node image.
Public Property | PlusImage | Gets or sets the image which will be used as plus image.
Public Property | RImage | The Image (often a 'plus') to use to indicate expandability of parent nodes Gets or sets the image which will be used as R image.
Public Property | RminusImage | The Image (often a 'plus') to use to indicate expandability of parent nodes Gets or sets the image which will be used as R minus image.
Public Property | RootNodeImage | Default icon to use for root nodes Gets or sets the image which will be used as root node image.
Public Property | RplusImage | The Image (often a 'plus') to use to indicate expandability of parent nodes Gets or sets the image which will be used as R plus image.
Public Property | SelectedLeafNodeImage | Default icon to use on the selected node if it is a leaf Gets or sets the image which will be used as selected leaf node image.
Public Property | SelectedParentNodeImage | Default icon to use for the selected node if it is a parent Gets or sets the image which will be used as selected parent node image.
Public Property | SelectedRootNodeImage | Default icon to use for the selected node if it is a root Gets or sets the image which will be used as selected root node image.
Public Property | TImage | Gets or sets the image which will be used as T image.
Public Property | TminusImage | Gets or sets the image which will be used as T minus image.
Public Property | TplusImage | Gets or sets the image which will be used as T plus image.
Top

See Also

Reference

WebTreeViewImagesSettings Class
ISNet.WebUI.WebTreeView Namespace


CheckBoxFalseImage Property

[image]
Intersoft WebTreeView Documentation
CheckBoxFalseImage Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewImagesSettings Class : CheckBoxFalseImage Property

Glossary Item Box

Gets or sets the image which will be used as checkbox falseimage.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as checkbox false image.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property CheckBoxFalseImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewImagesSettings
Dim value As System.String

instance.CheckBoxFalseImage = value

value = instance.CheckBoxFalseImage
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as checkbox false image.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string CheckBoxFalseImage {get; set;}
Delphi
public read-write property CheckBoxFalseImage: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as checkbox false image.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set CheckBoxFalseImage : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as checkbox false image.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_CheckBoxFalseImage();
public: __property void set_CheckBoxFalseImage(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as checkbox false image.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ CheckBoxFalseImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewImagesSettings Class
WebTreeViewImagesSettings Members


CheckBoxPartialImage Property

[image]
Intersoft WebTreeView Documentation
CheckBoxPartialImage Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewImagesSettings Class : CheckBoxPartialImage Property

Glossary Item Box

Gets or sets the image which will be used as checkbox partial image.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as checkbox partial image.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property CheckBoxPartialImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewImagesSettings
Dim value As System.String

instance.CheckBoxPartialImage = value

value = instance.CheckBoxPartialImage
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as checkbox partial image.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string CheckBoxPartialImage {get; set;}
Delphi
public read-write property CheckBoxPartialImage: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as checkbox partial image.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set CheckBoxPartialImage : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as checkbox partial image.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_CheckBoxPartialImage();
public: __property void set_CheckBoxPartialImage(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as checkbox partial image.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ CheckBoxPartialImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewImagesSettings Class
WebTreeViewImagesSettings Members


CheckBoxTrueImage Property

[image]
Intersoft WebTreeView Documentation
CheckBoxTrueImage Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewImagesSettings Class : CheckBoxTrueImage Property

Glossary Item Box

Gets or sets the image which will be used as checkbox true image.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as checkbox true image.")>
Public Property CheckBoxTrueImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewImagesSettings
Dim value As System.String

instance.CheckBoxTrueImage = value

value = instance.CheckBoxTrueImage
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as checkbox true image.")]
public System.string CheckBoxTrueImage {get; set;}
Delphi
public read-write property CheckBoxTrueImage: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as checkbox true image.")
public function get,set CheckBoxTrueImage : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as checkbox true image.")]
public: __property System.string* get_CheckBoxTrueImage();
public: __property void set_CheckBoxTrueImage(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as checkbox true image.")]
public:
property System.String^ CheckBoxTrueImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewImagesSettings Class
WebTreeViewImagesSettings Members


CollapseImage Property

[image]
Intersoft WebTreeView Documentation
CollapseImage Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewImagesSettings Class : CollapseImage Property

Glossary Item Box

The image (often a 'minus') indicating the collapsibility of parent nodes Gets or sets the image which will be used as collapse image.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as collapse image.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property CollapseImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewImagesSettings
Dim value As System.String

instance.CollapseImage = value

value = instance.CollapseImage
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as collapse image.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string CollapseImage {get; set;}
Delphi
public read-write property CollapseImage: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as collapse image.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set CollapseImage : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as collapse image.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_CollapseImage();
public: __property void set_CollapseImage(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as collapse image.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ CollapseImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewImagesSettings Class
WebTreeViewImagesSettings Members


DashImage Property

[image]
Intersoft WebTreeView Documentation
DashImage Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewImagesSettings Class : DashImage Property

Glossary Item Box

Gets or sets the image which will be used as dash image.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as dash image. ")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property DashImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewImagesSettings
Dim value As System.String

instance.DashImage = value

value = instance.DashImage
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as dash image. ")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string DashImage {get; set;}
Delphi
public read-write property DashImage: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as dash image. ")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set DashImage : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as dash image. ")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_DashImage();
public: __property void set_DashImage(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as dash image. ")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ DashImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewImagesSettings Class
WebTreeViewImagesSettings Members


DashminusImage Property

[image]
Intersoft WebTreeView Documentation
DashminusImage Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewImagesSettings Class : DashminusImage Property

Glossary Item Box

Gets or sets the image which will be used as dash minus image.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as dash minus image. ")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property DashminusImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewImagesSettings
Dim value As System.String

instance.DashminusImage = value

value = instance.DashminusImage
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as dash minus image. ")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.string DashminusImage {get; set;}
Delphi
public read-write property DashminusImage: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as dash minus image. ")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set DashminusImage : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as dash minus image. ")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_DashminusImage();
public: __property void set_DashminusImage(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as dash minus image. ")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ DashminusImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewImagesSettings Class
WebTreeViewImagesSettings Members


DashplusImage Property

[image]
Intersoft WebTreeView Documentation
DashplusImage Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewImagesSettings Class : DashplusImage Property

Glossary Item Box

The Image (often a 'plus') to use to indicate expandability of parent nodes Gets or sets the image which will be used as dash plus image.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as dash plus image. ")>
Public Property DashplusImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewImagesSettings
Dim value As System.String

instance.DashplusImage = value

value = instance.DashplusImage
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as dash plus image. ")]
public System.string DashplusImage {get; set;}
Delphi
public read-write property DashplusImage: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as dash plus image. ")
public function get,set DashplusImage : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as dash plus image. ")]
public: __property System.string* get_DashplusImage();
public: __property void set_DashplusImage(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as dash plus image. ")]
public:
property System.String^ DashplusImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewImagesSettings Class
WebTreeViewImagesSettings Members


ExpandedParentNodeImage Property

[image]
Intersoft WebTreeView Documentation
ExpandedParentNodeImage Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewImagesSettings Class : ExpandedParentNodeImage Property

Glossary Item Box

Default icon to use for expanded parent nodes Gets or sets the image which will be used as expanded parent node image.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as expanded parent node image.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property ExpandedParentNodeImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewImagesSettings
Dim value As System.String

instance.ExpandedParentNodeImage = value

value = instance.ExpandedParentNodeImage
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as expanded parent node image.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string ExpandedParentNodeImage {get; set;}
Delphi
public read-write property ExpandedParentNodeImage: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as expanded parent node image.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set ExpandedParentNodeImage : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as expanded parent node image.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_ExpandedParentNodeImage();
public: __property void set_ExpandedParentNodeImage(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as expanded parent node image.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ ExpandedParentNodeImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewImagesSettings Class
WebTreeViewImagesSettings Members


ExpandedRootNodeImage Property

[image]
Intersoft WebTreeView Documentation
ExpandedRootNodeImage Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewImagesSettings Class : ExpandedRootNodeImage Property

Glossary Item Box

Default icon to use for root nodes Gets or sets the image which will be used as expanded root node image.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as expanded root node image.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property ExpandedRootNodeImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewImagesSettings
Dim value As System.String

instance.ExpandedRootNodeImage = value

value = instance.ExpandedRootNodeImage
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as expanded root node image.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string ExpandedRootNodeImage {get; set;}
Delphi
public read-write property ExpandedRootNodeImage: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as expanded root node image.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set ExpandedRootNodeImage : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as expanded root node image.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_ExpandedRootNodeImage();
public: __property void set_ExpandedRootNodeImage(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as expanded root node image.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ ExpandedRootNodeImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewImagesSettings Class
WebTreeViewImagesSettings Members


ExpandedSelectedParentNodeImage Property

[image]
Intersoft WebTreeView Documentation
ExpandedSelectedParentNodeImage Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewImagesSettings Class : ExpandedSelectedParentNodeImage Property

Glossary Item Box

Default icon to use for the expanded selected node if it is a parent Gets or sets the image which will be used as expanded selected parent node image.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as expanded selected parent node image.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property ExpandedSelectedParentNodeImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewImagesSettings
Dim value As System.String

instance.ExpandedSelectedParentNodeImage = value

value = instance.ExpandedSelectedParentNodeImage
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as expanded selected parent node image.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string ExpandedSelectedParentNodeImage {get; set;}
Delphi
public read-write property ExpandedSelectedParentNodeImage: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as expanded selected parent node image.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set ExpandedSelectedParentNodeImage : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as expanded selected parent node image.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_ExpandedSelectedParentNodeImage();
public: __property void set_ExpandedSelectedParentNodeImage(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as expanded selected parent node image.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ ExpandedSelectedParentNodeImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewImagesSettings Class
WebTreeViewImagesSettings Members


ExpandedSelectedRootNodeImage Property

[image]
Intersoft WebTreeView Documentation
ExpandedSelectedRootNodeImage Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewImagesSettings Class : ExpandedSelectedRootNodeImage Property

Glossary Item Box

Default icon to use for the selected node if it is a root Gets or sets the image which will be used as expanded selected root node image.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as expanded selected root node image.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property ExpandedSelectedRootNodeImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewImagesSettings
Dim value As System.String

instance.ExpandedSelectedRootNodeImage = value

value = instance.ExpandedSelectedRootNodeImage
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as expanded selected root node image.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.string ExpandedSelectedRootNodeImage {get; set;}
Delphi
public read-write property ExpandedSelectedRootNodeImage: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as expanded selected root node image.")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set ExpandedSelectedRootNodeImage : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as expanded selected root node image.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_ExpandedSelectedRootNodeImage();
public: __property void set_ExpandedSelectedRootNodeImage(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as expanded selected root node image.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ ExpandedSelectedRootNodeImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewImagesSettings Class
WebTreeViewImagesSettings Members


ExpandImage Property

[image]
Intersoft WebTreeView Documentation
ExpandImage Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewImagesSettings Class : ExpandImage Property

Glossary Item Box

The Image (often a 'plus') to use to indicate expandability of parent nodes Gets or sets the image which will be used as expand image.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as expand image.")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property ExpandImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewImagesSettings
Dim value As System.String

instance.ExpandImage = value

value = instance.ExpandImage
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as expand image.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string ExpandImage {get; set;}
Delphi
public read-write property ExpandImage: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as expand image.")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set ExpandImage : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as expand image.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_ExpandImage();
public: __property void set_ExpandImage(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as expand image.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ ExpandImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewImagesSettings Class
WebTreeViewImagesSettings Members


IImage Property

[image]
Intersoft WebTreeView Documentation
IImage Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewImagesSettings Class : IImage Property

Glossary Item Box

Gets or sets the image which will be used as vertical node connector's image.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as vertical node connector's image. ")>
Public Property IImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewImagesSettings
Dim value As System.String

instance.IImage = value

value = instance.IImage
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as vertical node connector's image. ")]
public System.string IImage {get; set;}
Delphi
public read-write property IImage: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as vertical node connector's image. ")
public function get,set IImage : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as vertical node connector's image. ")]
public: __property System.string* get_IImage();
public: __property void set_IImage(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as vertical node connector's image. ")]
public:
property System.String^ IImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewImagesSettings Class
WebTreeViewImagesSettings Members


LeafNodeImage Property

[image]
Intersoft WebTreeView Documentation
LeafNodeImage Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewImagesSettings Class : LeafNodeImage Property

Glossary Item Box

Default icon to use for leaf nodes Gets or sets the image which will be used as leaf node image.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as leaf node image.")>
<ISNet.MarkAsStyleAttribute(True)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property LeafNodeImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewImagesSettings
Dim value As System.String

instance.LeafNodeImage = value

value = instance.LeafNodeImage
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as leaf node image.")]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string LeafNodeImage {get; set;}
Delphi
public read-write property LeafNodeImage: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as leaf node image.")
ISNet.MarkAsStyleAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set LeafNodeImage : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as leaf node image.")]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_LeafNodeImage();
public: __property void set_LeafNodeImage(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as leaf node image.")]
[ISNet.MarkAsStyleAttribute(true)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ LeafNodeImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewImagesSettings Class
WebTreeViewImagesSettings Members


LImage Property

[image]
Intersoft WebTreeView Documentation
LImage Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewImagesSettings Class : LImage Property

Glossary Item Box

Gets or sets the image which will be used as L image.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as L image. ")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property LImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewImagesSettings
Dim value As System.String

instance.LImage = value

value = instance.LImage
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as L image. ")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string LImage {get; set;}
Delphi
public read-write property LImage: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as L image. ")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set LImage : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as L image. ")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_LImage();
public: __property void set_LImage(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as L image. ")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ LImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewImagesSettings Class
WebTreeViewImagesSettings Members


LminusImage Property

[image]
Intersoft WebTreeView Documentation
LminusImage Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewImagesSettings Class : LminusImage Property

Glossary Item Box

Gets or sets the image which will be used as L minus image.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as L minus image. ")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property LminusImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewImagesSettings
Dim value As System.String

instance.LminusImage = value

value = instance.LminusImage
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as L minus image. ")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string LminusImage {get; set;}
Delphi
public read-write property LminusImage: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as L minus image. ")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set LminusImage : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as L minus image. ")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_LminusImage();
public: __property void set_LminusImage(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as L minus image. ")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ LminusImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewImagesSettings Class
WebTreeViewImagesSettings Members


LplusImage Property

[image]
Intersoft WebTreeView Documentation
LplusImage Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewImagesSettings Class : LplusImage Property

Glossary Item Box

Gets or sets the image which will be used as L plus image.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as L plus image.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property LplusImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewImagesSettings
Dim value As System.String

instance.LplusImage = value

value = instance.LplusImage
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as L plus image.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string LplusImage {get; set;}
Delphi
public read-write property LplusImage: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as L plus image.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set LplusImage : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as L plus image.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_LplusImage();
public: __property void set_LplusImage(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as L plus image.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ LplusImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewImagesSettings Class
WebTreeViewImagesSettings Members


MinusImage Property

[image]
Intersoft WebTreeView Documentation
MinusImage Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewImagesSettings Class : MinusImage Property

Glossary Item Box

Gets or sets the image which will be used as minus image.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as minus image.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property MinusImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewImagesSettings
Dim value As System.String

instance.MinusImage = value

value = instance.MinusImage
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as minus image.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string MinusImage {get; set;}
Delphi
public read-write property MinusImage: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as minus image.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set MinusImage : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as minus image.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_MinusImage();
public: __property void set_MinusImage(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as minus image.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ MinusImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewImagesSettings Class
WebTreeViewImagesSettings Members


NoexpandImage Property

[image]
Intersoft WebTreeView Documentation
NoexpandImage Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewImagesSettings Class : NoexpandImage Property

Glossary Item Box

The Image (often a 'plus') to use to indicate expandability of parent nodes Gets or sets the image which will be used as no expand image.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as no expand image.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property NoexpandImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewImagesSettings
Dim value As System.String

instance.NoexpandImage = value

value = instance.NoexpandImage
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as no expand image.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string NoexpandImage {get; set;}
Delphi
public read-write property NoexpandImage: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as no expand image.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set NoexpandImage : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as no expand image.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_NoexpandImage();
public: __property void set_NoexpandImage(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as no expand image.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ NoexpandImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewImagesSettings Class
WebTreeViewImagesSettings Members


ParentNodeImage Property

[image]
Intersoft WebTreeView Documentation
ParentNodeImage Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewImagesSettings Class : ParentNodeImage Property

Glossary Item Box

Default icon to use for parent nodes Gets or sets the image which will be used as parent node image.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as parent node image.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.MarkAsStyleAttribute(True)>
Public Property ParentNodeImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewImagesSettings
Dim value As System.String

instance.ParentNodeImage = value

value = instance.ParentNodeImage
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as parent node image.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.MarkAsStyleAttribute(true)]
public System.string ParentNodeImage {get; set;}
Delphi
public read-write property ParentNodeImage: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as parent node image.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.MarkAsStyleAttribute()
public function get,set ParentNodeImage : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as parent node image.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.MarkAsStyleAttribute(true)]
public: __property System.string* get_ParentNodeImage();
public: __property void set_ParentNodeImage(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as parent node image.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.MarkAsStyleAttribute(true)]
public:
property System.String^ ParentNodeImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewImagesSettings Class
WebTreeViewImagesSettings Members


PlusImage Property

[image]
Intersoft WebTreeView Documentation
PlusImage Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewImagesSettings Class : PlusImage Property

Glossary Item Box

Gets or sets the image which will be used as plus image.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as plus image. ")>
Public Property PlusImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewImagesSettings
Dim value As System.String

instance.PlusImage = value

value = instance.PlusImage
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as plus image. ")]
public System.string PlusImage {get; set;}
Delphi
public read-write property PlusImage: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as plus image. ")
public function get,set PlusImage : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as plus image. ")]
public: __property System.string* get_PlusImage();
public: __property void set_PlusImage(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as plus image. ")]
public:
property System.String^ PlusImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewImagesSettings Class
WebTreeViewImagesSettings Members


RImage Property

[image]
Intersoft WebTreeView Documentation
RImage Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewImagesSettings Class : RImage Property

Glossary Item Box

The Image (often a 'plus') to use to indicate expandability of parent nodes Gets or sets the image which will be used as R image.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as R image. ")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property RImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewImagesSettings
Dim value As System.String

instance.RImage = value

value = instance.RImage
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as R image. ")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string RImage {get; set;}
Delphi
public read-write property RImage: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as R image. ")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set RImage : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as R image. ")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_RImage();
public: __property void set_RImage(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as R image. ")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ RImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewImagesSettings Class
WebTreeViewImagesSettings Members


RminusImage Property

[image]
Intersoft WebTreeView Documentation
RminusImage Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewImagesSettings Class : RminusImage Property

Glossary Item Box

The Image (often a 'plus') to use to indicate expandability of parent nodes Gets or sets the image which will be used as R minus image.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as R minus image.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property RminusImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewImagesSettings
Dim value As System.String

instance.RminusImage = value

value = instance.RminusImage
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as R minus image.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.string RminusImage {get; set;}
Delphi
public read-write property RminusImage: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as R minus image.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set RminusImage : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as R minus image.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_RminusImage();
public: __property void set_RminusImage(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as R minus image.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ RminusImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewImagesSettings Class
WebTreeViewImagesSettings Members


RootNodeImage Property

[image]
Intersoft WebTreeView Documentation
RootNodeImage Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewImagesSettings Class : RootNodeImage Property

Glossary Item Box

Default icon to use for root nodes Gets or sets the image which will be used as root node image.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as root node image.")>
<ISNet.MarkAsStyleAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property RootNodeImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewImagesSettings
Dim value As System.String

instance.RootNodeImage = value

value = instance.RootNodeImage
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as root node image.")]
[ISNet.MarkAsStyleAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.string RootNodeImage {get; set;}
Delphi
public read-write property RootNodeImage: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as root node image.")
ISNet.MarkAsStyleAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set RootNodeImage : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as root node image.")]
[ISNet.MarkAsStyleAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_RootNodeImage();
public: __property void set_RootNodeImage(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as root node image.")]
[ISNet.MarkAsStyleAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ RootNodeImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewImagesSettings Class
WebTreeViewImagesSettings Members


RplusImage Property

[image]
Intersoft WebTreeView Documentation
RplusImage Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewImagesSettings Class : RplusImage Property

Glossary Item Box

The Image (often a 'plus') to use to indicate expandability of parent nodes Gets or sets the image which will be used as R plus image.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as R plus image.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property RplusImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewImagesSettings
Dim value As System.String

instance.RplusImage = value

value = instance.RplusImage
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as R plus image.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string RplusImage {get; set;}
Delphi
public read-write property RplusImage: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as R plus image.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set RplusImage : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as R plus image.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_RplusImage();
public: __property void set_RplusImage(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as R plus image.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ RplusImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewImagesSettings Class
WebTreeViewImagesSettings Members


SelectedLeafNodeImage Property

[image]
Intersoft WebTreeView Documentation
SelectedLeafNodeImage Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewImagesSettings Class : SelectedLeafNodeImage Property

Glossary Item Box

Default icon to use on the selected node if it is a leaf Gets or sets the image which will be used as selected leaf node image.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as selected leaf node image. ")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property SelectedLeafNodeImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewImagesSettings
Dim value As System.String

instance.SelectedLeafNodeImage = value

value = instance.SelectedLeafNodeImage
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as selected leaf node image. ")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.string SelectedLeafNodeImage {get; set;}
Delphi
public read-write property SelectedLeafNodeImage: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as selected leaf node image. ")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set SelectedLeafNodeImage : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as selected leaf node image. ")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_SelectedLeafNodeImage();
public: __property void set_SelectedLeafNodeImage(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as selected leaf node image. ")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ SelectedLeafNodeImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewImagesSettings Class
WebTreeViewImagesSettings Members


SelectedParentNodeImage Property

[image]
Intersoft WebTreeView Documentation
SelectedParentNodeImage Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewImagesSettings Class : SelectedParentNodeImage Property

Glossary Item Box

Default icon to use for the selected node if it is a parent Gets or sets the image which will be used as selected parent node image.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as selected parent node image. ")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property SelectedParentNodeImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewImagesSettings
Dim value As System.String

instance.SelectedParentNodeImage = value

value = instance.SelectedParentNodeImage
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as selected parent node image. ")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string SelectedParentNodeImage {get; set;}
Delphi
public read-write property SelectedParentNodeImage: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as selected parent node image. ")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set SelectedParentNodeImage : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as selected parent node image. ")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_SelectedParentNodeImage();
public: __property void set_SelectedParentNodeImage(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as selected parent node image. ")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ SelectedParentNodeImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewImagesSettings Class
WebTreeViewImagesSettings Members


SelectedRootNodeImage Property

[image]
Intersoft WebTreeView Documentation
SelectedRootNodeImage Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewImagesSettings Class : SelectedRootNodeImage Property

Glossary Item Box

Default icon to use for the selected node if it is a root Gets or sets the image which will be used as selected root node image.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as selected root node image.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property SelectedRootNodeImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewImagesSettings
Dim value As System.String

instance.SelectedRootNodeImage = value

value = instance.SelectedRootNodeImage
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as selected root node image.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string SelectedRootNodeImage {get; set;}
Delphi
public read-write property SelectedRootNodeImage: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as selected root node image.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set SelectedRootNodeImage : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as selected root node image.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_SelectedRootNodeImage();
public: __property void set_SelectedRootNodeImage(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as selected root node image.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ SelectedRootNodeImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewImagesSettings Class
WebTreeViewImagesSettings Members


TImage Property

[image]
Intersoft WebTreeView Documentation
TImage Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewImagesSettings Class : TImage Property

Glossary Item Box

Gets or sets the image which will be used as T image.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as T image. ")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property TImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewImagesSettings
Dim value As System.String

instance.TImage = value

value = instance.TImage
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as T image. ")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string TImage {get; set;}
Delphi
public read-write property TImage: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as T image. ")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set TImage : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as T image. ")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_TImage();
public: __property void set_TImage(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as T image. ")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ TImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewImagesSettings Class
WebTreeViewImagesSettings Members


TminusImage Property

[image]
Intersoft WebTreeView Documentation
TminusImage Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewImagesSettings Class : TminusImage Property

Glossary Item Box

Gets or sets the image which will be used as T minus image.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as T minus image. ")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property TminusImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewImagesSettings
Dim value As System.String

instance.TminusImage = value

value = instance.TminusImage
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as T minus image. ")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string TminusImage {get; set;}
Delphi
public read-write property TminusImage: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as T minus image. ")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set TminusImage : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as T minus image. ")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_TminusImage();
public: __property void set_TminusImage(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as T minus image. ")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ TminusImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewImagesSettings Class
WebTreeViewImagesSettings Members


TplusImage Property

[image]
Intersoft WebTreeView Documentation
TplusImage Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewImagesSettings Class : TplusImage Property

Glossary Item Box

Gets or sets the image which will be used as T plus image.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as T plus image. ")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property TplusImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewImagesSettings
Dim value As System.String

instance.TplusImage = value

value = instance.TplusImage
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as T plus image. ")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string TplusImage {get; set;}
Delphi
public read-write property TplusImage: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as T plus image. ")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set TplusImage : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as T plus image. ")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_TplusImage();
public: __property void set_TplusImage(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image which will be used as T plus image. ")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ TplusImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewImagesSettings Class
WebTreeViewImagesSettings Members


WebTreeViewNode Class

[image]
Intersoft WebTreeView Documentation
WebTreeViewNode Class
Members See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace : WebTreeViewNode Class

Glossary Item Box

Represents a unbound node which belongs to WebTreeView object. WebTreeViewNode contains many properties for you to customize a node.

Object Model

WebTreeViewNode Class

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Represents a unbound node which belongs to WebTreeView  object. WebTreeViewNode contains many properties for you to customize a node.")>
<System.Web.UI.ParseChildrenAttribute(ChildrenAsProperties=True, DefaultProperty="Nodes")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultPropertyAttribute("Text")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebTreeViewNode
   Inherits ISNet.WebUI.NamedObjectBase
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNode
C#
[System.ComponentModel.DescriptionAttribute("Represents a unbound node which belongs to WebTreeView  object. WebTreeViewNode contains many properties for you to customize a node.")]
[System.Web.UI.ParseChildrenAttribute(ChildrenAsProperties=true, DefaultProperty="Nodes")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultPropertyAttribute("Text")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebTreeViewNode : ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
Delphi
public class WebTreeViewNode = class(ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject)
JScript
System.ComponentModel.DescriptionAttribute("Represents a unbound node which belongs to WebTreeView  object. WebTreeViewNode contains many properties for you to customize a node.")
System.Web.UI.ParseChildrenAttribute(ChildrenAsProperties=, DefaultProperty="Nodes")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultPropertyAttribute("Text")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebTreeViewNode extends ISNet.WebUI.NamedObjectBase implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Represents a unbound node which belongs to WebTreeView  object. WebTreeViewNode contains many properties for you to customize a node.")]
[System.Web.UI.ParseChildrenAttribute(ChildrenAsProperties=true, DefaultProperty="Nodes")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultPropertyAttribute("Text")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebTreeViewNode : public ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
C++/CLI
[System.ComponentModel.DescriptionAttribute("Represents a unbound node which belongs to WebTreeView  object. WebTreeViewNode contains many properties for you to customize a node.")]
[System.Web.UI.ParseChildrenAttribute(ChildrenAsProperties=true, DefaultProperty="Nodes")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultPropertyAttribute("Text")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebTreeViewNode : public ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.NamedObjectBase
ISNet.WebUI.WebTreeView.WebTreeViewNode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNode Members
ISNet.WebUI.WebTreeView Namespace


WebTreeViewNode Class Members

[image]
Intersoft WebTreeView Documentation
WebTreeViewNode Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebTreeView Namespace : WebTreeViewNode Class

Glossary Item Box

The following tables list the members exposed by WebTreeViewNode.

Public Constructors

 | Name | Description
Public Constructor | WebTreeViewNode Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | AllowDrag | Determines whether this node can be dragged by end user.Specifies whether a node is allowed to be dragged or not.
Public Property | AllowDrop | Determines whether this node accept drop in a drag drop operation.Specifies whether a node is allowed to be dropped or not.
Public Property | AllowEditing | Specifies whether to allow edit.Specifies whether a node is allowed to be edited or not.
Public Property | Checked | Specifies whether the node is currently checked.Determines whether the specified node is currently checked or not.
Public Property | CheckedState | Gets or sets the checked state of the node.Determines the checked state of the node.
Public Property | ChildNodeExpandable | Specifies whether the node is expandable when it has childnodes.Specifies whether the child nodes of the specified node is expandable or not.
Public Property | Collection | (Inherited from ISNet.WebUI.NamedObjectBase)
Public Property | ContentTemplate | A fully customizable template used to hold custom node.
Public Property | CustomStyle | Gets or sets custom css style of the node.Gets or sets the custom CSS style of the node.
Public Property | DataItem | Specifies data from a node. The data can be a value from XML, if the WebTreeView is bound to XMLDataSource.
Public Property | Depth | Gets the depth level of the node.Gets or sets the Depth of the databindings.
Public Property | Enabled | Indicates whether the node is enable or disable.Indicates whether the node is enabled or disabled.
Public Property | Expanded | Specifies whether the node is currently expanded.Specifies whether the node is currently expanded or not.
Public Property | ExpandedImage | icon image to use if the node is expanded Gets or sets the expanded icon image of the node.
Public Property | Image | icon image to use if the node is collapsed Gets or sets the icon image of the node.
Public Property | ImageToolTip | Gets or sets the image tooltip text of the node.Gets or sets the image tooltip text of the node.
Public Property | MaxBindingDepth | Specifies relative max binding depth.Specifies relative maximum binding depth.
Public Property | Name | Overridden. Specifies the name of the node.
Public Property | NavigateURL | URL to load sub-tree contents from (XML).Specifies the URL to be loaded for sub-tree contents.
Public Property | NextSibling | Determines the next node (in the same level) of the specified node.
Public Property | Nodes | The collection of nodes for WebTreeView.Specifies a collection of WebTreeView's nodes.
Public Property | NodeType | Gets or sets the type of the node.Determines the type of a node, whether it is a root node, parent node, or leaf node.
Public Property | ParentNode | Determines whether the specified node is a parent node and has at least one child node.
Public Property | Path | Gets the path from the root node to the current nodeGets or sets the path of a node, path from the root node to the node itself.
Public Property | PreviousSibling | Determines the previous node (in the same level) of the specified node.
Public Property | Selectable | Indicates whether the node is selectable.Indicates whether the node is selectable or not.
Public Property | Selected | Specifies whether the node is currently selected.Indicates whether the node is selected or not.
Public Property | SelectedExpandedImage | icon image to use if the node is expanded Gets or sets the expanded icon image of the selected node.
Public Property | SelectedImage | icon image to use if the node is collapsed Gets or sets the collapsed icon image of the selected node.
Public Property | Sequence | Gets the sequence level of the node.Determines the index of a node viewed from the entire nodes in WebTreeView.
Public Property | ShowCheckBox | Specifies whether to show checkbox next to the node.Specifies whether to show checkbox next to a node.
Public Property | Tag | A holding custom info related to the node.A holding custom info related to the node.
Public Property | Target | The navigate target used when the node is selected.The navigate target used when the node is selected.
Public Property | Text | Gets or sets the display text of the node.Gets or sets the displayed text of the node.
Public Property | TextImage | Text image of the node. Gets or sets the text image of the node.
Public Property | TextImageToolTip | Gets or sets the tooltip text image of the node.Specifies the specified node's tooltip textimage.
Public Property | ToolTip | Gets or sets the tooltip text of the node.Gets or sets the tooltip text of the node.
Public Property | Value | Gets or sets the value of the node.
Public Property | Visible | Indicates whether the node is visible.Indicates whether the node is visible or invisible.
Top

Public Methods

 | Name | Description
Public Method | AddNode | Overloaded. Adds a new node to a WebTreeViewNode instance with no arguments.
Public Method | Check | Method used for checking a node.
Public Method | CheckAll | Method used for checking all node level.
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Collapse | Method used for collapsing a parent node.
Public Method | CollapseAll | Method used for collapsing all parent nodes.
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Expand | Method used for expanding a parent node.
Public Method | ExpandAll | Method used for expanding all parent nodes.
Public Method | ExpandHierarchyAndSelect | Method used for expanding a node's entire level and select itself. If a node has a child and grand child, all node levels will be expanded. If a node acts as a child node, the upper level node will be expanded.
Public Method | GetCurrentIndex | Method used for getting the current index of the selected node.
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | IsChildsVisible | Method used for determining whether the childe nodes (Visible = true) of the specified node is visible or not.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Navigate | Method used for navigating a node to a URL specified in NavigateURL property.
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Select | Method used for selecting a node.
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToggleExpandCollapse | Method used for toggling expand or collapse.
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | UnCheck | Method used for unchecking a node.
Public Method | UnCheckAll | Method used for unchecking all nodes.
Top

Protected Methods

 | Name | Description
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | IsInSerializationContext | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | OnItemAdd | (Inherited from ISNet.WebUI.NamedObjectBase)
Protected Method | OnItemRemove | (Inherited from ISNet.WebUI.NamedObjectBase)
Top

See Also

Reference

WebTreeViewNode Class
ISNet.WebUI.WebTreeView Namespace


WebTreeViewNode Constructor

[image]
Intersoft WebTreeView Documentation
WebTreeViewNode Constructor
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNode Class : WebTreeViewNode Constructor

Glossary Item Box

Initializes a new instance of WebTreeViewNode class.

Overload List

Overload | Description
WebTreeViewNode Constructor() | Initializes a new instance of WebTreeViewNode class with no argument.
WebTreeViewNode Constructor(String) | Initializes a new instance of WebTreeViewNode class with String parameter as its name.
WebTreeViewNode Constructor(String,Object) | Initializes a new instance of WebTreeViewNode class with String parameter and Object parameter.
WebTreeViewNode Constructor(SerializationInfo,StreamingContext) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNode Class
WebTreeViewNode Members


WebTreeViewNode Constructor()

[image]
Intersoft WebTreeView Documentation
WebTreeViewNode Constructor()
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNode Class > WebTreeViewNode Constructor : WebTreeViewNode Constructor()

Glossary Item Box

Initializes a new instance of WebTreeViewNode class with no argument.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebTreeViewNode class.")>
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebTreeViewNode()
C#
[System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebTreeViewNode class.")]
public WebTreeViewNode()
Delphi
public WebTreeViewNode();
JScript
System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebTreeViewNode class.")
public function WebTreeViewNode();
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebTreeViewNode class.")]
public: WebTreeViewNode();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebTreeViewNode class.")]
public:
WebTreeViewNode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNode Class
WebTreeViewNode Members
Overload List


WebTreeViewNode Constructor(String)

[image]
Intersoft WebTreeView Documentation
WebTreeViewNode Constructor(String)
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNode Class > WebTreeViewNode Constructor : WebTreeViewNode Constructor(String)

name
Name of the new WebTreeViewNode instance.

Glossary Item Box

Initializes a new instance of WebTreeViewNode class with String parameter as its name.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebTreeViewNode class with String parameter as its name. ")>
Public Function New( _
   ByVal name As System.String _
)
Visual Basic (Usage) Copy Code
Dim name As System.String

Dim instance As New WebTreeViewNode(name)
C#
[System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebTreeViewNode class with String parameter as its name. ")]
public WebTreeViewNode(
   System.string name
)
Delphi
public WebTreeViewNode(
    name: System.String
);
JScript
System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebTreeViewNode class with String parameter as its name. ")
public function WebTreeViewNode(
   name : System.String
);
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebTreeViewNode class with String parameter as its name. ")]
public: WebTreeViewNode(
   System.string* name
)
C++/CLI
[System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebTreeViewNode class with String parameter as its name. ")]
public:
WebTreeViewNode(
   System.String^ name
)

Parameters

name
Name of the new WebTreeViewNode instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNode Class
WebTreeViewNode Members
Overload List


WebTreeViewNode Constructor(String,Object)

[image]
Intersoft WebTreeView Documentation
WebTreeViewNode Constructor(String,Object)
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNode Class > WebTreeViewNode Constructor : WebTreeViewNode Constructor(String,Object)

text

The name of the node

value
The value of the node.

Glossary Item Box

Initializes a new instance of WebTreeViewNode class with String parameter and Object parameter.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebTreeViewNode class with String parameter as its text an Object parameter as its value. ")>
Public Function New( _
   ByVal text As System.String, _
   ByVal value As System.Object _
)
Visual Basic (Usage) Copy Code
Dim text As System.String
Dim value As System.Object

Dim instance As New WebTreeViewNode(text, value)
C#
[System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebTreeViewNode class with String parameter as its text an Object parameter as its value. ")]
public WebTreeViewNode(
   System.string text,
   System.object value
)
Delphi
public WebTreeViewNode(
    text: System.String;
    value: System.TObject
);
JScript
System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebTreeViewNode class with String parameter as its text an Object parameter as its value. ")
public function WebTreeViewNode(
   text : System.String,
   value : System.Object
);
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebTreeViewNode class with String parameter as its text an Object parameter as its value. ")]
public: WebTreeViewNode(
   System.string* text,
   System.Object* value
)
C++/CLI
[System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebTreeViewNode class with String parameter as its text an Object parameter as its value. ")]
public:
WebTreeViewNode(
   System.String^ text,
   System.Object^ value
)

Parameters

text

The name of the node

value
The value of the node.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNode Class
WebTreeViewNode Members
Overload List


WebTreeViewNode Constructor(SerializationInfo,StreamingContext)

[image]
Intersoft WebTreeView Documentation
WebTreeViewNode Constructor(SerializationInfo,StreamingContext)
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNode Class > WebTreeViewNode Constructor : WebTreeViewNode Constructor(SerializationInfo,StreamingContext)

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

Dim instance As New WebTreeViewNode(info, context)
C#
protected WebTreeViewNode(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
protected WebTreeViewNode(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
protected function WebTreeViewNode(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
protected: WebTreeViewNode(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
protected:
WebTreeViewNode(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNode Class
WebTreeViewNode Members
Overload List


WebTreeViewNode Class Methods

[image]
Intersoft WebTreeView Documentation
WebTreeViewNode Class Methods
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace : WebTreeViewNode Class

Glossary Item Box

For a list of all members of this type, see WebTreeViewNode members.

Public Methods

 | Name | Description
Public Method | AddNode | Overloaded. Adds a new node to a WebTreeViewNode instance with no arguments.
Public Method | Check | Method used for checking a node.
Public Method | CheckAll | Method used for checking all node level.
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Collapse | Method used for collapsing a parent node.
Public Method | CollapseAll | Method used for collapsing all parent nodes.
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Expand | Method used for expanding a parent node.
Public Method | ExpandAll | Method used for expanding all parent nodes.
Public Method | ExpandHierarchyAndSelect | Method used for expanding a node's entire level and select itself. If a node has a child and grand child, all node levels will be expanded. If a node acts as a child node, the upper level node will be expanded.
Public Method | GetCurrentIndex | Method used for getting the current index of the selected node.
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | IsChildsVisible | Method used for determining whether the childe nodes (Visible = true) of the specified node is visible or not.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Navigate | Method used for navigating a node to a URL specified in NavigateURL property.
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Select | Method used for selecting a node.
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToggleExpandCollapse | Method used for toggling expand or collapse.
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | UnCheck | Method used for unchecking a node.
Public Method | UnCheckAll | Method used for unchecking all nodes.
Top

Protected Methods

 | Name | Description
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | IsInSerializationContext | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | OnItemAdd | (Inherited from ISNet.WebUI.NamedObjectBase)
Protected Method | OnItemRemove | (Inherited from ISNet.WebUI.NamedObjectBase)
Top

See Also

Reference

WebTreeViewNode Class
ISNet.WebUI.WebTreeView Namespace


AddNode Method

[image]
Intersoft WebTreeView Documentation
AddNode Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNode Class : AddNode Method

Glossary Item Box

Adds a new node to a WebTreeViewNode instance with no arguments. Adds a new node to a WebTreeViewNode instance.

Overload List

Overload | Description
AddNode() | Adds a new node to a WebTreeViewNode instance with no arguments.
AddNode(String) | Adds a new node to a WebTreeViewNode instance (the new node will be its child node) with String parameter as its name.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNode Class
WebTreeViewNode Members


AddNode() Method

[image]
Intersoft WebTreeView Documentation
AddNode() Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNode Class > AddNode Method : AddNode() Method

Glossary Item Box

Adds a new node to a WebTreeViewNode instance with no arguments.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Adds a new node to a WebTreeViewNode instance with no arguments. ")>
Public Overloads Function AddNode() As WebTreeViewNode
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNode
Dim value As WebTreeViewNode

value = instance.AddNode()
C#
[System.ComponentModel.DescriptionAttribute("Adds a new node to a WebTreeViewNode instance with no arguments. ")]
public WebTreeViewNode AddNode()
Delphi
public function AddNode(): WebTreeViewNode;
JScript
System.ComponentModel.DescriptionAttribute("Adds a new node to a WebTreeViewNode instance with no arguments. ")
public function AddNode() : WebTreeViewNode;
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Adds a new node to a WebTreeViewNode instance with no arguments. ")]
public: WebTreeViewNode* AddNode();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Adds a new node to a WebTreeViewNode instance with no arguments. ")]
public:
WebTreeViewNode^ AddNode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNode Class
WebTreeViewNode Members
Overload List


AddNode(String) Method

[image]
Intersoft WebTreeView Documentation
AddNode(String) Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNode Class > AddNode Method : AddNode(String) Method

name
Name of the new WebTreeViewNode instance.

Glossary Item Box

Adds a new node to a WebTreeViewNode instance (the new node will be its child node) with String parameter as its name.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Adds a new node to a WebTreeViewNode instance (the new node will be its child node) with String parameter as its name.")>
Public Overloads Function AddNode( _
   ByVal name As System.String _
) As WebTreeViewNode
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNode
Dim name As System.String
Dim value As WebTreeViewNode

value = instance.AddNode(name)
C#
[System.ComponentModel.DescriptionAttribute("Adds a new node to a WebTreeViewNode instance (the new node will be its child node) with String parameter as its name.")]
public WebTreeViewNode AddNode(
   System.string name
)
Delphi
public function AddNode(
    name: System.String
): WebTreeViewNode;
JScript
System.ComponentModel.DescriptionAttribute("Adds a new node to a WebTreeViewNode instance (the new node will be its child node) with String parameter as its name.")
public function AddNode(
   name : System.String
) : WebTreeViewNode;
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Adds a new node to a WebTreeViewNode instance (the new node will be its child node) with String parameter as its name.")]
public: WebTreeViewNode* AddNode(
   System.string* name
)
C++/CLI
[System.ComponentModel.DescriptionAttribute("Adds a new node to a WebTreeViewNode instance (the new node will be its child node) with String parameter as its name.")]
public:
WebTreeViewNode^ AddNode(
   System.String^ name
)

Parameters

name
Name of the new WebTreeViewNode instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNode Class
WebTreeViewNode Members
Overload List


Check Method

[image]
Intersoft WebTreeView Documentation
Check Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNode Class : Check Method

Glossary Item Box

Method used for checking a node.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Method use for checking a node. ")>
Public Sub Check()
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNode

instance.Check()
C#
[System.ComponentModel.DescriptionAttribute("Method use for checking a node. ")]
public void Check()
Delphi
public procedure Check();
JScript
System.ComponentModel.DescriptionAttribute("Method use for checking a node. ")
public function Check();
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Method use for checking a node. ")]
public: void Check();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Method use for checking a node. ")]
public:
void Check();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNode Class
WebTreeViewNode Members


CheckAll Method

[image]
Intersoft WebTreeView Documentation
CheckAll Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNode Class : CheckAll Method

Glossary Item Box

Method used for checking all node level.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Method use for checking all node level. ")>
Public Sub CheckAll()
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNode

instance.CheckAll()
C#
[System.ComponentModel.DescriptionAttribute("Method use for checking all node level. ")]
public void CheckAll()
Delphi
public procedure CheckAll();
JScript
System.ComponentModel.DescriptionAttribute("Method use for checking all node level. ")
public function CheckAll();
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Method use for checking all node level. ")]
public: void CheckAll();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Method use for checking all node level. ")]
public:
void CheckAll();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNode Class
WebTreeViewNode Members


Collapse Method

[image]
Intersoft WebTreeView Documentation
Collapse Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNode Class : Collapse Method

Glossary Item Box

Method used for collapsing a parent node.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Method use for collapsing a parent node. ")>
Public Sub Collapse()
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNode

instance.Collapse()
C#
[System.ComponentModel.DescriptionAttribute("Method use for collapsing a parent node. ")]
public void Collapse()
Delphi
public procedure Collapse();
JScript
System.ComponentModel.DescriptionAttribute("Method use for collapsing a parent node. ")
public function Collapse();
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Method use for collapsing a parent node. ")]
public: void Collapse();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Method use for collapsing a parent node. ")]
public:
void Collapse();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNode Class
WebTreeViewNode Members


CollapseAll Method

[image]
Intersoft WebTreeView Documentation
CollapseAll Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNode Class : CollapseAll Method

Glossary Item Box

Method used for collapsing all parent nodes.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Method use for collapsing all parent nodes. ")>
Public Sub CollapseAll()
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNode

instance.CollapseAll()
C#
[System.ComponentModel.DescriptionAttribute("Method use for collapsing all parent nodes. ")]
public void CollapseAll()
Delphi
public procedure CollapseAll();
JScript
System.ComponentModel.DescriptionAttribute("Method use for collapsing all parent nodes. ")
public function CollapseAll();
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Method use for collapsing all parent nodes. ")]
public: void CollapseAll();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Method use for collapsing all parent nodes. ")]
public:
void CollapseAll();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNode Class
WebTreeViewNode Members


Expand Method

[image]
Intersoft WebTreeView Documentation
Expand Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNode Class : Expand Method

Glossary Item Box

Method used for expanding a parent node.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Method use for expanding a parent node. ")>
Public Sub Expand()
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNode

instance.Expand()
C#
[System.ComponentModel.DescriptionAttribute("Method use for expanding a parent node. ")]
public void Expand()
Delphi
public procedure Expand();
JScript
System.ComponentModel.DescriptionAttribute("Method use for expanding a parent node. ")
public function Expand();
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Method use for expanding a parent node. ")]
public: void Expand();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Method use for expanding a parent node. ")]
public:
void Expand();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNode Class
WebTreeViewNode Members


ExpandAll Method

[image]
Intersoft WebTreeView Documentation
ExpandAll Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNode Class : ExpandAll Method

Glossary Item Box

Method used for expanding all parent nodes.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Method use for expanding all parent nodes. ")>
Public Sub ExpandAll()
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNode

instance.ExpandAll()
C#
[System.ComponentModel.DescriptionAttribute("Method use for expanding all parent nodes. ")]
public void ExpandAll()
Delphi
public procedure ExpandAll();
JScript
System.ComponentModel.DescriptionAttribute("Method use for expanding all parent nodes. ")
public function ExpandAll();
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Method use for expanding all parent nodes. ")]
public: void ExpandAll();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Method use for expanding all parent nodes. ")]
public:
void ExpandAll();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNode Class
WebTreeViewNode Members


ExpandHierarchyAndSelect Method

[image]
Intersoft WebTreeView Documentation
ExpandHierarchyAndSelect Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNode Class : ExpandHierarchyAndSelect Method

Glossary Item Box

Method used for expanding a node's entire level and select itself. If a node has a child and grand child, all node levels will be expanded. If a node acts as a child node, the upper level node will be expanded.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Method used for expanding a node's entire level and select itself. If a node has a child and grand child, all node levels will be expanded. If a node acts as a child node, the upper level node will be expanded. ")>
Public Sub ExpandHierarchyAndSelect()
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNode

instance.ExpandHierarchyAndSelect()
C#
[System.ComponentModel.DescriptionAttribute("Method used for expanding a node's entire level and select itself. If a node has a child and grand child, all node levels will be expanded. If a node acts as a child node, the upper level node will be expanded. ")]
public void ExpandHierarchyAndSelect()
Delphi
public procedure ExpandHierarchyAndSelect();
JScript
System.ComponentModel.DescriptionAttribute("Method used for expanding a node's entire level and select itself. If a node has a child and grand child, all node levels will be expanded. If a node acts as a child node, the upper level node will be expanded. ")
public function ExpandHierarchyAndSelect();
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Method used for expanding a node's entire level and select itself. If a node has a child and grand child, all node levels will be expanded. If a node acts as a child node, the upper level node will be expanded. ")]
public: void ExpandHierarchyAndSelect();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Method used for expanding a node's entire level and select itself. If a node has a child and grand child, all node levels will be expanded. If a node acts as a child node, the upper level node will be expanded. ")]
public:
void ExpandHierarchyAndSelect();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNode Class
WebTreeViewNode Members


GetCurrentIndex Method

[image]
Intersoft WebTreeView Documentation
GetCurrentIndex Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNode Class : GetCurrentIndex Method

Glossary Item Box

Method used for getting the current index of the selected node.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Method use for getting the current index of the selected node.")>
Public Function GetCurrentIndex() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNode
Dim value As System.Integer

value = instance.GetCurrentIndex()
C#
[System.ComponentModel.DescriptionAttribute("Method use for getting the current index of the selected node.")]
public System.int GetCurrentIndex()
Delphi
public function GetCurrentIndex(): System.Integer;
JScript
System.ComponentModel.DescriptionAttribute("Method use for getting the current index of the selected node.")
public function GetCurrentIndex() : System.int;
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Method use for getting the current index of the selected node.")]
public: System.int GetCurrentIndex();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Method use for getting the current index of the selected node.")]
public:
System.int GetCurrentIndex();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNode Class
WebTreeViewNode Members


IsChildsVisible Method

[image]
Intersoft WebTreeView Documentation
IsChildsVisible Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNode Class : IsChildsVisible Method

Glossary Item Box

Method used for determining whether the childe nodes (Visible = true) of the specified node is visible or not.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Method use for determining whether the childe nodes (Visible = true) of the specified node is visible or not. ")>
Public Function IsChildsVisible() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNode
Dim value As System.Boolean

value = instance.IsChildsVisible()
C#
[System.ComponentModel.DescriptionAttribute("Method use for determining whether the childe nodes (Visible = true) of the specified node is visible or not. ")]
public System.bool IsChildsVisible()
Delphi
public function IsChildsVisible(): System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Method use for determining whether the childe nodes (Visible = true) of the specified node is visible or not. ")
public function IsChildsVisible() : System.boolean;
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Method use for determining whether the childe nodes (Visible = true) of the specified node is visible or not. ")]
public: System.bool IsChildsVisible();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Method use for determining whether the childe nodes (Visible = true) of the specified node is visible or not. ")]
public:
System.bool IsChildsVisible();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNode Class
WebTreeViewNode Members


Navigate Method

[image]
Intersoft WebTreeView Documentation
Navigate Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNode Class : Navigate Method

Glossary Item Box

Method used for navigating a node to a URL specified in NavigateURL property.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Method use for navigating a node to a URL specified in NavigateURL property. ")>
Public Sub Navigate()
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNode

instance.Navigate()
C#
[System.ComponentModel.DescriptionAttribute("Method use for navigating a node to a URL specified in NavigateURL property. ")]
public void Navigate()
Delphi
public procedure Navigate();
JScript
System.ComponentModel.DescriptionAttribute("Method use for navigating a node to a URL specified in NavigateURL property. ")
public function Navigate();
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Method use for navigating a node to a URL specified in NavigateURL property. ")]
public: void Navigate();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Method use for navigating a node to a URL specified in NavigateURL property. ")]
public:
void Navigate();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNode Class
WebTreeViewNode Members


Select Method

[image]
Intersoft WebTreeView Documentation
Select Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNode Class : Select Method

Glossary Item Box

Method used for selecting a node.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Method use for selecting a node. ")>
Public Sub Select()
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNode

instance.Select()
C#
[System.ComponentModel.DescriptionAttribute("Method use for selecting a node. ")]
public void Select()
Delphi
public procedure Select();
JScript
System.ComponentModel.DescriptionAttribute("Method use for selecting a node. ")
public function Select();
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Method use for selecting a node. ")]
public: void Select();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Method use for selecting a node. ")]
public:
void Select();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNode Class
WebTreeViewNode Members


ToggleExpandCollapse Method

[image]
Intersoft WebTreeView Documentation
ToggleExpandCollapse Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNode Class : ToggleExpandCollapse Method

Glossary Item Box

Method used for toggling expand or collapse.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Method use for toggling expand or collapse. ")>
Public Sub ToggleExpandCollapse()
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNode

instance.ToggleExpandCollapse()
C#
[System.ComponentModel.DescriptionAttribute("Method use for toggling expand or collapse. ")]
public void ToggleExpandCollapse()
Delphi
public procedure ToggleExpandCollapse();
JScript
System.ComponentModel.DescriptionAttribute("Method use for toggling expand or collapse. ")
public function ToggleExpandCollapse();
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Method use for toggling expand or collapse. ")]
public: void ToggleExpandCollapse();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Method use for toggling expand or collapse. ")]
public:
void ToggleExpandCollapse();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNode Class
WebTreeViewNode Members


UnCheck Method

[image]
Intersoft WebTreeView Documentation
UnCheck Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNode Class : UnCheck Method

Glossary Item Box

Method used for unchecking a node.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Method use for unchecking a node. ")>
Public Sub UnCheck()
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNode

instance.UnCheck()
C#
[System.ComponentModel.DescriptionAttribute("Method use for unchecking a node. ")]
public void UnCheck()
Delphi
public procedure UnCheck();
JScript
System.ComponentModel.DescriptionAttribute("Method use for unchecking a node. ")
public function UnCheck();
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Method use for unchecking a node. ")]
public: void UnCheck();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Method use for unchecking a node. ")]
public:
void UnCheck();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNode Class
WebTreeViewNode Members


UnCheckAll Method

[image]
Intersoft WebTreeView Documentation
UnCheckAll Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNode Class : UnCheckAll Method

Glossary Item Box

Method used for unchecking all nodes.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Method use for unchecking all nodes. ")>
Public Sub UnCheckAll()
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNode

instance.UnCheckAll()
C#
[System.ComponentModel.DescriptionAttribute("Method use for unchecking all nodes. ")]
public void UnCheckAll()
Delphi
public procedure UnCheckAll();
JScript
System.ComponentModel.DescriptionAttribute("Method use for unchecking all nodes. ")
public function UnCheckAll();
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Method use for unchecking all nodes. ")]
public: void UnCheckAll();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Method use for unchecking all nodes. ")]
public:
void UnCheckAll();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNode Class
WebTreeViewNode Members


WebTreeViewNode Class Properties

[image]
Intersoft WebTreeView Documentation
WebTreeViewNode Class Properties
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace : WebTreeViewNode Class

Glossary Item Box

For a list of all members of this type, see WebTreeViewNode members.

Public Properties

 | Name | Description
Public Property | AllowDrag | Determines whether this node can be dragged by end user.Specifies whether a node is allowed to be dragged or not.
Public Property | AllowDrop | Determines whether this node accept drop in a drag drop operation.Specifies whether a node is allowed to be dropped or not.
Public Property | AllowEditing | Specifies whether to allow edit.Specifies whether a node is allowed to be edited or not.
Public Property | Checked | Specifies whether the node is currently checked.Determines whether the specified node is currently checked or not.
Public Property | CheckedState | Gets or sets the checked state of the node.Determines the checked state of the node.
Public Property | ChildNodeExpandable | Specifies whether the node is expandable when it has childnodes.Specifies whether the child nodes of the specified node is expandable or not.
Public Property | Collection | (Inherited from ISNet.WebUI.NamedObjectBase)
Public Property | ContentTemplate | A fully customizable template used to hold custom node.
Public Property | CustomStyle | Gets or sets custom css style of the node.Gets or sets the custom CSS style of the node.
Public Property | DataItem | Specifies data from a node. The data can be a value from XML, if the WebTreeView is bound to XMLDataSource.
Public Property | Depth | Gets the depth level of the node.Gets or sets the Depth of the databindings.
Public Property | Enabled | Indicates whether the node is enable or disable.Indicates whether the node is enabled or disabled.
Public Property | Expanded | Specifies whether the node is currently expanded.Specifies whether the node is currently expanded or not.
Public Property | ExpandedImage | icon image to use if the node is expanded Gets or sets the expanded icon image of the node.
Public Property | Image | icon image to use if the node is collapsed Gets or sets the icon image of the node.
Public Property | ImageToolTip | Gets or sets the image tooltip text of the node.Gets or sets the image tooltip text of the node.
Public Property | MaxBindingDepth | Specifies relative max binding depth.Specifies relative maximum binding depth.
Public Property | Name | Overridden. Specifies the name of the node.
Public Property | NavigateURL | URL to load sub-tree contents from (XML).Specifies the URL to be loaded for sub-tree contents.
Public Property | NextSibling | Determines the next node (in the same level) of the specified node.
Public Property | Nodes | The collection of nodes for WebTreeView.Specifies a collection of WebTreeView's nodes.
Public Property | NodeType | Gets or sets the type of the node.Determines the type of a node, whether it is a root node, parent node, or leaf node.
Public Property | ParentNode | Determines whether the specified node is a parent node and has at least one child node.
Public Property | Path | Gets the path from the root node to the current nodeGets or sets the path of a node, path from the root node to the node itself.
Public Property | PreviousSibling | Determines the previous node (in the same level) of the specified node.
Public Property | Selectable | Indicates whether the node is selectable.Indicates whether the node is selectable or not.
Public Property | Selected | Specifies whether the node is currently selected.Indicates whether the node is selected or not.
Public Property | SelectedExpandedImage | icon image to use if the node is expanded Gets or sets the expanded icon image of the selected node.
Public Property | SelectedImage | icon image to use if the node is collapsed Gets or sets the collapsed icon image of the selected node.
Public Property | Sequence | Gets the sequence level of the node.Determines the index of a node viewed from the entire nodes in WebTreeView.
Public Property | ShowCheckBox | Specifies whether to show checkbox next to the node.Specifies whether to show checkbox next to a node.
Public Property | Tag | A holding custom info related to the node.A holding custom info related to the node.
Public Property | Target | The navigate target used when the node is selected.The navigate target used when the node is selected.
Public Property | Text | Gets or sets the display text of the node.Gets or sets the displayed text of the node.
Public Property | TextImage | Text image of the node. Gets or sets the text image of the node.
Public Property | TextImageToolTip | Gets or sets the tooltip text image of the node.Specifies the specified node's tooltip textimage.
Public Property | ToolTip | Gets or sets the tooltip text of the node.Gets or sets the tooltip text of the node.
Public Property | Value | Gets or sets the value of the node.
Public Property | Visible | Indicates whether the node is visible.Indicates whether the node is visible or invisible.
Top

See Also

Reference

WebTreeViewNode Class
ISNet.WebUI.WebTreeView Namespace


AllowDrag Property

[image]
Intersoft WebTreeView Documentation
AllowDrag Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNode Class : AllowDrag Property

Glossary Item Box

Determines whether this node can be dragged by end user.Specifies whether a node is allowed to be dragged or not.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Determines whether this node can be dragged by end user.")>
Public Property AllowDrag As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNode
Dim value As System.Boolean

instance.AllowDrag = value

value = instance.AllowDrag
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Determines whether this node can be dragged by end user.")]
public System.bool AllowDrag {get; set;}
Delphi
public read-write property AllowDrag: System.Boolean;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Determines whether this node can be dragged by end user.")
public function get,set AllowDrag : System.boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Determines whether this node can be dragged by end user.")]
public: __property System.bool get_AllowDrag();
public: __property void set_AllowDrag(
   System.bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Determines whether this node can be dragged by end user.")]
public:
property System.bool AllowDrag {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNode Class
WebTreeViewNode Members


AllowDrop Property

[image]
Intersoft WebTreeView Documentation
AllowDrop Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNode Class : AllowDrop Property

Glossary Item Box

Determines whether this node accept drop in a drag drop operation.Specifies whether a node is allowed to be dropped or not.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Determines whether this node accept drop in a drag drop operation.")>
Public Property AllowDrop As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNode
Dim value As System.Boolean

instance.AllowDrop = value

value = instance.AllowDrop
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether this node accept drop in a drag drop operation.")]
public System.bool AllowDrop {get; set;}
Delphi
public read-write property AllowDrop: System.Boolean;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Determines whether this node accept drop in a drag drop operation.")
public function get,set AllowDrop : System.boolean
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether this node accept drop in a drag drop operation.")]
public: __property System.bool get_AllowDrop();
public: __property void set_AllowDrop(
   System.bool value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether this node accept drop in a drag drop operation.")]
public:
property System.bool AllowDrop {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNode Class
WebTreeViewNode Members


AllowEditing Property

[image]
Intersoft WebTreeView Documentation
AllowEditing Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNode Class : AllowEditing Property

Glossary Item Box

Specifies whether to allow edit.Specifies whether a node is allowed to be edited or not.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether to allow edit.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property AllowEditing As AllowEditing
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNode
Dim value As AllowEditing

instance.AllowEditing = value

value = instance.AllowEditing
C#
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether to allow edit.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public AllowEditing AllowEditing {get; set;}
Delphi
public read-write property AllowEditing: AllowEditing;
JScript
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether to allow edit.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set AllowEditing : AllowEditing
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether to allow edit.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property AllowEditing get_AllowEditing();
public: __property void set_AllowEditing(
   AllowEditing value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether to allow edit.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property AllowEditing AllowEditing {
   AllowEditing get();
   void set (    AllowEditing value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNode Class
WebTreeViewNode Members


Checked Property

[image]
Intersoft WebTreeView Documentation
Checked Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNode Class : Checked Property

Glossary Item Box

Specifies whether the node is currently checked.Determines whether the specified node is currently checked or not.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies whether the node is currently checked.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property Checked As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNode
Dim value As System.Boolean

instance.Checked = value

value = instance.Checked
C#
[System.ComponentModel.DescriptionAttribute("Specifies whether the node is currently checked.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.bool Checked {get; set;}
Delphi
public read-write property Checked: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Specifies whether the node is currently checked.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set Checked : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies whether the node is currently checked.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.bool get_Checked();
public: __property void set_Checked(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies whether the node is currently checked.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.bool Checked {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNode Class
WebTreeViewNode Members


CheckedState Property

[image]
Intersoft WebTreeView Documentation
CheckedState Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNode Class : CheckedState Property

Glossary Item Box

Gets or sets the checked state of the node.Determines the checked state of the node.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the checked state of the node.")>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Property CheckedState As CheckState
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNode
Dim value As CheckState

instance.CheckedState = value

value = instance.CheckedState
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the checked state of the node.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
public CheckState CheckedState {get; set;}
Delphi
public read-write property CheckedState: CheckState;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the checked state of the node.")
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set CheckedState : CheckState
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the checked state of the node.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property CheckState get_CheckedState();
public: __property void set_CheckedState(
   CheckState value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the checked state of the node.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
property CheckState CheckedState {
   CheckState get();
   void set (    CheckState value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNode Class
WebTreeViewNode Members


ChildNodeExpandable Property

[image]
Intersoft WebTreeView Documentation
ChildNodeExpandable Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNode Class : ChildNodeExpandable Property

Glossary Item Box

Specifies whether the node is expandable when it has childnodes.Specifies whether the child nodes of the specified node is expandable or not.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.DescriptionAttribute("Specifies whether the node is expandable when it has childnodes.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property ChildNodeExpandable As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNode
Dim value As System.Boolean

instance.ChildNodeExpandable = value

value = instance.ChildNodeExpandable
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute("Specifies whether the node is expandable when it has childnodes.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.bool ChildNodeExpandable {get; set;}
Delphi
public read-write property ChildNodeExpandable: System.Boolean;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.DescriptionAttribute("Specifies whether the node is expandable when it has childnodes.")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set ChildNodeExpandable : System.boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute("Specifies whether the node is expandable when it has childnodes.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.bool get_ChildNodeExpandable();
public: __property void set_ChildNodeExpandable(
   System.bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute("Specifies whether the node is expandable when it has childnodes.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.bool ChildNodeExpandable {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNode Class
WebTreeViewNode Members


ContentTemplate Property

[image]
Intersoft WebTreeView Documentation
ContentTemplate Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNode Class : ContentTemplate Property

Glossary Item Box

A fully customizable template used to hold custom node.

Syntax

Visual Basic (Declaration)
<System.Web.UI.TemplateContainerAttribute(BindingDirection=BindingDirection.TwoWay, ContainerType=ISNet.WebUI.WebTreeView.WebContainerViewItem)>
<System.ComponentModel.BrowsableAttribute(False)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public Property ContentTemplate As System.Web.UI.ITemplate
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNode
Dim value As System.Web.UI.ITemplate

instance.ContentTemplate = value

value = instance.ContentTemplate
C#
[System.Web.UI.TemplateContainerAttribute(BindingDirection=BindingDirection.TwoWay, ContainerType=ISNet.WebUI.WebTreeView.WebContainerViewItem)]
[System.ComponentModel.BrowsableAttribute(false)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public System.Web.UI.ITemplate ContentTemplate {get; set;}
Delphi
public read-write property ContentTemplate: System.Web.UI.ITemplate;
JScript
System.Web.UI.TemplateContainerAttribute(BindingDirection=BindingDirection.TwoWay, ContainerType=ISNet.WebUI.WebTreeView.WebContainerViewItem)
System.ComponentModel.BrowsableAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
public function get,set ContentTemplate : System.Web.UI.ITemplate
Managed Extensions for C++
[System.Web.UI.TemplateContainerAttribute(BindingDirection=BindingDirection.TwoWay, ContainerType=ISNet.WebUI.WebTreeView.WebContainerViewItem)]
[System.ComponentModel.BrowsableAttribute(false)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public: __property System.Web.UI.ITemplate* get_ContentTemplate();
public: __property void set_ContentTemplate(
   System.Web.UI.ITemplate* value
);
C++/CLI
[System.Web.UI.TemplateContainerAttribute(BindingDirection=BindingDirection.TwoWay, ContainerType=ISNet.WebUI.WebTreeView.WebContainerViewItem)]
[System.ComponentModel.BrowsableAttribute(false)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public:
property System.Web.UI.ITemplate^ ContentTemplate {
   System.Web.UI.ITemplate^ get();
   void set (    System.Web.UI.ITemplate^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNode Class
WebTreeViewNode Members


CustomStyle Property

[image]
Intersoft WebTreeView Documentation
CustomStyle Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNode Class : CustomStyle Property

Glossary Item Box

Gets or sets custom css style of the node.Gets or sets the custom CSS style of the node.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets custom css style of the node.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Appearance")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property CustomStyle As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNode
Dim value As System.String

instance.CustomStyle = value

value = instance.CustomStyle
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets custom css style of the node.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string CustomStyle {get; set;}
Delphi
public read-write property CustomStyle: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets custom css style of the node.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Appearance")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set CustomStyle : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets custom css style of the node.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_CustomStyle();
public: __property void set_CustomStyle(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets custom css style of the node.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ CustomStyle {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNode Class
WebTreeViewNode Members


DataItem Property

[image]
Intersoft WebTreeView Documentation
DataItem Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNode Class : DataItem Property

Glossary Item Box

Specifies data from a node. The data can be a value from XML, if the WebTreeView is bound to XMLDataSource.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
Public Property DataItem As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNode
Dim value As System.Object

instance.DataItem = value

value = instance.DataItem
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public System.object DataItem {get; set;}
Delphi
public read-write property DataItem: System.TObject;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
public function get,set DataItem : System.Object
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public: __property System.Object* get_DataItem();
public: __property void set_DataItem(
   System.Object* value
);
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public:
property System.Object^ DataItem {
   System.Object^ get();
   void set (    System.Object^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNode Class
WebTreeViewNode Members


Depth Property

[image]
Intersoft WebTreeView Documentation
Depth Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNode Class : Depth Property

Glossary Item Box

Gets the depth level of the node.Gets or sets the Depth of the databindings.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.DescriptionAttribute("Gets the depth level of the node.")>
Public ReadOnly Property Depth As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNode
Dim value As System.Integer

value = instance.Depth
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.DescriptionAttribute("Gets the depth level of the node.")]
public System.int Depth {get;}
Delphi
public read-only property Depth: System.Integer;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.DescriptionAttribute("Gets the depth level of the node.")
public function get Depth : System.int
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.DescriptionAttribute("Gets the depth level of the node.")]
public: __property System.int get_Depth();
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.DescriptionAttribute("Gets the depth level of the node.")]
public:
property System.int Depth {
   System.int get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNode Class
WebTreeViewNode Members


Enabled Property

[image]
Intersoft WebTreeView Documentation
Enabled Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNode Class : Enabled Property

Glossary Item Box

Indicates whether the node is enable or disable.Indicates whether the node is enabled or disabled.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Indicates whether the node is enable or disable.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property Enabled As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNode
Dim value As System.Boolean

instance.Enabled = value

value = instance.Enabled
C#
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Indicates whether the node is enable or disable.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.bool Enabled {get; set;}
Delphi
public read-write property Enabled: System.Boolean;
JScript
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Indicates whether the node is enable or disable.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set Enabled : System.boolean
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Indicates whether the node is enable or disable.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.bool get_Enabled();
public: __property void set_Enabled(
   System.bool value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Indicates whether the node is enable or disable.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.bool Enabled {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNode Class
WebTreeViewNode Members


Expanded Property

[image]
Intersoft WebTreeView Documentation
Expanded Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNode Class : Expanded Property

Glossary Item Box

Specifies whether the node is currently expanded.Specifies whether the node is currently expanded or not.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies whether the node is currently expanded.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Expanded As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNode
Dim value As System.Boolean

instance.Expanded = value

value = instance.Expanded
C#
[System.ComponentModel.DescriptionAttribute("Specifies whether the node is currently expanded.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool Expanded {get; set;}
Delphi
public read-write property Expanded: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Specifies whether the node is currently expanded.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set Expanded : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies whether the node is currently expanded.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_Expanded();
public: __property void set_Expanded(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies whether the node is currently expanded.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool Expanded {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNode Class
WebTreeViewNode Members


ExpandedImage Property

[image]
Intersoft WebTreeView Documentation
ExpandedImage Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNode Class : ExpandedImage Property

Glossary Item Box

icon image to use if the node is expanded Gets or sets the expanded icon image of the node.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Appearance")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the icon image of the node. (apply to expanded node)")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property ExpandedImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNode
Dim value As System.String

instance.ExpandedImage = value

value = instance.ExpandedImage
C#
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the icon image of the node. (apply to expanded node)")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string ExpandedImage {get; set;}
Delphi
public read-write property ExpandedImage: System.String;
JScript
System.ComponentModel.CategoryAttribute("Appearance")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the icon image of the node. (apply to expanded node)")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set ExpandedImage : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the icon image of the node. (apply to expanded node)")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_ExpandedImage();
public: __property void set_ExpandedImage(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the icon image of the node. (apply to expanded node)")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ ExpandedImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNode Class
WebTreeViewNode Members


Image Property

[image]
Intersoft WebTreeView Documentation
Image Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNode Class : Image Property

Glossary Item Box

icon image to use if the node is collapsed Gets or sets the icon image of the node.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the icon image of the node. (apply to collapsed node)")>
Public Property Image As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNode
Dim value As System.String

instance.Image = value

value = instance.Image
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the icon image of the node. (apply to collapsed node)")]
public System.string Image {get; set;}
Delphi
public read-write property Image: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.DescriptionAttribute("Gets or sets the icon image of the node. (apply to collapsed node)")
public function get,set Image : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the icon image of the node. (apply to collapsed node)")]
public: __property System.string* get_Image();
public: __property void set_Image(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the icon image of the node. (apply to collapsed node)")]
public:
property System.String^ Image {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNode Class
WebTreeViewNode Members


ImageToolTip Property

[image]
Intersoft WebTreeView Documentation
ImageToolTip Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNode Class : ImageToolTip Property

Glossary Item Box

Gets or sets the image tooltip text of the node.Gets or sets the image tooltip text of the node.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the image tooltip text of the node.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property ImageToolTip As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNode
Dim value As System.String

instance.ImageToolTip = value

value = instance.ImageToolTip
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image tooltip text of the node.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string ImageToolTip {get; set;}
Delphi
public read-write property ImageToolTip: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.DescriptionAttribute("Gets or sets the image tooltip text of the node.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set ImageToolTip : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image tooltip text of the node.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_ImageToolTip();
public: __property void set_ImageToolTip(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image tooltip text of the node.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ ImageToolTip {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNode Class
WebTreeViewNode Members


MaxBindingDepth Property

[image]
Intersoft WebTreeView Documentation
MaxBindingDepth Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNode Class : MaxBindingDepth Property

Glossary Item Box

Specifies relative max binding depth.Specifies relative maximum binding depth.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies relative max binding depth.")>
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property MaxBindingDepth As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNode
Dim value As System.Integer

instance.MaxBindingDepth = value

value = instance.MaxBindingDepth
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies relative max binding depth.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.int MaxBindingDepth {get; set;}
Delphi
public read-write property MaxBindingDepth: System.Integer;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies relative max binding depth.")
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set MaxBindingDepth : System.int
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies relative max binding depth.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.int get_MaxBindingDepth();
public: __property void set_MaxBindingDepth(
   System.int value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies relative max binding depth.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.int MaxBindingDepth {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNode Class
WebTreeViewNode Members


Name Property

[image]
Intersoft WebTreeView Documentation
Name Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNode Class : Name Property

Glossary Item Box

Specifies the name of the node.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BrowsableAttribute(True)>
Public Overrides Property Name As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNode
Dim value As System.String

instance.Name = value

value = instance.Name
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BrowsableAttribute(true)]
public override System.string Name {get; set;}
Delphi
public read-write property Name: System.String; override;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BrowsableAttribute()
public override function get,set Name : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BrowsableAttribute(true)]
public: __property System.string* get_Name() override;
public: __property void set_Name(
   System.string* value
) override;
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BrowsableAttribute(true)]
public:
property System.String^ Name {
   System.String^ get() override;
   void set (    System.String^ value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNode Class
WebTreeViewNode Members


NavigateURL Property

[image]
Intersoft WebTreeView Documentation
NavigateURL Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNode Class : NavigateURL Property

Glossary Item Box

URL to load sub-tree contents from (XML).Specifies the URL to be loaded for sub-tree contents.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("URL to load sub-tree contents from (XML).")>
<System.ComponentModel.CategoryAttribute("Navigation")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property NavigateURL As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNode
Dim value As System.String

instance.NavigateURL = value

value = instance.NavigateURL
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("URL to load sub-tree contents from (XML).")]
[System.ComponentModel.CategoryAttribute("Navigation")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string NavigateURL {get; set;}
Delphi
public read-write property NavigateURL: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("URL to load sub-tree contents from (XML).")
System.ComponentModel.CategoryAttribute("Navigation")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set NavigateURL : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("URL to load sub-tree contents from (XML).")]
[System.ComponentModel.CategoryAttribute("Navigation")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_NavigateURL();
public: __property void set_NavigateURL(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("URL to load sub-tree contents from (XML).")]
[System.ComponentModel.CategoryAttribute("Navigation")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ NavigateURL {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNode Class
WebTreeViewNode Members


NextSibling Property

[image]
Intersoft WebTreeView Documentation
NextSibling Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNode Class : NextSibling Property

Glossary Item Box

Determines the next node (in the same level) of the specified node.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
Public ReadOnly Property NextSibling As WebTreeViewNode
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNode
Dim value As WebTreeViewNode

value = instance.NextSibling
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public WebTreeViewNode NextSibling {get;}
Delphi
public read-only property NextSibling: WebTreeViewNode;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
public function get NextSibling : WebTreeViewNode
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public: __property WebTreeViewNode* get_NextSibling();
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public:
property WebTreeViewNode^ NextSibling {
   WebTreeViewNode^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNode Class
WebTreeViewNode Members


Nodes Property

[image]
Intersoft WebTreeView Documentation
Nodes Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNode Class : Nodes Property

Glossary Item Box

The collection of nodes for WebTreeView.Specifies a collection of WebTreeView's nodes.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DescriptionAttribute("The collection of nodes for WebTreeView.")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerDefaultProperty)>
<ISNet.Serialization.BinarySerializableAttribute("SetNodes")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
Public ReadOnly Property Nodes As WebTreeViewNodeCollection
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNode
Dim value As WebTreeViewNodeCollection

value = instance.Nodes
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DescriptionAttribute("The collection of nodes for WebTreeView.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerDefaultProperty)]
[ISNet.Serialization.BinarySerializableAttribute("SetNodes")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public WebTreeViewNodeCollection Nodes {get;}
Delphi
public read-only property Nodes: WebTreeViewNodeCollection;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DescriptionAttribute("The collection of nodes for WebTreeView.")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerDefaultProperty)
ISNet.Serialization.BinarySerializableAttribute("SetNodes")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get Nodes : WebTreeViewNodeCollection
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DescriptionAttribute("The collection of nodes for WebTreeView.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerDefaultProperty)]
[ISNet.Serialization.BinarySerializableAttribute("SetNodes")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property WebTreeViewNodeCollection* get_Nodes();
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DescriptionAttribute("The collection of nodes for WebTreeView.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerDefaultProperty)]
[ISNet.Serialization.BinarySerializableAttribute("SetNodes")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property WebTreeViewNodeCollection^ Nodes {
   WebTreeViewNodeCollection^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNode Class
WebTreeViewNode Members


NodeType Property

[image]
Intersoft WebTreeView Documentation
NodeType Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNode Class : NodeType Property

Glossary Item Box

Gets or sets the type of the node.Determines the type of a node, whether it is a root node, parent node, or leaf node.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the type of the node.")>
<System.ComponentModel.BrowsableAttribute(False)>
Public ReadOnly Property NodeType As NodeType
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNode
Dim value As NodeType

value = instance.NodeType
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the type of the node.")]
[System.ComponentModel.BrowsableAttribute(false)]
public NodeType NodeType {get;}
Delphi
public read-only property NodeType: NodeType;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.DescriptionAttribute("Gets or sets the type of the node.")
System.ComponentModel.BrowsableAttribute()
public function get NodeType : NodeType
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the type of the node.")]
[System.ComponentModel.BrowsableAttribute(false)]
public: __property NodeType get_NodeType();
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the type of the node.")]
[System.ComponentModel.BrowsableAttribute(false)]
public:
property NodeType NodeType {
   NodeType get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNode Class
WebTreeViewNode Members


ParentNode Property

[image]
Intersoft WebTreeView Documentation
ParentNode Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNode Class : ParentNode Property

Glossary Item Box

Determines whether the specified node is a parent node and has at least one child node.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
Public ReadOnly Property ParentNode As WebTreeViewNode
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNode
Dim value As WebTreeViewNode

value = instance.ParentNode
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public WebTreeViewNode ParentNode {get;}
Delphi
public read-only property ParentNode: WebTreeViewNode;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
public function get ParentNode : WebTreeViewNode
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public: __property WebTreeViewNode* get_ParentNode();
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public:
property WebTreeViewNode^ ParentNode {
   WebTreeViewNode^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNode Class
WebTreeViewNode Members


Path Property

[image]
Intersoft WebTreeView Documentation
Path Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNode Class : Path Property

Glossary Item Box

Gets the path from the root node to the current nodeGets or sets the path of a node, path from the root node to the node itself.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets the path from the root node to the current node")>
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public ReadOnly Property Path As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNode
Dim value As System.String

value = instance.Path
C#
[System.ComponentModel.DescriptionAttribute("Gets the path from the root node to the current node")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public System.string Path {get;}
Delphi
public read-only property Path: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Gets the path from the root node to the current node")
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get Path : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets the path from the root node to the current node")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property System.string* get_Path();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets the path from the root node to the current node")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property System.String^ Path {
   System.String^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNode Class
WebTreeViewNode Members


PreviousSibling Property

[image]
Intersoft WebTreeView Documentation
PreviousSibling Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNode Class : PreviousSibling Property

Glossary Item Box

Determines the previous node (in the same level) of the specified node.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public ReadOnly Property PreviousSibling As WebTreeViewNode
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNode
Dim value As WebTreeViewNode

value = instance.PreviousSibling
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public WebTreeViewNode PreviousSibling {get;}
Delphi
public read-only property PreviousSibling: WebTreeViewNode;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get PreviousSibling : WebTreeViewNode
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property WebTreeViewNode* get_PreviousSibling();
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property WebTreeViewNode^ PreviousSibling {
   WebTreeViewNode^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNode Class
WebTreeViewNode Members


Selectable Property

[image]
Intersoft WebTreeView Documentation
Selectable Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNode Class : Selectable Property

Glossary Item Box

Indicates whether the node is selectable.Indicates whether the node is selectable or not.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Indicates whether the node is selectable.")>
Public Property Selectable As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNode
Dim value As System.Boolean

instance.Selectable = value

value = instance.Selectable
C#
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Indicates whether the node is selectable.")]
public System.bool Selectable {get; set;}
Delphi
public read-write property Selectable: System.Boolean;
JScript
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Indicates whether the node is selectable.")
public function get,set Selectable : System.boolean
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Indicates whether the node is selectable.")]
public: __property System.bool get_Selectable();
public: __property void set_Selectable(
   System.bool value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Indicates whether the node is selectable.")]
public:
property System.bool Selectable {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNode Class
WebTreeViewNode Members


Selected Property

[image]
Intersoft WebTreeView Documentation
Selected Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNode Class : Selected Property

Glossary Item Box

Specifies whether the node is currently selected.Indicates whether the node is selected or not.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies whether the node is currently selected.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property Selected As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNode
Dim value As System.Boolean

instance.Selected = value

value = instance.Selected
C#
[System.ComponentModel.DescriptionAttribute("Specifies whether the node is currently selected.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.bool Selected {get; set;}
Delphi
public read-write property Selected: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Specifies whether the node is currently selected.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set Selected : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies whether the node is currently selected.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.bool get_Selected();
public: __property void set_Selected(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies whether the node is currently selected.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.bool Selected {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNode Class
WebTreeViewNode Members


SelectedExpandedImage Property

[image]
Intersoft WebTreeView Documentation
SelectedExpandedImage Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNode Class : SelectedExpandedImage Property

Glossary Item Box

icon image to use if the node is expanded Gets or sets the expanded icon image of the selected node.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the icon image of the selected node. (apply to expanded node)")>
<System.ComponentModel.CategoryAttribute("Appearance")>
Public Property SelectedExpandedImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNode
Dim value As System.String

instance.SelectedExpandedImage = value

value = instance.SelectedExpandedImage
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the icon image of the selected node. (apply to expanded node)")]
[System.ComponentModel.CategoryAttribute("Appearance")]
public System.string SelectedExpandedImage {get; set;}
Delphi
public read-write property SelectedExpandedImage: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the icon image of the selected node. (apply to expanded node)")
System.ComponentModel.CategoryAttribute("Appearance")
public function get,set SelectedExpandedImage : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the icon image of the selected node. (apply to expanded node)")]
[System.ComponentModel.CategoryAttribute("Appearance")]
public: __property System.string* get_SelectedExpandedImage();
public: __property void set_SelectedExpandedImage(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the icon image of the selected node. (apply to expanded node)")]
[System.ComponentModel.CategoryAttribute("Appearance")]
public:
property System.String^ SelectedExpandedImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNode Class
WebTreeViewNode Members


SelectedImage Property

[image]
Intersoft WebTreeView Documentation
SelectedImage Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNode Class : SelectedImage Property

Glossary Item Box

icon image to use if the node is collapsed Gets or sets the collapsed icon image of the selected node.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the icon image of the selected node. (apply to collapsed node)")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property SelectedImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNode
Dim value As System.String

instance.SelectedImage = value

value = instance.SelectedImage
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the icon image of the selected node. (apply to collapsed node)")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string SelectedImage {get; set;}
Delphi
public read-write property SelectedImage: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.DescriptionAttribute("Gets or sets the icon image of the selected node. (apply to collapsed node)")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set SelectedImage : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the icon image of the selected node. (apply to collapsed node)")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_SelectedImage();
public: __property void set_SelectedImage(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the icon image of the selected node. (apply to collapsed node)")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ SelectedImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNode Class
WebTreeViewNode Members


Sequence Property

[image]
Intersoft WebTreeView Documentation
Sequence Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNode Class : Sequence Property

Glossary Item Box

Gets the sequence level of the node.Determines the index of a node viewed from the entire nodes in WebTreeView.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.DescriptionAttribute("Gets the sequence level of the node.")>
<System.ComponentModel.BrowsableAttribute(False)>
Public ReadOnly Property Sequence As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNode
Dim value As System.Integer

value = instance.Sequence
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.DescriptionAttribute("Gets the sequence level of the node.")]
[System.ComponentModel.BrowsableAttribute(false)]
public System.int Sequence {get;}
Delphi
public read-only property Sequence: System.Integer;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.DescriptionAttribute("Gets the sequence level of the node.")
System.ComponentModel.BrowsableAttribute()
public function get Sequence : System.int
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.DescriptionAttribute("Gets the sequence level of the node.")]
[System.ComponentModel.BrowsableAttribute(false)]
public: __property System.int get_Sequence();
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.DescriptionAttribute("Gets the sequence level of the node.")]
[System.ComponentModel.BrowsableAttribute(false)]
public:
property System.int Sequence {
   System.int get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNode Class
WebTreeViewNode Members


ShowCheckBox Property

[image]
Intersoft WebTreeView Documentation
ShowCheckBox Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNode Class : ShowCheckBox Property

Glossary Item Box

Specifies whether to show checkbox next to the node.Specifies whether to show checkbox next to a node.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether to show checkbox next to the node.")>
Public Property ShowCheckBox As ShowCheckBox
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNode
Dim value As ShowCheckBox

instance.ShowCheckBox = value

value = instance.ShowCheckBox
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether to show checkbox next to the node.")]
public ShowCheckBox ShowCheckBox {get; set;}
Delphi
public read-write property ShowCheckBox: ShowCheckBox;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether to show checkbox next to the node.")
public function get,set ShowCheckBox : ShowCheckBox
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether to show checkbox next to the node.")]
public: __property ShowCheckBox get_ShowCheckBox();
public: __property void set_ShowCheckBox(
   ShowCheckBox value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether to show checkbox next to the node.")]
public:
property ShowCheckBox ShowCheckBox {
   ShowCheckBox get();
   void set (    ShowCheckBox value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNode Class
WebTreeViewNode Members


Tag Property

[image]
Intersoft WebTreeView Documentation
Tag Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNode Class : Tag Property

Glossary Item Box

A holding custom info related to the node.A holding custom info related to the node.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("A holding custom info related to the node.")>
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property Tag As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNode
Dim value As System.String

instance.Tag = value

value = instance.Tag
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("A holding custom info related to the node.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string Tag {get; set;}
Delphi
public read-write property Tag: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("A holding custom info related to the node.")
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set Tag : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("A holding custom info related to the node.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_Tag();
public: __property void set_Tag(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("A holding custom info related to the node.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ Tag {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNode Class
WebTreeViewNode Members


Target Property

[image]
Intersoft WebTreeView Documentation
Target Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNode Class : Target Property

Glossary Item Box

The navigate target used when the node is selected.The navigate target used when the node is selected.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("The navigate target used when the node is selected.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Navigation")>
Public Property Target As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNode
Dim value As System.String

instance.Target = value

value = instance.Target
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The navigate target used when the node is selected.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Navigation")]
public System.string Target {get; set;}
Delphi
public read-write property Target: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("The navigate target used when the node is selected.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Navigation")
public function get,set Target : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The navigate target used when the node is selected.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Navigation")]
public: __property System.string* get_Target();
public: __property void set_Target(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The navigate target used when the node is selected.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Navigation")]
public:
property System.String^ Target {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNode Class
WebTreeViewNode Members


Text Property

[image]
Intersoft WebTreeView Documentation
Text Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNode Class : Text Property

Glossary Item Box

Gets or sets the display text of the node.Gets or sets the displayed text of the node.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the display text of the node.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Appearance")>
Public Property Text As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNode
Dim value As System.String

instance.Text = value

value = instance.Text
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the display text of the node.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
public System.string Text {get; set;}
Delphi
public read-write property Text: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the display text of the node.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Appearance")
public function get,set Text : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the display text of the node.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
public: __property System.string* get_Text();
public: __property void set_Text(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the display text of the node.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
public:
property System.String^ Text {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNode Class
WebTreeViewNode Members


TextImage Property

[image]
Intersoft WebTreeView Documentation
TextImage Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNode Class : TextImage Property

Glossary Item Box

Text image of the node. Gets or sets the text image of the node.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the text image of the node. (apply to text)")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property TextImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNode
Dim value As System.String

instance.TextImage = value

value = instance.TextImage
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the text image of the node. (apply to text)")]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string TextImage {get; set;}
Delphi
public read-write property TextImage: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the text image of the node. (apply to text)")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set TextImage : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the text image of the node. (apply to text)")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_TextImage();
public: __property void set_TextImage(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the text image of the node. (apply to text)")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ TextImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNode Class
WebTreeViewNode Members


TextImageToolTip Property

[image]
Intersoft WebTreeView Documentation
TextImageToolTip Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNode Class : TextImageToolTip Property

Glossary Item Box

Gets or sets the tooltip text image of the node.Specifies the specified node's tooltip textimage.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Appearance")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the tooltip text image of the node.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property TextImageToolTip As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNode
Dim value As System.String

instance.TextImageToolTip = value

value = instance.TextImageToolTip
C#
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the tooltip text image of the node.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string TextImageToolTip {get; set;}
Delphi
public read-write property TextImageToolTip: System.String;
JScript
System.ComponentModel.CategoryAttribute("Appearance")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the tooltip text image of the node.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set TextImageToolTip : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the tooltip text image of the node.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_TextImageToolTip();
public: __property void set_TextImageToolTip(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the tooltip text image of the node.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ TextImageToolTip {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNode Class
WebTreeViewNode Members


ToolTip Property

[image]
Intersoft WebTreeView Documentation
ToolTip Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNode Class : ToolTip Property

Glossary Item Box

Gets or sets the tooltip text of the node.Gets or sets the tooltip text of the node.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the tooltip text of the node.")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property ToolTip As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNode
Dim value As System.String

instance.ToolTip = value

value = instance.ToolTip
C#
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the tooltip text of the node.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string ToolTip {get; set;}
Delphi
public read-write property ToolTip: System.String;
JScript
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the tooltip text of the node.")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set ToolTip : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the tooltip text of the node.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_ToolTip();
public: __property void set_ToolTip(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the tooltip text of the node.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ ToolTip {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNode Class
WebTreeViewNode Members


Value Property

[image]
Intersoft WebTreeView Documentation
Value Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNode Class : Value Property

Glossary Item Box

Gets or sets the value of the node.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property Value As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNode
Dim value As System.Object

instance.Value = value

value = instance.Value
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public System.object Value {get; set;}
Delphi
public read-write property Value: System.TObject;
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get,set Value : System.Object
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property System.Object* get_Value();
public: __property void set_Value(
   System.Object* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property System.Object^ Value {
   System.Object^ get();
   void set (    System.Object^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNode Class
WebTreeViewNode Members


Visible Property

[image]
Intersoft WebTreeView Documentation
Visible Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNode Class : Visible Property

Glossary Item Box

Indicates whether the node is visible.Indicates whether the node is visible or invisible.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Indicates whether the node is visible.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Visible As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNode
Dim value As System.Boolean

instance.Visible = value

value = instance.Visible
C#
[System.ComponentModel.DescriptionAttribute("Indicates whether the node is visible.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool Visible {get; set;}
Delphi
public read-write property Visible: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Indicates whether the node is visible.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.DefaultValueAttribute()
public function get,set Visible : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Indicates whether the node is visible.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_Visible();
public: __property void set_Visible(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Indicates whether the node is visible.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool Visible {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNode Class
WebTreeViewNode Members


WebTreeViewNodeBinding Class

[image]
Intersoft WebTreeView Documentation
WebTreeViewNodeBinding Class
Members See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace : WebTreeViewNodeBinding Class

Glossary Item Box

Represents a bound node which belongs to WebTreeView object. WebTreeViewNodeBinding provides you numerous properties which you can set to meet your need.

Object Model

WebTreeViewNodeBinding Class

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Represents a bound node which belongs to WebTreeView  object. WebTreeViewNodeBinding provides you numerous properties which you can set to meet your need. ")>
Public Class WebTreeViewNodeBinding
   Inherits ISNet.WebUI.NamedObjectBase
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBinding
C#
[System.ComponentModel.DescriptionAttribute("Represents a bound node which belongs to WebTreeView  object. WebTreeViewNodeBinding provides you numerous properties which you can set to meet your need. ")]
public class WebTreeViewNodeBinding : ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
Delphi
public class WebTreeViewNodeBinding = class(ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject)
JScript
System.ComponentModel.DescriptionAttribute("Represents a bound node which belongs to WebTreeView  object. WebTreeViewNodeBinding provides you numerous properties which you can set to meet your need. ")
public class WebTreeViewNodeBinding extends ISNet.WebUI.NamedObjectBase implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Represents a bound node which belongs to WebTreeView  object. WebTreeViewNodeBinding provides you numerous properties which you can set to meet your need. ")]
public __gc class WebTreeViewNodeBinding : public ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject
C++/CLI
[System.ComponentModel.DescriptionAttribute("Represents a bound node which belongs to WebTreeView  object. WebTreeViewNodeBinding provides you numerous properties which you can set to meet your need. ")]
public ref class WebTreeViewNodeBinding : public ISNet.WebUI.NamedObjectBase, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.NamedObjectBase
ISNet.WebUI.WebTreeView.WebTreeViewNodeBinding

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBinding Members
ISNet.WebUI.WebTreeView Namespace


WebTreeViewNodeBinding Class Members

[image]
Intersoft WebTreeView Documentation
WebTreeViewNodeBinding Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebTreeView Namespace : WebTreeViewNodeBinding Class

Glossary Item Box

The following tables list the members exposed by WebTreeViewNodeBinding.

Public Constructors

 | Name | Description
Public Constructor | WebTreeViewNodeBinding Constructor | Initializes a new instance of WebTreeViewImagesSettings class.
Top

Public Properties

 | Name | Description
Public Property | AllowEditing | Specifies whether to allow edit.Gets or sets a node edit ability.
Public Property | AllowEditingField | Specifies data field for AllowEditing.Gets or sets a node edit ability based on the XML value.
Public Property | Checked | Specifies whether the node is currently checked.Determines whether the node is checked or unchecked.
Public Property | CheckedField | Specifies data field for Checked.Determines whether the node is checked or unchecked based on XML value.
Public Property | CheckedState | Gets or sets the checked state of the node.Gets or sets the checked state of the node.
Public Property | CheckedStateField | Specifies data field for CheckedState.Gets or sets the checked state of the node based on the XML value.
Public Property | ChildNodeExpandable | Specifies whether the node is expandable when it has childnodes.Specifies whether the child nodes of the specified node is expandable or not.
Public Property | ChildNodeExpandableField | Specifies data field for ChildNodeExpandable.Specifies whether the child nodes of the specified node is expandable or not based on the XML value.
Public Property | Collection | (Inherited from ISNet.WebUI.NamedObjectBase)
Public Property | DataMember | Gets or sets the data member.Gets or sets the Data Member.
Public Property | Depth | Gets or sets the depth.Gets or sets the Depth of the databindings.
Public Property | Enabled | Indicates whether the node is enable or disable.Specifies whether the node is enabled or disabled.
Public Property | EnabledField | Specifies data field for Enabled.Specifies whether the node is enabled or disabled based on the XML value.
Public Property | Expanded | Specifies whether the node is currently expanded.Specifies whether the node is expanded or not.
Public Property | ExpandedField | Specifies data field for Expanded.Specifies whether the node is expanded or not based on the XML value.
Public Property | ExpandedImage | icon image to use if the node is expanded Gets or sets the expanded node image icon.
Public Property | ExpandedImageField | icon image to use if the node is expanded Gets or sets the expanded node image icon based on the XML value.
Public Property | Image | icon image to use if the node is collapsed Gets or sets the collapsed node image icon.
Public Property | ImageField | icon image to use if the node is collapsed Gets or sets the collapsed node image icon based on the XML value.
Public Property | ImageToolTip | Gets or sets the image tooltip text of the node.Gets or sets the tooltip image icon.
Public Property | ImageToolTipField | Specifies data field for ImageToolTip.Gets or sets the tooltip image icon based on XML value.
Public Property | MaxBindingDepth | Specifies relative max binding depth.Set the node level you want to bind.
Public Property | MaxBindingDepthField | Specifies data field for MaxBindingDepth.Set the node level you want to bind based on the XML value.
Public Property | Name | (Inherited from ISNet.WebUI.NamedObjectBase)
Public Property | NameField | Specifies name field for node name.Gets or sets the name of the node based on the XML value.
Public Property | NavigateURL | URL to load sub-tree contents from (XML).Gets or sets the URL when a node is selected.
Public Property | NavigateURLField | Specifies data field for NavigateURL.Gets or sets the URL when a node is selected based on XML value.
Public Property | Selectable | Indicates whether the node is selectable.Determines whether the node is selectable or not.
Public Property | SelectableField | Specifies data field for Selectable.Determines whether the node is selectable or not based on the XML value.
Public Property | Selected | Specifies whether the node is currently selected.Determines whether a node is selected or not.
Public Property | SelectedExpandedImage | icon image to use if the node is expanded Gets or sets the expanded image of the node.
Public Property | SelectedExpandedImageField | icon image to use if the node is expanded Gets or sets the expanded image of the node based on the XML value.
Public Property | SelectedField | Specifies data field for Selected.Determines whether a node is selected or not based on the XML value.
Public Property | SelectedImage | icon image to use if the node is collapsed Gets or sets the collapse icon image of the selected node.
Public Property | SelectedImageField | icon image to use if the node is collapsed Gets or sets the collapse icon image of the selected node based on the XML value.
Public Property | ShowCheckBox | Specifies whether to show checkbox next to the node.Determines whether to show checkbox next to a node or not.
Public Property | ShowCheckBoxField | Specifies data field for ShowCheckBox.Determines whether to show checkbox next to a node or not based on the XML value.
Public Property | Tag | Gets or sets tag data.Gets or sets a string which contains data about the WebTreeViewNode.
Public Property | TagField | Specifies data field for Tag.Gets or sets a string which contains data about the WebTreeViewNode based on the XML value.
Public Property | Target | The navigate target used when the node is selected.Specifies the target window when the node is clicked.
Public Property | TargetField | Specifies data field for Target.Specifies the target window when the node is clicked based on the XML value.
Public Property | Text | Gets or sets the display text of the node.Gets or sets the text of a node that you want to display.
Public Property | TextField | Specifies data field for Text.Gets or sets the text of a node that you want to display based on the XML value.
Public Property | TextImage | Gets or sets text image.Specifies the image of a node's text.
Public Property | TextImageField | Specifies name field for text image.Specifies the image of a node's text based on the XML value.
Public Property | TextImageToolTip | Gets or sets the tooltip text image of the node.Specifies the specified node's tooltip textimage.
Public Property | TextImageToolTipField | Specifies data field for Text Image ToolTip.Specifies the specified node's tooltip textimage based on the XML value.
Public Property | ToolTip | Gets or sets the tooltip text of the node.Gets or sets the tooltip of a node.
Public Property | ToolTipField | Specifies data field for ToolTip.Gets or sets the tooltip of a node based on the XML value.
Public Property | Value | Gets or sets the value of the value.Gets or sets the value of a node.
Public Property | ValueField | Specifies data field for Value.Gets or sets the value of a node based on the XML value.
Public Property | Visible | Indicates whether the node is visible.Determines whether a node is visible or invisible.
Public Property | VisibleField | Specifies data field for Visible.Determines whether a node is visible or invisible based on the XML value.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | (Inherited from ISNet.WebUI.NamedObjectBase)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | Overrides ToString() method.
Top

Protected Methods

 | Name | Description
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | IsInSerializationContext | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | OnItemAdd | (Inherited from ISNet.WebUI.NamedObjectBase)
Protected Method | OnItemRemove | (Inherited from ISNet.WebUI.NamedObjectBase)
Top

See Also

Reference

WebTreeViewNodeBinding Class
ISNet.WebUI.WebTreeView Namespace


WebTreeViewNodeBinding Constructor

[image]
Intersoft WebTreeView Documentation
WebTreeViewNodeBinding Constructor
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBinding Class : WebTreeViewNodeBinding Constructor

Glossary Item Box

Initializes a new instance of WebTreeViewImagesSettings class.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebTreeViewNodeBinding class. ")>
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebTreeViewNodeBinding()
C#
[System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebTreeViewNodeBinding class. ")]
public WebTreeViewNodeBinding()
Delphi
public WebTreeViewNodeBinding();
JScript
System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebTreeViewNodeBinding class. ")
public function WebTreeViewNodeBinding();
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebTreeViewNodeBinding class. ")]
public: WebTreeViewNodeBinding();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebTreeViewNodeBinding class. ")]
public:
WebTreeViewNodeBinding();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBinding Class
WebTreeViewNodeBinding Members


WebTreeViewNodeBinding Class Methods

[image]
Intersoft WebTreeView Documentation
WebTreeViewNodeBinding Class Methods
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace : WebTreeViewNodeBinding Class

Glossary Item Box

For a list of all members of this type, see WebTreeViewNodeBinding members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | (Inherited from ISNet.WebUI.NamedObjectBase)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | Overrides ToString() method.
Top

Protected Methods

 | Name | Description
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | IsInSerializationContext | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | OnItemAdd | (Inherited from ISNet.WebUI.NamedObjectBase)
Protected Method | OnItemRemove | (Inherited from ISNet.WebUI.NamedObjectBase)
Top

See Also

Reference

WebTreeViewNodeBinding Class
ISNet.WebUI.WebTreeView Namespace


ToString Method

[image]
Intersoft WebTreeView Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBinding Class : ToString Method

Glossary Item Box

Overrides ToString() method.

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBinding
Dim value As System.String

value = instance.ToString()
C#
public override System.string ToString()
Delphi
public function ToString(): System.String; override;
JScript
public override function ToString() : System.String;
Managed Extensions for C++
public: System.string* ToString(); override
C++/CLI
public:
System.String^ ToString(); override

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBinding Class
WebTreeViewNodeBinding Members


WebTreeViewNodeBinding Class Properties

[image]
Intersoft WebTreeView Documentation
WebTreeViewNodeBinding Class Properties
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace : WebTreeViewNodeBinding Class

Glossary Item Box

For a list of all members of this type, see WebTreeViewNodeBinding members.

Public Properties

 | Name | Description
Public Property | AllowEditing | Specifies whether to allow edit.Gets or sets a node edit ability.
Public Property | AllowEditingField | Specifies data field for AllowEditing.Gets or sets a node edit ability based on the XML value.
Public Property | Checked | Specifies whether the node is currently checked.Determines whether the node is checked or unchecked.
Public Property | CheckedField | Specifies data field for Checked.Determines whether the node is checked or unchecked based on XML value.
Public Property | CheckedState | Gets or sets the checked state of the node.Gets or sets the checked state of the node.
Public Property | CheckedStateField | Specifies data field for CheckedState.Gets or sets the checked state of the node based on the XML value.
Public Property | ChildNodeExpandable | Specifies whether the node is expandable when it has childnodes.Specifies whether the child nodes of the specified node is expandable or not.
Public Property | ChildNodeExpandableField | Specifies data field for ChildNodeExpandable.Specifies whether the child nodes of the specified node is expandable or not based on the XML value.
Public Property | Collection | (Inherited from ISNet.WebUI.NamedObjectBase)
Public Property | DataMember | Gets or sets the data member.Gets or sets the Data Member.
Public Property | Depth | Gets or sets the depth.Gets or sets the Depth of the databindings.
Public Property | Enabled | Indicates whether the node is enable or disable.Specifies whether the node is enabled or disabled.
Public Property | EnabledField | Specifies data field for Enabled.Specifies whether the node is enabled or disabled based on the XML value.
Public Property | Expanded | Specifies whether the node is currently expanded.Specifies whether the node is expanded or not.
Public Property | ExpandedField | Specifies data field for Expanded.Specifies whether the node is expanded or not based on the XML value.
Public Property | ExpandedImage | icon image to use if the node is expanded Gets or sets the expanded node image icon.
Public Property | ExpandedImageField | icon image to use if the node is expanded Gets or sets the expanded node image icon based on the XML value.
Public Property | Image | icon image to use if the node is collapsed Gets or sets the collapsed node image icon.
Public Property | ImageField | icon image to use if the node is collapsed Gets or sets the collapsed node image icon based on the XML value.
Public Property | ImageToolTip | Gets or sets the image tooltip text of the node.Gets or sets the tooltip image icon.
Public Property | ImageToolTipField | Specifies data field for ImageToolTip.Gets or sets the tooltip image icon based on XML value.
Public Property | MaxBindingDepth | Specifies relative max binding depth.Set the node level you want to bind.
Public Property | MaxBindingDepthField | Specifies data field for MaxBindingDepth.Set the node level you want to bind based on the XML value.
Public Property | Name | (Inherited from ISNet.WebUI.NamedObjectBase)
Public Property | NameField | Specifies name field for node name.Gets or sets the name of the node based on the XML value.
Public Property | NavigateURL | URL to load sub-tree contents from (XML).Gets or sets the URL when a node is selected.
Public Property | NavigateURLField | Specifies data field for NavigateURL.Gets or sets the URL when a node is selected based on XML value.
Public Property | Selectable | Indicates whether the node is selectable.Determines whether the node is selectable or not.
Public Property | SelectableField | Specifies data field for Selectable.Determines whether the node is selectable or not based on the XML value.
Public Property | Selected | Specifies whether the node is currently selected.Determines whether a node is selected or not.
Public Property | SelectedExpandedImage | icon image to use if the node is expanded Gets or sets the expanded image of the node.
Public Property | SelectedExpandedImageField | icon image to use if the node is expanded Gets or sets the expanded image of the node based on the XML value.
Public Property | SelectedField | Specifies data field for Selected.Determines whether a node is selected or not based on the XML value.
Public Property | SelectedImage | icon image to use if the node is collapsed Gets or sets the collapse icon image of the selected node.
Public Property | SelectedImageField | icon image to use if the node is collapsed Gets or sets the collapse icon image of the selected node based on the XML value.
Public Property | ShowCheckBox | Specifies whether to show checkbox next to the node.Determines whether to show checkbox next to a node or not.
Public Property | ShowCheckBoxField | Specifies data field for ShowCheckBox.Determines whether to show checkbox next to a node or not based on the XML value.
Public Property | Tag | Gets or sets tag data.Gets or sets a string which contains data about the WebTreeViewNode.
Public Property | TagField | Specifies data field for Tag.Gets or sets a string which contains data about the WebTreeViewNode based on the XML value.
Public Property | Target | The navigate target used when the node is selected.Specifies the target window when the node is clicked.
Public Property | TargetField | Specifies data field for Target.Specifies the target window when the node is clicked based on the XML value.
Public Property | Text | Gets or sets the display text of the node.Gets or sets the text of a node that you want to display.
Public Property | TextField | Specifies data field for Text.Gets or sets the text of a node that you want to display based on the XML value.
Public Property | TextImage | Gets or sets text image.Specifies the image of a node's text.
Public Property | TextImageField | Specifies name field for text image.Specifies the image of a node's text based on the XML value.
Public Property | TextImageToolTip | Gets or sets the tooltip text image of the node.Specifies the specified node's tooltip textimage.
Public Property | TextImageToolTipField | Specifies data field for Text Image ToolTip.Specifies the specified node's tooltip textimage based on the XML value.
Public Property | ToolTip | Gets or sets the tooltip text of the node.Gets or sets the tooltip of a node.
Public Property | ToolTipField | Specifies data field for ToolTip.Gets or sets the tooltip of a node based on the XML value.
Public Property | Value | Gets or sets the value of the value.Gets or sets the value of a node.
Public Property | ValueField | Specifies data field for Value.Gets or sets the value of a node based on the XML value.
Public Property | Visible | Indicates whether the node is visible.Determines whether a node is visible or invisible.
Public Property | VisibleField | Specifies data field for Visible.Determines whether a node is visible or invisible based on the XML value.
Top

See Also

Reference

WebTreeViewNodeBinding Class
ISNet.WebUI.WebTreeView Namespace


AllowEditing Property

[image]
Intersoft WebTreeView Documentation
AllowEditing Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBinding Class : AllowEditing Property

Glossary Item Box

Specifies whether to allow edit.Gets or sets a node edit ability.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Default Properties")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether to allow edit.")>
Public Property AllowEditing As AllowEditing
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBinding
Dim value As AllowEditing

instance.AllowEditing = value

value = instance.AllowEditing
C#
[System.ComponentModel.CategoryAttribute("Default Properties")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether to allow edit.")]
public AllowEditing AllowEditing {get; set;}
Delphi
public read-write property AllowEditing: AllowEditing;
JScript
System.ComponentModel.CategoryAttribute("Default Properties")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether to allow edit.")
public function get,set AllowEditing : AllowEditing
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Default Properties")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether to allow edit.")]
public: __property AllowEditing get_AllowEditing();
public: __property void set_AllowEditing(
   AllowEditing value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Default Properties")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether to allow edit.")]
public:
property AllowEditing AllowEditing {
   AllowEditing get();
   void set (    AllowEditing value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBinding Class
WebTreeViewNodeBinding Members


AllowEditingField Property

[image]
Intersoft WebTreeView Documentation
AllowEditingField Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBinding Class : AllowEditingField Property

Glossary Item Box

Specifies data field for AllowEditing.Gets or sets a node edit ability based on the XML value.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Databindings")>
<System.ComponentModel.DescriptionAttribute("Specifies data field for AllowEditing.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property AllowEditingField As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBinding
Dim value As System.String

instance.AllowEditingField = value

value = instance.AllowEditingField
C#
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Databindings")]
[System.ComponentModel.DescriptionAttribute("Specifies data field for AllowEditing.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string AllowEditingField {get; set;}
Delphi
public read-write property AllowEditingField: System.String;
JScript
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Databindings")
System.ComponentModel.DescriptionAttribute("Specifies data field for AllowEditing.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set AllowEditingField : System.String
Managed Extensions for C++
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Databindings")]
[System.ComponentModel.DescriptionAttribute("Specifies data field for AllowEditing.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_AllowEditingField();
public: __property void set_AllowEditingField(
   System.string* value
);
C++/CLI
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Databindings")]
[System.ComponentModel.DescriptionAttribute("Specifies data field for AllowEditing.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ AllowEditingField {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBinding Class
WebTreeViewNodeBinding Members


Checked Property

[image]
Intersoft WebTreeView Documentation
Checked Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBinding Class : Checked Property

Glossary Item Box

Specifies whether the node is currently checked.Determines whether the node is checked or unchecked.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether the node is currently checked.")>
<System.ComponentModel.CategoryAttribute("Default Properties")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property Checked As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBinding
Dim value As System.Boolean

instance.Checked = value

value = instance.Checked
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the node is currently checked.")]
[System.ComponentModel.CategoryAttribute("Default Properties")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.bool Checked {get; set;}
Delphi
public read-write property Checked: System.Boolean;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether the node is currently checked.")
System.ComponentModel.CategoryAttribute("Default Properties")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set Checked : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the node is currently checked.")]
[System.ComponentModel.CategoryAttribute("Default Properties")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.bool get_Checked();
public: __property void set_Checked(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the node is currently checked.")]
[System.ComponentModel.CategoryAttribute("Default Properties")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.bool Checked {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBinding Class
WebTreeViewNodeBinding Members


CheckedField Property

[image]
Intersoft WebTreeView Documentation
CheckedField Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBinding Class : CheckedField Property

Glossary Item Box

Specifies data field for Checked.Determines whether the node is checked or unchecked based on XML value.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Databindings")>
<System.ComponentModel.DescriptionAttribute("Specifies data field for Checked.")>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property CheckedField As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBinding
Dim value As System.String

instance.CheckedField = value

value = instance.CheckedField
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Databindings")]
[System.ComponentModel.DescriptionAttribute("Specifies data field for Checked.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string CheckedField {get; set;}
Delphi
public read-write property CheckedField: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Databindings")
System.ComponentModel.DescriptionAttribute("Specifies data field for Checked.")
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set CheckedField : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Databindings")]
[System.ComponentModel.DescriptionAttribute("Specifies data field for Checked.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_CheckedField();
public: __property void set_CheckedField(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Databindings")]
[System.ComponentModel.DescriptionAttribute("Specifies data field for Checked.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ CheckedField {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBinding Class
WebTreeViewNodeBinding Members


CheckedState Property

[image]
Intersoft WebTreeView Documentation
CheckedState Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBinding Class : CheckedState Property

Glossary Item Box

Gets or sets the checked state of the node.Gets or sets the checked state of the node.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Default Properties")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the checked state of the node.")>
Public Property CheckedState As CheckState
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBinding
Dim value As CheckState

instance.CheckedState = value

value = instance.CheckedState
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Default Properties")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the checked state of the node.")]
public CheckState CheckedState {get; set;}
Delphi
public read-write property CheckedState: CheckState;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Default Properties")
System.ComponentModel.DescriptionAttribute("Gets or sets the checked state of the node.")
public function get,set CheckedState : CheckState
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Default Properties")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the checked state of the node.")]
public: __property CheckState get_CheckedState();
public: __property void set_CheckedState(
   CheckState value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Default Properties")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the checked state of the node.")]
public:
property CheckState CheckedState {
   CheckState get();
   void set (    CheckState value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBinding Class
WebTreeViewNodeBinding Members


CheckedStateField Property

[image]
Intersoft WebTreeView Documentation
CheckedStateField Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBinding Class : CheckedStateField Property

Glossary Item Box

Specifies data field for CheckedState.Gets or sets the checked state of the node based on the XML value.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Databindings")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies data field for CheckedState.")>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")>
Public Property CheckedStateField As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBinding
Dim value As System.String

instance.CheckedStateField = value

value = instance.CheckedStateField
C#
[System.ComponentModel.CategoryAttribute("Databindings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies data field for CheckedState.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
public System.string CheckedStateField {get; set;}
Delphi
public read-write property CheckedStateField: System.String;
JScript
System.ComponentModel.CategoryAttribute("Databindings")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies data field for CheckedState.")
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")
public function get,set CheckedStateField : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Databindings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies data field for CheckedState.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
public: __property System.string* get_CheckedStateField();
public: __property void set_CheckedStateField(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Databindings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies data field for CheckedState.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
public:
property System.String^ CheckedStateField {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBinding Class
WebTreeViewNodeBinding Members


ChildNodeExpandable Property

[image]
Intersoft WebTreeView Documentation
ChildNodeExpandable Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBinding Class : ChildNodeExpandable Property

Glossary Item Box

Specifies whether the node is expandable when it has childnodes.Specifies whether the child nodes of the specified node is expandable or not.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies whether the node is expandable when it has childnodes.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Property ChildNodeExpandable As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBinding
Dim value As System.Boolean

instance.ChildNodeExpandable = value

value = instance.ChildNodeExpandable
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies whether the node is expandable when it has childnodes.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public System.bool ChildNodeExpandable {get; set;}
Delphi
public read-write property ChildNodeExpandable: System.Boolean;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether the node is expandable when it has childnodes.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set ChildNodeExpandable : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies whether the node is expandable when it has childnodes.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property System.bool get_ChildNodeExpandable();
public: __property void set_ChildNodeExpandable(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies whether the node is expandable when it has childnodes.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
property System.bool ChildNodeExpandable {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBinding Class
WebTreeViewNodeBinding Members


ChildNodeExpandableField Property

[image]
Intersoft WebTreeView Documentation
ChildNodeExpandableField Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBinding Class : ChildNodeExpandableField Property

Glossary Item Box

Specifies data field for ChildNodeExpandable.Specifies whether the child nodes of the specified node is expandable or not based on the XML value.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies data field for ChildNodeExpandable.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Databindings")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")>
Public Property ChildNodeExpandableField As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBinding
Dim value As System.String

instance.ChildNodeExpandableField = value

value = instance.ChildNodeExpandableField
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies data field for ChildNodeExpandable.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Databindings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
public System.string ChildNodeExpandableField {get; set;}
Delphi
public read-write property ChildNodeExpandableField: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies data field for ChildNodeExpandable.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Databindings")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")
public function get,set ChildNodeExpandableField : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies data field for ChildNodeExpandable.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Databindings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
public: __property System.string* get_ChildNodeExpandableField();
public: __property void set_ChildNodeExpandableField(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies data field for ChildNodeExpandable.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Databindings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
public:
property System.String^ ChildNodeExpandableField {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBinding Class
WebTreeViewNodeBinding Members


DataMember Property

[image]
Intersoft WebTreeView Documentation
DataMember Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBinding Class : DataMember Property

Glossary Item Box

Gets or sets the data member.Gets or sets the Data Member.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Data")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the data member.")>
Public Property DataMember As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBinding
Dim value As System.String

instance.DataMember = value

value = instance.DataMember
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the data member.")]
public System.string DataMember {get; set;}
Delphi
public read-write property DataMember: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Data")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the data member.")
public function get,set DataMember : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the data member.")]
public: __property System.string* get_DataMember();
public: __property void set_DataMember(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the data member.")]
public:
property System.String^ DataMember {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBinding Class
WebTreeViewNodeBinding Members


Depth Property

[image]
Intersoft WebTreeView Documentation
Depth Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBinding Class : Depth Property

Glossary Item Box

Gets or sets the depth.Gets or sets the Depth of the databindings.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the depth.")>
<System.ComponentModel.CategoryAttribute("Data")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property Depth As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBinding
Dim value As System.Integer

instance.Depth = value

value = instance.Depth
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the depth.")]
[System.ComponentModel.CategoryAttribute("Data")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.int Depth {get; set;}
Delphi
public read-write property Depth: System.Integer;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the depth.")
System.ComponentModel.CategoryAttribute("Data")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set Depth : System.int
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the depth.")]
[System.ComponentModel.CategoryAttribute("Data")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.int get_Depth();
public: __property void set_Depth(
   System.int value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the depth.")]
[System.ComponentModel.CategoryAttribute("Data")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.int Depth {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBinding Class
WebTreeViewNodeBinding Members


Enabled Property

[image]
Intersoft WebTreeView Documentation
Enabled Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBinding Class : Enabled Property

Glossary Item Box

Indicates whether the node is enable or disable.Specifies whether the node is enabled or disabled.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Default Properties")>
<System.ComponentModel.DescriptionAttribute("Indicates whether the node is enable or disable.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property Enabled As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBinding
Dim value As System.Boolean

instance.Enabled = value

value = instance.Enabled
C#
[System.ComponentModel.CategoryAttribute("Default Properties")]
[System.ComponentModel.DescriptionAttribute("Indicates whether the node is enable or disable.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.bool Enabled {get; set;}
Delphi
public read-write property Enabled: System.Boolean;
JScript
System.ComponentModel.CategoryAttribute("Default Properties")
System.ComponentModel.DescriptionAttribute("Indicates whether the node is enable or disable.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set Enabled : System.boolean
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Default Properties")]
[System.ComponentModel.DescriptionAttribute("Indicates whether the node is enable or disable.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.bool get_Enabled();
public: __property void set_Enabled(
   System.bool value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Default Properties")]
[System.ComponentModel.DescriptionAttribute("Indicates whether the node is enable or disable.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.bool Enabled {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBinding Class
WebTreeViewNodeBinding Members


EnabledField Property

[image]
Intersoft WebTreeView Documentation
EnabledField Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBinding Class : EnabledField Property

Glossary Item Box

Specifies data field for Enabled.Specifies whether the node is enabled or disabled based on the XML value.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Databindings")>
<System.ComponentModel.DescriptionAttribute("Specifies data field for Enabled.")>
Public Property EnabledField As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBinding
Dim value As System.String

instance.EnabledField = value

value = instance.EnabledField
C#
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Databindings")]
[System.ComponentModel.DescriptionAttribute("Specifies data field for Enabled.")]
public System.string EnabledField {get; set;}
Delphi
public read-write property EnabledField: System.String;
JScript
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Databindings")
System.ComponentModel.DescriptionAttribute("Specifies data field for Enabled.")
public function get,set EnabledField : System.String
Managed Extensions for C++
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Databindings")]
[System.ComponentModel.DescriptionAttribute("Specifies data field for Enabled.")]
public: __property System.string* get_EnabledField();
public: __property void set_EnabledField(
   System.string* value
);
C++/CLI
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Databindings")]
[System.ComponentModel.DescriptionAttribute("Specifies data field for Enabled.")]
public:
property System.String^ EnabledField {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBinding Class
WebTreeViewNodeBinding Members


Expanded Property

[image]
Intersoft WebTreeView Documentation
Expanded Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBinding Class : Expanded Property

Glossary Item Box

Specifies whether the node is currently expanded.Specifies whether the node is expanded or not.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Default Properties")>
<System.ComponentModel.DescriptionAttribute("Specifies whether the node is currently expanded.")>
Public Property Expanded As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBinding
Dim value As System.Boolean

instance.Expanded = value

value = instance.Expanded
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Default Properties")]
[System.ComponentModel.DescriptionAttribute("Specifies whether the node is currently expanded.")]
public System.bool Expanded {get; set;}
Delphi
public read-write property Expanded: System.Boolean;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Default Properties")
System.ComponentModel.DescriptionAttribute("Specifies whether the node is currently expanded.")
public function get,set Expanded : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Default Properties")]
[System.ComponentModel.DescriptionAttribute("Specifies whether the node is currently expanded.")]
public: __property System.bool get_Expanded();
public: __property void set_Expanded(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Default Properties")]
[System.ComponentModel.DescriptionAttribute("Specifies whether the node is currently expanded.")]
public:
property System.bool Expanded {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBinding Class
WebTreeViewNodeBinding Members


ExpandedField Property

[image]
Intersoft WebTreeView Documentation
ExpandedField Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBinding Class : ExpandedField Property

Glossary Item Box

Specifies data field for Expanded.Specifies whether the node is expanded or not based on the XML value.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Databindings")>
<System.ComponentModel.DescriptionAttribute("Specifies data field for Expanded.")>
Public Property ExpandedField As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBinding
Dim value As System.String

instance.ExpandedField = value

value = instance.ExpandedField
C#
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Databindings")]
[System.ComponentModel.DescriptionAttribute("Specifies data field for Expanded.")]
public System.string ExpandedField {get; set;}
Delphi
public read-write property ExpandedField: System.String;
JScript
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Databindings")
System.ComponentModel.DescriptionAttribute("Specifies data field for Expanded.")
public function get,set ExpandedField : System.String
Managed Extensions for C++
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Databindings")]
[System.ComponentModel.DescriptionAttribute("Specifies data field for Expanded.")]
public: __property System.string* get_ExpandedField();
public: __property void set_ExpandedField(
   System.string* value
);
C++/CLI
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Databindings")]
[System.ComponentModel.DescriptionAttribute("Specifies data field for Expanded.")]
public:
property System.String^ ExpandedField {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBinding Class
WebTreeViewNodeBinding Members


ExpandedImage Property

[image]
Intersoft WebTreeView Documentation
ExpandedImage Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBinding Class : ExpandedImage Property

Glossary Item Box

icon image to use if the node is expanded Gets or sets the expanded node image icon.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Default Properties")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the icon image of the node. (apply to expanded node)")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property ExpandedImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBinding
Dim value As System.String

instance.ExpandedImage = value

value = instance.ExpandedImage
C#
[System.ComponentModel.CategoryAttribute("Default Properties")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the icon image of the node. (apply to expanded node)")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string ExpandedImage {get; set;}
Delphi
public read-write property ExpandedImage: System.String;
JScript
System.ComponentModel.CategoryAttribute("Default Properties")
System.ComponentModel.DescriptionAttribute("Gets or sets the icon image of the node. (apply to expanded node)")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set ExpandedImage : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Default Properties")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the icon image of the node. (apply to expanded node)")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_ExpandedImage();
public: __property void set_ExpandedImage(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Default Properties")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the icon image of the node. (apply to expanded node)")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ ExpandedImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBinding Class
WebTreeViewNodeBinding Members


ExpandedImageField Property

[image]
Intersoft WebTreeView Documentation
ExpandedImageField Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBinding Class : ExpandedImageField Property

Glossary Item Box

icon image to use if the node is expanded Gets or sets the expanded node image icon based on the XML value.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")>
<System.ComponentModel.DescriptionAttribute("Specifies data field for ExpandedImage.")>
<System.ComponentModel.CategoryAttribute("Databindings")>
Public Property ExpandedImageField As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBinding
Dim value As System.String

instance.ExpandedImageField = value

value = instance.ExpandedImageField
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
[System.ComponentModel.DescriptionAttribute("Specifies data field for ExpandedImage.")]
[System.ComponentModel.CategoryAttribute("Databindings")]
public System.string ExpandedImageField {get; set;}
Delphi
public read-write property ExpandedImageField: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")
System.ComponentModel.DescriptionAttribute("Specifies data field for ExpandedImage.")
System.ComponentModel.CategoryAttribute("Databindings")
public function get,set ExpandedImageField : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
[System.ComponentModel.DescriptionAttribute("Specifies data field for ExpandedImage.")]
[System.ComponentModel.CategoryAttribute("Databindings")]
public: __property System.string* get_ExpandedImageField();
public: __property void set_ExpandedImageField(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
[System.ComponentModel.DescriptionAttribute("Specifies data field for ExpandedImage.")]
[System.ComponentModel.CategoryAttribute("Databindings")]
public:
property System.String^ ExpandedImageField {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBinding Class
WebTreeViewNodeBinding Members


Image Property

[image]
Intersoft WebTreeView Documentation
Image Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBinding Class : Image Property

Glossary Item Box

icon image to use if the node is collapsed Gets or sets the collapsed node image icon.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Default Properties")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the icon image of the node. (apply to collapsed node)")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property Image As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBinding
Dim value As System.String

instance.Image = value

value = instance.Image
C#
[System.ComponentModel.CategoryAttribute("Default Properties")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the icon image of the node. (apply to collapsed node)")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string Image {get; set;}
Delphi
public read-write property Image: System.String;
JScript
System.ComponentModel.CategoryAttribute("Default Properties")
System.ComponentModel.DescriptionAttribute("Gets or sets the icon image of the node. (apply to collapsed node)")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set Image : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Default Properties")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the icon image of the node. (apply to collapsed node)")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_Image();
public: __property void set_Image(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Default Properties")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the icon image of the node. (apply to collapsed node)")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ Image {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBinding Class
WebTreeViewNodeBinding Members


ImageField Property

[image]
Intersoft WebTreeView Documentation
ImageField Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBinding Class : ImageField Property

Glossary Item Box

icon image to use if the node is collapsed Gets or sets the collapsed node image icon based on the XML value.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")>
<System.ComponentModel.DescriptionAttribute("Specifies data field for Image.")>
<System.ComponentModel.CategoryAttribute("Databindings")>
Public Property ImageField As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBinding
Dim value As System.String

instance.ImageField = value

value = instance.ImageField
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
[System.ComponentModel.DescriptionAttribute("Specifies data field for Image.")]
[System.ComponentModel.CategoryAttribute("Databindings")]
public System.string ImageField {get; set;}
Delphi
public read-write property ImageField: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")
System.ComponentModel.DescriptionAttribute("Specifies data field for Image.")
System.ComponentModel.CategoryAttribute("Databindings")
public function get,set ImageField : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
[System.ComponentModel.DescriptionAttribute("Specifies data field for Image.")]
[System.ComponentModel.CategoryAttribute("Databindings")]
public: __property System.string* get_ImageField();
public: __property void set_ImageField(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
[System.ComponentModel.DescriptionAttribute("Specifies data field for Image.")]
[System.ComponentModel.CategoryAttribute("Databindings")]
public:
property System.String^ ImageField {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBinding Class
WebTreeViewNodeBinding Members


ImageToolTip Property

[image]
Intersoft WebTreeView Documentation
ImageToolTip Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBinding Class : ImageToolTip Property

Glossary Item Box

Gets or sets the image tooltip text of the node.Gets or sets the tooltip image icon.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Default Properties")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the image tooltip text of the node.")>
Public Property ImageToolTip As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBinding
Dim value As System.String

instance.ImageToolTip = value

value = instance.ImageToolTip
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Default Properties")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image tooltip text of the node.")]
public System.string ImageToolTip {get; set;}
Delphi
public read-write property ImageToolTip: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Default Properties")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the image tooltip text of the node.")
public function get,set ImageToolTip : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Default Properties")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image tooltip text of the node.")]
public: __property System.string* get_ImageToolTip();
public: __property void set_ImageToolTip(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Default Properties")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the image tooltip text of the node.")]
public:
property System.String^ ImageToolTip {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBinding Class
WebTreeViewNodeBinding Members


ImageToolTipField Property

[image]
Intersoft WebTreeView Documentation
ImageToolTipField Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBinding Class : ImageToolTipField Property

Glossary Item Box

Specifies data field for ImageToolTip.Gets or sets the tooltip image icon based on XML value.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies data field for ImageToolTip.")>
<System.ComponentModel.CategoryAttribute("Databindings")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property ImageToolTipField As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBinding
Dim value As System.String

instance.ImageToolTipField = value

value = instance.ImageToolTipField
C#
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies data field for ImageToolTip.")]
[System.ComponentModel.CategoryAttribute("Databindings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string ImageToolTipField {get; set;}
Delphi
public read-write property ImageToolTipField: System.String;
JScript
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies data field for ImageToolTip.")
System.ComponentModel.CategoryAttribute("Databindings")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set ImageToolTipField : System.String
Managed Extensions for C++
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies data field for ImageToolTip.")]
[System.ComponentModel.CategoryAttribute("Databindings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_ImageToolTipField();
public: __property void set_ImageToolTipField(
   System.string* value
);
C++/CLI
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies data field for ImageToolTip.")]
[System.ComponentModel.CategoryAttribute("Databindings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ ImageToolTipField {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBinding Class
WebTreeViewNodeBinding Members


MaxBindingDepth Property

[image]
Intersoft WebTreeView Documentation
MaxBindingDepth Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBinding Class : MaxBindingDepth Property

Glossary Item Box

Specifies relative max binding depth.Set the node level you want to bind.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Default Properties")>
<System.ComponentModel.DescriptionAttribute("Specifies relative max binding depth.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property MaxBindingDepth As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBinding
Dim value As System.Integer

instance.MaxBindingDepth = value

value = instance.MaxBindingDepth
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Default Properties")]
[System.ComponentModel.DescriptionAttribute("Specifies relative max binding depth.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.int MaxBindingDepth {get; set;}
Delphi
public read-write property MaxBindingDepth: System.Integer;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Default Properties")
System.ComponentModel.DescriptionAttribute("Specifies relative max binding depth.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set MaxBindingDepth : System.int
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Default Properties")]
[System.ComponentModel.DescriptionAttribute("Specifies relative max binding depth.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.int get_MaxBindingDepth();
public: __property void set_MaxBindingDepth(
   System.int value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Default Properties")]
[System.ComponentModel.DescriptionAttribute("Specifies relative max binding depth.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.int MaxBindingDepth {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBinding Class
WebTreeViewNodeBinding Members


MaxBindingDepthField Property

[image]
Intersoft WebTreeView Documentation
MaxBindingDepthField Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBinding Class : MaxBindingDepthField Property

Glossary Item Box

Specifies data field for MaxBindingDepth.Set the node level you want to bind based on the XML value.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Databindings")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")>
<System.ComponentModel.DescriptionAttribute("Specifies data field for MaxBindingDepth.")>
Public Property MaxBindingDepthField As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBinding
Dim value As System.String

instance.MaxBindingDepthField = value

value = instance.MaxBindingDepthField
C#
[System.ComponentModel.CategoryAttribute("Databindings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
[System.ComponentModel.DescriptionAttribute("Specifies data field for MaxBindingDepth.")]
public System.string MaxBindingDepthField {get; set;}
Delphi
public read-write property MaxBindingDepthField: System.String;
JScript
System.ComponentModel.CategoryAttribute("Databindings")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")
System.ComponentModel.DescriptionAttribute("Specifies data field for MaxBindingDepth.")
public function get,set MaxBindingDepthField : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Databindings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
[System.ComponentModel.DescriptionAttribute("Specifies data field for MaxBindingDepth.")]
public: __property System.string* get_MaxBindingDepthField();
public: __property void set_MaxBindingDepthField(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Databindings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
[System.ComponentModel.DescriptionAttribute("Specifies data field for MaxBindingDepth.")]
public:
property System.String^ MaxBindingDepthField {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBinding Class
WebTreeViewNodeBinding Members


NameField Property

[image]
Intersoft WebTreeView Documentation
NameField Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBinding Class : NameField Property

Glossary Item Box

Specifies name field for node name.Gets or sets the name of the node based on the XML value.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies name field for node name.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")>
<System.ComponentModel.CategoryAttribute("Databindings")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property NameField As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBinding
Dim value As System.String

instance.NameField = value

value = instance.NameField
C#
[System.ComponentModel.DescriptionAttribute("Specifies name field for node name.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
[System.ComponentModel.CategoryAttribute("Databindings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string NameField {get; set;}
Delphi
public read-write property NameField: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies name field for node name.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")
System.ComponentModel.CategoryAttribute("Databindings")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set NameField : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies name field for node name.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
[System.ComponentModel.CategoryAttribute("Databindings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_NameField();
public: __property void set_NameField(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies name field for node name.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
[System.ComponentModel.CategoryAttribute("Databindings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ NameField {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBinding Class
WebTreeViewNodeBinding Members


NavigateURL Property

[image]
Intersoft WebTreeView Documentation
NavigateURL Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBinding Class : NavigateURL Property

Glossary Item Box

URL to load sub-tree contents from (XML).Gets or sets the URL when a node is selected.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("URL to load sub-tree contents from (XML).")>
<System.ComponentModel.CategoryAttribute("Default Properties")>
Public Property NavigateURL As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBinding
Dim value As System.String

instance.NavigateURL = value

value = instance.NavigateURL
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("URL to load sub-tree contents from (XML).")]
[System.ComponentModel.CategoryAttribute("Default Properties")]
public System.string NavigateURL {get; set;}
Delphi
public read-write property NavigateURL: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("URL to load sub-tree contents from (XML).")
System.ComponentModel.CategoryAttribute("Default Properties")
public function get,set NavigateURL : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("URL to load sub-tree contents from (XML).")]
[System.ComponentModel.CategoryAttribute("Default Properties")]
public: __property System.string* get_NavigateURL();
public: __property void set_NavigateURL(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("URL to load sub-tree contents from (XML).")]
[System.ComponentModel.CategoryAttribute("Default Properties")]
public:
property System.String^ NavigateURL {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBinding Class
WebTreeViewNodeBinding Members


NavigateURLField Property

[image]
Intersoft WebTreeView Documentation
NavigateURLField Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBinding Class : NavigateURLField Property

Glossary Item Box

Specifies data field for NavigateURL.Gets or sets the URL when a node is selected based on XML value.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies data field for NavigateURL.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Databindings")>
Public Property NavigateURLField As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBinding
Dim value As System.String

instance.NavigateURLField = value

value = instance.NavigateURLField
C#
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies data field for NavigateURL.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Databindings")]
public System.string NavigateURLField {get; set;}
Delphi
public read-write property NavigateURLField: System.String;
JScript
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies data field for NavigateURL.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Databindings")
public function get,set NavigateURLField : System.String
Managed Extensions for C++
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies data field for NavigateURL.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Databindings")]
public: __property System.string* get_NavigateURLField();
public: __property void set_NavigateURLField(
   System.string* value
);
C++/CLI
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies data field for NavigateURL.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Databindings")]
public:
property System.String^ NavigateURLField {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBinding Class
WebTreeViewNodeBinding Members


Selectable Property

[image]
Intersoft WebTreeView Documentation
Selectable Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBinding Class : Selectable Property

Glossary Item Box

Indicates whether the node is selectable.Determines whether the node is selectable or not.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Indicates whether the node is selectable.")>
<System.ComponentModel.CategoryAttribute("Default Properties")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property Selectable As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBinding
Dim value As System.Boolean

instance.Selectable = value

value = instance.Selectable
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Indicates whether the node is selectable.")]
[System.ComponentModel.CategoryAttribute("Default Properties")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.bool Selectable {get; set;}
Delphi
public read-write property Selectable: System.Boolean;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Indicates whether the node is selectable.")
System.ComponentModel.CategoryAttribute("Default Properties")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set Selectable : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Indicates whether the node is selectable.")]
[System.ComponentModel.CategoryAttribute("Default Properties")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.bool get_Selectable();
public: __property void set_Selectable(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Indicates whether the node is selectable.")]
[System.ComponentModel.CategoryAttribute("Default Properties")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.bool Selectable {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBinding Class
WebTreeViewNodeBinding Members


SelectableField Property

[image]
Intersoft WebTreeView Documentation
SelectableField Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBinding Class : SelectableField Property

Glossary Item Box

Specifies data field for Selectable.Determines whether the node is selectable or not based on the XML value.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies data field for Selectable.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Databindings")>
Public Property SelectableField As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBinding
Dim value As System.String

instance.SelectableField = value

value = instance.SelectableField
C#
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies data field for Selectable.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Databindings")]
public System.string SelectableField {get; set;}
Delphi
public read-write property SelectableField: System.String;
JScript
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies data field for Selectable.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Databindings")
public function get,set SelectableField : System.String
Managed Extensions for C++
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies data field for Selectable.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Databindings")]
public: __property System.string* get_SelectableField();
public: __property void set_SelectableField(
   System.string* value
);
C++/CLI
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies data field for Selectable.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Databindings")]
public:
property System.String^ SelectableField {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBinding Class
WebTreeViewNodeBinding Members


Selected Property

[image]
Intersoft WebTreeView Documentation
Selected Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBinding Class : Selected Property

Glossary Item Box

Specifies whether the node is currently selected.Determines whether a node is selected or not.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Default Properties")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether the node is currently selected.")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property Selected As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBinding
Dim value As System.Boolean

instance.Selected = value

value = instance.Selected
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Default Properties")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the node is currently selected.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.bool Selected {get; set;}
Delphi
public read-write property Selected: System.Boolean;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Default Properties")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether the node is currently selected.")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set Selected : System.boolean
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Default Properties")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the node is currently selected.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.bool get_Selected();
public: __property void set_Selected(
   System.bool value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Default Properties")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the node is currently selected.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.bool Selected {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBinding Class
WebTreeViewNodeBinding Members


SelectedExpandedImage Property

[image]
Intersoft WebTreeView Documentation
SelectedExpandedImage Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBinding Class : SelectedExpandedImage Property

Glossary Item Box

icon image to use if the node is expanded Gets or sets the expanded image of the node.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the icon image of the selected node. (apply to expanded node)")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Default Properties")>
Public Property SelectedExpandedImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBinding
Dim value As System.String

instance.SelectedExpandedImage = value

value = instance.SelectedExpandedImage
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the icon image of the selected node. (apply to expanded node)")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Default Properties")]
public System.string SelectedExpandedImage {get; set;}
Delphi
public read-write property SelectedExpandedImage: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the icon image of the selected node. (apply to expanded node)")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Default Properties")
public function get,set SelectedExpandedImage : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the icon image of the selected node. (apply to expanded node)")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Default Properties")]
public: __property System.string* get_SelectedExpandedImage();
public: __property void set_SelectedExpandedImage(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the icon image of the selected node. (apply to expanded node)")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Default Properties")]
public:
property System.String^ SelectedExpandedImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBinding Class
WebTreeViewNodeBinding Members


SelectedExpandedImageField Property

[image]
Intersoft WebTreeView Documentation
SelectedExpandedImageField Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBinding Class : SelectedExpandedImageField Property

Glossary Item Box

icon image to use if the node is expanded Gets or sets the expanded image of the node based on the XML value.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies data field for SelectedExpandedImage.")>
<System.ComponentModel.CategoryAttribute("Databindings")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")>
Public Property SelectedExpandedImageField As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBinding
Dim value As System.String

instance.SelectedExpandedImageField = value

value = instance.SelectedExpandedImageField
C#
[System.ComponentModel.DescriptionAttribute("Specifies data field for SelectedExpandedImage.")]
[System.ComponentModel.CategoryAttribute("Databindings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
public System.string SelectedExpandedImageField {get; set;}
Delphi
public read-write property SelectedExpandedImageField: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies data field for SelectedExpandedImage.")
System.ComponentModel.CategoryAttribute("Databindings")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")
public function get,set SelectedExpandedImageField : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies data field for SelectedExpandedImage.")]
[System.ComponentModel.CategoryAttribute("Databindings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
public: __property System.string* get_SelectedExpandedImageField();
public: __property void set_SelectedExpandedImageField(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies data field for SelectedExpandedImage.")]
[System.ComponentModel.CategoryAttribute("Databindings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
public:
property System.String^ SelectedExpandedImageField {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBinding Class
WebTreeViewNodeBinding Members


SelectedField Property

[image]
Intersoft WebTreeView Documentation
SelectedField Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBinding Class : SelectedField Property

Glossary Item Box

Specifies data field for Selected.Determines whether a node is selected or not based on the XML value.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")>
<System.ComponentModel.CategoryAttribute("Databindings")>
<System.ComponentModel.DescriptionAttribute("Specifies data field for Selected.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property SelectedField As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBinding
Dim value As System.String

instance.SelectedField = value

value = instance.SelectedField
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
[System.ComponentModel.CategoryAttribute("Databindings")]
[System.ComponentModel.DescriptionAttribute("Specifies data field for Selected.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string SelectedField {get; set;}
Delphi
public read-write property SelectedField: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")
System.ComponentModel.CategoryAttribute("Databindings")
System.ComponentModel.DescriptionAttribute("Specifies data field for Selected.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set SelectedField : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
[System.ComponentModel.CategoryAttribute("Databindings")]
[System.ComponentModel.DescriptionAttribute("Specifies data field for Selected.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_SelectedField();
public: __property void set_SelectedField(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
[System.ComponentModel.CategoryAttribute("Databindings")]
[System.ComponentModel.DescriptionAttribute("Specifies data field for Selected.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ SelectedField {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBinding Class
WebTreeViewNodeBinding Members


SelectedImage Property

[image]
Intersoft WebTreeView Documentation
SelectedImage Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBinding Class : SelectedImage Property

Glossary Item Box

icon image to use if the node is collapsed Gets or sets the collapse icon image of the selected node.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Default Properties")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the icon image of the selected node. (apply to collapsed node)")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property SelectedImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBinding
Dim value As System.String

instance.SelectedImage = value

value = instance.SelectedImage
C#
[System.ComponentModel.CategoryAttribute("Default Properties")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the icon image of the selected node. (apply to collapsed node)")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string SelectedImage {get; set;}
Delphi
public read-write property SelectedImage: System.String;
JScript
System.ComponentModel.CategoryAttribute("Default Properties")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the icon image of the selected node. (apply to collapsed node)")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set SelectedImage : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Default Properties")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the icon image of the selected node. (apply to collapsed node)")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_SelectedImage();
public: __property void set_SelectedImage(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Default Properties")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the icon image of the selected node. (apply to collapsed node)")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ SelectedImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBinding Class
WebTreeViewNodeBinding Members


SelectedImageField Property

[image]
Intersoft WebTreeView Documentation
SelectedImageField Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBinding Class : SelectedImageField Property

Glossary Item Box

icon image to use if the node is collapsed Gets or sets the collapse icon image of the selected node based on the XML value.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies data field for SelectedImage.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")>
<System.ComponentModel.CategoryAttribute("Databindings")>
Public Property SelectedImageField As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBinding
Dim value As System.String

instance.SelectedImageField = value

value = instance.SelectedImageField
C#
[System.ComponentModel.DescriptionAttribute("Specifies data field for SelectedImage.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
[System.ComponentModel.CategoryAttribute("Databindings")]
public System.string SelectedImageField {get; set;}
Delphi
public read-write property SelectedImageField: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies data field for SelectedImage.")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")
System.ComponentModel.CategoryAttribute("Databindings")
public function get,set SelectedImageField : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies data field for SelectedImage.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
[System.ComponentModel.CategoryAttribute("Databindings")]
public: __property System.string* get_SelectedImageField();
public: __property void set_SelectedImageField(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies data field for SelectedImage.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
[System.ComponentModel.CategoryAttribute("Databindings")]
public:
property System.String^ SelectedImageField {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBinding Class
WebTreeViewNodeBinding Members


ShowCheckBox Property

[image]
Intersoft WebTreeView Documentation
ShowCheckBox Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBinding Class : ShowCheckBox Property

Glossary Item Box

Specifies whether to show checkbox next to the node.Determines whether to show checkbox next to a node or not.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Default Properties")>
<System.ComponentModel.DescriptionAttribute("Specifies whether to show checkbox next to the node.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property ShowCheckBox As ShowCheckBox
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBinding
Dim value As ShowCheckBox

instance.ShowCheckBox = value

value = instance.ShowCheckBox
C#
[System.ComponentModel.CategoryAttribute("Default Properties")]
[System.ComponentModel.DescriptionAttribute("Specifies whether to show checkbox next to the node.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public ShowCheckBox ShowCheckBox {get; set;}
Delphi
public read-write property ShowCheckBox: ShowCheckBox;
JScript
System.ComponentModel.CategoryAttribute("Default Properties")
System.ComponentModel.DescriptionAttribute("Specifies whether to show checkbox next to the node.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set ShowCheckBox : ShowCheckBox
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Default Properties")]
[System.ComponentModel.DescriptionAttribute("Specifies whether to show checkbox next to the node.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property ShowCheckBox get_ShowCheckBox();
public: __property void set_ShowCheckBox(
   ShowCheckBox value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Default Properties")]
[System.ComponentModel.DescriptionAttribute("Specifies whether to show checkbox next to the node.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property ShowCheckBox ShowCheckBox {
   ShowCheckBox get();
   void set (    ShowCheckBox value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBinding Class
WebTreeViewNodeBinding Members


ShowCheckBoxField Property

[image]
Intersoft WebTreeView Documentation
ShowCheckBoxField Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBinding Class : ShowCheckBoxField Property

Glossary Item Box

Specifies data field for ShowCheckBox.Determines whether to show checkbox next to a node or not based on the XML value.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")>
<System.ComponentModel.CategoryAttribute("Databindings")>
<System.ComponentModel.DescriptionAttribute("Specifies data field for ShowCheckBox.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property ShowCheckBoxField As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBinding
Dim value As System.String

instance.ShowCheckBoxField = value

value = instance.ShowCheckBoxField
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
[System.ComponentModel.CategoryAttribute("Databindings")]
[System.ComponentModel.DescriptionAttribute("Specifies data field for ShowCheckBox.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string ShowCheckBoxField {get; set;}
Delphi
public read-write property ShowCheckBoxField: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")
System.ComponentModel.CategoryAttribute("Databindings")
System.ComponentModel.DescriptionAttribute("Specifies data field for ShowCheckBox.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set ShowCheckBoxField : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
[System.ComponentModel.CategoryAttribute("Databindings")]
[System.ComponentModel.DescriptionAttribute("Specifies data field for ShowCheckBox.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_ShowCheckBoxField();
public: __property void set_ShowCheckBoxField(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
[System.ComponentModel.CategoryAttribute("Databindings")]
[System.ComponentModel.DescriptionAttribute("Specifies data field for ShowCheckBox.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ ShowCheckBoxField {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBinding Class
WebTreeViewNodeBinding Members


Tag Property

[image]
Intersoft WebTreeView Documentation
Tag Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBinding Class : Tag Property

Glossary Item Box

Gets or sets tag data.Gets or sets a string which contains data about the WebTreeViewNode.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Default Properties")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets tag data.")>
Public Property Tag As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBinding
Dim value As System.String

instance.Tag = value

value = instance.Tag
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Default Properties")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets tag data.")]
public System.string Tag {get; set;}
Delphi
public read-write property Tag: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Default Properties")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets tag data.")
public function get,set Tag : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Default Properties")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets tag data.")]
public: __property System.string* get_Tag();
public: __property void set_Tag(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Default Properties")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets tag data.")]
public:
property System.String^ Tag {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBinding Class
WebTreeViewNodeBinding Members


TagField Property

[image]
Intersoft WebTreeView Documentation
TagField Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBinding Class : TagField Property

Glossary Item Box

Specifies data field for Tag.Gets or sets a string which contains data about the WebTreeViewNode based on the XML value.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies data field for Tag.")>
<System.ComponentModel.CategoryAttribute("Databindings")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property TagField As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBinding
Dim value As System.String

instance.TagField = value

value = instance.TagField
C#
[System.ComponentModel.DescriptionAttribute("Specifies data field for Tag.")]
[System.ComponentModel.CategoryAttribute("Databindings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string TagField {get; set;}
Delphi
public read-write property TagField: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies data field for Tag.")
System.ComponentModel.CategoryAttribute("Databindings")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set TagField : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies data field for Tag.")]
[System.ComponentModel.CategoryAttribute("Databindings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_TagField();
public: __property void set_TagField(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies data field for Tag.")]
[System.ComponentModel.CategoryAttribute("Databindings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ TagField {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBinding Class
WebTreeViewNodeBinding Members


Target Property

[image]
Intersoft WebTreeView Documentation
Target Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBinding Class : Target Property

Glossary Item Box

The navigate target used when the node is selected.Specifies the target window when the node is clicked.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Default Properties")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("The navigate target used when the node is selected.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property Target As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBinding
Dim value As System.String

instance.Target = value

value = instance.Target
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Default Properties")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The navigate target used when the node is selected.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string Target {get; set;}
Delphi
public read-write property Target: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Default Properties")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("The navigate target used when the node is selected.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set Target : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Default Properties")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The navigate target used when the node is selected.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_Target();
public: __property void set_Target(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Default Properties")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The navigate target used when the node is selected.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ Target {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBinding Class
WebTreeViewNodeBinding Members


TargetField Property

[image]
Intersoft WebTreeView Documentation
TargetField Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBinding Class : TargetField Property

Glossary Item Box

Specifies data field for Target.Specifies the target window when the node is clicked based on the XML value.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Databindings")>
<System.ComponentModel.DescriptionAttribute("Specifies data field for Target.")>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")>
Public Property TargetField As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBinding
Dim value As System.String

instance.TargetField = value

value = instance.TargetField
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Databindings")]
[System.ComponentModel.DescriptionAttribute("Specifies data field for Target.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
public System.string TargetField {get; set;}
Delphi
public read-write property TargetField: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Databindings")
System.ComponentModel.DescriptionAttribute("Specifies data field for Target.")
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")
public function get,set TargetField : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Databindings")]
[System.ComponentModel.DescriptionAttribute("Specifies data field for Target.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
public: __property System.string* get_TargetField();
public: __property void set_TargetField(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Databindings")]
[System.ComponentModel.DescriptionAttribute("Specifies data field for Target.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
public:
property System.String^ TargetField {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBinding Class
WebTreeViewNodeBinding Members


Text Property

[image]
Intersoft WebTreeView Documentation
Text Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBinding Class : Text Property

Glossary Item Box

Gets or sets the display text of the node.Gets or sets the text of a node that you want to display.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Default Properties")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the display text of the node.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property Text As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBinding
Dim value As System.String

instance.Text = value

value = instance.Text
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Default Properties")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the display text of the node.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string Text {get; set;}
Delphi
public read-write property Text: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Default Properties")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the display text of the node.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set Text : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Default Properties")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the display text of the node.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_Text();
public: __property void set_Text(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Default Properties")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the display text of the node.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ Text {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBinding Class
WebTreeViewNodeBinding Members


TextField Property

[image]
Intersoft WebTreeView Documentation
TextField Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBinding Class : TextField Property

Glossary Item Box

Specifies data field for Text.Gets or sets the text of a node that you want to display based on the XML value.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")>
<System.ComponentModel.CategoryAttribute("Databindings")>
<System.ComponentModel.DescriptionAttribute("Specifies data field for Text.")>
Public Property TextField As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBinding
Dim value As System.String

instance.TextField = value

value = instance.TextField
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
[System.ComponentModel.CategoryAttribute("Databindings")]
[System.ComponentModel.DescriptionAttribute("Specifies data field for Text.")]
public System.string TextField {get; set;}
Delphi
public read-write property TextField: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")
System.ComponentModel.CategoryAttribute("Databindings")
System.ComponentModel.DescriptionAttribute("Specifies data field for Text.")
public function get,set TextField : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
[System.ComponentModel.CategoryAttribute("Databindings")]
[System.ComponentModel.DescriptionAttribute("Specifies data field for Text.")]
public: __property System.string* get_TextField();
public: __property void set_TextField(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
[System.ComponentModel.CategoryAttribute("Databindings")]
[System.ComponentModel.DescriptionAttribute("Specifies data field for Text.")]
public:
property System.String^ TextField {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBinding Class
WebTreeViewNodeBinding Members


TextImage Property

[image]
Intersoft WebTreeView Documentation
TextImage Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBinding Class : TextImage Property

Glossary Item Box

Gets or sets text image.Specifies the image of a node's text.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets text image.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Default Properties")>
Public Property TextImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBinding
Dim value As System.String

instance.TextImage = value

value = instance.TextImage
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets text image.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Default Properties")]
public System.string TextImage {get; set;}
Delphi
public read-write property TextImage: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets text image.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Default Properties")
public function get,set TextImage : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets text image.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Default Properties")]
public: __property System.string* get_TextImage();
public: __property void set_TextImage(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets text image.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Default Properties")]
public:
property System.String^ TextImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBinding Class
WebTreeViewNodeBinding Members


TextImageField Property

[image]
Intersoft WebTreeView Documentation
TextImageField Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBinding Class : TextImageField Property

Glossary Item Box

Specifies name field for text image.Specifies the image of a node's text based on the XML value.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies name field for text image.")>
<System.ComponentModel.CategoryAttribute("Databindings")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")>
Public Property TextImageField As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBinding
Dim value As System.String

instance.TextImageField = value

value = instance.TextImageField
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies name field for text image.")]
[System.ComponentModel.CategoryAttribute("Databindings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
public System.string TextImageField {get; set;}
Delphi
public read-write property TextImageField: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies name field for text image.")
System.ComponentModel.CategoryAttribute("Databindings")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")
public function get,set TextImageField : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies name field for text image.")]
[System.ComponentModel.CategoryAttribute("Databindings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
public: __property System.string* get_TextImageField();
public: __property void set_TextImageField(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies name field for text image.")]
[System.ComponentModel.CategoryAttribute("Databindings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
public:
property System.String^ TextImageField {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBinding Class
WebTreeViewNodeBinding Members


TextImageToolTip Property

[image]
Intersoft WebTreeView Documentation
TextImageToolTip Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBinding Class : TextImageToolTip Property

Glossary Item Box

Gets or sets the tooltip text image of the node.Specifies the specified node's tooltip textimage.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Default Properties")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the tooltip text image of the node.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property TextImageToolTip As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBinding
Dim value As System.String

instance.TextImageToolTip = value

value = instance.TextImageToolTip
C#
[System.ComponentModel.CategoryAttribute("Default Properties")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the tooltip text image of the node.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string TextImageToolTip {get; set;}
Delphi
public read-write property TextImageToolTip: System.String;
JScript
System.ComponentModel.CategoryAttribute("Default Properties")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the tooltip text image of the node.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set TextImageToolTip : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Default Properties")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the tooltip text image of the node.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_TextImageToolTip();
public: __property void set_TextImageToolTip(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Default Properties")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the tooltip text image of the node.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ TextImageToolTip {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBinding Class
WebTreeViewNodeBinding Members


TextImageToolTipField Property

[image]
Intersoft WebTreeView Documentation
TextImageToolTipField Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBinding Class : TextImageToolTipField Property

Glossary Item Box

Specifies data field for Text Image ToolTip.Specifies the specified node's tooltip textimage based on the XML value.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Databindings")>
<System.ComponentModel.DescriptionAttribute("Specifies data field for Text Image ToolTip.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")>
Public Property TextImageToolTipField As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBinding
Dim value As System.String

instance.TextImageToolTipField = value

value = instance.TextImageToolTipField
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Databindings")]
[System.ComponentModel.DescriptionAttribute("Specifies data field for Text Image ToolTip.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
public System.string TextImageToolTipField {get; set;}
Delphi
public read-write property TextImageToolTipField: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Databindings")
System.ComponentModel.DescriptionAttribute("Specifies data field for Text Image ToolTip.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")
public function get,set TextImageToolTipField : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Databindings")]
[System.ComponentModel.DescriptionAttribute("Specifies data field for Text Image ToolTip.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
public: __property System.string* get_TextImageToolTipField();
public: __property void set_TextImageToolTipField(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Databindings")]
[System.ComponentModel.DescriptionAttribute("Specifies data field for Text Image ToolTip.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
public:
property System.String^ TextImageToolTipField {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBinding Class
WebTreeViewNodeBinding Members


ToolTip Property

[image]
Intersoft WebTreeView Documentation
ToolTip Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBinding Class : ToolTip Property

Glossary Item Box

Gets or sets the tooltip text of the node.Gets or sets the tooltip of a node.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Default Properties")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the tooltip text of the node.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property ToolTip As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBinding
Dim value As System.String

instance.ToolTip = value

value = instance.ToolTip
C#
[System.ComponentModel.CategoryAttribute("Default Properties")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the tooltip text of the node.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string ToolTip {get; set;}
Delphi
public read-write property ToolTip: System.String;
JScript
System.ComponentModel.CategoryAttribute("Default Properties")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the tooltip text of the node.")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set ToolTip : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Default Properties")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the tooltip text of the node.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_ToolTip();
public: __property void set_ToolTip(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Default Properties")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the tooltip text of the node.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ ToolTip {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBinding Class
WebTreeViewNodeBinding Members


ToolTipField Property

[image]
Intersoft WebTreeView Documentation
ToolTipField Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBinding Class : ToolTipField Property

Glossary Item Box

Specifies data field for ToolTip.Gets or sets the tooltip of a node based on the XML value.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies data field for ToolTip.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")>
<System.ComponentModel.CategoryAttribute("Databindings")>
Public Property ToolTipField As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBinding
Dim value As System.String

instance.ToolTipField = value

value = instance.ToolTipField
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies data field for ToolTip.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
[System.ComponentModel.CategoryAttribute("Databindings")]
public System.string ToolTipField {get; set;}
Delphi
public read-write property ToolTipField: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies data field for ToolTip.")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")
System.ComponentModel.CategoryAttribute("Databindings")
public function get,set ToolTipField : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies data field for ToolTip.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
[System.ComponentModel.CategoryAttribute("Databindings")]
public: __property System.string* get_ToolTipField();
public: __property void set_ToolTipField(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies data field for ToolTip.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
[System.ComponentModel.CategoryAttribute("Databindings")]
public:
property System.String^ ToolTipField {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBinding Class
WebTreeViewNodeBinding Members


Value Property

[image]
Intersoft WebTreeView Documentation
Value Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBinding Class : Value Property

Glossary Item Box

Gets or sets the value of the value.Gets or sets the value of a node.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Default Properties")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the value of the value.")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property Value As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBinding
Dim value As System.String

instance.Value = value

value = instance.Value
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Default Properties")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value of the value.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string Value {get; set;}
Delphi
public read-write property Value: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Default Properties")
System.ComponentModel.DescriptionAttribute("Gets or sets the value of the value.")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set Value : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Default Properties")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value of the value.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_Value();
public: __property void set_Value(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Default Properties")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value of the value.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ Value {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBinding Class
WebTreeViewNodeBinding Members


ValueField Property

[image]
Intersoft WebTreeView Documentation
ValueField Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBinding Class : ValueField Property

Glossary Item Box

Specifies data field for Value.Gets or sets the value of a node based on the XML value.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")>
<System.ComponentModel.CategoryAttribute("Databindings")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies data field for Value.")>
Public Property ValueField As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBinding
Dim value As System.String

instance.ValueField = value

value = instance.ValueField
C#
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
[System.ComponentModel.CategoryAttribute("Databindings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies data field for Value.")]
public System.string ValueField {get; set;}
Delphi
public read-write property ValueField: System.String;
JScript
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")
System.ComponentModel.CategoryAttribute("Databindings")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies data field for Value.")
public function get,set ValueField : System.String
Managed Extensions for C++
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
[System.ComponentModel.CategoryAttribute("Databindings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies data field for Value.")]
public: __property System.string* get_ValueField();
public: __property void set_ValueField(
   System.string* value
);
C++/CLI
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
[System.ComponentModel.CategoryAttribute("Databindings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies data field for Value.")]
public:
property System.String^ ValueField {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBinding Class
WebTreeViewNodeBinding Members


Visible Property

[image]
Intersoft WebTreeView Documentation
Visible Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBinding Class : Visible Property

Glossary Item Box

Indicates whether the node is visible.Determines whether a node is visible or invisible.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Default Properties")>
<System.ComponentModel.DescriptionAttribute("Indicates whether the node is visible.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property Visible As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBinding
Dim value As System.Boolean

instance.Visible = value

value = instance.Visible
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Default Properties")]
[System.ComponentModel.DescriptionAttribute("Indicates whether the node is visible.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.bool Visible {get; set;}
Delphi
public read-write property Visible: System.Boolean;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Default Properties")
System.ComponentModel.DescriptionAttribute("Indicates whether the node is visible.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set Visible : System.boolean
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Default Properties")]
[System.ComponentModel.DescriptionAttribute("Indicates whether the node is visible.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.bool get_Visible();
public: __property void set_Visible(
   System.bool value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Default Properties")]
[System.ComponentModel.DescriptionAttribute("Indicates whether the node is visible.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.bool Visible {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBinding Class
WebTreeViewNodeBinding Members


VisibleField Property

[image]
Intersoft WebTreeView Documentation
VisibleField Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBinding Class : VisibleField Property

Glossary Item Box

Specifies data field for Visible.Determines whether a node is visible or invisible based on the XML value.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Databindings")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")>
<System.ComponentModel.DescriptionAttribute("Specifies data field for Visible.")>
Public Property VisibleField As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBinding
Dim value As System.String

instance.VisibleField = value

value = instance.VisibleField
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Databindings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
[System.ComponentModel.DescriptionAttribute("Specifies data field for Visible.")]
public System.string VisibleField {get; set;}
Delphi
public read-write property VisibleField: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Databindings")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")
System.ComponentModel.DescriptionAttribute("Specifies data field for Visible.")
public function get,set VisibleField : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Databindings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
[System.ComponentModel.DescriptionAttribute("Specifies data field for Visible.")]
public: __property System.string* get_VisibleField();
public: __property void set_VisibleField(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Databindings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="Ӓ.Ӕ, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
[System.ComponentModel.DescriptionAttribute("Specifies data field for Visible.")]
public:
property System.String^ VisibleField {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBinding Class
WebTreeViewNodeBinding Members


WebTreeViewNodeBindingCollection Class

[image]
Intersoft WebTreeView Documentation
WebTreeViewNodeBindingCollection Class
Members See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace : WebTreeViewNodeBindingCollection Class

Glossary Item Box

Summary description for WebTreeViewNodeBindingCollection. A collection of WebTreeViewNodeBinding.

Object Model

WebTreeViewNodeBindingCollection Class

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("A collection of WebTreeViewNodeBinding. ")>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebTreeView.WebTreeViewBindingsEditor, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.Reflection.DefaultMemberAttribute("Item")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.SerializableAttribute()>
Public Class WebTreeViewNodeBindingCollection
   Inherits ISNet.WebUI.ISCollectionBase
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBindingCollection
C#
[System.ComponentModel.DescriptionAttribute("A collection of WebTreeViewNodeBinding. ")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebTreeView.WebTreeViewBindingsEditor, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.Reflection.DefaultMemberAttribute("Item")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.SerializableAttribute()]
public class WebTreeViewNodeBindingCollection : ISNet.WebUI.ISCollectionBase
Delphi
public class WebTreeViewNodeBindingCollection = class(ISNet.WebUI.ISCollectionBase)
JScript
System.ComponentModel.DescriptionAttribute("A collection of WebTreeViewNodeBinding. ")
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebTreeView.WebTreeViewBindingsEditor, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.Reflection.DefaultMemberAttribute("Item")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.SerializableAttribute()
public class WebTreeViewNodeBindingCollection extends ISNet.WebUI.ISCollectionBase
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("A collection of WebTreeViewNodeBinding. ")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebTreeView.WebTreeViewBindingsEditor, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.Reflection.DefaultMemberAttribute("Item")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.SerializableAttribute()]
public __gc class WebTreeViewNodeBindingCollection : public ISNet.WebUI.ISCollectionBase
C++/CLI
[System.ComponentModel.DescriptionAttribute("A collection of WebTreeViewNodeBinding. ")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.WebTreeView.WebTreeViewBindingsEditor, ISNet.WebUI.WebTreeView, Version=1.0.1500.401, Culture=neutral, PublicKeyToken=1c86f64ca0b1cfd4")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.Reflection.DefaultMemberAttribute("Item")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.SerializableAttribute()]
public ref class WebTreeViewNodeBindingCollection : public ISNet.WebUI.ISCollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
ISNet.WebUI.ISCollectionBase
ISNet.WebUI.WebTreeView.WebTreeViewNodeBindingCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBindingCollection Members
ISNet.WebUI.WebTreeView Namespace


WebTreeViewNodeBindingCollection Class Members

[image]
Intersoft WebTreeView Documentation
WebTreeViewNodeBindingCollection Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebTreeView Namespace : WebTreeViewNodeBindingCollection Class

Glossary Item Box

The following tables list the members exposed by WebTreeViewNodeBindingCollection.

Public Constructors

 | Name | Description
Public Constructor | WebTreeViewNodeBindingCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | All | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Overridden. Returns a Boolean value indicating whether the collection is read-only.Returns a Boolean value indicating whether the collection is read-only.
Public Property | Item | Property indexer for the collection. Property indexer for the collection.
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

Protected Properties

 | Name | Description
Protected Property | InnerList | (Inherited from System.Collections.CollectionBase)
Protected Property | List | (Inherited from System.Collections.CollectionBase)
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Add WebTreeViewNodeBinding object into the WebTreeViewNodeBinding collection. Adds a new node to a WebTreeViewNodeBindingCollection instance with WebTreeViewNodeBinding parameter as its name.
Public Method | Clear | Removes all WebTreeViewNodeBinding objects from the collection. Removes node objects from the node binding collection.
Public Method | Contains | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | CopyTo | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Exists | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetEnumerator | Returns an enumerator object for the collection. Returns an enumerator object for the collection.
Public Method | GetItem | Overloaded. (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetNamedItem | Property indexer for the collection. Uses the Name string to return an WebTreeViewNodeBinding object. Property indexer for the collection. Uses the Name string to return WebTreeView node object.
Public Method | IndexOf | Overloaded. (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Insert | Inserts a WebTreeViewNodeBinding object into the WebTreeViewNodeBinding collection at a specified index. Inserts a new WebTreeView node into a WebTreeView collection at a specified index.
Public Method | IntInsert | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Remove | Removes the specified WebTreeViewNodeBinding object from the collection. Removes the specified WebTreeView node object from the collection.
Public Method | setParent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateArray | (Inherited from ISNet.WebUI.ISCollectionBase)
Protected Method | IntAdd | (Inherited from ISNet.WebUI.ISCollectionBase)
Protected Method | IntClear | (Inherited from ISNet.WebUI.ISCollectionBase)
Protected Method | IntRemove | (Inherited from ISNet.WebUI.ISCollectionBase)
Protected Method | IntRemoveAt | (Inherited from ISNet.WebUI.ISCollectionBase)
Protected Method | OnClear | (Inherited from System.Collections.CollectionBase)
Protected Method | OnClearComplete | (Inherited from System.Collections.CollectionBase)
Protected Method | OnInsert | (Inherited from System.Collections.CollectionBase)
Protected Method | OnInsertComplete | Overridden.
Protected Method | OnRemove | (Inherited from System.Collections.CollectionBase)
Protected Method | OnRemoveComplete | (Inherited from System.Collections.CollectionBase)
Protected Method | OnSet | (Inherited from System.Collections.CollectionBase)
Protected Method | OnSetComplete | (Inherited from System.Collections.CollectionBase)
Protected Method | OnValidate | (Inherited from System.Collections.CollectionBase)
Protected Method | RemoveAt | Removes the WebTreeViewNodeBinding object at the specified index from the collection.
Top

See Also

Reference

WebTreeViewNodeBindingCollection Class
ISNet.WebUI.WebTreeView Namespace


WebTreeViewNodeBindingCollection Constructor

[image]
Intersoft WebTreeView Documentation
WebTreeViewNodeBindingCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBindingCollection Class : WebTreeViewNodeBindingCollection Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebTreeViewNodeBindingCollection class. ")>
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebTreeViewNodeBindingCollection()
C#
[System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebTreeViewNodeBindingCollection class. ")]
public WebTreeViewNodeBindingCollection()
Delphi
public WebTreeViewNodeBindingCollection();
JScript
System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebTreeViewNodeBindingCollection class. ")
public function WebTreeViewNodeBindingCollection();
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebTreeViewNodeBindingCollection class. ")]
public: WebTreeViewNodeBindingCollection();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebTreeViewNodeBindingCollection class. ")]
public:
WebTreeViewNodeBindingCollection();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBindingCollection Class
WebTreeViewNodeBindingCollection Members


WebTreeViewNodeBindingCollection Class Methods

[image]
Intersoft WebTreeView Documentation
WebTreeViewNodeBindingCollection Class Methods
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace : WebTreeViewNodeBindingCollection Class

Glossary Item Box

For a list of all members of this type, see WebTreeViewNodeBindingCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Add WebTreeViewNodeBinding object into the WebTreeViewNodeBinding collection. Adds a new node to a WebTreeViewNodeBindingCollection instance with WebTreeViewNodeBinding parameter as its name.
Public Method | Clear | Removes all WebTreeViewNodeBinding objects from the collection. Removes node objects from the node binding collection.
Public Method | Contains | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | CopyTo | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Exists | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetEnumerator | Returns an enumerator object for the collection. Returns an enumerator object for the collection.
Public Method | GetItem | Overloaded. (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetNamedItem | Property indexer for the collection. Uses the Name string to return an WebTreeViewNodeBinding object. Property indexer for the collection. Uses the Name string to return WebTreeView node object.
Public Method | IndexOf | Overloaded. (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Insert | Inserts a WebTreeViewNodeBinding object into the WebTreeViewNodeBinding collection at a specified index. Inserts a new WebTreeView node into a WebTreeView collection at a specified index.
Public Method | IntInsert | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Remove | Removes the specified WebTreeViewNodeBinding object from the collection. Removes the specified WebTreeView node object from the collection.
Public Method | setParent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateArray | (Inherited from ISNet.WebUI.ISCollectionBase)
Protected Method | IntAdd | (Inherited from ISNet.WebUI.ISCollectionBase)
Protected Method | IntClear | (Inherited from ISNet.WebUI.ISCollectionBase)
Protected Method | IntRemove | (Inherited from ISNet.WebUI.ISCollectionBase)
Protected Method | IntRemoveAt | (Inherited from ISNet.WebUI.ISCollectionBase)
Protected Method | OnClear | (Inherited from System.Collections.CollectionBase)
Protected Method | OnClearComplete | (Inherited from System.Collections.CollectionBase)
Protected Method | OnInsert | (Inherited from System.Collections.CollectionBase)
Protected Method | OnInsertComplete | Overridden.
Protected Method | OnRemove | (Inherited from System.Collections.CollectionBase)
Protected Method | OnRemoveComplete | (Inherited from System.Collections.CollectionBase)
Protected Method | OnSet | (Inherited from System.Collections.CollectionBase)
Protected Method | OnSetComplete | (Inherited from System.Collections.CollectionBase)
Protected Method | OnValidate | (Inherited from System.Collections.CollectionBase)
Protected Method | RemoveAt | Removes the WebTreeViewNodeBinding object at the specified index from the collection.
Top

See Also

Reference

WebTreeViewNodeBindingCollection Class
ISNet.WebUI.WebTreeView Namespace


Add Method

[image]
Intersoft WebTreeView Documentation
Add Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBindingCollection Class : Add Method

Glossary Item Box

Add WebTreeViewNodeBinding object into the WebTreeViewNodeBinding collection. Adds a new node to a WebTreeViewNodeBindingCollection instance with WebTreeViewNodeBinding parameter as its name. Adds a new node to a WebTreeViewNodeBindingCollection instance.

Overload List

Overload | Description
Add(WebTreeViewNodeBinding) | Add WebTreeViewNodeBinding object into the WebTreeViewNodeBinding collection. Adds a new node to a WebTreeViewNodeBindingCollection instance with WebTreeViewNodeBinding parameter as its name.
Add(String) | Creates a new node object in the collection and initializes its Name value. Adds a new node to a WebTreeViewNodeBindingCollection instance with String parameter as its name.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBindingCollection Class
WebTreeViewNodeBindingCollection Members


Add(WebTreeViewNodeBinding) Method

[image]
Intersoft WebTreeView Documentation
Add(WebTreeViewNodeBinding) Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBindingCollection Class > Add Method : Add(WebTreeViewNodeBinding) Method

node
The WebTreeViewNodeBinding object to be added.The specified node.

Glossary Item Box

Add WebTreeViewNodeBinding object into the WebTreeViewNodeBinding collection. Adds a new node to a WebTreeViewNodeBindingCollection instance with WebTreeViewNodeBinding parameter as its name.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Adds a new node to a WebTreeViewNodeBindingCollection instance  with WebTreeViewNodeBinding parameter as its name.")>
Public Overloads Overridable Function Add( _
   ByVal node As WebTreeViewNodeBinding _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBindingCollection
Dim node As WebTreeViewNodeBinding
Dim value As System.Integer

value = instance.Add(node)
C#
[System.ComponentModel.DescriptionAttribute("Adds a new node to a WebTreeViewNodeBindingCollection instance  with WebTreeViewNodeBinding parameter as its name.")]
public virtual System.int Add(
   WebTreeViewNodeBinding node
)
Delphi
public function Add(
    node: WebTreeViewNodeBinding
): System.Integer; virtual;
JScript
System.ComponentModel.DescriptionAttribute("Adds a new node to a WebTreeViewNodeBindingCollection instance  with WebTreeViewNodeBinding parameter as its name.")
public function Add(
   node : WebTreeViewNodeBinding
) : System.int;
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Adds a new node to a WebTreeViewNodeBindingCollection instance  with WebTreeViewNodeBinding parameter as its name.")]
public: virtual System.int Add(
   WebTreeViewNodeBinding* node
)
C++/CLI
[System.ComponentModel.DescriptionAttribute("Adds a new node to a WebTreeViewNodeBindingCollection instance  with WebTreeViewNodeBinding parameter as its name.")]
public:
virtual System.int Add(
   WebTreeViewNodeBinding^ node
)

Parameters

node
The WebTreeViewNodeBinding object to be added.The specified node.

Return Value

The index of the newly added node.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBindingCollection Class
WebTreeViewNodeBindingCollection Members
Overload List


Add(String) Method

[image]
Intersoft WebTreeView Documentation
Add(String) Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBindingCollection Class > Add Method : Add(String) Method

name
The unique Name value.Name of the new WebTreeViewNodeBindingCollection instance.

Glossary Item Box

Creates a new node object in the collection and initializes its Name value. Adds a new node to a WebTreeViewNodeBindingCollection instance with String parameter as its name.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Adds a new node to a WebTreeViewNodeBindingCollection instance  with String parameter as its name. ")>
Public Overloads Function Add( _
   ByVal name As System.String _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBindingCollection
Dim name As System.String
Dim value As System.Integer

value = instance.Add(name)
C#
[System.ComponentModel.DescriptionAttribute("Adds a new node to a WebTreeViewNodeBindingCollection instance  with String parameter as its name. ")]
public System.int Add(
   System.string name
)
Delphi
public function Add(
    name: System.String
): System.Integer;
JScript
System.ComponentModel.DescriptionAttribute("Adds a new node to a WebTreeViewNodeBindingCollection instance  with String parameter as its name. ")
public function Add(
   name : System.String
) : System.int;
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Adds a new node to a WebTreeViewNodeBindingCollection instance  with String parameter as its name. ")]
public: System.int Add(
   System.string* name
)
C++/CLI
[System.ComponentModel.DescriptionAttribute("Adds a new node to a WebTreeViewNodeBindingCollection instance  with String parameter as its name. ")]
public:
System.int Add(
   System.String^ name
)

Parameters

name
The unique Name value.Name of the new WebTreeViewNodeBindingCollection instance.

Return Value

The index of the newly-added node object within the collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBindingCollection Class
WebTreeViewNodeBindingCollection Members
Overload List


Clear Method

[image]
Intersoft WebTreeView Documentation
Clear Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBindingCollection Class : Clear Method

Glossary Item Box

Removes all WebTreeViewNodeBinding objects from the collection. Removes node objects from the node binding collection.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Removes node objects from the node binding collection. ")>
Public Shadows Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBindingCollection

instance.Clear()
C#
[System.ComponentModel.DescriptionAttribute("Removes node objects from the node binding collection. ")]
public new void Clear()
Delphi
public procedure Clear();
JScript
System.ComponentModel.DescriptionAttribute("Removes node objects from the node binding collection. ")
public hide function Clear();
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Removes node objects from the node binding collection. ")]
public: new void Clear();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Removes node objects from the node binding collection. ")]
public:
new void Clear();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBindingCollection Class
WebTreeViewNodeBindingCollection Members


GetEnumerator Method

[image]
Intersoft WebTreeView Documentation
GetEnumerator Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBindingCollection Class : GetEnumerator Method

Glossary Item Box

Returns an enumerator object for the collection. Returns an enumerator object for the collection.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Returns an enumerator object for the collection. ")>
Public Shadows Function GetEnumerator() As System.Collections.IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBindingCollection
Dim value As System.Collections.IEnumerator

value = instance.GetEnumerator()
C#
[System.ComponentModel.DescriptionAttribute("Returns an enumerator object for the collection. ")]
public new System.Collections.IEnumerator GetEnumerator()
Delphi
public function GetEnumerator(): System.Collections.IEnumerator;
JScript
System.ComponentModel.DescriptionAttribute("Returns an enumerator object for the collection. ")
public hide function GetEnumerator() : System.Collections.IEnumerator;
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Returns an enumerator object for the collection. ")]
public: new System.Collections.IEnumerator* GetEnumerator();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Returns an enumerator object for the collection. ")]
public:
new System.Collections.IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBindingCollection Class
WebTreeViewNodeBindingCollection Members


GetNamedItem Method

[image]
Intersoft WebTreeView Documentation
GetNamedItem Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBindingCollection Class : GetNamedItem Method

name
Name of the WebTreeViewNodeBindingCollection instance.

Glossary Item Box

Property indexer for the collection. Uses the Name string to return an WebTreeViewNodeBinding object. Property indexer for the collection. Uses the Name string to return WebTreeView node object.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Property indexer for the collection. Uses the Name string to return WebTreeView node object.")>
Public Function GetNamedItem( _
   ByVal name As System.String _
) As WebTreeViewNodeBinding
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBindingCollection
Dim name As System.String
Dim value As WebTreeViewNodeBinding

value = instance.GetNamedItem(name)
C#
[System.ComponentModel.DescriptionAttribute("Property indexer for the collection. Uses the Name string to return WebTreeView node object.")]
public WebTreeViewNodeBinding GetNamedItem(
   System.string name
)
Delphi
public function GetNamedItem(
    name: System.String
): WebTreeViewNodeBinding;
JScript
System.ComponentModel.DescriptionAttribute("Property indexer for the collection. Uses the Name string to return WebTreeView node object.")
public function GetNamedItem(
   name : System.String
) : WebTreeViewNodeBinding;
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Property indexer for the collection. Uses the Name string to return WebTreeView node object.")]
public: WebTreeViewNodeBinding* GetNamedItem(
   System.string* name
)
C++/CLI
[System.ComponentModel.DescriptionAttribute("Property indexer for the collection. Uses the Name string to return WebTreeView node object.")]
public:
WebTreeViewNodeBinding^ GetNamedItem(
   System.String^ name
)

Parameters

name
Name of the WebTreeViewNodeBindingCollection instance.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBindingCollection Class
WebTreeViewNodeBindingCollection Members


Insert Method

[image]
Intersoft WebTreeView Documentation
Insert Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBindingCollection Class : Insert Method

index
The position in the collection for the new WebTreeViewNodeBinding.The index of the specified node.
node
The WebTreeViewNodeBinding object to be inserted into the collection.The name of the specified node.

Glossary Item Box

Inserts a WebTreeViewNodeBinding object into the WebTreeViewNodeBinding collection at a specified index. Inserts a new WebTreeView node into a WebTreeView collection at a specified index.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Inserts a new WebTreeView node into a WebTreeView collection at a specified index.")>
Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal node As WebTreeViewNodeBinding _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBindingCollection
Dim index As System.Integer
Dim node As WebTreeViewNodeBinding

instance.Insert(index, node)
C#
[System.ComponentModel.DescriptionAttribute("Inserts a new WebTreeView node into a WebTreeView collection at a specified index.")]
public void Insert(
   System.int index,
   WebTreeViewNodeBinding node
)
Delphi
public procedure Insert(
    index: System.Integer;
    node: WebTreeViewNodeBinding
);
JScript
System.ComponentModel.DescriptionAttribute("Inserts a new WebTreeView node into a WebTreeView collection at a specified index.")
public function Insert(
   index : System.int,
   node : WebTreeViewNodeBinding
);
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Inserts a new WebTreeView node into a WebTreeView collection at a specified index.")]
public: void Insert(
   System.int index,
   WebTreeViewNodeBinding* node
)
C++/CLI
[System.ComponentModel.DescriptionAttribute("Inserts a new WebTreeView node into a WebTreeView collection at a specified index.")]
public:
void Insert(
   System.int index,
   WebTreeViewNodeBinding^ node
)

Parameters

index
The position in the collection for the new WebTreeViewNodeBinding.The index of the specified node.
node
The WebTreeViewNodeBinding object to be inserted into the collection.The name of the specified node.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBindingCollection Class
WebTreeViewNodeBindingCollection Members


OnInsertComplete Method

[image]
Intersoft WebTreeView Documentation
OnInsertComplete Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBindingCollection Class : OnInsertComplete Method

index
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnInsertComplete( _
   ByVal index As System.Integer, _
   ByVal value As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBindingCollection
Dim index As System.Integer
Dim value As System.Object

instance.OnInsertComplete(index, value)
C#
protected override void OnInsertComplete(
   System.int index,
   System.object value
)
Delphi
protected procedure OnInsertComplete(
    index: System.Integer;
    value: System.TObject
); override;
JScript
protected override function OnInsertComplete(
   index : System.int,
   value : System.Object
);
Managed Extensions for C++
protected: void OnInsertComplete(
   System.int index,
   System.Object* value
) override
C++/CLI
protected:
void OnInsertComplete(
   System.int index,
   System.Object^ value
) override

Parameters

index
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBindingCollection Class
WebTreeViewNodeBindingCollection Members


Remove Method

[image]
Intersoft WebTreeView Documentation
Remove Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBindingCollection Class : Remove Method

node
The WebTreeViewNodeBinding object to be removed from the collection.The name of the specified node.

Glossary Item Box

Removes the specified WebTreeViewNodeBinding object from the collection. Removes the specified WebTreeView node object from the collection.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Removes the specified WebTreeView node object from the collection.  ")>
Public Sub Remove( _
   ByVal node As WebTreeViewNodeBinding _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBindingCollection
Dim node As WebTreeViewNodeBinding

instance.Remove(node)
C#
[System.ComponentModel.DescriptionAttribute("Removes the specified WebTreeView node object from the collection.  ")]
public void Remove(
   WebTreeViewNodeBinding node
)
Delphi
public procedure Remove(
    node: WebTreeViewNodeBinding
);
JScript
System.ComponentModel.DescriptionAttribute("Removes the specified WebTreeView node object from the collection.  ")
public function Remove(
   node : WebTreeViewNodeBinding
);
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Removes the specified WebTreeView node object from the collection.  ")]
public: void Remove(
   WebTreeViewNodeBinding* node
)
C++/CLI
[System.ComponentModel.DescriptionAttribute("Removes the specified WebTreeView node object from the collection.  ")]
public:
void Remove(
   WebTreeViewNodeBinding^ node
)

Parameters

node
The WebTreeViewNodeBinding object to be removed from the collection.The name of the specified node.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBindingCollection Class
WebTreeViewNodeBindingCollection Members


RemoveAt Method

[image]
Intersoft WebTreeView Documentation
RemoveAt Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBindingCollection Class : RemoveAt Method

index
The index of the WebTreeViewNodeBinding object to be removed.

Glossary Item Box

Removes the WebTreeViewNodeBinding object at the specified index from the collection.

Syntax

Visual Basic (Declaration)
Protected Shadows Sub RemoveAt( _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBindingCollection
Dim index As System.Integer

instance.RemoveAt(index)
C#
protected new void RemoveAt(
   System.int index
)
Delphi
protected procedure RemoveAt(
    index: System.Integer
);
JScript
protected hide function RemoveAt(
   index : System.int
);
Managed Extensions for C++
protected: new void RemoveAt(
   System.int index
)
C++/CLI
protected:
new void RemoveAt(
   System.int index
)

Parameters

index
The index of the WebTreeViewNodeBinding object to be removed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBindingCollection Class
WebTreeViewNodeBindingCollection Members


WebTreeViewNodeBindingCollection Class Properties

[image]
Intersoft WebTreeView Documentation
WebTreeViewNodeBindingCollection Class Properties
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace : WebTreeViewNodeBindingCollection Class

Glossary Item Box

For a list of all members of this type, see WebTreeViewNodeBindingCollection members.

Public Properties

 | Name | Description
Public Property | All | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Overridden. Returns a Boolean value indicating whether the collection is read-only.Returns a Boolean value indicating whether the collection is read-only.
Public Property | Item | Property indexer for the collection. Property indexer for the collection.
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

Protected Properties

 | Name | Description
Protected Property | InnerList | (Inherited from System.Collections.CollectionBase)
Protected Property | List | (Inherited from System.Collections.CollectionBase)
Top

See Also

Reference

WebTreeViewNodeBindingCollection Class
ISNet.WebUI.WebTreeView Namespace


IsReadOnly Property

[image]
Intersoft WebTreeView Documentation
IsReadOnly Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBindingCollection Class : IsReadOnly Property

Glossary Item Box

Returns a Boolean value indicating whether the collection is read-only.Returns a Boolean value indicating whether the collection is read-only.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Returns a Boolean value indicating whether the collection is read-only.")>
Public Overrides ReadOnly Property IsReadOnly As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBindingCollection
Dim value As System.Boolean

value = instance.IsReadOnly
C#
[System.ComponentModel.DescriptionAttribute("Returns a Boolean value indicating whether the collection is read-only.")]
public override System.bool IsReadOnly {get;}
Delphi
public read-only property IsReadOnly: System.Boolean; override;
JScript
System.ComponentModel.DescriptionAttribute("Returns a Boolean value indicating whether the collection is read-only.")
public override function get IsReadOnly : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Returns a Boolean value indicating whether the collection is read-only.")]
public: __property System.bool get_IsReadOnly() override;
C++/CLI
[System.ComponentModel.DescriptionAttribute("Returns a Boolean value indicating whether the collection is read-only.")]
public:
property System.bool IsReadOnly {
   System.bool get() override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBindingCollection Class
WebTreeViewNodeBindingCollection Members


Item Property

[image]
Intersoft WebTreeView Documentation
Item Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBindingCollection Class : Item Property

index
The index of the specified node.

Glossary Item Box

Property indexer for the collection. Property indexer for the collection.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Property indexer for the collection. ")>
Public Default Property Item( _
   ByVal index As System.Integer _
) As WebTreeViewNodeBinding
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBindingCollection
Dim index As System.Integer
Dim value As WebTreeViewNodeBinding

instance.Item(index) = value

value = instance.Item(index)
C#
[System.ComponentModel.DescriptionAttribute("Property indexer for the collection. ")]
public WebTreeViewNodeBinding this[
   System.int index
]; {get; set;}
Delphi
public  this: : WebTreeViewNodeBinding;[
    index: System.Integer
]; read-write
JScript
System.ComponentModel.DescriptionAttribute("Property indexer for the collection. ")
public  this[
   index : System.int
] get,set : WebTreeViewNodeBinding
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Property indexer for the collection. ")]
public: __property WebTreeViewNodeBinding* get_Item   System.int index
;
public: __property void set_Item   System.int index,
   WebTreeViewNodeBinding* value
;
C++/CLI
[System.ComponentModel.DescriptionAttribute("Property indexer for the collection. ")]
public:
property WebTreeViewNodeBinding^ default [int] {
   WebTreeViewNodeBinding^ get(System.int index);
   void set (System.int index, WebTreeViewNodeBinding^ value);
}

Parameters

index
The index of the specified node.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBindingCollection Class
WebTreeViewNodeBindingCollection Members


WebTreeViewNodeCollection Class

[image]
Intersoft WebTreeView Documentation
WebTreeViewNodeCollection Class
Members See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace : WebTreeViewNodeCollection Class

Glossary Item Box

Summary description for WebTreeViewNodeCollection. A collection of WebTreeViewNode.

Object Model

WebTreeViewNodeCollection Class

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DescriptionAttribute("A collection of WebTreeViewNodeBinding. ")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.Reflection.DefaultMemberAttribute("Item")>
<System.SerializableAttribute()>
Public Class WebTreeViewNodeCollection
   Inherits ISNet.WebUI.ISCollectionBase
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeCollection
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("A collection of WebTreeViewNodeBinding. ")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.Reflection.DefaultMemberAttribute("Item")]
[System.SerializableAttribute()]
public class WebTreeViewNodeCollection : ISNet.WebUI.ISCollectionBase
Delphi
public class WebTreeViewNodeCollection = class(ISNet.WebUI.ISCollectionBase)
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DescriptionAttribute("A collection of WebTreeViewNodeBinding. ")
ISNet.Serialization.XmlSerializableAttribute()
System.Reflection.DefaultMemberAttribute("Item")
System.SerializableAttribute()
public class WebTreeViewNodeCollection extends ISNet.WebUI.ISCollectionBase
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("A collection of WebTreeViewNodeBinding. ")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.Reflection.DefaultMemberAttribute("Item")]
[System.SerializableAttribute()]
public __gc class WebTreeViewNodeCollection : public ISNet.WebUI.ISCollectionBase
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("A collection of WebTreeViewNodeBinding. ")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.Reflection.DefaultMemberAttribute("Item")]
[System.SerializableAttribute()]
public ref class WebTreeViewNodeCollection : public ISNet.WebUI.ISCollectionBase

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
ISNet.WebUI.ISCollectionBase
ISNet.WebUI.WebTreeView.WebTreeViewNodeCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeCollection Members
ISNet.WebUI.WebTreeView Namespace


WebTreeViewNodeCollection Class Members

[image]
Intersoft WebTreeView Documentation
WebTreeViewNodeCollection Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebTreeView Namespace : WebTreeViewNodeCollection Class

Glossary Item Box

The following tables list the members exposed by WebTreeViewNodeCollection.

Public Constructors

 | Name | Description
Public Constructor | WebTreeViewNodeCollection Constructor |
Top

Public Properties

 | Name | Description
Public Property | All | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Overridden. Returns a Boolean value indicating whether the collection is read-only. Returns a Boolean value indicating whether the collection is read-only.
Public Property | Item | Property indexer for the collection. Property indexer for the collection.
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

Protected Properties

 | Name | Description
Protected Property | InnerList | (Inherited from System.Collections.CollectionBase)
Protected Property | List | (Inherited from System.Collections.CollectionBase)
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Add WebTreeViewNode object into the WebTreeViewNode collection. Adds a new node to a WebTreeViewNodeBindingCollection instance with WebTreeViewNode parameter as its name.
Public Method | Clear | Removes all WebTreeViewNode objects from the collection. Removes node objects from the collection.
Public Method | Contains | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | CopyTo | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Exists | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetEnumerator | Returns an enumerator object for the collection. Returns an enumerator object for the collection.
Public Method | GetItem | Overloaded. (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetNamedItem | Property indexer for the collection. Uses the Name string to return an WebTreeViewNode object. Property indexer for the collection. Uses the Name string to return WebTreeView node object.
Public Method | IndexOf | Overloaded. (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Insert | Inserts a WebTreeViewNode object into the WebTreeViewNode collection at a specified index. Inserts a new WebTreeView node into a WebTreeView collection at a specified index.
Public Method | IntInsert | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Remove | Removes the specified WebTreeViewNode object from the collection. Removes the specified WebTreeView node object from the collection.
Public Method | setParent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateArray | (Inherited from ISNet.WebUI.ISCollectionBase)
Protected Method | IntAdd | (Inherited from ISNet.WebUI.ISCollectionBase)
Protected Method | IntClear | (Inherited from ISNet.WebUI.ISCollectionBase)
Protected Method | IntRemove | (Inherited from ISNet.WebUI.ISCollectionBase)
Protected Method | IntRemoveAt | (Inherited from ISNet.WebUI.ISCollectionBase)
Protected Method | OnClear | (Inherited from System.Collections.CollectionBase)
Protected Method | OnClearComplete | (Inherited from System.Collections.CollectionBase)
Protected Method | OnInsert | (Inherited from System.Collections.CollectionBase)
Protected Method | OnInsertComplete | Overridden.
Protected Method | OnRemove | (Inherited from System.Collections.CollectionBase)
Protected Method | OnRemoveComplete | (Inherited from System.Collections.CollectionBase)
Protected Method | OnSet | (Inherited from System.Collections.CollectionBase)
Protected Method | OnSetComplete | (Inherited from System.Collections.CollectionBase)
Protected Method | OnValidate | (Inherited from System.Collections.CollectionBase)
Protected Method | RemoveAt | Removes the WebTreeViewNode object at the specified index from the collection.
Top

See Also

Reference

WebTreeViewNodeCollection Class
ISNet.WebUI.WebTreeView Namespace


WebTreeViewNodeCollection Constructor

[image]
Intersoft WebTreeView Documentation
WebTreeViewNodeCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeCollection Class : WebTreeViewNodeCollection Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebTreeViewNodeBindingCollection class. ")>
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebTreeViewNodeCollection()
C#
[System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebTreeViewNodeBindingCollection class. ")]
public WebTreeViewNodeCollection()
Delphi
public WebTreeViewNodeCollection();
JScript
System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebTreeViewNodeBindingCollection class. ")
public function WebTreeViewNodeCollection();
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebTreeViewNodeBindingCollection class. ")]
public: WebTreeViewNodeCollection();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebTreeViewNodeBindingCollection class. ")]
public:
WebTreeViewNodeCollection();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeCollection Class
WebTreeViewNodeCollection Members


WebTreeViewNodeCollection Class Methods

[image]
Intersoft WebTreeView Documentation
WebTreeViewNodeCollection Class Methods
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace : WebTreeViewNodeCollection Class

Glossary Item Box

For a list of all members of this type, see WebTreeViewNodeCollection members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded. Add WebTreeViewNode object into the WebTreeViewNode collection. Adds a new node to a WebTreeViewNodeBindingCollection instance with WebTreeViewNode parameter as its name.
Public Method | Clear | Removes all WebTreeViewNode objects from the collection. Removes node objects from the collection.
Public Method | Contains | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | CopyTo | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Exists | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetEnumerator | Returns an enumerator object for the collection. Returns an enumerator object for the collection.
Public Method | GetItem | Overloaded. (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | GetNamedItem | Property indexer for the collection. Uses the Name string to return an WebTreeViewNode object. Property indexer for the collection. Uses the Name string to return WebTreeView node object.
Public Method | IndexOf | Overloaded. (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Insert | Inserts a WebTreeViewNode object into the WebTreeViewNode collection at a specified index. Inserts a new WebTreeView node into a WebTreeView collection at a specified index.
Public Method | IntInsert | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Method | Remove | Removes the specified WebTreeViewNode object from the collection. Removes the specified WebTreeView node object from the collection.
Public Method | setParent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

Protected Methods

 | Name | Description
Protected Method | CreateArray | (Inherited from ISNet.WebUI.ISCollectionBase)
Protected Method | IntAdd | (Inherited from ISNet.WebUI.ISCollectionBase)
Protected Method | IntClear | (Inherited from ISNet.WebUI.ISCollectionBase)
Protected Method | IntRemove | (Inherited from ISNet.WebUI.ISCollectionBase)
Protected Method | IntRemoveAt | (Inherited from ISNet.WebUI.ISCollectionBase)
Protected Method | OnClear | (Inherited from System.Collections.CollectionBase)
Protected Method | OnClearComplete | (Inherited from System.Collections.CollectionBase)
Protected Method | OnInsert | (Inherited from System.Collections.CollectionBase)
Protected Method | OnInsertComplete | Overridden.
Protected Method | OnRemove | (Inherited from System.Collections.CollectionBase)
Protected Method | OnRemoveComplete | (Inherited from System.Collections.CollectionBase)
Protected Method | OnSet | (Inherited from System.Collections.CollectionBase)
Protected Method | OnSetComplete | (Inherited from System.Collections.CollectionBase)
Protected Method | OnValidate | (Inherited from System.Collections.CollectionBase)
Protected Method | RemoveAt | Removes the WebTreeViewNode object at the specified index from the collection.
Top

See Also

Reference

WebTreeViewNodeCollection Class
ISNet.WebUI.WebTreeView Namespace


Add Method

[image]
Intersoft WebTreeView Documentation
Add Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeCollection Class : Add Method

Glossary Item Box

Add WebTreeViewNode object into the WebTreeViewNode collection. Adds a new node to a WebTreeViewNodeBindingCollection instance with WebTreeViewNode parameter as its name. Add a new node object to the collection.

Overload List

Overload | Description
Add(WebTreeViewNode) | Add WebTreeViewNode object into the WebTreeViewNode collection. Adds a new node to a WebTreeViewNodeBindingCollection instance with WebTreeViewNode parameter as its name.
Add(String) | Creates a new node object in the collection and initializes its Name value. Adds a new node to a WebTreeViewNodeBindingCollection instance with String parameter as its name.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeCollection Class
WebTreeViewNodeCollection Members


Add(WebTreeViewNode) Method

[image]
Intersoft WebTreeView Documentation
Add(WebTreeViewNode) Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeCollection Class > Add Method : Add(WebTreeViewNode) Method

node
The WebTreeViewNode object to be added.The specified node.

Glossary Item Box

Add WebTreeViewNode object into the WebTreeViewNode collection. Adds a new node to a WebTreeViewNodeBindingCollection instance with WebTreeViewNode parameter as its name.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Adds a new node to a WebTreeViewNodeBindingCollection instance  with WebTreeViewNodeBinding parameter as its name. ")>
Public Overloads Overridable Function Add( _
   ByVal node As WebTreeViewNode _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeCollection
Dim node As WebTreeViewNode
Dim value As System.Integer

value = instance.Add(node)
C#
[System.ComponentModel.DescriptionAttribute("Adds a new node to a WebTreeViewNodeBindingCollection instance  with WebTreeViewNodeBinding parameter as its name. ")]
public virtual System.int Add(
   WebTreeViewNode node
)
Delphi
public function Add(
    node: WebTreeViewNode
): System.Integer; virtual;
JScript
System.ComponentModel.DescriptionAttribute("Adds a new node to a WebTreeViewNodeBindingCollection instance  with WebTreeViewNodeBinding parameter as its name. ")
public function Add(
   node : WebTreeViewNode
) : System.int;
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Adds a new node to a WebTreeViewNodeBindingCollection instance  with WebTreeViewNodeBinding parameter as its name. ")]
public: virtual System.int Add(
   WebTreeViewNode* node
)
C++/CLI
[System.ComponentModel.DescriptionAttribute("Adds a new node to a WebTreeViewNodeBindingCollection instance  with WebTreeViewNodeBinding parameter as its name. ")]
public:
virtual System.int Add(
   WebTreeViewNode^ node
)

Parameters

node
The WebTreeViewNode object to be added.The specified node.

Return Value

The index of the newly added node.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeCollection Class
WebTreeViewNodeCollection Members
Overload List


Add(String) Method

[image]
Intersoft WebTreeView Documentation
Add(String) Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeCollection Class > Add Method : Add(String) Method

name
The unique Name value.Name of the new WebTreeViewNodeCollection instance.

Glossary Item Box

Creates a new node object in the collection and initializes its Name value. Adds a new node to a WebTreeViewNodeBindingCollection instance with String parameter as its name.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Adds a new node to a WebTreeViewNodeBindingCollection instance  with String parameter as its name. ")>
Public Overloads Function Add( _
   ByVal name As System.String _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeCollection
Dim name As System.String
Dim value As System.Integer

value = instance.Add(name)
C#
[System.ComponentModel.DescriptionAttribute("Adds a new node to a WebTreeViewNodeBindingCollection instance  with String parameter as its name. ")]
public System.int Add(
   System.string name
)
Delphi
public function Add(
    name: System.String
): System.Integer;
JScript
System.ComponentModel.DescriptionAttribute("Adds a new node to a WebTreeViewNodeBindingCollection instance  with String parameter as its name. ")
public function Add(
   name : System.String
) : System.int;
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Adds a new node to a WebTreeViewNodeBindingCollection instance  with String parameter as its name. ")]
public: System.int Add(
   System.string* name
)
C++/CLI
[System.ComponentModel.DescriptionAttribute("Adds a new node to a WebTreeViewNodeBindingCollection instance  with String parameter as its name. ")]
public:
System.int Add(
   System.String^ name
)

Parameters

name
The unique Name value.Name of the new WebTreeViewNodeCollection instance.

Return Value

The index of the newly-added node object within the collection.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeCollection Class
WebTreeViewNodeCollection Members
Overload List


Clear Method

[image]
Intersoft WebTreeView Documentation
Clear Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeCollection Class : Clear Method

Glossary Item Box

Removes all WebTreeViewNode objects from the collection. Removes node objects from the collection.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Removes node objects from the node binding collection.")>
Public Shadows Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeCollection

instance.Clear()
C#
[System.ComponentModel.DescriptionAttribute("Removes node objects from the node binding collection.")]
public new void Clear()
Delphi
public procedure Clear();
JScript
System.ComponentModel.DescriptionAttribute("Removes node objects from the node binding collection.")
public hide function Clear();
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Removes node objects from the node binding collection.")]
public: new void Clear();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Removes node objects from the node binding collection.")]
public:
new void Clear();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeCollection Class
WebTreeViewNodeCollection Members


GetEnumerator Method

[image]
Intersoft WebTreeView Documentation
GetEnumerator Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeCollection Class : GetEnumerator Method

Glossary Item Box

Returns an enumerator object for the collection. Returns an enumerator object for the collection.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("turns an enumerator object for the collection. ")>
Public Shadows Function GetEnumerator() As System.Collections.IEnumerator
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeCollection
Dim value As System.Collections.IEnumerator

value = instance.GetEnumerator()
C#
[System.ComponentModel.DescriptionAttribute("turns an enumerator object for the collection. ")]
public new System.Collections.IEnumerator GetEnumerator()
Delphi
public function GetEnumerator(): System.Collections.IEnumerator;
JScript
System.ComponentModel.DescriptionAttribute("turns an enumerator object for the collection. ")
public hide function GetEnumerator() : System.Collections.IEnumerator;
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("turns an enumerator object for the collection. ")]
public: new System.Collections.IEnumerator* GetEnumerator();
C++/CLI
[System.ComponentModel.DescriptionAttribute("turns an enumerator object for the collection. ")]
public:
new System.Collections.IEnumerator^ GetEnumerator();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeCollection Class
WebTreeViewNodeCollection Members


GetNamedItem Method

[image]
Intersoft WebTreeView Documentation
GetNamedItem Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeCollection Class : GetNamedItem Method

name
The name of the specified node.

Glossary Item Box

Property indexer for the collection. Uses the Name string to return an WebTreeViewNode object. Property indexer for the collection. Uses the Name string to return WebTreeView node object.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Property indexer for the collection. Uses the Name string to return WebTreeView node object. ")>
Public Function GetNamedItem( _
   ByVal name As System.String _
) As WebTreeViewNode
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeCollection
Dim name As System.String
Dim value As WebTreeViewNode

value = instance.GetNamedItem(name)
C#
[System.ComponentModel.DescriptionAttribute("Property indexer for the collection. Uses the Name string to return WebTreeView node object. ")]
public WebTreeViewNode GetNamedItem(
   System.string name
)
Delphi
public function GetNamedItem(
    name: System.String
): WebTreeViewNode;
JScript
System.ComponentModel.DescriptionAttribute("Property indexer for the collection. Uses the Name string to return WebTreeView node object. ")
public function GetNamedItem(
   name : System.String
) : WebTreeViewNode;
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Property indexer for the collection. Uses the Name string to return WebTreeView node object. ")]
public: WebTreeViewNode* GetNamedItem(
   System.string* name
)
C++/CLI
[System.ComponentModel.DescriptionAttribute("Property indexer for the collection. Uses the Name string to return WebTreeView node object. ")]
public:
WebTreeViewNode^ GetNamedItem(
   System.String^ name
)

Parameters

name
The name of the specified node.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeCollection Class
WebTreeViewNodeCollection Members


Insert Method

[image]
Intersoft WebTreeView Documentation
Insert Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeCollection Class : Insert Method

index
The position in the collection for the new WebTreeViewNode.The index of the specified node.
node
The WebTreeViewNode object to be inserted into the collection.The specified node.

Glossary Item Box

Inserts a WebTreeViewNode object into the WebTreeViewNode collection at a specified index. Inserts a new WebTreeView node into a WebTreeView collection at a specified index.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Inserts a new WebTreeView node into a WebTreeView collection at a specified index. ")>
Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal node As WebTreeViewNode _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeCollection
Dim index As System.Integer
Dim node As WebTreeViewNode

instance.Insert(index, node)
C#
[System.ComponentModel.DescriptionAttribute("Inserts a new WebTreeView node into a WebTreeView collection at a specified index. ")]
public void Insert(
   System.int index,
   WebTreeViewNode node
)
Delphi
public procedure Insert(
    index: System.Integer;
    node: WebTreeViewNode
);
JScript
System.ComponentModel.DescriptionAttribute("Inserts a new WebTreeView node into a WebTreeView collection at a specified index. ")
public function Insert(
   index : System.int,
   node : WebTreeViewNode
);
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Inserts a new WebTreeView node into a WebTreeView collection at a specified index. ")]
public: void Insert(
   System.int index,
   WebTreeViewNode* node
)
C++/CLI
[System.ComponentModel.DescriptionAttribute("Inserts a new WebTreeView node into a WebTreeView collection at a specified index. ")]
public:
void Insert(
   System.int index,
   WebTreeViewNode^ node
)

Parameters

index
The position in the collection for the new WebTreeViewNode.The index of the specified node.
node
The WebTreeViewNode object to be inserted into the collection.The specified node.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeCollection Class
WebTreeViewNodeCollection Members


OnInsertComplete Method

[image]
Intersoft WebTreeView Documentation
OnInsertComplete Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeCollection Class : OnInsertComplete Method

index
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnInsertComplete( _
   ByVal index As System.Integer, _
   ByVal value As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeCollection
Dim index As System.Integer
Dim value As System.Object

instance.OnInsertComplete(index, value)
C#
protected override void OnInsertComplete(
   System.int index,
   System.object value
)
Delphi
protected procedure OnInsertComplete(
    index: System.Integer;
    value: System.TObject
); override;
JScript
protected override function OnInsertComplete(
   index : System.int,
   value : System.Object
);
Managed Extensions for C++
protected: void OnInsertComplete(
   System.int index,
   System.Object* value
) override
C++/CLI
protected:
void OnInsertComplete(
   System.int index,
   System.Object^ value
) override

Parameters

index
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeCollection Class
WebTreeViewNodeCollection Members


Remove Method

[image]
Intersoft WebTreeView Documentation
Remove Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeCollection Class : Remove Method

node
The WebTreeViewNode object to be removed from the collection.The specified node.

Glossary Item Box

Removes the specified WebTreeViewNode object from the collection. Removes the specified WebTreeView node object from the collection.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Removes the specified WebTreeView node object from the collection. ")>
Public Sub Remove( _
   ByVal node As WebTreeViewNode _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeCollection
Dim node As WebTreeViewNode

instance.Remove(node)
C#
[System.ComponentModel.DescriptionAttribute("Removes the specified WebTreeView node object from the collection. ")]
public void Remove(
   WebTreeViewNode node
)
Delphi
public procedure Remove(
    node: WebTreeViewNode
);
JScript
System.ComponentModel.DescriptionAttribute("Removes the specified WebTreeView node object from the collection. ")
public function Remove(
   node : WebTreeViewNode
);
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Removes the specified WebTreeView node object from the collection. ")]
public: void Remove(
   WebTreeViewNode* node
)
C++/CLI
[System.ComponentModel.DescriptionAttribute("Removes the specified WebTreeView node object from the collection. ")]
public:
void Remove(
   WebTreeViewNode^ node
)

Parameters

node
The WebTreeViewNode object to be removed from the collection.The specified node.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeCollection Class
WebTreeViewNodeCollection Members


RemoveAt Method

[image]
Intersoft WebTreeView Documentation
RemoveAt Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeCollection Class : RemoveAt Method

index
The index of the WebTreeViewNode object to be removed.

Glossary Item Box

Removes the WebTreeViewNode object at the specified index from the collection.

Syntax

Visual Basic (Declaration)
Protected Shadows Sub RemoveAt( _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeCollection
Dim index As System.Integer

instance.RemoveAt(index)
C#
protected new void RemoveAt(
   System.int index
)
Delphi
protected procedure RemoveAt(
    index: System.Integer
);
JScript
protected hide function RemoveAt(
   index : System.int
);
Managed Extensions for C++
protected: new void RemoveAt(
   System.int index
)
C++/CLI
protected:
new void RemoveAt(
   System.int index
)

Parameters

index
The index of the WebTreeViewNode object to be removed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeCollection Class
WebTreeViewNodeCollection Members


WebTreeViewNodeCollection Class Properties

[image]
Intersoft WebTreeView Documentation
WebTreeViewNodeCollection Class Properties
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace : WebTreeViewNodeCollection Class

Glossary Item Box

For a list of all members of this type, see WebTreeViewNodeCollection members.

Public Properties

 | Name | Description
Public Property | All | (Inherited from ISNet.WebUI.ISCollectionBase)
Public Property | Capacity | (Inherited from System.Collections.CollectionBase)
Public Property | Count | (Inherited from System.Collections.CollectionBase)
Public Property | IsReadOnly | Overridden. Returns a Boolean value indicating whether the collection is read-only. Returns a Boolean value indicating whether the collection is read-only.
Public Property | Item | Property indexer for the collection. Property indexer for the collection.
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase)
Top

Protected Properties

 | Name | Description
Protected Property | InnerList | (Inherited from System.Collections.CollectionBase)
Protected Property | List | (Inherited from System.Collections.CollectionBase)
Top

See Also

Reference

WebTreeViewNodeCollection Class
ISNet.WebUI.WebTreeView Namespace


IsReadOnly Property

[image]
Intersoft WebTreeView Documentation
IsReadOnly Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeCollection Class : IsReadOnly Property

Glossary Item Box

Returns a Boolean value indicating whether the collection is read-only. Returns a Boolean value indicating whether the collection is read-only.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Returns a Boolean value indicating whether the collection is read-only. ")>
Public Overrides ReadOnly Property IsReadOnly As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeCollection
Dim value As System.Boolean

value = instance.IsReadOnly
C#
[System.ComponentModel.DescriptionAttribute("Returns a Boolean value indicating whether the collection is read-only. ")]
public override System.bool IsReadOnly {get;}
Delphi
public read-only property IsReadOnly: System.Boolean; override;
JScript
System.ComponentModel.DescriptionAttribute("Returns a Boolean value indicating whether the collection is read-only. ")
public override function get IsReadOnly : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Returns a Boolean value indicating whether the collection is read-only. ")]
public: __property System.bool get_IsReadOnly() override;
C++/CLI
[System.ComponentModel.DescriptionAttribute("Returns a Boolean value indicating whether the collection is read-only. ")]
public:
property System.bool IsReadOnly {
   System.bool get() override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeCollection Class
WebTreeViewNodeCollection Members


Item Property

[image]
Intersoft WebTreeView Documentation
Item Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeCollection Class : Item Property

index

Glossary Item Box

Property indexer for the collection. Property indexer for the collection.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Property indexer for the collection. ")>
Public Default Property Item( _
   ByVal index As System.Integer _
) As WebTreeViewNode
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeCollection
Dim index As System.Integer
Dim value As WebTreeViewNode

instance.Item(index) = value

value = instance.Item(index)
C#
[System.ComponentModel.DescriptionAttribute("Property indexer for the collection. ")]
public WebTreeViewNode this[
   System.int index
]; {get; set;}
Delphi
public  this: : WebTreeViewNode;[
    index: System.Integer
]; read-write
JScript
System.ComponentModel.DescriptionAttribute("Property indexer for the collection. ")
public  this[
   index : System.int
] get,set : WebTreeViewNode
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Property indexer for the collection. ")]
public: __property WebTreeViewNode* get_Item   System.int index
;
public: __property void set_Item   System.int index,
   WebTreeViewNode* value
;
C++/CLI
[System.ComponentModel.DescriptionAttribute("Property indexer for the collection. ")]
public:
property WebTreeViewNode^ default [int] {
   WebTreeViewNode^ get(System.int index);
   void set (System.int index, WebTreeViewNode^ value);
}

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeCollection Class
WebTreeViewNodeCollection Members


WebTreeViewNodeEditEventArgs Class

[image]
Intersoft WebTreeView Documentation
WebTreeViewNodeEditEventArgs Class
Members See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace : WebTreeViewNodeEditEventArgs Class

Glossary Item Box

Provides data for WebTreeView's node editing event.

Object Model

WebTreeViewNodeEditEventArgs Class

Syntax

Visual Basic (Declaration)
<System.ComponentModel.ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")>
<System.ComponentModel.DescriptionAttribute("Provides data for WebTreeView's node edit related event.")>
Public Class WebTreeViewNodeEditEventArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeEditEventArgs
C#
[System.ComponentModel.ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
[System.ComponentModel.DescriptionAttribute("Provides data for WebTreeView's node edit related event.")]
public class WebTreeViewNodeEditEventArgs : System.EventArgs
Delphi
public class WebTreeViewNodeEditEventArgs = class(System.EventArgs)
JScript
System.ComponentModel.ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")
System.ComponentModel.DescriptionAttribute("Provides data for WebTreeView's node edit related event.")
public class WebTreeViewNodeEditEventArgs extends System.EventArgs
Managed Extensions for C++
[System.ComponentModel.ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
[System.ComponentModel.DescriptionAttribute("Provides data for WebTreeView's node edit related event.")]
public __gc class WebTreeViewNodeEditEventArgs : public System.EventArgs
C++/CLI
[System.ComponentModel.ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
[System.ComponentModel.DescriptionAttribute("Provides data for WebTreeView's node edit related event.")]
public ref class WebTreeViewNodeEditEventArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
ISNet.WebUI.WebTreeView.WebTreeViewNodeEditEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeEditEventArgs Members
ISNet.WebUI.WebTreeView Namespace


WebTreeViewNodeEditEventArgs Class Members

[image]
Intersoft WebTreeView Documentation
WebTreeViewNodeEditEventArgs Class Members
See Also Properties Send Feedback
ISNet.WebUI.WebTreeView Namespace : WebTreeViewNodeEditEventArgs Class

Glossary Item Box

The following tables list the members exposed by WebTreeViewNodeEditEventArgs.

Public Constructors

 | Name | Description
Public Constructor | WebTreeViewNodeEditEventArgs Constructor | Initializes a new instance of WebTreeViewNodeEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | Command | Gets command type.Determines the type of operation, such as "NodeCopy", "NodeCollapse", "Initialize", etc.
Public Property | Node | Gets operated node.The specified node.
Public Property | OldText | Gets old text.The specified node's old text that wants to be edited.
Top

See Also

Reference

WebTreeViewNodeEditEventArgs Class
ISNet.WebUI.WebTreeView Namespace


WebTreeViewNodeEditEventArgs Constructor

[image]
Intersoft WebTreeView Documentation
WebTreeViewNodeEditEventArgs Constructor
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeEditEventArgs Class : WebTreeViewNodeEditEventArgs Constructor

command
node
oldText

Glossary Item Box

Initializes a new instance of WebTreeViewNodeEventArgs class.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebTreeViewNodeEditEventArgs class. ")>
Public Function New( _
   ByVal command As System.String, _
   ByVal node As WebTreeViewNode, _
   ByVal oldText As System.String _
)
Visual Basic (Usage) Copy Code
Dim command As System.String
Dim node As WebTreeViewNode
Dim oldText As System.String

Dim instance As New WebTreeViewNodeEditEventArgs(command, node, oldText)
C#
[System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebTreeViewNodeEditEventArgs class. ")]
public WebTreeViewNodeEditEventArgs(
   System.string command,
   WebTreeViewNode node,
   System.string oldText
)
Delphi
public WebTreeViewNodeEditEventArgs(
    command: System.String;
    node: WebTreeViewNode;
    oldText: System.String
);
JScript
System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebTreeViewNodeEditEventArgs class. ")
public function WebTreeViewNodeEditEventArgs(
   command : System.String,
   node : WebTreeViewNode,
   oldText : System.String
);
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebTreeViewNodeEditEventArgs class. ")]
public: WebTreeViewNodeEditEventArgs(
   System.string* command,
   WebTreeViewNode* node,
   System.string* oldText
)
C++/CLI
[System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebTreeViewNodeEditEventArgs class. ")]
public:
WebTreeViewNodeEditEventArgs(
   System.String^ command,
   WebTreeViewNode^ node,
   System.String^ oldText
)

Parameters

command
node
oldText

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeEditEventArgs Class
WebTreeViewNodeEditEventArgs Members


WebTreeViewNodeEditEventArgs Class Properties

[image]
Intersoft WebTreeView Documentation
WebTreeViewNodeEditEventArgs Class Properties
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace : WebTreeViewNodeEditEventArgs Class

Glossary Item Box

For a list of all members of this type, see WebTreeViewNodeEditEventArgs members.

Public Properties

 | Name | Description
Public Property | Command | Gets command type.Determines the type of operation, such as "NodeCopy", "NodeCollapse", "Initialize", etc.
Public Property | Node | Gets operated node.The specified node.
Public Property | OldText | Gets old text.The specified node's old text that wants to be edited.
Top

See Also

Reference

WebTreeViewNodeEditEventArgs Class
ISNet.WebUI.WebTreeView Namespace


Command Property

[image]
Intersoft WebTreeView Documentation
Command Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeEditEventArgs Class : Command Property

Glossary Item Box

Gets command type.Determines the type of operation, such as "NodeCopy", "NodeCollapse", "Initialize", etc.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets command type.")>
Public ReadOnly Property Command As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeEditEventArgs
Dim value As System.String

value = instance.Command
C#
[System.ComponentModel.DescriptionAttribute("Gets command type.")]
public System.string Command {get;}
Delphi
public read-only property Command: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Gets command type.")
public function get Command : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets command type.")]
public: __property System.string* get_Command();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets command type.")]
public:
property System.String^ Command {
   System.String^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeEditEventArgs Class
WebTreeViewNodeEditEventArgs Members


Node Property

[image]
Intersoft WebTreeView Documentation
Node Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeEditEventArgs Class : Node Property

Glossary Item Box

Gets operated node.The specified node.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets operated node.")>
Public ReadOnly Property Node As WebTreeViewNode
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeEditEventArgs
Dim value As WebTreeViewNode

value = instance.Node
C#
[System.ComponentModel.DescriptionAttribute("Gets operated node.")]
public WebTreeViewNode Node {get;}
Delphi
public read-only property Node: WebTreeViewNode;
JScript
System.ComponentModel.DescriptionAttribute("Gets operated node.")
public function get Node : WebTreeViewNode
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets operated node.")]
public: __property WebTreeViewNode* get_Node();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets operated node.")]
public:
property WebTreeViewNode^ Node {
   WebTreeViewNode^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeEditEventArgs Class
WebTreeViewNodeEditEventArgs Members


OldText Property

[image]
Intersoft WebTreeView Documentation
OldText Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeEditEventArgs Class : OldText Property

Glossary Item Box

Gets old text.The specified node's old text that wants to be edited.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets old text.")>
Public ReadOnly Property OldText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeEditEventArgs
Dim value As System.String

value = instance.OldText
C#
[System.ComponentModel.DescriptionAttribute("Gets old text.")]
public System.string OldText {get;}
Delphi
public read-only property OldText: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Gets old text.")
public function get OldText : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets old text.")]
public: __property System.string* get_OldText();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets old text.")]
public:
property System.String^ OldText {
   System.String^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeEditEventArgs Class
WebTreeViewNodeEditEventArgs Members


WebTreeViewNodeEventArgs Class

[image]
Intersoft WebTreeView Documentation
WebTreeViewNodeEventArgs Class
Members See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace : WebTreeViewNodeEventArgs Class

Glossary Item Box

Provides data for WebTreeView's node related event.

Object Model

WebTreeViewNodeEventArgs Class

Syntax

Visual Basic (Declaration)
<System.ComponentModel.ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")>
<System.ComponentModel.DescriptionAttribute("Provides data for WebTreeView's node related event.")>
Public Class WebTreeViewNodeEventArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeEventArgs
C#
[System.ComponentModel.ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
[System.ComponentModel.DescriptionAttribute("Provides data for WebTreeView's node related event.")]
public class WebTreeViewNodeEventArgs : System.EventArgs
Delphi
public class WebTreeViewNodeEventArgs = class(System.EventArgs)
JScript
System.ComponentModel.ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")
System.ComponentModel.DescriptionAttribute("Provides data for WebTreeView's node related event.")
public class WebTreeViewNodeEventArgs extends System.EventArgs
Managed Extensions for C++
[System.ComponentModel.ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
[System.ComponentModel.DescriptionAttribute("Provides data for WebTreeView's node related event.")]
public __gc class WebTreeViewNodeEventArgs : public System.EventArgs
C++/CLI
[System.ComponentModel.ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
[System.ComponentModel.DescriptionAttribute("Provides data for WebTreeView's node related event.")]
public ref class WebTreeViewNodeEventArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
ISNet.WebUI.WebTreeView.WebTreeViewNodeEventArgs
ISNet.WebUI.WebTreeView.WebTreeViewDragDropEventArgs
ISNet.WebUI.WebTreeView.WebTreeViewNodeMoveEventArgs
ISNet.WebUI.WebTreeView.WebTreeViewNodeRenameEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeEventArgs Members
ISNet.WebUI.WebTreeView Namespace


WebTreeViewNodeEventArgs Class Members

[image]
Intersoft WebTreeView Documentation
WebTreeViewNodeEventArgs Class Members
See Also Properties Send Feedback
ISNet.WebUI.WebTreeView Namespace : WebTreeViewNodeEventArgs Class

Glossary Item Box

The following tables list the members exposed by WebTreeViewNodeEventArgs.

Public Constructors

 | Name | Description
Public Constructor | WebTreeViewNodeEventArgs Constructor | Initializes a new instance of WebTreeViewNodeEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | Command | Gets command of WebTreeViewNode event arguments.Determines the type of operation, such as "NodeCopy", "NodeCollapse", "Initialize", etc.
Public Property | Node | Gets operated node.The specified node.
Top

See Also

Reference

WebTreeViewNodeEventArgs Class
ISNet.WebUI.WebTreeView Namespace


WebTreeViewNodeEventArgs Constructor

[image]
Intersoft WebTreeView Documentation
WebTreeViewNodeEventArgs Constructor
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeEventArgs Class : WebTreeViewNodeEventArgs Constructor

command
Determines the type of operation, such as "NodeCopy", "NodeCollapse", "Initialize", etc.
node
The specified node.

Glossary Item Box

Initializes a new instance of WebTreeViewNodeEventArgs class.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebTreeViewNodeEventArgs class. ")>
Public Function New( _
   ByVal command As System.String, _
   ByVal node As WebTreeViewNode _
)
Visual Basic (Usage) Copy Code
Dim command As System.String
Dim node As WebTreeViewNode

Dim instance As New WebTreeViewNodeEventArgs(command, node)
C#
[System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebTreeViewNodeEventArgs class. ")]
public WebTreeViewNodeEventArgs(
   System.string command,
   WebTreeViewNode node
)
Delphi
public WebTreeViewNodeEventArgs(
    command: System.String;
    node: WebTreeViewNode
);
JScript
System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebTreeViewNodeEventArgs class. ")
public function WebTreeViewNodeEventArgs(
   command : System.String,
   node : WebTreeViewNode
);
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebTreeViewNodeEventArgs class. ")]
public: WebTreeViewNodeEventArgs(
   System.string* command,
   WebTreeViewNode* node
)
C++/CLI
[System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebTreeViewNodeEventArgs class. ")]
public:
WebTreeViewNodeEventArgs(
   System.String^ command,
   WebTreeViewNode^ node
)

Parameters

command
Determines the type of operation, such as "NodeCopy", "NodeCollapse", "Initialize", etc.
node
The specified node.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeEventArgs Class
WebTreeViewNodeEventArgs Members


WebTreeViewNodeEventArgs Class Properties

[image]
Intersoft WebTreeView Documentation
WebTreeViewNodeEventArgs Class Properties
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace : WebTreeViewNodeEventArgs Class

Glossary Item Box

For a list of all members of this type, see WebTreeViewNodeEventArgs members.

Public Properties

 | Name | Description
Public Property | Command | Gets command of WebTreeViewNode event arguments.Determines the type of operation, such as "NodeCopy", "NodeCollapse", "Initialize", etc.
Public Property | Node | Gets operated node.The specified node.
Top

See Also

Reference

WebTreeViewNodeEventArgs Class
ISNet.WebUI.WebTreeView Namespace


Command Property

[image]
Intersoft WebTreeView Documentation
Command Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeEventArgs Class : Command Property

Glossary Item Box

Gets command of WebTreeViewNode event arguments.Determines the type of operation, such as "NodeCopy", "NodeCollapse", "Initialize", etc.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets command of WebTreeViewNode event arguments.")>
Public ReadOnly Property Command As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeEventArgs
Dim value As System.String

value = instance.Command
C#
[System.ComponentModel.DescriptionAttribute("Gets command of WebTreeViewNode event arguments.")]
public System.string Command {get;}
Delphi
public read-only property Command: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Gets command of WebTreeViewNode event arguments.")
public function get Command : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets command of WebTreeViewNode event arguments.")]
public: __property System.string* get_Command();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets command of WebTreeViewNode event arguments.")]
public:
property System.String^ Command {
   System.String^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeEventArgs Class
WebTreeViewNodeEventArgs Members


Node Property

[image]
Intersoft WebTreeView Documentation
Node Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeEventArgs Class : Node Property

Glossary Item Box

Gets operated node.The specified node.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets operated node.")>
Public ReadOnly Property Node As WebTreeViewNode
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeEventArgs
Dim value As WebTreeViewNode

value = instance.Node
C#
[System.ComponentModel.DescriptionAttribute("Gets operated node.")]
public WebTreeViewNode Node {get;}
Delphi
public read-only property Node: WebTreeViewNode;
JScript
System.ComponentModel.DescriptionAttribute("Gets operated node.")
public function get Node : WebTreeViewNode
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets operated node.")]
public: __property WebTreeViewNode* get_Node();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets operated node.")]
public:
property WebTreeViewNode^ Node {
   WebTreeViewNode^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeEventArgs Class
WebTreeViewNodeEventArgs Members


WebTreeViewNodeMoveEventArgs Class

[image]
Intersoft WebTreeView Documentation
WebTreeViewNodeMoveEventArgs Class
Members See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace : WebTreeViewNodeMoveEventArgs Class

Glossary Item Box

Provides data for WebTreeView's node moving event.

Object Model

WebTreeViewNodeMoveEventArgs Class

Syntax

Visual Basic (Declaration)
<System.ComponentModel.ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")>
<System.ComponentModel.DescriptionAttribute("Provides data for WebTreeView's node moving event.")>
Public Class WebTreeViewNodeMoveEventArgs
   Inherits WebTreeViewNodeEventArgs
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeMoveEventArgs
C#
[System.ComponentModel.ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
[System.ComponentModel.DescriptionAttribute("Provides data for WebTreeView's node moving event.")]
public class WebTreeViewNodeMoveEventArgs : WebTreeViewNodeEventArgs
Delphi
public class WebTreeViewNodeMoveEventArgs = class(WebTreeViewNodeEventArgs)
JScript
System.ComponentModel.ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")
System.ComponentModel.DescriptionAttribute("Provides data for WebTreeView's node moving event.")
public class WebTreeViewNodeMoveEventArgs extends WebTreeViewNodeEventArgs
Managed Extensions for C++
[System.ComponentModel.ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
[System.ComponentModel.DescriptionAttribute("Provides data for WebTreeView's node moving event.")]
public __gc class WebTreeViewNodeMoveEventArgs : public WebTreeViewNodeEventArgs
C++/CLI
[System.ComponentModel.ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
[System.ComponentModel.DescriptionAttribute("Provides data for WebTreeView's node moving event.")]
public ref class WebTreeViewNodeMoveEventArgs : public WebTreeViewNodeEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
ISNet.WebUI.WebTreeView.WebTreeViewNodeEventArgs
ISNet.WebUI.WebTreeView.WebTreeViewNodeMoveEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeMoveEventArgs Members
ISNet.WebUI.WebTreeView Namespace


WebTreeViewNodeMoveEventArgs Class Members

[image]
Intersoft WebTreeView Documentation
WebTreeViewNodeMoveEventArgs Class Members
See Also Properties Send Feedback
ISNet.WebUI.WebTreeView Namespace : WebTreeViewNodeMoveEventArgs Class

Glossary Item Box

The following tables list the members exposed by WebTreeViewNodeMoveEventArgs.

Public Constructors

 | Name | Description
Public Constructor | WebTreeViewNodeMoveEventArgs Constructor | Initializes a new instance of WebTreeViewNodeMoveEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | Command | Gets command of WebTreeViewNode event arguments.Determines the type of operation, such as "NodeCopy", "NodeCollapse", "Initialize", etc. (Inherited from ISNet.WebUI.WebTreeView.WebTreeViewNodeEventArgs)
Public Property | DestinationNode | Gets destination node of node move operation.
Public Property | InsertionMode | Gets insertion mode of node move operation.
Public Property | MoveType | Gets move type of node move operation.
Public Property | Node | Gets operated node.The specified node. (Inherited from ISNet.WebUI.WebTreeView.WebTreeViewNodeEventArgs)
Public Property | SourceNode | Gets source node of node move operation.
Top

See Also

Reference

WebTreeViewNodeMoveEventArgs Class
ISNet.WebUI.WebTreeView Namespace


WebTreeViewNodeMoveEventArgs Constructor

[image]
Intersoft WebTreeView Documentation
WebTreeViewNodeMoveEventArgs Constructor
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeMoveEventArgs Class : WebTreeViewNodeMoveEventArgs Constructor

sourceNode
destinationNode
moveType
insertionMode

Glossary Item Box

Initializes a new instance of WebTreeViewNodeMoveEventArgs class.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebTreeViewNodeMoveEventArgs class.")>
Public Function New( _
   ByVal sourceNode As WebTreeViewNode, _
   ByVal destinationNode As WebTreeViewNode, _
   ByVal moveType As NodeMoveType, _
   ByVal insertionMode As NodeMoveInsertionMode _
)
Visual Basic (Usage) Copy Code
Dim sourceNode As WebTreeViewNode
Dim destinationNode As WebTreeViewNode
Dim moveType As NodeMoveType
Dim insertionMode As NodeMoveInsertionMode

Dim instance As New WebTreeViewNodeMoveEventArgs(sourceNode, destinationNode, moveType, insertionMode)
C#
[System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebTreeViewNodeMoveEventArgs class.")]
public WebTreeViewNodeMoveEventArgs(
   WebTreeViewNode sourceNode,
   WebTreeViewNode destinationNode,
   NodeMoveType moveType,
   NodeMoveInsertionMode insertionMode
)
Delphi
public WebTreeViewNodeMoveEventArgs(
    sourceNode: WebTreeViewNode;
    destinationNode: WebTreeViewNode;
    moveType: NodeMoveType;
    insertionMode: NodeMoveInsertionMode
);
JScript
System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebTreeViewNodeMoveEventArgs class.")
public function WebTreeViewNodeMoveEventArgs(
   sourceNode : WebTreeViewNode,
   destinationNode : WebTreeViewNode,
   moveType : NodeMoveType,
   insertionMode : NodeMoveInsertionMode
);
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebTreeViewNodeMoveEventArgs class.")]
public: WebTreeViewNodeMoveEventArgs(
   WebTreeViewNode* sourceNode,
   WebTreeViewNode* destinationNode,
   NodeMoveType moveType,
   NodeMoveInsertionMode insertionMode
)
C++/CLI
[System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebTreeViewNodeMoveEventArgs class.")]
public:
WebTreeViewNodeMoveEventArgs(
   WebTreeViewNode^ sourceNode,
   WebTreeViewNode^ destinationNode,
   NodeMoveType moveType,
   NodeMoveInsertionMode insertionMode
)

Parameters

sourceNode
destinationNode
moveType
insertionMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeMoveEventArgs Class
WebTreeViewNodeMoveEventArgs Members


WebTreeViewNodeMoveEventArgs Class Properties

[image]
Intersoft WebTreeView Documentation
WebTreeViewNodeMoveEventArgs Class Properties
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace : WebTreeViewNodeMoveEventArgs Class

Glossary Item Box

For a list of all members of this type, see WebTreeViewNodeMoveEventArgs members.

Public Properties

 | Name | Description
Public Property | Command | Gets command of WebTreeViewNode event arguments.Determines the type of operation, such as "NodeCopy", "NodeCollapse", "Initialize", etc. (Inherited from ISNet.WebUI.WebTreeView.WebTreeViewNodeEventArgs)
Public Property | DestinationNode | Gets destination node of node move operation.
Public Property | InsertionMode | Gets insertion mode of node move operation.
Public Property | MoveType | Gets move type of node move operation.
Public Property | Node | Gets operated node.The specified node. (Inherited from ISNet.WebUI.WebTreeView.WebTreeViewNodeEventArgs)
Public Property | SourceNode | Gets source node of node move operation.
Top

See Also

Reference

WebTreeViewNodeMoveEventArgs Class
ISNet.WebUI.WebTreeView Namespace


DestinationNode Property

[image]
Intersoft WebTreeView Documentation
DestinationNode Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeMoveEventArgs Class : DestinationNode Property

Glossary Item Box

Gets destination node of node move operation.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets destination node of node move operation.")>
Public ReadOnly Property DestinationNode As WebTreeViewNode
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeMoveEventArgs
Dim value As WebTreeViewNode

value = instance.DestinationNode
C#
[System.ComponentModel.DescriptionAttribute("Gets destination node of node move operation.")]
public WebTreeViewNode DestinationNode {get;}
Delphi
public read-only property DestinationNode: WebTreeViewNode;
JScript
System.ComponentModel.DescriptionAttribute("Gets destination node of node move operation.")
public function get DestinationNode : WebTreeViewNode
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets destination node of node move operation.")]
public: __property WebTreeViewNode* get_DestinationNode();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets destination node of node move operation.")]
public:
property WebTreeViewNode^ DestinationNode {
   WebTreeViewNode^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeMoveEventArgs Class
WebTreeViewNodeMoveEventArgs Members


InsertionMode Property

[image]
Intersoft WebTreeView Documentation
InsertionMode Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeMoveEventArgs Class : InsertionMode Property

Glossary Item Box

Gets insertion mode of node move operation.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets insertion mode of node move operation.")>
Public ReadOnly Property InsertionMode As NodeMoveInsertionMode
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeMoveEventArgs
Dim value As NodeMoveInsertionMode

value = instance.InsertionMode
C#
[System.ComponentModel.DescriptionAttribute("Gets insertion mode of node move operation.")]
public NodeMoveInsertionMode InsertionMode {get;}
Delphi
public read-only property InsertionMode: NodeMoveInsertionMode;
JScript
System.ComponentModel.DescriptionAttribute("Gets insertion mode of node move operation.")
public function get InsertionMode : NodeMoveInsertionMode
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets insertion mode of node move operation.")]
public: __property NodeMoveInsertionMode get_InsertionMode();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets insertion mode of node move operation.")]
public:
property NodeMoveInsertionMode InsertionMode {
   NodeMoveInsertionMode get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeMoveEventArgs Class
WebTreeViewNodeMoveEventArgs Members


MoveType Property

[image]
Intersoft WebTreeView Documentation
MoveType Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeMoveEventArgs Class : MoveType Property

Glossary Item Box

Gets move type of node move operation.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets move type of node move operation.")>
Public ReadOnly Property MoveType As NodeMoveType
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeMoveEventArgs
Dim value As NodeMoveType

value = instance.MoveType
C#
[System.ComponentModel.DescriptionAttribute("Gets move type of node move operation.")]
public NodeMoveType MoveType {get;}
Delphi
public read-only property MoveType: NodeMoveType;
JScript
System.ComponentModel.DescriptionAttribute("Gets move type of node move operation.")
public function get MoveType : NodeMoveType
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets move type of node move operation.")]
public: __property NodeMoveType get_MoveType();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets move type of node move operation.")]
public:
property NodeMoveType MoveType {
   NodeMoveType get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeMoveEventArgs Class
WebTreeViewNodeMoveEventArgs Members


SourceNode Property

[image]
Intersoft WebTreeView Documentation
SourceNode Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeMoveEventArgs Class : SourceNode Property

Glossary Item Box

Gets source node of node move operation.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets source node of node move operation.")>
Public ReadOnly Property SourceNode As WebTreeViewNode
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeMoveEventArgs
Dim value As WebTreeViewNode

value = instance.SourceNode
C#
[System.ComponentModel.DescriptionAttribute("Gets source node of node move operation.")]
public WebTreeViewNode SourceNode {get;}
Delphi
public read-only property SourceNode: WebTreeViewNode;
JScript
System.ComponentModel.DescriptionAttribute("Gets source node of node move operation.")
public function get SourceNode : WebTreeViewNode
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets source node of node move operation.")]
public: __property WebTreeViewNode* get_SourceNode();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets source node of node move operation.")]
public:
property WebTreeViewNode^ SourceNode {
   WebTreeViewNode^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeMoveEventArgs Class
WebTreeViewNodeMoveEventArgs Members


WebTreeViewNodeRenameEventArgs Class

[image]
Intersoft WebTreeView Documentation
WebTreeViewNodeRenameEventArgs Class
Members See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace : WebTreeViewNodeRenameEventArgs Class

Glossary Item Box

Provides data for WebTreeView's node renaming event.

Object Model

WebTreeViewNodeRenameEventArgs Class

Syntax

Visual Basic (Declaration)
<System.ComponentModel.ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")>
<System.ComponentModel.DescriptionAttribute("Provides data for WebTreeView's node renaming event.")>
Public Class WebTreeViewNodeRenameEventArgs
   Inherits WebTreeViewNodeEventArgs
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeRenameEventArgs
C#
[System.ComponentModel.ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
[System.ComponentModel.DescriptionAttribute("Provides data for WebTreeView's node renaming event.")]
public class WebTreeViewNodeRenameEventArgs : WebTreeViewNodeEventArgs
Delphi
public class WebTreeViewNodeRenameEventArgs = class(WebTreeViewNodeEventArgs)
JScript
System.ComponentModel.ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")
System.ComponentModel.DescriptionAttribute("Provides data for WebTreeView's node renaming event.")
public class WebTreeViewNodeRenameEventArgs extends WebTreeViewNodeEventArgs
Managed Extensions for C++
[System.ComponentModel.ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
[System.ComponentModel.DescriptionAttribute("Provides data for WebTreeView's node renaming event.")]
public __gc class WebTreeViewNodeRenameEventArgs : public WebTreeViewNodeEventArgs
C++/CLI
[System.ComponentModel.ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
[System.ComponentModel.DescriptionAttribute("Provides data for WebTreeView's node renaming event.")]
public ref class WebTreeViewNodeRenameEventArgs : public WebTreeViewNodeEventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
ISNet.WebUI.WebTreeView.WebTreeViewNodeEventArgs
ISNet.WebUI.WebTreeView.WebTreeViewNodeRenameEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeRenameEventArgs Members
ISNet.WebUI.WebTreeView Namespace


WebTreeViewNodeRenameEventArgs Class Members

[image]
Intersoft WebTreeView Documentation
WebTreeViewNodeRenameEventArgs Class Members
See Also Properties Send Feedback
ISNet.WebUI.WebTreeView Namespace : WebTreeViewNodeRenameEventArgs Class

Glossary Item Box

The following tables list the members exposed by WebTreeViewNodeRenameEventArgs.

Public Constructors

 | Name | Description
Public Constructor | WebTreeViewNodeRenameEventArgs Constructor | Initializes a new instance of WebTreeViewNodeRenameEventArgs class.
Top

Public Properties

 | Name | Description
Public Property | Command | Gets command of WebTreeViewNode event arguments.Determines the type of operation, such as "NodeCopy", "NodeCollapse", "Initialize", etc. (Inherited from ISNet.WebUI.WebTreeView.WebTreeViewNodeEventArgs)
Public Property | Node | Gets operated node.The specified node. (Inherited from ISNet.WebUI.WebTreeView.WebTreeViewNodeEventArgs)
Public Property | OldText | Gets old text of node.The specified node's old text that wants to be replaced.
Top

See Also

Reference

WebTreeViewNodeRenameEventArgs Class
ISNet.WebUI.WebTreeView Namespace


WebTreeViewNodeRenameEventArgs Constructor

[image]
Intersoft WebTreeView Documentation
WebTreeViewNodeRenameEventArgs Constructor
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeRenameEventArgs Class : WebTreeViewNodeRenameEventArgs Constructor

oldText
The specified node's old text that wants to be replaced.
command
Determines the type of operation, such as "NodeCopy", "NodeCollapse", "Initialize", etc.
node
The specified node.

Glossary Item Box

Initializes a new instance of WebTreeViewNodeRenameEventArgs class.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebTreeViewNodeRenameEventArgs class.")>
Public Function New( _
   ByVal oldText As System.String, _
   ByVal command As System.String, _
   ByVal node As WebTreeViewNode _
)
Visual Basic (Usage) Copy Code
Dim oldText As System.String
Dim command As System.String
Dim node As WebTreeViewNode

Dim instance As New WebTreeViewNodeRenameEventArgs(oldText, command, node)
C#
[System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebTreeViewNodeRenameEventArgs class.")]
public WebTreeViewNodeRenameEventArgs(
   System.string oldText,
   System.string command,
   WebTreeViewNode node
)
Delphi
public WebTreeViewNodeRenameEventArgs(
    oldText: System.String;
    command: System.String;
    node: WebTreeViewNode
);
JScript
System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebTreeViewNodeRenameEventArgs class.")
public function WebTreeViewNodeRenameEventArgs(
   oldText : System.String,
   command : System.String,
   node : WebTreeViewNode
);
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebTreeViewNodeRenameEventArgs class.")]
public: WebTreeViewNodeRenameEventArgs(
   System.string* oldText,
   System.string* command,
   WebTreeViewNode* node
)
C++/CLI
[System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebTreeViewNodeRenameEventArgs class.")]
public:
WebTreeViewNodeRenameEventArgs(
   System.String^ oldText,
   System.String^ command,
   WebTreeViewNode^ node
)

Parameters

oldText
The specified node's old text that wants to be replaced.
command
Determines the type of operation, such as "NodeCopy", "NodeCollapse", "Initialize", etc.
node
The specified node.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeRenameEventArgs Class
WebTreeViewNodeRenameEventArgs Members


WebTreeViewNodeRenameEventArgs Class Properties

[image]
Intersoft WebTreeView Documentation
WebTreeViewNodeRenameEventArgs Class Properties
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace : WebTreeViewNodeRenameEventArgs Class

Glossary Item Box

For a list of all members of this type, see WebTreeViewNodeRenameEventArgs members.

Public Properties

 | Name | Description
Public Property | Command | Gets command of WebTreeViewNode event arguments.Determines the type of operation, such as "NodeCopy", "NodeCollapse", "Initialize", etc. (Inherited from ISNet.WebUI.WebTreeView.WebTreeViewNodeEventArgs)
Public Property | Node | Gets operated node.The specified node. (Inherited from ISNet.WebUI.WebTreeView.WebTreeViewNodeEventArgs)
Public Property | OldText | Gets old text of node.The specified node's old text that wants to be replaced.
Top

See Also

Reference

WebTreeViewNodeRenameEventArgs Class
ISNet.WebUI.WebTreeView Namespace


OldText Property

[image]
Intersoft WebTreeView Documentation
OldText Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeRenameEventArgs Class : OldText Property

Glossary Item Box

Gets old text of node.The specified node's old text that wants to be replaced.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets old text of node.")>
Public ReadOnly Property OldText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeRenameEventArgs
Dim value As System.String

value = instance.OldText
C#
[System.ComponentModel.DescriptionAttribute("Gets old text of node.")]
public System.string OldText {get;}
Delphi
public read-only property OldText: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Gets old text of node.")
public function get OldText : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets old text of node.")]
public: __property System.string* get_OldText();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets old text of node.")]
public:
property System.String^ OldText {
   System.String^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeRenameEventArgs Class
WebTreeViewNodeRenameEventArgs Members


WebTreeViewNodeSettings Class

[image]
Intersoft WebTreeView Documentation
WebTreeViewNodeSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace : WebTreeViewNodeSettings Class

Glossary Item Box

A collection of WebTreeView's node properties.

Object Model

WebTreeViewNodeSettings Class

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("A collection of WebTreeView's node settings.")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebTreeViewNodeSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeSettings
C#
[System.ComponentModel.DescriptionAttribute("A collection of WebTreeView's node settings.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebTreeViewNodeSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebTreeViewNodeSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.ComponentModel.DescriptionAttribute("A collection of WebTreeView's node settings.")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebTreeViewNodeSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("A collection of WebTreeView's node settings.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebTreeViewNodeSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.ComponentModel.DescriptionAttribute("A collection of WebTreeView's node settings.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebTreeViewNodeSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebTreeView.WebTreeViewNodeSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeSettings Members
ISNet.WebUI.WebTreeView Namespace


WebTreeViewNodeSettings Class Members

[image]
Intersoft WebTreeView Documentation
WebTreeViewNodeSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebTreeView Namespace : WebTreeViewNodeSettings Class

Glossary Item Box

The following tables list the members exposed by WebTreeViewNodeSettings.

Public Constructors

 | Name | Description
Public Constructor | WebTreeViewNodeSettings Constructor | Overloaded. Initializes a new instance of WebTreeViewNodeSettings class.
Top

Public Properties

 | Name | Description
Public Property | EnableAnimation | Specifies whether the expand/collapse node support animation.Determines whether the animation is enabled or disabled.
Public Property | EnableOpacityOnAnimation | Specifies whether the animation support opacity.Determines whether the opacity is enabled or disabled when animation is enabled.
Public Property | TargetWindow | Gets or sets the target window when the node is clicked.Determines the target window value for Node.Target property.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

Protected Methods

 | Name | Description
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | IsInSerializationContext | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebTreeViewNodeSettings Class
ISNet.WebUI.WebTreeView Namespace


WebTreeViewNodeSettings Constructor

[image]
Intersoft WebTreeView Documentation
WebTreeViewNodeSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeSettings Class : WebTreeViewNodeSettings Constructor

Glossary Item Box

Initializes a new instance of WebTreeViewNodeSettings class.

Overload List

Overload | Description
WebTreeViewNodeSettings Constructor() |
WebTreeViewNodeSettings Constructor(SerializationInfo,StreamingContext) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeSettings Class
WebTreeViewNodeSettings Members


WebTreeViewNodeSettings Constructor()

[image]
Intersoft WebTreeView Documentation
WebTreeViewNodeSettings Constructor()
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeSettings Class > WebTreeViewNodeSettings Constructor : WebTreeViewNodeSettings Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebTreeViewNodeSettings()
C#
public WebTreeViewNodeSettings()
Delphi
public WebTreeViewNodeSettings();
JScript
public function WebTreeViewNodeSettings();
Managed Extensions for C++
public: WebTreeViewNodeSettings();
C++/CLI
public:
WebTreeViewNodeSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeSettings Class
WebTreeViewNodeSettings Members
Overload List


WebTreeViewNodeSettings Constructor(SerializationInfo,StreamingContext)

[image]
Intersoft WebTreeView Documentation
WebTreeViewNodeSettings Constructor(SerializationInfo,StreamingContext)
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeSettings Class > WebTreeViewNodeSettings Constructor : WebTreeViewNodeSettings Constructor(SerializationInfo,StreamingContext)

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

Dim instance As New WebTreeViewNodeSettings(info, context)
C#
protected WebTreeViewNodeSettings(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
protected WebTreeViewNodeSettings(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
protected function WebTreeViewNodeSettings(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
protected: WebTreeViewNodeSettings(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
protected:
WebTreeViewNodeSettings(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeSettings Class
WebTreeViewNodeSettings Members
Overload List


WebTreeViewNodeSettings Class Properties

[image]
Intersoft WebTreeView Documentation
WebTreeViewNodeSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace : WebTreeViewNodeSettings Class

Glossary Item Box

For a list of all members of this type, see WebTreeViewNodeSettings members.

Public Properties

 | Name | Description
Public Property | EnableAnimation | Specifies whether the expand/collapse node support animation.Determines whether the animation is enabled or disabled.
Public Property | EnableOpacityOnAnimation | Specifies whether the animation support opacity.Determines whether the opacity is enabled or disabled when animation is enabled.
Public Property | TargetWindow | Gets or sets the target window when the node is clicked.Determines the target window value for Node.Target property.
Top

See Also

Reference

WebTreeViewNodeSettings Class
ISNet.WebUI.WebTreeView Namespace


EnableAnimation Property

[image]
Intersoft WebTreeView Documentation
EnableAnimation Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeSettings Class : EnableAnimation Property

Glossary Item Box

Specifies whether the expand/collapse node support animation.Determines whether the animation is enabled or disabled.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies whether the expand/collapse node support animation.")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property EnableAnimation As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeSettings
Dim value As System.Boolean

instance.EnableAnimation = value

value = instance.EnableAnimation
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies whether the expand/collapse node support animation.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.bool EnableAnimation {get; set;}
Delphi
public read-write property EnableAnimation: System.Boolean;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether the expand/collapse node support animation.")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set EnableAnimation : System.boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies whether the expand/collapse node support animation.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.bool get_EnableAnimation();
public: __property void set_EnableAnimation(
   System.bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies whether the expand/collapse node support animation.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.bool EnableAnimation {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeSettings Class
WebTreeViewNodeSettings Members


EnableOpacityOnAnimation Property

[image]
Intersoft WebTreeView Documentation
EnableOpacityOnAnimation Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeSettings Class : EnableOpacityOnAnimation Property

Glossary Item Box

Specifies whether the animation support opacity.Determines whether the opacity is enabled or disabled when animation is enabled.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.DescriptionAttribute("Specifies whether the animation support opacity.")>
Public Property EnableOpacityOnAnimation As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeSettings
Dim value As System.Boolean

instance.EnableOpacityOnAnimation = value

value = instance.EnableOpacityOnAnimation
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute("Specifies whether the animation support opacity.")]
public System.bool EnableOpacityOnAnimation {get; set;}
Delphi
public read-write property EnableOpacityOnAnimation: System.Boolean;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.DescriptionAttribute("Specifies whether the animation support opacity.")
public function get,set EnableOpacityOnAnimation : System.boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute("Specifies whether the animation support opacity.")]
public: __property System.bool get_EnableOpacityOnAnimation();
public: __property void set_EnableOpacityOnAnimation(
   System.bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute("Specifies whether the animation support opacity.")]
public:
property System.bool EnableOpacityOnAnimation {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeSettings Class
WebTreeViewNodeSettings Members


TargetWindow Property

[image]
Intersoft WebTreeView Documentation
TargetWindow Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeSettings Class : TargetWindow Property

Glossary Item Box

Gets or sets the target window when the node is clicked.Determines the target window value for Node.Target property.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the target window when the node is clicked.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property TargetWindow As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeSettings
Dim value As System.String

instance.TargetWindow = value

value = instance.TargetWindow
C#
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the target window when the node is clicked.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string TargetWindow {get; set;}
Delphi
public read-write property TargetWindow: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the target window when the node is clicked.")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set TargetWindow : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the target window when the node is clicked.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_TargetWindow();
public: __property void set_TargetWindow(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the target window when the node is clicked.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ TargetWindow {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeSettings Class
WebTreeViewNodeSettings Members


WebTreeViewNodeUpdatedEventArgs Class

[image]
Intersoft WebTreeView Documentation
WebTreeViewNodeUpdatedEventArgs Class
Members See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace : WebTreeViewNodeUpdatedEventArgs Class

Glossary Item Box

Object Model

WebTreeViewNodeUpdatedEventArgs Class

Syntax

Visual Basic (Declaration)
<System.ComponentModel.ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")>
<System.ComponentModel.DescriptionAttribute("Provides data for WebTreeView's node updated related event.")>
Public Class WebTreeViewNodeUpdatedEventArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeUpdatedEventArgs
C#
[System.ComponentModel.ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
[System.ComponentModel.DescriptionAttribute("Provides data for WebTreeView's node updated related event.")]
public class WebTreeViewNodeUpdatedEventArgs : System.EventArgs
Delphi
public class WebTreeViewNodeUpdatedEventArgs = class(System.EventArgs)
JScript
System.ComponentModel.ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")
System.ComponentModel.DescriptionAttribute("Provides data for WebTreeView's node updated related event.")
public class WebTreeViewNodeUpdatedEventArgs extends System.EventArgs
Managed Extensions for C++
[System.ComponentModel.ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
[System.ComponentModel.DescriptionAttribute("Provides data for WebTreeView's node updated related event.")]
public __gc class WebTreeViewNodeUpdatedEventArgs : public System.EventArgs
C++/CLI
[System.ComponentModel.ToolboxItemAttribute(ToolboxItemType=, ToolboxItemTypeName="")]
[System.ComponentModel.DescriptionAttribute("Provides data for WebTreeView's node updated related event.")]
public ref class WebTreeViewNodeUpdatedEventArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
ISNet.WebUI.WebTreeView.WebTreeViewNodeUpdatedEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeUpdatedEventArgs Members
ISNet.WebUI.WebTreeView Namespace


WebTreeViewNodeUpdatedEventArgs Class Members

[image]
Intersoft WebTreeView Documentation
WebTreeViewNodeUpdatedEventArgs Class Members
See Also Properties Send Feedback
ISNet.WebUI.WebTreeView Namespace : WebTreeViewNodeUpdatedEventArgs Class

Glossary Item Box

The following tables list the members exposed by WebTreeViewNodeUpdatedEventArgs.

Public Constructors

 | Name | Description
Public Constructor | WebTreeViewNodeUpdatedEventArgs Constructor |
Top

Public Properties

 | Name | Description
Public Property | Node | Gets operated node.
Public Property | OldValue | Gets old value.
Public Property | PropertyName | Gets Property Name.
Public Property | Value | Gets Value.
Top

See Also

Reference

WebTreeViewNodeUpdatedEventArgs Class
ISNet.WebUI.WebTreeView Namespace


WebTreeViewNodeUpdatedEventArgs Constructor

[image]
Intersoft WebTreeView Documentation
WebTreeViewNodeUpdatedEventArgs Constructor
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeUpdatedEventArgs Class : WebTreeViewNodeUpdatedEventArgs Constructor

node
propertyName
value
oldValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebTreeViewNodeUpdatedEventArgs class. ")>
Public Function New( _
   ByVal node As WebTreeViewNode, _
   ByVal propertyName As System.String, _
   ByVal value As System.Object, _
   ByVal oldValue As System.Object _
)
Visual Basic (Usage) Copy Code
Dim node As WebTreeViewNode
Dim propertyName As System.String
Dim value As System.Object
Dim oldValue As System.Object

Dim instance As New WebTreeViewNodeUpdatedEventArgs(node, propertyName, value, oldValue)
C#
[System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebTreeViewNodeUpdatedEventArgs class. ")]
public WebTreeViewNodeUpdatedEventArgs(
   WebTreeViewNode node,
   System.string propertyName,
   System.object value,
   System.object oldValue
)
Delphi
public WebTreeViewNodeUpdatedEventArgs(
    node: WebTreeViewNode;
    propertyName: System.String;
    value: System.TObject;
    oldValue: System.TObject
);
JScript
System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebTreeViewNodeUpdatedEventArgs class. ")
public function WebTreeViewNodeUpdatedEventArgs(
   node : WebTreeViewNode,
   propertyName : System.String,
   value : System.Object,
   oldValue : System.Object
);
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebTreeViewNodeUpdatedEventArgs class. ")]
public: WebTreeViewNodeUpdatedEventArgs(
   WebTreeViewNode* node,
   System.string* propertyName,
   System.Object* value,
   System.Object* oldValue
)
C++/CLI
[System.ComponentModel.DescriptionAttribute("Initializes a new instance of WebTreeViewNodeUpdatedEventArgs class. ")]
public:
WebTreeViewNodeUpdatedEventArgs(
   WebTreeViewNode^ node,
   System.String^ propertyName,
   System.Object^ value,
   System.Object^ oldValue
)

Parameters

node
propertyName
value
oldValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeUpdatedEventArgs Class
WebTreeViewNodeUpdatedEventArgs Members


WebTreeViewNodeUpdatedEventArgs Class Properties

[image]
Intersoft WebTreeView Documentation
WebTreeViewNodeUpdatedEventArgs Class Properties
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace : WebTreeViewNodeUpdatedEventArgs Class

Glossary Item Box

For a list of all members of this type, see WebTreeViewNodeUpdatedEventArgs members.

Public Properties

 | Name | Description
Public Property | Node | Gets operated node.
Public Property | OldValue | Gets old value.
Public Property | PropertyName | Gets Property Name.
Public Property | Value | Gets Value.
Top

See Also

Reference

WebTreeViewNodeUpdatedEventArgs Class
ISNet.WebUI.WebTreeView Namespace


Node Property

[image]
Intersoft WebTreeView Documentation
Node Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeUpdatedEventArgs Class : Node Property

Glossary Item Box

Gets operated node.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets operated node.")>
Public ReadOnly Property Node As WebTreeViewNode
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeUpdatedEventArgs
Dim value As WebTreeViewNode

value = instance.Node
C#
[System.ComponentModel.DescriptionAttribute("Gets operated node.")]
public WebTreeViewNode Node {get;}
Delphi
public read-only property Node: WebTreeViewNode;
JScript
System.ComponentModel.DescriptionAttribute("Gets operated node.")
public function get Node : WebTreeViewNode
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets operated node.")]
public: __property WebTreeViewNode* get_Node();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets operated node.")]
public:
property WebTreeViewNode^ Node {
   WebTreeViewNode^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeUpdatedEventArgs Class
WebTreeViewNodeUpdatedEventArgs Members


OldValue Property

[image]
Intersoft WebTreeView Documentation
OldValue Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeUpdatedEventArgs Class : OldValue Property

Glossary Item Box

Gets old value.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets old value.")>
Public ReadOnly Property OldValue As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeUpdatedEventArgs
Dim value As System.Object

value = instance.OldValue
C#
[System.ComponentModel.DescriptionAttribute("Gets old value.")]
public System.object OldValue {get;}
Delphi
public read-only property OldValue: System.TObject;
JScript
System.ComponentModel.DescriptionAttribute("Gets old value.")
public function get OldValue : System.Object
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets old value.")]
public: __property System.Object* get_OldValue();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets old value.")]
public:
property System.Object^ OldValue {
   System.Object^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeUpdatedEventArgs Class
WebTreeViewNodeUpdatedEventArgs Members


PropertyName Property

[image]
Intersoft WebTreeView Documentation
PropertyName Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeUpdatedEventArgs Class : PropertyName Property

Glossary Item Box

Gets Property Name.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets Property Name.")>
Public ReadOnly Property PropertyName As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeUpdatedEventArgs
Dim value As System.String

value = instance.PropertyName
C#
[System.ComponentModel.DescriptionAttribute("Gets Property Name.")]
public System.string PropertyName {get;}
Delphi
public read-only property PropertyName: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Gets Property Name.")
public function get PropertyName : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets Property Name.")]
public: __property System.string* get_PropertyName();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets Property Name.")]
public:
property System.String^ PropertyName {
   System.String^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeUpdatedEventArgs Class
WebTreeViewNodeUpdatedEventArgs Members


Value Property

[image]
Intersoft WebTreeView Documentation
Value Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeUpdatedEventArgs Class : Value Property

Glossary Item Box

Gets Value.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets Value.")>
Public ReadOnly Property Value As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeUpdatedEventArgs
Dim value As System.Object

value = instance.Value
C#
[System.ComponentModel.DescriptionAttribute("Gets Value.")]
public System.object Value {get;}
Delphi
public read-only property Value: System.TObject;
JScript
System.ComponentModel.DescriptionAttribute("Gets Value.")
public function get Value : System.Object
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets Value.")]
public: __property System.Object* get_Value();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets Value.")]
public:
property System.Object^ Value {
   System.Object^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeUpdatedEventArgs Class
WebTreeViewNodeUpdatedEventArgs Members


AllowEditing Enumeration

[image]
Intersoft WebTreeView Documentation
AllowEditing Enumeration
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace : AllowEditing Enumeration

Glossary Item Box

Enumerations for Allow Editing Specifies whether to allow node editting or not.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies whether to allow node editting or not.")>
Public Enum AllowEditing
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As AllowEditing
C#
[System.ComponentModel.DescriptionAttribute("Specifies whether to allow node editting or not.")]
public enum AllowEditing : System.Enum
Delphi
public enum AllowEditing = class(System.Enum)
JScript
System.ComponentModel.DescriptionAttribute("Specifies whether to allow node editting or not.")
public enum AllowEditing extends System.Enum
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies whether to allow node editting or not.")]
__value public enum AllowEditing : public System.Enum
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies whether to allow node editting or not.")]
public enum class AllowEditing : public System.Enum

Members

Member | Description
Default |
No | User can not edit a node
Yes | User can edit a node

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebTreeView.AllowEditing

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebTreeView Namespace


CheckBoxLocation Enumeration

[image]
Intersoft WebTreeView Documentation
CheckBoxLocation Enumeration
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace : CheckBoxLocation Enumeration

Glossary Item Box

Values indicating the location of checkbox.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Values indicating the location of checkbox.")>
Public Enum CheckBoxLocation
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As CheckBoxLocation
C#
[System.ComponentModel.DescriptionAttribute("Values indicating the location of checkbox.")]
public enum CheckBoxLocation : System.Enum
Delphi
public enum CheckBoxLocation = class(System.Enum)
JScript
System.ComponentModel.DescriptionAttribute("Values indicating the location of checkbox.")
public enum CheckBoxLocation extends System.Enum
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Values indicating the location of checkbox.")]
__value public enum CheckBoxLocation : public System.Enum
C++/CLI
[System.ComponentModel.DescriptionAttribute("Values indicating the location of checkbox.")]
public enum class CheckBoxLocation : public System.Enum

Members

Member | Description
All | Checkboxes are shown on all node level.
Leaf | Checkbox is shown on leaf node level.
None | Checkboxes are not shown on all nodes level.
Parent | Checkbox is shown on parent node level.
Root | Checkbox is shown on root node level.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebTreeView.CheckBoxLocation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebTreeView Namespace


CheckBoxType Enumeration

[image]
Intersoft WebTreeView Documentation
CheckBoxType Enumeration
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace : CheckBoxType Enumeration

Glossary Item Box

Values indicating which checkbox is used, normal two-state checkbox or TriState checkbox.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Values indicating which checkbox is used, normal two-state checkbox or TriState checkbox. ")>
Public Enum CheckBoxType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As CheckBoxType
C#
[System.ComponentModel.DescriptionAttribute("Values indicating which checkbox is used, normal two-state checkbox or TriState checkbox. ")]
public enum CheckBoxType : System.Enum
Delphi
public enum CheckBoxType = class(System.Enum)
JScript
System.ComponentModel.DescriptionAttribute("Values indicating which checkbox is used, normal two-state checkbox or TriState checkbox. ")
public enum CheckBoxType extends System.Enum
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Values indicating which checkbox is used, normal two-state checkbox or TriState checkbox. ")]
__value public enum CheckBoxType : public System.Enum
C++/CLI
[System.ComponentModel.DescriptionAttribute("Values indicating which checkbox is used, normal two-state checkbox or TriState checkbox. ")]
public enum class CheckBoxType : public System.Enum

Members

Member | Description
UseImage | Use user specified CheckBox image.
UseStandard | Use default CheckBox image.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebTreeView.CheckBoxType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebTreeView Namespace


CheckState Enumeration

[image]
Intersoft WebTreeView Documentation
CheckState Enumeration
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace : CheckState Enumeration

Glossary Item Box

Values representing checkbox's state.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Values representing checkbox's state. ")>
Public Enum CheckState
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As CheckState
C#
[System.ComponentModel.DescriptionAttribute("Values representing checkbox's state. ")]
public enum CheckState : System.Enum
Delphi
public enum CheckState = class(System.Enum)
JScript
System.ComponentModel.DescriptionAttribute("Values representing checkbox's state. ")
public enum CheckState extends System.Enum
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Values representing checkbox's state. ")]
__value public enum CheckState : public System.Enum
C++/CLI
[System.ComponentModel.DescriptionAttribute("Values representing checkbox's state. ")]
public enum class CheckState : public System.Enum

Members

Member | Description
Checked | The Checked state of a CheckBox.
Indeterminate | The Indetermintate state of a CheckBox.
UnChecked | The UnChecked state of a CheckBox.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebTreeView.CheckState

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebTreeView Namespace


NodeMoveInsertionMode Enumeration

[image]
Intersoft WebTreeView Documentation
NodeMoveInsertionMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace : NodeMoveInsertionMode Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Values indicating node move insertion mode.")>
Public Enum NodeMoveInsertionMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As NodeMoveInsertionMode
C#
[System.ComponentModel.DescriptionAttribute("Values indicating node move insertion mode.")]
public enum NodeMoveInsertionMode : System.Enum
Delphi
public enum NodeMoveInsertionMode = class(System.Enum)
JScript
System.ComponentModel.DescriptionAttribute("Values indicating node move insertion mode.")
public enum NodeMoveInsertionMode extends System.Enum
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Values indicating node move insertion mode.")]
__value public enum NodeMoveInsertionMode : public System.Enum
C++/CLI
[System.ComponentModel.DescriptionAttribute("Values indicating node move insertion mode.")]
public enum class NodeMoveInsertionMode : public System.Enum

Members

Member | Description
MoveAfter |
MoveBefore |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebTreeView.NodeMoveInsertionMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebTreeView Namespace


NodeMoveType Enumeration

[image]
Intersoft WebTreeView Documentation
NodeMoveType Enumeration
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace : NodeMoveType Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Values indicating node move type.")>
Public Enum NodeMoveType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As NodeMoveType
C#
[System.ComponentModel.DescriptionAttribute("Values indicating node move type.")]
public enum NodeMoveType : System.Enum
Delphi
public enum NodeMoveType = class(System.Enum)
JScript
System.ComponentModel.DescriptionAttribute("Values indicating node move type.")
public enum NodeMoveType extends System.Enum
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Values indicating node move type.")]
__value public enum NodeMoveType : public System.Enum
C++/CLI
[System.ComponentModel.DescriptionAttribute("Values indicating node move type.")]
public enum class NodeMoveType : public System.Enum

Members

Member | Description
MoveToChild |
MoveToSibling |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebTreeView.NodeMoveType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebTreeView Namespace


NodeType Enumeration

[image]
Intersoft WebTreeView Documentation
NodeType Enumeration
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace : NodeType Enumeration

Glossary Item Box

Values representing the type of a node.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Values representing the type of a node. ")>
Public Enum NodeType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As NodeType
C#
[System.ComponentModel.DescriptionAttribute("Values representing the type of a node. ")]
public enum NodeType : System.Enum
Delphi
public enum NodeType = class(System.Enum)
JScript
System.ComponentModel.DescriptionAttribute("Values representing the type of a node. ")
public enum NodeType extends System.Enum
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Values representing the type of a node. ")]
__value public enum NodeType : public System.Enum
C++/CLI
[System.ComponentModel.DescriptionAttribute("Values representing the type of a node. ")]
public enum class NodeType : public System.Enum

Members

Member | Description
Leaf | The type of a Node is Leaf.
Parent | The type of a Node is Parent.
Root | The type of a Node is Root.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebTreeView.NodeType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebTreeView Namespace


PostBackMode Enumeration

[image]
Intersoft WebTreeView Documentation
PostBackMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace : PostBackMode Enumeration

Glossary Item Box

Specifies which postback mode is set.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies which postback mode is set. ")>
Public Enum PostBackMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As PostBackMode
C#
[System.ComponentModel.DescriptionAttribute("Specifies which postback mode is set. ")]
public enum PostBackMode : System.Enum
Delphi
public enum PostBackMode = class(System.Enum)
JScript
System.ComponentModel.DescriptionAttribute("Specifies which postback mode is set. ")
public enum PostBackMode extends System.Enum
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies which postback mode is set. ")]
__value public enum PostBackMode : public System.Enum
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies which postback mode is set. ")]
public enum class PostBackMode : public System.Enum

Members

Member | Description
FlyPostBack | Set the PostBack mode to FlyPostBack.
FullPostBack | Set the PostBack mode to FullPostBack.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebTreeView.PostBackMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebTreeView Namespace


ShowCheckBox Enumeration

[image]
Intersoft WebTreeView Documentation
ShowCheckBox Enumeration
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace : ShowCheckBox Enumeration

Glossary Item Box

Enumerations for Show CheckBox Values indicating on which node level a checkbox will be shown.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Values indicating on which node level a checkbox will be shown. ")>
Public Enum ShowCheckBox
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As ShowCheckBox
C#
[System.ComponentModel.DescriptionAttribute("Values indicating on which node level a checkbox will be shown. ")]
public enum ShowCheckBox : System.Enum
Delphi
public enum ShowCheckBox = class(System.Enum)
JScript
System.ComponentModel.DescriptionAttribute("Values indicating on which node level a checkbox will be shown. ")
public enum ShowCheckBox extends System.Enum
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Values indicating on which node level a checkbox will be shown. ")]
__value public enum ShowCheckBox : public System.Enum
C++/CLI
[System.ComponentModel.DescriptionAttribute("Values indicating on which node level a checkbox will be shown. ")]
public enum class ShowCheckBox : public System.Enum

Members

Member | Description
Default |
No | CheckBox is not shown on every node.
Yes | CheckBox is shown on every node.

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebTreeView.ShowCheckBox

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebTreeView Namespace


InitializeChildNodesEventHandler Delegate

[image]
Intersoft WebTreeView Documentation
InitializeChildNodesEventHandler Delegate
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace : InitializeChildNodesEventHandler Delegate

sender
e

Glossary Item Box

Represents the method that handles InitializeChildNode event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub InitializeChildNodesEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As WebTreeViewNodeEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New InitializeChildNodesEventHandler(AddressOf HandlerMethod)
C#
public delegate void InitializeChildNodesEventHandler(
   System.object sender,
   WebTreeViewNodeEventArgs e
)
Delphi
public delegate InitializeChildNodesEventHandler(
    sender: System.TObject;
    e: WebTreeViewNodeEventArgs
);
JScript
public delegate InitializeChildNodesEventHandler(
   sender : System.Object,
   e : WebTreeViewNodeEventArgs
)
Managed Extensions for C++
public: __gc __delegate void InitializeChildNodesEventHandler(
   System.Object* sender,
   WebTreeViewNodeEventArgs* e
)
C++/CLI
public delegate void InitializeChildNodesEventHandler(
   System.Object^ sender,
   WebTreeViewNodeEventArgs^ e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InitializeChildNodesEventHandler Members
ISNet.WebUI.WebTreeView Namespace


InitializeNodeEventHandler Delegate

[image]
Intersoft WebTreeView Documentation
InitializeNodeEventHandler Delegate
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace : InitializeNodeEventHandler Delegate

sender
e

Glossary Item Box

Represents the method that handles InitializeNode event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub InitializeNodeEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As WebTreeViewNodeEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New InitializeNodeEventHandler(AddressOf HandlerMethod)
C#
public delegate void InitializeNodeEventHandler(
   System.object sender,
   WebTreeViewNodeEventArgs e
)
Delphi
public delegate InitializeNodeEventHandler(
    sender: System.TObject;
    e: WebTreeViewNodeEventArgs
);
JScript
public delegate InitializeNodeEventHandler(
   sender : System.Object,
   e : WebTreeViewNodeEventArgs
)
Managed Extensions for C++
public: __gc __delegate void InitializeNodeEventHandler(
   System.Object* sender,
   WebTreeViewNodeEventArgs* e
)
C++/CLI
public delegate void InitializeNodeEventHandler(
   System.Object^ sender,
   WebTreeViewNodeEventArgs^ e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

InitializeNodeEventHandler Members
ISNet.WebUI.WebTreeView Namespace


NodeAddEventHandler Delegate

[image]
Intersoft WebTreeView Documentation
NodeAddEventHandler Delegate
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace : NodeAddEventHandler Delegate

sender
e

Glossary Item Box

Represents the method that handles NodeAdd event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub NodeAddEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As WebTreeViewNodeEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New NodeAddEventHandler(AddressOf HandlerMethod)
C#
public delegate void NodeAddEventHandler(
   System.object sender,
   WebTreeViewNodeEventArgs e
)
Delphi
public delegate NodeAddEventHandler(
    sender: System.TObject;
    e: WebTreeViewNodeEventArgs
);
JScript
public delegate NodeAddEventHandler(
   sender : System.Object,
   e : WebTreeViewNodeEventArgs
)
Managed Extensions for C++
public: __gc __delegate void NodeAddEventHandler(
   System.Object* sender,
   WebTreeViewNodeEventArgs* e
)
C++/CLI
public delegate void NodeAddEventHandler(
   System.Object^ sender,
   WebTreeViewNodeEventArgs^ e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NodeAddEventHandler Members
ISNet.WebUI.WebTreeView Namespace


NodeCheckChangedEventHandler Delegate

[image]
Intersoft WebTreeView Documentation
NodeCheckChangedEventHandler Delegate
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace : NodeCheckChangedEventHandler Delegate

sender
e

Glossary Item Box

Represents the method that handles NodeCheckChanged event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub NodeCheckChangedEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As WebTreeViewNodeEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New NodeCheckChangedEventHandler(AddressOf HandlerMethod)
C#
public delegate void NodeCheckChangedEventHandler(
   System.object sender,
   WebTreeViewNodeEventArgs e
)
Delphi
public delegate NodeCheckChangedEventHandler(
    sender: System.TObject;
    e: WebTreeViewNodeEventArgs
);
JScript
public delegate NodeCheckChangedEventHandler(
   sender : System.Object,
   e : WebTreeViewNodeEventArgs
)
Managed Extensions for C++
public: __gc __delegate void NodeCheckChangedEventHandler(
   System.Object* sender,
   WebTreeViewNodeEventArgs* e
)
C++/CLI
public delegate void NodeCheckChangedEventHandler(
   System.Object^ sender,
   WebTreeViewNodeEventArgs^ e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NodeCheckChangedEventHandler Members
ISNet.WebUI.WebTreeView Namespace


NodeCollapseEventHandler Delegate

[image]
Intersoft WebTreeView Documentation
NodeCollapseEventHandler Delegate
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace : NodeCollapseEventHandler Delegate

sender
e

Glossary Item Box

Represents the method that handles NodeCollapse event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub NodeCollapseEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As WebTreeViewNodeEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New NodeCollapseEventHandler(AddressOf HandlerMethod)
C#
public delegate void NodeCollapseEventHandler(
   System.object sender,
   WebTreeViewNodeEventArgs e
)
Delphi
public delegate NodeCollapseEventHandler(
    sender: System.TObject;
    e: WebTreeViewNodeEventArgs
);
JScript
public delegate NodeCollapseEventHandler(
   sender : System.Object,
   e : WebTreeViewNodeEventArgs
)
Managed Extensions for C++
public: __gc __delegate void NodeCollapseEventHandler(
   System.Object* sender,
   WebTreeViewNodeEventArgs* e
)
C++/CLI
public delegate void NodeCollapseEventHandler(
   System.Object^ sender,
   WebTreeViewNodeEventArgs^ e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NodeCollapseEventHandler Members
ISNet.WebUI.WebTreeView Namespace


NodeCopyEventHandler Delegate

[image]
Intersoft WebTreeView Documentation
NodeCopyEventHandler Delegate
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace : NodeCopyEventHandler Delegate

sender
e

Glossary Item Box

Represents the method that handles NodeCopy event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub NodeCopyEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As WebTreeViewNodeCopyEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New NodeCopyEventHandler(AddressOf HandlerMethod)
C#
public delegate void NodeCopyEventHandler(
   System.object sender,
   WebTreeViewNodeCopyEventArgs e
)
Delphi
public delegate NodeCopyEventHandler(
    sender: System.TObject;
    e: WebTreeViewNodeCopyEventArgs
);
JScript
public delegate NodeCopyEventHandler(
   sender : System.Object,
   e : WebTreeViewNodeCopyEventArgs
)
Managed Extensions for C++
public: __gc __delegate void NodeCopyEventHandler(
   System.Object* sender,
   WebTreeViewNodeCopyEventArgs* e
)
C++/CLI
public delegate void NodeCopyEventHandler(
   System.Object^ sender,
   WebTreeViewNodeCopyEventArgs^ e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NodeCopyEventHandler Members
ISNet.WebUI.WebTreeView Namespace


NodeDeleteEventHandler Delegate

[image]
Intersoft WebTreeView Documentation
NodeDeleteEventHandler Delegate
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace : NodeDeleteEventHandler Delegate

sender
e

Glossary Item Box

Represents the method that handles NodeDelete event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub NodeDeleteEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As WebTreeViewNodeEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New NodeDeleteEventHandler(AddressOf HandlerMethod)
C#
public delegate void NodeDeleteEventHandler(
   System.object sender,
   WebTreeViewNodeEventArgs e
)
Delphi
public delegate NodeDeleteEventHandler(
    sender: System.TObject;
    e: WebTreeViewNodeEventArgs
);
JScript
public delegate NodeDeleteEventHandler(
   sender : System.Object,
   e : WebTreeViewNodeEventArgs
)
Managed Extensions for C++
public: __gc __delegate void NodeDeleteEventHandler(
   System.Object* sender,
   WebTreeViewNodeEventArgs* e
)
C++/CLI
public delegate void NodeDeleteEventHandler(
   System.Object^ sender,
   WebTreeViewNodeEventArgs^ e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NodeDeleteEventHandler Members
ISNet.WebUI.WebTreeView Namespace


NodeEditEventHandler Delegate

[image]
Intersoft WebTreeView Documentation
NodeEditEventHandler Delegate
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace : NodeEditEventHandler Delegate

sender
e

Glossary Item Box

Represents the method that handles NodeEdit event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub NodeEditEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As WebTreeViewNodeEditEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New NodeEditEventHandler(AddressOf HandlerMethod)
C#
public delegate void NodeEditEventHandler(
   System.object sender,
   WebTreeViewNodeEditEventArgs e
)
Delphi
public delegate NodeEditEventHandler(
    sender: System.TObject;
    e: WebTreeViewNodeEditEventArgs
);
JScript
public delegate NodeEditEventHandler(
   sender : System.Object,
   e : WebTreeViewNodeEditEventArgs
)
Managed Extensions for C++
public: __gc __delegate void NodeEditEventHandler(
   System.Object* sender,
   WebTreeViewNodeEditEventArgs* e
)
C++/CLI
public delegate void NodeEditEventHandler(
   System.Object^ sender,
   WebTreeViewNodeEditEventArgs^ e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NodeEditEventHandler Members
ISNet.WebUI.WebTreeView Namespace


NodeExpandEventHandler Delegate

[image]
Intersoft WebTreeView Documentation
NodeExpandEventHandler Delegate
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace : NodeExpandEventHandler Delegate

sender
e

Glossary Item Box

Represents the method that handles NodeExpand event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub NodeExpandEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As WebTreeViewNodeEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New NodeExpandEventHandler(AddressOf HandlerMethod)
C#
public delegate void NodeExpandEventHandler(
   System.object sender,
   WebTreeViewNodeEventArgs e
)
Delphi
public delegate NodeExpandEventHandler(
    sender: System.TObject;
    e: WebTreeViewNodeEventArgs
);
JScript
public delegate NodeExpandEventHandler(
   sender : System.Object,
   e : WebTreeViewNodeEventArgs
)
Managed Extensions for C++
public: __gc __delegate void NodeExpandEventHandler(
   System.Object* sender,
   WebTreeViewNodeEventArgs* e
)
C++/CLI
public delegate void NodeExpandEventHandler(
   System.Object^ sender,
   WebTreeViewNodeEventArgs^ e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NodeExpandEventHandler Members
ISNet.WebUI.WebTreeView Namespace


NodeMoveEventHandler Delegate

[image]
Intersoft WebTreeView Documentation
NodeMoveEventHandler Delegate
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace : NodeMoveEventHandler Delegate

sender
e

Glossary Item Box

Represents the method that handles NodeMove event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub NodeMoveEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As WebTreeViewNodeMoveEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New NodeMoveEventHandler(AddressOf HandlerMethod)
C#
public delegate void NodeMoveEventHandler(
   System.object sender,
   WebTreeViewNodeMoveEventArgs e
)
Delphi
public delegate NodeMoveEventHandler(
    sender: System.TObject;
    e: WebTreeViewNodeMoveEventArgs
);
JScript
public delegate NodeMoveEventHandler(
   sender : System.Object,
   e : WebTreeViewNodeMoveEventArgs
)
Managed Extensions for C++
public: __gc __delegate void NodeMoveEventHandler(
   System.Object* sender,
   WebTreeViewNodeMoveEventArgs* e
)
C++/CLI
public delegate void NodeMoveEventHandler(
   System.Object^ sender,
   WebTreeViewNodeMoveEventArgs^ e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NodeMoveEventHandler Members
ISNet.WebUI.WebTreeView Namespace


NodeRenameEventHandler Delegate

[image]
Intersoft WebTreeView Documentation
NodeRenameEventHandler Delegate
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace : NodeRenameEventHandler Delegate

sender
e

Glossary Item Box

Represents the method that handles NodeRename event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub NodeRenameEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As WebTreeViewNodeRenameEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New NodeRenameEventHandler(AddressOf HandlerMethod)
C#
public delegate void NodeRenameEventHandler(
   System.object sender,
   WebTreeViewNodeRenameEventArgs e
)
Delphi
public delegate NodeRenameEventHandler(
    sender: System.TObject;
    e: WebTreeViewNodeRenameEventArgs
);
JScript
public delegate NodeRenameEventHandler(
   sender : System.Object,
   e : WebTreeViewNodeRenameEventArgs
)
Managed Extensions for C++
public: __gc __delegate void NodeRenameEventHandler(
   System.Object* sender,
   WebTreeViewNodeRenameEventArgs* e
)
C++/CLI
public delegate void NodeRenameEventHandler(
   System.Object^ sender,
   WebTreeViewNodeRenameEventArgs^ e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NodeRenameEventHandler Members
ISNet.WebUI.WebTreeView Namespace


NodeSelectChangedEventHandler Delegate

[image]
Intersoft WebTreeView Documentation
NodeSelectChangedEventHandler Delegate
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace : NodeSelectChangedEventHandler Delegate

sender
e

Glossary Item Box

Represents the method that handles NodeSelectChanged event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub NodeSelectChangedEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As WebTreeViewNodeEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New NodeSelectChangedEventHandler(AddressOf HandlerMethod)
C#
public delegate void NodeSelectChangedEventHandler(
   System.object sender,
   WebTreeViewNodeEventArgs e
)
Delphi
public delegate NodeSelectChangedEventHandler(
    sender: System.TObject;
    e: WebTreeViewNodeEventArgs
);
JScript
public delegate NodeSelectChangedEventHandler(
   sender : System.Object,
   e : WebTreeViewNodeEventArgs
)
Managed Extensions for C++
public: __gc __delegate void NodeSelectChangedEventHandler(
   System.Object* sender,
   WebTreeViewNodeEventArgs* e
)
C++/CLI
public delegate void NodeSelectChangedEventHandler(
   System.Object^ sender,
   WebTreeViewNodeEventArgs^ e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NodeSelectChangedEventHandler Members
ISNet.WebUI.WebTreeView Namespace


NodeUpdatedEventHandler Delegate

[image]
Intersoft WebTreeView Documentation
NodeUpdatedEventHandler Delegate
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace : NodeUpdatedEventHandler Delegate

sender
e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Delegate Sub NodeUpdatedEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As WebTreeViewNodeUpdatedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New NodeUpdatedEventHandler(AddressOf HandlerMethod)
C#
public delegate void NodeUpdatedEventHandler(
   System.object sender,
   WebTreeViewNodeUpdatedEventArgs e
)
Delphi
public delegate NodeUpdatedEventHandler(
    sender: System.TObject;
    e: WebTreeViewNodeUpdatedEventArgs
);
JScript
public delegate NodeUpdatedEventHandler(
   sender : System.Object,
   e : WebTreeViewNodeUpdatedEventArgs
)
Managed Extensions for C++
public: __gc __delegate void NodeUpdatedEventHandler(
   System.Object* sender,
   WebTreeViewNodeUpdatedEventArgs* e
)
C++/CLI
public delegate void NodeUpdatedEventHandler(
   System.Object^ sender,
   WebTreeViewNodeUpdatedEventArgs^ e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NodeUpdatedEventHandler Members
ISNet.WebUI.WebTreeView Namespace


Client-side References

Client-side References
Send Feedback
Intersoft WebTreeView > Client-side References

Glossary Item Box

This section is designated to help user working with client-side references in WebTreeView.

In This Section

WebTreeViewClientSideEvents

WebTreeView

WebTreeViewNode

WebTreeViewNodeSettings

WebTreeViewImagesSettings

WebTreeViewAutoPostBackSettings

WebTreeView Global Functions


WebTreeViewClientSideEvents

WebTreeViewClientSideEvents
Send Feedback
Intersoft WebTreeView > Client-side References > WebTreeViewClientSideEvents

Glossary Item Box

WebGridClientEvents Properties

OnInitialized | Description When the WebTreeView is initialized, this event will be invoked. The parameter for this event is controlId.. ValueType String Default Value -
OnNodeCheckedChanged | Description This event will be invoked when you check or uncheck a node. The parameters for this event are controlId and node. ValueType String Default Value -
OnNodeCollapse | Description This event will be invoked when a node is collapsed. The parameters for this event are controlId and node. ValueType String Default Value -
OnNodeCopy | Description This event will be invoked when a node is copied. The parameters for this event are controlId and node. ValueType String Default Value -
OnNodeExpand | Description This event will be invoked when a node is expanded. The parameters for this event are controlId and node. ValueType String Default Value -
OnNodeMove | Description This event will be invoked when a node is moved. The parameters for this event are controlId and node. ValueType String Default Value -
OnNodeRename | Description This event will be invoked when a node is renamed. The parameters for this event are controlId, node, oldName, and newName. ValueType String Default Value -
OnNodeSelect | Description This event will be invoked when a node is selected. The parameters for this event are controlId and node. ValueType String Default Value -
OnUnload | Description This event will be invoked when WebTreeView is unloaded. The parameters for this event are controlId. ValueType String Default Value -


WebTreeView

WebTreeView
Send Feedback
Intersoft WebTreeView > Client-side References > WebTreeView

Glossary Item Box

WebTreeView Properties

ClassName | Description Gets the object class name. ValueType String Default Value "WebTreeView"
Nodes | Description The collection of nodes for WebTreeView. ValueType ISArray object Default Value Array
ClientSideEvents | Description Specifies the client side (JavaScript) TreeView events. ValueType WebTreeViewClientSideEvents Default Value null
NodeSettings | Description Contains node settings such as TargetWindow, and EnableAnimation. ValueType WebTreeViewNodeSettings Default Value javascript object
ImagesDirectory | Description Gets or sets the location of images used to render the control. ValueType String Default Value -
AllowExpandNodeOnSelect | Description Indicates whether to expand a parent node when it is selected. ValueType Boolean Default Value True
AllowCollapseNodeOnSelect | Description Indicates whether to collapse a parent node when it is selected. ValueType Boolean Default Value False
AllowDragDrop | Description Specifies whether to allow drag and drop of the tree nodes. ValueType Boolean Default Value False
AllowDropFromOtherControls | Description Indicates whether to allow drop from other Intersoft controls. ValueType Boolean Default Value False
AllowNodeEditing | Description Indicates whether to allow node editing. ValueType AllowEditing Default Value Yes
CheckedNodes | Description The collection of checkable nodes which are currently checked. ValueType ArrayList Default Value -
CheckBoxType | Description Gets or sets the type of node checkbox, whether to use image or standard checkbox. ValueType CheckBoxType Default Value UseStandard
EnableLoadOnDemand | Description Indicates whether to enable load on demand. ValueType Boolean Default Value False
LoadingStyle | Description Gets or sets the image to use while loading load-on-demand content. ValueType String Default Value -
LoadingText | Description Gets or sets the text to use while loading load-on-demand content. ValueType String Default Value "Loading..."
NodeStyle | Description Gets or sets the style of the node. ValueType DynamicStyle Default Value -
PostBackModeType | Description Gets or sets the type of postback mode, whether to use FlyPostBack or FullPostBack. ValueType PostBackMode Default Value FullPostBack
ShowExpandCollapse | Description Specifies whether to show the expand/collapse icon next to the tree nodes. ValueType Boolean Default Value True
ShowLines | Description Specifies whether to show lines connecting the tree nodes. ValueType Boolean Default Value True
ExpandCollapseImageWidth | Description Gets or sets the default width (in pixels) to use for expand/collapse images. ValueType Integer Default Value 20
LineImageHeight | Description Gets or sets the height (in pixels) to apply on line images. ValueType Integer Default Value 20
DefaultImageHeight | Description Gets or sets the default height (in pixels) to use for icon images. ValueType Integer Default Value 16
ImagesSettings | Description Contains images settings for WebTreeView. ValueType object (WebTreeViewImagesSettings) Default Value -
AutoCheckChildNodes | Description Specifies whether to check child nodes automatically. ValueType Boolean Default Value False

WebTreeView Methods
AddNode Description
Adds a new node to a WebTreeView instance.

Parameters
name ( String )
Name of the added node.

text ( String )
Text of the added node.

Remarks
-

Return Value
-

Samples
function btnAdd_Click()
{
var treeView = ISGetObject("WebTreeView1");
var node = treeView.GetSelectedNode();
var txt = document.getElementById("txtNewNode").value;

if(txt == "")
alert("Please type a text");
else
{
if(node != null)
node.AddNode(txt, txt);
 else
treeView.AddNode(txt, txt);
}
}
CheckAll Description
Checks all nodes level.

Parameters
-

Remarks
-

Return Value
void

Samples

function Button1_onclick()
{
var tv = ISGetObject("WebTreeView1");
tv.CheckAll();
}
ExpandAll Description
Expands all parent nodes.

Parameters
-

Remarks
-

Return Value
void

Samples

function Button1_onclick()
{
var tv = ISGetObject("WebTreeView1");
tv.ExpandAll();
}

FindNodesByText Description
Finds all nodes from the specified text.

Parameters
text ( String )
The specified text to be found.

Remarks
-

Return Value
-
Array

Samples

function FindNextNode()
{
var tv = ISGetObject("WebTreeView1");
var searchText = document.getElementById("txtSearch").value;
if(searchText != "")
{
var node = tv.FindNodesByText(searchText);
if(node != null)
node.Select();
else
alert("The search text can't be found");
}
else
alert("Please fill in the search text");
}

FindNextNodeByText Description
Find a node by the specified text starting from its root.

Parameters
text ( String )
The specified text to be found.

Remarks
-

Return Value
object (WebTreeViewNode)

Samples

function FindNextNode()
{
var tv = ISGetObject("WebTreeView1");
var searchText = document.getElementById("txtSearch").value;
if(searchText != "")
{
var node = tv.FindNextNodeByText(searchText);

if(node != null)
node.Select();
else
alert("The search text can't be found");
}
else
alert("Please fill in the search text");
}

UnCheckAll Description
Unchecks all node level.

Parameters
-

Remarks
-

Return Value
void

Samples
function Button1_onclick()
{
var tv = ISGetObject("WebTreeView1");
tv.UnCheckAll();
}
GetArrayNodes Description
Gets all nodes in 1 dimensional array.

Parameters
-

Remarks
-

Return Value
object

Samples

GetSelectedNode Description
Gets the selected node

Parameters
-

Remarks
-

Return Value
object (WebTreeViewNode)

Samples

function doWebTreeView1NodeSelect(ctrlId, node)
{
var tv = ISGetObject(ctrlId);
var selectedNode = tv.GetSelectedNode();
}

GetSelectedNodes Description
Gets the collection of selected nodes.

Parameters
-

Remarks
-

Return Value
ArrayList

Samples

function doWebTreeView1NodeSelect(ctrlId, node)
{
var divStatus = document.getElementById("divWebTreeView1SelectNodes");

var tv = ISGetObject(ctrlId);

var selectedNodes = tv.GetSelectedNodes();

divStatus.innerHTML = "";

if (selectedNodes!=null && selectedNodes.length>0)
{
for (var i=0;i<selectedNodes.length;i++)
{
divStatus.innerHTML += "- " + selectedNodes[i].Name + "<br>";
}
}
}

GetPathSeparator Description
Gets the character used to separate parts of the path.

Parameters
-

Remarks
-

Return Value
String

Samples

GetCheckedNodes Description
Gets the collection of checked nodes.

Parameters
-

Remarks
-

Return Value
ArrayList

Samples

function onWebTreeView1NodeCheckChanged(ctrlId, node)
{

var div1 = document.getElementById("divWebTreeView1CheckedNodes");

var checkedNodes = ISGetObject(ctrlId).GetCheckedNodes();

div1.innerHTML = "";

for (var i=0; i<checkedNodes.length; i++)
{
div1.innerHTML += "- " + checkedNodes[i].Name + " node <br>";
}
}


WebTreeViewNode

WebTreeViewNode
Send Feedback
Intersoft WebTreeView > Client-side References > WebTreeViewNode

Glossary Item Box

WebTreeViewNode Properties

Name | Description Specifies the name of the node. ValueType String Default Value -
AllowEditing | Description Specifies whether a node is allowed to be edited or not. ValueType AllowEditing Default Value Default
Checked | Description Determines whether the specified node is currently checked or not. ValueType Boolean Default Value False
CheckedState | Description Determines the checked state of the node. ValueType CheckState Default Value UnChecked
NavigateURL | Description Specifies the URL to be loaded for sub-tree contents. ValueType String Default Value -
Target | Description The navigate target used when the node is selected. ValueType String Default Value -
CustomStyle | Description Gets or sets the custom CSS style of the node. ValueType String Default Value -
DropableNodes | Description Determines the nodes which is dropable. ValueType JavaScript Array Default Value -
Enabled | Description Indicates whether the node is enabled or disabled. ValueType Boolean Default Value True
Image | Description Gets or sets the icon image of the node. ValueType String Default Value -
Expanded | Description Specifies whether the node is currently expanded or not. ValueType Boolean Default Value False
ExpandedImage | Description Gets or sets the expanded icon image of the node. ValueType String Default Value -
Nodes | Description Specifies a collection of WebTreeView's nodes. ValueType WebTreeViewNodeCollection Default Value -
Path | Description Gets or sets the path of a node, path from the root node to the node itself. ValueType String Default Value -
Selected | Description Indicates whether the node is selected or not. ValueType Boolean Default Value False
SelectedImage | Description Gets or sets the collapsed icon image of the selected node. ValueType String Default Value -
SelectedExpandedImage | Description Gets or sets the expanded icon image of the selected node. ValueType String Default Value -
Tag | Description A holding custom info related to the node. ValueType String Default Value -
Text | Description Gets or sets the displayed text of the node. ValueType String Default Value -
Value | Description Gets or sets the value of the node. ValueType Object Default Value -
ToolTip | Description Gets or sets the tooltip text of the node. ValueType String Default Value -
Visible | Description Indicates whether the node is visible or invisible. ValueType Boolean Default Value True
ImageToolTip | Description Gets or sets the image tooltip text of the node. ValueType String Default Value -
NodeIndex | Description Internal parameter for incremental index in added node ValueType Integer Default Value -
AllowDrag | Description Specifies whether a node is allowed to be dragged or not. ValueType Boolean Default Value True
AllowDrop | Description Specifies whether a node is allowed to be dropped or not. ValueType Boolean Default Value True
MaxBindingDepth | Description Specifies relative maximum binding depth. ValueType Integer Default Value -1
ChildNodeExpandable | Description Specifies whether the child node is expandable. ValueType Boolean Default Value True

WebTreeViewNode Methods
AddNode Description
Adds a new node to a WebTreeViewNode instance.

Parameters
name ( String )
Name of the added node.
text ( String )
Text of the added node.

Remarks
-

Return Value
-

Samples
function btnAdd_Click()
{
var treeView = ISGetObject("WebTreeView1");
var node = treeView.GetSelectedNode();
var txt = document.getElementById("txtNewNode").value;

if(txt == "")
alert("Please type a text");
else
{
if(node != null)
node.AddNode(txt, txt);
 else
treeView.AddNode(txt, txt);
}
}
DeleteNode Description
Deletes the node in a WebTreeView instance.

Parameters
-

Remarks
-

Return Value
void

Samples

function btnDelete_Click()

{
var treeView = ISGetObject("WebTreeView1");
var node = treeView.GetSelectedNode();

if(node != null)
node.DeleteNode();
 else
alert("Please select a node");
}

Check Description
Checks a node in a WebTreeView instance.

Parameters
-

Remarks
-

Return Value
void

Samples

function Button1_onclick()
{
var tv = ISGetObject("WebTreeView1");

if (tv.GetSelectedNode()!=null)
tv.GetSelectedNode().Check();
else
alert("Please select a node");
}

CheckAll Description
Checks all node level in a WebTreeView instance.

Parameters
-

Remarks
-

Return Value
void

Samples
function Button1_onclick()
{
var tv = ISGetObject("WebTreeView1");
tv.CheckAll();
}
Collapse Description
Collapses a parent node in a WebTreeView instance.

Parameters
-

Remarks
-

Return Value
void

Samples

function Button2_onclick()
{
var tv = ISGetObject("WebTreeView1");

if (tv.GetSelectedNode()!=null)
{
tv.GetSelectedNode().Collapse();
}
else
alert("Please select a node first !");
}

Expand Description
Expands a parent node in a WebTreeView instance.

Parameters
-

Remarks
-

Return Value
void

Samples

function Button2_onclick()
{
var tv = ISGetObject("WebTreeView1");

if (tv.GetSelectedNode()!=null)
{
tv.GetSelectedNode().Expand();
}
else
alert("Please select a node first !");
}

GetCurrentIndex Description
Gets the current index of the selected node.

Parameters
-

Remarks
-

Return Value
Integer

Samples

Select Description
Selects a node in a WebTreeView instance.

Parameters
-

Remarks
-

Return Value
void

Samples

function Button1_onclick()
{

var tv = ISGetObject("WebTreeView1");
var node = tv.FindNodeByPath(document.getElementById("txtPath").value);
var divStatus = document.getElementById("divWebTreeView1Node");

divStatus.innerHTML = "";

if (node!=null)
{
node.Select();
 divStatus.innerHTML = "Node is found <br>Node name : " + node.Name;
}
else
{
divStatus.innerHTML = "Node is not found";
}

}

Navigate Description
Navigates a node to a URL specified in NavigateURL property.

Parameters
-

Remarks
-

Return Value
void

Samples

ToggleExpandCollapse Description
Toggles expand or collapse in a WebTreeView instance.

Parameters
-

Remarks
-

Return Value
void

Samples

function Button1_onclick()
{
var tv = ISGetObject("WebTreeView1");

if (tv.GetSelectedNode()!=null)
{
tv.GetSelectedNode().ToggleExpandCollapse();
}
else
alert("Please select a node first !");
}

UnCheck Description
Unchecks a node in a WebTreeView instance.

Parameters
-

Remarks
-

Return Value
void

Samples

function Button1_onclick()
{
var tv = ISGetObject("WebTreeView1");

if (tv.GetSelectedNode()!=null)
tv.GetSelectedNode().UnCheck();
else
alert("Please select a node");
}

UnCheckAll Description
Unchecks a node.

Parameters
-

Remarks
-

Return Value
void

Samples
function Button1_onclick()
{
var tv = ISGetObject("WebTreeView1");
tv.UnCheckAll();
}
ExpandHierarchyAndSelect Description
Expands and selects nodes in a hierarchy. It is useful when every node is collapsed initially.

Parameters
-

Remarks
-

Return Value
void

Samples

GetDivEl Description
Gets the div element of the related node.

Parameters
-

Remarks
-

Return Value
object (HTML div)

Samples

GetElementText Description
Gets the text element of the related node.

Parameters
-

Remarks
-

Return Value
object (HTML text)

Samples

function treeExpand()
{
var treeView = ISGetObject("WebTreeView1");
if(treeView != null)
{
treeView.GetNodes()[0].Expand();
treeView.GetNodes()[0].GetNodes()[2].GetElementText().style.fontWeight = "Bold";
treeView.GetNodes()[0].GetNodes()[7].GetNodes()[3].GetElementText().style.fontWeight = "Bold";

for(var i=2; i<4; i++)
treeView.GetNodes()[0].GetNodes()[7].GetNodes()[i].GetElementText().style.fontStyle = "Italic";
}
}

GetElementImgColEx Description
Gets the collapsed/expanded image of the related node if ShowLines or ShowExpandCollpase is set to true.

Parameters
-

Remarks
-

Return Value
object (IMG element)

Samples

GetElementImg Description
Gets the element of image's icon from the related node.

Parameters
-

Remarks
-

Return Value
object (IMG element)

Samples

GetElement Description
Gets the HTML element of the related node.

Parameters
-

Remarks
-

Return Value
object (TABLE element)

Samples

GetElementCheckBox Description
Gets the checkbox element of the related node.

Parameters
-

Remarks
-

Return Value
- HTML CheckBox (normal CheckBox type)
- IMG element (EnableTriStateCheckBox=true)

Samples

Click Description
Raises click's event for the related node.

Parameters
-

Remarks
-

Return Value
void

Samples

SetNodeStyleToOver Description
Method used for setting node's style to OverStyle.

Parameters
-

Remarks
-

Return Value
void

Samples

SetNodeStyleToActive Description
Method used for setting node's style to ActiveStyle.

Parameters
-

Remarks
-

Return Value
void

Samples

GetNodes Description
Gets a collection of WebTreeView's nodes.

Parameters
-

Remarks
-

Return Value
object (WebTreeViewNodeCollection)

Samples

function Button1_onclick()
{
var tv = ISGetObject("WebTreeView1");
tv.GetNodes().GetNamedItem("Sports").GetNodes().GetNamedItem("Outdoor Sports").SetChecked(true);
}
GetSequence Description
Gets the index of a node viewed from the entire nodes in WebTreeView.

Parameters
-

Remarks
-

Return Value
Integer

Samples

GetImage Description
Gets the icon image of the node.

Parameters
-

Remarks
-

Return Value
String

Samples

SetImage Description
Sets the icon image of the node.

Parameters
value ( String )
The value of the image's icon.

Remarks
-

Return Value
String

Samples

GetNodeType Description
Gets the type of a node, whether it is a root node, parent node, or leaf node.

Parameters
-

Remarks
-

Return Value
NodeType

Samples

GetParentNode Description
Gets whether the specified node is a parent node and has at least one child node.

Parameters
-

Remarks
-

Return Value
object (WebTreeViewNode)

Samples

function doWebTreeView1NodeSelect(ctrlId, node)
{
var tv = ISGetObject(ctrlId);
var parentNode = node.GetParentNode();
}
GetPreviousSibling Description
Gets the previous node (in the same level) of the specified node.

Parameters
-

Remarks
-

Return Value
object (WebTreeViewNode)

Samples
function doWebTreeView1NodeSelect(ctrlId, node)
{
var tv = ISGetObject(ctrlId);
var parentNode = node.GetPreviousSibling();
}
GetNextSibling Description
Gets the next node (in the same level) of the specified node.

Parameters
-

Remarks
-

Return Value
object (WebTreeViewNode)

Samples
function doWebTreeView1NodeSelect(ctrlId, node)
{
var tv = ISGetObject(ctrlId);
var parentNode = node.GetNextSibling();
}
GetPreviousNode Description
Gets the previous node of the specified node.

Parameters
-

Remarks
-

Return Value
object (WebTreeViewNode)

Samples
function doWebTreeView1NodeSelect(ctrlId, node)
{
var tv = ISGetObject(ctrlId);
var parentNode = node.GetPreviousNode();
}
GetNextNode Description
Gets the next node of the specified node.

Parameters
-

Remarks
-

Return Value
object (WebTreeViewNode)

Samples
function doWebTreeView1NodeSelect(ctrlId, node)
{
var tv = ISGetObject(ctrlId);
var parentNode = node.GetNextNode();
}
GetPreviousVisibleNode Description
Gets the previous visible node of the specified node.

Parameters
-

Remarks
-

Return Value
object (WebTreeViewNode)

Samples

function doWebTreeView1NodeSelect(ctrlId, node)
{
var tv = ISGetObject(ctrlId);
var parentNode = node.GetPreviousVisibleNode();
}
GetNextVisibleNode Description
Gets the next visible node of the specified node.

Parameters
-

Remarks
-

Return Value
object (WebTreeViewNode)

Samples
function doWebTreeView1NodeSelect(ctrlId, node)
{
var tv = ISGetObject(ctrlId);
var parentNode = node.GetNextVisibleNode();
}
GetPath Description
Gets the path of a node, path from the root node to the node itself.

Parameters
-

Remarks
-

Return Value
String

Samples
function doWebTreeView1NodeSelect(ctrlId, node)
{
var tv = ISGetObject(ctrlId);
document.getElementById("tdPath").innerHTML = node.GetPath();
}
GetExpandedImage Description
Gets or the expanded icon image of the node.

Parameters
-

Remarks
-

Return Value
String

Samples

GetSelectedExpandedImage Description
Gets the expanded icon image of the selected node.

Parameters
-

Remarks
-

Return Value
String

Samples

GetImage Description
Gets the icon image of the node.

Parameters
-

Remarks
-

Return Value
String

Samples

SetExpanded Description
Sets whether the node is currently expanded or not.

Parameters
val ( Boolean )

Remarks
-

Return Value
Boolean

Samples

function Radio1_onclick()
{
document.getElementById("Radio2").checked = true;
document.getElementById("Radio1").checked = false;

var tv = ISGetObject("WebTreeView1");

if (tv.GetSelectedNode()!=null)
tv.GetSelectedNode().SetExpanded(true);
 else
alert("Please select a node first !");
}

SetSelected Description
Sets whether the node is selected or not.

Parameters
val ( Boolean )

Remarks
-

Return Value
Boolean

Samples

SetEnabled Description
Sets whether the node is enabled or disabled.

Parameters
val ( Boolean )

Remarks
-

Return Value
Boolean

Samples

function Button1_onclick()
{
var path = document.getElementById("txtPath").value;

if (path!=null && path!="")
{
var tv = ISGetObject("WebTreeView1");
var node = tv.FindNodeByPath(path);

if (node!=null)
node.SetEnabled(true);
 else
alert("path is not found");
}
else
alert("path is not found");
}
SetText Description
Sets the displayed text of the node.

Parameters
val ( String )
The value of the text.

Remarks
-

Return Value
String

Samples
function Update()
{
var tv = ISGetObject("WebTreeView1");
var txtText = document.getElementById("txtText");
var txtToolTip = document.getElementById("txtToolTip");
var node = tv.GetSelectedNode();

if (node!=null)
{
if(txtText.value != "")
node.SetText(txtText.value);
if(txtToolTip.value != "")
node.SetToolTip(txtToolTip.value);
}
else
alert("Please select a node first !");
}
SetToolTip Description
Sets the tooltip text of the node.

Parameters
val ( String )
The value of tooltip.

Remarks
-

Return Value
String

Samples
function Update()
{
var tv = ISGetObject("WebTreeView1");
var txtText = document.getElementById("txtText");
var txtToolTip = document.getElementById("txtToolTip");
var node = tv.GetSelectedNode();

if (node!=null)
{
if(txtText.value != "")
node.SetText(txtText.value);
if(txtToolTip.value != "")
node.SetToolTip(txtToolTip.value);
 }
else
alert("Please select a node first !");
}
SetTextImageToolTip Description
Sets the text image tooltip of the node.

Parameters
val ( String )
The value of TextImage's tooltip.

Remarks
-

Return Value
String

Samples

SetImageToolTip Description
Sets the image tooltip text of the node.

Parameters
val ( String )
The value of image's tooltip.

Remarks
-

Return Value
String

Samples

SetName Description
Sets the name of the node.

Parameters
val ( String )
The name of the node.

Remarks
-

Return Value
String

Samples

SetImage Description
Sets the icon image of the node.

Parameters
val ( String )
The value of icon image.

Remarks
-

Return Value
String

Samples

IsVisibleFirstNode Description
Indicates whether the first node in its collection is visible.

Parameters
-

Remarks
-

Return Value
Boolean

Samples

IsVisibleLastNode Description
Indicates whether the last node in its collection is visible.

Parameters
-

Remarks
-

Return Value
Boolean

Samples

HasVisibleNodes Description
Indicates whether the visible node exists.

Parameters
-

Remarks
-

Return Value
Boolean

Samples

BeginEditingNode Description
Method used for triggering node editing.

Parameters
-

Remarks
-

Return Value
void

Samples

EndEditingNode Description
Method used for terminating node editing.

Parameters
-

Remarks
-

Return Value
void

Samples


WebTreeViewNodeSettings

WebTreeViewNodeSettings
Send Feedback
Intersoft WebTreeView > Client-side References > WebTreeViewNodeSettings

Glossary Item Box

WebTreeViewNodeSettings Properties

EnableAnimation | Description Determines whether the animation is enabled or disabled. ValueType Boolean Default Value False
EnableOpacityOnAnimation | Description Determines whether the opacity is enabled or disabled when animation is enabled. ValueType Boolean Default Value False
TargetWindow | Description Determines the target window value for Node. ValueType String Default Value -


WebTreeViewImagesSettings

WebTreeViewImagesSettings
Send Feedback
Intersoft WebTreeView > Client-side References > WebTreeViewImagesSettings

Glossary Item Box

WebTreeViewImagesSettings Properties

CollapseImage | Description Gets or sets the image which will be used as collapse image. ValueType String Default Value -
LeafNodeImage | Description Gets or sets the image which will be used as leaf node image. ValueType String Default Value -
ParenNodeImage | Description Gets or sets the image which will be used as parent node image. ValueType String Default Value -
ExpandedParentNodeImage | Description Gets or sets the image which will be used as expanded parent node image. ValueType String Default Value -
RootNodeImage | Description Gets or sets the image which will be used as root node image. ValueType String Default Value -
ExpandedRootNodeImage | Description Gets or sets the image which will be used as expanded root node image. ValueType String Default Value -
CheckBoxTrueImage | Description Gets or sets the image which will be used as checkbox true image. ValueType String Default Value -
CheckBoxPartialImage | Description Gets or sets the image which will be used as checkbox partial image. ValueType String Default Value -
DashminusImage | Description Gets or sets the image which will be used as node's dash minus image. ValueType String Default Value -
DashplusImage | Description Gets or sets the image which will be used as node's dash plus image. ValueType String Default Value -
LImage | Description Gets or sets the image which will be used as left node's dash image. ValueType String Default Value -
LplusImage | Description Gets or sets the image which will be used as left node's dash plus image. ValueType String Default Value -
NoexpandImage | Description Gets or sets the image which will be used as node's no-expand image. ValueType String Default Value -
RImage | Description Gets or sets the image which will be used as right node's dash image. ValueType String Default Value -
RplusImage | Description Gets or sets the image which will be used as right node's dash plus image. ValueType String Default Value -
TminusImage | Description Gets or sets the image which will be used as node's dash Tminus image. ValueType String Default Value -
TplusImage | Description Gets or sets the image which will be used as node's dash Tplus image. ValueType String Default Value -


WebTreeViewAutoPostBackSettings

WebTreeViewAutoPostBackSettings
Send Feedback
Intersoft WebTreeView > Client-side References > WebTreeViewAutoPostBackSettings

Glossary Item Box

WebTreeViewAutoPostBackSettings Properties

OnNodeCheckChanged | Description Specifies WebTreeView to perform auto postback OnNodeCheckChanged. ValueType Boolean Default Value False
OnNodeCollapse | Description Specifies WebTreeView to perform auto postback OnNodeCollapse. ValueType Boolean Default Value False
OnNodeExpand | Description Specifies WebTreeView to perform auto postback OnNodeExpand. ValueType Boolean Default Value False
OnNodeRename | Description Specifies WebTreeView to perform auto postback OnNodeRename. ValueType Boolean Default Value False
OnNodeSelectChanged | Description Specifies WebTreeView to perform auto postback OnNodeSelectedChanged. ValueType Boolean Default Value False
OnNodeEdit | Description Specifies WebTreeView to perform auto postback OnNodeEdit. ValueType Boolean Default Value False
OnDragDrop | Description Specifies WebTreeView to perform auto postback OnDragDrop. ValueType Boolean Default Value False


WebTreeView Global Functions
Send Feedback
Intersoft WebTreeView > Client-side References > WebTreeView Global Functions

Glossary Item Box

WebTreeView Global Functions
InitWebTreeView Description
Creates WebTreeView object with its default settings from server side, attach WebTreeView behaviors, and initialize it.

Parameters
id ( String )
WebTreeView client side control ID (same as server side ID)
nodeIndex ( Int )
Internal parameter for incremental index in added node

Return Value
object (WebTreeView)

Samples


Product Support

Product Support
Send Feedback
Intersoft WebTreeView > Product Support

Glossary Item Box

This section contains product support in WebTreeView.NET.

In This Section

Bug Reports

Support Options


Bug Reports

Bug Reports
Send Feedback
Intersoft WebTreeView > Product Support > Bug Reports

Glossary Item Box

Please submit any bugs or product issues to webtreeviewsupport@intersoftpt.com

When submitting the bug report, make sure you have following information to avoid multiple communication roundtrip:

  • Product Edition (if applicable)
  • Full Product Version. Eg: 1.0.1500
  • Browsers (with Full Version, including Service Packs or HotFixes if any)
  • Operating System (with Full Version, including Service Packs or HotFixes if any)
  • Development Environment Products
  • Development Environment Versions
  • Affected Machines: Development, Production Server or Both
  • Monitors: Single or Dual

You also might need to provide issue-specific information such as:

  • Current result/behavior
  • Expected result/behavior
  • Steps to reproduce
  • Working/Compilable Samples


Support Options

Support Options
Send Feedback
Intersoft WebTreeView > Product Support > Support Options

Glossary Item Box

WebTreeView.NET is developed and fully supported by Intersoft Solutions Corp. The company provides several methods for registered customers to obtain technical supports.

Online Support

All of WebTreeView.NET users have free access to our online support at www.intersoftpt.com which includes latest product updates, bug fixes, FAQ, hundreds of Knowledge Base Articles.

Standard Email Support

You can also send email to webtreeviewsupport@intersoftpt.com for product troubleshooting or bugs. Please provides information on the product version, operating system name and version as well as your development environment and its version. Your email will be answered shortly by our technical support team.

The turnaround time for standard email support is 72 hours (at the latest).

Before sending out your email, we highly recommend you to initially search for the information on locally installed Reference and Online Support.

Developer Network Support

The company provides a rich web-based forums for registered customers to discuss about the product. You may find information and answer to your questions in the forums, or simply posting your message in the forums and our technical support team will answer it in short time.

To access the Developer Network, please go to Intersoft website and click on Developer Network.

Login details are required to access Developer Network. Please refer to your original order receipt sent from Intersoft Accounts. If you do not get the automated order receipt, please contact accounts@intersoftpt.com

Priority Support Options

The NEW Priority Support option allows registered customers to obtain technical support via direct e-mail or telephone support from our Senior Support Engineer.

This option is designated for advanced customers who require faster response time. The inquiries types are mostly intermediate to advanced involving application-specific scenarios, minor feature requests, quick patches and more.

For more information about the Priority Support pricing and online purchase, please visit Intersoft Solutions web site at http://www.intersoftpt.com

Phone Support

Phone Support is currently available only for registered customers who have purchased Priority Support. You can reach Technical Support through following numbers:

  • +62 21 25556680
  • +62 21 25556681
Please have your UserID ready when calling.

For pre-sales phone support, you may contact our Authorized Distributor at no cost.


Licensing

Licensing
Send Feedback
Intersoft WebTreeView > Licensing

Glossary Item Box

This section contains licensing in WebTreeView.NET.

In This Section

License Agreement

Copyright Information


License Agreement

License Agreement
Send Feedback
Intersoft WebTreeView > Licensing > License Agreement

Glossary Item Box

Software License Agreement for Intersoft Solutions Corp.

VERY IMPORTANT -- By installing the WebTreeView.NET Version 1.0 software (herein the 'SOFTWARE') developed by Intersoft Solutions Corp (hereinafter the 'VENDOR'), you are accepting the following License Agreement.

I. LICENSE AGREEMENT. This is a legal agreement between you (either an individual or a single entity) and VENDOR. By installing the SOFTWARE you are agreeing to be bound by the terms of this agreement. If you do not agree to the terms of this agreement, please kindly click the [CANCEL] icon to exit now. The installation process will be immediately terminated.

II. OWNERSHIP; GRANT OF LICENSE. This is a license agreement and NOT an agreement for sale. The VENDOR hereby grants to you, and you accept, a non-exclusive, non-transferable license to use, copy and modify the SOFTWARE only as authorized below.

III. PERMITTED USES. This LICENSE grants you the following rights:

A. The SOFTWARE is licensed per individual developer. You may make copies on more than one computer, as long as the use of the SOFTWARE is by the same developer. If you have purchased a "multi-pack" license, you may use a copy of the SOFTWARE identified in the multi-pack on the number of computers associated with the multi-pack (e.g. a five user multi-pack allows you to use the SOFTWARE on up to five computers concurrently or by five different developers, the ten user multi-pack on up to ten computers concurrently or by ten different developers). The SOFTWARE is in "use" on a computer when it is loaded into temporary memory (i.e. RAM) or installed into permanent memory (e.g. hard disk, CD-ROM, or other storage devise) of that computer. However, installation on a network server for the sole purpose of internal distribution to one or more other computer(s) shall not constitute "use" for which a separate license is required, provided you have a separate license for each computer to which the SOFTWARE is distributed.

B. Solely with respect to electronic documents included with the SOFTWARE, you may make a copy (either in hardcopy or electronic form) for each developer for which the Software has been licensed as described in Section III.A, above; provided, that such copies shall be used only by such developer for internal purposes and are not to be republished or distributed to any other third party.

C. Runtime and redistributable files. You may deploy your web applications using the SOFTWARE to any number of production server or clients with no additional charges. The SOFTWARE runtime files shouldn't be modified in any ways prior to deploying and all copyright notices should be retain.

IV. PROHIBITED USES. You may not, without the prior written permission of the VENDOR:

A. Disassemble, decompile or "unlock", decode or otherwise reverse translate or engineer, or attempt in any manner to reconstruct or discover any source code or underlying algorithms of SOFTWARE provided in object code form only.

B. Use, copy, modify, or merge copies of the SOFTWARE and any accompanying documents except as permitted in this LICENSE.

C. Transfer, rent, lease, or sublicense the SOFTWARE.

D. Separate the software programs comprising the SOFTWARE for use by more than one user at a time.

V. COPYRIGHT. All title and copyrights in and to the SOFTWARE (including but not limited to any images, photographs, animation, video, audio, music, text and "applets" incorporated into the SOFTWARE) and the accompanying printed materials are owned by the VENDOR or its suppliers. The SOFTWARE is protected by Indonesian copyright laws and international treaty provisions. All rights are reserved worldwide. You must treat the SOFTWARE like any other copyrighted material, except that you may, in addition to the copies permitted in this LICENSE, make one copy of the SOFTWARE solely for backup or archival purposes. No part of the accompanying printed materials may be reproduced, transmitted, transcribed, stored in any retrieval system, or translated into any language by any means without the express prior written permission of the VENDOR.

VI. TERMINATION

A. This LICENSE and your right to use the SOFTWARE will terminate immediately without notice from the VENDOR if you fail to comply with the terms and conditions of this LICENSE. Upon termination, you agree to destroy the SOFTWARE, including all accompanying documents and copies. This is in addition to and not in lieu of any criminal, civil or other remedies available to the VENDOR.

B. The VENDOR has the right to perform temporary or permanent TERMINATION to this LICENSE upon the detection of license violation described in Section III A. The SOFTWARE has implemented Installation Tracker which is used to increment the number of installations during the installation of SOFTWARE. Related to Section III A, the LICENSE will be temporarily or permanently terminated upon the detection of unauthorized transfer or distribution of the LICENSE to either private or public web site, or to ANY medium.

C. ANY VIOLATION TO THE COPYRIGHT, OR TO THIS LICENSE AGREEMENT, MAY RESULT IN SEVERE CIVIL AND CRIMINAL PENALTIES, AND WILL BE PROSECUTED TO THE MAXIMUM EXTENT POSSIBLE UNDER THE LAW.

VII. LIMITED WARRANTY.

A. The VENDOR warrants that the SOFTWARE will perform substantially in accordance with the accompanying printed materials or officially "online" documented materials for a period of thirty (30) days from the date of receipt. The VENDOR does not warranty that the SOFTWARE will be error-free.

B. Your exclusive remedy under the performance warranty set forth in Section X.A, shall be, at VENDOR's option, either (a) return of the purchase price paid, or (b) repair or replacement of the defective SOFTWARE. SOFTWARE purchased other than directly from the VENDOR shall be returned to the place it was purchased. This limited warranty is void if failure of the SOFTWARE has resulted from accident, abuse, or misapplication. Any replacement SOFTWARE will be warranted for the remainder of the original thirty (30) day period.


Copyright Information

Copyright Information
Send Feedback
Intersoft WebTreeView > Licensing > Copyright Information

Glossary Item Box

Information in this document, including URL and other Internet Web site references, is subject to change without notice. Complying with all applicable copyright laws is the responsibility of the user. Without limiting the rights under copyright, no part of this document may be reproduced, stored in or introduced into a retrieval system, or transmitted in any form or by any means (electronic, mechanical, photocopying, recording, or otherwise), or for any purpose, without the express written permission of Intersoft Solutions Corp.

Intersoft Solutions, Intersoft Solutions Logo, A Better Web Experience, WebUI.NET Framework, WebUI.NET Framework Logo, WebUI Studio.NET Family, WebCombo.NET, WebGrid.NET Enterprise, WebInput.NET, WebUIControls.NET, ISDataSource.NET, WebDesktop.NET, WebTreeView.NET are either trademarks or registered trademarks of Intersoft Solutions Corporation.

Copyright © 2000-2007 Intersoft Solutions Corp. All rights reserved.

ActiveX, Internet Explorer, Microsoft, Visual Basic, Visual Basic .NET, Visual C# .NET, Visual C++ .NET, Visual Studio, Visual Studio .NET, Windows, Windows 95, Windows 98, Windows 2000, Windows Millennium Edition, Windows .NET server family, Windows NT, Windows XP and Windows Vista are either registered trademarks or trademarks of Microsoft Corporation in the United States and/or other countries.

The names of actual companies and products mentioned herein may be the trademarks or registered trademarks of their respective owners.


Walkthrough: Binding WebGrid to AccessDataSource control

Walkthrough: Binding WebGrid to AccessDataSource control
Send Feedback

Glossary Item Box

This walkthrough shows you how to create and bind WebGrid to an AccessDataSource control.

During this walkthrough, you will learn how to do the following:

  • Use AccessDataSource.
  • Use SmartTag to set DataSource.
  • Use Data Source Configuration Wizard to set the Database and table.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Access to the Microsoft Access Northwind database.
  • Visual Studio 2005/2008/2010 Application.

Step-By-Step Instructions

To create new web application and bind WebGrid to AccessDataSource

  1. Launch Visual Studio.NET 2008.
  2. Click on File menu, then select New and click Web Site.
  3. Select ASP.NET Web Site in the Template box and set Location to HTTP.
  4. Named the Web Site and click OK.
  5. Right-click on Project's name and select Add New Item.
  6. Select Intersoft AppForm in the My Templates box and named it as Walkthrough.aspx.
  7. Drag WebGrid instance from ToolBar to WebForm.
  8. In the Solution Explorer, right-click on App_Data and select Add Existing Item.
  9. Browse and add NorthWind.mdb in C:\Program Files\Intersoft Solutions\Data (Default installation folder).
  10. Click the SmartTag on the upper right of the WebGrid.
  11. In Choose Data Source field, choose <New data source...>.

  12. In Data Source Configuration Wizard, choose AccessDatabase and click OK.

  13. Browse and select the database in App_Data (NorthWind.mdb) and click OK.

  14. Select the table that you want to use and click Next.

  15. In this step, you can view the table's database using Test Query button. Otherwise, click Finish to proceed to the next step.
  16. Finally, choose Retrieve Structure action in Connected to Data Source Control Wizard and click OK to apply all settings.

  17. Run the project and the WebGrid will look like following.


Event sequence of server side events

Event sequence of server side events
Send Feedback

Glossary Item Box

SUMMARY

There are many events in WebGrid, for example InitializeLayout, InitializeDataSource, PrepareDataBinding, etc. The purpose of this article is to give better explanation about which parts of codes are better placed in certain events and also the sequence of the events when they are executed during the first time the page is loaded.

MORE INFORMATION

The events sequence ordering in WebGrid.NET are (During Not On The FlyPostBack):

  1. WebGrid_ PreInitialize
  2. WebGrid_Initialize
  3. Page_Load : Event loading of the current page
  4. WebGrid_InitializeLayout : Layout initialization such as assigning static behavior, appearance and styles
  5. WebGrid_InitializeDataSource : Data source initialization
  6. WebGrid_PrepareDataBinding : Column structure retrieval and creation of necessary objects
  7. WebGrid_Load : Indication of successfully preparation of data binding process and data populating in all rows
  8. <<ServerControl Events>> - if Page.IsPostBack: Execution of server control events such as Button1_Click
  9. Page_PreRender
  10. ...
  11. WebGrid_Load
  12. WebGrid_PreRender
  13. ...
  14. Page_SaveViewState
  15. Page_Render
  16. ...
  17. WebGrid_InitializeTable
  18. WebGrid_InitializeColumn
  19. WebGrid_InitializeRow
  20. WebGrid_InitializeCell
  21. ...
  22. WebGrid_Unload

The events sequence ordering in WebGrid.NET are (During On The Fly PostBack):

  1. WebGrid_PreInitialize : Control initialization
  2. WebGrid_Initialize
  3. Page_Load : Event loading of the current page
  4. WebGrid_InitializeLayout : Layout initialization such as assigning static behavior, appearance and styles
  5. WebGrid_InitializeDataSource : Data source initialization
  6. WebGrid_PrepareDataBinding : Column structure retrieval and creation of necessary objects
  7. WebGrid_Load : Indication of successfully preparation of data binding process and data populating in all rows
  8. WebGrid_InitializePostback
  9. WebGrid_Unload

WebGrid_PrepareDataBinding process preceeds the WebGrid_Load process so that all data has been populated and can be accessed further in WebGrid_Load event. WebGrid_PrepareDataBinding process succeeds the WebGrid_Load process and that caused many limitation because certain objects can not be accessed effectively in any of page's events.

In ordinary ASP.NET control lifecycle methodology, the server events are always fired after Page_Load event. The purpose is obviously to allow access to all objects which should have been loaded during Initialization and Load event. The WebGrid.NET now has followed this methodology which can be seen from the current events sequence.

In this article, certain important events will be explained extensively in order to give a good programming style of where to place certain codes in proper events in WebGrid. The advantage of following this style is to utilize the advantages of WebGrid component extensively such as data caching feature is enabled if the assignment of WebGrid data source is placed in InitializeDataSource event.

  • WebGrid_ InitializeDataSource event

All codes related to the assignment of data source to the WebGrid component should be placed here. Since in this event, an instance of DataSourceEventArgs can be obtained, so the assignment code should be :
e.DataSource = DSName; // --> instead of WebGrid1.DataSource = DSName; Avoid assigning the DataSource property to the Grid object such as WebGrid.DataSource = DSName, since in the InitializeDataSource event, developers could obtain an object of DataSourceEventArgs here using e.

Codes that related to the DataTable structure creation, DataSet populating process with the DataAdapter and so many data related task could be processed here. In the conclusion, only data populating related codes should be placed here, no process of assigning WebGrid layout should be placed as depicted from the event name (InitializeDataSource)

There is no problem at all when bind the grid to the DataSource at DesignTime as can be depicted from the most of the WebGrid's samples and tutorials. Actually what's the difference between DesignTime binding and Runtime Binding ? DesignTime binding is used when the DataSource is relatively static and can be obtained at the design time without needing the web application to be run first. In example showing the Customers table in the grid. Runtime binding is a more complex scenario when the DataSource can't be obtained at Design Time and the grid needs to wait for users' selection in order to select which particular data source needs to be binded to the grid. In example a dropdownlist will show a list of tables to the users. The grid will be in invisible mode until users select a table from the dropdownlist. In this scenario, obviously it's not possible to bind a certain data source to the grid, so the solution is by waiting for a button_click event (for example) in order to switch the data source. Since the server control events will be invoked after the grid's events, then developers need to invoke ClearCachedDataSource() along with RebindDataSource() in order to force the grid to invoke the InitializeDataSource event once more. Then in that event, developers could programmatically switch the data source to be binded to the grid according to users selection. If the data source can't be decided at page_load then it is necessary to assign null to the grid's data source such as this : grid.DataSource = null; otherwise a classic error message will be produced such as this "Please set WebGrid1's datasource e.g. WebGrid1.DataSource = NorthWindLookups.GetProductList();"

  • WebGrid_PrepareDataBinding event

WebGrid has successfully binded its DataSource which defined using e.DataSource. In this event, developers can conveniently populate all the columns structure. There are many cases that developers often forgot to place all "object creation" codes under !IsPostBack condition, so please remember to place WebGrid1.RetrieveStructure() or WebGrid1.RetrieveHierarchicalStructure() under !IsPostBack condition. There are cases such as users has utilized resizing columns, sorting and grouping features and invoked PostBack to the server, but after the PostBack all the features applied are overrided back to the first configuration erasing all features that have been applied.

When the InitializeDataSource event is invoked and the codes inside the InitializeDataSource event are executed, WebGrid will proceed to invoke the PrepareDataBinding event automatically. If there is no single codes to be executed in the InitializeDataSource, then the grid will simply skip the PrepareDataBinding event.

There are some cases that developers would like to invoke InitializeDataSource event in order to assign a new DataSource to the WebGrid in the certain events such as Button1_Click event. The solution for that case is by simply invoking WebGrid1.ClearCachedDataSource() to remove all cached DataSource and proceed by invoking WebGrid1.RebindDataSource(). Whenever RebindDataSource method is invoked, WebGrid will automatically reinvoke InitializeDataSource event, so the concept of centralized DataSource initialization still persist.

Another issue is about the difference between using old tradition DataBind compared to using RebindDataSource in version 3.5. The data binding process can be processed only once in the internal processing. In order to overcome that limitation, a new method called RebindDataSource is introduced in order to invoke the InitializeDataSource event once again, but it is under one condition that ClearCachedDataSource is invoked first before invoking RebindDataSource, otherwise RebindDataSource will only invoke PrepareDataBinding event because there is a cache maintained inside the WebGrid.

  • WebGrid_InitializeLayout event

InitializeLayout event is originally designed to let developers programmatically configure static WebGrid's behavior, appearance, look and feel, styles etc. It is quite easy to configure the layout by just using e.Layout , since in this event developers could obtained the LayoutSetting properties from LayoutEventArgs. No dynamic objects or data related settings should be placed here especially if those objects are created during runtime.

This event is also an important event in order to modify the grid's layout and styles. All the layout settings could be configured and persisted here while it will be ignored at other events. Pay attention to the events sequences for developers who use Runtime Binding. Since the InitializeLayout event will be called before InitializeDataSource event and PrepareDataBinding event, then it won't be possible for grid to obtain the tables' name and columns' name. Try to reference this : WebGrid1.RootTable.Columns.GetNamedItem("CustomerID").CellStyle.HorizontalAlign = HorizontalAlign.Center, then developers will get the "Object Error", because the tables and columns population are created using either RetrieveStructure() or RetrieveHierarchicalStructure() at PrepareDataBinding. So what's the solution then ?

The solution is by manually configuring the root table and its child tables along with all columns at InitializeLayout event, such as this :

WebGrid1.RootTable = null;
WebGrid1.RootTable.Columns.Clear();
WebGrid1.RootTable.ChildTables.Clear();
WebGrid1.RootTable.DataMember = "Customers";
WebGrid1.RootTable.DataKeyField = "CustomerID";
foreach(string col in UseProfileRoot)
{
WebGrid1.RootTable.Columns.Add(new WebGridColumn(col, col, col));
}

WebGridTable childTable = new WebGridTable();
childTable.DataMember = "Orders";
childTable.DataKeyField = "OrderID";
foreach(string col in UseProfileChild)
{
childTable.Columns.Add(new WebGridColumn(col, col, col));
}
WebGrid1.RootTable.ChildTables.Add(childTable);

For developers who use Runtime Binding, make sure that the RootTable is null along with its child tables and also all columns, in order to avoid the clash between old data source and the new data source. The sign of conflict can be seen when the project is running and producing "The assign column ..... can't be found in the DataSource"

All the events ordering explained above are only applied during the first time the page is loaded and also during "normal" PostBack condition. It is not applied during OnTheFly PostBack. The reason behind that is because WebGrid is developed to avoid duplication calling of those all events. The duplication calling is avoided because the "action" against a request could be only performed after WebGrid_Load event. That is one reason why WebGrid PostBack process is much faster compared to the other conventional server controls. Here are the following comparison :

Conventional Server Control PostBack Process

  1. Init
  2. RestoreViewState (All objects are restored in this point which makes the process slow, in example 500 records of rows)
  3. Load
  4. RaisePostBackEvent (All objects are recreated again due to DataBinding process in order to response an action)

WebGrid OnTheFly PostBack Process

  1. Init
  2. RestoreViewState (Only restore dynamic objects and modified objects, no data population here, so there would be no problem even there are 1000 records)
  3. Load
  4. RaisePostBackEvent (Invoke InitDataSource or obtain from cache if data is cached and call other required events), continue to populate data according to user's action)

As can be seen from the comparison table, RestoreViewState process is extremely fast here (1 point), FlyPostBackHandler will use cached data (AutoDataCache feature - 1 point) and finally all data are populated directly based on user's action (1 point). So in the conclusion WebGrid is 3x times faster compared to conventional server control.


Features and benefits introduced by SmartWebResources™

Features and benefits introduced by SmartWebResources™
Send Feedback

Glossary Item Box

Here are lists of all features and benefits in SmartWebResources�?�:

  • Better throughput: IIS6 Kernel-level Caching
  • More secure: Does not use query string
  • Faster performance: Does not use Reflection. The SmartWebResources does not use WebResourceAttribute mechanism, so avoiding the needs to use Reflection.
  • Smaller output: Simpler path formatting and does not use long-encrypted string. For instance, the built-in ASP.NET 2.0�??s Web Resource commonly produced a web resource url such as /WebResource.axd?d=X3DBWN0WSNooBvJskjFXaHbLs_89EdATLyWdaCXXWBuO_EqnAFr_Di1ag4ubAsDdMu4h_k0tff_bX4YhT_csWQ2&t=632939437740000000. In SmartWebResources, the output url format is as simple as /ISRes.axd?C/WebCombo.js/4072001
  • Hassle-free Deployment: No more external client resources are required during deployment. Only one assembly is required to be copied into your app's bin folder.
  • Reduced Complexity: SmartWebResources includes automatic web resources configuration. When in auto mode, the client resources will be retrieved from Web Resources assembly whenever possible. Otherwise, it will automatically fallback the retrieval from traditional external resources which stored in IIS virtual directory (also known as CommonLibrary)
  • Easy to Configure: Easily configure the settings from application level. You can also customize the settings for individual control's instances for more precise control.
  • Flexibility: You can easily switch between SmartWebResources or external resources mode through EnableWebResources setting.
  • Seamless integration with VS 2005: The handlers and resources configuration can seamlessly added to your web application configuration.
  • FileSystem Project Support: For better design-time experience in FileSystem web project, the image resources are now properly displayed in the Visual Studio 2005 designer. Thanks to SmartWebResources Framework that provides automatic url conversion mechanism in design-time.


How does SmartWebResources™ work

How does SmartWebResources™ work
Send Feedback

Glossary Item Box

Each product has their own resources such as scripts and images. For instance, previously these resources are stored in /CommonLibrary/Shared for core framework resources. WebGrid�??s resources are stored in /CommonLibrary/WebGrid/v4_0_6200.

With SmartWebResources, they are now embedded into .NET assembly. Unlike ASP.NET�??s built-in Web Resources which embeds client resources in main assembly, SmartWebResources stores each product�??s client resources in separate assembly. This enables flexible update (maintenance) to the client resources without has to rebuild the main server-side assembly.
SmartWebResources implements each product�??s client resources as separate resources assembly. Each product that supports SmartWebResources technology will have a companion resources assembly. The resources assembly commonly has this format: [ProductAssemblyFullName].Resources.dll.
For instance, the assembly hierarchy for WebCombo.NET 4.0 looks like in the following illustration:

The SmartWebResources works by intercepting the HTTP request through custom HTTP handler that extended in the Framework runtime. The SmartWebResources will then dispatch the request and automatically determining the correct resources assembly, then finally fetching the resource from the assembly and deliver it to the client.
The way it works can be seen in the following illustration:

With SmartWebResources enabled, you no longer need to aware what you should do to configure the client scripts virtual directory, or where to locate/store it. You simply ensure that the resources assemblies are in the Bin folder of your application. For more information, read How-to: Configure SmartWebResources in a new web application.


Introducing SmartWebResources™

Introducing SmartWebResources™
Send Feedback

Glossary Item Box

ASP.NET 2.0 introduced Web Resources feature, which allows developers to embed the client resources into assemblies. They are fetched through the built-in WebResource.axd HTTP Handler that is specially designed for this purpose.

However, our SmartWebResources technology does not use the built-in ASP.NET 2.0�??s Web Resources due to several limitations and inflexibility and thus does not meet our requirements and does not suit into our products mechanism.

SmartWebResources�?� is designed to overcome the limitations of ASP.NET 2.0�??s Web Resources. Furthermore, it is developed with more advanced functionality and with better performance since it does not use Reflection.

SmartWebResources�?� takes advantage of custom HTTP Handler extensibility and tightly integrated into WebUI.NET Framework runtime to deliver high performance, secure and highly reusable components.


Assembly Overview

ISNet.WebUI.WebTreeView Assembly
See Also Send Feedback

Glossary Item Box

Namespaces

Namespace | Description
ISNet.WebUI.WebTreeView |


Getting Started - Intersoft WebTreeView Documentation

Getting Started
Send Feedback

Glossary Item Box


Introduction - Intersoft WebTreeView Documentation

Introduction
Send Feedback

Glossary Item Box


WebTreeView Class Fields

[image]
Intersoft WebTreeView Documentation
WebTreeView Class Fields
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace : WebTreeView Class

Glossary Item Box

For a list of all members of this type, see WebTreeView members.

Protected Fields

 | Name | Description
Protected Field | isPagePreRender | (Inherited from ISNet.WebUI.ISNetControl)
Protected Field | renderDHTML | (Inherited from ISNet.WebUI.ISNetControl)
Protected Field | renderNS | (Inherited from ISNet.WebUI.ISNetControl)
Protected Field | viewStateLoaded | (Inherited from ISNet.WebUI.ISNetControl)
Top

See Also

Reference

WebTreeView Class
ISNet.WebUI.WebTreeView Namespace

Concepts

Overview


WebTreeViewAutoPostBackSettings Class Methods

[image]
Intersoft WebTreeView Documentation
WebTreeViewAutoPostBackSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace : WebTreeViewAutoPostBackSettings Class

Glossary Item Box

For a list of all members of this type, see WebTreeViewAutoPostBackSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

Protected Methods

 | Name | Description
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | IsInSerializationContext | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebTreeViewAutoPostBackSettings Class
ISNet.WebUI.WebTreeView Namespace


Clone Method

[image]
Intersoft WebTreeView Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewAutoPostBackSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewAutoPostBackSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewAutoPostBackSettings Class
WebTreeViewAutoPostBackSettings Members


CopyFrom Method

[image]
Intersoft WebTreeView Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewAutoPostBackSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewAutoPostBackSettings Class
WebTreeViewAutoPostBackSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebTreeView Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewAutoPostBackSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewAutoPostBackSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewAutoPostBackSettings Class
WebTreeViewAutoPostBackSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebTreeView Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewAutoPostBackSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewAutoPostBackSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewAutoPostBackSettings Class
WebTreeViewAutoPostBackSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebTreeView Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewAutoPostBackSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewAutoPostBackSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewAutoPostBackSettings Class
WebTreeViewAutoPostBackSettings Members


GetHashCode Method

[image]
Intersoft WebTreeView Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewAutoPostBackSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewAutoPostBackSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewAutoPostBackSettings Class
WebTreeViewAutoPostBackSettings Members


GetPropertyString Method

[image]
Intersoft WebTreeView Documentation
GetPropertyString Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewAutoPostBackSettings Class : GetPropertyString Method

v

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetPropertyString( _
   ByVal v As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewAutoPostBackSettings
Dim v As System.String
Dim value As System.String

value = instance.GetPropertyString(v)
C#
protected virtual System.string GetPropertyString(
   System.string v
)
Delphi
protected function GetPropertyString(
    v: System.String
): System.String; virtual;
JScript
protected function GetPropertyString(
   v : System.String
) : System.String;
Managed Extensions for C++
protected: virtual System.string* GetPropertyString(
   System.string* v
)
C++/CLI
protected:
virtual System.String^ GetPropertyString(
   System.String^ v
)

Parameters

v

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewAutoPostBackSettings Class
WebTreeViewAutoPostBackSettings Members


IsEmpty Method

[image]
Intersoft WebTreeView Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewAutoPostBackSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewAutoPostBackSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewAutoPostBackSettings Class
WebTreeViewAutoPostBackSettings Members


IsInSerializationContext Method

[image]
Intersoft WebTreeView Documentation
IsInSerializationContext Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewAutoPostBackSettings Class : IsInSerializationContext Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function IsInSerializationContext() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewAutoPostBackSettings
Dim value As System.Boolean

value = instance.IsInSerializationContext()
C#
protected virtual System.bool IsInSerializationContext()
Delphi
protected function IsInSerializationContext(): System.Boolean; virtual;
JScript
protected function IsInSerializationContext() : System.boolean;
Managed Extensions for C++
protected: virtual System.bool IsInSerializationContext();
C++/CLI
protected:
virtual System.bool IsInSerializationContext();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewAutoPostBackSettings Class
WebTreeViewAutoPostBackSettings Members


Reset Method

[image]
Intersoft WebTreeView Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewAutoPostBackSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewAutoPostBackSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewAutoPostBackSettings Class
WebTreeViewAutoPostBackSettings Members


SerializeObjectData Method

[image]
Intersoft WebTreeView Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewAutoPostBackSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewAutoPostBackSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewAutoPostBackSettings Class
WebTreeViewAutoPostBackSettings Members


ToString Method

[image]
Intersoft WebTreeView Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewAutoPostBackSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewAutoPostBackSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewAutoPostBackSettings Class
WebTreeViewAutoPostBackSettings Members


WebTreeViewClientSideEvents Class Methods

[image]
Intersoft WebTreeView Documentation
WebTreeViewClientSideEvents Class Methods
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace : WebTreeViewClientSideEvents Class

Glossary Item Box

For a list of all members of this type, see WebTreeViewClientSideEvents members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

Protected Methods

 | Name | Description
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | IsInSerializationContext | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebTreeViewClientSideEvents Class
ISNet.WebUI.WebTreeView Namespace


Clone Method

[image]
Intersoft WebTreeView Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewClientSideEvents Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewClientSideEvents
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewClientSideEvents Class
WebTreeViewClientSideEvents Members


CopyFrom Method

[image]
Intersoft WebTreeView Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewClientSideEvents Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewClientSideEvents Class
WebTreeViewClientSideEvents Members


CopyFrom(Object) Method

[image]
Intersoft WebTreeView Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewClientSideEvents Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewClientSideEvents
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewClientSideEvents Class
WebTreeViewClientSideEvents Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebTreeView Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewClientSideEvents Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewClientSideEvents
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewClientSideEvents Class
WebTreeViewClientSideEvents Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebTreeView Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewClientSideEvents Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewClientSideEvents
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewClientSideEvents Class
WebTreeViewClientSideEvents Members


GetHashCode Method

[image]
Intersoft WebTreeView Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewClientSideEvents Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewClientSideEvents
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewClientSideEvents Class
WebTreeViewClientSideEvents Members


GetPropertyString Method

[image]
Intersoft WebTreeView Documentation
GetPropertyString Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewClientSideEvents Class : GetPropertyString Method

v

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetPropertyString( _
   ByVal v As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewClientSideEvents
Dim v As System.String
Dim value As System.String

value = instance.GetPropertyString(v)
C#
protected virtual System.string GetPropertyString(
   System.string v
)
Delphi
protected function GetPropertyString(
    v: System.String
): System.String; virtual;
JScript
protected function GetPropertyString(
   v : System.String
) : System.String;
Managed Extensions for C++
protected: virtual System.string* GetPropertyString(
   System.string* v
)
C++/CLI
protected:
virtual System.String^ GetPropertyString(
   System.String^ v
)

Parameters

v

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewClientSideEvents Class
WebTreeViewClientSideEvents Members


IsEmpty Method

[image]
Intersoft WebTreeView Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewClientSideEvents Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewClientSideEvents
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewClientSideEvents Class
WebTreeViewClientSideEvents Members


IsInSerializationContext Method

[image]
Intersoft WebTreeView Documentation
IsInSerializationContext Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewClientSideEvents Class : IsInSerializationContext Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function IsInSerializationContext() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewClientSideEvents
Dim value As System.Boolean

value = instance.IsInSerializationContext()
C#
protected virtual System.bool IsInSerializationContext()
Delphi
protected function IsInSerializationContext(): System.Boolean; virtual;
JScript
protected function IsInSerializationContext() : System.boolean;
Managed Extensions for C++
protected: virtual System.bool IsInSerializationContext();
C++/CLI
protected:
virtual System.bool IsInSerializationContext();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewClientSideEvents Class
WebTreeViewClientSideEvents Members


Reset Method

[image]
Intersoft WebTreeView Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewClientSideEvents Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewClientSideEvents

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewClientSideEvents Class
WebTreeViewClientSideEvents Members


SerializeObjectData Method

[image]
Intersoft WebTreeView Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewClientSideEvents Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewClientSideEvents
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewClientSideEvents Class
WebTreeViewClientSideEvents Members


ToString Method

[image]
Intersoft WebTreeView Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewClientSideEvents Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewClientSideEvents
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewClientSideEvents Class
WebTreeViewClientSideEvents Members


WebTreeViewDragDropSettings Class Methods

[image]
Intersoft WebTreeView Documentation
WebTreeViewDragDropSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace : WebTreeViewDragDropSettings Class

Glossary Item Box

For a list of all members of this type, see WebTreeViewDragDropSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

Protected Methods

 | Name | Description
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | IsInSerializationContext | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebTreeViewDragDropSettings Class
ISNet.WebUI.WebTreeView Namespace

Concepts

Drag and Drop


Clone Method

[image]
Intersoft WebTreeView Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewDragDropSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewDragDropSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewDragDropSettings Class
WebTreeViewDragDropSettings Members


CopyFrom Method

[image]
Intersoft WebTreeView Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewDragDropSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewDragDropSettings Class
WebTreeViewDragDropSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebTreeView Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewDragDropSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewDragDropSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewDragDropSettings Class
WebTreeViewDragDropSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebTreeView Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewDragDropSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewDragDropSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewDragDropSettings Class
WebTreeViewDragDropSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebTreeView Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewDragDropSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewDragDropSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewDragDropSettings Class
WebTreeViewDragDropSettings Members


GetHashCode Method

[image]
Intersoft WebTreeView Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewDragDropSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewDragDropSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewDragDropSettings Class
WebTreeViewDragDropSettings Members


GetPropertyString Method

[image]
Intersoft WebTreeView Documentation
GetPropertyString Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewDragDropSettings Class : GetPropertyString Method

v

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetPropertyString( _
   ByVal v As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewDragDropSettings
Dim v As System.String
Dim value As System.String

value = instance.GetPropertyString(v)
C#
protected virtual System.string GetPropertyString(
   System.string v
)
Delphi
protected function GetPropertyString(
    v: System.String
): System.String; virtual;
JScript
protected function GetPropertyString(
   v : System.String
) : System.String;
Managed Extensions for C++
protected: virtual System.string* GetPropertyString(
   System.string* v
)
C++/CLI
protected:
virtual System.String^ GetPropertyString(
   System.String^ v
)

Parameters

v

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewDragDropSettings Class
WebTreeViewDragDropSettings Members


IsEmpty Method

[image]
Intersoft WebTreeView Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewDragDropSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewDragDropSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewDragDropSettings Class
WebTreeViewDragDropSettings Members


IsInSerializationContext Method

[image]
Intersoft WebTreeView Documentation
IsInSerializationContext Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewDragDropSettings Class : IsInSerializationContext Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function IsInSerializationContext() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewDragDropSettings
Dim value As System.Boolean

value = instance.IsInSerializationContext()
C#
protected virtual System.bool IsInSerializationContext()
Delphi
protected function IsInSerializationContext(): System.Boolean; virtual;
JScript
protected function IsInSerializationContext() : System.boolean;
Managed Extensions for C++
protected: virtual System.bool IsInSerializationContext();
C++/CLI
protected:
virtual System.bool IsInSerializationContext();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewDragDropSettings Class
WebTreeViewDragDropSettings Members


Reset Method

[image]
Intersoft WebTreeView Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewDragDropSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewDragDropSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewDragDropSettings Class
WebTreeViewDragDropSettings Members


SerializeObjectData Method

[image]
Intersoft WebTreeView Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewDragDropSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewDragDropSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewDragDropSettings Class
WebTreeViewDragDropSettings Members


ToString Method

[image]
Intersoft WebTreeView Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewDragDropSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewDragDropSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewDragDropSettings Class
WebTreeViewDragDropSettings Members


WebTreeViewImagesSettings Class Methods

[image]
Intersoft WebTreeView Documentation
WebTreeViewImagesSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace : WebTreeViewImagesSettings Class

Glossary Item Box

For a list of all members of this type, see WebTreeViewImagesSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

Protected Methods

 | Name | Description
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | IsInSerializationContext | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebTreeViewImagesSettings Class
ISNet.WebUI.WebTreeView Namespace


Clone Method

[image]
Intersoft WebTreeView Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewImagesSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewImagesSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewImagesSettings Class
WebTreeViewImagesSettings Members


CopyFrom Method

[image]
Intersoft WebTreeView Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewImagesSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewImagesSettings Class
WebTreeViewImagesSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebTreeView Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewImagesSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewImagesSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewImagesSettings Class
WebTreeViewImagesSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebTreeView Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewImagesSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewImagesSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewImagesSettings Class
WebTreeViewImagesSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebTreeView Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewImagesSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewImagesSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewImagesSettings Class
WebTreeViewImagesSettings Members


GetHashCode Method

[image]
Intersoft WebTreeView Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewImagesSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewImagesSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewImagesSettings Class
WebTreeViewImagesSettings Members


GetPropertyString Method

[image]
Intersoft WebTreeView Documentation
GetPropertyString Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewImagesSettings Class : GetPropertyString Method

v

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetPropertyString( _
   ByVal v As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewImagesSettings
Dim v As System.String
Dim value As System.String

value = instance.GetPropertyString(v)
C#
protected virtual System.string GetPropertyString(
   System.string v
)
Delphi
protected function GetPropertyString(
    v: System.String
): System.String; virtual;
JScript
protected function GetPropertyString(
   v : System.String
) : System.String;
Managed Extensions for C++
protected: virtual System.string* GetPropertyString(
   System.string* v
)
C++/CLI
protected:
virtual System.String^ GetPropertyString(
   System.String^ v
)

Parameters

v

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewImagesSettings Class
WebTreeViewImagesSettings Members


IsEmpty Method

[image]
Intersoft WebTreeView Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewImagesSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewImagesSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewImagesSettings Class
WebTreeViewImagesSettings Members


IsInSerializationContext Method

[image]
Intersoft WebTreeView Documentation
IsInSerializationContext Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewImagesSettings Class : IsInSerializationContext Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function IsInSerializationContext() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewImagesSettings
Dim value As System.Boolean

value = instance.IsInSerializationContext()
C#
protected virtual System.bool IsInSerializationContext()
Delphi
protected function IsInSerializationContext(): System.Boolean; virtual;
JScript
protected function IsInSerializationContext() : System.boolean;
Managed Extensions for C++
protected: virtual System.bool IsInSerializationContext();
C++/CLI
protected:
virtual System.bool IsInSerializationContext();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewImagesSettings Class
WebTreeViewImagesSettings Members


Reset Method

[image]
Intersoft WebTreeView Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewImagesSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewImagesSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewImagesSettings Class
WebTreeViewImagesSettings Members


SerializeObjectData Method

[image]
Intersoft WebTreeView Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewImagesSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewImagesSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewImagesSettings Class
WebTreeViewImagesSettings Members


ToString Method

[image]
Intersoft WebTreeView Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewImagesSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewImagesSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewImagesSettings Class
WebTreeViewImagesSettings Members


WebTreeViewNodeBindingCollection Constructor

[image]
Intersoft WebTreeView Documentation
WebTreeViewNodeBindingCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBindingCollection Class : WebTreeViewNodeBindingCollection Constructor

Glossary Item Box

Initializes a new instance of WebTreeViewNodeBindingCollection class.

Overload List

Overload | Description
WebTreeViewNodeBindingCollection Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBindingCollection Class
WebTreeViewNodeBindingCollection Members


All Property

[image]
Intersoft WebTreeView Documentation
All Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBindingCollection Class : All Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
Public Property All As System.Object()
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBindingCollection
Dim value() As System.Object

instance.All = value

value = instance.All
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public System.object[] All {get; set;}
Delphi
public read-write property All: System.array of TObject;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
public function get,set All : System.Object[]
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public: __property System.Object*[]* get_All();
public: __property void set_All(
   System.Object*[]* value
);
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public:
property System.array<Object^>^ All {
   System.array<Object^>^ get();
   void set (    System.array<Object^>^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBindingCollection Class
WebTreeViewNodeBindingCollection Members


Capacity Property

[image]
Intersoft WebTreeView Documentation
Capacity Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBindingCollection Class : Capacity Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.InteropServices.ComVisibleAttribute(False)>
Public Property Capacity As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBindingCollection
Dim value As System.Integer

instance.Capacity = value

value = instance.Capacity
C#
[System.Runtime.InteropServices.ComVisibleAttribute(false)]
public System.int Capacity {get; set;}
Delphi
public read-write property Capacity: System.Integer;
JScript
System.Runtime.InteropServices.ComVisibleAttribute()
public function get,set Capacity : System.int
Managed Extensions for C++
[System.Runtime.InteropServices.ComVisibleAttribute(false)]
public: __property System.int get_Capacity();
public: __property void set_Capacity(
   System.int value
);
C++/CLI
[System.Runtime.InteropServices.ComVisibleAttribute(false)]
public:
property System.int Capacity {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBindingCollection Class
WebTreeViewNodeBindingCollection Members


Contains Method

[image]
Intersoft WebTreeView Documentation
Contains Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBindingCollection Class : Contains Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal value As ISNet.WebUI.INamedObject _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBindingCollection
Dim value As ISNet.WebUI.INamedObject
Dim value As System.Boolean

value = instance.Contains(value)
C#
public System.bool Contains(
   ISNet.WebUI.INamedObject value
)
Delphi
public function Contains(
    value: ISNet.WebUI.INamedObject
): System.Boolean;
JScript
public function Contains(
   value : ISNet.WebUI.INamedObject
) : System.boolean;
Managed Extensions for C++
public: System.bool Contains(
   ISNet.WebUI.INamedObject* value
)
C++/CLI
public:
System.bool Contains(
   ISNet.WebUI.INamedObject^ value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBindingCollection Class
WebTreeViewNodeBindingCollection Members


CopyTo Method

[image]
Intersoft WebTreeView Documentation
CopyTo Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBindingCollection Class : CopyTo Method

array
index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array() As ISNet.WebUI.INamedObject, _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBindingCollection
Dim array() As ISNet.WebUI.INamedObject
Dim index As System.Integer

instance.CopyTo(array, index)
C#
public void CopyTo(
   ISNet.WebUI.INamedObject[] array,
   System.int index
)
Delphi
public procedure CopyTo(
    array: ISNet.WebUI.INamedObjectarray of;
    index: System.Integer
);
JScript
public function CopyTo(
   array : ISNet.WebUI.INamedObject[],
   index : System.int
);
Managed Extensions for C++
public: void CopyTo(
   ISNet.WebUI.INamedObject*[]* array,
   System.int index
)
C++/CLI
public:
void CopyTo(
   ISNet.WebUI.array<INamedObject^>^ array,
   System.int index
)

Parameters

array
index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBindingCollection Class
WebTreeViewNodeBindingCollection Members


Count Property

[image]
Intersoft WebTreeView Documentation
Count Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBindingCollection Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBindingCollection
Dim value As System.Integer

value = instance.Count
C#
public System.int Count {get;}
Delphi
public read-only property Count: System.Integer;
JScript
public function get Count : System.int
Managed Extensions for C++
public: __property System.int get_Count();
C++/CLI
public:
property System.int Count {
   System.int get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBindingCollection Class
WebTreeViewNodeBindingCollection Members


CreateArray Method

[image]
Intersoft WebTreeView Documentation
CreateArray Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBindingCollection Class : CreateArray Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function CreateArray() As System.Object()
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBindingCollection
Dim value() As System.Object

value = instance.CreateArray()
C#
protected System.object[] CreateArray()
Delphi
protected function CreateArray(): System.array of TObject;
JScript
protected function CreateArray() : System.Object[];
Managed Extensions for C++
protected: System.Object*[]* CreateArray();
C++/CLI
protected:
System.array<Object^>^ CreateArray();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBindingCollection Class
WebTreeViewNodeBindingCollection Members


Exists Method

[image]
Intersoft WebTreeView Documentation
Exists Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBindingCollection Class : Exists Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Exists( _
   ByVal name As System.String _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBindingCollection
Dim name As System.String
Dim value As System.Boolean

value = instance.Exists(name)
C#
public System.bool Exists(
   System.string name
)
Delphi
public function Exists(
    name: System.String
): System.Boolean;
JScript
public function Exists(
   name : System.String
) : System.boolean;
Managed Extensions for C++
public: System.bool Exists(
   System.string* name
)
C++/CLI
public:
System.bool Exists(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBindingCollection Class
WebTreeViewNodeBindingCollection Members


GetItem Method

[image]
Intersoft WebTreeView Documentation
GetItem Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBindingCollection Class : GetItem Method

Glossary Item Box

Overload List

Overload | Description
GetItem(Int32) | (Inherited from ISNet.WebUI.ISCollectionBase)
GetItem(String) | (Inherited from ISNet.WebUI.ISCollectionBase)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBindingCollection Class
WebTreeViewNodeBindingCollection Members


GetItem(Int32) Method

[image]
Intersoft WebTreeView Documentation
GetItem(Int32) Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBindingCollection Class > GetItem Method : GetItem(Int32) Method

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function GetItem( _
   ByVal index As System.Integer _
) As ISNet.WebUI.INamedObject
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBindingCollection
Dim index As System.Integer
Dim value As ISNet.WebUI.INamedObject

value = instance.GetItem(index)
C#
public virtual ISNet.WebUI.INamedObject GetItem(
   System.int index
)
Delphi
public function GetItem(
    index: System.Integer
): ISNet.WebUI.INamedObject; virtual;
JScript
public function GetItem(
   index : System.int
) : ISNet.WebUI.INamedObject;
Managed Extensions for C++
public: virtual ISNet.WebUI.INamedObject* GetItem(
   System.int index
)
C++/CLI
public:
virtual ISNet.WebUI.INamedObject^ GetItem(
   System.int index
)

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBindingCollection Class
WebTreeViewNodeBindingCollection Members
Overload List


GetItem(String) Method

[image]
Intersoft WebTreeView Documentation
GetItem(String) Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBindingCollection Class > GetItem Method : GetItem(String) Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overloads Overridable Function GetItem( _
   ByVal name As System.String _
) As ISNet.WebUI.INamedObject
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBindingCollection
Dim name As System.String
Dim value As ISNet.WebUI.INamedObject

value = instance.GetItem(name)
C#
protected virtual ISNet.WebUI.INamedObject GetItem(
   System.string name
)
Delphi
protected function GetItem(
    name: System.String
): ISNet.WebUI.INamedObject; virtual;
JScript
protected function GetItem(
   name : System.String
) : ISNet.WebUI.INamedObject;
Managed Extensions for C++
protected: virtual ISNet.WebUI.INamedObject* GetItem(
   System.string* name
)
C++/CLI
protected:
virtual ISNet.WebUI.INamedObject^ GetItem(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBindingCollection Class
WebTreeViewNodeBindingCollection Members
Overload List


IndexOf Method

[image]
Intersoft WebTreeView Documentation
IndexOf Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBindingCollection Class : IndexOf Method

Glossary Item Box

Overload List

Overload | Description
IndexOf(String) | (Inherited from ISNet.WebUI.ISCollectionBase)
IndexOf(INamedObject) | (Inherited from ISNet.WebUI.ISCollectionBase)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBindingCollection Class
WebTreeViewNodeBindingCollection Members


IndexOf(INamedObject) Method

[image]
Intersoft WebTreeView Documentation
IndexOf(INamedObject) Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBindingCollection Class > IndexOf Method : IndexOf(INamedObject) Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal value As ISNet.WebUI.INamedObject _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBindingCollection
Dim value As ISNet.WebUI.INamedObject
Dim value As System.Integer

value = instance.IndexOf(value)
C#
public System.int IndexOf(
   ISNet.WebUI.INamedObject value
)
Delphi
public function IndexOf(
    value: ISNet.WebUI.INamedObject
): System.Integer;
JScript
public function IndexOf(
   value : ISNet.WebUI.INamedObject
) : System.int;
Managed Extensions for C++
public: System.int IndexOf(
   ISNet.WebUI.INamedObject* value
)
C++/CLI
public:
System.int IndexOf(
   ISNet.WebUI.INamedObject^ value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBindingCollection Class
WebTreeViewNodeBindingCollection Members
Overload List


IndexOf(String) Method

[image]
Intersoft WebTreeView Documentation
IndexOf(String) Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBindingCollection Class > IndexOf Method : IndexOf(String) Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function IndexOf( _
   ByVal name As System.String _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBindingCollection
Dim name As System.String
Dim value As System.Integer

value = instance.IndexOf(name)
C#
public virtual System.int IndexOf(
   System.string name
)
Delphi
public function IndexOf(
    name: System.String
): System.Integer; virtual;
JScript
public function IndexOf(
   name : System.String
) : System.int;
Managed Extensions for C++
public: virtual System.int IndexOf(
   System.string* name
)
C++/CLI
public:
virtual System.int IndexOf(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBindingCollection Class
WebTreeViewNodeBindingCollection Members
Overload List


InnerList Property

[image]
Intersoft WebTreeView Documentation
InnerList Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBindingCollection Class : InnerList Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property InnerList As System.Collections.ArrayList
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBindingCollection
Dim value As System.Collections.ArrayList

value = instance.InnerList
C#
protected System.Collections.ArrayList InnerList {get;}
Delphi
protected read-only property InnerList: System.Collections.ArrayList;
JScript
protected function get InnerList : System.Collections.ArrayList
Managed Extensions for C++
protected: __property System.Collections.ArrayList* get_InnerList();
C++/CLI
protected:
property System.Collections.ArrayList^ InnerList {
   System.Collections.ArrayList^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBindingCollection Class
WebTreeViewNodeBindingCollection Members


IntAdd Method

[image]
Intersoft WebTreeView Documentation
IntAdd Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBindingCollection Class : IntAdd Method

obj

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function IntAdd( _
   ByVal obj As ISNet.WebUI.INamedObject _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBindingCollection
Dim obj As ISNet.WebUI.INamedObject
Dim value As System.Integer

value = instance.IntAdd(obj)
C#
protected System.int IntAdd(
   ISNet.WebUI.INamedObject obj
)
Delphi
protected function IntAdd(
    obj: ISNet.WebUI.INamedObject
): System.Integer;
JScript
protected function IntAdd(
   obj : ISNet.WebUI.INamedObject
) : System.int;
Managed Extensions for C++
protected: System.int IntAdd(
   ISNet.WebUI.INamedObject* obj
)
C++/CLI
protected:
System.int IntAdd(
   ISNet.WebUI.INamedObject^ obj
)

Parameters

obj

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBindingCollection Class
WebTreeViewNodeBindingCollection Members


IntClear Method

[image]
Intersoft WebTreeView Documentation
IntClear Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBindingCollection Class : IntClear Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Sub IntClear()
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBindingCollection

instance.IntClear()
C#
protected void IntClear()
Delphi
protected procedure IntClear();
JScript
protected function IntClear();
Managed Extensions for C++
protected: void IntClear();
C++/CLI
protected:
void IntClear();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBindingCollection Class
WebTreeViewNodeBindingCollection Members


IntInsert Method

[image]
Intersoft WebTreeView Documentation
IntInsert Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBindingCollection Class : IntInsert Method

index
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub IntInsert( _
   ByVal index As System.Integer, _
   ByVal value As ISNet.WebUI.INamedObject _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBindingCollection
Dim index As System.Integer
Dim value As ISNet.WebUI.INamedObject

instance.IntInsert(index, value)
C#
public void IntInsert(
   System.int index,
   ISNet.WebUI.INamedObject value
)
Delphi
public procedure IntInsert(
    index: System.Integer;
    value: ISNet.WebUI.INamedObject
);
JScript
public function IntInsert(
   index : System.int,
   value : ISNet.WebUI.INamedObject
);
Managed Extensions for C++
public: void IntInsert(
   System.int index,
   ISNet.WebUI.INamedObject* value
)
C++/CLI
public:
void IntInsert(
   System.int index,
   ISNet.WebUI.INamedObject^ value
)

Parameters

index
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBindingCollection Class
WebTreeViewNodeBindingCollection Members


IntRemove Method

[image]
Intersoft WebTreeView Documentation
IntRemove Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBindingCollection Class : IntRemove Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Sub IntRemove( _
   ByVal value As ISNet.WebUI.INamedObject _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBindingCollection
Dim value As ISNet.WebUI.INamedObject

instance.IntRemove(value)
C#
protected void IntRemove(
   ISNet.WebUI.INamedObject value
)
Delphi
protected procedure IntRemove(
    value: ISNet.WebUI.INamedObject
);
JScript
protected function IntRemove(
   value : ISNet.WebUI.INamedObject
);
Managed Extensions for C++
protected: void IntRemove(
   ISNet.WebUI.INamedObject* value
)
C++/CLI
protected:
void IntRemove(
   ISNet.WebUI.INamedObject^ value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBindingCollection Class
WebTreeViewNodeBindingCollection Members


IntRemoveAt Method

[image]
Intersoft WebTreeView Documentation
IntRemoveAt Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBindingCollection Class : IntRemoveAt Method

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Sub IntRemoveAt( _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBindingCollection
Dim index As System.Integer

instance.IntRemoveAt(index)
C#
protected void IntRemoveAt(
   System.int index
)
Delphi
protected procedure IntRemoveAt(
    index: System.Integer
);
JScript
protected function IntRemoveAt(
   index : System.int
);
Managed Extensions for C++
protected: void IntRemoveAt(
   System.int index
)
C++/CLI
protected:
void IntRemoveAt(
   System.int index
)

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBindingCollection Class
WebTreeViewNodeBindingCollection Members


List Property

[image]
Intersoft WebTreeView Documentation
List Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBindingCollection Class : List Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property List As System.Collections.IList
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBindingCollection
Dim value As System.Collections.IList

value = instance.List
C#
protected System.Collections.IList List {get;}
Delphi
protected read-only property List: System.Collections.IList;
JScript
protected function get List : System.Collections.IList
Managed Extensions for C++
protected: __property System.Collections.IList* get_List();
C++/CLI
protected:
property System.Collections.IList^ List {
   System.Collections.IList^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBindingCollection Class
WebTreeViewNodeBindingCollection Members


OnClear Method

[image]
Intersoft WebTreeView Documentation
OnClear Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBindingCollection Class : OnClear Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnClear()
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBindingCollection

instance.OnClear()
C#
protected virtual void OnClear()
Delphi
protected procedure OnClear(); virtual;
JScript
protected function OnClear();
Managed Extensions for C++
protected: virtual void OnClear();
C++/CLI
protected:
virtual void OnClear();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBindingCollection Class
WebTreeViewNodeBindingCollection Members


OnClearComplete Method

[image]
Intersoft WebTreeView Documentation
OnClearComplete Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBindingCollection Class : OnClearComplete Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnClearComplete()
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBindingCollection

instance.OnClearComplete()
C#
protected virtual void OnClearComplete()
Delphi
protected procedure OnClearComplete(); virtual;
JScript
protected function OnClearComplete();
Managed Extensions for C++
protected: virtual void OnClearComplete();
C++/CLI
protected:
virtual void OnClearComplete();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBindingCollection Class
WebTreeViewNodeBindingCollection Members


OnInsert Method

[image]
Intersoft WebTreeView Documentation
OnInsert Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBindingCollection Class : OnInsert Method

index
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnInsert( _
   ByVal index As System.Integer, _
   ByVal value As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBindingCollection
Dim index As System.Integer
Dim value As System.Object

instance.OnInsert(index, value)
C#
protected virtual void OnInsert(
   System.int index,
   System.object value
)
Delphi
protected procedure OnInsert(
    index: System.Integer;
    value: System.TObject
); virtual;
JScript
protected function OnInsert(
   index : System.int,
   value : System.Object
);
Managed Extensions for C++
protected: virtual void OnInsert(
   System.int index,
   System.Object* value
)
C++/CLI
protected:
virtual void OnInsert(
   System.int index,
   System.Object^ value
)

Parameters

index
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBindingCollection Class
WebTreeViewNodeBindingCollection Members


OnRemove Method

[image]
Intersoft WebTreeView Documentation
OnRemove Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBindingCollection Class : OnRemove Method

index
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnRemove( _
   ByVal index As System.Integer, _
   ByVal value As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBindingCollection
Dim index As System.Integer
Dim value As System.Object

instance.OnRemove(index, value)
C#
protected virtual void OnRemove(
   System.int index,
   System.object value
)
Delphi
protected procedure OnRemove(
    index: System.Integer;
    value: System.TObject
); virtual;
JScript
protected function OnRemove(
   index : System.int,
   value : System.Object
);
Managed Extensions for C++
protected: virtual void OnRemove(
   System.int index,
   System.Object* value
)
C++/CLI
protected:
virtual void OnRemove(
   System.int index,
   System.Object^ value
)

Parameters

index
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBindingCollection Class
WebTreeViewNodeBindingCollection Members


OnRemoveComplete Method

[image]
Intersoft WebTreeView Documentation
OnRemoveComplete Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBindingCollection Class : OnRemoveComplete Method

index
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnRemoveComplete( _
   ByVal index As System.Integer, _
   ByVal value As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBindingCollection
Dim index As System.Integer
Dim value As System.Object

instance.OnRemoveComplete(index, value)
C#
protected virtual void OnRemoveComplete(
   System.int index,
   System.object value
)
Delphi
protected procedure OnRemoveComplete(
    index: System.Integer;
    value: System.TObject
); virtual;
JScript
protected function OnRemoveComplete(
   index : System.int,
   value : System.Object
);
Managed Extensions for C++
protected: virtual void OnRemoveComplete(
   System.int index,
   System.Object* value
)
C++/CLI
protected:
virtual void OnRemoveComplete(
   System.int index,
   System.Object^ value
)

Parameters

index
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBindingCollection Class
WebTreeViewNodeBindingCollection Members


OnSet Method

[image]
Intersoft WebTreeView Documentation
OnSet Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBindingCollection Class : OnSet Method

index
oldValue
newValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnSet( _
   ByVal index As System.Integer, _
   ByVal oldValue As System.Object, _
   ByVal newValue As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBindingCollection
Dim index As System.Integer
Dim oldValue As System.Object
Dim newValue As System.Object

instance.OnSet(index, oldValue, newValue)
C#
protected virtual void OnSet(
   System.int index,
   System.object oldValue,
   System.object newValue
)
Delphi
protected procedure OnSet(
    index: System.Integer;
    oldValue: System.TObject;
    newValue: System.TObject
); virtual;
JScript
protected function OnSet(
   index : System.int,
   oldValue : System.Object,
   newValue : System.Object
);
Managed Extensions for C++
protected: virtual void OnSet(
   System.int index,
   System.Object* oldValue,
   System.Object* newValue
)
C++/CLI
protected:
virtual void OnSet(
   System.int index,
   System.Object^ oldValue,
   System.Object^ newValue
)

Parameters

index
oldValue
newValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBindingCollection Class
WebTreeViewNodeBindingCollection Members


OnSetComplete Method

[image]
Intersoft WebTreeView Documentation
OnSetComplete Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBindingCollection Class : OnSetComplete Method

index
oldValue
newValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnSetComplete( _
   ByVal index As System.Integer, _
   ByVal oldValue As System.Object, _
   ByVal newValue As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBindingCollection
Dim index As System.Integer
Dim oldValue As System.Object
Dim newValue As System.Object

instance.OnSetComplete(index, oldValue, newValue)
C#
protected virtual void OnSetComplete(
   System.int index,
   System.object oldValue,
   System.object newValue
)
Delphi
protected procedure OnSetComplete(
    index: System.Integer;
    oldValue: System.TObject;
    newValue: System.TObject
); virtual;
JScript
protected function OnSetComplete(
   index : System.int,
   oldValue : System.Object,
   newValue : System.Object
);
Managed Extensions for C++
protected: virtual void OnSetComplete(
   System.int index,
   System.Object* oldValue,
   System.Object* newValue
)
C++/CLI
protected:
virtual void OnSetComplete(
   System.int index,
   System.Object^ oldValue,
   System.Object^ newValue
)

Parameters

index
oldValue
newValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBindingCollection Class
WebTreeViewNodeBindingCollection Members


OnValidate Method

[image]
Intersoft WebTreeView Documentation
OnValidate Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBindingCollection Class : OnValidate Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnValidate( _
   ByVal value As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBindingCollection
Dim value As System.Object

instance.OnValidate(value)
C#
protected virtual void OnValidate(
   System.object value
)
Delphi
protected procedure OnValidate(
    value: System.TObject
); virtual;
JScript
protected function OnValidate(
   value : System.Object
);
Managed Extensions for C++
protected: virtual void OnValidate(
   System.Object* value
)
C++/CLI
protected:
virtual void OnValidate(
   System.Object^ value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBindingCollection Class
WebTreeViewNodeBindingCollection Members


Parent Property

[image]
Intersoft WebTreeView Documentation
Parent Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBindingCollection Class : Parent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBindingCollection
Dim value As System.Object

value = instance.Parent
C#
public System.object Parent {get;}
Delphi
public read-only property Parent: System.TObject;
JScript
public function get Parent : System.Object
Managed Extensions for C++
public: __property System.Object* get_Parent();
C++/CLI
public:
property System.Object^ Parent {
   System.Object^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBindingCollection Class
WebTreeViewNodeBindingCollection Members


setParent Method

[image]
Intersoft WebTreeView Documentation
setParent Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBindingCollection Class : setParent Method

parent

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub setParent( _
   ByVal parent As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBindingCollection
Dim parent As System.Object

instance.setParent(parent)
C#
public virtual void setParent(
   System.object parent
)
Delphi
public procedure setParent(
    parent: System.TObject
); virtual;
JScript
public function setParent(
   parent : System.Object
);
Managed Extensions for C++
public: virtual void setParent(
   System.Object* parent
)
C++/CLI
public:
virtual void setParent(
   System.Object^ parent
)

Parameters

parent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBindingCollection Class
WebTreeViewNodeBindingCollection Members


Clone Method

[image]
Intersoft WebTreeView Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBinding Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBinding
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBinding Class
WebTreeViewNodeBinding Members


Collection Property

[image]
Intersoft WebTreeView Documentation
Collection Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBinding Class : Collection Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
Public Property Collection As ISNet.WebUI.ISCollectionBase
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBinding
Dim value As ISNet.WebUI.ISCollectionBase

instance.Collection = value

value = instance.Collection
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public ISNet.WebUI.ISCollectionBase Collection {get; set;}
Delphi
public read-write property Collection: ISNet.WebUI.ISCollectionBase;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
public function get,set Collection : ISNet.WebUI.ISCollectionBase
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public: __property ISNet.WebUI.ISCollectionBase* get_Collection();
public: __property void set_Collection(
   ISNet.WebUI.ISCollectionBase* value
);
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public:
property ISNet.WebUI.ISCollectionBase^ Collection {
   ISNet.WebUI.ISCollectionBase^ get();
   void set (    ISNet.WebUI.ISCollectionBase^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBinding Class
WebTreeViewNodeBinding Members


CopyFrom Method

[image]
Intersoft WebTreeView Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBinding Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBinding Class
WebTreeViewNodeBinding Members


CopyFrom(Object) Method

[image]
Intersoft WebTreeView Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBinding Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBinding
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBinding Class
WebTreeViewNodeBinding Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebTreeView Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBinding Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBinding
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBinding Class
WebTreeViewNodeBinding Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebTreeView Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBinding Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBinding
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBinding Class
WebTreeViewNodeBinding Members


GetHashCode Method

[image]
Intersoft WebTreeView Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBinding Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBinding
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBinding Class
WebTreeViewNodeBinding Members


GetObjectData Method

[image]
Intersoft WebTreeView Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBinding Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBinding
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public virtual void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); virtual;
JScript
public function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: virtual void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
virtual void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBinding Class
WebTreeViewNodeBinding Members


GetPropertyString Method

[image]
Intersoft WebTreeView Documentation
GetPropertyString Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBinding Class : GetPropertyString Method

v

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetPropertyString( _
   ByVal v As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBinding
Dim v As System.String
Dim value As System.String

value = instance.GetPropertyString(v)
C#
protected virtual System.string GetPropertyString(
   System.string v
)
Delphi
protected function GetPropertyString(
    v: System.String
): System.String; virtual;
JScript
protected function GetPropertyString(
   v : System.String
) : System.String;
Managed Extensions for C++
protected: virtual System.string* GetPropertyString(
   System.string* v
)
C++/CLI
protected:
virtual System.String^ GetPropertyString(
   System.String^ v
)

Parameters

v

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBinding Class
WebTreeViewNodeBinding Members


IsEmpty Method

[image]
Intersoft WebTreeView Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBinding Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBinding
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBinding Class
WebTreeViewNodeBinding Members


IsInSerializationContext Method

[image]
Intersoft WebTreeView Documentation
IsInSerializationContext Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBinding Class : IsInSerializationContext Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function IsInSerializationContext() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBinding
Dim value As System.Boolean

value = instance.IsInSerializationContext()
C#
protected virtual System.bool IsInSerializationContext()
Delphi
protected function IsInSerializationContext(): System.Boolean; virtual;
JScript
protected function IsInSerializationContext() : System.boolean;
Managed Extensions for C++
protected: virtual System.bool IsInSerializationContext();
C++/CLI
protected:
virtual System.bool IsInSerializationContext();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBinding Class
WebTreeViewNodeBinding Members


Name Property

[image]
Intersoft WebTreeView Documentation
Name Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBinding Class : Name Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Overridable Property Name As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBinding
Dim value As System.String

instance.Name = value

value = instance.Name
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public virtual System.string Name {get; set;}
Delphi
public read-write property Name: System.String; virtual;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get,set Name : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property virtual System.string* get_Name();
public: __property virtual void set_Name(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
virtual property System.String^ Name {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBinding Class
WebTreeViewNodeBinding Members


OnItemAdd Method

[image]
Intersoft WebTreeView Documentation
OnItemAdd Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBinding Class : OnItemAdd Method

collection

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnItemAdd( _
   ByVal collection As ISNet.WebUI.ISCollectionBase _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBinding
Dim collection As ISNet.WebUI.ISCollectionBase

instance.OnItemAdd(collection)
C#
protected virtual void OnItemAdd(
   ISNet.WebUI.ISCollectionBase collection
)
Delphi
protected procedure OnItemAdd(
    collection: ISNet.WebUI.ISCollectionBase
); virtual;
JScript
protected function OnItemAdd(
   collection : ISNet.WebUI.ISCollectionBase
);
Managed Extensions for C++
protected: virtual void OnItemAdd(
   ISNet.WebUI.ISCollectionBase* collection
)
C++/CLI
protected:
virtual void OnItemAdd(
   ISNet.WebUI.ISCollectionBase^ collection
)

Parameters

collection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBinding Class
WebTreeViewNodeBinding Members


OnItemRemove Method

[image]
Intersoft WebTreeView Documentation
OnItemRemove Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBinding Class : OnItemRemove Method

collection

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnItemRemove( _
   ByVal collection As ISNet.WebUI.ISCollectionBase _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBinding
Dim collection As ISNet.WebUI.ISCollectionBase

instance.OnItemRemove(collection)
C#
protected virtual void OnItemRemove(
   ISNet.WebUI.ISCollectionBase collection
)
Delphi
protected procedure OnItemRemove(
    collection: ISNet.WebUI.ISCollectionBase
); virtual;
JScript
protected function OnItemRemove(
   collection : ISNet.WebUI.ISCollectionBase
);
Managed Extensions for C++
protected: virtual void OnItemRemove(
   ISNet.WebUI.ISCollectionBase* collection
)
C++/CLI
protected:
virtual void OnItemRemove(
   ISNet.WebUI.ISCollectionBase^ collection
)

Parameters

collection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBinding Class
WebTreeViewNodeBinding Members


Reset Method

[image]
Intersoft WebTreeView Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBinding Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBinding

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBinding Class
WebTreeViewNodeBinding Members


SerializeObjectData Method

[image]
Intersoft WebTreeView Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeBinding Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeBinding
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeBinding Class
WebTreeViewNodeBinding Members


WebTreeViewNodeCollection Constructor

[image]
Intersoft WebTreeView Documentation
WebTreeViewNodeCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeCollection Class : WebTreeViewNodeCollection Constructor

Glossary Item Box

Initializes a new instance of WebTreeViewNode collection class.

Overload List

Overload | Description
WebTreeViewNodeCollection Constructor |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeCollection Class
WebTreeViewNodeCollection Members


All Property

[image]
Intersoft WebTreeView Documentation
All Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeCollection Class : All Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
Public Property All As System.Object()
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeCollection
Dim value() As System.Object

instance.All = value

value = instance.All
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public System.object[] All {get; set;}
Delphi
public read-write property All: System.array of TObject;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
public function get,set All : System.Object[]
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public: __property System.Object*[]* get_All();
public: __property void set_All(
   System.Object*[]* value
);
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public:
property System.array<Object^>^ All {
   System.array<Object^>^ get();
   void set (    System.array<Object^>^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeCollection Class
WebTreeViewNodeCollection Members


Capacity Property

[image]
Intersoft WebTreeView Documentation
Capacity Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeCollection Class : Capacity Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.InteropServices.ComVisibleAttribute(False)>
Public Property Capacity As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeCollection
Dim value As System.Integer

instance.Capacity = value

value = instance.Capacity
C#
[System.Runtime.InteropServices.ComVisibleAttribute(false)]
public System.int Capacity {get; set;}
Delphi
public read-write property Capacity: System.Integer;
JScript
System.Runtime.InteropServices.ComVisibleAttribute()
public function get,set Capacity : System.int
Managed Extensions for C++
[System.Runtime.InteropServices.ComVisibleAttribute(false)]
public: __property System.int get_Capacity();
public: __property void set_Capacity(
   System.int value
);
C++/CLI
[System.Runtime.InteropServices.ComVisibleAttribute(false)]
public:
property System.int Capacity {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeCollection Class
WebTreeViewNodeCollection Members


Contains Method

[image]
Intersoft WebTreeView Documentation
Contains Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeCollection Class : Contains Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal value As ISNet.WebUI.INamedObject _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeCollection
Dim value As ISNet.WebUI.INamedObject
Dim value As System.Boolean

value = instance.Contains(value)
C#
public System.bool Contains(
   ISNet.WebUI.INamedObject value
)
Delphi
public function Contains(
    value: ISNet.WebUI.INamedObject
): System.Boolean;
JScript
public function Contains(
   value : ISNet.WebUI.INamedObject
) : System.boolean;
Managed Extensions for C++
public: System.bool Contains(
   ISNet.WebUI.INamedObject* value
)
C++/CLI
public:
System.bool Contains(
   ISNet.WebUI.INamedObject^ value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeCollection Class
WebTreeViewNodeCollection Members


CopyTo Method

[image]
Intersoft WebTreeView Documentation
CopyTo Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeCollection Class : CopyTo Method

array
index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CopyTo( _
   ByVal array() As ISNet.WebUI.INamedObject, _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeCollection
Dim array() As ISNet.WebUI.INamedObject
Dim index As System.Integer

instance.CopyTo(array, index)
C#
public void CopyTo(
   ISNet.WebUI.INamedObject[] array,
   System.int index
)
Delphi
public procedure CopyTo(
    array: ISNet.WebUI.INamedObjectarray of;
    index: System.Integer
);
JScript
public function CopyTo(
   array : ISNet.WebUI.INamedObject[],
   index : System.int
);
Managed Extensions for C++
public: void CopyTo(
   ISNet.WebUI.INamedObject*[]* array,
   System.int index
)
C++/CLI
public:
void CopyTo(
   ISNet.WebUI.array<INamedObject^>^ array,
   System.int index
)

Parameters

array
index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeCollection Class
WebTreeViewNodeCollection Members


Count Property

[image]
Intersoft WebTreeView Documentation
Count Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeCollection Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Count As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeCollection
Dim value As System.Integer

value = instance.Count
C#
public System.int Count {get;}
Delphi
public read-only property Count: System.Integer;
JScript
public function get Count : System.int
Managed Extensions for C++
public: __property System.int get_Count();
C++/CLI
public:
property System.int Count {
   System.int get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeCollection Class
WebTreeViewNodeCollection Members


CreateArray Method

[image]
Intersoft WebTreeView Documentation
CreateArray Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeCollection Class : CreateArray Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function CreateArray() As System.Object()
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeCollection
Dim value() As System.Object

value = instance.CreateArray()
C#
protected System.object[] CreateArray()
Delphi
protected function CreateArray(): System.array of TObject;
JScript
protected function CreateArray() : System.Object[];
Managed Extensions for C++
protected: System.Object*[]* CreateArray();
C++/CLI
protected:
System.array<Object^>^ CreateArray();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeCollection Class
WebTreeViewNodeCollection Members


Exists Method

[image]
Intersoft WebTreeView Documentation
Exists Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeCollection Class : Exists Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Exists( _
   ByVal name As System.String _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeCollection
Dim name As System.String
Dim value As System.Boolean

value = instance.Exists(name)
C#
public System.bool Exists(
   System.string name
)
Delphi
public function Exists(
    name: System.String
): System.Boolean;
JScript
public function Exists(
   name : System.String
) : System.boolean;
Managed Extensions for C++
public: System.bool Exists(
   System.string* name
)
C++/CLI
public:
System.bool Exists(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeCollection Class
WebTreeViewNodeCollection Members


GetItem Method

[image]
Intersoft WebTreeView Documentation
GetItem Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeCollection Class : GetItem Method

Glossary Item Box

Overload List

Overload | Description
GetItem(Int32) | (Inherited from ISNet.WebUI.ISCollectionBase)
GetItem(String) | (Inherited from ISNet.WebUI.ISCollectionBase)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeCollection Class
WebTreeViewNodeCollection Members


GetItem(Int32) Method

[image]
Intersoft WebTreeView Documentation
GetItem(Int32) Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeCollection Class > GetItem Method : GetItem(Int32) Method

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function GetItem( _
   ByVal index As System.Integer _
) As ISNet.WebUI.INamedObject
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeCollection
Dim index As System.Integer
Dim value As ISNet.WebUI.INamedObject

value = instance.GetItem(index)
C#
public virtual ISNet.WebUI.INamedObject GetItem(
   System.int index
)
Delphi
public function GetItem(
    index: System.Integer
): ISNet.WebUI.INamedObject; virtual;
JScript
public function GetItem(
   index : System.int
) : ISNet.WebUI.INamedObject;
Managed Extensions for C++
public: virtual ISNet.WebUI.INamedObject* GetItem(
   System.int index
)
C++/CLI
public:
virtual ISNet.WebUI.INamedObject^ GetItem(
   System.int index
)

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeCollection Class
WebTreeViewNodeCollection Members
Overload List


GetItem(String) Method

[image]
Intersoft WebTreeView Documentation
GetItem(String) Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeCollection Class > GetItem Method : GetItem(String) Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overloads Overridable Function GetItem( _
   ByVal name As System.String _
) As ISNet.WebUI.INamedObject
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeCollection
Dim name As System.String
Dim value As ISNet.WebUI.INamedObject

value = instance.GetItem(name)
C#
protected virtual ISNet.WebUI.INamedObject GetItem(
   System.string name
)
Delphi
protected function GetItem(
    name: System.String
): ISNet.WebUI.INamedObject; virtual;
JScript
protected function GetItem(
   name : System.String
) : ISNet.WebUI.INamedObject;
Managed Extensions for C++
protected: virtual ISNet.WebUI.INamedObject* GetItem(
   System.string* name
)
C++/CLI
protected:
virtual ISNet.WebUI.INamedObject^ GetItem(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeCollection Class
WebTreeViewNodeCollection Members
Overload List


IndexOf Method

[image]
Intersoft WebTreeView Documentation
IndexOf Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeCollection Class : IndexOf Method

Glossary Item Box

Overload List

Overload | Description
IndexOf(String) | (Inherited from ISNet.WebUI.ISCollectionBase)
IndexOf(INamedObject) | (Inherited from ISNet.WebUI.ISCollectionBase)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeCollection Class
WebTreeViewNodeCollection Members


IndexOf(INamedObject) Method

[image]
Intersoft WebTreeView Documentation
IndexOf(INamedObject) Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeCollection Class > IndexOf Method : IndexOf(INamedObject) Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function IndexOf( _
   ByVal value As ISNet.WebUI.INamedObject _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeCollection
Dim value As ISNet.WebUI.INamedObject
Dim value As System.Integer

value = instance.IndexOf(value)
C#
public System.int IndexOf(
   ISNet.WebUI.INamedObject value
)
Delphi
public function IndexOf(
    value: ISNet.WebUI.INamedObject
): System.Integer;
JScript
public function IndexOf(
   value : ISNet.WebUI.INamedObject
) : System.int;
Managed Extensions for C++
public: System.int IndexOf(
   ISNet.WebUI.INamedObject* value
)
C++/CLI
public:
System.int IndexOf(
   ISNet.WebUI.INamedObject^ value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeCollection Class
WebTreeViewNodeCollection Members
Overload List


IndexOf(String) Method

[image]
Intersoft WebTreeView Documentation
IndexOf(String) Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeCollection Class > IndexOf Method : IndexOf(String) Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function IndexOf( _
   ByVal name As System.String _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeCollection
Dim name As System.String
Dim value As System.Integer

value = instance.IndexOf(name)
C#
public virtual System.int IndexOf(
   System.string name
)
Delphi
public function IndexOf(
    name: System.String
): System.Integer; virtual;
JScript
public function IndexOf(
   name : System.String
) : System.int;
Managed Extensions for C++
public: virtual System.int IndexOf(
   System.string* name
)
C++/CLI
public:
virtual System.int IndexOf(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeCollection Class
WebTreeViewNodeCollection Members
Overload List


InnerList Property

[image]
Intersoft WebTreeView Documentation
InnerList Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeCollection Class : InnerList Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property InnerList As System.Collections.ArrayList
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeCollection
Dim value As System.Collections.ArrayList

value = instance.InnerList
C#
protected System.Collections.ArrayList InnerList {get;}
Delphi
protected read-only property InnerList: System.Collections.ArrayList;
JScript
protected function get InnerList : System.Collections.ArrayList
Managed Extensions for C++
protected: __property System.Collections.ArrayList* get_InnerList();
C++/CLI
protected:
property System.Collections.ArrayList^ InnerList {
   System.Collections.ArrayList^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeCollection Class
WebTreeViewNodeCollection Members


IntAdd Method

[image]
Intersoft WebTreeView Documentation
IntAdd Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeCollection Class : IntAdd Method

obj

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function IntAdd( _
   ByVal obj As ISNet.WebUI.INamedObject _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeCollection
Dim obj As ISNet.WebUI.INamedObject
Dim value As System.Integer

value = instance.IntAdd(obj)
C#
protected System.int IntAdd(
   ISNet.WebUI.INamedObject obj
)
Delphi
protected function IntAdd(
    obj: ISNet.WebUI.INamedObject
): System.Integer;
JScript
protected function IntAdd(
   obj : ISNet.WebUI.INamedObject
) : System.int;
Managed Extensions for C++
protected: System.int IntAdd(
   ISNet.WebUI.INamedObject* obj
)
C++/CLI
protected:
System.int IntAdd(
   ISNet.WebUI.INamedObject^ obj
)

Parameters

obj

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeCollection Class
WebTreeViewNodeCollection Members


IntClear Method

[image]
Intersoft WebTreeView Documentation
IntClear Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeCollection Class : IntClear Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Sub IntClear()
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeCollection

instance.IntClear()
C#
protected void IntClear()
Delphi
protected procedure IntClear();
JScript
protected function IntClear();
Managed Extensions for C++
protected: void IntClear();
C++/CLI
protected:
void IntClear();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeCollection Class
WebTreeViewNodeCollection Members


IntInsert Method

[image]
Intersoft WebTreeView Documentation
IntInsert Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeCollection Class : IntInsert Method

index
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub IntInsert( _
   ByVal index As System.Integer, _
   ByVal value As ISNet.WebUI.INamedObject _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeCollection
Dim index As System.Integer
Dim value As ISNet.WebUI.INamedObject

instance.IntInsert(index, value)
C#
public void IntInsert(
   System.int index,
   ISNet.WebUI.INamedObject value
)
Delphi
public procedure IntInsert(
    index: System.Integer;
    value: ISNet.WebUI.INamedObject
);
JScript
public function IntInsert(
   index : System.int,
   value : ISNet.WebUI.INamedObject
);
Managed Extensions for C++
public: void IntInsert(
   System.int index,
   ISNet.WebUI.INamedObject* value
)
C++/CLI
public:
void IntInsert(
   System.int index,
   ISNet.WebUI.INamedObject^ value
)

Parameters

index
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeCollection Class
WebTreeViewNodeCollection Members


IntRemove Method

[image]
Intersoft WebTreeView Documentation
IntRemove Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeCollection Class : IntRemove Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Sub IntRemove( _
   ByVal value As ISNet.WebUI.INamedObject _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeCollection
Dim value As ISNet.WebUI.INamedObject

instance.IntRemove(value)
C#
protected void IntRemove(
   ISNet.WebUI.INamedObject value
)
Delphi
protected procedure IntRemove(
    value: ISNet.WebUI.INamedObject
);
JScript
protected function IntRemove(
   value : ISNet.WebUI.INamedObject
);
Managed Extensions for C++
protected: void IntRemove(
   ISNet.WebUI.INamedObject* value
)
C++/CLI
protected:
void IntRemove(
   ISNet.WebUI.INamedObject^ value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeCollection Class
WebTreeViewNodeCollection Members


IntRemoveAt Method

[image]
Intersoft WebTreeView Documentation
IntRemoveAt Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeCollection Class : IntRemoveAt Method

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Sub IntRemoveAt( _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeCollection
Dim index As System.Integer

instance.IntRemoveAt(index)
C#
protected void IntRemoveAt(
   System.int index
)
Delphi
protected procedure IntRemoveAt(
    index: System.Integer
);
JScript
protected function IntRemoveAt(
   index : System.int
);
Managed Extensions for C++
protected: void IntRemoveAt(
   System.int index
)
C++/CLI
protected:
void IntRemoveAt(
   System.int index
)

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeCollection Class
WebTreeViewNodeCollection Members


List Property

[image]
Intersoft WebTreeView Documentation
List Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeCollection Class : List Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property List As System.Collections.IList
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeCollection
Dim value As System.Collections.IList

value = instance.List
C#
protected System.Collections.IList List {get;}
Delphi
protected read-only property List: System.Collections.IList;
JScript
protected function get List : System.Collections.IList
Managed Extensions for C++
protected: __property System.Collections.IList* get_List();
C++/CLI
protected:
property System.Collections.IList^ List {
   System.Collections.IList^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeCollection Class
WebTreeViewNodeCollection Members


OnClear Method

[image]
Intersoft WebTreeView Documentation
OnClear Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeCollection Class : OnClear Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnClear()
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeCollection

instance.OnClear()
C#
protected virtual void OnClear()
Delphi
protected procedure OnClear(); virtual;
JScript
protected function OnClear();
Managed Extensions for C++
protected: virtual void OnClear();
C++/CLI
protected:
virtual void OnClear();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeCollection Class
WebTreeViewNodeCollection Members


OnClearComplete Method

[image]
Intersoft WebTreeView Documentation
OnClearComplete Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeCollection Class : OnClearComplete Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnClearComplete()
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeCollection

instance.OnClearComplete()
C#
protected virtual void OnClearComplete()
Delphi
protected procedure OnClearComplete(); virtual;
JScript
protected function OnClearComplete();
Managed Extensions for C++
protected: virtual void OnClearComplete();
C++/CLI
protected:
virtual void OnClearComplete();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeCollection Class
WebTreeViewNodeCollection Members


OnInsert Method

[image]
Intersoft WebTreeView Documentation
OnInsert Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeCollection Class : OnInsert Method

index
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnInsert( _
   ByVal index As System.Integer, _
   ByVal value As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeCollection
Dim index As System.Integer
Dim value As System.Object

instance.OnInsert(index, value)
C#
protected virtual void OnInsert(
   System.int index,
   System.object value
)
Delphi
protected procedure OnInsert(
    index: System.Integer;
    value: System.TObject
); virtual;
JScript
protected function OnInsert(
   index : System.int,
   value : System.Object
);
Managed Extensions for C++
protected: virtual void OnInsert(
   System.int index,
   System.Object* value
)
C++/CLI
protected:
virtual void OnInsert(
   System.int index,
   System.Object^ value
)

Parameters

index
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeCollection Class
WebTreeViewNodeCollection Members


OnRemove Method

[image]
Intersoft WebTreeView Documentation
OnRemove Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeCollection Class : OnRemove Method

index
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnRemove( _
   ByVal index As System.Integer, _
   ByVal value As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeCollection
Dim index As System.Integer
Dim value As System.Object

instance.OnRemove(index, value)
C#
protected virtual void OnRemove(
   System.int index,
   System.object value
)
Delphi
protected procedure OnRemove(
    index: System.Integer;
    value: System.TObject
); virtual;
JScript
protected function OnRemove(
   index : System.int,
   value : System.Object
);
Managed Extensions for C++
protected: virtual void OnRemove(
   System.int index,
   System.Object* value
)
C++/CLI
protected:
virtual void OnRemove(
   System.int index,
   System.Object^ value
)

Parameters

index
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeCollection Class
WebTreeViewNodeCollection Members


OnRemoveComplete Method

[image]
Intersoft WebTreeView Documentation
OnRemoveComplete Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeCollection Class : OnRemoveComplete Method

index
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnRemoveComplete( _
   ByVal index As System.Integer, _
   ByVal value As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeCollection
Dim index As System.Integer
Dim value As System.Object

instance.OnRemoveComplete(index, value)
C#
protected virtual void OnRemoveComplete(
   System.int index,
   System.object value
)
Delphi
protected procedure OnRemoveComplete(
    index: System.Integer;
    value: System.TObject
); virtual;
JScript
protected function OnRemoveComplete(
   index : System.int,
   value : System.Object
);
Managed Extensions for C++
protected: virtual void OnRemoveComplete(
   System.int index,
   System.Object* value
)
C++/CLI
protected:
virtual void OnRemoveComplete(
   System.int index,
   System.Object^ value
)

Parameters

index
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeCollection Class
WebTreeViewNodeCollection Members


OnSet Method

[image]
Intersoft WebTreeView Documentation
OnSet Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeCollection Class : OnSet Method

index
oldValue
newValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnSet( _
   ByVal index As System.Integer, _
   ByVal oldValue As System.Object, _
   ByVal newValue As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeCollection
Dim index As System.Integer
Dim oldValue As System.Object
Dim newValue As System.Object

instance.OnSet(index, oldValue, newValue)
C#
protected virtual void OnSet(
   System.int index,
   System.object oldValue,
   System.object newValue
)
Delphi
protected procedure OnSet(
    index: System.Integer;
    oldValue: System.TObject;
    newValue: System.TObject
); virtual;
JScript
protected function OnSet(
   index : System.int,
   oldValue : System.Object,
   newValue : System.Object
);
Managed Extensions for C++
protected: virtual void OnSet(
   System.int index,
   System.Object* oldValue,
   System.Object* newValue
)
C++/CLI
protected:
virtual void OnSet(
   System.int index,
   System.Object^ oldValue,
   System.Object^ newValue
)

Parameters

index
oldValue
newValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeCollection Class
WebTreeViewNodeCollection Members


OnSetComplete Method

[image]
Intersoft WebTreeView Documentation
OnSetComplete Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeCollection Class : OnSetComplete Method

index
oldValue
newValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnSetComplete( _
   ByVal index As System.Integer, _
   ByVal oldValue As System.Object, _
   ByVal newValue As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeCollection
Dim index As System.Integer
Dim oldValue As System.Object
Dim newValue As System.Object

instance.OnSetComplete(index, oldValue, newValue)
C#
protected virtual void OnSetComplete(
   System.int index,
   System.object oldValue,
   System.object newValue
)
Delphi
protected procedure OnSetComplete(
    index: System.Integer;
    oldValue: System.TObject;
    newValue: System.TObject
); virtual;
JScript
protected function OnSetComplete(
   index : System.int,
   oldValue : System.Object,
   newValue : System.Object
);
Managed Extensions for C++
protected: virtual void OnSetComplete(
   System.int index,
   System.Object* oldValue,
   System.Object* newValue
)
C++/CLI
protected:
virtual void OnSetComplete(
   System.int index,
   System.Object^ oldValue,
   System.Object^ newValue
)

Parameters

index
oldValue
newValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeCollection Class
WebTreeViewNodeCollection Members


OnValidate Method

[image]
Intersoft WebTreeView Documentation
OnValidate Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeCollection Class : OnValidate Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnValidate( _
   ByVal value As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeCollection
Dim value As System.Object

instance.OnValidate(value)
C#
protected virtual void OnValidate(
   System.object value
)
Delphi
protected procedure OnValidate(
    value: System.TObject
); virtual;
JScript
protected function OnValidate(
   value : System.Object
);
Managed Extensions for C++
protected: virtual void OnValidate(
   System.Object* value
)
C++/CLI
protected:
virtual void OnValidate(
   System.Object^ value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeCollection Class
WebTreeViewNodeCollection Members


Parent Property

[image]
Intersoft WebTreeView Documentation
Parent Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeCollection Class : Parent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeCollection
Dim value As System.Object

value = instance.Parent
C#
public System.object Parent {get;}
Delphi
public read-only property Parent: System.TObject;
JScript
public function get Parent : System.Object
Managed Extensions for C++
public: __property System.Object* get_Parent();
C++/CLI
public:
property System.Object^ Parent {
   System.Object^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeCollection Class
WebTreeViewNodeCollection Members


setParent Method

[image]
Intersoft WebTreeView Documentation
setParent Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeCollection Class : setParent Method

parent

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub setParent( _
   ByVal parent As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeCollection
Dim parent As System.Object

instance.setParent(parent)
C#
public virtual void setParent(
   System.object parent
)
Delphi
public procedure setParent(
    parent: System.TObject
); virtual;
JScript
public function setParent(
   parent : System.Object
);
Managed Extensions for C++
public: virtual void setParent(
   System.Object* parent
)
C++/CLI
public:
virtual void setParent(
   System.Object^ parent
)

Parameters

parent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeCollection Class
WebTreeViewNodeCollection Members


WebTreeViewNodeSettings Class Methods

[image]
Intersoft WebTreeView Documentation
WebTreeViewNodeSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace : WebTreeViewNodeSettings Class

Glossary Item Box

For a list of all members of this type, see WebTreeViewNodeSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

Protected Methods

 | Name | Description
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | IsInSerializationContext | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebTreeViewNodeSettings Class
ISNet.WebUI.WebTreeView Namespace


Clone Method

[image]
Intersoft WebTreeView Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeSettings Class
WebTreeViewNodeSettings Members


CopyFrom Method

[image]
Intersoft WebTreeView Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeSettings Class
WebTreeViewNodeSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebTreeView Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeSettings Class
WebTreeViewNodeSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebTreeView Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeSettings Class
WebTreeViewNodeSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebTreeView Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeSettings Class
WebTreeViewNodeSettings Members


GetHashCode Method

[image]
Intersoft WebTreeView Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeSettings Class
WebTreeViewNodeSettings Members


GetPropertyString Method

[image]
Intersoft WebTreeView Documentation
GetPropertyString Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeSettings Class : GetPropertyString Method

v

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetPropertyString( _
   ByVal v As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeSettings
Dim v As System.String
Dim value As System.String

value = instance.GetPropertyString(v)
C#
protected virtual System.string GetPropertyString(
   System.string v
)
Delphi
protected function GetPropertyString(
    v: System.String
): System.String; virtual;
JScript
protected function GetPropertyString(
   v : System.String
) : System.String;
Managed Extensions for C++
protected: virtual System.string* GetPropertyString(
   System.string* v
)
C++/CLI
protected:
virtual System.String^ GetPropertyString(
   System.String^ v
)

Parameters

v

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeSettings Class
WebTreeViewNodeSettings Members


IsEmpty Method

[image]
Intersoft WebTreeView Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeSettings Class
WebTreeViewNodeSettings Members


IsInSerializationContext Method

[image]
Intersoft WebTreeView Documentation
IsInSerializationContext Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeSettings Class : IsInSerializationContext Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function IsInSerializationContext() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeSettings
Dim value As System.Boolean

value = instance.IsInSerializationContext()
C#
protected virtual System.bool IsInSerializationContext()
Delphi
protected function IsInSerializationContext(): System.Boolean; virtual;
JScript
protected function IsInSerializationContext() : System.boolean;
Managed Extensions for C++
protected: virtual System.bool IsInSerializationContext();
C++/CLI
protected:
virtual System.bool IsInSerializationContext();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeSettings Class
WebTreeViewNodeSettings Members


Reset Method

[image]
Intersoft WebTreeView Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeSettings Class
WebTreeViewNodeSettings Members


SerializeObjectData Method

[image]
Intersoft WebTreeView Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeSettings Class
WebTreeViewNodeSettings Members


ToString Method

[image]
Intersoft WebTreeView Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNodeSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNodeSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNodeSettings Class
WebTreeViewNodeSettings Members


Clone Method

[image]
Intersoft WebTreeView Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNode Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNode
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNode Class
WebTreeViewNode Members


Collection Property

[image]
Intersoft WebTreeView Documentation
Collection Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNode Class : Collection Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
Public Property Collection As ISNet.WebUI.ISCollectionBase
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNode
Dim value As ISNet.WebUI.ISCollectionBase

instance.Collection = value

value = instance.Collection
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public ISNet.WebUI.ISCollectionBase Collection {get; set;}
Delphi
public read-write property Collection: ISNet.WebUI.ISCollectionBase;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
public function get,set Collection : ISNet.WebUI.ISCollectionBase
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public: __property ISNet.WebUI.ISCollectionBase* get_Collection();
public: __property void set_Collection(
   ISNet.WebUI.ISCollectionBase* value
);
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public:
property ISNet.WebUI.ISCollectionBase^ Collection {
   ISNet.WebUI.ISCollectionBase^ get();
   void set (    ISNet.WebUI.ISCollectionBase^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNode Class
WebTreeViewNode Members


CopyFrom Method

[image]
Intersoft WebTreeView Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNode Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNode Class
WebTreeViewNode Members


CopyFrom(Object) Method

[image]
Intersoft WebTreeView Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNode Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNode
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNode Class
WebTreeViewNode Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebTreeView Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNode Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNode
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNode Class
WebTreeViewNode Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebTreeView Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNode Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNode
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNode Class
WebTreeViewNode Members


GetHashCode Method

[image]
Intersoft WebTreeView Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNode Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNode
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNode Class
WebTreeViewNode Members


GetPropertyString Method

[image]
Intersoft WebTreeView Documentation
GetPropertyString Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNode Class : GetPropertyString Method

v

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetPropertyString( _
   ByVal v As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNode
Dim v As System.String
Dim value As System.String

value = instance.GetPropertyString(v)
C#
protected virtual System.string GetPropertyString(
   System.string v
)
Delphi
protected function GetPropertyString(
    v: System.String
): System.String; virtual;
JScript
protected function GetPropertyString(
   v : System.String
) : System.String;
Managed Extensions for C++
protected: virtual System.string* GetPropertyString(
   System.string* v
)
C++/CLI
protected:
virtual System.String^ GetPropertyString(
   System.String^ v
)

Parameters

v

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNode Class
WebTreeViewNode Members


IsEmpty Method

[image]
Intersoft WebTreeView Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNode Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNode
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNode Class
WebTreeViewNode Members


IsInSerializationContext Method

[image]
Intersoft WebTreeView Documentation
IsInSerializationContext Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNode Class : IsInSerializationContext Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function IsInSerializationContext() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNode
Dim value As System.Boolean

value = instance.IsInSerializationContext()
C#
protected virtual System.bool IsInSerializationContext()
Delphi
protected function IsInSerializationContext(): System.Boolean; virtual;
JScript
protected function IsInSerializationContext() : System.boolean;
Managed Extensions for C++
protected: virtual System.bool IsInSerializationContext();
C++/CLI
protected:
virtual System.bool IsInSerializationContext();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNode Class
WebTreeViewNode Members


OnItemAdd Method

[image]
Intersoft WebTreeView Documentation
OnItemAdd Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNode Class : OnItemAdd Method

collection

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnItemAdd( _
   ByVal collection As ISNet.WebUI.ISCollectionBase _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNode
Dim collection As ISNet.WebUI.ISCollectionBase

instance.OnItemAdd(collection)
C#
protected virtual void OnItemAdd(
   ISNet.WebUI.ISCollectionBase collection
)
Delphi
protected procedure OnItemAdd(
    collection: ISNet.WebUI.ISCollectionBase
); virtual;
JScript
protected function OnItemAdd(
   collection : ISNet.WebUI.ISCollectionBase
);
Managed Extensions for C++
protected: virtual void OnItemAdd(
   ISNet.WebUI.ISCollectionBase* collection
)
C++/CLI
protected:
virtual void OnItemAdd(
   ISNet.WebUI.ISCollectionBase^ collection
)

Parameters

collection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNode Class
WebTreeViewNode Members


OnItemRemove Method

[image]
Intersoft WebTreeView Documentation
OnItemRemove Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNode Class : OnItemRemove Method

collection

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnItemRemove( _
   ByVal collection As ISNet.WebUI.ISCollectionBase _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNode
Dim collection As ISNet.WebUI.ISCollectionBase

instance.OnItemRemove(collection)
C#
protected virtual void OnItemRemove(
   ISNet.WebUI.ISCollectionBase collection
)
Delphi
protected procedure OnItemRemove(
    collection: ISNet.WebUI.ISCollectionBase
); virtual;
JScript
protected function OnItemRemove(
   collection : ISNet.WebUI.ISCollectionBase
);
Managed Extensions for C++
protected: virtual void OnItemRemove(
   ISNet.WebUI.ISCollectionBase* collection
)
C++/CLI
protected:
virtual void OnItemRemove(
   ISNet.WebUI.ISCollectionBase^ collection
)

Parameters

collection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNode Class
WebTreeViewNode Members


Reset Method

[image]
Intersoft WebTreeView Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNode Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNode

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNode Class
WebTreeViewNode Members


SerializeObjectData Method

[image]
Intersoft WebTreeView Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNode Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNode
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNode Class
WebTreeViewNode Members


ToString Method

[image]
Intersoft WebTreeView Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeViewNode Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeViewNode
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeViewNode Class
WebTreeViewNode Members


AccessKey Property

[image]
Intersoft WebTreeView Documentation
AccessKey Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : AccessKey Property

Glossary Item Box

Keyboard shortcut used by the control.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overridable Property AccessKey As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.String

instance.AccessKey = value

value = instance.AccessKey
C#
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public virtual System.string AccessKey {get; set;}
Delphi
public read-write property AccessKey: System.String; virtual;
JScript
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set AccessKey : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property virtual System.string* get_AccessKey();
public: __property virtual void set_AccessKey(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
virtual property System.String^ AccessKey {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


Adapter Property

[image]
Intersoft WebTreeView Documentation
Adapter Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : Adapter Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property Adapter As System.Web.UI.Adapters.ControlAdapter
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Web.UI.Adapters.ControlAdapter

value = instance.Adapter
C#
protected System.Web.UI.Adapters.ControlAdapter Adapter {get;}
Delphi
protected read-only property Adapter: System.Web.UI.Adapters.ControlAdapter;
JScript
protected function get Adapter : System.Web.UI.Adapters.ControlAdapter
Managed Extensions for C++
protected: __property System.Web.UI.Adapters.ControlAdapter* get_Adapter();
C++/CLI
protected:
property System.Web.UI.Adapters.ControlAdapter^ Adapter {
   System.Web.UI.Adapters.ControlAdapter^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


AddAttributesToRender Method

[image]
Intersoft WebTreeView Documentation
AddAttributesToRender Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : AddAttributesToRender Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub AddAttributesToRender( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim writer As System.Web.UI.HtmlTextWriter

instance.AddAttributesToRender(writer)
C#
protected virtual void AddAttributesToRender(
   System.Web.UI.HtmlTextWriter writer
)
Delphi
protected procedure AddAttributesToRender(
    writer: System.Web.UI.HtmlTextWriter
); virtual;
JScript
protected function AddAttributesToRender(
   writer : System.Web.UI.HtmlTextWriter
);
Managed Extensions for C++
protected: virtual void AddAttributesToRender(
   System.Web.UI.HtmlTextWriter* writer
)
C++/CLI
protected:
virtual void AddAttributesToRender(
   System.Web.UI.HtmlTextWriter^ writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


AddParsedSubObject Method

[image]
Intersoft WebTreeView Documentation
AddParsedSubObject Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : AddParsedSubObject Method

obj

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Protected Overridable Sub AddParsedSubObject( _
   ByVal obj As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim obj As System.Object

instance.AddParsedSubObject(obj)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
protected virtual void AddParsedSubObject(
   System.object obj
)
Delphi
protected procedure AddParsedSubObject(
    obj: System.TObject
); virtual;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
protected function AddParsedSubObject(
   obj : System.Object
);
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
protected: virtual void AddParsedSubObject(
   System.Object* obj
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
protected:
virtual void AddParsedSubObject(
   System.Object^ obj
)

Parameters

obj

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


ApplyControlTheme Method

[image]
Intersoft WebTreeView Documentation
ApplyControlTheme Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : ApplyControlTheme Method

themeInfo

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function ApplyControlTheme( _
   ByVal themeInfo As ISNet.WebUI.ThemeInfo _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim themeInfo As ISNet.WebUI.ThemeInfo
Dim value As System.Boolean

value = instance.ApplyControlTheme(themeInfo)
C#
protected virtual System.bool ApplyControlTheme(
   ISNet.WebUI.ThemeInfo themeInfo
)
Delphi
protected function ApplyControlTheme(
    themeInfo: ISNet.WebUI.ThemeInfo
): System.Boolean; virtual;
JScript
protected function ApplyControlTheme(
   themeInfo : ISNet.WebUI.ThemeInfo
) : System.boolean;
Managed Extensions for C++
protected: virtual System.bool ApplyControlTheme(
   ISNet.WebUI.ThemeInfo* themeInfo
)
C++/CLI
protected:
virtual System.bool ApplyControlTheme(
   ISNet.WebUI.ThemeInfo^ themeInfo
)

Parameters

themeInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


ApplyStyle Method

[image]
Intersoft WebTreeView Documentation
ApplyStyle Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : ApplyStyle Method

s

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ApplyStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim s As System.Web.UI.WebControls.Style

instance.ApplyStyle(s)
C#
public void ApplyStyle(
   System.Web.UI.WebControls.Style s
)
Delphi
public procedure ApplyStyle(
    s: System.Web.UI.WebControls.Style
);
JScript
public function ApplyStyle(
   s : System.Web.UI.WebControls.Style
);
Managed Extensions for C++
public: void ApplyStyle(
   System.Web.UI.WebControls.Style* s
)
C++/CLI
public:
void ApplyStyle(
   System.Web.UI.WebControls.Style^ s
)

Parameters

s

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


ApplyStyleSheetSkin Method

[image]
Intersoft WebTreeView Documentation
ApplyStyleSheetSkin Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : ApplyStyleSheetSkin Method

page

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Overridable Sub ApplyStyleSheetSkin( _
   ByVal page As System.Web.UI.Page _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim page As System.Web.UI.Page

instance.ApplyStyleSheetSkin(page)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page page
)
Delphi
public procedure ApplyStyleSheetSkin(
    page: System.Web.UI.Page
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function ApplyStyleSheetSkin(
   page : System.Web.UI.Page
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page* page
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page^ page
)

Parameters

page

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


AppRelativeTemplateSourceDirectory Property

[image]
Intersoft WebTreeView Documentation
AppRelativeTemplateSourceDirectory Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : AppRelativeTemplateSourceDirectory Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<WebSysDescriptionAttribute("The virtual directory of the Page or UserControl that contains this control.")>
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property AppRelativeTemplateSourceDirectory As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.String

instance.AppRelativeTemplateSourceDirectory = value

value = instance.AppRelativeTemplateSourceDirectory
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[WebSysDescriptionAttribute("The virtual directory of the Page or UserControl that contains this control.")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public System.string AppRelativeTemplateSourceDirectory {get; set;}
Delphi
public read-write property AppRelativeTemplateSourceDirectory: System.String;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
WebSysDescriptionAttribute("The virtual directory of the Page or UserControl that contains this control.")
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get,set AppRelativeTemplateSourceDirectory : System.String
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[WebSysDescriptionAttribute("The virtual directory of the Page or UserControl that contains this control.")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property System.string* get_AppRelativeTemplateSourceDirectory();
public: __property void set_AppRelativeTemplateSourceDirectory(
   System.string* value
);
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[WebSysDescriptionAttribute("The virtual directory of the Page or UserControl that contains this control.")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property System.String^ AppRelativeTemplateSourceDirectory {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


AspNetAjaxSettings Property

[image]
Intersoft WebTreeView Documentation
AspNetAjaxSettings Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : AspNetAjaxSettings Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DefaultValueAttribute()>
Public ReadOnly Property AspNetAjaxSettings As ISNet.WebUI.AspNetAjaxSettings
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As ISNet.WebUI.AspNetAjaxSettings

value = instance.AspNetAjaxSettings
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
public ISNet.WebUI.AspNetAjaxSettings AspNetAjaxSettings {get;}
Delphi
public read-only property AspNetAjaxSettings: ISNet.WebUI.AspNetAjaxSettings;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get AspNetAjaxSettings : ISNet.WebUI.AspNetAjaxSettings
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property ISNet.WebUI.AspNetAjaxSettings* get_AspNetAjaxSettings();
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property ISNet.WebUI.AspNetAjaxSettings^ AspNetAjaxSettings {
   ISNet.WebUI.AspNetAjaxSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


AssignXmlInputHiddenUniqueID Method

[image]
Intersoft WebTreeView Documentation
AssignXmlInputHiddenUniqueID Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : AssignXmlInputHiddenUniqueID Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub AssignXmlInputHiddenUniqueID()
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView

instance.AssignXmlInputHiddenUniqueID()
C#
protected virtual void AssignXmlInputHiddenUniqueID()
Delphi
protected procedure AssignXmlInputHiddenUniqueID(); virtual;
JScript
protected function AssignXmlInputHiddenUniqueID();
Managed Extensions for C++
protected: virtual void AssignXmlInputHiddenUniqueID();
C++/CLI
protected:
virtual void AssignXmlInputHiddenUniqueID();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


Attributes Property

[image]
Intersoft WebTreeView Documentation
Attributes Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : Attributes Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Tag attributes of the control.")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
Public ReadOnly Property Attributes As System.Web.UI.AttributeCollection
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Web.UI.AttributeCollection

value = instance.Attributes
C#
[WebSysDescriptionAttribute("Tag attributes of the control.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public System.Web.UI.AttributeCollection Attributes {get;}
Delphi
public read-only property Attributes: System.Web.UI.AttributeCollection;
JScript
WebSysDescriptionAttribute("Tag attributes of the control.")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
public function get Attributes : System.Web.UI.AttributeCollection
Managed Extensions for C++
[WebSysDescriptionAttribute("Tag attributes of the control.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public: __property System.Web.UI.AttributeCollection* get_Attributes();
C++/CLI
[WebSysDescriptionAttribute("Tag attributes of the control.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public:
property System.Web.UI.AttributeCollection^ Attributes {
   System.Web.UI.AttributeCollection^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


BackColor Property

[image]
Intersoft WebTreeView Documentation
BackColor Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : BackColor Property

Glossary Item Box

Color of the background of the control.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Frame Appearance")>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Overridable Property BackColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Drawing.Color

instance.BackColor = value

value = instance.BackColor
C#
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
public virtual System.Drawing.Color BackColor {get; set;}
Delphi
public read-write property BackColor: System.Drawing.Color; virtual;
JScript
System.ComponentModel.CategoryAttribute("Frame Appearance")
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
ISNet.Serialization.BinarySerializableAttribute()
public function get,set BackColor : System.Drawing.Color
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property virtual System.Drawing.Color get_BackColor();
public: __property virtual void set_BackColor(
   System.Drawing.Color value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
virtual property System.Drawing.Color BackColor {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


BorderColor Property

[image]
Intersoft WebTreeView Documentation
BorderColor Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : BorderColor Property

Glossary Item Box

Color of the border around the control.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Frame Appearance")>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)>
Public Overridable Property BorderColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Drawing.Color

instance.BorderColor = value

value = instance.BorderColor
C#
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
public virtual System.Drawing.Color BorderColor {get; set;}
Delphi
public read-write property BorderColor: System.Drawing.Color; virtual;
JScript
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Frame Appearance")
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)
public function get,set BorderColor : System.Drawing.Color
Managed Extensions for C++
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
public: __property virtual System.Drawing.Color get_BorderColor();
public: __property virtual void set_BorderColor(
   System.Drawing.Color value
);
C++/CLI
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
public:
virtual property System.Drawing.Color BorderColor {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


BorderStyle Property

[image]
Intersoft WebTreeView Documentation
BorderStyle Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : BorderStyle Property

Glossary Item Box

Style of the border around the control.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Frame Appearance")>
Public Overridable Property BorderStyle As System.Web.UI.WebControls.BorderStyle
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Web.UI.WebControls.BorderStyle

instance.BorderStyle = value

value = instance.BorderStyle
C#
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
public virtual System.Web.UI.WebControls.BorderStyle BorderStyle {get; set;}
Delphi
public read-write property BorderStyle: System.Web.UI.WebControls.BorderStyle; virtual;
JScript
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Frame Appearance")
public function get,set BorderStyle : System.Web.UI.WebControls.BorderStyle
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
public: __property virtual System.Web.UI.WebControls.BorderStyle get_BorderStyle();
public: __property virtual void set_BorderStyle(
   System.Web.UI.WebControls.BorderStyle value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
public:
virtual property System.Web.UI.WebControls.BorderStyle BorderStyle {
   System.Web.UI.WebControls.BorderStyle get();
   void set (    System.Web.UI.WebControls.BorderStyle value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


BorderWidth Property

[image]
Intersoft WebTreeView Documentation
BorderWidth Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : BorderWidth Property

Glossary Item Box

Width of the border around the control.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.CategoryAttribute("Frame Appearance")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Overridable Property BorderWidth As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Web.UI.WebControls.Unit

instance.BorderWidth = value

value = instance.BorderWidth
C#
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
public virtual System.Web.UI.WebControls.Unit BorderWidth {get; set;}
Delphi
public read-write property BorderWidth: System.Web.UI.WebControls.Unit; virtual;
JScript
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.CategoryAttribute("Frame Appearance")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set BorderWidth : System.Web.UI.WebControls.Unit
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property virtual System.Web.UI.WebControls.Unit get_BorderWidth();
public: __property virtual void set_BorderWidth(
   System.Web.UI.WebControls.Unit value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
virtual property System.Web.UI.WebControls.Unit BorderWidth {
   System.Web.UI.WebControls.Unit get();
   void set (    System.Web.UI.WebControls.Unit value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


BuildProfileTree Method

[image]
Intersoft WebTreeView Documentation
BuildProfileTree Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : BuildProfileTree Method

parentId
calcViewState

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Sub BuildProfileTree( _
   ByVal parentId As System.String, _
   ByVal calcViewState As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim parentId As System.String
Dim calcViewState As System.Boolean

instance.BuildProfileTree(parentId, calcViewState)
C#
protected void BuildProfileTree(
   System.string parentId,
   System.bool calcViewState
)
Delphi
protected procedure BuildProfileTree(
    parentId: System.String;
    calcViewState: System.Boolean
);
JScript
protected function BuildProfileTree(
   parentId : System.String,
   calcViewState : System.boolean
);
Managed Extensions for C++
protected: void BuildProfileTree(
   System.string* parentId,
   System.bool calcViewState
)
C++/CLI
protected:
void BuildProfileTree(
   System.String^ parentId,
   System.bool calcViewState
)

Parameters

parentId
calcViewState

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


CanUseWebResources Method

[image]
Intersoft WebTreeView Documentation
CanUseWebResources Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : CanUseWebResources Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CanUseWebResources() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Boolean

value = instance.CanUseWebResources()
C#
public System.bool CanUseWebResources()
Delphi
public function CanUseWebResources(): System.Boolean;
JScript
public function CanUseWebResources() : System.boolean;
Managed Extensions for C++
public: System.bool CanUseWebResources();
C++/CLI
public:
System.bool CanUseWebResources();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


ChildControlsCreated Property

[image]
Intersoft WebTreeView Documentation
ChildControlsCreated Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : ChildControlsCreated Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Property ChildControlsCreated As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Boolean

instance.ChildControlsCreated = value

value = instance.ChildControlsCreated
C#
protected System.bool ChildControlsCreated {get; set;}
Delphi
protected read-write property ChildControlsCreated: System.Boolean;
JScript
protected function get,set ChildControlsCreated : System.boolean
Managed Extensions for C++
protected: __property System.bool get_ChildControlsCreated();
protected: __property void set_ChildControlsCreated(
   System.bool value
);
C++/CLI
protected:
property System.bool ChildControlsCreated {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


ClearCachedClientID Method

[image]
Intersoft WebTreeView Documentation
ClearCachedClientID Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : ClearCachedClientID Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Sub ClearCachedClientID()
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView

instance.ClearCachedClientID()
C#
protected void ClearCachedClientID()
Delphi
protected procedure ClearCachedClientID();
JScript
protected function ClearCachedClientID();
Managed Extensions for C++
protected: void ClearCachedClientID();
C++/CLI
protected:
void ClearCachedClientID();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


ClearChildControlState Method

[image]
Intersoft WebTreeView Documentation
ClearChildControlState Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : ClearChildControlState Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Sub ClearChildControlState()
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView

instance.ClearChildControlState()
C#
protected void ClearChildControlState()
Delphi
protected procedure ClearChildControlState();
JScript
protected function ClearChildControlState();
Managed Extensions for C++
protected: void ClearChildControlState();
C++/CLI
protected:
void ClearChildControlState();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


ClearChildState Method

[image]
Intersoft WebTreeView Documentation
ClearChildState Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : ClearChildState Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Sub ClearChildState()
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView

instance.ClearChildState()
C#
protected void ClearChildState()
Delphi
protected procedure ClearChildState();
JScript
protected function ClearChildState();
Managed Extensions for C++
protected: void ClearChildState();
C++/CLI
protected:
void ClearChildState();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


ClearChildViewState Method

[image]
Intersoft WebTreeView Documentation
ClearChildViewState Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : ClearChildViewState Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Sub ClearChildViewState()
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView

instance.ClearChildViewState()
C#
protected void ClearChildViewState()
Delphi
protected procedure ClearChildViewState();
JScript
protected function ClearChildViewState();
Managed Extensions for C++
protected: void ClearChildViewState();
C++/CLI
protected:
void ClearChildViewState();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


ClearEffectiveClientIDMode Method

[image]
Intersoft WebTreeView Documentation
ClearEffectiveClientIDMode Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : ClearEffectiveClientIDMode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Sub ClearEffectiveClientIDMode()
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView

instance.ClearEffectiveClientIDMode()
C#
protected void ClearEffectiveClientIDMode()
Delphi
protected procedure ClearEffectiveClientIDMode();
JScript
protected function ClearEffectiveClientIDMode();
Managed Extensions for C++
protected: void ClearEffectiveClientIDMode();
C++/CLI
protected:
void ClearEffectiveClientIDMode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


ClientID Property

[image]
Intersoft WebTreeView Documentation
ClientID Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : ClientID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<WebSysDescriptionAttribute("The ID of the control that is rendered for the client.")>
Public Overridable ReadOnly Property ClientID As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.String

value = instance.ClientID
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[WebSysDescriptionAttribute("The ID of the control that is rendered for the client.")]
public virtual System.string ClientID {get;}
Delphi
public read-only property ClientID: System.String; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
WebSysDescriptionAttribute("The ID of the control that is rendered for the client.")
public function get ClientID : System.String
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[WebSysDescriptionAttribute("The ID of the control that is rendered for the client.")]
public: __property virtual System.string* get_ClientID();
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[WebSysDescriptionAttribute("The ID of the control that is rendered for the client.")]
public:
virtual property System.String^ ClientID {
   System.String^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


ClientIDMode Property

[image]
Intersoft WebTreeView Documentation
ClientIDMode Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : ClientIDMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.ThemeableAttribute(False)>
<WebCategoryAttribute("Behavior")>
<System.ComponentModel.DefaultValueAttribute()>
<WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")>
Public Overridable Property ClientIDMode As System.Web.UI.ClientIDMode
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Web.UI.ClientIDMode

instance.ClientIDMode = value

value = instance.ClientIDMode
C#
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")]
public virtual System.Web.UI.ClientIDMode ClientIDMode {get; set;}
Delphi
public read-write property ClientIDMode: System.Web.UI.ClientIDMode; virtual;
JScript
System.Web.UI.ThemeableAttribute()
WebCategoryAttribute("Behavior")
System.ComponentModel.DefaultValueAttribute()
WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")
public function get,set ClientIDMode : System.Web.UI.ClientIDMode
Managed Extensions for C++
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")]
public: __property virtual System.Web.UI.ClientIDMode get_ClientIDMode();
public: __property virtual void set_ClientIDMode(
   System.Web.UI.ClientIDMode value
);
C++/CLI
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")]
public:
virtual property System.Web.UI.ClientIDMode ClientIDMode {
   System.Web.UI.ClientIDMode get();
   void set (    System.Web.UI.ClientIDMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


ClientIDSeparator Property

[image]
Intersoft WebTreeView Documentation
ClientIDSeparator Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : ClientIDSeparator Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property ClientIDSeparator As System.Char
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Char

value = instance.ClientIDSeparator
C#
protected System.char ClientIDSeparator {get;}
Delphi
protected read-only property ClientIDSeparator: System.Char;
JScript
protected function get ClientIDSeparator : System.char
Managed Extensions for C++
protected: __property System.char get_ClientIDSeparator();
C++/CLI
protected:
property System.char ClientIDSeparator {
   System.char get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


Clone Method

[image]
Intersoft WebTreeView Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


ControlDataTransferFormat Property

[image]
Intersoft WebTreeView Documentation
ControlDataTransferFormat Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : ControlDataTransferFormat Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines the format used to exchange the control's data across client and server.")>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Overridable Property ControlDataTransferFormat As ISNet.WebUI.DataTransferFormat
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As ISNet.WebUI.DataTransferFormat

instance.ControlDataTransferFormat = value

value = instance.ControlDataTransferFormat
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines the format used to exchange the control's data across client and server.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
public virtual ISNet.WebUI.DataTransferFormat ControlDataTransferFormat {get; set;}
Delphi
public read-write property ControlDataTransferFormat: ISNet.WebUI.DataTransferFormat; virtual;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines the format used to exchange the control's data across client and server.")
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set ControlDataTransferFormat : ISNet.WebUI.DataTransferFormat
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines the format used to exchange the control's data across client and server.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property virtual ISNet.WebUI.DataTransferFormat get_ControlDataTransferFormat();
public: __property virtual void set_ControlDataTransferFormat(
   ISNet.WebUI.DataTransferFormat value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines the format used to exchange the control's data across client and server.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
virtual property ISNet.WebUI.DataTransferFormat ControlDataTransferFormat {
   ISNet.WebUI.DataTransferFormat get();
   void set (    ISNet.WebUI.DataTransferFormat value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


ControlRequestHandler Method

[image]
Intersoft WebTreeView Documentation
ControlRequestHandler Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : ControlRequestHandler Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Sub ControlRequestHandler()
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView

instance.ControlRequestHandler()
C#
protected void ControlRequestHandler()
Delphi
protected procedure ControlRequestHandler();
JScript
protected function ControlRequestHandler();
Managed Extensions for C++
protected: void ControlRequestHandler();
C++/CLI
protected:
void ControlRequestHandler();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


Controls Property

[image]
Intersoft WebTreeView Documentation
Controls Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : Controls Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("The collection of child controls owned by the control.")>
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Overridable ReadOnly Property Controls As System.Web.UI.ControlCollection
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Web.UI.ControlCollection

value = instance.Controls
C#
[WebSysDescriptionAttribute("The collection of child controls owned by the control.")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public virtual System.Web.UI.ControlCollection Controls {get;}
Delphi
public read-only property Controls: System.Web.UI.ControlCollection; virtual;
JScript
WebSysDescriptionAttribute("The collection of child controls owned by the control.")
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get Controls : System.Web.UI.ControlCollection
Managed Extensions for C++
[WebSysDescriptionAttribute("The collection of child controls owned by the control.")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property virtual System.Web.UI.ControlCollection* get_Controls();
C++/CLI
[WebSysDescriptionAttribute("The collection of child controls owned by the control.")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
virtual property System.Web.UI.ControlCollection^ Controls {
   System.Web.UI.ControlCollection^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


ControlStyle Property

[image]
Intersoft WebTreeView Documentation
ControlStyle Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : ControlStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("The style associated with the control.")>
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public ReadOnly Property ControlStyle As System.Web.UI.WebControls.Style
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Web.UI.WebControls.Style

value = instance.ControlStyle
C#
[WebSysDescriptionAttribute("The style associated with the control.")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public System.Web.UI.WebControls.Style ControlStyle {get;}
Delphi
public read-only property ControlStyle: System.Web.UI.WebControls.Style;
JScript
WebSysDescriptionAttribute("The style associated with the control.")
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get ControlStyle : System.Web.UI.WebControls.Style
Managed Extensions for C++
[WebSysDescriptionAttribute("The style associated with the control.")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property System.Web.UI.WebControls.Style* get_ControlStyle();
C++/CLI
[WebSysDescriptionAttribute("The style associated with the control.")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property System.Web.UI.WebControls.Style^ ControlStyle {
   System.Web.UI.WebControls.Style^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


ControlStyleCreated Property

[image]
Intersoft WebTreeView Documentation
ControlStyleCreated Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : ControlStyleCreated Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
<WebSysDescriptionAttribute("Whether the style associated with the control has been created.")>
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public ReadOnly Property ControlStyleCreated As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Boolean

value = instance.ControlStyleCreated
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[WebSysDescriptionAttribute("Whether the style associated with the control has been created.")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public System.bool ControlStyleCreated {get;}
Delphi
public read-only property ControlStyleCreated: System.Boolean;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
WebSysDescriptionAttribute("Whether the style associated with the control has been created.")
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function get ControlStyleCreated : System.boolean
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[WebSysDescriptionAttribute("Whether the style associated with the control has been created.")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: __property System.bool get_ControlStyleCreated();
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[WebSysDescriptionAttribute("Whether the style associated with the control has been created.")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
property System.bool ControlStyleCreated {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


CopyBaseAttributes Method

[image]
Intersoft WebTreeView Documentation
CopyBaseAttributes Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : CopyBaseAttributes Method

controlSrc

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CopyBaseAttributes( _
   ByVal controlSrc As System.Web.UI.WebControls.WebControl _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim controlSrc As System.Web.UI.WebControls.WebControl

instance.CopyBaseAttributes(controlSrc)
C#
public void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl controlSrc
)
Delphi
public procedure CopyBaseAttributes(
    controlSrc: System.Web.UI.WebControls.WebControl
);
JScript
public function CopyBaseAttributes(
   controlSrc : System.Web.UI.WebControls.WebControl
);
Managed Extensions for C++
public: void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl* controlSrc
)
C++/CLI
public:
void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl^ controlSrc
)

Parameters

controlSrc

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


CopyFrom Method

[image]
Intersoft WebTreeView Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.ISNetControl)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


CopyFrom(Object) Method

[image]
Intersoft WebTreeView Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebTreeView Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members
Overload List


CreateControlCollection Method

[image]
Intersoft WebTreeView Documentation
CreateControlCollection Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : CreateControlCollection Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function CreateControlCollection() As System.Web.UI.ControlCollection
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Web.UI.ControlCollection

value = instance.CreateControlCollection()
C#
protected virtual System.Web.UI.ControlCollection CreateControlCollection()
Delphi
protected function CreateControlCollection(): System.Web.UI.ControlCollection; virtual;
JScript
protected function CreateControlCollection() : System.Web.UI.ControlCollection;
Managed Extensions for C++
protected: virtual System.Web.UI.ControlCollection* CreateControlCollection();
C++/CLI
protected:
virtual System.Web.UI.ControlCollection^ CreateControlCollection();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


CreateControlStyle Method

[image]
Intersoft WebTreeView Documentation
CreateControlStyle Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : CreateControlStyle Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function CreateControlStyle() As System.Web.UI.WebControls.Style
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Web.UI.WebControls.Style

value = instance.CreateControlStyle()
C#
protected virtual System.Web.UI.WebControls.Style CreateControlStyle()
Delphi
protected function CreateControlStyle(): System.Web.UI.WebControls.Style; virtual;
JScript
protected function CreateControlStyle() : System.Web.UI.WebControls.Style;
Managed Extensions for C++
protected: virtual System.Web.UI.WebControls.Style* CreateControlStyle();
C++/CLI
protected:
virtual System.Web.UI.WebControls.Style^ CreateControlStyle();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


CreateThemeInfo Method

[image]
Intersoft WebTreeView Documentation
CreateThemeInfo Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : CreateThemeInfo Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function CreateThemeInfo() As ISNet.WebUI.ThemeInfo
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As ISNet.WebUI.ThemeInfo

value = instance.CreateThemeInfo()
C#
protected virtual ISNet.WebUI.ThemeInfo CreateThemeInfo()
Delphi
protected function CreateThemeInfo(): ISNet.WebUI.ThemeInfo; virtual;
JScript
protected function CreateThemeInfo() : ISNet.WebUI.ThemeInfo;
Managed Extensions for C++
protected: virtual ISNet.WebUI.ThemeInfo* CreateThemeInfo();
C++/CLI
protected:
virtual ISNet.WebUI.ThemeInfo^ CreateThemeInfo();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


CssClass Property

[image]
Intersoft WebTreeView Documentation
CssClass Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : CssClass Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Frame Appearance")>
Public Overridable Property CssClass As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.String

instance.CssClass = value

value = instance.CssClass
C#
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
public virtual System.string CssClass {get; set;}
Delphi
public read-write property CssClass: System.String; virtual;
JScript
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Frame Appearance")
public function get,set CssClass : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
public: __property virtual System.string* get_CssClass();
public: __property virtual void set_CssClass(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
public:
virtual property System.String^ CssClass {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


DataBind(Boolean) Method

[image]
Intersoft WebTreeView Documentation
DataBind(Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class > DataBind Method : DataBind(Boolean) Method

raiseOnDataBinding

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overloads Overridable Sub DataBind( _
   ByVal raiseOnDataBinding As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim raiseOnDataBinding As System.Boolean

instance.DataBind(raiseOnDataBinding)
C#
protected virtual void DataBind(
   System.bool raiseOnDataBinding
)
Delphi
protected procedure DataBind(
    raiseOnDataBinding: System.Boolean
); virtual;
JScript
protected function DataBind(
   raiseOnDataBinding : System.boolean
);
Managed Extensions for C++
protected: virtual void DataBind(
   System.bool raiseOnDataBinding
)
C++/CLI
protected:
virtual void DataBind(
   System.bool raiseOnDataBinding
)

Parameters

raiseOnDataBinding

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members
Overload List


DataBindChildren Method

[image]
Intersoft WebTreeView Documentation
DataBindChildren Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : DataBindChildren Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub DataBindChildren()
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView

instance.DataBindChildren()
C#
protected virtual void DataBindChildren()
Delphi
protected procedure DataBindChildren(); virtual;
JScript
protected function DataBindChildren();
Managed Extensions for C++
protected: virtual void DataBindChildren();
C++/CLI
protected:
virtual void DataBindChildren();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


DataBinding Event

[image]
Intersoft WebTreeView Documentation
DataBinding Event
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : DataBinding Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the control's data binding expressions are to be evaluated.")>
<WebCategoryAttribute("Data")>
Public Event DataBinding As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim handler As System.EventHandler

AddHandler instance.DataBinding, handler
C#
[WebSysDescriptionAttribute("Fires when the control's data binding expressions are to be evaluated.")]
[WebCategoryAttribute("Data")]
public event System.EventHandler DataBinding
Delphi
public event DataBinding: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the control's data binding expressions are to be evaluated.")]
[WebCategoryAttribute("Data")]
public: __event System.EventHandler* DataBinding
C++/CLI
[WebSysDescriptionAttribute("Fires when the control's data binding expressions are to be evaluated.")]
[WebCategoryAttribute("Data")]
public:
event System.EventHandler^ DataBinding

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


DecodeRequest Method

[image]
Intersoft WebTreeView Documentation
DecodeRequest Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : DecodeRequest Method

request

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function DecodeRequest( _
   ByVal request As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim request As System.String
Dim value As System.String

value = instance.DecodeRequest(request)
C#
protected System.string DecodeRequest(
   System.string request
)
Delphi
protected function DecodeRequest(
    request: System.String
): System.String;
JScript
protected function DecodeRequest(
   request : System.String
) : System.String;
Managed Extensions for C++
protected: System.string* DecodeRequest(
   System.string* request
)
C++/CLI
protected:
System.String^ DecodeRequest(
   System.String^ request
)

Parameters

request

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


DeSerializeObjectData Method

[image]
Intersoft WebTreeView Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


Dispose Method

[image]
Intersoft WebTreeView Documentation
Dispose Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : Dispose Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView

instance.Dispose()
C#
public virtual void Dispose()
Delphi
public procedure Dispose(); virtual;
JScript
public function Dispose();
Managed Extensions for C++
public: virtual void Dispose();
C++/CLI
public:
virtual void Dispose();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


Disposed Event

[image]
Intersoft WebTreeView Documentation
Disposed Event
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : Disposed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the control has been disposed.")>
Public Event Disposed As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim handler As System.EventHandler

AddHandler instance.Disposed, handler
C#
[WebSysDescriptionAttribute("Fires when the control has been disposed.")]
public event System.EventHandler Disposed
Delphi
public event Disposed: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the control has been disposed.")]
public: __event System.EventHandler* Disposed
C++/CLI
[WebSysDescriptionAttribute("Fires when the control has been disposed.")]
public:
event System.EventHandler^ Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


Enabled Property

[image]
Intersoft WebTreeView Documentation
Enabled Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : Enabled Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Overridable Property Enabled As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Boolean

instance.Enabled = value

value = instance.Enabled
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public virtual System.bool Enabled {get; set;}
Delphi
public read-write property Enabled: System.Boolean; virtual;
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set Enabled : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property virtual System.bool get_Enabled();
public: __property virtual void set_Enabled(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
virtual property System.bool Enabled {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


EnableManagedTheming Property

[image]
Intersoft WebTreeView Documentation
EnableManagedTheming Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : EnableManagedTheming Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Overridable Property EnableManagedTheming As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Boolean

instance.EnableManagedTheming = value

value = instance.EnableManagedTheming
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public virtual System.bool EnableManagedTheming {get; set;}
Delphi
public read-write property EnableManagedTheming: System.Boolean; virtual;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set EnableManagedTheming : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property virtual System.bool get_EnableManagedTheming();
public: __property virtual void set_EnableManagedTheming(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
virtual property System.bool EnableManagedTheming {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


EnableTheming Property

[image]
Intersoft WebTreeView Documentation
EnableTheming Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : EnableTheming Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(True)>
Public Overridable Property EnableTheming As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Boolean

instance.EnableTheming = value

value = instance.EnableTheming
C#
[System.ComponentModel.BrowsableAttribute(true)]
public virtual System.bool EnableTheming {get; set;}
Delphi
public read-write property EnableTheming: System.Boolean; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
public function get,set EnableTheming : System.boolean
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(true)]
public: __property virtual System.bool get_EnableTheming();
public: __property virtual void set_EnableTheming(
   System.bool value
);
C++/CLI
[System.ComponentModel.BrowsableAttribute(true)]
public:
virtual property System.bool EnableTheming {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


EnableViewState Property

[image]
Intersoft WebTreeView Documentation
EnableViewState Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : EnableViewState Property

Glossary Item Box

Specifies whether the control automatically saves its state for use in round-trips.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overridable Property EnableViewState As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Boolean

instance.EnableViewState = value

value = instance.EnableViewState
C#
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public virtual System.bool EnableViewState {get; set;}
Delphi
public read-write property EnableViewState: System.Boolean; virtual;
JScript
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set EnableViewState : System.boolean
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property virtual System.bool get_EnableViewState();
public: __property virtual void set_EnableViewState(
   System.bool value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
virtual property System.bool EnableViewState {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


EnableWebResources Property

[image]
Intersoft WebTreeView Documentation
EnableWebResources Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : EnableWebResources Property

Glossary Item Box

Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory).

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). See help for more information and remarks.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Web Resources")>
Public Property EnableWebResources As ISNet.WebUI.WebResourceType
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As ISNet.WebUI.WebResourceType

instance.EnableWebResources = value

value = instance.EnableWebResources
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). See help for more information and remarks.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Web Resources")]
public ISNet.WebUI.WebResourceType EnableWebResources {get; set;}
Delphi
public read-write property EnableWebResources: ISNet.WebUI.WebResourceType;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). See help for more information and remarks.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Web Resources")
public function get,set EnableWebResources : ISNet.WebUI.WebResourceType
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). See help for more information and remarks.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Web Resources")]
public: __property ISNet.WebUI.WebResourceType get_EnableWebResources();
public: __property void set_EnableWebResources(
   ISNet.WebUI.WebResourceType value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). See help for more information and remarks.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Web Resources")]
public:
property ISNet.WebUI.WebResourceType EnableWebResources {
   ISNet.WebUI.WebResourceType get();
   void set (    ISNet.WebUI.WebResourceType value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


EnsureChildControls Method

[image]
Intersoft WebTreeView Documentation
EnsureChildControls Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : EnsureChildControls Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub EnsureChildControls()
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView

instance.EnsureChildControls()
C#
protected virtual void EnsureChildControls()
Delphi
protected procedure EnsureChildControls(); virtual;
JScript
protected function EnsureChildControls();
Managed Extensions for C++
protected: virtual void EnsureChildControls();
C++/CLI
protected:
virtual void EnsureChildControls();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


EnsureID Method

[image]
Intersoft WebTreeView Documentation
EnsureID Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : EnsureID Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Sub EnsureID()
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView

instance.EnsureID()
C#
protected void EnsureID()
Delphi
protected procedure EnsureID();
JScript
protected function EnsureID();
Managed Extensions for C++
protected: void EnsureID();
C++/CLI
protected:
void EnsureID();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


Events Property

[image]
Intersoft WebTreeView Documentation
Events Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : Events Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property Events As System.ComponentModel.EventHandlerList
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.ComponentModel.EventHandlerList

value = instance.Events
C#
protected System.ComponentModel.EventHandlerList Events {get;}
Delphi
protected read-only property Events: System.ComponentModel.EventHandlerList;
JScript
protected function get Events : System.ComponentModel.EventHandlerList
Managed Extensions for C++
protected: __property System.ComponentModel.EventHandlerList* get_Events();
C++/CLI
protected:
property System.ComponentModel.EventHandlerList^ Events {
   System.ComponentModel.EventHandlerList^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


FindControl Method

[image]
Intersoft WebTreeView Documentation
FindControl Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : FindControl Method

Glossary Item Box

Overload List

Overload | Description
FindControl(String) | (Inherited from ISNet.WebUI.ISNetControl)
FindControl(String,Int32) | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


FindControl(String) Method

[image]
Intersoft WebTreeView Documentation
FindControl(String) Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class > FindControl Method : FindControl(String) Method

id

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function FindControl( _
   ByVal id As System.String _
) As System.Web.UI.Control
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim id As System.String
Dim value As System.Web.UI.Control

value = instance.FindControl(id)
C#
public virtual System.Web.UI.Control FindControl(
   System.string id
)
Delphi
public function FindControl(
    id: System.String
): System.Web.UI.Control; virtual;
JScript
public function FindControl(
   id : System.String
) : System.Web.UI.Control;
Managed Extensions for C++
public: virtual System.Web.UI.Control* FindControl(
   System.string* id
)
C++/CLI
public:
virtual System.Web.UI.Control^ FindControl(
   System.String^ id
)

Parameters

id

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members
Overload List


FindControl(String,Int32) Method

[image]
Intersoft WebTreeView Documentation
FindControl(String,Int32) Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class > FindControl Method : FindControl(String,Int32) Method

id
pathOffset

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overloads Overridable Function FindControl( _
   ByVal id As System.String, _
   ByVal pathOffset As System.Integer _
) As System.Web.UI.Control
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim id As System.String
Dim pathOffset As System.Integer
Dim value As System.Web.UI.Control

value = instance.FindControl(id, pathOffset)
C#
protected virtual System.Web.UI.Control FindControl(
   System.string id,
   System.int pathOffset
)
Delphi
protected function FindControl(
    id: System.String;
    pathOffset: System.Integer
): System.Web.UI.Control; virtual;
JScript
protected function FindControl(
   id : System.String,
   pathOffset : System.int
) : System.Web.UI.Control;
Managed Extensions for C++
protected: virtual System.Web.UI.Control* FindControl(
   System.string* id,
   System.int pathOffset
)
C++/CLI
protected:
virtual System.Web.UI.Control^ FindControl(
   System.String^ id,
   System.int pathOffset
)

Parameters

id
pathOffset

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members
Overload List


Focus Method

[image]
Intersoft WebTreeView Documentation
Focus Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : Focus Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Focus()
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView

instance.Focus()
C#
public virtual void Focus()
Delphi
public procedure Focus(); virtual;
JScript
public function Focus();
Managed Extensions for C++
public: virtual void Focus();
C++/CLI
public:
virtual void Focus();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


ForceDisableXmlCompression Method

[image]
Intersoft WebTreeView Documentation
ForceDisableXmlCompression Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : ForceDisableXmlCompression Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ForceDisableXmlCompression()
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView

instance.ForceDisableXmlCompression()
C#
public void ForceDisableXmlCompression()
Delphi
public procedure ForceDisableXmlCompression();
JScript
public function ForceDisableXmlCompression();
Managed Extensions for C++
public: void ForceDisableXmlCompression();
C++/CLI
public:
void ForceDisableXmlCompression();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


ForeColor Property

[image]
Intersoft WebTreeView Documentation
ForeColor Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : ForeColor Property

Glossary Item Box

Color of the text within the control.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.CategoryAttribute("Frame Appearance")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Overridable Property ForeColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Drawing.Color

instance.ForeColor = value

value = instance.ForeColor
C#
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
public virtual System.Drawing.Color ForeColor {get; set;}
Delphi
public read-write property ForeColor: System.Drawing.Color; virtual;
JScript
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.CategoryAttribute("Frame Appearance")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set ForeColor : System.Drawing.Color
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property virtual System.Drawing.Color get_ForeColor();
public: __property virtual void set_ForeColor(
   System.Drawing.Color value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
virtual property System.Drawing.Color ForeColor {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


GetApplicationState Method

[image]
Intersoft WebTreeView Documentation
GetApplicationState Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : GetApplicationState Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetApplicationState() As System.Web.HttpApplicationState
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Web.HttpApplicationState

value = instance.GetApplicationState()
C#
protected virtual System.Web.HttpApplicationState GetApplicationState()
Delphi
protected function GetApplicationState(): System.Web.HttpApplicationState; virtual;
JScript
protected function GetApplicationState() : System.Web.HttpApplicationState;
Managed Extensions for C++
protected: virtual System.Web.HttpApplicationState* GetApplicationState();
C++/CLI
protected:
virtual System.Web.HttpApplicationState^ GetApplicationState();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


GetCachedAppTheme Method

[image]
Intersoft WebTreeView Documentation
GetCachedAppTheme Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : GetCachedAppTheme Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function GetCachedAppTheme() As ISNet.WebUI.ThemeInfo
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As ISNet.WebUI.ThemeInfo

value = instance.GetCachedAppTheme()
C#
protected ISNet.WebUI.ThemeInfo GetCachedAppTheme()
Delphi
protected function GetCachedAppTheme(): ISNet.WebUI.ThemeInfo;
JScript
protected function GetCachedAppTheme() : ISNet.WebUI.ThemeInfo;
Managed Extensions for C++
protected: ISNet.WebUI.ThemeInfo* GetCachedAppTheme();
C++/CLI
protected:
ISNet.WebUI.ThemeInfo^ GetCachedAppTheme();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


GetCurrentControlLifeCycle Method

[image]
Intersoft WebTreeView Documentation
GetCurrentControlLifeCycle Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : GetCurrentControlLifeCycle Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetCurrentControlLifeCycle() As ISNet.WebUI.ControlLifeCycle
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As ISNet.WebUI.ControlLifeCycle

value = instance.GetCurrentControlLifeCycle()
C#
public ISNet.WebUI.ControlLifeCycle GetCurrentControlLifeCycle()
Delphi
public function GetCurrentControlLifeCycle(): ISNet.WebUI.ControlLifeCycle;
JScript
public function GetCurrentControlLifeCycle() : ISNet.WebUI.ControlLifeCycle;
Managed Extensions for C++
public: ISNet.WebUI.ControlLifeCycle GetCurrentControlLifeCycle();
C++/CLI
public:
ISNet.WebUI.ControlLifeCycle GetCurrentControlLifeCycle();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


GetCurrentTheme Method

[image]
Intersoft WebTreeView Documentation
GetCurrentTheme Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : GetCurrentTheme Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetCurrentTheme() As ISNet.WebUI.ThemeInfo
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As ISNet.WebUI.ThemeInfo

value = instance.GetCurrentTheme()
C#
public ISNet.WebUI.ThemeInfo GetCurrentTheme()
Delphi
public function GetCurrentTheme(): ISNet.WebUI.ThemeInfo;
JScript
public function GetCurrentTheme() : ISNet.WebUI.ThemeInfo;
Managed Extensions for C++
public: ISNet.WebUI.ThemeInfo* GetCurrentTheme();
C++/CLI
public:
ISNet.WebUI.ThemeInfo^ GetCurrentTheme();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


GetDesignModeState Method

[image]
Intersoft WebTreeView Documentation
GetDesignModeState Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : GetDesignModeState Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.NoFlags,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=False,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=True)>
Protected Overridable Function GetDesignModeState() As System.Collections.IDictionary
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Collections.IDictionary

value = instance.GetDesignModeState()
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.NoFlags,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=true)]
protected virtual System.Collections.IDictionary GetDesignModeState()
Delphi
protected function GetDesignModeState(): System.Collections.IDictionary; virtual;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.NoFlags,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
protected function GetDesignModeState() : System.Collections.IDictionary;
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.NoFlags,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=true)]
protected: virtual System.Collections.IDictionary* GetDesignModeState();
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.NoFlags,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=true)]
protected:
virtual System.Collections.IDictionary^ GetDesignModeState();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


GetFrameworkDataFolder Method

[image]
Intersoft WebTreeView Documentation
GetFrameworkDataFolder Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : GetFrameworkDataFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkDataFolder() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.String

value = instance.GetFrameworkDataFolder()
C#
public System.string GetFrameworkDataFolder()
Delphi
public function GetFrameworkDataFolder(): System.String;
JScript
public function GetFrameworkDataFolder() : System.String;
Managed Extensions for C++
public: System.string* GetFrameworkDataFolder();
C++/CLI
public:
System.String^ GetFrameworkDataFolder();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


GetFrameworkFolder Method

[image]
Intersoft WebTreeView Documentation
GetFrameworkFolder Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : GetFrameworkFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkFolder() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.String

value = instance.GetFrameworkFolder()
C#
public System.string GetFrameworkFolder()
Delphi
public function GetFrameworkFolder(): System.String;
JScript
public function GetFrameworkFolder() : System.String;
Managed Extensions for C++
public: System.string* GetFrameworkFolder();
C++/CLI
public:
System.String^ GetFrameworkFolder();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


GetFrameworkVersion Method

[image]
Intersoft WebTreeView Documentation
GetFrameworkVersion Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : GetFrameworkVersion Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkVersion() As System.Version
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Version

value = instance.GetFrameworkVersion()
C#
public System.Version GetFrameworkVersion()
Delphi
public function GetFrameworkVersion(): System.Version;
JScript
public function GetFrameworkVersion() : System.Version;
Managed Extensions for C++
public: System.Version* GetFrameworkVersion();
C++/CLI
public:
System.Version^ GetFrameworkVersion();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


GetIntersoftFolder Method

[image]
Intersoft WebTreeView Documentation
GetIntersoftFolder Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : GetIntersoftFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetIntersoftFolder() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.String

value = instance.GetIntersoftFolder()
C#
public System.string GetIntersoftFolder()
Delphi
public function GetIntersoftFolder(): System.String;
JScript
public function GetIntersoftFolder() : System.String;
Managed Extensions for C++
public: System.string* GetIntersoftFolder();
C++/CLI
public:
System.String^ GetIntersoftFolder();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


GetLayoutFolder Method

[image]
Intersoft WebTreeView Documentation
GetLayoutFolder Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : GetLayoutFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetLayoutFolder() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.String

value = instance.GetLayoutFolder()
C#
public System.string GetLayoutFolder()
Delphi
public function GetLayoutFolder(): System.String;
JScript
public function GetLayoutFolder() : System.String;
Managed Extensions for C++
public: System.string* GetLayoutFolder();
C++/CLI
public:
System.String^ GetLayoutFolder();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


GetPostedXMLData Method

[image]
Intersoft WebTreeView Documentation
GetPostedXMLData Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : GetPostedXMLData Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetPostedXMLData() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.String

value = instance.GetPostedXMLData()
C#
public System.string GetPostedXMLData()
Delphi
public function GetPostedXMLData(): System.String;
JScript
public function GetPostedXMLData() : System.String;
Managed Extensions for C++
public: System.string* GetPostedXMLData();
C++/CLI
public:
System.String^ GetPostedXMLData();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


GetProductInfoKey Method

[image]
Intersoft WebTreeView Documentation
GetProductInfoKey Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : GetProductInfoKey Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetProductInfoKey() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.String

value = instance.GetProductInfoKey()
C#
public System.string GetProductInfoKey()
Delphi
public function GetProductInfoKey(): System.String;
JScript
public function GetProductInfoKey() : System.String;
Managed Extensions for C++
public: System.string* GetProductInfoKey();
C++/CLI
public:
System.String^ GetProductInfoKey();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


GetProductSimpleName Method

[image]
Intersoft WebTreeView Documentation
GetProductSimpleName Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : GetProductSimpleName Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetProductSimpleName() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.String

value = instance.GetProductSimpleName()
C#
public System.string GetProductSimpleName()
Delphi
public function GetProductSimpleName(): System.String;
JScript
public function GetProductSimpleName() : System.String;
Managed Extensions for C++
public: System.string* GetProductSimpleName();
C++/CLI
public:
System.String^ GetProductSimpleName();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


GetPropertyString Method

[image]
Intersoft WebTreeView Documentation
GetPropertyString Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : GetPropertyString Method

v

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetPropertyString( _
   ByVal v As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim v As System.String
Dim value As System.String

value = instance.GetPropertyString(v)
C#
protected virtual System.string GetPropertyString(
   System.string v
)
Delphi
protected function GetPropertyString(
    v: System.String
): System.String; virtual;
JScript
protected function GetPropertyString(
   v : System.String
) : System.String;
Managed Extensions for C++
protected: virtual System.string* GetPropertyString(
   System.string* v
)
C++/CLI
protected:
virtual System.String^ GetPropertyString(
   System.String^ v
)

Parameters

v

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


GetPropertyValue Method

[image]
Intersoft WebTreeView Documentation
GetPropertyValue Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : GetPropertyValue Method

defValue
propValue
webConfigKey

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetPropertyValue( _
   ByVal defValue As System.String, _
   ByVal propValue As System.String, _
   ByVal webConfigKey As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim defValue As System.String
Dim propValue As System.String
Dim webConfigKey As System.String
Dim value As System.String

value = instance.GetPropertyValue(defValue, propValue, webConfigKey)
C#
public System.string GetPropertyValue(
   System.string defValue,
   System.string propValue,
   System.string webConfigKey
)
Delphi
public function GetPropertyValue(
    defValue: System.String;
    propValue: System.String;
    webConfigKey: System.String
): System.String;
JScript
public function GetPropertyValue(
   defValue : System.String,
   propValue : System.String,
   webConfigKey : System.String
) : System.String;
Managed Extensions for C++
public: System.string* GetPropertyValue(
   System.string* defValue,
   System.string* propValue,
   System.string* webConfigKey
)
C++/CLI
public:
System.String^ GetPropertyValue(
   System.String^ defValue,
   System.String^ propValue,
   System.String^ webConfigKey
)

Parameters

defValue
propValue
webConfigKey

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


GetResourceStream Method

[image]
Intersoft WebTreeView Documentation
GetResourceStream Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : GetResourceStream Method

resourceUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetResourceStream( _
   ByVal resourceUrl As System.String _
) As System.IO.Stream
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim resourceUrl As System.String
Dim value As System.IO.Stream

value = instance.GetResourceStream(resourceUrl)
C#
public System.IO.Stream GetResourceStream(
   System.string resourceUrl
)
Delphi
public function GetResourceStream(
    resourceUrl: System.String
): System.IO.Stream;
JScript
public function GetResourceStream(
   resourceUrl : System.String
) : System.IO.Stream;
Managed Extensions for C++
public: System.IO.Stream* GetResourceStream(
   System.string* resourceUrl
)
C++/CLI
public:
System.IO.Stream^ GetResourceStream(
   System.String^ resourceUrl
)

Parameters

resourceUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


GetRouteUrl Method

[image]
Intersoft WebTreeView Documentation
GetRouteUrl Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : GetRouteUrl Method

Glossary Item Box

Overload List

Overload | Description
GetRouteUrl(Object) | (Inherited from System.Web.UI.Control)
GetRouteUrl(String,Object) | (Inherited from System.Web.UI.Control)
GetRouteUrl(RouteValueDictionary) | (Inherited from System.Web.UI.Control)
GetRouteUrl(String,RouteValueDictionary) | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


GetRouteUrl(Object) Method

[image]
Intersoft WebTreeView Documentation
GetRouteUrl(Object) Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class > GetRouteUrl Method : GetRouteUrl(Object) Method

routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As System.Object _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim routeParameters As System.Object
Dim value As System.String

value = instance.GetRouteUrl(routeParameters)
C#
public System.string GetRouteUrl(
   System.object routeParameters
)
Delphi
public function GetRouteUrl(
    routeParameters: System.TObject
): System.String;
JScript
public function GetRouteUrl(
   routeParameters : System.Object
) : System.String;
Managed Extensions for C++
public: System.string* GetRouteUrl(
   System.Object* routeParameters
)
C++/CLI
public:
System.String^ GetRouteUrl(
   System.Object^ routeParameters
)

Parameters

routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members
Overload List


GetRouteUrl(RouteValueDictionary) Method

[image]
Intersoft WebTreeView Documentation
GetRouteUrl(RouteValueDictionary) Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class > GetRouteUrl Method : GetRouteUrl(RouteValueDictionary) Method

routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim routeParameters As System.Web.Routing.RouteValueDictionary
Dim value As System.String

value = instance.GetRouteUrl(routeParameters)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.string GetRouteUrl(
   System.Web.Routing.RouteValueDictionary routeParameters
)
Delphi
public function GetRouteUrl(
    routeParameters: System.Web.Routing.RouteValueDictionary
): System.String;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function GetRouteUrl(
   routeParameters : System.Web.Routing.RouteValueDictionary
) : System.String;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.string* GetRouteUrl(
   System.Web.Routing.RouteValueDictionary* routeParameters
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.String^ GetRouteUrl(
   System.Web.Routing.RouteValueDictionary^ routeParameters
)

Parameters

routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members
Overload List


GetRouteUrl(String,Object) Method

[image]
Intersoft WebTreeView Documentation
GetRouteUrl(String,Object) Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class > GetRouteUrl Method : GetRouteUrl(String,Object) Method

routeName
routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeName As System.String, _
   ByVal routeParameters As System.Object _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim routeName As System.String
Dim routeParameters As System.Object
Dim value As System.String

value = instance.GetRouteUrl(routeName, routeParameters)
C#
public System.string GetRouteUrl(
   System.string routeName,
   System.object routeParameters
)
Delphi
public function GetRouteUrl(
    routeName: System.String;
    routeParameters: System.TObject
): System.String;
JScript
public function GetRouteUrl(
   routeName : System.String,
   routeParameters : System.Object
) : System.String;
Managed Extensions for C++
public: System.string* GetRouteUrl(
   System.string* routeName,
   System.Object* routeParameters
)
C++/CLI
public:
System.String^ GetRouteUrl(
   System.String^ routeName,
   System.Object^ routeParameters
)

Parameters

routeName
routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members
Overload List


GetRouteUrl(String,RouteValueDictionary) Method

[image]
Intersoft WebTreeView Documentation
GetRouteUrl(String,RouteValueDictionary) Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class > GetRouteUrl Method : GetRouteUrl(String,RouteValueDictionary) Method

routeName
routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeName As System.String, _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim routeName As System.String
Dim routeParameters As System.Web.Routing.RouteValueDictionary
Dim value As System.String

value = instance.GetRouteUrl(routeName, routeParameters)
C#
public System.string GetRouteUrl(
   System.string routeName,
   System.Web.Routing.RouteValueDictionary routeParameters
)
Delphi
public function GetRouteUrl(
    routeName: System.String;
    routeParameters: System.Web.Routing.RouteValueDictionary
): System.String;
JScript
public function GetRouteUrl(
   routeName : System.String,
   routeParameters : System.Web.Routing.RouteValueDictionary
) : System.String;
Managed Extensions for C++
public: System.string* GetRouteUrl(
   System.string* routeName,
   System.Web.Routing.RouteValueDictionary* routeParameters
)
C++/CLI
public:
System.String^ GetRouteUrl(
   System.String^ routeName,
   System.Web.Routing.RouteValueDictionary^ routeParameters
)

Parameters

routeName
routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members
Overload List


GetSessionLevelTheme Method

[image]
Intersoft WebTreeView Documentation
GetSessionLevelTheme Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : GetSessionLevelTheme Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function GetSessionLevelTheme() As ISNet.WebUI.ThemeInfo
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As ISNet.WebUI.ThemeInfo

value = instance.GetSessionLevelTheme()
C#
protected ISNet.WebUI.ThemeInfo GetSessionLevelTheme()
Delphi
protected function GetSessionLevelTheme(): ISNet.WebUI.ThemeInfo;
JScript
protected function GetSessionLevelTheme() : ISNet.WebUI.ThemeInfo;
Managed Extensions for C++
protected: ISNet.WebUI.ThemeInfo* GetSessionLevelTheme();
C++/CLI
protected:
ISNet.WebUI.ThemeInfo^ GetSessionLevelTheme();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


GetUniqueIDRelativeTo Method

[image]
Intersoft WebTreeView Documentation
GetUniqueIDRelativeTo Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : GetUniqueIDRelativeTo Method

control

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetUniqueIDRelativeTo( _
   ByVal control As System.Web.UI.Control _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim control As System.Web.UI.Control
Dim value As System.String

value = instance.GetUniqueIDRelativeTo(control)
C#
public System.string GetUniqueIDRelativeTo(
   System.Web.UI.Control control
)
Delphi
public function GetUniqueIDRelativeTo(
    control: System.Web.UI.Control
): System.String;
JScript
public function GetUniqueIDRelativeTo(
   control : System.Web.UI.Control
) : System.String;
Managed Extensions for C++
public: System.string* GetUniqueIDRelativeTo(
   System.Web.UI.Control* control
)
C++/CLI
public:
System.String^ GetUniqueIDRelativeTo(
   System.Web.UI.Control^ control
)

Parameters

control

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


HasAttributes Property

[image]
Intersoft WebTreeView Documentation
HasAttributes Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : HasAttributes Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public ReadOnly Property HasAttributes As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Boolean

value = instance.HasAttributes
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public System.bool HasAttributes {get;}
Delphi
public read-only property HasAttributes: System.Boolean;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get HasAttributes : System.boolean
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property System.bool get_HasAttributes();
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property System.bool HasAttributes {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


HasChildViewState Property

[image]
Intersoft WebTreeView Documentation
HasChildViewState Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : HasChildViewState Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property HasChildViewState As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Boolean

value = instance.HasChildViewState
C#
protected System.bool HasChildViewState {get;}
Delphi
protected read-only property HasChildViewState: System.Boolean;
JScript
protected function get HasChildViewState : System.boolean
Managed Extensions for C++
protected: __property System.bool get_HasChildViewState();
C++/CLI
protected:
property System.bool HasChildViewState {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


HasControls Method

[image]
Intersoft WebTreeView Documentation
HasControls Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : HasControls Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function HasControls() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Boolean

value = instance.HasControls()
C#
public virtual System.bool HasControls()
Delphi
public function HasControls(): System.Boolean; virtual;
JScript
public function HasControls() : System.boolean;
Managed Extensions for C++
public: virtual System.bool HasControls();
C++/CLI
public:
virtual System.bool HasControls();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


HasEvents Method

[image]
Intersoft WebTreeView Documentation
HasEvents Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : HasEvents Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Protected Function HasEvents() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Boolean

value = instance.HasEvents()
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
protected System.bool HasEvents()
Delphi
protected function HasEvents(): System.Boolean;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
protected function HasEvents() : System.boolean;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
protected: System.bool HasEvents();
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
protected:
System.bool HasEvents();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


Height Property

[image]
Intersoft WebTreeView Documentation
Height Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : Height Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Layout")>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Overridable Property Height As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Web.UI.WebControls.Unit

instance.Height = value

value = instance.Height
C#
[System.ComponentModel.CategoryAttribute("Layout")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
public virtual System.Web.UI.WebControls.Unit Height {get; set;}
Delphi
public read-write property Height: System.Web.UI.WebControls.Unit; virtual;
JScript
System.ComponentModel.CategoryAttribute("Layout")
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
ISNet.Serialization.BinarySerializableAttribute()
public function get,set Height : System.Web.UI.WebControls.Unit
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Layout")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property virtual System.Web.UI.WebControls.Unit get_Height();
public: __property virtual void set_Height(
   System.Web.UI.WebControls.Unit value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Layout")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
virtual property System.Web.UI.WebControls.Unit Height {
   System.Web.UI.WebControls.Unit get();
   void set (    System.Web.UI.WebControls.Unit value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


ID Property

[image]
Intersoft WebTreeView Documentation
ID Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : ID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.FilterableAttribute(False)>
<System.Web.UI.ThemeableAttribute(False)>
<WebSysDescriptionAttribute("Programmatic name of the control.")>
<System.ComponentModel.ParenthesizePropertyNameAttribute(True)>
<System.ComponentModel.MergablePropertyAttribute(False)>
Public Overridable Property ID As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.String

instance.ID = value

value = instance.ID
C#
[System.Web.UI.FilterableAttribute(false)]
[System.Web.UI.ThemeableAttribute(false)]
[WebSysDescriptionAttribute("Programmatic name of the control.")]
[System.ComponentModel.ParenthesizePropertyNameAttribute(true)]
[System.ComponentModel.MergablePropertyAttribute(false)]
public virtual System.string ID {get; set;}
Delphi
public read-write property ID: System.String; virtual;
JScript
System.Web.UI.FilterableAttribute()
System.Web.UI.ThemeableAttribute()
WebSysDescriptionAttribute("Programmatic name of the control.")
System.ComponentModel.ParenthesizePropertyNameAttribute()
System.ComponentModel.MergablePropertyAttribute()
public function get,set ID : System.String
Managed Extensions for C++
[System.Web.UI.FilterableAttribute(false)]
[System.Web.UI.ThemeableAttribute(false)]
[WebSysDescriptionAttribute("Programmatic name of the control.")]
[System.ComponentModel.ParenthesizePropertyNameAttribute(true)]
[System.ComponentModel.MergablePropertyAttribute(false)]
public: __property virtual System.string* get_ID();
public: __property virtual void set_ID(
   System.string* value
);
C++/CLI
[System.Web.UI.FilterableAttribute(false)]
[System.Web.UI.ThemeableAttribute(false)]
[WebSysDescriptionAttribute("Programmatic name of the control.")]
[System.ComponentModel.ParenthesizePropertyNameAttribute(true)]
[System.ComponentModel.MergablePropertyAttribute(false)]
public:
virtual property System.String^ ID {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


IdSeparator Property

[image]
Intersoft WebTreeView Documentation
IdSeparator Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : IdSeparator Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property IdSeparator As System.Char
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Char

value = instance.IdSeparator
C#
protected System.char IdSeparator {get;}
Delphi
protected read-only property IdSeparator: System.Char;
JScript
protected function get IdSeparator : System.char
Managed Extensions for C++
protected: __property System.char get_IdSeparator();
C++/CLI
protected:
property System.char IdSeparator {
   System.char get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


Init Event

[image]
Intersoft WebTreeView Documentation
Init Event
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : Init Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the page has been initialized.")>
Public Event Init As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim handler As System.EventHandler

AddHandler instance.Init, handler
C#
[WebSysDescriptionAttribute("Fires when the page has been initialized.")]
public event System.EventHandler Init
Delphi
public event Init: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the page has been initialized.")]
public: __event System.EventHandler* Init
C++/CLI
[WebSysDescriptionAttribute("Fires when the page has been initialized.")]
public:
event System.EventHandler^ Init

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


InitializeLayoutBehaviors Method

[image]
Intersoft WebTreeView Documentation
InitializeLayoutBehaviors Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : InitializeLayoutBehaviors Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub InitializeLayoutBehaviors()
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView

instance.InitializeLayoutBehaviors()
C#
protected virtual void InitializeLayoutBehaviors()
Delphi
protected procedure InitializeLayoutBehaviors(); virtual;
JScript
protected function InitializeLayoutBehaviors();
Managed Extensions for C++
protected: virtual void InitializeLayoutBehaviors();
C++/CLI
protected:
virtual void InitializeLayoutBehaviors();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


InitializeManagedTheming Method

[image]
Intersoft WebTreeView Documentation
InitializeManagedTheming Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : InitializeManagedTheming Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub InitializeManagedTheming()
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView

instance.InitializeManagedTheming()
C#
protected virtual void InitializeManagedTheming()
Delphi
protected procedure InitializeManagedTheming(); virtual;
JScript
protected function InitializeManagedTheming();
Managed Extensions for C++
protected: virtual void InitializeManagedTheming();
C++/CLI
protected:
virtual void InitializeManagedTheming();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


IsApplicationAvailable Method

[image]
Intersoft WebTreeView Documentation
IsApplicationAvailable Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : IsApplicationAvailable Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function IsApplicationAvailable() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Boolean

value = instance.IsApplicationAvailable()
C#
protected System.bool IsApplicationAvailable()
Delphi
protected function IsApplicationAvailable(): System.Boolean;
JScript
protected function IsApplicationAvailable() : System.boolean;
Managed Extensions for C++
protected: System.bool IsApplicationAvailable();
C++/CLI
protected:
System.bool IsApplicationAvailable();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


IsAppThemeEnabled Method

[image]
Intersoft WebTreeView Documentation
IsAppThemeEnabled Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : IsAppThemeEnabled Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function IsAppThemeEnabled() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Boolean

value = instance.IsAppThemeEnabled()
C#
protected virtual System.bool IsAppThemeEnabled()
Delphi
protected function IsAppThemeEnabled(): System.Boolean; virtual;
JScript
protected function IsAppThemeEnabled() : System.boolean;
Managed Extensions for C++
protected: virtual System.bool IsAppThemeEnabled();
C++/CLI
protected:
virtual System.bool IsAppThemeEnabled();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


IsAtlasCallback Method

[image]
Intersoft WebTreeView Documentation
IsAtlasCallback Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : IsAtlasCallback Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsAtlasCallback() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Boolean

value = instance.IsAtlasCallback()
C#
public System.bool IsAtlasCallback()
Delphi
public function IsAtlasCallback(): System.Boolean;
JScript
public function IsAtlasCallback() : System.boolean;
Managed Extensions for C++
public: System.bool IsAtlasCallback();
C++/CLI
public:
System.bool IsAtlasCallback();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


IsBetaRelease Method

[image]
Intersoft WebTreeView Documentation
IsBetaRelease Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : IsBetaRelease Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsBetaRelease() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Boolean

value = instance.IsBetaRelease()
C#
public System.bool IsBetaRelease()
Delphi
public function IsBetaRelease(): System.Boolean;
JScript
public function IsBetaRelease() : System.boolean;
Managed Extensions for C++
public: System.bool IsBetaRelease();
C++/CLI
public:
System.bool IsBetaRelease();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


IsChromeBrowser Method

[image]
Intersoft WebTreeView Documentation
IsChromeBrowser Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : IsChromeBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsChromeBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Boolean

value = instance.IsChromeBrowser()
C#
public System.bool IsChromeBrowser()
Delphi
public function IsChromeBrowser(): System.Boolean;
JScript
public function IsChromeBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsChromeBrowser();
C++/CLI
public:
System.bool IsChromeBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


IsControlThemed Property

[image]
Intersoft WebTreeView Documentation
IsControlThemed Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : IsControlThemed Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public ReadOnly Property IsControlThemed As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Boolean

value = instance.IsControlThemed
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public System.bool IsControlThemed {get;}
Delphi
public read-only property IsControlThemed: System.Boolean;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get IsControlThemed : System.boolean
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property System.bool get_IsControlThemed();
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property System.bool IsControlThemed {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


IsDesign Property

[image]
Intersoft WebTreeView Documentation
IsDesign Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : IsDesign Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Overridable ReadOnly Property IsDesign As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Boolean

value = instance.IsDesign
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public virtual System.bool IsDesign {get;}
Delphi
public read-only property IsDesign: System.Boolean; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get IsDesign : System.boolean
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property virtual System.bool get_IsDesign();
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
virtual property System.bool IsDesign {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


IsDynamicCreated Property

[image]
Intersoft WebTreeView Documentation
IsDynamicCreated Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : IsDynamicCreated Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
Public Property IsDynamicCreated As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Boolean

instance.IsDynamicCreated = value

value = instance.IsDynamicCreated
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public System.bool IsDynamicCreated {get; set;}
Delphi
public read-write property IsDynamicCreated: System.Boolean;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
public function get,set IsDynamicCreated : System.boolean
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public: __property System.bool get_IsDynamicCreated();
public: __property void set_IsDynamicCreated(
   System.bool value
);
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public:
property System.bool IsDynamicCreated {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


IsEmpty Method

[image]
Intersoft WebTreeView Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


IsFlyPostBackControl Method

[image]
Intersoft WebTreeView Documentation
IsFlyPostBackControl Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : IsFlyPostBackControl Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsFlyPostBackControl() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Boolean

value = instance.IsFlyPostBackControl()
C#
public virtual System.bool IsFlyPostBackControl()
Delphi
public function IsFlyPostBackControl(): System.Boolean; virtual;
JScript
public function IsFlyPostBackControl() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsFlyPostBackControl();
C++/CLI
public:
virtual System.bool IsFlyPostBackControl();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


IsFlyPostBackRequest Method

[image]
Intersoft WebTreeView Documentation
IsFlyPostBackRequest Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : IsFlyPostBackRequest Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsFlyPostBackRequest() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Boolean

value = instance.IsFlyPostBackRequest()
C#
public virtual System.bool IsFlyPostBackRequest()
Delphi
public function IsFlyPostBackRequest(): System.Boolean; virtual;
JScript
public function IsFlyPostBackRequest() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsFlyPostBackRequest();
C++/CLI
public:
virtual System.bool IsFlyPostBackRequest();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


IsGeckoBasedBrowser Method

[image]
Intersoft WebTreeView Documentation
IsGeckoBasedBrowser Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : IsGeckoBasedBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsGeckoBasedBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Boolean

value = instance.IsGeckoBasedBrowser()
C#
public System.bool IsGeckoBasedBrowser()
Delphi
public function IsGeckoBasedBrowser(): System.Boolean;
JScript
public function IsGeckoBasedBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsGeckoBasedBrowser();
C++/CLI
public:
System.bool IsGeckoBasedBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


IsGeckoVersion18 Method

[image]
Intersoft WebTreeView Documentation
IsGeckoVersion18 Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : IsGeckoVersion18 Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsGeckoVersion18() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Boolean

value = instance.IsGeckoVersion18()
C#
public System.bool IsGeckoVersion18()
Delphi
public function IsGeckoVersion18(): System.Boolean;
JScript
public function IsGeckoVersion18() : System.boolean;
Managed Extensions for C++
public: System.bool IsGeckoVersion18();
C++/CLI
public:
System.bool IsGeckoVersion18();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


IsInDesignMode Method

[image]
Intersoft WebTreeView Documentation
IsInDesignMode Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : IsInDesignMode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInDesignMode() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Boolean

value = instance.IsInDesignMode()
C#
public System.bool IsInDesignMode()
Delphi
public function IsInDesignMode(): System.Boolean;
JScript
public function IsInDesignMode() : System.boolean;
Managed Extensions for C++
public: System.bool IsInDesignMode();
C++/CLI
public:
System.bool IsInDesignMode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


IsInternalCreated Property

[image]
Intersoft WebTreeView Documentation
IsInternalCreated Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : IsInternalCreated Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
Public Property IsInternalCreated As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Boolean

instance.IsInternalCreated = value

value = instance.IsInternalCreated
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public System.bool IsInternalCreated {get; set;}
Delphi
public read-write property IsInternalCreated: System.Boolean;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
public function get,set IsInternalCreated : System.boolean
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public: __property System.bool get_IsInternalCreated();
public: __property void set_IsInternalCreated(
   System.bool value
);
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public:
property System.bool IsInternalCreated {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


IsInternetExplorer8Browser Method

[image]
Intersoft WebTreeView Documentation
IsInternetExplorer8Browser Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : IsInternetExplorer8Browser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInternetExplorer8Browser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Boolean

value = instance.IsInternetExplorer8Browser()
C#
public System.bool IsInternetExplorer8Browser()
Delphi
public function IsInternetExplorer8Browser(): System.Boolean;
JScript
public function IsInternetExplorer8Browser() : System.boolean;
Managed Extensions for C++
public: System.bool IsInternetExplorer8Browser();
C++/CLI
public:
System.bool IsInternetExplorer8Browser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


IsInternetExplorerBrowser Method

[image]
Intersoft WebTreeView Documentation
IsInternetExplorerBrowser Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : IsInternetExplorerBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInternetExplorerBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Boolean

value = instance.IsInternetExplorerBrowser()
C#
public System.bool IsInternetExplorerBrowser()
Delphi
public function IsInternetExplorerBrowser(): System.Boolean;
JScript
public function IsInternetExplorerBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsInternetExplorerBrowser();
C++/CLI
public:
System.bool IsInternetExplorerBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


IsLiteralContent Method

[image]
Intersoft WebTreeView Documentation
IsLiteralContent Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : IsLiteralContent Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function IsLiteralContent() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Boolean

value = instance.IsLiteralContent()
C#
protected System.bool IsLiteralContent()
Delphi
protected function IsLiteralContent(): System.Boolean;
JScript
protected function IsLiteralContent() : System.boolean;
Managed Extensions for C++
protected: System.bool IsLiteralContent();
C++/CLI
protected:
System.bool IsLiteralContent();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


IsMvc Property

[image]
Intersoft WebTreeView Documentation
IsMvc Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : IsMvc Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property IsMvc As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Boolean

value = instance.IsMvc
C#
protected System.bool IsMvc {get;}
Delphi
protected read-only property IsMvc: System.Boolean;
JScript
protected function get IsMvc : System.boolean
Managed Extensions for C++
protected: __property System.bool get_IsMvc();
C++/CLI
protected:
property System.bool IsMvc {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


IsOperaBrowser Method

[image]
Intersoft WebTreeView Documentation
IsOperaBrowser Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : IsOperaBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsOperaBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Boolean

value = instance.IsOperaBrowser()
C#
public System.bool IsOperaBrowser()
Delphi
public function IsOperaBrowser(): System.Boolean;
JScript
public function IsOperaBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsOperaBrowser();
C++/CLI
public:
System.bool IsOperaBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


isPagePreRender Field

[image]
Intersoft WebTreeView Documentation
isPagePreRender Field
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : isPagePreRender Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected isPagePreRender As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Boolean

value = instance.isPagePreRender

instance.isPagePreRender = value
C#
protected System.bool isPagePreRender
Delphi
protected field isPagePreRender: System.Boolean;
JScript
protected var isPagePreRender : System.boolean;
Managed Extensions for C++
protected: System.bool isPagePreRender
C++/CLI
protected:
System.bool isPagePreRender

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


IsSafariBrowser Method

[image]
Intersoft WebTreeView Documentation
IsSafariBrowser Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : IsSafariBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsSafariBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Boolean

value = instance.IsSafariBrowser()
C#
public System.bool IsSafariBrowser()
Delphi
public function IsSafariBrowser(): System.Boolean;
JScript
public function IsSafariBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsSafariBrowser();
C++/CLI
public:
System.bool IsSafariBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


IsSessionAvailable Method

[image]
Intersoft WebTreeView Documentation
IsSessionAvailable Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : IsSessionAvailable Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function IsSessionAvailable() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Boolean

value = instance.IsSessionAvailable()
C#
protected System.bool IsSessionAvailable()
Delphi
protected function IsSessionAvailable(): System.Boolean;
JScript
protected function IsSessionAvailable() : System.boolean;
Managed Extensions for C++
protected: System.bool IsSessionAvailable();
C++/CLI
protected:
System.bool IsSessionAvailable();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


IsTrackingViewState Property

[image]
Intersoft WebTreeView Documentation
IsTrackingViewState Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : IsTrackingViewState Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property IsTrackingViewState As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Boolean

value = instance.IsTrackingViewState
C#
protected System.bool IsTrackingViewState {get;}
Delphi
protected read-only property IsTrackingViewState: System.Boolean;
JScript
protected function get IsTrackingViewState : System.boolean
Managed Extensions for C++
protected: __property System.bool get_IsTrackingViewState();
C++/CLI
protected:
property System.bool IsTrackingViewState {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


IsUnloaded Property

[image]
Intersoft WebTreeView Documentation
IsUnloaded Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : IsUnloaded Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property IsUnloaded As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Boolean

instance.IsUnloaded = value

value = instance.IsUnloaded
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public System.bool IsUnloaded {get; set;}
Delphi
public read-write property IsUnloaded: System.Boolean;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get,set IsUnloaded : System.boolean
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property System.bool get_IsUnloaded();
public: __property void set_IsUnloaded(
   System.bool value
);
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property System.bool IsUnloaded {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


IsW3CStandardBrowser Method

[image]
Intersoft WebTreeView Documentation
IsW3CStandardBrowser Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : IsW3CStandardBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsW3CStandardBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Boolean

value = instance.IsW3CStandardBrowser()
C#
public System.bool IsW3CStandardBrowser()
Delphi
public function IsW3CStandardBrowser(): System.Boolean;
JScript
public function IsW3CStandardBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsW3CStandardBrowser();
C++/CLI
public:
System.bool IsW3CStandardBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


Load Event

[image]
Intersoft WebTreeView Documentation
Load Event
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : Load Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the page has been loaded.")>
Public Event Load As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim handler As System.EventHandler

AddHandler instance.Load, handler
C#
[WebSysDescriptionAttribute("Fires when the page has been loaded.")]
public event System.EventHandler Load
Delphi
public event Load: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the page has been loaded.")]
public: __event System.EventHandler* Load
C++/CLI
[WebSysDescriptionAttribute("Fires when the page has been loaded.")]
public:
event System.EventHandler^ Load

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


LoadControlState Method

[image]
Intersoft WebTreeView Documentation
LoadControlState Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : LoadControlState Method

savedState

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub LoadControlState( _
   ByVal savedState As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim savedState As System.Object

instance.LoadControlState(savedState)
C#
protected virtual void LoadControlState(
   System.object savedState
)
Delphi
protected procedure LoadControlState(
    savedState: System.TObject
); virtual;
JScript
protected function LoadControlState(
   savedState : System.Object
);
Managed Extensions for C++
protected: virtual void LoadControlState(
   System.Object* savedState
)
C++/CLI
protected:
virtual void LoadControlState(
   System.Object^ savedState
)

Parameters

savedState

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


LoadLayout Method

[image]
Intersoft WebTreeView Documentation
LoadLayout Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : LoadLayout Method

settings

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayout( _
   ByVal settings As ISNet.WebUI.LayoutInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim settings As ISNet.WebUI.LayoutInfo

instance.LoadLayout(settings)
C#
public virtual void LoadLayout(
   ISNet.WebUI.LayoutInfo settings
)
Delphi
public procedure LoadLayout(
    settings: ISNet.WebUI.LayoutInfo
); virtual;
JScript
public function LoadLayout(
   settings : ISNet.WebUI.LayoutInfo
);
Managed Extensions for C++
public: virtual void LoadLayout(
   ISNet.WebUI.LayoutInfo* settings
)
C++/CLI
public:
virtual void LoadLayout(
   ISNet.WebUI.LayoutInfo^ settings
)

Parameters

settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


LoadLayoutFromFile Method

[image]
Intersoft WebTreeView Documentation
LoadLayoutFromFile Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : LoadLayoutFromFile Method

filePath

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromFile( _
   ByVal filePath As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim filePath As System.String

instance.LoadLayoutFromFile(filePath)
C#
public virtual void LoadLayoutFromFile(
   System.string filePath
)
Delphi
public procedure LoadLayoutFromFile(
    filePath: System.String
); virtual;
JScript
public function LoadLayoutFromFile(
   filePath : System.String
);
Managed Extensions for C++
public: virtual void LoadLayoutFromFile(
   System.string* filePath
)
C++/CLI
public:
virtual void LoadLayoutFromFile(
   System.String^ filePath
)

Parameters

filePath

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


LoadLayoutFromPredefinedName Method

[image]
Intersoft WebTreeView Documentation
LoadLayoutFromPredefinedName Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : LoadLayoutFromPredefinedName Method

predefinedName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromPredefinedName( _
   ByVal predefinedName As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim predefinedName As System.String

instance.LoadLayoutFromPredefinedName(predefinedName)
C#
public virtual void LoadLayoutFromPredefinedName(
   System.string predefinedName
)
Delphi
public procedure LoadLayoutFromPredefinedName(
    predefinedName: System.String
); virtual;
JScript
public function LoadLayoutFromPredefinedName(
   predefinedName : System.String
);
Managed Extensions for C++
public: virtual void LoadLayoutFromPredefinedName(
   System.string* predefinedName
)
C++/CLI
public:
virtual void LoadLayoutFromPredefinedName(
   System.String^ predefinedName
)

Parameters

predefinedName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


LoadLayoutFromStream Method

[image]
Intersoft WebTreeView Documentation
LoadLayoutFromStream Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : LoadLayoutFromStream Method

stream

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromStream( _
   ByVal stream As System.IO.Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim stream As System.IO.Stream

instance.LoadLayoutFromStream(stream)
C#
public virtual void LoadLayoutFromStream(
   System.IO.Stream stream
)
Delphi
public procedure LoadLayoutFromStream(
    stream: System.IO.Stream
); virtual;
JScript
public function LoadLayoutFromStream(
   stream : System.IO.Stream
);
Managed Extensions for C++
public: virtual void LoadLayoutFromStream(
   System.IO.Stream* stream
)
C++/CLI
public:
virtual void LoadLayoutFromStream(
   System.IO.Stream^ stream
)

Parameters

stream

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


LoadViewStateByID Property

[image]
Intersoft WebTreeView Documentation
LoadViewStateByID Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : LoadViewStateByID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property LoadViewStateByID As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Boolean

value = instance.LoadViewStateByID
C#
protected System.bool LoadViewStateByID {get;}
Delphi
protected read-only property LoadViewStateByID: System.Boolean;
JScript
protected function get LoadViewStateByID : System.boolean
Managed Extensions for C++
protected: __property System.bool get_LoadViewStateByID();
C++/CLI
protected:
property System.bool LoadViewStateByID {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


MaxJsonLength Property

[image]
Intersoft WebTreeView Documentation
MaxJsonLength Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : MaxJsonLength Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the maximum length allowed for JSON Serializer.")>
<System.ComponentModel.DefaultValueAttribute()>
Protected Overridable Property MaxJsonLength As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Integer

instance.MaxJsonLength = value

value = instance.MaxJsonLength
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the maximum length allowed for JSON Serializer.")]
[System.ComponentModel.DefaultValueAttribute()]
protected virtual System.int MaxJsonLength {get; set;}
Delphi
protected read-write property MaxJsonLength: System.Integer; virtual;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the maximum length allowed for JSON Serializer.")
System.ComponentModel.DefaultValueAttribute()
protected function get,set MaxJsonLength : System.int
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the maximum length allowed for JSON Serializer.")]
[System.ComponentModel.DefaultValueAttribute()]
protected: __property virtual System.int get_MaxJsonLength();
protected: __property virtual void set_MaxJsonLength(
   System.int value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the maximum length allowed for JSON Serializer.")]
[System.ComponentModel.DefaultValueAttribute()]
protected:
virtual property System.int MaxJsonLength {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


MergeStyle Method

[image]
Intersoft WebTreeView Documentation
MergeStyle Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : MergeStyle Method

s

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub MergeStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim s As System.Web.UI.WebControls.Style

instance.MergeStyle(s)
C#
public void MergeStyle(
   System.Web.UI.WebControls.Style s
)
Delphi
public procedure MergeStyle(
    s: System.Web.UI.WebControls.Style
);
JScript
public function MergeStyle(
   s : System.Web.UI.WebControls.Style
);
Managed Extensions for C++
public: void MergeStyle(
   System.Web.UI.WebControls.Style* s
)
C++/CLI
public:
void MergeStyle(
   System.Web.UI.WebControls.Style^ s
)

Parameters

s

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


NamingContainer Property

[image]
Intersoft WebTreeView Documentation
NamingContainer Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : NamingContainer Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BindableAttribute(Bindable=False, Direction=BindingDirection.OneWay)>
<WebSysDescriptionAttribute("The containing control or page within which ID is unique.")>
Public Overridable ReadOnly Property NamingContainer As System.Web.UI.Control
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Web.UI.Control

value = instance.NamingContainer
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BindableAttribute(Bindable=false, Direction=BindingDirection.OneWay)]
[WebSysDescriptionAttribute("The containing control or page within which ID is unique.")]
public virtual System.Web.UI.Control NamingContainer {get;}
Delphi
public read-only property NamingContainer: System.Web.UI.Control; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
WebSysDescriptionAttribute("The containing control or page within which ID is unique.")
public function get NamingContainer : System.Web.UI.Control
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BindableAttribute(Bindable=false, Direction=BindingDirection.OneWay)]
[WebSysDescriptionAttribute("The containing control or page within which ID is unique.")]
public: __property virtual System.Web.UI.Control* get_NamingContainer();
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BindableAttribute(Bindable=false, Direction=BindingDirection.OneWay)]
[WebSysDescriptionAttribute("The containing control or page within which ID is unique.")]
public:
virtual property System.Web.UI.Control^ NamingContainer {
   System.Web.UI.Control^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


OnBubbleEvent Method

[image]
Intersoft WebTreeView Documentation
OnBubbleEvent Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : OnBubbleEvent Method

source
args

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnBubbleEvent( _
   ByVal source As System.Object, _
   ByVal args As System.EventArgs _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim source As System.Object
Dim args As System.EventArgs
Dim value As System.Boolean

value = instance.OnBubbleEvent(source, args)
C#
protected virtual System.bool OnBubbleEvent(
   System.object source,
   System.EventArgs args
)
Delphi
protected function OnBubbleEvent(
    source: System.TObject;
    args: System.EventArgs
): System.Boolean; virtual;
JScript
protected function OnBubbleEvent(
   source : System.Object,
   args : System.EventArgs
) : System.boolean;
Managed Extensions for C++
protected: virtual System.bool OnBubbleEvent(
   System.Object* source,
   System.EventArgs* args
)
C++/CLI
protected:
virtual System.bool OnBubbleEvent(
   System.Object^ source,
   System.EventArgs^ args
)

Parameters

source
args

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


OnDataBinding Method

[image]
Intersoft WebTreeView Documentation
OnDataBinding Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : OnDataBinding Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnDataBinding( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim e As System.EventArgs

instance.OnDataBinding(e)
C#
protected virtual void OnDataBinding(
   System.EventArgs e
)
Delphi
protected procedure OnDataBinding(
    e: System.EventArgs
); virtual;
JScript
protected function OnDataBinding(
   e : System.EventArgs
);
Managed Extensions for C++
protected: virtual void OnDataBinding(
   System.EventArgs* e
)
C++/CLI
protected:
virtual void OnDataBinding(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


OnInfoChanged Method

[image]
Intersoft WebTreeView Documentation
OnInfoChanged Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : OnInfoChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub OnInfoChanged( _
   ByVal e As ISNet.WebUI.SynchronizeEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim e As ISNet.WebUI.SynchronizeEventArgs

instance.OnInfoChanged(e)
C#
public void OnInfoChanged(
   ISNet.WebUI.SynchronizeEventArgs e
)
Delphi
public procedure OnInfoChanged(
    e: ISNet.WebUI.SynchronizeEventArgs
);
JScript
public function OnInfoChanged(
   e : ISNet.WebUI.SynchronizeEventArgs
);
Managed Extensions for C++
public: void OnInfoChanged(
   ISNet.WebUI.SynchronizeEventArgs* e
)
C++/CLI
public:
void OnInfoChanged(
   ISNet.WebUI.SynchronizeEventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


OnLoad Method

[image]
Intersoft WebTreeView Documentation
OnLoad Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : OnLoad Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnLoad( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim e As System.EventArgs

instance.OnLoad(e)
C#
protected virtual void OnLoad(
   System.EventArgs e
)
Delphi
protected procedure OnLoad(
    e: System.EventArgs
); virtual;
JScript
protected function OnLoad(
   e : System.EventArgs
);
Managed Extensions for C++
protected: virtual void OnLoad(
   System.EventArgs* e
)
C++/CLI
protected:
virtual void OnLoad(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


OnPreInitialize Method

[image]
Intersoft WebTreeView Documentation
OnPreInitialize Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : OnPreInitialize Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub OnPreInitialize()
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView

instance.OnPreInitialize()
C#
public virtual void OnPreInitialize()
Delphi
public procedure OnPreInitialize(); virtual;
JScript
public function OnPreInitialize();
Managed Extensions for C++
public: virtual void OnPreInitialize();
C++/CLI
public:
virtual void OnPreInitialize();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


Page Property

[image]
Intersoft WebTreeView Documentation
Page Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : Page Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property Page As System.Web.UI.Page
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Web.UI.Page

instance.Page = value

value = instance.Page
C#
public virtual System.Web.UI.Page Page {get; set;}
Delphi
public read-write property Page: System.Web.UI.Page; virtual;
JScript
public function get,set Page : System.Web.UI.Page
Managed Extensions for C++
public: __property virtual System.Web.UI.Page* get_Page();
public: __property virtual void set_Page(
   System.Web.UI.Page* value
);
C++/CLI
public:
virtual property System.Web.UI.Page^ Page {
   System.Web.UI.Page^ get();
   void set (    System.Web.UI.Page^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


Parent Property

[image]
Intersoft WebTreeView Documentation
Parent Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : Parent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<WebSysDescriptionAttribute("The control containing this control.")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BindableAttribute(Bindable=False, Direction=BindingDirection.OneWay)>
Public Overridable ReadOnly Property Parent As System.Web.UI.Control
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Web.UI.Control

value = instance.Parent
C#
[System.ComponentModel.BrowsableAttribute(false)]
[WebSysDescriptionAttribute("The control containing this control.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BindableAttribute(Bindable=false, Direction=BindingDirection.OneWay)]
public virtual System.Web.UI.Control Parent {get;}
Delphi
public read-only property Parent: System.Web.UI.Control; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
WebSysDescriptionAttribute("The control containing this control.")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get Parent : System.Web.UI.Control
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[WebSysDescriptionAttribute("The control containing this control.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BindableAttribute(Bindable=false, Direction=BindingDirection.OneWay)]
public: __property virtual System.Web.UI.Control* get_Parent();
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[WebSysDescriptionAttribute("The control containing this control.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BindableAttribute(Bindable=false, Direction=BindingDirection.OneWay)]
public:
virtual property System.Web.UI.Control^ Parent {
   System.Web.UI.Control^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


ParentStyleId Property

[image]
Intersoft WebTreeView Documentation
ParentStyleId Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : ParentStyleId Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
Public ReadOnly Property ParentStyleId As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.String

value = instance.ParentStyleId
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public System.string ParentStyleId {get;}
Delphi
public read-only property ParentStyleId: System.String;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
public function get ParentStyleId : System.String
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public: __property System.string* get_ParentStyleId();
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public:
property System.String^ ParentStyleId {
   System.String^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


PreInitialize Event

[image]
Intersoft WebTreeView Documentation
PreInitialize Event
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : PreInitialize Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event PreInitialize As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim handler As System.EventHandler

AddHandler instance.PreInitialize, handler
C#
public event System.EventHandler PreInitialize
Delphi
public event PreInitialize: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
public: __event System.EventHandler* PreInitialize
C++/CLI
public:
event System.EventHandler^ PreInitialize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


PreRender Event

[image]
Intersoft WebTreeView Documentation
PreRender Event
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : PreRender Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires before the page is rendered.")>
Public Event PreRender As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim handler As System.EventHandler

AddHandler instance.PreRender, handler
C#
[WebSysDescriptionAttribute("Fires before the page is rendered.")]
public event System.EventHandler PreRender
Delphi
public event PreRender: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires before the page is rendered.")]
public: __event System.EventHandler* PreRender
C++/CLI
[WebSysDescriptionAttribute("Fires before the page is rendered.")]
public:
event System.EventHandler^ PreRender

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


RaiseBubbleEvent Method

[image]
Intersoft WebTreeView Documentation
RaiseBubbleEvent Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : RaiseBubbleEvent Method

source
args

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Sub RaiseBubbleEvent( _
   ByVal source As System.Object, _
   ByVal args As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim source As System.Object
Dim args As System.EventArgs

instance.RaiseBubbleEvent(source, args)
C#
protected void RaiseBubbleEvent(
   System.object source,
   System.EventArgs args
)
Delphi
protected procedure RaiseBubbleEvent(
    source: System.TObject;
    args: System.EventArgs
);
JScript
protected function RaiseBubbleEvent(
   source : System.Object,
   args : System.EventArgs
);
Managed Extensions for C++
protected: void RaiseBubbleEvent(
   System.Object* source,
   System.EventArgs* args
)
C++/CLI
protected:
void RaiseBubbleEvent(
   System.Object^ source,
   System.EventArgs^ args
)

Parameters

source
args

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


RaisePostDataChangedEvent Method

[image]
Intersoft WebTreeView Documentation
RaisePostDataChangedEvent Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : RaisePostDataChangedEvent Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RaisePostDataChangedEvent()
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView

instance.RaisePostDataChangedEvent()
C#
public virtual void RaisePostDataChangedEvent()
Delphi
public procedure RaisePostDataChangedEvent(); virtual;
JScript
public function RaisePostDataChangedEvent();
Managed Extensions for C++
public: virtual void RaisePostDataChangedEvent();
C++/CLI
public:
virtual void RaisePostDataChangedEvent();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


ReadWebConfigValue Method

[image]
Intersoft WebTreeView Documentation
ReadWebConfigValue Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : ReadWebConfigValue Method

key

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ReadWebConfigValue( _
   ByVal key As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim key As System.String
Dim value As System.String

value = instance.ReadWebConfigValue(key)
C#
public System.string ReadWebConfigValue(
   System.string key
)
Delphi
public function ReadWebConfigValue(
    key: System.String
): System.String;
JScript
public function ReadWebConfigValue(
   key : System.String
) : System.String;
Managed Extensions for C++
public: System.string* ReadWebConfigValue(
   System.string* key
)
C++/CLI
public:
System.String^ ReadWebConfigValue(
   System.String^ key
)

Parameters

key

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


RegisterBoxSizing Method

[image]
Intersoft WebTreeView Documentation
RegisterBoxSizing Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : RegisterBoxSizing Method

Glossary Item Box

Overload List

Overload | Description
RegisterBoxSizing() | (Inherited from ISNet.WebUI.ISNetControl)
RegisterBoxSizing(Boolean) | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


RegisterBoxSizing() Method

[image]
Intersoft WebTreeView Documentation
RegisterBoxSizing() Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class > RegisterBoxSizing Method : RegisterBoxSizing() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub RegisterBoxSizing()
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView

instance.RegisterBoxSizing()
C#
public void RegisterBoxSizing()
Delphi
public procedure RegisterBoxSizing();
JScript
public function RegisterBoxSizing();
Managed Extensions for C++
public: void RegisterBoxSizing();
C++/CLI
public:
void RegisterBoxSizing();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members
Overload List


RegisterBoxSizing(Boolean) Method

[image]
Intersoft WebTreeView Documentation
RegisterBoxSizing(Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class > RegisterBoxSizing Method : RegisterBoxSizing(Boolean) Method

forceAll

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub RegisterBoxSizing( _
   ByVal forceAll As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim forceAll As System.Boolean

instance.RegisterBoxSizing(forceAll)
C#
public void RegisterBoxSizing(
   System.bool forceAll
)
Delphi
public procedure RegisterBoxSizing(
    forceAll: System.Boolean
);
JScript
public function RegisterBoxSizing(
   forceAll : System.boolean
);
Managed Extensions for C++
public: void RegisterBoxSizing(
   System.bool forceAll
)
C++/CLI
public:
void RegisterBoxSizing(
   System.bool forceAll
)

Parameters

forceAll

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members
Overload List


RegisterGlobalStyle Method

[image]
Intersoft WebTreeView Documentation
RegisterGlobalStyle Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : RegisterGlobalStyle Method

style

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterGlobalStyle( _
   ByVal style As ISNet.WebUI.WebStyle _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim style As ISNet.WebUI.WebStyle

instance.RegisterGlobalStyle(style)
C#
public void RegisterGlobalStyle(
   ISNet.WebUI.WebStyle style
)
Delphi
public procedure RegisterGlobalStyle(
    style: ISNet.WebUI.WebStyle
);
JScript
public function RegisterGlobalStyle(
   style : ISNet.WebUI.WebStyle
);
Managed Extensions for C++
public: void RegisterGlobalStyle(
   ISNet.WebUI.WebStyle* style
)
C++/CLI
public:
void RegisterGlobalStyle(
   ISNet.WebUI.WebStyle^ style
)

Parameters

style

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


RegisterLink Method

[image]
Intersoft WebTreeView Documentation
RegisterLink Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : RegisterLink Method

name
url

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterLink( _
   ByVal name As System.String, _
   ByVal url As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim name As System.String
Dim url As System.String

instance.RegisterLink(name, url)
C#
public void RegisterLink(
   System.string name,
   System.string url
)
Delphi
public procedure RegisterLink(
    name: System.String;
    url: System.String
);
JScript
public function RegisterLink(
   name : System.String,
   url : System.String
);
Managed Extensions for C++
public: void RegisterLink(
   System.string* name,
   System.string* url
)
C++/CLI
public:
void RegisterLink(
   System.String^ name,
   System.String^ url
)

Parameters

name
url

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


RegisterOptimizedCssClasses Method

[image]
Intersoft WebTreeView Documentation
RegisterOptimizedCssClasses Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : RegisterOptimizedCssClasses Method

runtimeStyleOnly

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterOptimizedCssClasses( _
   ByVal runtimeStyleOnly As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim runtimeStyleOnly As System.Boolean

instance.RegisterOptimizedCssClasses(runtimeStyleOnly)
C#
public void RegisterOptimizedCssClasses(
   System.bool runtimeStyleOnly
)
Delphi
public procedure RegisterOptimizedCssClasses(
    runtimeStyleOnly: System.Boolean
);
JScript
public function RegisterOptimizedCssClasses(
   runtimeStyleOnly : System.boolean
);
Managed Extensions for C++
public: void RegisterOptimizedCssClasses(
   System.bool runtimeStyleOnly
)
C++/CLI
public:
void RegisterOptimizedCssClasses(
   System.bool runtimeStyleOnly
)

Parameters

runtimeStyleOnly

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


RegisterPreloadImage Method

[image]
Intersoft WebTreeView Documentation
RegisterPreloadImage Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : RegisterPreloadImage Method

image

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterPreloadImage( _
   ByVal image As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim image As System.String

instance.RegisterPreloadImage(image)
C#
public void RegisterPreloadImage(
   System.string image
)
Delphi
public procedure RegisterPreloadImage(
    image: System.String
);
JScript
public function RegisterPreloadImage(
   image : System.String
);
Managed Extensions for C++
public: void RegisterPreloadImage(
   System.string* image
)
C++/CLI
public:
void RegisterPreloadImage(
   System.String^ image
)

Parameters

image

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


RegisterScript Method

[image]
Intersoft WebTreeView Documentation
RegisterScript Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : RegisterScript Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub RegisterScript()
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView

instance.RegisterScript()
C#
public override void RegisterScript()
Delphi
public procedure RegisterScript(); override;
JScript
public override function RegisterScript();
Managed Extensions for C++
public: void RegisterScript(); override
C++/CLI
public:
void RegisterScript(); override

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


RegisterSharePointHandler Method

[image]
Intersoft WebTreeView Documentation
RegisterSharePointHandler Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : RegisterSharePointHandler Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RegisterSharePointHandler()
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView

instance.RegisterSharePointHandler()
C#
public virtual void RegisterSharePointHandler()
Delphi
public procedure RegisterSharePointHandler(); virtual;
JScript
public function RegisterSharePointHandler();
Managed Extensions for C++
public: virtual void RegisterSharePointHandler();
C++/CLI
public:
virtual void RegisterSharePointHandler();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


RenderBeginTag Method

[image]
Intersoft WebTreeView Documentation
RenderBeginTag Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : RenderBeginTag Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RenderBeginTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderBeginTag(writer)
C#
public virtual void RenderBeginTag(
   System.Web.UI.HtmlTextWriter writer
)
Delphi
public procedure RenderBeginTag(
    writer: System.Web.UI.HtmlTextWriter
); virtual;
JScript
public function RenderBeginTag(
   writer : System.Web.UI.HtmlTextWriter
);
Managed Extensions for C++
public: virtual void RenderBeginTag(
   System.Web.UI.HtmlTextWriter* writer
)
C++/CLI
public:
virtual void RenderBeginTag(
   System.Web.UI.HtmlTextWriter^ writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


RenderControl Method

[image]
Intersoft WebTreeView Documentation
RenderControl Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : RenderControl Method

Glossary Item Box

Overload List

Overload | Description
RenderControl(HtmlTextWriter) | (Inherited from System.Web.UI.Control)
RenderControl(HtmlTextWriter,ControlAdapter) | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


RenderControl(HtmlTextWriter) Method

[image]
Intersoft WebTreeView Documentation
RenderControl(HtmlTextWriter) Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class > RenderControl Method : RenderControl(HtmlTextWriter) Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Overloads Overridable Sub RenderControl( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderControl(writer)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public virtual void RenderControl(
   System.Web.UI.HtmlTextWriter writer
)
Delphi
public procedure RenderControl(
    writer: System.Web.UI.HtmlTextWriter
); virtual;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function RenderControl(
   writer : System.Web.UI.HtmlTextWriter
);
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: virtual void RenderControl(
   System.Web.UI.HtmlTextWriter* writer
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
virtual void RenderControl(
   System.Web.UI.HtmlTextWriter^ writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members
Overload List


RenderControl(HtmlTextWriter,ControlAdapter) Method

[image]
Intersoft WebTreeView Documentation
RenderControl(HtmlTextWriter,ControlAdapter) Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class > RenderControl Method : RenderControl(HtmlTextWriter,ControlAdapter) Method

writer
adapter

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overloads Sub RenderControl( _
   ByVal writer As System.Web.UI.HtmlTextWriter, _
   ByVal adapter As System.Web.UI.Adapters.ControlAdapter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim writer As System.Web.UI.HtmlTextWriter
Dim adapter As System.Web.UI.Adapters.ControlAdapter

instance.RenderControl(writer, adapter)
C#
protected void RenderControl(
   System.Web.UI.HtmlTextWriter writer,
   System.Web.UI.Adapters.ControlAdapter adapter
)
Delphi
protected procedure RenderControl(
    writer: System.Web.UI.HtmlTextWriter;
    adapter: System.Web.UI.Adapters.ControlAdapter
);
JScript
protected function RenderControl(
   writer : System.Web.UI.HtmlTextWriter,
   adapter : System.Web.UI.Adapters.ControlAdapter
);
Managed Extensions for C++
protected: void RenderControl(
   System.Web.UI.HtmlTextWriter* writer,
   System.Web.UI.Adapters.ControlAdapter* adapter
)
C++/CLI
protected:
void RenderControl(
   System.Web.UI.HtmlTextWriter^ writer,
   System.Web.UI.Adapters.ControlAdapter^ adapter
)

Parameters

writer
adapter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members
Overload List


renderDHTML Field

[image]
Intersoft WebTreeView Documentation
renderDHTML Field
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : renderDHTML Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected renderDHTML As ISNet.WebUI.RenderDHTML
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As ISNet.WebUI.RenderDHTML

value = instance.renderDHTML

instance.renderDHTML = value
C#
protected ISNet.WebUI.RenderDHTML renderDHTML
Delphi
protected field renderDHTML: ISNet.WebUI.RenderDHTML;
JScript
protected var renderDHTML : ISNet.WebUI.RenderDHTML;
Managed Extensions for C++
protected: ISNet.WebUI.RenderDHTML* renderDHTML
C++/CLI
protected:
ISNet.WebUI.RenderDHTML^ renderDHTML

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


RenderEndTag Method

[image]
Intersoft WebTreeView Documentation
RenderEndTag Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : RenderEndTag Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub RenderEndTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderEndTag(writer)
C#
public override void RenderEndTag(
   System.Web.UI.HtmlTextWriter writer
)
Delphi
public procedure RenderEndTag(
    writer: System.Web.UI.HtmlTextWriter
); override;
JScript
public override function RenderEndTag(
   writer : System.Web.UI.HtmlTextWriter
);
Managed Extensions for C++
public: void RenderEndTag(
   System.Web.UI.HtmlTextWriter* writer
) override
C++/CLI
public:
void RenderEndTag(
   System.Web.UI.HtmlTextWriter^ writer
) override

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


RenderingCompatibility Property

[image]
Intersoft WebTreeView Documentation
RenderingCompatibility Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : RenderingCompatibility Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.BindableAttribute(Bindable=False, Direction=BindingDirection.OneWay)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Overridable Property RenderingCompatibility As System.Version
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Version

instance.RenderingCompatibility = value

value = instance.RenderingCompatibility
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.BindableAttribute(Bindable=false, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public virtual System.Version RenderingCompatibility {get; set;}
Delphi
public read-write property RenderingCompatibility: System.Version; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get,set RenderingCompatibility : System.Version
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.BindableAttribute(Bindable=false, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property virtual System.Version* get_RenderingCompatibility();
public: __property virtual void set_RenderingCompatibility(
   System.Version* value
);
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.BindableAttribute(Bindable=false, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
virtual property System.Version^ RenderingCompatibility {
   System.Version^ get();
   void set (    System.Version^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


RenderingMode Property

[image]
Intersoft WebTreeView Documentation
RenderingMode Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : RenderingMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets a value that specifies the HTML rendering behavior applied in this control.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Overridable Property RenderingMode As ISNet.WebUI.RenderMode
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As ISNet.WebUI.RenderMode

instance.RenderingMode = value

value = instance.RenderingMode
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that specifies the HTML rendering behavior applied in this control.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public virtual ISNet.WebUI.RenderMode RenderingMode {get; set;}
Delphi
public read-write property RenderingMode: ISNet.WebUI.RenderMode; virtual;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets a value that specifies the HTML rendering behavior applied in this control.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set RenderingMode : ISNet.WebUI.RenderMode
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that specifies the HTML rendering behavior applied in this control.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property virtual ISNet.WebUI.RenderMode get_RenderingMode();
public: __property virtual void set_RenderingMode(
   ISNet.WebUI.RenderMode value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that specifies the HTML rendering behavior applied in this control.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
virtual property ISNet.WebUI.RenderMode RenderingMode {
   ISNet.WebUI.RenderMode get();
   void set (    ISNet.WebUI.RenderMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


renderNS Field

[image]
Intersoft WebTreeView Documentation
renderNS Field
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : renderNS Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected renderNS As ISNet.WebUI.RenderNS
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As ISNet.WebUI.RenderNS

value = instance.renderNS

instance.renderNS = value
C#
protected ISNet.WebUI.RenderNS renderNS
Delphi
protected field renderNS: ISNet.WebUI.RenderNS;
JScript
protected var renderNS : ISNet.WebUI.RenderNS;
Managed Extensions for C++
protected: ISNet.WebUI.RenderNS* renderNS
C++/CLI
protected:
ISNet.WebUI.RenderNS^ renderNS

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


RequiresUIRefresh Property

[image]
Intersoft WebTreeView Documentation
RequiresUIRefresh Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : RequiresUIRefresh Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property RequiresUIRefresh As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Boolean

instance.RequiresUIRefresh = value

value = instance.RequiresUIRefresh
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public System.bool RequiresUIRefresh {get; set;}
Delphi
public read-write property RequiresUIRefresh: System.Boolean;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get,set RequiresUIRefresh : System.boolean
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property System.bool get_RequiresUIRefresh();
public: __property void set_RequiresUIRefresh(
   System.bool value
);
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property System.bool RequiresUIRefresh {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


Reset Method

[image]
Intersoft WebTreeView Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


ResetFilteredStyle Method

[image]
Intersoft WebTreeView Documentation
ResetFilteredStyle Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : ResetFilteredStyle Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ResetFilteredStyle()
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView

instance.ResetFilteredStyle()
C#
protected virtual void ResetFilteredStyle()
Delphi
protected procedure ResetFilteredStyle(); virtual;
JScript
protected function ResetFilteredStyle();
Managed Extensions for C++
protected: virtual void ResetFilteredStyle();
C++/CLI
protected:
virtual void ResetFilteredStyle();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


ResolveAdapter Method

[image]
Intersoft WebTreeView Documentation
ResolveAdapter Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : ResolveAdapter Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function ResolveAdapter() As System.Web.UI.Adapters.ControlAdapter
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Web.UI.Adapters.ControlAdapter

value = instance.ResolveAdapter()
C#
protected virtual System.Web.UI.Adapters.ControlAdapter ResolveAdapter()
Delphi
protected function ResolveAdapter(): System.Web.UI.Adapters.ControlAdapter; virtual;
JScript
protected function ResolveAdapter() : System.Web.UI.Adapters.ControlAdapter;
Managed Extensions for C++
protected: virtual System.Web.UI.Adapters.ControlAdapter* ResolveAdapter();
C++/CLI
protected:
virtual System.Web.UI.Adapters.ControlAdapter^ ResolveAdapter();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


ResolveClientUrl Method

[image]
Intersoft WebTreeView Documentation
ResolveClientUrl Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : ResolveClientUrl Method

relativeUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveClientUrl( _
   ByVal relativeUrl As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim relativeUrl As System.String
Dim value As System.String

value = instance.ResolveClientUrl(relativeUrl)
C#
public System.string ResolveClientUrl(
   System.string relativeUrl
)
Delphi
public function ResolveClientUrl(
    relativeUrl: System.String
): System.String;
JScript
public function ResolveClientUrl(
   relativeUrl : System.String
) : System.String;
Managed Extensions for C++
public: System.string* ResolveClientUrl(
   System.string* relativeUrl
)
C++/CLI
public:
System.String^ ResolveClientUrl(
   System.String^ relativeUrl
)

Parameters

relativeUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


ResolveImagePath Method

[image]
Intersoft WebTreeView Documentation
ResolveImagePath Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : ResolveImagePath Method

folder
image

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveImagePath( _
   ByVal folder As System.String, _
   ByVal image As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim folder As System.String
Dim image As System.String
Dim value As System.String

value = instance.ResolveImagePath(folder, image)
C#
public System.string ResolveImagePath(
   System.string folder,
   System.string image
)
Delphi
public function ResolveImagePath(
    folder: System.String;
    image: System.String
): System.String;
JScript
public function ResolveImagePath(
   folder : System.String,
   image : System.String
) : System.String;
Managed Extensions for C++
public: System.string* ResolveImagePath(
   System.string* folder,
   System.string* image
)
C++/CLI
public:
System.String^ ResolveImagePath(
   System.String^ folder,
   System.String^ image
)

Parameters

folder
image

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


ResolveRelativeURL Method

[image]
Intersoft WebTreeView Documentation
ResolveRelativeURL Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : ResolveRelativeURL Method

url

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ResolveRelativeURL( _
   ByVal url As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim url As System.String
Dim value As System.String

value = instance.ResolveRelativeURL(url)
C#
public virtual System.string ResolveRelativeURL(
   System.string url
)
Delphi
public function ResolveRelativeURL(
    url: System.String
): System.String; virtual;
JScript
public function ResolveRelativeURL(
   url : System.String
) : System.String;
Managed Extensions for C++
public: virtual System.string* ResolveRelativeURL(
   System.string* url
)
C++/CLI
public:
virtual System.String^ ResolveRelativeURL(
   System.String^ url
)

Parameters

url

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


ResolveResourceUrl Method

[image]
Intersoft WebTreeView Documentation
ResolveResourceUrl Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : ResolveResourceUrl Method

kind
defaultFolder
currentFolder
resourceName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveResourceUrl( _
   ByVal kind As ISNet.WebUI.ResourceKind, _
   ByVal defaultFolder As System.String, _
   ByVal currentFolder As System.String, _
   ByVal resourceName As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim kind As ISNet.WebUI.ResourceKind
Dim defaultFolder As System.String
Dim currentFolder As System.String
Dim resourceName As System.String
Dim value As System.String

value = instance.ResolveResourceUrl(kind, defaultFolder, currentFolder, resourceName)
C#
public System.string ResolveResourceUrl(
   ISNet.WebUI.ResourceKind kind,
   System.string defaultFolder,
   System.string currentFolder,
   System.string resourceName
)
Delphi
public function ResolveResourceUrl(
    kind: ISNet.WebUI.ResourceKind;
    defaultFolder: System.String;
    currentFolder: System.String;
    resourceName: System.String
): System.String;
JScript
public function ResolveResourceUrl(
   kind : ISNet.WebUI.ResourceKind,
   defaultFolder : System.String,
   currentFolder : System.String,
   resourceName : System.String
) : System.String;
Managed Extensions for C++
public: System.string* ResolveResourceUrl(
   ISNet.WebUI.ResourceKind kind,
   System.string* defaultFolder,
   System.string* currentFolder,
   System.string* resourceName
)
C++/CLI
public:
System.String^ ResolveResourceUrl(
   ISNet.WebUI.ResourceKind kind,
   System.String^ defaultFolder,
   System.String^ currentFolder,
   System.String^ resourceName
)

Parameters

kind
defaultFolder
currentFolder
resourceName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


ResolveUrl Method

[image]
Intersoft WebTreeView Documentation
ResolveUrl Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : ResolveUrl Method

relativeUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveUrl( _
   ByVal relativeUrl As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim relativeUrl As System.String
Dim value As System.String

value = instance.ResolveUrl(relativeUrl)
C#
public System.string ResolveUrl(
   System.string relativeUrl
)
Delphi
public function ResolveUrl(
    relativeUrl: System.String
): System.String;
JScript
public function ResolveUrl(
   relativeUrl : System.String
) : System.String;
Managed Extensions for C++
public: System.string* ResolveUrl(
   System.string* relativeUrl
)
C++/CLI
public:
System.String^ ResolveUrl(
   System.String^ relativeUrl
)

Parameters

relativeUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


RuntimeLicenseKey Property

[image]
Intersoft WebTreeView Documentation
RuntimeLicenseKey Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : RuntimeLicenseKey Property

Glossary Item Box

The runtime license key that is used for xcopy development. For Registered customers, please obtain the key through Intersoft Developer Network.

Syntax

Visual Basic (Declaration)
<ISNet.PersistLayoutAttribute(False)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("The runtime license key for xcopy deployment. Registered customers please obtain the key through Intersoft Developer Network.")>
Public Overridable Property RuntimeLicenseKey As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.String

instance.RuntimeLicenseKey = value

value = instance.RuntimeLicenseKey
C#
[ISNet.PersistLayoutAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The runtime license key for xcopy deployment. Registered customers please obtain the key through Intersoft Developer Network.")]
public virtual System.string RuntimeLicenseKey {get; set;}
Delphi
public read-write property RuntimeLicenseKey: System.String; virtual;
JScript
ISNet.PersistLayoutAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("The runtime license key for xcopy deployment. Registered customers please obtain the key through Intersoft Developer Network.")
public function get,set RuntimeLicenseKey : System.String
Managed Extensions for C++
[ISNet.PersistLayoutAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The runtime license key for xcopy deployment. Registered customers please obtain the key through Intersoft Developer Network.")]
public: __property virtual System.string* get_RuntimeLicenseKey();
public: __property virtual void set_RuntimeLicenseKey(
   System.string* value
);
C++/CLI
[ISNet.PersistLayoutAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The runtime license key for xcopy deployment. Registered customers please obtain the key through Intersoft Developer Network.")]
public:
virtual property System.String^ RuntimeLicenseKey {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


SaveControlState Method

[image]
Intersoft WebTreeView Documentation
SaveControlState Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : SaveControlState Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function SaveControlState() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Object

value = instance.SaveControlState()
C#
protected virtual System.object SaveControlState()
Delphi
protected function SaveControlState(): System.TObject; virtual;
JScript
protected function SaveControlState() : System.Object;
Managed Extensions for C++
protected: virtual System.Object* SaveControlState();
C++/CLI
protected:
virtual System.Object^ SaveControlState();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


SaveLayout Method

[image]
Intersoft WebTreeView Documentation
SaveLayout Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : SaveLayout Method

settings

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayout( _
   ByVal settings As ISNet.WebUI.LayoutInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim settings As ISNet.WebUI.LayoutInfo

instance.SaveLayout(settings)
C#
public virtual void SaveLayout(
   ISNet.WebUI.LayoutInfo settings
)
Delphi
public procedure SaveLayout(
    settings: ISNet.WebUI.LayoutInfo
); virtual;
JScript
public function SaveLayout(
   settings : ISNet.WebUI.LayoutInfo
);
Managed Extensions for C++
public: virtual void SaveLayout(
   ISNet.WebUI.LayoutInfo* settings
)
C++/CLI
public:
virtual void SaveLayout(
   ISNet.WebUI.LayoutInfo^ settings
)

Parameters

settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


SaveLayoutToFile Method

[image]
Intersoft WebTreeView Documentation
SaveLayoutToFile Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : SaveLayoutToFile Method

filePath
saveOptions

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayoutToFile( _
   ByVal filePath As System.String, _
   ByVal saveOptions As ISNet.WebUI.SaveLayoutOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim filePath As System.String
Dim saveOptions As ISNet.WebUI.SaveLayoutOptions

instance.SaveLayoutToFile(filePath, saveOptions)
C#
public virtual void SaveLayoutToFile(
   System.string filePath,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)
Delphi
public procedure SaveLayoutToFile(
    filePath: System.String;
    saveOptions: ISNet.WebUI.SaveLayoutOptions
); virtual;
JScript
public function SaveLayoutToFile(
   filePath : System.String,
   saveOptions : ISNet.WebUI.SaveLayoutOptions
);
Managed Extensions for C++
public: virtual void SaveLayoutToFile(
   System.string* filePath,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)
C++/CLI
public:
virtual void SaveLayoutToFile(
   System.String^ filePath,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)

Parameters

filePath
saveOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


SaveLayoutToStream Method

[image]
Intersoft WebTreeView Documentation
SaveLayoutToStream Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : SaveLayoutToStream Method

stream
saveOptions

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayoutToStream( _
   ByVal stream As System.IO.Stream, _
   ByVal saveOptions As ISNet.WebUI.SaveLayoutOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim stream As System.IO.Stream
Dim saveOptions As ISNet.WebUI.SaveLayoutOptions

instance.SaveLayoutToStream(stream, saveOptions)
C#
public virtual void SaveLayoutToStream(
   System.IO.Stream stream,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)
Delphi
public procedure SaveLayoutToStream(
    stream: System.IO.Stream;
    saveOptions: ISNet.WebUI.SaveLayoutOptions
); virtual;
JScript
public function SaveLayoutToStream(
   stream : System.IO.Stream,
   saveOptions : ISNet.WebUI.SaveLayoutOptions
);
Managed Extensions for C++
public: virtual void SaveLayoutToStream(
   System.IO.Stream* stream,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)
C++/CLI
public:
virtual void SaveLayoutToStream(
   System.IO.Stream^ stream,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)

Parameters

stream
saveOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


SaveViewStateOnFlyPostback Property

[image]
Intersoft WebTreeView Documentation
SaveViewStateOnFlyPostback Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : SaveViewStateOnFlyPostback Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property SaveViewStateOnFlyPostback As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Boolean

instance.SaveViewStateOnFlyPostback = value

value = instance.SaveViewStateOnFlyPostback
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public System.bool SaveViewStateOnFlyPostback {get; set;}
Delphi
public read-write property SaveViewStateOnFlyPostback: System.Boolean;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get,set SaveViewStateOnFlyPostback : System.boolean
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property System.bool get_SaveViewStateOnFlyPostback();
public: __property void set_SaveViewStateOnFlyPostback(
   System.bool value
);
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property System.bool SaveViewStateOnFlyPostback {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


SerializedJSFiles Property

[image]
Intersoft WebTreeView Documentation
SerializedJSFiles Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : SerializedJSFiles Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public ReadOnly Property SerializedJSFiles As System.Collections.ArrayList
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Collections.ArrayList

value = instance.SerializedJSFiles
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public System.Collections.ArrayList SerializedJSFiles {get;}
Delphi
public read-only property SerializedJSFiles: System.Collections.ArrayList;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get SerializedJSFiles : System.Collections.ArrayList
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property System.Collections.ArrayList* get_SerializedJSFiles();
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property System.Collections.ArrayList^ SerializedJSFiles {
   System.Collections.ArrayList^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


SerializedStyles Property

[image]
Intersoft WebTreeView Documentation
SerializedStyles Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : SerializedStyles Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
Public ReadOnly Property SerializedStyles As System.Collections.Generic.Dictionary(Of String,Object)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Collections.Generic.Dictionary(Of String,Object)

value = instance.SerializedStyles
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public System.Collections.Generic.Dictionary<string,object> SerializedStyles {get;}
Delphi
public read-only property SerializedStyles: System.Collections.Generic.Dictionary;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
public function get SerializedStyles : System.Collections.Generic.Dictionary
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public: __property System.Collections.Generic.Dictionary<string*,Object*>* get_SerializedStyles();
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public:
property System.Collections.Generic.Dictionary<String^,Object^>^ SerializedStyles {
   System.Collections.Generic.Dictionary<String^,Object^>^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


SerializeObjectData Method

[image]
Intersoft WebTreeView Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


SetDesignModeState Method

[image]
Intersoft WebTreeView Documentation
SetDesignModeState Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : SetDesignModeState Method

data

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub SetDesignModeState( _
   ByVal data As System.Collections.IDictionary _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim data As System.Collections.IDictionary

instance.SetDesignModeState(data)
C#
protected virtual void SetDesignModeState(
   System.Collections.IDictionary data
)
Delphi
protected procedure SetDesignModeState(
    data: System.Collections.IDictionary
); virtual;
JScript
protected function SetDesignModeState(
   data : System.Collections.IDictionary
);
Managed Extensions for C++
protected: virtual void SetDesignModeState(
   System.Collections.IDictionary* data
)
C++/CLI
protected:
virtual void SetDesignModeState(
   System.Collections.IDictionary^ data
)

Parameters

data

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


SetRenderMethodDelegate Method

[image]
Intersoft WebTreeView Documentation
SetRenderMethodDelegate Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : SetRenderMethodDelegate Method

renderMethod

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Sub SetRenderMethodDelegate( _
   ByVal renderMethod As System.Web.UI.RenderMethod _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim renderMethod As System.Web.UI.RenderMethod

instance.SetRenderMethodDelegate(renderMethod)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod renderMethod
)
Delphi
public procedure SetRenderMethodDelegate(
    renderMethod: System.Web.UI.RenderMethod
);
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function SetRenderMethodDelegate(
   renderMethod : System.Web.UI.RenderMethod
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod* renderMethod
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod^ renderMethod
)

Parameters

renderMethod

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


SetSessionTheme Method

[image]
Intersoft WebTreeView Documentation
SetSessionTheme Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : SetSessionTheme Method

themeInfo

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetSessionTheme( _
   ByVal themeInfo As ISNet.WebUI.ThemeInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim themeInfo As ISNet.WebUI.ThemeInfo

instance.SetSessionTheme(themeInfo)
C#
public void SetSessionTheme(
   ISNet.WebUI.ThemeInfo themeInfo
)
Delphi
public procedure SetSessionTheme(
    themeInfo: ISNet.WebUI.ThemeInfo
);
JScript
public function SetSessionTheme(
   themeInfo : ISNet.WebUI.ThemeInfo
);
Managed Extensions for C++
public: void SetSessionTheme(
   ISNet.WebUI.ThemeInfo* themeInfo
)
C++/CLI
public:
void SetSessionTheme(
   ISNet.WebUI.ThemeInfo^ themeInfo
)

Parameters

themeInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


SetTheme Method

[image]
Intersoft WebTreeView Documentation
SetTheme Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : SetTheme Method

themeInfo

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub SetTheme( _
   ByVal themeInfo As ISNet.WebUI.ThemeInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim themeInfo As ISNet.WebUI.ThemeInfo

instance.SetTheme(themeInfo)
C#
protected virtual void SetTheme(
   ISNet.WebUI.ThemeInfo themeInfo
)
Delphi
protected procedure SetTheme(
    themeInfo: ISNet.WebUI.ThemeInfo
); virtual;
JScript
protected function SetTheme(
   themeInfo : ISNet.WebUI.ThemeInfo
);
Managed Extensions for C++
protected: virtual void SetTheme(
   ISNet.WebUI.ThemeInfo* themeInfo
)
C++/CLI
protected:
virtual void SetTheme(
   ISNet.WebUI.ThemeInfo^ themeInfo
)

Parameters

themeInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


ShouldReturnJson Method

[image]
Intersoft WebTreeView Documentation
ShouldReturnJson Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : ShouldReturnJson Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ShouldReturnJson() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Boolean

value = instance.ShouldReturnJson()
C#
public virtual System.bool ShouldReturnJson()
Delphi
public function ShouldReturnJson(): System.Boolean; virtual;
JScript
public function ShouldReturnJson() : System.boolean;
Managed Extensions for C++
public: virtual System.bool ShouldReturnJson();
C++/CLI
public:
virtual System.bool ShouldReturnJson();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


ShowAboutBox Method

[image]
Intersoft WebTreeView Documentation
ShowAboutBox Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : ShowAboutBox Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Sub ShowAboutBox()
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView

instance.ShowAboutBox()
C#
protected void ShowAboutBox()
Delphi
protected procedure ShowAboutBox();
JScript
protected function ShowAboutBox();
Managed Extensions for C++
protected: void ShowAboutBox();
C++/CLI
protected:
void ShowAboutBox();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


Site Property

[image]
Intersoft WebTreeView Documentation
Site Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : Site Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<WebSysDescriptionAttribute("Site of the control.")>
<System.ComponentModel.BrowsableAttribute(False)>
Public Property Site As System.ComponentModel.ISite
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.ComponentModel.ISite

instance.Site = value

value = instance.Site
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[WebSysDescriptionAttribute("Site of the control.")]
[System.ComponentModel.BrowsableAttribute(false)]
public System.ComponentModel.ISite Site {get; set;}
Delphi
public read-write property Site: System.ComponentModel.ISite;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
WebSysDescriptionAttribute("Site of the control.")
System.ComponentModel.BrowsableAttribute()
public function get,set Site : System.ComponentModel.ISite
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[WebSysDescriptionAttribute("Site of the control.")]
[System.ComponentModel.BrowsableAttribute(false)]
public: __property System.ComponentModel.ISite* get_Site();
public: __property void set_Site(
   System.ComponentModel.ISite* value
);
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[WebSysDescriptionAttribute("Site of the control.")]
[System.ComponentModel.BrowsableAttribute(false)]
public:
property System.ComponentModel.ISite^ Site {
   System.ComponentModel.ISite^ get();
   void set (    System.ComponentModel.ISite^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


SkinID Property

[image]
Intersoft WebTreeView Documentation
SkinID Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : SkinID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(True)>
Public Overridable Property SkinID As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.String

instance.SkinID = value

value = instance.SkinID
C#
[System.ComponentModel.BrowsableAttribute(true)]
public virtual System.string SkinID {get; set;}
Delphi
public read-write property SkinID: System.String; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
public function get,set SkinID : System.String
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(true)]
public: __property virtual System.string* get_SkinID();
public: __property virtual void set_SkinID(
   System.string* value
);
C++/CLI
[System.ComponentModel.BrowsableAttribute(true)]
public:
virtual property System.String^ SkinID {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


Style Property

[image]
Intersoft WebTreeView Documentation
Style Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : Style Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
<WebSysDescriptionAttribute("Low-level access to control styles.")>
Public ReadOnly Property Style As System.Web.UI.CssStyleCollection
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Web.UI.CssStyleCollection

value = instance.Style
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[WebSysDescriptionAttribute("Low-level access to control styles.")]
public System.Web.UI.CssStyleCollection Style {get;}
Delphi
public read-only property Style: System.Web.UI.CssStyleCollection;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
WebSysDescriptionAttribute("Low-level access to control styles.")
public function get Style : System.Web.UI.CssStyleCollection
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[WebSysDescriptionAttribute("Low-level access to control styles.")]
public: __property System.Web.UI.CssStyleCollection* get_Style();
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[WebSysDescriptionAttribute("Low-level access to control styles.")]
public:
property System.Web.UI.CssStyleCollection^ Style {
   System.Web.UI.CssStyleCollection^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


SupportsDisabledAttribute Property

[image]
Intersoft WebTreeView Documentation
SupportsDisabledAttribute Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : SupportsDisabledAttribute Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
Public Overridable ReadOnly Property SupportsDisabledAttribute As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Boolean

value = instance.SupportsDisabledAttribute
C#
[System.ComponentModel.BrowsableAttribute(false)]
public virtual System.bool SupportsDisabledAttribute {get;}
Delphi
public read-only property SupportsDisabledAttribute: System.Boolean; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
public function get SupportsDisabledAttribute : System.boolean
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
public: __property virtual System.bool get_SupportsDisabledAttribute();
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
public:
virtual property System.bool SupportsDisabledAttribute {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


SupportXMLCultureInfo Property

[image]
Intersoft WebTreeView Documentation
SupportXMLCultureInfo Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : SupportXMLCultureInfo Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Overridable ReadOnly Property SupportXMLCultureInfo As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Boolean

value = instance.SupportXMLCultureInfo
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public virtual System.bool SupportXMLCultureInfo {get;}
Delphi
public read-only property SupportXMLCultureInfo: System.Boolean; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get SupportXMLCultureInfo : System.boolean
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property virtual System.bool get_SupportXMLCultureInfo();
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
virtual property System.bool SupportXMLCultureInfo {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


TabIndex Property

[image]
Intersoft WebTreeView Documentation
TabIndex Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : TabIndex Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Overridable Property TabIndex As System.Short
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Short

instance.TabIndex = value

value = instance.TabIndex
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public virtual System.short TabIndex {get; set;}
Delphi
public read-write property TabIndex: System.Int16; virtual;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set TabIndex : System.short
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property virtual System.short get_TabIndex();
public: __property virtual void set_TabIndex(
   System.short value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
virtual property System.short TabIndex {
   System.short get();
   void set (    System.short value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


TagKey Property

[image]
Intersoft WebTreeView Documentation
TagKey Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : TagKey Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
Protected Overridable ReadOnly Property TagKey As System.Web.UI.HtmlTextWriterTag
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Web.UI.HtmlTextWriterTag

value = instance.TagKey
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
protected virtual System.Web.UI.HtmlTextWriterTag TagKey {get;}
Delphi
protected read-only property TagKey: System.Web.UI.HtmlTextWriterTag; virtual;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
protected function get TagKey : System.Web.UI.HtmlTextWriterTag
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
protected: __property virtual System.Web.UI.HtmlTextWriterTag get_TagKey();
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
protected:
virtual property System.Web.UI.HtmlTextWriterTag TagKey {
   System.Web.UI.HtmlTextWriterTag get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


TagName Property

[image]
Intersoft WebTreeView Documentation
TagName Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : TagName Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Protected Overridable ReadOnly Property TagName As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.String

value = instance.TagName
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
protected virtual System.string TagName {get;}
Delphi
protected read-only property TagName: System.String; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
protected function get TagName : System.String
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
protected: __property virtual System.string* get_TagName();
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
protected:
virtual property System.String^ TagName {
   System.String^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


TemplateControl Property

[image]
Intersoft WebTreeView Documentation
TemplateControl Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : TemplateControl Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
<WebSysDescriptionAttribute("The TemplateControl that hosts this control.")>
<System.ComponentModel.BindableAttribute(Bindable=False, Direction=BindingDirection.OneWay)>
Public Property TemplateControl As System.Web.UI.TemplateControl
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Web.UI.TemplateControl

instance.TemplateControl = value

value = instance.TemplateControl
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[WebSysDescriptionAttribute("The TemplateControl that hosts this control.")]
[System.ComponentModel.BindableAttribute(Bindable=false, Direction=BindingDirection.OneWay)]
public System.Web.UI.TemplateControl TemplateControl {get; set;}
Delphi
public read-write property TemplateControl: System.Web.UI.TemplateControl;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
WebSysDescriptionAttribute("The TemplateControl that hosts this control.")
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set TemplateControl : System.Web.UI.TemplateControl
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[WebSysDescriptionAttribute("The TemplateControl that hosts this control.")]
[System.ComponentModel.BindableAttribute(Bindable=false, Direction=BindingDirection.OneWay)]
public: __property System.Web.UI.TemplateControl* get_TemplateControl();
public: __property void set_TemplateControl(
   System.Web.UI.TemplateControl* value
);
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[WebSysDescriptionAttribute("The TemplateControl that hosts this control.")]
[System.ComponentModel.BindableAttribute(Bindable=false, Direction=BindingDirection.OneWay)]
public:
property System.Web.UI.TemplateControl^ TemplateControl {
   System.Web.UI.TemplateControl^ get();
   void set (    System.Web.UI.TemplateControl^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


TemplateSourceDirectory Property

[image]
Intersoft WebTreeView Documentation
TemplateSourceDirectory Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : TemplateSourceDirectory Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<WebSysDescriptionAttribute("The virtual directory of the Page or UserControl that contains this control.")>
Public Overridable ReadOnly Property TemplateSourceDirectory As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.String

value = instance.TemplateSourceDirectory
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[WebSysDescriptionAttribute("The virtual directory of the Page or UserControl that contains this control.")]
public virtual System.string TemplateSourceDirectory {get;}
Delphi
public read-only property TemplateSourceDirectory: System.String; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
WebSysDescriptionAttribute("The virtual directory of the Page or UserControl that contains this control.")
public function get TemplateSourceDirectory : System.String
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[WebSysDescriptionAttribute("The virtual directory of the Page or UserControl that contains this control.")]
public: __property virtual System.string* get_TemplateSourceDirectory();
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[WebSysDescriptionAttribute("The virtual directory of the Page or UserControl that contains this control.")]
public:
virtual property System.String^ TemplateSourceDirectory {
   System.String^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


ToolTip Property

[image]
Intersoft WebTreeView Documentation
ToolTip Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : ToolTip Property

Glossary Item Box

The tooltip displayed when the mouse is over the control.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overridable Property ToolTip As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.String

instance.ToolTip = value

value = instance.ToolTip
C#
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public virtual System.string ToolTip {get; set;}
Delphi
public read-write property ToolTip: System.String; virtual;
JScript
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set ToolTip : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property virtual System.string* get_ToolTip();
public: __property virtual void set_ToolTip(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
virtual property System.String^ ToolTip {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


TrackViewState Method

[image]
Intersoft WebTreeView Documentation
TrackViewState Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : TrackViewState Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub TrackViewState()
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView

instance.TrackViewState()
C#
protected virtual void TrackViewState()
Delphi
protected procedure TrackViewState(); virtual;
JScript
protected function TrackViewState();
Managed Extensions for C++
protected: virtual void TrackViewState();
C++/CLI
protected:
virtual void TrackViewState();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


UniqueID Property

[image]
Intersoft WebTreeView Documentation
UniqueID Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : UniqueID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<WebSysDescriptionAttribute("The unique ID of the control within the page.")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Overridable ReadOnly Property UniqueID As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.String

value = instance.UniqueID
C#
[System.ComponentModel.BrowsableAttribute(false)]
[WebSysDescriptionAttribute("The unique ID of the control within the page.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public virtual System.string UniqueID {get;}
Delphi
public read-only property UniqueID: System.String; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
WebSysDescriptionAttribute("The unique ID of the control within the page.")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get UniqueID : System.String
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[WebSysDescriptionAttribute("The unique ID of the control within the page.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property virtual System.string* get_UniqueID();
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[WebSysDescriptionAttribute("The unique ID of the control within the page.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
virtual property System.String^ UniqueID {
   System.String^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


Unload Event

[image]
Intersoft WebTreeView Documentation
Unload Event
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : Unload Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the page is unloaded.")>
Public Event Unload As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim handler As System.EventHandler

AddHandler instance.Unload, handler
C#
[WebSysDescriptionAttribute("Fires when the page is unloaded.")]
public event System.EventHandler Unload
Delphi
public event Unload: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the page is unloaded.")]
public: __event System.EventHandler* Unload
C++/CLI
[WebSysDescriptionAttribute("Fires when the page is unloaded.")]
public:
event System.EventHandler^ Unload

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


UseDeepCloneForViewStateStorage Method

[image]
Intersoft WebTreeView Documentation
UseDeepCloneForViewStateStorage Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : UseDeepCloneForViewStateStorage Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function UseDeepCloneForViewStateStorage() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Boolean

value = instance.UseDeepCloneForViewStateStorage()
C#
protected virtual System.bool UseDeepCloneForViewStateStorage()
Delphi
protected function UseDeepCloneForViewStateStorage(): System.Boolean; virtual;
JScript
protected function UseDeepCloneForViewStateStorage() : System.boolean;
Managed Extensions for C++
protected: virtual System.bool UseDeepCloneForViewStateStorage();
C++/CLI
protected:
virtual System.bool UseDeepCloneForViewStateStorage();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


UseMemoryStreamStateType Method

[image]
Intersoft WebTreeView Documentation
UseMemoryStreamStateType Method
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : UseMemoryStreamStateType Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function UseMemoryStreamStateType() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Boolean

value = instance.UseMemoryStreamStateType()
C#
protected virtual System.bool UseMemoryStreamStateType()
Delphi
protected function UseMemoryStreamStateType(): System.Boolean; virtual;
JScript
protected function UseMemoryStreamStateType() : System.boolean;
Managed Extensions for C++
protected: virtual System.bool UseMemoryStreamStateType();
C++/CLI
protected:
virtual System.bool UseMemoryStreamStateType();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


ValidateRequestMode Property

[image]
Intersoft WebTreeView Documentation
ValidateRequestMode Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : ValidateRequestMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebCategoryAttribute("Behavior")>
<System.ComponentModel.DefaultValueAttribute()>
<WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")>
Public Overridable Property ValidateRequestMode As System.Web.UI.ValidateRequestMode
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Web.UI.ValidateRequestMode

instance.ValidateRequestMode = value

value = instance.ValidateRequestMode
C#
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")]
public virtual System.Web.UI.ValidateRequestMode ValidateRequestMode {get; set;}
Delphi
public read-write property ValidateRequestMode: System.Web.UI.ValidateRequestMode; virtual;
JScript
WebCategoryAttribute("Behavior")
System.ComponentModel.DefaultValueAttribute()
WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")
public function get,set ValidateRequestMode : System.Web.UI.ValidateRequestMode
Managed Extensions for C++
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")]
public: __property virtual System.Web.UI.ValidateRequestMode get_ValidateRequestMode();
public: __property virtual void set_ValidateRequestMode(
   System.Web.UI.ValidateRequestMode value
);
C++/CLI
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")]
public:
virtual property System.Web.UI.ValidateRequestMode ValidateRequestMode {
   System.Web.UI.ValidateRequestMode get();
   void set (    System.Web.UI.ValidateRequestMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


ViewState Property

[image]
Intersoft WebTreeView Documentation
ViewState Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : ViewState Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Current viewstate of the control.")>
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Protected Overridable ReadOnly Property ViewState As System.Web.UI.StateBag
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Web.UI.StateBag

value = instance.ViewState
C#
[WebSysDescriptionAttribute("Current viewstate of the control.")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
protected virtual System.Web.UI.StateBag ViewState {get;}
Delphi
protected read-only property ViewState: System.Web.UI.StateBag; virtual;
JScript
WebSysDescriptionAttribute("Current viewstate of the control.")
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
protected function get ViewState : System.Web.UI.StateBag
Managed Extensions for C++
[WebSysDescriptionAttribute("Current viewstate of the control.")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
protected: __property virtual System.Web.UI.StateBag* get_ViewState();
C++/CLI
[WebSysDescriptionAttribute("Current viewstate of the control.")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
protected:
virtual property System.Web.UI.StateBag^ ViewState {
   System.Web.UI.StateBag^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


ViewStateIgnoresCase Property

[image]
Intersoft WebTreeView Documentation
ViewStateIgnoresCase Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : ViewStateIgnoresCase Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
Protected Overridable ReadOnly Property ViewStateIgnoresCase As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Boolean

value = instance.ViewStateIgnoresCase
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
protected virtual System.bool ViewStateIgnoresCase {get;}
Delphi
protected read-only property ViewStateIgnoresCase: System.Boolean; virtual;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
protected function get ViewStateIgnoresCase : System.boolean
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
protected: __property virtual System.bool get_ViewStateIgnoresCase();
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
protected:
virtual property System.bool ViewStateIgnoresCase {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


ViewStateItems Property

[image]
Intersoft WebTreeView Documentation
ViewStateItems Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : ViewStateItems Property

Glossary Item Box

Gets or sets the item to be stored in view state storage.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.CategoryAttribute("View State Settings")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the items to be stored in view state storage.")>
Public Overridable Property ViewStateItems As ISNet.WebUI.ViewStateItem
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As ISNet.WebUI.ViewStateItem

instance.ViewStateItems = value

value = instance.ViewStateItems
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the items to be stored in view state storage.")]
public virtual ISNet.WebUI.ViewStateItem ViewStateItems {get; set;}
Delphi
public read-write property ViewStateItems: ISNet.WebUI.ViewStateItem; virtual;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.CategoryAttribute("View State Settings")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the items to be stored in view state storage.")
public function get,set ViewStateItems : ISNet.WebUI.ViewStateItem
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the items to be stored in view state storage.")]
public: __property virtual ISNet.WebUI.ViewStateItem get_ViewStateItems();
public: __property virtual void set_ViewStateItems(
   ISNet.WebUI.ViewStateItem value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the items to be stored in view state storage.")]
public:
virtual property ISNet.WebUI.ViewStateItem ViewStateItems {
   ISNet.WebUI.ViewStateItem get();
   void set (    ISNet.WebUI.ViewStateItem value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


viewStateLoaded Field

[image]
Intersoft WebTreeView Documentation
viewStateLoaded Field
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : viewStateLoaded Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected viewStateLoaded As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Boolean

value = instance.viewStateLoaded

instance.viewStateLoaded = value
C#
protected System.bool viewStateLoaded
Delphi
protected field viewStateLoaded: System.Boolean;
JScript
protected var viewStateLoaded : System.boolean;
Managed Extensions for C++
protected: System.bool viewStateLoaded
C++/CLI
protected:
System.bool viewStateLoaded

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


ViewStateMode Property

[image]
Intersoft WebTreeView Documentation
ViewStateMode Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : ViewStateMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.ThemeableAttribute(False)>
<WebCategoryAttribute("Behavior")>
<WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Overridable Property ViewStateMode As System.Web.UI.ViewStateMode
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Web.UI.ViewStateMode

instance.ViewStateMode = value

value = instance.ViewStateMode
C#
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")]
[System.ComponentModel.DefaultValueAttribute()]
public virtual System.Web.UI.ViewStateMode ViewStateMode {get; set;}
Delphi
public read-write property ViewStateMode: System.Web.UI.ViewStateMode; virtual;
JScript
System.Web.UI.ThemeableAttribute()
WebCategoryAttribute("Behavior")
WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")
System.ComponentModel.DefaultValueAttribute()
public function get,set ViewStateMode : System.Web.UI.ViewStateMode
Managed Extensions for C++
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property virtual System.Web.UI.ViewStateMode get_ViewStateMode();
public: __property virtual void set_ViewStateMode(
   System.Web.UI.ViewStateMode value
);
C++/CLI
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
virtual property System.Web.UI.ViewStateMode ViewStateMode {
   System.Web.UI.ViewStateMode get();
   void set (    System.Web.UI.ViewStateMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


ViewStateServerConnection Property

[image]
Intersoft WebTreeView Documentation
ViewStateServerConnection Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : ViewStateServerConnection Property

Glossary Item Box

Gets or sets the server connection string for file server-based viewstate storage.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the server connection string for file server-based viewstate storage.")>
<System.ComponentModel.CategoryAttribute("View State Settings")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overridable Property ViewStateServerConnection As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.String

instance.ViewStateServerConnection = value

value = instance.ViewStateServerConnection
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the server connection string for file server-based viewstate storage.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public virtual System.string ViewStateServerConnection {get; set;}
Delphi
public read-write property ViewStateServerConnection: System.String; virtual;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the server connection string for file server-based viewstate storage.")
System.ComponentModel.CategoryAttribute("View State Settings")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set ViewStateServerConnection : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the server connection string for file server-based viewstate storage.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property virtual System.string* get_ViewStateServerConnection();
public: __property virtual void set_ViewStateServerConnection(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the server connection string for file server-based viewstate storage.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
virtual property System.String^ ViewStateServerConnection {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


ViewStateStorage Property

[image]
Intersoft WebTreeView Documentation
ViewStateStorage Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : ViewStateStorage Property

Glossary Item Box

Gets or sets the location to store the viewstate of this control.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the location to store the viewstate of this control.")>
<System.ComponentModel.CategoryAttribute("View State Settings")>
Public Overridable Property ViewStateStorage As ISNet.WebUI.StateCacheStorage
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As ISNet.WebUI.StateCacheStorage

instance.ViewStateStorage = value

value = instance.ViewStateStorage
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the location to store the viewstate of this control.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
public virtual ISNet.WebUI.StateCacheStorage ViewStateStorage {get; set;}
Delphi
public read-write property ViewStateStorage: ISNet.WebUI.StateCacheStorage; virtual;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.DescriptionAttribute("Gets or sets the location to store the viewstate of this control.")
System.ComponentModel.CategoryAttribute("View State Settings")
public function get,set ViewStateStorage : ISNet.WebUI.StateCacheStorage
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the location to store the viewstate of this control.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
public: __property virtual ISNet.WebUI.StateCacheStorage get_ViewStateStorage();
public: __property virtual void set_ViewStateStorage(
   ISNet.WebUI.StateCacheStorage value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the location to store the viewstate of this control.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
public:
virtual property ISNet.WebUI.StateCacheStorage ViewStateStorage {
   ISNet.WebUI.StateCacheStorage get();
   void set (    ISNet.WebUI.StateCacheStorage value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


Visible Property

[image]
Intersoft WebTreeView Documentation
Visible Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : Visible Property

Glossary Item Box

Indicates whether the control is visible and rendered.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Overridable Property Visible As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Boolean

instance.Visible = value

value = instance.Visible
C#
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public virtual System.bool Visible {get; set;}
Delphi
public read-write property Visible: System.Boolean; virtual;
JScript
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set Visible : System.boolean
Managed Extensions for C++
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property virtual System.bool get_Visible();
public: __property virtual void set_Visible(
   System.bool value
);
C++/CLI
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
virtual property System.bool Visible {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


Width Property

[image]
Intersoft WebTreeView Documentation
Width Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : Width Property

Glossary Item Box

The width of the control.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Layout")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overridable Property Width As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Web.UI.WebControls.Unit

instance.Width = value

value = instance.Width
C#
[System.ComponentModel.CategoryAttribute("Layout")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public virtual System.Web.UI.WebControls.Unit Width {get; set;}
Delphi
public read-write property Width: System.Web.UI.WebControls.Unit; virtual;
JScript
System.ComponentModel.CategoryAttribute("Layout")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set Width : System.Web.UI.WebControls.Unit
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Layout")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property virtual System.Web.UI.WebControls.Unit get_Width();
public: __property virtual void set_Width(
   System.Web.UI.WebControls.Unit value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Layout")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
virtual property System.Web.UI.WebControls.Unit Width {
   System.Web.UI.WebControls.Unit get();
   void set (    System.Web.UI.WebControls.Unit value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


XmlCompressionEnabled Property

[image]
Intersoft WebTreeView Documentation
XmlCompressionEnabled Property
See Also Send Feedback
ISNet.WebUI.WebTreeView Namespace > WebTreeView Class : XmlCompressionEnabled Property

Glossary Item Box

Specifies whether the Xml used for clientside state storage should be compressed.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether the Xml used for clientside state storage should be compressed.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overridable Property XmlCompressionEnabled As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTreeView
Dim value As System.Boolean

instance.XmlCompressionEnabled = value

value = instance.XmlCompressionEnabled
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the Xml used for clientside state storage should be compressed.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public virtual System.bool XmlCompressionEnabled {get; set;}
Delphi
public read-write property XmlCompressionEnabled: System.Boolean; virtual;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether the Xml used for clientside state storage should be compressed.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set XmlCompressionEnabled : System.boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the Xml used for clientside state storage should be compressed.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property virtual System.bool get_XmlCompressionEnabled();
public: __property virtual void set_XmlCompressionEnabled(
   System.bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the Xml used for clientside state storage should be compressed.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
virtual property System.bool XmlCompressionEnabled {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTreeView Class
WebTreeView Members


ISNet.WebUI.WebTreeView Namespace Inheritance Hierarchy

ISNet.WebUI.WebTreeView Namespace Inheritance Hierarchy
See Also Send Feedback

Glossary Item Box

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.NamedObjectBase
ISNet.WebUI.WebTreeView.WebTreeViewNode
ISNet.WebUI.WebTreeView.WebTreeViewNodeBinding
ISNet.WebUI.WebTreeView.WebTreeViewAutoPostBackSettings
ISNet.WebUI.WebTreeView.WebTreeViewClientSideEvents
ISNet.WebUI.WebTreeView.WebTreeViewDragDropSettings
ISNet.WebUI.WebTreeView.WebTreeViewImagesSettings
ISNet.WebUI.WebTreeView.WebTreeViewNodeSettings
System.Collections.CollectionBase
ISNet.WebUI.ISCollectionBase
ISNet.WebUI.WebTreeView.WebTreeViewNodeBindingCollection
ISNet.WebUI.WebTreeView.WebTreeViewNodeCollection
System.EventArgs
ISNet.WebUI.WebTreeView.WebTreeViewNodeEditEventArgs
ISNet.WebUI.WebTreeView.WebTreeViewNodeEventArgs
ISNet.WebUI.WebTreeView.WebTreeViewDragDropEventArgs
ISNet.WebUI.WebTreeView.WebTreeViewNodeCopyEventArgs
ISNet.WebUI.WebTreeView.WebTreeViewNodeMoveEventArgs
ISNet.WebUI.WebTreeView.WebTreeViewNodeRenameEventArgs
ISNet.WebUI.WebTreeView.WebTreeViewNodeUpdatedEventArgs
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
ISNet.WebUI.ISNetControl
ISNet.WebUI.WebTreeView.WebTreeView

See Also

Reference

ISNet.WebUI.WebTreeView Assembly


Launching Samples and Tutorials in Visual Studio 2005

Launching Samples and Tutorials in Visual Studio 2005
Send Feedback

Glossary Item Box

This topic provides a step-by-step guidance on how to launch WebGrid's samples and tutorials in Visual Studio 2005

Configuring WebGrid's Tutorials in Visual Studio 2005

  1. Download the tutorials in http://intersoftpt.com/Support/KBArticle.aspx?aid=198&cid=2&tid=1&pid=39,47,55.
  2. Extract files to C:\Inetpub\wwwroot\ WG40TutorialsNET2.
  3. Right click on the WG40TutorialsNET2 directory and choose Properties >> WebSharing >> Share this folder >> click OK twice to apply the changes.
  4. Go to Control Panel >> Administrative Tools >> Internet Information Services >> Web Sites >> Default Web Site.
  5. Search for WG40TutorialsNET2 and Right click on it. Choose Properties >> ASP.NET Tab >> change the ASP.NET version to 2.0.50727 >> click OK.
  6. Go to WG40TutorialsNET2 directory in C:\Inetpub\wwwroot and run WG40TutorialsNET2 solution then search for Solution Explorer.
  7. In Solution Explorer, Right click on the bin folder, then choose Add References.
  8. Browse and add:
    - ISNet.WebGrid.dll from C:\Program Files\Intersoft Solutions\WebGrid.NET V4.0\Bin\NET2
    - ISNet.dll and ISNet.WebUI.dll from C:\Program Files\Intersoft Solutions\WebUI.NET Framework 3.0\Bin
  9. Compile and run the project.

Configuring WebGrid's Samples in Visual Studio 2005

  1. Download the samples in http://intersoftpt.com/Support/KBArticle.aspx?aid=198&cid=2&tid=1&pid=39,47,55
  2. Extract files to C:\Inetpub\wwwroot\ WG40SamplesNET2.
  3. Right click on the WG40TutorialsNET2 directory and choose Properties >> WebSharing >> Share this folder >> click OK twice to apply the changes.
  4. Go to Control Panel >> Administrative Tools >> Internet Information Services >> Web Sites >> Default Web Site.
  5. Search for WG40TutorialsNET2 and Right click on it. Choose Properties >> ASP.NET Tab >> change the ASP.NET version to 2.0.50727 >> click OK.
  6. Go to WG40TutorialsNET2 directory in C:\Inetpub\wwwroot and run WG40TutorialsNET2 solution then search for Solution Explorer.
  7. In Solution Explorer, Right click on the bin folder, then choose Add References.
  8. Browse and add:
    - ISNet.WebGrid.dll from C:\Program Files\Intersoft Solutions\WebGrid.NET V4.0\Bin\NET2
    - ISNet.dll and ISNet.WebUI.dll from C:\Program Files\Intersoft Solutions\WebUI.NET Framework 3.0\Bin
  9. Compile and run the project.


New SmartWebResources™ Framework

New SmartWebResources™ Framework
Send Feedback

Glossary Item Box

At Intersoft Solutions, we constantly conduct extensive research and development to deliver new innovations that help developers become more productive by reducing the efforts and overwhelming complexity in both development and deployment stage.

The brand-new SmartWebResources�?� Framework is one of the exciting technology that we had to offer in 2007 R1 platform. The key objective of SmartWebResources�?� is to eliminate the external physical resources �?? such as scripts, images, etc �?? which required by web components to function properly.

Problems introduced in traditional web components approach

Most web components require client resources such as scripts, images, stylesheets and other client files to gear up some advanced and powerful features. Normally these client resources are delivered through physical client files. In ASP.NET, these files may be located in aspnet_client folder or other common folder which needs to be mapped properly into IIS virtual path in order to function properly.

There are several issues with this traditional approach which causing inefficiency, such as:

  • Special IIS virtual directory is required to store the client resources. In several webhosting that does not support manual virtual directory setup, this can be a significant deployment problem.
  • Special attention and more efforts are required during deployment.
  • Versioning problems. This could cause overwhelming complexity while maintaining the versions of the client resources for specific components.
  • Complexity in maintaining control-specific�??s resources folder. For instance, some scripts are located in folder X, images in folder Y, and other scripts in folder Z.

The solution

The solution to the several issues mentioned above can be achieved by eliminating the requirements to use physical client resources. Thanks to the new SmartWebResources�?� Framework, the physical client resources can be completely eliminated.

The client resources are still required in our web components. It is just they are now stored in �??virtual location�?� which does not require the awareness of developers. They are fetched and delivered to client (browsers) in a new, different way.


a
about
after
against
all
along
also
although
am
among
an
and
are
as
at
be
became
because
been
being
between
but
by
can
caution
come
could
details
did
do
does
doing
done
during
each
early
far
finally
for
found
from
had
has
have
he
her
here
his
how
however
I
if
in
include
including
information
into
is
it
its
late
later
made
many
may
me
med
might
more
most
near
no
non
none
nor
not
note
of
off
on
only
or
other
over
saw
see
seen
several
she
since
so
some
such
than
that
the
their
them
then
there
these
they
this
those
through
tip
to
too
under
until
up
us
use
very
warning
was
we
were
when
where
which
while
who
with
you