Intersoft WebTextEditor

Intersoft WebTextEditor Documentation
Intersoft WebTextEditor
Send Feedback

Glossary Item Box

This section contains information about WebTextEditor.

In This Section

Getting Started

Waltkhrough Topics

How-to Topics

WebTextEditor

WebSpellChecker

WebFileUploader

Server-side References

Client-side References

Product Support

Licensing

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Getting Started

Getting Started
Send Feedback
Intersoft WebTextEditor > Getting Started

Glossary Item Box

This section is designated to help you quickly getting started with WebTextEditor.NET. You can use all links below to become familiar with WebTextEditor.

Installation

The following topics will guide you how to install WebTextEditor.NET and what the system requirements you need to have in order to run WebTextEditor.NET in your PC.

  • Installation Guide
  • System Requirements
  • Use Toolbox Utility Tool to add Intersoft Products to Visual Studio toolbox

Deployment

This section will help you to configure and set the application in deploying the project to server. It also provides a Deployment Checklist which contains the essential things you need to manage before proceeding to deployment.

  • Deployment Guide

Samples and Walkthroughs

This section will help you to locate the sample files available in the project.

  • Locating Samples Files

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Installation

Installation
Send Feedback
Intersoft WebTextEditor > Getting Started > Installation

Glossary Item Box

This section contains information on installing WebTextEditor.NET and specifying the system requirements needed by the component.

In This Section

Installation Guide
Information about installing WebTextEditor.NET on your PC.

System Requirements
Read about the Windows version, Visual Studio application, WebUI.NET Framework and other software requirements for installing WebTextEditor.NET.

Use Toolbox Utility Tool to add Intersoft Products to Visual Studio toolbox
Information about installing WebTextEditor control to Visual Studio toolbox using Toolbox Utility tool.

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Installation Guide

Installation Guide
See Also Send Feedback
Intersoft WebTextEditor > Getting Started > Installation > Installation Guide

Glossary Item Box

Installation Requirement

For system requirement, please see the System Requirements section.

Installing WebTextEditor

Intersoft has released the new setup installer which includes WebUI Framework 3, WebGrid Enterprise 7, WebCombo 4, WebInput 4, WebDesktop 3, WebTreeView, ISDataSource, WebScheduler 3, WebAqua 2, Intersoft Presenter, Intersoft Data Source, WebTextEditor, WebEssentials and ClientUI components.

Here are the step-by-step instructions to install WebTextEditor:

  1. Double click on the "intersoft webui studio 2010 r1.exe" icon to start the installation process. Read the instructions, and click next.

  2. Please read the license agreement. You must accept the terms in the license agreement in order to install WebTextEditor.

  3. Fill in your details such as User Name and Organization. Click Next to proceed.

  4. You can select the product edition and setup type that you would like to install and perform.

    The product contains three editions such as WebUI Studio for ASP.NET, WebUI Studio for Silverlight and WebUI Studio for WPF.

  5. You can select the target environment for the samples, either Microsoft Visual Studio 2008 or Microsoft Visual Studio 2010.

  6. You can also customize the Start Menu group and choose to create shortcuts for all users or just for yourself.

  7. Click Next to proceed with the installation process.

  8. The wizard is installing WebUI Studio 2010 R1.

  9. A window showing the installation progress appears. It will list the status of components that are being installed.

  10. After the installation process has been finished, you will see a confirmation window. Click Finish to close the window. At this rate, you have successfully installed the Intersoft WebUI Studio 2010 R1.

  11. To install the full version of WebTextEditor, proceed by using License Manager that can be triggered from Start menu >> All Programs >> Intersoft WebUI Studio 2010 R1 >> License Manager.

  12. Intersoft License Manager window will appear. Click "Add License" to proceed to the next step.

  13. Now, Select a product from the combo box. In this case, select WebTextEditor Version 1.0.1000 and enter the license according to the component.

  14. Click Add and it will automatically check the license with the server through internet connection. If it is correct, then you have successfully installed the full version of WebTextEditor.

See Also

Other Resources
{System Requirements}
Use Toolbox Utility Tool to add Intersoft Products to Visual Studio toolbox

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


System Requirements

System Requirements
See Also Send Feedback
Intersoft WebTextEditor > Getting Started > Installation > System Requirements

Glossary Item Box

Development Machine Requirements

  • Microsoft Windows Vista
  • Microsoft Windows 2000/2003/2008 Server family
  • Microsoft Windows XP Professional or Home Edition
  • Microsoft .NET Framework v2.0 or higher
  • Microsoft Visual Studio 2005 Professional/Team Studio/Express Edition
  • Microsoft Visual Studio 2008
  • Intersoft WebUI.NET Framework v3.0 or higher

Server Machine Requirements

  • Windows Server 2003 Enterprise
  • Windows Server 2003 Web Edition
  • Windows Server 2008
  • Internet Information Services 6.0 or later
  • Microsoft .NET Framework Version 2.0 or later
  • Intersoft WebUI.NET Framework v3.0 or higher

Client Machine Requirements

  • Microsoft Internet Explorer 5.5 or higher
  • Mozilla V1.7 +for Windows/Mac/Linux/Solaris
  • Firefox V1.0+ for Windows/Mac/Linux/Solaris
  • Netscape V7.0+ for Windows/Mac/Linux/Solaris
  • Opera 9.5+ for Windows/Mac/Linux/Solaris/FreeBSD/BeOS/QNX
  • Apple Safari 3+ for Windows/Mac

See Also

Other Resources
{Installation Guide}
Use Toolbox Utility Tool to add Intersoft Products to Visual Studio toolbox

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Use Toolbox Utility Tool to add Intersoft Products to Visual Studio toolbox

Use Toolbox Utility Tool to add Intersoft Products to Visual Studio toolbox
Send Feedback
Intersoft WebTextEditor > Getting Started > Installation > Use Toolbox Utility Tool to add Intersoft Products to Visual Studio toolbox

Glossary Item Box

This topic provides a step-by-step instruction on how to manually add Intersoft products to Visual Studio Toolbox using Toolbox Utility tool.

To add Intersoft products to Visual Studio Toolbox

  1. Run Intersoft ToolBox Utility for Visual Studio from Start Menu >> All Programs >> Intersoft WebUI Studio 2010 R1 >> Intersoft ToolBox Utility for Visual Studio or you can access ToolBoxUtility.exe from [Installation Folder]\Intersoft Solutions\Intersoft WebUI Studio 2010 R1\ToolBoxUtility
  2. Select on the Visual Studio platform you want Intersoft products to be installed. By default, it will automatically select all Visual Studio versions installed on your PC.

  3. Click Register to run the tool and wait until the process is finished.

  4. Finally, open your project and you will notice that Intersoft products has been installed successfully into Visual Studio Toolbox.

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Deployment

Deployment
Send Feedback
Intersoft WebTextEditor > Getting Started > Deployment

Glossary Item Box

This section contains information on configuring the application and guiding user with a step-by-step Checklist instructions for deployment purposes.

In This Section

Deployment Guide
Information about Deployment Checklist that will list all the important tasks you need to do before deploying the project.

Application Wide Configurations
Read about the WebTextEditor's ability to configure deployment-related properties via web.config, such as ScriptDirectory and many others.

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Deployment Guide

Deployment Guide
Send Feedback
Intersoft WebTextEditor > Getting Started > Deployment > Deployment Guide

Glossary Item Box

This section continues to guide you on how to deploy the project by using Deployment Manager.

In This Section

Using Deployment Manager
Learn how to use deployment manager to set the runtime license.

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Using Deployment Manager
Send Feedback
Intersoft WebTextEditor > Getting Started > Deployment > Deployment Guide > Using Deployment Manager

Glossary Item Box

Intersoft comes up with a new hassle-free Deployment Manager that is designated to help developers to easily manage configurations during deployment phase.

Now, you can quickly configure the common settings required in deployment such as entering runtime license keys, view state configurations and others through user-friendly Windows GUI application.

Using Deployment Manager

Here are the step-by-step instructions to use Deployment Manager:

  1. Open Deployment Manager from Start menu >> All Programs >> Intersoft WebUI Studio 2009 R1 >> WebUI Studio for ASP.NET >> Deployment Manager.
  2. Click Browse and select the project's directory of your web application to be configured. Click Next afterwards.

  3. Tick WebTextEditor.NET 1.0.1000 and put the Runtime License key according to the component. Click Next to proceed to the next step.

  4. In this step, there are many settings you can configure such as View State Storage, Optimization, Client Resources and Advanced sections.

    View State Storage Section

    View State Storage section lets you configure how ViewState is stored, specify how ViewState items are going to be saved in ViewState and determine the priority and duration of items stored in Cache object.

    Optimization Section

    Optimization section lets you choose whether to enable CSS Optimization and XML compression.

    Client Resources Section

    This section contains information on how to enable WebResources and set its mode.

    If you have applied SmartWebResources™ in your project, this option will be automatically selected with its default mode set to Auto.

    Advanced Section

    Advances section allows you to add necessary keys such as SharedScriptDirectory, ImagesDirectory or custom keys.

    In this section, you will learn how to assign the keys and values needed when you deploy the project.
    - In Advances section, click the ">" sign to move the available keys to the applied keys.
    - In Applied Keys table, Set the values like following:

    Key | Value
    ScriptDirectory | ~/CommonLibrary/WebTextEditor/V1_0_1000/
    SharedScriptDirectory | ~/CommonLibrary/Shared/
    ImagesDirectory | ~/CommonLibrary/Images/

    This section is very critical to be applied when you copy the CommonLibrary folder to the project's directory in development machine. However, if you have enabled SmartWebResources™, you no longer need to configure the directory settings.

  5. Click Next or Apply to save the configuration. Finally, the web.config has been updated successfully. Click Close to apply the settings.

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Application Wide Configurations

Application Wide Configurations
Send Feedback
Intersoft WebTextEditor > Getting Started > Deployment > Application Wide Configurations

Glossary Item Box

One of the unique features introduced since the initial products is the ability to configure specific deployment-related properties via web.config. WebUI.NET Framework further enhanced this capability by adding more properties which are configurable through web.config. Now, it also supports relative application path by using ~ character. The application-wide configurations feature allows centralized configuration for common deployment properties such as ScriptDirectory etc, which dramatically increase effectiveness and efficiency particularly for maintenance purpose.

Following is the list of properties that are configurable through web.config:

  • SharedScriptDirectory
  • ScriptDirectory
  • ImagesDirectory
  • ViewStateStorage
  • RuntimeLicenseKey
  • PageCachePriority
  • PageCacheDuration

The settings specified in web.config will only be applied to instances' properties that have Default value (unchanged).

The format of the key used for the configuration is AssemblyFullName.vProductVersion.Properties.

Examples:

The sample configuration in web.config below will change the property value of ScriptDirectory, ImagesDirectory and SharedScriptDirectory to all WebTextEditor V2.0.7200 instances in the application.

<configuration>

< appSettings>

<add key="ISNet.WebUI.WebTextEditor.v2_0_1500.ScriptDirectory" value ="~/CommonLibrary/WebTextEditor/V2_0_1500/" />

<add key="ISNet.WebUI.WebTextEditor.v2_0_1500.ImagesDirectory" value ="~/CommonLibrary/Images/" />

<add key="ISNet.WebUI.WebTextEditor.v2_0_1500.SharedScriptDirectory" value ="/CommonLibrary/Shared/" />

</appSettings>

... other settings

</configuration>

Additional application-wide configurations may be available specifically per product. Please refer to the Application-wide Configurations topic in the product's help file.

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Samples and Walkthroughs

Samples and Walkthroughs
Send Feedback
Intersoft WebTextEditor > Getting Started > Samples and Walkthroughs

Glossary Item Box

This section contains information about location of sample and tutorial files, example codes and how to use WebTextEditor.NET in Visual Studio 2008.

In This Section

Locating Sample Files
Discover the locations where sample files are stored on your computer or the installation source.

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Locating Samples Files

Locating Samples Files
Send Feedback
Intersoft WebTextEditor > Getting Started > Samples and Walkthroughs > Locating Samples Files

Glossary Item Box

The default locations for Sample files in this release are listed below. %install% represents the location where Intersoft's components are installed, such as \Program Files\Intersoft Solutions\.

Product | Sample Location
WebGrid C# Samples (Visual Studio 2008 Solution) | C:\%install%\Intersoft WebUI Studio 2009 R1\Samples\For ASP.NET\ISNet.WebUI.Samples\cs

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


What's New in V2.0

What's New in V2.0
Send Feedback
Intersoft WebTextEditor > What's New in V2.0

Glossary Item Box

This section describes the new features and technologies added in WebTextEditor 2.0. Here are the following lists of new features supported by WebTextEditor 2.0:

Support HTML5 and CSS3

WebTextEditor has been refined to fully support the latest web standards. This allows you to use many of the WebTextEditor features in your next-generation web applications and at the same time leveraging cutting-edge technologies such as HTML5 and CSS3.

  • To learn how to enable HTML5 rendering mode in WebTextEditor, see How-to: Enable HTML5 Rendering Mode.

Metro-Style Visual Theme

Designed from the ground up by Intersoft artist, WebTextEditor now is preloaded with the new dazzling metro style.

Thanks to WebTextEditor’s DefaultStyle – architecture, applying the new theme can be done as easy as one property set. The new theme is available as new options in DefaultStyleMode property in the WebTextEditor control.

The new theme is designed with flat, clean, minimalistic, and typography-focused concept. All elements in WebTextEditor besides callout and floating toolbar will be adjusted to use the selected style mode.

In order to apply the new theme, simply set DefaultStyleMode property to MetroStyle.

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


How-to: Enable HTML5 Rendering Mode

How-to: Enable HTML5 Rendering Mode
Send Feedback
Intersoft WebTextEditor > What's New in V2.0 > How-to: Enable HTML5 Rendering Mode

Glossary Item Box

This topic explains how to configure WebTextEditor to emit HTML5 compliance output.

Configure Doc Type

Each doctype declaration in HTML specification produces different results and behaviors, mostly in the layout and rendering aspects. WebTextEditor supports most commonly used doctype and automatically adjust the behaviors and rendering results by detecting the doctype declaration of the HTML page.

In version 2, WebTextEditor has been significantly enhanced to deliver consistent behaviors and layout in HTML5 pages. All features should work exactly as in other doctype.

To enable HTML5 support in WebTextEditor, make sure you have configured the HTML pages to use the proper doctype. The standard doctype for HTML5 is <!DOCTYPE html>.

The following code example shows how to use WebTextEditor in a simple WebForm using HTML5 doctype.

ASPX Copy Code
<%@ Page Language="C#" AutoEventWireup="true" CodeFile="Default.aspx.cs" Inherits="Default" %>
<%@ Register Assembly="ISNet.WebUI.WebTextEditor" Namespace="ISNet.WebUI.WebTextEditor" TagPrefix="ISWebTextEditor" %>

<!DOCTYPE html>
<html>
<head runat="server">
    <title></title>
</head>
<body>
    <form id="form1" runat="server">
    <div>
         <ISWebTextEditor:WebTextEditor ID="WebTextEditor1" runat="server">
         </ISWebTextEditor:WebTextEditor>
    </div>
    </form>
</body>
</html>

Note that the xmlns attribute is no longer necessary to be defined in the <html> tag. If you upgraded your existing pages, make sure the xmlns attribute is removed from the <html> tag.

Also, to enable percentage height in HTML5, you must define its height in body and html element. Here's the example

ASPX Copy Code
<head runat="server">
    <title></title>
    <style type="text/css">
    html, body
    {
        height: 100%;
        width: 100%;
        margin: 0;
        padding: 0;
    }
    </style>
</head>

In HTML5, height of an element is refer to its parent's height so this is necessary to define its parent element.

Configure Rendering Mode

To provide the best HTML5 support, WebInput needs to adjust several features that are commonly processed in the server-side such as markup rendering and AJAX callback response. Unfortunately, the HTML5 doctype cannot be automatically detected by the server-side browser capability. As such, WebTextEditor introduces a new property called RenderingMode which you must set explicitly in order to activate HTML5 compliance output.

You can set the rendering mode in a WebTextEditor instance individually by setting the RenderingMode property to HTML5 value, which is shown in the example below.

ASPX Copy Code
<ISWebTextEditor:WebTextEditor ID="WebTextEditor1" runat="server" RenderingMode="HTML5">
</ISWebTextEditor:WebTextEditor>

Alternatively, you can also apply the rendering mode globally through the application-wide configuration, see the following example.

Web.config Copy Code
<add key="ISNet.WebUI.WebTextEditor.v2_0_1500.RenderingMode" value="HTML5"/>
If your project is exclusively targeting HTML5, it's recommended to use application-wide configuration to apply the rendering mode to all WebTextEditor instances in the project.

For more information about application-wide settings in WebTextEditor, see Application Wide Configurations.

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Walkthrough Topics

Walkthrough Topics
See Also Send Feedback
Intersoft WebTextEditor > Walkthrough Topics

Glossary Item Box

The following list of walkthrough topics demonstrates how to use all features in WebTextEditor and how to manipulate WebTextEditor into some complex structures.

Custom Task Pane

The topic in this category provides information about creating task pane content.

  • Walkthrough: Creating Custom Task Pane Content

Integration with WebSpellChecker

The topic in this category provides information about Integration with WebSpellChecker.

  • Walkthrough: Integration with WebSpellChecker

Integration with FileUploader

The topic in this category provides information about integration with FileUploader.

  • Walkthrough: Integration with WebFileUploader

Mail Merge

The topics in this category provide information about enabling mail merge with data bound and custom collection.

  • Walkthrough: Enabling Mail Merge with Data Bound Collection
  • Walkthrough: Enabling Mail Merge with Custom Collection

Attachment Layout Mode

The topic in this category provides information about using WebFileUploader with AttachmentBar UI.

  • Walkthrough: Using WebFileUploader with AttachmentBar UI

Upload

The topics in this category provide information about configuring upload location and limits.

  • Walkthrough: Configuring Upload Location
  • Walkthrough: Configuring Upload Limits

See Also

Other Resources
{How-to topics}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


How-to topics

How-to topics
See Also Send Feedback
Intersoft WebTextEditor > How-to topics

Glossary Item Box

The following list of How-to topics describes how to implement various features and enhancements in WebTextEditor.

WebTextEditor - Insert Image

The topic in this category provides direct instruction on how to insert image to WebTextEditor.

  • How-to: Insert image to WebTextEditor

WebTextEditor - Insert Media

The topic in this category provides direct instruction on how to insert media to WebTextEditor.

  • How-to: Insert media to WebTextEditor

WebTextEditor - Insert Table

The topic in this category provides direct instruction on how to insert table to WebTextEditor.

  • How-to: Insert table to WebTextEditor

WebTextEditor - Enable Keyboard Support

The topic in this category provides direct instruction on how to enable and disable keyboard support.

  • How-to: Enable and disable keyboard support

WebTextEditor - Allow Resize

The topic in this category provides direct instruction on how to allow resize in WebTextEditor.

  • How-to: Allow Resize in WebTextEditor

WebTextEditor - Full Screen

The topic in this category provides direct instruction on how to enable full screen in WebTextEditor.

  • How-to: Enable Full Screen in WebTextEditor

WebTextEditor - Allow Style Merging

The topic in this category provides direct instruction on how to allow style merging in WebTextEditor.

  • How-to: Allow Style Merging in WebTextEditor

WebTextEditor - Load Custom CSS File

The topic in this category provides direct instruction on how to load custom CSS file in WebTextEditor.

  • How-to: Load Custom CSS File in WebTextEditor

WebTextEditor - Custom ToolBar

The topics in this category provide direct instructions on how to add custom toolbar using XML File.

  • How-to: Add Custom ToolBar using XML File
  • How-to: Save and Load ToolBar Structure

WebTextEditor - Customize ToolBar programmatically from server-side

The topics in this category provide direct instructions on how to add and remove command or toolbar.

  • How-to: Add Custom Command using InitializeToolBar server-side event
  • How-to: Remove Command using InitializeToolBar server-side event
  • How-to: Add Custom ToolBar using InitializeToolBar server-side event
  • How-to: Remove ToolBar using InitializeToolBar server-side event

WebTextEditor - Perform Document Properties Actions

The topics in this category provide direct instructions on how to import, save, print and preview a document.

  • How-to: Import a document to WebTextEditor
  • How-to: Save a document to WebTextEditor
  • How-to: Print a document to WebTextEditor
  • How-to: Preview a document in WebTextEditor

WebTextEditor - Customize Context Menu

The topic in this category provides direct instruction on how to add item in context menu.

  • How-to: Add Item in Context Menu

WebTextEditor - Data Binding

The topics in this category provide direct instructions on how to use WebTextEditor as Item Template of Details view.

  • How-to: Use WebTextEditor as Item Template of DetailsView
  • How-to: Integrate WebTextEditor in FormView

WebSpellChecker - User Interface

The topics in this category provide direct instructions on how to implement spell checker with red wave highlight and WebDialogBox.

  • How-to: Implement spell checker with red wave highlight
  • How-to: Implement spell checker with WebDialogBox

WebSpellChecker - Maximum text suggestion

The topics in this category provides direct instruction on how to customize maximum text suggestion.

  • How-to: Customize maximum text suggestion

WebFileUploader - IIS 6 and IIS 7 Integrated mode support

The topics in this category provide direct instructions on how to configure WebFileUploader in both IIS 6 and IIS 7 application.

  • How-to: Configure WebFileUploader for IIS 6 application
  • How-to: Configure WebFileUploader for IIS 7 application

See Also

Other Resources
{Walkthrough Topics}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


WebTextEditor Overview

WebTextEditor Overview
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor Overview

Glossary Item Box

WebTextEditor is the industry's first text editor that integrates intuitive writing tools, inline spelling checker, and sophisticated uploading capability in a single interface - enabling you to rapidly build rich CMS application that delivers breakthrough, unique editing experience to your end users.

WebTextEditor includes innovative features to simplify content authoring, such as:

  • Reliable formatting, high-performance editor with strict XHTML compliance output.
  • Sophisticated, elegant user interfaces.
  • Fluid smart toolbars and Word-style floating toolbar.
  • Spell check right within the editor; highlight errors in red-wave underlines and context menu for word suggestion.
  • One-click automatic hints suggestion in the status bar.
  • Integrated file uploader, lets users upload multiple files right within the editor.
  • Sophisticated asynchronous uploading technology, enables editing while uploading is in progress.
  • And more.

Intersoft WebTextEditor delivers all expected editing features, plus state-of-the-art interfaces,
rich user experiences and dozens of innovative features.

See Also

Other Resources
Core Editing Features
{Sections}
{Text Settings}
Sleek Design and Elegant User Interface
{Fluid, Smart ToolBar}
{View}
{Innovative Task Pane}
{Enable Context Menu}
Integration with WebSpellChecker
{Integration with FileUploader}
{Data Binding}
{Mail Merge}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Editing Architecture

Editing Architecture
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > Editing Architecture

Glossary Item Box

In This Section

Core Editing Features

XHTML 1.1 Compliance Output

Load custom CSS files

Enable Keyboard Support

Enable Context Menu

Auto Save

Save to HTML

Load from HTML

How-to: Save and Load Content

How-to: Save Content in FlyPostBack

See Also

Other Resources
WebTextEditor Overview
{Sections}
{Text Settings}
{Sleek Design and Elegant User Interface}
{Fluid, Smart ToolBar}
{View}
{Innovative Task Pane}
{Enable Context Menu}
{Integration with WebSpellChecker}
{Integration with FileUploader}
{Data Binding}
{Mail Merge}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Core Editing Features

Core Editing Features
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > Editing Architecture > Core Editing Features

Glossary Item Box

WebTextEditor is using its own editing engine that developed to support various kinds of new scenarios and to provide richer user experience. In addition to common editing scenarios such as text editing, font formatting and paragraph editing, WebTextEditor covers more advanced scenarios such as discussed in the following points.

WebTextEditor includes key editing features such as:

  • Streamline Cut, Copy and Paste Operation
  • Multiple Undo and Redo
  • Insert Link
  • Insert Image
  • Edit Image
  • Insert Media
  • Insert Symbol
  • Insert Table
  • Edit Table
  • Edit Cell Properties
  • Find
  • Replace
  • Word and Character Count
  • Html Inspector
  • Editing in html view

See Also

Other Resources
{XHTML 1.1 Compliance Output}
{Load custom CSS files}
{Enable Keyboard Support}
{Enable Context Menu}
{Auto Save}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Streamlined Cut, Copy and Paste Operation

Streamlined Cut, Copy and Paste Operation
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > Editing Architecture > Core Editing Features > Streamlined Cut, Copy and Paste Operation

Glossary Item Box

WebTextEditor implements sophisticated clipboard management to address the limitations and different specifications of clipboard in various browsers. Based on how users invoke the clipboard saving operation such as cut and copy, WebTextEditor automatically uses the best approach to manage the clipboard data according to the browser type.

This streamlined clipboard management is crucial to ensuring smooth clipboard operation in various browsers. As such, WebTextEditor manages the clipboard data and decides when it should get the clipboard data from browser, and when it should get from editor's internal cache.

User can perform clipboard operations through the following ways:

  1. Toolbar command
    Operation invoked through toolbar commands for cut and copy operation will use internal cache clipboard management.

    The limitation from this approach is that user cannot paste the clipboard data from editor to other place except to the editor itself.

  2. Keyboard shortcut
    Operation invoked through keyboard shortcut for cut and copy operation will use browser default clipboard management.

    When using keyboard shortcut, WebTextEditor will perform both saving mechanism at the same time when cut or copy operation is invoked, this can be achieved by setting EnableKeyboardShortcut property to true.

The purpose of this clipboard management is tightly integrated with paste operation. In paste operation, internal editor's cache of clipboard data will become the first priority to be pasted. If editor's internal cache is empty, WebTexteditor will obtain data from browser's default clipboard.

WebTextEditor also implements automatic sliding expiration for its internal clipboard cache to keep the clipboard data concurrent and latest.

See Also

Other Resources
{Multiple Undo and Redo}
{Insert Link}
{Insert Image}
{Edit Image}
{Insert Media}
{Insert Symbol}
{Insert Table}
{Edit Table}
Edit Cell Properties
{Find}
{Replace}
{Word and Character Count}
{Html Inspector}
{Editing in html view}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Multiple Undo and Redo

Multiple Undo and Redo
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > Editing Architecture > Core Editing Features > Multiple Undo and Redo

Glossary Item Box

WebTextEditor includes multiple undo and redo feature. It is unique in the way every action is logged with user-friendly message to a maximum of 20 stacks using FIFO (First-in-first-out) implementation. Each logged action can be found in Undo and Redo list, by clicking on the dropdown arrow of respective tool command.

WebTextEditor logs every action that cause changes to the editor, including typing. You can customize how fast WebTextEditor should log typing action. Simply set the provided UndoLatency property to an integer value measured in milliseconds. The default value is set to 1000(ms), which means every typing action will be logged on every 1000ms after the last stop.

See Also

Other Resources
{Streamlined Cut, Copy and Paste Operation}
{Insert Link}
{Insert Image}
{Edit Image}
{Insert Media}
{Insert Symbol}
{Insert Table}
{Edit Table}
{Edit Cell Properties}
{Find}
{Replace}
{Word and Character Count}
{Html Inspector}
Editing in html view

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Insert Link

Insert Link
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > Editing Architecture > Core Editing Features > Insert Link

Glossary Item Box

WebTextEditor provides a new user interface to insert link, which is focused on simplicity and efficiency. Link insertion in WebTextEditor is displayed with lightweight, elegant callout. In the callout, user can easily specify the url's text, address and other input.

If there is a text selection when user clicked on "Insert Link" command, the selection text will be automatically appearing in the url's Text.

See Also

Other Resources
{Streamlined Cut, Copy and Paste Operation}
{Multiple Undo and Redo}
{Insert Image}
{Edit Image}
{Insert Media}
{Insert Symbol}
Insert Table
{Edit Table}
{Edit Cell Properties}
{Find}
{Replace}
{Word and Character Count}
{Html Inspector}
{Editing in html view}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Insert Image

Insert Image
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > Editing Architecture > Core Editing Features > Insert Image

Glossary Item Box

WebTextEditor introduces new ways to work with images and provides more flexibility for user to insert images. User can insert images from callout interface or media gallery task pane.

Task pane is an independent visual element on sidebar panel that displays related contents and editing actions which significantly improves overall user experience. It enables users to perform editing tasks more easily and conveniently in a single interface.

Image insertion through callout can be done by clicking on "Insert from Web" command in the toolbar.

For further information about how to insert image through media gallery taskpane, please refer to task pane documentation.

In This Section

How-to: Insert image to WebTextEditor

See Also

Other Resources
{Streamlined Cut, Copy and Paste Operation}
{Multiple Undo and Redo}
{Insert Link}
{Edit Image}
{Insert Media}
Insert Symbol
{Insert Table}
{Edit Table}
{Edit Cell Properties}
{Find}
{Replace}
{Word and Character Count}
{Html Inspector}
{Editing in html view}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


How-to: Insert image to WebTextEditor

How-to: Insert image to WebTextEditor
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > Editing Architecture > Core Editing Features > Insert Image > How-to: Insert image to WebTextEditor

Glossary Item Box

WebTextEditor provides a method to insert image to the editor.

In this topic, you will learn how to insert image.

To insert image to WebTextEditor

  1. Simply click on the Media Gallery command in the toolbar to display the task pane.
  2. To insert an image to WebTextEditor, simply double clicking on the image or through the image's context menu. You can insert image along with its frame using image's context menu.

After the image is inserted, a lightweight callout interface will be shown close to your image position, enabling user to work with images more intuitively.

See Also

Other Resources
Insert Image

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Edit Image

Edit Image
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > Editing Architecture > Core Editing Features > Edit Image

Glossary Item Box

Every time an image is added to WebTextEditor, an editing image callout will appear near to the added image. User can perform image editing through this callout.

There are several settings of image that can be customized:

  • Media Title
    Specify title to the image.
  • Media Caption
    Specify caption to the image. This will be reflected if the image is using frame.
  • Link URL
    Specify link url of the image.
  • Caption Alignment
    Specify caption alignment of the image. This will be reflected if the image is using frame.
  • Size
    Specify the image's size.
  • UseFrame
    Specify whether the image should be contained in a frame.

See Also

Other Resources
{Streamlined Cut, Copy and Paste Operation}
{Multiple Undo and Redo}
{Insert Link}
{Insert Image}
{Insert Media}
{Insert Symbol}
{Insert Table}
{Edit Table}
{Edit Cell Properties}
{Find}
{Replace}
{Word and Character Count}
{Html Inspector}
{Editing in html view}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Insert Media

Insert Media
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > Editing Architecture > Core Editing Features > Insert Media

Glossary Item Box

Beside images, user can also insert other media type in WebTextEditor such as audios, videos, flash video and even Youtube video. Several type of media file that supported by WebTextEditor are .wav, .wma, .wmv, .avi, .mov, .mpeg and .mpg

Insert media can be done through callout interface or media gallery task pane. For further information about how to insert media through task pane, please refer to Task Pane documentation.

In This Section

How-to: Insert media to WebTextEditor

See Also

Other Resources
{Streamlined Cut, Copy and Paste Operation}
{Multiple Undo and Redo}
{Insert Link}
{Insert Image}
{Edit Image}
{Insert Symbol}
{Insert Table}
{Edit Table}
{Edit Cell Properties}
{Find}
{Replace}
{Word and Character Count}
{Html Inspector}
{Editing in html view}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


How-to: Insert media to WebTextEditor

How-to: Insert media to WebTextEditor
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > Editing Architecture > Core Editing Features > Insert Media > How-to: Insert media to WebTextEditor

Glossary Item Box

WebTextEditor provides a method to insert media to the editor.

In this topic, you will learn how to insert media.

To insert media to WebTextEditor

  1. Simply click on the Insert From Web command in the toolbar to display the callout.
  2. Define the Media Type such as Pictures, Audios, Videos, Flash videos and YouTube videos.
  3. Define the Media URL and then click Insert Media.

See Also

Other Resources
{Insert Media}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Insert Symbol

Insert Symbol
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > Editing Architecture > Core Editing Features > Insert Symbol

Glossary Item Box

There are 20 predefined symbols in WebTextEditor, user can insert the symbol to editor with Symbol pop up. Simply click on the "Insert Symbol" command on the toolbar, and choose the symbol to be inserted from the symbol popup.

See Also

Other Resources
{Streamlined Cut, Copy and Paste Operation}
{Multiple Undo and Redo}
{Insert Link}
{Insert Image}
{Edit Image}
{Insert Media}
{Insert Table}
{Edit Table}
{Edit Cell Properties}
{Find}
{Replace}
{Word and Character Count}
{Html Inspector}
{Editing in html view}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Insert Table

Insert Table
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > Editing Architecture > Core Editing Features > Insert Table

Glossary Item Box

WebTextEditor introduces new ways to work with table. User can insert table through intuitive Insert Table pop up similar to Microsoft Word, or through Insert Table task pane for more advanced table design task.

For further information about how to insert table through task pane, please refer to Task Pane documentation.

In This Section

How-to: Insert table to WebTextEditor

See Also

Other Resources
{Streamlined Cut, Copy and Paste Operation}
{Multiple Undo and Redo}
Insert Link
{Insert Image}
{Edit Image}
{Insert Media}
{Insert Symbol}
Edit Table
{Edit Cell Properties}
{Find}
{Replace}
{Word and Character Count}
{Html Inspector}
{Editing in html view}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


How-to: Insert table to WebTextEditor

How-to: Insert table to WebTextEditor
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > Editing Architecture > Core Editing Features > Insert Table > How-to: Insert table to WebTextEditor

Glossary Item Box

WebTextEditor provides a method to insert table to the editor.

In this topic, you will learn how to insert table.

To insert table to WebTextEditor

  1. Set TooBarMode property to Rich under ToolBarSettings.
  2. Simply click on the Media Gallery command in the toolbar to display the task pane.
  3. Click the Task pane button and choose Table Designer.
  4. In Table Designer, you can freely customize the table to be inserted. Click Insert Table when you done customizing the table.

  5. Otherwise, you can simply click Insert Table command in the toolbar and customize the table directly.

See Also

Other Resources
{Insert Table}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Edit Table

Edit Table
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > Editing Architecture > Core Editing Features > Edit Table

Glossary Item Box

WebTextEditor also provides comprehensive table editing commands, such as listed below.

  1. Insert columns to the left
    Add new column to the left of focused cell.
  2. Insert columns to the right
    Add new column to the right of focused cell.
  3. Delete columns
    Delete focused cell column.
  4. Insert Rows Above
    Add new row to above focused cell.
  5. Insert Rows Below
    Add new row below focused cell.
  6. Delete Rows
    Delete focused cell row.
  7. Merge Cells Down
    Merge focused cell with cell which position below focused cell.
  8. Merge Cells Right
    Merge focused cell with cell which position in the right of focused cell.
  9. Split Cells Vertical
    Split focused cell vertically.
  10. Split Cells Horizontal
    Split focused cell horizontally

In order to perform table editing in WebTextEditor, user should select on a table's cell and open Table Designer task pane. Alternatively, it can also be done through context menu.

See Also

Other Resources
{Streamlined Cut, Copy and Paste Operation}
{Multiple Undo and Redo}
{Insert Link}
{Insert Image}
{Edit Image}
{Insert Media}
{Insert Symbol}
{Insert Table}
{Edit Cell Properties}
{Find}
{Replace}
{Word and Character Count}
{Html Inspector}
{Editing in html view}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Edit Cell Properties

Edit Cell Properties
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > Editing Architecture > Core Editing Features > Edit Cell Properties

Glossary Item Box

WebTextEditor provides more convenience way to edit table cell's properties through table designer's task pane. It allows you to customize the following cell settings:

  1. Horizontal Align
  2. Vertical Align
  3. Width
  4. Height
  5. Back color
  6. Font color
  7. No wrap

See Also

Other Resources
{Streamlined Cut, Copy and Paste Operation}
{Multiple Undo and Redo}
{Insert Link}
{Insert Image}
{Edit Image}
{Insert Media}
{Insert Symbol}
{Insert Table}
{Edit Table}
{Find}
{Replace}
{Word and Character Count}
{Html Inspector}
{Editing in html view}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Find

Find
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > Editing Architecture > Core Editing Features > Find

Glossary Item Box

WebTextEditor's unique search feature allows user to search in both design and html view. As in other commands, the Find command displays lightweight callout interface to provide a better searching experience. When a match is found, the text will be selected. Additional message about the search result will be displayed inside the callout interface.

See Also

Other Resources
{Streamlined Cut, Copy and Paste Operation}
{Multiple Undo and Redo}
{Insert Link}
{Insert Image}
{Edit Image}
{Insert Media}
{Insert Symbol}
Insert Table
{Edit Table}
{Edit Cell Properties}
{Replace}
{Word and Character Count}
{Html Inspector}
{Editing in html view}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


How-to: Enable Find and Replace

How-to: Enable Find and Replace
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > Editing Architecture > Core Editing Features > Find > How-to: Enable Find and Replace

Glossary Item Box

WebTextEditor introduces a more intuitive user experience with lightweight, callout user interface to perform Find and Replace.

This topic will show you how to enable Find and Replace.

To enable Find and Replace

  1. Right click on WebTextEditor control and choose Properties.
  2. Expand ToolBarSettings and set ToolBarMode to Rich.
  3. Run the project. Try to click Find or Replace command to experience this feature.

See Also

Tasks
Walkthrough Topics
How-to topics

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Replace

Replace
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > Editing Architecture > Core Editing Features > Replace

Glossary Item Box

Similar to Find feature, user can perform replace operation in both design view and html view. The replace function includes match case option, and also provides action to perform find, replace and replace all.

See Also

Other Resources
{Streamlined Cut, Copy and Paste Operation}
{Multiple Undo and Redo}
{Insert Link}
Insert Image
{Edit Image}
{Insert Media}
{Insert Symbol}
{Insert Table}
{Edit Table}
{Edit Cell Properties}
{Find}
{Word and Character Count}
Html Inspector
{Editing in html view}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Word and Character Count

Word and Character Count
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > Editing Architecture > Core Editing Features > Word and Character Count

Glossary Item Box

Word count is enabled by default, while character count is disabled. To enable both word and character count, just set ShowWordInformation and ShowCharacterInformation property to true.

Character count information and other details are available in the word information's tooltip, and thus making efficient use of screen real estate.

See Also

Other Resources
{Streamlined Cut, Copy and Paste Operation}
{Multiple Undo and Redo}
{Insert Link}
{Insert Image}
{Edit Image}
{Insert Media}
{Insert Symbol}
{Insert Table}
{Edit Table}
{Edit Cell Properties}
{Find}
{Replace}
{Html Inspector}
{Editing in html view}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


How-to: Display Word and Character count

How-to: Display Word and Character count
Send Feedback
Intersoft WebTextEditor > WebTextEditor > Editing Architecture > Core Editing Features > Word and Character Count > How-to: Display Word and Character count

Glossary Item Box

WebTextEditor provides word and character count feature. Word count information is located in editor's status bar area, while character count information is located in the tooltip of word count visual element.

This topic will show you how to display Word and Character count.

To display Word and Character count

  1. Right click on WebTextEditor control and choose Properties.
  2. Set ShowCharacterInformation and ShowWordInformation to True.
  3. Run the project.

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Html Inspector

Html Inspector
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > Editing Architecture > Core Editing Features > Html Inspector

Glossary Item Box

WebTextEditor provides a capability to recognize selected text's html tag and its complete path. This information is located in WebTextEditor's status bar area. User can enable this feature by simply setting EnableHTMLInspector property to true.

Each html tag that displayed in HTML Inspector is clickable. When clicked, WebTextEditor will create a selection based on the clicked html tag.

See Also

Other Resources
{Streamlined Cut, Copy and Paste Operation}
{Multiple Undo and Redo}
{Insert Link}
{Insert Image}
{Edit Image}
{Insert Media}
{Insert Symbol}
{Insert Table}
{Edit Table}
{Edit Cell Properties}
{Find}
{Replace}
{Word and Character Count}
{Editing in html view}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Editing in html view

Editing in html view
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > Editing Architecture > Core Editing Features > Editing in html view

Glossary Item Box

User can perform basic text editing operation such as bold, italic, insert image, etc with just a single click on html toolbar. This simplifies text editing operation in html view as the html command automatically insert and close the tags, minimizing required typing effort.

See Also

Other Resources
{Streamlined Cut, Copy and Paste Operation}
{Multiple Undo and Redo}
{Insert Link}
{Insert Image}
{Edit Image}
Insert Media
{Insert Symbol}
{Insert Table}
{Edit Table}
{Edit Cell Properties}
{Find}
{Replace}
{Word and Character Count}
{Html Inspector}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


XHTML 1.1 Compliance Output

XHTML 1.1 Compliance Output
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > Editing Architecture > XHTML 1.1 Compliance Output

Glossary Item Box

WebTextEditor produces only XHTML 1.1 compliance content regardless of browsers. This is made possible with WebTextEditor's editing architecture that seamlessly translates invalid tags and obsolete attributes into valid XHTML 1.1 markup.

WebTextEditor's XHTML engine is enabled by default and thus doesn't require additional configuration.

See Also

Other Resources
{Core Editing Features}
{Load custom CSS files}
Enable Context Menu
Enable Keyboard Support
{Auto Save}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Load custom CSS files

Load custom CSS files
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > Editing Architecture > Load custom CSS files

Glossary Item Box

WebTextEditor provides built-in professional styles for working with editor in design view. For instances, each paragraph and headings will be properly formatted to make the document more readable.

In addition, WebTextEditor also provides flexibility for developers to add their own CSS files into the editor by adding each CSS file in the CssFiles collection. See an example in the following.

<ISWebTextEditor:WebTextEditor ID="WebTextEditor1" runat="server" Height="500px" Width="700px">
   <RootTextEditor Content="<h2>Intersoft WebAqua . . .">
      <CssFiles>
         <ISWebTextEditor:WebTextEditorCssFile FilePath="Css/CustomEditorStyle.css" />
      </CssFiles>
   </RootTextEditor>
</ISWebTextEditor:WebTextEditor>

See Also

Other Resources
{Core Editing Features}
{XHTML 1.1 Compliance Output}
{Enable Keyboard Support}
{Enable Context Menu}
{Auto Save}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Enable Keyboard Support

Enable Keyboard Support
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > Editing Architecture > Enable Keyboard Support

Glossary Item Box

WebTextEditor is designed to provide intuitive editing environment and rich editing experience which produces consistent results on all browsers. Since each browser has their own keyboard shortcut and unfortunately some of the editing operations do not generate the same results, WebTextEditor addresses this limitation with its own keyboard support.

The keyboard support is enabled by default in WebTextEditor. To disable keyboard support, simply set EnableKeyboardSupport property to false.

In This Section

How-to: Enable and disable keyboard support

See Also

Other Resources
{Core Editing Features}
{XHTML 1.1 Compliance Output}
{Load custom CSS files}
{Enable Context Menu}
Auto Save

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


How-to: Enable and disable keyboard support

How-to: Enable and disable keyboard support
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > Editing Architecture > Enable Keyboard Support > How-to: Enable and disable keyboard support

Glossary Item Box

WebTextEditor provides a property to enable and disable keyboard support.

In this topic, you will learn how to enable keyboard support.

To enable and disable keyboard support

  1. Set EnableKeyboardSupport to True in order to enable keyboard support, and vice versa.
  2. When you enable keyboard support, you can use keyboard to make the highlighted word to be Bold or Italic or underline.

See Also

Other Resources
{Enable Keyboard Support}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Enable Context Menu

Enable Context Menu
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > Editing Architecture > Enable Context Menu

Glossary Item Box

Context menu gives users a more intuitive and natural way to work with editing and authoring tasks. Cut, copy, paste and table editing operation are available based on the selected object. Context menu is not enabled by default. User can enable context menu by setting EnableContextMenu property to true.

User can also customize context menu based on specific scenarios, please refers to customize context menu sample for further information.

See Also

Other Resources
{Core Editing Features}
{XHTML 1.1 Compliance Output}
{Load custom CSS files}
{Enable Keyboard Support}
{Auto Save}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Auto Save

Auto Save
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > Editing Architecture > Auto Save

Glossary Item Box

WebTextEditor introduces innovative feature which performs auto saving based on configurable interval. Auto save operation will be invoked through AJAX callback and will be performed only when the document is modified. Developers can write their own codes to handle the auto saving operation in Save server-side event. For instances, the content can be saved to a file, database, or other storage.

Here are the steps to implement auto save in WebTextEditor:

  1. Set EnableAutoSave property to true.
  2. Set AutoSaveInterval property, default is 15 minutes.
  3. Handle OnSave server side event.
  4. Implement save mechanism in OnSave server side event.

    C# Copy Image Copy Code
    protected void WebTextEditor1_Save(object sender, WebTextEditorSaveArgs e)
{
   if (e.SaveAction == SaveAction.AutoSave)
   {
      StreamWriter sw = new StreamWriter(HttpContext.Current.Server.MapPath("./SampleHtml/AutoSave.html"));
      sw.Write(e.Content);
      sw.Flush();
      sw.Close();
   }
}

The above sample will perform auto save every 15 minute and the content will be saved to file "AutoSave.html".

See Also

Other Resources
Core Editing Features
{XHTML 1.1 Compliance Output}
{Load custom CSS files}
{Enable Keyboard Support}
{Enable Context Menu}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Save to HTML

Save to HTML
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > Editing Architecture > Save to HTML

Glossary Item Box

WebTextEditor enables developers to easily save editor's content to HTML file through server side or client side method.

In This Section

Server side HTML

Client side HTML

See Also

Other Resources
{Core Editing Features}
{XHTML 1.1 Compliance Output}
{Load custom CSS files}
{Enable Keyboard Support}
{Enable Context Menu}
{Auto Save}
{Load from HTML}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Server side HTML

Server side HTML
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > Editing Architecture > Save to HTML > Server side HTML

Glossary Item Box

In the server side, WebTextEditor provides SaveContentToFile method which includes a handful of save options. The save options are provided to handle numerous common scenarios in saving operation.

By default, WebTextEditor will save only editor's content to the file. To save the content with full html declaration, please specify saveFullHTML parameter to true. Optionally, you can also specify the HTML document type declaration (i.e, XHTML DocType) by specifying the docType parameter. For further information, please refer to the following parameter information.

The following table lists the parameters of SaveContentToFile method:

Parameter name | Data Type | Description
filename | String | Specifies the complete file path and name of the saved file
sectionName | String | Determines which section's content of WebTextEditor to be saved. This parameter is used in multiple sections mode.
docType | WebTextEditorHtmlDocType | Specifies whether the content of WebTextEditor should be saved with HTML or XHTML doctype. If docType is specified, WebTextEditor will automatically add the selected doctype declaration to the saved file.
title | String | Determines the title of the saved file. This parameter can be used if docType is specified.
saveFullHTML | Boolean | Determines whether WebTextEditor should produce complete HTML content, which includes valid doctype declaration, opening <html>, and <body> and so on.

See Also

Other Resources
Client side HTML

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Client side HTML

Client side HTML
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > Editing Architecture > Save to HTML > Client side HTML

Glossary Item Box

In client side, WebTextEditor provides SaveContent method which has a parameter to invoke save operation. The parameter is sectionName(string).

Note that SaveContent does not save the content to a file in the client-side due to security permission. Instead, it invokes Save server-side event through FlyPostback (AJAX) where developers can implement their own saving logic in the server-side. It's essential to implement Save server-side event properly as the event is fired consistently in other scenarios, such as auto save, server-side direct save method call, and more.

The sectionName parameter of SaveContent method is applicable only in multiple sections mode. To save all sections, simply specify the sectionName parameter to All value.

See Also

Other Resources
{Server side HTML}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Load from HTML

Load from HTML
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > Editing Architecture > Load from HTML

Glossary Item Box

WebTextEditor supports loading content from an HTML file in the server-side through LoadContentFromFile method.
The LoadContentFromFile method provides several options such as listed in the table below.

Parameter name | Data Type | Description
filename | String | The HTML file to be loaded
sectionName | String | Determines the WebTextEditor's section which the content will be loaded to. This parameter is used in multiple sections mode.
isCompleteHTML | Boolean | Determines whether the loaded file is a complete valid HTML file.

See Also

Other Resources
{Core Editing Features}
{XHTML 1.1 Compliance Output}
{Load custom CSS files}
{Enable Keyboard Support}
{Enable Context Menu}
{Auto Save}
{Save to HTML}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


How-to: Save and Load Content

How-to: Save and Load Content
Send Feedback
Intersoft WebTextEditor > WebTextEditor > Editing Architecture > How-to: Save and Load Content

Glossary Item Box

You can save and load content to HTML/Database.

In this topic, you will learn how to save and load content.

To save and load content to HTML

  1. To save content to file, use the provided SaveContentToFile server side method. There are 3 parameter for this method "fileName", "sectionName" and "docType". "sectionName" parameter is used to save the content from a specific editor section, where as "docType" is used to save the editor's content including html declaration (by default there is no html declaration). There are 2 options for "DocType", HTMLDocType and XHTMLDocType.

  2. Place the following code in button click event to save content to HTML file.

    C# Copy Image Copy Code
    protected void Button1_Click(object sender, EventArgs e)
{
   WebTextEditor1.SaveContentToFile(Server.MapPath("./SampleHtml/SavedFile.html"), WebTextEditorHtmlDocType.XHTMLDocType, "Title Name", true);
}

  3. To load content from file, please use LoadContentFromFile server side method. There are several parameters provided in this method such as "fileName", "sectionName" , "isCompleteHTML". "sectionName" parameter is used to load from file to specific section of editor (multiple section), "isCompleteHTML" parameter should be set to true if loaded file is a full/complete html file.

  4. Place the following code in button click event to load content from HTML file.
    C# Copy Image Copy Code
    protected void Button1_Click(object sender, EventArgs e)
{
   WebTextEditor1.LoadContentFromFile(Server.MapPath("./SampleHtml/Product Overview.html"), true);
}

  5. Run the project.

To save and load content to Database

  1. Bind Editor(Editor.mdb) database to AccessDataSource control.
  2. Place the following code in button click event to save content to database.
    C# Copy Image Copy Code
    protected void Button1_Click(object sender, EventArgs e)
{
   AccessDataSource1.UpdateParameters["ID"].DefaultValue = "1";
   AccessDataSource1.UpdateParameters["EditorName"].DefaultValue = "Budianto";
   AccessDataSource1.UpdateParameters["ScriptInformation"].DefaultValue = TextEditor1.RootTextEditor.Content;
   AccessDataSource1.Update();
}

  3. Place the following code in button click event to load content from database.
    C# Copy Image Copy Code
    protected void Button1_Click(object sender, EventArgs e)
{
   DataView data = (DataView)AccessDataSource1.Select(DataSourceSelectArguments.Empty);
   TextEditor1.RootTextEditor.Content = data.Table.Rows[0]["ScriptInformation"].ToString();
}

  4. Run the project.

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


How-to: Save Content in FlyPostBack

How-to: Save Content in FlyPostBack
Send Feedback
Intersoft WebTextEditor > WebTextEditor > Editing Architecture > How-to: Save Content in FlyPostBack

Glossary Item Box

WebTextEditor can perform save operation programmatically from client-side. When client-side API is used, WebTextEditor used FlyPostBack (AJAX) request to perform the save operation without the needs for page refresh.

This topic will show you how to save content in FlyPostBack.

To save content in FlyPostBack

  1. Create SaveContent() method in client-side to invoke FlyPostBack request.
    JavaScript Copy Image Copy Code
    function SaveContent()
{
   var rte = ISGetObject("WebTextEditor1");
   rte.SaveContent();
}

  2. Place the following code in WebTextEditor's Save server-side event to save content.
    C# Copy Image Copy Code
    protected void WebTextEditor1_Save(object sender, ISNet.WebUI.WebTextEditor.WebTextEditorSaveArgs e)
{
   StreamWriter sw = new StreamWriter(Server.MapPath("./SampleHtml/SaveContentFlyPostBack.html"), false, System.Text.Encoding.Default);
   sw.Write(e.Content);
   sw.Flush();
   sw.Close();
}

  3. Invoke SaveContent() using HTML button.

    <input id="Button1" type="button" value="Save Content" onclick="SaveContent()" />

  4. Run the project.

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Sections

Sections
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > Sections

Glossary Item Box

Unique to WebTextEditor is the capability to have more than one section in a single editor. This time-saving feature creates new possibilities and richer editing experiences that are previously difficult to achieve.

By default, WebTextEditor uses single section instead of multiple sections. Single section settings can be found in RootTextEditor property while multiple sections settings can be found in each TextEditorSection object.

To enable multiple sections, simple add the TextEditorSection object into TextEditorSections collection. When multiple sections are activated, the single section configuration such as in RootTextEditor will be automatically ignored.
There are several properties inside WebTextEditorSection such as:
  • Content
    Gets or sets the section's content.

  • Cssfiles
    This is a collection property; user can specify the custom CSS files to be loaded into the editor.
    Please refer to Load custom editor CSS files for further information.

  • Height
    Specify the minimum height of section. This property is applicable only in multiple sections. Leave it empty for single section.

  • Name
    Specify the name of section. This property is applicable only in multiple sections. Leave it empty for single section.

  • ReadOnly
    Specify whether the section should be read only.

  • Text
    Specify the caption text of the section. This property is applicable only in multiple sections. Leave it empty for single section.

  • WatermarkSettings
    This is a property that handle watermark of sections.
    • EnableWatermark
      Specify whether watermark should be enabled or not. By default, watermark is disabled.

    • WatermarkText
      Specify the watermark text for the section.

In This Section

Watermark

Read Only

See Also

Other Resources
WebTextEditor Overview
Core Editing Features
{Text Settings}
{Sleek Design and Elegant User Interface}
{Fluid, Smart ToolBar}
View
{Innovative Task Pane}
{Enable Context Menu}
{Integration with FileUploader}
{Integration with WebSpellChecker}
{Data Binding}
{Mail Merge}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Watermark

Watermark
Send Feedback
Intersoft WebTextEditor > WebTextEditor > Sections > Watermark

Glossary Item Box

With watermark feature, WebTextEditor can display a default text before any user interaction occurs on an empty editor. The text can be customized for more user-friendly message such as "Type here for subject".

Watermark can be customized in WatermarkSettings property in WebTextEditorSection object.

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


How-to: Enable Watermark

How-to: Enable Watermark
Send Feedback
Intersoft WebTextEditor > WebTextEditor > Sections > Watermark > How-to: Enable Watermark

Glossary Item Box

Watermark provides an intuitive way to display initial messages when the WebTextEditor content is empty.

This topic will show you how to enable Watermark.

To enable Watermark

  1. Right click on WebTextEditor control and choose Properties.
  2. Expand RootTextEditor >> WaterMarkSettings.
  3. Set EnableWatermark to True and Watermark to "Please click here to type...".
  4. Run the project.

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Read Only

Read Only
Send Feedback
Intersoft WebTextEditor > WebTextEditor > Sections > Read Only

Glossary Item Box

WebTextEditor also can be set to non editable (read-only mode). Simply set the section's ReadOnly property to true from server-side.

Read-only setting can also be set from client side; user can use SetReadOnly client side method. There are two parameters for this method: isReadOnly(boolean) and editorSectionName(string).

isReadOnly parameter determines whether the section should be read-only or not, while editorSectionName determines the section name when WebTextEditor is operating in multiple section. Otherwise, this parameter should be left empty.

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


How-to: Enable Multiple Sections

How-to: Enable Multiple Sections
Send Feedback
Intersoft WebTextEditor > WebTextEditor > Sections > How-to: Enable Multiple Sections

Glossary Item Box

Multiple Sections is a unique feature of WebTextEditor that enables multiple editable regions in a single instance.

This topic will show you how to enable Multiple Sections.

To enable Multiple Sections

  1. Right click on WebTextEditor control and choose Properties.
  2. Go to TextEditorSections and click the collection button.
  3. Add 1 WebTextEditorSection. Set Name to Summary and Content to "WebTextEditor is one of the latest components developed by Intersoft Solutions".
  4. Add another WebTextEditorSection. Set Name to Description and Content to "WebTextEditor is the industry's first text editor that integrates intuitive writing tools, inline spelling checker, and sophisticated uploading capability in a single interface".
  5. Run the project.

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Text Settings

Text Settings
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > Text Settings

Glossary Item Box

All textual settings in WebTextEditor are customizable and can be found in TextSettings property.
The following table lists all the customizable text settings:

Category | Text Setting Key | Description | Default Text Setting Value
Callout | CallOutButtonApplyText | Specifies the text of Apply button in callout. | Apply
 | CallOutButtonCancelText | Specifies the text of Cancel button in callout. | Cancel
 | CallOutButtonFindText | Specifies the text of Find button in callout. | Find
 | CallOutButtonInsertFromWebText | Specifies the text of Insert Media button in callout. | Insert Media
 | CallOutButtonInsertLinkText | Specifies the text of Insert Link button in callout. | Insert Link
 | CallOutButtonPasteText | Specifies the text of Paste button in callout. | Paste
 | CallOutButtonReplaceAllText | Specifies the text of Replace All button in callout. | Replace All
 | CallOutButtonReplaceText | Specifies the text of Replace button in callout. | Replace
 | CallOutCheckBoxMatchCaseText | Specifies the text of Match Case checkbox in callout. | Match Case
 | CallOutFindText | Specifies the text of Find field name in callout. | Find:
 | CallOutHyperlinkLinkText | Specifies the text of Link field name in callout. | Link:
 | CallOutHyperlinkTargetText | Specifies the text of Target field name in callout. | Target:
 | CallOutHyperlinkText | Specifies the text of Text field name in callout. | Text:
 | CallOutMediaAlignmentText | Specifies the text of Caption Alignment field name in callout. | Alignment:
 | CallOutMediaCaptionText | Specifies the text of Media Caption field name in callout. | Media Caption:
 | CallOutMediaLinkURLText | Specifies the text of Link URL field name in callout. | Link URL:
 | CallOutMediaSizeText | Specifies the text of Size field name in callout. | Size:
 | CallOutMediaTitleText | Specifies the text of Media Title field name in callout. | Media Title:
 | CallOutMediaTypeText | Specifies the text of Media Type field name in callout. | Media Type:
 | CallOutMediaURLText | Specifies the text of Media URL field name in callout. | Media URL:
 | CallOutMediaUseFrameText | Specifies the text of Use Frame checkbox in callout. | Use Frame
 | CallOutPasteTitleText | Specifies the text of Paste Information title in callout. | Paste Information
 | CallOutReplaceText | Specifies the text of Replace field name in callout. | Replace with:
Context menu | CopyText | Specifies the text of Copy menu item in context menu. | Copy
 | CutText | Specifies the text of Cut menu item in context menu. | Cut
 | PasteText | Specifies the text of Paste menu item in context menu. | Paste
Footers | DesignViewText | Specifies the text of Design view tab in footer row. | Design
 | HtmlViewText | Specifies the text of HTML view tab in footer row. | HTML
 | SplitViewText | Specifies the text of Split view tab in footer row. | Split
 | PreviewText | Specifies the text of Preview view tab in footer row. | Preview
 | ReadyText | Specifies the text displayed in status when the editor is in Ready state. | Ready.
 | CharacterInformationText | Specifies the text of character information in tooltip. | Character:{0}
 | WordsInformationText | Specifies the text of word information in footer row. | Words:{0}
 | SaveStatus | Specifies the text when auto save has been performed. | Saved at{0:g}.
TaskPane | TaskPaneHTMLViewText | Specifies the text of pane content when viewing in HTML view. | No action is available in this view.
Media Gallery | NoResultFoundText | Specifies the text when no result is found when searching the media in Media Gallery pane. | No results found.
 | SearchInText | Specifies the text of Search In field name in Media Gallery pane. | Search in:
 | ResultTypeText | Specifies the text of Result Type field name in Media Gallery pane. | Results should be:
 | SearchingMediaText | Specifies the text displayed in status bar when media search action is being performed. | Searching medias...
Table Designer | SplitCellHorizontal | Specifies the text of Split Cell Horizontal item in Table Designer pane and context menu. | Split Cells Horizontal
 | SplitCellVertical | Specifies the text of Split Cell Vertical item in Table Designer pane and context menu. | Split Cells Vertical
 | TableAlignmentText | Specifies the text of Table Alignment field name in Table Designer pane. | Alignment:
 | TableBackColorText | Specifies the text of Table Back Color field name in Table Designer pane. | Back color:
 | TableBorderColorText | Specifies the text of Table Border Color field name in Table Designer pane. | Border color:
 | TableBorderWidthText | Specifies the text of Table Border Width field name in Table Designer pane. | Border width:
 | TableCaptionText | Specifies the text of Table Caption field name in Table Designer pane. | Caption:
 | TableCellActionsText | Specifies the text of Cell Actions title in Table Designer pane. | Cell Actions
 | TableCellPaddingText | Specifies the text of Cell Padding field name in Table Designer pane. | Cellpadding:
 | TableCellPropertiesText | Specifies the text of Cell Properties title in Table Designer pane. | Cell Properties
 | TableCellSpacingText | Specifies the text of Cell Spacing field name in Table Designer pane. | Cellspacing:
 | TableColumnsText | Specifies the text of Columns field name in Table Designer pane. | Columns:
 | TableCustomText | Specifies the text of Custom radio button in Table Designer pane. | Custom
 | TableDesignerText | Specifies the text of Table Designer title. | Table Designer
 | TableFontColorText | Specifies the text of Table Font Color field name in Table Designer pane. | Font color:
 | TableHeightText | Specifies the text of Table Height field name in Table Designer pane. | Height:
 | TableHorizontalAlignText | Specifies the text of Table Horizontal Align field name in Table Designer pane. | Horizontal align:
 | TableNoWrapText | Specifies the text of No Wrap checkbox in Table Designer pane. | No wrap
 | TablePropertiesText | Specifies the text of Table Properties title in Table Designer pane. | Table Properties
 | TableRowsText | Specifies the text of Rows field name in Table Designer pane. | Rows:
 | TableSummaryText | Specifies the text of Summary field name in Table Designer pane. | Summary:
 | TableTemplateText | Specifies the text of Template radio button in Table Designer pane. | Template
 | TableVerticalAlignText | Specifies the text of Vertical Align field name in Table Designer pane. | Vertical Align:
 | TableWidthText | Specifies the text of Table Width field name in Table Designer pane. | Width:
 | EditTableLinkText | Specifies the text of Edit Table command in Table Designer toolbar. | Edit Table
 | DeleteColumnText | Specifies the text of Delete Column item in Table Designer pane and context menu. | Delete Columns
 | DeleteRowText | Specifies the text of Delete Row item in Table Designer pane and context menu. | Delete Rows
 | InsertLeftColumnsText | Specifies the text of Insert Columns to the Left item in Table Designer pane and context menu. | Insert Columns to the Left
 | InsertRightColumnsText | Specifies the text of Insert Columns to the Right item in Table Designer pane and context menu. | Insert Columns to the Right
 | InsertRowsAboveText | Specifies the text of Insert Rows Above item in Table Designer pane and context menu. | Insert Rows Above
 | InsertRowsBelowText | Specifies the text of Insert Rows Below item in Table Designer pane and context menu. | Insert Rows Below
 | InsertTableText | Specifies the text of Insert Table command in Table Designer toolbar. | Insert Table
 | MergeCellDown | Specifies the text of Merge Cell Down item in Table Designer pane and context menu. | Merge Cells Down
 | MergeCellRight | Specifies the text of Merge Cell Right item in Table Designer pane and context menu. | Merge Cells Right
Form Control | InsertButtonText | Specifies the text of Insert Button item in Form Control pane. | Insert Button
 | InsertFieldsetText | Specifies the text of Insert Fieldset item in Form Control pane. | Insert Fieldset
 | InsertHorizontalRuleText | Specifies the text of Insert Horizontal Rule item in Form Control pane. | Insert Horizontal Rule
 | InsertIFrameText | Specifies the text of Insert IFrame item in Form Control pane. | Insert IFrame
 | InsertInputButtonText | Specifies the text of Insert Input Button item in Form Control pane. | Insert Input Button
 | InsertInputCheckBoxText | Specifies the text of Insert Input CheckBox item in Form Control pane. | Insert Input CheckBox
 | InsertInputFileUploadText | Specifies the text of Insert Input File Upload item in Form Control pane. | Insert Input File Upload
 | InsertInputHiddenText | Specifies the text of Insert Input Hidden item in Form Control pane. | Insert Input Hidden
 | InsertInputPasswordText | Specifies the text of Insert Password item in Form Control pane. | Insert Input Password
 | InsertInputRadioText | Specifies the text of Insert Radio item in Form Control pane. | Insert Input Radio
 | InsertInputResetText | Specifies the text of Insert Reset item in Form Control pane. | Insert Input Reset
 | InsertInputSubmitText | Specifies the text of Insert Submit item in Form Control pane. | Insert Input Submit
 | InsertInputText | Specifies the text of Insert Text item in Form Control pane. | Insert Input Text
 | InsertMarqueeText | Specifies the text of Insert Marquee item in Form Control pane. | Insert Marquee
 | InsertSelectDropdownText | Specifies the text of Insert Select Dropdown item in Form Control pane. | Insert Select Dropdown
 | InsertSelectListboxText | Specifies the text of Insert Select Listbox item in Form Control pane. | Insert Select Listbox
 | InsertTextAreaText | Specifies the text of Insert TextArea item in Form Control pane. | Insert TextArea
Mail Merge | PreviewMailMergeText | Specifies the text that will be displayed in status bar when the preview data is being fetched. | Preview Mail Merge
 | SendMailMergeText | Specifies the text that will be displayed in status bar when the emails are being sent. | Sending mail
 | FailedSendMailText | Specifies the text that will be displayed in status bar when the emails failed to be sent. | Failed sending to {0} recipient(s)
 | SuccessSendMailText | Specifies the text that will be displayed in status bar when the emails have been successfully sent. | Send mail completed.

See Also

Other Resources
WebTextEditor Overview
Core Editing Features
{Sections}
{Sleek Design and Elegant User Interface}
{Fluid, Smart ToolBar}
{View}
{Innovative Task Pane}
{Enable Context Menu}
{Integration with FileUploader}
{Integration with WebSpellChecker}
{Data Binding}
{Mail Merge}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Layout

Layout
Send Feedback
Intersoft WebTextEditor > WebTextEditor > Layout

Glossary Item Box

This section contains information about User Interface element ni WebTextEditor.

In This Section

Sleek Design and Elegant User Interface

Fluid and Fixed Layout Support in Various Browsers

Lightweight UI Elements

Flexible Size in Limited Space

Professional Built-in Themes

Allow Style Merging

Load Custom CSS File

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Sleek Design and Elegant User Interface

Sleek Design and Elegant User Interface
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > Layout > Sleek Design and Elegant User Interface

Glossary Item Box

All elements in WebTextEditor have been carefully designed to be lightweight and minimalist style, yet providing powerful editing experience. The main header contains editor toolbar, which can seamlessly adjust itself to the container size and easily hidden when user needs more space for editing. The main footer can be used for view switching, navigating through layout structure, and status bar.

Most text editor components in the market still used old-fashioned dialog box interface for user input, such as input for images, hyperlink, tables, etc - which is less intuitive because of the "blocking" nature of the dialog box interface. WebTextEditor advances editing experience with a better, more intuitive approach. Called "block-less" user interface concept, WebTextEditor supports modern, lightweight callout and task pane for user interactions, which ultimately provides user with more intuitive way to work and interact with input fields and objects.

See Also

Other Resources
{Fluid and Fixed Layout Support in Various Browsers}
{Lightweight UI Elements}
{Flexible Size in Limited Space}
{Professional Built-in Themes}
{Allow Style Merging}
{Load Custom CSS File}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Fluid and Fixed Layout Support in Various Browsers

Fluid and Fixed Layout Support in Various Browsers
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > Layout > Fluid and Fixed Layout Support in Various Browsers

Glossary Item Box

WebTextEditor's layout and design have been carefully designed to support XHTML and HTML DOCTYPE and will render correctly in top browsers available in the market: IE 7, IE 8, Firefox Mozilla 3.0, Opera 9.5+, Safari 4 Beta, and Google Chrome.

By default, WebTextEditor is set to a fixed 500x700px size. When its size is set to percentage width and height, the size of WebTextEditor will be adjusted to its container size. When the container of WebTextEditor is resized, the elements of WebTextEditor will be adjusted as well. This behavior has been extensively tested to provide pixel perfect rendering in top browsers.

See Also

Other Resources
{Sleek Design and Elegant User Interface}
{Lightweight UI Elements}
{Flexible Size in Limited Space}
{Professional Built-in Themes}
{Allow Style Merging}
{Load Custom CSS File}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Lightweight UI Elements

Lightweight UI Elements
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > Layout > Lightweight UI Elements

Glossary Item Box

A number of controls, such as toolbar, combo, color picker, table pop up, symbol, and many more are used in WebTextEditor. These controls are developed as client controls, thus providing very lightweight elements used in WebTextEditor. As client controls, they also provide high performance and responsive user interface while significantly minimizing server-side page output.

See Also

Other Resources
{Sleek Design and Elegant User Interface}
{Fluid and Fixed Layout Support in Various Browsers}
{Flexible Size in Limited Space}
{Professional Built-in Themes}
{Allow Style Merging}
{Load Custom CSS File}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Flexible Size in Limited Space

Flexible Size in Limited Space
Send Feedback
Intersoft WebTextEditor > WebTextEditor > Layout > Flexible Size in Limited Space

Glossary Item Box

In certain scenarios, page might contain complex layout, leaving only a limited space where WebTextEditor can be placed. In this case, there are several options that can be enabled to overcome this limitation:

  • Hide ToolBar using header context menu
  • Allow Resize
  • Full Screen
  • Professional Built-in Themes
  • Allow Style Merging
  • Load Custom CSS File

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Hide ToolBar using header context menu

Hide ToolBar using header context menu
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > Layout > Flexible Size in Limited Space > Hide ToolBar using header context menu

Glossary Item Box

Context menu items in header area represent each toolbar available in WebTextEditor. The toolbar can be easily hidden by un-toggling the related menu item. When all toolbars are hidden, the header area will be compressed to 5px height, thus providing a larger editing area for user. The toolbar can easily be displayed afterwards, by toggling the related menu item.

See Also

Other Resources
{Allow Resize}
{Full Screen}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Allow Resize

Allow Resize
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > Layout > Flexible Size in Limited Space > Allow Resize

Glossary Item Box

WebTextEditor can be resized to a larger or smaller size by using resize element in main footer area. To enable this feature, simply set AllowResize property to one of the following value:

  • Yes
    Enable WebTextEditor to be resized horizontally and vertically

  • VerticalOnly
    Enable WebTextEditor to be resized vertically

  • HorizontalOnly
    Enable WebTextE ditor to be resized horizontally

  • No (default value)
    Disable resize functionality in WebTextEditor

As shown below, a gray area will be displayed above WebTextEditor when it's being resized. The gray area represents the final size of WebTextEditor after resize action is performed.

Related to AllowResize feature, maximum and minimum size can be set to WebTextEditor, using MaximumSize and MinimumSize properties. When both properties are set, WebTextEditor can only be enlarged until the value of maximum size and reduced to the value of minimum size.

For example: when MaximumSize property is set to 1024, 768, WebTextEditor can only be enlarged until 1024px width and 678px height. When MinimumSize is set to 500, 400; WebTextEditor can only be reduced until 500px width and 400px height. When both properties are set to -1, -1, there is no size limitation when WebTextEditor is resized.

In This Section

How-to: Allow Resize in WebTextEditor

See Also

Other Resources
{Full Screen}
{Hide ToolBar using header context menu}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


How-to: Allow Resize in WebTextEditor

How-to: Allow Resize in WebTextEditor
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > Layout > Flexible Size in Limited Space > Allow Resize > How-to: Allow Resize in WebTextEditor

Glossary Item Box

WebTextEditor provides a property to allow resize in WebTextEditor.

In this topic, you will learn how to allow resize.

To allow resize in WebTextEditor

  1. Set AllowResize property to Yes.
  2. When enabled, user can resize the editor by clicking the resizer element at the right-most part of the footer element.
  3. There are 3 value option in AllowResize property.
    • Yes: when this value is chosen, user can resize WebTextEditor vertically and horizontally.
    • HorizontalOnly: when this value is chosen, user can only resize WebTextEditor horizontally.
    • VerticalOnly: when this value is chosen, user can only resize WebTextEditor vertically.

See Also

Other Resources
{Allow Resize}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Full Screen

Full Screen
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > Layout > Flexible Size in Limited Space > Full Screen

Glossary Item Box

In certain scenarios where the layout is fixed, resize action might cause inconsistency in the page structured layout. In this case, Full Screen feature provides another option to view WebTextEditor in its maximum size, without modifying the structure of the other elements in the page.

When Full Screen is activated, WebTextEditor will float above the other elements in the page and its size will be maximized according to the size of the document, providing very maximum editing area for users without changing the layout structure of the page. When user has finished editing, he can deactivate Full Screen mode and WebTextEditor will be placed to its original container using its original size.

To activate Full Screen mode, simply click FullScreen command in the toolbar. By default, this command is added automatically to toolbar when toolbar mode is not Minimal; however it can be disabled by setting EnableFullScreen property to false.

In This Section

How-to: Enable Full Screen in WebTextEditor

See Also

Other Resources
{Hide ToolBar using header context menu}
{Allow Resize}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


How-to: Enable Full Screen in WebTextEditor

How-to: Enable Full Screen in WebTextEditor
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > Layout > Flexible Size in Limited Space > Full Screen > How-to: Enable Full Screen in WebTextEditor

Glossary Item Box

WebTextEditor provides a property to enable full screen in WebTextEditor.

In this topic, you will learn how to enable full screen.

To enable Full Screen in WebTextEditor

  1. Set EnableFullScreen property to Yes.
  2. Simply click Full Screen command in the toolbar.

See Also

Other Resources
{Full Screen}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Professional Built-in Themes

Professional Built-in Themes
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > Layout > Professional Built-in Themes

Glossary Item Box

WebTextEditor comes with three built-in themes: Intersoft style, Elegant Blue style, and Elegant Black style. All elements in WebTextEditor besides callout and floating toolbar will be adjusted to use the selected style mode.

Elegant Black style

Elegant Blue Style

Intersoft Style

By default, Intersoft style will be used as default style mode. To select a different style, simply change DefaultStyleMode property.

See Also

Other Resources
{Sleek Design and Elegant User Interface}
{Fluid and Fixed Layout Support in Various Browsers}
{Lightweight UI Elements}
{Flexible Size in Limited Space}
{Allow Style Merging}
{Load Custom CSS File}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Allow Style Merging

Allow Style Merging
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > Layout > Allow Style Merging

Glossary Item Box

When using default style mode, all styles in the control will use pre-defined styles according to the selected theme. In previous release, when a style is modified, the default style for that element will be removed and replaced with the custom style. For example: when BackColor=Red is specified in FrameStyle, all the other default style, such as font style, border style, and other styles, specified for FrameStyle will be removed. With this limitation, developer is forced to redefine the removed default style when he wants to modify a style.

Using Allow Style Merging feature available in WebUI Framework, custom style can be added without losing the original default style. So in the above example, the font style, border style and the other styles specified in FrameStyle will be persisted when BackColor=Red is added. Both style definitions will be combined in FrameStyle.

To disable this feature, simply change AllowStyleMerging property to False.

In This Section

How-to: Allow Style Merging in WebTextEditor

See Also

Other Resources
{Sleek Design and Elegant User Interface}
{Fluid and Fixed Layout Support in Various Browsers}
{Lightweight UI Elements}
{Flexible Size in Limited Space}
{Professional Built-in Themes}
{Load Custom CSS File}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


How-to: Allow Style Merging in WebTextEditor

How-to: Allow Style Merging in WebTextEditor
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > Layout > Allow Style Merging > How-to: Allow Style Merging in WebTextEditor

Glossary Item Box

WebTextEditor provides a property to allow style merging in WebTextEditor.

In this topic, you will learn how to allow style merging.

To allow style merging in WebTextEditor

  1. Set AllowDefaultStyleMerging property to True.
  2. In this sample, custom style is added to ViewTabStyle-Over. Try to hover HTML and Split view tabs and the text will use Red font color.

See Also

Other Resources
Allow Style Merging

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Load Custom CSS File

Load Custom CSS File
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > Layout > Load Custom CSS File

Glossary Item Box

WebTextEditor provides built-in professional styles when working with editor in Design view. For example, tables and image frame will be properly formatted to make the document more readable.

In addition, WebTextEditor also provides flexibility to add custom CSS files to WebTextEditor. The CSS files collection can be added in RootTextEditor >> CssFiles property, however when multiple section is enabled, the CSS files collection needs to be added in each section using [each WebTextEditorSection] >> CssFiles property.

In CSS file object, the following properties needs to be specified:

  • FilePath
    Specifies the path of CSS file.

  • Type
    Specifies the type of CSS file.
    There are two types supported in WebTextEditor: DesignerStyleSheet and RuntimeStyleSheet. Designer-typed CSS files will be loaded when editing the content in Design view, while runtime-typed CSS files will be used when previewing or printing the content.

When WebTextEditor is used in blog application or other content management application, usually there are certain format and styles that need to be applied for consistency purpose. Designer-typed styles used in WebTextEditor will not be used when the content is saved, previewed, and printing, making it suitable for this scenario. Instead, the runtime-typed styles will be automatically applied to the content.

Designer-typed style | Runtime-typed style
Designer-type style used in Design view | Runtime-typed style used in Preview

In This Section

How-to: Load Custom CSS File in WebTextEditor

See Also

Other Resources
{Sleek Design and Elegant User Interface}
{Fluid and Fixed Layout Support in Various Browsers}
{Lightweight UI Elements}
{Flexible Size in Limited Space}
{Professional Built-in Themes}
{Allow Style Merging}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


How-to: Load Custom CSS File in WebTextEditor

How-to: Load Custom CSS File in WebTextEditor
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > Layout > Load Custom CSS File > How-to: Load Custom CSS File in WebTextEditor

Glossary Item Box

WebTextEditor provides a property to load custom css file in WebTextEditor.

In this topic, you will learn how to load custom css file.

To load custom css file in WebTextEditor

  1. Load CssFiles property in RootTextEditor for single section or TextEditorSections for multiple selection.

  2. In this sample, notice that every "<h2>" tag will use "font-family: Trebuchet MS" and "color: darkRed". This is made possible with the custom stylesheet "EditorStyle.css" added to the editor.

See Also

Other Resources
{Load Custom CSS File}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


ToolBar

ToolBar
Send Feedback
Intersoft WebTextEditor > WebTextEditor > ToolBar

Glossary Item Box

This section contains information on how to use and customize ToolBar.

In This Section

Fluid, Smart ToolBar

Intuitive Word 2007-style Floating ToolBar

ToolBar Mode

ToolBar Settings

Custom ToolBar

XML Format for Custom ToolBar

Customize toolbar programmatically from server-side

Perform Document Properties Actions

HTML ToolBar

View-based ToolBar

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Fluid, Smart ToolBar

Fluid, Smart ToolBar
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > ToolBar > Fluid, Smart ToolBar

Glossary Item Box

One of the unique features of WebTextEditor's toolbar is its ability to detect whether or not the container size is sufficient to display all its commands. When the container size is not sufficient, it can adjust itself to hide the possible commands and placed the hidden commands in MoreMenu container. When the browser is resized and the container size is enlarged, it will detect that more area is now available and show the hidden commands.

In WebTextEditor, multiple toolbars can be added to main toolbar area. In Standard toolbar mode, Formatting and Standard toolbars are added to header area of WebTextEditor. With its fluid behavior, toolbar is able to detect whether or not its container can display multiple toolbars in a row. If the container size is not sufficient to display multiple toolbars in a row, it will be shifted to the next row, and so on.

When the container is enlarged to a sufficient size, toolbar will automatically adjust itself and multiple toolbars will be displayed in a row.

See Also

Other Resources
{Intuitive Word 2007-style Floating ToolBar}
{ToolBar Mode}
{ToolBar Settings}
{Custom ToolBar}
{XML Format for Custom ToolBar}
{Customize toolbar programmatically from server-side}
{Perform Document Properties Actions}
{HTML ToolBar}
{View-based ToolBar}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Intuitive Word 2007-style Floating ToolBar

Intuitive Word 2007-style Floating ToolBar
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > ToolBar > Intuitive Word 2007-style Floating ToolBar

Glossary Item Box

To provide a more intuitive editing experience, floating toolbar -- similar to Mini toolbar provided in Microsoft Office Word 2007 -- is natively supported in WebTextEditor. This feature can be enabled by setting ToolBarSettings >> EnableFloatingToolBar property to true.

When enabled, user can select text and floating toolbar will be displayed in half opacity near the latest position of cursor. Floating toolbar helps user work with basic formatting functionalities without have to navigating to the main toolbar area.

Floating toolbar applies independent styles that do not depend on selected theme. It will gradually fade out when user moves further from it and it will be hidden when user hovers on main toolbar area.

Floating toolbar will be displayed when a text is selected via mouse. It will not be displayed when user selects a text using keyboard navigation.

See Also

Other Resources
{Fluid, Smart ToolBar}
{ToolBar Mode}
{ToolBar Settings}
{Custom ToolBar}
{XML Format for Custom ToolBar}
{Customize toolbar programmatically from server-side}
{Perform Document Properties Actions}
{HTML ToolBar}
{View-based ToolBar}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


ToolBar Mode

ToolBar Mode
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > ToolBar > ToolBar Mode

Glossary Item Box

There are six toolbar modes available in WebTextEditor:

  • None.
    When this mode is selected, toolbar will be disabled. Moreover, when floating toolbar is also disabled, toolbar script will not be loaded.

  • Minimal. In this mode, Formatting and Standard toolbars are added. Formatting toolbar will include the following commands: Bold, Italic, Underline, Font Name, Font Color, Align Left, Align Center, Align Right, Bullets, and Numbering. Standard toolbar will include the following commands: Insert from Web and Media Gallery.

  • Standard. This mode is the default value for ToolBarMode property. In this mode, Formatting toolbar will include the following commands: Bold, Italic, Underline, Font Name, Font Size, Font Color, Text Highlight Color, Align Text Left, Align Text Center, Align Text Right, Align Text Justify, Bullets, Numbering, Decrease Indent, Increase Indent, Clear Formatting, and Quote. Standard toolbar will include the following commands: Undo, Redo, Hyperlink, Remove Hyperlink, Insert from Web, Media Gallery, and Full Screen.

  • Rich. In this mode, Formatting toolbar will include the following commands: Bold, Italic, Underline, Font Name, Font Size, Font Color, Text Highlight Color, Align Text Left, Align Text Center, Align Text Right, Align Text Justify, Bullets, Numbering, Decrease Indent, Increase Indent, Cut, Copy, Paste, Clear Formatting, and Quote. Standard toolbar will include the following commands: Undo, Redo, Spell Checker, Find, Replace, Hyperlink, Remove Hyperlink, Insert Table, Insert Symbol, Insert from Web, Media Gallery, and Full Screen.

  • Complete. In this mode, Formatting toolbar will include the following commands: Bold, Italic, Underline, Font Name, Font Size, Font Color, Text Highlight Color, Align Text Left, Align Text Center, Align Text Right, Align Text Justify, Paragraph, Bullets, Numbering, Decrease Indent, Increase Indent, Cut, Copy, Paste, Change Case, Subscript, Superscript, Strikethrough, Clear Formatting, and Quote. Standard toolbar will include the following commands: Undo, Redo, Spell Checker, Find, Replace, Hyperlink, Remove Hyperlink, Insert Table, Insert Symbol, Insert Form Control, Insert from Web, Media Gallery, and Full Screen.

  • Custom. In this mode, custom toolbar can be added to WebTextEditor. This topic will be further explained in next section.

ToolBar mode can be changed in ToolBarSettings >> ToolBarMode property.

See Also

Other Resources
{Fluid, Smart ToolBar}
{Intuitive Word 2007-style Floating ToolBar}
{ToolBar Settings}
{Custom ToolBar}
{XML Format for Custom ToolBar}
{Customize toolbar programmatically from server-side}
{Perform Document Properties Actions}
{HTML ToolBar}
{View-based ToolBar}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


How-to: Customize Toolbar Mode

How-to: Customize Toolbar Mode
Send Feedback
Intersoft WebTextEditor > WebTextEditor > ToolBar > ToolBar Mode > How-to: Customize Toolbar Mode

Glossary Item Box

WebTextEditor provides 6 toolbar modes: None, Minimal, Standard, Rich, Complete, and Custom.

This topic will show you how to customize Toolbar Mode.

To customize Toolbar Mode

  1. Right click on WebTextEditor control and choose Properties.
  2. Expand ToolBarSettings and set ToolBarMode to either None, Minimal, Standard, Rich, Complete or Custom.
  3. Run the project. Various commands will be loaded based on the configured toolbar modes.

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


ToolBar Settings

ToolBar Settings
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > ToolBar > ToolBar Settings

Glossary Item Box

By default, toolbar height is set to 24px and command height is set to 20px. Both properties can be customized using ToolBarSettings >> Height and ToolBarSettings >> CommandHeight properties.

Several other configurations that can be set in ToolBarSettings:

  • FontNames
    Specifies the options that will be listed in Font Names combo. The list should be set as comma separated value.

  • FontSizes
    Specifies the options that will be listed in Font Sizes combo. The list should be set as comma separated value.

  • Heading
    Specifies the options that will be listed in Paragraph Style combo. The list should be set as comma separated value.

  • LinkOptions
    Specifies the options that will be listed in Link combo included in the Hyperlink callout. The list should be set as comma separated value.

See Also

Other Resources
{Fluid, Smart ToolBar}
{Intuitive Word 2007-style Floating ToolBar}
{ToolBar Mode}
{Custom ToolBar}
{XML Format for Custom ToolBar}
{Customize toolbar programmatically from server-side}
{HTML ToolBar}
{View-based ToolBar}
{Perform Document Properties Actions}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


How-to: Show Toolbar at Runtime

How-to: Show Toolbar at Runtime
Send Feedback
Intersoft WebTextEditor > WebTextEditor > ToolBar > ToolBar Settings > How-to: Show Toolbar at Runtime

Glossary Item Box

In WebTextEditor, it is possible to hide certain toolbars onload and show them at runtime using the context menu. Simply set the Visible property of the toolbar that you want to hide in InitializeToolBar server side event.

In this topic, you will learn how to show Toolbar at runtime.

To show Toolbar at runtime

  1. Right click on WebTextEditor control and choose Properties.
  2. Set EnableContextMenu to True.
  3. Expand ToolBarSettings and set ToolBarMode to Complete.
  4. Hide standard toolbar using InitializeToolBar server-side event.
    C# Copy Image Copy Code
    protected void WebTextEditor1_InitializeToolBar(object sender, WebTextEditorToolBarArgs e)
{
   WebTextEditorToolBarCollection toolbars = e.ToolBar as WebTextEditorToolBarCollection;
   WebTextEditorToolBar tb = toolbars.GetNamedItem(WebTextEditor1.ID + "_tbStandard");

   if (tb != null)
      tb.Visible = false;
}

  5. Run the project. In this case, only Formatting toolbar is shown on load. Note that the commands included in Standard toolbar are not initially shown on load. Try to right click on header area and choose Standard options in context menu to show the Standard toolbar.

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Custom ToolBar

Custom ToolBar
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > ToolBar > Custom ToolBar

Glossary Item Box

Custom toolbar can be added to WebTextEditor using various approaches:

  • Using InitializeToolBar server-side event
    In certain scenarios, several commands might need to be added or removed while maintaining the remaining commands that have already been included in the toolbar. InitializeToolBar server-side event can be used for this purpose. This topic will be further explained in next topic.

  • Using XML File

    In Design-time

    To add custom toolbar, simply set ToolBarSettings >> ToolBarMode property to Custom, and set the path of custom XML file definition in ToolBarSettings >> ToolBarXMLFile property.

Programmatically

To add custom toolbar programmatically, use LoadToolBarsStructureFromXml method to load the xml file definition.

protected void Page_Load(object sender, EventArgs e)
{
WebTextEditor1.LoadToolBarsStructureFromXml(Server.MapPath("~/xml/new.xml"));
}

In This Section

How-to: Add Custom ToolBar using XML File

How-to: Save and Load ToolBar Structure

See Also

Other Resources
{Fluid, Smart ToolBar}
{Intuitive Word 2007-style Floating ToolBar}
{ToolBar Mode}
{ToolBar Settings}
{XML Format for Custom ToolBar}
{Customize toolbar programmatically from server-side}
{HTML ToolBar}
{View-based ToolBar}
{Perform Document Properties Actions}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


How-to: Add Custom ToolBar using XML File

How-to: Add Custom ToolBar using XML File
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > ToolBar > Custom ToolBar > How-to: Add Custom ToolBar using XML File

Glossary Item Box

WebTextEditor provides a property to add custom toolbar using xml file.

In this topic, you will learn how to add custom toolbar.

To add custom toolbar using xml file

  1. Create an xml file that contains WebTextEditor's toolbar collection, such as following:
    <WebTextEditorToolBarCollection>
  <WebTextEditorToolBar Name="WebTextEditor1_tbCustom" Category="Custom" Text="Custom 1">
    <ToolCommands>
      <WebTextEditorToolCommand Name="cmdChangeCase" Text="Change Case" CommandType="ChangeCase" DisplayMode="TextAndImage" Image=" tb_changecase.gif" Type="SplitButton">
        <Items>
          <WebTextEditorToolItem Name="itemUpperCase" Text="UPPER CASE" Image="tb_uppercase.gif" />
          <WebTextEditorToolItem Name="itemLowerCase" Text="lower case" Image=" tb_lowercase.gif" />
        </Items>
      </WebTextEditorToolCommand>
      <WebTextEditorToolCommand Name="cmdEmot" Type="ToggleButton" Text="Emot" DisplayMode="Image" Image="smiley.gif">
        <Items />
      </WebTextEditorToolCommand>
    </ToolCommands>
  </WebTextEditorToolBar>
</WebTextEditorToolBarCollection>
  2. Under ToolBarSettings, set ToolBarMode to Custom.
  3. Define the xml file you have created in ToolBarXMLFile property.

See Also

Tasks
{How-to: Save and Load ToolBar Structure}

Other Resources
{Custom ToolBar}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


How-to: Save and Load ToolBar Structure

How-to: Save and Load ToolBar Structure
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > ToolBar > Custom ToolBar > How-to: Save and Load ToolBar Structure

Glossary Item Box

WebTextEditor provides a property to save and load toolbar structure.

In this topic, you will learn how to save and load.

To save and load toolbar structure

  1. Drag two ASP.NET buttons into the WebForm.
  2. Use SaveToolBarsStructureToXml() method to save the toolbar structure, and use LoadToolBarsStructureFromXml() method to load the toolbar structure.
  3. Invoke the method in Button_Click server side event like following:
    C# Copy Code
    protected void Button1_Click(object sender, EventArgs e)
{
   WebTextEditor1.SaveToolBarsStructureToXml(Server.MapPath("XML/New.xml"));
}

protected void Button2_Click(object sender, EventArgs e)
{
   WebTextEditor1.LoadToolBarsStructureFromXml(Server.MapPath("XML/New.xml"));
}

See Also

Tasks
{How-to: Add Custom ToolBar using XML File}

Other Resources
{Custom ToolBar}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


XML Format for Custom ToolBar

XML Format for Custom ToolBar
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > ToolBar > XML Format for Custom ToolBar

Glossary Item Box

Custom toolbar can be added to WebTextEditor using XML File. The XML file should implement the following format:

  • The root node is WebTextEditorToolBarCollection
  • To represent each toolbar, create WebTextEditorToolBar and add it to the root node. WebTextEditorToolBar could have Name, Text, and Category attributes. The predefined Category values are Standard, Formatting, HTML, FloatingTop, FloatingBottom, Preview, and Custom. If you add custom toolbar, you should use Custom category.
  • Add ToolCommands node inside each toolbar node
  • To represent each command, add WebTextEditorToolCommand to ToolCommands node. The attributes of commands are:
    • Name: specifies the unique name of the command
    • Text: specifies the text that will be displayed in the command
    • DisplayMode: specifies the display mode of the command. Three options are available for this attributes: Text, Image, and TextAndImage.
    • Image: specifies the image path that will be displayed in the command
    • Type: specifies the type of the command. There are various types supported in toolbar: Button, ToggleButton, SplitButton, DropDownButton, and Separator. Note that unique ID must be assigned to Separator-typed command.
      o ToggleGroupName: specifies the name of a toggle group. If multiple commands are included in the same toggle group, the same ToggleGroupName must be assigned to them.
  • If the command type is SplitButton or DropDownButton, items can be added to the command. Add Items node inside the command node.
  • To represent each item, add WebTextEditorToolItem to Items node. The attributes of an item are:
    • Name: specifies the unique name of the item.
    • Text: specifies the text that will be displayed in the item.
    • Image: specifies the image that will be displayed in the item.

Example:

<WebTextEditorToolBarCollection>
  <WebTextEditorToolBar Name="WebTextEditor1_tbCustom" Category="Custom" Text="Custom 1">
    <ToolCommands>
      <WebTextEditorToolCommand Name="cmdChangeCase" Text="Change Case" CommandType="ChangeCase" DisplayMode="TextAndImage" Image=" tb_changecase.gif" Type="SplitButton">
        <Items>
          <WebTextEditorToolItem Name="itemUpperCase" Text="UPPER CASE" Image="tb_uppercase.gif" />
          <WebTextEditorToolItem Name="itemLowerCase" Text="lower case" Image=" tb_lowercase.gif" />
        </Items>
      </WebTextEditorToolCommand>
      <WebTextEditorToolCommand Name="cmdEmot" Type="ToggleButton" Text="Emot" DisplayMode="Image" Image="smiley.gif">
        <Items />
      </WebTextEditorToolCommand>
    </ToolCommands>
  </WebTextEditorToolBar>
</WebTextEditorToolBarCollection>

See Also

Other Resources
{Fluid, Smart ToolBar}
{Intuitive Word 2007-style Floating ToolBar}
{ToolBar Mode}
{ToolBar Settings}
{Custom ToolBar}
{Customize toolbar programmatically from server-side}
{HTML ToolBar}
{View-based ToolBar}
{Perform Document Properties Actions}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Customize toolbar programmatically from server-side

Customize toolbar programmatically from server-side
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > ToolBar > Customize toolbar programmatically from server-side

Glossary Item Box

InitializeToolBar server-side event will be invoked when toolbar is being initialized. In this event, commands can be created, added, or removed from toolbar collection. Main toolbar collection, HTML toolbar collection, Preview toolbar collection, and floating toolbar collection will be passed as the arguments of the event.

The following is the code snippet to add a command to toolbar collection.

C# Copy Image Copy Code
protected void WebTextEditor1_InitializeToolBar(object sender, ISNet.WebUI.WebTextEditor.WebTextEditorToolBarArgs e)

   {
       WebTextEditorToolBar tb = e.GetToolBarByCategory(WebTextEditorToolBarCategory.Standard);

       if (tb != null)
       {
           WebTextEditorToolCommandCollection commands = tb.ToolCommands;

           WebTextEditorToolCommand cmd = new WebTextEditorToolCommand();
           cmd.Name = "cmdEmoticon";
           cmd.Text = "Emoticon";
           cmd.ToggleGroupName = "TaskPane";
           cmd.Type = WebTextEditorToolBarCommandType.ToggleButton;
           cmd.DisplayMode = WebTextEditorToolBarCommandDisplayMode.Image;
           cmd.Image = "./images/other/smiley1.gif";
           commands.Add(cmd);
       }
   }

The following is the code snippet to remove a command from toolbar collection.

C# Copy Image Copy Code
protected void WebTextEditor1_InitializeToolBar(object sender, WebTextEditorToolBarArgs e)

   {

       WebTextEditorToolBar tb = e.GetToolBarByCategory(WebTextEditorToolBarCategory.Formatting);

       if (tb != null)

       {

           WebTextEditorToolCommandCollection commands = tb.ToolCommands;

           commands.Remove(commands.GetNamedItem("cmdFontColor"));

       }

   }

A toolbar collection could contain multiple toolbars. To easily search for a specific toolbar, GetToolBarByCategory method in the event�??s argument can be used. This method can retrieve toolbar object in the collection using the category and name of toolbar.

WebTextEditorToolBar tb = e.GetToolBarByCategory(WebTextEditorToolBarCategory.Custom, "tbCustom1");

In This Section

How-to: Add Custom Command using InitializeToolBar server-side event

How-to: Remove Command using InitializeToolBar server-side event

How-to: Add Custom ToolBar using InitializeToolbar server-side event

How-to: Remove ToolBar using InitializeToolBar server-side event

See Also

Other Resources
{Fluid, Smart ToolBar}
{Intuitive Word 2007-style Floating ToolBar}
{ToolBar Mode}
{ToolBar Settings}
{Custom ToolBar}
{XML Format for Custom ToolBar}
{HTML ToolBar}
{View-based ToolBar}
{Perform Document Properties Actions}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


How-to: Add Custom Command using InitializeToolBar server-side event

How-to: Add Custom Command using InitializeToolBar server-side event
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > ToolBar > Customize toolbar programmatically from server-side > How-to: Add Custom Command using InitializeToolBar server-side event

Glossary Item Box

WebTextEditor provides a property to add a new command during InitializeToolBar server side event.

In this topic, you will learn how to enable keyboard support.

To add Custom Command during server side event

  1. Implement InitializeToolBar server side event in the WebTextEditor. Here is the snippet to add the custom command to the Standard toolbar:
    C# Copy Code
    protected void WebTextEditor1_InitializeToolBar(object sender, ISNet.WebUI.WebTextEditor.WebTextEditorToolBarArgs e)
{
   WebTextEditorToolBar tb = e.GetToolBarByCategory(WebTextEditorToolBarCategory.Standard);

   WebTextEditorToolCommand tbCommand = tb.ToolCommands.CreateNewItem();
   tbCommand.Name = "cmdCustomButton";
   tbCommand.Text = "Custom Command";

   tb.ToolCommands.Add(tbCommand);
}

  2. Implement onToolBarClick client side event to display a message when the newly created command is clicked. Here is the snippet:
    Javascript Copy Code
    function WebTextEditor1_OnToolBarClick(controlId, command, commandSection)
{
   var rte = ISGetObject(controlId);
   switch (command.Name)
   {
      case "cmdCustomButton":
           alert("Custom button clicked");
           break;
   }
}

See Also

Tasks
{How-to: Remove Command using InitializeToolBar server-side event}
{How-to: Add Custom ToolBar using InitializeToolBar server-side event}
{How-to: Remove ToolBar using InitializeToolBar server-side event}

Other Resources
{Customize toolbar programmatically from server-side}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


How-to: Remove Command using InitializeToolBar server-side event

How-to: Remove Command using InitializeToolBar server-side event
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > ToolBar > Customize toolbar programmatically from server-side > How-to: Remove Command using InitializeToolBar server-side event

Glossary Item Box

WebTextEditor provides a property to remove command during InitializeToolBar server side event.

In this topic, you will learn how to remove command.

To remove command during Server Side event

  1. Implement InitializeToolBar server side event in the WebTextEditor. Here is the snippet to remove the command using their name and position from the Standard toolbar:
    C# Copy Code
    protected void WebTextEditor1_InitializeToolBar(object sender, ISNet.WebUI.WebTextEditor.WebTextEditorToolBarArgs e)
{
   WebTextEditorToolBar tb = e.GetToolBarByCategory(WebTextEditorToolBarCategory.Standard);

   WebTextEditorToolCommand cmdUndo = tb.ToolCommands.GetNamedItem("cmdUndo");
   WebTextEditorToolCommand cmdRedo = tb.ToolCommands.GetNamedItem("cmdRedo");

   tb.ToolCommands.RemoveAt(2);
   tb.ToolCommands.Remove(cmdUndo);
   tb.ToolCommands.Remove(cmdRedo);
}

See Also

Tasks
{How-to: Add Custom Command using InitializeToolBar server-side event}
{How-to: Add Custom ToolBar using InitializeToolBar server-side event}
{How-to: Remove ToolBar using InitializeToolBar server-side event}

Other Resources
{Customize toolbar programmatically from server-side}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


How-to: Add Custom ToolBar using InitializeToolBar server-side event

How-to: Add Custom ToolBar using InitializeToolBar server-side event
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > ToolBar > Customize toolbar programmatically from server-side > How-to: Add Custom ToolBar using InitializeToolBar server-side event

Glossary Item Box

WebTextEditor provides a property to add custom toolbar during InitializeToolBar server side event.

In this topic, you will learn how to add custom toolbar.

To custom toolbar during Server Side event

  1. Implement InitializeToolBar server side event in the WebTextEditor. Here is the snippet to add the custom toolbar with some commands to the WebTextEditor:
    C# Copy Code
    protected void WebTextEditor1_InitializeToolBar(object sender, ISNet.WebUI.WebTextEditor.WebTextEditorToolBarArgs e)
{
   WebTextEditorToolBar tbCustom = new WebTextEditorToolBar();
   tbCustom.Name = "tbCustom";

   WebTextEditorToolCommand cmdCustom1 = new WebTextEditorToolCommand();
   cmdCustom1.Name = "cmdCustom1";
   cmdCustom1.Text = "Custom Button 1";

   WebTextEditorToolCommand cmdCustom2 = new WebTextEditorToolCommand();
   cmdCustom2.Name = "cmdCustom2";
   cmdCustom2.Text = "Custom Button 2";

   tbCustom.ToolCommands.Add(cmdCustom1);
   tbCustom.ToolCommands.Add(cmdCustom2);

   WebTextEditor1.ToolBar.Add(tbCustom);
}

  2. Implement onToolBarClick client side event to display a message when the newly created command in the custom toolbar is clicked. Here is the snippet:
    Javascript Copy Code
    function WebTextEditor1_OnToolBarClick(controlId, command, commandSection)
{
   var rte = ISGetObject(controlId);

   switch (command.Name)
   {
      case "cmdCustom1":
            alert("Custom button 1 clicked");
            break;

      case "cmdCustom2":
            alert("Custom button 2 clicked");
            break;
   }
}

See Also

Tasks
{How-to: Add Custom Command using InitializeToolBar server-side event}
{How-to: Remove Command using InitializeToolBar server-side event}
{How-to: Remove ToolBar using InitializeToolBar server-side event}

Other Resources
{Customize toolbar programmatically from server-side}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


How-to: Remove ToolBar using InitializeToolBar server-side event

How-to: Remove ToolBar using InitializeToolBar server-side event
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > ToolBar > Customize toolbar programmatically from server-side > How-to: Remove ToolBar using InitializeToolBar server-side event

Glossary Item Box

WebTextEditor provides a property to remove toolbar during InitializeToolBar server side event.

In this topic, you will learn how to remove toolbar.

To remove toolbar during InitializeToolBar server side event

  1. Implement InitializeToolBar server side event in the WebTextEditor. Here is the snippet to remove toolbar using their name or position from the WebTextEditor:
    C# Copy Code
    protected void WebTextEditor1_InitializeToolBar(object sender, ISNet.WebUI.WebTextEditor.WebTextEditorToolBarArgs e)
{
   WebTextEditorToolBar tbFormatting = WebTextEditor1.ToolBar.GetNamedItem("WebTextEditor1_tbFormatting");
   WebTextEditor1.ToolBar.Remove(tbFormatting);
}

    OR

    C# Copy Code
    protected void WebTextEditor1_InitializeToolBar(object sender, ISNet.WebUI.WebTextEditor.WebTextEditorToolBarArgs e)
{
   WebTextEditor1.ToolBar.RemoveAt(0);
}

See Also

Tasks
{How-to: Add Custom Command using InitializeToolBar server-side event}
{How-to: Remove Command using InitializeToolBar server-side event}
{How-to: Add Custom ToolBar using InitializeToolBar server-side event}

Other Resources
{Customize toolbar programmatically from server-side}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Perform Document Properties Actions

Perform Document Properties Actions
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > ToolBar > Perform Document Properties Actions

Glossary Item Box

As an editing tool, user should be able to import, save, preview, and print a document.

Import a document

When EnableDocumentImport property is set to True, Import command will be added to toolbar. When this command is clicked, OnToolBarClick client-side event will be invoked. Various actions can be manually implemented in this event to import a document to editor.

Save a document

When EnableDocumentSave property is set to True, Save command will be added to toolbar. When this command is clicked, WebTextEditor will perform FlyPostBack and invoke Save server side event. The editor content will be persisted during this action, so developer can easily grab and save the value and manually.

Print a document

When EnableDocumentPrint is set to True, Print command will be added to toolbar. When this command is clicked, user will be prompted to select which printer that will be used to print the content.

Preview a document

When ViewSettings >> AllowPreview is set to True, Preview command will be added to toolbar. When this command is clicked, the view will be switched to Preview mode, where user can preview the content.

In This Section

How-to: Import a document to WebTextEditor

How-to: Save a document to WebTextEditor

How-to: Print a document to WebTextEditor

How-to: Preview a document in WebTextEditor

See Also

Other Resources
{Fluid, Smart ToolBar}
{Intuitive Word 2007-style Floating ToolBar}
{ToolBar Mode}
{ToolBar Settings}
{Custom ToolBar}
{XML Format for Custom ToolBar}
{Customize toolbar programmatically from server-side}
{HTML ToolBar}
{View-based ToolBar}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


How-to: Enable Document Properties Command

How-to: Enable Document Properties Command
Send Feedback
Intersoft WebTextEditor > WebTextEditor > ToolBar > Perform Document Properties Actions > How-to: Enable Document Properties Command

Glossary Item Box

As an editing tool, it's important to be able to import the content from a file, save and print the content of WebTextEditor.

This topic will show you how to enable document properties command.

To enable document properties command

  1. Right click on WebTextEditor control and choose Properties.
  2. You can set the following properties:
    • EnableDocumentImport: when enabled, you can import the content of WebTextEditor from an external source, such as file, database, etc
    • EnableDocumentSave: when enabled, you can save the content of WebTextEditor to an external source, such as file, database, etc.
    • EnableDocumentPrint: when enabled, you can print the content of WebTextEditor.
  3. When one of the properties above are enabled, the related command will be added to main toolbar, providing an easy way for users to import, save, and print content.
  4. To implement Import and Save feature, you can use OnToolBarClick client-side events.

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


How-to: Import a document to WebTextEditor

How-to: Import a document to WebTextEditor
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > ToolBar > Perform Document Properties Actions > How-to: Import a document to WebTextEditor

Glossary Item Box

WebTextEditor provides a method to implement document import during client side event.

In this topic, you will learn how to import a document.

To import document to WebTextEditor

  1. Set the EnableDocumentImport property in the WebTextEditor to True. This will add a new command, Import Command, to the WebTextEditor toolbar.
  2. The import function implementation is done during onToolBarClick client side event of WebTextEditor. Here is the snippet:
    C# Copy Code
    function WebTextEditor1_OnToolBarClick(controlId, command, commandSection)
{
   var rte = ISGetObject(controlId);

   if (command.Name == "cmdImport")
      alert("implement document import");
}

See Also

Tasks
{How-to: Save a document to WebTextEditor}
{How-to: Print a document to WebTextEditor}
{How-to: Preview a document in WebTextEditor}

Other Resources
{Perform Document Properties Actions}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


How-to: Save a document to WebTextEditor

How-to: Save a document to WebTextEditor
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > ToolBar > Perform Document Properties Actions > How-to: Save a document to WebTextEditor

Glossary Item Box

WebTextEditor provides a method to save the content to a document during server-side event.

In this topic, you will learn how to save a document.

To save document to WebTextEditor

  1. Set the EnableDocumentSave property in the WebTextEditor to True. This will add a new command, Save Command, to the WebTextEditor toolbar.
  2. Call SaveContentToFile method during onSave WebTextEditor server side event. Here is the snippet:
    C# Copy Code
    protected void WebTextEditor1_Save(object sender, WebTextEditorSaveArgs e)
{
   WebTextEditor1.SaveContentToFile(HttpContext.Current.Server.MapPath("./SampleHtml/SavedFile.html"), WebTextEditorHtmlDocType.XHTMLDocType);
}

See Also

Tasks
{How-to: Import a document to WebTextEditor}
{How-to: Print a document to WebTextEditor}
{How-to: Preview a document in WebTextEditor}

Other Resources
{Perform Document Properties Actions}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


How-to: Print a document to WebTextEditor

How-to: Print a document to WebTextEditor
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > ToolBar > Perform Document Properties Actions > How-to: Print a document to WebTextEditor

Glossary Item Box

WebTextEditor provides a method to print the content.

In this topic, you will learn how to print a document.

To print document to WebTextEditor

  1. Set the EnableDocumentPrint property in the WebTextEditor to True. This will add a new command, PrintCommand, to the WebTextEditor toolbar.

See Also

Tasks
{How-to: Import a document to WebTextEditor}
{How-to: Save a document to WebTextEditor}
{How-to: Preview a document in WebTextEditor}

Other Resources
{Perform Document Properties Actions}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


How-to: Preview a document in WebTextEditor

How-to: Preview a document in WebTextEditor
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > ToolBar > Perform Document Properties Actions > How-to: Preview a document in WebTextEditor

Glossary Item Box

WebTextEditor provides a method to preview the document before printing or mail merging.

In this topic, you will learn how to preview a document.

To preview document in WebTextEditor

  1. Right click on WebTextEditor control and choose Properties.
  2. Expand ViewSettings and set EnablePreview to True. This will add a new Toolbar command, which is Preview Command.
  3. Click on Preview command. Notice that the Toolbar command is automatically changed to Zoom Out, Zoom In and Print.

See Also

Tasks
{How-to: Import a document to WebTextEditor}
{How-to: Save a document to WebTextEditor}
{How-to: Print a document to WebTextEditor}

Other Resources
{Perform Document Properties Actions}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


HTML ToolBar

HTML ToolBar
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > ToolBar > HTML ToolBar

Glossary Item Box

The toolbar commands included in Design view offers editing functionalities that are useful when previewing the content. However those commands do not share the same functionality in HTML view.

WebTextEditor implements html-related toolbar when viewing in HTML view. When clicked, the command will add the related html tag to editor. After a command is clicked, its text will change to its close tag.

User can easily add some tags and click close tags command to add close tags for all previous opened tags.

There is no formatting applied to the content in HTML view, thus making it difficult to find a certain text. WebTextEditor provides Find and Replace functionality in HTML toolbar for easy text searching.

See Also

Other Resources
{Fluid, Smart ToolBar}
{Intuitive Word 2007-style Floating ToolBar}
{ToolBar Mode}
{ToolBar Settings}
{Custom ToolBar}
{XML Format for Custom ToolBar}
{Customize toolbar programmatically from server-side}
{View-based ToolBar}
{Perform Document Properties Actions}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


View-based ToolBar

View-based ToolBar
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > ToolBar > View-based ToolBar

Glossary Item Box

Main toolbar functionality only applies when viewing content in Design view, so when user view HTML view, the main toolbar will be hidden and HTML toolbar will be displayed and vice versa. ToolBar will also be adjusted when user focuses on editor or text area in Split view.

The state of main toolbar will be persisted when it's hidden. So when main toolbar is compressed to 5px height to provide larger editing area in Design view, the state will be persisted when user switches back from HTML view to Design view.

User cannot compress HTML toolbar to 5px height.

See Also

Other Resources
{Fluid, Smart ToolBar}
{Intuitive Word 2007-style Floating ToolBar}
{ToolBar Mode}
{ToolBar Settings}
{Custom ToolBar}
{XML Format for Custom ToolBar}
{Customize toolbar programmatically from server-side}
{HTML ToolBar}
{Perform Document Properties Actions}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


How-to: Set adaptive Toolbar mode

How-to: Set adaptive Toolbar mode
Send Feedback
Intersoft WebTextEditor > WebTextEditor > ToolBar > View-based ToolBar > How-to: Set adaptive Toolbar mode

Glossary Item Box

To accomodate HTML view related actions, WebTextEditor automatically shows a specific HTML toolbar when HTML view is activated. When the commands in HTML toolbar is clicked, the related tag will be added to editor, making it easier and more intuitive for users to perform editing in HTML view. User can continue to write the editor content in HTML format and simply choose close tags command to close all opened tags.

In this topic, you will learn how to use adaptive Toolbar view mode.

To set adaptive Toolbar view mode

  1. To enable HTML View and SplitView, go to ViewSettings and set EnableHTMLView and EnableSplitView to True.
  2. Try to activate HTML view and HTML Toolbar will be displayed like following.

  3. Or, choose HTML area in Split View like following.

  4. When you edit from HTML view and choose Design area in Split view, the latest state will be persisted.

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


View

View
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > View

Glossary Item Box

By default, four views are available in WebTextEditor: Design view, HTML view, Split view, and Preview. In Design view, user can view and edit the content visually, while in HTML view, user can view and edit the content in HTML mode. In Split view, the editing area will be split into two areas: the top area will show Design view while the bottom area will display HTML view. When Preview mode is active, user can view the content before it is further processed.

The four views can be enabled and disabled using the following properties in ViewSettings:

  • EnableDesignView
    Specifies whether or not Design view is enabled.

  • EnableHTMLView
    Specifies whether or not HTML view is enabled.

  • EnableSplitView
    Specifies whether or not Split view is enabled.

  • EnablePreview
    Specifies whether or not Preview view is enabled. This property is not enabled by default.

In This Section

Rich Design View

Adaptive HTML View

Intuitive Split View

Preview

See Also

Other Resources
WebTextEditor Overview
Core Editing Features
Sections
Fluid, Smart ToolBar
Innovative Task Pane
Enable Context Menu
Integration with WebSpellChecker
Integration with FileUploader
Data Binding
{Mail Merge}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Rich Design View

Rich Design View
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > View > Rich Design View

Glossary Item Box

WebTextEditor features a unique design view that provides rich editing capabilities, enabling a true WYSIWYG content authoring experience. The design view includes sophisticated user interfaces such as smart toolbars, lightweight visual elements, intuitive task pane, context menu, and more - allowing users to perform content editing in a more intuitive and natural way.

WebTextEditor does not allow EnableDesignView, EnableHTMLView, and EnableSplitView properties to be disabled. In that configuration, design view will still be enabled.

By default, design view will be activated on first load. To activate other view on first load, simply set ViewSettings >> SelectedViewMode property to the selected view. A view cannot be disabled if it is set as the selected view mode.

See Also

Other Resources
{Adaptive HTML View}
{Intuitive Split View}
{Preview}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Adaptive HTML View

Adaptive HTML View
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > View > Adaptive HTML View

Glossary Item Box

The HTML view allows users to develop more advanced contents by writing html markups directly in the editor. Unique to WebTextEditor, the HTML view displays its own toolbar that contains html-specific and codes writing related commands, minimizing the code-writing efforts.

For instances, click on "bold" command will add <b> tag to the current cursor position, type some text and then click on "close tags" to automatically add the closing </b> tag.

After changes have been made in HTML view, WebTextEditor automatically synchronizes the changes when you switch to Design or other views.

Design view provides rich, WYSIWYG content authoring capabilities

HTML view allows markup editing, suitable for advanced content developer

See Also

Other Resources
{Rich Design View}
Intuitive Split View
Preview

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Intuitive Split View

Intuitive Split View
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > View > Intuitive Split View

Glossary Item Box

With Split view, users can work with both visual design and html code in a single interface, eliminating the needs to go back-and-forth between views while improving productivity at the same time. WebTextEditor also automatically synchronizes the changes as user changed the editor's focus, ensuring each change is properly reflected to other views.

When Split view is enabled, all three views will be enabled even though the Design or HTML view is disabled. This behavior is implemented since Split view requires both views to be enabled.

Split view enables users to intuitively work with visual design and html code at the same time.

See Also

Other Resources
{Rich Design View}
{Adaptive HTML View}
{Preview}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Preview

Preview
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > View > Preview

Glossary Item Box

In Preview mode, user can preview the content before it is printed or further processed. When enabled, Preview tab will be added to the footer row, allowing user to switch to Preview mode easily. Besides using the Preview tab, user can click on Preview command in main toolbar to preview the content.

When editing the content in Design view, several internal styles, such as default font names and size, table and media frame style, etc, are loaded to WebTextEditor, allowing user to differentiate the elements in editor easily. These internal styles will not be loaded automatically when user preview the content in Preview mode. To include the styles when previewing or printing the content, simply set UseDefaultEditorStylesForPrint property to true.

Internal styles are not loaded in Preview mode
Internal styles are loaded in Preview mode

When Preview mode is active, main toolbar will be switched to Preview toolbar, that contains Zoom In, Zoom Out, and Print commands. By default, the zoom value used in WebTextEditor is 10%. This value can be modified in ViewSettings >> PreviewZoomValue property.

See Also

Other Resources
{Rich Design View}
{Adaptive HTML View}
{Intuitive Split View}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


How-to: Customize built-in View Mode

How-to: Customize built-in View Mode
Send Feedback
Intersoft WebTextEditor > WebTextEditor > View > How-to: Customize built-in View Mode

Glossary Item Box

By default, Design view will be displayed when WebTextEditor is loaded. However, you can customize the selected view mode displayed when WebTextEditor is first loaded.

This topic will show you how to customize built-in view mode.

To customize built-in View Mode

  1. Right click on WebTextEditor and choose Properties.
  2. Expand ViewSettings and set SelectedViewMode to either DesignView, HTMLView or SplitView.
  3. Run the project.

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Task Pane

Task Pane
Send Feedback
Intersoft WebTextEditor > WebTextEditor > Task Pane

Glossary Item Box

This section contains information on how to work with Task Pane.

In This Section

Innovative Task Pane

Customizable Task Pane Position

Media Gallery Task Pane

Media Gallery Settings

Media Resource Concept

Table Designer Task Pane

Form Control Task Pane

View-Based Task Pane

Custom Task Pane

Show and Hide Task Pane Programmatically

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Innovative Task Pane

Innovative Task Pane
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > Task Pane > Innovative Task Pane

Glossary Item Box

One of the key features in WebTextEditor is its block-less user interface concept. With this concept, WebTextEditor allows users to perform various actions without interrupting their editing process.

Task Pane is implemented to support this concept, providing a resizable and extensible container that can be used for multiple purposes without blocking the page. Multiple contents can be included in Task Pane, and users can easily switch between pane modes and implement individual behavior for each mode.

WebTextEditor includes three built-in task pane modes: Media Gallery, Table Designer, and Form Control. These three panes can be opened from the related commands in main toolbar when Complete toolbar mode is activated.

Another alternative is to use context menu options in Task Pane header. All available pane modes will be listed as the context menu items, so user can easily switch between pane modes using this menu.

See Also

Other Resources
{Customizable Task Pane Position}
{Media Gallery Task Pane}
{Media Gallery Settings}
{Media Resource Concept}
{Table Designer Task Pane}
{Form Control Task Pane}
{View-Based Task Pane}
{Custom Task Pane}
{Show and Hide Task Pane Programmatically}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Customizable Task Pane Position

Customizable Task Pane Position
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > Task Pane > Customizable Task Pane Position

Glossary Item Box

By default, Task Pane is positioned at the right part of WebTextEditor. However, the position can be switched to the left part of WebTextEditor by configuring TaskPaneSettings >> TaskPanePosition to Left.

Right-positioned Task Pane
Left-positioned Task Pane

See Also

Other Resources
{Innovative Task Pane}
{Media Gallery Task Pane}
{Media Gallery Settings}
{Media Resource Concept}
{Table Designer Task Pane}
{Form Control Task Pane}
{View-Based Task Pane}
{Custom Task Pane}
{Show and Hide Task Pane Programmatically}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Media Gallery Task Pane

Media Gallery Task Pane
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > Task Pane > Media Gallery Task Pane

Glossary Item Box

Media Gallery pane is used to search for media and insert them into WebTextEditor. To open Media Gallery pane, user can click on Media Gallery command in main toolbar or choose Media Gallery from Task Pane menu.

Media will be searched based on the search criteria inputted by user:

  • Search text.
    When search text is specified, WebTextEditor will search for media that contain the specified text. When search text is not specified, the search will retrieve all media.

  • Media Resources.
    Several resources can be specified in WebTextEditor in hierarchical mode. Media resource refers to an external storage where media are stored. User can determine whether the search action should be performed on all resources or a single resource.

  • Result type.
    The result of the search could vary from images, videos, audios, and Flash objects. User can determine whether the search action should returns all type of results or limited to a certain kind of type.

To insert the media to editor, user can simply double click on the media or use the media's context menu. Using media context menu, user can choose whether or not the inserted media be placed in a frame. When frame is used, caption can be added to the image.

If the media is stored in the web, user can use Insert from Web callout to insert the media to editor. Various types of media: pictures, audios, videos, Flash videos, and YouTube videos can be inserted to editor.

In most scenarios, the media is stored in local machine. Users have to upload the file to server before they can make use of it in the editor. WebTextEditor features deep integration with WebFileUploader enabling users to perform files uploading easily and intuitively. Simply click Insert from Computer command to upload the file and insert it in editor.

See Also

Other Resources
{Innovative Task Pane}
{Customizable Task Pane Position}
{Media Gallery Settings}
{Media Resource Concept}
{Table Designer Task Pane}
{Form Control Task Pane}
{View-Based Task Pane}
{Custom Task Pane}
{Show and Hide Task Pane Programmatically}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Media Gallery Settings

Media Gallery Settings
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > Task Pane > Media Gallery Settings

Glossary Item Box

In scenarios where Media Gallery is not needed, it can be disabled using TaskPaneSettings >> MediaGallery >> Enabled property. When Media Gallery is disabled, the Media Gallery command in main toolbar will also be removed.

The media retrieved as results of media search action will be displayed as thumbnails in media result container. By default, the thumbnail size is set to 55x55px size. To modify the size of thumbnail, the following properties can be configured: TaskPaneSettings >> MediaGallery >> ImageHeight and TaskPaneSettings >> MediaGallery >> ImageWidth.

When media search action is performed in multiple media resources, it could result in a large number of media. Retrieving large number of media could affect the performance when rendering and interacting with elements in client-side, thus by design the result is limited to 100 media only. To specify a larger number of search results, simply modify the value in TaskPaneSettings >> MediaGallery >> MaxMediaRetrieved property.

When first opened, media search action will be automatically performed in Media Gallery pane. This behavior can be disabled by setting TaskPaneSettings >> MediaGallery >> SearchMediaOnLoad property to False.

See Also

Other Resources
{Innovative Task Pane}
{Customizable Task Pane Position}
{Media Gallery Task Pane}
{Media Resource Concept}
{Table Designer Task Pane}
{Form Control Task Pane}
{View-Based Task Pane}
{Custom Task Pane}
{Show and Hide Task Pane Programmatically}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Media Resource Concept

Media Resource Concept
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > Task Pane > Media Resource Concept

Glossary Item Box

A media resource represents an external storage where media are stored. In this version, only URL storage is supported as media resource. If media are stored in multiple folders, multiple media resources can be created to represents multiple folders. The multiple folders can be also be grouped. User can perform search to individual resource or group.

Media Resource Property

Media Resource Group
Media Resource

The collection of media resource will be listed as hierarchical layout in Media Resources combo. For example: in the above screenshot, Product Images resource and Screenshot Images resource are grouped in Products group. When user selects Product Images item, the search will be performed in Product Images folder. If Products group is selected, search will be performed against all resources included in Products group, Product Images and Screenshot Images.

Using this approach, search can be performed to a specific resource(s) only, thus filtering the media retrieved as the result.

See Also

Other Resources
{Innovative Task Pane}
{Customizable Task Pane Position}
{Media Gallery Task Pane}
{Media Gallery Settings}
{Table Designer Task Pane}
{Form Control Task Pane}
{View-Based Task Pane}
{Custom Task Pane}
{Show and Hide Task Pane Programmatically}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


How-to: Enable Media Searching

How-to: Enable Media Searching
Send Feedback
Intersoft WebTextEditor > WebTextEditor > Task Pane > Media Resource Concept > How-to: Enable Media Searching

Glossary Item Box

WebTextEditor provides ways to enable Media Searching in Media Gallery, which are using search media on load and media resources.

This topic will show you how to enable media searching.

To search media on load

  1. Right click on WebTextEditor control and choose Properties.
  2. Expand TaskPaneSettings >> MediaGallery.
  3. Set Enabled to True.
  4. To limit the media retrieved in the media search, set MaxMediaRetrieved to 10.

To use Media Resources

  1. Right click on WebTextEditor control and choose Properties.
  2. Go to Media Resources and choose collection button.
  3. Add 1 media collection. Set Name to Products and Text to Products.
  4. Go to Resources and click the collection button.
  5. Add 2 members. For the first one, set Name to resProducts, Text to Product Images and Url to images/products/.
  6. For the second one, set Name to resScreenshots, SearchInChildFolder to True, Text to Screenshot Images and Url to images/screenshots/.
  7. Add another media collection. Set Name to Other and Text to Other.
  8. Go to Resources collection and click the collection button.
  9. Add 1 member. Set Name to resOther, Text to Other Images and Url to images/other/.
  10. Run the project. In this case, there are two MediaResourceGroup: Products and Other. Products group consists of products and screenshots folders, while Other group consist of other folder. In Media Gallery pane, open Search in combo. When you select Products group, the search will be performed in both products and screenshots folders, however if you select individual folder, for example: Screenshot Images, the search will be performed in screenshots folder only.

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Table Designer Task Pane

Table Designer Task Pane
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > Task Pane > Table Designer Task Pane

Glossary Item Box

In WebTextEditor, user can insert a table using two options:

  • Table pop up.
    Using table pop up, user can drag to select the number of rows and columns of the table. Table will be inserted with 100% width size.

  • Table Designer Task Pane
    Using Table Designer Task Pane, user can choose from a list of table layout template available or input the table dimensions and format before inserting the table into editor.

There are three modes in Table Designer pane: Insert Table, Edit Table, and Cell Actions. In Insert Table mode, user can choose a table template from a list available or input table dimensions and formatting. In this mode, user can also specifies cell dimensions and formatting that will be applied to all cells in the table.

Edit Table mode has the same layout as Insert Table mode, however user is not allowed to modify the number of rows and columns in the table to avoid loss of content if the rows and columns are reduced. User also cannot modify cell properties.

In Cell Actions mode, user can modify cell properties and perform cell actions, such as insert columns to the left, insert columns to the right, delete columns, insert rows above, insert rows below, delete rows, merge cells down, merge cells right, split cells vertical and split cells horizontal. These actions are also available in editor context menu when table is selected.

Not all browsers support table selection, thus navigating to Edit Table mode could be a little bit difficult. In this case, user can utilize Edit Table command in pane toolbar to activate Edit Table mode.

See Also

Other Resources
{Innovative Task Pane}
{Customizable Task Pane Position}
{Media Gallery Task Pane}
{Media Gallery Settings}
Media Resource Concept
{Form Control Task Pane}
{View-Based Task Pane}
{Custom Task Pane}
{Show and Hide Task Pane Programmatically}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Form Control Task Pane

Form Control Task Pane
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > Task Pane > Form Control Task Pane

Glossary Item Box

In Form Control pane, user can insert various form controls supported by WebTextEditor. To open Form Control pane, user can click on Form Control command in main toolbar or choose Form Control from Task Pane menu.

Various form controls that can be added to WebTextEditor are: Button, Fieldset, Horizontal Rule, IFrame, Input Button, Input Checkbox, Input File Upload, Input Hidden, Input Password, Input Reset, Input Submit, Input Text, Marquee, Select Dropdown, Select List box, and Text area.

See Also

Other Resources
{Innovative Task Pane}
{Customizable Task Pane Position}
{Media Gallery Task Pane}
{Media Gallery Settings}
{Media Resource Concept}
{Table Designer Task Pane}
{View-Based Task Pane}
{Custom Task Pane}
{Show and Hide Task Pane Programmatically}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


View-Based Task Pane

View-Based Task Pane
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > Task Pane > View-Based Task Pane

Glossary Item Box

Unlike Design view, Task Pane is not functional in HTML view, because user cannot view the result visually. So, when user views HTML view, the Task Pane mode will be switched to HTML pane mode, which displays empty content. When user switches back to Design view, the previous state of Task Pane will be persisted. This means, the last opened pane mode, including its values, will be persisted when user switches back to Design view.

This behavior is also implemented in Split view. HTML pane mode will be activated when user focuses on text area section and the last opened pane mode will be activated when user focuses on editor area.

See Also

Other Resources
{Innovative Task Pane}
{Customizable Task Pane Position}
{Media Gallery Task Pane}
{Media Gallery Settings}
{Media Resource Concept}
{Table Designer Task Pane}
{Form Control Task Pane}
{Custom Task Pane}
{Show and Hide Task Pane Programmatically}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Custom Task Pane

Custom Task Pane
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > Task Pane > Custom Task Pane

Glossary Item Box

WebTextEditor provides three built-in pane modes: Media Gallery, Table Designer, and Form Control. However in certain scenarios, custom pane mode might need to be implemented. In this case, developers can utilize the extensible pane interface to create their own custom pane mode in Task Pane.

To create a custom pane mode, developer need to create a pane content class that is inherited from TaskPaneContent object and assign a unique ID to the class.

Javascript Copy Code
function EmoticonPane()
{
     TaskPaneContent.call(this); //inherit from TaskPaneContent object
   this .Id = "Emoticon";
}

Several properties can be specified for the custom pane content:

  • Type
    This is mandatory property that should have unique value that indicates the pane content type implemented.

  • Caption
    Determines the caption of the pane content. The value will be used as the header text in pane content.

  • Image
    Determines the image of pane content. The value will be used as the image of the pane content in Task Pane menu item.

  • ShowHeader
    Determines whether or not the header should be enabled. Default value is True.

  • ShowToolBar
    Determines whether or not the toolbar should be enabled. Default value is True.

  • AllowMaximize
    Determines whether or not the pane is allowed to be maximized. Default value is False.

  • AllowClose
    Determines whether or not the pane is allowed to be closed. Default value is True.

  • AllowResize
    Determines whether or not the pane is allowed to be resized. Default value is True.

  • AllowContentOptions
    Determines whether or not the icon to show available pane content mode should be displayed. Default value is True.

Besides the properties, several interfaces can also be implemented:

  • GetContainerElement.
    This is mandatory function that should be implemented. This function should return the element that will be included in the content area of
    Task Pane.

  • OnCreate
    Specifies the event that will be invoked when the pane content is being created. The above pane content properties should be specified in this event. If toolbar is enabled, the toolbar commands should be added in this event.

  • OnInitialize
    Specifies the event that will be invoked when the pane content is being initialized. In this event, developer could implement function to initialize default values for input fields in the content area and so on.

  • OnClose
    Specifies the event that will be invoked when the pane content is being closed.

  • OnMaximize
    Specifies the event that will be invoked when the pane content is being maximized.

  • OnContentOptionsSelected
    Specifies the event that will be invoked when an item in Task Pane menu is selected.

  • OnResize
    Specifies the event that will be invoked when Task Pane is being resized.

  • OnAfterRender
    specifies the event that will be invoked after content rendering process is finished. In this event, developer can register behaviors to elements in the content area or insert new elements to the content area.

  • OnShow
    Specifies the event that will be invoked when the pane content is being shown.

  • OnUnload
    Specifies the event that will be invoked when the pane content is being unloaded. In this event, developer can unregister the behaviors attached to elements in the content area to avoid memory leak. Note that the pane is not unloaded when user switches between pane modes.

After the custom pane object is ready, it should be registered in WebTextEditor using RegisterPaneContent function. The custom pane object should be registered when WebTextEditor is initialized, in OnInitialize client-side event.

The custom pane is ready to use. To open the custom pane, developer could add custom command in main toolbar and open Task Pane when the command is clicked.

In This Section

Walkthrough: Creating Custom Task Pane Content

See Also

Other Resources
{Innovative Task Pane}
{Customizable Task Pane Position}
{Media Gallery Task Pane}
{Media Gallery Settings}
{Media Resource Concept}
{Table Designer Task Pane}
{Form Control Task Pane}
{View-Based Task Pane}
{Show and Hide Task Pane Programmatically}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Walkthrough: Creating Custom Task Pane Content

Walkthrough: Creating Custom Task Pane Content
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > Task Pane > Custom Task Pane > Walkthrough: Creating Custom Task Pane Content

Glossary Item Box

This walkthrough shows you how to create custom task pane in WebTextEditor.

During this walkthrough, you will learn how to do the following:

  • Create custom task pane in WebTextEditor.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Visual Studio 2008 Application.

Step-By-Step Instructions

To create custom task pane in WebTextEditor

  1. Launch Visual Studio.NET 2008.
  2. Click on File menu, then select New and click Web Site.
  3. Select ASP.NET Web Site in the Template box and set Location to HTTP.
  4. Named the Web Site and click OK.
  5. Copy the images folder under WebTextEditor >> Images from the WebTextEditor sample to your project root folder.
  6. Right-click on Project's name and select Add New Item.
  7. Select WebForm in the My Templates box and named it as Walkthrough.aspx.
  8. Drag WebTextEditor instance from ToolBar to WebForm
  9. In the WebForm aspx create a new javascript function for the custom task pane. Here is the snippet:
    JavaScript Copy Code
    function EmoticonPane()
{
   TaskPaneContent.call(this);   //inherit from TaskPaneContent object
   this.Id = "Emoticon";
   this.OnCreate = function()
   {
      this.Type = "Emoticon";
      this.Caption = "Emoticons";
   };
   this.GetContainerElement = function()
   {
      var str = "<div id='frame'>";
      for (var i = 1; i < 24; i++)
      {
         str += "<div style='float: left; padding-left: 5px;padding-bottom: 5px;'>"
            + "<img src='./images/other/smiley" + i + ".gif' style='cursor: pointer' "
            + "title='Click here to add this emoticon' /></div>";
      }
      str += "</div>";
      var div = document.createElement("DIV");
      div.innerHTML = str;
      return div.children[0];
   };
   this.OnAfterRender = function()
   {
      var el = document.getElementById("frame");
      Listener.Add(el, "onclick", InsertEmoticon, this);
   };
   this.OnClose = function()
   {
      var rte = this.Parent.Parent;
      rte.OnToolbarCommandNotify("Emoticon", false);
   };
   this.OnContentOptionsSelected = function()
   {
      var pane = this.Parent;
      var rte = pane.Parent;
      rte.OnToolbarCommandNotify("Emoticon", pane.ActiveType == "Emoticon" ? true : false);
   };
   this.Unload = function()
   {
      var el = document.getElementById("frame");
      Listener.Unload(el);};
   }

function InsertEmoticon()
{
   var paneContent = this;
   var rte = paneContent.Parent.Parent;
   var el = event.srcElement;
   if (el.tagName == "IMG")
      rte.InsertImage(el.src);
}

    The GetContainerElement function will create the list of images for this custom task pane. We also need to add element onclick event in the custom task pane during AfterRender event to add the image to the TextEditor area.

  10. Create the new Emoticon task pane during WebTextEditor onInitialize client side event. Here is the snippet:

    rte.RegisterPaneContent(new EmoticonPane());

  11. Implement WebTextEditor onToolBarClick client side event to toggle the Emoticon command that we create during InitializeToolBar server side event (detailed on the next step) and the Media Gallery command. Here is the snippet:
    JavaScript Copy Code
    function WebTextEditor1_OnToolBarClick(controlId, command, commandSection)
{
   var rte = ISGetObject(controlId);
   switch (command.Name)
   {
      case "cmdEmoticon":
         if (command.IsActive)
            rte.ShowTaskPane(command.Text);
         else
            rte.HideTaskPane();
         rte.OnToolbarCommandNotify("MediaGallery", false);
         break;
      case "cmdMediaGallery":
         rte.OnToolbarCommandNotify("Emoticon", false);
         break;
   }
}

  12. Implement WebTextEditor InitializeToolBar server side event to add Emoticon command to show/hide the Emoticon task pane. Here is the snippet:
    C# Copy Code
    protected void WebTextEditor1_InitializeToolBar(object sender, ISNet.WebUI.WebTextEditor.WebTextEditorToolBarArgs e)
{
   WebTextEditorToolBar tb = e.GetToolBarByCategory(WebTextEditorToolBarCategory.Standard);
   if (tb != null)
   {
      WebTextEditorToolCommandCollection commands = tb.ToolCommands;
      WebTextEditorToolCommand cmd = new WebTextEditorToolCommand();
      cmd.Name = "cmdEmoticon";
      cmd.Text = "Emoticon";
      cmd.ToggleGroupName = "TaskPane";
      cmd.Type = WebTextEditorToolBarCommandType.ToggleButton;
      cmd.DisplayMode = WebTextEditorToolBarCommandDisplayMode.Image;
      cmd.Image = "./images/other/smiley1.gif";
      commands.Add(cmd);
   }
}

  13. Run the sample in the Web Browser.

See Also

Other Resources
{Custom Task Pane}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Show and Hide Task Pane Programmatically

Show and Hide Task Pane Programmatically
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > Task Pane > Show and Hide Task Pane Programmatically

Glossary Item Box

In first load, Task Pane is not opened automatically. User has to click on the related commands in main toolbar to open it. Another alternative is to show Task Pane programmatically using ShowTaskPane function. The pane content mode that will be opened should be passed to the function as a parameter.

To hide Task Pane programmatically, HideTaskPane function can be used.

See Also

Other Resources
{Innovative Task Pane}
{Customizable Task Pane Position}
Media Gallery Task Pane
{Media Gallery Settings}
{Media Resource Concept}
{Table Designer Task Pane}
{Form Control Task Pane}
{View-Based Task Pane}
{Custom Task Pane}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Context Menu

Context Menu
Send Feedback
Intersoft WebTextEditor > WebTextEditor > Context Menu

Glossary Item Box

This section contains information on how to enable and customize Context Menu.

In This Section

Enable Context Menu

Customize Context Menu

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Enable Context Menu

Enable Context Menu
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > Context Menu > Enable Context Menu

Glossary Item Box

To edit and format the content, user can use toolbar, shortcut keys, and context menu. Context menu in WebTextEditor is not enabled by default. To enable context menu, simply set EnableContextMenu property to True.

When enabled, context menu will be displayed when user performs right click in editor area. When user performs right click in table-cell element, cell actions will also be listed in context menu.

When Spell Checker mode is active, the word suggestions will also be listed in context menu, however the context menu used in this mode is not the same menu used in WebTextEditor. The context menu in WebTextEditor will be disabled temporarily when Spell Checker mode is active.

See Also

Other Resources
Customize Context Menu

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


How-to: Enable Built-in Context Menu and Floating Toolbar

How-to: Enable Built-in Context Menu and Floating Toolbar
Send Feedback
Intersoft WebTextEditor > WebTextEditor > Context Menu > Enable Context Menu > How-to: Enable Built-in Context Menu and Floating Toolbar

Glossary Item Box

WebTextEditor revolutionizes editing experience with sophisticated, Word 2007-style floating toolbar. When enabled, user can access frequently accessed commands more quickly and efficiently. WebTextEditor also completes its feature by adding built-in context menu.

This topic will show you how to enable built-in context menu and Floating Toolbar.

To enable built-in Context Menu and Floating Toolbar

  1. To enable built-in context menu, right click WebTextEditor control and choose Properties. Set EnableContextMenu to True.
  2. To enable Floating Toolbar, go to WebTextEditor's Properties. Expand ToolBarSettings and set EnableFloatingToolBar to True.
  3. Run the project.

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Customize Context Menu

Customize Context Menu
Send Feedback
Intersoft WebTextEditor > WebTextEditor > Context Menu > Customize Context Menu

Glossary Item Box

Context Menu can be customized to include custom items or remove existing item. To customize context menu, items can be added or removed in OnEditorContextMenu client-side event.
JavaScript Copy Image Copy Code
function WebTextEditor1_OnEditorContextMenu(controlId, menuObj)
{
   var items = menuObj.RootMenu.Items;
   if (items.GetNamedItem("mLookUp") == null)
   {
      items.Add(new WebMenuSeparatorItem());
      items.Add(new WebMenuItem("mLookUp", "Look Up...", null, OnClick));
   }
}

In This Section

How-to: Add Item in Context Menu

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


How-to: Add Item in Context Menu

How-to: Add Item in Context Menu
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > Context Menu > Customize Context Menu > How-to: Add Item in Context Menu

Glossary Item Box

WebTextEditor provides a property to add item in context menu.

In this topic, you will learn how to add item.

To add item in context menu

  1. Set EnableContextMenu property to True.
  2. Place the following code under OnEditorContextMenu and OnClick client side events.
    C# Copy Code
    function WebTextEditor1_OnEditorContextMenu(controlId, menuObj)
{
   var items = menuObj.RootMenu.Items;

   if (items.GetNamedItem("mLookUp") == null)
   {
      items.Add(new WebMenuSeparatorItem());
      items.Add(new WebMenuItem("mLookUp", "Look Up...", null, OnClick));
   }
}

function OnClick(menuItem)
{
   if (menuItem.Name == "mLookUp")
   window.open("http://www.google.com/search?q=webui+studio");
}

  3. When you run the project, "Look Up..." item is added to editor's context menu. Try to right click on editor area and notice that "Look Up..." item is included in the context menu. When the item is clicked, a new window that refers to www.google.com will be opened.

See Also

Other Resources
{Customize Context Menu}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Integration with Intersoft Product

Integration with Intersoft Product
Send Feedback
Intersoft WebTextEditor > WebTextEditor > Integration with Intersoft Product

Glossary Item Box

This section contains information on how to integrate WebTextEditor with other Intersoft product.

In This Section

Integration with WebSpellChecker

Sophisticated Navigation Experience

Integration with FileUploader

How-to: Integrate to WebDesktop

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Integration with WebSpellChecker

Integration with WebSpellChecker
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > Integration with Intersoft Product > Integration with WebSpellChecker

Glossary Item Box

Integration with WebSpellChecker for spell checking can be done seamlessly and elegantly. To integrate WebTextEditor to WebSpellChecker, simply perform the following steps:

  • Add WebTextEditor and WebSpellChecker instances to the page
  • In WebSpellChecker instance, set the following properties:

    Product | Sample Location
    TargetControlId | The ID of WebTextEditor
    IntegratedToWebTextEditor | True

When integrated to editor, WebSpellChecker will automatically enable Microsoft Word-style red wave highlight feature. For more information about WebSpellChecker user interface, please refer to WebSpellChecker documentation.

In This Section

Sophisticated Navigation Experience

See Also

Other Resources
{Integration with FileUploader}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Sophisticated Navigation Experience

Sophisticated Navigation Experience
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > Integration with Intersoft Product > Sophisticated Navigation Experience

Glossary Item Box

WebSpellChecker introduces sophisticated navigation experience when integrated with WebTextEditor. It also automatically connects to WebTextEditor user interface providing more options for spell checking related commands. You can perform spell checking in several ways such as discussed below.

  • Spell checker command in toolbar.

    When WebSpellChecker integration is configured properly, the spell checker command in WebTextEditor's toolbar will be enabled. Click on this command to start spell checking which activates spell check editing mode. Click on the command again to exit from spell checking mode.

  • Auto-navigate spell checker command in status bar.

    This easy-to-access button provides user with convenient way to perform spell checking. It's particularly useful when the editor is loading in minimal toolbar configuration where spell checker command may not be available in the toolbar.

    When clicked for the first time, WebSpellChecker executes spell checking process and automatically focus on the first misspelled word with suggested word list displayed in intuitive context menu interface. Click on the button again to easily navigate to the next misspelled word.

In This Section

Walkthrough: Integration with WebSpellChecker

See Also

Other Resources
{Integration with WebSpellChecker}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Walkthrough: Integration with WebSpellChecker

Walkthrough: Integration with WebSpellChecker
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > Integration with Intersoft Product > Sophisticated Navigation Experience > Walkthrough: Integration with WebSpellChecker

Glossary Item Box

This walkthrough shows you how to integrate WebSpellChecker in WebTextEditor.

During this walkthrough, you will learn how to do the following:

  • Integrating WebSpellChecker in WebTextEditor.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Visual Studio 2008 Application.

Step-By-Step Instructions

To create custom task pane in WebTextEditor

  1. Launch Visual Studio.NET 2008.
  2. Click on File menu, then select New and click Web Site.
  3. Select ASP.NET Web Site in the Template box and set Location to HTTP.
  4. Named the Web Site and click OK.
  5. Right-click on Project's name and select Add New Item.
  6. Select WebForm in the My Templates box and named it as Walkthrough.aspx.
  7. Drag WebTextEditor instance from ToolBar to WebForm.
  8. Drag WebSpellChecker instance from ToolBar to WebForm.
  9. Copy the Dictionary folder under WebTextEditor >> Dictionary from WebTextEditor sample to the project root folder.
  10. Set the TargetControlID to WebTextEditor id control and IntegratedToWebTextEditor to true.

  11. Run the sample in Web Browser.

See Also

Other Resources
{Sophisticated Navigation Experience}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Integration with FileUploader

Integration with FileUploader
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > Integration with Intersoft Product > Integration with FileUploader

Glossary Item Box

When WebTextEditor is integrated to WebFileUploader, user is able to upload files using Insert from Computer command in task pane toolbar. The uploader callout will be displayed when the command is clicked, allowing user to select multiple files to upload.

When Upload Files button is clicked, the files will be uploaded. Pink-colored progress bar will be displayed in status bar, indicating the progress status of uploading process. During this process, user can continue editing the content, without having to wait for the uploading process to finish.

When integrated to WebFileUploader, the following configurations can be set in FileUploaderSettings property:

  • Enabled
    Specifies whether or not file uploader is enabled.

  • DefaultUploadPath
    Specifies the default upload path in case none is specified in media resource.

  • DefaultUploadMediaResource
    Specifies the default media resource that is used as default upload path.

  • AllowCancel
    Specifies whether or not the uploading process can be cancelled.

  • FilesCount
    Specifies the maximum number of files that can be uploaded in a single uploading process.

  • FileTypes
    Specifies the types of files that can be uploaded.

  • UploadSizeLimit
    Specifies the maximum size of an uploaded file.

  • TotalUploadSizeLimit
    Specifies the maximum size of total uploaded files.

In addition to the above configurations, the media resources where the files upload is allowed should have AllowUserUpload property set to true.

In This Section

Walkthrough: Integration with WebFileUploader

See Also

Other Resources
{Integration with WebSpellChecker}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Walkthrough: Integration with WebFileUploader

Walkthrough: Integration with WebFileUploader
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > Integration with Intersoft Product > Integration with FileUploader > Walkthrough: Integration with WebFileUploader

Glossary Item Box

This walkthrough shows you how to integrate FileUploader in WebTextEditor.

During this walkthrough, you will learn how to do the following:

  • Integrating WebFileUploader in WebTextEditor
  • Create media resources in WebTextEditor

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Visual Studio 2008 Application.

Step-By-Step Instructions

To create custom task pane in WebTextEditor

  1. Launch Visual Studio.NET 2008.
  2. Click on File menu, then select New and click Web Site.
  3. Select ASP.NET Web Site in the Template box and set Location to HTTP.
  4. Named the Web Site and click OK.
  5. Copy the Thumbnails folder under WebTextEditor >> Thumbnails from the WebTextEditor sample to your project root folder.
  6. Right-click on Project's name and select Add New Item.
  7. Select WebForm in the My Templates box and named it as Walkthrough.aspx.
  8. Drag WebTextEditor instance from ToolBar to WebForm.
  9. Add some Media Resources to WebTextEditor, for example Thumbnails folder, using MediaResources property in the WebTextEditor.
  10. Named the TextEditorResourceGroup to Media1 and set the TextEditorResource folder to Thumbnails and AllowUserUpload property to true.

  11. Set the Enabled to True and DefaultUploadMediaResources to Thumbnails (the TextEditorResource name) under FileUploaderSettings section.

  12. Run the sample using web browser. The FileUploader can be accessed by clicking the [Insert From Computer] button in the Media Gallery task pane.

See Also

Other Resources
{Integration with FileUploader}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


How-to: Integrate to WebDesktop

How-to: Integrate to WebDesktop
Send Feedback
Intersoft WebTextEditor > WebTextEditor > Integration with Intersoft Product > How-to: Integrate to WebDesktop

Glossary Item Box

WebTextEditor has a tight integration with WebDesktop.NET.

This topic will show you how to integrate WebTextEditor with WebDesktop.NET.

To integrate WebTextEditor with WebDesktop

  1. Create a page with WebTextEditor. Named the page as WebTextEditor.aspx.
  2. Create a page with WebDesktopManager. Set ShortcutIconVisible to True.
  3. Go to ShorcutIcons and click the collection button. Set the following properties below.

  4. Run the project. Try to click the shortcut icon and a window will be displayed along with WebTextEditor inside it.

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Data Binding

Data Binding
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > Data Binding

Glossary Item Box

WebTextEditor can be used as an item template of data bound controls. When it is used as the item template, the data can be bound using the same approach used when using .NET controls as item template. WebTextEditor can also be integrated as insert and edit template of data bound controls. Simply bind the data item to Content property, as shown in the following snippet.

< ISWebTextEditor : WebTextEditor ID="WebTextEditor1" runat="server" Height="200px" Width="500px" Content='<%# Bind("Notes") %>'>

This approach is not yet supported when multiple sections is enabled.

In This Section

How-to: Use WebTextEditor as Item Template of DetailsView

How-to: Integrate WebTextEditor in FormView

See Also

Other Resources
Overview WebTextEditor
Core Editing Features
{Sections}
{Text Settings}
{Sleek Design and Elegant User Interface}
{Fluid, Smart ToolBar}
{HTML ToolBar}
{View-based ToolBar}
{View}
{Innovative Task Pane}
{Enable Context Menu}
{Integration with FileUploader}
{Integration with WebSpellChecker}
{Mail Merge}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


How-to: Use WebTextEditor as Item Template of DetailsView

How-to: Use WebTextEditor as Item Template of DetailsView
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > Data Binding > How-to: Use WebTextEditor as Item Template of DetailsView

Glossary Item Box

WebTextEditor could be used as an item template in DetailsView control.

In this topic, you will learn how to use WebTextEditor as Item Template.

To use WebTextEditor as Item Template in DetailsView

  1. Create a DetailsView with employee data bound from the Northwind.mdb.
  2. Set the Notes field to ItemTemplate and change to edit template view mode.
  3. Drag WebTextEditor control from the Toolbox to the ItemTemplate and InsertItemTemplate of DetailsView.
  4. Set the EnableHTMLView property to false and EnableSplitView property to false under ViewSettings for both WebTextEditor in order to have a simpler look.
  5. Set the content property in WebTextEditor to bind the DetailsView field in the source view. Here is the snippet:

    <ISWebTextEditor:WebTextEditor ID="WebTextEditor1" runat="server" Height="200px" Width="500px" Content='<%# Bind("Notes") %>'
    .
    .
    .
    </ISWebTextEditor:WebTextEditor>

See Also

Tasks
{How-to: Integrate WebTextEditor in Forms View}

Other Resources
{Data Binding}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


How-to: Integrate WebTextEditor in FormView

How-to: Integrate WebTextEditor in FormView
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > Data Binding > How-to: Integrate WebTextEditor in FormView

Glossary Item Box

WebTextEditor can be integrated in FormView control.

In this topic, you will learn how to integrate WebTextEditor in FormView.

To integrate WebTextEditor in FormView

  1. Create a FormView with bounded customer data from Northwind.mdb.
  2. In EditItemTemplate and InsertItemTemplate, drag the WebTextEditor instance from the Toolbox to the EditItemTemplate FormView.

  3. Set the EnableHTMLView property to false and EnableSplitView property to false under ViewSettings; ToolbarMode property to Minimal under ToolbarSettings; Enabled property to False under TaskPaneSettings >> MediaGallery, for both WebTextEditor in order to have a simpler look.
  4. Set the content property in WebTextEditor to bind the FormView field in the source view. Here is the snippet:
    <ISWebTextEditor:WebTextEditor ID="WebTextEditor1" runat="server" Height="200px" Width="500px" Content='<%# Bind("Address") %>'>
    <TaskPaneSettings>
        <MediaGallery Enabled="false" />
    </TaskPaneSettings>
    <ViewSettings EnableHTMLView="false" EnableSplitView="false" />
    <ToolBarSettings ToolBarMode="Minimal" />
</ISWebTextEditor:WebTextEditor>

See Also

Tasks
{How-to: Use WebTextEditor as Item Template of Details View}

Other Resources
{Data Binding}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Mail Merge

Mail Merge
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > Mail Merge

Glossary Item Box

Mail merge is used when you want to send a set of documents that has the same kind of information but personalized for each recipient. To enable Mail Merge in WebTextEditor, simply set MailMergeSettings >> EnableMailMerge to true.

In This Section

Labels

Preview Mail Merge

Send Mail

Mail Merge-related Server-side Event

Walkthrough: Enabling Mail Merge with Data Bound Collection

Walkthrough: Enabling Mail Merge with Custom Collection

See Also

Other Resources
Overview WebTextEditor
{Core Editing Features}
{Sections}
{Text Settings}
{Fluid, Smart ToolBar}
{View}
{Innovative Task Pane}
{Enable Context Menu}
{Integration with FileUploader}
{Integration with WebSpellChecker}
{Data Binding}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Labels

Labels
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > Mail Merge > Labels

Glossary Item Box

A collection of labels can be specified in MailMergeSettings >> Labels property. When the content is sent, the labels will be replaced with its related value in the data context. The data context can be retrieved from data bound collection or custom collection.

Data Bound Collection

If data bound collection is used, each label will represent a specific field in the data source. Several properties that should be specified are:

  • DataSourceID
    Specifies the id of data source

  • DataMember
    Specifies the data member of data source that will be used to retrieve data

Each label can have the following properties:

  • Label
    Specifies the value of the label.

  • DataMember
    Specifies the field in the data context which represents the label.

  • FormatString
    Specifies the format string of the label.

Each label is related to a specific field in data context.

Custom Collection

If the data context is retrieved from a custom collection, each label will represent a specific property in the custom collection. The custom collection should be specified as the value of Recipients property.

WebTextEditor1.MailMergeSettings.Recipients = employees;

Each label can have the following properties:

  • Label
    Specifies the value of the label

  • DataMember
    Specifies the property in the data context which represents the label

  • FormatString
    Specifies the format string of the label

Whether data bound collection or custom collection is used to retrieve the data context, the label replacement will be performed automatically based on the configuration.

The collection of labels in this collection will be added to Label dropdown in main toolbar. User can easily choose one of the labels and add it to WebTextEditor. As a label indicator in editor, any action that could modify it manually will be prevented.

See Also

Other Resources
{Preview Mail Merge}
{Send Mail}
{Mail Merge-related Server-side Event}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Preview Mail Merge

Preview Mail Merge
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > Mail Merge > Preview Mail Merge

Glossary Item Box

When user switches to Preview mode, the labels will automatically be replaced with its related data member in the data context.

Several commands related to mail merge will be added in Preview toolbar. The commands are Send Mail and navigator commands: First, Previous, Next, and Last. User can navigate through the data context using the navigator commands.

See Also

Other Resources
{Labels}
{Send Mail}
{Mail Merge-related Server-side Event}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Send Mail

Send Mail
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > Mail Merge > Send Mail

Glossary Item Box

When the content is ready, it will be mailed when user clicks on SendMail command. Several configurations in MailMergeSettings should be configured:

  • EmailField
    Specifies the field in data context that represent the emails of recipients.

  • AutomaticSendMail
    Specifies whether or not the mail will be sent automatically by WebTextEditor using built-in mechanism. Default value is false.

  • From
    Specifies the sender email.

  • SubjectExpression
    Specifies the subject expression of the email. If this property contains label text, it will automatically be replaced with its related field when the mail is sent.

  • SMTP
    Specifies the SMTP server.

  • IsHTML
    Specifies whether or not the content will be sent as HTML-formatted email.

  • MailPriority
    Specifies the priority of the email.

When the emails failed to be sent to some recipients, it will be indicated in the status bar.

The failed email details can be retrieved in OnSendMailCompleted client-side event. In this event, three parameters will be passed:

  • controlId
    Specifies the id of WebTextEditor.

  • failed
    Specifies the number of emails failed to be sent.

  • failedEmails
    Specifies the emails failed to be sent, as a comma-separated value.

See Also

Other Resources
{Labels}
{Preview Mail Merge}
{Mail Merge-related Server-side Event}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Mail Merge-related Server-side Event

Mail Merge-related Server-side Event
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > Mail Merge > Mail Merge-related Server-side Event

Glossary Item Box

Even though labels will be replaced with its related field in the data context, several other processes might need to be performed during mail merge process. To accommodate this need, two server-side events are added to WebTextEditor:

  • OnMailMerge.
    This event will be invoked when mail merge process is performed in each record of data context.

  • OnMailMergeCompleted.
    This event will be invoked when mail merge process has been completed.

When AutomaticSendMail is set disabled, the custom process can be implemented in the following server-side event. Other custom process during send mail process can also be included in these events.

  • OnSendMail.
    This event will be invoked when each mail is about to be sent.

  • OnSendMailCompleted.
    This event will be invoked after all mail has been sent.

See Also

Other Resources
{Labels}
{Preview Mail Merge}
{Send Mail}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Walkthrough: Using Mail Merge

Walkthrough: Using Mail Merge
Send Feedback
Intersoft WebTextEditor > WebTextEditor > Mail Merge > Walkthrough: Using Mail Merge

Glossary Item Box

This walkthrough shows you how to enable mail merge with data bound collection in WebTextEditor.

During this walkthrough, you will learn how to do the following:

  • Enable mail merge
  • Bound access data source to WebTextEditor for mail merge purpose.
  • Bound custom collection to WebTextEditor for mail merge purpose.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Visual Studio 2008 Application.
  • Mail server for sending the email.
  • Northwind_Extended.mdb.

Step-By-Step Instructions

To enable mail merge with data bound collection

  1. Launch Visual Studio.NET 2008.
  2. Click on File menu, then select New and click Web Site.
  3. Select ASP.NET Web Site in the Template box and set Location to HTTP.
  4. Named the Web Site and click OK.
  5. Right-click on App_Data folder and select Add Existing Item, select Northwind_Extended.mdb from the file explorer.
  6. Right-click on Project's name and select Add New Item.
  7. Select WebForm in the My Templates box and named it as Walkthrough.aspx.
  8. Drag AccessDataSource instance from ToolBar to WebForm.
  9. Set the access data file to Northwind_Extended.mdb located in App_Data folder and select all columns from the Employees table.
  10. Drag WebTextEditor instance from ToolBar to WebForm.
  11. Set the WebTextEditor DataSourceID property to AccessDataSource control.
  12. Enable the MailMerge feature and add the required label for the mail merge in the Labels collection. The EmailField property will bind Email field from the collection. The SubjectExpression property also accepts MailMerge labels.

  13. Set the Content property of the WebTextEditor under the RootTextEditor section for the Mail Merge template. For example:

    <div>
    <span>Intersoft Solutions</span>
    <br />
    <span><em>cordially invites you, <span type="mailmerge">{FirstName}</span> <span type="mailmerge">{LastName}</span>, and your family to our</em></span>
    </div>

    The <span type="mailmerge">{FirstName}</span> will be substitute by the labels declared in the MailMerge WebTextEditor section.

  14. Set EnablePreview to true under the ViewSetting section to enable Mail Merge preview.
  15. Run the sample in Web Browser. Click the [Preview] command to preview the mail.

To enable mail merge with custom collection

  1. Launch Visual Studio.NET 2008.
  2. Click on File menu, then select New and click Web Site.
  3. Select ASP.NET Web Site in the Template box and set Location to HTTP.
  4. Named the Web Site and click OK.
  5. Right-click on Project's name and select Add New Item.
  6. Select WebForm in the My Templates box and named it as Walkthrough.aspx.
  7. Drag WebTextEditor instance from ToolBar to WebForm.
  8. Create a custom object ISEmployee in the WebForm code page. Here is the snippet:
    C# Copy Code
    public class ISEmployee
{
   public int EmployeeID { get; set; }
   public string FirstName { get; set; }
   public string LastName { get; set; }
   public string Address { get; set; }
   public string City { get; set; }
   public string Country { get; set; }
   public string Email { get; set; }
}

  9. Create a function to bind the custom collection to the WebTextEditor control which called during page load server side event. Here is the snippet:
    C# Copy Code
    private void BindCustomCollection()
{
   List employees = new List();
   ISEmployee emp = new ISEmployee();
   emp.EmployeeID = 1;
   emp.FirstName = "Nancy";
   emp.LastName = "Davolio";
   emp.Address = "Bridge Street";
   emp.City = "London";
   emp.Country = "UK";
   emp.Email = "ndavolio@employee.com";
   employees.Add(emp);

   emp = new ISEmployee();
   emp.EmployeeID = 2;
   emp.FirstName = "Andrew";
   emp.LastName = "Fuller";
   emp.Address = "Wood Street";
   emp.City = "Washington";
   emp.Country = "USA";
   emp.Email = "afuller@employee.com";
   employees.Add(emp);
   WebTextEditor1.MailMergeSettings.Recipients = employees;
}

  10. Enable the MailMerge feature and add the required label for the mail merge in the Labels collection. The EmailField property will bind Email field from the collection. The SubjectExpression property also accepts MailMerge labels.

  11. Set the Content property of the WebTextEditor under the RootTextEditor section for the Mail Merge template. For example:

    <div>
    <span>Intersoft Solutions</span>
    <br />
    <span><em>cordially invites you, <span type="mailmerge">{FirstName}</span> <span type="mailmerge">{LastName}</span>, and your family to our</em></span>
    </div>

    The <span type="mailmerge">{FirstName}</span> will be substitute by the labels declared in the MailMerge WebTextEditor section.

  12. Set EnablePreview to true under the ViewSetting section to enable Mail Merge preview.

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Walkthrough: Enabling Mail Merge with Data Bound Collection

Walkthrough: Enabling Mail Merge with Data Bound Collection
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > Mail Merge > Walkthrough: Enabling Mail Merge with Data Bound Collection

Glossary Item Box

This walkthrough shows you how to enable mail merge with data bound collection in WebTextEditor.

During this walkthrough, you will learn how to do the following:

  • Enable mail merge
  • Bound access data source to WebTextEditor for mail merge purpose.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Visual Studio 2008 Application.
  • Mail server for sending the email
  • Northwind_Extended.mdb

Step-By-Step Instructions

To enable mail merge with data bound collection

  1. Launch Visual Studio.NET 2008.
  2. Click on File menu, then select New and click Web Site.
  3. Select ASP.NET Web Site in the Template box and set Location to HTTP.
  4. Named the Web Site and click OK.
  5. Right-click on App_Data folder and select Add Existing Item, select Northwind_Extended.mdb from the file explorer.
  6. Right-click on Project's name and select Add New Item.
  7. Select WebForm in the My Templates box and named it as Walkthrough.aspx.
  8. Drag AccessDataSource instance from ToolBar to WebForm.
  9. Set the access data file to Northwind_Extended.mdb located in App_Data folder and select all columns from the Employees table.
  10. Drag WebTextEditor instance from ToolBar to WebForm.
  11. Set the WebTextEditor DataSourceID property to AccessDataSource control.
  12. Enable the MailMerge feature and add the required label for the mail merge in the Labels collection. The EmailField property will bind Email field from the collection. The SubjectExpression property also accepts MailMerge labels.

  13. Set the Content property of the WebTextEditor under the RootTextEditor section for the Mail Merge template. For example:

    <div><span>Intersoft Solutions</span><br /><span><em>cordially invites you, <span type="mailmerge">{FirstName}</span> <span type="mailmerge">{LastName}</span>, and your family to our</em></span></div>
    The <span type="mailmerge">{FirstName}</span> will be substitute by the labels decalred in the MailMerge WebTextEditor section.

  14. Set EnablePreview to true under the ViewSetting section to enable Mail Merge preview.
  15. Run the sample in Web Browser. Click the [Preview] command to preview the mail.

See Also

Tasks
{Walkthrough: Enabling Mail Merge with Custom Collection}

Other Resources
Mail Merge

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Walkthrough: Enabling Mail Merge with Custom Collection

Walkthrough: Enabling Mail Merge with Custom Collection
See Also Send Feedback
Intersoft WebTextEditor > WebTextEditor > Mail Merge > Walkthrough: Enabling Mail Merge with Custom Collection

Glossary Item Box

This walkthrough shows you how to enable mail merge with custom collection in WebTextEditor.

During this walkthrough, you will learn how to do the following:

  • Enable mail merge
  • Bound custom collection to WebTextEditor for mail merge purpose.

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Visual Studio 2008 Application.
  • Mail server for sending the email

Step-By-Step Instructions

To enable mail merge with custom collection

  1. Launch Visual Studio.NET 2008.
  2. Click on File menu, then select New and click Web Site.
  3. Select ASP.NET Web Site in the Template box and set Location to HTTP.
  4. Named the Web Site and click OK.
  5. Right-click on Project's name and select Add New Item.
  6. Select WebForm in the My Templates box and named it as Walkthrough.aspx.
  7. Drag WebTextEditor instance from ToolBar to WebForm.
  8. Create a custom object ISEmployee in the WebForm code page. Here is the snippet:
    C# Copy Code

    publicclass ISEmployee

    {
       public int EmployeeID { get; set; }
       public string FirstName { get; set; }
       public string LastName { get; set; }
       public string Address { get; set; }
       public string City { get; set; }
       public string Country { get; set; }
       public string Email { get; set; }
    }

  9. Create a function to bind the custom collection to the WebTextEditor control which called during page load server side event. Here is the snippet:
    C# Copy Code

    private void BindCustomCollection()

    {

       List<ISEmployee> employees = new List<ISEmployee>();

        ISEmployee emp = new ISEmployee();

       emp.EmployeeID = 1;

       emp.FirstName = "Nancy";

       emp.LastName = "Davolio";

       emp.Address = "Bridge Street";

       emp.City = "London";

       emp.Country = "UK";

       emp.Email = "ndavolio@employee.com";

       employees.Add(emp);

        emp = new ISEmployee();

       emp.EmployeeID = 2;

       emp.FirstName = "Andrew";

       emp.LastName = "Fuller";

       emp.Address = "Wood Street";

       emp.City = "Washington";

       emp.Country = "USA";

       emp.Email = "afuller@employee.com";

       employees.Add(emp);

        WebTextEditor1.MailMergeSettings.Recipients = employees;

    }

  10. Enable the MailMerge feature and add the required label for the mail merge in the Labels collection. The EmailField property will bind Email field from the collection. The SubjectExpression property also accepts MailMerge labels.

  11. Set the Content property of the WebTextEditor under the RootTextEditor section for the Mail Merge template. For example:

    <div><span>Intersoft Solutions</span><br /><span><em>cordially invites you, <span type="mailmerge">{FirstName}</span> <span type="mailmerge">{LastName}</span>, and your family to our</em></span></div>
    The <span type="mailmerge">{FirstName}</span> will be substitute by the labels decalred in the MailMerge WebTextEditor section.

  12. Set EnablePreview to true under the ViewSetting section to enable Mail Merge preview.

See Also

Tasks
{Walkthrough: Enabling Mail Merge with Data Bound Collection}

Other Resources
{Mail Merge}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


WebSpellChecker OverView

WebSpellChecker OverView
See Also Send Feedback
Intersoft WebTextEditor > WebSpellChecker OverView

Glossary Item Box

Intersoft WebSpellChecker is an easy-to-use, yet powerful spell checking component for ASP.NET. In addition to typical spell check features that you expected, WebSpellChecker delivers several innovative features that are not available elsewhere, such as Microsoft Word-style red-wave underline highlight, built-in dialogbox with intuitive design, natural integration with WebTextEditor, wide cross browsers support and more.

See Also

Other Resources
User Interface
{Maximum text suggestion}
{WebSpellChecker options}
{Use WebSpellChecker with other controls}
{Images settings}
{Text settings}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


User Interface

User Interface
See Also Send Feedback
Intersoft WebTextEditor > WebSpellChecker > User Interface

Glossary Item Box

Intersoft WebSpellChecker is the first spell checker component in the industry to provide two modes of spell checking user interface.

  1. Red-wave Underline Highlight
    WebSpellChecker introduces more natural, intuitive way to perform spell checking with red wave highlight feature. To correct misspelled words, just right click on each word and choose the correct word from the displayed context menu. It makes spell checking faster and easier than ever.

    The red wave highlight feature can only be enabled on editable IFRAME.

  2. Sleek Dialog Box Interface
    This mode will be automatically enabled when the target control is not an editable IFRAME. The dialog box interface includes visual elements that display checked words and the suggestion words list. Just double click on a word in suggestion list or click on the Change button to correct the misspelled word with the selected suggested word, and finally click on Done button to accept all changes and close the dialog box.

In This Section

How-to: Implement spell checker with red wave highlight

How-to: Implement spell checker with WebDialogBox

See Also

Other Resources
Overview WebSpellChecker
{Maximum text suggestion}
{WebSpellChecker options}
{Use WebSpellChecker with other controls}
{Images settings}
{Text settings}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


How-to: Implement spell checker with red wave highlight

How-to: Implement spell checker with red wave highlight
See Also Send Feedback
Intersoft WebTextEditor > WebSpellChecker > User Interface > How-to: Implement spell checker with red wave highlight

Glossary Item Box

WebSpellChecker provides a method to implement spell checker with red wave highlight.

In this topic, you will learn how to implement spell checker.

To implement spell checker with red wave highlight

  1. Create an editable IFRAME.
  2. Drag HTML button and WebSpellChecker controls to the WebForm.
  3. Set WebSpellChecker's TargetControlId property to IFRAME's id and TargetControlIdValue to innerHTML.
  4. Create a function called AddSpellChecker() and use CheckSpell() method to implement spell checker.
    JavaScript Copy Code
    function AddSpellChecker()
{
   var sp = ISGetObject("WebSpellChecker1");
   var text = sp.CheckSpell();
}

  5. Invoke AddSpellChecker() function from HTML button.

See Also

Tasks
{How-to: Implement spell checker with WebDialogBox}

Other Resources
{User Interface}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


How-to: Implement spell checker with WebDialogBox

How-to: Implement spell checker with WebDialogBox
See Also Send Feedback
Intersoft WebTextEditor > WebSpellChecker > User Interface > How-to: Implement spell checker with WebDialogBox

Glossary Item Box

WebSpellChecker provides a method to implement spell checker with WebDialogBox.

In this topic, you will learn how to implement spell checker.

To implement spell checker with WebDialogBox

  1. Create a div and HTML button.
  2. Drag WebSpellChecker control to WebForm.
  3. Set WebSpellChecker's TargetControlId property to the DIV's id.
  4. Set the DIV's text/value property. Since the content of DIV is stored in innerHTML property, then set TargetControlIdValue property to innerHTML for WebSpellChecker to be able to function properly.
  5. Create a function called AddSpellChecker() and use CheckSpell() method to implement spell checker.
    JavaScript Copy Code
    function CheckSpell()
{
   var sp = ISGetObject("WebSpellChecker1");
   sp.CheckSpell();
}

  6. Invoke AddSpellChecker() from the HTML button.

See Also

Tasks
{How-to: Implement spell checker with red wave highlight}

Other Resources
{User Interface}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Maximum text suggestion

Maximum text suggestion
See Also Send Feedback
Intersoft WebTextEditor > WebSpellChecker > Maximum text suggestion

Glossary Item Box

You can configure the number of maximum text suggestion for each misspelled word by specifying the MaximumTextSuggestion property to an integer value. The default value of maximum text suggestion is 10.

In This Section

How-to: Customize maximum text suggestion

See Also

Other Resources
Overview WebSpellChecker
User Interface
{WebSpellChecker options}
{Use WebSpellChecker with other controls}
{Images settings}
{Text settings}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


How-to: Customize maximum text suggestion

How-to: Customize maximum text suggestion
See Also Send Feedback
Intersoft WebTextEditor > WebSpellChecker > Maximum text suggestion > How-to: Customize maximum text suggestion

Glossary Item Box

WebSpellChecker provides a method to customize maximum text suggestion.

In this topic, you will learn how to customize maximum text suggestion.

To customize maximum text suggestion

  1. Create a textbox and HTML button.
  2. Drag WebSpellChecker control to WebForm.
  3. Set WebSpellChecker's TargetControlId property to the TextBox's id.
  4. Set TargetControlIdValue property to value.
  5. Set MaximumTextSuggestion to 5.
  6. Create a function called AddSpellChecker() and use CheckSpell() method to implement spell checker.
    JavaScript Copy Code
    function CheckSpell()
{
   var sp = ISGetObject("WebSpellChecker1");
   sp.CheckSpell();
}

  7. Invoke AddSpellChecker() from the HTML button.

See Also

Other Resources
{Maximum text suggestion}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


WebSpellChecker options

WebSpellChecker options
See Also Send Feedback
Intersoft WebTextEditor > WebSpellChecker > WebSpellChecker options

Glossary Item Box

User interaction on WebSpellChecker can be done through several options available in the context menu interface or in WebDialogBox interface.

Here are the options:

Change

Add to dictionary

Ignore

Ignore All

See Also

Other Resources
Overview WebSpellChecker
User Interface
{Maximum text suggestion}
{Images settings}
{Text settings}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Change

Change
See Also Send Feedback
Intersoft WebTextEditor > WebSpellChecker > WebSpellChecker options > Change

Glossary Item Box

This option is only available in WebDialogBox mode; it is used to change the selected misspelled word with the selected suggested word.

Alternatively, you can correct the misspelled word by simply double clicking on the suggested word.

See Also

Other Resources
{Add to dictionary}
{Ignore}
{Ignore All}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Add to dictionary

Add to dictionary
See Also Send Feedback
Intersoft WebTextEditor > WebSpellChecker > WebSpellChecker options > Add to dictionary

Glossary Item Box

Often times, WebSpellChecker may show specific terms such as scientific or other valid words as misspelled words. This occurred because the specific words don't exist in dictionary. WebSpellChecker makes it possible for users to add such words into dictionary, so that WebSpellChecker will not mark it as misspelled word again in the future. To add word to a dictionary, simply right click on the specific word and choose "Add to dictionary" option in the context menu.

In order to add to dictionary, the dictionary folder's permission should be granted with write access.

See Also

Other Resources
{Change}
{Ignore}
{Ignore All}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Ignore

Ignore
See Also Send Feedback
Intersoft WebTextEditor > WebSpellChecker > WebSpellChecker options > Ignore

Glossary Item Box

This command is used in a scenario where user would like WebSpellChecker to ignore a misspelled word so it will be marked as correct word instead of misspelled. If there are other similar words, WebSpellChecker will not mark other instances as correct word.

This command is available in both context menu and dialog box interface.

See Also

Other Resources
{Change}
{Add to dictionary}
{Ignore All}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Ignore All

Ignore All
See Also Send Feedback
Intersoft WebTextEditor > WebSpellChecker > WebSpellChecker options > Ignore All

Glossary Item Box

Similar with Ignore command, "Ignore all" will mark the misspelled word to correct word. The only difference is "Ignore all" will mark all similar words as correct words, instead of just the selected word.

See Also

Other Resources
{Change}
{Add to dictionary}
{Ignore}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Use WebSpellChecker with other controls

Use WebSpellChecker with other controls
See Also Send Feedback
Intersoft WebTextEditor > WebSpellChecker > Use WebSpellChecker with other controls

Glossary Item Box

Integration between WebSpellChecker with other controls is made easy and simple. It is controlled with two properties, TargetControlId and TargetControlIdValue.

In This Section

TargetControlId

TargetControlIdValue

See Also

Other Resources
Overview WebSpellChecker
{User Interface}
{Maximum text suggestion}
{WebSpellChecker options}
{Images settings}
{Text settings}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


TargetControlId

TargetControlId
See Also Send Feedback
Intersoft WebTextEditor > WebSpellChecker > Use WebSpellChecker with other controls > TargetControlId

Glossary Item Box

This property is required to determine the target control for spell check. For instance, TargetControlId should be filled with "TextBox1" value if you would like to spell check on TextBox1 control.

See Also

Other Resources
{TargetControlIdValue}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


TargetControlIdValue

TargetControlIdValue
See Also Send Feedback
Intersoft WebTextEditor > WebSpellChecker > Use WebSpellChecker with other controls > TargetControlIdValue

Glossary Item Box

This property determines the client-side property of the element from which WebSpellChecker should obtain the value for spell check. It's important to note that the value or content property should be accessible from client-side. For instance, if WebSpellChecker is targetting TextBox server side control, then the TargetControlIdValue property should be set to "value" instead of "Text".

Integration between WebSpellChecker and WebTextEditor is slightly different as you don�??t need to specify TargetControlIdValue property. Instead, please set the IntegratedToWebTextEditor property to true and TargetControlId property to the ID of WebTextEditor. For further information about this integration, please refer to Integration with WebSpellChecker topic in WebTextEditor User Interface whitepaper.

See Also

Other Resources
{TargetControlId}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Images settings

Images settings
See Also Send Feedback
Intersoft WebTextEditor > WebSpellChecker > Images settings

Glossary Item Box

WebSpellChecker provides highly customizable settings for images, which can be done in ImagesSettings property.

Here is the list of customizable images in WebSpellChecker:

Category | Image Setting Key | Default Image Setting Value
Misspell Highlight line | ErrorLine | red_underline.gif
WebDialogBox inprogres image | InProgress | inprogress.gif

See Also

Other Resources
Overview WebSpellChecker
{User Interface}
{Maximum text suggestion}
{WebSpellChecker options}
{Use WebSpellChecker with other controls}
{Text settings}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Text settings

Text settings
See Also Send Feedback
Intersoft WebTextEditor > WebSpellChecker > Text settings

Glossary Item Box

Similar to other WebUI Studio® member, all textual settings in WebSpellChecker can be customized via TextSettings property.

The following is the list of customizable textual settings in WebSpellChecker:

Category | Image Setting Key | Default Image Setting Value
Context Menu | AddToDictionaryText | Add to dictionary
 | IgnoreAllText | Ignore all
 | IgnoreText | Ignore

See Also

Other Resources
Overview WebSpellChecker
{User Interface}
Maximum text suggestion
{WebSpellChecker options}
{Use WebSpellChecker with other controls}
{Images settings}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


WebFileUploader

WebFileUploader
See Also Send Feedback
Intersoft WebTextEditor > WebFileUploader

Glossary Item Box

Intersoft WebFileUploader is a memory-efficient ASP.NET file uploading component that supports asynchronous multiple files upload without page refresh. Unlike standard ASP.NET file uploader, WebFileUploader enables large file uploading with very minimum memory and resources consumption.

WebFileUploader introduces revolutionary experiences which enables you to select multiple files in a single instance and shows uploading progress in real time - making file uploading more intuitive, simpler and faster than ever. Furthermore, it also allows you to abort currently uploaded file, or cancel the pending uploads.

Intersoft WebFileUploader naturally integrates advanced uploading features with sophisticated user experiences, making file uploading more intuitive, faster and hassle-free.

Best of all, WebFileUploader uses 100% HTML technology for all its features, and fully supports all modern browsers including Firefox, Safari, Chrome and Opera. By 100% HTML technology, it means that WebFileUploader doesn't require Flash plug-in to support multiple files uploading and many other features that are previously only possible to be achieved with Flash plug-in - making WebFileUploader the most advanced, powerful and reliable file uploading component for the ASP.NET platform.

See Also

Other Resources
Concept
{Features}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Concept

Concept
Send Feedback
Intersoft WebTextEditor > WebFileUploader > Concept

Glossary Item Box

WebFileUploader is an easy to use; high performance and advanced file upload component which allows you to upload multiple files without page refresh.

This section explains the fundamental concept of WebFileUploader to help you understand how it works, and to enable you leveraging many of its advanced features for your web application.

In This Section

User Interface

Upload Mode

User Interactions and Events

File Validation

Progress Bar

Customization

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


User Interface

User Interface
See Also Send Feedback
Intersoft WebTextEditor > WebFileUploader > Concept > User Interface

Glossary Item Box

WebFileUploader includes two user interface layout, panel and attachment bar.

Panel user interface layout provides rich user interface upload elements. There are checkbox, textbox, selection button, add button, remove button, upload button, cancel all button, upload button. With panel layout, you can easily perform file selection, and then uploading multiple files, or cancelling running uploads.

Panel layout provides users with richer uploading experiences

AttachmentBar user interface layout is state-of-the-art design that minimizes the form of WebUploader component, making efficient use of screen real estate. It is specifically designed for attachment box in data entry form for uploading attachment files.

Perfect for data entry form with limited space, Attachment layout brings powerful multiple file
uploading capabilities into a compact, minimal user interface.

See Also

Other Resources
Upload Mode
{User Interactions and Events}
{File Validation}
{Progress Bar}
{Customization}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Upload Mode

Upload Mode
See Also Send Feedback
Intersoft WebTextEditor > WebFileUploader > Concept > Upload Mode

Glossary Item Box

WebFileUploader comes with two uploading mode, automatic and batch upload.

Automatic mode will automatically perform file uploading after a file is selected, while batch upload allows you to select several files and then upload them together in a single session.

For batch upload mode, WebFileUploader provides customizable upload priority, such as priority by series, or by type.

See Also

Other Resources
{User Interface}
{File Validation}
{Progress Bar}
{Customization}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


User Interactions and Events

User Interactions and Events
See Also Send Feedback
Intersoft WebTextEditor > WebFileUploader > Concept > User Interactions and Events

Glossary Item Box

WebFileUploader is designed with robust architecture which allows various user interactions. Each interaction is properly recorded as status in the client object model, enabling you to easily inspect on the interaction status.

WebFileUploader provides the following interactions:

  • File selecting
  • File selected
  • File added
  • File removed
  • File about to upload
  • File uploading
  • File uploaded
  • File canceled
  • File aborted

In addition, WebFileUploader provides comprehensive client-side and server-side events which allow developers to perform additional processing or customization during the event. Some available events are before upload, uploading, after upload, and error event. Please refer to client-side and server-side reference for more details.

See Also

Other Resources
{User Interface}
{Upload Mode}
{File Validation}
{Progress Bar}
{Customization}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


File Validation

File Validation
See Also Send Feedback
Intersoft WebTextEditor > WebFileUploader > Concept > File Validation

Glossary Item Box

WebFileUploader provides several built-in validations enabling you to easily limit files to be uploaded. You can validate files by type, redundant file, size and custom. In Panel layout, an error indicator will appear when invalid file is selected.

See Also

Other Resources
{User Interface}
{Upload Mode}
{User Interactions and Events}
{Progress Bar}
{Customization}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Progress Bar

Progress Bar
See Also Send Feedback
Intersoft WebTextEditor > WebFileUploader > Concept > Progress Bar

Glossary Item Box

One of the key features in WebFileUploader is its ability to show uploading progress in real-time. WebFileUploader provides rich user interface for progress bars. Each uploaded file has its own progress bar, and another total progress bar that shows uploading progress in overall.

Furthermore, you can show progress information by completion percentage, by size or by time remaining.

See Also

Other Resources
{User Interface}
{Upload Mode}
{User Interactions and Events}
{File Validation}
{Customization}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Customization

Customization
See Also Send Feedback
Intersoft WebTextEditor > WebFileUploader > Concept > Customization

Glossary Item Box

Customizing the look and appearance of WebFileUploader is easy and straightforward with skin and localization. WebFileUploader provides styling for user interface elements such as frame, textbox, button, text and more.

Localization is also supported with text properties such as caption, tooltips, and texts and more. The text properties can be found in TextSettings object of the control.

WebFileUploader allows you to completely customize its appearance and textual settings

See Also

Other Resources
{User Interface}
{Upload Mode}
{User Interactions and Events}
{File Validation}
{Progress Bar}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Features

Features
See Also Send Feedback
Intersoft WebTextEditor > WebFileUploader > Features

Glossary Item Box

WebFileUploader includes many advanced features to address the most demanding file uploading requirements such as discussed in the following.

In This Section

Large files uploading with minimal resources consumption

IIS 6 and IIS 7 Integrated mode support

WebFarm and multiple worker requests support with built-in FileStateServer

Rich user experiences

Built-in file saving

Real-time progress bar

Upload

Client-side events

Server-side events

Initial files count

Limit upload files by type, count or custom

Limit upload size and total upload size

See Also

Other Resources
{Overview}
{Concept}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Large files uploading with minimal resources consumption

Large files uploading with minimal resources consumption
See Also Send Feedback
Intersoft WebTextEditor > WebFileUploader > Features > Large files uploading with minimal resources consumption

Glossary Item Box

The standard ASP.NET file upload component will often failed when you tried to upload large files, for instance, a 10 mb file. Two of the most common errors are request time out and out of memory error. That happened because the standard file uploading implementation in ASP.NET requires the file to be entirely uploaded before it returns a response to the client side.

WebFileUploader takes advantage of HttpModule technology to handle large file upload with a more sophisticated implementation that doesn't perform memory-level buffering. As the result, WebFileUploader can handle large file uploads with very minimal memory and resources consumption.

By default, ASP.NET application restricts maximum request length to 4MB. To enable your application to accept larger files, please configure the maxRequestLength in web.config to higher value. The maxRequestLength value is measured in kilobytes.

The following configuration sets the application to allow file upload with size up to 100MB.

< configuration >

    < system.web >

        < httpRuntime maxRequestLength = "102400" />

    </ system.web >

</ configuration >

For IIS 7.0, there are additional settings that need to be configured.

  1. Set maxAllowedContentLength to a higher value, which is measured in bytes

    Open your application's web.config file, and add the following.

    < system.webServer >

        < security >

          < requestFiltering >

            < requestLimits maxAllowedContentLength = "102400000" />    </requestFiltering >

        </ security >

    </ system.webServer >

  2. Unlock the mode override in applicationHost.config

    Open IIS 7 application configuration file which is usually located in C:\windows\system32\inetsrv\config, and change the overrideModeDefault to Allow, such as shown in the following.

    < section name = "requestFiltering" overrideModeDefault="Allow" />

See Also

Other Resources
{IIS 6 and IIS 7 Integrated mode support}
{Webfarm and multiple worker requests support with built-in FileStateServer}
{Rich user experiences}
{Built-in file saving}
{Real-time progress bar}
{Upload}
{Client-side events}
{Server-side events}
{Initial files count}
{Limit upload files by type, count, or custom}
{Limit upload size and total upload size}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


IIS 6 and IIS 7 Integrated mode support

IIS 6 and IIS 7 Integrated mode support
See Also Send Feedback
Intersoft WebTextEditor > WebFileUploader > Features > IIS 6 and IIS 7 Integrated mode support

Glossary Item Box

WebFileUploader is built upon http module to provide reliable, memory-efficient implementation for large file uploads support. In addition, it also relies on http handler to support many advanced features such ability to abort currently uploaded files, cancel other pending uploads, and more.

To use WebFileUploader in ASP.NET application that target IIS 6, please add the following entries to your web.config.

  • Add WebFileUploader hander to <httpHanders> section:

    <add verb = "GET" path="WebFileUploaderHttpHandler.axd" validate="false" type="ISNet.WebUI.WebTextEditor.WebFileUploaderHttpHandler, ISNet.WebUI.WebTextEditor" />

  • Add WebFileUploader module to <httpModules> section

    <add name = "WebFileUploaderHttpModule" type="ISNet.WebUI.WebTextEditor.WebFileUploaderHttpModule, ISNet.WebUI.WebTextEditor">

The following configuration applies for ASP.NET application that target IIS 7.

  • Add WebFileUploader hander to <handlers> section  under <system.webServer>:

    <add name = "WebFileUploaderHttpHandler" verb="GET" path="WebFileUploaderHttpHandler.axd" type="ISNet.WebUI.WebTextEditor.WebFileUploaderHttpHandler, ISNet.WebUI.WebTextEditor" preCondition="integratedMode" />

  • Add WebFileUploader module to <modules> section under <system.webServer>:

    <add name = "WebFileUploaderHttpModule" preCondition="managedHandler" type="ISNet.WebUI.WebTextEditor.WebFileUploaderHttpModule, ISNet.WebUI.WebTextEditor">

In This Section

How-to: Configure WebFileUploader for IIS 6 application

How-to: Configure WebFileUploaded for IIS 7 application

See Also

Other Resources
{Large files uploading with minimal resources consumption}
{Webfarm and multiple worker requests support with built-in FileStateServer}
{Rich user experiences}
{Built-in file saving}
{Real-time progress bar}
{Upload}
{Client-side events}
{Server-side events}
{Initial files count}
{Limit upload files by type, count, or custom}
{Limit upload size and total upload size}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


How-to: Configure WebFileUploader for IIS 6 application

How-to: Configure WebFileUploader for IIS 6 application
See Also Send Feedback
Intersoft WebTextEditor > WebFileUploader > Features > IIS 6 and IIS 7 Integrated mode support > How-to: Configure WebFileUploader for IIS 6 application

Glossary Item Box

Some configuration is needed in the web.config to run WebFileUploader in IIS6.

In this topic, you will learn how to configure web.config.

To configure WebFileUploader for IIS 6 application

  1. By default, ASP.NET application restricts maximum request length to 4MB. To enable your application to accept larger files, please configure the maxRequestLength in web.config to higher value. The maxRequestLength value is measured in kilobytes. Here is a snippet to increase your file size to 100MB:
    <configuration>
    <system.web>
        <httpRuntime maxRequestLength="102400" />
    </system.web>
</configuration>
  2. Add WebFileUploader handler to <httpHandlers> section in your project web.config. Here is the snippet:
    <add verb="GET" path="WebFileUploaderHttpHandler.axd" validate="false" type="ISNet.WebUI.WebTextEditor.WebFileUploaderHttpHandler, ISNet.WebUI.WebTextEditor" />
  3. Add WebFileUploader module to <httpModules> section in your project web.config. Here is the snippet:
    <add name="WebFileUploaderHttpModule" type="ISNet.WebUI.WebTextEditor.WebFileUploaderHttpModule, ISNet.WebUI.WebTextEditor" />

See Also

Tasks
{How-to: Configure WebFileUploader for IIS 7 application}

Other Resources
{IIS 6 and IIS 7 Integrated mode support}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


How-to: Configure WebFileUploader for IIS 7 application

How-to: Configure WebFileUploader for IIS 7 application
See Also Send Feedback
Intersoft WebTextEditor > WebFileUploader > Features > IIS 6 and IIS 7 Integrated mode support > How-to: Configure WebFileUploader for IIS 7 application

Glossary Item Box

Some configuration is needed in the web.config to run WebFileUploader in IIS7.

=In this topic, you will learn how to configure web.config.

To configure WebFileUploader for IIS 7 application

  1. Follow the configuration required to run WebFileUploader in IIS6.
  2. Set maxAllowedContentLength to a higher value, which is measured in bytes, to 100MB in web.config. Here is the snippet:
    <system.webServer>
    <security>
      <requestFiltering>
        <requestLimits maxAllowedContentLength="104857600" />    </requestFiltering>
    </security>
</system.webServer>
  3. Unlock the mode override in applicationHost.config. Open IIS 7 application configuration file, default location in C:\windows\system32\inetsrv\config, and change the overrideModeDefault to Allow. Here is the snippet:
    <section name="requestFiltering" overrideModeDefault="Allow" />
  4. Add WebFileUploader handler to <handlers> section under <system.webServer>. Here is the snippet:
    <add name="WebFileUploaderHttpHandler" verb="GET" path="WebFileUploaderHttpHandler.axd" type="ISNet.WebUI.WebTextEditor.WebFileUploaderHttpHandler, ISNet.WebUI.WebTextEditor" preCondition="integratedMode" />
  5. Add WebFileUploader module to <modules> section under <system.webServer>. Here is the snippet:
    <add name="WebFileUploaderHttpModule" preCondition="managedHandler" type="ISNet.WebUI.WebTextEditor.WebFileUploaderHttpModule, ISNet.WebUI.WebTextEditor" />

See Also

Tasks
{How-to: Configure WebFileUploader for IIS 6 application}

Other Resources
{IIS 6 and IIS 7 Integrated mode support}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


WebFarm and multiple worker requests support with built-in FileStateServer

WebFarm and multiple worker requests support with built-in FileStateServer
See Also Send Feedback
Intersoft WebTextEditor > WebFileUploader > Features > WebFarm and multiple worker requests support with built-in FileStateServer

Glossary Item Box

Due to AJAX uploading mechanism, most file upload components will fail to work when the application is used in webfarm environment, or in server running multiple worker requests.

When running your application in such configuration, the load balancer automatically redirects the AJAX request to one of the available servers which may not be the originating server that receives the upload data. This mechanism affects the file upload component since the AJAX request may receive invalid response and thus unable to obtain the required upload information which finally failing the progress bar.

Intersoft WebFileUploader addressed this limitation elegantly with its high-performance, reliable FileStateServer technology. When using FileStateServer, WebFileUploader streamlines all required uploading information in its state server, making it possible for AJAX request to receive real-time synchronized information regardless of the server that process the request.

To enable FileStateServer in WebFileUploader to support webfarm configuration, simply add the following entries to your web.config:

<add key = "ISNet.WebUI.WebFileUploader.ContextStorage"

value = "FileServer" />

<add key = "ISNet.WebUI.WebFileUploader.ContextStorageFileServer"

value = "path=\\Server\ContextUploadStorage" />

Make sure all your load balanced servers have the permissions and sufficient security settings to access the server and the shared resource. You may need to provide network credentials in your web.config to allow your application to access the specified server resource.

See Also

Other Resources
{Large files uploading with minimal resources consumption}
{IIS 6 and IIS 7 Integrated mode support}
{Rich user experiences}
{Built-in file saving}
{Real-time progress bar}
{Upload}
{Client-side events}
{Server-side events}
{Initial files count}
{Limit upload files by type, count, or custom}
{Limit upload size and total upload size}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Rich user experiences

Rich user experiences
See Also Send Feedback
Intersoft WebTextEditor > WebFileUploader > Features > Rich user experiences

Glossary Item Box

Sophisticatedly-designed interfaces and state-of-the-art experiences are what set WebFileUploader apart from other similar component in the industry. It provides end-to-end user experiences which makes file uploading easier and more intuitive than ever.

WebFileUploader comes with two user interface for file uploading, panel layout and attachment bar layout.

In This Section

Panel Layout Mode

Attachment Layout Mode

See Also

Other Resources
{Large files uploading with minimal resources consumption}
{IIS 6 and IIS 7 Integrated mode support}
{Webfarm and multiple worker requests support with built-in FileStateServer}
{Built-in file saving}
{Real-time progress bar}
{Upload}
{Client-side events}
{Server-side events}
{Initial files count}
{Limit upload files by type, count, or custom}
{Limit upload size and total upload size}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Panel Layout Mode

Panel Layout Mode
See Also Send Feedback
Intersoft WebTextEditor > WebFileUploader > Features > Rich user experiences > Panel Layout Mode

Glossary Item Box

The panel layout provides more comprehensive visual elements, and therefore is more suitable for uploading form. The panel layout offers streamlined user experiences such as explained below.

In This Section

Selection Experience

Uploading Experience

Completion Experience

See Also

Other Resources
{Attachment Layout Mode}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Selection Experience

Selection Experience
See Also Send Feedback
Intersoft WebTextEditor > WebFileUploader > Features > Rich user experiences > Panel Layout Mode > Selection Experience

Glossary Item Box

  • Upload visual elements are arranged elegantly, makes it intuitive to users.
  • When a validation error occurred, an error indicator is shown next to the Select button, makes it easy for users to notice the validation error. When hovered, the error message will be shown in the tooltip.

See Also

Other Resources
{Uploading Experience}
{Completion Experience}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Uploading Experience

Uploading Experience
See Also Send Feedback
Intersoft WebTextEditor > WebFileUploader > Features > Rich user experiences > Panel Layout Mode > Uploading Experience

Glossary Item Box

  • When a file upload is in progress, a progress bar will be shown next to it displaying the current upload progress.
  • Intuitive status indicators make it easy for users to understand the file upload status. Successfully uploaded files will be marked with success indicator, as well as failed or canceled files. To see the error message of failed upload, simply mouse over on the error indicator.
  • User can abort the currently uploaded file by clicking on the Abort button next to the progress bar. When an upload is aborted, WebFileUploader will process to the next pending uploads.
  • User can also cancel pending uploads by clicking on the Cancel button. Ultimately, user can click on Cancel All button in the status area to cancel all uploads. When cancel all is invoked, WebFileUploader will delete the successfully uploaded files, abort the current file in progress, and cancel pending uploads.
  • The overall progress bar is shown in the status area displaying the total progress of all uploads. Hover on the overall progress bar area to see the detailed progress information.

See Also

Other Resources
{Selection Experience}
{Completion Experience}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Completion Experience

Completion Experience
See Also Send Feedback
Intersoft WebTextEditor > WebFileUploader > Features > Rich user experiences > Panel Layout Mode > Completion Experience

Glossary Item Box

  • When the upload session is completed, WebFileUploader sets the user interface to summary state, where the status area now displays the summary of the file uploads.
  • The Start Over button is made visible in this state. When clicked, WebFileUploader will reset its state back to Selection Experience, making the file uploader ready to be used for the next upload session.

See Also

Other Resources
{Selection Experience}
{Uploading Experience}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Attachment Layout Mode

Attachment Layout Mode
See Also Send Feedback
Intersoft WebTextEditor > WebFileUploader > Features > Rich user experiences > Attachment Layout Mode

Glossary Item Box

Similar to the experiences in Panel layout mode above, Attachment layout mode also provides streamlined user experience that makes uploading easy even in compact user interface such as explained below.

In This Section

Selection Experience

Uploading Experience

Completion Experience

Walkthrough: Using WebFileUploader with Attachment BarUI

See Also

Other Resources
{Panel Layout Mode}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Selection Experience

Selection Experience
See Also Send Feedback
Intersoft WebTextEditor > WebFileUploader > Features > Rich user experiences > Attachment Layout Mode > Selection Experience

Glossary Item Box

  • Powerful uploading capabilities packed in minimal, fluid user interfaces.
  • The attachment layout has only a button to attach a file. When selected, the file will be added to the main fluid container. The container will grow or shrink automatically as you add or remove files.
  • To remove a file, simply click on the red X button, or select the file with a mouse click then press Delete button.
  • The attachment layout doesn't include the command to perform uploading process. This is by design due to the nature of the user interface. In most cases, you may already have a button to perform data saving, where you can call WebFileUploader's client-side API to programmatically perform file uploading.

See Also

Tasks
{Walkthrough: Using WebFileUploader with AttachmentBar UI}

Other Resources
{Uploading Experience}
{Completion Experience}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Uploading Experience

Uploading Experience
See Also Send Feedback
Intersoft WebTextEditor > WebFileUploader > Features > Rich user experiences > Attachment Layout Mode > Uploading Experience

Glossary Item Box

  • WebFileUploader makes efficient use of screen real estate smartly by reusing the space of unnecessary existing visual elements according to the upload context.
  • Status indicators will be shown next to the file. Simply hover on it to see its detailed status information.
  • To cancel pending uploads, simply click on the red X button. User can also cancel all uploads by clicking on the Cancel All button.

See Also

Tasks
{Walkthrough: Using WebFileUploader with AttachmentBar UI}

Other Resources
{Selection Experience}
{Completion Experience}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Completion Experience

Completion Experience
See Also Send Feedback
Intersoft WebTextEditor > WebFileUploader > Features > Rich user experiences > Attachment Layout Mode > Completion Experience

Glossary Item Box

  • When all files have been processed, WebFileUploader sets the user interface to summary state. Notice that the upload summary is now displayed in the caption bar.
  • Click on Start Over to go back into Selection Experience for the next upload session.

See Also

Tasks
{Walkthrough: Using WebFileUploader with AttachmentBar UI}

Other Resources
{Selection Experience}
{Uploading Experience}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Walkthrough: Using WebFileUploader with AttachmentBar UI

Walkthrough: Using WebFileUploader with AttachmentBar UI
See Also Send Feedback
Intersoft WebTextEditor > WebFileUploader > Features > Rich user experiences > Attachment Layout Mode > Walkthrough: Using WebFileUploader with AttachmentBar UI

Glossary Item Box

This walkthrough shows you AttachmentBar UI in WebFileUploader.

During this walkthrough, you will learn how to do the following:

  • Setting AttachmentBar UI in WebFileUploader

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Visual Studio 2008 Application.

Step-By-Step Instructions

To enable mail merge with custom collection

  1. Launch Visual Studio.NET 2008.
  2. Click on File menu, then select New and click Web Site.
  3. Select ASP.NET Web Site in the Template box and set Location to HTTP.
  4. Named the Web Site and click OK.
  5. Right-click on Project's name and select New Folder.
  6. Named the folder Upload.
  7. Right-click on Project's name and select Add New Item.
  8. Select WebForm in the My Templates box and named it as Walkthrough.aspx.
  9. Drag WebFileUploader instance from ToolBar to WebForm.
  10. Set the UploadPath property to the newly created Upload folder, the value of this property should be ./Upload
  11. Set the WebFileUploader UILayout property to AttachmentBar.
  12. Drag a HTML button from toolbar to WebForm and implement the onClick event to send the file in the WebFileUploader. Here is the snippet:
    Javascript Copy Code
    function Button1_onclick()
{
   var wfu = ISGetObject("WebFileUploader1");
   if (wfu.IsUploadInProgress())
   {
      alert("Uploading is already in progress. Please wait.");
      return;
   }
   if (wfu.GetValidFilesCount() > 0)
      wfu.UploadFiles();
   else
      alert("You haven't added any files to the attachment box. Please try to add some files.");
}

    Add some validation in the button click event to check whether upload is in progress and if any file is supplied in the WebFileUploader.

  13. Implement OnError and OnCompleted WebFileUploader client side event to display a message if the upload is completed or any error occurred during upload progress.
    C# Copy Code
    functionupload_Completed(id)
{
   alert("The uploading process has completed");
}

functionupload_Error(id, fileInfo, errorMessage)
{
   alert("The uploading process has failed due to error '" + unescape(errorMessage) + "'");
}

  14. Run the sample in a Web Browser.

See Also

Other Resources
{Attachment Layout Mode}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Built-in file saving

Built-in file saving
See Also Send Feedback
Intersoft WebTextEditor > WebFileUploader > Features > Built-in file saving

Glossary Item Box

Unlike standard ASP.NET file upload, WebFileUploader doesn't require you to write codes to save uploaded files. Just set the UploadPath property of the WebFileUploader control and you're all set.

WebFileUploader automatically saves all uploaded files to the specified upload path. Make sure you have configured sufficient security and permission settings for ASP.NET worker process to acess the specified upload path.

You can enter physical path, IIS virtual path, or network path for the upload location. The default upload path is ~/Upload.

See Also

Other Resources
{Large files uploading with minimal resources consumption}
{IIS 6 and IIS 7 Integrated mode support}
{Webfarm and multiple worker requests support with built-in FileStateServer}
{Rich user experiences}
{Real-time progress bar}
{Upload}
{Client-side events}
{Server-side events}
{Initial files count}
{Limit upload files by type, count, or custom}
{Limit upload size and total upload size}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Real-time progress bar

Real-time progress bar
See Also Send Feedback
Intersoft WebTextEditor > WebFileUploader > Features > Real-time progress bar

Glossary Item Box

Intersoft WebFileUploader revolutionizes uploading experience with innovative, real-time progress bar feature. With this feature, user can now see the current uploading progress directly within the file upload interface, making file uploading more engaging and intuitive. Furthermore, WebFileUploader also provides more sophisticated progress information such as uploaded size and estimated completion time.

WebFileUploader shows two types of progress bar, for each file upload and for overall upload progress status.

In addition, WebFileUploader provides comprehensive progress bar options enabling you to customize the progress bar behaviors. For instances, you can disable the overall progress bar, or change the progress information type to show uploaded size instead of percent completed.

The following is a list of properties for customizing progress bar:

  • ProgressLatency.
    This property lets you specify the time latency for progress bar update. Default value is 500 milliseconds.

  • ProgressInformationType.
    The information type for individual upload progress. Default value is Percentage, while other options are Size and TimeRemaining.

  • ProgressInformationTypeForTotal.
    Similar to ProgressInformationType, this property is to set the information type for the overall progress bar.

  • ShowProgressArea.
    Determines whether progress bar area should be shown.

  • ShowProgressBar.
    Determines whether the progress bar for each upload should be shown.

  • ShowProgressBarForTotal.
    Determines whether the progress bar for overall upload should be shown.

WebFileUploader also provides comprehensive styles for customizing the appearance of the progress bar. You can customize the progress bar frame, the information text, the status text, the mask style and more.

The progress bar feature requires additional http handler registration on your web.config. Please refer to IIS Support for more details.

See Also

Other Resources
{Large files uploading with minimal resources consumption}
{IIS 6 and IIS 7 Integrated mode support}
{Webfarm and multiple worker requests support with built-in FileStateServer}
{Rich user experiences}
{Built-in file saving}
{Upload}
{Client-side events}
{Server-side events}
{Initial files count}
{Limit upload files by type, count, or custom}
{Limit upload size and total upload size}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Upload

Upload
See Also Send Feedback
Intersoft WebTextEditor > WebFileUploader > Features > Upload

Glossary Item Box

Automatic upload

With automatic upload feature, each selected file will be uploaded immediately without any additional efforts. This feature is suitable for data form that accepts only a single file upload. However, it could be useful in some other advanced scenarios as well, such as in mail application.

To use automatic upload behavior, simply set UploadType of the uploader control to Automatic value.

Batch upload

Batch upload is the default upload type in WebFileUploader. With batch upload, users can add multiple files in the uploader interface, and then upload all selected files in a single session.

Batch upload provides more intuitive and better controls on the uploading process - such as users can add several files, or remove unnecessary files or change the files - making it the preferred upload type for most file uploading scenarios.

Batch upload with priority

When using batch upload type, you can also configure the upload priority which decides the logical order of the files to be uploaded.

You can set the upload priorty by series, which is the default value, or by type. By series means the files will be uploaded in the original sequence as they were added in the uploader interface, while by type means files with same type will be uploaded first, then following the other types in alphabetical order.

To configure upload priority, simply set PriorityUploadType property.

Simultaneous batch upload

By default, WebFileUploader uploads one file at a time to avoid over consumption on bandwidth and resources. However, WebFileUploader can also be configured to upload multiple files asynchronously to support enterprise-level usage, such as internal or corporate web application.

Since WebFileUploader will upload all files simultaneously, please use this feature with caution as it will significantly affect your server's workload and resources consumption. Make sure you have load-tested your server properly to use this feature.

You may also want to enable validations on the total upload size or allowed file types for security purpose.

To enable simultaneous uploads, just set AllowSimultaneousUpload to true.

In This Section

Walkthrough: Configuring Upload Location

Walkthrough: Configuring Upload Limits

See Also

Other Resources
{Large files uploading with minimal resources consumption}
{IIS 6 and IIS 7 Integrated mode support}
{Webfarm and multiple worker requests support with built-in FileStateServer}
{Rich user experiences}
{Built-in file saving}
{Real-time progress bar}
{Client-side events}
{Server-side events}
{Initial files count}
{Limit upload files by type, count, or custom}
{Limit upload size and total upload size}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Walkthrough: Configuring Upload Location

Walkthrough: Configuring Upload Location
See Also Send Feedback
Intersoft WebTextEditor > WebFileUploader > Features > Upload > Walkthrough: Configuring Upload Location

Glossary Item Box

This walkthrough shows you how to configure upload location in WebFileUploader.

During this walkthrough, you will learn how to do the following:

  • Configuring upload location for WebFileUploader

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Visual Studio 2008 Application.

Step-By-Step Instructions

To enable mail merge with custom collection

  1. Launch Visual Studio.NET 2008.
  2. Click on File menu, then select New and click Web Site.
  3. Select ASP.NET Web Site in the Template box and set Location to HTTP.
  4. Named the Web Site and click OK.
  5. Right-click on Project's name and select New Folder.
  6. Named the folder Upload.
  7. Right-click on Project's name and select Add New Item.
  8. Select WebForm in the My Templates box and named it as Walkthrough.aspx.
  9. Drag WebFileUploader instance from ToolBar to WebForm.
  10. Set the UploadPath property to the newly created Upload folder, the value of this property should be ./Upload
  11. Run the sample in the Web Browser, the entire uploaded file will be located in the upload folder.

See Also

Tasks
{Walkthrough: Configuring Upload Limits}

Other Resources
{Upload}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Walkthrough: Configuring Upload Limits

Walkthrough: Configuring Upload Limits
See Also Send Feedback
Intersoft WebTextEditor > WebFileUploader > Features > Upload > Walkthrough: Configuring Upload Limits

Glossary Item Box

This walkthrough shows you how to configure upload file size limit in WebFileUploader.

During this walkthrough, you will learn how to do the following:

  • Configuring upload location for WebFileUploader
  • Configuring file size limit for WebFileUploader

Prerequisites

In order to complete this walkthrough, you will need the following:

  • Visual Studio 2008 Application.

Step-By-Step Instructions

To enable mail merge with custom collection

  1. Launch Visual Studio.NET 2008.
  2. Click on File menu, then select New and click Web Site.
  3. Select ASP.NET Web Site in the Template box and set Location to HTTP.
  4. Named the Web Site and click OK.
  5. Right-click on Project's name and select New Folder.
  6. Named the folder Upload.
  7. Right-click on Project's name and select Add New Item.
  8. Select WebForm in the My Templates box and named it as Walkthrough.aspx.
  9. Drag WebFileUploader instance from ToolBar to WebForm.
  10. Set the UploadPath property to the newly created Upload folder, the value of this property should be ./Upload.
  11. Set the UploadSizeLimit to 50000, to limit the upload of each file to 50KB. TotalUploadSizeLimit could also be set to limit the total file size uploaded to the server in each upload process.
  12. Run the sample in the Web Browser, trying to upload a file larger than 50KB will result in a failure.

See Also

Tasks
{Walkthrough: Configuring Upload Location}

Other Resources
{Upload}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Client-side events

Client-side events
See Also Send Feedback
Intersoft WebTextEditor > WebFileUploader > Features > Client-side events

Glossary Item Box

WebFileUploader is designed with rock-solid API and extensible client-side events to give you total control over uploading process. Works in conjunction with real-time progress bar feature, WebFileUploader sent event notification to client-side in real-time - such as OnBeforeUpload, OnAfterUpload OnErrorUpload, and even OnUploading event.

The following lists the available client side events in more details:

  • OnInitialize.
    Fired once when the control is initialized.

  • OnBeforeUpload.
    Fired when a file is about to be uploaded.

  • OnAfterUpload.
    Fired when a file has been successfully uploaded.

  • OnUploading.
    Fired when uploader control receives progress information on a file being uploaded.

  • OnCancelUpload.
    Fired when a file upload is cancelled.

  • OnErrorUpload.
    Fired when a file upload is failed due to error.

The following example shows how to handle the client-side events, and shows the information passed to the parameter of each event.

<ISWebTextEditor:WebFileUploaderID="WebFileUploader1"runat="server"
Width="450px" UploadPath="./Upload"AllowAdd="false"             AllowRemove="false">
      <ClientSideEventsOnAfterUpload="doAfterUpload"
                OnBeforeUpload="doBeforeUpload"OnCancelUpload="doCancelUpload"
                 OnInitialize="doInitialize"OnUploading="doProcessing"
                OnError="doErrorUpload" />
</ISWebTextEditor:WebFileUploader>
C# Copy Code
function doAfterUpload(id, webFileUploadInfo)

       {
           WriteLog("AfterUpload Event : File " +
webFileUploadInfo.GetFileName() + " is uploaded.");
       }

       function doErrorUpload(id, webFileUploadInfo, errorMessage,
errorStackTrace)
       {
           WriteLog("ErrorUpload Event : File " +
webFileUploadInfo.GetFileName() + " is failed to upload due
to error '"+ errorMessage + "'");
       }

       function doBeforeUpload(id, webFileUploadInfo)
       {
           WriteLog("BeforeUpload Event : File " +
webFileUploadInfo.GetFileName() + " is about to upload.");
       }

       function doCancelUpload(id, webFileUploadInfo)
       {
           WriteLog("CancelUpload Event : File " +
webFileUploadInfo.GetFileName() + " is cancelled.");
       }

       function doInitialize(id)
       {
           WriteLog("Initialize Event : Initialize " + id + " control.");
       }

       function doProcessing(id, webFileUploadInfo)
       {
           WriteLog("Uploading Event : Uploading file " +
webFileUploadInfo.GetFileName() + " is " + webFileUploadInfo.UploadedLength + " bytes of " + webFileUploadInfo.ContentLength + " bytes.");
       }

See Also

Other Resources
{Large files uploading with minimal resources consumption}
{IIS 6 and IIS 7 Integrated mode support}
{Webfarm and multiple worker requests support with built-in FileStateServer}
{Rich user experiences}
{Built-in file saving}
{Real-time progress bar}
{Upload}
{Server-side events}
{Initial files count}
{Limit upload files by type, count, or custom}
{Limit upload size and total upload size}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Server-side events

Server-side events
See Also Send Feedback
Intersoft WebTextEditor > WebFileUploader > Features > Server-side events

Glossary Item Box

In addition to client-side events, WebFileUploader also provides comprehensive server-side events, making it easy for developers to customize and extend the control with additional processing on certain event.

WebFileUploader is designed with sophisticated architecture that enables server-side events to be raised properly, although WebFileUploader doesn't have direct access to the Page object due to the nature of its architecture that used more advanced HttpModule/HttpHandler technology instead of old-fashioned AJAX.

The following lists server-side events available in WebFileUploader.

  • Uploading.
    Fired when a file upload is in progress. This event will be invoked continuously during the upload progress.

  • AfterUpload.
    Fired when a file upload is succeeded.

  • CancelUpload.
    Fired when a file upload is cancelled.

  • ErrorUpload.
    Fired when a file upload is failed due to error.

All server-side events receive WebFileUploaderFileEventArgs parameter that contains information about an upload file in the context.

The WebFileUploadInfo object provides complete information about an upload file,
such as file name, status, error message and more.

The following C# example shows how to move the uploaded file to another folder after a successful file upload.

See Also

Other Resources
{Large files uploading with minimal resources consumption}
{IIS 6 and IIS 7 Integrated mode support}
{Webfarm and multiple worker requests support with built-in FileStateServer}
Rich user experiences
{Built-in file saving}
{Real-time progress bar}
{Upload}
{Client-side events}
{Initial files count}
{Limit upload files by type, count, or custom}
{Limit upload size and total upload size}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Initial files count

Initial files count
See Also Send Feedback
Intersoft WebTextEditor > WebFileUploader > Features > Initial files count

Glossary Item Box

WebFileUploader gives you the flexibility to set the number of initial file upload fields that displayed in panel user interface. This property is not applicable for attachment bar user interface.

WebFileUploader is configured to show only three upload fields.

To customize this setting, simply set the InitialFileCount property to a number that you desire.

See Also

Other Resources
{Large files uploading with minimal resources consumption}
{IIS 6 and IIS 7 Integrated mode support}
{Webfarm and multiple worker requests support with built-in FileStateServer}
{Rich user experiences}
{Built-in file saving}
{Real-time progress bar}
{Upload}
{Client-side events}
{Server-side events}
{Limit upload files by type, count, or custom}
{Limit upload size and total upload size}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Limit upload files by type, count, or custom

Limit upload files by type, count, or custom
See Also Send Feedback
Intersoft WebTextEditor > WebFileUploader > Features > Limit upload files by type, count, or custom

Glossary Item Box

WebFileUploader includes sophisticated built-in validation before user can select the file to be uploaded. It can perform validation by file types, file count, and custom validation.

By default, WebFileUploader automatically validates redundant files. That means you can't select the same file that already been added.

To limit file types, set the FileTypes property to the file extensions with mask. You can enter multiple file types by separating each type with a semicolon separator, such as *.png;*.gif;*.jpg

To limit files count, simply set the FilesCount to an integer number.

The file types, file count and custom validation is performed in client-side, while file size validation is performed in server-side.

Code Example:

<ISWebTextEditor:WebFileUploader ID="WebFileUploader1" runat="server" FilesCount="5" FileTypes="*.zip;*.rar" Width="500px">
</ISWebTextEditor:WebFileUploader>

See Also

Other Resources
{Large files uploading with minimal resources consumption}
{IIS 6 and IIS 7 Integrated mode support}
{Webfarm and multiple worker requests support with built-in FileStateServer}
{Rich user experiences}
{Built-in file saving}
{Real-time progress bar}
{Upload}
{Client-side events}
{Server-side events}
{Initial files count}
{Limit upload size and total upload size}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


How-to: Validate Upload

How-to: Validate Upload
Send Feedback
Intersoft WebTextEditor > WebFileUploader > Features > Limit upload files by type, count, or custom > How-to: Validate Upload

Glossary Item Box

WebFileUploader includes sophisticated built-in validation before user can select the file to be uploaded. It can perform validation by file types, file count, and custom validation.

In this topic, you will learn how to validate upload by file types and file count.

To validate upload

  1. Right click on WebFileUploader control and choose Properties.
  2. Set FilesCount to 5 and FileTypes to *.zip;*.rar.
  3. Run the project. In this case, you can only upload file up to 5 files and each file type only contains either .zip or .rar.

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Limit upload size and total upload size

Limit upload size and total upload size
See Also Send Feedback
Intersoft WebTextEditor > WebFileUploader > Features > Limit upload size and total upload size

Glossary Item Box

In most cases, your application would need to limit the upload size of an individual file for security and resource management purpose. By default, WebUploader doesn't set upload size limit.

To customize upload size limit, please set UploadSizeLimit property to an integer value with the scale of byte.

In addition, WebFileUploader also enables you to limit the total size of all uploaded files. When it reach the maximum size, it will abort the current file being uploaded and cancel the rest pending uploads.

To configure total upload size limit, please set TotalUploadSizeLimit property to an integer value with the scale of byte.

The following example shows a WebFileUploader with individual upload size configured to 10 kilobytes and total upload size to 100 kilobytes.

<ISWebTextEditor:WebFileUploader ID="WebFileUploader1" runat="server"
                              TotalUploadSizeLimit="100000" UploadSizeLimit="10000">
</ISWebTextEditor:WebFileUploader>

See Also

Other Resources
{Large files uploading with minimal resources consumption}
{IIS 6 and IIS 7 Integrated mode support}
{Webfarm and multiple worker requests support with built-in FileStateServer}
{Rich user experiences}
{Built-in file saving}
{Real-time progress bar}
{Upload}
{Client-side events}
{Server-side events}
{Initial files count}
{Limit upload files by type, count, or custom}

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Server-side References

Server-side References
Send Feedback
Intersoft WebTextEditor > Server-side References

Glossary Item Box

This section is designated to help user working with server-side references in WebTextEditor.

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


ISNet.WebUI.WebTextEditor Namespace

ISNet.WebUI.WebTextEditor Namespace
See Also Inheritance Hierarchy Send Feedback

Glossary Item Box

Classes

 | Class | Description
Class | ImageListForm |
Class | Presets |
Class | SerializableList<T> |
Class | WebFileUploader | Intersoft WebFileUploader is a memory-efficient ASP.NET file uploading component that supports asynchronous multiple files upload without page refresh. Unlike standard ASP.NET file uploader, WebFileUploader enables large file uploading with very minimum memory and resources consumption.
Class | WebFileUploaderClientSideEvents | A collection of WebUploader's client side events.
Class | WebFileUploaderFileEventArgs |
Class | WebFileUploaderFileInfo | A collection of members in WebUploader' file info.
Class | WebFileUploaderFileProcessor | FileProcessor is used to process byte data from a multi-part form and save it to the disk.
Class | WebFileUploaderHttpHandler |
Class | WebFileUploaderHttpModule |
Class | WebFileUploaderImageSettings | A collection of WebUploader's images settings.
Class | WebFileUploaderInfo |
Class | WebFileUploaderProgressInformation | A collection of members in WebUploader's progress information.
Class | WebFileUploaderStyleSettings | A collection of members in WebUploader's style settings.
Class | WebFileUploaderTextSettings | A collection of settings which controls the text shown in WebUploader.
Class | WebSpellChecker | Intersoft WebSpellChecker is an easy-to-use, yet powerful spell checking component for ASP.NET. In addition to typical spell check features that you expected, WebSpellChecker delivers several innovative features that are not available elsewhere, such as Microsoft Word-style red-wave underline highlight, built-in dialogbox with intuitive design, natural integration with WebTextEditor, wide cross browsers support and more.
Class | WebSpellCheckerClientSideEvents | A collection of WebSpellChecker's client side events.
Class | WebSpellCheckerDictionaryData |
Class | WebSpellCheckerDictionaryDataCollection |
Class | WebSpellCheckerImagesSettings | A collection of WebSpellChecker's images settings.
Class | WebSpellCheckerTextSettings | A collection of settings which controls the text shown in WebSpellChecker.
Class | WebSpellCheckerTextSuggestion | A collection of WebSpellChecker's text suggestion settings.
Class | WebSpellCheckerTextSuggestionCollection | A collection of text suggestion used by WebSpellChecker.
Class | WebTextEditor | Intersoft WebTextEditor is a business-oriented text editor that seamlessly combines innovative features, elegant interface and great UX in a single box! With multitude of rich editing features – such as built-in media gallery, table designer, innovative red-wave highlight spell checker, and real-progress file uploader – WebTextEditor rediscovers the art of editing, and makes content authoring easier, simpler and more intuitive.
Class | WebTextEditor.PostBackAction | Specifies PostBackAction of WebTextEditor
Class | WebTextEditorBeforeSendMailArgs | Provides data for before SendMail event.
Class | WebTextEditorClientSideEvents | A collection of WebTextEditor's client side events.
Class | WebTextEditorCssFile | A collection of WebTextEditor's css files.
Class | WebTextEditorDataSourceInfo |
Class | WebTextEditorEditorSettings | A collection of WebTextEditor's editor settings.
Class | WebTextEditorFileUploaderSettings | A collection of WebTextEditor's uploader settings.
Class | WebTextEditorImagesSettings | A collection of WebTextEditor's images settings.
Class | WebTextEditorLabel | A collection of WebTextEditor's mail merge label settings.
Class | WebTextEditorLabelCollection | A collection of mail merge's label used by WebTextEditor.
Class | WebTextEditorMailMergeArgs | Provides data for MailMerge event.
Class | WebTextEditorMailMergeCompletedArgs | Provides data for MailMerge completed event.
Class | WebTextEditorMailMergeObject |
Class | WebTextEditorMailMergeSettings | A collection of WebTextEditor's mail merge settings.
Class | WebTextEditorMedia | A collection of members in WebTextEditor's media.
Class | WebTextEditorMediaCollection | A collection of media used by WebTextEditor.
Class | WebTextEditorMediaResourceGroup | A collection of members in WebTextEditor's media resource group.
Class | WebTextEditorMediaResourceGroupCollection | A collection of media resource group used by WebTextEditor.
Class | WebTextEditorResource | A collection of members media resource used by WebTextEditor for media searching.
Class | WebTextEditorResourceCollection | A collection of media resource used by WebTextEditor for media searching.
Class | WebTextEditorSaveArgs | Provides data for Save event.
Class | WebTextEditorSection | A collection of members in WebTextEditor's section.
Class | WebTextEditorSendMailArgs | Provides data for SendMail event.
Class | WebTextEditorSendMailCompletedArgs | Provides data for SendMail complete event.
Class | WebTextEditorTaskPaneSettings | A collection of WebTextEditor's TaskPane settings.
Class | WebTextEditorTextSettings | A collection of settings which controls the text shown in WebTextEditor.
Class | WebTextEditorToolBar | A collection of members in WebTextEditor's ToolBar.
Class | WebTextEditorToolBarArgs | Provides data for ToolBar event.
Class | WebTextEditorToolBarCollection | The data collection of ToolBar used by WebTextEditor.
Class | WebTextEditorToolBarSettings | A collection of WebTextEditor's ToolBar settings.
Class | WebTextEditorToolCommand | A collection of members in WebTextEditor's ToolBar command.
Class | WebTextEditorToolCommandCollection | The data collection of ToolBar's command used by WebTextEditor.
Class | WebTextEditorToolItem | A collection of members in WebTextEditor's ToolBar command dropdown list.
Class | WebTextEditorToolItemCollection | The data collection of ToolBar's command dropdown list used by WebTextEditor.
Class | WebTextEditorViewSettings | A collection of settings used for view in WebTextEditor.
Class | WebTextEditorWatermarkSettings | A collection of settings used for watermark in WebTextEditor.
Class | WebUIComponentEditor | Summary description for WebInputComponentEditor.

Delegates

 | Delegate | Description
Delegate | UploadFileEventHandler | Delegates that handles the UploadFile event.
Delegate | ValidateUploadFileEventHandler | Delegates that handles the ValidateUploadFile event.
Delegate | WebTextEditorBeforeSendMailEventHandler | Delegates that handles the before Send Mail event.
Delegate | WebTextEditorMailMergeCompletedEventHandler | Delegates that handles the MailMerge completed event.
Delegate | WebTextEditorMailMergeEventHandler | Delegates that handles the MailMerge event.
Delegate | WebTextEditorSaveEventHandler | Delegates that handles the Save event.
Delegate | WebTextEditorSendMailCompletedEventHandler | Delegates that handles the Send Mail completed event.
Delegate | WebTextEditorSendMailEventHandler | Delegates that handles the Send Mail event.
Delegate | WebTextEditorToolBarEventHandler | Delegates that handles the ToolBar event.

Enumerations

 | Enumeration | Description
Enumeration | PostbackMode | Determines which Postback mode is used.
Enumeration | PriorityUploadType | Specifies which PriorityUpload type is used.
Enumeration | ProgressInformationType | Determines which progres information type is used.
Enumeration | SaveType | Determines which SaveType is used.
Enumeration | UILayout | Determines which UILayout is used.
Enumeration | UploadType | Determines which UploadType is used.
Enumeration | ValidationType | Determines which Validation type is used.
Enumeration | WebSpellCheckerContextMenuStyle | Determines which context menu style is used.
Enumeration | WebTextEditorClientScript |
Enumeration | WebTextEditorClientStyle |
Enumeration | WebTextEditorCssType | Specifies which EditorCssType is used.
Enumeration | WebTextEditorDefaultStyleMode | Determines which DefaultStyle mode is used.
Enumeration | WebTextEditorEnterKeyAction | Determines which EnterKeyAction is used.
Enumeration | WebTextEditorHtmlDocType | Determines which HtmlDoctype is used.
Enumeration | WebTextEditorMediaResourceType | Specifies which ResourceType is used.
Enumeration | WebTextEditorMediaType | Specifies which MediaType is used.
Enumeration | WebTextEditorParagraphMode | Determines which Paragraph mode is used.
Enumeration | WebTextEditorResizeMode | Determines which resize mode is used.
Enumeration | WebTextEditorSerializationMode | Specifies which serialization mode is used.
Enumeration | WebTextEditorTaskPanePosition | Specifies which TaskPane position is used.
Enumeration | WebTextEditorToolBarCategory | Determines which ToolBar category is used.
Enumeration | WebTextEditorToolBarCommandDisplayMode | Determines which DisplayMode is used for ToolBar command.
Enumeration | WebTextEditorToolBarCommandType | Specifies which CommandType is used in WebTextEditor's ToolBar command.
Enumeration | WebTextEditorToolBarMode | Determines which ToolBar mode is used.
Enumeration | WebTextEditorToolCommandType | Specifies which command is used in WebTextEditor's ToolBar command.
Enumeration | WebTextEditorViewMode | Specifies WebTextEditor view mode.
Enumeration | WebUploadInfoStatus | Specifies WebUploader info status.

See Also

Reference

ISNet.WebUI.WebTextEditor Assembly

© 2013 Intersoft Solutions Corp. All Rights Reserved.


ImageListForm Class

[image]
Intersoft WebTextEditor Documentation
ImageListForm Class
Members See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : ImageListForm Class

Glossary Item Box

Object Model

ImageListForm Class

Syntax

Visual Basic (Declaration)
Public Class ImageListForm
   Inherits System.Windows.Forms.Form
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
C#
public class ImageListForm : System.Windows.Forms.Form
Delphi
public class ImageListForm = class(System.Windows.Forms.Form)
JScript
public class ImageListForm extends System.Windows.Forms.Form
Managed Extensions for C++
public __gc class ImageListForm : public System.Windows.Forms.Form
C++/CLI
public ref class ImageListForm : public System.Windows.Forms.Form

Inheritance Hierarchy

System.Object
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
ISNet.WebUI.WebTextEditor.ImageListForm

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Members
ISNet.WebUI.WebTextEditor Namespace


ImageListForm Class Members

[image]
Intersoft WebTextEditor Documentation
ImageListForm Class Members
See Also Properties Methods Events Send Feedback
ISNet.WebUI.WebTextEditor Namespace : ImageListForm Class

Glossary Item Box

The following tables list the members exposed by ImageListForm.

Public Constructors

 | Name | Description
Public Constructor | ImageListForm Constructor |
Top

Public Properties

 | Name | Description
Public Property | AcceptButton | (Inherited from System.Windows.Forms.Form)
Public Property | AccessibilityObject | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | (Inherited from System.Windows.Forms.Control)
Public Property | ActiveControl | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | ActiveMdiChild | (Inherited from System.Windows.Forms.Form)
Public Property | AllowDrop | (Inherited from System.Windows.Forms.Control)
Public Property | AllowTransparency | (Inherited from System.Windows.Forms.Form)
Public Property | Anchor | (Inherited from System.Windows.Forms.Control)
Public Property | AutoScaleDimensions | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScaleMode | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScroll | (Inherited from System.Windows.Forms.Form)
Public Property | AutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMinSize | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollOffset | (Inherited from System.Windows.Forms.Control)
Public Property | AutoScrollPosition | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoSize | (Inherited from System.Windows.Forms.Form)
Public Property | AutoSizeMode | (Inherited from System.Windows.Forms.Form)
Public Property | AutoValidate | (Inherited from System.Windows.Forms.Form)
Public Property | BackColor | (Inherited from System.Windows.Forms.Form)
Public Property | BackgroundImage | (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImageLayout | (Inherited from System.Windows.Forms.Control)
Public Property | BindingContext | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | Bottom | (Inherited from System.Windows.Forms.Control)
Public Property | Bounds | (Inherited from System.Windows.Forms.Control)
Public Property | CancelButton | (Inherited from System.Windows.Forms.Form)
Public Property | CanFocus | (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | (Inherited from System.Windows.Forms.Control)
Public Property | Capture | (Inherited from System.Windows.Forms.Control)
Public Property | CausesValidation | (Inherited from System.Windows.Forms.Control)
Public Property | ClientRectangle | (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | (Inherited from System.Windows.Forms.Form)
Public Property | CompanyName | (Inherited from System.Windows.Forms.Control)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenu | (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenuStrip | (Inherited from System.Windows.Forms.Control)
Public Property | ControlBox | (Inherited from System.Windows.Forms.Form)
Public Property | Controls | (Inherited from System.Windows.Forms.Control)
Public Property | Created | (Inherited from System.Windows.Forms.Control)
Public Property | CurrentAutoScaleDimensions | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | Cursor | (Inherited from System.Windows.Forms.Control)
Public Property | DataBindings | (Inherited from System.Windows.Forms.Control)
Public Property | DesktopBounds | (Inherited from System.Windows.Forms.Form)
Public Property | DesktopLocation | (Inherited from System.Windows.Forms.Form)
Public Property | DialogResult | (Inherited from System.Windows.Forms.Form)
Public Property | DisplayRectangle | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Disposing | (Inherited from System.Windows.Forms.Control)
Public Property | Dock | (Inherited from System.Windows.Forms.Control)
Public Property | Enabled | (Inherited from System.Windows.Forms.Control)
Public Property | Focused | (Inherited from System.Windows.Forms.Control)
Public Property | Font | (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | (Inherited from System.Windows.Forms.Control)
Public Property | FormBorderStyle | (Inherited from System.Windows.Forms.Form)
Public Property | Handle | (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | (Inherited from System.Windows.Forms.Control)
Public Property | Height | (Inherited from System.Windows.Forms.Control)
Public Property | HelpButton | (Inherited from System.Windows.Forms.Form)
Public Property | HorizontalScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Icon | (Inherited from System.Windows.Forms.Form)
Public Property | ImeMode | (Inherited from System.Windows.Forms.Control)
Public Property | InvokeRequired | (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | (Inherited from System.Windows.Forms.Control)
Public Property | IsDisposed | (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | (Inherited from System.Windows.Forms.Control)
Public Property | IsMdiChild | (Inherited from System.Windows.Forms.Form)
Public Property | IsMdiContainer | (Inherited from System.Windows.Forms.Form)
Public Property | IsMirrored | (Inherited from System.Windows.Forms.Control)
Public Property | IsRestrictedWindow | (Inherited from System.Windows.Forms.Form)
Public Property | KeyPreview | (Inherited from System.Windows.Forms.Form)
Public Property | LayoutEngine | (Inherited from System.Windows.Forms.Control)
Public Property | Left | (Inherited from System.Windows.Forms.Control)
Public Property | Location | (Inherited from System.Windows.Forms.Form)
Public Property | MainMenuStrip | (Inherited from System.Windows.Forms.Form)
Public Property | MaximizeBox | (Inherited from System.Windows.Forms.Form)
Public Property | MaximumSize | (Inherited from System.Windows.Forms.Form)
Public Property | MdiChildren | (Inherited from System.Windows.Forms.Form)
Public Property | MdiParent | (Inherited from System.Windows.Forms.Form)
Public Property | Menu | (Inherited from System.Windows.Forms.Form)
Public Property | MergedMenu | (Inherited from System.Windows.Forms.Form)
Public Property | MinimizeBox | (Inherited from System.Windows.Forms.Form)
Public Property | MinimumSize | (Inherited from System.Windows.Forms.Form)
Public Property | Modal | (Inherited from System.Windows.Forms.Form)
Public Property | Name | (Inherited from System.Windows.Forms.Control)
Public Property | Opacity | (Inherited from System.Windows.Forms.Form)
Public Property | OwnedForms | (Inherited from System.Windows.Forms.Form)
Public Property | Owner | (Inherited from System.Windows.Forms.Form)
Public Property | Padding | (Inherited from System.Windows.Forms.Control)
Public Property | Parent | (Inherited from System.Windows.Forms.Control)
Public Property | ParentForm | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | PreferredSize | (Inherited from System.Windows.Forms.Control)
Public Property | ProductName | (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | (Inherited from System.Windows.Forms.Control)
Public Property | RecreatingHandle | (Inherited from System.Windows.Forms.Control)
Public Property | Region | (Inherited from System.Windows.Forms.Control)
Public Property | RestoreBounds | (Inherited from System.Windows.Forms.Form)
Public Property | Right | (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeftLayout | (Inherited from System.Windows.Forms.Form)
Public Property | ShowIcon | (Inherited from System.Windows.Forms.Form)
Public Property | ShowInTaskbar | (Inherited from System.Windows.Forms.Form)
Public Property | Site | (Inherited from System.Windows.Forms.Control)
Public Property | Size | (Inherited from System.Windows.Forms.Form)
Public Property | SizeGripStyle | (Inherited from System.Windows.Forms.Form)
Public Property | StartPosition | (Inherited from System.Windows.Forms.Form)
Public Property | Tag | (Inherited from System.Windows.Forms.Control)
Public Property | Text | (Inherited from System.Windows.Forms.Form)
Public Property | Top | (Inherited from System.Windows.Forms.Control)
Public Property | TopLevel | (Inherited from System.Windows.Forms.Form)
Public Property | TopLevelControl | (Inherited from System.Windows.Forms.Control)
Public Property | TopMost | (Inherited from System.Windows.Forms.Form)
Public Property | TransparencyKey | (Inherited from System.Windows.Forms.Form)
Public Property | UseWaitCursor | (Inherited from System.Windows.Forms.Control)
Public Property | VerticalScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Visible | (Inherited from System.Windows.Forms.Control)
Public Property | Width | (Inherited from System.Windows.Forms.Control)
Public Property | WindowState | (Inherited from System.Windows.Forms.Form)
Top

Protected Properties

 | Name | Description
Protected Property | AutoScaleFactor | (Inherited from System.Windows.Forms.ContainerControl)
Protected Property | CanEnableIme | (Inherited from System.Windows.Forms.ContainerControl)
Protected Property | CanRaiseEvents | (Inherited from System.Windows.Forms.Control)
Protected Property | CreateParams | (Inherited from System.Windows.Forms.Form)
Protected Property | DefaultCursor | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultImeMode | (Inherited from System.Windows.Forms.Form)
Protected Property | DefaultMargin | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultMaximumSize | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultMinimumSize | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultPadding | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultSize | (Inherited from System.Windows.Forms.Form)
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | DoubleBuffered | (Inherited from System.Windows.Forms.Control)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Protected Property | FontHeight | (Inherited from System.Windows.Forms.Control)
Protected Property | HScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Property | ImeModeBase | (Inherited from System.Windows.Forms.Control)
Protected Property | MaximizedBounds | (Inherited from System.Windows.Forms.Form)
Protected Property | ResizeRedraw | (Inherited from System.Windows.Forms.Control)
Protected Property | ScaleChildren | (Inherited from System.Windows.Forms.Control)
Protected Property | ShowWithoutActivation | (Inherited from System.Windows.Forms.Form)
Protected Property | VScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Top

Public Methods

 | Name | Description
Public Method | Activate | (Inherited from System.Windows.Forms.Form)
Public Method | AddOwnedForm | (Inherited from System.Windows.Forms.Form)
Public Method | BeginInvoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | (Inherited from System.Windows.Forms.Control)
Public Method | Close | (Inherited from System.Windows.Forms.Form)
Public Method | Contains | (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded. Overridden. Clean up any resources being used.
Public Method | DoDragDrop | (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | (Inherited from System.Windows.Forms.Control)
Public Method | FindForm | (Inherited from System.Windows.Forms.Control)
Public Method | Focus | (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetPreferredSize | (Inherited from System.Windows.Forms.Control)
Public Method | Hide | (Inherited from System.Windows.Forms.Control)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | LayoutMdi | (Inherited from System.Windows.Forms.Form)
Public Method | PerformAutoScale | (Inherited from System.Windows.Forms.ContainerControl)
Public Method | PerformLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToClient | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | (Inherited from System.Windows.Forms.Control)
Public Method | RemoveOwnedForm | (Inherited from System.Windows.Forms.Form)
Public Method | ResetText | (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Scale | (Inherited from System.Windows.Forms.Control)
Public Method | ScrollControlIntoView | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | Select | Overloaded. (Inherited from System.Windows.Forms.Form)
Public Method | SelectNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | (Inherited from System.Windows.Forms.Control)
Public Method | SetAutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | SetBounds | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | SetDesktopBounds | (Inherited from System.Windows.Forms.Form)
Public Method | SetDesktopLocation | (Inherited from System.Windows.Forms.Form)
Public Method | Show | Overloaded. (Inherited from System.Windows.Forms.Form)
Public Method | ShowDialog | Overloaded. (Inherited from System.Windows.Forms.Form)
Public Method | SuspendLayout | (Inherited from System.Windows.Forms.Control)
Public Method | ToString | (Inherited from System.Windows.Forms.Form)
Public Method | Update | (Inherited from System.Windows.Forms.Control)
Public Method | Validate | Overloaded. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | ValidateChildren | Overloaded. (Inherited from System.Windows.Forms.Form)
Top

Protected Methods

 | Name | Description
Protected Method | ActivateMdiChild | (Inherited from System.Windows.Forms.Form)
Protected Method | AdjustFormScrollbars | (Inherited from System.Windows.Forms.Form)
Protected Method | CenterToParent | (Inherited from System.Windows.Forms.Form)
Protected Method | CenterToScreen | (Inherited from System.Windows.Forms.Form)
Protected Method | CreateAccessibilityInstance | (Inherited from System.Windows.Forms.Control)
Protected Method | CreateControlsInstance | (Inherited from System.Windows.Forms.Form)
Protected Method | CreateHandle | (Inherited from System.Windows.Forms.Form)
Protected Method | DefWndProc | (Inherited from System.Windows.Forms.Form)
Protected Method | DestroyHandle | (Inherited from System.Windows.Forms.Control)
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | GetAccessibilityObjectById | (Inherited from System.Windows.Forms.Control)
Protected Method | GetAutoSizeMode | (Inherited from System.Windows.Forms.Control)
Protected Method | GetScaledBounds | (Inherited from System.Windows.Forms.Form)
Protected Method | GetScrollState | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | GetStyle | (Inherited from System.Windows.Forms.Control)
Protected Method | GetTopLevel | (Inherited from System.Windows.Forms.Control)
Protected Method | InitLayout | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokeGotFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokeLostFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokeOnClick | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokePaint | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokePaintBackground | (Inherited from System.Windows.Forms.Control)
Protected Method | IsInputChar | (Inherited from System.Windows.Forms.Control)
Protected Method | IsInputKey | (Inherited from System.Windows.Forms.Control)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Protected Method | NotifyInvalidate | (Inherited from System.Windows.Forms.Control)
Protected Method | OnActivated | (Inherited from System.Windows.Forms.Form)
Protected Method | OnAutoSizeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnAutoValidateChanged | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | OnBackColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnBackgroundImageChanged | (Inherited from System.Windows.Forms.Form)
Protected Method | OnBackgroundImageLayoutChanged | (Inherited from System.Windows.Forms.Form)
Protected Method | OnBindingContextChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnCausesValidationChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnChangeUICues | (Inherited from System.Windows.Forms.Control)
Protected Method | OnClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnClientSizeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnClosed | (Inherited from System.Windows.Forms.Form)
Protected Method | OnClosing | (Inherited from System.Windows.Forms.Form)
Protected Method | OnContextMenuChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnContextMenuStripChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnControlAdded | (Inherited from System.Windows.Forms.Control)
Protected Method | OnControlRemoved | (Inherited from System.Windows.Forms.Control)
Protected Method | OnCreateControl | (Inherited from System.Windows.Forms.Form)
Protected Method | OnCursorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDeactivate | (Inherited from System.Windows.Forms.Form)
Protected Method | OnDockChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDoubleClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragDrop | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragEnter | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragLeave | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragOver | (Inherited from System.Windows.Forms.Control)
Protected Method | OnEnabledChanged | (Inherited from System.Windows.Forms.Form)
Protected Method | OnEnter | (Inherited from System.Windows.Forms.Form)
Protected Method | OnFontChanged | (Inherited from System.Windows.Forms.Form)
Protected Method | OnForeColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnFormClosed | (Inherited from System.Windows.Forms.Form)
Protected Method | OnFormClosing | (Inherited from System.Windows.Forms.Form)
Protected Method | OnGiveFeedback | (Inherited from System.Windows.Forms.Control)
Protected Method | OnGotFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | OnHandleCreated | (Inherited from System.Windows.Forms.Form)
Protected Method | OnHandleDestroyed | (Inherited from System.Windows.Forms.Form)
Protected Method | OnHelpButtonClicked | (Inherited from System.Windows.Forms.Form)
Protected Method | OnHelpRequested | (Inherited from System.Windows.Forms.Control)
Protected Method | OnImeModeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnInputLanguageChanged | (Inherited from System.Windows.Forms.Form)
Protected Method | OnInputLanguageChanging | (Inherited from System.Windows.Forms.Form)
Protected Method | OnInvalidated | (Inherited from System.Windows.Forms.Control)
Protected Method | OnKeyDown | (Inherited from System.Windows.Forms.Control)
Protected Method | OnKeyPress | (Inherited from System.Windows.Forms.Control)
Protected Method | OnKeyUp | (Inherited from System.Windows.Forms.Control)
Protected Method | OnLayout | (Inherited from System.Windows.Forms.Form)
Protected Method | OnLeave | (Inherited from System.Windows.Forms.Control)
Protected Method | OnLoad | (Inherited from System.Windows.Forms.Form)
Protected Method | OnLocationChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnLostFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMarginChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMaximizedBoundsChanged | (Inherited from System.Windows.Forms.Form)
Protected Method | OnMaximumSizeChanged | (Inherited from System.Windows.Forms.Form)
Protected Method | OnMdiChildActivate | (Inherited from System.Windows.Forms.Form)
Protected Method | OnMenuComplete | (Inherited from System.Windows.Forms.Form)
Protected Method | OnMenuStart | (Inherited from System.Windows.Forms.Form)
Protected Method | OnMinimumSizeChanged | (Inherited from System.Windows.Forms.Form)
Protected Method | OnMouseCaptureChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseDoubleClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseDown | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseEnter | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseHover | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseLeave | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseMove | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseUp | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseWheel | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnMove | (Inherited from System.Windows.Forms.Control)
Protected Method | OnNotifyMessage | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPaddingChanged | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnPaint | (Inherited from System.Windows.Forms.Form)
Protected Method | OnPaintBackground | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnParentBackColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentBackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentBindingContextChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentChanged | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | OnParentCursorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentEnabledChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentFontChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentForeColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentRightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentVisibleChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPreviewKeyDown | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPrint | (Inherited from System.Windows.Forms.Control)
Protected Method | OnQueryContinueDrag | (Inherited from System.Windows.Forms.Control)
Protected Method | OnRegionChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnResize | (Inherited from System.Windows.Forms.Form)
Protected Method | OnResizeBegin | (Inherited from System.Windows.Forms.Form)
Protected Method | OnResizeEnd | (Inherited from System.Windows.Forms.Form)
Protected Method | OnRightToLeftChanged | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnRightToLeftLayoutChanged | (Inherited from System.Windows.Forms.Form)
Protected Method | OnScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnShown | (Inherited from System.Windows.Forms.Form)
Protected Method | OnSizeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnStyleChanged | (Inherited from System.Windows.Forms.Form)
Protected Method | OnSystemColorsChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnTabIndexChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnTabStopChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnTextChanged | (Inherited from System.Windows.Forms.Form)
Protected Method | OnValidated | (Inherited from System.Windows.Forms.Control)
Protected Method | OnValidating | (Inherited from System.Windows.Forms.Control)
Protected Method | OnVisibleChanged | (Inherited from System.Windows.Forms.Form)
Protected Method | ProcessCmdKey | (Inherited from System.Windows.Forms.Form)
Protected Method | ProcessDialogChar | (Inherited from System.Windows.Forms.Form)
Protected Method | ProcessDialogKey | (Inherited from System.Windows.Forms.Form)
Protected Method | ProcessKeyEventArgs | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessKeyPreview | (Inherited from System.Windows.Forms.Form)
Protected Method | ProcessTabKey | (Inherited from System.Windows.Forms.Form)
Protected Method | RaiseDragEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RaiseKeyEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RaiseMouseEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RaisePaintEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RecreateHandle | (Inherited from System.Windows.Forms.Control)
Protected Method | ResetMouseEventArgs | (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateAlignment | Overloaded. (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateHorizontal | (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateLeftRight | (Inherited from System.Windows.Forms.Control)
Protected Method | ScaleControl | (Inherited from System.Windows.Forms.Form)
Protected Method | ScrollToControl | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | SetAutoSizeMode | (Inherited from System.Windows.Forms.Control)
Protected Method | SetBoundsCore | (Inherited from System.Windows.Forms.Form)
Protected Method | SetClientSizeCore | (Inherited from System.Windows.Forms.Form)
Protected Method | SetDisplayRectLocation | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | SetScrollState | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | SetStyle | (Inherited from System.Windows.Forms.Control)
Protected Method | SetTopLevel | (Inherited from System.Windows.Forms.Control)
Protected Method | SetVisibleCore | (Inherited from System.Windows.Forms.Form)
Protected Method | SizeFromClientSize | (Inherited from System.Windows.Forms.Control)
Protected Method | UpdateDefaultButton | (Inherited from System.Windows.Forms.Form)
Protected Method | UpdateStyles | (Inherited from System.Windows.Forms.Control)
Protected Method | UpdateZOrder | (Inherited from System.Windows.Forms.Control)
Protected Method | WndProc | (Inherited from System.Windows.Forms.Form)
Top

Public Events

 | Name | Description
Public Event | Activated | (Inherited from System.Windows.Forms.Form)
Public Event | AutoSizeChanged | (Inherited from System.Windows.Forms.Form)
Public Event | AutoValidateChanged | (Inherited from System.Windows.Forms.Form)
Public Event | BackColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | (Inherited from System.Windows.Forms.Control)
Public Event | Click | (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Deactivate | (Inherited from System.Windows.Forms.Form)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | DockChanged | (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Enter | (Inherited from System.Windows.Forms.Control)
Public Event | FontChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | FormClosed | (Inherited from System.Windows.Forms.Form)
Public Event | FormClosing | (Inherited from System.Windows.Forms.Form)
Public Event | GiveFeedback | (Inherited from System.Windows.Forms.Control)
Public Event | GotFocus | (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | (Inherited from System.Windows.Forms.Control)
Public Event | HelpButtonClicked | (Inherited from System.Windows.Forms.Form)
Public Event | HelpRequested | (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | InputLanguageChanged | (Inherited from System.Windows.Forms.Form)
Public Event | InputLanguageChanging | (Inherited from System.Windows.Forms.Form)
Public Event | Invalidated | (Inherited from System.Windows.Forms.Control)
Public Event | KeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | (Inherited from System.Windows.Forms.Control)
Public Event | Layout | (Inherited from System.Windows.Forms.Control)
Public Event | Leave | (Inherited from System.Windows.Forms.Control)
Public Event | Load | (Inherited from System.Windows.Forms.Form)
Public Event | LocationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | LostFocus | (Inherited from System.Windows.Forms.Control)
Public Event | MaximizedBoundsChanged | (Inherited from System.Windows.Forms.Form)
Public Event | MaximumSizeChanged | (Inherited from System.Windows.Forms.Form)
Public Event | MdiChildActivate | (Inherited from System.Windows.Forms.Form)
Public Event | MenuComplete | (Inherited from System.Windows.Forms.Form)
Public Event | MenuStart | (Inherited from System.Windows.Forms.Form)
Public Event | MinimumSizeChanged | (Inherited from System.Windows.Forms.Form)
Public Event | MouseCaptureChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | (Inherited from System.Windows.Forms.Control)
Public Event | MouseWheel | (Inherited from System.Windows.Forms.Control)
Public Event | Move | (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Paint | (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Resize | (Inherited from System.Windows.Forms.Control)
Public Event | ResizeBegin | (Inherited from System.Windows.Forms.Form)
Public Event | ResizeEnd | (Inherited from System.Windows.Forms.Form)
Public Event | RightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftLayoutChanged | (Inherited from System.Windows.Forms.Form)
Public Event | Scroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Event | Shown | (Inherited from System.Windows.Forms.Form)
Public Event | SizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TextChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Validated | (Inherited from System.Windows.Forms.Control)
Public Event | Validating | (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

ImageListForm Class
ISNet.WebUI.WebTextEditor Namespace


ImageListForm Constructor

[image]
Intersoft WebTextEditor Documentation
ImageListForm Constructor
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : ImageListForm Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New ImageListForm()
C#
public ImageListForm()
Delphi
public ImageListForm();
JScript
public function ImageListForm();
Managed Extensions for C++
public: ImageListForm();
C++/CLI
public:
ImageListForm();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


ImageListForm Class Methods

[image]
Intersoft WebTextEditor Documentation
ImageListForm Class Methods
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : ImageListForm Class

Glossary Item Box

For a list of all members of this type, see ImageListForm members.

Public Methods

 | Name | Description
Public Method | Activate | (Inherited from System.Windows.Forms.Form)
Public Method | AddOwnedForm | (Inherited from System.Windows.Forms.Form)
Public Method | BeginInvoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | BringToFront | (Inherited from System.Windows.Forms.Control)
Public Method | Close | (Inherited from System.Windows.Forms.Form)
Public Method | Contains | (Inherited from System.Windows.Forms.Control)
Public Method | CreateControl | (Inherited from System.Windows.Forms.Control)
Public Method | CreateGraphics | (Inherited from System.Windows.Forms.Control)
Public Method | CreateObjRef | (Inherited from System.MarshalByRefObject)
Public Method | Dispose | Overloaded. Overridden. Clean up any resources being used.
Public Method | DoDragDrop | (Inherited from System.Windows.Forms.Control)
Public Method | DrawToBitmap | (Inherited from System.Windows.Forms.Control)
Public Method | EndInvoke | (Inherited from System.Windows.Forms.Control)
Public Method | FindForm | (Inherited from System.Windows.Forms.Control)
Public Method | Focus | (Inherited from System.Windows.Forms.Control)
Public Method | GetChildAtPoint | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | GetContainerControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | GetNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | GetPreferredSize | (Inherited from System.Windows.Forms.Control)
Public Method | Hide | (Inherited from System.Windows.Forms.Control)
Public Method | InitializeLifetimeService | (Inherited from System.MarshalByRefObject)
Public Method | Invalidate | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Invoke | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | LayoutMdi | (Inherited from System.Windows.Forms.Form)
Public Method | PerformAutoScale | (Inherited from System.Windows.Forms.ContainerControl)
Public Method | PerformLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | PointToClient | (Inherited from System.Windows.Forms.Control)
Public Method | PointToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessControlMessage | (Inherited from System.Windows.Forms.Control)
Public Method | PreProcessMessage | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToClient | (Inherited from System.Windows.Forms.Control)
Public Method | RectangleToScreen | (Inherited from System.Windows.Forms.Control)
Public Method | Refresh | (Inherited from System.Windows.Forms.Control)
Public Method | RemoveOwnedForm | (Inherited from System.Windows.Forms.Form)
Public Method | ResetText | (Inherited from System.Windows.Forms.Control)
Public Method | ResumeLayout | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | Scale | (Inherited from System.Windows.Forms.Control)
Public Method | ScrollControlIntoView | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | Select | Overloaded. (Inherited from System.Windows.Forms.Form)
Public Method | SelectNextControl | (Inherited from System.Windows.Forms.Control)
Public Method | SendToBack | (Inherited from System.Windows.Forms.Control)
Public Method | SetAutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Method | SetBounds | Overloaded. (Inherited from System.Windows.Forms.Control)
Public Method | SetDesktopBounds | (Inherited from System.Windows.Forms.Form)
Public Method | SetDesktopLocation | (Inherited from System.Windows.Forms.Form)
Public Method | Show | Overloaded. (Inherited from System.Windows.Forms.Form)
Public Method | ShowDialog | Overloaded. (Inherited from System.Windows.Forms.Form)
Public Method | SuspendLayout | (Inherited from System.Windows.Forms.Control)
Public Method | ToString | (Inherited from System.Windows.Forms.Form)
Public Method | Update | (Inherited from System.Windows.Forms.Control)
Public Method | Validate | Overloaded. (Inherited from System.Windows.Forms.ContainerControl)
Public Method | ValidateChildren | Overloaded. (Inherited from System.Windows.Forms.Form)
Top

Protected Methods

 | Name | Description
Protected Method | ActivateMdiChild | (Inherited from System.Windows.Forms.Form)
Protected Method | AdjustFormScrollbars | (Inherited from System.Windows.Forms.Form)
Protected Method | CenterToParent | (Inherited from System.Windows.Forms.Form)
Protected Method | CenterToScreen | (Inherited from System.Windows.Forms.Form)
Protected Method | CreateAccessibilityInstance | (Inherited from System.Windows.Forms.Control)
Protected Method | CreateControlsInstance | (Inherited from System.Windows.Forms.Form)
Protected Method | CreateHandle | (Inherited from System.Windows.Forms.Form)
Protected Method | DefWndProc | (Inherited from System.Windows.Forms.Form)
Protected Method | DestroyHandle | (Inherited from System.Windows.Forms.Control)
Protected Method | Finalize | (Inherited from System.ComponentModel.Component)
Protected Method | GetAccessibilityObjectById | (Inherited from System.Windows.Forms.Control)
Protected Method | GetAutoSizeMode | (Inherited from System.Windows.Forms.Control)
Protected Method | GetScaledBounds | (Inherited from System.Windows.Forms.Form)
Protected Method | GetScrollState | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | GetService | (Inherited from System.ComponentModel.Component)
Protected Method | GetStyle | (Inherited from System.Windows.Forms.Control)
Protected Method | GetTopLevel | (Inherited from System.Windows.Forms.Control)
Protected Method | InitLayout | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokeGotFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokeLostFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokeOnClick | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokePaint | (Inherited from System.Windows.Forms.Control)
Protected Method | InvokePaintBackground | (Inherited from System.Windows.Forms.Control)
Protected Method | IsInputChar | (Inherited from System.Windows.Forms.Control)
Protected Method | IsInputKey | (Inherited from System.Windows.Forms.Control)
Protected Method | MemberwiseClone | Overloaded. (Inherited from System.MarshalByRefObject)
Protected Method | NotifyInvalidate | (Inherited from System.Windows.Forms.Control)
Protected Method | OnActivated | (Inherited from System.Windows.Forms.Form)
Protected Method | OnAutoSizeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnAutoValidateChanged | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | OnBackColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnBackgroundImageChanged | (Inherited from System.Windows.Forms.Form)
Protected Method | OnBackgroundImageLayoutChanged | (Inherited from System.Windows.Forms.Form)
Protected Method | OnBindingContextChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnCausesValidationChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnChangeUICues | (Inherited from System.Windows.Forms.Control)
Protected Method | OnClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnClientSizeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnClosed | (Inherited from System.Windows.Forms.Form)
Protected Method | OnClosing | (Inherited from System.Windows.Forms.Form)
Protected Method | OnContextMenuChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnContextMenuStripChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnControlAdded | (Inherited from System.Windows.Forms.Control)
Protected Method | OnControlRemoved | (Inherited from System.Windows.Forms.Control)
Protected Method | OnCreateControl | (Inherited from System.Windows.Forms.Form)
Protected Method | OnCursorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDeactivate | (Inherited from System.Windows.Forms.Form)
Protected Method | OnDockChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDoubleClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragDrop | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragEnter | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragLeave | (Inherited from System.Windows.Forms.Control)
Protected Method | OnDragOver | (Inherited from System.Windows.Forms.Control)
Protected Method | OnEnabledChanged | (Inherited from System.Windows.Forms.Form)
Protected Method | OnEnter | (Inherited from System.Windows.Forms.Form)
Protected Method | OnFontChanged | (Inherited from System.Windows.Forms.Form)
Protected Method | OnForeColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnFormClosed | (Inherited from System.Windows.Forms.Form)
Protected Method | OnFormClosing | (Inherited from System.Windows.Forms.Form)
Protected Method | OnGiveFeedback | (Inherited from System.Windows.Forms.Control)
Protected Method | OnGotFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | OnHandleCreated | (Inherited from System.Windows.Forms.Form)
Protected Method | OnHandleDestroyed | (Inherited from System.Windows.Forms.Form)
Protected Method | OnHelpButtonClicked | (Inherited from System.Windows.Forms.Form)
Protected Method | OnHelpRequested | (Inherited from System.Windows.Forms.Control)
Protected Method | OnImeModeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnInputLanguageChanged | (Inherited from System.Windows.Forms.Form)
Protected Method | OnInputLanguageChanging | (Inherited from System.Windows.Forms.Form)
Protected Method | OnInvalidated | (Inherited from System.Windows.Forms.Control)
Protected Method | OnKeyDown | (Inherited from System.Windows.Forms.Control)
Protected Method | OnKeyPress | (Inherited from System.Windows.Forms.Control)
Protected Method | OnKeyUp | (Inherited from System.Windows.Forms.Control)
Protected Method | OnLayout | (Inherited from System.Windows.Forms.Form)
Protected Method | OnLeave | (Inherited from System.Windows.Forms.Control)
Protected Method | OnLoad | (Inherited from System.Windows.Forms.Form)
Protected Method | OnLocationChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnLostFocus | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMarginChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMaximizedBoundsChanged | (Inherited from System.Windows.Forms.Form)
Protected Method | OnMaximumSizeChanged | (Inherited from System.Windows.Forms.Form)
Protected Method | OnMdiChildActivate | (Inherited from System.Windows.Forms.Form)
Protected Method | OnMenuComplete | (Inherited from System.Windows.Forms.Form)
Protected Method | OnMenuStart | (Inherited from System.Windows.Forms.Form)
Protected Method | OnMinimumSizeChanged | (Inherited from System.Windows.Forms.Form)
Protected Method | OnMouseCaptureChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseDoubleClick | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseDown | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseEnter | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseHover | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseLeave | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseMove | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseUp | (Inherited from System.Windows.Forms.Control)
Protected Method | OnMouseWheel | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnMove | (Inherited from System.Windows.Forms.Control)
Protected Method | OnNotifyMessage | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPaddingChanged | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnPaint | (Inherited from System.Windows.Forms.Form)
Protected Method | OnPaintBackground | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnParentBackColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentBackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentBindingContextChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentChanged | (Inherited from System.Windows.Forms.ContainerControl)
Protected Method | OnParentCursorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentEnabledChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentFontChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentForeColorChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentRightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnParentVisibleChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPreviewKeyDown | (Inherited from System.Windows.Forms.Control)
Protected Method | OnPrint | (Inherited from System.Windows.Forms.Control)
Protected Method | OnQueryContinueDrag | (Inherited from System.Windows.Forms.Control)
Protected Method | OnRegionChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnResize | (Inherited from System.Windows.Forms.Form)
Protected Method | OnResizeBegin | (Inherited from System.Windows.Forms.Form)
Protected Method | OnResizeEnd | (Inherited from System.Windows.Forms.Form)
Protected Method | OnRightToLeftChanged | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnRightToLeftLayoutChanged | (Inherited from System.Windows.Forms.Form)
Protected Method | OnScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | OnShown | (Inherited from System.Windows.Forms.Form)
Protected Method | OnSizeChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnStyleChanged | (Inherited from System.Windows.Forms.Form)
Protected Method | OnSystemColorsChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnTabIndexChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnTabStopChanged | (Inherited from System.Windows.Forms.Control)
Protected Method | OnTextChanged | (Inherited from System.Windows.Forms.Form)
Protected Method | OnValidated | (Inherited from System.Windows.Forms.Control)
Protected Method | OnValidating | (Inherited from System.Windows.Forms.Control)
Protected Method | OnVisibleChanged | (Inherited from System.Windows.Forms.Form)
Protected Method | ProcessCmdKey | (Inherited from System.Windows.Forms.Form)
Protected Method | ProcessDialogChar | (Inherited from System.Windows.Forms.Form)
Protected Method | ProcessDialogKey | (Inherited from System.Windows.Forms.Form)
Protected Method | ProcessKeyEventArgs | (Inherited from System.Windows.Forms.Control)
Protected Method | ProcessKeyPreview | (Inherited from System.Windows.Forms.Form)
Protected Method | ProcessTabKey | (Inherited from System.Windows.Forms.Form)
Protected Method | RaiseDragEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RaiseKeyEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RaiseMouseEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RaisePaintEvent | (Inherited from System.Windows.Forms.Control)
Protected Method | RecreateHandle | (Inherited from System.Windows.Forms.Control)
Protected Method | ResetMouseEventArgs | (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateAlignment | Overloaded. (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateHorizontal | (Inherited from System.Windows.Forms.Control)
Protected Method | RtlTranslateLeftRight | (Inherited from System.Windows.Forms.Control)
Protected Method | ScaleControl | (Inherited from System.Windows.Forms.Form)
Protected Method | ScrollToControl | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | SetAutoSizeMode | (Inherited from System.Windows.Forms.Control)
Protected Method | SetBoundsCore | (Inherited from System.Windows.Forms.Form)
Protected Method | SetClientSizeCore | (Inherited from System.Windows.Forms.Form)
Protected Method | SetDisplayRectLocation | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | SetScrollState | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Method | SetStyle | (Inherited from System.Windows.Forms.Control)
Protected Method | SetTopLevel | (Inherited from System.Windows.Forms.Control)
Protected Method | SetVisibleCore | (Inherited from System.Windows.Forms.Form)
Protected Method | SizeFromClientSize | (Inherited from System.Windows.Forms.Control)
Protected Method | UpdateDefaultButton | (Inherited from System.Windows.Forms.Form)
Protected Method | UpdateStyles | (Inherited from System.Windows.Forms.Control)
Protected Method | UpdateZOrder | (Inherited from System.Windows.Forms.Control)
Protected Method | WndProc | (Inherited from System.Windows.Forms.Form)
Top

See Also

Reference

ImageListForm Class
ISNet.WebUI.WebTextEditor Namespace


Dispose Method

[image]
Intersoft WebTextEditor Documentation
Dispose Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : Dispose Method

Glossary Item Box

Clean up any resources being used.

Overload List

Overload | Description
Dispose(Boolean) | Clean up any resources being used.
Dispose() | (Inherited from System.ComponentModel.Component)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


Dispose(Boolean) Method

[image]
Intersoft WebTextEditor Documentation
Dispose(Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class > Dispose Method : Dispose(Boolean) Method

disposing
true if managed resources should be disposed; otherwise, false.

Glossary Item Box

Clean up any resources being used.

Syntax

Visual Basic (Declaration)
Protected Overloads Overrides Sub Dispose( _
   ByVal disposing As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim disposing As System.Boolean

instance.Dispose(disposing)
C#
protected override void Dispose(
   System.bool disposing
)
Delphi
protected procedure Dispose(
    disposing: System.Boolean
); override;
JScript
protected override function Dispose(
   disposing : System.boolean
);
Managed Extensions for C++
protected: void Dispose(
   System.bool disposing
) override
C++/CLI
protected:
void Dispose(
   System.bool disposing
) override

Parameters

disposing
true if managed resources should be disposed; otherwise, false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members
Overload List


Presets Class

[image]
Intersoft WebTextEditor Documentation
Presets Class
Members See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : Presets Class

Glossary Item Box

Object Model

Presets Class

Syntax

Visual Basic (Declaration)
Public Class Presets
Visual Basic (Usage) Copy Code
Dim instance As Presets
C#
public class Presets
Delphi
public class Presets
JScript
public class Presets
Managed Extensions for C++
public __gc class Presets
C++/CLI
public ref class Presets

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebTextEditor.Presets

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Presets Members
ISNet.WebUI.WebTextEditor Namespace


Presets Class Members

[image]
Intersoft WebTextEditor Documentation
Presets Class Members
See Also Methods Send Feedback
ISNet.WebUI.WebTextEditor Namespace : Presets Class

Glossary Item Box

The following tables list the members exposed by Presets.

Public Constructors

 | Name | Description
Public Constructor | Presets Constructor |
Top

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetDefaultStyle |
Top

See Also

Reference

Presets Class
ISNet.WebUI.WebTextEditor Namespace


Presets Constructor

[image]
Intersoft WebTextEditor Documentation
Presets Constructor
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > Presets Class : Presets Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New Presets()
C#
public Presets()
Delphi
public Presets();
JScript
public function Presets();
Managed Extensions for C++
public: Presets();
C++/CLI
public:
Presets();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Presets Class
Presets Members


Presets Class Methods

[image]
Intersoft WebTextEditor Documentation
Presets Class Methods
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : Presets Class

Glossary Item Box

For a list of all members of this type, see Presets members.

Public Methods

 | Name | Description
static (Shared in Visual Basic) | GetDefaultStyle |
Top

See Also

Reference

Presets Class
ISNet.WebUI.WebTextEditor Namespace


GetDefaultStyle Method

[image]
Intersoft WebTextEditor Documentation
GetDefaultStyle Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > Presets Class : GetDefaultStyle Method

mode
styleName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Function GetDefaultStyle( _
   ByVal mode As WebTextEditorDefaultStyleMode, _
   ByVal styleName As System.String _
) As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim mode As WebTextEditorDefaultStyleMode
Dim styleName As System.String
Dim value As ISNet.WebUI.WebStyle

value = Presets.GetDefaultStyle(mode, styleName)
C#
public static ISNet.WebUI.WebStyle GetDefaultStyle(
   WebTextEditorDefaultStyleMode mode,
   System.string styleName
)
Delphi
public function GetDefaultStyle(
    mode: WebTextEditorDefaultStyleMode;
    styleName: System.String
): ISNet.WebUI.WebStyle; static;
JScript
public static function GetDefaultStyle(
   mode : WebTextEditorDefaultStyleMode,
   styleName : System.String
) : ISNet.WebUI.WebStyle;
Managed Extensions for C++
public: static ISNet.WebUI.WebStyle* GetDefaultStyle(
   WebTextEditorDefaultStyleMode mode,
   System.string* styleName
)
C++/CLI
public:
static ISNet.WebUI.WebStyle^ GetDefaultStyle(
   WebTextEditorDefaultStyleMode mode,
   System.String^ styleName
)

Parameters

mode
styleName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Presets Class
Presets Members


SerializableList<T> Class

T
[image]
Intersoft WebTextEditor Documentation
SerializableList<T> Class
Members See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : SerializableList<T> Class

Glossary Item Box

Object Model

SerializableList<T> Class

Syntax

Visual Basic (Declaration)
<System.SerializableAttribute()>
Public Class SerializableList(Of T)
   Inherits System.Collections.Generic.List(Of T)
Visual Basic (Usage) Copy Code
Dim instance As SerializableList(Of T)
C#
[System.SerializableAttribute()]
public class SerializableList<T> : System.Collections.Generic.List<T>
Delphi
public class SerializableList = class(System.Collections.Generic.List)
JScript
JScript does not support Generics.
Managed Extensions for C++
[System.SerializableAttribute()]
public __gc class SerializableList<T> : public System.Collections.Generic.List<T>
C++/CLI
[System.SerializableAttribute()]
generic<typename T>
public ref class SerializableList : public System.Collections.Generic.List<T>

Type Parameters

T

Inheritance Hierarchy

System.Object
System.Collections.Generic.List<T>
ISNet.WebUI.WebTextEditor.SerializableList<T>

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializableList<T> Members
ISNet.WebUI.WebTextEditor Namespace


SerializableList<T> Class Members

[image]
Intersoft WebTextEditor Documentation
SerializableList<T> Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebTextEditor Namespace : SerializableList<T> Class

Glossary Item Box

The following tables list the members exposed by SerializableList<T>.

Public Constructors

 | Name | Description
Public Constructor | SerializableList<T> Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.Generic.List<T>)
Public Property | Count | (Inherited from System.Collections.Generic.List<T>)
Public Property | Item | (Inherited from System.Collections.Generic.List<T>)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.Generic.List<T>)
Public Method | AddRange | (Inherited from System.Collections.Generic.List<T>)
Public Method | AsReadOnly | (Inherited from System.Collections.Generic.List<T>)
Public Method | BinarySearch | Overloaded. (Inherited from System.Collections.Generic.List<T>)
Public Method | Clear | (Inherited from System.Collections.Generic.List<T>)
Public Method | Contains | (Inherited from System.Collections.Generic.List<T>)
Public Method | ConvertAll<TOutput> | (Inherited from System.Collections.Generic.List<T>)
Public Method | CopyTo | Overloaded. (Inherited from System.Collections.Generic.List<T>)
Public Method | Exists | (Inherited from System.Collections.Generic.List<T>)
Public Method | Find | (Inherited from System.Collections.Generic.List<T>)
Public Method | FindAll | (Inherited from System.Collections.Generic.List<T>)
Public Method | FindIndex | Overloaded. (Inherited from System.Collections.Generic.List<T>)
Public Method | FindLast | (Inherited from System.Collections.Generic.List<T>)
Public Method | FindLastIndex | Overloaded. (Inherited from System.Collections.Generic.List<T>)
Public Method | ForEach | (Inherited from System.Collections.Generic.List<T>)
Public Method | GetEnumerator | (Inherited from System.Collections.Generic.List<T>)
Public Method | GetObjectData |
Public Method | GetRange | (Inherited from System.Collections.Generic.List<T>)
Public Method | IndexOf | Overloaded. (Inherited from System.Collections.Generic.List<T>)
Public Method | Insert | (Inherited from System.Collections.Generic.List<T>)
Public Method | InsertRange | (Inherited from System.Collections.Generic.List<T>)
Public Method | LastIndexOf | Overloaded. (Inherited from System.Collections.Generic.List<T>)
Public Method | Remove | (Inherited from System.Collections.Generic.List<T>)
Public Method | RemoveAll | (Inherited from System.Collections.Generic.List<T>)
Public Method | RemoveAt | (Inherited from System.Collections.Generic.List<T>)
Public Method | RemoveRange | (Inherited from System.Collections.Generic.List<T>)
Public Method | Reverse | Overloaded. (Inherited from System.Collections.Generic.List<T>)
Public Method | Sort | Overloaded. (Inherited from System.Collections.Generic.List<T>)
Public Method | ToArray | (Inherited from System.Collections.Generic.List<T>)
Public Method | TrimExcess | (Inherited from System.Collections.Generic.List<T>)
Public Method | TrueForAll | (Inherited from System.Collections.Generic.List<T>)
Top

See Also

Reference

SerializableList<T> Class
ISNet.WebUI.WebTextEditor Namespace


SerializableList<T> Constructor

[image]
Intersoft WebTextEditor Documentation
SerializableList<T> Constructor
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > SerializableList<T> Class : SerializableList<T> Constructor

Glossary Item Box

Overload List

Overload | Description
SerializableList<T> Constructor() |
SerializableList<T> Constructor(SerializationInfo,StreamingContext) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializableList<T> Class
SerializableList<T> Members


SerializableList<T> Constructor()

[image]
Intersoft WebTextEditor Documentation
SerializableList<T> Constructor()
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > SerializableList<T> Class > SerializableList<T> Constructor : SerializableList<T> Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New SerializableList(Of T)()
C#
public SerializableList<T>()
Delphi
public SerializableList<T>();
JScript
public function SerializableList<T>();
Managed Extensions for C++
public: SerializableList<T>();
C++/CLI
public:
SerializableList<T>();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializableList<T> Class
SerializableList<T> Members
Overload List


SerializableList<T> Constructor(SerializationInfo,StreamingContext)

[image]
Intersoft WebTextEditor Documentation
SerializableList<T> Constructor(SerializationInfo,StreamingContext)
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > SerializableList<T> Class > SerializableList<T> Constructor : SerializableList<T> Constructor(SerializationInfo,StreamingContext)

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

Dim instance As New SerializableList(Of T)(info, context)
C#
protected SerializableList<T>(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
protected SerializableList<T>(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
protected function SerializableList<T>(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
protected: SerializableList<T>(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
protected:
SerializableList<T>(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializableList<T> Class
SerializableList<T> Members
Overload List


SerializableList<T> Class Methods

[image]
Intersoft WebTextEditor Documentation
SerializableList<T> Class Methods
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : SerializableList<T> Class

Glossary Item Box

For a list of all members of this type, see SerializableList<T> members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.Generic.List<T>)
Public Method | AddRange | (Inherited from System.Collections.Generic.List<T>)
Public Method | AsReadOnly | (Inherited from System.Collections.Generic.List<T>)
Public Method | BinarySearch | Overloaded. (Inherited from System.Collections.Generic.List<T>)
Public Method | Clear | (Inherited from System.Collections.Generic.List<T>)
Public Method | Contains | (Inherited from System.Collections.Generic.List<T>)
Public Method | ConvertAll<TOutput> | (Inherited from System.Collections.Generic.List<T>)
Public Method | CopyTo | Overloaded. (Inherited from System.Collections.Generic.List<T>)
Public Method | Exists | (Inherited from System.Collections.Generic.List<T>)
Public Method | Find | (Inherited from System.Collections.Generic.List<T>)
Public Method | FindAll | (Inherited from System.Collections.Generic.List<T>)
Public Method | FindIndex | Overloaded. (Inherited from System.Collections.Generic.List<T>)
Public Method | FindLast | (Inherited from System.Collections.Generic.List<T>)
Public Method | FindLastIndex | Overloaded. (Inherited from System.Collections.Generic.List<T>)
Public Method | ForEach | (Inherited from System.Collections.Generic.List<T>)
Public Method | GetEnumerator | (Inherited from System.Collections.Generic.List<T>)
Public Method | GetObjectData |
Public Method | GetRange | (Inherited from System.Collections.Generic.List<T>)
Public Method | IndexOf | Overloaded. (Inherited from System.Collections.Generic.List<T>)
Public Method | Insert | (Inherited from System.Collections.Generic.List<T>)
Public Method | InsertRange | (Inherited from System.Collections.Generic.List<T>)
Public Method | LastIndexOf | Overloaded. (Inherited from System.Collections.Generic.List<T>)
Public Method | Remove | (Inherited from System.Collections.Generic.List<T>)
Public Method | RemoveAll | (Inherited from System.Collections.Generic.List<T>)
Public Method | RemoveAt | (Inherited from System.Collections.Generic.List<T>)
Public Method | RemoveRange | (Inherited from System.Collections.Generic.List<T>)
Public Method | Reverse | Overloaded. (Inherited from System.Collections.Generic.List<T>)
Public Method | Sort | Overloaded. (Inherited from System.Collections.Generic.List<T>)
Public Method | ToArray | (Inherited from System.Collections.Generic.List<T>)
Public Method | TrimExcess | (Inherited from System.Collections.Generic.List<T>)
Public Method | TrueForAll | (Inherited from System.Collections.Generic.List<T>)
Top

See Also

Reference

SerializableList<T> Class
ISNet.WebUI.WebTextEditor Namespace


GetObjectData Method

[image]
Intersoft WebTextEditor Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > SerializableList<T> Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As SerializableList(Of T)
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializableList<T> Class
SerializableList<T> Members


WebFileUploader Class

[image]
Intersoft WebTextEditor Documentation
WebFileUploader Class
Members See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebFileUploader Class

Glossary Item Box

Intersoft WebFileUploader is a memory-efficient ASP.NET file uploading component that supports asynchronous multiple files upload without page refresh. Unlike standard ASP.NET file uploader, WebFileUploader enables large file uploading with very minimum memory and resources consumption.

Object Model

WebFileUploader Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.ToolboxDataAttribute("<{0}:WebFileUploader runat=server></{0}:WebFileUploader>")>
<System.ComponentModel.DefaultPropertyAttribute("UploadPath")>
<ISNet.Serialization.XmlSerializableAttribute(JSFileNames="WebFileUploader.js", Type=XmlSerializationType.ClientAndLayout)>
<System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand Or  _
    SecurityAction.Deny Or  _
    SecurityAction.LinkDemand,
   Unrestricted=False)>
<System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand Or  _
    SecurityAction.Assert Or  _
    SecurityAction.Deny Or  _
    SecurityAction.PermitOnly Or  _
    SecurityAction.LinkDemand Or  _
    SecurityAction.InheritanceDemand,
   Unrestricted=False)>
Public Class WebFileUploader
   Inherits ISNet.WebUI.ISNetControl
   Implements ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
C#
[System.Web.UI.ToolboxDataAttribute("<{0}:WebFileUploader runat=server></{0}:WebFileUploader>")]
[System.ComponentModel.DefaultPropertyAttribute("UploadPath")]
[ISNet.Serialization.XmlSerializableAttribute(JSFileNames="WebFileUploader.js", Type=XmlSerializationType.ClientAndLayout)]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public class WebFileUploader : ISNet.WebUI.ISNetControl, ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings
Delphi
public class WebFileUploader = class(ISNet.WebUI.ISNetControl, ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings)
JScript
System.Web.UI.ToolboxDataAttribute("<{0}:WebFileUploader runat=server></{0}:WebFileUploader>")
System.ComponentModel.DefaultPropertyAttribute("UploadPath")
ISNet.Serialization.XmlSerializableAttribute(JSFileNames="WebFileUploader.js", Type=XmlSerializationType.ClientAndLayout)
System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=)
System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=)
public class WebFileUploader extends ISNet.WebUI.ISNetControl implements ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings
Managed Extensions for C++
[System.Web.UI.ToolboxDataAttribute("<{0}:WebFileUploader runat=server></{0}:WebFileUploader>")]
[System.ComponentModel.DefaultPropertyAttribute("UploadPath")]
[ISNet.Serialization.XmlSerializableAttribute(JSFileNames="WebFileUploader.js", Type=XmlSerializationType.ClientAndLayout)]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public __gc class WebFileUploader : public ISNet.WebUI.ISNetControl, ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings
C++/CLI
[System.Web.UI.ToolboxDataAttribute("<{0}:WebFileUploader runat=server></{0}:WebFileUploader>")]
[System.ComponentModel.DefaultPropertyAttribute("UploadPath")]
[ISNet.Serialization.XmlSerializableAttribute(JSFileNames="WebFileUploader.js", Type=XmlSerializationType.ClientAndLayout)]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public ref class WebFileUploader : public ISNet.WebUI.ISNetControl, ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings

Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
ISNet.WebUI.ISNetControl
ISNet.WebUI.WebTextEditor.WebFileUploader

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Members
ISNet.WebUI.WebTextEditor Namespace


WebFileUploader Class Members

[image]
Intersoft WebTextEditor Documentation
WebFileUploader Class Members
See Also Fields Properties Methods Events Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebFileUploader Class

Glossary Item Box

The following tables list the members exposed by WebFileUploader.

Public Constructors

 | Name | Description
Public Constructor | WebFileUploader Constructor | Overloaded.
Top

Protected Fields

 | Name | Description
Protected Field | isPagePreRender | (Inherited from ISNet.WebUI.ISNetControl)
Protected Field | renderDHTML | (Inherited from ISNet.WebUI.ISNetControl)
Protected Field | renderNS | (Inherited from ISNet.WebUI.ISNetControl)
Protected Field | viewStateLoaded | (Inherited from ISNet.WebUI.ISNetControl)
Top

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | AllowAdd | Gets or sets a value indicating whether user can add upload field via Add button.
Public Property | AllowCancel | Determines whether allow cancel is true or not.
Public Property | AllowRemove | Gets or sets a value indicating whether user can remove upload field via Remove button.
Public Property | AllowSimultaneousUpload | Gets or sets a value indicating whether simultaneous upload is allowed.
Public Property | AppRelativeTemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | AspNetAjaxSettings | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Attributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BackColor | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | BorderColor | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | BorderStyle | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | BorderWidth | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Caption | Specifies caption of WebUploader.
Public Property | ClientAction |
Public Property | ClientID | (Inherited from System.Web.UI.Control)
Public Property | ClientIDMode | (Inherited from System.Web.UI.Control)
Public Property | ClientSideEvents | Contains client side events supported by WebUploader.
Public Property | ControlDataTransferFormat | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Controls | (Inherited from System.Web.UI.Control)
Public Property | ControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ControlStyleCreated | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | CssClass | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | DefaultButtonHeight | Specifies button height of WebUploader.
Public Property | DefaultButtonWidth | Specifies button width of WebUploader.
Public Property | DefaultProgressBarHeight | Specifies progress bar's height of WebUploader.
Public Property | DefaultSelectButtonHeight | Specifies select button height of WebUploader.
Public Property | DefaultSelectButtonWidth | Specifies select button width of WebUploader.
Public Property | DefaultTextBoxHeight | Specifies TextBox height of WebUploader.
Public Property | DefaultTextBoxWidth | Specifies TextBox width of WebUploader.
Public Property | Enabled | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableManagedTheming | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | FilesCount | The total number of file that can be uploaded (0 for no limit).
Public Property | FileTypes | Specifies File type of WebUploader.
Public Property | FlyPostBackSettings | Configures the settings used by the control when performing OnTheFly postback.
Public Property | Font | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ForeColor | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | GUID |
Public Property | HasAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Height | Overridden.
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | ImagesDirectory | Gets or sets the directory where all required scripts for the control are stored.
Public Property | ImageSettings | Provides settings that control the images in WebUploader.
Public Property | InitialFilesCount | The total number of file that can be uploaded (0 for no limit).
Public Property | IsControlThemed | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | IsDesign | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | IsDynamicCreated | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | IsInternalCreated | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | IsUnloaded | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | MaxTextLength |
Public Property | NamingContainer | (Inherited from System.Web.UI.Control)
Public Property | Page | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Parent | (Inherited from System.Web.UI.Control)
Public Property | ParentStyleId | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | PostbackMode | Specifies Postback mode of WebUploader.
Public Property | PriorityUploadType | Specifies priority upload type of WebUploader.
Public Property | ProgressInformation | Provides WebUploader progress information.
Public Property | ProgressLatency | Specifies progress latency of WebUploader.
Public Property | RenderingCompatibility | (Inherited from System.Web.UI.Control)
Public Property | RenderingMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RequiresUIRefresh | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RuntimeLicenseKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | SaveViewStateOnFlyPostback | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ScriptDirectory | Overridden. Gets or sets the directory where all required scripts for the control are stored.
Public Property | SerializedJSFiles | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | SerializedStyles | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | SharedScriptDirectory | Overridden. Gets or sets the directory where all required scripts for the control are stored.
Public Property | Site | (Inherited from System.Web.UI.Control)
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Style | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | StyleSettings | Contains interactive style for WebUploader.
Public Property | SupportsDisabledAttribute | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | SupportXMLCultureInfo | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | TabIndex | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | TemplateControl | (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | TextSettings | Provides settings that control text that shown in WebUploader.
Public Property | ToolTip | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | TotalUploadSizeLimit | The total number of bytes that can be uploaded (0 for no limit).
Public Property | UILayout | Specifies UILayout of WebUploader.
Public Property | UniqueID | (Inherited from System.Web.UI.Control)
Public Property | UploadPath | Specifies upload path of WebUploader.
Public Property | UploadSizeLimit | The number of bytes that can be uploaded (0 for no limit) for each file.
Public Property | UploadType | Specifies upload type of WebUploader.
Public Property | UseDefaultStyle | Gets or sets a value indicating whether default style is used.
Public Property | ValidateRequestMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateItems | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateServerConnection | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateStorage | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Visible | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Width | Overridden.
Public Property | XmlCompressionEnabled | (Inherited from ISNet.WebUI.ISNetControl)
Top

Protected Properties

 | Name | Description
Protected Property | Adapter | (Inherited from System.Web.UI.Control)
Protected Property | ChildControlsCreated | (Inherited from System.Web.UI.Control)
Protected Property | ClientIDSeparator | (Inherited from System.Web.UI.Control)
Protected Property | DefaultImagesFolder | Overridden.
Protected Property | Events | (Inherited from System.Web.UI.Control)
Protected Property | HasChildViewState | (Inherited from System.Web.UI.Control)
Protected Property | IdSeparator | (Inherited from System.Web.UI.Control)
Protected Property | IsMvc | (Inherited from ISNet.WebUI.ISNetControl)
Protected Property | IsTrackingViewState | (Inherited from System.Web.UI.Control)
Protected Property | LicenseType | Overridden.
Protected Property | LoadViewStateByID | (Inherited from System.Web.UI.Control)
Protected Property | MaxJsonLength | (Inherited from ISNet.WebUI.ISNetControl)
Protected Property | Product | Overridden.
Protected Property | ProductIcon | Overridden.
Protected Property | ProductImage | Overridden.
Protected Property | TagKey | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Property | TagName | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Property | ViewState | (Inherited from System.Web.UI.Control)
Protected Property | ViewStateIgnoresCase | (Inherited from System.Web.UI.Control)
Top

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CanUseWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Clone | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | DataBind | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | ForceDisableXmlCompression | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetClientAction |
static (Shared in Visual Basic) | GetContext | Overloaded.
Public Method | GetCurrentControlLifeCycle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkDataFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkVersion | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetIntersoftFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetLayoutFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetObjectData | Overridden.
Public Method | GetPhysicalUploadPath |
Public Method | GetPostedXMLData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductInfoKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductSimpleName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetPropertyValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetResourceStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetRouteUrl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | GetUniqueIDRelativeTo | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
static (Shared in Visual Basic) | HasNewerContext |
Public Method | IsAtlasCallback | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsBetaRelease | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsChromeBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackRequest | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoBasedBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoVersion18 | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInDesignMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorer8Browser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorerBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsOperaBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsSafariBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsW3CStandardBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromPredefinedName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadPostData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | OnAfterUpload | Fires after uploading proces.
static (Shared in Visual Basic) | OnApplicationEnd |
static (Shared in Visual Basic) | OnApplicationStart |
Public Method | OnCancelUpload | Fires when cancel is triggered when uploading process.
Public Method | OnErrorUpload | Fires when uploading process generate error.
Public Method | OnInfoChanged | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | OnPreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | OnPreRender | Overloaded. Overridden.
Public Method | OnRequest |
Public Method | OnUploading | Fires when WebUploader is in uploading process.
Public Method | RaisePostDataChangedEvent | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ReadWebConfigValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterBoxSizing | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterGlobalStyle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterLink | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterOptimizedCssClasses | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterPreloadImage | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterScript | Overridden.
Public Method | RegisterSharePointHandler | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderBeginTag | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderControl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Reset | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveImagePath | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveRelativeURL | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveResourceUrl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SaveLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Public Method | SetSessionTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SetUploadPath |
Public Method | ShouldReturnJson | (Inherited from ISNet.WebUI.ISNetControl)
Top

Protected Methods

 | Name | Description
Protected Method | AddAttributesToRender | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | AddParsedSubObject | (Inherited from System.Web.UI.Control)
Protected Method | ApplyControlTheme | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | AssignXmlInputHiddenUniqueID | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | BuildProfileTree | (Inherited from System.Web.UI.Control)
Protected Method | ClearCachedClientID | (Inherited from System.Web.UI.Control)
Protected Method | ClearChildControlState | (Inherited from System.Web.UI.Control)
Protected Method | ClearChildState | (Inherited from System.Web.UI.Control)
Protected Method | ClearChildViewState | (Inherited from System.Web.UI.Control)
Protected Method | ClearEffectiveClientIDMode | (Inherited from System.Web.UI.Control)
Protected Method | ControlRequestHandler | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | CreateChildControls | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | CreateControlCollection | (Inherited from System.Web.UI.Control)
Protected Method | CreateControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | CreateThemeInfo | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | DataBindChildren | (Inherited from System.Web.UI.Control)
Protected Method | DecodeRequest | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | EnsureChildControls | (Inherited from System.Web.UI.Control)
Protected Method | EnsureID | (Inherited from System.Web.UI.Control)
Protected Method | GetApplicationState | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | GetCachedAppTheme | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | GetDesignModeState | (Inherited from System.Web.UI.Control)
Protected Method | GetDHTMLRenderer | Overridden.
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | GetSessionLevelTheme | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | HasEvents | (Inherited from System.Web.UI.Control)
Protected Method | InitializeDefaultStyles | Overridden.
Protected Method | InitializeLayoutBehaviors | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | InitializeManagedTheming | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | InitializeStyles | Overridden.
Protected Method | IsApplicationAvailable | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | IsAppThemeEnabled | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | IsLiteralContent | (Inherited from System.Web.UI.Control)
Protected Method | IsSessionAvailable | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | LoadControlState | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | LoadViewState | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | OnBubbleEvent | (Inherited from System.Web.UI.Control)
Protected Method | OnDataBinding | (Inherited from System.Web.UI.Control)
Protected Method | OnInit | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | OnLoad | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | RaiseBubbleEvent | (Inherited from System.Web.UI.Control)
Protected Method | RenderContents | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | ResetFilteredStyle | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | ResolveAdapter | (Inherited from System.Web.UI.Control)
Protected Method | SaveControlState | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | SaveViewState | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | SetDesignModeState | (Inherited from System.Web.UI.Control)
Protected Method | SetTheme | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | ShowAboutBox | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | TrackViewState | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | UseDeepCloneForViewStateStorage | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | UseMemoryStreamStateType | (Inherited from ISNet.WebUI.ISNetControl)
Top

Public Events

 | Name | Description
Public Event | AfterUpload |
Public Event | CancelUpload |
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | ErrorUpload |
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Public Event | Uploading |
Top

See Also

Reference

WebFileUploader Class
ISNet.WebUI.WebTextEditor Namespace


WebFileUploader Constructor

[image]
Intersoft WebTextEditor Documentation
WebFileUploader Constructor
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : WebFileUploader Constructor

Glossary Item Box

Overload List

Overload | Description
WebFileUploader Constructor() |
WebFileUploader Constructor(SerializationInfo,StreamingContext) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


WebFileUploader Constructor()

[image]
Intersoft WebTextEditor Documentation
WebFileUploader Constructor()
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class > WebFileUploader Constructor : WebFileUploader Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebFileUploader()
C#
public WebFileUploader()
Delphi
public WebFileUploader();
JScript
public function WebFileUploader();
Managed Extensions for C++
public: WebFileUploader();
C++/CLI
public:
WebFileUploader();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members
Overload List


WebFileUploader Constructor(SerializationInfo,StreamingContext)

[image]
Intersoft WebTextEditor Documentation
WebFileUploader Constructor(SerializationInfo,StreamingContext)
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class > WebFileUploader Constructor : WebFileUploader Constructor(SerializationInfo,StreamingContext)

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

Dim instance As New WebFileUploader(info, context)
C#
protected WebFileUploader(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
protected WebFileUploader(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
protected function WebFileUploader(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
protected: WebFileUploader(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
protected:
WebFileUploader(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members
Overload List


WebFileUploader Class Methods

[image]
Intersoft WebTextEditor Documentation
WebFileUploader Class Methods
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebFileUploader Class

Glossary Item Box

For a list of all members of this type, see WebFileUploader members.

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CanUseWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Clone | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | DataBind | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | ForceDisableXmlCompression | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetClientAction |
static (Shared in Visual Basic) | GetContext | Overloaded.
Public Method | GetCurrentControlLifeCycle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkDataFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkVersion | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetIntersoftFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetLayoutFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetObjectData | Overridden.
Public Method | GetPhysicalUploadPath |
Public Method | GetPostedXMLData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductInfoKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductSimpleName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetPropertyValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetResourceStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetRouteUrl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | GetUniqueIDRelativeTo | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
static (Shared in Visual Basic) | HasNewerContext |
Public Method | IsAtlasCallback | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsBetaRelease | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsChromeBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackRequest | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoBasedBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoVersion18 | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInDesignMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorer8Browser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorerBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsOperaBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsSafariBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsW3CStandardBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromPredefinedName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadPostData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | OnAfterUpload | Fires after uploading proces.
static (Shared in Visual Basic) | OnApplicationEnd |
static (Shared in Visual Basic) | OnApplicationStart |
Public Method | OnCancelUpload | Fires when cancel is triggered when uploading process.
Public Method | OnErrorUpload | Fires when uploading process generate error.
Public Method | OnInfoChanged | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | OnPreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | OnPreRender | Overloaded. Overridden.
Public Method | OnRequest |
Public Method | OnUploading | Fires when WebUploader is in uploading process.
Public Method | RaisePostDataChangedEvent | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ReadWebConfigValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterBoxSizing | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterGlobalStyle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterLink | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterOptimizedCssClasses | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterPreloadImage | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterScript | Overridden.
Public Method | RegisterSharePointHandler | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderBeginTag | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderControl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Reset | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveImagePath | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveRelativeURL | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveResourceUrl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SaveLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Public Method | SetSessionTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SetUploadPath |
Public Method | ShouldReturnJson | (Inherited from ISNet.WebUI.ISNetControl)
Top

Protected Methods

 | Name | Description
Protected Method | AddAttributesToRender | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | AddParsedSubObject | (Inherited from System.Web.UI.Control)
Protected Method | ApplyControlTheme | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | AssignXmlInputHiddenUniqueID | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | BuildProfileTree | (Inherited from System.Web.UI.Control)
Protected Method | ClearCachedClientID | (Inherited from System.Web.UI.Control)
Protected Method | ClearChildControlState | (Inherited from System.Web.UI.Control)
Protected Method | ClearChildState | (Inherited from System.Web.UI.Control)
Protected Method | ClearChildViewState | (Inherited from System.Web.UI.Control)
Protected Method | ClearEffectiveClientIDMode | (Inherited from System.Web.UI.Control)
Protected Method | ControlRequestHandler | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | CreateChildControls | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | CreateControlCollection | (Inherited from System.Web.UI.Control)
Protected Method | CreateControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | CreateThemeInfo | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | DataBindChildren | (Inherited from System.Web.UI.Control)
Protected Method | DecodeRequest | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | EnsureChildControls | (Inherited from System.Web.UI.Control)
Protected Method | EnsureID | (Inherited from System.Web.UI.Control)
Protected Method | GetApplicationState | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | GetCachedAppTheme | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | GetDesignModeState | (Inherited from System.Web.UI.Control)
Protected Method | GetDHTMLRenderer | Overridden.
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | GetSessionLevelTheme | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | HasEvents | (Inherited from System.Web.UI.Control)
Protected Method | InitializeDefaultStyles | Overridden.
Protected Method | InitializeLayoutBehaviors | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | InitializeManagedTheming | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | InitializeStyles | Overridden.
Protected Method | IsApplicationAvailable | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | IsAppThemeEnabled | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | IsLiteralContent | (Inherited from System.Web.UI.Control)
Protected Method | IsSessionAvailable | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | LoadControlState | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | LoadViewState | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | OnBubbleEvent | (Inherited from System.Web.UI.Control)
Protected Method | OnDataBinding | (Inherited from System.Web.UI.Control)
Protected Method | OnInit | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | OnLoad | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | RaiseBubbleEvent | (Inherited from System.Web.UI.Control)
Protected Method | RenderContents | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | ResetFilteredStyle | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | ResolveAdapter | (Inherited from System.Web.UI.Control)
Protected Method | SaveControlState | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | SaveViewState | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | SetDesignModeState | (Inherited from System.Web.UI.Control)
Protected Method | SetTheme | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | ShowAboutBox | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | TrackViewState | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | UseDeepCloneForViewStateStorage | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | UseMemoryStreamStateType | (Inherited from ISNet.WebUI.ISNetControl)
Top

See Also

Reference

WebFileUploader Class
ISNet.WebUI.WebTextEditor Namespace


GetClientAction Method

[image]
Intersoft WebTextEditor Documentation
GetClientAction Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : GetClientAction Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetClientAction() As ISNet.WebUI.BaseClientSideAction
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As ISNet.WebUI.BaseClientSideAction

value = instance.GetClientAction()
C#
public ISNet.WebUI.BaseClientSideAction GetClientAction()
Delphi
public function GetClientAction(): ISNet.WebUI.BaseClientSideAction;
JScript
public function GetClientAction() : ISNet.WebUI.BaseClientSideAction;
Managed Extensions for C++
public: ISNet.WebUI.BaseClientSideAction* GetClientAction();
C++/CLI
public:
ISNet.WebUI.BaseClientSideAction^ GetClientAction();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


GetContext Method

[image]
Intersoft WebTextEditor Documentation
GetContext Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : GetContext Method

Glossary Item Box

Overload List

Overload | Description
GetContext(String) |
GetContext(WebFileUploader) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


GetContext(String) Method

[image]
Intersoft WebTextEditor Documentation
GetContext(String) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class > GetContext Method : GetContext(String) Method

guid

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function GetContext( _
   ByVal guid As System.String _
) As WebFileUploaderInfo
Visual Basic (Usage) Copy Code
Dim guid As System.String
Dim value As WebFileUploaderInfo

value = WebFileUploader.GetContext(guid)
C#
public static WebFileUploaderInfo GetContext(
   System.string guid
)
Delphi
public function GetContext(
    guid: System.String
): WebFileUploaderInfo; static;
JScript
public static function GetContext(
   guid : System.String
) : WebFileUploaderInfo;
Managed Extensions for C++
public: static WebFileUploaderInfo* GetContext(
   System.string* guid
)
C++/CLI
public:
static WebFileUploaderInfo^ GetContext(
   System.String^ guid
)

Parameters

guid

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members
Overload List


GetContext(WebFileUploader) Method

[image]
Intersoft WebTextEditor Documentation
GetContext(WebFileUploader) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class > GetContext Method : GetContext(WebFileUploader) Method

fileUploader

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Shared Function GetContext( _
   ByVal fileUploader As WebFileUploader _
) As WebFileUploaderInfo
Visual Basic (Usage) Copy Code
Dim fileUploader As WebFileUploader
Dim value As WebFileUploaderInfo

value = WebFileUploader.GetContext(fileUploader)
C#
public static WebFileUploaderInfo GetContext(
   WebFileUploader fileUploader
)
Delphi
public function GetContext(
    fileUploader: WebFileUploader
): WebFileUploaderInfo; static;
JScript
public static function GetContext(
   fileUploader : WebFileUploader
) : WebFileUploaderInfo;
Managed Extensions for C++
public: static WebFileUploaderInfo* GetContext(
   WebFileUploader* fileUploader
)
C++/CLI
public:
static WebFileUploaderInfo^ GetContext(
   WebFileUploader^ fileUploader
)

Parameters

fileUploader

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members
Overload List


GetDHTMLRenderer Method

[image]
Intersoft WebTextEditor Documentation
GetDHTMLRenderer Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : GetDHTMLRenderer Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetDHTMLRenderer() As ISNet.WebUI.RenderDHTML
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As ISNet.WebUI.RenderDHTML

value = instance.GetDHTMLRenderer()
C#
protected override ISNet.WebUI.RenderDHTML GetDHTMLRenderer()
Delphi
protected function GetDHTMLRenderer(): ISNet.WebUI.RenderDHTML; override;
JScript
protected override function GetDHTMLRenderer() : ISNet.WebUI.RenderDHTML;
Managed Extensions for C++
protected: ISNet.WebUI.RenderDHTML* GetDHTMLRenderer(); override
C++/CLI
protected:
ISNet.WebUI.RenderDHTML^ GetDHTMLRenderer(); override

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


GetObjectData Method

[image]
Intersoft WebTextEditor Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


GetPhysicalUploadPath Method

[image]
Intersoft WebTextEditor Documentation
GetPhysicalUploadPath Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : GetPhysicalUploadPath Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetPhysicalUploadPath() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.String

value = instance.GetPhysicalUploadPath()
C#
public System.string GetPhysicalUploadPath()
Delphi
public function GetPhysicalUploadPath(): System.String;
JScript
public function GetPhysicalUploadPath() : System.String;
Managed Extensions for C++
public: System.string* GetPhysicalUploadPath();
C++/CLI
public:
System.String^ GetPhysicalUploadPath();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


HasNewerContext Method

[image]
Intersoft WebTextEditor Documentation
HasNewerContext Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : HasNewerContext Method

guid
lastAccess

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Function HasNewerContext( _
   ByVal guid As System.String, _
   ByVal lastAccess As System.Date _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim guid As System.String
Dim lastAccess As System.Date
Dim value As System.Boolean

value = WebFileUploader.HasNewerContext(guid, lastAccess)
C#
public static System.bool HasNewerContext(
   System.string guid,
   System.DateTime lastAccess
)
Delphi
public function HasNewerContext(
    guid: System.String;
    lastAccess: System.DateTime
): System.Boolean; static;
JScript
public static function HasNewerContext(
   guid : System.String,
   lastAccess : System.DateTime
) : System.boolean;
Managed Extensions for C++
public: static System.bool HasNewerContext(
   System.string* guid,
   System.DateTime lastAccess
)
C++/CLI
public:
static System.bool HasNewerContext(
   System.String^ guid,
   System.DateTime lastAccess
)

Parameters

guid
lastAccess

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


InitializeDefaultStyles Method

[image]
Intersoft WebTextEditor Documentation
InitializeDefaultStyles Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : InitializeDefaultStyles Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overrides Sub InitializeDefaultStyles()
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader

instance.InitializeDefaultStyles()
C#
protected override void InitializeDefaultStyles()
Delphi
protected procedure InitializeDefaultStyles(); override;
JScript
protected override function InitializeDefaultStyles();
Managed Extensions for C++
protected: void InitializeDefaultStyles(); override
C++/CLI
protected:
void InitializeDefaultStyles(); override

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


InitializeStyles Method

[image]
Intersoft WebTextEditor Documentation
InitializeStyles Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : InitializeStyles Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overrides Sub InitializeStyles()
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader

instance.InitializeStyles()
C#
protected override void InitializeStyles()
Delphi
protected procedure InitializeStyles(); override;
JScript
protected override function InitializeStyles();
Managed Extensions for C++
protected: void InitializeStyles(); override
C++/CLI
protected:
void InitializeStyles(); override

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


OnAfterUpload Method

[image]
Intersoft WebTextEditor Documentation
OnAfterUpload Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : OnAfterUpload Method

e

Glossary Item Box

Fires after uploading proces.

Syntax

Visual Basic (Declaration)
Public Sub OnAfterUpload( _
   ByVal e As WebFileUploaderFileEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim e As WebFileUploaderFileEventArgs

instance.OnAfterUpload(e)
C#
public void OnAfterUpload(
   WebFileUploaderFileEventArgs e
)
Delphi
public procedure OnAfterUpload(
    e: WebFileUploaderFileEventArgs
);
JScript
public function OnAfterUpload(
   e : WebFileUploaderFileEventArgs
);
Managed Extensions for C++
public: void OnAfterUpload(
   WebFileUploaderFileEventArgs* e
)
C++/CLI
public:
void OnAfterUpload(
   WebFileUploaderFileEventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


OnApplicationEnd Method

[image]
Intersoft WebTextEditor Documentation
OnApplicationEnd Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : OnApplicationEnd Method

application

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Sub OnApplicationEnd( _
   ByVal application As System.Web.HttpApplication _
)
Visual Basic (Usage) Copy Code
Dim application As System.Web.HttpApplication

WebFileUploader.OnApplicationEnd(application)
C#
public static void OnApplicationEnd(
   System.Web.HttpApplication application
)
Delphi
public procedure OnApplicationEnd(
    application: System.Web.HttpApplication
); static;
JScript
public static function OnApplicationEnd(
   application : System.Web.HttpApplication
);
Managed Extensions for C++
public: static void OnApplicationEnd(
   System.Web.HttpApplication* application
)
C++/CLI
public:
static void OnApplicationEnd(
   System.Web.HttpApplication^ application
)

Parameters

application

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


OnApplicationStart Method

[image]
Intersoft WebTextEditor Documentation
OnApplicationStart Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : OnApplicationStart Method

application
contextFilePath

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shared Sub OnApplicationStart( _
   ByVal application As System.Web.HttpApplication, _
   ByVal contextFilePath As System.String _
)
Visual Basic (Usage) Copy Code
Dim application As System.Web.HttpApplication
Dim contextFilePath As System.String

WebFileUploader.OnApplicationStart(application, contextFilePath)
C#
public static void OnApplicationStart(
   System.Web.HttpApplication application,
   System.string contextFilePath
)
Delphi
public procedure OnApplicationStart(
    application: System.Web.HttpApplication;
    contextFilePath: System.String
); static;
JScript
public static function OnApplicationStart(
   application : System.Web.HttpApplication,
   contextFilePath : System.String
);
Managed Extensions for C++
public: static void OnApplicationStart(
   System.Web.HttpApplication* application,
   System.string* contextFilePath
)
C++/CLI
public:
static void OnApplicationStart(
   System.Web.HttpApplication^ application,
   System.String^ contextFilePath
)

Parameters

application
contextFilePath

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


OnCancelUpload Method

[image]
Intersoft WebTextEditor Documentation
OnCancelUpload Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : OnCancelUpload Method

e

Glossary Item Box

Fires when cancel is triggered when uploading process.

Syntax

Visual Basic (Declaration)
Public Sub OnCancelUpload( _
   ByVal e As WebFileUploaderFileEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim e As WebFileUploaderFileEventArgs

instance.OnCancelUpload(e)
C#
public void OnCancelUpload(
   WebFileUploaderFileEventArgs e
)
Delphi
public procedure OnCancelUpload(
    e: WebFileUploaderFileEventArgs
);
JScript
public function OnCancelUpload(
   e : WebFileUploaderFileEventArgs
);
Managed Extensions for C++
public: void OnCancelUpload(
   WebFileUploaderFileEventArgs* e
)
C++/CLI
public:
void OnCancelUpload(
   WebFileUploaderFileEventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


OnErrorUpload Method

[image]
Intersoft WebTextEditor Documentation
OnErrorUpload Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : OnErrorUpload Method

e

Glossary Item Box

Fires when uploading process generate error.

Syntax

Visual Basic (Declaration)
Public Sub OnErrorUpload( _
   ByVal e As WebFileUploaderFileEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim e As WebFileUploaderFileEventArgs

instance.OnErrorUpload(e)
C#
public void OnErrorUpload(
   WebFileUploaderFileEventArgs e
)
Delphi
public procedure OnErrorUpload(
    e: WebFileUploaderFileEventArgs
);
JScript
public function OnErrorUpload(
   e : WebFileUploaderFileEventArgs
);
Managed Extensions for C++
public: void OnErrorUpload(
   WebFileUploaderFileEventArgs* e
)
C++/CLI
public:
void OnErrorUpload(
   WebFileUploaderFileEventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


OnPreRender Method

[image]
Intersoft WebTextEditor Documentation
OnPreRender Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : OnPreRender Method

Glossary Item Box

Overload List

Overload | Description
OnPreRender(EventArgs) |
OnPreRender() |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


OnPreRender(EventArgs) Method

[image]
Intersoft WebTextEditor Documentation
OnPreRender(EventArgs) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class > OnPreRender Method : OnPreRender(EventArgs) Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overloads Overrides Sub OnPreRender( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim e As System.EventArgs

instance.OnPreRender(e)
C#
protected override void OnPreRender(
   System.EventArgs e
)
Delphi
protected procedure OnPreRender(
    e: System.EventArgs
); override;
JScript
protected override function OnPreRender(
   e : System.EventArgs
);
Managed Extensions for C++
protected: void OnPreRender(
   System.EventArgs* e
) override
C++/CLI
protected:
void OnPreRender(
   System.EventArgs^ e
) override

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members
Overload List


OnPreRender() Method

[image]
Intersoft WebTextEditor Documentation
OnPreRender() Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class > OnPreRender Method : OnPreRender() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub OnPreRender()
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader

instance.OnPreRender()
C#
public void OnPreRender()
Delphi
public procedure OnPreRender();
JScript
public function OnPreRender();
Managed Extensions for C++
public: void OnPreRender();
C++/CLI
public:
void OnPreRender();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members
Overload List


OnRequest Method

[image]
Intersoft WebTextEditor Documentation
OnRequest Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : OnRequest Method

requestObject

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub OnRequest( _
   ByVal requestObject As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim requestObject As System.Object

instance.OnRequest(requestObject)
C#
public void OnRequest(
   System.object requestObject
)
Delphi
public procedure OnRequest(
    requestObject: System.TObject
);
JScript
public function OnRequest(
   requestObject : System.Object
);
Managed Extensions for C++
public: void OnRequest(
   System.Object* requestObject
)
C++/CLI
public:
void OnRequest(
   System.Object^ requestObject
)

Parameters

requestObject

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


OnUploading Method

[image]
Intersoft WebTextEditor Documentation
OnUploading Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : OnUploading Method

e

Glossary Item Box

Fires when WebUploader is in uploading process.

Syntax

Visual Basic (Declaration)
Public Sub OnUploading( _
   ByVal e As WebFileUploaderFileEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim e As WebFileUploaderFileEventArgs

instance.OnUploading(e)
C#
public void OnUploading(
   WebFileUploaderFileEventArgs e
)
Delphi
public procedure OnUploading(
    e: WebFileUploaderFileEventArgs
);
JScript
public function OnUploading(
   e : WebFileUploaderFileEventArgs
);
Managed Extensions for C++
public: void OnUploading(
   WebFileUploaderFileEventArgs* e
)
C++/CLI
public:
void OnUploading(
   WebFileUploaderFileEventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


RegisterScript Method

[image]
Intersoft WebTextEditor Documentation
RegisterScript Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : RegisterScript Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub RegisterScript()
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader

instance.RegisterScript()
C#
public override void RegisterScript()
Delphi
public procedure RegisterScript(); override;
JScript
public override function RegisterScript();
Managed Extensions for C++
public: void RegisterScript(); override
C++/CLI
public:
void RegisterScript(); override

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


SetUploadPath Method

[image]
Intersoft WebTextEditor Documentation
SetUploadPath Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : SetUploadPath Method

path

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetUploadPath( _
   ByVal path As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim path As System.String

instance.SetUploadPath(path)
C#
public void SetUploadPath(
   System.string path
)
Delphi
public procedure SetUploadPath(
    path: System.String
);
JScript
public function SetUploadPath(
   path : System.String
);
Managed Extensions for C++
public: void SetUploadPath(
   System.string* path
)
C++/CLI
public:
void SetUploadPath(
   System.String^ path
)

Parameters

path

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


WebFileUploader Class Properties

[image]
Intersoft WebTextEditor Documentation
WebFileUploader Class Properties
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebFileUploader Class

Glossary Item Box

For a list of all members of this type, see WebFileUploader members.

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | AllowAdd | Gets or sets a value indicating whether user can add upload field via Add button.
Public Property | AllowCancel | Determines whether allow cancel is true or not.
Public Property | AllowRemove | Gets or sets a value indicating whether user can remove upload field via Remove button.
Public Property | AllowSimultaneousUpload | Gets or sets a value indicating whether simultaneous upload is allowed.
Public Property | AppRelativeTemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | AspNetAjaxSettings | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Attributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BackColor | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | BorderColor | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | BorderStyle | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | BorderWidth | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Caption | Specifies caption of WebUploader.
Public Property | ClientAction |
Public Property | ClientID | (Inherited from System.Web.UI.Control)
Public Property | ClientIDMode | (Inherited from System.Web.UI.Control)
Public Property | ClientSideEvents | Contains client side events supported by WebUploader.
Public Property | ControlDataTransferFormat | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Controls | (Inherited from System.Web.UI.Control)
Public Property | ControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ControlStyleCreated | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | CssClass | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | DefaultButtonHeight | Specifies button height of WebUploader.
Public Property | DefaultButtonWidth | Specifies button width of WebUploader.
Public Property | DefaultProgressBarHeight | Specifies progress bar's height of WebUploader.
Public Property | DefaultSelectButtonHeight | Specifies select button height of WebUploader.
Public Property | DefaultSelectButtonWidth | Specifies select button width of WebUploader.
Public Property | DefaultTextBoxHeight | Specifies TextBox height of WebUploader.
Public Property | DefaultTextBoxWidth | Specifies TextBox width of WebUploader.
Public Property | Enabled | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableManagedTheming | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | FilesCount | The total number of file that can be uploaded (0 for no limit).
Public Property | FileTypes | Specifies File type of WebUploader.
Public Property | FlyPostBackSettings | Configures the settings used by the control when performing OnTheFly postback.
Public Property | Font | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ForeColor | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | GUID |
Public Property | HasAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Height | Overridden.
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | ImagesDirectory | Gets or sets the directory where all required scripts for the control are stored.
Public Property | ImageSettings | Provides settings that control the images in WebUploader.
Public Property | InitialFilesCount | The total number of file that can be uploaded (0 for no limit).
Public Property | IsControlThemed | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | IsDesign | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | IsDynamicCreated | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | IsInternalCreated | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | IsUnloaded | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | MaxTextLength |
Public Property | NamingContainer | (Inherited from System.Web.UI.Control)
Public Property | Page | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Parent | (Inherited from System.Web.UI.Control)
Public Property | ParentStyleId | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | PostbackMode | Specifies Postback mode of WebUploader.
Public Property | PriorityUploadType | Specifies priority upload type of WebUploader.
Public Property | ProgressInformation | Provides WebUploader progress information.
Public Property | ProgressLatency | Specifies progress latency of WebUploader.
Public Property | RenderingCompatibility | (Inherited from System.Web.UI.Control)
Public Property | RenderingMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RequiresUIRefresh | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RuntimeLicenseKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | SaveViewStateOnFlyPostback | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ScriptDirectory | Overridden. Gets or sets the directory where all required scripts for the control are stored.
Public Property | SerializedJSFiles | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | SerializedStyles | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | SharedScriptDirectory | Overridden. Gets or sets the directory where all required scripts for the control are stored.
Public Property | Site | (Inherited from System.Web.UI.Control)
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Style | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | StyleSettings | Contains interactive style for WebUploader.
Public Property | SupportsDisabledAttribute | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | SupportXMLCultureInfo | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | TabIndex | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | TemplateControl | (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | TextSettings | Provides settings that control text that shown in WebUploader.
Public Property | ToolTip | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | TotalUploadSizeLimit | The total number of bytes that can be uploaded (0 for no limit).
Public Property | UILayout | Specifies UILayout of WebUploader.
Public Property | UniqueID | (Inherited from System.Web.UI.Control)
Public Property | UploadPath | Specifies upload path of WebUploader.
Public Property | UploadSizeLimit | The number of bytes that can be uploaded (0 for no limit) for each file.
Public Property | UploadType | Specifies upload type of WebUploader.
Public Property | UseDefaultStyle | Gets or sets a value indicating whether default style is used.
Public Property | ValidateRequestMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateItems | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateServerConnection | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateStorage | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Visible | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Width | Overridden.
Public Property | XmlCompressionEnabled | (Inherited from ISNet.WebUI.ISNetControl)
Top

Protected Properties

 | Name | Description
Protected Property | Adapter | (Inherited from System.Web.UI.Control)
Protected Property | ChildControlsCreated | (Inherited from System.Web.UI.Control)
Protected Property | ClientIDSeparator | (Inherited from System.Web.UI.Control)
Protected Property | DefaultImagesFolder | Overridden.
Protected Property | Events | (Inherited from System.Web.UI.Control)
Protected Property | HasChildViewState | (Inherited from System.Web.UI.Control)
Protected Property | IdSeparator | (Inherited from System.Web.UI.Control)
Protected Property | IsMvc | (Inherited from ISNet.WebUI.ISNetControl)
Protected Property | IsTrackingViewState | (Inherited from System.Web.UI.Control)
Protected Property | LicenseType | Overridden.
Protected Property | LoadViewStateByID | (Inherited from System.Web.UI.Control)
Protected Property | MaxJsonLength | (Inherited from ISNet.WebUI.ISNetControl)
Protected Property | Product | Overridden.
Protected Property | ProductIcon | Overridden.
Protected Property | ProductImage | Overridden.
Protected Property | TagKey | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Property | TagName | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Property | ViewState | (Inherited from System.Web.UI.Control)
Protected Property | ViewStateIgnoresCase | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

WebFileUploader Class
ISNet.WebUI.WebTextEditor Namespace


AllowAdd Property

[image]
Intersoft WebTextEditor Documentation
AllowAdd Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : AllowAdd Property

Glossary Item Box

Gets or sets a value indicating whether user can add upload field via Add button.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets a value indicating whether user can add upload field via Add button.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.ThemeableAttribute(False)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Property AllowAdd As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Boolean

instance.AllowAdd = value

value = instance.AllowAdd
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value indicating whether user can add upload field via Add button.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.ThemeableAttribute(false)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public System.bool AllowAdd {get; set;}
Delphi
public read-write property AllowAdd: System.Boolean;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets a value indicating whether user can add upload field via Add button.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.ThemeableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set AllowAdd : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value indicating whether user can add upload field via Add button.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.ThemeableAttribute(false)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property System.bool get_AllowAdd();
public: __property void set_AllowAdd(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value indicating whether user can add upload field via Add button.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.ThemeableAttribute(false)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
property System.bool AllowAdd {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


AllowCancel Property

[image]
Intersoft WebTextEditor Documentation
AllowCancel Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : AllowCancel Property

Glossary Item Box

Determines whether allow cancel is true or not.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property AllowCancel As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Boolean

instance.AllowCancel = value

value = instance.AllowCancel
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.bool AllowCancel {get; set;}
Delphi
public read-write property AllowCancel: System.Boolean;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set AllowCancel : System.boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.bool get_AllowCancel();
public: __property void set_AllowCancel(
   System.bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.bool AllowCancel {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


AllowRemove Property

[image]
Intersoft WebTextEditor Documentation
AllowRemove Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : AllowRemove Property

Glossary Item Box

Gets or sets a value indicating whether user can remove upload field via Remove button.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.Web.UI.ThemeableAttribute(False)>
<System.ComponentModel.DescriptionAttribute("Gets or sets a value indicating whether user can remove upload field via Remove button.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property AllowRemove As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Boolean

instance.AllowRemove = value

value = instance.AllowRemove
C#
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.ThemeableAttribute(false)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value indicating whether user can remove upload field via Remove button.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.bool AllowRemove {get; set;}
Delphi
public read-write property AllowRemove: System.Boolean;
JScript
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.Web.UI.ThemeableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets a value indicating whether user can remove upload field via Remove button.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set AllowRemove : System.boolean
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.ThemeableAttribute(false)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value indicating whether user can remove upload field via Remove button.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.bool get_AllowRemove();
public: __property void set_AllowRemove(
   System.bool value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.ThemeableAttribute(false)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value indicating whether user can remove upload field via Remove button.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.bool AllowRemove {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


AllowSimultaneousUpload Property

[image]
Intersoft WebTextEditor Documentation
AllowSimultaneousUpload Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : AllowSimultaneousUpload Property

Glossary Item Box

Gets or sets a value indicating whether simultaneous upload is allowed.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets a value indicating whether simultaneous upload is allowed.")>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.Web.UI.ThemeableAttribute(False)>
Public Property AllowSimultaneousUpload As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Boolean

instance.AllowSimultaneousUpload = value

value = instance.AllowSimultaneousUpload
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value indicating whether simultaneous upload is allowed.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.ThemeableAttribute(false)]
public System.bool AllowSimultaneousUpload {get; set;}
Delphi
public read-write property AllowSimultaneousUpload: System.Boolean;
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets a value indicating whether simultaneous upload is allowed.")
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.Web.UI.ThemeableAttribute()
public function get,set AllowSimultaneousUpload : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value indicating whether simultaneous upload is allowed.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.ThemeableAttribute(false)]
public: __property System.bool get_AllowSimultaneousUpload();
public: __property void set_AllowSimultaneousUpload(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value indicating whether simultaneous upload is allowed.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.ThemeableAttribute(false)]
public:
property System.bool AllowSimultaneousUpload {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


Caption Property

[image]
Intersoft WebTextEditor Documentation
Caption Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : Caption Property

Glossary Item Box

Specifies caption of WebUploader.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Appearance")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Property Caption As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.String

instance.Caption = value

value = instance.Caption
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public System.string Caption {get; set;}
Delphi
public read-write property Caption: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Appearance")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set Caption : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property System.string* get_Caption();
public: __property void set_Caption(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
property System.String^ Caption {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


ClientAction Property

[image]
Intersoft WebTextEditor Documentation
ClientAction Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : ClientAction Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public ReadOnly Property ClientAction As ISNet.WebUI.BaseClientSideAction
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As ISNet.WebUI.BaseClientSideAction

value = instance.ClientAction
C#
[System.ComponentModel.BrowsableAttribute(false)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public ISNet.WebUI.BaseClientSideAction ClientAction {get;}
Delphi
public read-only property ClientAction: ISNet.WebUI.BaseClientSideAction;
JScript
System.ComponentModel.BrowsableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get ClientAction : ISNet.WebUI.BaseClientSideAction
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property ISNet.WebUI.BaseClientSideAction* get_ClientAction();
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property ISNet.WebUI.BaseClientSideAction^ ClientAction {
   ISNet.WebUI.BaseClientSideAction^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


ClientSideEvents Property

[image]
Intersoft WebTextEditor Documentation
ClientSideEvents Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : ClientSideEvents Property

Glossary Item Box

Contains client side events supported by WebUploader.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property ClientSideEvents As WebFileUploaderClientSideEvents
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As WebFileUploaderClientSideEvents

instance.ClientSideEvents = value

value = instance.ClientSideEvents
C#
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public WebFileUploaderClientSideEvents ClientSideEvents {get; set;}
Delphi
public read-write property ClientSideEvents: WebFileUploaderClientSideEvents;
JScript
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set ClientSideEvents : WebFileUploaderClientSideEvents
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property WebFileUploaderClientSideEvents* get_ClientSideEvents();
public: __property void set_ClientSideEvents(
   WebFileUploaderClientSideEvents* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property WebFileUploaderClientSideEvents^ ClientSideEvents {
   WebFileUploaderClientSideEvents^ get();
   void set (    WebFileUploaderClientSideEvents^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


DefaultButtonHeight Property

[image]
Intersoft WebTextEditor Documentation
DefaultButtonHeight Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : DefaultButtonHeight Property

Glossary Item Box

Specifies button height of WebUploader.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property DefaultButtonHeight As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Web.UI.WebControls.Unit

instance.DefaultButtonHeight = value

value = instance.DefaultButtonHeight
C#
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.Web.UI.WebControls.Unit DefaultButtonHeight {get; set;}
Delphi
public read-write property DefaultButtonHeight: System.Web.UI.WebControls.Unit;
JScript
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set DefaultButtonHeight : System.Web.UI.WebControls.Unit
Managed Extensions for C++
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.Web.UI.WebControls.Unit get_DefaultButtonHeight();
public: __property void set_DefaultButtonHeight(
   System.Web.UI.WebControls.Unit value
);
C++/CLI
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.Web.UI.WebControls.Unit DefaultButtonHeight {
   System.Web.UI.WebControls.Unit get();
   void set (    System.Web.UI.WebControls.Unit value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


DefaultButtonWidth Property

[image]
Intersoft WebTextEditor Documentation
DefaultButtonWidth Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : DefaultButtonWidth Property

Glossary Item Box

Specifies button width of WebUploader.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property DefaultButtonWidth As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Web.UI.WebControls.Unit

instance.DefaultButtonWidth = value

value = instance.DefaultButtonWidth
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DefaultValueAttribute()]
public System.Web.UI.WebControls.Unit DefaultButtonWidth {get; set;}
Delphi
public read-write property DefaultButtonWidth: System.Web.UI.WebControls.Unit;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.DefaultValueAttribute()
public function get,set DefaultButtonWidth : System.Web.UI.WebControls.Unit
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.Web.UI.WebControls.Unit get_DefaultButtonWidth();
public: __property void set_DefaultButtonWidth(
   System.Web.UI.WebControls.Unit value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.Web.UI.WebControls.Unit DefaultButtonWidth {
   System.Web.UI.WebControls.Unit get();
   void set (    System.Web.UI.WebControls.Unit value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


DefaultImagesFolder Property

[image]
Intersoft WebTextEditor Documentation
DefaultImagesFolder Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : DefaultImagesFolder Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property DefaultImagesFolder As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.String

value = instance.DefaultImagesFolder
C#
protected override System.string DefaultImagesFolder {get;}
Delphi
protected read-only property DefaultImagesFolder: System.String; override;
JScript
protected override function get DefaultImagesFolder : System.String
Managed Extensions for C++
protected: __property System.string* get_DefaultImagesFolder() override;
C++/CLI
protected:
property System.String^ DefaultImagesFolder {
   System.String^ get() override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


DefaultProgressBarHeight Property

[image]
Intersoft WebTextEditor Documentation
DefaultProgressBarHeight Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : DefaultProgressBarHeight Property

Glossary Item Box

Specifies progress bar's height of WebUploader.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.CategoryAttribute("Appearance")>
Public Property DefaultProgressBarHeight As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Web.UI.WebControls.Unit

instance.DefaultProgressBarHeight = value

value = instance.DefaultProgressBarHeight
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Appearance")]
public System.Web.UI.WebControls.Unit DefaultProgressBarHeight {get; set;}
Delphi
public read-write property DefaultProgressBarHeight: System.Web.UI.WebControls.Unit;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.CategoryAttribute("Appearance")
public function get,set DefaultProgressBarHeight : System.Web.UI.WebControls.Unit
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Appearance")]
public: __property System.Web.UI.WebControls.Unit get_DefaultProgressBarHeight();
public: __property void set_DefaultProgressBarHeight(
   System.Web.UI.WebControls.Unit value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Appearance")]
public:
property System.Web.UI.WebControls.Unit DefaultProgressBarHeight {
   System.Web.UI.WebControls.Unit get();
   void set (    System.Web.UI.WebControls.Unit value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


DefaultSelectButtonHeight Property

[image]
Intersoft WebTextEditor Documentation
DefaultSelectButtonHeight Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : DefaultSelectButtonHeight Property

Glossary Item Box

Specifies select button height of WebUploader.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Appearance")>
Public Property DefaultSelectButtonHeight As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Web.UI.WebControls.Unit

instance.DefaultSelectButtonHeight = value

value = instance.DefaultSelectButtonHeight
C#
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
public System.Web.UI.WebControls.Unit DefaultSelectButtonHeight {get; set;}
Delphi
public read-write property DefaultSelectButtonHeight: System.Web.UI.WebControls.Unit;
JScript
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Appearance")
public function get,set DefaultSelectButtonHeight : System.Web.UI.WebControls.Unit
Managed Extensions for C++
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
public: __property System.Web.UI.WebControls.Unit get_DefaultSelectButtonHeight();
public: __property void set_DefaultSelectButtonHeight(
   System.Web.UI.WebControls.Unit value
);
C++/CLI
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
public:
property System.Web.UI.WebControls.Unit DefaultSelectButtonHeight {
   System.Web.UI.WebControls.Unit get();
   void set (    System.Web.UI.WebControls.Unit value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


DefaultSelectButtonWidth Property

[image]
Intersoft WebTextEditor Documentation
DefaultSelectButtonWidth Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : DefaultSelectButtonWidth Property

Glossary Item Box

Specifies select button width of WebUploader.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property DefaultSelectButtonWidth As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Web.UI.WebControls.Unit

instance.DefaultSelectButtonWidth = value

value = instance.DefaultSelectButtonWidth
C#
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DefaultValueAttribute()]
public System.Web.UI.WebControls.Unit DefaultSelectButtonWidth {get; set;}
Delphi
public read-write property DefaultSelectButtonWidth: System.Web.UI.WebControls.Unit;
JScript
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.DefaultValueAttribute()
public function get,set DefaultSelectButtonWidth : System.Web.UI.WebControls.Unit
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.Web.UI.WebControls.Unit get_DefaultSelectButtonWidth();
public: __property void set_DefaultSelectButtonWidth(
   System.Web.UI.WebControls.Unit value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.Web.UI.WebControls.Unit DefaultSelectButtonWidth {
   System.Web.UI.WebControls.Unit get();
   void set (    System.Web.UI.WebControls.Unit value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


DefaultTextBoxHeight Property

[image]
Intersoft WebTextEditor Documentation
DefaultTextBoxHeight Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : DefaultTextBoxHeight Property

Glossary Item Box

Specifies TextBox height of WebUploader.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Property DefaultTextBoxHeight As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Web.UI.WebControls.Unit

instance.DefaultTextBoxHeight = value

value = instance.DefaultTextBoxHeight
C#
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public System.Web.UI.WebControls.Unit DefaultTextBoxHeight {get; set;}
Delphi
public read-write property DefaultTextBoxHeight: System.Web.UI.WebControls.Unit;
JScript
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set DefaultTextBoxHeight : System.Web.UI.WebControls.Unit
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property System.Web.UI.WebControls.Unit get_DefaultTextBoxHeight();
public: __property void set_DefaultTextBoxHeight(
   System.Web.UI.WebControls.Unit value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
property System.Web.UI.WebControls.Unit DefaultTextBoxHeight {
   System.Web.UI.WebControls.Unit get();
   void set (    System.Web.UI.WebControls.Unit value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


DefaultTextBoxWidth Property

[image]
Intersoft WebTextEditor Documentation
DefaultTextBoxWidth Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : DefaultTextBoxWidth Property

Glossary Item Box

Specifies TextBox width of WebUploader.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property DefaultTextBoxWidth As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Web.UI.WebControls.Unit

instance.DefaultTextBoxWidth = value

value = instance.DefaultTextBoxWidth
C#
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.Web.UI.WebControls.Unit DefaultTextBoxWidth {get; set;}
Delphi
public read-write property DefaultTextBoxWidth: System.Web.UI.WebControls.Unit;
JScript
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set DefaultTextBoxWidth : System.Web.UI.WebControls.Unit
Managed Extensions for C++
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.Web.UI.WebControls.Unit get_DefaultTextBoxWidth();
public: __property void set_DefaultTextBoxWidth(
   System.Web.UI.WebControls.Unit value
);
C++/CLI
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.Web.UI.WebControls.Unit DefaultTextBoxWidth {
   System.Web.UI.WebControls.Unit get();
   void set (    System.Web.UI.WebControls.Unit value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


FilesCount Property

[image]
Intersoft WebTextEditor Documentation
FilesCount Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : FilesCount Property

Glossary Item Box

The total number of file that can be uploaded (0 for no limit).

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.DescriptionAttribute("The total number of file that can be uploaded (0 for no limit).")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Property FilesCount As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Integer

instance.FilesCount = value

value = instance.FilesCount
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DescriptionAttribute("The total number of file that can be uploaded (0 for no limit).")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public System.int FilesCount {get; set;}
Delphi
public read-write property FilesCount: System.Integer;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.DescriptionAttribute("The total number of file that can be uploaded (0 for no limit).")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set FilesCount : System.int
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DescriptionAttribute("The total number of file that can be uploaded (0 for no limit).")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property System.int get_FilesCount();
public: __property void set_FilesCount(
   System.int value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DescriptionAttribute("The total number of file that can be uploaded (0 for no limit).")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
property System.int FilesCount {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


FileTypes Property

[image]
Intersoft WebTextEditor Documentation
FileTypes Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : FileTypes Property

Glossary Item Box

Specifies File type of WebUploader.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property FileTypes As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.String

instance.FileTypes = value

value = instance.FileTypes
C#
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string FileTypes {get; set;}
Delphi
public read-write property FileTypes: System.String;
JScript
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set FileTypes : System.String
Managed Extensions for C++
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_FileTypes();
public: __property void set_FileTypes(
   System.string* value
);
C++/CLI
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ FileTypes {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


FlyPostBackSettings Property

[image]
Intersoft WebTextEditor Documentation
FlyPostBackSettings Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : FlyPostBackSettings Property

Glossary Item Box

Configures the settings used by the control when performing OnTheFly postback.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DescriptionAttribute("Configures the settings used by the control when performing OnTheFly postback.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
Public ReadOnly Property FlyPostBackSettings As ISNet.WebUI.FlyPostBackSettings
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As ISNet.WebUI.FlyPostBackSettings

value = instance.FlyPostBackSettings
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Configures the settings used by the control when performing OnTheFly postback.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public ISNet.WebUI.FlyPostBackSettings FlyPostBackSettings {get;}
Delphi
public read-only property FlyPostBackSettings: ISNet.WebUI.FlyPostBackSettings;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DescriptionAttribute("Configures the settings used by the control when performing OnTheFly postback.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
public function get FlyPostBackSettings : ISNet.WebUI.FlyPostBackSettings
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Configures the settings used by the control when performing OnTheFly postback.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public: __property ISNet.WebUI.FlyPostBackSettings* get_FlyPostBackSettings();
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Configures the settings used by the control when performing OnTheFly postback.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public:
property ISNet.WebUI.FlyPostBackSettings^ FlyPostBackSettings {
   ISNet.WebUI.FlyPostBackSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


GUID Property

[image]
Intersoft WebTextEditor Documentation
GUID Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : GUID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BrowsableAttribute(False)>
Public Property GUID As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.String

instance.GUID = value

value = instance.GUID
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BrowsableAttribute(false)]
public System.string GUID {get; set;}
Delphi
public read-write property GUID: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BrowsableAttribute()
public function get,set GUID : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BrowsableAttribute(false)]
public: __property System.string* get_GUID();
public: __property void set_GUID(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BrowsableAttribute(false)]
public:
property System.String^ GUID {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


Height Property

[image]
Intersoft WebTextEditor Documentation
Height Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : Height Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Layout")>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.DefaultValueAttribute()>
Public Overrides Property Height As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Web.UI.WebControls.Unit

instance.Height = value

value = instance.Height
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Layout")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DefaultValueAttribute()]
public override System.Web.UI.WebControls.Unit Height {get; set;}
Delphi
public read-write property Height: System.Web.UI.WebControls.Unit; override;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Layout")
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.DefaultValueAttribute()
public override function get,set Height : System.Web.UI.WebControls.Unit
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Layout")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.Web.UI.WebControls.Unit get_Height() override;
public: __property void set_Height(
   System.Web.UI.WebControls.Unit value
) override;
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Layout")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.Web.UI.WebControls.Unit Height {
   System.Web.UI.WebControls.Unit get() override;
   void set (    System.Web.UI.WebControls.Unit value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


ImagesDirectory Property

[image]
Intersoft WebTextEditor Documentation
ImagesDirectory Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : ImagesDirectory Property

Glossary Item Box

Gets or sets the directory where all required scripts for the control are stored.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required scripts for the control are stored.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.CategoryAttribute("Client Script Directory")>
Public Property ImagesDirectory As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.String

instance.ImagesDirectory = value

value = instance.ImagesDirectory
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required scripts for the control are stored.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
public System.string ImagesDirectory {get; set;}
Delphi
public read-write property ImagesDirectory: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required scripts for the control are stored.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.CategoryAttribute("Client Script Directory")
public function get,set ImagesDirectory : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required scripts for the control are stored.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
public: __property System.string* get_ImagesDirectory();
public: __property void set_ImagesDirectory(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required scripts for the control are stored.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
public:
property System.String^ ImagesDirectory {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


ImageSettings Property

[image]
Intersoft WebTextEditor Documentation
ImageSettings Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : ImageSettings Property

Glossary Item Box

Provides settings that control the images in WebUploader.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Settings")>
<ISNet.PersistLayoutAttribute(False)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property ImageSettings As WebFileUploaderImageSettings
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As WebFileUploaderImageSettings

instance.ImageSettings = value

value = instance.ImageSettings
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Settings")]
[ISNet.PersistLayoutAttribute(false)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public WebFileUploaderImageSettings ImageSettings {get; set;}
Delphi
public read-write property ImageSettings: WebFileUploaderImageSettings;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Settings")
ISNet.PersistLayoutAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set ImageSettings : WebFileUploaderImageSettings
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Settings")]
[ISNet.PersistLayoutAttribute(false)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property WebFileUploaderImageSettings* get_ImageSettings();
public: __property void set_ImageSettings(
   WebFileUploaderImageSettings* value
);
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Settings")]
[ISNet.PersistLayoutAttribute(false)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property WebFileUploaderImageSettings^ ImageSettings {
   WebFileUploaderImageSettings^ get();
   void set (    WebFileUploaderImageSettings^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


InitialFilesCount Property

[image]
Intersoft WebTextEditor Documentation
InitialFilesCount Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : InitialFilesCount Property

Glossary Item Box

The total number of file that can be uploaded (0 for no limit).

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.DescriptionAttribute("The total number of file that can be uploaded (0 for no limit).")>
Public Property InitialFilesCount As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Integer

instance.InitialFilesCount = value

value = instance.InitialFilesCount
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DescriptionAttribute("The total number of file that can be uploaded (0 for no limit).")]
public System.int InitialFilesCount {get; set;}
Delphi
public read-write property InitialFilesCount: System.Integer;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.DescriptionAttribute("The total number of file that can be uploaded (0 for no limit).")
public function get,set InitialFilesCount : System.int
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DescriptionAttribute("The total number of file that can be uploaded (0 for no limit).")]
public: __property System.int get_InitialFilesCount();
public: __property void set_InitialFilesCount(
   System.int value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DescriptionAttribute("The total number of file that can be uploaded (0 for no limit).")]
public:
property System.int InitialFilesCount {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


LicenseType Property

[image]
Intersoft WebTextEditor Documentation
LicenseType Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : LicenseType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overrides Property LicenseType As ISNet.WebUI.LicType
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As ISNet.WebUI.LicType

instance.LicenseType = value

value = instance.LicenseType
C#
protected override ISNet.WebUI.LicType LicenseType {get; set;}
Delphi
protected read-write property LicenseType: ISNet.WebUI.LicType; override;
JScript
protected override function get,set LicenseType : ISNet.WebUI.LicType
Managed Extensions for C++
protected: __property ISNet.WebUI.LicType get_LicenseType() override;
protected: __property void set_LicenseType(
   ISNet.WebUI.LicType value
) override;
C++/CLI
protected:
property ISNet.WebUI.LicType LicenseType {
   ISNet.WebUI.LicType get() override;
   void set (    ISNet.WebUI.LicType value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


MaxTextLength Property

[image]
Intersoft WebTextEditor Documentation
MaxTextLength Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : MaxTextLength Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the maximum length of the file name to be displayed in the user interface, which is applicable only in AttachmentBar UI mode.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Property MaxTextLength As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Integer

instance.MaxTextLength = value

value = instance.MaxTextLength
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the maximum length of the file name to be displayed in the user interface, which is applicable only in AttachmentBar UI mode.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public System.int MaxTextLength {get; set;}
Delphi
public read-write property MaxTextLength: System.Integer;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the maximum length of the file name to be displayed in the user interface, which is applicable only in AttachmentBar UI mode.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set MaxTextLength : System.int
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the maximum length of the file name to be displayed in the user interface, which is applicable only in AttachmentBar UI mode.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property System.int get_MaxTextLength();
public: __property void set_MaxTextLength(
   System.int value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the maximum length of the file name to be displayed in the user interface, which is applicable only in AttachmentBar UI mode.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
property System.int MaxTextLength {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


PostbackMode Property

[image]
Intersoft WebTextEditor Documentation
PostbackMode Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : PostbackMode Property

Glossary Item Box

Specifies Postback mode of WebUploader.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Property PostbackMode As PostbackMode
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As PostbackMode

instance.PostbackMode = value

value = instance.PostbackMode
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public PostbackMode PostbackMode {get; set;}
Delphi
public read-write property PostbackMode: PostbackMode;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set PostbackMode : PostbackMode
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property PostbackMode get_PostbackMode();
public: __property void set_PostbackMode(
   PostbackMode value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
property PostbackMode PostbackMode {
   PostbackMode get();
   void set (    PostbackMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


PriorityUploadType Property

[image]
Intersoft WebTextEditor Documentation
PriorityUploadType Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : PriorityUploadType Property

Glossary Item Box

Specifies priority upload type of WebUploader.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.DescriptionAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property PriorityUploadType As PriorityUploadType
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As PriorityUploadType

instance.PriorityUploadType = value

value = instance.PriorityUploadType
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public PriorityUploadType PriorityUploadType {get; set;}
Delphi
public read-write property PriorityUploadType: PriorityUploadType;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.DescriptionAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set PriorityUploadType : PriorityUploadType
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property PriorityUploadType get_PriorityUploadType();
public: __property void set_PriorityUploadType(
   PriorityUploadType value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property PriorityUploadType PriorityUploadType {
   PriorityUploadType get();
   void set (    PriorityUploadType value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


Product Property

[image]
Intersoft WebTextEditor Documentation
Product Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : Product Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property Product As ISNet.WebUI.ProductInfo
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As ISNet.WebUI.ProductInfo

value = instance.Product
C#
protected override ISNet.WebUI.ProductInfo Product {get;}
Delphi
protected read-only property Product: ISNet.WebUI.ProductInfo; override;
JScript
protected override function get Product : ISNet.WebUI.ProductInfo
Managed Extensions for C++
protected: __property ISNet.WebUI.ProductInfo* get_Product() override;
C++/CLI
protected:
property ISNet.WebUI.ProductInfo^ Product {
   ISNet.WebUI.ProductInfo^ get() override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


ProductIcon Property

[image]
Intersoft WebTextEditor Documentation
ProductIcon Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : ProductIcon Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property ProductIcon As System.Drawing.Icon
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Drawing.Icon

value = instance.ProductIcon
C#
protected override System.Drawing.Icon ProductIcon {get;}
Delphi
protected read-only property ProductIcon: System.Drawing.Icon; override;
JScript
protected override function get ProductIcon : System.Drawing.Icon
Managed Extensions for C++
protected: __property System.Drawing.Icon* get_ProductIcon() override;
C++/CLI
protected:
property System.Drawing.Icon^ ProductIcon {
   System.Drawing.Icon^ get() override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


ProductImage Property

[image]
Intersoft WebTextEditor Documentation
ProductImage Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : ProductImage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property ProductImage As System.Drawing.Image
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Drawing.Image

value = instance.ProductImage
C#
protected override System.Drawing.Image ProductImage {get;}
Delphi
protected read-only property ProductImage: System.Drawing.Image; override;
JScript
protected override function get ProductImage : System.Drawing.Image
Managed Extensions for C++
protected: __property System.Drawing.Image* get_ProductImage() override;
C++/CLI
protected:
property System.Drawing.Image^ ProductImage {
   System.Drawing.Image^ get() override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


ProgressInformation Property

[image]
Intersoft WebTextEditor Documentation
ProgressInformation Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : ProgressInformation Property

Glossary Item Box

Provides WebUploader progress information.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<ISNet.PersistLayoutAttribute(False)>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property ProgressInformation As WebFileUploaderProgressInformation
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As WebFileUploaderProgressInformation

instance.ProgressInformation = value

value = instance.ProgressInformation
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.PersistLayoutAttribute(false)]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public WebFileUploaderProgressInformation ProgressInformation {get; set;}
Delphi
public read-write property ProgressInformation: WebFileUploaderProgressInformation;
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
ISNet.PersistLayoutAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set ProgressInformation : WebFileUploaderProgressInformation
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.PersistLayoutAttribute(false)]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property WebFileUploaderProgressInformation* get_ProgressInformation();
public: __property void set_ProgressInformation(
   WebFileUploaderProgressInformation* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.PersistLayoutAttribute(false)]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property WebFileUploaderProgressInformation^ ProgressInformation {
   WebFileUploaderProgressInformation^ get();
   void set (    WebFileUploaderProgressInformation^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


ProgressLatency Property

[image]
Intersoft WebTextEditor Documentation
ProgressLatency Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : ProgressLatency Property

Glossary Item Box

Specifies progress latency of WebUploader.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute()>
Public Property ProgressLatency As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Integer

instance.ProgressLatency = value

value = instance.ProgressLatency
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute()]
public System.int ProgressLatency {get; set;}
Delphi
public read-write property ProgressLatency: System.Integer;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute()
public function get,set ProgressLatency : System.int
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute()]
public: __property System.int get_ProgressLatency();
public: __property void set_ProgressLatency(
   System.int value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute()]
public:
property System.int ProgressLatency {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


ScriptDirectory Property

[image]
Intersoft WebTextEditor Documentation
ScriptDirectory Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : ScriptDirectory Property

Glossary Item Box

Gets or sets the directory where all required scripts for the control are stored.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Client Script Directory")>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required scripts for the control are stored.")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Overrides Property ScriptDirectory As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.String

instance.ScriptDirectory = value

value = instance.ScriptDirectory
C#
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required scripts for the control are stored.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public override System.string ScriptDirectory {get; set;}
Delphi
public read-write property ScriptDirectory: System.String; override;
JScript
System.ComponentModel.CategoryAttribute("Client Script Directory")
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required scripts for the control are stored.")
ISNet.Serialization.BinarySerializableAttribute()
public override function get,set ScriptDirectory : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required scripts for the control are stored.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_ScriptDirectory() override;
public: __property void set_ScriptDirectory(
   System.string* value
) override;
C++/CLI
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required scripts for the control are stored.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ ScriptDirectory {
   System.String^ get() override;
   void set (    System.String^ value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


SharedScriptDirectory Property

[image]
Intersoft WebTextEditor Documentation
SharedScriptDirectory Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : SharedScriptDirectory Property

Glossary Item Box

Gets or sets the directory where all required scripts for the control are stored.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Client Script Directory")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required scripts for the control are stored.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Overrides Property SharedScriptDirectory As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.String

instance.SharedScriptDirectory = value

value = instance.SharedScriptDirectory
C#
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required scripts for the control are stored.")]
[System.ComponentModel.DefaultValueAttribute()]
public override System.string SharedScriptDirectory {get; set;}
Delphi
public read-write property SharedScriptDirectory: System.String; override;
JScript
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Client Script Directory")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required scripts for the control are stored.")
System.ComponentModel.DefaultValueAttribute()
public override function get,set SharedScriptDirectory : System.String
Managed Extensions for C++
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required scripts for the control are stored.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_SharedScriptDirectory() override;
public: __property void set_SharedScriptDirectory(
   System.string* value
) override;
C++/CLI
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required scripts for the control are stored.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ SharedScriptDirectory {
   System.String^ get() override;
   void set (    System.String^ value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


StyleSettings Property

[image]
Intersoft WebTextEditor Documentation
StyleSettings Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : StyleSettings Property

Glossary Item Box

Contains interactive style for WebUploader.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.PersistLayoutAttribute(False)>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.CategoryAttribute("Settings")>
Public Property StyleSettings As WebFileUploaderStyleSettings
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As WebFileUploaderStyleSettings

instance.StyleSettings = value

value = instance.StyleSettings
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.PersistLayoutAttribute(false)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Settings")]
public WebFileUploaderStyleSettings StyleSettings {get; set;}
Delphi
public read-write property StyleSettings: WebFileUploaderStyleSettings;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.PersistLayoutAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.CategoryAttribute("Settings")
public function get,set StyleSettings : WebFileUploaderStyleSettings
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.PersistLayoutAttribute(false)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Settings")]
public: __property WebFileUploaderStyleSettings* get_StyleSettings();
public: __property void set_StyleSettings(
   WebFileUploaderStyleSettings* value
);
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.PersistLayoutAttribute(false)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Settings")]
public:
property WebFileUploaderStyleSettings^ StyleSettings {
   WebFileUploaderStyleSettings^ get();
   void set (    WebFileUploaderStyleSettings^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


TextSettings Property

[image]
Intersoft WebTextEditor Documentation
TextSettings Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : TextSettings Property

Glossary Item Box

Provides settings that control text that shown in WebUploader.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<ISNet.PersistLayoutAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Settings")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public Property TextSettings As WebFileUploaderTextSettings
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As WebFileUploaderTextSettings

instance.TextSettings = value

value = instance.TextSettings
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.PersistLayoutAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Settings")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public WebFileUploaderTextSettings TextSettings {get; set;}
Delphi
public read-write property TextSettings: WebFileUploaderTextSettings;
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.PersistLayoutAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Settings")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
public function get,set TextSettings : WebFileUploaderTextSettings
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.PersistLayoutAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Settings")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public: __property WebFileUploaderTextSettings* get_TextSettings();
public: __property void set_TextSettings(
   WebFileUploaderTextSettings* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.PersistLayoutAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Settings")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public:
property WebFileUploaderTextSettings^ TextSettings {
   WebFileUploaderTextSettings^ get();
   void set (    WebFileUploaderTextSettings^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


TotalUploadSizeLimit Property

[image]
Intersoft WebTextEditor Documentation
TotalUploadSizeLimit Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : TotalUploadSizeLimit Property

Glossary Item Box

The total number of bytes that can be uploaded (0 for no limit).

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.DescriptionAttribute("The total number of bytes that can be uploaded (0 for no limit).")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Property TotalUploadSizeLimit As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Integer

instance.TotalUploadSizeLimit = value

value = instance.TotalUploadSizeLimit
C#
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DescriptionAttribute("The total number of bytes that can be uploaded (0 for no limit).")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public System.int TotalUploadSizeLimit {get; set;}
Delphi
public read-write property TotalUploadSizeLimit: System.Integer;
JScript
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.DescriptionAttribute("The total number of bytes that can be uploaded (0 for no limit).")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set TotalUploadSizeLimit : System.int
Managed Extensions for C++
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DescriptionAttribute("The total number of bytes that can be uploaded (0 for no limit).")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property System.int get_TotalUploadSizeLimit();
public: __property void set_TotalUploadSizeLimit(
   System.int value
);
C++/CLI
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DescriptionAttribute("The total number of bytes that can be uploaded (0 for no limit).")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
property System.int TotalUploadSizeLimit {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


UILayout Property

[image]
Intersoft WebTextEditor Documentation
UILayout Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : UILayout Property

Glossary Item Box

Specifies UILayout of WebUploader.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Appearance")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Property UILayout As UILayout
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As UILayout

instance.UILayout = value

value = instance.UILayout
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public UILayout UILayout {get; set;}
Delphi
public read-write property UILayout: UILayout;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Appearance")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set UILayout : UILayout
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property UILayout get_UILayout();
public: __property void set_UILayout(
   UILayout value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
property UILayout UILayout {
   UILayout get();
   void set (    UILayout value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


UploadPath Property

[image]
Intersoft WebTextEditor Documentation
UploadPath Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : UploadPath Property

Glossary Item Box

Specifies upload path of WebUploader.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property UploadPath As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.String

instance.UploadPath = value

value = instance.UploadPath
C#
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.string UploadPath {get; set;}
Delphi
public read-write property UploadPath: System.String;
JScript
System.ComponentModel.DescriptionAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set UploadPath : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_UploadPath();
public: __property void set_UploadPath(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ UploadPath {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


UploadSizeLimit Property

[image]
Intersoft WebTextEditor Documentation
UploadSizeLimit Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : UploadSizeLimit Property

Glossary Item Box

The number of bytes that can be uploaded (0 for no limit) for each file.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("The number of bytes that can be uploaded (0 for no limit) for each file.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property UploadSizeLimit As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Integer

instance.UploadSizeLimit = value

value = instance.UploadSizeLimit
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The number of bytes that can be uploaded (0 for no limit) for each file.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.int UploadSizeLimit {get; set;}
Delphi
public read-write property UploadSizeLimit: System.Integer;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("The number of bytes that can be uploaded (0 for no limit) for each file.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set UploadSizeLimit : System.int
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The number of bytes that can be uploaded (0 for no limit) for each file.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.int get_UploadSizeLimit();
public: __property void set_UploadSizeLimit(
   System.int value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The number of bytes that can be uploaded (0 for no limit) for each file.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.int UploadSizeLimit {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


UploadType Property

[image]
Intersoft WebTextEditor Documentation
UploadType Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : UploadType Property

Glossary Item Box

Specifies upload type of WebUploader.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.DescriptionAttribute()>
Public Property UploadType As UploadType
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As UploadType

instance.UploadType = value

value = instance.UploadType
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute()]
public UploadType UploadType {get; set;}
Delphi
public read-write property UploadType: UploadType;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.DescriptionAttribute()
public function get,set UploadType : UploadType
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute()]
public: __property UploadType get_UploadType();
public: __property void set_UploadType(
   UploadType value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute()]
public:
property UploadType UploadType {
   UploadType get();
   void set (    UploadType value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


UseDefaultStyle Property

[image]
Intersoft WebTextEditor Documentation
UseDefaultStyle Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : UseDefaultStyle Property

Glossary Item Box

Gets or sets a value indicating whether default style is used.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets a value indicating whether default style is used.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.DefaultValueAttribute()>
<System.Web.UI.ThemeableAttribute(False)>
Public Property UseDefaultStyle As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Boolean

instance.UseDefaultStyle = value

value = instance.UseDefaultStyle
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value indicating whether default style is used.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.ThemeableAttribute(false)]
public System.bool UseDefaultStyle {get; set;}
Delphi
public read-write property UseDefaultStyle: System.Boolean;
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets a value indicating whether default style is used.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.DefaultValueAttribute()
System.Web.UI.ThemeableAttribute()
public function get,set UseDefaultStyle : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value indicating whether default style is used.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.ThemeableAttribute(false)]
public: __property System.bool get_UseDefaultStyle();
public: __property void set_UseDefaultStyle(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value indicating whether default style is used.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.ThemeableAttribute(false)]
public:
property System.bool UseDefaultStyle {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


Width Property

[image]
Intersoft WebTextEditor Documentation
Width Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : Width Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Layout")>
Public Overrides Property Width As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Web.UI.WebControls.Unit

instance.Width = value

value = instance.Width
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Layout")]
public override System.Web.UI.WebControls.Unit Width {get; set;}
Delphi
public read-write property Width: System.Web.UI.WebControls.Unit; override;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Layout")
public override function get,set Width : System.Web.UI.WebControls.Unit
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Layout")]
public: __property System.Web.UI.WebControls.Unit get_Width() override;
public: __property void set_Width(
   System.Web.UI.WebControls.Unit value
) override;
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Layout")]
public:
property System.Web.UI.WebControls.Unit Width {
   System.Web.UI.WebControls.Unit get() override;
   void set (    System.Web.UI.WebControls.Unit value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


WebFileUploader Class Events

[image]
Intersoft WebTextEditor Documentation
WebFileUploader Class Events
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebFileUploader Class

Glossary Item Box

For a list of all members of this type, see WebFileUploader members.

Public Events

 | Name | Description
Public Event | AfterUpload |
Public Event | CancelUpload |
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | ErrorUpload |
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Public Event | Uploading |
Top

See Also

Reference

WebFileUploader Class
ISNet.WebUI.WebTextEditor Namespace


AfterUpload Event

[image]
Intersoft WebTextEditor Documentation
AfterUpload Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : AfterUpload Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event AfterUpload As UploadFileEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim handler As UploadFileEventHandler

AddHandler instance.AfterUpload, handler
C#
public event UploadFileEventHandler AfterUpload
Delphi
public event AfterUpload: UploadFileEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
public: __event UploadFileEventHandler* AfterUpload
C++/CLI
public:
event UploadFileEventHandler^ AfterUpload

Event Data

The event handler receives an argument of type WebFileUploaderFileEventArgs containing data related to this event. The following WebFileUploaderFileEventArgs properties provide information specific to this event.

Property | Description
WebFileUploadInfo |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


CancelUpload Event

[image]
Intersoft WebTextEditor Documentation
CancelUpload Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : CancelUpload Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event CancelUpload As UploadFileEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim handler As UploadFileEventHandler

AddHandler instance.CancelUpload, handler
C#
public event UploadFileEventHandler CancelUpload
Delphi
public event CancelUpload: UploadFileEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
public: __event UploadFileEventHandler* CancelUpload
C++/CLI
public:
event UploadFileEventHandler^ CancelUpload

Event Data

The event handler receives an argument of type WebFileUploaderFileEventArgs containing data related to this event. The following WebFileUploaderFileEventArgs properties provide information specific to this event.

Property | Description
WebFileUploadInfo |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


ErrorUpload Event

[image]
Intersoft WebTextEditor Documentation
ErrorUpload Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : ErrorUpload Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event ErrorUpload As UploadFileEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim handler As UploadFileEventHandler

AddHandler instance.ErrorUpload, handler
C#
public event UploadFileEventHandler ErrorUpload
Delphi
public event ErrorUpload: UploadFileEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
public: __event UploadFileEventHandler* ErrorUpload
C++/CLI
public:
event UploadFileEventHandler^ ErrorUpload

Event Data

The event handler receives an argument of type WebFileUploaderFileEventArgs containing data related to this event. The following WebFileUploaderFileEventArgs properties provide information specific to this event.

Property | Description
WebFileUploadInfo |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


Uploading Event

[image]
Intersoft WebTextEditor Documentation
Uploading Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : Uploading Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event Uploading As UploadFileEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim handler As UploadFileEventHandler

AddHandler instance.Uploading, handler
C#
public event UploadFileEventHandler Uploading
Delphi
public event Uploading: UploadFileEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
public: __event UploadFileEventHandler* Uploading
C++/CLI
public:
event UploadFileEventHandler^ Uploading

Event Data

The event handler receives an argument of type WebFileUploaderFileEventArgs containing data related to this event. The following WebFileUploaderFileEventArgs properties provide information specific to this event.

Property | Description
WebFileUploadInfo |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


WebFileUploaderClientSideEvents Class

[image]
Intersoft WebTextEditor Documentation
WebFileUploaderClientSideEvents Class
Members See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebFileUploaderClientSideEvents Class

Glossary Item Box

A collection of WebUploader's client side events.

Object Model

WebFileUploaderClientSideEvents Class

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Class WebFileUploaderClientSideEvents
   Inherits ISNet.WebUI.ClientEvents
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderClientSideEvents
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public class WebFileUploaderClientSideEvents : ISNet.WebUI.ClientEvents, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebFileUploaderClientSideEvents = class(ISNet.WebUI.ClientEvents, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public class WebFileUploaderClientSideEvents extends ISNet.WebUI.ClientEvents implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public __gc class WebFileUploaderClientSideEvents : public ISNet.WebUI.ClientEvents, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public ref class WebFileUploaderClientSideEvents : public ISNet.WebUI.ClientEvents, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.ClientEvents
ISNet.WebUI.WebTextEditor.WebFileUploaderClientSideEvents

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderClientSideEvents Members
ISNet.WebUI.WebTextEditor Namespace


WebFileUploaderClientSideEvents Class Members

[image]
Intersoft WebTextEditor Documentation
WebFileUploaderClientSideEvents Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebFileUploaderClientSideEvents Class

Glossary Item Box

The following tables list the members exposed by WebFileUploaderClientSideEvents.

Public Constructors

 | Name | Description
Public Constructor | WebFileUploaderClientSideEvents Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | OnAfterUpload | Specifies the client side (JavaScript) function name that will be invoked when a file is uploaded.
Public Property | OnBeforeUpload | Specifies the client side (JavaScript) function name that will be invoked before a file is uploaded.
Public Property | OnCancelUpload | Specifies the client side (JavaScript) function name that will be invoked when uploading a file is cancelled.
Public Property | OnCompleted | Specifies the client side (JavaScript) function name that will be invoked when the uploading process has been completed regardless of the individual upload status.
Public Property | OnError |
Public Property | OnFileAdded | Specifies the client side (JavaScript) function name that will be invoked when a file is added to uploader.
Public Property | OnFileRemoved | Specifies the client side (JavaScript) function name that will be invoked when a file is removed from uploader.
Public Property | OnInitialize | Specifies the client side (JavaScript) function name that will be invoked when control is initialized.
Public Property | OnUploading | Specifies the client side (JavaScript) function name that will be invoked while uploading file.
Public Property | OnValidate | Specifies the client side (JavaScript) function name that will be invoked when custom validating an upload file.
Top

Public Methods

 | Name | Description
Public Method | CheckEventHandlerName | (Inherited from ISNet.WebUI.ClientEvents)
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsAnyAttachEventHandlers | (Inherited from ISNet.WebUI.ClientEvents)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | IsValidEventHandlerName | (Inherited from ISNet.WebUI.ClientEvents)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

Protected Methods

 | Name | Description
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | IsInSerializationContext | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebFileUploaderClientSideEvents Class
ISNet.WebUI.WebTextEditor Namespace


WebFileUploaderClientSideEvents Constructor

[image]
Intersoft WebTextEditor Documentation
WebFileUploaderClientSideEvents Constructor
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderClientSideEvents Class : WebFileUploaderClientSideEvents Constructor

Glossary Item Box

Overload List

Overload | Description
WebFileUploaderClientSideEvents Constructor() |
WebFileUploaderClientSideEvents Constructor(SerializationInfo,StreamingContext) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderClientSideEvents Class
WebFileUploaderClientSideEvents Members


WebFileUploaderClientSideEvents Constructor()

[image]
Intersoft WebTextEditor Documentation
WebFileUploaderClientSideEvents Constructor()
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderClientSideEvents Class > WebFileUploaderClientSideEvents Constructor : WebFileUploaderClientSideEvents Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebFileUploaderClientSideEvents()
C#
public WebFileUploaderClientSideEvents()
Delphi
public WebFileUploaderClientSideEvents();
JScript
public function WebFileUploaderClientSideEvents();
Managed Extensions for C++
public: WebFileUploaderClientSideEvents();
C++/CLI
public:
WebFileUploaderClientSideEvents();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderClientSideEvents Class
WebFileUploaderClientSideEvents Members
Overload List


WebFileUploaderClientSideEvents Constructor(SerializationInfo,StreamingContext)

[image]
Intersoft WebTextEditor Documentation
WebFileUploaderClientSideEvents Constructor(SerializationInfo,StreamingContext)
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderClientSideEvents Class > WebFileUploaderClientSideEvents Constructor : WebFileUploaderClientSideEvents Constructor(SerializationInfo,StreamingContext)

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

Dim instance As New WebFileUploaderClientSideEvents(info, context)
C#
protected WebFileUploaderClientSideEvents(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
protected WebFileUploaderClientSideEvents(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
protected function WebFileUploaderClientSideEvents(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
protected: WebFileUploaderClientSideEvents(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
protected:
WebFileUploaderClientSideEvents(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderClientSideEvents Class
WebFileUploaderClientSideEvents Members
Overload List


WebFileUploaderClientSideEvents Class Methods

[image]
Intersoft WebTextEditor Documentation
WebFileUploaderClientSideEvents Class Methods
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebFileUploaderClientSideEvents Class

Glossary Item Box

For a list of all members of this type, see WebFileUploaderClientSideEvents members.

Public Methods

 | Name | Description
Public Method | CheckEventHandlerName | (Inherited from ISNet.WebUI.ClientEvents)
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsAnyAttachEventHandlers | (Inherited from ISNet.WebUI.ClientEvents)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | IsValidEventHandlerName | (Inherited from ISNet.WebUI.ClientEvents)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

Protected Methods

 | Name | Description
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | IsInSerializationContext | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebFileUploaderClientSideEvents Class
ISNet.WebUI.WebTextEditor Namespace


GetObjectData Method

[image]
Intersoft WebTextEditor Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderClientSideEvents Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderClientSideEvents
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderClientSideEvents Class
WebFileUploaderClientSideEvents Members


WebFileUploaderClientSideEvents Class Properties

[image]
Intersoft WebTextEditor Documentation
WebFileUploaderClientSideEvents Class Properties
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebFileUploaderClientSideEvents Class

Glossary Item Box

For a list of all members of this type, see WebFileUploaderClientSideEvents members.

Public Properties

 | Name | Description
Public Property | OnAfterUpload | Specifies the client side (JavaScript) function name that will be invoked when a file is uploaded.
Public Property | OnBeforeUpload | Specifies the client side (JavaScript) function name that will be invoked before a file is uploaded.
Public Property | OnCancelUpload | Specifies the client side (JavaScript) function name that will be invoked when uploading a file is cancelled.
Public Property | OnCompleted | Specifies the client side (JavaScript) function name that will be invoked when the uploading process has been completed regardless of the individual upload status.
Public Property | OnError |
Public Property | OnFileAdded | Specifies the client side (JavaScript) function name that will be invoked when a file is added to uploader.
Public Property | OnFileRemoved | Specifies the client side (JavaScript) function name that will be invoked when a file is removed from uploader.
Public Property | OnInitialize | Specifies the client side (JavaScript) function name that will be invoked when control is initialized.
Public Property | OnUploading | Specifies the client side (JavaScript) function name that will be invoked while uploading file.
Public Property | OnValidate | Specifies the client side (JavaScript) function name that will be invoked when custom validating an upload file.
Top

See Also

Reference

WebFileUploaderClientSideEvents Class
ISNet.WebUI.WebTextEditor Namespace


OnAfterUpload Property

[image]
Intersoft WebTextEditor Documentation
OnAfterUpload Property
See Also Example Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderClientSideEvents Class : OnAfterUpload Property

Glossary Item Box

Specifies the client side (JavaScript) function name that will be invoked when a file is uploaded.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.EventParameterAttribute("controlId, webFileUploadInfo")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when a file is uploaded. Parameters (controlId, webFileUploadInfo)")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property OnAfterUpload As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderClientSideEvents
Dim value As System.String

instance.OnAfterUpload = value

value = instance.OnAfterUpload
C#
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, webFileUploadInfo")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when a file is uploaded. Parameters (controlId, webFileUploadInfo)")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string OnAfterUpload {get; set;}
Delphi
public read-write property OnAfterUpload: System.String;
JScript
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.EventParameterAttribute("controlId, webFileUploadInfo")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when a file is uploaded. Parameters (controlId, webFileUploadInfo)")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set OnAfterUpload : System.String
Managed Extensions for C++
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, webFileUploadInfo")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when a file is uploaded. Parameters (controlId, webFileUploadInfo)")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_OnAfterUpload();
public: __property void set_OnAfterUpload(
   System.string* value
);
C++/CLI
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, webFileUploadInfo")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when a file is uploaded. Parameters (controlId, webFileUploadInfo)")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ OnAfterUpload {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default is null.

Remarks

Parameters :
  • controlId - string

Example

C# Copy Code
function doBeforeUpload(controlId, webFileUploadInfo)
{
    // do some action here
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderClientSideEvents Class
WebFileUploaderClientSideEvents Members


OnBeforeUpload Property

[image]
Intersoft WebTextEditor Documentation
OnBeforeUpload Property
See Also Example Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderClientSideEvents Class : OnBeforeUpload Property

Glossary Item Box

Specifies the client side (JavaScript) function name that will be invoked before a file is uploaded.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.EventParameterAttribute("controlId, webFileUploadInfo")>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked before a file is uploaded. Parameters (controlId, webFileUploadInfo)")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property OnBeforeUpload As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderClientSideEvents
Dim value As System.String

instance.OnBeforeUpload = value

value = instance.OnBeforeUpload
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, webFileUploadInfo")]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked before a file is uploaded. Parameters (controlId, webFileUploadInfo)")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string OnBeforeUpload {get; set;}
Delphi
public read-write property OnBeforeUpload: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.EventParameterAttribute("controlId, webFileUploadInfo")
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked before a file is uploaded. Parameters (controlId, webFileUploadInfo)")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set OnBeforeUpload : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, webFileUploadInfo")]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked before a file is uploaded. Parameters (controlId, webFileUploadInfo)")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_OnBeforeUpload();
public: __property void set_OnBeforeUpload(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, webFileUploadInfo")]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked before a file is uploaded. Parameters (controlId, webFileUploadInfo)")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ OnBeforeUpload {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default is null.

Remarks

Parameters :
  • controlId - string

Example

C# Copy Code
function doBeforeUpload(controlId, webFileUploadInfo)
{
    // do some action here
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderClientSideEvents Class
WebFileUploaderClientSideEvents Members


OnCancelUpload Property

[image]
Intersoft WebTextEditor Documentation
OnCancelUpload Property
See Also Example Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderClientSideEvents Class : OnCancelUpload Property

Glossary Item Box

Specifies the client side (JavaScript) function name that will be invoked when uploading a file is cancelled.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when uploading a file is cancelled. Parameters (controlId, webFileUploadInfo)")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.EventParameterAttribute("controlId, webFileUploadInfo")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property OnCancelUpload As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderClientSideEvents
Dim value As System.String

instance.OnCancelUpload = value

value = instance.OnCancelUpload
C#
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when uploading a file is cancelled. Parameters (controlId, webFileUploadInfo)")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, webFileUploadInfo")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string OnCancelUpload {get; set;}
Delphi
public read-write property OnCancelUpload: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when uploading a file is cancelled. Parameters (controlId, webFileUploadInfo)")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.EventParameterAttribute("controlId, webFileUploadInfo")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set OnCancelUpload : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when uploading a file is cancelled. Parameters (controlId, webFileUploadInfo)")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, webFileUploadInfo")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_OnCancelUpload();
public: __property void set_OnCancelUpload(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when uploading a file is cancelled. Parameters (controlId, webFileUploadInfo)")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, webFileUploadInfo")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ OnCancelUpload {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default is null.

Remarks

Parameters :
  • controlId - string

Example

C# Copy Code
function doBeforeUpload(controlId, webFileUploadInfo)
{
    // do some action here
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderClientSideEvents Class
WebFileUploaderClientSideEvents Members


OnCompleted Property

[image]
Intersoft WebTextEditor Documentation
OnCompleted Property
See Also Example Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderClientSideEvents Class : OnCompleted Property

Glossary Item Box

Specifies the client side (JavaScript) function name that will be invoked when the uploading process has been completed regardless of the individual upload status.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.EventParameterAttribute("controlId")>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when the uploading process has been completed regardless of the individual upload status. Parameters (controlId)")>
Public Property OnCompleted As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderClientSideEvents
Dim value As System.String

instance.OnCompleted = value

value = instance.OnCompleted
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when the uploading process has been completed regardless of the individual upload status. Parameters (controlId)")]
public System.string OnCompleted {get; set;}
Delphi
public read-write property OnCompleted: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.EventParameterAttribute("controlId")
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when the uploading process has been completed regardless of the individual upload status. Parameters (controlId)")
public function get,set OnCompleted : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when the uploading process has been completed regardless of the individual upload status. Parameters (controlId)")]
public: __property System.string* get_OnCompleted();
public: __property void set_OnCompleted(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when the uploading process has been completed regardless of the individual upload status. Parameters (controlId)")]
public:
property System.String^ OnCompleted {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default is null.

Remarks

Parameters :
  • controlId - string

Example

C# Copy Code
function doCompleted(controlId)
{
    // do some action here
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderClientSideEvents Class
WebFileUploaderClientSideEvents Members


OnError Property

[image]
Intersoft WebTextEditor Documentation
OnError Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderClientSideEvents Class : OnError Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when an error occurred during file uploading process. Parameters (controlId, webFileUploadInfo, errorMessage, errorDetail)")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.EventParameterAttribute("controlId")>
Public Property OnError As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderClientSideEvents
Dim value As System.String

instance.OnError = value

value = instance.OnError
C#
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when an error occurred during file uploading process. Parameters (controlId, webFileUploadInfo, errorMessage, errorDetail)")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId")]
public System.string OnError {get; set;}
Delphi
public read-write property OnError: System.String;
JScript
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when an error occurred during file uploading process. Parameters (controlId, webFileUploadInfo, errorMessage, errorDetail)")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.EventParameterAttribute("controlId")
public function get,set OnError : System.String
Managed Extensions for C++
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when an error occurred during file uploading process. Parameters (controlId, webFileUploadInfo, errorMessage, errorDetail)")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId")]
public: __property System.string* get_OnError();
public: __property void set_OnError(
   System.string* value
);
C++/CLI
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when an error occurred during file uploading process. Parameters (controlId, webFileUploadInfo, errorMessage, errorDetail)")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId")]
public:
property System.String^ OnError {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderClientSideEvents Class
WebFileUploaderClientSideEvents Members


OnFileAdded Property

[image]
Intersoft WebTextEditor Documentation
OnFileAdded Property
See Also Example Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderClientSideEvents Class : OnFileAdded Property

Glossary Item Box

Specifies the client side (JavaScript) function name that will be invoked when a file is added to uploader.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when a file is added to uploader. Parameters (controlId, webFileUploadInfo)")>
<ISNet.EventParameterAttribute("controlId, webFileUploadInfo")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property OnFileAdded As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderClientSideEvents
Dim value As System.String

instance.OnFileAdded = value

value = instance.OnFileAdded
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when a file is added to uploader. Parameters (controlId, webFileUploadInfo)")]
[ISNet.EventParameterAttribute("controlId, webFileUploadInfo")]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string OnFileAdded {get; set;}
Delphi
public read-write property OnFileAdded: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when a file is added to uploader. Parameters (controlId, webFileUploadInfo)")
ISNet.EventParameterAttribute("controlId, webFileUploadInfo")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set OnFileAdded : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when a file is added to uploader. Parameters (controlId, webFileUploadInfo)")]
[ISNet.EventParameterAttribute("controlId, webFileUploadInfo")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_OnFileAdded();
public: __property void set_OnFileAdded(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when a file is added to uploader. Parameters (controlId, webFileUploadInfo)")]
[ISNet.EventParameterAttribute("controlId, webFileUploadInfo")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ OnFileAdded {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default is null.

Remarks

Parameters :
  • controlId - string

Example

C# Copy Code
function doFileAdded(controlId, webFileUploadInfo)
{
    // do some action here
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderClientSideEvents Class
WebFileUploaderClientSideEvents Members


OnFileRemoved Property

[image]
Intersoft WebTextEditor Documentation
OnFileRemoved Property
See Also Example Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderClientSideEvents Class : OnFileRemoved Property

Glossary Item Box

Specifies the client side (JavaScript) function name that will be invoked when a file is removed from uploader.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when a file is removed from uploader. Parameters (controlId, webFileUploadInfo)")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.EventParameterAttribute("controlId, webFileUploadInfo")>
Public Property OnFileRemoved As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderClientSideEvents
Dim value As System.String

instance.OnFileRemoved = value

value = instance.OnFileRemoved
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when a file is removed from uploader. Parameters (controlId, webFileUploadInfo)")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, webFileUploadInfo")]
public System.string OnFileRemoved {get; set;}
Delphi
public read-write property OnFileRemoved: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when a file is removed from uploader. Parameters (controlId, webFileUploadInfo)")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.EventParameterAttribute("controlId, webFileUploadInfo")
public function get,set OnFileRemoved : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when a file is removed from uploader. Parameters (controlId, webFileUploadInfo)")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, webFileUploadInfo")]
public: __property System.string* get_OnFileRemoved();
public: __property void set_OnFileRemoved(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when a file is removed from uploader. Parameters (controlId, webFileUploadInfo)")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, webFileUploadInfo")]
public:
property System.String^ OnFileRemoved {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default is null.

Remarks

Parameters :
  • controlId - string

Example

C# Copy Code
function doFileRemoved(controlId, webFileUploadInfo)
{
    // do some action here
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderClientSideEvents Class
WebFileUploaderClientSideEvents Members


OnInitialize Property

[image]
Intersoft WebTextEditor Documentation
OnInitialize Property
See Also Example Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderClientSideEvents Class : OnInitialize Property

Glossary Item Box

Specifies the client side (JavaScript) function name that will be invoked when control is initialized.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.EventParameterAttribute("controlId")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when control is initialized. Parameters (controlId)")>
Public Property OnInitialize As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderClientSideEvents
Dim value As System.String

instance.OnInitialize = value

value = instance.OnInitialize
C#
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when control is initialized. Parameters (controlId)")]
public System.string OnInitialize {get; set;}
Delphi
public read-write property OnInitialize: System.String;
JScript
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.EventParameterAttribute("controlId")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when control is initialized. Parameters (controlId)")
public function get,set OnInitialize : System.String
Managed Extensions for C++
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when control is initialized. Parameters (controlId)")]
public: __property System.string* get_OnInitialize();
public: __property void set_OnInitialize(
   System.string* value
);
C++/CLI
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when control is initialized. Parameters (controlId)")]
public:
property System.String^ OnInitialize {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default is null.

Remarks

Parameters :
  • controlId - string

Example

C# Copy Code
function doInitialize(controlId)
{
    // do some action here
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderClientSideEvents Class
WebFileUploaderClientSideEvents Members


OnUploading Property

[image]
Intersoft WebTextEditor Documentation
OnUploading Property
See Also Example Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderClientSideEvents Class : OnUploading Property

Glossary Item Box

Specifies the client side (JavaScript) function name that will be invoked while uploading file.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.EventParameterAttribute("controlId, webFileUploadInfo")>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked while uploading file. Parameters (controlId, webFileUploadInfo)")>
Public Property OnUploading As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderClientSideEvents
Dim value As System.String

instance.OnUploading = value

value = instance.OnUploading
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId, webFileUploadInfo")]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked while uploading file. Parameters (controlId, webFileUploadInfo)")]
public System.string OnUploading {get; set;}
Delphi
public read-write property OnUploading: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.EventParameterAttribute("controlId, webFileUploadInfo")
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked while uploading file. Parameters (controlId, webFileUploadInfo)")
public function get,set OnUploading : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId, webFileUploadInfo")]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked while uploading file. Parameters (controlId, webFileUploadInfo)")]
public: __property System.string* get_OnUploading();
public: __property void set_OnUploading(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId, webFileUploadInfo")]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked while uploading file. Parameters (controlId, webFileUploadInfo)")]
public:
property System.String^ OnUploading {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default is null.

Remarks

Parameters :
  • controlId - string

Example

C# Copy Code
function doUploading(controlId, webFileUploadInfo)
{
    // do some action here
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderClientSideEvents Class
WebFileUploaderClientSideEvents Members


OnValidate Property

[image]
Intersoft WebTextEditor Documentation
OnValidate Property
See Also Example Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderClientSideEvents Class : OnValidate Property

Glossary Item Box

Specifies the client side (JavaScript) function name that will be invoked when custom validating an upload file.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when custom validating an upload file. Parameters (controlId, validationType, validationValue, isValid)")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.EventParameterAttribute("controlId, validationType, fileName, isValid")>
Public Property OnValidate As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderClientSideEvents
Dim value As System.String

instance.OnValidate = value

value = instance.OnValidate
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when custom validating an upload file. Parameters (controlId, validationType, validationValue, isValid)")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, validationType, fileName, isValid")]
public System.string OnValidate {get; set;}
Delphi
public read-write property OnValidate: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when custom validating an upload file. Parameters (controlId, validationType, validationValue, isValid)")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.EventParameterAttribute("controlId, validationType, fileName, isValid")
public function get,set OnValidate : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when custom validating an upload file. Parameters (controlId, validationType, validationValue, isValid)")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, validationType, fileName, isValid")]
public: __property System.string* get_OnValidate();
public: __property void set_OnValidate(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the client side (JavaScript) function name that will be invoked when custom validating an upload file. Parameters (controlId, validationType, validationValue, isValid)")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WebUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, validationType, fileName, isValid")]
public:
property System.String^ OnValidate {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default is null.

Remarks

Parameters :
  • controlId - string

Example

C# Copy Code
function doValidate(controlId, validationType, validationValue, isValid)
{
    // do some action here
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderClientSideEvents Class
WebFileUploaderClientSideEvents Members


WebFileUploaderFileEventArgs Class

[image]
Intersoft WebTextEditor Documentation
WebFileUploaderFileEventArgs Class
Members See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebFileUploaderFileEventArgs Class

Glossary Item Box

Object Model

WebFileUploaderFileEventArgs Class

Syntax

Visual Basic (Declaration)
Public Class WebFileUploaderFileEventArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderFileEventArgs
C#
public class WebFileUploaderFileEventArgs : System.EventArgs
Delphi
public class WebFileUploaderFileEventArgs = class(System.EventArgs)
JScript
public class WebFileUploaderFileEventArgs extends System.EventArgs
Managed Extensions for C++
public __gc class WebFileUploaderFileEventArgs : public System.EventArgs
C++/CLI
public ref class WebFileUploaderFileEventArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
ISNet.WebUI.WebTextEditor.WebFileUploaderFileEventArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderFileEventArgs Members
ISNet.WebUI.WebTextEditor Namespace


WebFileUploaderFileEventArgs Class Members

[image]
Intersoft WebTextEditor Documentation
WebFileUploaderFileEventArgs Class Members
See Also Properties Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebFileUploaderFileEventArgs Class

Glossary Item Box

The following tables list the members exposed by WebFileUploaderFileEventArgs.

Public Constructors

 | Name | Description
Public Constructor | WebFileUploaderFileEventArgs Constructor |
Top

Public Properties

 | Name | Description
Public Property | WebFileUploadInfo |
Top

See Also

Reference

WebFileUploaderFileEventArgs Class
ISNet.WebUI.WebTextEditor Namespace


WebFileUploaderFileEventArgs Constructor

[image]
Intersoft WebTextEditor Documentation
WebFileUploaderFileEventArgs Constructor
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderFileEventArgs Class : WebFileUploaderFileEventArgs Constructor

webFileUploadInfo

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal webFileUploadInfo As WebFileUploaderFileInfo _
)
Visual Basic (Usage) Copy Code
Dim webFileUploadInfo As WebFileUploaderFileInfo

Dim instance As New WebFileUploaderFileEventArgs(webFileUploadInfo)
C#
public WebFileUploaderFileEventArgs(
   WebFileUploaderFileInfo webFileUploadInfo
)
Delphi
public WebFileUploaderFileEventArgs(
    webFileUploadInfo: WebFileUploaderFileInfo
);
JScript
public function WebFileUploaderFileEventArgs(
   webFileUploadInfo : WebFileUploaderFileInfo
);
Managed Extensions for C++
public: WebFileUploaderFileEventArgs(
   WebFileUploaderFileInfo* webFileUploadInfo
)
C++/CLI
public:
WebFileUploaderFileEventArgs(
   WebFileUploaderFileInfo^ webFileUploadInfo
)

Parameters

webFileUploadInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderFileEventArgs Class
WebFileUploaderFileEventArgs Members


WebFileUploaderFileEventArgs Class Properties

[image]
Intersoft WebTextEditor Documentation
WebFileUploaderFileEventArgs Class Properties
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebFileUploaderFileEventArgs Class

Glossary Item Box

For a list of all members of this type, see WebFileUploaderFileEventArgs members.

Public Properties

 | Name | Description
Public Property | WebFileUploadInfo |
Top

See Also

Reference

WebFileUploaderFileEventArgs Class
ISNet.WebUI.WebTextEditor Namespace


WebFileUploadInfo Property

[image]
Intersoft WebTextEditor Documentation
WebFileUploadInfo Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderFileEventArgs Class : WebFileUploadInfo Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property WebFileUploadInfo As WebFileUploaderFileInfo
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderFileEventArgs
Dim value As WebFileUploaderFileInfo

value = instance.WebFileUploadInfo
C#
public WebFileUploaderFileInfo WebFileUploadInfo {get;}
Delphi
public read-only property WebFileUploadInfo: WebFileUploaderFileInfo;
JScript
public function get WebFileUploadInfo : WebFileUploaderFileInfo
Managed Extensions for C++
public: __property WebFileUploaderFileInfo* get_WebFileUploadInfo();
C++/CLI
public:
property WebFileUploaderFileInfo^ WebFileUploadInfo {
   WebFileUploaderFileInfo^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderFileEventArgs Class
WebFileUploaderFileEventArgs Members


WebFileUploaderFileInfo Class

[image]
Intersoft WebTextEditor Documentation
WebFileUploaderFileInfo Class
Members See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebFileUploaderFileInfo Class

Glossary Item Box

A collection of members in WebUploader' file info.

Object Model

WebFileUploaderFileInfo Class

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.SerializableAttribute()>
Public Class WebFileUploaderFileInfo
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderFileInfo
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.SerializableAttribute()]
public class WebFileUploaderFileInfo : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebFileUploaderFileInfo = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.SerializableAttribute()
public class WebFileUploaderFileInfo extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.SerializableAttribute()]
public __gc class WebFileUploaderFileInfo : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.SerializableAttribute()]
public ref class WebFileUploaderFileInfo : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebTextEditor.WebFileUploaderFileInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderFileInfo Members
ISNet.WebUI.WebTextEditor Namespace


WebFileUploaderFileInfo Class Members

[image]
Intersoft WebTextEditor Documentation
WebFileUploaderFileInfo Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebFileUploaderFileInfo Class

Glossary Item Box

The following tables list the members exposed by WebFileUploaderFileInfo.

Public Constructors

 | Name | Description
Public Constructor | WebFileUploaderFileInfo Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | ContentLength |
Public Property | Error |
Public Property | ErrorMessage |
Public Property | ErrorStackTrace |
Public Property | FileName |
Public Property | IsModuleProcessed |
Public Property | Status |
Public Property | Stream |
Public Property | TimeRemaining |
Public Property | UploadedLength |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString |
Top

Protected Methods

 | Name | Description
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | IsInSerializationContext | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebFileUploaderFileInfo Class
ISNet.WebUI.WebTextEditor Namespace


WebFileUploaderFileInfo Constructor

[image]
Intersoft WebTextEditor Documentation
WebFileUploaderFileInfo Constructor
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderFileInfo Class : WebFileUploaderFileInfo Constructor

Glossary Item Box

Overload List

Overload | Description
WebFileUploaderFileInfo Constructor(String,String,Int32) |
WebFileUploaderFileInfo Constructor(SerializationInfo,StreamingContext) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderFileInfo Class
WebFileUploaderFileInfo Members


WebFileUploaderFileInfo Constructor(String,String,Int32)

[image]
Intersoft WebTextEditor Documentation
WebFileUploaderFileInfo Constructor(String,String,Int32)
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderFileInfo Class > WebFileUploaderFileInfo Constructor : WebFileUploaderFileInfo Constructor(String,String,Int32)

fileName
path
hashCode

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fileName As System.String, _
   ByVal path As System.String, _
   ByVal hashCode As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim fileName As System.String
Dim path As System.String
Dim hashCode As System.Integer

Dim instance As New WebFileUploaderFileInfo(fileName, path, hashCode)
C#
public WebFileUploaderFileInfo(
   System.string fileName,
   System.string path,
   System.int hashCode
)
Delphi
public WebFileUploaderFileInfo(
    fileName: System.String;
    path: System.String;
    hashCode: System.Integer
);
JScript
public function WebFileUploaderFileInfo(
   fileName : System.String,
   path : System.String,
   hashCode : System.int
);
Managed Extensions for C++
public: WebFileUploaderFileInfo(
   System.string* fileName,
   System.string* path,
   System.int hashCode
)
C++/CLI
public:
WebFileUploaderFileInfo(
   System.String^ fileName,
   System.String^ path,
   System.int hashCode
)

Parameters

fileName
path
hashCode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderFileInfo Class
WebFileUploaderFileInfo Members
Overload List


WebFileUploaderFileInfo Constructor(SerializationInfo,StreamingContext)

[image]
Intersoft WebTextEditor Documentation
WebFileUploaderFileInfo Constructor(SerializationInfo,StreamingContext)
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderFileInfo Class > WebFileUploaderFileInfo Constructor : WebFileUploaderFileInfo Constructor(SerializationInfo,StreamingContext)

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

Dim instance As New WebFileUploaderFileInfo(info, context)
C#
protected WebFileUploaderFileInfo(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
protected WebFileUploaderFileInfo(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
protected function WebFileUploaderFileInfo(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
protected: WebFileUploaderFileInfo(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
protected:
WebFileUploaderFileInfo(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderFileInfo Class
WebFileUploaderFileInfo Members
Overload List


WebFileUploaderFileInfo Class Methods

[image]
Intersoft WebTextEditor Documentation
WebFileUploaderFileInfo Class Methods
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebFileUploaderFileInfo Class

Glossary Item Box

For a list of all members of this type, see WebFileUploaderFileInfo members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString |
Top

Protected Methods

 | Name | Description
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | IsInSerializationContext | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebFileUploaderFileInfo Class
ISNet.WebUI.WebTextEditor Namespace


GetObjectData Method

[image]
Intersoft WebTextEditor Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderFileInfo Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderFileInfo
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderFileInfo Class
WebFileUploaderFileInfo Members


ToString Method

[image]
Intersoft WebTextEditor Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderFileInfo Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderFileInfo
Dim value As System.String

value = instance.ToString()
C#
public override System.string ToString()
Delphi
public function ToString(): System.String; override;
JScript
public override function ToString() : System.String;
Managed Extensions for C++
public: System.string* ToString(); override
C++/CLI
public:
System.String^ ToString(); override

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderFileInfo Class
WebFileUploaderFileInfo Members


WebFileUploaderFileInfo Class Properties

[image]
Intersoft WebTextEditor Documentation
WebFileUploaderFileInfo Class Properties
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebFileUploaderFileInfo Class

Glossary Item Box

For a list of all members of this type, see WebFileUploaderFileInfo members.

Public Properties

 | Name | Description
Public Property | ContentLength |
Public Property | Error |
Public Property | ErrorMessage |
Public Property | ErrorStackTrace |
Public Property | FileName |
Public Property | IsModuleProcessed |
Public Property | Status |
Public Property | Stream |
Public Property | TimeRemaining |
Public Property | UploadedLength |
Top

See Also

Reference

WebFileUploaderFileInfo Class
ISNet.WebUI.WebTextEditor Namespace


ContentLength Property

[image]
Intersoft WebTextEditor Documentation
ContentLength Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderFileInfo Class : ContentLength Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property ContentLength As System.Long
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderFileInfo
Dim value As System.Long

instance.ContentLength = value

value = instance.ContentLength
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.long ContentLength {get; set;}
Delphi
public read-write property ContentLength: System.Int64;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set ContentLength : System.long
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.long get_ContentLength();
public: __property void set_ContentLength(
   System.long value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.int64 ContentLength {
   System.int64 get();
   void set (    System.int64 value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderFileInfo Class
WebFileUploaderFileInfo Members


Error Property

[image]
Intersoft WebTextEditor Documentation
Error Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderFileInfo Class : Error Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property Error As System.Exception
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderFileInfo
Dim value As System.Exception

instance.Error = value

value = instance.Error
C#
[ISNet.Serialization.BinarySerializableAttribute()]
public System.Exception Error {get; set;}
Delphi
public read-write property Error: System.Exception;
JScript
ISNet.Serialization.BinarySerializableAttribute()
public function get,set Error : System.Exception
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.Exception* get_Error();
public: __property void set_Error(
   System.Exception* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.Exception^ Error {
   System.Exception^ get();
   void set (    System.Exception^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderFileInfo Class
WebFileUploaderFileInfo Members


ErrorMessage Property

[image]
Intersoft WebTextEditor Documentation
ErrorMessage Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderFileInfo Class : ErrorMessage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public ReadOnly Property ErrorMessage As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderFileInfo
Dim value As System.String

value = instance.ErrorMessage
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string ErrorMessage {get;}
Delphi
public read-only property ErrorMessage: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get ErrorMessage : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_ErrorMessage();
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ ErrorMessage {
   System.String^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderFileInfo Class
WebFileUploaderFileInfo Members


ErrorStackTrace Property

[image]
Intersoft WebTextEditor Documentation
ErrorStackTrace Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderFileInfo Class : ErrorStackTrace Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public ReadOnly Property ErrorStackTrace As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderFileInfo
Dim value As System.String

value = instance.ErrorStackTrace
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string ErrorStackTrace {get;}
Delphi
public read-only property ErrorStackTrace: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get ErrorStackTrace : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_ErrorStackTrace();
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ ErrorStackTrace {
   System.String^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderFileInfo Class
WebFileUploaderFileInfo Members


FileName Property

[image]
Intersoft WebTextEditor Documentation
FileName Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderFileInfo Class : FileName Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute("SetFileName")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public ReadOnly Property FileName As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderFileInfo
Dim value As System.String

value = instance.FileName
C#
[ISNet.Serialization.BinarySerializableAttribute("SetFileName")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string FileName {get;}
Delphi
public read-only property FileName: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute("SetFileName")
ISNet.Serialization.XmlSerializableAttribute()
public function get FileName : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute("SetFileName")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_FileName();
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute("SetFileName")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ FileName {
   System.String^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderFileInfo Class
WebFileUploaderFileInfo Members


IsModuleProcessed Property

[image]
Intersoft WebTextEditor Documentation
IsModuleProcessed Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderFileInfo Class : IsModuleProcessed Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property IsModuleProcessed As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderFileInfo
Dim value As System.Boolean

instance.IsModuleProcessed = value

value = instance.IsModuleProcessed
C#
[ISNet.Serialization.BinarySerializableAttribute()]
public System.bool IsModuleProcessed {get; set;}
Delphi
public read-write property IsModuleProcessed: System.Boolean;
JScript
ISNet.Serialization.BinarySerializableAttribute()
public function get,set IsModuleProcessed : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.bool get_IsModuleProcessed();
public: __property void set_IsModuleProcessed(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.bool IsModuleProcessed {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderFileInfo Class
WebFileUploaderFileInfo Members


Status Property

[image]
Intersoft WebTextEditor Documentation
Status Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderFileInfo Class : Status Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property Status As WebUploadInfoStatus
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderFileInfo
Dim value As WebUploadInfoStatus

instance.Status = value

value = instance.Status
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public WebUploadInfoStatus Status {get; set;}
Delphi
public read-write property Status: WebUploadInfoStatus;
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set Status : WebUploadInfoStatus
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property WebUploadInfoStatus get_Status();
public: __property void set_Status(
   WebUploadInfoStatus value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property WebUploadInfoStatus Status {
   WebUploadInfoStatus get();
   void set (    WebUploadInfoStatus value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderFileInfo Class
WebFileUploaderFileInfo Members


Stream Property

[image]
Intersoft WebTextEditor Documentation
Stream Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderFileInfo Class : Stream Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Stream As System.IO.MemoryStream
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderFileInfo
Dim value As System.IO.MemoryStream

value = instance.Stream
C#
public System.IO.MemoryStream Stream {get;}
Delphi
public read-only property Stream: System.IO.MemoryStream;
JScript
public function get Stream : System.IO.MemoryStream
Managed Extensions for C++
public: __property System.IO.MemoryStream* get_Stream();
C++/CLI
public:
property System.IO.MemoryStream^ Stream {
   System.IO.MemoryStream^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderFileInfo Class
WebFileUploaderFileInfo Members


TimeRemaining Property

[image]
Intersoft WebTextEditor Documentation
TimeRemaining Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderFileInfo Class : TimeRemaining Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute("SetTimeRemaining")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public ReadOnly Property TimeRemaining As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderFileInfo
Dim value As System.String

value = instance.TimeRemaining
C#
[ISNet.Serialization.BinarySerializableAttribute("SetTimeRemaining")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string TimeRemaining {get;}
Delphi
public read-only property TimeRemaining: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute("SetTimeRemaining")
ISNet.Serialization.XmlSerializableAttribute()
public function get TimeRemaining : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute("SetTimeRemaining")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_TimeRemaining();
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute("SetTimeRemaining")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ TimeRemaining {
   System.String^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderFileInfo Class
WebFileUploaderFileInfo Members


UploadedLength Property

[image]
Intersoft WebTextEditor Documentation
UploadedLength Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderFileInfo Class : UploadedLength Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property UploadedLength As System.Long
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderFileInfo
Dim value As System.Long

instance.UploadedLength = value

value = instance.UploadedLength
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.long UploadedLength {get; set;}
Delphi
public read-write property UploadedLength: System.Int64;
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set UploadedLength : System.long
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.long get_UploadedLength();
public: __property void set_UploadedLength(
   System.long value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.int64 UploadedLength {
   System.int64 get();
   void set (    System.int64 value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderFileInfo Class
WebFileUploaderFileInfo Members


WebFileUploaderFileProcessor Class

[image]
Intersoft WebTextEditor Documentation
WebFileUploaderFileProcessor Class
Members See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebFileUploaderFileProcessor Class

Glossary Item Box

FileProcessor is used to process byte data from a multi-part form and save it to the disk.

Object Model

WebFileUploaderFileProcessor Class

Syntax

Visual Basic (Declaration)
Public Class WebFileUploaderFileProcessor
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderFileProcessor
C#
public class WebFileUploaderFileProcessor
Delphi
public class WebFileUploaderFileProcessor
JScript
public class WebFileUploaderFileProcessor
Managed Extensions for C++
public __gc class WebFileUploaderFileProcessor
C++/CLI
public ref class WebFileUploaderFileProcessor

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebTextEditor.WebFileUploaderFileProcessor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderFileProcessor Members
ISNet.WebUI.WebTextEditor Namespace


WebFileUploaderFileProcessor Class Members

[image]
Intersoft WebTextEditor Documentation
WebFileUploaderFileProcessor Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebFileUploaderFileProcessor Class

Glossary Item Box

The following tables list the members exposed by WebFileUploaderFileProcessor.

Public Constructors

 | Name | Description
Public Constructor | WebFileUploaderFileProcessor Constructor | Default constructor with the path of where the files should be uploaded.
Top

Public Properties

 | Name | Description
Public Property | FinishedFiles | Property used to get the finished files.
Top

Public Methods

 | Name | Description
Public Method | CloseStreams | Close the stream, and reset the filename.
Public Method | Dispose | Clean up method.
Public Method | GetFieldSeperators | This method should be ran on the bytes that are returned on GetPreloadedEntityBody().
Public Method | ProcessBuffer | Method that is used to process the buffer. It may call itself several times as it looks for new files that may be possible in each buffer.
Top

See Also

Reference

WebFileUploaderFileProcessor Class
ISNet.WebUI.WebTextEditor Namespace


WebFileUploaderFileProcessor Constructor

[image]
Intersoft WebTextEditor Documentation
WebFileUploaderFileProcessor Constructor
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderFileProcessor Class : WebFileUploaderFileProcessor Constructor

fileName
uploadLocation

Glossary Item Box

Default constructor with the path of where the files should be uploaded.

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal fileName As System.String, _
   ByVal uploadLocation As System.String _
)
Visual Basic (Usage) Copy Code
Dim fileName As System.String
Dim uploadLocation As System.String

Dim instance As New WebFileUploaderFileProcessor(fileName, uploadLocation)
C#
public WebFileUploaderFileProcessor(
   System.string fileName,
   System.string uploadLocation
)
Delphi
public WebFileUploaderFileProcessor(
    fileName: System.String;
    uploadLocation: System.String
);
JScript
public function WebFileUploaderFileProcessor(
   fileName : System.String,
   uploadLocation : System.String
);
Managed Extensions for C++
public: WebFileUploaderFileProcessor(
   System.string* fileName,
   System.string* uploadLocation
)
C++/CLI
public:
WebFileUploaderFileProcessor(
   System.String^ fileName,
   System.String^ uploadLocation
)

Parameters

fileName
uploadLocation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderFileProcessor Class
WebFileUploaderFileProcessor Members


WebFileUploaderFileProcessor Class Methods

[image]
Intersoft WebTextEditor Documentation
WebFileUploaderFileProcessor Class Methods
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebFileUploaderFileProcessor Class

Glossary Item Box

For a list of all members of this type, see WebFileUploaderFileProcessor members.

Public Methods

 | Name | Description
Public Method | CloseStreams | Close the stream, and reset the filename.
Public Method | Dispose | Clean up method.
Public Method | GetFieldSeperators | This method should be ran on the bytes that are returned on GetPreloadedEntityBody().
Public Method | ProcessBuffer | Method that is used to process the buffer. It may call itself several times as it looks for new files that may be possible in each buffer.
Top

See Also

Reference

WebFileUploaderFileProcessor Class
ISNet.WebUI.WebTextEditor Namespace


CloseStreams Method

[image]
Intersoft WebTextEditor Documentation
CloseStreams Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderFileProcessor Class : CloseStreams Method

Glossary Item Box

Close the stream, and reset the filename.

Syntax

Visual Basic (Declaration)
Public Sub CloseStreams()
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderFileProcessor

instance.CloseStreams()
C#
public void CloseStreams()
Delphi
public procedure CloseStreams();
JScript
public function CloseStreams();
Managed Extensions for C++
public: void CloseStreams();
C++/CLI
public:
void CloseStreams();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderFileProcessor Class
WebFileUploaderFileProcessor Members


Dispose Method

[image]
Intersoft WebTextEditor Documentation
Dispose Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderFileProcessor Class : Dispose Method

Glossary Item Box

Clean up method.

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderFileProcessor

instance.Dispose()
C#
public void Dispose()
Delphi
public procedure Dispose();
JScript
public function Dispose();
Managed Extensions for C++
public: void Dispose();
C++/CLI
public:
void Dispose();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderFileProcessor Class
WebFileUploaderFileProcessor Members


GetFieldSeperators Method

[image]
Intersoft WebTextEditor Documentation
GetFieldSeperators Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderFileProcessor Class : GetFieldSeperators Method

bufferData

Glossary Item Box

This method should be ran on the bytes that are returned on GetPreloadedEntityBody().

Syntax

Visual Basic (Declaration)
Public Sub GetFieldSeperators( _
   ByRef bufferData As System.Byte() _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderFileProcessor
Dim bufferData As System.Byte()

instance.GetFieldSeperators(bufferData)
C#
public void GetFieldSeperators(
   ref System.byte[] bufferData
)
Delphi
public procedure GetFieldSeperators(
   var  bufferData: System.array of Byte
);
JScript
public function GetFieldSeperators(
   bufferData : System.byte[]
);
Managed Extensions for C++
public: void GetFieldSeperators(
   ref System.byte[] bufferData
)
C++/CLI
public:
void GetFieldSeperators(
   System.array<byte>% bufferData
)

Parameters

bufferData

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderFileProcessor Class
WebFileUploaderFileProcessor Members


ProcessBuffer Method

[image]
Intersoft WebTextEditor Documentation
ProcessBuffer Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderFileProcessor Class : ProcessBuffer Method

bufferData
Byte data to scan
addToBufferHistory
If true, it will add it to the buffer history. If false, it will not.

Glossary Item Box

Method that is used to process the buffer. It may call itself several times as it looks for new files that may be possible in each buffer.

Syntax

Visual Basic (Declaration)
Public Sub ProcessBuffer( _
   ByRef bufferData As System.Byte(), _
   ByVal addToBufferHistory As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderFileProcessor
Dim bufferData As System.Byte()
Dim addToBufferHistory As System.Boolean

instance.ProcessBuffer(bufferData, addToBufferHistory)
C#
public void ProcessBuffer(
   ref System.byte[] bufferData,
   System.bool addToBufferHistory
)
Delphi
public procedure ProcessBuffer(
   var  bufferData: System.array of Byte;
    addToBufferHistory: System.Boolean
);
JScript
public function ProcessBuffer(
   bufferData : System.byte[],
   addToBufferHistory : System.boolean
);
Managed Extensions for C++
public: void ProcessBuffer(
   ref System.byte[] bufferData,
   System.bool addToBufferHistory
)
C++/CLI
public:
void ProcessBuffer(
   System.array<byte>% bufferData,
   System.bool addToBufferHistory
)

Parameters

bufferData
Byte data to scan
addToBufferHistory
If true, it will add it to the buffer history. If false, it will not.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderFileProcessor Class
WebFileUploaderFileProcessor Members


WebFileUploaderFileProcessor Class Properties

[image]
Intersoft WebTextEditor Documentation
WebFileUploaderFileProcessor Class Properties
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebFileUploaderFileProcessor Class

Glossary Item Box

For a list of all members of this type, see WebFileUploaderFileProcessor members.

Public Properties

 | Name | Description
Public Property | FinishedFiles | Property used to get the finished files.
Top

See Also

Reference

WebFileUploaderFileProcessor Class
ISNet.WebUI.WebTextEditor Namespace


FinishedFiles Property

[image]
Intersoft WebTextEditor Documentation
FinishedFiles Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderFileProcessor Class : FinishedFiles Property

Glossary Item Box

Property used to get the finished files.

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FinishedFiles As System.Collections.Generic.List(Of String)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderFileProcessor
Dim value As System.Collections.Generic.List(Of String)

value = instance.FinishedFiles
C#
public System.Collections.Generic.List<string> FinishedFiles {get;}
Delphi
public read-only property FinishedFiles: System.Collections.Generic.List;
JScript
public function get FinishedFiles : System.Collections.Generic.List
Managed Extensions for C++
public: __property System.Collections.Generic.List<string*>* get_FinishedFiles();
C++/CLI
public:
property System.Collections.Generic.List<String^>^ FinishedFiles {
   System.Collections.Generic.List<String^>^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderFileProcessor Class
WebFileUploaderFileProcessor Members


WebFileUploaderHttpHandler Class

[image]
Intersoft WebTextEditor Documentation
WebFileUploaderHttpHandler Class
Members See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebFileUploaderHttpHandler Class

Glossary Item Box

Object Model

WebFileUploaderHttpHandler Class

Syntax

Visual Basic (Declaration)
Public Class WebFileUploaderHttpHandler
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderHttpHandler
C#
public class WebFileUploaderHttpHandler
Delphi
public class WebFileUploaderHttpHandler
JScript
public class WebFileUploaderHttpHandler
Managed Extensions for C++
public __gc class WebFileUploaderHttpHandler
C++/CLI
public ref class WebFileUploaderHttpHandler

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebTextEditor.WebFileUploaderHttpHandler

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderHttpHandler Members
ISNet.WebUI.WebTextEditor Namespace


WebFileUploaderHttpHandler Class Members

[image]
Intersoft WebTextEditor Documentation
WebFileUploaderHttpHandler Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebFileUploaderHttpHandler Class

Glossary Item Box

The following tables list the members exposed by WebFileUploaderHttpHandler.

Public Constructors

 | Name | Description
Public Constructor | WebFileUploaderHttpHandler Constructor |
Top

Public Properties

 | Name | Description
Public Property | IsReusable |
Top

Public Methods

 | Name | Description
Public Method | ProcessRequest |
Top

See Also

Reference

WebFileUploaderHttpHandler Class
ISNet.WebUI.WebTextEditor Namespace


WebFileUploaderHttpHandler Constructor

[image]
Intersoft WebTextEditor Documentation
WebFileUploaderHttpHandler Constructor
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderHttpHandler Class : WebFileUploaderHttpHandler Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebFileUploaderHttpHandler()
C#
public WebFileUploaderHttpHandler()
Delphi
public WebFileUploaderHttpHandler();
JScript
public function WebFileUploaderHttpHandler();
Managed Extensions for C++
public: WebFileUploaderHttpHandler();
C++/CLI
public:
WebFileUploaderHttpHandler();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderHttpHandler Class
WebFileUploaderHttpHandler Members


WebFileUploaderHttpHandler Class Methods

[image]
Intersoft WebTextEditor Documentation
WebFileUploaderHttpHandler Class Methods
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebFileUploaderHttpHandler Class

Glossary Item Box

For a list of all members of this type, see WebFileUploaderHttpHandler members.

Public Methods

 | Name | Description
Public Method | ProcessRequest |
Top

See Also

Reference

WebFileUploaderHttpHandler Class
ISNet.WebUI.WebTextEditor Namespace


ProcessRequest Method

[image]
Intersoft WebTextEditor Documentation
ProcessRequest Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderHttpHandler Class : ProcessRequest Method

context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ProcessRequest( _
   ByVal context As System.Web.HttpContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderHttpHandler
Dim context As System.Web.HttpContext

instance.ProcessRequest(context)
C#
public void ProcessRequest(
   System.Web.HttpContext context
)
Delphi
public procedure ProcessRequest(
    context: System.Web.HttpContext
);
JScript
public function ProcessRequest(
   context : System.Web.HttpContext
);
Managed Extensions for C++
public: void ProcessRequest(
   System.Web.HttpContext* context
)
C++/CLI
public:
void ProcessRequest(
   System.Web.HttpContext^ context
)

Parameters

context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderHttpHandler Class
WebFileUploaderHttpHandler Members


WebFileUploaderHttpHandler Class Properties

[image]
Intersoft WebTextEditor Documentation
WebFileUploaderHttpHandler Class Properties
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebFileUploaderHttpHandler Class

Glossary Item Box

For a list of all members of this type, see WebFileUploaderHttpHandler members.

Public Properties

 | Name | Description
Public Property | IsReusable |
Top

See Also

Reference

WebFileUploaderHttpHandler Class
ISNet.WebUI.WebTextEditor Namespace


IsReusable Property

[image]
Intersoft WebTextEditor Documentation
IsReusable Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderHttpHandler Class : IsReusable Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsReusable As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderHttpHandler
Dim value As System.Boolean

value = instance.IsReusable
C#
public System.bool IsReusable {get;}
Delphi
public read-only property IsReusable: System.Boolean;
JScript
public function get IsReusable : System.boolean
Managed Extensions for C++
public: __property System.bool get_IsReusable();
C++/CLI
public:
property System.bool IsReusable {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderHttpHandler Class
WebFileUploaderHttpHandler Members


WebFileUploaderHttpModule Class

[image]
Intersoft WebTextEditor Documentation
WebFileUploaderHttpModule Class
Members See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebFileUploaderHttpModule Class

Glossary Item Box

Object Model

WebFileUploaderHttpModule Class

Syntax

Visual Basic (Declaration)
Public Class WebFileUploaderHttpModule
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderHttpModule
C#
public class WebFileUploaderHttpModule
Delphi
public class WebFileUploaderHttpModule
JScript
public class WebFileUploaderHttpModule
Managed Extensions for C++
public __gc class WebFileUploaderHttpModule
C++/CLI
public ref class WebFileUploaderHttpModule

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebTextEditor.WebFileUploaderHttpModule

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderHttpModule Members
ISNet.WebUI.WebTextEditor Namespace


WebFileUploaderHttpModule Class Members

[image]
Intersoft WebTextEditor Documentation
WebFileUploaderHttpModule Class Members
See Also Methods Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebFileUploaderHttpModule Class

Glossary Item Box

The following tables list the members exposed by WebFileUploaderHttpModule.

Public Constructors

 | Name | Description
Public Constructor | WebFileUploaderHttpModule Constructor |
Top

Public Methods

 | Name | Description
Public Method | Dispose | You will need to configure this module in the web.config file of your web and register it with IIS before being able to use it. For more information see the following link: http://go.microsoft.com/?linkid=8101007
Public Method | Init |
Top

See Also

Reference

WebFileUploaderHttpModule Class
ISNet.WebUI.WebTextEditor Namespace


WebFileUploaderHttpModule Constructor

[image]
Intersoft WebTextEditor Documentation
WebFileUploaderHttpModule Constructor
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderHttpModule Class : WebFileUploaderHttpModule Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebFileUploaderHttpModule()
C#
public WebFileUploaderHttpModule()
Delphi
public WebFileUploaderHttpModule();
JScript
public function WebFileUploaderHttpModule();
Managed Extensions for C++
public: WebFileUploaderHttpModule();
C++/CLI
public:
WebFileUploaderHttpModule();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderHttpModule Class
WebFileUploaderHttpModule Members


WebFileUploaderHttpModule Class Methods

[image]
Intersoft WebTextEditor Documentation
WebFileUploaderHttpModule Class Methods
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebFileUploaderHttpModule Class

Glossary Item Box

For a list of all members of this type, see WebFileUploaderHttpModule members.

Public Methods

 | Name | Description
Public Method | Dispose | You will need to configure this module in the web.config file of your web and register it with IIS before being able to use it. For more information see the following link: http://go.microsoft.com/?linkid=8101007
Public Method | Init |
Top

See Also

Reference

WebFileUploaderHttpModule Class
ISNet.WebUI.WebTextEditor Namespace


Dispose Method

[image]
Intersoft WebTextEditor Documentation
Dispose Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderHttpModule Class : Dispose Method

Glossary Item Box

You will need to configure this module in the web.config file of your web and register it with IIS before being able to use it. For more information see the following link: http://go.microsoft.com/?linkid=8101007

Syntax

Visual Basic (Declaration)
Public Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderHttpModule

instance.Dispose()
C#
public void Dispose()
Delphi
public procedure Dispose();
JScript
public function Dispose();
Managed Extensions for C++
public: void Dispose();
C++/CLI
public:
void Dispose();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderHttpModule Class
WebFileUploaderHttpModule Members


Init Method

[image]
Intersoft WebTextEditor Documentation
Init Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderHttpModule Class : Init Method

context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Init( _
   ByVal context As System.Web.HttpApplication _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderHttpModule
Dim context As System.Web.HttpApplication

instance.Init(context)
C#
public void Init(
   System.Web.HttpApplication context
)
Delphi
public procedure Init(
    context: System.Web.HttpApplication
);
JScript
public function Init(
   context : System.Web.HttpApplication
);
Managed Extensions for C++
public: void Init(
   System.Web.HttpApplication* context
)
C++/CLI
public:
void Init(
   System.Web.HttpApplication^ context
)

Parameters

context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderHttpModule Class
WebFileUploaderHttpModule Members


WebFileUploaderImageSettings Class

[image]
Intersoft WebTextEditor Documentation
WebFileUploaderImageSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebFileUploaderImageSettings Class

Glossary Item Box

A collection of WebUploader's images settings.

Object Model

WebFileUploaderImageSettings Class

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Class WebFileUploaderImageSettings
   Inherits ISNet.WebUI.Settings
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderImageSettings
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public class WebFileUploaderImageSettings : ISNet.WebUI.Settings, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebFileUploaderImageSettings = class(ISNet.WebUI.Settings, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public class WebFileUploaderImageSettings extends ISNet.WebUI.Settings implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public __gc class WebFileUploaderImageSettings : public ISNet.WebUI.Settings, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public ref class WebFileUploaderImageSettings : public ISNet.WebUI.Settings, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.Settings
ISNet.WebUI.WebTextEditor.WebFileUploaderImageSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderImageSettings Members
ISNet.WebUI.WebTextEditor Namespace


WebFileUploaderImageSettings Class Members

[image]
Intersoft WebTextEditor Documentation
WebFileUploaderImageSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebFileUploaderImageSettings Class

Glossary Item Box

The following tables list the members exposed by WebFileUploaderImageSettings.

Public Constructors

 | Name | Description
Public Constructor | WebFileUploaderImageSettings Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Abort |
Public Property | BgColorButton |
Public Property | Control | (Inherited from ISNet.WebUI.Settings)
Public Property | Delete |
Public Property | Failed |
Public Property | FileName | (Inherited from ISNet.WebUI.Settings)
Public Property | Progress |
Public Property | Required |
Public Property | Success |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | InitSettings | (Inherited from ISNet.WebUI.Settings)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

Protected Methods

 | Name | Description
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | IsInSerializationContext | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebFileUploaderImageSettings Class
ISNet.WebUI.WebTextEditor Namespace


WebFileUploaderImageSettings Constructor

[image]
Intersoft WebTextEditor Documentation
WebFileUploaderImageSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderImageSettings Class : WebFileUploaderImageSettings Constructor

Glossary Item Box

Overload List

Overload | Description
WebFileUploaderImageSettings Constructor() |
WebFileUploaderImageSettings Constructor(SerializationInfo,StreamingContext) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderImageSettings Class
WebFileUploaderImageSettings Members


WebFileUploaderImageSettings Constructor()

[image]
Intersoft WebTextEditor Documentation
WebFileUploaderImageSettings Constructor()
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderImageSettings Class > WebFileUploaderImageSettings Constructor : WebFileUploaderImageSettings Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebFileUploaderImageSettings()
C#
public WebFileUploaderImageSettings()
Delphi
public WebFileUploaderImageSettings();
JScript
public function WebFileUploaderImageSettings();
Managed Extensions for C++
public: WebFileUploaderImageSettings();
C++/CLI
public:
WebFileUploaderImageSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderImageSettings Class
WebFileUploaderImageSettings Members
Overload List


WebFileUploaderImageSettings Constructor(SerializationInfo,StreamingContext)

[image]
Intersoft WebTextEditor Documentation
WebFileUploaderImageSettings Constructor(SerializationInfo,StreamingContext)
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderImageSettings Class > WebFileUploaderImageSettings Constructor : WebFileUploaderImageSettings Constructor(SerializationInfo,StreamingContext)

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

Dim instance As New WebFileUploaderImageSettings(info, context)
C#
protected WebFileUploaderImageSettings(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
protected WebFileUploaderImageSettings(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
protected function WebFileUploaderImageSettings(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
protected: WebFileUploaderImageSettings(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
protected:
WebFileUploaderImageSettings(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderImageSettings Class
WebFileUploaderImageSettings Members
Overload List


WebFileUploaderImageSettings Class Methods

[image]
Intersoft WebTextEditor Documentation
WebFileUploaderImageSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebFileUploaderImageSettings Class

Glossary Item Box

For a list of all members of this type, see WebFileUploaderImageSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | InitSettings | (Inherited from ISNet.WebUI.Settings)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

Protected Methods

 | Name | Description
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | IsInSerializationContext | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebFileUploaderImageSettings Class
ISNet.WebUI.WebTextEditor Namespace


GetObjectData Method

[image]
Intersoft WebTextEditor Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderImageSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderImageSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderImageSettings Class
WebFileUploaderImageSettings Members


WebFileUploaderImageSettings Class Properties

[image]
Intersoft WebTextEditor Documentation
WebFileUploaderImageSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebFileUploaderImageSettings Class

Glossary Item Box

For a list of all members of this type, see WebFileUploaderImageSettings members.

Public Properties

 | Name | Description
Public Property | Abort |
Public Property | BgColorButton |
Public Property | Control | (Inherited from ISNet.WebUI.Settings)
Public Property | Delete |
Public Property | Failed |
Public Property | FileName | (Inherited from ISNet.WebUI.Settings)
Public Property | Progress |
Public Property | Required |
Public Property | Success |
Top

See Also

Reference

WebFileUploaderImageSettings Class
ISNet.WebUI.WebTextEditor Namespace


Abort Property

[image]
Intersoft WebTextEditor Documentation
Abort Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderImageSettings Class : Abort Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property Abort As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderImageSettings
Dim value As System.String

instance.Abort = value

value = instance.Abort
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string Abort {get; set;}
Delphi
public read-write property Abort: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set Abort : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_Abort();
public: __property void set_Abort(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ Abort {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderImageSettings Class
WebFileUploaderImageSettings Members


BgColorButton Property

[image]
Intersoft WebTextEditor Documentation
BgColorButton Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderImageSettings Class : BgColorButton Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property BgColorButton As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderImageSettings
Dim value As System.String

instance.BgColorButton = value

value = instance.BgColorButton
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string BgColorButton {get; set;}
Delphi
public read-write property BgColorButton: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
ISNet.Serialization.BinarySerializableAttribute()
public function get,set BgColorButton : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_BgColorButton();
public: __property void set_BgColorButton(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ BgColorButton {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderImageSettings Class
WebFileUploaderImageSettings Members


Delete Property

[image]
Intersoft WebTextEditor Documentation
Delete Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderImageSettings Class : Delete Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property Delete As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderImageSettings
Dim value As System.String

instance.Delete = value

value = instance.Delete
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string Delete {get; set;}
Delphi
public read-write property Delete: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set Delete : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_Delete();
public: __property void set_Delete(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ Delete {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderImageSettings Class
WebFileUploaderImageSettings Members


Failed Property

[image]
Intersoft WebTextEditor Documentation
Failed Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderImageSettings Class : Failed Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Property Failed As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderImageSettings
Dim value As System.String

instance.Failed = value

value = instance.Failed
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public System.string Failed {get; set;}
Delphi
public read-write property Failed: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set Failed : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property System.string* get_Failed();
public: __property void set_Failed(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
property System.String^ Failed {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderImageSettings Class
WebFileUploaderImageSettings Members


Progress Property

[image]
Intersoft WebTextEditor Documentation
Progress Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderImageSettings Class : Progress Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property Progress As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderImageSettings
Dim value As System.String

instance.Progress = value

value = instance.Progress
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string Progress {get; set;}
Delphi
public read-write property Progress: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
ISNet.Serialization.BinarySerializableAttribute()
public function get,set Progress : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_Progress();
public: __property void set_Progress(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ Progress {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderImageSettings Class
WebFileUploaderImageSettings Members


Required Property

[image]
Intersoft WebTextEditor Documentation
Required Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderImageSettings Class : Required Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property Required As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderImageSettings
Dim value As System.String

instance.Required = value

value = instance.Required
C#
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string Required {get; set;}
Delphi
public read-write property Required: System.String;
JScript
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set Required : System.String
Managed Extensions for C++
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_Required();
public: __property void set_Required(
   System.string* value
);
C++/CLI
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ Required {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderImageSettings Class
WebFileUploaderImageSettings Members


Success Property

[image]
Intersoft WebTextEditor Documentation
Success Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderImageSettings Class : Success Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property Success As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderImageSettings
Dim value As System.String

instance.Success = value

value = instance.Success
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string Success {get; set;}
Delphi
public read-write property Success: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
ISNet.Serialization.BinarySerializableAttribute()
public function get,set Success : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_Success();
public: __property void set_Success(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ Success {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderImageSettings Class
WebFileUploaderImageSettings Members


WebFileUploaderInfo Class

[image]
Intersoft WebTextEditor Documentation
WebFileUploaderInfo Class
Members See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebFileUploaderInfo Class

Glossary Item Box

Object Model

WebFileUploaderInfo Class

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.SerializableAttribute()>
Public Class WebFileUploaderInfo
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderInfo
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.SerializableAttribute()]
public class WebFileUploaderInfo : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebFileUploaderInfo = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.SerializableAttribute()
public class WebFileUploaderInfo extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.SerializableAttribute()]
public __gc class WebFileUploaderInfo : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.SerializableAttribute()]
public ref class WebFileUploaderInfo : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebTextEditor.WebFileUploaderInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderInfo Members
ISNet.WebUI.WebTextEditor Namespace


WebFileUploaderInfo Class Members

[image]
Intersoft WebTextEditor Documentation
WebFileUploaderInfo Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebFileUploaderInfo Class

Glossary Item Box

The following tables list the members exposed by WebFileUploaderInfo.

Public Constructors

 | Name | Description
Public Constructor | WebFileUploaderInfo Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | CacheDuration | The cache duration in minutess
Public Property | CacheIdentifier |
Public Property | CachePriority |
Public Property | ContextStorage |
Public Property | ContextStorageFileServer |
Public Property | Error |
Public Property | ErrorMessage |
Public Property | ErrorStackTrace |
Public Property | Files |
Public Property | GUID |
Public Property | IsServerEventsHandled |
Public Property | OwnerControl |
Public Property | OwnerControlUnique |
Public Property | OwnerPage |
Public Property | Path |
Public Property | TotalUploadSizeLimit |
Public Property | UploadSizeLimit |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | UpdateContextState |
Top

Protected Methods

 | Name | Description
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | IsInSerializationContext | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebFileUploaderInfo Class
ISNet.WebUI.WebTextEditor Namespace


WebFileUploaderInfo Constructor

[image]
Intersoft WebTextEditor Documentation
WebFileUploaderInfo Constructor
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderInfo Class : WebFileUploaderInfo Constructor

Glossary Item Box

Overload List

Overload | Description
WebFileUploaderInfo Constructor() |
WebFileUploaderInfo Constructor(SerializationInfo,StreamingContext) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderInfo Class
WebFileUploaderInfo Members


WebFileUploaderInfo Constructor()

[image]
Intersoft WebTextEditor Documentation
WebFileUploaderInfo Constructor()
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderInfo Class > WebFileUploaderInfo Constructor : WebFileUploaderInfo Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebFileUploaderInfo()
C#
public WebFileUploaderInfo()
Delphi
public WebFileUploaderInfo();
JScript
public function WebFileUploaderInfo();
Managed Extensions for C++
public: WebFileUploaderInfo();
C++/CLI
public:
WebFileUploaderInfo();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderInfo Class
WebFileUploaderInfo Members
Overload List


WebFileUploaderInfo Constructor(SerializationInfo,StreamingContext)

[image]
Intersoft WebTextEditor Documentation
WebFileUploaderInfo Constructor(SerializationInfo,StreamingContext)
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderInfo Class > WebFileUploaderInfo Constructor : WebFileUploaderInfo Constructor(SerializationInfo,StreamingContext)

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

Dim instance As New WebFileUploaderInfo(info, context)
C#
protected WebFileUploaderInfo(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
protected WebFileUploaderInfo(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
protected function WebFileUploaderInfo(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
protected: WebFileUploaderInfo(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
protected:
WebFileUploaderInfo(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderInfo Class
WebFileUploaderInfo Members
Overload List


WebFileUploaderInfo Class Methods

[image]
Intersoft WebTextEditor Documentation
WebFileUploaderInfo Class Methods
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebFileUploaderInfo Class

Glossary Item Box

For a list of all members of this type, see WebFileUploaderInfo members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | UpdateContextState |
Top

Protected Methods

 | Name | Description
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | IsInSerializationContext | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebFileUploaderInfo Class
ISNet.WebUI.WebTextEditor Namespace


GetObjectData Method

[image]
Intersoft WebTextEditor Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderInfo Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderInfo
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderInfo Class
WebFileUploaderInfo Members


UpdateContextState Method

[image]
Intersoft WebTextEditor Documentation
UpdateContextState Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderInfo Class : UpdateContextState Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub UpdateContextState()
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderInfo

instance.UpdateContextState()
C#
public void UpdateContextState()
Delphi
public procedure UpdateContextState();
JScript
public function UpdateContextState();
Managed Extensions for C++
public: void UpdateContextState();
C++/CLI
public:
void UpdateContextState();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderInfo Class
WebFileUploaderInfo Members


WebFileUploaderInfo Class Properties

[image]
Intersoft WebTextEditor Documentation
WebFileUploaderInfo Class Properties
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebFileUploaderInfo Class

Glossary Item Box

For a list of all members of this type, see WebFileUploaderInfo members.

Public Properties

 | Name | Description
Public Property | CacheDuration | The cache duration in minutess
Public Property | CacheIdentifier |
Public Property | CachePriority |
Public Property | ContextStorage |
Public Property | ContextStorageFileServer |
Public Property | Error |
Public Property | ErrorMessage |
Public Property | ErrorStackTrace |
Public Property | Files |
Public Property | GUID |
Public Property | IsServerEventsHandled |
Public Property | OwnerControl |
Public Property | OwnerControlUnique |
Public Property | OwnerPage |
Public Property | Path |
Public Property | TotalUploadSizeLimit |
Public Property | UploadSizeLimit |
Top

See Also

Reference

WebFileUploaderInfo Class
ISNet.WebUI.WebTextEditor Namespace


CacheDuration Property

[image]
Intersoft WebTextEditor Documentation
CacheDuration Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderInfo Class : CacheDuration Property

Glossary Item Box

The cache duration in minutess

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property CacheDuration As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderInfo
Dim value As System.Integer

instance.CacheDuration = value

value = instance.CacheDuration
C#
[ISNet.Serialization.BinarySerializableAttribute()]
public System.int CacheDuration {get; set;}
Delphi
public read-write property CacheDuration: System.Integer;
JScript
ISNet.Serialization.BinarySerializableAttribute()
public function get,set CacheDuration : System.int
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.int get_CacheDuration();
public: __property void set_CacheDuration(
   System.int value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.int CacheDuration {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderInfo Class
WebFileUploaderInfo Members


CacheIdentifier Property

[image]
Intersoft WebTextEditor Documentation
CacheIdentifier Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderInfo Class : CacheIdentifier Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CacheIdentifier As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderInfo
Dim value As System.String

value = instance.CacheIdentifier
C#
public System.string CacheIdentifier {get;}
Delphi
public read-only property CacheIdentifier: System.String;
JScript
public function get CacheIdentifier : System.String
Managed Extensions for C++
public: __property System.string* get_CacheIdentifier();
C++/CLI
public:
property System.String^ CacheIdentifier {
   System.String^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderInfo Class
WebFileUploaderInfo Members


CachePriority Property

[image]
Intersoft WebTextEditor Documentation
CachePriority Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderInfo Class : CachePriority Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property CachePriority As System.Web.Caching.CacheItemPriority
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderInfo
Dim value As System.Web.Caching.CacheItemPriority

instance.CachePriority = value

value = instance.CachePriority
C#
[ISNet.Serialization.BinarySerializableAttribute()]
public System.Web.Caching.CacheItemPriority CachePriority {get; set;}
Delphi
public read-write property CachePriority: System.Web.Caching.CacheItemPriority;
JScript
ISNet.Serialization.BinarySerializableAttribute()
public function get,set CachePriority : System.Web.Caching.CacheItemPriority
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.Web.Caching.CacheItemPriority get_CachePriority();
public: __property void set_CachePriority(
   System.Web.Caching.CacheItemPriority value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.Web.Caching.CacheItemPriority CachePriority {
   System.Web.Caching.CacheItemPriority get();
   void set (    System.Web.Caching.CacheItemPriority value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderInfo Class
WebFileUploaderInfo Members


ContextStorage Property

[image]
Intersoft WebTextEditor Documentation
ContextStorage Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderInfo Class : ContextStorage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property ContextStorage As ISNet.WebUI.CacheStorage
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderInfo
Dim value As ISNet.WebUI.CacheStorage

instance.ContextStorage = value

value = instance.ContextStorage
C#
[ISNet.Serialization.BinarySerializableAttribute()]
public ISNet.WebUI.CacheStorage ContextStorage {get; set;}
Delphi
public read-write property ContextStorage: ISNet.WebUI.CacheStorage;
JScript
ISNet.Serialization.BinarySerializableAttribute()
public function get,set ContextStorage : ISNet.WebUI.CacheStorage
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property ISNet.WebUI.CacheStorage get_ContextStorage();
public: __property void set_ContextStorage(
   ISNet.WebUI.CacheStorage value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property ISNet.WebUI.CacheStorage ContextStorage {
   ISNet.WebUI.CacheStorage get();
   void set (    ISNet.WebUI.CacheStorage value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderInfo Class
WebFileUploaderInfo Members


ContextStorageFileServer Property

[image]
Intersoft WebTextEditor Documentation
ContextStorageFileServer Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderInfo Class : ContextStorageFileServer Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property ContextStorageFileServer As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderInfo
Dim value As System.String

instance.ContextStorageFileServer = value

value = instance.ContextStorageFileServer
C#
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string ContextStorageFileServer {get; set;}
Delphi
public read-write property ContextStorageFileServer: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
public function get,set ContextStorageFileServer : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_ContextStorageFileServer();
public: __property void set_ContextStorageFileServer(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ ContextStorageFileServer {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderInfo Class
WebFileUploaderInfo Members


Error Property

[image]
Intersoft WebTextEditor Documentation
Error Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderInfo Class : Error Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute("SetError")>
Public Property Error As System.Exception
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderInfo
Dim value As System.Exception

instance.Error = value

value = instance.Error
C#
[ISNet.Serialization.BinarySerializableAttribute("SetError")]
public System.Exception Error {get; set;}
Delphi
public read-write property Error: System.Exception;
JScript
ISNet.Serialization.BinarySerializableAttribute("SetError")
public function get,set Error : System.Exception
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute("SetError")]
public: __property System.Exception* get_Error();
public: __property void set_Error(
   System.Exception* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute("SetError")]
public:
property System.Exception^ Error {
   System.Exception^ get();
   void set (    System.Exception^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderInfo Class
WebFileUploaderInfo Members


ErrorMessage Property

[image]
Intersoft WebTextEditor Documentation
ErrorMessage Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderInfo Class : ErrorMessage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public ReadOnly Property ErrorMessage As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderInfo
Dim value As System.String

value = instance.ErrorMessage
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string ErrorMessage {get;}
Delphi
public read-only property ErrorMessage: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get ErrorMessage : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_ErrorMessage();
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ ErrorMessage {
   System.String^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderInfo Class
WebFileUploaderInfo Members


ErrorStackTrace Property

[image]
Intersoft WebTextEditor Documentation
ErrorStackTrace Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderInfo Class : ErrorStackTrace Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public ReadOnly Property ErrorStackTrace As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderInfo
Dim value As System.String

value = instance.ErrorStackTrace
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string ErrorStackTrace {get;}
Delphi
public read-only property ErrorStackTrace: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get ErrorStackTrace : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_ErrorStackTrace();
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ ErrorStackTrace {
   System.String^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderInfo Class
WebFileUploaderInfo Members


Files Property

[image]
Intersoft WebTextEditor Documentation
Files Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderInfo Class : Files Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute("SetFiles")>
Public ReadOnly Property Files As SerializableList(Of WebFileUploaderFileInfo)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderInfo
Dim value As SerializableList(Of WebFileUploaderFileInfo)

value = instance.Files
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("SetFiles")]
public SerializableList<WebFileUploaderFileInfo> Files {get;}
Delphi
public read-only property Files: SerializableList;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute("SetFiles")
public function get Files : SerializableList
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("SetFiles")]
public: __property SerializableList<WebFileUploaderFileInfo*>* get_Files();
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("SetFiles")]
public:
property SerializableList<WebFileUploaderFileInfo^>^ Files {
   SerializableList<WebFileUploaderFileInfo^>^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderInfo Class
WebFileUploaderInfo Members


GUID Property

[image]
Intersoft WebTextEditor Documentation
GUID Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderInfo Class : GUID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute("SetGUID")>
Public ReadOnly Property GUID As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderInfo
Dim value As System.String

value = instance.GUID
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("SetGUID")]
public System.string GUID {get;}
Delphi
public read-only property GUID: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute("SetGUID")
public function get GUID : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("SetGUID")]
public: __property System.string* get_GUID();
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute("SetGUID")]
public:
property System.String^ GUID {
   System.String^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderInfo Class
WebFileUploaderInfo Members


IsServerEventsHandled Property

[image]
Intersoft WebTextEditor Documentation
IsServerEventsHandled Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderInfo Class : IsServerEventsHandled Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property IsServerEventsHandled As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderInfo
Dim value As System.Boolean

instance.IsServerEventsHandled = value

value = instance.IsServerEventsHandled
C#
[ISNet.Serialization.BinarySerializableAttribute()]
public System.bool IsServerEventsHandled {get; set;}
Delphi
public read-write property IsServerEventsHandled: System.Boolean;
JScript
ISNet.Serialization.BinarySerializableAttribute()
public function get,set IsServerEventsHandled : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.bool get_IsServerEventsHandled();
public: __property void set_IsServerEventsHandled(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.bool IsServerEventsHandled {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderInfo Class
WebFileUploaderInfo Members


OwnerControl Property

[image]
Intersoft WebTextEditor Documentation
OwnerControl Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderInfo Class : OwnerControl Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute("SetOwnerControl")>
Public ReadOnly Property OwnerControl As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderInfo
Dim value As System.String

value = instance.OwnerControl
C#
[ISNet.Serialization.BinarySerializableAttribute("SetOwnerControl")]
public System.string OwnerControl {get;}
Delphi
public read-only property OwnerControl: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute("SetOwnerControl")
public function get OwnerControl : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute("SetOwnerControl")]
public: __property System.string* get_OwnerControl();
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute("SetOwnerControl")]
public:
property System.String^ OwnerControl {
   System.String^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderInfo Class
WebFileUploaderInfo Members


OwnerControlUnique Property

[image]
Intersoft WebTextEditor Documentation
OwnerControlUnique Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderInfo Class : OwnerControlUnique Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute("SetOwnerControlUnique")>
Public ReadOnly Property OwnerControlUnique As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderInfo
Dim value As System.String

value = instance.OwnerControlUnique
C#
[ISNet.Serialization.BinarySerializableAttribute("SetOwnerControlUnique")]
public System.string OwnerControlUnique {get;}
Delphi
public read-only property OwnerControlUnique: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute("SetOwnerControlUnique")
public function get OwnerControlUnique : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute("SetOwnerControlUnique")]
public: __property System.string* get_OwnerControlUnique();
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute("SetOwnerControlUnique")]
public:
property System.String^ OwnerControlUnique {
   System.String^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderInfo Class
WebFileUploaderInfo Members


OwnerPage Property

[image]
Intersoft WebTextEditor Documentation
OwnerPage Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderInfo Class : OwnerPage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute("SetOwnerPage")>
Public ReadOnly Property OwnerPage As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderInfo
Dim value As System.String

value = instance.OwnerPage
C#
[ISNet.Serialization.BinarySerializableAttribute("SetOwnerPage")]
public System.string OwnerPage {get;}
Delphi
public read-only property OwnerPage: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute("SetOwnerPage")
public function get OwnerPage : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute("SetOwnerPage")]
public: __property System.string* get_OwnerPage();
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute("SetOwnerPage")]
public:
property System.String^ OwnerPage {
   System.String^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderInfo Class
WebFileUploaderInfo Members


Path Property

[image]
Intersoft WebTextEditor Documentation
Path Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderInfo Class : Path Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute("SetPath")>
Public ReadOnly Property Path As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderInfo
Dim value As System.String

value = instance.Path
C#
[ISNet.Serialization.BinarySerializableAttribute("SetPath")]
public System.string Path {get;}
Delphi
public read-only property Path: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute("SetPath")
public function get Path : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute("SetPath")]
public: __property System.string* get_Path();
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute("SetPath")]
public:
property System.String^ Path {
   System.String^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderInfo Class
WebFileUploaderInfo Members


TotalUploadSizeLimit Property

[image]
Intersoft WebTextEditor Documentation
TotalUploadSizeLimit Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderInfo Class : TotalUploadSizeLimit Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute("SetTotalUploadSizeLimit")>
Public ReadOnly Property TotalUploadSizeLimit As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderInfo
Dim value As System.Integer

value = instance.TotalUploadSizeLimit
C#
[ISNet.Serialization.BinarySerializableAttribute("SetTotalUploadSizeLimit")]
public System.int TotalUploadSizeLimit {get;}
Delphi
public read-only property TotalUploadSizeLimit: System.Integer;
JScript
ISNet.Serialization.BinarySerializableAttribute("SetTotalUploadSizeLimit")
public function get TotalUploadSizeLimit : System.int
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute("SetTotalUploadSizeLimit")]
public: __property System.int get_TotalUploadSizeLimit();
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute("SetTotalUploadSizeLimit")]
public:
property System.int TotalUploadSizeLimit {
   System.int get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderInfo Class
WebFileUploaderInfo Members


UploadSizeLimit Property

[image]
Intersoft WebTextEditor Documentation
UploadSizeLimit Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderInfo Class : UploadSizeLimit Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute("SetUploadSizeLimit")>
Public ReadOnly Property UploadSizeLimit As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderInfo
Dim value As System.Integer

value = instance.UploadSizeLimit
C#
[ISNet.Serialization.BinarySerializableAttribute("SetUploadSizeLimit")]
public System.int UploadSizeLimit {get;}
Delphi
public read-only property UploadSizeLimit: System.Integer;
JScript
ISNet.Serialization.BinarySerializableAttribute("SetUploadSizeLimit")
public function get UploadSizeLimit : System.int
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute("SetUploadSizeLimit")]
public: __property System.int get_UploadSizeLimit();
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute("SetUploadSizeLimit")]
public:
property System.int UploadSizeLimit {
   System.int get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderInfo Class
WebFileUploaderInfo Members


WebFileUploaderProgressInformation Class

[image]
Intersoft WebTextEditor Documentation
WebFileUploaderProgressInformation Class
Members See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebFileUploaderProgressInformation Class

Glossary Item Box

A collection of members in WebUploader's progress information.

Object Model

WebFileUploaderProgressInformation Class

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Class WebFileUploaderProgressInformation
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderProgressInformation
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public class WebFileUploaderProgressInformation : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebFileUploaderProgressInformation = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public class WebFileUploaderProgressInformation extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public __gc class WebFileUploaderProgressInformation : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public ref class WebFileUploaderProgressInformation : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebTextEditor.WebFileUploaderProgressInformation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderProgressInformation Members
ISNet.WebUI.WebTextEditor Namespace


WebFileUploaderProgressInformation Class Members

[image]
Intersoft WebTextEditor Documentation
WebFileUploaderProgressInformation Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebFileUploaderProgressInformation Class

Glossary Item Box

The following tables list the members exposed by WebFileUploaderProgressInformation.

Public Constructors

 | Name | Description
Public Constructor | WebFileUploaderProgressInformation Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | ProgressInformationType | Specifies ProgressBar file type of WebUploader.
Public Property | ProgressInformationTypeForTotal | Specifies ProgressInformation type of WebUploader.
Public Property | ShowProgressArea | Determines whether show progress area is true or not.
Public Property | ShowProgressBar | Determines whether show progress bar is true or not.
Public Property | ShowProgressBarForTotal | Determines whether show progress bar for total is true or not.
Public Property | SpecificProgressBarFileTypes | Specifies ProgressBar file types of WebUploader.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

Protected Methods

 | Name | Description
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | IsInSerializationContext | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebFileUploaderProgressInformation Class
ISNet.WebUI.WebTextEditor Namespace


WebFileUploaderProgressInformation Constructor

[image]
Intersoft WebTextEditor Documentation
WebFileUploaderProgressInformation Constructor
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderProgressInformation Class : WebFileUploaderProgressInformation Constructor

Glossary Item Box

Overload List

Overload | Description
WebFileUploaderProgressInformation Constructor() |
WebFileUploaderProgressInformation Constructor(SerializationInfo,StreamingContext) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderProgressInformation Class
WebFileUploaderProgressInformation Members


WebFileUploaderProgressInformation Constructor()

[image]
Intersoft WebTextEditor Documentation
WebFileUploaderProgressInformation Constructor()
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderProgressInformation Class > WebFileUploaderProgressInformation Constructor : WebFileUploaderProgressInformation Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebFileUploaderProgressInformation()
C#
public WebFileUploaderProgressInformation()
Delphi
public WebFileUploaderProgressInformation();
JScript
public function WebFileUploaderProgressInformation();
Managed Extensions for C++
public: WebFileUploaderProgressInformation();
C++/CLI
public:
WebFileUploaderProgressInformation();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderProgressInformation Class
WebFileUploaderProgressInformation Members
Overload List


WebFileUploaderProgressInformation Constructor(SerializationInfo,StreamingContext)

[image]
Intersoft WebTextEditor Documentation
WebFileUploaderProgressInformation Constructor(SerializationInfo,StreamingContext)
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderProgressInformation Class > WebFileUploaderProgressInformation Constructor : WebFileUploaderProgressInformation Constructor(SerializationInfo,StreamingContext)

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

Dim instance As New WebFileUploaderProgressInformation(info, context)
C#
protected WebFileUploaderProgressInformation(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
protected WebFileUploaderProgressInformation(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
protected function WebFileUploaderProgressInformation(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
protected: WebFileUploaderProgressInformation(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
protected:
WebFileUploaderProgressInformation(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderProgressInformation Class
WebFileUploaderProgressInformation Members
Overload List


WebFileUploaderProgressInformation Class Methods

[image]
Intersoft WebTextEditor Documentation
WebFileUploaderProgressInformation Class Methods
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebFileUploaderProgressInformation Class

Glossary Item Box

For a list of all members of this type, see WebFileUploaderProgressInformation members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

Protected Methods

 | Name | Description
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | IsInSerializationContext | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebFileUploaderProgressInformation Class
ISNet.WebUI.WebTextEditor Namespace


GetObjectData Method

[image]
Intersoft WebTextEditor Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderProgressInformation Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderProgressInformation
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderProgressInformation Class
WebFileUploaderProgressInformation Members


WebFileUploaderProgressInformation Class Properties

[image]
Intersoft WebTextEditor Documentation
WebFileUploaderProgressInformation Class Properties
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebFileUploaderProgressInformation Class

Glossary Item Box

For a list of all members of this type, see WebFileUploaderProgressInformation members.

Public Properties

 | Name | Description
Public Property | ProgressInformationType | Specifies ProgressBar file type of WebUploader.
Public Property | ProgressInformationTypeForTotal | Specifies ProgressInformation type of WebUploader.
Public Property | ShowProgressArea | Determines whether show progress area is true or not.
Public Property | ShowProgressBar | Determines whether show progress bar is true or not.
Public Property | ShowProgressBarForTotal | Determines whether show progress bar for total is true or not.
Public Property | SpecificProgressBarFileTypes | Specifies ProgressBar file types of WebUploader.
Top

See Also

Reference

WebFileUploaderProgressInformation Class
ISNet.WebUI.WebTextEditor Namespace


ProgressInformationType Property

[image]
Intersoft WebTextEditor Documentation
ProgressInformationType Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderProgressInformation Class : ProgressInformationType Property

Glossary Item Box

Specifies ProgressBar file type of WebUploader.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Property ProgressInformationType As ProgressInformationType
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderProgressInformation
Dim value As ProgressInformationType

instance.ProgressInformationType = value

value = instance.ProgressInformationType
C#
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public ProgressInformationType ProgressInformationType {get; set;}
Delphi
public read-write property ProgressInformationType: ProgressInformationType;
JScript
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set ProgressInformationType : ProgressInformationType
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property ProgressInformationType get_ProgressInformationType();
public: __property void set_ProgressInformationType(
   ProgressInformationType value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
property ProgressInformationType ProgressInformationType {
   ProgressInformationType get();
   void set (    ProgressInformationType value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderProgressInformation Class
WebFileUploaderProgressInformation Members


ProgressInformationTypeForTotal Property

[image]
Intersoft WebTextEditor Documentation
ProgressInformationTypeForTotal Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderProgressInformation Class : ProgressInformationTypeForTotal Property

Glossary Item Box

Specifies ProgressInformation type of WebUploader.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property ProgressInformationTypeForTotal As ProgressInformationType
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderProgressInformation
Dim value As ProgressInformationType

instance.ProgressInformationTypeForTotal = value

value = instance.ProgressInformationTypeForTotal
C#
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public ProgressInformationType ProgressInformationTypeForTotal {get; set;}
Delphi
public read-write property ProgressInformationTypeForTotal: ProgressInformationType;
JScript
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set ProgressInformationTypeForTotal : ProgressInformationType
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property ProgressInformationType get_ProgressInformationTypeForTotal();
public: __property void set_ProgressInformationTypeForTotal(
   ProgressInformationType value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property ProgressInformationType ProgressInformationTypeForTotal {
   ProgressInformationType get();
   void set (    ProgressInformationType value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderProgressInformation Class
WebFileUploaderProgressInformation Members


ShowProgressArea Property

[image]
Intersoft WebTextEditor Documentation
ShowProgressArea Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderProgressInformation Class : ShowProgressArea Property

Glossary Item Box

Determines whether show progress area is true or not.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Determines whether show progress area is true or not.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property ShowProgressArea As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderProgressInformation
Dim value As System.Boolean

instance.ShowProgressArea = value

value = instance.ShowProgressArea
C#
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether show progress area is true or not.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.bool ShowProgressArea {get; set;}
Delphi
public read-write property ShowProgressArea: System.Boolean;
JScript
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Determines whether show progress area is true or not.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set ShowProgressArea : System.boolean
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether show progress area is true or not.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.bool get_ShowProgressArea();
public: __property void set_ShowProgressArea(
   System.bool value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether show progress area is true or not.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.bool ShowProgressArea {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderProgressInformation Class
WebFileUploaderProgressInformation Members


ShowProgressBar Property

[image]
Intersoft WebTextEditor Documentation
ShowProgressBar Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderProgressInformation Class : ShowProgressBar Property

Glossary Item Box

Determines whether show progress bar is true or not.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Determines whether show progress bar is true or not.")>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property ShowProgressBar As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderProgressInformation
Dim value As System.Boolean

instance.ShowProgressBar = value

value = instance.ShowProgressBar
C#
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Determines whether show progress bar is true or not.")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.bool ShowProgressBar {get; set;}
Delphi
public read-write property ShowProgressBar: System.Boolean;
JScript
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Determines whether show progress bar is true or not.")
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set ShowProgressBar : System.boolean
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Determines whether show progress bar is true or not.")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.bool get_ShowProgressBar();
public: __property void set_ShowProgressBar(
   System.bool value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Determines whether show progress bar is true or not.")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.bool ShowProgressBar {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderProgressInformation Class
WebFileUploaderProgressInformation Members


ShowProgressBarForTotal Property

[image]
Intersoft WebTextEditor Documentation
ShowProgressBarForTotal Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderProgressInformation Class : ShowProgressBarForTotal Property

Glossary Item Box

Determines whether show progress bar for total is true or not.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Determines whether show progress bar for total is true or not.")>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.CategoryAttribute("Appearance")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property ShowProgressBarForTotal As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderProgressInformation
Dim value As System.Boolean

instance.ShowProgressBarForTotal = value

value = instance.ShowProgressBarForTotal
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Determines whether show progress bar for total is true or not.")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.bool ShowProgressBarForTotal {get; set;}
Delphi
public read-write property ShowProgressBarForTotal: System.Boolean;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Determines whether show progress bar for total is true or not.")
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.CategoryAttribute("Appearance")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set ShowProgressBarForTotal : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Determines whether show progress bar for total is true or not.")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.bool get_ShowProgressBarForTotal();
public: __property void set_ShowProgressBarForTotal(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Determines whether show progress bar for total is true or not.")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.bool ShowProgressBarForTotal {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderProgressInformation Class
WebFileUploaderProgressInformation Members


SpecificProgressBarFileTypes Property

[image]
Intersoft WebTextEditor Documentation
SpecificProgressBarFileTypes Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderProgressInformation Class : SpecificProgressBarFileTypes Property

Glossary Item Box

Specifies ProgressBar file types of WebUploader.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.DescriptionAttribute("Specifies ProgressBar file types.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Property SpecificProgressBarFileTypes As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderProgressInformation
Dim value As System.String

instance.SpecificProgressBarFileTypes = value

value = instance.SpecificProgressBarFileTypes
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute("Specifies ProgressBar file types.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public System.string SpecificProgressBarFileTypes {get; set;}
Delphi
public read-write property SpecificProgressBarFileTypes: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.DescriptionAttribute("Specifies ProgressBar file types.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set SpecificProgressBarFileTypes : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute("Specifies ProgressBar file types.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property System.string* get_SpecificProgressBarFileTypes();
public: __property void set_SpecificProgressBarFileTypes(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute("Specifies ProgressBar file types.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
property System.String^ SpecificProgressBarFileTypes {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderProgressInformation Class
WebFileUploaderProgressInformation Members


WebFileUploaderStyleSettings Class

[image]
Intersoft WebTextEditor Documentation
WebFileUploaderStyleSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebFileUploaderStyleSettings Class

Glossary Item Box

A collection of members in WebUploader's style settings.

Object Model

WebFileUploaderStyleSettings Class

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Class WebFileUploaderStyleSettings
   Inherits ISNet.WebUI.Settings
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderStyleSettings
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public class WebFileUploaderStyleSettings : ISNet.WebUI.Settings, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebFileUploaderStyleSettings = class(ISNet.WebUI.Settings, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public class WebFileUploaderStyleSettings extends ISNet.WebUI.Settings implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public __gc class WebFileUploaderStyleSettings : public ISNet.WebUI.Settings, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public ref class WebFileUploaderStyleSettings : public ISNet.WebUI.Settings, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.Settings
ISNet.WebUI.WebTextEditor.WebFileUploaderStyleSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderStyleSettings Members
ISNet.WebUI.WebTextEditor Namespace


WebFileUploaderStyleSettings Class Members

[image]
Intersoft WebTextEditor Documentation
WebFileUploaderStyleSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebFileUploaderStyleSettings Class

Glossary Item Box

The following tables list the members exposed by WebFileUploaderStyleSettings.

Public Constructors

 | Name | Description
Public Constructor | WebFileUploaderStyleSettings Constructor |
Top

Public Properties

 | Name | Description
Public Property | AttachmentFileCancelledStyle |
Public Property | AttachmentFileErrorStyle |
Public Property | AttachmentFileSelectedStyle |
Public Property | AttachmentFileStyle |
Public Property | AttachmentFileUploadedStyle |
Public Property | AttachmentFileUploadingStyle |
Public Property | ButtonStyle |
Public Property | CaptionStyle |
Public Property | Control | (Inherited from ISNet.WebUI.Settings)
Public Property | Directory | Overridden. Gets or sets directory for current settings.
Public Property | FileName | (Inherited from ISNet.WebUI.Settings)
Public Property | FileUploadContainerForAttachmentBarStyle |
Public Property | FileUploadContainerStyle |
Public Property | FrameStyle |
Public Property | MessageStyle |
Public Property | ProgressBarFrameStyle |
Public Property | ProgressBarInformationTextStyle |
Public Property | ProgressBarStatusTextStyle |
Public Property | ProgressBarStyle |
Public Property | TextBoxStyle |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | (Inherited from ISNet.WebUI.Settings)
Public Method | InitializeDefaultStyles |
Public Method | InitSettings | (Inherited from ISNet.WebUI.Settings)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

Protected Methods

 | Name | Description
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | IsInSerializationContext | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebFileUploaderStyleSettings Class
ISNet.WebUI.WebTextEditor Namespace


WebFileUploaderStyleSettings Constructor

[image]
Intersoft WebTextEditor Documentation
WebFileUploaderStyleSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderStyleSettings Class : WebFileUploaderStyleSettings Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebFileUploaderStyleSettings()
C#
public WebFileUploaderStyleSettings()
Delphi
public WebFileUploaderStyleSettings();
JScript
public function WebFileUploaderStyleSettings();
Managed Extensions for C++
public: WebFileUploaderStyleSettings();
C++/CLI
public:
WebFileUploaderStyleSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderStyleSettings Class
WebFileUploaderStyleSettings Members


WebFileUploaderStyleSettings Class Methods

[image]
Intersoft WebTextEditor Documentation
WebFileUploaderStyleSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebFileUploaderStyleSettings Class

Glossary Item Box

For a list of all members of this type, see WebFileUploaderStyleSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | (Inherited from ISNet.WebUI.Settings)
Public Method | InitializeDefaultStyles |
Public Method | InitSettings | (Inherited from ISNet.WebUI.Settings)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

Protected Methods

 | Name | Description
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | IsInSerializationContext | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebFileUploaderStyleSettings Class
ISNet.WebUI.WebTextEditor Namespace


InitializeDefaultStyles Method

[image]
Intersoft WebTextEditor Documentation
InitializeDefaultStyles Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderStyleSettings Class : InitializeDefaultStyles Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub InitializeDefaultStyles()
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderStyleSettings

instance.InitializeDefaultStyles()
C#
public void InitializeDefaultStyles()
Delphi
public procedure InitializeDefaultStyles();
JScript
public function InitializeDefaultStyles();
Managed Extensions for C++
public: void InitializeDefaultStyles();
C++/CLI
public:
void InitializeDefaultStyles();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderStyleSettings Class
WebFileUploaderStyleSettings Members


WebFileUploaderStyleSettings Class Properties

[image]
Intersoft WebTextEditor Documentation
WebFileUploaderStyleSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebFileUploaderStyleSettings Class

Glossary Item Box

For a list of all members of this type, see WebFileUploaderStyleSettings members.

Public Properties

 | Name | Description
Public Property | AttachmentFileCancelledStyle |
Public Property | AttachmentFileErrorStyle |
Public Property | AttachmentFileSelectedStyle |
Public Property | AttachmentFileStyle |
Public Property | AttachmentFileUploadedStyle |
Public Property | AttachmentFileUploadingStyle |
Public Property | ButtonStyle |
Public Property | CaptionStyle |
Public Property | Control | (Inherited from ISNet.WebUI.Settings)
Public Property | Directory | Overridden. Gets or sets directory for current settings.
Public Property | FileName | (Inherited from ISNet.WebUI.Settings)
Public Property | FileUploadContainerForAttachmentBarStyle |
Public Property | FileUploadContainerStyle |
Public Property | FrameStyle |
Public Property | MessageStyle |
Public Property | ProgressBarFrameStyle |
Public Property | ProgressBarInformationTextStyle |
Public Property | ProgressBarStatusTextStyle |
Public Property | ProgressBarStyle |
Public Property | TextBoxStyle |
Top

See Also

Reference

WebFileUploaderStyleSettings Class
ISNet.WebUI.WebTextEditor Namespace


AttachmentFileCancelledStyle Property

[image]
Intersoft WebTextEditor Documentation
AttachmentFileCancelledStyle Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderStyleSettings Class : AttachmentFileCancelledStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property AttachmentFileCancelledStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderStyleSettings
Dim value As ISNet.WebUI.WebStyle

instance.AttachmentFileCancelledStyle = value

value = instance.AttachmentFileCancelledStyle
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public ISNet.WebUI.WebStyle AttachmentFileCancelledStyle {get; set;}
Delphi
public read-write property AttachmentFileCancelledStyle: ISNet.WebUI.WebStyle;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set AttachmentFileCancelledStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property ISNet.WebUI.WebStyle* get_AttachmentFileCancelledStyle();
public: __property void set_AttachmentFileCancelledStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property ISNet.WebUI.WebStyle^ AttachmentFileCancelledStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderStyleSettings Class
WebFileUploaderStyleSettings Members


AttachmentFileErrorStyle Property

[image]
Intersoft WebTextEditor Documentation
AttachmentFileErrorStyle Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderStyleSettings Class : AttachmentFileErrorStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.CategoryAttribute("Appearance")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property AttachmentFileErrorStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderStyleSettings
Dim value As ISNet.WebUI.WebStyle

instance.AttachmentFileErrorStyle = value

value = instance.AttachmentFileErrorStyle
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
public ISNet.WebUI.WebStyle AttachmentFileErrorStyle {get; set;}
Delphi
public read-write property AttachmentFileErrorStyle: ISNet.WebUI.WebStyle;
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.CategoryAttribute("Appearance")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set AttachmentFileErrorStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property ISNet.WebUI.WebStyle* get_AttachmentFileErrorStyle();
public: __property void set_AttachmentFileErrorStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property ISNet.WebUI.WebStyle^ AttachmentFileErrorStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderStyleSettings Class
WebFileUploaderStyleSettings Members


AttachmentFileSelectedStyle Property

[image]
Intersoft WebTextEditor Documentation
AttachmentFileSelectedStyle Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderStyleSettings Class : AttachmentFileSelectedStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property AttachmentFileSelectedStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderStyleSettings
Dim value As ISNet.WebUI.WebStyle

instance.AttachmentFileSelectedStyle = value

value = instance.AttachmentFileSelectedStyle
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public ISNet.WebUI.WebStyle AttachmentFileSelectedStyle {get; set;}
Delphi
public read-write property AttachmentFileSelectedStyle: ISNet.WebUI.WebStyle;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set AttachmentFileSelectedStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property ISNet.WebUI.WebStyle* get_AttachmentFileSelectedStyle();
public: __property void set_AttachmentFileSelectedStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property ISNet.WebUI.WebStyle^ AttachmentFileSelectedStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderStyleSettings Class
WebFileUploaderStyleSettings Members


AttachmentFileStyle Property

[image]
Intersoft WebTextEditor Documentation
AttachmentFileStyle Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderStyleSettings Class : AttachmentFileStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public Property AttachmentFileStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderStyleSettings
Dim value As ISNet.WebUI.WebStyle

instance.AttachmentFileStyle = value

value = instance.AttachmentFileStyle
C#
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public ISNet.WebUI.WebStyle AttachmentFileStyle {get; set;}
Delphi
public read-write property AttachmentFileStyle: ISNet.WebUI.WebStyle;
JScript
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Appearance")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
public function get,set AttachmentFileStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public: __property ISNet.WebUI.WebStyle* get_AttachmentFileStyle();
public: __property void set_AttachmentFileStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public:
property ISNet.WebUI.WebStyle^ AttachmentFileStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderStyleSettings Class
WebFileUploaderStyleSettings Members


AttachmentFileUploadedStyle Property

[image]
Intersoft WebTextEditor Documentation
AttachmentFileUploadedStyle Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderStyleSettings Class : AttachmentFileUploadedStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
Public Property AttachmentFileUploadedStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderStyleSettings
Dim value As ISNet.WebUI.WebStyle

instance.AttachmentFileUploadedStyle = value

value = instance.AttachmentFileUploadedStyle
C#
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
public ISNet.WebUI.WebStyle AttachmentFileUploadedStyle {get; set;}
Delphi
public read-write property AttachmentFileUploadedStyle: ISNet.WebUI.WebStyle;
JScript
System.ComponentModel.CategoryAttribute("Appearance")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
public function get,set AttachmentFileUploadedStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
public: __property ISNet.WebUI.WebStyle* get_AttachmentFileUploadedStyle();
public: __property void set_AttachmentFileUploadedStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
public:
property ISNet.WebUI.WebStyle^ AttachmentFileUploadedStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderStyleSettings Class
WebFileUploaderStyleSettings Members


AttachmentFileUploadingStyle Property

[image]
Intersoft WebTextEditor Documentation
AttachmentFileUploadingStyle Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderStyleSettings Class : AttachmentFileUploadingStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.CategoryAttribute("Appearance")>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property AttachmentFileUploadingStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderStyleSettings
Dim value As ISNet.WebUI.WebStyle

instance.AttachmentFileUploadingStyle = value

value = instance.AttachmentFileUploadingStyle
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public ISNet.WebUI.WebStyle AttachmentFileUploadingStyle {get; set;}
Delphi
public read-write property AttachmentFileUploadingStyle: ISNet.WebUI.WebStyle;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.CategoryAttribute("Appearance")
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set AttachmentFileUploadingStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property ISNet.WebUI.WebStyle* get_AttachmentFileUploadingStyle();
public: __property void set_AttachmentFileUploadingStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property ISNet.WebUI.WebStyle^ AttachmentFileUploadingStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderStyleSettings Class
WebFileUploaderStyleSettings Members


ButtonStyle Property

[image]
Intersoft WebTextEditor Documentation
ButtonStyle Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderStyleSettings Class : ButtonStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public Property ButtonStyle As ISNet.WebUI.DynamicStyle
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderStyleSettings
Dim value As ISNet.WebUI.DynamicStyle

instance.ButtonStyle = value

value = instance.ButtonStyle
C#
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public ISNet.WebUI.DynamicStyle ButtonStyle {get; set;}
Delphi
public read-write property ButtonStyle: ISNet.WebUI.DynamicStyle;
JScript
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.BinarySerializableAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
public function get,set ButtonStyle : ISNet.WebUI.DynamicStyle
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public: __property ISNet.WebUI.DynamicStyle* get_ButtonStyle();
public: __property void set_ButtonStyle(
   ISNet.WebUI.DynamicStyle* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public:
property ISNet.WebUI.DynamicStyle^ ButtonStyle {
   ISNet.WebUI.DynamicStyle^ get();
   void set (    ISNet.WebUI.DynamicStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderStyleSettings Class
WebFileUploaderStyleSettings Members


CaptionStyle Property

[image]
Intersoft WebTextEditor Documentation
CaptionStyle Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderStyleSettings Class : CaptionStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Appearance")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
Public Property CaptionStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderStyleSettings
Dim value As ISNet.WebUI.WebStyle

instance.CaptionStyle = value

value = instance.CaptionStyle
C#
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public ISNet.WebUI.WebStyle CaptionStyle {get; set;}
Delphi
public read-write property CaptionStyle: ISNet.WebUI.WebStyle;
JScript
System.ComponentModel.CategoryAttribute("Appearance")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
public function get,set CaptionStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public: __property ISNet.WebUI.WebStyle* get_CaptionStyle();
public: __property void set_CaptionStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public:
property ISNet.WebUI.WebStyle^ CaptionStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderStyleSettings Class
WebFileUploaderStyleSettings Members


Directory Property

[image]
Intersoft WebTextEditor Documentation
Directory Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderStyleSettings Class : Directory Property

Glossary Item Box

Gets or sets directory for current settings.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute(True)>
Public Overrides Property Directory As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderStyleSettings
Dim value As System.String

instance.Directory = value

value = instance.Directory
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
public override System.string Directory {get; set;}
Delphi
public read-write property Directory: System.String; override;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public override function get,set Directory : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
public: __property System.string* get_Directory() override;
public: __property void set_Directory(
   System.string* value
) override;
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
public:
property System.String^ Directory {
   System.String^ get() override;
   void set (    System.String^ value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderStyleSettings Class
WebFileUploaderStyleSettings Members


FileUploadContainerForAttachmentBarStyle Property

[image]
Intersoft WebTextEditor Documentation
FileUploadContainerForAttachmentBarStyle Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderStyleSettings Class : FileUploadContainerForAttachmentBarStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property FileUploadContainerForAttachmentBarStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderStyleSettings
Dim value As ISNet.WebUI.WebStyle

instance.FileUploadContainerForAttachmentBarStyle = value

value = instance.FileUploadContainerForAttachmentBarStyle
C#
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
public ISNet.WebUI.WebStyle FileUploadContainerForAttachmentBarStyle {get; set;}
Delphi
public read-write property FileUploadContainerForAttachmentBarStyle: ISNet.WebUI.WebStyle;
JScript
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DefaultValueAttribute()
public function get,set FileUploadContainerForAttachmentBarStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property ISNet.WebUI.WebStyle* get_FileUploadContainerForAttachmentBarStyle();
public: __property void set_FileUploadContainerForAttachmentBarStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property ISNet.WebUI.WebStyle^ FileUploadContainerForAttachmentBarStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderStyleSettings Class
WebFileUploaderStyleSettings Members


FileUploadContainerStyle Property

[image]
Intersoft WebTextEditor Documentation
FileUploadContainerStyle Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderStyleSettings Class : FileUploadContainerStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
Public Property FileUploadContainerStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderStyleSettings
Dim value As ISNet.WebUI.WebStyle

instance.FileUploadContainerStyle = value

value = instance.FileUploadContainerStyle
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public ISNet.WebUI.WebStyle FileUploadContainerStyle {get; set;}
Delphi
public read-write property FileUploadContainerStyle: ISNet.WebUI.WebStyle;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
public function get,set FileUploadContainerStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public: __property ISNet.WebUI.WebStyle* get_FileUploadContainerStyle();
public: __property void set_FileUploadContainerStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public:
property ISNet.WebUI.WebStyle^ FileUploadContainerStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderStyleSettings Class
WebFileUploaderStyleSettings Members


FrameStyle Property

[image]
Intersoft WebTextEditor Documentation
FrameStyle Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderStyleSettings Class : FrameStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property FrameStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderStyleSettings
Dim value As ISNet.WebUI.WebStyle

instance.FrameStyle = value

value = instance.FrameStyle
C#
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public ISNet.WebUI.WebStyle FrameStyle {get; set;}
Delphi
public read-write property FrameStyle: ISNet.WebUI.WebStyle;
JScript
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set FrameStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property ISNet.WebUI.WebStyle* get_FrameStyle();
public: __property void set_FrameStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property ISNet.WebUI.WebStyle^ FrameStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderStyleSettings Class
WebFileUploaderStyleSettings Members


MessageStyle Property

[image]
Intersoft WebTextEditor Documentation
MessageStyle Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderStyleSettings Class : MessageStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property MessageStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderStyleSettings
Dim value As ISNet.WebUI.WebStyle

instance.MessageStyle = value

value = instance.MessageStyle
C#
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
public ISNet.WebUI.WebStyle MessageStyle {get; set;}
Delphi
public read-write property MessageStyle: ISNet.WebUI.WebStyle;
JScript
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.DefaultValueAttribute()
public function get,set MessageStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property ISNet.WebUI.WebStyle* get_MessageStyle();
public: __property void set_MessageStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property ISNet.WebUI.WebStyle^ MessageStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderStyleSettings Class
WebFileUploaderStyleSettings Members


ProgressBarFrameStyle Property

[image]
Intersoft WebTextEditor Documentation
ProgressBarFrameStyle Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderStyleSettings Class : ProgressBarFrameStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Appearance")>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public Property ProgressBarFrameStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderStyleSettings
Dim value As ISNet.WebUI.WebStyle

instance.ProgressBarFrameStyle = value

value = instance.ProgressBarFrameStyle
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public ISNet.WebUI.WebStyle ProgressBarFrameStyle {get; set;}
Delphi
public read-write property ProgressBarFrameStyle: ISNet.WebUI.WebStyle;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Appearance")
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
public function get,set ProgressBarFrameStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public: __property ISNet.WebUI.WebStyle* get_ProgressBarFrameStyle();
public: __property void set_ProgressBarFrameStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public:
property ISNet.WebUI.WebStyle^ ProgressBarFrameStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderStyleSettings Class
WebFileUploaderStyleSettings Members


ProgressBarInformationTextStyle Property

[image]
Intersoft WebTextEditor Documentation
ProgressBarInformationTextStyle Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderStyleSettings Class : ProgressBarInformationTextStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Appearance")>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property ProgressBarInformationTextStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderStyleSettings
Dim value As ISNet.WebUI.WebStyle

instance.ProgressBarInformationTextStyle = value

value = instance.ProgressBarInformationTextStyle
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public ISNet.WebUI.WebStyle ProgressBarInformationTextStyle {get; set;}
Delphi
public read-write property ProgressBarInformationTextStyle: ISNet.WebUI.WebStyle;
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Appearance")
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set ProgressBarInformationTextStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property ISNet.WebUI.WebStyle* get_ProgressBarInformationTextStyle();
public: __property void set_ProgressBarInformationTextStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Appearance")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property ISNet.WebUI.WebStyle^ ProgressBarInformationTextStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderStyleSettings Class
WebFileUploaderStyleSettings Members


ProgressBarStatusTextStyle Property

[image]
Intersoft WebTextEditor Documentation
ProgressBarStatusTextStyle Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderStyleSettings Class : ProgressBarStatusTextStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Appearance")>
Public Property ProgressBarStatusTextStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderStyleSettings
Dim value As ISNet.WebUI.WebStyle

instance.ProgressBarStatusTextStyle = value

value = instance.ProgressBarStatusTextStyle
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
public ISNet.WebUI.WebStyle ProgressBarStatusTextStyle {get; set;}
Delphi
public read-write property ProgressBarStatusTextStyle: ISNet.WebUI.WebStyle;
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Appearance")
public function get,set ProgressBarStatusTextStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
public: __property ISNet.WebUI.WebStyle* get_ProgressBarStatusTextStyle();
public: __property void set_ProgressBarStatusTextStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
public:
property ISNet.WebUI.WebStyle^ ProgressBarStatusTextStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderStyleSettings Class
WebFileUploaderStyleSettings Members


ProgressBarStyle Property

[image]
Intersoft WebTextEditor Documentation
ProgressBarStyle Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderStyleSettings Class : ProgressBarStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property ProgressBarStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderStyleSettings
Dim value As ISNet.WebUI.WebStyle

instance.ProgressBarStyle = value

value = instance.ProgressBarStyle
C#
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
public ISNet.WebUI.WebStyle ProgressBarStyle {get; set;}
Delphi
public read-write property ProgressBarStyle: ISNet.WebUI.WebStyle;
JScript
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Appearance")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DefaultValueAttribute()
public function get,set ProgressBarStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property ISNet.WebUI.WebStyle* get_ProgressBarStyle();
public: __property void set_ProgressBarStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property ISNet.WebUI.WebStyle^ ProgressBarStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderStyleSettings Class
WebFileUploaderStyleSettings Members


TextBoxStyle Property

[image]
Intersoft WebTextEditor Documentation
TextBoxStyle Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderStyleSettings Class : TextBoxStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Appearance")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property TextBoxStyle As ISNet.WebUI.DynamicStyle
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderStyleSettings
Dim value As ISNet.WebUI.DynamicStyle

instance.TextBoxStyle = value

value = instance.TextBoxStyle
C#
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public ISNet.WebUI.DynamicStyle TextBoxStyle {get; set;}
Delphi
public read-write property TextBoxStyle: ISNet.WebUI.DynamicStyle;
JScript
System.ComponentModel.CategoryAttribute("Appearance")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set TextBoxStyle : ISNet.WebUI.DynamicStyle
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property ISNet.WebUI.DynamicStyle* get_TextBoxStyle();
public: __property void set_TextBoxStyle(
   ISNet.WebUI.DynamicStyle* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Appearance")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property ISNet.WebUI.DynamicStyle^ TextBoxStyle {
   ISNet.WebUI.DynamicStyle^ get();
   void set (    ISNet.WebUI.DynamicStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderStyleSettings Class
WebFileUploaderStyleSettings Members


WebFileUploaderTextSettings Class

[image]
Intersoft WebTextEditor Documentation
WebFileUploaderTextSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebFileUploaderTextSettings Class

Glossary Item Box

A collection of settings which controls the text shown in WebUploader.

Object Model

WebFileUploaderTextSettings Class

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Class WebFileUploaderTextSettings
   Inherits ISNet.WebUI.Settings
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderTextSettings
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public class WebFileUploaderTextSettings : ISNet.WebUI.Settings, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebFileUploaderTextSettings = class(ISNet.WebUI.Settings, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public class WebFileUploaderTextSettings extends ISNet.WebUI.Settings implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public __gc class WebFileUploaderTextSettings : public ISNet.WebUI.Settings, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public ref class WebFileUploaderTextSettings : public ISNet.WebUI.Settings, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.Settings
ISNet.WebUI.WebTextEditor.WebFileUploaderTextSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderTextSettings Members
ISNet.WebUI.WebTextEditor Namespace


WebFileUploaderTextSettings Class Members

[image]
Intersoft WebTextEditor Documentation
WebFileUploaderTextSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebFileUploaderTextSettings Class

Glossary Item Box

The following tables list the members exposed by WebFileUploaderTextSettings.

Public Constructors

 | Name | Description
Public Constructor | WebFileUploaderTextSettings Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | AbortText | Specifies abort text of WebUploader.
Public Property | ButtonAddText | Specifies add button text of WebUploader.
Public Property | ButtonCancelAllText | Specifies cancel all text button of WebUploader.
Public Property | ButtonCancelledText | Specifies canceled button text of WebUploader.
Public Property | ButtonCancellingText | Specifies canceling button text of WebUploader.
Public Property | ButtonCancelText | Specifies cancel button text of WebUploader.
Public Property | ButtonErrorText | Specifies button error text of WebUploader.
Public Property | ButtonRemoveText | Specifies remove button text of WebUploader.
Public Property | ButtonSelectText | Specifies button select text of WebUploader.
Public Property | ButtonStartOverText | Specifies button start over text of WebUploader.
Public Property | ButtonUploadedText | Specifies button uploader text of WebUploader.
Public Property | ButtonUploadingText | Specifies button uploading text of WebUploader.
Public Property | ButtonUploadText | Specifies upload button text of WebUploader.
Public Property | Control | (Inherited from ISNet.WebUI.Settings)
Public Property | FileName | (Inherited from ISNet.WebUI.Settings)
Public Property | MessageText | Specifies message text of WebUploader.
Public Property | ProgressAreaOKButtonText | Specifies OK button text in ProgressArea of WebUploader.
Public Property | ProgressBarStatusText | Specifies ProgressBar status text of WebUploader.
Public Property | ProgressBarTotalStatusText | Specifies ProgressBar total status text of WebUploader.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | InitSettings | (Inherited from ISNet.WebUI.Settings)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

Protected Methods

 | Name | Description
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | IsInSerializationContext | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebFileUploaderTextSettings Class
ISNet.WebUI.WebTextEditor Namespace


WebFileUploaderTextSettings Constructor

[image]
Intersoft WebTextEditor Documentation
WebFileUploaderTextSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderTextSettings Class : WebFileUploaderTextSettings Constructor

Glossary Item Box

Overload List

Overload | Description
WebFileUploaderTextSettings Constructor() |
WebFileUploaderTextSettings Constructor(SerializationInfo,StreamingContext) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderTextSettings Class
WebFileUploaderTextSettings Members


WebFileUploaderTextSettings Constructor()

[image]
Intersoft WebTextEditor Documentation
WebFileUploaderTextSettings Constructor()
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderTextSettings Class > WebFileUploaderTextSettings Constructor : WebFileUploaderTextSettings Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebFileUploaderTextSettings()
C#
public WebFileUploaderTextSettings()
Delphi
public WebFileUploaderTextSettings();
JScript
public function WebFileUploaderTextSettings();
Managed Extensions for C++
public: WebFileUploaderTextSettings();
C++/CLI
public:
WebFileUploaderTextSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderTextSettings Class
WebFileUploaderTextSettings Members
Overload List


WebFileUploaderTextSettings Constructor(SerializationInfo,StreamingContext)

[image]
Intersoft WebTextEditor Documentation
WebFileUploaderTextSettings Constructor(SerializationInfo,StreamingContext)
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderTextSettings Class > WebFileUploaderTextSettings Constructor : WebFileUploaderTextSettings Constructor(SerializationInfo,StreamingContext)

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

Dim instance As New WebFileUploaderTextSettings(info, context)
C#
protected WebFileUploaderTextSettings(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
protected WebFileUploaderTextSettings(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
protected function WebFileUploaderTextSettings(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
protected: WebFileUploaderTextSettings(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
protected:
WebFileUploaderTextSettings(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderTextSettings Class
WebFileUploaderTextSettings Members
Overload List


WebFileUploaderTextSettings Class Methods

[image]
Intersoft WebTextEditor Documentation
WebFileUploaderTextSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebFileUploaderTextSettings Class

Glossary Item Box

For a list of all members of this type, see WebFileUploaderTextSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | InitSettings | (Inherited from ISNet.WebUI.Settings)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

Protected Methods

 | Name | Description
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | IsInSerializationContext | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebFileUploaderTextSettings Class
ISNet.WebUI.WebTextEditor Namespace


GetObjectData Method

[image]
Intersoft WebTextEditor Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderTextSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderTextSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderTextSettings Class
WebFileUploaderTextSettings Members


WebFileUploaderTextSettings Class Properties

[image]
Intersoft WebTextEditor Documentation
WebFileUploaderTextSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebFileUploaderTextSettings Class

Glossary Item Box

For a list of all members of this type, see WebFileUploaderTextSettings members.

Public Properties

 | Name | Description
Public Property | AbortText | Specifies abort text of WebUploader.
Public Property | ButtonAddText | Specifies add button text of WebUploader.
Public Property | ButtonCancelAllText | Specifies cancel all text button of WebUploader.
Public Property | ButtonCancelledText | Specifies canceled button text of WebUploader.
Public Property | ButtonCancellingText | Specifies canceling button text of WebUploader.
Public Property | ButtonCancelText | Specifies cancel button text of WebUploader.
Public Property | ButtonErrorText | Specifies button error text of WebUploader.
Public Property | ButtonRemoveText | Specifies remove button text of WebUploader.
Public Property | ButtonSelectText | Specifies button select text of WebUploader.
Public Property | ButtonStartOverText | Specifies button start over text of WebUploader.
Public Property | ButtonUploadedText | Specifies button uploader text of WebUploader.
Public Property | ButtonUploadingText | Specifies button uploading text of WebUploader.
Public Property | ButtonUploadText | Specifies upload button text of WebUploader.
Public Property | Control | (Inherited from ISNet.WebUI.Settings)
Public Property | FileName | (Inherited from ISNet.WebUI.Settings)
Public Property | MessageText | Specifies message text of WebUploader.
Public Property | ProgressAreaOKButtonText | Specifies OK button text in ProgressArea of WebUploader.
Public Property | ProgressBarStatusText | Specifies ProgressBar status text of WebUploader.
Public Property | ProgressBarTotalStatusText | Specifies ProgressBar total status text of WebUploader.
Top

See Also

Reference

WebFileUploaderTextSettings Class
ISNet.WebUI.WebTextEditor Namespace


AbortText Property

[image]
Intersoft WebTextEditor Documentation
AbortText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderTextSettings Class : AbortText Property

Glossary Item Box

Specifies abort text of WebUploader.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property AbortText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderTextSettings
Dim value As System.String

instance.AbortText = value

value = instance.AbortText
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string AbortText {get; set;}
Delphi
public read-write property AbortText: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
ISNet.Serialization.BinarySerializableAttribute()
public function get,set AbortText : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_AbortText();
public: __property void set_AbortText(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ AbortText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderTextSettings Class
WebFileUploaderTextSettings Members


ButtonAddText Property

[image]
Intersoft WebTextEditor Documentation
ButtonAddText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderTextSettings Class : ButtonAddText Property

Glossary Item Box

Specifies add button text of WebUploader.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property ButtonAddText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderTextSettings
Dim value As System.String

instance.ButtonAddText = value

value = instance.ButtonAddText
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string ButtonAddText {get; set;}
Delphi
public read-write property ButtonAddText: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set ButtonAddText : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_ButtonAddText();
public: __property void set_ButtonAddText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ ButtonAddText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderTextSettings Class
WebFileUploaderTextSettings Members


ButtonCancelAllText Property

[image]
Intersoft WebTextEditor Documentation
ButtonCancelAllText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderTextSettings Class : ButtonCancelAllText Property

Glossary Item Box

Specifies cancel all text button of WebUploader.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property ButtonCancelAllText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderTextSettings
Dim value As System.String

instance.ButtonCancelAllText = value

value = instance.ButtonCancelAllText
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string ButtonCancelAllText {get; set;}
Delphi
public read-write property ButtonCancelAllText: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set ButtonCancelAllText : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_ButtonCancelAllText();
public: __property void set_ButtonCancelAllText(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ ButtonCancelAllText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderTextSettings Class
WebFileUploaderTextSettings Members


ButtonCancelledText Property

[image]
Intersoft WebTextEditor Documentation
ButtonCancelledText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderTextSettings Class : ButtonCancelledText Property

Glossary Item Box

Specifies canceled button text of WebUploader.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Property ButtonCancelledText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderTextSettings
Dim value As System.String

instance.ButtonCancelledText = value

value = instance.ButtonCancelledText
C#
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public System.string ButtonCancelledText {get; set;}
Delphi
public read-write property ButtonCancelledText: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set ButtonCancelledText : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property System.string* get_ButtonCancelledText();
public: __property void set_ButtonCancelledText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
property System.String^ ButtonCancelledText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderTextSettings Class
WebFileUploaderTextSettings Members


ButtonCancellingText Property

[image]
Intersoft WebTextEditor Documentation
ButtonCancellingText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderTextSettings Class : ButtonCancellingText Property

Glossary Item Box

Specifies canceling button text of WebUploader.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property ButtonCancellingText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderTextSettings
Dim value As System.String

instance.ButtonCancellingText = value

value = instance.ButtonCancellingText
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string ButtonCancellingText {get; set;}
Delphi
public read-write property ButtonCancellingText: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
ISNet.Serialization.BinarySerializableAttribute()
public function get,set ButtonCancellingText : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_ButtonCancellingText();
public: __property void set_ButtonCancellingText(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ ButtonCancellingText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderTextSettings Class
WebFileUploaderTextSettings Members


ButtonCancelText Property

[image]
Intersoft WebTextEditor Documentation
ButtonCancelText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderTextSettings Class : ButtonCancelText Property

Glossary Item Box

Specifies cancel button text of WebUploader.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property ButtonCancelText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderTextSettings
Dim value As System.String

instance.ButtonCancelText = value

value = instance.ButtonCancelText
C#
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string ButtonCancelText {get; set;}
Delphi
public read-write property ButtonCancelText: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
ISNet.Serialization.XmlSerializableAttribute()
public function get,set ButtonCancelText : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_ButtonCancelText();
public: __property void set_ButtonCancelText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ ButtonCancelText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderTextSettings Class
WebFileUploaderTextSettings Members


ButtonErrorText Property

[image]
Intersoft WebTextEditor Documentation
ButtonErrorText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderTextSettings Class : ButtonErrorText Property

Glossary Item Box

Specifies button error text of WebUploader.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property ButtonErrorText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderTextSettings
Dim value As System.String

instance.ButtonErrorText = value

value = instance.ButtonErrorText
C#
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.string ButtonErrorText {get; set;}
Delphi
public read-write property ButtonErrorText: System.String;
JScript
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set ButtonErrorText : System.String
Managed Extensions for C++
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_ButtonErrorText();
public: __property void set_ButtonErrorText(
   System.string* value
);
C++/CLI
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ ButtonErrorText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderTextSettings Class
WebFileUploaderTextSettings Members


ButtonRemoveText Property

[image]
Intersoft WebTextEditor Documentation
ButtonRemoveText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderTextSettings Class : ButtonRemoveText Property

Glossary Item Box

Specifies remove button text of WebUploader.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property ButtonRemoveText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderTextSettings
Dim value As System.String

instance.ButtonRemoveText = value

value = instance.ButtonRemoveText
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string ButtonRemoveText {get; set;}
Delphi
public read-write property ButtonRemoveText: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set ButtonRemoveText : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_ButtonRemoveText();
public: __property void set_ButtonRemoveText(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ ButtonRemoveText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderTextSettings Class
WebFileUploaderTextSettings Members


ButtonSelectText Property

[image]
Intersoft WebTextEditor Documentation
ButtonSelectText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderTextSettings Class : ButtonSelectText Property

Glossary Item Box

Specifies button select text of WebUploader.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property ButtonSelectText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderTextSettings
Dim value As System.String

instance.ButtonSelectText = value

value = instance.ButtonSelectText
C#
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string ButtonSelectText {get; set;}
Delphi
public read-write property ButtonSelectText: System.String;
JScript
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set ButtonSelectText : System.String
Managed Extensions for C++
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_ButtonSelectText();
public: __property void set_ButtonSelectText(
   System.string* value
);
C++/CLI
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ ButtonSelectText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderTextSettings Class
WebFileUploaderTextSettings Members


ButtonStartOverText Property

[image]
Intersoft WebTextEditor Documentation
ButtonStartOverText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderTextSettings Class : ButtonStartOverText Property

Glossary Item Box

Specifies button start over text of WebUploader.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property ButtonStartOverText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderTextSettings
Dim value As System.String

instance.ButtonStartOverText = value

value = instance.ButtonStartOverText
C#
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string ButtonStartOverText {get; set;}
Delphi
public read-write property ButtonStartOverText: System.String;
JScript
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set ButtonStartOverText : System.String
Managed Extensions for C++
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_ButtonStartOverText();
public: __property void set_ButtonStartOverText(
   System.string* value
);
C++/CLI
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ ButtonStartOverText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderTextSettings Class
WebFileUploaderTextSettings Members


ButtonUploadedText Property

[image]
Intersoft WebTextEditor Documentation
ButtonUploadedText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderTextSettings Class : ButtonUploadedText Property

Glossary Item Box

Specifies button uploader text of WebUploader.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property ButtonUploadedText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderTextSettings
Dim value As System.String

instance.ButtonUploadedText = value

value = instance.ButtonUploadedText
C#
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.string ButtonUploadedText {get; set;}
Delphi
public read-write property ButtonUploadedText: System.String;
JScript
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set ButtonUploadedText : System.String
Managed Extensions for C++
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_ButtonUploadedText();
public: __property void set_ButtonUploadedText(
   System.string* value
);
C++/CLI
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ ButtonUploadedText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderTextSettings Class
WebFileUploaderTextSettings Members


ButtonUploadingText Property

[image]
Intersoft WebTextEditor Documentation
ButtonUploadingText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderTextSettings Class : ButtonUploadingText Property

Glossary Item Box

Specifies button uploading text of WebUploader.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property ButtonUploadingText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderTextSettings
Dim value As System.String

instance.ButtonUploadingText = value

value = instance.ButtonUploadingText
C#
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string ButtonUploadingText {get; set;}
Delphi
public read-write property ButtonUploadingText: System.String;
JScript
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set ButtonUploadingText : System.String
Managed Extensions for C++
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_ButtonUploadingText();
public: __property void set_ButtonUploadingText(
   System.string* value
);
C++/CLI
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ ButtonUploadingText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderTextSettings Class
WebFileUploaderTextSettings Members


ButtonUploadText Property

[image]
Intersoft WebTextEditor Documentation
ButtonUploadText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderTextSettings Class : ButtonUploadText Property

Glossary Item Box

Specifies upload button text of WebUploader.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property ButtonUploadText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderTextSettings
Dim value As System.String

instance.ButtonUploadText = value

value = instance.ButtonUploadText
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string ButtonUploadText {get; set;}
Delphi
public read-write property ButtonUploadText: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
ISNet.Serialization.BinarySerializableAttribute()
public function get,set ButtonUploadText : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_ButtonUploadText();
public: __property void set_ButtonUploadText(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ ButtonUploadText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderTextSettings Class
WebFileUploaderTextSettings Members


MessageText Property

[image]
Intersoft WebTextEditor Documentation
MessageText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderTextSettings Class : MessageText Property

Glossary Item Box

Specifies message text of WebUploader.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property MessageText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderTextSettings
Dim value As System.String

instance.MessageText = value

value = instance.MessageText
C#
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string MessageText {get; set;}
Delphi
public read-write property MessageText: System.String;
JScript
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set MessageText : System.String
Managed Extensions for C++
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_MessageText();
public: __property void set_MessageText(
   System.string* value
);
C++/CLI
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ MessageText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderTextSettings Class
WebFileUploaderTextSettings Members


ProgressAreaOKButtonText Property

[image]
Intersoft WebTextEditor Documentation
ProgressAreaOKButtonText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderTextSettings Class : ProgressAreaOKButtonText Property

Glossary Item Box

Specifies OK button text in ProgressArea of WebUploader.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property ProgressAreaOKButtonText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderTextSettings
Dim value As System.String

instance.ProgressAreaOKButtonText = value

value = instance.ProgressAreaOKButtonText
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string ProgressAreaOKButtonText {get; set;}
Delphi
public read-write property ProgressAreaOKButtonText: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set ProgressAreaOKButtonText : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_ProgressAreaOKButtonText();
public: __property void set_ProgressAreaOKButtonText(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ ProgressAreaOKButtonText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderTextSettings Class
WebFileUploaderTextSettings Members


ProgressBarStatusText Property

[image]
Intersoft WebTextEditor Documentation
ProgressBarStatusText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderTextSettings Class : ProgressBarStatusText Property

Glossary Item Box

Specifies ProgressBar status text of WebUploader.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property ProgressBarStatusText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderTextSettings
Dim value As System.String

instance.ProgressBarStatusText = value

value = instance.ProgressBarStatusText
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string ProgressBarStatusText {get; set;}
Delphi
public read-write property ProgressBarStatusText: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
ISNet.Serialization.BinarySerializableAttribute()
public function get,set ProgressBarStatusText : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_ProgressBarStatusText();
public: __property void set_ProgressBarStatusText(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ ProgressBarStatusText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderTextSettings Class
WebFileUploaderTextSettings Members


ProgressBarTotalStatusText Property

[image]
Intersoft WebTextEditor Documentation
ProgressBarTotalStatusText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderTextSettings Class : ProgressBarTotalStatusText Property

Glossary Item Box

Specifies ProgressBar total status text of WebUploader.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property ProgressBarTotalStatusText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderTextSettings
Dim value As System.String

instance.ProgressBarTotalStatusText = value

value = instance.ProgressBarTotalStatusText
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string ProgressBarTotalStatusText {get; set;}
Delphi
public read-write property ProgressBarTotalStatusText: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set ProgressBarTotalStatusText : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_ProgressBarTotalStatusText();
public: __property void set_ProgressBarTotalStatusText(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ ProgressBarTotalStatusText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderTextSettings Class
WebFileUploaderTextSettings Members


WebSpellChecker Class

[image]
Intersoft WebTextEditor Documentation
WebSpellChecker Class
Members See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebSpellChecker Class

Glossary Item Box

Intersoft WebSpellChecker is an easy-to-use, yet powerful spell checking component for ASP.NET. In addition to typical spell check features that you expected, WebSpellChecker delivers several innovative features that are not available elsewhere, such as Microsoft Word-style red-wave underline highlight, built-in dialogbox with intuitive design, natural integration with WebTextEditor, wide cross browsers support and more.

Object Model

WebSpellChecker Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.ToolboxDataAttribute("<{0}:WebSpellChecker runat=server></{0}:WebSpellChecker>")>
<ISNet.Serialization.XmlSerializableAttribute(JSFileNames="WebSpellChecker.js", Type=XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ISNet.WebUI.WebTextEditor.WebSpellCheckerDesigner, ISNet.WebUI.WebTextEditor, Version=1.0.1000.9, Culture=neutral, PublicKeyToken=b1f2a8511635667a")>
<System.SerializableAttribute()>
<System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand Or  _
    SecurityAction.Deny Or  _
    SecurityAction.LinkDemand,
   Unrestricted=False)>
<System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand Or  _
    SecurityAction.Assert Or  _
    SecurityAction.Deny Or  _
    SecurityAction.PermitOnly Or  _
    SecurityAction.LinkDemand Or  _
    SecurityAction.InheritanceDemand,
   Unrestricted=False)>
Public Class WebSpellChecker
   Inherits ISNet.WebUI.ISNetControl
   Implements ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
C#
[System.Web.UI.ToolboxDataAttribute("<{0}:WebSpellChecker runat=server></{0}:WebSpellChecker>")]
[ISNet.Serialization.XmlSerializableAttribute(JSFileNames="WebSpellChecker.js", Type=XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ISNet.WebUI.WebTextEditor.WebSpellCheckerDesigner, ISNet.WebUI.WebTextEditor, Version=1.0.1000.9, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.SerializableAttribute()]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public class WebSpellChecker : ISNet.WebUI.ISNetControl, ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings
Delphi
public class WebSpellChecker = class(ISNet.WebUI.ISNetControl, ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings)
JScript
System.Web.UI.ToolboxDataAttribute("<{0}:WebSpellChecker runat=server></{0}:WebSpellChecker>")
ISNet.Serialization.XmlSerializableAttribute(JSFileNames="WebSpellChecker.js", Type=XmlSerializationType.ClientAndLayout)
System.ComponentModel.DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ISNet.WebUI.WebTextEditor.WebSpellCheckerDesigner, ISNet.WebUI.WebTextEditor, Version=1.0.1000.9, Culture=neutral, PublicKeyToken=b1f2a8511635667a")
System.SerializableAttribute()
System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=)
System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=)
public class WebSpellChecker extends ISNet.WebUI.ISNetControl implements ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings
Managed Extensions for C++
[System.Web.UI.ToolboxDataAttribute("<{0}:WebSpellChecker runat=server></{0}:WebSpellChecker>")]
[ISNet.Serialization.XmlSerializableAttribute(JSFileNames="WebSpellChecker.js", Type=XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ISNet.WebUI.WebTextEditor.WebSpellCheckerDesigner, ISNet.WebUI.WebTextEditor, Version=1.0.1000.9, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.SerializableAttribute()]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public __gc class WebSpellChecker : public ISNet.WebUI.ISNetControl, ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings
C++/CLI
[System.Web.UI.ToolboxDataAttribute("<{0}:WebSpellChecker runat=server></{0}:WebSpellChecker>")]
[ISNet.Serialization.XmlSerializableAttribute(JSFileNames="WebSpellChecker.js", Type=XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ISNet.WebUI.WebTextEditor.WebSpellCheckerDesigner, ISNet.WebUI.WebTextEditor, Version=1.0.1000.9, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.SerializableAttribute()]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public ref class WebSpellChecker : public ISNet.WebUI.ISNetControl, ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings

Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
ISNet.WebUI.ISNetControl
ISNet.WebUI.WebTextEditor.WebSpellChecker

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Members
ISNet.WebUI.WebTextEditor Namespace


WebSpellChecker Class Members

[image]
Intersoft WebTextEditor Documentation
WebSpellChecker Class Members
See Also Fields Properties Methods Events Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebSpellChecker Class

Glossary Item Box

The following tables list the members exposed by WebSpellChecker.

Public Constructors

 | Name | Description
Public Constructor | WebSpellChecker Constructor | Overloaded.
Top

Protected Fields

 | Name | Description
Protected Field | isPagePreRender | (Inherited from ISNet.WebUI.ISNetControl)
Protected Field | renderDHTML | (Inherited from ISNet.WebUI.ISNetControl)
Protected Field | renderNS | (Inherited from ISNet.WebUI.ISNetControl)
Protected Field | viewStateLoaded | (Inherited from ISNet.WebUI.ISNetControl)
Top

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ActionName |
Public Property | AllowAddToDictionary | Determines whether AddToDictionary menu should appear or not in context menu.
Public Property | AppRelativeTemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | AspNetAjaxSettings | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Attributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BackColor | Overridden.
Public Property | BorderColor | Overridden.
Public Property | BorderStyle | Overridden.
Public Property | BorderWidth | Overridden.
Public Property | ClientID | (Inherited from System.Web.UI.Control)
Public Property | ClientIDMode | (Inherited from System.Web.UI.Control)
Public Property | ClientSideEvents | Contains client side events supported by WebSpellChecker.
Public Property | ContextMenuStyle | Specifies WebSpellChecker's context menu style.
Public Property | ControlDataTransferFormat | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Controls | (Inherited from System.Web.UI.Control)
Public Property | ControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ControlStyleCreated | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | CssClass | Overridden.
Public Property | DialogBoxURL | The WebDialogBox's URL.
Public Property | DictionaryData | The dictionary data collection.
Public Property | DictionaryDirectory | Gets or sets the dictionary directory.
Public Property | Enabled | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableManagedTheming | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | FlyPostBackSettings | Configures the settings used by the control when performing OnTheFly postback.
Public Property | Font | Overridden.
Public Property | ForeColor | Overridden.
Public Property | FormKey |
Public Property | HasAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Height | Overridden.
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | ImagesDirectory | Gets or sets the images directory.
Public Property | ImagesSettings | Provides the settings that control the images in WebSpellChecker.
Public Property | IntegratedToWebTextEditor | Determines whether WebSpellChecker is integrated with WebRichTextEditor
Public Property | IsControlThemed | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | IsDesign | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | IsDynamicCreated | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | IsFlyPostBack |
Public Property | IsInternalCreated | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | IsUnloaded | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | MaximumTextSuggestion | Gets or sets the maximum text suggestion.
Public Property | NamingContainer | (Inherited from System.Web.UI.Control)
Public Property | Page | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Parent | (Inherited from System.Web.UI.Control)
Public Property | ParentStyleId | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RenderingCompatibility | (Inherited from System.Web.UI.Control)
Public Property | RenderingMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RequiresUIRefresh | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RuntimeLicenseKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | SaveViewStateOnFlyPostback | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ScriptDirectory | Overridden. Gets or sets the directory where all required scripts for the control are stored.
Public Property | SerializedJSFiles | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | SerializedStyles | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | SharedScriptDirectory | Overridden. Gets or sets the directory where all required framework scripts for the control are stored.
Public Property | Site | (Inherited from System.Web.UI.Control)
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Style | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | SupportsDisabledAttribute | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | SupportXMLCultureInfo | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | TabIndex | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | TargetControlId | Specifies WebSpellChecker target ControlId.
Public Property | TargetControlIdValue | Gets or sets the TargetControlId's Value.
Public Property | TemplateControl | (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | TextSettings | Provides settings that control text that shown in WebSpellChecker.
Public Property | TextSuggestionCollection | The text suggestion data collection.
Public Property | ToolTip | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | UniqueID | (Inherited from System.Web.UI.Control)
Public Property | ValidateRequestMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateItems | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateServerConnection | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateStorage | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Visible | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | WebDesktopScriptDirectory | Gets or sets the IIS path to locate WebDesktop's script directory. This property is only applicable when SmartWebResources is not enabled.
Public Property | Width | Overridden.
Public Property | XmlCompressionEnabled | (Inherited from ISNet.WebUI.ISNetControl)
Top

Protected Properties

 | Name | Description
Protected Property | Adapter | (Inherited from System.Web.UI.Control)
Protected Property | ChildControlsCreated | (Inherited from System.Web.UI.Control)
Protected Property | ClientIDSeparator | (Inherited from System.Web.UI.Control)
Protected Property | DefaultImagesFolder | Overridden.
Protected Property | Events | (Inherited from System.Web.UI.Control)
Protected Property | HasChildViewState | (Inherited from System.Web.UI.Control)
Protected Property | IdSeparator | (Inherited from System.Web.UI.Control)
Protected Property | IsMvc | (Inherited from ISNet.WebUI.ISNetControl)
Protected Property | IsTrackingViewState | (Inherited from System.Web.UI.Control)
Protected Property | LicenseType | Overridden.
Protected Property | LoadViewStateByID | (Inherited from System.Web.UI.Control)
Protected Property | MaxJsonLength | (Inherited from ISNet.WebUI.ISNetControl)
Protected Property | Product | Overridden.
Protected Property | ProductIcon | Overridden.
Protected Property | ProductImage | Overridden.
Protected Property | TagKey | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Property | TagName | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Property | ViewState | (Inherited from System.Web.UI.Control)
Protected Property | ViewStateIgnoresCase | (Inherited from System.Web.UI.Control)
Top

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CanUseWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CheckConstrains | Overridden.
Public Method | Clone | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | DataBind | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | ForceDisableXmlCompression | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetClientAction |
Public Method | GetCurrentControlLifeCycle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkDataFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkVersion | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetIntersoftFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetLayoutFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetObjectData | Overridden.
Public Method | GetPostedXMLData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductInfoKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductSimpleName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetPropertyValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetResourceStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetRouteUrl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | GetUniqueIDRelativeTo | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | IsAtlasCallback | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsBetaRelease | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsChromeBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackRequest | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoBasedBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoVersion18 | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInDesignMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorer8Browser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorerBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsOperaBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsSafariBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsW3CStandardBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromPredefinedName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadPostData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | OnInfoChanged | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | OnPreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RaisePostDataChangedEvent | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ReadWebConfigValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RecreateChildControls |
Public Method | RegisterBoxSizing | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterGlobalStyle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterLink | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterOptimizedCssClasses | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterPreloadImage | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterScript | Overridden.
Public Method | RegisterSharePointHandler | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderBeginTag | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderControl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | Overridden.
Public Method | Reset | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveImagePath | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveRelativeURL | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveResourceUrl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SaveLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Public Method | SetSessionTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ShouldReturnJson | (Inherited from ISNet.WebUI.ISNetControl)
Top

Protected Methods

 | Name | Description
Protected Method | AddAttributesToRender | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | AddParsedSubObject | (Inherited from System.Web.UI.Control)
Protected Method | ApplyControlTheme | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | AssignXmlInputHiddenUniqueID | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | BuildProfileTree | (Inherited from System.Web.UI.Control)
Protected Method | ClearCachedClientID | (Inherited from System.Web.UI.Control)
Protected Method | ClearChildControlState | (Inherited from System.Web.UI.Control)
Protected Method | ClearChildState | (Inherited from System.Web.UI.Control)
Protected Method | ClearChildViewState | (Inherited from System.Web.UI.Control)
Protected Method | ClearEffectiveClientIDMode | (Inherited from System.Web.UI.Control)
Protected Method | ControlRequestHandler | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | CreateChildControls | Overridden.
Protected Method | CreateControlCollection | (Inherited from System.Web.UI.Control)
Protected Method | CreateControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | CreateThemeInfo | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | DataBindChildren | (Inherited from System.Web.UI.Control)
Protected Method | DecodeRequest | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | EnsureChildControls | (Inherited from System.Web.UI.Control)
Protected Method | EnsureID | (Inherited from System.Web.UI.Control)
Protected Method | GetApplicationState | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | GetCachedAppTheme | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | GetDesignModeState | (Inherited from System.Web.UI.Control)
Protected Method | GetDHTMLRenderer | Overridden.
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | GetSessionLevelTheme | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | HasEvents | (Inherited from System.Web.UI.Control)
Protected Method | InitializeDefaultStyles | Overridden.
Protected Method | InitializeLayoutBehaviors | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | InitializeManagedTheming | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | IsApplicationAvailable | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | IsAppThemeEnabled | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | IsLiteralContent | (Inherited from System.Web.UI.Control)
Protected Method | IsSessionAvailable | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | LoadControlState | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | LoadViewState | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | OnBubbleEvent | (Inherited from System.Web.UI.Control)
Protected Method | OnDataBinding | (Inherited from System.Web.UI.Control)
Protected Method | OnInit | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | OnLoad | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | OnPreRender | Overridden.
Protected Method | RaiseBubbleEvent | (Inherited from System.Web.UI.Control)
Protected Method | RenderContents | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | ResetFilteredStyle | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | ResolveAdapter | (Inherited from System.Web.UI.Control)
Protected Method | SaveControlState | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | SaveViewState | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | SetDesignModeState | (Inherited from System.Web.UI.Control)
Protected Method | SetTheme | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | ShowAboutBox | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | TrackViewState | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | UseDeepCloneForViewStateStorage | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | UseMemoryStreamStateType | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | WebSpellChecker_Init |
Top

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

WebSpellChecker Class
ISNet.WebUI.WebTextEditor Namespace


WebSpellChecker Constructor

[image]
Intersoft WebTextEditor Documentation
WebSpellChecker Constructor
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : WebSpellChecker Constructor

Glossary Item Box

Overload List

Overload | Description
WebSpellChecker Constructor() |
WebSpellChecker Constructor(SerializationInfo,StreamingContext) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


WebSpellChecker Constructor()

[image]
Intersoft WebTextEditor Documentation
WebSpellChecker Constructor()
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class > WebSpellChecker Constructor : WebSpellChecker Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebSpellChecker()
C#
public WebSpellChecker()
Delphi
public WebSpellChecker();
JScript
public function WebSpellChecker();
Managed Extensions for C++
public: WebSpellChecker();
C++/CLI
public:
WebSpellChecker();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members
Overload List


WebSpellChecker Constructor(SerializationInfo,StreamingContext)

[image]
Intersoft WebTextEditor Documentation
WebSpellChecker Constructor(SerializationInfo,StreamingContext)
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class > WebSpellChecker Constructor : WebSpellChecker Constructor(SerializationInfo,StreamingContext)

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

Dim instance As New WebSpellChecker(info, context)
C#
protected WebSpellChecker(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
protected WebSpellChecker(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
protected function WebSpellChecker(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
protected: WebSpellChecker(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
protected:
WebSpellChecker(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members
Overload List


WebSpellChecker Class Methods

[image]
Intersoft WebTextEditor Documentation
WebSpellChecker Class Methods
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebSpellChecker Class

Glossary Item Box

For a list of all members of this type, see WebSpellChecker members.

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CanUseWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CheckConstrains | Overridden.
Public Method | Clone | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | DataBind | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | ForceDisableXmlCompression | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetClientAction |
Public Method | GetCurrentControlLifeCycle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkDataFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkVersion | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetIntersoftFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetLayoutFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetObjectData | Overridden.
Public Method | GetPostedXMLData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductInfoKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductSimpleName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetPropertyValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetResourceStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetRouteUrl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | GetUniqueIDRelativeTo | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | IsAtlasCallback | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsBetaRelease | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsChromeBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackRequest | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoBasedBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoVersion18 | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInDesignMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorer8Browser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorerBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsOperaBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsSafariBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsW3CStandardBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromPredefinedName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadPostData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | OnInfoChanged | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | OnPreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RaisePostDataChangedEvent | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ReadWebConfigValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RecreateChildControls |
Public Method | RegisterBoxSizing | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterGlobalStyle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterLink | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterOptimizedCssClasses | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterPreloadImage | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterScript | Overridden.
Public Method | RegisterSharePointHandler | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderBeginTag | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderControl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | Overridden.
Public Method | Reset | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveImagePath | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveRelativeURL | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveResourceUrl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SaveLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Public Method | SetSessionTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ShouldReturnJson | (Inherited from ISNet.WebUI.ISNetControl)
Top

Protected Methods

 | Name | Description
Protected Method | AddAttributesToRender | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | AddParsedSubObject | (Inherited from System.Web.UI.Control)
Protected Method | ApplyControlTheme | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | AssignXmlInputHiddenUniqueID | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | BuildProfileTree | (Inherited from System.Web.UI.Control)
Protected Method | ClearCachedClientID | (Inherited from System.Web.UI.Control)
Protected Method | ClearChildControlState | (Inherited from System.Web.UI.Control)
Protected Method | ClearChildState | (Inherited from System.Web.UI.Control)
Protected Method | ClearChildViewState | (Inherited from System.Web.UI.Control)
Protected Method | ClearEffectiveClientIDMode | (Inherited from System.Web.UI.Control)
Protected Method | ControlRequestHandler | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | CreateChildControls | Overridden.
Protected Method | CreateControlCollection | (Inherited from System.Web.UI.Control)
Protected Method | CreateControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | CreateThemeInfo | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | DataBindChildren | (Inherited from System.Web.UI.Control)
Protected Method | DecodeRequest | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | EnsureChildControls | (Inherited from System.Web.UI.Control)
Protected Method | EnsureID | (Inherited from System.Web.UI.Control)
Protected Method | GetApplicationState | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | GetCachedAppTheme | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | GetDesignModeState | (Inherited from System.Web.UI.Control)
Protected Method | GetDHTMLRenderer | Overridden.
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | GetSessionLevelTheme | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | HasEvents | (Inherited from System.Web.UI.Control)
Protected Method | InitializeDefaultStyles | Overridden.
Protected Method | InitializeLayoutBehaviors | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | InitializeManagedTheming | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | IsApplicationAvailable | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | IsAppThemeEnabled | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | IsLiteralContent | (Inherited from System.Web.UI.Control)
Protected Method | IsSessionAvailable | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | LoadControlState | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | LoadViewState | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | OnBubbleEvent | (Inherited from System.Web.UI.Control)
Protected Method | OnDataBinding | (Inherited from System.Web.UI.Control)
Protected Method | OnInit | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | OnLoad | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | OnPreRender | Overridden.
Protected Method | RaiseBubbleEvent | (Inherited from System.Web.UI.Control)
Protected Method | RenderContents | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | ResetFilteredStyle | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | ResolveAdapter | (Inherited from System.Web.UI.Control)
Protected Method | SaveControlState | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | SaveViewState | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | SetDesignModeState | (Inherited from System.Web.UI.Control)
Protected Method | SetTheme | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | ShowAboutBox | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | TrackViewState | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | UseDeepCloneForViewStateStorage | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | UseMemoryStreamStateType | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | WebSpellChecker_Init |
Top

See Also

Reference

WebSpellChecker Class
ISNet.WebUI.WebTextEditor Namespace


CheckConstrains Method

[image]
Intersoft WebTextEditor Documentation
CheckConstrains Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : CheckConstrains Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub CheckConstrains()
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker

instance.CheckConstrains()
C#
public override void CheckConstrains()
Delphi
public procedure CheckConstrains(); override;
JScript
public override function CheckConstrains();
Managed Extensions for C++
public: void CheckConstrains(); override
C++/CLI
public:
void CheckConstrains(); override

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


CreateChildControls Method

[image]
Intersoft WebTextEditor Documentation
CreateChildControls Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : CreateChildControls Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overrides Sub CreateChildControls()
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker

instance.CreateChildControls()
C#
protected override void CreateChildControls()
Delphi
protected procedure CreateChildControls(); override;
JScript
protected override function CreateChildControls();
Managed Extensions for C++
protected: void CreateChildControls(); override
C++/CLI
protected:
void CreateChildControls(); override

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


GetClientAction Method

[image]
Intersoft WebTextEditor Documentation
GetClientAction Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : GetClientAction Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetClientAction() As ISNet.WebUI.BaseClientSideAction
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As ISNet.WebUI.BaseClientSideAction

value = instance.GetClientAction()
C#
public ISNet.WebUI.BaseClientSideAction GetClientAction()
Delphi
public function GetClientAction(): ISNet.WebUI.BaseClientSideAction;
JScript
public function GetClientAction() : ISNet.WebUI.BaseClientSideAction;
Managed Extensions for C++
public: ISNet.WebUI.BaseClientSideAction* GetClientAction();
C++/CLI
public:
ISNet.WebUI.BaseClientSideAction^ GetClientAction();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


GetDHTMLRenderer Method

[image]
Intersoft WebTextEditor Documentation
GetDHTMLRenderer Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : GetDHTMLRenderer Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetDHTMLRenderer() As ISNet.WebUI.RenderDHTML
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As ISNet.WebUI.RenderDHTML

value = instance.GetDHTMLRenderer()
C#
protected override ISNet.WebUI.RenderDHTML GetDHTMLRenderer()
Delphi
protected function GetDHTMLRenderer(): ISNet.WebUI.RenderDHTML; override;
JScript
protected override function GetDHTMLRenderer() : ISNet.WebUI.RenderDHTML;
Managed Extensions for C++
protected: ISNet.WebUI.RenderDHTML* GetDHTMLRenderer(); override
C++/CLI
protected:
ISNet.WebUI.RenderDHTML^ GetDHTMLRenderer(); override

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


GetObjectData Method

[image]
Intersoft WebTextEditor Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


InitializeDefaultStyles Method

[image]
Intersoft WebTextEditor Documentation
InitializeDefaultStyles Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : InitializeDefaultStyles Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overrides Sub InitializeDefaultStyles()
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker

instance.InitializeDefaultStyles()
C#
protected override void InitializeDefaultStyles()
Delphi
protected procedure InitializeDefaultStyles(); override;
JScript
protected override function InitializeDefaultStyles();
Managed Extensions for C++
protected: void InitializeDefaultStyles(); override
C++/CLI
protected:
void InitializeDefaultStyles(); override

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


OnPreRender Method

[image]
Intersoft WebTextEditor Documentation
OnPreRender Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : OnPreRender Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnPreRender( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim e As System.EventArgs

instance.OnPreRender(e)
C#
protected override void OnPreRender(
   System.EventArgs e
)
Delphi
protected procedure OnPreRender(
    e: System.EventArgs
); override;
JScript
protected override function OnPreRender(
   e : System.EventArgs
);
Managed Extensions for C++
protected: void OnPreRender(
   System.EventArgs* e
) override
C++/CLI
protected:
void OnPreRender(
   System.EventArgs^ e
) override

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


RecreateChildControls Method

[image]
Intersoft WebTextEditor Documentation
RecreateChildControls Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : RecreateChildControls Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RecreateChildControls()
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker

instance.RecreateChildControls()
C#
public void RecreateChildControls()
Delphi
public procedure RecreateChildControls();
JScript
public function RecreateChildControls();
Managed Extensions for C++
public: void RecreateChildControls();
C++/CLI
public:
void RecreateChildControls();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


RegisterScript Method

[image]
Intersoft WebTextEditor Documentation
RegisterScript Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : RegisterScript Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub RegisterScript()
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker

instance.RegisterScript()
C#
public override void RegisterScript()
Delphi
public procedure RegisterScript(); override;
JScript
public override function RegisterScript();
Managed Extensions for C++
public: void RegisterScript(); override
C++/CLI
public:
void RegisterScript(); override

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


RenderEndTag Method

[image]
Intersoft WebTextEditor Documentation
RenderEndTag Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : RenderEndTag Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub RenderEndTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderEndTag(writer)
C#
public override void RenderEndTag(
   System.Web.UI.HtmlTextWriter writer
)
Delphi
public procedure RenderEndTag(
    writer: System.Web.UI.HtmlTextWriter
); override;
JScript
public override function RenderEndTag(
   writer : System.Web.UI.HtmlTextWriter
);
Managed Extensions for C++
public: void RenderEndTag(
   System.Web.UI.HtmlTextWriter* writer
) override
C++/CLI
public:
void RenderEndTag(
   System.Web.UI.HtmlTextWriter^ writer
) override

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


WebSpellChecker_Init Method

[image]
Intersoft WebTextEditor Documentation
WebSpellChecker_Init Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : WebSpellChecker_Init Method

sender
e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Sub WebSpellChecker_Init( _
   ByVal sender As System.Object, _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim sender As System.Object
Dim e As System.EventArgs

instance.WebSpellChecker_Init(sender, e)
C#
protected void WebSpellChecker_Init(
   System.object sender,
   System.EventArgs e
)
Delphi
protected procedure WebSpellChecker_Init(
    sender: System.TObject;
    e: System.EventArgs
);
JScript
protected function WebSpellChecker_Init(
   sender : System.Object,
   e : System.EventArgs
);
Managed Extensions for C++
protected: void WebSpellChecker_Init(
   System.Object* sender,
   System.EventArgs* e
)
C++/CLI
protected:
void WebSpellChecker_Init(
   System.Object^ sender,
   System.EventArgs^ e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


WebSpellChecker Class Properties

[image]
Intersoft WebTextEditor Documentation
WebSpellChecker Class Properties
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebSpellChecker Class

Glossary Item Box

For a list of all members of this type, see WebSpellChecker members.

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ActionName |
Public Property | AllowAddToDictionary | Determines whether AddToDictionary menu should appear or not in context menu.
Public Property | AppRelativeTemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | AspNetAjaxSettings | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Attributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BackColor | Overridden.
Public Property | BorderColor | Overridden.
Public Property | BorderStyle | Overridden.
Public Property | BorderWidth | Overridden.
Public Property | ClientID | (Inherited from System.Web.UI.Control)
Public Property | ClientIDMode | (Inherited from System.Web.UI.Control)
Public Property | ClientSideEvents | Contains client side events supported by WebSpellChecker.
Public Property | ContextMenuStyle | Specifies WebSpellChecker's context menu style.
Public Property | ControlDataTransferFormat | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Controls | (Inherited from System.Web.UI.Control)
Public Property | ControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ControlStyleCreated | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | CssClass | Overridden.
Public Property | DialogBoxURL | The WebDialogBox's URL.
Public Property | DictionaryData | The dictionary data collection.
Public Property | DictionaryDirectory | Gets or sets the dictionary directory.
Public Property | Enabled | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableManagedTheming | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | FlyPostBackSettings | Configures the settings used by the control when performing OnTheFly postback.
Public Property | Font | Overridden.
Public Property | ForeColor | Overridden.
Public Property | FormKey |
Public Property | HasAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Height | Overridden.
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | ImagesDirectory | Gets or sets the images directory.
Public Property | ImagesSettings | Provides the settings that control the images in WebSpellChecker.
Public Property | IntegratedToWebTextEditor | Determines whether WebSpellChecker is integrated with WebRichTextEditor
Public Property | IsControlThemed | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | IsDesign | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | IsDynamicCreated | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | IsFlyPostBack |
Public Property | IsInternalCreated | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | IsUnloaded | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | MaximumTextSuggestion | Gets or sets the maximum text suggestion.
Public Property | NamingContainer | (Inherited from System.Web.UI.Control)
Public Property | Page | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Parent | (Inherited from System.Web.UI.Control)
Public Property | ParentStyleId | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RenderingCompatibility | (Inherited from System.Web.UI.Control)
Public Property | RenderingMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RequiresUIRefresh | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RuntimeLicenseKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | SaveViewStateOnFlyPostback | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ScriptDirectory | Overridden. Gets or sets the directory where all required scripts for the control are stored.
Public Property | SerializedJSFiles | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | SerializedStyles | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | SharedScriptDirectory | Overridden. Gets or sets the directory where all required framework scripts for the control are stored.
Public Property | Site | (Inherited from System.Web.UI.Control)
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Style | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | SupportsDisabledAttribute | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | SupportXMLCultureInfo | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | TabIndex | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | TargetControlId | Specifies WebSpellChecker target ControlId.
Public Property | TargetControlIdValue | Gets or sets the TargetControlId's Value.
Public Property | TemplateControl | (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | TextSettings | Provides settings that control text that shown in WebSpellChecker.
Public Property | TextSuggestionCollection | The text suggestion data collection.
Public Property | ToolTip | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | UniqueID | (Inherited from System.Web.UI.Control)
Public Property | ValidateRequestMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateItems | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateServerConnection | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateStorage | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Visible | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | WebDesktopScriptDirectory | Gets or sets the IIS path to locate WebDesktop's script directory. This property is only applicable when SmartWebResources is not enabled.
Public Property | Width | Overridden.
Public Property | XmlCompressionEnabled | (Inherited from ISNet.WebUI.ISNetControl)
Top

Protected Properties

 | Name | Description
Protected Property | Adapter | (Inherited from System.Web.UI.Control)
Protected Property | ChildControlsCreated | (Inherited from System.Web.UI.Control)
Protected Property | ClientIDSeparator | (Inherited from System.Web.UI.Control)
Protected Property | DefaultImagesFolder | Overridden.
Protected Property | Events | (Inherited from System.Web.UI.Control)
Protected Property | HasChildViewState | (Inherited from System.Web.UI.Control)
Protected Property | IdSeparator | (Inherited from System.Web.UI.Control)
Protected Property | IsMvc | (Inherited from ISNet.WebUI.ISNetControl)
Protected Property | IsTrackingViewState | (Inherited from System.Web.UI.Control)
Protected Property | LicenseType | Overridden.
Protected Property | LoadViewStateByID | (Inherited from System.Web.UI.Control)
Protected Property | MaxJsonLength | (Inherited from ISNet.WebUI.ISNetControl)
Protected Property | Product | Overridden.
Protected Property | ProductIcon | Overridden.
Protected Property | ProductImage | Overridden.
Protected Property | TagKey | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Property | TagName | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Property | ViewState | (Inherited from System.Web.UI.Control)
Protected Property | ViewStateIgnoresCase | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

WebSpellChecker Class
ISNet.WebUI.WebTextEditor Namespace


ActionName Property

[image]
Intersoft WebTextEditor Documentation
ActionName Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : ActionName Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
Public Property ActionName As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.String

instance.ActionName = value

value = instance.ActionName
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public System.string ActionName {get; set;}
Delphi
public read-write property ActionName: System.String;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
public function get,set ActionName : System.String
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public: __property System.string* get_ActionName();
public: __property void set_ActionName(
   System.string* value
);
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public:
property System.String^ ActionName {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


AllowAddToDictionary Property

[image]
Intersoft WebTextEditor Documentation
AllowAddToDictionary Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : AllowAddToDictionary Property

Glossary Item Box

Determines whether AddToDictionary menu should appear or not in context menu.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Determines whether AddToDictionary menu should appear or not in context menu.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("SpellChecker")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property AllowAddToDictionary As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Boolean

instance.AllowAddToDictionary = value

value = instance.AllowAddToDictionary
C#
[System.ComponentModel.DescriptionAttribute("Determines whether AddToDictionary menu should appear or not in context menu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("SpellChecker")]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool AllowAddToDictionary {get; set;}
Delphi
public read-write property AllowAddToDictionary: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Determines whether AddToDictionary menu should appear or not in context menu.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("SpellChecker")
System.ComponentModel.DefaultValueAttribute()
public function get,set AllowAddToDictionary : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Determines whether AddToDictionary menu should appear or not in context menu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("SpellChecker")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_AllowAddToDictionary();
public: __property void set_AllowAddToDictionary(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Determines whether AddToDictionary menu should appear or not in context menu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("SpellChecker")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool AllowAddToDictionary {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


BackColor Property

[image]
Intersoft WebTextEditor Documentation
BackColor Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : BackColor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
Public Overrides Property BackColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Drawing.Color

instance.BackColor = value

value = instance.BackColor
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public override System.Drawing.Color BackColor {get; set;}
Delphi
public read-write property BackColor: System.Drawing.Color; override;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
public override function get,set BackColor : System.Drawing.Color
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public: __property System.Drawing.Color get_BackColor() override;
public: __property void set_BackColor(
   System.Drawing.Color value
) override;
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public:
property System.Drawing.Color BackColor {
   System.Drawing.Color get() override;
   void set (    System.Drawing.Color value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


BorderColor Property

[image]
Intersoft WebTextEditor Documentation
BorderColor Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : BorderColor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
Public Overrides Property BorderColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Drawing.Color

instance.BorderColor = value

value = instance.BorderColor
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public override System.Drawing.Color BorderColor {get; set;}
Delphi
public read-write property BorderColor: System.Drawing.Color; override;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
public override function get,set BorderColor : System.Drawing.Color
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public: __property System.Drawing.Color get_BorderColor() override;
public: __property void set_BorderColor(
   System.Drawing.Color value
) override;
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public:
property System.Drawing.Color BorderColor {
   System.Drawing.Color get() override;
   void set (    System.Drawing.Color value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


BorderStyle Property

[image]
Intersoft WebTextEditor Documentation
BorderStyle Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : BorderStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Overrides Property BorderStyle As System.Web.UI.WebControls.BorderStyle
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Web.UI.WebControls.BorderStyle

instance.BorderStyle = value

value = instance.BorderStyle
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public override System.Web.UI.WebControls.BorderStyle BorderStyle {get; set;}
Delphi
public read-write property BorderStyle: System.Web.UI.WebControls.BorderStyle; override;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public override function get,set BorderStyle : System.Web.UI.WebControls.BorderStyle
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property System.Web.UI.WebControls.BorderStyle get_BorderStyle() override;
public: __property void set_BorderStyle(
   System.Web.UI.WebControls.BorderStyle value
) override;
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property System.Web.UI.WebControls.BorderStyle BorderStyle {
   System.Web.UI.WebControls.BorderStyle get() override;
   void set (    System.Web.UI.WebControls.BorderStyle value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


BorderWidth Property

[image]
Intersoft WebTextEditor Documentation
BorderWidth Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : BorderWidth Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
Public Overrides Property BorderWidth As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Web.UI.WebControls.Unit

instance.BorderWidth = value

value = instance.BorderWidth
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public override System.Web.UI.WebControls.Unit BorderWidth {get; set;}
Delphi
public read-write property BorderWidth: System.Web.UI.WebControls.Unit; override;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
public override function get,set BorderWidth : System.Web.UI.WebControls.Unit
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public: __property System.Web.UI.WebControls.Unit get_BorderWidth() override;
public: __property void set_BorderWidth(
   System.Web.UI.WebControls.Unit value
) override;
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public:
property System.Web.UI.WebControls.Unit BorderWidth {
   System.Web.UI.WebControls.Unit get() override;
   void set (    System.Web.UI.WebControls.Unit value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


ClientSideEvents Property

[image]
Intersoft WebTextEditor Documentation
ClientSideEvents Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : ClientSideEvents Property

Glossary Item Box

Contains client side events supported by WebSpellChecker.

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.ComponentModel.DescriptionAttribute("Contains client side events supported by WebSpellChecker.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute(True)>
Public ReadOnly Property ClientSideEvents As WebSpellCheckerClientSideEvents
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As WebSpellCheckerClientSideEvents

value = instance.ClientSideEvents
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DescriptionAttribute("Contains client side events supported by WebSpellChecker.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
public WebSpellCheckerClientSideEvents ClientSideEvents {get;}
Delphi
public read-only property ClientSideEvents: WebSpellCheckerClientSideEvents;
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.ComponentModel.DescriptionAttribute("Contains client side events supported by WebSpellChecker.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Client Side Events")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get ClientSideEvents : WebSpellCheckerClientSideEvents
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DescriptionAttribute("Contains client side events supported by WebSpellChecker.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
public: __property WebSpellCheckerClientSideEvents* get_ClientSideEvents();
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DescriptionAttribute("Contains client side events supported by WebSpellChecker.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
public:
property WebSpellCheckerClientSideEvents^ ClientSideEvents {
   WebSpellCheckerClientSideEvents^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


ContextMenuStyle Property

[image]
Intersoft WebTextEditor Documentation
ContextMenuStyle Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : ContextMenuStyle Property

Glossary Item Box

Specifies WebSpellChecker's context menu style.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("SpellChecker")>
<System.ComponentModel.DescriptionAttribute()>
Public Property ContextMenuStyle As WebSpellCheckerContextMenuStyle
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As WebSpellCheckerContextMenuStyle

instance.ContextMenuStyle = value

value = instance.ContextMenuStyle
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("SpellChecker")]
[System.ComponentModel.DescriptionAttribute()]
public WebSpellCheckerContextMenuStyle ContextMenuStyle {get; set;}
Delphi
public read-write property ContextMenuStyle: WebSpellCheckerContextMenuStyle;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("SpellChecker")
System.ComponentModel.DescriptionAttribute()
public function get,set ContextMenuStyle : WebSpellCheckerContextMenuStyle
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("SpellChecker")]
[System.ComponentModel.DescriptionAttribute()]
public: __property WebSpellCheckerContextMenuStyle get_ContextMenuStyle();
public: __property void set_ContextMenuStyle(
   WebSpellCheckerContextMenuStyle value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("SpellChecker")]
[System.ComponentModel.DescriptionAttribute()]
public:
property WebSpellCheckerContextMenuStyle ContextMenuStyle {
   WebSpellCheckerContextMenuStyle get();
   void set (    WebSpellCheckerContextMenuStyle value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


CssClass Property

[image]
Intersoft WebTextEditor Documentation
CssClass Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : CssClass Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
Public Overrides Property CssClass As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.String

instance.CssClass = value

value = instance.CssClass
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public override System.string CssClass {get; set;}
Delphi
public read-write property CssClass: System.String; override;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
public override function get,set CssClass : System.String
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public: __property System.string* get_CssClass() override;
public: __property void set_CssClass(
   System.string* value
) override;
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public:
property System.String^ CssClass {
   System.String^ get() override;
   void set (    System.String^ value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


DefaultImagesFolder Property

[image]
Intersoft WebTextEditor Documentation
DefaultImagesFolder Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : DefaultImagesFolder Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property DefaultImagesFolder As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.String

value = instance.DefaultImagesFolder
C#
protected override System.string DefaultImagesFolder {get;}
Delphi
protected read-only property DefaultImagesFolder: System.String; override;
JScript
protected override function get DefaultImagesFolder : System.String
Managed Extensions for C++
protected: __property System.string* get_DefaultImagesFolder() override;
C++/CLI
protected:
property System.String^ DefaultImagesFolder {
   System.String^ get() override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


DialogBoxURL Property

[image]
Intersoft WebTextEditor Documentation
DialogBoxURL Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : DialogBoxURL Property

Glossary Item Box

The WebDialogBox's URL.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("SpellChecker")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("The WebDialogBox's URL.")>
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public ReadOnly Property DialogBoxURL As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.String

value = instance.DialogBoxURL
C#
[System.ComponentModel.CategoryAttribute("SpellChecker")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("The WebDialogBox's URL.")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public System.string DialogBoxURL {get;}
Delphi
public read-only property DialogBoxURL: System.String;
JScript
System.ComponentModel.CategoryAttribute("SpellChecker")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("The WebDialogBox's URL.")
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get DialogBoxURL : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("SpellChecker")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("The WebDialogBox's URL.")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property System.string* get_DialogBoxURL();
C++/CLI
[System.ComponentModel.CategoryAttribute("SpellChecker")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("The WebDialogBox's URL.")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property System.String^ DialogBoxURL {
   System.String^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


DictionaryData Property

[image]
Intersoft WebTextEditor Documentation
DictionaryData Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : DictionaryData Property

Glossary Item Box

The dictionary data collection.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("SpellChecker")>
<System.ComponentModel.DescriptionAttribute("The dictionary data collection.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<ISNet.Serialization.BinarySerializableAttribute("setDictionaryDataCollection")>
<System.ComponentModel.BrowsableAttribute(False)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public ReadOnly Property DictionaryData As WebSpellCheckerDictionaryDataCollection
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As WebSpellCheckerDictionaryDataCollection

value = instance.DictionaryData
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("SpellChecker")]
[System.ComponentModel.DescriptionAttribute("The dictionary data collection.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[ISNet.Serialization.BinarySerializableAttribute("setDictionaryDataCollection")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public WebSpellCheckerDictionaryDataCollection DictionaryData {get;}
Delphi
public read-only property DictionaryData: WebSpellCheckerDictionaryDataCollection;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("SpellChecker")
System.ComponentModel.DescriptionAttribute("The dictionary data collection.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
ISNet.Serialization.BinarySerializableAttribute("setDictionaryDataCollection")
System.ComponentModel.BrowsableAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
public function get DictionaryData : WebSpellCheckerDictionaryDataCollection
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("SpellChecker")]
[System.ComponentModel.DescriptionAttribute("The dictionary data collection.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[ISNet.Serialization.BinarySerializableAttribute("setDictionaryDataCollection")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public: __property WebSpellCheckerDictionaryDataCollection* get_DictionaryData();
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("SpellChecker")]
[System.ComponentModel.DescriptionAttribute("The dictionary data collection.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[ISNet.Serialization.BinarySerializableAttribute("setDictionaryDataCollection")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public:
property WebSpellCheckerDictionaryDataCollection^ DictionaryData {
   WebSpellCheckerDictionaryDataCollection^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


DictionaryDirectory Property

[image]
Intersoft WebTextEditor Documentation
DictionaryDirectory Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : DictionaryDirectory Property

Glossary Item Box

Gets or sets the dictionary directory.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the dictionary directory.")>
<System.ComponentModel.CategoryAttribute("SpellChecker")>
Public Property DictionaryDirectory As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.String

instance.DictionaryDirectory = value

value = instance.DictionaryDirectory
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the dictionary directory.")]
[System.ComponentModel.CategoryAttribute("SpellChecker")]
public System.string DictionaryDirectory {get; set;}
Delphi
public read-write property DictionaryDirectory: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the dictionary directory.")
System.ComponentModel.CategoryAttribute("SpellChecker")
public function get,set DictionaryDirectory : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the dictionary directory.")]
[System.ComponentModel.CategoryAttribute("SpellChecker")]
public: __property System.string* get_DictionaryDirectory();
public: __property void set_DictionaryDirectory(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the dictionary directory.")]
[System.ComponentModel.CategoryAttribute("SpellChecker")]
public:
property System.String^ DictionaryDirectory {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


FlyPostBackSettings Property

[image]
Intersoft WebTextEditor Documentation
FlyPostBackSettings Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : FlyPostBackSettings Property

Glossary Item Box

Configures the settings used by the control when performing OnTheFly postback.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Configures the settings used by the control when performing OnTheFly postback.")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public ReadOnly Property FlyPostBackSettings As ISNet.WebUI.FlyPostBackSettings
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As ISNet.WebUI.FlyPostBackSettings

value = instance.FlyPostBackSettings
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Configures the settings used by the control when performing OnTheFly postback.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public ISNet.WebUI.FlyPostBackSettings FlyPostBackSettings {get;}
Delphi
public read-only property FlyPostBackSettings: ISNet.WebUI.FlyPostBackSettings;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Configures the settings used by the control when performing OnTheFly postback.")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
public function get FlyPostBackSettings : ISNet.WebUI.FlyPostBackSettings
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Configures the settings used by the control when performing OnTheFly postback.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public: __property ISNet.WebUI.FlyPostBackSettings* get_FlyPostBackSettings();
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Configures the settings used by the control when performing OnTheFly postback.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public:
property ISNet.WebUI.FlyPostBackSettings^ FlyPostBackSettings {
   ISNet.WebUI.FlyPostBackSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


Font Property

[image]
Intersoft WebTextEditor Documentation
Font Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : Font Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Overrides ReadOnly Property Font As System.Web.UI.WebControls.FontInfo
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Web.UI.WebControls.FontInfo

value = instance.Font
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public override System.Web.UI.WebControls.FontInfo Font {get;}
Delphi
public read-only property Font: System.Web.UI.WebControls.FontInfo; override;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public override function get Font : System.Web.UI.WebControls.FontInfo
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property System.Web.UI.WebControls.FontInfo* get_Font() override;
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property System.Web.UI.WebControls.FontInfo^ Font {
   System.Web.UI.WebControls.FontInfo^ get() override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


ForeColor Property

[image]
Intersoft WebTextEditor Documentation
ForeColor Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : ForeColor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
Public Overrides Property ForeColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Drawing.Color

instance.ForeColor = value

value = instance.ForeColor
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public override System.Drawing.Color ForeColor {get; set;}
Delphi
public read-write property ForeColor: System.Drawing.Color; override;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
public override function get,set ForeColor : System.Drawing.Color
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public: __property System.Drawing.Color get_ForeColor() override;
public: __property void set_ForeColor(
   System.Drawing.Color value
) override;
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public:
property System.Drawing.Color ForeColor {
   System.Drawing.Color get() override;
   void set (    System.Drawing.Color value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


FormKey Property

[image]
Intersoft WebTextEditor Documentation
FormKey Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : FormKey Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
Public ReadOnly Property FormKey As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.String

value = instance.FormKey
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public System.string FormKey {get;}
Delphi
public read-only property FormKey: System.String;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
public function get FormKey : System.String
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public: __property System.string* get_FormKey();
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public:
property System.String^ FormKey {
   System.String^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


Height Property

[image]
Intersoft WebTextEditor Documentation
Height Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : Height Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
Public Overrides Property Height As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Web.UI.WebControls.Unit

instance.Height = value

value = instance.Height
C#
[System.ComponentModel.BrowsableAttribute(false)]
public override System.Web.UI.WebControls.Unit Height {get; set;}
Delphi
public read-write property Height: System.Web.UI.WebControls.Unit; override;
JScript
System.ComponentModel.BrowsableAttribute()
public override function get,set Height : System.Web.UI.WebControls.Unit
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
public: __property System.Web.UI.WebControls.Unit get_Height() override;
public: __property void set_Height(
   System.Web.UI.WebControls.Unit value
) override;
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
public:
property System.Web.UI.WebControls.Unit Height {
   System.Web.UI.WebControls.Unit get() override;
   void set (    System.Web.UI.WebControls.Unit value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


ImagesDirectory Property

[image]
Intersoft WebTextEditor Documentation
ImagesDirectory Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : ImagesDirectory Property

Glossary Item Box

Gets or sets the images directory.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the images directory.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("SpellChecker")>
Public Property ImagesDirectory As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.String

instance.ImagesDirectory = value

value = instance.ImagesDirectory
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the images directory.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("SpellChecker")]
public System.string ImagesDirectory {get; set;}
Delphi
public read-write property ImagesDirectory: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the images directory.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("SpellChecker")
public function get,set ImagesDirectory : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the images directory.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("SpellChecker")]
public: __property System.string* get_ImagesDirectory();
public: __property void set_ImagesDirectory(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the images directory.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("SpellChecker")]
public:
property System.String^ ImagesDirectory {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


ImagesSettings Property

[image]
Intersoft WebTextEditor Documentation
ImagesSettings Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : ImagesSettings Property

Glossary Item Box

Provides the settings that control the images in WebSpellChecker.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute("setImagesSettings")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Provides the settings that control the images in WebSpellChecker.")>
<System.ComponentModel.CategoryAttribute("SpellChecker")>
Public ReadOnly Property ImagesSettings As WebSpellCheckerImagesSettings
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As WebSpellCheckerImagesSettings

value = instance.ImagesSettings
C#
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setImagesSettings")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Provides the settings that control the images in WebSpellChecker.")]
[System.ComponentModel.CategoryAttribute("SpellChecker")]
public WebSpellCheckerImagesSettings ImagesSettings {get;}
Delphi
public read-only property ImagesSettings: WebSpellCheckerImagesSettings;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute("setImagesSettings")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Provides the settings that control the images in WebSpellChecker.")
System.ComponentModel.CategoryAttribute("SpellChecker")
public function get ImagesSettings : WebSpellCheckerImagesSettings
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setImagesSettings")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Provides the settings that control the images in WebSpellChecker.")]
[System.ComponentModel.CategoryAttribute("SpellChecker")]
public: __property WebSpellCheckerImagesSettings* get_ImagesSettings();
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setImagesSettings")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Provides the settings that control the images in WebSpellChecker.")]
[System.ComponentModel.CategoryAttribute("SpellChecker")]
public:
property WebSpellCheckerImagesSettings^ ImagesSettings {
   WebSpellCheckerImagesSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


IntegratedToWebTextEditor Property

[image]
Intersoft WebTextEditor Documentation
IntegratedToWebTextEditor Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : IntegratedToWebTextEditor Property

Glossary Item Box

Determines whether WebSpellChecker is integrated with WebRichTextEditor

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Determines whether WebSpellChecker is integrated with WebRichTextEditor.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("SpellChecker")>
Public Property IntegratedToWebTextEditor As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Boolean

instance.IntegratedToWebTextEditor = value

value = instance.IntegratedToWebTextEditor
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether WebSpellChecker is integrated with WebRichTextEditor.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("SpellChecker")]
public System.bool IntegratedToWebTextEditor {get; set;}
Delphi
public read-write property IntegratedToWebTextEditor: System.Boolean;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Determines whether WebSpellChecker is integrated with WebRichTextEditor.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("SpellChecker")
public function get,set IntegratedToWebTextEditor : System.boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether WebSpellChecker is integrated with WebRichTextEditor.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("SpellChecker")]
public: __property System.bool get_IntegratedToWebTextEditor();
public: __property void set_IntegratedToWebTextEditor(
   System.bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether WebSpellChecker is integrated with WebRichTextEditor.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("SpellChecker")]
public:
property System.bool IntegratedToWebTextEditor {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


IsFlyPostBack Property

[image]
Intersoft WebTextEditor Documentation
IsFlyPostBack Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : IsFlyPostBack Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.DescriptionAttribute("Returns whether this WebSpellChecker instance invokes OnTheFly postback.")>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Property IsFlyPostBack As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Boolean

instance.IsFlyPostBack = value

value = instance.IsFlyPostBack
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.DescriptionAttribute("Returns whether this WebSpellChecker instance invokes OnTheFly postback.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
public System.bool IsFlyPostBack {get; set;}
Delphi
public read-write property IsFlyPostBack: System.Boolean;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.DescriptionAttribute("Returns whether this WebSpellChecker instance invokes OnTheFly postback.")
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set IsFlyPostBack : System.boolean
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.DescriptionAttribute("Returns whether this WebSpellChecker instance invokes OnTheFly postback.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property System.bool get_IsFlyPostBack();
public: __property void set_IsFlyPostBack(
   System.bool value
);
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.DescriptionAttribute("Returns whether this WebSpellChecker instance invokes OnTheFly postback.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
property System.bool IsFlyPostBack {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


LicenseType Property

[image]
Intersoft WebTextEditor Documentation
LicenseType Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : LicenseType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overrides NotOverridable Property LicenseType As ISNet.WebUI.LicType
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As ISNet.WebUI.LicType

instance.LicenseType = value

value = instance.LicenseType
C#
protected override ISNet.WebUI.LicType LicenseType {get; set;}
Delphi
protected read-write property LicenseType: ISNet.WebUI.LicType; override;
JScript
protected override function get,set LicenseType : ISNet.WebUI.LicType
Managed Extensions for C++
protected: __property ISNet.WebUI.LicType get_LicenseType() override;
protected: __property void set_LicenseType(
   ISNet.WebUI.LicType value
) override;
C++/CLI
protected:
property ISNet.WebUI.LicType LicenseType {
   ISNet.WebUI.LicType get() override;
   void set (    ISNet.WebUI.LicType value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


MaximumTextSuggestion Property

[image]
Intersoft WebTextEditor Documentation
MaximumTextSuggestion Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : MaximumTextSuggestion Property

Glossary Item Box

Gets or sets the maximum text suggestion.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the maximum text suggestion.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("SpellChecker")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property MaximumTextSuggestion As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Integer

instance.MaximumTextSuggestion = value

value = instance.MaximumTextSuggestion
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the maximum text suggestion.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("SpellChecker")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.int MaximumTextSuggestion {get; set;}
Delphi
public read-write property MaximumTextSuggestion: System.Integer;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the maximum text suggestion.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("SpellChecker")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set MaximumTextSuggestion : System.int
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the maximum text suggestion.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("SpellChecker")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.int get_MaximumTextSuggestion();
public: __property void set_MaximumTextSuggestion(
   System.int value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the maximum text suggestion.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("SpellChecker")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.int MaximumTextSuggestion {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


Product Property

[image]
Intersoft WebTextEditor Documentation
Product Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : Product Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property Product As ISNet.WebUI.ProductInfo
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As ISNet.WebUI.ProductInfo

value = instance.Product
C#
protected override ISNet.WebUI.ProductInfo Product {get;}
Delphi
protected read-only property Product: ISNet.WebUI.ProductInfo; override;
JScript
protected override function get Product : ISNet.WebUI.ProductInfo
Managed Extensions for C++
protected: __property ISNet.WebUI.ProductInfo* get_Product() override;
C++/CLI
protected:
property ISNet.WebUI.ProductInfo^ Product {
   ISNet.WebUI.ProductInfo^ get() override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


ProductIcon Property

[image]
Intersoft WebTextEditor Documentation
ProductIcon Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : ProductIcon Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property ProductIcon As System.Drawing.Icon
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Drawing.Icon

value = instance.ProductIcon
C#
protected override System.Drawing.Icon ProductIcon {get;}
Delphi
protected read-only property ProductIcon: System.Drawing.Icon; override;
JScript
protected override function get ProductIcon : System.Drawing.Icon
Managed Extensions for C++
protected: __property System.Drawing.Icon* get_ProductIcon() override;
C++/CLI
protected:
property System.Drawing.Icon^ ProductIcon {
   System.Drawing.Icon^ get() override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


ProductImage Property

[image]
Intersoft WebTextEditor Documentation
ProductImage Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : ProductImage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property ProductImage As System.Drawing.Image
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Drawing.Image

value = instance.ProductImage
C#
protected override System.Drawing.Image ProductImage {get;}
Delphi
protected read-only property ProductImage: System.Drawing.Image; override;
JScript
protected override function get ProductImage : System.Drawing.Image
Managed Extensions for C++
protected: __property System.Drawing.Image* get_ProductImage() override;
C++/CLI
protected:
property System.Drawing.Image^ ProductImage {
   System.Drawing.Image^ get() override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


ScriptDirectory Property

[image]
Intersoft WebTextEditor Documentation
ScriptDirectory Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : ScriptDirectory Property

Glossary Item Box

Gets or sets the directory where all required scripts for the control are stored.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required scripts for the control are stored.")>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Client Script Directory")>
Public Overrides Property ScriptDirectory As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.String

instance.ScriptDirectory = value

value = instance.ScriptDirectory
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required scripts for the control are stored.")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
public override System.string ScriptDirectory {get; set;}
Delphi
public read-write property ScriptDirectory: System.String; override;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required scripts for the control are stored.")
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Client Script Directory")
public override function get,set ScriptDirectory : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required scripts for the control are stored.")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
public: __property System.string* get_ScriptDirectory() override;
public: __property void set_ScriptDirectory(
   System.string* value
) override;
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required scripts for the control are stored.")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
public:
property System.String^ ScriptDirectory {
   System.String^ get() override;
   void set (    System.String^ value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


SharedScriptDirectory Property

[image]
Intersoft WebTextEditor Documentation
SharedScriptDirectory Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : SharedScriptDirectory Property

Glossary Item Box

Gets or sets the directory where all required framework scripts for the control are stored.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Client Script Directory")>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required framework scripts for the control are stored.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Overrides Property SharedScriptDirectory As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.String

instance.SharedScriptDirectory = value

value = instance.SharedScriptDirectory
C#
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required framework scripts for the control are stored.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public override System.string SharedScriptDirectory {get; set;}
Delphi
public read-write property SharedScriptDirectory: System.String; override;
JScript
System.ComponentModel.CategoryAttribute("Client Script Directory")
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required framework scripts for the control are stored.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public override function get,set SharedScriptDirectory : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required framework scripts for the control are stored.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_SharedScriptDirectory() override;
public: __property void set_SharedScriptDirectory(
   System.string* value
) override;
C++/CLI
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required framework scripts for the control are stored.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ SharedScriptDirectory {
   System.String^ get() override;
   void set (    System.String^ value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


TargetControlId Property

[image]
Intersoft WebTextEditor Documentation
TargetControlId Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : TargetControlId Property

Glossary Item Box

Specifies WebSpellChecker target ControlId.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the target ControlId of WebSpellChecker.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("SpellChecker")>
<System.Web.UI.IDReferencePropertyAttribute(System.Web.UI.WebControls.WebControl)>
<System.ComponentModel.TypeConverterAttribute("System.Web.UI.WebControls.ControlIDConverter, System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property TargetControlId As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.String

instance.TargetControlId = value

value = instance.TargetControlId
C#
[System.ComponentModel.DescriptionAttribute("Specifies the target ControlId of WebSpellChecker.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("SpellChecker")]
[System.Web.UI.IDReferencePropertyAttribute(System.Web.UI.WebControls.WebControl)]
[System.ComponentModel.TypeConverterAttribute("System.Web.UI.WebControls.ControlIDConverter, System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.string TargetControlId {get; set;}
Delphi
public read-write property TargetControlId: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the target ControlId of WebSpellChecker.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("SpellChecker")
System.Web.UI.IDReferencePropertyAttribute(System.Web.UI.WebControls.WebControl)
System.ComponentModel.TypeConverterAttribute("System.Web.UI.WebControls.ControlIDConverter, System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set TargetControlId : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the target ControlId of WebSpellChecker.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("SpellChecker")]
[System.Web.UI.IDReferencePropertyAttribute(System.Web.UI.WebControls.WebControl)]
[System.ComponentModel.TypeConverterAttribute("System.Web.UI.WebControls.ControlIDConverter, System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_TargetControlId();
public: __property void set_TargetControlId(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the target ControlId of WebSpellChecker.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("SpellChecker")]
[System.Web.UI.IDReferencePropertyAttribute(System.Web.UI.WebControls.WebControl)]
[System.ComponentModel.TypeConverterAttribute("System.Web.UI.WebControls.ControlIDConverter, System.Web, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ TargetControlId {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


TargetControlIdValue Property

[image]
Intersoft WebTextEditor Documentation
TargetControlIdValue Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : TargetControlIdValue Property

Glossary Item Box

Gets or sets the TargetControlId's Value.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the TargetControlId's Value.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("SpellChecker")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property TargetControlIdValue As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.String

instance.TargetControlIdValue = value

value = instance.TargetControlIdValue
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the TargetControlId's Value.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("SpellChecker")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string TargetControlIdValue {get; set;}
Delphi
public read-write property TargetControlIdValue: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the TargetControlId's Value.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("SpellChecker")
System.ComponentModel.DefaultValueAttribute()
public function get,set TargetControlIdValue : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the TargetControlId's Value.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("SpellChecker")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_TargetControlIdValue();
public: __property void set_TargetControlIdValue(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the TargetControlId's Value.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("SpellChecker")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ TargetControlIdValue {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


TextSettings Property

[image]
Intersoft WebTextEditor Documentation
TextSettings Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : TextSettings Property

Glossary Item Box

Provides settings that control text that shown in WebSpellChecker.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("SpellChecker")>
<System.ComponentModel.DescriptionAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public ReadOnly Property TextSettings As WebSpellCheckerTextSettings
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As WebSpellCheckerTextSettings

value = instance.TextSettings
C#
[System.ComponentModel.CategoryAttribute("SpellChecker")]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public WebSpellCheckerTextSettings TextSettings {get;}
Delphi
public read-only property TextSettings: WebSpellCheckerTextSettings;
JScript
System.ComponentModel.CategoryAttribute("SpellChecker")
System.ComponentModel.DescriptionAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
public function get TextSettings : WebSpellCheckerTextSettings
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("SpellChecker")]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public: __property WebSpellCheckerTextSettings* get_TextSettings();
C++/CLI
[System.ComponentModel.CategoryAttribute("SpellChecker")]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public:
property WebSpellCheckerTextSettings^ TextSettings {
   WebSpellCheckerTextSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


TextSuggestionCollection Property

[image]
Intersoft WebTextEditor Documentation
TextSuggestionCollection Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : TextSuggestionCollection Property

Glossary Item Box

The text suggestion data collection.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute("setTextSuggestion")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.CategoryAttribute("SpellChecker")>
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DescriptionAttribute("The text suggestion data collection.")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public ReadOnly Property TextSuggestionCollection As WebSpellCheckerTextSuggestionCollection
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As WebSpellCheckerTextSuggestionCollection

value = instance.TextSuggestionCollection
C#
[ISNet.Serialization.BinarySerializableAttribute("setTextSuggestion")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("SpellChecker")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DescriptionAttribute("The text suggestion data collection.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public WebSpellCheckerTextSuggestionCollection TextSuggestionCollection {get;}
Delphi
public read-only property TextSuggestionCollection: WebSpellCheckerTextSuggestionCollection;
JScript
ISNet.Serialization.BinarySerializableAttribute("setTextSuggestion")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.CategoryAttribute("SpellChecker")
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DescriptionAttribute("The text suggestion data collection.")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get TextSuggestionCollection : WebSpellCheckerTextSuggestionCollection
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute("setTextSuggestion")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("SpellChecker")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DescriptionAttribute("The text suggestion data collection.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property WebSpellCheckerTextSuggestionCollection* get_TextSuggestionCollection();
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute("setTextSuggestion")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("SpellChecker")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DescriptionAttribute("The text suggestion data collection.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property WebSpellCheckerTextSuggestionCollection^ TextSuggestionCollection {
   WebSpellCheckerTextSuggestionCollection^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


WebDesktopScriptDirectory Property

[image]
Intersoft WebTextEditor Documentation
WebDesktopScriptDirectory Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : WebDesktopScriptDirectory Property

Glossary Item Box

Gets or sets the IIS path to locate WebDesktop's script directory. This property is only applicable when SmartWebResources is not enabled.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Client Script Directory")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the IIS path to locate WebDesktop's script directory. This property is only applicable when SmartWebResources is not enabled.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property WebDesktopScriptDirectory As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.String

instance.WebDesktopScriptDirectory = value

value = instance.WebDesktopScriptDirectory
C#
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the IIS path to locate WebDesktop's script directory. This property is only applicable when SmartWebResources is not enabled.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.string WebDesktopScriptDirectory {get; set;}
Delphi
public read-write property WebDesktopScriptDirectory: System.String;
JScript
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Client Script Directory")
System.ComponentModel.DescriptionAttribute("Gets or sets the IIS path to locate WebDesktop's script directory. This property is only applicable when SmartWebResources is not enabled.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set WebDesktopScriptDirectory : System.String
Managed Extensions for C++
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the IIS path to locate WebDesktop's script directory. This property is only applicable when SmartWebResources is not enabled.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_WebDesktopScriptDirectory();
public: __property void set_WebDesktopScriptDirectory(
   System.string* value
);
C++/CLI
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the IIS path to locate WebDesktop's script directory. This property is only applicable when SmartWebResources is not enabled.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ WebDesktopScriptDirectory {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


Width Property

[image]
Intersoft WebTextEditor Documentation
Width Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : Width Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
Public Overrides Property Width As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Web.UI.WebControls.Unit

instance.Width = value

value = instance.Width
C#
[System.ComponentModel.BrowsableAttribute(false)]
public override System.Web.UI.WebControls.Unit Width {get; set;}
Delphi
public read-write property Width: System.Web.UI.WebControls.Unit; override;
JScript
System.ComponentModel.BrowsableAttribute()
public override function get,set Width : System.Web.UI.WebControls.Unit
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
public: __property System.Web.UI.WebControls.Unit get_Width() override;
public: __property void set_Width(
   System.Web.UI.WebControls.Unit value
) override;
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
public:
property System.Web.UI.WebControls.Unit Width {
   System.Web.UI.WebControls.Unit get() override;
   void set (    System.Web.UI.WebControls.Unit value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


WebSpellCheckerClientSideEvents Class

[image]
Intersoft WebTextEditor Documentation
WebSpellCheckerClientSideEvents Class
Members See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebSpellCheckerClientSideEvents Class

Glossary Item Box

A collection of WebSpellChecker's client side events.

Object Model

WebSpellCheckerClientSideEvents Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebSpellCheckerClientSideEvents
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerClientSideEvents
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebSpellCheckerClientSideEvents : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebSpellCheckerClientSideEvents = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebSpellCheckerClientSideEvents extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebSpellCheckerClientSideEvents : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebSpellCheckerClientSideEvents : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebTextEditor.WebSpellCheckerClientSideEvents

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerClientSideEvents Members
ISNet.WebUI.WebTextEditor Namespace


WebSpellCheckerClientSideEvents Class Members

[image]
Intersoft WebTextEditor Documentation
WebSpellCheckerClientSideEvents Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebSpellCheckerClientSideEvents Class

Glossary Item Box

The following tables list the members exposed by WebSpellCheckerClientSideEvents.

Public Constructors

 | Name | Description
Public Constructor | WebSpellCheckerClientSideEvents Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | OnAfterCheckSpell | Gets or sets the event handler after check spell is performed.
Public Property | OnBeforeCheckSpell | Gets or sets the event handler before check spell is performed.
Public Property | OnClickContextMenuItem | Gets or sets the event handler when context menu item is clicked.
Public Property | OnContextMenu | Gets or sets the event handler when WebSpellChecker's context menu is about to be displayed.
Public Property | OnExitSpellCheck | Gets or sets the event handler when exit spell check.
Public Property | OnInitialize | Gets or sets the event handler when WebSpellChecker is initialized.
Public Property | OnReplaceWord | Gets or sets the event handler when WebSpellChecker replace word.
Public Property | OnSpellCheckingCompleted | Gets or sets the event handler when spell checking is completed.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

Protected Methods

 | Name | Description
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | IsInSerializationContext | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSpellCheckerClientSideEvents Class
ISNet.WebUI.WebTextEditor Namespace


WebSpellCheckerClientSideEvents Constructor

[image]
Intersoft WebTextEditor Documentation
WebSpellCheckerClientSideEvents Constructor
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerClientSideEvents Class : WebSpellCheckerClientSideEvents Constructor

Glossary Item Box

Overload List

Overload | Description
WebSpellCheckerClientSideEvents Constructor() |
WebSpellCheckerClientSideEvents Constructor(SerializationInfo,StreamingContext) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerClientSideEvents Class
WebSpellCheckerClientSideEvents Members


WebSpellCheckerClientSideEvents Constructor()

[image]
Intersoft WebTextEditor Documentation
WebSpellCheckerClientSideEvents Constructor()
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerClientSideEvents Class > WebSpellCheckerClientSideEvents Constructor : WebSpellCheckerClientSideEvents Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebSpellCheckerClientSideEvents()
C#
public WebSpellCheckerClientSideEvents()
Delphi
public WebSpellCheckerClientSideEvents();
JScript
public function WebSpellCheckerClientSideEvents();
Managed Extensions for C++
public: WebSpellCheckerClientSideEvents();
C++/CLI
public:
WebSpellCheckerClientSideEvents();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerClientSideEvents Class
WebSpellCheckerClientSideEvents Members
Overload List


WebSpellCheckerClientSideEvents Constructor(SerializationInfo,StreamingContext)

[image]
Intersoft WebTextEditor Documentation
WebSpellCheckerClientSideEvents Constructor(SerializationInfo,StreamingContext)
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerClientSideEvents Class > WebSpellCheckerClientSideEvents Constructor : WebSpellCheckerClientSideEvents Constructor(SerializationInfo,StreamingContext)

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

Dim instance As New WebSpellCheckerClientSideEvents(info, context)
C#
protected WebSpellCheckerClientSideEvents(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
protected WebSpellCheckerClientSideEvents(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
protected function WebSpellCheckerClientSideEvents(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
protected: WebSpellCheckerClientSideEvents(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
protected:
WebSpellCheckerClientSideEvents(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerClientSideEvents Class
WebSpellCheckerClientSideEvents Members
Overload List


WebSpellCheckerClientSideEvents Class Properties

[image]
Intersoft WebTextEditor Documentation
WebSpellCheckerClientSideEvents Class Properties
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebSpellCheckerClientSideEvents Class

Glossary Item Box

For a list of all members of this type, see WebSpellCheckerClientSideEvents members.

Public Properties

 | Name | Description
Public Property | OnAfterCheckSpell | Gets or sets the event handler after check spell is performed.
Public Property | OnBeforeCheckSpell | Gets or sets the event handler before check spell is performed.
Public Property | OnClickContextMenuItem | Gets or sets the event handler when context menu item is clicked.
Public Property | OnContextMenu | Gets or sets the event handler when WebSpellChecker's context menu is about to be displayed.
Public Property | OnExitSpellCheck | Gets or sets the event handler when exit spell check.
Public Property | OnInitialize | Gets or sets the event handler when WebSpellChecker is initialized.
Public Property | OnReplaceWord | Gets or sets the event handler when WebSpellChecker replace word.
Public Property | OnSpellCheckingCompleted | Gets or sets the event handler when spell checking is completed.
Top

See Also

Reference

WebSpellCheckerClientSideEvents Class
ISNet.WebUI.WebTextEditor Namespace


OnAfterCheckSpell Property

[image]
Intersoft WebTextEditor Documentation
OnAfterCheckSpell Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerClientSideEvents Class : OnAfterCheckSpell Property

Glossary Item Box

Gets or sets the event handler after check spell is performed.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.EventParameterAttribute("controlId")>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler after check spell is performed.")>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
Public Property OnAfterCheckSpell As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerClientSideEvents
Dim value As System.String

instance.OnAfterCheckSpell = value

value = instance.OnAfterCheckSpell
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler after check spell is performed.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public System.string OnAfterCheckSpell {get; set;}
Delphi
public read-write property OnAfterCheckSpell: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.EventParameterAttribute("controlId")
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler after check spell is performed.")
System.ComponentModel.CategoryAttribute("Client Side Events")
public function get,set OnAfterCheckSpell : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler after check spell is performed.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public: __property System.string* get_OnAfterCheckSpell();
public: __property void set_OnAfterCheckSpell(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler after check spell is performed.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public:
property System.String^ OnAfterCheckSpell {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerClientSideEvents Class
WebSpellCheckerClientSideEvents Members


OnBeforeCheckSpell Property

[image]
Intersoft WebTextEditor Documentation
OnBeforeCheckSpell Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerClientSideEvents Class : OnBeforeCheckSpell Property

Glossary Item Box

Gets or sets the event handler before check spell is performed.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler before check spell is performed.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.EventParameterAttribute("controlId")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property OnBeforeCheckSpell As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerClientSideEvents
Dim value As System.String

instance.OnBeforeCheckSpell = value

value = instance.OnBeforeCheckSpell
C#
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler before check spell is performed.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.EventParameterAttribute("controlId")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string OnBeforeCheckSpell {get; set;}
Delphi
public read-write property OnBeforeCheckSpell: System.String;
JScript
System.ComponentModel.CategoryAttribute("Client Side Events")
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler before check spell is performed.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.EventParameterAttribute("controlId")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set OnBeforeCheckSpell : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler before check spell is performed.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.EventParameterAttribute("controlId")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_OnBeforeCheckSpell();
public: __property void set_OnBeforeCheckSpell(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler before check spell is performed.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.EventParameterAttribute("controlId")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ OnBeforeCheckSpell {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerClientSideEvents Class
WebSpellCheckerClientSideEvents Members


OnClickContextMenuItem Property

[image]
Intersoft WebTextEditor Documentation
OnClickContextMenuItem Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerClientSideEvents Class : OnClickContextMenuItem Property

Glossary Item Box

Gets or sets the event handler when context menu item is clicked.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when context menu item is clicked.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.EventParameterAttribute("controlId, menuObj, action")>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
Public Property OnClickContextMenuItem As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerClientSideEvents
Dim value As System.String

instance.OnClickContextMenuItem = value

value = instance.OnClickContextMenuItem
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when context menu item is clicked.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, menuObj, action")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public System.string OnClickContextMenuItem {get; set;}
Delphi
public read-write property OnClickContextMenuItem: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when context menu item is clicked.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Client Side Events")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.EventParameterAttribute("controlId, menuObj, action")
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
public function get,set OnClickContextMenuItem : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when context menu item is clicked.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, menuObj, action")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public: __property System.string* get_OnClickContextMenuItem();
public: __property void set_OnClickContextMenuItem(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when context menu item is clicked.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, menuObj, action")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public:
property System.String^ OnClickContextMenuItem {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerClientSideEvents Class
WebSpellCheckerClientSideEvents Members


OnContextMenu Property

[image]
Intersoft WebTextEditor Documentation
OnContextMenu Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerClientSideEvents Class : OnContextMenu Property

Glossary Item Box

Gets or sets the event handler when WebSpellChecker's context menu is about to be displayed.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.EventParameterAttribute("controlId, menuObject, element")>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when WebSpellChecker's context menu is about to be displayed.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property OnContextMenu As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerClientSideEvents
Dim value As System.String

instance.OnContextMenu = value

value = instance.OnContextMenu
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, menuObject, element")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when WebSpellChecker's context menu is about to be displayed.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string OnContextMenu {get; set;}
Delphi
public read-write property OnContextMenu: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.EventParameterAttribute("controlId, menuObject, element")
System.ComponentModel.CategoryAttribute("Client Side Events")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when WebSpellChecker's context menu is about to be displayed.")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set OnContextMenu : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, menuObject, element")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when WebSpellChecker's context menu is about to be displayed.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_OnContextMenu();
public: __property void set_OnContextMenu(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, menuObject, element")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when WebSpellChecker's context menu is about to be displayed.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ OnContextMenu {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerClientSideEvents Class
WebSpellCheckerClientSideEvents Members


OnExitSpellCheck Property

[image]
Intersoft WebTextEditor Documentation
OnExitSpellCheck Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerClientSideEvents Class : OnExitSpellCheck Property

Glossary Item Box

Gets or sets the event handler when exit spell check.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.EventParameterAttribute("controlId")>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when exit spell check.")>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
Public Property OnExitSpellCheck As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerClientSideEvents
Dim value As System.String

instance.OnExitSpellCheck = value

value = instance.OnExitSpellCheck
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when exit spell check.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public System.string OnExitSpellCheck {get; set;}
Delphi
public read-write property OnExitSpellCheck: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.EventParameterAttribute("controlId")
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when exit spell check.")
System.ComponentModel.CategoryAttribute("Client Side Events")
public function get,set OnExitSpellCheck : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when exit spell check.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public: __property System.string* get_OnExitSpellCheck();
public: __property void set_OnExitSpellCheck(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when exit spell check.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public:
property System.String^ OnExitSpellCheck {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerClientSideEvents Class
WebSpellCheckerClientSideEvents Members


OnInitialize Property

[image]
Intersoft WebTextEditor Documentation
OnInitialize Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerClientSideEvents Class : OnInitialize Property

Glossary Item Box

Gets or sets the event handler when WebSpellChecker is initialized.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.EventParameterAttribute("controlId")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when WebSpellChecker is initialized.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
Public Property OnInitialize As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerClientSideEvents
Dim value As System.String

instance.OnInitialize = value

value = instance.OnInitialize
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when WebSpellChecker is initialized.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public System.string OnInitialize {get; set;}
Delphi
public read-write property OnInitialize: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.EventParameterAttribute("controlId")
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when WebSpellChecker is initialized.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Client Side Events")
public function get,set OnInitialize : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when WebSpellChecker is initialized.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public: __property System.string* get_OnInitialize();
public: __property void set_OnInitialize(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when WebSpellChecker is initialized.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public:
property System.String^ OnInitialize {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerClientSideEvents Class
WebSpellCheckerClientSideEvents Members


OnReplaceWord Property

[image]
Intersoft WebTextEditor Documentation
OnReplaceWord Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerClientSideEvents Class : OnReplaceWord Property

Glossary Item Box

Gets or sets the event handler when WebSpellChecker replace word.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.EventParameterAttribute("controlId, menuItem, originalWord, suggestionWords")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when exit spell check.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property OnReplaceWord As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerClientSideEvents
Dim value As System.String

instance.OnReplaceWord = value

value = instance.OnReplaceWord
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, menuItem, originalWord, suggestionWords")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when exit spell check.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string OnReplaceWord {get; set;}
Delphi
public read-write property OnReplaceWord: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.EventParameterAttribute("controlId, menuItem, originalWord, suggestionWords")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Client Side Events")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when exit spell check.")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set OnReplaceWord : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, menuItem, originalWord, suggestionWords")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when exit spell check.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_OnReplaceWord();
public: __property void set_OnReplaceWord(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, menuItem, originalWord, suggestionWords")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when exit spell check.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ OnReplaceWord {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerClientSideEvents Class
WebSpellCheckerClientSideEvents Members


OnSpellCheckingCompleted Property

[image]
Intersoft WebTextEditor Documentation
OnSpellCheckingCompleted Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerClientSideEvents Class : OnSpellCheckingCompleted Property

Glossary Item Box

Gets or sets the event handler when spell checking is completed.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when spell checking is completed.")>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<ISNet.EventParameterAttribute("controlId")>
Public Property OnSpellCheckingCompleted As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerClientSideEvents
Dim value As System.String

instance.OnSpellCheckingCompleted = value

value = instance.OnSpellCheckingCompleted
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when spell checking is completed.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[ISNet.EventParameterAttribute("controlId")]
public System.string OnSpellCheckingCompleted {get; set;}
Delphi
public read-write property OnSpellCheckingCompleted: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when spell checking is completed.")
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Client Side Events")
ISNet.EventParameterAttribute("controlId")
public function get,set OnSpellCheckingCompleted : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when spell checking is completed.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[ISNet.EventParameterAttribute("controlId")]
public: __property System.string* get_OnSpellCheckingCompleted();
public: __property void set_OnSpellCheckingCompleted(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler when spell checking is completed.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[ISNet.EventParameterAttribute("controlId")]
public:
property System.String^ OnSpellCheckingCompleted {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerClientSideEvents Class
WebSpellCheckerClientSideEvents Members


WebSpellCheckerDictionaryData Class

[image]
Intersoft WebTextEditor Documentation
WebSpellCheckerDictionaryData Class
Members See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebSpellCheckerDictionaryData Class

Glossary Item Box

Object Model

WebSpellCheckerDictionaryData Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebSpellCheckerDictionaryData
   Inherits ISNet.WebUI.NamedObjectBase2
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerDictionaryData
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebSpellCheckerDictionaryData : ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
Delphi
public class WebSpellCheckerDictionaryData = class(ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebSpellCheckerDictionaryData extends ISNet.WebUI.NamedObjectBase2 implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebSpellCheckerDictionaryData : public ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebSpellCheckerDictionaryData : public ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.NamedObjectBase2
ISNet.WebUI.WebTextEditor.WebSpellCheckerDictionaryData

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerDictionaryData Members
ISNet.WebUI.WebTextEditor Namespace


WebSpellCheckerDictionaryData Class Members

[image]
Intersoft WebTextEditor Documentation
WebSpellCheckerDictionaryData Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebSpellCheckerDictionaryData Class

Glossary Item Box

The following tables list the members exposed by WebSpellCheckerDictionaryData.

Public Constructors

 | Name | Description
Public Constructor | WebSpellCheckerDictionaryData Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Collection | (Inherited from ISNet.WebUI.NamedObjectBase2)
Public Property | CollectionString | Specifies suggestion text.
Public Property | Name | (Inherited from ISNet.WebUI.NamedObjectBase2)
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

Protected Methods

 | Name | Description
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | IsInSerializationContext | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | OnItemAdd | (Inherited from ISNet.WebUI.NamedObjectBase2)
Protected Method | OnItemRemove | (Inherited from ISNet.WebUI.NamedObjectBase2)
Top

See Also

Reference

WebSpellCheckerDictionaryData Class
ISNet.WebUI.WebTextEditor Namespace


WebSpellCheckerDictionaryData Constructor

[image]
Intersoft WebTextEditor Documentation
WebSpellCheckerDictionaryData Constructor
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerDictionaryData Class : WebSpellCheckerDictionaryData Constructor

Glossary Item Box

Overload List

Overload | Description
WebSpellCheckerDictionaryData Constructor() |
WebSpellCheckerDictionaryData Constructor(SerializationInfo,StreamingContext) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerDictionaryData Class
WebSpellCheckerDictionaryData Members


WebSpellCheckerDictionaryData Constructor()

[image]
Intersoft WebTextEditor Documentation
WebSpellCheckerDictionaryData Constructor()
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerDictionaryData Class > WebSpellCheckerDictionaryData Constructor : WebSpellCheckerDictionaryData Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebSpellCheckerDictionaryData()
C#
public WebSpellCheckerDictionaryData()
Delphi
public WebSpellCheckerDictionaryData();
JScript
public function WebSpellCheckerDictionaryData();
Managed Extensions for C++
public: WebSpellCheckerDictionaryData();
C++/CLI
public:
WebSpellCheckerDictionaryData();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerDictionaryData Class
WebSpellCheckerDictionaryData Members
Overload List


WebSpellCheckerDictionaryData Constructor(SerializationInfo,StreamingContext)

[image]
Intersoft WebTextEditor Documentation
WebSpellCheckerDictionaryData Constructor(SerializationInfo,StreamingContext)
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerDictionaryData Class > WebSpellCheckerDictionaryData Constructor : WebSpellCheckerDictionaryData Constructor(SerializationInfo,StreamingContext)

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

Dim instance As New WebSpellCheckerDictionaryData(info, context)
C#
protected WebSpellCheckerDictionaryData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
protected WebSpellCheckerDictionaryData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
protected function WebSpellCheckerDictionaryData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
protected: WebSpellCheckerDictionaryData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
protected:
WebSpellCheckerDictionaryData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerDictionaryData Class
WebSpellCheckerDictionaryData Members
Overload List


WebSpellCheckerDictionaryData Class Methods

[image]
Intersoft WebTextEditor Documentation
WebSpellCheckerDictionaryData Class Methods
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebSpellCheckerDictionaryData Class

Glossary Item Box

For a list of all members of this type, see WebSpellCheckerDictionaryData members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

Protected Methods

 | Name | Description
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | IsInSerializationContext | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | OnItemAdd | (Inherited from ISNet.WebUI.NamedObjectBase2)
Protected Method | OnItemRemove | (Inherited from ISNet.WebUI.NamedObjectBase2)
Top

See Also

Reference

WebSpellCheckerDictionaryData Class
ISNet.WebUI.WebTextEditor Namespace


GetObjectData Method

[image]
Intersoft WebTextEditor Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerDictionaryData Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerDictionaryData
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerDictionaryData Class
WebSpellCheckerDictionaryData Members


WebSpellCheckerDictionaryData Class Properties

[image]
Intersoft WebTextEditor Documentation
WebSpellCheckerDictionaryData Class Properties
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebSpellCheckerDictionaryData Class

Glossary Item Box

For a list of all members of this type, see WebSpellCheckerDictionaryData members.

Public Properties

 | Name | Description
Public Property | Collection | (Inherited from ISNet.WebUI.NamedObjectBase2)
Public Property | CollectionString | Specifies suggestion text.
Public Property | Name | (Inherited from ISNet.WebUI.NamedObjectBase2)
Top

See Also

Reference

WebSpellCheckerDictionaryData Class
ISNet.WebUI.WebTextEditor Namespace


CollectionString Property

[image]
Intersoft WebTextEditor Documentation
CollectionString Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerDictionaryData Class : CollectionString Property

Glossary Item Box

Specifies suggestion text.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies dictionary collection string.")>
<System.ComponentModel.CategoryAttribute("SpellChecker")>
Public ReadOnly Property CollectionString As System.Collections.Generic.SortedList(Of String,String)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerDictionaryData
Dim value As System.Collections.Generic.SortedList(Of String,String)

value = instance.CollectionString
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies dictionary collection string.")]
[System.ComponentModel.CategoryAttribute("SpellChecker")]
public System.Collections.Generic.SortedList<string,string> CollectionString {get;}
Delphi
public read-only property CollectionString: System.Collections.Generic.SortedList;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies dictionary collection string.")
System.ComponentModel.CategoryAttribute("SpellChecker")
public function get CollectionString : System.Collections.Generic.SortedList
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies dictionary collection string.")]
[System.ComponentModel.CategoryAttribute("SpellChecker")]
public: __property System.Collections.Generic.SortedList<string*,string*>* get_CollectionString();
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies dictionary collection string.")]
[System.ComponentModel.CategoryAttribute("SpellChecker")]
public:
property System.Collections.Generic.SortedList<String^,String^>^ CollectionString {
   System.Collections.Generic.SortedList<String^,String^>^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerDictionaryData Class
WebSpellCheckerDictionaryData Members


WebSpellCheckerDictionaryDataCollection Class

[image]
Intersoft WebTextEditor Documentation
WebSpellCheckerDictionaryDataCollection Class
Members See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebSpellCheckerDictionaryDataCollection Class

Glossary Item Box

Object Model

WebSpellCheckerDictionaryDataCollection Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebSpellCheckerDictionaryDataCollection
   Inherits ISNet.WebUI.ISGenericCollectionBase(Of WebTextEditorMedia)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerDictionaryDataCollection
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebSpellCheckerDictionaryDataCollection : ISNet.WebUI.ISGenericCollectionBase<WebTextEditorMedia>
Delphi
public class WebSpellCheckerDictionaryDataCollection = class(ISNet.WebUI.ISGenericCollectionBase)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebSpellCheckerDictionaryDataCollection extends ISNet.WebUI.ISGenericCollectionBase
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebSpellCheckerDictionaryDataCollection : public ISNet.WebUI.ISGenericCollectionBase<WebTextEditorMedia>
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebSpellCheckerDictionaryDataCollection : public ISNet.WebUI.ISGenericCollectionBase<WebTextEditorMedia>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
ISNet.WebUI.ISCollectionBase<T>
ISNet.WebUI.ISGenericCollectionBase<T>
ISNet.WebUI.WebTextEditor.WebSpellCheckerDictionaryDataCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerDictionaryDataCollection Members
ISNet.WebUI.WebTextEditor Namespace


WebSpellCheckerDictionaryDataCollection Class Members

[image]
Intersoft WebTextEditor Documentation
WebSpellCheckerDictionaryDataCollection Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebSpellCheckerDictionaryDataCollection Class

Glossary Item Box

The following tables list the members exposed by WebSpellCheckerDictionaryDataCollection.

Public Constructors

 | Name | Description
Public Constructor | WebSpellCheckerDictionaryDataCollection Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | All | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

Protected Properties

 | Name | Description
Protected Property | Items | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CreateNewItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorMedia>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | GetNamedItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorMedia>)
Public Method | GetObjectData | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | SerializerConstructor | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorMedia>)
Public Method | SetParent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

Protected Methods

 | Name | Description
Protected Method | ClearItems | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorMedia>)
Protected Method | CreateArray | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Protected Method | InsertItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorMedia>)
Protected Method | RemoveItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorMedia>)
Protected Method | SetItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorMedia>)
Top

See Also

Reference

WebSpellCheckerDictionaryDataCollection Class
ISNet.WebUI.WebTextEditor Namespace


WebSpellCheckerDictionaryDataCollection Constructor

[image]
Intersoft WebTextEditor Documentation
WebSpellCheckerDictionaryDataCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerDictionaryDataCollection Class : WebSpellCheckerDictionaryDataCollection Constructor

Glossary Item Box

Overload List

Overload | Description
WebSpellCheckerDictionaryDataCollection Constructor() |
WebSpellCheckerDictionaryDataCollection Constructor(SerializationInfo,StreamingContext) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerDictionaryDataCollection Class
WebSpellCheckerDictionaryDataCollection Members


WebSpellCheckerDictionaryDataCollection Constructor()

[image]
Intersoft WebTextEditor Documentation
WebSpellCheckerDictionaryDataCollection Constructor()
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerDictionaryDataCollection Class > WebSpellCheckerDictionaryDataCollection Constructor : WebSpellCheckerDictionaryDataCollection Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebSpellCheckerDictionaryDataCollection()
C#
public WebSpellCheckerDictionaryDataCollection()
Delphi
public WebSpellCheckerDictionaryDataCollection();
JScript
public function WebSpellCheckerDictionaryDataCollection();
Managed Extensions for C++
public: WebSpellCheckerDictionaryDataCollection();
C++/CLI
public:
WebSpellCheckerDictionaryDataCollection();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerDictionaryDataCollection Class
WebSpellCheckerDictionaryDataCollection Members
Overload List


WebSpellCheckerDictionaryDataCollection Constructor(SerializationInfo,StreamingContext)

[image]
Intersoft WebTextEditor Documentation
WebSpellCheckerDictionaryDataCollection Constructor(SerializationInfo,StreamingContext)
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerDictionaryDataCollection Class > WebSpellCheckerDictionaryDataCollection Constructor : WebSpellCheckerDictionaryDataCollection Constructor(SerializationInfo,StreamingContext)

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

Dim instance As New WebSpellCheckerDictionaryDataCollection(info, context)
C#
protected WebSpellCheckerDictionaryDataCollection(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
protected WebSpellCheckerDictionaryDataCollection(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
protected function WebSpellCheckerDictionaryDataCollection(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
protected: WebSpellCheckerDictionaryDataCollection(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
protected:
WebSpellCheckerDictionaryDataCollection(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerDictionaryDataCollection Class
WebSpellCheckerDictionaryDataCollection Members
Overload List


WebSpellCheckerImagesSettings Class

[image]
Intersoft WebTextEditor Documentation
WebSpellCheckerImagesSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebSpellCheckerImagesSettings Class

Glossary Item Box

A collection of WebSpellChecker's images settings.

Object Model

WebSpellCheckerImagesSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebSpellCheckerImagesSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerImagesSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebSpellCheckerImagesSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebSpellCheckerImagesSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebSpellCheckerImagesSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebSpellCheckerImagesSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebSpellCheckerImagesSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebTextEditor.WebSpellCheckerImagesSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerImagesSettings Members
ISNet.WebUI.WebTextEditor Namespace


WebSpellCheckerImagesSettings Class Members

[image]
Intersoft WebTextEditor Documentation
WebSpellCheckerImagesSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebSpellCheckerImagesSettings Class

Glossary Item Box

The following tables list the members exposed by WebSpellCheckerImagesSettings.

Public Constructors

 | Name | Description
Public Constructor | WebSpellCheckerImagesSettings Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | ErrorLine | Gets or sets the default image used for error line.
Public Property | InProgress | Gets or sets the default image used for in progress status.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

Protected Methods

 | Name | Description
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | IsInSerializationContext | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSpellCheckerImagesSettings Class
ISNet.WebUI.WebTextEditor Namespace


WebSpellCheckerImagesSettings Constructor

[image]
Intersoft WebTextEditor Documentation
WebSpellCheckerImagesSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerImagesSettings Class : WebSpellCheckerImagesSettings Constructor

Glossary Item Box

Overload List

Overload | Description
WebSpellCheckerImagesSettings Constructor() |
WebSpellCheckerImagesSettings Constructor(SerializationInfo,StreamingContext) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerImagesSettings Class
WebSpellCheckerImagesSettings Members


WebSpellCheckerImagesSettings Constructor()

[image]
Intersoft WebTextEditor Documentation
WebSpellCheckerImagesSettings Constructor()
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerImagesSettings Class > WebSpellCheckerImagesSettings Constructor : WebSpellCheckerImagesSettings Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebSpellCheckerImagesSettings()
C#
public WebSpellCheckerImagesSettings()
Delphi
public WebSpellCheckerImagesSettings();
JScript
public function WebSpellCheckerImagesSettings();
Managed Extensions for C++
public: WebSpellCheckerImagesSettings();
C++/CLI
public:
WebSpellCheckerImagesSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerImagesSettings Class
WebSpellCheckerImagesSettings Members
Overload List


WebSpellCheckerImagesSettings Constructor(SerializationInfo,StreamingContext)

[image]
Intersoft WebTextEditor Documentation
WebSpellCheckerImagesSettings Constructor(SerializationInfo,StreamingContext)
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerImagesSettings Class > WebSpellCheckerImagesSettings Constructor : WebSpellCheckerImagesSettings Constructor(SerializationInfo,StreamingContext)

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

Dim instance As New WebSpellCheckerImagesSettings(info, context)
C#
protected WebSpellCheckerImagesSettings(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
protected WebSpellCheckerImagesSettings(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
protected function WebSpellCheckerImagesSettings(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
protected: WebSpellCheckerImagesSettings(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
protected:
WebSpellCheckerImagesSettings(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerImagesSettings Class
WebSpellCheckerImagesSettings Members
Overload List


WebSpellCheckerImagesSettings Class Methods

[image]
Intersoft WebTextEditor Documentation
WebSpellCheckerImagesSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebSpellCheckerImagesSettings Class

Glossary Item Box

For a list of all members of this type, see WebSpellCheckerImagesSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

Protected Methods

 | Name | Description
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | IsInSerializationContext | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSpellCheckerImagesSettings Class
ISNet.WebUI.WebTextEditor Namespace


GetObjectData Method

[image]
Intersoft WebTextEditor Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerImagesSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerImagesSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerImagesSettings Class
WebSpellCheckerImagesSettings Members


WebSpellCheckerImagesSettings Class Properties

[image]
Intersoft WebTextEditor Documentation
WebSpellCheckerImagesSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebSpellCheckerImagesSettings Class

Glossary Item Box

For a list of all members of this type, see WebSpellCheckerImagesSettings members.

Public Properties

 | Name | Description
Public Property | ErrorLine | Gets or sets the default image used for error line.
Public Property | InProgress | Gets or sets the default image used for in progress status.
Top

See Also

Reference

WebSpellCheckerImagesSettings Class
ISNet.WebUI.WebTextEditor Namespace


ErrorLine Property

[image]
Intersoft WebTextEditor Documentation
ErrorLine Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerImagesSettings Class : ErrorLine Property

Glossary Item Box

Gets or sets the default image used for error line.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for error line.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property ErrorLine As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerImagesSettings
Dim value As System.String

instance.ErrorLine = value

value = instance.ErrorLine
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for error line.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string ErrorLine {get; set;}
Delphi
public read-write property ErrorLine: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for error line.")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set ErrorLine : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for error line.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_ErrorLine();
public: __property void set_ErrorLine(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for error line.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ ErrorLine {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerImagesSettings Class
WebSpellCheckerImagesSettings Members


InProgress Property

[image]
Intersoft WebTextEditor Documentation
InProgress Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerImagesSettings Class : InProgress Property

Glossary Item Box

Gets or sets the default image used for in progress status.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for in progress status.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property InProgress As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerImagesSettings
Dim value As System.String

instance.InProgress = value

value = instance.InProgress
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for in progress status.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string InProgress {get; set;}
Delphi
public read-write property InProgress: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for in progress status.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set InProgress : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for in progress status.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_InProgress();
public: __property void set_InProgress(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the default image used for in progress status.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ InProgress {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerImagesSettings Class
WebSpellCheckerImagesSettings Members


WebSpellCheckerTextSettings Class

[image]
Intersoft WebTextEditor Documentation
WebSpellCheckerTextSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebSpellCheckerTextSettings Class

Glossary Item Box

A collection of settings which controls the text shown in WebSpellChecker.

Object Model

WebSpellCheckerTextSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebSpellCheckerTextSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerTextSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebSpellCheckerTextSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebSpellCheckerTextSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebSpellCheckerTextSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebSpellCheckerTextSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebSpellCheckerTextSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebTextEditor.WebSpellCheckerTextSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerTextSettings Members
ISNet.WebUI.WebTextEditor Namespace


WebSpellCheckerTextSettings Class Members

[image]
Intersoft WebTextEditor Documentation
WebSpellCheckerTextSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebSpellCheckerTextSettings Class

Glossary Item Box

The following tables list the members exposed by WebSpellCheckerTextSettings.

Public Constructors

 | Name | Description
Public Constructor | WebSpellCheckerTextSettings Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | AddToDictionaryText | Specifies the text of add to dictionary text in content menu.
Public Property | IgnoreAllText | Specifies the text of ignore all text option in content menu.
Public Property | IgnoreText | Specifies the text of ignore option in content menu.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

Protected Methods

 | Name | Description
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | IsInSerializationContext | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSpellCheckerTextSettings Class
ISNet.WebUI.WebTextEditor Namespace


WebSpellCheckerTextSettings Constructor

[image]
Intersoft WebTextEditor Documentation
WebSpellCheckerTextSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerTextSettings Class : WebSpellCheckerTextSettings Constructor

Glossary Item Box

Overload List

Overload | Description
WebSpellCheckerTextSettings Constructor() |
WebSpellCheckerTextSettings Constructor(SerializationInfo,StreamingContext) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerTextSettings Class
WebSpellCheckerTextSettings Members


WebSpellCheckerTextSettings Constructor()

[image]
Intersoft WebTextEditor Documentation
WebSpellCheckerTextSettings Constructor()
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerTextSettings Class > WebSpellCheckerTextSettings Constructor : WebSpellCheckerTextSettings Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebSpellCheckerTextSettings()
C#
public WebSpellCheckerTextSettings()
Delphi
public WebSpellCheckerTextSettings();
JScript
public function WebSpellCheckerTextSettings();
Managed Extensions for C++
public: WebSpellCheckerTextSettings();
C++/CLI
public:
WebSpellCheckerTextSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerTextSettings Class
WebSpellCheckerTextSettings Members
Overload List


WebSpellCheckerTextSettings Constructor(SerializationInfo,StreamingContext)

[image]
Intersoft WebTextEditor Documentation
WebSpellCheckerTextSettings Constructor(SerializationInfo,StreamingContext)
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerTextSettings Class > WebSpellCheckerTextSettings Constructor : WebSpellCheckerTextSettings Constructor(SerializationInfo,StreamingContext)

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

Dim instance As New WebSpellCheckerTextSettings(info, context)
C#
protected WebSpellCheckerTextSettings(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
protected WebSpellCheckerTextSettings(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
protected function WebSpellCheckerTextSettings(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
protected: WebSpellCheckerTextSettings(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
protected:
WebSpellCheckerTextSettings(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerTextSettings Class
WebSpellCheckerTextSettings Members
Overload List


WebSpellCheckerTextSettings Class Methods

[image]
Intersoft WebTextEditor Documentation
WebSpellCheckerTextSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebSpellCheckerTextSettings Class

Glossary Item Box

For a list of all members of this type, see WebSpellCheckerTextSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

Protected Methods

 | Name | Description
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | IsInSerializationContext | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSpellCheckerTextSettings Class
ISNet.WebUI.WebTextEditor Namespace


GetObjectData Method

[image]
Intersoft WebTextEditor Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerTextSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerTextSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerTextSettings Class
WebSpellCheckerTextSettings Members


WebSpellCheckerTextSettings Class Properties

[image]
Intersoft WebTextEditor Documentation
WebSpellCheckerTextSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebSpellCheckerTextSettings Class

Glossary Item Box

For a list of all members of this type, see WebSpellCheckerTextSettings members.

Public Properties

 | Name | Description
Public Property | AddToDictionaryText | Specifies the text of add to dictionary text in content menu.
Public Property | IgnoreAllText | Specifies the text of ignore all text option in content menu.
Public Property | IgnoreText | Specifies the text of ignore option in content menu.
Top

See Also

Reference

WebSpellCheckerTextSettings Class
ISNet.WebUI.WebTextEditor Namespace


AddToDictionaryText Property

[image]
Intersoft WebTextEditor Documentation
AddToDictionaryText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerTextSettings Class : AddToDictionaryText Property

Glossary Item Box

Specifies the text of add to dictionary text in content menu.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the text of add to dictionary option in content menu.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("SpellChecker")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property AddToDictionaryText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerTextSettings
Dim value As System.String

instance.AddToDictionaryText = value

value = instance.AddToDictionaryText
C#
[System.ComponentModel.DescriptionAttribute("Specifies the text of add to dictionary option in content menu.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("SpellChecker")]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string AddToDictionaryText {get; set;}
Delphi
public read-write property AddToDictionaryText: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the text of add to dictionary option in content menu.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("SpellChecker")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set AddToDictionaryText : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the text of add to dictionary option in content menu.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("SpellChecker")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_AddToDictionaryText();
public: __property void set_AddToDictionaryText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the text of add to dictionary option in content menu.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("SpellChecker")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ AddToDictionaryText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerTextSettings Class
WebSpellCheckerTextSettings Members


IgnoreAllText Property

[image]
Intersoft WebTextEditor Documentation
IgnoreAllText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerTextSettings Class : IgnoreAllText Property

Glossary Item Box

Specifies the text of ignore all text option in content menu.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("SpellChecker")>
<System.ComponentModel.DescriptionAttribute("Specifies the text of ignore all text option in content menu.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property IgnoreAllText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerTextSettings
Dim value As System.String

instance.IgnoreAllText = value

value = instance.IgnoreAllText
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("SpellChecker")]
[System.ComponentModel.DescriptionAttribute("Specifies the text of ignore all text option in content menu.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string IgnoreAllText {get; set;}
Delphi
public read-write property IgnoreAllText: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("SpellChecker")
System.ComponentModel.DescriptionAttribute("Specifies the text of ignore all text option in content menu.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set IgnoreAllText : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("SpellChecker")]
[System.ComponentModel.DescriptionAttribute("Specifies the text of ignore all text option in content menu.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_IgnoreAllText();
public: __property void set_IgnoreAllText(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("SpellChecker")]
[System.ComponentModel.DescriptionAttribute("Specifies the text of ignore all text option in content menu.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ IgnoreAllText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerTextSettings Class
WebSpellCheckerTextSettings Members


IgnoreText Property

[image]
Intersoft WebTextEditor Documentation
IgnoreText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerTextSettings Class : IgnoreText Property

Glossary Item Box

Specifies the text of ignore option in content menu.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the text of ignore option in content menu.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("SpellChecker")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property IgnoreText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerTextSettings
Dim value As System.String

instance.IgnoreText = value

value = instance.IgnoreText
C#
[System.ComponentModel.DescriptionAttribute("Specifies the text of ignore option in content menu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("SpellChecker")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.string IgnoreText {get; set;}
Delphi
public read-write property IgnoreText: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the text of ignore option in content menu.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("SpellChecker")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set IgnoreText : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the text of ignore option in content menu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("SpellChecker")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_IgnoreText();
public: __property void set_IgnoreText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the text of ignore option in content menu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("SpellChecker")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ IgnoreText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerTextSettings Class
WebSpellCheckerTextSettings Members


WebSpellCheckerTextSuggestion Class

[image]
Intersoft WebTextEditor Documentation
WebSpellCheckerTextSuggestion Class
Members See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebSpellCheckerTextSuggestion Class

Glossary Item Box

A collection of WebSpellChecker's text suggestion settings.

Object Model

WebSpellCheckerTextSuggestion Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebSpellCheckerTextSuggestion
   Inherits ISNet.WebUI.NamedObjectBase2
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerTextSuggestion
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebSpellCheckerTextSuggestion : ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
Delphi
public class WebSpellCheckerTextSuggestion = class(ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebSpellCheckerTextSuggestion extends ISNet.WebUI.NamedObjectBase2 implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebSpellCheckerTextSuggestion : public ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebSpellCheckerTextSuggestion : public ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.NamedObjectBase2
ISNet.WebUI.WebTextEditor.WebSpellCheckerTextSuggestion

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerTextSuggestion Members
ISNet.WebUI.WebTextEditor Namespace


WebSpellCheckerTextSuggestion Class Members

[image]
Intersoft WebTextEditor Documentation
WebSpellCheckerTextSuggestion Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebSpellCheckerTextSuggestion Class

Glossary Item Box

The following tables list the members exposed by WebSpellCheckerTextSuggestion.

Public Constructors

 | Name | Description
Public Constructor | WebSpellCheckerTextSuggestion Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Collection | (Inherited from ISNet.WebUI.NamedObjectBase2)
Public Property | Name | (Inherited from ISNet.WebUI.NamedObjectBase2)
Public Property | OriginalText | Specifies original text.
Public Property | SuggestionText | Specifies suggestion text.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

Protected Methods

 | Name | Description
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | IsInSerializationContext | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | OnItemAdd | (Inherited from ISNet.WebUI.NamedObjectBase2)
Protected Method | OnItemRemove | (Inherited from ISNet.WebUI.NamedObjectBase2)
Top

See Also

Reference

WebSpellCheckerTextSuggestion Class
ISNet.WebUI.WebTextEditor Namespace


WebSpellCheckerTextSuggestion Constructor

[image]
Intersoft WebTextEditor Documentation
WebSpellCheckerTextSuggestion Constructor
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerTextSuggestion Class : WebSpellCheckerTextSuggestion Constructor

Glossary Item Box

Overload List

Overload | Description
WebSpellCheckerTextSuggestion Constructor() |
WebSpellCheckerTextSuggestion Constructor(SerializationInfo,StreamingContext) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerTextSuggestion Class
WebSpellCheckerTextSuggestion Members


WebSpellCheckerTextSuggestion Constructor()

[image]
Intersoft WebTextEditor Documentation
WebSpellCheckerTextSuggestion Constructor()
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerTextSuggestion Class > WebSpellCheckerTextSuggestion Constructor : WebSpellCheckerTextSuggestion Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebSpellCheckerTextSuggestion()
C#
public WebSpellCheckerTextSuggestion()
Delphi
public WebSpellCheckerTextSuggestion();
JScript
public function WebSpellCheckerTextSuggestion();
Managed Extensions for C++
public: WebSpellCheckerTextSuggestion();
C++/CLI
public:
WebSpellCheckerTextSuggestion();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerTextSuggestion Class
WebSpellCheckerTextSuggestion Members
Overload List


WebSpellCheckerTextSuggestion Constructor(SerializationInfo,StreamingContext)

[image]
Intersoft WebTextEditor Documentation
WebSpellCheckerTextSuggestion Constructor(SerializationInfo,StreamingContext)
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerTextSuggestion Class > WebSpellCheckerTextSuggestion Constructor : WebSpellCheckerTextSuggestion Constructor(SerializationInfo,StreamingContext)

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

Dim instance As New WebSpellCheckerTextSuggestion(info, context)
C#
protected WebSpellCheckerTextSuggestion(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
protected WebSpellCheckerTextSuggestion(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
protected function WebSpellCheckerTextSuggestion(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
protected: WebSpellCheckerTextSuggestion(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
protected:
WebSpellCheckerTextSuggestion(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerTextSuggestion Class
WebSpellCheckerTextSuggestion Members
Overload List


WebSpellCheckerTextSuggestion Class Methods

[image]
Intersoft WebTextEditor Documentation
WebSpellCheckerTextSuggestion Class Methods
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebSpellCheckerTextSuggestion Class

Glossary Item Box

For a list of all members of this type, see WebSpellCheckerTextSuggestion members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

Protected Methods

 | Name | Description
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | IsInSerializationContext | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | OnItemAdd | (Inherited from ISNet.WebUI.NamedObjectBase2)
Protected Method | OnItemRemove | (Inherited from ISNet.WebUI.NamedObjectBase2)
Top

See Also

Reference

WebSpellCheckerTextSuggestion Class
ISNet.WebUI.WebTextEditor Namespace


GetObjectData Method

[image]
Intersoft WebTextEditor Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerTextSuggestion Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerTextSuggestion
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerTextSuggestion Class
WebSpellCheckerTextSuggestion Members


WebSpellCheckerTextSuggestion Class Properties

[image]
Intersoft WebTextEditor Documentation
WebSpellCheckerTextSuggestion Class Properties
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebSpellCheckerTextSuggestion Class

Glossary Item Box

For a list of all members of this type, see WebSpellCheckerTextSuggestion members.

Public Properties

 | Name | Description
Public Property | Collection | (Inherited from ISNet.WebUI.NamedObjectBase2)
Public Property | Name | (Inherited from ISNet.WebUI.NamedObjectBase2)
Public Property | OriginalText | Specifies original text.
Public Property | SuggestionText | Specifies suggestion text.
Top

See Also

Reference

WebSpellCheckerTextSuggestion Class
ISNet.WebUI.WebTextEditor Namespace


OriginalText Property

[image]
Intersoft WebTextEditor Documentation
OriginalText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerTextSuggestion Class : OriginalText Property

Glossary Item Box

Specifies original text.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("SpellChecker")>
<System.ComponentModel.DescriptionAttribute("Specifies original text.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property OriginalText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerTextSuggestion
Dim value As System.String

instance.OriginalText = value

value = instance.OriginalText
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("SpellChecker")]
[System.ComponentModel.DescriptionAttribute("Specifies original text.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string OriginalText {get; set;}
Delphi
public read-write property OriginalText: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("SpellChecker")
System.ComponentModel.DescriptionAttribute("Specifies original text.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set OriginalText : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("SpellChecker")]
[System.ComponentModel.DescriptionAttribute("Specifies original text.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_OriginalText();
public: __property void set_OriginalText(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("SpellChecker")]
[System.ComponentModel.DescriptionAttribute("Specifies original text.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ OriginalText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerTextSuggestion Class
WebSpellCheckerTextSuggestion Members


SuggestionText Property

[image]
Intersoft WebTextEditor Documentation
SuggestionText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerTextSuggestion Class : SuggestionText Property

Glossary Item Box

Specifies suggestion text.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies suggestion text.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("SpellChecker")>
Public Property SuggestionText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerTextSuggestion
Dim value As System.String

instance.SuggestionText = value

value = instance.SuggestionText
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies suggestion text.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("SpellChecker")]
public System.string SuggestionText {get; set;}
Delphi
public read-write property SuggestionText: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies suggestion text.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("SpellChecker")
public function get,set SuggestionText : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies suggestion text.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("SpellChecker")]
public: __property System.string* get_SuggestionText();
public: __property void set_SuggestionText(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies suggestion text.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("SpellChecker")]
public:
property System.String^ SuggestionText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerTextSuggestion Class
WebSpellCheckerTextSuggestion Members


WebSpellCheckerTextSuggestionCollection Class

[image]
Intersoft WebTextEditor Documentation
WebSpellCheckerTextSuggestionCollection Class
Members See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebSpellCheckerTextSuggestionCollection Class

Glossary Item Box

A collection of text suggestion used by WebSpellChecker.

Object Model

WebSpellCheckerTextSuggestionCollection Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebSpellCheckerTextSuggestionCollection
   Inherits ISNet.WebUI.ISGenericCollectionBase(Of WebTextEditorMedia)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerTextSuggestionCollection
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebSpellCheckerTextSuggestionCollection : ISNet.WebUI.ISGenericCollectionBase<WebTextEditorMedia>
Delphi
public class WebSpellCheckerTextSuggestionCollection = class(ISNet.WebUI.ISGenericCollectionBase)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebSpellCheckerTextSuggestionCollection extends ISNet.WebUI.ISGenericCollectionBase
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebSpellCheckerTextSuggestionCollection : public ISNet.WebUI.ISGenericCollectionBase<WebTextEditorMedia>
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebSpellCheckerTextSuggestionCollection : public ISNet.WebUI.ISGenericCollectionBase<WebTextEditorMedia>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
ISNet.WebUI.ISCollectionBase<T>
ISNet.WebUI.ISGenericCollectionBase<T>
ISNet.WebUI.WebTextEditor.WebSpellCheckerTextSuggestionCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerTextSuggestionCollection Members
ISNet.WebUI.WebTextEditor Namespace


WebSpellCheckerTextSuggestionCollection Class Members

[image]
Intersoft WebTextEditor Documentation
WebSpellCheckerTextSuggestionCollection Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebSpellCheckerTextSuggestionCollection Class

Glossary Item Box

The following tables list the members exposed by WebSpellCheckerTextSuggestionCollection.

Public Constructors

 | Name | Description
Public Constructor | WebSpellCheckerTextSuggestionCollection Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | All | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

Protected Properties

 | Name | Description
Protected Property | Items | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CreateNewItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorMedia>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | GetNamedItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorMedia>)
Public Method | GetObjectData | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | SerializerConstructor | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorMedia>)
Public Method | SetParent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

Protected Methods

 | Name | Description
Protected Method | ClearItems | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorMedia>)
Protected Method | CreateArray | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Protected Method | InsertItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorMedia>)
Protected Method | RemoveItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorMedia>)
Protected Method | SetItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorMedia>)
Top

See Also

Reference

WebSpellCheckerTextSuggestionCollection Class
ISNet.WebUI.WebTextEditor Namespace


WebSpellCheckerTextSuggestionCollection Constructor

[image]
Intersoft WebTextEditor Documentation
WebSpellCheckerTextSuggestionCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerTextSuggestionCollection Class : WebSpellCheckerTextSuggestionCollection Constructor

Glossary Item Box

Overload List

Overload | Description
WebSpellCheckerTextSuggestionCollection Constructor() |
WebSpellCheckerTextSuggestionCollection Constructor(SerializationInfo,StreamingContext) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerTextSuggestionCollection Class
WebSpellCheckerTextSuggestionCollection Members


WebSpellCheckerTextSuggestionCollection Constructor()

[image]
Intersoft WebTextEditor Documentation
WebSpellCheckerTextSuggestionCollection Constructor()
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerTextSuggestionCollection Class > WebSpellCheckerTextSuggestionCollection Constructor : WebSpellCheckerTextSuggestionCollection Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebSpellCheckerTextSuggestionCollection()
C#
public WebSpellCheckerTextSuggestionCollection()
Delphi
public WebSpellCheckerTextSuggestionCollection();
JScript
public function WebSpellCheckerTextSuggestionCollection();
Managed Extensions for C++
public: WebSpellCheckerTextSuggestionCollection();
C++/CLI
public:
WebSpellCheckerTextSuggestionCollection();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerTextSuggestionCollection Class
WebSpellCheckerTextSuggestionCollection Members
Overload List


WebSpellCheckerTextSuggestionCollection Constructor(SerializationInfo,StreamingContext)

[image]
Intersoft WebTextEditor Documentation
WebSpellCheckerTextSuggestionCollection Constructor(SerializationInfo,StreamingContext)
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerTextSuggestionCollection Class > WebSpellCheckerTextSuggestionCollection Constructor : WebSpellCheckerTextSuggestionCollection Constructor(SerializationInfo,StreamingContext)

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

Dim instance As New WebSpellCheckerTextSuggestionCollection(info, context)
C#
protected WebSpellCheckerTextSuggestionCollection(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
protected WebSpellCheckerTextSuggestionCollection(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
protected function WebSpellCheckerTextSuggestionCollection(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
protected: WebSpellCheckerTextSuggestionCollection(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
protected:
WebSpellCheckerTextSuggestionCollection(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerTextSuggestionCollection Class
WebSpellCheckerTextSuggestionCollection Members
Overload List


WebTextEditor Class

[image]
Intersoft WebTextEditor Documentation
WebTextEditor Class
Members See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditor Class

Glossary Item Box

Intersoft WebTextEditor is a business-oriented text editor that seamlessly combines innovative features, elegant interface and great UX in a single box! With multitude of rich editing features – such as built-in media gallery, table designer, innovative red-wave highlight spell checker, and real-progress file uploader – WebTextEditor rediscovers the art of editing, and makes content authoring easier, simpler and more intuitive.

Object Model

WebTextEditor Class

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ISNet.WebUI.WebTextEditor.WebTextEditorDesigner, ISNet.WebUI.WebTextEditor, Version=1.0.1000.9, Culture=neutral, PublicKeyToken=b1f2a8511635667a")>
<System.Web.UI.ToolboxDataAttribute("<{0}:WebTextEditor runat=server Width="700px" Height="500px"></{0}:WebTextEditor>")>
<ISNet.Serialization.XmlSerializableAttribute(JSFileNames="WebTextEditor.js;WebTextEditor_Render.js;WebTextEditor_Editor.js;WebTextEditor_Helper.js;WebTextEditor_UI.js;WebTextEditor_UIAction.js", Type=XmlSerializationType.ClientAndLayout)>
<System.SerializableAttribute()>
<System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand Or  _
    SecurityAction.Deny Or  _
    SecurityAction.LinkDemand,
   Unrestricted=False)>
<System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand Or  _
    SecurityAction.Assert Or  _
    SecurityAction.Deny Or  _
    SecurityAction.PermitOnly Or  _
    SecurityAction.LinkDemand Or  _
    SecurityAction.InheritanceDemand,
   Unrestricted=False)>
Public Class WebTextEditor
   Inherits ISNet.WebUI.ISNetControl
   Implements ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IDataSourceControlSupport, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
C#
[System.ComponentModel.DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ISNet.WebUI.WebTextEditor.WebTextEditorDesigner, ISNet.WebUI.WebTextEditor, Version=1.0.1000.9, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.Web.UI.ToolboxDataAttribute("<{0}:WebTextEditor runat=server Width="700px" Height="500px"></{0}:WebTextEditor>")]
[ISNet.Serialization.XmlSerializableAttribute(JSFileNames="WebTextEditor.js;WebTextEditor_Render.js;WebTextEditor_Editor.js;WebTextEditor_Helper.js;WebTextEditor_UI.js;WebTextEditor_UIAction.js", Type=XmlSerializationType.ClientAndLayout)]
[System.SerializableAttribute()]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public class WebTextEditor : ISNet.WebUI.ISNetControl, ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IDataSourceControlSupport, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings
Delphi
public class WebTextEditor = class(ISNet.WebUI.ISNetControl, ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IDataSourceControlSupport, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings)
JScript
System.ComponentModel.DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ISNet.WebUI.WebTextEditor.WebTextEditorDesigner, ISNet.WebUI.WebTextEditor, Version=1.0.1000.9, Culture=neutral, PublicKeyToken=b1f2a8511635667a")
System.Web.UI.ToolboxDataAttribute("<{0}:WebTextEditor runat=server Width="700px" Height="500px"></{0}:WebTextEditor>")
ISNet.Serialization.XmlSerializableAttribute(JSFileNames="WebTextEditor.js;WebTextEditor_Render.js;WebTextEditor_Editor.js;WebTextEditor_Helper.js;WebTextEditor_UI.js;WebTextEditor_UIAction.js", Type=XmlSerializationType.ClientAndLayout)
System.SerializableAttribute()
System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=)
System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=)
public class WebTextEditor extends ISNet.WebUI.ISNetControl implements ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IDataSourceControlSupport, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings
Managed Extensions for C++
[System.ComponentModel.DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ISNet.WebUI.WebTextEditor.WebTextEditorDesigner, ISNet.WebUI.WebTextEditor, Version=1.0.1000.9, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.Web.UI.ToolboxDataAttribute("<{0}:WebTextEditor runat=server Width="700px" Height="500px"></{0}:WebTextEditor>")]
[ISNet.Serialization.XmlSerializableAttribute(JSFileNames="WebTextEditor.js;WebTextEditor_Render.js;WebTextEditor_Editor.js;WebTextEditor_Helper.js;WebTextEditor_UI.js;WebTextEditor_UIAction.js", Type=XmlSerializationType.ClientAndLayout)]
[System.SerializableAttribute()]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public __gc class WebTextEditor : public ISNet.WebUI.ISNetControl, ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IDataSourceControlSupport, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings
C++/CLI
[System.ComponentModel.DesignerAttribute(DesignerBaseTypeName="System.ComponentModel.Design.IDesigner", DesignerTypeName="ISNet.WebUI.WebTextEditor.WebTextEditorDesigner, ISNet.WebUI.WebTextEditor, Version=1.0.1000.9, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.Web.UI.ToolboxDataAttribute("<{0}:WebTextEditor runat=server Width="700px" Height="500px"></{0}:WebTextEditor>")]
[ISNet.Serialization.XmlSerializableAttribute(JSFileNames="WebTextEditor.js;WebTextEditor_Render.js;WebTextEditor_Editor.js;WebTextEditor_Helper.js;WebTextEditor_UI.js;WebTextEditor_UIAction.js", Type=XmlSerializationType.ClientAndLayout)]
[System.SerializableAttribute()]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[System.Web.AspNetHostingPermissionAttribute(Level=AspNetHostingPermissionLevel.Minimal,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public ref class WebTextEditor : public ISNet.WebUI.ISNetControl, ISNet.ICopyable, ISNet.IObjectState, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.Serialization.XmlSerialization.IXmlSerialize, ISNet.WebUI.IBaseISNetControl, ISNet.WebUI.IClientAction, ISNet.WebUI.IDataSourceControlSupport, ISNet.WebUI.IFlyPostBack, ISNet.WebUI.IInfo, ISNet.WebUI.ILayoutSettings

Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
ISNet.WebUI.ISNetControl
ISNet.WebUI.WebTextEditor.WebTextEditor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Members
ISNet.WebUI.WebTextEditor Namespace


WebTextEditor Class Members

[image]
Intersoft WebTextEditor Documentation
WebTextEditor Class Members
See Also Fields Properties Methods Events Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditor Class

Glossary Item Box

The following tables list the members exposed by WebTextEditor.

Public Constructors

 | Name | Description
Public Constructor | WebTextEditor Constructor | Overloaded.
Top

Protected Fields

 | Name | Description
Protected Field | isPagePreRender | (Inherited from ISNet.WebUI.ISNetControl)
Protected Field | renderDHTML | (Inherited from ISNet.WebUI.ISNetControl)
Protected Field | renderNS | (Inherited from ISNet.WebUI.ISNetControl)
Protected Field | viewStateLoaded | (Inherited from ISNet.WebUI.ISNetControl)
Top

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ActionName |
Public Property | AllowDefaultStyleMerging | Gets or sets the value that determines whether or not the default style can be merged with custom styles.
Public Property | AllowResize | Determines whether or not resize action is allowed.
Public Property | AppRelativeTemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | AspNetAjaxSettings | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Attributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | AutoSaveInterval | Specifies auto save interval (in minute).
Public Property | BackColor | Overridden.
Public Property | BorderColor | Overridden.
Public Property | BorderStyle | Overridden.
Public Property | BorderWidth | Overridden.
Public Property | ClientAction | Returns ClientSideAction class
Public Property | ClientID | (Inherited from System.Web.UI.Control)
Public Property | ClientIDMode | (Inherited from System.Web.UI.Control)
Public Property | ClientSideEvents | Contains client side events supported by WebTextEditor.
Public Property | Content | Specifies content of RootTextEditor.
Public Property | ControlDataTransferFormat | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Controls | (Inherited from System.Web.UI.Control)
Public Property | ControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ControlStyleCreated | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | CssClass | Overridden.
Public Property | DataMember | Specifies mail merge DataMember.
Public Property | DataSourceCount |
Public Property | DataSourceID | Specifies mail merge DataSource's ID.
Public Property | DataSourceManager | Overridden.
Public Property | DefaultStyleMode | Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled.
Public Property | EditorCss |
Public Property | EditorSettings | Provides settings that control the behaviors of the editor in WebTextEditor.
Public Property | EditorTableStyleCss |
Public Property | EnableAutoSave | Determines whether or not auto save feature is enabled.
Public Property | EnableContextMenu | Determines whether or not context menu is enabled.
Public Property | Enabled | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableDocumentImport | Determines whether or not document import is enabled.
Public Property | EnableDocumentPrint | Determines whether or not document print is enabled.
Public Property | EnableDocumentSave | Determines whether or not document save is enabled.
Public Property | EnableEditorTabKey | Determines whether or not WebTextEditor should handle Tab key.
Public Property | EnableFullScreen | Gets or sets the value that determines whether or not full screen feature is enabled.
Public Property | EnableHTMLInspector | Determines whether or not html inspector is enabled.
Public Property | EnableKeyboardSupport | Determines whether or not keyboard support is enabled.
Public Property | EnableManagedTheming | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableXHTMLCompliance | Determines whether or not the WebTextEditor's output is XHTML compliance.
Public Property | EnterKeyAction | Specifies WebTextEditor behavior when enter key is pressed.
Public Property | FileUploader |
Public Property | FileUploaderSettings | Provides settings that control the behaviors of the file uploader in WebTextEditor.
Public Property | FloatingToolBarFrameStyle | Contains interactive style for Floating ToolBar frame.
Public Property | FlyPostBackSettings | Configures the settings used by the control when performing OnTheFly postback.
Public Property | FocusOnLoad |
Public Property | Font | Overridden.
Public Property | FooterFrameStyle | Contains interactive style for footer frame.
Public Property | ForeColor | Overridden.
Public Property | FrameLayerStyle | Contains interactive style for Frame layer that will be displayed when the editor is resized.
Public Property | FrameStyle | Contains interactive style for Frame.
Public Property | HasAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | HeaderFrameStyle | Contains interactive style for header frame.
Public Property | Height | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | HTMLInspectorContentStyle | Contains interactive style for the content of HTML inspector section in footer.
Public Property | HTMLInspectorLeftIndicatorDisabledStyle | Contains interactive style for left indicator of HTML inspector in footer when it is disabled.
Public Property | HTMLInspectorLeftIndicatorStyle | Contains interactive style for left indicator of HTML inspector section in footer.
Public Property | HTMLInspectorRightIndicatorDisabledStyle | Contains interactive style for right indicator of HTML inspector in footer when it is disabled.
Public Property | HTMLInspectorRightIndicatorStyle | Contains interactive style for right indicator of HTML inspector section in footer.
Public Property | HTMLToolBar |
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | ImagesDirectory | Gets or sets the images directory.
Public Property | ImagesSettings | Provides settings that control the images in WebTextEditor.
Public Property | IsControlThemed | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | IsDesign | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | IsDynamicCreated | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | IsFlyPostBack |
Public Property | IsInternalCreated | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | IsUnloaded | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | LeftFooterStyle | Contains interactive style for left section of footer.
Public Property | MailMergeLabelStyle | Contains interactive style for mail merge label.
Public Property | MailMergeSettings | Provides settings that control the behaviors of mail merge in WebTextEditor.
Public Property | MaximumSize | Gets or sets the value that determines the maximum size of WebTextEditor when it is resized.
Public Property | MediaResources | The media resources collection used by WebTextEditor to filter the media in Media Gallery task pane.
Public Property | Medias | The media collection used by WebTextEditor in Media Gallery task pane.
Public Property | MinimumSize | Gets or sets the value that determines the minimum size of WebTextEditor when it is resized.
Public Property | NamingContainer | (Inherited from System.Web.UI.Control)
Public Property | Page | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ParagraphMode | Specifies the behavior for paragraph editing.
Public Property | Parent | (Inherited from System.Web.UI.Control)
Public Property | ParentStyleId | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | PreventScriptInjection | Determines whether or not script tag is removed from WebTextEditor.
Public Property | PreviewToolBar |
Public Property | RawFloatingToolBar |
Public Property | RenderingCompatibility | (Inherited from System.Web.UI.Control)
Public Property | RenderingMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RequiresUIRefresh | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ResizerStyle | Contains interactive style for resizer in footer.
Public Property | RightFooterStyle | Contains interactive style for right section of footer.
Public Property | RootTextEditor | Provides settings that control the behaviors of single section in WebTextEditor.
Public Property | RuntimeLicenseKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | SaveViewStateOnFlyPostback | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ScriptDirectory | Overridden. Gets or sets the directory where all required scripts for the control are stored.
Public Property | SectionLineStyle | Contains interactive style for TextEditor Section Line.
Public Property | SectionTextStyle | Contains interactive style for TextEditor Section Text.
Public Property | SerializedJSFiles | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | SerializedStyles | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | SharedScriptDirectory | Overridden. Gets or sets the directory where all required framework scripts for the control are stored.
Public Property | ShowCallOutOnMediaInsert | Determines whether or not callout will appear when media is inserted.
Public Property | ShowCharacterInformation | Determines whether or not character information should be shown as tooltip.
Public Property | ShowMediaActionOnMediaSelect | Determines whether or not media action will appear when media is selected.
Public Property | ShowWordInformation | Determines whether or not word information should be shown.
Public Property | Site | (Inherited from System.Web.UI.Control)
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | SplitterStyle | Contains interactive style for Splitter.
Public Property | Style | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | SupportsDisabledAttribute | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | SupportXMLCultureInfo | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | TabIndex | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | TaskPaneSettings | Provides settings that control the behaviors of the taskpane in WebTextEditor.
Public Property | TemplateControl | (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | TextEditorSections | Provides settings that control the behaviors of multiple section in WebTextEditor.
Public Property | TextSettings | Provides settings that control text that shown in WebTextEditor.
Public Property | ToolBar |
Public Property | ToolBarSettings | Provides settings that control the behaviors of the toolbar in WebTextEditor.
Public Property | ToolTip | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | UndoLatency | Specifies undo latency interval (in milisecond).
Public Property | UniqueID | (Inherited from System.Web.UI.Control)
Public Property | UploadBarFrameStyle | Contains interactive style for upload bar frame in footer.
Public Property | UploadBarTextStyle | Contains interactive style for upload bar text in footer.
Public Property | UseDefaultEditorStylesForPrint | Determines whether or not default styles are included when the printing the content.
Public Property | UseDefaultStyle | Determines whether or not WebTextEditor is using default style.
Public Property | ValidateRequestMode | (Inherited from System.Web.UI.Control)
Public Property | ViewIndicatorStyle | Contains interactive style for view tab indicator in footer.
Public Property | ViewSettings | Provides settings that control the behaviors of the view in WebTextEditor.
Public Property | ViewStateItems | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateServerConnection | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateStorage | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewTabStyle | Contains interactive style for view tab in footer.
Public Property | Visible | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | WatermarkStyle | Contains interactive style for TextEditor's Watermark.
Public Property | WebDesktopScriptDirectory | Gets or sets the IIS path to locate WebDesktop's script directory. This property is only applicable when SmartWebResources is not enabled.
Public Property | Width | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | XmlCompressionEnabled | (Inherited from ISNet.WebUI.ISNetControl)
Top

Protected Properties

 | Name | Description
Protected Property | Adapter | (Inherited from System.Web.UI.Control)
Protected Property | ChildControlsCreated | (Inherited from System.Web.UI.Control)
Protected Property | ClientIDSeparator | (Inherited from System.Web.UI.Control)
Protected Property | DefaultImagesFolder | Overridden.
Protected Property | Events | (Inherited from System.Web.UI.Control)
Protected Property | HasChildViewState | (Inherited from System.Web.UI.Control)
Protected Property | IdSeparator | (Inherited from System.Web.UI.Control)
Protected Property | IsMvc | (Inherited from ISNet.WebUI.ISNetControl)
Protected Property | IsTrackingViewState | (Inherited from System.Web.UI.Control)
Protected Property | LicenseType | Overridden.
Protected Property | LoadViewStateByID | (Inherited from System.Web.UI.Control)
Protected Property | MaxJsonLength | (Inherited from ISNet.WebUI.ISNetControl)
Protected Property | Product | Overridden.
Protected Property | ProductIcon | Overridden.
Protected Property | ProductImage | Overridden.
Protected Property | SupportDataSourceControl | Overridden.
Protected Property | TagKey | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Property | TagName | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Property | ViewState | (Inherited from System.Web.UI.Control)
Protected Property | ViewStateIgnoresCase | (Inherited from System.Web.UI.Control)
Top

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CanUseWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CheckConstrains | Overridden.
Public Method | Clone | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | DataBind | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | ForceDisableXmlCompression | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetClientAction |
Public Method | GetCurrentControlLifeCycle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkDataFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkVersion | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetIntersoftFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetLayoutFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetObjectData | Overridden.
Public Method | GetPostedXMLData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductInfoKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductSimpleName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetPropertyValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetResourceStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetRouteUrl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | GetUniqueIDRelativeTo | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | IsAtlasCallback | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsBetaRelease | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsChromeBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackRequest | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoBasedBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoVersion18 | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInDesignMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorer8Browser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorerBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsOperaBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsSafariBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsW3CStandardBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadContentFromFile | Overloaded. Load WebTextEditor's content from file.
Public Method | LoadLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromPredefinedName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadPostData | Overridden.
Public Method | LoadToolBarsStructureFromXml | Overloaded. Load ToolBar structure from xml file.
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | OnInfoChanged | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | OnPreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | PerformMailMerge | Overloaded. Perform mail merge from WebTextEditor's content to mail merge string with recipient provided
Public Method | PerformSendMail | Perform send mail action on mail merge collection.
Public Method | RaisePostBackEvent |
Public Method | RaisePostDataChangedEvent | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ReadWebConfigValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RecreateChildControls |
Public Method | RegisterBoxSizing | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterClientScript |
Public Method | RegisterClientStyle |
Public Method | RegisterGlobalStyle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterLink | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterOptimizedCssClasses | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterPreloadImage | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterScript | Overridden.
Public Method | RegisterSharePointHandler | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderBeginTag | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderControl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | Overridden.
Public Method | Reset | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveImagePath | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveRelativeURL | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveResourceUrl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SaveContentToFile | Overloaded. Save WebTextEditor's content to file.
Public Method | SaveLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveToolBarsStructureToXml | Overloaded. Save ToolBar structure to xml file.
Public Method | SearchMedias | Perform media searching in WebTextEditor.
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Public Method | SetSessionTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ShouldReturnJson | (Inherited from ISNet.WebUI.ISNetControl)
Top

Protected Methods

 | Name | Description
Protected Method | AddAttributesToRender | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | AddParsedSubObject | (Inherited from System.Web.UI.Control)
Protected Method | ApplyControlTheme | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | AssignXmlInputHiddenUniqueID | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | BuildProfileTree | (Inherited from System.Web.UI.Control)
Protected Method | ClearCachedClientID | (Inherited from System.Web.UI.Control)
Protected Method | ClearChildControlState | (Inherited from System.Web.UI.Control)
Protected Method | ClearChildState | (Inherited from System.Web.UI.Control)
Protected Method | ClearChildViewState | (Inherited from System.Web.UI.Control)
Protected Method | ClearEffectiveClientIDMode | (Inherited from System.Web.UI.Control)
Protected Method | ControlRequestHandler | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | CreateChildControls | Overridden.
Protected Method | CreateControlCollection | (Inherited from System.Web.UI.Control)
Protected Method | CreateControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | CreateThemeInfo | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | DataBindChildren | (Inherited from System.Web.UI.Control)
Protected Method | DecodeRequest | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | EnsureChildControls | (Inherited from System.Web.UI.Control)
Protected Method | EnsureID | (Inherited from System.Web.UI.Control)
Protected Method | GetApplicationState | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | GetCachedAppTheme | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | GetDesignModeState | (Inherited from System.Web.UI.Control)
Protected Method | GetDHTMLRenderer | Overridden.
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | GetSessionLevelTheme | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | HasEvents | (Inherited from System.Web.UI.Control)
Protected Method | InitializeDefaultStyles | Overridden.
Protected Method | InitializeLayoutBehaviors | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | InitializeManagedTheming | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | IsApplicationAvailable | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | IsAppThemeEnabled | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | IsLiteralContent | (Inherited from System.Web.UI.Control)
Protected Method | IsSessionAvailable | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | LoadControlState | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | LoadViewState | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | OnBeforeSendMail |
Protected Method | OnBubbleEvent | (Inherited from System.Web.UI.Control)
Protected Method | OnDataBinding | (Inherited from System.Web.UI.Control)
Protected Method | OnInit | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | OnInitializeToolBar |
Protected Method | OnLoad | Overridden.
Protected Method | OnMailMerge |
Protected Method | OnMailMergeCompleted |
Protected Method | OnPreRender | Overridden.
Protected Method | OnSave |
Protected Method | OnSendMail |
Protected Method | OnSendMailCompleted |
Protected Method | RaiseBubbleEvent | (Inherited from System.Web.UI.Control)
Protected Method | RenderContents | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | ResetFilteredStyle | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | ResolveAdapter | (Inherited from System.Web.UI.Control)
Protected Method | SaveControlState | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | SaveViewState | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | SetDesignModeState | (Inherited from System.Web.UI.Control)
Protected Method | SetTheme | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | ShowAboutBox | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | TrackViewState | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | UseDeepCloneForViewStateStorage | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | UseMemoryStreamStateType | (Inherited from ISNet.WebUI.ISNetControl)
Top

Public Events

 | Name | Description
Public Event | BeforeSendMail | Fires before send mail action is performed.
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | InitializeToolBar | Fires when the toolbar is initialized.
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | MailMerge | Fires when mail merge is being processed in each data context.
Public Event | MailMergeCompleted | Fires when mail merge process is completed.
Public Event | PreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Save | Fires when the content is being saved.
Public Event | SendMail | Fires when each email is being sent.
Public Event | SendMailCompleted | Fires when sending email action is completed.
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

WebTextEditor Class
ISNet.WebUI.WebTextEditor Namespace


WebTextEditor Constructor

[image]
Intersoft WebTextEditor Documentation
WebTextEditor Constructor
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : WebTextEditor Constructor

Glossary Item Box

Overload List

Overload | Description
WebTextEditor Constructor() |
WebTextEditor Constructor(SerializationInfo,StreamingContext) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


WebTextEditor Constructor()

[image]
Intersoft WebTextEditor Documentation
WebTextEditor Constructor()
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class > WebTextEditor Constructor : WebTextEditor Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebTextEditor()
C#
public WebTextEditor()
Delphi
public WebTextEditor();
JScript
public function WebTextEditor();
Managed Extensions for C++
public: WebTextEditor();
C++/CLI
public:
WebTextEditor();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members
Overload List


WebTextEditor Constructor(SerializationInfo,StreamingContext)

[image]
Intersoft WebTextEditor Documentation
WebTextEditor Constructor(SerializationInfo,StreamingContext)
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class > WebTextEditor Constructor : WebTextEditor Constructor(SerializationInfo,StreamingContext)

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

Dim instance As New WebTextEditor(info, context)
C#
protected WebTextEditor(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
protected WebTextEditor(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
protected function WebTextEditor(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
protected: WebTextEditor(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
protected:
WebTextEditor(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members
Overload List


WebTextEditor Class Methods

[image]
Intersoft WebTextEditor Documentation
WebTextEditor Class Methods
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditor Class

Glossary Item Box

For a list of all members of this type, see WebTextEditor members.

Public Methods

 | Name | Description
Public Method | ApplyStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | (Inherited from System.Web.UI.Control)
Public Method | CanUseWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CheckConstrains | Overridden.
Public Method | Clone | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | CopyBaseAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | DataBind | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Dispose | (Inherited from System.Web.UI.Control)
Public Method | FindControl | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | Focus | (Inherited from System.Web.UI.Control)
Public Method | ForceDisableXmlCompression | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetClientAction |
Public Method | GetCurrentControlLifeCycle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetCurrentTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkDataFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetFrameworkVersion | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetIntersoftFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetLayoutFolder | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetObjectData | Overridden.
Public Method | GetPostedXMLData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductInfoKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetProductSimpleName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetPropertyValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetResourceStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | GetRouteUrl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | GetUniqueIDRelativeTo | (Inherited from System.Web.UI.Control)
Public Method | HasControls | (Inherited from System.Web.UI.Control)
Public Method | IsAtlasCallback | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsBetaRelease | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsChromeBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackControl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsFlyPostBackRequest | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoBasedBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsGeckoVersion18 | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInDesignMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorer8Browser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsInternetExplorerBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsOperaBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsSafariBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | IsW3CStandardBrowser | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadContentFromFile | Overloaded. Load WebTextEditor's content from file.
Public Method | LoadLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromPredefinedName | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadLayoutFromStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | LoadPostData | Overridden.
Public Method | LoadToolBarsStructureFromXml | Overloaded. Load ToolBar structure from xml file.
Public Method | MergeStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | OnInfoChanged | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | OnPreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | PerformMailMerge | Overloaded. Perform mail merge from WebTextEditor's content to mail merge string with recipient provided
Public Method | PerformSendMail | Perform send mail action on mail merge collection.
Public Method | RaisePostBackEvent |
Public Method | RaisePostDataChangedEvent | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ReadWebConfigValue | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RecreateChildControls |
Public Method | RegisterBoxSizing | Overloaded. (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterClientScript |
Public Method | RegisterClientStyle |
Public Method | RegisterGlobalStyle | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterLink | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterOptimizedCssClasses | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterPreloadImage | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RegisterScript | Overridden.
Public Method | RegisterSharePointHandler | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderBeginTag | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | RenderControl | Overloaded. (Inherited from System.Web.UI.Control)
Public Method | RenderEndTag | Overridden.
Public Method | Reset | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveClientUrl | (Inherited from System.Web.UI.Control)
Public Method | ResolveImagePath | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveRelativeURL | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveResourceUrl | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ResolveUrl | (Inherited from System.Web.UI.Control)
Public Method | SaveContentToFile | Overloaded. Save WebTextEditor's content to file.
Public Method | SaveLayout | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToFile | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveLayoutToStream | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SaveToolBarsStructureToXml | Overloaded. Save ToolBar structure to xml file.
Public Method | SearchMedias | Perform media searching in WebTextEditor.
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | SetRenderMethodDelegate | (Inherited from System.Web.UI.Control)
Public Method | SetSessionTheme | (Inherited from ISNet.WebUI.ISNetControl)
Public Method | ShouldReturnJson | (Inherited from ISNet.WebUI.ISNetControl)
Top

Protected Methods

 | Name | Description
Protected Method | AddAttributesToRender | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | AddParsedSubObject | (Inherited from System.Web.UI.Control)
Protected Method | ApplyControlTheme | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | AssignXmlInputHiddenUniqueID | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | BuildProfileTree | (Inherited from System.Web.UI.Control)
Protected Method | ClearCachedClientID | (Inherited from System.Web.UI.Control)
Protected Method | ClearChildControlState | (Inherited from System.Web.UI.Control)
Protected Method | ClearChildState | (Inherited from System.Web.UI.Control)
Protected Method | ClearChildViewState | (Inherited from System.Web.UI.Control)
Protected Method | ClearEffectiveClientIDMode | (Inherited from System.Web.UI.Control)
Protected Method | ControlRequestHandler | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | CreateChildControls | Overridden.
Protected Method | CreateControlCollection | (Inherited from System.Web.UI.Control)
Protected Method | CreateControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | CreateThemeInfo | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | DataBindChildren | (Inherited from System.Web.UI.Control)
Protected Method | DecodeRequest | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | EnsureChildControls | (Inherited from System.Web.UI.Control)
Protected Method | EnsureID | (Inherited from System.Web.UI.Control)
Protected Method | GetApplicationState | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | GetCachedAppTheme | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | GetDesignModeState | (Inherited from System.Web.UI.Control)
Protected Method | GetDHTMLRenderer | Overridden.
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | GetSessionLevelTheme | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | HasEvents | (Inherited from System.Web.UI.Control)
Protected Method | InitializeDefaultStyles | Overridden.
Protected Method | InitializeLayoutBehaviors | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | InitializeManagedTheming | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | IsApplicationAvailable | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | IsAppThemeEnabled | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | IsLiteralContent | (Inherited from System.Web.UI.Control)
Protected Method | IsSessionAvailable | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | LoadControlState | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | LoadViewState | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | OnBeforeSendMail |
Protected Method | OnBubbleEvent | (Inherited from System.Web.UI.Control)
Protected Method | OnDataBinding | (Inherited from System.Web.UI.Control)
Protected Method | OnInit | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | OnInitializeToolBar |
Protected Method | OnLoad | Overridden.
Protected Method | OnMailMerge |
Protected Method | OnMailMergeCompleted |
Protected Method | OnPreRender | Overridden.
Protected Method | OnSave |
Protected Method | OnSendMail |
Protected Method | OnSendMailCompleted |
Protected Method | RaiseBubbleEvent | (Inherited from System.Web.UI.Control)
Protected Method | RenderContents | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | ResetFilteredStyle | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | ResolveAdapter | (Inherited from System.Web.UI.Control)
Protected Method | SaveControlState | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | SaveViewState | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | SetDesignModeState | (Inherited from System.Web.UI.Control)
Protected Method | SetTheme | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | ShowAboutBox | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | TrackViewState | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Method | UseDeepCloneForViewStateStorage | (Inherited from ISNet.WebUI.ISNetControl)
Protected Method | UseMemoryStreamStateType | (Inherited from ISNet.WebUI.ISNetControl)
Top

See Also

Reference

WebTextEditor Class
ISNet.WebUI.WebTextEditor Namespace


CheckConstrains Method

[image]
Intersoft WebTextEditor Documentation
CheckConstrains Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : CheckConstrains Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub CheckConstrains()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor

instance.CheckConstrains()
C#
public override void CheckConstrains()
Delphi
public procedure CheckConstrains(); override;
JScript
public override function CheckConstrains();
Managed Extensions for C++
public: void CheckConstrains(); override
C++/CLI
public:
void CheckConstrains(); override

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


CreateChildControls Method

[image]
Intersoft WebTextEditor Documentation
CreateChildControls Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : CreateChildControls Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overrides Sub CreateChildControls()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor

instance.CreateChildControls()
C#
protected override void CreateChildControls()
Delphi
protected procedure CreateChildControls(); override;
JScript
protected override function CreateChildControls();
Managed Extensions for C++
protected: void CreateChildControls(); override
C++/CLI
protected:
void CreateChildControls(); override

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


GetClientAction Method

[image]
Intersoft WebTextEditor Documentation
GetClientAction Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : GetClientAction Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetClientAction() As ISNet.WebUI.BaseClientSideAction
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As ISNet.WebUI.BaseClientSideAction

value = instance.GetClientAction()
C#
public ISNet.WebUI.BaseClientSideAction GetClientAction()
Delphi
public function GetClientAction(): ISNet.WebUI.BaseClientSideAction;
JScript
public function GetClientAction() : ISNet.WebUI.BaseClientSideAction;
Managed Extensions for C++
public: ISNet.WebUI.BaseClientSideAction* GetClientAction();
C++/CLI
public:
ISNet.WebUI.BaseClientSideAction^ GetClientAction();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


GetDHTMLRenderer Method

[image]
Intersoft WebTextEditor Documentation
GetDHTMLRenderer Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : GetDHTMLRenderer Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overrides Function GetDHTMLRenderer() As ISNet.WebUI.RenderDHTML
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As ISNet.WebUI.RenderDHTML

value = instance.GetDHTMLRenderer()
C#
protected override ISNet.WebUI.RenderDHTML GetDHTMLRenderer()
Delphi
protected function GetDHTMLRenderer(): ISNet.WebUI.RenderDHTML; override;
JScript
protected override function GetDHTMLRenderer() : ISNet.WebUI.RenderDHTML;
Managed Extensions for C++
protected: ISNet.WebUI.RenderDHTML* GetDHTMLRenderer(); override
C++/CLI
protected:
ISNet.WebUI.RenderDHTML^ GetDHTMLRenderer(); override

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


GetObjectData Method

[image]
Intersoft WebTextEditor Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


InitializeDefaultStyles Method

[image]
Intersoft WebTextEditor Documentation
InitializeDefaultStyles Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : InitializeDefaultStyles Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overrides Sub InitializeDefaultStyles()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor

instance.InitializeDefaultStyles()
C#
protected override void InitializeDefaultStyles()
Delphi
protected procedure InitializeDefaultStyles(); override;
JScript
protected override function InitializeDefaultStyles();
Managed Extensions for C++
protected: void InitializeDefaultStyles(); override
C++/CLI
protected:
void InitializeDefaultStyles(); override

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


LoadContentFromFile Method

[image]
Intersoft WebTextEditor Documentation
LoadContentFromFile Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : LoadContentFromFile Method

Glossary Item Box

Load WebTextEditor's content from file.

Overload List

Overload | Description
LoadContentFromFile(String) | Load WebTextEditor's content from file.
LoadContentFromFile(String,Boolean) | Load WebTextEditor's content from file.
LoadContentFromFile(String,String) | Load WebTextEditor's content from file.
LoadContentFromFile(String,String,Boolean) | Load WebTextEditor's content from file.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


LoadContentFromFile(String) Method

[image]
Intersoft WebTextEditor Documentation
LoadContentFromFile(String) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class > LoadContentFromFile Method : LoadContentFromFile(String) Method

fileName

Glossary Item Box

Load WebTextEditor's content from file.

Syntax

Visual Basic (Declaration)
Public Overloads Sub LoadContentFromFile( _
   ByVal fileName As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim fileName As System.String

instance.LoadContentFromFile(fileName)
C#
public void LoadContentFromFile(
   System.string fileName
)
Delphi
public procedure LoadContentFromFile(
    fileName: System.String
);
JScript
public function LoadContentFromFile(
   fileName : System.String
);
Managed Extensions for C++
public: void LoadContentFromFile(
   System.string* fileName
)
C++/CLI
public:
void LoadContentFromFile(
   System.String^ fileName
)

Parameters

fileName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members
Overload List


LoadContentFromFile(String,Boolean) Method

[image]
Intersoft WebTextEditor Documentation
LoadContentFromFile(String,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class > LoadContentFromFile Method : LoadContentFromFile(String,Boolean) Method

fileName
isCompleteHTML

Glossary Item Box

Load WebTextEditor's content from file.

Syntax

Visual Basic (Declaration)
Public Overloads Sub LoadContentFromFile( _
   ByVal fileName As System.String, _
   ByVal isCompleteHTML As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim fileName As System.String
Dim isCompleteHTML As System.Boolean

instance.LoadContentFromFile(fileName, isCompleteHTML)
C#
public void LoadContentFromFile(
   System.string fileName,
   System.bool isCompleteHTML
)
Delphi
public procedure LoadContentFromFile(
    fileName: System.String;
    isCompleteHTML: System.Boolean
);
JScript
public function LoadContentFromFile(
   fileName : System.String,
   isCompleteHTML : System.boolean
);
Managed Extensions for C++
public: void LoadContentFromFile(
   System.string* fileName,
   System.bool isCompleteHTML
)
C++/CLI
public:
void LoadContentFromFile(
   System.String^ fileName,
   System.bool isCompleteHTML
)

Parameters

fileName
isCompleteHTML

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members
Overload List


LoadContentFromFile(String,String) Method

[image]
Intersoft WebTextEditor Documentation
LoadContentFromFile(String,String) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class > LoadContentFromFile Method : LoadContentFromFile(String,String) Method

fileName
sectionName

Glossary Item Box

Load WebTextEditor's content from file.

Syntax

Visual Basic (Declaration)
Public Overloads Sub LoadContentFromFile( _
   ByVal fileName As System.String, _
   ByVal sectionName As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim fileName As System.String
Dim sectionName As System.String

instance.LoadContentFromFile(fileName, sectionName)
C#
public void LoadContentFromFile(
   System.string fileName,
   System.string sectionName
)
Delphi
public procedure LoadContentFromFile(
    fileName: System.String;
    sectionName: System.String
);
JScript
public function LoadContentFromFile(
   fileName : System.String,
   sectionName : System.String
);
Managed Extensions for C++
public: void LoadContentFromFile(
   System.string* fileName,
   System.string* sectionName
)
C++/CLI
public:
void LoadContentFromFile(
   System.String^ fileName,
   System.String^ sectionName
)

Parameters

fileName
sectionName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members
Overload List


LoadContentFromFile(String,String,Boolean) Method

[image]
Intersoft WebTextEditor Documentation
LoadContentFromFile(String,String,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class > LoadContentFromFile Method : LoadContentFromFile(String,String,Boolean) Method

fileName
sectionName
isCompleteHTML

Glossary Item Box

Load WebTextEditor's content from file.

Syntax

Visual Basic (Declaration)
Public Overloads Sub LoadContentFromFile( _
   ByVal fileName As System.String, _
   ByVal sectionName As System.String, _
   ByVal isCompleteHTML As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim fileName As System.String
Dim sectionName As System.String
Dim isCompleteHTML As System.Boolean

instance.LoadContentFromFile(fileName, sectionName, isCompleteHTML)
C#
public void LoadContentFromFile(
   System.string fileName,
   System.string sectionName,
   System.bool isCompleteHTML
)
Delphi
public procedure LoadContentFromFile(
    fileName: System.String;
    sectionName: System.String;
    isCompleteHTML: System.Boolean
);
JScript
public function LoadContentFromFile(
   fileName : System.String,
   sectionName : System.String,
   isCompleteHTML : System.boolean
);
Managed Extensions for C++
public: void LoadContentFromFile(
   System.string* fileName,
   System.string* sectionName,
   System.bool isCompleteHTML
)
C++/CLI
public:
void LoadContentFromFile(
   System.String^ fileName,
   System.String^ sectionName,
   System.bool isCompleteHTML
)

Parameters

fileName
sectionName
isCompleteHTML

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members
Overload List


LoadPostData Method

[image]
Intersoft WebTextEditor Documentation
LoadPostData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : LoadPostData Method

postDataKey
postCollection

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Function LoadPostData( _
   ByVal postDataKey As System.String, _
   ByVal postCollection As System.Collections.Specialized.NameValueCollection _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim postDataKey As System.String
Dim postCollection As System.Collections.Specialized.NameValueCollection
Dim value As System.Boolean

value = instance.LoadPostData(postDataKey, postCollection)
C#
public override System.bool LoadPostData(
   System.string postDataKey,
   System.Collections.Specialized.NameValueCollection postCollection
)
Delphi
public function LoadPostData(
    postDataKey: System.String;
    postCollection: System.Collections.Specialized.NameValueCollection
): System.Boolean; override;
JScript
public override function LoadPostData(
   postDataKey : System.String,
   postCollection : System.Collections.Specialized.NameValueCollection
) : System.boolean;
Managed Extensions for C++
public: System.bool LoadPostData(
   System.string* postDataKey,
   System.Collections.Specialized.NameValueCollection* postCollection
) override
C++/CLI
public:
System.bool LoadPostData(
   System.String^ postDataKey,
   System.Collections.Specialized.NameValueCollection^ postCollection
) override

Parameters

postDataKey
postCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


LoadToolBarsStructureFromXml Method

[image]
Intersoft WebTextEditor Documentation
LoadToolBarsStructureFromXml Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : LoadToolBarsStructureFromXml Method

Glossary Item Box

Load ToolBar structure from xml file.

Overload List

Overload | Description
LoadToolBarsStructureFromXml(String) | Load ToolBar structure from xml file.
LoadToolBarsStructureFromXml(XmlDocument) | Load ToolBar structure from xml file.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


LoadToolBarsStructureFromXml(String) Method

[image]
Intersoft WebTextEditor Documentation
LoadToolBarsStructureFromXml(String) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class > LoadToolBarsStructureFromXml Method : LoadToolBarsStructureFromXml(String) Method

fileName

Glossary Item Box

Load ToolBar structure from xml file.

Syntax

Visual Basic (Declaration)
Public Overloads Sub LoadToolBarsStructureFromXml( _
   ByVal fileName As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim fileName As System.String

instance.LoadToolBarsStructureFromXml(fileName)
C#
public void LoadToolBarsStructureFromXml(
   System.string fileName
)
Delphi
public procedure LoadToolBarsStructureFromXml(
    fileName: System.String
);
JScript
public function LoadToolBarsStructureFromXml(
   fileName : System.String
);
Managed Extensions for C++
public: void LoadToolBarsStructureFromXml(
   System.string* fileName
)
C++/CLI
public:
void LoadToolBarsStructureFromXml(
   System.String^ fileName
)

Parameters

fileName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members
Overload List


LoadToolBarsStructureFromXml(XmlDocument) Method

[image]
Intersoft WebTextEditor Documentation
LoadToolBarsStructureFromXml(XmlDocument) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class > LoadToolBarsStructureFromXml Method : LoadToolBarsStructureFromXml(XmlDocument) Method

doc

Glossary Item Box

Load ToolBar structure from xml file.

Syntax

Visual Basic (Declaration)
Public Overloads Sub LoadToolBarsStructureFromXml( _
   ByVal doc As System.Xml.XmlDocument _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim doc As System.Xml.XmlDocument

instance.LoadToolBarsStructureFromXml(doc)
C#
public void LoadToolBarsStructureFromXml(
   System.Xml.XmlDocument doc
)
Delphi
public procedure LoadToolBarsStructureFromXml(
    doc: System.Xml.XmlDocument
);
JScript
public function LoadToolBarsStructureFromXml(
   doc : System.Xml.XmlDocument
);
Managed Extensions for C++
public: void LoadToolBarsStructureFromXml(
   System.Xml.XmlDocument* doc
)
C++/CLI
public:
void LoadToolBarsStructureFromXml(
   System.Xml.XmlDocument^ doc
)

Parameters

doc

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members
Overload List


OnBeforeSendMail Method

[image]
Intersoft WebTextEditor Documentation
OnBeforeSendMail Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : OnBeforeSendMail Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnBeforeSendMail( _
   ByVal e As WebTextEditorBeforeSendMailArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim e As WebTextEditorBeforeSendMailArgs

instance.OnBeforeSendMail(e)
C#
protected virtual void OnBeforeSendMail(
   WebTextEditorBeforeSendMailArgs e
)
Delphi
protected procedure OnBeforeSendMail(
    e: WebTextEditorBeforeSendMailArgs
); virtual;
JScript
protected function OnBeforeSendMail(
   e : WebTextEditorBeforeSendMailArgs
);
Managed Extensions for C++
protected: virtual void OnBeforeSendMail(
   WebTextEditorBeforeSendMailArgs* e
)
C++/CLI
protected:
virtual void OnBeforeSendMail(
   WebTextEditorBeforeSendMailArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


OnInitializeToolBar Method

[image]
Intersoft WebTextEditor Documentation
OnInitializeToolBar Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : OnInitializeToolBar Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnInitializeToolBar( _
   ByVal e As WebTextEditorToolBarArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim e As WebTextEditorToolBarArgs

instance.OnInitializeToolBar(e)
C#
protected virtual void OnInitializeToolBar(
   WebTextEditorToolBarArgs e
)
Delphi
protected procedure OnInitializeToolBar(
    e: WebTextEditorToolBarArgs
); virtual;
JScript
protected function OnInitializeToolBar(
   e : WebTextEditorToolBarArgs
);
Managed Extensions for C++
protected: virtual void OnInitializeToolBar(
   WebTextEditorToolBarArgs* e
)
C++/CLI
protected:
virtual void OnInitializeToolBar(
   WebTextEditorToolBarArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


OnLoad Method

[image]
Intersoft WebTextEditor Documentation
OnLoad Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : OnLoad Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnLoad( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim e As System.EventArgs

instance.OnLoad(e)
C#
protected override void OnLoad(
   System.EventArgs e
)
Delphi
protected procedure OnLoad(
    e: System.EventArgs
); override;
JScript
protected override function OnLoad(
   e : System.EventArgs
);
Managed Extensions for C++
protected: void OnLoad(
   System.EventArgs* e
) override
C++/CLI
protected:
void OnLoad(
   System.EventArgs^ e
) override

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


OnMailMerge Method

[image]
Intersoft WebTextEditor Documentation
OnMailMerge Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : OnMailMerge Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnMailMerge( _
   ByVal e As WebTextEditorMailMergeArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim e As WebTextEditorMailMergeArgs

instance.OnMailMerge(e)
C#
protected virtual void OnMailMerge(
   WebTextEditorMailMergeArgs e
)
Delphi
protected procedure OnMailMerge(
    e: WebTextEditorMailMergeArgs
); virtual;
JScript
protected function OnMailMerge(
   e : WebTextEditorMailMergeArgs
);
Managed Extensions for C++
protected: virtual void OnMailMerge(
   WebTextEditorMailMergeArgs* e
)
C++/CLI
protected:
virtual void OnMailMerge(
   WebTextEditorMailMergeArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


OnMailMergeCompleted Method

[image]
Intersoft WebTextEditor Documentation
OnMailMergeCompleted Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : OnMailMergeCompleted Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnMailMergeCompleted( _
   ByVal e As WebTextEditorMailMergeCompletedArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim e As WebTextEditorMailMergeCompletedArgs

instance.OnMailMergeCompleted(e)
C#
protected virtual void OnMailMergeCompleted(
   WebTextEditorMailMergeCompletedArgs e
)
Delphi
protected procedure OnMailMergeCompleted(
    e: WebTextEditorMailMergeCompletedArgs
); virtual;
JScript
protected function OnMailMergeCompleted(
   e : WebTextEditorMailMergeCompletedArgs
);
Managed Extensions for C++
protected: virtual void OnMailMergeCompleted(
   WebTextEditorMailMergeCompletedArgs* e
)
C++/CLI
protected:
virtual void OnMailMergeCompleted(
   WebTextEditorMailMergeCompletedArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


OnPreRender Method

[image]
Intersoft WebTextEditor Documentation
OnPreRender Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : OnPreRender Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overrides Sub OnPreRender( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim e As System.EventArgs

instance.OnPreRender(e)
C#
protected override void OnPreRender(
   System.EventArgs e
)
Delphi
protected procedure OnPreRender(
    e: System.EventArgs
); override;
JScript
protected override function OnPreRender(
   e : System.EventArgs
);
Managed Extensions for C++
protected: void OnPreRender(
   System.EventArgs* e
) override
C++/CLI
protected:
void OnPreRender(
   System.EventArgs^ e
) override

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


OnSave Method

[image]
Intersoft WebTextEditor Documentation
OnSave Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : OnSave Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnSave( _
   ByVal e As WebTextEditorSaveArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim e As WebTextEditorSaveArgs

instance.OnSave(e)
C#
protected virtual void OnSave(
   WebTextEditorSaveArgs e
)
Delphi
protected procedure OnSave(
    e: WebTextEditorSaveArgs
); virtual;
JScript
protected function OnSave(
   e : WebTextEditorSaveArgs
);
Managed Extensions for C++
protected: virtual void OnSave(
   WebTextEditorSaveArgs* e
)
C++/CLI
protected:
virtual void OnSave(
   WebTextEditorSaveArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


OnSendMail Method

[image]
Intersoft WebTextEditor Documentation
OnSendMail Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : OnSendMail Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnSendMail( _
   ByVal e As WebTextEditorSendMailArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim e As WebTextEditorSendMailArgs

instance.OnSendMail(e)
C#
protected virtual void OnSendMail(
   WebTextEditorSendMailArgs e
)
Delphi
protected procedure OnSendMail(
    e: WebTextEditorSendMailArgs
); virtual;
JScript
protected function OnSendMail(
   e : WebTextEditorSendMailArgs
);
Managed Extensions for C++
protected: virtual void OnSendMail(
   WebTextEditorSendMailArgs* e
)
C++/CLI
protected:
virtual void OnSendMail(
   WebTextEditorSendMailArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


OnSendMailCompleted Method

[image]
Intersoft WebTextEditor Documentation
OnSendMailCompleted Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : OnSendMailCompleted Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnSendMailCompleted( _
   ByVal e As WebTextEditorSendMailCompletedArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim e As WebTextEditorSendMailCompletedArgs

instance.OnSendMailCompleted(e)
C#
protected virtual void OnSendMailCompleted(
   WebTextEditorSendMailCompletedArgs e
)
Delphi
protected procedure OnSendMailCompleted(
    e: WebTextEditorSendMailCompletedArgs
); virtual;
JScript
protected function OnSendMailCompleted(
   e : WebTextEditorSendMailCompletedArgs
);
Managed Extensions for C++
protected: virtual void OnSendMailCompleted(
   WebTextEditorSendMailCompletedArgs* e
)
C++/CLI
protected:
virtual void OnSendMailCompleted(
   WebTextEditorSendMailCompletedArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


PerformMailMerge Method

[image]
Intersoft WebTextEditor Documentation
PerformMailMerge Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : PerformMailMerge Method

Glossary Item Box

Perform mail merge from WebTextEditor's content to mail merge string with recipient provided

Overload List

Overload | Description
PerformMailMerge() | Perform mail merge from WebTextEditor's content to mail merge string with recipient provided
PerformMailMerge(String,IEnumerable,WebTextEditorLabelCollection) | Perform mail merge from WebTextEditor's content to mail merge string with recipient provided

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


PerformMailMerge() Method

[image]
Intersoft WebTextEditor Documentation
PerformMailMerge() Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class > PerformMailMerge Method : PerformMailMerge() Method

Glossary Item Box

Perform mail merge from WebTextEditor's content to mail merge string with recipient provided

Syntax

Visual Basic (Declaration)
Public Overloads Function PerformMailMerge() As System.Collections.Generic.List(Of WebTextEditorMailMergeObject)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Collections.Generic.List(Of WebTextEditorMailMergeObject)

value = instance.PerformMailMerge()
C#
public System.Collections.Generic.List<WebTextEditorMailMergeObject> PerformMailMerge()
Delphi
public function PerformMailMerge(): System.Collections.Generic.List;
JScript
public function PerformMailMerge() : System.Collections.Generic.List;
Managed Extensions for C++
public: System.Collections.Generic.List<WebTextEditorMailMergeObject*>* PerformMailMerge();
C++/CLI
public:
System.Collections.Generic.List<WebTextEditorMailMergeObject^>^ PerformMailMerge();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members
Overload List


PerformMailMerge(String,IEnumerable,WebTextEditorLabelCollection) Method

[image]
Intersoft WebTextEditor Documentation
PerformMailMerge(String,IEnumerable,WebTextEditorLabelCollection) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class > PerformMailMerge Method : PerformMailMerge(String,IEnumerable,WebTextEditorLabelCollection) Method

text
recipients
labels

Glossary Item Box

Perform mail merge from WebTextEditor's content to mail merge string with recipient provided

Syntax

Visual Basic (Declaration)
Public Overloads Function PerformMailMerge( _
   ByVal text As System.String, _
   ByVal recipients As System.Collections.IEnumerable, _
   ByVal labels As WebTextEditorLabelCollection _
) As System.Collections.Generic.List(Of WebTextEditorMailMergeObject)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim text As System.String
Dim recipients As System.Collections.IEnumerable
Dim labels As WebTextEditorLabelCollection
Dim value As System.Collections.Generic.List(Of WebTextEditorMailMergeObject)

value = instance.PerformMailMerge(text, recipients, labels)
C#
public System.Collections.Generic.List<WebTextEditorMailMergeObject> PerformMailMerge(
   System.string text,
   System.Collections.IEnumerable recipients,
   WebTextEditorLabelCollection labels
)
Delphi
public function PerformMailMerge(
    text: System.String;
    recipients: System.Collections.IEnumerable;
    labels: WebTextEditorLabelCollection
): System.Collections.Generic.List;
JScript
public function PerformMailMerge(
   text : System.String,
   recipients : System.Collections.IEnumerable,
   labels : WebTextEditorLabelCollection
) : System.Collections.Generic.List;
Managed Extensions for C++
public: System.Collections.Generic.List<WebTextEditorMailMergeObject*>* PerformMailMerge(
   System.string* text,
   System.Collections.IEnumerable* recipients,
   WebTextEditorLabelCollection* labels
)
C++/CLI
public:
System.Collections.Generic.List<WebTextEditorMailMergeObject^>^ PerformMailMerge(
   System.String^ text,
   System.Collections.IEnumerable^ recipients,
   WebTextEditorLabelCollection^ labels
)

Parameters

text
recipients
labels

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members
Overload List


PerformSendMail Method

[image]
Intersoft WebTextEditor Documentation
PerformSendMail Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : PerformSendMail Method

data

Glossary Item Box

Perform send mail action on mail merge collection.

Syntax

Visual Basic (Declaration)
Public Sub PerformSendMail( _
   ByVal data As System.Collections.Generic.List(Of WebTextEditorMailMergeObject) _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim data As System.Collections.Generic.List(Of WebTextEditorMailMergeObject)

instance.PerformSendMail(data)
C#
public void PerformSendMail(
   System.Collections.Generic.List<WebTextEditorMailMergeObject> data
)
Delphi
public procedure PerformSendMail(
    data: System.Collections.Generic.List
);
JScript
public function PerformSendMail(
   data : System.Collections.Generic.List
);
Managed Extensions for C++
public: void PerformSendMail(
   System.Collections.Generic.List<WebTextEditorMailMergeObject*>* data
)
C++/CLI
public:
void PerformSendMail(
   System.Collections.Generic.List<WebTextEditorMailMergeObject^>^ data
)

Parameters

data

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


RaisePostBackEvent Method

[image]
Intersoft WebTextEditor Documentation
RaisePostBackEvent Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : RaisePostBackEvent Method

eventArgument

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RaisePostBackEvent( _
   ByVal eventArgument As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim eventArgument As System.String

instance.RaisePostBackEvent(eventArgument)
C#
public void RaisePostBackEvent(
   System.string eventArgument
)
Delphi
public procedure RaisePostBackEvent(
    eventArgument: System.String
);
JScript
public function RaisePostBackEvent(
   eventArgument : System.String
);
Managed Extensions for C++
public: void RaisePostBackEvent(
   System.string* eventArgument
)
C++/CLI
public:
void RaisePostBackEvent(
   System.String^ eventArgument
)

Parameters

eventArgument

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


RecreateChildControls Method

[image]
Intersoft WebTextEditor Documentation
RecreateChildControls Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : RecreateChildControls Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RecreateChildControls()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor

instance.RecreateChildControls()
C#
public void RecreateChildControls()
Delphi
public procedure RecreateChildControls();
JScript
public function RecreateChildControls();
Managed Extensions for C++
public: void RecreateChildControls();
C++/CLI
public:
void RecreateChildControls();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


RegisterClientScript Method

[image]
Intersoft WebTextEditor Documentation
RegisterClientScript Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : RegisterClientScript Method

type

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterClientScript( _
   ByVal type As WebTextEditorClientScript _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim type As WebTextEditorClientScript

instance.RegisterClientScript(type)
C#
public void RegisterClientScript(
   WebTextEditorClientScript type
)
Delphi
public procedure RegisterClientScript(
    type: WebTextEditorClientScript
);
JScript
public function RegisterClientScript(
   type : WebTextEditorClientScript
);
Managed Extensions for C++
public: void RegisterClientScript(
   WebTextEditorClientScript type
)
C++/CLI
public:
void RegisterClientScript(
   WebTextEditorClientScript type
)

Parameters

type

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


RegisterClientStyle Method

[image]
Intersoft WebTextEditor Documentation
RegisterClientStyle Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : RegisterClientStyle Method

type

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterClientStyle( _
   ByVal type As WebTextEditorClientStyle _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim type As WebTextEditorClientStyle

instance.RegisterClientStyle(type)
C#
public void RegisterClientStyle(
   WebTextEditorClientStyle type
)
Delphi
public procedure RegisterClientStyle(
    type: WebTextEditorClientStyle
);
JScript
public function RegisterClientStyle(
   type : WebTextEditorClientStyle
);
Managed Extensions for C++
public: void RegisterClientStyle(
   WebTextEditorClientStyle type
)
C++/CLI
public:
void RegisterClientStyle(
   WebTextEditorClientStyle type
)

Parameters

type

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


RegisterScript Method

[image]
Intersoft WebTextEditor Documentation
RegisterScript Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : RegisterScript Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub RegisterScript()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor

instance.RegisterScript()
C#
public override void RegisterScript()
Delphi
public procedure RegisterScript(); override;
JScript
public override function RegisterScript();
Managed Extensions for C++
public: void RegisterScript(); override
C++/CLI
public:
void RegisterScript(); override

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


RenderEndTag Method

[image]
Intersoft WebTextEditor Documentation
RenderEndTag Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : RenderEndTag Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides Sub RenderEndTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderEndTag(writer)
C#
public override void RenderEndTag(
   System.Web.UI.HtmlTextWriter writer
)
Delphi
public procedure RenderEndTag(
    writer: System.Web.UI.HtmlTextWriter
); override;
JScript
public override function RenderEndTag(
   writer : System.Web.UI.HtmlTextWriter
);
Managed Extensions for C++
public: void RenderEndTag(
   System.Web.UI.HtmlTextWriter* writer
) override
C++/CLI
public:
void RenderEndTag(
   System.Web.UI.HtmlTextWriter^ writer
) override

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


SaveContentToFile Method

[image]
Intersoft WebTextEditor Documentation
SaveContentToFile Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : SaveContentToFile Method

Glossary Item Box

Save WebTextEditor's content to file.

Overload List

Overload | Description
SaveContentToFile(String) | Save WebTextEditor's content to file.
SaveContentToFile(String,WebTextEditorHtmlDocType) | Save WebTextEditor's content to file.
SaveContentToFile(String,WebTextEditorHtmlDocType,String) | Save WebTextEditor's content to file.
SaveContentToFile(String,WebTextEditorHtmlDocType,String,Boolean) | Save WebTextEditor's content to file.
SaveContentToFile(String,String) | Save WebTextEditor's content to file.
SaveContentToFile(String,String,WebTextEditorHtmlDocType) | Save WebTextEditor's content to file.
SaveContentToFile(String,String,WebTextEditorHtmlDocType,String) | Save WebTextEditor's content to file.
SaveContentToFile(String,String,WebTextEditorHtmlDocType,String,Boolean) | Save WebTextEditor's content to file.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


SaveContentToFile(String) Method

[image]
Intersoft WebTextEditor Documentation
SaveContentToFile(String) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class > SaveContentToFile Method : SaveContentToFile(String) Method

fileName

Glossary Item Box

Save WebTextEditor's content to file.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SaveContentToFile( _
   ByVal fileName As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim fileName As System.String

instance.SaveContentToFile(fileName)
C#
public void SaveContentToFile(
   System.string fileName
)
Delphi
public procedure SaveContentToFile(
    fileName: System.String
);
JScript
public function SaveContentToFile(
   fileName : System.String
);
Managed Extensions for C++
public: void SaveContentToFile(
   System.string* fileName
)
C++/CLI
public:
void SaveContentToFile(
   System.String^ fileName
)

Parameters

fileName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members
Overload List


SaveContentToFile(String,WebTextEditorHtmlDocType) Method

[image]
Intersoft WebTextEditor Documentation
SaveContentToFile(String,WebTextEditorHtmlDocType) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class > SaveContentToFile Method : SaveContentToFile(String,WebTextEditorHtmlDocType) Method

fileName
docType

Glossary Item Box

Save WebTextEditor's content to file.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SaveContentToFile( _
   ByVal fileName As System.String, _
   ByVal docType As WebTextEditorHtmlDocType _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim fileName As System.String
Dim docType As WebTextEditorHtmlDocType

instance.SaveContentToFile(fileName, docType)
C#
public void SaveContentToFile(
   System.string fileName,
   WebTextEditorHtmlDocType docType
)
Delphi
public procedure SaveContentToFile(
    fileName: System.String;
    docType: WebTextEditorHtmlDocType
);
JScript
public function SaveContentToFile(
   fileName : System.String,
   docType : WebTextEditorHtmlDocType
);
Managed Extensions for C++
public: void SaveContentToFile(
   System.string* fileName,
   WebTextEditorHtmlDocType docType
)
C++/CLI
public:
void SaveContentToFile(
   System.String^ fileName,
   WebTextEditorHtmlDocType docType
)

Parameters

fileName
docType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members
Overload List


SaveContentToFile(String,WebTextEditorHtmlDocType,String) Method

[image]
Intersoft WebTextEditor Documentation
SaveContentToFile(String,WebTextEditorHtmlDocType,String) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class > SaveContentToFile Method : SaveContentToFile(String,WebTextEditorHtmlDocType,String) Method

fileName
docType
title

Glossary Item Box

Save WebTextEditor's content to file.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SaveContentToFile( _
   ByVal fileName As System.String, _
   ByVal docType As WebTextEditorHtmlDocType, _
   ByVal title As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim fileName As System.String
Dim docType As WebTextEditorHtmlDocType
Dim title As System.String

instance.SaveContentToFile(fileName, docType, title)
C#
public void SaveContentToFile(
   System.string fileName,
   WebTextEditorHtmlDocType docType,
   System.string title
)
Delphi
public procedure SaveContentToFile(
    fileName: System.String;
    docType: WebTextEditorHtmlDocType;
    title: System.String
);
JScript
public function SaveContentToFile(
   fileName : System.String,
   docType : WebTextEditorHtmlDocType,
   title : System.String
);
Managed Extensions for C++
public: void SaveContentToFile(
   System.string* fileName,
   WebTextEditorHtmlDocType docType,
   System.string* title
)
C++/CLI
public:
void SaveContentToFile(
   System.String^ fileName,
   WebTextEditorHtmlDocType docType,
   System.String^ title
)

Parameters

fileName
docType
title

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members
Overload List


SaveContentToFile(String,WebTextEditorHtmlDocType,String,Boolean) Method

[image]
Intersoft WebTextEditor Documentation
SaveContentToFile(String,WebTextEditorHtmlDocType,String,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class > SaveContentToFile Method : SaveContentToFile(String,WebTextEditorHtmlDocType,String,Boolean) Method

fileName
docType
title
saveFullHTML

Glossary Item Box

Save WebTextEditor's content to file.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SaveContentToFile( _
   ByVal fileName As System.String, _
   ByVal docType As WebTextEditorHtmlDocType, _
   ByVal title As System.String, _
   ByVal saveFullHTML As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim fileName As System.String
Dim docType As WebTextEditorHtmlDocType
Dim title As System.String
Dim saveFullHTML As System.Boolean

instance.SaveContentToFile(fileName, docType, title, saveFullHTML)
C#
public void SaveContentToFile(
   System.string fileName,
   WebTextEditorHtmlDocType docType,
   System.string title,
   System.bool saveFullHTML
)
Delphi
public procedure SaveContentToFile(
    fileName: System.String;
    docType: WebTextEditorHtmlDocType;
    title: System.String;
    saveFullHTML: System.Boolean
);
JScript
public function SaveContentToFile(
   fileName : System.String,
   docType : WebTextEditorHtmlDocType,
   title : System.String,
   saveFullHTML : System.boolean
);
Managed Extensions for C++
public: void SaveContentToFile(
   System.string* fileName,
   WebTextEditorHtmlDocType docType,
   System.string* title,
   System.bool saveFullHTML
)
C++/CLI
public:
void SaveContentToFile(
   System.String^ fileName,
   WebTextEditorHtmlDocType docType,
   System.String^ title,
   System.bool saveFullHTML
)

Parameters

fileName
docType
title
saveFullHTML

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members
Overload List


SaveContentToFile(String,String) Method

[image]
Intersoft WebTextEditor Documentation
SaveContentToFile(String,String) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class > SaveContentToFile Method : SaveContentToFile(String,String) Method

fileName
sectionName

Glossary Item Box

Save WebTextEditor's content to file.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SaveContentToFile( _
   ByVal fileName As System.String, _
   ByVal sectionName As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim fileName As System.String
Dim sectionName As System.String

instance.SaveContentToFile(fileName, sectionName)
C#
public void SaveContentToFile(
   System.string fileName,
   System.string sectionName
)
Delphi
public procedure SaveContentToFile(
    fileName: System.String;
    sectionName: System.String
);
JScript
public function SaveContentToFile(
   fileName : System.String,
   sectionName : System.String
);
Managed Extensions for C++
public: void SaveContentToFile(
   System.string* fileName,
   System.string* sectionName
)
C++/CLI
public:
void SaveContentToFile(
   System.String^ fileName,
   System.String^ sectionName
)

Parameters

fileName
sectionName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members
Overload List


SaveContentToFile(String,String,WebTextEditorHtmlDocType) Method

[image]
Intersoft WebTextEditor Documentation
SaveContentToFile(String,String,WebTextEditorHtmlDocType) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class > SaveContentToFile Method : SaveContentToFile(String,String,WebTextEditorHtmlDocType) Method

fileName
sectionName
docType

Glossary Item Box

Save WebTextEditor's content to file.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SaveContentToFile( _
   ByVal fileName As System.String, _
   ByVal sectionName As System.String, _
   ByVal docType As WebTextEditorHtmlDocType _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim fileName As System.String
Dim sectionName As System.String
Dim docType As WebTextEditorHtmlDocType

instance.SaveContentToFile(fileName, sectionName, docType)
C#
public void SaveContentToFile(
   System.string fileName,
   System.string sectionName,
   WebTextEditorHtmlDocType docType
)
Delphi
public procedure SaveContentToFile(
    fileName: System.String;
    sectionName: System.String;
    docType: WebTextEditorHtmlDocType
);
JScript
public function SaveContentToFile(
   fileName : System.String,
   sectionName : System.String,
   docType : WebTextEditorHtmlDocType
);
Managed Extensions for C++
public: void SaveContentToFile(
   System.string* fileName,
   System.string* sectionName,
   WebTextEditorHtmlDocType docType
)
C++/CLI
public:
void SaveContentToFile(
   System.String^ fileName,
   System.String^ sectionName,
   WebTextEditorHtmlDocType docType
)

Parameters

fileName
sectionName
docType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members
Overload List


SaveContentToFile(String,String,WebTextEditorHtmlDocType,String) Method

[image]
Intersoft WebTextEditor Documentation
SaveContentToFile(String,String,WebTextEditorHtmlDocType,String) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class > SaveContentToFile Method : SaveContentToFile(String,String,WebTextEditorHtmlDocType,String) Method

fileName
sectionName
docType
title

Glossary Item Box

Save WebTextEditor's content to file.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SaveContentToFile( _
   ByVal fileName As System.String, _
   ByVal sectionName As System.String, _
   ByVal docType As WebTextEditorHtmlDocType, _
   ByVal title As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim fileName As System.String
Dim sectionName As System.String
Dim docType As WebTextEditorHtmlDocType
Dim title As System.String

instance.SaveContentToFile(fileName, sectionName, docType, title)
C#
public void SaveContentToFile(
   System.string fileName,
   System.string sectionName,
   WebTextEditorHtmlDocType docType,
   System.string title
)
Delphi
public procedure SaveContentToFile(
    fileName: System.String;
    sectionName: System.String;
    docType: WebTextEditorHtmlDocType;
    title: System.String
);
JScript
public function SaveContentToFile(
   fileName : System.String,
   sectionName : System.String,
   docType : WebTextEditorHtmlDocType,
   title : System.String
);
Managed Extensions for C++
public: void SaveContentToFile(
   System.string* fileName,
   System.string* sectionName,
   WebTextEditorHtmlDocType docType,
   System.string* title
)
C++/CLI
public:
void SaveContentToFile(
   System.String^ fileName,
   System.String^ sectionName,
   WebTextEditorHtmlDocType docType,
   System.String^ title
)

Parameters

fileName
sectionName
docType
title

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members
Overload List


SaveContentToFile(String,String,WebTextEditorHtmlDocType,String,Boolean) Method

[image]
Intersoft WebTextEditor Documentation
SaveContentToFile(String,String,WebTextEditorHtmlDocType,String,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class > SaveContentToFile Method : SaveContentToFile(String,String,WebTextEditorHtmlDocType,String,Boolean) Method

fileName
sectionName
docType
title
saveFullHTML

Glossary Item Box

Save WebTextEditor's content to file.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SaveContentToFile( _
   ByVal fileName As System.String, _
   ByVal sectionName As System.String, _
   ByVal docType As WebTextEditorHtmlDocType, _
   ByVal title As System.String, _
   ByVal saveFullHTML As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim fileName As System.String
Dim sectionName As System.String
Dim docType As WebTextEditorHtmlDocType
Dim title As System.String
Dim saveFullHTML As System.Boolean

instance.SaveContentToFile(fileName, sectionName, docType, title, saveFullHTML)
C#
public void SaveContentToFile(
   System.string fileName,
   System.string sectionName,
   WebTextEditorHtmlDocType docType,
   System.string title,
   System.bool saveFullHTML
)
Delphi
public procedure SaveContentToFile(
    fileName: System.String;
    sectionName: System.String;
    docType: WebTextEditorHtmlDocType;
    title: System.String;
    saveFullHTML: System.Boolean
);
JScript
public function SaveContentToFile(
   fileName : System.String,
   sectionName : System.String,
   docType : WebTextEditorHtmlDocType,
   title : System.String,
   saveFullHTML : System.boolean
);
Managed Extensions for C++
public: void SaveContentToFile(
   System.string* fileName,
   System.string* sectionName,
   WebTextEditorHtmlDocType docType,
   System.string* title,
   System.bool saveFullHTML
)
C++/CLI
public:
void SaveContentToFile(
   System.String^ fileName,
   System.String^ sectionName,
   WebTextEditorHtmlDocType docType,
   System.String^ title,
   System.bool saveFullHTML
)

Parameters

fileName
sectionName
docType
title
saveFullHTML

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members
Overload List


SaveToolBarsStructureToXml Method

[image]
Intersoft WebTextEditor Documentation
SaveToolBarsStructureToXml Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : SaveToolBarsStructureToXml Method

Glossary Item Box

Save ToolBar structure to xml file.

Overload List

Overload | Description
SaveToolBarsStructureToXml(String) | Save ToolBar structure to xml file.
SaveToolBarsStructureToXml() | Save ToolBar structure to xml file.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


SaveToolBarsStructureToXml(String) Method

[image]
Intersoft WebTextEditor Documentation
SaveToolBarsStructureToXml(String) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class > SaveToolBarsStructureToXml Method : SaveToolBarsStructureToXml(String) Method

fileName

Glossary Item Box

Save ToolBar structure to xml file.

Syntax

Visual Basic (Declaration)
Public Overloads Sub SaveToolBarsStructureToXml( _
   ByVal fileName As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim fileName As System.String

instance.SaveToolBarsStructureToXml(fileName)
C#
public void SaveToolBarsStructureToXml(
   System.string fileName
)
Delphi
public procedure SaveToolBarsStructureToXml(
    fileName: System.String
);
JScript
public function SaveToolBarsStructureToXml(
   fileName : System.String
);
Managed Extensions for C++
public: void SaveToolBarsStructureToXml(
   System.string* fileName
)
C++/CLI
public:
void SaveToolBarsStructureToXml(
   System.String^ fileName
)

Parameters

fileName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members
Overload List


SaveToolBarsStructureToXml() Method

[image]
Intersoft WebTextEditor Documentation
SaveToolBarsStructureToXml() Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class > SaveToolBarsStructureToXml Method : SaveToolBarsStructureToXml() Method

Glossary Item Box

Save ToolBar structure to xml file.

Syntax

Visual Basic (Declaration)
Public Overloads Function SaveToolBarsStructureToXml() As System.Xml.XmlDocument
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Xml.XmlDocument

value = instance.SaveToolBarsStructureToXml()
C#
public System.Xml.XmlDocument SaveToolBarsStructureToXml()
Delphi
public function SaveToolBarsStructureToXml(): System.Xml.XmlDocument;
JScript
public function SaveToolBarsStructureToXml() : System.Xml.XmlDocument;
Managed Extensions for C++
public: System.Xml.XmlDocument* SaveToolBarsStructureToXml();
C++/CLI
public:
System.Xml.XmlDocument^ SaveToolBarsStructureToXml();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members
Overload List


SearchMedias Method

[image]
Intersoft WebTextEditor Documentation
SearchMedias Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : SearchMedias Method

xmlResponse

Glossary Item Box

Perform media searching in WebTextEditor.

Syntax

Visual Basic (Declaration)
Public Sub SearchMedias( _
   ByVal xmlResponse As System.Xml.XmlDocument _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim xmlResponse As System.Xml.XmlDocument

instance.SearchMedias(xmlResponse)
C#
public void SearchMedias(
   System.Xml.XmlDocument xmlResponse
)
Delphi
public procedure SearchMedias(
    xmlResponse: System.Xml.XmlDocument
);
JScript
public function SearchMedias(
   xmlResponse : System.Xml.XmlDocument
);
Managed Extensions for C++
public: void SearchMedias(
   System.Xml.XmlDocument* xmlResponse
)
C++/CLI
public:
void SearchMedias(
   System.Xml.XmlDocument^ xmlResponse
)

Parameters

xmlResponse

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


WebTextEditor Class Properties

[image]
Intersoft WebTextEditor Documentation
WebTextEditor Class Properties
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditor Class

Glossary Item Box

For a list of all members of this type, see WebTextEditor members.

Public Properties

 | Name | Description
Public Property | AccessKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ActionName |
Public Property | AllowDefaultStyleMerging | Gets or sets the value that determines whether or not the default style can be merged with custom styles.
Public Property | AllowResize | Determines whether or not resize action is allowed.
Public Property | AppRelativeTemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | AspNetAjaxSettings | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Attributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | AutoSaveInterval | Specifies auto save interval (in minute).
Public Property | BackColor | Overridden.
Public Property | BorderColor | Overridden.
Public Property | BorderStyle | Overridden.
Public Property | BorderWidth | Overridden.
Public Property | ClientAction | Returns ClientSideAction class
Public Property | ClientID | (Inherited from System.Web.UI.Control)
Public Property | ClientIDMode | (Inherited from System.Web.UI.Control)
Public Property | ClientSideEvents | Contains client side events supported by WebTextEditor.
Public Property | Content | Specifies content of RootTextEditor.
Public Property | ControlDataTransferFormat | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | Controls | (Inherited from System.Web.UI.Control)
Public Property | ControlStyle | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ControlStyleCreated | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | CssClass | Overridden.
Public Property | DataMember | Specifies mail merge DataMember.
Public Property | DataSourceCount |
Public Property | DataSourceID | Specifies mail merge DataSource's ID.
Public Property | DataSourceManager | Overridden.
Public Property | DefaultStyleMode | Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled.
Public Property | EditorCss |
Public Property | EditorSettings | Provides settings that control the behaviors of the editor in WebTextEditor.
Public Property | EditorTableStyleCss |
Public Property | EnableAutoSave | Determines whether or not auto save feature is enabled.
Public Property | EnableContextMenu | Determines whether or not context menu is enabled.
Public Property | Enabled | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableDocumentImport | Determines whether or not document import is enabled.
Public Property | EnableDocumentPrint | Determines whether or not document print is enabled.
Public Property | EnableDocumentSave | Determines whether or not document save is enabled.
Public Property | EnableEditorTabKey | Determines whether or not WebTextEditor should handle Tab key.
Public Property | EnableFullScreen | Gets or sets the value that determines whether or not full screen feature is enabled.
Public Property | EnableHTMLInspector | Determines whether or not html inspector is enabled.
Public Property | EnableKeyboardSupport | Determines whether or not keyboard support is enabled.
Public Property | EnableManagedTheming | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableTheming | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableWebResources | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | EnableXHTMLCompliance | Determines whether or not the WebTextEditor's output is XHTML compliance.
Public Property | EnterKeyAction | Specifies WebTextEditor behavior when enter key is pressed.
Public Property | FileUploader |
Public Property | FileUploaderSettings | Provides settings that control the behaviors of the file uploader in WebTextEditor.
Public Property | FloatingToolBarFrameStyle | Contains interactive style for Floating ToolBar frame.
Public Property | FlyPostBackSettings | Configures the settings used by the control when performing OnTheFly postback.
Public Property | FocusOnLoad |
Public Property | Font | Overridden.
Public Property | FooterFrameStyle | Contains interactive style for footer frame.
Public Property | ForeColor | Overridden.
Public Property | FrameLayerStyle | Contains interactive style for Frame layer that will be displayed when the editor is resized.
Public Property | FrameStyle | Contains interactive style for Frame.
Public Property | HasAttributes | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | HeaderFrameStyle | Contains interactive style for header frame.
Public Property | Height | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | HTMLInspectorContentStyle | Contains interactive style for the content of HTML inspector section in footer.
Public Property | HTMLInspectorLeftIndicatorDisabledStyle | Contains interactive style for left indicator of HTML inspector in footer when it is disabled.
Public Property | HTMLInspectorLeftIndicatorStyle | Contains interactive style for left indicator of HTML inspector section in footer.
Public Property | HTMLInspectorRightIndicatorDisabledStyle | Contains interactive style for right indicator of HTML inspector in footer when it is disabled.
Public Property | HTMLInspectorRightIndicatorStyle | Contains interactive style for right indicator of HTML inspector section in footer.
Public Property | HTMLToolBar |
Public Property | ID | (Inherited from System.Web.UI.Control)
Public Property | ImagesDirectory | Gets or sets the images directory.
Public Property | ImagesSettings | Provides settings that control the images in WebTextEditor.
Public Property | IsControlThemed | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | IsDesign | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | IsDynamicCreated | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | IsFlyPostBack |
Public Property | IsInternalCreated | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | IsUnloaded | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | LeftFooterStyle | Contains interactive style for left section of footer.
Public Property | MailMergeLabelStyle | Contains interactive style for mail merge label.
Public Property | MailMergeSettings | Provides settings that control the behaviors of mail merge in WebTextEditor.
Public Property | MaximumSize | Gets or sets the value that determines the maximum size of WebTextEditor when it is resized.
Public Property | MediaResources | The media resources collection used by WebTextEditor to filter the media in Media Gallery task pane.
Public Property | Medias | The media collection used by WebTextEditor in Media Gallery task pane.
Public Property | MinimumSize | Gets or sets the value that determines the minimum size of WebTextEditor when it is resized.
Public Property | NamingContainer | (Inherited from System.Web.UI.Control)
Public Property | Page | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ParagraphMode | Specifies the behavior for paragraph editing.
Public Property | Parent | (Inherited from System.Web.UI.Control)
Public Property | ParentStyleId | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | PreventScriptInjection | Determines whether or not script tag is removed from WebTextEditor.
Public Property | PreviewToolBar |
Public Property | RawFloatingToolBar |
Public Property | RenderingCompatibility | (Inherited from System.Web.UI.Control)
Public Property | RenderingMode | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | RequiresUIRefresh | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ResizerStyle | Contains interactive style for resizer in footer.
Public Property | RightFooterStyle | Contains interactive style for right section of footer.
Public Property | RootTextEditor | Provides settings that control the behaviors of single section in WebTextEditor.
Public Property | RuntimeLicenseKey | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | SaveViewStateOnFlyPostback | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ScriptDirectory | Overridden. Gets or sets the directory where all required scripts for the control are stored.
Public Property | SectionLineStyle | Contains interactive style for TextEditor Section Line.
Public Property | SectionTextStyle | Contains interactive style for TextEditor Section Text.
Public Property | SerializedJSFiles | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | SerializedStyles | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | SharedScriptDirectory | Overridden. Gets or sets the directory where all required framework scripts for the control are stored.
Public Property | ShowCallOutOnMediaInsert | Determines whether or not callout will appear when media is inserted.
Public Property | ShowCharacterInformation | Determines whether or not character information should be shown as tooltip.
Public Property | ShowMediaActionOnMediaSelect | Determines whether or not media action will appear when media is selected.
Public Property | ShowWordInformation | Determines whether or not word information should be shown.
Public Property | Site | (Inherited from System.Web.UI.Control)
Public Property | SkinID | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | SplitterStyle | Contains interactive style for Splitter.
Public Property | Style | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | SupportsDisabledAttribute | (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | SupportXMLCultureInfo | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | TabIndex | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | TaskPaneSettings | Provides settings that control the behaviors of the taskpane in WebTextEditor.
Public Property | TemplateControl | (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | (Inherited from System.Web.UI.Control)
Public Property | TextEditorSections | Provides settings that control the behaviors of multiple section in WebTextEditor.
Public Property | TextSettings | Provides settings that control text that shown in WebTextEditor.
Public Property | ToolBar |
Public Property | ToolBarSettings | Provides settings that control the behaviors of the toolbar in WebTextEditor.
Public Property | ToolTip | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | UndoLatency | Specifies undo latency interval (in milisecond).
Public Property | UniqueID | (Inherited from System.Web.UI.Control)
Public Property | UploadBarFrameStyle | Contains interactive style for upload bar frame in footer.
Public Property | UploadBarTextStyle | Contains interactive style for upload bar text in footer.
Public Property | UseDefaultEditorStylesForPrint | Determines whether or not default styles are included when the printing the content.
Public Property | UseDefaultStyle | Determines whether or not WebTextEditor is using default style.
Public Property | ValidateRequestMode | (Inherited from System.Web.UI.Control)
Public Property | ViewIndicatorStyle | Contains interactive style for view tab indicator in footer.
Public Property | ViewSettings | Provides settings that control the behaviors of the view in WebTextEditor.
Public Property | ViewStateItems | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateMode | (Inherited from System.Web.UI.Control)
Public Property | ViewStateServerConnection | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewStateStorage | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | ViewTabStyle | Contains interactive style for view tab in footer.
Public Property | Visible | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | WatermarkStyle | Contains interactive style for TextEditor's Watermark.
Public Property | WebDesktopScriptDirectory | Gets or sets the IIS path to locate WebDesktop's script directory. This property is only applicable when SmartWebResources is not enabled.
Public Property | Width | (Inherited from ISNet.WebUI.ISNetControl)
Public Property | XmlCompressionEnabled | (Inherited from ISNet.WebUI.ISNetControl)
Top

Protected Properties

 | Name | Description
Protected Property | Adapter | (Inherited from System.Web.UI.Control)
Protected Property | ChildControlsCreated | (Inherited from System.Web.UI.Control)
Protected Property | ClientIDSeparator | (Inherited from System.Web.UI.Control)
Protected Property | DefaultImagesFolder | Overridden.
Protected Property | Events | (Inherited from System.Web.UI.Control)
Protected Property | HasChildViewState | (Inherited from System.Web.UI.Control)
Protected Property | IdSeparator | (Inherited from System.Web.UI.Control)
Protected Property | IsMvc | (Inherited from ISNet.WebUI.ISNetControl)
Protected Property | IsTrackingViewState | (Inherited from System.Web.UI.Control)
Protected Property | LicenseType | Overridden.
Protected Property | LoadViewStateByID | (Inherited from System.Web.UI.Control)
Protected Property | MaxJsonLength | (Inherited from ISNet.WebUI.ISNetControl)
Protected Property | Product | Overridden.
Protected Property | ProductIcon | Overridden.
Protected Property | ProductImage | Overridden.
Protected Property | SupportDataSourceControl | Overridden.
Protected Property | TagKey | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Property | TagName | (Inherited from System.Web.UI.WebControls.WebControl)
Protected Property | ViewState | (Inherited from System.Web.UI.Control)
Protected Property | ViewStateIgnoresCase | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

WebTextEditor Class
ISNet.WebUI.WebTextEditor Namespace


ActionName Property

[image]
Intersoft WebTextEditor Documentation
ActionName Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : ActionName Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property ActionName As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.String

instance.ActionName = value

value = instance.ActionName
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public System.string ActionName {get; set;}
Delphi
public read-write property ActionName: System.String;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get,set ActionName : System.String
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property System.string* get_ActionName();
public: __property void set_ActionName(
   System.string* value
);
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property System.String^ ActionName {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


AllowDefaultStyleMerging Property

[image]
Intersoft WebTextEditor Documentation
AllowDefaultStyleMerging Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : AllowDefaultStyleMerging Property

Glossary Item Box

Gets or sets the value that determines whether or not the default style can be merged with custom styles.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not the default style can be merged with custom styles.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
Public Property AllowDefaultStyleMerging As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Boolean

instance.AllowDefaultStyleMerging = value

value = instance.AllowDefaultStyleMerging
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not the default style can be merged with custom styles.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public System.bool AllowDefaultStyleMerging {get; set;}
Delphi
public read-write property AllowDefaultStyleMerging: System.Boolean;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not the default style can be merged with custom styles.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
public function get,set AllowDefaultStyleMerging : System.boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not the default style can be merged with custom styles.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public: __property System.bool get_AllowDefaultStyleMerging();
public: __property void set_AllowDefaultStyleMerging(
   System.bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not the default style can be merged with custom styles.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
public:
property System.bool AllowDefaultStyleMerging {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is True.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


AllowResize Property

[image]
Intersoft WebTextEditor Documentation
AllowResize Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : AllowResize Property

Glossary Item Box

Determines whether or not resize action is allowed.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Determines whether or not resize action is allowed.")>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Property AllowResize As WebTextEditorResizeMode
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As WebTextEditorResizeMode

instance.AllowResize = value

value = instance.AllowResize
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether or not resize action is allowed.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
public WebTextEditorResizeMode AllowResize {get; set;}
Delphi
public read-write property AllowResize: WebTextEditorResizeMode;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Determines whether or not resize action is allowed.")
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set AllowResize : WebTextEditorResizeMode
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether or not resize action is allowed.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property WebTextEditorResizeMode get_AllowResize();
public: __property void set_AllowResize(
   WebTextEditorResizeMode value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether or not resize action is allowed.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
property WebTextEditorResizeMode AllowResize {
   WebTextEditorResizeMode get();
   void set (    WebTextEditorResizeMode value);
}

Property Value

The default value is No.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


AutoSaveInterval Property

[image]
Intersoft WebTextEditor Documentation
AutoSaveInterval Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : AutoSaveInterval Property

Glossary Item Box

Specifies auto save interval (in minute).

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies auto save interval (in minute).")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Property AutoSaveInterval As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Integer

instance.AutoSaveInterval = value

value = instance.AutoSaveInterval
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies auto save interval (in minute).")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public System.int AutoSaveInterval {get; set;}
Delphi
public read-write property AutoSaveInterval: System.Integer;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies auto save interval (in minute).")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set AutoSaveInterval : System.int
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies auto save interval (in minute).")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property System.int get_AutoSaveInterval();
public: __property void set_AutoSaveInterval(
   System.int value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies auto save interval (in minute).")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
property System.int AutoSaveInterval {
   System.int get();
   void set (    System.int value);
}

Property Value

The default value is 15 minute.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


BackColor Property

[image]
Intersoft WebTextEditor Documentation
BackColor Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : BackColor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Overrides Property BackColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Drawing.Color

instance.BackColor = value

value = instance.BackColor
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public override System.Drawing.Color BackColor {get; set;}
Delphi
public read-write property BackColor: System.Drawing.Color; override;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public override function get,set BackColor : System.Drawing.Color
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property System.Drawing.Color get_BackColor() override;
public: __property void set_BackColor(
   System.Drawing.Color value
) override;
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property System.Drawing.Color BackColor {
   System.Drawing.Color get() override;
   void set (    System.Drawing.Color value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


BorderColor Property

[image]
Intersoft WebTextEditor Documentation
BorderColor Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : BorderColor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
Public Overrides Property BorderColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Drawing.Color

instance.BorderColor = value

value = instance.BorderColor
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public override System.Drawing.Color BorderColor {get; set;}
Delphi
public read-write property BorderColor: System.Drawing.Color; override;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
public override function get,set BorderColor : System.Drawing.Color
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public: __property System.Drawing.Color get_BorderColor() override;
public: __property void set_BorderColor(
   System.Drawing.Color value
) override;
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public:
property System.Drawing.Color BorderColor {
   System.Drawing.Color get() override;
   void set (    System.Drawing.Color value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


BorderStyle Property

[image]
Intersoft WebTextEditor Documentation
BorderStyle Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : BorderStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Overrides Property BorderStyle As System.Web.UI.WebControls.BorderStyle
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Web.UI.WebControls.BorderStyle

instance.BorderStyle = value

value = instance.BorderStyle
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public override System.Web.UI.WebControls.BorderStyle BorderStyle {get; set;}
Delphi
public read-write property BorderStyle: System.Web.UI.WebControls.BorderStyle; override;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public override function get,set BorderStyle : System.Web.UI.WebControls.BorderStyle
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property System.Web.UI.WebControls.BorderStyle get_BorderStyle() override;
public: __property void set_BorderStyle(
   System.Web.UI.WebControls.BorderStyle value
) override;
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property System.Web.UI.WebControls.BorderStyle BorderStyle {
   System.Web.UI.WebControls.BorderStyle get() override;
   void set (    System.Web.UI.WebControls.BorderStyle value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


BorderWidth Property

[image]
Intersoft WebTextEditor Documentation
BorderWidth Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : BorderWidth Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
Public Overrides Property BorderWidth As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Web.UI.WebControls.Unit

instance.BorderWidth = value

value = instance.BorderWidth
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public override System.Web.UI.WebControls.Unit BorderWidth {get; set;}
Delphi
public read-write property BorderWidth: System.Web.UI.WebControls.Unit; override;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
public override function get,set BorderWidth : System.Web.UI.WebControls.Unit
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public: __property System.Web.UI.WebControls.Unit get_BorderWidth() override;
public: __property void set_BorderWidth(
   System.Web.UI.WebControls.Unit value
) override;
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public:
property System.Web.UI.WebControls.Unit BorderWidth {
   System.Web.UI.WebControls.Unit get() override;
   void set (    System.Web.UI.WebControls.Unit value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


ClientAction Property

[image]
Intersoft WebTextEditor Documentation
ClientAction Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : ClientAction Property

Glossary Item Box

Returns ClientSideAction class

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DescriptionAttribute("Returns ClientSideAction class.")>
Public ReadOnly Property ClientAction As ISNet.WebUI.BaseClientSideAction
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As ISNet.WebUI.BaseClientSideAction

value = instance.ClientAction
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DescriptionAttribute("Returns ClientSideAction class.")]
public ISNet.WebUI.BaseClientSideAction ClientAction {get;}
Delphi
public read-only property ClientAction: ISNet.WebUI.BaseClientSideAction;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DescriptionAttribute("Returns ClientSideAction class.")
public function get ClientAction : ISNet.WebUI.BaseClientSideAction
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DescriptionAttribute("Returns ClientSideAction class.")]
public: __property ISNet.WebUI.BaseClientSideAction* get_ClientAction();
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DescriptionAttribute("Returns ClientSideAction class.")]
public:
property ISNet.WebUI.BaseClientSideAction^ ClientAction {
   ISNet.WebUI.BaseClientSideAction^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


ClientSideEvents Property

[image]
Intersoft WebTextEditor Documentation
ClientSideEvents Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : ClientSideEvents Property

Glossary Item Box

Contains client side events supported by WebTextEditor.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Contains client side events supported by WebTextEditor.")>
Public ReadOnly Property ClientSideEvents As WebTextEditorClientSideEvents
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As WebTextEditorClientSideEvents

value = instance.ClientSideEvents
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains client side events supported by WebTextEditor.")]
public WebTextEditorClientSideEvents ClientSideEvents {get;}
Delphi
public read-only property ClientSideEvents: WebTextEditorClientSideEvents;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Client Side Events")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Contains client side events supported by WebTextEditor.")
public function get ClientSideEvents : WebTextEditorClientSideEvents
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains client side events supported by WebTextEditor.")]
public: __property WebTextEditorClientSideEvents* get_ClientSideEvents();
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains client side events supported by WebTextEditor.")]
public:
property WebTextEditorClientSideEvents^ ClientSideEvents {
   WebTextEditorClientSideEvents^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


Content Property

[image]
Intersoft WebTextEditor Documentation
Content Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : Content Property

Glossary Item Box

Specifies content of RootTextEditor.

Syntax

Visual Basic (Declaration)
Public Property Content As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.String

instance.Content = value

value = instance.Content
C#
public System.string Content {get; set;}
Delphi
public read-write property Content: System.String;
JScript
public function get,set Content : System.String
Managed Extensions for C++
public: __property System.string* get_Content();
public: __property void set_Content(
   System.string* value
);
C++/CLI
public:
property System.String^ Content {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


CssClass Property

[image]
Intersoft WebTextEditor Documentation
CssClass Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : CssClass Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
Public Overrides Property CssClass As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.String

instance.CssClass = value

value = instance.CssClass
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public override System.string CssClass {get; set;}
Delphi
public read-write property CssClass: System.String; override;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
public override function get,set CssClass : System.String
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public: __property System.string* get_CssClass() override;
public: __property void set_CssClass(
   System.string* value
) override;
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public:
property System.String^ CssClass {
   System.String^ get() override;
   void set (    System.String^ value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


DataMember Property

[image]
Intersoft WebTextEditor Documentation
DataMember Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : DataMember Property

Glossary Item Box

Specifies mail merge DataMember.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Data")>
<System.ComponentModel.DescriptionAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.PersistLayoutAttribute(False)>
Public Property DataMember As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.String

instance.DataMember = value

value = instance.DataMember
C#
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.PersistLayoutAttribute(false)]
public System.string DataMember {get; set;}
Delphi
public read-write property DataMember: System.String;
JScript
System.ComponentModel.CategoryAttribute("Data")
System.ComponentModel.DescriptionAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.PersistLayoutAttribute()
public function get,set DataMember : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.PersistLayoutAttribute(false)]
public: __property System.string* get_DataMember();
public: __property void set_DataMember(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.PersistLayoutAttribute(false)]
public:
property System.String^ DataMember {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


DataSourceCount Property

[image]
Intersoft WebTextEditor Documentation
DataSourceCount Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : DataSourceCount Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Mail Merge")>
<System.ComponentModel.DescriptionAttribute("Specifies the value that determines the total number of recipients in Mail Merge.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property DataSourceCount As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Integer

instance.DataSourceCount = value

value = instance.DataSourceCount
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Mail Merge")]
[System.ComponentModel.DescriptionAttribute("Specifies the value that determines the total number of recipients in Mail Merge.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public System.int DataSourceCount {get; set;}
Delphi
public read-write property DataSourceCount: System.Integer;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Mail Merge")
System.ComponentModel.DescriptionAttribute("Specifies the value that determines the total number of recipients in Mail Merge.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get,set DataSourceCount : System.int
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Mail Merge")]
[System.ComponentModel.DescriptionAttribute("Specifies the value that determines the total number of recipients in Mail Merge.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property System.int get_DataSourceCount();
public: __property void set_DataSourceCount(
   System.int value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Mail Merge")]
[System.ComponentModel.DescriptionAttribute("Specifies the value that determines the total number of recipients in Mail Merge.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property System.int DataSourceCount {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


DataSourceID Property

[image]
Intersoft WebTextEditor Documentation
DataSourceID Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : DataSourceID Property

Glossary Item Box

Specifies mail merge DataSource's ID.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Data")>
<System.ComponentModel.DescriptionAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.Web.UI.IDReferencePropertyAttribute(System.Web.UI.DataSourceControl)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property DataSourceID As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.String

instance.DataSourceID = value

value = instance.DataSourceID
C#
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.IDReferencePropertyAttribute(System.Web.UI.DataSourceControl)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string DataSourceID {get; set;}
Delphi
public read-write property DataSourceID: System.String;
JScript
System.ComponentModel.CategoryAttribute("Data")
System.ComponentModel.DescriptionAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.Web.UI.IDReferencePropertyAttribute(System.Web.UI.DataSourceControl)
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set DataSourceID : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.IDReferencePropertyAttribute(System.Web.UI.DataSourceControl)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_DataSourceID();
public: __property void set_DataSourceID(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Data")]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.IDReferencePropertyAttribute(System.Web.UI.DataSourceControl)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ DataSourceID {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


DataSourceManager Property

[image]
Intersoft WebTextEditor Documentation
DataSourceManager Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : DataSourceManager Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overrides ReadOnly Property DataSourceManager As ISNet.WebUI.DataSourceInfo
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As ISNet.WebUI.DataSourceInfo

value = instance.DataSourceManager
C#
public override ISNet.WebUI.DataSourceInfo DataSourceManager {get;}
Delphi
public read-only property DataSourceManager: ISNet.WebUI.DataSourceInfo; override;
JScript
public override function get DataSourceManager : ISNet.WebUI.DataSourceInfo
Managed Extensions for C++
public: __property ISNet.WebUI.DataSourceInfo* get_DataSourceManager() override;
C++/CLI
public:
property ISNet.WebUI.DataSourceInfo^ DataSourceManager {
   ISNet.WebUI.DataSourceInfo^ get() override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


DefaultImagesFolder Property

[image]
Intersoft WebTextEditor Documentation
DefaultImagesFolder Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : DefaultImagesFolder Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property DefaultImagesFolder As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.String

value = instance.DefaultImagesFolder
C#
protected override System.string DefaultImagesFolder {get;}
Delphi
protected read-only property DefaultImagesFolder: System.String; override;
JScript
protected override function get DefaultImagesFolder : System.String
Managed Extensions for C++
protected: __property System.string* get_DefaultImagesFolder() override;
C++/CLI
protected:
property System.String^ DefaultImagesFolder {
   System.String^ get() override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


DefaultStyleMode Property

[image]
Intersoft WebTextEditor Documentation
DefaultStyleMode Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : DefaultStyleMode Property

Glossary Item Box

Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled.")>
<System.ComponentModel.CategoryAttribute("General")>
Public Property DefaultStyleMode As WebTextEditorDefaultStyleMode
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As WebTextEditorDefaultStyleMode

instance.DefaultStyleMode = value

value = instance.DefaultStyleMode
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled.")]
[System.ComponentModel.CategoryAttribute("General")]
public WebTextEditorDefaultStyleMode DefaultStyleMode {get; set;}
Delphi
public read-write property DefaultStyleMode: WebTextEditorDefaultStyleMode;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled.")
System.ComponentModel.CategoryAttribute("General")
public function get,set DefaultStyleMode : WebTextEditorDefaultStyleMode
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled.")]
[System.ComponentModel.CategoryAttribute("General")]
public: __property WebTextEditorDefaultStyleMode get_DefaultStyleMode();
public: __property void set_DefaultStyleMode(
   WebTextEditorDefaultStyleMode value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled.")]
[System.ComponentModel.CategoryAttribute("General")]
public:
property WebTextEditorDefaultStyleMode DefaultStyleMode {
   WebTextEditorDefaultStyleMode get();
   void set (    WebTextEditorDefaultStyleMode value);
}

Property Value

There are two default styles in WebTextEditor, ElegantBlueStyle and ElegantBlackStyle.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


EditorCss Property

[image]
Intersoft WebTextEditor Documentation
EditorCss Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : EditorCss Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute()>
Public Property EditorCss As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.String

instance.EditorCss = value

value = instance.EditorCss
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute()]
public System.string EditorCss {get; set;}
Delphi
public read-write property EditorCss: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute()
public function get,set EditorCss : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute()]
public: __property System.string* get_EditorCss();
public: __property void set_EditorCss(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute()]
public:
property System.String^ EditorCss {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


EditorSettings Property

[image]
Intersoft WebTextEditor Documentation
EditorSettings Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : EditorSettings Property

Glossary Item Box

Provides settings that control the behaviors of the editor in WebTextEditor.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute("setEditorSettings")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Provides settings that control the behaviors of the editor in WebTextEditor.")>
<System.ComponentModel.CategoryAttribute("Editor")>
Public ReadOnly Property EditorSettings As WebTextEditorEditorSettings
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As WebTextEditorEditorSettings

value = instance.EditorSettings
C#
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setEditorSettings")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Provides settings that control the behaviors of the editor in WebTextEditor.")]
[System.ComponentModel.CategoryAttribute("Editor")]
public WebTextEditorEditorSettings EditorSettings {get;}
Delphi
public read-only property EditorSettings: WebTextEditorEditorSettings;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute("setEditorSettings")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Provides settings that control the behaviors of the editor in WebTextEditor.")
System.ComponentModel.CategoryAttribute("Editor")
public function get EditorSettings : WebTextEditorEditorSettings
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setEditorSettings")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Provides settings that control the behaviors of the editor in WebTextEditor.")]
[System.ComponentModel.CategoryAttribute("Editor")]
public: __property WebTextEditorEditorSettings* get_EditorSettings();
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setEditorSettings")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Provides settings that control the behaviors of the editor in WebTextEditor.")]
[System.ComponentModel.CategoryAttribute("Editor")]
public:
property WebTextEditorEditorSettings^ EditorSettings {
   WebTextEditorEditorSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


EditorTableStyleCss Property

[image]
Intersoft WebTextEditor Documentation
EditorTableStyleCss Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : EditorTableStyleCss Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute()>
Public Property EditorTableStyleCss As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.String

instance.EditorTableStyleCss = value

value = instance.EditorTableStyleCss
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute()]
public System.string EditorTableStyleCss {get; set;}
Delphi
public read-write property EditorTableStyleCss: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute()
public function get,set EditorTableStyleCss : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute()]
public: __property System.string* get_EditorTableStyleCss();
public: __property void set_EditorTableStyleCss(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute()]
public:
property System.String^ EditorTableStyleCss {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


EnableAutoSave Property

[image]
Intersoft WebTextEditor Documentation
EnableAutoSave Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : EnableAutoSave Property

Glossary Item Box

Determines whether or not auto save feature is enabled.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Determines whether or not auto save feature is enabled.")>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Property EnableAutoSave As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Boolean

instance.EnableAutoSave = value

value = instance.EnableAutoSave
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether or not auto save feature is enabled.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
public System.bool EnableAutoSave {get; set;}
Delphi
public read-write property EnableAutoSave: System.Boolean;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Determines whether or not auto save feature is enabled.")
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set EnableAutoSave : System.boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether or not auto save feature is enabled.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property System.bool get_EnableAutoSave();
public: __property void set_EnableAutoSave(
   System.bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether or not auto save feature is enabled.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
property System.bool EnableAutoSave {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is False.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


EnableContextMenu Property

[image]
Intersoft WebTextEditor Documentation
EnableContextMenu Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : EnableContextMenu Property

Glossary Item Box

Determines whether or not context menu is enabled.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Determines whether or not context menu is enabled.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property EnableContextMenu As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Boolean

instance.EnableContextMenu = value

value = instance.EnableContextMenu
C#
[System.ComponentModel.DescriptionAttribute("Determines whether or not context menu is enabled.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool EnableContextMenu {get; set;}
Delphi
public read-write property EnableContextMenu: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Determines whether or not context menu is enabled.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set EnableContextMenu : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Determines whether or not context menu is enabled.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_EnableContextMenu();
public: __property void set_EnableContextMenu(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Determines whether or not context menu is enabled.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool EnableContextMenu {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is False.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


EnableDocumentImport Property

[image]
Intersoft WebTextEditor Documentation
EnableDocumentImport Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : EnableDocumentImport Property

Glossary Item Box

Determines whether or not document import is enabled.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.DescriptionAttribute("Determines whether or not document import is enabled.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property EnableDocumentImport As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Boolean

instance.EnableDocumentImport = value

value = instance.EnableDocumentImport
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute("Determines whether or not document import is enabled.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.bool EnableDocumentImport {get; set;}
Delphi
public read-write property EnableDocumentImport: System.Boolean;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.DescriptionAttribute("Determines whether or not document import is enabled.")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set EnableDocumentImport : System.boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute("Determines whether or not document import is enabled.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.bool get_EnableDocumentImport();
public: __property void set_EnableDocumentImport(
   System.bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute("Determines whether or not document import is enabled.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.bool EnableDocumentImport {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is False.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


EnableDocumentPrint Property

[image]
Intersoft WebTextEditor Documentation
EnableDocumentPrint Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : EnableDocumentPrint Property

Glossary Item Box

Determines whether or not document print is enabled.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Determines whether or not document print is enabled.")>
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property EnableDocumentPrint As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Boolean

instance.EnableDocumentPrint = value

value = instance.EnableDocumentPrint
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Determines whether or not document print is enabled.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.bool EnableDocumentPrint {get; set;}
Delphi
public read-write property EnableDocumentPrint: System.Boolean;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Determines whether or not document print is enabled.")
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set EnableDocumentPrint : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Determines whether or not document print is enabled.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.bool get_EnableDocumentPrint();
public: __property void set_EnableDocumentPrint(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Determines whether or not document print is enabled.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.bool EnableDocumentPrint {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is False.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


EnableDocumentSave Property

[image]
Intersoft WebTextEditor Documentation
EnableDocumentSave Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : EnableDocumentSave Property

Glossary Item Box

Determines whether or not document save is enabled.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Determines whether or not document save is enabled.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property EnableDocumentSave As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Boolean

instance.EnableDocumentSave = value

value = instance.EnableDocumentSave
C#
[System.ComponentModel.DescriptionAttribute("Determines whether or not document save is enabled.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.bool EnableDocumentSave {get; set;}
Delphi
public read-write property EnableDocumentSave: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Determines whether or not document save is enabled.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set EnableDocumentSave : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Determines whether or not document save is enabled.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.bool get_EnableDocumentSave();
public: __property void set_EnableDocumentSave(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Determines whether or not document save is enabled.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.bool EnableDocumentSave {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is False.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


EnableEditorTabKey Property

[image]
Intersoft WebTextEditor Documentation
EnableEditorTabKey Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : EnableEditorTabKey Property

Glossary Item Box

Determines whether or not WebTextEditor should handle Tab key.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Determines whether or not WebTextEditor should handle Tab key.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Editor")>
Public Property EnableEditorTabKey As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Boolean

instance.EnableEditorTabKey = value

value = instance.EnableEditorTabKey
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether or not WebTextEditor should handle Tab key.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Editor")]
public System.bool EnableEditorTabKey {get; set;}
Delphi
public read-write property EnableEditorTabKey: System.Boolean;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Determines whether or not WebTextEditor should handle Tab key.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Editor")
public function get,set EnableEditorTabKey : System.boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether or not WebTextEditor should handle Tab key.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Editor")]
public: __property System.bool get_EnableEditorTabKey();
public: __property void set_EnableEditorTabKey(
   System.bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether or not WebTextEditor should handle Tab key.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Editor")]
public:
property System.bool EnableEditorTabKey {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is False.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


EnableFullScreen Property

[image]
Intersoft WebTextEditor Documentation
EnableFullScreen Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : EnableFullScreen Property

Glossary Item Box

Gets or sets the value that determines whether or not full screen feature is enabled.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not full screen feature is enabled.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Property EnableFullScreen As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Boolean

instance.EnableFullScreen = value

value = instance.EnableFullScreen
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not full screen feature is enabled.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public System.bool EnableFullScreen {get; set;}
Delphi
public read-write property EnableFullScreen: System.Boolean;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not full screen feature is enabled.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set EnableFullScreen : System.boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not full screen feature is enabled.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property System.bool get_EnableFullScreen();
public: __property void set_EnableFullScreen(
   System.bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not full screen feature is enabled.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
property System.bool EnableFullScreen {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is True.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


EnableHTMLInspector Property

[image]
Intersoft WebTextEditor Documentation
EnableHTMLInspector Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : EnableHTMLInspector Property

Glossary Item Box

Determines whether or not html inspector is enabled.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Determines whether or not html inspector is enabled.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property EnableHTMLInspector As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Boolean

instance.EnableHTMLInspector = value

value = instance.EnableHTMLInspector
C#
[System.ComponentModel.DescriptionAttribute("Determines whether or not html inspector is enabled.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool EnableHTMLInspector {get; set;}
Delphi
public read-write property EnableHTMLInspector: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Determines whether or not html inspector is enabled.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.DefaultValueAttribute()
public function get,set EnableHTMLInspector : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Determines whether or not html inspector is enabled.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_EnableHTMLInspector();
public: __property void set_EnableHTMLInspector(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Determines whether or not html inspector is enabled.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool EnableHTMLInspector {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is False.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


EnableKeyboardSupport Property

[image]
Intersoft WebTextEditor Documentation
EnableKeyboardSupport Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : EnableKeyboardSupport Property

Glossary Item Box

Determines whether or not keyboard support is enabled.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Determines whether or not keyboard support is enabled.")>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property EnableKeyboardSupport As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Boolean

instance.EnableKeyboardSupport = value

value = instance.EnableKeyboardSupport
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Determines whether or not keyboard support is enabled.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool EnableKeyboardSupport {get; set;}
Delphi
public read-write property EnableKeyboardSupport: System.Boolean;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Determines whether or not keyboard support is enabled.")
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.DefaultValueAttribute()
public function get,set EnableKeyboardSupport : System.boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Determines whether or not keyboard support is enabled.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_EnableKeyboardSupport();
public: __property void set_EnableKeyboardSupport(
   System.bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Determines whether or not keyboard support is enabled.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool EnableKeyboardSupport {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is True.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


EnableXHTMLCompliance Property

[image]
Intersoft WebTextEditor Documentation
EnableXHTMLCompliance Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : EnableXHTMLCompliance Property

Glossary Item Box

Determines whether or not the WebTextEditor's output is XHTML compliance.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Determines whether or not the WebTextEditor's output is XHTML compliance.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property EnableXHTMLCompliance As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Boolean

instance.EnableXHTMLCompliance = value

value = instance.EnableXHTMLCompliance
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether or not the WebTextEditor's output is XHTML compliance.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.bool EnableXHTMLCompliance {get; set;}
Delphi
public read-write property EnableXHTMLCompliance: System.Boolean;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Determines whether or not the WebTextEditor's output is XHTML compliance.")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set EnableXHTMLCompliance : System.boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether or not the WebTextEditor's output is XHTML compliance.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.bool get_EnableXHTMLCompliance();
public: __property void set_EnableXHTMLCompliance(
   System.bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether or not the WebTextEditor's output is XHTML compliance.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.bool EnableXHTMLCompliance {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is True.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


EnterKeyAction Property

[image]
Intersoft WebTextEditor Documentation
EnterKeyAction Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : EnterKeyAction Property

Glossary Item Box

Specifies WebTextEditor behavior when enter key is pressed.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies WebTextEditor behavior when enter key is pressed.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Editor")>
Public Property EnterKeyAction As WebTextEditorEnterKeyAction
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As WebTextEditorEnterKeyAction

instance.EnterKeyAction = value

value = instance.EnterKeyAction
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies WebTextEditor behavior when enter key is pressed.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Editor")]
public WebTextEditorEnterKeyAction EnterKeyAction {get; set;}
Delphi
public read-write property EnterKeyAction: WebTextEditorEnterKeyAction;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies WebTextEditor behavior when enter key is pressed.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Editor")
public function get,set EnterKeyAction : WebTextEditorEnterKeyAction
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies WebTextEditor behavior when enter key is pressed.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Editor")]
public: __property WebTextEditorEnterKeyAction get_EnterKeyAction();
public: __property void set_EnterKeyAction(
   WebTextEditorEnterKeyAction value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies WebTextEditor behavior when enter key is pressed.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Editor")]
public:
property WebTextEditorEnterKeyAction EnterKeyAction {
   WebTextEditorEnterKeyAction get();
   void set (    WebTextEditorEnterKeyAction value);
}

Property Value

The default value is Default.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


FileUploader Property

[image]
Intersoft WebTextEditor Documentation
FileUploader Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : FileUploader Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public ReadOnly Property FileUploader As WebFileUploader
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As WebFileUploader

value = instance.FileUploader
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public WebFileUploader FileUploader {get;}
Delphi
public read-only property FileUploader: WebFileUploader;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get FileUploader : WebFileUploader
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property WebFileUploader* get_FileUploader();
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property WebFileUploader^ FileUploader {
   WebFileUploader^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


FileUploaderSettings Property

[image]
Intersoft WebTextEditor Documentation
FileUploaderSettings Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : FileUploaderSettings Property

Glossary Item Box

Provides settings that control the behaviors of the file uploader in WebTextEditor.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Provides settings that control the behaviors of the file uploader in WebTextEditor.")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.BinarySerializableAttribute("setFileUploaderSettings")>
Public ReadOnly Property FileUploaderSettings As WebTextEditorFileUploaderSettings
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As WebTextEditorFileUploaderSettings

value = instance.FileUploaderSettings
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Provides settings that control the behaviors of the file uploader in WebTextEditor.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute("setFileUploaderSettings")]
public WebTextEditorFileUploaderSettings FileUploaderSettings {get;}
Delphi
public read-only property FileUploaderSettings: WebTextEditorFileUploaderSettings;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Provides settings that control the behaviors of the file uploader in WebTextEditor.")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.BinarySerializableAttribute("setFileUploaderSettings")
public function get FileUploaderSettings : WebTextEditorFileUploaderSettings
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Provides settings that control the behaviors of the file uploader in WebTextEditor.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute("setFileUploaderSettings")]
public: __property WebTextEditorFileUploaderSettings* get_FileUploaderSettings();
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Provides settings that control the behaviors of the file uploader in WebTextEditor.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute("setFileUploaderSettings")]
public:
property WebTextEditorFileUploaderSettings^ FileUploaderSettings {
   WebTextEditorFileUploaderSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


FloatingToolBarFrameStyle Property

[image]
Intersoft WebTextEditor Documentation
FloatingToolBarFrameStyle Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : FloatingToolBarFrameStyle Property

Glossary Item Box

Contains interactive style for Floating ToolBar frame.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Style - General")>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for Floating ToolBar frame.")>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property FloatingToolBarFrameStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As ISNet.WebUI.WebStyle

instance.FloatingToolBarFrameStyle = value

value = instance.FloatingToolBarFrameStyle
C#
[System.ComponentModel.CategoryAttribute("Style - General")]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Floating ToolBar frame.")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public ISNet.WebUI.WebStyle FloatingToolBarFrameStyle {get; set;}
Delphi
public read-write property FloatingToolBarFrameStyle: ISNet.WebUI.WebStyle;
JScript
System.ComponentModel.CategoryAttribute("Style - General")
System.ComponentModel.DescriptionAttribute("Contains interactive style for Floating ToolBar frame.")
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set FloatingToolBarFrameStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Style - General")]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Floating ToolBar frame.")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property ISNet.WebUI.WebStyle* get_FloatingToolBarFrameStyle();
public: __property void set_FloatingToolBarFrameStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Style - General")]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Floating ToolBar frame.")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property ISNet.WebUI.WebStyle^ FloatingToolBarFrameStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


FlyPostBackSettings Property

[image]
Intersoft WebTextEditor Documentation
FlyPostBackSettings Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : FlyPostBackSettings Property

Glossary Item Box

Configures the settings used by the control when performing OnTheFly postback.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Configures the settings used by the control when performing OnTheFly postback.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
Public ReadOnly Property FlyPostBackSettings As ISNet.WebUI.FlyPostBackSettings
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As ISNet.WebUI.FlyPostBackSettings

value = instance.FlyPostBackSettings
C#
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Configures the settings used by the control when performing OnTheFly postback.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
public ISNet.WebUI.FlyPostBackSettings FlyPostBackSettings {get;}
Delphi
public read-only property FlyPostBackSettings: ISNet.WebUI.FlyPostBackSettings;
JScript
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Configures the settings used by the control when performing OnTheFly postback.")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
public function get FlyPostBackSettings : ISNet.WebUI.FlyPostBackSettings
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Configures the settings used by the control when performing OnTheFly postback.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
public: __property ISNet.WebUI.FlyPostBackSettings* get_FlyPostBackSettings();
C++/CLI
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Configures the settings used by the control when performing OnTheFly postback.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
public:
property ISNet.WebUI.FlyPostBackSettings^ FlyPostBackSettings {
   ISNet.WebUI.FlyPostBackSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


FocusOnLoad Property

[image]
Intersoft WebTextEditor Documentation
FocusOnLoad Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : FocusOnLoad Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not WebTextEditor should be focused on load.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Property FocusOnLoad As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Boolean

instance.FocusOnLoad = value

value = instance.FocusOnLoad
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not WebTextEditor should be focused on load.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public System.bool FocusOnLoad {get; set;}
Delphi
public read-write property FocusOnLoad: System.Boolean;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not WebTextEditor should be focused on load.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set FocusOnLoad : System.boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not WebTextEditor should be focused on load.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property System.bool get_FocusOnLoad();
public: __property void set_FocusOnLoad(
   System.bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines whether or not WebTextEditor should be focused on load.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
property System.bool FocusOnLoad {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


Font Property

[image]
Intersoft WebTextEditor Documentation
Font Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : Font Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Overrides ReadOnly Property Font As System.Web.UI.WebControls.FontInfo
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Web.UI.WebControls.FontInfo

value = instance.Font
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public override System.Web.UI.WebControls.FontInfo Font {get;}
Delphi
public read-only property Font: System.Web.UI.WebControls.FontInfo; override;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public override function get Font : System.Web.UI.WebControls.FontInfo
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property System.Web.UI.WebControls.FontInfo* get_Font() override;
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property System.Web.UI.WebControls.FontInfo^ Font {
   System.Web.UI.WebControls.FontInfo^ get() override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


FooterFrameStyle Property

[image]
Intersoft WebTextEditor Documentation
FooterFrameStyle Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : FooterFrameStyle Property

Glossary Item Box

Contains interactive style for footer frame.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for footer frame.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.CategoryAttribute("Style - General")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property FooterFrameStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As ISNet.WebUI.WebStyle

instance.FooterFrameStyle = value

value = instance.FooterFrameStyle
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for footer frame.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Style - General")]
[System.ComponentModel.DefaultValueAttribute()]
public ISNet.WebUI.WebStyle FooterFrameStyle {get; set;}
Delphi
public read-write property FooterFrameStyle: ISNet.WebUI.WebStyle;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.DescriptionAttribute("Contains interactive style for footer frame.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.CategoryAttribute("Style - General")
System.ComponentModel.DefaultValueAttribute()
public function get,set FooterFrameStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for footer frame.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Style - General")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property ISNet.WebUI.WebStyle* get_FooterFrameStyle();
public: __property void set_FooterFrameStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for footer frame.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Style - General")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property ISNet.WebUI.WebStyle^ FooterFrameStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


ForeColor Property

[image]
Intersoft WebTextEditor Documentation
ForeColor Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : ForeColor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Overrides Property ForeColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Drawing.Color

instance.ForeColor = value

value = instance.ForeColor
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public override System.Drawing.Color ForeColor {get; set;}
Delphi
public read-write property ForeColor: System.Drawing.Color; override;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public override function get,set ForeColor : System.Drawing.Color
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property System.Drawing.Color get_ForeColor() override;
public: __property void set_ForeColor(
   System.Drawing.Color value
) override;
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property System.Drawing.Color ForeColor {
   System.Drawing.Color get() override;
   void set (    System.Drawing.Color value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


FrameLayerStyle Property

[image]
Intersoft WebTextEditor Documentation
FrameLayerStyle Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : FrameLayerStyle Property

Glossary Item Box

Contains interactive style for Frame layer that will be displayed when the editor is resized.

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Style - General")>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for Frame layer that will be displayed when the editor is resized.")>
Public Property FrameLayerStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As ISNet.WebUI.WebStyle

instance.FrameLayerStyle = value

value = instance.FrameLayerStyle
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Style - General")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Frame layer that will be displayed when the editor is resized.")]
public ISNet.WebUI.WebStyle FrameLayerStyle {get; set;}
Delphi
public read-write property FrameLayerStyle: ISNet.WebUI.WebStyle;
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Style - General")
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.DescriptionAttribute("Contains interactive style for Frame layer that will be displayed when the editor is resized.")
public function get,set FrameLayerStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Style - General")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Frame layer that will be displayed when the editor is resized.")]
public: __property ISNet.WebUI.WebStyle* get_FrameLayerStyle();
public: __property void set_FrameLayerStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Style - General")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Frame layer that will be displayed when the editor is resized.")]
public:
property ISNet.WebUI.WebStyle^ FrameLayerStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


FrameStyle Property

[image]
Intersoft WebTextEditor Documentation
FrameStyle Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : FrameStyle Property

Glossary Item Box

Contains interactive style for Frame.

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Style - General")>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for Frame.")>
Public Property FrameStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As ISNet.WebUI.WebStyle

instance.FrameStyle = value

value = instance.FrameStyle
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Style - General")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Frame.")]
public ISNet.WebUI.WebStyle FrameStyle {get; set;}
Delphi
public read-write property FrameStyle: ISNet.WebUI.WebStyle;
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Style - General")
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.DescriptionAttribute("Contains interactive style for Frame.")
public function get,set FrameStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Style - General")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Frame.")]
public: __property ISNet.WebUI.WebStyle* get_FrameStyle();
public: __property void set_FrameStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Style - General")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Frame.")]
public:
property ISNet.WebUI.WebStyle^ FrameStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


HeaderFrameStyle Property

[image]
Intersoft WebTextEditor Documentation
HeaderFrameStyle Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : HeaderFrameStyle Property

Glossary Item Box

Contains interactive style for header frame.

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Style - General")>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for header frame.")>
Public Property HeaderFrameStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As ISNet.WebUI.WebStyle

instance.HeaderFrameStyle = value

value = instance.HeaderFrameStyle
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Style - General")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for header frame.")]
public ISNet.WebUI.WebStyle HeaderFrameStyle {get; set;}
Delphi
public read-write property HeaderFrameStyle: ISNet.WebUI.WebStyle;
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Style - General")
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.DescriptionAttribute("Contains interactive style for header frame.")
public function get,set HeaderFrameStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Style - General")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for header frame.")]
public: __property ISNet.WebUI.WebStyle* get_HeaderFrameStyle();
public: __property void set_HeaderFrameStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Style - General")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for header frame.")]
public:
property ISNet.WebUI.WebStyle^ HeaderFrameStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


HTMLInspectorContentStyle Property

[image]
Intersoft WebTextEditor Documentation
HTMLInspectorContentStyle Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : HTMLInspectorContentStyle Property

Glossary Item Box

Contains interactive style for the content of HTML inspector section in footer.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Style - Footer")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for the content of HTML inspector section in footer.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property HTMLInspectorContentStyle As ISNet.WebUI.DynamicStyle
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As ISNet.WebUI.DynamicStyle

instance.HTMLInspectorContentStyle = value

value = instance.HTMLInspectorContentStyle
C#
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Style - Footer")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for the content of HTML inspector section in footer.")]
[System.ComponentModel.DefaultValueAttribute()]
public ISNet.WebUI.DynamicStyle HTMLInspectorContentStyle {get; set;}
Delphi
public read-write property HTMLInspectorContentStyle: ISNet.WebUI.DynamicStyle;
JScript
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Style - Footer")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Contains interactive style for the content of HTML inspector section in footer.")
System.ComponentModel.DefaultValueAttribute()
public function get,set HTMLInspectorContentStyle : ISNet.WebUI.DynamicStyle
Managed Extensions for C++
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Style - Footer")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for the content of HTML inspector section in footer.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property ISNet.WebUI.DynamicStyle* get_HTMLInspectorContentStyle();
public: __property void set_HTMLInspectorContentStyle(
   ISNet.WebUI.DynamicStyle* value
);
C++/CLI
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Style - Footer")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for the content of HTML inspector section in footer.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property ISNet.WebUI.DynamicStyle^ HTMLInspectorContentStyle {
   ISNet.WebUI.DynamicStyle^ get();
   void set (    ISNet.WebUI.DynamicStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


HTMLInspectorLeftIndicatorDisabledStyle Property

[image]
Intersoft WebTextEditor Documentation
HTMLInspectorLeftIndicatorDisabledStyle Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : HTMLInspectorLeftIndicatorDisabledStyle Property

Glossary Item Box

Contains interactive style for left indicator of HTML inspector in footer when it is disabled.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for left indicator of HTML inspector in footer when it is disabled.")>
<System.ComponentModel.CategoryAttribute("Style - Footer")>
Public Property HTMLInspectorLeftIndicatorDisabledStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As ISNet.WebUI.WebStyle

instance.HTMLInspectorLeftIndicatorDisabledStyle = value

value = instance.HTMLInspectorLeftIndicatorDisabledStyle
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for left indicator of HTML inspector in footer when it is disabled.")]
[System.ComponentModel.CategoryAttribute("Style - Footer")]
public ISNet.WebUI.WebStyle HTMLInspectorLeftIndicatorDisabledStyle {get; set;}
Delphi
public read-write property HTMLInspectorLeftIndicatorDisabledStyle: ISNet.WebUI.WebStyle;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Contains interactive style for left indicator of HTML inspector in footer when it is disabled.")
System.ComponentModel.CategoryAttribute("Style - Footer")
public function get,set HTMLInspectorLeftIndicatorDisabledStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for left indicator of HTML inspector in footer when it is disabled.")]
[System.ComponentModel.CategoryAttribute("Style - Footer")]
public: __property ISNet.WebUI.WebStyle* get_HTMLInspectorLeftIndicatorDisabledStyle();
public: __property void set_HTMLInspectorLeftIndicatorDisabledStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for left indicator of HTML inspector in footer when it is disabled.")]
[System.ComponentModel.CategoryAttribute("Style - Footer")]
public:
property ISNet.WebUI.WebStyle^ HTMLInspectorLeftIndicatorDisabledStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


HTMLInspectorLeftIndicatorStyle Property

[image]
Intersoft WebTextEditor Documentation
HTMLInspectorLeftIndicatorStyle Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : HTMLInspectorLeftIndicatorStyle Property

Glossary Item Box

Contains interactive style for left indicator of HTML inspector section in footer.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Style - Footer")>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for left indicator of HTML inspector section in footer.")>
Public Property HTMLInspectorLeftIndicatorStyle As ISNet.WebUI.DynamicStyle
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As ISNet.WebUI.DynamicStyle

instance.HTMLInspectorLeftIndicatorStyle = value

value = instance.HTMLInspectorLeftIndicatorStyle
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Style - Footer")]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for left indicator of HTML inspector section in footer.")]
public ISNet.WebUI.DynamicStyle HTMLInspectorLeftIndicatorStyle {get; set;}
Delphi
public read-write property HTMLInspectorLeftIndicatorStyle: ISNet.WebUI.DynamicStyle;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Style - Footer")
System.ComponentModel.DescriptionAttribute("Contains interactive style for left indicator of HTML inspector section in footer.")
public function get,set HTMLInspectorLeftIndicatorStyle : ISNet.WebUI.DynamicStyle
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Style - Footer")]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for left indicator of HTML inspector section in footer.")]
public: __property ISNet.WebUI.DynamicStyle* get_HTMLInspectorLeftIndicatorStyle();
public: __property void set_HTMLInspectorLeftIndicatorStyle(
   ISNet.WebUI.DynamicStyle* value
);
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Style - Footer")]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for left indicator of HTML inspector section in footer.")]
public:
property ISNet.WebUI.DynamicStyle^ HTMLInspectorLeftIndicatorStyle {
   ISNet.WebUI.DynamicStyle^ get();
   void set (    ISNet.WebUI.DynamicStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


HTMLInspectorRightIndicatorDisabledStyle Property

[image]
Intersoft WebTextEditor Documentation
HTMLInspectorRightIndicatorDisabledStyle Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : HTMLInspectorRightIndicatorDisabledStyle Property

Glossary Item Box

Contains interactive style for right indicator of HTML inspector in footer when it is disabled.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for right indicator of HTML inspector in footer when it is disabled.")>
<System.ComponentModel.CategoryAttribute("Style - Footer")>
Public Property HTMLInspectorRightIndicatorDisabledStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As ISNet.WebUI.WebStyle

instance.HTMLInspectorRightIndicatorDisabledStyle = value

value = instance.HTMLInspectorRightIndicatorDisabledStyle
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for right indicator of HTML inspector in footer when it is disabled.")]
[System.ComponentModel.CategoryAttribute("Style - Footer")]
public ISNet.WebUI.WebStyle HTMLInspectorRightIndicatorDisabledStyle {get; set;}
Delphi
public read-write property HTMLInspectorRightIndicatorDisabledStyle: ISNet.WebUI.WebStyle;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Contains interactive style for right indicator of HTML inspector in footer when it is disabled.")
System.ComponentModel.CategoryAttribute("Style - Footer")
public function get,set HTMLInspectorRightIndicatorDisabledStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for right indicator of HTML inspector in footer when it is disabled.")]
[System.ComponentModel.CategoryAttribute("Style - Footer")]
public: __property ISNet.WebUI.WebStyle* get_HTMLInspectorRightIndicatorDisabledStyle();
public: __property void set_HTMLInspectorRightIndicatorDisabledStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for right indicator of HTML inspector in footer when it is disabled.")]
[System.ComponentModel.CategoryAttribute("Style - Footer")]
public:
property ISNet.WebUI.WebStyle^ HTMLInspectorRightIndicatorDisabledStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


HTMLInspectorRightIndicatorStyle Property

[image]
Intersoft WebTextEditor Documentation
HTMLInspectorRightIndicatorStyle Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : HTMLInspectorRightIndicatorStyle Property

Glossary Item Box

Contains interactive style for right indicator of HTML inspector section in footer.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Style - Footer")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for right indicator of HTML inspector section in footer.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property HTMLInspectorRightIndicatorStyle As ISNet.WebUI.DynamicStyle
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As ISNet.WebUI.DynamicStyle

instance.HTMLInspectorRightIndicatorStyle = value

value = instance.HTMLInspectorRightIndicatorStyle
C#
[System.ComponentModel.CategoryAttribute("Style - Footer")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for right indicator of HTML inspector section in footer.")]
[System.ComponentModel.DefaultValueAttribute()]
public ISNet.WebUI.DynamicStyle HTMLInspectorRightIndicatorStyle {get; set;}
Delphi
public read-write property HTMLInspectorRightIndicatorStyle: ISNet.WebUI.DynamicStyle;
JScript
System.ComponentModel.CategoryAttribute("Style - Footer")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Contains interactive style for right indicator of HTML inspector section in footer.")
System.ComponentModel.DefaultValueAttribute()
public function get,set HTMLInspectorRightIndicatorStyle : ISNet.WebUI.DynamicStyle
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Style - Footer")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for right indicator of HTML inspector section in footer.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property ISNet.WebUI.DynamicStyle* get_HTMLInspectorRightIndicatorStyle();
public: __property void set_HTMLInspectorRightIndicatorStyle(
   ISNet.WebUI.DynamicStyle* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Style - Footer")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for right indicator of HTML inspector section in footer.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property ISNet.WebUI.DynamicStyle^ HTMLInspectorRightIndicatorStyle {
   ISNet.WebUI.DynamicStyle^ get();
   void set (    ISNet.WebUI.DynamicStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


HTMLToolBar Property

[image]
Intersoft WebTextEditor Documentation
HTMLToolBar Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : HTMLToolBar Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebTextEditor, Version=1.0.1000.9, Culture=neutral, PublicKeyToken=b1f2a8511635667a")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines HTML toolbar collection.")>
<System.ComponentModel.CategoryAttribute("Toolbar")>
Public ReadOnly Property HTMLToolBar As WebTextEditorToolBarCollection
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As WebTextEditorToolBarCollection

value = instance.HTMLToolBar
C#
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebTextEditor, Version=1.0.1000.9, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines HTML toolbar collection.")]
[System.ComponentModel.CategoryAttribute("Toolbar")]
public WebTextEditorToolBarCollection HTMLToolBar {get;}
Delphi
public read-only property HTMLToolBar: WebTextEditorToolBarCollection;
JScript
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebTextEditor, Version=1.0.1000.9, Culture=neutral, PublicKeyToken=b1f2a8511635667a")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines HTML toolbar collection.")
System.ComponentModel.CategoryAttribute("Toolbar")
public function get HTMLToolBar : WebTextEditorToolBarCollection
Managed Extensions for C++
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebTextEditor, Version=1.0.1000.9, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines HTML toolbar collection.")]
[System.ComponentModel.CategoryAttribute("Toolbar")]
public: __property WebTextEditorToolBarCollection* get_HTMLToolBar();
C++/CLI
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebTextEditor, Version=1.0.1000.9, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines HTML toolbar collection.")]
[System.ComponentModel.CategoryAttribute("Toolbar")]
public:
property WebTextEditorToolBarCollection^ HTMLToolBar {
   WebTextEditorToolBarCollection^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


ImagesDirectory Property

[image]
Intersoft WebTextEditor Documentation
ImagesDirectory Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : ImagesDirectory Property

Glossary Item Box

Gets or sets the images directory.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the images directory.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property ImagesDirectory As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.String

instance.ImagesDirectory = value

value = instance.ImagesDirectory
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the images directory.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string ImagesDirectory {get; set;}
Delphi
public read-write property ImagesDirectory: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("Gets or sets the images directory.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set ImagesDirectory : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the images directory.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_ImagesDirectory();
public: __property void set_ImagesDirectory(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the images directory.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ ImagesDirectory {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


ImagesSettings Property

[image]
Intersoft WebTextEditor Documentation
ImagesSettings Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : ImagesSettings Property

Glossary Item Box

Provides settings that control the images in WebTextEditor.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute("setImagesSettings")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Provides settings that control the images in WebTextEditor.")>
Public ReadOnly Property ImagesSettings As WebTextEditorImagesSettings
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As WebTextEditorImagesSettings

value = instance.ImagesSettings
C#
[ISNet.Serialization.BinarySerializableAttribute("setImagesSettings")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Provides settings that control the images in WebTextEditor.")]
public WebTextEditorImagesSettings ImagesSettings {get;}
Delphi
public read-only property ImagesSettings: WebTextEditorImagesSettings;
JScript
ISNet.Serialization.BinarySerializableAttribute("setImagesSettings")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Provides settings that control the images in WebTextEditor.")
public function get ImagesSettings : WebTextEditorImagesSettings
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute("setImagesSettings")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Provides settings that control the images in WebTextEditor.")]
public: __property WebTextEditorImagesSettings* get_ImagesSettings();
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute("setImagesSettings")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Provides settings that control the images in WebTextEditor.")]
public:
property WebTextEditorImagesSettings^ ImagesSettings {
   WebTextEditorImagesSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


IsFlyPostBack Property

[image]
Intersoft WebTextEditor Documentation
IsFlyPostBack Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : IsFlyPostBack Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Returns whether this WebTextEditor instance invokes OnTheFly postback.")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Property IsFlyPostBack As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Boolean

instance.IsFlyPostBack = value

value = instance.IsFlyPostBack
C#
[System.ComponentModel.DescriptionAttribute("Returns whether this WebTextEditor instance invokes OnTheFly postback.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public System.bool IsFlyPostBack {get; set;}
Delphi
public read-write property IsFlyPostBack: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Returns whether this WebTextEditor instance invokes OnTheFly postback.")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set IsFlyPostBack : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Returns whether this WebTextEditor instance invokes OnTheFly postback.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property System.bool get_IsFlyPostBack();
public: __property void set_IsFlyPostBack(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Returns whether this WebTextEditor instance invokes OnTheFly postback.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
property System.bool IsFlyPostBack {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


LeftFooterStyle Property

[image]
Intersoft WebTextEditor Documentation
LeftFooterStyle Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : LeftFooterStyle Property

Glossary Item Box

Contains interactive style for left section of footer.

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.CategoryAttribute("Style - Footer")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for left section of footer.")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property LeftFooterStyle As ISNet.WebUI.DynamicStyle
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As ISNet.WebUI.DynamicStyle

instance.LeftFooterStyle = value

value = instance.LeftFooterStyle
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Style - Footer")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for left section of footer.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public ISNet.WebUI.DynamicStyle LeftFooterStyle {get; set;}
Delphi
public read-write property LeftFooterStyle: ISNet.WebUI.DynamicStyle;
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.CategoryAttribute("Style - Footer")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Contains interactive style for left section of footer.")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set LeftFooterStyle : ISNet.WebUI.DynamicStyle
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Style - Footer")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for left section of footer.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property ISNet.WebUI.DynamicStyle* get_LeftFooterStyle();
public: __property void set_LeftFooterStyle(
   ISNet.WebUI.DynamicStyle* value
);
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Style - Footer")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for left section of footer.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property ISNet.WebUI.DynamicStyle^ LeftFooterStyle {
   ISNet.WebUI.DynamicStyle^ get();
   void set (    ISNet.WebUI.DynamicStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


LicenseType Property

[image]
Intersoft WebTextEditor Documentation
LicenseType Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : LicenseType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overrides NotOverridable Property LicenseType As ISNet.WebUI.LicType
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As ISNet.WebUI.LicType

instance.LicenseType = value

value = instance.LicenseType
C#
protected override ISNet.WebUI.LicType LicenseType {get; set;}
Delphi
protected read-write property LicenseType: ISNet.WebUI.LicType; override;
JScript
protected override function get,set LicenseType : ISNet.WebUI.LicType
Managed Extensions for C++
protected: __property ISNet.WebUI.LicType get_LicenseType() override;
protected: __property void set_LicenseType(
   ISNet.WebUI.LicType value
) override;
C++/CLI
protected:
property ISNet.WebUI.LicType LicenseType {
   ISNet.WebUI.LicType get() override;
   void set (    ISNet.WebUI.LicType value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


MailMergeLabelStyle Property

[image]
Intersoft WebTextEditor Documentation
MailMergeLabelStyle Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : MailMergeLabelStyle Property

Glossary Item Box

Contains interactive style for mail merge label.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for mail merge label.")>
<System.ComponentModel.CategoryAttribute("Style - General")>
Public Property MailMergeLabelStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As ISNet.WebUI.WebStyle

instance.MailMergeLabelStyle = value

value = instance.MailMergeLabelStyle
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for mail merge label.")]
[System.ComponentModel.CategoryAttribute("Style - General")]
public ISNet.WebUI.WebStyle MailMergeLabelStyle {get; set;}
Delphi
public read-write property MailMergeLabelStyle: ISNet.WebUI.WebStyle;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Contains interactive style for mail merge label.")
System.ComponentModel.CategoryAttribute("Style - General")
public function get,set MailMergeLabelStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for mail merge label.")]
[System.ComponentModel.CategoryAttribute("Style - General")]
public: __property ISNet.WebUI.WebStyle* get_MailMergeLabelStyle();
public: __property void set_MailMergeLabelStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for mail merge label.")]
[System.ComponentModel.CategoryAttribute("Style - General")]
public:
property ISNet.WebUI.WebStyle^ MailMergeLabelStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


MailMergeSettings Property

[image]
Intersoft WebTextEditor Documentation
MailMergeSettings Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : MailMergeSettings Property

Glossary Item Box

Provides settings that control the behaviors of mail merge in WebTextEditor.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute("setMailMergeSettings")>
<System.ComponentModel.DescriptionAttribute("Provides settings that control the behaviors of mail merge in WebTextEditor.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DefaultValueAttribute()>
Public ReadOnly Property MailMergeSettings As WebTextEditorMailMergeSettings
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As WebTextEditorMailMergeSettings

value = instance.MailMergeSettings
C#
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setMailMergeSettings")]
[System.ComponentModel.DescriptionAttribute("Provides settings that control the behaviors of mail merge in WebTextEditor.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
public WebTextEditorMailMergeSettings MailMergeSettings {get;}
Delphi
public read-only property MailMergeSettings: WebTextEditorMailMergeSettings;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute("setMailMergeSettings")
System.ComponentModel.DescriptionAttribute("Provides settings that control the behaviors of mail merge in WebTextEditor.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DefaultValueAttribute()
public function get MailMergeSettings : WebTextEditorMailMergeSettings
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setMailMergeSettings")]
[System.ComponentModel.DescriptionAttribute("Provides settings that control the behaviors of mail merge in WebTextEditor.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property WebTextEditorMailMergeSettings* get_MailMergeSettings();
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setMailMergeSettings")]
[System.ComponentModel.DescriptionAttribute("Provides settings that control the behaviors of mail merge in WebTextEditor.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property WebTextEditorMailMergeSettings^ MailMergeSettings {
   WebTextEditorMailMergeSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


MaximumSize Property

[image]
Intersoft WebTextEditor Documentation
MaximumSize Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : MaximumSize Property

Glossary Item Box

Gets or sets the value that determines the maximum size of WebTextEditor when it is resized.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the maximum size of WebTextEditor when it is resized.")>
<System.ComponentModel.CategoryAttribute("Layout")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property MaximumSize As System.Drawing.Size
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Drawing.Size

instance.MaximumSize = value

value = instance.MaximumSize
C#
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the maximum size of WebTextEditor when it is resized.")]
[System.ComponentModel.CategoryAttribute("Layout")]
[System.ComponentModel.DefaultValueAttribute()]
public System.Drawing.Size MaximumSize {get; set;}
Delphi
public read-write property MaximumSize: System.Drawing.Size;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the maximum size of WebTextEditor when it is resized.")
System.ComponentModel.CategoryAttribute("Layout")
System.ComponentModel.DefaultValueAttribute()
public function get,set MaximumSize : System.Drawing.Size
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the maximum size of WebTextEditor when it is resized.")]
[System.ComponentModel.CategoryAttribute("Layout")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.Drawing.Size get_MaximumSize();
public: __property void set_MaximumSize(
   System.Drawing.Size value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the maximum size of WebTextEditor when it is resized.")]
[System.ComponentModel.CategoryAttribute("Layout")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.Drawing.Size MaximumSize {
   System.Drawing.Size get();
   void set (    System.Drawing.Size value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


MediaResources Property

[image]
Intersoft WebTextEditor Documentation
MediaResources Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : MediaResources Property

Glossary Item Box

The media resources collection used by WebTextEditor to filter the media in Media Gallery task pane.

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebTextEditor, Version=1.0.1000.9, Culture=neutral, PublicKeyToken=b1f2a8511635667a")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.BinarySerializableAttribute("setMediaResources")>
<System.ComponentModel.DescriptionAttribute("The media resources collection used by WebTextEditor to filter the media in Media Gallery task pane.")>
Public ReadOnly Property MediaResources As WebTextEditorMediaResourceGroupCollection
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As WebTextEditorMediaResourceGroupCollection

value = instance.MediaResources
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebTextEditor, Version=1.0.1000.9, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute("setMediaResources")]
[System.ComponentModel.DescriptionAttribute("The media resources collection used by WebTextEditor to filter the media in Media Gallery task pane.")]
public WebTextEditorMediaResourceGroupCollection MediaResources {get;}
Delphi
public read-only property MediaResources: WebTextEditorMediaResourceGroupCollection;
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebTextEditor, Version=1.0.1000.9, Culture=neutral, PublicKeyToken=b1f2a8511635667a")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.BinarySerializableAttribute("setMediaResources")
System.ComponentModel.DescriptionAttribute("The media resources collection used by WebTextEditor to filter the media in Media Gallery task pane.")
public function get MediaResources : WebTextEditorMediaResourceGroupCollection
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebTextEditor, Version=1.0.1000.9, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute("setMediaResources")]
[System.ComponentModel.DescriptionAttribute("The media resources collection used by WebTextEditor to filter the media in Media Gallery task pane.")]
public: __property WebTextEditorMediaResourceGroupCollection* get_MediaResources();
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebTextEditor, Version=1.0.1000.9, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute("setMediaResources")]
[System.ComponentModel.DescriptionAttribute("The media resources collection used by WebTextEditor to filter the media in Media Gallery task pane.")]
public:
property WebTextEditorMediaResourceGroupCollection^ MediaResources {
   WebTextEditorMediaResourceGroupCollection^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


Medias Property

[image]
Intersoft WebTextEditor Documentation
Medias Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : Medias Property

Glossary Item Box

The media collection used by WebTextEditor in Media Gallery task pane.

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<ISNet.Serialization.BinarySerializableAttribute("setMedias")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("The media collection used by WebTextEditor in Media Gallery task pane.")>
<ISNet.Serialization.XmlSerializableAttribute(True)>
Public ReadOnly Property Medias As WebTextEditorMediaCollection
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As WebTextEditorMediaCollection

value = instance.Medias
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[ISNet.Serialization.BinarySerializableAttribute("setMedias")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("The media collection used by WebTextEditor in Media Gallery task pane.")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
public WebTextEditorMediaCollection Medias {get;}
Delphi
public read-only property Medias: WebTextEditorMediaCollection;
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
ISNet.Serialization.BinarySerializableAttribute("setMedias")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("The media collection used by WebTextEditor in Media Gallery task pane.")
ISNet.Serialization.XmlSerializableAttribute()
public function get Medias : WebTextEditorMediaCollection
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[ISNet.Serialization.BinarySerializableAttribute("setMedias")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("The media collection used by WebTextEditor in Media Gallery task pane.")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
public: __property WebTextEditorMediaCollection* get_Medias();
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[ISNet.Serialization.BinarySerializableAttribute("setMedias")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("The media collection used by WebTextEditor in Media Gallery task pane.")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
public:
property WebTextEditorMediaCollection^ Medias {
   WebTextEditorMediaCollection^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


MinimumSize Property

[image]
Intersoft WebTextEditor Documentation
MinimumSize Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : MinimumSize Property

Glossary Item Box

Gets or sets the value that determines the minimum size of WebTextEditor when it is resized.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the minimum size of WebTextEditor when it is resized.")>
<System.ComponentModel.CategoryAttribute("Layout")>
Public Property MinimumSize As System.Drawing.Size
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Drawing.Size

instance.MinimumSize = value

value = instance.MinimumSize
C#
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the minimum size of WebTextEditor when it is resized.")]
[System.ComponentModel.CategoryAttribute("Layout")]
public System.Drawing.Size MinimumSize {get; set;}
Delphi
public read-write property MinimumSize: System.Drawing.Size;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the minimum size of WebTextEditor when it is resized.")
System.ComponentModel.CategoryAttribute("Layout")
public function get,set MinimumSize : System.Drawing.Size
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the minimum size of WebTextEditor when it is resized.")]
[System.ComponentModel.CategoryAttribute("Layout")]
public: __property System.Drawing.Size get_MinimumSize();
public: __property void set_MinimumSize(
   System.Drawing.Size value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the minimum size of WebTextEditor when it is resized.")]
[System.ComponentModel.CategoryAttribute("Layout")]
public:
property System.Drawing.Size MinimumSize {
   System.Drawing.Size get();
   void set (    System.Drawing.Size value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


ParagraphMode Property

[image]
Intersoft WebTextEditor Documentation
ParagraphMode Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : ParagraphMode Property

Glossary Item Box

Specifies the behavior for paragraph editing.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the behavior for paragraph editing.")>
<System.ComponentModel.CategoryAttribute("Editor")>
Public Property ParagraphMode As WebTextEditorParagraphMode
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As WebTextEditorParagraphMode

instance.ParagraphMode = value

value = instance.ParagraphMode
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the behavior for paragraph editing.")]
[System.ComponentModel.CategoryAttribute("Editor")]
public WebTextEditorParagraphMode ParagraphMode {get; set;}
Delphi
public read-write property ParagraphMode: WebTextEditorParagraphMode;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the behavior for paragraph editing.")
System.ComponentModel.CategoryAttribute("Editor")
public function get,set ParagraphMode : WebTextEditorParagraphMode
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the behavior for paragraph editing.")]
[System.ComponentModel.CategoryAttribute("Editor")]
public: __property WebTextEditorParagraphMode get_ParagraphMode();
public: __property void set_ParagraphMode(
   WebTextEditorParagraphMode value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the behavior for paragraph editing.")]
[System.ComponentModel.CategoryAttribute("Editor")]
public:
property WebTextEditorParagraphMode ParagraphMode {
   WebTextEditorParagraphMode get();
   void set (    WebTextEditorParagraphMode value);
}

Property Value

The default value is UseParagraph.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


PreventScriptInjection Property

[image]
Intersoft WebTextEditor Documentation
PreventScriptInjection Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : PreventScriptInjection Property

Glossary Item Box

Determines whether or not script tag is removed from WebTextEditor.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Determines whether or not script tag is removed from WebTextEditor.")>
<System.ComponentModel.CategoryAttribute("Editor")>
Public Property PreventScriptInjection As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Boolean

instance.PreventScriptInjection = value

value = instance.PreventScriptInjection
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Determines whether or not script tag is removed from WebTextEditor.")]
[System.ComponentModel.CategoryAttribute("Editor")]
public System.bool PreventScriptInjection {get; set;}
Delphi
public read-write property PreventScriptInjection: System.Boolean;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Determines whether or not script tag is removed from WebTextEditor.")
System.ComponentModel.CategoryAttribute("Editor")
public function get,set PreventScriptInjection : System.boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Determines whether or not script tag is removed from WebTextEditor.")]
[System.ComponentModel.CategoryAttribute("Editor")]
public: __property System.bool get_PreventScriptInjection();
public: __property void set_PreventScriptInjection(
   System.bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Determines whether or not script tag is removed from WebTextEditor.")]
[System.ComponentModel.CategoryAttribute("Editor")]
public:
property System.bool PreventScriptInjection {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is True.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


PreviewToolBar Property

[image]
Intersoft WebTextEditor Documentation
PreviewToolBar Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : PreviewToolBar Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebTextEditor, Version=1.0.1000.9, Culture=neutral, PublicKeyToken=b1f2a8511635667a")>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines Preview toolbar collection.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Toolbar")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public ReadOnly Property PreviewToolBar As WebTextEditorToolBarCollection
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As WebTextEditorToolBarCollection

value = instance.PreviewToolBar
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebTextEditor, Version=1.0.1000.9, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines Preview toolbar collection.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Toolbar")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public WebTextEditorToolBarCollection PreviewToolBar {get;}
Delphi
public read-only property PreviewToolBar: WebTextEditorToolBarCollection;
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebTextEditor, Version=1.0.1000.9, Culture=neutral, PublicKeyToken=b1f2a8511635667a")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines Preview toolbar collection.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Toolbar")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get PreviewToolBar : WebTextEditorToolBarCollection
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebTextEditor, Version=1.0.1000.9, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines Preview toolbar collection.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Toolbar")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property WebTextEditorToolBarCollection* get_PreviewToolBar();
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebTextEditor, Version=1.0.1000.9, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines Preview toolbar collection.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Toolbar")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property WebTextEditorToolBarCollection^ PreviewToolBar {
   WebTextEditorToolBarCollection^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


Product Property

[image]
Intersoft WebTextEditor Documentation
Product Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : Product Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property Product As ISNet.WebUI.ProductInfo
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As ISNet.WebUI.ProductInfo

value = instance.Product
C#
protected override ISNet.WebUI.ProductInfo Product {get;}
Delphi
protected read-only property Product: ISNet.WebUI.ProductInfo; override;
JScript
protected override function get Product : ISNet.WebUI.ProductInfo
Managed Extensions for C++
protected: __property ISNet.WebUI.ProductInfo* get_Product() override;
C++/CLI
protected:
property ISNet.WebUI.ProductInfo^ Product {
   ISNet.WebUI.ProductInfo^ get() override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


ProductIcon Property

[image]
Intersoft WebTextEditor Documentation
ProductIcon Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : ProductIcon Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property ProductIcon As System.Drawing.Icon
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Drawing.Icon

value = instance.ProductIcon
C#
protected override System.Drawing.Icon ProductIcon {get;}
Delphi
protected read-only property ProductIcon: System.Drawing.Icon; override;
JScript
protected override function get ProductIcon : System.Drawing.Icon
Managed Extensions for C++
protected: __property System.Drawing.Icon* get_ProductIcon() override;
C++/CLI
protected:
property System.Drawing.Icon^ ProductIcon {
   System.Drawing.Icon^ get() override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


ProductImage Property

[image]
Intersoft WebTextEditor Documentation
ProductImage Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : ProductImage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property ProductImage As System.Drawing.Image
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Drawing.Image

value = instance.ProductImage
C#
protected override System.Drawing.Image ProductImage {get;}
Delphi
protected read-only property ProductImage: System.Drawing.Image; override;
JScript
protected override function get ProductImage : System.Drawing.Image
Managed Extensions for C++
protected: __property System.Drawing.Image* get_ProductImage() override;
C++/CLI
protected:
property System.Drawing.Image^ ProductImage {
   System.Drawing.Image^ get() override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


RawFloatingToolBar Property

[image]
Intersoft WebTextEditor Documentation
RawFloatingToolBar Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : RawFloatingToolBar Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Toolbar")>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines floating toolbar collection.")>
Public ReadOnly Property RawFloatingToolBar As WebTextEditorToolBarCollection
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As WebTextEditorToolBarCollection

value = instance.RawFloatingToolBar
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Toolbar")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines floating toolbar collection.")]
public WebTextEditorToolBarCollection RawFloatingToolBar {get;}
Delphi
public read-only property RawFloatingToolBar: WebTextEditorToolBarCollection;
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Toolbar")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines floating toolbar collection.")
public function get RawFloatingToolBar : WebTextEditorToolBarCollection
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Toolbar")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines floating toolbar collection.")]
public: __property WebTextEditorToolBarCollection* get_RawFloatingToolBar();
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Toolbar")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines floating toolbar collection.")]
public:
property WebTextEditorToolBarCollection^ RawFloatingToolBar {
   WebTextEditorToolBarCollection^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


ResizerStyle Property

[image]
Intersoft WebTextEditor Documentation
ResizerStyle Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : ResizerStyle Property

Glossary Item Box

Contains interactive style for resizer in footer.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Style - Footer")>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for resizer in footer.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
Public Property ResizerStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As ISNet.WebUI.WebStyle

instance.ResizerStyle = value

value = instance.ResizerStyle
C#
[System.ComponentModel.CategoryAttribute("Style - Footer")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for resizer in footer.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public ISNet.WebUI.WebStyle ResizerStyle {get; set;}
Delphi
public read-write property ResizerStyle: ISNet.WebUI.WebStyle;
JScript
System.ComponentModel.CategoryAttribute("Style - Footer")
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Contains interactive style for resizer in footer.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
public function get,set ResizerStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Style - Footer")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for resizer in footer.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public: __property ISNet.WebUI.WebStyle* get_ResizerStyle();
public: __property void set_ResizerStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Style - Footer")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for resizer in footer.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public:
property ISNet.WebUI.WebStyle^ ResizerStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


RightFooterStyle Property

[image]
Intersoft WebTextEditor Documentation
RightFooterStyle Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : RightFooterStyle Property

Glossary Item Box

Contains interactive style for right section of footer.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for right section of footer.")>
<System.ComponentModel.CategoryAttribute("Style - Footer")>
Public Property RightFooterStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As ISNet.WebUI.WebStyle

instance.RightFooterStyle = value

value = instance.RightFooterStyle
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for right section of footer.")]
[System.ComponentModel.CategoryAttribute("Style - Footer")]
public ISNet.WebUI.WebStyle RightFooterStyle {get; set;}
Delphi
public read-write property RightFooterStyle: ISNet.WebUI.WebStyle;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Contains interactive style for right section of footer.")
System.ComponentModel.CategoryAttribute("Style - Footer")
public function get,set RightFooterStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for right section of footer.")]
[System.ComponentModel.CategoryAttribute("Style - Footer")]
public: __property ISNet.WebUI.WebStyle* get_RightFooterStyle();
public: __property void set_RightFooterStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for right section of footer.")]
[System.ComponentModel.CategoryAttribute("Style - Footer")]
public:
property ISNet.WebUI.WebStyle^ RightFooterStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


RootTextEditor Property

[image]
Intersoft WebTextEditor Documentation
RootTextEditor Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : RootTextEditor Property

Glossary Item Box

Provides settings that control the behaviors of single section in WebTextEditor.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Provides settings that control the behaviors of single section in WebTextEditor.")>
<System.ComponentModel.CategoryAttribute("Editor")>
Public ReadOnly Property RootTextEditor As WebTextEditorSection
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As WebTextEditorSection

value = instance.RootTextEditor
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Provides settings that control the behaviors of single section in WebTextEditor.")]
[System.ComponentModel.CategoryAttribute("Editor")]
public WebTextEditorSection RootTextEditor {get;}
Delphi
public read-only property RootTextEditor: WebTextEditorSection;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Provides settings that control the behaviors of single section in WebTextEditor.")
System.ComponentModel.CategoryAttribute("Editor")
public function get RootTextEditor : WebTextEditorSection
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Provides settings that control the behaviors of single section in WebTextEditor.")]
[System.ComponentModel.CategoryAttribute("Editor")]
public: __property WebTextEditorSection* get_RootTextEditor();
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Provides settings that control the behaviors of single section in WebTextEditor.")]
[System.ComponentModel.CategoryAttribute("Editor")]
public:
property WebTextEditorSection^ RootTextEditor {
   WebTextEditorSection^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


ScriptDirectory Property

[image]
Intersoft WebTextEditor Documentation
ScriptDirectory Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : ScriptDirectory Property

Glossary Item Box

Gets or sets the directory where all required scripts for the control are stored.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Client Script Directory")>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required scripts for the control are stored.")>
Public Overrides Property ScriptDirectory As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.String

instance.ScriptDirectory = value

value = instance.ScriptDirectory
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required scripts for the control are stored.")]
public override System.string ScriptDirectory {get; set;}
Delphi
public read-write property ScriptDirectory: System.String; override;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Client Script Directory")
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required scripts for the control are stored.")
public override function get,set ScriptDirectory : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required scripts for the control are stored.")]
public: __property System.string* get_ScriptDirectory() override;
public: __property void set_ScriptDirectory(
   System.string* value
) override;
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required scripts for the control are stored.")]
public:
property System.String^ ScriptDirectory {
   System.String^ get() override;
   void set (    System.String^ value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


SectionLineStyle Property

[image]
Intersoft WebTextEditor Documentation
SectionLineStyle Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : SectionLineStyle Property

Glossary Item Box

Contains interactive style for TextEditor Section Line.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for TextEditor Section Line.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Style - Section")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public Property SectionLineStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As ISNet.WebUI.WebStyle

instance.SectionLineStyle = value

value = instance.SectionLineStyle
C#
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for TextEditor Section Line.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Style - Section")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public ISNet.WebUI.WebStyle SectionLineStyle {get; set;}
Delphi
public read-write property SectionLineStyle: ISNet.WebUI.WebStyle;
JScript
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.DescriptionAttribute("Contains interactive style for TextEditor Section Line.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Style - Section")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
public function get,set SectionLineStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for TextEditor Section Line.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Style - Section")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public: __property ISNet.WebUI.WebStyle* get_SectionLineStyle();
public: __property void set_SectionLineStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for TextEditor Section Line.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Style - Section")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public:
property ISNet.WebUI.WebStyle^ SectionLineStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


SectionTextStyle Property

[image]
Intersoft WebTextEditor Documentation
SectionTextStyle Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : SectionTextStyle Property

Glossary Item Box

Contains interactive style for TextEditor Section Text.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for TextEditor Section Text.")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Style - Section")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property SectionTextStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As ISNet.WebUI.WebStyle

instance.SectionTextStyle = value

value = instance.SectionTextStyle
C#
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for TextEditor Section Text.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Style - Section")]
[System.ComponentModel.DefaultValueAttribute()]
public ISNet.WebUI.WebStyle SectionTextStyle {get; set;}
Delphi
public read-write property SectionTextStyle: ISNet.WebUI.WebStyle;
JScript
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
ISNet.Serialization.BinarySerializableAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DescriptionAttribute("Contains interactive style for TextEditor Section Text.")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Style - Section")
System.ComponentModel.DefaultValueAttribute()
public function get,set SectionTextStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for TextEditor Section Text.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Style - Section")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property ISNet.WebUI.WebStyle* get_SectionTextStyle();
public: __property void set_SectionTextStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for TextEditor Section Text.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Style - Section")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property ISNet.WebUI.WebStyle^ SectionTextStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


SharedScriptDirectory Property

[image]
Intersoft WebTextEditor Documentation
SharedScriptDirectory Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : SharedScriptDirectory Property

Glossary Item Box

Gets or sets the directory where all required framework scripts for the control are stored.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Client Script Directory")>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required framework scripts for the control are stored.")>
Public Overrides Property SharedScriptDirectory As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.String

instance.SharedScriptDirectory = value

value = instance.SharedScriptDirectory
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required framework scripts for the control are stored.")]
public override System.string SharedScriptDirectory {get; set;}
Delphi
public read-write property SharedScriptDirectory: System.String; override;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Client Script Directory")
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required framework scripts for the control are stored.")
public override function get,set SharedScriptDirectory : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required framework scripts for the control are stored.")]
public: __property System.string* get_SharedScriptDirectory() override;
public: __property void set_SharedScriptDirectory(
   System.string* value
) override;
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the directory where all required framework scripts for the control are stored.")]
public:
property System.String^ SharedScriptDirectory {
   System.String^ get() override;
   void set (    System.String^ value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


ShowCallOutOnMediaInsert Property

[image]
Intersoft WebTextEditor Documentation
ShowCallOutOnMediaInsert Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : ShowCallOutOnMediaInsert Property

Glossary Item Box

Determines whether or not callout will appear when media is inserted.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Determines whether or not callout will appear when media is inserted.")>
<System.ComponentModel.CategoryAttribute("Editor")>
Public Property ShowCallOutOnMediaInsert As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Boolean

instance.ShowCallOutOnMediaInsert = value

value = instance.ShowCallOutOnMediaInsert
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether or not callout will appear when media is inserted.")]
[System.ComponentModel.CategoryAttribute("Editor")]
public System.bool ShowCallOutOnMediaInsert {get; set;}
Delphi
public read-write property ShowCallOutOnMediaInsert: System.Boolean;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Determines whether or not callout will appear when media is inserted.")
System.ComponentModel.CategoryAttribute("Editor")
public function get,set ShowCallOutOnMediaInsert : System.boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether or not callout will appear when media is inserted.")]
[System.ComponentModel.CategoryAttribute("Editor")]
public: __property System.bool get_ShowCallOutOnMediaInsert();
public: __property void set_ShowCallOutOnMediaInsert(
   System.bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether or not callout will appear when media is inserted.")]
[System.ComponentModel.CategoryAttribute("Editor")]
public:
property System.bool ShowCallOutOnMediaInsert {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is True.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


ShowCharacterInformation Property

[image]
Intersoft WebTextEditor Documentation
ShowCharacterInformation Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : ShowCharacterInformation Property

Glossary Item Box

Determines whether or not character information should be shown as tooltip.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Determines whether or not character information should be shown as tooltip.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property ShowCharacterInformation As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Boolean

instance.ShowCharacterInformation = value

value = instance.ShowCharacterInformation
C#
[System.ComponentModel.DescriptionAttribute("Determines whether or not character information should be shown as tooltip.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool ShowCharacterInformation {get; set;}
Delphi
public read-write property ShowCharacterInformation: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Determines whether or not character information should be shown as tooltip.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.DefaultValueAttribute()
public function get,set ShowCharacterInformation : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Determines whether or not character information should be shown as tooltip.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_ShowCharacterInformation();
public: __property void set_ShowCharacterInformation(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Determines whether or not character information should be shown as tooltip.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool ShowCharacterInformation {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is False.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


ShowMediaActionOnMediaSelect Property

[image]
Intersoft WebTextEditor Documentation
ShowMediaActionOnMediaSelect Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : ShowMediaActionOnMediaSelect Property

Glossary Item Box

Determines whether or not media action will appear when media is selected.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Determines whether or not media action will appear when media is selected.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Editor")>
Public Property ShowMediaActionOnMediaSelect As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Boolean

instance.ShowMediaActionOnMediaSelect = value

value = instance.ShowMediaActionOnMediaSelect
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether or not media action will appear when media is selected.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Editor")]
public System.bool ShowMediaActionOnMediaSelect {get; set;}
Delphi
public read-write property ShowMediaActionOnMediaSelect: System.Boolean;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Determines whether or not media action will appear when media is selected.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Editor")
public function get,set ShowMediaActionOnMediaSelect : System.boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether or not media action will appear when media is selected.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Editor")]
public: __property System.bool get_ShowMediaActionOnMediaSelect();
public: __property void set_ShowMediaActionOnMediaSelect(
   System.bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether or not media action will appear when media is selected.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Editor")]
public:
property System.bool ShowMediaActionOnMediaSelect {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is True.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


ShowWordInformation Property

[image]
Intersoft WebTextEditor Documentation
ShowWordInformation Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : ShowWordInformation Property

Glossary Item Box

Determines whether or not word information should be shown.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Determines whether or not word information should be shown.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property ShowWordInformation As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Boolean

instance.ShowWordInformation = value

value = instance.ShowWordInformation
C#
[System.ComponentModel.DescriptionAttribute("Determines whether or not word information should be shown.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool ShowWordInformation {get; set;}
Delphi
public read-write property ShowWordInformation: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Determines whether or not word information should be shown.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.DefaultValueAttribute()
public function get,set ShowWordInformation : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Determines whether or not word information should be shown.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_ShowWordInformation();
public: __property void set_ShowWordInformation(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Determines whether or not word information should be shown.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool ShowWordInformation {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is True.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


SplitterStyle Property

[image]
Intersoft WebTextEditor Documentation
SplitterStyle Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : SplitterStyle Property

Glossary Item Box

Contains interactive style for Splitter.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Style - General")>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for Splitter.")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public Property SplitterStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As ISNet.WebUI.WebStyle

instance.SplitterStyle = value

value = instance.SplitterStyle
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Style - General")]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Splitter.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public ISNet.WebUI.WebStyle SplitterStyle {get; set;}
Delphi
public read-write property SplitterStyle: ISNet.WebUI.WebStyle;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Style - General")
System.ComponentModel.DescriptionAttribute("Contains interactive style for Splitter.")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
public function get,set SplitterStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Style - General")]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Splitter.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public: __property ISNet.WebUI.WebStyle* get_SplitterStyle();
public: __property void set_SplitterStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Style - General")]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for Splitter.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public:
property ISNet.WebUI.WebStyle^ SplitterStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


SupportDataSourceControl Property

[image]
Intersoft WebTextEditor Documentation
SupportDataSourceControl Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : SupportDataSourceControl Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overrides ReadOnly Property SupportDataSourceControl As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Boolean

value = instance.SupportDataSourceControl
C#
protected override System.bool SupportDataSourceControl {get;}
Delphi
protected read-only property SupportDataSourceControl: System.Boolean; override;
JScript
protected override function get SupportDataSourceControl : System.boolean
Managed Extensions for C++
protected: __property System.bool get_SupportDataSourceControl() override;
C++/CLI
protected:
property System.bool SupportDataSourceControl {
   System.bool get() override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


TaskPaneSettings Property

[image]
Intersoft WebTextEditor Documentation
TaskPaneSettings Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : TaskPaneSettings Property

Glossary Item Box

Provides settings that control the behaviors of the taskpane in WebTextEditor.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute(True)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Provides settings that control the behaviors of the task pane in WebTextEditor.")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.BinarySerializableAttribute("setTaskPaneSettings")>
<System.ComponentModel.CategoryAttribute("General")>
Public ReadOnly Property TaskPaneSettings As WebTextEditorTaskPaneSettings
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As WebTextEditorTaskPaneSettings

value = instance.TaskPaneSettings
C#
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Provides settings that control the behaviors of the task pane in WebTextEditor.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute("setTaskPaneSettings")]
[System.ComponentModel.CategoryAttribute("General")]
public WebTextEditorTaskPaneSettings TaskPaneSettings {get;}
Delphi
public read-only property TaskPaneSettings: WebTextEditorTaskPaneSettings;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Provides settings that control the behaviors of the task pane in WebTextEditor.")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.BinarySerializableAttribute("setTaskPaneSettings")
System.ComponentModel.CategoryAttribute("General")
public function get TaskPaneSettings : WebTextEditorTaskPaneSettings
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Provides settings that control the behaviors of the task pane in WebTextEditor.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute("setTaskPaneSettings")]
[System.ComponentModel.CategoryAttribute("General")]
public: __property WebTextEditorTaskPaneSettings* get_TaskPaneSettings();
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Provides settings that control the behaviors of the task pane in WebTextEditor.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.BinarySerializableAttribute("setTaskPaneSettings")]
[System.ComponentModel.CategoryAttribute("General")]
public:
property WebTextEditorTaskPaneSettings^ TaskPaneSettings {
   WebTextEditorTaskPaneSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


TextEditorSections Property

[image]
Intersoft WebTextEditor Documentation
TextEditorSections Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : TextEditorSections Property

Glossary Item Box

Provides settings that control the behaviors of multiple section in WebTextEditor.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DescriptionAttribute("Provides settings that control the behaviors of multiple section in WebTextEditor.")>
<System.ComponentModel.CategoryAttribute("Editor")>
Public ReadOnly Property TextEditorSections As System.Collections.Generic.List(Of WebTextEditorSection)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Collections.Generic.List(Of WebTextEditorSection)

value = instance.TextEditorSections
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Provides settings that control the behaviors of multiple section in WebTextEditor.")]
[System.ComponentModel.CategoryAttribute("Editor")]
public System.Collections.Generic.List<WebTextEditorSection> TextEditorSections {get;}
Delphi
public read-only property TextEditorSections: System.Collections.Generic.List;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DescriptionAttribute("Provides settings that control the behaviors of multiple section in WebTextEditor.")
System.ComponentModel.CategoryAttribute("Editor")
public function get TextEditorSections : System.Collections.Generic.List
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Provides settings that control the behaviors of multiple section in WebTextEditor.")]
[System.ComponentModel.CategoryAttribute("Editor")]
public: __property System.Collections.Generic.List<WebTextEditorSection*>* get_TextEditorSections();
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Provides settings that control the behaviors of multiple section in WebTextEditor.")]
[System.ComponentModel.CategoryAttribute("Editor")]
public:
property System.Collections.Generic.List<WebTextEditorSection^>^ TextEditorSections {
   System.Collections.Generic.List<WebTextEditorSection^>^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


TextSettings Property

[image]
Intersoft WebTextEditor Documentation
TextSettings Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : TextSettings Property

Glossary Item Box

Provides settings that control text that shown in WebTextEditor.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Provides settings that control text that shown in WebTextEditor.")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public ReadOnly Property TextSettings As WebTextEditorTextSettings
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As WebTextEditorTextSettings

value = instance.TextSettings
C#
[System.ComponentModel.DescriptionAttribute("Provides settings that control text that shown in WebTextEditor.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public WebTextEditorTextSettings TextSettings {get;}
Delphi
public read-only property TextSettings: WebTextEditorTextSettings;
JScript
System.ComponentModel.DescriptionAttribute("Provides settings that control text that shown in WebTextEditor.")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get TextSettings : WebTextEditorTextSettings
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Provides settings that control text that shown in WebTextEditor.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property WebTextEditorTextSettings* get_TextSettings();
C++/CLI
[System.ComponentModel.DescriptionAttribute("Provides settings that control text that shown in WebTextEditor.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property WebTextEditorTextSettings^ TextSettings {
   WebTextEditorTextSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


ToolBar Property

[image]
Intersoft WebTextEditor Documentation
ToolBar Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : ToolBar Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebTextEditor, Version=1.0.1000.9, Culture=neutral, PublicKeyToken=b1f2a8511635667a")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines main toolbar collection.")>
<System.ComponentModel.CategoryAttribute("Toolbar")>
Public ReadOnly Property ToolBar As WebTextEditorToolBarCollection
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As WebTextEditorToolBarCollection

value = instance.ToolBar
C#
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebTextEditor, Version=1.0.1000.9, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines main toolbar collection.")]
[System.ComponentModel.CategoryAttribute("Toolbar")]
public WebTextEditorToolBarCollection ToolBar {get;}
Delphi
public read-only property ToolBar: WebTextEditorToolBarCollection;
JScript
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebTextEditor, Version=1.0.1000.9, Culture=neutral, PublicKeyToken=b1f2a8511635667a")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines main toolbar collection.")
System.ComponentModel.CategoryAttribute("Toolbar")
public function get ToolBar : WebTextEditorToolBarCollection
Managed Extensions for C++
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebTextEditor, Version=1.0.1000.9, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines main toolbar collection.")]
[System.ComponentModel.CategoryAttribute("Toolbar")]
public: __property WebTextEditorToolBarCollection* get_ToolBar();
C++/CLI
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebTextEditor, Version=1.0.1000.9, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines main toolbar collection.")]
[System.ComponentModel.CategoryAttribute("Toolbar")]
public:
property WebTextEditorToolBarCollection^ ToolBar {
   WebTextEditorToolBarCollection^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


ToolBarSettings Property

[image]
Intersoft WebTextEditor Documentation
ToolBarSettings Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : ToolBarSettings Property

Glossary Item Box

Provides settings that control the behaviors of the toolbar in WebTextEditor.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute("setToolBarSettings")>
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Provides settings that control the behaviors of the toolbar in WebTextEditor.")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public ReadOnly Property ToolBarSettings As WebTextEditorToolBarSettings
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As WebTextEditorToolBarSettings

value = instance.ToolBarSettings
C#
[ISNet.Serialization.BinarySerializableAttribute("setToolBarSettings")]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Provides settings that control the behaviors of the toolbar in WebTextEditor.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public WebTextEditorToolBarSettings ToolBarSettings {get;}
Delphi
public read-only property ToolBarSettings: WebTextEditorToolBarSettings;
JScript
ISNet.Serialization.BinarySerializableAttribute("setToolBarSettings")
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Provides settings that control the behaviors of the toolbar in WebTextEditor.")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
public function get ToolBarSettings : WebTextEditorToolBarSettings
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute("setToolBarSettings")]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Provides settings that control the behaviors of the toolbar in WebTextEditor.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public: __property WebTextEditorToolBarSettings* get_ToolBarSettings();
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute("setToolBarSettings")]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Provides settings that control the behaviors of the toolbar in WebTextEditor.")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public:
property WebTextEditorToolBarSettings^ ToolBarSettings {
   WebTextEditorToolBarSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


UndoLatency Property

[image]
Intersoft WebTextEditor Documentation
UndoLatency Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : UndoLatency Property

Glossary Item Box

Specifies undo latency interval (in milisecond).

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies undo latency interval (in milisecond).")>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Property UndoLatency As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Integer

instance.UndoLatency = value

value = instance.UndoLatency
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies undo latency interval (in milisecond).")]
[System.ComponentModel.CategoryAttribute("Behavior")]
public System.int UndoLatency {get; set;}
Delphi
public read-write property UndoLatency: System.Integer;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies undo latency interval (in milisecond).")
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set UndoLatency : System.int
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies undo latency interval (in milisecond).")]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property System.int get_UndoLatency();
public: __property void set_UndoLatency(
   System.int value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies undo latency interval (in milisecond).")]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
property System.int UndoLatency {
   System.int get();
   void set (    System.int value);
}

Property Value

The default value is 1000 ms.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


UploadBarFrameStyle Property

[image]
Intersoft WebTextEditor Documentation
UploadBarFrameStyle Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : UploadBarFrameStyle Property

Glossary Item Box

Contains interactive style for upload bar frame in footer.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.CategoryAttribute("Style - Section")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for upload bar frame in footer.")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property UploadBarFrameStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As ISNet.WebUI.WebStyle

instance.UploadBarFrameStyle = value

value = instance.UploadBarFrameStyle
C#
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Style - Section")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for upload bar frame in footer.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public ISNet.WebUI.WebStyle UploadBarFrameStyle {get; set;}
Delphi
public read-write property UploadBarFrameStyle: ISNet.WebUI.WebStyle;
JScript
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
ISNet.Serialization.BinarySerializableAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.CategoryAttribute("Style - Section")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DescriptionAttribute("Contains interactive style for upload bar frame in footer.")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set UploadBarFrameStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Style - Section")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for upload bar frame in footer.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property ISNet.WebUI.WebStyle* get_UploadBarFrameStyle();
public: __property void set_UploadBarFrameStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Style - Section")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for upload bar frame in footer.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property ISNet.WebUI.WebStyle^ UploadBarFrameStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


UploadBarTextStyle Property

[image]
Intersoft WebTextEditor Documentation
UploadBarTextStyle Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : UploadBarTextStyle Property

Glossary Item Box

Contains interactive style for upload bar text in footer.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for upload bar text in footer.")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.CategoryAttribute("Style - Section")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property UploadBarTextStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As ISNet.WebUI.WebStyle

instance.UploadBarTextStyle = value

value = instance.UploadBarTextStyle
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for upload bar text in footer.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Style - Section")]
[System.ComponentModel.DefaultValueAttribute()]
public ISNet.WebUI.WebStyle UploadBarTextStyle {get; set;}
Delphi
public read-write property UploadBarTextStyle: ISNet.WebUI.WebStyle;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.ComponentModel.DescriptionAttribute("Contains interactive style for upload bar text in footer.")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.CategoryAttribute("Style - Section")
System.ComponentModel.DefaultValueAttribute()
public function get,set UploadBarTextStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for upload bar text in footer.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Style - Section")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property ISNet.WebUI.WebStyle* get_UploadBarTextStyle();
public: __property void set_UploadBarTextStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for upload bar text in footer.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.CategoryAttribute("Style - Section")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property ISNet.WebUI.WebStyle^ UploadBarTextStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


UseDefaultEditorStylesForPrint Property

[image]
Intersoft WebTextEditor Documentation
UseDefaultEditorStylesForPrint Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : UseDefaultEditorStylesForPrint Property

Glossary Item Box

Determines whether or not default styles are included when the printing the content.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Determines whether or not default styles are included when the printing the content.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Property UseDefaultEditorStylesForPrint As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Boolean

instance.UseDefaultEditorStylesForPrint = value

value = instance.UseDefaultEditorStylesForPrint
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether or not default styles are included when the printing the content.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public System.bool UseDefaultEditorStylesForPrint {get; set;}
Delphi
public read-write property UseDefaultEditorStylesForPrint: System.Boolean;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Determines whether or not default styles are included when the printing the content.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set UseDefaultEditorStylesForPrint : System.boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether or not default styles are included when the printing the content.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property System.bool get_UseDefaultEditorStylesForPrint();
public: __property void set_UseDefaultEditorStylesForPrint(
   System.bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether or not default styles are included when the printing the content.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
property System.bool UseDefaultEditorStylesForPrint {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is True.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


UseDefaultStyle Property

[image]
Intersoft WebTextEditor Documentation
UseDefaultStyle Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : UseDefaultStyle Property

Glossary Item Box

Determines whether or not WebTextEditor is using default style.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Determines whether or not WebTextEditor is using default style.")>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Property UseDefaultStyle As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Boolean

instance.UseDefaultStyle = value

value = instance.UseDefaultStyle
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether or not WebTextEditor is using default style.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
public System.bool UseDefaultStyle {get; set;}
Delphi
public read-write property UseDefaultStyle: System.Boolean;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Determines whether or not WebTextEditor is using default style.")
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set UseDefaultStyle : System.boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether or not WebTextEditor is using default style.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property System.bool get_UseDefaultStyle();
public: __property void set_UseDefaultStyle(
   System.bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether or not WebTextEditor is using default style.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
property System.bool UseDefaultStyle {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is True.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


ViewIndicatorStyle Property

[image]
Intersoft WebTextEditor Documentation
ViewIndicatorStyle Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : ViewIndicatorStyle Property

Glossary Item Box

Contains interactive style for view tab indicator in footer.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for view tab indicator in footer.")>
<System.ComponentModel.CategoryAttribute("Style - Footer")>
Public Property ViewIndicatorStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As ISNet.WebUI.WebStyle

instance.ViewIndicatorStyle = value

value = instance.ViewIndicatorStyle
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for view tab indicator in footer.")]
[System.ComponentModel.CategoryAttribute("Style - Footer")]
public ISNet.WebUI.WebStyle ViewIndicatorStyle {get; set;}
Delphi
public read-write property ViewIndicatorStyle: ISNet.WebUI.WebStyle;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Contains interactive style for view tab indicator in footer.")
System.ComponentModel.CategoryAttribute("Style - Footer")
public function get,set ViewIndicatorStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for view tab indicator in footer.")]
[System.ComponentModel.CategoryAttribute("Style - Footer")]
public: __property ISNet.WebUI.WebStyle* get_ViewIndicatorStyle();
public: __property void set_ViewIndicatorStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for view tab indicator in footer.")]
[System.ComponentModel.CategoryAttribute("Style - Footer")]
public:
property ISNet.WebUI.WebStyle^ ViewIndicatorStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


ViewSettings Property

[image]
Intersoft WebTextEditor Documentation
ViewSettings Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : ViewSettings Property

Glossary Item Box

Provides settings that control the behaviors of the view in WebTextEditor.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute("setViewSettings")>
<System.ComponentModel.DescriptionAttribute("Provides settings that control the behaviors of the view in WebTextEditor.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
Public ReadOnly Property ViewSettings As WebTextEditorViewSettings
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As WebTextEditorViewSettings

value = instance.ViewSettings
C#
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setViewSettings")]
[System.ComponentModel.DescriptionAttribute("Provides settings that control the behaviors of the view in WebTextEditor.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public WebTextEditorViewSettings ViewSettings {get;}
Delphi
public read-only property ViewSettings: WebTextEditorViewSettings;
JScript
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute("setViewSettings")
System.ComponentModel.DescriptionAttribute("Provides settings that control the behaviors of the view in WebTextEditor.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
public function get ViewSettings : WebTextEditorViewSettings
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setViewSettings")]
[System.ComponentModel.DescriptionAttribute("Provides settings that control the behaviors of the view in WebTextEditor.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public: __property WebTextEditorViewSettings* get_ViewSettings();
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute("setViewSettings")]
[System.ComponentModel.DescriptionAttribute("Provides settings that control the behaviors of the view in WebTextEditor.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
public:
property WebTextEditorViewSettings^ ViewSettings {
   WebTextEditorViewSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


ViewTabStyle Property

[image]
Intersoft WebTextEditor Documentation
ViewTabStyle Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : ViewTabStyle Property

Glossary Item Box

Contains interactive style for view tab in footer.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Style - Footer")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for view tab in footer.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property ViewTabStyle As ISNet.WebUI.DynamicStyle
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As ISNet.WebUI.DynamicStyle

instance.ViewTabStyle = value

value = instance.ViewTabStyle
C#
[System.ComponentModel.CategoryAttribute("Style - Footer")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for view tab in footer.")]
[System.ComponentModel.DefaultValueAttribute()]
public ISNet.WebUI.DynamicStyle ViewTabStyle {get; set;}
Delphi
public read-write property ViewTabStyle: ISNet.WebUI.DynamicStyle;
JScript
System.ComponentModel.CategoryAttribute("Style - Footer")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
ISNet.Serialization.XmlSerializableAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Contains interactive style for view tab in footer.")
System.ComponentModel.DefaultValueAttribute()
public function get,set ViewTabStyle : ISNet.WebUI.DynamicStyle
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Style - Footer")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for view tab in footer.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property ISNet.WebUI.DynamicStyle* get_ViewTabStyle();
public: __property void set_ViewTabStyle(
   ISNet.WebUI.DynamicStyle* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Style - Footer")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for view tab in footer.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property ISNet.WebUI.DynamicStyle^ ViewTabStyle {
   ISNet.WebUI.DynamicStyle^ get();
   void set (    ISNet.WebUI.DynamicStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


WatermarkStyle Property

[image]
Intersoft WebTextEditor Documentation
WatermarkStyle Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : WatermarkStyle Property

Glossary Item Box

Contains interactive style for TextEditor's Watermark.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)>
<System.ComponentModel.DescriptionAttribute("Contains interactive style for TextEditor's Watermark.")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Style - General")>
Public Property WatermarkStyle As ISNet.WebUI.WebStyle
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As ISNet.WebUI.WebStyle

instance.WatermarkStyle = value

value = instance.WatermarkStyle
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for TextEditor's Watermark.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Style - General")]
public ISNet.WebUI.WebStyle WatermarkStyle {get; set;}
Delphi
public read-write property WatermarkStyle: ISNet.WebUI.WebStyle;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)
System.ComponentModel.DescriptionAttribute("Contains interactive style for TextEditor's Watermark.")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Style - General")
public function get,set WatermarkStyle : ISNet.WebUI.WebStyle
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for TextEditor's Watermark.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Style - General")]
public: __property ISNet.WebUI.WebStyle* get_WatermarkStyle();
public: __property void set_WatermarkStyle(
   ISNet.WebUI.WebStyle* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.ClientAndLayout)]
[System.ComponentModel.DescriptionAttribute("Contains interactive style for TextEditor's Watermark.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ExpandableObjectConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Style - General")]
public:
property ISNet.WebUI.WebStyle^ WatermarkStyle {
   ISNet.WebUI.WebStyle^ get();
   void set (    ISNet.WebUI.WebStyle^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


WebDesktopScriptDirectory Property

[image]
Intersoft WebTextEditor Documentation
WebDesktopScriptDirectory Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : WebDesktopScriptDirectory Property

Glossary Item Box

Gets or sets the IIS path to locate WebDesktop's script directory. This property is only applicable when SmartWebResources is not enabled.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Client Script Directory")>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the IIS path to locate WebDesktop's script directory. This property is only applicable when SmartWebResources is not enabled.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property WebDesktopScriptDirectory As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.String

instance.WebDesktopScriptDirectory = value

value = instance.WebDesktopScriptDirectory
C#
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the IIS path to locate WebDesktop's script directory. This property is only applicable when SmartWebResources is not enabled.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string WebDesktopScriptDirectory {get; set;}
Delphi
public read-write property WebDesktopScriptDirectory: System.String;
JScript
System.ComponentModel.CategoryAttribute("Client Script Directory")
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.DescriptionAttribute("Gets or sets the IIS path to locate WebDesktop's script directory. This property is only applicable when SmartWebResources is not enabled.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set WebDesktopScriptDirectory : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the IIS path to locate WebDesktop's script directory. This property is only applicable when SmartWebResources is not enabled.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_WebDesktopScriptDirectory();
public: __property void set_WebDesktopScriptDirectory(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Client Script Directory")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the IIS path to locate WebDesktop's script directory. This property is only applicable when SmartWebResources is not enabled.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ WebDesktopScriptDirectory {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


WebTextEditor Class Events

[image]
Intersoft WebTextEditor Documentation
WebTextEditor Class Events
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditor Class

Glossary Item Box

For a list of all members of this type, see WebTextEditor members.

Public Events

 | Name | Description
Public Event | BeforeSendMail | Fires before send mail action is performed.
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | InitializeToolBar | Fires when the toolbar is initialized.
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | MailMerge | Fires when mail merge is being processed in each data context.
Public Event | MailMergeCompleted | Fires when mail merge process is completed.
Public Event | PreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Save | Fires when the content is being saved.
Public Event | SendMail | Fires when each email is being sent.
Public Event | SendMailCompleted | Fires when sending email action is completed.
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

WebTextEditor Class
ISNet.WebUI.WebTextEditor Namespace


BeforeSendMail Event

[image]
Intersoft WebTextEditor Documentation
BeforeSendMail Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : BeforeSendMail Event

Glossary Item Box

Fires before send mail action is performed.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Mail Merge")>
<System.ComponentModel.DescriptionAttribute("Fires before send mail action is performed.")>
Public Event BeforeSendMail As WebTextEditorBeforeSendMailEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim handler As WebTextEditorBeforeSendMailEventHandler

AddHandler instance.BeforeSendMail, handler
C#
[System.ComponentModel.CategoryAttribute("Mail Merge")]
[System.ComponentModel.DescriptionAttribute("Fires before send mail action is performed.")]
public event WebTextEditorBeforeSendMailEventHandler BeforeSendMail
Delphi
public event BeforeSendMail: WebTextEditorBeforeSendMailEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Mail Merge")]
[System.ComponentModel.DescriptionAttribute("Fires before send mail action is performed.")]
public: __event WebTextEditorBeforeSendMailEventHandler* BeforeSendMail
C++/CLI
[System.ComponentModel.CategoryAttribute("Mail Merge")]
[System.ComponentModel.DescriptionAttribute("Fires before send mail action is performed.")]
public:
event WebTextEditorBeforeSendMailEventHandler^ BeforeSendMail

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


InitializeToolBar Event

[image]
Intersoft WebTextEditor Documentation
InitializeToolBar Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : InitializeToolBar Event

Glossary Item Box

Fires when the toolbar is initialized.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.DescriptionAttribute("Fires when the toolbar is initialized.")>
Public Event InitializeToolBar As WebTextEditorToolBarEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim handler As WebTextEditorToolBarEventHandler

AddHandler instance.InitializeToolBar, handler
C#
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute("Fires when the toolbar is initialized.")]
public event WebTextEditorToolBarEventHandler InitializeToolBar
Delphi
public event InitializeToolBar: WebTextEditorToolBarEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute("Fires when the toolbar is initialized.")]
public: __event WebTextEditorToolBarEventHandler* InitializeToolBar
C++/CLI
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.DescriptionAttribute("Fires when the toolbar is initialized.")]
public:
event WebTextEditorToolBarEventHandler^ InitializeToolBar

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


MailMerge Event

[image]
Intersoft WebTextEditor Documentation
MailMerge Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : MailMerge Event

Glossary Item Box

Fires when mail merge is being processed in each data context.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Mail Merge")>
<System.ComponentModel.DescriptionAttribute("Fires when mail merge is being processed in each data context.")>
Public Event MailMerge As WebTextEditorMailMergeEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim handler As WebTextEditorMailMergeEventHandler

AddHandler instance.MailMerge, handler
C#
[System.ComponentModel.CategoryAttribute("Mail Merge")]
[System.ComponentModel.DescriptionAttribute("Fires when mail merge is being processed in each data context.")]
public event WebTextEditorMailMergeEventHandler MailMerge
Delphi
public event MailMerge: WebTextEditorMailMergeEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Mail Merge")]
[System.ComponentModel.DescriptionAttribute("Fires when mail merge is being processed in each data context.")]
public: __event WebTextEditorMailMergeEventHandler* MailMerge
C++/CLI
[System.ComponentModel.CategoryAttribute("Mail Merge")]
[System.ComponentModel.DescriptionAttribute("Fires when mail merge is being processed in each data context.")]
public:
event WebTextEditorMailMergeEventHandler^ MailMerge

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


MailMergeCompleted Event

[image]
Intersoft WebTextEditor Documentation
MailMergeCompleted Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : MailMergeCompleted Event

Glossary Item Box

Fires when mail merge process is completed.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Mail Merge")>
<System.ComponentModel.DescriptionAttribute("Fires when mail merge process is completed.")>
Public Event MailMergeCompleted As WebTextEditorMailMergeCompletedEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim handler As WebTextEditorMailMergeCompletedEventHandler

AddHandler instance.MailMergeCompleted, handler
C#
[System.ComponentModel.CategoryAttribute("Mail Merge")]
[System.ComponentModel.DescriptionAttribute("Fires when mail merge process is completed.")]
public event WebTextEditorMailMergeCompletedEventHandler MailMergeCompleted
Delphi
public event MailMergeCompleted: WebTextEditorMailMergeCompletedEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Mail Merge")]
[System.ComponentModel.DescriptionAttribute("Fires when mail merge process is completed.")]
public: __event WebTextEditorMailMergeCompletedEventHandler* MailMergeCompleted
C++/CLI
[System.ComponentModel.CategoryAttribute("Mail Merge")]
[System.ComponentModel.DescriptionAttribute("Fires when mail merge process is completed.")]
public:
event WebTextEditorMailMergeCompletedEventHandler^ MailMergeCompleted

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


Save Event

[image]
Intersoft WebTextEditor Documentation
Save Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : Save Event

Glossary Item Box

Fires when the content is being saved.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Fires when the content is being saved.")>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Event Save As WebTextEditorSaveEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim handler As WebTextEditorSaveEventHandler

AddHandler instance.Save, handler
C#
[System.ComponentModel.DescriptionAttribute("Fires when the content is being saved.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
public event WebTextEditorSaveEventHandler Save
Delphi
public event Save: WebTextEditorSaveEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Fires when the content is being saved.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __event WebTextEditorSaveEventHandler* Save
C++/CLI
[System.ComponentModel.DescriptionAttribute("Fires when the content is being saved.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
event WebTextEditorSaveEventHandler^ Save

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


SendMail Event

[image]
Intersoft WebTextEditor Documentation
SendMail Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : SendMail Event

Glossary Item Box

Fires when each email is being sent.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Mail Merge")>
<System.ComponentModel.DescriptionAttribute("Fires when each email is being sent.")>
Public Event SendMail As WebTextEditorSendMailEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim handler As WebTextEditorSendMailEventHandler

AddHandler instance.SendMail, handler
C#
[System.ComponentModel.CategoryAttribute("Mail Merge")]
[System.ComponentModel.DescriptionAttribute("Fires when each email is being sent.")]
public event WebTextEditorSendMailEventHandler SendMail
Delphi
public event SendMail: WebTextEditorSendMailEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Mail Merge")]
[System.ComponentModel.DescriptionAttribute("Fires when each email is being sent.")]
public: __event WebTextEditorSendMailEventHandler* SendMail
C++/CLI
[System.ComponentModel.CategoryAttribute("Mail Merge")]
[System.ComponentModel.DescriptionAttribute("Fires when each email is being sent.")]
public:
event WebTextEditorSendMailEventHandler^ SendMail

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


SendMailCompleted Event

[image]
Intersoft WebTextEditor Documentation
SendMailCompleted Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : SendMailCompleted Event

Glossary Item Box

Fires when sending email action is completed.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Mail Merge")>
<System.ComponentModel.DescriptionAttribute("Fires when sending email action is completed.")>
Public Event SendMailCompleted As WebTextEditorSendMailCompletedEventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim handler As WebTextEditorSendMailCompletedEventHandler

AddHandler instance.SendMailCompleted, handler
C#
[System.ComponentModel.CategoryAttribute("Mail Merge")]
[System.ComponentModel.DescriptionAttribute("Fires when sending email action is completed.")]
public event WebTextEditorSendMailCompletedEventHandler SendMailCompleted
Delphi
public event SendMailCompleted: WebTextEditorSendMailCompletedEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Mail Merge")]
[System.ComponentModel.DescriptionAttribute("Fires when sending email action is completed.")]
public: __event WebTextEditorSendMailCompletedEventHandler* SendMailCompleted
C++/CLI
[System.ComponentModel.CategoryAttribute("Mail Merge")]
[System.ComponentModel.DescriptionAttribute("Fires when sending email action is completed.")]
public:
event WebTextEditorSendMailCompletedEventHandler^ SendMailCompleted

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


WebTextEditor.PostBackAction Class

[image]
Intersoft WebTextEditor Documentation
WebTextEditor.PostBackAction Class
Members See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditor.PostBackAction Class

Glossary Item Box

Specifies PostBackAction of WebTextEditor

Object Model

WebTextEditor.PostBackAction Class

Syntax

Visual Basic (Declaration)
Public Class WebTextEditor.PostBackAction
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor.PostBackAction
C#
public class WebTextEditor.PostBackAction
Delphi
public class WebTextEditor.PostBackAction
JScript
public class WebTextEditor.PostBackAction
Managed Extensions for C++
public __gc class WebTextEditor.PostBackAction
C++/CLI
public ref class WebTextEditor.PostBackAction

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebTextEditor.WebTextEditor.PostBackAction

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor.PostBackAction Members
ISNet.WebUI.WebTextEditor Namespace


WebTextEditor.PostBackAction Class Members

[image]
Intersoft WebTextEditor Documentation
WebTextEditor.PostBackAction Class Members
See Also Fields Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditor.PostBackAction Class

Glossary Item Box

The following tables list the members exposed by WebTextEditor.PostBackAction.

Public Constructors

 | Name | Description
Public Constructor | WebTextEditor.PostBackAction Constructor |
Top

Public Fields

 | Name | Description
Public Field | PreviewMailMerge |
Public Field | Save |
Public Field | SaveAll |
Public Field | SearchImage |
Public Field | SendMailMerge |
Public Field | SetFileUploaderPath |
Top

See Also

Reference

WebTextEditor.PostBackAction Class
ISNet.WebUI.WebTextEditor Namespace


WebTextEditor.PostBackAction Constructor

[image]
Intersoft WebTextEditor Documentation
WebTextEditor.PostBackAction Constructor
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor.PostBackAction Class : WebTextEditor.PostBackAction Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebTextEditor.PostBackAction()
C#
public WebTextEditor.PostBackAction()
Delphi
public WebTextEditor.PostBackAction();
JScript
public function WebTextEditor.PostBackAction();
Managed Extensions for C++
public: WebTextEditor.PostBackAction();
C++/CLI
public:
WebTextEditor.PostBackAction();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor.PostBackAction Class
WebTextEditor.PostBackAction Members


WebTextEditor.PostBackAction Class Fields

[image]
Intersoft WebTextEditor Documentation
WebTextEditor.PostBackAction Class Fields
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditor.PostBackAction Class

Glossary Item Box

For a list of all members of this type, see WebTextEditor.PostBackAction members.

Public Fields

 | Name | Description
Public Field | PreviewMailMerge |
Public Field | Save |
Public Field | SaveAll |
Public Field | SearchImage |
Public Field | SendMailMerge |
Public Field | SetFileUploaderPath |
Top

See Also

Reference

WebTextEditor.PostBackAction Class
ISNet.WebUI.WebTextEditor Namespace


PreviewMailMerge Field

[image]
Intersoft WebTextEditor Documentation
PreviewMailMerge Field
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor.PostBackAction Class : PreviewMailMerge Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const PreviewMailMerge As System.String
Visual Basic (Usage) Copy Code
Dim value As System.String

value = WebTextEditor.PostBackAction.PreviewMailMerge
C#
public const System.string PreviewMailMerge
Delphi
public field PreviewMailMerge: System.String; Const
JScript
public constvar PreviewMailMerge : System.String;
Managed Extensions for C++
public: const System.string* PreviewMailMerge
C++/CLI
public:
const System.String^ PreviewMailMerge

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor.PostBackAction Class
WebTextEditor.PostBackAction Members


Save Field

[image]
Intersoft WebTextEditor Documentation
Save Field
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor.PostBackAction Class : Save Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const Save As System.String
Visual Basic (Usage) Copy Code
Dim value As System.String

value = WebTextEditor.PostBackAction.Save
C#
public const System.string Save
Delphi
public field Save: System.String; Const
JScript
public constvar Save : System.String;
Managed Extensions for C++
public: const System.string* Save
C++/CLI
public:
const System.String^ Save

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor.PostBackAction Class
WebTextEditor.PostBackAction Members


SaveAll Field

[image]
Intersoft WebTextEditor Documentation
SaveAll Field
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor.PostBackAction Class : SaveAll Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const SaveAll As System.String
Visual Basic (Usage) Copy Code
Dim value As System.String

value = WebTextEditor.PostBackAction.SaveAll
C#
public const System.string SaveAll
Delphi
public field SaveAll: System.String; Const
JScript
public constvar SaveAll : System.String;
Managed Extensions for C++
public: const System.string* SaveAll
C++/CLI
public:
const System.String^ SaveAll

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor.PostBackAction Class
WebTextEditor.PostBackAction Members


SearchImage Field

[image]
Intersoft WebTextEditor Documentation
SearchImage Field
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor.PostBackAction Class : SearchImage Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const SearchImage As System.String
Visual Basic (Usage) Copy Code
Dim value As System.String

value = WebTextEditor.PostBackAction.SearchImage
C#
public const System.string SearchImage
Delphi
public field SearchImage: System.String; Const
JScript
public constvar SearchImage : System.String;
Managed Extensions for C++
public: const System.string* SearchImage
C++/CLI
public:
const System.String^ SearchImage

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor.PostBackAction Class
WebTextEditor.PostBackAction Members


SendMailMerge Field

[image]
Intersoft WebTextEditor Documentation
SendMailMerge Field
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor.PostBackAction Class : SendMailMerge Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const SendMailMerge As System.String
Visual Basic (Usage) Copy Code
Dim value As System.String

value = WebTextEditor.PostBackAction.SendMailMerge
C#
public const System.string SendMailMerge
Delphi
public field SendMailMerge: System.String; Const
JScript
public constvar SendMailMerge : System.String;
Managed Extensions for C++
public: const System.string* SendMailMerge
C++/CLI
public:
const System.String^ SendMailMerge

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor.PostBackAction Class
WebTextEditor.PostBackAction Members


SetFileUploaderPath Field

[image]
Intersoft WebTextEditor Documentation
SetFileUploaderPath Field
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor.PostBackAction Class : SetFileUploaderPath Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Const SetFileUploaderPath As System.String
Visual Basic (Usage) Copy Code
Dim value As System.String

value = WebTextEditor.PostBackAction.SetFileUploaderPath
C#
public const System.string SetFileUploaderPath
Delphi
public field SetFileUploaderPath: System.String; Const
JScript
public constvar SetFileUploaderPath : System.String;
Managed Extensions for C++
public: const System.string* SetFileUploaderPath
C++/CLI
public:
const System.String^ SetFileUploaderPath

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor.PostBackAction Class
WebTextEditor.PostBackAction Members


WebTextEditorBeforeSendMailArgs Class

[image]
Intersoft WebTextEditor Documentation
WebTextEditorBeforeSendMailArgs Class
Members See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorBeforeSendMailArgs Class

Glossary Item Box

Provides data for before SendMail event.

Object Model

WebTextEditorBeforeSendMailArgs Class

Syntax

Visual Basic (Declaration)
Public Class WebTextEditorBeforeSendMailArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorBeforeSendMailArgs
C#
public class WebTextEditorBeforeSendMailArgs : System.EventArgs
Delphi
public class WebTextEditorBeforeSendMailArgs = class(System.EventArgs)
JScript
public class WebTextEditorBeforeSendMailArgs extends System.EventArgs
Managed Extensions for C++
public __gc class WebTextEditorBeforeSendMailArgs : public System.EventArgs
C++/CLI
public ref class WebTextEditorBeforeSendMailArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
ISNet.WebUI.WebTextEditor.WebTextEditorBeforeSendMailArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorBeforeSendMailArgs Members
ISNet.WebUI.WebTextEditor Namespace


WebTextEditorBeforeSendMailArgs Class Members

[image]
Intersoft WebTextEditor Documentation
WebTextEditorBeforeSendMailArgs Class Members
See Also Properties Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorBeforeSendMailArgs Class

Glossary Item Box

The following tables list the members exposed by WebTextEditorBeforeSendMailArgs.

Public Constructors

 | Name | Description
Public Constructor | WebTextEditorBeforeSendMailArgs Constructor |
Top

Public Properties

 | Name | Description
Public Property | Cancel |
Public Property | Data |
Top

See Also

Reference

WebTextEditorBeforeSendMailArgs Class
ISNet.WebUI.WebTextEditor Namespace


WebTextEditorBeforeSendMailArgs Constructor

[image]
Intersoft WebTextEditor Documentation
WebTextEditorBeforeSendMailArgs Constructor
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorBeforeSendMailArgs Class : WebTextEditorBeforeSendMailArgs Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebTextEditorBeforeSendMailArgs()
C#
public WebTextEditorBeforeSendMailArgs()
Delphi
public WebTextEditorBeforeSendMailArgs();
JScript
public function WebTextEditorBeforeSendMailArgs();
Managed Extensions for C++
public: WebTextEditorBeforeSendMailArgs();
C++/CLI
public:
WebTextEditorBeforeSendMailArgs();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorBeforeSendMailArgs Class
WebTextEditorBeforeSendMailArgs Members


WebTextEditorBeforeSendMailArgs Class Properties

[image]
Intersoft WebTextEditor Documentation
WebTextEditorBeforeSendMailArgs Class Properties
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorBeforeSendMailArgs Class

Glossary Item Box

For a list of all members of this type, see WebTextEditorBeforeSendMailArgs members.

Public Properties

 | Name | Description
Public Property | Cancel |
Public Property | Data |
Top

See Also

Reference

WebTextEditorBeforeSendMailArgs Class
ISNet.WebUI.WebTextEditor Namespace


Cancel Property

[image]
Intersoft WebTextEditor Documentation
Cancel Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorBeforeSendMailArgs Class : Cancel Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Cancel As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorBeforeSendMailArgs
Dim value As System.Boolean

instance.Cancel = value

value = instance.Cancel
C#
public System.bool Cancel {get; set;}
Delphi
public read-write property Cancel: System.Boolean;
JScript
public function get,set Cancel : System.boolean
Managed Extensions for C++
public: __property System.bool get_Cancel();
public: __property void set_Cancel(
   System.bool value
);
C++/CLI
public:
property System.bool Cancel {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorBeforeSendMailArgs Class
WebTextEditorBeforeSendMailArgs Members


Data Property

[image]
Intersoft WebTextEditor Documentation
Data Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorBeforeSendMailArgs Class : Data Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Data As System.Collections.Generic.List(Of WebTextEditorMailMergeObject)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorBeforeSendMailArgs
Dim value As System.Collections.Generic.List(Of WebTextEditorMailMergeObject)

instance.Data = value

value = instance.Data
C#
public System.Collections.Generic.List<WebTextEditorMailMergeObject> Data {get; set;}
Delphi
public read-write property Data: System.Collections.Generic.List;
JScript
public function get,set Data : System.Collections.Generic.List
Managed Extensions for C++
public: __property System.Collections.Generic.List<WebTextEditorMailMergeObject*>* get_Data();
public: __property void set_Data(
   System.Collections.Generic.List<WebTextEditorMailMergeObject*>* value
);
C++/CLI
public:
property System.Collections.Generic.List<WebTextEditorMailMergeObject^>^ Data {
   System.Collections.Generic.List<WebTextEditorMailMergeObject^>^ get();
   void set (    System.Collections.Generic.List<WebTextEditorMailMergeObject^>^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorBeforeSendMailArgs Class
WebTextEditorBeforeSendMailArgs Members


WebTextEditorClientSideEvents Class

[image]
Intersoft WebTextEditor Documentation
WebTextEditorClientSideEvents Class
Members See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorClientSideEvents Class

Glossary Item Box

A collection of WebTextEditor's client side events.

Object Model

WebTextEditorClientSideEvents Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebTextEditorClientSideEvents
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorClientSideEvents
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebTextEditorClientSideEvents : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebTextEditorClientSideEvents = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebTextEditorClientSideEvents extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebTextEditorClientSideEvents : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebTextEditorClientSideEvents : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebTextEditor.WebTextEditorClientSideEvents

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorClientSideEvents Members
ISNet.WebUI.WebTextEditor Namespace


WebTextEditorClientSideEvents Class Members

[image]
Intersoft WebTextEditor Documentation
WebTextEditorClientSideEvents Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorClientSideEvents Class

Glossary Item Box

The following tables list the members exposed by WebTextEditorClientSideEvents.

Public Constructors

 | Name | Description
Public Constructor | WebTextEditorClientSideEvents Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | OnAfterExecCommand | Gets or sets the event handler that will be invoked after ExecCommand is performed.
Public Property | OnAfterResize | Gets or sets the event handler that will be invoked after WebTextEditor is resized.
Public Property | OnAfterUpload | Gets or sets the event handler that will be invoked after a file is uploaded.
Public Property | OnBeforeExecCommand | Gets or sets the event handler that will be invoked before ExecCommand is performed.
Public Property | OnBeforeResize | Gets or sets the event handler that will be invoked before WebTextEditor is resized.
Public Property | OnBeforeUpload | Gets or sets the event handler that will be invoked before file(s) are uploaded.
Public Property | OnCancelUpload | Gets or sets the event handler that will be invoked when an uploading file process is cancelled.
Public Property | OnEditorContextMenu | Gets or sets the event handler that will be invoked when the editor's context menu is about to be displayed.
Public Property | OnInitialize | Gets or sets the event handler that will be invoked when WebTextEditor is initialized.
Public Property | OnInitializeToolBar | Gets or sets the event handler that will be invoked when toolbars are being initialized.
Public Property | OnKeyDown | Gets or sets the event handler that will be invoked when key down.
Public Property | OnMediaSelected | Gets or sets the event handler that will be invoked when a media is selected.
Public Property | OnResponse | Gets or sets the event handler that will be invoked when a response from server is returned.
Public Property | OnSave | Gets or sets the event handler that will be invoked when WebTextEditor's content is saved.
Public Property | OnSendMailCompleted | Gets or sets the event handler that will be invoked when send mail action is completed.
Public Property | OnToolBarClick | Gets or sets the event handler that will be invoked when a command in toolbar is clicked.
Public Property | OnUploaderCompleted | Gets or sets the event handler that will be invoked when uploading process has been completed regardless of the individual upload status.
Public Property | OnUploaderError | Gets or sets the event handler that will be invoked when an error occurred during file uploading process.
Public Property | OnUploaderFileAdded | Gets or sets the event handler that will be invoked when a file is added to the integrated file uploader.
Public Property | OnUploaderFileRemoved | Gets or sets the event handler that will be invoked when a file is removed from the integrated file uploader.
Public Property | OnUploaderInitialize | Gets or sets the event handler that will be invoked when the integrated file uploader is being initialized.
Public Property | OnUploaderValidate | Gets or sets the event handler that will be invoked when validating a file that is added to the integrated file uploader.
Public Property | OnUploading | Gets or sets the event handler that will be invoked when a file is being uploaded.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

Protected Methods

 | Name | Description
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | IsInSerializationContext | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebTextEditorClientSideEvents Class
ISNet.WebUI.WebTextEditor Namespace


WebTextEditorClientSideEvents Constructor

[image]
Intersoft WebTextEditor Documentation
WebTextEditorClientSideEvents Constructor
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorClientSideEvents Class : WebTextEditorClientSideEvents Constructor

Glossary Item Box

Overload List

Overload | Description
WebTextEditorClientSideEvents Constructor() |
WebTextEditorClientSideEvents Constructor(SerializationInfo,StreamingContext) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorClientSideEvents Class
WebTextEditorClientSideEvents Members


WebTextEditorClientSideEvents Constructor()

[image]
Intersoft WebTextEditor Documentation
WebTextEditorClientSideEvents Constructor()
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorClientSideEvents Class > WebTextEditorClientSideEvents Constructor : WebTextEditorClientSideEvents Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebTextEditorClientSideEvents()
C#
public WebTextEditorClientSideEvents()
Delphi
public WebTextEditorClientSideEvents();
JScript
public function WebTextEditorClientSideEvents();
Managed Extensions for C++
public: WebTextEditorClientSideEvents();
C++/CLI
public:
WebTextEditorClientSideEvents();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorClientSideEvents Class
WebTextEditorClientSideEvents Members
Overload List


WebTextEditorClientSideEvents Constructor(SerializationInfo,StreamingContext)

[image]
Intersoft WebTextEditor Documentation
WebTextEditorClientSideEvents Constructor(SerializationInfo,StreamingContext)
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorClientSideEvents Class > WebTextEditorClientSideEvents Constructor : WebTextEditorClientSideEvents Constructor(SerializationInfo,StreamingContext)

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

Dim instance As New WebTextEditorClientSideEvents(info, context)
C#
protected WebTextEditorClientSideEvents(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
protected WebTextEditorClientSideEvents(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
protected function WebTextEditorClientSideEvents(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
protected: WebTextEditorClientSideEvents(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
protected:
WebTextEditorClientSideEvents(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorClientSideEvents Class
WebTextEditorClientSideEvents Members
Overload List


WebTextEditorClientSideEvents Class Properties

[image]
Intersoft WebTextEditor Documentation
WebTextEditorClientSideEvents Class Properties
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorClientSideEvents Class

Glossary Item Box

For a list of all members of this type, see WebTextEditorClientSideEvents members.

Public Properties

 | Name | Description
Public Property | OnAfterExecCommand | Gets or sets the event handler that will be invoked after ExecCommand is performed.
Public Property | OnAfterResize | Gets or sets the event handler that will be invoked after WebTextEditor is resized.
Public Property | OnAfterUpload | Gets or sets the event handler that will be invoked after a file is uploaded.
Public Property | OnBeforeExecCommand | Gets or sets the event handler that will be invoked before ExecCommand is performed.
Public Property | OnBeforeResize | Gets or sets the event handler that will be invoked before WebTextEditor is resized.
Public Property | OnBeforeUpload | Gets or sets the event handler that will be invoked before file(s) are uploaded.
Public Property | OnCancelUpload | Gets or sets the event handler that will be invoked when an uploading file process is cancelled.
Public Property | OnEditorContextMenu | Gets or sets the event handler that will be invoked when the editor's context menu is about to be displayed.
Public Property | OnInitialize | Gets or sets the event handler that will be invoked when WebTextEditor is initialized.
Public Property | OnInitializeToolBar | Gets or sets the event handler that will be invoked when toolbars are being initialized.
Public Property | OnKeyDown | Gets or sets the event handler that will be invoked when key down.
Public Property | OnMediaSelected | Gets or sets the event handler that will be invoked when a media is selected.
Public Property | OnResponse | Gets or sets the event handler that will be invoked when a response from server is returned.
Public Property | OnSave | Gets or sets the event handler that will be invoked when WebTextEditor's content is saved.
Public Property | OnSendMailCompleted | Gets or sets the event handler that will be invoked when send mail action is completed.
Public Property | OnToolBarClick | Gets or sets the event handler that will be invoked when a command in toolbar is clicked.
Public Property | OnUploaderCompleted | Gets or sets the event handler that will be invoked when uploading process has been completed regardless of the individual upload status.
Public Property | OnUploaderError | Gets or sets the event handler that will be invoked when an error occurred during file uploading process.
Public Property | OnUploaderFileAdded | Gets or sets the event handler that will be invoked when a file is added to the integrated file uploader.
Public Property | OnUploaderFileRemoved | Gets or sets the event handler that will be invoked when a file is removed from the integrated file uploader.
Public Property | OnUploaderInitialize | Gets or sets the event handler that will be invoked when the integrated file uploader is being initialized.
Public Property | OnUploaderValidate | Gets or sets the event handler that will be invoked when validating a file that is added to the integrated file uploader.
Public Property | OnUploading | Gets or sets the event handler that will be invoked when a file is being uploaded.
Top

See Also

Reference

WebTextEditorClientSideEvents Class
ISNet.WebUI.WebTextEditor Namespace


OnAfterExecCommand Property

[image]
Intersoft WebTextEditor Documentation
OnAfterExecCommand Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorClientSideEvents Class : OnAfterExecCommand Property

Glossary Item Box

Gets or sets the event handler that will be invoked after ExecCommand is performed.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.EventParameterAttribute("controlId, action")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked after ExecCommand is performed.")>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
Public Property OnAfterExecCommand As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorClientSideEvents
Dim value As System.String

instance.OnAfterExecCommand = value

value = instance.OnAfterExecCommand
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, action")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked after ExecCommand is performed.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public System.string OnAfterExecCommand {get; set;}
Delphi
public read-write property OnAfterExecCommand: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.EventParameterAttribute("controlId, action")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked after ExecCommand is performed.")
System.ComponentModel.CategoryAttribute("Client Side Events")
public function get,set OnAfterExecCommand : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, action")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked after ExecCommand is performed.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public: __property System.string* get_OnAfterExecCommand();
public: __property void set_OnAfterExecCommand(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, action")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked after ExecCommand is performed.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public:
property System.String^ OnAfterExecCommand {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorClientSideEvents Class
WebTextEditorClientSideEvents Members


OnAfterResize Property

[image]
Intersoft WebTextEditor Documentation
OnAfterResize Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorClientSideEvents Class : OnAfterResize Property

Glossary Item Box

Gets or sets the event handler that will be invoked after WebTextEditor is resized.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked after WebTextEditor is resized.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.EventParameterAttribute("controlId")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property OnAfterResize As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorClientSideEvents
Dim value As System.String

instance.OnAfterResize = value

value = instance.OnAfterResize
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked after WebTextEditor is resized.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string OnAfterResize {get; set;}
Delphi
public read-write property OnAfterResize: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked after WebTextEditor is resized.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.EventParameterAttribute("controlId")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Client Side Events")
System.ComponentModel.DefaultValueAttribute()
public function get,set OnAfterResize : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked after WebTextEditor is resized.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_OnAfterResize();
public: __property void set_OnAfterResize(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked after WebTextEditor is resized.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ OnAfterResize {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorClientSideEvents Class
WebTextEditorClientSideEvents Members


OnAfterUpload Property

[image]
Intersoft WebTextEditor Documentation
OnAfterUpload Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorClientSideEvents Class : OnAfterUpload Property

Glossary Item Box

Gets or sets the event handler that will be invoked after a file is uploaded.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked after a file is uploaded.")>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<ISNet.EventParameterAttribute("controlId, webFileUploadInfo")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
Public Property OnAfterUpload As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorClientSideEvents
Dim value As System.String

instance.OnAfterUpload = value

value = instance.OnAfterUpload
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked after a file is uploaded.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[ISNet.EventParameterAttribute("controlId, webFileUploadInfo")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public System.string OnAfterUpload {get; set;}
Delphi
public read-write property OnAfterUpload: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked after a file is uploaded.")
System.ComponentModel.CategoryAttribute("Client Side Events")
ISNet.EventParameterAttribute("controlId, webFileUploadInfo")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
public function get,set OnAfterUpload : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked after a file is uploaded.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[ISNet.EventParameterAttribute("controlId, webFileUploadInfo")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public: __property System.string* get_OnAfterUpload();
public: __property void set_OnAfterUpload(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked after a file is uploaded.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[ISNet.EventParameterAttribute("controlId, webFileUploadInfo")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public:
property System.String^ OnAfterUpload {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorClientSideEvents Class
WebTextEditorClientSideEvents Members


OnBeforeExecCommand Property

[image]
Intersoft WebTextEditor Documentation
OnBeforeExecCommand Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorClientSideEvents Class : OnBeforeExecCommand Property

Glossary Item Box

Gets or sets the event handler that will be invoked before ExecCommand is performed.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.EventParameterAttribute("controlId, action")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked before ExecCommand is performed.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property OnBeforeExecCommand As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorClientSideEvents
Dim value As System.String

instance.OnBeforeExecCommand = value

value = instance.OnBeforeExecCommand
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, action")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked before ExecCommand is performed.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string OnBeforeExecCommand {get; set;}
Delphi
public read-write property OnBeforeExecCommand: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.EventParameterAttribute("controlId, action")
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked before ExecCommand is performed.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Client Side Events")
System.ComponentModel.DefaultValueAttribute()
public function get,set OnBeforeExecCommand : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, action")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked before ExecCommand is performed.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_OnBeforeExecCommand();
public: __property void set_OnBeforeExecCommand(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, action")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked before ExecCommand is performed.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ OnBeforeExecCommand {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorClientSideEvents Class
WebTextEditorClientSideEvents Members


OnBeforeResize Property

[image]
Intersoft WebTextEditor Documentation
OnBeforeResize Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorClientSideEvents Class : OnBeforeResize Property

Glossary Item Box

Gets or sets the event handler that will be invoked before WebTextEditor is resized.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<ISNet.EventParameterAttribute("controlId")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked before WebTextEditor is resized.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property OnBeforeResize As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorClientSideEvents
Dim value As System.String

instance.OnBeforeResize = value

value = instance.OnBeforeResize
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked before WebTextEditor is resized.")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string OnBeforeResize {get; set;}
Delphi
public read-write property OnBeforeResize: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
System.ComponentModel.CategoryAttribute("Client Side Events")
ISNet.EventParameterAttribute("controlId")
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked before WebTextEditor is resized.")
System.ComponentModel.DefaultValueAttribute()
public function get,set OnBeforeResize : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked before WebTextEditor is resized.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_OnBeforeResize();
public: __property void set_OnBeforeResize(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked before WebTextEditor is resized.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ OnBeforeResize {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorClientSideEvents Class
WebTextEditorClientSideEvents Members


OnBeforeUpload Property

[image]
Intersoft WebTextEditor Documentation
OnBeforeUpload Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorClientSideEvents Class : OnBeforeUpload Property

Glossary Item Box

Gets or sets the event handler that will be invoked before file(s) are uploaded.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked before file(s) are uploaded.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.EventParameterAttribute("controlId, webFileUploadInfo")>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property OnBeforeUpload As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorClientSideEvents
Dim value As System.String

instance.OnBeforeUpload = value

value = instance.OnBeforeUpload
C#
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked before file(s) are uploaded.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, webFileUploadInfo")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string OnBeforeUpload {get; set;}
Delphi
public read-write property OnBeforeUpload: System.String;
JScript
System.ComponentModel.CategoryAttribute("Client Side Events")
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked before file(s) are uploaded.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.EventParameterAttribute("controlId, webFileUploadInfo")
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set OnBeforeUpload : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked before file(s) are uploaded.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, webFileUploadInfo")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_OnBeforeUpload();
public: __property void set_OnBeforeUpload(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked before file(s) are uploaded.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, webFileUploadInfo")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ OnBeforeUpload {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorClientSideEvents Class
WebTextEditorClientSideEvents Members


OnCancelUpload Property

[image]
Intersoft WebTextEditor Documentation
OnCancelUpload Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorClientSideEvents Class : OnCancelUpload Property

Glossary Item Box

Gets or sets the event handler that will be invoked when an uploading file process is cancelled.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when an uploading file process is cancelled.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.EventParameterAttribute("controlId, webFileUploadInfo")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property OnCancelUpload As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorClientSideEvents
Dim value As System.String

instance.OnCancelUpload = value

value = instance.OnCancelUpload
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when an uploading file process is cancelled.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, webFileUploadInfo")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string OnCancelUpload {get; set;}
Delphi
public read-write property OnCancelUpload: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when an uploading file process is cancelled.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.EventParameterAttribute("controlId, webFileUploadInfo")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Client Side Events")
System.ComponentModel.DefaultValueAttribute()
public function get,set OnCancelUpload : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when an uploading file process is cancelled.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, webFileUploadInfo")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_OnCancelUpload();
public: __property void set_OnCancelUpload(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when an uploading file process is cancelled.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, webFileUploadInfo")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ OnCancelUpload {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorClientSideEvents Class
WebTextEditorClientSideEvents Members


OnEditorContextMenu Property

[image]
Intersoft WebTextEditor Documentation
OnEditorContextMenu Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorClientSideEvents Class : OnEditorContextMenu Property

Glossary Item Box

Gets or sets the event handler that will be invoked when the editor's context menu is about to be displayed.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.EventParameterAttribute("controlId, menuObj")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when the editor's context menu is about to be displayed.")>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
Public Property OnEditorContextMenu As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorClientSideEvents
Dim value As System.String

instance.OnEditorContextMenu = value

value = instance.OnEditorContextMenu
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId, menuObj")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when the editor's context menu is about to be displayed.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public System.string OnEditorContextMenu {get; set;}
Delphi
public read-write property OnEditorContextMenu: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.EventParameterAttribute("controlId, menuObj")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when the editor's context menu is about to be displayed.")
System.ComponentModel.CategoryAttribute("Client Side Events")
public function get,set OnEditorContextMenu : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId, menuObj")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when the editor's context menu is about to be displayed.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public: __property System.string* get_OnEditorContextMenu();
public: __property void set_OnEditorContextMenu(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId, menuObj")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when the editor's context menu is about to be displayed.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public:
property System.String^ OnEditorContextMenu {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorClientSideEvents Class
WebTextEditorClientSideEvents Members


OnInitialize Property

[image]
Intersoft WebTextEditor Documentation
OnInitialize Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorClientSideEvents Class : OnInitialize Property

Glossary Item Box

Gets or sets the event handler that will be invoked when WebTextEditor is initialized.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.EventParameterAttribute("controlId")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when WebTextEditor is initialized.")>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
Public Property OnInitialize As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorClientSideEvents
Dim value As System.String

instance.OnInitialize = value

value = instance.OnInitialize
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when WebTextEditor is initialized.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public System.string OnInitialize {get; set;}
Delphi
public read-write property OnInitialize: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.EventParameterAttribute("controlId")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when WebTextEditor is initialized.")
System.ComponentModel.CategoryAttribute("Client Side Events")
public function get,set OnInitialize : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when WebTextEditor is initialized.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public: __property System.string* get_OnInitialize();
public: __property void set_OnInitialize(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when WebTextEditor is initialized.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public:
property System.String^ OnInitialize {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorClientSideEvents Class
WebTextEditorClientSideEvents Members


OnInitializeToolBar Property

[image]
Intersoft WebTextEditor Documentation
OnInitializeToolBar Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorClientSideEvents Class : OnInitializeToolBar Property

Glossary Item Box

Gets or sets the event handler that will be invoked when toolbars are being initialized.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.EventParameterAttribute("controlId, e")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when toolbars are being initialized.")>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property OnInitializeToolBar As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorClientSideEvents
Dim value As System.String

instance.OnInitializeToolBar = value

value = instance.OnInitializeToolBar
C#
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, e")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when toolbars are being initialized.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string OnInitializeToolBar {get; set;}
Delphi
public read-write property OnInitializeToolBar: System.String;
JScript
System.ComponentModel.CategoryAttribute("Client Side Events")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.EventParameterAttribute("controlId, e")
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when toolbars are being initialized.")
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set OnInitializeToolBar : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, e")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when toolbars are being initialized.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_OnInitializeToolBar();
public: __property void set_OnInitializeToolBar(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, e")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when toolbars are being initialized.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ OnInitializeToolBar {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorClientSideEvents Class
WebTextEditorClientSideEvents Members


OnKeyDown Property

[image]
Intersoft WebTextEditor Documentation
OnKeyDown Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorClientSideEvents Class : OnKeyDown Property

Glossary Item Box

Gets or sets the event handler that will be invoked when key down.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when key down.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.EventParameterAttribute("controlId, keyCode")>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property OnKeyDown As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorClientSideEvents
Dim value As System.String

instance.OnKeyDown = value

value = instance.OnKeyDown
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when key down.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, keyCode")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string OnKeyDown {get; set;}
Delphi
public read-write property OnKeyDown: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when key down.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.EventParameterAttribute("controlId, keyCode")
System.ComponentModel.CategoryAttribute("Client Side Events")
System.ComponentModel.DefaultValueAttribute()
public function get,set OnKeyDown : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when key down.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, keyCode")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_OnKeyDown();
public: __property void set_OnKeyDown(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when key down.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, keyCode")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ OnKeyDown {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorClientSideEvents Class
WebTextEditorClientSideEvents Members


OnMediaSelected Property

[image]
Intersoft WebTextEditor Documentation
OnMediaSelected Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorClientSideEvents Class : OnMediaSelected Property

Glossary Item Box

Gets or sets the event handler that will be invoked when a media is selected.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when a media is selected.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.EventParameterAttribute("controlId, mediaElement")>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property OnMediaSelected As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorClientSideEvents
Dim value As System.String

instance.OnMediaSelected = value

value = instance.OnMediaSelected
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when a media is selected.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, mediaElement")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string OnMediaSelected {get; set;}
Delphi
public read-write property OnMediaSelected: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when a media is selected.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.EventParameterAttribute("controlId, mediaElement")
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Client Side Events")
System.ComponentModel.DefaultValueAttribute()
public function get,set OnMediaSelected : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when a media is selected.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, mediaElement")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_OnMediaSelected();
public: __property void set_OnMediaSelected(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when a media is selected.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, mediaElement")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ OnMediaSelected {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorClientSideEvents Class
WebTextEditorClientSideEvents Members


OnResponse Property

[image]
Intersoft WebTextEditor Documentation
OnResponse Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorClientSideEvents Class : OnResponse Property

Glossary Item Box

Gets or sets the event handler that will be invoked when a response from server is returned.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.EventParameterAttribute("controlId, status")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when a response from server is returned.")>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
Public Property OnResponse As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorClientSideEvents
Dim value As System.String

instance.OnResponse = value

value = instance.OnResponse
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, status")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when a response from server is returned.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public System.string OnResponse {get; set;}
Delphi
public read-write property OnResponse: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.EventParameterAttribute("controlId, status")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when a response from server is returned.")
System.ComponentModel.CategoryAttribute("Client Side Events")
public function get,set OnResponse : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, status")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when a response from server is returned.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public: __property System.string* get_OnResponse();
public: __property void set_OnResponse(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, status")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when a response from server is returned.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public:
property System.String^ OnResponse {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorClientSideEvents Class
WebTextEditorClientSideEvents Members


OnSave Property

[image]
Intersoft WebTextEditor Documentation
OnSave Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorClientSideEvents Class : OnSave Property

Glossary Item Box

Gets or sets the event handler that will be invoked when WebTextEditor's content is saved.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.EventParameterAttribute("controlId")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked the content of WebTextEditor content is being saved.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
Public Property OnSave As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorClientSideEvents
Dim value As System.String

instance.OnSave = value

value = instance.OnSave
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked the content of WebTextEditor content is being saved.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public System.string OnSave {get; set;}
Delphi
public read-write property OnSave: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.EventParameterAttribute("controlId")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked the content of WebTextEditor content is being saved.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Client Side Events")
public function get,set OnSave : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked the content of WebTextEditor content is being saved.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public: __property System.string* get_OnSave();
public: __property void set_OnSave(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked the content of WebTextEditor content is being saved.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public:
property System.String^ OnSave {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorClientSideEvents Class
WebTextEditorClientSideEvents Members


OnSendMailCompleted Property

[image]
Intersoft WebTextEditor Documentation
OnSendMailCompleted Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorClientSideEvents Class : OnSendMailCompleted Property

Glossary Item Box

Gets or sets the event handler that will be invoked when send mail action is completed.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.EventParameterAttribute("controlId, failed, failedEmails")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when send mail action is completed.")>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
Public Property OnSendMailCompleted As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorClientSideEvents
Dim value As System.String

instance.OnSendMailCompleted = value

value = instance.OnSendMailCompleted
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, failed, failedEmails")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when send mail action is completed.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public System.string OnSendMailCompleted {get; set;}
Delphi
public read-write property OnSendMailCompleted: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.EventParameterAttribute("controlId, failed, failedEmails")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when send mail action is completed.")
System.ComponentModel.CategoryAttribute("Client Side Events")
public function get,set OnSendMailCompleted : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, failed, failedEmails")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when send mail action is completed.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public: __property System.string* get_OnSendMailCompleted();
public: __property void set_OnSendMailCompleted(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, failed, failedEmails")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when send mail action is completed.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public:
property System.String^ OnSendMailCompleted {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorClientSideEvents Class
WebTextEditorClientSideEvents Members


OnToolBarClick Property

[image]
Intersoft WebTextEditor Documentation
OnToolBarClick Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorClientSideEvents Class : OnToolBarClick Property

Glossary Item Box

Gets or sets the event handler that will be invoked when a command in toolbar is clicked.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.EventParameterAttribute("controlId, command, commandSection")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when a command in toolbar is clicked.")>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
Public Property OnToolBarClick As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorClientSideEvents
Dim value As System.String

instance.OnToolBarClick = value

value = instance.OnToolBarClick
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, command, commandSection")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when a command in toolbar is clicked.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public System.string OnToolBarClick {get; set;}
Delphi
public read-write property OnToolBarClick: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.EventParameterAttribute("controlId, command, commandSection")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when a command in toolbar is clicked.")
System.ComponentModel.CategoryAttribute("Client Side Events")
public function get,set OnToolBarClick : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, command, commandSection")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when a command in toolbar is clicked.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public: __property System.string* get_OnToolBarClick();
public: __property void set_OnToolBarClick(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, command, commandSection")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when a command in toolbar is clicked.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public:
property System.String^ OnToolBarClick {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorClientSideEvents Class
WebTextEditorClientSideEvents Members


OnUploaderCompleted Property

[image]
Intersoft WebTextEditor Documentation
OnUploaderCompleted Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorClientSideEvents Class : OnUploaderCompleted Property

Glossary Item Box

Gets or sets the event handler that will be invoked when uploading process has been completed regardless of the individual upload status.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.EventParameterAttribute("controlId")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when uploading process has been completed regardless of the individual upload status.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
Public Property OnUploaderCompleted As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorClientSideEvents
Dim value As System.String

instance.OnUploaderCompleted = value

value = instance.OnUploaderCompleted
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when uploading process has been completed regardless of the individual upload status.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public System.string OnUploaderCompleted {get; set;}
Delphi
public read-write property OnUploaderCompleted: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.EventParameterAttribute("controlId")
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when uploading process has been completed regardless of the individual upload status.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Client Side Events")
public function get,set OnUploaderCompleted : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when uploading process has been completed regardless of the individual upload status.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public: __property System.string* get_OnUploaderCompleted();
public: __property void set_OnUploaderCompleted(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when uploading process has been completed regardless of the individual upload status.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public:
property System.String^ OnUploaderCompleted {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorClientSideEvents Class
WebTextEditorClientSideEvents Members


OnUploaderError Property

[image]
Intersoft WebTextEditor Documentation
OnUploaderError Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorClientSideEvents Class : OnUploaderError Property

Glossary Item Box

Gets or sets the event handler that will be invoked when an error occurred during file uploading process.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.EventParameterAttribute("controlId, webFileUploadInfo, errorMessage, errorDetail")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when an error occurred during file uploading process.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
Public Property OnUploaderError As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorClientSideEvents
Dim value As System.String

instance.OnUploaderError = value

value = instance.OnUploaderError
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, webFileUploadInfo, errorMessage, errorDetail")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when an error occurred during file uploading process.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public System.string OnUploaderError {get; set;}
Delphi
public read-write property OnUploaderError: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.EventParameterAttribute("controlId, webFileUploadInfo, errorMessage, errorDetail")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when an error occurred during file uploading process.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Client Side Events")
public function get,set OnUploaderError : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, webFileUploadInfo, errorMessage, errorDetail")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when an error occurred during file uploading process.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public: __property System.string* get_OnUploaderError();
public: __property void set_OnUploaderError(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, webFileUploadInfo, errorMessage, errorDetail")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when an error occurred during file uploading process.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public:
property System.String^ OnUploaderError {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorClientSideEvents Class
WebTextEditorClientSideEvents Members


OnUploaderFileAdded Property

[image]
Intersoft WebTextEditor Documentation
OnUploaderFileAdded Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorClientSideEvents Class : OnUploaderFileAdded Property

Glossary Item Box

Gets or sets the event handler that will be invoked when a file is added to the integrated file uploader.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.EventParameterAttribute("controlId, webFileUploadInfo")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when a file is added to the integrated file uploader.")>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
Public Property OnUploaderFileAdded As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorClientSideEvents
Dim value As System.String

instance.OnUploaderFileAdded = value

value = instance.OnUploaderFileAdded
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, webFileUploadInfo")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when a file is added to the integrated file uploader.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public System.string OnUploaderFileAdded {get; set;}
Delphi
public read-write property OnUploaderFileAdded: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.EventParameterAttribute("controlId, webFileUploadInfo")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when a file is added to the integrated file uploader.")
System.ComponentModel.CategoryAttribute("Client Side Events")
public function get,set OnUploaderFileAdded : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, webFileUploadInfo")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when a file is added to the integrated file uploader.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public: __property System.string* get_OnUploaderFileAdded();
public: __property void set_OnUploaderFileAdded(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.EventParameterAttribute("controlId, webFileUploadInfo")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when a file is added to the integrated file uploader.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public:
property System.String^ OnUploaderFileAdded {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorClientSideEvents Class
WebTextEditorClientSideEvents Members


OnUploaderFileRemoved Property

[image]
Intersoft WebTextEditor Documentation
OnUploaderFileRemoved Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorClientSideEvents Class : OnUploaderFileRemoved Property

Glossary Item Box

Gets or sets the event handler that will be invoked when a file is removed from the integrated file uploader.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<ISNet.EventParameterAttribute("controlId, webFileUploadInfo")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when a file is removed from the integrated file uploader.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property OnUploaderFileRemoved As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorClientSideEvents
Dim value As System.String

instance.OnUploaderFileRemoved = value

value = instance.OnUploaderFileRemoved
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[ISNet.EventParameterAttribute("controlId, webFileUploadInfo")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when a file is removed from the integrated file uploader.")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string OnUploaderFileRemoved {get; set;}
Delphi
public read-write property OnUploaderFileRemoved: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
System.ComponentModel.CategoryAttribute("Client Side Events")
ISNet.EventParameterAttribute("controlId, webFileUploadInfo")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when a file is removed from the integrated file uploader.")
System.ComponentModel.DefaultValueAttribute()
public function get,set OnUploaderFileRemoved : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[ISNet.EventParameterAttribute("controlId, webFileUploadInfo")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when a file is removed from the integrated file uploader.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_OnUploaderFileRemoved();
public: __property void set_OnUploaderFileRemoved(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[ISNet.EventParameterAttribute("controlId, webFileUploadInfo")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when a file is removed from the integrated file uploader.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ OnUploaderFileRemoved {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorClientSideEvents Class
WebTextEditorClientSideEvents Members


OnUploaderInitialize Property

[image]
Intersoft WebTextEditor Documentation
OnUploaderInitialize Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorClientSideEvents Class : OnUploaderInitialize Property

Glossary Item Box

Gets or sets the event handler that will be invoked when the integrated file uploader is being initialized.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.EventParameterAttribute("controlId")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when the integrated file uploader is being initialized.")>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
Public Property OnUploaderInitialize As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorClientSideEvents
Dim value As System.String

instance.OnUploaderInitialize = value

value = instance.OnUploaderInitialize
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when the integrated file uploader is being initialized.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public System.string OnUploaderInitialize {get; set;}
Delphi
public read-write property OnUploaderInitialize: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.EventParameterAttribute("controlId")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when the integrated file uploader is being initialized.")
System.ComponentModel.CategoryAttribute("Client Side Events")
public function get,set OnUploaderInitialize : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when the integrated file uploader is being initialized.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public: __property System.string* get_OnUploaderInitialize();
public: __property void set_OnUploaderInitialize(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.EventParameterAttribute("controlId")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when the integrated file uploader is being initialized.")]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
public:
property System.String^ OnUploaderInitialize {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorClientSideEvents Class
WebTextEditorClientSideEvents Members


OnUploaderValidate Property

[image]
Intersoft WebTextEditor Documentation
OnUploaderValidate Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorClientSideEvents Class : OnUploaderValidate Property

Glossary Item Box

Gets or sets the event handler that will be invoked when validating a file that is added to the integrated file uploader.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when validating a file that is added to the integrated file uploader.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.EventParameterAttribute("controlId, validationType, value, isValid")>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
Public Property OnUploaderValidate As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorClientSideEvents
Dim value As System.String

instance.OnUploaderValidate = value

value = instance.OnUploaderValidate
C#
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when validating a file that is added to the integrated file uploader.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, validationType, value, isValid")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public System.string OnUploaderValidate {get; set;}
Delphi
public read-write property OnUploaderValidate: System.String;
JScript
System.ComponentModel.CategoryAttribute("Client Side Events")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when validating a file that is added to the integrated file uploader.")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.EventParameterAttribute("controlId, validationType, value, isValid")
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
public function get,set OnUploaderValidate : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when validating a file that is added to the integrated file uploader.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, validationType, value, isValid")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public: __property System.string* get_OnUploaderValidate();
public: __property void set_OnUploaderValidate(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when validating a file that is added to the integrated file uploader.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, validationType, value, isValid")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
public:
property System.String^ OnUploaderValidate {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorClientSideEvents Class
WebTextEditorClientSideEvents Members


OnUploading Property

[image]
Intersoft WebTextEditor Documentation
OnUploading Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorClientSideEvents Class : OnUploading Property

Glossary Item Box

Gets or sets the event handler that will be invoked when a file is being uploaded.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when a file is being uploaded.")>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.EventParameterAttribute("controlId, webFileUploadInfo")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Client Side Events")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property OnUploading As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorClientSideEvents
Dim value As System.String

instance.OnUploading = value

value = instance.OnUploading
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when a file is being uploaded.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, webFileUploadInfo")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string OnUploading {get; set;}
Delphi
public read-write property OnUploading: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when a file is being uploaded.")
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.EventParameterAttribute("controlId, webFileUploadInfo")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Client Side Events")
System.ComponentModel.DefaultValueAttribute()
public function get,set OnUploading : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when a file is being uploaded.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, webFileUploadInfo")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_OnUploading();
public: __property void set_OnUploading(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the event handler that will be invoked when a file is being uploaded.")]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="ISNet.WeUI.Design.ClientSideEventEditor, ISNet.WebUI.Design")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.EventParameterAttribute("controlId, webFileUploadInfo")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Client Side Events")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ OnUploading {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorClientSideEvents Class
WebTextEditorClientSideEvents Members


WebTextEditorCssFile Class

[image]
Intersoft WebTextEditor Documentation
WebTextEditorCssFile Class
Members See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorCssFile Class

Glossary Item Box

A collection of WebTextEditor's css files.

Object Model

WebTextEditorCssFile Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebTextEditorCssFile
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorCssFile
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebTextEditorCssFile : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebTextEditorCssFile = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebTextEditorCssFile extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebTextEditorCssFile : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebTextEditorCssFile : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebTextEditor.WebTextEditorCssFile

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorCssFile Members
ISNet.WebUI.WebTextEditor Namespace


WebTextEditorCssFile Class Members

[image]
Intersoft WebTextEditor Documentation
WebTextEditorCssFile Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorCssFile Class

Glossary Item Box

The following tables list the members exposed by WebTextEditorCssFile.

Public Constructors

 | Name | Description
Public Constructor | WebTextEditorCssFile Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | FilePath | Specifies the path of css file.
Public Property | Type | Specifies the type of css file.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

Protected Methods

 | Name | Description
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | IsInSerializationContext | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebTextEditorCssFile Class
ISNet.WebUI.WebTextEditor Namespace


WebTextEditorCssFile Constructor

[image]
Intersoft WebTextEditor Documentation
WebTextEditorCssFile Constructor
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorCssFile Class : WebTextEditorCssFile Constructor

Glossary Item Box

Overload List

Overload | Description
WebTextEditorCssFile Constructor() |
WebTextEditorCssFile Constructor(SerializationInfo,StreamingContext) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorCssFile Class
WebTextEditorCssFile Members


WebTextEditorCssFile Constructor()

[image]
Intersoft WebTextEditor Documentation
WebTextEditorCssFile Constructor()
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorCssFile Class > WebTextEditorCssFile Constructor : WebTextEditorCssFile Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebTextEditorCssFile()
C#
public WebTextEditorCssFile()
Delphi
public WebTextEditorCssFile();
JScript
public function WebTextEditorCssFile();
Managed Extensions for C++
public: WebTextEditorCssFile();
C++/CLI
public:
WebTextEditorCssFile();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorCssFile Class
WebTextEditorCssFile Members
Overload List


WebTextEditorCssFile Constructor(SerializationInfo,StreamingContext)

[image]
Intersoft WebTextEditor Documentation
WebTextEditorCssFile Constructor(SerializationInfo,StreamingContext)
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorCssFile Class > WebTextEditorCssFile Constructor : WebTextEditorCssFile Constructor(SerializationInfo,StreamingContext)

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

Dim instance As New WebTextEditorCssFile(info, context)
C#
protected WebTextEditorCssFile(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
protected WebTextEditorCssFile(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
protected function WebTextEditorCssFile(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
protected: WebTextEditorCssFile(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
protected:
WebTextEditorCssFile(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorCssFile Class
WebTextEditorCssFile Members
Overload List


WebTextEditorCssFile Class Methods

[image]
Intersoft WebTextEditor Documentation
WebTextEditorCssFile Class Methods
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorCssFile Class

Glossary Item Box

For a list of all members of this type, see WebTextEditorCssFile members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

Protected Methods

 | Name | Description
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | IsInSerializationContext | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebTextEditorCssFile Class
ISNet.WebUI.WebTextEditor Namespace


GetObjectData Method

[image]
Intersoft WebTextEditor Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorCssFile Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorCssFile
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorCssFile Class
WebTextEditorCssFile Members


WebTextEditorCssFile Class Properties

[image]
Intersoft WebTextEditor Documentation
WebTextEditorCssFile Class Properties
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorCssFile Class

Glossary Item Box

For a list of all members of this type, see WebTextEditorCssFile members.

Public Properties

 | Name | Description
Public Property | FilePath | Specifies the path of css file.
Public Property | Type | Specifies the type of css file.
Top

See Also

Reference

WebTextEditorCssFile Class
ISNet.WebUI.WebTextEditor Namespace


FilePath Property

[image]
Intersoft WebTextEditor Documentation
FilePath Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorCssFile Class : FilePath Property

Glossary Item Box

Specifies the path of css file.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the path of css file.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Css")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property FilePath As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorCssFile
Dim value As System.String

instance.FilePath = value

value = instance.FilePath
C#
[System.ComponentModel.DescriptionAttribute("Specifies the path of css file.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Css")]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string FilePath {get; set;}
Delphi
public read-write property FilePath: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the path of css file.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Css")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set FilePath : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the path of css file.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Css")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_FilePath();
public: __property void set_FilePath(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the path of css file.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Css")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ FilePath {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorCssFile Class
WebTextEditorCssFile Members


Type Property

[image]
Intersoft WebTextEditor Documentation
Type Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorCssFile Class : Type Property

Glossary Item Box

Specifies the type of css file.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the type of css file.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Css")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Type As WebTextEditorCssType
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorCssFile
Dim value As WebTextEditorCssType

instance.Type = value

value = instance.Type
C#
[System.ComponentModel.DescriptionAttribute("Specifies the type of css file.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Css")]
[System.ComponentModel.DefaultValueAttribute()]
public WebTextEditorCssType Type {get; set;}
Delphi
public read-write property Type: WebTextEditorCssType;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the type of css file.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Css")
System.ComponentModel.DefaultValueAttribute()
public function get,set Type : WebTextEditorCssType
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the type of css file.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Css")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property WebTextEditorCssType get_Type();
public: __property void set_Type(
   WebTextEditorCssType value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the type of css file.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Css")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property WebTextEditorCssType Type {
   WebTextEditorCssType get();
   void set (    WebTextEditorCssType value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorCssFile Class
WebTextEditorCssFile Members


WebTextEditorDataSourceInfo Class

[image]
Intersoft WebTextEditor Documentation
WebTextEditorDataSourceInfo Class
Members See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorDataSourceInfo Class

Glossary Item Box

Object Model

WebTextEditorDataSourceInfo Class

Syntax

Visual Basic (Declaration)
Public Class WebTextEditorDataSourceInfo
   Inherits ISNet.WebUI.DataSourceInfo
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorDataSourceInfo
C#
public class WebTextEditorDataSourceInfo : ISNet.WebUI.DataSourceInfo
Delphi
public class WebTextEditorDataSourceInfo = class(ISNet.WebUI.DataSourceInfo)
JScript
public class WebTextEditorDataSourceInfo extends ISNet.WebUI.DataSourceInfo
Managed Extensions for C++
public __gc class WebTextEditorDataSourceInfo : public ISNet.WebUI.DataSourceInfo
C++/CLI
public ref class WebTextEditorDataSourceInfo : public ISNet.WebUI.DataSourceInfo

Inheritance Hierarchy

System.Object
ISNet.WebUI.DataSourceInfo
ISNet.WebUI.WebTextEditor.WebTextEditorDataSourceInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorDataSourceInfo Members
ISNet.WebUI.WebTextEditor Namespace


WebTextEditorDataSourceInfo Class Members

[image]
Intersoft WebTextEditor Documentation
WebTextEditorDataSourceInfo Class Members
See Also Properties Methods Events Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorDataSourceInfo Class

Glossary Item Box

The following tables list the members exposed by WebTextEditorDataSourceInfo.

Public Constructors

 | Name | Description
Public Constructor | WebTextEditorDataSourceInfo Constructor |
Top

Public Properties

 | Name | Description
Public Property | Control | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Property | CurrentDataSource | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Property | IgnoreDataSourceViewChanged | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Property | IsBoundUsingDataSourceID | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Property | IsDataSourceViewValid | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Property | RequiresDataBinding | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Property | SelectArguments | (Inherited from ISNet.WebUI.DataSourceInfo)
Top

Public Methods

 | Name | Description
Public Method | DataBind | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Method | EnsureDataBound | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Method | FindControl | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Method | GetData | Overloaded. (Inherited from ISNet.WebUI.DataSourceInfo)
Public Method | GetDataSourceControl | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Method | GetDataSourceID | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Method | GetSelectParameters | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Method | GetTable | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Method | IsIntersoftDataSourceControl | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Method | SetViewValid | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Method | ValidateDataSource | (Inherited from ISNet.WebUI.DataSourceInfo)
Top

Protected Methods

 | Name | Description
Protected Method | CreateDataSourceSelectArguments | (Inherited from ISNet.WebUI.DataSourceInfo)
Protected Method | OnDataSourceViewSelectCallback | (Inherited from ISNet.WebUI.DataSourceInfo)
Protected Method | PerformSelect | Overridden.
Protected Method | Reset | (Inherited from ISNet.WebUI.DataSourceInfo)
Top

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Event | DataBound | (Inherited from ISNet.WebUI.DataSourceInfo)
Top

See Also

Reference

WebTextEditorDataSourceInfo Class
ISNet.WebUI.WebTextEditor Namespace


WebTextEditorDataSourceInfo Constructor

[image]
Intersoft WebTextEditor Documentation
WebTextEditorDataSourceInfo Constructor
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorDataSourceInfo Class : WebTextEditorDataSourceInfo Constructor

textEditor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal textEditor As WebTextEditor _
)
Visual Basic (Usage) Copy Code
Dim textEditor As WebTextEditor

Dim instance As New WebTextEditorDataSourceInfo(textEditor)
C#
public WebTextEditorDataSourceInfo(
   WebTextEditor textEditor
)
Delphi
public WebTextEditorDataSourceInfo(
    textEditor: WebTextEditor
);
JScript
public function WebTextEditorDataSourceInfo(
   textEditor : WebTextEditor
);
Managed Extensions for C++
public: WebTextEditorDataSourceInfo(
   WebTextEditor* textEditor
)
C++/CLI
public:
WebTextEditorDataSourceInfo(
   WebTextEditor^ textEditor
)

Parameters

textEditor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorDataSourceInfo Class
WebTextEditorDataSourceInfo Members


WebTextEditorDataSourceInfo Class Methods

[image]
Intersoft WebTextEditor Documentation
WebTextEditorDataSourceInfo Class Methods
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorDataSourceInfo Class

Glossary Item Box

For a list of all members of this type, see WebTextEditorDataSourceInfo members.

Public Methods

 | Name | Description
Public Method | DataBind | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Method | EnsureDataBound | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Method | FindControl | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Method | GetData | Overloaded. (Inherited from ISNet.WebUI.DataSourceInfo)
Public Method | GetDataSourceControl | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Method | GetDataSourceID | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Method | GetSelectParameters | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Method | GetTable | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Method | IsIntersoftDataSourceControl | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Method | SetViewValid | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Method | ValidateDataSource | (Inherited from ISNet.WebUI.DataSourceInfo)
Top

Protected Methods

 | Name | Description
Protected Method | CreateDataSourceSelectArguments | (Inherited from ISNet.WebUI.DataSourceInfo)
Protected Method | OnDataSourceViewSelectCallback | (Inherited from ISNet.WebUI.DataSourceInfo)
Protected Method | PerformSelect | Overridden.
Protected Method | Reset | (Inherited from ISNet.WebUI.DataSourceInfo)
Top

See Also

Reference

WebTextEditorDataSourceInfo Class
ISNet.WebUI.WebTextEditor Namespace


PerformSelect Method

[image]
Intersoft WebTextEditor Documentation
PerformSelect Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorDataSourceInfo Class : PerformSelect Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overrides Sub PerformSelect()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorDataSourceInfo

instance.PerformSelect()
C#
protected override void PerformSelect()
Delphi
protected procedure PerformSelect(); override;
JScript
protected override function PerformSelect();
Managed Extensions for C++
protected: void PerformSelect(); override
C++/CLI
protected:
void PerformSelect(); override

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorDataSourceInfo Class
WebTextEditorDataSourceInfo Members


WebTextEditorEditorSettings Class

[image]
Intersoft WebTextEditor Documentation
WebTextEditorEditorSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorEditorSettings Class

Glossary Item Box

A collection of WebTextEditor's editor settings.

Object Model

WebTextEditorEditorSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebTextEditorEditorSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorEditorSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebTextEditorEditorSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebTextEditorEditorSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebTextEditorEditorSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebTextEditorEditorSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebTextEditorEditorSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebTextEditor.WebTextEditorEditorSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorEditorSettings Members
ISNet.WebUI.WebTextEditor Namespace


WebTextEditorEditorSettings Class Members

[image]
Intersoft WebTextEditor Documentation
WebTextEditorEditorSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorEditorSettings Class

Glossary Item Box

The following tables list the members exposed by WebTextEditorEditorSettings.

Public Constructors

 | Name | Description
Public Constructor | WebTextEditorEditorSettings Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | DefaultFontName | Specifies the default font name used in Editor.
Public Property | DefaultFontSize | Specifies the default font size used in Editor.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

Protected Methods

 | Name | Description
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | IsInSerializationContext | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebTextEditorEditorSettings Class
ISNet.WebUI.WebTextEditor Namespace


WebTextEditorEditorSettings Constructor

[image]
Intersoft WebTextEditor Documentation
WebTextEditorEditorSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorEditorSettings Class : WebTextEditorEditorSettings Constructor

Glossary Item Box

Overload List

Overload | Description
WebTextEditorEditorSettings Constructor() |
WebTextEditorEditorSettings Constructor(SerializationInfo,StreamingContext) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorEditorSettings Class
WebTextEditorEditorSettings Members


WebTextEditorEditorSettings Constructor()

[image]
Intersoft WebTextEditor Documentation
WebTextEditorEditorSettings Constructor()
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorEditorSettings Class > WebTextEditorEditorSettings Constructor : WebTextEditorEditorSettings Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebTextEditorEditorSettings()
C#
public WebTextEditorEditorSettings()
Delphi
public WebTextEditorEditorSettings();
JScript
public function WebTextEditorEditorSettings();
Managed Extensions for C++
public: WebTextEditorEditorSettings();
C++/CLI
public:
WebTextEditorEditorSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorEditorSettings Class
WebTextEditorEditorSettings Members
Overload List


WebTextEditorEditorSettings Constructor(SerializationInfo,StreamingContext)

[image]
Intersoft WebTextEditor Documentation
WebTextEditorEditorSettings Constructor(SerializationInfo,StreamingContext)
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorEditorSettings Class > WebTextEditorEditorSettings Constructor : WebTextEditorEditorSettings Constructor(SerializationInfo,StreamingContext)

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

Dim instance As New WebTextEditorEditorSettings(info, context)
C#
protected WebTextEditorEditorSettings(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
protected WebTextEditorEditorSettings(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
protected function WebTextEditorEditorSettings(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
protected: WebTextEditorEditorSettings(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
protected:
WebTextEditorEditorSettings(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorEditorSettings Class
WebTextEditorEditorSettings Members
Overload List


WebTextEditorEditorSettings Class Methods

[image]
Intersoft WebTextEditor Documentation
WebTextEditorEditorSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorEditorSettings Class

Glossary Item Box

For a list of all members of this type, see WebTextEditorEditorSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

Protected Methods

 | Name | Description
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | IsInSerializationContext | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebTextEditorEditorSettings Class
ISNet.WebUI.WebTextEditor Namespace


GetObjectData Method

[image]
Intersoft WebTextEditor Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorEditorSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorEditorSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorEditorSettings Class
WebTextEditorEditorSettings Members


WebTextEditorEditorSettings Class Properties

[image]
Intersoft WebTextEditor Documentation
WebTextEditorEditorSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorEditorSettings Class

Glossary Item Box

For a list of all members of this type, see WebTextEditorEditorSettings members.

Public Properties

 | Name | Description
Public Property | DefaultFontName | Specifies the default font name used in Editor.
Public Property | DefaultFontSize | Specifies the default font size used in Editor.
Top

See Also

Reference

WebTextEditorEditorSettings Class
ISNet.WebUI.WebTextEditor Namespace


DefaultFontName Property

[image]
Intersoft WebTextEditor Documentation
DefaultFontName Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorEditorSettings Class : DefaultFontName Property

Glossary Item Box

Specifies the default font name used in Editor.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the default font name used in Editor.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Text")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property DefaultFontName As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorEditorSettings
Dim value As System.String

instance.DefaultFontName = value

value = instance.DefaultFontName
C#
[System.ComponentModel.DescriptionAttribute("Specifies the default font name used in Editor.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string DefaultFontName {get; set;}
Delphi
public read-write property DefaultFontName: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the default font name used in Editor.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Text")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set DefaultFontName : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the default font name used in Editor.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_DefaultFontName();
public: __property void set_DefaultFontName(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the default font name used in Editor.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ DefaultFontName {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default value is Lucida Grande.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorEditorSettings Class
WebTextEditorEditorSettings Members


DefaultFontSize Property

[image]
Intersoft WebTextEditor Documentation
DefaultFontSize Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorEditorSettings Class : DefaultFontSize Property

Glossary Item Box

Specifies the default font size used in Editor.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the default font size used in Editor.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Text")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property DefaultFontSize As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorEditorSettings
Dim value As System.String

instance.DefaultFontSize = value

value = instance.DefaultFontSize
C#
[System.ComponentModel.DescriptionAttribute("Specifies the default font size used in Editor.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string DefaultFontSize {get; set;}
Delphi
public read-write property DefaultFontSize: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the default font size used in Editor.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Text")
System.ComponentModel.DefaultValueAttribute()
public function get,set DefaultFontSize : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the default font size used in Editor.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_DefaultFontSize();
public: __property void set_DefaultFontSize(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the default font size used in Editor.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ DefaultFontSize {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default value is 9.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorEditorSettings Class
WebTextEditorEditorSettings Members


WebTextEditorFileUploaderSettings Class

[image]
Intersoft WebTextEditor Documentation
WebTextEditorFileUploaderSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorFileUploaderSettings Class

Glossary Item Box

A collection of WebTextEditor's uploader settings.

Object Model

WebTextEditorFileUploaderSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebTextEditorFileUploaderSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorFileUploaderSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebTextEditorFileUploaderSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebTextEditorFileUploaderSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebTextEditorFileUploaderSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebTextEditorFileUploaderSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebTextEditorFileUploaderSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebTextEditor.WebTextEditorFileUploaderSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorFileUploaderSettings Members
ISNet.WebUI.WebTextEditor Namespace


WebTextEditorFileUploaderSettings Class Members

[image]
Intersoft WebTextEditor Documentation
WebTextEditorFileUploaderSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorFileUploaderSettings Class

Glossary Item Box

The following tables list the members exposed by WebTextEditorFileUploaderSettings.

Public Constructors

 | Name | Description
Public Constructor | WebTextEditorFileUploaderSettings Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | AllowCancel | Specifies whether or not the uploading process can be cancelled.
Public Property | DefaultUploadMediaResource | Specifies the default media resource that is used as default upload path.
Public Property | DefaultUploadPath | Specifies the default upload path in case none is specified in media resource.
Public Property | Enabled | Specifies whether or not file uploader is enabled.
Public Property | FilesCount | Specifies the maximum number of files that can be uploaded in a single uploading process.
Public Property | FileTypes | Specifies the types of files that can be uploaded.
Public Property | TotalUploadSizeLimit | Specifies the maximum size of total uploaded files.
Public Property | UploadSizeLimit | Specifies the maximum size of an uploaded file.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

Protected Methods

 | Name | Description
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | IsInSerializationContext | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebTextEditorFileUploaderSettings Class
ISNet.WebUI.WebTextEditor Namespace


WebTextEditorFileUploaderSettings Constructor

[image]
Intersoft WebTextEditor Documentation
WebTextEditorFileUploaderSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorFileUploaderSettings Class : WebTextEditorFileUploaderSettings Constructor

Glossary Item Box

Overload List

Overload | Description
WebTextEditorFileUploaderSettings Constructor() |
WebTextEditorFileUploaderSettings Constructor(SerializationInfo,StreamingContext) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorFileUploaderSettings Class
WebTextEditorFileUploaderSettings Members


WebTextEditorFileUploaderSettings Constructor()

[image]
Intersoft WebTextEditor Documentation
WebTextEditorFileUploaderSettings Constructor()
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorFileUploaderSettings Class > WebTextEditorFileUploaderSettings Constructor : WebTextEditorFileUploaderSettings Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebTextEditorFileUploaderSettings()
C#
public WebTextEditorFileUploaderSettings()
Delphi
public WebTextEditorFileUploaderSettings();
JScript
public function WebTextEditorFileUploaderSettings();
Managed Extensions for C++
public: WebTextEditorFileUploaderSettings();
C++/CLI
public:
WebTextEditorFileUploaderSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorFileUploaderSettings Class
WebTextEditorFileUploaderSettings Members
Overload List


WebTextEditorFileUploaderSettings Constructor(SerializationInfo,StreamingContext)

[image]
Intersoft WebTextEditor Documentation
WebTextEditorFileUploaderSettings Constructor(SerializationInfo,StreamingContext)
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorFileUploaderSettings Class > WebTextEditorFileUploaderSettings Constructor : WebTextEditorFileUploaderSettings Constructor(SerializationInfo,StreamingContext)

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

Dim instance As New WebTextEditorFileUploaderSettings(info, context)
C#
protected WebTextEditorFileUploaderSettings(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
protected WebTextEditorFileUploaderSettings(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
protected function WebTextEditorFileUploaderSettings(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
protected: WebTextEditorFileUploaderSettings(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
protected:
WebTextEditorFileUploaderSettings(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorFileUploaderSettings Class
WebTextEditorFileUploaderSettings Members
Overload List


WebTextEditorFileUploaderSettings Class Methods

[image]
Intersoft WebTextEditor Documentation
WebTextEditorFileUploaderSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorFileUploaderSettings Class

Glossary Item Box

For a list of all members of this type, see WebTextEditorFileUploaderSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

Protected Methods

 | Name | Description
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | IsInSerializationContext | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebTextEditorFileUploaderSettings Class
ISNet.WebUI.WebTextEditor Namespace


GetObjectData Method

[image]
Intersoft WebTextEditor Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorFileUploaderSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorFileUploaderSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorFileUploaderSettings Class
WebTextEditorFileUploaderSettings Members


WebTextEditorFileUploaderSettings Class Properties

[image]
Intersoft WebTextEditor Documentation
WebTextEditorFileUploaderSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorFileUploaderSettings Class

Glossary Item Box

For a list of all members of this type, see WebTextEditorFileUploaderSettings members.

Public Properties

 | Name | Description
Public Property | AllowCancel | Specifies whether or not the uploading process can be cancelled.
Public Property | DefaultUploadMediaResource | Specifies the default media resource that is used as default upload path.
Public Property | DefaultUploadPath | Specifies the default upload path in case none is specified in media resource.
Public Property | Enabled | Specifies whether or not file uploader is enabled.
Public Property | FilesCount | Specifies the maximum number of files that can be uploaded in a single uploading process.
Public Property | FileTypes | Specifies the types of files that can be uploaded.
Public Property | TotalUploadSizeLimit | Specifies the maximum size of total uploaded files.
Public Property | UploadSizeLimit | Specifies the maximum size of an uploaded file.
Top

See Also

Reference

WebTextEditorFileUploaderSettings Class
ISNet.WebUI.WebTextEditor Namespace


AllowCancel Property

[image]
Intersoft WebTextEditor Documentation
AllowCancel Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorFileUploaderSettings Class : AllowCancel Property

Glossary Item Box

Specifies whether or not the uploading process can be cancelled.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies whether or not the uploading process can be cancelled.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("FileUploader")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property AllowCancel As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorFileUploaderSettings
Dim value As System.Boolean

instance.AllowCancel = value

value = instance.AllowCancel
C#
[System.ComponentModel.DescriptionAttribute("Specifies whether or not the uploading process can be cancelled.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("FileUploader")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.bool AllowCancel {get; set;}
Delphi
public read-write property AllowCancel: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Specifies whether or not the uploading process can be cancelled.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("FileUploader")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set AllowCancel : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies whether or not the uploading process can be cancelled.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("FileUploader")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.bool get_AllowCancel();
public: __property void set_AllowCancel(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies whether or not the uploading process can be cancelled.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("FileUploader")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.bool AllowCancel {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is true.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorFileUploaderSettings Class
WebTextEditorFileUploaderSettings Members


DefaultUploadMediaResource Property

[image]
Intersoft WebTextEditor Documentation
DefaultUploadMediaResource Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorFileUploaderSettings Class : DefaultUploadMediaResource Property

Glossary Item Box

Specifies the default media resource that is used as default upload path.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("FileUploader")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the default media resource that is used as default upload path.")>
Public Property DefaultUploadMediaResource As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorFileUploaderSettings
Dim value As System.String

instance.DefaultUploadMediaResource = value

value = instance.DefaultUploadMediaResource
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("FileUploader")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the default media resource that is used as default upload path.")]
public System.string DefaultUploadMediaResource {get; set;}
Delphi
public read-write property DefaultUploadMediaResource: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("FileUploader")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the default media resource that is used as default upload path.")
public function get,set DefaultUploadMediaResource : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("FileUploader")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the default media resource that is used as default upload path.")]
public: __property System.string* get_DefaultUploadMediaResource();
public: __property void set_DefaultUploadMediaResource(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("FileUploader")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the default media resource that is used as default upload path.")]
public:
property System.String^ DefaultUploadMediaResource {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default value is "".

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorFileUploaderSettings Class
WebTextEditorFileUploaderSettings Members


DefaultUploadPath Property

[image]
Intersoft WebTextEditor Documentation
DefaultUploadPath Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorFileUploaderSettings Class : DefaultUploadPath Property

Glossary Item Box

Specifies the default upload path in case none is specified in media resource.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("FileUploader")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the default upload path in case none is specified in media resource.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property DefaultUploadPath As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorFileUploaderSettings
Dim value As System.String

instance.DefaultUploadPath = value

value = instance.DefaultUploadPath
C#
[System.ComponentModel.CategoryAttribute("FileUploader")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the default upload path in case none is specified in media resource.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string DefaultUploadPath {get; set;}
Delphi
public read-write property DefaultUploadPath: System.String;
JScript
System.ComponentModel.CategoryAttribute("FileUploader")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the default upload path in case none is specified in media resource.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set DefaultUploadPath : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("FileUploader")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the default upload path in case none is specified in media resource.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_DefaultUploadPath();
public: __property void set_DefaultUploadPath(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("FileUploader")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the default upload path in case none is specified in media resource.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ DefaultUploadPath {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default value is "".

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorFileUploaderSettings Class
WebTextEditorFileUploaderSettings Members


Enabled Property

[image]
Intersoft WebTextEditor Documentation
Enabled Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorFileUploaderSettings Class : Enabled Property

Glossary Item Box

Specifies whether or not file uploader is enabled.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies whether or not file uploader is enabled.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("FileUploader")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Enabled As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorFileUploaderSettings
Dim value As System.Boolean

instance.Enabled = value

value = instance.Enabled
C#
[System.ComponentModel.DescriptionAttribute("Specifies whether or not file uploader is enabled.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("FileUploader")]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool Enabled {get; set;}
Delphi
public read-write property Enabled: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Specifies whether or not file uploader is enabled.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("FileUploader")
System.ComponentModel.DefaultValueAttribute()
public function get,set Enabled : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies whether or not file uploader is enabled.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("FileUploader")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_Enabled();
public: __property void set_Enabled(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies whether or not file uploader is enabled.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("FileUploader")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool Enabled {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is true.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorFileUploaderSettings Class
WebTextEditorFileUploaderSettings Members


FilesCount Property

[image]
Intersoft WebTextEditor Documentation
FilesCount Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorFileUploaderSettings Class : FilesCount Property

Glossary Item Box

Specifies the maximum number of files that can be uploaded in a single uploading process.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("FileUploader")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the maximum number of files that can be uploaded in a single uploading process.")>
Public Property FilesCount As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorFileUploaderSettings
Dim value As System.Integer

instance.FilesCount = value

value = instance.FilesCount
C#
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("FileUploader")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the maximum number of files that can be uploaded in a single uploading process.")]
public System.int FilesCount {get; set;}
Delphi
public read-write property FilesCount: System.Integer;
JScript
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("FileUploader")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the maximum number of files that can be uploaded in a single uploading process.")
public function get,set FilesCount : System.int
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("FileUploader")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the maximum number of files that can be uploaded in a single uploading process.")]
public: __property System.int get_FilesCount();
public: __property void set_FilesCount(
   System.int value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("FileUploader")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the maximum number of files that can be uploaded in a single uploading process.")]
public:
property System.int FilesCount {
   System.int get();
   void set (    System.int value);
}

Property Value

The default value is -1.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorFileUploaderSettings Class
WebTextEditorFileUploaderSettings Members


FileTypes Property

[image]
Intersoft WebTextEditor Documentation
FileTypes Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorFileUploaderSettings Class : FileTypes Property

Glossary Item Box

Specifies the types of files that can be uploaded.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the types of files that can be uploaded.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("FileUploader")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property FileTypes As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorFileUploaderSettings
Dim value As System.String

instance.FileTypes = value

value = instance.FileTypes
C#
[System.ComponentModel.DescriptionAttribute("Specifies the types of files that can be uploaded.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("FileUploader")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string FileTypes {get; set;}
Delphi
public read-write property FileTypes: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the types of files that can be uploaded.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("FileUploader")
System.ComponentModel.DefaultValueAttribute()
public function get,set FileTypes : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the types of files that can be uploaded.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("FileUploader")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_FileTypes();
public: __property void set_FileTypes(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the types of files that can be uploaded.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("FileUploader")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ FileTypes {
   System.String^ get();
   void set (    System.String^ value);
}

Property Value

The default value is "".

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorFileUploaderSettings Class
WebTextEditorFileUploaderSettings Members


TotalUploadSizeLimit Property

[image]
Intersoft WebTextEditor Documentation
TotalUploadSizeLimit Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorFileUploaderSettings Class : TotalUploadSizeLimit Property

Glossary Item Box

Specifies the maximum size of total uploaded files.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("FileUploader")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the maximum size of total uploaded files.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property TotalUploadSizeLimit As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorFileUploaderSettings
Dim value As System.Integer

instance.TotalUploadSizeLimit = value

value = instance.TotalUploadSizeLimit
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("FileUploader")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the maximum size of total uploaded files.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.int TotalUploadSizeLimit {get; set;}
Delphi
public read-write property TotalUploadSizeLimit: System.Integer;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("FileUploader")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the maximum size of total uploaded files.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set TotalUploadSizeLimit : System.int
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("FileUploader")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the maximum size of total uploaded files.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.int get_TotalUploadSizeLimit();
public: __property void set_TotalUploadSizeLimit(
   System.int value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("FileUploader")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the maximum size of total uploaded files.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.int TotalUploadSizeLimit {
   System.int get();
   void set (    System.int value);
}

Property Value

The default value is -1.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorFileUploaderSettings Class
WebTextEditorFileUploaderSettings Members


UploadSizeLimit Property

[image]
Intersoft WebTextEditor Documentation
UploadSizeLimit Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorFileUploaderSettings Class : UploadSizeLimit Property

Glossary Item Box

Specifies the maximum size of an uploaded file.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the maximum size of an uploaded file.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("FileUploader")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property UploadSizeLimit As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorFileUploaderSettings
Dim value As System.Integer

instance.UploadSizeLimit = value

value = instance.UploadSizeLimit
C#
[System.ComponentModel.DescriptionAttribute("Specifies the maximum size of an uploaded file.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("FileUploader")]
[System.ComponentModel.DefaultValueAttribute()]
public System.int UploadSizeLimit {get; set;}
Delphi
public read-write property UploadSizeLimit: System.Integer;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the maximum size of an uploaded file.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("FileUploader")
System.ComponentModel.DefaultValueAttribute()
public function get,set UploadSizeLimit : System.int
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the maximum size of an uploaded file.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("FileUploader")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.int get_UploadSizeLimit();
public: __property void set_UploadSizeLimit(
   System.int value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the maximum size of an uploaded file.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("FileUploader")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.int UploadSizeLimit {
   System.int get();
   void set (    System.int value);
}

Property Value

The default value is -1.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorFileUploaderSettings Class
WebTextEditorFileUploaderSettings Members


WebTextEditorImagesSettings Class

[image]
Intersoft WebTextEditor Documentation
WebTextEditorImagesSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorImagesSettings Class

Glossary Item Box

A collection of WebTextEditor's images settings.

Object Model

WebTextEditorImagesSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebTextEditorImagesSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebTextEditorImagesSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebTextEditorImagesSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebTextEditorImagesSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebTextEditorImagesSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebTextEditorImagesSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebTextEditor.WebTextEditorImagesSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Members
ISNet.WebUI.WebTextEditor Namespace


WebTextEditorImagesSettings Class Members

[image]
Intersoft WebTextEditor Documentation
WebTextEditorImagesSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorImagesSettings Class

Glossary Item Box

The following tables list the members exposed by WebTextEditorImagesSettings.

Public Constructors

 | Name | Description
Public Constructor | WebTextEditorImagesSettings Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Abort | Specifies the abort image during uploading file process.
Public Property | AlignTextCenter | Specifies the image of Align Text Center command in main toolbar.
Public Property | AlignTextJustify | Specifies the image of Align Text Justify command in main toolbar.
Public Property | AlignTextLeft | Specifies the image of Align Text Left command in main toolbar.
Public Property | AlignTextRight | Specifies the image of Align Text Right command in main toolbar.
Public Property | Apply | Specifies the image of Apply command in Table Designer toolbar.
Public Property | Bold | Specifies the image of Bold command in main toolbar.
Public Property | Bullets | Specifies the image of Bullets command in main toolbar.
Public Property | Button | Specifies the image of Insert Button item.
Public Property | CallOutBottomLeft | Specifies the BottomLeft image of the callout.
Public Property | CallOutBottomLeftPointer | Specifies the bottom left pointer image of the callout.
Public Property | CallOutBottomRight | Specifies the BottomRight image of the callout.
Public Property | CallOutBottomRightPointer | Specifies the bottom right pointer image of the callout.
Public Property | CallOutButtonCenterActive | Specifies the active center button image in the callout.
Public Property | CallOutButtonCenterInactive | Specifies the inactive center button image in the callout.
Public Property | CallOutButtonCenterOver | Specifies the hovered center button image in the callout.
Public Property | CallOutButtonLeftActive | Specifies the active left button image in the callout.
Public Property | CallOutButtonLeftInactive | Specifies the inactive left button image in the callout.
Public Property | CallOutButtonLeftOver | Specifies the hovered left button image in the callout.
Public Property | CallOutButtonRightActive | Specifies the active right button image in the callout.
Public Property | CallOutButtonRightInactive | Specifies the inactive right button image in the callout.
Public Property | CallOutButtonRightOver | Specifies the hovered right button image in the callout.
Public Property | CallOutClose | Specifies the close image in the callout.
Public Property | CallOutCloseHover | Specifies the hovered close image in the callout.
Public Property | CallOutMiddleBottom | Specifies the MiddleBottom image of the callout.
Public Property | CallOutMiddleLeft | Specifies the MiddleLeft image of the callout.
Public Property | CallOutMiddleRight | Specifies the MiddleRight image of the callout.
Public Property | CallOutMiddleTop | Specifies the MiddleTop image of the callout.
Public Property | CallOutTopLeft | Specifies the TopLeft image of the callout.
Public Property | CallOutTopLeftPointer | Specifies the top left pointer image of the callout.
Public Property | CallOutTopRight | Specifies the TopRight image of the callout.
Public Property | CallOutTopRightPointer | Specifies the top right pointer image of the callout.
Public Property | Cancel | Specifies the image of Cancel command in Table Designer toolbar.
Public Property | ChangeCase | Specifies the image of Change Case command in main toolbar.
Public Property | ClearFormatting | Specifies the image of Clear Formatting command in main toolbar.
Public Property | Copy | Specifies the image of Copy command in main toolbar.
Public Property | Cut | Specifies the image of Cut command in main toolbar.
Public Property | DecreaseIndent | Specifies the image of Decrease Indent command in main toolbar.
Public Property | DeleteColumn | Specifies the image of Delete Column item.
Public Property | DeleteRow | Specifies the image of Delete Row item.
Public Property | DropDownImage | Specifies the dropdown image in toolbar.
Public Property | Emoticon | Specifies the image of Emoticon command in main toolbar.
Public Property | Find | Specifies the image of Find command in main toolbar.
Public Property | First | Specifies the image of First command in Preview toolbar.
Public Property | FontColor | Specifies the image of Font Color command in main toolbar.
Public Property | FullScreen | Specifies the image of Full Screen command in main toolbar.
Public Property | HorizontalRule | Specifies the image of Insert Horizontal Rule item.
Public Property | Hyperlink | Specifies the image of Hyperlink command in main toolbar.
Public Property | IFrame | Specifies the image of Insert IFrame item.
Public Property | Import | Specifies the image of Import command in main toolbar.
Public Property | IncreaseIndent | Specifies the image of Increase Indent command in main toolbar.
Public Property | InProgress | Specifies the image that indicates that a flypostback action is in progress.
Public Property | InputButton | Specifies the image of Insert Input Button item.
Public Property | InputCheckBox | Specifies the image of Insert Input Checkbox item.
Public Property | InputFileUpload | Specifies the image of Insert Input Upload item.
Public Property | InputHidden | Specifies the image of Insert Input Hidden item.
Public Property | InputPassword | Specifies the image of Insert Input Password item.
Public Property | InputRadio | Specifies the image of Insert Input Radio item.
Public Property | InputReset | Specifies the image of Insert Input Reset item.
Public Property | InputSubmit | Specifies the image of Insert Input Submit item.
Public Property | InputText | Specifies the image of Insert Input Text item.
Public Property | InsertFormControl | Specifies the image of Insert Form Control command in main toolbar.
Public Property | InsertFromWeb | Specifies the image of Insert From Web command in Media Gallery toolbar.
Public Property | InsertLeftColumns | Specifies the image of Insert Columns to Left item.
Public Property | InsertRightColumns | Specifies the image of Insert Columns to Right item.
Public Property | InsertRowsAbove | Specifies the image of Insert Rows Above item.
Public Property | InsertRowsBelow | Specifies the image of Insert Rows Below item.
Public Property | InsertSymbol | Specifies the image of Insert Symbol command in main toolbar.
Public Property | InsertTable | Specifies the image of Insert Table command in Table Designer toolbar.
Public Property | Italic | Specifies the image of Italic command in main toolbar.
Public Property | Last | Specifies the image of Last command in Preview toolbar.
Public Property | LowerCase | Specifies the image of Lower Case item in Change Case dropdown menu.
Public Property | Marquee | Specifies the image of Insert Marquee item.
Public Property | MediaAVI | Specifies the image that indicates AVI media type.
Public Property | MediaDeleteAction | Specifies the delete image in media action container
Public Property | MediaEditAction | Specifies the edit image in media action container.
Public Property | MediaGallery | Specifies the image of Media Gallery command in main toolbar.
Public Property | MediaMOV | Specifies the image that indicates MOV media type.
Public Property | MediaMP3 | Specifies the image that indicates MP3 media type.
Public Property | MediaMPG | Specifies the image that indicates MPG media type.
Public Property | MediaSWF | Specifies the image that indicates SWF media type.
Public Property | MediaWAV | Specifies the image that indicates WAV media type.
Public Property | MediaWMA | Specifies the image that indicates WMA media type.
Public Property | MediaWMV | SSpecifies the image that indicates WMV media type.
Public Property | MediaYouTube | Specifies the image that indicates YouTube media type.
Public Property | MenuFormatting | Specifies the Formatting menu item in header context menu.
Public Property | MenuStandard | Specifies the Standard menu item in header context menu.
Public Property | MergeCellDown | Specifies the image of Merge Cell Down item.
Public Property | MergeCellRight | Specifies the image of Merge Cell Right item.
Public Property | MergeCells | Specifies the image of Merge Cells item.
Public Property | MoreImage | Specifies the image that indicates more menu in toolbar.
Public Property | Next | Specifies the image of Next command in Preview toolbar.
Public Property | Numbering | Specifies the image of Numbering command in main toolbar.
Public Property | Paste | Specifies the image of Paste command in main toolbar.
Public Property | Preview | Specifies the image of Preview command in main toolbar.
Public Property | Previous | Specifies the image of Previous command in Preview toolbar.
Public Property | Print | Specifies the image of Print command in main toolbar.
Public Property | Quote | Specifies the image of Quote command in main toolbar.
Public Property | Redo | Specifies the image of Redo command in main toolbar.
Public Property | RemoveLink | Specifies the image of Remove Link command in main toolbar.
Public Property | Replace | Specifies the image of Replace command in main toolbar.
Public Property | Save | Specifies the image of Save command in main toolbar.
Public Property | SectionCollapse | Specifies the image used to indicate collapse state in section image header.
Public Property | SectionExpand | Specifies the image used to indicate expand state in section image header.
Public Property | SelectDropdown | Specifies the image of Insert Select Dropdown item.
Public Property | SelectListbox | Specifies the image of Insert Select Listbox item.
Public Property | SendMail | Specifies the image of Send Mail command in Preview toolbar.
Public Property | SpellChecker | Specifies the image of Spell Checker command in main toolbar and footer row.
Public Property | SplitCellHorizontal | Specifies the image of Split Cell Horizontal item.
Public Property | SplitCells | Specifies the image of Split Cells item.
Public Property | SplitCellVertical | Specifies the image of Split Cell Vertical item.
Public Property | Strikethrough | Specifies the image of Strikethrough command in main toolbar.
Public Property | Subscript | Specifies the image of Subscript command in main toolbar.
Public Property | Superscript | Specifies the image of Superscript command in main toolbar.
Public Property | TextArea | Specifies the image of Insert TextArea item.
Public Property | TextHighlightColor | Specifies the image of Text Highlight Color command in main toolbar.
Public Property | Underline | Specifies the image of Underline command in main toolbar.
Public Property | Undo | Specifies the image of Undo command in main toolbar.
Public Property | Upload | Specifies the image of Upload command in Media Gallery toolbar.
Public Property | UpperCase | Specifies the image of Upper Case item in Change Case dropdown menu.
Public Property | ZoomIn | Specifies the image of Zoom In command in Preview toolbar.
Public Property | ZoomOut | Specifies the image of Zoom Out command in Preview toolbar.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

Protected Methods

 | Name | Description
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | IsInSerializationContext | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebTextEditorImagesSettings Class
ISNet.WebUI.WebTextEditor Namespace


WebTextEditorImagesSettings Constructor

[image]
Intersoft WebTextEditor Documentation
WebTextEditorImagesSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : WebTextEditorImagesSettings Constructor

Glossary Item Box

Overload List

Overload | Description
WebTextEditorImagesSettings Constructor() |
WebTextEditorImagesSettings Constructor(SerializationInfo,StreamingContext) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


WebTextEditorImagesSettings Constructor()

[image]
Intersoft WebTextEditor Documentation
WebTextEditorImagesSettings Constructor()
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class > WebTextEditorImagesSettings Constructor : WebTextEditorImagesSettings Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebTextEditorImagesSettings()
C#
public WebTextEditorImagesSettings()
Delphi
public WebTextEditorImagesSettings();
JScript
public function WebTextEditorImagesSettings();
Managed Extensions for C++
public: WebTextEditorImagesSettings();
C++/CLI
public:
WebTextEditorImagesSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members
Overload List


WebTextEditorImagesSettings Constructor(SerializationInfo,StreamingContext)

[image]
Intersoft WebTextEditor Documentation
WebTextEditorImagesSettings Constructor(SerializationInfo,StreamingContext)
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class > WebTextEditorImagesSettings Constructor : WebTextEditorImagesSettings Constructor(SerializationInfo,StreamingContext)

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

Dim instance As New WebTextEditorImagesSettings(info, context)
C#
protected WebTextEditorImagesSettings(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
protected WebTextEditorImagesSettings(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
protected function WebTextEditorImagesSettings(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
protected: WebTextEditorImagesSettings(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
protected:
WebTextEditorImagesSettings(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members
Overload List


WebTextEditorImagesSettings Class Methods

[image]
Intersoft WebTextEditor Documentation
WebTextEditorImagesSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorImagesSettings Class

Glossary Item Box

For a list of all members of this type, see WebTextEditorImagesSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

Protected Methods

 | Name | Description
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | IsInSerializationContext | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebTextEditorImagesSettings Class
ISNet.WebUI.WebTextEditor Namespace


GetObjectData Method

[image]
Intersoft WebTextEditor Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


WebTextEditorImagesSettings Class Properties

[image]
Intersoft WebTextEditor Documentation
WebTextEditorImagesSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorImagesSettings Class

Glossary Item Box

For a list of all members of this type, see WebTextEditorImagesSettings members.

Public Properties

 | Name | Description
Public Property | Abort | Specifies the abort image during uploading file process.
Public Property | AlignTextCenter | Specifies the image of Align Text Center command in main toolbar.
Public Property | AlignTextJustify | Specifies the image of Align Text Justify command in main toolbar.
Public Property | AlignTextLeft | Specifies the image of Align Text Left command in main toolbar.
Public Property | AlignTextRight | Specifies the image of Align Text Right command in main toolbar.
Public Property | Apply | Specifies the image of Apply command in Table Designer toolbar.
Public Property | Bold | Specifies the image of Bold command in main toolbar.
Public Property | Bullets | Specifies the image of Bullets command in main toolbar.
Public Property | Button | Specifies the image of Insert Button item.
Public Property | CallOutBottomLeft | Specifies the BottomLeft image of the callout.
Public Property | CallOutBottomLeftPointer | Specifies the bottom left pointer image of the callout.
Public Property | CallOutBottomRight | Specifies the BottomRight image of the callout.
Public Property | CallOutBottomRightPointer | Specifies the bottom right pointer image of the callout.
Public Property | CallOutButtonCenterActive | Specifies the active center button image in the callout.
Public Property | CallOutButtonCenterInactive | Specifies the inactive center button image in the callout.
Public Property | CallOutButtonCenterOver | Specifies the hovered center button image in the callout.
Public Property | CallOutButtonLeftActive | Specifies the active left button image in the callout.
Public Property | CallOutButtonLeftInactive | Specifies the inactive left button image in the callout.
Public Property | CallOutButtonLeftOver | Specifies the hovered left button image in the callout.
Public Property | CallOutButtonRightActive | Specifies the active right button image in the callout.
Public Property | CallOutButtonRightInactive | Specifies the inactive right button image in the callout.
Public Property | CallOutButtonRightOver | Specifies the hovered right button image in the callout.
Public Property | CallOutClose | Specifies the close image in the callout.
Public Property | CallOutCloseHover | Specifies the hovered close image in the callout.
Public Property | CallOutMiddleBottom | Specifies the MiddleBottom image of the callout.
Public Property | CallOutMiddleLeft | Specifies the MiddleLeft image of the callout.
Public Property | CallOutMiddleRight | Specifies the MiddleRight image of the callout.
Public Property | CallOutMiddleTop | Specifies the MiddleTop image of the callout.
Public Property | CallOutTopLeft | Specifies the TopLeft image of the callout.
Public Property | CallOutTopLeftPointer | Specifies the top left pointer image of the callout.
Public Property | CallOutTopRight | Specifies the TopRight image of the callout.
Public Property | CallOutTopRightPointer | Specifies the top right pointer image of the callout.
Public Property | Cancel | Specifies the image of Cancel command in Table Designer toolbar.
Public Property | ChangeCase | Specifies the image of Change Case command in main toolbar.
Public Property | ClearFormatting | Specifies the image of Clear Formatting command in main toolbar.
Public Property | Copy | Specifies the image of Copy command in main toolbar.
Public Property | Cut | Specifies the image of Cut command in main toolbar.
Public Property | DecreaseIndent | Specifies the image of Decrease Indent command in main toolbar.
Public Property | DeleteColumn | Specifies the image of Delete Column item.
Public Property | DeleteRow | Specifies the image of Delete Row item.
Public Property | DropDownImage | Specifies the dropdown image in toolbar.
Public Property | Emoticon | Specifies the image of Emoticon command in main toolbar.
Public Property | Find | Specifies the image of Find command in main toolbar.
Public Property | First | Specifies the image of First command in Preview toolbar.
Public Property | FontColor | Specifies the image of Font Color command in main toolbar.
Public Property | FullScreen | Specifies the image of Full Screen command in main toolbar.
Public Property | HorizontalRule | Specifies the image of Insert Horizontal Rule item.
Public Property | Hyperlink | Specifies the image of Hyperlink command in main toolbar.
Public Property | IFrame | Specifies the image of Insert IFrame item.
Public Property | Import | Specifies the image of Import command in main toolbar.
Public Property | IncreaseIndent | Specifies the image of Increase Indent command in main toolbar.
Public Property | InProgress | Specifies the image that indicates that a flypostback action is in progress.
Public Property | InputButton | Specifies the image of Insert Input Button item.
Public Property | InputCheckBox | Specifies the image of Insert Input Checkbox item.
Public Property | InputFileUpload | Specifies the image of Insert Input Upload item.
Public Property | InputHidden | Specifies the image of Insert Input Hidden item.
Public Property | InputPassword | Specifies the image of Insert Input Password item.
Public Property | InputRadio | Specifies the image of Insert Input Radio item.
Public Property | InputReset | Specifies the image of Insert Input Reset item.
Public Property | InputSubmit | Specifies the image of Insert Input Submit item.
Public Property | InputText | Specifies the image of Insert Input Text item.
Public Property | InsertFormControl | Specifies the image of Insert Form Control command in main toolbar.
Public Property | InsertFromWeb | Specifies the image of Insert From Web command in Media Gallery toolbar.
Public Property | InsertLeftColumns | Specifies the image of Insert Columns to Left item.
Public Property | InsertRightColumns | Specifies the image of Insert Columns to Right item.
Public Property | InsertRowsAbove | Specifies the image of Insert Rows Above item.
Public Property | InsertRowsBelow | Specifies the image of Insert Rows Below item.
Public Property | InsertSymbol | Specifies the image of Insert Symbol command in main toolbar.
Public Property | InsertTable | Specifies the image of Insert Table command in Table Designer toolbar.
Public Property | Italic | Specifies the image of Italic command in main toolbar.
Public Property | Last | Specifies the image of Last command in Preview toolbar.
Public Property | LowerCase | Specifies the image of Lower Case item in Change Case dropdown menu.
Public Property | Marquee | Specifies the image of Insert Marquee item.
Public Property | MediaAVI | Specifies the image that indicates AVI media type.
Public Property | MediaDeleteAction | Specifies the delete image in media action container
Public Property | MediaEditAction | Specifies the edit image in media action container.
Public Property | MediaGallery | Specifies the image of Media Gallery command in main toolbar.
Public Property | MediaMOV | Specifies the image that indicates MOV media type.
Public Property | MediaMP3 | Specifies the image that indicates MP3 media type.
Public Property | MediaMPG | Specifies the image that indicates MPG media type.
Public Property | MediaSWF | Specifies the image that indicates SWF media type.
Public Property | MediaWAV | Specifies the image that indicates WAV media type.
Public Property | MediaWMA | Specifies the image that indicates WMA media type.
Public Property | MediaWMV | SSpecifies the image that indicates WMV media type.
Public Property | MediaYouTube | Specifies the image that indicates YouTube media type.
Public Property | MenuFormatting | Specifies the Formatting menu item in header context menu.
Public Property | MenuStandard | Specifies the Standard menu item in header context menu.
Public Property | MergeCellDown | Specifies the image of Merge Cell Down item.
Public Property | MergeCellRight | Specifies the image of Merge Cell Right item.
Public Property | MergeCells | Specifies the image of Merge Cells item.
Public Property | MoreImage | Specifies the image that indicates more menu in toolbar.
Public Property | Next | Specifies the image of Next command in Preview toolbar.
Public Property | Numbering | Specifies the image of Numbering command in main toolbar.
Public Property | Paste | Specifies the image of Paste command in main toolbar.
Public Property | Preview | Specifies the image of Preview command in main toolbar.
Public Property | Previous | Specifies the image of Previous command in Preview toolbar.
Public Property | Print | Specifies the image of Print command in main toolbar.
Public Property | Quote | Specifies the image of Quote command in main toolbar.
Public Property | Redo | Specifies the image of Redo command in main toolbar.
Public Property | RemoveLink | Specifies the image of Remove Link command in main toolbar.
Public Property | Replace | Specifies the image of Replace command in main toolbar.
Public Property | Save | Specifies the image of Save command in main toolbar.
Public Property | SectionCollapse | Specifies the image used to indicate collapse state in section image header.
Public Property | SectionExpand | Specifies the image used to indicate expand state in section image header.
Public Property | SelectDropdown | Specifies the image of Insert Select Dropdown item.
Public Property | SelectListbox | Specifies the image of Insert Select Listbox item.
Public Property | SendMail | Specifies the image of Send Mail command in Preview toolbar.
Public Property | SpellChecker | Specifies the image of Spell Checker command in main toolbar and footer row.
Public Property | SplitCellHorizontal | Specifies the image of Split Cell Horizontal item.
Public Property | SplitCells | Specifies the image of Split Cells item.
Public Property | SplitCellVertical | Specifies the image of Split Cell Vertical item.
Public Property | Strikethrough | Specifies the image of Strikethrough command in main toolbar.
Public Property | Subscript | Specifies the image of Subscript command in main toolbar.
Public Property | Superscript | Specifies the image of Superscript command in main toolbar.
Public Property | TextArea | Specifies the image of Insert TextArea item.
Public Property | TextHighlightColor | Specifies the image of Text Highlight Color command in main toolbar.
Public Property | Underline | Specifies the image of Underline command in main toolbar.
Public Property | Undo | Specifies the image of Undo command in main toolbar.
Public Property | Upload | Specifies the image of Upload command in Media Gallery toolbar.
Public Property | UpperCase | Specifies the image of Upper Case item in Change Case dropdown menu.
Public Property | ZoomIn | Specifies the image of Zoom In command in Preview toolbar.
Public Property | ZoomOut | Specifies the image of Zoom Out command in Preview toolbar.
Top

See Also

Reference

WebTextEditorImagesSettings Class
ISNet.WebUI.WebTextEditor Namespace


Abort Property

[image]
Intersoft WebTextEditor Documentation
Abort Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : Abort Property

Glossary Item Box

Specifies the abort image during uploading file process.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the abort image during uploading file process.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Abort As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.Abort = value

value = instance.Abort
C#
[System.ComponentModel.DescriptionAttribute("Specifies the abort image during uploading file process.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string Abort {get; set;}
Delphi
public read-write property Abort: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the abort image during uploading file process.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.DefaultValueAttribute()
public function get,set Abort : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the abort image during uploading file process.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_Abort();
public: __property void set_Abort(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the abort image during uploading file process.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ Abort {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


AlignTextCenter Property

[image]
Intersoft WebTextEditor Documentation
AlignTextCenter Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : AlignTextCenter Property

Glossary Item Box

Specifies the image of Align Text Center command in main toolbar.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the image of Align Text Center command in main toolbar.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property AlignTextCenter As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.AlignTextCenter = value

value = instance.AlignTextCenter
C#
[System.ComponentModel.DescriptionAttribute("Specifies the image of Align Text Center command in main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string AlignTextCenter {get; set;}
Delphi
public read-write property AlignTextCenter: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the image of Align Text Center command in main toolbar.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.DefaultValueAttribute()
public function get,set AlignTextCenter : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the image of Align Text Center command in main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_AlignTextCenter();
public: __property void set_AlignTextCenter(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the image of Align Text Center command in main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ AlignTextCenter {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


AlignTextJustify Property

[image]
Intersoft WebTextEditor Documentation
AlignTextJustify Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : AlignTextJustify Property

Glossary Item Box

Specifies the image of Align Text Justify command in main toolbar.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the image of Align Text Justify command in main toolbar.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property AlignTextJustify As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.AlignTextJustify = value

value = instance.AlignTextJustify
C#
[System.ComponentModel.DescriptionAttribute("Specifies the image of Align Text Justify command in main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string AlignTextJustify {get; set;}
Delphi
public read-write property AlignTextJustify: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the image of Align Text Justify command in main toolbar.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.DefaultValueAttribute()
public function get,set AlignTextJustify : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the image of Align Text Justify command in main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_AlignTextJustify();
public: __property void set_AlignTextJustify(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the image of Align Text Justify command in main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ AlignTextJustify {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


AlignTextLeft Property

[image]
Intersoft WebTextEditor Documentation
AlignTextLeft Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : AlignTextLeft Property

Glossary Item Box

Specifies the image of Align Text Left command in main toolbar.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the image of Align Text Left command in main toolbar.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property AlignTextLeft As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.AlignTextLeft = value

value = instance.AlignTextLeft
C#
[System.ComponentModel.DescriptionAttribute("Specifies the image of Align Text Left command in main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string AlignTextLeft {get; set;}
Delphi
public read-write property AlignTextLeft: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the image of Align Text Left command in main toolbar.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.DefaultValueAttribute()
public function get,set AlignTextLeft : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the image of Align Text Left command in main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_AlignTextLeft();
public: __property void set_AlignTextLeft(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the image of Align Text Left command in main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ AlignTextLeft {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


AlignTextRight Property

[image]
Intersoft WebTextEditor Documentation
AlignTextRight Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : AlignTextRight Property

Glossary Item Box

Specifies the image of Align Text Right command in main toolbar.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Image Settings")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the image of Align Text Right command in main toolbar.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property AlignTextRight As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.AlignTextRight = value

value = instance.AlignTextRight
C#
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Align Text Right command in main toolbar.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string AlignTextRight {get; set;}
Delphi
public read-write property AlignTextRight: System.String;
JScript
System.ComponentModel.CategoryAttribute("Image Settings")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the image of Align Text Right command in main toolbar.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set AlignTextRight : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Align Text Right command in main toolbar.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_AlignTextRight();
public: __property void set_AlignTextRight(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Align Text Right command in main toolbar.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ AlignTextRight {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


Apply Property

[image]
Intersoft WebTextEditor Documentation
Apply Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : Apply Property

Glossary Item Box

Specifies the image of Apply command in Table Designer toolbar.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the image of Apply command in Table Designer toolbar.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Apply As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.Apply = value

value = instance.Apply
C#
[System.ComponentModel.DescriptionAttribute("Specifies the image of Apply command in Table Designer toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string Apply {get; set;}
Delphi
public read-write property Apply: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the image of Apply command in Table Designer toolbar.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.DefaultValueAttribute()
public function get,set Apply : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the image of Apply command in Table Designer toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_Apply();
public: __property void set_Apply(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the image of Apply command in Table Designer toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ Apply {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


Bold Property

[image]
Intersoft WebTextEditor Documentation
Bold Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : Bold Property

Glossary Item Box

Specifies the image of Bold command in main toolbar.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the image of Bold command in main toolbar.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Bold As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.Bold = value

value = instance.Bold
C#
[System.ComponentModel.DescriptionAttribute("Specifies the image of Bold command in main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.string Bold {get; set;}
Delphi
public read-write property Bold: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the image of Bold command in main toolbar.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set Bold : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the image of Bold command in main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_Bold();
public: __property void set_Bold(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the image of Bold command in main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ Bold {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


Bullets Property

[image]
Intersoft WebTextEditor Documentation
Bullets Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : Bullets Property

Glossary Item Box

Specifies the image of Bullets command in main toolbar.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.DescriptionAttribute("Specifies the image of Bullets command in main toolbar.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property Bullets As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.Bullets = value

value = instance.Bullets
C#
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Bullets command in main toolbar.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string Bullets {get; set;}
Delphi
public read-write property Bullets: System.String;
JScript
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.DescriptionAttribute("Specifies the image of Bullets command in main toolbar.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set Bullets : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Bullets command in main toolbar.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_Bullets();
public: __property void set_Bullets(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Bullets command in main toolbar.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ Bullets {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


Button Property

[image]
Intersoft WebTextEditor Documentation
Button Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : Button Property

Glossary Item Box

Specifies the image of Insert Button item.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Button item.")>
Public Property Button As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.Button = value

value = instance.Button
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Button item.")]
public System.string Button {get; set;}
Delphi
public read-write property Button: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Button item.")
public function get,set Button : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Button item.")]
public: __property System.string* get_Button();
public: __property void set_Button(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Button item.")]
public:
property System.String^ Button {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


CallOutBottomLeft Property

[image]
Intersoft WebTextEditor Documentation
CallOutBottomLeft Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : CallOutBottomLeft Property

Glossary Item Box

Specifies the BottomLeft image of the callout.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.DescriptionAttribute("Specifies the BottomLeft image of the callout.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property CallOutBottomLeft As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.CallOutBottomLeft = value

value = instance.CallOutBottomLeft
C#
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the BottomLeft image of the callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string CallOutBottomLeft {get; set;}
Delphi
public read-write property CallOutBottomLeft: System.String;
JScript
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.DescriptionAttribute("Specifies the BottomLeft image of the callout.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set CallOutBottomLeft : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the BottomLeft image of the callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_CallOutBottomLeft();
public: __property void set_CallOutBottomLeft(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the BottomLeft image of the callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ CallOutBottomLeft {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


CallOutBottomLeftPointer Property

[image]
Intersoft WebTextEditor Documentation
CallOutBottomLeftPointer Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : CallOutBottomLeftPointer Property

Glossary Item Box

Specifies the bottom left pointer image of the callout.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the bottom left pointer image of the callout.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property CallOutBottomLeftPointer As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.CallOutBottomLeftPointer = value

value = instance.CallOutBottomLeftPointer
C#
[System.ComponentModel.DescriptionAttribute("Specifies the bottom left pointer image of the callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string CallOutBottomLeftPointer {get; set;}
Delphi
public read-write property CallOutBottomLeftPointer: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the bottom left pointer image of the callout.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.DefaultValueAttribute()
public function get,set CallOutBottomLeftPointer : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the bottom left pointer image of the callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_CallOutBottomLeftPointer();
public: __property void set_CallOutBottomLeftPointer(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the bottom left pointer image of the callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ CallOutBottomLeftPointer {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


CallOutBottomRight Property

[image]
Intersoft WebTextEditor Documentation
CallOutBottomRight Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : CallOutBottomRight Property

Glossary Item Box

Specifies the BottomRight image of the callout.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the BottomRight image of the callout.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property CallOutBottomRight As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.CallOutBottomRight = value

value = instance.CallOutBottomRight
C#
[System.ComponentModel.DescriptionAttribute("Specifies the BottomRight image of the callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string CallOutBottomRight {get; set;}
Delphi
public read-write property CallOutBottomRight: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the BottomRight image of the callout.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set CallOutBottomRight : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the BottomRight image of the callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_CallOutBottomRight();
public: __property void set_CallOutBottomRight(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the BottomRight image of the callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ CallOutBottomRight {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


CallOutBottomRightPointer Property

[image]
Intersoft WebTextEditor Documentation
CallOutBottomRightPointer Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : CallOutBottomRightPointer Property

Glossary Item Box

Specifies the bottom right pointer image of the callout.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.DescriptionAttribute("Specifies the bottom right pointer image of the callout.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property CallOutBottomRightPointer As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.CallOutBottomRightPointer = value

value = instance.CallOutBottomRightPointer
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the bottom right pointer image of the callout.")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string CallOutBottomRightPointer {get; set;}
Delphi
public read-write property CallOutBottomRightPointer: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.DescriptionAttribute("Specifies the bottom right pointer image of the callout.")
System.ComponentModel.DefaultValueAttribute()
public function get,set CallOutBottomRightPointer : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the bottom right pointer image of the callout.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_CallOutBottomRightPointer();
public: __property void set_CallOutBottomRightPointer(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the bottom right pointer image of the callout.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ CallOutBottomRightPointer {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


CallOutButtonCenterActive Property

[image]
Intersoft WebTextEditor Documentation
CallOutButtonCenterActive Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : CallOutButtonCenterActive Property

Glossary Item Box

Specifies the active center button image in the callout.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the active center button image in the callout.")>
<System.ComponentModel.CategoryAttribute("Image Settings")>
Public Property CallOutButtonCenterActive As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.CallOutButtonCenterActive = value

value = instance.CallOutButtonCenterActive
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the active center button image in the callout.")]
[System.ComponentModel.CategoryAttribute("Image Settings")]
public System.string CallOutButtonCenterActive {get; set;}
Delphi
public read-write property CallOutButtonCenterActive: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the active center button image in the callout.")
System.ComponentModel.CategoryAttribute("Image Settings")
public function get,set CallOutButtonCenterActive : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the active center button image in the callout.")]
[System.ComponentModel.CategoryAttribute("Image Settings")]
public: __property System.string* get_CallOutButtonCenterActive();
public: __property void set_CallOutButtonCenterActive(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the active center button image in the callout.")]
[System.ComponentModel.CategoryAttribute("Image Settings")]
public:
property System.String^ CallOutButtonCenterActive {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


CallOutButtonCenterInactive Property

[image]
Intersoft WebTextEditor Documentation
CallOutButtonCenterInactive Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : CallOutButtonCenterInactive Property

Glossary Item Box

Specifies the inactive center button image in the callout.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the inactive center button image in the callout.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property CallOutButtonCenterInactive As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.CallOutButtonCenterInactive = value

value = instance.CallOutButtonCenterInactive
C#
[System.ComponentModel.DescriptionAttribute("Specifies the inactive center button image in the callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string CallOutButtonCenterInactive {get; set;}
Delphi
public read-write property CallOutButtonCenterInactive: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the inactive center button image in the callout.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.DefaultValueAttribute()
public function get,set CallOutButtonCenterInactive : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the inactive center button image in the callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_CallOutButtonCenterInactive();
public: __property void set_CallOutButtonCenterInactive(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the inactive center button image in the callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ CallOutButtonCenterInactive {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


CallOutButtonCenterOver Property

[image]
Intersoft WebTextEditor Documentation
CallOutButtonCenterOver Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : CallOutButtonCenterOver Property

Glossary Item Box

Specifies the hovered center button image in the callout.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the hovered center button image in the callout.")>
<System.ComponentModel.CategoryAttribute("Image Settings")>
Public Property CallOutButtonCenterOver As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.CallOutButtonCenterOver = value

value = instance.CallOutButtonCenterOver
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the hovered center button image in the callout.")]
[System.ComponentModel.CategoryAttribute("Image Settings")]
public System.string CallOutButtonCenterOver {get; set;}
Delphi
public read-write property CallOutButtonCenterOver: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the hovered center button image in the callout.")
System.ComponentModel.CategoryAttribute("Image Settings")
public function get,set CallOutButtonCenterOver : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the hovered center button image in the callout.")]
[System.ComponentModel.CategoryAttribute("Image Settings")]
public: __property System.string* get_CallOutButtonCenterOver();
public: __property void set_CallOutButtonCenterOver(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the hovered center button image in the callout.")]
[System.ComponentModel.CategoryAttribute("Image Settings")]
public:
property System.String^ CallOutButtonCenterOver {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


CallOutButtonLeftActive Property

[image]
Intersoft WebTextEditor Documentation
CallOutButtonLeftActive Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : CallOutButtonLeftActive Property

Glossary Item Box

Specifies the active left button image in the callout.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the active left button image in the callout.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property CallOutButtonLeftActive As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.CallOutButtonLeftActive = value

value = instance.CallOutButtonLeftActive
C#
[System.ComponentModel.DescriptionAttribute("Specifies the active left button image in the callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.string CallOutButtonLeftActive {get; set;}
Delphi
public read-write property CallOutButtonLeftActive: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the active left button image in the callout.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set CallOutButtonLeftActive : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the active left button image in the callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_CallOutButtonLeftActive();
public: __property void set_CallOutButtonLeftActive(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the active left button image in the callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ CallOutButtonLeftActive {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


CallOutButtonLeftInactive Property

[image]
Intersoft WebTextEditor Documentation
CallOutButtonLeftInactive Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : CallOutButtonLeftInactive Property

Glossary Item Box

Specifies the inactive left button image in the callout.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the inactive left button image in the callout.")>
<System.ComponentModel.CategoryAttribute("Image Settings")>
Public Property CallOutButtonLeftInactive As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.CallOutButtonLeftInactive = value

value = instance.CallOutButtonLeftInactive
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the inactive left button image in the callout.")]
[System.ComponentModel.CategoryAttribute("Image Settings")]
public System.string CallOutButtonLeftInactive {get; set;}
Delphi
public read-write property CallOutButtonLeftInactive: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the inactive left button image in the callout.")
System.ComponentModel.CategoryAttribute("Image Settings")
public function get,set CallOutButtonLeftInactive : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the inactive left button image in the callout.")]
[System.ComponentModel.CategoryAttribute("Image Settings")]
public: __property System.string* get_CallOutButtonLeftInactive();
public: __property void set_CallOutButtonLeftInactive(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the inactive left button image in the callout.")]
[System.ComponentModel.CategoryAttribute("Image Settings")]
public:
property System.String^ CallOutButtonLeftInactive {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


CallOutButtonLeftOver Property

[image]
Intersoft WebTextEditor Documentation
CallOutButtonLeftOver Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : CallOutButtonLeftOver Property

Glossary Item Box

Specifies the hovered left button image in the callout.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the hovered left button image in the callout.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property CallOutButtonLeftOver As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.CallOutButtonLeftOver = value

value = instance.CallOutButtonLeftOver
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the hovered left button image in the callout.")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string CallOutButtonLeftOver {get; set;}
Delphi
public read-write property CallOutButtonLeftOver: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the hovered left button image in the callout.")
System.ComponentModel.DefaultValueAttribute()
public function get,set CallOutButtonLeftOver : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the hovered left button image in the callout.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_CallOutButtonLeftOver();
public: __property void set_CallOutButtonLeftOver(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the hovered left button image in the callout.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ CallOutButtonLeftOver {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


CallOutButtonRightActive Property

[image]
Intersoft WebTextEditor Documentation
CallOutButtonRightActive Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : CallOutButtonRightActive Property

Glossary Item Box

Specifies the active right button image in the callout.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.DescriptionAttribute("Specifies the active right button image in the callout.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property CallOutButtonRightActive As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.CallOutButtonRightActive = value

value = instance.CallOutButtonRightActive
C#
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the active right button image in the callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string CallOutButtonRightActive {get; set;}
Delphi
public read-write property CallOutButtonRightActive: System.String;
JScript
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.DescriptionAttribute("Specifies the active right button image in the callout.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set CallOutButtonRightActive : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the active right button image in the callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_CallOutButtonRightActive();
public: __property void set_CallOutButtonRightActive(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the active right button image in the callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ CallOutButtonRightActive {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


CallOutButtonRightInactive Property

[image]
Intersoft WebTextEditor Documentation
CallOutButtonRightInactive Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : CallOutButtonRightInactive Property

Glossary Item Box

Specifies the inactive right button image in the callout.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the inactive right button image in the callout.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property CallOutButtonRightInactive As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.CallOutButtonRightInactive = value

value = instance.CallOutButtonRightInactive
C#
[System.ComponentModel.DescriptionAttribute("Specifies the inactive right button image in the callout.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string CallOutButtonRightInactive {get; set;}
Delphi
public read-write property CallOutButtonRightInactive: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the inactive right button image in the callout.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.DefaultValueAttribute()
public function get,set CallOutButtonRightInactive : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the inactive right button image in the callout.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_CallOutButtonRightInactive();
public: __property void set_CallOutButtonRightInactive(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the inactive right button image in the callout.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ CallOutButtonRightInactive {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


CallOutButtonRightOver Property

[image]
Intersoft WebTextEditor Documentation
CallOutButtonRightOver Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : CallOutButtonRightOver Property

Glossary Item Box

Specifies the hovered right button image in the callout.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the hovered right button image in the callout.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property CallOutButtonRightOver As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.CallOutButtonRightOver = value

value = instance.CallOutButtonRightOver
C#
[System.ComponentModel.DescriptionAttribute("Specifies the hovered right button image in the callout.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string CallOutButtonRightOver {get; set;}
Delphi
public read-write property CallOutButtonRightOver: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the hovered right button image in the callout.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set CallOutButtonRightOver : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the hovered right button image in the callout.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_CallOutButtonRightOver();
public: __property void set_CallOutButtonRightOver(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the hovered right button image in the callout.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ CallOutButtonRightOver {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


CallOutClose Property

[image]
Intersoft WebTextEditor Documentation
CallOutClose Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : CallOutClose Property

Glossary Item Box

Specifies the close image in the callout.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the close image in the callout.")>
<System.ComponentModel.CategoryAttribute("Image Settings")>
Public Property CallOutClose As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.CallOutClose = value

value = instance.CallOutClose
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the close image in the callout.")]
[System.ComponentModel.CategoryAttribute("Image Settings")]
public System.string CallOutClose {get; set;}
Delphi
public read-write property CallOutClose: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the close image in the callout.")
System.ComponentModel.CategoryAttribute("Image Settings")
public function get,set CallOutClose : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the close image in the callout.")]
[System.ComponentModel.CategoryAttribute("Image Settings")]
public: __property System.string* get_CallOutClose();
public: __property void set_CallOutClose(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the close image in the callout.")]
[System.ComponentModel.CategoryAttribute("Image Settings")]
public:
property System.String^ CallOutClose {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


CallOutCloseHover Property

[image]
Intersoft WebTextEditor Documentation
CallOutCloseHover Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : CallOutCloseHover Property

Glossary Item Box

Specifies the hovered close image in the callout.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.DescriptionAttribute("Specifies the hovered close image in the callout.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property CallOutCloseHover As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.CallOutCloseHover = value

value = instance.CallOutCloseHover
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the hovered close image in the callout.")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string CallOutCloseHover {get; set;}
Delphi
public read-write property CallOutCloseHover: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.DescriptionAttribute("Specifies the hovered close image in the callout.")
System.ComponentModel.DefaultValueAttribute()
public function get,set CallOutCloseHover : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the hovered close image in the callout.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_CallOutCloseHover();
public: __property void set_CallOutCloseHover(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the hovered close image in the callout.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ CallOutCloseHover {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


CallOutMiddleBottom Property

[image]
Intersoft WebTextEditor Documentation
CallOutMiddleBottom Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : CallOutMiddleBottom Property

Glossary Item Box

Specifies the MiddleBottom image of the callout.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the MiddleBottom image of the callout.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property CallOutMiddleBottom As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.CallOutMiddleBottom = value

value = instance.CallOutMiddleBottom
C#
[System.ComponentModel.DescriptionAttribute("Specifies the MiddleBottom image of the callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.string CallOutMiddleBottom {get; set;}
Delphi
public read-write property CallOutMiddleBottom: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the MiddleBottom image of the callout.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set CallOutMiddleBottom : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the MiddleBottom image of the callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_CallOutMiddleBottom();
public: __property void set_CallOutMiddleBottom(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the MiddleBottom image of the callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ CallOutMiddleBottom {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


CallOutMiddleLeft Property

[image]
Intersoft WebTextEditor Documentation
CallOutMiddleLeft Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : CallOutMiddleLeft Property

Glossary Item Box

Specifies the MiddleLeft image of the callout.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the MiddleLeft image of the callout.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property CallOutMiddleLeft As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.CallOutMiddleLeft = value

value = instance.CallOutMiddleLeft
C#
[System.ComponentModel.DescriptionAttribute("Specifies the MiddleLeft image of the callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string CallOutMiddleLeft {get; set;}
Delphi
public read-write property CallOutMiddleLeft: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the MiddleLeft image of the callout.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.DefaultValueAttribute()
public function get,set CallOutMiddleLeft : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the MiddleLeft image of the callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_CallOutMiddleLeft();
public: __property void set_CallOutMiddleLeft(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the MiddleLeft image of the callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ CallOutMiddleLeft {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


CallOutMiddleRight Property

[image]
Intersoft WebTextEditor Documentation
CallOutMiddleRight Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : CallOutMiddleRight Property

Glossary Item Box

Specifies the MiddleRight image of the callout.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the MiddleRight image of the callout.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property CallOutMiddleRight As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.CallOutMiddleRight = value

value = instance.CallOutMiddleRight
C#
[System.ComponentModel.DescriptionAttribute("Specifies the MiddleRight image of the callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string CallOutMiddleRight {get; set;}
Delphi
public read-write property CallOutMiddleRight: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the MiddleRight image of the callout.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.DefaultValueAttribute()
public function get,set CallOutMiddleRight : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the MiddleRight image of the callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_CallOutMiddleRight();
public: __property void set_CallOutMiddleRight(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the MiddleRight image of the callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ CallOutMiddleRight {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


CallOutMiddleTop Property

[image]
Intersoft WebTextEditor Documentation
CallOutMiddleTop Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : CallOutMiddleTop Property

Glossary Item Box

Specifies the MiddleTop image of the callout.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the MiddleTop image of the callout.")>
<System.ComponentModel.CategoryAttribute("Image Settings")>
Public Property CallOutMiddleTop As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.CallOutMiddleTop = value

value = instance.CallOutMiddleTop
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the MiddleTop image of the callout.")]
[System.ComponentModel.CategoryAttribute("Image Settings")]
public System.string CallOutMiddleTop {get; set;}
Delphi
public read-write property CallOutMiddleTop: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the MiddleTop image of the callout.")
System.ComponentModel.CategoryAttribute("Image Settings")
public function get,set CallOutMiddleTop : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the MiddleTop image of the callout.")]
[System.ComponentModel.CategoryAttribute("Image Settings")]
public: __property System.string* get_CallOutMiddleTop();
public: __property void set_CallOutMiddleTop(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the MiddleTop image of the callout.")]
[System.ComponentModel.CategoryAttribute("Image Settings")]
public:
property System.String^ CallOutMiddleTop {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


CallOutTopLeft Property

[image]
Intersoft WebTextEditor Documentation
CallOutTopLeft Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : CallOutTopLeft Property

Glossary Item Box

Specifies the TopLeft image of the callout.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.DescriptionAttribute("Specifies the TopLeft image of the callout.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property CallOutTopLeft As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.CallOutTopLeft = value

value = instance.CallOutTopLeft
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the TopLeft image of the callout.")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string CallOutTopLeft {get; set;}
Delphi
public read-write property CallOutTopLeft: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.DescriptionAttribute("Specifies the TopLeft image of the callout.")
System.ComponentModel.DefaultValueAttribute()
public function get,set CallOutTopLeft : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the TopLeft image of the callout.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_CallOutTopLeft();
public: __property void set_CallOutTopLeft(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the TopLeft image of the callout.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ CallOutTopLeft {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


CallOutTopLeftPointer Property

[image]
Intersoft WebTextEditor Documentation
CallOutTopLeftPointer Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : CallOutTopLeftPointer Property

Glossary Item Box

Specifies the top left pointer image of the callout.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the top left pointer image of the callout.")>
<System.ComponentModel.CategoryAttribute("Image Settings")>
Public Property CallOutTopLeftPointer As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.CallOutTopLeftPointer = value

value = instance.CallOutTopLeftPointer
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the top left pointer image of the callout.")]
[System.ComponentModel.CategoryAttribute("Image Settings")]
public System.string CallOutTopLeftPointer {get; set;}
Delphi
public read-write property CallOutTopLeftPointer: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the top left pointer image of the callout.")
System.ComponentModel.CategoryAttribute("Image Settings")
public function get,set CallOutTopLeftPointer : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the top left pointer image of the callout.")]
[System.ComponentModel.CategoryAttribute("Image Settings")]
public: __property System.string* get_CallOutTopLeftPointer();
public: __property void set_CallOutTopLeftPointer(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the top left pointer image of the callout.")]
[System.ComponentModel.CategoryAttribute("Image Settings")]
public:
property System.String^ CallOutTopLeftPointer {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


CallOutTopRight Property

[image]
Intersoft WebTextEditor Documentation
CallOutTopRight Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : CallOutTopRight Property

Glossary Item Box

Specifies the TopRight image of the callout.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the TopRight image of the callout.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property CallOutTopRight As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.CallOutTopRight = value

value = instance.CallOutTopRight
C#
[System.ComponentModel.DescriptionAttribute("Specifies the TopRight image of the callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.string CallOutTopRight {get; set;}
Delphi
public read-write property CallOutTopRight: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the TopRight image of the callout.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set CallOutTopRight : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the TopRight image of the callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_CallOutTopRight();
public: __property void set_CallOutTopRight(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the TopRight image of the callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ CallOutTopRight {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


CallOutTopRightPointer Property

[image]
Intersoft WebTextEditor Documentation
CallOutTopRightPointer Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : CallOutTopRightPointer Property

Glossary Item Box

Specifies the top right pointer image of the callout.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the top right pointer image of the callout.")>
<System.ComponentModel.CategoryAttribute("Image Settings")>
Public Property CallOutTopRightPointer As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.CallOutTopRightPointer = value

value = instance.CallOutTopRightPointer
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the top right pointer image of the callout.")]
[System.ComponentModel.CategoryAttribute("Image Settings")]
public System.string CallOutTopRightPointer {get; set;}
Delphi
public read-write property CallOutTopRightPointer: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the top right pointer image of the callout.")
System.ComponentModel.CategoryAttribute("Image Settings")
public function get,set CallOutTopRightPointer : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the top right pointer image of the callout.")]
[System.ComponentModel.CategoryAttribute("Image Settings")]
public: __property System.string* get_CallOutTopRightPointer();
public: __property void set_CallOutTopRightPointer(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the top right pointer image of the callout.")]
[System.ComponentModel.CategoryAttribute("Image Settings")]
public:
property System.String^ CallOutTopRightPointer {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


Cancel Property

[image]
Intersoft WebTextEditor Documentation
Cancel Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : Cancel Property

Glossary Item Box

Specifies the image of Cancel command in Table Designer toolbar.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the image of Cancel command in Table Designer toolbar.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property Cancel As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.Cancel = value

value = instance.Cancel
C#
[System.ComponentModel.DescriptionAttribute("Specifies the image of Cancel command in Table Designer toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string Cancel {get; set;}
Delphi
public read-write property Cancel: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the image of Cancel command in Table Designer toolbar.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set Cancel : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the image of Cancel command in Table Designer toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_Cancel();
public: __property void set_Cancel(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the image of Cancel command in Table Designer toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ Cancel {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


ChangeCase Property

[image]
Intersoft WebTextEditor Documentation
ChangeCase Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : ChangeCase Property

Glossary Item Box

Specifies the image of Change Case command in main toolbar.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the image of Change Case command in main toolbar.")>
Public Property ChangeCase As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.ChangeCase = value

value = instance.ChangeCase
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Change Case command in main toolbar.")]
public System.string ChangeCase {get; set;}
Delphi
public read-write property ChangeCase: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the image of Change Case command in main toolbar.")
public function get,set ChangeCase : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Change Case command in main toolbar.")]
public: __property System.string* get_ChangeCase();
public: __property void set_ChangeCase(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Change Case command in main toolbar.")]
public:
property System.String^ ChangeCase {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


ClearFormatting Property

[image]
Intersoft WebTextEditor Documentation
ClearFormatting Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : ClearFormatting Property

Glossary Item Box

Specifies the image of Clear Formatting command in main toolbar.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the image of Clear Formatting command in main toolbar.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property ClearFormatting As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.ClearFormatting = value

value = instance.ClearFormatting
C#
[System.ComponentModel.DescriptionAttribute("Specifies the image of Clear Formatting command in main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string ClearFormatting {get; set;}
Delphi
public read-write property ClearFormatting: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the image of Clear Formatting command in main toolbar.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.DefaultValueAttribute()
public function get,set ClearFormatting : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the image of Clear Formatting command in main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_ClearFormatting();
public: __property void set_ClearFormatting(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the image of Clear Formatting command in main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ ClearFormatting {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


Copy Property

[image]
Intersoft WebTextEditor Documentation
Copy Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : Copy Property

Glossary Item Box

Specifies the image of Copy command in main toolbar.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the image of Copy command in main toolbar.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property Copy As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.Copy = value

value = instance.Copy
C#
[System.ComponentModel.DescriptionAttribute("Specifies the image of Copy command in main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string Copy {get; set;}
Delphi
public read-write property Copy: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the image of Copy command in main toolbar.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set Copy : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the image of Copy command in main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_Copy();
public: __property void set_Copy(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the image of Copy command in main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ Copy {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


Cut Property

[image]
Intersoft WebTextEditor Documentation
Cut Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : Cut Property

Glossary Item Box

Specifies the image of Cut command in main toolbar.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the image of Cut command in main toolbar.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Cut As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.Cut = value

value = instance.Cut
C#
[System.ComponentModel.DescriptionAttribute("Specifies the image of Cut command in main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string Cut {get; set;}
Delphi
public read-write property Cut: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the image of Cut command in main toolbar.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.DefaultValueAttribute()
public function get,set Cut : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the image of Cut command in main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_Cut();
public: __property void set_Cut(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the image of Cut command in main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ Cut {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


DecreaseIndent Property

[image]
Intersoft WebTextEditor Documentation
DecreaseIndent Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : DecreaseIndent Property

Glossary Item Box

Specifies the image of Decrease Indent command in main toolbar.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the image of Decrease Indent command in main toolbar.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property DecreaseIndent As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.DecreaseIndent = value

value = instance.DecreaseIndent
C#
[System.ComponentModel.DescriptionAttribute("Specifies the image of Decrease Indent command in main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.string DecreaseIndent {get; set;}
Delphi
public read-write property DecreaseIndent: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the image of Decrease Indent command in main toolbar.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set DecreaseIndent : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the image of Decrease Indent command in main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_DecreaseIndent();
public: __property void set_DecreaseIndent(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the image of Decrease Indent command in main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ DecreaseIndent {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


DeleteColumn Property

[image]
Intersoft WebTextEditor Documentation
DeleteColumn Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : DeleteColumn Property

Glossary Item Box

Specifies the image of Delete Column item.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the image of Delete Column item.")>
<System.ComponentModel.CategoryAttribute("Image Settings")>
Public Property DeleteColumn As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.DeleteColumn = value

value = instance.DeleteColumn
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Delete Column item.")]
[System.ComponentModel.CategoryAttribute("Image Settings")]
public System.string DeleteColumn {get; set;}
Delphi
public read-write property DeleteColumn: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the image of Delete Column item.")
System.ComponentModel.CategoryAttribute("Image Settings")
public function get,set DeleteColumn : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Delete Column item.")]
[System.ComponentModel.CategoryAttribute("Image Settings")]
public: __property System.string* get_DeleteColumn();
public: __property void set_DeleteColumn(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Delete Column item.")]
[System.ComponentModel.CategoryAttribute("Image Settings")]
public:
property System.String^ DeleteColumn {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


DeleteRow Property

[image]
Intersoft WebTextEditor Documentation
DeleteRow Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : DeleteRow Property

Glossary Item Box

Specifies the image of Delete Row item.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the image of Delete Row item.")>
Public Property DeleteRow As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.DeleteRow = value

value = instance.DeleteRow
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Delete Row item.")]
public System.string DeleteRow {get; set;}
Delphi
public read-write property DeleteRow: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the image of Delete Row item.")
public function get,set DeleteRow : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Delete Row item.")]
public: __property System.string* get_DeleteRow();
public: __property void set_DeleteRow(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Delete Row item.")]
public:
property System.String^ DeleteRow {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


DropDownImage Property

[image]
Intersoft WebTextEditor Documentation
DropDownImage Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : DropDownImage Property

Glossary Item Box

Specifies the dropdown image in toolbar.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.DescriptionAttribute("Specifies the dropdown image in toolbar.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property DropDownImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.DropDownImage = value

value = instance.DropDownImage
C#
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the dropdown image in toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string DropDownImage {get; set;}
Delphi
public read-write property DropDownImage: System.String;
JScript
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.DescriptionAttribute("Specifies the dropdown image in toolbar.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set DropDownImage : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the dropdown image in toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_DropDownImage();
public: __property void set_DropDownImage(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the dropdown image in toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ DropDownImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


Emoticon Property

[image]
Intersoft WebTextEditor Documentation
Emoticon Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : Emoticon Property

Glossary Item Box

Specifies the image of Emoticon command in main toolbar.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the image of Emoticon command in main toolbar.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Emoticon As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.Emoticon = value

value = instance.Emoticon
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Emoticon command in main toolbar.")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string Emoticon {get; set;}
Delphi
public read-write property Emoticon: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the image of Emoticon command in main toolbar.")
System.ComponentModel.DefaultValueAttribute()
public function get,set Emoticon : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Emoticon command in main toolbar.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_Emoticon();
public: __property void set_Emoticon(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Emoticon command in main toolbar.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ Emoticon {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


Find Property

[image]
Intersoft WebTextEditor Documentation
Find Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : Find Property

Glossary Item Box

Specifies the image of Find command in main toolbar.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.DescriptionAttribute("Specifies the image of Find command in main toolbar.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property Find As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.Find = value

value = instance.Find
C#
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Find command in main toolbar.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string Find {get; set;}
Delphi
public read-write property Find: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.DescriptionAttribute("Specifies the image of Find command in main toolbar.")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set Find : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Find command in main toolbar.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_Find();
public: __property void set_Find(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Find command in main toolbar.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ Find {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


First Property

[image]
Intersoft WebTextEditor Documentation
First Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : First Property

Glossary Item Box

Specifies the image of First command in Preview toolbar.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the image of First command in Preview toolbar.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property First As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.First = value

value = instance.First
C#
[System.ComponentModel.DescriptionAttribute("Specifies the image of First command in Preview toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.string First {get; set;}
Delphi
public read-write property First: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the image of First command in Preview toolbar.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set First : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the image of First command in Preview toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_First();
public: __property void set_First(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the image of First command in Preview toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ First {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


FontColor Property

[image]
Intersoft WebTextEditor Documentation
FontColor Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : FontColor Property

Glossary Item Box

Specifies the image of Font Color command in main toolbar.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the image of Font Color command in main toolbar.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property FontColor As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.FontColor = value

value = instance.FontColor
C#
[System.ComponentModel.DescriptionAttribute("Specifies the image of Font Color command in main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string FontColor {get; set;}
Delphi
public read-write property FontColor: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the image of Font Color command in main toolbar.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.DefaultValueAttribute()
public function get,set FontColor : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the image of Font Color command in main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_FontColor();
public: __property void set_FontColor(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the image of Font Color command in main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ FontColor {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


FullScreen Property

[image]
Intersoft WebTextEditor Documentation
FullScreen Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : FullScreen Property

Glossary Item Box

Specifies the image of Full Screen command in main toolbar.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the image of Full Screen command in main toolbar.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property FullScreen As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.FullScreen = value

value = instance.FullScreen
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Full Screen command in main toolbar.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string FullScreen {get; set;}
Delphi
public read-write property FullScreen: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the image of Full Screen command in main toolbar.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set FullScreen : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Full Screen command in main toolbar.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_FullScreen();
public: __property void set_FullScreen(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Full Screen command in main toolbar.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ FullScreen {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


HorizontalRule Property

[image]
Intersoft WebTextEditor Documentation
HorizontalRule Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : HorizontalRule Property

Glossary Item Box

Specifies the image of Insert Horizontal Rule item.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Horizontal Rule item.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property HorizontalRule As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.HorizontalRule = value

value = instance.HorizontalRule
C#
[System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Horizontal Rule item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string HorizontalRule {get; set;}
Delphi
public read-write property HorizontalRule: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Horizontal Rule item.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.DefaultValueAttribute()
public function get,set HorizontalRule : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Horizontal Rule item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_HorizontalRule();
public: __property void set_HorizontalRule(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Horizontal Rule item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ HorizontalRule {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


Hyperlink Property

[image]
Intersoft WebTextEditor Documentation
Hyperlink Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : Hyperlink Property

Glossary Item Box

Specifies the image of Hyperlink command in main toolbar.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the image of Hyperlink command in main toolbar.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Hyperlink As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.Hyperlink = value

value = instance.Hyperlink
C#
[System.ComponentModel.DescriptionAttribute("Specifies the image of Hyperlink command in main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string Hyperlink {get; set;}
Delphi
public read-write property Hyperlink: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the image of Hyperlink command in main toolbar.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.DefaultValueAttribute()
public function get,set Hyperlink : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the image of Hyperlink command in main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_Hyperlink();
public: __property void set_Hyperlink(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the image of Hyperlink command in main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ Hyperlink {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


IFrame Property

[image]
Intersoft WebTextEditor Documentation
IFrame Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : IFrame Property

Glossary Item Box

Specifies the image of Insert IFrame item.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the image of Insert IFrame item.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property IFrame As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.IFrame = value

value = instance.IFrame
C#
[System.ComponentModel.DescriptionAttribute("Specifies the image of Insert IFrame item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.string IFrame {get; set;}
Delphi
public read-write property IFrame: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the image of Insert IFrame item.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set IFrame : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the image of Insert IFrame item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_IFrame();
public: __property void set_IFrame(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the image of Insert IFrame item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ IFrame {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


Import Property

[image]
Intersoft WebTextEditor Documentation
Import Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : Import Property

Glossary Item Box

Specifies the image of Import command in main toolbar.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Image Settings")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the image of Import command in main toolbar.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property Import As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.Import = value

value = instance.Import
C#
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Import command in main toolbar.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string Import {get; set;}
Delphi
public read-write property Import: System.String;
JScript
System.ComponentModel.CategoryAttribute("Image Settings")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the image of Import command in main toolbar.")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set Import : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Import command in main toolbar.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_Import();
public: __property void set_Import(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Import command in main toolbar.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ Import {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


IncreaseIndent Property

[image]
Intersoft WebTextEditor Documentation
IncreaseIndent Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : IncreaseIndent Property

Glossary Item Box

Specifies the image of Increase Indent command in main toolbar.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the image of Increase Indent command in main toolbar.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property IncreaseIndent As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.IncreaseIndent = value

value = instance.IncreaseIndent
C#
[System.ComponentModel.DescriptionAttribute("Specifies the image of Increase Indent command in main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.string IncreaseIndent {get; set;}
Delphi
public read-write property IncreaseIndent: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the image of Increase Indent command in main toolbar.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set IncreaseIndent : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the image of Increase Indent command in main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_IncreaseIndent();
public: __property void set_IncreaseIndent(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the image of Increase Indent command in main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ IncreaseIndent {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


InProgress Property

[image]
Intersoft WebTextEditor Documentation
InProgress Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : InProgress Property

Glossary Item Box

Specifies the image that indicates that a flypostback action is in progress.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the image that indicates that a flypostback action is in progress.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property InProgress As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.InProgress = value

value = instance.InProgress
C#
[System.ComponentModel.DescriptionAttribute("Specifies the image that indicates that a flypostback action is in progress.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.string InProgress {get; set;}
Delphi
public read-write property InProgress: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the image that indicates that a flypostback action is in progress.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set InProgress : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the image that indicates that a flypostback action is in progress.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_InProgress();
public: __property void set_InProgress(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the image that indicates that a flypostback action is in progress.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ InProgress {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


InputButton Property

[image]
Intersoft WebTextEditor Documentation
InputButton Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : InputButton Property

Glossary Item Box

Specifies the image of Insert Input Button item.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Input Button item.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property InputButton As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.InputButton = value

value = instance.InputButton
C#
[System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Input Button item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string InputButton {get; set;}
Delphi
public read-write property InputButton: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Input Button item.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.DefaultValueAttribute()
public function get,set InputButton : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Input Button item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_InputButton();
public: __property void set_InputButton(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Input Button item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ InputButton {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


InputCheckBox Property

[image]
Intersoft WebTextEditor Documentation
InputCheckBox Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : InputCheckBox Property

Glossary Item Box

Specifies the image of Insert Input Checkbox item.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Input Checkbox item.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property InputCheckBox As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.InputCheckBox = value

value = instance.InputCheckBox
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Input Checkbox item.")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string InputCheckBox {get; set;}
Delphi
public read-write property InputCheckBox: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Input Checkbox item.")
System.ComponentModel.DefaultValueAttribute()
public function get,set InputCheckBox : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Input Checkbox item.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_InputCheckBox();
public: __property void set_InputCheckBox(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Input Checkbox item.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ InputCheckBox {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


InputFileUpload Property

[image]
Intersoft WebTextEditor Documentation
InputFileUpload Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : InputFileUpload Property

Glossary Item Box

Specifies the image of Insert Input Upload item.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Input Upload item.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property InputFileUpload As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.InputFileUpload = value

value = instance.InputFileUpload
C#
[System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Input Upload item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string InputFileUpload {get; set;}
Delphi
public read-write property InputFileUpload: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Input Upload item.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.DefaultValueAttribute()
public function get,set InputFileUpload : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Input Upload item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_InputFileUpload();
public: __property void set_InputFileUpload(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Input Upload item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ InputFileUpload {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


InputHidden Property

[image]
Intersoft WebTextEditor Documentation
InputHidden Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : InputHidden Property

Glossary Item Box

Specifies the image of Insert Input Hidden item.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Input Hidden item.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property InputHidden As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.InputHidden = value

value = instance.InputHidden
C#
[System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Input Hidden item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string InputHidden {get; set;}
Delphi
public read-write property InputHidden: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Input Hidden item.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.DefaultValueAttribute()
public function get,set InputHidden : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Input Hidden item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_InputHidden();
public: __property void set_InputHidden(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Input Hidden item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ InputHidden {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


InputPassword Property

[image]
Intersoft WebTextEditor Documentation
InputPassword Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : InputPassword Property

Glossary Item Box

Specifies the image of Insert Input Password item.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Input Password item.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property InputPassword As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.InputPassword = value

value = instance.InputPassword
C#
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Input Password item.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string InputPassword {get; set;}
Delphi
public read-write property InputPassword: System.String;
JScript
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Input Password item.")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set InputPassword : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Input Password item.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_InputPassword();
public: __property void set_InputPassword(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Input Password item.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ InputPassword {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


InputRadio Property

[image]
Intersoft WebTextEditor Documentation
InputRadio Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : InputRadio Property

Glossary Item Box

Specifies the image of Insert Input Radio item.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Input Radio item.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property InputRadio As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.InputRadio = value

value = instance.InputRadio
C#
[System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Input Radio item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.string InputRadio {get; set;}
Delphi
public read-write property InputRadio: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Input Radio item.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set InputRadio : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Input Radio item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_InputRadio();
public: __property void set_InputRadio(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Input Radio item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ InputRadio {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


InputReset Property

[image]
Intersoft WebTextEditor Documentation
InputReset Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : InputReset Property

Glossary Item Box

Specifies the image of Insert Input Reset item.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Input Reset item.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property InputReset As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.InputReset = value

value = instance.InputReset
C#
[System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Input Reset item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string InputReset {get; set;}
Delphi
public read-write property InputReset: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Input Reset item.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.DefaultValueAttribute()
public function get,set InputReset : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Input Reset item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_InputReset();
public: __property void set_InputReset(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Input Reset item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ InputReset {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


InputSubmit Property

[image]
Intersoft WebTextEditor Documentation
InputSubmit Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : InputSubmit Property

Glossary Item Box

Specifies the image of Insert Input Submit item.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Input Submit item.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property InputSubmit As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.InputSubmit = value

value = instance.InputSubmit
C#
[System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Input Submit item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.string InputSubmit {get; set;}
Delphi
public read-write property InputSubmit: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Input Submit item.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set InputSubmit : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Input Submit item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_InputSubmit();
public: __property void set_InputSubmit(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Input Submit item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ InputSubmit {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


InputText Property

[image]
Intersoft WebTextEditor Documentation
InputText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : InputText Property

Glossary Item Box

Specifies the image of Insert Input Text item.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Input Text item.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property InputText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.InputText = value

value = instance.InputText
C#
[System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Input Text item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string InputText {get; set;}
Delphi
public read-write property InputText: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Input Text item.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.DefaultValueAttribute()
public function get,set InputText : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Input Text item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_InputText();
public: __property void set_InputText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Input Text item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ InputText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


InsertFormControl Property

[image]
Intersoft WebTextEditor Documentation
InsertFormControl Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : InsertFormControl Property

Glossary Item Box

Specifies the image of Insert Form Control command in main toolbar.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Form Control command in main toolbar.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property InsertFormControl As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.InsertFormControl = value

value = instance.InsertFormControl
C#
[System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Form Control command in main toolbar.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string InsertFormControl {get; set;}
Delphi
public read-write property InsertFormControl: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Form Control command in main toolbar.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set InsertFormControl : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Form Control command in main toolbar.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_InsertFormControl();
public: __property void set_InsertFormControl(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Form Control command in main toolbar.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ InsertFormControl {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


InsertFromWeb Property

[image]
Intersoft WebTextEditor Documentation
InsertFromWeb Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : InsertFromWeb Property

Glossary Item Box

Specifies the image of Insert From Web command in Media Gallery toolbar.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the image of Insert From Web command in Media Gallery toolbar.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property InsertFromWeb As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.InsertFromWeb = value

value = instance.InsertFromWeb
C#
[System.ComponentModel.DescriptionAttribute("Specifies the image of Insert From Web command in Media Gallery toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string InsertFromWeb {get; set;}
Delphi
public read-write property InsertFromWeb: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the image of Insert From Web command in Media Gallery toolbar.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set InsertFromWeb : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the image of Insert From Web command in Media Gallery toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_InsertFromWeb();
public: __property void set_InsertFromWeb(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the image of Insert From Web command in Media Gallery toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ InsertFromWeb {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


InsertLeftColumns Property

[image]
Intersoft WebTextEditor Documentation
InsertLeftColumns Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : InsertLeftColumns Property

Glossary Item Box

Specifies the image of Insert Columns to Left item.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Columns to Left item.")>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property InsertLeftColumns As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.InsertLeftColumns = value

value = instance.InsertLeftColumns
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Columns to Left item.")]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string InsertLeftColumns {get; set;}
Delphi
public read-write property InsertLeftColumns: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Columns to Left item.")
System.ComponentModel.CategoryAttribute("Image Settings")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set InsertLeftColumns : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Columns to Left item.")]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_InsertLeftColumns();
public: __property void set_InsertLeftColumns(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Columns to Left item.")]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ InsertLeftColumns {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


InsertRightColumns Property

[image]
Intersoft WebTextEditor Documentation
InsertRightColumns Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : InsertRightColumns Property

Glossary Item Box

Specifies the image of Insert Columns to Right item.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Columns to Right item.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property InsertRightColumns As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.InsertRightColumns = value

value = instance.InsertRightColumns
C#
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Columns to Right item.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string InsertRightColumns {get; set;}
Delphi
public read-write property InsertRightColumns: System.String;
JScript
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Columns to Right item.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set InsertRightColumns : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Columns to Right item.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_InsertRightColumns();
public: __property void set_InsertRightColumns(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Columns to Right item.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ InsertRightColumns {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


InsertRowsAbove Property

[image]
Intersoft WebTextEditor Documentation
InsertRowsAbove Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : InsertRowsAbove Property

Glossary Item Box

Specifies the image of Insert Rows Above item.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Rows Above item.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property InsertRowsAbove As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.InsertRowsAbove = value

value = instance.InsertRowsAbove
C#
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Rows Above item.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string InsertRowsAbove {get; set;}
Delphi
public read-write property InsertRowsAbove: System.String;
JScript
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Rows Above item.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set InsertRowsAbove : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Rows Above item.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_InsertRowsAbove();
public: __property void set_InsertRowsAbove(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Rows Above item.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ InsertRowsAbove {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


InsertRowsBelow Property

[image]
Intersoft WebTextEditor Documentation
InsertRowsBelow Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : InsertRowsBelow Property

Glossary Item Box

Specifies the image of Insert Rows Below item.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Rows Below item.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property InsertRowsBelow As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.InsertRowsBelow = value

value = instance.InsertRowsBelow
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Rows Below item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string InsertRowsBelow {get; set;}
Delphi
public read-write property InsertRowsBelow: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Rows Below item.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set InsertRowsBelow : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Rows Below item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_InsertRowsBelow();
public: __property void set_InsertRowsBelow(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Rows Below item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ InsertRowsBelow {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


InsertSymbol Property

[image]
Intersoft WebTextEditor Documentation
InsertSymbol Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : InsertSymbol Property

Glossary Item Box

Specifies the image of Insert Symbol command in main toolbar.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Symbol command in main toolbar.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property InsertSymbol As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.InsertSymbol = value

value = instance.InsertSymbol
C#
[System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Symbol command in main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string InsertSymbol {get; set;}
Delphi
public read-write property InsertSymbol: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Symbol command in main toolbar.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.DefaultValueAttribute()
public function get,set InsertSymbol : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Symbol command in main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_InsertSymbol();
public: __property void set_InsertSymbol(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Symbol command in main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ InsertSymbol {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


InsertTable Property

[image]
Intersoft WebTextEditor Documentation
InsertTable Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : InsertTable Property

Glossary Item Box

Specifies the image of Insert Table command in Table Designer toolbar.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Image Settings")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Table command in Table Designer toolbar.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property InsertTable As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.InsertTable = value

value = instance.InsertTable
C#
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Table command in Table Designer toolbar.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string InsertTable {get; set;}
Delphi
public read-write property InsertTable: System.String;
JScript
System.ComponentModel.CategoryAttribute("Image Settings")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Table command in Table Designer toolbar.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set InsertTable : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Table command in Table Designer toolbar.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_InsertTable();
public: __property void set_InsertTable(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Table command in Table Designer toolbar.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ InsertTable {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


Italic Property

[image]
Intersoft WebTextEditor Documentation
Italic Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : Italic Property

Glossary Item Box

Specifies the image of Italic command in main toolbar.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the image of Italic command in main toolbar.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Italic As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.Italic = value

value = instance.Italic
C#
[System.ComponentModel.DescriptionAttribute("Specifies the image of Italic command in main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string Italic {get; set;}
Delphi
public read-write property Italic: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the image of Italic command in main toolbar.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.DefaultValueAttribute()
public function get,set Italic : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the image of Italic command in main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_Italic();
public: __property void set_Italic(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the image of Italic command in main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ Italic {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


Last Property

[image]
Intersoft WebTextEditor Documentation
Last Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : Last Property

Glossary Item Box

Specifies the image of Last command in Preview toolbar.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the image of Last command in Preview toolbar.")>
<System.ComponentModel.CategoryAttribute("Image Settings")>
Public Property Last As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.Last = value

value = instance.Last
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Last command in Preview toolbar.")]
[System.ComponentModel.CategoryAttribute("Image Settings")]
public System.string Last {get; set;}
Delphi
public read-write property Last: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the image of Last command in Preview toolbar.")
System.ComponentModel.CategoryAttribute("Image Settings")
public function get,set Last : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Last command in Preview toolbar.")]
[System.ComponentModel.CategoryAttribute("Image Settings")]
public: __property System.string* get_Last();
public: __property void set_Last(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Last command in Preview toolbar.")]
[System.ComponentModel.CategoryAttribute("Image Settings")]
public:
property System.String^ Last {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


LowerCase Property

[image]
Intersoft WebTextEditor Documentation
LowerCase Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : LowerCase Property

Glossary Item Box

Specifies the image of Lower Case item in Change Case dropdown menu.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the image of Lower Case item in Change Case dropdown menu.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property LowerCase As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.LowerCase = value

value = instance.LowerCase
C#
[System.ComponentModel.DescriptionAttribute("Specifies the image of Lower Case item in Change Case dropdown menu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string LowerCase {get; set;}
Delphi
public read-write property LowerCase: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the image of Lower Case item in Change Case dropdown menu.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set LowerCase : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the image of Lower Case item in Change Case dropdown menu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_LowerCase();
public: __property void set_LowerCase(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the image of Lower Case item in Change Case dropdown menu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ LowerCase {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


Marquee Property

[image]
Intersoft WebTextEditor Documentation
Marquee Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : Marquee Property

Glossary Item Box

Specifies the image of Insert Marquee item.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Marquee item.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property Marquee As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.Marquee = value

value = instance.Marquee
C#
[System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Marquee item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string Marquee {get; set;}
Delphi
public read-write property Marquee: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Marquee item.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set Marquee : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Marquee item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_Marquee();
public: __property void set_Marquee(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Marquee item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ Marquee {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


MediaAVI Property

[image]
Intersoft WebTextEditor Documentation
MediaAVI Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : MediaAVI Property

Glossary Item Box

Specifies the image that indicates AVI media type.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the image that indicates AVI media type.")>
<System.ComponentModel.CategoryAttribute("Image Settings")>
Public Property MediaAVI As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.MediaAVI = value

value = instance.MediaAVI
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the image that indicates AVI media type.")]
[System.ComponentModel.CategoryAttribute("Image Settings")]
public System.string MediaAVI {get; set;}
Delphi
public read-write property MediaAVI: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the image that indicates AVI media type.")
System.ComponentModel.CategoryAttribute("Image Settings")
public function get,set MediaAVI : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the image that indicates AVI media type.")]
[System.ComponentModel.CategoryAttribute("Image Settings")]
public: __property System.string* get_MediaAVI();
public: __property void set_MediaAVI(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the image that indicates AVI media type.")]
[System.ComponentModel.CategoryAttribute("Image Settings")]
public:
property System.String^ MediaAVI {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


MediaDeleteAction Property

[image]
Intersoft WebTextEditor Documentation
MediaDeleteAction Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : MediaDeleteAction Property

Glossary Item Box

Specifies the delete image in media action container

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.DescriptionAttribute("Specifies the delete image in media action container.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property MediaDeleteAction As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.MediaDeleteAction = value

value = instance.MediaDeleteAction
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the delete image in media action container.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string MediaDeleteAction {get; set;}
Delphi
public read-write property MediaDeleteAction: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.DescriptionAttribute("Specifies the delete image in media action container.")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set MediaDeleteAction : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the delete image in media action container.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_MediaDeleteAction();
public: __property void set_MediaDeleteAction(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the delete image in media action container.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ MediaDeleteAction {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


MediaEditAction Property

[image]
Intersoft WebTextEditor Documentation
MediaEditAction Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : MediaEditAction Property

Glossary Item Box

Specifies the edit image in media action container.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the edit image in media action container.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property MediaEditAction As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.MediaEditAction = value

value = instance.MediaEditAction
C#
[System.ComponentModel.DescriptionAttribute("Specifies the edit image in media action container.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string MediaEditAction {get; set;}
Delphi
public read-write property MediaEditAction: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the edit image in media action container.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set MediaEditAction : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the edit image in media action container.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_MediaEditAction();
public: __property void set_MediaEditAction(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the edit image in media action container.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ MediaEditAction {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


MediaGallery Property

[image]
Intersoft WebTextEditor Documentation
MediaGallery Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : MediaGallery Property

Glossary Item Box

Specifies the image of Media Gallery command in main toolbar.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the image of Media Gallery command in main toolbar.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property MediaGallery As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.MediaGallery = value

value = instance.MediaGallery
C#
[System.ComponentModel.DescriptionAttribute("Specifies the image of Media Gallery command in main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string MediaGallery {get; set;}
Delphi
public read-write property MediaGallery: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the image of Media Gallery command in main toolbar.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.DefaultValueAttribute()
public function get,set MediaGallery : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the image of Media Gallery command in main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_MediaGallery();
public: __property void set_MediaGallery(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the image of Media Gallery command in main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ MediaGallery {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


MediaMOV Property

[image]
Intersoft WebTextEditor Documentation
MediaMOV Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : MediaMOV Property

Glossary Item Box

Specifies the image that indicates MOV media type.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.DescriptionAttribute("Specifies the image that indicates MOV media type.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property MediaMOV As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.MediaMOV = value

value = instance.MediaMOV
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the image that indicates MOV media type.")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string MediaMOV {get; set;}
Delphi
public read-write property MediaMOV: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.DescriptionAttribute("Specifies the image that indicates MOV media type.")
System.ComponentModel.DefaultValueAttribute()
public function get,set MediaMOV : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the image that indicates MOV media type.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_MediaMOV();
public: __property void set_MediaMOV(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the image that indicates MOV media type.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ MediaMOV {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


MediaMP3 Property

[image]
Intersoft WebTextEditor Documentation
MediaMP3 Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : MediaMP3 Property

Glossary Item Box

Specifies the image that indicates MP3 media type.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the image that indicates MP3 media type.")>
<System.ComponentModel.CategoryAttribute("Image Settings")>
Public Property MediaMP3 As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.MediaMP3 = value

value = instance.MediaMP3
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the image that indicates MP3 media type.")]
[System.ComponentModel.CategoryAttribute("Image Settings")]
public System.string MediaMP3 {get; set;}
Delphi
public read-write property MediaMP3: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the image that indicates MP3 media type.")
System.ComponentModel.CategoryAttribute("Image Settings")
public function get,set MediaMP3 : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the image that indicates MP3 media type.")]
[System.ComponentModel.CategoryAttribute("Image Settings")]
public: __property System.string* get_MediaMP3();
public: __property void set_MediaMP3(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the image that indicates MP3 media type.")]
[System.ComponentModel.CategoryAttribute("Image Settings")]
public:
property System.String^ MediaMP3 {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


MediaMPG Property

[image]
Intersoft WebTextEditor Documentation
MediaMPG Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : MediaMPG Property

Glossary Item Box

Specifies the image that indicates MPG media type.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.DescriptionAttribute("Specifies the image that indicates MPG media type.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property MediaMPG As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.MediaMPG = value

value = instance.MediaMPG
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the image that indicates MPG media type.")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string MediaMPG {get; set;}
Delphi
public read-write property MediaMPG: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.DescriptionAttribute("Specifies the image that indicates MPG media type.")
System.ComponentModel.DefaultValueAttribute()
public function get,set MediaMPG : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the image that indicates MPG media type.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_MediaMPG();
public: __property void set_MediaMPG(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the image that indicates MPG media type.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ MediaMPG {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


MediaSWF Property

[image]
Intersoft WebTextEditor Documentation
MediaSWF Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : MediaSWF Property

Glossary Item Box

Specifies the image that indicates SWF media type.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the image that indicates SWF media type.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property MediaSWF As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.MediaSWF = value

value = instance.MediaSWF
C#
[System.ComponentModel.DescriptionAttribute("Specifies the image that indicates SWF media type.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.string MediaSWF {get; set;}
Delphi
public read-write property MediaSWF: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the image that indicates SWF media type.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set MediaSWF : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the image that indicates SWF media type.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_MediaSWF();
public: __property void set_MediaSWF(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the image that indicates SWF media type.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ MediaSWF {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


MediaWAV Property

[image]
Intersoft WebTextEditor Documentation
MediaWAV Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : MediaWAV Property

Glossary Item Box

Specifies the image that indicates WAV media type.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the image that indicates WAV media type.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property MediaWAV As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.MediaWAV = value

value = instance.MediaWAV
C#
[System.ComponentModel.DescriptionAttribute("Specifies the image that indicates WAV media type.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string MediaWAV {get; set;}
Delphi
public read-write property MediaWAV: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the image that indicates WAV media type.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.DefaultValueAttribute()
public function get,set MediaWAV : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the image that indicates WAV media type.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_MediaWAV();
public: __property void set_MediaWAV(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the image that indicates WAV media type.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ MediaWAV {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


MediaWMA Property

[image]
Intersoft WebTextEditor Documentation
MediaWMA Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : MediaWMA Property

Glossary Item Box

Specifies the image that indicates WMA media type.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the image that indicates WMA media type.")>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property MediaWMA As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.MediaWMA = value

value = instance.MediaWMA
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image that indicates WMA media type.")]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string MediaWMA {get; set;}
Delphi
public read-write property MediaWMA: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the image that indicates WMA media type.")
System.ComponentModel.CategoryAttribute("Image Settings")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set MediaWMA : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image that indicates WMA media type.")]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_MediaWMA();
public: __property void set_MediaWMA(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image that indicates WMA media type.")]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ MediaWMA {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


MediaWMV Property

[image]
Intersoft WebTextEditor Documentation
MediaWMV Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : MediaWMV Property

Glossary Item Box

SSpecifies the image that indicates WMV media type.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the image that indicates WMV media type.")>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property MediaWMV As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.MediaWMV = value

value = instance.MediaWMV
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the image that indicates WMV media type.")]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string MediaWMV {get; set;}
Delphi
public read-write property MediaWMV: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the image that indicates WMV media type.")
System.ComponentModel.CategoryAttribute("Image Settings")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set MediaWMV : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the image that indicates WMV media type.")]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_MediaWMV();
public: __property void set_MediaWMV(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the image that indicates WMV media type.")]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ MediaWMV {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


MediaYouTube Property

[image]
Intersoft WebTextEditor Documentation
MediaYouTube Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : MediaYouTube Property

Glossary Item Box

Specifies the image that indicates YouTube media type.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the image that indicates YouTube media type.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property MediaYouTube As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.MediaYouTube = value

value = instance.MediaYouTube
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the image that indicates YouTube media type.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string MediaYouTube {get; set;}
Delphi
public read-write property MediaYouTube: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the image that indicates YouTube media type.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set MediaYouTube : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the image that indicates YouTube media type.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_MediaYouTube();
public: __property void set_MediaYouTube(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the image that indicates YouTube media type.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ MediaYouTube {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


MenuFormatting Property

[image]
Intersoft WebTextEditor Documentation
MenuFormatting Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : MenuFormatting Property

Glossary Item Box

Specifies the Formatting menu item in header context menu.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.DescriptionAttribute("Specifies the Formatting menu item in header context menu.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property MenuFormatting As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.MenuFormatting = value

value = instance.MenuFormatting
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the Formatting menu item in header context menu.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string MenuFormatting {get; set;}
Delphi
public read-write property MenuFormatting: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.DescriptionAttribute("Specifies the Formatting menu item in header context menu.")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set MenuFormatting : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the Formatting menu item in header context menu.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_MenuFormatting();
public: __property void set_MenuFormatting(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the Formatting menu item in header context menu.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ MenuFormatting {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


MenuStandard Property

[image]
Intersoft WebTextEditor Documentation
MenuStandard Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : MenuStandard Property

Glossary Item Box

Specifies the Standard menu item in header context menu.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the Standard menu item in header context menu.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property MenuStandard As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.MenuStandard = value

value = instance.MenuStandard
C#
[System.ComponentModel.DescriptionAttribute("Specifies the Standard menu item in header context menu.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string MenuStandard {get; set;}
Delphi
public read-write property MenuStandard: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the Standard menu item in header context menu.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set MenuStandard : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the Standard menu item in header context menu.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_MenuStandard();
public: __property void set_MenuStandard(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the Standard menu item in header context menu.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ MenuStandard {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


MergeCellDown Property

[image]
Intersoft WebTextEditor Documentation
MergeCellDown Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : MergeCellDown Property

Glossary Item Box

Specifies the image of Merge Cell Down item.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the image of Merge Cell Down item.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property MergeCellDown As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.MergeCellDown = value

value = instance.MergeCellDown
C#
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Merge Cell Down item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string MergeCellDown {get; set;}
Delphi
public read-write property MergeCellDown: System.String;
JScript
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the image of Merge Cell Down item.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set MergeCellDown : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Merge Cell Down item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_MergeCellDown();
public: __property void set_MergeCellDown(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Merge Cell Down item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ MergeCellDown {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


MergeCellRight Property

[image]
Intersoft WebTextEditor Documentation
MergeCellRight Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : MergeCellRight Property

Glossary Item Box

Specifies the image of Merge Cell Right item.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the image of Merge Cell Right item.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property MergeCellRight As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.MergeCellRight = value

value = instance.MergeCellRight
C#
[System.ComponentModel.DescriptionAttribute("Specifies the image of Merge Cell Right item.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string MergeCellRight {get; set;}
Delphi
public read-write property MergeCellRight: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the image of Merge Cell Right item.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set MergeCellRight : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the image of Merge Cell Right item.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_MergeCellRight();
public: __property void set_MergeCellRight(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the image of Merge Cell Right item.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ MergeCellRight {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


MergeCells Property

[image]
Intersoft WebTextEditor Documentation
MergeCells Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : MergeCells Property

Glossary Item Box

Specifies the image of Merge Cells item.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the image of Merge Cells item.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property MergeCells As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.MergeCells = value

value = instance.MergeCells
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Merge Cells item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string MergeCells {get; set;}
Delphi
public read-write property MergeCells: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the image of Merge Cells item.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set MergeCells : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Merge Cells item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_MergeCells();
public: __property void set_MergeCells(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Merge Cells item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ MergeCells {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


MoreImage Property

[image]
Intersoft WebTextEditor Documentation
MoreImage Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : MoreImage Property

Glossary Item Box

Specifies the image that indicates more menu in toolbar.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the image that indicates more menu in toolbar.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property MoreImage As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.MoreImage = value

value = instance.MoreImage
C#
[System.ComponentModel.DescriptionAttribute("Specifies the image that indicates more menu in toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string MoreImage {get; set;}
Delphi
public read-write property MoreImage: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the image that indicates more menu in toolbar.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.DefaultValueAttribute()
public function get,set MoreImage : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the image that indicates more menu in toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_MoreImage();
public: __property void set_MoreImage(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the image that indicates more menu in toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ MoreImage {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


Next Property

[image]
Intersoft WebTextEditor Documentation
Next Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : Next Property

Glossary Item Box

Specifies the image of Next command in Preview toolbar.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the image of Next command in Preview toolbar.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Next As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.Next = value

value = instance.Next
C#
[System.ComponentModel.DescriptionAttribute("Specifies the image of Next command in Preview toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string Next {get; set;}
Delphi
public read-write property Next: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the image of Next command in Preview toolbar.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.DefaultValueAttribute()
public function get,set Next : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the image of Next command in Preview toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_Next();
public: __property void set_Next(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the image of Next command in Preview toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ Next {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


Numbering Property

[image]
Intersoft WebTextEditor Documentation
Numbering Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : Numbering Property

Glossary Item Box

Specifies the image of Numbering command in main toolbar.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the image of Numbering command in main toolbar.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property Numbering As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.Numbering = value

value = instance.Numbering
C#
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Numbering command in main toolbar.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string Numbering {get; set;}
Delphi
public read-write property Numbering: System.String;
JScript
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the image of Numbering command in main toolbar.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set Numbering : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Numbering command in main toolbar.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_Numbering();
public: __property void set_Numbering(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Numbering command in main toolbar.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ Numbering {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


Paste Property

[image]
Intersoft WebTextEditor Documentation
Paste Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : Paste Property

Glossary Item Box

Specifies the image of Paste command in main toolbar.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.DescriptionAttribute("Specifies the image of Paste command in main toolbar.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property Paste As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.Paste = value

value = instance.Paste
C#
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Paste command in main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string Paste {get; set;}
Delphi
public read-write property Paste: System.String;
JScript
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.DescriptionAttribute("Specifies the image of Paste command in main toolbar.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set Paste : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Paste command in main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_Paste();
public: __property void set_Paste(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Paste command in main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ Paste {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


Preview Property

[image]
Intersoft WebTextEditor Documentation
Preview Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : Preview Property

Glossary Item Box

Specifies the image of Preview command in main toolbar.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the image of Preview command in main toolbar.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Preview As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.Preview = value

value = instance.Preview
C#
[System.ComponentModel.DescriptionAttribute("Specifies the image of Preview command in main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.string Preview {get; set;}
Delphi
public read-write property Preview: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the image of Preview command in main toolbar.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set Preview : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the image of Preview command in main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_Preview();
public: __property void set_Preview(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the image of Preview command in main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ Preview {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


Previous Property

[image]
Intersoft WebTextEditor Documentation
Previous Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : Previous Property

Glossary Item Box

Specifies the image of Previous command in Preview toolbar.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the image of Previous command in Preview toolbar.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Previous As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.Previous = value

value = instance.Previous
C#
[System.ComponentModel.DescriptionAttribute("Specifies the image of Previous command in Preview toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string Previous {get; set;}
Delphi
public read-write property Previous: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the image of Previous command in Preview toolbar.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.DefaultValueAttribute()
public function get,set Previous : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the image of Previous command in Preview toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_Previous();
public: __property void set_Previous(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the image of Previous command in Preview toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ Previous {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


Print Property

[image]
Intersoft WebTextEditor Documentation
Print Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : Print Property

Glossary Item Box

Specifies the image of Print command in main toolbar.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the image of Print command in main toolbar.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Print As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.Print = value

value = instance.Print
C#
[System.ComponentModel.DescriptionAttribute("Specifies the image of Print command in main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string Print {get; set;}
Delphi
public read-write property Print: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the image of Print command in main toolbar.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.DefaultValueAttribute()
public function get,set Print : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the image of Print command in main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_Print();
public: __property void set_Print(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the image of Print command in main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ Print {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


Quote Property

[image]
Intersoft WebTextEditor Documentation
Quote Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : Quote Property

Glossary Item Box

Specifies the image of Quote command in main toolbar.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the image of Quote command in main toolbar.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Quote As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.Quote = value

value = instance.Quote
C#
[System.ComponentModel.DescriptionAttribute("Specifies the image of Quote command in main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.string Quote {get; set;}
Delphi
public read-write property Quote: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the image of Quote command in main toolbar.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set Quote : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the image of Quote command in main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_Quote();
public: __property void set_Quote(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the image of Quote command in main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ Quote {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


Redo Property

[image]
Intersoft WebTextEditor Documentation
Redo Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : Redo Property

Glossary Item Box

Specifies the image of Redo command in main toolbar.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the image of Redo command in main toolbar.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property Redo As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.Redo = value

value = instance.Redo
C#
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Redo command in main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string Redo {get; set;}
Delphi
public read-write property Redo: System.String;
JScript
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the image of Redo command in main toolbar.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set Redo : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Redo command in main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_Redo();
public: __property void set_Redo(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Redo command in main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ Redo {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


RemoveLink Property

[image]
Intersoft WebTextEditor Documentation
RemoveLink Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : RemoveLink Property

Glossary Item Box

Specifies the image of Remove Link command in main toolbar.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.DescriptionAttribute("Specifies the image of Remove Link command in main toolbar.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property RemoveLink As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.RemoveLink = value

value = instance.RemoveLink
C#
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Remove Link command in main toolbar.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string RemoveLink {get; set;}
Delphi
public read-write property RemoveLink: System.String;
JScript
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.DescriptionAttribute("Specifies the image of Remove Link command in main toolbar.")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set RemoveLink : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Remove Link command in main toolbar.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_RemoveLink();
public: __property void set_RemoveLink(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Remove Link command in main toolbar.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ RemoveLink {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


Replace Property

[image]
Intersoft WebTextEditor Documentation
Replace Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : Replace Property

Glossary Item Box

Specifies the image of Replace command in main toolbar.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the image of Replace command in main toolbar.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Replace As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.Replace = value

value = instance.Replace
C#
[System.ComponentModel.DescriptionAttribute("Specifies the image of Replace command in main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.string Replace {get; set;}
Delphi
public read-write property Replace: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the image of Replace command in main toolbar.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set Replace : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the image of Replace command in main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_Replace();
public: __property void set_Replace(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the image of Replace command in main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ Replace {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


Save Property

[image]
Intersoft WebTextEditor Documentation
Save Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : Save Property

Glossary Item Box

Specifies the image of Save command in main toolbar.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the image of Save command in main toolbar.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Save As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.Save = value

value = instance.Save
C#
[System.ComponentModel.DescriptionAttribute("Specifies the image of Save command in main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.string Save {get; set;}
Delphi
public read-write property Save: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the image of Save command in main toolbar.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set Save : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the image of Save command in main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_Save();
public: __property void set_Save(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the image of Save command in main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ Save {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


SectionCollapse Property

[image]
Intersoft WebTextEditor Documentation
SectionCollapse Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : SectionCollapse Property

Glossary Item Box

Specifies the image used to indicate collapse state in section image header.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate collapse state in section image header.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property SectionCollapse As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.SectionCollapse = value

value = instance.SectionCollapse
C#
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate collapse state in section image header.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.string SectionCollapse {get; set;}
Delphi
public read-write property SectionCollapse: System.String;
JScript
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate collapse state in section image header.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set SectionCollapse : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate collapse state in section image header.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_SectionCollapse();
public: __property void set_SectionCollapse(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate collapse state in section image header.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ SectionCollapse {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


SectionExpand Property

[image]
Intersoft WebTextEditor Documentation
SectionExpand Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : SectionExpand Property

Glossary Item Box

Specifies the image used to indicate expand state in section image header.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate expand state in section image header.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property SectionExpand As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.SectionExpand = value

value = instance.SectionExpand
C#
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate expand state in section image header.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string SectionExpand {get; set;}
Delphi
public read-write property SectionExpand: System.String;
JScript
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate expand state in section image header.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set SectionExpand : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate expand state in section image header.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_SectionExpand();
public: __property void set_SectionExpand(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the image used to indicate expand state in section image header.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ SectionExpand {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


SelectDropdown Property

[image]
Intersoft WebTextEditor Documentation
SelectDropdown Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : SelectDropdown Property

Glossary Item Box

Specifies the image of Insert Select Dropdown item.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Select Dropdown item.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property SelectDropdown As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.SelectDropdown = value

value = instance.SelectDropdown
C#
[System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Select Dropdown item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string SelectDropdown {get; set;}
Delphi
public read-write property SelectDropdown: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Select Dropdown item.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.DefaultValueAttribute()
public function get,set SelectDropdown : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Select Dropdown item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_SelectDropdown();
public: __property void set_SelectDropdown(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Select Dropdown item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ SelectDropdown {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


SelectListbox Property

[image]
Intersoft WebTextEditor Documentation
SelectListbox Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : SelectListbox Property

Glossary Item Box

Specifies the image of Insert Select Listbox item.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Select Listbox item.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property SelectListbox As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.SelectListbox = value

value = instance.SelectListbox
C#
[System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Select Listbox item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string SelectListbox {get; set;}
Delphi
public read-write property SelectListbox: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Select Listbox item.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set SelectListbox : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Select Listbox item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_SelectListbox();
public: __property void set_SelectListbox(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the image of Insert Select Listbox item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ SelectListbox {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


SendMail Property

[image]
Intersoft WebTextEditor Documentation
SendMail Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : SendMail Property

Glossary Item Box

Specifies the image of Send Mail command in Preview toolbar.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the image of Send Mail command in Preview toolbar.")>
<System.ComponentModel.CategoryAttribute("Image Settings")>
Public Property SendMail As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.SendMail = value

value = instance.SendMail
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Send Mail command in Preview toolbar.")]
[System.ComponentModel.CategoryAttribute("Image Settings")]
public System.string SendMail {get; set;}
Delphi
public read-write property SendMail: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the image of Send Mail command in Preview toolbar.")
System.ComponentModel.CategoryAttribute("Image Settings")
public function get,set SendMail : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Send Mail command in Preview toolbar.")]
[System.ComponentModel.CategoryAttribute("Image Settings")]
public: __property System.string* get_SendMail();
public: __property void set_SendMail(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Send Mail command in Preview toolbar.")]
[System.ComponentModel.CategoryAttribute("Image Settings")]
public:
property System.String^ SendMail {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


SpellChecker Property

[image]
Intersoft WebTextEditor Documentation
SpellChecker Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : SpellChecker Property

Glossary Item Box

Specifies the image of Spell Checker command in main toolbar and footer row.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the image of Spell Checker command in main toolbar and footer row.")>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property SpellChecker As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.SpellChecker = value

value = instance.SpellChecker
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Spell Checker command in main toolbar and footer row.")]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string SpellChecker {get; set;}
Delphi
public read-write property SpellChecker: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the image of Spell Checker command in main toolbar and footer row.")
System.ComponentModel.CategoryAttribute("Image Settings")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set SpellChecker : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Spell Checker command in main toolbar and footer row.")]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_SpellChecker();
public: __property void set_SpellChecker(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Spell Checker command in main toolbar and footer row.")]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ SpellChecker {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


SplitCellHorizontal Property

[image]
Intersoft WebTextEditor Documentation
SplitCellHorizontal Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : SplitCellHorizontal Property

Glossary Item Box

Specifies the image of Split Cell Horizontal item.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.DescriptionAttribute("Specifies the image of Split Cell Horizontal item.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property SplitCellHorizontal As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.SplitCellHorizontal = value

value = instance.SplitCellHorizontal
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Split Cell Horizontal item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string SplitCellHorizontal {get; set;}
Delphi
public read-write property SplitCellHorizontal: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.DescriptionAttribute("Specifies the image of Split Cell Horizontal item.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set SplitCellHorizontal : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Split Cell Horizontal item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_SplitCellHorizontal();
public: __property void set_SplitCellHorizontal(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Split Cell Horizontal item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ SplitCellHorizontal {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


SplitCells Property

[image]
Intersoft WebTextEditor Documentation
SplitCells Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : SplitCells Property

Glossary Item Box

Specifies the image of Split Cells item.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the image of Split Cells item.")>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property SplitCells As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.SplitCells = value

value = instance.SplitCells
C#
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Split Cells item.")]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string SplitCells {get; set;}
Delphi
public read-write property SplitCells: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the image of Split Cells item.")
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set SplitCells : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Split Cells item.")]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_SplitCells();
public: __property void set_SplitCells(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Split Cells item.")]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ SplitCells {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


SplitCellVertical Property

[image]
Intersoft WebTextEditor Documentation
SplitCellVertical Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : SplitCellVertical Property

Glossary Item Box

Specifies the image of Split Cell Vertical item.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the image of Split Cell Vertical item.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property SplitCellVertical As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.SplitCellVertical = value

value = instance.SplitCellVertical
C#
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Split Cell Vertical item.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string SplitCellVertical {get; set;}
Delphi
public read-write property SplitCellVertical: System.String;
JScript
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the image of Split Cell Vertical item.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set SplitCellVertical : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Split Cell Vertical item.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_SplitCellVertical();
public: __property void set_SplitCellVertical(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Split Cell Vertical item.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ SplitCellVertical {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


Strikethrough Property

[image]
Intersoft WebTextEditor Documentation
Strikethrough Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : Strikethrough Property

Glossary Item Box

Specifies the image of Strikethrough command in main toolbar.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the image of Strikethrough command in main toolbar.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property Strikethrough As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.Strikethrough = value

value = instance.Strikethrough
C#
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Strikethrough command in main toolbar.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string Strikethrough {get; set;}
Delphi
public read-write property Strikethrough: System.String;
JScript
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the image of Strikethrough command in main toolbar.")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set Strikethrough : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Strikethrough command in main toolbar.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_Strikethrough();
public: __property void set_Strikethrough(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Strikethrough command in main toolbar.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ Strikethrough {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


Subscript Property

[image]
Intersoft WebTextEditor Documentation
Subscript Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : Subscript Property

Glossary Item Box

Specifies the image of Subscript command in main toolbar.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the image of Subscript command in main toolbar.")>
<System.ComponentModel.CategoryAttribute("Image Settings")>
Public Property Subscript As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.Subscript = value

value = instance.Subscript
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Subscript command in main toolbar.")]
[System.ComponentModel.CategoryAttribute("Image Settings")]
public System.string Subscript {get; set;}
Delphi
public read-write property Subscript: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the image of Subscript command in main toolbar.")
System.ComponentModel.CategoryAttribute("Image Settings")
public function get,set Subscript : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Subscript command in main toolbar.")]
[System.ComponentModel.CategoryAttribute("Image Settings")]
public: __property System.string* get_Subscript();
public: __property void set_Subscript(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Subscript command in main toolbar.")]
[System.ComponentModel.CategoryAttribute("Image Settings")]
public:
property System.String^ Subscript {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


Superscript Property

[image]
Intersoft WebTextEditor Documentation
Superscript Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : Superscript Property

Glossary Item Box

Specifies the image of Superscript command in main toolbar.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the image of Superscript command in main toolbar.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property Superscript As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.Superscript = value

value = instance.Superscript
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Superscript command in main toolbar.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string Superscript {get; set;}
Delphi
public read-write property Superscript: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the image of Superscript command in main toolbar.")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set Superscript : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Superscript command in main toolbar.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_Superscript();
public: __property void set_Superscript(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Superscript command in main toolbar.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ Superscript {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


TextArea Property

[image]
Intersoft WebTextEditor Documentation
TextArea Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : TextArea Property

Glossary Item Box

Specifies the image of Insert TextArea item.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the image of Insert TextArea item.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property TextArea As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.TextArea = value

value = instance.TextArea
C#
[System.ComponentModel.DescriptionAttribute("Specifies the image of Insert TextArea item.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string TextArea {get; set;}
Delphi
public read-write property TextArea: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the image of Insert TextArea item.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set TextArea : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the image of Insert TextArea item.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_TextArea();
public: __property void set_TextArea(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the image of Insert TextArea item.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ TextArea {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


TextHighlightColor Property

[image]
Intersoft WebTextEditor Documentation
TextHighlightColor Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : TextHighlightColor Property

Glossary Item Box

Specifies the image of Text Highlight Color command in main toolbar.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the image of Text Highlight Color command in main toolbar.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property TextHighlightColor As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.TextHighlightColor = value

value = instance.TextHighlightColor
C#
[System.ComponentModel.DescriptionAttribute("Specifies the image of Text Highlight Color command in main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.string TextHighlightColor {get; set;}
Delphi
public read-write property TextHighlightColor: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the image of Text Highlight Color command in main toolbar.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set TextHighlightColor : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the image of Text Highlight Color command in main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_TextHighlightColor();
public: __property void set_TextHighlightColor(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the image of Text Highlight Color command in main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ TextHighlightColor {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


Underline Property

[image]
Intersoft WebTextEditor Documentation
Underline Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : Underline Property

Glossary Item Box

Specifies the image of Underline command in main toolbar.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the image of Underline command in main toolbar.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Underline As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.Underline = value

value = instance.Underline
C#
[System.ComponentModel.DescriptionAttribute("Specifies the image of Underline command in main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string Underline {get; set;}
Delphi
public read-write property Underline: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the image of Underline command in main toolbar.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.DefaultValueAttribute()
public function get,set Underline : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the image of Underline command in main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_Underline();
public: __property void set_Underline(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the image of Underline command in main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ Underline {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


Undo Property

[image]
Intersoft WebTextEditor Documentation
Undo Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : Undo Property

Glossary Item Box

Specifies the image of Undo command in main toolbar.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the image of Undo command in main toolbar.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Undo As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.Undo = value

value = instance.Undo
C#
[System.ComponentModel.DescriptionAttribute("Specifies the image of Undo command in main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string Undo {get; set;}
Delphi
public read-write property Undo: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the image of Undo command in main toolbar.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.DefaultValueAttribute()
public function get,set Undo : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the image of Undo command in main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_Undo();
public: __property void set_Undo(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the image of Undo command in main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ Undo {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


Upload Property

[image]
Intersoft WebTextEditor Documentation
Upload Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : Upload Property

Glossary Item Box

Specifies the image of Upload command in Media Gallery toolbar.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the image of Upload command in Media Gallery toolbar.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Upload As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.Upload = value

value = instance.Upload
C#
[System.ComponentModel.DescriptionAttribute("Specifies the image of Upload command in Media Gallery toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string Upload {get; set;}
Delphi
public read-write property Upload: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the image of Upload command in Media Gallery toolbar.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.DefaultValueAttribute()
public function get,set Upload : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the image of Upload command in Media Gallery toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_Upload();
public: __property void set_Upload(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the image of Upload command in Media Gallery toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ Upload {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


UpperCase Property

[image]
Intersoft WebTextEditor Documentation
UpperCase Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : UpperCase Property

Glossary Item Box

Specifies the image of Upper Case item in Change Case dropdown menu.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the image of Upper Case item in Change Case dropdown menu.")>
Public Property UpperCase As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.UpperCase = value

value = instance.UpperCase
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Upper Case item in Change Case dropdown menu.")]
public System.string UpperCase {get; set;}
Delphi
public read-write property UpperCase: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the image of Upper Case item in Change Case dropdown menu.")
public function get,set UpperCase : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Upper Case item in Change Case dropdown menu.")]
public: __property System.string* get_UpperCase();
public: __property void set_UpperCase(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Upper Case item in Change Case dropdown menu.")]
public:
property System.String^ UpperCase {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


ZoomIn Property

[image]
Intersoft WebTextEditor Documentation
ZoomIn Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : ZoomIn Property

Glossary Item Box

Specifies the image of Zoom In command in Preview toolbar.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.DescriptionAttribute("Specifies the image of Zoom In command in Preview toolbar.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property ZoomIn As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.ZoomIn = value

value = instance.ZoomIn
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Zoom In command in Preview toolbar.")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string ZoomIn {get; set;}
Delphi
public read-write property ZoomIn: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.DescriptionAttribute("Specifies the image of Zoom In command in Preview toolbar.")
System.ComponentModel.DefaultValueAttribute()
public function get,set ZoomIn : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Zoom In command in Preview toolbar.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_ZoomIn();
public: __property void set_ZoomIn(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the image of Zoom In command in Preview toolbar.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ ZoomIn {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


ZoomOut Property

[image]
Intersoft WebTextEditor Documentation
ZoomOut Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : ZoomOut Property

Glossary Item Box

Specifies the image of Zoom Out command in Preview toolbar.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the image of Zoom Out command in Preview toolbar.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Image Settings")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property ZoomOut As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

instance.ZoomOut = value

value = instance.ZoomOut
C#
[System.ComponentModel.DescriptionAttribute("Specifies the image of Zoom Out command in Preview toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string ZoomOut {get; set;}
Delphi
public read-write property ZoomOut: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the image of Zoom Out command in Preview toolbar.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Image Settings")
System.ComponentModel.DefaultValueAttribute()
public function get,set ZoomOut : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the image of Zoom Out command in Preview toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_ZoomOut();
public: __property void set_ZoomOut(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the image of Zoom Out command in Preview toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Image Settings")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ ZoomOut {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


WebTextEditorLabel Class

[image]
Intersoft WebTextEditor Documentation
WebTextEditorLabel Class
Members See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorLabel Class

Glossary Item Box

A collection of WebTextEditor's mail merge label settings.

Object Model

WebTextEditorLabel Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebTextEditorLabel
   Inherits ISNet.WebUI.NamedObjectBase2
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorLabel
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebTextEditorLabel : ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
Delphi
public class WebTextEditorLabel = class(ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebTextEditorLabel extends ISNet.WebUI.NamedObjectBase2 implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebTextEditorLabel : public ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebTextEditorLabel : public ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.NamedObjectBase2
ISNet.WebUI.WebTextEditor.WebTextEditorLabel

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorLabel Members
ISNet.WebUI.WebTextEditor Namespace


WebTextEditorLabel Class Members

[image]
Intersoft WebTextEditor Documentation
WebTextEditorLabel Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorLabel Class

Glossary Item Box

The following tables list the members exposed by WebTextEditorLabel.

Public Constructors

 | Name | Description
Public Constructor | WebTextEditorLabel Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Collection | (Inherited from ISNet.WebUI.NamedObjectBase2)
Public Property | DataMember | Specifies the field in data context which represents the label.
Public Property | FormatString | Specifies the format string of the label.
Public Property | Label | Gets or sets the value of the MailMerge label.
Public Property | Name | (Inherited from ISNet.WebUI.NamedObjectBase2)
Public Property | Value |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

Protected Methods

 | Name | Description
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | IsInSerializationContext | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | OnItemAdd | (Inherited from ISNet.WebUI.NamedObjectBase2)
Protected Method | OnItemRemove | (Inherited from ISNet.WebUI.NamedObjectBase2)
Top

See Also

Reference

WebTextEditorLabel Class
ISNet.WebUI.WebTextEditor Namespace


WebTextEditorLabel Constructor

[image]
Intersoft WebTextEditor Documentation
WebTextEditorLabel Constructor
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorLabel Class : WebTextEditorLabel Constructor

Glossary Item Box

Overload List

Overload | Description
WebTextEditorLabel Constructor() |
WebTextEditorLabel Constructor(SerializationInfo,StreamingContext) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorLabel Class
WebTextEditorLabel Members


WebTextEditorLabel Constructor()

[image]
Intersoft WebTextEditor Documentation
WebTextEditorLabel Constructor()
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorLabel Class > WebTextEditorLabel Constructor : WebTextEditorLabel Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebTextEditorLabel()
C#
public WebTextEditorLabel()
Delphi
public WebTextEditorLabel();
JScript
public function WebTextEditorLabel();
Managed Extensions for C++
public: WebTextEditorLabel();
C++/CLI
public:
WebTextEditorLabel();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorLabel Class
WebTextEditorLabel Members
Overload List


WebTextEditorLabel Constructor(SerializationInfo,StreamingContext)

[image]
Intersoft WebTextEditor Documentation
WebTextEditorLabel Constructor(SerializationInfo,StreamingContext)
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorLabel Class > WebTextEditorLabel Constructor : WebTextEditorLabel Constructor(SerializationInfo,StreamingContext)

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

Dim instance As New WebTextEditorLabel(info, context)
C#
protected WebTextEditorLabel(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
protected WebTextEditorLabel(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
protected function WebTextEditorLabel(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
protected: WebTextEditorLabel(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
protected:
WebTextEditorLabel(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorLabel Class
WebTextEditorLabel Members
Overload List


WebTextEditorLabel Class Methods

[image]
Intersoft WebTextEditor Documentation
WebTextEditorLabel Class Methods
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorLabel Class

Glossary Item Box

For a list of all members of this type, see WebTextEditorLabel members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

Protected Methods

 | Name | Description
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | IsInSerializationContext | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | OnItemAdd | (Inherited from ISNet.WebUI.NamedObjectBase2)
Protected Method | OnItemRemove | (Inherited from ISNet.WebUI.NamedObjectBase2)
Top

See Also

Reference

WebTextEditorLabel Class
ISNet.WebUI.WebTextEditor Namespace


GetObjectData Method

[image]
Intersoft WebTextEditor Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorLabel Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorLabel
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorLabel Class
WebTextEditorLabel Members


WebTextEditorLabel Class Properties

[image]
Intersoft WebTextEditor Documentation
WebTextEditorLabel Class Properties
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorLabel Class

Glossary Item Box

For a list of all members of this type, see WebTextEditorLabel members.

Public Properties

 | Name | Description
Public Property | Collection | (Inherited from ISNet.WebUI.NamedObjectBase2)
Public Property | DataMember | Specifies the field in data context which represents the label.
Public Property | FormatString | Specifies the format string of the label.
Public Property | Label | Gets or sets the value of the MailMerge label.
Public Property | Name | (Inherited from ISNet.WebUI.NamedObjectBase2)
Public Property | Value |
Top

See Also

Reference

WebTextEditorLabel Class
ISNet.WebUI.WebTextEditor Namespace


DataMember Property

[image]
Intersoft WebTextEditor Documentation
DataMember Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorLabel Class : DataMember Property

Glossary Item Box

Specifies the field in data context which represents the label.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the field in data context which represents the label.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Mail Merge Label")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property DataMember As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorLabel
Dim value As System.String

instance.DataMember = value

value = instance.DataMember
C#
[System.ComponentModel.DescriptionAttribute("Specifies the field in data context which represents the label.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Mail Merge Label")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string DataMember {get; set;}
Delphi
public read-write property DataMember: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the field in data context which represents the label.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Mail Merge Label")
System.ComponentModel.DefaultValueAttribute()
public function get,set DataMember : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the field in data context which represents the label.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Mail Merge Label")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_DataMember();
public: __property void set_DataMember(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the field in data context which represents the label.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Mail Merge Label")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ DataMember {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorLabel Class
WebTextEditorLabel Members


FormatString Property

[image]
Intersoft WebTextEditor Documentation
FormatString Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorLabel Class : FormatString Property

Glossary Item Box

Specifies the format string of the label.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the format string of the label.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Mail Merge Label")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property FormatString As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorLabel
Dim value As System.String

instance.FormatString = value

value = instance.FormatString
C#
[System.ComponentModel.DescriptionAttribute("Specifies the format string of the label.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Mail Merge Label")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.string FormatString {get; set;}
Delphi
public read-write property FormatString: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the format string of the label.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Mail Merge Label")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set FormatString : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the format string of the label.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Mail Merge Label")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_FormatString();
public: __property void set_FormatString(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the format string of the label.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Mail Merge Label")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ FormatString {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorLabel Class
WebTextEditorLabel Members


Label Property

[image]
Intersoft WebTextEditor Documentation
Label Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorLabel Class : Label Property

Glossary Item Box

Gets or sets the value of the MailMerge label.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the value of the MailMerge label.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Mail Merge Label")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Label As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorLabel
Dim value As System.String

instance.Label = value

value = instance.Label
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the value of the MailMerge label.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Mail Merge Label")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string Label {get; set;}
Delphi
public read-write property Label: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the value of the MailMerge label.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Mail Merge Label")
System.ComponentModel.DefaultValueAttribute()
public function get,set Label : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the value of the MailMerge label.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Mail Merge Label")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_Label();
public: __property void set_Label(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the value of the MailMerge label.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Mail Merge Label")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ Label {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorLabel Class
WebTextEditorLabel Members


Value Property

[image]
Intersoft WebTextEditor Documentation
Value Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorLabel Class : Value Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.DescriptionAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Mail Merge Label")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.BrowsableAttribute(False)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property Value As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorLabel
Dim value As System.String

instance.Value = value

value = instance.Value
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Mail Merge Label")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BrowsableAttribute(false)]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string Value {get; set;}
Delphi
public read-write property Value: System.String;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.DescriptionAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Mail Merge Label")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.BrowsableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set Value : System.String
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Mail Merge Label")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BrowsableAttribute(false)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_Value();
public: __property void set_Value(
   System.string* value
);
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Mail Merge Label")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BrowsableAttribute(false)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ Value {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorLabel Class
WebTextEditorLabel Members


WebTextEditorLabelCollection Class

[image]
Intersoft WebTextEditor Documentation
WebTextEditorLabelCollection Class
Members See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorLabelCollection Class

Glossary Item Box

A collection of mail merge's label used by WebTextEditor.

Object Model

WebTextEditorLabelCollection Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebTextEditorLabelCollection
   Inherits ISNet.WebUI.ISGenericCollectionBase(Of WebTextEditorLabel)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorLabelCollection
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebTextEditorLabelCollection : ISNet.WebUI.ISGenericCollectionBase<WebTextEditorLabel>
Delphi
public class WebTextEditorLabelCollection = class(ISNet.WebUI.ISGenericCollectionBase)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebTextEditorLabelCollection extends ISNet.WebUI.ISGenericCollectionBase
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebTextEditorLabelCollection : public ISNet.WebUI.ISGenericCollectionBase<WebTextEditorLabel>
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebTextEditorLabelCollection : public ISNet.WebUI.ISGenericCollectionBase<WebTextEditorLabel>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
ISNet.WebUI.ISCollectionBase<T>
ISNet.WebUI.ISGenericCollectionBase<T>
ISNet.WebUI.WebTextEditor.WebTextEditorLabelCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorLabelCollection Members
ISNet.WebUI.WebTextEditor Namespace


WebTextEditorLabelCollection Class Members

[image]
Intersoft WebTextEditor Documentation
WebTextEditorLabelCollection Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorLabelCollection Class

Glossary Item Box

The following tables list the members exposed by WebTextEditorLabelCollection.

Public Constructors

 | Name | Description
Public Constructor | WebTextEditorLabelCollection Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | All | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

Protected Properties

 | Name | Description
Protected Property | Items | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CreateNewItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorLabel>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | GetNamedItem |
Public Method | GetObjectData | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | SerializerConstructor | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorLabel>)
Public Method | SetParent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

Protected Methods

 | Name | Description
Protected Method | ClearItems | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorLabel>)
Protected Method | CreateArray | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Protected Method | InsertItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorLabel>)
Protected Method | RemoveItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorLabel>)
Protected Method | SetItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorLabel>)
Top

See Also

Reference

WebTextEditorLabelCollection Class
ISNet.WebUI.WebTextEditor Namespace


WebTextEditorLabelCollection Constructor

[image]
Intersoft WebTextEditor Documentation
WebTextEditorLabelCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorLabelCollection Class : WebTextEditorLabelCollection Constructor

Glossary Item Box

Overload List

Overload | Description
WebTextEditorLabelCollection Constructor() |
WebTextEditorLabelCollection Constructor(SerializationInfo,StreamingContext) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorLabelCollection Class
WebTextEditorLabelCollection Members


WebTextEditorLabelCollection Constructor()

[image]
Intersoft WebTextEditor Documentation
WebTextEditorLabelCollection Constructor()
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorLabelCollection Class > WebTextEditorLabelCollection Constructor : WebTextEditorLabelCollection Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebTextEditorLabelCollection()
C#
public WebTextEditorLabelCollection()
Delphi
public WebTextEditorLabelCollection();
JScript
public function WebTextEditorLabelCollection();
Managed Extensions for C++
public: WebTextEditorLabelCollection();
C++/CLI
public:
WebTextEditorLabelCollection();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorLabelCollection Class
WebTextEditorLabelCollection Members
Overload List


WebTextEditorLabelCollection Constructor(SerializationInfo,StreamingContext)

[image]
Intersoft WebTextEditor Documentation
WebTextEditorLabelCollection Constructor(SerializationInfo,StreamingContext)
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorLabelCollection Class > WebTextEditorLabelCollection Constructor : WebTextEditorLabelCollection Constructor(SerializationInfo,StreamingContext)

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

Dim instance As New WebTextEditorLabelCollection(info, context)
C#
protected WebTextEditorLabelCollection(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
protected WebTextEditorLabelCollection(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
protected function WebTextEditorLabelCollection(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
protected: WebTextEditorLabelCollection(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
protected:
WebTextEditorLabelCollection(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorLabelCollection Class
WebTextEditorLabelCollection Members
Overload List


WebTextEditorLabelCollection Class Methods

[image]
Intersoft WebTextEditor Documentation
WebTextEditorLabelCollection Class Methods
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorLabelCollection Class

Glossary Item Box

For a list of all members of this type, see WebTextEditorLabelCollection members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CreateNewItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorLabel>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | GetNamedItem |
Public Method | GetObjectData | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | SerializerConstructor | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorLabel>)
Public Method | SetParent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

Protected Methods

 | Name | Description
Protected Method | ClearItems | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorLabel>)
Protected Method | CreateArray | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Protected Method | InsertItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorLabel>)
Protected Method | RemoveItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorLabel>)
Protected Method | SetItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorLabel>)
Top

See Also

Reference

WebTextEditorLabelCollection Class
ISNet.WebUI.WebTextEditor Namespace


GetNamedItem Method

[image]
Intersoft WebTextEditor Documentation
GetNamedItem Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorLabelCollection Class : GetNamedItem Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shadows Function GetNamedItem( _
   ByVal name As System.String _
) As WebTextEditorLabel
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorLabelCollection
Dim name As System.String
Dim value As WebTextEditorLabel

value = instance.GetNamedItem(name)
C#
public new WebTextEditorLabel GetNamedItem(
   System.string name
)
Delphi
public function GetNamedItem(
    name: System.String
): WebTextEditorLabel;
JScript
public hide function GetNamedItem(
   name : System.String
) : WebTextEditorLabel;
Managed Extensions for C++
public: new WebTextEditorLabel* GetNamedItem(
   System.string* name
)
C++/CLI
public:
new WebTextEditorLabel^ GetNamedItem(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorLabelCollection Class
WebTextEditorLabelCollection Members


WebTextEditorMailMergeArgs Class

[image]
Intersoft WebTextEditor Documentation
WebTextEditorMailMergeArgs Class
Members See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorMailMergeArgs Class

Glossary Item Box

Provides data for MailMerge event.

Object Model

WebTextEditorMailMergeArgs Class

Syntax

Visual Basic (Declaration)
Public Class WebTextEditorMailMergeArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMailMergeArgs
C#
public class WebTextEditorMailMergeArgs : System.EventArgs
Delphi
public class WebTextEditorMailMergeArgs = class(System.EventArgs)
JScript
public class WebTextEditorMailMergeArgs extends System.EventArgs
Managed Extensions for C++
public __gc class WebTextEditorMailMergeArgs : public System.EventArgs
C++/CLI
public ref class WebTextEditorMailMergeArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
ISNet.WebUI.WebTextEditor.WebTextEditorMailMergeArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMailMergeArgs Members
ISNet.WebUI.WebTextEditor Namespace


WebTextEditorMailMergeArgs Class Members

[image]
Intersoft WebTextEditor Documentation
WebTextEditorMailMergeArgs Class Members
See Also Properties Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorMailMergeArgs Class

Glossary Item Box

The following tables list the members exposed by WebTextEditorMailMergeArgs.

Public Constructors

 | Name | Description
Public Constructor | WebTextEditorMailMergeArgs Constructor |
Top

Public Properties

 | Name | Description
Public Property | MailMerge |
Top

See Also

Reference

WebTextEditorMailMergeArgs Class
ISNet.WebUI.WebTextEditor Namespace


WebTextEditorMailMergeArgs Constructor

[image]
Intersoft WebTextEditor Documentation
WebTextEditorMailMergeArgs Constructor
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMailMergeArgs Class : WebTextEditorMailMergeArgs Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebTextEditorMailMergeArgs()
C#
public WebTextEditorMailMergeArgs()
Delphi
public WebTextEditorMailMergeArgs();
JScript
public function WebTextEditorMailMergeArgs();
Managed Extensions for C++
public: WebTextEditorMailMergeArgs();
C++/CLI
public:
WebTextEditorMailMergeArgs();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMailMergeArgs Class
WebTextEditorMailMergeArgs Members


WebTextEditorMailMergeArgs Class Properties

[image]
Intersoft WebTextEditor Documentation
WebTextEditorMailMergeArgs Class Properties
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorMailMergeArgs Class

Glossary Item Box

For a list of all members of this type, see WebTextEditorMailMergeArgs members.

Public Properties

 | Name | Description
Public Property | MailMerge |
Top

See Also

Reference

WebTextEditorMailMergeArgs Class
ISNet.WebUI.WebTextEditor Namespace


MailMerge Property

[image]
Intersoft WebTextEditor Documentation
MailMerge Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMailMergeArgs Class : MailMerge Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property MailMerge As WebTextEditorMailMergeObject
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMailMergeArgs
Dim value As WebTextEditorMailMergeObject

instance.MailMerge = value

value = instance.MailMerge
C#
public WebTextEditorMailMergeObject MailMerge {get; set;}
Delphi
public read-write property MailMerge: WebTextEditorMailMergeObject;
JScript
public function get,set MailMerge : WebTextEditorMailMergeObject
Managed Extensions for C++
public: __property WebTextEditorMailMergeObject* get_MailMerge();
public: __property void set_MailMerge(
   WebTextEditorMailMergeObject* value
);
C++/CLI
public:
property WebTextEditorMailMergeObject^ MailMerge {
   WebTextEditorMailMergeObject^ get();
   void set (    WebTextEditorMailMergeObject^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMailMergeArgs Class
WebTextEditorMailMergeArgs Members


WebTextEditorMailMergeCompletedArgs Class

[image]
Intersoft WebTextEditor Documentation
WebTextEditorMailMergeCompletedArgs Class
Members See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorMailMergeCompletedArgs Class

Glossary Item Box

Provides data for MailMerge completed event.

Object Model

WebTextEditorMailMergeCompletedArgs Class

Syntax

Visual Basic (Declaration)
Public Class WebTextEditorMailMergeCompletedArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMailMergeCompletedArgs
C#
public class WebTextEditorMailMergeCompletedArgs : System.EventArgs
Delphi
public class WebTextEditorMailMergeCompletedArgs = class(System.EventArgs)
JScript
public class WebTextEditorMailMergeCompletedArgs extends System.EventArgs
Managed Extensions for C++
public __gc class WebTextEditorMailMergeCompletedArgs : public System.EventArgs
C++/CLI
public ref class WebTextEditorMailMergeCompletedArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
ISNet.WebUI.WebTextEditor.WebTextEditorMailMergeCompletedArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMailMergeCompletedArgs Members
ISNet.WebUI.WebTextEditor Namespace


WebTextEditorMailMergeCompletedArgs Class Members

[image]
Intersoft WebTextEditor Documentation
WebTextEditorMailMergeCompletedArgs Class Members
See Also Properties Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorMailMergeCompletedArgs Class

Glossary Item Box

The following tables list the members exposed by WebTextEditorMailMergeCompletedArgs.

Public Constructors

 | Name | Description
Public Constructor | WebTextEditorMailMergeCompletedArgs Constructor |
Top

Public Properties

 | Name | Description
Public Property | Data |
Top

See Also

Reference

WebTextEditorMailMergeCompletedArgs Class
ISNet.WebUI.WebTextEditor Namespace


WebTextEditorMailMergeCompletedArgs Constructor

[image]
Intersoft WebTextEditor Documentation
WebTextEditorMailMergeCompletedArgs Constructor
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMailMergeCompletedArgs Class : WebTextEditorMailMergeCompletedArgs Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebTextEditorMailMergeCompletedArgs()
C#
public WebTextEditorMailMergeCompletedArgs()
Delphi
public WebTextEditorMailMergeCompletedArgs();
JScript
public function WebTextEditorMailMergeCompletedArgs();
Managed Extensions for C++
public: WebTextEditorMailMergeCompletedArgs();
C++/CLI
public:
WebTextEditorMailMergeCompletedArgs();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMailMergeCompletedArgs Class
WebTextEditorMailMergeCompletedArgs Members


WebTextEditorMailMergeCompletedArgs Class Properties

[image]
Intersoft WebTextEditor Documentation
WebTextEditorMailMergeCompletedArgs Class Properties
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorMailMergeCompletedArgs Class

Glossary Item Box

For a list of all members of this type, see WebTextEditorMailMergeCompletedArgs members.

Public Properties

 | Name | Description
Public Property | Data |
Top

See Also

Reference

WebTextEditorMailMergeCompletedArgs Class
ISNet.WebUI.WebTextEditor Namespace


Data Property

[image]
Intersoft WebTextEditor Documentation
Data Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMailMergeCompletedArgs Class : Data Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Data As System.Collections.Generic.List(Of WebTextEditorMailMergeObject)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMailMergeCompletedArgs
Dim value As System.Collections.Generic.List(Of WebTextEditorMailMergeObject)

instance.Data = value

value = instance.Data
C#
public System.Collections.Generic.List<WebTextEditorMailMergeObject> Data {get; set;}
Delphi
public read-write property Data: System.Collections.Generic.List;
JScript
public function get,set Data : System.Collections.Generic.List
Managed Extensions for C++
public: __property System.Collections.Generic.List<WebTextEditorMailMergeObject*>* get_Data();
public: __property void set_Data(
   System.Collections.Generic.List<WebTextEditorMailMergeObject*>* value
);
C++/CLI
public:
property System.Collections.Generic.List<WebTextEditorMailMergeObject^>^ Data {
   System.Collections.Generic.List<WebTextEditorMailMergeObject^>^ get();
   void set (    System.Collections.Generic.List<WebTextEditorMailMergeObject^>^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMailMergeCompletedArgs Class
WebTextEditorMailMergeCompletedArgs Members


WebTextEditorMailMergeObject Class

[image]
Intersoft WebTextEditor Documentation
WebTextEditorMailMergeObject Class
Members See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorMailMergeObject Class

Glossary Item Box

Object Model

WebTextEditorMailMergeObject Class

Syntax

Visual Basic (Declaration)
Public Class WebTextEditorMailMergeObject
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMailMergeObject
C#
public class WebTextEditorMailMergeObject : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebTextEditorMailMergeObject = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
public class WebTextEditorMailMergeObject extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
public __gc class WebTextEditorMailMergeObject : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
public ref class WebTextEditorMailMergeObject : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebTextEditor.WebTextEditorMailMergeObject

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMailMergeObject Members
ISNet.WebUI.WebTextEditor Namespace


WebTextEditorMailMergeObject Class Members

[image]
Intersoft WebTextEditor Documentation
WebTextEditorMailMergeObject Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorMailMergeObject Class

Glossary Item Box

The following tables list the members exposed by WebTextEditorMailMergeObject.

Public Constructors

 | Name | Description
Public Constructor | WebTextEditorMailMergeObject Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | DataContext |
Public Property | Email |
Public Property | MailMerge |
Public Property | Subject |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

Protected Methods

 | Name | Description
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | IsInSerializationContext | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebTextEditorMailMergeObject Class
ISNet.WebUI.WebTextEditor Namespace


WebTextEditorMailMergeObject Constructor

[image]
Intersoft WebTextEditor Documentation
WebTextEditorMailMergeObject Constructor
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMailMergeObject Class : WebTextEditorMailMergeObject Constructor

Glossary Item Box

Overload List

Overload | Description
WebTextEditorMailMergeObject Constructor() |
WebTextEditorMailMergeObject Constructor(SerializationInfo,StreamingContext) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMailMergeObject Class
WebTextEditorMailMergeObject Members


WebTextEditorMailMergeObject Constructor()

[image]
Intersoft WebTextEditor Documentation
WebTextEditorMailMergeObject Constructor()
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMailMergeObject Class > WebTextEditorMailMergeObject Constructor : WebTextEditorMailMergeObject Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebTextEditorMailMergeObject()
C#
public WebTextEditorMailMergeObject()
Delphi
public WebTextEditorMailMergeObject();
JScript
public function WebTextEditorMailMergeObject();
Managed Extensions for C++
public: WebTextEditorMailMergeObject();
C++/CLI
public:
WebTextEditorMailMergeObject();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMailMergeObject Class
WebTextEditorMailMergeObject Members
Overload List


WebTextEditorMailMergeObject Constructor(SerializationInfo,StreamingContext)

[image]
Intersoft WebTextEditor Documentation
WebTextEditorMailMergeObject Constructor(SerializationInfo,StreamingContext)
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMailMergeObject Class > WebTextEditorMailMergeObject Constructor : WebTextEditorMailMergeObject Constructor(SerializationInfo,StreamingContext)

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

Dim instance As New WebTextEditorMailMergeObject(info, context)
C#
protected WebTextEditorMailMergeObject(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
protected WebTextEditorMailMergeObject(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
protected function WebTextEditorMailMergeObject(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
protected: WebTextEditorMailMergeObject(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
protected:
WebTextEditorMailMergeObject(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMailMergeObject Class
WebTextEditorMailMergeObject Members
Overload List


WebTextEditorMailMergeObject Class Methods

[image]
Intersoft WebTextEditor Documentation
WebTextEditorMailMergeObject Class Methods
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorMailMergeObject Class

Glossary Item Box

For a list of all members of this type, see WebTextEditorMailMergeObject members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

Protected Methods

 | Name | Description
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | IsInSerializationContext | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebTextEditorMailMergeObject Class
ISNet.WebUI.WebTextEditor Namespace


GetObjectData Method

[image]
Intersoft WebTextEditor Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMailMergeObject Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMailMergeObject
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMailMergeObject Class
WebTextEditorMailMergeObject Members


WebTextEditorMailMergeObject Class Properties

[image]
Intersoft WebTextEditor Documentation
WebTextEditorMailMergeObject Class Properties
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorMailMergeObject Class

Glossary Item Box

For a list of all members of this type, see WebTextEditorMailMergeObject members.

Public Properties

 | Name | Description
Public Property | DataContext |
Public Property | Email |
Public Property | MailMerge |
Public Property | Subject |
Top

See Also

Reference

WebTextEditorMailMergeObject Class
ISNet.WebUI.WebTextEditor Namespace


DataContext Property

[image]
Intersoft WebTextEditor Documentation
DataContext Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMailMergeObject Class : DataContext Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property DataContext As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMailMergeObject
Dim value As System.Object

instance.DataContext = value

value = instance.DataContext
C#
public System.object DataContext {get; set;}
Delphi
public read-write property DataContext: System.TObject;
JScript
public function get,set DataContext : System.Object
Managed Extensions for C++
public: __property System.Object* get_DataContext();
public: __property void set_DataContext(
   System.Object* value
);
C++/CLI
public:
property System.Object^ DataContext {
   System.Object^ get();
   void set (    System.Object^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMailMergeObject Class
WebTextEditorMailMergeObject Members


Email Property

[image]
Intersoft WebTextEditor Documentation
Email Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMailMergeObject Class : Email Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Email As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMailMergeObject
Dim value As System.String

instance.Email = value

value = instance.Email
C#
public System.string Email {get; set;}
Delphi
public read-write property Email: System.String;
JScript
public function get,set Email : System.String
Managed Extensions for C++
public: __property System.string* get_Email();
public: __property void set_Email(
   System.string* value
);
C++/CLI
public:
property System.String^ Email {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMailMergeObject Class
WebTextEditorMailMergeObject Members


MailMerge Property

[image]
Intersoft WebTextEditor Documentation
MailMerge Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMailMergeObject Class : MailMerge Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property MailMerge As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMailMergeObject
Dim value As System.String

instance.MailMerge = value

value = instance.MailMerge
C#
public System.string MailMerge {get; set;}
Delphi
public read-write property MailMerge: System.String;
JScript
public function get,set MailMerge : System.String
Managed Extensions for C++
public: __property System.string* get_MailMerge();
public: __property void set_MailMerge(
   System.string* value
);
C++/CLI
public:
property System.String^ MailMerge {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMailMergeObject Class
WebTextEditorMailMergeObject Members


Subject Property

[image]
Intersoft WebTextEditor Documentation
Subject Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMailMergeObject Class : Subject Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Subject As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMailMergeObject
Dim value As System.String

instance.Subject = value

value = instance.Subject
C#
public System.string Subject {get; set;}
Delphi
public read-write property Subject: System.String;
JScript
public function get,set Subject : System.String
Managed Extensions for C++
public: __property System.string* get_Subject();
public: __property void set_Subject(
   System.string* value
);
C++/CLI
public:
property System.String^ Subject {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMailMergeObject Class
WebTextEditorMailMergeObject Members


WebTextEditorMailMergeSettings Class

[image]
Intersoft WebTextEditor Documentation
WebTextEditorMailMergeSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorMailMergeSettings Class

Glossary Item Box

A collection of WebTextEditor's mail merge settings.

Object Model

WebTextEditorMailMergeSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebTextEditorMailMergeSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMailMergeSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebTextEditorMailMergeSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebTextEditorMailMergeSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebTextEditorMailMergeSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebTextEditorMailMergeSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebTextEditorMailMergeSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebTextEditor.WebTextEditorMailMergeSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMailMergeSettings Members
ISNet.WebUI.WebTextEditor Namespace


WebTextEditorMailMergeSettings Class Members

[image]
Intersoft WebTextEditor Documentation
WebTextEditorMailMergeSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorMailMergeSettings Class

Glossary Item Box

The following tables list the members exposed by WebTextEditorMailMergeSettings.

Public Constructors

 | Name | Description
Public Constructor | WebTextEditorMailMergeSettings Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | AutomaticSendMail | Specifies whether or not the mail will be sent automatically by WebTextEditor using built-in mechanism.
Public Property | EmailField | Specifies the field in data context that represent the emails of recipients.
Public Property | EnableMailMerge | Specifies whether or not Mail Merge should be enabled.
Public Property | From | Specifies the sender email.
Public Property | IsHTML | Specifies whether or not the content will be sent as HTML-formatted email.
Public Property | Labels | Specifies the labels collection of mail merge.
Public Property | MailPriority | Specifies the priority of the email.
Public Property | Recipients |
Public Property | SMTP | Specifies the SMTP server.
Public Property | SubjectExpression | Specifies the subject expression of the email.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

Protected Methods

 | Name | Description
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | IsInSerializationContext | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebTextEditorMailMergeSettings Class
ISNet.WebUI.WebTextEditor Namespace


WebTextEditorMailMergeSettings Constructor

[image]
Intersoft WebTextEditor Documentation
WebTextEditorMailMergeSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMailMergeSettings Class : WebTextEditorMailMergeSettings Constructor

Glossary Item Box

Overload List

Overload | Description
WebTextEditorMailMergeSettings Constructor() |
WebTextEditorMailMergeSettings Constructor(SerializationInfo,StreamingContext) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMailMergeSettings Class
WebTextEditorMailMergeSettings Members


WebTextEditorMailMergeSettings Constructor()

[image]
Intersoft WebTextEditor Documentation
WebTextEditorMailMergeSettings Constructor()
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMailMergeSettings Class > WebTextEditorMailMergeSettings Constructor : WebTextEditorMailMergeSettings Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebTextEditorMailMergeSettings()
C#
public WebTextEditorMailMergeSettings()
Delphi
public WebTextEditorMailMergeSettings();
JScript
public function WebTextEditorMailMergeSettings();
Managed Extensions for C++
public: WebTextEditorMailMergeSettings();
C++/CLI
public:
WebTextEditorMailMergeSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMailMergeSettings Class
WebTextEditorMailMergeSettings Members
Overload List


WebTextEditorMailMergeSettings Constructor(SerializationInfo,StreamingContext)

[image]
Intersoft WebTextEditor Documentation
WebTextEditorMailMergeSettings Constructor(SerializationInfo,StreamingContext)
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMailMergeSettings Class > WebTextEditorMailMergeSettings Constructor : WebTextEditorMailMergeSettings Constructor(SerializationInfo,StreamingContext)

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

Dim instance As New WebTextEditorMailMergeSettings(info, context)
C#
protected WebTextEditorMailMergeSettings(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
protected WebTextEditorMailMergeSettings(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
protected function WebTextEditorMailMergeSettings(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
protected: WebTextEditorMailMergeSettings(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
protected:
WebTextEditorMailMergeSettings(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMailMergeSettings Class
WebTextEditorMailMergeSettings Members
Overload List


WebTextEditorMailMergeSettings Class Methods

[image]
Intersoft WebTextEditor Documentation
WebTextEditorMailMergeSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorMailMergeSettings Class

Glossary Item Box

For a list of all members of this type, see WebTextEditorMailMergeSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

Protected Methods

 | Name | Description
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | IsInSerializationContext | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebTextEditorMailMergeSettings Class
ISNet.WebUI.WebTextEditor Namespace


GetObjectData Method

[image]
Intersoft WebTextEditor Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMailMergeSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMailMergeSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMailMergeSettings Class
WebTextEditorMailMergeSettings Members


WebTextEditorMailMergeSettings Class Properties

[image]
Intersoft WebTextEditor Documentation
WebTextEditorMailMergeSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorMailMergeSettings Class

Glossary Item Box

For a list of all members of this type, see WebTextEditorMailMergeSettings members.

Public Properties

 | Name | Description
Public Property | AutomaticSendMail | Specifies whether or not the mail will be sent automatically by WebTextEditor using built-in mechanism.
Public Property | EmailField | Specifies the field in data context that represent the emails of recipients.
Public Property | EnableMailMerge | Specifies whether or not Mail Merge should be enabled.
Public Property | From | Specifies the sender email.
Public Property | IsHTML | Specifies whether or not the content will be sent as HTML-formatted email.
Public Property | Labels | Specifies the labels collection of mail merge.
Public Property | MailPriority | Specifies the priority of the email.
Public Property | Recipients |
Public Property | SMTP | Specifies the SMTP server.
Public Property | SubjectExpression | Specifies the subject expression of the email.
Top

See Also

Reference

WebTextEditorMailMergeSettings Class
ISNet.WebUI.WebTextEditor Namespace


AutomaticSendMail Property

[image]
Intersoft WebTextEditor Documentation
AutomaticSendMail Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMailMergeSettings Class : AutomaticSendMail Property

Glossary Item Box

Specifies whether or not the mail will be sent automatically by WebTextEditor using built-in mechanism.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether or not the mail will be sent automatically by WebTextEditor using built-in mechanism.")>
<System.ComponentModel.CategoryAttribute("Mail Settings")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property AutomaticSendMail As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMailMergeSettings
Dim value As System.Boolean

instance.AutomaticSendMail = value

value = instance.AutomaticSendMail
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not the mail will be sent automatically by WebTextEditor using built-in mechanism.")]
[System.ComponentModel.CategoryAttribute("Mail Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool AutomaticSendMail {get; set;}
Delphi
public read-write property AutomaticSendMail: System.Boolean;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether or not the mail will be sent automatically by WebTextEditor using built-in mechanism.")
System.ComponentModel.CategoryAttribute("Mail Settings")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set AutomaticSendMail : System.boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not the mail will be sent automatically by WebTextEditor using built-in mechanism.")]
[System.ComponentModel.CategoryAttribute("Mail Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_AutomaticSendMail();
public: __property void set_AutomaticSendMail(
   System.bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not the mail will be sent automatically by WebTextEditor using built-in mechanism.")]
[System.ComponentModel.CategoryAttribute("Mail Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool AutomaticSendMail {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMailMergeSettings Class
WebTextEditorMailMergeSettings Members


EmailField Property

[image]
Intersoft WebTextEditor Documentation
EmailField Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMailMergeSettings Class : EmailField Property

Glossary Item Box

Specifies the field in data context that represent the emails of recipients.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Mail Merge")>
<System.ComponentModel.DescriptionAttribute("Specifies the field in data context that represent the emails of recipients.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property EmailField As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMailMergeSettings
Dim value As System.String

instance.EmailField = value

value = instance.EmailField
C#
[System.ComponentModel.CategoryAttribute("Mail Merge")]
[System.ComponentModel.DescriptionAttribute("Specifies the field in data context that represent the emails of recipients.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string EmailField {get; set;}
Delphi
public read-write property EmailField: System.String;
JScript
System.ComponentModel.CategoryAttribute("Mail Merge")
System.ComponentModel.DescriptionAttribute("Specifies the field in data context that represent the emails of recipients.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set EmailField : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Mail Merge")]
[System.ComponentModel.DescriptionAttribute("Specifies the field in data context that represent the emails of recipients.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_EmailField();
public: __property void set_EmailField(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Mail Merge")]
[System.ComponentModel.DescriptionAttribute("Specifies the field in data context that represent the emails of recipients.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ EmailField {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMailMergeSettings Class
WebTextEditorMailMergeSettings Members


EnableMailMerge Property

[image]
Intersoft WebTextEditor Documentation
EnableMailMerge Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMailMergeSettings Class : EnableMailMerge Property

Glossary Item Box

Specifies whether or not Mail Merge should be enabled.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies whether or not Mail Merge should be enabled.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Mail Merge")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property EnableMailMerge As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMailMergeSettings
Dim value As System.Boolean

instance.EnableMailMerge = value

value = instance.EnableMailMerge
C#
[System.ComponentModel.DescriptionAttribute("Specifies whether or not Mail Merge should be enabled.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Mail Merge")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.bool EnableMailMerge {get; set;}
Delphi
public read-write property EnableMailMerge: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Specifies whether or not Mail Merge should be enabled.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Mail Merge")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set EnableMailMerge : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies whether or not Mail Merge should be enabled.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Mail Merge")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.bool get_EnableMailMerge();
public: __property void set_EnableMailMerge(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies whether or not Mail Merge should be enabled.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Mail Merge")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.bool EnableMailMerge {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is False.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMailMergeSettings Class
WebTextEditorMailMergeSettings Members


From Property

[image]
Intersoft WebTextEditor Documentation
From Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMailMergeSettings Class : From Property

Glossary Item Box

Specifies the sender email.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the sender email.")>
<System.ComponentModel.CategoryAttribute("Mail Settings")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property From As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMailMergeSettings
Dim value As System.String

instance.From = value

value = instance.From
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the sender email.")]
[System.ComponentModel.CategoryAttribute("Mail Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.string From {get; set;}
Delphi
public read-write property From: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the sender email.")
System.ComponentModel.CategoryAttribute("Mail Settings")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set From : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the sender email.")]
[System.ComponentModel.CategoryAttribute("Mail Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_From();
public: __property void set_From(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the sender email.")]
[System.ComponentModel.CategoryAttribute("Mail Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ From {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMailMergeSettings Class
WebTextEditorMailMergeSettings Members


IsHTML Property

[image]
Intersoft WebTextEditor Documentation
IsHTML Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMailMergeSettings Class : IsHTML Property

Glossary Item Box

Specifies whether or not the content will be sent as HTML-formatted email.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Mail Settings")>
<System.ComponentModel.DescriptionAttribute("Specifies whether or not the content will be sent as HTML-formatted email.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property IsHTML As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMailMergeSettings
Dim value As System.Boolean

instance.IsHTML = value

value = instance.IsHTML
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Mail Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not the content will be sent as HTML-formatted email.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.bool IsHTML {get; set;}
Delphi
public read-write property IsHTML: System.Boolean;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Mail Settings")
System.ComponentModel.DescriptionAttribute("Specifies whether or not the content will be sent as HTML-formatted email.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set IsHTML : System.boolean
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Mail Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not the content will be sent as HTML-formatted email.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.bool get_IsHTML();
public: __property void set_IsHTML(
   System.bool value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Mail Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not the content will be sent as HTML-formatted email.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.bool IsHTML {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is True.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMailMergeSettings Class
WebTextEditorMailMergeSettings Members


Labels Property

[image]
Intersoft WebTextEditor Documentation
Labels Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMailMergeSettings Class : Labels Property

Glossary Item Box

Specifies the labels collection of mail merge.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Mail Merge")>
<System.ComponentModel.DescriptionAttribute("Specifies the labels collection of mail merge.")>
<ISNet.Serialization.BinarySerializableAttribute("setLabels")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebTextEditor, Version=1.0.1000.9, Culture=neutral, PublicKeyToken=b1f2a8511635667a")>
Public ReadOnly Property Labels As WebTextEditorLabelCollection
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMailMergeSettings
Dim value As WebTextEditorLabelCollection

value = instance.Labels
C#
[System.ComponentModel.CategoryAttribute("Mail Merge")]
[System.ComponentModel.DescriptionAttribute("Specifies the labels collection of mail merge.")]
[ISNet.Serialization.BinarySerializableAttribute("setLabels")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebTextEditor, Version=1.0.1000.9, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
public WebTextEditorLabelCollection Labels {get;}
Delphi
public read-only property Labels: WebTextEditorLabelCollection;
JScript
System.ComponentModel.CategoryAttribute("Mail Merge")
System.ComponentModel.DescriptionAttribute("Specifies the labels collection of mail merge.")
ISNet.Serialization.BinarySerializableAttribute("setLabels")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebTextEditor, Version=1.0.1000.9, Culture=neutral, PublicKeyToken=b1f2a8511635667a")
public function get Labels : WebTextEditorLabelCollection
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Mail Merge")]
[System.ComponentModel.DescriptionAttribute("Specifies the labels collection of mail merge.")]
[ISNet.Serialization.BinarySerializableAttribute("setLabels")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebTextEditor, Version=1.0.1000.9, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
public: __property WebTextEditorLabelCollection* get_Labels();
C++/CLI
[System.ComponentModel.CategoryAttribute("Mail Merge")]
[System.ComponentModel.DescriptionAttribute("Specifies the labels collection of mail merge.")]
[ISNet.Serialization.BinarySerializableAttribute("setLabels")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebTextEditor, Version=1.0.1000.9, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
public:
property WebTextEditorLabelCollection^ Labels {
   WebTextEditorLabelCollection^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMailMergeSettings Class
WebTextEditorMailMergeSettings Members


MailPriority Property

[image]
Intersoft WebTextEditor Documentation
MailPriority Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMailMergeSettings Class : MailPriority Property

Glossary Item Box

Specifies the priority of the email.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Mail Settings")>
<System.ComponentModel.DescriptionAttribute("Specifies the priority of the email.")>
Public Property MailPriority As System.Net.Mail.MailPriority
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMailMergeSettings
Dim value As System.Net.Mail.MailPriority

instance.MailPriority = value

value = instance.MailPriority
C#
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Mail Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the priority of the email.")]
public System.Net.Mail.MailPriority MailPriority {get; set;}
Delphi
public read-write property MailPriority: System.Net.Mail.MailPriority;
JScript
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Mail Settings")
System.ComponentModel.DescriptionAttribute("Specifies the priority of the email.")
public function get,set MailPriority : System.Net.Mail.MailPriority
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Mail Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the priority of the email.")]
public: __property System.Net.Mail.MailPriority get_MailPriority();
public: __property void set_MailPriority(
   System.Net.Mail.MailPriority value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Mail Settings")]
[System.ComponentModel.DescriptionAttribute("Specifies the priority of the email.")]
public:
property System.Net.Mail.MailPriority MailPriority {
   System.Net.Mail.MailPriority get();
   void set (    System.Net.Mail.MailPriority value);
}

Property Value

The default value is Normal.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMailMergeSettings Class
WebTextEditorMailMergeSettings Members


Recipients Property

[image]
Intersoft WebTextEditor Documentation
Recipients Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMailMergeSettings Class : Recipients Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
Public Property Recipients As System.Collections.IEnumerable
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMailMergeSettings
Dim value As System.Collections.IEnumerable

instance.Recipients = value

value = instance.Recipients
C#
[System.ComponentModel.BrowsableAttribute(false)]
public System.Collections.IEnumerable Recipients {get; set;}
Delphi
public read-write property Recipients: System.Collections.IEnumerable;
JScript
System.ComponentModel.BrowsableAttribute()
public function get,set Recipients : System.Collections.IEnumerable
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
public: __property System.Collections.IEnumerable* get_Recipients();
public: __property void set_Recipients(
   System.Collections.IEnumerable* value
);
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
public:
property System.Collections.IEnumerable^ Recipients {
   System.Collections.IEnumerable^ get();
   void set (    System.Collections.IEnumerable^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMailMergeSettings Class
WebTextEditorMailMergeSettings Members


SMTP Property

[image]
Intersoft WebTextEditor Documentation
SMTP Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMailMergeSettings Class : SMTP Property

Glossary Item Box

Specifies the SMTP server.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Mail Settings")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the SMTP server.")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property SMTP As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMailMergeSettings
Dim value As System.String

instance.SMTP = value

value = instance.SMTP
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Mail Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the SMTP server.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string SMTP {get; set;}
Delphi
public read-write property SMTP: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Mail Settings")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the SMTP server.")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set SMTP : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Mail Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the SMTP server.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_SMTP();
public: __property void set_SMTP(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Mail Settings")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the SMTP server.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ SMTP {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMailMergeSettings Class
WebTextEditorMailMergeSettings Members


SubjectExpression Property

[image]
Intersoft WebTextEditor Documentation
SubjectExpression Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMailMergeSettings Class : SubjectExpression Property

Glossary Item Box

Specifies the subject expression of the email.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Mail Merge")>
<System.ComponentModel.DescriptionAttribute("Specifies the subject expression of the email.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property SubjectExpression As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMailMergeSettings
Dim value As System.String

instance.SubjectExpression = value

value = instance.SubjectExpression
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Mail Merge")]
[System.ComponentModel.DescriptionAttribute("Specifies the subject expression of the email.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.string SubjectExpression {get; set;}
Delphi
public read-write property SubjectExpression: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Mail Merge")
System.ComponentModel.DescriptionAttribute("Specifies the subject expression of the email.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set SubjectExpression : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Mail Merge")]
[System.ComponentModel.DescriptionAttribute("Specifies the subject expression of the email.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_SubjectExpression();
public: __property void set_SubjectExpression(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Mail Merge")]
[System.ComponentModel.DescriptionAttribute("Specifies the subject expression of the email.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ SubjectExpression {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMailMergeSettings Class
WebTextEditorMailMergeSettings Members


WebTextEditorMedia Class

[image]
Intersoft WebTextEditor Documentation
WebTextEditorMedia Class
Members See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorMedia Class

Glossary Item Box

A collection of members in WebTextEditor's media.

Object Model

WebTextEditorMedia Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebTextEditorMedia
   Inherits ISNet.WebUI.NamedObjectBase2
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMedia
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebTextEditorMedia : ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
Delphi
public class WebTextEditorMedia = class(ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebTextEditorMedia extends ISNet.WebUI.NamedObjectBase2 implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebTextEditorMedia : public ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebTextEditorMedia : public ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.NamedObjectBase2
ISNet.WebUI.WebTextEditor.WebTextEditorMedia

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMedia Members
ISNet.WebUI.WebTextEditor Namespace


WebTextEditorMedia Class Members

[image]
Intersoft WebTextEditor Documentation
WebTextEditorMedia Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorMedia Class

Glossary Item Box

The following tables list the members exposed by WebTextEditorMedia.

Public Constructors

 | Name | Description
Public Constructor | WebTextEditorMedia Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Alignment | Specifies the extension of the media.
Public Property | Caption | Specifies the caption of the media.
Public Property | Collection | (Inherited from ISNet.WebUI.NamedObjectBase2)
Public Property | DateModified | Specifies the date modified of the media.
Public Property | Description | Specifies the description of the media.
Public Property | Extension | Specifies the extension of the media.
Public Property | FileName | Specifies the file name of the media.
Public Property | Height | Specifies the size of the media.
Public Property | LinkURL | Specifies the link url of the media.
Public Property | Name | Overridden. Specifies the name of the resource.
Public Property | PhysicalPath | Specifies the physical path of the media.
Public Property | Size | Specifies the size of the media.
Public Property | Title | Specifies the tooltip text of the media.
Public Property | UseFrame | Specifies whether or not the added media should use caption frame.
Public Property | VirtualPath | Specifies the virtual path of the media.
Public Property | Width | Specifies the size of the media.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

Protected Methods

 | Name | Description
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | IsInSerializationContext | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | OnItemAdd | (Inherited from ISNet.WebUI.NamedObjectBase2)
Protected Method | OnItemRemove | (Inherited from ISNet.WebUI.NamedObjectBase2)
Top

See Also

Reference

WebTextEditorMedia Class
ISNet.WebUI.WebTextEditor Namespace


WebTextEditorMedia Constructor

[image]
Intersoft WebTextEditor Documentation
WebTextEditorMedia Constructor
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMedia Class : WebTextEditorMedia Constructor

Glossary Item Box

Overload List

Overload | Description
WebTextEditorMedia Constructor() |
WebTextEditorMedia Constructor(SerializationInfo,StreamingContext) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMedia Class
WebTextEditorMedia Members


WebTextEditorMedia Constructor()

[image]
Intersoft WebTextEditor Documentation
WebTextEditorMedia Constructor()
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMedia Class > WebTextEditorMedia Constructor : WebTextEditorMedia Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebTextEditorMedia()
C#
public WebTextEditorMedia()
Delphi
public WebTextEditorMedia();
JScript
public function WebTextEditorMedia();
Managed Extensions for C++
public: WebTextEditorMedia();
C++/CLI
public:
WebTextEditorMedia();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMedia Class
WebTextEditorMedia Members
Overload List


WebTextEditorMedia Constructor(SerializationInfo,StreamingContext)

[image]
Intersoft WebTextEditor Documentation
WebTextEditorMedia Constructor(SerializationInfo,StreamingContext)
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMedia Class > WebTextEditorMedia Constructor : WebTextEditorMedia Constructor(SerializationInfo,StreamingContext)

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

Dim instance As New WebTextEditorMedia(info, context)
C#
protected WebTextEditorMedia(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
protected WebTextEditorMedia(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
protected function WebTextEditorMedia(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
protected: WebTextEditorMedia(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
protected:
WebTextEditorMedia(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMedia Class
WebTextEditorMedia Members
Overload List


WebTextEditorMedia Class Methods

[image]
Intersoft WebTextEditor Documentation
WebTextEditorMedia Class Methods
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorMedia Class

Glossary Item Box

For a list of all members of this type, see WebTextEditorMedia members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

Protected Methods

 | Name | Description
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | IsInSerializationContext | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | OnItemAdd | (Inherited from ISNet.WebUI.NamedObjectBase2)
Protected Method | OnItemRemove | (Inherited from ISNet.WebUI.NamedObjectBase2)
Top

See Also

Reference

WebTextEditorMedia Class
ISNet.WebUI.WebTextEditor Namespace


GetObjectData Method

[image]
Intersoft WebTextEditor Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMedia Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMedia
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMedia Class
WebTextEditorMedia Members


WebTextEditorMedia Class Properties

[image]
Intersoft WebTextEditor Documentation
WebTextEditorMedia Class Properties
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorMedia Class

Glossary Item Box

For a list of all members of this type, see WebTextEditorMedia members.

Public Properties

 | Name | Description
Public Property | Alignment | Specifies the extension of the media.
Public Property | Caption | Specifies the caption of the media.
Public Property | Collection | (Inherited from ISNet.WebUI.NamedObjectBase2)
Public Property | DateModified | Specifies the date modified of the media.
Public Property | Description | Specifies the description of the media.
Public Property | Extension | Specifies the extension of the media.
Public Property | FileName | Specifies the file name of the media.
Public Property | Height | Specifies the size of the media.
Public Property | LinkURL | Specifies the link url of the media.
Public Property | Name | Overridden. Specifies the name of the resource.
Public Property | PhysicalPath | Specifies the physical path of the media.
Public Property | Size | Specifies the size of the media.
Public Property | Title | Specifies the tooltip text of the media.
Public Property | UseFrame | Specifies whether or not the added media should use caption frame.
Public Property | VirtualPath | Specifies the virtual path of the media.
Public Property | Width | Specifies the size of the media.
Top

See Also

Reference

WebTextEditorMedia Class
ISNet.WebUI.WebTextEditor Namespace


Alignment Property

[image]
Intersoft WebTextEditor Documentation
Alignment Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMedia Class : Alignment Property

Glossary Item Box

Specifies the extension of the media.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the extension of the media.")>
<System.ComponentModel.CategoryAttribute("Media")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property Alignment As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMedia
Dim value As System.String

instance.Alignment = value

value = instance.Alignment
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the extension of the media.")]
[System.ComponentModel.CategoryAttribute("Media")]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string Alignment {get; set;}
Delphi
public read-write property Alignment: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the extension of the media.")
System.ComponentModel.CategoryAttribute("Media")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set Alignment : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the extension of the media.")]
[System.ComponentModel.CategoryAttribute("Media")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_Alignment();
public: __property void set_Alignment(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the extension of the media.")]
[System.ComponentModel.CategoryAttribute("Media")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ Alignment {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMedia Class
WebTextEditorMedia Members


Caption Property

[image]
Intersoft WebTextEditor Documentation
Caption Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMedia Class : Caption Property

Glossary Item Box

Specifies the caption of the media.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the caption of the media.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Media")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Caption As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMedia
Dim value As System.String

instance.Caption = value

value = instance.Caption
C#
[System.ComponentModel.DescriptionAttribute("Specifies the caption of the media.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Media")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string Caption {get; set;}
Delphi
public read-write property Caption: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the caption of the media.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Media")
System.ComponentModel.DefaultValueAttribute()
public function get,set Caption : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the caption of the media.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Media")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_Caption();
public: __property void set_Caption(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the caption of the media.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Media")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ Caption {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMedia Class
WebTextEditorMedia Members


DateModified Property

[image]
Intersoft WebTextEditor Documentation
DateModified Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMedia Class : DateModified Property

Glossary Item Box

Specifies the date modified of the media.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Media")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the modified date of the media.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property DateModified As System.Date
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMedia
Dim value As System.Date

instance.DateModified = value

value = instance.DateModified
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Media")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the modified date of the media.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.DateTime DateModified {get; set;}
Delphi
public read-write property DateModified: System.DateTime;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Media")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the modified date of the media.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set DateModified : System.DateTime
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Media")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the modified date of the media.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.DateTime get_DateModified();
public: __property void set_DateModified(
   System.DateTime value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Media")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the modified date of the media.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.DateTime DateModified {
   System.DateTime get();
   void set (    System.DateTime value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMedia Class
WebTextEditorMedia Members


Description Property

[image]
Intersoft WebTextEditor Documentation
Description Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMedia Class : Description Property

Glossary Item Box

Specifies the description of the media.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the description of the media.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Media")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Description As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMedia
Dim value As System.String

instance.Description = value

value = instance.Description
C#
[System.ComponentModel.DescriptionAttribute("Specifies the description of the media.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Media")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string Description {get; set;}
Delphi
public read-write property Description: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the description of the media.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Media")
System.ComponentModel.DefaultValueAttribute()
public function get,set Description : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the description of the media.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Media")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_Description();
public: __property void set_Description(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the description of the media.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Media")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ Description {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMedia Class
WebTextEditorMedia Members


Extension Property

[image]
Intersoft WebTextEditor Documentation
Extension Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMedia Class : Extension Property

Glossary Item Box

Specifies the extension of the media.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the extension of the media.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Media")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property Extension As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMedia
Dim value As System.String

instance.Extension = value

value = instance.Extension
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the extension of the media.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Media")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string Extension {get; set;}
Delphi
public read-write property Extension: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the extension of the media.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Media")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set Extension : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the extension of the media.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Media")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_Extension();
public: __property void set_Extension(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the extension of the media.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Media")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ Extension {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMedia Class
WebTextEditorMedia Members


FileName Property

[image]
Intersoft WebTextEditor Documentation
FileName Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMedia Class : FileName Property

Glossary Item Box

Specifies the file name of the media.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Media")>
<System.ComponentModel.DescriptionAttribute("Specifies the file name of the media.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property FileName As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMedia
Dim value As System.String

instance.FileName = value

value = instance.FileName
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Media")]
[System.ComponentModel.DescriptionAttribute("Specifies the file name of the media.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string FileName {get; set;}
Delphi
public read-write property FileName: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Media")
System.ComponentModel.DescriptionAttribute("Specifies the file name of the media.")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set FileName : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Media")]
[System.ComponentModel.DescriptionAttribute("Specifies the file name of the media.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_FileName();
public: __property void set_FileName(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Media")]
[System.ComponentModel.DescriptionAttribute("Specifies the file name of the media.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ FileName {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMedia Class
WebTextEditorMedia Members


Height Property

[image]
Intersoft WebTextEditor Documentation
Height Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMedia Class : Height Property

Glossary Item Box

Specifies the size of the media.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Media")>
<System.ComponentModel.DescriptionAttribute("Specifies the height of the media.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Height As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMedia
Dim value As System.Integer

instance.Height = value

value = instance.Height
C#
[System.ComponentModel.CategoryAttribute("Media")]
[System.ComponentModel.DescriptionAttribute("Specifies the height of the media.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.int Height {get; set;}
Delphi
public read-write property Height: System.Integer;
JScript
System.ComponentModel.CategoryAttribute("Media")
System.ComponentModel.DescriptionAttribute("Specifies the height of the media.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set Height : System.int
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Media")]
[System.ComponentModel.DescriptionAttribute("Specifies the height of the media.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.int get_Height();
public: __property void set_Height(
   System.int value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Media")]
[System.ComponentModel.DescriptionAttribute("Specifies the height of the media.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.int Height {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMedia Class
WebTextEditorMedia Members


LinkURL Property

[image]
Intersoft WebTextEditor Documentation
LinkURL Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMedia Class : LinkURL Property

Glossary Item Box

Specifies the link url of the media.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Media")>
<System.ComponentModel.DescriptionAttribute("Specifies the link url of the media.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property LinkURL As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMedia
Dim value As System.String

instance.LinkURL = value

value = instance.LinkURL
C#
[System.ComponentModel.CategoryAttribute("Media")]
[System.ComponentModel.DescriptionAttribute("Specifies the link url of the media.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string LinkURL {get; set;}
Delphi
public read-write property LinkURL: System.String;
JScript
System.ComponentModel.CategoryAttribute("Media")
System.ComponentModel.DescriptionAttribute("Specifies the link url of the media.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set LinkURL : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Media")]
[System.ComponentModel.DescriptionAttribute("Specifies the link url of the media.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_LinkURL();
public: __property void set_LinkURL(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Media")]
[System.ComponentModel.DescriptionAttribute("Specifies the link url of the media.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ LinkURL {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMedia Class
WebTextEditorMedia Members


Name Property

[image]
Intersoft WebTextEditor Documentation
Name Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMedia Class : Name Property

Glossary Item Box

Specifies the name of the resource.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.BrowsableAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the name of the resource.")>
<System.ComponentModel.CategoryAttribute("General")>
Public Overrides Property Name As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMedia
Dim value As System.String

instance.Name = value

value = instance.Name
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the name of the resource.")]
[System.ComponentModel.CategoryAttribute("General")]
public override System.string Name {get; set;}
Delphi
public read-write property Name: System.String; override;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the name of the resource.")
System.ComponentModel.CategoryAttribute("General")
public override function get,set Name : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the name of the resource.")]
[System.ComponentModel.CategoryAttribute("General")]
public: __property System.string* get_Name() override;
public: __property void set_Name(
   System.string* value
) override;
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the name of the resource.")]
[System.ComponentModel.CategoryAttribute("General")]
public:
property System.String^ Name {
   System.String^ get() override;
   void set (    System.String^ value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMedia Class
WebTextEditorMedia Members


PhysicalPath Property

[image]
Intersoft WebTextEditor Documentation
PhysicalPath Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMedia Class : PhysicalPath Property

Glossary Item Box

Specifies the physical path of the media.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the physical path of the media.")>
<System.ComponentModel.CategoryAttribute("Media")>
Public Property PhysicalPath As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMedia
Dim value As System.String

instance.PhysicalPath = value

value = instance.PhysicalPath
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the physical path of the media.")]
[System.ComponentModel.CategoryAttribute("Media")]
public System.string PhysicalPath {get; set;}
Delphi
public read-write property PhysicalPath: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the physical path of the media.")
System.ComponentModel.CategoryAttribute("Media")
public function get,set PhysicalPath : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the physical path of the media.")]
[System.ComponentModel.CategoryAttribute("Media")]
public: __property System.string* get_PhysicalPath();
public: __property void set_PhysicalPath(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the physical path of the media.")]
[System.ComponentModel.CategoryAttribute("Media")]
public:
property System.String^ PhysicalPath {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMedia Class
WebTextEditorMedia Members


Size Property

[image]
Intersoft WebTextEditor Documentation
Size Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMedia Class : Size Property

Glossary Item Box

Specifies the size of the media.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Media")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the size of the media.")>
Public Property Size As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMedia
Dim value As System.String

instance.Size = value

value = instance.Size
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Media")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the size of the media.")]
public System.string Size {get; set;}
Delphi
public read-write property Size: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Media")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the size of the media.")
public function get,set Size : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Media")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the size of the media.")]
public: __property System.string* get_Size();
public: __property void set_Size(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Media")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the size of the media.")]
public:
property System.String^ Size {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMedia Class
WebTextEditorMedia Members


Title Property

[image]
Intersoft WebTextEditor Documentation
Title Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMedia Class : Title Property

Glossary Item Box

Specifies the tooltip text of the media.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of the media.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Media")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Title As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMedia
Dim value As System.String

instance.Title = value

value = instance.Title
C#
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of the media.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Media")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.string Title {get; set;}
Delphi
public read-write property Title: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of the media.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Media")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set Title : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of the media.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Media")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_Title();
public: __property void set_Title(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the tooltip text of the media.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Media")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ Title {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMedia Class
WebTextEditorMedia Members


UseFrame Property

[image]
Intersoft WebTextEditor Documentation
UseFrame Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMedia Class : UseFrame Property

Glossary Item Box

Specifies whether or not the added media should use caption frame.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies whether or not the added media should use caption frame.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Media")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property UseFrame As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMedia
Dim value As System.Boolean

instance.UseFrame = value

value = instance.UseFrame
C#
[System.ComponentModel.DescriptionAttribute("Specifies whether or not the added media should use caption frame.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Media")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.bool UseFrame {get; set;}
Delphi
public read-write property UseFrame: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Specifies whether or not the added media should use caption frame.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Media")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set UseFrame : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies whether or not the added media should use caption frame.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Media")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.bool get_UseFrame();
public: __property void set_UseFrame(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies whether or not the added media should use caption frame.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Media")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.bool UseFrame {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMedia Class
WebTextEditorMedia Members


VirtualPath Property

[image]
Intersoft WebTextEditor Documentation
VirtualPath Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMedia Class : VirtualPath Property

Glossary Item Box

Specifies the virtual path of the media.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the virtual path of the media.")>
<System.ComponentModel.CategoryAttribute("Media")>
Public Property VirtualPath As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMedia
Dim value As System.String

instance.VirtualPath = value

value = instance.VirtualPath
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the virtual path of the media.")]
[System.ComponentModel.CategoryAttribute("Media")]
public System.string VirtualPath {get; set;}
Delphi
public read-write property VirtualPath: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the virtual path of the media.")
System.ComponentModel.CategoryAttribute("Media")
public function get,set VirtualPath : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the virtual path of the media.")]
[System.ComponentModel.CategoryAttribute("Media")]
public: __property System.string* get_VirtualPath();
public: __property void set_VirtualPath(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the virtual path of the media.")]
[System.ComponentModel.CategoryAttribute("Media")]
public:
property System.String^ VirtualPath {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMedia Class
WebTextEditorMedia Members


Width Property

[image]
Intersoft WebTextEditor Documentation
Width Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMedia Class : Width Property

Glossary Item Box

Specifies the size of the media.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Media")>
<System.ComponentModel.DescriptionAttribute("Specifies the width of the media.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Width As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMedia
Dim value As System.Integer

instance.Width = value

value = instance.Width
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Media")]
[System.ComponentModel.DescriptionAttribute("Specifies the width of the media.")]
[System.ComponentModel.DefaultValueAttribute()]
public System.int Width {get; set;}
Delphi
public read-write property Width: System.Integer;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Media")
System.ComponentModel.DescriptionAttribute("Specifies the width of the media.")
System.ComponentModel.DefaultValueAttribute()
public function get,set Width : System.int
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Media")]
[System.ComponentModel.DescriptionAttribute("Specifies the width of the media.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.int get_Width();
public: __property void set_Width(
   System.int value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Media")]
[System.ComponentModel.DescriptionAttribute("Specifies the width of the media.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.int Width {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMedia Class
WebTextEditorMedia Members


WebTextEditorMediaCollection Class

[image]
Intersoft WebTextEditor Documentation
WebTextEditorMediaCollection Class
Members See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorMediaCollection Class

Glossary Item Box

A collection of media used by WebTextEditor.

Object Model

WebTextEditorMediaCollection Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebTextEditorMediaCollection
   Inherits ISNet.WebUI.ISGenericCollectionBase(Of WebTextEditorMedia)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMediaCollection
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebTextEditorMediaCollection : ISNet.WebUI.ISGenericCollectionBase<WebTextEditorMedia>
Delphi
public class WebTextEditorMediaCollection = class(ISNet.WebUI.ISGenericCollectionBase)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebTextEditorMediaCollection extends ISNet.WebUI.ISGenericCollectionBase
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebTextEditorMediaCollection : public ISNet.WebUI.ISGenericCollectionBase<WebTextEditorMedia>
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebTextEditorMediaCollection : public ISNet.WebUI.ISGenericCollectionBase<WebTextEditorMedia>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
ISNet.WebUI.ISCollectionBase<T>
ISNet.WebUI.ISGenericCollectionBase<T>
ISNet.WebUI.WebTextEditor.WebTextEditorMediaCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaCollection Members
ISNet.WebUI.WebTextEditor Namespace


WebTextEditorMediaCollection Class Members

[image]
Intersoft WebTextEditor Documentation
WebTextEditorMediaCollection Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorMediaCollection Class

Glossary Item Box

The following tables list the members exposed by WebTextEditorMediaCollection.

Public Constructors

 | Name | Description
Public Constructor | WebTextEditorMediaCollection Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | All | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

Protected Properties

 | Name | Description
Protected Property | Items | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CreateNewItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorMedia>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | GetNamedItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorMedia>)
Public Method | GetObjectData | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | SerializerConstructor | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorMedia>)
Public Method | SetParent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

Protected Methods

 | Name | Description
Protected Method | ClearItems | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorMedia>)
Protected Method | CreateArray | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Protected Method | InsertItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorMedia>)
Protected Method | RemoveItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorMedia>)
Protected Method | SetItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorMedia>)
Top

See Also

Reference

WebTextEditorMediaCollection Class
ISNet.WebUI.WebTextEditor Namespace


WebTextEditorMediaCollection Constructor

[image]
Intersoft WebTextEditor Documentation
WebTextEditorMediaCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMediaCollection Class : WebTextEditorMediaCollection Constructor

Glossary Item Box

Overload List

Overload | Description
WebTextEditorMediaCollection Constructor() |
WebTextEditorMediaCollection Constructor(SerializationInfo,StreamingContext) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaCollection Class
WebTextEditorMediaCollection Members


WebTextEditorMediaCollection Constructor()

[image]
Intersoft WebTextEditor Documentation
WebTextEditorMediaCollection Constructor()
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMediaCollection Class > WebTextEditorMediaCollection Constructor : WebTextEditorMediaCollection Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebTextEditorMediaCollection()
C#
public WebTextEditorMediaCollection()
Delphi
public WebTextEditorMediaCollection();
JScript
public function WebTextEditorMediaCollection();
Managed Extensions for C++
public: WebTextEditorMediaCollection();
C++/CLI
public:
WebTextEditorMediaCollection();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaCollection Class
WebTextEditorMediaCollection Members
Overload List


WebTextEditorMediaCollection Constructor(SerializationInfo,StreamingContext)

[image]
Intersoft WebTextEditor Documentation
WebTextEditorMediaCollection Constructor(SerializationInfo,StreamingContext)
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMediaCollection Class > WebTextEditorMediaCollection Constructor : WebTextEditorMediaCollection Constructor(SerializationInfo,StreamingContext)

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

Dim instance As New WebTextEditorMediaCollection(info, context)
C#
protected WebTextEditorMediaCollection(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
protected WebTextEditorMediaCollection(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
protected function WebTextEditorMediaCollection(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
protected: WebTextEditorMediaCollection(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
protected:
WebTextEditorMediaCollection(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaCollection Class
WebTextEditorMediaCollection Members
Overload List


WebTextEditorMediaResourceGroup Class

[image]
Intersoft WebTextEditor Documentation
WebTextEditorMediaResourceGroup Class
Members See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorMediaResourceGroup Class

Glossary Item Box

A collection of members in WebTextEditor's media resource group.

Object Model

WebTextEditorMediaResourceGroup Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebTextEditorMediaResourceGroup
   Inherits ISNet.WebUI.NamedObjectBase2
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMediaResourceGroup
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebTextEditorMediaResourceGroup : ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
Delphi
public class WebTextEditorMediaResourceGroup = class(ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebTextEditorMediaResourceGroup extends ISNet.WebUI.NamedObjectBase2 implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebTextEditorMediaResourceGroup : public ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebTextEditorMediaResourceGroup : public ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.NamedObjectBase2
ISNet.WebUI.WebTextEditor.WebTextEditorMediaResourceGroup

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaResourceGroup Members
ISNet.WebUI.WebTextEditor Namespace


WebTextEditorMediaResourceGroup Class Members

[image]
Intersoft WebTextEditor Documentation
WebTextEditorMediaResourceGroup Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorMediaResourceGroup Class

Glossary Item Box

The following tables list the members exposed by WebTextEditorMediaResourceGroup.

Public Constructors

 | Name | Description
Public Constructor | WebTextEditorMediaResourceGroup Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Collection | (Inherited from ISNet.WebUI.NamedObjectBase2)
Public Property | GroupResourceVisible | Specifies whether or not the group resource should be displayed in the Search In combo.
Public Property | Name | Overridden. Specifies the name of the media group resource.
Public Property | Resources | The media resources collection used by WebTextEditor to filter the media in Media Gallery task pane.
Public Property | Text | Gets or sets the value that determines the text of the media resource group.
Public Property | Type | Gets or sets the value that determines the type of the media resource group.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

Protected Methods

 | Name | Description
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | IsInSerializationContext | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | OnItemAdd | (Inherited from ISNet.WebUI.NamedObjectBase2)
Protected Method | OnItemRemove | (Inherited from ISNet.WebUI.NamedObjectBase2)
Top

See Also

Reference

WebTextEditorMediaResourceGroup Class
ISNet.WebUI.WebTextEditor Namespace


WebTextEditorMediaResourceGroup Constructor

[image]
Intersoft WebTextEditor Documentation
WebTextEditorMediaResourceGroup Constructor
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMediaResourceGroup Class : WebTextEditorMediaResourceGroup Constructor

Glossary Item Box

Overload List

Overload | Description
WebTextEditorMediaResourceGroup Constructor() |
WebTextEditorMediaResourceGroup Constructor(SerializationInfo,StreamingContext) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaResourceGroup Class
WebTextEditorMediaResourceGroup Members


WebTextEditorMediaResourceGroup Constructor()

[image]
Intersoft WebTextEditor Documentation
WebTextEditorMediaResourceGroup Constructor()
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMediaResourceGroup Class > WebTextEditorMediaResourceGroup Constructor : WebTextEditorMediaResourceGroup Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebTextEditorMediaResourceGroup()
C#
public WebTextEditorMediaResourceGroup()
Delphi
public WebTextEditorMediaResourceGroup();
JScript
public function WebTextEditorMediaResourceGroup();
Managed Extensions for C++
public: WebTextEditorMediaResourceGroup();
C++/CLI
public:
WebTextEditorMediaResourceGroup();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaResourceGroup Class
WebTextEditorMediaResourceGroup Members
Overload List


WebTextEditorMediaResourceGroup Constructor(SerializationInfo,StreamingContext)

[image]
Intersoft WebTextEditor Documentation
WebTextEditorMediaResourceGroup Constructor(SerializationInfo,StreamingContext)
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMediaResourceGroup Class > WebTextEditorMediaResourceGroup Constructor : WebTextEditorMediaResourceGroup Constructor(SerializationInfo,StreamingContext)

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

Dim instance As New WebTextEditorMediaResourceGroup(info, context)
C#
protected WebTextEditorMediaResourceGroup(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
protected WebTextEditorMediaResourceGroup(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
protected function WebTextEditorMediaResourceGroup(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
protected: WebTextEditorMediaResourceGroup(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
protected:
WebTextEditorMediaResourceGroup(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaResourceGroup Class
WebTextEditorMediaResourceGroup Members
Overload List


WebTextEditorMediaResourceGroup Class Methods

[image]
Intersoft WebTextEditor Documentation
WebTextEditorMediaResourceGroup Class Methods
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorMediaResourceGroup Class

Glossary Item Box

For a list of all members of this type, see WebTextEditorMediaResourceGroup members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

Protected Methods

 | Name | Description
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | IsInSerializationContext | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | OnItemAdd | (Inherited from ISNet.WebUI.NamedObjectBase2)
Protected Method | OnItemRemove | (Inherited from ISNet.WebUI.NamedObjectBase2)
Top

See Also

Reference

WebTextEditorMediaResourceGroup Class
ISNet.WebUI.WebTextEditor Namespace


GetObjectData Method

[image]
Intersoft WebTextEditor Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMediaResourceGroup Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMediaResourceGroup
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaResourceGroup Class
WebTextEditorMediaResourceGroup Members


WebTextEditorMediaResourceGroup Class Properties

[image]
Intersoft WebTextEditor Documentation
WebTextEditorMediaResourceGroup Class Properties
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorMediaResourceGroup Class

Glossary Item Box

For a list of all members of this type, see WebTextEditorMediaResourceGroup members.

Public Properties

 | Name | Description
Public Property | Collection | (Inherited from ISNet.WebUI.NamedObjectBase2)
Public Property | GroupResourceVisible | Specifies whether or not the group resource should be displayed in the Search In combo.
Public Property | Name | Overridden. Specifies the name of the media group resource.
Public Property | Resources | The media resources collection used by WebTextEditor to filter the media in Media Gallery task pane.
Public Property | Text | Gets or sets the value that determines the text of the media resource group.
Public Property | Type | Gets or sets the value that determines the type of the media resource group.
Top

See Also

Reference

WebTextEditorMediaResourceGroup Class
ISNet.WebUI.WebTextEditor Namespace


GroupResourceVisible Property

[image]
Intersoft WebTextEditor Documentation
GroupResourceVisible Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMediaResourceGroup Class : GroupResourceVisible Property

Glossary Item Box

Specifies whether or not the group resource should be displayed in the Search In combo.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether or not the group resource should be displayed in the Search In combo.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property GroupResourceVisible As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMediaResourceGroup
Dim value As System.Boolean

instance.GroupResourceVisible = value

value = instance.GroupResourceVisible
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not the group resource should be displayed in the Search In combo.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool GroupResourceVisible {get; set;}
Delphi
public read-write property GroupResourceVisible: System.Boolean;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether or not the group resource should be displayed in the Search In combo.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DefaultValueAttribute()
public function get,set GroupResourceVisible : System.boolean
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not the group resource should be displayed in the Search In combo.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_GroupResourceVisible();
public: __property void set_GroupResourceVisible(
   System.bool value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not the group resource should be displayed in the Search In combo.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool GroupResourceVisible {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaResourceGroup Class
WebTextEditorMediaResourceGroup Members


Name Property

[image]
Intersoft WebTextEditor Documentation
Name Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMediaResourceGroup Class : Name Property

Glossary Item Box

Specifies the name of the media group resource.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the name of the media group resource.")>
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)>
<System.ComponentModel.BrowsableAttribute(True)>
Public Overrides Property Name As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMediaResourceGroup
Dim value As System.String

instance.Name = value

value = instance.Name
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the name of the media group resource.")]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[System.ComponentModel.BrowsableAttribute(true)]
public override System.string Name {get; set;}
Delphi
public read-write property Name: System.String; override;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the name of the media group resource.")
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)
System.ComponentModel.BrowsableAttribute()
public override function get,set Name : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the name of the media group resource.")]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[System.ComponentModel.BrowsableAttribute(true)]
public: __property System.string* get_Name() override;
public: __property void set_Name(
   System.string* value
) override;
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the name of the media group resource.")]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[System.ComponentModel.BrowsableAttribute(true)]
public:
property System.String^ Name {
   System.String^ get() override;
   void set (    System.String^ value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaResourceGroup Class
WebTextEditorMediaResourceGroup Members


Resources Property

[image]
Intersoft WebTextEditor Documentation
Resources Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMediaResourceGroup Class : Resources Property

Glossary Item Box

The media resources collection used by WebTextEditor to filter the media in Media Gallery task pane.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute("setMediaResource")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebTextEditor, Version=1.0.1000.9, Culture=neutral, PublicKeyToken=b1f2a8511635667a")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("The media resources collection used by WebTextEditor to filter the media in Media Gallery task pane.")>
Public ReadOnly Property Resources As WebTextEditorResourceCollection
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMediaResourceGroup
Dim value As WebTextEditorResourceCollection

value = instance.Resources
C#
[ISNet.Serialization.BinarySerializableAttribute("setMediaResource")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebTextEditor, Version=1.0.1000.9, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("The media resources collection used by WebTextEditor to filter the media in Media Gallery task pane.")]
public WebTextEditorResourceCollection Resources {get;}
Delphi
public read-only property Resources: WebTextEditorResourceCollection;
JScript
ISNet.Serialization.BinarySerializableAttribute("setMediaResource")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebTextEditor, Version=1.0.1000.9, Culture=neutral, PublicKeyToken=b1f2a8511635667a")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("The media resources collection used by WebTextEditor to filter the media in Media Gallery task pane.")
public function get Resources : WebTextEditorResourceCollection
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute("setMediaResource")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebTextEditor, Version=1.0.1000.9, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("The media resources collection used by WebTextEditor to filter the media in Media Gallery task pane.")]
public: __property WebTextEditorResourceCollection* get_Resources();
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute("setMediaResource")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebTextEditor, Version=1.0.1000.9, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("The media resources collection used by WebTextEditor to filter the media in Media Gallery task pane.")]
public:
property WebTextEditorResourceCollection^ Resources {
   WebTextEditorResourceCollection^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaResourceGroup Class
WebTextEditorMediaResourceGroup Members


Text Property

[image]
Intersoft WebTextEditor Documentation
Text Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMediaResourceGroup Class : Text Property

Glossary Item Box

Gets or sets the value that determines the text of the media resource group.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the text of the media resource group.")>
Public Property Text As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMediaResourceGroup
Dim value As System.String

instance.Text = value

value = instance.Text
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the text of the media resource group.")]
public System.string Text {get; set;}
Delphi
public read-write property Text: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the text of the media resource group.")
public function get,set Text : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the text of the media resource group.")]
public: __property System.string* get_Text();
public: __property void set_Text(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the text of the media resource group.")]
public:
property System.String^ Text {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaResourceGroup Class
WebTextEditorMediaResourceGroup Members


Type Property

[image]
Intersoft WebTextEditor Documentation
Type Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMediaResourceGroup Class : Type Property

Glossary Item Box

Gets or sets the value that determines the type of the media resource group.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the type of the media resource group.")>
Public Property Type As WebTextEditorMediaResourceType
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMediaResourceGroup
Dim value As WebTextEditorMediaResourceType

instance.Type = value

value = instance.Type
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the type of the media resource group.")]
public WebTextEditorMediaResourceType Type {get; set;}
Delphi
public read-write property Type: WebTextEditorMediaResourceType;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the type of the media resource group.")
public function get,set Type : WebTextEditorMediaResourceType
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the type of the media resource group.")]
public: __property WebTextEditorMediaResourceType get_Type();
public: __property void set_Type(
   WebTextEditorMediaResourceType value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the value that determines the type of the media resource group.")]
public:
property WebTextEditorMediaResourceType Type {
   WebTextEditorMediaResourceType get();
   void set (    WebTextEditorMediaResourceType value);
}

Property Value

There are four default styles in AllResources, LocalServer, Service and Database.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaResourceGroup Class
WebTextEditorMediaResourceGroup Members


WebTextEditorMediaResourceGroupCollection Class

[image]
Intersoft WebTextEditor Documentation
WebTextEditorMediaResourceGroupCollection Class
Members See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorMediaResourceGroupCollection Class

Glossary Item Box

A collection of media resource group used by WebTextEditor.

Object Model

WebTextEditorMediaResourceGroupCollection Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebTextEditorMediaResourceGroupCollection
   Inherits ISNet.WebUI.ISGenericCollectionBase(Of WebTextEditorMediaResourceGroup)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMediaResourceGroupCollection
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebTextEditorMediaResourceGroupCollection : ISNet.WebUI.ISGenericCollectionBase<WebTextEditorMediaResourceGroup>
Delphi
public class WebTextEditorMediaResourceGroupCollection = class(ISNet.WebUI.ISGenericCollectionBase)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebTextEditorMediaResourceGroupCollection extends ISNet.WebUI.ISGenericCollectionBase
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebTextEditorMediaResourceGroupCollection : public ISNet.WebUI.ISGenericCollectionBase<WebTextEditorMediaResourceGroup>
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebTextEditorMediaResourceGroupCollection : public ISNet.WebUI.ISGenericCollectionBase<WebTextEditorMediaResourceGroup>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
ISNet.WebUI.ISCollectionBase<T>
ISNet.WebUI.ISGenericCollectionBase<T>
ISNet.WebUI.WebTextEditor.WebTextEditorMediaResourceGroupCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaResourceGroupCollection Members
ISNet.WebUI.WebTextEditor Namespace


WebTextEditorMediaResourceGroupCollection Class Members

[image]
Intersoft WebTextEditor Documentation
WebTextEditorMediaResourceGroupCollection Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorMediaResourceGroupCollection Class

Glossary Item Box

The following tables list the members exposed by WebTextEditorMediaResourceGroupCollection.

Public Constructors

 | Name | Description
Public Constructor | WebTextEditorMediaResourceGroupCollection Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | All | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

Protected Properties

 | Name | Description
Protected Property | Items | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CreateNewItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorMediaResourceGroup>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | GetNamedItem |
Public Method | GetObjectData | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | SerializerConstructor | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorMediaResourceGroup>)
Public Method | SetParent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

Protected Methods

 | Name | Description
Protected Method | ClearItems | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorMediaResourceGroup>)
Protected Method | CreateArray | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Protected Method | InsertItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorMediaResourceGroup>)
Protected Method | RemoveItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorMediaResourceGroup>)
Protected Method | SetItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorMediaResourceGroup>)
Top

See Also

Reference

WebTextEditorMediaResourceGroupCollection Class
ISNet.WebUI.WebTextEditor Namespace


WebTextEditorMediaResourceGroupCollection Constructor

[image]
Intersoft WebTextEditor Documentation
WebTextEditorMediaResourceGroupCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMediaResourceGroupCollection Class : WebTextEditorMediaResourceGroupCollection Constructor

Glossary Item Box

Overload List

Overload | Description
WebTextEditorMediaResourceGroupCollection Constructor() |
WebTextEditorMediaResourceGroupCollection Constructor(SerializationInfo,StreamingContext) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaResourceGroupCollection Class
WebTextEditorMediaResourceGroupCollection Members


WebTextEditorMediaResourceGroupCollection Constructor()

[image]
Intersoft WebTextEditor Documentation
WebTextEditorMediaResourceGroupCollection Constructor()
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMediaResourceGroupCollection Class > WebTextEditorMediaResourceGroupCollection Constructor : WebTextEditorMediaResourceGroupCollection Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebTextEditorMediaResourceGroupCollection()
C#
public WebTextEditorMediaResourceGroupCollection()
Delphi
public WebTextEditorMediaResourceGroupCollection();
JScript
public function WebTextEditorMediaResourceGroupCollection();
Managed Extensions for C++
public: WebTextEditorMediaResourceGroupCollection();
C++/CLI
public:
WebTextEditorMediaResourceGroupCollection();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaResourceGroupCollection Class
WebTextEditorMediaResourceGroupCollection Members
Overload List


WebTextEditorMediaResourceGroupCollection Constructor(SerializationInfo,StreamingContext)

[image]
Intersoft WebTextEditor Documentation
WebTextEditorMediaResourceGroupCollection Constructor(SerializationInfo,StreamingContext)
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMediaResourceGroupCollection Class > WebTextEditorMediaResourceGroupCollection Constructor : WebTextEditorMediaResourceGroupCollection Constructor(SerializationInfo,StreamingContext)

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

Dim instance As New WebTextEditorMediaResourceGroupCollection(info, context)
C#
protected WebTextEditorMediaResourceGroupCollection(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
protected WebTextEditorMediaResourceGroupCollection(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
protected function WebTextEditorMediaResourceGroupCollection(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
protected: WebTextEditorMediaResourceGroupCollection(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
protected:
WebTextEditorMediaResourceGroupCollection(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaResourceGroupCollection Class
WebTextEditorMediaResourceGroupCollection Members
Overload List


WebTextEditorMediaResourceGroupCollection Class Methods

[image]
Intersoft WebTextEditor Documentation
WebTextEditorMediaResourceGroupCollection Class Methods
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorMediaResourceGroupCollection Class

Glossary Item Box

For a list of all members of this type, see WebTextEditorMediaResourceGroupCollection members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CreateNewItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorMediaResourceGroup>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | GetNamedItem |
Public Method | GetObjectData | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | SerializerConstructor | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorMediaResourceGroup>)
Public Method | SetParent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

Protected Methods

 | Name | Description
Protected Method | ClearItems | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorMediaResourceGroup>)
Protected Method | CreateArray | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Protected Method | InsertItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorMediaResourceGroup>)
Protected Method | RemoveItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorMediaResourceGroup>)
Protected Method | SetItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorMediaResourceGroup>)
Top

See Also

Reference

WebTextEditorMediaResourceGroupCollection Class
ISNet.WebUI.WebTextEditor Namespace


GetNamedItem Method

[image]
Intersoft WebTextEditor Documentation
GetNamedItem Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMediaResourceGroupCollection Class : GetNamedItem Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shadows Function GetNamedItem( _
   ByVal name As System.String _
) As WebTextEditorMediaResourceGroup
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMediaResourceGroupCollection
Dim name As System.String
Dim value As WebTextEditorMediaResourceGroup

value = instance.GetNamedItem(name)
C#
public new WebTextEditorMediaResourceGroup GetNamedItem(
   System.string name
)
Delphi
public function GetNamedItem(
    name: System.String
): WebTextEditorMediaResourceGroup;
JScript
public hide function GetNamedItem(
   name : System.String
) : WebTextEditorMediaResourceGroup;
Managed Extensions for C++
public: new WebTextEditorMediaResourceGroup* GetNamedItem(
   System.string* name
)
C++/CLI
public:
new WebTextEditorMediaResourceGroup^ GetNamedItem(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaResourceGroupCollection Class
WebTextEditorMediaResourceGroupCollection Members


WebTextEditorResource Class

[image]
Intersoft WebTextEditor Documentation
WebTextEditorResource Class
Members See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorResource Class

Glossary Item Box

A collection of members media resource used by WebTextEditor for media searching.

Object Model

WebTextEditorResource Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebTextEditorResource
   Inherits ISNet.WebUI.NamedObjectBase2
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorResource
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebTextEditorResource : ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
Delphi
public class WebTextEditorResource = class(ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebTextEditorResource extends ISNet.WebUI.NamedObjectBase2 implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebTextEditorResource : public ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebTextEditorResource : public ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.NamedObjectBase2
ISNet.WebUI.WebTextEditor.WebTextEditorResource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorResource Members
ISNet.WebUI.WebTextEditor Namespace


WebTextEditorResource Class Members

[image]
Intersoft WebTextEditor Documentation
WebTextEditorResource Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorResource Class

Glossary Item Box

The following tables list the members exposed by WebTextEditorResource.

Public Constructors

 | Name | Description
Public Constructor | WebTextEditorResource Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | AllowUserUpload | Specifies whether or not user is allowed to upload medias to this url.
Public Property | Collection | (Inherited from ISNet.WebUI.NamedObjectBase2)
Public Property | Name | Overridden. Specifies the name of the resource.
Public Property | RemoteVirtualPath | Specifies the virtual path of resource if the url is in remote server.
Public Property | SearchInChildFolder | Specifies whether or not the search should be performed in child folders.
Public Property | Text | Specifies the text of the resource.
Public Property | Url | Specifies the url of the resource. If in local server, the url must be the virtual path of the folder.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

Protected Methods

 | Name | Description
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | IsInSerializationContext | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | OnItemAdd | (Inherited from ISNet.WebUI.NamedObjectBase2)
Protected Method | OnItemRemove | (Inherited from ISNet.WebUI.NamedObjectBase2)
Top

See Also

Reference

WebTextEditorResource Class
ISNet.WebUI.WebTextEditor Namespace


WebTextEditorResource Constructor

[image]
Intersoft WebTextEditor Documentation
WebTextEditorResource Constructor
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorResource Class : WebTextEditorResource Constructor

Glossary Item Box

Overload List

Overload | Description
WebTextEditorResource Constructor() |
WebTextEditorResource Constructor(SerializationInfo,StreamingContext) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorResource Class
WebTextEditorResource Members


WebTextEditorResource Constructor()

[image]
Intersoft WebTextEditor Documentation
WebTextEditorResource Constructor()
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorResource Class > WebTextEditorResource Constructor : WebTextEditorResource Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebTextEditorResource()
C#
public WebTextEditorResource()
Delphi
public WebTextEditorResource();
JScript
public function WebTextEditorResource();
Managed Extensions for C++
public: WebTextEditorResource();
C++/CLI
public:
WebTextEditorResource();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorResource Class
WebTextEditorResource Members
Overload List


WebTextEditorResource Constructor(SerializationInfo,StreamingContext)

[image]
Intersoft WebTextEditor Documentation
WebTextEditorResource Constructor(SerializationInfo,StreamingContext)
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorResource Class > WebTextEditorResource Constructor : WebTextEditorResource Constructor(SerializationInfo,StreamingContext)

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

Dim instance As New WebTextEditorResource(info, context)
C#
protected WebTextEditorResource(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
protected WebTextEditorResource(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
protected function WebTextEditorResource(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
protected: WebTextEditorResource(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
protected:
WebTextEditorResource(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorResource Class
WebTextEditorResource Members
Overload List


WebTextEditorResource Class Methods

[image]
Intersoft WebTextEditor Documentation
WebTextEditorResource Class Methods
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorResource Class

Glossary Item Box

For a list of all members of this type, see WebTextEditorResource members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

Protected Methods

 | Name | Description
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | IsInSerializationContext | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | OnItemAdd | (Inherited from ISNet.WebUI.NamedObjectBase2)
Protected Method | OnItemRemove | (Inherited from ISNet.WebUI.NamedObjectBase2)
Top

See Also

Reference

WebTextEditorResource Class
ISNet.WebUI.WebTextEditor Namespace


GetObjectData Method

[image]
Intersoft WebTextEditor Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorResource Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorResource
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorResource Class
WebTextEditorResource Members


WebTextEditorResource Class Properties

[image]
Intersoft WebTextEditor Documentation
WebTextEditorResource Class Properties
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorResource Class

Glossary Item Box

For a list of all members of this type, see WebTextEditorResource members.

Public Properties

 | Name | Description
Public Property | AllowUserUpload | Specifies whether or not user is allowed to upload medias to this url.
Public Property | Collection | (Inherited from ISNet.WebUI.NamedObjectBase2)
Public Property | Name | Overridden. Specifies the name of the resource.
Public Property | RemoteVirtualPath | Specifies the virtual path of resource if the url is in remote server.
Public Property | SearchInChildFolder | Specifies whether or not the search should be performed in child folders.
Public Property | Text | Specifies the text of the resource.
Public Property | Url | Specifies the url of the resource. If in local server, the url must be the virtual path of the folder.
Top

See Also

Reference

WebTextEditorResource Class
ISNet.WebUI.WebTextEditor Namespace


AllowUserUpload Property

[image]
Intersoft WebTextEditor Documentation
AllowUserUpload Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorResource Class : AllowUserUpload Property

Glossary Item Box

Specifies whether or not user is allowed to upload medias to this url.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether or not user is allowed to upload medias to this url.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property AllowUserUpload As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorResource
Dim value As System.Boolean

instance.AllowUserUpload = value

value = instance.AllowUserUpload
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not user is allowed to upload medias to this url.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.bool AllowUserUpload {get; set;}
Delphi
public read-write property AllowUserUpload: System.Boolean;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether or not user is allowed to upload medias to this url.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set AllowUserUpload : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not user is allowed to upload medias to this url.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.bool get_AllowUserUpload();
public: __property void set_AllowUserUpload(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not user is allowed to upload medias to this url.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.bool AllowUserUpload {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorResource Class
WebTextEditorResource Members


Name Property

[image]
Intersoft WebTextEditor Documentation
Name Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorResource Class : Name Property

Glossary Item Box

Specifies the name of the resource.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the name of the resource.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.BrowsableAttribute(True)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)>
<System.ComponentModel.CategoryAttribute("General")>
Public Overrides Property Name As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorResource
Dim value As System.String

instance.Name = value

value = instance.Name
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the name of the resource.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[System.ComponentModel.CategoryAttribute("General")]
public override System.string Name {get; set;}
Delphi
public read-write property Name: System.String; override;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the name of the resource.")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)
System.ComponentModel.CategoryAttribute("General")
public override function get,set Name : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the name of the resource.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[System.ComponentModel.CategoryAttribute("General")]
public: __property System.string* get_Name() override;
public: __property void set_Name(
   System.string* value
) override;
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the name of the resource.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[System.ComponentModel.CategoryAttribute("General")]
public:
property System.String^ Name {
   System.String^ get() override;
   void set (    System.String^ value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorResource Class
WebTextEditorResource Members


RemoteVirtualPath Property

[image]
Intersoft WebTextEditor Documentation
RemoteVirtualPath Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorResource Class : RemoteVirtualPath Property

Glossary Item Box

Specifies the virtual path of resource if the url is in remote server.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the virtual path of resource if the url is in remote server.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property RemoteVirtualPath As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorResource
Dim value As System.String

instance.RemoteVirtualPath = value

value = instance.RemoteVirtualPath
C#
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the virtual path of resource if the url is in remote server.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.string RemoteVirtualPath {get; set;}
Delphi
public read-write property RemoteVirtualPath: System.String;
JScript
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the virtual path of resource if the url is in remote server.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set RemoteVirtualPath : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the virtual path of resource if the url is in remote server.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_RemoteVirtualPath();
public: __property void set_RemoteVirtualPath(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the virtual path of resource if the url is in remote server.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ RemoteVirtualPath {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorResource Class
WebTextEditorResource Members


SearchInChildFolder Property

[image]
Intersoft WebTextEditor Documentation
SearchInChildFolder Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorResource Class : SearchInChildFolder Property

Glossary Item Box

Specifies whether or not the search should be performed in child folders.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether or not the search should be performed in child folders.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property SearchInChildFolder As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorResource
Dim value As System.Boolean

instance.SearchInChildFolder = value

value = instance.SearchInChildFolder
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not the search should be performed in child folders.")]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool SearchInChildFolder {get; set;}
Delphi
public read-write property SearchInChildFolder: System.Boolean;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether or not the search should be performed in child folders.")
System.ComponentModel.DefaultValueAttribute()
public function get,set SearchInChildFolder : System.boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not the search should be performed in child folders.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_SearchInChildFolder();
public: __property void set_SearchInChildFolder(
   System.bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not the search should be performed in child folders.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool SearchInChildFolder {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorResource Class
WebTextEditorResource Members


Text Property

[image]
Intersoft WebTextEditor Documentation
Text Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorResource Class : Text Property

Glossary Item Box

Specifies the text of the resource.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the text of the resource.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property Text As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorResource
Dim value As System.String

instance.Text = value

value = instance.Text
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of the resource.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string Text {get; set;}
Delphi
public read-write property Text: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the text of the resource.")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set Text : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of the resource.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_Text();
public: __property void set_Text(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of the resource.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ Text {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorResource Class
WebTextEditorResource Members


Url Property

[image]
Intersoft WebTextEditor Documentation
Url Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorResource Class : Url Property

Glossary Item Box

Specifies the url of the resource. If in local server, the url must be the virtual path of the folder.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the url of the resource. If in local server, the url must be the virtual path of the folder.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
Public Property Url As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorResource
Dim value As System.String

instance.Url = value

value = instance.Url
C#
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the url of the resource. If in local server, the url must be the virtual path of the folder.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
public System.string Url {get; set;}
Delphi
public read-write property Url: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the url of the resource. If in local server, the url must be the virtual path of the folder.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("General")
public function get,set Url : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the url of the resource. If in local server, the url must be the virtual path of the folder.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
public: __property System.string* get_Url();
public: __property void set_Url(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the url of the resource. If in local server, the url must be the virtual path of the folder.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
public:
property System.String^ Url {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorResource Class
WebTextEditorResource Members


WebTextEditorResourceCollection Class

[image]
Intersoft WebTextEditor Documentation
WebTextEditorResourceCollection Class
Members See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorResourceCollection Class

Glossary Item Box

A collection of media resource used by WebTextEditor for media searching.

Object Model

WebTextEditorResourceCollection Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebTextEditorResourceCollection
   Inherits ISNet.WebUI.ISGenericCollectionBase(Of WebTextEditorResource)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorResourceCollection
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebTextEditorResourceCollection : ISNet.WebUI.ISGenericCollectionBase<WebTextEditorResource>
Delphi
public class WebTextEditorResourceCollection = class(ISNet.WebUI.ISGenericCollectionBase)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebTextEditorResourceCollection extends ISNet.WebUI.ISGenericCollectionBase
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebTextEditorResourceCollection : public ISNet.WebUI.ISGenericCollectionBase<WebTextEditorResource>
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebTextEditorResourceCollection : public ISNet.WebUI.ISGenericCollectionBase<WebTextEditorResource>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
ISNet.WebUI.ISCollectionBase<T>
ISNet.WebUI.ISGenericCollectionBase<T>
ISNet.WebUI.WebTextEditor.WebTextEditorResourceCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorResourceCollection Members
ISNet.WebUI.WebTextEditor Namespace


WebTextEditorResourceCollection Class Members

[image]
Intersoft WebTextEditor Documentation
WebTextEditorResourceCollection Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorResourceCollection Class

Glossary Item Box

The following tables list the members exposed by WebTextEditorResourceCollection.

Public Constructors

 | Name | Description
Public Constructor | WebTextEditorResourceCollection Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | All | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

Protected Properties

 | Name | Description
Protected Property | Items | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CreateNewItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorResource>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | GetNamedItem |
Public Method | GetObjectData | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | SerializerConstructor | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorResource>)
Public Method | SetParent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

Protected Methods

 | Name | Description
Protected Method | ClearItems | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorResource>)
Protected Method | CreateArray | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Protected Method | InsertItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorResource>)
Protected Method | RemoveItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorResource>)
Protected Method | SetItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorResource>)
Top

See Also

Reference

WebTextEditorResourceCollection Class
ISNet.WebUI.WebTextEditor Namespace


WebTextEditorResourceCollection Constructor

[image]
Intersoft WebTextEditor Documentation
WebTextEditorResourceCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorResourceCollection Class : WebTextEditorResourceCollection Constructor

Glossary Item Box

Overload List

Overload | Description
WebTextEditorResourceCollection Constructor() |
WebTextEditorResourceCollection Constructor(SerializationInfo,StreamingContext) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorResourceCollection Class
WebTextEditorResourceCollection Members


WebTextEditorResourceCollection Constructor()

[image]
Intersoft WebTextEditor Documentation
WebTextEditorResourceCollection Constructor()
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorResourceCollection Class > WebTextEditorResourceCollection Constructor : WebTextEditorResourceCollection Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebTextEditorResourceCollection()
C#
public WebTextEditorResourceCollection()
Delphi
public WebTextEditorResourceCollection();
JScript
public function WebTextEditorResourceCollection();
Managed Extensions for C++
public: WebTextEditorResourceCollection();
C++/CLI
public:
WebTextEditorResourceCollection();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorResourceCollection Class
WebTextEditorResourceCollection Members
Overload List


WebTextEditorResourceCollection Constructor(SerializationInfo,StreamingContext)

[image]
Intersoft WebTextEditor Documentation
WebTextEditorResourceCollection Constructor(SerializationInfo,StreamingContext)
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorResourceCollection Class > WebTextEditorResourceCollection Constructor : WebTextEditorResourceCollection Constructor(SerializationInfo,StreamingContext)

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

Dim instance As New WebTextEditorResourceCollection(info, context)
C#
protected WebTextEditorResourceCollection(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
protected WebTextEditorResourceCollection(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
protected function WebTextEditorResourceCollection(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
protected: WebTextEditorResourceCollection(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
protected:
WebTextEditorResourceCollection(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorResourceCollection Class
WebTextEditorResourceCollection Members
Overload List


WebTextEditorResourceCollection Class Methods

[image]
Intersoft WebTextEditor Documentation
WebTextEditorResourceCollection Class Methods
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorResourceCollection Class

Glossary Item Box

For a list of all members of this type, see WebTextEditorResourceCollection members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CreateNewItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorResource>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | GetNamedItem |
Public Method | GetObjectData | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | SerializerConstructor | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorResource>)
Public Method | SetParent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

Protected Methods

 | Name | Description
Protected Method | ClearItems | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorResource>)
Protected Method | CreateArray | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Protected Method | InsertItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorResource>)
Protected Method | RemoveItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorResource>)
Protected Method | SetItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorResource>)
Top

See Also

Reference

WebTextEditorResourceCollection Class
ISNet.WebUI.WebTextEditor Namespace


GetNamedItem Method

[image]
Intersoft WebTextEditor Documentation
GetNamedItem Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorResourceCollection Class : GetNamedItem Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shadows Function GetNamedItem( _
   ByVal name As System.String _
) As WebTextEditorResource
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorResourceCollection
Dim name As System.String
Dim value As WebTextEditorResource

value = instance.GetNamedItem(name)
C#
public new WebTextEditorResource GetNamedItem(
   System.string name
)
Delphi
public function GetNamedItem(
    name: System.String
): WebTextEditorResource;
JScript
public hide function GetNamedItem(
   name : System.String
) : WebTextEditorResource;
Managed Extensions for C++
public: new WebTextEditorResource* GetNamedItem(
   System.string* name
)
C++/CLI
public:
new WebTextEditorResource^ GetNamedItem(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorResourceCollection Class
WebTextEditorResourceCollection Members


WebTextEditorSaveArgs Class

[image]
Intersoft WebTextEditor Documentation
WebTextEditorSaveArgs Class
Members See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorSaveArgs Class

Glossary Item Box

Provides data for Save event.

Object Model

WebTextEditorSaveArgs Class

Syntax

Visual Basic (Declaration)
Public Class WebTextEditorSaveArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorSaveArgs
C#
public class WebTextEditorSaveArgs : System.EventArgs
Delphi
public class WebTextEditorSaveArgs = class(System.EventArgs)
JScript
public class WebTextEditorSaveArgs extends System.EventArgs
Managed Extensions for C++
public __gc class WebTextEditorSaveArgs : public System.EventArgs
C++/CLI
public ref class WebTextEditorSaveArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
ISNet.WebUI.WebTextEditor.WebTextEditorSaveArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorSaveArgs Members
ISNet.WebUI.WebTextEditor Namespace


WebTextEditorSaveArgs Class Members

[image]
Intersoft WebTextEditor Documentation
WebTextEditorSaveArgs Class Members
See Also Properties Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorSaveArgs Class

Glossary Item Box

The following tables list the members exposed by WebTextEditorSaveArgs.

Public Constructors

 | Name | Description
Public Constructor | WebTextEditorSaveArgs Constructor |
Top

Public Properties

 | Name | Description
Public Property | Content |
Public Property | ContentCollection |
Public Property | SaveAction |
Top

See Also

Reference

WebTextEditorSaveArgs Class
ISNet.WebUI.WebTextEditor Namespace


WebTextEditorSaveArgs Constructor

[image]
Intersoft WebTextEditor Documentation
WebTextEditorSaveArgs Constructor
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorSaveArgs Class : WebTextEditorSaveArgs Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebTextEditorSaveArgs()
C#
public WebTextEditorSaveArgs()
Delphi
public WebTextEditorSaveArgs();
JScript
public function WebTextEditorSaveArgs();
Managed Extensions for C++
public: WebTextEditorSaveArgs();
C++/CLI
public:
WebTextEditorSaveArgs();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorSaveArgs Class
WebTextEditorSaveArgs Members


WebTextEditorSaveArgs Class Properties

[image]
Intersoft WebTextEditor Documentation
WebTextEditorSaveArgs Class Properties
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorSaveArgs Class

Glossary Item Box

For a list of all members of this type, see WebTextEditorSaveArgs members.

Public Properties

 | Name | Description
Public Property | Content |
Public Property | ContentCollection |
Public Property | SaveAction |
Top

See Also

Reference

WebTextEditorSaveArgs Class
ISNet.WebUI.WebTextEditor Namespace


Content Property

[image]
Intersoft WebTextEditor Documentation
Content Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorSaveArgs Class : Content Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Content As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorSaveArgs
Dim value As System.String

instance.Content = value

value = instance.Content
C#
public System.string Content {get; set;}
Delphi
public read-write property Content: System.String;
JScript
public function get,set Content : System.String
Managed Extensions for C++
public: __property System.string* get_Content();
public: __property void set_Content(
   System.string* value
);
C++/CLI
public:
property System.String^ Content {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorSaveArgs Class
WebTextEditorSaveArgs Members


ContentCollection Property

[image]
Intersoft WebTextEditor Documentation
ContentCollection Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorSaveArgs Class : ContentCollection Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property ContentCollection As System.Collections.Generic.Dictionary(Of String,String)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorSaveArgs
Dim value As System.Collections.Generic.Dictionary(Of String,String)

instance.ContentCollection = value

value = instance.ContentCollection
C#
public System.Collections.Generic.Dictionary<string,string> ContentCollection {get; set;}
Delphi
public read-write property ContentCollection: System.Collections.Generic.Dictionary;
JScript
public function get,set ContentCollection : System.Collections.Generic.Dictionary
Managed Extensions for C++
public: __property System.Collections.Generic.Dictionary<string*,string*>* get_ContentCollection();
public: __property void set_ContentCollection(
   System.Collections.Generic.Dictionary<string*,string*>* value
);
C++/CLI
public:
property System.Collections.Generic.Dictionary<String^,String^>^ ContentCollection {
   System.Collections.Generic.Dictionary<String^,String^>^ get();
   void set (    System.Collections.Generic.Dictionary<String^,String^>^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorSaveArgs Class
WebTextEditorSaveArgs Members


SaveAction Property

[image]
Intersoft WebTextEditor Documentation
SaveAction Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorSaveArgs Class : SaveAction Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property SaveAction As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorSaveArgs
Dim value As System.String

instance.SaveAction = value

value = instance.SaveAction
C#
public System.string SaveAction {get; set;}
Delphi
public read-write property SaveAction: System.String;
JScript
public function get,set SaveAction : System.String
Managed Extensions for C++
public: __property System.string* get_SaveAction();
public: __property void set_SaveAction(
   System.string* value
);
C++/CLI
public:
property System.String^ SaveAction {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorSaveArgs Class
WebTextEditorSaveArgs Members


WebTextEditorSection Class

[image]
Intersoft WebTextEditor Documentation
WebTextEditorSection Class
Members See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorSection Class

Glossary Item Box

A collection of members in WebTextEditor's section.

Object Model

WebTextEditorSection Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebTextEditorSection
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorSection
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebTextEditorSection : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebTextEditorSection = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebTextEditorSection extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebTextEditorSection : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebTextEditorSection : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebTextEditor.WebTextEditorSection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorSection Members
ISNet.WebUI.WebTextEditor Namespace


WebTextEditorSection Class Members

[image]
Intersoft WebTextEditor Documentation
WebTextEditorSection Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorSection Class

Glossary Item Box

The following tables list the members exposed by WebTextEditorSection.

Public Constructors

 | Name | Description
Public Constructor | WebTextEditorSection Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | AllowCollapse |
Public Property | CompleteHTMLString |
Public Property | Content | Specifies content of section.
Public Property | CssFiles | Specifies the collection css files of section.
Public Property | Height | Specifies the height of section, applied in multiple section.
Public Property | IsCompleteHTML |
Public Property | Name | Specifies the name of section.
Public Property | ReadOnly | Determines whether the section is readonly or not.
Public Property | StyleString |
Public Property | Text | Specifies the section text, applied in multiple section.
Public Property | WatermarkSettings | Specifies the WatermarkSettings of section.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

Protected Methods

 | Name | Description
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | IsInSerializationContext | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebTextEditorSection Class
ISNet.WebUI.WebTextEditor Namespace


WebTextEditorSection Constructor

[image]
Intersoft WebTextEditor Documentation
WebTextEditorSection Constructor
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorSection Class : WebTextEditorSection Constructor

Glossary Item Box

Overload List

Overload | Description
WebTextEditorSection Constructor() |
WebTextEditorSection Constructor(SerializationInfo,StreamingContext) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorSection Class
WebTextEditorSection Members


WebTextEditorSection Constructor()

[image]
Intersoft WebTextEditor Documentation
WebTextEditorSection Constructor()
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorSection Class > WebTextEditorSection Constructor : WebTextEditorSection Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebTextEditorSection()
C#
public WebTextEditorSection()
Delphi
public WebTextEditorSection();
JScript
public function WebTextEditorSection();
Managed Extensions for C++
public: WebTextEditorSection();
C++/CLI
public:
WebTextEditorSection();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorSection Class
WebTextEditorSection Members
Overload List


WebTextEditorSection Constructor(SerializationInfo,StreamingContext)

[image]
Intersoft WebTextEditor Documentation
WebTextEditorSection Constructor(SerializationInfo,StreamingContext)
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorSection Class > WebTextEditorSection Constructor : WebTextEditorSection Constructor(SerializationInfo,StreamingContext)

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

Dim instance As New WebTextEditorSection(info, context)
C#
protected WebTextEditorSection(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
protected WebTextEditorSection(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
protected function WebTextEditorSection(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
protected: WebTextEditorSection(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
protected:
WebTextEditorSection(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorSection Class
WebTextEditorSection Members
Overload List


WebTextEditorSection Class Methods

[image]
Intersoft WebTextEditor Documentation
WebTextEditorSection Class Methods
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorSection Class

Glossary Item Box

For a list of all members of this type, see WebTextEditorSection members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

Protected Methods

 | Name | Description
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | IsInSerializationContext | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebTextEditorSection Class
ISNet.WebUI.WebTextEditor Namespace


GetObjectData Method

[image]
Intersoft WebTextEditor Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorSection Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorSection
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorSection Class
WebTextEditorSection Members


WebTextEditorSection Class Properties

[image]
Intersoft WebTextEditor Documentation
WebTextEditorSection Class Properties
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorSection Class

Glossary Item Box

For a list of all members of this type, see WebTextEditorSection members.

Public Properties

 | Name | Description
Public Property | AllowCollapse |
Public Property | CompleteHTMLString |
Public Property | Content | Specifies content of section.
Public Property | CssFiles | Specifies the collection css files of section.
Public Property | Height | Specifies the height of section, applied in multiple section.
Public Property | IsCompleteHTML |
Public Property | Name | Specifies the name of section.
Public Property | ReadOnly | Determines whether the section is readonly or not.
Public Property | StyleString |
Public Property | Text | Specifies the section text, applied in multiple section.
Public Property | WatermarkSettings | Specifies the WatermarkSettings of section.
Top

See Also

Reference

WebTextEditorSection Class
ISNet.WebUI.WebTextEditor Namespace


AllowCollapse Property

[image]
Intersoft WebTextEditor Documentation
AllowCollapse Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorSection Class : AllowCollapse Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BrowsableAttribute(False)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.CategoryAttribute("Section")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property AllowCollapse As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorSection
Dim value As System.Boolean

instance.AllowCollapse = value

value = instance.AllowCollapse
C#
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BrowsableAttribute(false)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.CategoryAttribute("Section")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.bool AllowCollapse {get; set;}
Delphi
public read-write property AllowCollapse: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BrowsableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.CategoryAttribute("Section")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set AllowCollapse : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BrowsableAttribute(false)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.CategoryAttribute("Section")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.bool get_AllowCollapse();
public: __property void set_AllowCollapse(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BrowsableAttribute(false)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.CategoryAttribute("Section")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.bool AllowCollapse {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorSection Class
WebTextEditorSection Members


CompleteHTMLString Property

[image]
Intersoft WebTextEditor Documentation
CompleteHTMLString Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorSection Class : CompleteHTMLString Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute()>
Public Property CompleteHTMLString As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorSection
Dim value As System.String

instance.CompleteHTMLString = value

value = instance.CompleteHTMLString
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute()]
public System.string CompleteHTMLString {get; set;}
Delphi
public read-write property CompleteHTMLString: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute()
public function get,set CompleteHTMLString : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute()]
public: __property System.string* get_CompleteHTMLString();
public: __property void set_CompleteHTMLString(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute()]
public:
property System.String^ CompleteHTMLString {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorSection Class
WebTextEditorSection Members


Content Property

[image]
Intersoft WebTextEditor Documentation
Content Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorSection Class : Content Property

Glossary Item Box

Specifies content of section.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies content of section.")>
<System.ComponentModel.CategoryAttribute("Section")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Content As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorSection
Dim value As System.String

instance.Content = value

value = instance.Content
C#
[System.ComponentModel.DescriptionAttribute("Specifies content of section.")]
[System.ComponentModel.CategoryAttribute("Section")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.string Content {get; set;}
Delphi
public read-write property Content: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies content of section.")
System.ComponentModel.CategoryAttribute("Section")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set Content : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies content of section.")]
[System.ComponentModel.CategoryAttribute("Section")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_Content();
public: __property void set_Content(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies content of section.")]
[System.ComponentModel.CategoryAttribute("Section")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ Content {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorSection Class
WebTextEditorSection Members


CssFiles Property

[image]
Intersoft WebTextEditor Documentation
CssFiles Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorSection Class : CssFiles Property

Glossary Item Box

Specifies the collection css files of section.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the collection css files of section.")>
<System.ComponentModel.CategoryAttribute("Section")>
Public ReadOnly Property CssFiles As System.Collections.Generic.List(Of WebTextEditorCssFile)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorSection
Dim value As System.Collections.Generic.List(Of WebTextEditorCssFile)

value = instance.CssFiles
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the collection css files of section.")]
[System.ComponentModel.CategoryAttribute("Section")]
public System.Collections.Generic.List<WebTextEditorCssFile> CssFiles {get;}
Delphi
public read-only property CssFiles: System.Collections.Generic.List;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the collection css files of section.")
System.ComponentModel.CategoryAttribute("Section")
public function get CssFiles : System.Collections.Generic.List
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the collection css files of section.")]
[System.ComponentModel.CategoryAttribute("Section")]
public: __property System.Collections.Generic.List<WebTextEditorCssFile*>* get_CssFiles();
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the collection css files of section.")]
[System.ComponentModel.CategoryAttribute("Section")]
public:
property System.Collections.Generic.List<WebTextEditorCssFile^>^ CssFiles {
   System.Collections.Generic.List<WebTextEditorCssFile^>^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorSection Class
WebTextEditorSection Members


Height Property

[image]
Intersoft WebTextEditor Documentation
Height Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorSection Class : Height Property

Glossary Item Box

Specifies the height of section, applied in multiple section.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Section")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the height of section, applied in multiple section.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property Height As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorSection
Dim value As System.Web.UI.WebControls.Unit

instance.Height = value

value = instance.Height
C#
[System.ComponentModel.CategoryAttribute("Section")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the height of section, applied in multiple section.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.Web.UI.WebControls.Unit Height {get; set;}
Delphi
public read-write property Height: System.Web.UI.WebControls.Unit;
JScript
System.ComponentModel.CategoryAttribute("Section")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the height of section, applied in multiple section.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set Height : System.Web.UI.WebControls.Unit
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Section")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the height of section, applied in multiple section.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.Web.UI.WebControls.Unit get_Height();
public: __property void set_Height(
   System.Web.UI.WebControls.Unit value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Section")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the height of section, applied in multiple section.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.Web.UI.WebControls.Unit Height {
   System.Web.UI.WebControls.Unit get();
   void set (    System.Web.UI.WebControls.Unit value);
}

Property Value

The default value is 100(pixel).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorSection Class
WebTextEditorSection Members


IsCompleteHTML Property

[image]
Intersoft WebTextEditor Documentation
IsCompleteHTML Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorSection Class : IsCompleteHTML Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.DescriptionAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Property IsCompleteHTML As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorSection
Dim value As System.Boolean

instance.IsCompleteHTML = value

value = instance.IsCompleteHTML
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public System.bool IsCompleteHTML {get; set;}
Delphi
public read-write property IsCompleteHTML: System.Boolean;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.DescriptionAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set IsCompleteHTML : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property System.bool get_IsCompleteHTML();
public: __property void set_IsCompleteHTML(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
property System.bool IsCompleteHTML {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorSection Class
WebTextEditorSection Members


Name Property

[image]
Intersoft WebTextEditor Documentation
Name Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorSection Class : Name Property

Glossary Item Box

Specifies the name of section.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the name of section.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Section")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property Name As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorSection
Dim value As System.String

instance.Name = value

value = instance.Name
C#
[System.ComponentModel.DescriptionAttribute("Specifies the name of section.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Section")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string Name {get; set;}
Delphi
public read-write property Name: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the name of section.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Section")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)
ISNet.Serialization.XmlSerializableAttribute()
public function get,set Name : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the name of section.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Section")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_Name();
public: __property void set_Name(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the name of section.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Section")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ Name {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorSection Class
WebTextEditorSection Members


ReadOnly Property

[image]
Intersoft WebTextEditor Documentation
ReadOnly Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorSection Class : ReadOnly Property

Glossary Item Box

Determines whether the section is readonly or not.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Determines whether the section is readonly or not.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Section")>
Public Property ReadOnly As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorSection
Dim value As System.Boolean

instance.ReadOnly = value

value = instance.ReadOnly
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether the section is readonly or not.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Section")]
public System.bool ReadOnly {get; set;}
Delphi
public read-write property ReadOnly: System.Boolean;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Determines whether the section is readonly or not.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Section")
public function get,set ReadOnly : System.boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether the section is readonly or not.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Section")]
public: __property System.bool get_ReadOnly();
public: __property void set_ReadOnly(
   System.bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Determines whether the section is readonly or not.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Section")]
public:
property System.bool ReadOnly {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is False.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorSection Class
WebTextEditorSection Members


StyleString Property

[image]
Intersoft WebTextEditor Documentation
StyleString Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorSection Class : StyleString Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.DescriptionAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.BrowsableAttribute(False)>
Public Property StyleString As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorSection
Dim value As System.String

instance.StyleString = value

value = instance.StyleString
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BrowsableAttribute(false)]
public System.string StyleString {get; set;}
Delphi
public read-write property StyleString: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.DescriptionAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.BrowsableAttribute()
public function get,set StyleString : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BrowsableAttribute(false)]
public: __property System.string* get_StyleString();
public: __property void set_StyleString(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BrowsableAttribute(false)]
public:
property System.String^ StyleString {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorSection Class
WebTextEditorSection Members


Text Property

[image]
Intersoft WebTextEditor Documentation
Text Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorSection Class : Text Property

Glossary Item Box

Specifies the section text, applied in multiple section.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the section text, applied in multiple section.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Section")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Text As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorSection
Dim value As System.String

instance.Text = value

value = instance.Text
C#
[System.ComponentModel.DescriptionAttribute("Specifies the section text, applied in multiple section.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Section")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.string Text {get; set;}
Delphi
public read-write property Text: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the section text, applied in multiple section.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Section")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set Text : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the section text, applied in multiple section.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Section")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_Text();
public: __property void set_Text(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the section text, applied in multiple section.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Section")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ Text {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorSection Class
WebTextEditorSection Members


WatermarkSettings Property

[image]
Intersoft WebTextEditor Documentation
WatermarkSettings Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorSection Class : WatermarkSettings Property

Glossary Item Box

Specifies the WatermarkSettings of section.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.DescriptionAttribute("Specifies the WatermarkSettings of section.")>
<System.ComponentModel.CategoryAttribute("Section")>
Public ReadOnly Property WatermarkSettings As WebTextEditorWatermarkSettings
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorSection
Dim value As WebTextEditorWatermarkSettings

value = instance.WatermarkSettings
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Specifies the WatermarkSettings of section.")]
[System.ComponentModel.CategoryAttribute("Section")]
public WebTextEditorWatermarkSettings WatermarkSettings {get;}
Delphi
public read-only property WatermarkSettings: WebTextEditorWatermarkSettings;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.DescriptionAttribute("Specifies the WatermarkSettings of section.")
System.ComponentModel.CategoryAttribute("Section")
public function get WatermarkSettings : WebTextEditorWatermarkSettings
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Specifies the WatermarkSettings of section.")]
[System.ComponentModel.CategoryAttribute("Section")]
public: __property WebTextEditorWatermarkSettings* get_WatermarkSettings();
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.DescriptionAttribute("Specifies the WatermarkSettings of section.")]
[System.ComponentModel.CategoryAttribute("Section")]
public:
property WebTextEditorWatermarkSettings^ WatermarkSettings {
   WebTextEditorWatermarkSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorSection Class
WebTextEditorSection Members


WebTextEditorSendMailArgs Class

[image]
Intersoft WebTextEditor Documentation
WebTextEditorSendMailArgs Class
Members See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorSendMailArgs Class

Glossary Item Box

Provides data for SendMail event.

Object Model

WebTextEditorSendMailArgs Class

Syntax

Visual Basic (Declaration)
Public Class WebTextEditorSendMailArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorSendMailArgs
C#
public class WebTextEditorSendMailArgs : System.EventArgs
Delphi
public class WebTextEditorSendMailArgs = class(System.EventArgs)
JScript
public class WebTextEditorSendMailArgs extends System.EventArgs
Managed Extensions for C++
public __gc class WebTextEditorSendMailArgs : public System.EventArgs
C++/CLI
public ref class WebTextEditorSendMailArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
ISNet.WebUI.WebTextEditor.WebTextEditorSendMailArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorSendMailArgs Members
ISNet.WebUI.WebTextEditor Namespace


WebTextEditorSendMailArgs Class Members

[image]
Intersoft WebTextEditor Documentation
WebTextEditorSendMailArgs Class Members
See Also Properties Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorSendMailArgs Class

Glossary Item Box

The following tables list the members exposed by WebTextEditorSendMailArgs.

Public Constructors

 | Name | Description
Public Constructor | WebTextEditorSendMailArgs Constructor |
Top

Public Properties

 | Name | Description
Public Property | Cancel |
Public Property | MailMerge |
Public Property | MailMessage |
Public Property | SmtpClient |
Top

See Also

Reference

WebTextEditorSendMailArgs Class
ISNet.WebUI.WebTextEditor Namespace


WebTextEditorSendMailArgs Constructor

[image]
Intersoft WebTextEditor Documentation
WebTextEditorSendMailArgs Constructor
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorSendMailArgs Class : WebTextEditorSendMailArgs Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebTextEditorSendMailArgs()
C#
public WebTextEditorSendMailArgs()
Delphi
public WebTextEditorSendMailArgs();
JScript
public function WebTextEditorSendMailArgs();
Managed Extensions for C++
public: WebTextEditorSendMailArgs();
C++/CLI
public:
WebTextEditorSendMailArgs();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorSendMailArgs Class
WebTextEditorSendMailArgs Members


WebTextEditorSendMailArgs Class Properties

[image]
Intersoft WebTextEditor Documentation
WebTextEditorSendMailArgs Class Properties
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorSendMailArgs Class

Glossary Item Box

For a list of all members of this type, see WebTextEditorSendMailArgs members.

Public Properties

 | Name | Description
Public Property | Cancel |
Public Property | MailMerge |
Public Property | MailMessage |
Public Property | SmtpClient |
Top

See Also

Reference

WebTextEditorSendMailArgs Class
ISNet.WebUI.WebTextEditor Namespace


Cancel Property

[image]
Intersoft WebTextEditor Documentation
Cancel Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorSendMailArgs Class : Cancel Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Cancel As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorSendMailArgs
Dim value As System.Boolean

instance.Cancel = value

value = instance.Cancel
C#
public System.bool Cancel {get; set;}
Delphi
public read-write property Cancel: System.Boolean;
JScript
public function get,set Cancel : System.boolean
Managed Extensions for C++
public: __property System.bool get_Cancel();
public: __property void set_Cancel(
   System.bool value
);
C++/CLI
public:
property System.bool Cancel {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorSendMailArgs Class
WebTextEditorSendMailArgs Members


MailMerge Property

[image]
Intersoft WebTextEditor Documentation
MailMerge Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorSendMailArgs Class : MailMerge Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property MailMerge As WebTextEditorMailMergeObject
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorSendMailArgs
Dim value As WebTextEditorMailMergeObject

instance.MailMerge = value

value = instance.MailMerge
C#
public WebTextEditorMailMergeObject MailMerge {get; set;}
Delphi
public read-write property MailMerge: WebTextEditorMailMergeObject;
JScript
public function get,set MailMerge : WebTextEditorMailMergeObject
Managed Extensions for C++
public: __property WebTextEditorMailMergeObject* get_MailMerge();
public: __property void set_MailMerge(
   WebTextEditorMailMergeObject* value
);
C++/CLI
public:
property WebTextEditorMailMergeObject^ MailMerge {
   WebTextEditorMailMergeObject^ get();
   void set (    WebTextEditorMailMergeObject^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorSendMailArgs Class
WebTextEditorSendMailArgs Members


MailMessage Property

[image]
Intersoft WebTextEditor Documentation
MailMessage Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorSendMailArgs Class : MailMessage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property MailMessage As System.Net.Mail.MailMessage
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorSendMailArgs
Dim value As System.Net.Mail.MailMessage

instance.MailMessage = value

value = instance.MailMessage
C#
public System.Net.Mail.MailMessage MailMessage {get; set;}
Delphi
public read-write property MailMessage: System.Net.Mail.MailMessage;
JScript
public function get,set MailMessage : System.Net.Mail.MailMessage
Managed Extensions for C++
public: __property System.Net.Mail.MailMessage* get_MailMessage();
public: __property void set_MailMessage(
   System.Net.Mail.MailMessage* value
);
C++/CLI
public:
property System.Net.Mail.MailMessage^ MailMessage {
   System.Net.Mail.MailMessage^ get();
   void set (    System.Net.Mail.MailMessage^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorSendMailArgs Class
WebTextEditorSendMailArgs Members


SmtpClient Property

[image]
Intersoft WebTextEditor Documentation
SmtpClient Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorSendMailArgs Class : SmtpClient Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property SmtpClient As System.Net.Mail.SmtpClient
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorSendMailArgs
Dim value As System.Net.Mail.SmtpClient

instance.SmtpClient = value

value = instance.SmtpClient
C#
public System.Net.Mail.SmtpClient SmtpClient {get; set;}
Delphi
public read-write property SmtpClient: System.Net.Mail.SmtpClient;
JScript
public function get,set SmtpClient : System.Net.Mail.SmtpClient
Managed Extensions for C++
public: __property System.Net.Mail.SmtpClient* get_SmtpClient();
public: __property void set_SmtpClient(
   System.Net.Mail.SmtpClient* value
);
C++/CLI
public:
property System.Net.Mail.SmtpClient^ SmtpClient {
   System.Net.Mail.SmtpClient^ get();
   void set (    System.Net.Mail.SmtpClient^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorSendMailArgs Class
WebTextEditorSendMailArgs Members


WebTextEditorSendMailCompletedArgs Class

[image]
Intersoft WebTextEditor Documentation
WebTextEditorSendMailCompletedArgs Class
Members See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorSendMailCompletedArgs Class

Glossary Item Box

Provides data for SendMail complete event.

Object Model

WebTextEditorSendMailCompletedArgs Class

Syntax

Visual Basic (Declaration)
Public Class WebTextEditorSendMailCompletedArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorSendMailCompletedArgs
C#
public class WebTextEditorSendMailCompletedArgs : System.EventArgs
Delphi
public class WebTextEditorSendMailCompletedArgs = class(System.EventArgs)
JScript
public class WebTextEditorSendMailCompletedArgs extends System.EventArgs
Managed Extensions for C++
public __gc class WebTextEditorSendMailCompletedArgs : public System.EventArgs
C++/CLI
public ref class WebTextEditorSendMailCompletedArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
ISNet.WebUI.WebTextEditor.WebTextEditorSendMailCompletedArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorSendMailCompletedArgs Members
ISNet.WebUI.WebTextEditor Namespace


WebTextEditorSendMailCompletedArgs Class Members

[image]
Intersoft WebTextEditor Documentation
WebTextEditorSendMailCompletedArgs Class Members
See Also Properties Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorSendMailCompletedArgs Class

Glossary Item Box

The following tables list the members exposed by WebTextEditorSendMailCompletedArgs.

Public Constructors

 | Name | Description
Public Constructor | WebTextEditorSendMailCompletedArgs Constructor |
Top

Public Properties

 | Name | Description
Public Property | FailedEmails |
Top

See Also

Reference

WebTextEditorSendMailCompletedArgs Class
ISNet.WebUI.WebTextEditor Namespace


WebTextEditorSendMailCompletedArgs Constructor

[image]
Intersoft WebTextEditor Documentation
WebTextEditorSendMailCompletedArgs Constructor
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorSendMailCompletedArgs Class : WebTextEditorSendMailCompletedArgs Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebTextEditorSendMailCompletedArgs()
C#
public WebTextEditorSendMailCompletedArgs()
Delphi
public WebTextEditorSendMailCompletedArgs();
JScript
public function WebTextEditorSendMailCompletedArgs();
Managed Extensions for C++
public: WebTextEditorSendMailCompletedArgs();
C++/CLI
public:
WebTextEditorSendMailCompletedArgs();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorSendMailCompletedArgs Class
WebTextEditorSendMailCompletedArgs Members


WebTextEditorSendMailCompletedArgs Class Properties

[image]
Intersoft WebTextEditor Documentation
WebTextEditorSendMailCompletedArgs Class Properties
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorSendMailCompletedArgs Class

Glossary Item Box

For a list of all members of this type, see WebTextEditorSendMailCompletedArgs members.

Public Properties

 | Name | Description
Public Property | FailedEmails |
Top

See Also

Reference

WebTextEditorSendMailCompletedArgs Class
ISNet.WebUI.WebTextEditor Namespace


FailedEmails Property

[image]
Intersoft WebTextEditor Documentation
FailedEmails Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorSendMailCompletedArgs Class : FailedEmails Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property FailedEmails As System.Collections.Generic.List(Of String)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorSendMailCompletedArgs
Dim value As System.Collections.Generic.List(Of String)

instance.FailedEmails = value

value = instance.FailedEmails
C#
public System.Collections.Generic.List<string> FailedEmails {get; set;}
Delphi
public read-write property FailedEmails: System.Collections.Generic.List;
JScript
public function get,set FailedEmails : System.Collections.Generic.List
Managed Extensions for C++
public: __property System.Collections.Generic.List<string*>* get_FailedEmails();
public: __property void set_FailedEmails(
   System.Collections.Generic.List<string*>* value
);
C++/CLI
public:
property System.Collections.Generic.List<String^>^ FailedEmails {
   System.Collections.Generic.List<String^>^ get();
   void set (    System.Collections.Generic.List<String^>^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorSendMailCompletedArgs Class
WebTextEditorSendMailCompletedArgs Members


WebTextEditorTaskPaneSettings Class

[image]
Intersoft WebTextEditor Documentation
WebTextEditorTaskPaneSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorTaskPaneSettings Class

Glossary Item Box

A collection of WebTextEditor's TaskPane settings.

Object Model

WebTextEditorTaskPaneSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebTextEditorTaskPaneSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTaskPaneSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebTextEditorTaskPaneSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebTextEditorTaskPaneSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebTextEditorTaskPaneSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebTextEditorTaskPaneSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebTextEditorTaskPaneSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebTextEditor.WebTextEditorTaskPaneSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTaskPaneSettings Members
ISNet.WebUI.WebTextEditor Namespace


WebTextEditorTaskPaneSettings Class Members

[image]
Intersoft WebTextEditor Documentation
WebTextEditorTaskPaneSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorTaskPaneSettings Class

Glossary Item Box

The following tables list the members exposed by WebTextEditorTaskPaneSettings.

Public Constructors

 | Name | Description
Public Constructor | WebTextEditorTaskPaneSettings Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | CustomPanes |
Public Property | FileUploader |
Public Property | ImageEditor |
Public Property | MediaGallery |
Public Property | PropertyWindow |
Public Property | Research |
Public Property | SpellChecker |
Public Property | TaskPanePosition | Specifies the task pane position when it is displayed.
Public Property | ToolBox |
Public Property | UseCustomPane | Specifies whether or not custom pane is used in task pane.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

Protected Methods

 | Name | Description
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | IsInSerializationContext | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebTextEditorTaskPaneSettings Class
ISNet.WebUI.WebTextEditor Namespace


WebTextEditorTaskPaneSettings Constructor

[image]
Intersoft WebTextEditor Documentation
WebTextEditorTaskPaneSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTaskPaneSettings Class : WebTextEditorTaskPaneSettings Constructor

Glossary Item Box

Overload List

Overload | Description
WebTextEditorTaskPaneSettings Constructor() |
WebTextEditorTaskPaneSettings Constructor(SerializationInfo,StreamingContext) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTaskPaneSettings Class
WebTextEditorTaskPaneSettings Members


WebTextEditorTaskPaneSettings Constructor()

[image]
Intersoft WebTextEditor Documentation
WebTextEditorTaskPaneSettings Constructor()
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTaskPaneSettings Class > WebTextEditorTaskPaneSettings Constructor : WebTextEditorTaskPaneSettings Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebTextEditorTaskPaneSettings()
C#
public WebTextEditorTaskPaneSettings()
Delphi
public WebTextEditorTaskPaneSettings();
JScript
public function WebTextEditorTaskPaneSettings();
Managed Extensions for C++
public: WebTextEditorTaskPaneSettings();
C++/CLI
public:
WebTextEditorTaskPaneSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTaskPaneSettings Class
WebTextEditorTaskPaneSettings Members
Overload List


WebTextEditorTaskPaneSettings Constructor(SerializationInfo,StreamingContext)

[image]
Intersoft WebTextEditor Documentation
WebTextEditorTaskPaneSettings Constructor(SerializationInfo,StreamingContext)
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTaskPaneSettings Class > WebTextEditorTaskPaneSettings Constructor : WebTextEditorTaskPaneSettings Constructor(SerializationInfo,StreamingContext)

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

Dim instance As New WebTextEditorTaskPaneSettings(info, context)
C#
protected WebTextEditorTaskPaneSettings(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
protected WebTextEditorTaskPaneSettings(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
protected function WebTextEditorTaskPaneSettings(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
protected: WebTextEditorTaskPaneSettings(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
protected:
WebTextEditorTaskPaneSettings(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTaskPaneSettings Class
WebTextEditorTaskPaneSettings Members
Overload List


WebTextEditorTaskPaneSettings Class Methods

[image]
Intersoft WebTextEditor Documentation
WebTextEditorTaskPaneSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorTaskPaneSettings Class

Glossary Item Box

For a list of all members of this type, see WebTextEditorTaskPaneSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

Protected Methods

 | Name | Description
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | IsInSerializationContext | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebTextEditorTaskPaneSettings Class
ISNet.WebUI.WebTextEditor Namespace


GetObjectData Method

[image]
Intersoft WebTextEditor Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTaskPaneSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTaskPaneSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTaskPaneSettings Class
WebTextEditorTaskPaneSettings Members


WebTextEditorTaskPaneSettings Class Properties

[image]
Intersoft WebTextEditor Documentation
WebTextEditorTaskPaneSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorTaskPaneSettings Class

Glossary Item Box

For a list of all members of this type, see WebTextEditorTaskPaneSettings members.

Public Properties

 | Name | Description
Public Property | CustomPanes |
Public Property | FileUploader |
Public Property | ImageEditor |
Public Property | MediaGallery |
Public Property | PropertyWindow |
Public Property | Research |
Public Property | SpellChecker |
Public Property | TaskPanePosition | Specifies the task pane position when it is displayed.
Public Property | ToolBox |
Public Property | UseCustomPane | Specifies whether or not custom pane is used in task pane.
Top

See Also

Reference

WebTextEditorTaskPaneSettings Class
ISNet.WebUI.WebTextEditor Namespace


CustomPanes Property

[image]
Intersoft WebTextEditor Documentation
CustomPanes Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTaskPaneSettings Class : CustomPanes Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Pane")>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<System.ComponentModel.DescriptionAttribute()>
Public ReadOnly Property CustomPanes As CustomPaneCollection
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTaskPaneSettings
Dim value As CustomPaneCollection

value = instance.CustomPanes
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Pane")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DescriptionAttribute()]
public CustomPaneCollection CustomPanes {get;}
Delphi
public read-only property CustomPanes: CustomPaneCollection;
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Pane")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute()
public function get CustomPanes : CustomPaneCollection
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Pane")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DescriptionAttribute()]
public: __property CustomPaneCollection* get_CustomPanes();
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Pane")]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DescriptionAttribute()]
public:
property CustomPaneCollection^ CustomPanes {
   CustomPaneCollection^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTaskPaneSettings Class
WebTextEditorTaskPaneSettings Members


FileUploader Property

[image]
Intersoft WebTextEditor Documentation
FileUploader Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTaskPaneSettings Class : FileUploader Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DescriptionAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Pane")>
<System.ComponentModel.DefaultValueAttribute()>
Public ReadOnly Property FileUploader As FileUploader
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTaskPaneSettings
Dim value As FileUploader

value = instance.FileUploader
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Pane")]
[System.ComponentModel.DefaultValueAttribute()]
public FileUploader FileUploader {get;}
Delphi
public read-only property FileUploader: FileUploader;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DescriptionAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Pane")
System.ComponentModel.DefaultValueAttribute()
public function get FileUploader : FileUploader
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Pane")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property FileUploader* get_FileUploader();
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Pane")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property FileUploader^ FileUploader {
   FileUploader^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTaskPaneSettings Class
WebTextEditorTaskPaneSettings Members


ImageEditor Property

[image]
Intersoft WebTextEditor Documentation
ImageEditor Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTaskPaneSettings Class : ImageEditor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.BrowsableAttribute(False)>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Pane")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute()>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public ReadOnly Property ImageEditor As ImageEditor
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTaskPaneSettings
Dim value As ImageEditor

value = instance.ImageEditor
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.BrowsableAttribute(false)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Pane")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public ImageEditor ImageEditor {get;}
Delphi
public read-only property ImageEditor: ImageEditor;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.BrowsableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Pane")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get ImageEditor : ImageEditor
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.BrowsableAttribute(false)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Pane")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property ImageEditor* get_ImageEditor();
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.BrowsableAttribute(false)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Pane")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property ImageEditor^ ImageEditor {
   ImageEditor^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTaskPaneSettings Class
WebTextEditorTaskPaneSettings Members


MediaGallery Property

[image]
Intersoft WebTextEditor Documentation
MediaGallery Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTaskPaneSettings Class : MediaGallery Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Pane")>
<System.ComponentModel.DefaultValueAttribute()>
Public ReadOnly Property MediaGallery As MediaGallery
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTaskPaneSettings
Dim value As MediaGallery

value = instance.MediaGallery
C#
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Pane")]
[System.ComponentModel.DefaultValueAttribute()]
public MediaGallery MediaGallery {get;}
Delphi
public read-only property MediaGallery: MediaGallery;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Pane")
System.ComponentModel.DefaultValueAttribute()
public function get MediaGallery : MediaGallery
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Pane")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property MediaGallery* get_MediaGallery();
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Pane")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property MediaGallery^ MediaGallery {
   MediaGallery^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTaskPaneSettings Class
WebTextEditorTaskPaneSettings Members


PropertyWindow Property

[image]
Intersoft WebTextEditor Documentation
PropertyWindow Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTaskPaneSettings Class : PropertyWindow Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.BrowsableAttribute(False)>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute()>
<System.ComponentModel.CategoryAttribute("Pane")>
Public ReadOnly Property PropertyWindow As PropertyWindow
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTaskPaneSettings
Dim value As PropertyWindow

value = instance.PropertyWindow
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.BrowsableAttribute(false)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.CategoryAttribute("Pane")]
public PropertyWindow PropertyWindow {get;}
Delphi
public read-only property PropertyWindow: PropertyWindow;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.BrowsableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute()
System.ComponentModel.CategoryAttribute("Pane")
public function get PropertyWindow : PropertyWindow
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.BrowsableAttribute(false)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.CategoryAttribute("Pane")]
public: __property PropertyWindow* get_PropertyWindow();
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.BrowsableAttribute(false)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.CategoryAttribute("Pane")]
public:
property PropertyWindow^ PropertyWindow {
   PropertyWindow^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTaskPaneSettings Class
WebTextEditorTaskPaneSettings Members


Research Property

[image]
Intersoft WebTextEditor Documentation
Research Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTaskPaneSettings Class : Research Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.CategoryAttribute("Pane")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public ReadOnly Property Research As Research
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTaskPaneSettings
Dim value As Research

value = instance.Research
C#
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Pane")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public Research Research {get;}
Delphi
public read-only property Research: Research;
JScript
System.ComponentModel.DescriptionAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.CategoryAttribute("Pane")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get Research : Research
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Pane")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property Research* get_Research();
C++/CLI
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.CategoryAttribute("Pane")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property Research^ Research {
   Research^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTaskPaneSettings Class
WebTextEditorTaskPaneSettings Members


SpellChecker Property

[image]
Intersoft WebTextEditor Documentation
SpellChecker Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTaskPaneSettings Class : SpellChecker Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DescriptionAttribute()>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.CategoryAttribute("Pane")>
<System.ComponentModel.DefaultValueAttribute()>
Public ReadOnly Property SpellChecker As SpellChecker
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTaskPaneSettings
Dim value As SpellChecker

value = instance.SpellChecker
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.CategoryAttribute("Pane")]
[System.ComponentModel.DefaultValueAttribute()]
public SpellChecker SpellChecker {get;}
Delphi
public read-only property SpellChecker: SpellChecker;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DescriptionAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.CategoryAttribute("Pane")
System.ComponentModel.DefaultValueAttribute()
public function get SpellChecker : SpellChecker
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.CategoryAttribute("Pane")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property SpellChecker* get_SpellChecker();
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DescriptionAttribute()]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.CategoryAttribute("Pane")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property SpellChecker^ SpellChecker {
   SpellChecker^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTaskPaneSettings Class
WebTextEditorTaskPaneSettings Members


TaskPanePosition Property

[image]
Intersoft WebTextEditor Documentation
TaskPanePosition Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTaskPaneSettings Class : TaskPanePosition Property

Glossary Item Box

Specifies the task pane position when it is displayed.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the task pane position when it is displayed.")>
<System.ComponentModel.CategoryAttribute("Pane")>
Public Property TaskPanePosition As WebTextEditorTaskPanePosition
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTaskPaneSettings
Dim value As WebTextEditorTaskPanePosition

instance.TaskPanePosition = value

value = instance.TaskPanePosition
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the task pane position when it is displayed.")]
[System.ComponentModel.CategoryAttribute("Pane")]
public WebTextEditorTaskPanePosition TaskPanePosition {get; set;}
Delphi
public read-write property TaskPanePosition: WebTextEditorTaskPanePosition;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the task pane position when it is displayed.")
System.ComponentModel.CategoryAttribute("Pane")
public function get,set TaskPanePosition : WebTextEditorTaskPanePosition
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the task pane position when it is displayed.")]
[System.ComponentModel.CategoryAttribute("Pane")]
public: __property WebTextEditorTaskPanePosition get_TaskPanePosition();
public: __property void set_TaskPanePosition(
   WebTextEditorTaskPanePosition value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the task pane position when it is displayed.")]
[System.ComponentModel.CategoryAttribute("Pane")]
public:
property WebTextEditorTaskPanePosition TaskPanePosition {
   WebTextEditorTaskPanePosition get();
   void set (    WebTextEditorTaskPanePosition value);
}

Property Value

The default value is Right.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTaskPaneSettings Class
WebTextEditorTaskPaneSettings Members


ToolBox Property

[image]
Intersoft WebTextEditor Documentation
ToolBox Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTaskPaneSettings Class : ToolBox Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.BrowsableAttribute(False)>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute()>
<System.ComponentModel.CategoryAttribute("Pane")>
Public ReadOnly Property ToolBox As ToolBox
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTaskPaneSettings
Dim value As ToolBox

value = instance.ToolBox
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.BrowsableAttribute(false)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.CategoryAttribute("Pane")]
public ToolBox ToolBox {get;}
Delphi
public read-only property ToolBox: ToolBox;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.BrowsableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute()
System.ComponentModel.CategoryAttribute("Pane")
public function get ToolBox : ToolBox
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.BrowsableAttribute(false)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.CategoryAttribute("Pane")]
public: __property ToolBox* get_ToolBox();
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.BrowsableAttribute(false)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute()]
[System.ComponentModel.CategoryAttribute("Pane")]
public:
property ToolBox^ ToolBox {
   ToolBox^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTaskPaneSettings Class
WebTextEditorTaskPaneSettings Members


UseCustomPane Property

[image]
Intersoft WebTextEditor Documentation
UseCustomPane Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTaskPaneSettings Class : UseCustomPane Property

Glossary Item Box

Specifies whether or not custom pane is used in task pane.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies whether or not custom pane is used in task pane.")>
<System.ComponentModel.CategoryAttribute("Pane")>
Public Property UseCustomPane As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTaskPaneSettings
Dim value As System.Boolean

instance.UseCustomPane = value

value = instance.UseCustomPane
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not custom pane is used in task pane.")]
[System.ComponentModel.CategoryAttribute("Pane")]
public System.bool UseCustomPane {get; set;}
Delphi
public read-write property UseCustomPane: System.Boolean;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether or not custom pane is used in task pane.")
System.ComponentModel.CategoryAttribute("Pane")
public function get,set UseCustomPane : System.boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not custom pane is used in task pane.")]
[System.ComponentModel.CategoryAttribute("Pane")]
public: __property System.bool get_UseCustomPane();
public: __property void set_UseCustomPane(
   System.bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not custom pane is used in task pane.")]
[System.ComponentModel.CategoryAttribute("Pane")]
public:
property System.bool UseCustomPane {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is false.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTaskPaneSettings Class
WebTextEditorTaskPaneSettings Members


WebTextEditorTextSettings Class

[image]
Intersoft WebTextEditor Documentation
WebTextEditorTextSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorTextSettings Class

Glossary Item Box

A collection of settings which controls the text shown in WebTextEditor.

Object Model

WebTextEditorTextSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebTextEditorTextSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebTextEditorTextSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebTextEditorTextSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebTextEditorTextSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebTextEditorTextSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebTextEditorTextSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebTextEditor.WebTextEditorTextSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Members
ISNet.WebUI.WebTextEditor Namespace


WebTextEditorTextSettings Class Members

[image]
Intersoft WebTextEditor Documentation
WebTextEditorTextSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorTextSettings Class

Glossary Item Box

The following tables list the members exposed by WebTextEditorTextSettings.

Public Constructors

 | Name | Description
Public Constructor | WebTextEditorTextSettings Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | CallOutButtonApplyText | Specifies the text of Apply button in callout.
Public Property | CallOutButtonCancelText | Specifies the text of Cancel button in callout.
Public Property | CallOutButtonFindText | Specifies the text of Find button in callout..
Public Property | CallOutButtonInsertFromWebText | Specifies the text of Insert Media button in callout.
Public Property | CallOutButtonInsertLinkText | Specifies the text of Insert Link button in callout.
Public Property | CallOutButtonPasteText | Specifies the text of Paste button in callout.
Public Property | CallOutButtonReplaceAllText | Specifies the text of Replace All button in callout.
Public Property | CallOutButtonReplaceText | Specifies the text of Replace button in callout.
Public Property | CallOutCheckBoxMatchCaseText | Specifies the text of Match Case checkbox in callout.
Public Property | CallOutFindText | Specifies the text of Find field name in callout.
Public Property | CallOutHyperlinkLinkText | Specifies the text of Link field name in callout.
Public Property | CallOutHyperlinkTargetText | Specifies the text of Target field name in callout.
Public Property | CallOutHyperlinkText | Specifies the text of Text field name in callout.
Public Property | CallOutMediaAlignmentText | Specifies the text of Caption Alignment field name in callout.
Public Property | CallOutMediaCaptionText | Specifies the text of Media Caption field name in callout.
Public Property | CallOutMediaLinkURLText | Specifies the text of Link URL field name in callout.
Public Property | CallOutMediaSizeText | Specifies the text of Size field name in callout.
Public Property | CallOutMediaTitleText | Specifies the text of Media Title field name in callout.
Public Property | CallOutMediaTypeText | Specifies the text of Media Type field name in callout.
Public Property | CallOutMediaURLText | Specifies the text of Media URL field name in callout.
Public Property | CallOutMediaUseFrameText | Specifies the text of Use Frame checkbox in callout.
Public Property | CallOutPasteTitleText | Specifies the text of Paste Information title in callout.
Public Property | CallOutReplaceText | Specifies the text of Replace field name in callout.
Public Property | CharacterInformationText | Specifies the text of character information in tooltip.
Public Property | CopyText | Specifies the text of Copy menu item in context menu.
Public Property | CutText | Specifies the text of Cut menu item in context menu.
Public Property | DeleteColumnText | Specifies the text of Delete Column item in Table Designer pane and context menu.
Public Property | DeleteRowText | Specifies the text of Delete Row item in Table Designer pane and context menu.
Public Property | DesignViewText | Specifies the text of Design view tab in footer row.
Public Property | EditTableText | Specifies the text of Edit Table command in Table Designer toolbar.
Public Property | FailedSendMailText | Specifies the text that will be displayed in status bar when the mails failed to be sent.
Public Property | ForceExitSpellCheckingStatus | Specifies the text when force spell checker to exit.
Public Property | HtmlViewText | Specifies the text of HTML view tab in footer row.
Public Property | InsertButtonText | Specifies the text of Insert Button item in Form Control pane.
Public Property | InsertFieldsetText | Specifies the text of Insert Fieldset item in Form Control pane.
Public Property | InsertHorizontalRuleText | Specifies the text of Insert Horizontal Rule item in Form Control pane.
Public Property | InsertIFrameText | Specifies the text of Insert IFrame item in Form Control pane.
Public Property | InsertInputButtonText | Specifies the text of Insert Input Button item in Form Control pane.
Public Property | InsertInputCheckBoxText | Specifies the text of Insert Input CheckBox item in Form Control pane.
Public Property | InsertInputFileUploadText | Specifies the text of Insert Input File Upload item in Form Control pane.
Public Property | InsertInputHiddenText | Specifies the text of Insert Input Hidden item in Form Control pane.
Public Property | InsertInputPasswordText | Specifies the text of Insert Password item in Form Control pane.
Public Property | InsertInputRadioText | Specifies the text of Insert Radio item in Form Control pane.
Public Property | InsertInputResetText | Specifies the text of Insert Reset item in Form Control pane.
Public Property | InsertInputSubmitText | Specifies the text of Insert Submit item in Form Control pane.
Public Property | InsertInputText | Specifies the text of Insert Text item in Form Control pane.
Public Property | InsertLeftColumnsText | Specifies the text of Insert Columns to the Left item in Table Designer pane and context menu.
Public Property | InsertMarqueeText | Specifies the text of Insert Marquee item in Form Control pane.
Public Property | InsertMergeCellsText | Specifies the text of Merge Cells item in Table Designer pane and context menu.
Public Property | InsertRightColumnsText | Specifies the text of Insert Columns to the Right item in Table Designer pane and context menu.
Public Property | InsertRowsAboveText | Specifies the text of Insert Rows Above item in Table Designer pane and context menu.
Public Property | InsertRowsBelowText | Specifies the text of Insert Rows Below item in Table Designer pane and context menu.
Public Property | InsertSelectDropdownText | Specifies the text of Insert Select Dropdown item in Form Control pane.
Public Property | InsertSelectListboxText | Specifies the text of Insert Select Listbox item in Form Control pane.
Public Property | InsertSplitCellsText | Specifies the text of Split Cells item in Table Designer pane and context menu.
Public Property | InsertTableText | Specifies the text of Insert Table command in Table Designer toolbar.
Public Property | InsertTextAreaText | Specifies the text of Insert TextArea item in Form Control pane.
Public Property | MergeCellDown | Specifies the text of Merge Cell Down item in Table Designer pane and context menu.
Public Property | MergeCellRight | Specifies the text of Merge Cell Right item in Table Designer pane and context menu.
Public Property | NoResultFoundText | Specifies the text when no result is found when searching the media in Media Gallery pane.
Public Property | PasteText | Specifies the text of Paste menu item in context menu.
Public Property | PreviewMailMergeText | Specifies the text that will be displayed in status bar when the preview data is being fetched.
Public Property | PreviewText | Specifies the text of Preview view tab in footer row.
Public Property | ReadyText | Specifies the text displayed in status when the editor is in Ready state.
Public Property | ResultTypeText | Specifies the text of Result Type field name in Media Gallery pane.
Public Property | SaveStatus | Specifies the text when auto save has been performed.
Public Property | SearchingMediaText | Specifies the text displayed in status bar when media search action is being performed.
Public Property | SearchInText | Specifies the text of Search In field name in Media Gallery pane.
Public Property | SendMailMergeText | Specifies the text that will be displayed in status bar when the mails are being sent.
Public Property | SpellCheckingCompletedStatus | Specifies the text when spell checking has been completed.
Public Property | SplitCellHorizontal | Specifies the text of Split Cell Horizontal item in Table Designer pane and context menu.
Public Property | SplitCellVertical | Specifies the text of Split Cell Vertical item in Table Designer pane and context menu.
Public Property | SplitViewText | Specifies the text of Split view tab in footer row.
Public Property | SuccessSendMailText | Specifies the text that will be displayed in status bar when the emails have been successfully sent.
Public Property | TableAlignmentText | Specifies the text of Table Alignment field name in Table Designer pane.
Public Property | TableBackColorText | Specifies the text of Table Back Color field name in Table Designer pane.
Public Property | TableBorderColorText | Specifies the text of Table Border Color field name in Table Designer pane.
Public Property | TableBorderWidthText | Specifies the text of Table Border Width field name in Table Designer pane.
Public Property | TableCaptionText | Specifies the text of Table Caption field name in Table Designer pane.
Public Property | TableCellActionsText | Specifies the text of Cell Actions title in Table Designer pane.
Public Property | TableCellPaddingText | Specifies the text of Cell Padding field name in Table Designer pane.
Public Property | TableCellPropertiesText | Specifies the text of Cell Properties title in Table Designer pane.
Public Property | TableCellSpacingText | Specifies the text of Cell Spacing field name in Table Designer pane.
Public Property | TableColumnsText | Specifies the text of Columns field name in Table Designer pane.
Public Property | TableCustomText | Specifies the text of Custom radio button in Table Designer pane.
Public Property | TableDesignerText | Specifies the text of Table Designer title.
Public Property | TableFontColorText | Specifies the text of Table Font Color field name in Table Designer pane.
Public Property | TableHeightText | Specifies the text of Table Height field name in Table Designer pane.
Public Property | TableHorizontalAlignText | Specifies the text of Table Horizontal Align field name in Table Designer pane.
Public Property | TableNoWrapText | Specifies the text of No Wrap checkbox in Table Designer pane.
Public Property | TablePropertiesText | Specifies the text of Table Properties title in Table Designer pane.
Public Property | TableRowsText | Specifies the text of Rows field name in Table Designer pane.
Public Property | TableSummaryText | Specifies the text of Summary field name in Table Designer pane.
Public Property | TableTemplateText | Specifies the text of Template radio button in Table Designer pane.
Public Property | TableVerticalAlignText | Specifies the text of Vertical Align field name in Table Designer pane.
Public Property | TableWidthText | Specifies the text of Table Width field name in Table Designer pane.
Public Property | TaskPaneHTMLViewText | Specifies the text of pane content when viewing in HTML view.
Public Property | WordsInformationText | Specifies the text of word information in footer row.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

Protected Methods

 | Name | Description
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | IsInSerializationContext | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebTextEditorTextSettings Class
ISNet.WebUI.WebTextEditor Namespace


WebTextEditorTextSettings Constructor

[image]
Intersoft WebTextEditor Documentation
WebTextEditorTextSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : WebTextEditorTextSettings Constructor

Glossary Item Box

Overload List

Overload | Description
WebTextEditorTextSettings Constructor() |
WebTextEditorTextSettings Constructor(SerializationInfo,StreamingContext) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


WebTextEditorTextSettings Constructor()

[image]
Intersoft WebTextEditor Documentation
WebTextEditorTextSettings Constructor()
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class > WebTextEditorTextSettings Constructor : WebTextEditorTextSettings Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebTextEditorTextSettings()
C#
public WebTextEditorTextSettings()
Delphi
public WebTextEditorTextSettings();
JScript
public function WebTextEditorTextSettings();
Managed Extensions for C++
public: WebTextEditorTextSettings();
C++/CLI
public:
WebTextEditorTextSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members
Overload List


WebTextEditorTextSettings Constructor(SerializationInfo,StreamingContext)

[image]
Intersoft WebTextEditor Documentation
WebTextEditorTextSettings Constructor(SerializationInfo,StreamingContext)
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class > WebTextEditorTextSettings Constructor : WebTextEditorTextSettings Constructor(SerializationInfo,StreamingContext)

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

Dim instance As New WebTextEditorTextSettings(info, context)
C#
protected WebTextEditorTextSettings(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
protected WebTextEditorTextSettings(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
protected function WebTextEditorTextSettings(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
protected: WebTextEditorTextSettings(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
protected:
WebTextEditorTextSettings(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members
Overload List


WebTextEditorTextSettings Class Methods

[image]
Intersoft WebTextEditor Documentation
WebTextEditorTextSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorTextSettings Class

Glossary Item Box

For a list of all members of this type, see WebTextEditorTextSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

Protected Methods

 | Name | Description
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | IsInSerializationContext | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebTextEditorTextSettings Class
ISNet.WebUI.WebTextEditor Namespace


GetObjectData Method

[image]
Intersoft WebTextEditor Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


WebTextEditorTextSettings Class Properties

[image]
Intersoft WebTextEditor Documentation
WebTextEditorTextSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorTextSettings Class

Glossary Item Box

For a list of all members of this type, see WebTextEditorTextSettings members.

Public Properties

 | Name | Description
Public Property | CallOutButtonApplyText | Specifies the text of Apply button in callout.
Public Property | CallOutButtonCancelText | Specifies the text of Cancel button in callout.
Public Property | CallOutButtonFindText | Specifies the text of Find button in callout..
Public Property | CallOutButtonInsertFromWebText | Specifies the text of Insert Media button in callout.
Public Property | CallOutButtonInsertLinkText | Specifies the text of Insert Link button in callout.
Public Property | CallOutButtonPasteText | Specifies the text of Paste button in callout.
Public Property | CallOutButtonReplaceAllText | Specifies the text of Replace All button in callout.
Public Property | CallOutButtonReplaceText | Specifies the text of Replace button in callout.
Public Property | CallOutCheckBoxMatchCaseText | Specifies the text of Match Case checkbox in callout.
Public Property | CallOutFindText | Specifies the text of Find field name in callout.
Public Property | CallOutHyperlinkLinkText | Specifies the text of Link field name in callout.
Public Property | CallOutHyperlinkTargetText | Specifies the text of Target field name in callout.
Public Property | CallOutHyperlinkText | Specifies the text of Text field name in callout.
Public Property | CallOutMediaAlignmentText | Specifies the text of Caption Alignment field name in callout.
Public Property | CallOutMediaCaptionText | Specifies the text of Media Caption field name in callout.
Public Property | CallOutMediaLinkURLText | Specifies the text of Link URL field name in callout.
Public Property | CallOutMediaSizeText | Specifies the text of Size field name in callout.
Public Property | CallOutMediaTitleText | Specifies the text of Media Title field name in callout.
Public Property | CallOutMediaTypeText | Specifies the text of Media Type field name in callout.
Public Property | CallOutMediaURLText | Specifies the text of Media URL field name in callout.
Public Property | CallOutMediaUseFrameText | Specifies the text of Use Frame checkbox in callout.
Public Property | CallOutPasteTitleText | Specifies the text of Paste Information title in callout.
Public Property | CallOutReplaceText | Specifies the text of Replace field name in callout.
Public Property | CharacterInformationText | Specifies the text of character information in tooltip.
Public Property | CopyText | Specifies the text of Copy menu item in context menu.
Public Property | CutText | Specifies the text of Cut menu item in context menu.
Public Property | DeleteColumnText | Specifies the text of Delete Column item in Table Designer pane and context menu.
Public Property | DeleteRowText | Specifies the text of Delete Row item in Table Designer pane and context menu.
Public Property | DesignViewText | Specifies the text of Design view tab in footer row.
Public Property | EditTableText | Specifies the text of Edit Table command in Table Designer toolbar.
Public Property | FailedSendMailText | Specifies the text that will be displayed in status bar when the mails failed to be sent.
Public Property | ForceExitSpellCheckingStatus | Specifies the text when force spell checker to exit.
Public Property | HtmlViewText | Specifies the text of HTML view tab in footer row.
Public Property | InsertButtonText | Specifies the text of Insert Button item in Form Control pane.
Public Property | InsertFieldsetText | Specifies the text of Insert Fieldset item in Form Control pane.
Public Property | InsertHorizontalRuleText | Specifies the text of Insert Horizontal Rule item in Form Control pane.
Public Property | InsertIFrameText | Specifies the text of Insert IFrame item in Form Control pane.
Public Property | InsertInputButtonText | Specifies the text of Insert Input Button item in Form Control pane.
Public Property | InsertInputCheckBoxText | Specifies the text of Insert Input CheckBox item in Form Control pane.
Public Property | InsertInputFileUploadText | Specifies the text of Insert Input File Upload item in Form Control pane.
Public Property | InsertInputHiddenText | Specifies the text of Insert Input Hidden item in Form Control pane.
Public Property | InsertInputPasswordText | Specifies the text of Insert Password item in Form Control pane.
Public Property | InsertInputRadioText | Specifies the text of Insert Radio item in Form Control pane.
Public Property | InsertInputResetText | Specifies the text of Insert Reset item in Form Control pane.
Public Property | InsertInputSubmitText | Specifies the text of Insert Submit item in Form Control pane.
Public Property | InsertInputText | Specifies the text of Insert Text item in Form Control pane.
Public Property | InsertLeftColumnsText | Specifies the text of Insert Columns to the Left item in Table Designer pane and context menu.
Public Property | InsertMarqueeText | Specifies the text of Insert Marquee item in Form Control pane.
Public Property | InsertMergeCellsText | Specifies the text of Merge Cells item in Table Designer pane and context menu.
Public Property | InsertRightColumnsText | Specifies the text of Insert Columns to the Right item in Table Designer pane and context menu.
Public Property | InsertRowsAboveText | Specifies the text of Insert Rows Above item in Table Designer pane and context menu.
Public Property | InsertRowsBelowText | Specifies the text of Insert Rows Below item in Table Designer pane and context menu.
Public Property | InsertSelectDropdownText | Specifies the text of Insert Select Dropdown item in Form Control pane.
Public Property | InsertSelectListboxText | Specifies the text of Insert Select Listbox item in Form Control pane.
Public Property | InsertSplitCellsText | Specifies the text of Split Cells item in Table Designer pane and context menu.
Public Property | InsertTableText | Specifies the text of Insert Table command in Table Designer toolbar.
Public Property | InsertTextAreaText | Specifies the text of Insert TextArea item in Form Control pane.
Public Property | MergeCellDown | Specifies the text of Merge Cell Down item in Table Designer pane and context menu.
Public Property | MergeCellRight | Specifies the text of Merge Cell Right item in Table Designer pane and context menu.
Public Property | NoResultFoundText | Specifies the text when no result is found when searching the media in Media Gallery pane.
Public Property | PasteText | Specifies the text of Paste menu item in context menu.
Public Property | PreviewMailMergeText | Specifies the text that will be displayed in status bar when the preview data is being fetched.
Public Property | PreviewText | Specifies the text of Preview view tab in footer row.
Public Property | ReadyText | Specifies the text displayed in status when the editor is in Ready state.
Public Property | ResultTypeText | Specifies the text of Result Type field name in Media Gallery pane.
Public Property | SaveStatus | Specifies the text when auto save has been performed.
Public Property | SearchingMediaText | Specifies the text displayed in status bar when media search action is being performed.
Public Property | SearchInText | Specifies the text of Search In field name in Media Gallery pane.
Public Property | SendMailMergeText | Specifies the text that will be displayed in status bar when the mails are being sent.
Public Property | SpellCheckingCompletedStatus | Specifies the text when spell checking has been completed.
Public Property | SplitCellHorizontal | Specifies the text of Split Cell Horizontal item in Table Designer pane and context menu.
Public Property | SplitCellVertical | Specifies the text of Split Cell Vertical item in Table Designer pane and context menu.
Public Property | SplitViewText | Specifies the text of Split view tab in footer row.
Public Property | SuccessSendMailText | Specifies the text that will be displayed in status bar when the emails have been successfully sent.
Public Property | TableAlignmentText | Specifies the text of Table Alignment field name in Table Designer pane.
Public Property | TableBackColorText | Specifies the text of Table Back Color field name in Table Designer pane.
Public Property | TableBorderColorText | Specifies the text of Table Border Color field name in Table Designer pane.
Public Property | TableBorderWidthText | Specifies the text of Table Border Width field name in Table Designer pane.
Public Property | TableCaptionText | Specifies the text of Table Caption field name in Table Designer pane.
Public Property | TableCellActionsText | Specifies the text of Cell Actions title in Table Designer pane.
Public Property | TableCellPaddingText | Specifies the text of Cell Padding field name in Table Designer pane.
Public Property | TableCellPropertiesText | Specifies the text of Cell Properties title in Table Designer pane.
Public Property | TableCellSpacingText | Specifies the text of Cell Spacing field name in Table Designer pane.
Public Property | TableColumnsText | Specifies the text of Columns field name in Table Designer pane.
Public Property | TableCustomText | Specifies the text of Custom radio button in Table Designer pane.
Public Property | TableDesignerText | Specifies the text of Table Designer title.
Public Property | TableFontColorText | Specifies the text of Table Font Color field name in Table Designer pane.
Public Property | TableHeightText | Specifies the text of Table Height field name in Table Designer pane.
Public Property | TableHorizontalAlignText | Specifies the text of Table Horizontal Align field name in Table Designer pane.
Public Property | TableNoWrapText | Specifies the text of No Wrap checkbox in Table Designer pane.
Public Property | TablePropertiesText | Specifies the text of Table Properties title in Table Designer pane.
Public Property | TableRowsText | Specifies the text of Rows field name in Table Designer pane.
Public Property | TableSummaryText | Specifies the text of Summary field name in Table Designer pane.
Public Property | TableTemplateText | Specifies the text of Template radio button in Table Designer pane.
Public Property | TableVerticalAlignText | Specifies the text of Vertical Align field name in Table Designer pane.
Public Property | TableWidthText | Specifies the text of Table Width field name in Table Designer pane.
Public Property | TaskPaneHTMLViewText | Specifies the text of pane content when viewing in HTML view.
Public Property | WordsInformationText | Specifies the text of word information in footer row.
Top

See Also

Reference

WebTextEditorTextSettings Class
ISNet.WebUI.WebTextEditor Namespace


CallOutButtonApplyText Property

[image]
Intersoft WebTextEditor Documentation
CallOutButtonApplyText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : CallOutButtonApplyText Property

Glossary Item Box

Specifies the text of Apply button in callout.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Text")>
<System.ComponentModel.DescriptionAttribute("Specifies the text of Apply button in callout.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property CallOutButtonApplyText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.CallOutButtonApplyText = value

value = instance.CallOutButtonApplyText
C#
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Apply button in callout.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string CallOutButtonApplyText {get; set;}
Delphi
public read-write property CallOutButtonApplyText: System.String;
JScript
System.ComponentModel.CategoryAttribute("Text")
System.ComponentModel.DescriptionAttribute("Specifies the text of Apply button in callout.")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set CallOutButtonApplyText : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Apply button in callout.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_CallOutButtonApplyText();
public: __property void set_CallOutButtonApplyText(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Apply button in callout.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ CallOutButtonApplyText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


CallOutButtonCancelText Property

[image]
Intersoft WebTextEditor Documentation
CallOutButtonCancelText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : CallOutButtonCancelText Property

Glossary Item Box

Specifies the text of Cancel button in callout.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Text")>
<System.ComponentModel.DescriptionAttribute("Specifies the text of Cancel button in callout.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property CallOutButtonCancelText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.CallOutButtonCancelText = value

value = instance.CallOutButtonCancelText
C#
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Cancel button in callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string CallOutButtonCancelText {get; set;}
Delphi
public read-write property CallOutButtonCancelText: System.String;
JScript
System.ComponentModel.CategoryAttribute("Text")
System.ComponentModel.DescriptionAttribute("Specifies the text of Cancel button in callout.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set CallOutButtonCancelText : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Cancel button in callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_CallOutButtonCancelText();
public: __property void set_CallOutButtonCancelText(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Cancel button in callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ CallOutButtonCancelText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


CallOutButtonFindText Property

[image]
Intersoft WebTextEditor Documentation
CallOutButtonFindText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : CallOutButtonFindText Property

Glossary Item Box

Specifies the text of Find button in callout..

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the text of Find button in callout.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Text")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property CallOutButtonFindText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.CallOutButtonFindText = value

value = instance.CallOutButtonFindText
C#
[System.ComponentModel.DescriptionAttribute("Specifies the text of Find button in callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string CallOutButtonFindText {get; set;}
Delphi
public read-write property CallOutButtonFindText: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the text of Find button in callout.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Text")
System.ComponentModel.DefaultValueAttribute()
public function get,set CallOutButtonFindText : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the text of Find button in callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_CallOutButtonFindText();
public: __property void set_CallOutButtonFindText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the text of Find button in callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ CallOutButtonFindText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


CallOutButtonInsertFromWebText Property

[image]
Intersoft WebTextEditor Documentation
CallOutButtonInsertFromWebText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : CallOutButtonInsertFromWebText Property

Glossary Item Box

Specifies the text of Insert Media button in callout.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Media button in callout.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Text")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property CallOutButtonInsertFromWebText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.CallOutButtonInsertFromWebText = value

value = instance.CallOutButtonInsertFromWebText
C#
[System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Media button in callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string CallOutButtonInsertFromWebText {get; set;}
Delphi
public read-write property CallOutButtonInsertFromWebText: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Media button in callout.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Text")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set CallOutButtonInsertFromWebText : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Media button in callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_CallOutButtonInsertFromWebText();
public: __property void set_CallOutButtonInsertFromWebText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Media button in callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ CallOutButtonInsertFromWebText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


CallOutButtonInsertLinkText Property

[image]
Intersoft WebTextEditor Documentation
CallOutButtonInsertLinkText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : CallOutButtonInsertLinkText Property

Glossary Item Box

Specifies the text of Insert Link button in callout.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Link button in callout.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Text")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property CallOutButtonInsertLinkText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.CallOutButtonInsertLinkText = value

value = instance.CallOutButtonInsertLinkText
C#
[System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Link button in callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string CallOutButtonInsertLinkText {get; set;}
Delphi
public read-write property CallOutButtonInsertLinkText: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Link button in callout.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Text")
System.ComponentModel.DefaultValueAttribute()
public function get,set CallOutButtonInsertLinkText : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Link button in callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_CallOutButtonInsertLinkText();
public: __property void set_CallOutButtonInsertLinkText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Link button in callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ CallOutButtonInsertLinkText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


CallOutButtonPasteText Property

[image]
Intersoft WebTextEditor Documentation
CallOutButtonPasteText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : CallOutButtonPasteText Property

Glossary Item Box

Specifies the text of Paste button in callout.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Text")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the text of Paste button in callout.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property CallOutButtonPasteText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.CallOutButtonPasteText = value

value = instance.CallOutButtonPasteText
C#
[System.ComponentModel.CategoryAttribute("Text")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Paste button in callout.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string CallOutButtonPasteText {get; set;}
Delphi
public read-write property CallOutButtonPasteText: System.String;
JScript
System.ComponentModel.CategoryAttribute("Text")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the text of Paste button in callout.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set CallOutButtonPasteText : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Text")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Paste button in callout.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_CallOutButtonPasteText();
public: __property void set_CallOutButtonPasteText(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Text")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Paste button in callout.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ CallOutButtonPasteText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


CallOutButtonReplaceAllText Property

[image]
Intersoft WebTextEditor Documentation
CallOutButtonReplaceAllText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : CallOutButtonReplaceAllText Property

Glossary Item Box

Specifies the text of Replace All button in callout.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the text of Replace All button in callout.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Text")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property CallOutButtonReplaceAllText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.CallOutButtonReplaceAllText = value

value = instance.CallOutButtonReplaceAllText
C#
[System.ComponentModel.DescriptionAttribute("Specifies the text of Replace All button in callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string CallOutButtonReplaceAllText {get; set;}
Delphi
public read-write property CallOutButtonReplaceAllText: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the text of Replace All button in callout.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Text")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set CallOutButtonReplaceAllText : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the text of Replace All button in callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_CallOutButtonReplaceAllText();
public: __property void set_CallOutButtonReplaceAllText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the text of Replace All button in callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ CallOutButtonReplaceAllText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


CallOutButtonReplaceText Property

[image]
Intersoft WebTextEditor Documentation
CallOutButtonReplaceText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : CallOutButtonReplaceText Property

Glossary Item Box

Specifies the text of Replace button in callout.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the text of Replace button in callout.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Text")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property CallOutButtonReplaceText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.CallOutButtonReplaceText = value

value = instance.CallOutButtonReplaceText
C#
[System.ComponentModel.DescriptionAttribute("Specifies the text of Replace button in callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.string CallOutButtonReplaceText {get; set;}
Delphi
public read-write property CallOutButtonReplaceText: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the text of Replace button in callout.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Text")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set CallOutButtonReplaceText : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the text of Replace button in callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_CallOutButtonReplaceText();
public: __property void set_CallOutButtonReplaceText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the text of Replace button in callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ CallOutButtonReplaceText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


CallOutCheckBoxMatchCaseText Property

[image]
Intersoft WebTextEditor Documentation
CallOutCheckBoxMatchCaseText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : CallOutCheckBoxMatchCaseText Property

Glossary Item Box

Specifies the text of Match Case checkbox in callout.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the text of Match Case checkbox in callout.")>
<System.ComponentModel.CategoryAttribute("Text")>
Public Property CallOutCheckBoxMatchCaseText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.CallOutCheckBoxMatchCaseText = value

value = instance.CallOutCheckBoxMatchCaseText
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Match Case checkbox in callout.")]
[System.ComponentModel.CategoryAttribute("Text")]
public System.string CallOutCheckBoxMatchCaseText {get; set;}
Delphi
public read-write property CallOutCheckBoxMatchCaseText: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the text of Match Case checkbox in callout.")
System.ComponentModel.CategoryAttribute("Text")
public function get,set CallOutCheckBoxMatchCaseText : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Match Case checkbox in callout.")]
[System.ComponentModel.CategoryAttribute("Text")]
public: __property System.string* get_CallOutCheckBoxMatchCaseText();
public: __property void set_CallOutCheckBoxMatchCaseText(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Match Case checkbox in callout.")]
[System.ComponentModel.CategoryAttribute("Text")]
public:
property System.String^ CallOutCheckBoxMatchCaseText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


CallOutFindText Property

[image]
Intersoft WebTextEditor Documentation
CallOutFindText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : CallOutFindText Property

Glossary Item Box

Specifies the text of Find field name in callout.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Text")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the text of Find field name in callout.")>
Public Property CallOutFindText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.CallOutFindText = value

value = instance.CallOutFindText
C#
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Find field name in callout.")]
public System.string CallOutFindText {get; set;}
Delphi
public read-write property CallOutFindText: System.String;
JScript
System.ComponentModel.CategoryAttribute("Text")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the text of Find field name in callout.")
public function get,set CallOutFindText : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Find field name in callout.")]
public: __property System.string* get_CallOutFindText();
public: __property void set_CallOutFindText(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Find field name in callout.")]
public:
property System.String^ CallOutFindText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


CallOutHyperlinkLinkText Property

[image]
Intersoft WebTextEditor Documentation
CallOutHyperlinkLinkText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : CallOutHyperlinkLinkText Property

Glossary Item Box

Specifies the text of Link field name in callout.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Text")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the text of Link field name in callout.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property CallOutHyperlinkLinkText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.CallOutHyperlinkLinkText = value

value = instance.CallOutHyperlinkLinkText
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Link field name in callout.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string CallOutHyperlinkLinkText {get; set;}
Delphi
public read-write property CallOutHyperlinkLinkText: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Text")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the text of Link field name in callout.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set CallOutHyperlinkLinkText : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Link field name in callout.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_CallOutHyperlinkLinkText();
public: __property void set_CallOutHyperlinkLinkText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Link field name in callout.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ CallOutHyperlinkLinkText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


CallOutHyperlinkTargetText Property

[image]
Intersoft WebTextEditor Documentation
CallOutHyperlinkTargetText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : CallOutHyperlinkTargetText Property

Glossary Item Box

Specifies the text of Target field name in callout.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the text of Target field name in callout.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Text")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property CallOutHyperlinkTargetText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.CallOutHyperlinkTargetText = value

value = instance.CallOutHyperlinkTargetText
C#
[System.ComponentModel.DescriptionAttribute("Specifies the text of Target field name in callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string CallOutHyperlinkTargetText {get; set;}
Delphi
public read-write property CallOutHyperlinkTargetText: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the text of Target field name in callout.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Text")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set CallOutHyperlinkTargetText : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the text of Target field name in callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_CallOutHyperlinkTargetText();
public: __property void set_CallOutHyperlinkTargetText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the text of Target field name in callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ CallOutHyperlinkTargetText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


CallOutHyperlinkText Property

[image]
Intersoft WebTextEditor Documentation
CallOutHyperlinkText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : CallOutHyperlinkText Property

Glossary Item Box

Specifies the text of Text field name in callout.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Text")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the text of Text field name in callout.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property CallOutHyperlinkText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.CallOutHyperlinkText = value

value = instance.CallOutHyperlinkText
C#
[System.ComponentModel.CategoryAttribute("Text")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Text field name in callout.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string CallOutHyperlinkText {get; set;}
Delphi
public read-write property CallOutHyperlinkText: System.String;
JScript
System.ComponentModel.CategoryAttribute("Text")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the text of Text field name in callout.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set CallOutHyperlinkText : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Text")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Text field name in callout.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_CallOutHyperlinkText();
public: __property void set_CallOutHyperlinkText(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Text")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Text field name in callout.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ CallOutHyperlinkText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


CallOutMediaAlignmentText Property

[image]
Intersoft WebTextEditor Documentation
CallOutMediaAlignmentText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : CallOutMediaAlignmentText Property

Glossary Item Box

Specifies the text of Caption Alignment field name in callout.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the text of Caption Alignment field name in callout.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Text")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property CallOutMediaAlignmentText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.CallOutMediaAlignmentText = value

value = instance.CallOutMediaAlignmentText
C#
[System.ComponentModel.DescriptionAttribute("Specifies the text of Caption Alignment field name in callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string CallOutMediaAlignmentText {get; set;}
Delphi
public read-write property CallOutMediaAlignmentText: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the text of Caption Alignment field name in callout.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Text")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set CallOutMediaAlignmentText : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the text of Caption Alignment field name in callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_CallOutMediaAlignmentText();
public: __property void set_CallOutMediaAlignmentText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the text of Caption Alignment field name in callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ CallOutMediaAlignmentText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


CallOutMediaCaptionText Property

[image]
Intersoft WebTextEditor Documentation
CallOutMediaCaptionText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : CallOutMediaCaptionText Property

Glossary Item Box

Specifies the text of Media Caption field name in callout.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the text of Media Caption field name in callout.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Text")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property CallOutMediaCaptionText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.CallOutMediaCaptionText = value

value = instance.CallOutMediaCaptionText
C#
[System.ComponentModel.DescriptionAttribute("Specifies the text of Media Caption field name in callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.string CallOutMediaCaptionText {get; set;}
Delphi
public read-write property CallOutMediaCaptionText: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the text of Media Caption field name in callout.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Text")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set CallOutMediaCaptionText : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the text of Media Caption field name in callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_CallOutMediaCaptionText();
public: __property void set_CallOutMediaCaptionText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the text of Media Caption field name in callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ CallOutMediaCaptionText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


CallOutMediaLinkURLText Property

[image]
Intersoft WebTextEditor Documentation
CallOutMediaLinkURLText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : CallOutMediaLinkURLText Property

Glossary Item Box

Specifies the text of Link URL field name in callout.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the text of Link URL field name in callout.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Text")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property CallOutMediaLinkURLText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.CallOutMediaLinkURLText = value

value = instance.CallOutMediaLinkURLText
C#
[System.ComponentModel.DescriptionAttribute("Specifies the text of Link URL field name in callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string CallOutMediaLinkURLText {get; set;}
Delphi
public read-write property CallOutMediaLinkURLText: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the text of Link URL field name in callout.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Text")
System.ComponentModel.DefaultValueAttribute()
public function get,set CallOutMediaLinkURLText : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the text of Link URL field name in callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_CallOutMediaLinkURLText();
public: __property void set_CallOutMediaLinkURLText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the text of Link URL field name in callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ CallOutMediaLinkURLText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


CallOutMediaSizeText Property

[image]
Intersoft WebTextEditor Documentation
CallOutMediaSizeText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : CallOutMediaSizeText Property

Glossary Item Box

Specifies the text of Size field name in callout.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the text of Size field name in callout.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Text")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property CallOutMediaSizeText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.CallOutMediaSizeText = value

value = instance.CallOutMediaSizeText
C#
[System.ComponentModel.DescriptionAttribute("Specifies the text of Size field name in callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.string CallOutMediaSizeText {get; set;}
Delphi
public read-write property CallOutMediaSizeText: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the text of Size field name in callout.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Text")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set CallOutMediaSizeText : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the text of Size field name in callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_CallOutMediaSizeText();
public: __property void set_CallOutMediaSizeText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the text of Size field name in callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ CallOutMediaSizeText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


CallOutMediaTitleText Property

[image]
Intersoft WebTextEditor Documentation
CallOutMediaTitleText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : CallOutMediaTitleText Property

Glossary Item Box

Specifies the text of Media Title field name in callout.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the text of Media Title field name in callout.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Text")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property CallOutMediaTitleText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.CallOutMediaTitleText = value

value = instance.CallOutMediaTitleText
C#
[System.ComponentModel.DescriptionAttribute("Specifies the text of Media Title field name in callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string CallOutMediaTitleText {get; set;}
Delphi
public read-write property CallOutMediaTitleText: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the text of Media Title field name in callout.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Text")
System.ComponentModel.DefaultValueAttribute()
public function get,set CallOutMediaTitleText : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the text of Media Title field name in callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_CallOutMediaTitleText();
public: __property void set_CallOutMediaTitleText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the text of Media Title field name in callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ CallOutMediaTitleText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


CallOutMediaTypeText Property

[image]
Intersoft WebTextEditor Documentation
CallOutMediaTypeText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : CallOutMediaTypeText Property

Glossary Item Box

Specifies the text of Media Type field name in callout.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the text of Media Type field name in callout.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Text")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property CallOutMediaTypeText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.CallOutMediaTypeText = value

value = instance.CallOutMediaTypeText
C#
[System.ComponentModel.DescriptionAttribute("Specifies the text of Media Type field name in callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string CallOutMediaTypeText {get; set;}
Delphi
public read-write property CallOutMediaTypeText: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the text of Media Type field name in callout.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Text")
System.ComponentModel.DefaultValueAttribute()
public function get,set CallOutMediaTypeText : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the text of Media Type field name in callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_CallOutMediaTypeText();
public: __property void set_CallOutMediaTypeText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the text of Media Type field name in callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ CallOutMediaTypeText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


CallOutMediaURLText Property

[image]
Intersoft WebTextEditor Documentation
CallOutMediaURLText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : CallOutMediaURLText Property

Glossary Item Box

Specifies the text of Media URL field name in callout.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the text of Media URL field name in callout.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Text")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property CallOutMediaURLText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.CallOutMediaURLText = value

value = instance.CallOutMediaURLText
C#
[System.ComponentModel.DescriptionAttribute("Specifies the text of Media URL field name in callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string CallOutMediaURLText {get; set;}
Delphi
public read-write property CallOutMediaURLText: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the text of Media URL field name in callout.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Text")
System.ComponentModel.DefaultValueAttribute()
public function get,set CallOutMediaURLText : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the text of Media URL field name in callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_CallOutMediaURLText();
public: __property void set_CallOutMediaURLText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the text of Media URL field name in callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ CallOutMediaURLText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


CallOutMediaUseFrameText Property

[image]
Intersoft WebTextEditor Documentation
CallOutMediaUseFrameText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : CallOutMediaUseFrameText Property

Glossary Item Box

Specifies the text of Use Frame checkbox in callout.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the text of Use Frame checkbox in callout.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Text")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property CallOutMediaUseFrameText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.CallOutMediaUseFrameText = value

value = instance.CallOutMediaUseFrameText
C#
[System.ComponentModel.DescriptionAttribute("Specifies the text of Use Frame checkbox in callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string CallOutMediaUseFrameText {get; set;}
Delphi
public read-write property CallOutMediaUseFrameText: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the text of Use Frame checkbox in callout.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Text")
System.ComponentModel.DefaultValueAttribute()
public function get,set CallOutMediaUseFrameText : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the text of Use Frame checkbox in callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_CallOutMediaUseFrameText();
public: __property void set_CallOutMediaUseFrameText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the text of Use Frame checkbox in callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ CallOutMediaUseFrameText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


CallOutPasteTitleText Property

[image]
Intersoft WebTextEditor Documentation
CallOutPasteTitleText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : CallOutPasteTitleText Property

Glossary Item Box

Specifies the text of Paste Information title in callout.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the text of Paste Information title in callout.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Text")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property CallOutPasteTitleText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.CallOutPasteTitleText = value

value = instance.CallOutPasteTitleText
C#
[System.ComponentModel.DescriptionAttribute("Specifies the text of Paste Information title in callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string CallOutPasteTitleText {get; set;}
Delphi
public read-write property CallOutPasteTitleText: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the text of Paste Information title in callout.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Text")
System.ComponentModel.DefaultValueAttribute()
public function get,set CallOutPasteTitleText : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the text of Paste Information title in callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_CallOutPasteTitleText();
public: __property void set_CallOutPasteTitleText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the text of Paste Information title in callout.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ CallOutPasteTitleText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


CallOutReplaceText Property

[image]
Intersoft WebTextEditor Documentation
CallOutReplaceText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : CallOutReplaceText Property

Glossary Item Box

Specifies the text of Replace field name in callout.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the text of Replace field name in callout.")>
<System.ComponentModel.CategoryAttribute("Text")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property CallOutReplaceText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.CallOutReplaceText = value

value = instance.CallOutReplaceText
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Replace field name in callout.")]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string CallOutReplaceText {get; set;}
Delphi
public read-write property CallOutReplaceText: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the text of Replace field name in callout.")
System.ComponentModel.CategoryAttribute("Text")
System.ComponentModel.DefaultValueAttribute()
public function get,set CallOutReplaceText : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Replace field name in callout.")]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_CallOutReplaceText();
public: __property void set_CallOutReplaceText(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Replace field name in callout.")]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ CallOutReplaceText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


CharacterInformationText Property

[image]
Intersoft WebTextEditor Documentation
CharacterInformationText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : CharacterInformationText Property

Glossary Item Box

Specifies the text of character information in tooltip.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Text")>
<System.ComponentModel.DescriptionAttribute("Specifies the text of character information in tooltip.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property CharacterInformationText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.CharacterInformationText = value

value = instance.CharacterInformationText
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DescriptionAttribute("Specifies the text of character information in tooltip.")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string CharacterInformationText {get; set;}
Delphi
public read-write property CharacterInformationText: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Text")
System.ComponentModel.DescriptionAttribute("Specifies the text of character information in tooltip.")
System.ComponentModel.DefaultValueAttribute()
public function get,set CharacterInformationText : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DescriptionAttribute("Specifies the text of character information in tooltip.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_CharacterInformationText();
public: __property void set_CharacterInformationText(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DescriptionAttribute("Specifies the text of character information in tooltip.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ CharacterInformationText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


CopyText Property

[image]
Intersoft WebTextEditor Documentation
CopyText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : CopyText Property

Glossary Item Box

Specifies the text of Copy menu item in context menu.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the text of Copy menu item in context menu.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Text")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property CopyText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.CopyText = value

value = instance.CopyText
C#
[System.ComponentModel.DescriptionAttribute("Specifies the text of Copy menu item in context menu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.string CopyText {get; set;}
Delphi
public read-write property CopyText: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the text of Copy menu item in context menu.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Text")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set CopyText : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the text of Copy menu item in context menu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_CopyText();
public: __property void set_CopyText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the text of Copy menu item in context menu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ CopyText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


CutText Property

[image]
Intersoft WebTextEditor Documentation
CutText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : CutText Property

Glossary Item Box

Specifies the text of Cut menu item in context menu.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the text of Cut menu item in context menu.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Text")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property CutText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.CutText = value

value = instance.CutText
C#
[System.ComponentModel.DescriptionAttribute("Specifies the text of Cut menu item in context menu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string CutText {get; set;}
Delphi
public read-write property CutText: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the text of Cut menu item in context menu.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Text")
System.ComponentModel.DefaultValueAttribute()
public function get,set CutText : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the text of Cut menu item in context menu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_CutText();
public: __property void set_CutText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the text of Cut menu item in context menu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ CutText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


DeleteColumnText Property

[image]
Intersoft WebTextEditor Documentation
DeleteColumnText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : DeleteColumnText Property

Glossary Item Box

Specifies the text of Delete Column item in Table Designer pane and context menu.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the text of Delete Column item in Table Designer pane and context menu.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Text")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property DeleteColumnText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.DeleteColumnText = value

value = instance.DeleteColumnText
C#
[System.ComponentModel.DescriptionAttribute("Specifies the text of Delete Column item in Table Designer pane and context menu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string DeleteColumnText {get; set;}
Delphi
public read-write property DeleteColumnText: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the text of Delete Column item in Table Designer pane and context menu.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Text")
System.ComponentModel.DefaultValueAttribute()
public function get,set DeleteColumnText : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the text of Delete Column item in Table Designer pane and context menu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_DeleteColumnText();
public: __property void set_DeleteColumnText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the text of Delete Column item in Table Designer pane and context menu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ DeleteColumnText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


DeleteRowText Property

[image]
Intersoft WebTextEditor Documentation
DeleteRowText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : DeleteRowText Property

Glossary Item Box

Specifies the text of Delete Row item in Table Designer pane and context menu.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the text of Delete Row item in Table Designer pane and context menu.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Text")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property DeleteRowText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.DeleteRowText = value

value = instance.DeleteRowText
C#
[System.ComponentModel.DescriptionAttribute("Specifies the text of Delete Row item in Table Designer pane and context menu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.string DeleteRowText {get; set;}
Delphi
public read-write property DeleteRowText: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the text of Delete Row item in Table Designer pane and context menu.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Text")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set DeleteRowText : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the text of Delete Row item in Table Designer pane and context menu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_DeleteRowText();
public: __property void set_DeleteRowText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the text of Delete Row item in Table Designer pane and context menu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ DeleteRowText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


DesignViewText Property

[image]
Intersoft WebTextEditor Documentation
DesignViewText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : DesignViewText Property

Glossary Item Box

Specifies the text of Design view tab in footer row.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the text of Design view tab in footer row.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Text")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property DesignViewText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.DesignViewText = value

value = instance.DesignViewText
C#
[System.ComponentModel.DescriptionAttribute("Specifies the text of Design view tab in footer row.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string DesignViewText {get; set;}
Delphi
public read-write property DesignViewText: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the text of Design view tab in footer row.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Text")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set DesignViewText : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the text of Design view tab in footer row.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_DesignViewText();
public: __property void set_DesignViewText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the text of Design view tab in footer row.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ DesignViewText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


EditTableText Property

[image]
Intersoft WebTextEditor Documentation
EditTableText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : EditTableText Property

Glossary Item Box

Specifies the text of Edit Table command in Table Designer toolbar.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the text of Edit Table command in Table Designer toolbar.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Text")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property EditTableText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.EditTableText = value

value = instance.EditTableText
C#
[System.ComponentModel.DescriptionAttribute("Specifies the text of Edit Table command in Table Designer toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string EditTableText {get; set;}
Delphi
public read-write property EditTableText: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the text of Edit Table command in Table Designer toolbar.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Text")
System.ComponentModel.DefaultValueAttribute()
public function get,set EditTableText : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the text of Edit Table command in Table Designer toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_EditTableText();
public: __property void set_EditTableText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the text of Edit Table command in Table Designer toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ EditTableText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


FailedSendMailText Property

[image]
Intersoft WebTextEditor Documentation
FailedSendMailText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : FailedSendMailText Property

Glossary Item Box

Specifies the text that will be displayed in status bar when the mails failed to be sent.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Text")>
<System.ComponentModel.DescriptionAttribute("Specifies the text that will be displayed in status bar when the mails failed to be sent.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property FailedSendMailText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.FailedSendMailText = value

value = instance.FailedSendMailText
C#
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DescriptionAttribute("Specifies the text that will be displayed in status bar when the mails failed to be sent.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string FailedSendMailText {get; set;}
Delphi
public read-write property FailedSendMailText: System.String;
JScript
System.ComponentModel.CategoryAttribute("Text")
System.ComponentModel.DescriptionAttribute("Specifies the text that will be displayed in status bar when the mails failed to be sent.")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set FailedSendMailText : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DescriptionAttribute("Specifies the text that will be displayed in status bar when the mails failed to be sent.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_FailedSendMailText();
public: __property void set_FailedSendMailText(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DescriptionAttribute("Specifies the text that will be displayed in status bar when the mails failed to be sent.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ FailedSendMailText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


ForceExitSpellCheckingStatus Property

[image]
Intersoft WebTextEditor Documentation
ForceExitSpellCheckingStatus Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : ForceExitSpellCheckingStatus Property

Glossary Item Box

Specifies the text when force spell checker to exit.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the text when force spell checker to exit.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Text")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property ForceExitSpellCheckingStatus As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.ForceExitSpellCheckingStatus = value

value = instance.ForceExitSpellCheckingStatus
C#
[System.ComponentModel.DescriptionAttribute("Specifies the text when force spell checker to exit.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string ForceExitSpellCheckingStatus {get; set;}
Delphi
public read-write property ForceExitSpellCheckingStatus: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the text when force spell checker to exit.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Text")
System.ComponentModel.DefaultValueAttribute()
public function get,set ForceExitSpellCheckingStatus : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the text when force spell checker to exit.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_ForceExitSpellCheckingStatus();
public: __property void set_ForceExitSpellCheckingStatus(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the text when force spell checker to exit.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ ForceExitSpellCheckingStatus {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


HtmlViewText Property

[image]
Intersoft WebTextEditor Documentation
HtmlViewText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : HtmlViewText Property

Glossary Item Box

Specifies the text of HTML view tab in footer row.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the text of HTML view tab in footer row.")>
<System.ComponentModel.CategoryAttribute("Text")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property HtmlViewText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.HtmlViewText = value

value = instance.HtmlViewText
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of HTML view tab in footer row.")]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.string HtmlViewText {get; set;}
Delphi
public read-write property HtmlViewText: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the text of HTML view tab in footer row.")
System.ComponentModel.CategoryAttribute("Text")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set HtmlViewText : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of HTML view tab in footer row.")]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_HtmlViewText();
public: __property void set_HtmlViewText(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of HTML view tab in footer row.")]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ HtmlViewText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


InsertButtonText Property

[image]
Intersoft WebTextEditor Documentation
InsertButtonText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : InsertButtonText Property

Glossary Item Box

Specifies the text of Insert Button item in Form Control pane.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Button item in Form Control pane.")>
<System.ComponentModel.CategoryAttribute("Text")>
Public Property InsertButtonText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.InsertButtonText = value

value = instance.InsertButtonText
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Button item in Form Control pane.")]
[System.ComponentModel.CategoryAttribute("Text")]
public System.string InsertButtonText {get; set;}
Delphi
public read-write property InsertButtonText: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Button item in Form Control pane.")
System.ComponentModel.CategoryAttribute("Text")
public function get,set InsertButtonText : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Button item in Form Control pane.")]
[System.ComponentModel.CategoryAttribute("Text")]
public: __property System.string* get_InsertButtonText();
public: __property void set_InsertButtonText(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Button item in Form Control pane.")]
[System.ComponentModel.CategoryAttribute("Text")]
public:
property System.String^ InsertButtonText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


InsertFieldsetText Property

[image]
Intersoft WebTextEditor Documentation
InsertFieldsetText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : InsertFieldsetText Property

Glossary Item Box

Specifies the text of Insert Fieldset item in Form Control pane.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Fieldset item in Form Control pane.")>
<System.ComponentModel.CategoryAttribute("Text")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property InsertFieldsetText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.InsertFieldsetText = value

value = instance.InsertFieldsetText
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Fieldset item in Form Control pane.")]
[System.ComponentModel.CategoryAttribute("Text")]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string InsertFieldsetText {get; set;}
Delphi
public read-write property InsertFieldsetText: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Fieldset item in Form Control pane.")
System.ComponentModel.CategoryAttribute("Text")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set InsertFieldsetText : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Fieldset item in Form Control pane.")]
[System.ComponentModel.CategoryAttribute("Text")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_InsertFieldsetText();
public: __property void set_InsertFieldsetText(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Fieldset item in Form Control pane.")]
[System.ComponentModel.CategoryAttribute("Text")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ InsertFieldsetText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


InsertHorizontalRuleText Property

[image]
Intersoft WebTextEditor Documentation
InsertHorizontalRuleText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : InsertHorizontalRuleText Property

Glossary Item Box

Specifies the text of Insert Horizontal Rule item in Form Control pane.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Text")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Horizontal Rule item in Form Control pane.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property InsertHorizontalRuleText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.InsertHorizontalRuleText = value

value = instance.InsertHorizontalRuleText
C#
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Horizontal Rule item in Form Control pane.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.string InsertHorizontalRuleText {get; set;}
Delphi
public read-write property InsertHorizontalRuleText: System.String;
JScript
System.ComponentModel.CategoryAttribute("Text")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Horizontal Rule item in Form Control pane.")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set InsertHorizontalRuleText : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Horizontal Rule item in Form Control pane.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_InsertHorizontalRuleText();
public: __property void set_InsertHorizontalRuleText(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Horizontal Rule item in Form Control pane.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ InsertHorizontalRuleText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


InsertIFrameText Property

[image]
Intersoft WebTextEditor Documentation
InsertIFrameText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : InsertIFrameText Property

Glossary Item Box

Specifies the text of Insert IFrame item in Form Control pane.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the text of Insert IFrame item in Form Control pane.")>
<System.ComponentModel.CategoryAttribute("Text")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property InsertIFrameText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.InsertIFrameText = value

value = instance.InsertIFrameText
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Insert IFrame item in Form Control pane.")]
[System.ComponentModel.CategoryAttribute("Text")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string InsertIFrameText {get; set;}
Delphi
public read-write property InsertIFrameText: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the text of Insert IFrame item in Form Control pane.")
System.ComponentModel.CategoryAttribute("Text")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set InsertIFrameText : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Insert IFrame item in Form Control pane.")]
[System.ComponentModel.CategoryAttribute("Text")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_InsertIFrameText();
public: __property void set_InsertIFrameText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Insert IFrame item in Form Control pane.")]
[System.ComponentModel.CategoryAttribute("Text")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ InsertIFrameText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


InsertInputButtonText Property

[image]
Intersoft WebTextEditor Documentation
InsertInputButtonText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : InsertInputButtonText Property

Glossary Item Box

Specifies the text of Insert Input Button item in Form Control pane.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Input Button item in Form Control pane.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Text")>
Public Property InsertInputButtonText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.InsertInputButtonText = value

value = instance.InsertInputButtonText
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Input Button item in Form Control pane.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
public System.string InsertInputButtonText {get; set;}
Delphi
public read-write property InsertInputButtonText: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Input Button item in Form Control pane.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Text")
public function get,set InsertInputButtonText : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Input Button item in Form Control pane.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
public: __property System.string* get_InsertInputButtonText();
public: __property void set_InsertInputButtonText(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Input Button item in Form Control pane.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
public:
property System.String^ InsertInputButtonText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


InsertInputCheckBoxText Property

[image]
Intersoft WebTextEditor Documentation
InsertInputCheckBoxText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : InsertInputCheckBoxText Property

Glossary Item Box

Specifies the text of Insert Input CheckBox item in Form Control pane.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Input CheckBox item in Form Control pane.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Text")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property InsertInputCheckBoxText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.InsertInputCheckBoxText = value

value = instance.InsertInputCheckBoxText
C#
[System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Input CheckBox item in Form Control pane.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.string InsertInputCheckBoxText {get; set;}
Delphi
public read-write property InsertInputCheckBoxText: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Input CheckBox item in Form Control pane.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Text")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set InsertInputCheckBoxText : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Input CheckBox item in Form Control pane.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_InsertInputCheckBoxText();
public: __property void set_InsertInputCheckBoxText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Input CheckBox item in Form Control pane.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ InsertInputCheckBoxText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


InsertInputFileUploadText Property

[image]
Intersoft WebTextEditor Documentation
InsertInputFileUploadText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : InsertInputFileUploadText Property

Glossary Item Box

Specifies the text of Insert Input File Upload item in Form Control pane.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Input File Upload item in Form Control pane.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Text")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property InsertInputFileUploadText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.InsertInputFileUploadText = value

value = instance.InsertInputFileUploadText
C#
[System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Input File Upload item in Form Control pane.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string InsertInputFileUploadText {get; set;}
Delphi
public read-write property InsertInputFileUploadText: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Input File Upload item in Form Control pane.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Text")
System.ComponentModel.DefaultValueAttribute()
public function get,set InsertInputFileUploadText : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Input File Upload item in Form Control pane.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_InsertInputFileUploadText();
public: __property void set_InsertInputFileUploadText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Input File Upload item in Form Control pane.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ InsertInputFileUploadText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


InsertInputHiddenText Property

[image]
Intersoft WebTextEditor Documentation
InsertInputHiddenText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : InsertInputHiddenText Property

Glossary Item Box

Specifies the text of Insert Input Hidden item in Form Control pane.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Text")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Input Hidden item in Form Control pane.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property InsertInputHiddenText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.InsertInputHiddenText = value

value = instance.InsertInputHiddenText
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Input Hidden item in Form Control pane.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string InsertInputHiddenText {get; set;}
Delphi
public read-write property InsertInputHiddenText: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Text")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Input Hidden item in Form Control pane.")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set InsertInputHiddenText : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Input Hidden item in Form Control pane.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_InsertInputHiddenText();
public: __property void set_InsertInputHiddenText(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Input Hidden item in Form Control pane.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ InsertInputHiddenText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


InsertInputPasswordText Property

[image]
Intersoft WebTextEditor Documentation
InsertInputPasswordText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : InsertInputPasswordText Property

Glossary Item Box

Specifies the text of Insert Password item in Form Control pane.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Text")>
<System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Password item in Form Control pane.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property InsertInputPasswordText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.InsertInputPasswordText = value

value = instance.InsertInputPasswordText
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Password item in Form Control pane.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string InsertInputPasswordText {get; set;}
Delphi
public read-write property InsertInputPasswordText: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Text")
System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Password item in Form Control pane.")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set InsertInputPasswordText : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Password item in Form Control pane.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_InsertInputPasswordText();
public: __property void set_InsertInputPasswordText(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Password item in Form Control pane.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ InsertInputPasswordText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


InsertInputRadioText Property

[image]
Intersoft WebTextEditor Documentation
InsertInputRadioText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : InsertInputRadioText Property

Glossary Item Box

Specifies the text of Insert Radio item in Form Control pane.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Radio item in Form Control pane.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Text")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property InsertInputRadioText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.InsertInputRadioText = value

value = instance.InsertInputRadioText
C#
[System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Radio item in Form Control pane.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string InsertInputRadioText {get; set;}
Delphi
public read-write property InsertInputRadioText: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Radio item in Form Control pane.")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Text")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set InsertInputRadioText : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Radio item in Form Control pane.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_InsertInputRadioText();
public: __property void set_InsertInputRadioText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Radio item in Form Control pane.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ InsertInputRadioText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


InsertInputResetText Property

[image]
Intersoft WebTextEditor Documentation
InsertInputResetText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : InsertInputResetText Property

Glossary Item Box

Specifies the text of Insert Reset item in Form Control pane.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Reset item in Form Control pane.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Text")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property InsertInputResetText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.InsertInputResetText = value

value = instance.InsertInputResetText
C#
[System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Reset item in Form Control pane.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.string InsertInputResetText {get; set;}
Delphi
public read-write property InsertInputResetText: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Reset item in Form Control pane.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Text")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set InsertInputResetText : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Reset item in Form Control pane.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_InsertInputResetText();
public: __property void set_InsertInputResetText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Reset item in Form Control pane.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ InsertInputResetText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


InsertInputSubmitText Property

[image]
Intersoft WebTextEditor Documentation
InsertInputSubmitText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : InsertInputSubmitText Property

Glossary Item Box

Specifies the text of Insert Submit item in Form Control pane.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Submit item in Form Control pane.")>
<System.ComponentModel.CategoryAttribute("Text")>
Public Property InsertInputSubmitText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.InsertInputSubmitText = value

value = instance.InsertInputSubmitText
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Submit item in Form Control pane.")]
[System.ComponentModel.CategoryAttribute("Text")]
public System.string InsertInputSubmitText {get; set;}
Delphi
public read-write property InsertInputSubmitText: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Submit item in Form Control pane.")
System.ComponentModel.CategoryAttribute("Text")
public function get,set InsertInputSubmitText : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Submit item in Form Control pane.")]
[System.ComponentModel.CategoryAttribute("Text")]
public: __property System.string* get_InsertInputSubmitText();
public: __property void set_InsertInputSubmitText(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Submit item in Form Control pane.")]
[System.ComponentModel.CategoryAttribute("Text")]
public:
property System.String^ InsertInputSubmitText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


InsertInputText Property

[image]
Intersoft WebTextEditor Documentation
InsertInputText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : InsertInputText Property

Glossary Item Box

Specifies the text of Insert Text item in Form Control pane.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Text")>
<System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Text item in Form Control pane.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property InsertInputText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.InsertInputText = value

value = instance.InsertInputText
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Text item in Form Control pane.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string InsertInputText {get; set;}
Delphi
public read-write property InsertInputText: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Text")
System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Text item in Form Control pane.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set InsertInputText : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Text item in Form Control pane.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_InsertInputText();
public: __property void set_InsertInputText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Text item in Form Control pane.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ InsertInputText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


InsertLeftColumnsText Property

[image]
Intersoft WebTextEditor Documentation
InsertLeftColumnsText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : InsertLeftColumnsText Property

Glossary Item Box

Specifies the text of Insert Columns to the Left item in Table Designer pane and context menu.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Columns to the Left item in Table Designer pane and context menu.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Text")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property InsertLeftColumnsText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.InsertLeftColumnsText = value

value = instance.InsertLeftColumnsText
C#
[System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Columns to the Left item in Table Designer pane and context menu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string InsertLeftColumnsText {get; set;}
Delphi
public read-write property InsertLeftColumnsText: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Columns to the Left item in Table Designer pane and context menu.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Text")
System.ComponentModel.DefaultValueAttribute()
public function get,set InsertLeftColumnsText : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Columns to the Left item in Table Designer pane and context menu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_InsertLeftColumnsText();
public: __property void set_InsertLeftColumnsText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Columns to the Left item in Table Designer pane and context menu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ InsertLeftColumnsText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


InsertMarqueeText Property

[image]
Intersoft WebTextEditor Documentation
InsertMarqueeText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : InsertMarqueeText Property

Glossary Item Box

Specifies the text of Insert Marquee item in Form Control pane.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Marquee item in Form Control pane.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Text")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property InsertMarqueeText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.InsertMarqueeText = value

value = instance.InsertMarqueeText
C#
[System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Marquee item in Form Control pane.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string InsertMarqueeText {get; set;}
Delphi
public read-write property InsertMarqueeText: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Marquee item in Form Control pane.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Text")
System.ComponentModel.DefaultValueAttribute()
public function get,set InsertMarqueeText : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Marquee item in Form Control pane.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_InsertMarqueeText();
public: __property void set_InsertMarqueeText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Marquee item in Form Control pane.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ InsertMarqueeText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


InsertMergeCellsText Property

[image]
Intersoft WebTextEditor Documentation
InsertMergeCellsText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : InsertMergeCellsText Property

Glossary Item Box

Specifies the text of Merge Cells item in Table Designer pane and context menu.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Text")>
<System.ComponentModel.DescriptionAttribute("Specifies the text of Merge Cells item in Table Designer pane and context menu.")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property InsertMergeCellsText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.InsertMergeCellsText = value

value = instance.InsertMergeCellsText
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Merge Cells item in Table Designer pane and context menu.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string InsertMergeCellsText {get; set;}
Delphi
public read-write property InsertMergeCellsText: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Text")
System.ComponentModel.DescriptionAttribute("Specifies the text of Merge Cells item in Table Designer pane and context menu.")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set InsertMergeCellsText : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Merge Cells item in Table Designer pane and context menu.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_InsertMergeCellsText();
public: __property void set_InsertMergeCellsText(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Merge Cells item in Table Designer pane and context menu.")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ InsertMergeCellsText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


InsertRightColumnsText Property

[image]
Intersoft WebTextEditor Documentation
InsertRightColumnsText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : InsertRightColumnsText Property

Glossary Item Box

Specifies the text of Insert Columns to the Right item in Table Designer pane and context menu.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Text")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Columns to the Right item in Table Designer pane and context menu.")>
Public Property InsertRightColumnsText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.InsertRightColumnsText = value

value = instance.InsertRightColumnsText
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Columns to the Right item in Table Designer pane and context menu.")]
public System.string InsertRightColumnsText {get; set;}
Delphi
public read-write property InsertRightColumnsText: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Text")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Columns to the Right item in Table Designer pane and context menu.")
public function get,set InsertRightColumnsText : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Columns to the Right item in Table Designer pane and context menu.")]
public: __property System.string* get_InsertRightColumnsText();
public: __property void set_InsertRightColumnsText(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Columns to the Right item in Table Designer pane and context menu.")]
public:
property System.String^ InsertRightColumnsText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


InsertRowsAboveText Property

[image]
Intersoft WebTextEditor Documentation
InsertRowsAboveText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : InsertRowsAboveText Property

Glossary Item Box

Specifies the text of Insert Rows Above item in Table Designer pane and context menu.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Rows Above item in Table Designer pane and context menu.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Text")>
Public Property InsertRowsAboveText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.InsertRowsAboveText = value

value = instance.InsertRowsAboveText
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Rows Above item in Table Designer pane and context menu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
public System.string InsertRowsAboveText {get; set;}
Delphi
public read-write property InsertRowsAboveText: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Rows Above item in Table Designer pane and context menu.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Text")
public function get,set InsertRowsAboveText : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Rows Above item in Table Designer pane and context menu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
public: __property System.string* get_InsertRowsAboveText();
public: __property void set_InsertRowsAboveText(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Rows Above item in Table Designer pane and context menu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
public:
property System.String^ InsertRowsAboveText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


InsertRowsBelowText Property

[image]
Intersoft WebTextEditor Documentation
InsertRowsBelowText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : InsertRowsBelowText Property

Glossary Item Box

Specifies the text of Insert Rows Below item in Table Designer pane and context menu.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Rows Below item in Table Designer pane and context menu.")>
<System.ComponentModel.CategoryAttribute("Text")>
Public Property InsertRowsBelowText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.InsertRowsBelowText = value

value = instance.InsertRowsBelowText
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Rows Below item in Table Designer pane and context menu.")]
[System.ComponentModel.CategoryAttribute("Text")]
public System.string InsertRowsBelowText {get; set;}
Delphi
public read-write property InsertRowsBelowText: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Rows Below item in Table Designer pane and context menu.")
System.ComponentModel.CategoryAttribute("Text")
public function get,set InsertRowsBelowText : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Rows Below item in Table Designer pane and context menu.")]
[System.ComponentModel.CategoryAttribute("Text")]
public: __property System.string* get_InsertRowsBelowText();
public: __property void set_InsertRowsBelowText(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Rows Below item in Table Designer pane and context menu.")]
[System.ComponentModel.CategoryAttribute("Text")]
public:
property System.String^ InsertRowsBelowText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


InsertSelectDropdownText Property

[image]
Intersoft WebTextEditor Documentation
InsertSelectDropdownText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : InsertSelectDropdownText Property

Glossary Item Box

Specifies the text of Insert Select Dropdown item in Form Control pane.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Select Dropdown item in Form Control pane.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Text")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property InsertSelectDropdownText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.InsertSelectDropdownText = value

value = instance.InsertSelectDropdownText
C#
[System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Select Dropdown item in Form Control pane.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.string InsertSelectDropdownText {get; set;}
Delphi
public read-write property InsertSelectDropdownText: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Select Dropdown item in Form Control pane.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Text")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set InsertSelectDropdownText : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Select Dropdown item in Form Control pane.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_InsertSelectDropdownText();
public: __property void set_InsertSelectDropdownText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Select Dropdown item in Form Control pane.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ InsertSelectDropdownText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


InsertSelectListboxText Property

[image]
Intersoft WebTextEditor Documentation
InsertSelectListboxText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : InsertSelectListboxText Property

Glossary Item Box

Specifies the text of Insert Select Listbox item in Form Control pane.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Select Listbox item in Form Control pane.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Text")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property InsertSelectListboxText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.InsertSelectListboxText = value

value = instance.InsertSelectListboxText
C#
[System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Select Listbox item in Form Control pane.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string InsertSelectListboxText {get; set;}
Delphi
public read-write property InsertSelectListboxText: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Select Listbox item in Form Control pane.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Text")
System.ComponentModel.DefaultValueAttribute()
public function get,set InsertSelectListboxText : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Select Listbox item in Form Control pane.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_InsertSelectListboxText();
public: __property void set_InsertSelectListboxText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Select Listbox item in Form Control pane.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ InsertSelectListboxText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


InsertSplitCellsText Property

[image]
Intersoft WebTextEditor Documentation
InsertSplitCellsText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : InsertSplitCellsText Property

Glossary Item Box

Specifies the text of Split Cells item in Table Designer pane and context menu.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Text")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the text of Split Cells item in Table Designer pane and context menu.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property InsertSplitCellsText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.InsertSplitCellsText = value

value = instance.InsertSplitCellsText
C#
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Split Cells item in Table Designer pane and context menu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string InsertSplitCellsText {get; set;}
Delphi
public read-write property InsertSplitCellsText: System.String;
JScript
System.ComponentModel.CategoryAttribute("Text")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the text of Split Cells item in Table Designer pane and context menu.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set InsertSplitCellsText : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Split Cells item in Table Designer pane and context menu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_InsertSplitCellsText();
public: __property void set_InsertSplitCellsText(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Split Cells item in Table Designer pane and context menu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ InsertSplitCellsText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


InsertTableText Property

[image]
Intersoft WebTextEditor Documentation
InsertTableText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : InsertTableText Property

Glossary Item Box

Specifies the text of Insert Table command in Table Designer toolbar.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Table command in Table Designer toolbar.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Text")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property InsertTableText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.InsertTableText = value

value = instance.InsertTableText
C#
[System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Table command in Table Designer toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.string InsertTableText {get; set;}
Delphi
public read-write property InsertTableText: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Table command in Table Designer toolbar.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Text")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set InsertTableText : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Table command in Table Designer toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_InsertTableText();
public: __property void set_InsertTableText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the text of Insert Table command in Table Designer toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ InsertTableText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


InsertTextAreaText Property

[image]
Intersoft WebTextEditor Documentation
InsertTextAreaText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : InsertTextAreaText Property

Glossary Item Box

Specifies the text of Insert TextArea item in Form Control pane.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Text")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the text of Insert TextArea item in Form Control pane.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property InsertTextAreaText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.InsertTextAreaText = value

value = instance.InsertTextAreaText
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Insert TextArea item in Form Control pane.")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string InsertTextAreaText {get; set;}
Delphi
public read-write property InsertTextAreaText: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Text")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the text of Insert TextArea item in Form Control pane.")
System.ComponentModel.DefaultValueAttribute()
public function get,set InsertTextAreaText : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Insert TextArea item in Form Control pane.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_InsertTextAreaText();
public: __property void set_InsertTextAreaText(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Insert TextArea item in Form Control pane.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ InsertTextAreaText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


MergeCellDown Property

[image]
Intersoft WebTextEditor Documentation
MergeCellDown Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : MergeCellDown Property

Glossary Item Box

Specifies the text of Merge Cell Down item in Table Designer pane and context menu.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the text of Merge Cell Down item in Table Designer pane and context menu.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Text")>
Public Property MergeCellDown As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.MergeCellDown = value

value = instance.MergeCellDown
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Merge Cell Down item in Table Designer pane and context menu.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text")]
public System.string MergeCellDown {get; set;}
Delphi
public read-write property MergeCellDown: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the text of Merge Cell Down item in Table Designer pane and context menu.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Text")
public function get,set MergeCellDown : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Merge Cell Down item in Table Designer pane and context menu.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text")]
public: __property System.string* get_MergeCellDown();
public: __property void set_MergeCellDown(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Merge Cell Down item in Table Designer pane and context menu.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text")]
public:
property System.String^ MergeCellDown {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


MergeCellRight Property

[image]
Intersoft WebTextEditor Documentation
MergeCellRight Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : MergeCellRight Property

Glossary Item Box

Specifies the text of Merge Cell Right item in Table Designer pane and context menu.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the text of Merge Cell Right item in Table Designer pane and context menu.")>
<System.ComponentModel.CategoryAttribute("Text")>
Public Property MergeCellRight As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.MergeCellRight = value

value = instance.MergeCellRight
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Merge Cell Right item in Table Designer pane and context menu.")]
[System.ComponentModel.CategoryAttribute("Text")]
public System.string MergeCellRight {get; set;}
Delphi
public read-write property MergeCellRight: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the text of Merge Cell Right item in Table Designer pane and context menu.")
System.ComponentModel.CategoryAttribute("Text")
public function get,set MergeCellRight : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Merge Cell Right item in Table Designer pane and context menu.")]
[System.ComponentModel.CategoryAttribute("Text")]
public: __property System.string* get_MergeCellRight();
public: __property void set_MergeCellRight(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Merge Cell Right item in Table Designer pane and context menu.")]
[System.ComponentModel.CategoryAttribute("Text")]
public:
property System.String^ MergeCellRight {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


NoResultFoundText Property

[image]
Intersoft WebTextEditor Documentation
NoResultFoundText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : NoResultFoundText Property

Glossary Item Box

Specifies the text when no result is found when searching the media in Media Gallery pane.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Text")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the text when no result is found when searching the media in Media Gallery pane.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property NoResultFoundText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.NoResultFoundText = value

value = instance.NoResultFoundText
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the text when no result is found when searching the media in Media Gallery pane.")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string NoResultFoundText {get; set;}
Delphi
public read-write property NoResultFoundText: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Text")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the text when no result is found when searching the media in Media Gallery pane.")
System.ComponentModel.DefaultValueAttribute()
public function get,set NoResultFoundText : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the text when no result is found when searching the media in Media Gallery pane.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_NoResultFoundText();
public: __property void set_NoResultFoundText(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the text when no result is found when searching the media in Media Gallery pane.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ NoResultFoundText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


PasteText Property

[image]
Intersoft WebTextEditor Documentation
PasteText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : PasteText Property

Glossary Item Box

Specifies the text of Paste menu item in context menu.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the text of Paste menu item in context menu.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Text")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property PasteText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.PasteText = value

value = instance.PasteText
C#
[System.ComponentModel.DescriptionAttribute("Specifies the text of Paste menu item in context menu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string PasteText {get; set;}
Delphi
public read-write property PasteText: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the text of Paste menu item in context menu.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Text")
System.ComponentModel.DefaultValueAttribute()
public function get,set PasteText : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the text of Paste menu item in context menu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_PasteText();
public: __property void set_PasteText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the text of Paste menu item in context menu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ PasteText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


PreviewMailMergeText Property

[image]
Intersoft WebTextEditor Documentation
PreviewMailMergeText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : PreviewMailMergeText Property

Glossary Item Box

Specifies the text that will be displayed in status bar when the preview data is being fetched.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the text that will be displayed in status bar when the preview data is being fetched.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Text")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property PreviewMailMergeText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.PreviewMailMergeText = value

value = instance.PreviewMailMergeText
C#
[System.ComponentModel.DescriptionAttribute("Specifies the text that will be displayed in status bar when the preview data is being fetched.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string PreviewMailMergeText {get; set;}
Delphi
public read-write property PreviewMailMergeText: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the text that will be displayed in status bar when the preview data is being fetched.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Text")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set PreviewMailMergeText : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the text that will be displayed in status bar when the preview data is being fetched.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_PreviewMailMergeText();
public: __property void set_PreviewMailMergeText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the text that will be displayed in status bar when the preview data is being fetched.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ PreviewMailMergeText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


PreviewText Property

[image]
Intersoft WebTextEditor Documentation
PreviewText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : PreviewText Property

Glossary Item Box

Specifies the text of Preview view tab in footer row.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the text of Preview view tab in footer row.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Text")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property PreviewText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.PreviewText = value

value = instance.PreviewText
C#
[System.ComponentModel.DescriptionAttribute("Specifies the text of Preview view tab in footer row.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.string PreviewText {get; set;}
Delphi
public read-write property PreviewText: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the text of Preview view tab in footer row.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Text")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set PreviewText : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the text of Preview view tab in footer row.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_PreviewText();
public: __property void set_PreviewText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the text of Preview view tab in footer row.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ PreviewText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


ReadyText Property

[image]
Intersoft WebTextEditor Documentation
ReadyText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : ReadyText Property

Glossary Item Box

Specifies the text displayed in status when the editor is in Ready state.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the text displayed in status when the editor is in Ready state.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Text")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property ReadyText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.ReadyText = value

value = instance.ReadyText
C#
[System.ComponentModel.DescriptionAttribute("Specifies the text displayed in status when the editor is in Ready state.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string ReadyText {get; set;}
Delphi
public read-write property ReadyText: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the text displayed in status when the editor is in Ready state.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Text")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set ReadyText : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the text displayed in status when the editor is in Ready state.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_ReadyText();
public: __property void set_ReadyText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the text displayed in status when the editor is in Ready state.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ ReadyText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


ResultTypeText Property

[image]
Intersoft WebTextEditor Documentation
ResultTypeText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : ResultTypeText Property

Glossary Item Box

Specifies the text of Result Type field name in Media Gallery pane.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the text of Result Type field name in Media Gallery pane.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Text")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property ResultTypeText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.ResultTypeText = value

value = instance.ResultTypeText
C#
[System.ComponentModel.DescriptionAttribute("Specifies the text of Result Type field name in Media Gallery pane.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string ResultTypeText {get; set;}
Delphi
public read-write property ResultTypeText: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the text of Result Type field name in Media Gallery pane.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Text")
System.ComponentModel.DefaultValueAttribute()
public function get,set ResultTypeText : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the text of Result Type field name in Media Gallery pane.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_ResultTypeText();
public: __property void set_ResultTypeText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the text of Result Type field name in Media Gallery pane.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ ResultTypeText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


SaveStatus Property

[image]
Intersoft WebTextEditor Documentation
SaveStatus Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : SaveStatus Property

Glossary Item Box

Specifies the text when auto save has been performed.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the text when auto save has been performed.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Text")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property SaveStatus As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.SaveStatus = value

value = instance.SaveStatus
C#
[System.ComponentModel.DescriptionAttribute("Specifies the text when auto save has been performed.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string SaveStatus {get; set;}
Delphi
public read-write property SaveStatus: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the text when auto save has been performed.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Text")
System.ComponentModel.DefaultValueAttribute()
public function get,set SaveStatus : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the text when auto save has been performed.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_SaveStatus();
public: __property void set_SaveStatus(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the text when auto save has been performed.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ SaveStatus {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


SearchingMediaText Property

[image]
Intersoft WebTextEditor Documentation
SearchingMediaText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : SearchingMediaText Property

Glossary Item Box

Specifies the text displayed in status bar when media search action is being performed.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the text displayed in status bar when media search action is being performed.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Text")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property SearchingMediaText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.SearchingMediaText = value

value = instance.SearchingMediaText
C#
[System.ComponentModel.DescriptionAttribute("Specifies the text displayed in status bar when media search action is being performed.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string SearchingMediaText {get; set;}
Delphi
public read-write property SearchingMediaText: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the text displayed in status bar when media search action is being performed.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Text")
System.ComponentModel.DefaultValueAttribute()
public function get,set SearchingMediaText : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the text displayed in status bar when media search action is being performed.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_SearchingMediaText();
public: __property void set_SearchingMediaText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the text displayed in status bar when media search action is being performed.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ SearchingMediaText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


SearchInText Property

[image]
Intersoft WebTextEditor Documentation
SearchInText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : SearchInText Property

Glossary Item Box

Specifies the text of Search In field name in Media Gallery pane.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the text of Search In field name in Media Gallery pane.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Text")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property SearchInText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.SearchInText = value

value = instance.SearchInText
C#
[System.ComponentModel.DescriptionAttribute("Specifies the text of Search In field name in Media Gallery pane.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string SearchInText {get; set;}
Delphi
public read-write property SearchInText: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the text of Search In field name in Media Gallery pane.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Text")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set SearchInText : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the text of Search In field name in Media Gallery pane.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_SearchInText();
public: __property void set_SearchInText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the text of Search In field name in Media Gallery pane.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ SearchInText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


SendMailMergeText Property

[image]
Intersoft WebTextEditor Documentation
SendMailMergeText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : SendMailMergeText Property

Glossary Item Box

Specifies the text that will be displayed in status bar when the mails are being sent.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the text that will be displayed in status bar when the mails are being sent.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Text")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property SendMailMergeText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.SendMailMergeText = value

value = instance.SendMailMergeText
C#
[System.ComponentModel.DescriptionAttribute("Specifies the text that will be displayed in status bar when the mails are being sent.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string SendMailMergeText {get; set;}
Delphi
public read-write property SendMailMergeText: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the text that will be displayed in status bar when the mails are being sent.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Text")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set SendMailMergeText : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the text that will be displayed in status bar when the mails are being sent.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_SendMailMergeText();
public: __property void set_SendMailMergeText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the text that will be displayed in status bar when the mails are being sent.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ SendMailMergeText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


SpellCheckingCompletedStatus Property

[image]
Intersoft WebTextEditor Documentation
SpellCheckingCompletedStatus Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : SpellCheckingCompletedStatus Property

Glossary Item Box

Specifies the text when spell checking has been completed.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the text when spell checking has been completed.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Text")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property SpellCheckingCompletedStatus As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.SpellCheckingCompletedStatus = value

value = instance.SpellCheckingCompletedStatus
C#
[System.ComponentModel.DescriptionAttribute("Specifies the text when spell checking has been completed.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.string SpellCheckingCompletedStatus {get; set;}
Delphi
public read-write property SpellCheckingCompletedStatus: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the text when spell checking has been completed.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Text")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set SpellCheckingCompletedStatus : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the text when spell checking has been completed.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_SpellCheckingCompletedStatus();
public: __property void set_SpellCheckingCompletedStatus(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the text when spell checking has been completed.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ SpellCheckingCompletedStatus {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


SplitCellHorizontal Property

[image]
Intersoft WebTextEditor Documentation
SplitCellHorizontal Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : SplitCellHorizontal Property

Glossary Item Box

Specifies the text of Split Cell Horizontal item in Table Designer pane and context menu.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Text")>
<System.ComponentModel.DescriptionAttribute("Specifies the text of Split Cell Horizontal item in Table Designer pane and context menu.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property SplitCellHorizontal As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.SplitCellHorizontal = value

value = instance.SplitCellHorizontal
C#
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Split Cell Horizontal item in Table Designer pane and context menu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string SplitCellHorizontal {get; set;}
Delphi
public read-write property SplitCellHorizontal: System.String;
JScript
System.ComponentModel.CategoryAttribute("Text")
System.ComponentModel.DescriptionAttribute("Specifies the text of Split Cell Horizontal item in Table Designer pane and context menu.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set SplitCellHorizontal : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Split Cell Horizontal item in Table Designer pane and context menu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_SplitCellHorizontal();
public: __property void set_SplitCellHorizontal(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Split Cell Horizontal item in Table Designer pane and context menu.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ SplitCellHorizontal {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


SplitCellVertical Property

[image]
Intersoft WebTextEditor Documentation
SplitCellVertical Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : SplitCellVertical Property

Glossary Item Box

Specifies the text of Split Cell Vertical item in Table Designer pane and context menu.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Text")>
<System.ComponentModel.DescriptionAttribute("Specifies the text of Split Cell Vertical item in Table Designer pane and context menu.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property SplitCellVertical As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.SplitCellVertical = value

value = instance.SplitCellVertical
C#
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Split Cell Vertical item in Table Designer pane and context menu.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string SplitCellVertical {get; set;}
Delphi
public read-write property SplitCellVertical: System.String;
JScript
System.ComponentModel.CategoryAttribute("Text")
System.ComponentModel.DescriptionAttribute("Specifies the text of Split Cell Vertical item in Table Designer pane and context menu.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set SplitCellVertical : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Split Cell Vertical item in Table Designer pane and context menu.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_SplitCellVertical();
public: __property void set_SplitCellVertical(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Split Cell Vertical item in Table Designer pane and context menu.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ SplitCellVertical {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


SplitViewText Property

[image]
Intersoft WebTextEditor Documentation
SplitViewText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : SplitViewText Property

Glossary Item Box

Specifies the text of Split view tab in footer row.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Text")>
<System.ComponentModel.DescriptionAttribute("Specifies the text of Split view tab in footer row.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property SplitViewText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.SplitViewText = value

value = instance.SplitViewText
C#
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Split view tab in footer row.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string SplitViewText {get; set;}
Delphi
public read-write property SplitViewText: System.String;
JScript
System.ComponentModel.CategoryAttribute("Text")
System.ComponentModel.DescriptionAttribute("Specifies the text of Split view tab in footer row.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set SplitViewText : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Split view tab in footer row.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_SplitViewText();
public: __property void set_SplitViewText(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Split view tab in footer row.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ SplitViewText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


SuccessSendMailText Property

[image]
Intersoft WebTextEditor Documentation
SuccessSendMailText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : SuccessSendMailText Property

Glossary Item Box

Specifies the text that will be displayed in status bar when the emails have been successfully sent.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the text that will be displayed in status bar when the emails have been successfully sent.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Text")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property SuccessSendMailText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.SuccessSendMailText = value

value = instance.SuccessSendMailText
C#
[System.ComponentModel.DescriptionAttribute("Specifies the text that will be displayed in status bar when the emails have been successfully sent.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string SuccessSendMailText {get; set;}
Delphi
public read-write property SuccessSendMailText: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the text that will be displayed in status bar when the emails have been successfully sent.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Text")
System.ComponentModel.DefaultValueAttribute()
public function get,set SuccessSendMailText : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the text that will be displayed in status bar when the emails have been successfully sent.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_SuccessSendMailText();
public: __property void set_SuccessSendMailText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the text that will be displayed in status bar when the emails have been successfully sent.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ SuccessSendMailText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


TableAlignmentText Property

[image]
Intersoft WebTextEditor Documentation
TableAlignmentText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : TableAlignmentText Property

Glossary Item Box

Specifies the text of Table Alignment field name in Table Designer pane.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Text")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the text of Table Alignment field name in Table Designer pane.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property TableAlignmentText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.TableAlignmentText = value

value = instance.TableAlignmentText
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Table Alignment field name in Table Designer pane.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string TableAlignmentText {get; set;}
Delphi
public read-write property TableAlignmentText: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Text")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the text of Table Alignment field name in Table Designer pane.")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set TableAlignmentText : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Table Alignment field name in Table Designer pane.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_TableAlignmentText();
public: __property void set_TableAlignmentText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Table Alignment field name in Table Designer pane.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ TableAlignmentText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


TableBackColorText Property

[image]
Intersoft WebTextEditor Documentation
TableBackColorText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : TableBackColorText Property

Glossary Item Box

Specifies the text of Table Back Color field name in Table Designer pane.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the text of Table Back Color field name in Table Designer pane.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Text")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property TableBackColorText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.TableBackColorText = value

value = instance.TableBackColorText
C#
[System.ComponentModel.DescriptionAttribute("Specifies the text of Table Back Color field name in Table Designer pane.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string TableBackColorText {get; set;}
Delphi
public read-write property TableBackColorText: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the text of Table Back Color field name in Table Designer pane.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Text")
System.ComponentModel.DefaultValueAttribute()
public function get,set TableBackColorText : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the text of Table Back Color field name in Table Designer pane.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_TableBackColorText();
public: __property void set_TableBackColorText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the text of Table Back Color field name in Table Designer pane.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ TableBackColorText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


TableBorderColorText Property

[image]
Intersoft WebTextEditor Documentation
TableBorderColorText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : TableBorderColorText Property

Glossary Item Box

Specifies the text of Table Border Color field name in Table Designer pane.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Text")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the text of Table Border Color field name in Table Designer pane.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property TableBorderColorText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.TableBorderColorText = value

value = instance.TableBorderColorText
C#
[System.ComponentModel.CategoryAttribute("Text")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Table Border Color field name in Table Designer pane.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string TableBorderColorText {get; set;}
Delphi
public read-write property TableBorderColorText: System.String;
JScript
System.ComponentModel.CategoryAttribute("Text")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the text of Table Border Color field name in Table Designer pane.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set TableBorderColorText : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Text")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Table Border Color field name in Table Designer pane.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_TableBorderColorText();
public: __property void set_TableBorderColorText(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Text")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Table Border Color field name in Table Designer pane.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ TableBorderColorText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


TableBorderWidthText Property

[image]
Intersoft WebTextEditor Documentation
TableBorderWidthText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : TableBorderWidthText Property

Glossary Item Box

Specifies the text of Table Border Width field name in Table Designer pane.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Text")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the text of Table Border Width field name in Table Designer pane.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property TableBorderWidthText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.TableBorderWidthText = value

value = instance.TableBorderWidthText
C#
[System.ComponentModel.CategoryAttribute("Text")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Table Border Width field name in Table Designer pane.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string TableBorderWidthText {get; set;}
Delphi
public read-write property TableBorderWidthText: System.String;
JScript
System.ComponentModel.CategoryAttribute("Text")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the text of Table Border Width field name in Table Designer pane.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set TableBorderWidthText : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Text")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Table Border Width field name in Table Designer pane.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_TableBorderWidthText();
public: __property void set_TableBorderWidthText(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Text")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Table Border Width field name in Table Designer pane.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ TableBorderWidthText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


TableCaptionText Property

[image]
Intersoft WebTextEditor Documentation
TableCaptionText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : TableCaptionText Property

Glossary Item Box

Specifies the text of Table Caption field name in Table Designer pane.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Text")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the text of Table Caption field name in Table Designer pane.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property TableCaptionText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.TableCaptionText = value

value = instance.TableCaptionText
C#
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Table Caption field name in Table Designer pane.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string TableCaptionText {get; set;}
Delphi
public read-write property TableCaptionText: System.String;
JScript
System.ComponentModel.CategoryAttribute("Text")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the text of Table Caption field name in Table Designer pane.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set TableCaptionText : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Table Caption field name in Table Designer pane.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_TableCaptionText();
public: __property void set_TableCaptionText(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Table Caption field name in Table Designer pane.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ TableCaptionText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


TableCellActionsText Property

[image]
Intersoft WebTextEditor Documentation
TableCellActionsText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : TableCellActionsText Property

Glossary Item Box

Specifies the text of Cell Actions title in Table Designer pane.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the text of Cell Actions title in Table Designer pane.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Text")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property TableCellActionsText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.TableCellActionsText = value

value = instance.TableCellActionsText
C#
[System.ComponentModel.DescriptionAttribute("Specifies the text of Cell Actions title in Table Designer pane.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string TableCellActionsText {get; set;}
Delphi
public read-write property TableCellActionsText: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the text of Cell Actions title in Table Designer pane.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Text")
System.ComponentModel.DefaultValueAttribute()
public function get,set TableCellActionsText : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the text of Cell Actions title in Table Designer pane.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_TableCellActionsText();
public: __property void set_TableCellActionsText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the text of Cell Actions title in Table Designer pane.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ TableCellActionsText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


TableCellPaddingText Property

[image]
Intersoft WebTextEditor Documentation
TableCellPaddingText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : TableCellPaddingText Property

Glossary Item Box

Specifies the text of Cell Padding field name in Table Designer pane.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the text of Cell Padding field name in Table Designer pane.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Text")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property TableCellPaddingText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.TableCellPaddingText = value

value = instance.TableCellPaddingText
C#
[System.ComponentModel.DescriptionAttribute("Specifies the text of Cell Padding field name in Table Designer pane.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string TableCellPaddingText {get; set;}
Delphi
public read-write property TableCellPaddingText: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the text of Cell Padding field name in Table Designer pane.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Text")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set TableCellPaddingText : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the text of Cell Padding field name in Table Designer pane.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_TableCellPaddingText();
public: __property void set_TableCellPaddingText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the text of Cell Padding field name in Table Designer pane.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ TableCellPaddingText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


TableCellPropertiesText Property

[image]
Intersoft WebTextEditor Documentation
TableCellPropertiesText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : TableCellPropertiesText Property

Glossary Item Box

Specifies the text of Cell Properties title in Table Designer pane.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Text")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the text of Cell Properties title in Table Designer pane.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property TableCellPropertiesText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.TableCellPropertiesText = value

value = instance.TableCellPropertiesText
C#
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Cell Properties title in Table Designer pane.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string TableCellPropertiesText {get; set;}
Delphi
public read-write property TableCellPropertiesText: System.String;
JScript
System.ComponentModel.CategoryAttribute("Text")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the text of Cell Properties title in Table Designer pane.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set TableCellPropertiesText : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Cell Properties title in Table Designer pane.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_TableCellPropertiesText();
public: __property void set_TableCellPropertiesText(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Cell Properties title in Table Designer pane.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ TableCellPropertiesText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


TableCellSpacingText Property

[image]
Intersoft WebTextEditor Documentation
TableCellSpacingText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : TableCellSpacingText Property

Glossary Item Box

Specifies the text of Cell Spacing field name in Table Designer pane.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the text of Cell Spacing field name in Table Designer pane.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Text")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property TableCellSpacingText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.TableCellSpacingText = value

value = instance.TableCellSpacingText
C#
[System.ComponentModel.DescriptionAttribute("Specifies the text of Cell Spacing field name in Table Designer pane.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string TableCellSpacingText {get; set;}
Delphi
public read-write property TableCellSpacingText: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the text of Cell Spacing field name in Table Designer pane.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Text")
System.ComponentModel.DefaultValueAttribute()
public function get,set TableCellSpacingText : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the text of Cell Spacing field name in Table Designer pane.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_TableCellSpacingText();
public: __property void set_TableCellSpacingText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the text of Cell Spacing field name in Table Designer pane.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ TableCellSpacingText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


TableColumnsText Property

[image]
Intersoft WebTextEditor Documentation
TableColumnsText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : TableColumnsText Property

Glossary Item Box

Specifies the text of Columns field name in Table Designer pane.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Text")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the text of Columns field name in Table Designer pane.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property TableColumnsText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.TableColumnsText = value

value = instance.TableColumnsText
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Columns field name in Table Designer pane.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string TableColumnsText {get; set;}
Delphi
public read-write property TableColumnsText: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Text")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the text of Columns field name in Table Designer pane.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set TableColumnsText : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Columns field name in Table Designer pane.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_TableColumnsText();
public: __property void set_TableColumnsText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Columns field name in Table Designer pane.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ TableColumnsText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


TableCustomText Property

[image]
Intersoft WebTextEditor Documentation
TableCustomText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : TableCustomText Property

Glossary Item Box

Specifies the text of Custom radio button in Table Designer pane.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the text of Custom radio button in Table Designer pane.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Text")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property TableCustomText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.TableCustomText = value

value = instance.TableCustomText
C#
[System.ComponentModel.DescriptionAttribute("Specifies the text of Custom radio button in Table Designer pane.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.string TableCustomText {get; set;}
Delphi
public read-write property TableCustomText: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the text of Custom radio button in Table Designer pane.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Text")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set TableCustomText : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the text of Custom radio button in Table Designer pane.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_TableCustomText();
public: __property void set_TableCustomText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the text of Custom radio button in Table Designer pane.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ TableCustomText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


TableDesignerText Property

[image]
Intersoft WebTextEditor Documentation
TableDesignerText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : TableDesignerText Property

Glossary Item Box

Specifies the text of Table Designer title.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the text of Table Designer title.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Text")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property TableDesignerText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.TableDesignerText = value

value = instance.TableDesignerText
C#
[System.ComponentModel.DescriptionAttribute("Specifies the text of Table Designer title.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string TableDesignerText {get; set;}
Delphi
public read-write property TableDesignerText: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the text of Table Designer title.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Text")
System.ComponentModel.DefaultValueAttribute()
public function get,set TableDesignerText : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the text of Table Designer title.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_TableDesignerText();
public: __property void set_TableDesignerText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the text of Table Designer title.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ TableDesignerText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


TableFontColorText Property

[image]
Intersoft WebTextEditor Documentation
TableFontColorText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : TableFontColorText Property

Glossary Item Box

Specifies the text of Table Font Color field name in Table Designer pane.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Text")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the text of Table Font Color field name in Table Designer pane.")>
Public Property TableFontColorText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.TableFontColorText = value

value = instance.TableFontColorText
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Table Font Color field name in Table Designer pane.")]
public System.string TableFontColorText {get; set;}
Delphi
public read-write property TableFontColorText: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Text")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the text of Table Font Color field name in Table Designer pane.")
public function get,set TableFontColorText : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Table Font Color field name in Table Designer pane.")]
public: __property System.string* get_TableFontColorText();
public: __property void set_TableFontColorText(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Table Font Color field name in Table Designer pane.")]
public:
property System.String^ TableFontColorText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


TableHeightText Property

[image]
Intersoft WebTextEditor Documentation
TableHeightText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : TableHeightText Property

Glossary Item Box

Specifies the text of Table Height field name in Table Designer pane.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Text")>
<System.ComponentModel.DescriptionAttribute("Specifies the text of Table Height field name in Table Designer pane.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property TableHeightText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.TableHeightText = value

value = instance.TableHeightText
C#
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Table Height field name in Table Designer pane.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string TableHeightText {get; set;}
Delphi
public read-write property TableHeightText: System.String;
JScript
System.ComponentModel.CategoryAttribute("Text")
System.ComponentModel.DescriptionAttribute("Specifies the text of Table Height field name in Table Designer pane.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set TableHeightText : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Table Height field name in Table Designer pane.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_TableHeightText();
public: __property void set_TableHeightText(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Table Height field name in Table Designer pane.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ TableHeightText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


TableHorizontalAlignText Property

[image]
Intersoft WebTextEditor Documentation
TableHorizontalAlignText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : TableHorizontalAlignText Property

Glossary Item Box

Specifies the text of Table Horizontal Align field name in Table Designer pane.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the text of Table Horizontal Align field name in Table Designer pane.")>
<System.ComponentModel.CategoryAttribute("Text")>
Public Property TableHorizontalAlignText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.TableHorizontalAlignText = value

value = instance.TableHorizontalAlignText
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Table Horizontal Align field name in Table Designer pane.")]
[System.ComponentModel.CategoryAttribute("Text")]
public System.string TableHorizontalAlignText {get; set;}
Delphi
public read-write property TableHorizontalAlignText: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the text of Table Horizontal Align field name in Table Designer pane.")
System.ComponentModel.CategoryAttribute("Text")
public function get,set TableHorizontalAlignText : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Table Horizontal Align field name in Table Designer pane.")]
[System.ComponentModel.CategoryAttribute("Text")]
public: __property System.string* get_TableHorizontalAlignText();
public: __property void set_TableHorizontalAlignText(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Table Horizontal Align field name in Table Designer pane.")]
[System.ComponentModel.CategoryAttribute("Text")]
public:
property System.String^ TableHorizontalAlignText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


TableNoWrapText Property

[image]
Intersoft WebTextEditor Documentation
TableNoWrapText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : TableNoWrapText Property

Glossary Item Box

Specifies the text of No Wrap checkbox in Table Designer pane.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the text of No Wrap checkbox in Table Designer pane.")>
<System.ComponentModel.CategoryAttribute("Text")>
Public Property TableNoWrapText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.TableNoWrapText = value

value = instance.TableNoWrapText
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of No Wrap checkbox in Table Designer pane.")]
[System.ComponentModel.CategoryAttribute("Text")]
public System.string TableNoWrapText {get; set;}
Delphi
public read-write property TableNoWrapText: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the text of No Wrap checkbox in Table Designer pane.")
System.ComponentModel.CategoryAttribute("Text")
public function get,set TableNoWrapText : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of No Wrap checkbox in Table Designer pane.")]
[System.ComponentModel.CategoryAttribute("Text")]
public: __property System.string* get_TableNoWrapText();
public: __property void set_TableNoWrapText(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of No Wrap checkbox in Table Designer pane.")]
[System.ComponentModel.CategoryAttribute("Text")]
public:
property System.String^ TableNoWrapText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


TablePropertiesText Property

[image]
Intersoft WebTextEditor Documentation
TablePropertiesText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : TablePropertiesText Property

Glossary Item Box

Specifies the text of Table Properties title in Table Designer pane.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the text of Table Properties title in Table Designer pane.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Text")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property TablePropertiesText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.TablePropertiesText = value

value = instance.TablePropertiesText
C#
[System.ComponentModel.DescriptionAttribute("Specifies the text of Table Properties title in Table Designer pane.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string TablePropertiesText {get; set;}
Delphi
public read-write property TablePropertiesText: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the text of Table Properties title in Table Designer pane.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Text")
System.ComponentModel.DefaultValueAttribute()
public function get,set TablePropertiesText : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the text of Table Properties title in Table Designer pane.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_TablePropertiesText();
public: __property void set_TablePropertiesText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the text of Table Properties title in Table Designer pane.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ TablePropertiesText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


TableRowsText Property

[image]
Intersoft WebTextEditor Documentation
TableRowsText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : TableRowsText Property

Glossary Item Box

Specifies the text of Rows field name in Table Designer pane.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the text of Rows field name in Table Designer pane.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("Text")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property TableRowsText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.TableRowsText = value

value = instance.TableRowsText
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Rows field name in Table Designer pane.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string TableRowsText {get; set;}
Delphi
public read-write property TableRowsText: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the text of Rows field name in Table Designer pane.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("Text")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set TableRowsText : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Rows field name in Table Designer pane.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_TableRowsText();
public: __property void set_TableRowsText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Rows field name in Table Designer pane.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("Text")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ TableRowsText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


TableSummaryText Property

[image]
Intersoft WebTextEditor Documentation
TableSummaryText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : TableSummaryText Property

Glossary Item Box

Specifies the text of Summary field name in Table Designer pane.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Text")>
<System.ComponentModel.DescriptionAttribute("Specifies the text of Summary field name in Table Designer pane.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property TableSummaryText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.TableSummaryText = value

value = instance.TableSummaryText
C#
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Summary field name in Table Designer pane.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string TableSummaryText {get; set;}
Delphi
public read-write property TableSummaryText: System.String;
JScript
System.ComponentModel.CategoryAttribute("Text")
System.ComponentModel.DescriptionAttribute("Specifies the text of Summary field name in Table Designer pane.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set TableSummaryText : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Summary field name in Table Designer pane.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_TableSummaryText();
public: __property void set_TableSummaryText(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DescriptionAttribute("Specifies the text of Summary field name in Table Designer pane.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ TableSummaryText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


TableTemplateText Property

[image]
Intersoft WebTextEditor Documentation
TableTemplateText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : TableTemplateText Property

Glossary Item Box

Specifies the text of Template radio button in Table Designer pane.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the text of Template radio button in Table Designer pane.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Text")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property TableTemplateText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.TableTemplateText = value

value = instance.TableTemplateText
C#
[System.ComponentModel.DescriptionAttribute("Specifies the text of Template radio button in Table Designer pane.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string TableTemplateText {get; set;}
Delphi
public read-write property TableTemplateText: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the text of Template radio button in Table Designer pane.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Text")
System.ComponentModel.DefaultValueAttribute()
public function get,set TableTemplateText : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the text of Template radio button in Table Designer pane.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_TableTemplateText();
public: __property void set_TableTemplateText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the text of Template radio button in Table Designer pane.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ TableTemplateText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


TableVerticalAlignText Property

[image]
Intersoft WebTextEditor Documentation
TableVerticalAlignText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : TableVerticalAlignText Property

Glossary Item Box

Specifies the text of Vertical Align field name in Table Designer pane.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the text of Vertical Align field name in Table Designer pane.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Text")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property TableVerticalAlignText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.TableVerticalAlignText = value

value = instance.TableVerticalAlignText
C#
[System.ComponentModel.DescriptionAttribute("Specifies the text of Vertical Align field name in Table Designer pane.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string TableVerticalAlignText {get; set;}
Delphi
public read-write property TableVerticalAlignText: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the text of Vertical Align field name in Table Designer pane.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Text")
System.ComponentModel.DefaultValueAttribute()
public function get,set TableVerticalAlignText : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the text of Vertical Align field name in Table Designer pane.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_TableVerticalAlignText();
public: __property void set_TableVerticalAlignText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the text of Vertical Align field name in Table Designer pane.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ TableVerticalAlignText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


TableWidthText Property

[image]
Intersoft WebTextEditor Documentation
TableWidthText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : TableWidthText Property

Glossary Item Box

Specifies the text of Table Width field name in Table Designer pane.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the text of Table Width field name in Table Designer pane.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Text")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property TableWidthText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.TableWidthText = value

value = instance.TableWidthText
C#
[System.ComponentModel.DescriptionAttribute("Specifies the text of Table Width field name in Table Designer pane.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string TableWidthText {get; set;}
Delphi
public read-write property TableWidthText: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the text of Table Width field name in Table Designer pane.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Text")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set TableWidthText : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the text of Table Width field name in Table Designer pane.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_TableWidthText();
public: __property void set_TableWidthText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the text of Table Width field name in Table Designer pane.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ TableWidthText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


TaskPaneHTMLViewText Property

[image]
Intersoft WebTextEditor Documentation
TaskPaneHTMLViewText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : TaskPaneHTMLViewText Property

Glossary Item Box

Specifies the text of pane content when viewing in HTML view.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Text")>
<System.ComponentModel.DescriptionAttribute("Specifies the text of pane content when viewing in HTML view.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property TaskPaneHTMLViewText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.TaskPaneHTMLViewText = value

value = instance.TaskPaneHTMLViewText
C#
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DescriptionAttribute("Specifies the text of pane content when viewing in HTML view.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string TaskPaneHTMLViewText {get; set;}
Delphi
public read-write property TaskPaneHTMLViewText: System.String;
JScript
System.ComponentModel.CategoryAttribute("Text")
System.ComponentModel.DescriptionAttribute("Specifies the text of pane content when viewing in HTML view.")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set TaskPaneHTMLViewText : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DescriptionAttribute("Specifies the text of pane content when viewing in HTML view.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_TaskPaneHTMLViewText();
public: __property void set_TaskPaneHTMLViewText(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DescriptionAttribute("Specifies the text of pane content when viewing in HTML view.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ TaskPaneHTMLViewText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


WordsInformationText Property

[image]
Intersoft WebTextEditor Documentation
WordsInformationText Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : WordsInformationText Property

Glossary Item Box

Specifies the text of word information in footer row.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the text of word information in footer row.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Text")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property WordsInformationText As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

instance.WordsInformationText = value

value = instance.WordsInformationText
C#
[System.ComponentModel.DescriptionAttribute("Specifies the text of word information in footer row.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string WordsInformationText {get; set;}
Delphi
public read-write property WordsInformationText: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the text of word information in footer row.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Text")
System.ComponentModel.DefaultValueAttribute()
public function get,set WordsInformationText : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the text of word information in footer row.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_WordsInformationText();
public: __property void set_WordsInformationText(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the text of word information in footer row.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Text")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ WordsInformationText {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


WebTextEditorToolBar Class

[image]
Intersoft WebTextEditor Documentation
WebTextEditorToolBar Class
Members See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorToolBar Class

Glossary Item Box

A collection of members in WebTextEditor's ToolBar.

Object Model

WebTextEditorToolBar Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebTextEditorToolBar
   Inherits ISNet.WebUI.NamedObjectBase2
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBar
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebTextEditorToolBar : ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
Delphi
public class WebTextEditorToolBar = class(ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebTextEditorToolBar extends ISNet.WebUI.NamedObjectBase2 implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebTextEditorToolBar : public ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebTextEditorToolBar : public ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.NamedObjectBase2
ISNet.WebUI.WebTextEditor.WebTextEditorToolBar

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBar Members
ISNet.WebUI.WebTextEditor Namespace


WebTextEditorToolBar Class Members

[image]
Intersoft WebTextEditor Documentation
WebTextEditorToolBar Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorToolBar Class

Glossary Item Box

The following tables list the members exposed by WebTextEditorToolBar.

Public Constructors

 | Name | Description
Public Constructor | WebTextEditorToolBar Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Category | Specifies the category of toolbar.
Public Property | Collection | (Inherited from ISNet.WebUI.NamedObjectBase2)
Public Property | Name | Overridden. Specifies the name of toolbar.
Public Property | Text | Specifies the text of toolbar.
Public Property | ToolCommands | Specifies the tool commands collection.
Public Property | Visible | Specifies whether or not the toolbar is visible on load.
Top

Public Methods

 | Name | Description
Public Method | Add | Overloaded.
Public Method | AddSeparator | Perform add separator type command.
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

Protected Methods

 | Name | Description
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | IsInSerializationContext | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | OnItemAdd | (Inherited from ISNet.WebUI.NamedObjectBase2)
Protected Method | OnItemRemove | (Inherited from ISNet.WebUI.NamedObjectBase2)
Top

See Also

Reference

WebTextEditorToolBar Class
ISNet.WebUI.WebTextEditor Namespace


WebTextEditorToolBar Constructor

[image]
Intersoft WebTextEditor Documentation
WebTextEditorToolBar Constructor
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBar Class : WebTextEditorToolBar Constructor

Glossary Item Box

Overload List

Overload | Description
WebTextEditorToolBar Constructor() |
WebTextEditorToolBar Constructor(WebTextEditor) |
WebTextEditorToolBar Constructor(SerializationInfo,StreamingContext) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBar Class
WebTextEditorToolBar Members


WebTextEditorToolBar Constructor()

[image]
Intersoft WebTextEditor Documentation
WebTextEditorToolBar Constructor()
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBar Class > WebTextEditorToolBar Constructor : WebTextEditorToolBar Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebTextEditorToolBar()
C#
public WebTextEditorToolBar()
Delphi
public WebTextEditorToolBar();
JScript
public function WebTextEditorToolBar();
Managed Extensions for C++
public: WebTextEditorToolBar();
C++/CLI
public:
WebTextEditorToolBar();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBar Class
WebTextEditorToolBar Members
Overload List


WebTextEditorToolBar Constructor(WebTextEditor)

[image]
Intersoft WebTextEditor Documentation
WebTextEditorToolBar Constructor(WebTextEditor)
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBar Class > WebTextEditorToolBar Constructor : WebTextEditorToolBar Constructor(WebTextEditor)

control

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal control As WebTextEditor _
)
Visual Basic (Usage) Copy Code
Dim control As WebTextEditor

Dim instance As New WebTextEditorToolBar(control)
C#
public WebTextEditorToolBar(
   WebTextEditor control
)
Delphi
public WebTextEditorToolBar(
    control: WebTextEditor
);
JScript
public function WebTextEditorToolBar(
   control : WebTextEditor
);
Managed Extensions for C++
public: WebTextEditorToolBar(
   WebTextEditor* control
)
C++/CLI
public:
WebTextEditorToolBar(
   WebTextEditor^ control
)

Parameters

control

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBar Class
WebTextEditorToolBar Members
Overload List


WebTextEditorToolBar Constructor(SerializationInfo,StreamingContext)

[image]
Intersoft WebTextEditor Documentation
WebTextEditorToolBar Constructor(SerializationInfo,StreamingContext)
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBar Class > WebTextEditorToolBar Constructor : WebTextEditorToolBar Constructor(SerializationInfo,StreamingContext)

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

Dim instance As New WebTextEditorToolBar(info, context)
C#
protected WebTextEditorToolBar(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
protected WebTextEditorToolBar(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
protected function WebTextEditorToolBar(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
protected: WebTextEditorToolBar(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
protected:
WebTextEditorToolBar(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBar Class
WebTextEditorToolBar Members
Overload List


WebTextEditorToolBar Class Methods

[image]
Intersoft WebTextEditor Documentation
WebTextEditorToolBar Class Methods
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorToolBar Class

Glossary Item Box

For a list of all members of this type, see WebTextEditorToolBar members.

Public Methods

 | Name | Description
Public Method | Add | Overloaded.
Public Method | AddSeparator | Perform add separator type command.
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

Protected Methods

 | Name | Description
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | IsInSerializationContext | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | OnItemAdd | (Inherited from ISNet.WebUI.NamedObjectBase2)
Protected Method | OnItemRemove | (Inherited from ISNet.WebUI.NamedObjectBase2)
Top

See Also

Reference

WebTextEditorToolBar Class
ISNet.WebUI.WebTextEditor Namespace


Add Method

[image]
Intersoft WebTextEditor Documentation
Add Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBar Class : Add Method

Glossary Item Box

Overload List

Overload | Description
Add(List<WebTextEditorToolCommandType>) |
Add(WebTextEditorToolCommandType) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBar Class
WebTextEditorToolBar Members


Add(List<WebTextEditorToolCommandType>) Method

[image]
Intersoft WebTextEditor Documentation
Add(List<WebTextEditorToolCommandType>) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBar Class > Add Method : Add(List<WebTextEditorToolCommandType>) Method

types

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub Add( _
   ByVal types As System.Collections.Generic.List(Of WebTextEditorToolCommandType) _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBar
Dim types As System.Collections.Generic.List(Of WebTextEditorToolCommandType)

instance.Add(types)
C#
public void Add(
   System.Collections.Generic.List<WebTextEditorToolCommandType> types
)
Delphi
public procedure Add(
    types: System.Collections.Generic.List
);
JScript
public function Add(
   types : System.Collections.Generic.List
);
Managed Extensions for C++
public: void Add(
   System.Collections.Generic.List<WebTextEditorToolCommandType>* types
)
C++/CLI
public:
void Add(
   System.Collections.Generic.List<WebTextEditorToolCommandType>^ types
)

Parameters

types

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBar Class
WebTextEditorToolBar Members
Overload List


Add(WebTextEditorToolCommandType) Method

[image]
Intersoft WebTextEditor Documentation
Add(WebTextEditorToolCommandType) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBar Class > Add Method : Add(WebTextEditorToolCommandType) Method

type

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub Add( _
   ByVal type As WebTextEditorToolCommandType _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBar
Dim type As WebTextEditorToolCommandType

instance.Add(type)
C#
public void Add(
   WebTextEditorToolCommandType type
)
Delphi
public procedure Add(
    type: WebTextEditorToolCommandType
);
JScript
public function Add(
   type : WebTextEditorToolCommandType
);
Managed Extensions for C++
public: void Add(
   WebTextEditorToolCommandType type
)
C++/CLI
public:
void Add(
   WebTextEditorToolCommandType type
)

Parameters

type

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBar Class
WebTextEditorToolBar Members
Overload List


AddSeparator Method

[image]
Intersoft WebTextEditor Documentation
AddSeparator Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBar Class : AddSeparator Method

index

Glossary Item Box

Perform add separator type command.

Syntax

Visual Basic (Declaration)
Public Sub AddSeparator( _
   ByVal index As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBar
Dim index As System.String

instance.AddSeparator(index)
C#
public void AddSeparator(
   System.string index
)
Delphi
public procedure AddSeparator(
    index: System.String
);
JScript
public function AddSeparator(
   index : System.String
);
Managed Extensions for C++
public: void AddSeparator(
   System.string* index
)
C++/CLI
public:
void AddSeparator(
   System.String^ index
)

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBar Class
WebTextEditorToolBar Members


GetObjectData Method

[image]
Intersoft WebTextEditor Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBar Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBar
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBar Class
WebTextEditorToolBar Members


WebTextEditorToolBar Class Properties

[image]
Intersoft WebTextEditor Documentation
WebTextEditorToolBar Class Properties
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorToolBar Class

Glossary Item Box

For a list of all members of this type, see WebTextEditorToolBar members.

Public Properties

 | Name | Description
Public Property | Category | Specifies the category of toolbar.
Public Property | Collection | (Inherited from ISNet.WebUI.NamedObjectBase2)
Public Property | Name | Overridden. Specifies the name of toolbar.
Public Property | Text | Specifies the text of toolbar.
Public Property | ToolCommands | Specifies the tool commands collection.
Public Property | Visible | Specifies whether or not the toolbar is visible on load.
Top

See Also

Reference

WebTextEditorToolBar Class
ISNet.WebUI.WebTextEditor Namespace


Category Property

[image]
Intersoft WebTextEditor Documentation
Category Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBar Class : Category Property

Glossary Item Box

Specifies the category of toolbar.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BrowsableAttribute(True)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the category of toolbar.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("ToolBar")>
Public Property Category As WebTextEditorToolBarCategory
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBar
Dim value As WebTextEditorToolBarCategory

instance.Category = value

value = instance.Category
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the category of toolbar.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("ToolBar")]
public WebTextEditorToolBarCategory Category {get; set;}
Delphi
public read-write property Category: WebTextEditorToolBarCategory;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the category of toolbar.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("ToolBar")
public function get,set Category : WebTextEditorToolBarCategory
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the category of toolbar.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("ToolBar")]
public: __property WebTextEditorToolBarCategory get_Category();
public: __property void set_Category(
   WebTextEditorToolBarCategory value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the category of toolbar.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("ToolBar")]
public:
property WebTextEditorToolBarCategory Category {
   WebTextEditorToolBarCategory get();
   void set (    WebTextEditorToolBarCategory value);
}

Property Value

The default value is Standard.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBar Class
WebTextEditorToolBar Members


Name Property

[image]
Intersoft WebTextEditor Documentation
Name Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBar Class : Name Property

Glossary Item Box

Specifies the name of toolbar.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BrowsableAttribute(True)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("ToolBar")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the name of toolbar.")>
Public Overrides Property Name As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBar
Dim value As System.String

instance.Name = value

value = instance.Name
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("ToolBar")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the name of toolbar.")]
public override System.string Name {get; set;}
Delphi
public read-write property Name: System.String; override;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("ToolBar")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the name of toolbar.")
public override function get,set Name : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("ToolBar")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the name of toolbar.")]
public: __property System.string* get_Name() override;
public: __property void set_Name(
   System.string* value
) override;
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("ToolBar")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the name of toolbar.")]
public:
property System.String^ Name {
   System.String^ get() override;
   void set (    System.String^ value) override;
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBar Class
WebTextEditorToolBar Members


Text Property

[image]
Intersoft WebTextEditor Documentation
Text Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBar Class : Text Property

Glossary Item Box

Specifies the text of toolbar.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("ToolBar")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the text of toolbar.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property Text As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBar
Dim value As System.String

instance.Text = value

value = instance.Text
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("ToolBar")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of toolbar.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string Text {get; set;}
Delphi
public read-write property Text: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("ToolBar")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the text of toolbar.")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set Text : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("ToolBar")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of toolbar.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_Text();
public: __property void set_Text(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("ToolBar")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of toolbar.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ Text {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBar Class
WebTextEditorToolBar Members


ToolCommands Property

[image]
Intersoft WebTextEditor Documentation
ToolCommands Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBar Class : ToolCommands Property

Glossary Item Box

Specifies the tool commands collection.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute(True)>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebTextEditor, Version=1.0.1000.9, Culture=neutral, PublicKeyToken=b1f2a8511635667a")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the tool commands collection.")>
<System.ComponentModel.CategoryAttribute("ToolBar")>
Public Property ToolCommands As WebTextEditorToolCommandCollection
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBar
Dim value As WebTextEditorToolCommandCollection

instance.ToolCommands = value

value = instance.ToolCommands
C#
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebTextEditor, Version=1.0.1000.9, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the tool commands collection.")]
[System.ComponentModel.CategoryAttribute("ToolBar")]
public WebTextEditorToolCommandCollection ToolCommands {get; set;}
Delphi
public read-write property ToolCommands: WebTextEditorToolCommandCollection;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebTextEditor, Version=1.0.1000.9, Culture=neutral, PublicKeyToken=b1f2a8511635667a")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the tool commands collection.")
System.ComponentModel.CategoryAttribute("ToolBar")
public function get,set ToolCommands : WebTextEditorToolCommandCollection
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebTextEditor, Version=1.0.1000.9, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the tool commands collection.")]
[System.ComponentModel.CategoryAttribute("ToolBar")]
public: __property WebTextEditorToolCommandCollection* get_ToolCommands();
public: __property void set_ToolCommands(
   WebTextEditorToolCommandCollection* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebTextEditor, Version=1.0.1000.9, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the tool commands collection.")]
[System.ComponentModel.CategoryAttribute("ToolBar")]
public:
property WebTextEditorToolCommandCollection^ ToolCommands {
   WebTextEditorToolCommandCollection^ get();
   void set (    WebTextEditorToolCommandCollection^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBar Class
WebTextEditorToolBar Members


Visible Property

[image]
Intersoft WebTextEditor Documentation
Visible Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBar Class : Visible Property

Glossary Item Box

Specifies whether or not the toolbar is visible on load.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies whether or not the toolbar is visible on load.")>
<System.ComponentModel.CategoryAttribute("ToolBar")>
Public Property Visible As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBar
Dim value As System.Boolean

instance.Visible = value

value = instance.Visible
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not the toolbar is visible on load.")]
[System.ComponentModel.CategoryAttribute("ToolBar")]
public System.bool Visible {get; set;}
Delphi
public read-write property Visible: System.Boolean;
JScript
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether or not the toolbar is visible on load.")
System.ComponentModel.CategoryAttribute("ToolBar")
public function get,set Visible : System.boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not the toolbar is visible on load.")]
[System.ComponentModel.CategoryAttribute("ToolBar")]
public: __property System.bool get_Visible();
public: __property void set_Visible(
   System.bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not the toolbar is visible on load.")]
[System.ComponentModel.CategoryAttribute("ToolBar")]
public:
property System.bool Visible {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is True.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBar Class
WebTextEditorToolBar Members


WebTextEditorToolBarArgs Class

[image]
Intersoft WebTextEditor Documentation
WebTextEditorToolBarArgs Class
Members See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorToolBarArgs Class

Glossary Item Box

Provides data for ToolBar event.

Object Model

WebTextEditorToolBarArgs Class

Syntax

Visual Basic (Declaration)
Public Class WebTextEditorToolBarArgs
   Inherits System.EventArgs
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBarArgs
C#
public class WebTextEditorToolBarArgs : System.EventArgs
Delphi
public class WebTextEditorToolBarArgs = class(System.EventArgs)
JScript
public class WebTextEditorToolBarArgs extends System.EventArgs
Managed Extensions for C++
public __gc class WebTextEditorToolBarArgs : public System.EventArgs
C++/CLI
public ref class WebTextEditorToolBarArgs : public System.EventArgs

Inheritance Hierarchy

System.Object
System.EventArgs
ISNet.WebUI.WebTextEditor.WebTextEditorToolBarArgs

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBarArgs Members
ISNet.WebUI.WebTextEditor Namespace


WebTextEditorToolBarArgs Class Members

[image]
Intersoft WebTextEditor Documentation
WebTextEditorToolBarArgs Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorToolBarArgs Class

Glossary Item Box

The following tables list the members exposed by WebTextEditorToolBarArgs.

Public Constructors

 | Name | Description
Public Constructor | WebTextEditorToolBarArgs Constructor |
Top

Public Properties

 | Name | Description
Public Property | Cancel |
Public Property | FloatingToolBar |
Public Property | HTMLToolBar |
Public Property | PreviewToolBar |
Public Property | ToolBar |
Top

Public Methods

 | Name | Description
Public Method | GetToolBarByCategory | Overloaded.
Top

See Also

Reference

WebTextEditorToolBarArgs Class
ISNet.WebUI.WebTextEditor Namespace


WebTextEditorToolBarArgs Constructor

[image]
Intersoft WebTextEditor Documentation
WebTextEditorToolBarArgs Constructor
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBarArgs Class : WebTextEditorToolBarArgs Constructor

toolbar
htmlToolBar
previewToolBar
floatingToolBar

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New( _
   ByVal toolbar As WebTextEditorToolBarCollection, _
   ByVal htmlToolBar As WebTextEditorToolBarCollection, _
   ByVal previewToolBar As WebTextEditorToolBarCollection, _
   ByVal floatingToolBar As WebTextEditorToolBarCollection _
)
Visual Basic (Usage) Copy Code
Dim toolbar As WebTextEditorToolBarCollection
Dim htmlToolBar As WebTextEditorToolBarCollection
Dim previewToolBar As WebTextEditorToolBarCollection
Dim floatingToolBar As WebTextEditorToolBarCollection

Dim instance As New WebTextEditorToolBarArgs(toolbar, htmlToolBar, previewToolBar, floatingToolBar)
C#
public WebTextEditorToolBarArgs(
   WebTextEditorToolBarCollection toolbar,
   WebTextEditorToolBarCollection htmlToolBar,
   WebTextEditorToolBarCollection previewToolBar,
   WebTextEditorToolBarCollection floatingToolBar
)
Delphi
public WebTextEditorToolBarArgs(
    toolbar: WebTextEditorToolBarCollection;
    htmlToolBar: WebTextEditorToolBarCollection;
    previewToolBar: WebTextEditorToolBarCollection;
    floatingToolBar: WebTextEditorToolBarCollection
);
JScript
public function WebTextEditorToolBarArgs(
   toolbar : WebTextEditorToolBarCollection,
   htmlToolBar : WebTextEditorToolBarCollection,
   previewToolBar : WebTextEditorToolBarCollection,
   floatingToolBar : WebTextEditorToolBarCollection
);
Managed Extensions for C++
public: WebTextEditorToolBarArgs(
   WebTextEditorToolBarCollection* toolbar,
   WebTextEditorToolBarCollection* htmlToolBar,
   WebTextEditorToolBarCollection* previewToolBar,
   WebTextEditorToolBarCollection* floatingToolBar
)
C++/CLI
public:
WebTextEditorToolBarArgs(
   WebTextEditorToolBarCollection^ toolbar,
   WebTextEditorToolBarCollection^ htmlToolBar,
   WebTextEditorToolBarCollection^ previewToolBar,
   WebTextEditorToolBarCollection^ floatingToolBar
)

Parameters

toolbar
htmlToolBar
previewToolBar
floatingToolBar

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBarArgs Class
WebTextEditorToolBarArgs Members


WebTextEditorToolBarArgs Class Methods

[image]
Intersoft WebTextEditor Documentation
WebTextEditorToolBarArgs Class Methods
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorToolBarArgs Class

Glossary Item Box

For a list of all members of this type, see WebTextEditorToolBarArgs members.

Public Methods

 | Name | Description
Public Method | GetToolBarByCategory | Overloaded.
Top

See Also

Reference

WebTextEditorToolBarArgs Class
ISNet.WebUI.WebTextEditor Namespace


GetToolBarByCategory Method

[image]
Intersoft WebTextEditor Documentation
GetToolBarByCategory Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBarArgs Class : GetToolBarByCategory Method

Glossary Item Box

Overload List

Overload | Description
GetToolBarByCategory(WebTextEditorToolBarCategory) |
GetToolBarByCategory(WebTextEditorToolBarCategory,String) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBarArgs Class
WebTextEditorToolBarArgs Members


GetToolBarByCategory(WebTextEditorToolBarCategory) Method

[image]
Intersoft WebTextEditor Documentation
GetToolBarByCategory(WebTextEditorToolBarCategory) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBarArgs Class > GetToolBarByCategory Method : GetToolBarByCategory(WebTextEditorToolBarCategory) Method

category

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetToolBarByCategory( _
   ByVal category As WebTextEditorToolBarCategory _
) As WebTextEditorToolBar
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBarArgs
Dim category As WebTextEditorToolBarCategory
Dim value As WebTextEditorToolBar

value = instance.GetToolBarByCategory(category)
C#
public WebTextEditorToolBar GetToolBarByCategory(
   WebTextEditorToolBarCategory category
)
Delphi
public function GetToolBarByCategory(
    category: WebTextEditorToolBarCategory
): WebTextEditorToolBar;
JScript
public function GetToolBarByCategory(
   category : WebTextEditorToolBarCategory
) : WebTextEditorToolBar;
Managed Extensions for C++
public: WebTextEditorToolBar* GetToolBarByCategory(
   WebTextEditorToolBarCategory category
)
C++/CLI
public:
WebTextEditorToolBar^ GetToolBarByCategory(
   WebTextEditorToolBarCategory category
)

Parameters

category

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBarArgs Class
WebTextEditorToolBarArgs Members
Overload List


GetToolBarByCategory(WebTextEditorToolBarCategory,String) Method

[image]
Intersoft WebTextEditor Documentation
GetToolBarByCategory(WebTextEditorToolBarCategory,String) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBarArgs Class > GetToolBarByCategory Method : GetToolBarByCategory(WebTextEditorToolBarCategory,String) Method

category
name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetToolBarByCategory( _
   ByVal category As WebTextEditorToolBarCategory, _
   ByVal name As System.String _
) As WebTextEditorToolBar
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBarArgs
Dim category As WebTextEditorToolBarCategory
Dim name As System.String
Dim value As WebTextEditorToolBar

value = instance.GetToolBarByCategory(category, name)
C#
public WebTextEditorToolBar GetToolBarByCategory(
   WebTextEditorToolBarCategory category,
   System.string name
)
Delphi
public function GetToolBarByCategory(
    category: WebTextEditorToolBarCategory;
    name: System.String
): WebTextEditorToolBar;
JScript
public function GetToolBarByCategory(
   category : WebTextEditorToolBarCategory,
   name : System.String
) : WebTextEditorToolBar;
Managed Extensions for C++
public: WebTextEditorToolBar* GetToolBarByCategory(
   WebTextEditorToolBarCategory category,
   System.string* name
)
C++/CLI
public:
WebTextEditorToolBar^ GetToolBarByCategory(
   WebTextEditorToolBarCategory category,
   System.String^ name
)

Parameters

category
name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBarArgs Class
WebTextEditorToolBarArgs Members
Overload List


WebTextEditorToolBarArgs Class Properties

[image]
Intersoft WebTextEditor Documentation
WebTextEditorToolBarArgs Class Properties
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorToolBarArgs Class

Glossary Item Box

For a list of all members of this type, see WebTextEditorToolBarArgs members.

Public Properties

 | Name | Description
Public Property | Cancel |
Public Property | FloatingToolBar |
Public Property | HTMLToolBar |
Public Property | PreviewToolBar |
Public Property | ToolBar |
Top

See Also

Reference

WebTextEditorToolBarArgs Class
ISNet.WebUI.WebTextEditor Namespace


Cancel Property

[image]
Intersoft WebTextEditor Documentation
Cancel Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBarArgs Class : Cancel Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property Cancel As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBarArgs
Dim value As System.Boolean

instance.Cancel = value

value = instance.Cancel
C#
public System.bool Cancel {get; set;}
Delphi
public read-write property Cancel: System.Boolean;
JScript
public function get,set Cancel : System.boolean
Managed Extensions for C++
public: __property System.bool get_Cancel();
public: __property void set_Cancel(
   System.bool value
);
C++/CLI
public:
property System.bool Cancel {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBarArgs Class
WebTextEditorToolBarArgs Members


FloatingToolBar Property

[image]
Intersoft WebTextEditor Documentation
FloatingToolBar Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBarArgs Class : FloatingToolBar Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property FloatingToolBar As WebTextEditorToolBarCollection
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBarArgs
Dim value As WebTextEditorToolBarCollection

value = instance.FloatingToolBar
C#
public WebTextEditorToolBarCollection FloatingToolBar {get;}
Delphi
public read-only property FloatingToolBar: WebTextEditorToolBarCollection;
JScript
public function get FloatingToolBar : WebTextEditorToolBarCollection
Managed Extensions for C++
public: __property WebTextEditorToolBarCollection* get_FloatingToolBar();
C++/CLI
public:
property WebTextEditorToolBarCollection^ FloatingToolBar {
   WebTextEditorToolBarCollection^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBarArgs Class
WebTextEditorToolBarArgs Members


HTMLToolBar Property

[image]
Intersoft WebTextEditor Documentation
HTMLToolBar Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBarArgs Class : HTMLToolBar Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property HTMLToolBar As WebTextEditorToolBarCollection
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBarArgs
Dim value As WebTextEditorToolBarCollection

value = instance.HTMLToolBar
C#
public WebTextEditorToolBarCollection HTMLToolBar {get;}
Delphi
public read-only property HTMLToolBar: WebTextEditorToolBarCollection;
JScript
public function get HTMLToolBar : WebTextEditorToolBarCollection
Managed Extensions for C++
public: __property WebTextEditorToolBarCollection* get_HTMLToolBar();
C++/CLI
public:
property WebTextEditorToolBarCollection^ HTMLToolBar {
   WebTextEditorToolBarCollection^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBarArgs Class
WebTextEditorToolBarArgs Members


PreviewToolBar Property

[image]
Intersoft WebTextEditor Documentation
PreviewToolBar Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBarArgs Class : PreviewToolBar Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property PreviewToolBar As WebTextEditorToolBarCollection
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBarArgs
Dim value As WebTextEditorToolBarCollection

value = instance.PreviewToolBar
C#
public WebTextEditorToolBarCollection PreviewToolBar {get;}
Delphi
public read-only property PreviewToolBar: WebTextEditorToolBarCollection;
JScript
public function get PreviewToolBar : WebTextEditorToolBarCollection
Managed Extensions for C++
public: __property WebTextEditorToolBarCollection* get_PreviewToolBar();
C++/CLI
public:
property WebTextEditorToolBarCollection^ PreviewToolBar {
   WebTextEditorToolBarCollection^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBarArgs Class
WebTextEditorToolBarArgs Members


ToolBar Property

[image]
Intersoft WebTextEditor Documentation
ToolBar Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBarArgs Class : ToolBar Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property ToolBar As WebTextEditorToolBarCollection
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBarArgs
Dim value As WebTextEditorToolBarCollection

value = instance.ToolBar
C#
public WebTextEditorToolBarCollection ToolBar {get;}
Delphi
public read-only property ToolBar: WebTextEditorToolBarCollection;
JScript
public function get ToolBar : WebTextEditorToolBarCollection
Managed Extensions for C++
public: __property WebTextEditorToolBarCollection* get_ToolBar();
C++/CLI
public:
property WebTextEditorToolBarCollection^ ToolBar {
   WebTextEditorToolBarCollection^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBarArgs Class
WebTextEditorToolBarArgs Members


WebTextEditorToolBarCollection Class

[image]
Intersoft WebTextEditor Documentation
WebTextEditorToolBarCollection Class
Members See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorToolBarCollection Class

Glossary Item Box

The data collection of ToolBar used by WebTextEditor.

Object Model

WebTextEditorToolBarCollection Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebTextEditorToolBarCollection
   Inherits ISNet.WebUI.ISGenericCollectionBase(Of WebTextEditorToolBar)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBarCollection
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebTextEditorToolBarCollection : ISNet.WebUI.ISGenericCollectionBase<WebTextEditorToolBar>
Delphi
public class WebTextEditorToolBarCollection = class(ISNet.WebUI.ISGenericCollectionBase)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebTextEditorToolBarCollection extends ISNet.WebUI.ISGenericCollectionBase
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebTextEditorToolBarCollection : public ISNet.WebUI.ISGenericCollectionBase<WebTextEditorToolBar>
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebTextEditorToolBarCollection : public ISNet.WebUI.ISGenericCollectionBase<WebTextEditorToolBar>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
ISNet.WebUI.ISCollectionBase<T>
ISNet.WebUI.ISGenericCollectionBase<T>
ISNet.WebUI.WebTextEditor.WebTextEditorToolBarCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBarCollection Members
ISNet.WebUI.WebTextEditor Namespace


WebTextEditorToolBarCollection Class Members

[image]
Intersoft WebTextEditor Documentation
WebTextEditorToolBarCollection Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorToolBarCollection Class

Glossary Item Box

The following tables list the members exposed by WebTextEditorToolBarCollection.

Public Constructors

 | Name | Description
Public Constructor | WebTextEditorToolBarCollection Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | All | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

Protected Properties

 | Name | Description
Protected Property | Items | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CreateNewItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorToolBar>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | GetNamedItem |
Public Method | GetObjectData | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | SerializerConstructor | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorToolBar>)
Public Method | SetParent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

Protected Methods

 | Name | Description
Protected Method | ClearItems | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorToolBar>)
Protected Method | CreateArray | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Protected Method | InsertItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorToolBar>)
Protected Method | RemoveItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorToolBar>)
Protected Method | SetItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorToolBar>)
Top

See Also

Reference

WebTextEditorToolBarCollection Class
ISNet.WebUI.WebTextEditor Namespace


WebTextEditorToolBarCollection Constructor

[image]
Intersoft WebTextEditor Documentation
WebTextEditorToolBarCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBarCollection Class : WebTextEditorToolBarCollection Constructor

Glossary Item Box

Overload List

Overload | Description
WebTextEditorToolBarCollection Constructor() |
WebTextEditorToolBarCollection Constructor(SerializationInfo,StreamingContext) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBarCollection Class
WebTextEditorToolBarCollection Members


WebTextEditorToolBarCollection Constructor()

[image]
Intersoft WebTextEditor Documentation
WebTextEditorToolBarCollection Constructor()
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBarCollection Class > WebTextEditorToolBarCollection Constructor : WebTextEditorToolBarCollection Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebTextEditorToolBarCollection()
C#
public WebTextEditorToolBarCollection()
Delphi
public WebTextEditorToolBarCollection();
JScript
public function WebTextEditorToolBarCollection();
Managed Extensions for C++
public: WebTextEditorToolBarCollection();
C++/CLI
public:
WebTextEditorToolBarCollection();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBarCollection Class
WebTextEditorToolBarCollection Members
Overload List


WebTextEditorToolBarCollection Constructor(SerializationInfo,StreamingContext)

[image]
Intersoft WebTextEditor Documentation
WebTextEditorToolBarCollection Constructor(SerializationInfo,StreamingContext)
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBarCollection Class > WebTextEditorToolBarCollection Constructor : WebTextEditorToolBarCollection Constructor(SerializationInfo,StreamingContext)

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

Dim instance As New WebTextEditorToolBarCollection(info, context)
C#
protected WebTextEditorToolBarCollection(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
protected WebTextEditorToolBarCollection(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
protected function WebTextEditorToolBarCollection(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
protected: WebTextEditorToolBarCollection(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
protected:
WebTextEditorToolBarCollection(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBarCollection Class
WebTextEditorToolBarCollection Members
Overload List


WebTextEditorToolBarCollection Class Methods

[image]
Intersoft WebTextEditor Documentation
WebTextEditorToolBarCollection Class Methods
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorToolBarCollection Class

Glossary Item Box

For a list of all members of this type, see WebTextEditorToolBarCollection members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CreateNewItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorToolBar>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | GetNamedItem |
Public Method | GetObjectData | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | SerializerConstructor | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorToolBar>)
Public Method | SetParent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

Protected Methods

 | Name | Description
Protected Method | ClearItems | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorToolBar>)
Protected Method | CreateArray | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Protected Method | InsertItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorToolBar>)
Protected Method | RemoveItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorToolBar>)
Protected Method | SetItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorToolBar>)
Top

See Also

Reference

WebTextEditorToolBarCollection Class
ISNet.WebUI.WebTextEditor Namespace


GetNamedItem Method

[image]
Intersoft WebTextEditor Documentation
GetNamedItem Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBarCollection Class : GetNamedItem Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shadows Function GetNamedItem( _
   ByVal name As System.String _
) As WebTextEditorToolBar
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBarCollection
Dim name As System.String
Dim value As WebTextEditorToolBar

value = instance.GetNamedItem(name)
C#
public new WebTextEditorToolBar GetNamedItem(
   System.string name
)
Delphi
public function GetNamedItem(
    name: System.String
): WebTextEditorToolBar;
JScript
public hide function GetNamedItem(
   name : System.String
) : WebTextEditorToolBar;
Managed Extensions for C++
public: new WebTextEditorToolBar* GetNamedItem(
   System.string* name
)
C++/CLI
public:
new WebTextEditorToolBar^ GetNamedItem(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBarCollection Class
WebTextEditorToolBarCollection Members


WebTextEditorToolBarSettings Class

[image]
Intersoft WebTextEditor Documentation
WebTextEditorToolBarSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorToolBarSettings Class

Glossary Item Box

A collection of WebTextEditor's ToolBar settings.

Object Model

WebTextEditorToolBarSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebTextEditorToolBarSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBarSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebTextEditorToolBarSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebTextEditorToolBarSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebTextEditorToolBarSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebTextEditorToolBarSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebTextEditorToolBarSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebTextEditor.WebTextEditorToolBarSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBarSettings Members
ISNet.WebUI.WebTextEditor Namespace


WebTextEditorToolBarSettings Class Members

[image]
Intersoft WebTextEditor Documentation
WebTextEditorToolBarSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorToolBarSettings Class

Glossary Item Box

The following tables list the members exposed by WebTextEditorToolBarSettings.

Public Constructors

 | Name | Description
Public Constructor | WebTextEditorToolBarSettings Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | AllowAttachFile | Specifies whether or not Attach File command should be displayed in main toolbar.
Public Property | CommandHeight | Specifies the command height of the main toolbar.
Public Property | EnableFloatingToolBar | Specifies whether or not the floating toolbar is enabled.
Public Property | FontNames | Gets or sets the font names used as the collection in Font combo.
Public Property | FontSizes | Gets or sets the font sizes used as the collection in Font combo.
Public Property | Heading | Gets or sets the headings used as the collection in Font combo.
Public Property | Height | Specifies the height of the main toolbar.
Public Property | LinkOptions | Gets or sets the link options used as the combo collection in Hyperlink callout. The list should be set as comma separated value.
Public Property | SerializationMode | Gets or sets the serialization mode used in toolbar.
Public Property | SynchronizeCommandLatency | Gets or sets synchronize tool command latency interval (in milisecond).
Public Property | ToolBarMode | Specifies the toolbar mode in text editor.
Public Property | ToolBarXMLFile | Specifies the xml file that contains custom toolbar structure. This property will be used when the ToolBarMode is set to Custom.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

Protected Methods

 | Name | Description
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | IsInSerializationContext | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebTextEditorToolBarSettings Class
ISNet.WebUI.WebTextEditor Namespace


WebTextEditorToolBarSettings Constructor

[image]
Intersoft WebTextEditor Documentation
WebTextEditorToolBarSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBarSettings Class : WebTextEditorToolBarSettings Constructor

Glossary Item Box

Overload List

Overload | Description
WebTextEditorToolBarSettings Constructor() |
WebTextEditorToolBarSettings Constructor(SerializationInfo,StreamingContext) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBarSettings Class
WebTextEditorToolBarSettings Members


WebTextEditorToolBarSettings Constructor()

[image]
Intersoft WebTextEditor Documentation
WebTextEditorToolBarSettings Constructor()
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBarSettings Class > WebTextEditorToolBarSettings Constructor : WebTextEditorToolBarSettings Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebTextEditorToolBarSettings()
C#
public WebTextEditorToolBarSettings()
Delphi
public WebTextEditorToolBarSettings();
JScript
public function WebTextEditorToolBarSettings();
Managed Extensions for C++
public: WebTextEditorToolBarSettings();
C++/CLI
public:
WebTextEditorToolBarSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBarSettings Class
WebTextEditorToolBarSettings Members
Overload List


WebTextEditorToolBarSettings Constructor(SerializationInfo,StreamingContext)

[image]
Intersoft WebTextEditor Documentation
WebTextEditorToolBarSettings Constructor(SerializationInfo,StreamingContext)
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBarSettings Class > WebTextEditorToolBarSettings Constructor : WebTextEditorToolBarSettings Constructor(SerializationInfo,StreamingContext)

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

Dim instance As New WebTextEditorToolBarSettings(info, context)
C#
protected WebTextEditorToolBarSettings(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
protected WebTextEditorToolBarSettings(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
protected function WebTextEditorToolBarSettings(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
protected: WebTextEditorToolBarSettings(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
protected:
WebTextEditorToolBarSettings(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBarSettings Class
WebTextEditorToolBarSettings Members
Overload List


WebTextEditorToolBarSettings Class Methods

[image]
Intersoft WebTextEditor Documentation
WebTextEditorToolBarSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorToolBarSettings Class

Glossary Item Box

For a list of all members of this type, see WebTextEditorToolBarSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

Protected Methods

 | Name | Description
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | IsInSerializationContext | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebTextEditorToolBarSettings Class
ISNet.WebUI.WebTextEditor Namespace


GetObjectData Method

[image]
Intersoft WebTextEditor Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBarSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBarSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBarSettings Class
WebTextEditorToolBarSettings Members


WebTextEditorToolBarSettings Class Properties

[image]
Intersoft WebTextEditor Documentation
WebTextEditorToolBarSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorToolBarSettings Class

Glossary Item Box

For a list of all members of this type, see WebTextEditorToolBarSettings members.

Public Properties

 | Name | Description
Public Property | AllowAttachFile | Specifies whether or not Attach File command should be displayed in main toolbar.
Public Property | CommandHeight | Specifies the command height of the main toolbar.
Public Property | EnableFloatingToolBar | Specifies whether or not the floating toolbar is enabled.
Public Property | FontNames | Gets or sets the font names used as the collection in Font combo.
Public Property | FontSizes | Gets or sets the font sizes used as the collection in Font combo.
Public Property | Heading | Gets or sets the headings used as the collection in Font combo.
Public Property | Height | Specifies the height of the main toolbar.
Public Property | LinkOptions | Gets or sets the link options used as the combo collection in Hyperlink callout. The list should be set as comma separated value.
Public Property | SerializationMode | Gets or sets the serialization mode used in toolbar.
Public Property | SynchronizeCommandLatency | Gets or sets synchronize tool command latency interval (in milisecond).
Public Property | ToolBarMode | Specifies the toolbar mode in text editor.
Public Property | ToolBarXMLFile | Specifies the xml file that contains custom toolbar structure. This property will be used when the ToolBarMode is set to Custom.
Top

See Also

Reference

WebTextEditorToolBarSettings Class
ISNet.WebUI.WebTextEditor Namespace


AllowAttachFile Property

[image]
Intersoft WebTextEditor Documentation
AllowAttachFile Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBarSettings Class : AllowAttachFile Property

Glossary Item Box

Specifies whether or not Attach File command should be displayed in main toolbar.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies whether or not Attach File command should be displayed in main toolbar.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property AllowAttachFile As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBarSettings
Dim value As System.Boolean

instance.AllowAttachFile = value

value = instance.AllowAttachFile
C#
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not Attach File command should be displayed in main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.bool AllowAttachFile {get; set;}
Delphi
public read-write property AllowAttachFile: System.Boolean;
JScript
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether or not Attach File command should be displayed in main toolbar.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set AllowAttachFile : System.boolean
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not Attach File command should be displayed in main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.bool get_AllowAttachFile();
public: __property void set_AllowAttachFile(
   System.bool value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not Attach File command should be displayed in main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.bool AllowAttachFile {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBarSettings Class
WebTextEditorToolBarSettings Members


CommandHeight Property

[image]
Intersoft WebTextEditor Documentation
CommandHeight Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBarSettings Class : CommandHeight Property

Glossary Item Box

Specifies the command height of the main toolbar.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the command height of the main toolbar.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property CommandHeight As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBarSettings
Dim value As System.Integer

instance.CommandHeight = value

value = instance.CommandHeight
C#
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the command height of the main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.int CommandHeight {get; set;}
Delphi
public read-write property CommandHeight: System.Integer;
JScript
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the command height of the main toolbar.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set CommandHeight : System.int
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the command height of the main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.int get_CommandHeight();
public: __property void set_CommandHeight(
   System.int value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the command height of the main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.int CommandHeight {
   System.int get();
   void set (    System.int value);
}

Property Value

The default value is 20px.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBarSettings Class
WebTextEditorToolBarSettings Members


EnableFloatingToolBar Property

[image]
Intersoft WebTextEditor Documentation
EnableFloatingToolBar Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBarSettings Class : EnableFloatingToolBar Property

Glossary Item Box

Specifies whether or not the floating toolbar is enabled.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies whether or not the floating toolbar is enabled.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property EnableFloatingToolBar As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBarSettings
Dim value As System.Boolean

instance.EnableFloatingToolBar = value

value = instance.EnableFloatingToolBar
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not the floating toolbar is enabled.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.bool EnableFloatingToolBar {get; set;}
Delphi
public read-write property EnableFloatingToolBar: System.Boolean;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether or not the floating toolbar is enabled.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set EnableFloatingToolBar : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not the floating toolbar is enabled.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.bool get_EnableFloatingToolBar();
public: __property void set_EnableFloatingToolBar(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not the floating toolbar is enabled.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.bool EnableFloatingToolBar {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is True.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBarSettings Class
WebTextEditorToolBarSettings Members


FontNames Property

[image]
Intersoft WebTextEditor Documentation
FontNames Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBarSettings Class : FontNames Property

Glossary Item Box

Gets or sets the font names used as the collection in Font combo.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Layout")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the font names used as the collection in combo.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property FontNames As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBarSettings
Dim value As System.String

instance.FontNames = value

value = instance.FontNames
C#
[System.ComponentModel.CategoryAttribute("Layout")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the font names used as the collection in combo.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string FontNames {get; set;}
Delphi
public read-write property FontNames: System.String;
JScript
System.ComponentModel.CategoryAttribute("Layout")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the font names used as the collection in combo.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set FontNames : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Layout")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the font names used as the collection in combo.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_FontNames();
public: __property void set_FontNames(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Layout")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the font names used as the collection in combo.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ FontNames {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBarSettings Class
WebTextEditorToolBarSettings Members


FontSizes Property

[image]
Intersoft WebTextEditor Documentation
FontSizes Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBarSettings Class : FontSizes Property

Glossary Item Box

Gets or sets the font sizes used as the collection in Font combo.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Layout")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the font sizes used as the collection in combo.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property FontSizes As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBarSettings
Dim value As System.String

instance.FontSizes = value

value = instance.FontSizes
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Layout")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the font sizes used as the collection in combo.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string FontSizes {get; set;}
Delphi
public read-write property FontSizes: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Layout")
System.ComponentModel.DescriptionAttribute("Gets or sets the font sizes used as the collection in combo.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set FontSizes : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Layout")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the font sizes used as the collection in combo.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_FontSizes();
public: __property void set_FontSizes(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Layout")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the font sizes used as the collection in combo.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ FontSizes {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBarSettings Class
WebTextEditorToolBarSettings Members


Heading Property

[image]
Intersoft WebTextEditor Documentation
Heading Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBarSettings Class : Heading Property

Glossary Item Box

Gets or sets the headings used as the collection in Font combo.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Layout")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets the headings used as the collection in combo.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property Heading As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBarSettings
Dim value As System.String

instance.Heading = value

value = instance.Heading
C#
[System.ComponentModel.CategoryAttribute("Layout")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the headings used as the collection in combo.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string Heading {get; set;}
Delphi
public read-write property Heading: System.String;
JScript
System.ComponentModel.CategoryAttribute("Layout")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the headings used as the collection in combo.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set Heading : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Layout")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the headings used as the collection in combo.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_Heading();
public: __property void set_Heading(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Layout")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets the headings used as the collection in combo.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ Heading {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBarSettings Class
WebTextEditorToolBarSettings Members


Height Property

[image]
Intersoft WebTextEditor Documentation
Height Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBarSettings Class : Height Property

Glossary Item Box

Specifies the height of the main toolbar.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the height of the main toolbar.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Height As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBarSettings
Dim value As System.Integer

instance.Height = value

value = instance.Height
C#
[System.ComponentModel.DescriptionAttribute("Specifies the height of the main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public System.int Height {get; set;}
Delphi
public read-write property Height: System.Integer;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the height of the main toolbar.")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DefaultValueAttribute()
public function get,set Height : System.int
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the height of the main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.int get_Height();
public: __property void set_Height(
   System.int value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the height of the main toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.int Height {
   System.int get();
   void set (    System.int value);
}

Property Value

The default value is 24px.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBarSettings Class
WebTextEditorToolBarSettings Members


LinkOptions Property

[image]
Intersoft WebTextEditor Documentation
LinkOptions Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBarSettings Class : LinkOptions Property

Glossary Item Box

Gets or sets the link options used as the combo collection in Hyperlink callout. The list should be set as comma separated value.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Layout")>
<System.ComponentModel.DescriptionAttribute("Gets or sets the link options used as the combo collection in Hyperlink callout. The list should be set as comma separated value.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property LinkOptions As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBarSettings
Dim value As System.String

instance.LinkOptions = value

value = instance.LinkOptions
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Layout")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the link options used as the combo collection in Hyperlink callout. The list should be set as comma separated value.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.string LinkOptions {get; set;}
Delphi
public read-write property LinkOptions: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Layout")
System.ComponentModel.DescriptionAttribute("Gets or sets the link options used as the combo collection in Hyperlink callout. The list should be set as comma separated value.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set LinkOptions : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Layout")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the link options used as the combo collection in Hyperlink callout. The list should be set as comma separated value.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.string* get_LinkOptions();
public: __property void set_LinkOptions(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Layout")]
[System.ComponentModel.DescriptionAttribute("Gets or sets the link options used as the combo collection in Hyperlink callout. The list should be set as comma separated value.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.String^ LinkOptions {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBarSettings Class
WebTextEditorToolBarSettings Members


SerializationMode Property

[image]
Intersoft WebTextEditor Documentation
SerializationMode Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBarSettings Class : SerializationMode Property

Glossary Item Box

Gets or sets the serialization mode used in toolbar.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the serialization mode used in toolbar.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property SerializationMode As WebTextEditorSerializationMode
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBarSettings
Dim value As WebTextEditorSerializationMode

instance.SerializationMode = value

value = instance.SerializationMode
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the serialization mode used in toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
public WebTextEditorSerializationMode SerializationMode {get; set;}
Delphi
public read-write property SerializationMode: WebTextEditorSerializationMode;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the serialization mode used in toolbar.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set SerializationMode : WebTextEditorSerializationMode
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the serialization mode used in toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property WebTextEditorSerializationMode get_SerializationMode();
public: __property void set_SerializationMode(
   WebTextEditorSerializationMode value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the serialization mode used in toolbar.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property WebTextEditorSerializationMode SerializationMode {
   WebTextEditorSerializationMode get();
   void set (    WebTextEditorSerializationMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBarSettings Class
WebTextEditorToolBarSettings Members


SynchronizeCommandLatency Property

[image]
Intersoft WebTextEditor Documentation
SynchronizeCommandLatency Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBarSettings Class : SynchronizeCommandLatency Property

Glossary Item Box

Gets or sets synchronize tool command latency interval (in milisecond).

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Gets or sets synchronize tool command latency interval (in milisecond).")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property SynchronizeCommandLatency As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBarSettings
Dim value As System.Integer

instance.SynchronizeCommandLatency = value

value = instance.SynchronizeCommandLatency
C#
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets synchronize tool command latency interval (in milisecond).")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.int SynchronizeCommandLatency {get; set;}
Delphi
public read-write property SynchronizeCommandLatency: System.Integer;
JScript
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets synchronize tool command latency interval (in milisecond).")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set SynchronizeCommandLatency : System.int
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets synchronize tool command latency interval (in milisecond).")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.int get_SynchronizeCommandLatency();
public: __property void set_SynchronizeCommandLatency(
   System.int value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Gets or sets synchronize tool command latency interval (in milisecond).")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.int SynchronizeCommandLatency {
   System.int get();
   void set (    System.int value);
}

Property Value

The default value is 500ms.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBarSettings Class
WebTextEditorToolBarSettings Members


ToolBarMode Property

[image]
Intersoft WebTextEditor Documentation
ToolBarMode Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBarSettings Class : ToolBarMode Property

Glossary Item Box

Specifies the toolbar mode in text editor.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the toolbar mode in text editor.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property ToolBarMode As WebTextEditorToolBarMode
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBarSettings
Dim value As WebTextEditorToolBarMode

instance.ToolBarMode = value

value = instance.ToolBarMode
C#
[System.ComponentModel.DescriptionAttribute("Specifies the toolbar mode in text editor.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
public WebTextEditorToolBarMode ToolBarMode {get; set;}
Delphi
public read-write property ToolBarMode: WebTextEditorToolBarMode;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the toolbar mode in text editor.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set ToolBarMode : WebTextEditorToolBarMode
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the toolbar mode in text editor.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property WebTextEditorToolBarMode get_ToolBarMode();
public: __property void set_ToolBarMode(
   WebTextEditorToolBarMode value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the toolbar mode in text editor.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property WebTextEditorToolBarMode ToolBarMode {
   WebTextEditorToolBarMode get();
   void set (    WebTextEditorToolBarMode value);
}

Property Value

The default value is Standard.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBarSettings Class
WebTextEditorToolBarSettings Members


ToolBarXMLFile Property

[image]
Intersoft WebTextEditor Documentation
ToolBarXMLFile Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBarSettings Class : ToolBarXMLFile Property

Glossary Item Box

Specifies the xml file that contains custom toolbar structure. This property will be used when the ToolBarMode is set to Custom.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the xml file that contains custom toolbar structure. This property will be used when the ToolBarMode is set to Custom.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property ToolBarXMLFile As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBarSettings
Dim value As System.String

instance.ToolBarXMLFile = value

value = instance.ToolBarXMLFile
C#
[System.ComponentModel.DescriptionAttribute("Specifies the xml file that contains custom toolbar structure. This property will be used when the ToolBarMode is set to Custom.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.string ToolBarXMLFile {get; set;}
Delphi
public read-write property ToolBarXMLFile: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the xml file that contains custom toolbar structure. This property will be used when the ToolBarMode is set to Custom.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set ToolBarXMLFile : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the xml file that contains custom toolbar structure. This property will be used when the ToolBarMode is set to Custom.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_ToolBarXMLFile();
public: __property void set_ToolBarXMLFile(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the xml file that contains custom toolbar structure. This property will be used when the ToolBarMode is set to Custom.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ ToolBarXMLFile {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBarSettings Class
WebTextEditorToolBarSettings Members


WebTextEditorToolCommand Class

[image]
Intersoft WebTextEditor Documentation
WebTextEditorToolCommand Class
Members See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorToolCommand Class

Glossary Item Box

A collection of members in WebTextEditor's ToolBar command.

Object Model

WebTextEditorToolCommand Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebTextEditorToolCommand
   Inherits ISNet.WebUI.NamedObjectBase2
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolCommand
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebTextEditorToolCommand : ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
Delphi
public class WebTextEditorToolCommand = class(ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebTextEditorToolCommand extends ISNet.WebUI.NamedObjectBase2 implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebTextEditorToolCommand : public ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebTextEditorToolCommand : public ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.NamedObjectBase2
ISNet.WebUI.WebTextEditor.WebTextEditorToolCommand

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolCommand Members
ISNet.WebUI.WebTextEditor Namespace


WebTextEditorToolCommand Class Members

[image]
Intersoft WebTextEditor Documentation
WebTextEditorToolCommand Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorToolCommand Class

Glossary Item Box

The following tables list the members exposed by WebTextEditorToolCommand.

Public Constructors

 | Name | Description
Public Constructor | WebTextEditorToolCommand Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Collection | (Inherited from ISNet.WebUI.NamedObjectBase2)
Public Property | CommandType |
Public Property | DisplayMode |
Public Property | Image |
Public Property | Items |
Public Property | Name |
Public Property | Text |
Public Property | ToggleGroupName |
Public Property | Type |
Public Property | Width |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

Protected Methods

 | Name | Description
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | IsInSerializationContext | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | OnItemAdd | (Inherited from ISNet.WebUI.NamedObjectBase2)
Protected Method | OnItemRemove | (Inherited from ISNet.WebUI.NamedObjectBase2)
Top

See Also

Reference

WebTextEditorToolCommand Class
ISNet.WebUI.WebTextEditor Namespace


WebTextEditorToolCommand Constructor

[image]
Intersoft WebTextEditor Documentation
WebTextEditorToolCommand Constructor
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolCommand Class : WebTextEditorToolCommand Constructor

Glossary Item Box

Overload List

Overload | Description
WebTextEditorToolCommand Constructor() |
WebTextEditorToolCommand Constructor(SerializationInfo,StreamingContext) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolCommand Class
WebTextEditorToolCommand Members


WebTextEditorToolCommand Constructor()

[image]
Intersoft WebTextEditor Documentation
WebTextEditorToolCommand Constructor()
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolCommand Class > WebTextEditorToolCommand Constructor : WebTextEditorToolCommand Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebTextEditorToolCommand()
C#
public WebTextEditorToolCommand()
Delphi
public WebTextEditorToolCommand();
JScript
public function WebTextEditorToolCommand();
Managed Extensions for C++
public: WebTextEditorToolCommand();
C++/CLI
public:
WebTextEditorToolCommand();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolCommand Class
WebTextEditorToolCommand Members
Overload List


WebTextEditorToolCommand Constructor(SerializationInfo,StreamingContext)

[image]
Intersoft WebTextEditor Documentation
WebTextEditorToolCommand Constructor(SerializationInfo,StreamingContext)
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolCommand Class > WebTextEditorToolCommand Constructor : WebTextEditorToolCommand Constructor(SerializationInfo,StreamingContext)

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

Dim instance As New WebTextEditorToolCommand(info, context)
C#
protected WebTextEditorToolCommand(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
protected WebTextEditorToolCommand(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
protected function WebTextEditorToolCommand(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
protected: WebTextEditorToolCommand(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
protected:
WebTextEditorToolCommand(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolCommand Class
WebTextEditorToolCommand Members
Overload List


WebTextEditorToolCommand Class Methods

[image]
Intersoft WebTextEditor Documentation
WebTextEditorToolCommand Class Methods
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorToolCommand Class

Glossary Item Box

For a list of all members of this type, see WebTextEditorToolCommand members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

Protected Methods

 | Name | Description
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | IsInSerializationContext | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | OnItemAdd | (Inherited from ISNet.WebUI.NamedObjectBase2)
Protected Method | OnItemRemove | (Inherited from ISNet.WebUI.NamedObjectBase2)
Top

See Also

Reference

WebTextEditorToolCommand Class
ISNet.WebUI.WebTextEditor Namespace


GetObjectData Method

[image]
Intersoft WebTextEditor Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolCommand Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolCommand
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolCommand Class
WebTextEditorToolCommand Members


WebTextEditorToolCommand Class Properties

[image]
Intersoft WebTextEditor Documentation
WebTextEditorToolCommand Class Properties
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorToolCommand Class

Glossary Item Box

For a list of all members of this type, see WebTextEditorToolCommand members.

Public Properties

 | Name | Description
Public Property | Collection | (Inherited from ISNet.WebUI.NamedObjectBase2)
Public Property | CommandType |
Public Property | DisplayMode |
Public Property | Image |
Public Property | Items |
Public Property | Name |
Public Property | Text |
Public Property | ToggleGroupName |
Public Property | Type |
Public Property | Width |
Top

See Also

Reference

WebTextEditorToolCommand Class
ISNet.WebUI.WebTextEditor Namespace


CommandType Property

[image]
Intersoft WebTextEditor Documentation
CommandType Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolCommand Class : CommandType Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the editor type of the tool command.")>
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property CommandType As WebTextEditorToolCommandType
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolCommand
Dim value As WebTextEditorToolCommandType

instance.CommandType = value

value = instance.CommandType
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the editor type of the tool command.")]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public WebTextEditorToolCommandType CommandType {get; set;}
Delphi
public read-write property CommandType: WebTextEditorToolCommandType;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the editor type of the tool command.")
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set CommandType : WebTextEditorToolCommandType
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the editor type of the tool command.")]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property WebTextEditorToolCommandType get_CommandType();
public: __property void set_CommandType(
   WebTextEditorToolCommandType value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the editor type of the tool command.")]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property WebTextEditorToolCommandType CommandType {
   WebTextEditorToolCommandType get();
   void set (    WebTextEditorToolCommandType value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolCommand Class
WebTextEditorToolCommand Members


DisplayMode Property

[image]
Intersoft WebTextEditor Documentation
DisplayMode Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolCommand Class : DisplayMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the display mode of the tool command.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property DisplayMode As WebTextEditorToolBarCommandDisplayMode
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolCommand
Dim value As WebTextEditorToolBarCommandDisplayMode

instance.DisplayMode = value

value = instance.DisplayMode
C#
[System.ComponentModel.DescriptionAttribute("Specifies the display mode of the tool command.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public WebTextEditorToolBarCommandDisplayMode DisplayMode {get; set;}
Delphi
public read-write property DisplayMode: WebTextEditorToolBarCommandDisplayMode;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the display mode of the tool command.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set DisplayMode : WebTextEditorToolBarCommandDisplayMode
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the display mode of the tool command.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property WebTextEditorToolBarCommandDisplayMode get_DisplayMode();
public: __property void set_DisplayMode(
   WebTextEditorToolBarCommandDisplayMode value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the display mode of the tool command.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property WebTextEditorToolBarCommandDisplayMode DisplayMode {
   WebTextEditorToolBarCommandDisplayMode get();
   void set (    WebTextEditorToolBarCommandDisplayMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolCommand Class
WebTextEditorToolCommand Members


Image Property

[image]
Intersoft WebTextEditor Documentation
Image Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolCommand Class : Image Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("Specifies the image path of the tool command.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property Image As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolCommand
Dim value As System.String

instance.Image = value

value = instance.Image
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Specifies the image path of the tool command.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string Image {get; set;}
Delphi
public read-write property Image: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("Specifies the image path of the tool command.")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set Image : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Specifies the image path of the tool command.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_Image();
public: __property void set_Image(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Specifies the image path of the tool command.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ Image {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolCommand Class
WebTextEditorToolCommand Members


Items Property

[image]
Intersoft WebTextEditor Documentation
Items Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolCommand Class : Items Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebTextEditor, Version=1.0.1000.9, Culture=neutral, PublicKeyToken=b1f2a8511635667a")>
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DescriptionAttribute("Specifies the tool item collection.")>
<ISNet.Serialization.BinarySerializableAttribute(False)>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<ISNet.Serialization.XmlSerializableAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Items As WebTextEditorToolItemCollection
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolCommand
Dim value As WebTextEditorToolItemCollection

instance.Items = value

value = instance.Items
C#
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebTextEditor, Version=1.0.1000.9, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DescriptionAttribute("Specifies the tool item collection.")]
[ISNet.Serialization.BinarySerializableAttribute(false)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public WebTextEditorToolItemCollection Items {get; set;}
Delphi
public read-write property Items: WebTextEditorToolItemCollection;
JScript
System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebTextEditor, Version=1.0.1000.9, Culture=neutral, PublicKeyToken=b1f2a8511635667a")
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the tool item collection.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set Items : WebTextEditorToolItemCollection
Managed Extensions for C++
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebTextEditor, Version=1.0.1000.9, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DescriptionAttribute("Specifies the tool item collection.")]
[ISNet.Serialization.BinarySerializableAttribute(false)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property WebTextEditorToolItemCollection* get_Items();
public: __property void set_Items(
   WebTextEditorToolItemCollection* value
);
C++/CLI
[System.ComponentModel.EditorAttribute(EditorBaseTypeName="System.Drawing.Design.UITypeEditor, System.Drawing, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a", EditorTypeName="., ISNet.WebUI.WebTextEditor, Version=1.0.1000.9, Culture=neutral, PublicKeyToken=b1f2a8511635667a")]
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DescriptionAttribute("Specifies the tool item collection.")]
[ISNet.Serialization.BinarySerializableAttribute(false)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[ISNet.Serialization.XmlSerializableAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property WebTextEditorToolItemCollection^ Items {
   WebTextEditorToolItemCollection^ get();
   void set (    WebTextEditorToolItemCollection^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolCommand Class
WebTextEditorToolCommand Members


Name Property

[image]
Intersoft WebTextEditor Documentation
Name Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolCommand Class : Name Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("Specifies the name of the tool command.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.BrowsableAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Shadows Property Name As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolCommand
Dim value As System.String

instance.Name = value

value = instance.Name
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Specifies the name of the tool command.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BrowsableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public new System.string Name {get; set;}
Delphi
public read-write property Name: System.String;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("Specifies the name of the tool command.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.BrowsableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public hide function get,set Name : System.String
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Specifies the name of the tool command.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BrowsableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property new System.string* get_Name();
public: __property new void set_Name(
   System.string* value
);
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Specifies the name of the tool command.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BrowsableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
new property System.String^ Name {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolCommand Class
WebTextEditorToolCommand Members


Text Property

[image]
Intersoft WebTextEditor Documentation
Text Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolCommand Class : Text Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DescriptionAttribute("Specifies the text of the tool command.")>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property Text As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolCommand
Dim value As System.String

instance.Text = value

value = instance.Text
C#
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Specifies the text of the tool command.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.string Text {get; set;}
Delphi
public read-write property Text: System.String;
JScript
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DescriptionAttribute("Specifies the text of the tool command.")
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set Text : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Specifies the text of the tool command.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.string* get_Text();
public: __property void set_Text(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DescriptionAttribute("Specifies the text of the tool command.")]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.String^ Text {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolCommand Class
WebTextEditorToolCommand Members


ToggleGroupName Property

[image]
Intersoft WebTextEditor Documentation
ToggleGroupName Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolCommand Class : ToggleGroupName Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the toggle group name of the tool command.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property ToggleGroupName As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolCommand
Dim value As System.String

instance.ToggleGroupName = value

value = instance.ToggleGroupName
C#
[System.ComponentModel.DescriptionAttribute("Specifies the toggle group name of the tool command.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public System.string ToggleGroupName {get; set;}
Delphi
public read-write property ToggleGroupName: System.String;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the toggle group name of the tool command.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get,set ToggleGroupName : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the toggle group name of the tool command.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property System.string* get_ToggleGroupName();
public: __property void set_ToggleGroupName(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the toggle group name of the tool command.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property System.String^ ToggleGroupName {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolCommand Class
WebTextEditorToolCommand Members


Type Property

[image]
Intersoft WebTextEditor Documentation
Type Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolCommand Class : Type Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("ToolBar")>
<System.ComponentModel.DescriptionAttribute("Specifies the type of the tool command.")>
<System.ComponentModel.BrowsableAttribute(False)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property Type As WebTextEditorToolBarCommandType
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolCommand
Dim value As WebTextEditorToolBarCommandType

instance.Type = value

value = instance.Type
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("ToolBar")]
[System.ComponentModel.DescriptionAttribute("Specifies the type of the tool command.")]
[System.ComponentModel.BrowsableAttribute(false)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public WebTextEditorToolBarCommandType Type {get; set;}
Delphi
public read-write property Type: WebTextEditorToolBarCommandType;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("ToolBar")
System.ComponentModel.DescriptionAttribute("Specifies the type of the tool command.")
System.ComponentModel.BrowsableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set Type : WebTextEditorToolBarCommandType
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("ToolBar")]
[System.ComponentModel.DescriptionAttribute("Specifies the type of the tool command.")]
[System.ComponentModel.BrowsableAttribute(false)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property WebTextEditorToolBarCommandType get_Type();
public: __property void set_Type(
   WebTextEditorToolBarCommandType value
);
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("ToolBar")]
[System.ComponentModel.DescriptionAttribute("Specifies the type of the tool command.")]
[System.ComponentModel.BrowsableAttribute(false)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property WebTextEditorToolBarCommandType Type {
   WebTextEditorToolBarCommandType get();
   void set (    WebTextEditorToolBarCommandType value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolCommand Class
WebTextEditorToolCommand Members


Width Property

[image]
Intersoft WebTextEditor Documentation
Width Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolCommand Class : Width Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DescriptionAttribute("Specifies the width of the tool command.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property Width As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolCommand
Dim value As System.Integer

instance.Width = value

value = instance.Width
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DescriptionAttribute("Specifies the width of the tool command.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public System.int Width {get; set;}
Delphi
public read-write property Width: System.Integer;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the width of the tool command.")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set Width : System.int
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DescriptionAttribute("Specifies the width of the tool command.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property System.int get_Width();
public: __property void set_Width(
   System.int value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DescriptionAttribute("Specifies the width of the tool command.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property System.int Width {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolCommand Class
WebTextEditorToolCommand Members


WebTextEditorToolCommandCollection Class

[image]
Intersoft WebTextEditor Documentation
WebTextEditorToolCommandCollection Class
Members See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorToolCommandCollection Class

Glossary Item Box

The data collection of ToolBar's command used by WebTextEditor.

Object Model

WebTextEditorToolCommandCollection Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebTextEditorToolCommandCollection
   Inherits ISNet.WebUI.ISGenericCollectionBase(Of WebTextEditorToolCommand)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolCommandCollection
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebTextEditorToolCommandCollection : ISNet.WebUI.ISGenericCollectionBase<WebTextEditorToolCommand>
Delphi
public class WebTextEditorToolCommandCollection = class(ISNet.WebUI.ISGenericCollectionBase)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebTextEditorToolCommandCollection extends ISNet.WebUI.ISGenericCollectionBase
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebTextEditorToolCommandCollection : public ISNet.WebUI.ISGenericCollectionBase<WebTextEditorToolCommand>
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebTextEditorToolCommandCollection : public ISNet.WebUI.ISGenericCollectionBase<WebTextEditorToolCommand>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
ISNet.WebUI.ISCollectionBase<T>
ISNet.WebUI.ISGenericCollectionBase<T>
ISNet.WebUI.WebTextEditor.WebTextEditorToolCommandCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolCommandCollection Members
ISNet.WebUI.WebTextEditor Namespace


WebTextEditorToolCommandCollection Class Members

[image]
Intersoft WebTextEditor Documentation
WebTextEditorToolCommandCollection Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorToolCommandCollection Class

Glossary Item Box

The following tables list the members exposed by WebTextEditorToolCommandCollection.

Public Constructors

 | Name | Description
Public Constructor | WebTextEditorToolCommandCollection Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | All | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

Protected Properties

 | Name | Description
Protected Property | Items | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CreateNewItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorToolCommand>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | GetNamedItem |
Public Method | GetObjectData | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | SerializerConstructor | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorToolCommand>)
Public Method | SetParent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

Protected Methods

 | Name | Description
Protected Method | ClearItems | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorToolCommand>)
Protected Method | CreateArray | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Protected Method | InsertItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorToolCommand>)
Protected Method | RemoveItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorToolCommand>)
Protected Method | SetItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorToolCommand>)
Top

See Also

Reference

WebTextEditorToolCommandCollection Class
ISNet.WebUI.WebTextEditor Namespace


WebTextEditorToolCommandCollection Constructor

[image]
Intersoft WebTextEditor Documentation
WebTextEditorToolCommandCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolCommandCollection Class : WebTextEditorToolCommandCollection Constructor

Glossary Item Box

Overload List

Overload | Description
WebTextEditorToolCommandCollection Constructor() |
WebTextEditorToolCommandCollection Constructor(SerializationInfo,StreamingContext) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolCommandCollection Class
WebTextEditorToolCommandCollection Members


WebTextEditorToolCommandCollection Constructor()

[image]
Intersoft WebTextEditor Documentation
WebTextEditorToolCommandCollection Constructor()
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolCommandCollection Class > WebTextEditorToolCommandCollection Constructor : WebTextEditorToolCommandCollection Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebTextEditorToolCommandCollection()
C#
public WebTextEditorToolCommandCollection()
Delphi
public WebTextEditorToolCommandCollection();
JScript
public function WebTextEditorToolCommandCollection();
Managed Extensions for C++
public: WebTextEditorToolCommandCollection();
C++/CLI
public:
WebTextEditorToolCommandCollection();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolCommandCollection Class
WebTextEditorToolCommandCollection Members
Overload List


WebTextEditorToolCommandCollection Constructor(SerializationInfo,StreamingContext)

[image]
Intersoft WebTextEditor Documentation
WebTextEditorToolCommandCollection Constructor(SerializationInfo,StreamingContext)
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolCommandCollection Class > WebTextEditorToolCommandCollection Constructor : WebTextEditorToolCommandCollection Constructor(SerializationInfo,StreamingContext)

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

Dim instance As New WebTextEditorToolCommandCollection(info, context)
C#
protected WebTextEditorToolCommandCollection(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
protected WebTextEditorToolCommandCollection(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
protected function WebTextEditorToolCommandCollection(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
protected: WebTextEditorToolCommandCollection(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
protected:
WebTextEditorToolCommandCollection(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolCommandCollection Class
WebTextEditorToolCommandCollection Members
Overload List


WebTextEditorToolCommandCollection Class Methods

[image]
Intersoft WebTextEditor Documentation
WebTextEditorToolCommandCollection Class Methods
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorToolCommandCollection Class

Glossary Item Box

For a list of all members of this type, see WebTextEditorToolCommandCollection members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CreateNewItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorToolCommand>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | GetNamedItem |
Public Method | GetObjectData | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | SerializerConstructor | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorToolCommand>)
Public Method | SetParent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

Protected Methods

 | Name | Description
Protected Method | ClearItems | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorToolCommand>)
Protected Method | CreateArray | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Protected Method | InsertItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorToolCommand>)
Protected Method | RemoveItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorToolCommand>)
Protected Method | SetItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorToolCommand>)
Top

See Also

Reference

WebTextEditorToolCommandCollection Class
ISNet.WebUI.WebTextEditor Namespace


GetNamedItem Method

[image]
Intersoft WebTextEditor Documentation
GetNamedItem Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolCommandCollection Class : GetNamedItem Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shadows Function GetNamedItem( _
   ByVal name As System.String _
) As WebTextEditorToolCommand
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolCommandCollection
Dim name As System.String
Dim value As WebTextEditorToolCommand

value = instance.GetNamedItem(name)
C#
public new WebTextEditorToolCommand GetNamedItem(
   System.string name
)
Delphi
public function GetNamedItem(
    name: System.String
): WebTextEditorToolCommand;
JScript
public hide function GetNamedItem(
   name : System.String
) : WebTextEditorToolCommand;
Managed Extensions for C++
public: new WebTextEditorToolCommand* GetNamedItem(
   System.string* name
)
C++/CLI
public:
new WebTextEditorToolCommand^ GetNamedItem(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolCommandCollection Class
WebTextEditorToolCommandCollection Members


WebTextEditorToolItem Class

[image]
Intersoft WebTextEditor Documentation
WebTextEditorToolItem Class
Members See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorToolItem Class

Glossary Item Box

A collection of members in WebTextEditor's ToolBar command dropdown list.

Object Model

WebTextEditorToolItem Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebTextEditorToolItem
   Inherits ISNet.WebUI.NamedObjectBase2
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolItem
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebTextEditorToolItem : ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
Delphi
public class WebTextEditorToolItem = class(ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebTextEditorToolItem extends ISNet.WebUI.NamedObjectBase2 implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebTextEditorToolItem : public ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebTextEditorToolItem : public ISNet.WebUI.NamedObjectBase2, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize, ISNet.WebUI.INamedObject2

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.NamedObjectBase2
ISNet.WebUI.WebTextEditor.WebTextEditorToolItem

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolItem Members
ISNet.WebUI.WebTextEditor Namespace


WebTextEditorToolItem Class Members

[image]
Intersoft WebTextEditor Documentation
WebTextEditorToolItem Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorToolItem Class

Glossary Item Box

The following tables list the members exposed by WebTextEditorToolItem.

Public Constructors

 | Name | Description
Public Constructor | WebTextEditorToolItem Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | Collection | (Inherited from ISNet.WebUI.NamedObjectBase2)
Public Property | DisplayMode |
Public Property | Image |
Public Property | Name |
Public Property | Text |
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

Protected Methods

 | Name | Description
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | IsInSerializationContext | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | OnItemAdd | (Inherited from ISNet.WebUI.NamedObjectBase2)
Protected Method | OnItemRemove | (Inherited from ISNet.WebUI.NamedObjectBase2)
Top

See Also

Reference

WebTextEditorToolItem Class
ISNet.WebUI.WebTextEditor Namespace


WebTextEditorToolItem Constructor

[image]
Intersoft WebTextEditor Documentation
WebTextEditorToolItem Constructor
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolItem Class : WebTextEditorToolItem Constructor

Glossary Item Box

Overload List

Overload | Description
WebTextEditorToolItem Constructor() |
WebTextEditorToolItem Constructor(SerializationInfo,StreamingContext) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolItem Class
WebTextEditorToolItem Members


WebTextEditorToolItem Constructor()

[image]
Intersoft WebTextEditor Documentation
WebTextEditorToolItem Constructor()
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolItem Class > WebTextEditorToolItem Constructor : WebTextEditorToolItem Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebTextEditorToolItem()
C#
public WebTextEditorToolItem()
Delphi
public WebTextEditorToolItem();
JScript
public function WebTextEditorToolItem();
Managed Extensions for C++
public: WebTextEditorToolItem();
C++/CLI
public:
WebTextEditorToolItem();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolItem Class
WebTextEditorToolItem Members
Overload List


WebTextEditorToolItem Constructor(SerializationInfo,StreamingContext)

[image]
Intersoft WebTextEditor Documentation
WebTextEditorToolItem Constructor(SerializationInfo,StreamingContext)
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolItem Class > WebTextEditorToolItem Constructor : WebTextEditorToolItem Constructor(SerializationInfo,StreamingContext)

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

Dim instance As New WebTextEditorToolItem(info, context)
C#
protected WebTextEditorToolItem(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
protected WebTextEditorToolItem(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
protected function WebTextEditorToolItem(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
protected: WebTextEditorToolItem(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
protected:
WebTextEditorToolItem(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolItem Class
WebTextEditorToolItem Members
Overload List


WebTextEditorToolItem Class Methods

[image]
Intersoft WebTextEditor Documentation
WebTextEditorToolItem Class Methods
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorToolItem Class

Glossary Item Box

For a list of all members of this type, see WebTextEditorToolItem members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

Protected Methods

 | Name | Description
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | IsInSerializationContext | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | OnItemAdd | (Inherited from ISNet.WebUI.NamedObjectBase2)
Protected Method | OnItemRemove | (Inherited from ISNet.WebUI.NamedObjectBase2)
Top

See Also

Reference

WebTextEditorToolItem Class
ISNet.WebUI.WebTextEditor Namespace


GetObjectData Method

[image]
Intersoft WebTextEditor Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolItem Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolItem
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolItem Class
WebTextEditorToolItem Members


WebTextEditorToolItem Class Properties

[image]
Intersoft WebTextEditor Documentation
WebTextEditorToolItem Class Properties
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorToolItem Class

Glossary Item Box

For a list of all members of this type, see WebTextEditorToolItem members.

Public Properties

 | Name | Description
Public Property | Collection | (Inherited from ISNet.WebUI.NamedObjectBase2)
Public Property | DisplayMode |
Public Property | Image |
Public Property | Name |
Public Property | Text |
Top

See Also

Reference

WebTextEditorToolItem Class
ISNet.WebUI.WebTextEditor Namespace


DisplayMode Property

[image]
Intersoft WebTextEditor Documentation
DisplayMode Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolItem Class : DisplayMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies the display mode of the tool item.")>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property DisplayMode As WebTextEditorToolBarCommandDisplayMode
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolItem
Dim value As WebTextEditorToolBarCommandDisplayMode

instance.DisplayMode = value

value = instance.DisplayMode
C#
[System.ComponentModel.DescriptionAttribute("Specifies the display mode of the tool item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public WebTextEditorToolBarCommandDisplayMode DisplayMode {get; set;}
Delphi
public read-write property DisplayMode: WebTextEditorToolBarCommandDisplayMode;
JScript
System.ComponentModel.DescriptionAttribute("Specifies the display mode of the tool item.")
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set DisplayMode : WebTextEditorToolBarCommandDisplayMode
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies the display mode of the tool item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property WebTextEditorToolBarCommandDisplayMode get_DisplayMode();
public: __property void set_DisplayMode(
   WebTextEditorToolBarCommandDisplayMode value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies the display mode of the tool item.")]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property WebTextEditorToolBarCommandDisplayMode DisplayMode {
   WebTextEditorToolBarCommandDisplayMode get();
   void set (    WebTextEditorToolBarCommandDisplayMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolItem Class
WebTextEditorToolItem Members


Image Property

[image]
Intersoft WebTextEditor Documentation
Image Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolItem Class : Image Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the image path of the tool item.")>
<System.ComponentModel.CategoryAttribute("General")>
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property Image As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolItem
Dim value As System.String

instance.Image = value

value = instance.Image
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image path of the tool item.")]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.string Image {get; set;}
Delphi
public read-write property Image: System.String;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the image path of the tool item.")
System.ComponentModel.CategoryAttribute("General")
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
public function get,set Image : System.String
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image path of the tool item.")]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.string* get_Image();
public: __property void set_Image(
   System.string* value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the image path of the tool item.")]
[System.ComponentModel.CategoryAttribute("General")]
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.String^ Image {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolItem Class
WebTextEditorToolItem Members


Name Property

[image]
Intersoft WebTextEditor Documentation
Name Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolItem Class : Name Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)>
<System.ComponentModel.CategoryAttribute("General")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the name of the tool item.")>
Public Shadows Property Name As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolItem
Dim value As System.String

instance.Name = value

value = instance.Name
C#
[System.ComponentModel.BrowsableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the name of the tool item.")]
public new System.string Name {get; set;}
Delphi
public read-write property Name: System.String;
JScript
System.ComponentModel.BrowsableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)
System.ComponentModel.CategoryAttribute("General")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the name of the tool item.")
public hide function get,set Name : System.String
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the name of the tool item.")]
public: __property new System.string* get_Name();
public: __property new void set_Name(
   System.string* value
);
C++/CLI
[System.ComponentModel.BrowsableAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[System.ComponentModel.CategoryAttribute("General")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the name of the tool item.")]
public:
new property System.String^ Name {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolItem Class
WebTextEditorToolItem Members


Text Property

[image]
Intersoft WebTextEditor Documentation
Text Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolItem Class : Text Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the text of the tool item.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("General")>
Public Property Text As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolItem
Dim value As System.String

instance.Text = value

value = instance.Text
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of the tool item.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
public System.string Text {get; set;}
Delphi
public read-write property Text: System.String;
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the text of the tool item.")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("General")
public function get,set Text : System.String
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of the tool item.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
public: __property System.string* get_Text();
public: __property void set_Text(
   System.string* value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the text of the tool item.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("General")]
public:
property System.String^ Text {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolItem Class
WebTextEditorToolItem Members


WebTextEditorToolItemCollection Class

[image]
Intersoft WebTextEditor Documentation
WebTextEditorToolItemCollection Class
Members See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorToolItemCollection Class

Glossary Item Box

The data collection of ToolBar's command dropdown list used by WebTextEditor.

Object Model

WebTextEditorToolItemCollection Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebTextEditorToolItemCollection
   Inherits ISNet.WebUI.ISGenericCollectionBase(Of WebTextEditorToolItem)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolItemCollection
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebTextEditorToolItemCollection : ISNet.WebUI.ISGenericCollectionBase<WebTextEditorToolItem>
Delphi
public class WebTextEditorToolItemCollection = class(ISNet.WebUI.ISGenericCollectionBase)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebTextEditorToolItemCollection extends ISNet.WebUI.ISGenericCollectionBase
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebTextEditorToolItemCollection : public ISNet.WebUI.ISGenericCollectionBase<WebTextEditorToolItem>
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebTextEditorToolItemCollection : public ISNet.WebUI.ISGenericCollectionBase<WebTextEditorToolItem>

Inheritance Hierarchy

System.Object
System.Collections.ObjectModel.Collection<T>
ISNet.WebUI.ISCollectionBase<T>
ISNet.WebUI.ISGenericCollectionBase<T>
ISNet.WebUI.WebTextEditor.WebTextEditorToolItemCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolItemCollection Members
ISNet.WebUI.WebTextEditor Namespace


WebTextEditorToolItemCollection Class Members

[image]
Intersoft WebTextEditor Documentation
WebTextEditorToolItemCollection Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorToolItemCollection Class

Glossary Item Box

The following tables list the members exposed by WebTextEditorToolItemCollection.

Public Constructors

 | Name | Description
Public Constructor | WebTextEditorToolItemCollection Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | All | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

Protected Properties

 | Name | Description
Protected Property | Items | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Top

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CreateNewItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorToolItem>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | GetNamedItem |
Public Method | GetObjectData | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | SerializerConstructor | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorToolItem>)
Public Method | SetParent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

Protected Methods

 | Name | Description
Protected Method | ClearItems | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorToolItem>)
Protected Method | CreateArray | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Protected Method | InsertItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorToolItem>)
Protected Method | RemoveItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorToolItem>)
Protected Method | SetItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorToolItem>)
Top

See Also

Reference

WebTextEditorToolItemCollection Class
ISNet.WebUI.WebTextEditor Namespace


WebTextEditorToolItemCollection Constructor

[image]
Intersoft WebTextEditor Documentation
WebTextEditorToolItemCollection Constructor
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolItemCollection Class : WebTextEditorToolItemCollection Constructor

Glossary Item Box

Overload List

Overload | Description
WebTextEditorToolItemCollection Constructor() |
WebTextEditorToolItemCollection Constructor(SerializationInfo,StreamingContext) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolItemCollection Class
WebTextEditorToolItemCollection Members


WebTextEditorToolItemCollection Constructor()

[image]
Intersoft WebTextEditor Documentation
WebTextEditorToolItemCollection Constructor()
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolItemCollection Class > WebTextEditorToolItemCollection Constructor : WebTextEditorToolItemCollection Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebTextEditorToolItemCollection()
C#
public WebTextEditorToolItemCollection()
Delphi
public WebTextEditorToolItemCollection();
JScript
public function WebTextEditorToolItemCollection();
Managed Extensions for C++
public: WebTextEditorToolItemCollection();
C++/CLI
public:
WebTextEditorToolItemCollection();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolItemCollection Class
WebTextEditorToolItemCollection Members
Overload List


WebTextEditorToolItemCollection Constructor(SerializationInfo,StreamingContext)

[image]
Intersoft WebTextEditor Documentation
WebTextEditorToolItemCollection Constructor(SerializationInfo,StreamingContext)
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolItemCollection Class > WebTextEditorToolItemCollection Constructor : WebTextEditorToolItemCollection Constructor(SerializationInfo,StreamingContext)

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

Dim instance As New WebTextEditorToolItemCollection(info, context)
C#
protected WebTextEditorToolItemCollection(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
protected WebTextEditorToolItemCollection(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
protected function WebTextEditorToolItemCollection(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
protected: WebTextEditorToolItemCollection(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
protected:
WebTextEditorToolItemCollection(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolItemCollection Class
WebTextEditorToolItemCollection Members
Overload List


WebTextEditorToolItemCollection Class Methods

[image]
Intersoft WebTextEditor Documentation
WebTextEditorToolItemCollection Class Methods
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorToolItemCollection Class

Glossary Item Box

For a list of all members of this type, see WebTextEditorToolItemCollection members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CreateNewItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorToolItem>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | GetNamedItem |
Public Method | GetObjectData | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | SerializerConstructor | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorToolItem>)
Public Method | SetParent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

Protected Methods

 | Name | Description
Protected Method | ClearItems | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorToolItem>)
Protected Method | CreateArray | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Protected Method | InsertItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorToolItem>)
Protected Method | RemoveItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorToolItem>)
Protected Method | SetItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorToolItem>)
Top

See Also

Reference

WebTextEditorToolItemCollection Class
ISNet.WebUI.WebTextEditor Namespace


GetNamedItem Method

[image]
Intersoft WebTextEditor Documentation
GetNamedItem Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolItemCollection Class : GetNamedItem Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Shadows Function GetNamedItem( _
   ByVal name As System.String _
) As WebTextEditorToolItem
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolItemCollection
Dim name As System.String
Dim value As WebTextEditorToolItem

value = instance.GetNamedItem(name)
C#
public new WebTextEditorToolItem GetNamedItem(
   System.string name
)
Delphi
public function GetNamedItem(
    name: System.String
): WebTextEditorToolItem;
JScript
public hide function GetNamedItem(
   name : System.String
) : WebTextEditorToolItem;
Managed Extensions for C++
public: new WebTextEditorToolItem* GetNamedItem(
   System.string* name
)
C++/CLI
public:
new WebTextEditorToolItem^ GetNamedItem(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolItemCollection Class
WebTextEditorToolItemCollection Members


WebTextEditorViewSettings Class

[image]
Intersoft WebTextEditor Documentation
WebTextEditorViewSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorViewSettings Class

Glossary Item Box

A collection of settings used for view in WebTextEditor.

Object Model

WebTextEditorViewSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebTextEditorViewSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorViewSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebTextEditorViewSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebTextEditorViewSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebTextEditorViewSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebTextEditorViewSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebTextEditorViewSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebTextEditor.WebTextEditorViewSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorViewSettings Members
ISNet.WebUI.WebTextEditor Namespace


WebTextEditorViewSettings Class Members

[image]
Intersoft WebTextEditor Documentation
WebTextEditorViewSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorViewSettings Class

Glossary Item Box

The following tables list the members exposed by WebTextEditorViewSettings.

Public Constructors

 | Name | Description
Public Constructor | WebTextEditorViewSettings Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | EnableDesignView | Specifies whether or not the Design view tab is enabled.
Public Property | EnableHTMLView | Specifies whether or not the HTML view tab is enabled.
Public Property | EnablePreview | Specifies whether or not the Preview view tab is enabled.
Public Property | EnableSplitView | Specifies whether or not the Split view tab is enabled.
Public Property | PreviewZoomValue | Specifies the increment and decrement of preview zoom feature (percentage).
Public Property | SelectedViewMode | Specifies the selected view mode when the editor is first loaded.
Public Property | ViewTabWidth | Specifies the width of each view tab.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

Protected Methods

 | Name | Description
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | IsInSerializationContext | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebTextEditorViewSettings Class
ISNet.WebUI.WebTextEditor Namespace


WebTextEditorViewSettings Constructor

[image]
Intersoft WebTextEditor Documentation
WebTextEditorViewSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorViewSettings Class : WebTextEditorViewSettings Constructor

Glossary Item Box

Overload List

Overload | Description
WebTextEditorViewSettings Constructor() |
WebTextEditorViewSettings Constructor(SerializationInfo,StreamingContext) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorViewSettings Class
WebTextEditorViewSettings Members


WebTextEditorViewSettings Constructor()

[image]
Intersoft WebTextEditor Documentation
WebTextEditorViewSettings Constructor()
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorViewSettings Class > WebTextEditorViewSettings Constructor : WebTextEditorViewSettings Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebTextEditorViewSettings()
C#
public WebTextEditorViewSettings()
Delphi
public WebTextEditorViewSettings();
JScript
public function WebTextEditorViewSettings();
Managed Extensions for C++
public: WebTextEditorViewSettings();
C++/CLI
public:
WebTextEditorViewSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorViewSettings Class
WebTextEditorViewSettings Members
Overload List


WebTextEditorViewSettings Constructor(SerializationInfo,StreamingContext)

[image]
Intersoft WebTextEditor Documentation
WebTextEditorViewSettings Constructor(SerializationInfo,StreamingContext)
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorViewSettings Class > WebTextEditorViewSettings Constructor : WebTextEditorViewSettings Constructor(SerializationInfo,StreamingContext)

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

Dim instance As New WebTextEditorViewSettings(info, context)
C#
protected WebTextEditorViewSettings(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
protected WebTextEditorViewSettings(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
protected function WebTextEditorViewSettings(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
protected: WebTextEditorViewSettings(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
protected:
WebTextEditorViewSettings(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorViewSettings Class
WebTextEditorViewSettings Members
Overload List


WebTextEditorViewSettings Class Methods

[image]
Intersoft WebTextEditor Documentation
WebTextEditorViewSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorViewSettings Class

Glossary Item Box

For a list of all members of this type, see WebTextEditorViewSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

Protected Methods

 | Name | Description
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | IsInSerializationContext | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebTextEditorViewSettings Class
ISNet.WebUI.WebTextEditor Namespace


GetObjectData Method

[image]
Intersoft WebTextEditor Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorViewSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorViewSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorViewSettings Class
WebTextEditorViewSettings Members


WebTextEditorViewSettings Class Properties

[image]
Intersoft WebTextEditor Documentation
WebTextEditorViewSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorViewSettings Class

Glossary Item Box

For a list of all members of this type, see WebTextEditorViewSettings members.

Public Properties

 | Name | Description
Public Property | EnableDesignView | Specifies whether or not the Design view tab is enabled.
Public Property | EnableHTMLView | Specifies whether or not the HTML view tab is enabled.
Public Property | EnablePreview | Specifies whether or not the Preview view tab is enabled.
Public Property | EnableSplitView | Specifies whether or not the Split view tab is enabled.
Public Property | PreviewZoomValue | Specifies the increment and decrement of preview zoom feature (percentage).
Public Property | SelectedViewMode | Specifies the selected view mode when the editor is first loaded.
Public Property | ViewTabWidth | Specifies the width of each view tab.
Top

See Also

Reference

WebTextEditorViewSettings Class
ISNet.WebUI.WebTextEditor Namespace


EnableDesignView Property

[image]
Intersoft WebTextEditor Documentation
EnableDesignView Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorViewSettings Class : EnableDesignView Property

Glossary Item Box

Specifies whether or not the Design view tab is enabled.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("View")>
<System.ComponentModel.DescriptionAttribute("Specifies whether or not the Design view tab is enabled.")>
<ISNet.Serialization.XmlSerializableAttribute()>
Public Property EnableDesignView As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorViewSettings
Dim value As System.Boolean

instance.EnableDesignView = value

value = instance.EnableDesignView
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("View")]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not the Design view tab is enabled.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public System.bool EnableDesignView {get; set;}
Delphi
public read-write property EnableDesignView: System.Boolean;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("View")
System.ComponentModel.DescriptionAttribute("Specifies whether or not the Design view tab is enabled.")
ISNet.Serialization.XmlSerializableAttribute()
public function get,set EnableDesignView : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("View")]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not the Design view tab is enabled.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public: __property System.bool get_EnableDesignView();
public: __property void set_EnableDesignView(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("View")]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not the Design view tab is enabled.")]
[ISNet.Serialization.XmlSerializableAttribute()]
public:
property System.bool EnableDesignView {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is True.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorViewSettings Class
WebTextEditorViewSettings Members


EnableHTMLView Property

[image]
Intersoft WebTextEditor Documentation
EnableHTMLView Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorViewSettings Class : EnableHTMLView Property

Glossary Item Box

Specifies whether or not the HTML view tab is enabled.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies whether or not the HTML view tab is enabled.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("View")>
Public Property EnableHTMLView As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorViewSettings
Dim value As System.Boolean

instance.EnableHTMLView = value

value = instance.EnableHTMLView
C#
[System.ComponentModel.DescriptionAttribute("Specifies whether or not the HTML view tab is enabled.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("View")]
public System.bool EnableHTMLView {get; set;}
Delphi
public read-write property EnableHTMLView: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Specifies whether or not the HTML view tab is enabled.")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("View")
public function get,set EnableHTMLView : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies whether or not the HTML view tab is enabled.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("View")]
public: __property System.bool get_EnableHTMLView();
public: __property void set_EnableHTMLView(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies whether or not the HTML view tab is enabled.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("View")]
public:
property System.bool EnableHTMLView {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is True.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorViewSettings Class
WebTextEditorViewSettings Members


EnablePreview Property

[image]
Intersoft WebTextEditor Documentation
EnablePreview Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorViewSettings Class : EnablePreview Property

Glossary Item Box

Specifies whether or not the Preview view tab is enabled.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies whether or not the Preview view tab is enabled.")>
<System.ComponentModel.CategoryAttribute("View")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property EnablePreview As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorViewSettings
Dim value As System.Boolean

instance.EnablePreview = value

value = instance.EnablePreview
C#
[System.ComponentModel.DescriptionAttribute("Specifies whether or not the Preview view tab is enabled.")]
[System.ComponentModel.CategoryAttribute("View")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool EnablePreview {get; set;}
Delphi
public read-write property EnablePreview: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Specifies whether or not the Preview view tab is enabled.")
System.ComponentModel.CategoryAttribute("View")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set EnablePreview : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies whether or not the Preview view tab is enabled.")]
[System.ComponentModel.CategoryAttribute("View")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_EnablePreview();
public: __property void set_EnablePreview(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies whether or not the Preview view tab is enabled.")]
[System.ComponentModel.CategoryAttribute("View")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool EnablePreview {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is False.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorViewSettings Class
WebTextEditorViewSettings Members


EnableSplitView Property

[image]
Intersoft WebTextEditor Documentation
EnableSplitView Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorViewSettings Class : EnableSplitView Property

Glossary Item Box

Specifies whether or not the Split view tab is enabled.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether or not the Split view tab is enabled.")>
<System.ComponentModel.CategoryAttribute("View")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property EnableSplitView As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorViewSettings
Dim value As System.Boolean

instance.EnableSplitView = value

value = instance.EnableSplitView
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not the Split view tab is enabled.")]
[System.ComponentModel.CategoryAttribute("View")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.bool EnableSplitView {get; set;}
Delphi
public read-write property EnableSplitView: System.Boolean;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether or not the Split view tab is enabled.")
System.ComponentModel.CategoryAttribute("View")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set EnableSplitView : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not the Split view tab is enabled.")]
[System.ComponentModel.CategoryAttribute("View")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.bool get_EnableSplitView();
public: __property void set_EnableSplitView(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether or not the Split view tab is enabled.")]
[System.ComponentModel.CategoryAttribute("View")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.bool EnableSplitView {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is True.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorViewSettings Class
WebTextEditorViewSettings Members


PreviewZoomValue Property

[image]
Intersoft WebTextEditor Documentation
PreviewZoomValue Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorViewSettings Class : PreviewZoomValue Property

Glossary Item Box

Specifies the increment and decrement of preview zoom feature (percentage).

Syntax

Visual Basic (Declaration)
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("View")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the increment and decrement of preview zoom feature (percentage).")>
Public Property PreviewZoomValue As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorViewSettings
Dim value As System.Integer

instance.PreviewZoomValue = value

value = instance.PreviewZoomValue
C#
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("View")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the increment and decrement of preview zoom feature (percentage).")]
public System.int PreviewZoomValue {get; set;}
Delphi
public read-write property PreviewZoomValue: System.Integer;
JScript
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("View")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the increment and decrement of preview zoom feature (percentage).")
public function get,set PreviewZoomValue : System.int
Managed Extensions for C++
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("View")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the increment and decrement of preview zoom feature (percentage).")]
public: __property System.int get_PreviewZoomValue();
public: __property void set_PreviewZoomValue(
   System.int value
);
C++/CLI
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("View")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the increment and decrement of preview zoom feature (percentage).")]
public:
property System.int PreviewZoomValue {
   System.int get();
   void set (    System.int value);
}

Property Value

The default value is 10 (percentage).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorViewSettings Class
WebTextEditorViewSettings Members


SelectedViewMode Property

[image]
Intersoft WebTextEditor Documentation
SelectedViewMode Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorViewSettings Class : SelectedViewMode Property

Glossary Item Box

Specifies the selected view mode when the editor is first loaded.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("View")>
<System.ComponentModel.DescriptionAttribute("Specifies the selected view mode when the editor is first loaded.")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Property SelectedViewMode As WebTextEditorViewMode
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorViewSettings
Dim value As WebTextEditorViewMode

instance.SelectedViewMode = value

value = instance.SelectedViewMode
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("View")]
[System.ComponentModel.DescriptionAttribute("Specifies the selected view mode when the editor is first loaded.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public WebTextEditorViewMode SelectedViewMode {get; set;}
Delphi
public read-write property SelectedViewMode: WebTextEditorViewMode;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("View")
System.ComponentModel.DescriptionAttribute("Specifies the selected view mode when the editor is first loaded.")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set SelectedViewMode : WebTextEditorViewMode
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("View")]
[System.ComponentModel.DescriptionAttribute("Specifies the selected view mode when the editor is first loaded.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property WebTextEditorViewMode get_SelectedViewMode();
public: __property void set_SelectedViewMode(
   WebTextEditorViewMode value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("View")]
[System.ComponentModel.DescriptionAttribute("Specifies the selected view mode when the editor is first loaded.")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
property WebTextEditorViewMode SelectedViewMode {
   WebTextEditorViewMode get();
   void set (    WebTextEditorViewMode value);
}

Property Value

The default value is Design view.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorViewSettings Class
WebTextEditorViewSettings Members


ViewTabWidth Property

[image]
Intersoft WebTextEditor Documentation
ViewTabWidth Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorViewSettings Class : ViewTabWidth Property

Glossary Item Box

Specifies the width of each view tab.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the width of each view tab")>
<System.ComponentModel.CategoryAttribute("View")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Property ViewTabWidth As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorViewSettings
Dim value As System.Integer

instance.ViewTabWidth = value

value = instance.ViewTabWidth
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the width of each view tab")]
[System.ComponentModel.CategoryAttribute("View")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public System.int ViewTabWidth {get; set;}
Delphi
public read-write property ViewTabWidth: System.Integer;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the width of each view tab")
System.ComponentModel.CategoryAttribute("View")
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
ISNet.Serialization.BinarySerializableAttribute()
public function get,set ViewTabWidth : System.int
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the width of each view tab")]
[System.ComponentModel.CategoryAttribute("View")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property System.int get_ViewTabWidth();
public: __property void set_ViewTabWidth(
   System.int value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the width of each view tab")]
[System.ComponentModel.CategoryAttribute("View")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
property System.int ViewTabWidth {
   System.int get();
   void set (    System.int value);
}

Property Value

The default value is 75px.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorViewSettings Class
WebTextEditorViewSettings Members


WebTextEditorWatermarkSettings Class

[image]
Intersoft WebTextEditor Documentation
WebTextEditorWatermarkSettings Class
Members See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorWatermarkSettings Class

Glossary Item Box

A collection of settings used for watermark in WebTextEditor.

Object Model

WebTextEditorWatermarkSettings Class

Syntax

Visual Basic (Declaration)
<System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)>
<System.SerializableAttribute()>
Public Class WebTextEditorWatermarkSettings
   Inherits ISNet.WebUI.WebUIBaseClass
   Implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorWatermarkSettings
C#
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public class WebTextEditorWatermarkSettings : ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Delphi
public class WebTextEditorWatermarkSettings = class(ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize)
JScript
System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)
System.SerializableAttribute()
public class WebTextEditorWatermarkSettings extends ISNet.WebUI.WebUIBaseClass implements ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
Managed Extensions for C++
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public __gc class WebTextEditorWatermarkSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize
C++/CLI
[System.Web.UI.PersistenceModeAttribute(PersistenceMode.InnerProperty)]
[System.SerializableAttribute()]
public ref class WebTextEditorWatermarkSettings : public ISNet.WebUI.WebUIBaseClass, ISNet.ICopyable, ISNet.IResetable, ISNet.Serialization.BinarySerialization.IBinarySerialize

Inheritance Hierarchy

System.Object
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.WebTextEditor.WebTextEditorWatermarkSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorWatermarkSettings Members
ISNet.WebUI.WebTextEditor Namespace


WebTextEditorWatermarkSettings Class Members

[image]
Intersoft WebTextEditor Documentation
WebTextEditorWatermarkSettings Class Members
See Also Properties Methods Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorWatermarkSettings Class

Glossary Item Box

The following tables list the members exposed by WebTextEditorWatermarkSettings.

Public Constructors

 | Name | Description
Public Constructor | WebTextEditorWatermarkSettings Constructor | Overloaded.
Top

Public Properties

 | Name | Description
Public Property | EnableWatermark | Specifies whether or not watermark is enabled in editor.
Public Property | Watermark | Specifies the watermark text in editor.
Top

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

Protected Methods

 | Name | Description
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | IsInSerializationContext | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebTextEditorWatermarkSettings Class
ISNet.WebUI.WebTextEditor Namespace


WebTextEditorWatermarkSettings Constructor

[image]
Intersoft WebTextEditor Documentation
WebTextEditorWatermarkSettings Constructor
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorWatermarkSettings Class : WebTextEditorWatermarkSettings Constructor

Glossary Item Box

Overload List

Overload | Description
WebTextEditorWatermarkSettings Constructor() |
WebTextEditorWatermarkSettings Constructor(SerializationInfo,StreamingContext) |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorWatermarkSettings Class
WebTextEditorWatermarkSettings Members


WebTextEditorWatermarkSettings Constructor()

[image]
Intersoft WebTextEditor Documentation
WebTextEditorWatermarkSettings Constructor()
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorWatermarkSettings Class > WebTextEditorWatermarkSettings Constructor : WebTextEditorWatermarkSettings Constructor()

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebTextEditorWatermarkSettings()
C#
public WebTextEditorWatermarkSettings()
Delphi
public WebTextEditorWatermarkSettings();
JScript
public function WebTextEditorWatermarkSettings();
Managed Extensions for C++
public: WebTextEditorWatermarkSettings();
C++/CLI
public:
WebTextEditorWatermarkSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorWatermarkSettings Class
WebTextEditorWatermarkSettings Members
Overload List


WebTextEditorWatermarkSettings Constructor(SerializationInfo,StreamingContext)

[image]
Intersoft WebTextEditor Documentation
WebTextEditorWatermarkSettings Constructor(SerializationInfo,StreamingContext)
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorWatermarkSettings Class > WebTextEditorWatermarkSettings Constructor : WebTextEditorWatermarkSettings Constructor(SerializationInfo,StreamingContext)

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function New( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

Dim instance As New WebTextEditorWatermarkSettings(info, context)
C#
protected WebTextEditorWatermarkSettings(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
protected WebTextEditorWatermarkSettings(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
protected function WebTextEditorWatermarkSettings(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
protected: WebTextEditorWatermarkSettings(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
protected:
WebTextEditorWatermarkSettings(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorWatermarkSettings Class
WebTextEditorWatermarkSettings Members
Overload List


WebTextEditorWatermarkSettings Class Methods

[image]
Intersoft WebTextEditor Documentation
WebTextEditorWatermarkSettings Class Methods
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorWatermarkSettings Class

Glossary Item Box

For a list of all members of this type, see WebTextEditorWatermarkSettings members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | Overridden.
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

Protected Methods

 | Name | Description
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | IsInSerializationContext | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebTextEditorWatermarkSettings Class
ISNet.WebUI.WebTextEditor Namespace


GetObjectData Method

[image]
Intersoft WebTextEditor Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorWatermarkSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=True,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Overrides Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorWatermarkSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public override void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); override;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
public override function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
) override
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.SerializationFormatter,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=true,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
) override

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorWatermarkSettings Class
WebTextEditorWatermarkSettings Members


WebTextEditorWatermarkSettings Class Properties

[image]
Intersoft WebTextEditor Documentation
WebTextEditorWatermarkSettings Class Properties
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorWatermarkSettings Class

Glossary Item Box

For a list of all members of this type, see WebTextEditorWatermarkSettings members.

Public Properties

 | Name | Description
Public Property | EnableWatermark | Specifies whether or not watermark is enabled in editor.
Public Property | Watermark | Specifies the watermark text in editor.
Top

See Also

Reference

WebTextEditorWatermarkSettings Class
ISNet.WebUI.WebTextEditor Namespace


EnableWatermark Property

[image]
Intersoft WebTextEditor Documentation
EnableWatermark Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorWatermarkSettings Class : EnableWatermark Property

Glossary Item Box

Specifies whether or not watermark is enabled in editor.

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Specifies whether or not watermark is enabled in editor.")>
<System.ComponentModel.CategoryAttribute("Section")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
Public Property EnableWatermark As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorWatermarkSettings
Dim value As System.Boolean

instance.EnableWatermark = value

value = instance.EnableWatermark
C#
[System.ComponentModel.DescriptionAttribute("Specifies whether or not watermark is enabled in editor.")]
[System.ComponentModel.CategoryAttribute("Section")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool EnableWatermark {get; set;}
Delphi
public read-write property EnableWatermark: System.Boolean;
JScript
System.ComponentModel.DescriptionAttribute("Specifies whether or not watermark is enabled in editor.")
System.ComponentModel.CategoryAttribute("Section")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set EnableWatermark : System.boolean
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Specifies whether or not watermark is enabled in editor.")]
[System.ComponentModel.CategoryAttribute("Section")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_EnableWatermark();
public: __property void set_EnableWatermark(
   System.bool value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Specifies whether or not watermark is enabled in editor.")]
[System.ComponentModel.CategoryAttribute("Section")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool EnableWatermark {
   System.bool get();
   void set (    System.bool value);
}

Property Value

The default value is False.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorWatermarkSettings Class
WebTextEditorWatermarkSettings Members


Watermark Property

[image]
Intersoft WebTextEditor Documentation
Watermark Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorWatermarkSettings Class : Watermark Property

Glossary Item Box

Specifies the watermark text in editor.

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Section")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies the watermark text in editor")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property Watermark As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorWatermarkSettings
Dim value As System.String

instance.Watermark = value

value = instance.Watermark
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Section")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the watermark text in editor")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.string Watermark {get; set;}
Delphi
public read-write property Watermark: System.String;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.CategoryAttribute("Section")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the watermark text in editor")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set Watermark : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Section")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the watermark text in editor")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_Watermark();
public: __property void set_Watermark(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Section")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies the watermark text in editor")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ Watermark {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorWatermarkSettings Class
WebTextEditorWatermarkSettings Members


WebUIComponentEditor Class

[image]
Intersoft WebTextEditor Documentation
WebUIComponentEditor Class
Members See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebUIComponentEditor Class

Glossary Item Box

Summary description for WebInputComponentEditor.

Object Model

WebUIComponentEditor Class

Syntax

Visual Basic (Declaration)
Public Class WebUIComponentEditor
   Inherits System.Windows.Forms.Design.WindowsFormsComponentEditor
Visual Basic (Usage) Copy Code
Dim instance As WebUIComponentEditor
C#
public class WebUIComponentEditor : System.Windows.Forms.Design.WindowsFormsComponentEditor
Delphi
public class WebUIComponentEditor = class(System.Windows.Forms.Design.WindowsFormsComponentEditor)
JScript
public class WebUIComponentEditor extends System.Windows.Forms.Design.WindowsFormsComponentEditor
Managed Extensions for C++
public __gc class WebUIComponentEditor : public System.Windows.Forms.Design.WindowsFormsComponentEditor
C++/CLI
public ref class WebUIComponentEditor : public System.Windows.Forms.Design.WindowsFormsComponentEditor

Inheritance Hierarchy

System.Object
System.ComponentModel.ComponentEditor
System.Windows.Forms.Design.WindowsFormsComponentEditor
ISNet.WebUI.WebTextEditor.WebUIComponentEditor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebUIComponentEditor Members
ISNet.WebUI.WebTextEditor Namespace


WebUIComponentEditor Class Members

[image]
Intersoft WebTextEditor Documentation
WebUIComponentEditor Class Members
See Also Properties Methods Events Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebUIComponentEditor Class

Glossary Item Box

The following tables list the members exposed by WebUIComponentEditor.

Public Constructors

 | Name | Description
Public Constructor | WebUIComponentEditor Constructor |
Top

Public Properties

 | Name | Description
Public Property | DesignerForm |
Top

Public Methods

 | Name | Description
Public Method | EditComponent | Overloaded. Overridden.
Top

Protected Methods

 | Name | Description
Protected Method | GetComponentEditorPages | (Inherited from System.Windows.Forms.Design.WindowsFormsComponentEditor)
Protected Method | GetInitialComponentEditorPageIndex | (Inherited from System.Windows.Forms.Design.WindowsFormsComponentEditor)
Top

Public Events

 | Name | Description
Public Event | ApplyChanges |
Top

See Also

Reference

WebUIComponentEditor Class
ISNet.WebUI.WebTextEditor Namespace


WebUIComponentEditor Constructor

[image]
Intersoft WebTextEditor Documentation
WebUIComponentEditor Constructor
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebUIComponentEditor Class : WebUIComponentEditor Constructor

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function New()
Visual Basic (Usage) Copy Code
Dim instance As New WebUIComponentEditor()
C#
public WebUIComponentEditor()
Delphi
public WebUIComponentEditor();
JScript
public function WebUIComponentEditor();
Managed Extensions for C++
public: WebUIComponentEditor();
C++/CLI
public:
WebUIComponentEditor();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebUIComponentEditor Class
WebUIComponentEditor Members


WebUIComponentEditor Class Methods

[image]
Intersoft WebTextEditor Documentation
WebUIComponentEditor Class Methods
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebUIComponentEditor Class

Glossary Item Box

For a list of all members of this type, see WebUIComponentEditor members.

Public Methods

 | Name | Description
Public Method | EditComponent | Overloaded. Overridden.
Top

Protected Methods

 | Name | Description
Protected Method | GetComponentEditorPages | (Inherited from System.Windows.Forms.Design.WindowsFormsComponentEditor)
Protected Method | GetInitialComponentEditorPageIndex | (Inherited from System.Windows.Forms.Design.WindowsFormsComponentEditor)
Top

See Also

Reference

WebUIComponentEditor Class
ISNet.WebUI.WebTextEditor Namespace


EditComponent Method

[image]
Intersoft WebTextEditor Documentation
EditComponent Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebUIComponentEditor Class : EditComponent Method

Glossary Item Box

Overload List

Overload | Description
EditComponent(ITypeDescriptorContext,Object,IWin32Window) |
EditComponent(ITypeDescriptorContext,Object) | (Inherited from System.Windows.Forms.Design.WindowsFormsComponentEditor)
EditComponent(Object,IWin32Window) | (Inherited from System.Windows.Forms.Design.WindowsFormsComponentEditor)
EditComponent(Object) | (Inherited from System.ComponentModel.ComponentEditor)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebUIComponentEditor Class
WebUIComponentEditor Members


EditComponent(ITypeDescriptorContext,Object,IWin32Window) Method

[image]
Intersoft WebTextEditor Documentation
EditComponent(ITypeDescriptorContext,Object,IWin32Window) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebUIComponentEditor Class > EditComponent Method : EditComponent(ITypeDescriptorContext,Object,IWin32Window) Method

context
component
owner

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overrides Function EditComponent( _
   ByVal context As System.ComponentModel.ITypeDescriptorContext, _
   ByVal component As System.Object, _
   ByVal owner As System.Windows.Forms.IWin32Window _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebUIComponentEditor
Dim context As System.ComponentModel.ITypeDescriptorContext
Dim component As System.Object
Dim owner As System.Windows.Forms.IWin32Window
Dim value As System.Boolean

value = instance.EditComponent(context, component, owner)
C#
public override System.bool EditComponent(
   System.ComponentModel.ITypeDescriptorContext context,
   System.object component,
   System.Windows.Forms.IWin32Window owner
)
Delphi
public function EditComponent(
    context: System.ComponentModel.ITypeDescriptorContext;
    component: System.TObject;
    owner: System.Windows.Forms.IWin32Window
): System.Boolean; override;
JScript
public override function EditComponent(
   context : System.ComponentModel.ITypeDescriptorContext,
   component : System.Object,
   owner : System.Windows.Forms.IWin32Window
) : System.boolean;
Managed Extensions for C++
public: System.bool EditComponent(
   System.ComponentModel.ITypeDescriptorContext* context,
   System.Object* component,
   System.Windows.Forms.IWin32Window* owner
) override
C++/CLI
public:
System.bool EditComponent(
   System.ComponentModel.ITypeDescriptorContext^ context,
   System.Object^ component,
   System.Windows.Forms.IWin32Window^ owner
) override

Parameters

context
component
owner

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebUIComponentEditor Class
WebUIComponentEditor Members
Overload List


WebUIComponentEditor Class Properties

[image]
Intersoft WebTextEditor Documentation
WebUIComponentEditor Class Properties
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebUIComponentEditor Class

Glossary Item Box

For a list of all members of this type, see WebUIComponentEditor members.

Public Properties

 | Name | Description
Public Property | DesignerForm |
Top

See Also

Reference

WebUIComponentEditor Class
ISNet.WebUI.WebTextEditor Namespace


DesignerForm Property

[image]
Intersoft WebTextEditor Documentation
DesignerForm Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebUIComponentEditor Class : DesignerForm Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property DesignerForm As System.Windows.Forms.Form
Visual Basic (Usage) Copy Code
Dim instance As WebUIComponentEditor
Dim value As System.Windows.Forms.Form

instance.DesignerForm = value

value = instance.DesignerForm
C#
public System.Windows.Forms.Form DesignerForm {get; set;}
Delphi
public read-write property DesignerForm: System.Windows.Forms.Form;
JScript
public function get,set DesignerForm : System.Windows.Forms.Form
Managed Extensions for C++
public: __property System.Windows.Forms.Form* get_DesignerForm();
public: __property void set_DesignerForm(
   System.Windows.Forms.Form* value
);
C++/CLI
public:
property System.Windows.Forms.Form^ DesignerForm {
   System.Windows.Forms.Form^ get();
   void set (    System.Windows.Forms.Form^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebUIComponentEditor Class
WebUIComponentEditor Members


WebUIComponentEditor Class Events

[image]
Intersoft WebTextEditor Documentation
WebUIComponentEditor Class Events
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebUIComponentEditor Class

Glossary Item Box

For a list of all members of this type, see WebUIComponentEditor members.

Public Events

 | Name | Description
Public Event | ApplyChanges |
Top

See Also

Reference

WebUIComponentEditor Class
ISNet.WebUI.WebTextEditor Namespace


ApplyChanges Event

[image]
Intersoft WebTextEditor Documentation
ApplyChanges Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebUIComponentEditor Class : ApplyChanges Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event ApplyChanges As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebUIComponentEditor
Dim handler As System.EventHandler

AddHandler instance.ApplyChanges, handler
C#
public event System.EventHandler ApplyChanges
Delphi
public event ApplyChanges: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
public: __event System.EventHandler* ApplyChanges
C++/CLI
public:
event System.EventHandler^ ApplyChanges

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebUIComponentEditor Class
WebUIComponentEditor Members


PostbackMode Enumeration

[image]
Intersoft WebTextEditor Documentation
PostbackMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : PostbackMode Enumeration

Glossary Item Box

Determines which Postback mode is used.

Syntax

Visual Basic (Declaration)
Public Enum PostbackMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As PostbackMode
C#
public enum PostbackMode : System.Enum
Delphi
public enum PostbackMode = class(System.Enum)
JScript
public enum PostbackMode extends System.Enum
Managed Extensions for C++
__value public enum PostbackMode : public System.Enum
C++/CLI
public enum class PostbackMode : public System.Enum

Members

Member | Description
FlyPostBack |
FullPostBack |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebTextEditor.PostbackMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebTextEditor Namespace


PriorityUploadType Enumeration

[image]
Intersoft WebTextEditor Documentation
PriorityUploadType Enumeration
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : PriorityUploadType Enumeration

Glossary Item Box

Specifies which PriorityUpload type is used.

Syntax

Visual Basic (Declaration)
Public Enum PriorityUploadType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As PriorityUploadType
C#
public enum PriorityUploadType : System.Enum
Delphi
public enum PriorityUploadType = class(System.Enum)
JScript
public enum PriorityUploadType extends System.Enum
Managed Extensions for C++
__value public enum PriorityUploadType : public System.Enum
C++/CLI
public enum class PriorityUploadType : public System.Enum

Members

Member | Description
BySeries |
ByType |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebTextEditor.PriorityUploadType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebTextEditor Namespace


ProgressInformationType Enumeration

[image]
Intersoft WebTextEditor Documentation
ProgressInformationType Enumeration
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : ProgressInformationType Enumeration

Glossary Item Box

Determines which progres information type is used.

Syntax

Visual Basic (Declaration)
Public Enum ProgressInformationType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As ProgressInformationType
C#
public enum ProgressInformationType : System.Enum
Delphi
public enum ProgressInformationType = class(System.Enum)
JScript
public enum ProgressInformationType extends System.Enum
Managed Extensions for C++
__value public enum ProgressInformationType : public System.Enum
C++/CLI
public enum class ProgressInformationType : public System.Enum

Members

Member | Description
Percentage |
Size |
TimeRemaining |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebTextEditor.ProgressInformationType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebTextEditor Namespace


SaveType Enumeration

[image]
Intersoft WebTextEditor Documentation
SaveType Enumeration
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : SaveType Enumeration

Glossary Item Box

Determines which SaveType is used.

Syntax

Visual Basic (Declaration)
Public Enum SaveType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As SaveType
C#
public enum SaveType : System.Enum
Delphi
public enum SaveType = class(System.Enum)
JScript
public enum SaveType extends System.Enum
Managed Extensions for C++
__value public enum SaveType : public System.Enum
C++/CLI
public enum class SaveType : public System.Enum

Members

Member | Description
File |
MemoryStream |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebTextEditor.SaveType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebTextEditor Namespace


UILayout Enumeration

[image]
Intersoft WebTextEditor Documentation
UILayout Enumeration
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : UILayout Enumeration

Glossary Item Box

Determines which UILayout is used.

Syntax

Visual Basic (Declaration)
Public Enum UILayout
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As UILayout
C#
public enum UILayout : System.Enum
Delphi
public enum UILayout = class(System.Enum)
JScript
public enum UILayout extends System.Enum
Managed Extensions for C++
__value public enum UILayout : public System.Enum
C++/CLI
public enum class UILayout : public System.Enum

Members

Member | Description
AttachmentBar |
None |
Panel |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebTextEditor.UILayout

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebTextEditor Namespace


UploadType Enumeration

[image]
Intersoft WebTextEditor Documentation
UploadType Enumeration
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : UploadType Enumeration

Glossary Item Box

Determines which UploadType is used.

Syntax

Visual Basic (Declaration)
Public Enum UploadType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As UploadType
C#
public enum UploadType : System.Enum
Delphi
public enum UploadType = class(System.Enum)
JScript
public enum UploadType extends System.Enum
Managed Extensions for C++
__value public enum UploadType : public System.Enum
C++/CLI
public enum class UploadType : public System.Enum

Members

Member | Description
AutomaticUpload |
BatchUpload |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebTextEditor.UploadType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebTextEditor Namespace


ValidationType Enumeration

[image]
Intersoft WebTextEditor Documentation
ValidationType Enumeration
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : ValidationType Enumeration

Glossary Item Box

Determines which Validation type is used.

Syntax

Visual Basic (Declaration)
Public Enum ValidationType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As ValidationType
C#
public enum ValidationType : System.Enum
Delphi
public enum ValidationType = class(System.Enum)
JScript
public enum ValidationType extends System.Enum
Managed Extensions for C++
__value public enum ValidationType : public System.Enum
C++/CLI
public enum class ValidationType : public System.Enum

Members

Member | Description
Custom |
FilesCount |
RedundantFile |
Size |
Type |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebTextEditor.ValidationType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebTextEditor Namespace


WebSpellCheckerContextMenuStyle Enumeration

[image]
Intersoft WebTextEditor Documentation
WebSpellCheckerContextMenuStyle Enumeration
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebSpellCheckerContextMenuStyle Enumeration

Glossary Item Box

Determines which context menu style is used.

Syntax

Visual Basic (Declaration)
Public Enum WebSpellCheckerContextMenuStyle
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerContextMenuStyle
C#
public enum WebSpellCheckerContextMenuStyle : System.Enum
Delphi
public enum WebSpellCheckerContextMenuStyle = class(System.Enum)
JScript
public enum WebSpellCheckerContextMenuStyle extends System.Enum
Managed Extensions for C++
__value public enum WebSpellCheckerContextMenuStyle : public System.Enum
C++/CLI
public enum class WebSpellCheckerContextMenuStyle : public System.Enum

Members

Member | Description
ElegantBlackStyle |
ElegantBlueStyle |
IntersoftStyle |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebTextEditor.WebSpellCheckerContextMenuStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebTextEditor Namespace


WebTextEditorClientScript Enumeration

[image]
Intersoft WebTextEditor Documentation
WebTextEditorClientScript Enumeration
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorClientScript Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum WebTextEditorClientScript
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorClientScript
C#
public enum WebTextEditorClientScript : System.Enum
Delphi
public enum WebTextEditorClientScript = class(System.Enum)
JScript
public enum WebTextEditorClientScript extends System.Enum
Managed Extensions for C++
__value public enum WebTextEditorClientScript : public System.Enum
C++/CLI
public enum class WebTextEditorClientScript : public System.Enum

Members

Member | Description
ClientColorPicker |
ClientCombo |
ClientSymbol |
ClientTable |
ClientToolBar |
FormControl |
MediaGallery |
TableDesigner |
TaskPane |
ToolBarRuntime |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebTextEditor.WebTextEditorClientScript

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebTextEditor Namespace


WebTextEditorClientStyle Enumeration

[image]
Intersoft WebTextEditor Documentation
WebTextEditorClientStyle Enumeration
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorClientStyle Enumeration

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Enum WebTextEditorClientStyle
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorClientStyle
C#
public enum WebTextEditorClientStyle : System.Enum
Delphi
public enum WebTextEditorClientStyle = class(System.Enum)
JScript
public enum WebTextEditorClientStyle extends System.Enum
Managed Extensions for C++
__value public enum WebTextEditorClientStyle : public System.Enum
C++/CLI
public enum class WebTextEditorClientStyle : public System.Enum

Members

Member | Description
BlackComboStyle |
BlackTableStyle |
BlackTaskPaneStyle |
BlueComboStyle |
BlueTableStyle |
BlueTaskPaneStyle |
CallOut |
ClientColorPicker |
ClientSymbol |
IntersoftComboStyle |
IntersoftTableStyle |
IntersoftTaskPaneStyle |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebTextEditor.WebTextEditorClientStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebTextEditor Namespace


WebTextEditorCssType Enumeration

[image]
Intersoft WebTextEditor Documentation
WebTextEditorCssType Enumeration
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorCssType Enumeration

Glossary Item Box

Specifies which EditorCssType is used.

Syntax

Visual Basic (Declaration)
Public Enum WebTextEditorCssType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorCssType
C#
public enum WebTextEditorCssType : System.Enum
Delphi
public enum WebTextEditorCssType = class(System.Enum)
JScript
public enum WebTextEditorCssType extends System.Enum
Managed Extensions for C++
__value public enum WebTextEditorCssType : public System.Enum
C++/CLI
public enum class WebTextEditorCssType : public System.Enum

Members

Member | Description
DesignerStyleSheet |
RuntimeStyleSheet |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebTextEditor.WebTextEditorCssType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebTextEditor Namespace


WebTextEditorDefaultStyleMode Enumeration

[image]
Intersoft WebTextEditor Documentation
WebTextEditorDefaultStyleMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorDefaultStyleMode Enumeration

Glossary Item Box

Determines which DefaultStyle mode is used.

Syntax

Visual Basic (Declaration)
Public Enum WebTextEditorDefaultStyleMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorDefaultStyleMode
C#
public enum WebTextEditorDefaultStyleMode : System.Enum
Delphi
public enum WebTextEditorDefaultStyleMode = class(System.Enum)
JScript
public enum WebTextEditorDefaultStyleMode extends System.Enum
Managed Extensions for C++
__value public enum WebTextEditorDefaultStyleMode : public System.Enum
C++/CLI
public enum class WebTextEditorDefaultStyleMode : public System.Enum

Members

Member | Description
ElegantBlackStyle |
ElegantBlueStyle |
IntersoftStyle |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebTextEditor.WebTextEditorDefaultStyleMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebTextEditor Namespace


WebTextEditorEnterKeyAction Enumeration

[image]
Intersoft WebTextEditor Documentation
WebTextEditorEnterKeyAction Enumeration
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorEnterKeyAction Enumeration

Glossary Item Box

Determines which EnterKeyAction is used.

Syntax

Visual Basic (Declaration)
Public Enum WebTextEditorEnterKeyAction
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorEnterKeyAction
C#
public enum WebTextEditorEnterKeyAction : System.Enum
Delphi
public enum WebTextEditorEnterKeyAction = class(System.Enum)
JScript
public enum WebTextEditorEnterKeyAction extends System.Enum
Managed Extensions for C++
__value public enum WebTextEditorEnterKeyAction : public System.Enum
C++/CLI
public enum class WebTextEditorEnterKeyAction : public System.Enum

Members

Member | Description
Default |
UseBRTag |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebTextEditor.WebTextEditorEnterKeyAction

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebTextEditor Namespace


WebTextEditorHtmlDocType Enumeration

[image]
Intersoft WebTextEditor Documentation
WebTextEditorHtmlDocType Enumeration
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorHtmlDocType Enumeration

Glossary Item Box

Determines which HtmlDoctype is used.

Syntax

Visual Basic (Declaration)
Public Enum WebTextEditorHtmlDocType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorHtmlDocType
C#
public enum WebTextEditorHtmlDocType : System.Enum
Delphi
public enum WebTextEditorHtmlDocType = class(System.Enum)
JScript
public enum WebTextEditorHtmlDocType extends System.Enum
Managed Extensions for C++
__value public enum WebTextEditorHtmlDocType : public System.Enum
C++/CLI
public enum class WebTextEditorHtmlDocType : public System.Enum

Members

Member | Description
HTMLDocType |
XHTMLDocType |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebTextEditor.WebTextEditorHtmlDocType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebTextEditor Namespace


WebTextEditorMediaResourceType Enumeration

[image]
Intersoft WebTextEditor Documentation
WebTextEditorMediaResourceType Enumeration
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorMediaResourceType Enumeration

Glossary Item Box

Specifies which ResourceType is used.

Syntax

Visual Basic (Declaration)
Public Enum WebTextEditorMediaResourceType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMediaResourceType
C#
public enum WebTextEditorMediaResourceType : System.Enum
Delphi
public enum WebTextEditorMediaResourceType = class(System.Enum)
JScript
public enum WebTextEditorMediaResourceType extends System.Enum
Managed Extensions for C++
__value public enum WebTextEditorMediaResourceType : public System.Enum
C++/CLI
public enum class WebTextEditorMediaResourceType : public System.Enum

Members

Member | Description
Database |
LocalServer |
Service |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebTextEditor.WebTextEditorMediaResourceType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebTextEditor Namespace


WebTextEditorMediaType Enumeration

[image]
Intersoft WebTextEditor Documentation
WebTextEditorMediaType Enumeration
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorMediaType Enumeration

Glossary Item Box

Specifies which MediaType is used.

Syntax

Visual Basic (Declaration)
Public Enum WebTextEditorMediaType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMediaType
C#
public enum WebTextEditorMediaType : System.Enum
Delphi
public enum WebTextEditorMediaType = class(System.Enum)
JScript
public enum WebTextEditorMediaType extends System.Enum
Managed Extensions for C++
__value public enum WebTextEditorMediaType : public System.Enum
C++/CLI
public enum class WebTextEditorMediaType : public System.Enum

Members

Member | Description
AllTypes |
Audios |
FlashObjects |
Images |
Videos |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebTextEditor.WebTextEditorMediaType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebTextEditor Namespace


WebTextEditorParagraphMode Enumeration

[image]
Intersoft WebTextEditor Documentation
WebTextEditorParagraphMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorParagraphMode Enumeration

Glossary Item Box

Determines which Paragraph mode is used.

Syntax

Visual Basic (Declaration)
Public Enum WebTextEditorParagraphMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorParagraphMode
C#
public enum WebTextEditorParagraphMode : System.Enum
Delphi
public enum WebTextEditorParagraphMode = class(System.Enum)
JScript
public enum WebTextEditorParagraphMode extends System.Enum
Managed Extensions for C++
__value public enum WebTextEditorParagraphMode : public System.Enum
C++/CLI
public enum class WebTextEditorParagraphMode : public System.Enum

Members

Member | Description
UseDiv |
UseParagraph |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebTextEditor.WebTextEditorParagraphMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebTextEditor Namespace


WebTextEditorResizeMode Enumeration

[image]
Intersoft WebTextEditor Documentation
WebTextEditorResizeMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorResizeMode Enumeration

Glossary Item Box

Determines which resize mode is used.

Syntax

Visual Basic (Declaration)
Public Enum WebTextEditorResizeMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorResizeMode
C#
public enum WebTextEditorResizeMode : System.Enum
Delphi
public enum WebTextEditorResizeMode = class(System.Enum)
JScript
public enum WebTextEditorResizeMode extends System.Enum
Managed Extensions for C++
__value public enum WebTextEditorResizeMode : public System.Enum
C++/CLI
public enum class WebTextEditorResizeMode : public System.Enum

Members

Member | Description
HorizontalOnly |
No |
VerticalOnly |
Yes |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebTextEditor.WebTextEditorResizeMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebTextEditor Namespace


WebTextEditorSerializationMode Enumeration

[image]
Intersoft WebTextEditor Documentation
WebTextEditorSerializationMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorSerializationMode Enumeration

Glossary Item Box

Specifies which serialization mode is used.

Syntax

Visual Basic (Declaration)
Public Enum WebTextEditorSerializationMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorSerializationMode
C#
public enum WebTextEditorSerializationMode : System.Enum
Delphi
public enum WebTextEditorSerializationMode = class(System.Enum)
JScript
public enum WebTextEditorSerializationMode extends System.Enum
Managed Extensions for C++
__value public enum WebTextEditorSerializationMode : public System.Enum
C++/CLI
public enum class WebTextEditorSerializationMode : public System.Enum

Members

Member | Description
Client |
Server |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebTextEditor.WebTextEditorSerializationMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebTextEditor Namespace


WebTextEditorTaskPanePosition Enumeration

[image]
Intersoft WebTextEditor Documentation
WebTextEditorTaskPanePosition Enumeration
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorTaskPanePosition Enumeration

Glossary Item Box

Specifies which TaskPane position is used.

Syntax

Visual Basic (Declaration)
Public Enum WebTextEditorTaskPanePosition
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTaskPanePosition
C#
public enum WebTextEditorTaskPanePosition : System.Enum
Delphi
public enum WebTextEditorTaskPanePosition = class(System.Enum)
JScript
public enum WebTextEditorTaskPanePosition extends System.Enum
Managed Extensions for C++
__value public enum WebTextEditorTaskPanePosition : public System.Enum
C++/CLI
public enum class WebTextEditorTaskPanePosition : public System.Enum

Members

Member | Description
Left |
Right |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebTextEditor.WebTextEditorTaskPanePosition

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebTextEditor Namespace


WebTextEditorToolBarCategory Enumeration

[image]
Intersoft WebTextEditor Documentation
WebTextEditorToolBarCategory Enumeration
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorToolBarCategory Enumeration

Glossary Item Box

Determines which ToolBar category is used.

Syntax

Visual Basic (Declaration)
Public Enum WebTextEditorToolBarCategory
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBarCategory
C#
public enum WebTextEditorToolBarCategory : System.Enum
Delphi
public enum WebTextEditorToolBarCategory = class(System.Enum)
JScript
public enum WebTextEditorToolBarCategory extends System.Enum
Managed Extensions for C++
__value public enum WebTextEditorToolBarCategory : public System.Enum
C++/CLI
public enum class WebTextEditorToolBarCategory : public System.Enum

Members

Member | Description
Custom |
FloatingBottom |
FloatingTop |
Formatting |
HTML |
Preview |
Standard |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebTextEditor.WebTextEditorToolBarCategory

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebTextEditor Namespace


WebTextEditorToolBarCommandDisplayMode Enumeration

[image]
Intersoft WebTextEditor Documentation
WebTextEditorToolBarCommandDisplayMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorToolBarCommandDisplayMode Enumeration

Glossary Item Box

Determines which DisplayMode is used for ToolBar command.

Syntax

Visual Basic (Declaration)
Public Enum WebTextEditorToolBarCommandDisplayMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBarCommandDisplayMode
C#
public enum WebTextEditorToolBarCommandDisplayMode : System.Enum
Delphi
public enum WebTextEditorToolBarCommandDisplayMode = class(System.Enum)
JScript
public enum WebTextEditorToolBarCommandDisplayMode extends System.Enum
Managed Extensions for C++
__value public enum WebTextEditorToolBarCommandDisplayMode : public System.Enum
C++/CLI
public enum class WebTextEditorToolBarCommandDisplayMode : public System.Enum

Members

Member | Description
Image |
Text |
TextAndImage |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebTextEditor.WebTextEditorToolBarCommandDisplayMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebTextEditor Namespace


WebTextEditorToolBarCommandType Enumeration

[image]
Intersoft WebTextEditor Documentation
WebTextEditorToolBarCommandType Enumeration
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorToolBarCommandType Enumeration

Glossary Item Box

Specifies which CommandType is used in WebTextEditor's ToolBar command.

Syntax

Visual Basic (Declaration)
Public Enum WebTextEditorToolBarCommandType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBarCommandType
C#
public enum WebTextEditorToolBarCommandType : System.Enum
Delphi
public enum WebTextEditorToolBarCommandType = class(System.Enum)
JScript
public enum WebTextEditorToolBarCommandType extends System.Enum
Managed Extensions for C++
__value public enum WebTextEditorToolBarCommandType : public System.Enum
C++/CLI
public enum class WebTextEditorToolBarCommandType : public System.Enum

Members

Member | Description
Button |
DropDownButton |
InternalCustom |
Separator |
SplitButton |
ToggleButton |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebTextEditor.WebTextEditorToolBarCommandType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebTextEditor Namespace


WebTextEditorToolBarMode Enumeration

[image]
Intersoft WebTextEditor Documentation
WebTextEditorToolBarMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorToolBarMode Enumeration

Glossary Item Box

Determines which ToolBar mode is used.

Syntax

Visual Basic (Declaration)
Public Enum WebTextEditorToolBarMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBarMode
C#
public enum WebTextEditorToolBarMode : System.Enum
Delphi
public enum WebTextEditorToolBarMode = class(System.Enum)
JScript
public enum WebTextEditorToolBarMode extends System.Enum
Managed Extensions for C++
__value public enum WebTextEditorToolBarMode : public System.Enum
C++/CLI
public enum class WebTextEditorToolBarMode : public System.Enum

Members

Member | Description
Complete |
Custom |
Minimal |
None |
Rich |
Standard |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebTextEditor.WebTextEditorToolBarMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebTextEditor Namespace


WebTextEditorToolCommandType Enumeration

[image]
Intersoft WebTextEditor Documentation
WebTextEditorToolCommandType Enumeration
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorToolCommandType Enumeration

Glossary Item Box

Specifies which command is used in WebTextEditor's ToolBar command.

Syntax

Visual Basic (Declaration)
Public Enum WebTextEditorToolCommandType
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolCommandType
C#
public enum WebTextEditorToolCommandType : System.Enum
Delphi
public enum WebTextEditorToolCommandType = class(System.Enum)
JScript
public enum WebTextEditorToolCommandType extends System.Enum
Managed Extensions for C++
__value public enum WebTextEditorToolCommandType : public System.Enum
C++/CLI
public enum class WebTextEditorToolCommandType : public System.Enum

Members

Member | Description
AlignCenter |
AlignJustify |
AlignLeft |
AlignRight |
Bold |
Bullets |
ChangeCase |
ClearFormatting |
Copy |
Cut |
DecreaseIndent |
Emoticon |
Find |
First |
Font |
FontColor |
FontSize |
FullScreen |
Heading |
HTMLBold |
HTMLBullets |
HTMLCloseTags |
HTMLFind |
HTMLHyperlink |
HTMLInsertMedia |
HTMLItalic |
HTMLListItem |
HTMLNumbering |
HTMLReplace |
HTMLUnderline |
Hyperlink |
Import |
IncreaseIndent |
InsertFormControl |
InsertFromComputer |
InsertFromWeb |
InsertLabel |
InsertSymbol |
InsertTable |
Italic |
Last |
MediaGallery |
Next |
Numbering |
Paste |
Preview |
Previous |
Print |
Quote |
Redo |
RemoveLink |
Replace |
Save |
SendMail |
SpellChecker |
Strikethrough |
Subscript |
Superscript |
TextHighlightColor |
Underline |
Undo |
ZoomIn |
ZoomOut |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebTextEditor.WebTextEditorToolCommandType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebTextEditor Namespace


WebTextEditorViewMode Enumeration

[image]
Intersoft WebTextEditor Documentation
WebTextEditorViewMode Enumeration
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorViewMode Enumeration

Glossary Item Box

Specifies WebTextEditor view mode.

Syntax

Visual Basic (Declaration)
Public Enum WebTextEditorViewMode
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorViewMode
C#
public enum WebTextEditorViewMode : System.Enum
Delphi
public enum WebTextEditorViewMode = class(System.Enum)
JScript
public enum WebTextEditorViewMode extends System.Enum
Managed Extensions for C++
__value public enum WebTextEditorViewMode : public System.Enum
C++/CLI
public enum class WebTextEditorViewMode : public System.Enum

Members

Member | Description
DesignView |
HTMLView |
SplitView |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebTextEditor.WebTextEditorViewMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebTextEditor Namespace


WebUploadInfoStatus Enumeration

[image]
Intersoft WebTextEditor Documentation
WebUploadInfoStatus Enumeration
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebUploadInfoStatus Enumeration

Glossary Item Box

Specifies WebUploader info status.

Syntax

Visual Basic (Declaration)
Public Enum WebUploadInfoStatus
   Inherits System.Enum
Visual Basic (Usage) Copy Code
Dim instance As WebUploadInfoStatus
C#
public enum WebUploadInfoStatus : System.Enum
Delphi
public enum WebUploadInfoStatus = class(System.Enum)
JScript
public enum WebUploadInfoStatus extends System.Enum
Managed Extensions for C++
__value public enum WebUploadInfoStatus : public System.Enum
C++/CLI
public enum class WebUploadInfoStatus : public System.Enum

Members

Member | Description
Cancelled |
Cancelling |
Created |
Error |
Uploaded |
Uploading |

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
ISNet.WebUI.WebTextEditor.WebUploadInfoStatus

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ISNet.WebUI.WebTextEditor Namespace


UploadFileEventHandler Delegate

[image]
Intersoft WebTextEditor Documentation
UploadFileEventHandler Delegate
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : UploadFileEventHandler Delegate

sender
e

Glossary Item Box

Delegates that handles the UploadFile event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub UploadFileEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As WebFileUploaderFileEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New UploadFileEventHandler(AddressOf HandlerMethod)
C#
public delegate void UploadFileEventHandler(
   System.object sender,
   WebFileUploaderFileEventArgs e
)
Delphi
public delegate UploadFileEventHandler(
    sender: System.TObject;
    e: WebFileUploaderFileEventArgs
);
JScript
public delegate UploadFileEventHandler(
   sender : System.Object,
   e : WebFileUploaderFileEventArgs
)
Managed Extensions for C++
public: __gc __delegate void UploadFileEventHandler(
   System.Object* sender,
   WebFileUploaderFileEventArgs* e
)
C++/CLI
public delegate void UploadFileEventHandler(
   System.Object^ sender,
   WebFileUploaderFileEventArgs^ e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

UploadFileEventHandler Members
ISNet.WebUI.WebTextEditor Namespace


ValidateUploadFileEventHandler Delegate

[image]
Intersoft WebTextEditor Documentation
ValidateUploadFileEventHandler Delegate
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : ValidateUploadFileEventHandler Delegate

sender
e

Glossary Item Box

Delegates that handles the ValidateUploadFile event.

Syntax

Visual Basic (Declaration)
Public Delegate Function ValidateUploadFileEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As WebFileUploaderFileEventArgs _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As New ValidateUploadFileEventHandler(AddressOf HandlerMethod)
C#
public delegate System.bool ValidateUploadFileEventHandler(
   System.object sender,
   WebFileUploaderFileEventArgs e
)
Delphi
public delegate ValidateUploadFileEventHandler(
    sender: System.TObject;
    e: WebFileUploaderFileEventArgs
);
JScript
public delegate ValidateUploadFileEventHandler(
   sender : System.Object,
   e : WebFileUploaderFileEventArgs
) : System.boolean
Managed Extensions for C++
public: __gc __delegate System.bool ValidateUploadFileEventHandler(
   System.Object* sender,
   WebFileUploaderFileEventArgs* e
)
C++/CLI
public delegate System.bool ValidateUploadFileEventHandler(
   System.Object^ sender,
   WebFileUploaderFileEventArgs^ e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ValidateUploadFileEventHandler Members
ISNet.WebUI.WebTextEditor Namespace


WebTextEditorBeforeSendMailEventHandler Delegate

[image]
Intersoft WebTextEditor Documentation
WebTextEditorBeforeSendMailEventHandler Delegate
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorBeforeSendMailEventHandler Delegate

sender
e

Glossary Item Box

Delegates that handles the before Send Mail event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub WebTextEditorBeforeSendMailEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As WebTextEditorBeforeSendMailArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New WebTextEditorBeforeSendMailEventHandler(AddressOf HandlerMethod)
C#
public delegate void WebTextEditorBeforeSendMailEventHandler(
   System.object sender,
   WebTextEditorBeforeSendMailArgs e
)
Delphi
public delegate WebTextEditorBeforeSendMailEventHandler(
    sender: System.TObject;
    e: WebTextEditorBeforeSendMailArgs
);
JScript
public delegate WebTextEditorBeforeSendMailEventHandler(
   sender : System.Object,
   e : WebTextEditorBeforeSendMailArgs
)
Managed Extensions for C++
public: __gc __delegate void WebTextEditorBeforeSendMailEventHandler(
   System.Object* sender,
   WebTextEditorBeforeSendMailArgs* e
)
C++/CLI
public delegate void WebTextEditorBeforeSendMailEventHandler(
   System.Object^ sender,
   WebTextEditorBeforeSendMailArgs^ e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorBeforeSendMailEventHandler Members
ISNet.WebUI.WebTextEditor Namespace


WebTextEditorMailMergeCompletedEventHandler Delegate

[image]
Intersoft WebTextEditor Documentation
WebTextEditorMailMergeCompletedEventHandler Delegate
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorMailMergeCompletedEventHandler Delegate

sender
e

Glossary Item Box

Delegates that handles the MailMerge completed event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub WebTextEditorMailMergeCompletedEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As WebTextEditorMailMergeCompletedArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New WebTextEditorMailMergeCompletedEventHandler(AddressOf HandlerMethod)
C#
public delegate void WebTextEditorMailMergeCompletedEventHandler(
   System.object sender,
   WebTextEditorMailMergeCompletedArgs e
)
Delphi
public delegate WebTextEditorMailMergeCompletedEventHandler(
    sender: System.TObject;
    e: WebTextEditorMailMergeCompletedArgs
);
JScript
public delegate WebTextEditorMailMergeCompletedEventHandler(
   sender : System.Object,
   e : WebTextEditorMailMergeCompletedArgs
)
Managed Extensions for C++
public: __gc __delegate void WebTextEditorMailMergeCompletedEventHandler(
   System.Object* sender,
   WebTextEditorMailMergeCompletedArgs* e
)
C++/CLI
public delegate void WebTextEditorMailMergeCompletedEventHandler(
   System.Object^ sender,
   WebTextEditorMailMergeCompletedArgs^ e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMailMergeCompletedEventHandler Members
ISNet.WebUI.WebTextEditor Namespace


WebTextEditorMailMergeEventHandler Delegate

[image]
Intersoft WebTextEditor Documentation
WebTextEditorMailMergeEventHandler Delegate
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorMailMergeEventHandler Delegate

sender
e

Glossary Item Box

Delegates that handles the MailMerge event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub WebTextEditorMailMergeEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As WebTextEditorMailMergeArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New WebTextEditorMailMergeEventHandler(AddressOf HandlerMethod)
C#
public delegate void WebTextEditorMailMergeEventHandler(
   System.object sender,
   WebTextEditorMailMergeArgs e
)
Delphi
public delegate WebTextEditorMailMergeEventHandler(
    sender: System.TObject;
    e: WebTextEditorMailMergeArgs
);
JScript
public delegate WebTextEditorMailMergeEventHandler(
   sender : System.Object,
   e : WebTextEditorMailMergeArgs
)
Managed Extensions for C++
public: __gc __delegate void WebTextEditorMailMergeEventHandler(
   System.Object* sender,
   WebTextEditorMailMergeArgs* e
)
C++/CLI
public delegate void WebTextEditorMailMergeEventHandler(
   System.Object^ sender,
   WebTextEditorMailMergeArgs^ e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMailMergeEventHandler Members
ISNet.WebUI.WebTextEditor Namespace


WebTextEditorSaveEventHandler Delegate

[image]
Intersoft WebTextEditor Documentation
WebTextEditorSaveEventHandler Delegate
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorSaveEventHandler Delegate

sender
e

Glossary Item Box

Delegates that handles the Save event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub WebTextEditorSaveEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As WebTextEditorSaveArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New WebTextEditorSaveEventHandler(AddressOf HandlerMethod)
C#
public delegate void WebTextEditorSaveEventHandler(
   System.object sender,
   WebTextEditorSaveArgs e
)
Delphi
public delegate WebTextEditorSaveEventHandler(
    sender: System.TObject;
    e: WebTextEditorSaveArgs
);
JScript
public delegate WebTextEditorSaveEventHandler(
   sender : System.Object,
   e : WebTextEditorSaveArgs
)
Managed Extensions for C++
public: __gc __delegate void WebTextEditorSaveEventHandler(
   System.Object* sender,
   WebTextEditorSaveArgs* e
)
C++/CLI
public delegate void WebTextEditorSaveEventHandler(
   System.Object^ sender,
   WebTextEditorSaveArgs^ e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorSaveEventHandler Members
ISNet.WebUI.WebTextEditor Namespace


WebTextEditorSendMailCompletedEventHandler Delegate

[image]
Intersoft WebTextEditor Documentation
WebTextEditorSendMailCompletedEventHandler Delegate
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorSendMailCompletedEventHandler Delegate

sender
e

Glossary Item Box

Delegates that handles the Send Mail completed event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub WebTextEditorSendMailCompletedEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As WebTextEditorSendMailCompletedArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New WebTextEditorSendMailCompletedEventHandler(AddressOf HandlerMethod)
C#
public delegate void WebTextEditorSendMailCompletedEventHandler(
   System.object sender,
   WebTextEditorSendMailCompletedArgs e
)
Delphi
public delegate WebTextEditorSendMailCompletedEventHandler(
    sender: System.TObject;
    e: WebTextEditorSendMailCompletedArgs
);
JScript
public delegate WebTextEditorSendMailCompletedEventHandler(
   sender : System.Object,
   e : WebTextEditorSendMailCompletedArgs
)
Managed Extensions for C++
public: __gc __delegate void WebTextEditorSendMailCompletedEventHandler(
   System.Object* sender,
   WebTextEditorSendMailCompletedArgs* e
)
C++/CLI
public delegate void WebTextEditorSendMailCompletedEventHandler(
   System.Object^ sender,
   WebTextEditorSendMailCompletedArgs^ e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorSendMailCompletedEventHandler Members
ISNet.WebUI.WebTextEditor Namespace


WebTextEditorSendMailEventHandler Delegate

[image]
Intersoft WebTextEditor Documentation
WebTextEditorSendMailEventHandler Delegate
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorSendMailEventHandler Delegate

sender
e

Glossary Item Box

Delegates that handles the Send Mail event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub WebTextEditorSendMailEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As WebTextEditorSendMailArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New WebTextEditorSendMailEventHandler(AddressOf HandlerMethod)
C#
public delegate void WebTextEditorSendMailEventHandler(
   System.object sender,
   WebTextEditorSendMailArgs e
)
Delphi
public delegate WebTextEditorSendMailEventHandler(
    sender: System.TObject;
    e: WebTextEditorSendMailArgs
);
JScript
public delegate WebTextEditorSendMailEventHandler(
   sender : System.Object,
   e : WebTextEditorSendMailArgs
)
Managed Extensions for C++
public: __gc __delegate void WebTextEditorSendMailEventHandler(
   System.Object* sender,
   WebTextEditorSendMailArgs* e
)
C++/CLI
public delegate void WebTextEditorSendMailEventHandler(
   System.Object^ sender,
   WebTextEditorSendMailArgs^ e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorSendMailEventHandler Members
ISNet.WebUI.WebTextEditor Namespace


WebTextEditorToolBarEventHandler Delegate

[image]
Intersoft WebTextEditor Documentation
WebTextEditorToolBarEventHandler Delegate
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorToolBarEventHandler Delegate

sender
e

Glossary Item Box

Delegates that handles the ToolBar event.

Syntax

Visual Basic (Declaration)
Public Delegate Sub WebTextEditorToolBarEventHandler( _
   ByVal sender As System.Object, _
   ByVal e As WebTextEditorToolBarArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As New WebTextEditorToolBarEventHandler(AddressOf HandlerMethod)
C#
public delegate void WebTextEditorToolBarEventHandler(
   System.object sender,
   WebTextEditorToolBarArgs e
)
Delphi
public delegate WebTextEditorToolBarEventHandler(
    sender: System.TObject;
    e: WebTextEditorToolBarArgs
);
JScript
public delegate WebTextEditorToolBarEventHandler(
   sender : System.Object,
   e : WebTextEditorToolBarArgs
)
Managed Extensions for C++
public: __gc __delegate void WebTextEditorToolBarEventHandler(
   System.Object* sender,
   WebTextEditorToolBarArgs* e
)
C++/CLI
public delegate void WebTextEditorToolBarEventHandler(
   System.Object^ sender,
   WebTextEditorToolBarArgs^ e
)

Parameters

sender
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBarEventHandler Members
ISNet.WebUI.WebTextEditor Namespace


Client-side References

Client-side References
Send Feedback
Intersoft WebTextEditor > Client-side References

Glossary Item Box

This section is designated to help user working with client-side references in WebTextEditor.

In This Section

WebTextEditor

WebTextEditorClientSideEvents

WebSpellChecker

WebSpellCheckerClientSideEvents

WebSpellCheckerImagesSettings

WebSpellCheckerTextSettings

WebFileUploader

WebFileUploaderClientSideEvents

WebFileUploaderTextSettings

WebFileUploaderImagesSettings

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


WebTextEditor

WebTextEditor
Send Feedback
Intersoft WebTextEditor > Client-side References > WebTextEditor

Glossary Item Box

WebTextEditor Properties

ScriptDirectory | Description Gets or sets the directory where all required scripts for the control are stored. ValueType Default Value
ImagesDirectory | Description Gets or sets the images directory. ValueType Default Value
ViewStateStorage | Description Gets or sets the location to store the viewstate of this control. ValueType Default Value
AccessKey | Description Keyboard shortcut used by the control. ValueType Default Value
Enabled | Description Enables state of the control. ValueType Default Value
TabIndex | Description The tab order of the control. ValueType Default Value
ToolTip | Description The tooltip displayed when the mouse is over the control. ValueType Default Value
Width | Description The width of the control. ValueType Default Value
Height | Description The height of the control. ValueType Default Value
DefaultStyleMode | Description Gets or sets the value that determines the mode of the default style when UseDefaultStyle is enabled. ValueType Default Value
AllowDefaultStyleMerging | Description Gets or sets the value that determines whether or not the default style can be merged with custom styles. ValueType Default Value
UseDefaultStyle | Description Determines whether WebTextEditor is using default style. ValueType Default Value
AllowResize | Description Determines whether resize action is allowed. ValueType Default Value
EnableDocumentImport | Description Determines whether document import is enabled. ValueType Default Value
EnableDocumentSave | Description Determines whether document save is enabled. ValueType Default Value
EnableDocumentPrint | Description Determines whether document print is enabled. ValueType Default Value
EnableContextMenu | Description Determines whether context menu is enabled. ValueType Default Value
EnableHTMLInspector | Description Determines whether html inspector is enabled. ValueType Default Value
EnableKeyboardSupport | Description Determines whether keyboard support is enabled. ValueType Default Value
ShowCharacterInformation | Description Determines whether character information should be shown as tooltip. ValueType Default Value
ShowWordInformation | Description Determines whether word information should be shown. ValueType Default Value
EnableFullScreen | Description Gets or sets the value that determines whether full screen feature is enabled. ValueType Default Value
EnableAutoSave | Description Determines whether auto save feature is enabled. ValueType Default Value
MinimumSize | Description Gets or sets the value that determines the minimum size of WebTextEditor when it is resized. ValueType Default Value
MaximumSize | Description Gets or sets the value that determines the maximum size of WebTextEditor when it is resized. ValueType Default Value
UndoLatency | Description Specifies undo latency interal (in milisecond). ValueType Default Value
MediaResources | Description The media resources collection used by WebTextEditor to filter the media in Media Gallery task pane. ValueType Default Value
RootTextEditor | Description Provides settings that control the behaviors of single section in WebTextEditor. ValueType Default Value
TextEditorSections | Description Provides settings that control the behaviors of multiple section in WebTextEditor. ValueType Default Value
EnableEditorTabKey | Description Determines whether WebTextEditor should handle Tab key. ValueType Default Value
EnterKeyAction | Description Specifies WebTextEditor behavior when enter key is pressed. ValueType Default Value
ParagraphMode | Description Specifies the behavior of paragraph editing. ValueType Default Value
ShowCallOutOnMediaInsert | Description Determines whether callour will appear when media is inserted. ValueType Default Value
ShowMediaActionOnMediaSelect | Description Determines whether media action will appear when media is selected. ValueType Default Value
PreventScriptInjection | Description Determines whether script tag is removed from WebTextEditor. ValueType Default Value
EnableXHTMLCompliance | Description Determines whether WebTextEditor's output is XHTML compliance. ValueType Default Value
ToolBarSettings | Description Provides settings that control the behaviors of the toolbar in WebTextEditor. ValueType Default Value
TextSettings | Description Provides settings that control text shown in WebTextEditor. ValueType Default Value
ViewSettings | Description Provides settings that control the behaviors of the view in WebTextEditor. ValueType Default Value
ImagesSettings | Description Provides settings thta control the images in WebTextEditor. ValueType Default Value
TaskPaneSettings | Description Provides settings that control the behaviors of the task pane in WebTextEditor. ValueType Default Value
EditorSettings | Description Provides settings that control the behaviors of the editor in WebTextEditor. ValueType Default Value
MailMergeSettings | Description Provides settings that control the behaviors of mail merge in WebTextEditor. ValueType Default Value
ClientSideEvents | Description Contains Client-side events supported by WebTextEditor. ValueType Default Value

WebTextEditor Methods

GetElement Description
Gets the WebTextEditor element.

Parameters

Remarks

Return Value

Samples
GetFrameLayerElement Description
Gets the frame layer element.

Parameters

Remarks

Return Value

Samples
GetMainHeaderElement Description
Gets the main header element.

Parameters

Remarks

Return Value

Samples
GetHTMLToolBar Description
Gets the HTML toolbar object.

Parameters

Remarks

Return Value

Samples
GetMainContentElement Description
Gets the main content element.

Parameters

Remarks

Return Value

Samples
GetMainFooterElement Description
Gets the footer element.

Parameters

Remarks

Return Value

Samples
GetMainContentFrameElement Description
Gets the footer content element.

Parameters

Remarks

Return Value

Samples
GetMainContentTableElement Description
Gets the footer content table element.

Parameters

Remarks

Return Value

Samples
GetEditorFrameElement Description
Gets the WebTextEditor frame element.

Parameters

Remarks

Return Value

Samples
GetEditorContentFrameElement Description
Gets the WebTextEditor content element.

Parameters

Remarks

Return Value

Samples
GetEditorLayerFrameElement Description
Gets the WebTextEditor layer frame element.

Parameters

Remarks

Return Value

Samples
GetSplitterElement Description
Gets the splitter element.

Parameters

Remarks

Return Value

Samples
GetSplitterIndicatorElement Description
Gets the splitter indicator element.

Parameters

Remarks

Return Value

Samples
GetTaskPaneElement Description
Gets the TaskPane element.

Parameters

Remarks

Return Value

Samples
SetValueToCurrentPosition Description
Sets value in the last active cursor position.

Parameters

Remarks

Return Value

Samples
SetFocus Description
Sets focus on editor.

Parameters

Remarks

Return Value

Samples
RegisterIFrameBehavior Description
Registers the behavior to IFrame element.

Parameters

Remarks

Return Value

Samples
UnregisterIFrameBehavior Description
Unregisters the events attached to editor iframe.

Parameters

Remarks

Return Value

Samples
ToggleToolBar Description
Toggles toolbar elements.

Parameters

Remarks

Return Value

Samples
ResetEditorState Description
Resets the editor state.

Parameters

Remarks

Return Value

Samples
SetHeaderHeightCache Description
Sets the header height.

Parameters

Remarks

Return Value

Samples
HideCallOut Description
Hides the callout manually.

Parameters

Remarks

Return Value

Samples
GetViewIndicatorElement Description
Gets the view indicator element.

Parameters

Remarks

Return Value

Samples
GetDesignViewTabElement Description
Gets the design view tab element.

Parameters

Remarks

Return Value

Samples
GetHTMLViewTabElement Description
Gets the html view tab element.

Parameters

Remarks

Return Value

Samples
GetSplitViewTabElement Description
Gets the split view tab element.

Parameters

Remarks

Return Value

Samples
GetWordsInformationTabElement Description
Gets the word information tab element.

Parameters

Remarks

Return Value

Samples
GetSpellCheckerTabElement Description
Gets the spell checker tab element.

Parameters

Remarks

Return Value

Samples
GetHTMLInspectorTabElement Description
Gets the html inspector tab element.

Parameters

Remarks

Return Value

Samples
GetHTMLInspectorDivElement Description
Gets the html inspector div element.

Parameters

Remarks

Return Value

Samples
GetHTMLInspectorLeftIndicatorElement Description
Gets the html inspector left indicator element.

Parameters

Remarks

Return Value

Samples
GetHTMLInspectorRightIndicatorElement Description
Gets the html inspector right indicator element.

Parameters

Remarks

Return Value

Samples
GetHTMLInspectorContentElement Description
Gets the html inspector content element.

Parameters

Remarks

Return Value

Samples
GetHTMLInspectorContentTableElement Description
Gets the html inspector content table element.

Parameters

Remarks

Return Value

Samples
GetUploadBarElement Description
Gets the upload bar element.

Parameters

Remarks

Return Value

Samples
GetUploadBarFrameElement Description
Gets the upload bar frame element.

Parameters

Remarks

Return Value

Samples
GetUploadBarContentElement Description
Gets the upload bar content element.

Parameters

Remarks

Return Value

Samples
GetStatusBarElement Description
Gets the status bar element.

Parameters

Remarks

Return Value

Samples
GetResizerElement Description
Gets the resizer element.

Parameters

Remarks

Return Value

Samples
GetFloatingToolBarElement Description
Gets the floating toolbar element.

Parameters

Remarks

Return Value

Samples
GetMediaActionFrameElement Description
Gets the media action frame element.

Parameters

Remarks

Return Value

Samples
CheckSpell Description
Starts check spelling.

Parameters

Remarks

Return Value

Samples
RemoveSpellChecker Description
Gets the remove check spell.

Parameters

Remarks

Return Value

Samples
GetDesignViewFrameByName Description
Gets design view frame by section name.

Parameters
sectionName

Remarks

Return Value

Samples
GetSelectedDesignViewFrame Description
Gets selected design view frame.

Parameters

Remarks

Return Value

Samples
GetHtmlViewFrameByName Description
Gets html view by section name.

Parameters
sectionName

Remarks

Return Value

Samples
GetSelectedHTMLViewFrame Description
Gets selected html view frame.

Parameters

Remarks

Return Value

Samples
ShowDesignViewByName Description
Shows design view by section name.

Parameters
sectionName

Remarks

Return Value

Samples
HideDesignViewByName Description
Hides design view by section name.

Parameters
sectionName

Remarks

Return Value

Samples
HideHtmlViewByName Description
Hides html view by section name.

Parameters
sectionName

Remarks

Return Value

Samples
GetSectionObjectByName Description
Gets section object by name.

Parameters
sectionName

Remarks

Return Value

Samples
GetSectionFrameBySectionName Description
Gets section Frame by section name.

Parameters
sectionName

Remarks

Return Value

Samples
GetSelectedSectionElement Description
Gets selected section element.

Parameters

Remarks

Return Value

Samples
GetSelectedSectionObject Description
Gets selected section object.

Parameters

Remarks

Return Value

Samples
GetSelectedSectionElementByName Description
Gets selected section element by section name.

Parameters
sectionName

Remarks

Return Value

Samples
GetSectionElementByName Description
Gets section element by name.

Parameters
sectionName

Remarks

Return Value

Samples
GetSelectedHtmlSectionElement Description
Gets selected html section element.

Parameters

Remarks

Return Value

Samples
GetHtmlSectionElementByName Description
Gets html section element by section name.

Parameters
sectionName

Remarks

Return Value

Samples
GetTextAreaBySectionName Description
Gets textarea by section name.

Parameters
sectionName

Remarks

Return Value

Samples
GetSelectedTextArea Description
Gets selected textarea from selected html view.

Parameters

Remarks

Return Value

Samples
GetSelectedWatermark Description
Gets selected watermark element.

Parameters

Remarks

Return Value

Samples
ShowAllWatermark Description
Shows all watermark.

Parameters

Remarks

Return Value

Samples
ShowSelectedWatermark Description
Shows selected watermark by name.

Parameters
name

Remarks

Return Value

Samples
HideAllWatermark Description
Hides all watermark.

Parameters

Remarks

Return Value

Samples
HideSelectedWatermark Description
Hides selected watermark.

Parameters

Remarks

Return Value

Samples
GetImageBySectionName Description
Gets image's section by section name.

Parameters
sectionName

Remarks

Return Value

Samples
GetSectionTableBySectionName Description
Gets section table element by section name.

Parameters
sectionName

Remarks

Return Value

Samples
GetSectionImageFrameBySectionName Description
Get section image frame by section name.

Parameters
sectionName

Remarks

Return Value

Samples
GetAllSections Description
Gets all section.

Parameters

Remarks

Return Value

Samples
ExecCommand Description
Invokes WebTextEditor exec command.

Parameters
Operation

Remarks

Return Value

Samples
TextAreaExecCommand Description
Invokes WebTextEditor's textarea.

Parameters
operation, command, isCloseTag

Remarks

Return Value

Samples
InsertTable Description
Inserts table to editor.

Parameters
column, row

Remarks

Return Value

Samples
InsertsImage Description
Inserts image to editor.

Parameters
url, width, height, useFrame

Remarks

Return Value

Samples
InsertMedia Description
Inserts media such as video to editor.

Parameters
url, width, height, mediaType, isToolBar

Remarks

Return Value

Samples
InsertFormControl Description
Inserts form control to editor.

Parameters
command

Remarks

Return Value

Samples
SetValue Description
Sets value to editor, sectionName should be empty if it is single section.

Parameters
contentString, sectionName

Remarks

Return Value

Samples
GetValue Description
Gets value from editor, sectionName should be empty if it is single section.

Parameters
sectionName

Remarks

Return Value

Samples
ShowUploadingProgress Description
Shows uploading progress.

Parameters
percentage, msg

Remarks

Return Value

Samples
HideUploadingProgress Description
Hides uploading progress.

Parameters

Remarks

Return Value

Samples
RefreshMediaGallery Description
Refresh media gallery.

Parameters

Remarks

Return Value

Samples
GetUploadLocations Description
Gets upload locations.

Parameters

Remarks

Return Value

Samples
OnToolbarCommandNotify Description

Parameters
commandName, toggleState, enabledState, isFloatingToolbar

Remarks

Return Value

Samples
SaveContent Description
Saves WebTextEditor content client side method. If it is single section then sectionName can be empty. sectionName can be specified with "All" if user wants to save all sections.

Parameters
sectionName

Remarks

Return Value

Samples
ShowUploadingProgress Description
Shows uploading progress.

Parameters
percentage, msg

Remarks

Return Value

Samples
HideUploadingProgress Description
Hides uploading progress.

Parameters

Remarks

Return Value

Samples
RefreshMediaGallery Description
Refresh media gallery.

Parameters

Remarks

Return Value

Samples
GetUploadLocations Description
Gets upload locations.

Parameters

Remarks

Return Value

Samples
OnToolbarCommandNotify Description

Parameters
commandName, toggleState, enabledState, isFloatingToolbar

Remarks

Return Value

Samples
SaveContent Description
Saves WebTextEditor content client side method. If it is single section then sectionName can be empty. sectionName can be specified with "All" if user wants to save all sections.

Parameters
sectionName

Remarks

Return Value

Samples

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


WebTextEditorClientSideEvents

WebTextEditorClientSideEvents
Send Feedback
Intersoft WebTextEditor > Client-side References > WebTextEditorClientSideEvents

Glossary Item Box

WebTextEditorClientSideEvents Properties

OnAfterExecCommand | Description Gets or sets the event handler after execCommand is executed. Parameters controlId, action Default Value -
OnBeforeExecCommand | Description Gets or sets the event handler before execCommand is executed. Parameters controlId, action Default Value -
OnEditorContextMenu | Description Gets or sets the event handler when context menu is about to show. Parameters controlId, menuObject Default Value -
OnInitialize | Description Gets or sets the event handler when WebTextEditor is initialized. Parameters controlId Default Value -
OnSave | Description Gets or sets the event handler before save is executed. Parameters controlId Default Value -
OnToolBarClick | Description Gets or sets the event handler when toolbar is clicked. Parameters controlId, command, commandSection Default Value -
OnResponse | Description Gets or sets the event handler that will be invoked when a response from server is returned. Parameters controlId, status Default Value -
OnSendMailCompleted | Description Gets or sets the event handler that will be invoked when send mail action is completed. Parameters controlId, failed, failedEmails Default Value -
OnSendMailCompleted | Description Gets or sets the event handler that will be invoked when send mail action is completed. Parameters controlId, failed, failedEmails Default Value -
OnKeyDown | Description Gets or sets the event handler that will be invoked when there is key down action in editor. Parameters - Default Value -
OnMediaSelected | Description Gets or sets the event handler that will be invoked when a media is selected. Parameters - Default Value -
OnBeforeResize | Description Gets or sets the event handler that will be invoked before the editor is resized. Parameters - Default Value -
OnAfterResize | Description Gets or sets the event handler that will be invoked after the editor is resized. Parameters - Default Value -
OnBeforeUpload | Description Gets or sets the event handler that will be invoked before file(s) are uploaded. Parameters - Default Value -
OnUploaderValidate | Description Gets or sets the event handler that will be invoked when validating a file that is added to the integrated file uploader. Parameters - Default Value -
OnUploading | Description Gets or sets the event handler that will be invoked when a file is being uploaded. Parameters - Default Value -
OnAfterUpload | Description Gets or sets the event handler that will be invoked after a file is uploaded. Parameters - Default Value -
OnCancelUpload | Description Gets or sets the event handler that will be invoked when an uploading file process is cancelled. Parameters - Default Value -
OnUploaderInitialize | Description Gets or sets the event handler that will be invoked when the integrated file uploader is being initialized. Parameters - Default Value -
OnUploaderError | Description Gets or sets the event handler that will be invoked when an error occurred during file uploading process. Parameters - Default Value -
OnUploaderCompleted | Description Gets or sets the event handler that will be invoked when uploading process has been completed regardless of the individual upload status. Parameters - Default Value -
OnUploaderFileAdded | Description Gets or sets the event handler that will be invoked when a file is added to the integrated file uploader. Parameters - Default Value -
OnUploaderFileRemoved | Description Gets or sets the event handler that will be invoked when a file is removed from the integrated file uploader. Parameters controlId, failed, failedEmails Default Value -

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


WebSpellChecker

WebSpellChecker
Send Feedback
Intersoft WebTextEditor > Client-side References > WebSpellChecker

Glossary Item Box

WebSpellChecker Properties

ScriptDirectory | Description Gets or sets the directory where all required scripts for the control are stored. ValueType Default Value
ImagesDirectory | Description Gets or sets the images directory. ValueType Default Value
ViewStateStorage | Description Gets or sets the location to store the viewstate of this control. ValueType Default Value
AccessKey | Description Keyboard shortcut used by the control. ValueType Default Value
TabIndex | Description The tab order of the control. ValueType Default Value
ToolTip | Description The tooltip displayed when the mouse is over the control. ValueType Default Value
TargetControlId | Description Specifies the target ControlId of WebSpellChecker. ValueType Default Value
TargetControlIdValue | Description Gets or sets the TargetControlId's value. ValueType Default Value
IntegratedToWebTextEditor | Description Determines whether WebSpellChecker is integrated with WebTextEditor. ValueType Default Value
ImagesSettings | Description Provides the settings that control the images in WebSpellChecker. ValueType Default Value
TextSettings | Description Provides the settings that control the text in WebSpellChecker. ValueType Default Value
ClientSideEvents | Description Contains Client-side events supported by WebSpellChecker. ValueType Default Value
AllowAddToDictionary | Description Determines whether AddToDictionay menu should appear in context menu. ValueType Default Value

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


WebSpellCheckerClientSideEvents

WebSpellCheckerClientSideEvents
Send Feedback
Intersoft WebTextEditor > Client-side References > WebSpellCheckerClientSideEvents

Glossary Item Box

WebSpellCheckerClientSideEvents Properties

OnInitialize | Description Gets or sets the event handler when WebSpellChecker is initialized. Parameters controlId Default Value -
OnBeforeCheckSpell | Description Gets or sets the event handler before check spell is performed. Parameters controlId Default Value -
OnAfterCheckSpell | Description Gets or sets the event handler after check spell is performed. Parameters controlId Default Value -
OnContextMenu | Description Gets or sets the event handler when WebSpellChecker's context menu is about to be displayed. Parameters controlId, menuObject, element Default Value -
OnClickContextMenuItem | Description Gets or sets the event handler before save is executed.Gets or sets the event handler when context menu item is clicked. Parameters controlId, menuObj, action Default Value -
OnExitSpellCheck | Description Gets or sets the event handler when exit spell check. Parameters controlId Default Value -
OnReplaceWord | Description Gets or sets the event handler when WebSpellChecker replace word. Parameters controlId, menuItem, originalWord, suggestionWords Default Value -
OnSpellCheckingCompleted | Description Gets or sets the event handler when spell checking is completed. Parameters controlId Default Value -

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


WebSpellCheckerImagesSettings

WebSpellCheckerImagesSettings
Send Feedback
Intersoft WebTextEditor > Client-side References > WebSpellCheckerImagesSettings

Glossary Item Box

WebSpellCheckerImagesSettings Properties

ErrorLine | Description Gets or sets the default image used for error line. ValueType Default Value
InProgress | Description Gets or sets the default image used for In Progress status. ValueType Default Value

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


WebSpellCheckerTextSettings

WebSpellCheckerTextSettings
Send Feedback
Intersoft WebTextEditor > Client-side References > WebSpellCheckerTextSettings

Glossary Item Box

WebSpellCheckerTextSettings Properties

AddToDictionaryText | Description Specifies the text of AddToDictionary option in context menu. ValueType Default Value
IgnoreText | Description Specifies the text of ignore option in context menu. ValueType Default Value
IgnoreAllText | Description Specifies the text of ignore all text option in context menu. ValueType Default Value

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


WebFileUploader

WebFileUploader
Send Feedback
Intersoft WebTextEditor > Client-side References > WebFileUploader

Glossary Item Box

WebFileUploader Properties

ScriptDirectory | Description Gets or sets the directory where all required scripts for the control are stored. ValueType Default Value
ImagesDirectory | Description Gets or sets the directory where all required images for the control are stored. ValueType Default Value
UILayout | Description Specifies the layout to be used in the control. ValueType Default Value
DefaultButtonHeight | Description Specifies the default height of the button. ValueType Default Value
DefaultButtonWidth | Description Specifies the default width of the button. ValueType Default Value
DefaultTextBoxHeight | Description Specifies the default height of the text box. ValueType Default Value
DefaultTextBoxWidth | Description Specifies the default width of the text box. ValueType Default Value
DefaultSelectButtonHeight | Description Specifies the default height of the select button. ValueType Default Value
DefaultSelectButtonWidth | Description Specifies the default width of the select button. ValueType Default Value
DefaultProgressBarHeight | Description Specifies the default height of the progress bar. ValueType Default Value
Caption | Description Specifies the caption of the control. ValueType Default Value
UploadType | Description Specifies the type of upload. ValueType Default Value
PriorityUploadType | Description Specifies the priority of upload type. ValueType Default Value
FileTypes | Description Specifies the types of file. ValueType Default Value
UploadSizeLimit | Description The number of bytes that can be uploaded (0 for no limit) for each file. ValueType Default Value
FilesCount | Description The total number of file that can be uploaded (0 for no limit). ValueType Default Value
InitialFilesCount | Description The initial total number of file that can be uploaded (0 for no limit). ValueType Default Value
AllowCancel | Description Determine whether allow cancel is enabled. ValueType Default Value
AllowSimultaneousUpload | Description Gets or sets a value indicating whether simultaneous upload is allowed. ValueType Default Value
ClientSideEvents | Description Contains Client-side events supported by WebFileUploader. ValueType Default Value
ProgressInformation | Description Provides settings that control progress information in WebFileUploader. ValueType Default Value
TextSettings | Description Provides settings that control text shown in WebFileUploader. ValueType Default Value
ImageSettings | Description Provides settings that control images in WebTextEditor. ValueType Default Value
StyleSettings | Description Provides settings that control styles in WebTextEditor. ValueType Default Value

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


WebFileUploaderClientSideEvents
Send Feedback
Intersoft WebTextEditor > Client-side References > WebFileUploaderClientSideEvents

Glossary Item Box

WebFileUploaderClientSideEvents

OnBeforeUpload | Description Specifies the Client-side function name that will be invoked before a file is uploaded. ValueType Default Value
OnValidate | Description Specifies the Client-side function name that will be invoked when custom validating an upload file. ValueType Default Value
OnAfterUpload | Description Specifies the Client-side function name that will be invoked when a file is uploaded. ValueType Default Value
OnCancelUpload | Description Specifies the Client-side function name that will be invoked when uploading a file is cancelled. ValueType Default Value
OnInitialize | Description Specifies the Client-side function name that will be invoked when control is initialized. ValueType Default Value
OnError | Description Specifies the Client-side function name that will be invoked when an error occured during file uploading process. ValueType Default Value
OnCompleted | Description Specifies the Client-side function name that will be invoked when the uploading process has been completed regardless of the individual upload status. ValueType Default Value
OnFileAdded | Description Specifies the Client-side function name that will be invoked when a file is added to uploader. ValueType Default Value
OnFileRemoved | Description Specifies the Client-side function name that will be invoked when a file is removed from uploader. ValueType Default Value

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


WebFileUploaderTextSettings

WebFileUploaderTextSettings
Send Feedback
Intersoft WebTextEditor > Client-side References > WebFileUploaderTextSettings

Glossary Item Box

WebFileUploaderTextSettings Properties

ButtonSelectText | Description Get or sets the text button when select file. ValueType Default Value
ButtonCancelText | Description Gets or sets the text button when cancel the file. ValueType Default Value
ButtonUploadingText | Description Gets or sets the text button when uploading the file. ValueType Default Value
ButtonUploadedText | Description Gets or sets the text button when file is uploaded. ValueType Default Value
ButtonErrorText | Description Gets or sets the text button when there is an error occured in file uploading. ValueType Default Value
ButtonCancellingText | Description Gets or sets the text button when cancelling the file. ValueType Default Value
ButtonCancelledText | Description Gets or sets the text button when file upload is cancelled. ValueType Default Value
AbortText | Description Gets or sets the text button when file upload is aborted. ValueType Default Value
MessageText | Description Gets or sets the text information message when upload process is finished. ValueType Default Value
ButtonAddText | Description Gets or sets the text button when add file. ValueType Default Value
ButtonRemoveText | Description Gets or sets the text button when remove file. ValueType Default Value
ButtonUploadText | Description Gets or sets the text button when upload file. ValueType Default Value
ProgressBarStatusText | Description Gets or sets the text status when the progress bar is completed. ValueType Default Value
ProgressBarStatusErrorText | Description Gets or sets the text status when the progress bar results error. ValueType Default Value
ProgressBarTotalStatusText | Description Gets or sets the text status (in number) when the progress bar is completed. ValueType Default Value
ProgressAreaOKButtonText | Description Gets or sets the text button in the progress area. ValueType Default Value

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


WebFileUploaderImagesSettings

WebFileUploaderImagesSettings
Send Feedback
Intersoft WebTextEditor > Client-side References > WebFileUploaderImagesSettings

Glossary Item Box

WebFileUploaderImagesSetting Properties

Abort | Description Sets the abort button image. ValueType Default Value
BgColorButton | Description Sets the background color button. ValueType Default Value
Delete | Description Sets the delete button image. ValueType Default Value
Failed | Description Sets the failed button image. ValueType Default Value
Progress | Description Sets the progress image. ValueType Default Value
Required | Description Sets the required button image. ValueType Default Value
Success | Description Sets the success button image. ValueType Default Value

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Product Support

Product Support
Send Feedback
Intersoft WebTextEditor > Product Support

Glossary Item Box

This section contains product support in WebTextEditor.

In This Section

Bug Reports

Support Options

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Bug Reports

Bug Reports
Send Feedback
Intersoft WebTextEditor > Product Support > Bug Reports

Glossary Item Box

Please submit any bugs or product issues to technical@intersoftpt.com

When submitting the bug report, make sure you have following information to avoid multiple communication roundtrip:

  • Product Edition (if applicable)
  • Full Product Version. Eg: 1.0.1500
  • Browsers (with Full Version, including Service Packs or HotFixes if any)
  • Operating System (with Full Version, including Service Packs or HotFixes if any)
  • Development Environment Products
  • Development Environment Versions
  • Affected Machines: Development, Production Server or Both
  • Monitors: Single or Dual

You also might need to provide issue-specific information such as:

  • Current result/behavior
  • Expected result/behavior
  • Steps to reproduce
  • Working/Compilable Samples

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Support Options

Support Options
Send Feedback
Intersoft WebTextEditor > Product Support > Support Options

Glossary Item Box

Intersoft Presenter is developed and fully supported by Intersoft Solutions Corp. The company provides several methods for registered customers to obtain technical supports.

Online Support

All of Intersoft Presenter users have free access to our online support at www.intersoftpt.com which includes latest product updates, bug fixes, FAQ, hundreds of Knowledge Base Articles.

Standard Email Support

You can also send email to technical@intersoftpt.com for product troubleshooting or bugs. Please provides information on the product version, operating system name and version as well as your development environment and its version. Your email will be answered shortly by our technical support team.

The turnaround time for standard email support is 72 hours (at the latest).

Before sending out your email, we highly recommend you to initially search for the information on locally installed Reference and Online Support.

Developer Network Support

The company provides a rich web-based forums for registered customers to discuss about the product. You may find information and answer to your questions in the forums, or simply posting your message in the forums and our technical support team will answer it in short time.

To access the Developer Network, please go to Intersoft website and click on Developer Network.

Login details are required to access Developer Network. Please refer to your original order receipt sent from Intersoft Accounts. If you do not get the automated order receipt, please contact accounts@intersoftpt.com

Priority Support Options

The NEW Priority Support option allows registered customers to obtain technical support via direct e-mail or telephone support from our Senior Support Engineer.

This option is designated for advanced customers who require faster response time. The inquiries types are mostly intermediate to advanced involving application-specific scenarios, minor feature requests, quick patches and more.

For more information about the Priority Support pricing and online purchase, please visit Intersoft Solutions web site at http://www.intersoftpt.com

Phone Support

Phone Support is currently available only for registered customers who have purchased Priority Support. You can reach Technical Support through following numbers:

  • +62 21 25556680
  • +62 21 25556681
Please have your UserID ready when calling.

For pre-sales phone support, you may contact our Authorized Distributor at no cost.

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Licensing

Licensing
Send Feedback
Intersoft WebTextEditor > Licensing

Glossary Item Box

This section contains licensing in WebTextEditor.

In This Section

License Agreement

Copyright Information

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


License Agreement

License Agreement
Send Feedback
Intersoft WebTextEditor > Licensing > License Agreement

Glossary Item Box

Software License Agreement for Intersoft Solutions Corp.

VERY IMPORTANT -- By installing the WebTextEditor Version 1.0 software (herein the 'SOFTWARE') developed by Intersoft Solutions Corp (hereinafter the 'VENDOR'), you are accepting the following License Agreement.

I. LICENSE AGREEMENT. This is a legal agreement between you (either an individual or a single entity) and VENDOR. By installing the SOFTWARE you are agreeing to be bound by the terms of this agreement. If you do not agree to the terms of this agreement, please kindly click the [CANCEL] icon to exit now. The installation process will be immediately terminated.

II. OWNERSHIP; GRANT OF LICENSE. This is a license agreement and NOT an agreement for sale. The VENDOR hereby grants to you, and you accept, a non-exclusive, non-transferable license to use, copy and modify the SOFTWARE only as authorized below.

III. PERMITTED USES. This LICENSE grants you the following rights:

A. The SOFTWARE is licensed per individual developer. You may make copies on more than one computer, as long as the use of the SOFTWARE is by the same developer. If you have purchased a "multi-pack" license, you may use a copy of the SOFTWARE identified in the multi-pack on the number of computers associated with the multi-pack (e.g. a five user multi-pack allows you to use the SOFTWARE on up to five computers concurrently or by five different developers, the ten user multi-pack on up to ten computers concurrently or by ten different developers). The SOFTWARE is in "use" on a computer when it is loaded into temporary memory (i.e. RAM) or installed into permanent memory (e.g. hard disk, CD-ROM, or other storage devise) of that computer. However, installation on a network server for the sole purpose of internal distribution to one or more other computer(s) shall not constitute "use" for which a separate license is required, provided you have a separate license for each computer to which the SOFTWARE is distributed.

B. Solely with respect to electronic documents included with the SOFTWARE, you may make a copy (either in hardcopy or electronic form) for each developer for which the Software has been licensed as described in Section III.A, above; provided, that such copies shall be used only by such developer for internal purposes and are not to be republished or distributed to any other third party.

C. Runtime and redistributable files. You may deploy your web applications using the SOFTWARE to any number of production server or clients with no additional charges. The SOFTWARE runtime files shouldn't be modified in any ways prior to deploying and all copyright notices should be retain.

IV. PROHIBITED USES. You may not, without the prior written permission of the VENDOR:

A. Disassemble, decompile or "unlock", decode or otherwise reverse translate or engineer, or attempt in any manner to reconstruct or discover any source code or underlying algorithms of SOFTWARE provided in object code form only.

B. Use, copy, modify, or merge copies of the SOFTWARE and any accompanying documents except as permitted in this LICENSE.

C. Transfer, rent, lease, or sublicense the SOFTWARE.

D. Separate the software programs comprising the SOFTWARE for use by more than one user at a time.

V. COPYRIGHT. All title and copyrights in and to the SOFTWARE (including but not limited to any images, photographs, animation, video, audio, music, text and "applets" incorporated into the SOFTWARE) and the accompanying printed materials are owned by the VENDOR or its suppliers. The SOFTWARE is protected by Indonesian copyright laws and international treaty provisions. All rights are reserved worldwide. You must treat the SOFTWARE like any other copyrighted material, except that you may, in addition to the copies permitted in this LICENSE, make one copy of the SOFTWARE solely for backup or archival purposes. No part of the accompanying printed materials may be reproduced, transmitted, transcribed, stored in any retrieval system, or translated into any language by any means without the express prior written permission of the VENDOR.

VI. TERMINATION

A. This LICENSE and your right to use the SOFTWARE will terminate immediately without notice from the VENDOR if you fail to comply with the terms and conditions of this LICENSE. Upon termination, you agree to destroy the SOFTWARE, including all accompanying documents and copies. This is in addition to and not in lieu of any criminal, civil or other remedies available to the VENDOR.

B. The VENDOR has the right to perform temporary or permanent TERMINATION to this LICENSE upon the detection of license violation described in Section III A. The SOFTWARE has implemented Installation Tracker which is used to increment the number of installations during the installation of SOFTWARE. Related to Section III A, the LICENSE will be temporarily or permanently terminated upon the detection of unauthorized transfer or distribution of the LICENSE to either private or public web site, or to ANY medium.

C. ANY VIOLATION TO THE COPYRIGHT, OR TO THIS LICENSE AGREEMENT, MAY RESULT IN SEVERE CIVIL AND CRIMINAL PENALTIES, AND WILL BE PROSECUTED TO THE MAXIMUM EXTENT POSSIBLE UNDER THE LAW.

VII. LIMITED WARRANTY.

A. The VENDOR warrants that the SOFTWARE will perform substantially in accordance with the accompanying printed materials or officially "online" documented materials for a period of thirty (30) days from the date of receipt. The VENDOR does not warranty that the SOFTWARE will be error-free.

B. Your exclusive remedy under the performance warranty set forth in Section X.A, shall be, at VENDOR's option, either (a) return of the purchase price paid, or (b) repair or replacement of the defective SOFTWARE. SOFTWARE purchased other than directly from the VENDOR shall be returned to the place it was purchased. This limited warranty is void if failure of the SOFTWARE has resulted from accident, abuse, or misapplication. Any replacement SOFTWARE will be warranted for the remainder of the original thirty (30) day period.

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Copyright Information

Copyright Information
Send Feedback
Intersoft WebTextEditor > Licensing > Copyright Information

Glossary Item Box

Information in this document, including URL and other Internet Web site references, is subject to change without notice. Complying with all applicable copyright laws is the responsibility of the user. Without limiting the rights under copyright, no part of this document may be reproduced, stored in or introduced into a retrieval system, or transmitted in any form or by any means (electronic, mechanical, photocopying, recording, or otherwise), or for any purpose, without the express written permission of Intersoft Solutions Corp.

Intersoft Solutions, Intersoft Solutions Logo, A Better Web Experience, WebUI.NET Framework, WebUI.NET Framework Logo, WebUI Studio.NET Family, WebCombo.NET, WebGrid.NET Enterprise, WebInput.NET, WebUIControls.NET, ISDataSource.NET, WebDesktop.NET, WebTreeView.NET , WebAqua.NET, WebScheduler.NET, Intersoft Presenter are either trademarks or registered trademarks of Intersoft Solutions Corporation.

Copyright © 2000-2009 Intersoft Solutions Corp. All rights reserved.

ActiveX, Internet Explorer, Microsoft, Visual Basic, Visual Basic .NET, Visual C# .NET, Visual C++ .NET, Visual Studio, Visual Studio .NET, Windows, Windows 95, Windows 98, Windows 2000, Windows Millennium Edition, Windows .NET server family, Windows NT, Windows XP and Windows Vista are either registered trademarks or trademarks of Microsoft Corporation in the United States and/or other countries.

The names of actual companies and products mentioned herein may be the trademarks or registered trademarks of their respective owners.

© 2013 Intersoft Solutions Corp. All Rights Reserved.

©2013. All Rights Reserved.


Assembly Overview

ISNet.WebUI.WebTextEditor Assembly
See Also Send Feedback

Glossary Item Box

Namespaces

Namespace | Description
ISNet.WebUI.WebTextEditor |


Getting Started - Intersoft WebTextEditor Documentation

Getting Started
Send Feedback

Glossary Item Box


Introduction - Intersoft WebTextEditor Documentation

Introduction
Send Feedback

Glossary Item Box


ImageListForm Class Events

[image]
Intersoft WebTextEditor Documentation
ImageListForm Class Events
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : ImageListForm Class

Glossary Item Box

For a list of all members of this type, see ImageListForm members.

Public Events

 | Name | Description
Public Event | Activated | (Inherited from System.Windows.Forms.Form)
Public Event | AutoSizeChanged | (Inherited from System.Windows.Forms.Form)
Public Event | AutoValidateChanged | (Inherited from System.Windows.Forms.Form)
Public Event | BackColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BackgroundImageLayoutChanged | (Inherited from System.Windows.Forms.Control)
Public Event | BindingContextChanged | (Inherited from System.Windows.Forms.Control)
Public Event | CausesValidationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ChangeUICues | (Inherited from System.Windows.Forms.Control)
Public Event | Click | (Inherited from System.Windows.Forms.Control)
Public Event | ClientSizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ContextMenuStripChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ControlAdded | (Inherited from System.Windows.Forms.Control)
Public Event | ControlRemoved | (Inherited from System.Windows.Forms.Control)
Public Event | CursorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Deactivate | (Inherited from System.Windows.Forms.Form)
Public Event | Disposed | (Inherited from System.ComponentModel.Component)
Public Event | DockChanged | (Inherited from System.Windows.Forms.Control)
Public Event | DoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | DragDrop | (Inherited from System.Windows.Forms.Control)
Public Event | DragEnter | (Inherited from System.Windows.Forms.Control)
Public Event | DragLeave | (Inherited from System.Windows.Forms.Control)
Public Event | DragOver | (Inherited from System.Windows.Forms.Control)
Public Event | EnabledChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Enter | (Inherited from System.Windows.Forms.Control)
Public Event | FontChanged | (Inherited from System.Windows.Forms.Control)
Public Event | ForeColorChanged | (Inherited from System.Windows.Forms.Control)
Public Event | FormClosed | (Inherited from System.Windows.Forms.Form)
Public Event | FormClosing | (Inherited from System.Windows.Forms.Form)
Public Event | GiveFeedback | (Inherited from System.Windows.Forms.Control)
Public Event | GotFocus | (Inherited from System.Windows.Forms.Control)
Public Event | HandleCreated | (Inherited from System.Windows.Forms.Control)
Public Event | HandleDestroyed | (Inherited from System.Windows.Forms.Control)
Public Event | HelpButtonClicked | (Inherited from System.Windows.Forms.Form)
Public Event | HelpRequested | (Inherited from System.Windows.Forms.Control)
Public Event | ImeModeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | InputLanguageChanged | (Inherited from System.Windows.Forms.Form)
Public Event | InputLanguageChanging | (Inherited from System.Windows.Forms.Form)
Public Event | Invalidated | (Inherited from System.Windows.Forms.Control)
Public Event | KeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | KeyPress | (Inherited from System.Windows.Forms.Control)
Public Event | KeyUp | (Inherited from System.Windows.Forms.Control)
Public Event | Layout | (Inherited from System.Windows.Forms.Control)
Public Event | Leave | (Inherited from System.Windows.Forms.Control)
Public Event | Load | (Inherited from System.Windows.Forms.Form)
Public Event | LocationChanged | (Inherited from System.Windows.Forms.Control)
Public Event | LostFocus | (Inherited from System.Windows.Forms.Control)
Public Event | MaximizedBoundsChanged | (Inherited from System.Windows.Forms.Form)
Public Event | MaximumSizeChanged | (Inherited from System.Windows.Forms.Form)
Public Event | MdiChildActivate | (Inherited from System.Windows.Forms.Form)
Public Event | MenuComplete | (Inherited from System.Windows.Forms.Form)
Public Event | MenuStart | (Inherited from System.Windows.Forms.Form)
Public Event | MinimumSizeChanged | (Inherited from System.Windows.Forms.Form)
Public Event | MouseCaptureChanged | (Inherited from System.Windows.Forms.Control)
Public Event | MouseClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDoubleClick | (Inherited from System.Windows.Forms.Control)
Public Event | MouseDown | (Inherited from System.Windows.Forms.Control)
Public Event | MouseEnter | (Inherited from System.Windows.Forms.Control)
Public Event | MouseHover | (Inherited from System.Windows.Forms.Control)
Public Event | MouseLeave | (Inherited from System.Windows.Forms.Control)
Public Event | MouseMove | (Inherited from System.Windows.Forms.Control)
Public Event | MouseUp | (Inherited from System.Windows.Forms.Control)
Public Event | MouseWheel | (Inherited from System.Windows.Forms.Control)
Public Event | Move | (Inherited from System.Windows.Forms.Control)
Public Event | PaddingChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Paint | (Inherited from System.Windows.Forms.Control)
Public Event | ParentChanged | (Inherited from System.Windows.Forms.Control)
Public Event | PreviewKeyDown | (Inherited from System.Windows.Forms.Control)
Public Event | QueryAccessibilityHelp | (Inherited from System.Windows.Forms.Control)
Public Event | QueryContinueDrag | (Inherited from System.Windows.Forms.Control)
Public Event | RegionChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Resize | (Inherited from System.Windows.Forms.Control)
Public Event | ResizeBegin | (Inherited from System.Windows.Forms.Form)
Public Event | ResizeEnd | (Inherited from System.Windows.Forms.Form)
Public Event | RightToLeftChanged | (Inherited from System.Windows.Forms.Control)
Public Event | RightToLeftLayoutChanged | (Inherited from System.Windows.Forms.Form)
Public Event | Scroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Event | Shown | (Inherited from System.Windows.Forms.Form)
Public Event | SizeChanged | (Inherited from System.Windows.Forms.Control)
Public Event | StyleChanged | (Inherited from System.Windows.Forms.Control)
Public Event | SystemColorsChanged | (Inherited from System.Windows.Forms.Control)
Public Event | TextChanged | (Inherited from System.Windows.Forms.Control)
Public Event | Validated | (Inherited from System.Windows.Forms.Control)
Public Event | Validating | (Inherited from System.Windows.Forms.Control)
Public Event | VisibleChanged | (Inherited from System.Windows.Forms.Control)
Top

See Also

Reference

ImageListForm Class
ISNet.WebUI.WebTextEditor Namespace


ImageListForm Class Properties

[image]
Intersoft WebTextEditor Documentation
ImageListForm Class Properties
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : ImageListForm Class

Glossary Item Box

For a list of all members of this type, see ImageListForm members.

Public Properties

 | Name | Description
Public Property | AcceptButton | (Inherited from System.Windows.Forms.Form)
Public Property | AccessibilityObject | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDefaultActionDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleDescription | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleName | (Inherited from System.Windows.Forms.Control)
Public Property | AccessibleRole | (Inherited from System.Windows.Forms.Control)
Public Property | ActiveControl | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | ActiveMdiChild | (Inherited from System.Windows.Forms.Form)
Public Property | AllowDrop | (Inherited from System.Windows.Forms.Control)
Public Property | AllowTransparency | (Inherited from System.Windows.Forms.Form)
Public Property | Anchor | (Inherited from System.Windows.Forms.Control)
Public Property | AutoScaleDimensions | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScaleMode | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | AutoScroll | (Inherited from System.Windows.Forms.Form)
Public Property | AutoScrollMargin | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollMinSize | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoScrollOffset | (Inherited from System.Windows.Forms.Control)
Public Property | AutoScrollPosition | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | AutoSize | (Inherited from System.Windows.Forms.Form)
Public Property | AutoSizeMode | (Inherited from System.Windows.Forms.Form)
Public Property | AutoValidate | (Inherited from System.Windows.Forms.Form)
Public Property | BackColor | (Inherited from System.Windows.Forms.Form)
Public Property | BackgroundImage | (Inherited from System.Windows.Forms.Control)
Public Property | BackgroundImageLayout | (Inherited from System.Windows.Forms.Control)
Public Property | BindingContext | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | Bottom | (Inherited from System.Windows.Forms.Control)
Public Property | Bounds | (Inherited from System.Windows.Forms.Control)
Public Property | CancelButton | (Inherited from System.Windows.Forms.Form)
Public Property | CanFocus | (Inherited from System.Windows.Forms.Control)
Public Property | CanSelect | (Inherited from System.Windows.Forms.Control)
Public Property | Capture | (Inherited from System.Windows.Forms.Control)
Public Property | CausesValidation | (Inherited from System.Windows.Forms.Control)
Public Property | ClientRectangle | (Inherited from System.Windows.Forms.Control)
Public Property | ClientSize | (Inherited from System.Windows.Forms.Form)
Public Property | CompanyName | (Inherited from System.Windows.Forms.Control)
Public Property | Container | (Inherited from System.ComponentModel.Component)
Public Property | ContainsFocus | (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenu | (Inherited from System.Windows.Forms.Control)
Public Property | ContextMenuStrip | (Inherited from System.Windows.Forms.Control)
Public Property | ControlBox | (Inherited from System.Windows.Forms.Form)
Public Property | Controls | (Inherited from System.Windows.Forms.Control)
Public Property | Created | (Inherited from System.Windows.Forms.Control)
Public Property | CurrentAutoScaleDimensions | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | Cursor | (Inherited from System.Windows.Forms.Control)
Public Property | DataBindings | (Inherited from System.Windows.Forms.Control)
Public Property | DesktopBounds | (Inherited from System.Windows.Forms.Form)
Public Property | DesktopLocation | (Inherited from System.Windows.Forms.Form)
Public Property | DialogResult | (Inherited from System.Windows.Forms.Form)
Public Property | DisplayRectangle | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Disposing | (Inherited from System.Windows.Forms.Control)
Public Property | Dock | (Inherited from System.Windows.Forms.Control)
Public Property | Enabled | (Inherited from System.Windows.Forms.Control)
Public Property | Focused | (Inherited from System.Windows.Forms.Control)
Public Property | Font | (Inherited from System.Windows.Forms.Control)
Public Property | ForeColor | (Inherited from System.Windows.Forms.Control)
Public Property | FormBorderStyle | (Inherited from System.Windows.Forms.Form)
Public Property | Handle | (Inherited from System.Windows.Forms.Control)
Public Property | HasChildren | (Inherited from System.Windows.Forms.Control)
Public Property | Height | (Inherited from System.Windows.Forms.Control)
Public Property | HelpButton | (Inherited from System.Windows.Forms.Form)
Public Property | HorizontalScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Icon | (Inherited from System.Windows.Forms.Form)
Public Property | ImeMode | (Inherited from System.Windows.Forms.Control)
Public Property | InvokeRequired | (Inherited from System.Windows.Forms.Control)
Public Property | IsAccessible | (Inherited from System.Windows.Forms.Control)
Public Property | IsDisposed | (Inherited from System.Windows.Forms.Control)
Public Property | IsHandleCreated | (Inherited from System.Windows.Forms.Control)
Public Property | IsMdiChild | (Inherited from System.Windows.Forms.Form)
Public Property | IsMdiContainer | (Inherited from System.Windows.Forms.Form)
Public Property | IsMirrored | (Inherited from System.Windows.Forms.Control)
Public Property | IsRestrictedWindow | (Inherited from System.Windows.Forms.Form)
Public Property | KeyPreview | (Inherited from System.Windows.Forms.Form)
Public Property | LayoutEngine | (Inherited from System.Windows.Forms.Control)
Public Property | Left | (Inherited from System.Windows.Forms.Control)
Public Property | Location | (Inherited from System.Windows.Forms.Form)
Public Property | MainMenuStrip | (Inherited from System.Windows.Forms.Form)
Public Property | MaximizeBox | (Inherited from System.Windows.Forms.Form)
Public Property | MaximumSize | (Inherited from System.Windows.Forms.Form)
Public Property | MdiChildren | (Inherited from System.Windows.Forms.Form)
Public Property | MdiParent | (Inherited from System.Windows.Forms.Form)
Public Property | Menu | (Inherited from System.Windows.Forms.Form)
Public Property | MergedMenu | (Inherited from System.Windows.Forms.Form)
Public Property | MinimizeBox | (Inherited from System.Windows.Forms.Form)
Public Property | MinimumSize | (Inherited from System.Windows.Forms.Form)
Public Property | Modal | (Inherited from System.Windows.Forms.Form)
Public Property | Name | (Inherited from System.Windows.Forms.Control)
Public Property | Opacity | (Inherited from System.Windows.Forms.Form)
Public Property | OwnedForms | (Inherited from System.Windows.Forms.Form)
Public Property | Owner | (Inherited from System.Windows.Forms.Form)
Public Property | Padding | (Inherited from System.Windows.Forms.Control)
Public Property | Parent | (Inherited from System.Windows.Forms.Control)
Public Property | ParentForm | (Inherited from System.Windows.Forms.ContainerControl)
Public Property | PreferredSize | (Inherited from System.Windows.Forms.Control)
Public Property | ProductName | (Inherited from System.Windows.Forms.Control)
Public Property | ProductVersion | (Inherited from System.Windows.Forms.Control)
Public Property | RecreatingHandle | (Inherited from System.Windows.Forms.Control)
Public Property | Region | (Inherited from System.Windows.Forms.Control)
Public Property | RestoreBounds | (Inherited from System.Windows.Forms.Form)
Public Property | Right | (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeft | (Inherited from System.Windows.Forms.Control)
Public Property | RightToLeftLayout | (Inherited from System.Windows.Forms.Form)
Public Property | ShowIcon | (Inherited from System.Windows.Forms.Form)
Public Property | ShowInTaskbar | (Inherited from System.Windows.Forms.Form)
Public Property | Site | (Inherited from System.Windows.Forms.Control)
Public Property | Size | (Inherited from System.Windows.Forms.Form)
Public Property | SizeGripStyle | (Inherited from System.Windows.Forms.Form)
Public Property | StartPosition | (Inherited from System.Windows.Forms.Form)
Public Property | Tag | (Inherited from System.Windows.Forms.Control)
Public Property | Text | (Inherited from System.Windows.Forms.Form)
Public Property | Top | (Inherited from System.Windows.Forms.Control)
Public Property | TopLevel | (Inherited from System.Windows.Forms.Form)
Public Property | TopLevelControl | (Inherited from System.Windows.Forms.Control)
Public Property | TopMost | (Inherited from System.Windows.Forms.Form)
Public Property | TransparencyKey | (Inherited from System.Windows.Forms.Form)
Public Property | UseWaitCursor | (Inherited from System.Windows.Forms.Control)
Public Property | VerticalScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Public Property | Visible | (Inherited from System.Windows.Forms.Control)
Public Property | Width | (Inherited from System.Windows.Forms.Control)
Public Property | WindowState | (Inherited from System.Windows.Forms.Form)
Top

Protected Properties

 | Name | Description
Protected Property | AutoScaleFactor | (Inherited from System.Windows.Forms.ContainerControl)
Protected Property | CanEnableIme | (Inherited from System.Windows.Forms.ContainerControl)
Protected Property | CanRaiseEvents | (Inherited from System.Windows.Forms.Control)
Protected Property | CreateParams | (Inherited from System.Windows.Forms.Form)
Protected Property | DefaultCursor | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultImeMode | (Inherited from System.Windows.Forms.Form)
Protected Property | DefaultMargin | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultMaximumSize | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultMinimumSize | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultPadding | (Inherited from System.Windows.Forms.Control)
Protected Property | DefaultSize | (Inherited from System.Windows.Forms.Form)
Protected Property | DesignMode | (Inherited from System.ComponentModel.Component)
Protected Property | DoubleBuffered | (Inherited from System.Windows.Forms.Control)
Protected Property | Events | (Inherited from System.ComponentModel.Component)
Protected Property | FontHeight | (Inherited from System.Windows.Forms.Control)
Protected Property | HScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Protected Property | ImeModeBase | (Inherited from System.Windows.Forms.Control)
Protected Property | MaximizedBounds | (Inherited from System.Windows.Forms.Form)
Protected Property | ResizeRedraw | (Inherited from System.Windows.Forms.Control)
Protected Property | ScaleChildren | (Inherited from System.Windows.Forms.Control)
Protected Property | ShowWithoutActivation | (Inherited from System.Windows.Forms.Form)
Protected Property | VScroll | (Inherited from System.Windows.Forms.ScrollableControl)
Top

See Also

Reference

ImageListForm Class
ISNet.WebUI.WebTextEditor Namespace


AcceptButton Property

[image]
Intersoft WebTextEditor Documentation
AcceptButton Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : AcceptButton Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<SRDescriptionAttribute("The accept button of the form. If this is set, the button is 'clicked' whenever the user presses the 'ENTER' key.")>
Public Property AcceptButton As System.Windows.Forms.IButtonControl
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Windows.Forms.IButtonControl

instance.AcceptButton = value

value = instance.AcceptButton
C#
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("The accept button of the form. If this is set, the button is 'clicked' whenever the user presses the 'ENTER' key.")]
public System.Windows.Forms.IButtonControl AcceptButton {get; set;}
Delphi
public read-write property AcceptButton: System.Windows.Forms.IButtonControl;
JScript
System.ComponentModel.DefaultValueAttribute()
SRDescriptionAttribute("The accept button of the form. If this is set, the button is 'clicked' whenever the user presses the 'ENTER' key.")
public function get,set AcceptButton : System.Windows.Forms.IButtonControl
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("The accept button of the form. If this is set, the button is 'clicked' whenever the user presses the 'ENTER' key.")]
public: __property System.Windows.Forms.IButtonControl* get_AcceptButton();
public: __property void set_AcceptButton(
   System.Windows.Forms.IButtonControl* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("The accept button of the form. If this is set, the button is 'clicked' whenever the user presses the 'ENTER' key.")]
public:
property System.Windows.Forms.IButtonControl^ AcceptButton {
   System.Windows.Forms.IButtonControl^ get();
   void set (    System.Windows.Forms.IButtonControl^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


AccessibilityObject Property

[image]
Intersoft WebTextEditor Documentation
AccessibilityObject Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : AccessibilityObject Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<System.ComponentModel.BrowsableAttribute(False)>
<SRDescriptionAttribute("The accessibility object for this control.")>
Public ReadOnly Property AccessibilityObject As System.Windows.Forms.AccessibleObject
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Windows.Forms.AccessibleObject

value = instance.AccessibilityObject
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.ComponentModel.BrowsableAttribute(false)]
[SRDescriptionAttribute("The accessibility object for this control.")]
public System.Windows.Forms.AccessibleObject AccessibilityObject {get;}
Delphi
public read-only property AccessibilityObject: System.Windows.Forms.AccessibleObject;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
System.ComponentModel.BrowsableAttribute()
SRDescriptionAttribute("The accessibility object for this control.")
public function get AccessibilityObject : System.Windows.Forms.AccessibleObject
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.ComponentModel.BrowsableAttribute(false)]
[SRDescriptionAttribute("The accessibility object for this control.")]
public: __property System.Windows.Forms.AccessibleObject* get_AccessibilityObject();
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.ComponentModel.BrowsableAttribute(false)]
[SRDescriptionAttribute("The accessibility object for this control.")]
public:
property System.Windows.Forms.AccessibleObject^ AccessibilityObject {
   System.Windows.Forms.AccessibleObject^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


AccessibleDefaultActionDescription Property

[image]
Intersoft WebTextEditor Documentation
AccessibleDefaultActionDescription Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : AccessibleDefaultActionDescription Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<SRDescriptionAttribute("The default action description of the control.")>
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<SRCategoryAttribute("Accessibility")>
Public Property AccessibleDefaultActionDescription As System.String
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.String

instance.AccessibleDefaultActionDescription = value

value = instance.AccessibleDefaultActionDescription
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRDescriptionAttribute("The default action description of the control.")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[SRCategoryAttribute("Accessibility")]
public System.string AccessibleDefaultActionDescription {get; set;}
Delphi
public read-write property AccessibleDefaultActionDescription: System.String;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
SRDescriptionAttribute("The default action description of the control.")
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
SRCategoryAttribute("Accessibility")
public function get,set AccessibleDefaultActionDescription : System.String
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRDescriptionAttribute("The default action description of the control.")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[SRCategoryAttribute("Accessibility")]
public: __property System.string* get_AccessibleDefaultActionDescription();
public: __property void set_AccessibleDefaultActionDescription(
   System.string* value
);
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRDescriptionAttribute("The default action description of the control.")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[SRCategoryAttribute("Accessibility")]
public:
property System.String^ AccessibleDefaultActionDescription {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


AccessibleDescription Property

[image]
Intersoft WebTextEditor Documentation
AccessibleDescription Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : AccessibleDescription Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.LocalizableAttribute(True)>
<SRCategoryAttribute("Accessibility")>
<SRDescriptionAttribute("The description that will be reported to accessibility clients.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property AccessibleDescription As System.String
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.String

instance.AccessibleDescription = value

value = instance.AccessibleDescription
C#
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Accessibility")]
[SRDescriptionAttribute("The description that will be reported to accessibility clients.")]
[System.ComponentModel.DefaultValueAttribute()]
public System.string AccessibleDescription {get; set;}
Delphi
public read-write property AccessibleDescription: System.String;
JScript
System.ComponentModel.LocalizableAttribute()
SRCategoryAttribute("Accessibility")
SRDescriptionAttribute("The description that will be reported to accessibility clients.")
System.ComponentModel.DefaultValueAttribute()
public function get,set AccessibleDescription : System.String
Managed Extensions for C++
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Accessibility")]
[SRDescriptionAttribute("The description that will be reported to accessibility clients.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.string* get_AccessibleDescription();
public: __property void set_AccessibleDescription(
   System.string* value
);
C++/CLI
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Accessibility")]
[SRDescriptionAttribute("The description that will be reported to accessibility clients.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.String^ AccessibleDescription {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


AccessibleName Property

[image]
Intersoft WebTextEditor Documentation
AccessibleName Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : AccessibleName Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.LocalizableAttribute(True)>
<SRCategoryAttribute("Accessibility")>
<SRDescriptionAttribute("The name that will be reported to accessibility clients.")>
Public Property AccessibleName As System.String
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.String

instance.AccessibleName = value

value = instance.AccessibleName
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Accessibility")]
[SRDescriptionAttribute("The name that will be reported to accessibility clients.")]
public System.string AccessibleName {get; set;}
Delphi
public read-write property AccessibleName: System.String;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.LocalizableAttribute()
SRCategoryAttribute("Accessibility")
SRDescriptionAttribute("The name that will be reported to accessibility clients.")
public function get,set AccessibleName : System.String
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Accessibility")]
[SRDescriptionAttribute("The name that will be reported to accessibility clients.")]
public: __property System.string* get_AccessibleName();
public: __property void set_AccessibleName(
   System.string* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Accessibility")]
[SRDescriptionAttribute("The name that will be reported to accessibility clients.")]
public:
property System.String^ AccessibleName {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


AccessibleRole Property

[image]
Intersoft WebTextEditor Documentation
AccessibleRole Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : AccessibleRole Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The role that will be reported to accessibility clients.")>
<System.ComponentModel.DefaultValueAttribute()>
<SRCategoryAttribute("Accessibility")>
Public Property AccessibleRole As System.Windows.Forms.AccessibleRole
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Windows.Forms.AccessibleRole

instance.AccessibleRole = value

value = instance.AccessibleRole
C#
[SRDescriptionAttribute("The role that will be reported to accessibility clients.")]
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Accessibility")]
public System.Windows.Forms.AccessibleRole AccessibleRole {get; set;}
Delphi
public read-write property AccessibleRole: System.Windows.Forms.AccessibleRole;
JScript
SRDescriptionAttribute("The role that will be reported to accessibility clients.")
System.ComponentModel.DefaultValueAttribute()
SRCategoryAttribute("Accessibility")
public function get,set AccessibleRole : System.Windows.Forms.AccessibleRole
Managed Extensions for C++
[SRDescriptionAttribute("The role that will be reported to accessibility clients.")]
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Accessibility")]
public: __property System.Windows.Forms.AccessibleRole get_AccessibleRole();
public: __property void set_AccessibleRole(
   System.Windows.Forms.AccessibleRole value
);
C++/CLI
[SRDescriptionAttribute("The role that will be reported to accessibility clients.")]
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Accessibility")]
public:
property System.Windows.Forms.AccessibleRole AccessibleRole {
   System.Windows.Forms.AccessibleRole get();
   void set (    System.Windows.Forms.AccessibleRole value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


Activate Method

[image]
Intersoft WebTextEditor Documentation
Activate Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : Activate Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Activate()
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm

instance.Activate()
C#
public void Activate()
Delphi
public procedure Activate();
JScript
public function Activate();
Managed Extensions for C++
public: void Activate();
C++/CLI
public:
void Activate();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


Activated Event

[image]
Intersoft WebTextEditor Documentation
Activated Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : Activated Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Focus")>
<SRDescriptionAttribute("Occurs whenever the form is activated.")>
Public Event Activated As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.EventHandler

AddHandler instance.Activated, handler
C#
[SRCategoryAttribute("Focus")]
[SRDescriptionAttribute("Occurs whenever the form is activated.")]
public event System.EventHandler Activated
Delphi
public event Activated: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Focus")]
[SRDescriptionAttribute("Occurs whenever the form is activated.")]
public: __event System.EventHandler* Activated
C++/CLI
[SRCategoryAttribute("Focus")]
[SRDescriptionAttribute("Occurs whenever the form is activated.")]
public:
event System.EventHandler^ Activated

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


ActivateMdiChild Method

[image]
Intersoft WebTextEditor Documentation
ActivateMdiChild Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : ActivateMdiChild Method

form

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Sub ActivateMdiChild( _
   ByVal form As System.Windows.Forms.Form _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim form As System.Windows.Forms.Form

instance.ActivateMdiChild(form)
C#
protected void ActivateMdiChild(
   System.Windows.Forms.Form form
)
Delphi
protected procedure ActivateMdiChild(
    form: System.Windows.Forms.Form
);
JScript
protected function ActivateMdiChild(
   form : System.Windows.Forms.Form
);
Managed Extensions for C++
protected: void ActivateMdiChild(
   System.Windows.Forms.Form* form
)
C++/CLI
protected:
void ActivateMdiChild(
   System.Windows.Forms.Form^ form
)

Parameters

form

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


ActiveControl Property

[image]
Intersoft WebTextEditor Documentation
ActiveControl Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : ActiveControl Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("The currently active control.")>
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property ActiveControl As System.Windows.Forms.Control
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Windows.Forms.Control

instance.ActiveControl = value

value = instance.ActiveControl
C#
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("The currently active control.")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public System.Windows.Forms.Control ActiveControl {get; set;}
Delphi
public read-write property ActiveControl: System.Windows.Forms.Control;
JScript
SRCategoryAttribute("Behavior")
SRDescriptionAttribute("The currently active control.")
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get,set ActiveControl : System.Windows.Forms.Control
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("The currently active control.")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property System.Windows.Forms.Control* get_ActiveControl();
public: __property void set_ActiveControl(
   System.Windows.Forms.Control* value
);
C++/CLI
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("The currently active control.")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property System.Windows.Forms.Control^ ActiveControl {
   System.Windows.Forms.Control^ get();
   void set (    System.Windows.Forms.Control^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


ActiveMdiChild Property

[image]
Intersoft WebTextEditor Documentation
ActiveMdiChild Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : ActiveMdiChild Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<SRDescriptionAttribute("The currently active MDI child form.")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public ReadOnly Property ActiveMdiChild As System.Windows.Forms.Form
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Windows.Forms.Form

value = instance.ActiveMdiChild
C#
[System.ComponentModel.BrowsableAttribute(false)]
[SRDescriptionAttribute("The currently active MDI child form.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public System.Windows.Forms.Form ActiveMdiChild {get;}
Delphi
public read-only property ActiveMdiChild: System.Windows.Forms.Form;
JScript
System.ComponentModel.BrowsableAttribute()
SRDescriptionAttribute("The currently active MDI child form.")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get ActiveMdiChild : System.Windows.Forms.Form
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[SRDescriptionAttribute("The currently active MDI child form.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property System.Windows.Forms.Form* get_ActiveMdiChild();
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[SRDescriptionAttribute("The currently active MDI child form.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property System.Windows.Forms.Form^ ActiveMdiChild {
   System.Windows.Forms.Form^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


AddOwnedForm Method

[image]
Intersoft WebTextEditor Documentation
AddOwnedForm Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : AddOwnedForm Method

ownedForm

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub AddOwnedForm( _
   ByVal ownedForm As System.Windows.Forms.Form _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim ownedForm As System.Windows.Forms.Form

instance.AddOwnedForm(ownedForm)
C#
public void AddOwnedForm(
   System.Windows.Forms.Form ownedForm
)
Delphi
public procedure AddOwnedForm(
    ownedForm: System.Windows.Forms.Form
);
JScript
public function AddOwnedForm(
   ownedForm : System.Windows.Forms.Form
);
Managed Extensions for C++
public: void AddOwnedForm(
   System.Windows.Forms.Form* ownedForm
)
C++/CLI
public:
void AddOwnedForm(
   System.Windows.Forms.Form^ ownedForm
)

Parameters

ownedForm

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


AdjustFormScrollbars Method

[image]
Intersoft WebTextEditor Documentation
AdjustFormScrollbars Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : AdjustFormScrollbars Method

displayScrollbars

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub AdjustFormScrollbars( _
   ByVal displayScrollbars As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim displayScrollbars As System.Boolean

instance.AdjustFormScrollbars(displayScrollbars)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void AdjustFormScrollbars(
   System.bool displayScrollbars
)
Delphi
protected procedure AdjustFormScrollbars(
    displayScrollbars: System.Boolean
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function AdjustFormScrollbars(
   displayScrollbars : System.boolean
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void AdjustFormScrollbars(
   System.bool displayScrollbars
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void AdjustFormScrollbars(
   System.bool displayScrollbars
)

Parameters

displayScrollbars

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


AllowDrop Property

[image]
Intersoft WebTextEditor Documentation
AllowDrop Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : AllowDrop Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Indicates whether the control can accept data that the user drags onto it.")>
<System.ComponentModel.DefaultValueAttribute()>
<SRCategoryAttribute("Behavior")>
Public Overridable Property AllowDrop As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Boolean

instance.AllowDrop = value

value = instance.AllowDrop
C#
[SRDescriptionAttribute("Indicates whether the control can accept data that the user drags onto it.")]
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
public virtual System.bool AllowDrop {get; set;}
Delphi
public read-write property AllowDrop: System.Boolean; virtual;
JScript
SRDescriptionAttribute("Indicates whether the control can accept data that the user drags onto it.")
System.ComponentModel.DefaultValueAttribute()
SRCategoryAttribute("Behavior")
public function get,set AllowDrop : System.boolean
Managed Extensions for C++
[SRDescriptionAttribute("Indicates whether the control can accept data that the user drags onto it.")]
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
public: __property virtual System.bool get_AllowDrop();
public: __property virtual void set_AllowDrop(
   System.bool value
);
C++/CLI
[SRDescriptionAttribute("Indicates whether the control can accept data that the user drags onto it.")]
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
public:
virtual property System.bool AllowDrop {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


AllowTransparency Property

[image]
Intersoft WebTextEditor Documentation
AllowTransparency Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : AllowTransparency Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<SRDescriptionAttribute("Indicates whether the opacity of the control can be adjusted. ")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property AllowTransparency As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Boolean

instance.AllowTransparency = value

value = instance.AllowTransparency
C#
[System.ComponentModel.BrowsableAttribute(false)]
[SRDescriptionAttribute("Indicates whether the opacity of the control can be adjusted. ")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public System.bool AllowTransparency {get; set;}
Delphi
public read-write property AllowTransparency: System.Boolean;
JScript
System.ComponentModel.BrowsableAttribute()
SRDescriptionAttribute("Indicates whether the opacity of the control can be adjusted. ")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get,set AllowTransparency : System.boolean
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[SRDescriptionAttribute("Indicates whether the opacity of the control can be adjusted. ")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property System.bool get_AllowTransparency();
public: __property void set_AllowTransparency(
   System.bool value
);
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[SRDescriptionAttribute("Indicates whether the opacity of the control can be adjusted. ")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property System.bool AllowTransparency {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


Anchor Property

[image]
Intersoft WebTextEditor Documentation
Anchor Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : Anchor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.LocalizableAttribute(True)>
<SRDescriptionAttribute("Defines the edges of the container to which a certain control is bound. When a control is anchored to an edge, the distance between the control's closest edge and the specified edge will remain constant. ")>
<SRCategoryAttribute("Layout")>
<System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.Repaint)>
Public Overridable Property Anchor As System.Windows.Forms.AnchorStyles
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Windows.Forms.AnchorStyles

instance.Anchor = value

value = instance.Anchor
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.LocalizableAttribute(true)]
[SRDescriptionAttribute("Defines the edges of the container to which a certain control is bound. When a control is anchored to an edge, the distance between the control's closest edge and the specified edge will remain constant. ")]
[SRCategoryAttribute("Layout")]
[System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.Repaint)]
public virtual System.Windows.Forms.AnchorStyles Anchor {get; set;}
Delphi
public read-write property Anchor: System.Windows.Forms.AnchorStyles; virtual;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.LocalizableAttribute()
SRDescriptionAttribute("Defines the edges of the container to which a certain control is bound. When a control is anchored to an edge, the distance between the control's closest edge and the specified edge will remain constant. ")
SRCategoryAttribute("Layout")
System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.Repaint)
public function get,set Anchor : System.Windows.Forms.AnchorStyles
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.LocalizableAttribute(true)]
[SRDescriptionAttribute("Defines the edges of the container to which a certain control is bound. When a control is anchored to an edge, the distance between the control's closest edge and the specified edge will remain constant. ")]
[SRCategoryAttribute("Layout")]
[System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.Repaint)]
public: __property virtual System.Windows.Forms.AnchorStyles get_Anchor();
public: __property virtual void set_Anchor(
   System.Windows.Forms.AnchorStyles value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.LocalizableAttribute(true)]
[SRDescriptionAttribute("Defines the edges of the container to which a certain control is bound. When a control is anchored to an edge, the distance between the control's closest edge and the specified edge will remain constant. ")]
[SRCategoryAttribute("Layout")]
[System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.Repaint)]
public:
virtual property System.Windows.Forms.AnchorStyles Anchor {
   System.Windows.Forms.AnchorStyles get();
   void set (    System.Windows.Forms.AnchorStyles value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


AutoScaleDimensions Property

[image]
Intersoft WebTextEditor Documentation
AutoScaleDimensions Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : AutoScaleDimensions Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.LocalizableAttribute(True)>
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<SRCategoryAttribute("Layout")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
Public Property AutoScaleDimensions As System.Drawing.SizeF
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Drawing.SizeF

instance.AutoScaleDimensions = value

value = instance.AutoScaleDimensions
C#
[System.ComponentModel.LocalizableAttribute(true)]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRCategoryAttribute("Layout")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public System.Drawing.SizeF AutoScaleDimensions {get; set;}
Delphi
public read-write property AutoScaleDimensions: System.Drawing.SizeF;
JScript
System.ComponentModel.LocalizableAttribute()
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
SRCategoryAttribute("Layout")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
public function get,set AutoScaleDimensions : System.Drawing.SizeF
Managed Extensions for C++
[System.ComponentModel.LocalizableAttribute(true)]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRCategoryAttribute("Layout")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public: __property System.Drawing.SizeF get_AutoScaleDimensions();
public: __property void set_AutoScaleDimensions(
   System.Drawing.SizeF value
);
C++/CLI
[System.ComponentModel.LocalizableAttribute(true)]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRCategoryAttribute("Layout")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public:
property System.Drawing.SizeF AutoScaleDimensions {
   System.Drawing.SizeF get();
   void set (    System.Drawing.SizeF value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


AutoScaleFactor Property

[image]
Intersoft WebTextEditor Documentation
AutoScaleFactor Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : AutoScaleFactor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property AutoScaleFactor As System.Drawing.SizeF
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Drawing.SizeF

value = instance.AutoScaleFactor
C#
protected System.Drawing.SizeF AutoScaleFactor {get;}
Delphi
protected read-only property AutoScaleFactor: System.Drawing.SizeF;
JScript
protected function get AutoScaleFactor : System.Drawing.SizeF
Managed Extensions for C++
protected: __property System.Drawing.SizeF get_AutoScaleFactor();
C++/CLI
protected:
property System.Drawing.SizeF AutoScaleFactor {
   System.Drawing.SizeF get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


AutoScaleMode Property

[image]
Intersoft WebTextEditor Documentation
AutoScaleMode Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : AutoScaleMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Layout")>
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
<SRDescriptionAttribute("Determines how the form or control will scale when screen resolution or fonts change.")>
Public Property AutoScaleMode As System.Windows.Forms.AutoScaleMode
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Windows.Forms.AutoScaleMode

instance.AutoScaleMode = value

value = instance.AutoScaleMode
C#
[SRCategoryAttribute("Layout")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[SRDescriptionAttribute("Determines how the form or control will scale when screen resolution or fonts change.")]
public System.Windows.Forms.AutoScaleMode AutoScaleMode {get; set;}
Delphi
public read-write property AutoScaleMode: System.Windows.Forms.AutoScaleMode;
JScript
SRCategoryAttribute("Layout")
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
SRDescriptionAttribute("Determines how the form or control will scale when screen resolution or fonts change.")
public function get,set AutoScaleMode : System.Windows.Forms.AutoScaleMode
Managed Extensions for C++
[SRCategoryAttribute("Layout")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[SRDescriptionAttribute("Determines how the form or control will scale when screen resolution or fonts change.")]
public: __property System.Windows.Forms.AutoScaleMode get_AutoScaleMode();
public: __property void set_AutoScaleMode(
   System.Windows.Forms.AutoScaleMode value
);
C++/CLI
[SRCategoryAttribute("Layout")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[SRDescriptionAttribute("Determines how the form or control will scale when screen resolution or fonts change.")]
public:
property System.Windows.Forms.AutoScaleMode AutoScaleMode {
   System.Windows.Forms.AutoScaleMode get();
   void set (    System.Windows.Forms.AutoScaleMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


AutoScroll Property

[image]
Intersoft WebTextEditor Documentation
AutoScroll Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : AutoScroll Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.LocalizableAttribute(True)>
Public Overridable Property AutoScroll As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Boolean

instance.AutoScroll = value

value = instance.AutoScroll
C#
[System.ComponentModel.LocalizableAttribute(true)]
public virtual System.bool AutoScroll {get; set;}
Delphi
public read-write property AutoScroll: System.Boolean; virtual;
JScript
System.ComponentModel.LocalizableAttribute()
public function get,set AutoScroll : System.boolean
Managed Extensions for C++
[System.ComponentModel.LocalizableAttribute(true)]
public: __property virtual System.bool get_AutoScroll();
public: __property virtual void set_AutoScroll(
   System.bool value
);
C++/CLI
[System.ComponentModel.LocalizableAttribute(true)]
public:
virtual property System.bool AutoScroll {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


AutoScrollMargin Property

[image]
Intersoft WebTextEditor Documentation
AutoScrollMargin Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : AutoScrollMargin Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Layout")>
<SRDescriptionAttribute("The margin around controls during auto scroll.")>
<System.ComponentModel.LocalizableAttribute(True)>
Public Property AutoScrollMargin As System.Drawing.Size
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Drawing.Size

instance.AutoScrollMargin = value

value = instance.AutoScrollMargin
C#
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("The margin around controls during auto scroll.")]
[System.ComponentModel.LocalizableAttribute(true)]
public System.Drawing.Size AutoScrollMargin {get; set;}
Delphi
public read-write property AutoScrollMargin: System.Drawing.Size;
JScript
SRCategoryAttribute("Layout")
SRDescriptionAttribute("The margin around controls during auto scroll.")
System.ComponentModel.LocalizableAttribute()
public function get,set AutoScrollMargin : System.Drawing.Size
Managed Extensions for C++
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("The margin around controls during auto scroll.")]
[System.ComponentModel.LocalizableAttribute(true)]
public: __property System.Drawing.Size get_AutoScrollMargin();
public: __property void set_AutoScrollMargin(
   System.Drawing.Size value
);
C++/CLI
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("The margin around controls during auto scroll.")]
[System.ComponentModel.LocalizableAttribute(true)]
public:
property System.Drawing.Size AutoScrollMargin {
   System.Drawing.Size get();
   void set (    System.Drawing.Size value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


AutoScrollMinSize Property

[image]
Intersoft WebTextEditor Documentation
AutoScrollMinSize Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : AutoScrollMinSize Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The minimum logical size for the auto scroll region.")>
<System.ComponentModel.LocalizableAttribute(True)>
<SRCategoryAttribute("Layout")>
Public Property AutoScrollMinSize As System.Drawing.Size
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Drawing.Size

instance.AutoScrollMinSize = value

value = instance.AutoScrollMinSize
C#
[SRDescriptionAttribute("The minimum logical size for the auto scroll region.")]
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Layout")]
public System.Drawing.Size AutoScrollMinSize {get; set;}
Delphi
public read-write property AutoScrollMinSize: System.Drawing.Size;
JScript
SRDescriptionAttribute("The minimum logical size for the auto scroll region.")
System.ComponentModel.LocalizableAttribute()
SRCategoryAttribute("Layout")
public function get,set AutoScrollMinSize : System.Drawing.Size
Managed Extensions for C++
[SRDescriptionAttribute("The minimum logical size for the auto scroll region.")]
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Layout")]
public: __property System.Drawing.Size get_AutoScrollMinSize();
public: __property void set_AutoScrollMinSize(
   System.Drawing.Size value
);
C++/CLI
[SRDescriptionAttribute("The minimum logical size for the auto scroll region.")]
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Layout")]
public:
property System.Drawing.Size AutoScrollMinSize {
   System.Drawing.Size get();
   void set (    System.Drawing.Size value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


AutoScrollOffset Property

[image]
Intersoft WebTextEditor Documentation
AutoScrollOffset Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : AutoScrollOffset Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DefaultValueAttribute()>
Public Overridable Property AutoScrollOffset As System.Drawing.Point
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Drawing.Point

instance.AutoScrollOffset = value

value = instance.AutoScrollOffset
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
public virtual System.Drawing.Point AutoScrollOffset {get; set;}
Delphi
public read-write property AutoScrollOffset: System.Drawing.Point; virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set AutoScrollOffset : System.Drawing.Point
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property virtual System.Drawing.Point get_AutoScrollOffset();
public: __property virtual void set_AutoScrollOffset(
   System.Drawing.Point value
);
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
public:
virtual property System.Drawing.Point AutoScrollOffset {
   System.Drawing.Point get();
   void set (    System.Drawing.Point value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


AutoScrollPosition Property

[image]
Intersoft WebTextEditor Documentation
AutoScrollPosition Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : AutoScrollPosition Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Layout")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
<SRDescriptionAttribute("The current position of the auto-scrolling scroll bar.")>
Public Property AutoScrollPosition As System.Drawing.Point
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Drawing.Point

instance.AutoScrollPosition = value

value = instance.AutoScrollPosition
C#
[SRCategoryAttribute("Layout")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[SRDescriptionAttribute("The current position of the auto-scrolling scroll bar.")]
public System.Drawing.Point AutoScrollPosition {get; set;}
Delphi
public read-write property AutoScrollPosition: System.Drawing.Point;
JScript
SRCategoryAttribute("Layout")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
SRDescriptionAttribute("The current position of the auto-scrolling scroll bar.")
public function get,set AutoScrollPosition : System.Drawing.Point
Managed Extensions for C++
[SRCategoryAttribute("Layout")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[SRDescriptionAttribute("The current position of the auto-scrolling scroll bar.")]
public: __property System.Drawing.Point get_AutoScrollPosition();
public: __property void set_AutoScrollPosition(
   System.Drawing.Point value
);
C++/CLI
[SRCategoryAttribute("Layout")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[SRDescriptionAttribute("The current position of the auto-scrolling scroll bar.")]
public:
property System.Drawing.Point AutoScrollPosition {
   System.Drawing.Point get();
   void set (    System.Drawing.Point value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


AutoSize Property

[image]
Intersoft WebTextEditor Documentation
AutoSize Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : AutoSize Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(True)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)>
<System.ComponentModel.EditorBrowsableAttribute()>
Public Overridable Property AutoSize As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Boolean

instance.AutoSize = value

value = instance.AutoSize
C#
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[System.ComponentModel.EditorBrowsableAttribute()]
public virtual System.bool AutoSize {get; set;}
Delphi
public read-write property AutoSize: System.Boolean; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)
System.ComponentModel.EditorBrowsableAttribute()
public function get,set AutoSize : System.boolean
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[System.ComponentModel.EditorBrowsableAttribute()]
public: __property virtual System.bool get_AutoSize();
public: __property virtual void set_AutoSize(
   System.bool value
);
C++/CLI
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
[System.ComponentModel.EditorBrowsableAttribute()]
public:
virtual property System.bool AutoSize {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


AutoSizeChanged Event

[image]
Intersoft WebTextEditor Documentation
AutoSizeChanged Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : AutoSizeChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(True)>
<SRDescriptionAttribute("Occurs when the AutoSize property has changed.")>
<System.ComponentModel.EditorBrowsableAttribute()>
<SRCategoryAttribute("Property Changed")>
Public Event AutoSizeChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.EventHandler

AddHandler instance.AutoSizeChanged, handler
C#
[System.ComponentModel.BrowsableAttribute(true)]
[SRDescriptionAttribute("Occurs when the AutoSize property has changed.")]
[System.ComponentModel.EditorBrowsableAttribute()]
[SRCategoryAttribute("Property Changed")]
public event System.EventHandler AutoSizeChanged
Delphi
public event AutoSizeChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(true)]
[SRDescriptionAttribute("Occurs when the AutoSize property has changed.")]
[System.ComponentModel.EditorBrowsableAttribute()]
[SRCategoryAttribute("Property Changed")]
public: __event System.EventHandler* AutoSizeChanged
C++/CLI
[System.ComponentModel.BrowsableAttribute(true)]
[SRDescriptionAttribute("Occurs when the AutoSize property has changed.")]
[System.ComponentModel.EditorBrowsableAttribute()]
[SRCategoryAttribute("Property Changed")]
public:
event System.EventHandler^ AutoSizeChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


AutoSizeMode Property

[image]
Intersoft WebTextEditor Documentation
AutoSizeMode Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : AutoSizeMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.LocalizableAttribute(True)>
<SRCategoryAttribute("Layout")>
<SRDescriptionAttribute("Specifies the mode by which the user interface element automatically resizes itself.")>
<System.ComponentModel.BrowsableAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
Public Property AutoSizeMode As System.Windows.Forms.AutoSizeMode
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Windows.Forms.AutoSizeMode

instance.AutoSizeMode = value

value = instance.AutoSizeMode
C#
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Specifies the mode by which the user interface element automatically resizes itself.")]
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public System.Windows.Forms.AutoSizeMode AutoSizeMode {get; set;}
Delphi
public read-write property AutoSizeMode: System.Windows.Forms.AutoSizeMode;
JScript
System.ComponentModel.LocalizableAttribute()
SRCategoryAttribute("Layout")
SRDescriptionAttribute("Specifies the mode by which the user interface element automatically resizes itself.")
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get,set AutoSizeMode : System.Windows.Forms.AutoSizeMode
Managed Extensions for C++
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Specifies the mode by which the user interface element automatically resizes itself.")]
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.Windows.Forms.AutoSizeMode get_AutoSizeMode();
public: __property void set_AutoSizeMode(
   System.Windows.Forms.AutoSizeMode value
);
C++/CLI
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Specifies the mode by which the user interface element automatically resizes itself.")]
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.Windows.Forms.AutoSizeMode AutoSizeMode {
   System.Windows.Forms.AutoSizeMode get();
   void set (    System.Windows.Forms.AutoSizeMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


AutoValidate Property

[image]
Intersoft WebTextEditor Documentation
AutoValidate Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : AutoValidate Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute()>
<System.ComponentModel.BrowsableAttribute(True)>
Public Overridable Property AutoValidate As System.Windows.Forms.AutoValidate
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Windows.Forms.AutoValidate

instance.AutoValidate = value

value = instance.AutoValidate
C#
[System.ComponentModel.EditorBrowsableAttribute()]
[System.ComponentModel.BrowsableAttribute(true)]
public virtual System.Windows.Forms.AutoValidate AutoValidate {get; set;}
Delphi
public read-write property AutoValidate: System.Windows.Forms.AutoValidate; virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute()
System.ComponentModel.BrowsableAttribute()
public function get,set AutoValidate : System.Windows.Forms.AutoValidate
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute()]
[System.ComponentModel.BrowsableAttribute(true)]
public: __property virtual System.Windows.Forms.AutoValidate get_AutoValidate();
public: __property virtual void set_AutoValidate(
   System.Windows.Forms.AutoValidate value
);
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute()]
[System.ComponentModel.BrowsableAttribute(true)]
public:
virtual property System.Windows.Forms.AutoValidate AutoValidate {
   System.Windows.Forms.AutoValidate get();
   void set (    System.Windows.Forms.AutoValidate value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


AutoValidateChanged Event

[image]
Intersoft WebTextEditor Documentation
AutoValidateChanged Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : AutoValidateChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute()>
<System.ComponentModel.BrowsableAttribute(True)>
Public Event AutoValidateChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.EventHandler

AddHandler instance.AutoValidateChanged, handler
C#
[System.ComponentModel.EditorBrowsableAttribute()]
[System.ComponentModel.BrowsableAttribute(true)]
public event System.EventHandler AutoValidateChanged
Delphi
public event AutoValidateChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute()]
[System.ComponentModel.BrowsableAttribute(true)]
public: __event System.EventHandler* AutoValidateChanged
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute()]
[System.ComponentModel.BrowsableAttribute(true)]
public:
event System.EventHandler^ AutoValidateChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


BackColor Property

[image]
Intersoft WebTextEditor Documentation
BackColor Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : BackColor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property BackColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Drawing.Color

instance.BackColor = value

value = instance.BackColor
C#
public virtual System.Drawing.Color BackColor {get; set;}
Delphi
public read-write property BackColor: System.Drawing.Color; virtual;
JScript
public function get,set BackColor : System.Drawing.Color
Managed Extensions for C++
public: __property virtual System.Drawing.Color get_BackColor();
public: __property virtual void set_BackColor(
   System.Drawing.Color value
);
C++/CLI
public:
virtual property System.Drawing.Color BackColor {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


BackColorChanged Event

[image]
Intersoft WebTextEditor Documentation
BackColorChanged Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : BackColorChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Property Changed")>
<SRDescriptionAttribute("Event raised when the value of the BackColor property is changed on Control.")>
Public Event BackColorChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.EventHandler

AddHandler instance.BackColorChanged, handler
C#
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the BackColor property is changed on Control.")]
public event System.EventHandler BackColorChanged
Delphi
public event BackColorChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the BackColor property is changed on Control.")]
public: __event System.EventHandler* BackColorChanged
C++/CLI
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the BackColor property is changed on Control.")]
public:
event System.EventHandler^ BackColorChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


BackgroundImage Property

[image]
Intersoft WebTextEditor Documentation
BackgroundImage Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : BackgroundImage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.LocalizableAttribute(True)>
<SRDescriptionAttribute("The background image used for the control.")>
<SRCategoryAttribute("Appearance")>
<System.ComponentModel.DefaultValueAttribute()>
Public Overridable Property BackgroundImage As System.Drawing.Image
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Drawing.Image

instance.BackgroundImage = value

value = instance.BackgroundImage
C#
[System.ComponentModel.LocalizableAttribute(true)]
[SRDescriptionAttribute("The background image used for the control.")]
[SRCategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
public virtual System.Drawing.Image BackgroundImage {get; set;}
Delphi
public read-write property BackgroundImage: System.Drawing.Image; virtual;
JScript
System.ComponentModel.LocalizableAttribute()
SRDescriptionAttribute("The background image used for the control.")
SRCategoryAttribute("Appearance")
System.ComponentModel.DefaultValueAttribute()
public function get,set BackgroundImage : System.Drawing.Image
Managed Extensions for C++
[System.ComponentModel.LocalizableAttribute(true)]
[SRDescriptionAttribute("The background image used for the control.")]
[SRCategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property virtual System.Drawing.Image* get_BackgroundImage();
public: __property virtual void set_BackgroundImage(
   System.Drawing.Image* value
);
C++/CLI
[System.ComponentModel.LocalizableAttribute(true)]
[SRDescriptionAttribute("The background image used for the control.")]
[SRCategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
public:
virtual property System.Drawing.Image^ BackgroundImage {
   System.Drawing.Image^ get();
   void set (    System.Drawing.Image^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


BackgroundImageChanged Event

[image]
Intersoft WebTextEditor Documentation
BackgroundImageChanged Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : BackgroundImageChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Property Changed")>
<SRDescriptionAttribute("Event raised when the value of the BackgroundImage property is changed on Control.")>
Public Event BackgroundImageChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.EventHandler

AddHandler instance.BackgroundImageChanged, handler
C#
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the BackgroundImage property is changed on Control.")]
public event System.EventHandler BackgroundImageChanged
Delphi
public event BackgroundImageChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the BackgroundImage property is changed on Control.")]
public: __event System.EventHandler* BackgroundImageChanged
C++/CLI
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the BackgroundImage property is changed on Control.")]
public:
event System.EventHandler^ BackgroundImageChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


BackgroundImageLayout Property

[image]
Intersoft WebTextEditor Documentation
BackgroundImageLayout Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : BackgroundImageLayout Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.LocalizableAttribute(True)>
<SRDescriptionAttribute("The background image layout used for the component.")>
<SRCategoryAttribute("Appearance")>
<System.ComponentModel.DefaultValueAttribute()>
Public Overridable Property BackgroundImageLayout As System.Windows.Forms.ImageLayout
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Windows.Forms.ImageLayout

instance.BackgroundImageLayout = value

value = instance.BackgroundImageLayout
C#
[System.ComponentModel.LocalizableAttribute(true)]
[SRDescriptionAttribute("The background image layout used for the component.")]
[SRCategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
public virtual System.Windows.Forms.ImageLayout BackgroundImageLayout {get; set;}
Delphi
public read-write property BackgroundImageLayout: System.Windows.Forms.ImageLayout; virtual;
JScript
System.ComponentModel.LocalizableAttribute()
SRDescriptionAttribute("The background image layout used for the component.")
SRCategoryAttribute("Appearance")
System.ComponentModel.DefaultValueAttribute()
public function get,set BackgroundImageLayout : System.Windows.Forms.ImageLayout
Managed Extensions for C++
[System.ComponentModel.LocalizableAttribute(true)]
[SRDescriptionAttribute("The background image layout used for the component.")]
[SRCategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property virtual System.Windows.Forms.ImageLayout get_BackgroundImageLayout();
public: __property virtual void set_BackgroundImageLayout(
   System.Windows.Forms.ImageLayout value
);
C++/CLI
[System.ComponentModel.LocalizableAttribute(true)]
[SRDescriptionAttribute("The background image layout used for the component.")]
[SRCategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
public:
virtual property System.Windows.Forms.ImageLayout BackgroundImageLayout {
   System.Windows.Forms.ImageLayout get();
   void set (    System.Windows.Forms.ImageLayout value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


BackgroundImageLayoutChanged Event

[image]
Intersoft WebTextEditor Documentation
BackgroundImageLayoutChanged Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : BackgroundImageLayoutChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Event raised when the value of the BackgroundImageLayout property is changed on Control.")>
<SRCategoryAttribute("Property Changed")>
Public Event BackgroundImageLayoutChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.EventHandler

AddHandler instance.BackgroundImageLayoutChanged, handler
C#
[SRDescriptionAttribute("Event raised when the value of the BackgroundImageLayout property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public event System.EventHandler BackgroundImageLayoutChanged
Delphi
public event BackgroundImageLayoutChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Event raised when the value of the BackgroundImageLayout property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public: __event System.EventHandler* BackgroundImageLayoutChanged
C++/CLI
[SRDescriptionAttribute("Event raised when the value of the BackgroundImageLayout property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public:
event System.EventHandler^ BackgroundImageLayoutChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


BeginInvoke Method

[image]
Intersoft WebTextEditor Documentation
BeginInvoke Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : BeginInvoke Method

Glossary Item Box

Overload List

Overload | Description
BeginInvoke(Delegate) | (Inherited from System.Windows.Forms.Control)
BeginInvoke(Delegate,Object[]) | (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


BeginInvoke(Delegate) Method

[image]
Intersoft WebTextEditor Documentation
BeginInvoke(Delegate) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class > BeginInvoke Method : BeginInvoke(Delegate) Method

method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function BeginInvoke( _
   ByVal method As System.Delegate _
) As System.IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim method As System.Delegate
Dim value As System.IAsyncResult

value = instance.BeginInvoke(method)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.IAsyncResult BeginInvoke(
   System.Delegate method
)
Delphi
public function BeginInvoke(
    method: System.Delegate
): System.IAsyncResult;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function BeginInvoke(
   method : System.Delegate
) : System.IAsyncResult;
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.IAsyncResult* BeginInvoke(
   System.Delegate* method
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.IAsyncResult^ BeginInvoke(
   System.Delegate^ method
)

Parameters

method

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members
Overload List


BeginInvoke(Delegate,Object[]) Method

[image]
Intersoft WebTextEditor Documentation
BeginInvoke(Delegate,Object[]) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class > BeginInvoke Method : BeginInvoke(Delegate,Object[]) Method

method
args

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Overloads Function BeginInvoke( _
   ByVal method As System.Delegate, _
   ByVal ParamArray args() As System.Object _
) As System.IAsyncResult
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim method As System.Delegate
Dim args() As System.Object
Dim value As System.IAsyncResult

value = instance.BeginInvoke(method, args)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public System.IAsyncResult BeginInvoke(
   System.Delegate method,
   params System.object[] args
)
Delphi
public function BeginInvoke(
    method: System.Delegate;
   params  args: System.TObjectarray of
): System.IAsyncResult;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function BeginInvoke(
   method : System.Delegate,
   args : System.Object[]
) : System.IAsyncResult;
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: System.IAsyncResult* BeginInvoke(
   System.Delegate* method,
   params System.Object*[]* args
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
System.IAsyncResult^ BeginInvoke(
   System.Delegate^ method,
   ... System.array<Object^>^ args
)

Parameters

method
args

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members
Overload List


BindingContext Property

[image]
Intersoft WebTextEditor Documentation
BindingContext Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : BindingContext Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<SRDescriptionAttribute("The binding manager for the container control.  This manages all bindings of child controls to lists.")>
Public Overridable Property BindingContext As System.Windows.Forms.BindingContext
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Windows.Forms.BindingContext

instance.BindingContext = value

value = instance.BindingContext
C#
[System.ComponentModel.BrowsableAttribute(false)]
[SRDescriptionAttribute("The binding manager for the container control.  This manages all bindings of child controls to lists.")]
public virtual System.Windows.Forms.BindingContext BindingContext {get; set;}
Delphi
public read-write property BindingContext: System.Windows.Forms.BindingContext; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
SRDescriptionAttribute("The binding manager for the container control.  This manages all bindings of child controls to lists.")
public function get,set BindingContext : System.Windows.Forms.BindingContext
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[SRDescriptionAttribute("The binding manager for the container control.  This manages all bindings of child controls to lists.")]
public: __property virtual System.Windows.Forms.BindingContext* get_BindingContext();
public: __property virtual void set_BindingContext(
   System.Windows.Forms.BindingContext* value
);
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[SRDescriptionAttribute("The binding manager for the container control.  This manages all bindings of child controls to lists.")]
public:
virtual property System.Windows.Forms.BindingContext^ BindingContext {
   System.Windows.Forms.BindingContext^ get();
   void set (    System.Windows.Forms.BindingContext^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


BindingContextChanged Event

[image]
Intersoft WebTextEditor Documentation
BindingContextChanged Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : BindingContextChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Property Changed")>
<SRDescriptionAttribute("Event raised when the value of the BindingContext property is changed on Control.")>
Public Event BindingContextChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.EventHandler

AddHandler instance.BindingContextChanged, handler
C#
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the BindingContext property is changed on Control.")]
public event System.EventHandler BindingContextChanged
Delphi
public event BindingContextChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the BindingContext property is changed on Control.")]
public: __event System.EventHandler* BindingContextChanged
C++/CLI
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the BindingContext property is changed on Control.")]
public:
event System.EventHandler^ BindingContextChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


Bottom Property

[image]
Intersoft WebTextEditor Documentation
Bottom Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : Bottom Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Layout")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<SRDescriptionAttribute("The bottom of the control, in container coordinates.")>
Public ReadOnly Property Bottom As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Integer

value = instance.Bottom
C#
[SRCategoryAttribute("Layout")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRDescriptionAttribute("The bottom of the control, in container coordinates.")]
public System.int Bottom {get;}
Delphi
public read-only property Bottom: System.Integer;
JScript
SRCategoryAttribute("Layout")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
SRDescriptionAttribute("The bottom of the control, in container coordinates.")
public function get Bottom : System.int
Managed Extensions for C++
[SRCategoryAttribute("Layout")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRDescriptionAttribute("The bottom of the control, in container coordinates.")]
public: __property System.int get_Bottom();
C++/CLI
[SRCategoryAttribute("Layout")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRDescriptionAttribute("The bottom of the control, in container coordinates.")]
public:
property System.int Bottom {
   System.int get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


Bounds Property

[image]
Intersoft WebTextEditor Documentation
Bounds Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : Bounds Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<SRDescriptionAttribute("The bounds of the control, in container coordinates.")>
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<SRCategoryAttribute("Layout")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property Bounds As System.Drawing.Rectangle
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Drawing.Rectangle

instance.Bounds = value

value = instance.Bounds
C#
[System.ComponentModel.BrowsableAttribute(false)]
[SRDescriptionAttribute("The bounds of the control, in container coordinates.")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRCategoryAttribute("Layout")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public System.Drawing.Rectangle Bounds {get; set;}
Delphi
public read-write property Bounds: System.Drawing.Rectangle;
JScript
System.ComponentModel.BrowsableAttribute()
SRDescriptionAttribute("The bounds of the control, in container coordinates.")
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
SRCategoryAttribute("Layout")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get,set Bounds : System.Drawing.Rectangle
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[SRDescriptionAttribute("The bounds of the control, in container coordinates.")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRCategoryAttribute("Layout")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property System.Drawing.Rectangle get_Bounds();
public: __property void set_Bounds(
   System.Drawing.Rectangle value
);
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[SRDescriptionAttribute("The bounds of the control, in container coordinates.")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRCategoryAttribute("Layout")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property System.Drawing.Rectangle Bounds {
   System.Drawing.Rectangle get();
   void set (    System.Drawing.Rectangle value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


BringToFront Method

[image]
Intersoft WebTextEditor Documentation
BringToFront Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : BringToFront Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub BringToFront()
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm

instance.BringToFront()
C#
public void BringToFront()
Delphi
public procedure BringToFront();
JScript
public function BringToFront();
Managed Extensions for C++
public: void BringToFront();
C++/CLI
public:
void BringToFront();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


CancelButton Property

[image]
Intersoft WebTextEditor Documentation
CancelButton Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : CancelButton Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<SRDescriptionAttribute("The cancel button of the form. If this property is set, the button is 'clicked' whenever the user presses the 'ESC' key.")>
Public Property CancelButton As System.Windows.Forms.IButtonControl
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Windows.Forms.IButtonControl

instance.CancelButton = value

value = instance.CancelButton
C#
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("The cancel button of the form. If this property is set, the button is 'clicked' whenever the user presses the 'ESC' key.")]
public System.Windows.Forms.IButtonControl CancelButton {get; set;}
Delphi
public read-write property CancelButton: System.Windows.Forms.IButtonControl;
JScript
System.ComponentModel.DefaultValueAttribute()
SRDescriptionAttribute("The cancel button of the form. If this property is set, the button is 'clicked' whenever the user presses the 'ESC' key.")
public function get,set CancelButton : System.Windows.Forms.IButtonControl
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("The cancel button of the form. If this property is set, the button is 'clicked' whenever the user presses the 'ESC' key.")]
public: __property System.Windows.Forms.IButtonControl* get_CancelButton();
public: __property void set_CancelButton(
   System.Windows.Forms.IButtonControl* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("The cancel button of the form. If this property is set, the button is 'clicked' whenever the user presses the 'ESC' key.")]
public:
property System.Windows.Forms.IButtonControl^ CancelButton {
   System.Windows.Forms.IButtonControl^ get();
   void set (    System.Windows.Forms.IButtonControl^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


CanEnableIme Property

[image]
Intersoft WebTextEditor Documentation
CanEnableIme Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : CanEnableIme Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property CanEnableIme As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Boolean

value = instance.CanEnableIme
C#
protected virtual System.bool CanEnableIme {get;}
Delphi
protected read-only property CanEnableIme: System.Boolean; virtual;
JScript
protected function get CanEnableIme : System.boolean
Managed Extensions for C++
protected: __property virtual System.bool get_CanEnableIme();
C++/CLI
protected:
virtual property System.bool CanEnableIme {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


CanFocus Property

[image]
Intersoft WebTextEditor Documentation
CanFocus Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : CanFocus Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<SRCategoryAttribute("Focus")>
<SRDescriptionAttribute("Checks if this control can receive the focus.")>
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<System.ComponentModel.BrowsableAttribute(False)>
Public ReadOnly Property CanFocus As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Boolean

value = instance.CanFocus
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[SRCategoryAttribute("Focus")]
[SRDescriptionAttribute("Checks if this control can receive the focus.")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.ComponentModel.BrowsableAttribute(false)]
public System.bool CanFocus {get;}
Delphi
public read-only property CanFocus: System.Boolean;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
SRCategoryAttribute("Focus")
SRDescriptionAttribute("Checks if this control can receive the focus.")
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
System.ComponentModel.BrowsableAttribute()
public function get CanFocus : System.boolean
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[SRCategoryAttribute("Focus")]
[SRDescriptionAttribute("Checks if this control can receive the focus.")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.ComponentModel.BrowsableAttribute(false)]
public: __property System.bool get_CanFocus();
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[SRCategoryAttribute("Focus")]
[SRDescriptionAttribute("Checks if this control can receive the focus.")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.ComponentModel.BrowsableAttribute(false)]
public:
property System.bool CanFocus {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


CanRaiseEvents Property

[image]
Intersoft WebTextEditor Documentation
CanRaiseEvents Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : CanRaiseEvents Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property CanRaiseEvents As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Boolean

value = instance.CanRaiseEvents
C#
protected virtual System.bool CanRaiseEvents {get;}
Delphi
protected read-only property CanRaiseEvents: System.Boolean; virtual;
JScript
protected function get CanRaiseEvents : System.boolean
Managed Extensions for C++
protected: __property virtual System.bool get_CanRaiseEvents();
C++/CLI
protected:
virtual property System.bool CanRaiseEvents {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


CanSelect Property

[image]
Intersoft WebTextEditor Documentation
CanSelect Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : CanSelect Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<SRDescriptionAttribute("Checks if this control can be selected.")>
<SRCategoryAttribute("Focus")>
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public ReadOnly Property CanSelect As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Boolean

value = instance.CanSelect
C#
[System.ComponentModel.BrowsableAttribute(false)]
[SRDescriptionAttribute("Checks if this control can be selected.")]
[SRCategoryAttribute("Focus")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public System.bool CanSelect {get;}
Delphi
public read-only property CanSelect: System.Boolean;
JScript
System.ComponentModel.BrowsableAttribute()
SRDescriptionAttribute("Checks if this control can be selected.")
SRCategoryAttribute("Focus")
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get CanSelect : System.boolean
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[SRDescriptionAttribute("Checks if this control can be selected.")]
[SRCategoryAttribute("Focus")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property System.bool get_CanSelect();
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[SRDescriptionAttribute("Checks if this control can be selected.")]
[SRCategoryAttribute("Focus")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property System.bool CanSelect {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


Capture Property

[image]
Intersoft WebTextEditor Documentation
Capture Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : Capture Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<SRCategoryAttribute("Focus")>
<SRDescriptionAttribute("Determines if this control is currently capturing all mouse input.")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
Public Property Capture As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Boolean

instance.Capture = value

value = instance.Capture
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRCategoryAttribute("Focus")]
[SRDescriptionAttribute("Determines if this control is currently capturing all mouse input.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public System.bool Capture {get; set;}
Delphi
public read-write property Capture: System.Boolean;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
SRCategoryAttribute("Focus")
SRDescriptionAttribute("Determines if this control is currently capturing all mouse input.")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
public function get,set Capture : System.boolean
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRCategoryAttribute("Focus")]
[SRDescriptionAttribute("Determines if this control is currently capturing all mouse input.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public: __property System.bool get_Capture();
public: __property void set_Capture(
   System.bool value
);
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRCategoryAttribute("Focus")]
[SRDescriptionAttribute("Determines if this control is currently capturing all mouse input.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public:
property System.bool Capture {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


CausesValidation Property

[image]
Intersoft WebTextEditor Documentation
CausesValidation Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : CausesValidation Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<SRCategoryAttribute("Focus")>
<SRDescriptionAttribute("Indicates whether this component raises validation events. ")>
Public Property CausesValidation As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Boolean

instance.CausesValidation = value

value = instance.CausesValidation
C#
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Focus")]
[SRDescriptionAttribute("Indicates whether this component raises validation events. ")]
public System.bool CausesValidation {get; set;}
Delphi
public read-write property CausesValidation: System.Boolean;
JScript
System.ComponentModel.DefaultValueAttribute()
SRCategoryAttribute("Focus")
SRDescriptionAttribute("Indicates whether this component raises validation events. ")
public function get,set CausesValidation : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Focus")]
[SRDescriptionAttribute("Indicates whether this component raises validation events. ")]
public: __property System.bool get_CausesValidation();
public: __property void set_CausesValidation(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Focus")]
[SRDescriptionAttribute("Indicates whether this component raises validation events. ")]
public:
property System.bool CausesValidation {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


CausesValidationChanged Event

[image]
Intersoft WebTextEditor Documentation
CausesValidationChanged Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : CausesValidationChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Event raised when the value of the CausesValidation property is changed on Control.")>
<SRCategoryAttribute("Property Changed")>
Public Event CausesValidationChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.EventHandler

AddHandler instance.CausesValidationChanged, handler
C#
[SRDescriptionAttribute("Event raised when the value of the CausesValidation property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public event System.EventHandler CausesValidationChanged
Delphi
public event CausesValidationChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Event raised when the value of the CausesValidation property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public: __event System.EventHandler* CausesValidationChanged
C++/CLI
[SRDescriptionAttribute("Event raised when the value of the CausesValidation property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public:
event System.EventHandler^ CausesValidationChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


CenterToParent Method

[image]
Intersoft WebTextEditor Documentation
CenterToParent Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : CenterToParent Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Sub CenterToParent()
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm

instance.CenterToParent()
C#
protected void CenterToParent()
Delphi
protected procedure CenterToParent();
JScript
protected function CenterToParent();
Managed Extensions for C++
protected: void CenterToParent();
C++/CLI
protected:
void CenterToParent();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


CenterToScreen Method

[image]
Intersoft WebTextEditor Documentation
CenterToScreen Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : CenterToScreen Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Sub CenterToScreen()
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm

instance.CenterToScreen()
C#
protected void CenterToScreen()
Delphi
protected procedure CenterToScreen();
JScript
protected function CenterToScreen();
Managed Extensions for C++
protected: void CenterToScreen();
C++/CLI
protected:
void CenterToScreen();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


ChangeUICues Event

[image]
Intersoft WebTextEditor Documentation
ChangeUICues Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : ChangeUICues Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("Occurs when focus rectangles and keyboard cue underlines are being shown or hidden.")>
Public Event ChangeUICues As System.Windows.Forms.UICuesEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.Windows.Forms.UICuesEventHandler

AddHandler instance.ChangeUICues, handler
C#
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when focus rectangles and keyboard cue underlines are being shown or hidden.")]
public event System.Windows.Forms.UICuesEventHandler ChangeUICues
Delphi
public event ChangeUICues: System.Windows.Forms.UICuesEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when focus rectangles and keyboard cue underlines are being shown or hidden.")]
public: __event System.Windows.Forms.UICuesEventHandler* ChangeUICues
C++/CLI
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when focus rectangles and keyboard cue underlines are being shown or hidden.")]
public:
event System.Windows.Forms.UICuesEventHandler^ ChangeUICues

Event Data

The event handler receives an argument of type System.Windows.Forms.UICuesEventArgs containing data related to this event. The following UICuesEventArgs properties provide information specific to this event.

Property | Description
Changed | Gets the bitwise combination of the System.Windows.Forms.UICues values.
ChangeFocus | Gets a value indicating whether the state of the focus cues has changed.
ChangeKeyboard | Gets a value indicating whether the state of the keyboard cues has changed.
ShowFocus | Gets a value indicating whether focus rectangles are shown after the change.
ShowKeyboard | Gets a value indicating whether keyboard cues are underlined after the change.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


Click Event

[image]
Intersoft WebTextEditor Documentation
Click Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : Click Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Action")>
<SRDescriptionAttribute("Occurs when the component is clicked.")>
Public Event Click As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.EventHandler

AddHandler instance.Click, handler
C#
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when the component is clicked.")]
public event System.EventHandler Click
Delphi
public event Click: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when the component is clicked.")]
public: __event System.EventHandler* Click
C++/CLI
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when the component is clicked.")]
public:
event System.EventHandler^ Click

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


ClientRectangle Property

[image]
Intersoft WebTextEditor Documentation
ClientRectangle Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : ClientRectangle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Layout")>
<SRDescriptionAttribute("Retrieves the rectangle of the inner area of this control.")>
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public ReadOnly Property ClientRectangle As System.Drawing.Rectangle
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Drawing.Rectangle

value = instance.ClientRectangle
C#
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Retrieves the rectangle of the inner area of this control.")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public System.Drawing.Rectangle ClientRectangle {get;}
Delphi
public read-only property ClientRectangle: System.Drawing.Rectangle;
JScript
SRCategoryAttribute("Layout")
SRDescriptionAttribute("Retrieves the rectangle of the inner area of this control.")
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get ClientRectangle : System.Drawing.Rectangle
Managed Extensions for C++
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Retrieves the rectangle of the inner area of this control.")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property System.Drawing.Rectangle get_ClientRectangle();
C++/CLI
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Retrieves the rectangle of the inner area of this control.")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property System.Drawing.Rectangle ClientRectangle {
   System.Drawing.Rectangle get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


ClientSize Property

[image]
Intersoft WebTextEditor Documentation
ClientSize Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : ClientSize Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.LocalizableAttribute(True)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)>
Public Property ClientSize As System.Drawing.Size
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Drawing.Size

instance.ClientSize = value

value = instance.ClientSize
C#
[System.ComponentModel.LocalizableAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
public System.Drawing.Size ClientSize {get; set;}
Delphi
public read-write property ClientSize: System.Drawing.Size;
JScript
System.ComponentModel.LocalizableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)
public function get,set ClientSize : System.Drawing.Size
Managed Extensions for C++
[System.ComponentModel.LocalizableAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
public: __property System.Drawing.Size get_ClientSize();
public: __property void set_ClientSize(
   System.Drawing.Size value
);
C++/CLI
[System.ComponentModel.LocalizableAttribute(true)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Visible)]
public:
property System.Drawing.Size ClientSize {
   System.Drawing.Size get();
   void set (    System.Drawing.Size value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


ClientSizeChanged Event

[image]
Intersoft WebTextEditor Documentation
ClientSizeChanged Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : ClientSizeChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Property Changed")>
<SRDescriptionAttribute("Event raised when the value of the ClientSize property is changed on Control.")>
Public Event ClientSizeChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.EventHandler

AddHandler instance.ClientSizeChanged, handler
C#
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the ClientSize property is changed on Control.")]
public event System.EventHandler ClientSizeChanged
Delphi
public event ClientSizeChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the ClientSize property is changed on Control.")]
public: __event System.EventHandler* ClientSizeChanged
C++/CLI
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the ClientSize property is changed on Control.")]
public:
event System.EventHandler^ ClientSizeChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


Close Method

[image]
Intersoft WebTextEditor Documentation
Close Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : Close Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Close()
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm

instance.Close()
C#
public void Close()
Delphi
public procedure Close();
JScript
public function Close();
Managed Extensions for C++
public: void Close();
C++/CLI
public:
void Close();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


CompanyName Property

[image]
Intersoft WebTextEditor Documentation
CompanyName Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : CompanyName Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("ControlCompanyNameDescr")>
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
Public ReadOnly Property CompanyName As System.String
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.String

value = instance.CompanyName
C#
[System.ComponentModel.DescriptionAttribute("ControlCompanyNameDescr")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public System.string CompanyName {get;}
Delphi
public read-only property CompanyName: System.String;
JScript
System.ComponentModel.DescriptionAttribute("ControlCompanyNameDescr")
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
public function get CompanyName : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("ControlCompanyNameDescr")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public: __property System.string* get_CompanyName();
C++/CLI
[System.ComponentModel.DescriptionAttribute("ControlCompanyNameDescr")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public:
property System.String^ CompanyName {
   System.String^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


Container Property

[image]
Intersoft WebTextEditor Documentation
Container Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : Container Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public ReadOnly Property Container As System.ComponentModel.IContainer
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.ComponentModel.IContainer

value = instance.Container
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public System.ComponentModel.IContainer Container {get;}
Delphi
public read-only property Container: System.ComponentModel.IContainer;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get Container : System.ComponentModel.IContainer
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property System.ComponentModel.IContainer* get_Container();
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property System.ComponentModel.IContainer^ Container {
   System.ComponentModel.IContainer^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


Contains Method

[image]
Intersoft WebTextEditor Documentation
Contains Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : Contains Method

ctl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function Contains( _
   ByVal ctl As System.Windows.Forms.Control _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim ctl As System.Windows.Forms.Control
Dim value As System.Boolean

value = instance.Contains(ctl)
C#
public System.bool Contains(
   System.Windows.Forms.Control ctl
)
Delphi
public function Contains(
    ctl: System.Windows.Forms.Control
): System.Boolean;
JScript
public function Contains(
   ctl : System.Windows.Forms.Control
) : System.boolean;
Managed Extensions for C++
public: System.bool Contains(
   System.Windows.Forms.Control* ctl
)
C++/CLI
public:
System.bool Contains(
   System.Windows.Forms.Control^ ctl
)

Parameters

ctl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


ContainsFocus Property

[image]
Intersoft WebTextEditor Documentation
ContainsFocus Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : ContainsFocus Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
<SRDescriptionAttribute("Determines if this control or one if its children currently has the focus.")>
Public ReadOnly Property ContainsFocus As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Boolean

value = instance.ContainsFocus
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[SRDescriptionAttribute("Determines if this control or one if its children currently has the focus.")]
public System.bool ContainsFocus {get;}
Delphi
public read-only property ContainsFocus: System.Boolean;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
SRDescriptionAttribute("Determines if this control or one if its children currently has the focus.")
public function get ContainsFocus : System.boolean
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[SRDescriptionAttribute("Determines if this control or one if its children currently has the focus.")]
public: __property System.bool get_ContainsFocus();
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[SRDescriptionAttribute("Determines if this control or one if its children currently has the focus.")]
public:
property System.bool ContainsFocus {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


ContextMenu Property

[image]
Intersoft WebTextEditor Documentation
ContextMenu Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : ContextMenu Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<SRCategoryAttribute("Behavior")>
<System.ComponentModel.DefaultValueAttribute()>
<SRDescriptionAttribute("The shortcut menu to display when the user right-clicks the control.")>
Public Overridable Property ContextMenu As System.Windows.Forms.ContextMenu
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Windows.Forms.ContextMenu

instance.ContextMenu = value

value = instance.ContextMenu
C#
[System.ComponentModel.BrowsableAttribute(false)]
[SRCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("The shortcut menu to display when the user right-clicks the control.")]
public virtual System.Windows.Forms.ContextMenu ContextMenu {get; set;}
Delphi
public read-write property ContextMenu: System.Windows.Forms.ContextMenu; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
SRCategoryAttribute("Behavior")
System.ComponentModel.DefaultValueAttribute()
SRDescriptionAttribute("The shortcut menu to display when the user right-clicks the control.")
public function get,set ContextMenu : System.Windows.Forms.ContextMenu
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[SRCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("The shortcut menu to display when the user right-clicks the control.")]
public: __property virtual System.Windows.Forms.ContextMenu* get_ContextMenu();
public: __property virtual void set_ContextMenu(
   System.Windows.Forms.ContextMenu* value
);
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[SRCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("The shortcut menu to display when the user right-clicks the control.")]
public:
virtual property System.Windows.Forms.ContextMenu^ ContextMenu {
   System.Windows.Forms.ContextMenu^ get();
   void set (    System.Windows.Forms.ContextMenu^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


ContextMenuChanged Event

[image]
Intersoft WebTextEditor Documentation
ContextMenuChanged Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : ContextMenuChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<SRDescriptionAttribute("Occurs when the value of the ContextMenu property changes.")>
<SRCategoryAttribute("Property Changed")>
Public Event ContextMenuChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.EventHandler

AddHandler instance.ContextMenuChanged, handler
C#
[System.ComponentModel.BrowsableAttribute(false)]
[SRDescriptionAttribute("Occurs when the value of the ContextMenu property changes.")]
[SRCategoryAttribute("Property Changed")]
public event System.EventHandler ContextMenuChanged
Delphi
public event ContextMenuChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[SRDescriptionAttribute("Occurs when the value of the ContextMenu property changes.")]
[SRCategoryAttribute("Property Changed")]
public: __event System.EventHandler* ContextMenuChanged
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[SRDescriptionAttribute("Occurs when the value of the ContextMenu property changes.")]
[SRCategoryAttribute("Property Changed")]
public:
event System.EventHandler^ ContextMenuChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


ContextMenuStrip Property

[image]
Intersoft WebTextEditor Documentation
ContextMenuStrip Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : ContextMenuStrip Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("The shortcut menu to display when the user right-clicks the control.")>
Public Overridable Property ContextMenuStrip As System.Windows.Forms.ContextMenuStrip
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Windows.Forms.ContextMenuStrip

instance.ContextMenuStrip = value

value = instance.ContextMenuStrip
C#
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("The shortcut menu to display when the user right-clicks the control.")]
public virtual System.Windows.Forms.ContextMenuStrip ContextMenuStrip {get; set;}
Delphi
public read-write property ContextMenuStrip: System.Windows.Forms.ContextMenuStrip; virtual;
JScript
System.ComponentModel.DefaultValueAttribute()
SRCategoryAttribute("Behavior")
SRDescriptionAttribute("The shortcut menu to display when the user right-clicks the control.")
public function get,set ContextMenuStrip : System.Windows.Forms.ContextMenuStrip
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("The shortcut menu to display when the user right-clicks the control.")]
public: __property virtual System.Windows.Forms.ContextMenuStrip* get_ContextMenuStrip();
public: __property virtual void set_ContextMenuStrip(
   System.Windows.Forms.ContextMenuStrip* value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("The shortcut menu to display when the user right-clicks the control.")]
public:
virtual property System.Windows.Forms.ContextMenuStrip^ ContextMenuStrip {
   System.Windows.Forms.ContextMenuStrip^ get();
   void set (    System.Windows.Forms.ContextMenuStrip^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


ContextMenuStripChanged Event

[image]
Intersoft WebTextEditor Documentation
ContextMenuStripChanged Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : ContextMenuStripChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the value of the ContextMenuStrip property changes.")>
<SRCategoryAttribute("Property Changed")>
Public Event ContextMenuStripChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.EventHandler

AddHandler instance.ContextMenuStripChanged, handler
C#
[SRDescriptionAttribute("Occurs when the value of the ContextMenuStrip property changes.")]
[SRCategoryAttribute("Property Changed")]
public event System.EventHandler ContextMenuStripChanged
Delphi
public event ContextMenuStripChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the value of the ContextMenuStrip property changes.")]
[SRCategoryAttribute("Property Changed")]
public: __event System.EventHandler* ContextMenuStripChanged
C++/CLI
[SRDescriptionAttribute("Occurs when the value of the ContextMenuStrip property changes.")]
[SRCategoryAttribute("Property Changed")]
public:
event System.EventHandler^ ContextMenuStripChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


ControlAdded Event

[image]
Intersoft WebTextEditor Documentation
ControlAdded Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : ControlAdded Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(True)>
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("Occurs when a control is added to this control.")>
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Event ControlAdded As System.Windows.Forms.ControlEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.Windows.Forms.ControlEventHandler

AddHandler instance.ControlAdded, handler
C#
[System.ComponentModel.BrowsableAttribute(true)]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when a control is added to this control.")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public event System.Windows.Forms.ControlEventHandler ControlAdded
Delphi
public event ControlAdded: System.Windows.Forms.ControlEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(true)]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when a control is added to this control.")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: __event System.Windows.Forms.ControlEventHandler* ControlAdded
C++/CLI
[System.ComponentModel.BrowsableAttribute(true)]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when a control is added to this control.")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
event System.Windows.Forms.ControlEventHandler^ ControlAdded

Event Data

The event handler receives an argument of type System.Windows.Forms.ControlEventArgs containing data related to this event. The following ControlEventArgs properties provide information specific to this event.

Property | Description
Control | Gets the control object used by this event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


ControlBox Property

[image]
Intersoft WebTextEditor Documentation
ControlBox Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : ControlBox Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<SRCategoryAttribute("Window Style")>
<SRDescriptionAttribute("Determines whether a form has a Control/System menu box.")>
Public Property ControlBox As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Boolean

instance.ControlBox = value

value = instance.ControlBox
C#
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Window Style")]
[SRDescriptionAttribute("Determines whether a form has a Control/System menu box.")]
public System.bool ControlBox {get; set;}
Delphi
public read-write property ControlBox: System.Boolean;
JScript
System.ComponentModel.DefaultValueAttribute()
SRCategoryAttribute("Window Style")
SRDescriptionAttribute("Determines whether a form has a Control/System menu box.")
public function get,set ControlBox : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Window Style")]
[SRDescriptionAttribute("Determines whether a form has a Control/System menu box.")]
public: __property System.bool get_ControlBox();
public: __property void set_ControlBox(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Window Style")]
[SRDescriptionAttribute("Determines whether a form has a Control/System menu box.")]
public:
property System.bool ControlBox {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


ControlRemoved Event

[image]
Intersoft WebTextEditor Documentation
ControlRemoved Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : ControlRemoved Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when a control is removed from this control.")>
<SRCategoryAttribute("Behavior")>
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<System.ComponentModel.BrowsableAttribute(True)>
Public Event ControlRemoved As System.Windows.Forms.ControlEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.Windows.Forms.ControlEventHandler

AddHandler instance.ControlRemoved, handler
C#
[SRDescriptionAttribute("Occurs when a control is removed from this control.")]
[SRCategoryAttribute("Behavior")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.ComponentModel.BrowsableAttribute(true)]
public event System.Windows.Forms.ControlEventHandler ControlRemoved
Delphi
public event ControlRemoved: System.Windows.Forms.ControlEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when a control is removed from this control.")]
[SRCategoryAttribute("Behavior")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.ComponentModel.BrowsableAttribute(true)]
public: __event System.Windows.Forms.ControlEventHandler* ControlRemoved
C++/CLI
[SRDescriptionAttribute("Occurs when a control is removed from this control.")]
[SRCategoryAttribute("Behavior")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.ComponentModel.BrowsableAttribute(true)]
public:
event System.Windows.Forms.ControlEventHandler^ ControlRemoved

Event Data

The event handler receives an argument of type System.Windows.Forms.ControlEventArgs containing data related to this event. The following ControlEventArgs properties provide information specific to this event.

Property | Description
Control | Gets the control object used by this event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


Controls Property

[image]
Intersoft WebTextEditor Documentation
Controls Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : Controls Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The collection of child controls within this control.")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.ComponentModel.BrowsableAttribute(False)>
Public ReadOnly Property Controls As System.Windows.Forms.Control.ControlCollection
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Windows.Forms.Control.ControlCollection

value = instance.Controls
C#
[SRDescriptionAttribute("The collection of child controls within this control.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.BrowsableAttribute(false)]
public System.Windows.Forms.Control.ControlCollection Controls {get;}
Delphi
public read-only property Controls: System.Windows.Forms.Control.ControlCollection;
JScript
SRDescriptionAttribute("The collection of child controls within this control.")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.ComponentModel.BrowsableAttribute()
public function get Controls : System.Windows.Forms.Control.ControlCollection
Managed Extensions for C++
[SRDescriptionAttribute("The collection of child controls within this control.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.BrowsableAttribute(false)]
public: __property System.Windows.Forms.Control.ControlCollection* get_Controls();
C++/CLI
[SRDescriptionAttribute("The collection of child controls within this control.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.BrowsableAttribute(false)]
public:
property System.Windows.Forms.Control.ControlCollection^ Controls {
   System.Windows.Forms.Control.ControlCollection^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


CreateAccessibilityInstance Method

[image]
Intersoft WebTextEditor Documentation
CreateAccessibilityInstance Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : CreateAccessibilityInstance Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Function CreateAccessibilityInstance() As System.Windows.Forms.AccessibleObject
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Windows.Forms.AccessibleObject

value = instance.CreateAccessibilityInstance()
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual System.Windows.Forms.AccessibleObject CreateAccessibilityInstance()
Delphi
protected function CreateAccessibilityInstance(): System.Windows.Forms.AccessibleObject; virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function CreateAccessibilityInstance() : System.Windows.Forms.AccessibleObject;
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual System.Windows.Forms.AccessibleObject* CreateAccessibilityInstance();
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual System.Windows.Forms.AccessibleObject^ CreateAccessibilityInstance();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


CreateControl Method

[image]
Intersoft WebTextEditor Documentation
CreateControl Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : CreateControl Method

Glossary Item Box

Overload List

Overload | Description
CreateControl | (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


CreateControl() Method

[image]
Intersoft WebTextEditor Documentation
CreateControl() Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : CreateControl() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CreateControl()
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm

instance.CreateControl()
C#
public void CreateControl()
Delphi
public procedure CreateControl();
JScript
public function CreateControl();
Managed Extensions for C++
public: void CreateControl();
C++/CLI
public:
void CreateControl();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


CreateControlsInstance Method

[image]
Intersoft WebTextEditor Documentation
CreateControlsInstance Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : CreateControlsInstance Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Function CreateControlsInstance() As System.Windows.Forms.Control.ControlCollection
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Windows.Forms.Control.ControlCollection

value = instance.CreateControlsInstance()
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual System.Windows.Forms.Control.ControlCollection CreateControlsInstance()
Delphi
protected function CreateControlsInstance(): System.Windows.Forms.Control.ControlCollection; virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function CreateControlsInstance() : System.Windows.Forms.Control.ControlCollection;
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual System.Windows.Forms.Control.ControlCollection* CreateControlsInstance();
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual System.Windows.Forms.Control.ControlCollection^ CreateControlsInstance();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


Created Property

[image]
Intersoft WebTextEditor Documentation
Created Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : Created Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<SRDescriptionAttribute("Determines if the control has been fully created.")>
<System.ComponentModel.BrowsableAttribute(False)>
Public ReadOnly Property Created As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Boolean

value = instance.Created
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRDescriptionAttribute("Determines if the control has been fully created.")]
[System.ComponentModel.BrowsableAttribute(false)]
public System.bool Created {get;}
Delphi
public read-only property Created: System.Boolean;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
SRDescriptionAttribute("Determines if the control has been fully created.")
System.ComponentModel.BrowsableAttribute()
public function get Created : System.boolean
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRDescriptionAttribute("Determines if the control has been fully created.")]
[System.ComponentModel.BrowsableAttribute(false)]
public: __property System.bool get_Created();
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRDescriptionAttribute("Determines if the control has been fully created.")]
[System.ComponentModel.BrowsableAttribute(false)]
public:
property System.bool Created {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


CreateGraphics Method

[image]
Intersoft WebTextEditor Documentation
CreateGraphics Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : CreateGraphics Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CreateGraphics() As System.Drawing.Graphics
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Drawing.Graphics

value = instance.CreateGraphics()
C#
public System.Drawing.Graphics CreateGraphics()
Delphi
public function CreateGraphics(): System.Drawing.Graphics;
JScript
public function CreateGraphics() : System.Drawing.Graphics;
Managed Extensions for C++
public: System.Drawing.Graphics* CreateGraphics();
C++/CLI
public:
System.Drawing.Graphics^ CreateGraphics();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


CreateHandle Method

[image]
Intersoft WebTextEditor Documentation
CreateHandle Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : CreateHandle Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub CreateHandle()
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm

instance.CreateHandle()
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void CreateHandle()
Delphi
protected procedure CreateHandle(); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function CreateHandle();
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void CreateHandle();
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void CreateHandle();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


CreateObjRef Method

[image]
Intersoft WebTextEditor Documentation
CreateObjRef Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : CreateObjRef Method

requestedType

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.SecurityCriticalAttribute()>
Public Overridable Function CreateObjRef( _
   ByVal requestedType As System.Type _
) As System.Runtime.Remoting.ObjRef
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim requestedType As System.Type
Dim value As System.Runtime.Remoting.ObjRef

value = instance.CreateObjRef(requestedType)
C#
[System.Security.SecurityCriticalAttribute()]
public virtual System.Runtime.Remoting.ObjRef CreateObjRef(
   System.Type requestedType
)
Delphi
public function CreateObjRef(
    requestedType: System.Type
): System.Runtime.Remoting.ObjRef; virtual;
JScript
System.Security.SecurityCriticalAttribute()
public function CreateObjRef(
   requestedType : System.Type
) : System.Runtime.Remoting.ObjRef;
Managed Extensions for C++
[System.Security.SecurityCriticalAttribute()]
public: virtual System.Runtime.Remoting.ObjRef* CreateObjRef(
   System.Type* requestedType
)
C++/CLI
[System.Security.SecurityCriticalAttribute()]
public:
virtual System.Runtime.Remoting.ObjRef^ CreateObjRef(
   System.Type^ requestedType
)

Parameters

requestedType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


CreateParams Property

[image]
Intersoft WebTextEditor Documentation
CreateParams Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : CreateParams Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property CreateParams As System.Windows.Forms.CreateParams
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Windows.Forms.CreateParams

value = instance.CreateParams
C#
protected virtual System.Windows.Forms.CreateParams CreateParams {get;}
Delphi
protected read-only property CreateParams: System.Windows.Forms.CreateParams; virtual;
JScript
protected function get CreateParams : System.Windows.Forms.CreateParams
Managed Extensions for C++
protected: __property virtual System.Windows.Forms.CreateParams* get_CreateParams();
C++/CLI
protected:
virtual property System.Windows.Forms.CreateParams^ CreateParams {
   System.Windows.Forms.CreateParams^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


CurrentAutoScaleDimensions Property

[image]
Intersoft WebTextEditor Documentation
CurrentAutoScaleDimensions Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : CurrentAutoScaleDimensions Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Layout")>
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<System.ComponentModel.BrowsableAttribute(False)>
Public ReadOnly Property CurrentAutoScaleDimensions As System.Drawing.SizeF
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Drawing.SizeF

value = instance.CurrentAutoScaleDimensions
C#
[SRCategoryAttribute("Layout")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.ComponentModel.BrowsableAttribute(false)]
public System.Drawing.SizeF CurrentAutoScaleDimensions {get;}
Delphi
public read-only property CurrentAutoScaleDimensions: System.Drawing.SizeF;
JScript
SRCategoryAttribute("Layout")
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
System.ComponentModel.BrowsableAttribute()
public function get CurrentAutoScaleDimensions : System.Drawing.SizeF
Managed Extensions for C++
[SRCategoryAttribute("Layout")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.ComponentModel.BrowsableAttribute(false)]
public: __property System.Drawing.SizeF get_CurrentAutoScaleDimensions();
C++/CLI
[SRCategoryAttribute("Layout")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.ComponentModel.BrowsableAttribute(false)]
public:
property System.Drawing.SizeF CurrentAutoScaleDimensions {
   System.Drawing.SizeF get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


Cursor Property

[image]
Intersoft WebTextEditor Documentation
Cursor Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : Cursor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The cursor that appears when the pointer moves over the control.")>
<SRCategoryAttribute("Appearance")>
<System.ComponentModel.AmbientValueAttribute()>
Public Overridable Property Cursor As System.Windows.Forms.Cursor
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Windows.Forms.Cursor

instance.Cursor = value

value = instance.Cursor
C#
[SRDescriptionAttribute("The cursor that appears when the pointer moves over the control.")]
[SRCategoryAttribute("Appearance")]
[System.ComponentModel.AmbientValueAttribute()]
public virtual System.Windows.Forms.Cursor Cursor {get; set;}
Delphi
public read-write property Cursor: System.Windows.Forms.Cursor; virtual;
JScript
SRDescriptionAttribute("The cursor that appears when the pointer moves over the control.")
SRCategoryAttribute("Appearance")
System.ComponentModel.AmbientValueAttribute()
public function get,set Cursor : System.Windows.Forms.Cursor
Managed Extensions for C++
[SRDescriptionAttribute("The cursor that appears when the pointer moves over the control.")]
[SRCategoryAttribute("Appearance")]
[System.ComponentModel.AmbientValueAttribute()]
public: __property virtual System.Windows.Forms.Cursor* get_Cursor();
public: __property virtual void set_Cursor(
   System.Windows.Forms.Cursor* value
);
C++/CLI
[SRDescriptionAttribute("The cursor that appears when the pointer moves over the control.")]
[SRCategoryAttribute("Appearance")]
[System.ComponentModel.AmbientValueAttribute()]
public:
virtual property System.Windows.Forms.Cursor^ Cursor {
   System.Windows.Forms.Cursor^ get();
   void set (    System.Windows.Forms.Cursor^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


CursorChanged Event

[image]
Intersoft WebTextEditor Documentation
CursorChanged Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : CursorChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Event raised when the value of the Cursor property is changed on Control.")>
<SRCategoryAttribute("Property Changed")>
Public Event CursorChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.EventHandler

AddHandler instance.CursorChanged, handler
C#
[SRDescriptionAttribute("Event raised when the value of the Cursor property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public event System.EventHandler CursorChanged
Delphi
public event CursorChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Event raised when the value of the Cursor property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public: __event System.EventHandler* CursorChanged
C++/CLI
[SRDescriptionAttribute("Event raised when the value of the Cursor property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public:
event System.EventHandler^ CursorChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


DataBindings Property

[image]
Intersoft WebTextEditor Documentation
DataBindings Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : DataBindings Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.All)>
<SRDescriptionAttribute("The data bindings for the control.")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
<System.ComponentModel.ParenthesizePropertyNameAttribute(True)>
<SRCategoryAttribute("Data")>
Public ReadOnly Property DataBindings As System.Windows.Forms.ControlBindingsCollection
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Windows.Forms.ControlBindingsCollection

value = instance.DataBindings
C#
[System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.All)]
[SRDescriptionAttribute("The data bindings for the control.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.ParenthesizePropertyNameAttribute(true)]
[SRCategoryAttribute("Data")]
public System.Windows.Forms.ControlBindingsCollection DataBindings {get;}
Delphi
public read-only property DataBindings: System.Windows.Forms.ControlBindingsCollection;
JScript
System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.All)
SRDescriptionAttribute("The data bindings for the control.")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)
System.ComponentModel.ParenthesizePropertyNameAttribute()
SRCategoryAttribute("Data")
public function get DataBindings : System.Windows.Forms.ControlBindingsCollection
Managed Extensions for C++
[System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.All)]
[SRDescriptionAttribute("The data bindings for the control.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.ParenthesizePropertyNameAttribute(true)]
[SRCategoryAttribute("Data")]
public: __property System.Windows.Forms.ControlBindingsCollection* get_DataBindings();
C++/CLI
[System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.All)]
[SRDescriptionAttribute("The data bindings for the control.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
[System.ComponentModel.ParenthesizePropertyNameAttribute(true)]
[SRCategoryAttribute("Data")]
public:
property System.Windows.Forms.ControlBindingsCollection^ DataBindings {
   System.Windows.Forms.ControlBindingsCollection^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


Deactivate Event

[image]
Intersoft WebTextEditor Documentation
Deactivate Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : Deactivate Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Focus")>
<SRDescriptionAttribute("Occurs whenever the form is deactivated.")>
Public Event Deactivate As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.EventHandler

AddHandler instance.Deactivate, handler
C#
[SRCategoryAttribute("Focus")]
[SRDescriptionAttribute("Occurs whenever the form is deactivated.")]
public event System.EventHandler Deactivate
Delphi
public event Deactivate: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Focus")]
[SRDescriptionAttribute("Occurs whenever the form is deactivated.")]
public: __event System.EventHandler* Deactivate
C++/CLI
[SRCategoryAttribute("Focus")]
[SRDescriptionAttribute("Occurs whenever the form is deactivated.")]
public:
event System.EventHandler^ Deactivate

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


DefaultCursor Property

[image]
Intersoft WebTextEditor Documentation
DefaultCursor Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : DefaultCursor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property DefaultCursor As System.Windows.Forms.Cursor
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Windows.Forms.Cursor

value = instance.DefaultCursor
C#
protected virtual System.Windows.Forms.Cursor DefaultCursor {get;}
Delphi
protected read-only property DefaultCursor: System.Windows.Forms.Cursor; virtual;
JScript
protected function get DefaultCursor : System.Windows.Forms.Cursor
Managed Extensions for C++
protected: __property virtual System.Windows.Forms.Cursor* get_DefaultCursor();
C++/CLI
protected:
virtual property System.Windows.Forms.Cursor^ DefaultCursor {
   System.Windows.Forms.Cursor^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


DefaultImeMode Property

[image]
Intersoft WebTextEditor Documentation
DefaultImeMode Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : DefaultImeMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property DefaultImeMode As System.Windows.Forms.ImeMode
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Windows.Forms.ImeMode

value = instance.DefaultImeMode
C#
protected virtual System.Windows.Forms.ImeMode DefaultImeMode {get;}
Delphi
protected read-only property DefaultImeMode: System.Windows.Forms.ImeMode; virtual;
JScript
protected function get DefaultImeMode : System.Windows.Forms.ImeMode
Managed Extensions for C++
protected: __property virtual System.Windows.Forms.ImeMode get_DefaultImeMode();
C++/CLI
protected:
virtual property System.Windows.Forms.ImeMode DefaultImeMode {
   System.Windows.Forms.ImeMode get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


DefaultMargin Property

[image]
Intersoft WebTextEditor Documentation
DefaultMargin Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : DefaultMargin Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property DefaultMargin As System.Windows.Forms.Padding
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Windows.Forms.Padding

value = instance.DefaultMargin
C#
protected virtual System.Windows.Forms.Padding DefaultMargin {get;}
Delphi
protected read-only property DefaultMargin: System.Windows.Forms.Padding; virtual;
JScript
protected function get DefaultMargin : System.Windows.Forms.Padding
Managed Extensions for C++
protected: __property virtual System.Windows.Forms.Padding get_DefaultMargin();
C++/CLI
protected:
virtual property System.Windows.Forms.Padding DefaultMargin {
   System.Windows.Forms.Padding get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


DefaultMaximumSize Property

[image]
Intersoft WebTextEditor Documentation
DefaultMaximumSize Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : DefaultMaximumSize Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property DefaultMaximumSize As System.Drawing.Size
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Drawing.Size

value = instance.DefaultMaximumSize
C#
protected virtual System.Drawing.Size DefaultMaximumSize {get;}
Delphi
protected read-only property DefaultMaximumSize: System.Drawing.Size; virtual;
JScript
protected function get DefaultMaximumSize : System.Drawing.Size
Managed Extensions for C++
protected: __property virtual System.Drawing.Size get_DefaultMaximumSize();
C++/CLI
protected:
virtual property System.Drawing.Size DefaultMaximumSize {
   System.Drawing.Size get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


DefaultMinimumSize Property

[image]
Intersoft WebTextEditor Documentation
DefaultMinimumSize Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : DefaultMinimumSize Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property DefaultMinimumSize As System.Drawing.Size
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Drawing.Size

value = instance.DefaultMinimumSize
C#
protected virtual System.Drawing.Size DefaultMinimumSize {get;}
Delphi
protected read-only property DefaultMinimumSize: System.Drawing.Size; virtual;
JScript
protected function get DefaultMinimumSize : System.Drawing.Size
Managed Extensions for C++
protected: __property virtual System.Drawing.Size get_DefaultMinimumSize();
C++/CLI
protected:
virtual property System.Drawing.Size DefaultMinimumSize {
   System.Drawing.Size get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


DefaultPadding Property

[image]
Intersoft WebTextEditor Documentation
DefaultPadding Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : DefaultPadding Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property DefaultPadding As System.Windows.Forms.Padding
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Windows.Forms.Padding

value = instance.DefaultPadding
C#
protected virtual System.Windows.Forms.Padding DefaultPadding {get;}
Delphi
protected read-only property DefaultPadding: System.Windows.Forms.Padding; virtual;
JScript
protected function get DefaultPadding : System.Windows.Forms.Padding
Managed Extensions for C++
protected: __property virtual System.Windows.Forms.Padding get_DefaultPadding();
C++/CLI
protected:
virtual property System.Windows.Forms.Padding DefaultPadding {
   System.Windows.Forms.Padding get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


DefaultSize Property

[image]
Intersoft WebTextEditor Documentation
DefaultSize Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : DefaultSize Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable ReadOnly Property DefaultSize As System.Drawing.Size
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Drawing.Size

value = instance.DefaultSize
C#
protected virtual System.Drawing.Size DefaultSize {get;}
Delphi
protected read-only property DefaultSize: System.Drawing.Size; virtual;
JScript
protected function get DefaultSize : System.Drawing.Size
Managed Extensions for C++
protected: __property virtual System.Drawing.Size get_DefaultSize();
C++/CLI
protected:
virtual property System.Drawing.Size DefaultSize {
   System.Drawing.Size get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


DefWndProc Method

[image]
Intersoft WebTextEditor Documentation
DefWndProc Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : DefWndProc Method

m

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=False,
   UnmanagedCode=True,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=False,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand Or  _
    SecurityAction.Deny Or  _
    SecurityAction.LinkDemand,
   Unrestricted=False)>
Protected Overridable Sub DefWndProc( _
   ByRef m As System.Windows.Forms.Message _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim m As System.Windows.Forms.Message

instance.DefWndProc(m)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
protected virtual void DefWndProc(
   ref System.Windows.Forms.Message m
)
Delphi
protected procedure DefWndProc(
   var  m: System.Windows.Forms.Message
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=)
protected function DefWndProc(
   m : System.Windows.Forms.Message
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
protected: virtual void DefWndProc(
   ref System.Windows.Forms.Message m
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
protected:
virtual void DefWndProc(
   System.Windows.Forms.Message% m
)

Parameters

m

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


DesignMode Property

[image]
Intersoft WebTextEditor Documentation
DesignMode Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : DesignMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
Protected ReadOnly Property DesignMode As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Boolean

value = instance.DesignMode
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
protected System.bool DesignMode {get;}
Delphi
protected read-only property DesignMode: System.Boolean;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
protected function get DesignMode : System.boolean
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
protected: __property System.bool get_DesignMode();
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
protected:
property System.bool DesignMode {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


DesktopBounds Property

[image]
Intersoft WebTextEditor Documentation
DesktopBounds Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : DesktopBounds Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The bounds of this form in desktop coordinates.")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<SRCategoryAttribute("Layout")>
<System.ComponentModel.BrowsableAttribute(False)>
Public Property DesktopBounds As System.Drawing.Rectangle
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Drawing.Rectangle

instance.DesktopBounds = value

value = instance.DesktopBounds
C#
[SRDescriptionAttribute("The bounds of this form in desktop coordinates.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[SRCategoryAttribute("Layout")]
[System.ComponentModel.BrowsableAttribute(false)]
public System.Drawing.Rectangle DesktopBounds {get; set;}
Delphi
public read-write property DesktopBounds: System.Drawing.Rectangle;
JScript
SRDescriptionAttribute("The bounds of this form in desktop coordinates.")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
SRCategoryAttribute("Layout")
System.ComponentModel.BrowsableAttribute()
public function get,set DesktopBounds : System.Drawing.Rectangle
Managed Extensions for C++
[SRDescriptionAttribute("The bounds of this form in desktop coordinates.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[SRCategoryAttribute("Layout")]
[System.ComponentModel.BrowsableAttribute(false)]
public: __property System.Drawing.Rectangle get_DesktopBounds();
public: __property void set_DesktopBounds(
   System.Drawing.Rectangle value
);
C++/CLI
[SRDescriptionAttribute("The bounds of this form in desktop coordinates.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[SRCategoryAttribute("Layout")]
[System.ComponentModel.BrowsableAttribute(false)]
public:
property System.Drawing.Rectangle DesktopBounds {
   System.Drawing.Rectangle get();
   void set (    System.Drawing.Rectangle value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


DesktopLocation Property

[image]
Intersoft WebTextEditor Documentation
DesktopLocation Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : DesktopLocation Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The location of this form in desktop coordinates.")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<SRCategoryAttribute("Layout")>
<System.ComponentModel.BrowsableAttribute(False)>
Public Property DesktopLocation As System.Drawing.Point
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Drawing.Point

instance.DesktopLocation = value

value = instance.DesktopLocation
C#
[SRDescriptionAttribute("The location of this form in desktop coordinates.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[SRCategoryAttribute("Layout")]
[System.ComponentModel.BrowsableAttribute(false)]
public System.Drawing.Point DesktopLocation {get; set;}
Delphi
public read-write property DesktopLocation: System.Drawing.Point;
JScript
SRDescriptionAttribute("The location of this form in desktop coordinates.")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
SRCategoryAttribute("Layout")
System.ComponentModel.BrowsableAttribute()
public function get,set DesktopLocation : System.Drawing.Point
Managed Extensions for C++
[SRDescriptionAttribute("The location of this form in desktop coordinates.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[SRCategoryAttribute("Layout")]
[System.ComponentModel.BrowsableAttribute(false)]
public: __property System.Drawing.Point get_DesktopLocation();
public: __property void set_DesktopLocation(
   System.Drawing.Point value
);
C++/CLI
[SRDescriptionAttribute("The location of this form in desktop coordinates.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[SRCategoryAttribute("Layout")]
[System.ComponentModel.BrowsableAttribute(false)]
public:
property System.Drawing.Point DesktopLocation {
   System.Drawing.Point get();
   void set (    System.Drawing.Point value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


DestroyHandle Method

[image]
Intersoft WebTextEditor Documentation
DestroyHandle Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : DestroyHandle Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.SafeSubWindows Or  _
    UIPermissionWindow.SafeTopLevelWindows Or  _
    UIPermissionWindow.AllWindows,
   Clipboard=UIPermissionClipboard.NoClipboard,
   Action=SecurityAction.Demand Or  _
    SecurityAction.Deny Or  _
    SecurityAction.LinkDemand,
   Unrestricted=False)>
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=False,
   UnmanagedCode=True,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=False,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand Or  _
    SecurityAction.Assert Or  _
    SecurityAction.Deny Or  _
    SecurityAction.PermitOnly Or  _
    SecurityAction.LinkDemand Or  _
    SecurityAction.InheritanceDemand,
   Unrestricted=False)>
Protected Overridable Sub DestroyHandle()
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm

instance.DestroyHandle()
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.SafeSubWindows |
    UIPermissionWindow.SafeTopLevelWindows |
    UIPermissionWindow.AllWindows,
   Clipboard=UIPermissionClipboard.NoClipboard,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
protected virtual void DestroyHandle()
Delphi
protected procedure DestroyHandle(); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.SafeSubWindows |
    UIPermissionWindow.SafeTopLevelWindows |
    UIPermissionWindow.AllWindows,
   Clipboard=UIPermissionClipboard.NoClipboard,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=)
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=)
protected function DestroyHandle();
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.SafeSubWindows |
    UIPermissionWindow.SafeTopLevelWindows |
    UIPermissionWindow.AllWindows,
   Clipboard=UIPermissionClipboard.NoClipboard,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
protected: virtual void DestroyHandle();
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.SafeSubWindows |
    UIPermissionWindow.SafeTopLevelWindows |
    UIPermissionWindow.AllWindows,
   Clipboard=UIPermissionClipboard.NoClipboard,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
protected:
virtual void DestroyHandle();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


DialogResult Property

[image]
Intersoft WebTextEditor Documentation
DialogResult Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : DialogResult Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("The value this form will return if displayed as a dialog box.")>
Public Property DialogResult As System.Windows.Forms.DialogResult
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Windows.Forms.DialogResult

instance.DialogResult = value

value = instance.DialogResult
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("The value this form will return if displayed as a dialog box.")]
public System.Windows.Forms.DialogResult DialogResult {get; set;}
Delphi
public read-write property DialogResult: System.Windows.Forms.DialogResult;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
SRCategoryAttribute("Behavior")
SRDescriptionAttribute("The value this form will return if displayed as a dialog box.")
public function get,set DialogResult : System.Windows.Forms.DialogResult
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("The value this form will return if displayed as a dialog box.")]
public: __property System.Windows.Forms.DialogResult get_DialogResult();
public: __property void set_DialogResult(
   System.Windows.Forms.DialogResult value
);
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("The value this form will return if displayed as a dialog box.")]
public:
property System.Windows.Forms.DialogResult DialogResult {
   System.Windows.Forms.DialogResult get();
   void set (    System.Windows.Forms.DialogResult value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


DisplayRectangle Property

[image]
Intersoft WebTextEditor Documentation
DisplayRectangle Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : DisplayRectangle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable ReadOnly Property DisplayRectangle As System.Drawing.Rectangle
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Drawing.Rectangle

value = instance.DisplayRectangle
C#
public virtual System.Drawing.Rectangle DisplayRectangle {get;}
Delphi
public read-only property DisplayRectangle: System.Drawing.Rectangle; virtual;
JScript
public function get DisplayRectangle : System.Drawing.Rectangle
Managed Extensions for C++
public: __property virtual System.Drawing.Rectangle get_DisplayRectangle();
C++/CLI
public:
virtual property System.Drawing.Rectangle DisplayRectangle {
   System.Drawing.Rectangle get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


Dispose() Method

[image]
Intersoft WebTextEditor Documentation
Dispose() Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class > Dispose Method : Dispose() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm

instance.Dispose()
C#
public void Dispose()
Delphi
public procedure Dispose();
JScript
public function Dispose();
Managed Extensions for C++
public: void Dispose();
C++/CLI
public:
void Dispose();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members
Overload List


Disposed Event

[image]
Intersoft WebTextEditor Documentation
Disposed Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : Disposed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Event Disposed As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.EventHandler

AddHandler instance.Disposed, handler
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public event System.EventHandler Disposed
Delphi
public event Disposed: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: __event System.EventHandler* Disposed
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
event System.EventHandler^ Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


Disposing Property

[image]
Intersoft WebTextEditor Documentation
Disposing Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : Disposing Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Determines whether this control is in the process of being disposed. ")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<System.ComponentModel.BrowsableAttribute(False)>
Public ReadOnly Property Disposing As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Boolean

value = instance.Disposing
C#
[SRDescriptionAttribute("Determines whether this control is in the process of being disposed. ")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.ComponentModel.BrowsableAttribute(false)]
public System.bool Disposing {get;}
Delphi
public read-only property Disposing: System.Boolean;
JScript
SRDescriptionAttribute("Determines whether this control is in the process of being disposed. ")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
System.ComponentModel.BrowsableAttribute()
public function get Disposing : System.boolean
Managed Extensions for C++
[SRDescriptionAttribute("Determines whether this control is in the process of being disposed. ")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.ComponentModel.BrowsableAttribute(false)]
public: __property System.bool get_Disposing();
C++/CLI
[SRDescriptionAttribute("Determines whether this control is in the process of being disposed. ")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.ComponentModel.BrowsableAttribute(false)]
public:
property System.bool Disposing {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


Dock Property

[image]
Intersoft WebTextEditor Documentation
Dock Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : Dock Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Layout")>
<System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.Repaint)>
<System.ComponentModel.LocalizableAttribute(True)>
<SRDescriptionAttribute("Defines which borders of the control are bound to the container. ")>
<System.ComponentModel.DefaultValueAttribute()>
Public Overridable Property Dock As System.Windows.Forms.DockStyle
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Windows.Forms.DockStyle

instance.Dock = value

value = instance.Dock
C#
[SRCategoryAttribute("Layout")]
[System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.Repaint)]
[System.ComponentModel.LocalizableAttribute(true)]
[SRDescriptionAttribute("Defines which borders of the control are bound to the container. ")]
[System.ComponentModel.DefaultValueAttribute()]
public virtual System.Windows.Forms.DockStyle Dock {get; set;}
Delphi
public read-write property Dock: System.Windows.Forms.DockStyle; virtual;
JScript
SRCategoryAttribute("Layout")
System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.Repaint)
System.ComponentModel.LocalizableAttribute()
SRDescriptionAttribute("Defines which borders of the control are bound to the container. ")
System.ComponentModel.DefaultValueAttribute()
public function get,set Dock : System.Windows.Forms.DockStyle
Managed Extensions for C++
[SRCategoryAttribute("Layout")]
[System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.Repaint)]
[System.ComponentModel.LocalizableAttribute(true)]
[SRDescriptionAttribute("Defines which borders of the control are bound to the container. ")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property virtual System.Windows.Forms.DockStyle get_Dock();
public: __property virtual void set_Dock(
   System.Windows.Forms.DockStyle value
);
C++/CLI
[SRCategoryAttribute("Layout")]
[System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.Repaint)]
[System.ComponentModel.LocalizableAttribute(true)]
[SRDescriptionAttribute("Defines which borders of the control are bound to the container. ")]
[System.ComponentModel.DefaultValueAttribute()]
public:
virtual property System.Windows.Forms.DockStyle Dock {
   System.Windows.Forms.DockStyle get();
   void set (    System.Windows.Forms.DockStyle value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


DockChanged Event

[image]
Intersoft WebTextEditor Documentation
DockChanged Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : DockChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Event raised when the value of the Dock property is changed on Control.")>
<SRCategoryAttribute("Property Changed")>
Public Event DockChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.EventHandler

AddHandler instance.DockChanged, handler
C#
[SRDescriptionAttribute("Event raised when the value of the Dock property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public event System.EventHandler DockChanged
Delphi
public event DockChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Event raised when the value of the Dock property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public: __event System.EventHandler* DockChanged
C++/CLI
[SRDescriptionAttribute("Event raised when the value of the Dock property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public:
event System.EventHandler^ DockChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


DoDragDrop Method

[image]
Intersoft WebTextEditor Documentation
DoDragDrop Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : DoDragDrop Method

data
allowedEffects

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.NoWindows,
   Clipboard=UIPermissionClipboard.OwnClipboard,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Function DoDragDrop( _
   ByVal data As System.Object, _
   ByVal allowedEffects As System.Windows.Forms.DragDropEffects _
) As System.Windows.Forms.DragDropEffects
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim data As System.Object
Dim allowedEffects As System.Windows.Forms.DragDropEffects
Dim value As System.Windows.Forms.DragDropEffects

value = instance.DoDragDrop(data, allowedEffects)
C#
[System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.NoWindows,
   Clipboard=UIPermissionClipboard.OwnClipboard,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public System.Windows.Forms.DragDropEffects DoDragDrop(
   System.object data,
   System.Windows.Forms.DragDropEffects allowedEffects
)
Delphi
public function DoDragDrop(
    data: System.TObject;
    allowedEffects: System.Windows.Forms.DragDropEffects
): System.Windows.Forms.DragDropEffects;
JScript
System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.NoWindows,
   Clipboard=UIPermissionClipboard.OwnClipboard,
   Action=SecurityAction.Demand,
   Unrestricted=)
public function DoDragDrop(
   data : System.Object,
   allowedEffects : System.Windows.Forms.DragDropEffects
) : System.Windows.Forms.DragDropEffects;
Managed Extensions for C++
[System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.NoWindows,
   Clipboard=UIPermissionClipboard.OwnClipboard,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: System.Windows.Forms.DragDropEffects DoDragDrop(
   System.Object* data,
   System.Windows.Forms.DragDropEffects allowedEffects
)
C++/CLI
[System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.NoWindows,
   Clipboard=UIPermissionClipboard.OwnClipboard,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
System.Windows.Forms.DragDropEffects DoDragDrop(
   System.Object^ data,
   System.Windows.Forms.DragDropEffects allowedEffects
)

Parameters

data
allowedEffects

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


DoubleBuffered Property

[image]
Intersoft WebTextEditor Documentation
DoubleBuffered Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : DoubleBuffered Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Indicates whether the control will be double buffered.")>
<SRCategoryAttribute("Behavior")>
Protected Overridable Property DoubleBuffered As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Boolean

instance.DoubleBuffered = value

value = instance.DoubleBuffered
C#
[SRDescriptionAttribute("Indicates whether the control will be double buffered.")]
[SRCategoryAttribute("Behavior")]
protected virtual System.bool DoubleBuffered {get; set;}
Delphi
protected read-write property DoubleBuffered: System.Boolean; virtual;
JScript
SRDescriptionAttribute("Indicates whether the control will be double buffered.")
SRCategoryAttribute("Behavior")
protected function get,set DoubleBuffered : System.boolean
Managed Extensions for C++
[SRDescriptionAttribute("Indicates whether the control will be double buffered.")]
[SRCategoryAttribute("Behavior")]
protected: __property virtual System.bool get_DoubleBuffered();
protected: __property virtual void set_DoubleBuffered(
   System.bool value
);
C++/CLI
[SRDescriptionAttribute("Indicates whether the control will be double buffered.")]
[SRCategoryAttribute("Behavior")]
protected:
virtual property System.bool DoubleBuffered {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


DoubleClick Event

[image]
Intersoft WebTextEditor Documentation
DoubleClick Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : DoubleClick Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the component is double-clicked.")>
<SRCategoryAttribute("Action")>
Public Event DoubleClick As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.EventHandler

AddHandler instance.DoubleClick, handler
C#
[SRDescriptionAttribute("Occurs when the component is double-clicked.")]
[SRCategoryAttribute("Action")]
public event System.EventHandler DoubleClick
Delphi
public event DoubleClick: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the component is double-clicked.")]
[SRCategoryAttribute("Action")]
public: __event System.EventHandler* DoubleClick
C++/CLI
[SRDescriptionAttribute("Occurs when the component is double-clicked.")]
[SRCategoryAttribute("Action")]
public:
event System.EventHandler^ DoubleClick

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


DragDrop Event

[image]
Intersoft WebTextEditor Documentation
DragDrop Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : DragDrop Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when a drag-and-drop operation is completed.")>
<SRCategoryAttribute("Drag Drop")>
Public Event DragDrop As System.Windows.Forms.DragEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.Windows.Forms.DragEventHandler

AddHandler instance.DragDrop, handler
C#
[SRDescriptionAttribute("Occurs when a drag-and-drop operation is completed.")]
[SRCategoryAttribute("Drag Drop")]
public event System.Windows.Forms.DragEventHandler DragDrop
Delphi
public event DragDrop: System.Windows.Forms.DragEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when a drag-and-drop operation is completed.")]
[SRCategoryAttribute("Drag Drop")]
public: __event System.Windows.Forms.DragEventHandler* DragDrop
C++/CLI
[SRDescriptionAttribute("Occurs when a drag-and-drop operation is completed.")]
[SRCategoryAttribute("Drag Drop")]
public:
event System.Windows.Forms.DragEventHandler^ DragDrop

Event Data

The event handler receives an argument of type System.Windows.Forms.DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


DragEnter Event

[image]
Intersoft WebTextEditor Documentation
DragEnter Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : DragEnter Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Drag Drop")>
<SRDescriptionAttribute("Occurs when the mouse drags an item into the client area for this Control.")>
Public Event DragEnter As System.Windows.Forms.DragEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.Windows.Forms.DragEventHandler

AddHandler instance.DragEnter, handler
C#
[SRCategoryAttribute("Drag Drop")]
[SRDescriptionAttribute("Occurs when the mouse drags an item into the client area for this Control.")]
public event System.Windows.Forms.DragEventHandler DragEnter
Delphi
public event DragEnter: System.Windows.Forms.DragEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Drag Drop")]
[SRDescriptionAttribute("Occurs when the mouse drags an item into the client area for this Control.")]
public: __event System.Windows.Forms.DragEventHandler* DragEnter
C++/CLI
[SRCategoryAttribute("Drag Drop")]
[SRDescriptionAttribute("Occurs when the mouse drags an item into the client area for this Control.")]
public:
event System.Windows.Forms.DragEventHandler^ DragEnter

Event Data

The event handler receives an argument of type System.Windows.Forms.DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


DragLeave Event

[image]
Intersoft WebTextEditor Documentation
DragLeave Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : DragLeave Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Drag Drop")>
<SRDescriptionAttribute("Occurs when an object is dragged out of the control's bounds.")>
Public Event DragLeave As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.EventHandler

AddHandler instance.DragLeave, handler
C#
[SRCategoryAttribute("Drag Drop")]
[SRDescriptionAttribute("Occurs when an object is dragged out of the control's bounds.")]
public event System.EventHandler DragLeave
Delphi
public event DragLeave: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Drag Drop")]
[SRDescriptionAttribute("Occurs when an object is dragged out of the control's bounds.")]
public: __event System.EventHandler* DragLeave
C++/CLI
[SRCategoryAttribute("Drag Drop")]
[SRDescriptionAttribute("Occurs when an object is dragged out of the control's bounds.")]
public:
event System.EventHandler^ DragLeave

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


DragOver Event

[image]
Intersoft WebTextEditor Documentation
DragOver Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : DragOver Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Drag Drop")>
<SRDescriptionAttribute("Occurs when an object is dragged over the control's bounds.")>
Public Event DragOver As System.Windows.Forms.DragEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.Windows.Forms.DragEventHandler

AddHandler instance.DragOver, handler
C#
[SRCategoryAttribute("Drag Drop")]
[SRDescriptionAttribute("Occurs when an object is dragged over the control's bounds.")]
public event System.Windows.Forms.DragEventHandler DragOver
Delphi
public event DragOver: System.Windows.Forms.DragEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Drag Drop")]
[SRDescriptionAttribute("Occurs when an object is dragged over the control's bounds.")]
public: __event System.Windows.Forms.DragEventHandler* DragOver
C++/CLI
[SRCategoryAttribute("Drag Drop")]
[SRDescriptionAttribute("Occurs when an object is dragged over the control's bounds.")]
public:
event System.Windows.Forms.DragEventHandler^ DragOver

Event Data

The event handler receives an argument of type System.Windows.Forms.DragEventArgs containing data related to this event. The following DragEventArgs properties provide information specific to this event.

Property | Description
AllowedEffect | Gets which drag-and-drop operations are allowed by the originator (or source) of the drag event.
Data | Gets the System.Windows.Forms.IDataObject that contains the data associated with this event.
Effect | Gets or sets the target drop effect in a drag-and-drop operation.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys, as well as the state of the mouse buttons.
X | Gets the x-coordinate of the mouse pointer, in screen coordinates.
Y | Gets the y-coordinate of the mouse pointer, in screen coordinates.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


DrawToBitmap Method

[image]
Intersoft WebTextEditor Documentation
DrawToBitmap Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : DrawToBitmap Method

bitmap
targetBounds

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.SafeSubWindows Or  _
    UIPermissionWindow.SafeTopLevelWindows Or  _
    UIPermissionWindow.AllWindows,
   Clipboard=UIPermissionClipboard.NoClipboard,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Sub DrawToBitmap( _
   ByVal bitmap As System.Drawing.Bitmap, _
   ByVal targetBounds As System.Drawing.Rectangle _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim bitmap As System.Drawing.Bitmap
Dim targetBounds As System.Drawing.Rectangle

instance.DrawToBitmap(bitmap, targetBounds)
C#
[System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.SafeSubWindows |
    UIPermissionWindow.SafeTopLevelWindows |
    UIPermissionWindow.AllWindows,
   Clipboard=UIPermissionClipboard.NoClipboard,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public void DrawToBitmap(
   System.Drawing.Bitmap bitmap,
   System.Drawing.Rectangle targetBounds
)
Delphi
public procedure DrawToBitmap(
    bitmap: System.Drawing.Bitmap;
    targetBounds: System.Drawing.Rectangle
);
JScript
System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.SafeSubWindows |
    UIPermissionWindow.SafeTopLevelWindows |
    UIPermissionWindow.AllWindows,
   Clipboard=UIPermissionClipboard.NoClipboard,
   Action=SecurityAction.Demand,
   Unrestricted=)
public function DrawToBitmap(
   bitmap : System.Drawing.Bitmap,
   targetBounds : System.Drawing.Rectangle
);
Managed Extensions for C++
[System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.SafeSubWindows |
    UIPermissionWindow.SafeTopLevelWindows |
    UIPermissionWindow.AllWindows,
   Clipboard=UIPermissionClipboard.NoClipboard,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: void DrawToBitmap(
   System.Drawing.Bitmap* bitmap,
   System.Drawing.Rectangle targetBounds
)
C++/CLI
[System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.SafeSubWindows |
    UIPermissionWindow.SafeTopLevelWindows |
    UIPermissionWindow.AllWindows,
   Clipboard=UIPermissionClipboard.NoClipboard,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
void DrawToBitmap(
   System.Drawing.Bitmap^ bitmap,
   System.Drawing.Rectangle targetBounds
)

Parameters

bitmap
targetBounds

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


Enabled Property

[image]
Intersoft WebTextEditor Documentation
Enabled Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : Enabled Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Indicates whether the control is enabled.")>
<System.ComponentModel.LocalizableAttribute(True)>
<SRCategoryAttribute("Behavior")>
<System.Runtime.InteropServices.DispIdAttribute(-514)>
Public Property Enabled As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Boolean

instance.Enabled = value

value = instance.Enabled
C#
[SRDescriptionAttribute("Indicates whether the control is enabled.")]
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Behavior")]
[System.Runtime.InteropServices.DispIdAttribute(-514)]
public System.bool Enabled {get; set;}
Delphi
public read-write property Enabled: System.Boolean;
JScript
SRDescriptionAttribute("Indicates whether the control is enabled.")
System.ComponentModel.LocalizableAttribute()
SRCategoryAttribute("Behavior")
System.Runtime.InteropServices.DispIdAttribute(-514)
public function get,set Enabled : System.boolean
Managed Extensions for C++
[SRDescriptionAttribute("Indicates whether the control is enabled.")]
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Behavior")]
[System.Runtime.InteropServices.DispIdAttribute(-514)]
public: __property System.bool get_Enabled();
public: __property void set_Enabled(
   System.bool value
);
C++/CLI
[SRDescriptionAttribute("Indicates whether the control is enabled.")]
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Behavior")]
[System.Runtime.InteropServices.DispIdAttribute(-514)]
public:
property System.bool Enabled {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


EnabledChanged Event

[image]
Intersoft WebTextEditor Documentation
EnabledChanged Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : EnabledChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Property Changed")>
<SRDescriptionAttribute("Occurs when the control's enabled state changes.")>
Public Event EnabledChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.EventHandler

AddHandler instance.EnabledChanged, handler
C#
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the control's enabled state changes.")]
public event System.EventHandler EnabledChanged
Delphi
public event EnabledChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the control's enabled state changes.")]
public: __event System.EventHandler* EnabledChanged
C++/CLI
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the control's enabled state changes.")]
public:
event System.EventHandler^ EnabledChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


EndInvoke Method

[image]
Intersoft WebTextEditor Documentation
EndInvoke Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : EndInvoke Method

asyncResult

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Function EndInvoke( _
   ByVal asyncResult As System.IAsyncResult _
) As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim asyncResult As System.IAsyncResult
Dim value As System.Object

value = instance.EndInvoke(asyncResult)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public System.object EndInvoke(
   System.IAsyncResult asyncResult
)
Delphi
public function EndInvoke(
    asyncResult: System.IAsyncResult
): System.TObject;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function EndInvoke(
   asyncResult : System.IAsyncResult
) : System.Object;
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: System.Object* EndInvoke(
   System.IAsyncResult* asyncResult
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
System.Object^ EndInvoke(
   System.IAsyncResult^ asyncResult
)

Parameters

asyncResult

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


Enter Event

[image]
Intersoft WebTextEditor Documentation
Enter Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : Enter Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the control becomes the active control of the form.")>
<SRCategoryAttribute("Focus")>
Public Event Enter As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.EventHandler

AddHandler instance.Enter, handler
C#
[SRDescriptionAttribute("Occurs when the control becomes the active control of the form.")]
[SRCategoryAttribute("Focus")]
public event System.EventHandler Enter
Delphi
public event Enter: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the control becomes the active control of the form.")]
[SRCategoryAttribute("Focus")]
public: __event System.EventHandler* Enter
C++/CLI
[SRDescriptionAttribute("Occurs when the control becomes the active control of the form.")]
[SRCategoryAttribute("Focus")]
public:
event System.EventHandler^ Enter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


Events Property

[image]
Intersoft WebTextEditor Documentation
Events Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : Events Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property Events As System.ComponentModel.EventHandlerList
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.ComponentModel.EventHandlerList

value = instance.Events
C#
protected System.ComponentModel.EventHandlerList Events {get;}
Delphi
protected read-only property Events: System.ComponentModel.EventHandlerList;
JScript
protected function get Events : System.ComponentModel.EventHandlerList
Managed Extensions for C++
protected: __property System.ComponentModel.EventHandlerList* get_Events();
C++/CLI
protected:
property System.ComponentModel.EventHandlerList^ Events {
   System.ComponentModel.EventHandlerList^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


Finalize Method

[image]
Intersoft WebTextEditor Documentation
Finalize Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : Finalize Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub Finalize()
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm

instance.Finalize()
C#
protected virtual void Finalize()
Delphi
protected procedure Finalize(); virtual;
JScript
protected function Finalize();
Managed Extensions for C++
protected: virtual void Finalize();
C++/CLI
protected:
virtual void Finalize();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


FindForm Method

[image]
Intersoft WebTextEditor Documentation
FindForm Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : FindForm Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
<System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.SafeSubWindows Or  _
    UIPermissionWindow.SafeTopLevelWindows Or  _
    UIPermissionWindow.AllWindows,
   Clipboard=UIPermissionClipboard.NoClipboard,
   Action=SecurityAction.Demand,
   Unrestricted=False)>
Public Function FindForm() As System.Windows.Forms.Form
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Windows.Forms.Form

value = instance.FindForm()
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
[System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.SafeSubWindows |
    UIPermissionWindow.SafeTopLevelWindows |
    UIPermissionWindow.AllWindows,
   Clipboard=UIPermissionClipboard.NoClipboard,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public System.Windows.Forms.Form FindForm()
Delphi
public function FindForm(): System.Windows.Forms.Form;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.SafeSubWindows |
    UIPermissionWindow.SafeTopLevelWindows |
    UIPermissionWindow.AllWindows,
   Clipboard=UIPermissionClipboard.NoClipboard,
   Action=SecurityAction.Demand,
   Unrestricted=)
public function FindForm() : System.Windows.Forms.Form;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
[System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.SafeSubWindows |
    UIPermissionWindow.SafeTopLevelWindows |
    UIPermissionWindow.AllWindows,
   Clipboard=UIPermissionClipboard.NoClipboard,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public: System.Windows.Forms.Form* FindForm();
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
[System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.SafeSubWindows |
    UIPermissionWindow.SafeTopLevelWindows |
    UIPermissionWindow.AllWindows,
   Clipboard=UIPermissionClipboard.NoClipboard,
   Action=SecurityAction.Demand,
   Unrestricted=false)]
public:
System.Windows.Forms.Form^ FindForm();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


Focus Method

[image]
Intersoft WebTextEditor Documentation
Focus Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : Focus Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Function Focus() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Boolean

value = instance.Focus()
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public System.bool Focus()
Delphi
public function Focus(): System.Boolean;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function Focus() : System.boolean;
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: System.bool Focus();
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
System.bool Focus();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


Focused Property

[image]
Intersoft WebTextEditor Documentation
Focused Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : Focused Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<SRDescriptionAttribute("Determines if this control has focus.")>
<System.ComponentModel.BrowsableAttribute(False)>
Public Overridable ReadOnly Property Focused As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Boolean

value = instance.Focused
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRDescriptionAttribute("Determines if this control has focus.")]
[System.ComponentModel.BrowsableAttribute(false)]
public virtual System.bool Focused {get;}
Delphi
public read-only property Focused: System.Boolean; virtual;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
SRDescriptionAttribute("Determines if this control has focus.")
System.ComponentModel.BrowsableAttribute()
public function get Focused : System.boolean
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRDescriptionAttribute("Determines if this control has focus.")]
[System.ComponentModel.BrowsableAttribute(false)]
public: __property virtual System.bool get_Focused();
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRDescriptionAttribute("Determines if this control has focus.")]
[System.ComponentModel.BrowsableAttribute(false)]
public:
virtual property System.bool Focused {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


Font Property

[image]
Intersoft WebTextEditor Documentation
Font Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : Font Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.AmbientValueAttribute()>
<SRCategoryAttribute("Appearance")>
<System.ComponentModel.LocalizableAttribute(True)>
<System.Runtime.InteropServices.DispIdAttribute(-512)>
<SRDescriptionAttribute("The font used to display text in the control.")>
Public Overridable Property Font As System.Drawing.Font
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Drawing.Font

instance.Font = value

value = instance.Font
C#
[System.ComponentModel.AmbientValueAttribute()]
[SRCategoryAttribute("Appearance")]
[System.ComponentModel.LocalizableAttribute(true)]
[System.Runtime.InteropServices.DispIdAttribute(-512)]
[SRDescriptionAttribute("The font used to display text in the control.")]
public virtual System.Drawing.Font Font {get; set;}
Delphi
public read-write property Font: System.Drawing.Font; virtual;
JScript
System.ComponentModel.AmbientValueAttribute()
SRCategoryAttribute("Appearance")
System.ComponentModel.LocalizableAttribute()
System.Runtime.InteropServices.DispIdAttribute(-512)
SRDescriptionAttribute("The font used to display text in the control.")
public function get,set Font : System.Drawing.Font
Managed Extensions for C++
[System.ComponentModel.AmbientValueAttribute()]
[SRCategoryAttribute("Appearance")]
[System.ComponentModel.LocalizableAttribute(true)]
[System.Runtime.InteropServices.DispIdAttribute(-512)]
[SRDescriptionAttribute("The font used to display text in the control.")]
public: __property virtual System.Drawing.Font* get_Font();
public: __property virtual void set_Font(
   System.Drawing.Font* value
);
C++/CLI
[System.ComponentModel.AmbientValueAttribute()]
[SRCategoryAttribute("Appearance")]
[System.ComponentModel.LocalizableAttribute(true)]
[System.Runtime.InteropServices.DispIdAttribute(-512)]
[SRDescriptionAttribute("The font used to display text in the control.")]
public:
virtual property System.Drawing.Font^ Font {
   System.Drawing.Font^ get();
   void set (    System.Drawing.Font^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


FontChanged Event

[image]
Intersoft WebTextEditor Documentation
FontChanged Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : FontChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Event raised when the value of the Font property is changed on Control.")>
<SRCategoryAttribute("Property Changed")>
Public Event FontChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.EventHandler

AddHandler instance.FontChanged, handler
C#
[SRDescriptionAttribute("Event raised when the value of the Font property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public event System.EventHandler FontChanged
Delphi
public event FontChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Event raised when the value of the Font property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public: __event System.EventHandler* FontChanged
C++/CLI
[SRDescriptionAttribute("Event raised when the value of the Font property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public:
event System.EventHandler^ FontChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


FontHeight Property

[image]
Intersoft WebTextEditor Documentation
FontHeight Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : FontHeight Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Property FontHeight As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Integer

instance.FontHeight = value

value = instance.FontHeight
C#
protected System.int FontHeight {get; set;}
Delphi
protected read-write property FontHeight: System.Integer;
JScript
protected function get,set FontHeight : System.int
Managed Extensions for C++
protected: __property System.int get_FontHeight();
protected: __property void set_FontHeight(
   System.int value
);
C++/CLI
protected:
property System.int FontHeight {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


ForeColor Property

[image]
Intersoft WebTextEditor Documentation
ForeColor Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : ForeColor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The foreground color of this component, which is used to display text.")>
<System.Runtime.InteropServices.DispIdAttribute(-513)>
<SRCategoryAttribute("Appearance")>
Public Overridable Property ForeColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Drawing.Color

instance.ForeColor = value

value = instance.ForeColor
C#
[SRDescriptionAttribute("The foreground color of this component, which is used to display text.")]
[System.Runtime.InteropServices.DispIdAttribute(-513)]
[SRCategoryAttribute("Appearance")]
public virtual System.Drawing.Color ForeColor {get; set;}
Delphi
public read-write property ForeColor: System.Drawing.Color; virtual;
JScript
SRDescriptionAttribute("The foreground color of this component, which is used to display text.")
System.Runtime.InteropServices.DispIdAttribute(-513)
SRCategoryAttribute("Appearance")
public function get,set ForeColor : System.Drawing.Color
Managed Extensions for C++
[SRDescriptionAttribute("The foreground color of this component, which is used to display text.")]
[System.Runtime.InteropServices.DispIdAttribute(-513)]
[SRCategoryAttribute("Appearance")]
public: __property virtual System.Drawing.Color get_ForeColor();
public: __property virtual void set_ForeColor(
   System.Drawing.Color value
);
C++/CLI
[SRDescriptionAttribute("The foreground color of this component, which is used to display text.")]
[System.Runtime.InteropServices.DispIdAttribute(-513)]
[SRCategoryAttribute("Appearance")]
public:
virtual property System.Drawing.Color ForeColor {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


ForeColorChanged Event

[image]
Intersoft WebTextEditor Documentation
ForeColorChanged Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : ForeColorChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Property Changed")>
<SRDescriptionAttribute("Event raised when the value of the ForeColor property is changed on Control.")>
Public Event ForeColorChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.EventHandler

AddHandler instance.ForeColorChanged, handler
C#
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the ForeColor property is changed on Control.")]
public event System.EventHandler ForeColorChanged
Delphi
public event ForeColorChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the ForeColor property is changed on Control.")]
public: __event System.EventHandler* ForeColorChanged
C++/CLI
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the ForeColor property is changed on Control.")]
public:
event System.EventHandler^ ForeColorChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


FormBorderStyle Property

[image]
Intersoft WebTextEditor Documentation
FormBorderStyle Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : FormBorderStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<SRDescriptionAttribute("Indicates the appearance and behavior of the border and title bar of the form.")>
<System.Runtime.InteropServices.DispIdAttribute(-504)>
<SRCategoryAttribute("Appearance")>
Public Property FormBorderStyle As System.Windows.Forms.FormBorderStyle
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Windows.Forms.FormBorderStyle

instance.FormBorderStyle = value

value = instance.FormBorderStyle
C#
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("Indicates the appearance and behavior of the border and title bar of the form.")]
[System.Runtime.InteropServices.DispIdAttribute(-504)]
[SRCategoryAttribute("Appearance")]
public System.Windows.Forms.FormBorderStyle FormBorderStyle {get; set;}
Delphi
public read-write property FormBorderStyle: System.Windows.Forms.FormBorderStyle;
JScript
System.ComponentModel.DefaultValueAttribute()
SRDescriptionAttribute("Indicates the appearance and behavior of the border and title bar of the form.")
System.Runtime.InteropServices.DispIdAttribute(-504)
SRCategoryAttribute("Appearance")
public function get,set FormBorderStyle : System.Windows.Forms.FormBorderStyle
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("Indicates the appearance and behavior of the border and title bar of the form.")]
[System.Runtime.InteropServices.DispIdAttribute(-504)]
[SRCategoryAttribute("Appearance")]
public: __property System.Windows.Forms.FormBorderStyle get_FormBorderStyle();
public: __property void set_FormBorderStyle(
   System.Windows.Forms.FormBorderStyle value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("Indicates the appearance and behavior of the border and title bar of the form.")]
[System.Runtime.InteropServices.DispIdAttribute(-504)]
[SRCategoryAttribute("Appearance")]
public:
property System.Windows.Forms.FormBorderStyle FormBorderStyle {
   System.Windows.Forms.FormBorderStyle get();
   void set (    System.Windows.Forms.FormBorderStyle value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


FormClosed Event

[image]
Intersoft WebTextEditor Documentation
FormClosed Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : FormClosed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("Occurs whenever the user closes the form, after the form has been closed and specifies the close reason.")>
Public Event FormClosed As System.Windows.Forms.FormClosedEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.Windows.Forms.FormClosedEventHandler

AddHandler instance.FormClosed, handler
C#
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs whenever the user closes the form, after the form has been closed and specifies the close reason.")]
public event System.Windows.Forms.FormClosedEventHandler FormClosed
Delphi
public event FormClosed: System.Windows.Forms.FormClosedEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs whenever the user closes the form, after the form has been closed and specifies the close reason.")]
public: __event System.Windows.Forms.FormClosedEventHandler* FormClosed
C++/CLI
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs whenever the user closes the form, after the form has been closed and specifies the close reason.")]
public:
event System.Windows.Forms.FormClosedEventHandler^ FormClosed

Event Data

The event handler receives an argument of type System.Windows.Forms.FormClosedEventArgs containing data related to this event. The following FormClosedEventArgs properties provide information specific to this event.

Property | Description
CloseReason | Gets a value that indicates why the form was closed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


FormClosing Event

[image]
Intersoft WebTextEditor Documentation
FormClosing Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : FormClosing Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs whenever the user closes the form, before the form has been closed and specifies the close reason.")>
<SRCategoryAttribute("Behavior")>
Public Event FormClosing As System.Windows.Forms.FormClosingEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.Windows.Forms.FormClosingEventHandler

AddHandler instance.FormClosing, handler
C#
[SRDescriptionAttribute("Occurs whenever the user closes the form, before the form has been closed and specifies the close reason.")]
[SRCategoryAttribute("Behavior")]
public event System.Windows.Forms.FormClosingEventHandler FormClosing
Delphi
public event FormClosing: System.Windows.Forms.FormClosingEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs whenever the user closes the form, before the form has been closed and specifies the close reason.")]
[SRCategoryAttribute("Behavior")]
public: __event System.Windows.Forms.FormClosingEventHandler* FormClosing
C++/CLI
[SRDescriptionAttribute("Occurs whenever the user closes the form, before the form has been closed and specifies the close reason.")]
[SRCategoryAttribute("Behavior")]
public:
event System.Windows.Forms.FormClosingEventHandler^ FormClosing

Event Data

The event handler receives an argument of type System.Windows.Forms.FormClosingEventArgs containing data related to this event. The following FormClosingEventArgs properties provide information specific to this event.

Property | Description
Cancel (Inherited from System.ComponentModel.CancelEventArgs) |
CloseReason | Gets a value that indicates why the form is being closed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


GetAccessibilityObjectById Method

[image]
Intersoft WebTextEditor Documentation
GetAccessibilityObjectById Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : GetAccessibilityObjectById Method

objectId

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetAccessibilityObjectById( _
   ByVal objectId As System.Integer _
) As System.Windows.Forms.AccessibleObject
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim objectId As System.Integer
Dim value As System.Windows.Forms.AccessibleObject

value = instance.GetAccessibilityObjectById(objectId)
C#
protected virtual System.Windows.Forms.AccessibleObject GetAccessibilityObjectById(
   System.int objectId
)
Delphi
protected function GetAccessibilityObjectById(
    objectId: System.Integer
): System.Windows.Forms.AccessibleObject; virtual;
JScript
protected function GetAccessibilityObjectById(
   objectId : System.int
) : System.Windows.Forms.AccessibleObject;
Managed Extensions for C++
protected: virtual System.Windows.Forms.AccessibleObject* GetAccessibilityObjectById(
   System.int objectId
)
C++/CLI
protected:
virtual System.Windows.Forms.AccessibleObject^ GetAccessibilityObjectById(
   System.int objectId
)

Parameters

objectId

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


GetAutoSizeMode Method

[image]
Intersoft WebTextEditor Documentation
GetAutoSizeMode Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : GetAutoSizeMode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function GetAutoSizeMode() As System.Windows.Forms.AutoSizeMode
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Windows.Forms.AutoSizeMode

value = instance.GetAutoSizeMode()
C#
protected System.Windows.Forms.AutoSizeMode GetAutoSizeMode()
Delphi
protected function GetAutoSizeMode(): System.Windows.Forms.AutoSizeMode;
JScript
protected function GetAutoSizeMode() : System.Windows.Forms.AutoSizeMode;
Managed Extensions for C++
protected: System.Windows.Forms.AutoSizeMode GetAutoSizeMode();
C++/CLI
protected:
System.Windows.Forms.AutoSizeMode GetAutoSizeMode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


GetChildAtPoint Method

[image]
Intersoft WebTextEditor Documentation
GetChildAtPoint Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : GetChildAtPoint Method

Glossary Item Box

Overload List

Overload | Description
GetChildAtPoint(Point,GetChildAtPointSkip) | (Inherited from System.Windows.Forms.Control)
GetChildAtPoint(Point) | (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


GetChildAtPoint(Point) Method

[image]
Intersoft WebTextEditor Documentation
GetChildAtPoint(Point) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class > GetChildAtPoint Method : GetChildAtPoint(Point) Method

pt

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function GetChildAtPoint( _
   ByVal pt As System.Drawing.Point _
) As System.Windows.Forms.Control
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim pt As System.Drawing.Point
Dim value As System.Windows.Forms.Control

value = instance.GetChildAtPoint(pt)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.Windows.Forms.Control GetChildAtPoint(
   System.Drawing.Point pt
)
Delphi
public function GetChildAtPoint(
    pt: System.Drawing.Point
): System.Windows.Forms.Control;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function GetChildAtPoint(
   pt : System.Drawing.Point
) : System.Windows.Forms.Control;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.Windows.Forms.Control* GetChildAtPoint(
   System.Drawing.Point pt
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.Windows.Forms.Control^ GetChildAtPoint(
   System.Drawing.Point pt
)

Parameters

pt

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members
Overload List


GetChildAtPoint(Point,GetChildAtPointSkip) Method

[image]
Intersoft WebTextEditor Documentation
GetChildAtPoint(Point,GetChildAtPointSkip) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class > GetChildAtPoint Method : GetChildAtPoint(Point,GetChildAtPointSkip) Method

pt
skipValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetChildAtPoint( _
   ByVal pt As System.Drawing.Point, _
   ByVal skipValue As System.Windows.Forms.GetChildAtPointSkip _
) As System.Windows.Forms.Control
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim pt As System.Drawing.Point
Dim skipValue As System.Windows.Forms.GetChildAtPointSkip
Dim value As System.Windows.Forms.Control

value = instance.GetChildAtPoint(pt, skipValue)
C#
public System.Windows.Forms.Control GetChildAtPoint(
   System.Drawing.Point pt,
   System.Windows.Forms.GetChildAtPointSkip skipValue
)
Delphi
public function GetChildAtPoint(
    pt: System.Drawing.Point;
    skipValue: System.Windows.Forms.GetChildAtPointSkip
): System.Windows.Forms.Control;
JScript
public function GetChildAtPoint(
   pt : System.Drawing.Point,
   skipValue : System.Windows.Forms.GetChildAtPointSkip
) : System.Windows.Forms.Control;
Managed Extensions for C++
public: System.Windows.Forms.Control* GetChildAtPoint(
   System.Drawing.Point pt,
   System.Windows.Forms.GetChildAtPointSkip skipValue
)
C++/CLI
public:
System.Windows.Forms.Control^ GetChildAtPoint(
   System.Drawing.Point pt,
   System.Windows.Forms.GetChildAtPointSkip skipValue
)

Parameters

pt
skipValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members
Overload List


GetContainerControl Method

[image]
Intersoft WebTextEditor Documentation
GetContainerControl Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : GetContainerControl Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetContainerControl() As System.Windows.Forms.IContainerControl
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Windows.Forms.IContainerControl

value = instance.GetContainerControl()
C#
public System.Windows.Forms.IContainerControl GetContainerControl()
Delphi
public function GetContainerControl(): System.Windows.Forms.IContainerControl;
JScript
public function GetContainerControl() : System.Windows.Forms.IContainerControl;
Managed Extensions for C++
public: System.Windows.Forms.IContainerControl* GetContainerControl();
C++/CLI
public:
System.Windows.Forms.IContainerControl^ GetContainerControl();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


GetLifetimeService Method

[image]
Intersoft WebTextEditor Documentation
GetLifetimeService Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : GetLifetimeService Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.SecurityCriticalAttribute()>
Public Function GetLifetimeService() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Object

value = instance.GetLifetimeService()
C#
[System.Security.SecurityCriticalAttribute()]
public System.object GetLifetimeService()
Delphi
public function GetLifetimeService(): System.TObject;
JScript
System.Security.SecurityCriticalAttribute()
public function GetLifetimeService() : System.Object;
Managed Extensions for C++
[System.Security.SecurityCriticalAttribute()]
public: System.Object* GetLifetimeService();
C++/CLI
[System.Security.SecurityCriticalAttribute()]
public:
System.Object^ GetLifetimeService();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


GetNextControl Method

[image]
Intersoft WebTextEditor Documentation
GetNextControl Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : GetNextControl Method

ctl
forward

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetNextControl( _
   ByVal ctl As System.Windows.Forms.Control, _
   ByVal forward As System.Boolean _
) As System.Windows.Forms.Control
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim ctl As System.Windows.Forms.Control
Dim forward As System.Boolean
Dim value As System.Windows.Forms.Control

value = instance.GetNextControl(ctl, forward)
C#
public System.Windows.Forms.Control GetNextControl(
   System.Windows.Forms.Control ctl,
   System.bool forward
)
Delphi
public function GetNextControl(
    ctl: System.Windows.Forms.Control;
    forward: System.Boolean
): System.Windows.Forms.Control;
JScript
public function GetNextControl(
   ctl : System.Windows.Forms.Control,
   forward : System.boolean
) : System.Windows.Forms.Control;
Managed Extensions for C++
public: System.Windows.Forms.Control* GetNextControl(
   System.Windows.Forms.Control* ctl,
   System.bool forward
)
C++/CLI
public:
System.Windows.Forms.Control^ GetNextControl(
   System.Windows.Forms.Control^ ctl,
   System.bool forward
)

Parameters

ctl
forward

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


GetPreferredSize Method

[image]
Intersoft WebTextEditor Documentation
GetPreferredSize Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : GetPreferredSize Method

proposedSize

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Overridable Function GetPreferredSize( _
   ByVal proposedSize As System.Drawing.Size _
) As System.Drawing.Size
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim proposedSize As System.Drawing.Size
Dim value As System.Drawing.Size

value = instance.GetPreferredSize(proposedSize)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public virtual System.Drawing.Size GetPreferredSize(
   System.Drawing.Size proposedSize
)
Delphi
public function GetPreferredSize(
    proposedSize: System.Drawing.Size
): System.Drawing.Size; virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function GetPreferredSize(
   proposedSize : System.Drawing.Size
) : System.Drawing.Size;
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: virtual System.Drawing.Size GetPreferredSize(
   System.Drawing.Size proposedSize
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
virtual System.Drawing.Size GetPreferredSize(
   System.Drawing.Size proposedSize
)

Parameters

proposedSize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


GetScaledBounds Method

[image]
Intersoft WebTextEditor Documentation
GetScaledBounds Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : GetScaledBounds Method

bounds
factor
specified

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Function GetScaledBounds( _
   ByVal bounds As System.Drawing.Rectangle, _
   ByVal factor As System.Drawing.SizeF, _
   ByVal specified As System.Windows.Forms.BoundsSpecified _
) As System.Drawing.Rectangle
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim bounds As System.Drawing.Rectangle
Dim factor As System.Drawing.SizeF
Dim specified As System.Windows.Forms.BoundsSpecified
Dim value As System.Drawing.Rectangle

value = instance.GetScaledBounds(bounds, factor, specified)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual System.Drawing.Rectangle GetScaledBounds(
   System.Drawing.Rectangle bounds,
   System.Drawing.SizeF factor,
   System.Windows.Forms.BoundsSpecified specified
)
Delphi
protected function GetScaledBounds(
    bounds: System.Drawing.Rectangle;
    factor: System.Drawing.SizeF;
    specified: System.Windows.Forms.BoundsSpecified
): System.Drawing.Rectangle; virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function GetScaledBounds(
   bounds : System.Drawing.Rectangle,
   factor : System.Drawing.SizeF,
   specified : System.Windows.Forms.BoundsSpecified
) : System.Drawing.Rectangle;
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual System.Drawing.Rectangle GetScaledBounds(
   System.Drawing.Rectangle bounds,
   System.Drawing.SizeF factor,
   System.Windows.Forms.BoundsSpecified specified
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual System.Drawing.Rectangle GetScaledBounds(
   System.Drawing.Rectangle bounds,
   System.Drawing.SizeF factor,
   System.Windows.Forms.BoundsSpecified specified
)

Parameters

bounds
factor
specified

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


GetScrollState Method

[image]
Intersoft WebTextEditor Documentation
GetScrollState Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : GetScrollState Method

bit

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Function GetScrollState( _
   ByVal bit As System.Integer _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim bit As System.Integer
Dim value As System.Boolean

value = instance.GetScrollState(bit)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected System.bool GetScrollState(
   System.int bit
)
Delphi
protected function GetScrollState(
    bit: System.Integer
): System.Boolean;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function GetScrollState(
   bit : System.int
) : System.boolean;
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: System.bool GetScrollState(
   System.int bit
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
System.bool GetScrollState(
   System.int bit
)

Parameters

bit

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


GetService Method

[image]
Intersoft WebTextEditor Documentation
GetService Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : GetService Method

service

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetService( _
   ByVal service As System.Type _
) As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim service As System.Type
Dim value As System.Object

value = instance.GetService(service)
C#
protected virtual System.object GetService(
   System.Type service
)
Delphi
protected function GetService(
    service: System.Type
): System.TObject; virtual;
JScript
protected function GetService(
   service : System.Type
) : System.Object;
Managed Extensions for C++
protected: virtual System.Object* GetService(
   System.Type* service
)
C++/CLI
protected:
virtual System.Object^ GetService(
   System.Type^ service
)

Parameters

service

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


GetStyle Method

[image]
Intersoft WebTextEditor Documentation
GetStyle Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : GetStyle Method

flag

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function GetStyle( _
   ByVal flag As System.Windows.Forms.ControlStyles _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim flag As System.Windows.Forms.ControlStyles
Dim value As System.Boolean

value = instance.GetStyle(flag)
C#
protected System.bool GetStyle(
   System.Windows.Forms.ControlStyles flag
)
Delphi
protected function GetStyle(
    flag: System.Windows.Forms.ControlStyles
): System.Boolean;
JScript
protected function GetStyle(
   flag : System.Windows.Forms.ControlStyles
) : System.boolean;
Managed Extensions for C++
protected: System.bool GetStyle(
   System.Windows.Forms.ControlStyles flag
)
C++/CLI
protected:
System.bool GetStyle(
   System.Windows.Forms.ControlStyles flag
)

Parameters

flag

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


GetTopLevel Method

[image]
Intersoft WebTextEditor Documentation
GetTopLevel Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : GetTopLevel Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function GetTopLevel() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Boolean

value = instance.GetTopLevel()
C#
protected System.bool GetTopLevel()
Delphi
protected function GetTopLevel(): System.Boolean;
JScript
protected function GetTopLevel() : System.boolean;
Managed Extensions for C++
protected: System.bool GetTopLevel();
C++/CLI
protected:
System.bool GetTopLevel();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


GiveFeedback Event

[image]
Intersoft WebTextEditor Documentation
GiveFeedback Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : GiveFeedback Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Drag Drop")>
<SRDescriptionAttribute("Occurs when the mouse drags an item. The system requests that the Control provide feedback to that effect.")>
Public Event GiveFeedback As System.Windows.Forms.GiveFeedbackEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.Windows.Forms.GiveFeedbackEventHandler

AddHandler instance.GiveFeedback, handler
C#
[SRCategoryAttribute("Drag Drop")]
[SRDescriptionAttribute("Occurs when the mouse drags an item. The system requests that the Control provide feedback to that effect.")]
public event System.Windows.Forms.GiveFeedbackEventHandler GiveFeedback
Delphi
public event GiveFeedback: System.Windows.Forms.GiveFeedbackEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Drag Drop")]
[SRDescriptionAttribute("Occurs when the mouse drags an item. The system requests that the Control provide feedback to that effect.")]
public: __event System.Windows.Forms.GiveFeedbackEventHandler* GiveFeedback
C++/CLI
[SRCategoryAttribute("Drag Drop")]
[SRDescriptionAttribute("Occurs when the mouse drags an item. The system requests that the Control provide feedback to that effect.")]
public:
event System.Windows.Forms.GiveFeedbackEventHandler^ GiveFeedback

Event Data

The event handler receives an argument of type System.Windows.Forms.GiveFeedbackEventArgs containing data related to this event. The following GiveFeedbackEventArgs properties provide information specific to this event.

Property | Description
Effect | Gets the drag-and-drop operation feedback that is displayed.
UseDefaultCursors | Gets or sets whether drag operation should use the default cursors that are associated with drag-drop effects.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


GotFocus Event

[image]
Intersoft WebTextEditor Documentation
GotFocus Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : GotFocus Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Focus")>
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<System.ComponentModel.BrowsableAttribute(False)>
<SRDescriptionAttribute("Occurs when the control gets focus.")>
Public Event GotFocus As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.EventHandler

AddHandler instance.GotFocus, handler
C#
[SRCategoryAttribute("Focus")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.ComponentModel.BrowsableAttribute(false)]
[SRDescriptionAttribute("Occurs when the control gets focus.")]
public event System.EventHandler GotFocus
Delphi
public event GotFocus: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Focus")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.ComponentModel.BrowsableAttribute(false)]
[SRDescriptionAttribute("Occurs when the control gets focus.")]
public: __event System.EventHandler* GotFocus
C++/CLI
[SRCategoryAttribute("Focus")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.ComponentModel.BrowsableAttribute(false)]
[SRDescriptionAttribute("Occurs when the control gets focus.")]
public:
event System.EventHandler^ GotFocus

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


Handle Property

[image]
Intersoft WebTextEditor Documentation
Handle Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : Handle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.InteropServices.DispIdAttribute(-515)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
<SRDescriptionAttribute("The native handle for this control.")>
Public ReadOnly Property Handle As System.IntPtr
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.IntPtr

value = instance.Handle
C#
[System.Runtime.InteropServices.DispIdAttribute(-515)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[SRDescriptionAttribute("The native handle for this control.")]
public System.IntPtr Handle {get;}
Delphi
public read-only property Handle: System.IntPtr;
JScript
System.Runtime.InteropServices.DispIdAttribute(-515)
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
SRDescriptionAttribute("The native handle for this control.")
public function get Handle : System.IntPtr
Managed Extensions for C++
[System.Runtime.InteropServices.DispIdAttribute(-515)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[SRDescriptionAttribute("The native handle for this control.")]
public: __property System.IntPtr get_Handle();
C++/CLI
[System.Runtime.InteropServices.DispIdAttribute(-515)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[SRDescriptionAttribute("The native handle for this control.")]
public:
property System.IntPtr Handle {
   System.IntPtr get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


HandleCreated Event

[image]
Intersoft WebTextEditor Documentation
HandleCreated Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : HandleCreated Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<SRDescriptionAttribute("Occurs when the control's native handle is created.")>
<System.ComponentModel.BrowsableAttribute(False)>
<SRCategoryAttribute("Private")>
Public Event HandleCreated As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.EventHandler

AddHandler instance.HandleCreated, handler
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRDescriptionAttribute("Occurs when the control's native handle is created.")]
[System.ComponentModel.BrowsableAttribute(false)]
[SRCategoryAttribute("Private")]
public event System.EventHandler HandleCreated
Delphi
public event HandleCreated: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRDescriptionAttribute("Occurs when the control's native handle is created.")]
[System.ComponentModel.BrowsableAttribute(false)]
[SRCategoryAttribute("Private")]
public: __event System.EventHandler* HandleCreated
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRDescriptionAttribute("Occurs when the control's native handle is created.")]
[System.ComponentModel.BrowsableAttribute(false)]
[SRCategoryAttribute("Private")]
public:
event System.EventHandler^ HandleCreated

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


HandleDestroyed Event

[image]
Intersoft WebTextEditor Documentation
HandleDestroyed Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : HandleDestroyed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<SRDescriptionAttribute("Occurs when the control's native handle is destroyed.")>
<SRCategoryAttribute("Private")>
<System.ComponentModel.BrowsableAttribute(False)>
Public Event HandleDestroyed As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.EventHandler

AddHandler instance.HandleDestroyed, handler
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRDescriptionAttribute("Occurs when the control's native handle is destroyed.")]
[SRCategoryAttribute("Private")]
[System.ComponentModel.BrowsableAttribute(false)]
public event System.EventHandler HandleDestroyed
Delphi
public event HandleDestroyed: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRDescriptionAttribute("Occurs when the control's native handle is destroyed.")]
[SRCategoryAttribute("Private")]
[System.ComponentModel.BrowsableAttribute(false)]
public: __event System.EventHandler* HandleDestroyed
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRDescriptionAttribute("Occurs when the control's native handle is destroyed.")]
[SRCategoryAttribute("Private")]
[System.ComponentModel.BrowsableAttribute(false)]
public:
event System.EventHandler^ HandleDestroyed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


HasChildren Property

[image]
Intersoft WebTextEditor Documentation
HasChildren Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : HasChildren Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<SRDescriptionAttribute("Indicates whether the control contains one or more child controls.")>
Public ReadOnly Property HasChildren As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Boolean

value = instance.HasChildren
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[SRDescriptionAttribute("Indicates whether the control contains one or more child controls.")]
public System.bool HasChildren {get;}
Delphi
public read-only property HasChildren: System.Boolean;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
SRDescriptionAttribute("Indicates whether the control contains one or more child controls.")
public function get HasChildren : System.boolean
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[SRDescriptionAttribute("Indicates whether the control contains one or more child controls.")]
public: __property System.bool get_HasChildren();
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[SRDescriptionAttribute("Indicates whether the control contains one or more child controls.")]
public:
property System.bool HasChildren {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


Height Property

[image]
Intersoft WebTextEditor Documentation
Height Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : Height Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Layout")>
<SRDescriptionAttribute("The height of the user interface element, in pixels.")>
<System.ComponentModel.EditorBrowsableAttribute()>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
Public Property Height As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Integer

instance.Height = value

value = instance.Height
C#
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("The height of the user interface element, in pixels.")]
[System.ComponentModel.EditorBrowsableAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public System.int Height {get; set;}
Delphi
public read-write property Height: System.Integer;
JScript
SRCategoryAttribute("Layout")
SRDescriptionAttribute("The height of the user interface element, in pixels.")
System.ComponentModel.EditorBrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
public function get,set Height : System.int
Managed Extensions for C++
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("The height of the user interface element, in pixels.")]
[System.ComponentModel.EditorBrowsableAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public: __property System.int get_Height();
public: __property void set_Height(
   System.int value
);
C++/CLI
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("The height of the user interface element, in pixels.")]
[System.ComponentModel.EditorBrowsableAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public:
property System.int Height {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


HelpButton Property

[image]
Intersoft WebTextEditor Documentation
HelpButton Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : HelpButton Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Determines whether a form has a Help button on the caption bar.")>
<SRCategoryAttribute("Window Style")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property HelpButton As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Boolean

instance.HelpButton = value

value = instance.HelpButton
C#
[SRDescriptionAttribute("Determines whether a form has a Help button on the caption bar.")]
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool HelpButton {get; set;}
Delphi
public read-write property HelpButton: System.Boolean;
JScript
SRDescriptionAttribute("Determines whether a form has a Help button on the caption bar.")
SRCategoryAttribute("Window Style")
System.ComponentModel.DefaultValueAttribute()
public function get,set HelpButton : System.boolean
Managed Extensions for C++
[SRDescriptionAttribute("Determines whether a form has a Help button on the caption bar.")]
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_HelpButton();
public: __property void set_HelpButton(
   System.bool value
);
C++/CLI
[SRDescriptionAttribute("Determines whether a form has a Help button on the caption bar.")]
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool HelpButton {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


HelpButtonClicked Event

[image]
Intersoft WebTextEditor Documentation
HelpButtonClicked Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : HelpButtonClicked Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Event raised when the help button is clicked.")>
<System.ComponentModel.EditorBrowsableAttribute()>
<SRCategoryAttribute("Behavior")>
<System.ComponentModel.BrowsableAttribute(True)>
Public Event HelpButtonClicked As System.ComponentModel.CancelEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.ComponentModel.CancelEventHandler

AddHandler instance.HelpButtonClicked, handler
C#
[SRDescriptionAttribute("Event raised when the help button is clicked.")]
[System.ComponentModel.EditorBrowsableAttribute()]
[SRCategoryAttribute("Behavior")]
[System.ComponentModel.BrowsableAttribute(true)]
public event System.ComponentModel.CancelEventHandler HelpButtonClicked
Delphi
public event HelpButtonClicked: System.ComponentModel.CancelEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Event raised when the help button is clicked.")]
[System.ComponentModel.EditorBrowsableAttribute()]
[SRCategoryAttribute("Behavior")]
[System.ComponentModel.BrowsableAttribute(true)]
public: __event System.ComponentModel.CancelEventHandler* HelpButtonClicked
C++/CLI
[SRDescriptionAttribute("Event raised when the help button is clicked.")]
[System.ComponentModel.EditorBrowsableAttribute()]
[SRCategoryAttribute("Behavior")]
[System.ComponentModel.BrowsableAttribute(true)]
public:
event System.ComponentModel.CancelEventHandler^ HelpButtonClicked

Event Data

The event handler receives an argument of type System.ComponentModel.CancelEventArgs containing data related to this event. The following CancelEventArgs properties provide information specific to this event.

Property | Description
Cancel |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


HelpRequested Event

[image]
Intersoft WebTextEditor Documentation
HelpRequested Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : HelpRequested Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the user invokes Help for the control.")>
<SRCategoryAttribute("Behavior")>
Public Event HelpRequested As System.Windows.Forms.HelpEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.Windows.Forms.HelpEventHandler

AddHandler instance.HelpRequested, handler
C#
[SRDescriptionAttribute("Occurs when the user invokes Help for the control.")]
[SRCategoryAttribute("Behavior")]
public event System.Windows.Forms.HelpEventHandler HelpRequested
Delphi
public event HelpRequested: System.Windows.Forms.HelpEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the user invokes Help for the control.")]
[SRCategoryAttribute("Behavior")]
public: __event System.Windows.Forms.HelpEventHandler* HelpRequested
C++/CLI
[SRDescriptionAttribute("Occurs when the user invokes Help for the control.")]
[SRCategoryAttribute("Behavior")]
public:
event System.Windows.Forms.HelpEventHandler^ HelpRequested

Event Data

The event handler receives an argument of type System.Windows.Forms.HelpEventArgs containing data related to this event. The following HelpEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value indicating whether the help event was handled.
MousePos | Gets the screen coordinates of the mouse pointer.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


Hide Method

[image]
Intersoft WebTextEditor Documentation
Hide Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : Hide Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Sub Hide()
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm

instance.Hide()
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void Hide()
Delphi
public procedure Hide();
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function Hide();
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void Hide();
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void Hide();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


HorizontalScroll Property

[image]
Intersoft WebTextEditor Documentation
HorizontalScroll Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : HorizontalScroll Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Gets the horizontal scroll bar for this ScrollableControl.")>
<System.ComponentModel.EditorBrowsableAttribute()>
<SRCategoryAttribute("Layout")>
<System.ComponentModel.BrowsableAttribute(False)>
Public ReadOnly Property HorizontalScroll As System.Windows.Forms.HScrollProperties
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Windows.Forms.HScrollProperties

value = instance.HorizontalScroll
C#
[SRDescriptionAttribute("Gets the horizontal scroll bar for this ScrollableControl.")]
[System.ComponentModel.EditorBrowsableAttribute()]
[SRCategoryAttribute("Layout")]
[System.ComponentModel.BrowsableAttribute(false)]
public System.Windows.Forms.HScrollProperties HorizontalScroll {get;}
Delphi
public read-only property HorizontalScroll: System.Windows.Forms.HScrollProperties;
JScript
SRDescriptionAttribute("Gets the horizontal scroll bar for this ScrollableControl.")
System.ComponentModel.EditorBrowsableAttribute()
SRCategoryAttribute("Layout")
System.ComponentModel.BrowsableAttribute()
public function get HorizontalScroll : System.Windows.Forms.HScrollProperties
Managed Extensions for C++
[SRDescriptionAttribute("Gets the horizontal scroll bar for this ScrollableControl.")]
[System.ComponentModel.EditorBrowsableAttribute()]
[SRCategoryAttribute("Layout")]
[System.ComponentModel.BrowsableAttribute(false)]
public: __property System.Windows.Forms.HScrollProperties* get_HorizontalScroll();
C++/CLI
[SRDescriptionAttribute("Gets the horizontal scroll bar for this ScrollableControl.")]
[System.ComponentModel.EditorBrowsableAttribute()]
[SRCategoryAttribute("Layout")]
[System.ComponentModel.BrowsableAttribute(false)]
public:
property System.Windows.Forms.HScrollProperties^ HorizontalScroll {
   System.Windows.Forms.HScrollProperties^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


HScroll Property

[image]
Intersoft WebTextEditor Documentation
HScroll Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : HScroll Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Property HScroll As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Boolean

instance.HScroll = value

value = instance.HScroll
C#
protected System.bool HScroll {get; set;}
Delphi
protected read-write property HScroll: System.Boolean;
JScript
protected function get,set HScroll : System.boolean
Managed Extensions for C++
protected: __property System.bool get_HScroll();
protected: __property void set_HScroll(
   System.bool value
);
C++/CLI
protected:
property System.bool HScroll {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


Icon Property

[image]
Intersoft WebTextEditor Documentation
Icon Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : Icon Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.AmbientValueAttribute()>
<SRDescriptionAttribute("Indicates the icon for a form. This icon is displayed in the form's system menu box and when the form is minimized.")>
<SRCategoryAttribute("Window Style")>
<System.ComponentModel.LocalizableAttribute(True)>
Public Property Icon As System.Drawing.Icon
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Drawing.Icon

instance.Icon = value

value = instance.Icon
C#
[System.ComponentModel.AmbientValueAttribute()]
[SRDescriptionAttribute("Indicates the icon for a form. This icon is displayed in the form's system menu box and when the form is minimized.")]
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.LocalizableAttribute(true)]
public System.Drawing.Icon Icon {get; set;}
Delphi
public read-write property Icon: System.Drawing.Icon;
JScript
System.ComponentModel.AmbientValueAttribute()
SRDescriptionAttribute("Indicates the icon for a form. This icon is displayed in the form's system menu box and when the form is minimized.")
SRCategoryAttribute("Window Style")
System.ComponentModel.LocalizableAttribute()
public function get,set Icon : System.Drawing.Icon
Managed Extensions for C++
[System.ComponentModel.AmbientValueAttribute()]
[SRDescriptionAttribute("Indicates the icon for a form. This icon is displayed in the form's system menu box and when the form is minimized.")]
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.LocalizableAttribute(true)]
public: __property System.Drawing.Icon* get_Icon();
public: __property void set_Icon(
   System.Drawing.Icon* value
);
C++/CLI
[System.ComponentModel.AmbientValueAttribute()]
[SRDescriptionAttribute("Indicates the icon for a form. This icon is displayed in the form's system menu box and when the form is minimized.")]
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.LocalizableAttribute(true)]
public:
property System.Drawing.Icon^ Icon {
   System.Drawing.Icon^ get();
   void set (    System.Drawing.Icon^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


ImeMode Property

[image]
Intersoft WebTextEditor Documentation
ImeMode Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : ImeMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.AmbientValueAttribute()>
<SRDescriptionAttribute("Determines the IME (Input Method Editor) status of the object when selected.")>
<SRCategoryAttribute("Behavior")>
<System.ComponentModel.LocalizableAttribute(True)>
Public Property ImeMode As System.Windows.Forms.ImeMode
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Windows.Forms.ImeMode

instance.ImeMode = value

value = instance.ImeMode
C#
[System.ComponentModel.AmbientValueAttribute()]
[SRDescriptionAttribute("Determines the IME (Input Method Editor) status of the object when selected.")]
[SRCategoryAttribute("Behavior")]
[System.ComponentModel.LocalizableAttribute(true)]
public System.Windows.Forms.ImeMode ImeMode {get; set;}
Delphi
public read-write property ImeMode: System.Windows.Forms.ImeMode;
JScript
System.ComponentModel.AmbientValueAttribute()
SRDescriptionAttribute("Determines the IME (Input Method Editor) status of the object when selected.")
SRCategoryAttribute("Behavior")
System.ComponentModel.LocalizableAttribute()
public function get,set ImeMode : System.Windows.Forms.ImeMode
Managed Extensions for C++
[System.ComponentModel.AmbientValueAttribute()]
[SRDescriptionAttribute("Determines the IME (Input Method Editor) status of the object when selected.")]
[SRCategoryAttribute("Behavior")]
[System.ComponentModel.LocalizableAttribute(true)]
public: __property System.Windows.Forms.ImeMode get_ImeMode();
public: __property void set_ImeMode(
   System.Windows.Forms.ImeMode value
);
C++/CLI
[System.ComponentModel.AmbientValueAttribute()]
[SRDescriptionAttribute("Determines the IME (Input Method Editor) status of the object when selected.")]
[SRCategoryAttribute("Behavior")]
[System.ComponentModel.LocalizableAttribute(true)]
public:
property System.Windows.Forms.ImeMode ImeMode {
   System.Windows.Forms.ImeMode get();
   void set (    System.Windows.Forms.ImeMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


ImeModeBase Property

[image]
Intersoft WebTextEditor Documentation
ImeModeBase Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : ImeModeBase Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Property ImeModeBase As System.Windows.Forms.ImeMode
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Windows.Forms.ImeMode

instance.ImeModeBase = value

value = instance.ImeModeBase
C#
protected virtual System.Windows.Forms.ImeMode ImeModeBase {get; set;}
Delphi
protected read-write property ImeModeBase: System.Windows.Forms.ImeMode; virtual;
JScript
protected function get,set ImeModeBase : System.Windows.Forms.ImeMode
Managed Extensions for C++
protected: __property virtual System.Windows.Forms.ImeMode get_ImeModeBase();
protected: __property virtual void set_ImeModeBase(
   System.Windows.Forms.ImeMode value
);
C++/CLI
protected:
virtual property System.Windows.Forms.ImeMode ImeModeBase {
   System.Windows.Forms.ImeMode get();
   void set (    System.Windows.Forms.ImeMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


ImeModeChanged Event

[image]
Intersoft WebTextEditor Documentation
ImeModeChanged Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : ImeModeChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WinCategoryAttribute("Behavior")>
<SRDescriptionAttribute("Occurs when the control's input method editor (IME) mode changes.")>
Public Event ImeModeChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.EventHandler

AddHandler instance.ImeModeChanged, handler
C#
[WinCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when the control's input method editor (IME) mode changes.")]
public event System.EventHandler ImeModeChanged
Delphi
public event ImeModeChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WinCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when the control's input method editor (IME) mode changes.")]
public: __event System.EventHandler* ImeModeChanged
C++/CLI
[WinCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when the control's input method editor (IME) mode changes.")]
public:
event System.EventHandler^ ImeModeChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


InitializeLifetimeService Method

[image]
Intersoft WebTextEditor Documentation
InitializeLifetimeService Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : InitializeLifetimeService Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.SecurityCriticalAttribute()>
Public Overridable Function InitializeLifetimeService() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Object

value = instance.InitializeLifetimeService()
C#
[System.Security.SecurityCriticalAttribute()]
public virtual System.object InitializeLifetimeService()
Delphi
public function InitializeLifetimeService(): System.TObject; virtual;
JScript
System.Security.SecurityCriticalAttribute()
public function InitializeLifetimeService() : System.Object;
Managed Extensions for C++
[System.Security.SecurityCriticalAttribute()]
public: virtual System.Object* InitializeLifetimeService();
C++/CLI
[System.Security.SecurityCriticalAttribute()]
public:
virtual System.Object^ InitializeLifetimeService();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


InitLayout Method

[image]
Intersoft WebTextEditor Documentation
InitLayout Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : InitLayout Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub InitLayout()
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm

instance.InitLayout()
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void InitLayout()
Delphi
protected procedure InitLayout(); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function InitLayout();
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void InitLayout();
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void InitLayout();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


InputLanguageChanged Event

[image]
Intersoft WebTextEditor Documentation
InputLanguageChanged Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : InputLanguageChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs whenever the language used for input for this form changes.")>
<SRCategoryAttribute("Behavior")>
Public Event InputLanguageChanged As System.Windows.Forms.InputLanguageChangedEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.Windows.Forms.InputLanguageChangedEventHandler

AddHandler instance.InputLanguageChanged, handler
C#
[SRDescriptionAttribute("Occurs whenever the language used for input for this form changes.")]
[SRCategoryAttribute("Behavior")]
public event System.Windows.Forms.InputLanguageChangedEventHandler InputLanguageChanged
Delphi
public event InputLanguageChanged: System.Windows.Forms.InputLanguageChangedEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs whenever the language used for input for this form changes.")]
[SRCategoryAttribute("Behavior")]
public: __event System.Windows.Forms.InputLanguageChangedEventHandler* InputLanguageChanged
C++/CLI
[SRDescriptionAttribute("Occurs whenever the language used for input for this form changes.")]
[SRCategoryAttribute("Behavior")]
public:
event System.Windows.Forms.InputLanguageChangedEventHandler^ InputLanguageChanged

Event Data

The event handler receives an argument of type System.Windows.Forms.InputLanguageChangedEventArgs containing data related to this event. The following InputLanguageChangedEventArgs properties provide information specific to this event.

Property | Description
CharSet | Gets the character set associated with the new input language.
Culture | Gets the locale of the input language.
InputLanguage | Gets a value indicating the input language.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


InputLanguageChanging Event

[image]
Intersoft WebTextEditor Documentation
InputLanguageChanging Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : InputLanguageChanging Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("A request by the system to change the input language for this form. This request can be refused.")>
Public Event InputLanguageChanging As System.Windows.Forms.InputLanguageChangingEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.Windows.Forms.InputLanguageChangingEventHandler

AddHandler instance.InputLanguageChanging, handler
C#
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("A request by the system to change the input language for this form. This request can be refused.")]
public event System.Windows.Forms.InputLanguageChangingEventHandler InputLanguageChanging
Delphi
public event InputLanguageChanging: System.Windows.Forms.InputLanguageChangingEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("A request by the system to change the input language for this form. This request can be refused.")]
public: __event System.Windows.Forms.InputLanguageChangingEventHandler* InputLanguageChanging
C++/CLI
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("A request by the system to change the input language for this form. This request can be refused.")]
public:
event System.Windows.Forms.InputLanguageChangingEventHandler^ InputLanguageChanging

Event Data

The event handler receives an argument of type System.Windows.Forms.InputLanguageChangingEventArgs containing data related to this event. The following InputLanguageChangingEventArgs properties provide information specific to this event.

Property | Description
Cancel (Inherited from System.ComponentModel.CancelEventArgs) |
Culture | Gets the locale of the requested input language.
InputLanguage | Gets a value indicating the input language.
SysCharSet | Gets a value indicating whether the system default font supports the character set required for the requested input language.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


Invalidate Method

[image]
Intersoft WebTextEditor Documentation
Invalidate Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : Invalidate Method

Glossary Item Box

Overload List

Overload | Description
Invalidate(Region) | (Inherited from System.Windows.Forms.Control)
Invalidate(Region,Boolean) | (Inherited from System.Windows.Forms.Control)
Invalidate() | (Inherited from System.Windows.Forms.Control)
Invalidate(Boolean) | (Inherited from System.Windows.Forms.Control)
Invalidate(Rectangle) | (Inherited from System.Windows.Forms.Control)
Invalidate(Rectangle,Boolean) | (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


Invalidate() Method

[image]
Intersoft WebTextEditor Documentation
Invalidate() Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class > Invalidate Method : Invalidate() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub Invalidate()
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm

instance.Invalidate()
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void Invalidate()
Delphi
public procedure Invalidate();
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function Invalidate();
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void Invalidate();
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void Invalidate();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members
Overload List


Invalidate(Boolean) Method

[image]
Intersoft WebTextEditor Documentation
Invalidate(Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class > Invalidate Method : Invalidate(Boolean) Method

invalidateChildren

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate( _
   ByVal invalidateChildren As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim invalidateChildren As System.Boolean

instance.Invalidate(invalidateChildren)
C#
public void Invalidate(
   System.bool invalidateChildren
)
Delphi
public procedure Invalidate(
    invalidateChildren: System.Boolean
);
JScript
public function Invalidate(
   invalidateChildren : System.boolean
);
Managed Extensions for C++
public: void Invalidate(
   System.bool invalidateChildren
)
C++/CLI
public:
void Invalidate(
   System.bool invalidateChildren
)

Parameters

invalidateChildren

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members
Overload List


Invalidate(Rectangle) Method

[image]
Intersoft WebTextEditor Documentation
Invalidate(Rectangle) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class > Invalidate Method : Invalidate(Rectangle) Method

rc

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub Invalidate( _
   ByVal rc As System.Drawing.Rectangle _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim rc As System.Drawing.Rectangle

instance.Invalidate(rc)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void Invalidate(
   System.Drawing.Rectangle rc
)
Delphi
public procedure Invalidate(
    rc: System.Drawing.Rectangle
);
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function Invalidate(
   rc : System.Drawing.Rectangle
);
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void Invalidate(
   System.Drawing.Rectangle rc
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void Invalidate(
   System.Drawing.Rectangle rc
)

Parameters

rc

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members
Overload List


Invalidate(Rectangle,Boolean) Method

[image]
Intersoft WebTextEditor Documentation
Invalidate(Rectangle,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class > Invalidate Method : Invalidate(Rectangle,Boolean) Method

rc
invalidateChildren

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate( _
   ByVal rc As System.Drawing.Rectangle, _
   ByVal invalidateChildren As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim rc As System.Drawing.Rectangle
Dim invalidateChildren As System.Boolean

instance.Invalidate(rc, invalidateChildren)
C#
public void Invalidate(
   System.Drawing.Rectangle rc,
   System.bool invalidateChildren
)
Delphi
public procedure Invalidate(
    rc: System.Drawing.Rectangle;
    invalidateChildren: System.Boolean
);
JScript
public function Invalidate(
   rc : System.Drawing.Rectangle,
   invalidateChildren : System.boolean
);
Managed Extensions for C++
public: void Invalidate(
   System.Drawing.Rectangle rc,
   System.bool invalidateChildren
)
C++/CLI
public:
void Invalidate(
   System.Drawing.Rectangle rc,
   System.bool invalidateChildren
)

Parameters

rc
invalidateChildren

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members
Overload List


Invalidate(Region) Method

[image]
Intersoft WebTextEditor Documentation
Invalidate(Region) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class > Invalidate Method : Invalidate(Region) Method

region

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub Invalidate( _
   ByVal region As System.Drawing.Region _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim region As System.Drawing.Region

instance.Invalidate(region)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void Invalidate(
   System.Drawing.Region region
)
Delphi
public procedure Invalidate(
    region: System.Drawing.Region
);
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function Invalidate(
   region : System.Drawing.Region
);
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void Invalidate(
   System.Drawing.Region* region
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void Invalidate(
   System.Drawing.Region^ region
)

Parameters

region

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members
Overload List


Invalidate(Region,Boolean) Method

[image]
Intersoft WebTextEditor Documentation
Invalidate(Region,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class > Invalidate Method : Invalidate(Region,Boolean) Method

region
invalidateChildren

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub Invalidate( _
   ByVal region As System.Drawing.Region, _
   ByVal invalidateChildren As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim region As System.Drawing.Region
Dim invalidateChildren As System.Boolean

instance.Invalidate(region, invalidateChildren)
C#
public void Invalidate(
   System.Drawing.Region region,
   System.bool invalidateChildren
)
Delphi
public procedure Invalidate(
    region: System.Drawing.Region;
    invalidateChildren: System.Boolean
);
JScript
public function Invalidate(
   region : System.Drawing.Region,
   invalidateChildren : System.boolean
);
Managed Extensions for C++
public: void Invalidate(
   System.Drawing.Region* region,
   System.bool invalidateChildren
)
C++/CLI
public:
void Invalidate(
   System.Drawing.Region^ region,
   System.bool invalidateChildren
)

Parameters

region
invalidateChildren

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members
Overload List


Invalidated Event

[image]
Intersoft WebTextEditor Documentation
Invalidated Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : Invalidated Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<System.ComponentModel.BrowsableAttribute(False)>
<SRDescriptionAttribute("Occurs when a control's display requires redrawing.")>
<SRCategoryAttribute("Appearance")>
Public Event Invalidated As System.Windows.Forms.InvalidateEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.Windows.Forms.InvalidateEventHandler

AddHandler instance.Invalidated, handler
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.ComponentModel.BrowsableAttribute(false)]
[SRDescriptionAttribute("Occurs when a control's display requires redrawing.")]
[SRCategoryAttribute("Appearance")]
public event System.Windows.Forms.InvalidateEventHandler Invalidated
Delphi
public event Invalidated: System.Windows.Forms.InvalidateEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.ComponentModel.BrowsableAttribute(false)]
[SRDescriptionAttribute("Occurs when a control's display requires redrawing.")]
[SRCategoryAttribute("Appearance")]
public: __event System.Windows.Forms.InvalidateEventHandler* Invalidated
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.ComponentModel.BrowsableAttribute(false)]
[SRDescriptionAttribute("Occurs when a control's display requires redrawing.")]
[SRCategoryAttribute("Appearance")]
public:
event System.Windows.Forms.InvalidateEventHandler^ Invalidated

Event Data

The event handler receives an argument of type System.Windows.Forms.InvalidateEventArgs containing data related to this event. The following InvalidateEventArgs properties provide information specific to this event.

Property | Description
InvalidRect | Gets the System.Drawing.Rectangle that contains the invalidated window area.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


Invoke Method

[image]
Intersoft WebTextEditor Documentation
Invoke Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : Invoke Method

Glossary Item Box

Overload List

Overload | Description
Invoke(Delegate) | (Inherited from System.Windows.Forms.Control)
Invoke(Delegate,Object[]) | (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


Invoke(Delegate) Method

[image]
Intersoft WebTextEditor Documentation
Invoke(Delegate) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class > Invoke Method : Invoke(Delegate) Method

method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function Invoke( _
   ByVal method As System.Delegate _
) As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim method As System.Delegate
Dim value As System.Object

value = instance.Invoke(method)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.object Invoke(
   System.Delegate method
)
Delphi
public function Invoke(
    method: System.Delegate
): System.TObject;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function Invoke(
   method : System.Delegate
) : System.Object;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.Object* Invoke(
   System.Delegate* method
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.Object^ Invoke(
   System.Delegate^ method
)

Parameters

method

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members
Overload List


Invoke(Delegate,Object[]) Method

[image]
Intersoft WebTextEditor Documentation
Invoke(Delegate,Object[]) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class > Invoke Method : Invoke(Delegate,Object[]) Method

method
args

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function Invoke( _
   ByVal method As System.Delegate, _
   ByVal ParamArray args() As System.Object _
) As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim method As System.Delegate
Dim args() As System.Object
Dim value As System.Object

value = instance.Invoke(method, args)
C#
public System.object Invoke(
   System.Delegate method,
   params System.object[] args
)
Delphi
public function Invoke(
    method: System.Delegate;
   params  args: System.TObjectarray of
): System.TObject;
JScript
public function Invoke(
   method : System.Delegate,
   args : System.Object[]
) : System.Object;
Managed Extensions for C++
public: System.Object* Invoke(
   System.Delegate* method,
   params System.Object*[]* args
)
C++/CLI
public:
System.Object^ Invoke(
   System.Delegate^ method,
   ... System.array<Object^>^ args
)

Parameters

method
args

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members
Overload List


InvokeGotFocus Method

[image]
Intersoft WebTextEditor Documentation
InvokeGotFocus Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : InvokeGotFocus Method

toInvoke
e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Sub InvokeGotFocus( _
   ByVal toInvoke As System.Windows.Forms.Control, _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim toInvoke As System.Windows.Forms.Control
Dim e As System.EventArgs

instance.InvokeGotFocus(toInvoke, e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected void InvokeGotFocus(
   System.Windows.Forms.Control toInvoke,
   System.EventArgs e
)
Delphi
protected procedure InvokeGotFocus(
    toInvoke: System.Windows.Forms.Control;
    e: System.EventArgs
);
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function InvokeGotFocus(
   toInvoke : System.Windows.Forms.Control,
   e : System.EventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: void InvokeGotFocus(
   System.Windows.Forms.Control* toInvoke,
   System.EventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
void InvokeGotFocus(
   System.Windows.Forms.Control^ toInvoke,
   System.EventArgs^ e
)

Parameters

toInvoke
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


InvokeLostFocus Method

[image]
Intersoft WebTextEditor Documentation
InvokeLostFocus Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : InvokeLostFocus Method

toInvoke
e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Sub InvokeLostFocus( _
   ByVal toInvoke As System.Windows.Forms.Control, _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim toInvoke As System.Windows.Forms.Control
Dim e As System.EventArgs

instance.InvokeLostFocus(toInvoke, e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected void InvokeLostFocus(
   System.Windows.Forms.Control toInvoke,
   System.EventArgs e
)
Delphi
protected procedure InvokeLostFocus(
    toInvoke: System.Windows.Forms.Control;
    e: System.EventArgs
);
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function InvokeLostFocus(
   toInvoke : System.Windows.Forms.Control,
   e : System.EventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: void InvokeLostFocus(
   System.Windows.Forms.Control* toInvoke,
   System.EventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
void InvokeLostFocus(
   System.Windows.Forms.Control^ toInvoke,
   System.EventArgs^ e
)

Parameters

toInvoke
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


InvokeOnClick Method

[image]
Intersoft WebTextEditor Documentation
InvokeOnClick Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : InvokeOnClick Method

toInvoke
e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Sub InvokeOnClick( _
   ByVal toInvoke As System.Windows.Forms.Control, _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim toInvoke As System.Windows.Forms.Control
Dim e As System.EventArgs

instance.InvokeOnClick(toInvoke, e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected void InvokeOnClick(
   System.Windows.Forms.Control toInvoke,
   System.EventArgs e
)
Delphi
protected procedure InvokeOnClick(
    toInvoke: System.Windows.Forms.Control;
    e: System.EventArgs
);
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function InvokeOnClick(
   toInvoke : System.Windows.Forms.Control,
   e : System.EventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: void InvokeOnClick(
   System.Windows.Forms.Control* toInvoke,
   System.EventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
void InvokeOnClick(
   System.Windows.Forms.Control^ toInvoke,
   System.EventArgs^ e
)

Parameters

toInvoke
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


InvokePaint Method

[image]
Intersoft WebTextEditor Documentation
InvokePaint Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : InvokePaint Method

c
e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Protected Sub InvokePaint( _
   ByVal c As System.Windows.Forms.Control, _
   ByVal e As System.Windows.Forms.PaintEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim c As System.Windows.Forms.Control
Dim e As System.Windows.Forms.PaintEventArgs

instance.InvokePaint(c, e)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
protected void InvokePaint(
   System.Windows.Forms.Control c,
   System.Windows.Forms.PaintEventArgs e
)
Delphi
protected procedure InvokePaint(
    c: System.Windows.Forms.Control;
    e: System.Windows.Forms.PaintEventArgs
);
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
protected function InvokePaint(
   c : System.Windows.Forms.Control,
   e : System.Windows.Forms.PaintEventArgs
);
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
protected: void InvokePaint(
   System.Windows.Forms.Control* c,
   System.Windows.Forms.PaintEventArgs* e
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
protected:
void InvokePaint(
   System.Windows.Forms.Control^ c,
   System.Windows.Forms.PaintEventArgs^ e
)

Parameters

c
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


InvokePaintBackground Method

[image]
Intersoft WebTextEditor Documentation
InvokePaintBackground Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : InvokePaintBackground Method

c
e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Protected Sub InvokePaintBackground( _
   ByVal c As System.Windows.Forms.Control, _
   ByVal e As System.Windows.Forms.PaintEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim c As System.Windows.Forms.Control
Dim e As System.Windows.Forms.PaintEventArgs

instance.InvokePaintBackground(c, e)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
protected void InvokePaintBackground(
   System.Windows.Forms.Control c,
   System.Windows.Forms.PaintEventArgs e
)
Delphi
protected procedure InvokePaintBackground(
    c: System.Windows.Forms.Control;
    e: System.Windows.Forms.PaintEventArgs
);
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
protected function InvokePaintBackground(
   c : System.Windows.Forms.Control,
   e : System.Windows.Forms.PaintEventArgs
);
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
protected: void InvokePaintBackground(
   System.Windows.Forms.Control* c,
   System.Windows.Forms.PaintEventArgs* e
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
protected:
void InvokePaintBackground(
   System.Windows.Forms.Control^ c,
   System.Windows.Forms.PaintEventArgs^ e
)

Parameters

c
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


InvokeRequired Property

[image]
Intersoft WebTextEditor Documentation
InvokeRequired Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : InvokeRequired Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<SRDescriptionAttribute("Determines if Invoke or BeginInvoke should be used to access this control cross-thread.")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
Public ReadOnly Property InvokeRequired As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Boolean

value = instance.InvokeRequired
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRDescriptionAttribute("Determines if Invoke or BeginInvoke should be used to access this control cross-thread.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public System.bool InvokeRequired {get;}
Delphi
public read-only property InvokeRequired: System.Boolean;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
SRDescriptionAttribute("Determines if Invoke or BeginInvoke should be used to access this control cross-thread.")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
public function get InvokeRequired : System.boolean
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRDescriptionAttribute("Determines if Invoke or BeginInvoke should be used to access this control cross-thread.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public: __property System.bool get_InvokeRequired();
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRDescriptionAttribute("Determines if Invoke or BeginInvoke should be used to access this control cross-thread.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public:
property System.bool InvokeRequired {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


IsAccessible Property

[image]
Intersoft WebTextEditor Documentation
IsAccessible Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : IsAccessible Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<SRDescriptionAttribute("Indicates whether the control is visible to accessibility applications.")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<SRCategoryAttribute("Behavior")>
Public Property IsAccessible As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Boolean

instance.IsAccessible = value

value = instance.IsAccessible
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRDescriptionAttribute("Indicates whether the control is visible to accessibility applications.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[SRCategoryAttribute("Behavior")]
public System.bool IsAccessible {get; set;}
Delphi
public read-write property IsAccessible: System.Boolean;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
SRDescriptionAttribute("Indicates whether the control is visible to accessibility applications.")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
SRCategoryAttribute("Behavior")
public function get,set IsAccessible : System.boolean
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRDescriptionAttribute("Indicates whether the control is visible to accessibility applications.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[SRCategoryAttribute("Behavior")]
public: __property System.bool get_IsAccessible();
public: __property void set_IsAccessible(
   System.bool value
);
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRDescriptionAttribute("Indicates whether the control is visible to accessibility applications.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[SRCategoryAttribute("Behavior")]
public:
property System.bool IsAccessible {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


IsDisposed Property

[image]
Intersoft WebTextEditor Documentation
IsDisposed Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : IsDisposed Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<SRDescriptionAttribute("Determines if this control has been disposed.")>
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public ReadOnly Property IsDisposed As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Boolean

value = instance.IsDisposed
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[SRDescriptionAttribute("Determines if this control has been disposed.")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public System.bool IsDisposed {get;}
Delphi
public read-only property IsDisposed: System.Boolean;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
SRDescriptionAttribute("Determines if this control has been disposed.")
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function get IsDisposed : System.boolean
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[SRDescriptionAttribute("Determines if this control has been disposed.")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: __property System.bool get_IsDisposed();
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[SRDescriptionAttribute("Determines if this control has been disposed.")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
property System.bool IsDisposed {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


IsHandleCreated Property

[image]
Intersoft WebTextEditor Documentation
IsHandleCreated Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : IsHandleCreated Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<SRDescriptionAttribute("Indicates whether the control has a handle associated with it.")>
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public ReadOnly Property IsHandleCreated As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Boolean

value = instance.IsHandleCreated
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[SRDescriptionAttribute("Indicates whether the control has a handle associated with it.")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public System.bool IsHandleCreated {get;}
Delphi
public read-only property IsHandleCreated: System.Boolean;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
SRDescriptionAttribute("Indicates whether the control has a handle associated with it.")
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function get IsHandleCreated : System.boolean
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[SRDescriptionAttribute("Indicates whether the control has a handle associated with it.")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: __property System.bool get_IsHandleCreated();
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[SRDescriptionAttribute("Indicates whether the control has a handle associated with it.")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
property System.bool IsHandleCreated {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


IsInputChar Method

[image]
Intersoft WebTextEditor Documentation
IsInputChar Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : IsInputChar Method

charCode

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.SafeSubWindows Or  _
    UIPermissionWindow.SafeTopLevelWindows Or  _
    UIPermissionWindow.AllWindows,
   Clipboard=UIPermissionClipboard.NoClipboard,
   Action=SecurityAction.Demand Or  _
    SecurityAction.Assert Or  _
    SecurityAction.Deny Or  _
    SecurityAction.PermitOnly Or  _
    SecurityAction.LinkDemand Or  _
    SecurityAction.InheritanceDemand,
   Unrestricted=False)>
Protected Overridable Function IsInputChar( _
   ByVal charCode As System.Char _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim charCode As System.Char
Dim value As System.Boolean

value = instance.IsInputChar(charCode)
C#
[System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.SafeSubWindows |
    UIPermissionWindow.SafeTopLevelWindows |
    UIPermissionWindow.AllWindows,
   Clipboard=UIPermissionClipboard.NoClipboard,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
protected virtual System.bool IsInputChar(
   System.char charCode
)
Delphi
protected function IsInputChar(
    charCode: System.Char
): System.Boolean; virtual;
JScript
System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.SafeSubWindows |
    UIPermissionWindow.SafeTopLevelWindows |
    UIPermissionWindow.AllWindows,
   Clipboard=UIPermissionClipboard.NoClipboard,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=)
protected function IsInputChar(
   charCode : System.char
) : System.boolean;
Managed Extensions for C++
[System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.SafeSubWindows |
    UIPermissionWindow.SafeTopLevelWindows |
    UIPermissionWindow.AllWindows,
   Clipboard=UIPermissionClipboard.NoClipboard,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
protected: virtual System.bool IsInputChar(
   System.char charCode
)
C++/CLI
[System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.SafeSubWindows |
    UIPermissionWindow.SafeTopLevelWindows |
    UIPermissionWindow.AllWindows,
   Clipboard=UIPermissionClipboard.NoClipboard,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
protected:
virtual System.bool IsInputChar(
   System.char charCode
)

Parameters

charCode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


IsInputKey Method

[image]
Intersoft WebTextEditor Documentation
IsInputKey Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : IsInputKey Method

keyData

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.SafeSubWindows Or  _
    UIPermissionWindow.SafeTopLevelWindows Or  _
    UIPermissionWindow.AllWindows,
   Clipboard=UIPermissionClipboard.NoClipboard,
   Action=SecurityAction.Demand Or  _
    SecurityAction.Assert Or  _
    SecurityAction.Deny Or  _
    SecurityAction.PermitOnly Or  _
    SecurityAction.LinkDemand Or  _
    SecurityAction.InheritanceDemand,
   Unrestricted=False)>
Protected Overridable Function IsInputKey( _
   ByVal keyData As System.Windows.Forms.Keys _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim keyData As System.Windows.Forms.Keys
Dim value As System.Boolean

value = instance.IsInputKey(keyData)
C#
[System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.SafeSubWindows |
    UIPermissionWindow.SafeTopLevelWindows |
    UIPermissionWindow.AllWindows,
   Clipboard=UIPermissionClipboard.NoClipboard,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
protected virtual System.bool IsInputKey(
   System.Windows.Forms.Keys keyData
)
Delphi
protected function IsInputKey(
    keyData: System.Windows.Forms.Keys
): System.Boolean; virtual;
JScript
System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.SafeSubWindows |
    UIPermissionWindow.SafeTopLevelWindows |
    UIPermissionWindow.AllWindows,
   Clipboard=UIPermissionClipboard.NoClipboard,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=)
protected function IsInputKey(
   keyData : System.Windows.Forms.Keys
) : System.boolean;
Managed Extensions for C++
[System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.SafeSubWindows |
    UIPermissionWindow.SafeTopLevelWindows |
    UIPermissionWindow.AllWindows,
   Clipboard=UIPermissionClipboard.NoClipboard,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
protected: virtual System.bool IsInputKey(
   System.Windows.Forms.Keys keyData
)
C++/CLI
[System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.SafeSubWindows |
    UIPermissionWindow.SafeTopLevelWindows |
    UIPermissionWindow.AllWindows,
   Clipboard=UIPermissionClipboard.NoClipboard,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
protected:
virtual System.bool IsInputKey(
   System.Windows.Forms.Keys keyData
)

Parameters

keyData

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


IsMdiChild Property

[image]
Intersoft WebTextEditor Documentation
IsMdiChild Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : IsMdiChild Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Window Style")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
<SRDescriptionAttribute("Determines whether the form is a child of a MDI container.")>
Public ReadOnly Property IsMdiChild As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Boolean

value = instance.IsMdiChild
C#
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[SRDescriptionAttribute("Determines whether the form is a child of a MDI container.")]
public System.bool IsMdiChild {get;}
Delphi
public read-only property IsMdiChild: System.Boolean;
JScript
SRCategoryAttribute("Window Style")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
SRDescriptionAttribute("Determines whether the form is a child of a MDI container.")
public function get IsMdiChild : System.boolean
Managed Extensions for C++
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[SRDescriptionAttribute("Determines whether the form is a child of a MDI container.")]
public: __property System.bool get_IsMdiChild();
C++/CLI
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[SRDescriptionAttribute("Determines whether the form is a child of a MDI container.")]
public:
property System.bool IsMdiChild {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


IsMdiContainer Property

[image]
Intersoft WebTextEditor Documentation
IsMdiContainer Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : IsMdiContainer Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Window Style")>
<SRDescriptionAttribute("Determines whether the form is an MDI container.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property IsMdiContainer As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Boolean

instance.IsMdiContainer = value

value = instance.IsMdiContainer
C#
[SRCategoryAttribute("Window Style")]
[SRDescriptionAttribute("Determines whether the form is an MDI container.")]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool IsMdiContainer {get; set;}
Delphi
public read-write property IsMdiContainer: System.Boolean;
JScript
SRCategoryAttribute("Window Style")
SRDescriptionAttribute("Determines whether the form is an MDI container.")
System.ComponentModel.DefaultValueAttribute()
public function get,set IsMdiContainer : System.boolean
Managed Extensions for C++
[SRCategoryAttribute("Window Style")]
[SRDescriptionAttribute("Determines whether the form is an MDI container.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_IsMdiContainer();
public: __property void set_IsMdiContainer(
   System.bool value
);
C++/CLI
[SRCategoryAttribute("Window Style")]
[SRDescriptionAttribute("Determines whether the form is an MDI container.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool IsMdiContainer {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


IsMirrored Property

[image]
Intersoft WebTextEditor Documentation
IsMirrored Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : IsMirrored Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<SRDescriptionAttribute("Indicates whether the control is mirrored.")>
<System.ComponentModel.BrowsableAttribute(False)>
<SRCategoryAttribute("Layout")>
Public ReadOnly Property IsMirrored As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Boolean

value = instance.IsMirrored
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[SRDescriptionAttribute("Indicates whether the control is mirrored.")]
[System.ComponentModel.BrowsableAttribute(false)]
[SRCategoryAttribute("Layout")]
public System.bool IsMirrored {get;}
Delphi
public read-only property IsMirrored: System.Boolean;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
SRDescriptionAttribute("Indicates whether the control is mirrored.")
System.ComponentModel.BrowsableAttribute()
SRCategoryAttribute("Layout")
public function get IsMirrored : System.boolean
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[SRDescriptionAttribute("Indicates whether the control is mirrored.")]
[System.ComponentModel.BrowsableAttribute(false)]
[SRCategoryAttribute("Layout")]
public: __property System.bool get_IsMirrored();
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[SRDescriptionAttribute("Indicates whether the control is mirrored.")]
[System.ComponentModel.BrowsableAttribute(false)]
[SRCategoryAttribute("Layout")]
public:
property System.bool IsMirrored {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


IsRestrictedWindow Property

[image]
Intersoft WebTextEditor Documentation
IsRestrictedWindow Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : IsRestrictedWindow Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public ReadOnly Property IsRestrictedWindow As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Boolean

value = instance.IsRestrictedWindow
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public System.bool IsRestrictedWindow {get;}
Delphi
public read-only property IsRestrictedWindow: System.Boolean;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function get IsRestrictedWindow : System.boolean
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: __property System.bool get_IsRestrictedWindow();
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
property System.bool IsRestrictedWindow {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


KeyDown Event

[image]
Intersoft WebTextEditor Documentation
KeyDown Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : KeyDown Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when a key is first pressed.")>
<SRCategoryAttribute("Key")>
Public Event KeyDown As System.Windows.Forms.KeyEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.Windows.Forms.KeyEventHandler

AddHandler instance.KeyDown, handler
C#
[SRDescriptionAttribute("Occurs when a key is first pressed.")]
[SRCategoryAttribute("Key")]
public event System.Windows.Forms.KeyEventHandler KeyDown
Delphi
public event KeyDown: System.Windows.Forms.KeyEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when a key is first pressed.")]
[SRCategoryAttribute("Key")]
public: __event System.Windows.Forms.KeyEventHandler* KeyDown
C++/CLI
[SRDescriptionAttribute("Occurs when a key is first pressed.")]
[SRCategoryAttribute("Key")]
public:
event System.Windows.Forms.KeyEventHandler^ KeyDown

Event Data

The event handler receives an argument of type System.Windows.Forms.KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
Handled | Gets or sets a value indicating whether the event was handled.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key data for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event. The flags indicate which combination of CTRL, SHIFT, and ALT keys was pressed.
Shift | Gets a value indicating whether the SHIFT key was pressed.
SuppressKeyPress | Gets or sets a value indicating whether the key event should be passed on to the underlying control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


KeyPress Event

[image]
Intersoft WebTextEditor Documentation
KeyPress Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : KeyPress Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Key")>
<SRDescriptionAttribute("Occurs when the control has focus and the user presses and releases a key.")>
Public Event KeyPress As System.Windows.Forms.KeyPressEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.Windows.Forms.KeyPressEventHandler

AddHandler instance.KeyPress, handler
C#
[SRCategoryAttribute("Key")]
[SRDescriptionAttribute("Occurs when the control has focus and the user presses and releases a key.")]
public event System.Windows.Forms.KeyPressEventHandler KeyPress
Delphi
public event KeyPress: System.Windows.Forms.KeyPressEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Key")]
[SRDescriptionAttribute("Occurs when the control has focus and the user presses and releases a key.")]
public: __event System.Windows.Forms.KeyPressEventHandler* KeyPress
C++/CLI
[SRCategoryAttribute("Key")]
[SRDescriptionAttribute("Occurs when the control has focus and the user presses and releases a key.")]
public:
event System.Windows.Forms.KeyPressEventHandler^ KeyPress

Event Data

The event handler receives an argument of type System.Windows.Forms.KeyPressEventArgs containing data related to this event. The following KeyPressEventArgs properties provide information specific to this event.

Property | Description
Handled | Gets or sets a value indicating whether the System.Windows.Forms.Control.KeyPress event was handled.
KeyChar | Gets or sets the character corresponding to the key pressed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


KeyPreview Property

[image]
Intersoft WebTextEditor Documentation
KeyPreview Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : KeyPreview Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Determines whether keyboard events for controls on the form are registered with the form.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property KeyPreview As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Boolean

instance.KeyPreview = value

value = instance.KeyPreview
C#
[SRDescriptionAttribute("Determines whether keyboard events for controls on the form are registered with the form.")]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool KeyPreview {get; set;}
Delphi
public read-write property KeyPreview: System.Boolean;
JScript
SRDescriptionAttribute("Determines whether keyboard events for controls on the form are registered with the form.")
System.ComponentModel.DefaultValueAttribute()
public function get,set KeyPreview : System.boolean
Managed Extensions for C++
[SRDescriptionAttribute("Determines whether keyboard events for controls on the form are registered with the form.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_KeyPreview();
public: __property void set_KeyPreview(
   System.bool value
);
C++/CLI
[SRDescriptionAttribute("Determines whether keyboard events for controls on the form are registered with the form.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool KeyPreview {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


KeyUp Event

[image]
Intersoft WebTextEditor Documentation
KeyUp Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : KeyUp Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when a key is released.")>
<SRCategoryAttribute("Key")>
Public Event KeyUp As System.Windows.Forms.KeyEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.Windows.Forms.KeyEventHandler

AddHandler instance.KeyUp, handler
C#
[SRDescriptionAttribute("Occurs when a key is released.")]
[SRCategoryAttribute("Key")]
public event System.Windows.Forms.KeyEventHandler KeyUp
Delphi
public event KeyUp: System.Windows.Forms.KeyEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when a key is released.")]
[SRCategoryAttribute("Key")]
public: __event System.Windows.Forms.KeyEventHandler* KeyUp
C++/CLI
[SRDescriptionAttribute("Occurs when a key is released.")]
[SRCategoryAttribute("Key")]
public:
event System.Windows.Forms.KeyEventHandler^ KeyUp

Event Data

The event handler receives an argument of type System.Windows.Forms.KeyEventArgs containing data related to this event. The following KeyEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
Handled | Gets or sets a value indicating whether the event was handled.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key data for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event. The flags indicate which combination of CTRL, SHIFT, and ALT keys was pressed.
Shift | Gets a value indicating whether the SHIFT key was pressed.
SuppressKeyPress | Gets or sets a value indicating whether the key event should be passed on to the underlying control.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


Layout Event

[image]
Intersoft WebTextEditor Documentation
Layout Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : Layout Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Layout")>
<SRDescriptionAttribute("Occurs when the control is about to lay out its contents.")>
Public Event Layout As System.Windows.Forms.LayoutEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.Windows.Forms.LayoutEventHandler

AddHandler instance.Layout, handler
C#
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Occurs when the control is about to lay out its contents.")]
public event System.Windows.Forms.LayoutEventHandler Layout
Delphi
public event Layout: System.Windows.Forms.LayoutEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Occurs when the control is about to lay out its contents.")]
public: __event System.Windows.Forms.LayoutEventHandler* Layout
C++/CLI
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Occurs when the control is about to lay out its contents.")]
public:
event System.Windows.Forms.LayoutEventHandler^ Layout

Event Data

The event handler receives an argument of type System.Windows.Forms.LayoutEventArgs containing data related to this event. The following LayoutEventArgs properties provide information specific to this event.

Property | Description
AffectedComponent | Gets the System.ComponentModel.Component affected by the layout change.
AffectedControl | Gets the child control affected by the change.
AffectedProperty | Gets the property affected by the change.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


LayoutEngine Property

[image]
Intersoft WebTextEditor Documentation
LayoutEngine Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : LayoutEngine Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Overridable ReadOnly Property LayoutEngine As System.Windows.Forms.Layout.LayoutEngine
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Windows.Forms.Layout.LayoutEngine

value = instance.LayoutEngine
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public virtual System.Windows.Forms.Layout.LayoutEngine LayoutEngine {get;}
Delphi
public read-only property LayoutEngine: System.Windows.Forms.Layout.LayoutEngine; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function get LayoutEngine : System.Windows.Forms.Layout.LayoutEngine
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: __property virtual System.Windows.Forms.Layout.LayoutEngine* get_LayoutEngine();
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
virtual property System.Windows.Forms.Layout.LayoutEngine^ LayoutEngine {
   System.Windows.Forms.Layout.LayoutEngine^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


LayoutMdi Method

[image]
Intersoft WebTextEditor Documentation
LayoutMdi Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : LayoutMdi Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub LayoutMdi( _
   ByVal value As System.Windows.Forms.MdiLayout _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Windows.Forms.MdiLayout

instance.LayoutMdi(value)
C#
public void LayoutMdi(
   System.Windows.Forms.MdiLayout value
)
Delphi
public procedure LayoutMdi(
    value: System.Windows.Forms.MdiLayout
);
JScript
public function LayoutMdi(
   value : System.Windows.Forms.MdiLayout
);
Managed Extensions for C++
public: void LayoutMdi(
   System.Windows.Forms.MdiLayout value
)
C++/CLI
public:
void LayoutMdi(
   System.Windows.Forms.MdiLayout value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


Leave Event

[image]
Intersoft WebTextEditor Documentation
Leave Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : Leave Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Focus")>
<SRDescriptionAttribute("Occurs when the control is no longer the active control of the form.")>
Public Event Leave As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.EventHandler

AddHandler instance.Leave, handler
C#
[SRCategoryAttribute("Focus")]
[SRDescriptionAttribute("Occurs when the control is no longer the active control of the form.")]
public event System.EventHandler Leave
Delphi
public event Leave: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Focus")]
[SRDescriptionAttribute("Occurs when the control is no longer the active control of the form.")]
public: __event System.EventHandler* Leave
C++/CLI
[SRCategoryAttribute("Focus")]
[SRDescriptionAttribute("Occurs when the control is no longer the active control of the form.")]
public:
event System.EventHandler^ Leave

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


Left Property

[image]
Intersoft WebTextEditor Documentation
Left Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : Left Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<SRDescriptionAttribute("The upper left of the control, in container coordinates.")>
<SRCategoryAttribute("Layout")>
<System.ComponentModel.EditorBrowsableAttribute()>
Public Property Left As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Integer

instance.Left = value

value = instance.Left
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[SRDescriptionAttribute("The upper left of the control, in container coordinates.")]
[SRCategoryAttribute("Layout")]
[System.ComponentModel.EditorBrowsableAttribute()]
public System.int Left {get; set;}
Delphi
public read-write property Left: System.Integer;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
SRDescriptionAttribute("The upper left of the control, in container coordinates.")
SRCategoryAttribute("Layout")
System.ComponentModel.EditorBrowsableAttribute()
public function get,set Left : System.int
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[SRDescriptionAttribute("The upper left of the control, in container coordinates.")]
[SRCategoryAttribute("Layout")]
[System.ComponentModel.EditorBrowsableAttribute()]
public: __property System.int get_Left();
public: __property void set_Left(
   System.int value
);
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[SRDescriptionAttribute("The upper left of the control, in container coordinates.")]
[SRCategoryAttribute("Layout")]
[System.ComponentModel.EditorBrowsableAttribute()]
public:
property System.int Left {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


Load Event

[image]
Intersoft WebTextEditor Documentation
Load Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : Load Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs whenever the user loads the form.")>
<SRCategoryAttribute("Behavior")>
Public Event Load As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.EventHandler

AddHandler instance.Load, handler
C#
[SRDescriptionAttribute("Occurs whenever the user loads the form.")]
[SRCategoryAttribute("Behavior")]
public event System.EventHandler Load
Delphi
public event Load: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs whenever the user loads the form.")]
[SRCategoryAttribute("Behavior")]
public: __event System.EventHandler* Load
C++/CLI
[SRDescriptionAttribute("Occurs whenever the user loads the form.")]
[SRCategoryAttribute("Behavior")]
public:
event System.EventHandler^ Load

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


Location Property

[image]
Intersoft WebTextEditor Documentation
Location Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : Location Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.SettingsBindableAttribute(True)>
Public Property Location As System.Drawing.Point
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Drawing.Point

instance.Location = value

value = instance.Location
C#
[System.ComponentModel.SettingsBindableAttribute(true)]
public System.Drawing.Point Location {get; set;}
Delphi
public read-write property Location: System.Drawing.Point;
JScript
System.ComponentModel.SettingsBindableAttribute()
public function get,set Location : System.Drawing.Point
Managed Extensions for C++
[System.ComponentModel.SettingsBindableAttribute(true)]
public: __property System.Drawing.Point get_Location();
public: __property void set_Location(
   System.Drawing.Point value
);
C++/CLI
[System.ComponentModel.SettingsBindableAttribute(true)]
public:
property System.Drawing.Point Location {
   System.Drawing.Point get();
   void set (    System.Drawing.Point value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


LocationChanged Event

[image]
Intersoft WebTextEditor Documentation
LocationChanged Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : LocationChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Property Changed")>
<SRDescriptionAttribute("Event raised when the value of the Location property is changed on Control.")>
Public Event LocationChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.EventHandler

AddHandler instance.LocationChanged, handler
C#
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the Location property is changed on Control.")]
public event System.EventHandler LocationChanged
Delphi
public event LocationChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the Location property is changed on Control.")]
public: __event System.EventHandler* LocationChanged
C++/CLI
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the Location property is changed on Control.")]
public:
event System.EventHandler^ LocationChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


LostFocus Event

[image]
Intersoft WebTextEditor Documentation
LostFocus Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : LostFocus Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the control loses focus.")>
<SRCategoryAttribute("Focus")>
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<System.ComponentModel.BrowsableAttribute(False)>
Public Event LostFocus As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.EventHandler

AddHandler instance.LostFocus, handler
C#
[SRDescriptionAttribute("Occurs when the control loses focus.")]
[SRCategoryAttribute("Focus")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.ComponentModel.BrowsableAttribute(false)]
public event System.EventHandler LostFocus
Delphi
public event LostFocus: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the control loses focus.")]
[SRCategoryAttribute("Focus")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.ComponentModel.BrowsableAttribute(false)]
public: __event System.EventHandler* LostFocus
C++/CLI
[SRDescriptionAttribute("Occurs when the control loses focus.")]
[SRCategoryAttribute("Focus")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.ComponentModel.BrowsableAttribute(false)]
public:
event System.EventHandler^ LostFocus

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


MainMenuStrip Property

[image]
Intersoft WebTextEditor Documentation
MainMenuStrip Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : MainMenuStrip Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Window Style")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ReferenceConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.DefaultValueAttribute()>
<SRDescriptionAttribute("Specifies the primary MenuStrip for the Form. This property is used for keyboard activation and automatic merging in MDI.")>
Public Property MainMenuStrip As System.Windows.Forms.MenuStrip
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Windows.Forms.MenuStrip

instance.MainMenuStrip = value

value = instance.MainMenuStrip
C#
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ReferenceConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("Specifies the primary MenuStrip for the Form. This property is used for keyboard activation and automatic merging in MDI.")]
public System.Windows.Forms.MenuStrip MainMenuStrip {get; set;}
Delphi
public read-write property MainMenuStrip: System.Windows.Forms.MenuStrip;
JScript
SRCategoryAttribute("Window Style")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ReferenceConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.DefaultValueAttribute()
SRDescriptionAttribute("Specifies the primary MenuStrip for the Form. This property is used for keyboard activation and automatic merging in MDI.")
public function get,set MainMenuStrip : System.Windows.Forms.MenuStrip
Managed Extensions for C++
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ReferenceConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("Specifies the primary MenuStrip for the Form. This property is used for keyboard activation and automatic merging in MDI.")]
public: __property System.Windows.Forms.MenuStrip* get_MainMenuStrip();
public: __property void set_MainMenuStrip(
   System.Windows.Forms.MenuStrip* value
);
C++/CLI
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ReferenceConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("Specifies the primary MenuStrip for the Form. This property is used for keyboard activation and automatic merging in MDI.")]
public:
property System.Windows.Forms.MenuStrip^ MainMenuStrip {
   System.Windows.Forms.MenuStrip^ get();
   void set (    System.Windows.Forms.MenuStrip^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


MaximizeBox Property

[image]
Intersoft WebTextEditor Documentation
MaximizeBox Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : MaximizeBox Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Window Style")>
<SRDescriptionAttribute("Determines whether a form has a maximize box in the upper-right corner of its caption bar.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property MaximizeBox As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Boolean

instance.MaximizeBox = value

value = instance.MaximizeBox
C#
[SRCategoryAttribute("Window Style")]
[SRDescriptionAttribute("Determines whether a form has a maximize box in the upper-right corner of its caption bar.")]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool MaximizeBox {get; set;}
Delphi
public read-write property MaximizeBox: System.Boolean;
JScript
SRCategoryAttribute("Window Style")
SRDescriptionAttribute("Determines whether a form has a maximize box in the upper-right corner of its caption bar.")
System.ComponentModel.DefaultValueAttribute()
public function get,set MaximizeBox : System.boolean
Managed Extensions for C++
[SRCategoryAttribute("Window Style")]
[SRDescriptionAttribute("Determines whether a form has a maximize box in the upper-right corner of its caption bar.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_MaximizeBox();
public: __property void set_MaximizeBox(
   System.bool value
);
C++/CLI
[SRCategoryAttribute("Window Style")]
[SRDescriptionAttribute("Determines whether a form has a maximize box in the upper-right corner of its caption bar.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool MaximizeBox {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


MaximizedBounds Property

[image]
Intersoft WebTextEditor Documentation
MaximizedBounds Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : MaximizedBounds Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Property MaximizedBounds As System.Drawing.Rectangle
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Drawing.Rectangle

instance.MaximizedBounds = value

value = instance.MaximizedBounds
C#
protected System.Drawing.Rectangle MaximizedBounds {get; set;}
Delphi
protected read-write property MaximizedBounds: System.Drawing.Rectangle;
JScript
protected function get,set MaximizedBounds : System.Drawing.Rectangle
Managed Extensions for C++
protected: __property System.Drawing.Rectangle get_MaximizedBounds();
protected: __property void set_MaximizedBounds(
   System.Drawing.Rectangle value
);
C++/CLI
protected:
property System.Drawing.Rectangle MaximizedBounds {
   System.Drawing.Rectangle get();
   void set (    System.Drawing.Rectangle value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


MaximizedBoundsChanged Event

[image]
Intersoft WebTextEditor Documentation
MaximizedBoundsChanged Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : MaximizedBoundsChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Event raised when the value of the MaximizedBounds property is changed on Form.")>
<SRCategoryAttribute("Property Changed")>
Public Event MaximizedBoundsChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.EventHandler

AddHandler instance.MaximizedBoundsChanged, handler
C#
[SRDescriptionAttribute("Event raised when the value of the MaximizedBounds property is changed on Form.")]
[SRCategoryAttribute("Property Changed")]
public event System.EventHandler MaximizedBoundsChanged
Delphi
public event MaximizedBoundsChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Event raised when the value of the MaximizedBounds property is changed on Form.")]
[SRCategoryAttribute("Property Changed")]
public: __event System.EventHandler* MaximizedBoundsChanged
C++/CLI
[SRDescriptionAttribute("Event raised when the value of the MaximizedBounds property is changed on Form.")]
[SRCategoryAttribute("Property Changed")]
public:
event System.EventHandler^ MaximizedBoundsChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


MaximumSize Property

[image]
Intersoft WebTextEditor Documentation
MaximumSize Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : MaximumSize Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.LocalizableAttribute(True)>
<System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.Repaint)>
<SRCategoryAttribute("Layout")>
<SRDescriptionAttribute("The maximum size the form can be resized to.")>
Public Overridable Property MaximumSize As System.Drawing.Size
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Drawing.Size

instance.MaximumSize = value

value = instance.MaximumSize
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.LocalizableAttribute(true)]
[System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.Repaint)]
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("The maximum size the form can be resized to.")]
public virtual System.Drawing.Size MaximumSize {get; set;}
Delphi
public read-write property MaximumSize: System.Drawing.Size; virtual;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.LocalizableAttribute()
System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.Repaint)
SRCategoryAttribute("Layout")
SRDescriptionAttribute("The maximum size the form can be resized to.")
public function get,set MaximumSize : System.Drawing.Size
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.LocalizableAttribute(true)]
[System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.Repaint)]
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("The maximum size the form can be resized to.")]
public: __property virtual System.Drawing.Size get_MaximumSize();
public: __property virtual void set_MaximumSize(
   System.Drawing.Size value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.LocalizableAttribute(true)]
[System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.Repaint)]
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("The maximum size the form can be resized to.")]
public:
virtual property System.Drawing.Size MaximumSize {
   System.Drawing.Size get();
   void set (    System.Drawing.Size value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


MaximumSizeChanged Event

[image]
Intersoft WebTextEditor Documentation
MaximumSizeChanged Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : MaximumSizeChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Property Changed")>
<SRDescriptionAttribute("Event raised when the value of the MaximumSize property is changed on Form.")>
Public Event MaximumSizeChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.EventHandler

AddHandler instance.MaximumSizeChanged, handler
C#
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the MaximumSize property is changed on Form.")]
public event System.EventHandler MaximumSizeChanged
Delphi
public event MaximumSizeChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the MaximumSize property is changed on Form.")]
public: __event System.EventHandler* MaximumSizeChanged
C++/CLI
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the MaximumSize property is changed on Form.")]
public:
event System.EventHandler^ MaximumSizeChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


MdiChildActivate Event

[image]
Intersoft WebTextEditor Documentation
MdiChildActivate Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : MdiChildActivate Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Layout")>
<SRDescriptionAttribute("Occurs when an MDI Child window is activated.")>
Public Event MdiChildActivate As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.EventHandler

AddHandler instance.MdiChildActivate, handler
C#
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Occurs when an MDI Child window is activated.")]
public event System.EventHandler MdiChildActivate
Delphi
public event MdiChildActivate: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Occurs when an MDI Child window is activated.")]
public: __event System.EventHandler* MdiChildActivate
C++/CLI
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Occurs when an MDI Child window is activated.")]
public:
event System.EventHandler^ MdiChildActivate

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


MdiChildren Property

[image]
Intersoft WebTextEditor Documentation
MdiChildren Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : MdiChildren Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Retrieves the MDI children of this form.")>
<SRCategoryAttribute("Window Style")>
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public ReadOnly Property MdiChildren As System.Windows.Forms.Form()
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value() As System.Windows.Forms.Form

value = instance.MdiChildren
C#
[SRDescriptionAttribute("Retrieves the MDI children of this form.")]
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public System.Windows.Forms.Form[] MdiChildren {get;}
Delphi
public read-only property MdiChildren: System.Windows.Forms.array of Form;
JScript
SRDescriptionAttribute("Retrieves the MDI children of this form.")
SRCategoryAttribute("Window Style")
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get MdiChildren : System.Windows.Forms.Form[]
Managed Extensions for C++
[SRDescriptionAttribute("Retrieves the MDI children of this form.")]
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property System.Windows.Forms.Form*[]* get_MdiChildren();
C++/CLI
[SRDescriptionAttribute("Retrieves the MDI children of this form.")]
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property System.Windows.Forms.array<Form^>^ MdiChildren {
   System.Windows.Forms.array<Form^>^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


MdiParent Property

[image]
Intersoft WebTextEditor Documentation
MdiParent Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : MdiParent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<SRCategoryAttribute("Window Style")>
<SRDescriptionAttribute("Retrieves the MDI parent of this form.")>
<System.ComponentModel.BrowsableAttribute(False)>
Public Property MdiParent As System.Windows.Forms.Form
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Windows.Forms.Form

instance.MdiParent = value

value = instance.MdiParent
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[SRCategoryAttribute("Window Style")]
[SRDescriptionAttribute("Retrieves the MDI parent of this form.")]
[System.ComponentModel.BrowsableAttribute(false)]
public System.Windows.Forms.Form MdiParent {get; set;}
Delphi
public read-write property MdiParent: System.Windows.Forms.Form;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
SRCategoryAttribute("Window Style")
SRDescriptionAttribute("Retrieves the MDI parent of this form.")
System.ComponentModel.BrowsableAttribute()
public function get,set MdiParent : System.Windows.Forms.Form
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[SRCategoryAttribute("Window Style")]
[SRDescriptionAttribute("Retrieves the MDI parent of this form.")]
[System.ComponentModel.BrowsableAttribute(false)]
public: __property System.Windows.Forms.Form* get_MdiParent();
public: __property void set_MdiParent(
   System.Windows.Forms.Form* value
);
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[SRCategoryAttribute("Window Style")]
[SRDescriptionAttribute("Retrieves the MDI parent of this form.")]
[System.ComponentModel.BrowsableAttribute(false)]
public:
property System.Windows.Forms.Form^ MdiParent {
   System.Windows.Forms.Form^ get();
   void set (    System.Windows.Forms.Form^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


MemberwiseClone Method

[image]
Intersoft WebTextEditor Documentation
MemberwiseClone Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : MemberwiseClone Method

Glossary Item Box

Overload List

Overload | Description
MemberwiseClone(Boolean) | (Inherited from System.MarshalByRefObject)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


MemberwiseClone(Boolean) Method

[image]
Intersoft WebTextEditor Documentation
MemberwiseClone(Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class > MemberwiseClone Method : MemberwiseClone(Boolean) Method

cloneIdentity

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overloads Function MemberwiseClone( _
   ByVal cloneIdentity As System.Boolean _
) As System.MarshalByRefObject
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim cloneIdentity As System.Boolean
Dim value As System.MarshalByRefObject

value = instance.MemberwiseClone(cloneIdentity)
C#
protected System.MarshalByRefObject MemberwiseClone(
   System.bool cloneIdentity
)
Delphi
protected function MemberwiseClone(
    cloneIdentity: System.Boolean
): System.MarshalByRefObject;
JScript
protected function MemberwiseClone(
   cloneIdentity : System.boolean
) : System.MarshalByRefObject;
Managed Extensions for C++
protected: System.MarshalByRefObject* MemberwiseClone(
   System.bool cloneIdentity
)
C++/CLI
protected:
System.MarshalByRefObject^ MemberwiseClone(
   System.bool cloneIdentity
)

Parameters

cloneIdentity

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members
Overload List


Menu Property

[image]
Intersoft WebTextEditor Documentation
Menu Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : Menu Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<SRCategoryAttribute("Window Style")>
<System.ComponentModel.DefaultValueAttribute()>
<SRDescriptionAttribute("The main menu of the form. This must be set to a component of type MainMenu.")>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ReferenceConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
Public Property Menu As System.Windows.Forms.MainMenu
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Windows.Forms.MainMenu

instance.Menu = value

value = instance.Menu
C#
[System.ComponentModel.BrowsableAttribute(false)]
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("The main menu of the form. This must be set to a component of type MainMenu.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ReferenceConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public System.Windows.Forms.MainMenu Menu {get; set;}
Delphi
public read-write property Menu: System.Windows.Forms.MainMenu;
JScript
System.ComponentModel.BrowsableAttribute()
SRCategoryAttribute("Window Style")
System.ComponentModel.DefaultValueAttribute()
SRDescriptionAttribute("The main menu of the form. This must be set to a component of type MainMenu.")
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ReferenceConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
public function get,set Menu : System.Windows.Forms.MainMenu
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("The main menu of the form. This must be set to a component of type MainMenu.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ReferenceConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public: __property System.Windows.Forms.MainMenu* get_Menu();
public: __property void set_Menu(
   System.Windows.Forms.MainMenu* value
);
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("The main menu of the form. This must be set to a component of type MainMenu.")]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.ReferenceConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public:
property System.Windows.Forms.MainMenu^ Menu {
   System.Windows.Forms.MainMenu^ get();
   void set (    System.Windows.Forms.MainMenu^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


MenuComplete Event

[image]
Intersoft WebTextEditor Documentation
MenuComplete Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : MenuComplete Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("Occurs when menu selection is completed and menu modal message loop has exited.")>
Public Event MenuComplete As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.EventHandler

AddHandler instance.MenuComplete, handler
C#
[System.ComponentModel.BrowsableAttribute(false)]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when menu selection is completed and menu modal message loop has exited.")]
public event System.EventHandler MenuComplete
Delphi
public event MenuComplete: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when menu selection is completed and menu modal message loop has exited.")]
public: __event System.EventHandler* MenuComplete
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when menu selection is completed and menu modal message loop has exited.")]
public:
event System.EventHandler^ MenuComplete

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


MenuStart Event

[image]
Intersoft WebTextEditor Documentation
MenuStart Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : MenuStart Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
<System.ComponentModel.BrowsableAttribute(False)>
<SRDescriptionAttribute("Occurs when any menu is displayed and menu modal message loop is entered.")>
Public Event MenuStart As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.EventHandler

AddHandler instance.MenuStart, handler
C#
[SRCategoryAttribute("Behavior")]
[System.ComponentModel.BrowsableAttribute(false)]
[SRDescriptionAttribute("Occurs when any menu is displayed and menu modal message loop is entered.")]
public event System.EventHandler MenuStart
Delphi
public event MenuStart: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
[System.ComponentModel.BrowsableAttribute(false)]
[SRDescriptionAttribute("Occurs when any menu is displayed and menu modal message loop is entered.")]
public: __event System.EventHandler* MenuStart
C++/CLI
[SRCategoryAttribute("Behavior")]
[System.ComponentModel.BrowsableAttribute(false)]
[SRDescriptionAttribute("Occurs when any menu is displayed and menu modal message loop is entered.")]
public:
event System.EventHandler^ MenuStart

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


MergedMenu Property

[image]
Intersoft WebTextEditor Documentation
MergedMenu Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : MergedMenu Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<SRCategoryAttribute("Window Style")>
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<SRDescriptionAttribute("The merged menu of this form, which is used when displaying a single merged MDI menu.")>
Public ReadOnly Property MergedMenu As System.Windows.Forms.MainMenu
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Windows.Forms.MainMenu

value = instance.MergedMenu
C#
[System.ComponentModel.BrowsableAttribute(false)]
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[SRDescriptionAttribute("The merged menu of this form, which is used when displaying a single merged MDI menu.")]
public System.Windows.Forms.MainMenu MergedMenu {get;}
Delphi
public read-only property MergedMenu: System.Windows.Forms.MainMenu;
JScript
System.ComponentModel.BrowsableAttribute()
SRCategoryAttribute("Window Style")
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
SRDescriptionAttribute("The merged menu of this form, which is used when displaying a single merged MDI menu.")
public function get MergedMenu : System.Windows.Forms.MainMenu
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[SRDescriptionAttribute("The merged menu of this form, which is used when displaying a single merged MDI menu.")]
public: __property System.Windows.Forms.MainMenu* get_MergedMenu();
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[SRDescriptionAttribute("The merged menu of this form, which is used when displaying a single merged MDI menu.")]
public:
property System.Windows.Forms.MainMenu^ MergedMenu {
   System.Windows.Forms.MainMenu^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


MinimizeBox Property

[image]
Intersoft WebTextEditor Documentation
MinimizeBox Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : MinimizeBox Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Window Style")>
<System.ComponentModel.DefaultValueAttribute()>
<SRDescriptionAttribute("Determines whether a form has a minimize box in the upper-right corner of its caption bar.")>
Public Property MinimizeBox As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Boolean

instance.MinimizeBox = value

value = instance.MinimizeBox
C#
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("Determines whether a form has a minimize box in the upper-right corner of its caption bar.")]
public System.bool MinimizeBox {get; set;}
Delphi
public read-write property MinimizeBox: System.Boolean;
JScript
SRCategoryAttribute("Window Style")
System.ComponentModel.DefaultValueAttribute()
SRDescriptionAttribute("Determines whether a form has a minimize box in the upper-right corner of its caption bar.")
public function get,set MinimizeBox : System.boolean
Managed Extensions for C++
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("Determines whether a form has a minimize box in the upper-right corner of its caption bar.")]
public: __property System.bool get_MinimizeBox();
public: __property void set_MinimizeBox(
   System.bool value
);
C++/CLI
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("Determines whether a form has a minimize box in the upper-right corner of its caption bar.")]
public:
property System.bool MinimizeBox {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


MinimumSize Property

[image]
Intersoft WebTextEditor Documentation
MinimumSize Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : MinimumSize Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The minimum size the form can be resized to.")>
<System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.Repaint)>
<SRCategoryAttribute("Layout")>
<System.ComponentModel.LocalizableAttribute(True)>
Public Overridable Property MinimumSize As System.Drawing.Size
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Drawing.Size

instance.MinimumSize = value

value = instance.MinimumSize
C#
[SRDescriptionAttribute("The minimum size the form can be resized to.")]
[System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.Repaint)]
[SRCategoryAttribute("Layout")]
[System.ComponentModel.LocalizableAttribute(true)]
public virtual System.Drawing.Size MinimumSize {get; set;}
Delphi
public read-write property MinimumSize: System.Drawing.Size; virtual;
JScript
SRDescriptionAttribute("The minimum size the form can be resized to.")
System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.Repaint)
SRCategoryAttribute("Layout")
System.ComponentModel.LocalizableAttribute()
public function get,set MinimumSize : System.Drawing.Size
Managed Extensions for C++
[SRDescriptionAttribute("The minimum size the form can be resized to.")]
[System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.Repaint)]
[SRCategoryAttribute("Layout")]
[System.ComponentModel.LocalizableAttribute(true)]
public: __property virtual System.Drawing.Size get_MinimumSize();
public: __property virtual void set_MinimumSize(
   System.Drawing.Size value
);
C++/CLI
[SRDescriptionAttribute("The minimum size the form can be resized to.")]
[System.ComponentModel.RefreshPropertiesAttribute(RefreshProperties.Repaint)]
[SRCategoryAttribute("Layout")]
[System.ComponentModel.LocalizableAttribute(true)]
public:
virtual property System.Drawing.Size MinimumSize {
   System.Drawing.Size get();
   void set (    System.Drawing.Size value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


MinimumSizeChanged Event

[image]
Intersoft WebTextEditor Documentation
MinimumSizeChanged Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : MinimumSizeChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Event raised when the value of the MinimumSize property is changed on Form.")>
<SRCategoryAttribute("Property Changed")>
Public Event MinimumSizeChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.EventHandler

AddHandler instance.MinimumSizeChanged, handler
C#
[SRDescriptionAttribute("Event raised when the value of the MinimumSize property is changed on Form.")]
[SRCategoryAttribute("Property Changed")]
public event System.EventHandler MinimumSizeChanged
Delphi
public event MinimumSizeChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Event raised when the value of the MinimumSize property is changed on Form.")]
[SRCategoryAttribute("Property Changed")]
public: __event System.EventHandler* MinimumSizeChanged
C++/CLI
[SRDescriptionAttribute("Event raised when the value of the MinimumSize property is changed on Form.")]
[SRCategoryAttribute("Property Changed")]
public:
event System.EventHandler^ MinimumSizeChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


Modal Property

[image]
Intersoft WebTextEditor Documentation
Modal Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : Modal Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Indicates if this form is currently being displayed as a modal dialog box.")>
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<SRCategoryAttribute("Window Style")>
Public ReadOnly Property Modal As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Boolean

value = instance.Modal
C#
[SRDescriptionAttribute("Indicates if this form is currently being displayed as a modal dialog box.")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[SRCategoryAttribute("Window Style")]
public System.bool Modal {get;}
Delphi
public read-only property Modal: System.Boolean;
JScript
SRDescriptionAttribute("Indicates if this form is currently being displayed as a modal dialog box.")
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
SRCategoryAttribute("Window Style")
public function get Modal : System.boolean
Managed Extensions for C++
[SRDescriptionAttribute("Indicates if this form is currently being displayed as a modal dialog box.")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[SRCategoryAttribute("Window Style")]
public: __property System.bool get_Modal();
C++/CLI
[SRDescriptionAttribute("Indicates if this form is currently being displayed as a modal dialog box.")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[SRCategoryAttribute("Window Style")]
public:
property System.bool Modal {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


MouseCaptureChanged Event

[image]
Intersoft WebTextEditor Documentation
MouseCaptureChanged Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : MouseCaptureChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs after the mouse capture is changed.")>
<SRCategoryAttribute("Action")>
Public Event MouseCaptureChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.EventHandler

AddHandler instance.MouseCaptureChanged, handler
C#
[SRDescriptionAttribute("Occurs after the mouse capture is changed.")]
[SRCategoryAttribute("Action")]
public event System.EventHandler MouseCaptureChanged
Delphi
public event MouseCaptureChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs after the mouse capture is changed.")]
[SRCategoryAttribute("Action")]
public: __event System.EventHandler* MouseCaptureChanged
C++/CLI
[SRDescriptionAttribute("Occurs after the mouse capture is changed.")]
[SRCategoryAttribute("Action")]
public:
event System.EventHandler^ MouseCaptureChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


MouseClick Event

[image]
Intersoft WebTextEditor Documentation
MouseClick Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : MouseClick Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the control is clicked by the mouse.")>
<SRCategoryAttribute("Action")>
Public Event MouseClick As System.Windows.Forms.MouseEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.Windows.Forms.MouseEventHandler

AddHandler instance.MouseClick, handler
C#
[SRDescriptionAttribute("Occurs when the control is clicked by the mouse.")]
[SRCategoryAttribute("Action")]
public event System.Windows.Forms.MouseEventHandler MouseClick
Delphi
public event MouseClick: System.Windows.Forms.MouseEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the control is clicked by the mouse.")]
[SRCategoryAttribute("Action")]
public: __event System.Windows.Forms.MouseEventHandler* MouseClick
C++/CLI
[SRDescriptionAttribute("Occurs when the control is clicked by the mouse.")]
[SRCategoryAttribute("Action")]
public:
event System.Windows.Forms.MouseEventHandler^ MouseClick

Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


MouseDoubleClick Event

[image]
Intersoft WebTextEditor Documentation
MouseDoubleClick Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : MouseDoubleClick Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Action")>
<SRDescriptionAttribute("Occurs when the control is double clicked by the mouse.")>
Public Event MouseDoubleClick As System.Windows.Forms.MouseEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.Windows.Forms.MouseEventHandler

AddHandler instance.MouseDoubleClick, handler
C#
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when the control is double clicked by the mouse.")]
public event System.Windows.Forms.MouseEventHandler MouseDoubleClick
Delphi
public event MouseDoubleClick: System.Windows.Forms.MouseEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when the control is double clicked by the mouse.")]
public: __event System.Windows.Forms.MouseEventHandler* MouseDoubleClick
C++/CLI
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when the control is double clicked by the mouse.")]
public:
event System.Windows.Forms.MouseEventHandler^ MouseDoubleClick

Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


MouseDown Event

[image]
Intersoft WebTextEditor Documentation
MouseDown Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : MouseDown Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the mouse pointer is over the component and a mouse button is pressed.")>
<SRCategoryAttribute("Mouse")>
Public Event MouseDown As System.Windows.Forms.MouseEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.Windows.Forms.MouseEventHandler

AddHandler instance.MouseDown, handler
C#
[SRDescriptionAttribute("Occurs when the mouse pointer is over the component and a mouse button is pressed.")]
[SRCategoryAttribute("Mouse")]
public event System.Windows.Forms.MouseEventHandler MouseDown
Delphi
public event MouseDown: System.Windows.Forms.MouseEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the mouse pointer is over the component and a mouse button is pressed.")]
[SRCategoryAttribute("Mouse")]
public: __event System.Windows.Forms.MouseEventHandler* MouseDown
C++/CLI
[SRDescriptionAttribute("Occurs when the mouse pointer is over the component and a mouse button is pressed.")]
[SRCategoryAttribute("Mouse")]
public:
event System.Windows.Forms.MouseEventHandler^ MouseDown

Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


MouseEnter Event

[image]
Intersoft WebTextEditor Documentation
MouseEnter Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : MouseEnter Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the mouse enters the visible part of the control.")>
<SRCategoryAttribute("Mouse")>
Public Event MouseEnter As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.EventHandler

AddHandler instance.MouseEnter, handler
C#
[SRDescriptionAttribute("Occurs when the mouse enters the visible part of the control.")]
[SRCategoryAttribute("Mouse")]
public event System.EventHandler MouseEnter
Delphi
public event MouseEnter: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the mouse enters the visible part of the control.")]
[SRCategoryAttribute("Mouse")]
public: __event System.EventHandler* MouseEnter
C++/CLI
[SRDescriptionAttribute("Occurs when the mouse enters the visible part of the control.")]
[SRCategoryAttribute("Mouse")]
public:
event System.EventHandler^ MouseEnter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


MouseHover Event

[image]
Intersoft WebTextEditor Documentation
MouseHover Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : MouseHover Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Mouse")>
<SRDescriptionAttribute("Occurs when the mouse remains stationary inside of the control for an amount of time.")>
Public Event MouseHover As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.EventHandler

AddHandler instance.MouseHover, handler
C#
[SRCategoryAttribute("Mouse")]
[SRDescriptionAttribute("Occurs when the mouse remains stationary inside of the control for an amount of time.")]
public event System.EventHandler MouseHover
Delphi
public event MouseHover: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Mouse")]
[SRDescriptionAttribute("Occurs when the mouse remains stationary inside of the control for an amount of time.")]
public: __event System.EventHandler* MouseHover
C++/CLI
[SRCategoryAttribute("Mouse")]
[SRDescriptionAttribute("Occurs when the mouse remains stationary inside of the control for an amount of time.")]
public:
event System.EventHandler^ MouseHover

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


MouseLeave Event

[image]
Intersoft WebTextEditor Documentation
MouseLeave Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : MouseLeave Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Mouse")>
<SRDescriptionAttribute("Occurs when the mouse leaves the visible part of the control.")>
Public Event MouseLeave As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.EventHandler

AddHandler instance.MouseLeave, handler
C#
[SRCategoryAttribute("Mouse")]
[SRDescriptionAttribute("Occurs when the mouse leaves the visible part of the control.")]
public event System.EventHandler MouseLeave
Delphi
public event MouseLeave: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Mouse")]
[SRDescriptionAttribute("Occurs when the mouse leaves the visible part of the control.")]
public: __event System.EventHandler* MouseLeave
C++/CLI
[SRCategoryAttribute("Mouse")]
[SRDescriptionAttribute("Occurs when the mouse leaves the visible part of the control.")]
public:
event System.EventHandler^ MouseLeave

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


MouseMove Event

[image]
Intersoft WebTextEditor Documentation
MouseMove Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : MouseMove Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the mouse pointer is moved over the component.")>
<SRCategoryAttribute("Mouse")>
Public Event MouseMove As System.Windows.Forms.MouseEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.Windows.Forms.MouseEventHandler

AddHandler instance.MouseMove, handler
C#
[SRDescriptionAttribute("Occurs when the mouse pointer is moved over the component.")]
[SRCategoryAttribute("Mouse")]
public event System.Windows.Forms.MouseEventHandler MouseMove
Delphi
public event MouseMove: System.Windows.Forms.MouseEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the mouse pointer is moved over the component.")]
[SRCategoryAttribute("Mouse")]
public: __event System.Windows.Forms.MouseEventHandler* MouseMove
C++/CLI
[SRDescriptionAttribute("Occurs when the mouse pointer is moved over the component.")]
[SRCategoryAttribute("Mouse")]
public:
event System.Windows.Forms.MouseEventHandler^ MouseMove

Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


MouseUp Event

[image]
Intersoft WebTextEditor Documentation
MouseUp Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : MouseUp Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the mouse pointer is over the component and a mouse button is released.")>
<SRCategoryAttribute("Mouse")>
Public Event MouseUp As System.Windows.Forms.MouseEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.Windows.Forms.MouseEventHandler

AddHandler instance.MouseUp, handler
C#
[SRDescriptionAttribute("Occurs when the mouse pointer is over the component and a mouse button is released.")]
[SRCategoryAttribute("Mouse")]
public event System.Windows.Forms.MouseEventHandler MouseUp
Delphi
public event MouseUp: System.Windows.Forms.MouseEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the mouse pointer is over the component and a mouse button is released.")]
[SRCategoryAttribute("Mouse")]
public: __event System.Windows.Forms.MouseEventHandler* MouseUp
C++/CLI
[SRDescriptionAttribute("Occurs when the mouse pointer is over the component and a mouse button is released.")]
[SRCategoryAttribute("Mouse")]
public:
event System.Windows.Forms.MouseEventHandler^ MouseUp

Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


MouseWheel Event

[image]
Intersoft WebTextEditor Documentation
MouseWheel Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : MouseWheel Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Mouse")>
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<SRDescriptionAttribute("Occurs when the mouse wheel moves while the control has focus.")>
<System.ComponentModel.BrowsableAttribute(False)>
Public Event MouseWheel As System.Windows.Forms.MouseEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.Windows.Forms.MouseEventHandler

AddHandler instance.MouseWheel, handler
C#
[SRCategoryAttribute("Mouse")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRDescriptionAttribute("Occurs when the mouse wheel moves while the control has focus.")]
[System.ComponentModel.BrowsableAttribute(false)]
public event System.Windows.Forms.MouseEventHandler MouseWheel
Delphi
public event MouseWheel: System.Windows.Forms.MouseEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Mouse")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRDescriptionAttribute("Occurs when the mouse wheel moves while the control has focus.")]
[System.ComponentModel.BrowsableAttribute(false)]
public: __event System.Windows.Forms.MouseEventHandler* MouseWheel
C++/CLI
[SRCategoryAttribute("Mouse")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRDescriptionAttribute("Occurs when the mouse wheel moves while the control has focus.")]
[System.ComponentModel.BrowsableAttribute(false)]
public:
event System.Windows.Forms.MouseEventHandler^ MouseWheel

Event Data

The event handler receives an argument of type System.Windows.Forms.MouseEventArgs containing data related to this event. The following MouseEventArgs properties provide information specific to this event.

Property | Description
Button | Gets which mouse button was pressed.
Clicks | Gets the number of times the mouse button was pressed and released.
Delta | Gets a signed count of the number of detents the mouse wheel has rotated, multiplied by the WHEEL_DELTA constant. A detent is one notch of the mouse wheel.
Location | Gets the location of the mouse during the generating mouse event.
X | Gets the x-coordinate of the mouse during the generating mouse event.
Y | Gets the y-coordinate of the mouse during the generating mouse event.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


Move Event

[image]
Intersoft WebTextEditor Documentation
Move Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : Move Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Layout")>
<SRDescriptionAttribute("Occurs when a control is moved.")>
Public Event Move As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.EventHandler

AddHandler instance.Move, handler
C#
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Occurs when a control is moved.")]
public event System.EventHandler Move
Delphi
public event Move: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Occurs when a control is moved.")]
public: __event System.EventHandler* Move
C++/CLI
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Occurs when a control is moved.")]
public:
event System.EventHandler^ Move

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


Name Property

[image]
Intersoft WebTextEditor Documentation
Name Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : Name Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
Public Property Name As System.String
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.String

instance.Name = value

value = instance.Name
C#
[System.ComponentModel.BrowsableAttribute(false)]
public System.string Name {get; set;}
Delphi
public read-write property Name: System.String;
JScript
System.ComponentModel.BrowsableAttribute()
public function get,set Name : System.String
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
public: __property System.string* get_Name();
public: __property void set_Name(
   System.string* value
);
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
public:
property System.String^ Name {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


NotifyInvalidate Method

[image]
Intersoft WebTextEditor Documentation
NotifyInvalidate Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : NotifyInvalidate Method

invalidatedArea

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub NotifyInvalidate( _
   ByVal invalidatedArea As System.Drawing.Rectangle _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim invalidatedArea As System.Drawing.Rectangle

instance.NotifyInvalidate(invalidatedArea)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void NotifyInvalidate(
   System.Drawing.Rectangle invalidatedArea
)
Delphi
protected procedure NotifyInvalidate(
    invalidatedArea: System.Drawing.Rectangle
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function NotifyInvalidate(
   invalidatedArea : System.Drawing.Rectangle
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void NotifyInvalidate(
   System.Drawing.Rectangle invalidatedArea
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void NotifyInvalidate(
   System.Drawing.Rectangle invalidatedArea
)

Parameters

invalidatedArea

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnActivated Method

[image]
Intersoft WebTextEditor Documentation
OnActivated Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnActivated Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnActivated( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.EventArgs

instance.OnActivated(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnActivated(
   System.EventArgs e
)
Delphi
protected procedure OnActivated(
    e: System.EventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnActivated(
   e : System.EventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnActivated(
   System.EventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnActivated(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnAutoSizeChanged Method

[image]
Intersoft WebTextEditor Documentation
OnAutoSizeChanged Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnAutoSizeChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnAutoSizeChanged( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.EventArgs

instance.OnAutoSizeChanged(e)
C#
protected virtual void OnAutoSizeChanged(
   System.EventArgs e
)
Delphi
protected procedure OnAutoSizeChanged(
    e: System.EventArgs
); virtual;
JScript
protected function OnAutoSizeChanged(
   e : System.EventArgs
);
Managed Extensions for C++
protected: virtual void OnAutoSizeChanged(
   System.EventArgs* e
)
C++/CLI
protected:
virtual void OnAutoSizeChanged(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnAutoValidateChanged Method

[image]
Intersoft WebTextEditor Documentation
OnAutoValidateChanged Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnAutoValidateChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnAutoValidateChanged( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.EventArgs

instance.OnAutoValidateChanged(e)
C#
protected virtual void OnAutoValidateChanged(
   System.EventArgs e
)
Delphi
protected procedure OnAutoValidateChanged(
    e: System.EventArgs
); virtual;
JScript
protected function OnAutoValidateChanged(
   e : System.EventArgs
);
Managed Extensions for C++
protected: virtual void OnAutoValidateChanged(
   System.EventArgs* e
)
C++/CLI
protected:
virtual void OnAutoValidateChanged(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnBackColorChanged Method

[image]
Intersoft WebTextEditor Documentation
OnBackColorChanged Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnBackColorChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnBackColorChanged( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.EventArgs

instance.OnBackColorChanged(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnBackColorChanged(
   System.EventArgs e
)
Delphi
protected procedure OnBackColorChanged(
    e: System.EventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnBackColorChanged(
   e : System.EventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnBackColorChanged(
   System.EventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnBackColorChanged(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnBackgroundImageChanged Method

[image]
Intersoft WebTextEditor Documentation
OnBackgroundImageChanged Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnBackgroundImageChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnBackgroundImageChanged( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.EventArgs

instance.OnBackgroundImageChanged(e)
C#
protected virtual void OnBackgroundImageChanged(
   System.EventArgs e
)
Delphi
protected procedure OnBackgroundImageChanged(
    e: System.EventArgs
); virtual;
JScript
protected function OnBackgroundImageChanged(
   e : System.EventArgs
);
Managed Extensions for C++
protected: virtual void OnBackgroundImageChanged(
   System.EventArgs* e
)
C++/CLI
protected:
virtual void OnBackgroundImageChanged(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnBackgroundImageLayoutChanged Method

[image]
Intersoft WebTextEditor Documentation
OnBackgroundImageLayoutChanged Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnBackgroundImageLayoutChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnBackgroundImageLayoutChanged( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.EventArgs

instance.OnBackgroundImageLayoutChanged(e)
C#
protected virtual void OnBackgroundImageLayoutChanged(
   System.EventArgs e
)
Delphi
protected procedure OnBackgroundImageLayoutChanged(
    e: System.EventArgs
); virtual;
JScript
protected function OnBackgroundImageLayoutChanged(
   e : System.EventArgs
);
Managed Extensions for C++
protected: virtual void OnBackgroundImageLayoutChanged(
   System.EventArgs* e
)
C++/CLI
protected:
virtual void OnBackgroundImageLayoutChanged(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnBindingContextChanged Method

[image]
Intersoft WebTextEditor Documentation
OnBindingContextChanged Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnBindingContextChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnBindingContextChanged( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.EventArgs

instance.OnBindingContextChanged(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnBindingContextChanged(
   System.EventArgs e
)
Delphi
protected procedure OnBindingContextChanged(
    e: System.EventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnBindingContextChanged(
   e : System.EventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnBindingContextChanged(
   System.EventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnBindingContextChanged(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnCausesValidationChanged Method

[image]
Intersoft WebTextEditor Documentation
OnCausesValidationChanged Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnCausesValidationChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnCausesValidationChanged( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.EventArgs

instance.OnCausesValidationChanged(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnCausesValidationChanged(
   System.EventArgs e
)
Delphi
protected procedure OnCausesValidationChanged(
    e: System.EventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnCausesValidationChanged(
   e : System.EventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnCausesValidationChanged(
   System.EventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnCausesValidationChanged(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnChangeUICues Method

[image]
Intersoft WebTextEditor Documentation
OnChangeUICues Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnChangeUICues Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnChangeUICues( _
   ByVal e As System.Windows.Forms.UICuesEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.Windows.Forms.UICuesEventArgs

instance.OnChangeUICues(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnChangeUICues(
   System.Windows.Forms.UICuesEventArgs e
)
Delphi
protected procedure OnChangeUICues(
    e: System.Windows.Forms.UICuesEventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnChangeUICues(
   e : System.Windows.Forms.UICuesEventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnChangeUICues(
   System.Windows.Forms.UICuesEventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnChangeUICues(
   System.Windows.Forms.UICuesEventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnClick Method

[image]
Intersoft WebTextEditor Documentation
OnClick Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnClick Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnClick( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.EventArgs

instance.OnClick(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnClick(
   System.EventArgs e
)
Delphi
protected procedure OnClick(
    e: System.EventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnClick(
   e : System.EventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnClick(
   System.EventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnClick(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnClientSizeChanged Method

[image]
Intersoft WebTextEditor Documentation
OnClientSizeChanged Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnClientSizeChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnClientSizeChanged( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.EventArgs

instance.OnClientSizeChanged(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnClientSizeChanged(
   System.EventArgs e
)
Delphi
protected procedure OnClientSizeChanged(
    e: System.EventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnClientSizeChanged(
   e : System.EventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnClientSizeChanged(
   System.EventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnClientSizeChanged(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnClosed Method

[image]
Intersoft WebTextEditor Documentation
OnClosed Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnClosed Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnClosed( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.EventArgs

instance.OnClosed(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnClosed(
   System.EventArgs e
)
Delphi
protected procedure OnClosed(
    e: System.EventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnClosed(
   e : System.EventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnClosed(
   System.EventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnClosed(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnClosing Method

[image]
Intersoft WebTextEditor Documentation
OnClosing Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnClosing Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnClosing( _
   ByVal e As System.ComponentModel.CancelEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.ComponentModel.CancelEventArgs

instance.OnClosing(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnClosing(
   System.ComponentModel.CancelEventArgs e
)
Delphi
protected procedure OnClosing(
    e: System.ComponentModel.CancelEventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnClosing(
   e : System.ComponentModel.CancelEventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnClosing(
   System.ComponentModel.CancelEventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnClosing(
   System.ComponentModel.CancelEventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnContextMenuChanged Method

[image]
Intersoft WebTextEditor Documentation
OnContextMenuChanged Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnContextMenuChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnContextMenuChanged( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.EventArgs

instance.OnContextMenuChanged(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnContextMenuChanged(
   System.EventArgs e
)
Delphi
protected procedure OnContextMenuChanged(
    e: System.EventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnContextMenuChanged(
   e : System.EventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnContextMenuChanged(
   System.EventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnContextMenuChanged(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnContextMenuStripChanged Method

[image]
Intersoft WebTextEditor Documentation
OnContextMenuStripChanged Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnContextMenuStripChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnContextMenuStripChanged( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.EventArgs

instance.OnContextMenuStripChanged(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnContextMenuStripChanged(
   System.EventArgs e
)
Delphi
protected procedure OnContextMenuStripChanged(
    e: System.EventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnContextMenuStripChanged(
   e : System.EventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnContextMenuStripChanged(
   System.EventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnContextMenuStripChanged(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnControlAdded Method

[image]
Intersoft WebTextEditor Documentation
OnControlAdded Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnControlAdded Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnControlAdded( _
   ByVal e As System.Windows.Forms.ControlEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.Windows.Forms.ControlEventArgs

instance.OnControlAdded(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnControlAdded(
   System.Windows.Forms.ControlEventArgs e
)
Delphi
protected procedure OnControlAdded(
    e: System.Windows.Forms.ControlEventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnControlAdded(
   e : System.Windows.Forms.ControlEventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnControlAdded(
   System.Windows.Forms.ControlEventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnControlAdded(
   System.Windows.Forms.ControlEventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnControlRemoved Method

[image]
Intersoft WebTextEditor Documentation
OnControlRemoved Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnControlRemoved Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnControlRemoved( _
   ByVal e As System.Windows.Forms.ControlEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.Windows.Forms.ControlEventArgs

instance.OnControlRemoved(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnControlRemoved(
   System.Windows.Forms.ControlEventArgs e
)
Delphi
protected procedure OnControlRemoved(
    e: System.Windows.Forms.ControlEventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnControlRemoved(
   e : System.Windows.Forms.ControlEventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnControlRemoved(
   System.Windows.Forms.ControlEventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnControlRemoved(
   System.Windows.Forms.ControlEventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnCreateControl Method

[image]
Intersoft WebTextEditor Documentation
OnCreateControl Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnCreateControl Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnCreateControl()
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm

instance.OnCreateControl()
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnCreateControl()
Delphi
protected procedure OnCreateControl(); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnCreateControl();
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnCreateControl();
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnCreateControl();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnCursorChanged Method

[image]
Intersoft WebTextEditor Documentation
OnCursorChanged Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnCursorChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnCursorChanged( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.EventArgs

instance.OnCursorChanged(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnCursorChanged(
   System.EventArgs e
)
Delphi
protected procedure OnCursorChanged(
    e: System.EventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnCursorChanged(
   e : System.EventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnCursorChanged(
   System.EventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnCursorChanged(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnDeactivate Method

[image]
Intersoft WebTextEditor Documentation
OnDeactivate Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnDeactivate Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnDeactivate( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.EventArgs

instance.OnDeactivate(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnDeactivate(
   System.EventArgs e
)
Delphi
protected procedure OnDeactivate(
    e: System.EventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnDeactivate(
   e : System.EventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnDeactivate(
   System.EventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnDeactivate(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnDockChanged Method

[image]
Intersoft WebTextEditor Documentation
OnDockChanged Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnDockChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnDockChanged( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.EventArgs

instance.OnDockChanged(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnDockChanged(
   System.EventArgs e
)
Delphi
protected procedure OnDockChanged(
    e: System.EventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnDockChanged(
   e : System.EventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnDockChanged(
   System.EventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnDockChanged(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnDoubleClick Method

[image]
Intersoft WebTextEditor Documentation
OnDoubleClick Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnDoubleClick Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnDoubleClick( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.EventArgs

instance.OnDoubleClick(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnDoubleClick(
   System.EventArgs e
)
Delphi
protected procedure OnDoubleClick(
    e: System.EventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnDoubleClick(
   e : System.EventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnDoubleClick(
   System.EventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnDoubleClick(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnDragDrop Method

[image]
Intersoft WebTextEditor Documentation
OnDragDrop Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnDragDrop Method

drgevent

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnDragDrop( _
   ByVal drgevent As System.Windows.Forms.DragEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim drgevent As System.Windows.Forms.DragEventArgs

instance.OnDragDrop(drgevent)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnDragDrop(
   System.Windows.Forms.DragEventArgs drgevent
)
Delphi
protected procedure OnDragDrop(
    drgevent: System.Windows.Forms.DragEventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnDragDrop(
   drgevent : System.Windows.Forms.DragEventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnDragDrop(
   System.Windows.Forms.DragEventArgs* drgevent
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnDragDrop(
   System.Windows.Forms.DragEventArgs^ drgevent
)

Parameters

drgevent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnDragEnter Method

[image]
Intersoft WebTextEditor Documentation
OnDragEnter Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnDragEnter Method

drgevent

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnDragEnter( _
   ByVal drgevent As System.Windows.Forms.DragEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim drgevent As System.Windows.Forms.DragEventArgs

instance.OnDragEnter(drgevent)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnDragEnter(
   System.Windows.Forms.DragEventArgs drgevent
)
Delphi
protected procedure OnDragEnter(
    drgevent: System.Windows.Forms.DragEventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnDragEnter(
   drgevent : System.Windows.Forms.DragEventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnDragEnter(
   System.Windows.Forms.DragEventArgs* drgevent
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnDragEnter(
   System.Windows.Forms.DragEventArgs^ drgevent
)

Parameters

drgevent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnDragLeave Method

[image]
Intersoft WebTextEditor Documentation
OnDragLeave Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnDragLeave Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnDragLeave( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.EventArgs

instance.OnDragLeave(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnDragLeave(
   System.EventArgs e
)
Delphi
protected procedure OnDragLeave(
    e: System.EventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnDragLeave(
   e : System.EventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnDragLeave(
   System.EventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnDragLeave(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnDragOver Method

[image]
Intersoft WebTextEditor Documentation
OnDragOver Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnDragOver Method

drgevent

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnDragOver( _
   ByVal drgevent As System.Windows.Forms.DragEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim drgevent As System.Windows.Forms.DragEventArgs

instance.OnDragOver(drgevent)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnDragOver(
   System.Windows.Forms.DragEventArgs drgevent
)
Delphi
protected procedure OnDragOver(
    drgevent: System.Windows.Forms.DragEventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnDragOver(
   drgevent : System.Windows.Forms.DragEventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnDragOver(
   System.Windows.Forms.DragEventArgs* drgevent
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnDragOver(
   System.Windows.Forms.DragEventArgs^ drgevent
)

Parameters

drgevent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnEnabledChanged Method

[image]
Intersoft WebTextEditor Documentation
OnEnabledChanged Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnEnabledChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnEnabledChanged( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.EventArgs

instance.OnEnabledChanged(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnEnabledChanged(
   System.EventArgs e
)
Delphi
protected procedure OnEnabledChanged(
    e: System.EventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnEnabledChanged(
   e : System.EventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnEnabledChanged(
   System.EventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnEnabledChanged(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnEnter Method

[image]
Intersoft WebTextEditor Documentation
OnEnter Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnEnter Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnEnter( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.EventArgs

instance.OnEnter(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnEnter(
   System.EventArgs e
)
Delphi
protected procedure OnEnter(
    e: System.EventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnEnter(
   e : System.EventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnEnter(
   System.EventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnEnter(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnFontChanged Method

[image]
Intersoft WebTextEditor Documentation
OnFontChanged Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnFontChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnFontChanged( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.EventArgs

instance.OnFontChanged(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnFontChanged(
   System.EventArgs e
)
Delphi
protected procedure OnFontChanged(
    e: System.EventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnFontChanged(
   e : System.EventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnFontChanged(
   System.EventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnFontChanged(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnForeColorChanged Method

[image]
Intersoft WebTextEditor Documentation
OnForeColorChanged Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnForeColorChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnForeColorChanged( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.EventArgs

instance.OnForeColorChanged(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnForeColorChanged(
   System.EventArgs e
)
Delphi
protected procedure OnForeColorChanged(
    e: System.EventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnForeColorChanged(
   e : System.EventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnForeColorChanged(
   System.EventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnForeColorChanged(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnFormClosed Method

[image]
Intersoft WebTextEditor Documentation
OnFormClosed Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnFormClosed Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnFormClosed( _
   ByVal e As System.Windows.Forms.FormClosedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.Windows.Forms.FormClosedEventArgs

instance.OnFormClosed(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnFormClosed(
   System.Windows.Forms.FormClosedEventArgs e
)
Delphi
protected procedure OnFormClosed(
    e: System.Windows.Forms.FormClosedEventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnFormClosed(
   e : System.Windows.Forms.FormClosedEventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnFormClosed(
   System.Windows.Forms.FormClosedEventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnFormClosed(
   System.Windows.Forms.FormClosedEventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnFormClosing Method

[image]
Intersoft WebTextEditor Documentation
OnFormClosing Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnFormClosing Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnFormClosing( _
   ByVal e As System.Windows.Forms.FormClosingEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.Windows.Forms.FormClosingEventArgs

instance.OnFormClosing(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnFormClosing(
   System.Windows.Forms.FormClosingEventArgs e
)
Delphi
protected procedure OnFormClosing(
    e: System.Windows.Forms.FormClosingEventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnFormClosing(
   e : System.Windows.Forms.FormClosingEventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnFormClosing(
   System.Windows.Forms.FormClosingEventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnFormClosing(
   System.Windows.Forms.FormClosingEventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnGiveFeedback Method

[image]
Intersoft WebTextEditor Documentation
OnGiveFeedback Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnGiveFeedback Method

gfbevent

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnGiveFeedback( _
   ByVal gfbevent As System.Windows.Forms.GiveFeedbackEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim gfbevent As System.Windows.Forms.GiveFeedbackEventArgs

instance.OnGiveFeedback(gfbevent)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnGiveFeedback(
   System.Windows.Forms.GiveFeedbackEventArgs gfbevent
)
Delphi
protected procedure OnGiveFeedback(
    gfbevent: System.Windows.Forms.GiveFeedbackEventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnGiveFeedback(
   gfbevent : System.Windows.Forms.GiveFeedbackEventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnGiveFeedback(
   System.Windows.Forms.GiveFeedbackEventArgs* gfbevent
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnGiveFeedback(
   System.Windows.Forms.GiveFeedbackEventArgs^ gfbevent
)

Parameters

gfbevent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnGotFocus Method

[image]
Intersoft WebTextEditor Documentation
OnGotFocus Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnGotFocus Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnGotFocus( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.EventArgs

instance.OnGotFocus(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnGotFocus(
   System.EventArgs e
)
Delphi
protected procedure OnGotFocus(
    e: System.EventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnGotFocus(
   e : System.EventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnGotFocus(
   System.EventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnGotFocus(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnHandleCreated Method

[image]
Intersoft WebTextEditor Documentation
OnHandleCreated Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnHandleCreated Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnHandleCreated( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.EventArgs

instance.OnHandleCreated(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnHandleCreated(
   System.EventArgs e
)
Delphi
protected procedure OnHandleCreated(
    e: System.EventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnHandleCreated(
   e : System.EventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnHandleCreated(
   System.EventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnHandleCreated(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnHandleDestroyed Method

[image]
Intersoft WebTextEditor Documentation
OnHandleDestroyed Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnHandleDestroyed Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnHandleDestroyed( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.EventArgs

instance.OnHandleDestroyed(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnHandleDestroyed(
   System.EventArgs e
)
Delphi
protected procedure OnHandleDestroyed(
    e: System.EventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnHandleDestroyed(
   e : System.EventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnHandleDestroyed(
   System.EventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnHandleDestroyed(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnHelpButtonClicked Method

[image]
Intersoft WebTextEditor Documentation
OnHelpButtonClicked Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnHelpButtonClicked Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnHelpButtonClicked( _
   ByVal e As System.ComponentModel.CancelEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.ComponentModel.CancelEventArgs

instance.OnHelpButtonClicked(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnHelpButtonClicked(
   System.ComponentModel.CancelEventArgs e
)
Delphi
protected procedure OnHelpButtonClicked(
    e: System.ComponentModel.CancelEventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnHelpButtonClicked(
   e : System.ComponentModel.CancelEventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnHelpButtonClicked(
   System.ComponentModel.CancelEventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnHelpButtonClicked(
   System.ComponentModel.CancelEventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnHelpRequested Method

[image]
Intersoft WebTextEditor Documentation
OnHelpRequested Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnHelpRequested Method

hevent

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnHelpRequested( _
   ByVal hevent As System.Windows.Forms.HelpEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim hevent As System.Windows.Forms.HelpEventArgs

instance.OnHelpRequested(hevent)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnHelpRequested(
   System.Windows.Forms.HelpEventArgs hevent
)
Delphi
protected procedure OnHelpRequested(
    hevent: System.Windows.Forms.HelpEventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnHelpRequested(
   hevent : System.Windows.Forms.HelpEventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnHelpRequested(
   System.Windows.Forms.HelpEventArgs* hevent
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnHelpRequested(
   System.Windows.Forms.HelpEventArgs^ hevent
)

Parameters

hevent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnImeModeChanged Method

[image]
Intersoft WebTextEditor Documentation
OnImeModeChanged Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnImeModeChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnImeModeChanged( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.EventArgs

instance.OnImeModeChanged(e)
C#
protected virtual void OnImeModeChanged(
   System.EventArgs e
)
Delphi
protected procedure OnImeModeChanged(
    e: System.EventArgs
); virtual;
JScript
protected function OnImeModeChanged(
   e : System.EventArgs
);
Managed Extensions for C++
protected: virtual void OnImeModeChanged(
   System.EventArgs* e
)
C++/CLI
protected:
virtual void OnImeModeChanged(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnInputLanguageChanged Method

[image]
Intersoft WebTextEditor Documentation
OnInputLanguageChanged Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnInputLanguageChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnInputLanguageChanged( _
   ByVal e As System.Windows.Forms.InputLanguageChangedEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.Windows.Forms.InputLanguageChangedEventArgs

instance.OnInputLanguageChanged(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnInputLanguageChanged(
   System.Windows.Forms.InputLanguageChangedEventArgs e
)
Delphi
protected procedure OnInputLanguageChanged(
    e: System.Windows.Forms.InputLanguageChangedEventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnInputLanguageChanged(
   e : System.Windows.Forms.InputLanguageChangedEventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnInputLanguageChanged(
   System.Windows.Forms.InputLanguageChangedEventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnInputLanguageChanged(
   System.Windows.Forms.InputLanguageChangedEventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnInputLanguageChanging Method

[image]
Intersoft WebTextEditor Documentation
OnInputLanguageChanging Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnInputLanguageChanging Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnInputLanguageChanging( _
   ByVal e As System.Windows.Forms.InputLanguageChangingEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.Windows.Forms.InputLanguageChangingEventArgs

instance.OnInputLanguageChanging(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnInputLanguageChanging(
   System.Windows.Forms.InputLanguageChangingEventArgs e
)
Delphi
protected procedure OnInputLanguageChanging(
    e: System.Windows.Forms.InputLanguageChangingEventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnInputLanguageChanging(
   e : System.Windows.Forms.InputLanguageChangingEventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnInputLanguageChanging(
   System.Windows.Forms.InputLanguageChangingEventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnInputLanguageChanging(
   System.Windows.Forms.InputLanguageChangingEventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnInvalidated Method

[image]
Intersoft WebTextEditor Documentation
OnInvalidated Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnInvalidated Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnInvalidated( _
   ByVal e As System.Windows.Forms.InvalidateEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.Windows.Forms.InvalidateEventArgs

instance.OnInvalidated(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnInvalidated(
   System.Windows.Forms.InvalidateEventArgs e
)
Delphi
protected procedure OnInvalidated(
    e: System.Windows.Forms.InvalidateEventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnInvalidated(
   e : System.Windows.Forms.InvalidateEventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnInvalidated(
   System.Windows.Forms.InvalidateEventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnInvalidated(
   System.Windows.Forms.InvalidateEventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnKeyDown Method

[image]
Intersoft WebTextEditor Documentation
OnKeyDown Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnKeyDown Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnKeyDown( _
   ByVal e As System.Windows.Forms.KeyEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.Windows.Forms.KeyEventArgs

instance.OnKeyDown(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnKeyDown(
   System.Windows.Forms.KeyEventArgs e
)
Delphi
protected procedure OnKeyDown(
    e: System.Windows.Forms.KeyEventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnKeyDown(
   e : System.Windows.Forms.KeyEventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnKeyDown(
   System.Windows.Forms.KeyEventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnKeyDown(
   System.Windows.Forms.KeyEventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnKeyPress Method

[image]
Intersoft WebTextEditor Documentation
OnKeyPress Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnKeyPress Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnKeyPress( _
   ByVal e As System.Windows.Forms.KeyPressEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.Windows.Forms.KeyPressEventArgs

instance.OnKeyPress(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnKeyPress(
   System.Windows.Forms.KeyPressEventArgs e
)
Delphi
protected procedure OnKeyPress(
    e: System.Windows.Forms.KeyPressEventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnKeyPress(
   e : System.Windows.Forms.KeyPressEventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnKeyPress(
   System.Windows.Forms.KeyPressEventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnKeyPress(
   System.Windows.Forms.KeyPressEventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnKeyUp Method

[image]
Intersoft WebTextEditor Documentation
OnKeyUp Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnKeyUp Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnKeyUp( _
   ByVal e As System.Windows.Forms.KeyEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.Windows.Forms.KeyEventArgs

instance.OnKeyUp(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnKeyUp(
   System.Windows.Forms.KeyEventArgs e
)
Delphi
protected procedure OnKeyUp(
    e: System.Windows.Forms.KeyEventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnKeyUp(
   e : System.Windows.Forms.KeyEventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnKeyUp(
   System.Windows.Forms.KeyEventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnKeyUp(
   System.Windows.Forms.KeyEventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnLayout Method

[image]
Intersoft WebTextEditor Documentation
OnLayout Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnLayout Method

levent

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnLayout( _
   ByVal levent As System.Windows.Forms.LayoutEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim levent As System.Windows.Forms.LayoutEventArgs

instance.OnLayout(levent)
C#
protected virtual void OnLayout(
   System.Windows.Forms.LayoutEventArgs levent
)
Delphi
protected procedure OnLayout(
    levent: System.Windows.Forms.LayoutEventArgs
); virtual;
JScript
protected function OnLayout(
   levent : System.Windows.Forms.LayoutEventArgs
);
Managed Extensions for C++
protected: virtual void OnLayout(
   System.Windows.Forms.LayoutEventArgs* levent
)
C++/CLI
protected:
virtual void OnLayout(
   System.Windows.Forms.LayoutEventArgs^ levent
)

Parameters

levent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnLeave Method

[image]
Intersoft WebTextEditor Documentation
OnLeave Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnLeave Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnLeave( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.EventArgs

instance.OnLeave(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnLeave(
   System.EventArgs e
)
Delphi
protected procedure OnLeave(
    e: System.EventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnLeave(
   e : System.EventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnLeave(
   System.EventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnLeave(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnLoad Method

[image]
Intersoft WebTextEditor Documentation
OnLoad Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnLoad Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnLoad( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.EventArgs

instance.OnLoad(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnLoad(
   System.EventArgs e
)
Delphi
protected procedure OnLoad(
    e: System.EventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnLoad(
   e : System.EventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnLoad(
   System.EventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnLoad(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnLocationChanged Method

[image]
Intersoft WebTextEditor Documentation
OnLocationChanged Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnLocationChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnLocationChanged( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.EventArgs

instance.OnLocationChanged(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnLocationChanged(
   System.EventArgs e
)
Delphi
protected procedure OnLocationChanged(
    e: System.EventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnLocationChanged(
   e : System.EventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnLocationChanged(
   System.EventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnLocationChanged(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnLostFocus Method

[image]
Intersoft WebTextEditor Documentation
OnLostFocus Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnLostFocus Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnLostFocus( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.EventArgs

instance.OnLostFocus(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnLostFocus(
   System.EventArgs e
)
Delphi
protected procedure OnLostFocus(
    e: System.EventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnLostFocus(
   e : System.EventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnLostFocus(
   System.EventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnLostFocus(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnMarginChanged Method

[image]
Intersoft WebTextEditor Documentation
OnMarginChanged Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnMarginChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnMarginChanged( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.EventArgs

instance.OnMarginChanged(e)
C#
protected virtual void OnMarginChanged(
   System.EventArgs e
)
Delphi
protected procedure OnMarginChanged(
    e: System.EventArgs
); virtual;
JScript
protected function OnMarginChanged(
   e : System.EventArgs
);
Managed Extensions for C++
protected: virtual void OnMarginChanged(
   System.EventArgs* e
)
C++/CLI
protected:
virtual void OnMarginChanged(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnMaximizedBoundsChanged Method

[image]
Intersoft WebTextEditor Documentation
OnMaximizedBoundsChanged Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnMaximizedBoundsChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnMaximizedBoundsChanged( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.EventArgs

instance.OnMaximizedBoundsChanged(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnMaximizedBoundsChanged(
   System.EventArgs e
)
Delphi
protected procedure OnMaximizedBoundsChanged(
    e: System.EventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnMaximizedBoundsChanged(
   e : System.EventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnMaximizedBoundsChanged(
   System.EventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnMaximizedBoundsChanged(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnMaximumSizeChanged Method

[image]
Intersoft WebTextEditor Documentation
OnMaximumSizeChanged Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnMaximumSizeChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnMaximumSizeChanged( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.EventArgs

instance.OnMaximumSizeChanged(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnMaximumSizeChanged(
   System.EventArgs e
)
Delphi
protected procedure OnMaximumSizeChanged(
    e: System.EventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnMaximumSizeChanged(
   e : System.EventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnMaximumSizeChanged(
   System.EventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnMaximumSizeChanged(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnMdiChildActivate Method

[image]
Intersoft WebTextEditor Documentation
OnMdiChildActivate Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnMdiChildActivate Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnMdiChildActivate( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.EventArgs

instance.OnMdiChildActivate(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnMdiChildActivate(
   System.EventArgs e
)
Delphi
protected procedure OnMdiChildActivate(
    e: System.EventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnMdiChildActivate(
   e : System.EventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnMdiChildActivate(
   System.EventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnMdiChildActivate(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnMenuComplete Method

[image]
Intersoft WebTextEditor Documentation
OnMenuComplete Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnMenuComplete Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnMenuComplete( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.EventArgs

instance.OnMenuComplete(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnMenuComplete(
   System.EventArgs e
)
Delphi
protected procedure OnMenuComplete(
    e: System.EventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnMenuComplete(
   e : System.EventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnMenuComplete(
   System.EventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnMenuComplete(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnMenuStart Method

[image]
Intersoft WebTextEditor Documentation
OnMenuStart Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnMenuStart Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnMenuStart( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.EventArgs

instance.OnMenuStart(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnMenuStart(
   System.EventArgs e
)
Delphi
protected procedure OnMenuStart(
    e: System.EventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnMenuStart(
   e : System.EventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnMenuStart(
   System.EventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnMenuStart(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnMinimumSizeChanged Method

[image]
Intersoft WebTextEditor Documentation
OnMinimumSizeChanged Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnMinimumSizeChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnMinimumSizeChanged( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.EventArgs

instance.OnMinimumSizeChanged(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnMinimumSizeChanged(
   System.EventArgs e
)
Delphi
protected procedure OnMinimumSizeChanged(
    e: System.EventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnMinimumSizeChanged(
   e : System.EventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnMinimumSizeChanged(
   System.EventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnMinimumSizeChanged(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnMouseCaptureChanged Method

[image]
Intersoft WebTextEditor Documentation
OnMouseCaptureChanged Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnMouseCaptureChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnMouseCaptureChanged( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.EventArgs

instance.OnMouseCaptureChanged(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnMouseCaptureChanged(
   System.EventArgs e
)
Delphi
protected procedure OnMouseCaptureChanged(
    e: System.EventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnMouseCaptureChanged(
   e : System.EventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnMouseCaptureChanged(
   System.EventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnMouseCaptureChanged(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnMouseClick Method

[image]
Intersoft WebTextEditor Documentation
OnMouseClick Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnMouseClick Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnMouseClick( _
   ByVal e As System.Windows.Forms.MouseEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.Windows.Forms.MouseEventArgs

instance.OnMouseClick(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnMouseClick(
   System.Windows.Forms.MouseEventArgs e
)
Delphi
protected procedure OnMouseClick(
    e: System.Windows.Forms.MouseEventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnMouseClick(
   e : System.Windows.Forms.MouseEventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnMouseClick(
   System.Windows.Forms.MouseEventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnMouseClick(
   System.Windows.Forms.MouseEventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnMouseDoubleClick Method

[image]
Intersoft WebTextEditor Documentation
OnMouseDoubleClick Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnMouseDoubleClick Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnMouseDoubleClick( _
   ByVal e As System.Windows.Forms.MouseEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.Windows.Forms.MouseEventArgs

instance.OnMouseDoubleClick(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnMouseDoubleClick(
   System.Windows.Forms.MouseEventArgs e
)
Delphi
protected procedure OnMouseDoubleClick(
    e: System.Windows.Forms.MouseEventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnMouseDoubleClick(
   e : System.Windows.Forms.MouseEventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnMouseDoubleClick(
   System.Windows.Forms.MouseEventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnMouseDoubleClick(
   System.Windows.Forms.MouseEventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnMouseDown Method

[image]
Intersoft WebTextEditor Documentation
OnMouseDown Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnMouseDown Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnMouseDown( _
   ByVal e As System.Windows.Forms.MouseEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.Windows.Forms.MouseEventArgs

instance.OnMouseDown(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnMouseDown(
   System.Windows.Forms.MouseEventArgs e
)
Delphi
protected procedure OnMouseDown(
    e: System.Windows.Forms.MouseEventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnMouseDown(
   e : System.Windows.Forms.MouseEventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnMouseDown(
   System.Windows.Forms.MouseEventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnMouseDown(
   System.Windows.Forms.MouseEventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnMouseEnter Method

[image]
Intersoft WebTextEditor Documentation
OnMouseEnter Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnMouseEnter Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnMouseEnter( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.EventArgs

instance.OnMouseEnter(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnMouseEnter(
   System.EventArgs e
)
Delphi
protected procedure OnMouseEnter(
    e: System.EventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnMouseEnter(
   e : System.EventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnMouseEnter(
   System.EventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnMouseEnter(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnMouseHover Method

[image]
Intersoft WebTextEditor Documentation
OnMouseHover Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnMouseHover Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnMouseHover( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.EventArgs

instance.OnMouseHover(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnMouseHover(
   System.EventArgs e
)
Delphi
protected procedure OnMouseHover(
    e: System.EventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnMouseHover(
   e : System.EventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnMouseHover(
   System.EventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnMouseHover(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnMouseLeave Method

[image]
Intersoft WebTextEditor Documentation
OnMouseLeave Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnMouseLeave Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnMouseLeave( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.EventArgs

instance.OnMouseLeave(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnMouseLeave(
   System.EventArgs e
)
Delphi
protected procedure OnMouseLeave(
    e: System.EventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnMouseLeave(
   e : System.EventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnMouseLeave(
   System.EventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnMouseLeave(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnMouseMove Method

[image]
Intersoft WebTextEditor Documentation
OnMouseMove Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnMouseMove Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnMouseMove( _
   ByVal e As System.Windows.Forms.MouseEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.Windows.Forms.MouseEventArgs

instance.OnMouseMove(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnMouseMove(
   System.Windows.Forms.MouseEventArgs e
)
Delphi
protected procedure OnMouseMove(
    e: System.Windows.Forms.MouseEventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnMouseMove(
   e : System.Windows.Forms.MouseEventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnMouseMove(
   System.Windows.Forms.MouseEventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnMouseMove(
   System.Windows.Forms.MouseEventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnMouseUp Method

[image]
Intersoft WebTextEditor Documentation
OnMouseUp Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnMouseUp Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnMouseUp( _
   ByVal e As System.Windows.Forms.MouseEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.Windows.Forms.MouseEventArgs

instance.OnMouseUp(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnMouseUp(
   System.Windows.Forms.MouseEventArgs e
)
Delphi
protected procedure OnMouseUp(
    e: System.Windows.Forms.MouseEventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnMouseUp(
   e : System.Windows.Forms.MouseEventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnMouseUp(
   System.Windows.Forms.MouseEventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnMouseUp(
   System.Windows.Forms.MouseEventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnMouseWheel Method

[image]
Intersoft WebTextEditor Documentation
OnMouseWheel Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnMouseWheel Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnMouseWheel( _
   ByVal e As System.Windows.Forms.MouseEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.Windows.Forms.MouseEventArgs

instance.OnMouseWheel(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnMouseWheel(
   System.Windows.Forms.MouseEventArgs e
)
Delphi
protected procedure OnMouseWheel(
    e: System.Windows.Forms.MouseEventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnMouseWheel(
   e : System.Windows.Forms.MouseEventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnMouseWheel(
   System.Windows.Forms.MouseEventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnMouseWheel(
   System.Windows.Forms.MouseEventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnMove Method

[image]
Intersoft WebTextEditor Documentation
OnMove Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnMove Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnMove( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.EventArgs

instance.OnMove(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnMove(
   System.EventArgs e
)
Delphi
protected procedure OnMove(
    e: System.EventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnMove(
   e : System.EventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnMove(
   System.EventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnMove(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnNotifyMessage Method

[image]
Intersoft WebTextEditor Documentation
OnNotifyMessage Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnNotifyMessage Method

m

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnNotifyMessage( _
   ByVal m As System.Windows.Forms.Message _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim m As System.Windows.Forms.Message

instance.OnNotifyMessage(m)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnNotifyMessage(
   System.Windows.Forms.Message m
)
Delphi
protected procedure OnNotifyMessage(
    m: System.Windows.Forms.Message
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnNotifyMessage(
   m : System.Windows.Forms.Message
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnNotifyMessage(
   System.Windows.Forms.Message m
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnNotifyMessage(
   System.Windows.Forms.Message m
)

Parameters

m

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnPaddingChanged Method

[image]
Intersoft WebTextEditor Documentation
OnPaddingChanged Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnPaddingChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnPaddingChanged( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.EventArgs

instance.OnPaddingChanged(e)
C#
protected virtual void OnPaddingChanged(
   System.EventArgs e
)
Delphi
protected procedure OnPaddingChanged(
    e: System.EventArgs
); virtual;
JScript
protected function OnPaddingChanged(
   e : System.EventArgs
);
Managed Extensions for C++
protected: virtual void OnPaddingChanged(
   System.EventArgs* e
)
C++/CLI
protected:
virtual void OnPaddingChanged(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnPaint Method

[image]
Intersoft WebTextEditor Documentation
OnPaint Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnPaint Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnPaint( _
   ByVal e As System.Windows.Forms.PaintEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.Windows.Forms.PaintEventArgs

instance.OnPaint(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnPaint(
   System.Windows.Forms.PaintEventArgs e
)
Delphi
protected procedure OnPaint(
    e: System.Windows.Forms.PaintEventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnPaint(
   e : System.Windows.Forms.PaintEventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnPaint(
   System.Windows.Forms.PaintEventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnPaint(
   System.Windows.Forms.PaintEventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnPaintBackground Method

[image]
Intersoft WebTextEditor Documentation
OnPaintBackground Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnPaintBackground Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnPaintBackground( _
   ByVal e As System.Windows.Forms.PaintEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.Windows.Forms.PaintEventArgs

instance.OnPaintBackground(e)
C#
protected virtual void OnPaintBackground(
   System.Windows.Forms.PaintEventArgs e
)
Delphi
protected procedure OnPaintBackground(
    e: System.Windows.Forms.PaintEventArgs
); virtual;
JScript
protected function OnPaintBackground(
   e : System.Windows.Forms.PaintEventArgs
);
Managed Extensions for C++
protected: virtual void OnPaintBackground(
   System.Windows.Forms.PaintEventArgs* e
)
C++/CLI
protected:
virtual void OnPaintBackground(
   System.Windows.Forms.PaintEventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnParentBackColorChanged Method

[image]
Intersoft WebTextEditor Documentation
OnParentBackColorChanged Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnParentBackColorChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnParentBackColorChanged( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.EventArgs

instance.OnParentBackColorChanged(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnParentBackColorChanged(
   System.EventArgs e
)
Delphi
protected procedure OnParentBackColorChanged(
    e: System.EventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnParentBackColorChanged(
   e : System.EventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnParentBackColorChanged(
   System.EventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnParentBackColorChanged(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnParentBackgroundImageChanged Method

[image]
Intersoft WebTextEditor Documentation
OnParentBackgroundImageChanged Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnParentBackgroundImageChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnParentBackgroundImageChanged( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.EventArgs

instance.OnParentBackgroundImageChanged(e)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnParentBackgroundImageChanged(
   System.EventArgs e
)
Delphi
protected procedure OnParentBackgroundImageChanged(
    e: System.EventArgs
); virtual;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnParentBackgroundImageChanged(
   e : System.EventArgs
);
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnParentBackgroundImageChanged(
   System.EventArgs* e
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnParentBackgroundImageChanged(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnParentBindingContextChanged Method

[image]
Intersoft WebTextEditor Documentation
OnParentBindingContextChanged Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnParentBindingContextChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnParentBindingContextChanged( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.EventArgs

instance.OnParentBindingContextChanged(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnParentBindingContextChanged(
   System.EventArgs e
)
Delphi
protected procedure OnParentBindingContextChanged(
    e: System.EventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnParentBindingContextChanged(
   e : System.EventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnParentBindingContextChanged(
   System.EventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnParentBindingContextChanged(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnParentChanged Method

[image]
Intersoft WebTextEditor Documentation
OnParentChanged Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnParentChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnParentChanged( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.EventArgs

instance.OnParentChanged(e)
C#
protected virtual void OnParentChanged(
   System.EventArgs e
)
Delphi
protected procedure OnParentChanged(
    e: System.EventArgs
); virtual;
JScript
protected function OnParentChanged(
   e : System.EventArgs
);
Managed Extensions for C++
protected: virtual void OnParentChanged(
   System.EventArgs* e
)
C++/CLI
protected:
virtual void OnParentChanged(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnParentCursorChanged Method

[image]
Intersoft WebTextEditor Documentation
OnParentCursorChanged Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnParentCursorChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnParentCursorChanged( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.EventArgs

instance.OnParentCursorChanged(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnParentCursorChanged(
   System.EventArgs e
)
Delphi
protected procedure OnParentCursorChanged(
    e: System.EventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnParentCursorChanged(
   e : System.EventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnParentCursorChanged(
   System.EventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnParentCursorChanged(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnParentEnabledChanged Method

[image]
Intersoft WebTextEditor Documentation
OnParentEnabledChanged Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnParentEnabledChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnParentEnabledChanged( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.EventArgs

instance.OnParentEnabledChanged(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnParentEnabledChanged(
   System.EventArgs e
)
Delphi
protected procedure OnParentEnabledChanged(
    e: System.EventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnParentEnabledChanged(
   e : System.EventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnParentEnabledChanged(
   System.EventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnParentEnabledChanged(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnParentFontChanged Method

[image]
Intersoft WebTextEditor Documentation
OnParentFontChanged Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnParentFontChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnParentFontChanged( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.EventArgs

instance.OnParentFontChanged(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnParentFontChanged(
   System.EventArgs e
)
Delphi
protected procedure OnParentFontChanged(
    e: System.EventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnParentFontChanged(
   e : System.EventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnParentFontChanged(
   System.EventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnParentFontChanged(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnParentForeColorChanged Method

[image]
Intersoft WebTextEditor Documentation
OnParentForeColorChanged Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnParentForeColorChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnParentForeColorChanged( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.EventArgs

instance.OnParentForeColorChanged(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnParentForeColorChanged(
   System.EventArgs e
)
Delphi
protected procedure OnParentForeColorChanged(
    e: System.EventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnParentForeColorChanged(
   e : System.EventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnParentForeColorChanged(
   System.EventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnParentForeColorChanged(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnParentRightToLeftChanged Method

[image]
Intersoft WebTextEditor Documentation
OnParentRightToLeftChanged Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnParentRightToLeftChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnParentRightToLeftChanged( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.EventArgs

instance.OnParentRightToLeftChanged(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnParentRightToLeftChanged(
   System.EventArgs e
)
Delphi
protected procedure OnParentRightToLeftChanged(
    e: System.EventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnParentRightToLeftChanged(
   e : System.EventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnParentRightToLeftChanged(
   System.EventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnParentRightToLeftChanged(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnParentVisibleChanged Method

[image]
Intersoft WebTextEditor Documentation
OnParentVisibleChanged Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnParentVisibleChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnParentVisibleChanged( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.EventArgs

instance.OnParentVisibleChanged(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnParentVisibleChanged(
   System.EventArgs e
)
Delphi
protected procedure OnParentVisibleChanged(
    e: System.EventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnParentVisibleChanged(
   e : System.EventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnParentVisibleChanged(
   System.EventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnParentVisibleChanged(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnPreviewKeyDown Method

[image]
Intersoft WebTextEditor Documentation
OnPreviewKeyDown Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnPreviewKeyDown Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=False,
   UnmanagedCode=True,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=False,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand Or  _
    SecurityAction.Deny Or  _
    SecurityAction.LinkDemand,
   Unrestricted=False)>
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=False,
   UnmanagedCode=True,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=False,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand Or  _
    SecurityAction.Assert Or  _
    SecurityAction.Deny Or  _
    SecurityAction.PermitOnly Or  _
    SecurityAction.LinkDemand Or  _
    SecurityAction.InheritanceDemand,
   Unrestricted=False)>
Protected Overridable Sub OnPreviewKeyDown( _
   ByVal e As System.Windows.Forms.PreviewKeyDownEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.Windows.Forms.PreviewKeyDownEventArgs

instance.OnPreviewKeyDown(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
protected virtual void OnPreviewKeyDown(
   System.Windows.Forms.PreviewKeyDownEventArgs e
)
Delphi
protected procedure OnPreviewKeyDown(
    e: System.Windows.Forms.PreviewKeyDownEventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=)
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=)
protected function OnPreviewKeyDown(
   e : System.Windows.Forms.PreviewKeyDownEventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
protected: virtual void OnPreviewKeyDown(
   System.Windows.Forms.PreviewKeyDownEventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
protected:
virtual void OnPreviewKeyDown(
   System.Windows.Forms.PreviewKeyDownEventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnPrint Method

[image]
Intersoft WebTextEditor Documentation
OnPrint Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnPrint Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnPrint( _
   ByVal e As System.Windows.Forms.PaintEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.Windows.Forms.PaintEventArgs

instance.OnPrint(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnPrint(
   System.Windows.Forms.PaintEventArgs e
)
Delphi
protected procedure OnPrint(
    e: System.Windows.Forms.PaintEventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnPrint(
   e : System.Windows.Forms.PaintEventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnPrint(
   System.Windows.Forms.PaintEventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnPrint(
   System.Windows.Forms.PaintEventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnQueryContinueDrag Method

[image]
Intersoft WebTextEditor Documentation
OnQueryContinueDrag Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnQueryContinueDrag Method

qcdevent

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnQueryContinueDrag( _
   ByVal qcdevent As System.Windows.Forms.QueryContinueDragEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim qcdevent As System.Windows.Forms.QueryContinueDragEventArgs

instance.OnQueryContinueDrag(qcdevent)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnQueryContinueDrag(
   System.Windows.Forms.QueryContinueDragEventArgs qcdevent
)
Delphi
protected procedure OnQueryContinueDrag(
    qcdevent: System.Windows.Forms.QueryContinueDragEventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnQueryContinueDrag(
   qcdevent : System.Windows.Forms.QueryContinueDragEventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnQueryContinueDrag(
   System.Windows.Forms.QueryContinueDragEventArgs* qcdevent
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnQueryContinueDrag(
   System.Windows.Forms.QueryContinueDragEventArgs^ qcdevent
)

Parameters

qcdevent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnRegionChanged Method

[image]
Intersoft WebTextEditor Documentation
OnRegionChanged Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnRegionChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnRegionChanged( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.EventArgs

instance.OnRegionChanged(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnRegionChanged(
   System.EventArgs e
)
Delphi
protected procedure OnRegionChanged(
    e: System.EventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnRegionChanged(
   e : System.EventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnRegionChanged(
   System.EventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnRegionChanged(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnResize Method

[image]
Intersoft WebTextEditor Documentation
OnResize Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnResize Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnResize( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.EventArgs

instance.OnResize(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnResize(
   System.EventArgs e
)
Delphi
protected procedure OnResize(
    e: System.EventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnResize(
   e : System.EventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnResize(
   System.EventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnResize(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnResizeBegin Method

[image]
Intersoft WebTextEditor Documentation
OnResizeBegin Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnResizeBegin Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnResizeBegin( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.EventArgs

instance.OnResizeBegin(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnResizeBegin(
   System.EventArgs e
)
Delphi
protected procedure OnResizeBegin(
    e: System.EventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnResizeBegin(
   e : System.EventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnResizeBegin(
   System.EventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnResizeBegin(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnResizeEnd Method

[image]
Intersoft WebTextEditor Documentation
OnResizeEnd Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnResizeEnd Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnResizeEnd( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.EventArgs

instance.OnResizeEnd(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnResizeEnd(
   System.EventArgs e
)
Delphi
protected procedure OnResizeEnd(
    e: System.EventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnResizeEnd(
   e : System.EventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnResizeEnd(
   System.EventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnResizeEnd(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnRightToLeftChanged Method

[image]
Intersoft WebTextEditor Documentation
OnRightToLeftChanged Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnRightToLeftChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnRightToLeftChanged( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.EventArgs

instance.OnRightToLeftChanged(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnRightToLeftChanged(
   System.EventArgs e
)
Delphi
protected procedure OnRightToLeftChanged(
    e: System.EventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnRightToLeftChanged(
   e : System.EventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnRightToLeftChanged(
   System.EventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnRightToLeftChanged(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnRightToLeftLayoutChanged Method

[image]
Intersoft WebTextEditor Documentation
OnRightToLeftLayoutChanged Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnRightToLeftLayoutChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnRightToLeftLayoutChanged( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.EventArgs

instance.OnRightToLeftLayoutChanged(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnRightToLeftLayoutChanged(
   System.EventArgs e
)
Delphi
protected procedure OnRightToLeftLayoutChanged(
    e: System.EventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnRightToLeftLayoutChanged(
   e : System.EventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnRightToLeftLayoutChanged(
   System.EventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnRightToLeftLayoutChanged(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnScroll Method

[image]
Intersoft WebTextEditor Documentation
OnScroll Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnScroll Method

se

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnScroll( _
   ByVal se As System.Windows.Forms.ScrollEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim se As System.Windows.Forms.ScrollEventArgs

instance.OnScroll(se)
C#
protected virtual void OnScroll(
   System.Windows.Forms.ScrollEventArgs se
)
Delphi
protected procedure OnScroll(
    se: System.Windows.Forms.ScrollEventArgs
); virtual;
JScript
protected function OnScroll(
   se : System.Windows.Forms.ScrollEventArgs
);
Managed Extensions for C++
protected: virtual void OnScroll(
   System.Windows.Forms.ScrollEventArgs* se
)
C++/CLI
protected:
virtual void OnScroll(
   System.Windows.Forms.ScrollEventArgs^ se
)

Parameters

se

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnShown Method

[image]
Intersoft WebTextEditor Documentation
OnShown Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnShown Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnShown( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.EventArgs

instance.OnShown(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnShown(
   System.EventArgs e
)
Delphi
protected procedure OnShown(
    e: System.EventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnShown(
   e : System.EventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnShown(
   System.EventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnShown(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnSizeChanged Method

[image]
Intersoft WebTextEditor Documentation
OnSizeChanged Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnSizeChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnSizeChanged( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.EventArgs

instance.OnSizeChanged(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnSizeChanged(
   System.EventArgs e
)
Delphi
protected procedure OnSizeChanged(
    e: System.EventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnSizeChanged(
   e : System.EventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnSizeChanged(
   System.EventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnSizeChanged(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnStyleChanged Method

[image]
Intersoft WebTextEditor Documentation
OnStyleChanged Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnStyleChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnStyleChanged( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.EventArgs

instance.OnStyleChanged(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnStyleChanged(
   System.EventArgs e
)
Delphi
protected procedure OnStyleChanged(
    e: System.EventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnStyleChanged(
   e : System.EventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnStyleChanged(
   System.EventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnStyleChanged(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnSystemColorsChanged Method

[image]
Intersoft WebTextEditor Documentation
OnSystemColorsChanged Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnSystemColorsChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnSystemColorsChanged( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.EventArgs

instance.OnSystemColorsChanged(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnSystemColorsChanged(
   System.EventArgs e
)
Delphi
protected procedure OnSystemColorsChanged(
    e: System.EventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnSystemColorsChanged(
   e : System.EventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnSystemColorsChanged(
   System.EventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnSystemColorsChanged(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnTabIndexChanged Method

[image]
Intersoft WebTextEditor Documentation
OnTabIndexChanged Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnTabIndexChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnTabIndexChanged( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.EventArgs

instance.OnTabIndexChanged(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnTabIndexChanged(
   System.EventArgs e
)
Delphi
protected procedure OnTabIndexChanged(
    e: System.EventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnTabIndexChanged(
   e : System.EventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnTabIndexChanged(
   System.EventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnTabIndexChanged(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnTabStopChanged Method

[image]
Intersoft WebTextEditor Documentation
OnTabStopChanged Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnTabStopChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnTabStopChanged( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.EventArgs

instance.OnTabStopChanged(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnTabStopChanged(
   System.EventArgs e
)
Delphi
protected procedure OnTabStopChanged(
    e: System.EventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnTabStopChanged(
   e : System.EventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnTabStopChanged(
   System.EventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnTabStopChanged(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnTextChanged Method

[image]
Intersoft WebTextEditor Documentation
OnTextChanged Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnTextChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnTextChanged( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.EventArgs

instance.OnTextChanged(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnTextChanged(
   System.EventArgs e
)
Delphi
protected procedure OnTextChanged(
    e: System.EventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnTextChanged(
   e : System.EventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnTextChanged(
   System.EventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnTextChanged(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnValidated Method

[image]
Intersoft WebTextEditor Documentation
OnValidated Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnValidated Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnValidated( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.EventArgs

instance.OnValidated(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnValidated(
   System.EventArgs e
)
Delphi
protected procedure OnValidated(
    e: System.EventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnValidated(
   e : System.EventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnValidated(
   System.EventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnValidated(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnValidating Method

[image]
Intersoft WebTextEditor Documentation
OnValidating Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnValidating Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnValidating( _
   ByVal e As System.ComponentModel.CancelEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.ComponentModel.CancelEventArgs

instance.OnValidating(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnValidating(
   System.ComponentModel.CancelEventArgs e
)
Delphi
protected procedure OnValidating(
    e: System.ComponentModel.CancelEventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnValidating(
   e : System.ComponentModel.CancelEventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnValidating(
   System.ComponentModel.CancelEventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnValidating(
   System.ComponentModel.CancelEventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OnVisibleChanged Method

[image]
Intersoft WebTextEditor Documentation
OnVisibleChanged Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OnVisibleChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub OnVisibleChanged( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim e As System.EventArgs

instance.OnVisibleChanged(e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void OnVisibleChanged(
   System.EventArgs e
)
Delphi
protected procedure OnVisibleChanged(
    e: System.EventArgs
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function OnVisibleChanged(
   e : System.EventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void OnVisibleChanged(
   System.EventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void OnVisibleChanged(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


Opacity Property

[image]
Intersoft WebTextEditor Documentation
Opacity Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : Opacity Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Window Style")>
<System.ComponentModel.DefaultValueAttribute()>
<SRDescriptionAttribute("The opacity percentage of the control. ")>
<System.ComponentModel.TypeConverterAttribute("System.Windows.Forms.OpacityConverter, System.Windows.Forms, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
Public Property Opacity As System.Double
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Double

instance.Opacity = value

value = instance.Opacity
C#
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("The opacity percentage of the control. ")]
[System.ComponentModel.TypeConverterAttribute("System.Windows.Forms.OpacityConverter, System.Windows.Forms, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public System.double Opacity {get; set;}
Delphi
public read-write property Opacity: System.Double;
JScript
SRCategoryAttribute("Window Style")
System.ComponentModel.DefaultValueAttribute()
SRDescriptionAttribute("The opacity percentage of the control. ")
System.ComponentModel.TypeConverterAttribute("System.Windows.Forms.OpacityConverter, System.Windows.Forms, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
public function get,set Opacity : System.double
Managed Extensions for C++
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("The opacity percentage of the control. ")]
[System.ComponentModel.TypeConverterAttribute("System.Windows.Forms.OpacityConverter, System.Windows.Forms, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public: __property System.double get_Opacity();
public: __property void set_Opacity(
   System.double value
);
C++/CLI
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("The opacity percentage of the control. ")]
[System.ComponentModel.TypeConverterAttribute("System.Windows.Forms.OpacityConverter, System.Windows.Forms, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
public:
property System.double Opacity {
   System.double get();
   void set (    System.double value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


OwnedForms Property

[image]
Intersoft WebTextEditor Documentation
OwnedForms Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : OwnedForms Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<SRCategoryAttribute("Window Style")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<SRDescriptionAttribute("Array of forms owned by this form.")>
Public ReadOnly Property OwnedForms As System.Windows.Forms.Form()
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value() As System.Windows.Forms.Form

value = instance.OwnedForms
C#
[System.ComponentModel.BrowsableAttribute(false)]
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[SRDescriptionAttribute("Array of forms owned by this form.")]
public System.Windows.Forms.Form[] OwnedForms {get;}
Delphi
public read-only property OwnedForms: System.Windows.Forms.array of Form;
JScript
System.ComponentModel.BrowsableAttribute()
SRCategoryAttribute("Window Style")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
SRDescriptionAttribute("Array of forms owned by this form.")
public function get OwnedForms : System.Windows.Forms.Form[]
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[SRDescriptionAttribute("Array of forms owned by this form.")]
public: __property System.Windows.Forms.Form*[]* get_OwnedForms();
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[SRDescriptionAttribute("Array of forms owned by this form.")]
public:
property System.Windows.Forms.array<Form^>^ OwnedForms {
   System.Windows.Forms.array<Form^>^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


Owner Property

[image]
Intersoft WebTextEditor Documentation
Owner Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : Owner Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<SRCategoryAttribute("Window Style")>
<System.ComponentModel.BrowsableAttribute(False)>
<SRDescriptionAttribute("The owner of this form.")>
Public Property Owner As System.Windows.Forms.Form
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Windows.Forms.Form

instance.Owner = value

value = instance.Owner
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.BrowsableAttribute(false)]
[SRDescriptionAttribute("The owner of this form.")]
public System.Windows.Forms.Form Owner {get; set;}
Delphi
public read-write property Owner: System.Windows.Forms.Form;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
SRCategoryAttribute("Window Style")
System.ComponentModel.BrowsableAttribute()
SRDescriptionAttribute("The owner of this form.")
public function get,set Owner : System.Windows.Forms.Form
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.BrowsableAttribute(false)]
[SRDescriptionAttribute("The owner of this form.")]
public: __property System.Windows.Forms.Form* get_Owner();
public: __property void set_Owner(
   System.Windows.Forms.Form* value
);
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.BrowsableAttribute(false)]
[SRDescriptionAttribute("The owner of this form.")]
public:
property System.Windows.Forms.Form^ Owner {
   System.Windows.Forms.Form^ get();
   void set (    System.Windows.Forms.Form^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


Padding Property

[image]
Intersoft WebTextEditor Documentation
Padding Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : Padding Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Specifies the interior spacing of a control.")>
<System.ComponentModel.LocalizableAttribute(True)>
<SRCategoryAttribute("Layout")>
Public Property Padding As System.Windows.Forms.Padding
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Windows.Forms.Padding

instance.Padding = value

value = instance.Padding
C#
[SRDescriptionAttribute("Specifies the interior spacing of a control.")]
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Layout")]
public System.Windows.Forms.Padding Padding {get; set;}
Delphi
public read-write property Padding: System.Windows.Forms.Padding;
JScript
SRDescriptionAttribute("Specifies the interior spacing of a control.")
System.ComponentModel.LocalizableAttribute()
SRCategoryAttribute("Layout")
public function get,set Padding : System.Windows.Forms.Padding
Managed Extensions for C++
[SRDescriptionAttribute("Specifies the interior spacing of a control.")]
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Layout")]
public: __property System.Windows.Forms.Padding get_Padding();
public: __property void set_Padding(
   System.Windows.Forms.Padding value
);
C++/CLI
[SRDescriptionAttribute("Specifies the interior spacing of a control.")]
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Layout")]
public:
property System.Windows.Forms.Padding Padding {
   System.Windows.Forms.Padding get();
   void set (    System.Windows.Forms.Padding value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


PaddingChanged Event

[image]
Intersoft WebTextEditor Documentation
PaddingChanged Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : PaddingChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Layout")>
<SRDescriptionAttribute("Occurs when the Padding property has changed.")>
Public Event PaddingChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.EventHandler

AddHandler instance.PaddingChanged, handler
C#
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Occurs when the Padding property has changed.")]
public event System.EventHandler PaddingChanged
Delphi
public event PaddingChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Occurs when the Padding property has changed.")]
public: __event System.EventHandler* PaddingChanged
C++/CLI
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Occurs when the Padding property has changed.")]
public:
event System.EventHandler^ PaddingChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


Paint Event

[image]
Intersoft WebTextEditor Documentation
Paint Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : Paint Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when a control needs repainting.")>
<SRCategoryAttribute("Appearance")>
Public Event Paint As System.Windows.Forms.PaintEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.Windows.Forms.PaintEventHandler

AddHandler instance.Paint, handler
C#
[SRDescriptionAttribute("Occurs when a control needs repainting.")]
[SRCategoryAttribute("Appearance")]
public event System.Windows.Forms.PaintEventHandler Paint
Delphi
public event Paint: System.Windows.Forms.PaintEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when a control needs repainting.")]
[SRCategoryAttribute("Appearance")]
public: __event System.Windows.Forms.PaintEventHandler* Paint
C++/CLI
[SRDescriptionAttribute("Occurs when a control needs repainting.")]
[SRCategoryAttribute("Appearance")]
public:
event System.Windows.Forms.PaintEventHandler^ Paint

Event Data

The event handler receives an argument of type System.Windows.Forms.PaintEventArgs containing data related to this event. The following PaintEventArgs properties provide information specific to this event.

Property | Description
ClipRectangle | Gets the rectangle in which to paint.
Graphics | Gets the graphics used to paint.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


Parent Property

[image]
Intersoft WebTextEditor Documentation
Parent Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : Parent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The parent of this control.")>
<System.ComponentModel.BrowsableAttribute(False)>
<SRCategoryAttribute("Behavior")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property Parent As System.Windows.Forms.Control
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Windows.Forms.Control

instance.Parent = value

value = instance.Parent
C#
[SRDescriptionAttribute("The parent of this control.")]
[System.ComponentModel.BrowsableAttribute(false)]
[SRCategoryAttribute("Behavior")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public System.Windows.Forms.Control Parent {get; set;}
Delphi
public read-write property Parent: System.Windows.Forms.Control;
JScript
SRDescriptionAttribute("The parent of this control.")
System.ComponentModel.BrowsableAttribute()
SRCategoryAttribute("Behavior")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get,set Parent : System.Windows.Forms.Control
Managed Extensions for C++
[SRDescriptionAttribute("The parent of this control.")]
[System.ComponentModel.BrowsableAttribute(false)]
[SRCategoryAttribute("Behavior")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property System.Windows.Forms.Control* get_Parent();
public: __property void set_Parent(
   System.Windows.Forms.Control* value
);
C++/CLI
[SRDescriptionAttribute("The parent of this control.")]
[System.ComponentModel.BrowsableAttribute(false)]
[SRCategoryAttribute("Behavior")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property System.Windows.Forms.Control^ Parent {
   System.Windows.Forms.Control^ get();
   void set (    System.Windows.Forms.Control^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


ParentChanged Event

[image]
Intersoft WebTextEditor Documentation
ParentChanged Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : ParentChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Property Changed")>
<SRDescriptionAttribute("Event raised when the value of the Parent property is changed on Control.")>
Public Event ParentChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.EventHandler

AddHandler instance.ParentChanged, handler
C#
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the Parent property is changed on Control.")]
public event System.EventHandler ParentChanged
Delphi
public event ParentChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the Parent property is changed on Control.")]
public: __event System.EventHandler* ParentChanged
C++/CLI
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the Parent property is changed on Control.")]
public:
event System.EventHandler^ ParentChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


ParentForm Property

[image]
Intersoft WebTextEditor Documentation
ParentForm Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : ParentForm Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<SRCategoryAttribute("Appearance")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<SRDescriptionAttribute("The parent form of this container control.")>
Public ReadOnly Property ParentForm As System.Windows.Forms.Form
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Windows.Forms.Form

value = instance.ParentForm
C#
[System.ComponentModel.BrowsableAttribute(false)]
[SRCategoryAttribute("Appearance")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[SRDescriptionAttribute("The parent form of this container control.")]
public System.Windows.Forms.Form ParentForm {get;}
Delphi
public read-only property ParentForm: System.Windows.Forms.Form;
JScript
System.ComponentModel.BrowsableAttribute()
SRCategoryAttribute("Appearance")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
SRDescriptionAttribute("The parent form of this container control.")
public function get ParentForm : System.Windows.Forms.Form
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[SRCategoryAttribute("Appearance")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[SRDescriptionAttribute("The parent form of this container control.")]
public: __property System.Windows.Forms.Form* get_ParentForm();
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[SRCategoryAttribute("Appearance")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[SRDescriptionAttribute("The parent form of this container control.")]
public:
property System.Windows.Forms.Form^ ParentForm {
   System.Windows.Forms.Form^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


PerformAutoScale Method

[image]
Intersoft WebTextEditor Documentation
PerformAutoScale Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : PerformAutoScale Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Sub PerformAutoScale()
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm

instance.PerformAutoScale()
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void PerformAutoScale()
Delphi
public procedure PerformAutoScale();
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function PerformAutoScale();
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void PerformAutoScale();
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void PerformAutoScale();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


PerformLayout Method

[image]
Intersoft WebTextEditor Documentation
PerformLayout Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : PerformLayout Method

Glossary Item Box

Overload List

Overload | Description
PerformLayout() | (Inherited from System.Windows.Forms.Control)
PerformLayout(Control,String) | (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


PerformLayout() Method

[image]
Intersoft WebTextEditor Documentation
PerformLayout() Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class > PerformLayout Method : PerformLayout() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Overloads Sub PerformLayout()
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm

instance.PerformLayout()
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public void PerformLayout()
Delphi
public procedure PerformLayout();
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function PerformLayout();
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: void PerformLayout();
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
void PerformLayout();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members
Overload List


PerformLayout(Control,String) Method

[image]
Intersoft WebTextEditor Documentation
PerformLayout(Control,String) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class > PerformLayout Method : PerformLayout(Control,String) Method

affectedControl
affectedProperty

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Overloads Sub PerformLayout( _
   ByVal affectedControl As System.Windows.Forms.Control, _
   ByVal affectedProperty As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim affectedControl As System.Windows.Forms.Control
Dim affectedProperty As System.String

instance.PerformLayout(affectedControl, affectedProperty)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public void PerformLayout(
   System.Windows.Forms.Control affectedControl,
   System.string affectedProperty
)
Delphi
public procedure PerformLayout(
    affectedControl: System.Windows.Forms.Control;
    affectedProperty: System.String
);
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function PerformLayout(
   affectedControl : System.Windows.Forms.Control,
   affectedProperty : System.String
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: void PerformLayout(
   System.Windows.Forms.Control* affectedControl,
   System.string* affectedProperty
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
void PerformLayout(
   System.Windows.Forms.Control^ affectedControl,
   System.String^ affectedProperty
)

Parameters

affectedControl
affectedProperty

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members
Overload List


PointToClient Method

[image]
Intersoft WebTextEditor Documentation
PointToClient Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : PointToClient Method

p

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Function PointToClient( _
   ByVal p As System.Drawing.Point _
) As System.Drawing.Point
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim p As System.Drawing.Point
Dim value As System.Drawing.Point

value = instance.PointToClient(p)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.Drawing.Point PointToClient(
   System.Drawing.Point p
)
Delphi
public function PointToClient(
    p: System.Drawing.Point
): System.Drawing.Point;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function PointToClient(
   p : System.Drawing.Point
) : System.Drawing.Point;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.Drawing.Point PointToClient(
   System.Drawing.Point p
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.Drawing.Point PointToClient(
   System.Drawing.Point p
)

Parameters

p

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


PointToScreen Method

[image]
Intersoft WebTextEditor Documentation
PointToScreen Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : PointToScreen Method

p

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function PointToScreen( _
   ByVal p As System.Drawing.Point _
) As System.Drawing.Point
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim p As System.Drawing.Point
Dim value As System.Drawing.Point

value = instance.PointToScreen(p)
C#
public System.Drawing.Point PointToScreen(
   System.Drawing.Point p
)
Delphi
public function PointToScreen(
    p: System.Drawing.Point
): System.Drawing.Point;
JScript
public function PointToScreen(
   p : System.Drawing.Point
) : System.Drawing.Point;
Managed Extensions for C++
public: System.Drawing.Point PointToScreen(
   System.Drawing.Point p
)
C++/CLI
public:
System.Drawing.Point PointToScreen(
   System.Drawing.Point p
)

Parameters

p

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


PreferredSize Property

[image]
Intersoft WebTextEditor Documentation
PreferredSize Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : PreferredSize Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
Public ReadOnly Property PreferredSize As System.Drawing.Size
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Drawing.Size

value = instance.PreferredSize
C#
[System.ComponentModel.BrowsableAttribute(false)]
public System.Drawing.Size PreferredSize {get;}
Delphi
public read-only property PreferredSize: System.Drawing.Size;
JScript
System.ComponentModel.BrowsableAttribute()
public function get PreferredSize : System.Drawing.Size
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
public: __property System.Drawing.Size get_PreferredSize();
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
public:
property System.Drawing.Size PreferredSize {
   System.Drawing.Size get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


PreProcessControlMessage Method

[image]
Intersoft WebTextEditor Documentation
PreProcessControlMessage Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : PreProcessControlMessage Method

msg

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=False,
   UnmanagedCode=True,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=False,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand Or  _
    SecurityAction.Deny Or  _
    SecurityAction.LinkDemand,
   Unrestricted=False)>
Public Function PreProcessControlMessage( _
   ByRef msg As System.Windows.Forms.Message _
) As System.Windows.Forms.PreProcessControlState
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim msg As System.Windows.Forms.Message
Dim value As System.Windows.Forms.PreProcessControlState

value = instance.PreProcessControlMessage(msg)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
public System.Windows.Forms.PreProcessControlState PreProcessControlMessage(
   ref System.Windows.Forms.Message msg
)
Delphi
public function PreProcessControlMessage(
   var  msg: System.Windows.Forms.Message
): System.Windows.Forms.PreProcessControlState;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=)
public function PreProcessControlMessage(
   msg : System.Windows.Forms.Message
) : System.Windows.Forms.PreProcessControlState;
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
public: System.Windows.Forms.PreProcessControlState PreProcessControlMessage(
   ref System.Windows.Forms.Message msg
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
public:
System.Windows.Forms.PreProcessControlState PreProcessControlMessage(
   System.Windows.Forms.Message% msg
)

Parameters

msg

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


PreProcessMessage Method

[image]
Intersoft WebTextEditor Documentation
PreProcessMessage Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : PreProcessMessage Method

msg

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=False,
   UnmanagedCode=True,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=False,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand Or  _
    SecurityAction.Deny Or  _
    SecurityAction.LinkDemand,
   Unrestricted=False)>
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=False,
   UnmanagedCode=True,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=False,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand Or  _
    SecurityAction.Assert Or  _
    SecurityAction.Deny Or  _
    SecurityAction.PermitOnly Or  _
    SecurityAction.LinkDemand Or  _
    SecurityAction.InheritanceDemand,
   Unrestricted=False)>
Public Overridable Function PreProcessMessage( _
   ByRef msg As System.Windows.Forms.Message _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim msg As System.Windows.Forms.Message
Dim value As System.Boolean

value = instance.PreProcessMessage(msg)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public virtual System.bool PreProcessMessage(
   ref System.Windows.Forms.Message msg
)
Delphi
public function PreProcessMessage(
   var  msg: System.Windows.Forms.Message
): System.Boolean; virtual;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=)
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=)
public function PreProcessMessage(
   msg : System.Windows.Forms.Message
) : System.boolean;
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public: virtual System.bool PreProcessMessage(
   ref System.Windows.Forms.Message msg
)
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
public:
virtual System.bool PreProcessMessage(
   System.Windows.Forms.Message% msg
)

Parameters

msg

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


PreviewKeyDown Event

[image]
Intersoft WebTextEditor Documentation
PreviewKeyDown Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : PreviewKeyDown Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Key")>
<SRDescriptionAttribute("Occurs before the KeyDown event when a key is pressed while focus is on this control.")>
Public Event PreviewKeyDown As System.Windows.Forms.PreviewKeyDownEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.Windows.Forms.PreviewKeyDownEventHandler

AddHandler instance.PreviewKeyDown, handler
C#
[SRCategoryAttribute("Key")]
[SRDescriptionAttribute("Occurs before the KeyDown event when a key is pressed while focus is on this control.")]
public event System.Windows.Forms.PreviewKeyDownEventHandler PreviewKeyDown
Delphi
public event PreviewKeyDown: System.Windows.Forms.PreviewKeyDownEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Key")]
[SRDescriptionAttribute("Occurs before the KeyDown event when a key is pressed while focus is on this control.")]
public: __event System.Windows.Forms.PreviewKeyDownEventHandler* PreviewKeyDown
C++/CLI
[SRCategoryAttribute("Key")]
[SRDescriptionAttribute("Occurs before the KeyDown event when a key is pressed while focus is on this control.")]
public:
event System.Windows.Forms.PreviewKeyDownEventHandler^ PreviewKeyDown

Event Data

The event handler receives an argument of type System.Windows.Forms.PreviewKeyDownEventArgs containing data related to this event. The following PreviewKeyDownEventArgs properties provide information specific to this event.

Property | Description
Alt | Gets a value indicating whether the ALT key was pressed.
Control | Gets a value indicating whether the CTRL key was pressed.
IsInputKey | Gets or sets a value indicating whether a key is a regular input key.
KeyCode | Gets the keyboard code for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyData | Gets the key data for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
KeyValue | Gets the keyboard value for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Modifiers | Gets the modifier flags for a System.Windows.Forms.Control.KeyDown or System.Windows.Forms.Control.KeyUp event.
Shift | Gets a value indicating whether the SHIFT key was pressed.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


ProcessCmdKey Method

[image]
Intersoft WebTextEditor Documentation
ProcessCmdKey Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : ProcessCmdKey Method

msg
keyData

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=False,
   UnmanagedCode=True,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=False,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand Or  _
    SecurityAction.Deny Or  _
    SecurityAction.LinkDemand,
   Unrestricted=False)>
Protected Overridable Function ProcessCmdKey( _
   ByRef msg As System.Windows.Forms.Message, _
   ByVal keyData As System.Windows.Forms.Keys _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim msg As System.Windows.Forms.Message
Dim keyData As System.Windows.Forms.Keys
Dim value As System.Boolean

value = instance.ProcessCmdKey(msg, keyData)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
protected virtual System.bool ProcessCmdKey(
   ref System.Windows.Forms.Message msg,
   System.Windows.Forms.Keys keyData
)
Delphi
protected function ProcessCmdKey(
   var  msg: System.Windows.Forms.Message;
    keyData: System.Windows.Forms.Keys
): System.Boolean; virtual;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=)
protected function ProcessCmdKey(
   msg : System.Windows.Forms.Message,
   keyData : System.Windows.Forms.Keys
) : System.boolean;
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
protected: virtual System.bool ProcessCmdKey(
   ref System.Windows.Forms.Message msg,
   System.Windows.Forms.Keys keyData
)
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
protected:
virtual System.bool ProcessCmdKey(
   System.Windows.Forms.Message% msg,
   System.Windows.Forms.Keys keyData
)

Parameters

msg
keyData

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


ProcessDialogChar Method

[image]
Intersoft WebTextEditor Documentation
ProcessDialogChar Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : ProcessDialogChar Method

charCode

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.SafeSubWindows Or  _
    UIPermissionWindow.SafeTopLevelWindows Or  _
    UIPermissionWindow.AllWindows,
   Clipboard=UIPermissionClipboard.NoClipboard,
   Action=SecurityAction.Demand Or  _
    SecurityAction.Deny Or  _
    SecurityAction.LinkDemand,
   Unrestricted=False)>
Protected Overridable Function ProcessDialogChar( _
   ByVal charCode As System.Char _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim charCode As System.Char
Dim value As System.Boolean

value = instance.ProcessDialogChar(charCode)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.SafeSubWindows |
    UIPermissionWindow.SafeTopLevelWindows |
    UIPermissionWindow.AllWindows,
   Clipboard=UIPermissionClipboard.NoClipboard,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
protected virtual System.bool ProcessDialogChar(
   System.char charCode
)
Delphi
protected function ProcessDialogChar(
    charCode: System.Char
): System.Boolean; virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.SafeSubWindows |
    UIPermissionWindow.SafeTopLevelWindows |
    UIPermissionWindow.AllWindows,
   Clipboard=UIPermissionClipboard.NoClipboard,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=)
protected function ProcessDialogChar(
   charCode : System.char
) : System.boolean;
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.SafeSubWindows |
    UIPermissionWindow.SafeTopLevelWindows |
    UIPermissionWindow.AllWindows,
   Clipboard=UIPermissionClipboard.NoClipboard,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
protected: virtual System.bool ProcessDialogChar(
   System.char charCode
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.SafeSubWindows |
    UIPermissionWindow.SafeTopLevelWindows |
    UIPermissionWindow.AllWindows,
   Clipboard=UIPermissionClipboard.NoClipboard,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
protected:
virtual System.bool ProcessDialogChar(
   System.char charCode
)

Parameters

charCode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


ProcessDialogKey Method

[image]
Intersoft WebTextEditor Documentation
ProcessDialogKey Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : ProcessDialogKey Method

keyData

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.SafeSubWindows Or  _
    UIPermissionWindow.SafeTopLevelWindows Or  _
    UIPermissionWindow.AllWindows,
   Clipboard=UIPermissionClipboard.NoClipboard,
   Action=SecurityAction.Demand Or  _
    SecurityAction.Deny Or  _
    SecurityAction.LinkDemand,
   Unrestricted=False)>
Protected Overridable Function ProcessDialogKey( _
   ByVal keyData As System.Windows.Forms.Keys _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim keyData As System.Windows.Forms.Keys
Dim value As System.Boolean

value = instance.ProcessDialogKey(keyData)
C#
[System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.SafeSubWindows |
    UIPermissionWindow.SafeTopLevelWindows |
    UIPermissionWindow.AllWindows,
   Clipboard=UIPermissionClipboard.NoClipboard,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
protected virtual System.bool ProcessDialogKey(
   System.Windows.Forms.Keys keyData
)
Delphi
protected function ProcessDialogKey(
    keyData: System.Windows.Forms.Keys
): System.Boolean; virtual;
JScript
System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.SafeSubWindows |
    UIPermissionWindow.SafeTopLevelWindows |
    UIPermissionWindow.AllWindows,
   Clipboard=UIPermissionClipboard.NoClipboard,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=)
protected function ProcessDialogKey(
   keyData : System.Windows.Forms.Keys
) : System.boolean;
Managed Extensions for C++
[System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.SafeSubWindows |
    UIPermissionWindow.SafeTopLevelWindows |
    UIPermissionWindow.AllWindows,
   Clipboard=UIPermissionClipboard.NoClipboard,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
protected: virtual System.bool ProcessDialogKey(
   System.Windows.Forms.Keys keyData
)
C++/CLI
[System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.SafeSubWindows |
    UIPermissionWindow.SafeTopLevelWindows |
    UIPermissionWindow.AllWindows,
   Clipboard=UIPermissionClipboard.NoClipboard,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
protected:
virtual System.bool ProcessDialogKey(
   System.Windows.Forms.Keys keyData
)

Parameters

keyData

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


ProcessKeyEventArgs Method

[image]
Intersoft WebTextEditor Documentation
ProcessKeyEventArgs Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : ProcessKeyEventArgs Method

m

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=False,
   UnmanagedCode=True,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=False,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand Or  _
    SecurityAction.Deny Or  _
    SecurityAction.LinkDemand,
   Unrestricted=False)>
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=False,
   UnmanagedCode=True,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=False,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand Or  _
    SecurityAction.Assert Or  _
    SecurityAction.Deny Or  _
    SecurityAction.PermitOnly Or  _
    SecurityAction.LinkDemand Or  _
    SecurityAction.InheritanceDemand,
   Unrestricted=False)>
Protected Overridable Function ProcessKeyEventArgs( _
   ByRef m As System.Windows.Forms.Message _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim m As System.Windows.Forms.Message
Dim value As System.Boolean

value = instance.ProcessKeyEventArgs(m)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
protected virtual System.bool ProcessKeyEventArgs(
   ref System.Windows.Forms.Message m
)
Delphi
protected function ProcessKeyEventArgs(
   var  m: System.Windows.Forms.Message
): System.Boolean; virtual;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=)
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=)
protected function ProcessKeyEventArgs(
   m : System.Windows.Forms.Message
) : System.boolean;
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
protected: virtual System.bool ProcessKeyEventArgs(
   ref System.Windows.Forms.Message m
)
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand |
    SecurityAction.Assert |
    SecurityAction.Deny |
    SecurityAction.PermitOnly |
    SecurityAction.LinkDemand |
    SecurityAction.InheritanceDemand,
   Unrestricted=false)]
protected:
virtual System.bool ProcessKeyEventArgs(
   System.Windows.Forms.Message% m
)

Parameters

m

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


ProcessKeyPreview Method

[image]
Intersoft WebTextEditor Documentation
ProcessKeyPreview Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : ProcessKeyPreview Method

m

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=False,
   UnmanagedCode=True,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=False,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand Or  _
    SecurityAction.Deny Or  _
    SecurityAction.LinkDemand,
   Unrestricted=False)>
Protected Overridable Function ProcessKeyPreview( _
   ByRef m As System.Windows.Forms.Message _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim m As System.Windows.Forms.Message
Dim value As System.Boolean

value = instance.ProcessKeyPreview(m)
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
protected virtual System.bool ProcessKeyPreview(
   ref System.Windows.Forms.Message m
)
Delphi
protected function ProcessKeyPreview(
   var  m: System.Windows.Forms.Message
): System.Boolean; virtual;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=)
protected function ProcessKeyPreview(
   m : System.Windows.Forms.Message
) : System.boolean;
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
protected: virtual System.bool ProcessKeyPreview(
   ref System.Windows.Forms.Message m
)
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
protected:
virtual System.bool ProcessKeyPreview(
   System.Windows.Forms.Message% m
)

Parameters

m

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


ProcessTabKey Method

[image]
Intersoft WebTextEditor Documentation
ProcessTabKey Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : ProcessTabKey Method

forward

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.SafeSubWindows Or  _
    UIPermissionWindow.SafeTopLevelWindows Or  _
    UIPermissionWindow.AllWindows,
   Clipboard=UIPermissionClipboard.NoClipboard,
   Action=SecurityAction.Demand Or  _
    SecurityAction.Deny Or  _
    SecurityAction.LinkDemand,
   Unrestricted=False)>
Protected Overridable Function ProcessTabKey( _
   ByVal forward As System.Boolean _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim forward As System.Boolean
Dim value As System.Boolean

value = instance.ProcessTabKey(forward)
C#
[System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.SafeSubWindows |
    UIPermissionWindow.SafeTopLevelWindows |
    UIPermissionWindow.AllWindows,
   Clipboard=UIPermissionClipboard.NoClipboard,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
protected virtual System.bool ProcessTabKey(
   System.bool forward
)
Delphi
protected function ProcessTabKey(
    forward: System.Boolean
): System.Boolean; virtual;
JScript
System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.SafeSubWindows |
    UIPermissionWindow.SafeTopLevelWindows |
    UIPermissionWindow.AllWindows,
   Clipboard=UIPermissionClipboard.NoClipboard,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=)
protected function ProcessTabKey(
   forward : System.boolean
) : System.boolean;
Managed Extensions for C++
[System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.SafeSubWindows |
    UIPermissionWindow.SafeTopLevelWindows |
    UIPermissionWindow.AllWindows,
   Clipboard=UIPermissionClipboard.NoClipboard,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
protected: virtual System.bool ProcessTabKey(
   System.bool forward
)
C++/CLI
[System.Security.Permissions.UIPermissionAttribute(Window=UIPermissionWindow.SafeSubWindows |
    UIPermissionWindow.SafeTopLevelWindows |
    UIPermissionWindow.AllWindows,
   Clipboard=UIPermissionClipboard.NoClipboard,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
protected:
virtual System.bool ProcessTabKey(
   System.bool forward
)

Parameters

forward

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


ProductName Property

[image]
Intersoft WebTextEditor Documentation
ProductName Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : ProductName Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<System.ComponentModel.BrowsableAttribute(False)>
<SRDescriptionAttribute("Retrieves the name of the product associated with this component.")>
Public ReadOnly Property ProductName As System.String
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.String

value = instance.ProductName
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.ComponentModel.BrowsableAttribute(false)]
[SRDescriptionAttribute("Retrieves the name of the product associated with this component.")]
public System.string ProductName {get;}
Delphi
public read-only property ProductName: System.String;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
System.ComponentModel.BrowsableAttribute()
SRDescriptionAttribute("Retrieves the name of the product associated with this component.")
public function get ProductName : System.String
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.ComponentModel.BrowsableAttribute(false)]
[SRDescriptionAttribute("Retrieves the name of the product associated with this component.")]
public: __property System.string* get_ProductName();
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.ComponentModel.BrowsableAttribute(false)]
[SRDescriptionAttribute("Retrieves the name of the product associated with this component.")]
public:
property System.String^ ProductName {
   System.String^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


ProductVersion Property

[image]
Intersoft WebTextEditor Documentation
ProductVersion Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : ProductVersion Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<SRDescriptionAttribute("Retrieves the version of the product associated with this component.")>
Public ReadOnly Property ProductVersion As System.String
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.String

value = instance.ProductVersion
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRDescriptionAttribute("Retrieves the version of the product associated with this component.")]
public System.string ProductVersion {get;}
Delphi
public read-only property ProductVersion: System.String;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
SRDescriptionAttribute("Retrieves the version of the product associated with this component.")
public function get ProductVersion : System.String
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRDescriptionAttribute("Retrieves the version of the product associated with this component.")]
public: __property System.string* get_ProductVersion();
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRDescriptionAttribute("Retrieves the version of the product associated with this component.")]
public:
property System.String^ ProductVersion {
   System.String^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


QueryAccessibilityHelp Event

[image]
Intersoft WebTextEditor Documentation
QueryAccessibilityHelp Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : QueryAccessibilityHelp Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Behavior")>
<SRDescriptionAttribute("Occurs when an Accessibility client invokes Help for the control.")>
Public Event QueryAccessibilityHelp As System.Windows.Forms.QueryAccessibilityHelpEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.Windows.Forms.QueryAccessibilityHelpEventHandler

AddHandler instance.QueryAccessibilityHelp, handler
C#
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when an Accessibility client invokes Help for the control.")]
public event System.Windows.Forms.QueryAccessibilityHelpEventHandler QueryAccessibilityHelp
Delphi
public event QueryAccessibilityHelp: System.Windows.Forms.QueryAccessibilityHelpEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when an Accessibility client invokes Help for the control.")]
public: __event System.Windows.Forms.QueryAccessibilityHelpEventHandler* QueryAccessibilityHelp
C++/CLI
[SRCategoryAttribute("Behavior")]
[SRDescriptionAttribute("Occurs when an Accessibility client invokes Help for the control.")]
public:
event System.Windows.Forms.QueryAccessibilityHelpEventHandler^ QueryAccessibilityHelp

Event Data

The event handler receives an argument of type System.Windows.Forms.QueryAccessibilityHelpEventArgs containing data related to this event. The following QueryAccessibilityHelpEventArgs properties provide information specific to this event.

Property | Description
HelpKeyword | Gets or sets the Help keyword for the specified control.
HelpNamespace | Gets or sets a value specifying the name of the Help file.
HelpString | Gets or sets the string defining what Help to get for the System.Windows.Forms.AccessibleObject.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


QueryContinueDrag Event

[image]
Intersoft WebTextEditor Documentation
QueryContinueDrag Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : QueryContinueDrag Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the mouse drags an item. The system requests whether the drag-and-drop operation should be allowed to continue.")>
<SRCategoryAttribute("Drag Drop")>
Public Event QueryContinueDrag As System.Windows.Forms.QueryContinueDragEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.Windows.Forms.QueryContinueDragEventHandler

AddHandler instance.QueryContinueDrag, handler
C#
[SRDescriptionAttribute("Occurs when the mouse drags an item. The system requests whether the drag-and-drop operation should be allowed to continue.")]
[SRCategoryAttribute("Drag Drop")]
public event System.Windows.Forms.QueryContinueDragEventHandler QueryContinueDrag
Delphi
public event QueryContinueDrag: System.Windows.Forms.QueryContinueDragEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the mouse drags an item. The system requests whether the drag-and-drop operation should be allowed to continue.")]
[SRCategoryAttribute("Drag Drop")]
public: __event System.Windows.Forms.QueryContinueDragEventHandler* QueryContinueDrag
C++/CLI
[SRDescriptionAttribute("Occurs when the mouse drags an item. The system requests whether the drag-and-drop operation should be allowed to continue.")]
[SRCategoryAttribute("Drag Drop")]
public:
event System.Windows.Forms.QueryContinueDragEventHandler^ QueryContinueDrag

Event Data

The event handler receives an argument of type System.Windows.Forms.QueryContinueDragEventArgs containing data related to this event. The following QueryContinueDragEventArgs properties provide information specific to this event.

Property | Description
Action | Gets or sets the status of a drag-and-drop operation.
EscapePressed | Gets whether the user pressed the ESC key.
KeyState | Gets the current state of the SHIFT, CTRL, and ALT keys.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


RaiseDragEvent Method

[image]
Intersoft WebTextEditor Documentation
RaiseDragEvent Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : RaiseDragEvent Method

key
e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Sub RaiseDragEvent( _
   ByVal key As System.Object, _
   ByVal e As System.Windows.Forms.DragEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim key As System.Object
Dim e As System.Windows.Forms.DragEventArgs

instance.RaiseDragEvent(key, e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected void RaiseDragEvent(
   System.object key,
   System.Windows.Forms.DragEventArgs e
)
Delphi
protected procedure RaiseDragEvent(
    key: System.TObject;
    e: System.Windows.Forms.DragEventArgs
);
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function RaiseDragEvent(
   key : System.Object,
   e : System.Windows.Forms.DragEventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: void RaiseDragEvent(
   System.Object* key,
   System.Windows.Forms.DragEventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
void RaiseDragEvent(
   System.Object^ key,
   System.Windows.Forms.DragEventArgs^ e
)

Parameters

key
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


RaiseKeyEvent Method

[image]
Intersoft WebTextEditor Documentation
RaiseKeyEvent Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : RaiseKeyEvent Method

key
e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Sub RaiseKeyEvent( _
   ByVal key As System.Object, _
   ByVal e As System.Windows.Forms.KeyEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim key As System.Object
Dim e As System.Windows.Forms.KeyEventArgs

instance.RaiseKeyEvent(key, e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected void RaiseKeyEvent(
   System.object key,
   System.Windows.Forms.KeyEventArgs e
)
Delphi
protected procedure RaiseKeyEvent(
    key: System.TObject;
    e: System.Windows.Forms.KeyEventArgs
);
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function RaiseKeyEvent(
   key : System.Object,
   e : System.Windows.Forms.KeyEventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: void RaiseKeyEvent(
   System.Object* key,
   System.Windows.Forms.KeyEventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
void RaiseKeyEvent(
   System.Object^ key,
   System.Windows.Forms.KeyEventArgs^ e
)

Parameters

key
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


RaiseMouseEvent Method

[image]
Intersoft WebTextEditor Documentation
RaiseMouseEvent Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : RaiseMouseEvent Method

key
e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Sub RaiseMouseEvent( _
   ByVal key As System.Object, _
   ByVal e As System.Windows.Forms.MouseEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim key As System.Object
Dim e As System.Windows.Forms.MouseEventArgs

instance.RaiseMouseEvent(key, e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected void RaiseMouseEvent(
   System.object key,
   System.Windows.Forms.MouseEventArgs e
)
Delphi
protected procedure RaiseMouseEvent(
    key: System.TObject;
    e: System.Windows.Forms.MouseEventArgs
);
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function RaiseMouseEvent(
   key : System.Object,
   e : System.Windows.Forms.MouseEventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: void RaiseMouseEvent(
   System.Object* key,
   System.Windows.Forms.MouseEventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
void RaiseMouseEvent(
   System.Object^ key,
   System.Windows.Forms.MouseEventArgs^ e
)

Parameters

key
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


RaisePaintEvent Method

[image]
Intersoft WebTextEditor Documentation
RaisePaintEvent Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : RaisePaintEvent Method

key
e

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Sub RaisePaintEvent( _
   ByVal key As System.Object, _
   ByVal e As System.Windows.Forms.PaintEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim key As System.Object
Dim e As System.Windows.Forms.PaintEventArgs

instance.RaisePaintEvent(key, e)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected void RaisePaintEvent(
   System.object key,
   System.Windows.Forms.PaintEventArgs e
)
Delphi
protected procedure RaisePaintEvent(
    key: System.TObject;
    e: System.Windows.Forms.PaintEventArgs
);
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function RaisePaintEvent(
   key : System.Object,
   e : System.Windows.Forms.PaintEventArgs
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: void RaisePaintEvent(
   System.Object* key,
   System.Windows.Forms.PaintEventArgs* e
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
void RaisePaintEvent(
   System.Object^ key,
   System.Windows.Forms.PaintEventArgs^ e
)

Parameters

key
e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


RecreateHandle Method

[image]
Intersoft WebTextEditor Documentation
RecreateHandle Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : RecreateHandle Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Protected Sub RecreateHandle()
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm

instance.RecreateHandle()
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
protected void RecreateHandle()
Delphi
protected procedure RecreateHandle();
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
protected function RecreateHandle();
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
protected: void RecreateHandle();
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
protected:
void RecreateHandle();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


RecreatingHandle Property

[image]
Intersoft WebTextEditor Documentation
RecreatingHandle Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : RecreatingHandle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<SRCategoryAttribute("Behavior")>
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<SRDescriptionAttribute("Determines if this control is in the process of recreating its handle.")>
Public ReadOnly Property RecreatingHandle As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Boolean

value = instance.RecreatingHandle
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[SRCategoryAttribute("Behavior")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRDescriptionAttribute("Determines if this control is in the process of recreating its handle.")]
public System.bool RecreatingHandle {get;}
Delphi
public read-only property RecreatingHandle: System.Boolean;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
SRCategoryAttribute("Behavior")
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
SRDescriptionAttribute("Determines if this control is in the process of recreating its handle.")
public function get RecreatingHandle : System.boolean
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[SRCategoryAttribute("Behavior")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRDescriptionAttribute("Determines if this control is in the process of recreating its handle.")]
public: __property System.bool get_RecreatingHandle();
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[SRCategoryAttribute("Behavior")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRDescriptionAttribute("Determines if this control is in the process of recreating its handle.")]
public:
property System.bool RecreatingHandle {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


RectangleToClient Method

[image]
Intersoft WebTextEditor Documentation
RectangleToClient Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : RectangleToClient Method

r

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function RectangleToClient( _
   ByVal r As System.Drawing.Rectangle _
) As System.Drawing.Rectangle
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim r As System.Drawing.Rectangle
Dim value As System.Drawing.Rectangle

value = instance.RectangleToClient(r)
C#
public System.Drawing.Rectangle RectangleToClient(
   System.Drawing.Rectangle r
)
Delphi
public function RectangleToClient(
    r: System.Drawing.Rectangle
): System.Drawing.Rectangle;
JScript
public function RectangleToClient(
   r : System.Drawing.Rectangle
) : System.Drawing.Rectangle;
Managed Extensions for C++
public: System.Drawing.Rectangle RectangleToClient(
   System.Drawing.Rectangle r
)
C++/CLI
public:
System.Drawing.Rectangle RectangleToClient(
   System.Drawing.Rectangle r
)

Parameters

r

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


RectangleToScreen Method

[image]
Intersoft WebTextEditor Documentation
RectangleToScreen Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : RectangleToScreen Method

r

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function RectangleToScreen( _
   ByVal r As System.Drawing.Rectangle _
) As System.Drawing.Rectangle
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim r As System.Drawing.Rectangle
Dim value As System.Drawing.Rectangle

value = instance.RectangleToScreen(r)
C#
public System.Drawing.Rectangle RectangleToScreen(
   System.Drawing.Rectangle r
)
Delphi
public function RectangleToScreen(
    r: System.Drawing.Rectangle
): System.Drawing.Rectangle;
JScript
public function RectangleToScreen(
   r : System.Drawing.Rectangle
) : System.Drawing.Rectangle;
Managed Extensions for C++
public: System.Drawing.Rectangle RectangleToScreen(
   System.Drawing.Rectangle r
)
C++/CLI
public:
System.Drawing.Rectangle RectangleToScreen(
   System.Drawing.Rectangle r
)

Parameters

r

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


Refresh Method

[image]
Intersoft WebTextEditor Documentation
Refresh Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : Refresh Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Refresh()
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm

instance.Refresh()
C#
public virtual void Refresh()
Delphi
public procedure Refresh(); virtual;
JScript
public function Refresh();
Managed Extensions for C++
public: virtual void Refresh();
C++/CLI
public:
virtual void Refresh();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


Region Property

[image]
Intersoft WebTextEditor Documentation
Region Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : Region Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The region, or shape, of this control.")>
<SRCategoryAttribute("Layout")>
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Property Region As System.Drawing.Region
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Drawing.Region

instance.Region = value

value = instance.Region
C#
[SRDescriptionAttribute("The region, or shape, of this control.")]
[SRCategoryAttribute("Layout")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public System.Drawing.Region Region {get; set;}
Delphi
public read-write property Region: System.Drawing.Region;
JScript
SRDescriptionAttribute("The region, or shape, of this control.")
SRCategoryAttribute("Layout")
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function get,set Region : System.Drawing.Region
Managed Extensions for C++
[SRDescriptionAttribute("The region, or shape, of this control.")]
[SRCategoryAttribute("Layout")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: __property System.Drawing.Region* get_Region();
public: __property void set_Region(
   System.Drawing.Region* value
);
C++/CLI
[SRDescriptionAttribute("The region, or shape, of this control.")]
[SRCategoryAttribute("Layout")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
property System.Drawing.Region^ Region {
   System.Drawing.Region^ get();
   void set (    System.Drawing.Region^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


RegionChanged Event

[image]
Intersoft WebTextEditor Documentation
RegionChanged Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : RegionChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Event raised when the value of Region property is changed on Control.")>
<SRCategoryAttribute("Property Changed")>
Public Event RegionChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.EventHandler

AddHandler instance.RegionChanged, handler
C#
[SRDescriptionAttribute("Event raised when the value of Region property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public event System.EventHandler RegionChanged
Delphi
public event RegionChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Event raised when the value of Region property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public: __event System.EventHandler* RegionChanged
C++/CLI
[SRDescriptionAttribute("Event raised when the value of Region property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public:
event System.EventHandler^ RegionChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


RemoveOwnedForm Method

[image]
Intersoft WebTextEditor Documentation
RemoveOwnedForm Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : RemoveOwnedForm Method

ownedForm

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RemoveOwnedForm( _
   ByVal ownedForm As System.Windows.Forms.Form _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim ownedForm As System.Windows.Forms.Form

instance.RemoveOwnedForm(ownedForm)
C#
public void RemoveOwnedForm(
   System.Windows.Forms.Form ownedForm
)
Delphi
public procedure RemoveOwnedForm(
    ownedForm: System.Windows.Forms.Form
);
JScript
public function RemoveOwnedForm(
   ownedForm : System.Windows.Forms.Form
);
Managed Extensions for C++
public: void RemoveOwnedForm(
   System.Windows.Forms.Form* ownedForm
)
C++/CLI
public:
void RemoveOwnedForm(
   System.Windows.Forms.Form^ ownedForm
)

Parameters

ownedForm

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


ResetMouseEventArgs Method

[image]
Intersoft WebTextEditor Documentation
ResetMouseEventArgs Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : ResetMouseEventArgs Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Sub ResetMouseEventArgs()
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm

instance.ResetMouseEventArgs()
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected void ResetMouseEventArgs()
Delphi
protected procedure ResetMouseEventArgs();
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function ResetMouseEventArgs();
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: void ResetMouseEventArgs();
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
void ResetMouseEventArgs();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


ResetText Method

[image]
Intersoft WebTextEditor Documentation
ResetText Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : ResetText Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub ResetText()
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm

instance.ResetText()
C#
public virtual void ResetText()
Delphi
public procedure ResetText(); virtual;
JScript
public function ResetText();
Managed Extensions for C++
public: virtual void ResetText();
C++/CLI
public:
virtual void ResetText();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


Resize Event

[image]
Intersoft WebTextEditor Documentation
Resize Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : Resize Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Layout")>
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<SRDescriptionAttribute("Occurs when a control is resized.")>
Public Event Resize As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.EventHandler

AddHandler instance.Resize, handler
C#
[SRCategoryAttribute("Layout")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRDescriptionAttribute("Occurs when a control is resized.")]
public event System.EventHandler Resize
Delphi
public event Resize: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Layout")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRDescriptionAttribute("Occurs when a control is resized.")]
public: __event System.EventHandler* Resize
C++/CLI
[SRCategoryAttribute("Layout")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRDescriptionAttribute("Occurs when a control is resized.")]
public:
event System.EventHandler^ Resize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


ResizeBegin Event

[image]
Intersoft WebTextEditor Documentation
ResizeBegin Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : ResizeBegin Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the form enters the sizing modal loop.")>
<SRCategoryAttribute("Action")>
Public Event ResizeBegin As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.EventHandler

AddHandler instance.ResizeBegin, handler
C#
[SRDescriptionAttribute("Occurs when the form enters the sizing modal loop.")]
[SRCategoryAttribute("Action")]
public event System.EventHandler ResizeBegin
Delphi
public event ResizeBegin: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the form enters the sizing modal loop.")]
[SRCategoryAttribute("Action")]
public: __event System.EventHandler* ResizeBegin
C++/CLI
[SRDescriptionAttribute("Occurs when the form enters the sizing modal loop.")]
[SRCategoryAttribute("Action")]
public:
event System.EventHandler^ ResizeBegin

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


ResizeEnd Event

[image]
Intersoft WebTextEditor Documentation
ResizeEnd Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : ResizeEnd Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Action")>
<SRDescriptionAttribute("Occurs when the form exits the sizing modal loop.")>
Public Event ResizeEnd As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.EventHandler

AddHandler instance.ResizeEnd, handler
C#
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when the form exits the sizing modal loop.")]
public event System.EventHandler ResizeEnd
Delphi
public event ResizeEnd: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when the form exits the sizing modal loop.")]
public: __event System.EventHandler* ResizeEnd
C++/CLI
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when the form exits the sizing modal loop.")]
public:
event System.EventHandler^ ResizeEnd

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


ResizeRedraw Property

[image]
Intersoft WebTextEditor Documentation
ResizeRedraw Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : ResizeRedraw Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Indicates whether the control should redraw itself when resized.")>
Protected Property ResizeRedraw As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Boolean

instance.ResizeRedraw = value

value = instance.ResizeRedraw
C#
[SRDescriptionAttribute("Indicates whether the control should redraw itself when resized.")]
protected System.bool ResizeRedraw {get; set;}
Delphi
protected read-write property ResizeRedraw: System.Boolean;
JScript
SRDescriptionAttribute("Indicates whether the control should redraw itself when resized.")
protected function get,set ResizeRedraw : System.boolean
Managed Extensions for C++
[SRDescriptionAttribute("Indicates whether the control should redraw itself when resized.")]
protected: __property System.bool get_ResizeRedraw();
protected: __property void set_ResizeRedraw(
   System.bool value
);
C++/CLI
[SRDescriptionAttribute("Indicates whether the control should redraw itself when resized.")]
protected:
property System.bool ResizeRedraw {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


RestoreBounds Property

[image]
Intersoft WebTextEditor Documentation
RestoreBounds Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : RestoreBounds Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
Public ReadOnly Property RestoreBounds As System.Drawing.Rectangle
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Drawing.Rectangle

value = instance.RestoreBounds
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public System.Drawing.Rectangle RestoreBounds {get;}
Delphi
public read-only property RestoreBounds: System.Drawing.Rectangle;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
public function get RestoreBounds : System.Drawing.Rectangle
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public: __property System.Drawing.Rectangle get_RestoreBounds();
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public:
property System.Drawing.Rectangle RestoreBounds {
   System.Drawing.Rectangle get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


ResumeLayout Method

[image]
Intersoft WebTextEditor Documentation
ResumeLayout Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : ResumeLayout Method

Glossary Item Box

Overload List

Overload | Description
ResumeLayout() | (Inherited from System.Windows.Forms.Control)
ResumeLayout(Boolean) | (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


ResumeLayout() Method

[image]
Intersoft WebTextEditor Documentation
ResumeLayout() Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class > ResumeLayout Method : ResumeLayout() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub ResumeLayout()
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm

instance.ResumeLayout()
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void ResumeLayout()
Delphi
public procedure ResumeLayout();
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function ResumeLayout();
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void ResumeLayout();
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void ResumeLayout();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members
Overload List


ResumeLayout(Boolean) Method

[image]
Intersoft WebTextEditor Documentation
ResumeLayout(Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class > ResumeLayout Method : ResumeLayout(Boolean) Method

performLayout

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub ResumeLayout( _
   ByVal performLayout As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim performLayout As System.Boolean

instance.ResumeLayout(performLayout)
C#
public void ResumeLayout(
   System.bool performLayout
)
Delphi
public procedure ResumeLayout(
    performLayout: System.Boolean
);
JScript
public function ResumeLayout(
   performLayout : System.boolean
);
Managed Extensions for C++
public: void ResumeLayout(
   System.bool performLayout
)
C++/CLI
public:
void ResumeLayout(
   System.bool performLayout
)

Parameters

performLayout

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members
Overload List


Right Property

[image]
Intersoft WebTextEditor Documentation
Right Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : Right Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<SRDescriptionAttribute("The distance, in pixels, between the right edge of the control and the left edge of its container's client area.")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<SRCategoryAttribute("Layout")>
Public ReadOnly Property Right As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Integer

value = instance.Right
C#
[System.ComponentModel.BrowsableAttribute(false)]
[SRDescriptionAttribute("The distance, in pixels, between the right edge of the control and the left edge of its container's client area.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRCategoryAttribute("Layout")]
public System.int Right {get;}
Delphi
public read-only property Right: System.Integer;
JScript
System.ComponentModel.BrowsableAttribute()
SRDescriptionAttribute("The distance, in pixels, between the right edge of the control and the left edge of its container's client area.")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
SRCategoryAttribute("Layout")
public function get Right : System.int
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[SRDescriptionAttribute("The distance, in pixels, between the right edge of the control and the left edge of its container's client area.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRCategoryAttribute("Layout")]
public: __property System.int get_Right();
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[SRDescriptionAttribute("The distance, in pixels, between the right edge of the control and the left edge of its container's client area.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[SRCategoryAttribute("Layout")]
public:
property System.int Right {
   System.int get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


RightToLeft Property

[image]
Intersoft WebTextEditor Documentation
RightToLeft Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : RightToLeft Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.AmbientValueAttribute()>
<System.ComponentModel.LocalizableAttribute(True)>
<SRCategoryAttribute("Appearance")>
<SRDescriptionAttribute("Indicates whether the component should draw right-to-left for RTL languages.")>
Public Overridable Property RightToLeft As System.Windows.Forms.RightToLeft
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Windows.Forms.RightToLeft

instance.RightToLeft = value

value = instance.RightToLeft
C#
[System.ComponentModel.AmbientValueAttribute()]
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Indicates whether the component should draw right-to-left for RTL languages.")]
public virtual System.Windows.Forms.RightToLeft RightToLeft {get; set;}
Delphi
public read-write property RightToLeft: System.Windows.Forms.RightToLeft; virtual;
JScript
System.ComponentModel.AmbientValueAttribute()
System.ComponentModel.LocalizableAttribute()
SRCategoryAttribute("Appearance")
SRDescriptionAttribute("Indicates whether the component should draw right-to-left for RTL languages.")
public function get,set RightToLeft : System.Windows.Forms.RightToLeft
Managed Extensions for C++
[System.ComponentModel.AmbientValueAttribute()]
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Indicates whether the component should draw right-to-left for RTL languages.")]
public: __property virtual System.Windows.Forms.RightToLeft get_RightToLeft();
public: __property virtual void set_RightToLeft(
   System.Windows.Forms.RightToLeft value
);
C++/CLI
[System.ComponentModel.AmbientValueAttribute()]
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Appearance")]
[SRDescriptionAttribute("Indicates whether the component should draw right-to-left for RTL languages.")]
public:
virtual property System.Windows.Forms.RightToLeft RightToLeft {
   System.Windows.Forms.RightToLeft get();
   void set (    System.Windows.Forms.RightToLeft value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


RightToLeftChanged Event

[image]
Intersoft WebTextEditor Documentation
RightToLeftChanged Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : RightToLeftChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the value of the RightToLeft property changes.")>
<SRCategoryAttribute("Property Changed")>
Public Event RightToLeftChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.EventHandler

AddHandler instance.RightToLeftChanged, handler
C#
[SRDescriptionAttribute("Occurs when the value of the RightToLeft property changes.")]
[SRCategoryAttribute("Property Changed")]
public event System.EventHandler RightToLeftChanged
Delphi
public event RightToLeftChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the value of the RightToLeft property changes.")]
[SRCategoryAttribute("Property Changed")]
public: __event System.EventHandler* RightToLeftChanged
C++/CLI
[SRDescriptionAttribute("Occurs when the value of the RightToLeft property changes.")]
[SRCategoryAttribute("Property Changed")]
public:
event System.EventHandler^ RightToLeftChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


RightToLeftLayout Property

[image]
Intersoft WebTextEditor Documentation
RightToLeftLayout Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : RightToLeftLayout Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Appearance")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.LocalizableAttribute(True)>
<SRDescriptionAttribute("Indicates whether the control layout is right-to-left when the RightToLeft property is set to Yes.")>
Public Overridable Property RightToLeftLayout As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Boolean

instance.RightToLeftLayout = value

value = instance.RightToLeftLayout
C#
[SRCategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.LocalizableAttribute(true)]
[SRDescriptionAttribute("Indicates whether the control layout is right-to-left when the RightToLeft property is set to Yes.")]
public virtual System.bool RightToLeftLayout {get; set;}
Delphi
public read-write property RightToLeftLayout: System.Boolean; virtual;
JScript
SRCategoryAttribute("Appearance")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.LocalizableAttribute()
SRDescriptionAttribute("Indicates whether the control layout is right-to-left when the RightToLeft property is set to Yes.")
public function get,set RightToLeftLayout : System.boolean
Managed Extensions for C++
[SRCategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.LocalizableAttribute(true)]
[SRDescriptionAttribute("Indicates whether the control layout is right-to-left when the RightToLeft property is set to Yes.")]
public: __property virtual System.bool get_RightToLeftLayout();
public: __property virtual void set_RightToLeftLayout(
   System.bool value
);
C++/CLI
[SRCategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.LocalizableAttribute(true)]
[SRDescriptionAttribute("Indicates whether the control layout is right-to-left when the RightToLeft property is set to Yes.")]
public:
virtual property System.bool RightToLeftLayout {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


RightToLeftLayoutChanged Event

[image]
Intersoft WebTextEditor Documentation
RightToLeftLayoutChanged Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : RightToLeftLayoutChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the value of the RightToLeftLayout property changes.")>
<SRCategoryAttribute("Property Changed")>
Public Event RightToLeftLayoutChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.EventHandler

AddHandler instance.RightToLeftLayoutChanged, handler
C#
[SRDescriptionAttribute("Occurs when the value of the RightToLeftLayout property changes.")]
[SRCategoryAttribute("Property Changed")]
public event System.EventHandler RightToLeftLayoutChanged
Delphi
public event RightToLeftLayoutChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the value of the RightToLeftLayout property changes.")]
[SRCategoryAttribute("Property Changed")]
public: __event System.EventHandler* RightToLeftLayoutChanged
C++/CLI
[SRDescriptionAttribute("Occurs when the value of the RightToLeftLayout property changes.")]
[SRCategoryAttribute("Property Changed")]
public:
event System.EventHandler^ RightToLeftLayoutChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


RtlTranslateAlignment Method

[image]
Intersoft WebTextEditor Documentation
RtlTranslateAlignment Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : RtlTranslateAlignment Method

Glossary Item Box

Overload List

Overload | Description
RtlTranslateAlignment(HorizontalAlignment) | (Inherited from System.Windows.Forms.Control)
RtlTranslateAlignment(LeftRightAlignment) | (Inherited from System.Windows.Forms.Control)
RtlTranslateAlignment(ContentAlignment) | (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


RtlTranslateAlignment(ContentAlignment) Method

[image]
Intersoft WebTextEditor Documentation
RtlTranslateAlignment(ContentAlignment) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class > RtlTranslateAlignment Method : RtlTranslateAlignment(ContentAlignment) Method

align

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overloads Function RtlTranslateAlignment( _
   ByVal align As System.Drawing.ContentAlignment _
) As System.Drawing.ContentAlignment
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim align As System.Drawing.ContentAlignment
Dim value As System.Drawing.ContentAlignment

value = instance.RtlTranslateAlignment(align)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected System.Drawing.ContentAlignment RtlTranslateAlignment(
   System.Drawing.ContentAlignment align
)
Delphi
protected function RtlTranslateAlignment(
    align: System.Drawing.ContentAlignment
): System.Drawing.ContentAlignment;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function RtlTranslateAlignment(
   align : System.Drawing.ContentAlignment
) : System.Drawing.ContentAlignment;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: System.Drawing.ContentAlignment RtlTranslateAlignment(
   System.Drawing.ContentAlignment align
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
System.Drawing.ContentAlignment RtlTranslateAlignment(
   System.Drawing.ContentAlignment align
)

Parameters

align

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members
Overload List


RtlTranslateAlignment(HorizontalAlignment) Method

[image]
Intersoft WebTextEditor Documentation
RtlTranslateAlignment(HorizontalAlignment) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class > RtlTranslateAlignment Method : RtlTranslateAlignment(HorizontalAlignment) Method

align

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Protected Overloads Function RtlTranslateAlignment( _
   ByVal align As System.Windows.Forms.HorizontalAlignment _
) As System.Windows.Forms.HorizontalAlignment
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim align As System.Windows.Forms.HorizontalAlignment
Dim value As System.Windows.Forms.HorizontalAlignment

value = instance.RtlTranslateAlignment(align)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
protected System.Windows.Forms.HorizontalAlignment RtlTranslateAlignment(
   System.Windows.Forms.HorizontalAlignment align
)
Delphi
protected function RtlTranslateAlignment(
    align: System.Windows.Forms.HorizontalAlignment
): System.Windows.Forms.HorizontalAlignment;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
protected function RtlTranslateAlignment(
   align : System.Windows.Forms.HorizontalAlignment
) : System.Windows.Forms.HorizontalAlignment;
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
protected: System.Windows.Forms.HorizontalAlignment RtlTranslateAlignment(
   System.Windows.Forms.HorizontalAlignment align
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
protected:
System.Windows.Forms.HorizontalAlignment RtlTranslateAlignment(
   System.Windows.Forms.HorizontalAlignment align
)

Parameters

align

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members
Overload List


RtlTranslateAlignment(LeftRightAlignment) Method

[image]
Intersoft WebTextEditor Documentation
RtlTranslateAlignment(LeftRightAlignment) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class > RtlTranslateAlignment Method : RtlTranslateAlignment(LeftRightAlignment) Method

align

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Protected Overloads Function RtlTranslateAlignment( _
   ByVal align As System.Windows.Forms.LeftRightAlignment _
) As System.Windows.Forms.LeftRightAlignment
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim align As System.Windows.Forms.LeftRightAlignment
Dim value As System.Windows.Forms.LeftRightAlignment

value = instance.RtlTranslateAlignment(align)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
protected System.Windows.Forms.LeftRightAlignment RtlTranslateAlignment(
   System.Windows.Forms.LeftRightAlignment align
)
Delphi
protected function RtlTranslateAlignment(
    align: System.Windows.Forms.LeftRightAlignment
): System.Windows.Forms.LeftRightAlignment;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
protected function RtlTranslateAlignment(
   align : System.Windows.Forms.LeftRightAlignment
) : System.Windows.Forms.LeftRightAlignment;
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
protected: System.Windows.Forms.LeftRightAlignment RtlTranslateAlignment(
   System.Windows.Forms.LeftRightAlignment align
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
protected:
System.Windows.Forms.LeftRightAlignment RtlTranslateAlignment(
   System.Windows.Forms.LeftRightAlignment align
)

Parameters

align

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members
Overload List


RtlTranslateHorizontal Method

[image]
Intersoft WebTextEditor Documentation
RtlTranslateHorizontal Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : RtlTranslateHorizontal Method

align

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Function RtlTranslateHorizontal( _
   ByVal align As System.Windows.Forms.HorizontalAlignment _
) As System.Windows.Forms.HorizontalAlignment
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim align As System.Windows.Forms.HorizontalAlignment
Dim value As System.Windows.Forms.HorizontalAlignment

value = instance.RtlTranslateHorizontal(align)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected System.Windows.Forms.HorizontalAlignment RtlTranslateHorizontal(
   System.Windows.Forms.HorizontalAlignment align
)
Delphi
protected function RtlTranslateHorizontal(
    align: System.Windows.Forms.HorizontalAlignment
): System.Windows.Forms.HorizontalAlignment;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function RtlTranslateHorizontal(
   align : System.Windows.Forms.HorizontalAlignment
) : System.Windows.Forms.HorizontalAlignment;
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: System.Windows.Forms.HorizontalAlignment RtlTranslateHorizontal(
   System.Windows.Forms.HorizontalAlignment align
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
System.Windows.Forms.HorizontalAlignment RtlTranslateHorizontal(
   System.Windows.Forms.HorizontalAlignment align
)

Parameters

align

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


RtlTranslateLeftRight Method

[image]
Intersoft WebTextEditor Documentation
RtlTranslateLeftRight Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : RtlTranslateLeftRight Method

align

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Function RtlTranslateLeftRight( _
   ByVal align As System.Windows.Forms.LeftRightAlignment _
) As System.Windows.Forms.LeftRightAlignment
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim align As System.Windows.Forms.LeftRightAlignment
Dim value As System.Windows.Forms.LeftRightAlignment

value = instance.RtlTranslateLeftRight(align)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected System.Windows.Forms.LeftRightAlignment RtlTranslateLeftRight(
   System.Windows.Forms.LeftRightAlignment align
)
Delphi
protected function RtlTranslateLeftRight(
    align: System.Windows.Forms.LeftRightAlignment
): System.Windows.Forms.LeftRightAlignment;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function RtlTranslateLeftRight(
   align : System.Windows.Forms.LeftRightAlignment
) : System.Windows.Forms.LeftRightAlignment;
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: System.Windows.Forms.LeftRightAlignment RtlTranslateLeftRight(
   System.Windows.Forms.LeftRightAlignment align
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
System.Windows.Forms.LeftRightAlignment RtlTranslateLeftRight(
   System.Windows.Forms.LeftRightAlignment align
)

Parameters

align

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


Scale Method

[image]
Intersoft WebTextEditor Documentation
Scale Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : Scale Method

Glossary Item Box

Overload List

Overload | Description
Scale | (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


Scale(SizeF) Method

[image]
Intersoft WebTextEditor Documentation
Scale(SizeF) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class > Scale Method : Scale(SizeF) Method

factor

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Overloads Sub Scale( _
   ByVal factor As System.Drawing.SizeF _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim factor As System.Drawing.SizeF

instance.Scale(factor)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public void Scale(
   System.Drawing.SizeF factor
)
Delphi
public procedure Scale(
    factor: System.Drawing.SizeF
);
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function Scale(
   factor : System.Drawing.SizeF
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: void Scale(
   System.Drawing.SizeF factor
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
void Scale(
   System.Drawing.SizeF factor
)

Parameters

factor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members
Overload List


ScaleChildren Property

[image]
Intersoft WebTextEditor Documentation
ScaleChildren Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : ScaleChildren Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable ReadOnly Property ScaleChildren As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Boolean

value = instance.ScaleChildren
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual System.bool ScaleChildren {get;}
Delphi
protected read-only property ScaleChildren: System.Boolean; virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function get ScaleChildren : System.boolean
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: __property virtual System.bool get_ScaleChildren();
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual property System.bool ScaleChildren {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


ScaleControl Method

[image]
Intersoft WebTextEditor Documentation
ScaleControl Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : ScaleControl Method

Glossary Item Box

Overload List

Overload | Description
ScaleControl | (Inherited from System.Windows.Forms.Form)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


ScaleControl(SizeF,BoundsSpecified) Method

[image]
Intersoft WebTextEditor Documentation
ScaleControl(SizeF,BoundsSpecified) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : ScaleControl(SizeF,BoundsSpecified) Method

factor
specified

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub ScaleControl( _
   ByVal factor As System.Drawing.SizeF, _
   ByVal specified As System.Windows.Forms.BoundsSpecified _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim factor As System.Drawing.SizeF
Dim specified As System.Windows.Forms.BoundsSpecified

instance.ScaleControl(factor, specified)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void ScaleControl(
   System.Drawing.SizeF factor,
   System.Windows.Forms.BoundsSpecified specified
)
Delphi
protected procedure ScaleControl(
    factor: System.Drawing.SizeF;
    specified: System.Windows.Forms.BoundsSpecified
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function ScaleControl(
   factor : System.Drawing.SizeF,
   specified : System.Windows.Forms.BoundsSpecified
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void ScaleControl(
   System.Drawing.SizeF factor,
   System.Windows.Forms.BoundsSpecified specified
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void ScaleControl(
   System.Drawing.SizeF factor,
   System.Windows.Forms.BoundsSpecified specified
)

Parameters

factor
specified

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


Scroll Event

[image]
Intersoft WebTextEditor Documentation
Scroll Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : Scroll Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Action")>
<SRDescriptionAttribute("Occurs when the user moves the scroll box.")>
Public Event Scroll As System.Windows.Forms.ScrollEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.Windows.Forms.ScrollEventHandler

AddHandler instance.Scroll, handler
C#
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when the user moves the scroll box.")]
public event System.Windows.Forms.ScrollEventHandler Scroll
Delphi
public event Scroll: System.Windows.Forms.ScrollEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when the user moves the scroll box.")]
public: __event System.Windows.Forms.ScrollEventHandler* Scroll
C++/CLI
[SRCategoryAttribute("Action")]
[SRDescriptionAttribute("Occurs when the user moves the scroll box.")]
public:
event System.Windows.Forms.ScrollEventHandler^ Scroll

Event Data

The event handler receives an argument of type System.Windows.Forms.ScrollEventArgs containing data related to this event. The following ScrollEventArgs properties provide information specific to this event.

Property | Description
NewValue | Gets or sets the new System.Windows.Forms.ScrollBar.Value of the scroll bar.
OldValue | Gets the old System.Windows.Forms.ScrollBar.Value of the scroll bar.
ScrollOrientation | Gets the scroll bar orientation that raised the Scroll event.
Type | Gets the type of scroll event that occurred.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


ScrollControlIntoView Method

[image]
Intersoft WebTextEditor Documentation
ScrollControlIntoView Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : ScrollControlIntoView Method

activeControl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ScrollControlIntoView( _
   ByVal activeControl As System.Windows.Forms.Control _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim activeControl As System.Windows.Forms.Control

instance.ScrollControlIntoView(activeControl)
C#
public void ScrollControlIntoView(
   System.Windows.Forms.Control activeControl
)
Delphi
public procedure ScrollControlIntoView(
    activeControl: System.Windows.Forms.Control
);
JScript
public function ScrollControlIntoView(
   activeControl : System.Windows.Forms.Control
);
Managed Extensions for C++
public: void ScrollControlIntoView(
   System.Windows.Forms.Control* activeControl
)
C++/CLI
public:
void ScrollControlIntoView(
   System.Windows.Forms.Control^ activeControl
)

Parameters

activeControl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


ScrollToControl Method

[image]
Intersoft WebTextEditor Documentation
ScrollToControl Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : ScrollToControl Method

activeControl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function ScrollToControl( _
   ByVal activeControl As System.Windows.Forms.Control _
) As System.Drawing.Point
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim activeControl As System.Windows.Forms.Control
Dim value As System.Drawing.Point

value = instance.ScrollToControl(activeControl)
C#
protected virtual System.Drawing.Point ScrollToControl(
   System.Windows.Forms.Control activeControl
)
Delphi
protected function ScrollToControl(
    activeControl: System.Windows.Forms.Control
): System.Drawing.Point; virtual;
JScript
protected function ScrollToControl(
   activeControl : System.Windows.Forms.Control
) : System.Drawing.Point;
Managed Extensions for C++
protected: virtual System.Drawing.Point ScrollToControl(
   System.Windows.Forms.Control* activeControl
)
C++/CLI
protected:
virtual System.Drawing.Point ScrollToControl(
   System.Windows.Forms.Control^ activeControl
)

Parameters

activeControl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


Select Method

[image]
Intersoft WebTextEditor Documentation
Select Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : Select Method

Glossary Item Box

Overload List

Overload | Description
Select(Boolean,Boolean) | (Inherited from System.Windows.Forms.Form)
Select() | (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


Select() Method

[image]
Intersoft WebTextEditor Documentation
Select() Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class > Select Method : Select() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub Select()
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm

instance.Select()
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void Select()
Delphi
public procedure Select();
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function Select();
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void Select();
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void Select();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members
Overload List


Select(Boolean,Boolean) Method

[image]
Intersoft WebTextEditor Documentation
Select(Boolean,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class > Select Method : Select(Boolean,Boolean) Method

directed
forward

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overloads Overridable Sub Select( _
   ByVal directed As System.Boolean, _
   ByVal forward As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim directed As System.Boolean
Dim forward As System.Boolean

instance.Select(directed, forward)
C#
protected virtual void Select(
   System.bool directed,
   System.bool forward
)
Delphi
protected procedure Select(
    directed: System.Boolean;
    forward: System.Boolean
); virtual;
JScript
protected function Select(
   directed : System.boolean,
   forward : System.boolean
);
Managed Extensions for C++
protected: virtual void Select(
   System.bool directed,
   System.bool forward
)
C++/CLI
protected:
virtual void Select(
   System.bool directed,
   System.bool forward
)

Parameters

directed
forward

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members
Overload List


SelectNextControl Method

[image]
Intersoft WebTextEditor Documentation
SelectNextControl Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : SelectNextControl Method

ctl
forward
tabStopOnly
nested
wrap

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function SelectNextControl( _
   ByVal ctl As System.Windows.Forms.Control, _
   ByVal forward As System.Boolean, _
   ByVal tabStopOnly As System.Boolean, _
   ByVal nested As System.Boolean, _
   ByVal wrap As System.Boolean _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim ctl As System.Windows.Forms.Control
Dim forward As System.Boolean
Dim tabStopOnly As System.Boolean
Dim nested As System.Boolean
Dim wrap As System.Boolean
Dim value As System.Boolean

value = instance.SelectNextControl(ctl, forward, tabStopOnly, nested, wrap)
C#
public System.bool SelectNextControl(
   System.Windows.Forms.Control ctl,
   System.bool forward,
   System.bool tabStopOnly,
   System.bool nested,
   System.bool wrap
)
Delphi
public function SelectNextControl(
    ctl: System.Windows.Forms.Control;
    forward: System.Boolean;
    tabStopOnly: System.Boolean;
    nested: System.Boolean;
    wrap: System.Boolean
): System.Boolean;
JScript
public function SelectNextControl(
   ctl : System.Windows.Forms.Control,
   forward : System.boolean,
   tabStopOnly : System.boolean,
   nested : System.boolean,
   wrap : System.boolean
) : System.boolean;
Managed Extensions for C++
public: System.bool SelectNextControl(
   System.Windows.Forms.Control* ctl,
   System.bool forward,
   System.bool tabStopOnly,
   System.bool nested,
   System.bool wrap
)
C++/CLI
public:
System.bool SelectNextControl(
   System.Windows.Forms.Control^ ctl,
   System.bool forward,
   System.bool tabStopOnly,
   System.bool nested,
   System.bool wrap
)

Parameters

ctl
forward
tabStopOnly
nested
wrap

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


SendToBack Method

[image]
Intersoft WebTextEditor Documentation
SendToBack Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : SendToBack Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SendToBack()
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm

instance.SendToBack()
C#
public void SendToBack()
Delphi
public procedure SendToBack();
JScript
public function SendToBack();
Managed Extensions for C++
public: void SendToBack();
C++/CLI
public:
void SendToBack();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


SetAutoScrollMargin Method

[image]
Intersoft WebTextEditor Documentation
SetAutoScrollMargin Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : SetAutoScrollMargin Method

x
y

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetAutoScrollMargin( _
   ByVal x As System.Integer, _
   ByVal y As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim x As System.Integer
Dim y As System.Integer

instance.SetAutoScrollMargin(x, y)
C#
public void SetAutoScrollMargin(
   System.int x,
   System.int y
)
Delphi
public procedure SetAutoScrollMargin(
    x: System.Integer;
    y: System.Integer
);
JScript
public function SetAutoScrollMargin(
   x : System.int,
   y : System.int
);
Managed Extensions for C++
public: void SetAutoScrollMargin(
   System.int x,
   System.int y
)
C++/CLI
public:
void SetAutoScrollMargin(
   System.int x,
   System.int y
)

Parameters

x
y

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


SetAutoSizeMode Method

[image]
Intersoft WebTextEditor Documentation
SetAutoSizeMode Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : SetAutoSizeMode Method

mode

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Sub SetAutoSizeMode( _
   ByVal mode As System.Windows.Forms.AutoSizeMode _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim mode As System.Windows.Forms.AutoSizeMode

instance.SetAutoSizeMode(mode)
C#
protected void SetAutoSizeMode(
   System.Windows.Forms.AutoSizeMode mode
)
Delphi
protected procedure SetAutoSizeMode(
    mode: System.Windows.Forms.AutoSizeMode
);
JScript
protected function SetAutoSizeMode(
   mode : System.Windows.Forms.AutoSizeMode
);
Managed Extensions for C++
protected: void SetAutoSizeMode(
   System.Windows.Forms.AutoSizeMode mode
)
C++/CLI
protected:
void SetAutoSizeMode(
   System.Windows.Forms.AutoSizeMode mode
)

Parameters

mode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


SetBounds Method

[image]
Intersoft WebTextEditor Documentation
SetBounds Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : SetBounds Method

Glossary Item Box

Overload List

Overload | Description
SetBounds(Int32,Int32,Int32,Int32) | (Inherited from System.Windows.Forms.Control)
SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) | (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


SetBounds(Int32,Int32,Int32,Int32) Method

[image]
Intersoft WebTextEditor Documentation
SetBounds(Int32,Int32,Int32,Int32) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class > SetBounds Method : SetBounds(Int32,Int32,Int32,Int32) Method

x
y
width
height

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetBounds( _
   ByVal x As System.Integer, _
   ByVal y As System.Integer, _
   ByVal width As System.Integer, _
   ByVal height As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim x As System.Integer
Dim y As System.Integer
Dim width As System.Integer
Dim height As System.Integer

instance.SetBounds(x, y, width, height)
C#
public void SetBounds(
   System.int x,
   System.int y,
   System.int width,
   System.int height
)
Delphi
public procedure SetBounds(
    x: System.Integer;
    y: System.Integer;
    width: System.Integer;
    height: System.Integer
);
JScript
public function SetBounds(
   x : System.int,
   y : System.int,
   width : System.int,
   height : System.int
);
Managed Extensions for C++
public: void SetBounds(
   System.int x,
   System.int y,
   System.int width,
   System.int height
)
C++/CLI
public:
void SetBounds(
   System.int x,
   System.int y,
   System.int width,
   System.int height
)

Parameters

x
y
width
height

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members
Overload List


SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) Method

[image]
Intersoft WebTextEditor Documentation
SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class > SetBounds Method : SetBounds(Int32,Int32,Int32,Int32,BoundsSpecified) Method

x
y
width
height
specified

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub SetBounds( _
   ByVal x As System.Integer, _
   ByVal y As System.Integer, _
   ByVal width As System.Integer, _
   ByVal height As System.Integer, _
   ByVal specified As System.Windows.Forms.BoundsSpecified _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim x As System.Integer
Dim y As System.Integer
Dim width As System.Integer
Dim height As System.Integer
Dim specified As System.Windows.Forms.BoundsSpecified

instance.SetBounds(x, y, width, height, specified)
C#
public void SetBounds(
   System.int x,
   System.int y,
   System.int width,
   System.int height,
   System.Windows.Forms.BoundsSpecified specified
)
Delphi
public procedure SetBounds(
    x: System.Integer;
    y: System.Integer;
    width: System.Integer;
    height: System.Integer;
    specified: System.Windows.Forms.BoundsSpecified
);
JScript
public function SetBounds(
   x : System.int,
   y : System.int,
   width : System.int,
   height : System.int,
   specified : System.Windows.Forms.BoundsSpecified
);
Managed Extensions for C++
public: void SetBounds(
   System.int x,
   System.int y,
   System.int width,
   System.int height,
   System.Windows.Forms.BoundsSpecified specified
)
C++/CLI
public:
void SetBounds(
   System.int x,
   System.int y,
   System.int width,
   System.int height,
   System.Windows.Forms.BoundsSpecified specified
)

Parameters

x
y
width
height
specified

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members
Overload List


SetBoundsCore Method

[image]
Intersoft WebTextEditor Documentation
SetBoundsCore Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : SetBoundsCore Method

x
y
width
height
specified

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub SetBoundsCore( _
   ByVal x As System.Integer, _
   ByVal y As System.Integer, _
   ByVal width As System.Integer, _
   ByVal height As System.Integer, _
   ByVal specified As System.Windows.Forms.BoundsSpecified _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim x As System.Integer
Dim y As System.Integer
Dim width As System.Integer
Dim height As System.Integer
Dim specified As System.Windows.Forms.BoundsSpecified

instance.SetBoundsCore(x, y, width, height, specified)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void SetBoundsCore(
   System.int x,
   System.int y,
   System.int width,
   System.int height,
   System.Windows.Forms.BoundsSpecified specified
)
Delphi
protected procedure SetBoundsCore(
    x: System.Integer;
    y: System.Integer;
    width: System.Integer;
    height: System.Integer;
    specified: System.Windows.Forms.BoundsSpecified
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function SetBoundsCore(
   x : System.int,
   y : System.int,
   width : System.int,
   height : System.int,
   specified : System.Windows.Forms.BoundsSpecified
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void SetBoundsCore(
   System.int x,
   System.int y,
   System.int width,
   System.int height,
   System.Windows.Forms.BoundsSpecified specified
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void SetBoundsCore(
   System.int x,
   System.int y,
   System.int width,
   System.int height,
   System.Windows.Forms.BoundsSpecified specified
)

Parameters

x
y
width
height
specified

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


SetClientSizeCore Method

[image]
Intersoft WebTextEditor Documentation
SetClientSizeCore Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : SetClientSizeCore Method

x
y

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub SetClientSizeCore( _
   ByVal x As System.Integer, _
   ByVal y As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim x As System.Integer
Dim y As System.Integer

instance.SetClientSizeCore(x, y)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void SetClientSizeCore(
   System.int x,
   System.int y
)
Delphi
protected procedure SetClientSizeCore(
    x: System.Integer;
    y: System.Integer
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function SetClientSizeCore(
   x : System.int,
   y : System.int
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void SetClientSizeCore(
   System.int x,
   System.int y
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void SetClientSizeCore(
   System.int x,
   System.int y
)

Parameters

x
y

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


SetDesktopBounds Method

[image]
Intersoft WebTextEditor Documentation
SetDesktopBounds Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : SetDesktopBounds Method

x
y
width
height

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetDesktopBounds( _
   ByVal x As System.Integer, _
   ByVal y As System.Integer, _
   ByVal width As System.Integer, _
   ByVal height As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim x As System.Integer
Dim y As System.Integer
Dim width As System.Integer
Dim height As System.Integer

instance.SetDesktopBounds(x, y, width, height)
C#
public void SetDesktopBounds(
   System.int x,
   System.int y,
   System.int width,
   System.int height
)
Delphi
public procedure SetDesktopBounds(
    x: System.Integer;
    y: System.Integer;
    width: System.Integer;
    height: System.Integer
);
JScript
public function SetDesktopBounds(
   x : System.int,
   y : System.int,
   width : System.int,
   height : System.int
);
Managed Extensions for C++
public: void SetDesktopBounds(
   System.int x,
   System.int y,
   System.int width,
   System.int height
)
C++/CLI
public:
void SetDesktopBounds(
   System.int x,
   System.int y,
   System.int width,
   System.int height
)

Parameters

x
y
width
height

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


SetDesktopLocation Method

[image]
Intersoft WebTextEditor Documentation
SetDesktopLocation Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : SetDesktopLocation Method

x
y

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetDesktopLocation( _
   ByVal x As System.Integer, _
   ByVal y As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim x As System.Integer
Dim y As System.Integer

instance.SetDesktopLocation(x, y)
C#
public void SetDesktopLocation(
   System.int x,
   System.int y
)
Delphi
public procedure SetDesktopLocation(
    x: System.Integer;
    y: System.Integer
);
JScript
public function SetDesktopLocation(
   x : System.int,
   y : System.int
);
Managed Extensions for C++
public: void SetDesktopLocation(
   System.int x,
   System.int y
)
C++/CLI
public:
void SetDesktopLocation(
   System.int x,
   System.int y
)

Parameters

x
y

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


SetDisplayRectLocation Method

[image]
Intersoft WebTextEditor Documentation
SetDisplayRectLocation Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : SetDisplayRectLocation Method

x
y

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Sub SetDisplayRectLocation( _
   ByVal x As System.Integer, _
   ByVal y As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim x As System.Integer
Dim y As System.Integer

instance.SetDisplayRectLocation(x, y)
C#
protected void SetDisplayRectLocation(
   System.int x,
   System.int y
)
Delphi
protected procedure SetDisplayRectLocation(
    x: System.Integer;
    y: System.Integer
);
JScript
protected function SetDisplayRectLocation(
   x : System.int,
   y : System.int
);
Managed Extensions for C++
protected: void SetDisplayRectLocation(
   System.int x,
   System.int y
)
C++/CLI
protected:
void SetDisplayRectLocation(
   System.int x,
   System.int y
)

Parameters

x
y

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


SetScrollState Method

[image]
Intersoft WebTextEditor Documentation
SetScrollState Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : SetScrollState Method

bit
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Sub SetScrollState( _
   ByVal bit As System.Integer, _
   ByVal value As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim bit As System.Integer
Dim value As System.Boolean

instance.SetScrollState(bit, value)
C#
protected void SetScrollState(
   System.int bit,
   System.bool value
)
Delphi
protected procedure SetScrollState(
    bit: System.Integer;
    value: System.Boolean
);
JScript
protected function SetScrollState(
   bit : System.int,
   value : System.boolean
);
Managed Extensions for C++
protected: void SetScrollState(
   System.int bit,
   System.bool value
)
C++/CLI
protected:
void SetScrollState(
   System.int bit,
   System.bool value
)

Parameters

bit
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


SetStyle Method

[image]
Intersoft WebTextEditor Documentation
SetStyle Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : SetStyle Method

flag
value

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Sub SetStyle( _
   ByVal flag As System.Windows.Forms.ControlStyles, _
   ByVal value As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim flag As System.Windows.Forms.ControlStyles
Dim value As System.Boolean

instance.SetStyle(flag, value)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected void SetStyle(
   System.Windows.Forms.ControlStyles flag,
   System.bool value
)
Delphi
protected procedure SetStyle(
    flag: System.Windows.Forms.ControlStyles;
    value: System.Boolean
);
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function SetStyle(
   flag : System.Windows.Forms.ControlStyles,
   value : System.boolean
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: void SetStyle(
   System.Windows.Forms.ControlStyles flag,
   System.bool value
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
void SetStyle(
   System.Windows.Forms.ControlStyles flag,
   System.bool value
)

Parameters

flag
value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


SetTopLevel Method

[image]
Intersoft WebTextEditor Documentation
SetTopLevel Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : SetTopLevel Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Sub SetTopLevel( _
   ByVal value As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Boolean

instance.SetTopLevel(value)
C#
protected void SetTopLevel(
   System.bool value
)
Delphi
protected procedure SetTopLevel(
    value: System.Boolean
);
JScript
protected function SetTopLevel(
   value : System.boolean
);
Managed Extensions for C++
protected: void SetTopLevel(
   System.bool value
)
C++/CLI
protected:
void SetTopLevel(
   System.bool value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


SetVisibleCore Method

[image]
Intersoft WebTextEditor Documentation
SetVisibleCore Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : SetVisibleCore Method

value

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Sub SetVisibleCore( _
   ByVal value As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Boolean

instance.SetVisibleCore(value)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual void SetVisibleCore(
   System.bool value
)
Delphi
protected procedure SetVisibleCore(
    value: System.Boolean
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function SetVisibleCore(
   value : System.boolean
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual void SetVisibleCore(
   System.bool value
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual void SetVisibleCore(
   System.bool value
)

Parameters

value

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


Show Method

[image]
Intersoft WebTextEditor Documentation
Show Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : Show Method

Glossary Item Box

Overload List

Overload | Description
Show(IWin32Window) | (Inherited from System.Windows.Forms.Form)
Show() | (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


Show() Method

[image]
Intersoft WebTextEditor Documentation
Show() Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class > Show Method : Show() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Sub Show()
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm

instance.Show()
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public void Show()
Delphi
public procedure Show();
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function Show();
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: void Show();
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
void Show();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members
Overload List


Show(IWin32Window) Method

[image]
Intersoft WebTextEditor Documentation
Show(IWin32Window) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class > Show Method : Show(IWin32Window) Method

owner

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub Show( _
   ByVal owner As System.Windows.Forms.IWin32Window _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim owner As System.Windows.Forms.IWin32Window

instance.Show(owner)
C#
public void Show(
   System.Windows.Forms.IWin32Window owner
)
Delphi
public procedure Show(
    owner: System.Windows.Forms.IWin32Window
);
JScript
public function Show(
   owner : System.Windows.Forms.IWin32Window
);
Managed Extensions for C++
public: void Show(
   System.Windows.Forms.IWin32Window* owner
)
C++/CLI
public:
void Show(
   System.Windows.Forms.IWin32Window^ owner
)

Parameters

owner

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members
Overload List


ShowDialog Method

[image]
Intersoft WebTextEditor Documentation
ShowDialog Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : ShowDialog Method

Glossary Item Box

Overload List

Overload | Description
ShowDialog() | (Inherited from System.Windows.Forms.Form)
ShowDialog(IWin32Window) | (Inherited from System.Windows.Forms.Form)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


ShowDialog() Method

[image]
Intersoft WebTextEditor Documentation
ShowDialog() Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class > ShowDialog Method : ShowDialog() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function ShowDialog() As System.Windows.Forms.DialogResult
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Windows.Forms.DialogResult

value = instance.ShowDialog()
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.Windows.Forms.DialogResult ShowDialog()
Delphi
public function ShowDialog(): System.Windows.Forms.DialogResult;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function ShowDialog() : System.Windows.Forms.DialogResult;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.Windows.Forms.DialogResult ShowDialog();
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.Windows.Forms.DialogResult ShowDialog();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members
Overload List


ShowDialog(IWin32Window) Method

[image]
Intersoft WebTextEditor Documentation
ShowDialog(IWin32Window) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class > ShowDialog Method : ShowDialog(IWin32Window) Method

owner

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function ShowDialog( _
   ByVal owner As System.Windows.Forms.IWin32Window _
) As System.Windows.Forms.DialogResult
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim owner As System.Windows.Forms.IWin32Window
Dim value As System.Windows.Forms.DialogResult

value = instance.ShowDialog(owner)
C#
public System.Windows.Forms.DialogResult ShowDialog(
   System.Windows.Forms.IWin32Window owner
)
Delphi
public function ShowDialog(
    owner: System.Windows.Forms.IWin32Window
): System.Windows.Forms.DialogResult;
JScript
public function ShowDialog(
   owner : System.Windows.Forms.IWin32Window
) : System.Windows.Forms.DialogResult;
Managed Extensions for C++
public: System.Windows.Forms.DialogResult ShowDialog(
   System.Windows.Forms.IWin32Window* owner
)
C++/CLI
public:
System.Windows.Forms.DialogResult ShowDialog(
   System.Windows.Forms.IWin32Window^ owner
)

Parameters

owner

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members
Overload List


ShowIcon Property

[image]
Intersoft WebTextEditor Documentation
ShowIcon Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : ShowIcon Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<SRCategoryAttribute("Window Style")>
<SRDescriptionAttribute("Indicates whether an icon is displayed in the title bar of the form.")>
Public Property ShowIcon As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Boolean

instance.ShowIcon = value

value = instance.ShowIcon
C#
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Window Style")]
[SRDescriptionAttribute("Indicates whether an icon is displayed in the title bar of the form.")]
public System.bool ShowIcon {get; set;}
Delphi
public read-write property ShowIcon: System.Boolean;
JScript
System.ComponentModel.DefaultValueAttribute()
SRCategoryAttribute("Window Style")
SRDescriptionAttribute("Indicates whether an icon is displayed in the title bar of the form.")
public function get,set ShowIcon : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Window Style")]
[SRDescriptionAttribute("Indicates whether an icon is displayed in the title bar of the form.")]
public: __property System.bool get_ShowIcon();
public: __property void set_ShowIcon(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Window Style")]
[SRDescriptionAttribute("Indicates whether an icon is displayed in the title bar of the form.")]
public:
property System.bool ShowIcon {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


ShowInTaskbar Property

[image]
Intersoft WebTextEditor Documentation
ShowInTaskbar Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : ShowInTaskbar Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Window Style")>
<System.ComponentModel.DefaultValueAttribute()>
<SRDescriptionAttribute("Determines whether the form appears in the Windows Taskbar.")>
Public Property ShowInTaskbar As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Boolean

instance.ShowInTaskbar = value

value = instance.ShowInTaskbar
C#
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("Determines whether the form appears in the Windows Taskbar.")]
public System.bool ShowInTaskbar {get; set;}
Delphi
public read-write property ShowInTaskbar: System.Boolean;
JScript
SRCategoryAttribute("Window Style")
System.ComponentModel.DefaultValueAttribute()
SRDescriptionAttribute("Determines whether the form appears in the Windows Taskbar.")
public function get,set ShowInTaskbar : System.boolean
Managed Extensions for C++
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("Determines whether the form appears in the Windows Taskbar.")]
public: __property System.bool get_ShowInTaskbar();
public: __property void set_ShowInTaskbar(
   System.bool value
);
C++/CLI
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("Determines whether the form appears in the Windows Taskbar.")]
public:
property System.bool ShowInTaskbar {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


Shown Event

[image]
Intersoft WebTextEditor Documentation
Shown Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : Shown Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs whenever the form is first shown.")>
<SRCategoryAttribute("Behavior")>
Public Event Shown As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.EventHandler

AddHandler instance.Shown, handler
C#
[SRDescriptionAttribute("Occurs whenever the form is first shown.")]
[SRCategoryAttribute("Behavior")]
public event System.EventHandler Shown
Delphi
public event Shown: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs whenever the form is first shown.")]
[SRCategoryAttribute("Behavior")]
public: __event System.EventHandler* Shown
C++/CLI
[SRDescriptionAttribute("Occurs whenever the form is first shown.")]
[SRCategoryAttribute("Behavior")]
public:
event System.EventHandler^ Shown

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


ShowWithoutActivation Property

[image]
Intersoft WebTextEditor Documentation
ShowWithoutActivation Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : ShowWithoutActivation Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
Protected Overridable ReadOnly Property ShowWithoutActivation As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Boolean

value = instance.ShowWithoutActivation
C#
[System.ComponentModel.BrowsableAttribute(false)]
protected virtual System.bool ShowWithoutActivation {get;}
Delphi
protected read-only property ShowWithoutActivation: System.Boolean; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
protected function get ShowWithoutActivation : System.boolean
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
protected: __property virtual System.bool get_ShowWithoutActivation();
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
protected:
virtual property System.bool ShowWithoutActivation {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


Site Property

[image]
Intersoft WebTextEditor Documentation
Site Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : Site Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Overridable Property Site As System.ComponentModel.ISite
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.ComponentModel.ISite

instance.Site = value

value = instance.Site
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public virtual System.ComponentModel.ISite Site {get; set;}
Delphi
public read-write property Site: System.ComponentModel.ISite; virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function get,set Site : System.ComponentModel.ISite
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: __property virtual System.ComponentModel.ISite* get_Site();
public: __property virtual void set_Site(
   System.ComponentModel.ISite* value
);
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
virtual property System.ComponentModel.ISite^ Site {
   System.ComponentModel.ISite^ get();
   void set (    System.ComponentModel.ISite^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


Size Property

[image]
Intersoft WebTextEditor Documentation
Size Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : Size Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.LocalizableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property Size As System.Drawing.Size
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Drawing.Size

instance.Size = value

value = instance.Size
C#
[System.ComponentModel.LocalizableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public System.Drawing.Size Size {get; set;}
Delphi
public read-write property Size: System.Drawing.Size;
JScript
System.ComponentModel.LocalizableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get,set Size : System.Drawing.Size
Managed Extensions for C++
[System.ComponentModel.LocalizableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property System.Drawing.Size get_Size();
public: __property void set_Size(
   System.Drawing.Size value
);
C++/CLI
[System.ComponentModel.LocalizableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property System.Drawing.Size Size {
   System.Drawing.Size get();
   void set (    System.Drawing.Size value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


SizeChanged Event

[image]
Intersoft WebTextEditor Documentation
SizeChanged Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : SizeChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Event raised when the value of the Size property is changed on Control.")>
<SRCategoryAttribute("Property Changed")>
Public Event SizeChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.EventHandler

AddHandler instance.SizeChanged, handler
C#
[SRDescriptionAttribute("Event raised when the value of the Size property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public event System.EventHandler SizeChanged
Delphi
public event SizeChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Event raised when the value of the Size property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public: __event System.EventHandler* SizeChanged
C++/CLI
[SRDescriptionAttribute("Event raised when the value of the Size property is changed on Control.")]
[SRCategoryAttribute("Property Changed")]
public:
event System.EventHandler^ SizeChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


SizeFromClientSize Method

[image]
Intersoft WebTextEditor Documentation
SizeFromClientSize Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : SizeFromClientSize Method

Glossary Item Box

Overload List

Overload | Description
SizeFromClientSize | (Inherited from System.Windows.Forms.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


SizeFromClientSize(Size) Method

[image]
Intersoft WebTextEditor Documentation
SizeFromClientSize(Size) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : SizeFromClientSize(Size) Method

clientSize

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Function SizeFromClientSize( _
   ByVal clientSize As System.Drawing.Size _
) As System.Drawing.Size
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim clientSize As System.Drawing.Size
Dim value As System.Drawing.Size

value = instance.SizeFromClientSize(clientSize)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual System.Drawing.Size SizeFromClientSize(
   System.Drawing.Size clientSize
)
Delphi
protected function SizeFromClientSize(
    clientSize: System.Drawing.Size
): System.Drawing.Size; virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function SizeFromClientSize(
   clientSize : System.Drawing.Size
) : System.Drawing.Size;
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: virtual System.Drawing.Size SizeFromClientSize(
   System.Drawing.Size clientSize
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
virtual System.Drawing.Size SizeFromClientSize(
   System.Drawing.Size clientSize
)

Parameters

clientSize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


SizeGripStyle Property

[image]
Intersoft WebTextEditor Documentation
SizeGripStyle Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : SizeGripStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Window Style")>
<System.ComponentModel.DefaultValueAttribute()>
<SRDescriptionAttribute("Determines when the SizeGrip will be displayed for the form.")>
Public Property SizeGripStyle As System.Windows.Forms.SizeGripStyle
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Windows.Forms.SizeGripStyle

instance.SizeGripStyle = value

value = instance.SizeGripStyle
C#
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("Determines when the SizeGrip will be displayed for the form.")]
public System.Windows.Forms.SizeGripStyle SizeGripStyle {get; set;}
Delphi
public read-write property SizeGripStyle: System.Windows.Forms.SizeGripStyle;
JScript
SRCategoryAttribute("Window Style")
System.ComponentModel.DefaultValueAttribute()
SRDescriptionAttribute("Determines when the SizeGrip will be displayed for the form.")
public function get,set SizeGripStyle : System.Windows.Forms.SizeGripStyle
Managed Extensions for C++
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("Determines when the SizeGrip will be displayed for the form.")]
public: __property System.Windows.Forms.SizeGripStyle get_SizeGripStyle();
public: __property void set_SizeGripStyle(
   System.Windows.Forms.SizeGripStyle value
);
C++/CLI
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DefaultValueAttribute()]
[SRDescriptionAttribute("Determines when the SizeGrip will be displayed for the form.")]
public:
property System.Windows.Forms.SizeGripStyle SizeGripStyle {
   System.Windows.Forms.SizeGripStyle get();
   void set (    System.Windows.Forms.SizeGripStyle value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


StartPosition Property

[image]
Intersoft WebTextEditor Documentation
StartPosition Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : StartPosition Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Layout")>
<System.ComponentModel.LocalizableAttribute(True)>
<SRDescriptionAttribute("Determines the position of a form when it first appears.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property StartPosition As System.Windows.Forms.FormStartPosition
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Windows.Forms.FormStartPosition

instance.StartPosition = value

value = instance.StartPosition
C#
[SRCategoryAttribute("Layout")]
[System.ComponentModel.LocalizableAttribute(true)]
[SRDescriptionAttribute("Determines the position of a form when it first appears.")]
[System.ComponentModel.DefaultValueAttribute()]
public System.Windows.Forms.FormStartPosition StartPosition {get; set;}
Delphi
public read-write property StartPosition: System.Windows.Forms.FormStartPosition;
JScript
SRCategoryAttribute("Layout")
System.ComponentModel.LocalizableAttribute()
SRDescriptionAttribute("Determines the position of a form when it first appears.")
System.ComponentModel.DefaultValueAttribute()
public function get,set StartPosition : System.Windows.Forms.FormStartPosition
Managed Extensions for C++
[SRCategoryAttribute("Layout")]
[System.ComponentModel.LocalizableAttribute(true)]
[SRDescriptionAttribute("Determines the position of a form when it first appears.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.Windows.Forms.FormStartPosition get_StartPosition();
public: __property void set_StartPosition(
   System.Windows.Forms.FormStartPosition value
);
C++/CLI
[SRCategoryAttribute("Layout")]
[System.ComponentModel.LocalizableAttribute(true)]
[SRDescriptionAttribute("Determines the position of a form when it first appears.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.Windows.Forms.FormStartPosition StartPosition {
   System.Windows.Forms.FormStartPosition get();
   void set (    System.Windows.Forms.FormStartPosition value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


StyleChanged Event

[image]
Intersoft WebTextEditor Documentation
StyleChanged Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : StyleChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Event raised when the window style of a Control is changed.")>
<SRCategoryAttribute("Behavior")>
Public Event StyleChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.EventHandler

AddHandler instance.StyleChanged, handler
C#
[SRDescriptionAttribute("Event raised when the window style of a Control is changed.")]
[SRCategoryAttribute("Behavior")]
public event System.EventHandler StyleChanged
Delphi
public event StyleChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Event raised when the window style of a Control is changed.")]
[SRCategoryAttribute("Behavior")]
public: __event System.EventHandler* StyleChanged
C++/CLI
[SRDescriptionAttribute("Event raised when the window style of a Control is changed.")]
[SRCategoryAttribute("Behavior")]
public:
event System.EventHandler^ StyleChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


SuspendLayout Method

[image]
Intersoft WebTextEditor Documentation
SuspendLayout Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : SuspendLayout Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SuspendLayout()
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm

instance.SuspendLayout()
C#
public void SuspendLayout()
Delphi
public procedure SuspendLayout();
JScript
public function SuspendLayout();
Managed Extensions for C++
public: void SuspendLayout();
C++/CLI
public:
void SuspendLayout();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


SystemColorsChanged Event

[image]
Intersoft WebTextEditor Documentation
SystemColorsChanged Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : SystemColorsChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Event raised when the system colors change.")>
<SRCategoryAttribute("Behavior")>
Public Event SystemColorsChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.EventHandler

AddHandler instance.SystemColorsChanged, handler
C#
[SRDescriptionAttribute("Event raised when the system colors change.")]
[SRCategoryAttribute("Behavior")]
public event System.EventHandler SystemColorsChanged
Delphi
public event SystemColorsChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Event raised when the system colors change.")]
[SRCategoryAttribute("Behavior")]
public: __event System.EventHandler* SystemColorsChanged
C++/CLI
[SRDescriptionAttribute("Event raised when the system colors change.")]
[SRCategoryAttribute("Behavior")]
public:
event System.EventHandler^ SystemColorsChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


Tag Property

[image]
Intersoft WebTextEditor Documentation
Tag Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : Tag Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.TypeConverterAttribute("System.ComponentModel.StringConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")>
<System.ComponentModel.LocalizableAttribute(False)>
<SRDescriptionAttribute("User-defined data associated with the object.")>
<System.ComponentModel.DefaultValueAttribute()>
<SRCategoryAttribute("Data")>
Public Property Tag As System.Object
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Object

instance.Tag = value

value = instance.Tag
C#
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.StringConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.LocalizableAttribute(false)]
[SRDescriptionAttribute("User-defined data associated with the object.")]
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Data")]
public System.object Tag {get; set;}
Delphi
public read-write property Tag: System.TObject;
JScript
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.TypeConverterAttribute("System.ComponentModel.StringConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")
System.ComponentModel.LocalizableAttribute()
SRDescriptionAttribute("User-defined data associated with the object.")
System.ComponentModel.DefaultValueAttribute()
SRCategoryAttribute("Data")
public function get,set Tag : System.Object
Managed Extensions for C++
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.StringConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.LocalizableAttribute(false)]
[SRDescriptionAttribute("User-defined data associated with the object.")]
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Data")]
public: __property System.Object* get_Tag();
public: __property void set_Tag(
   System.Object* value
);
C++/CLI
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.TypeConverterAttribute("System.ComponentModel.StringConverter, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089")]
[System.ComponentModel.LocalizableAttribute(false)]
[SRDescriptionAttribute("User-defined data associated with the object.")]
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Data")]
public:
property System.Object^ Tag {
   System.Object^ get();
   void set (    System.Object^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


Text Property

[image]
Intersoft WebTextEditor Documentation
Text Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : Text Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.SettingsBindableAttribute(True)>
Public Overridable Property Text As System.String
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.String

instance.Text = value

value = instance.Text
C#
[System.ComponentModel.SettingsBindableAttribute(true)]
public virtual System.string Text {get; set;}
Delphi
public read-write property Text: System.String; virtual;
JScript
System.ComponentModel.SettingsBindableAttribute()
public function get,set Text : System.String
Managed Extensions for C++
[System.ComponentModel.SettingsBindableAttribute(true)]
public: __property virtual System.string* get_Text();
public: __property virtual void set_Text(
   System.string* value
);
C++/CLI
[System.ComponentModel.SettingsBindableAttribute(true)]
public:
virtual property System.String^ Text {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


TextChanged Event

[image]
Intersoft WebTextEditor Documentation
TextChanged Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : TextChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Property Changed")>
<SRDescriptionAttribute("Event raised when the value of the Text property is changed on Control.")>
Public Event TextChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.EventHandler

AddHandler instance.TextChanged, handler
C#
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the Text property is changed on Control.")]
public event System.EventHandler TextChanged
Delphi
public event TextChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the Text property is changed on Control.")]
public: __event System.EventHandler* TextChanged
C++/CLI
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Event raised when the value of the Text property is changed on Control.")]
public:
event System.EventHandler^ TextChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


Top Property

[image]
Intersoft WebTextEditor Documentation
Top Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : Top Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("The top of the control, in container coordinates.")>
<SRCategoryAttribute("Layout")>
<System.ComponentModel.EditorBrowsableAttribute()>
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property Top As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Integer

instance.Top = value

value = instance.Top
C#
[SRDescriptionAttribute("The top of the control, in container coordinates.")]
[SRCategoryAttribute("Layout")]
[System.ComponentModel.EditorBrowsableAttribute()]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public System.int Top {get; set;}
Delphi
public read-write property Top: System.Integer;
JScript
SRDescriptionAttribute("The top of the control, in container coordinates.")
SRCategoryAttribute("Layout")
System.ComponentModel.EditorBrowsableAttribute()
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get,set Top : System.int
Managed Extensions for C++
[SRDescriptionAttribute("The top of the control, in container coordinates.")]
[SRCategoryAttribute("Layout")]
[System.ComponentModel.EditorBrowsableAttribute()]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property System.int get_Top();
public: __property void set_Top(
   System.int value
);
C++/CLI
[SRDescriptionAttribute("The top of the control, in container coordinates.")]
[SRCategoryAttribute("Layout")]
[System.ComponentModel.EditorBrowsableAttribute()]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property System.int Top {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


TopLevel Property

[image]
Intersoft WebTextEditor Documentation
TopLevel Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : TopLevel Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Property TopLevel As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Boolean

instance.TopLevel = value

value = instance.TopLevel
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public System.bool TopLevel {get; set;}
Delphi
public read-write property TopLevel: System.Boolean;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function get,set TopLevel : System.boolean
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: __property System.bool get_TopLevel();
public: __property void set_TopLevel(
   System.bool value
);
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
property System.bool TopLevel {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


TopLevelControl Property

[image]
Intersoft WebTextEditor Documentation
TopLevelControl Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : TopLevelControl Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<System.ComponentModel.BrowsableAttribute(False)>
<SRCategoryAttribute("Behavior")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<SRDescriptionAttribute("Retrieves the top-level control that contains this control.")>
Public ReadOnly Property TopLevelControl As System.Windows.Forms.Control
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Windows.Forms.Control

value = instance.TopLevelControl
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.ComponentModel.BrowsableAttribute(false)]
[SRCategoryAttribute("Behavior")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[SRDescriptionAttribute("Retrieves the top-level control that contains this control.")]
public System.Windows.Forms.Control TopLevelControl {get;}
Delphi
public read-only property TopLevelControl: System.Windows.Forms.Control;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
System.ComponentModel.BrowsableAttribute()
SRCategoryAttribute("Behavior")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
SRDescriptionAttribute("Retrieves the top-level control that contains this control.")
public function get TopLevelControl : System.Windows.Forms.Control
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.ComponentModel.BrowsableAttribute(false)]
[SRCategoryAttribute("Behavior")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[SRDescriptionAttribute("Retrieves the top-level control that contains this control.")]
public: __property System.Windows.Forms.Control* get_TopLevelControl();
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.ComponentModel.BrowsableAttribute(false)]
[SRCategoryAttribute("Behavior")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[SRDescriptionAttribute("Retrieves the top-level control that contains this control.")]
public:
property System.Windows.Forms.Control^ TopLevelControl {
   System.Windows.Forms.Control^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


TopMost Property

[image]
Intersoft WebTextEditor Documentation
TopMost Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : TopMost Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Indicates whether the form always appears above all other forms that do not have this property set to true.")>
<SRCategoryAttribute("Window Style")>
<System.ComponentModel.DefaultValueAttribute()>
Public Property TopMost As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Boolean

instance.TopMost = value

value = instance.TopMost
C#
[SRDescriptionAttribute("Indicates whether the form always appears above all other forms that do not have this property set to true.")]
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DefaultValueAttribute()]
public System.bool TopMost {get; set;}
Delphi
public read-write property TopMost: System.Boolean;
JScript
SRDescriptionAttribute("Indicates whether the form always appears above all other forms that do not have this property set to true.")
SRCategoryAttribute("Window Style")
System.ComponentModel.DefaultValueAttribute()
public function get,set TopMost : System.boolean
Managed Extensions for C++
[SRDescriptionAttribute("Indicates whether the form always appears above all other forms that do not have this property set to true.")]
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property System.bool get_TopMost();
public: __property void set_TopMost(
   System.bool value
);
C++/CLI
[SRDescriptionAttribute("Indicates whether the form always appears above all other forms that do not have this property set to true.")]
[SRCategoryAttribute("Window Style")]
[System.ComponentModel.DefaultValueAttribute()]
public:
property System.bool TopMost {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


ToString Method

[image]
Intersoft WebTextEditor Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


TransparencyKey Property

[image]
Intersoft WebTextEditor Documentation
TransparencyKey Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : TransparencyKey Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("A color which will appear transparent when painted on the form.")>
<SRCategoryAttribute("Window Style")>
Public Property TransparencyKey As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Drawing.Color

instance.TransparencyKey = value

value = instance.TransparencyKey
C#
[SRDescriptionAttribute("A color which will appear transparent when painted on the form.")]
[SRCategoryAttribute("Window Style")]
public System.Drawing.Color TransparencyKey {get; set;}
Delphi
public read-write property TransparencyKey: System.Drawing.Color;
JScript
SRDescriptionAttribute("A color which will appear transparent when painted on the form.")
SRCategoryAttribute("Window Style")
public function get,set TransparencyKey : System.Drawing.Color
Managed Extensions for C++
[SRDescriptionAttribute("A color which will appear transparent when painted on the form.")]
[SRCategoryAttribute("Window Style")]
public: __property System.Drawing.Color get_TransparencyKey();
public: __property void set_TransparencyKey(
   System.Drawing.Color value
);
C++/CLI
[SRDescriptionAttribute("A color which will appear transparent when painted on the form.")]
[SRCategoryAttribute("Window Style")]
public:
property System.Drawing.Color TransparencyKey {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


Update Method

[image]
Intersoft WebTextEditor Documentation
Update Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : Update Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub Update()
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm

instance.Update()
C#
public void Update()
Delphi
public procedure Update();
JScript
public function Update();
Managed Extensions for C++
public: void Update();
C++/CLI
public:
void Update();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


UpdateDefaultButton Method

[image]
Intersoft WebTextEditor Documentation
UpdateDefaultButton Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : UpdateDefaultButton Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub UpdateDefaultButton()
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm

instance.UpdateDefaultButton()
C#
protected virtual void UpdateDefaultButton()
Delphi
protected procedure UpdateDefaultButton(); virtual;
JScript
protected function UpdateDefaultButton();
Managed Extensions for C++
protected: virtual void UpdateDefaultButton();
C++/CLI
protected:
virtual void UpdateDefaultButton();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


UpdateStyles Method

[image]
Intersoft WebTextEditor Documentation
UpdateStyles Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : UpdateStyles Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Sub UpdateStyles()
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm

instance.UpdateStyles()
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected void UpdateStyles()
Delphi
protected procedure UpdateStyles();
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function UpdateStyles();
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: void UpdateStyles();
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
void UpdateStyles();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


UpdateZOrder Method

[image]
Intersoft WebTextEditor Documentation
UpdateZOrder Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : UpdateZOrder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Sub UpdateZOrder()
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm

instance.UpdateZOrder()
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected void UpdateZOrder()
Delphi
protected procedure UpdateZOrder();
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
protected function UpdateZOrder();
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected: void UpdateZOrder();
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected:
void UpdateZOrder();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


UseWaitCursor Property

[image]
Intersoft WebTextEditor Documentation
UseWaitCursor Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : UseWaitCursor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(True)>
<SRCategoryAttribute("Appearance")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.EditorBrowsableAttribute()>
<SRDescriptionAttribute("When this property is true, the Cursor property of the control and its child controls is set to WaitCursor.")>
Public Property UseWaitCursor As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Boolean

instance.UseWaitCursor = value

value = instance.UseWaitCursor
C#
[System.ComponentModel.BrowsableAttribute(true)]
[SRCategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.EditorBrowsableAttribute()]
[SRDescriptionAttribute("When this property is true, the Cursor property of the control and its child controls is set to WaitCursor.")]
public System.bool UseWaitCursor {get; set;}
Delphi
public read-write property UseWaitCursor: System.Boolean;
JScript
System.ComponentModel.BrowsableAttribute()
SRCategoryAttribute("Appearance")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.EditorBrowsableAttribute()
SRDescriptionAttribute("When this property is true, the Cursor property of the control and its child controls is set to WaitCursor.")
public function get,set UseWaitCursor : System.boolean
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(true)]
[SRCategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.EditorBrowsableAttribute()]
[SRDescriptionAttribute("When this property is true, the Cursor property of the control and its child controls is set to WaitCursor.")]
public: __property System.bool get_UseWaitCursor();
public: __property void set_UseWaitCursor(
   System.bool value
);
C++/CLI
[System.ComponentModel.BrowsableAttribute(true)]
[SRCategoryAttribute("Appearance")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.EditorBrowsableAttribute()]
[SRDescriptionAttribute("When this property is true, the Cursor property of the control and its child controls is set to WaitCursor.")]
public:
property System.bool UseWaitCursor {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


Validate Method

[image]
Intersoft WebTextEditor Documentation
Validate Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : Validate Method

Glossary Item Box

Overload List

Overload | Description
Validate() | (Inherited from System.Windows.Forms.ContainerControl)
Validate(Boolean) | (Inherited from System.Windows.Forms.ContainerControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


Validate() Method

[image]
Intersoft WebTextEditor Documentation
Validate() Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class > Validate Method : Validate() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function Validate() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Boolean

value = instance.Validate()
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.bool Validate()
Delphi
public function Validate(): System.Boolean;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function Validate() : System.boolean;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.bool Validate();
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.bool Validate();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members
Overload List


Validate(Boolean) Method

[image]
Intersoft WebTextEditor Documentation
Validate(Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class > Validate Method : Validate(Boolean) Method

checkAutoValidate

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function Validate( _
   ByVal checkAutoValidate As System.Boolean _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim checkAutoValidate As System.Boolean
Dim value As System.Boolean

value = instance.Validate(checkAutoValidate)
C#
public System.bool Validate(
   System.bool checkAutoValidate
)
Delphi
public function Validate(
    checkAutoValidate: System.Boolean
): System.Boolean;
JScript
public function Validate(
   checkAutoValidate : System.boolean
) : System.boolean;
Managed Extensions for C++
public: System.bool Validate(
   System.bool checkAutoValidate
)
C++/CLI
public:
System.bool Validate(
   System.bool checkAutoValidate
)

Parameters

checkAutoValidate

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members
Overload List


ValidateChildren Method

[image]
Intersoft WebTextEditor Documentation
ValidateChildren Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : ValidateChildren Method

Glossary Item Box

Overload List

Overload | Description
ValidateChildren() | (Inherited from System.Windows.Forms.Form)
ValidateChildren(ValidationConstraints) | (Inherited from System.Windows.Forms.Form)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


ValidateChildren() Method

[image]
Intersoft WebTextEditor Documentation
ValidateChildren() Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class > ValidateChildren Method : ValidateChildren() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(True)>
<System.ComponentModel.EditorBrowsableAttribute()>
Public Overloads Overridable Function ValidateChildren() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Boolean

value = instance.ValidateChildren()
C#
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.EditorBrowsableAttribute()]
public virtual System.bool ValidateChildren()
Delphi
public function ValidateChildren(): System.Boolean; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.EditorBrowsableAttribute()
public function ValidateChildren() : System.boolean;
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.EditorBrowsableAttribute()]
public: virtual System.bool ValidateChildren();
C++/CLI
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.EditorBrowsableAttribute()]
public:
virtual System.bool ValidateChildren();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members
Overload List


ValidateChildren(ValidationConstraints) Method

[image]
Intersoft WebTextEditor Documentation
ValidateChildren(ValidationConstraints) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class > ValidateChildren Method : ValidateChildren(ValidationConstraints) Method

validationConstraints

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(True)>
<System.ComponentModel.EditorBrowsableAttribute()>
Public Overloads Overridable Function ValidateChildren( _
   ByVal validationConstraints As System.Windows.Forms.ValidationConstraints _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim validationConstraints As System.Windows.Forms.ValidationConstraints
Dim value As System.Boolean

value = instance.ValidateChildren(validationConstraints)
C#
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.EditorBrowsableAttribute()]
public virtual System.bool ValidateChildren(
   System.Windows.Forms.ValidationConstraints validationConstraints
)
Delphi
public function ValidateChildren(
    validationConstraints: System.Windows.Forms.ValidationConstraints
): System.Boolean; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.EditorBrowsableAttribute()
public function ValidateChildren(
   validationConstraints : System.Windows.Forms.ValidationConstraints
) : System.boolean;
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.EditorBrowsableAttribute()]
public: virtual System.bool ValidateChildren(
   System.Windows.Forms.ValidationConstraints validationConstraints
)
C++/CLI
[System.ComponentModel.BrowsableAttribute(true)]
[System.ComponentModel.EditorBrowsableAttribute()]
public:
virtual System.bool ValidateChildren(
   System.Windows.Forms.ValidationConstraints validationConstraints
)

Parameters

validationConstraints

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members
Overload List


Validated Event

[image]
Intersoft WebTextEditor Documentation
Validated Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : Validated Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs after a control has been successfully validated.")>
<SRCategoryAttribute("Focus")>
Public Event Validated As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.EventHandler

AddHandler instance.Validated, handler
C#
[SRDescriptionAttribute("Occurs after a control has been successfully validated.")]
[SRCategoryAttribute("Focus")]
public event System.EventHandler Validated
Delphi
public event Validated: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs after a control has been successfully validated.")]
[SRCategoryAttribute("Focus")]
public: __event System.EventHandler* Validated
C++/CLI
[SRDescriptionAttribute("Occurs after a control has been successfully validated.")]
[SRCategoryAttribute("Focus")]
public:
event System.EventHandler^ Validated

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


Validating Event

[image]
Intersoft WebTextEditor Documentation
Validating Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : Validating Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Occurs when the control is validating.")>
<SRCategoryAttribute("Focus")>
Public Event Validating As System.ComponentModel.CancelEventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.ComponentModel.CancelEventHandler

AddHandler instance.Validating, handler
C#
[SRDescriptionAttribute("Occurs when the control is validating.")]
[SRCategoryAttribute("Focus")]
public event System.ComponentModel.CancelEventHandler Validating
Delphi
public event Validating: System.ComponentModel.CancelEventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRDescriptionAttribute("Occurs when the control is validating.")]
[SRCategoryAttribute("Focus")]
public: __event System.ComponentModel.CancelEventHandler* Validating
C++/CLI
[SRDescriptionAttribute("Occurs when the control is validating.")]
[SRCategoryAttribute("Focus")]
public:
event System.ComponentModel.CancelEventHandler^ Validating

Event Data

The event handler receives an argument of type System.ComponentModel.CancelEventArgs containing data related to this event. The following CancelEventArgs properties provide information specific to this event.

Property | Description
Cancel |

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


VerticalScroll Property

[image]
Intersoft WebTextEditor Documentation
VerticalScroll Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : VerticalScroll Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Gets the vertical scroll bar for this ScrollableControl.")>
<System.ComponentModel.EditorBrowsableAttribute()>
<SRCategoryAttribute("Layout")>
<System.ComponentModel.BrowsableAttribute(False)>
Public ReadOnly Property VerticalScroll As System.Windows.Forms.VScrollProperties
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Windows.Forms.VScrollProperties

value = instance.VerticalScroll
C#
[SRDescriptionAttribute("Gets the vertical scroll bar for this ScrollableControl.")]
[System.ComponentModel.EditorBrowsableAttribute()]
[SRCategoryAttribute("Layout")]
[System.ComponentModel.BrowsableAttribute(false)]
public System.Windows.Forms.VScrollProperties VerticalScroll {get;}
Delphi
public read-only property VerticalScroll: System.Windows.Forms.VScrollProperties;
JScript
SRDescriptionAttribute("Gets the vertical scroll bar for this ScrollableControl.")
System.ComponentModel.EditorBrowsableAttribute()
SRCategoryAttribute("Layout")
System.ComponentModel.BrowsableAttribute()
public function get VerticalScroll : System.Windows.Forms.VScrollProperties
Managed Extensions for C++
[SRDescriptionAttribute("Gets the vertical scroll bar for this ScrollableControl.")]
[System.ComponentModel.EditorBrowsableAttribute()]
[SRCategoryAttribute("Layout")]
[System.ComponentModel.BrowsableAttribute(false)]
public: __property System.Windows.Forms.VScrollProperties* get_VerticalScroll();
C++/CLI
[SRDescriptionAttribute("Gets the vertical scroll bar for this ScrollableControl.")]
[System.ComponentModel.EditorBrowsableAttribute()]
[SRCategoryAttribute("Layout")]
[System.ComponentModel.BrowsableAttribute(false)]
public:
property System.Windows.Forms.VScrollProperties^ VerticalScroll {
   System.Windows.Forms.VScrollProperties^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


Visible Property

[image]
Intersoft WebTextEditor Documentation
Visible Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : Visible Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRDescriptionAttribute("Determines whether the control is visible or hidden.")>
<System.ComponentModel.LocalizableAttribute(True)>
<SRCategoryAttribute("Behavior")>
Public Property Visible As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Boolean

instance.Visible = value

value = instance.Visible
C#
[SRDescriptionAttribute("Determines whether the control is visible or hidden.")]
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Behavior")]
public System.bool Visible {get; set;}
Delphi
public read-write property Visible: System.Boolean;
JScript
SRDescriptionAttribute("Determines whether the control is visible or hidden.")
System.ComponentModel.LocalizableAttribute()
SRCategoryAttribute("Behavior")
public function get,set Visible : System.boolean
Managed Extensions for C++
[SRDescriptionAttribute("Determines whether the control is visible or hidden.")]
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Behavior")]
public: __property System.bool get_Visible();
public: __property void set_Visible(
   System.bool value
);
C++/CLI
[SRDescriptionAttribute("Determines whether the control is visible or hidden.")]
[System.ComponentModel.LocalizableAttribute(true)]
[SRCategoryAttribute("Behavior")]
public:
property System.bool Visible {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


VisibleChanged Event

[image]
Intersoft WebTextEditor Documentation
VisibleChanged Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : VisibleChanged Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<SRCategoryAttribute("Property Changed")>
<SRDescriptionAttribute("Occurs when the control's visibility changes.")>
Public Event VisibleChanged As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim handler As System.EventHandler

AddHandler instance.VisibleChanged, handler
C#
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the control's visibility changes.")]
public event System.EventHandler VisibleChanged
Delphi
public event VisibleChanged: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the control's visibility changes.")]
public: __event System.EventHandler* VisibleChanged
C++/CLI
[SRCategoryAttribute("Property Changed")]
[SRDescriptionAttribute("Occurs when the control's visibility changes.")]
public:
event System.EventHandler^ VisibleChanged

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


VScroll Property

[image]
Intersoft WebTextEditor Documentation
VScroll Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : VScroll Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Property VScroll As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Boolean

instance.VScroll = value

value = instance.VScroll
C#
protected System.bool VScroll {get; set;}
Delphi
protected read-write property VScroll: System.Boolean;
JScript
protected function get,set VScroll : System.boolean
Managed Extensions for C++
protected: __property System.bool get_VScroll();
protected: __property void set_VScroll(
   System.bool value
);
C++/CLI
protected:
property System.bool VScroll {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


Width Property

[image]
Intersoft WebTextEditor Documentation
Width Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : Width Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute()>
<SRDescriptionAttribute("The width of the control, in container coordinates.")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
<SRCategoryAttribute("Layout")>
Public Property Width As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Integer

instance.Width = value

value = instance.Width
C#
[System.ComponentModel.EditorBrowsableAttribute()]
[SRDescriptionAttribute("The width of the control, in container coordinates.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[SRCategoryAttribute("Layout")]
public System.int Width {get; set;}
Delphi
public read-write property Width: System.Integer;
JScript
System.ComponentModel.EditorBrowsableAttribute()
SRDescriptionAttribute("The width of the control, in container coordinates.")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
SRCategoryAttribute("Layout")
public function get,set Width : System.int
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute()]
[SRDescriptionAttribute("The width of the control, in container coordinates.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[SRCategoryAttribute("Layout")]
public: __property System.int get_Width();
public: __property void set_Width(
   System.int value
);
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute()]
[SRDescriptionAttribute("The width of the control, in container coordinates.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[SRCategoryAttribute("Layout")]
public:
property System.int Width {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


WindowState Property

[image]
Intersoft WebTextEditor Documentation
WindowState Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : WindowState Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<SRCategoryAttribute("Layout")>
<SRDescriptionAttribute("Determines the initial visual state of the form.")>
Public Property WindowState As System.Windows.Forms.FormWindowState
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim value As System.Windows.Forms.FormWindowState

instance.WindowState = value

value = instance.WindowState
C#
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Determines the initial visual state of the form.")]
public System.Windows.Forms.FormWindowState WindowState {get; set;}
Delphi
public read-write property WindowState: System.Windows.Forms.FormWindowState;
JScript
System.ComponentModel.DefaultValueAttribute()
SRCategoryAttribute("Layout")
SRDescriptionAttribute("Determines the initial visual state of the form.")
public function get,set WindowState : System.Windows.Forms.FormWindowState
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Determines the initial visual state of the form.")]
public: __property System.Windows.Forms.FormWindowState get_WindowState();
public: __property void set_WindowState(
   System.Windows.Forms.FormWindowState value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[SRCategoryAttribute("Layout")]
[SRDescriptionAttribute("Determines the initial visual state of the form.")]
public:
property System.Windows.Forms.FormWindowState WindowState {
   System.Windows.Forms.FormWindowState get();
   void set (    System.Windows.Forms.FormWindowState value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


WndProc Method

[image]
Intersoft WebTextEditor Documentation
WndProc Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > ImageListForm Class : WndProc Method

m

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=False,
   UnmanagedCode=True,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=False,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand Or  _
    SecurityAction.Deny Or  _
    SecurityAction.LinkDemand,
   Unrestricted=False)>
Protected Overridable Sub WndProc( _
   ByRef m As System.Windows.Forms.Message _
)
Visual Basic (Usage) Copy Code
Dim instance As ImageListForm
Dim m As System.Windows.Forms.Message

instance.WndProc(m)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
protected virtual void WndProc(
   ref System.Windows.Forms.Message m
)
Delphi
protected procedure WndProc(
   var  m: System.Windows.Forms.Message
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=)
protected function WndProc(
   m : System.Windows.Forms.Message
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
protected: virtual void WndProc(
   ref System.Windows.Forms.Message m
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.UnmanagedCode,
   Assertion=false,
   UnmanagedCode=true,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand |
    SecurityAction.Deny |
    SecurityAction.LinkDemand,
   Unrestricted=false)]
protected:
virtual void WndProc(
   System.Windows.Forms.Message% m
)

Parameters

m

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageListForm Class
ImageListForm Members


SerializableList<T> Class Properties

[image]
Intersoft WebTextEditor Documentation
SerializableList<T> Class Properties
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : SerializableList<T> Class

Glossary Item Box

For a list of all members of this type, see SerializableList<T> members.

Public Properties

 | Name | Description
Public Property | Capacity | (Inherited from System.Collections.Generic.List<T>)
Public Property | Count | (Inherited from System.Collections.Generic.List<T>)
Public Property | Item | (Inherited from System.Collections.Generic.List<T>)
Top

See Also

Reference

SerializableList<T> Class
ISNet.WebUI.WebTextEditor Namespace


Add Method

[image]
Intersoft WebTextEditor Documentation
Add Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > SerializableList<T> Class : Add Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Sub Add( _
   ByVal item As T _
)
Visual Basic (Usage) Copy Code
Dim instance As SerializableList(Of T)
Dim item As T

instance.Add(item)
C#
[__DynamicallyInvokableAttribute()]
public void Add(
   T item
)
Delphi
public procedure Add(
    item: T
);
JScript
__DynamicallyInvokableAttribute()
public function Add(
   item : T
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void Add(
   T* item
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void Add(
   T^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializableList<T> Class
SerializableList<T> Members


AddRange Method

[image]
Intersoft WebTextEditor Documentation
AddRange Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > SerializableList<T> Class : AddRange Method

collection

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Sub AddRange( _
   ByVal collection As System.Collections.Generic.IEnumerable(Of T) _
)
Visual Basic (Usage) Copy Code
Dim instance As SerializableList(Of T)
Dim collection As System.Collections.Generic.IEnumerable(Of T)

instance.AddRange(collection)
C#
[__DynamicallyInvokableAttribute()]
public void AddRange(
   System.Collections.Generic.IEnumerable<T> collection
)
Delphi
public procedure AddRange(
    collection: System.Collections.Generic.IEnumerable
);
JScript
__DynamicallyInvokableAttribute()
public function AddRange(
   collection : System.Collections.Generic.IEnumerable
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void AddRange(
   System.Collections.Generic.IEnumerable<T*>* collection
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void AddRange(
   System.Collections.Generic.IEnumerable<T^>^ collection
)

Parameters

collection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializableList<T> Class
SerializableList<T> Members


AsReadOnly Method

[image]
Intersoft WebTextEditor Documentation
AsReadOnly Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > SerializableList<T> Class : AsReadOnly Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function AsReadOnly() As System.Collections.ObjectModel.ReadOnlyCollection(Of T)
Visual Basic (Usage) Copy Code
Dim instance As SerializableList(Of T)
Dim value As System.Collections.ObjectModel.ReadOnlyCollection(Of T)

value = instance.AsReadOnly()
C#
public System.Collections.ObjectModel.ReadOnlyCollection<T> AsReadOnly()
Delphi
public function AsReadOnly(): System.Collections.ObjectModel.ReadOnlyCollection;
JScript
public function AsReadOnly() : System.Collections.ObjectModel.ReadOnlyCollection;
Managed Extensions for C++
public: System.Collections.ObjectModel.ReadOnlyCollection<T*>* AsReadOnly();
C++/CLI
public:
System.Collections.ObjectModel.ReadOnlyCollection<T^>^ AsReadOnly();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializableList<T> Class
SerializableList<T> Members


BinarySearch Method

[image]
Intersoft WebTextEditor Documentation
BinarySearch Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > SerializableList<T> Class : BinarySearch Method

Glossary Item Box

Overload List

Overload | Description
BinarySearch(Int32,Int32,T,IComparer<T>) | (Inherited from System.Collections.Generic.List<T>)
BinarySearch(T) | (Inherited from System.Collections.Generic.List<T>)
BinarySearch(T,IComparer<T>) | (Inherited from System.Collections.Generic.List<T>)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializableList<T> Class
SerializableList<T> Members


BinarySearch(T) Method

[image]
Intersoft WebTextEditor Documentation
BinarySearch(T) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > SerializableList<T> Class > BinarySearch Method : BinarySearch(T) Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Overloads Function BinarySearch( _
   ByVal item As T _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As SerializableList(Of T)
Dim item As T
Dim value As System.Integer

value = instance.BinarySearch(item)
C#
[__DynamicallyInvokableAttribute()]
public System.int BinarySearch(
   T item
)
Delphi
public function BinarySearch(
    item: T
): System.Integer;
JScript
__DynamicallyInvokableAttribute()
public function BinarySearch(
   item : T
) : System.int;
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: System.int BinarySearch(
   T* item
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
System.int BinarySearch(
   T^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializableList<T> Class
SerializableList<T> Members
Overload List


BinarySearch(T,IComparer<T>) Method

[image]
Intersoft WebTextEditor Documentation
BinarySearch(T,IComparer<T>) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > SerializableList<T> Class > BinarySearch Method : BinarySearch(T,IComparer<T>) Method

item
comparer

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Overloads Function BinarySearch( _
   ByVal item As T, _
   ByVal comparer As System.Collections.Generic.IComparer(Of T) _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As SerializableList(Of T)
Dim item As T
Dim comparer As System.Collections.Generic.IComparer(Of T)
Dim value As System.Integer

value = instance.BinarySearch(item, comparer)
C#
[__DynamicallyInvokableAttribute()]
public System.int BinarySearch(
   T item,
   System.Collections.Generic.IComparer<T> comparer
)
Delphi
public function BinarySearch(
    item: T;
    comparer: System.Collections.Generic.IComparer
): System.Integer;
JScript
__DynamicallyInvokableAttribute()
public function BinarySearch(
   item : T,
   comparer : System.Collections.Generic.IComparer
) : System.int;
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: System.int BinarySearch(
   T* item,
   System.Collections.Generic.IComparer<T*>* comparer
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
System.int BinarySearch(
   T^ item,
   System.Collections.Generic.IComparer<T^>^ comparer
)

Parameters

item
comparer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializableList<T> Class
SerializableList<T> Members
Overload List


BinarySearch(Int32,Int32,T,IComparer<T>) Method

[image]
Intersoft WebTextEditor Documentation
BinarySearch(Int32,Int32,T,IComparer<T>) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > SerializableList<T> Class > BinarySearch Method : BinarySearch(Int32,Int32,T,IComparer<T>) Method

index
count
item
comparer

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Overloads Function BinarySearch( _
   ByVal index As System.Integer, _
   ByVal count As System.Integer, _
   ByVal item As T, _
   ByVal comparer As System.Collections.Generic.IComparer(Of T) _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As SerializableList(Of T)
Dim index As System.Integer
Dim count As System.Integer
Dim item As T
Dim comparer As System.Collections.Generic.IComparer(Of T)
Dim value As System.Integer

value = instance.BinarySearch(index, count, item, comparer)
C#
[__DynamicallyInvokableAttribute()]
public System.int BinarySearch(
   System.int index,
   System.int count,
   T item,
   System.Collections.Generic.IComparer<T> comparer
)
Delphi
public function BinarySearch(
    index: System.Integer;
    count: System.Integer;
    item: T;
    comparer: System.Collections.Generic.IComparer
): System.Integer;
JScript
__DynamicallyInvokableAttribute()
public function BinarySearch(
   index : System.int,
   count : System.int,
   item : T,
   comparer : System.Collections.Generic.IComparer
) : System.int;
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: System.int BinarySearch(
   System.int index,
   System.int count,
   T* item,
   System.Collections.Generic.IComparer<T*>* comparer
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
System.int BinarySearch(
   System.int index,
   System.int count,
   T^ item,
   System.Collections.Generic.IComparer<T^>^ comparer
)

Parameters

index
count
item
comparer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializableList<T> Class
SerializableList<T> Members
Overload List


Capacity Property

[image]
Intersoft WebTextEditor Documentation
Capacity Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > SerializableList<T> Class : Capacity Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Property Capacity As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As SerializableList(Of T)
Dim value As System.Integer

instance.Capacity = value

value = instance.Capacity
C#
[__DynamicallyInvokableAttribute()]
public System.int Capacity {get; set;}
Delphi
public read-write property Capacity: System.Integer;
JScript
__DynamicallyInvokableAttribute()
public function get,set Capacity : System.int
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: __property System.int get_Capacity();
public: __property void set_Capacity(
   System.int value
);
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
property System.int Capacity {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializableList<T> Class
SerializableList<T> Members


Clear Method

[image]
Intersoft WebTextEditor Documentation
Clear Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > SerializableList<T> Class : Clear Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As SerializableList(Of T)

instance.Clear()
C#
[__DynamicallyInvokableAttribute()]
public void Clear()
Delphi
public procedure Clear();
JScript
__DynamicallyInvokableAttribute()
public function Clear();
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void Clear();
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void Clear();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializableList<T> Class
SerializableList<T> Members


Contains Method

[image]
Intersoft WebTextEditor Documentation
Contains Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > SerializableList<T> Class : Contains Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Function Contains( _
   ByVal item As T _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As SerializableList(Of T)
Dim item As T
Dim value As System.Boolean

value = instance.Contains(item)
C#
[__DynamicallyInvokableAttribute()]
public System.bool Contains(
   T item
)
Delphi
public function Contains(
    item: T
): System.Boolean;
JScript
__DynamicallyInvokableAttribute()
public function Contains(
   item : T
) : System.boolean;
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: System.bool Contains(
   T* item
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
System.bool Contains(
   T^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializableList<T> Class
SerializableList<T> Members


ConvertAll<TOutput> Method

TOutput
[image]
Intersoft WebTextEditor Documentation
ConvertAll<TOutput> Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > SerializableList<T> Class : ConvertAll<TOutput> Method

converter

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ConvertAll(Of TOutput)( _
   ByVal converter As System.Converter(Of T,TOutput) _
) As System.Collections.Generic.List(Of TOutput)
Visual Basic (Usage) Copy Code
Dim instance As SerializableList(Of T)
Dim converter As System.Converter(Of T,TOutput)
Dim value As System.Collections.Generic.List(Of TOutput)

value = instance.ConvertAll(Of TOutput)(converter)
C#
public System.Collections.Generic.List<TOutput> ConvertAll<TOutput>(
   System.Converter<T,TOutput> converter
)
Delphi
public function ConvertAll(
    converter: System.Converter
): System.Collections.Generic.List;
JScript
public function ConvertAll(
   converter : System.Converter
) : System.Collections.Generic.List;
Managed Extensions for C++
public: System.Collections.Generic.List<TOutput*>* ConvertAll<TOutput>(
   System.Converter<T*,TOutput*>* converter
)
C++/CLI
public:
System.Collections.Generic.List<TOutput^>^ ConvertAllgeneric<typename TOutput>
(
   System.Converter<T^,TOutput^>^ converter
)

Parameters

converter

Type Parameters

TOutput

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializableList<T> Class
SerializableList<T> Members


CopyTo Method

[image]
Intersoft WebTextEditor Documentation
CopyTo Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > SerializableList<T> Class : CopyTo Method

Glossary Item Box

Overload List

Overload | Description
CopyTo(T[]) | (Inherited from System.Collections.Generic.List<T>)
CopyTo(Int32,T[],Int32,Int32) | (Inherited from System.Collections.Generic.List<T>)
CopyTo(T[],Int32) | (Inherited from System.Collections.Generic.List<T>)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializableList<T> Class
SerializableList<T> Members


CopyTo(T[]) Method

[image]
Intersoft WebTextEditor Documentation
CopyTo(T[]) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > SerializableList<T> Class > CopyTo Method : CopyTo(T[]) Method

array

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
<__DynamicallyInvokableAttribute()>
Public Overloads Sub CopyTo( _
   ByVal array() As T _
)
Visual Basic (Usage) Copy Code
Dim instance As SerializableList(Of T)
Dim array() As T

instance.CopyTo(array)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public void CopyTo(
   T[] array
)
Delphi
public procedure CopyTo(
    array: Tarray of
);
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
__DynamicallyInvokableAttribute()
public function CopyTo(
   array : T[]
);
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public: void CopyTo(
   T*[]* array
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public:
void CopyTo(
   array<T^>^ array
)

Parameters

array

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializableList<T> Class
SerializableList<T> Members
Overload List


CopyTo(T[],Int32) Method

[image]
Intersoft WebTextEditor Documentation
CopyTo(T[],Int32) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > SerializableList<T> Class > CopyTo Method : CopyTo(T[],Int32) Method

array
arrayIndex

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Overloads Sub CopyTo( _
   ByVal array() As T, _
   ByVal arrayIndex As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As SerializableList(Of T)
Dim array() As T
Dim arrayIndex As System.Integer

instance.CopyTo(array, arrayIndex)
C#
[__DynamicallyInvokableAttribute()]
public void CopyTo(
   T[] array,
   System.int arrayIndex
)
Delphi
public procedure CopyTo(
    array: Tarray of;
    arrayIndex: System.Integer
);
JScript
__DynamicallyInvokableAttribute()
public function CopyTo(
   array : T[],
   arrayIndex : System.int
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void CopyTo(
   T*[]* array,
   System.int arrayIndex
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void CopyTo(
   array<T^>^ array,
   System.int arrayIndex
)

Parameters

array
arrayIndex

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializableList<T> Class
SerializableList<T> Members
Overload List


CopyTo(Int32,T[],Int32,Int32) Method

[image]
Intersoft WebTextEditor Documentation
CopyTo(Int32,T[],Int32,Int32) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > SerializableList<T> Class > CopyTo Method : CopyTo(Int32,T[],Int32,Int32) Method

index
array
arrayIndex
count

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Overloads Sub CopyTo( _
   ByVal index As System.Integer, _
   ByVal array() As T, _
   ByVal arrayIndex As System.Integer, _
   ByVal count As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As SerializableList(Of T)
Dim index As System.Integer
Dim array() As T
Dim arrayIndex As System.Integer
Dim count As System.Integer

instance.CopyTo(index, array, arrayIndex, count)
C#
[__DynamicallyInvokableAttribute()]
public void CopyTo(
   System.int index,
   T[] array,
   System.int arrayIndex,
   System.int count
)
Delphi
public procedure CopyTo(
    index: System.Integer;
    array: Tarray of;
    arrayIndex: System.Integer;
    count: System.Integer
);
JScript
__DynamicallyInvokableAttribute()
public function CopyTo(
   index : System.int,
   array : T[],
   arrayIndex : System.int,
   count : System.int
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void CopyTo(
   System.int index,
   T*[]* array,
   System.int arrayIndex,
   System.int count
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void CopyTo(
   System.int index,
   array<T^>^ array,
   System.int arrayIndex,
   System.int count
)

Parameters

index
array
arrayIndex
count

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializableList<T> Class
SerializableList<T> Members
Overload List


Count Property

[image]
Intersoft WebTextEditor Documentation
Count Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > SerializableList<T> Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public ReadOnly Property Count As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As SerializableList(Of T)
Dim value As System.Integer

value = instance.Count
C#
[__DynamicallyInvokableAttribute()]
public System.int Count {get;}
Delphi
public read-only property Count: System.Integer;
JScript
__DynamicallyInvokableAttribute()
public function get Count : System.int
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: __property System.int get_Count();
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
property System.int Count {
   System.int get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializableList<T> Class
SerializableList<T> Members


Exists Method

[image]
Intersoft WebTextEditor Documentation
Exists Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > SerializableList<T> Class : Exists Method

match

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Function Exists( _
   ByVal match As System.Predicate(Of T) _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As SerializableList(Of T)
Dim match As System.Predicate(Of T)
Dim value As System.Boolean

value = instance.Exists(match)
C#
[__DynamicallyInvokableAttribute()]
public System.bool Exists(
   System.Predicate<T> match
)
Delphi
public function Exists(
    match: System.Predicate
): System.Boolean;
JScript
__DynamicallyInvokableAttribute()
public function Exists(
   match : System.Predicate
) : System.boolean;
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: System.bool Exists(
   System.Predicate<T*>* match
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
System.bool Exists(
   System.Predicate<T^>^ match
)

Parameters

match

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializableList<T> Class
SerializableList<T> Members


Find Method

[image]
Intersoft WebTextEditor Documentation
Find Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > SerializableList<T> Class : Find Method

match

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Function Find( _
   ByVal match As System.Predicate(Of T) _
) As T
Visual Basic (Usage) Copy Code
Dim instance As SerializableList(Of T)
Dim match As System.Predicate(Of T)
Dim value As T

value = instance.Find(match)
C#
[__DynamicallyInvokableAttribute()]
public T Find(
   System.Predicate<T> match
)
Delphi
public function Find(
    match: System.Predicate
): T;
JScript
__DynamicallyInvokableAttribute()
public function Find(
   match : System.Predicate
) : T;
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: T* Find(
   System.Predicate<T*>* match
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
T^ Find(
   System.Predicate<T^>^ match
)

Parameters

match

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializableList<T> Class
SerializableList<T> Members


FindAll Method

[image]
Intersoft WebTextEditor Documentation
FindAll Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > SerializableList<T> Class : FindAll Method

match

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Function FindAll( _
   ByVal match As System.Predicate(Of T) _
) As System.Collections.Generic.List(Of T)
Visual Basic (Usage) Copy Code
Dim instance As SerializableList(Of T)
Dim match As System.Predicate(Of T)
Dim value As System.Collections.Generic.List(Of T)

value = instance.FindAll(match)
C#
[__DynamicallyInvokableAttribute()]
public System.Collections.Generic.List<T> FindAll(
   System.Predicate<T> match
)
Delphi
public function FindAll(
    match: System.Predicate
): System.Collections.Generic.List;
JScript
__DynamicallyInvokableAttribute()
public function FindAll(
   match : System.Predicate
) : System.Collections.Generic.List;
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: System.Collections.Generic.List<T*>* FindAll(
   System.Predicate<T*>* match
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
System.Collections.Generic.List<T^>^ FindAll(
   System.Predicate<T^>^ match
)

Parameters

match

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializableList<T> Class
SerializableList<T> Members


FindIndex Method

[image]
Intersoft WebTextEditor Documentation
FindIndex Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > SerializableList<T> Class : FindIndex Method

Glossary Item Box

Overload List

Overload | Description
FindIndex(Predicate<T>) | (Inherited from System.Collections.Generic.List<T>)
FindIndex(Int32,Predicate<T>) | (Inherited from System.Collections.Generic.List<T>)
FindIndex(Int32,Int32,Predicate<T>) | (Inherited from System.Collections.Generic.List<T>)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializableList<T> Class
SerializableList<T> Members


FindIndex(Int32,Int32,Predicate<T>) Method

[image]
Intersoft WebTextEditor Documentation
FindIndex(Int32,Int32,Predicate<T>) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > SerializableList<T> Class > FindIndex Method : FindIndex(Int32,Int32,Predicate<T>) Method

startIndex
count
match

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Overloads Function FindIndex( _
   ByVal startIndex As System.Integer, _
   ByVal count As System.Integer, _
   ByVal match As System.Predicate(Of T) _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As SerializableList(Of T)
Dim startIndex As System.Integer
Dim count As System.Integer
Dim match As System.Predicate(Of T)
Dim value As System.Integer

value = instance.FindIndex(startIndex, count, match)
C#
[__DynamicallyInvokableAttribute()]
public System.int FindIndex(
   System.int startIndex,
   System.int count,
   System.Predicate<T> match
)
Delphi
public function FindIndex(
    startIndex: System.Integer;
    count: System.Integer;
    match: System.Predicate
): System.Integer;
JScript
__DynamicallyInvokableAttribute()
public function FindIndex(
   startIndex : System.int,
   count : System.int,
   match : System.Predicate
) : System.int;
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: System.int FindIndex(
   System.int startIndex,
   System.int count,
   System.Predicate<T*>* match
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
System.int FindIndex(
   System.int startIndex,
   System.int count,
   System.Predicate<T^>^ match
)

Parameters

startIndex
count
match

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializableList<T> Class
SerializableList<T> Members
Overload List


FindIndex(Int32,Predicate<T>) Method

[image]
Intersoft WebTextEditor Documentation
FindIndex(Int32,Predicate<T>) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > SerializableList<T> Class > FindIndex Method : FindIndex(Int32,Predicate<T>) Method

startIndex
match

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Overloads Function FindIndex( _
   ByVal startIndex As System.Integer, _
   ByVal match As System.Predicate(Of T) _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As SerializableList(Of T)
Dim startIndex As System.Integer
Dim match As System.Predicate(Of T)
Dim value As System.Integer

value = instance.FindIndex(startIndex, match)
C#
[__DynamicallyInvokableAttribute()]
public System.int FindIndex(
   System.int startIndex,
   System.Predicate<T> match
)
Delphi
public function FindIndex(
    startIndex: System.Integer;
    match: System.Predicate
): System.Integer;
JScript
__DynamicallyInvokableAttribute()
public function FindIndex(
   startIndex : System.int,
   match : System.Predicate
) : System.int;
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: System.int FindIndex(
   System.int startIndex,
   System.Predicate<T*>* match
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
System.int FindIndex(
   System.int startIndex,
   System.Predicate<T^>^ match
)

Parameters

startIndex
match

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializableList<T> Class
SerializableList<T> Members
Overload List


FindIndex(Predicate<T>) Method

[image]
Intersoft WebTextEditor Documentation
FindIndex(Predicate<T>) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > SerializableList<T> Class > FindIndex Method : FindIndex(Predicate<T>) Method

match

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Overloads Function FindIndex( _
   ByVal match As System.Predicate(Of T) _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As SerializableList(Of T)
Dim match As System.Predicate(Of T)
Dim value As System.Integer

value = instance.FindIndex(match)
C#
[__DynamicallyInvokableAttribute()]
public System.int FindIndex(
   System.Predicate<T> match
)
Delphi
public function FindIndex(
    match: System.Predicate
): System.Integer;
JScript
__DynamicallyInvokableAttribute()
public function FindIndex(
   match : System.Predicate
) : System.int;
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: System.int FindIndex(
   System.Predicate<T*>* match
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
System.int FindIndex(
   System.Predicate<T^>^ match
)

Parameters

match

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializableList<T> Class
SerializableList<T> Members
Overload List


FindLast Method

[image]
Intersoft WebTextEditor Documentation
FindLast Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > SerializableList<T> Class : FindLast Method

match

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Function FindLast( _
   ByVal match As System.Predicate(Of T) _
) As T
Visual Basic (Usage) Copy Code
Dim instance As SerializableList(Of T)
Dim match As System.Predicate(Of T)
Dim value As T

value = instance.FindLast(match)
C#
[__DynamicallyInvokableAttribute()]
public T FindLast(
   System.Predicate<T> match
)
Delphi
public function FindLast(
    match: System.Predicate
): T;
JScript
__DynamicallyInvokableAttribute()
public function FindLast(
   match : System.Predicate
) : T;
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: T* FindLast(
   System.Predicate<T*>* match
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
T^ FindLast(
   System.Predicate<T^>^ match
)

Parameters

match

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializableList<T> Class
SerializableList<T> Members


FindLastIndex Method

[image]
Intersoft WebTextEditor Documentation
FindLastIndex Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > SerializableList<T> Class : FindLastIndex Method

Glossary Item Box

Overload List

Overload | Description
FindLastIndex(Predicate<T>) | (Inherited from System.Collections.Generic.List<T>)
FindLastIndex(Int32,Predicate<T>) | (Inherited from System.Collections.Generic.List<T>)
FindLastIndex(Int32,Int32,Predicate<T>) | (Inherited from System.Collections.Generic.List<T>)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializableList<T> Class
SerializableList<T> Members


FindLastIndex(Int32,Int32,Predicate<T>) Method

[image]
Intersoft WebTextEditor Documentation
FindLastIndex(Int32,Int32,Predicate<T>) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > SerializableList<T> Class > FindLastIndex Method : FindLastIndex(Int32,Int32,Predicate<T>) Method

startIndex
count
match

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Overloads Function FindLastIndex( _
   ByVal startIndex As System.Integer, _
   ByVal count As System.Integer, _
   ByVal match As System.Predicate(Of T) _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As SerializableList(Of T)
Dim startIndex As System.Integer
Dim count As System.Integer
Dim match As System.Predicate(Of T)
Dim value As System.Integer

value = instance.FindLastIndex(startIndex, count, match)
C#
[__DynamicallyInvokableAttribute()]
public System.int FindLastIndex(
   System.int startIndex,
   System.int count,
   System.Predicate<T> match
)
Delphi
public function FindLastIndex(
    startIndex: System.Integer;
    count: System.Integer;
    match: System.Predicate
): System.Integer;
JScript
__DynamicallyInvokableAttribute()
public function FindLastIndex(
   startIndex : System.int,
   count : System.int,
   match : System.Predicate
) : System.int;
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: System.int FindLastIndex(
   System.int startIndex,
   System.int count,
   System.Predicate<T*>* match
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
System.int FindLastIndex(
   System.int startIndex,
   System.int count,
   System.Predicate<T^>^ match
)

Parameters

startIndex
count
match

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializableList<T> Class
SerializableList<T> Members
Overload List


FindLastIndex(Int32,Predicate<T>) Method

[image]
Intersoft WebTextEditor Documentation
FindLastIndex(Int32,Predicate<T>) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > SerializableList<T> Class > FindLastIndex Method : FindLastIndex(Int32,Predicate<T>) Method

startIndex
match

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Overloads Function FindLastIndex( _
   ByVal startIndex As System.Integer, _
   ByVal match As System.Predicate(Of T) _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As SerializableList(Of T)
Dim startIndex As System.Integer
Dim match As System.Predicate(Of T)
Dim value As System.Integer

value = instance.FindLastIndex(startIndex, match)
C#
[__DynamicallyInvokableAttribute()]
public System.int FindLastIndex(
   System.int startIndex,
   System.Predicate<T> match
)
Delphi
public function FindLastIndex(
    startIndex: System.Integer;
    match: System.Predicate
): System.Integer;
JScript
__DynamicallyInvokableAttribute()
public function FindLastIndex(
   startIndex : System.int,
   match : System.Predicate
) : System.int;
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: System.int FindLastIndex(
   System.int startIndex,
   System.Predicate<T*>* match
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
System.int FindLastIndex(
   System.int startIndex,
   System.Predicate<T^>^ match
)

Parameters

startIndex
match

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializableList<T> Class
SerializableList<T> Members
Overload List


FindLastIndex(Predicate<T>) Method

[image]
Intersoft WebTextEditor Documentation
FindLastIndex(Predicate<T>) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > SerializableList<T> Class > FindLastIndex Method : FindLastIndex(Predicate<T>) Method

match

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Overloads Function FindLastIndex( _
   ByVal match As System.Predicate(Of T) _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As SerializableList(Of T)
Dim match As System.Predicate(Of T)
Dim value As System.Integer

value = instance.FindLastIndex(match)
C#
[__DynamicallyInvokableAttribute()]
public System.int FindLastIndex(
   System.Predicate<T> match
)
Delphi
public function FindLastIndex(
    match: System.Predicate
): System.Integer;
JScript
__DynamicallyInvokableAttribute()
public function FindLastIndex(
   match : System.Predicate
) : System.int;
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: System.int FindLastIndex(
   System.Predicate<T*>* match
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
System.int FindLastIndex(
   System.Predicate<T^>^ match
)

Parameters

match

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializableList<T> Class
SerializableList<T> Members
Overload List


ForEach Method

[image]
Intersoft WebTextEditor Documentation
ForEach Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > SerializableList<T> Class : ForEach Method

action

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ForEach( _
   ByVal action As System.Action(Of T) _
)
Visual Basic (Usage) Copy Code
Dim instance As SerializableList(Of T)
Dim action As System.Action(Of T)

instance.ForEach(action)
C#
public void ForEach(
   System.Action<T> action
)
Delphi
public procedure ForEach(
    action: System.Action
);
JScript
public function ForEach(
   action : System.Action
);
Managed Extensions for C++
public: void ForEach(
   System.Action<T*>* action
)
C++/CLI
public:
void ForEach(
   System.Action<T^>^ action
)

Parameters

action

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializableList<T> Class
SerializableList<T> Members


GetEnumerator Method

[image]
Intersoft WebTextEditor Documentation
GetEnumerator Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > SerializableList<T> Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Function GetEnumerator() As System.Collections.Generic.List(Of T)
Visual Basic (Usage) Copy Code
Dim instance As SerializableList(Of T)
Dim value As System.Collections.Generic.List(Of T)

value = instance.GetEnumerator()
C#
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public System.Collections.Generic.List<T> GetEnumerator()
Delphi
public function GetEnumerator(): System.Collections.Generic.List;
JScript
__DynamicallyInvokableAttribute()
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function GetEnumerator() : System.Collections.Generic.List;
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: System.Collections.Generic.List<T*>* GetEnumerator();
C++/CLI
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
System.Collections.Generic.List<T^>^ GetEnumerator();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializableList<T> Class
SerializableList<T> Members


GetRange Method

[image]
Intersoft WebTextEditor Documentation
GetRange Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > SerializableList<T> Class : GetRange Method

index
count

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Function GetRange( _
   ByVal index As System.Integer, _
   ByVal count As System.Integer _
) As System.Collections.Generic.List(Of T)
Visual Basic (Usage) Copy Code
Dim instance As SerializableList(Of T)
Dim index As System.Integer
Dim count As System.Integer
Dim value As System.Collections.Generic.List(Of T)

value = instance.GetRange(index, count)
C#
[__DynamicallyInvokableAttribute()]
public System.Collections.Generic.List<T> GetRange(
   System.int index,
   System.int count
)
Delphi
public function GetRange(
    index: System.Integer;
    count: System.Integer
): System.Collections.Generic.List;
JScript
__DynamicallyInvokableAttribute()
public function GetRange(
   index : System.int,
   count : System.int
) : System.Collections.Generic.List;
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: System.Collections.Generic.List<T*>* GetRange(
   System.int index,
   System.int count
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
System.Collections.Generic.List<T^>^ GetRange(
   System.int index,
   System.int count
)

Parameters

index
count

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializableList<T> Class
SerializableList<T> Members


IndexOf Method

[image]
Intersoft WebTextEditor Documentation
IndexOf Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > SerializableList<T> Class : IndexOf Method

Glossary Item Box

Overload List

Overload | Description
IndexOf(T) | (Inherited from System.Collections.Generic.List<T>)
IndexOf(T,Int32) | (Inherited from System.Collections.Generic.List<T>)
IndexOf(T,Int32,Int32) | (Inherited from System.Collections.Generic.List<T>)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializableList<T> Class
SerializableList<T> Members


IndexOf(T) Method

[image]
Intersoft WebTextEditor Documentation
IndexOf(T) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > SerializableList<T> Class > IndexOf Method : IndexOf(T) Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
<__DynamicallyInvokableAttribute()>
Public Overloads Function IndexOf( _
   ByVal item As T _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As SerializableList(Of T)
Dim item As T
Dim value As System.Integer

value = instance.IndexOf(item)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public System.int IndexOf(
   T item
)
Delphi
public function IndexOf(
    item: T
): System.Integer;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
__DynamicallyInvokableAttribute()
public function IndexOf(
   item : T
) : System.int;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public: System.int IndexOf(
   T* item
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public:
System.int IndexOf(
   T^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializableList<T> Class
SerializableList<T> Members
Overload List


IndexOf(T,Int32) Method

[image]
Intersoft WebTextEditor Documentation
IndexOf(T,Int32) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > SerializableList<T> Class > IndexOf Method : IndexOf(T,Int32) Method

item
index

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Overloads Function IndexOf( _
   ByVal item As T, _
   ByVal index As System.Integer _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As SerializableList(Of T)
Dim item As T
Dim index As System.Integer
Dim value As System.Integer

value = instance.IndexOf(item, index)
C#
[__DynamicallyInvokableAttribute()]
public System.int IndexOf(
   T item,
   System.int index
)
Delphi
public function IndexOf(
    item: T;
    index: System.Integer
): System.Integer;
JScript
__DynamicallyInvokableAttribute()
public function IndexOf(
   item : T,
   index : System.int
) : System.int;
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: System.int IndexOf(
   T* item,
   System.int index
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
System.int IndexOf(
   T^ item,
   System.int index
)

Parameters

item
index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializableList<T> Class
SerializableList<T> Members
Overload List


IndexOf(T,Int32,Int32) Method

[image]
Intersoft WebTextEditor Documentation
IndexOf(T,Int32,Int32) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > SerializableList<T> Class > IndexOf Method : IndexOf(T,Int32,Int32) Method

item
index
count

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Overloads Function IndexOf( _
   ByVal item As T, _
   ByVal index As System.Integer, _
   ByVal count As System.Integer _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As SerializableList(Of T)
Dim item As T
Dim index As System.Integer
Dim count As System.Integer
Dim value As System.Integer

value = instance.IndexOf(item, index, count)
C#
[__DynamicallyInvokableAttribute()]
public System.int IndexOf(
   T item,
   System.int index,
   System.int count
)
Delphi
public function IndexOf(
    item: T;
    index: System.Integer;
    count: System.Integer
): System.Integer;
JScript
__DynamicallyInvokableAttribute()
public function IndexOf(
   item : T,
   index : System.int,
   count : System.int
) : System.int;
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: System.int IndexOf(
   T* item,
   System.int index,
   System.int count
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
System.int IndexOf(
   T^ item,
   System.int index,
   System.int count
)

Parameters

item
index
count

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializableList<T> Class
SerializableList<T> Members
Overload List


Insert Method

[image]
Intersoft WebTextEditor Documentation
Insert Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > SerializableList<T> Class : Insert Method

index
item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal item As T _
)
Visual Basic (Usage) Copy Code
Dim instance As SerializableList(Of T)
Dim index As System.Integer
Dim item As T

instance.Insert(index, item)
C#
[__DynamicallyInvokableAttribute()]
public void Insert(
   System.int index,
   T item
)
Delphi
public procedure Insert(
    index: System.Integer;
    item: T
);
JScript
__DynamicallyInvokableAttribute()
public function Insert(
   index : System.int,
   item : T
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void Insert(
   System.int index,
   T* item
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void Insert(
   System.int index,
   T^ item
)

Parameters

index
item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializableList<T> Class
SerializableList<T> Members


InsertRange Method

[image]
Intersoft WebTextEditor Documentation
InsertRange Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > SerializableList<T> Class : InsertRange Method

index
collection

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Sub InsertRange( _
   ByVal index As System.Integer, _
   ByVal collection As System.Collections.Generic.IEnumerable(Of T) _
)
Visual Basic (Usage) Copy Code
Dim instance As SerializableList(Of T)
Dim index As System.Integer
Dim collection As System.Collections.Generic.IEnumerable(Of T)

instance.InsertRange(index, collection)
C#
[__DynamicallyInvokableAttribute()]
public void InsertRange(
   System.int index,
   System.Collections.Generic.IEnumerable<T> collection
)
Delphi
public procedure InsertRange(
    index: System.Integer;
    collection: System.Collections.Generic.IEnumerable
);
JScript
__DynamicallyInvokableAttribute()
public function InsertRange(
   index : System.int,
   collection : System.Collections.Generic.IEnumerable
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void InsertRange(
   System.int index,
   System.Collections.Generic.IEnumerable<T*>* collection
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void InsertRange(
   System.int index,
   System.Collections.Generic.IEnumerable<T^>^ collection
)

Parameters

index
collection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializableList<T> Class
SerializableList<T> Members


Item Property

[image]
Intersoft WebTextEditor Documentation
Item Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > SerializableList<T> Class : Item Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Default Property Item( _
   ByVal index As System.Integer _
) As T
Visual Basic (Usage) Copy Code
Dim instance As SerializableList(Of T)
Dim index As System.Integer
Dim value As T

instance.Item(index) = value

value = instance.Item(index)
C#
[__DynamicallyInvokableAttribute()]
public T this[
   System.int index
]; {get; set;}
Delphi
public  this: : T;[
    index: System.Integer
]; read-write
JScript
__DynamicallyInvokableAttribute()
public  this[
   index : System.int
] get,set : T
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: __property T* get_Item   System.int index
;
public: __property void set_Item   System.int index,
   T* value
;
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
property T^ default [int] {
   T^ get(System.int index);
   void set (System.int index, T^ value);
}

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializableList<T> Class
SerializableList<T> Members


LastIndexOf Method

[image]
Intersoft WebTextEditor Documentation
LastIndexOf Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > SerializableList<T> Class : LastIndexOf Method

Glossary Item Box

Overload List

Overload | Description
LastIndexOf(T) | (Inherited from System.Collections.Generic.List<T>)
LastIndexOf(T,Int32) | (Inherited from System.Collections.Generic.List<T>)
LastIndexOf(T,Int32,Int32) | (Inherited from System.Collections.Generic.List<T>)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializableList<T> Class
SerializableList<T> Members


LastIndexOf(T) Method

[image]
Intersoft WebTextEditor Documentation
LastIndexOf(T) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > SerializableList<T> Class > LastIndexOf Method : LastIndexOf(T) Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Overloads Function LastIndexOf( _
   ByVal item As T _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As SerializableList(Of T)
Dim item As T
Dim value As System.Integer

value = instance.LastIndexOf(item)
C#
[__DynamicallyInvokableAttribute()]
public System.int LastIndexOf(
   T item
)
Delphi
public function LastIndexOf(
    item: T
): System.Integer;
JScript
__DynamicallyInvokableAttribute()
public function LastIndexOf(
   item : T
) : System.int;
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: System.int LastIndexOf(
   T* item
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
System.int LastIndexOf(
   T^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializableList<T> Class
SerializableList<T> Members
Overload List


LastIndexOf(T,Int32) Method

[image]
Intersoft WebTextEditor Documentation
LastIndexOf(T,Int32) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > SerializableList<T> Class > LastIndexOf Method : LastIndexOf(T,Int32) Method

item
index

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Overloads Function LastIndexOf( _
   ByVal item As T, _
   ByVal index As System.Integer _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As SerializableList(Of T)
Dim item As T
Dim index As System.Integer
Dim value As System.Integer

value = instance.LastIndexOf(item, index)
C#
[__DynamicallyInvokableAttribute()]
public System.int LastIndexOf(
   T item,
   System.int index
)
Delphi
public function LastIndexOf(
    item: T;
    index: System.Integer
): System.Integer;
JScript
__DynamicallyInvokableAttribute()
public function LastIndexOf(
   item : T,
   index : System.int
) : System.int;
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: System.int LastIndexOf(
   T* item,
   System.int index
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
System.int LastIndexOf(
   T^ item,
   System.int index
)

Parameters

item
index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializableList<T> Class
SerializableList<T> Members
Overload List


LastIndexOf(T,Int32,Int32) Method

[image]
Intersoft WebTextEditor Documentation
LastIndexOf(T,Int32,Int32) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > SerializableList<T> Class > LastIndexOf Method : LastIndexOf(T,Int32,Int32) Method

item
index
count

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Overloads Function LastIndexOf( _
   ByVal item As T, _
   ByVal index As System.Integer, _
   ByVal count As System.Integer _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As SerializableList(Of T)
Dim item As T
Dim index As System.Integer
Dim count As System.Integer
Dim value As System.Integer

value = instance.LastIndexOf(item, index, count)
C#
[__DynamicallyInvokableAttribute()]
public System.int LastIndexOf(
   T item,
   System.int index,
   System.int count
)
Delphi
public function LastIndexOf(
    item: T;
    index: System.Integer;
    count: System.Integer
): System.Integer;
JScript
__DynamicallyInvokableAttribute()
public function LastIndexOf(
   item : T,
   index : System.int,
   count : System.int
) : System.int;
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: System.int LastIndexOf(
   T* item,
   System.int index,
   System.int count
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
System.int LastIndexOf(
   T^ item,
   System.int index,
   System.int count
)

Parameters

item
index
count

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializableList<T> Class
SerializableList<T> Members
Overload List


Remove Method

[image]
Intersoft WebTextEditor Documentation
Remove Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > SerializableList<T> Class : Remove Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
<__DynamicallyInvokableAttribute()>
Public Function Remove( _
   ByVal item As T _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As SerializableList(Of T)
Dim item As T
Dim value As System.Boolean

value = instance.Remove(item)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public System.bool Remove(
   T item
)
Delphi
public function Remove(
    item: T
): System.Boolean;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
__DynamicallyInvokableAttribute()
public function Remove(
   item : T
) : System.boolean;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public: System.bool Remove(
   T* item
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public:
System.bool Remove(
   T^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializableList<T> Class
SerializableList<T> Members


RemoveAll Method

[image]
Intersoft WebTextEditor Documentation
RemoveAll Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > SerializableList<T> Class : RemoveAll Method

match

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Function RemoveAll( _
   ByVal match As System.Predicate(Of T) _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As SerializableList(Of T)
Dim match As System.Predicate(Of T)
Dim value As System.Integer

value = instance.RemoveAll(match)
C#
[__DynamicallyInvokableAttribute()]
public System.int RemoveAll(
   System.Predicate<T> match
)
Delphi
public function RemoveAll(
    match: System.Predicate
): System.Integer;
JScript
__DynamicallyInvokableAttribute()
public function RemoveAll(
   match : System.Predicate
) : System.int;
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: System.int RemoveAll(
   System.Predicate<T*>* match
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
System.int RemoveAll(
   System.Predicate<T^>^ match
)

Parameters

match

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializableList<T> Class
SerializableList<T> Members


RemoveAt Method

[image]
Intersoft WebTextEditor Documentation
RemoveAt Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > SerializableList<T> Class : RemoveAt Method

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As SerializableList(Of T)
Dim index As System.Integer

instance.RemoveAt(index)
C#
[__DynamicallyInvokableAttribute()]
public void RemoveAt(
   System.int index
)
Delphi
public procedure RemoveAt(
    index: System.Integer
);
JScript
__DynamicallyInvokableAttribute()
public function RemoveAt(
   index : System.int
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void RemoveAt(
   System.int index
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void RemoveAt(
   System.int index
)

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializableList<T> Class
SerializableList<T> Members


RemoveRange Method

[image]
Intersoft WebTextEditor Documentation
RemoveRange Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > SerializableList<T> Class : RemoveRange Method

index
count

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Sub RemoveRange( _
   ByVal index As System.Integer, _
   ByVal count As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As SerializableList(Of T)
Dim index As System.Integer
Dim count As System.Integer

instance.RemoveRange(index, count)
C#
[__DynamicallyInvokableAttribute()]
public void RemoveRange(
   System.int index,
   System.int count
)
Delphi
public procedure RemoveRange(
    index: System.Integer;
    count: System.Integer
);
JScript
__DynamicallyInvokableAttribute()
public function RemoveRange(
   index : System.int,
   count : System.int
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void RemoveRange(
   System.int index,
   System.int count
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void RemoveRange(
   System.int index,
   System.int count
)

Parameters

index
count

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializableList<T> Class
SerializableList<T> Members


Reverse Method

[image]
Intersoft WebTextEditor Documentation
Reverse Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > SerializableList<T> Class : Reverse Method

Glossary Item Box

Overload List

Overload | Description
Reverse() | (Inherited from System.Collections.Generic.List<T>)
Reverse(Int32,Int32) | (Inherited from System.Collections.Generic.List<T>)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializableList<T> Class
SerializableList<T> Members


Reverse() Method

[image]
Intersoft WebTextEditor Documentation
Reverse() Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > SerializableList<T> Class > Reverse Method : Reverse() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Overloads Sub Reverse()
Visual Basic (Usage) Copy Code
Dim instance As SerializableList(Of T)

instance.Reverse()
C#
[__DynamicallyInvokableAttribute()]
public void Reverse()
Delphi
public procedure Reverse();
JScript
__DynamicallyInvokableAttribute()
public function Reverse();
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void Reverse();
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void Reverse();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializableList<T> Class
SerializableList<T> Members
Overload List


Reverse(Int32,Int32) Method

[image]
Intersoft WebTextEditor Documentation
Reverse(Int32,Int32) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > SerializableList<T> Class > Reverse Method : Reverse(Int32,Int32) Method

index
count

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Overloads Sub Reverse( _
   ByVal index As System.Integer, _
   ByVal count As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As SerializableList(Of T)
Dim index As System.Integer
Dim count As System.Integer

instance.Reverse(index, count)
C#
[__DynamicallyInvokableAttribute()]
public void Reverse(
   System.int index,
   System.int count
)
Delphi
public procedure Reverse(
    index: System.Integer;
    count: System.Integer
);
JScript
__DynamicallyInvokableAttribute()
public function Reverse(
   index : System.int,
   count : System.int
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void Reverse(
   System.int index,
   System.int count
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void Reverse(
   System.int index,
   System.int count
)

Parameters

index
count

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializableList<T> Class
SerializableList<T> Members
Overload List


Sort Method

[image]
Intersoft WebTextEditor Documentation
Sort Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > SerializableList<T> Class : Sort Method

Glossary Item Box

Overload List

Overload | Description
Sort() | (Inherited from System.Collections.Generic.List<T>)
Sort(IComparer<T>) | (Inherited from System.Collections.Generic.List<T>)
Sort(Int32,Int32,IComparer<T>) | (Inherited from System.Collections.Generic.List<T>)
Sort(Comparison<T>) | (Inherited from System.Collections.Generic.List<T>)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializableList<T> Class
SerializableList<T> Members


Sort() Method

[image]
Intersoft WebTextEditor Documentation
Sort() Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > SerializableList<T> Class > Sort Method : Sort() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Overloads Sub Sort()
Visual Basic (Usage) Copy Code
Dim instance As SerializableList(Of T)

instance.Sort()
C#
[__DynamicallyInvokableAttribute()]
public void Sort()
Delphi
public procedure Sort();
JScript
__DynamicallyInvokableAttribute()
public function Sort();
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void Sort();
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void Sort();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializableList<T> Class
SerializableList<T> Members
Overload List


Sort(Comparison<T>) Method

[image]
Intersoft WebTextEditor Documentation
Sort(Comparison<T>) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > SerializableList<T> Class > Sort Method : Sort(Comparison<T>) Method

comparison

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Overloads Sub Sort( _
   ByVal comparison As System.Comparison(Of T) _
)
Visual Basic (Usage) Copy Code
Dim instance As SerializableList(Of T)
Dim comparison As System.Comparison(Of T)

instance.Sort(comparison)
C#
[__DynamicallyInvokableAttribute()]
public void Sort(
   System.Comparison<T> comparison
)
Delphi
public procedure Sort(
    comparison: System.Comparison
);
JScript
__DynamicallyInvokableAttribute()
public function Sort(
   comparison : System.Comparison
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void Sort(
   System.Comparison<T*>* comparison
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void Sort(
   System.Comparison<T^>^ comparison
)

Parameters

comparison

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializableList<T> Class
SerializableList<T> Members
Overload List


Sort(IComparer<T>) Method

[image]
Intersoft WebTextEditor Documentation
Sort(IComparer<T>) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > SerializableList<T> Class > Sort Method : Sort(IComparer<T>) Method

comparer

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Overloads Sub Sort( _
   ByVal comparer As System.Collections.Generic.IComparer(Of T) _
)
Visual Basic (Usage) Copy Code
Dim instance As SerializableList(Of T)
Dim comparer As System.Collections.Generic.IComparer(Of T)

instance.Sort(comparer)
C#
[__DynamicallyInvokableAttribute()]
public void Sort(
   System.Collections.Generic.IComparer<T> comparer
)
Delphi
public procedure Sort(
    comparer: System.Collections.Generic.IComparer
);
JScript
__DynamicallyInvokableAttribute()
public function Sort(
   comparer : System.Collections.Generic.IComparer
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void Sort(
   System.Collections.Generic.IComparer<T*>* comparer
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void Sort(
   System.Collections.Generic.IComparer<T^>^ comparer
)

Parameters

comparer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializableList<T> Class
SerializableList<T> Members
Overload List


Sort(Int32,Int32,IComparer<T>) Method

[image]
Intersoft WebTextEditor Documentation
Sort(Int32,Int32,IComparer<T>) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > SerializableList<T> Class > Sort Method : Sort(Int32,Int32,IComparer<T>) Method

index
count
comparer

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Overloads Sub Sort( _
   ByVal index As System.Integer, _
   ByVal count As System.Integer, _
   ByVal comparer As System.Collections.Generic.IComparer(Of T) _
)
Visual Basic (Usage) Copy Code
Dim instance As SerializableList(Of T)
Dim index As System.Integer
Dim count As System.Integer
Dim comparer As System.Collections.Generic.IComparer(Of T)

instance.Sort(index, count, comparer)
C#
[__DynamicallyInvokableAttribute()]
public void Sort(
   System.int index,
   System.int count,
   System.Collections.Generic.IComparer<T> comparer
)
Delphi
public procedure Sort(
    index: System.Integer;
    count: System.Integer;
    comparer: System.Collections.Generic.IComparer
);
JScript
__DynamicallyInvokableAttribute()
public function Sort(
   index : System.int,
   count : System.int,
   comparer : System.Collections.Generic.IComparer
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void Sort(
   System.int index,
   System.int count,
   System.Collections.Generic.IComparer<T*>* comparer
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void Sort(
   System.int index,
   System.int count,
   System.Collections.Generic.IComparer<T^>^ comparer
)

Parameters

index
count
comparer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializableList<T> Class
SerializableList<T> Members
Overload List


ToArray Method

[image]
Intersoft WebTextEditor Documentation
ToArray Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > SerializableList<T> Class : ToArray Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Function ToArray() As T()
Visual Basic (Usage) Copy Code
Dim instance As SerializableList(Of T)
Dim value() As T

value = instance.ToArray()
C#
[__DynamicallyInvokableAttribute()]
public T[] ToArray()
Delphi
public function ToArray(): array of T;
JScript
__DynamicallyInvokableAttribute()
public function ToArray() : T[];
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: T*[]* ToArray();
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
array<T^>^ ToArray();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializableList<T> Class
SerializableList<T> Members


TrimExcess Method

[image]
Intersoft WebTextEditor Documentation
TrimExcess Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > SerializableList<T> Class : TrimExcess Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Sub TrimExcess()
Visual Basic (Usage) Copy Code
Dim instance As SerializableList(Of T)

instance.TrimExcess()
C#
[__DynamicallyInvokableAttribute()]
public void TrimExcess()
Delphi
public procedure TrimExcess();
JScript
__DynamicallyInvokableAttribute()
public function TrimExcess();
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void TrimExcess();
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void TrimExcess();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializableList<T> Class
SerializableList<T> Members


TrueForAll Method

[image]
Intersoft WebTextEditor Documentation
TrueForAll Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > SerializableList<T> Class : TrueForAll Method

match

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Function TrueForAll( _
   ByVal match As System.Predicate(Of T) _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As SerializableList(Of T)
Dim match As System.Predicate(Of T)
Dim value As System.Boolean

value = instance.TrueForAll(match)
C#
[__DynamicallyInvokableAttribute()]
public System.bool TrueForAll(
   System.Predicate<T> match
)
Delphi
public function TrueForAll(
    match: System.Predicate
): System.Boolean;
JScript
__DynamicallyInvokableAttribute()
public function TrueForAll(
   match : System.Predicate
) : System.boolean;
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: System.bool TrueForAll(
   System.Predicate<T*>* match
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
System.bool TrueForAll(
   System.Predicate<T^>^ match
)

Parameters

match

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SerializableList<T> Class
SerializableList<T> Members


WebFileUploader Class Fields

[image]
Intersoft WebTextEditor Documentation
WebFileUploader Class Fields
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebFileUploader Class

Glossary Item Box

For a list of all members of this type, see WebFileUploader members.

Protected Fields

 | Name | Description
Protected Field | isPagePreRender | (Inherited from ISNet.WebUI.ISNetControl)
Protected Field | renderDHTML | (Inherited from ISNet.WebUI.ISNetControl)
Protected Field | renderNS | (Inherited from ISNet.WebUI.ISNetControl)
Protected Field | viewStateLoaded | (Inherited from ISNet.WebUI.ISNetControl)
Top

See Also

Reference

WebFileUploader Class
ISNet.WebUI.WebTextEditor Namespace


CheckEventHandlerName Method

[image]
Intersoft WebTextEditor Documentation
CheckEventHandlerName Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderClientSideEvents Class : CheckEventHandlerName Method

eventName
eventHandlerName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub CheckEventHandlerName( _
   ByVal eventName As System.String, _
   ByVal eventHandlerName As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderClientSideEvents
Dim eventName As System.String
Dim eventHandlerName As System.String

instance.CheckEventHandlerName(eventName, eventHandlerName)
C#
public virtual void CheckEventHandlerName(
   System.string eventName,
   System.string eventHandlerName
)
Delphi
public procedure CheckEventHandlerName(
    eventName: System.String;
    eventHandlerName: System.String
); virtual;
JScript
public function CheckEventHandlerName(
   eventName : System.String,
   eventHandlerName : System.String
);
Managed Extensions for C++
public: virtual void CheckEventHandlerName(
   System.string* eventName,
   System.string* eventHandlerName
)
C++/CLI
public:
virtual void CheckEventHandlerName(
   System.String^ eventName,
   System.String^ eventHandlerName
)

Parameters

eventName
eventHandlerName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderClientSideEvents Class
WebFileUploaderClientSideEvents Members


Clone Method

[image]
Intersoft WebTextEditor Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderClientSideEvents Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderClientSideEvents
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderClientSideEvents Class
WebFileUploaderClientSideEvents Members


CopyFrom Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderClientSideEvents Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderClientSideEvents Class
WebFileUploaderClientSideEvents Members


CopyFrom(Object) Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderClientSideEvents Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderClientSideEvents
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderClientSideEvents Class
WebFileUploaderClientSideEvents Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderClientSideEvents Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderClientSideEvents
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderClientSideEvents Class
WebFileUploaderClientSideEvents Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebTextEditor Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderClientSideEvents Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderClientSideEvents
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderClientSideEvents Class
WebFileUploaderClientSideEvents Members


GetHashCode Method

[image]
Intersoft WebTextEditor Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderClientSideEvents Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderClientSideEvents
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderClientSideEvents Class
WebFileUploaderClientSideEvents Members


GetPropertyString Method

[image]
Intersoft WebTextEditor Documentation
GetPropertyString Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderClientSideEvents Class : GetPropertyString Method

v

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetPropertyString( _
   ByVal v As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderClientSideEvents
Dim v As System.String
Dim value As System.String

value = instance.GetPropertyString(v)
C#
protected virtual System.string GetPropertyString(
   System.string v
)
Delphi
protected function GetPropertyString(
    v: System.String
): System.String; virtual;
JScript
protected function GetPropertyString(
   v : System.String
) : System.String;
Managed Extensions for C++
protected: virtual System.string* GetPropertyString(
   System.string* v
)
C++/CLI
protected:
virtual System.String^ GetPropertyString(
   System.String^ v
)

Parameters

v

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderClientSideEvents Class
WebFileUploaderClientSideEvents Members


IsAnyAttachEventHandlers Method

[image]
Intersoft WebTextEditor Documentation
IsAnyAttachEventHandlers Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderClientSideEvents Class : IsAnyAttachEventHandlers Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsAnyAttachEventHandlers() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderClientSideEvents
Dim value As System.Boolean

value = instance.IsAnyAttachEventHandlers()
C#
public virtual System.bool IsAnyAttachEventHandlers()
Delphi
public function IsAnyAttachEventHandlers(): System.Boolean; virtual;
JScript
public function IsAnyAttachEventHandlers() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsAnyAttachEventHandlers();
C++/CLI
public:
virtual System.bool IsAnyAttachEventHandlers();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderClientSideEvents Class
WebFileUploaderClientSideEvents Members


IsEmpty Method

[image]
Intersoft WebTextEditor Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderClientSideEvents Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderClientSideEvents
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderClientSideEvents Class
WebFileUploaderClientSideEvents Members


IsInSerializationContext Method

[image]
Intersoft WebTextEditor Documentation
IsInSerializationContext Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderClientSideEvents Class : IsInSerializationContext Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function IsInSerializationContext() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderClientSideEvents
Dim value As System.Boolean

value = instance.IsInSerializationContext()
C#
protected virtual System.bool IsInSerializationContext()
Delphi
protected function IsInSerializationContext(): System.Boolean; virtual;
JScript
protected function IsInSerializationContext() : System.boolean;
Managed Extensions for C++
protected: virtual System.bool IsInSerializationContext();
C++/CLI
protected:
virtual System.bool IsInSerializationContext();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderClientSideEvents Class
WebFileUploaderClientSideEvents Members


IsValidEventHandlerName Method

[image]
Intersoft WebTextEditor Documentation
IsValidEventHandlerName Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderClientSideEvents Class : IsValidEventHandlerName Method

eventHandlerName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsValidEventHandlerName( _
   ByVal eventHandlerName As System.String _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderClientSideEvents
Dim eventHandlerName As System.String
Dim value As System.Boolean

value = instance.IsValidEventHandlerName(eventHandlerName)
C#
public virtual System.bool IsValidEventHandlerName(
   System.string eventHandlerName
)
Delphi
public function IsValidEventHandlerName(
    eventHandlerName: System.String
): System.Boolean; virtual;
JScript
public function IsValidEventHandlerName(
   eventHandlerName : System.String
) : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsValidEventHandlerName(
   System.string* eventHandlerName
)
C++/CLI
public:
virtual System.bool IsValidEventHandlerName(
   System.String^ eventHandlerName
)

Parameters

eventHandlerName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderClientSideEvents Class
WebFileUploaderClientSideEvents Members


Reset Method

[image]
Intersoft WebTextEditor Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderClientSideEvents Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderClientSideEvents

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderClientSideEvents Class
WebFileUploaderClientSideEvents Members


SerializeObjectData Method

[image]
Intersoft WebTextEditor Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderClientSideEvents Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderClientSideEvents
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderClientSideEvents Class
WebFileUploaderClientSideEvents Members


ToString Method

[image]
Intersoft WebTextEditor Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderClientSideEvents Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderClientSideEvents
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderClientSideEvents Class
WebFileUploaderClientSideEvents Members


Clone Method

[image]
Intersoft WebTextEditor Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderFileInfo Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderFileInfo
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderFileInfo Class
WebFileUploaderFileInfo Members


CopyFrom Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderFileInfo Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderFileInfo Class
WebFileUploaderFileInfo Members


CopyFrom(Object) Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderFileInfo Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderFileInfo
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderFileInfo Class
WebFileUploaderFileInfo Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderFileInfo Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderFileInfo
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderFileInfo Class
WebFileUploaderFileInfo Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebTextEditor Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderFileInfo Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderFileInfo
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderFileInfo Class
WebFileUploaderFileInfo Members


GetHashCode Method

[image]
Intersoft WebTextEditor Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderFileInfo Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderFileInfo
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderFileInfo Class
WebFileUploaderFileInfo Members


GetPropertyString Method

[image]
Intersoft WebTextEditor Documentation
GetPropertyString Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderFileInfo Class : GetPropertyString Method

v

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetPropertyString( _
   ByVal v As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderFileInfo
Dim v As System.String
Dim value As System.String

value = instance.GetPropertyString(v)
C#
protected virtual System.string GetPropertyString(
   System.string v
)
Delphi
protected function GetPropertyString(
    v: System.String
): System.String; virtual;
JScript
protected function GetPropertyString(
   v : System.String
) : System.String;
Managed Extensions for C++
protected: virtual System.string* GetPropertyString(
   System.string* v
)
C++/CLI
protected:
virtual System.String^ GetPropertyString(
   System.String^ v
)

Parameters

v

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderFileInfo Class
WebFileUploaderFileInfo Members


IsEmpty Method

[image]
Intersoft WebTextEditor Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderFileInfo Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderFileInfo
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderFileInfo Class
WebFileUploaderFileInfo Members


IsInSerializationContext Method

[image]
Intersoft WebTextEditor Documentation
IsInSerializationContext Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderFileInfo Class : IsInSerializationContext Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function IsInSerializationContext() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderFileInfo
Dim value As System.Boolean

value = instance.IsInSerializationContext()
C#
protected virtual System.bool IsInSerializationContext()
Delphi
protected function IsInSerializationContext(): System.Boolean; virtual;
JScript
protected function IsInSerializationContext() : System.boolean;
Managed Extensions for C++
protected: virtual System.bool IsInSerializationContext();
C++/CLI
protected:
virtual System.bool IsInSerializationContext();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderFileInfo Class
WebFileUploaderFileInfo Members


Reset Method

[image]
Intersoft WebTextEditor Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderFileInfo Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderFileInfo

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderFileInfo Class
WebFileUploaderFileInfo Members


SerializeObjectData Method

[image]
Intersoft WebTextEditor Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderFileInfo Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderFileInfo
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderFileInfo Class
WebFileUploaderFileInfo Members


Clone Method

[image]
Intersoft WebTextEditor Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderImageSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderImageSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderImageSettings Class
WebFileUploaderImageSettings Members


Control Property

[image]
Intersoft WebTextEditor Documentation
Control Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderImageSettings Class : Control Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Overridable Property Control As System.Web.UI.Control
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderImageSettings
Dim value As System.Web.UI.Control

instance.Control = value

value = instance.Control
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public virtual System.Web.UI.Control Control {get; set;}
Delphi
public read-write property Control: System.Web.UI.Control; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get,set Control : System.Web.UI.Control
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property virtual System.Web.UI.Control* get_Control();
public: __property virtual void set_Control(
   System.Web.UI.Control* value
);
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
virtual property System.Web.UI.Control^ Control {
   System.Web.UI.Control^ get();
   void set (    System.Web.UI.Control^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderImageSettings Class
WebFileUploaderImageSettings Members


CopyFrom Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderImageSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderImageSettings Class
WebFileUploaderImageSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderImageSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderImageSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderImageSettings Class
WebFileUploaderImageSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderImageSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderImageSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderImageSettings Class
WebFileUploaderImageSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebTextEditor Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderImageSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderImageSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderImageSettings Class
WebFileUploaderImageSettings Members


FileName Property

[image]
Intersoft WebTextEditor Documentation
FileName Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderImageSettings Class : FileName Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Overridable Property FileName As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderImageSettings
Dim value As System.String

instance.FileName = value

value = instance.FileName
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public virtual System.string FileName {get; set;}
Delphi
public read-write property FileName: System.String; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get,set FileName : System.String
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property virtual System.string* get_FileName();
public: __property virtual void set_FileName(
   System.string* value
);
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
virtual property System.String^ FileName {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderImageSettings Class
WebFileUploaderImageSettings Members


GetHashCode Method

[image]
Intersoft WebTextEditor Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderImageSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderImageSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderImageSettings Class
WebFileUploaderImageSettings Members


GetPropertyString Method

[image]
Intersoft WebTextEditor Documentation
GetPropertyString Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderImageSettings Class : GetPropertyString Method

v

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetPropertyString( _
   ByVal v As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderImageSettings
Dim v As System.String
Dim value As System.String

value = instance.GetPropertyString(v)
C#
protected virtual System.string GetPropertyString(
   System.string v
)
Delphi
protected function GetPropertyString(
    v: System.String
): System.String; virtual;
JScript
protected function GetPropertyString(
   v : System.String
) : System.String;
Managed Extensions for C++
protected: virtual System.string* GetPropertyString(
   System.string* v
)
C++/CLI
protected:
virtual System.String^ GetPropertyString(
   System.String^ v
)

Parameters

v

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderImageSettings Class
WebFileUploaderImageSettings Members


InitSettings Method

[image]
Intersoft WebTextEditor Documentation
InitSettings Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderImageSettings Class : InitSettings Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub InitSettings()
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderImageSettings

instance.InitSettings()
C#
public virtual void InitSettings()
Delphi
public procedure InitSettings(); virtual;
JScript
public function InitSettings();
Managed Extensions for C++
public: virtual void InitSettings();
C++/CLI
public:
virtual void InitSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderImageSettings Class
WebFileUploaderImageSettings Members


IsEmpty Method

[image]
Intersoft WebTextEditor Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderImageSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderImageSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderImageSettings Class
WebFileUploaderImageSettings Members


IsInSerializationContext Method

[image]
Intersoft WebTextEditor Documentation
IsInSerializationContext Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderImageSettings Class : IsInSerializationContext Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function IsInSerializationContext() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderImageSettings
Dim value As System.Boolean

value = instance.IsInSerializationContext()
C#
protected virtual System.bool IsInSerializationContext()
Delphi
protected function IsInSerializationContext(): System.Boolean; virtual;
JScript
protected function IsInSerializationContext() : System.boolean;
Managed Extensions for C++
protected: virtual System.bool IsInSerializationContext();
C++/CLI
protected:
virtual System.bool IsInSerializationContext();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderImageSettings Class
WebFileUploaderImageSettings Members


Reset Method

[image]
Intersoft WebTextEditor Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderImageSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderImageSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderImageSettings Class
WebFileUploaderImageSettings Members


SerializeObjectData Method

[image]
Intersoft WebTextEditor Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderImageSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderImageSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderImageSettings Class
WebFileUploaderImageSettings Members


ToString Method

[image]
Intersoft WebTextEditor Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderImageSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderImageSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderImageSettings Class
WebFileUploaderImageSettings Members


Clone Method

[image]
Intersoft WebTextEditor Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderInfo Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderInfo
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderInfo Class
WebFileUploaderInfo Members


CopyFrom Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderInfo Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderInfo Class
WebFileUploaderInfo Members


CopyFrom(Object) Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderInfo Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderInfo
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderInfo Class
WebFileUploaderInfo Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderInfo Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderInfo
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderInfo Class
WebFileUploaderInfo Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebTextEditor Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderInfo Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderInfo
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderInfo Class
WebFileUploaderInfo Members


GetHashCode Method

[image]
Intersoft WebTextEditor Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderInfo Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderInfo
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderInfo Class
WebFileUploaderInfo Members


GetPropertyString Method

[image]
Intersoft WebTextEditor Documentation
GetPropertyString Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderInfo Class : GetPropertyString Method

v

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetPropertyString( _
   ByVal v As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderInfo
Dim v As System.String
Dim value As System.String

value = instance.GetPropertyString(v)
C#
protected virtual System.string GetPropertyString(
   System.string v
)
Delphi
protected function GetPropertyString(
    v: System.String
): System.String; virtual;
JScript
protected function GetPropertyString(
   v : System.String
) : System.String;
Managed Extensions for C++
protected: virtual System.string* GetPropertyString(
   System.string* v
)
C++/CLI
protected:
virtual System.String^ GetPropertyString(
   System.String^ v
)

Parameters

v

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderInfo Class
WebFileUploaderInfo Members


IsEmpty Method

[image]
Intersoft WebTextEditor Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderInfo Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderInfo
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderInfo Class
WebFileUploaderInfo Members


IsInSerializationContext Method

[image]
Intersoft WebTextEditor Documentation
IsInSerializationContext Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderInfo Class : IsInSerializationContext Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function IsInSerializationContext() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderInfo
Dim value As System.Boolean

value = instance.IsInSerializationContext()
C#
protected virtual System.bool IsInSerializationContext()
Delphi
protected function IsInSerializationContext(): System.Boolean; virtual;
JScript
protected function IsInSerializationContext() : System.boolean;
Managed Extensions for C++
protected: virtual System.bool IsInSerializationContext();
C++/CLI
protected:
virtual System.bool IsInSerializationContext();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderInfo Class
WebFileUploaderInfo Members


Reset Method

[image]
Intersoft WebTextEditor Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderInfo Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderInfo

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderInfo Class
WebFileUploaderInfo Members


SerializeObjectData Method

[image]
Intersoft WebTextEditor Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderInfo Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderInfo
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderInfo Class
WebFileUploaderInfo Members


ToString Method

[image]
Intersoft WebTextEditor Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderInfo Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderInfo
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderInfo Class
WebFileUploaderInfo Members


Clone Method

[image]
Intersoft WebTextEditor Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderProgressInformation Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderProgressInformation
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderProgressInformation Class
WebFileUploaderProgressInformation Members


CopyFrom Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderProgressInformation Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderProgressInformation Class
WebFileUploaderProgressInformation Members


CopyFrom(Object) Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderProgressInformation Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderProgressInformation
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderProgressInformation Class
WebFileUploaderProgressInformation Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderProgressInformation Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderProgressInformation
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderProgressInformation Class
WebFileUploaderProgressInformation Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebTextEditor Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderProgressInformation Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderProgressInformation
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderProgressInformation Class
WebFileUploaderProgressInformation Members


GetHashCode Method

[image]
Intersoft WebTextEditor Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderProgressInformation Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderProgressInformation
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderProgressInformation Class
WebFileUploaderProgressInformation Members


GetPropertyString Method

[image]
Intersoft WebTextEditor Documentation
GetPropertyString Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderProgressInformation Class : GetPropertyString Method

v

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetPropertyString( _
   ByVal v As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderProgressInformation
Dim v As System.String
Dim value As System.String

value = instance.GetPropertyString(v)
C#
protected virtual System.string GetPropertyString(
   System.string v
)
Delphi
protected function GetPropertyString(
    v: System.String
): System.String; virtual;
JScript
protected function GetPropertyString(
   v : System.String
) : System.String;
Managed Extensions for C++
protected: virtual System.string* GetPropertyString(
   System.string* v
)
C++/CLI
protected:
virtual System.String^ GetPropertyString(
   System.String^ v
)

Parameters

v

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderProgressInformation Class
WebFileUploaderProgressInformation Members


IsEmpty Method

[image]
Intersoft WebTextEditor Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderProgressInformation Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderProgressInformation
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderProgressInformation Class
WebFileUploaderProgressInformation Members


IsInSerializationContext Method

[image]
Intersoft WebTextEditor Documentation
IsInSerializationContext Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderProgressInformation Class : IsInSerializationContext Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function IsInSerializationContext() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderProgressInformation
Dim value As System.Boolean

value = instance.IsInSerializationContext()
C#
protected virtual System.bool IsInSerializationContext()
Delphi
protected function IsInSerializationContext(): System.Boolean; virtual;
JScript
protected function IsInSerializationContext() : System.boolean;
Managed Extensions for C++
protected: virtual System.bool IsInSerializationContext();
C++/CLI
protected:
virtual System.bool IsInSerializationContext();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderProgressInformation Class
WebFileUploaderProgressInformation Members


Reset Method

[image]
Intersoft WebTextEditor Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderProgressInformation Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderProgressInformation

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderProgressInformation Class
WebFileUploaderProgressInformation Members


SerializeObjectData Method

[image]
Intersoft WebTextEditor Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderProgressInformation Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderProgressInformation
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderProgressInformation Class
WebFileUploaderProgressInformation Members


ToString Method

[image]
Intersoft WebTextEditor Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderProgressInformation Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderProgressInformation
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderProgressInformation Class
WebFileUploaderProgressInformation Members


Clone Method

[image]
Intersoft WebTextEditor Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderStyleSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderStyleSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderStyleSettings Class
WebFileUploaderStyleSettings Members


Control Property

[image]
Intersoft WebTextEditor Documentation
Control Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderStyleSettings Class : Control Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Overridable Property Control As System.Web.UI.Control
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderStyleSettings
Dim value As System.Web.UI.Control

instance.Control = value

value = instance.Control
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public virtual System.Web.UI.Control Control {get; set;}
Delphi
public read-write property Control: System.Web.UI.Control; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get,set Control : System.Web.UI.Control
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property virtual System.Web.UI.Control* get_Control();
public: __property virtual void set_Control(
   System.Web.UI.Control* value
);
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
virtual property System.Web.UI.Control^ Control {
   System.Web.UI.Control^ get();
   void set (    System.Web.UI.Control^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderStyleSettings Class
WebFileUploaderStyleSettings Members


CopyFrom Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderStyleSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderStyleSettings Class
WebFileUploaderStyleSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderStyleSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderStyleSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderStyleSettings Class
WebFileUploaderStyleSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderStyleSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderStyleSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderStyleSettings Class
WebFileUploaderStyleSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebTextEditor Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderStyleSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderStyleSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderStyleSettings Class
WebFileUploaderStyleSettings Members


FileName Property

[image]
Intersoft WebTextEditor Documentation
FileName Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderStyleSettings Class : FileName Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Overridable Property FileName As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderStyleSettings
Dim value As System.String

instance.FileName = value

value = instance.FileName
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public virtual System.string FileName {get; set;}
Delphi
public read-write property FileName: System.String; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get,set FileName : System.String
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property virtual System.string* get_FileName();
public: __property virtual void set_FileName(
   System.string* value
);
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
virtual property System.String^ FileName {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderStyleSettings Class
WebFileUploaderStyleSettings Members


GetHashCode Method

[image]
Intersoft WebTextEditor Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderStyleSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderStyleSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderStyleSettings Class
WebFileUploaderStyleSettings Members


GetObjectData Method

[image]
Intersoft WebTextEditor Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderStyleSettings Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderStyleSettings
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public virtual void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); virtual;
JScript
public function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: virtual void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
virtual void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderStyleSettings Class
WebFileUploaderStyleSettings Members


GetPropertyString Method

[image]
Intersoft WebTextEditor Documentation
GetPropertyString Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderStyleSettings Class : GetPropertyString Method

v

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetPropertyString( _
   ByVal v As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderStyleSettings
Dim v As System.String
Dim value As System.String

value = instance.GetPropertyString(v)
C#
protected virtual System.string GetPropertyString(
   System.string v
)
Delphi
protected function GetPropertyString(
    v: System.String
): System.String; virtual;
JScript
protected function GetPropertyString(
   v : System.String
) : System.String;
Managed Extensions for C++
protected: virtual System.string* GetPropertyString(
   System.string* v
)
C++/CLI
protected:
virtual System.String^ GetPropertyString(
   System.String^ v
)

Parameters

v

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderStyleSettings Class
WebFileUploaderStyleSettings Members


InitSettings Method

[image]
Intersoft WebTextEditor Documentation
InitSettings Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderStyleSettings Class : InitSettings Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub InitSettings()
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderStyleSettings

instance.InitSettings()
C#
public virtual void InitSettings()
Delphi
public procedure InitSettings(); virtual;
JScript
public function InitSettings();
Managed Extensions for C++
public: virtual void InitSettings();
C++/CLI
public:
virtual void InitSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderStyleSettings Class
WebFileUploaderStyleSettings Members


IsEmpty Method

[image]
Intersoft WebTextEditor Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderStyleSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderStyleSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderStyleSettings Class
WebFileUploaderStyleSettings Members


IsInSerializationContext Method

[image]
Intersoft WebTextEditor Documentation
IsInSerializationContext Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderStyleSettings Class : IsInSerializationContext Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function IsInSerializationContext() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderStyleSettings
Dim value As System.Boolean

value = instance.IsInSerializationContext()
C#
protected virtual System.bool IsInSerializationContext()
Delphi
protected function IsInSerializationContext(): System.Boolean; virtual;
JScript
protected function IsInSerializationContext() : System.boolean;
Managed Extensions for C++
protected: virtual System.bool IsInSerializationContext();
C++/CLI
protected:
virtual System.bool IsInSerializationContext();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderStyleSettings Class
WebFileUploaderStyleSettings Members


Reset Method

[image]
Intersoft WebTextEditor Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderStyleSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderStyleSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderStyleSettings Class
WebFileUploaderStyleSettings Members


SerializeObjectData Method

[image]
Intersoft WebTextEditor Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderStyleSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderStyleSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderStyleSettings Class
WebFileUploaderStyleSettings Members


ToString Method

[image]
Intersoft WebTextEditor Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderStyleSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderStyleSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderStyleSettings Class
WebFileUploaderStyleSettings Members


Clone Method

[image]
Intersoft WebTextEditor Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderTextSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderTextSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderTextSettings Class
WebFileUploaderTextSettings Members


Control Property

[image]
Intersoft WebTextEditor Documentation
Control Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderTextSettings Class : Control Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Overridable Property Control As System.Web.UI.Control
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderTextSettings
Dim value As System.Web.UI.Control

instance.Control = value

value = instance.Control
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public virtual System.Web.UI.Control Control {get; set;}
Delphi
public read-write property Control: System.Web.UI.Control; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get,set Control : System.Web.UI.Control
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property virtual System.Web.UI.Control* get_Control();
public: __property virtual void set_Control(
   System.Web.UI.Control* value
);
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
virtual property System.Web.UI.Control^ Control {
   System.Web.UI.Control^ get();
   void set (    System.Web.UI.Control^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderTextSettings Class
WebFileUploaderTextSettings Members


CopyFrom Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderTextSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderTextSettings Class
WebFileUploaderTextSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderTextSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderTextSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderTextSettings Class
WebFileUploaderTextSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderTextSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderTextSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderTextSettings Class
WebFileUploaderTextSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebTextEditor Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderTextSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderTextSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderTextSettings Class
WebFileUploaderTextSettings Members


FileName Property

[image]
Intersoft WebTextEditor Documentation
FileName Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderTextSettings Class : FileName Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Overridable Property FileName As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderTextSettings
Dim value As System.String

instance.FileName = value

value = instance.FileName
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public virtual System.string FileName {get; set;}
Delphi
public read-write property FileName: System.String; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get,set FileName : System.String
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property virtual System.string* get_FileName();
public: __property virtual void set_FileName(
   System.string* value
);
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
virtual property System.String^ FileName {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderTextSettings Class
WebFileUploaderTextSettings Members


GetHashCode Method

[image]
Intersoft WebTextEditor Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderTextSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderTextSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderTextSettings Class
WebFileUploaderTextSettings Members


GetPropertyString Method

[image]
Intersoft WebTextEditor Documentation
GetPropertyString Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderTextSettings Class : GetPropertyString Method

v

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetPropertyString( _
   ByVal v As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderTextSettings
Dim v As System.String
Dim value As System.String

value = instance.GetPropertyString(v)
C#
protected virtual System.string GetPropertyString(
   System.string v
)
Delphi
protected function GetPropertyString(
    v: System.String
): System.String; virtual;
JScript
protected function GetPropertyString(
   v : System.String
) : System.String;
Managed Extensions for C++
protected: virtual System.string* GetPropertyString(
   System.string* v
)
C++/CLI
protected:
virtual System.String^ GetPropertyString(
   System.String^ v
)

Parameters

v

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderTextSettings Class
WebFileUploaderTextSettings Members


InitSettings Method

[image]
Intersoft WebTextEditor Documentation
InitSettings Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderTextSettings Class : InitSettings Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub InitSettings()
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderTextSettings

instance.InitSettings()
C#
public virtual void InitSettings()
Delphi
public procedure InitSettings(); virtual;
JScript
public function InitSettings();
Managed Extensions for C++
public: virtual void InitSettings();
C++/CLI
public:
virtual void InitSettings();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderTextSettings Class
WebFileUploaderTextSettings Members


IsEmpty Method

[image]
Intersoft WebTextEditor Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderTextSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderTextSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderTextSettings Class
WebFileUploaderTextSettings Members


IsInSerializationContext Method

[image]
Intersoft WebTextEditor Documentation
IsInSerializationContext Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderTextSettings Class : IsInSerializationContext Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function IsInSerializationContext() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderTextSettings
Dim value As System.Boolean

value = instance.IsInSerializationContext()
C#
protected virtual System.bool IsInSerializationContext()
Delphi
protected function IsInSerializationContext(): System.Boolean; virtual;
JScript
protected function IsInSerializationContext() : System.boolean;
Managed Extensions for C++
protected: virtual System.bool IsInSerializationContext();
C++/CLI
protected:
virtual System.bool IsInSerializationContext();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderTextSettings Class
WebFileUploaderTextSettings Members


Reset Method

[image]
Intersoft WebTextEditor Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderTextSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderTextSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderTextSettings Class
WebFileUploaderTextSettings Members


SerializeObjectData Method

[image]
Intersoft WebTextEditor Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderTextSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderTextSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderTextSettings Class
WebFileUploaderTextSettings Members


ToString Method

[image]
Intersoft WebTextEditor Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploaderTextSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploaderTextSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploaderTextSettings Class
WebFileUploaderTextSettings Members


AccessKey Property

[image]
Intersoft WebTextEditor Documentation
AccessKey Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : AccessKey Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overridable Property AccessKey As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.String

instance.AccessKey = value

value = instance.AccessKey
C#
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public virtual System.string AccessKey {get; set;}
Delphi
public read-write property AccessKey: System.String; virtual;
JScript
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set AccessKey : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property virtual System.string* get_AccessKey();
public: __property virtual void set_AccessKey(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
virtual property System.String^ AccessKey {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


Adapter Property

[image]
Intersoft WebTextEditor Documentation
Adapter Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : Adapter Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property Adapter As System.Web.UI.Adapters.ControlAdapter
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Web.UI.Adapters.ControlAdapter

value = instance.Adapter
C#
protected System.Web.UI.Adapters.ControlAdapter Adapter {get;}
Delphi
protected read-only property Adapter: System.Web.UI.Adapters.ControlAdapter;
JScript
protected function get Adapter : System.Web.UI.Adapters.ControlAdapter
Managed Extensions for C++
protected: __property System.Web.UI.Adapters.ControlAdapter* get_Adapter();
C++/CLI
protected:
property System.Web.UI.Adapters.ControlAdapter^ Adapter {
   System.Web.UI.Adapters.ControlAdapter^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


AddAttributesToRender Method

[image]
Intersoft WebTextEditor Documentation
AddAttributesToRender Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : AddAttributesToRender Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub AddAttributesToRender( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim writer As System.Web.UI.HtmlTextWriter

instance.AddAttributesToRender(writer)
C#
protected virtual void AddAttributesToRender(
   System.Web.UI.HtmlTextWriter writer
)
Delphi
protected procedure AddAttributesToRender(
    writer: System.Web.UI.HtmlTextWriter
); virtual;
JScript
protected function AddAttributesToRender(
   writer : System.Web.UI.HtmlTextWriter
);
Managed Extensions for C++
protected: virtual void AddAttributesToRender(
   System.Web.UI.HtmlTextWriter* writer
)
C++/CLI
protected:
virtual void AddAttributesToRender(
   System.Web.UI.HtmlTextWriter^ writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


AddParsedSubObject Method

[image]
Intersoft WebTextEditor Documentation
AddParsedSubObject Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : AddParsedSubObject Method

obj

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Protected Overridable Sub AddParsedSubObject( _
   ByVal obj As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim obj As System.Object

instance.AddParsedSubObject(obj)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
protected virtual void AddParsedSubObject(
   System.object obj
)
Delphi
protected procedure AddParsedSubObject(
    obj: System.TObject
); virtual;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
protected function AddParsedSubObject(
   obj : System.Object
);
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
protected: virtual void AddParsedSubObject(
   System.Object* obj
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
protected:
virtual void AddParsedSubObject(
   System.Object^ obj
)

Parameters

obj

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


ApplyControlTheme Method

[image]
Intersoft WebTextEditor Documentation
ApplyControlTheme Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : ApplyControlTheme Method

themeInfo

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function ApplyControlTheme( _
   ByVal themeInfo As ISNet.WebUI.ThemeInfo _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim themeInfo As ISNet.WebUI.ThemeInfo
Dim value As System.Boolean

value = instance.ApplyControlTheme(themeInfo)
C#
protected virtual System.bool ApplyControlTheme(
   ISNet.WebUI.ThemeInfo themeInfo
)
Delphi
protected function ApplyControlTheme(
    themeInfo: ISNet.WebUI.ThemeInfo
): System.Boolean; virtual;
JScript
protected function ApplyControlTheme(
   themeInfo : ISNet.WebUI.ThemeInfo
) : System.boolean;
Managed Extensions for C++
protected: virtual System.bool ApplyControlTheme(
   ISNet.WebUI.ThemeInfo* themeInfo
)
C++/CLI
protected:
virtual System.bool ApplyControlTheme(
   ISNet.WebUI.ThemeInfo^ themeInfo
)

Parameters

themeInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


ApplyStyle Method

[image]
Intersoft WebTextEditor Documentation
ApplyStyle Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : ApplyStyle Method

s

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ApplyStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim s As System.Web.UI.WebControls.Style

instance.ApplyStyle(s)
C#
public void ApplyStyle(
   System.Web.UI.WebControls.Style s
)
Delphi
public procedure ApplyStyle(
    s: System.Web.UI.WebControls.Style
);
JScript
public function ApplyStyle(
   s : System.Web.UI.WebControls.Style
);
Managed Extensions for C++
public: void ApplyStyle(
   System.Web.UI.WebControls.Style* s
)
C++/CLI
public:
void ApplyStyle(
   System.Web.UI.WebControls.Style^ s
)

Parameters

s

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


ApplyStyleSheetSkin Method

[image]
Intersoft WebTextEditor Documentation
ApplyStyleSheetSkin Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : ApplyStyleSheetSkin Method

page

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Overridable Sub ApplyStyleSheetSkin( _
   ByVal page As System.Web.UI.Page _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim page As System.Web.UI.Page

instance.ApplyStyleSheetSkin(page)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page page
)
Delphi
public procedure ApplyStyleSheetSkin(
    page: System.Web.UI.Page
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function ApplyStyleSheetSkin(
   page : System.Web.UI.Page
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page* page
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page^ page
)

Parameters

page

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


AppRelativeTemplateSourceDirectory Property

[image]
Intersoft WebTextEditor Documentation
AppRelativeTemplateSourceDirectory Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : AppRelativeTemplateSourceDirectory Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<WebSysDescriptionAttribute("The virtual directory of the Page or UserControl that contains this control.")>
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property AppRelativeTemplateSourceDirectory As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.String

instance.AppRelativeTemplateSourceDirectory = value

value = instance.AppRelativeTemplateSourceDirectory
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[WebSysDescriptionAttribute("The virtual directory of the Page or UserControl that contains this control.")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public System.string AppRelativeTemplateSourceDirectory {get; set;}
Delphi
public read-write property AppRelativeTemplateSourceDirectory: System.String;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
WebSysDescriptionAttribute("The virtual directory of the Page or UserControl that contains this control.")
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get,set AppRelativeTemplateSourceDirectory : System.String
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[WebSysDescriptionAttribute("The virtual directory of the Page or UserControl that contains this control.")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property System.string* get_AppRelativeTemplateSourceDirectory();
public: __property void set_AppRelativeTemplateSourceDirectory(
   System.string* value
);
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[WebSysDescriptionAttribute("The virtual directory of the Page or UserControl that contains this control.")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property System.String^ AppRelativeTemplateSourceDirectory {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


AspNetAjaxSettings Property

[image]
Intersoft WebTextEditor Documentation
AspNetAjaxSettings Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : AspNetAjaxSettings Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DefaultValueAttribute()>
Public ReadOnly Property AspNetAjaxSettings As ISNet.WebUI.AspNetAjaxSettings
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As ISNet.WebUI.AspNetAjaxSettings

value = instance.AspNetAjaxSettings
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
public ISNet.WebUI.AspNetAjaxSettings AspNetAjaxSettings {get;}
Delphi
public read-only property AspNetAjaxSettings: ISNet.WebUI.AspNetAjaxSettings;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get AspNetAjaxSettings : ISNet.WebUI.AspNetAjaxSettings
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property ISNet.WebUI.AspNetAjaxSettings* get_AspNetAjaxSettings();
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property ISNet.WebUI.AspNetAjaxSettings^ AspNetAjaxSettings {
   ISNet.WebUI.AspNetAjaxSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


AssignXmlInputHiddenUniqueID Method

[image]
Intersoft WebTextEditor Documentation
AssignXmlInputHiddenUniqueID Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : AssignXmlInputHiddenUniqueID Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub AssignXmlInputHiddenUniqueID()
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader

instance.AssignXmlInputHiddenUniqueID()
C#
protected virtual void AssignXmlInputHiddenUniqueID()
Delphi
protected procedure AssignXmlInputHiddenUniqueID(); virtual;
JScript
protected function AssignXmlInputHiddenUniqueID();
Managed Extensions for C++
protected: virtual void AssignXmlInputHiddenUniqueID();
C++/CLI
protected:
virtual void AssignXmlInputHiddenUniqueID();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


Attributes Property

[image]
Intersoft WebTextEditor Documentation
Attributes Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : Attributes Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Tag attributes of the control.")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
Public ReadOnly Property Attributes As System.Web.UI.AttributeCollection
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Web.UI.AttributeCollection

value = instance.Attributes
C#
[WebSysDescriptionAttribute("Tag attributes of the control.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public System.Web.UI.AttributeCollection Attributes {get;}
Delphi
public read-only property Attributes: System.Web.UI.AttributeCollection;
JScript
WebSysDescriptionAttribute("Tag attributes of the control.")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
public function get Attributes : System.Web.UI.AttributeCollection
Managed Extensions for C++
[WebSysDescriptionAttribute("Tag attributes of the control.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public: __property System.Web.UI.AttributeCollection* get_Attributes();
C++/CLI
[WebSysDescriptionAttribute("Tag attributes of the control.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public:
property System.Web.UI.AttributeCollection^ Attributes {
   System.Web.UI.AttributeCollection^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


BackColor Property

[image]
Intersoft WebTextEditor Documentation
BackColor Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : BackColor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Frame Appearance")>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Overridable Property BackColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Drawing.Color

instance.BackColor = value

value = instance.BackColor
C#
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
public virtual System.Drawing.Color BackColor {get; set;}
Delphi
public read-write property BackColor: System.Drawing.Color; virtual;
JScript
System.ComponentModel.CategoryAttribute("Frame Appearance")
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
ISNet.Serialization.BinarySerializableAttribute()
public function get,set BackColor : System.Drawing.Color
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property virtual System.Drawing.Color get_BackColor();
public: __property virtual void set_BackColor(
   System.Drawing.Color value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
virtual property System.Drawing.Color BackColor {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


BorderColor Property

[image]
Intersoft WebTextEditor Documentation
BorderColor Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : BorderColor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Frame Appearance")>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)>
Public Overridable Property BorderColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Drawing.Color

instance.BorderColor = value

value = instance.BorderColor
C#
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
public virtual System.Drawing.Color BorderColor {get; set;}
Delphi
public read-write property BorderColor: System.Drawing.Color; virtual;
JScript
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Frame Appearance")
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)
public function get,set BorderColor : System.Drawing.Color
Managed Extensions for C++
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
public: __property virtual System.Drawing.Color get_BorderColor();
public: __property virtual void set_BorderColor(
   System.Drawing.Color value
);
C++/CLI
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
public:
virtual property System.Drawing.Color BorderColor {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


BorderStyle Property

[image]
Intersoft WebTextEditor Documentation
BorderStyle Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : BorderStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Frame Appearance")>
Public Overridable Property BorderStyle As System.Web.UI.WebControls.BorderStyle
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Web.UI.WebControls.BorderStyle

instance.BorderStyle = value

value = instance.BorderStyle
C#
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
public virtual System.Web.UI.WebControls.BorderStyle BorderStyle {get; set;}
Delphi
public read-write property BorderStyle: System.Web.UI.WebControls.BorderStyle; virtual;
JScript
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Frame Appearance")
public function get,set BorderStyle : System.Web.UI.WebControls.BorderStyle
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
public: __property virtual System.Web.UI.WebControls.BorderStyle get_BorderStyle();
public: __property virtual void set_BorderStyle(
   System.Web.UI.WebControls.BorderStyle value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
public:
virtual property System.Web.UI.WebControls.BorderStyle BorderStyle {
   System.Web.UI.WebControls.BorderStyle get();
   void set (    System.Web.UI.WebControls.BorderStyle value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


BorderWidth Property

[image]
Intersoft WebTextEditor Documentation
BorderWidth Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : BorderWidth Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.CategoryAttribute("Frame Appearance")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Overridable Property BorderWidth As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Web.UI.WebControls.Unit

instance.BorderWidth = value

value = instance.BorderWidth
C#
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
public virtual System.Web.UI.WebControls.Unit BorderWidth {get; set;}
Delphi
public read-write property BorderWidth: System.Web.UI.WebControls.Unit; virtual;
JScript
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.CategoryAttribute("Frame Appearance")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set BorderWidth : System.Web.UI.WebControls.Unit
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property virtual System.Web.UI.WebControls.Unit get_BorderWidth();
public: __property virtual void set_BorderWidth(
   System.Web.UI.WebControls.Unit value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
virtual property System.Web.UI.WebControls.Unit BorderWidth {
   System.Web.UI.WebControls.Unit get();
   void set (    System.Web.UI.WebControls.Unit value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


BuildProfileTree Method

[image]
Intersoft WebTextEditor Documentation
BuildProfileTree Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : BuildProfileTree Method

parentId
calcViewState

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Sub BuildProfileTree( _
   ByVal parentId As System.String, _
   ByVal calcViewState As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim parentId As System.String
Dim calcViewState As System.Boolean

instance.BuildProfileTree(parentId, calcViewState)
C#
protected void BuildProfileTree(
   System.string parentId,
   System.bool calcViewState
)
Delphi
protected procedure BuildProfileTree(
    parentId: System.String;
    calcViewState: System.Boolean
);
JScript
protected function BuildProfileTree(
   parentId : System.String,
   calcViewState : System.boolean
);
Managed Extensions for C++
protected: void BuildProfileTree(
   System.string* parentId,
   System.bool calcViewState
)
C++/CLI
protected:
void BuildProfileTree(
   System.String^ parentId,
   System.bool calcViewState
)

Parameters

parentId
calcViewState

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


CanUseWebResources Method

[image]
Intersoft WebTextEditor Documentation
CanUseWebResources Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : CanUseWebResources Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CanUseWebResources() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Boolean

value = instance.CanUseWebResources()
C#
public System.bool CanUseWebResources()
Delphi
public function CanUseWebResources(): System.Boolean;
JScript
public function CanUseWebResources() : System.boolean;
Managed Extensions for C++
public: System.bool CanUseWebResources();
C++/CLI
public:
System.bool CanUseWebResources();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


ChildControlsCreated Property

[image]
Intersoft WebTextEditor Documentation
ChildControlsCreated Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : ChildControlsCreated Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Property ChildControlsCreated As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Boolean

instance.ChildControlsCreated = value

value = instance.ChildControlsCreated
C#
protected System.bool ChildControlsCreated {get; set;}
Delphi
protected read-write property ChildControlsCreated: System.Boolean;
JScript
protected function get,set ChildControlsCreated : System.boolean
Managed Extensions for C++
protected: __property System.bool get_ChildControlsCreated();
protected: __property void set_ChildControlsCreated(
   System.bool value
);
C++/CLI
protected:
property System.bool ChildControlsCreated {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


ClearCachedClientID Method

[image]
Intersoft WebTextEditor Documentation
ClearCachedClientID Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : ClearCachedClientID Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Sub ClearCachedClientID()
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader

instance.ClearCachedClientID()
C#
protected void ClearCachedClientID()
Delphi
protected procedure ClearCachedClientID();
JScript
protected function ClearCachedClientID();
Managed Extensions for C++
protected: void ClearCachedClientID();
C++/CLI
protected:
void ClearCachedClientID();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


ClearChildControlState Method

[image]
Intersoft WebTextEditor Documentation
ClearChildControlState Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : ClearChildControlState Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Sub ClearChildControlState()
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader

instance.ClearChildControlState()
C#
protected void ClearChildControlState()
Delphi
protected procedure ClearChildControlState();
JScript
protected function ClearChildControlState();
Managed Extensions for C++
protected: void ClearChildControlState();
C++/CLI
protected:
void ClearChildControlState();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


ClearChildState Method

[image]
Intersoft WebTextEditor Documentation
ClearChildState Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : ClearChildState Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Sub ClearChildState()
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader

instance.ClearChildState()
C#
protected void ClearChildState()
Delphi
protected procedure ClearChildState();
JScript
protected function ClearChildState();
Managed Extensions for C++
protected: void ClearChildState();
C++/CLI
protected:
void ClearChildState();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


ClearChildViewState Method

[image]
Intersoft WebTextEditor Documentation
ClearChildViewState Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : ClearChildViewState Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Sub ClearChildViewState()
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader

instance.ClearChildViewState()
C#
protected void ClearChildViewState()
Delphi
protected procedure ClearChildViewState();
JScript
protected function ClearChildViewState();
Managed Extensions for C++
protected: void ClearChildViewState();
C++/CLI
protected:
void ClearChildViewState();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


ClearEffectiveClientIDMode Method

[image]
Intersoft WebTextEditor Documentation
ClearEffectiveClientIDMode Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : ClearEffectiveClientIDMode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Sub ClearEffectiveClientIDMode()
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader

instance.ClearEffectiveClientIDMode()
C#
protected void ClearEffectiveClientIDMode()
Delphi
protected procedure ClearEffectiveClientIDMode();
JScript
protected function ClearEffectiveClientIDMode();
Managed Extensions for C++
protected: void ClearEffectiveClientIDMode();
C++/CLI
protected:
void ClearEffectiveClientIDMode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


ClientID Property

[image]
Intersoft WebTextEditor Documentation
ClientID Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : ClientID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<WebSysDescriptionAttribute("The ID of the control that is rendered for the client.")>
Public Overridable ReadOnly Property ClientID As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.String

value = instance.ClientID
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[WebSysDescriptionAttribute("The ID of the control that is rendered for the client.")]
public virtual System.string ClientID {get;}
Delphi
public read-only property ClientID: System.String; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
WebSysDescriptionAttribute("The ID of the control that is rendered for the client.")
public function get ClientID : System.String
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[WebSysDescriptionAttribute("The ID of the control that is rendered for the client.")]
public: __property virtual System.string* get_ClientID();
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[WebSysDescriptionAttribute("The ID of the control that is rendered for the client.")]
public:
virtual property System.String^ ClientID {
   System.String^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


ClientIDMode Property

[image]
Intersoft WebTextEditor Documentation
ClientIDMode Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : ClientIDMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.ThemeableAttribute(False)>
<WebCategoryAttribute("Behavior")>
<System.ComponentModel.DefaultValueAttribute()>
<WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")>
Public Overridable Property ClientIDMode As System.Web.UI.ClientIDMode
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Web.UI.ClientIDMode

instance.ClientIDMode = value

value = instance.ClientIDMode
C#
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")]
public virtual System.Web.UI.ClientIDMode ClientIDMode {get; set;}
Delphi
public read-write property ClientIDMode: System.Web.UI.ClientIDMode; virtual;
JScript
System.Web.UI.ThemeableAttribute()
WebCategoryAttribute("Behavior")
System.ComponentModel.DefaultValueAttribute()
WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")
public function get,set ClientIDMode : System.Web.UI.ClientIDMode
Managed Extensions for C++
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")]
public: __property virtual System.Web.UI.ClientIDMode get_ClientIDMode();
public: __property virtual void set_ClientIDMode(
   System.Web.UI.ClientIDMode value
);
C++/CLI
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")]
public:
virtual property System.Web.UI.ClientIDMode ClientIDMode {
   System.Web.UI.ClientIDMode get();
   void set (    System.Web.UI.ClientIDMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


ClientIDSeparator Property

[image]
Intersoft WebTextEditor Documentation
ClientIDSeparator Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : ClientIDSeparator Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property ClientIDSeparator As System.Char
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Char

value = instance.ClientIDSeparator
C#
protected System.char ClientIDSeparator {get;}
Delphi
protected read-only property ClientIDSeparator: System.Char;
JScript
protected function get ClientIDSeparator : System.char
Managed Extensions for C++
protected: __property System.char get_ClientIDSeparator();
C++/CLI
protected:
property System.char ClientIDSeparator {
   System.char get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


Clone Method

[image]
Intersoft WebTextEditor Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


ControlDataTransferFormat Property

[image]
Intersoft WebTextEditor Documentation
ControlDataTransferFormat Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : ControlDataTransferFormat Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines the format used to exchange the control's data across client and server.")>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Overridable Property ControlDataTransferFormat As ISNet.WebUI.DataTransferFormat
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As ISNet.WebUI.DataTransferFormat

instance.ControlDataTransferFormat = value

value = instance.ControlDataTransferFormat
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines the format used to exchange the control's data across client and server.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
public virtual ISNet.WebUI.DataTransferFormat ControlDataTransferFormat {get; set;}
Delphi
public read-write property ControlDataTransferFormat: ISNet.WebUI.DataTransferFormat; virtual;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines the format used to exchange the control's data across client and server.")
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set ControlDataTransferFormat : ISNet.WebUI.DataTransferFormat
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines the format used to exchange the control's data across client and server.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property virtual ISNet.WebUI.DataTransferFormat get_ControlDataTransferFormat();
public: __property virtual void set_ControlDataTransferFormat(
   ISNet.WebUI.DataTransferFormat value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines the format used to exchange the control's data across client and server.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
virtual property ISNet.WebUI.DataTransferFormat ControlDataTransferFormat {
   ISNet.WebUI.DataTransferFormat get();
   void set (    ISNet.WebUI.DataTransferFormat value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


ControlRequestHandler Method

[image]
Intersoft WebTextEditor Documentation
ControlRequestHandler Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : ControlRequestHandler Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Sub ControlRequestHandler()
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader

instance.ControlRequestHandler()
C#
protected void ControlRequestHandler()
Delphi
protected procedure ControlRequestHandler();
JScript
protected function ControlRequestHandler();
Managed Extensions for C++
protected: void ControlRequestHandler();
C++/CLI
protected:
void ControlRequestHandler();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


Controls Property

[image]
Intersoft WebTextEditor Documentation
Controls Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : Controls Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("The collection of child controls owned by the control.")>
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Overridable ReadOnly Property Controls As System.Web.UI.ControlCollection
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Web.UI.ControlCollection

value = instance.Controls
C#
[WebSysDescriptionAttribute("The collection of child controls owned by the control.")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public virtual System.Web.UI.ControlCollection Controls {get;}
Delphi
public read-only property Controls: System.Web.UI.ControlCollection; virtual;
JScript
WebSysDescriptionAttribute("The collection of child controls owned by the control.")
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get Controls : System.Web.UI.ControlCollection
Managed Extensions for C++
[WebSysDescriptionAttribute("The collection of child controls owned by the control.")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property virtual System.Web.UI.ControlCollection* get_Controls();
C++/CLI
[WebSysDescriptionAttribute("The collection of child controls owned by the control.")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
virtual property System.Web.UI.ControlCollection^ Controls {
   System.Web.UI.ControlCollection^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


ControlStyle Property

[image]
Intersoft WebTextEditor Documentation
ControlStyle Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : ControlStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("The style associated with the control.")>
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public ReadOnly Property ControlStyle As System.Web.UI.WebControls.Style
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Web.UI.WebControls.Style

value = instance.ControlStyle
C#
[WebSysDescriptionAttribute("The style associated with the control.")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public System.Web.UI.WebControls.Style ControlStyle {get;}
Delphi
public read-only property ControlStyle: System.Web.UI.WebControls.Style;
JScript
WebSysDescriptionAttribute("The style associated with the control.")
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get ControlStyle : System.Web.UI.WebControls.Style
Managed Extensions for C++
[WebSysDescriptionAttribute("The style associated with the control.")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property System.Web.UI.WebControls.Style* get_ControlStyle();
C++/CLI
[WebSysDescriptionAttribute("The style associated with the control.")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property System.Web.UI.WebControls.Style^ ControlStyle {
   System.Web.UI.WebControls.Style^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


ControlStyleCreated Property

[image]
Intersoft WebTextEditor Documentation
ControlStyleCreated Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : ControlStyleCreated Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
<WebSysDescriptionAttribute("Whether the style associated with the control has been created.")>
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public ReadOnly Property ControlStyleCreated As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Boolean

value = instance.ControlStyleCreated
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[WebSysDescriptionAttribute("Whether the style associated with the control has been created.")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public System.bool ControlStyleCreated {get;}
Delphi
public read-only property ControlStyleCreated: System.Boolean;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
WebSysDescriptionAttribute("Whether the style associated with the control has been created.")
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function get ControlStyleCreated : System.boolean
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[WebSysDescriptionAttribute("Whether the style associated with the control has been created.")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: __property System.bool get_ControlStyleCreated();
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[WebSysDescriptionAttribute("Whether the style associated with the control has been created.")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
property System.bool ControlStyleCreated {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


CopyBaseAttributes Method

[image]
Intersoft WebTextEditor Documentation
CopyBaseAttributes Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : CopyBaseAttributes Method

controlSrc

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CopyBaseAttributes( _
   ByVal controlSrc As System.Web.UI.WebControls.WebControl _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim controlSrc As System.Web.UI.WebControls.WebControl

instance.CopyBaseAttributes(controlSrc)
C#
public void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl controlSrc
)
Delphi
public procedure CopyBaseAttributes(
    controlSrc: System.Web.UI.WebControls.WebControl
);
JScript
public function CopyBaseAttributes(
   controlSrc : System.Web.UI.WebControls.WebControl
);
Managed Extensions for C++
public: void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl* controlSrc
)
C++/CLI
public:
void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl^ controlSrc
)

Parameters

controlSrc

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


CopyFrom Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.ISNetControl)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


CopyFrom(Object) Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members
Overload List


CreateChildControls Method

[image]
Intersoft WebTextEditor Documentation
CreateChildControls Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : CreateChildControls Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub CreateChildControls()
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader

instance.CreateChildControls()
C#
protected virtual void CreateChildControls()
Delphi
protected procedure CreateChildControls(); virtual;
JScript
protected function CreateChildControls();
Managed Extensions for C++
protected: virtual void CreateChildControls();
C++/CLI
protected:
virtual void CreateChildControls();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


CreateControlCollection Method

[image]
Intersoft WebTextEditor Documentation
CreateControlCollection Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : CreateControlCollection Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function CreateControlCollection() As System.Web.UI.ControlCollection
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Web.UI.ControlCollection

value = instance.CreateControlCollection()
C#
protected virtual System.Web.UI.ControlCollection CreateControlCollection()
Delphi
protected function CreateControlCollection(): System.Web.UI.ControlCollection; virtual;
JScript
protected function CreateControlCollection() : System.Web.UI.ControlCollection;
Managed Extensions for C++
protected: virtual System.Web.UI.ControlCollection* CreateControlCollection();
C++/CLI
protected:
virtual System.Web.UI.ControlCollection^ CreateControlCollection();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


CreateControlStyle Method

[image]
Intersoft WebTextEditor Documentation
CreateControlStyle Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : CreateControlStyle Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function CreateControlStyle() As System.Web.UI.WebControls.Style
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Web.UI.WebControls.Style

value = instance.CreateControlStyle()
C#
protected virtual System.Web.UI.WebControls.Style CreateControlStyle()
Delphi
protected function CreateControlStyle(): System.Web.UI.WebControls.Style; virtual;
JScript
protected function CreateControlStyle() : System.Web.UI.WebControls.Style;
Managed Extensions for C++
protected: virtual System.Web.UI.WebControls.Style* CreateControlStyle();
C++/CLI
protected:
virtual System.Web.UI.WebControls.Style^ CreateControlStyle();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


CreateThemeInfo Method

[image]
Intersoft WebTextEditor Documentation
CreateThemeInfo Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : CreateThemeInfo Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function CreateThemeInfo() As ISNet.WebUI.ThemeInfo
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As ISNet.WebUI.ThemeInfo

value = instance.CreateThemeInfo()
C#
protected virtual ISNet.WebUI.ThemeInfo CreateThemeInfo()
Delphi
protected function CreateThemeInfo(): ISNet.WebUI.ThemeInfo; virtual;
JScript
protected function CreateThemeInfo() : ISNet.WebUI.ThemeInfo;
Managed Extensions for C++
protected: virtual ISNet.WebUI.ThemeInfo* CreateThemeInfo();
C++/CLI
protected:
virtual ISNet.WebUI.ThemeInfo^ CreateThemeInfo();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


CssClass Property

[image]
Intersoft WebTextEditor Documentation
CssClass Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : CssClass Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Frame Appearance")>
Public Overridable Property CssClass As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.String

instance.CssClass = value

value = instance.CssClass
C#
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
public virtual System.string CssClass {get; set;}
Delphi
public read-write property CssClass: System.String; virtual;
JScript
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Frame Appearance")
public function get,set CssClass : System.String
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
public: __property virtual System.string* get_CssClass();
public: __property virtual void set_CssClass(
   System.string* value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
public:
virtual property System.String^ CssClass {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


DataBind Method

[image]
Intersoft WebTextEditor Documentation
DataBind Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : DataBind Method

Glossary Item Box

Overload List

Overload | Description
DataBind() | (Inherited from System.Web.UI.Control)
DataBind(Boolean) | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


DataBind() Method

[image]
Intersoft WebTextEditor Documentation
DataBind() Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class > DataBind Method : DataBind() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Overridable Sub DataBind()
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader

instance.DataBind()
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public virtual void DataBind()
Delphi
public procedure DataBind(); virtual;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function DataBind();
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: virtual void DataBind();
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
virtual void DataBind();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members
Overload List


DataBind(Boolean) Method

[image]
Intersoft WebTextEditor Documentation
DataBind(Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class > DataBind Method : DataBind(Boolean) Method

raiseOnDataBinding

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overloads Overridable Sub DataBind( _
   ByVal raiseOnDataBinding As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim raiseOnDataBinding As System.Boolean

instance.DataBind(raiseOnDataBinding)
C#
protected virtual void DataBind(
   System.bool raiseOnDataBinding
)
Delphi
protected procedure DataBind(
    raiseOnDataBinding: System.Boolean
); virtual;
JScript
protected function DataBind(
   raiseOnDataBinding : System.boolean
);
Managed Extensions for C++
protected: virtual void DataBind(
   System.bool raiseOnDataBinding
)
C++/CLI
protected:
virtual void DataBind(
   System.bool raiseOnDataBinding
)

Parameters

raiseOnDataBinding

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members
Overload List


DataBindChildren Method

[image]
Intersoft WebTextEditor Documentation
DataBindChildren Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : DataBindChildren Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub DataBindChildren()
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader

instance.DataBindChildren()
C#
protected virtual void DataBindChildren()
Delphi
protected procedure DataBindChildren(); virtual;
JScript
protected function DataBindChildren();
Managed Extensions for C++
protected: virtual void DataBindChildren();
C++/CLI
protected:
virtual void DataBindChildren();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


DataBinding Event

[image]
Intersoft WebTextEditor Documentation
DataBinding Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : DataBinding Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the control's data binding expressions are to be evaluated.")>
<WebCategoryAttribute("Data")>
Public Event DataBinding As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim handler As System.EventHandler

AddHandler instance.DataBinding, handler
C#
[WebSysDescriptionAttribute("Fires when the control's data binding expressions are to be evaluated.")]
[WebCategoryAttribute("Data")]
public event System.EventHandler DataBinding
Delphi
public event DataBinding: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the control's data binding expressions are to be evaluated.")]
[WebCategoryAttribute("Data")]
public: __event System.EventHandler* DataBinding
C++/CLI
[WebSysDescriptionAttribute("Fires when the control's data binding expressions are to be evaluated.")]
[WebCategoryAttribute("Data")]
public:
event System.EventHandler^ DataBinding

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


DecodeRequest Method

[image]
Intersoft WebTextEditor Documentation
DecodeRequest Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : DecodeRequest Method

request

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function DecodeRequest( _
   ByVal request As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim request As System.String
Dim value As System.String

value = instance.DecodeRequest(request)
C#
protected System.string DecodeRequest(
   System.string request
)
Delphi
protected function DecodeRequest(
    request: System.String
): System.String;
JScript
protected function DecodeRequest(
   request : System.String
) : System.String;
Managed Extensions for C++
protected: System.string* DecodeRequest(
   System.string* request
)
C++/CLI
protected:
System.String^ DecodeRequest(
   System.String^ request
)

Parameters

request

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


DeSerializeObjectData Method

[image]
Intersoft WebTextEditor Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


Dispose Method

[image]
Intersoft WebTextEditor Documentation
Dispose Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : Dispose Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader

instance.Dispose()
C#
public virtual void Dispose()
Delphi
public procedure Dispose(); virtual;
JScript
public function Dispose();
Managed Extensions for C++
public: virtual void Dispose();
C++/CLI
public:
virtual void Dispose();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


Disposed Event

[image]
Intersoft WebTextEditor Documentation
Disposed Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : Disposed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the control has been disposed.")>
Public Event Disposed As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim handler As System.EventHandler

AddHandler instance.Disposed, handler
C#
[WebSysDescriptionAttribute("Fires when the control has been disposed.")]
public event System.EventHandler Disposed
Delphi
public event Disposed: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the control has been disposed.")]
public: __event System.EventHandler* Disposed
C++/CLI
[WebSysDescriptionAttribute("Fires when the control has been disposed.")]
public:
event System.EventHandler^ Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


Enabled Property

[image]
Intersoft WebTextEditor Documentation
Enabled Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : Enabled Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Overridable Property Enabled As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Boolean

instance.Enabled = value

value = instance.Enabled
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public virtual System.bool Enabled {get; set;}
Delphi
public read-write property Enabled: System.Boolean; virtual;
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set Enabled : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property virtual System.bool get_Enabled();
public: __property virtual void set_Enabled(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
virtual property System.bool Enabled {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


EnableManagedTheming Property

[image]
Intersoft WebTextEditor Documentation
EnableManagedTheming Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : EnableManagedTheming Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Overridable Property EnableManagedTheming As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Boolean

instance.EnableManagedTheming = value

value = instance.EnableManagedTheming
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public virtual System.bool EnableManagedTheming {get; set;}
Delphi
public read-write property EnableManagedTheming: System.Boolean; virtual;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set EnableManagedTheming : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property virtual System.bool get_EnableManagedTheming();
public: __property virtual void set_EnableManagedTheming(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
virtual property System.bool EnableManagedTheming {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


EnableTheming Property

[image]
Intersoft WebTextEditor Documentation
EnableTheming Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : EnableTheming Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(True)>
Public Overridable Property EnableTheming As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Boolean

instance.EnableTheming = value

value = instance.EnableTheming
C#
[System.ComponentModel.BrowsableAttribute(true)]
public virtual System.bool EnableTheming {get; set;}
Delphi
public read-write property EnableTheming: System.Boolean; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
public function get,set EnableTheming : System.boolean
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(true)]
public: __property virtual System.bool get_EnableTheming();
public: __property virtual void set_EnableTheming(
   System.bool value
);
C++/CLI
[System.ComponentModel.BrowsableAttribute(true)]
public:
virtual property System.bool EnableTheming {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


EnableViewState Property

[image]
Intersoft WebTextEditor Documentation
EnableViewState Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : EnableViewState Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overridable Property EnableViewState As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Boolean

instance.EnableViewState = value

value = instance.EnableViewState
C#
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public virtual System.bool EnableViewState {get; set;}
Delphi
public read-write property EnableViewState: System.Boolean; virtual;
JScript
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set EnableViewState : System.boolean
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property virtual System.bool get_EnableViewState();
public: __property virtual void set_EnableViewState(
   System.bool value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
virtual property System.bool EnableViewState {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


EnableWebResources Property

[image]
Intersoft WebTextEditor Documentation
EnableWebResources Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : EnableWebResources Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). See help for more information and remarks.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Web Resources")>
Public Property EnableWebResources As ISNet.WebUI.WebResourceType
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As ISNet.WebUI.WebResourceType

instance.EnableWebResources = value

value = instance.EnableWebResources
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). See help for more information and remarks.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Web Resources")]
public ISNet.WebUI.WebResourceType EnableWebResources {get; set;}
Delphi
public read-write property EnableWebResources: ISNet.WebUI.WebResourceType;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). See help for more information and remarks.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Web Resources")
public function get,set EnableWebResources : ISNet.WebUI.WebResourceType
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). See help for more information and remarks.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Web Resources")]
public: __property ISNet.WebUI.WebResourceType get_EnableWebResources();
public: __property void set_EnableWebResources(
   ISNet.WebUI.WebResourceType value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). See help for more information and remarks.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Web Resources")]
public:
property ISNet.WebUI.WebResourceType EnableWebResources {
   ISNet.WebUI.WebResourceType get();
   void set (    ISNet.WebUI.WebResourceType value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


EnsureChildControls Method

[image]
Intersoft WebTextEditor Documentation
EnsureChildControls Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : EnsureChildControls Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub EnsureChildControls()
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader

instance.EnsureChildControls()
C#
protected virtual void EnsureChildControls()
Delphi
protected procedure EnsureChildControls(); virtual;
JScript
protected function EnsureChildControls();
Managed Extensions for C++
protected: virtual void EnsureChildControls();
C++/CLI
protected:
virtual void EnsureChildControls();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


EnsureID Method

[image]
Intersoft WebTextEditor Documentation
EnsureID Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : EnsureID Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Sub EnsureID()
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader

instance.EnsureID()
C#
protected void EnsureID()
Delphi
protected procedure EnsureID();
JScript
protected function EnsureID();
Managed Extensions for C++
protected: void EnsureID();
C++/CLI
protected:
void EnsureID();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


Events Property

[image]
Intersoft WebTextEditor Documentation
Events Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : Events Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property Events As System.ComponentModel.EventHandlerList
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.ComponentModel.EventHandlerList

value = instance.Events
C#
protected System.ComponentModel.EventHandlerList Events {get;}
Delphi
protected read-only property Events: System.ComponentModel.EventHandlerList;
JScript
protected function get Events : System.ComponentModel.EventHandlerList
Managed Extensions for C++
protected: __property System.ComponentModel.EventHandlerList* get_Events();
C++/CLI
protected:
property System.ComponentModel.EventHandlerList^ Events {
   System.ComponentModel.EventHandlerList^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


FindControl Method

[image]
Intersoft WebTextEditor Documentation
FindControl Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : FindControl Method

Glossary Item Box

Overload List

Overload | Description
FindControl(String) | (Inherited from ISNet.WebUI.ISNetControl)
FindControl(String,Int32) | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


FindControl(String) Method

[image]
Intersoft WebTextEditor Documentation
FindControl(String) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class > FindControl Method : FindControl(String) Method

id

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function FindControl( _
   ByVal id As System.String _
) As System.Web.UI.Control
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim id As System.String
Dim value As System.Web.UI.Control

value = instance.FindControl(id)
C#
public virtual System.Web.UI.Control FindControl(
   System.string id
)
Delphi
public function FindControl(
    id: System.String
): System.Web.UI.Control; virtual;
JScript
public function FindControl(
   id : System.String
) : System.Web.UI.Control;
Managed Extensions for C++
public: virtual System.Web.UI.Control* FindControl(
   System.string* id
)
C++/CLI
public:
virtual System.Web.UI.Control^ FindControl(
   System.String^ id
)

Parameters

id

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members
Overload List


FindControl(String,Int32) Method

[image]
Intersoft WebTextEditor Documentation
FindControl(String,Int32) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class > FindControl Method : FindControl(String,Int32) Method

id
pathOffset

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overloads Overridable Function FindControl( _
   ByVal id As System.String, _
   ByVal pathOffset As System.Integer _
) As System.Web.UI.Control
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim id As System.String
Dim pathOffset As System.Integer
Dim value As System.Web.UI.Control

value = instance.FindControl(id, pathOffset)
C#
protected virtual System.Web.UI.Control FindControl(
   System.string id,
   System.int pathOffset
)
Delphi
protected function FindControl(
    id: System.String;
    pathOffset: System.Integer
): System.Web.UI.Control; virtual;
JScript
protected function FindControl(
   id : System.String,
   pathOffset : System.int
) : System.Web.UI.Control;
Managed Extensions for C++
protected: virtual System.Web.UI.Control* FindControl(
   System.string* id,
   System.int pathOffset
)
C++/CLI
protected:
virtual System.Web.UI.Control^ FindControl(
   System.String^ id,
   System.int pathOffset
)

Parameters

id
pathOffset

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members
Overload List


Focus Method

[image]
Intersoft WebTextEditor Documentation
Focus Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : Focus Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Focus()
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader

instance.Focus()
C#
public virtual void Focus()
Delphi
public procedure Focus(); virtual;
JScript
public function Focus();
Managed Extensions for C++
public: virtual void Focus();
C++/CLI
public:
virtual void Focus();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


Font Property

[image]
Intersoft WebTextEditor Documentation
Font Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : Font Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Frame Appearance")>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)>
Public Overridable ReadOnly Property Font As System.Web.UI.WebControls.FontInfo
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Web.UI.WebControls.FontInfo

value = instance.Font
C#
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
public virtual System.Web.UI.WebControls.FontInfo Font {get;}
Delphi
public read-only property Font: System.Web.UI.WebControls.FontInfo; virtual;
JScript
System.ComponentModel.CategoryAttribute("Frame Appearance")
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)
public function get Font : System.Web.UI.WebControls.FontInfo
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
public: __property virtual System.Web.UI.WebControls.FontInfo* get_Font();
C++/CLI
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
public:
virtual property System.Web.UI.WebControls.FontInfo^ Font {
   System.Web.UI.WebControls.FontInfo^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


ForceDisableXmlCompression Method

[image]
Intersoft WebTextEditor Documentation
ForceDisableXmlCompression Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : ForceDisableXmlCompression Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ForceDisableXmlCompression()
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader

instance.ForceDisableXmlCompression()
C#
public void ForceDisableXmlCompression()
Delphi
public procedure ForceDisableXmlCompression();
JScript
public function ForceDisableXmlCompression();
Managed Extensions for C++
public: void ForceDisableXmlCompression();
C++/CLI
public:
void ForceDisableXmlCompression();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


ForeColor Property

[image]
Intersoft WebTextEditor Documentation
ForeColor Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : ForeColor Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.CategoryAttribute("Frame Appearance")>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Overridable Property ForeColor As System.Drawing.Color
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Drawing.Color

instance.ForeColor = value

value = instance.ForeColor
C#
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
public virtual System.Drawing.Color ForeColor {get; set;}
Delphi
public read-write property ForeColor: System.Drawing.Color; virtual;
JScript
ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.CategoryAttribute("Frame Appearance")
ISNet.Serialization.BinarySerializableAttribute()
public function get,set ForeColor : System.Drawing.Color
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property virtual System.Drawing.Color get_ForeColor();
public: __property virtual void set_ForeColor(
   System.Drawing.Color value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute(XmlSerializationType.Layout)]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Frame Appearance")]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
virtual property System.Drawing.Color ForeColor {
   System.Drawing.Color get();
   void set (    System.Drawing.Color value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


GetApplicationState Method

[image]
Intersoft WebTextEditor Documentation
GetApplicationState Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : GetApplicationState Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetApplicationState() As System.Web.HttpApplicationState
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Web.HttpApplicationState

value = instance.GetApplicationState()
C#
protected virtual System.Web.HttpApplicationState GetApplicationState()
Delphi
protected function GetApplicationState(): System.Web.HttpApplicationState; virtual;
JScript
protected function GetApplicationState() : System.Web.HttpApplicationState;
Managed Extensions for C++
protected: virtual System.Web.HttpApplicationState* GetApplicationState();
C++/CLI
protected:
virtual System.Web.HttpApplicationState^ GetApplicationState();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


GetCachedAppTheme Method

[image]
Intersoft WebTextEditor Documentation
GetCachedAppTheme Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : GetCachedAppTheme Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function GetCachedAppTheme() As ISNet.WebUI.ThemeInfo
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As ISNet.WebUI.ThemeInfo

value = instance.GetCachedAppTheme()
C#
protected ISNet.WebUI.ThemeInfo GetCachedAppTheme()
Delphi
protected function GetCachedAppTheme(): ISNet.WebUI.ThemeInfo;
JScript
protected function GetCachedAppTheme() : ISNet.WebUI.ThemeInfo;
Managed Extensions for C++
protected: ISNet.WebUI.ThemeInfo* GetCachedAppTheme();
C++/CLI
protected:
ISNet.WebUI.ThemeInfo^ GetCachedAppTheme();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


GetCurrentControlLifeCycle Method

[image]
Intersoft WebTextEditor Documentation
GetCurrentControlLifeCycle Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : GetCurrentControlLifeCycle Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetCurrentControlLifeCycle() As ISNet.WebUI.ControlLifeCycle
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As ISNet.WebUI.ControlLifeCycle

value = instance.GetCurrentControlLifeCycle()
C#
public ISNet.WebUI.ControlLifeCycle GetCurrentControlLifeCycle()
Delphi
public function GetCurrentControlLifeCycle(): ISNet.WebUI.ControlLifeCycle;
JScript
public function GetCurrentControlLifeCycle() : ISNet.WebUI.ControlLifeCycle;
Managed Extensions for C++
public: ISNet.WebUI.ControlLifeCycle GetCurrentControlLifeCycle();
C++/CLI
public:
ISNet.WebUI.ControlLifeCycle GetCurrentControlLifeCycle();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


GetCurrentTheme Method

[image]
Intersoft WebTextEditor Documentation
GetCurrentTheme Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : GetCurrentTheme Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetCurrentTheme() As ISNet.WebUI.ThemeInfo
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As ISNet.WebUI.ThemeInfo

value = instance.GetCurrentTheme()
C#
public ISNet.WebUI.ThemeInfo GetCurrentTheme()
Delphi
public function GetCurrentTheme(): ISNet.WebUI.ThemeInfo;
JScript
public function GetCurrentTheme() : ISNet.WebUI.ThemeInfo;
Managed Extensions for C++
public: ISNet.WebUI.ThemeInfo* GetCurrentTheme();
C++/CLI
public:
ISNet.WebUI.ThemeInfo^ GetCurrentTheme();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


GetDesignModeState Method

[image]
Intersoft WebTextEditor Documentation
GetDesignModeState Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : GetDesignModeState Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.NoFlags,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=False,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=True)>
Protected Overridable Function GetDesignModeState() As System.Collections.IDictionary
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Collections.IDictionary

value = instance.GetDesignModeState()
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.NoFlags,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=true)]
protected virtual System.Collections.IDictionary GetDesignModeState()
Delphi
protected function GetDesignModeState(): System.Collections.IDictionary; virtual;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.NoFlags,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
protected function GetDesignModeState() : System.Collections.IDictionary;
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.NoFlags,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=true)]
protected: virtual System.Collections.IDictionary* GetDesignModeState();
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.NoFlags,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=true)]
protected:
virtual System.Collections.IDictionary^ GetDesignModeState();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


GetFrameworkDataFolder Method

[image]
Intersoft WebTextEditor Documentation
GetFrameworkDataFolder Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : GetFrameworkDataFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkDataFolder() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.String

value = instance.GetFrameworkDataFolder()
C#
public System.string GetFrameworkDataFolder()
Delphi
public function GetFrameworkDataFolder(): System.String;
JScript
public function GetFrameworkDataFolder() : System.String;
Managed Extensions for C++
public: System.string* GetFrameworkDataFolder();
C++/CLI
public:
System.String^ GetFrameworkDataFolder();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


GetFrameworkFolder Method

[image]
Intersoft WebTextEditor Documentation
GetFrameworkFolder Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : GetFrameworkFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkFolder() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.String

value = instance.GetFrameworkFolder()
C#
public System.string GetFrameworkFolder()
Delphi
public function GetFrameworkFolder(): System.String;
JScript
public function GetFrameworkFolder() : System.String;
Managed Extensions for C++
public: System.string* GetFrameworkFolder();
C++/CLI
public:
System.String^ GetFrameworkFolder();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


GetFrameworkVersion Method

[image]
Intersoft WebTextEditor Documentation
GetFrameworkVersion Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : GetFrameworkVersion Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkVersion() As System.Version
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Version

value = instance.GetFrameworkVersion()
C#
public System.Version GetFrameworkVersion()
Delphi
public function GetFrameworkVersion(): System.Version;
JScript
public function GetFrameworkVersion() : System.Version;
Managed Extensions for C++
public: System.Version* GetFrameworkVersion();
C++/CLI
public:
System.Version^ GetFrameworkVersion();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


GetIntersoftFolder Method

[image]
Intersoft WebTextEditor Documentation
GetIntersoftFolder Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : GetIntersoftFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetIntersoftFolder() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.String

value = instance.GetIntersoftFolder()
C#
public System.string GetIntersoftFolder()
Delphi
public function GetIntersoftFolder(): System.String;
JScript
public function GetIntersoftFolder() : System.String;
Managed Extensions for C++
public: System.string* GetIntersoftFolder();
C++/CLI
public:
System.String^ GetIntersoftFolder();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


GetLayoutFolder Method

[image]
Intersoft WebTextEditor Documentation
GetLayoutFolder Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : GetLayoutFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetLayoutFolder() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.String

value = instance.GetLayoutFolder()
C#
public System.string GetLayoutFolder()
Delphi
public function GetLayoutFolder(): System.String;
JScript
public function GetLayoutFolder() : System.String;
Managed Extensions for C++
public: System.string* GetLayoutFolder();
C++/CLI
public:
System.String^ GetLayoutFolder();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


GetPostedXMLData Method

[image]
Intersoft WebTextEditor Documentation
GetPostedXMLData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : GetPostedXMLData Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetPostedXMLData() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.String

value = instance.GetPostedXMLData()
C#
public System.string GetPostedXMLData()
Delphi
public function GetPostedXMLData(): System.String;
JScript
public function GetPostedXMLData() : System.String;
Managed Extensions for C++
public: System.string* GetPostedXMLData();
C++/CLI
public:
System.String^ GetPostedXMLData();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


GetProductInfoKey Method

[image]
Intersoft WebTextEditor Documentation
GetProductInfoKey Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : GetProductInfoKey Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetProductInfoKey() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.String

value = instance.GetProductInfoKey()
C#
public System.string GetProductInfoKey()
Delphi
public function GetProductInfoKey(): System.String;
JScript
public function GetProductInfoKey() : System.String;
Managed Extensions for C++
public: System.string* GetProductInfoKey();
C++/CLI
public:
System.String^ GetProductInfoKey();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


GetProductSimpleName Method

[image]
Intersoft WebTextEditor Documentation
GetProductSimpleName Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : GetProductSimpleName Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetProductSimpleName() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.String

value = instance.GetProductSimpleName()
C#
public System.string GetProductSimpleName()
Delphi
public function GetProductSimpleName(): System.String;
JScript
public function GetProductSimpleName() : System.String;
Managed Extensions for C++
public: System.string* GetProductSimpleName();
C++/CLI
public:
System.String^ GetProductSimpleName();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


GetPropertyString Method

[image]
Intersoft WebTextEditor Documentation
GetPropertyString Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : GetPropertyString Method

v

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetPropertyString( _
   ByVal v As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim v As System.String
Dim value As System.String

value = instance.GetPropertyString(v)
C#
protected virtual System.string GetPropertyString(
   System.string v
)
Delphi
protected function GetPropertyString(
    v: System.String
): System.String; virtual;
JScript
protected function GetPropertyString(
   v : System.String
) : System.String;
Managed Extensions for C++
protected: virtual System.string* GetPropertyString(
   System.string* v
)
C++/CLI
protected:
virtual System.String^ GetPropertyString(
   System.String^ v
)

Parameters

v

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


GetPropertyValue Method

[image]
Intersoft WebTextEditor Documentation
GetPropertyValue Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : GetPropertyValue Method

defValue
propValue
webConfigKey

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetPropertyValue( _
   ByVal defValue As System.String, _
   ByVal propValue As System.String, _
   ByVal webConfigKey As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim defValue As System.String
Dim propValue As System.String
Dim webConfigKey As System.String
Dim value As System.String

value = instance.GetPropertyValue(defValue, propValue, webConfigKey)
C#
public System.string GetPropertyValue(
   System.string defValue,
   System.string propValue,
   System.string webConfigKey
)
Delphi
public function GetPropertyValue(
    defValue: System.String;
    propValue: System.String;
    webConfigKey: System.String
): System.String;
JScript
public function GetPropertyValue(
   defValue : System.String,
   propValue : System.String,
   webConfigKey : System.String
) : System.String;
Managed Extensions for C++
public: System.string* GetPropertyValue(
   System.string* defValue,
   System.string* propValue,
   System.string* webConfigKey
)
C++/CLI
public:
System.String^ GetPropertyValue(
   System.String^ defValue,
   System.String^ propValue,
   System.String^ webConfigKey
)

Parameters

defValue
propValue
webConfigKey

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


GetResourceStream Method

[image]
Intersoft WebTextEditor Documentation
GetResourceStream Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : GetResourceStream Method

resourceUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetResourceStream( _
   ByVal resourceUrl As System.String _
) As System.IO.Stream
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim resourceUrl As System.String
Dim value As System.IO.Stream

value = instance.GetResourceStream(resourceUrl)
C#
public System.IO.Stream GetResourceStream(
   System.string resourceUrl
)
Delphi
public function GetResourceStream(
    resourceUrl: System.String
): System.IO.Stream;
JScript
public function GetResourceStream(
   resourceUrl : System.String
) : System.IO.Stream;
Managed Extensions for C++
public: System.IO.Stream* GetResourceStream(
   System.string* resourceUrl
)
C++/CLI
public:
System.IO.Stream^ GetResourceStream(
   System.String^ resourceUrl
)

Parameters

resourceUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


GetRouteUrl Method

[image]
Intersoft WebTextEditor Documentation
GetRouteUrl Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : GetRouteUrl Method

Glossary Item Box

Overload List

Overload | Description
GetRouteUrl(Object) | (Inherited from System.Web.UI.Control)
GetRouteUrl(String,Object) | (Inherited from System.Web.UI.Control)
GetRouteUrl(RouteValueDictionary) | (Inherited from System.Web.UI.Control)
GetRouteUrl(String,RouteValueDictionary) | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


GetRouteUrl(Object) Method

[image]
Intersoft WebTextEditor Documentation
GetRouteUrl(Object) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class > GetRouteUrl Method : GetRouteUrl(Object) Method

routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As System.Object _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim routeParameters As System.Object
Dim value As System.String

value = instance.GetRouteUrl(routeParameters)
C#
public System.string GetRouteUrl(
   System.object routeParameters
)
Delphi
public function GetRouteUrl(
    routeParameters: System.TObject
): System.String;
JScript
public function GetRouteUrl(
   routeParameters : System.Object
) : System.String;
Managed Extensions for C++
public: System.string* GetRouteUrl(
   System.Object* routeParameters
)
C++/CLI
public:
System.String^ GetRouteUrl(
   System.Object^ routeParameters
)

Parameters

routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members
Overload List


GetRouteUrl(RouteValueDictionary) Method

[image]
Intersoft WebTextEditor Documentation
GetRouteUrl(RouteValueDictionary) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class > GetRouteUrl Method : GetRouteUrl(RouteValueDictionary) Method

routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim routeParameters As System.Web.Routing.RouteValueDictionary
Dim value As System.String

value = instance.GetRouteUrl(routeParameters)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.string GetRouteUrl(
   System.Web.Routing.RouteValueDictionary routeParameters
)
Delphi
public function GetRouteUrl(
    routeParameters: System.Web.Routing.RouteValueDictionary
): System.String;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function GetRouteUrl(
   routeParameters : System.Web.Routing.RouteValueDictionary
) : System.String;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.string* GetRouteUrl(
   System.Web.Routing.RouteValueDictionary* routeParameters
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.String^ GetRouteUrl(
   System.Web.Routing.RouteValueDictionary^ routeParameters
)

Parameters

routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members
Overload List


GetRouteUrl(String,Object) Method

[image]
Intersoft WebTextEditor Documentation
GetRouteUrl(String,Object) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class > GetRouteUrl Method : GetRouteUrl(String,Object) Method

routeName
routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeName As System.String, _
   ByVal routeParameters As System.Object _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim routeName As System.String
Dim routeParameters As System.Object
Dim value As System.String

value = instance.GetRouteUrl(routeName, routeParameters)
C#
public System.string GetRouteUrl(
   System.string routeName,
   System.object routeParameters
)
Delphi
public function GetRouteUrl(
    routeName: System.String;
    routeParameters: System.TObject
): System.String;
JScript
public function GetRouteUrl(
   routeName : System.String,
   routeParameters : System.Object
) : System.String;
Managed Extensions for C++
public: System.string* GetRouteUrl(
   System.string* routeName,
   System.Object* routeParameters
)
C++/CLI
public:
System.String^ GetRouteUrl(
   System.String^ routeName,
   System.Object^ routeParameters
)

Parameters

routeName
routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members
Overload List


GetRouteUrl(String,RouteValueDictionary) Method

[image]
Intersoft WebTextEditor Documentation
GetRouteUrl(String,RouteValueDictionary) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class > GetRouteUrl Method : GetRouteUrl(String,RouteValueDictionary) Method

routeName
routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeName As System.String, _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim routeName As System.String
Dim routeParameters As System.Web.Routing.RouteValueDictionary
Dim value As System.String

value = instance.GetRouteUrl(routeName, routeParameters)
C#
public System.string GetRouteUrl(
   System.string routeName,
   System.Web.Routing.RouteValueDictionary routeParameters
)
Delphi
public function GetRouteUrl(
    routeName: System.String;
    routeParameters: System.Web.Routing.RouteValueDictionary
): System.String;
JScript
public function GetRouteUrl(
   routeName : System.String,
   routeParameters : System.Web.Routing.RouteValueDictionary
) : System.String;
Managed Extensions for C++
public: System.string* GetRouteUrl(
   System.string* routeName,
   System.Web.Routing.RouteValueDictionary* routeParameters
)
C++/CLI
public:
System.String^ GetRouteUrl(
   System.String^ routeName,
   System.Web.Routing.RouteValueDictionary^ routeParameters
)

Parameters

routeName
routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members
Overload List


GetSessionLevelTheme Method

[image]
Intersoft WebTextEditor Documentation
GetSessionLevelTheme Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : GetSessionLevelTheme Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function GetSessionLevelTheme() As ISNet.WebUI.ThemeInfo
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As ISNet.WebUI.ThemeInfo

value = instance.GetSessionLevelTheme()
C#
protected ISNet.WebUI.ThemeInfo GetSessionLevelTheme()
Delphi
protected function GetSessionLevelTheme(): ISNet.WebUI.ThemeInfo;
JScript
protected function GetSessionLevelTheme() : ISNet.WebUI.ThemeInfo;
Managed Extensions for C++
protected: ISNet.WebUI.ThemeInfo* GetSessionLevelTheme();
C++/CLI
protected:
ISNet.WebUI.ThemeInfo^ GetSessionLevelTheme();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


GetUniqueIDRelativeTo Method

[image]
Intersoft WebTextEditor Documentation
GetUniqueIDRelativeTo Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : GetUniqueIDRelativeTo Method

control

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetUniqueIDRelativeTo( _
   ByVal control As System.Web.UI.Control _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim control As System.Web.UI.Control
Dim value As System.String

value = instance.GetUniqueIDRelativeTo(control)
C#
public System.string GetUniqueIDRelativeTo(
   System.Web.UI.Control control
)
Delphi
public function GetUniqueIDRelativeTo(
    control: System.Web.UI.Control
): System.String;
JScript
public function GetUniqueIDRelativeTo(
   control : System.Web.UI.Control
) : System.String;
Managed Extensions for C++
public: System.string* GetUniqueIDRelativeTo(
   System.Web.UI.Control* control
)
C++/CLI
public:
System.String^ GetUniqueIDRelativeTo(
   System.Web.UI.Control^ control
)

Parameters

control

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


HasAttributes Property

[image]
Intersoft WebTextEditor Documentation
HasAttributes Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : HasAttributes Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public ReadOnly Property HasAttributes As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Boolean

value = instance.HasAttributes
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public System.bool HasAttributes {get;}
Delphi
public read-only property HasAttributes: System.Boolean;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get HasAttributes : System.boolean
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property System.bool get_HasAttributes();
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property System.bool HasAttributes {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


HasChildViewState Property

[image]
Intersoft WebTextEditor Documentation
HasChildViewState Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : HasChildViewState Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property HasChildViewState As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Boolean

value = instance.HasChildViewState
C#
protected System.bool HasChildViewState {get;}
Delphi
protected read-only property HasChildViewState: System.Boolean;
JScript
protected function get HasChildViewState : System.boolean
Managed Extensions for C++
protected: __property System.bool get_HasChildViewState();
C++/CLI
protected:
property System.bool HasChildViewState {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


HasControls Method

[image]
Intersoft WebTextEditor Documentation
HasControls Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : HasControls Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function HasControls() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Boolean

value = instance.HasControls()
C#
public virtual System.bool HasControls()
Delphi
public function HasControls(): System.Boolean; virtual;
JScript
public function HasControls() : System.boolean;
Managed Extensions for C++
public: virtual System.bool HasControls();
C++/CLI
public:
virtual System.bool HasControls();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


HasEvents Method

[image]
Intersoft WebTextEditor Documentation
HasEvents Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : HasEvents Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Protected Function HasEvents() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Boolean

value = instance.HasEvents()
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
protected System.bool HasEvents()
Delphi
protected function HasEvents(): System.Boolean;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
protected function HasEvents() : System.boolean;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
protected: System.bool HasEvents();
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
protected:
System.bool HasEvents();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


ID Property

[image]
Intersoft WebTextEditor Documentation
ID Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : ID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.FilterableAttribute(False)>
<System.Web.UI.ThemeableAttribute(False)>
<WebSysDescriptionAttribute("Programmatic name of the control.")>
<System.ComponentModel.ParenthesizePropertyNameAttribute(True)>
<System.ComponentModel.MergablePropertyAttribute(False)>
Public Overridable Property ID As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.String

instance.ID = value

value = instance.ID
C#
[System.Web.UI.FilterableAttribute(false)]
[System.Web.UI.ThemeableAttribute(false)]
[WebSysDescriptionAttribute("Programmatic name of the control.")]
[System.ComponentModel.ParenthesizePropertyNameAttribute(true)]
[System.ComponentModel.MergablePropertyAttribute(false)]
public virtual System.string ID {get; set;}
Delphi
public read-write property ID: System.String; virtual;
JScript
System.Web.UI.FilterableAttribute()
System.Web.UI.ThemeableAttribute()
WebSysDescriptionAttribute("Programmatic name of the control.")
System.ComponentModel.ParenthesizePropertyNameAttribute()
System.ComponentModel.MergablePropertyAttribute()
public function get,set ID : System.String
Managed Extensions for C++
[System.Web.UI.FilterableAttribute(false)]
[System.Web.UI.ThemeableAttribute(false)]
[WebSysDescriptionAttribute("Programmatic name of the control.")]
[System.ComponentModel.ParenthesizePropertyNameAttribute(true)]
[System.ComponentModel.MergablePropertyAttribute(false)]
public: __property virtual System.string* get_ID();
public: __property virtual void set_ID(
   System.string* value
);
C++/CLI
[System.Web.UI.FilterableAttribute(false)]
[System.Web.UI.ThemeableAttribute(false)]
[WebSysDescriptionAttribute("Programmatic name of the control.")]
[System.ComponentModel.ParenthesizePropertyNameAttribute(true)]
[System.ComponentModel.MergablePropertyAttribute(false)]
public:
virtual property System.String^ ID {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


IdSeparator Property

[image]
Intersoft WebTextEditor Documentation
IdSeparator Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : IdSeparator Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property IdSeparator As System.Char
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Char

value = instance.IdSeparator
C#
protected System.char IdSeparator {get;}
Delphi
protected read-only property IdSeparator: System.Char;
JScript
protected function get IdSeparator : System.char
Managed Extensions for C++
protected: __property System.char get_IdSeparator();
C++/CLI
protected:
property System.char IdSeparator {
   System.char get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


Init Event

[image]
Intersoft WebTextEditor Documentation
Init Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : Init Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the page has been initialized.")>
Public Event Init As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim handler As System.EventHandler

AddHandler instance.Init, handler
C#
[WebSysDescriptionAttribute("Fires when the page has been initialized.")]
public event System.EventHandler Init
Delphi
public event Init: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the page has been initialized.")]
public: __event System.EventHandler* Init
C++/CLI
[WebSysDescriptionAttribute("Fires when the page has been initialized.")]
public:
event System.EventHandler^ Init

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


InitializeLayoutBehaviors Method

[image]
Intersoft WebTextEditor Documentation
InitializeLayoutBehaviors Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : InitializeLayoutBehaviors Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub InitializeLayoutBehaviors()
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader

instance.InitializeLayoutBehaviors()
C#
protected virtual void InitializeLayoutBehaviors()
Delphi
protected procedure InitializeLayoutBehaviors(); virtual;
JScript
protected function InitializeLayoutBehaviors();
Managed Extensions for C++
protected: virtual void InitializeLayoutBehaviors();
C++/CLI
protected:
virtual void InitializeLayoutBehaviors();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


InitializeManagedTheming Method

[image]
Intersoft WebTextEditor Documentation
InitializeManagedTheming Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : InitializeManagedTheming Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub InitializeManagedTheming()
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader

instance.InitializeManagedTheming()
C#
protected virtual void InitializeManagedTheming()
Delphi
protected procedure InitializeManagedTheming(); virtual;
JScript
protected function InitializeManagedTheming();
Managed Extensions for C++
protected: virtual void InitializeManagedTheming();
C++/CLI
protected:
virtual void InitializeManagedTheming();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


IsApplicationAvailable Method

[image]
Intersoft WebTextEditor Documentation
IsApplicationAvailable Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : IsApplicationAvailable Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function IsApplicationAvailable() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Boolean

value = instance.IsApplicationAvailable()
C#
protected System.bool IsApplicationAvailable()
Delphi
protected function IsApplicationAvailable(): System.Boolean;
JScript
protected function IsApplicationAvailable() : System.boolean;
Managed Extensions for C++
protected: System.bool IsApplicationAvailable();
C++/CLI
protected:
System.bool IsApplicationAvailable();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


IsAppThemeEnabled Method

[image]
Intersoft WebTextEditor Documentation
IsAppThemeEnabled Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : IsAppThemeEnabled Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function IsAppThemeEnabled() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Boolean

value = instance.IsAppThemeEnabled()
C#
protected virtual System.bool IsAppThemeEnabled()
Delphi
protected function IsAppThemeEnabled(): System.Boolean; virtual;
JScript
protected function IsAppThemeEnabled() : System.boolean;
Managed Extensions for C++
protected: virtual System.bool IsAppThemeEnabled();
C++/CLI
protected:
virtual System.bool IsAppThemeEnabled();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


IsAtlasCallback Method

[image]
Intersoft WebTextEditor Documentation
IsAtlasCallback Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : IsAtlasCallback Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsAtlasCallback() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Boolean

value = instance.IsAtlasCallback()
C#
public System.bool IsAtlasCallback()
Delphi
public function IsAtlasCallback(): System.Boolean;
JScript
public function IsAtlasCallback() : System.boolean;
Managed Extensions for C++
public: System.bool IsAtlasCallback();
C++/CLI
public:
System.bool IsAtlasCallback();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


IsBetaRelease Method

[image]
Intersoft WebTextEditor Documentation
IsBetaRelease Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : IsBetaRelease Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsBetaRelease() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Boolean

value = instance.IsBetaRelease()
C#
public System.bool IsBetaRelease()
Delphi
public function IsBetaRelease(): System.Boolean;
JScript
public function IsBetaRelease() : System.boolean;
Managed Extensions for C++
public: System.bool IsBetaRelease();
C++/CLI
public:
System.bool IsBetaRelease();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


IsChromeBrowser Method

[image]
Intersoft WebTextEditor Documentation
IsChromeBrowser Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : IsChromeBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsChromeBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Boolean

value = instance.IsChromeBrowser()
C#
public System.bool IsChromeBrowser()
Delphi
public function IsChromeBrowser(): System.Boolean;
JScript
public function IsChromeBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsChromeBrowser();
C++/CLI
public:
System.bool IsChromeBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


IsControlThemed Property

[image]
Intersoft WebTextEditor Documentation
IsControlThemed Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : IsControlThemed Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public ReadOnly Property IsControlThemed As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Boolean

value = instance.IsControlThemed
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public System.bool IsControlThemed {get;}
Delphi
public read-only property IsControlThemed: System.Boolean;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get IsControlThemed : System.boolean
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property System.bool get_IsControlThemed();
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property System.bool IsControlThemed {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


IsDesign Property

[image]
Intersoft WebTextEditor Documentation
IsDesign Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : IsDesign Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Overridable ReadOnly Property IsDesign As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Boolean

value = instance.IsDesign
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public virtual System.bool IsDesign {get;}
Delphi
public read-only property IsDesign: System.Boolean; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get IsDesign : System.boolean
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property virtual System.bool get_IsDesign();
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
virtual property System.bool IsDesign {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


IsDynamicCreated Property

[image]
Intersoft WebTextEditor Documentation
IsDynamicCreated Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : IsDynamicCreated Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
Public Property IsDynamicCreated As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Boolean

instance.IsDynamicCreated = value

value = instance.IsDynamicCreated
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public System.bool IsDynamicCreated {get; set;}
Delphi
public read-write property IsDynamicCreated: System.Boolean;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
public function get,set IsDynamicCreated : System.boolean
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public: __property System.bool get_IsDynamicCreated();
public: __property void set_IsDynamicCreated(
   System.bool value
);
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public:
property System.bool IsDynamicCreated {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


IsEmpty Method

[image]
Intersoft WebTextEditor Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


IsFlyPostBackControl Method

[image]
Intersoft WebTextEditor Documentation
IsFlyPostBackControl Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : IsFlyPostBackControl Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsFlyPostBackControl() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Boolean

value = instance.IsFlyPostBackControl()
C#
public virtual System.bool IsFlyPostBackControl()
Delphi
public function IsFlyPostBackControl(): System.Boolean; virtual;
JScript
public function IsFlyPostBackControl() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsFlyPostBackControl();
C++/CLI
public:
virtual System.bool IsFlyPostBackControl();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


IsFlyPostBackRequest Method

[image]
Intersoft WebTextEditor Documentation
IsFlyPostBackRequest Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : IsFlyPostBackRequest Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsFlyPostBackRequest() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Boolean

value = instance.IsFlyPostBackRequest()
C#
public virtual System.bool IsFlyPostBackRequest()
Delphi
public function IsFlyPostBackRequest(): System.Boolean; virtual;
JScript
public function IsFlyPostBackRequest() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsFlyPostBackRequest();
C++/CLI
public:
virtual System.bool IsFlyPostBackRequest();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


IsGeckoBasedBrowser Method

[image]
Intersoft WebTextEditor Documentation
IsGeckoBasedBrowser Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : IsGeckoBasedBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsGeckoBasedBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Boolean

value = instance.IsGeckoBasedBrowser()
C#
public System.bool IsGeckoBasedBrowser()
Delphi
public function IsGeckoBasedBrowser(): System.Boolean;
JScript
public function IsGeckoBasedBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsGeckoBasedBrowser();
C++/CLI
public:
System.bool IsGeckoBasedBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


IsGeckoVersion18 Method

[image]
Intersoft WebTextEditor Documentation
IsGeckoVersion18 Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : IsGeckoVersion18 Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsGeckoVersion18() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Boolean

value = instance.IsGeckoVersion18()
C#
public System.bool IsGeckoVersion18()
Delphi
public function IsGeckoVersion18(): System.Boolean;
JScript
public function IsGeckoVersion18() : System.boolean;
Managed Extensions for C++
public: System.bool IsGeckoVersion18();
C++/CLI
public:
System.bool IsGeckoVersion18();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


IsInDesignMode Method

[image]
Intersoft WebTextEditor Documentation
IsInDesignMode Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : IsInDesignMode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInDesignMode() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Boolean

value = instance.IsInDesignMode()
C#
public System.bool IsInDesignMode()
Delphi
public function IsInDesignMode(): System.Boolean;
JScript
public function IsInDesignMode() : System.boolean;
Managed Extensions for C++
public: System.bool IsInDesignMode();
C++/CLI
public:
System.bool IsInDesignMode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


IsInternalCreated Property

[image]
Intersoft WebTextEditor Documentation
IsInternalCreated Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : IsInternalCreated Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
Public Property IsInternalCreated As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Boolean

instance.IsInternalCreated = value

value = instance.IsInternalCreated
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public System.bool IsInternalCreated {get; set;}
Delphi
public read-write property IsInternalCreated: System.Boolean;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
public function get,set IsInternalCreated : System.boolean
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public: __property System.bool get_IsInternalCreated();
public: __property void set_IsInternalCreated(
   System.bool value
);
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public:
property System.bool IsInternalCreated {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


IsInternetExplorer8Browser Method

[image]
Intersoft WebTextEditor Documentation
IsInternetExplorer8Browser Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : IsInternetExplorer8Browser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInternetExplorer8Browser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Boolean

value = instance.IsInternetExplorer8Browser()
C#
public System.bool IsInternetExplorer8Browser()
Delphi
public function IsInternetExplorer8Browser(): System.Boolean;
JScript
public function IsInternetExplorer8Browser() : System.boolean;
Managed Extensions for C++
public: System.bool IsInternetExplorer8Browser();
C++/CLI
public:
System.bool IsInternetExplorer8Browser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


IsInternetExplorerBrowser Method

[image]
Intersoft WebTextEditor Documentation
IsInternetExplorerBrowser Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : IsInternetExplorerBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInternetExplorerBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Boolean

value = instance.IsInternetExplorerBrowser()
C#
public System.bool IsInternetExplorerBrowser()
Delphi
public function IsInternetExplorerBrowser(): System.Boolean;
JScript
public function IsInternetExplorerBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsInternetExplorerBrowser();
C++/CLI
public:
System.bool IsInternetExplorerBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


IsLiteralContent Method

[image]
Intersoft WebTextEditor Documentation
IsLiteralContent Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : IsLiteralContent Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function IsLiteralContent() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Boolean

value = instance.IsLiteralContent()
C#
protected System.bool IsLiteralContent()
Delphi
protected function IsLiteralContent(): System.Boolean;
JScript
protected function IsLiteralContent() : System.boolean;
Managed Extensions for C++
protected: System.bool IsLiteralContent();
C++/CLI
protected:
System.bool IsLiteralContent();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


IsMvc Property

[image]
Intersoft WebTextEditor Documentation
IsMvc Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : IsMvc Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property IsMvc As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Boolean

value = instance.IsMvc
C#
protected System.bool IsMvc {get;}
Delphi
protected read-only property IsMvc: System.Boolean;
JScript
protected function get IsMvc : System.boolean
Managed Extensions for C++
protected: __property System.bool get_IsMvc();
C++/CLI
protected:
property System.bool IsMvc {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


IsOperaBrowser Method

[image]
Intersoft WebTextEditor Documentation
IsOperaBrowser Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : IsOperaBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsOperaBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Boolean

value = instance.IsOperaBrowser()
C#
public System.bool IsOperaBrowser()
Delphi
public function IsOperaBrowser(): System.Boolean;
JScript
public function IsOperaBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsOperaBrowser();
C++/CLI
public:
System.bool IsOperaBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


isPagePreRender Field

[image]
Intersoft WebTextEditor Documentation
isPagePreRender Field
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : isPagePreRender Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected isPagePreRender As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Boolean

value = instance.isPagePreRender

instance.isPagePreRender = value
C#
protected System.bool isPagePreRender
Delphi
protected field isPagePreRender: System.Boolean;
JScript
protected var isPagePreRender : System.boolean;
Managed Extensions for C++
protected: System.bool isPagePreRender
C++/CLI
protected:
System.bool isPagePreRender

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


IsSafariBrowser Method

[image]
Intersoft WebTextEditor Documentation
IsSafariBrowser Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : IsSafariBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsSafariBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Boolean

value = instance.IsSafariBrowser()
C#
public System.bool IsSafariBrowser()
Delphi
public function IsSafariBrowser(): System.Boolean;
JScript
public function IsSafariBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsSafariBrowser();
C++/CLI
public:
System.bool IsSafariBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


IsSessionAvailable Method

[image]
Intersoft WebTextEditor Documentation
IsSessionAvailable Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : IsSessionAvailable Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function IsSessionAvailable() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Boolean

value = instance.IsSessionAvailable()
C#
protected System.bool IsSessionAvailable()
Delphi
protected function IsSessionAvailable(): System.Boolean;
JScript
protected function IsSessionAvailable() : System.boolean;
Managed Extensions for C++
protected: System.bool IsSessionAvailable();
C++/CLI
protected:
System.bool IsSessionAvailable();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


IsTrackingViewState Property

[image]
Intersoft WebTextEditor Documentation
IsTrackingViewState Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : IsTrackingViewState Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property IsTrackingViewState As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Boolean

value = instance.IsTrackingViewState
C#
protected System.bool IsTrackingViewState {get;}
Delphi
protected read-only property IsTrackingViewState: System.Boolean;
JScript
protected function get IsTrackingViewState : System.boolean
Managed Extensions for C++
protected: __property System.bool get_IsTrackingViewState();
C++/CLI
protected:
property System.bool IsTrackingViewState {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


IsUnloaded Property

[image]
Intersoft WebTextEditor Documentation
IsUnloaded Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : IsUnloaded Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property IsUnloaded As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Boolean

instance.IsUnloaded = value

value = instance.IsUnloaded
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public System.bool IsUnloaded {get; set;}
Delphi
public read-write property IsUnloaded: System.Boolean;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get,set IsUnloaded : System.boolean
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property System.bool get_IsUnloaded();
public: __property void set_IsUnloaded(
   System.bool value
);
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property System.bool IsUnloaded {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


IsW3CStandardBrowser Method

[image]
Intersoft WebTextEditor Documentation
IsW3CStandardBrowser Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : IsW3CStandardBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsW3CStandardBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Boolean

value = instance.IsW3CStandardBrowser()
C#
public System.bool IsW3CStandardBrowser()
Delphi
public function IsW3CStandardBrowser(): System.Boolean;
JScript
public function IsW3CStandardBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsW3CStandardBrowser();
C++/CLI
public:
System.bool IsW3CStandardBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


Load Event

[image]
Intersoft WebTextEditor Documentation
Load Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : Load Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the page has been loaded.")>
Public Event Load As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim handler As System.EventHandler

AddHandler instance.Load, handler
C#
[WebSysDescriptionAttribute("Fires when the page has been loaded.")]
public event System.EventHandler Load
Delphi
public event Load: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the page has been loaded.")]
public: __event System.EventHandler* Load
C++/CLI
[WebSysDescriptionAttribute("Fires when the page has been loaded.")]
public:
event System.EventHandler^ Load

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


LoadControlState Method

[image]
Intersoft WebTextEditor Documentation
LoadControlState Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : LoadControlState Method

savedState

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub LoadControlState( _
   ByVal savedState As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim savedState As System.Object

instance.LoadControlState(savedState)
C#
protected virtual void LoadControlState(
   System.object savedState
)
Delphi
protected procedure LoadControlState(
    savedState: System.TObject
); virtual;
JScript
protected function LoadControlState(
   savedState : System.Object
);
Managed Extensions for C++
protected: virtual void LoadControlState(
   System.Object* savedState
)
C++/CLI
protected:
virtual void LoadControlState(
   System.Object^ savedState
)

Parameters

savedState

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


LoadLayout Method

[image]
Intersoft WebTextEditor Documentation
LoadLayout Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : LoadLayout Method

settings

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayout( _
   ByVal settings As ISNet.WebUI.LayoutInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim settings As ISNet.WebUI.LayoutInfo

instance.LoadLayout(settings)
C#
public virtual void LoadLayout(
   ISNet.WebUI.LayoutInfo settings
)
Delphi
public procedure LoadLayout(
    settings: ISNet.WebUI.LayoutInfo
); virtual;
JScript
public function LoadLayout(
   settings : ISNet.WebUI.LayoutInfo
);
Managed Extensions for C++
public: virtual void LoadLayout(
   ISNet.WebUI.LayoutInfo* settings
)
C++/CLI
public:
virtual void LoadLayout(
   ISNet.WebUI.LayoutInfo^ settings
)

Parameters

settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


LoadLayoutFromFile Method

[image]
Intersoft WebTextEditor Documentation
LoadLayoutFromFile Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : LoadLayoutFromFile Method

filePath

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromFile( _
   ByVal filePath As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim filePath As System.String

instance.LoadLayoutFromFile(filePath)
C#
public virtual void LoadLayoutFromFile(
   System.string filePath
)
Delphi
public procedure LoadLayoutFromFile(
    filePath: System.String
); virtual;
JScript
public function LoadLayoutFromFile(
   filePath : System.String
);
Managed Extensions for C++
public: virtual void LoadLayoutFromFile(
   System.string* filePath
)
C++/CLI
public:
virtual void LoadLayoutFromFile(
   System.String^ filePath
)

Parameters

filePath

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


LoadLayoutFromPredefinedName Method

[image]
Intersoft WebTextEditor Documentation
LoadLayoutFromPredefinedName Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : LoadLayoutFromPredefinedName Method

predefinedName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromPredefinedName( _
   ByVal predefinedName As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim predefinedName As System.String

instance.LoadLayoutFromPredefinedName(predefinedName)
C#
public virtual void LoadLayoutFromPredefinedName(
   System.string predefinedName
)
Delphi
public procedure LoadLayoutFromPredefinedName(
    predefinedName: System.String
); virtual;
JScript
public function LoadLayoutFromPredefinedName(
   predefinedName : System.String
);
Managed Extensions for C++
public: virtual void LoadLayoutFromPredefinedName(
   System.string* predefinedName
)
C++/CLI
public:
virtual void LoadLayoutFromPredefinedName(
   System.String^ predefinedName
)

Parameters

predefinedName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


LoadLayoutFromStream Method

[image]
Intersoft WebTextEditor Documentation
LoadLayoutFromStream Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : LoadLayoutFromStream Method

stream

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromStream( _
   ByVal stream As System.IO.Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim stream As System.IO.Stream

instance.LoadLayoutFromStream(stream)
C#
public virtual void LoadLayoutFromStream(
   System.IO.Stream stream
)
Delphi
public procedure LoadLayoutFromStream(
    stream: System.IO.Stream
); virtual;
JScript
public function LoadLayoutFromStream(
   stream : System.IO.Stream
);
Managed Extensions for C++
public: virtual void LoadLayoutFromStream(
   System.IO.Stream* stream
)
C++/CLI
public:
virtual void LoadLayoutFromStream(
   System.IO.Stream^ stream
)

Parameters

stream

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


LoadPostData Method

[image]
Intersoft WebTextEditor Documentation
LoadPostData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : LoadPostData Method

postDataKey
postCollection

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function LoadPostData( _
   ByVal postDataKey As System.String, _
   ByVal postCollection As System.Collections.Specialized.NameValueCollection _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim postDataKey As System.String
Dim postCollection As System.Collections.Specialized.NameValueCollection
Dim value As System.Boolean

value = instance.LoadPostData(postDataKey, postCollection)
C#
public virtual System.bool LoadPostData(
   System.string postDataKey,
   System.Collections.Specialized.NameValueCollection postCollection
)
Delphi
public function LoadPostData(
    postDataKey: System.String;
    postCollection: System.Collections.Specialized.NameValueCollection
): System.Boolean; virtual;
JScript
public function LoadPostData(
   postDataKey : System.String,
   postCollection : System.Collections.Specialized.NameValueCollection
) : System.boolean;
Managed Extensions for C++
public: virtual System.bool LoadPostData(
   System.string* postDataKey,
   System.Collections.Specialized.NameValueCollection* postCollection
)
C++/CLI
public:
virtual System.bool LoadPostData(
   System.String^ postDataKey,
   System.Collections.Specialized.NameValueCollection^ postCollection
)

Parameters

postDataKey
postCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


LoadViewState Method

[image]
Intersoft WebTextEditor Documentation
LoadViewState Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : LoadViewState Method

savedState

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub LoadViewState( _
   ByVal savedState As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim savedState As System.Object

instance.LoadViewState(savedState)
C#
protected virtual void LoadViewState(
   System.object savedState
)
Delphi
protected procedure LoadViewState(
    savedState: System.TObject
); virtual;
JScript
protected function LoadViewState(
   savedState : System.Object
);
Managed Extensions for C++
protected: virtual void LoadViewState(
   System.Object* savedState
)
C++/CLI
protected:
virtual void LoadViewState(
   System.Object^ savedState
)

Parameters

savedState

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


LoadViewStateByID Property

[image]
Intersoft WebTextEditor Documentation
LoadViewStateByID Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : LoadViewStateByID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property LoadViewStateByID As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Boolean

value = instance.LoadViewStateByID
C#
protected System.bool LoadViewStateByID {get;}
Delphi
protected read-only property LoadViewStateByID: System.Boolean;
JScript
protected function get LoadViewStateByID : System.boolean
Managed Extensions for C++
protected: __property System.bool get_LoadViewStateByID();
C++/CLI
protected:
property System.bool LoadViewStateByID {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


MaxJsonLength Property

[image]
Intersoft WebTextEditor Documentation
MaxJsonLength Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : MaxJsonLength Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the maximum length allowed for JSON Serializer.")>
<System.ComponentModel.DefaultValueAttribute()>
Protected Overridable Property MaxJsonLength As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Integer

instance.MaxJsonLength = value

value = instance.MaxJsonLength
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the maximum length allowed for JSON Serializer.")]
[System.ComponentModel.DefaultValueAttribute()]
protected virtual System.int MaxJsonLength {get; set;}
Delphi
protected read-write property MaxJsonLength: System.Integer; virtual;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the maximum length allowed for JSON Serializer.")
System.ComponentModel.DefaultValueAttribute()
protected function get,set MaxJsonLength : System.int
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the maximum length allowed for JSON Serializer.")]
[System.ComponentModel.DefaultValueAttribute()]
protected: __property virtual System.int get_MaxJsonLength();
protected: __property virtual void set_MaxJsonLength(
   System.int value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the maximum length allowed for JSON Serializer.")]
[System.ComponentModel.DefaultValueAttribute()]
protected:
virtual property System.int MaxJsonLength {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


MergeStyle Method

[image]
Intersoft WebTextEditor Documentation
MergeStyle Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : MergeStyle Method

s

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub MergeStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim s As System.Web.UI.WebControls.Style

instance.MergeStyle(s)
C#
public void MergeStyle(
   System.Web.UI.WebControls.Style s
)
Delphi
public procedure MergeStyle(
    s: System.Web.UI.WebControls.Style
);
JScript
public function MergeStyle(
   s : System.Web.UI.WebControls.Style
);
Managed Extensions for C++
public: void MergeStyle(
   System.Web.UI.WebControls.Style* s
)
C++/CLI
public:
void MergeStyle(
   System.Web.UI.WebControls.Style^ s
)

Parameters

s

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


NamingContainer Property

[image]
Intersoft WebTextEditor Documentation
NamingContainer Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : NamingContainer Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BindableAttribute(Bindable=False, Direction=BindingDirection.OneWay)>
<WebSysDescriptionAttribute("The containing control or page within which ID is unique.")>
Public Overridable ReadOnly Property NamingContainer As System.Web.UI.Control
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Web.UI.Control

value = instance.NamingContainer
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BindableAttribute(Bindable=false, Direction=BindingDirection.OneWay)]
[WebSysDescriptionAttribute("The containing control or page within which ID is unique.")]
public virtual System.Web.UI.Control NamingContainer {get;}
Delphi
public read-only property NamingContainer: System.Web.UI.Control; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
WebSysDescriptionAttribute("The containing control or page within which ID is unique.")
public function get NamingContainer : System.Web.UI.Control
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BindableAttribute(Bindable=false, Direction=BindingDirection.OneWay)]
[WebSysDescriptionAttribute("The containing control or page within which ID is unique.")]
public: __property virtual System.Web.UI.Control* get_NamingContainer();
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BindableAttribute(Bindable=false, Direction=BindingDirection.OneWay)]
[WebSysDescriptionAttribute("The containing control or page within which ID is unique.")]
public:
virtual property System.Web.UI.Control^ NamingContainer {
   System.Web.UI.Control^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


OnBubbleEvent Method

[image]
Intersoft WebTextEditor Documentation
OnBubbleEvent Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : OnBubbleEvent Method

source
args

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnBubbleEvent( _
   ByVal source As System.Object, _
   ByVal args As System.EventArgs _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim source As System.Object
Dim args As System.EventArgs
Dim value As System.Boolean

value = instance.OnBubbleEvent(source, args)
C#
protected virtual System.bool OnBubbleEvent(
   System.object source,
   System.EventArgs args
)
Delphi
protected function OnBubbleEvent(
    source: System.TObject;
    args: System.EventArgs
): System.Boolean; virtual;
JScript
protected function OnBubbleEvent(
   source : System.Object,
   args : System.EventArgs
) : System.boolean;
Managed Extensions for C++
protected: virtual System.bool OnBubbleEvent(
   System.Object* source,
   System.EventArgs* args
)
C++/CLI
protected:
virtual System.bool OnBubbleEvent(
   System.Object^ source,
   System.EventArgs^ args
)

Parameters

source
args

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


OnDataBinding Method

[image]
Intersoft WebTextEditor Documentation
OnDataBinding Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : OnDataBinding Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnDataBinding( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim e As System.EventArgs

instance.OnDataBinding(e)
C#
protected virtual void OnDataBinding(
   System.EventArgs e
)
Delphi
protected procedure OnDataBinding(
    e: System.EventArgs
); virtual;
JScript
protected function OnDataBinding(
   e : System.EventArgs
);
Managed Extensions for C++
protected: virtual void OnDataBinding(
   System.EventArgs* e
)
C++/CLI
protected:
virtual void OnDataBinding(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


OnInfoChanged Method

[image]
Intersoft WebTextEditor Documentation
OnInfoChanged Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : OnInfoChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub OnInfoChanged( _
   ByVal e As ISNet.WebUI.SynchronizeEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim e As ISNet.WebUI.SynchronizeEventArgs

instance.OnInfoChanged(e)
C#
public void OnInfoChanged(
   ISNet.WebUI.SynchronizeEventArgs e
)
Delphi
public procedure OnInfoChanged(
    e: ISNet.WebUI.SynchronizeEventArgs
);
JScript
public function OnInfoChanged(
   e : ISNet.WebUI.SynchronizeEventArgs
);
Managed Extensions for C++
public: void OnInfoChanged(
   ISNet.WebUI.SynchronizeEventArgs* e
)
C++/CLI
public:
void OnInfoChanged(
   ISNet.WebUI.SynchronizeEventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


OnInit Method

[image]
Intersoft WebTextEditor Documentation
OnInit Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : OnInit Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnInit( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim e As System.EventArgs

instance.OnInit(e)
C#
protected virtual void OnInit(
   System.EventArgs e
)
Delphi
protected procedure OnInit(
    e: System.EventArgs
); virtual;
JScript
protected function OnInit(
   e : System.EventArgs
);
Managed Extensions for C++
protected: virtual void OnInit(
   System.EventArgs* e
)
C++/CLI
protected:
virtual void OnInit(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


OnLoad Method

[image]
Intersoft WebTextEditor Documentation
OnLoad Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : OnLoad Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnLoad( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim e As System.EventArgs

instance.OnLoad(e)
C#
protected virtual void OnLoad(
   System.EventArgs e
)
Delphi
protected procedure OnLoad(
    e: System.EventArgs
); virtual;
JScript
protected function OnLoad(
   e : System.EventArgs
);
Managed Extensions for C++
protected: virtual void OnLoad(
   System.EventArgs* e
)
C++/CLI
protected:
virtual void OnLoad(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


OnPreInitialize Method

[image]
Intersoft WebTextEditor Documentation
OnPreInitialize Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : OnPreInitialize Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub OnPreInitialize()
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader

instance.OnPreInitialize()
C#
public virtual void OnPreInitialize()
Delphi
public procedure OnPreInitialize(); virtual;
JScript
public function OnPreInitialize();
Managed Extensions for C++
public: virtual void OnPreInitialize();
C++/CLI
public:
virtual void OnPreInitialize();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


Page Property

[image]
Intersoft WebTextEditor Documentation
Page Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : Page Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property Page As System.Web.UI.Page
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Web.UI.Page

instance.Page = value

value = instance.Page
C#
public virtual System.Web.UI.Page Page {get; set;}
Delphi
public read-write property Page: System.Web.UI.Page; virtual;
JScript
public function get,set Page : System.Web.UI.Page
Managed Extensions for C++
public: __property virtual System.Web.UI.Page* get_Page();
public: __property virtual void set_Page(
   System.Web.UI.Page* value
);
C++/CLI
public:
virtual property System.Web.UI.Page^ Page {
   System.Web.UI.Page^ get();
   void set (    System.Web.UI.Page^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


Parent Property

[image]
Intersoft WebTextEditor Documentation
Parent Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : Parent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<WebSysDescriptionAttribute("The control containing this control.")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BindableAttribute(Bindable=False, Direction=BindingDirection.OneWay)>
Public Overridable ReadOnly Property Parent As System.Web.UI.Control
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Web.UI.Control

value = instance.Parent
C#
[System.ComponentModel.BrowsableAttribute(false)]
[WebSysDescriptionAttribute("The control containing this control.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BindableAttribute(Bindable=false, Direction=BindingDirection.OneWay)]
public virtual System.Web.UI.Control Parent {get;}
Delphi
public read-only property Parent: System.Web.UI.Control; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
WebSysDescriptionAttribute("The control containing this control.")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get Parent : System.Web.UI.Control
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[WebSysDescriptionAttribute("The control containing this control.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BindableAttribute(Bindable=false, Direction=BindingDirection.OneWay)]
public: __property virtual System.Web.UI.Control* get_Parent();
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[WebSysDescriptionAttribute("The control containing this control.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BindableAttribute(Bindable=false, Direction=BindingDirection.OneWay)]
public:
virtual property System.Web.UI.Control^ Parent {
   System.Web.UI.Control^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


ParentStyleId Property

[image]
Intersoft WebTextEditor Documentation
ParentStyleId Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : ParentStyleId Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
Public ReadOnly Property ParentStyleId As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.String

value = instance.ParentStyleId
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public System.string ParentStyleId {get;}
Delphi
public read-only property ParentStyleId: System.String;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
public function get ParentStyleId : System.String
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public: __property System.string* get_ParentStyleId();
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public:
property System.String^ ParentStyleId {
   System.String^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


PreInitialize Event

[image]
Intersoft WebTextEditor Documentation
PreInitialize Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : PreInitialize Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event PreInitialize As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim handler As System.EventHandler

AddHandler instance.PreInitialize, handler
C#
public event System.EventHandler PreInitialize
Delphi
public event PreInitialize: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
public: __event System.EventHandler* PreInitialize
C++/CLI
public:
event System.EventHandler^ PreInitialize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


PreRender Event

[image]
Intersoft WebTextEditor Documentation
PreRender Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : PreRender Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires before the page is rendered.")>
Public Event PreRender As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim handler As System.EventHandler

AddHandler instance.PreRender, handler
C#
[WebSysDescriptionAttribute("Fires before the page is rendered.")]
public event System.EventHandler PreRender
Delphi
public event PreRender: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires before the page is rendered.")]
public: __event System.EventHandler* PreRender
C++/CLI
[WebSysDescriptionAttribute("Fires before the page is rendered.")]
public:
event System.EventHandler^ PreRender

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


RaiseBubbleEvent Method

[image]
Intersoft WebTextEditor Documentation
RaiseBubbleEvent Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : RaiseBubbleEvent Method

source
args

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Sub RaiseBubbleEvent( _
   ByVal source As System.Object, _
   ByVal args As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim source As System.Object
Dim args As System.EventArgs

instance.RaiseBubbleEvent(source, args)
C#
protected void RaiseBubbleEvent(
   System.object source,
   System.EventArgs args
)
Delphi
protected procedure RaiseBubbleEvent(
    source: System.TObject;
    args: System.EventArgs
);
JScript
protected function RaiseBubbleEvent(
   source : System.Object,
   args : System.EventArgs
);
Managed Extensions for C++
protected: void RaiseBubbleEvent(
   System.Object* source,
   System.EventArgs* args
)
C++/CLI
protected:
void RaiseBubbleEvent(
   System.Object^ source,
   System.EventArgs^ args
)

Parameters

source
args

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


RaisePostDataChangedEvent Method

[image]
Intersoft WebTextEditor Documentation
RaisePostDataChangedEvent Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : RaisePostDataChangedEvent Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RaisePostDataChangedEvent()
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader

instance.RaisePostDataChangedEvent()
C#
public virtual void RaisePostDataChangedEvent()
Delphi
public procedure RaisePostDataChangedEvent(); virtual;
JScript
public function RaisePostDataChangedEvent();
Managed Extensions for C++
public: virtual void RaisePostDataChangedEvent();
C++/CLI
public:
virtual void RaisePostDataChangedEvent();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


ReadWebConfigValue Method

[image]
Intersoft WebTextEditor Documentation
ReadWebConfigValue Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : ReadWebConfigValue Method

key

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ReadWebConfigValue( _
   ByVal key As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim key As System.String
Dim value As System.String

value = instance.ReadWebConfigValue(key)
C#
public System.string ReadWebConfigValue(
   System.string key
)
Delphi
public function ReadWebConfigValue(
    key: System.String
): System.String;
JScript
public function ReadWebConfigValue(
   key : System.String
) : System.String;
Managed Extensions for C++
public: System.string* ReadWebConfigValue(
   System.string* key
)
C++/CLI
public:
System.String^ ReadWebConfigValue(
   System.String^ key
)

Parameters

key

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


RegisterBoxSizing Method

[image]
Intersoft WebTextEditor Documentation
RegisterBoxSizing Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : RegisterBoxSizing Method

Glossary Item Box

Overload List

Overload | Description
RegisterBoxSizing() | (Inherited from ISNet.WebUI.ISNetControl)
RegisterBoxSizing(Boolean) | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


RegisterBoxSizing() Method

[image]
Intersoft WebTextEditor Documentation
RegisterBoxSizing() Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class > RegisterBoxSizing Method : RegisterBoxSizing() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub RegisterBoxSizing()
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader

instance.RegisterBoxSizing()
C#
public void RegisterBoxSizing()
Delphi
public procedure RegisterBoxSizing();
JScript
public function RegisterBoxSizing();
Managed Extensions for C++
public: void RegisterBoxSizing();
C++/CLI
public:
void RegisterBoxSizing();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members
Overload List


RegisterBoxSizing(Boolean) Method

[image]
Intersoft WebTextEditor Documentation
RegisterBoxSizing(Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class > RegisterBoxSizing Method : RegisterBoxSizing(Boolean) Method

forceAll

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub RegisterBoxSizing( _
   ByVal forceAll As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim forceAll As System.Boolean

instance.RegisterBoxSizing(forceAll)
C#
public void RegisterBoxSizing(
   System.bool forceAll
)
Delphi
public procedure RegisterBoxSizing(
    forceAll: System.Boolean
);
JScript
public function RegisterBoxSizing(
   forceAll : System.boolean
);
Managed Extensions for C++
public: void RegisterBoxSizing(
   System.bool forceAll
)
C++/CLI
public:
void RegisterBoxSizing(
   System.bool forceAll
)

Parameters

forceAll

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members
Overload List


RegisterGlobalStyle Method

[image]
Intersoft WebTextEditor Documentation
RegisterGlobalStyle Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : RegisterGlobalStyle Method

style

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterGlobalStyle( _
   ByVal style As ISNet.WebUI.WebStyle _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim style As ISNet.WebUI.WebStyle

instance.RegisterGlobalStyle(style)
C#
public void RegisterGlobalStyle(
   ISNet.WebUI.WebStyle style
)
Delphi
public procedure RegisterGlobalStyle(
    style: ISNet.WebUI.WebStyle
);
JScript
public function RegisterGlobalStyle(
   style : ISNet.WebUI.WebStyle
);
Managed Extensions for C++
public: void RegisterGlobalStyle(
   ISNet.WebUI.WebStyle* style
)
C++/CLI
public:
void RegisterGlobalStyle(
   ISNet.WebUI.WebStyle^ style
)

Parameters

style

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


RegisterLink Method

[image]
Intersoft WebTextEditor Documentation
RegisterLink Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : RegisterLink Method

name
url

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterLink( _
   ByVal name As System.String, _
   ByVal url As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim name As System.String
Dim url As System.String

instance.RegisterLink(name, url)
C#
public void RegisterLink(
   System.string name,
   System.string url
)
Delphi
public procedure RegisterLink(
    name: System.String;
    url: System.String
);
JScript
public function RegisterLink(
   name : System.String,
   url : System.String
);
Managed Extensions for C++
public: void RegisterLink(
   System.string* name,
   System.string* url
)
C++/CLI
public:
void RegisterLink(
   System.String^ name,
   System.String^ url
)

Parameters

name
url

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


RegisterOptimizedCssClasses Method

[image]
Intersoft WebTextEditor Documentation
RegisterOptimizedCssClasses Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : RegisterOptimizedCssClasses Method

runtimeStyleOnly

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterOptimizedCssClasses( _
   ByVal runtimeStyleOnly As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim runtimeStyleOnly As System.Boolean

instance.RegisterOptimizedCssClasses(runtimeStyleOnly)
C#
public void RegisterOptimizedCssClasses(
   System.bool runtimeStyleOnly
)
Delphi
public procedure RegisterOptimizedCssClasses(
    runtimeStyleOnly: System.Boolean
);
JScript
public function RegisterOptimizedCssClasses(
   runtimeStyleOnly : System.boolean
);
Managed Extensions for C++
public: void RegisterOptimizedCssClasses(
   System.bool runtimeStyleOnly
)
C++/CLI
public:
void RegisterOptimizedCssClasses(
   System.bool runtimeStyleOnly
)

Parameters

runtimeStyleOnly

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


RegisterPreloadImage Method

[image]
Intersoft WebTextEditor Documentation
RegisterPreloadImage Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : RegisterPreloadImage Method

image

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterPreloadImage( _
   ByVal image As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim image As System.String

instance.RegisterPreloadImage(image)
C#
public void RegisterPreloadImage(
   System.string image
)
Delphi
public procedure RegisterPreloadImage(
    image: System.String
);
JScript
public function RegisterPreloadImage(
   image : System.String
);
Managed Extensions for C++
public: void RegisterPreloadImage(
   System.string* image
)
C++/CLI
public:
void RegisterPreloadImage(
   System.String^ image
)

Parameters

image

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


RegisterSharePointHandler Method

[image]
Intersoft WebTextEditor Documentation
RegisterSharePointHandler Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : RegisterSharePointHandler Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RegisterSharePointHandler()
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader

instance.RegisterSharePointHandler()
C#
public virtual void RegisterSharePointHandler()
Delphi
public procedure RegisterSharePointHandler(); virtual;
JScript
public function RegisterSharePointHandler();
Managed Extensions for C++
public: virtual void RegisterSharePointHandler();
C++/CLI
public:
virtual void RegisterSharePointHandler();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


RenderBeginTag Method

[image]
Intersoft WebTextEditor Documentation
RenderBeginTag Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : RenderBeginTag Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RenderBeginTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderBeginTag(writer)
C#
public virtual void RenderBeginTag(
   System.Web.UI.HtmlTextWriter writer
)
Delphi
public procedure RenderBeginTag(
    writer: System.Web.UI.HtmlTextWriter
); virtual;
JScript
public function RenderBeginTag(
   writer : System.Web.UI.HtmlTextWriter
);
Managed Extensions for C++
public: virtual void RenderBeginTag(
   System.Web.UI.HtmlTextWriter* writer
)
C++/CLI
public:
virtual void RenderBeginTag(
   System.Web.UI.HtmlTextWriter^ writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


RenderContents Method

[image]
Intersoft WebTextEditor Documentation
RenderContents Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : RenderContents Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub RenderContents( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderContents(writer)
C#
protected virtual void RenderContents(
   System.Web.UI.HtmlTextWriter writer
)
Delphi
protected procedure RenderContents(
    writer: System.Web.UI.HtmlTextWriter
); virtual;
JScript
protected function RenderContents(
   writer : System.Web.UI.HtmlTextWriter
);
Managed Extensions for C++
protected: virtual void RenderContents(
   System.Web.UI.HtmlTextWriter* writer
)
C++/CLI
protected:
virtual void RenderContents(
   System.Web.UI.HtmlTextWriter^ writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


RenderControl Method

[image]
Intersoft WebTextEditor Documentation
RenderControl Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : RenderControl Method

Glossary Item Box

Overload List

Overload | Description
RenderControl(HtmlTextWriter) | (Inherited from System.Web.UI.Control)
RenderControl(HtmlTextWriter,ControlAdapter) | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


RenderControl(HtmlTextWriter) Method

[image]
Intersoft WebTextEditor Documentation
RenderControl(HtmlTextWriter) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class > RenderControl Method : RenderControl(HtmlTextWriter) Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Overloads Overridable Sub RenderControl( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderControl(writer)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public virtual void RenderControl(
   System.Web.UI.HtmlTextWriter writer
)
Delphi
public procedure RenderControl(
    writer: System.Web.UI.HtmlTextWriter
); virtual;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function RenderControl(
   writer : System.Web.UI.HtmlTextWriter
);
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: virtual void RenderControl(
   System.Web.UI.HtmlTextWriter* writer
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
virtual void RenderControl(
   System.Web.UI.HtmlTextWriter^ writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members
Overload List


RenderControl(HtmlTextWriter,ControlAdapter) Method

[image]
Intersoft WebTextEditor Documentation
RenderControl(HtmlTextWriter,ControlAdapter) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class > RenderControl Method : RenderControl(HtmlTextWriter,ControlAdapter) Method

writer
adapter

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overloads Sub RenderControl( _
   ByVal writer As System.Web.UI.HtmlTextWriter, _
   ByVal adapter As System.Web.UI.Adapters.ControlAdapter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim writer As System.Web.UI.HtmlTextWriter
Dim adapter As System.Web.UI.Adapters.ControlAdapter

instance.RenderControl(writer, adapter)
C#
protected void RenderControl(
   System.Web.UI.HtmlTextWriter writer,
   System.Web.UI.Adapters.ControlAdapter adapter
)
Delphi
protected procedure RenderControl(
    writer: System.Web.UI.HtmlTextWriter;
    adapter: System.Web.UI.Adapters.ControlAdapter
);
JScript
protected function RenderControl(
   writer : System.Web.UI.HtmlTextWriter,
   adapter : System.Web.UI.Adapters.ControlAdapter
);
Managed Extensions for C++
protected: void RenderControl(
   System.Web.UI.HtmlTextWriter* writer,
   System.Web.UI.Adapters.ControlAdapter* adapter
)
C++/CLI
protected:
void RenderControl(
   System.Web.UI.HtmlTextWriter^ writer,
   System.Web.UI.Adapters.ControlAdapter^ adapter
)

Parameters

writer
adapter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members
Overload List


renderDHTML Field

[image]
Intersoft WebTextEditor Documentation
renderDHTML Field
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : renderDHTML Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected renderDHTML As ISNet.WebUI.RenderDHTML
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As ISNet.WebUI.RenderDHTML

value = instance.renderDHTML

instance.renderDHTML = value
C#
protected ISNet.WebUI.RenderDHTML renderDHTML
Delphi
protected field renderDHTML: ISNet.WebUI.RenderDHTML;
JScript
protected var renderDHTML : ISNet.WebUI.RenderDHTML;
Managed Extensions for C++
protected: ISNet.WebUI.RenderDHTML* renderDHTML
C++/CLI
protected:
ISNet.WebUI.RenderDHTML^ renderDHTML

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


RenderEndTag Method

[image]
Intersoft WebTextEditor Documentation
RenderEndTag Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : RenderEndTag Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RenderEndTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderEndTag(writer)
C#
public virtual void RenderEndTag(
   System.Web.UI.HtmlTextWriter writer
)
Delphi
public procedure RenderEndTag(
    writer: System.Web.UI.HtmlTextWriter
); virtual;
JScript
public function RenderEndTag(
   writer : System.Web.UI.HtmlTextWriter
);
Managed Extensions for C++
public: virtual void RenderEndTag(
   System.Web.UI.HtmlTextWriter* writer
)
C++/CLI
public:
virtual void RenderEndTag(
   System.Web.UI.HtmlTextWriter^ writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


RenderingCompatibility Property

[image]
Intersoft WebTextEditor Documentation
RenderingCompatibility Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : RenderingCompatibility Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.BindableAttribute(Bindable=False, Direction=BindingDirection.OneWay)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Overridable Property RenderingCompatibility As System.Version
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Version

instance.RenderingCompatibility = value

value = instance.RenderingCompatibility
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.BindableAttribute(Bindable=false, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public virtual System.Version RenderingCompatibility {get; set;}
Delphi
public read-write property RenderingCompatibility: System.Version; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get,set RenderingCompatibility : System.Version
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.BindableAttribute(Bindable=false, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property virtual System.Version* get_RenderingCompatibility();
public: __property virtual void set_RenderingCompatibility(
   System.Version* value
);
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.BindableAttribute(Bindable=false, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
virtual property System.Version^ RenderingCompatibility {
   System.Version^ get();
   void set (    System.Version^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


RenderingMode Property

[image]
Intersoft WebTextEditor Documentation
RenderingMode Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : RenderingMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets a value that specifies the HTML rendering behavior applied in this control.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Overridable Property RenderingMode As ISNet.WebUI.RenderMode
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As ISNet.WebUI.RenderMode

instance.RenderingMode = value

value = instance.RenderingMode
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that specifies the HTML rendering behavior applied in this control.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public virtual ISNet.WebUI.RenderMode RenderingMode {get; set;}
Delphi
public read-write property RenderingMode: ISNet.WebUI.RenderMode; virtual;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets a value that specifies the HTML rendering behavior applied in this control.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set RenderingMode : ISNet.WebUI.RenderMode
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that specifies the HTML rendering behavior applied in this control.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property virtual ISNet.WebUI.RenderMode get_RenderingMode();
public: __property virtual void set_RenderingMode(
   ISNet.WebUI.RenderMode value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that specifies the HTML rendering behavior applied in this control.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
virtual property ISNet.WebUI.RenderMode RenderingMode {
   ISNet.WebUI.RenderMode get();
   void set (    ISNet.WebUI.RenderMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


renderNS Field

[image]
Intersoft WebTextEditor Documentation
renderNS Field
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : renderNS Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected renderNS As ISNet.WebUI.RenderNS
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As ISNet.WebUI.RenderNS

value = instance.renderNS

instance.renderNS = value
C#
protected ISNet.WebUI.RenderNS renderNS
Delphi
protected field renderNS: ISNet.WebUI.RenderNS;
JScript
protected var renderNS : ISNet.WebUI.RenderNS;
Managed Extensions for C++
protected: ISNet.WebUI.RenderNS* renderNS
C++/CLI
protected:
ISNet.WebUI.RenderNS^ renderNS

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


RequiresUIRefresh Property

[image]
Intersoft WebTextEditor Documentation
RequiresUIRefresh Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : RequiresUIRefresh Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property RequiresUIRefresh As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Boolean

instance.RequiresUIRefresh = value

value = instance.RequiresUIRefresh
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public System.bool RequiresUIRefresh {get; set;}
Delphi
public read-write property RequiresUIRefresh: System.Boolean;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get,set RequiresUIRefresh : System.boolean
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property System.bool get_RequiresUIRefresh();
public: __property void set_RequiresUIRefresh(
   System.bool value
);
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property System.bool RequiresUIRefresh {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


Reset Method

[image]
Intersoft WebTextEditor Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


ResetFilteredStyle Method

[image]
Intersoft WebTextEditor Documentation
ResetFilteredStyle Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : ResetFilteredStyle Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ResetFilteredStyle()
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader

instance.ResetFilteredStyle()
C#
protected virtual void ResetFilteredStyle()
Delphi
protected procedure ResetFilteredStyle(); virtual;
JScript
protected function ResetFilteredStyle();
Managed Extensions for C++
protected: virtual void ResetFilteredStyle();
C++/CLI
protected:
virtual void ResetFilteredStyle();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


ResolveAdapter Method

[image]
Intersoft WebTextEditor Documentation
ResolveAdapter Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : ResolveAdapter Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function ResolveAdapter() As System.Web.UI.Adapters.ControlAdapter
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Web.UI.Adapters.ControlAdapter

value = instance.ResolveAdapter()
C#
protected virtual System.Web.UI.Adapters.ControlAdapter ResolveAdapter()
Delphi
protected function ResolveAdapter(): System.Web.UI.Adapters.ControlAdapter; virtual;
JScript
protected function ResolveAdapter() : System.Web.UI.Adapters.ControlAdapter;
Managed Extensions for C++
protected: virtual System.Web.UI.Adapters.ControlAdapter* ResolveAdapter();
C++/CLI
protected:
virtual System.Web.UI.Adapters.ControlAdapter^ ResolveAdapter();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


ResolveClientUrl Method

[image]
Intersoft WebTextEditor Documentation
ResolveClientUrl Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : ResolveClientUrl Method

relativeUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveClientUrl( _
   ByVal relativeUrl As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim relativeUrl As System.String
Dim value As System.String

value = instance.ResolveClientUrl(relativeUrl)
C#
public System.string ResolveClientUrl(
   System.string relativeUrl
)
Delphi
public function ResolveClientUrl(
    relativeUrl: System.String
): System.String;
JScript
public function ResolveClientUrl(
   relativeUrl : System.String
) : System.String;
Managed Extensions for C++
public: System.string* ResolveClientUrl(
   System.string* relativeUrl
)
C++/CLI
public:
System.String^ ResolveClientUrl(
   System.String^ relativeUrl
)

Parameters

relativeUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


ResolveImagePath Method

[image]
Intersoft WebTextEditor Documentation
ResolveImagePath Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : ResolveImagePath Method

folder
image

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveImagePath( _
   ByVal folder As System.String, _
   ByVal image As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim folder As System.String
Dim image As System.String
Dim value As System.String

value = instance.ResolveImagePath(folder, image)
C#
public System.string ResolveImagePath(
   System.string folder,
   System.string image
)
Delphi
public function ResolveImagePath(
    folder: System.String;
    image: System.String
): System.String;
JScript
public function ResolveImagePath(
   folder : System.String,
   image : System.String
) : System.String;
Managed Extensions for C++
public: System.string* ResolveImagePath(
   System.string* folder,
   System.string* image
)
C++/CLI
public:
System.String^ ResolveImagePath(
   System.String^ folder,
   System.String^ image
)

Parameters

folder
image

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


ResolveRelativeURL Method

[image]
Intersoft WebTextEditor Documentation
ResolveRelativeURL Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : ResolveRelativeURL Method

url

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ResolveRelativeURL( _
   ByVal url As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim url As System.String
Dim value As System.String

value = instance.ResolveRelativeURL(url)
C#
public virtual System.string ResolveRelativeURL(
   System.string url
)
Delphi
public function ResolveRelativeURL(
    url: System.String
): System.String; virtual;
JScript
public function ResolveRelativeURL(
   url : System.String
) : System.String;
Managed Extensions for C++
public: virtual System.string* ResolveRelativeURL(
   System.string* url
)
C++/CLI
public:
virtual System.String^ ResolveRelativeURL(
   System.String^ url
)

Parameters

url

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


ResolveResourceUrl Method

[image]
Intersoft WebTextEditor Documentation
ResolveResourceUrl Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : ResolveResourceUrl Method

kind
defaultFolder
currentFolder
resourceName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveResourceUrl( _
   ByVal kind As ISNet.WebUI.ResourceKind, _
   ByVal defaultFolder As System.String, _
   ByVal currentFolder As System.String, _
   ByVal resourceName As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim kind As ISNet.WebUI.ResourceKind
Dim defaultFolder As System.String
Dim currentFolder As System.String
Dim resourceName As System.String
Dim value As System.String

value = instance.ResolveResourceUrl(kind, defaultFolder, currentFolder, resourceName)
C#
public System.string ResolveResourceUrl(
   ISNet.WebUI.ResourceKind kind,
   System.string defaultFolder,
   System.string currentFolder,
   System.string resourceName
)
Delphi
public function ResolveResourceUrl(
    kind: ISNet.WebUI.ResourceKind;
    defaultFolder: System.String;
    currentFolder: System.String;
    resourceName: System.String
): System.String;
JScript
public function ResolveResourceUrl(
   kind : ISNet.WebUI.ResourceKind,
   defaultFolder : System.String,
   currentFolder : System.String,
   resourceName : System.String
) : System.String;
Managed Extensions for C++
public: System.string* ResolveResourceUrl(
   ISNet.WebUI.ResourceKind kind,
   System.string* defaultFolder,
   System.string* currentFolder,
   System.string* resourceName
)
C++/CLI
public:
System.String^ ResolveResourceUrl(
   ISNet.WebUI.ResourceKind kind,
   System.String^ defaultFolder,
   System.String^ currentFolder,
   System.String^ resourceName
)

Parameters

kind
defaultFolder
currentFolder
resourceName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


ResolveUrl Method

[image]
Intersoft WebTextEditor Documentation
ResolveUrl Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : ResolveUrl Method

relativeUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveUrl( _
   ByVal relativeUrl As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim relativeUrl As System.String
Dim value As System.String

value = instance.ResolveUrl(relativeUrl)
C#
public System.string ResolveUrl(
   System.string relativeUrl
)
Delphi
public function ResolveUrl(
    relativeUrl: System.String
): System.String;
JScript
public function ResolveUrl(
   relativeUrl : System.String
) : System.String;
Managed Extensions for C++
public: System.string* ResolveUrl(
   System.string* relativeUrl
)
C++/CLI
public:
System.String^ ResolveUrl(
   System.String^ relativeUrl
)

Parameters

relativeUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


RuntimeLicenseKey Property

[image]
Intersoft WebTextEditor Documentation
RuntimeLicenseKey Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : RuntimeLicenseKey Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.PersistLayoutAttribute(False)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("The runtime license key for xcopy deployment. Registered customers please obtain the key through Intersoft Developer Network.")>
Public Overridable Property RuntimeLicenseKey As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.String

instance.RuntimeLicenseKey = value

value = instance.RuntimeLicenseKey
C#
[ISNet.PersistLayoutAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The runtime license key for xcopy deployment. Registered customers please obtain the key through Intersoft Developer Network.")]
public virtual System.string RuntimeLicenseKey {get; set;}
Delphi
public read-write property RuntimeLicenseKey: System.String; virtual;
JScript
ISNet.PersistLayoutAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("The runtime license key for xcopy deployment. Registered customers please obtain the key through Intersoft Developer Network.")
public function get,set RuntimeLicenseKey : System.String
Managed Extensions for C++
[ISNet.PersistLayoutAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The runtime license key for xcopy deployment. Registered customers please obtain the key through Intersoft Developer Network.")]
public: __property virtual System.string* get_RuntimeLicenseKey();
public: __property virtual void set_RuntimeLicenseKey(
   System.string* value
);
C++/CLI
[ISNet.PersistLayoutAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The runtime license key for xcopy deployment. Registered customers please obtain the key through Intersoft Developer Network.")]
public:
virtual property System.String^ RuntimeLicenseKey {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


SaveControlState Method

[image]
Intersoft WebTextEditor Documentation
SaveControlState Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : SaveControlState Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function SaveControlState() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Object

value = instance.SaveControlState()
C#
protected virtual System.object SaveControlState()
Delphi
protected function SaveControlState(): System.TObject; virtual;
JScript
protected function SaveControlState() : System.Object;
Managed Extensions for C++
protected: virtual System.Object* SaveControlState();
C++/CLI
protected:
virtual System.Object^ SaveControlState();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


SaveLayout Method

[image]
Intersoft WebTextEditor Documentation
SaveLayout Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : SaveLayout Method

settings

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayout( _
   ByVal settings As ISNet.WebUI.LayoutInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim settings As ISNet.WebUI.LayoutInfo

instance.SaveLayout(settings)
C#
public virtual void SaveLayout(
   ISNet.WebUI.LayoutInfo settings
)
Delphi
public procedure SaveLayout(
    settings: ISNet.WebUI.LayoutInfo
); virtual;
JScript
public function SaveLayout(
   settings : ISNet.WebUI.LayoutInfo
);
Managed Extensions for C++
public: virtual void SaveLayout(
   ISNet.WebUI.LayoutInfo* settings
)
C++/CLI
public:
virtual void SaveLayout(
   ISNet.WebUI.LayoutInfo^ settings
)

Parameters

settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


SaveLayoutToFile Method

[image]
Intersoft WebTextEditor Documentation
SaveLayoutToFile Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : SaveLayoutToFile Method

filePath
saveOptions

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayoutToFile( _
   ByVal filePath As System.String, _
   ByVal saveOptions As ISNet.WebUI.SaveLayoutOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim filePath As System.String
Dim saveOptions As ISNet.WebUI.SaveLayoutOptions

instance.SaveLayoutToFile(filePath, saveOptions)
C#
public virtual void SaveLayoutToFile(
   System.string filePath,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)
Delphi
public procedure SaveLayoutToFile(
    filePath: System.String;
    saveOptions: ISNet.WebUI.SaveLayoutOptions
); virtual;
JScript
public function SaveLayoutToFile(
   filePath : System.String,
   saveOptions : ISNet.WebUI.SaveLayoutOptions
);
Managed Extensions for C++
public: virtual void SaveLayoutToFile(
   System.string* filePath,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)
C++/CLI
public:
virtual void SaveLayoutToFile(
   System.String^ filePath,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)

Parameters

filePath
saveOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


SaveLayoutToStream Method

[image]
Intersoft WebTextEditor Documentation
SaveLayoutToStream Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : SaveLayoutToStream Method

stream
saveOptions

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayoutToStream( _
   ByVal stream As System.IO.Stream, _
   ByVal saveOptions As ISNet.WebUI.SaveLayoutOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim stream As System.IO.Stream
Dim saveOptions As ISNet.WebUI.SaveLayoutOptions

instance.SaveLayoutToStream(stream, saveOptions)
C#
public virtual void SaveLayoutToStream(
   System.IO.Stream stream,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)
Delphi
public procedure SaveLayoutToStream(
    stream: System.IO.Stream;
    saveOptions: ISNet.WebUI.SaveLayoutOptions
); virtual;
JScript
public function SaveLayoutToStream(
   stream : System.IO.Stream,
   saveOptions : ISNet.WebUI.SaveLayoutOptions
);
Managed Extensions for C++
public: virtual void SaveLayoutToStream(
   System.IO.Stream* stream,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)
C++/CLI
public:
virtual void SaveLayoutToStream(
   System.IO.Stream^ stream,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)

Parameters

stream
saveOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


SaveViewState Method

[image]
Intersoft WebTextEditor Documentation
SaveViewState Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : SaveViewState Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function SaveViewState() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Object

value = instance.SaveViewState()
C#
protected virtual System.object SaveViewState()
Delphi
protected function SaveViewState(): System.TObject; virtual;
JScript
protected function SaveViewState() : System.Object;
Managed Extensions for C++
protected: virtual System.Object* SaveViewState();
C++/CLI
protected:
virtual System.Object^ SaveViewState();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


SaveViewStateOnFlyPostback Property

[image]
Intersoft WebTextEditor Documentation
SaveViewStateOnFlyPostback Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : SaveViewStateOnFlyPostback Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property SaveViewStateOnFlyPostback As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Boolean

instance.SaveViewStateOnFlyPostback = value

value = instance.SaveViewStateOnFlyPostback
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public System.bool SaveViewStateOnFlyPostback {get; set;}
Delphi
public read-write property SaveViewStateOnFlyPostback: System.Boolean;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get,set SaveViewStateOnFlyPostback : System.boolean
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property System.bool get_SaveViewStateOnFlyPostback();
public: __property void set_SaveViewStateOnFlyPostback(
   System.bool value
);
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property System.bool SaveViewStateOnFlyPostback {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


SerializedJSFiles Property

[image]
Intersoft WebTextEditor Documentation
SerializedJSFiles Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : SerializedJSFiles Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public ReadOnly Property SerializedJSFiles As System.Collections.ArrayList
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Collections.ArrayList

value = instance.SerializedJSFiles
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public System.Collections.ArrayList SerializedJSFiles {get;}
Delphi
public read-only property SerializedJSFiles: System.Collections.ArrayList;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get SerializedJSFiles : System.Collections.ArrayList
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property System.Collections.ArrayList* get_SerializedJSFiles();
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property System.Collections.ArrayList^ SerializedJSFiles {
   System.Collections.ArrayList^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


SerializedStyles Property

[image]
Intersoft WebTextEditor Documentation
SerializedStyles Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : SerializedStyles Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
Public ReadOnly Property SerializedStyles As System.Collections.Generic.Dictionary(Of String,Object)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Collections.Generic.Dictionary(Of String,Object)

value = instance.SerializedStyles
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public System.Collections.Generic.Dictionary<string,object> SerializedStyles {get;}
Delphi
public read-only property SerializedStyles: System.Collections.Generic.Dictionary;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
public function get SerializedStyles : System.Collections.Generic.Dictionary
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public: __property System.Collections.Generic.Dictionary<string*,Object*>* get_SerializedStyles();
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public:
property System.Collections.Generic.Dictionary<String^,Object^>^ SerializedStyles {
   System.Collections.Generic.Dictionary<String^,Object^>^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


SerializeObjectData Method

[image]
Intersoft WebTextEditor Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


SetDesignModeState Method

[image]
Intersoft WebTextEditor Documentation
SetDesignModeState Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : SetDesignModeState Method

data

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub SetDesignModeState( _
   ByVal data As System.Collections.IDictionary _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim data As System.Collections.IDictionary

instance.SetDesignModeState(data)
C#
protected virtual void SetDesignModeState(
   System.Collections.IDictionary data
)
Delphi
protected procedure SetDesignModeState(
    data: System.Collections.IDictionary
); virtual;
JScript
protected function SetDesignModeState(
   data : System.Collections.IDictionary
);
Managed Extensions for C++
protected: virtual void SetDesignModeState(
   System.Collections.IDictionary* data
)
C++/CLI
protected:
virtual void SetDesignModeState(
   System.Collections.IDictionary^ data
)

Parameters

data

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


SetRenderMethodDelegate Method

[image]
Intersoft WebTextEditor Documentation
SetRenderMethodDelegate Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : SetRenderMethodDelegate Method

renderMethod

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Sub SetRenderMethodDelegate( _
   ByVal renderMethod As System.Web.UI.RenderMethod _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim renderMethod As System.Web.UI.RenderMethod

instance.SetRenderMethodDelegate(renderMethod)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod renderMethod
)
Delphi
public procedure SetRenderMethodDelegate(
    renderMethod: System.Web.UI.RenderMethod
);
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function SetRenderMethodDelegate(
   renderMethod : System.Web.UI.RenderMethod
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod* renderMethod
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod^ renderMethod
)

Parameters

renderMethod

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


SetSessionTheme Method

[image]
Intersoft WebTextEditor Documentation
SetSessionTheme Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : SetSessionTheme Method

themeInfo

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetSessionTheme( _
   ByVal themeInfo As ISNet.WebUI.ThemeInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim themeInfo As ISNet.WebUI.ThemeInfo

instance.SetSessionTheme(themeInfo)
C#
public void SetSessionTheme(
   ISNet.WebUI.ThemeInfo themeInfo
)
Delphi
public procedure SetSessionTheme(
    themeInfo: ISNet.WebUI.ThemeInfo
);
JScript
public function SetSessionTheme(
   themeInfo : ISNet.WebUI.ThemeInfo
);
Managed Extensions for C++
public: void SetSessionTheme(
   ISNet.WebUI.ThemeInfo* themeInfo
)
C++/CLI
public:
void SetSessionTheme(
   ISNet.WebUI.ThemeInfo^ themeInfo
)

Parameters

themeInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


SetTheme Method

[image]
Intersoft WebTextEditor Documentation
SetTheme Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : SetTheme Method

themeInfo

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub SetTheme( _
   ByVal themeInfo As ISNet.WebUI.ThemeInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim themeInfo As ISNet.WebUI.ThemeInfo

instance.SetTheme(themeInfo)
C#
protected virtual void SetTheme(
   ISNet.WebUI.ThemeInfo themeInfo
)
Delphi
protected procedure SetTheme(
    themeInfo: ISNet.WebUI.ThemeInfo
); virtual;
JScript
protected function SetTheme(
   themeInfo : ISNet.WebUI.ThemeInfo
);
Managed Extensions for C++
protected: virtual void SetTheme(
   ISNet.WebUI.ThemeInfo* themeInfo
)
C++/CLI
protected:
virtual void SetTheme(
   ISNet.WebUI.ThemeInfo^ themeInfo
)

Parameters

themeInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


ShouldReturnJson Method

[image]
Intersoft WebTextEditor Documentation
ShouldReturnJson Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : ShouldReturnJson Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ShouldReturnJson() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Boolean

value = instance.ShouldReturnJson()
C#
public virtual System.bool ShouldReturnJson()
Delphi
public function ShouldReturnJson(): System.Boolean; virtual;
JScript
public function ShouldReturnJson() : System.boolean;
Managed Extensions for C++
public: virtual System.bool ShouldReturnJson();
C++/CLI
public:
virtual System.bool ShouldReturnJson();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


ShowAboutBox Method

[image]
Intersoft WebTextEditor Documentation
ShowAboutBox Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : ShowAboutBox Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Sub ShowAboutBox()
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader

instance.ShowAboutBox()
C#
protected void ShowAboutBox()
Delphi
protected procedure ShowAboutBox();
JScript
protected function ShowAboutBox();
Managed Extensions for C++
protected: void ShowAboutBox();
C++/CLI
protected:
void ShowAboutBox();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


Site Property

[image]
Intersoft WebTextEditor Documentation
Site Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : Site Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<WebSysDescriptionAttribute("Site of the control.")>
<System.ComponentModel.BrowsableAttribute(False)>
Public Property Site As System.ComponentModel.ISite
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.ComponentModel.ISite

instance.Site = value

value = instance.Site
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[WebSysDescriptionAttribute("Site of the control.")]
[System.ComponentModel.BrowsableAttribute(false)]
public System.ComponentModel.ISite Site {get; set;}
Delphi
public read-write property Site: System.ComponentModel.ISite;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
WebSysDescriptionAttribute("Site of the control.")
System.ComponentModel.BrowsableAttribute()
public function get,set Site : System.ComponentModel.ISite
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[WebSysDescriptionAttribute("Site of the control.")]
[System.ComponentModel.BrowsableAttribute(false)]
public: __property System.ComponentModel.ISite* get_Site();
public: __property void set_Site(
   System.ComponentModel.ISite* value
);
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[WebSysDescriptionAttribute("Site of the control.")]
[System.ComponentModel.BrowsableAttribute(false)]
public:
property System.ComponentModel.ISite^ Site {
   System.ComponentModel.ISite^ get();
   void set (    System.ComponentModel.ISite^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


SkinID Property

[image]
Intersoft WebTextEditor Documentation
SkinID Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : SkinID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(True)>
Public Overridable Property SkinID As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.String

instance.SkinID = value

value = instance.SkinID
C#
[System.ComponentModel.BrowsableAttribute(true)]
public virtual System.string SkinID {get; set;}
Delphi
public read-write property SkinID: System.String; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
public function get,set SkinID : System.String
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(true)]
public: __property virtual System.string* get_SkinID();
public: __property virtual void set_SkinID(
   System.string* value
);
C++/CLI
[System.ComponentModel.BrowsableAttribute(true)]
public:
virtual property System.String^ SkinID {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


Style Property

[image]
Intersoft WebTextEditor Documentation
Style Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : Style Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
<WebSysDescriptionAttribute("Low-level access to control styles.")>
Public ReadOnly Property Style As System.Web.UI.CssStyleCollection
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Web.UI.CssStyleCollection

value = instance.Style
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[WebSysDescriptionAttribute("Low-level access to control styles.")]
public System.Web.UI.CssStyleCollection Style {get;}
Delphi
public read-only property Style: System.Web.UI.CssStyleCollection;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
WebSysDescriptionAttribute("Low-level access to control styles.")
public function get Style : System.Web.UI.CssStyleCollection
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[WebSysDescriptionAttribute("Low-level access to control styles.")]
public: __property System.Web.UI.CssStyleCollection* get_Style();
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[WebSysDescriptionAttribute("Low-level access to control styles.")]
public:
property System.Web.UI.CssStyleCollection^ Style {
   System.Web.UI.CssStyleCollection^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


SupportsDisabledAttribute Property

[image]
Intersoft WebTextEditor Documentation
SupportsDisabledAttribute Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : SupportsDisabledAttribute Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
Public Overridable ReadOnly Property SupportsDisabledAttribute As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Boolean

value = instance.SupportsDisabledAttribute
C#
[System.ComponentModel.BrowsableAttribute(false)]
public virtual System.bool SupportsDisabledAttribute {get;}
Delphi
public read-only property SupportsDisabledAttribute: System.Boolean; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
public function get SupportsDisabledAttribute : System.boolean
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
public: __property virtual System.bool get_SupportsDisabledAttribute();
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
public:
virtual property System.bool SupportsDisabledAttribute {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


SupportXMLCultureInfo Property

[image]
Intersoft WebTextEditor Documentation
SupportXMLCultureInfo Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : SupportXMLCultureInfo Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Overridable ReadOnly Property SupportXMLCultureInfo As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Boolean

value = instance.SupportXMLCultureInfo
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public virtual System.bool SupportXMLCultureInfo {get;}
Delphi
public read-only property SupportXMLCultureInfo: System.Boolean; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get SupportXMLCultureInfo : System.boolean
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property virtual System.bool get_SupportXMLCultureInfo();
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
virtual property System.bool SupportXMLCultureInfo {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


TabIndex Property

[image]
Intersoft WebTextEditor Documentation
TabIndex Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : TabIndex Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Overridable Property TabIndex As System.Short
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Short

instance.TabIndex = value

value = instance.TabIndex
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public virtual System.short TabIndex {get; set;}
Delphi
public read-write property TabIndex: System.Int16; virtual;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set TabIndex : System.short
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property virtual System.short get_TabIndex();
public: __property virtual void set_TabIndex(
   System.short value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
virtual property System.short TabIndex {
   System.short get();
   void set (    System.short value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


TagKey Property

[image]
Intersoft WebTextEditor Documentation
TagKey Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : TagKey Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
Protected Overridable ReadOnly Property TagKey As System.Web.UI.HtmlTextWriterTag
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Web.UI.HtmlTextWriterTag

value = instance.TagKey
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
protected virtual System.Web.UI.HtmlTextWriterTag TagKey {get;}
Delphi
protected read-only property TagKey: System.Web.UI.HtmlTextWriterTag; virtual;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
protected function get TagKey : System.Web.UI.HtmlTextWriterTag
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
protected: __property virtual System.Web.UI.HtmlTextWriterTag get_TagKey();
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
protected:
virtual property System.Web.UI.HtmlTextWriterTag TagKey {
   System.Web.UI.HtmlTextWriterTag get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


TagName Property

[image]
Intersoft WebTextEditor Documentation
TagName Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : TagName Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Protected Overridable ReadOnly Property TagName As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.String

value = instance.TagName
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
protected virtual System.string TagName {get;}
Delphi
protected read-only property TagName: System.String; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
protected function get TagName : System.String
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
protected: __property virtual System.string* get_TagName();
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
protected:
virtual property System.String^ TagName {
   System.String^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


TemplateControl Property

[image]
Intersoft WebTextEditor Documentation
TemplateControl Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : TemplateControl Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
<WebSysDescriptionAttribute("The TemplateControl that hosts this control.")>
<System.ComponentModel.BindableAttribute(Bindable=False, Direction=BindingDirection.OneWay)>
Public Property TemplateControl As System.Web.UI.TemplateControl
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Web.UI.TemplateControl

instance.TemplateControl = value

value = instance.TemplateControl
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[WebSysDescriptionAttribute("The TemplateControl that hosts this control.")]
[System.ComponentModel.BindableAttribute(Bindable=false, Direction=BindingDirection.OneWay)]
public System.Web.UI.TemplateControl TemplateControl {get; set;}
Delphi
public read-write property TemplateControl: System.Web.UI.TemplateControl;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
WebSysDescriptionAttribute("The TemplateControl that hosts this control.")
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set TemplateControl : System.Web.UI.TemplateControl
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[WebSysDescriptionAttribute("The TemplateControl that hosts this control.")]
[System.ComponentModel.BindableAttribute(Bindable=false, Direction=BindingDirection.OneWay)]
public: __property System.Web.UI.TemplateControl* get_TemplateControl();
public: __property void set_TemplateControl(
   System.Web.UI.TemplateControl* value
);
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[WebSysDescriptionAttribute("The TemplateControl that hosts this control.")]
[System.ComponentModel.BindableAttribute(Bindable=false, Direction=BindingDirection.OneWay)]
public:
property System.Web.UI.TemplateControl^ TemplateControl {
   System.Web.UI.TemplateControl^ get();
   void set (    System.Web.UI.TemplateControl^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


TemplateSourceDirectory Property

[image]
Intersoft WebTextEditor Documentation
TemplateSourceDirectory Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : TemplateSourceDirectory Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<WebSysDescriptionAttribute("The virtual directory of the Page or UserControl that contains this control.")>
Public Overridable ReadOnly Property TemplateSourceDirectory As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.String

value = instance.TemplateSourceDirectory
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[WebSysDescriptionAttribute("The virtual directory of the Page or UserControl that contains this control.")]
public virtual System.string TemplateSourceDirectory {get;}
Delphi
public read-only property TemplateSourceDirectory: System.String; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
WebSysDescriptionAttribute("The virtual directory of the Page or UserControl that contains this control.")
public function get TemplateSourceDirectory : System.String
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[WebSysDescriptionAttribute("The virtual directory of the Page or UserControl that contains this control.")]
public: __property virtual System.string* get_TemplateSourceDirectory();
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[WebSysDescriptionAttribute("The virtual directory of the Page or UserControl that contains this control.")]
public:
virtual property System.String^ TemplateSourceDirectory {
   System.String^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


ToolTip Property

[image]
Intersoft WebTextEditor Documentation
ToolTip Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : ToolTip Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overridable Property ToolTip As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.String

instance.ToolTip = value

value = instance.ToolTip
C#
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public virtual System.string ToolTip {get; set;}
Delphi
public read-write property ToolTip: System.String; virtual;
JScript
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set ToolTip : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property virtual System.string* get_ToolTip();
public: __property virtual void set_ToolTip(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
virtual property System.String^ ToolTip {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


TrackViewState Method

[image]
Intersoft WebTextEditor Documentation
TrackViewState Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : TrackViewState Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub TrackViewState()
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader

instance.TrackViewState()
C#
protected virtual void TrackViewState()
Delphi
protected procedure TrackViewState(); virtual;
JScript
protected function TrackViewState();
Managed Extensions for C++
protected: virtual void TrackViewState();
C++/CLI
protected:
virtual void TrackViewState();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


UniqueID Property

[image]
Intersoft WebTextEditor Documentation
UniqueID Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : UniqueID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<WebSysDescriptionAttribute("The unique ID of the control within the page.")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Overridable ReadOnly Property UniqueID As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.String

value = instance.UniqueID
C#
[System.ComponentModel.BrowsableAttribute(false)]
[WebSysDescriptionAttribute("The unique ID of the control within the page.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public virtual System.string UniqueID {get;}
Delphi
public read-only property UniqueID: System.String; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
WebSysDescriptionAttribute("The unique ID of the control within the page.")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get UniqueID : System.String
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[WebSysDescriptionAttribute("The unique ID of the control within the page.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property virtual System.string* get_UniqueID();
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[WebSysDescriptionAttribute("The unique ID of the control within the page.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
virtual property System.String^ UniqueID {
   System.String^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


Unload Event

[image]
Intersoft WebTextEditor Documentation
Unload Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : Unload Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the page is unloaded.")>
Public Event Unload As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim handler As System.EventHandler

AddHandler instance.Unload, handler
C#
[WebSysDescriptionAttribute("Fires when the page is unloaded.")]
public event System.EventHandler Unload
Delphi
public event Unload: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the page is unloaded.")]
public: __event System.EventHandler* Unload
C++/CLI
[WebSysDescriptionAttribute("Fires when the page is unloaded.")]
public:
event System.EventHandler^ Unload

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


UseDeepCloneForViewStateStorage Method

[image]
Intersoft WebTextEditor Documentation
UseDeepCloneForViewStateStorage Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : UseDeepCloneForViewStateStorage Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function UseDeepCloneForViewStateStorage() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Boolean

value = instance.UseDeepCloneForViewStateStorage()
C#
protected virtual System.bool UseDeepCloneForViewStateStorage()
Delphi
protected function UseDeepCloneForViewStateStorage(): System.Boolean; virtual;
JScript
protected function UseDeepCloneForViewStateStorage() : System.boolean;
Managed Extensions for C++
protected: virtual System.bool UseDeepCloneForViewStateStorage();
C++/CLI
protected:
virtual System.bool UseDeepCloneForViewStateStorage();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


UseMemoryStreamStateType Method

[image]
Intersoft WebTextEditor Documentation
UseMemoryStreamStateType Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : UseMemoryStreamStateType Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function UseMemoryStreamStateType() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Boolean

value = instance.UseMemoryStreamStateType()
C#
protected virtual System.bool UseMemoryStreamStateType()
Delphi
protected function UseMemoryStreamStateType(): System.Boolean; virtual;
JScript
protected function UseMemoryStreamStateType() : System.boolean;
Managed Extensions for C++
protected: virtual System.bool UseMemoryStreamStateType();
C++/CLI
protected:
virtual System.bool UseMemoryStreamStateType();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


ValidateRequestMode Property

[image]
Intersoft WebTextEditor Documentation
ValidateRequestMode Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : ValidateRequestMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebCategoryAttribute("Behavior")>
<System.ComponentModel.DefaultValueAttribute()>
<WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")>
Public Overridable Property ValidateRequestMode As System.Web.UI.ValidateRequestMode
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Web.UI.ValidateRequestMode

instance.ValidateRequestMode = value

value = instance.ValidateRequestMode
C#
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")]
public virtual System.Web.UI.ValidateRequestMode ValidateRequestMode {get; set;}
Delphi
public read-write property ValidateRequestMode: System.Web.UI.ValidateRequestMode; virtual;
JScript
WebCategoryAttribute("Behavior")
System.ComponentModel.DefaultValueAttribute()
WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")
public function get,set ValidateRequestMode : System.Web.UI.ValidateRequestMode
Managed Extensions for C++
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")]
public: __property virtual System.Web.UI.ValidateRequestMode get_ValidateRequestMode();
public: __property virtual void set_ValidateRequestMode(
   System.Web.UI.ValidateRequestMode value
);
C++/CLI
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")]
public:
virtual property System.Web.UI.ValidateRequestMode ValidateRequestMode {
   System.Web.UI.ValidateRequestMode get();
   void set (    System.Web.UI.ValidateRequestMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


ViewState Property

[image]
Intersoft WebTextEditor Documentation
ViewState Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : ViewState Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Current viewstate of the control.")>
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Protected Overridable ReadOnly Property ViewState As System.Web.UI.StateBag
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Web.UI.StateBag

value = instance.ViewState
C#
[WebSysDescriptionAttribute("Current viewstate of the control.")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
protected virtual System.Web.UI.StateBag ViewState {get;}
Delphi
protected read-only property ViewState: System.Web.UI.StateBag; virtual;
JScript
WebSysDescriptionAttribute("Current viewstate of the control.")
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
protected function get ViewState : System.Web.UI.StateBag
Managed Extensions for C++
[WebSysDescriptionAttribute("Current viewstate of the control.")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
protected: __property virtual System.Web.UI.StateBag* get_ViewState();
C++/CLI
[WebSysDescriptionAttribute("Current viewstate of the control.")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
protected:
virtual property System.Web.UI.StateBag^ ViewState {
   System.Web.UI.StateBag^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


ViewStateIgnoresCase Property

[image]
Intersoft WebTextEditor Documentation
ViewStateIgnoresCase Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : ViewStateIgnoresCase Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
Protected Overridable ReadOnly Property ViewStateIgnoresCase As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Boolean

value = instance.ViewStateIgnoresCase
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
protected virtual System.bool ViewStateIgnoresCase {get;}
Delphi
protected read-only property ViewStateIgnoresCase: System.Boolean; virtual;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
protected function get ViewStateIgnoresCase : System.boolean
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
protected: __property virtual System.bool get_ViewStateIgnoresCase();
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
protected:
virtual property System.bool ViewStateIgnoresCase {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


ViewStateItems Property

[image]
Intersoft WebTextEditor Documentation
ViewStateItems Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : ViewStateItems Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.CategoryAttribute("View State Settings")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the items to be stored in view state storage.")>
Public Overridable Property ViewStateItems As ISNet.WebUI.ViewStateItem
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As ISNet.WebUI.ViewStateItem

instance.ViewStateItems = value

value = instance.ViewStateItems
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the items to be stored in view state storage.")]
public virtual ISNet.WebUI.ViewStateItem ViewStateItems {get; set;}
Delphi
public read-write property ViewStateItems: ISNet.WebUI.ViewStateItem; virtual;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.CategoryAttribute("View State Settings")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the items to be stored in view state storage.")
public function get,set ViewStateItems : ISNet.WebUI.ViewStateItem
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the items to be stored in view state storage.")]
public: __property virtual ISNet.WebUI.ViewStateItem get_ViewStateItems();
public: __property virtual void set_ViewStateItems(
   ISNet.WebUI.ViewStateItem value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the items to be stored in view state storage.")]
public:
virtual property ISNet.WebUI.ViewStateItem ViewStateItems {
   ISNet.WebUI.ViewStateItem get();
   void set (    ISNet.WebUI.ViewStateItem value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


viewStateLoaded Field

[image]
Intersoft WebTextEditor Documentation
viewStateLoaded Field
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : viewStateLoaded Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected viewStateLoaded As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Boolean

value = instance.viewStateLoaded

instance.viewStateLoaded = value
C#
protected System.bool viewStateLoaded
Delphi
protected field viewStateLoaded: System.Boolean;
JScript
protected var viewStateLoaded : System.boolean;
Managed Extensions for C++
protected: System.bool viewStateLoaded
C++/CLI
protected:
System.bool viewStateLoaded

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


ViewStateMode Property

[image]
Intersoft WebTextEditor Documentation
ViewStateMode Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : ViewStateMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.ThemeableAttribute(False)>
<WebCategoryAttribute("Behavior")>
<WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Overridable Property ViewStateMode As System.Web.UI.ViewStateMode
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Web.UI.ViewStateMode

instance.ViewStateMode = value

value = instance.ViewStateMode
C#
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")]
[System.ComponentModel.DefaultValueAttribute()]
public virtual System.Web.UI.ViewStateMode ViewStateMode {get; set;}
Delphi
public read-write property ViewStateMode: System.Web.UI.ViewStateMode; virtual;
JScript
System.Web.UI.ThemeableAttribute()
WebCategoryAttribute("Behavior")
WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")
System.ComponentModel.DefaultValueAttribute()
public function get,set ViewStateMode : System.Web.UI.ViewStateMode
Managed Extensions for C++
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property virtual System.Web.UI.ViewStateMode get_ViewStateMode();
public: __property virtual void set_ViewStateMode(
   System.Web.UI.ViewStateMode value
);
C++/CLI
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
virtual property System.Web.UI.ViewStateMode ViewStateMode {
   System.Web.UI.ViewStateMode get();
   void set (    System.Web.UI.ViewStateMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


ViewStateServerConnection Property

[image]
Intersoft WebTextEditor Documentation
ViewStateServerConnection Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : ViewStateServerConnection Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the server connection string for file server-based viewstate storage.")>
<System.ComponentModel.CategoryAttribute("View State Settings")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overridable Property ViewStateServerConnection As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.String

instance.ViewStateServerConnection = value

value = instance.ViewStateServerConnection
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the server connection string for file server-based viewstate storage.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public virtual System.string ViewStateServerConnection {get; set;}
Delphi
public read-write property ViewStateServerConnection: System.String; virtual;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the server connection string for file server-based viewstate storage.")
System.ComponentModel.CategoryAttribute("View State Settings")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set ViewStateServerConnection : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the server connection string for file server-based viewstate storage.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property virtual System.string* get_ViewStateServerConnection();
public: __property virtual void set_ViewStateServerConnection(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the server connection string for file server-based viewstate storage.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
virtual property System.String^ ViewStateServerConnection {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


ViewStateStorage Property

[image]
Intersoft WebTextEditor Documentation
ViewStateStorage Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : ViewStateStorage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the location to store the viewstate of this control.")>
<System.ComponentModel.CategoryAttribute("View State Settings")>
Public Overridable Property ViewStateStorage As ISNet.WebUI.StateCacheStorage
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As ISNet.WebUI.StateCacheStorage

instance.ViewStateStorage = value

value = instance.ViewStateStorage
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the location to store the viewstate of this control.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
public virtual ISNet.WebUI.StateCacheStorage ViewStateStorage {get; set;}
Delphi
public read-write property ViewStateStorage: ISNet.WebUI.StateCacheStorage; virtual;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.DescriptionAttribute("Gets or sets the location to store the viewstate of this control.")
System.ComponentModel.CategoryAttribute("View State Settings")
public function get,set ViewStateStorage : ISNet.WebUI.StateCacheStorage
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the location to store the viewstate of this control.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
public: __property virtual ISNet.WebUI.StateCacheStorage get_ViewStateStorage();
public: __property virtual void set_ViewStateStorage(
   ISNet.WebUI.StateCacheStorage value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the location to store the viewstate of this control.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
public:
virtual property ISNet.WebUI.StateCacheStorage ViewStateStorage {
   ISNet.WebUI.StateCacheStorage get();
   void set (    ISNet.WebUI.StateCacheStorage value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


Visible Property

[image]
Intersoft WebTextEditor Documentation
Visible Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : Visible Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Overridable Property Visible As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Boolean

instance.Visible = value

value = instance.Visible
C#
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public virtual System.bool Visible {get; set;}
Delphi
public read-write property Visible: System.Boolean; virtual;
JScript
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set Visible : System.boolean
Managed Extensions for C++
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property virtual System.bool get_Visible();
public: __property virtual void set_Visible(
   System.bool value
);
C++/CLI
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
virtual property System.bool Visible {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


XmlCompressionEnabled Property

[image]
Intersoft WebTextEditor Documentation
XmlCompressionEnabled Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebFileUploader Class : XmlCompressionEnabled Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether the Xml used for clientside state storage should be compressed.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overridable Property XmlCompressionEnabled As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebFileUploader
Dim value As System.Boolean

instance.XmlCompressionEnabled = value

value = instance.XmlCompressionEnabled
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the Xml used for clientside state storage should be compressed.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public virtual System.bool XmlCompressionEnabled {get; set;}
Delphi
public read-write property XmlCompressionEnabled: System.Boolean; virtual;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether the Xml used for clientside state storage should be compressed.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set XmlCompressionEnabled : System.boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the Xml used for clientside state storage should be compressed.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property virtual System.bool get_XmlCompressionEnabled();
public: __property virtual void set_XmlCompressionEnabled(
   System.bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the Xml used for clientside state storage should be compressed.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
virtual property System.bool XmlCompressionEnabled {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebFileUploader Class
WebFileUploader Members


WebSpellChecker Class Events

[image]
Intersoft WebTextEditor Documentation
WebSpellChecker Class Events
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebSpellChecker Class

Glossary Item Box

For a list of all members of this type, see WebSpellChecker members.

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from System.Web.UI.Control)
Public Event | Disposed | (Inherited from System.Web.UI.Control)
Public Event | Init | (Inherited from System.Web.UI.Control)
Public Event | Load | (Inherited from System.Web.UI.Control)
Public Event | PreInitialize | (Inherited from ISNet.WebUI.ISNetControl)
Public Event | PreRender | (Inherited from System.Web.UI.Control)
Public Event | Unload | (Inherited from System.Web.UI.Control)
Top

See Also

Reference

WebSpellChecker Class
ISNet.WebUI.WebTextEditor Namespace


WebSpellChecker Class Fields

[image]
Intersoft WebTextEditor Documentation
WebSpellChecker Class Fields
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebSpellChecker Class

Glossary Item Box

For a list of all members of this type, see WebSpellChecker members.

Protected Fields

 | Name | Description
Protected Field | isPagePreRender | (Inherited from ISNet.WebUI.ISNetControl)
Protected Field | renderDHTML | (Inherited from ISNet.WebUI.ISNetControl)
Protected Field | renderNS | (Inherited from ISNet.WebUI.ISNetControl)
Protected Field | viewStateLoaded | (Inherited from ISNet.WebUI.ISNetControl)
Top

See Also

Reference

WebSpellChecker Class
ISNet.WebUI.WebTextEditor Namespace


WebSpellCheckerClientSideEvents Class Methods

[image]
Intersoft WebTextEditor Documentation
WebSpellCheckerClientSideEvents Class Methods
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebSpellCheckerClientSideEvents Class

Glossary Item Box

For a list of all members of this type, see WebSpellCheckerClientSideEvents members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

Protected Methods

 | Name | Description
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | IsInSerializationContext | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebSpellCheckerClientSideEvents Class
ISNet.WebUI.WebTextEditor Namespace


Clone Method

[image]
Intersoft WebTextEditor Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerClientSideEvents Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerClientSideEvents
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerClientSideEvents Class
WebSpellCheckerClientSideEvents Members


CopyFrom Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerClientSideEvents Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerClientSideEvents Class
WebSpellCheckerClientSideEvents Members


CopyFrom(Object) Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerClientSideEvents Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerClientSideEvents
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerClientSideEvents Class
WebSpellCheckerClientSideEvents Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerClientSideEvents Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerClientSideEvents
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerClientSideEvents Class
WebSpellCheckerClientSideEvents Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebTextEditor Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerClientSideEvents Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerClientSideEvents
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerClientSideEvents Class
WebSpellCheckerClientSideEvents Members


GetHashCode Method

[image]
Intersoft WebTextEditor Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerClientSideEvents Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerClientSideEvents
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerClientSideEvents Class
WebSpellCheckerClientSideEvents Members


GetObjectData Method

[image]
Intersoft WebTextEditor Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerClientSideEvents Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerClientSideEvents
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public virtual void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); virtual;
JScript
public function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: virtual void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
virtual void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerClientSideEvents Class
WebSpellCheckerClientSideEvents Members


GetPropertyString Method

[image]
Intersoft WebTextEditor Documentation
GetPropertyString Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerClientSideEvents Class : GetPropertyString Method

v

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetPropertyString( _
   ByVal v As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerClientSideEvents
Dim v As System.String
Dim value As System.String

value = instance.GetPropertyString(v)
C#
protected virtual System.string GetPropertyString(
   System.string v
)
Delphi
protected function GetPropertyString(
    v: System.String
): System.String; virtual;
JScript
protected function GetPropertyString(
   v : System.String
) : System.String;
Managed Extensions for C++
protected: virtual System.string* GetPropertyString(
   System.string* v
)
C++/CLI
protected:
virtual System.String^ GetPropertyString(
   System.String^ v
)

Parameters

v

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerClientSideEvents Class
WebSpellCheckerClientSideEvents Members


IsEmpty Method

[image]
Intersoft WebTextEditor Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerClientSideEvents Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerClientSideEvents
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerClientSideEvents Class
WebSpellCheckerClientSideEvents Members


IsInSerializationContext Method

[image]
Intersoft WebTextEditor Documentation
IsInSerializationContext Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerClientSideEvents Class : IsInSerializationContext Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function IsInSerializationContext() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerClientSideEvents
Dim value As System.Boolean

value = instance.IsInSerializationContext()
C#
protected virtual System.bool IsInSerializationContext()
Delphi
protected function IsInSerializationContext(): System.Boolean; virtual;
JScript
protected function IsInSerializationContext() : System.boolean;
Managed Extensions for C++
protected: virtual System.bool IsInSerializationContext();
C++/CLI
protected:
virtual System.bool IsInSerializationContext();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerClientSideEvents Class
WebSpellCheckerClientSideEvents Members


Reset Method

[image]
Intersoft WebTextEditor Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerClientSideEvents Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerClientSideEvents

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerClientSideEvents Class
WebSpellCheckerClientSideEvents Members


SerializeObjectData Method

[image]
Intersoft WebTextEditor Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerClientSideEvents Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerClientSideEvents
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerClientSideEvents Class
WebSpellCheckerClientSideEvents Members


ToString Method

[image]
Intersoft WebTextEditor Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerClientSideEvents Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerClientSideEvents
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerClientSideEvents Class
WebSpellCheckerClientSideEvents Members


WebSpellCheckerDictionaryDataCollection Class Methods

[image]
Intersoft WebTextEditor Documentation
WebSpellCheckerDictionaryDataCollection Class Methods
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebSpellCheckerDictionaryDataCollection Class

Glossary Item Box

For a list of all members of this type, see WebSpellCheckerDictionaryDataCollection members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CreateNewItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorMedia>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | GetNamedItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorMedia>)
Public Method | GetObjectData | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | SerializerConstructor | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorMedia>)
Public Method | SetParent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

Protected Methods

 | Name | Description
Protected Method | ClearItems | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorMedia>)
Protected Method | CreateArray | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Protected Method | InsertItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorMedia>)
Protected Method | RemoveItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorMedia>)
Protected Method | SetItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorMedia>)
Top

See Also

Reference

WebSpellCheckerDictionaryDataCollection Class
ISNet.WebUI.WebTextEditor Namespace


WebSpellCheckerDictionaryDataCollection Class Properties

[image]
Intersoft WebTextEditor Documentation
WebSpellCheckerDictionaryDataCollection Class Properties
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebSpellCheckerDictionaryDataCollection Class

Glossary Item Box

For a list of all members of this type, see WebSpellCheckerDictionaryDataCollection members.

Public Properties

 | Name | Description
Public Property | All | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

Protected Properties

 | Name | Description
Protected Property | Items | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Top

See Also

Reference

WebSpellCheckerDictionaryDataCollection Class
ISNet.WebUI.WebTextEditor Namespace


Add Method

[image]
Intersoft WebTextEditor Documentation
Add Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerDictionaryDataCollection Class : Add Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Sub Add( _
   ByVal item As ISNet.WebUI.INamedObject2 _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerDictionaryDataCollection
Dim item As ISNet.WebUI.INamedObject2

instance.Add(item)
C#
[__DynamicallyInvokableAttribute()]
public void Add(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public procedure Add(
    item: ISNet.WebUI.INamedObject2
);
JScript
__DynamicallyInvokableAttribute()
public function Add(
   item : ISNet.WebUI.INamedObject2
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void Add(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void Add(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerDictionaryDataCollection Class
WebSpellCheckerDictionaryDataCollection Members


All Property

[image]
Intersoft WebTextEditor Documentation
All Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerDictionaryDataCollection Class : All Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public ReadOnly Property All As ISNet.WebUI.INamedObject2()
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerDictionaryDataCollection
Dim value() As ISNet.WebUI.INamedObject2

value = instance.All
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public ISNet.WebUI.INamedObject2[] All {get;}
Delphi
public read-only property All: ISNet.WebUI.array of INamedObject2;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get All : ISNet.WebUI.INamedObject2[]
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property ISNet.WebUI.INamedObject2*[]* get_All();
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property ISNet.WebUI.array<INamedObject2^>^ All {
   ISNet.WebUI.array<INamedObject2^>^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerDictionaryDataCollection Class
WebSpellCheckerDictionaryDataCollection Members


Clear Method

[image]
Intersoft WebTextEditor Documentation
Clear Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerDictionaryDataCollection Class : Clear Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerDictionaryDataCollection

instance.Clear()
C#
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public void Clear()
Delphi
public procedure Clear();
JScript
__DynamicallyInvokableAttribute()
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function Clear();
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: void Clear();
C++/CLI
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
void Clear();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerDictionaryDataCollection Class
WebSpellCheckerDictionaryDataCollection Members


ClearItems Method

[image]
Intersoft WebTextEditor Documentation
ClearItems Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerDictionaryDataCollection Class : ClearItems Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ClearItems()
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerDictionaryDataCollection

instance.ClearItems()
C#
protected virtual void ClearItems()
Delphi
protected procedure ClearItems(); virtual;
JScript
protected function ClearItems();
Managed Extensions for C++
protected: virtual void ClearItems();
C++/CLI
protected:
virtual void ClearItems();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerDictionaryDataCollection Class
WebSpellCheckerDictionaryDataCollection Members


Contains Method

[image]
Intersoft WebTextEditor Documentation
Contains Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerDictionaryDataCollection Class : Contains Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
<__DynamicallyInvokableAttribute()>
Public Function Contains( _
   ByVal item As ISNet.WebUI.INamedObject2 _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerDictionaryDataCollection
Dim item As ISNet.WebUI.INamedObject2
Dim value As System.Boolean

value = instance.Contains(item)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public System.bool Contains(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public function Contains(
    item: ISNet.WebUI.INamedObject2
): System.Boolean;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
__DynamicallyInvokableAttribute()
public function Contains(
   item : ISNet.WebUI.INamedObject2
) : System.boolean;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public: System.bool Contains(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public:
System.bool Contains(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerDictionaryDataCollection Class
WebSpellCheckerDictionaryDataCollection Members


CopyTo Method

[image]
Intersoft WebTextEditor Documentation
CopyTo Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerDictionaryDataCollection Class : CopyTo Method

array
index

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Sub CopyTo( _
   ByVal array() As ISNet.WebUI.INamedObject2, _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerDictionaryDataCollection
Dim array() As ISNet.WebUI.INamedObject2
Dim index As System.Integer

instance.CopyTo(array, index)
C#
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public void CopyTo(
   ISNet.WebUI.INamedObject2[] array,
   System.int index
)
Delphi
public procedure CopyTo(
    array: ISNet.WebUI.INamedObject2array of;
    index: System.Integer
);
JScript
__DynamicallyInvokableAttribute()
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function CopyTo(
   array : ISNet.WebUI.INamedObject2[],
   index : System.int
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: void CopyTo(
   ISNet.WebUI.INamedObject2*[]* array,
   System.int index
)
C++/CLI
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
void CopyTo(
   ISNet.WebUI.array<INamedObject2^>^ array,
   System.int index
)

Parameters

array
index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerDictionaryDataCollection Class
WebSpellCheckerDictionaryDataCollection Members


Count Property

[image]
Intersoft WebTextEditor Documentation
Count Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerDictionaryDataCollection Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public ReadOnly Property Count As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerDictionaryDataCollection
Dim value As System.Integer

value = instance.Count
C#
[__DynamicallyInvokableAttribute()]
public System.int Count {get;}
Delphi
public read-only property Count: System.Integer;
JScript
__DynamicallyInvokableAttribute()
public function get Count : System.int
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: __property System.int get_Count();
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
property System.int Count {
   System.int get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerDictionaryDataCollection Class
WebSpellCheckerDictionaryDataCollection Members


CreateArray Method

[image]
Intersoft WebTextEditor Documentation
CreateArray Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerDictionaryDataCollection Class : CreateArray Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function CreateArray() As ISNet.WebUI.INamedObject2()
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerDictionaryDataCollection
Dim value() As ISNet.WebUI.INamedObject2

value = instance.CreateArray()
C#
protected ISNet.WebUI.INamedObject2[] CreateArray()
Delphi
protected function CreateArray(): ISNet.WebUI.array of INamedObject2;
JScript
protected function CreateArray() : ISNet.WebUI.INamedObject2[];
Managed Extensions for C++
protected: ISNet.WebUI.INamedObject2*[]* CreateArray();
C++/CLI
protected:
ISNet.WebUI.array<INamedObject2^>^ CreateArray();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerDictionaryDataCollection Class
WebSpellCheckerDictionaryDataCollection Members


CreateNewItem Method

[image]
Intersoft WebTextEditor Documentation
CreateNewItem Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerDictionaryDataCollection Class : CreateNewItem Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CreateNewItem() As WebTextEditorMedia
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerDictionaryDataCollection
Dim value As WebTextEditorMedia

value = instance.CreateNewItem()
C#
public WebTextEditorMedia CreateNewItem()
Delphi
public function CreateNewItem(): WebTextEditorMedia;
JScript
public function CreateNewItem() : WebTextEditorMedia;
Managed Extensions for C++
public: WebTextEditorMedia* CreateNewItem();
C++/CLI
public:
WebTextEditorMedia^ CreateNewItem();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerDictionaryDataCollection Class
WebSpellCheckerDictionaryDataCollection Members


GetEnumerator Method

[image]
Intersoft WebTextEditor Documentation
GetEnumerator Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerDictionaryDataCollection Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Function GetEnumerator() As System.Collections.Generic.IEnumerator(Of INamedObject2)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerDictionaryDataCollection
Dim value As System.Collections.Generic.IEnumerator(Of INamedObject2)

value = instance.GetEnumerator()
C#
[__DynamicallyInvokableAttribute()]
public System.Collections.Generic.IEnumerator<INamedObject2> GetEnumerator()
Delphi
public function GetEnumerator(): System.Collections.Generic.IEnumerator;
JScript
__DynamicallyInvokableAttribute()
public function GetEnumerator() : System.Collections.Generic.IEnumerator;
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: System.Collections.Generic.IEnumerator<INamedObject2*>* GetEnumerator();
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
System.Collections.Generic.IEnumerator<INamedObject2^>^ GetEnumerator();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerDictionaryDataCollection Class
WebSpellCheckerDictionaryDataCollection Members


GetNamedItem Method

[image]
Intersoft WebTextEditor Documentation
GetNamedItem Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerDictionaryDataCollection Class : GetNamedItem Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetNamedItem( _
   ByVal name As System.String _
) As WebTextEditorMedia
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerDictionaryDataCollection
Dim name As System.String
Dim value As WebTextEditorMedia

value = instance.GetNamedItem(name)
C#
public WebTextEditorMedia GetNamedItem(
   System.string name
)
Delphi
public function GetNamedItem(
    name: System.String
): WebTextEditorMedia;
JScript
public function GetNamedItem(
   name : System.String
) : WebTextEditorMedia;
Managed Extensions for C++
public: WebTextEditorMedia* GetNamedItem(
   System.string* name
)
C++/CLI
public:
WebTextEditorMedia^ GetNamedItem(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerDictionaryDataCollection Class
WebSpellCheckerDictionaryDataCollection Members


GetObjectData Method

[image]
Intersoft WebTextEditor Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerDictionaryDataCollection Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerDictionaryDataCollection
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerDictionaryDataCollection Class
WebSpellCheckerDictionaryDataCollection Members


IndexOf Method

[image]
Intersoft WebTextEditor Documentation
IndexOf Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerDictionaryDataCollection Class : IndexOf Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
<__DynamicallyInvokableAttribute()>
Public Function IndexOf( _
   ByVal item As ISNet.WebUI.INamedObject2 _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerDictionaryDataCollection
Dim item As ISNet.WebUI.INamedObject2
Dim value As System.Integer

value = instance.IndexOf(item)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public System.int IndexOf(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public function IndexOf(
    item: ISNet.WebUI.INamedObject2
): System.Integer;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
__DynamicallyInvokableAttribute()
public function IndexOf(
   item : ISNet.WebUI.INamedObject2
) : System.int;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public: System.int IndexOf(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public:
System.int IndexOf(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerDictionaryDataCollection Class
WebSpellCheckerDictionaryDataCollection Members


Insert Method

[image]
Intersoft WebTextEditor Documentation
Insert Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerDictionaryDataCollection Class : Insert Method

index
item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal item As ISNet.WebUI.INamedObject2 _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerDictionaryDataCollection
Dim index As System.Integer
Dim item As ISNet.WebUI.INamedObject2

instance.Insert(index, item)
C#
[__DynamicallyInvokableAttribute()]
public void Insert(
   System.int index,
   ISNet.WebUI.INamedObject2 item
)
Delphi
public procedure Insert(
    index: System.Integer;
    item: ISNet.WebUI.INamedObject2
);
JScript
__DynamicallyInvokableAttribute()
public function Insert(
   index : System.int,
   item : ISNet.WebUI.INamedObject2
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void Insert(
   System.int index,
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void Insert(
   System.int index,
   ISNet.WebUI.INamedObject2^ item
)

Parameters

index
item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerDictionaryDataCollection Class
WebSpellCheckerDictionaryDataCollection Members


InsertItem Method

[image]
Intersoft WebTextEditor Documentation
InsertItem Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerDictionaryDataCollection Class : InsertItem Method

index
item

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub InsertItem( _
   ByVal index As System.Integer, _
   ByVal item As ISNet.WebUI.INamedObject2 _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerDictionaryDataCollection
Dim index As System.Integer
Dim item As ISNet.WebUI.INamedObject2

instance.InsertItem(index, item)
C#
protected virtual void InsertItem(
   System.int index,
   ISNet.WebUI.INamedObject2 item
)
Delphi
protected procedure InsertItem(
    index: System.Integer;
    item: ISNet.WebUI.INamedObject2
); virtual;
JScript
protected function InsertItem(
   index : System.int,
   item : ISNet.WebUI.INamedObject2
);
Managed Extensions for C++
protected: virtual void InsertItem(
   System.int index,
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
protected:
virtual void InsertItem(
   System.int index,
   ISNet.WebUI.INamedObject2^ item
)

Parameters

index
item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerDictionaryDataCollection Class
WebSpellCheckerDictionaryDataCollection Members


Item Property

[image]
Intersoft WebTextEditor Documentation
Item Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerDictionaryDataCollection Class : Item Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Default Property Item( _
   ByVal index As System.Integer _
) As ISNet.WebUI.INamedObject2
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerDictionaryDataCollection
Dim index As System.Integer
Dim value As ISNet.WebUI.INamedObject2

instance.Item(index) = value

value = instance.Item(index)
C#
[__DynamicallyInvokableAttribute()]
public ISNet.WebUI.INamedObject2 this[
   System.int index
]; {get; set;}
Delphi
public  this: : ISNet.WebUI.INamedObject2;[
    index: System.Integer
]; read-write
JScript
__DynamicallyInvokableAttribute()
public  this[
   index : System.int
] get,set : ISNet.WebUI.INamedObject2
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: __property ISNet.WebUI.INamedObject2* get_Item   System.int index
;
public: __property void set_Item   System.int index,
   ISNet.WebUI.INamedObject2* value
;
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
property ISNet.WebUI.INamedObject2^ default [int] {
   ISNet.WebUI.INamedObject2^ get(System.int index);
   void set (System.int index, ISNet.WebUI.INamedObject2^ value);
}

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerDictionaryDataCollection Class
WebSpellCheckerDictionaryDataCollection Members


Items Property

[image]
Intersoft WebTextEditor Documentation
Items Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerDictionaryDataCollection Class : Items Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Protected ReadOnly Property Items As System.Collections.Generic.IList(Of INamedObject2)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerDictionaryDataCollection
Dim value As System.Collections.Generic.IList(Of INamedObject2)

value = instance.Items
C#
[__DynamicallyInvokableAttribute()]
protected System.Collections.Generic.IList<INamedObject2> Items {get;}
Delphi
protected read-only property Items: System.Collections.Generic.IList;
JScript
__DynamicallyInvokableAttribute()
protected function get Items : System.Collections.Generic.IList
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
protected: __property System.Collections.Generic.IList<INamedObject2*>* get_Items();
C++/CLI
[__DynamicallyInvokableAttribute()]
protected:
property System.Collections.Generic.IList<INamedObject2^>^ Items {
   System.Collections.Generic.IList<INamedObject2^>^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerDictionaryDataCollection Class
WebSpellCheckerDictionaryDataCollection Members


Parent Property

[image]
Intersoft WebTextEditor Documentation
Parent Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerDictionaryDataCollection Class : Parent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerDictionaryDataCollection
Dim value As System.Object

value = instance.Parent
C#
public System.object Parent {get;}
Delphi
public read-only property Parent: System.TObject;
JScript
public function get Parent : System.Object
Managed Extensions for C++
public: __property System.Object* get_Parent();
C++/CLI
public:
property System.Object^ Parent {
   System.Object^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerDictionaryDataCollection Class
WebSpellCheckerDictionaryDataCollection Members


Remove Method

[image]
Intersoft WebTextEditor Documentation
Remove Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerDictionaryDataCollection Class : Remove Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Function Remove( _
   ByVal item As ISNet.WebUI.INamedObject2 _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerDictionaryDataCollection
Dim item As ISNet.WebUI.INamedObject2
Dim value As System.Boolean

value = instance.Remove(item)
C#
[__DynamicallyInvokableAttribute()]
public System.bool Remove(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public function Remove(
    item: ISNet.WebUI.INamedObject2
): System.Boolean;
JScript
__DynamicallyInvokableAttribute()
public function Remove(
   item : ISNet.WebUI.INamedObject2
) : System.boolean;
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: System.bool Remove(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
System.bool Remove(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerDictionaryDataCollection Class
WebSpellCheckerDictionaryDataCollection Members


RemoveAt Method

[image]
Intersoft WebTextEditor Documentation
RemoveAt Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerDictionaryDataCollection Class : RemoveAt Method

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerDictionaryDataCollection
Dim index As System.Integer

instance.RemoveAt(index)
C#
[__DynamicallyInvokableAttribute()]
public void RemoveAt(
   System.int index
)
Delphi
public procedure RemoveAt(
    index: System.Integer
);
JScript
__DynamicallyInvokableAttribute()
public function RemoveAt(
   index : System.int
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void RemoveAt(
   System.int index
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void RemoveAt(
   System.int index
)

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerDictionaryDataCollection Class
WebSpellCheckerDictionaryDataCollection Members


RemoveItem Method

[image]
Intersoft WebTextEditor Documentation
RemoveItem Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerDictionaryDataCollection Class : RemoveItem Method

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub RemoveItem( _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerDictionaryDataCollection
Dim index As System.Integer

instance.RemoveItem(index)
C#
protected virtual void RemoveItem(
   System.int index
)
Delphi
protected procedure RemoveItem(
    index: System.Integer
); virtual;
JScript
protected function RemoveItem(
   index : System.int
);
Managed Extensions for C++
protected: virtual void RemoveItem(
   System.int index
)
C++/CLI
protected:
virtual void RemoveItem(
   System.int index
)

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerDictionaryDataCollection Class
WebSpellCheckerDictionaryDataCollection Members


SerializerConstructor Method

[image]
Intersoft WebTextEditor Documentation
SerializerConstructor Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerDictionaryDataCollection Class : SerializerConstructor Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializerConstructor( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerDictionaryDataCollection
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializerConstructor(info, context)
C#
public void SerializerConstructor(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializerConstructor(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializerConstructor(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializerConstructor(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializerConstructor(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerDictionaryDataCollection Class
WebSpellCheckerDictionaryDataCollection Members


SetItem Method

[image]
Intersoft WebTextEditor Documentation
SetItem Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerDictionaryDataCollection Class : SetItem Method

index
item

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub SetItem( _
   ByVal index As System.Integer, _
   ByVal item As ISNet.WebUI.INamedObject2 _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerDictionaryDataCollection
Dim index As System.Integer
Dim item As ISNet.WebUI.INamedObject2

instance.SetItem(index, item)
C#
protected virtual void SetItem(
   System.int index,
   ISNet.WebUI.INamedObject2 item
)
Delphi
protected procedure SetItem(
    index: System.Integer;
    item: ISNet.WebUI.INamedObject2
); virtual;
JScript
protected function SetItem(
   index : System.int,
   item : ISNet.WebUI.INamedObject2
);
Managed Extensions for C++
protected: virtual void SetItem(
   System.int index,
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
protected:
virtual void SetItem(
   System.int index,
   ISNet.WebUI.INamedObject2^ item
)

Parameters

index
item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerDictionaryDataCollection Class
WebSpellCheckerDictionaryDataCollection Members


SetParent Method

[image]
Intersoft WebTextEditor Documentation
SetParent Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerDictionaryDataCollection Class : SetParent Method

parent

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SetParent( _
   ByVal parent As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerDictionaryDataCollection
Dim parent As System.Object

instance.SetParent(parent)
C#
public virtual void SetParent(
   System.object parent
)
Delphi
public procedure SetParent(
    parent: System.TObject
); virtual;
JScript
public function SetParent(
   parent : System.Object
);
Managed Extensions for C++
public: virtual void SetParent(
   System.Object* parent
)
C++/CLI
public:
virtual void SetParent(
   System.Object^ parent
)

Parameters

parent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerDictionaryDataCollection Class
WebSpellCheckerDictionaryDataCollection Members


Clone Method

[image]
Intersoft WebTextEditor Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerDictionaryData Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerDictionaryData
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerDictionaryData Class
WebSpellCheckerDictionaryData Members


Collection Property

[image]
Intersoft WebTextEditor Documentation
Collection Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerDictionaryData Class : Collection Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
Public Property Collection As ISNet.WebUI.ISCollectionBase(Of INamedObject2)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerDictionaryData
Dim value As ISNet.WebUI.ISCollectionBase(Of INamedObject2)

instance.Collection = value

value = instance.Collection
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public ISNet.WebUI.ISCollectionBase<INamedObject2> Collection {get; set;}
Delphi
public read-write property Collection: ISNet.WebUI.ISCollectionBase;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
public function get,set Collection : ISNet.WebUI.ISCollectionBase
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public: __property ISNet.WebUI.ISCollectionBase<INamedObject2*>* get_Collection();
public: __property void set_Collection(
   ISNet.WebUI.ISCollectionBase<INamedObject2*>* value
);
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public:
property ISNet.WebUI.ISCollectionBase<INamedObject2^>^ Collection {
   ISNet.WebUI.ISCollectionBase<INamedObject2^>^ get();
   void set (    ISNet.WebUI.ISCollectionBase<INamedObject2^>^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerDictionaryData Class
WebSpellCheckerDictionaryData Members


CopyFrom Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerDictionaryData Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerDictionaryData Class
WebSpellCheckerDictionaryData Members


CopyFrom(Object) Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerDictionaryData Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerDictionaryData
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerDictionaryData Class
WebSpellCheckerDictionaryData Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerDictionaryData Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerDictionaryData
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerDictionaryData Class
WebSpellCheckerDictionaryData Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebTextEditor Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerDictionaryData Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerDictionaryData
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerDictionaryData Class
WebSpellCheckerDictionaryData Members


GetHashCode Method

[image]
Intersoft WebTextEditor Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerDictionaryData Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerDictionaryData
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerDictionaryData Class
WebSpellCheckerDictionaryData Members


GetPropertyString Method

[image]
Intersoft WebTextEditor Documentation
GetPropertyString Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerDictionaryData Class : GetPropertyString Method

v

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetPropertyString( _
   ByVal v As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerDictionaryData
Dim v As System.String
Dim value As System.String

value = instance.GetPropertyString(v)
C#
protected virtual System.string GetPropertyString(
   System.string v
)
Delphi
protected function GetPropertyString(
    v: System.String
): System.String; virtual;
JScript
protected function GetPropertyString(
   v : System.String
) : System.String;
Managed Extensions for C++
protected: virtual System.string* GetPropertyString(
   System.string* v
)
C++/CLI
protected:
virtual System.String^ GetPropertyString(
   System.String^ v
)

Parameters

v

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerDictionaryData Class
WebSpellCheckerDictionaryData Members


IsEmpty Method

[image]
Intersoft WebTextEditor Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerDictionaryData Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerDictionaryData
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerDictionaryData Class
WebSpellCheckerDictionaryData Members


IsInSerializationContext Method

[image]
Intersoft WebTextEditor Documentation
IsInSerializationContext Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerDictionaryData Class : IsInSerializationContext Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function IsInSerializationContext() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerDictionaryData
Dim value As System.Boolean

value = instance.IsInSerializationContext()
C#
protected virtual System.bool IsInSerializationContext()
Delphi
protected function IsInSerializationContext(): System.Boolean; virtual;
JScript
protected function IsInSerializationContext() : System.boolean;
Managed Extensions for C++
protected: virtual System.bool IsInSerializationContext();
C++/CLI
protected:
virtual System.bool IsInSerializationContext();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerDictionaryData Class
WebSpellCheckerDictionaryData Members


Name Property

[image]
Intersoft WebTextEditor Documentation
Name Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerDictionaryData Class : Name Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BrowsableAttribute(False)>
Public Overridable Property Name As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerDictionaryData
Dim value As System.String

instance.Name = value

value = instance.Name
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BrowsableAttribute(false)]
public virtual System.string Name {get; set;}
Delphi
public read-write property Name: System.String; virtual;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BrowsableAttribute()
public function get,set Name : System.String
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BrowsableAttribute(false)]
public: __property virtual System.string* get_Name();
public: __property virtual void set_Name(
   System.string* value
);
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BrowsableAttribute(false)]
public:
virtual property System.String^ Name {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerDictionaryData Class
WebSpellCheckerDictionaryData Members


OnItemAdd Method

[image]
Intersoft WebTextEditor Documentation
OnItemAdd Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerDictionaryData Class : OnItemAdd Method

collection

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnItemAdd( _
   ByVal collection As ISNet.WebUI.ISCollectionBase(Of INamedObject2) _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerDictionaryData
Dim collection As ISNet.WebUI.ISCollectionBase(Of INamedObject2)

instance.OnItemAdd(collection)
C#
protected virtual void OnItemAdd(
   ISNet.WebUI.ISCollectionBase<INamedObject2> collection
)
Delphi
protected procedure OnItemAdd(
    collection: ISNet.WebUI.ISCollectionBase
); virtual;
JScript
protected function OnItemAdd(
   collection : ISNet.WebUI.ISCollectionBase
);
Managed Extensions for C++
protected: virtual void OnItemAdd(
   ISNet.WebUI.ISCollectionBase<INamedObject2*>* collection
)
C++/CLI
protected:
virtual void OnItemAdd(
   ISNet.WebUI.ISCollectionBase<INamedObject2^>^ collection
)

Parameters

collection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerDictionaryData Class
WebSpellCheckerDictionaryData Members


OnItemRemove Method

[image]
Intersoft WebTextEditor Documentation
OnItemRemove Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerDictionaryData Class : OnItemRemove Method

collection

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnItemRemove( _
   ByVal collection As ISNet.WebUI.ISCollectionBase(Of INamedObject2) _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerDictionaryData
Dim collection As ISNet.WebUI.ISCollectionBase(Of INamedObject2)

instance.OnItemRemove(collection)
C#
protected virtual void OnItemRemove(
   ISNet.WebUI.ISCollectionBase<INamedObject2> collection
)
Delphi
protected procedure OnItemRemove(
    collection: ISNet.WebUI.ISCollectionBase
); virtual;
JScript
protected function OnItemRemove(
   collection : ISNet.WebUI.ISCollectionBase
);
Managed Extensions for C++
protected: virtual void OnItemRemove(
   ISNet.WebUI.ISCollectionBase<INamedObject2*>* collection
)
C++/CLI
protected:
virtual void OnItemRemove(
   ISNet.WebUI.ISCollectionBase<INamedObject2^>^ collection
)

Parameters

collection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerDictionaryData Class
WebSpellCheckerDictionaryData Members


Reset Method

[image]
Intersoft WebTextEditor Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerDictionaryData Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerDictionaryData

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerDictionaryData Class
WebSpellCheckerDictionaryData Members


SerializeObjectData Method

[image]
Intersoft WebTextEditor Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerDictionaryData Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerDictionaryData
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerDictionaryData Class
WebSpellCheckerDictionaryData Members


ToString Method

[image]
Intersoft WebTextEditor Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerDictionaryData Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerDictionaryData
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerDictionaryData Class
WebSpellCheckerDictionaryData Members


Clone Method

[image]
Intersoft WebTextEditor Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerImagesSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerImagesSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerImagesSettings Class
WebSpellCheckerImagesSettings Members


CopyFrom Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerImagesSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerImagesSettings Class
WebSpellCheckerImagesSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerImagesSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerImagesSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerImagesSettings Class
WebSpellCheckerImagesSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerImagesSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerImagesSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerImagesSettings Class
WebSpellCheckerImagesSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebTextEditor Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerImagesSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerImagesSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerImagesSettings Class
WebSpellCheckerImagesSettings Members


GetHashCode Method

[image]
Intersoft WebTextEditor Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerImagesSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerImagesSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerImagesSettings Class
WebSpellCheckerImagesSettings Members


GetPropertyString Method

[image]
Intersoft WebTextEditor Documentation
GetPropertyString Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerImagesSettings Class : GetPropertyString Method

v

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetPropertyString( _
   ByVal v As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerImagesSettings
Dim v As System.String
Dim value As System.String

value = instance.GetPropertyString(v)
C#
protected virtual System.string GetPropertyString(
   System.string v
)
Delphi
protected function GetPropertyString(
    v: System.String
): System.String; virtual;
JScript
protected function GetPropertyString(
   v : System.String
) : System.String;
Managed Extensions for C++
protected: virtual System.string* GetPropertyString(
   System.string* v
)
C++/CLI
protected:
virtual System.String^ GetPropertyString(
   System.String^ v
)

Parameters

v

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerImagesSettings Class
WebSpellCheckerImagesSettings Members


IsEmpty Method

[image]
Intersoft WebTextEditor Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerImagesSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerImagesSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerImagesSettings Class
WebSpellCheckerImagesSettings Members


IsInSerializationContext Method

[image]
Intersoft WebTextEditor Documentation
IsInSerializationContext Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerImagesSettings Class : IsInSerializationContext Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function IsInSerializationContext() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerImagesSettings
Dim value As System.Boolean

value = instance.IsInSerializationContext()
C#
protected virtual System.bool IsInSerializationContext()
Delphi
protected function IsInSerializationContext(): System.Boolean; virtual;
JScript
protected function IsInSerializationContext() : System.boolean;
Managed Extensions for C++
protected: virtual System.bool IsInSerializationContext();
C++/CLI
protected:
virtual System.bool IsInSerializationContext();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerImagesSettings Class
WebSpellCheckerImagesSettings Members


Reset Method

[image]
Intersoft WebTextEditor Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerImagesSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerImagesSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerImagesSettings Class
WebSpellCheckerImagesSettings Members


SerializeObjectData Method

[image]
Intersoft WebTextEditor Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerImagesSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerImagesSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerImagesSettings Class
WebSpellCheckerImagesSettings Members


ToString Method

[image]
Intersoft WebTextEditor Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerImagesSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerImagesSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerImagesSettings Class
WebSpellCheckerImagesSettings Members


Clone Method

[image]
Intersoft WebTextEditor Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerTextSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerTextSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerTextSettings Class
WebSpellCheckerTextSettings Members


CopyFrom Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerTextSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerTextSettings Class
WebSpellCheckerTextSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerTextSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerTextSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerTextSettings Class
WebSpellCheckerTextSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerTextSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerTextSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerTextSettings Class
WebSpellCheckerTextSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebTextEditor Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerTextSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerTextSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerTextSettings Class
WebSpellCheckerTextSettings Members


GetHashCode Method

[image]
Intersoft WebTextEditor Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerTextSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerTextSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerTextSettings Class
WebSpellCheckerTextSettings Members


GetPropertyString Method

[image]
Intersoft WebTextEditor Documentation
GetPropertyString Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerTextSettings Class : GetPropertyString Method

v

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetPropertyString( _
   ByVal v As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerTextSettings
Dim v As System.String
Dim value As System.String

value = instance.GetPropertyString(v)
C#
protected virtual System.string GetPropertyString(
   System.string v
)
Delphi
protected function GetPropertyString(
    v: System.String
): System.String; virtual;
JScript
protected function GetPropertyString(
   v : System.String
) : System.String;
Managed Extensions for C++
protected: virtual System.string* GetPropertyString(
   System.string* v
)
C++/CLI
protected:
virtual System.String^ GetPropertyString(
   System.String^ v
)

Parameters

v

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerTextSettings Class
WebSpellCheckerTextSettings Members


IsEmpty Method

[image]
Intersoft WebTextEditor Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerTextSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerTextSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerTextSettings Class
WebSpellCheckerTextSettings Members


IsInSerializationContext Method

[image]
Intersoft WebTextEditor Documentation
IsInSerializationContext Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerTextSettings Class : IsInSerializationContext Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function IsInSerializationContext() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerTextSettings
Dim value As System.Boolean

value = instance.IsInSerializationContext()
C#
protected virtual System.bool IsInSerializationContext()
Delphi
protected function IsInSerializationContext(): System.Boolean; virtual;
JScript
protected function IsInSerializationContext() : System.boolean;
Managed Extensions for C++
protected: virtual System.bool IsInSerializationContext();
C++/CLI
protected:
virtual System.bool IsInSerializationContext();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerTextSettings Class
WebSpellCheckerTextSettings Members


Reset Method

[image]
Intersoft WebTextEditor Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerTextSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerTextSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerTextSettings Class
WebSpellCheckerTextSettings Members


SerializeObjectData Method

[image]
Intersoft WebTextEditor Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerTextSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerTextSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerTextSettings Class
WebSpellCheckerTextSettings Members


ToString Method

[image]
Intersoft WebTextEditor Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerTextSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerTextSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerTextSettings Class
WebSpellCheckerTextSettings Members


WebSpellCheckerTextSuggestionCollection Class Methods

[image]
Intersoft WebTextEditor Documentation
WebSpellCheckerTextSuggestionCollection Class Methods
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebSpellCheckerTextSuggestionCollection Class

Glossary Item Box

For a list of all members of this type, see WebSpellCheckerTextSuggestionCollection members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CreateNewItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorMedia>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | GetNamedItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorMedia>)
Public Method | GetObjectData | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | SerializerConstructor | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorMedia>)
Public Method | SetParent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

Protected Methods

 | Name | Description
Protected Method | ClearItems | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorMedia>)
Protected Method | CreateArray | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Protected Method | InsertItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorMedia>)
Protected Method | RemoveItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorMedia>)
Protected Method | SetItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorMedia>)
Top

See Also

Reference

WebSpellCheckerTextSuggestionCollection Class
ISNet.WebUI.WebTextEditor Namespace


WebSpellCheckerTextSuggestionCollection Class Properties

[image]
Intersoft WebTextEditor Documentation
WebSpellCheckerTextSuggestionCollection Class Properties
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebSpellCheckerTextSuggestionCollection Class

Glossary Item Box

For a list of all members of this type, see WebSpellCheckerTextSuggestionCollection members.

Public Properties

 | Name | Description
Public Property | All | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

Protected Properties

 | Name | Description
Protected Property | Items | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Top

See Also

Reference

WebSpellCheckerTextSuggestionCollection Class
ISNet.WebUI.WebTextEditor Namespace


Add Method

[image]
Intersoft WebTextEditor Documentation
Add Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerTextSuggestionCollection Class : Add Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Sub Add( _
   ByVal item As ISNet.WebUI.INamedObject2 _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerTextSuggestionCollection
Dim item As ISNet.WebUI.INamedObject2

instance.Add(item)
C#
[__DynamicallyInvokableAttribute()]
public void Add(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public procedure Add(
    item: ISNet.WebUI.INamedObject2
);
JScript
__DynamicallyInvokableAttribute()
public function Add(
   item : ISNet.WebUI.INamedObject2
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void Add(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void Add(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerTextSuggestionCollection Class
WebSpellCheckerTextSuggestionCollection Members


All Property

[image]
Intersoft WebTextEditor Documentation
All Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerTextSuggestionCollection Class : All Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public ReadOnly Property All As ISNet.WebUI.INamedObject2()
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerTextSuggestionCollection
Dim value() As ISNet.WebUI.INamedObject2

value = instance.All
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public ISNet.WebUI.INamedObject2[] All {get;}
Delphi
public read-only property All: ISNet.WebUI.array of INamedObject2;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get All : ISNet.WebUI.INamedObject2[]
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property ISNet.WebUI.INamedObject2*[]* get_All();
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property ISNet.WebUI.array<INamedObject2^>^ All {
   ISNet.WebUI.array<INamedObject2^>^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerTextSuggestionCollection Class
WebSpellCheckerTextSuggestionCollection Members


Clear Method

[image]
Intersoft WebTextEditor Documentation
Clear Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerTextSuggestionCollection Class : Clear Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerTextSuggestionCollection

instance.Clear()
C#
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public void Clear()
Delphi
public procedure Clear();
JScript
__DynamicallyInvokableAttribute()
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function Clear();
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: void Clear();
C++/CLI
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
void Clear();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerTextSuggestionCollection Class
WebSpellCheckerTextSuggestionCollection Members


ClearItems Method

[image]
Intersoft WebTextEditor Documentation
ClearItems Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerTextSuggestionCollection Class : ClearItems Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ClearItems()
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerTextSuggestionCollection

instance.ClearItems()
C#
protected virtual void ClearItems()
Delphi
protected procedure ClearItems(); virtual;
JScript
protected function ClearItems();
Managed Extensions for C++
protected: virtual void ClearItems();
C++/CLI
protected:
virtual void ClearItems();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerTextSuggestionCollection Class
WebSpellCheckerTextSuggestionCollection Members


Contains Method

[image]
Intersoft WebTextEditor Documentation
Contains Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerTextSuggestionCollection Class : Contains Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
<__DynamicallyInvokableAttribute()>
Public Function Contains( _
   ByVal item As ISNet.WebUI.INamedObject2 _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerTextSuggestionCollection
Dim item As ISNet.WebUI.INamedObject2
Dim value As System.Boolean

value = instance.Contains(item)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public System.bool Contains(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public function Contains(
    item: ISNet.WebUI.INamedObject2
): System.Boolean;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
__DynamicallyInvokableAttribute()
public function Contains(
   item : ISNet.WebUI.INamedObject2
) : System.boolean;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public: System.bool Contains(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public:
System.bool Contains(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerTextSuggestionCollection Class
WebSpellCheckerTextSuggestionCollection Members


CopyTo Method

[image]
Intersoft WebTextEditor Documentation
CopyTo Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerTextSuggestionCollection Class : CopyTo Method

array
index

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Sub CopyTo( _
   ByVal array() As ISNet.WebUI.INamedObject2, _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerTextSuggestionCollection
Dim array() As ISNet.WebUI.INamedObject2
Dim index As System.Integer

instance.CopyTo(array, index)
C#
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public void CopyTo(
   ISNet.WebUI.INamedObject2[] array,
   System.int index
)
Delphi
public procedure CopyTo(
    array: ISNet.WebUI.INamedObject2array of;
    index: System.Integer
);
JScript
__DynamicallyInvokableAttribute()
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function CopyTo(
   array : ISNet.WebUI.INamedObject2[],
   index : System.int
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: void CopyTo(
   ISNet.WebUI.INamedObject2*[]* array,
   System.int index
)
C++/CLI
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
void CopyTo(
   ISNet.WebUI.array<INamedObject2^>^ array,
   System.int index
)

Parameters

array
index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerTextSuggestionCollection Class
WebSpellCheckerTextSuggestionCollection Members


Count Property

[image]
Intersoft WebTextEditor Documentation
Count Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerTextSuggestionCollection Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public ReadOnly Property Count As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerTextSuggestionCollection
Dim value As System.Integer

value = instance.Count
C#
[__DynamicallyInvokableAttribute()]
public System.int Count {get;}
Delphi
public read-only property Count: System.Integer;
JScript
__DynamicallyInvokableAttribute()
public function get Count : System.int
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: __property System.int get_Count();
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
property System.int Count {
   System.int get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerTextSuggestionCollection Class
WebSpellCheckerTextSuggestionCollection Members


CreateArray Method

[image]
Intersoft WebTextEditor Documentation
CreateArray Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerTextSuggestionCollection Class : CreateArray Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function CreateArray() As ISNet.WebUI.INamedObject2()
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerTextSuggestionCollection
Dim value() As ISNet.WebUI.INamedObject2

value = instance.CreateArray()
C#
protected ISNet.WebUI.INamedObject2[] CreateArray()
Delphi
protected function CreateArray(): ISNet.WebUI.array of INamedObject2;
JScript
protected function CreateArray() : ISNet.WebUI.INamedObject2[];
Managed Extensions for C++
protected: ISNet.WebUI.INamedObject2*[]* CreateArray();
C++/CLI
protected:
ISNet.WebUI.array<INamedObject2^>^ CreateArray();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerTextSuggestionCollection Class
WebSpellCheckerTextSuggestionCollection Members


CreateNewItem Method

[image]
Intersoft WebTextEditor Documentation
CreateNewItem Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerTextSuggestionCollection Class : CreateNewItem Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CreateNewItem() As WebTextEditorMedia
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerTextSuggestionCollection
Dim value As WebTextEditorMedia

value = instance.CreateNewItem()
C#
public WebTextEditorMedia CreateNewItem()
Delphi
public function CreateNewItem(): WebTextEditorMedia;
JScript
public function CreateNewItem() : WebTextEditorMedia;
Managed Extensions for C++
public: WebTextEditorMedia* CreateNewItem();
C++/CLI
public:
WebTextEditorMedia^ CreateNewItem();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerTextSuggestionCollection Class
WebSpellCheckerTextSuggestionCollection Members


GetEnumerator Method

[image]
Intersoft WebTextEditor Documentation
GetEnumerator Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerTextSuggestionCollection Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Function GetEnumerator() As System.Collections.Generic.IEnumerator(Of INamedObject2)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerTextSuggestionCollection
Dim value As System.Collections.Generic.IEnumerator(Of INamedObject2)

value = instance.GetEnumerator()
C#
[__DynamicallyInvokableAttribute()]
public System.Collections.Generic.IEnumerator<INamedObject2> GetEnumerator()
Delphi
public function GetEnumerator(): System.Collections.Generic.IEnumerator;
JScript
__DynamicallyInvokableAttribute()
public function GetEnumerator() : System.Collections.Generic.IEnumerator;
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: System.Collections.Generic.IEnumerator<INamedObject2*>* GetEnumerator();
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
System.Collections.Generic.IEnumerator<INamedObject2^>^ GetEnumerator();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerTextSuggestionCollection Class
WebSpellCheckerTextSuggestionCollection Members


GetNamedItem Method

[image]
Intersoft WebTextEditor Documentation
GetNamedItem Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerTextSuggestionCollection Class : GetNamedItem Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetNamedItem( _
   ByVal name As System.String _
) As WebTextEditorMedia
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerTextSuggestionCollection
Dim name As System.String
Dim value As WebTextEditorMedia

value = instance.GetNamedItem(name)
C#
public WebTextEditorMedia GetNamedItem(
   System.string name
)
Delphi
public function GetNamedItem(
    name: System.String
): WebTextEditorMedia;
JScript
public function GetNamedItem(
   name : System.String
) : WebTextEditorMedia;
Managed Extensions for C++
public: WebTextEditorMedia* GetNamedItem(
   System.string* name
)
C++/CLI
public:
WebTextEditorMedia^ GetNamedItem(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerTextSuggestionCollection Class
WebSpellCheckerTextSuggestionCollection Members


GetObjectData Method

[image]
Intersoft WebTextEditor Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerTextSuggestionCollection Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerTextSuggestionCollection
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerTextSuggestionCollection Class
WebSpellCheckerTextSuggestionCollection Members


IndexOf Method

[image]
Intersoft WebTextEditor Documentation
IndexOf Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerTextSuggestionCollection Class : IndexOf Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
<__DynamicallyInvokableAttribute()>
Public Function IndexOf( _
   ByVal item As ISNet.WebUI.INamedObject2 _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerTextSuggestionCollection
Dim item As ISNet.WebUI.INamedObject2
Dim value As System.Integer

value = instance.IndexOf(item)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public System.int IndexOf(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public function IndexOf(
    item: ISNet.WebUI.INamedObject2
): System.Integer;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
__DynamicallyInvokableAttribute()
public function IndexOf(
   item : ISNet.WebUI.INamedObject2
) : System.int;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public: System.int IndexOf(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public:
System.int IndexOf(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerTextSuggestionCollection Class
WebSpellCheckerTextSuggestionCollection Members


Insert Method

[image]
Intersoft WebTextEditor Documentation
Insert Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerTextSuggestionCollection Class : Insert Method

index
item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal item As ISNet.WebUI.INamedObject2 _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerTextSuggestionCollection
Dim index As System.Integer
Dim item As ISNet.WebUI.INamedObject2

instance.Insert(index, item)
C#
[__DynamicallyInvokableAttribute()]
public void Insert(
   System.int index,
   ISNet.WebUI.INamedObject2 item
)
Delphi
public procedure Insert(
    index: System.Integer;
    item: ISNet.WebUI.INamedObject2
);
JScript
__DynamicallyInvokableAttribute()
public function Insert(
   index : System.int,
   item : ISNet.WebUI.INamedObject2
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void Insert(
   System.int index,
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void Insert(
   System.int index,
   ISNet.WebUI.INamedObject2^ item
)

Parameters

index
item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerTextSuggestionCollection Class
WebSpellCheckerTextSuggestionCollection Members


InsertItem Method

[image]
Intersoft WebTextEditor Documentation
InsertItem Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerTextSuggestionCollection Class : InsertItem Method

index
item

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub InsertItem( _
   ByVal index As System.Integer, _
   ByVal item As ISNet.WebUI.INamedObject2 _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerTextSuggestionCollection
Dim index As System.Integer
Dim item As ISNet.WebUI.INamedObject2

instance.InsertItem(index, item)
C#
protected virtual void InsertItem(
   System.int index,
   ISNet.WebUI.INamedObject2 item
)
Delphi
protected procedure InsertItem(
    index: System.Integer;
    item: ISNet.WebUI.INamedObject2
); virtual;
JScript
protected function InsertItem(
   index : System.int,
   item : ISNet.WebUI.INamedObject2
);
Managed Extensions for C++
protected: virtual void InsertItem(
   System.int index,
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
protected:
virtual void InsertItem(
   System.int index,
   ISNet.WebUI.INamedObject2^ item
)

Parameters

index
item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerTextSuggestionCollection Class
WebSpellCheckerTextSuggestionCollection Members


Item Property

[image]
Intersoft WebTextEditor Documentation
Item Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerTextSuggestionCollection Class : Item Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Default Property Item( _
   ByVal index As System.Integer _
) As ISNet.WebUI.INamedObject2
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerTextSuggestionCollection
Dim index As System.Integer
Dim value As ISNet.WebUI.INamedObject2

instance.Item(index) = value

value = instance.Item(index)
C#
[__DynamicallyInvokableAttribute()]
public ISNet.WebUI.INamedObject2 this[
   System.int index
]; {get; set;}
Delphi
public  this: : ISNet.WebUI.INamedObject2;[
    index: System.Integer
]; read-write
JScript
__DynamicallyInvokableAttribute()
public  this[
   index : System.int
] get,set : ISNet.WebUI.INamedObject2
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: __property ISNet.WebUI.INamedObject2* get_Item   System.int index
;
public: __property void set_Item   System.int index,
   ISNet.WebUI.INamedObject2* value
;
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
property ISNet.WebUI.INamedObject2^ default [int] {
   ISNet.WebUI.INamedObject2^ get(System.int index);
   void set (System.int index, ISNet.WebUI.INamedObject2^ value);
}

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerTextSuggestionCollection Class
WebSpellCheckerTextSuggestionCollection Members


Items Property

[image]
Intersoft WebTextEditor Documentation
Items Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerTextSuggestionCollection Class : Items Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Protected ReadOnly Property Items As System.Collections.Generic.IList(Of INamedObject2)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerTextSuggestionCollection
Dim value As System.Collections.Generic.IList(Of INamedObject2)

value = instance.Items
C#
[__DynamicallyInvokableAttribute()]
protected System.Collections.Generic.IList<INamedObject2> Items {get;}
Delphi
protected read-only property Items: System.Collections.Generic.IList;
JScript
__DynamicallyInvokableAttribute()
protected function get Items : System.Collections.Generic.IList
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
protected: __property System.Collections.Generic.IList<INamedObject2*>* get_Items();
C++/CLI
[__DynamicallyInvokableAttribute()]
protected:
property System.Collections.Generic.IList<INamedObject2^>^ Items {
   System.Collections.Generic.IList<INamedObject2^>^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerTextSuggestionCollection Class
WebSpellCheckerTextSuggestionCollection Members


Parent Property

[image]
Intersoft WebTextEditor Documentation
Parent Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerTextSuggestionCollection Class : Parent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerTextSuggestionCollection
Dim value As System.Object

value = instance.Parent
C#
public System.object Parent {get;}
Delphi
public read-only property Parent: System.TObject;
JScript
public function get Parent : System.Object
Managed Extensions for C++
public: __property System.Object* get_Parent();
C++/CLI
public:
property System.Object^ Parent {
   System.Object^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerTextSuggestionCollection Class
WebSpellCheckerTextSuggestionCollection Members


Remove Method

[image]
Intersoft WebTextEditor Documentation
Remove Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerTextSuggestionCollection Class : Remove Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Function Remove( _
   ByVal item As ISNet.WebUI.INamedObject2 _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerTextSuggestionCollection
Dim item As ISNet.WebUI.INamedObject2
Dim value As System.Boolean

value = instance.Remove(item)
C#
[__DynamicallyInvokableAttribute()]
public System.bool Remove(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public function Remove(
    item: ISNet.WebUI.INamedObject2
): System.Boolean;
JScript
__DynamicallyInvokableAttribute()
public function Remove(
   item : ISNet.WebUI.INamedObject2
) : System.boolean;
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: System.bool Remove(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
System.bool Remove(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerTextSuggestionCollection Class
WebSpellCheckerTextSuggestionCollection Members


RemoveAt Method

[image]
Intersoft WebTextEditor Documentation
RemoveAt Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerTextSuggestionCollection Class : RemoveAt Method

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerTextSuggestionCollection
Dim index As System.Integer

instance.RemoveAt(index)
C#
[__DynamicallyInvokableAttribute()]
public void RemoveAt(
   System.int index
)
Delphi
public procedure RemoveAt(
    index: System.Integer
);
JScript
__DynamicallyInvokableAttribute()
public function RemoveAt(
   index : System.int
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void RemoveAt(
   System.int index
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void RemoveAt(
   System.int index
)

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerTextSuggestionCollection Class
WebSpellCheckerTextSuggestionCollection Members


RemoveItem Method

[image]
Intersoft WebTextEditor Documentation
RemoveItem Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerTextSuggestionCollection Class : RemoveItem Method

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub RemoveItem( _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerTextSuggestionCollection
Dim index As System.Integer

instance.RemoveItem(index)
C#
protected virtual void RemoveItem(
   System.int index
)
Delphi
protected procedure RemoveItem(
    index: System.Integer
); virtual;
JScript
protected function RemoveItem(
   index : System.int
);
Managed Extensions for C++
protected: virtual void RemoveItem(
   System.int index
)
C++/CLI
protected:
virtual void RemoveItem(
   System.int index
)

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerTextSuggestionCollection Class
WebSpellCheckerTextSuggestionCollection Members


SerializerConstructor Method

[image]
Intersoft WebTextEditor Documentation
SerializerConstructor Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerTextSuggestionCollection Class : SerializerConstructor Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializerConstructor( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerTextSuggestionCollection
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializerConstructor(info, context)
C#
public void SerializerConstructor(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializerConstructor(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializerConstructor(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializerConstructor(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializerConstructor(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerTextSuggestionCollection Class
WebSpellCheckerTextSuggestionCollection Members


SetItem Method

[image]
Intersoft WebTextEditor Documentation
SetItem Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerTextSuggestionCollection Class : SetItem Method

index
item

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub SetItem( _
   ByVal index As System.Integer, _
   ByVal item As ISNet.WebUI.INamedObject2 _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerTextSuggestionCollection
Dim index As System.Integer
Dim item As ISNet.WebUI.INamedObject2

instance.SetItem(index, item)
C#
protected virtual void SetItem(
   System.int index,
   ISNet.WebUI.INamedObject2 item
)
Delphi
protected procedure SetItem(
    index: System.Integer;
    item: ISNet.WebUI.INamedObject2
); virtual;
JScript
protected function SetItem(
   index : System.int,
   item : ISNet.WebUI.INamedObject2
);
Managed Extensions for C++
protected: virtual void SetItem(
   System.int index,
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
protected:
virtual void SetItem(
   System.int index,
   ISNet.WebUI.INamedObject2^ item
)

Parameters

index
item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerTextSuggestionCollection Class
WebSpellCheckerTextSuggestionCollection Members


SetParent Method

[image]
Intersoft WebTextEditor Documentation
SetParent Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerTextSuggestionCollection Class : SetParent Method

parent

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SetParent( _
   ByVal parent As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerTextSuggestionCollection
Dim parent As System.Object

instance.SetParent(parent)
C#
public virtual void SetParent(
   System.object parent
)
Delphi
public procedure SetParent(
    parent: System.TObject
); virtual;
JScript
public function SetParent(
   parent : System.Object
);
Managed Extensions for C++
public: virtual void SetParent(
   System.Object* parent
)
C++/CLI
public:
virtual void SetParent(
   System.Object^ parent
)

Parameters

parent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerTextSuggestionCollection Class
WebSpellCheckerTextSuggestionCollection Members


Clone Method

[image]
Intersoft WebTextEditor Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerTextSuggestion Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerTextSuggestion
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerTextSuggestion Class
WebSpellCheckerTextSuggestion Members


Collection Property

[image]
Intersoft WebTextEditor Documentation
Collection Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerTextSuggestion Class : Collection Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
Public Property Collection As ISNet.WebUI.ISCollectionBase(Of INamedObject2)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerTextSuggestion
Dim value As ISNet.WebUI.ISCollectionBase(Of INamedObject2)

instance.Collection = value

value = instance.Collection
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public ISNet.WebUI.ISCollectionBase<INamedObject2> Collection {get; set;}
Delphi
public read-write property Collection: ISNet.WebUI.ISCollectionBase;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
public function get,set Collection : ISNet.WebUI.ISCollectionBase
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public: __property ISNet.WebUI.ISCollectionBase<INamedObject2*>* get_Collection();
public: __property void set_Collection(
   ISNet.WebUI.ISCollectionBase<INamedObject2*>* value
);
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public:
property ISNet.WebUI.ISCollectionBase<INamedObject2^>^ Collection {
   ISNet.WebUI.ISCollectionBase<INamedObject2^>^ get();
   void set (    ISNet.WebUI.ISCollectionBase<INamedObject2^>^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerTextSuggestion Class
WebSpellCheckerTextSuggestion Members


CopyFrom Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerTextSuggestion Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerTextSuggestion Class
WebSpellCheckerTextSuggestion Members


CopyFrom(Object) Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerTextSuggestion Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerTextSuggestion
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerTextSuggestion Class
WebSpellCheckerTextSuggestion Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerTextSuggestion Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerTextSuggestion
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerTextSuggestion Class
WebSpellCheckerTextSuggestion Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebTextEditor Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerTextSuggestion Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerTextSuggestion
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerTextSuggestion Class
WebSpellCheckerTextSuggestion Members


GetHashCode Method

[image]
Intersoft WebTextEditor Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerTextSuggestion Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerTextSuggestion
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerTextSuggestion Class
WebSpellCheckerTextSuggestion Members


GetPropertyString Method

[image]
Intersoft WebTextEditor Documentation
GetPropertyString Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerTextSuggestion Class : GetPropertyString Method

v

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetPropertyString( _
   ByVal v As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerTextSuggestion
Dim v As System.String
Dim value As System.String

value = instance.GetPropertyString(v)
C#
protected virtual System.string GetPropertyString(
   System.string v
)
Delphi
protected function GetPropertyString(
    v: System.String
): System.String; virtual;
JScript
protected function GetPropertyString(
   v : System.String
) : System.String;
Managed Extensions for C++
protected: virtual System.string* GetPropertyString(
   System.string* v
)
C++/CLI
protected:
virtual System.String^ GetPropertyString(
   System.String^ v
)

Parameters

v

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerTextSuggestion Class
WebSpellCheckerTextSuggestion Members


IsEmpty Method

[image]
Intersoft WebTextEditor Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerTextSuggestion Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerTextSuggestion
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerTextSuggestion Class
WebSpellCheckerTextSuggestion Members


IsInSerializationContext Method

[image]
Intersoft WebTextEditor Documentation
IsInSerializationContext Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerTextSuggestion Class : IsInSerializationContext Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function IsInSerializationContext() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerTextSuggestion
Dim value As System.Boolean

value = instance.IsInSerializationContext()
C#
protected virtual System.bool IsInSerializationContext()
Delphi
protected function IsInSerializationContext(): System.Boolean; virtual;
JScript
protected function IsInSerializationContext() : System.boolean;
Managed Extensions for C++
protected: virtual System.bool IsInSerializationContext();
C++/CLI
protected:
virtual System.bool IsInSerializationContext();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerTextSuggestion Class
WebSpellCheckerTextSuggestion Members


Name Property

[image]
Intersoft WebTextEditor Documentation
Name Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerTextSuggestion Class : Name Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BrowsableAttribute(False)>
Public Overridable Property Name As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerTextSuggestion
Dim value As System.String

instance.Name = value

value = instance.Name
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BrowsableAttribute(false)]
public virtual System.string Name {get; set;}
Delphi
public read-write property Name: System.String; virtual;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BrowsableAttribute()
public function get,set Name : System.String
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BrowsableAttribute(false)]
public: __property virtual System.string* get_Name();
public: __property virtual void set_Name(
   System.string* value
);
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BrowsableAttribute(false)]
public:
virtual property System.String^ Name {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerTextSuggestion Class
WebSpellCheckerTextSuggestion Members


OnItemAdd Method

[image]
Intersoft WebTextEditor Documentation
OnItemAdd Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerTextSuggestion Class : OnItemAdd Method

collection

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnItemAdd( _
   ByVal collection As ISNet.WebUI.ISCollectionBase(Of INamedObject2) _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerTextSuggestion
Dim collection As ISNet.WebUI.ISCollectionBase(Of INamedObject2)

instance.OnItemAdd(collection)
C#
protected virtual void OnItemAdd(
   ISNet.WebUI.ISCollectionBase<INamedObject2> collection
)
Delphi
protected procedure OnItemAdd(
    collection: ISNet.WebUI.ISCollectionBase
); virtual;
JScript
protected function OnItemAdd(
   collection : ISNet.WebUI.ISCollectionBase
);
Managed Extensions for C++
protected: virtual void OnItemAdd(
   ISNet.WebUI.ISCollectionBase<INamedObject2*>* collection
)
C++/CLI
protected:
virtual void OnItemAdd(
   ISNet.WebUI.ISCollectionBase<INamedObject2^>^ collection
)

Parameters

collection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerTextSuggestion Class
WebSpellCheckerTextSuggestion Members


OnItemRemove Method

[image]
Intersoft WebTextEditor Documentation
OnItemRemove Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerTextSuggestion Class : OnItemRemove Method

collection

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnItemRemove( _
   ByVal collection As ISNet.WebUI.ISCollectionBase(Of INamedObject2) _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerTextSuggestion
Dim collection As ISNet.WebUI.ISCollectionBase(Of INamedObject2)

instance.OnItemRemove(collection)
C#
protected virtual void OnItemRemove(
   ISNet.WebUI.ISCollectionBase<INamedObject2> collection
)
Delphi
protected procedure OnItemRemove(
    collection: ISNet.WebUI.ISCollectionBase
); virtual;
JScript
protected function OnItemRemove(
   collection : ISNet.WebUI.ISCollectionBase
);
Managed Extensions for C++
protected: virtual void OnItemRemove(
   ISNet.WebUI.ISCollectionBase<INamedObject2*>* collection
)
C++/CLI
protected:
virtual void OnItemRemove(
   ISNet.WebUI.ISCollectionBase<INamedObject2^>^ collection
)

Parameters

collection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerTextSuggestion Class
WebSpellCheckerTextSuggestion Members


Reset Method

[image]
Intersoft WebTextEditor Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerTextSuggestion Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerTextSuggestion

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerTextSuggestion Class
WebSpellCheckerTextSuggestion Members


SerializeObjectData Method

[image]
Intersoft WebTextEditor Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerTextSuggestion Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerTextSuggestion
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerTextSuggestion Class
WebSpellCheckerTextSuggestion Members


ToString Method

[image]
Intersoft WebTextEditor Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellCheckerTextSuggestion Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSpellCheckerTextSuggestion
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellCheckerTextSuggestion Class
WebSpellCheckerTextSuggestion Members


AccessKey Property

[image]
Intersoft WebTextEditor Documentation
AccessKey Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : AccessKey Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overridable Property AccessKey As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.String

instance.AccessKey = value

value = instance.AccessKey
C#
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public virtual System.string AccessKey {get; set;}
Delphi
public read-write property AccessKey: System.String; virtual;
JScript
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set AccessKey : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property virtual System.string* get_AccessKey();
public: __property virtual void set_AccessKey(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
virtual property System.String^ AccessKey {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


Adapter Property

[image]
Intersoft WebTextEditor Documentation
Adapter Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : Adapter Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property Adapter As System.Web.UI.Adapters.ControlAdapter
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Web.UI.Adapters.ControlAdapter

value = instance.Adapter
C#
protected System.Web.UI.Adapters.ControlAdapter Adapter {get;}
Delphi
protected read-only property Adapter: System.Web.UI.Adapters.ControlAdapter;
JScript
protected function get Adapter : System.Web.UI.Adapters.ControlAdapter
Managed Extensions for C++
protected: __property System.Web.UI.Adapters.ControlAdapter* get_Adapter();
C++/CLI
protected:
property System.Web.UI.Adapters.ControlAdapter^ Adapter {
   System.Web.UI.Adapters.ControlAdapter^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


AddAttributesToRender Method

[image]
Intersoft WebTextEditor Documentation
AddAttributesToRender Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : AddAttributesToRender Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub AddAttributesToRender( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim writer As System.Web.UI.HtmlTextWriter

instance.AddAttributesToRender(writer)
C#
protected virtual void AddAttributesToRender(
   System.Web.UI.HtmlTextWriter writer
)
Delphi
protected procedure AddAttributesToRender(
    writer: System.Web.UI.HtmlTextWriter
); virtual;
JScript
protected function AddAttributesToRender(
   writer : System.Web.UI.HtmlTextWriter
);
Managed Extensions for C++
protected: virtual void AddAttributesToRender(
   System.Web.UI.HtmlTextWriter* writer
)
C++/CLI
protected:
virtual void AddAttributesToRender(
   System.Web.UI.HtmlTextWriter^ writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


AddParsedSubObject Method

[image]
Intersoft WebTextEditor Documentation
AddParsedSubObject Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : AddParsedSubObject Method

obj

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Protected Overridable Sub AddParsedSubObject( _
   ByVal obj As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim obj As System.Object

instance.AddParsedSubObject(obj)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
protected virtual void AddParsedSubObject(
   System.object obj
)
Delphi
protected procedure AddParsedSubObject(
    obj: System.TObject
); virtual;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
protected function AddParsedSubObject(
   obj : System.Object
);
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
protected: virtual void AddParsedSubObject(
   System.Object* obj
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
protected:
virtual void AddParsedSubObject(
   System.Object^ obj
)

Parameters

obj

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


ApplyControlTheme Method

[image]
Intersoft WebTextEditor Documentation
ApplyControlTheme Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : ApplyControlTheme Method

themeInfo

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function ApplyControlTheme( _
   ByVal themeInfo As ISNet.WebUI.ThemeInfo _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim themeInfo As ISNet.WebUI.ThemeInfo
Dim value As System.Boolean

value = instance.ApplyControlTheme(themeInfo)
C#
protected virtual System.bool ApplyControlTheme(
   ISNet.WebUI.ThemeInfo themeInfo
)
Delphi
protected function ApplyControlTheme(
    themeInfo: ISNet.WebUI.ThemeInfo
): System.Boolean; virtual;
JScript
protected function ApplyControlTheme(
   themeInfo : ISNet.WebUI.ThemeInfo
) : System.boolean;
Managed Extensions for C++
protected: virtual System.bool ApplyControlTheme(
   ISNet.WebUI.ThemeInfo* themeInfo
)
C++/CLI
protected:
virtual System.bool ApplyControlTheme(
   ISNet.WebUI.ThemeInfo^ themeInfo
)

Parameters

themeInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


ApplyStyle Method

[image]
Intersoft WebTextEditor Documentation
ApplyStyle Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : ApplyStyle Method

s

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ApplyStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim s As System.Web.UI.WebControls.Style

instance.ApplyStyle(s)
C#
public void ApplyStyle(
   System.Web.UI.WebControls.Style s
)
Delphi
public procedure ApplyStyle(
    s: System.Web.UI.WebControls.Style
);
JScript
public function ApplyStyle(
   s : System.Web.UI.WebControls.Style
);
Managed Extensions for C++
public: void ApplyStyle(
   System.Web.UI.WebControls.Style* s
)
C++/CLI
public:
void ApplyStyle(
   System.Web.UI.WebControls.Style^ s
)

Parameters

s

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


ApplyStyleSheetSkin Method

[image]
Intersoft WebTextEditor Documentation
ApplyStyleSheetSkin Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : ApplyStyleSheetSkin Method

page

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Overridable Sub ApplyStyleSheetSkin( _
   ByVal page As System.Web.UI.Page _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim page As System.Web.UI.Page

instance.ApplyStyleSheetSkin(page)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page page
)
Delphi
public procedure ApplyStyleSheetSkin(
    page: System.Web.UI.Page
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function ApplyStyleSheetSkin(
   page : System.Web.UI.Page
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page* page
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page^ page
)

Parameters

page

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


AppRelativeTemplateSourceDirectory Property

[image]
Intersoft WebTextEditor Documentation
AppRelativeTemplateSourceDirectory Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : AppRelativeTemplateSourceDirectory Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<WebSysDescriptionAttribute("The virtual directory of the Page or UserControl that contains this control.")>
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property AppRelativeTemplateSourceDirectory As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.String

instance.AppRelativeTemplateSourceDirectory = value

value = instance.AppRelativeTemplateSourceDirectory
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[WebSysDescriptionAttribute("The virtual directory of the Page or UserControl that contains this control.")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public System.string AppRelativeTemplateSourceDirectory {get; set;}
Delphi
public read-write property AppRelativeTemplateSourceDirectory: System.String;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
WebSysDescriptionAttribute("The virtual directory of the Page or UserControl that contains this control.")
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get,set AppRelativeTemplateSourceDirectory : System.String
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[WebSysDescriptionAttribute("The virtual directory of the Page or UserControl that contains this control.")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property System.string* get_AppRelativeTemplateSourceDirectory();
public: __property void set_AppRelativeTemplateSourceDirectory(
   System.string* value
);
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[WebSysDescriptionAttribute("The virtual directory of the Page or UserControl that contains this control.")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property System.String^ AppRelativeTemplateSourceDirectory {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


AspNetAjaxSettings Property

[image]
Intersoft WebTextEditor Documentation
AspNetAjaxSettings Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : AspNetAjaxSettings Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DefaultValueAttribute()>
Public ReadOnly Property AspNetAjaxSettings As ISNet.WebUI.AspNetAjaxSettings
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As ISNet.WebUI.AspNetAjaxSettings

value = instance.AspNetAjaxSettings
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
public ISNet.WebUI.AspNetAjaxSettings AspNetAjaxSettings {get;}
Delphi
public read-only property AspNetAjaxSettings: ISNet.WebUI.AspNetAjaxSettings;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get AspNetAjaxSettings : ISNet.WebUI.AspNetAjaxSettings
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property ISNet.WebUI.AspNetAjaxSettings* get_AspNetAjaxSettings();
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property ISNet.WebUI.AspNetAjaxSettings^ AspNetAjaxSettings {
   ISNet.WebUI.AspNetAjaxSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


AssignXmlInputHiddenUniqueID Method

[image]
Intersoft WebTextEditor Documentation
AssignXmlInputHiddenUniqueID Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : AssignXmlInputHiddenUniqueID Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub AssignXmlInputHiddenUniqueID()
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker

instance.AssignXmlInputHiddenUniqueID()
C#
protected virtual void AssignXmlInputHiddenUniqueID()
Delphi
protected procedure AssignXmlInputHiddenUniqueID(); virtual;
JScript
protected function AssignXmlInputHiddenUniqueID();
Managed Extensions for C++
protected: virtual void AssignXmlInputHiddenUniqueID();
C++/CLI
protected:
virtual void AssignXmlInputHiddenUniqueID();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


Attributes Property

[image]
Intersoft WebTextEditor Documentation
Attributes Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : Attributes Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Tag attributes of the control.")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
Public ReadOnly Property Attributes As System.Web.UI.AttributeCollection
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Web.UI.AttributeCollection

value = instance.Attributes
C#
[WebSysDescriptionAttribute("Tag attributes of the control.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public System.Web.UI.AttributeCollection Attributes {get;}
Delphi
public read-only property Attributes: System.Web.UI.AttributeCollection;
JScript
WebSysDescriptionAttribute("Tag attributes of the control.")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
public function get Attributes : System.Web.UI.AttributeCollection
Managed Extensions for C++
[WebSysDescriptionAttribute("Tag attributes of the control.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public: __property System.Web.UI.AttributeCollection* get_Attributes();
C++/CLI
[WebSysDescriptionAttribute("Tag attributes of the control.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public:
property System.Web.UI.AttributeCollection^ Attributes {
   System.Web.UI.AttributeCollection^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


BuildProfileTree Method

[image]
Intersoft WebTextEditor Documentation
BuildProfileTree Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : BuildProfileTree Method

parentId
calcViewState

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Sub BuildProfileTree( _
   ByVal parentId As System.String, _
   ByVal calcViewState As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim parentId As System.String
Dim calcViewState As System.Boolean

instance.BuildProfileTree(parentId, calcViewState)
C#
protected void BuildProfileTree(
   System.string parentId,
   System.bool calcViewState
)
Delphi
protected procedure BuildProfileTree(
    parentId: System.String;
    calcViewState: System.Boolean
);
JScript
protected function BuildProfileTree(
   parentId : System.String,
   calcViewState : System.boolean
);
Managed Extensions for C++
protected: void BuildProfileTree(
   System.string* parentId,
   System.bool calcViewState
)
C++/CLI
protected:
void BuildProfileTree(
   System.String^ parentId,
   System.bool calcViewState
)

Parameters

parentId
calcViewState

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


CanUseWebResources Method

[image]
Intersoft WebTextEditor Documentation
CanUseWebResources Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : CanUseWebResources Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CanUseWebResources() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Boolean

value = instance.CanUseWebResources()
C#
public System.bool CanUseWebResources()
Delphi
public function CanUseWebResources(): System.Boolean;
JScript
public function CanUseWebResources() : System.boolean;
Managed Extensions for C++
public: System.bool CanUseWebResources();
C++/CLI
public:
System.bool CanUseWebResources();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


ChildControlsCreated Property

[image]
Intersoft WebTextEditor Documentation
ChildControlsCreated Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : ChildControlsCreated Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Property ChildControlsCreated As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Boolean

instance.ChildControlsCreated = value

value = instance.ChildControlsCreated
C#
protected System.bool ChildControlsCreated {get; set;}
Delphi
protected read-write property ChildControlsCreated: System.Boolean;
JScript
protected function get,set ChildControlsCreated : System.boolean
Managed Extensions for C++
protected: __property System.bool get_ChildControlsCreated();
protected: __property void set_ChildControlsCreated(
   System.bool value
);
C++/CLI
protected:
property System.bool ChildControlsCreated {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


ClearCachedClientID Method

[image]
Intersoft WebTextEditor Documentation
ClearCachedClientID Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : ClearCachedClientID Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Sub ClearCachedClientID()
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker

instance.ClearCachedClientID()
C#
protected void ClearCachedClientID()
Delphi
protected procedure ClearCachedClientID();
JScript
protected function ClearCachedClientID();
Managed Extensions for C++
protected: void ClearCachedClientID();
C++/CLI
protected:
void ClearCachedClientID();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


ClearChildControlState Method

[image]
Intersoft WebTextEditor Documentation
ClearChildControlState Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : ClearChildControlState Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Sub ClearChildControlState()
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker

instance.ClearChildControlState()
C#
protected void ClearChildControlState()
Delphi
protected procedure ClearChildControlState();
JScript
protected function ClearChildControlState();
Managed Extensions for C++
protected: void ClearChildControlState();
C++/CLI
protected:
void ClearChildControlState();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


ClearChildState Method

[image]
Intersoft WebTextEditor Documentation
ClearChildState Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : ClearChildState Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Sub ClearChildState()
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker

instance.ClearChildState()
C#
protected void ClearChildState()
Delphi
protected procedure ClearChildState();
JScript
protected function ClearChildState();
Managed Extensions for C++
protected: void ClearChildState();
C++/CLI
protected:
void ClearChildState();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


ClearChildViewState Method

[image]
Intersoft WebTextEditor Documentation
ClearChildViewState Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : ClearChildViewState Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Sub ClearChildViewState()
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker

instance.ClearChildViewState()
C#
protected void ClearChildViewState()
Delphi
protected procedure ClearChildViewState();
JScript
protected function ClearChildViewState();
Managed Extensions for C++
protected: void ClearChildViewState();
C++/CLI
protected:
void ClearChildViewState();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


ClearEffectiveClientIDMode Method

[image]
Intersoft WebTextEditor Documentation
ClearEffectiveClientIDMode Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : ClearEffectiveClientIDMode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Sub ClearEffectiveClientIDMode()
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker

instance.ClearEffectiveClientIDMode()
C#
protected void ClearEffectiveClientIDMode()
Delphi
protected procedure ClearEffectiveClientIDMode();
JScript
protected function ClearEffectiveClientIDMode();
Managed Extensions for C++
protected: void ClearEffectiveClientIDMode();
C++/CLI
protected:
void ClearEffectiveClientIDMode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


ClientID Property

[image]
Intersoft WebTextEditor Documentation
ClientID Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : ClientID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<WebSysDescriptionAttribute("The ID of the control that is rendered for the client.")>
Public Overridable ReadOnly Property ClientID As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.String

value = instance.ClientID
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[WebSysDescriptionAttribute("The ID of the control that is rendered for the client.")]
public virtual System.string ClientID {get;}
Delphi
public read-only property ClientID: System.String; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
WebSysDescriptionAttribute("The ID of the control that is rendered for the client.")
public function get ClientID : System.String
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[WebSysDescriptionAttribute("The ID of the control that is rendered for the client.")]
public: __property virtual System.string* get_ClientID();
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[WebSysDescriptionAttribute("The ID of the control that is rendered for the client.")]
public:
virtual property System.String^ ClientID {
   System.String^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


ClientIDMode Property

[image]
Intersoft WebTextEditor Documentation
ClientIDMode Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : ClientIDMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.ThemeableAttribute(False)>
<WebCategoryAttribute("Behavior")>
<System.ComponentModel.DefaultValueAttribute()>
<WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")>
Public Overridable Property ClientIDMode As System.Web.UI.ClientIDMode
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Web.UI.ClientIDMode

instance.ClientIDMode = value

value = instance.ClientIDMode
C#
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")]
public virtual System.Web.UI.ClientIDMode ClientIDMode {get; set;}
Delphi
public read-write property ClientIDMode: System.Web.UI.ClientIDMode; virtual;
JScript
System.Web.UI.ThemeableAttribute()
WebCategoryAttribute("Behavior")
System.ComponentModel.DefaultValueAttribute()
WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")
public function get,set ClientIDMode : System.Web.UI.ClientIDMode
Managed Extensions for C++
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")]
public: __property virtual System.Web.UI.ClientIDMode get_ClientIDMode();
public: __property virtual void set_ClientIDMode(
   System.Web.UI.ClientIDMode value
);
C++/CLI
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")]
public:
virtual property System.Web.UI.ClientIDMode ClientIDMode {
   System.Web.UI.ClientIDMode get();
   void set (    System.Web.UI.ClientIDMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


ClientIDSeparator Property

[image]
Intersoft WebTextEditor Documentation
ClientIDSeparator Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : ClientIDSeparator Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property ClientIDSeparator As System.Char
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Char

value = instance.ClientIDSeparator
C#
protected System.char ClientIDSeparator {get;}
Delphi
protected read-only property ClientIDSeparator: System.Char;
JScript
protected function get ClientIDSeparator : System.char
Managed Extensions for C++
protected: __property System.char get_ClientIDSeparator();
C++/CLI
protected:
property System.char ClientIDSeparator {
   System.char get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


Clone Method

[image]
Intersoft WebTextEditor Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


ControlDataTransferFormat Property

[image]
Intersoft WebTextEditor Documentation
ControlDataTransferFormat Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : ControlDataTransferFormat Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines the format used to exchange the control's data across client and server.")>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Overridable Property ControlDataTransferFormat As ISNet.WebUI.DataTransferFormat
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As ISNet.WebUI.DataTransferFormat

instance.ControlDataTransferFormat = value

value = instance.ControlDataTransferFormat
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines the format used to exchange the control's data across client and server.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
public virtual ISNet.WebUI.DataTransferFormat ControlDataTransferFormat {get; set;}
Delphi
public read-write property ControlDataTransferFormat: ISNet.WebUI.DataTransferFormat; virtual;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines the format used to exchange the control's data across client and server.")
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set ControlDataTransferFormat : ISNet.WebUI.DataTransferFormat
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines the format used to exchange the control's data across client and server.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property virtual ISNet.WebUI.DataTransferFormat get_ControlDataTransferFormat();
public: __property virtual void set_ControlDataTransferFormat(
   ISNet.WebUI.DataTransferFormat value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines the format used to exchange the control's data across client and server.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
virtual property ISNet.WebUI.DataTransferFormat ControlDataTransferFormat {
   ISNet.WebUI.DataTransferFormat get();
   void set (    ISNet.WebUI.DataTransferFormat value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


ControlRequestHandler Method

[image]
Intersoft WebTextEditor Documentation
ControlRequestHandler Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : ControlRequestHandler Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Sub ControlRequestHandler()
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker

instance.ControlRequestHandler()
C#
protected void ControlRequestHandler()
Delphi
protected procedure ControlRequestHandler();
JScript
protected function ControlRequestHandler();
Managed Extensions for C++
protected: void ControlRequestHandler();
C++/CLI
protected:
void ControlRequestHandler();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


Controls Property

[image]
Intersoft WebTextEditor Documentation
Controls Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : Controls Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("The collection of child controls owned by the control.")>
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Overridable ReadOnly Property Controls As System.Web.UI.ControlCollection
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Web.UI.ControlCollection

value = instance.Controls
C#
[WebSysDescriptionAttribute("The collection of child controls owned by the control.")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public virtual System.Web.UI.ControlCollection Controls {get;}
Delphi
public read-only property Controls: System.Web.UI.ControlCollection; virtual;
JScript
WebSysDescriptionAttribute("The collection of child controls owned by the control.")
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get Controls : System.Web.UI.ControlCollection
Managed Extensions for C++
[WebSysDescriptionAttribute("The collection of child controls owned by the control.")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property virtual System.Web.UI.ControlCollection* get_Controls();
C++/CLI
[WebSysDescriptionAttribute("The collection of child controls owned by the control.")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
virtual property System.Web.UI.ControlCollection^ Controls {
   System.Web.UI.ControlCollection^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


ControlStyle Property

[image]
Intersoft WebTextEditor Documentation
ControlStyle Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : ControlStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("The style associated with the control.")>
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public ReadOnly Property ControlStyle As System.Web.UI.WebControls.Style
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Web.UI.WebControls.Style

value = instance.ControlStyle
C#
[WebSysDescriptionAttribute("The style associated with the control.")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public System.Web.UI.WebControls.Style ControlStyle {get;}
Delphi
public read-only property ControlStyle: System.Web.UI.WebControls.Style;
JScript
WebSysDescriptionAttribute("The style associated with the control.")
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get ControlStyle : System.Web.UI.WebControls.Style
Managed Extensions for C++
[WebSysDescriptionAttribute("The style associated with the control.")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property System.Web.UI.WebControls.Style* get_ControlStyle();
C++/CLI
[WebSysDescriptionAttribute("The style associated with the control.")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property System.Web.UI.WebControls.Style^ ControlStyle {
   System.Web.UI.WebControls.Style^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


ControlStyleCreated Property

[image]
Intersoft WebTextEditor Documentation
ControlStyleCreated Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : ControlStyleCreated Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
<WebSysDescriptionAttribute("Whether the style associated with the control has been created.")>
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public ReadOnly Property ControlStyleCreated As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Boolean

value = instance.ControlStyleCreated
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[WebSysDescriptionAttribute("Whether the style associated with the control has been created.")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public System.bool ControlStyleCreated {get;}
Delphi
public read-only property ControlStyleCreated: System.Boolean;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
WebSysDescriptionAttribute("Whether the style associated with the control has been created.")
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function get ControlStyleCreated : System.boolean
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[WebSysDescriptionAttribute("Whether the style associated with the control has been created.")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: __property System.bool get_ControlStyleCreated();
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[WebSysDescriptionAttribute("Whether the style associated with the control has been created.")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
property System.bool ControlStyleCreated {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


CopyBaseAttributes Method

[image]
Intersoft WebTextEditor Documentation
CopyBaseAttributes Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : CopyBaseAttributes Method

controlSrc

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CopyBaseAttributes( _
   ByVal controlSrc As System.Web.UI.WebControls.WebControl _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim controlSrc As System.Web.UI.WebControls.WebControl

instance.CopyBaseAttributes(controlSrc)
C#
public void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl controlSrc
)
Delphi
public procedure CopyBaseAttributes(
    controlSrc: System.Web.UI.WebControls.WebControl
);
JScript
public function CopyBaseAttributes(
   controlSrc : System.Web.UI.WebControls.WebControl
);
Managed Extensions for C++
public: void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl* controlSrc
)
C++/CLI
public:
void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl^ controlSrc
)

Parameters

controlSrc

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


CopyFrom Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.ISNetControl)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


CopyFrom(Object) Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members
Overload List


CreateControlCollection Method

[image]
Intersoft WebTextEditor Documentation
CreateControlCollection Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : CreateControlCollection Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function CreateControlCollection() As System.Web.UI.ControlCollection
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Web.UI.ControlCollection

value = instance.CreateControlCollection()
C#
protected virtual System.Web.UI.ControlCollection CreateControlCollection()
Delphi
protected function CreateControlCollection(): System.Web.UI.ControlCollection; virtual;
JScript
protected function CreateControlCollection() : System.Web.UI.ControlCollection;
Managed Extensions for C++
protected: virtual System.Web.UI.ControlCollection* CreateControlCollection();
C++/CLI
protected:
virtual System.Web.UI.ControlCollection^ CreateControlCollection();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


CreateControlStyle Method

[image]
Intersoft WebTextEditor Documentation
CreateControlStyle Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : CreateControlStyle Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function CreateControlStyle() As System.Web.UI.WebControls.Style
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Web.UI.WebControls.Style

value = instance.CreateControlStyle()
C#
protected virtual System.Web.UI.WebControls.Style CreateControlStyle()
Delphi
protected function CreateControlStyle(): System.Web.UI.WebControls.Style; virtual;
JScript
protected function CreateControlStyle() : System.Web.UI.WebControls.Style;
Managed Extensions for C++
protected: virtual System.Web.UI.WebControls.Style* CreateControlStyle();
C++/CLI
protected:
virtual System.Web.UI.WebControls.Style^ CreateControlStyle();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


CreateThemeInfo Method

[image]
Intersoft WebTextEditor Documentation
CreateThemeInfo Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : CreateThemeInfo Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function CreateThemeInfo() As ISNet.WebUI.ThemeInfo
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As ISNet.WebUI.ThemeInfo

value = instance.CreateThemeInfo()
C#
protected virtual ISNet.WebUI.ThemeInfo CreateThemeInfo()
Delphi
protected function CreateThemeInfo(): ISNet.WebUI.ThemeInfo; virtual;
JScript
protected function CreateThemeInfo() : ISNet.WebUI.ThemeInfo;
Managed Extensions for C++
protected: virtual ISNet.WebUI.ThemeInfo* CreateThemeInfo();
C++/CLI
protected:
virtual ISNet.WebUI.ThemeInfo^ CreateThemeInfo();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


DataBind Method

[image]
Intersoft WebTextEditor Documentation
DataBind Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : DataBind Method

Glossary Item Box

Overload List

Overload | Description
DataBind() | (Inherited from System.Web.UI.Control)
DataBind(Boolean) | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


DataBind() Method

[image]
Intersoft WebTextEditor Documentation
DataBind() Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class > DataBind Method : DataBind() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Overridable Sub DataBind()
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker

instance.DataBind()
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public virtual void DataBind()
Delphi
public procedure DataBind(); virtual;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function DataBind();
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: virtual void DataBind();
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
virtual void DataBind();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members
Overload List


DataBind(Boolean) Method

[image]
Intersoft WebTextEditor Documentation
DataBind(Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class > DataBind Method : DataBind(Boolean) Method

raiseOnDataBinding

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overloads Overridable Sub DataBind( _
   ByVal raiseOnDataBinding As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim raiseOnDataBinding As System.Boolean

instance.DataBind(raiseOnDataBinding)
C#
protected virtual void DataBind(
   System.bool raiseOnDataBinding
)
Delphi
protected procedure DataBind(
    raiseOnDataBinding: System.Boolean
); virtual;
JScript
protected function DataBind(
   raiseOnDataBinding : System.boolean
);
Managed Extensions for C++
protected: virtual void DataBind(
   System.bool raiseOnDataBinding
)
C++/CLI
protected:
virtual void DataBind(
   System.bool raiseOnDataBinding
)

Parameters

raiseOnDataBinding

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members
Overload List


DataBindChildren Method

[image]
Intersoft WebTextEditor Documentation
DataBindChildren Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : DataBindChildren Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub DataBindChildren()
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker

instance.DataBindChildren()
C#
protected virtual void DataBindChildren()
Delphi
protected procedure DataBindChildren(); virtual;
JScript
protected function DataBindChildren();
Managed Extensions for C++
protected: virtual void DataBindChildren();
C++/CLI
protected:
virtual void DataBindChildren();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


DataBinding Event

[image]
Intersoft WebTextEditor Documentation
DataBinding Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : DataBinding Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the control's data binding expressions are to be evaluated.")>
<WebCategoryAttribute("Data")>
Public Event DataBinding As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim handler As System.EventHandler

AddHandler instance.DataBinding, handler
C#
[WebSysDescriptionAttribute("Fires when the control's data binding expressions are to be evaluated.")]
[WebCategoryAttribute("Data")]
public event System.EventHandler DataBinding
Delphi
public event DataBinding: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the control's data binding expressions are to be evaluated.")]
[WebCategoryAttribute("Data")]
public: __event System.EventHandler* DataBinding
C++/CLI
[WebSysDescriptionAttribute("Fires when the control's data binding expressions are to be evaluated.")]
[WebCategoryAttribute("Data")]
public:
event System.EventHandler^ DataBinding

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


DecodeRequest Method

[image]
Intersoft WebTextEditor Documentation
DecodeRequest Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : DecodeRequest Method

request

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function DecodeRequest( _
   ByVal request As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim request As System.String
Dim value As System.String

value = instance.DecodeRequest(request)
C#
protected System.string DecodeRequest(
   System.string request
)
Delphi
protected function DecodeRequest(
    request: System.String
): System.String;
JScript
protected function DecodeRequest(
   request : System.String
) : System.String;
Managed Extensions for C++
protected: System.string* DecodeRequest(
   System.string* request
)
C++/CLI
protected:
System.String^ DecodeRequest(
   System.String^ request
)

Parameters

request

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


DeSerializeObjectData Method

[image]
Intersoft WebTextEditor Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


Dispose Method

[image]
Intersoft WebTextEditor Documentation
Dispose Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : Dispose Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker

instance.Dispose()
C#
public virtual void Dispose()
Delphi
public procedure Dispose(); virtual;
JScript
public function Dispose();
Managed Extensions for C++
public: virtual void Dispose();
C++/CLI
public:
virtual void Dispose();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


Disposed Event

[image]
Intersoft WebTextEditor Documentation
Disposed Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : Disposed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the control has been disposed.")>
Public Event Disposed As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim handler As System.EventHandler

AddHandler instance.Disposed, handler
C#
[WebSysDescriptionAttribute("Fires when the control has been disposed.")]
public event System.EventHandler Disposed
Delphi
public event Disposed: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the control has been disposed.")]
public: __event System.EventHandler* Disposed
C++/CLI
[WebSysDescriptionAttribute("Fires when the control has been disposed.")]
public:
event System.EventHandler^ Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


Enabled Property

[image]
Intersoft WebTextEditor Documentation
Enabled Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : Enabled Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Overridable Property Enabled As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Boolean

instance.Enabled = value

value = instance.Enabled
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public virtual System.bool Enabled {get; set;}
Delphi
public read-write property Enabled: System.Boolean; virtual;
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set Enabled : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property virtual System.bool get_Enabled();
public: __property virtual void set_Enabled(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
virtual property System.bool Enabled {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


EnableManagedTheming Property

[image]
Intersoft WebTextEditor Documentation
EnableManagedTheming Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : EnableManagedTheming Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Overridable Property EnableManagedTheming As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Boolean

instance.EnableManagedTheming = value

value = instance.EnableManagedTheming
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public virtual System.bool EnableManagedTheming {get; set;}
Delphi
public read-write property EnableManagedTheming: System.Boolean; virtual;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set EnableManagedTheming : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property virtual System.bool get_EnableManagedTheming();
public: __property virtual void set_EnableManagedTheming(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
virtual property System.bool EnableManagedTheming {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


EnableTheming Property

[image]
Intersoft WebTextEditor Documentation
EnableTheming Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : EnableTheming Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(True)>
Public Overridable Property EnableTheming As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Boolean

instance.EnableTheming = value

value = instance.EnableTheming
C#
[System.ComponentModel.BrowsableAttribute(true)]
public virtual System.bool EnableTheming {get; set;}
Delphi
public read-write property EnableTheming: System.Boolean; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
public function get,set EnableTheming : System.boolean
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(true)]
public: __property virtual System.bool get_EnableTheming();
public: __property virtual void set_EnableTheming(
   System.bool value
);
C++/CLI
[System.ComponentModel.BrowsableAttribute(true)]
public:
virtual property System.bool EnableTheming {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


EnableViewState Property

[image]
Intersoft WebTextEditor Documentation
EnableViewState Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : EnableViewState Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overridable Property EnableViewState As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Boolean

instance.EnableViewState = value

value = instance.EnableViewState
C#
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public virtual System.bool EnableViewState {get; set;}
Delphi
public read-write property EnableViewState: System.Boolean; virtual;
JScript
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set EnableViewState : System.boolean
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property virtual System.bool get_EnableViewState();
public: __property virtual void set_EnableViewState(
   System.bool value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
virtual property System.bool EnableViewState {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


EnableWebResources Property

[image]
Intersoft WebTextEditor Documentation
EnableWebResources Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : EnableWebResources Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). See help for more information and remarks.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Web Resources")>
Public Property EnableWebResources As ISNet.WebUI.WebResourceType
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As ISNet.WebUI.WebResourceType

instance.EnableWebResources = value

value = instance.EnableWebResources
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). See help for more information and remarks.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Web Resources")]
public ISNet.WebUI.WebResourceType EnableWebResources {get; set;}
Delphi
public read-write property EnableWebResources: ISNet.WebUI.WebResourceType;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). See help for more information and remarks.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Web Resources")
public function get,set EnableWebResources : ISNet.WebUI.WebResourceType
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). See help for more information and remarks.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Web Resources")]
public: __property ISNet.WebUI.WebResourceType get_EnableWebResources();
public: __property void set_EnableWebResources(
   ISNet.WebUI.WebResourceType value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). See help for more information and remarks.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Web Resources")]
public:
property ISNet.WebUI.WebResourceType EnableWebResources {
   ISNet.WebUI.WebResourceType get();
   void set (    ISNet.WebUI.WebResourceType value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


EnsureChildControls Method

[image]
Intersoft WebTextEditor Documentation
EnsureChildControls Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : EnsureChildControls Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub EnsureChildControls()
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker

instance.EnsureChildControls()
C#
protected virtual void EnsureChildControls()
Delphi
protected procedure EnsureChildControls(); virtual;
JScript
protected function EnsureChildControls();
Managed Extensions for C++
protected: virtual void EnsureChildControls();
C++/CLI
protected:
virtual void EnsureChildControls();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


EnsureID Method

[image]
Intersoft WebTextEditor Documentation
EnsureID Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : EnsureID Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Sub EnsureID()
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker

instance.EnsureID()
C#
protected void EnsureID()
Delphi
protected procedure EnsureID();
JScript
protected function EnsureID();
Managed Extensions for C++
protected: void EnsureID();
C++/CLI
protected:
void EnsureID();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


Events Property

[image]
Intersoft WebTextEditor Documentation
Events Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : Events Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property Events As System.ComponentModel.EventHandlerList
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.ComponentModel.EventHandlerList

value = instance.Events
C#
protected System.ComponentModel.EventHandlerList Events {get;}
Delphi
protected read-only property Events: System.ComponentModel.EventHandlerList;
JScript
protected function get Events : System.ComponentModel.EventHandlerList
Managed Extensions for C++
protected: __property System.ComponentModel.EventHandlerList* get_Events();
C++/CLI
protected:
property System.ComponentModel.EventHandlerList^ Events {
   System.ComponentModel.EventHandlerList^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


FindControl Method

[image]
Intersoft WebTextEditor Documentation
FindControl Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : FindControl Method

Glossary Item Box

Overload List

Overload | Description
FindControl(String) | (Inherited from ISNet.WebUI.ISNetControl)
FindControl(String,Int32) | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


FindControl(String) Method

[image]
Intersoft WebTextEditor Documentation
FindControl(String) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class > FindControl Method : FindControl(String) Method

id

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function FindControl( _
   ByVal id As System.String _
) As System.Web.UI.Control
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim id As System.String
Dim value As System.Web.UI.Control

value = instance.FindControl(id)
C#
public virtual System.Web.UI.Control FindControl(
   System.string id
)
Delphi
public function FindControl(
    id: System.String
): System.Web.UI.Control; virtual;
JScript
public function FindControl(
   id : System.String
) : System.Web.UI.Control;
Managed Extensions for C++
public: virtual System.Web.UI.Control* FindControl(
   System.string* id
)
C++/CLI
public:
virtual System.Web.UI.Control^ FindControl(
   System.String^ id
)

Parameters

id

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members
Overload List


FindControl(String,Int32) Method

[image]
Intersoft WebTextEditor Documentation
FindControl(String,Int32) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class > FindControl Method : FindControl(String,Int32) Method

id
pathOffset

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overloads Overridable Function FindControl( _
   ByVal id As System.String, _
   ByVal pathOffset As System.Integer _
) As System.Web.UI.Control
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim id As System.String
Dim pathOffset As System.Integer
Dim value As System.Web.UI.Control

value = instance.FindControl(id, pathOffset)
C#
protected virtual System.Web.UI.Control FindControl(
   System.string id,
   System.int pathOffset
)
Delphi
protected function FindControl(
    id: System.String;
    pathOffset: System.Integer
): System.Web.UI.Control; virtual;
JScript
protected function FindControl(
   id : System.String,
   pathOffset : System.int
) : System.Web.UI.Control;
Managed Extensions for C++
protected: virtual System.Web.UI.Control* FindControl(
   System.string* id,
   System.int pathOffset
)
C++/CLI
protected:
virtual System.Web.UI.Control^ FindControl(
   System.String^ id,
   System.int pathOffset
)

Parameters

id
pathOffset

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members
Overload List


Focus Method

[image]
Intersoft WebTextEditor Documentation
Focus Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : Focus Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Focus()
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker

instance.Focus()
C#
public virtual void Focus()
Delphi
public procedure Focus(); virtual;
JScript
public function Focus();
Managed Extensions for C++
public: virtual void Focus();
C++/CLI
public:
virtual void Focus();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


ForceDisableXmlCompression Method

[image]
Intersoft WebTextEditor Documentation
ForceDisableXmlCompression Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : ForceDisableXmlCompression Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ForceDisableXmlCompression()
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker

instance.ForceDisableXmlCompression()
C#
public void ForceDisableXmlCompression()
Delphi
public procedure ForceDisableXmlCompression();
JScript
public function ForceDisableXmlCompression();
Managed Extensions for C++
public: void ForceDisableXmlCompression();
C++/CLI
public:
void ForceDisableXmlCompression();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


GetApplicationState Method

[image]
Intersoft WebTextEditor Documentation
GetApplicationState Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : GetApplicationState Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetApplicationState() As System.Web.HttpApplicationState
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Web.HttpApplicationState

value = instance.GetApplicationState()
C#
protected virtual System.Web.HttpApplicationState GetApplicationState()
Delphi
protected function GetApplicationState(): System.Web.HttpApplicationState; virtual;
JScript
protected function GetApplicationState() : System.Web.HttpApplicationState;
Managed Extensions for C++
protected: virtual System.Web.HttpApplicationState* GetApplicationState();
C++/CLI
protected:
virtual System.Web.HttpApplicationState^ GetApplicationState();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


GetCachedAppTheme Method

[image]
Intersoft WebTextEditor Documentation
GetCachedAppTheme Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : GetCachedAppTheme Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function GetCachedAppTheme() As ISNet.WebUI.ThemeInfo
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As ISNet.WebUI.ThemeInfo

value = instance.GetCachedAppTheme()
C#
protected ISNet.WebUI.ThemeInfo GetCachedAppTheme()
Delphi
protected function GetCachedAppTheme(): ISNet.WebUI.ThemeInfo;
JScript
protected function GetCachedAppTheme() : ISNet.WebUI.ThemeInfo;
Managed Extensions for C++
protected: ISNet.WebUI.ThemeInfo* GetCachedAppTheme();
C++/CLI
protected:
ISNet.WebUI.ThemeInfo^ GetCachedAppTheme();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


GetCurrentControlLifeCycle Method

[image]
Intersoft WebTextEditor Documentation
GetCurrentControlLifeCycle Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : GetCurrentControlLifeCycle Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetCurrentControlLifeCycle() As ISNet.WebUI.ControlLifeCycle
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As ISNet.WebUI.ControlLifeCycle

value = instance.GetCurrentControlLifeCycle()
C#
public ISNet.WebUI.ControlLifeCycle GetCurrentControlLifeCycle()
Delphi
public function GetCurrentControlLifeCycle(): ISNet.WebUI.ControlLifeCycle;
JScript
public function GetCurrentControlLifeCycle() : ISNet.WebUI.ControlLifeCycle;
Managed Extensions for C++
public: ISNet.WebUI.ControlLifeCycle GetCurrentControlLifeCycle();
C++/CLI
public:
ISNet.WebUI.ControlLifeCycle GetCurrentControlLifeCycle();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


GetCurrentTheme Method

[image]
Intersoft WebTextEditor Documentation
GetCurrentTheme Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : GetCurrentTheme Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetCurrentTheme() As ISNet.WebUI.ThemeInfo
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As ISNet.WebUI.ThemeInfo

value = instance.GetCurrentTheme()
C#
public ISNet.WebUI.ThemeInfo GetCurrentTheme()
Delphi
public function GetCurrentTheme(): ISNet.WebUI.ThemeInfo;
JScript
public function GetCurrentTheme() : ISNet.WebUI.ThemeInfo;
Managed Extensions for C++
public: ISNet.WebUI.ThemeInfo* GetCurrentTheme();
C++/CLI
public:
ISNet.WebUI.ThemeInfo^ GetCurrentTheme();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


GetDesignModeState Method

[image]
Intersoft WebTextEditor Documentation
GetDesignModeState Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : GetDesignModeState Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.NoFlags,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=False,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=True)>
Protected Overridable Function GetDesignModeState() As System.Collections.IDictionary
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Collections.IDictionary

value = instance.GetDesignModeState()
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.NoFlags,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=true)]
protected virtual System.Collections.IDictionary GetDesignModeState()
Delphi
protected function GetDesignModeState(): System.Collections.IDictionary; virtual;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.NoFlags,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
protected function GetDesignModeState() : System.Collections.IDictionary;
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.NoFlags,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=true)]
protected: virtual System.Collections.IDictionary* GetDesignModeState();
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.NoFlags,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=true)]
protected:
virtual System.Collections.IDictionary^ GetDesignModeState();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


GetFrameworkDataFolder Method

[image]
Intersoft WebTextEditor Documentation
GetFrameworkDataFolder Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : GetFrameworkDataFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkDataFolder() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.String

value = instance.GetFrameworkDataFolder()
C#
public System.string GetFrameworkDataFolder()
Delphi
public function GetFrameworkDataFolder(): System.String;
JScript
public function GetFrameworkDataFolder() : System.String;
Managed Extensions for C++
public: System.string* GetFrameworkDataFolder();
C++/CLI
public:
System.String^ GetFrameworkDataFolder();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


GetFrameworkFolder Method

[image]
Intersoft WebTextEditor Documentation
GetFrameworkFolder Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : GetFrameworkFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkFolder() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.String

value = instance.GetFrameworkFolder()
C#
public System.string GetFrameworkFolder()
Delphi
public function GetFrameworkFolder(): System.String;
JScript
public function GetFrameworkFolder() : System.String;
Managed Extensions for C++
public: System.string* GetFrameworkFolder();
C++/CLI
public:
System.String^ GetFrameworkFolder();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


GetFrameworkVersion Method

[image]
Intersoft WebTextEditor Documentation
GetFrameworkVersion Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : GetFrameworkVersion Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkVersion() As System.Version
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Version

value = instance.GetFrameworkVersion()
C#
public System.Version GetFrameworkVersion()
Delphi
public function GetFrameworkVersion(): System.Version;
JScript
public function GetFrameworkVersion() : System.Version;
Managed Extensions for C++
public: System.Version* GetFrameworkVersion();
C++/CLI
public:
System.Version^ GetFrameworkVersion();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


GetIntersoftFolder Method

[image]
Intersoft WebTextEditor Documentation
GetIntersoftFolder Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : GetIntersoftFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetIntersoftFolder() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.String

value = instance.GetIntersoftFolder()
C#
public System.string GetIntersoftFolder()
Delphi
public function GetIntersoftFolder(): System.String;
JScript
public function GetIntersoftFolder() : System.String;
Managed Extensions for C++
public: System.string* GetIntersoftFolder();
C++/CLI
public:
System.String^ GetIntersoftFolder();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


GetLayoutFolder Method

[image]
Intersoft WebTextEditor Documentation
GetLayoutFolder Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : GetLayoutFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetLayoutFolder() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.String

value = instance.GetLayoutFolder()
C#
public System.string GetLayoutFolder()
Delphi
public function GetLayoutFolder(): System.String;
JScript
public function GetLayoutFolder() : System.String;
Managed Extensions for C++
public: System.string* GetLayoutFolder();
C++/CLI
public:
System.String^ GetLayoutFolder();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


GetPostedXMLData Method

[image]
Intersoft WebTextEditor Documentation
GetPostedXMLData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : GetPostedXMLData Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetPostedXMLData() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.String

value = instance.GetPostedXMLData()
C#
public System.string GetPostedXMLData()
Delphi
public function GetPostedXMLData(): System.String;
JScript
public function GetPostedXMLData() : System.String;
Managed Extensions for C++
public: System.string* GetPostedXMLData();
C++/CLI
public:
System.String^ GetPostedXMLData();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


GetProductInfoKey Method

[image]
Intersoft WebTextEditor Documentation
GetProductInfoKey Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : GetProductInfoKey Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetProductInfoKey() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.String

value = instance.GetProductInfoKey()
C#
public System.string GetProductInfoKey()
Delphi
public function GetProductInfoKey(): System.String;
JScript
public function GetProductInfoKey() : System.String;
Managed Extensions for C++
public: System.string* GetProductInfoKey();
C++/CLI
public:
System.String^ GetProductInfoKey();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


GetProductSimpleName Method

[image]
Intersoft WebTextEditor Documentation
GetProductSimpleName Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : GetProductSimpleName Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetProductSimpleName() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.String

value = instance.GetProductSimpleName()
C#
public System.string GetProductSimpleName()
Delphi
public function GetProductSimpleName(): System.String;
JScript
public function GetProductSimpleName() : System.String;
Managed Extensions for C++
public: System.string* GetProductSimpleName();
C++/CLI
public:
System.String^ GetProductSimpleName();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


GetPropertyString Method

[image]
Intersoft WebTextEditor Documentation
GetPropertyString Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : GetPropertyString Method

v

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetPropertyString( _
   ByVal v As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim v As System.String
Dim value As System.String

value = instance.GetPropertyString(v)
C#
protected virtual System.string GetPropertyString(
   System.string v
)
Delphi
protected function GetPropertyString(
    v: System.String
): System.String; virtual;
JScript
protected function GetPropertyString(
   v : System.String
) : System.String;
Managed Extensions for C++
protected: virtual System.string* GetPropertyString(
   System.string* v
)
C++/CLI
protected:
virtual System.String^ GetPropertyString(
   System.String^ v
)

Parameters

v

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


GetPropertyValue Method

[image]
Intersoft WebTextEditor Documentation
GetPropertyValue Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : GetPropertyValue Method

defValue
propValue
webConfigKey

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetPropertyValue( _
   ByVal defValue As System.String, _
   ByVal propValue As System.String, _
   ByVal webConfigKey As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim defValue As System.String
Dim propValue As System.String
Dim webConfigKey As System.String
Dim value As System.String

value = instance.GetPropertyValue(defValue, propValue, webConfigKey)
C#
public System.string GetPropertyValue(
   System.string defValue,
   System.string propValue,
   System.string webConfigKey
)
Delphi
public function GetPropertyValue(
    defValue: System.String;
    propValue: System.String;
    webConfigKey: System.String
): System.String;
JScript
public function GetPropertyValue(
   defValue : System.String,
   propValue : System.String,
   webConfigKey : System.String
) : System.String;
Managed Extensions for C++
public: System.string* GetPropertyValue(
   System.string* defValue,
   System.string* propValue,
   System.string* webConfigKey
)
C++/CLI
public:
System.String^ GetPropertyValue(
   System.String^ defValue,
   System.String^ propValue,
   System.String^ webConfigKey
)

Parameters

defValue
propValue
webConfigKey

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


GetResourceStream Method

[image]
Intersoft WebTextEditor Documentation
GetResourceStream Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : GetResourceStream Method

resourceUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetResourceStream( _
   ByVal resourceUrl As System.String _
) As System.IO.Stream
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim resourceUrl As System.String
Dim value As System.IO.Stream

value = instance.GetResourceStream(resourceUrl)
C#
public System.IO.Stream GetResourceStream(
   System.string resourceUrl
)
Delphi
public function GetResourceStream(
    resourceUrl: System.String
): System.IO.Stream;
JScript
public function GetResourceStream(
   resourceUrl : System.String
) : System.IO.Stream;
Managed Extensions for C++
public: System.IO.Stream* GetResourceStream(
   System.string* resourceUrl
)
C++/CLI
public:
System.IO.Stream^ GetResourceStream(
   System.String^ resourceUrl
)

Parameters

resourceUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


GetRouteUrl Method

[image]
Intersoft WebTextEditor Documentation
GetRouteUrl Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : GetRouteUrl Method

Glossary Item Box

Overload List

Overload | Description
GetRouteUrl(Object) | (Inherited from System.Web.UI.Control)
GetRouteUrl(String,Object) | (Inherited from System.Web.UI.Control)
GetRouteUrl(RouteValueDictionary) | (Inherited from System.Web.UI.Control)
GetRouteUrl(String,RouteValueDictionary) | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


GetRouteUrl(Object) Method

[image]
Intersoft WebTextEditor Documentation
GetRouteUrl(Object) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class > GetRouteUrl Method : GetRouteUrl(Object) Method

routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As System.Object _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim routeParameters As System.Object
Dim value As System.String

value = instance.GetRouteUrl(routeParameters)
C#
public System.string GetRouteUrl(
   System.object routeParameters
)
Delphi
public function GetRouteUrl(
    routeParameters: System.TObject
): System.String;
JScript
public function GetRouteUrl(
   routeParameters : System.Object
) : System.String;
Managed Extensions for C++
public: System.string* GetRouteUrl(
   System.Object* routeParameters
)
C++/CLI
public:
System.String^ GetRouteUrl(
   System.Object^ routeParameters
)

Parameters

routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members
Overload List


GetRouteUrl(RouteValueDictionary) Method

[image]
Intersoft WebTextEditor Documentation
GetRouteUrl(RouteValueDictionary) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class > GetRouteUrl Method : GetRouteUrl(RouteValueDictionary) Method

routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim routeParameters As System.Web.Routing.RouteValueDictionary
Dim value As System.String

value = instance.GetRouteUrl(routeParameters)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.string GetRouteUrl(
   System.Web.Routing.RouteValueDictionary routeParameters
)
Delphi
public function GetRouteUrl(
    routeParameters: System.Web.Routing.RouteValueDictionary
): System.String;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function GetRouteUrl(
   routeParameters : System.Web.Routing.RouteValueDictionary
) : System.String;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.string* GetRouteUrl(
   System.Web.Routing.RouteValueDictionary* routeParameters
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.String^ GetRouteUrl(
   System.Web.Routing.RouteValueDictionary^ routeParameters
)

Parameters

routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members
Overload List


GetRouteUrl(String,Object) Method

[image]
Intersoft WebTextEditor Documentation
GetRouteUrl(String,Object) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class > GetRouteUrl Method : GetRouteUrl(String,Object) Method

routeName
routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeName As System.String, _
   ByVal routeParameters As System.Object _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim routeName As System.String
Dim routeParameters As System.Object
Dim value As System.String

value = instance.GetRouteUrl(routeName, routeParameters)
C#
public System.string GetRouteUrl(
   System.string routeName,
   System.object routeParameters
)
Delphi
public function GetRouteUrl(
    routeName: System.String;
    routeParameters: System.TObject
): System.String;
JScript
public function GetRouteUrl(
   routeName : System.String,
   routeParameters : System.Object
) : System.String;
Managed Extensions for C++
public: System.string* GetRouteUrl(
   System.string* routeName,
   System.Object* routeParameters
)
C++/CLI
public:
System.String^ GetRouteUrl(
   System.String^ routeName,
   System.Object^ routeParameters
)

Parameters

routeName
routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members
Overload List


GetRouteUrl(String,RouteValueDictionary) Method

[image]
Intersoft WebTextEditor Documentation
GetRouteUrl(String,RouteValueDictionary) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class > GetRouteUrl Method : GetRouteUrl(String,RouteValueDictionary) Method

routeName
routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeName As System.String, _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim routeName As System.String
Dim routeParameters As System.Web.Routing.RouteValueDictionary
Dim value As System.String

value = instance.GetRouteUrl(routeName, routeParameters)
C#
public System.string GetRouteUrl(
   System.string routeName,
   System.Web.Routing.RouteValueDictionary routeParameters
)
Delphi
public function GetRouteUrl(
    routeName: System.String;
    routeParameters: System.Web.Routing.RouteValueDictionary
): System.String;
JScript
public function GetRouteUrl(
   routeName : System.String,
   routeParameters : System.Web.Routing.RouteValueDictionary
) : System.String;
Managed Extensions for C++
public: System.string* GetRouteUrl(
   System.string* routeName,
   System.Web.Routing.RouteValueDictionary* routeParameters
)
C++/CLI
public:
System.String^ GetRouteUrl(
   System.String^ routeName,
   System.Web.Routing.RouteValueDictionary^ routeParameters
)

Parameters

routeName
routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members
Overload List


GetSessionLevelTheme Method

[image]
Intersoft WebTextEditor Documentation
GetSessionLevelTheme Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : GetSessionLevelTheme Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function GetSessionLevelTheme() As ISNet.WebUI.ThemeInfo
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As ISNet.WebUI.ThemeInfo

value = instance.GetSessionLevelTheme()
C#
protected ISNet.WebUI.ThemeInfo GetSessionLevelTheme()
Delphi
protected function GetSessionLevelTheme(): ISNet.WebUI.ThemeInfo;
JScript
protected function GetSessionLevelTheme() : ISNet.WebUI.ThemeInfo;
Managed Extensions for C++
protected: ISNet.WebUI.ThemeInfo* GetSessionLevelTheme();
C++/CLI
protected:
ISNet.WebUI.ThemeInfo^ GetSessionLevelTheme();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


GetUniqueIDRelativeTo Method

[image]
Intersoft WebTextEditor Documentation
GetUniqueIDRelativeTo Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : GetUniqueIDRelativeTo Method

control

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetUniqueIDRelativeTo( _
   ByVal control As System.Web.UI.Control _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim control As System.Web.UI.Control
Dim value As System.String

value = instance.GetUniqueIDRelativeTo(control)
C#
public System.string GetUniqueIDRelativeTo(
   System.Web.UI.Control control
)
Delphi
public function GetUniqueIDRelativeTo(
    control: System.Web.UI.Control
): System.String;
JScript
public function GetUniqueIDRelativeTo(
   control : System.Web.UI.Control
) : System.String;
Managed Extensions for C++
public: System.string* GetUniqueIDRelativeTo(
   System.Web.UI.Control* control
)
C++/CLI
public:
System.String^ GetUniqueIDRelativeTo(
   System.Web.UI.Control^ control
)

Parameters

control

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


HasAttributes Property

[image]
Intersoft WebTextEditor Documentation
HasAttributes Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : HasAttributes Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public ReadOnly Property HasAttributes As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Boolean

value = instance.HasAttributes
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public System.bool HasAttributes {get;}
Delphi
public read-only property HasAttributes: System.Boolean;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get HasAttributes : System.boolean
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property System.bool get_HasAttributes();
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property System.bool HasAttributes {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


HasChildViewState Property

[image]
Intersoft WebTextEditor Documentation
HasChildViewState Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : HasChildViewState Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property HasChildViewState As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Boolean

value = instance.HasChildViewState
C#
protected System.bool HasChildViewState {get;}
Delphi
protected read-only property HasChildViewState: System.Boolean;
JScript
protected function get HasChildViewState : System.boolean
Managed Extensions for C++
protected: __property System.bool get_HasChildViewState();
C++/CLI
protected:
property System.bool HasChildViewState {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


HasControls Method

[image]
Intersoft WebTextEditor Documentation
HasControls Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : HasControls Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function HasControls() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Boolean

value = instance.HasControls()
C#
public virtual System.bool HasControls()
Delphi
public function HasControls(): System.Boolean; virtual;
JScript
public function HasControls() : System.boolean;
Managed Extensions for C++
public: virtual System.bool HasControls();
C++/CLI
public:
virtual System.bool HasControls();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


HasEvents Method

[image]
Intersoft WebTextEditor Documentation
HasEvents Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : HasEvents Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Protected Function HasEvents() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Boolean

value = instance.HasEvents()
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
protected System.bool HasEvents()
Delphi
protected function HasEvents(): System.Boolean;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
protected function HasEvents() : System.boolean;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
protected: System.bool HasEvents();
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
protected:
System.bool HasEvents();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


ID Property

[image]
Intersoft WebTextEditor Documentation
ID Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : ID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.FilterableAttribute(False)>
<System.Web.UI.ThemeableAttribute(False)>
<WebSysDescriptionAttribute("Programmatic name of the control.")>
<System.ComponentModel.ParenthesizePropertyNameAttribute(True)>
<System.ComponentModel.MergablePropertyAttribute(False)>
Public Overridable Property ID As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.String

instance.ID = value

value = instance.ID
C#
[System.Web.UI.FilterableAttribute(false)]
[System.Web.UI.ThemeableAttribute(false)]
[WebSysDescriptionAttribute("Programmatic name of the control.")]
[System.ComponentModel.ParenthesizePropertyNameAttribute(true)]
[System.ComponentModel.MergablePropertyAttribute(false)]
public virtual System.string ID {get; set;}
Delphi
public read-write property ID: System.String; virtual;
JScript
System.Web.UI.FilterableAttribute()
System.Web.UI.ThemeableAttribute()
WebSysDescriptionAttribute("Programmatic name of the control.")
System.ComponentModel.ParenthesizePropertyNameAttribute()
System.ComponentModel.MergablePropertyAttribute()
public function get,set ID : System.String
Managed Extensions for C++
[System.Web.UI.FilterableAttribute(false)]
[System.Web.UI.ThemeableAttribute(false)]
[WebSysDescriptionAttribute("Programmatic name of the control.")]
[System.ComponentModel.ParenthesizePropertyNameAttribute(true)]
[System.ComponentModel.MergablePropertyAttribute(false)]
public: __property virtual System.string* get_ID();
public: __property virtual void set_ID(
   System.string* value
);
C++/CLI
[System.Web.UI.FilterableAttribute(false)]
[System.Web.UI.ThemeableAttribute(false)]
[WebSysDescriptionAttribute("Programmatic name of the control.")]
[System.ComponentModel.ParenthesizePropertyNameAttribute(true)]
[System.ComponentModel.MergablePropertyAttribute(false)]
public:
virtual property System.String^ ID {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


IdSeparator Property

[image]
Intersoft WebTextEditor Documentation
IdSeparator Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : IdSeparator Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property IdSeparator As System.Char
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Char

value = instance.IdSeparator
C#
protected System.char IdSeparator {get;}
Delphi
protected read-only property IdSeparator: System.Char;
JScript
protected function get IdSeparator : System.char
Managed Extensions for C++
protected: __property System.char get_IdSeparator();
C++/CLI
protected:
property System.char IdSeparator {
   System.char get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


Init Event

[image]
Intersoft WebTextEditor Documentation
Init Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : Init Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the page has been initialized.")>
Public Event Init As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim handler As System.EventHandler

AddHandler instance.Init, handler
C#
[WebSysDescriptionAttribute("Fires when the page has been initialized.")]
public event System.EventHandler Init
Delphi
public event Init: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the page has been initialized.")]
public: __event System.EventHandler* Init
C++/CLI
[WebSysDescriptionAttribute("Fires when the page has been initialized.")]
public:
event System.EventHandler^ Init

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


InitializeLayoutBehaviors Method

[image]
Intersoft WebTextEditor Documentation
InitializeLayoutBehaviors Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : InitializeLayoutBehaviors Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub InitializeLayoutBehaviors()
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker

instance.InitializeLayoutBehaviors()
C#
protected virtual void InitializeLayoutBehaviors()
Delphi
protected procedure InitializeLayoutBehaviors(); virtual;
JScript
protected function InitializeLayoutBehaviors();
Managed Extensions for C++
protected: virtual void InitializeLayoutBehaviors();
C++/CLI
protected:
virtual void InitializeLayoutBehaviors();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


InitializeManagedTheming Method

[image]
Intersoft WebTextEditor Documentation
InitializeManagedTheming Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : InitializeManagedTheming Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub InitializeManagedTheming()
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker

instance.InitializeManagedTheming()
C#
protected virtual void InitializeManagedTheming()
Delphi
protected procedure InitializeManagedTheming(); virtual;
JScript
protected function InitializeManagedTheming();
Managed Extensions for C++
protected: virtual void InitializeManagedTheming();
C++/CLI
protected:
virtual void InitializeManagedTheming();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


IsApplicationAvailable Method

[image]
Intersoft WebTextEditor Documentation
IsApplicationAvailable Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : IsApplicationAvailable Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function IsApplicationAvailable() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Boolean

value = instance.IsApplicationAvailable()
C#
protected System.bool IsApplicationAvailable()
Delphi
protected function IsApplicationAvailable(): System.Boolean;
JScript
protected function IsApplicationAvailable() : System.boolean;
Managed Extensions for C++
protected: System.bool IsApplicationAvailable();
C++/CLI
protected:
System.bool IsApplicationAvailable();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


IsAppThemeEnabled Method

[image]
Intersoft WebTextEditor Documentation
IsAppThemeEnabled Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : IsAppThemeEnabled Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function IsAppThemeEnabled() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Boolean

value = instance.IsAppThemeEnabled()
C#
protected virtual System.bool IsAppThemeEnabled()
Delphi
protected function IsAppThemeEnabled(): System.Boolean; virtual;
JScript
protected function IsAppThemeEnabled() : System.boolean;
Managed Extensions for C++
protected: virtual System.bool IsAppThemeEnabled();
C++/CLI
protected:
virtual System.bool IsAppThemeEnabled();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


IsAtlasCallback Method

[image]
Intersoft WebTextEditor Documentation
IsAtlasCallback Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : IsAtlasCallback Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsAtlasCallback() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Boolean

value = instance.IsAtlasCallback()
C#
public System.bool IsAtlasCallback()
Delphi
public function IsAtlasCallback(): System.Boolean;
JScript
public function IsAtlasCallback() : System.boolean;
Managed Extensions for C++
public: System.bool IsAtlasCallback();
C++/CLI
public:
System.bool IsAtlasCallback();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


IsBetaRelease Method

[image]
Intersoft WebTextEditor Documentation
IsBetaRelease Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : IsBetaRelease Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsBetaRelease() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Boolean

value = instance.IsBetaRelease()
C#
public System.bool IsBetaRelease()
Delphi
public function IsBetaRelease(): System.Boolean;
JScript
public function IsBetaRelease() : System.boolean;
Managed Extensions for C++
public: System.bool IsBetaRelease();
C++/CLI
public:
System.bool IsBetaRelease();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


IsChromeBrowser Method

[image]
Intersoft WebTextEditor Documentation
IsChromeBrowser Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : IsChromeBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsChromeBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Boolean

value = instance.IsChromeBrowser()
C#
public System.bool IsChromeBrowser()
Delphi
public function IsChromeBrowser(): System.Boolean;
JScript
public function IsChromeBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsChromeBrowser();
C++/CLI
public:
System.bool IsChromeBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


IsControlThemed Property

[image]
Intersoft WebTextEditor Documentation
IsControlThemed Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : IsControlThemed Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public ReadOnly Property IsControlThemed As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Boolean

value = instance.IsControlThemed
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public System.bool IsControlThemed {get;}
Delphi
public read-only property IsControlThemed: System.Boolean;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get IsControlThemed : System.boolean
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property System.bool get_IsControlThemed();
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property System.bool IsControlThemed {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


IsDesign Property

[image]
Intersoft WebTextEditor Documentation
IsDesign Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : IsDesign Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Overridable ReadOnly Property IsDesign As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Boolean

value = instance.IsDesign
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public virtual System.bool IsDesign {get;}
Delphi
public read-only property IsDesign: System.Boolean; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get IsDesign : System.boolean
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property virtual System.bool get_IsDesign();
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
virtual property System.bool IsDesign {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


IsDynamicCreated Property

[image]
Intersoft WebTextEditor Documentation
IsDynamicCreated Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : IsDynamicCreated Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
Public Property IsDynamicCreated As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Boolean

instance.IsDynamicCreated = value

value = instance.IsDynamicCreated
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public System.bool IsDynamicCreated {get; set;}
Delphi
public read-write property IsDynamicCreated: System.Boolean;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
public function get,set IsDynamicCreated : System.boolean
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public: __property System.bool get_IsDynamicCreated();
public: __property void set_IsDynamicCreated(
   System.bool value
);
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public:
property System.bool IsDynamicCreated {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


IsEmpty Method

[image]
Intersoft WebTextEditor Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


IsFlyPostBackControl Method

[image]
Intersoft WebTextEditor Documentation
IsFlyPostBackControl Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : IsFlyPostBackControl Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsFlyPostBackControl() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Boolean

value = instance.IsFlyPostBackControl()
C#
public virtual System.bool IsFlyPostBackControl()
Delphi
public function IsFlyPostBackControl(): System.Boolean; virtual;
JScript
public function IsFlyPostBackControl() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsFlyPostBackControl();
C++/CLI
public:
virtual System.bool IsFlyPostBackControl();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


IsFlyPostBackRequest Method

[image]
Intersoft WebTextEditor Documentation
IsFlyPostBackRequest Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : IsFlyPostBackRequest Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsFlyPostBackRequest() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Boolean

value = instance.IsFlyPostBackRequest()
C#
public virtual System.bool IsFlyPostBackRequest()
Delphi
public function IsFlyPostBackRequest(): System.Boolean; virtual;
JScript
public function IsFlyPostBackRequest() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsFlyPostBackRequest();
C++/CLI
public:
virtual System.bool IsFlyPostBackRequest();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


IsGeckoBasedBrowser Method

[image]
Intersoft WebTextEditor Documentation
IsGeckoBasedBrowser Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : IsGeckoBasedBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsGeckoBasedBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Boolean

value = instance.IsGeckoBasedBrowser()
C#
public System.bool IsGeckoBasedBrowser()
Delphi
public function IsGeckoBasedBrowser(): System.Boolean;
JScript
public function IsGeckoBasedBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsGeckoBasedBrowser();
C++/CLI
public:
System.bool IsGeckoBasedBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


IsGeckoVersion18 Method

[image]
Intersoft WebTextEditor Documentation
IsGeckoVersion18 Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : IsGeckoVersion18 Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsGeckoVersion18() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Boolean

value = instance.IsGeckoVersion18()
C#
public System.bool IsGeckoVersion18()
Delphi
public function IsGeckoVersion18(): System.Boolean;
JScript
public function IsGeckoVersion18() : System.boolean;
Managed Extensions for C++
public: System.bool IsGeckoVersion18();
C++/CLI
public:
System.bool IsGeckoVersion18();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


IsInDesignMode Method

[image]
Intersoft WebTextEditor Documentation
IsInDesignMode Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : IsInDesignMode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInDesignMode() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Boolean

value = instance.IsInDesignMode()
C#
public System.bool IsInDesignMode()
Delphi
public function IsInDesignMode(): System.Boolean;
JScript
public function IsInDesignMode() : System.boolean;
Managed Extensions for C++
public: System.bool IsInDesignMode();
C++/CLI
public:
System.bool IsInDesignMode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


IsInternalCreated Property

[image]
Intersoft WebTextEditor Documentation
IsInternalCreated Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : IsInternalCreated Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
Public Property IsInternalCreated As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Boolean

instance.IsInternalCreated = value

value = instance.IsInternalCreated
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public System.bool IsInternalCreated {get; set;}
Delphi
public read-write property IsInternalCreated: System.Boolean;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
public function get,set IsInternalCreated : System.boolean
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public: __property System.bool get_IsInternalCreated();
public: __property void set_IsInternalCreated(
   System.bool value
);
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public:
property System.bool IsInternalCreated {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


IsInternetExplorer8Browser Method

[image]
Intersoft WebTextEditor Documentation
IsInternetExplorer8Browser Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : IsInternetExplorer8Browser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInternetExplorer8Browser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Boolean

value = instance.IsInternetExplorer8Browser()
C#
public System.bool IsInternetExplorer8Browser()
Delphi
public function IsInternetExplorer8Browser(): System.Boolean;
JScript
public function IsInternetExplorer8Browser() : System.boolean;
Managed Extensions for C++
public: System.bool IsInternetExplorer8Browser();
C++/CLI
public:
System.bool IsInternetExplorer8Browser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


IsInternetExplorerBrowser Method

[image]
Intersoft WebTextEditor Documentation
IsInternetExplorerBrowser Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : IsInternetExplorerBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInternetExplorerBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Boolean

value = instance.IsInternetExplorerBrowser()
C#
public System.bool IsInternetExplorerBrowser()
Delphi
public function IsInternetExplorerBrowser(): System.Boolean;
JScript
public function IsInternetExplorerBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsInternetExplorerBrowser();
C++/CLI
public:
System.bool IsInternetExplorerBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


IsLiteralContent Method

[image]
Intersoft WebTextEditor Documentation
IsLiteralContent Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : IsLiteralContent Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function IsLiteralContent() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Boolean

value = instance.IsLiteralContent()
C#
protected System.bool IsLiteralContent()
Delphi
protected function IsLiteralContent(): System.Boolean;
JScript
protected function IsLiteralContent() : System.boolean;
Managed Extensions for C++
protected: System.bool IsLiteralContent();
C++/CLI
protected:
System.bool IsLiteralContent();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


IsMvc Property

[image]
Intersoft WebTextEditor Documentation
IsMvc Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : IsMvc Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property IsMvc As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Boolean

value = instance.IsMvc
C#
protected System.bool IsMvc {get;}
Delphi
protected read-only property IsMvc: System.Boolean;
JScript
protected function get IsMvc : System.boolean
Managed Extensions for C++
protected: __property System.bool get_IsMvc();
C++/CLI
protected:
property System.bool IsMvc {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


IsOperaBrowser Method

[image]
Intersoft WebTextEditor Documentation
IsOperaBrowser Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : IsOperaBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsOperaBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Boolean

value = instance.IsOperaBrowser()
C#
public System.bool IsOperaBrowser()
Delphi
public function IsOperaBrowser(): System.Boolean;
JScript
public function IsOperaBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsOperaBrowser();
C++/CLI
public:
System.bool IsOperaBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


isPagePreRender Field

[image]
Intersoft WebTextEditor Documentation
isPagePreRender Field
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : isPagePreRender Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected isPagePreRender As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Boolean

value = instance.isPagePreRender

instance.isPagePreRender = value
C#
protected System.bool isPagePreRender
Delphi
protected field isPagePreRender: System.Boolean;
JScript
protected var isPagePreRender : System.boolean;
Managed Extensions for C++
protected: System.bool isPagePreRender
C++/CLI
protected:
System.bool isPagePreRender

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


IsSafariBrowser Method

[image]
Intersoft WebTextEditor Documentation
IsSafariBrowser Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : IsSafariBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsSafariBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Boolean

value = instance.IsSafariBrowser()
C#
public System.bool IsSafariBrowser()
Delphi
public function IsSafariBrowser(): System.Boolean;
JScript
public function IsSafariBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsSafariBrowser();
C++/CLI
public:
System.bool IsSafariBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


IsSessionAvailable Method

[image]
Intersoft WebTextEditor Documentation
IsSessionAvailable Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : IsSessionAvailable Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function IsSessionAvailable() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Boolean

value = instance.IsSessionAvailable()
C#
protected System.bool IsSessionAvailable()
Delphi
protected function IsSessionAvailable(): System.Boolean;
JScript
protected function IsSessionAvailable() : System.boolean;
Managed Extensions for C++
protected: System.bool IsSessionAvailable();
C++/CLI
protected:
System.bool IsSessionAvailable();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


IsTrackingViewState Property

[image]
Intersoft WebTextEditor Documentation
IsTrackingViewState Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : IsTrackingViewState Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property IsTrackingViewState As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Boolean

value = instance.IsTrackingViewState
C#
protected System.bool IsTrackingViewState {get;}
Delphi
protected read-only property IsTrackingViewState: System.Boolean;
JScript
protected function get IsTrackingViewState : System.boolean
Managed Extensions for C++
protected: __property System.bool get_IsTrackingViewState();
C++/CLI
protected:
property System.bool IsTrackingViewState {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


IsUnloaded Property

[image]
Intersoft WebTextEditor Documentation
IsUnloaded Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : IsUnloaded Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property IsUnloaded As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Boolean

instance.IsUnloaded = value

value = instance.IsUnloaded
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public System.bool IsUnloaded {get; set;}
Delphi
public read-write property IsUnloaded: System.Boolean;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get,set IsUnloaded : System.boolean
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property System.bool get_IsUnloaded();
public: __property void set_IsUnloaded(
   System.bool value
);
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property System.bool IsUnloaded {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


IsW3CStandardBrowser Method

[image]
Intersoft WebTextEditor Documentation
IsW3CStandardBrowser Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : IsW3CStandardBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsW3CStandardBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Boolean

value = instance.IsW3CStandardBrowser()
C#
public System.bool IsW3CStandardBrowser()
Delphi
public function IsW3CStandardBrowser(): System.Boolean;
JScript
public function IsW3CStandardBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsW3CStandardBrowser();
C++/CLI
public:
System.bool IsW3CStandardBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


Load Event

[image]
Intersoft WebTextEditor Documentation
Load Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : Load Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the page has been loaded.")>
Public Event Load As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim handler As System.EventHandler

AddHandler instance.Load, handler
C#
[WebSysDescriptionAttribute("Fires when the page has been loaded.")]
public event System.EventHandler Load
Delphi
public event Load: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the page has been loaded.")]
public: __event System.EventHandler* Load
C++/CLI
[WebSysDescriptionAttribute("Fires when the page has been loaded.")]
public:
event System.EventHandler^ Load

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


LoadControlState Method

[image]
Intersoft WebTextEditor Documentation
LoadControlState Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : LoadControlState Method

savedState

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub LoadControlState( _
   ByVal savedState As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim savedState As System.Object

instance.LoadControlState(savedState)
C#
protected virtual void LoadControlState(
   System.object savedState
)
Delphi
protected procedure LoadControlState(
    savedState: System.TObject
); virtual;
JScript
protected function LoadControlState(
   savedState : System.Object
);
Managed Extensions for C++
protected: virtual void LoadControlState(
   System.Object* savedState
)
C++/CLI
protected:
virtual void LoadControlState(
   System.Object^ savedState
)

Parameters

savedState

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


LoadLayout Method

[image]
Intersoft WebTextEditor Documentation
LoadLayout Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : LoadLayout Method

settings

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayout( _
   ByVal settings As ISNet.WebUI.LayoutInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim settings As ISNet.WebUI.LayoutInfo

instance.LoadLayout(settings)
C#
public virtual void LoadLayout(
   ISNet.WebUI.LayoutInfo settings
)
Delphi
public procedure LoadLayout(
    settings: ISNet.WebUI.LayoutInfo
); virtual;
JScript
public function LoadLayout(
   settings : ISNet.WebUI.LayoutInfo
);
Managed Extensions for C++
public: virtual void LoadLayout(
   ISNet.WebUI.LayoutInfo* settings
)
C++/CLI
public:
virtual void LoadLayout(
   ISNet.WebUI.LayoutInfo^ settings
)

Parameters

settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


LoadLayoutFromFile Method

[image]
Intersoft WebTextEditor Documentation
LoadLayoutFromFile Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : LoadLayoutFromFile Method

filePath

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromFile( _
   ByVal filePath As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim filePath As System.String

instance.LoadLayoutFromFile(filePath)
C#
public virtual void LoadLayoutFromFile(
   System.string filePath
)
Delphi
public procedure LoadLayoutFromFile(
    filePath: System.String
); virtual;
JScript
public function LoadLayoutFromFile(
   filePath : System.String
);
Managed Extensions for C++
public: virtual void LoadLayoutFromFile(
   System.string* filePath
)
C++/CLI
public:
virtual void LoadLayoutFromFile(
   System.String^ filePath
)

Parameters

filePath

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


LoadLayoutFromPredefinedName Method

[image]
Intersoft WebTextEditor Documentation
LoadLayoutFromPredefinedName Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : LoadLayoutFromPredefinedName Method

predefinedName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromPredefinedName( _
   ByVal predefinedName As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim predefinedName As System.String

instance.LoadLayoutFromPredefinedName(predefinedName)
C#
public virtual void LoadLayoutFromPredefinedName(
   System.string predefinedName
)
Delphi
public procedure LoadLayoutFromPredefinedName(
    predefinedName: System.String
); virtual;
JScript
public function LoadLayoutFromPredefinedName(
   predefinedName : System.String
);
Managed Extensions for C++
public: virtual void LoadLayoutFromPredefinedName(
   System.string* predefinedName
)
C++/CLI
public:
virtual void LoadLayoutFromPredefinedName(
   System.String^ predefinedName
)

Parameters

predefinedName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


LoadLayoutFromStream Method

[image]
Intersoft WebTextEditor Documentation
LoadLayoutFromStream Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : LoadLayoutFromStream Method

stream

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromStream( _
   ByVal stream As System.IO.Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim stream As System.IO.Stream

instance.LoadLayoutFromStream(stream)
C#
public virtual void LoadLayoutFromStream(
   System.IO.Stream stream
)
Delphi
public procedure LoadLayoutFromStream(
    stream: System.IO.Stream
); virtual;
JScript
public function LoadLayoutFromStream(
   stream : System.IO.Stream
);
Managed Extensions for C++
public: virtual void LoadLayoutFromStream(
   System.IO.Stream* stream
)
C++/CLI
public:
virtual void LoadLayoutFromStream(
   System.IO.Stream^ stream
)

Parameters

stream

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


LoadPostData Method

[image]
Intersoft WebTextEditor Documentation
LoadPostData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : LoadPostData Method

postDataKey
postCollection

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function LoadPostData( _
   ByVal postDataKey As System.String, _
   ByVal postCollection As System.Collections.Specialized.NameValueCollection _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim postDataKey As System.String
Dim postCollection As System.Collections.Specialized.NameValueCollection
Dim value As System.Boolean

value = instance.LoadPostData(postDataKey, postCollection)
C#
public virtual System.bool LoadPostData(
   System.string postDataKey,
   System.Collections.Specialized.NameValueCollection postCollection
)
Delphi
public function LoadPostData(
    postDataKey: System.String;
    postCollection: System.Collections.Specialized.NameValueCollection
): System.Boolean; virtual;
JScript
public function LoadPostData(
   postDataKey : System.String,
   postCollection : System.Collections.Specialized.NameValueCollection
) : System.boolean;
Managed Extensions for C++
public: virtual System.bool LoadPostData(
   System.string* postDataKey,
   System.Collections.Specialized.NameValueCollection* postCollection
)
C++/CLI
public:
virtual System.bool LoadPostData(
   System.String^ postDataKey,
   System.Collections.Specialized.NameValueCollection^ postCollection
)

Parameters

postDataKey
postCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


LoadViewState Method

[image]
Intersoft WebTextEditor Documentation
LoadViewState Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : LoadViewState Method

savedState

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub LoadViewState( _
   ByVal savedState As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim savedState As System.Object

instance.LoadViewState(savedState)
C#
protected virtual void LoadViewState(
   System.object savedState
)
Delphi
protected procedure LoadViewState(
    savedState: System.TObject
); virtual;
JScript
protected function LoadViewState(
   savedState : System.Object
);
Managed Extensions for C++
protected: virtual void LoadViewState(
   System.Object* savedState
)
C++/CLI
protected:
virtual void LoadViewState(
   System.Object^ savedState
)

Parameters

savedState

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


LoadViewStateByID Property

[image]
Intersoft WebTextEditor Documentation
LoadViewStateByID Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : LoadViewStateByID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property LoadViewStateByID As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Boolean

value = instance.LoadViewStateByID
C#
protected System.bool LoadViewStateByID {get;}
Delphi
protected read-only property LoadViewStateByID: System.Boolean;
JScript
protected function get LoadViewStateByID : System.boolean
Managed Extensions for C++
protected: __property System.bool get_LoadViewStateByID();
C++/CLI
protected:
property System.bool LoadViewStateByID {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


MaxJsonLength Property

[image]
Intersoft WebTextEditor Documentation
MaxJsonLength Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : MaxJsonLength Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the maximum length allowed for JSON Serializer.")>
<System.ComponentModel.DefaultValueAttribute()>
Protected Overridable Property MaxJsonLength As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Integer

instance.MaxJsonLength = value

value = instance.MaxJsonLength
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the maximum length allowed for JSON Serializer.")]
[System.ComponentModel.DefaultValueAttribute()]
protected virtual System.int MaxJsonLength {get; set;}
Delphi
protected read-write property MaxJsonLength: System.Integer; virtual;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the maximum length allowed for JSON Serializer.")
System.ComponentModel.DefaultValueAttribute()
protected function get,set MaxJsonLength : System.int
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the maximum length allowed for JSON Serializer.")]
[System.ComponentModel.DefaultValueAttribute()]
protected: __property virtual System.int get_MaxJsonLength();
protected: __property virtual void set_MaxJsonLength(
   System.int value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the maximum length allowed for JSON Serializer.")]
[System.ComponentModel.DefaultValueAttribute()]
protected:
virtual property System.int MaxJsonLength {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


MergeStyle Method

[image]
Intersoft WebTextEditor Documentation
MergeStyle Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : MergeStyle Method

s

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub MergeStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim s As System.Web.UI.WebControls.Style

instance.MergeStyle(s)
C#
public void MergeStyle(
   System.Web.UI.WebControls.Style s
)
Delphi
public procedure MergeStyle(
    s: System.Web.UI.WebControls.Style
);
JScript
public function MergeStyle(
   s : System.Web.UI.WebControls.Style
);
Managed Extensions for C++
public: void MergeStyle(
   System.Web.UI.WebControls.Style* s
)
C++/CLI
public:
void MergeStyle(
   System.Web.UI.WebControls.Style^ s
)

Parameters

s

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


NamingContainer Property

[image]
Intersoft WebTextEditor Documentation
NamingContainer Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : NamingContainer Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BindableAttribute(Bindable=False, Direction=BindingDirection.OneWay)>
<WebSysDescriptionAttribute("The containing control or page within which ID is unique.")>
Public Overridable ReadOnly Property NamingContainer As System.Web.UI.Control
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Web.UI.Control

value = instance.NamingContainer
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BindableAttribute(Bindable=false, Direction=BindingDirection.OneWay)]
[WebSysDescriptionAttribute("The containing control or page within which ID is unique.")]
public virtual System.Web.UI.Control NamingContainer {get;}
Delphi
public read-only property NamingContainer: System.Web.UI.Control; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
WebSysDescriptionAttribute("The containing control or page within which ID is unique.")
public function get NamingContainer : System.Web.UI.Control
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BindableAttribute(Bindable=false, Direction=BindingDirection.OneWay)]
[WebSysDescriptionAttribute("The containing control or page within which ID is unique.")]
public: __property virtual System.Web.UI.Control* get_NamingContainer();
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BindableAttribute(Bindable=false, Direction=BindingDirection.OneWay)]
[WebSysDescriptionAttribute("The containing control or page within which ID is unique.")]
public:
virtual property System.Web.UI.Control^ NamingContainer {
   System.Web.UI.Control^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


OnBubbleEvent Method

[image]
Intersoft WebTextEditor Documentation
OnBubbleEvent Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : OnBubbleEvent Method

source
args

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnBubbleEvent( _
   ByVal source As System.Object, _
   ByVal args As System.EventArgs _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim source As System.Object
Dim args As System.EventArgs
Dim value As System.Boolean

value = instance.OnBubbleEvent(source, args)
C#
protected virtual System.bool OnBubbleEvent(
   System.object source,
   System.EventArgs args
)
Delphi
protected function OnBubbleEvent(
    source: System.TObject;
    args: System.EventArgs
): System.Boolean; virtual;
JScript
protected function OnBubbleEvent(
   source : System.Object,
   args : System.EventArgs
) : System.boolean;
Managed Extensions for C++
protected: virtual System.bool OnBubbleEvent(
   System.Object* source,
   System.EventArgs* args
)
C++/CLI
protected:
virtual System.bool OnBubbleEvent(
   System.Object^ source,
   System.EventArgs^ args
)

Parameters

source
args

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


OnDataBinding Method

[image]
Intersoft WebTextEditor Documentation
OnDataBinding Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : OnDataBinding Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnDataBinding( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim e As System.EventArgs

instance.OnDataBinding(e)
C#
protected virtual void OnDataBinding(
   System.EventArgs e
)
Delphi
protected procedure OnDataBinding(
    e: System.EventArgs
); virtual;
JScript
protected function OnDataBinding(
   e : System.EventArgs
);
Managed Extensions for C++
protected: virtual void OnDataBinding(
   System.EventArgs* e
)
C++/CLI
protected:
virtual void OnDataBinding(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


OnInfoChanged Method

[image]
Intersoft WebTextEditor Documentation
OnInfoChanged Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : OnInfoChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub OnInfoChanged( _
   ByVal e As ISNet.WebUI.SynchronizeEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim e As ISNet.WebUI.SynchronizeEventArgs

instance.OnInfoChanged(e)
C#
public void OnInfoChanged(
   ISNet.WebUI.SynchronizeEventArgs e
)
Delphi
public procedure OnInfoChanged(
    e: ISNet.WebUI.SynchronizeEventArgs
);
JScript
public function OnInfoChanged(
   e : ISNet.WebUI.SynchronizeEventArgs
);
Managed Extensions for C++
public: void OnInfoChanged(
   ISNet.WebUI.SynchronizeEventArgs* e
)
C++/CLI
public:
void OnInfoChanged(
   ISNet.WebUI.SynchronizeEventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


OnInit Method

[image]
Intersoft WebTextEditor Documentation
OnInit Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : OnInit Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnInit( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim e As System.EventArgs

instance.OnInit(e)
C#
protected virtual void OnInit(
   System.EventArgs e
)
Delphi
protected procedure OnInit(
    e: System.EventArgs
); virtual;
JScript
protected function OnInit(
   e : System.EventArgs
);
Managed Extensions for C++
protected: virtual void OnInit(
   System.EventArgs* e
)
C++/CLI
protected:
virtual void OnInit(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


OnLoad Method

[image]
Intersoft WebTextEditor Documentation
OnLoad Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : OnLoad Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnLoad( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim e As System.EventArgs

instance.OnLoad(e)
C#
protected virtual void OnLoad(
   System.EventArgs e
)
Delphi
protected procedure OnLoad(
    e: System.EventArgs
); virtual;
JScript
protected function OnLoad(
   e : System.EventArgs
);
Managed Extensions for C++
protected: virtual void OnLoad(
   System.EventArgs* e
)
C++/CLI
protected:
virtual void OnLoad(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


OnPreInitialize Method

[image]
Intersoft WebTextEditor Documentation
OnPreInitialize Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : OnPreInitialize Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub OnPreInitialize()
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker

instance.OnPreInitialize()
C#
public virtual void OnPreInitialize()
Delphi
public procedure OnPreInitialize(); virtual;
JScript
public function OnPreInitialize();
Managed Extensions for C++
public: virtual void OnPreInitialize();
C++/CLI
public:
virtual void OnPreInitialize();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


Page Property

[image]
Intersoft WebTextEditor Documentation
Page Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : Page Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property Page As System.Web.UI.Page
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Web.UI.Page

instance.Page = value

value = instance.Page
C#
public virtual System.Web.UI.Page Page {get; set;}
Delphi
public read-write property Page: System.Web.UI.Page; virtual;
JScript
public function get,set Page : System.Web.UI.Page
Managed Extensions for C++
public: __property virtual System.Web.UI.Page* get_Page();
public: __property virtual void set_Page(
   System.Web.UI.Page* value
);
C++/CLI
public:
virtual property System.Web.UI.Page^ Page {
   System.Web.UI.Page^ get();
   void set (    System.Web.UI.Page^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


Parent Property

[image]
Intersoft WebTextEditor Documentation
Parent Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : Parent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<WebSysDescriptionAttribute("The control containing this control.")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BindableAttribute(Bindable=False, Direction=BindingDirection.OneWay)>
Public Overridable ReadOnly Property Parent As System.Web.UI.Control
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Web.UI.Control

value = instance.Parent
C#
[System.ComponentModel.BrowsableAttribute(false)]
[WebSysDescriptionAttribute("The control containing this control.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BindableAttribute(Bindable=false, Direction=BindingDirection.OneWay)]
public virtual System.Web.UI.Control Parent {get;}
Delphi
public read-only property Parent: System.Web.UI.Control; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
WebSysDescriptionAttribute("The control containing this control.")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get Parent : System.Web.UI.Control
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[WebSysDescriptionAttribute("The control containing this control.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BindableAttribute(Bindable=false, Direction=BindingDirection.OneWay)]
public: __property virtual System.Web.UI.Control* get_Parent();
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[WebSysDescriptionAttribute("The control containing this control.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BindableAttribute(Bindable=false, Direction=BindingDirection.OneWay)]
public:
virtual property System.Web.UI.Control^ Parent {
   System.Web.UI.Control^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


ParentStyleId Property

[image]
Intersoft WebTextEditor Documentation
ParentStyleId Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : ParentStyleId Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
Public ReadOnly Property ParentStyleId As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.String

value = instance.ParentStyleId
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public System.string ParentStyleId {get;}
Delphi
public read-only property ParentStyleId: System.String;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
public function get ParentStyleId : System.String
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public: __property System.string* get_ParentStyleId();
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public:
property System.String^ ParentStyleId {
   System.String^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


PreInitialize Event

[image]
Intersoft WebTextEditor Documentation
PreInitialize Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : PreInitialize Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event PreInitialize As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim handler As System.EventHandler

AddHandler instance.PreInitialize, handler
C#
public event System.EventHandler PreInitialize
Delphi
public event PreInitialize: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
public: __event System.EventHandler* PreInitialize
C++/CLI
public:
event System.EventHandler^ PreInitialize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


PreRender Event

[image]
Intersoft WebTextEditor Documentation
PreRender Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : PreRender Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires before the page is rendered.")>
Public Event PreRender As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim handler As System.EventHandler

AddHandler instance.PreRender, handler
C#
[WebSysDescriptionAttribute("Fires before the page is rendered.")]
public event System.EventHandler PreRender
Delphi
public event PreRender: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires before the page is rendered.")]
public: __event System.EventHandler* PreRender
C++/CLI
[WebSysDescriptionAttribute("Fires before the page is rendered.")]
public:
event System.EventHandler^ PreRender

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


RaiseBubbleEvent Method

[image]
Intersoft WebTextEditor Documentation
RaiseBubbleEvent Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : RaiseBubbleEvent Method

source
args

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Sub RaiseBubbleEvent( _
   ByVal source As System.Object, _
   ByVal args As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim source As System.Object
Dim args As System.EventArgs

instance.RaiseBubbleEvent(source, args)
C#
protected void RaiseBubbleEvent(
   System.object source,
   System.EventArgs args
)
Delphi
protected procedure RaiseBubbleEvent(
    source: System.TObject;
    args: System.EventArgs
);
JScript
protected function RaiseBubbleEvent(
   source : System.Object,
   args : System.EventArgs
);
Managed Extensions for C++
protected: void RaiseBubbleEvent(
   System.Object* source,
   System.EventArgs* args
)
C++/CLI
protected:
void RaiseBubbleEvent(
   System.Object^ source,
   System.EventArgs^ args
)

Parameters

source
args

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


RaisePostDataChangedEvent Method

[image]
Intersoft WebTextEditor Documentation
RaisePostDataChangedEvent Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : RaisePostDataChangedEvent Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RaisePostDataChangedEvent()
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker

instance.RaisePostDataChangedEvent()
C#
public virtual void RaisePostDataChangedEvent()
Delphi
public procedure RaisePostDataChangedEvent(); virtual;
JScript
public function RaisePostDataChangedEvent();
Managed Extensions for C++
public: virtual void RaisePostDataChangedEvent();
C++/CLI
public:
virtual void RaisePostDataChangedEvent();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


ReadWebConfigValue Method

[image]
Intersoft WebTextEditor Documentation
ReadWebConfigValue Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : ReadWebConfigValue Method

key

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ReadWebConfigValue( _
   ByVal key As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim key As System.String
Dim value As System.String

value = instance.ReadWebConfigValue(key)
C#
public System.string ReadWebConfigValue(
   System.string key
)
Delphi
public function ReadWebConfigValue(
    key: System.String
): System.String;
JScript
public function ReadWebConfigValue(
   key : System.String
) : System.String;
Managed Extensions for C++
public: System.string* ReadWebConfigValue(
   System.string* key
)
C++/CLI
public:
System.String^ ReadWebConfigValue(
   System.String^ key
)

Parameters

key

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


RegisterBoxSizing Method

[image]
Intersoft WebTextEditor Documentation
RegisterBoxSizing Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : RegisterBoxSizing Method

Glossary Item Box

Overload List

Overload | Description
RegisterBoxSizing() | (Inherited from ISNet.WebUI.ISNetControl)
RegisterBoxSizing(Boolean) | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


RegisterBoxSizing() Method

[image]
Intersoft WebTextEditor Documentation
RegisterBoxSizing() Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class > RegisterBoxSizing Method : RegisterBoxSizing() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub RegisterBoxSizing()
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker

instance.RegisterBoxSizing()
C#
public void RegisterBoxSizing()
Delphi
public procedure RegisterBoxSizing();
JScript
public function RegisterBoxSizing();
Managed Extensions for C++
public: void RegisterBoxSizing();
C++/CLI
public:
void RegisterBoxSizing();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members
Overload List


RegisterBoxSizing(Boolean) Method

[image]
Intersoft WebTextEditor Documentation
RegisterBoxSizing(Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class > RegisterBoxSizing Method : RegisterBoxSizing(Boolean) Method

forceAll

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub RegisterBoxSizing( _
   ByVal forceAll As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim forceAll As System.Boolean

instance.RegisterBoxSizing(forceAll)
C#
public void RegisterBoxSizing(
   System.bool forceAll
)
Delphi
public procedure RegisterBoxSizing(
    forceAll: System.Boolean
);
JScript
public function RegisterBoxSizing(
   forceAll : System.boolean
);
Managed Extensions for C++
public: void RegisterBoxSizing(
   System.bool forceAll
)
C++/CLI
public:
void RegisterBoxSizing(
   System.bool forceAll
)

Parameters

forceAll

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members
Overload List


RegisterGlobalStyle Method

[image]
Intersoft WebTextEditor Documentation
RegisterGlobalStyle Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : RegisterGlobalStyle Method

style

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterGlobalStyle( _
   ByVal style As ISNet.WebUI.WebStyle _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim style As ISNet.WebUI.WebStyle

instance.RegisterGlobalStyle(style)
C#
public void RegisterGlobalStyle(
   ISNet.WebUI.WebStyle style
)
Delphi
public procedure RegisterGlobalStyle(
    style: ISNet.WebUI.WebStyle
);
JScript
public function RegisterGlobalStyle(
   style : ISNet.WebUI.WebStyle
);
Managed Extensions for C++
public: void RegisterGlobalStyle(
   ISNet.WebUI.WebStyle* style
)
C++/CLI
public:
void RegisterGlobalStyle(
   ISNet.WebUI.WebStyle^ style
)

Parameters

style

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


RegisterLink Method

[image]
Intersoft WebTextEditor Documentation
RegisterLink Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : RegisterLink Method

name
url

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterLink( _
   ByVal name As System.String, _
   ByVal url As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim name As System.String
Dim url As System.String

instance.RegisterLink(name, url)
C#
public void RegisterLink(
   System.string name,
   System.string url
)
Delphi
public procedure RegisterLink(
    name: System.String;
    url: System.String
);
JScript
public function RegisterLink(
   name : System.String,
   url : System.String
);
Managed Extensions for C++
public: void RegisterLink(
   System.string* name,
   System.string* url
)
C++/CLI
public:
void RegisterLink(
   System.String^ name,
   System.String^ url
)

Parameters

name
url

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


RegisterOptimizedCssClasses Method

[image]
Intersoft WebTextEditor Documentation
RegisterOptimizedCssClasses Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : RegisterOptimizedCssClasses Method

runtimeStyleOnly

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterOptimizedCssClasses( _
   ByVal runtimeStyleOnly As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim runtimeStyleOnly As System.Boolean

instance.RegisterOptimizedCssClasses(runtimeStyleOnly)
C#
public void RegisterOptimizedCssClasses(
   System.bool runtimeStyleOnly
)
Delphi
public procedure RegisterOptimizedCssClasses(
    runtimeStyleOnly: System.Boolean
);
JScript
public function RegisterOptimizedCssClasses(
   runtimeStyleOnly : System.boolean
);
Managed Extensions for C++
public: void RegisterOptimizedCssClasses(
   System.bool runtimeStyleOnly
)
C++/CLI
public:
void RegisterOptimizedCssClasses(
   System.bool runtimeStyleOnly
)

Parameters

runtimeStyleOnly

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


RegisterPreloadImage Method

[image]
Intersoft WebTextEditor Documentation
RegisterPreloadImage Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : RegisterPreloadImage Method

image

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterPreloadImage( _
   ByVal image As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim image As System.String

instance.RegisterPreloadImage(image)
C#
public void RegisterPreloadImage(
   System.string image
)
Delphi
public procedure RegisterPreloadImage(
    image: System.String
);
JScript
public function RegisterPreloadImage(
   image : System.String
);
Managed Extensions for C++
public: void RegisterPreloadImage(
   System.string* image
)
C++/CLI
public:
void RegisterPreloadImage(
   System.String^ image
)

Parameters

image

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


RegisterSharePointHandler Method

[image]
Intersoft WebTextEditor Documentation
RegisterSharePointHandler Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : RegisterSharePointHandler Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RegisterSharePointHandler()
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker

instance.RegisterSharePointHandler()
C#
public virtual void RegisterSharePointHandler()
Delphi
public procedure RegisterSharePointHandler(); virtual;
JScript
public function RegisterSharePointHandler();
Managed Extensions for C++
public: virtual void RegisterSharePointHandler();
C++/CLI
public:
virtual void RegisterSharePointHandler();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


RenderBeginTag Method

[image]
Intersoft WebTextEditor Documentation
RenderBeginTag Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : RenderBeginTag Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RenderBeginTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderBeginTag(writer)
C#
public virtual void RenderBeginTag(
   System.Web.UI.HtmlTextWriter writer
)
Delphi
public procedure RenderBeginTag(
    writer: System.Web.UI.HtmlTextWriter
); virtual;
JScript
public function RenderBeginTag(
   writer : System.Web.UI.HtmlTextWriter
);
Managed Extensions for C++
public: virtual void RenderBeginTag(
   System.Web.UI.HtmlTextWriter* writer
)
C++/CLI
public:
virtual void RenderBeginTag(
   System.Web.UI.HtmlTextWriter^ writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


RenderContents Method

[image]
Intersoft WebTextEditor Documentation
RenderContents Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : RenderContents Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub RenderContents( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderContents(writer)
C#
protected virtual void RenderContents(
   System.Web.UI.HtmlTextWriter writer
)
Delphi
protected procedure RenderContents(
    writer: System.Web.UI.HtmlTextWriter
); virtual;
JScript
protected function RenderContents(
   writer : System.Web.UI.HtmlTextWriter
);
Managed Extensions for C++
protected: virtual void RenderContents(
   System.Web.UI.HtmlTextWriter* writer
)
C++/CLI
protected:
virtual void RenderContents(
   System.Web.UI.HtmlTextWriter^ writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


RenderControl Method

[image]
Intersoft WebTextEditor Documentation
RenderControl Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : RenderControl Method

Glossary Item Box

Overload List

Overload | Description
RenderControl(HtmlTextWriter) | (Inherited from System.Web.UI.Control)
RenderControl(HtmlTextWriter,ControlAdapter) | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


RenderControl(HtmlTextWriter) Method

[image]
Intersoft WebTextEditor Documentation
RenderControl(HtmlTextWriter) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class > RenderControl Method : RenderControl(HtmlTextWriter) Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Overloads Overridable Sub RenderControl( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderControl(writer)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public virtual void RenderControl(
   System.Web.UI.HtmlTextWriter writer
)
Delphi
public procedure RenderControl(
    writer: System.Web.UI.HtmlTextWriter
); virtual;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function RenderControl(
   writer : System.Web.UI.HtmlTextWriter
);
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: virtual void RenderControl(
   System.Web.UI.HtmlTextWriter* writer
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
virtual void RenderControl(
   System.Web.UI.HtmlTextWriter^ writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members
Overload List


RenderControl(HtmlTextWriter,ControlAdapter) Method

[image]
Intersoft WebTextEditor Documentation
RenderControl(HtmlTextWriter,ControlAdapter) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class > RenderControl Method : RenderControl(HtmlTextWriter,ControlAdapter) Method

writer
adapter

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overloads Sub RenderControl( _
   ByVal writer As System.Web.UI.HtmlTextWriter, _
   ByVal adapter As System.Web.UI.Adapters.ControlAdapter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim writer As System.Web.UI.HtmlTextWriter
Dim adapter As System.Web.UI.Adapters.ControlAdapter

instance.RenderControl(writer, adapter)
C#
protected void RenderControl(
   System.Web.UI.HtmlTextWriter writer,
   System.Web.UI.Adapters.ControlAdapter adapter
)
Delphi
protected procedure RenderControl(
    writer: System.Web.UI.HtmlTextWriter;
    adapter: System.Web.UI.Adapters.ControlAdapter
);
JScript
protected function RenderControl(
   writer : System.Web.UI.HtmlTextWriter,
   adapter : System.Web.UI.Adapters.ControlAdapter
);
Managed Extensions for C++
protected: void RenderControl(
   System.Web.UI.HtmlTextWriter* writer,
   System.Web.UI.Adapters.ControlAdapter* adapter
)
C++/CLI
protected:
void RenderControl(
   System.Web.UI.HtmlTextWriter^ writer,
   System.Web.UI.Adapters.ControlAdapter^ adapter
)

Parameters

writer
adapter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members
Overload List


renderDHTML Field

[image]
Intersoft WebTextEditor Documentation
renderDHTML Field
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : renderDHTML Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected renderDHTML As ISNet.WebUI.RenderDHTML
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As ISNet.WebUI.RenderDHTML

value = instance.renderDHTML

instance.renderDHTML = value
C#
protected ISNet.WebUI.RenderDHTML renderDHTML
Delphi
protected field renderDHTML: ISNet.WebUI.RenderDHTML;
JScript
protected var renderDHTML : ISNet.WebUI.RenderDHTML;
Managed Extensions for C++
protected: ISNet.WebUI.RenderDHTML* renderDHTML
C++/CLI
protected:
ISNet.WebUI.RenderDHTML^ renderDHTML

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


RenderingCompatibility Property

[image]
Intersoft WebTextEditor Documentation
RenderingCompatibility Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : RenderingCompatibility Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.BindableAttribute(Bindable=False, Direction=BindingDirection.OneWay)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Overridable Property RenderingCompatibility As System.Version
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Version

instance.RenderingCompatibility = value

value = instance.RenderingCompatibility
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.BindableAttribute(Bindable=false, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public virtual System.Version RenderingCompatibility {get; set;}
Delphi
public read-write property RenderingCompatibility: System.Version; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get,set RenderingCompatibility : System.Version
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.BindableAttribute(Bindable=false, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property virtual System.Version* get_RenderingCompatibility();
public: __property virtual void set_RenderingCompatibility(
   System.Version* value
);
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.BindableAttribute(Bindable=false, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
virtual property System.Version^ RenderingCompatibility {
   System.Version^ get();
   void set (    System.Version^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


RenderingMode Property

[image]
Intersoft WebTextEditor Documentation
RenderingMode Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : RenderingMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets a value that specifies the HTML rendering behavior applied in this control.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Overridable Property RenderingMode As ISNet.WebUI.RenderMode
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As ISNet.WebUI.RenderMode

instance.RenderingMode = value

value = instance.RenderingMode
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that specifies the HTML rendering behavior applied in this control.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public virtual ISNet.WebUI.RenderMode RenderingMode {get; set;}
Delphi
public read-write property RenderingMode: ISNet.WebUI.RenderMode; virtual;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets a value that specifies the HTML rendering behavior applied in this control.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set RenderingMode : ISNet.WebUI.RenderMode
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that specifies the HTML rendering behavior applied in this control.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property virtual ISNet.WebUI.RenderMode get_RenderingMode();
public: __property virtual void set_RenderingMode(
   ISNet.WebUI.RenderMode value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that specifies the HTML rendering behavior applied in this control.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
virtual property ISNet.WebUI.RenderMode RenderingMode {
   ISNet.WebUI.RenderMode get();
   void set (    ISNet.WebUI.RenderMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


renderNS Field

[image]
Intersoft WebTextEditor Documentation
renderNS Field
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : renderNS Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected renderNS As ISNet.WebUI.RenderNS
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As ISNet.WebUI.RenderNS

value = instance.renderNS

instance.renderNS = value
C#
protected ISNet.WebUI.RenderNS renderNS
Delphi
protected field renderNS: ISNet.WebUI.RenderNS;
JScript
protected var renderNS : ISNet.WebUI.RenderNS;
Managed Extensions for C++
protected: ISNet.WebUI.RenderNS* renderNS
C++/CLI
protected:
ISNet.WebUI.RenderNS^ renderNS

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


RequiresUIRefresh Property

[image]
Intersoft WebTextEditor Documentation
RequiresUIRefresh Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : RequiresUIRefresh Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property RequiresUIRefresh As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Boolean

instance.RequiresUIRefresh = value

value = instance.RequiresUIRefresh
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public System.bool RequiresUIRefresh {get; set;}
Delphi
public read-write property RequiresUIRefresh: System.Boolean;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get,set RequiresUIRefresh : System.boolean
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property System.bool get_RequiresUIRefresh();
public: __property void set_RequiresUIRefresh(
   System.bool value
);
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property System.bool RequiresUIRefresh {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


Reset Method

[image]
Intersoft WebTextEditor Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


ResetFilteredStyle Method

[image]
Intersoft WebTextEditor Documentation
ResetFilteredStyle Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : ResetFilteredStyle Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ResetFilteredStyle()
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker

instance.ResetFilteredStyle()
C#
protected virtual void ResetFilteredStyle()
Delphi
protected procedure ResetFilteredStyle(); virtual;
JScript
protected function ResetFilteredStyle();
Managed Extensions for C++
protected: virtual void ResetFilteredStyle();
C++/CLI
protected:
virtual void ResetFilteredStyle();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


ResolveAdapter Method

[image]
Intersoft WebTextEditor Documentation
ResolveAdapter Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : ResolveAdapter Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function ResolveAdapter() As System.Web.UI.Adapters.ControlAdapter
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Web.UI.Adapters.ControlAdapter

value = instance.ResolveAdapter()
C#
protected virtual System.Web.UI.Adapters.ControlAdapter ResolveAdapter()
Delphi
protected function ResolveAdapter(): System.Web.UI.Adapters.ControlAdapter; virtual;
JScript
protected function ResolveAdapter() : System.Web.UI.Adapters.ControlAdapter;
Managed Extensions for C++
protected: virtual System.Web.UI.Adapters.ControlAdapter* ResolveAdapter();
C++/CLI
protected:
virtual System.Web.UI.Adapters.ControlAdapter^ ResolveAdapter();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


ResolveClientUrl Method

[image]
Intersoft WebTextEditor Documentation
ResolveClientUrl Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : ResolveClientUrl Method

relativeUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveClientUrl( _
   ByVal relativeUrl As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim relativeUrl As System.String
Dim value As System.String

value = instance.ResolveClientUrl(relativeUrl)
C#
public System.string ResolveClientUrl(
   System.string relativeUrl
)
Delphi
public function ResolveClientUrl(
    relativeUrl: System.String
): System.String;
JScript
public function ResolveClientUrl(
   relativeUrl : System.String
) : System.String;
Managed Extensions for C++
public: System.string* ResolveClientUrl(
   System.string* relativeUrl
)
C++/CLI
public:
System.String^ ResolveClientUrl(
   System.String^ relativeUrl
)

Parameters

relativeUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


ResolveImagePath Method

[image]
Intersoft WebTextEditor Documentation
ResolveImagePath Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : ResolveImagePath Method

folder
image

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveImagePath( _
   ByVal folder As System.String, _
   ByVal image As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim folder As System.String
Dim image As System.String
Dim value As System.String

value = instance.ResolveImagePath(folder, image)
C#
public System.string ResolveImagePath(
   System.string folder,
   System.string image
)
Delphi
public function ResolveImagePath(
    folder: System.String;
    image: System.String
): System.String;
JScript
public function ResolveImagePath(
   folder : System.String,
   image : System.String
) : System.String;
Managed Extensions for C++
public: System.string* ResolveImagePath(
   System.string* folder,
   System.string* image
)
C++/CLI
public:
System.String^ ResolveImagePath(
   System.String^ folder,
   System.String^ image
)

Parameters

folder
image

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


ResolveRelativeURL Method

[image]
Intersoft WebTextEditor Documentation
ResolveRelativeURL Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : ResolveRelativeURL Method

url

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ResolveRelativeURL( _
   ByVal url As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim url As System.String
Dim value As System.String

value = instance.ResolveRelativeURL(url)
C#
public virtual System.string ResolveRelativeURL(
   System.string url
)
Delphi
public function ResolveRelativeURL(
    url: System.String
): System.String; virtual;
JScript
public function ResolveRelativeURL(
   url : System.String
) : System.String;
Managed Extensions for C++
public: virtual System.string* ResolveRelativeURL(
   System.string* url
)
C++/CLI
public:
virtual System.String^ ResolveRelativeURL(
   System.String^ url
)

Parameters

url

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


ResolveResourceUrl Method

[image]
Intersoft WebTextEditor Documentation
ResolveResourceUrl Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : ResolveResourceUrl Method

kind
defaultFolder
currentFolder
resourceName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveResourceUrl( _
   ByVal kind As ISNet.WebUI.ResourceKind, _
   ByVal defaultFolder As System.String, _
   ByVal currentFolder As System.String, _
   ByVal resourceName As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim kind As ISNet.WebUI.ResourceKind
Dim defaultFolder As System.String
Dim currentFolder As System.String
Dim resourceName As System.String
Dim value As System.String

value = instance.ResolveResourceUrl(kind, defaultFolder, currentFolder, resourceName)
C#
public System.string ResolveResourceUrl(
   ISNet.WebUI.ResourceKind kind,
   System.string defaultFolder,
   System.string currentFolder,
   System.string resourceName
)
Delphi
public function ResolveResourceUrl(
    kind: ISNet.WebUI.ResourceKind;
    defaultFolder: System.String;
    currentFolder: System.String;
    resourceName: System.String
): System.String;
JScript
public function ResolveResourceUrl(
   kind : ISNet.WebUI.ResourceKind,
   defaultFolder : System.String,
   currentFolder : System.String,
   resourceName : System.String
) : System.String;
Managed Extensions for C++
public: System.string* ResolveResourceUrl(
   ISNet.WebUI.ResourceKind kind,
   System.string* defaultFolder,
   System.string* currentFolder,
   System.string* resourceName
)
C++/CLI
public:
System.String^ ResolveResourceUrl(
   ISNet.WebUI.ResourceKind kind,
   System.String^ defaultFolder,
   System.String^ currentFolder,
   System.String^ resourceName
)

Parameters

kind
defaultFolder
currentFolder
resourceName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


ResolveUrl Method

[image]
Intersoft WebTextEditor Documentation
ResolveUrl Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : ResolveUrl Method

relativeUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveUrl( _
   ByVal relativeUrl As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim relativeUrl As System.String
Dim value As System.String

value = instance.ResolveUrl(relativeUrl)
C#
public System.string ResolveUrl(
   System.string relativeUrl
)
Delphi
public function ResolveUrl(
    relativeUrl: System.String
): System.String;
JScript
public function ResolveUrl(
   relativeUrl : System.String
) : System.String;
Managed Extensions for C++
public: System.string* ResolveUrl(
   System.string* relativeUrl
)
C++/CLI
public:
System.String^ ResolveUrl(
   System.String^ relativeUrl
)

Parameters

relativeUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


RuntimeLicenseKey Property

[image]
Intersoft WebTextEditor Documentation
RuntimeLicenseKey Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : RuntimeLicenseKey Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.PersistLayoutAttribute(False)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("The runtime license key for xcopy deployment. Registered customers please obtain the key through Intersoft Developer Network.")>
Public Overridable Property RuntimeLicenseKey As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.String

instance.RuntimeLicenseKey = value

value = instance.RuntimeLicenseKey
C#
[ISNet.PersistLayoutAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The runtime license key for xcopy deployment. Registered customers please obtain the key through Intersoft Developer Network.")]
public virtual System.string RuntimeLicenseKey {get; set;}
Delphi
public read-write property RuntimeLicenseKey: System.String; virtual;
JScript
ISNet.PersistLayoutAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("The runtime license key for xcopy deployment. Registered customers please obtain the key through Intersoft Developer Network.")
public function get,set RuntimeLicenseKey : System.String
Managed Extensions for C++
[ISNet.PersistLayoutAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The runtime license key for xcopy deployment. Registered customers please obtain the key through Intersoft Developer Network.")]
public: __property virtual System.string* get_RuntimeLicenseKey();
public: __property virtual void set_RuntimeLicenseKey(
   System.string* value
);
C++/CLI
[ISNet.PersistLayoutAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The runtime license key for xcopy deployment. Registered customers please obtain the key through Intersoft Developer Network.")]
public:
virtual property System.String^ RuntimeLicenseKey {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


SaveControlState Method

[image]
Intersoft WebTextEditor Documentation
SaveControlState Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : SaveControlState Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function SaveControlState() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Object

value = instance.SaveControlState()
C#
protected virtual System.object SaveControlState()
Delphi
protected function SaveControlState(): System.TObject; virtual;
JScript
protected function SaveControlState() : System.Object;
Managed Extensions for C++
protected: virtual System.Object* SaveControlState();
C++/CLI
protected:
virtual System.Object^ SaveControlState();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


SaveLayout Method

[image]
Intersoft WebTextEditor Documentation
SaveLayout Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : SaveLayout Method

settings

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayout( _
   ByVal settings As ISNet.WebUI.LayoutInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim settings As ISNet.WebUI.LayoutInfo

instance.SaveLayout(settings)
C#
public virtual void SaveLayout(
   ISNet.WebUI.LayoutInfo settings
)
Delphi
public procedure SaveLayout(
    settings: ISNet.WebUI.LayoutInfo
); virtual;
JScript
public function SaveLayout(
   settings : ISNet.WebUI.LayoutInfo
);
Managed Extensions for C++
public: virtual void SaveLayout(
   ISNet.WebUI.LayoutInfo* settings
)
C++/CLI
public:
virtual void SaveLayout(
   ISNet.WebUI.LayoutInfo^ settings
)

Parameters

settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


SaveLayoutToFile Method

[image]
Intersoft WebTextEditor Documentation
SaveLayoutToFile Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : SaveLayoutToFile Method

filePath
saveOptions

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayoutToFile( _
   ByVal filePath As System.String, _
   ByVal saveOptions As ISNet.WebUI.SaveLayoutOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim filePath As System.String
Dim saveOptions As ISNet.WebUI.SaveLayoutOptions

instance.SaveLayoutToFile(filePath, saveOptions)
C#
public virtual void SaveLayoutToFile(
   System.string filePath,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)
Delphi
public procedure SaveLayoutToFile(
    filePath: System.String;
    saveOptions: ISNet.WebUI.SaveLayoutOptions
); virtual;
JScript
public function SaveLayoutToFile(
   filePath : System.String,
   saveOptions : ISNet.WebUI.SaveLayoutOptions
);
Managed Extensions for C++
public: virtual void SaveLayoutToFile(
   System.string* filePath,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)
C++/CLI
public:
virtual void SaveLayoutToFile(
   System.String^ filePath,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)

Parameters

filePath
saveOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


SaveLayoutToStream Method

[image]
Intersoft WebTextEditor Documentation
SaveLayoutToStream Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : SaveLayoutToStream Method

stream
saveOptions

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayoutToStream( _
   ByVal stream As System.IO.Stream, _
   ByVal saveOptions As ISNet.WebUI.SaveLayoutOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim stream As System.IO.Stream
Dim saveOptions As ISNet.WebUI.SaveLayoutOptions

instance.SaveLayoutToStream(stream, saveOptions)
C#
public virtual void SaveLayoutToStream(
   System.IO.Stream stream,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)
Delphi
public procedure SaveLayoutToStream(
    stream: System.IO.Stream;
    saveOptions: ISNet.WebUI.SaveLayoutOptions
); virtual;
JScript
public function SaveLayoutToStream(
   stream : System.IO.Stream,
   saveOptions : ISNet.WebUI.SaveLayoutOptions
);
Managed Extensions for C++
public: virtual void SaveLayoutToStream(
   System.IO.Stream* stream,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)
C++/CLI
public:
virtual void SaveLayoutToStream(
   System.IO.Stream^ stream,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)

Parameters

stream
saveOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


SaveViewState Method

[image]
Intersoft WebTextEditor Documentation
SaveViewState Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : SaveViewState Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function SaveViewState() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Object

value = instance.SaveViewState()
C#
protected virtual System.object SaveViewState()
Delphi
protected function SaveViewState(): System.TObject; virtual;
JScript
protected function SaveViewState() : System.Object;
Managed Extensions for C++
protected: virtual System.Object* SaveViewState();
C++/CLI
protected:
virtual System.Object^ SaveViewState();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


SaveViewStateOnFlyPostback Property

[image]
Intersoft WebTextEditor Documentation
SaveViewStateOnFlyPostback Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : SaveViewStateOnFlyPostback Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property SaveViewStateOnFlyPostback As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Boolean

instance.SaveViewStateOnFlyPostback = value

value = instance.SaveViewStateOnFlyPostback
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public System.bool SaveViewStateOnFlyPostback {get; set;}
Delphi
public read-write property SaveViewStateOnFlyPostback: System.Boolean;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get,set SaveViewStateOnFlyPostback : System.boolean
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property System.bool get_SaveViewStateOnFlyPostback();
public: __property void set_SaveViewStateOnFlyPostback(
   System.bool value
);
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property System.bool SaveViewStateOnFlyPostback {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


SerializedJSFiles Property

[image]
Intersoft WebTextEditor Documentation
SerializedJSFiles Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : SerializedJSFiles Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public ReadOnly Property SerializedJSFiles As System.Collections.ArrayList
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Collections.ArrayList

value = instance.SerializedJSFiles
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public System.Collections.ArrayList SerializedJSFiles {get;}
Delphi
public read-only property SerializedJSFiles: System.Collections.ArrayList;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get SerializedJSFiles : System.Collections.ArrayList
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property System.Collections.ArrayList* get_SerializedJSFiles();
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property System.Collections.ArrayList^ SerializedJSFiles {
   System.Collections.ArrayList^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


SerializedStyles Property

[image]
Intersoft WebTextEditor Documentation
SerializedStyles Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : SerializedStyles Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
Public ReadOnly Property SerializedStyles As System.Collections.Generic.Dictionary(Of String,Object)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Collections.Generic.Dictionary(Of String,Object)

value = instance.SerializedStyles
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public System.Collections.Generic.Dictionary<string,object> SerializedStyles {get;}
Delphi
public read-only property SerializedStyles: System.Collections.Generic.Dictionary;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
public function get SerializedStyles : System.Collections.Generic.Dictionary
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public: __property System.Collections.Generic.Dictionary<string*,Object*>* get_SerializedStyles();
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public:
property System.Collections.Generic.Dictionary<String^,Object^>^ SerializedStyles {
   System.Collections.Generic.Dictionary<String^,Object^>^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


SerializeObjectData Method

[image]
Intersoft WebTextEditor Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


SetDesignModeState Method

[image]
Intersoft WebTextEditor Documentation
SetDesignModeState Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : SetDesignModeState Method

data

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub SetDesignModeState( _
   ByVal data As System.Collections.IDictionary _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim data As System.Collections.IDictionary

instance.SetDesignModeState(data)
C#
protected virtual void SetDesignModeState(
   System.Collections.IDictionary data
)
Delphi
protected procedure SetDesignModeState(
    data: System.Collections.IDictionary
); virtual;
JScript
protected function SetDesignModeState(
   data : System.Collections.IDictionary
);
Managed Extensions for C++
protected: virtual void SetDesignModeState(
   System.Collections.IDictionary* data
)
C++/CLI
protected:
virtual void SetDesignModeState(
   System.Collections.IDictionary^ data
)

Parameters

data

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


SetRenderMethodDelegate Method

[image]
Intersoft WebTextEditor Documentation
SetRenderMethodDelegate Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : SetRenderMethodDelegate Method

renderMethod

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Sub SetRenderMethodDelegate( _
   ByVal renderMethod As System.Web.UI.RenderMethod _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim renderMethod As System.Web.UI.RenderMethod

instance.SetRenderMethodDelegate(renderMethod)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod renderMethod
)
Delphi
public procedure SetRenderMethodDelegate(
    renderMethod: System.Web.UI.RenderMethod
);
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function SetRenderMethodDelegate(
   renderMethod : System.Web.UI.RenderMethod
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod* renderMethod
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod^ renderMethod
)

Parameters

renderMethod

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


SetSessionTheme Method

[image]
Intersoft WebTextEditor Documentation
SetSessionTheme Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : SetSessionTheme Method

themeInfo

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetSessionTheme( _
   ByVal themeInfo As ISNet.WebUI.ThemeInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim themeInfo As ISNet.WebUI.ThemeInfo

instance.SetSessionTheme(themeInfo)
C#
public void SetSessionTheme(
   ISNet.WebUI.ThemeInfo themeInfo
)
Delphi
public procedure SetSessionTheme(
    themeInfo: ISNet.WebUI.ThemeInfo
);
JScript
public function SetSessionTheme(
   themeInfo : ISNet.WebUI.ThemeInfo
);
Managed Extensions for C++
public: void SetSessionTheme(
   ISNet.WebUI.ThemeInfo* themeInfo
)
C++/CLI
public:
void SetSessionTheme(
   ISNet.WebUI.ThemeInfo^ themeInfo
)

Parameters

themeInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


SetTheme Method

[image]
Intersoft WebTextEditor Documentation
SetTheme Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : SetTheme Method

themeInfo

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub SetTheme( _
   ByVal themeInfo As ISNet.WebUI.ThemeInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim themeInfo As ISNet.WebUI.ThemeInfo

instance.SetTheme(themeInfo)
C#
protected virtual void SetTheme(
   ISNet.WebUI.ThemeInfo themeInfo
)
Delphi
protected procedure SetTheme(
    themeInfo: ISNet.WebUI.ThemeInfo
); virtual;
JScript
protected function SetTheme(
   themeInfo : ISNet.WebUI.ThemeInfo
);
Managed Extensions for C++
protected: virtual void SetTheme(
   ISNet.WebUI.ThemeInfo* themeInfo
)
C++/CLI
protected:
virtual void SetTheme(
   ISNet.WebUI.ThemeInfo^ themeInfo
)

Parameters

themeInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


ShouldReturnJson Method

[image]
Intersoft WebTextEditor Documentation
ShouldReturnJson Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : ShouldReturnJson Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ShouldReturnJson() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Boolean

value = instance.ShouldReturnJson()
C#
public virtual System.bool ShouldReturnJson()
Delphi
public function ShouldReturnJson(): System.Boolean; virtual;
JScript
public function ShouldReturnJson() : System.boolean;
Managed Extensions for C++
public: virtual System.bool ShouldReturnJson();
C++/CLI
public:
virtual System.bool ShouldReturnJson();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


ShowAboutBox Method

[image]
Intersoft WebTextEditor Documentation
ShowAboutBox Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : ShowAboutBox Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Sub ShowAboutBox()
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker

instance.ShowAboutBox()
C#
protected void ShowAboutBox()
Delphi
protected procedure ShowAboutBox();
JScript
protected function ShowAboutBox();
Managed Extensions for C++
protected: void ShowAboutBox();
C++/CLI
protected:
void ShowAboutBox();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


Site Property

[image]
Intersoft WebTextEditor Documentation
Site Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : Site Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<WebSysDescriptionAttribute("Site of the control.")>
<System.ComponentModel.BrowsableAttribute(False)>
Public Property Site As System.ComponentModel.ISite
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.ComponentModel.ISite

instance.Site = value

value = instance.Site
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[WebSysDescriptionAttribute("Site of the control.")]
[System.ComponentModel.BrowsableAttribute(false)]
public System.ComponentModel.ISite Site {get; set;}
Delphi
public read-write property Site: System.ComponentModel.ISite;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
WebSysDescriptionAttribute("Site of the control.")
System.ComponentModel.BrowsableAttribute()
public function get,set Site : System.ComponentModel.ISite
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[WebSysDescriptionAttribute("Site of the control.")]
[System.ComponentModel.BrowsableAttribute(false)]
public: __property System.ComponentModel.ISite* get_Site();
public: __property void set_Site(
   System.ComponentModel.ISite* value
);
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[WebSysDescriptionAttribute("Site of the control.")]
[System.ComponentModel.BrowsableAttribute(false)]
public:
property System.ComponentModel.ISite^ Site {
   System.ComponentModel.ISite^ get();
   void set (    System.ComponentModel.ISite^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


SkinID Property

[image]
Intersoft WebTextEditor Documentation
SkinID Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : SkinID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(True)>
Public Overridable Property SkinID As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.String

instance.SkinID = value

value = instance.SkinID
C#
[System.ComponentModel.BrowsableAttribute(true)]
public virtual System.string SkinID {get; set;}
Delphi
public read-write property SkinID: System.String; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
public function get,set SkinID : System.String
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(true)]
public: __property virtual System.string* get_SkinID();
public: __property virtual void set_SkinID(
   System.string* value
);
C++/CLI
[System.ComponentModel.BrowsableAttribute(true)]
public:
virtual property System.String^ SkinID {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


Style Property

[image]
Intersoft WebTextEditor Documentation
Style Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : Style Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
<WebSysDescriptionAttribute("Low-level access to control styles.")>
Public ReadOnly Property Style As System.Web.UI.CssStyleCollection
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Web.UI.CssStyleCollection

value = instance.Style
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[WebSysDescriptionAttribute("Low-level access to control styles.")]
public System.Web.UI.CssStyleCollection Style {get;}
Delphi
public read-only property Style: System.Web.UI.CssStyleCollection;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
WebSysDescriptionAttribute("Low-level access to control styles.")
public function get Style : System.Web.UI.CssStyleCollection
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[WebSysDescriptionAttribute("Low-level access to control styles.")]
public: __property System.Web.UI.CssStyleCollection* get_Style();
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[WebSysDescriptionAttribute("Low-level access to control styles.")]
public:
property System.Web.UI.CssStyleCollection^ Style {
   System.Web.UI.CssStyleCollection^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


SupportsDisabledAttribute Property

[image]
Intersoft WebTextEditor Documentation
SupportsDisabledAttribute Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : SupportsDisabledAttribute Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
Public Overridable ReadOnly Property SupportsDisabledAttribute As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Boolean

value = instance.SupportsDisabledAttribute
C#
[System.ComponentModel.BrowsableAttribute(false)]
public virtual System.bool SupportsDisabledAttribute {get;}
Delphi
public read-only property SupportsDisabledAttribute: System.Boolean; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
public function get SupportsDisabledAttribute : System.boolean
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
public: __property virtual System.bool get_SupportsDisabledAttribute();
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
public:
virtual property System.bool SupportsDisabledAttribute {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


SupportXMLCultureInfo Property

[image]
Intersoft WebTextEditor Documentation
SupportXMLCultureInfo Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : SupportXMLCultureInfo Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Overridable ReadOnly Property SupportXMLCultureInfo As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Boolean

value = instance.SupportXMLCultureInfo
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public virtual System.bool SupportXMLCultureInfo {get;}
Delphi
public read-only property SupportXMLCultureInfo: System.Boolean; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get SupportXMLCultureInfo : System.boolean
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property virtual System.bool get_SupportXMLCultureInfo();
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
virtual property System.bool SupportXMLCultureInfo {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


TabIndex Property

[image]
Intersoft WebTextEditor Documentation
TabIndex Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : TabIndex Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Overridable Property TabIndex As System.Short
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Short

instance.TabIndex = value

value = instance.TabIndex
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public virtual System.short TabIndex {get; set;}
Delphi
public read-write property TabIndex: System.Int16; virtual;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set TabIndex : System.short
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property virtual System.short get_TabIndex();
public: __property virtual void set_TabIndex(
   System.short value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
virtual property System.short TabIndex {
   System.short get();
   void set (    System.short value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


TagKey Property

[image]
Intersoft WebTextEditor Documentation
TagKey Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : TagKey Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
Protected Overridable ReadOnly Property TagKey As System.Web.UI.HtmlTextWriterTag
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Web.UI.HtmlTextWriterTag

value = instance.TagKey
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
protected virtual System.Web.UI.HtmlTextWriterTag TagKey {get;}
Delphi
protected read-only property TagKey: System.Web.UI.HtmlTextWriterTag; virtual;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
protected function get TagKey : System.Web.UI.HtmlTextWriterTag
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
protected: __property virtual System.Web.UI.HtmlTextWriterTag get_TagKey();
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
protected:
virtual property System.Web.UI.HtmlTextWriterTag TagKey {
   System.Web.UI.HtmlTextWriterTag get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


TagName Property

[image]
Intersoft WebTextEditor Documentation
TagName Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : TagName Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Protected Overridable ReadOnly Property TagName As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.String

value = instance.TagName
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
protected virtual System.string TagName {get;}
Delphi
protected read-only property TagName: System.String; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
protected function get TagName : System.String
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
protected: __property virtual System.string* get_TagName();
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
protected:
virtual property System.String^ TagName {
   System.String^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


TemplateControl Property

[image]
Intersoft WebTextEditor Documentation
TemplateControl Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : TemplateControl Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
<WebSysDescriptionAttribute("The TemplateControl that hosts this control.")>
<System.ComponentModel.BindableAttribute(Bindable=False, Direction=BindingDirection.OneWay)>
Public Property TemplateControl As System.Web.UI.TemplateControl
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Web.UI.TemplateControl

instance.TemplateControl = value

value = instance.TemplateControl
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[WebSysDescriptionAttribute("The TemplateControl that hosts this control.")]
[System.ComponentModel.BindableAttribute(Bindable=false, Direction=BindingDirection.OneWay)]
public System.Web.UI.TemplateControl TemplateControl {get; set;}
Delphi
public read-write property TemplateControl: System.Web.UI.TemplateControl;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
WebSysDescriptionAttribute("The TemplateControl that hosts this control.")
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set TemplateControl : System.Web.UI.TemplateControl
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[WebSysDescriptionAttribute("The TemplateControl that hosts this control.")]
[System.ComponentModel.BindableAttribute(Bindable=false, Direction=BindingDirection.OneWay)]
public: __property System.Web.UI.TemplateControl* get_TemplateControl();
public: __property void set_TemplateControl(
   System.Web.UI.TemplateControl* value
);
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[WebSysDescriptionAttribute("The TemplateControl that hosts this control.")]
[System.ComponentModel.BindableAttribute(Bindable=false, Direction=BindingDirection.OneWay)]
public:
property System.Web.UI.TemplateControl^ TemplateControl {
   System.Web.UI.TemplateControl^ get();
   void set (    System.Web.UI.TemplateControl^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


TemplateSourceDirectory Property

[image]
Intersoft WebTextEditor Documentation
TemplateSourceDirectory Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : TemplateSourceDirectory Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<WebSysDescriptionAttribute("The virtual directory of the Page or UserControl that contains this control.")>
Public Overridable ReadOnly Property TemplateSourceDirectory As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.String

value = instance.TemplateSourceDirectory
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[WebSysDescriptionAttribute("The virtual directory of the Page or UserControl that contains this control.")]
public virtual System.string TemplateSourceDirectory {get;}
Delphi
public read-only property TemplateSourceDirectory: System.String; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
WebSysDescriptionAttribute("The virtual directory of the Page or UserControl that contains this control.")
public function get TemplateSourceDirectory : System.String
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[WebSysDescriptionAttribute("The virtual directory of the Page or UserControl that contains this control.")]
public: __property virtual System.string* get_TemplateSourceDirectory();
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[WebSysDescriptionAttribute("The virtual directory of the Page or UserControl that contains this control.")]
public:
virtual property System.String^ TemplateSourceDirectory {
   System.String^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


ToolTip Property

[image]
Intersoft WebTextEditor Documentation
ToolTip Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : ToolTip Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overridable Property ToolTip As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.String

instance.ToolTip = value

value = instance.ToolTip
C#
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public virtual System.string ToolTip {get; set;}
Delphi
public read-write property ToolTip: System.String; virtual;
JScript
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set ToolTip : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property virtual System.string* get_ToolTip();
public: __property virtual void set_ToolTip(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
virtual property System.String^ ToolTip {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


TrackViewState Method

[image]
Intersoft WebTextEditor Documentation
TrackViewState Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : TrackViewState Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub TrackViewState()
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker

instance.TrackViewState()
C#
protected virtual void TrackViewState()
Delphi
protected procedure TrackViewState(); virtual;
JScript
protected function TrackViewState();
Managed Extensions for C++
protected: virtual void TrackViewState();
C++/CLI
protected:
virtual void TrackViewState();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


UniqueID Property

[image]
Intersoft WebTextEditor Documentation
UniqueID Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : UniqueID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<WebSysDescriptionAttribute("The unique ID of the control within the page.")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Overridable ReadOnly Property UniqueID As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.String

value = instance.UniqueID
C#
[System.ComponentModel.BrowsableAttribute(false)]
[WebSysDescriptionAttribute("The unique ID of the control within the page.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public virtual System.string UniqueID {get;}
Delphi
public read-only property UniqueID: System.String; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
WebSysDescriptionAttribute("The unique ID of the control within the page.")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get UniqueID : System.String
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[WebSysDescriptionAttribute("The unique ID of the control within the page.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property virtual System.string* get_UniqueID();
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[WebSysDescriptionAttribute("The unique ID of the control within the page.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
virtual property System.String^ UniqueID {
   System.String^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


Unload Event

[image]
Intersoft WebTextEditor Documentation
Unload Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : Unload Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the page is unloaded.")>
Public Event Unload As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim handler As System.EventHandler

AddHandler instance.Unload, handler
C#
[WebSysDescriptionAttribute("Fires when the page is unloaded.")]
public event System.EventHandler Unload
Delphi
public event Unload: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the page is unloaded.")]
public: __event System.EventHandler* Unload
C++/CLI
[WebSysDescriptionAttribute("Fires when the page is unloaded.")]
public:
event System.EventHandler^ Unload

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


UseDeepCloneForViewStateStorage Method

[image]
Intersoft WebTextEditor Documentation
UseDeepCloneForViewStateStorage Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : UseDeepCloneForViewStateStorage Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function UseDeepCloneForViewStateStorage() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Boolean

value = instance.UseDeepCloneForViewStateStorage()
C#
protected virtual System.bool UseDeepCloneForViewStateStorage()
Delphi
protected function UseDeepCloneForViewStateStorage(): System.Boolean; virtual;
JScript
protected function UseDeepCloneForViewStateStorage() : System.boolean;
Managed Extensions for C++
protected: virtual System.bool UseDeepCloneForViewStateStorage();
C++/CLI
protected:
virtual System.bool UseDeepCloneForViewStateStorage();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


UseMemoryStreamStateType Method

[image]
Intersoft WebTextEditor Documentation
UseMemoryStreamStateType Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : UseMemoryStreamStateType Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function UseMemoryStreamStateType() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Boolean

value = instance.UseMemoryStreamStateType()
C#
protected virtual System.bool UseMemoryStreamStateType()
Delphi
protected function UseMemoryStreamStateType(): System.Boolean; virtual;
JScript
protected function UseMemoryStreamStateType() : System.boolean;
Managed Extensions for C++
protected: virtual System.bool UseMemoryStreamStateType();
C++/CLI
protected:
virtual System.bool UseMemoryStreamStateType();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


ValidateRequestMode Property

[image]
Intersoft WebTextEditor Documentation
ValidateRequestMode Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : ValidateRequestMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebCategoryAttribute("Behavior")>
<System.ComponentModel.DefaultValueAttribute()>
<WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")>
Public Overridable Property ValidateRequestMode As System.Web.UI.ValidateRequestMode
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Web.UI.ValidateRequestMode

instance.ValidateRequestMode = value

value = instance.ValidateRequestMode
C#
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")]
public virtual System.Web.UI.ValidateRequestMode ValidateRequestMode {get; set;}
Delphi
public read-write property ValidateRequestMode: System.Web.UI.ValidateRequestMode; virtual;
JScript
WebCategoryAttribute("Behavior")
System.ComponentModel.DefaultValueAttribute()
WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")
public function get,set ValidateRequestMode : System.Web.UI.ValidateRequestMode
Managed Extensions for C++
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")]
public: __property virtual System.Web.UI.ValidateRequestMode get_ValidateRequestMode();
public: __property virtual void set_ValidateRequestMode(
   System.Web.UI.ValidateRequestMode value
);
C++/CLI
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")]
public:
virtual property System.Web.UI.ValidateRequestMode ValidateRequestMode {
   System.Web.UI.ValidateRequestMode get();
   void set (    System.Web.UI.ValidateRequestMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


ViewState Property

[image]
Intersoft WebTextEditor Documentation
ViewState Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : ViewState Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Current viewstate of the control.")>
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Protected Overridable ReadOnly Property ViewState As System.Web.UI.StateBag
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Web.UI.StateBag

value = instance.ViewState
C#
[WebSysDescriptionAttribute("Current viewstate of the control.")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
protected virtual System.Web.UI.StateBag ViewState {get;}
Delphi
protected read-only property ViewState: System.Web.UI.StateBag; virtual;
JScript
WebSysDescriptionAttribute("Current viewstate of the control.")
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
protected function get ViewState : System.Web.UI.StateBag
Managed Extensions for C++
[WebSysDescriptionAttribute("Current viewstate of the control.")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
protected: __property virtual System.Web.UI.StateBag* get_ViewState();
C++/CLI
[WebSysDescriptionAttribute("Current viewstate of the control.")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
protected:
virtual property System.Web.UI.StateBag^ ViewState {
   System.Web.UI.StateBag^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


ViewStateIgnoresCase Property

[image]
Intersoft WebTextEditor Documentation
ViewStateIgnoresCase Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : ViewStateIgnoresCase Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
Protected Overridable ReadOnly Property ViewStateIgnoresCase As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Boolean

value = instance.ViewStateIgnoresCase
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
protected virtual System.bool ViewStateIgnoresCase {get;}
Delphi
protected read-only property ViewStateIgnoresCase: System.Boolean; virtual;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
protected function get ViewStateIgnoresCase : System.boolean
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
protected: __property virtual System.bool get_ViewStateIgnoresCase();
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
protected:
virtual property System.bool ViewStateIgnoresCase {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


ViewStateItems Property

[image]
Intersoft WebTextEditor Documentation
ViewStateItems Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : ViewStateItems Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.CategoryAttribute("View State Settings")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the items to be stored in view state storage.")>
Public Overridable Property ViewStateItems As ISNet.WebUI.ViewStateItem
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As ISNet.WebUI.ViewStateItem

instance.ViewStateItems = value

value = instance.ViewStateItems
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the items to be stored in view state storage.")]
public virtual ISNet.WebUI.ViewStateItem ViewStateItems {get; set;}
Delphi
public read-write property ViewStateItems: ISNet.WebUI.ViewStateItem; virtual;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.CategoryAttribute("View State Settings")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the items to be stored in view state storage.")
public function get,set ViewStateItems : ISNet.WebUI.ViewStateItem
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the items to be stored in view state storage.")]
public: __property virtual ISNet.WebUI.ViewStateItem get_ViewStateItems();
public: __property virtual void set_ViewStateItems(
   ISNet.WebUI.ViewStateItem value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the items to be stored in view state storage.")]
public:
virtual property ISNet.WebUI.ViewStateItem ViewStateItems {
   ISNet.WebUI.ViewStateItem get();
   void set (    ISNet.WebUI.ViewStateItem value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


viewStateLoaded Field

[image]
Intersoft WebTextEditor Documentation
viewStateLoaded Field
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : viewStateLoaded Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected viewStateLoaded As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Boolean

value = instance.viewStateLoaded

instance.viewStateLoaded = value
C#
protected System.bool viewStateLoaded
Delphi
protected field viewStateLoaded: System.Boolean;
JScript
protected var viewStateLoaded : System.boolean;
Managed Extensions for C++
protected: System.bool viewStateLoaded
C++/CLI
protected:
System.bool viewStateLoaded

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


ViewStateMode Property

[image]
Intersoft WebTextEditor Documentation
ViewStateMode Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : ViewStateMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.ThemeableAttribute(False)>
<WebCategoryAttribute("Behavior")>
<WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Overridable Property ViewStateMode As System.Web.UI.ViewStateMode
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Web.UI.ViewStateMode

instance.ViewStateMode = value

value = instance.ViewStateMode
C#
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")]
[System.ComponentModel.DefaultValueAttribute()]
public virtual System.Web.UI.ViewStateMode ViewStateMode {get; set;}
Delphi
public read-write property ViewStateMode: System.Web.UI.ViewStateMode; virtual;
JScript
System.Web.UI.ThemeableAttribute()
WebCategoryAttribute("Behavior")
WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")
System.ComponentModel.DefaultValueAttribute()
public function get,set ViewStateMode : System.Web.UI.ViewStateMode
Managed Extensions for C++
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property virtual System.Web.UI.ViewStateMode get_ViewStateMode();
public: __property virtual void set_ViewStateMode(
   System.Web.UI.ViewStateMode value
);
C++/CLI
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
virtual property System.Web.UI.ViewStateMode ViewStateMode {
   System.Web.UI.ViewStateMode get();
   void set (    System.Web.UI.ViewStateMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


ViewStateServerConnection Property

[image]
Intersoft WebTextEditor Documentation
ViewStateServerConnection Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : ViewStateServerConnection Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the server connection string for file server-based viewstate storage.")>
<System.ComponentModel.CategoryAttribute("View State Settings")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overridable Property ViewStateServerConnection As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.String

instance.ViewStateServerConnection = value

value = instance.ViewStateServerConnection
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the server connection string for file server-based viewstate storage.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public virtual System.string ViewStateServerConnection {get; set;}
Delphi
public read-write property ViewStateServerConnection: System.String; virtual;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the server connection string for file server-based viewstate storage.")
System.ComponentModel.CategoryAttribute("View State Settings")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set ViewStateServerConnection : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the server connection string for file server-based viewstate storage.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property virtual System.string* get_ViewStateServerConnection();
public: __property virtual void set_ViewStateServerConnection(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the server connection string for file server-based viewstate storage.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
virtual property System.String^ ViewStateServerConnection {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


ViewStateStorage Property

[image]
Intersoft WebTextEditor Documentation
ViewStateStorage Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : ViewStateStorage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the location to store the viewstate of this control.")>
<System.ComponentModel.CategoryAttribute("View State Settings")>
Public Overridable Property ViewStateStorage As ISNet.WebUI.StateCacheStorage
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As ISNet.WebUI.StateCacheStorage

instance.ViewStateStorage = value

value = instance.ViewStateStorage
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the location to store the viewstate of this control.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
public virtual ISNet.WebUI.StateCacheStorage ViewStateStorage {get; set;}
Delphi
public read-write property ViewStateStorage: ISNet.WebUI.StateCacheStorage; virtual;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.DescriptionAttribute("Gets or sets the location to store the viewstate of this control.")
System.ComponentModel.CategoryAttribute("View State Settings")
public function get,set ViewStateStorage : ISNet.WebUI.StateCacheStorage
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the location to store the viewstate of this control.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
public: __property virtual ISNet.WebUI.StateCacheStorage get_ViewStateStorage();
public: __property virtual void set_ViewStateStorage(
   ISNet.WebUI.StateCacheStorage value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the location to store the viewstate of this control.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
public:
virtual property ISNet.WebUI.StateCacheStorage ViewStateStorage {
   ISNet.WebUI.StateCacheStorage get();
   void set (    ISNet.WebUI.StateCacheStorage value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


Visible Property

[image]
Intersoft WebTextEditor Documentation
Visible Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : Visible Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Overridable Property Visible As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Boolean

instance.Visible = value

value = instance.Visible
C#
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public virtual System.bool Visible {get; set;}
Delphi
public read-write property Visible: System.Boolean; virtual;
JScript
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set Visible : System.boolean
Managed Extensions for C++
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property virtual System.bool get_Visible();
public: __property virtual void set_Visible(
   System.bool value
);
C++/CLI
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
virtual property System.bool Visible {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


XmlCompressionEnabled Property

[image]
Intersoft WebTextEditor Documentation
XmlCompressionEnabled Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebSpellChecker Class : XmlCompressionEnabled Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether the Xml used for clientside state storage should be compressed.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overridable Property XmlCompressionEnabled As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebSpellChecker
Dim value As System.Boolean

instance.XmlCompressionEnabled = value

value = instance.XmlCompressionEnabled
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the Xml used for clientside state storage should be compressed.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public virtual System.bool XmlCompressionEnabled {get; set;}
Delphi
public read-write property XmlCompressionEnabled: System.Boolean; virtual;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether the Xml used for clientside state storage should be compressed.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set XmlCompressionEnabled : System.boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the Xml used for clientside state storage should be compressed.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property virtual System.bool get_XmlCompressionEnabled();
public: __property virtual void set_XmlCompressionEnabled(
   System.bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the Xml used for clientside state storage should be compressed.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
virtual property System.bool XmlCompressionEnabled {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebSpellChecker Class
WebSpellChecker Members


WebTextEditor Class Fields

[image]
Intersoft WebTextEditor Documentation
WebTextEditor Class Fields
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditor Class

Glossary Item Box

For a list of all members of this type, see WebTextEditor members.

Protected Fields

 | Name | Description
Protected Field | isPagePreRender | (Inherited from ISNet.WebUI.ISNetControl)
Protected Field | renderDHTML | (Inherited from ISNet.WebUI.ISNetControl)
Protected Field | renderNS | (Inherited from ISNet.WebUI.ISNetControl)
Protected Field | viewStateLoaded | (Inherited from ISNet.WebUI.ISNetControl)
Top

See Also

Reference

WebTextEditor Class
ISNet.WebUI.WebTextEditor Namespace


WebTextEditorClientSideEvents Class Methods

[image]
Intersoft WebTextEditor Documentation
WebTextEditorClientSideEvents Class Methods
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorClientSideEvents Class

Glossary Item Box

For a list of all members of this type, see WebTextEditorClientSideEvents members.

Public Methods

 | Name | Description
Public Method | Clone | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | CopyFrom | Overloaded. (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | DeSerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetHashCode | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | GetObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | IsEmpty | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | Reset | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | SerializeObjectData | (Inherited from ISNet.WebUI.WebUIBaseClass)
Public Method | ToString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

Protected Methods

 | Name | Description
Protected Method | GetPropertyString | (Inherited from ISNet.WebUI.WebUIBaseClass)
Protected Method | IsInSerializationContext | (Inherited from ISNet.WebUI.WebUIBaseClass)
Top

See Also

Reference

WebTextEditorClientSideEvents Class
ISNet.WebUI.WebTextEditor Namespace


Clone Method

[image]
Intersoft WebTextEditor Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorClientSideEvents Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorClientSideEvents
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorClientSideEvents Class
WebTextEditorClientSideEvents Members


CopyFrom Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorClientSideEvents Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorClientSideEvents Class
WebTextEditorClientSideEvents Members


CopyFrom(Object) Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorClientSideEvents Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorClientSideEvents
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorClientSideEvents Class
WebTextEditorClientSideEvents Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorClientSideEvents Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorClientSideEvents
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorClientSideEvents Class
WebTextEditorClientSideEvents Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebTextEditor Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorClientSideEvents Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorClientSideEvents
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorClientSideEvents Class
WebTextEditorClientSideEvents Members


GetHashCode Method

[image]
Intersoft WebTextEditor Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorClientSideEvents Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorClientSideEvents
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorClientSideEvents Class
WebTextEditorClientSideEvents Members


GetObjectData Method

[image]
Intersoft WebTextEditor Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorClientSideEvents Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorClientSideEvents
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public virtual void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
); virtual;
JScript
public function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: virtual void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
virtual void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorClientSideEvents Class
WebTextEditorClientSideEvents Members


GetPropertyString Method

[image]
Intersoft WebTextEditor Documentation
GetPropertyString Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorClientSideEvents Class : GetPropertyString Method

v

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetPropertyString( _
   ByVal v As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorClientSideEvents
Dim v As System.String
Dim value As System.String

value = instance.GetPropertyString(v)
C#
protected virtual System.string GetPropertyString(
   System.string v
)
Delphi
protected function GetPropertyString(
    v: System.String
): System.String; virtual;
JScript
protected function GetPropertyString(
   v : System.String
) : System.String;
Managed Extensions for C++
protected: virtual System.string* GetPropertyString(
   System.string* v
)
C++/CLI
protected:
virtual System.String^ GetPropertyString(
   System.String^ v
)

Parameters

v

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorClientSideEvents Class
WebTextEditorClientSideEvents Members


IsEmpty Method

[image]
Intersoft WebTextEditor Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorClientSideEvents Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorClientSideEvents
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorClientSideEvents Class
WebTextEditorClientSideEvents Members


IsInSerializationContext Method

[image]
Intersoft WebTextEditor Documentation
IsInSerializationContext Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorClientSideEvents Class : IsInSerializationContext Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function IsInSerializationContext() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorClientSideEvents
Dim value As System.Boolean

value = instance.IsInSerializationContext()
C#
protected virtual System.bool IsInSerializationContext()
Delphi
protected function IsInSerializationContext(): System.Boolean; virtual;
JScript
protected function IsInSerializationContext() : System.boolean;
Managed Extensions for C++
protected: virtual System.bool IsInSerializationContext();
C++/CLI
protected:
virtual System.bool IsInSerializationContext();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorClientSideEvents Class
WebTextEditorClientSideEvents Members


Reset Method

[image]
Intersoft WebTextEditor Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorClientSideEvents Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorClientSideEvents

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorClientSideEvents Class
WebTextEditorClientSideEvents Members


SerializeObjectData Method

[image]
Intersoft WebTextEditor Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorClientSideEvents Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorClientSideEvents
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorClientSideEvents Class
WebTextEditorClientSideEvents Members


ToString Method

[image]
Intersoft WebTextEditor Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorClientSideEvents Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorClientSideEvents
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorClientSideEvents Class
WebTextEditorClientSideEvents Members


Clone Method

[image]
Intersoft WebTextEditor Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorCssFile Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorCssFile
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorCssFile Class
WebTextEditorCssFile Members


CopyFrom Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorCssFile Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorCssFile Class
WebTextEditorCssFile Members


CopyFrom(Object) Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorCssFile Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorCssFile
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorCssFile Class
WebTextEditorCssFile Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorCssFile Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorCssFile
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorCssFile Class
WebTextEditorCssFile Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebTextEditor Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorCssFile Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorCssFile
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorCssFile Class
WebTextEditorCssFile Members


GetHashCode Method

[image]
Intersoft WebTextEditor Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorCssFile Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorCssFile
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorCssFile Class
WebTextEditorCssFile Members


GetPropertyString Method

[image]
Intersoft WebTextEditor Documentation
GetPropertyString Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorCssFile Class : GetPropertyString Method

v

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetPropertyString( _
   ByVal v As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorCssFile
Dim v As System.String
Dim value As System.String

value = instance.GetPropertyString(v)
C#
protected virtual System.string GetPropertyString(
   System.string v
)
Delphi
protected function GetPropertyString(
    v: System.String
): System.String; virtual;
JScript
protected function GetPropertyString(
   v : System.String
) : System.String;
Managed Extensions for C++
protected: virtual System.string* GetPropertyString(
   System.string* v
)
C++/CLI
protected:
virtual System.String^ GetPropertyString(
   System.String^ v
)

Parameters

v

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorCssFile Class
WebTextEditorCssFile Members


IsEmpty Method

[image]
Intersoft WebTextEditor Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorCssFile Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorCssFile
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorCssFile Class
WebTextEditorCssFile Members


IsInSerializationContext Method

[image]
Intersoft WebTextEditor Documentation
IsInSerializationContext Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorCssFile Class : IsInSerializationContext Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function IsInSerializationContext() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorCssFile
Dim value As System.Boolean

value = instance.IsInSerializationContext()
C#
protected virtual System.bool IsInSerializationContext()
Delphi
protected function IsInSerializationContext(): System.Boolean; virtual;
JScript
protected function IsInSerializationContext() : System.boolean;
Managed Extensions for C++
protected: virtual System.bool IsInSerializationContext();
C++/CLI
protected:
virtual System.bool IsInSerializationContext();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorCssFile Class
WebTextEditorCssFile Members


Reset Method

[image]
Intersoft WebTextEditor Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorCssFile Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorCssFile

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorCssFile Class
WebTextEditorCssFile Members


SerializeObjectData Method

[image]
Intersoft WebTextEditor Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorCssFile Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorCssFile
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorCssFile Class
WebTextEditorCssFile Members


ToString Method

[image]
Intersoft WebTextEditor Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorCssFile Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorCssFile
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorCssFile Class
WebTextEditorCssFile Members


WebTextEditorDataSourceInfo Class Events

[image]
Intersoft WebTextEditor Documentation
WebTextEditorDataSourceInfo Class Events
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorDataSourceInfo Class

Glossary Item Box

For a list of all members of this type, see WebTextEditorDataSourceInfo members.

Public Events

 | Name | Description
Public Event | DataBinding | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Event | DataBound | (Inherited from ISNet.WebUI.DataSourceInfo)
Top

See Also

Reference

WebTextEditorDataSourceInfo Class
ISNet.WebUI.WebTextEditor Namespace


WebTextEditorDataSourceInfo Class Properties

[image]
Intersoft WebTextEditor Documentation
WebTextEditorDataSourceInfo Class Properties
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorDataSourceInfo Class

Glossary Item Box

For a list of all members of this type, see WebTextEditorDataSourceInfo members.

Public Properties

 | Name | Description
Public Property | Control | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Property | CurrentDataSource | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Property | IgnoreDataSourceViewChanged | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Property | IsBoundUsingDataSourceID | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Property | IsDataSourceViewValid | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Property | RequiresDataBinding | (Inherited from ISNet.WebUI.DataSourceInfo)
Public Property | SelectArguments | (Inherited from ISNet.WebUI.DataSourceInfo)
Top

See Also

Reference

WebTextEditorDataSourceInfo Class
ISNet.WebUI.WebTextEditor Namespace


Control Property

[image]
Intersoft WebTextEditor Documentation
Control Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorDataSourceInfo Class : Control Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Control As ISNet.WebUI.ISNetControl
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorDataSourceInfo
Dim value As ISNet.WebUI.ISNetControl

value = instance.Control
C#
public ISNet.WebUI.ISNetControl Control {get;}
Delphi
public read-only property Control: ISNet.WebUI.ISNetControl;
JScript
public function get Control : ISNet.WebUI.ISNetControl
Managed Extensions for C++
public: __property ISNet.WebUI.ISNetControl* get_Control();
C++/CLI
public:
property ISNet.WebUI.ISNetControl^ Control {
   ISNet.WebUI.ISNetControl^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorDataSourceInfo Class
WebTextEditorDataSourceInfo Members


CreateDataSourceSelectArguments Method

[image]
Intersoft WebTextEditor Documentation
CreateDataSourceSelectArguments Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorDataSourceInfo Class : CreateDataSourceSelectArguments Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function CreateDataSourceSelectArguments() As System.Web.UI.DataSourceSelectArguments
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorDataSourceInfo
Dim value As System.Web.UI.DataSourceSelectArguments

value = instance.CreateDataSourceSelectArguments()
C#
protected virtual System.Web.UI.DataSourceSelectArguments CreateDataSourceSelectArguments()
Delphi
protected function CreateDataSourceSelectArguments(): System.Web.UI.DataSourceSelectArguments; virtual;
JScript
protected function CreateDataSourceSelectArguments() : System.Web.UI.DataSourceSelectArguments;
Managed Extensions for C++
protected: virtual System.Web.UI.DataSourceSelectArguments* CreateDataSourceSelectArguments();
C++/CLI
protected:
virtual System.Web.UI.DataSourceSelectArguments^ CreateDataSourceSelectArguments();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorDataSourceInfo Class
WebTextEditorDataSourceInfo Members


CurrentDataSource Property

[image]
Intersoft WebTextEditor Documentation
CurrentDataSource Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorDataSourceInfo Class : CurrentDataSource Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property CurrentDataSource As System.Collections.IEnumerable
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorDataSourceInfo
Dim value As System.Collections.IEnumerable

value = instance.CurrentDataSource
C#
public System.Collections.IEnumerable CurrentDataSource {get;}
Delphi
public read-only property CurrentDataSource: System.Collections.IEnumerable;
JScript
public function get CurrentDataSource : System.Collections.IEnumerable
Managed Extensions for C++
public: __property System.Collections.IEnumerable* get_CurrentDataSource();
C++/CLI
public:
property System.Collections.IEnumerable^ CurrentDataSource {
   System.Collections.IEnumerable^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorDataSourceInfo Class
WebTextEditorDataSourceInfo Members


DataBind Method

[image]
Intersoft WebTextEditor Documentation
DataBind Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorDataSourceInfo Class : DataBind Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub DataBind()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorDataSourceInfo

instance.DataBind()
C#
public virtual void DataBind()
Delphi
public procedure DataBind(); virtual;
JScript
public function DataBind();
Managed Extensions for C++
public: virtual void DataBind();
C++/CLI
public:
virtual void DataBind();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorDataSourceInfo Class
WebTextEditorDataSourceInfo Members


DataBinding Event

[image]
Intersoft WebTextEditor Documentation
DataBinding Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorDataSourceInfo Class : DataBinding Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event DataBinding As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorDataSourceInfo
Dim handler As System.EventHandler

AddHandler instance.DataBinding, handler
C#
public event System.EventHandler DataBinding
Delphi
public event DataBinding: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
public: __event System.EventHandler* DataBinding
C++/CLI
public:
event System.EventHandler^ DataBinding

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorDataSourceInfo Class
WebTextEditorDataSourceInfo Members


DataBound Event

[image]
Intersoft WebTextEditor Documentation
DataBound Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorDataSourceInfo Class : DataBound Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event DataBound As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorDataSourceInfo
Dim handler As System.EventHandler

AddHandler instance.DataBound, handler
C#
public event System.EventHandler DataBound
Delphi
public event DataBound: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
public: __event System.EventHandler* DataBound
C++/CLI
public:
event System.EventHandler^ DataBound

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorDataSourceInfo Class
WebTextEditorDataSourceInfo Members


EnsureDataBound Method

[image]
Intersoft WebTextEditor Documentation
EnsureDataBound Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorDataSourceInfo Class : EnsureDataBound Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub EnsureDataBound()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorDataSourceInfo

instance.EnsureDataBound()
C#
public virtual void EnsureDataBound()
Delphi
public procedure EnsureDataBound(); virtual;
JScript
public function EnsureDataBound();
Managed Extensions for C++
public: virtual void EnsureDataBound();
C++/CLI
public:
virtual void EnsureDataBound();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorDataSourceInfo Class
WebTextEditorDataSourceInfo Members


FindControl Method

[image]
Intersoft WebTextEditor Documentation
FindControl Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorDataSourceInfo Class : FindControl Method

control
controlID

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function FindControl( _
   ByVal control As System.Web.UI.Control, _
   ByVal controlID As System.String _
) As System.Web.UI.Control
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorDataSourceInfo
Dim control As System.Web.UI.Control
Dim controlID As System.String
Dim value As System.Web.UI.Control

value = instance.FindControl(control, controlID)
C#
public System.Web.UI.Control FindControl(
   System.Web.UI.Control control,
   System.string controlID
)
Delphi
public function FindControl(
    control: System.Web.UI.Control;
    controlID: System.String
): System.Web.UI.Control;
JScript
public function FindControl(
   control : System.Web.UI.Control,
   controlID : System.String
) : System.Web.UI.Control;
Managed Extensions for C++
public: System.Web.UI.Control* FindControl(
   System.Web.UI.Control* control,
   System.string* controlID
)
C++/CLI
public:
System.Web.UI.Control^ FindControl(
   System.Web.UI.Control^ control,
   System.String^ controlID
)

Parameters

control
controlID

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorDataSourceInfo Class
WebTextEditorDataSourceInfo Members


GetData Method

[image]
Intersoft WebTextEditor Documentation
GetData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorDataSourceInfo Class : GetData Method

Glossary Item Box

Overload List

Overload | Description
GetData() | (Inherited from ISNet.WebUI.DataSourceInfo)
GetData(String) | (Inherited from ISNet.WebUI.DataSourceInfo)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorDataSourceInfo Class
WebTextEditorDataSourceInfo Members


GetData() Method

[image]
Intersoft WebTextEditor Documentation
GetData() Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorDataSourceInfo Class > GetData Method : GetData() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetData() As System.Web.UI.DataSourceView
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorDataSourceInfo
Dim value As System.Web.UI.DataSourceView

value = instance.GetData()
C#
public System.Web.UI.DataSourceView GetData()
Delphi
public function GetData(): System.Web.UI.DataSourceView;
JScript
public function GetData() : System.Web.UI.DataSourceView;
Managed Extensions for C++
public: System.Web.UI.DataSourceView* GetData();
C++/CLI
public:
System.Web.UI.DataSourceView^ GetData();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorDataSourceInfo Class
WebTextEditorDataSourceInfo Members
Overload List


GetData(String) Method

[image]
Intersoft WebTextEditor Documentation
GetData(String) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorDataSourceInfo Class > GetData Method : GetData(String) Method

viewName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetData( _
   ByVal viewName As System.String _
) As System.Web.UI.DataSourceView
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorDataSourceInfo
Dim viewName As System.String
Dim value As System.Web.UI.DataSourceView

value = instance.GetData(viewName)
C#
public System.Web.UI.DataSourceView GetData(
   System.string viewName
)
Delphi
public function GetData(
    viewName: System.String
): System.Web.UI.DataSourceView;
JScript
public function GetData(
   viewName : System.String
) : System.Web.UI.DataSourceView;
Managed Extensions for C++
public: System.Web.UI.DataSourceView* GetData(
   System.string* viewName
)
C++/CLI
public:
System.Web.UI.DataSourceView^ GetData(
   System.String^ viewName
)

Parameters

viewName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorDataSourceInfo Class
WebTextEditorDataSourceInfo Members
Overload List


GetDataSourceControl Method

[image]
Intersoft WebTextEditor Documentation
GetDataSourceControl Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorDataSourceInfo Class : GetDataSourceControl Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetDataSourceControl() As System.Web.UI.Control
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorDataSourceInfo
Dim value As System.Web.UI.Control

value = instance.GetDataSourceControl()
C#
public System.Web.UI.Control GetDataSourceControl()
Delphi
public function GetDataSourceControl(): System.Web.UI.Control;
JScript
public function GetDataSourceControl() : System.Web.UI.Control;
Managed Extensions for C++
public: System.Web.UI.Control* GetDataSourceControl();
C++/CLI
public:
System.Web.UI.Control^ GetDataSourceControl();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorDataSourceInfo Class
WebTextEditorDataSourceInfo Members


GetDataSourceID Method

[image]
Intersoft WebTextEditor Documentation
GetDataSourceID Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorDataSourceInfo Class : GetDataSourceID Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetDataSourceID() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorDataSourceInfo
Dim value As System.String

value = instance.GetDataSourceID()
C#
public System.string GetDataSourceID()
Delphi
public function GetDataSourceID(): System.String;
JScript
public function GetDataSourceID() : System.String;
Managed Extensions for C++
public: System.string* GetDataSourceID();
C++/CLI
public:
System.String^ GetDataSourceID();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorDataSourceInfo Class
WebTextEditorDataSourceInfo Members


GetSelectParameters Method

[image]
Intersoft WebTextEditor Documentation
GetSelectParameters Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorDataSourceInfo Class : GetSelectParameters Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetSelectParameters() As System.Web.UI.WebControls.ParameterCollection
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorDataSourceInfo
Dim value As System.Web.UI.WebControls.ParameterCollection

value = instance.GetSelectParameters()
C#
public System.Web.UI.WebControls.ParameterCollection GetSelectParameters()
Delphi
public function GetSelectParameters(): System.Web.UI.WebControls.ParameterCollection;
JScript
public function GetSelectParameters() : System.Web.UI.WebControls.ParameterCollection;
Managed Extensions for C++
public: System.Web.UI.WebControls.ParameterCollection* GetSelectParameters();
C++/CLI
public:
System.Web.UI.WebControls.ParameterCollection^ GetSelectParameters();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorDataSourceInfo Class
WebTextEditorDataSourceInfo Members


GetTable Method

[image]
Intersoft WebTextEditor Documentation
GetTable Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorDataSourceInfo Class : GetTable Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetTable( _
   ByVal name As System.String _
) As ISNet.WebUI.IDataSourceTable
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorDataSourceInfo
Dim name As System.String
Dim value As ISNet.WebUI.IDataSourceTable

value = instance.GetTable(name)
C#
public ISNet.WebUI.IDataSourceTable GetTable(
   System.string name
)
Delphi
public function GetTable(
    name: System.String
): ISNet.WebUI.IDataSourceTable;
JScript
public function GetTable(
   name : System.String
) : ISNet.WebUI.IDataSourceTable;
Managed Extensions for C++
public: ISNet.WebUI.IDataSourceTable* GetTable(
   System.string* name
)
C++/CLI
public:
ISNet.WebUI.IDataSourceTable^ GetTable(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorDataSourceInfo Class
WebTextEditorDataSourceInfo Members


IgnoreDataSourceViewChanged Property

[image]
Intersoft WebTextEditor Documentation
IgnoreDataSourceViewChanged Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorDataSourceInfo Class : IgnoreDataSourceViewChanged Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public WriteOnly Property IgnoreDataSourceViewChanged As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorDataSourceInfo

instance.IgnoreDataSourceViewChanged = value
C#
public System.bool IgnoreDataSourceViewChanged {set;}
Delphi
public write-only property IgnoreDataSourceViewChanged: System.Boolean;
JScript
public function set IgnoreDataSourceViewChanged : System.boolean
Managed Extensions for C++
public: __property void set_IgnoreDataSourceViewChanged(
   System.bool value
);
C++/CLI
public:
property System.bool IgnoreDataSourceViewChanged {
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorDataSourceInfo Class
WebTextEditorDataSourceInfo Members


IsBoundUsingDataSourceID Property

[image]
Intersoft WebTextEditor Documentation
IsBoundUsingDataSourceID Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorDataSourceInfo Class : IsBoundUsingDataSourceID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsBoundUsingDataSourceID As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorDataSourceInfo
Dim value As System.Boolean

value = instance.IsBoundUsingDataSourceID
C#
public System.bool IsBoundUsingDataSourceID {get;}
Delphi
public read-only property IsBoundUsingDataSourceID: System.Boolean;
JScript
public function get IsBoundUsingDataSourceID : System.boolean
Managed Extensions for C++
public: __property System.bool get_IsBoundUsingDataSourceID();
C++/CLI
public:
property System.bool IsBoundUsingDataSourceID {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorDataSourceInfo Class
WebTextEditorDataSourceInfo Members


IsDataSourceViewValid Property

[image]
Intersoft WebTextEditor Documentation
IsDataSourceViewValid Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorDataSourceInfo Class : IsDataSourceViewValid Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property IsDataSourceViewValid As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorDataSourceInfo
Dim value As System.Boolean

value = instance.IsDataSourceViewValid
C#
public System.bool IsDataSourceViewValid {get;}
Delphi
public read-only property IsDataSourceViewValid: System.Boolean;
JScript
public function get IsDataSourceViewValid : System.boolean
Managed Extensions for C++
public: __property System.bool get_IsDataSourceViewValid();
C++/CLI
public:
property System.bool IsDataSourceViewValid {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorDataSourceInfo Class
WebTextEditorDataSourceInfo Members


IsIntersoftDataSourceControl Method

[image]
Intersoft WebTextEditor Documentation
IsIntersoftDataSourceControl Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorDataSourceInfo Class : IsIntersoftDataSourceControl Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsIntersoftDataSourceControl() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorDataSourceInfo
Dim value As System.Boolean

value = instance.IsIntersoftDataSourceControl()
C#
public System.bool IsIntersoftDataSourceControl()
Delphi
public function IsIntersoftDataSourceControl(): System.Boolean;
JScript
public function IsIntersoftDataSourceControl() : System.boolean;
Managed Extensions for C++
public: System.bool IsIntersoftDataSourceControl();
C++/CLI
public:
System.bool IsIntersoftDataSourceControl();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorDataSourceInfo Class
WebTextEditorDataSourceInfo Members


OnDataSourceViewSelectCallback Method

[image]
Intersoft WebTextEditor Documentation
OnDataSourceViewSelectCallback Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorDataSourceInfo Class : OnDataSourceViewSelectCallback Method

data

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnDataSourceViewSelectCallback( _
   ByVal data As System.Collections.IEnumerable _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorDataSourceInfo
Dim data As System.Collections.IEnumerable

instance.OnDataSourceViewSelectCallback(data)
C#
protected virtual void OnDataSourceViewSelectCallback(
   System.Collections.IEnumerable data
)
Delphi
protected procedure OnDataSourceViewSelectCallback(
    data: System.Collections.IEnumerable
); virtual;
JScript
protected function OnDataSourceViewSelectCallback(
   data : System.Collections.IEnumerable
);
Managed Extensions for C++
protected: virtual void OnDataSourceViewSelectCallback(
   System.Collections.IEnumerable* data
)
C++/CLI
protected:
virtual void OnDataSourceViewSelectCallback(
   System.Collections.IEnumerable^ data
)

Parameters

data

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorDataSourceInfo Class
WebTextEditorDataSourceInfo Members


RequiresDataBinding Property

[image]
Intersoft WebTextEditor Documentation
RequiresDataBinding Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorDataSourceInfo Class : RequiresDataBinding Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Property RequiresDataBinding As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorDataSourceInfo
Dim value As System.Boolean

instance.RequiresDataBinding = value

value = instance.RequiresDataBinding
C#
public System.bool RequiresDataBinding {get; set;}
Delphi
public read-write property RequiresDataBinding: System.Boolean;
JScript
public function get,set RequiresDataBinding : System.boolean
Managed Extensions for C++
public: __property System.bool get_RequiresDataBinding();
public: __property void set_RequiresDataBinding(
   System.bool value
);
C++/CLI
public:
property System.bool RequiresDataBinding {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorDataSourceInfo Class
WebTextEditorDataSourceInfo Members


Reset Method

[image]
Intersoft WebTextEditor Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorDataSourceInfo Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorDataSourceInfo

instance.Reset()
C#
protected virtual void Reset()
Delphi
protected procedure Reset(); virtual;
JScript
protected function Reset();
Managed Extensions for C++
protected: virtual void Reset();
C++/CLI
protected:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorDataSourceInfo Class
WebTextEditorDataSourceInfo Members


SelectArguments Property

[image]
Intersoft WebTextEditor Documentation
SelectArguments Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorDataSourceInfo Class : SelectArguments Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property SelectArguments As System.Web.UI.DataSourceSelectArguments
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorDataSourceInfo
Dim value As System.Web.UI.DataSourceSelectArguments

value = instance.SelectArguments
C#
public System.Web.UI.DataSourceSelectArguments SelectArguments {get;}
Delphi
public read-only property SelectArguments: System.Web.UI.DataSourceSelectArguments;
JScript
public function get SelectArguments : System.Web.UI.DataSourceSelectArguments
Managed Extensions for C++
public: __property System.Web.UI.DataSourceSelectArguments* get_SelectArguments();
C++/CLI
public:
property System.Web.UI.DataSourceSelectArguments^ SelectArguments {
   System.Web.UI.DataSourceSelectArguments^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorDataSourceInfo Class
WebTextEditorDataSourceInfo Members


SetViewValid Method

[image]
Intersoft WebTextEditor Documentation
SetViewValid Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorDataSourceInfo Class : SetViewValid Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetViewValid()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorDataSourceInfo

instance.SetViewValid()
C#
public void SetViewValid()
Delphi
public procedure SetViewValid();
JScript
public function SetViewValid();
Managed Extensions for C++
public: void SetViewValid();
C++/CLI
public:
void SetViewValid();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorDataSourceInfo Class
WebTextEditorDataSourceInfo Members


ValidateDataSource Method

[image]
Intersoft WebTextEditor Documentation
ValidateDataSource Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorDataSourceInfo Class : ValidateDataSource Method

dataSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ValidateDataSource( _
   ByVal dataSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorDataSourceInfo
Dim dataSource As System.Object

instance.ValidateDataSource(dataSource)
C#
public void ValidateDataSource(
   System.object dataSource
)
Delphi
public procedure ValidateDataSource(
    dataSource: System.TObject
);
JScript
public function ValidateDataSource(
   dataSource : System.Object
);
Managed Extensions for C++
public: void ValidateDataSource(
   System.Object* dataSource
)
C++/CLI
public:
void ValidateDataSource(
   System.Object^ dataSource
)

Parameters

dataSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorDataSourceInfo Class
WebTextEditorDataSourceInfo Members


Clone Method

[image]
Intersoft WebTextEditor Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorEditorSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorEditorSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorEditorSettings Class
WebTextEditorEditorSettings Members


CopyFrom Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorEditorSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorEditorSettings Class
WebTextEditorEditorSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorEditorSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorEditorSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorEditorSettings Class
WebTextEditorEditorSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorEditorSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorEditorSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorEditorSettings Class
WebTextEditorEditorSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebTextEditor Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorEditorSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorEditorSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorEditorSettings Class
WebTextEditorEditorSettings Members


GetHashCode Method

[image]
Intersoft WebTextEditor Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorEditorSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorEditorSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorEditorSettings Class
WebTextEditorEditorSettings Members


GetPropertyString Method

[image]
Intersoft WebTextEditor Documentation
GetPropertyString Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorEditorSettings Class : GetPropertyString Method

v

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetPropertyString( _
   ByVal v As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorEditorSettings
Dim v As System.String
Dim value As System.String

value = instance.GetPropertyString(v)
C#
protected virtual System.string GetPropertyString(
   System.string v
)
Delphi
protected function GetPropertyString(
    v: System.String
): System.String; virtual;
JScript
protected function GetPropertyString(
   v : System.String
) : System.String;
Managed Extensions for C++
protected: virtual System.string* GetPropertyString(
   System.string* v
)
C++/CLI
protected:
virtual System.String^ GetPropertyString(
   System.String^ v
)

Parameters

v

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorEditorSettings Class
WebTextEditorEditorSettings Members


IsEmpty Method

[image]
Intersoft WebTextEditor Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorEditorSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorEditorSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorEditorSettings Class
WebTextEditorEditorSettings Members


IsInSerializationContext Method

[image]
Intersoft WebTextEditor Documentation
IsInSerializationContext Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorEditorSettings Class : IsInSerializationContext Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function IsInSerializationContext() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorEditorSettings
Dim value As System.Boolean

value = instance.IsInSerializationContext()
C#
protected virtual System.bool IsInSerializationContext()
Delphi
protected function IsInSerializationContext(): System.Boolean; virtual;
JScript
protected function IsInSerializationContext() : System.boolean;
Managed Extensions for C++
protected: virtual System.bool IsInSerializationContext();
C++/CLI
protected:
virtual System.bool IsInSerializationContext();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorEditorSettings Class
WebTextEditorEditorSettings Members


Reset Method

[image]
Intersoft WebTextEditor Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorEditorSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorEditorSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorEditorSettings Class
WebTextEditorEditorSettings Members


SerializeObjectData Method

[image]
Intersoft WebTextEditor Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorEditorSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorEditorSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorEditorSettings Class
WebTextEditorEditorSettings Members


ToString Method

[image]
Intersoft WebTextEditor Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorEditorSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorEditorSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorEditorSettings Class
WebTextEditorEditorSettings Members


Clone Method

[image]
Intersoft WebTextEditor Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorFileUploaderSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorFileUploaderSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorFileUploaderSettings Class
WebTextEditorFileUploaderSettings Members


CopyFrom Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorFileUploaderSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorFileUploaderSettings Class
WebTextEditorFileUploaderSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorFileUploaderSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorFileUploaderSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorFileUploaderSettings Class
WebTextEditorFileUploaderSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorFileUploaderSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorFileUploaderSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorFileUploaderSettings Class
WebTextEditorFileUploaderSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebTextEditor Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorFileUploaderSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorFileUploaderSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorFileUploaderSettings Class
WebTextEditorFileUploaderSettings Members


GetHashCode Method

[image]
Intersoft WebTextEditor Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorFileUploaderSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorFileUploaderSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorFileUploaderSettings Class
WebTextEditorFileUploaderSettings Members


GetPropertyString Method

[image]
Intersoft WebTextEditor Documentation
GetPropertyString Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorFileUploaderSettings Class : GetPropertyString Method

v

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetPropertyString( _
   ByVal v As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorFileUploaderSettings
Dim v As System.String
Dim value As System.String

value = instance.GetPropertyString(v)
C#
protected virtual System.string GetPropertyString(
   System.string v
)
Delphi
protected function GetPropertyString(
    v: System.String
): System.String; virtual;
JScript
protected function GetPropertyString(
   v : System.String
) : System.String;
Managed Extensions for C++
protected: virtual System.string* GetPropertyString(
   System.string* v
)
C++/CLI
protected:
virtual System.String^ GetPropertyString(
   System.String^ v
)

Parameters

v

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorFileUploaderSettings Class
WebTextEditorFileUploaderSettings Members


IsEmpty Method

[image]
Intersoft WebTextEditor Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorFileUploaderSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorFileUploaderSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorFileUploaderSettings Class
WebTextEditorFileUploaderSettings Members


IsInSerializationContext Method

[image]
Intersoft WebTextEditor Documentation
IsInSerializationContext Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorFileUploaderSettings Class : IsInSerializationContext Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function IsInSerializationContext() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorFileUploaderSettings
Dim value As System.Boolean

value = instance.IsInSerializationContext()
C#
protected virtual System.bool IsInSerializationContext()
Delphi
protected function IsInSerializationContext(): System.Boolean; virtual;
JScript
protected function IsInSerializationContext() : System.boolean;
Managed Extensions for C++
protected: virtual System.bool IsInSerializationContext();
C++/CLI
protected:
virtual System.bool IsInSerializationContext();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorFileUploaderSettings Class
WebTextEditorFileUploaderSettings Members


Reset Method

[image]
Intersoft WebTextEditor Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorFileUploaderSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorFileUploaderSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorFileUploaderSettings Class
WebTextEditorFileUploaderSettings Members


SerializeObjectData Method

[image]
Intersoft WebTextEditor Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorFileUploaderSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorFileUploaderSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorFileUploaderSettings Class
WebTextEditorFileUploaderSettings Members


ToString Method

[image]
Intersoft WebTextEditor Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorFileUploaderSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorFileUploaderSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorFileUploaderSettings Class
WebTextEditorFileUploaderSettings Members


Clone Method

[image]
Intersoft WebTextEditor Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


CopyFrom Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebTextEditor Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


GetHashCode Method

[image]
Intersoft WebTextEditor Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


GetPropertyString Method

[image]
Intersoft WebTextEditor Documentation
GetPropertyString Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : GetPropertyString Method

v

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetPropertyString( _
   ByVal v As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim v As System.String
Dim value As System.String

value = instance.GetPropertyString(v)
C#
protected virtual System.string GetPropertyString(
   System.string v
)
Delphi
protected function GetPropertyString(
    v: System.String
): System.String; virtual;
JScript
protected function GetPropertyString(
   v : System.String
) : System.String;
Managed Extensions for C++
protected: virtual System.string* GetPropertyString(
   System.string* v
)
C++/CLI
protected:
virtual System.String^ GetPropertyString(
   System.String^ v
)

Parameters

v

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


IsEmpty Method

[image]
Intersoft WebTextEditor Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


IsInSerializationContext Method

[image]
Intersoft WebTextEditor Documentation
IsInSerializationContext Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : IsInSerializationContext Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function IsInSerializationContext() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.Boolean

value = instance.IsInSerializationContext()
C#
protected virtual System.bool IsInSerializationContext()
Delphi
protected function IsInSerializationContext(): System.Boolean; virtual;
JScript
protected function IsInSerializationContext() : System.boolean;
Managed Extensions for C++
protected: virtual System.bool IsInSerializationContext();
C++/CLI
protected:
virtual System.bool IsInSerializationContext();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


Reset Method

[image]
Intersoft WebTextEditor Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


SerializeObjectData Method

[image]
Intersoft WebTextEditor Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


ToString Method

[image]
Intersoft WebTextEditor Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorImagesSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorImagesSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorImagesSettings Class
WebTextEditorImagesSettings Members


WebTextEditorLabelCollection Class Properties

[image]
Intersoft WebTextEditor Documentation
WebTextEditorLabelCollection Class Properties
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorLabelCollection Class

Glossary Item Box

For a list of all members of this type, see WebTextEditorLabelCollection members.

Public Properties

 | Name | Description
Public Property | All | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

Protected Properties

 | Name | Description
Protected Property | Items | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Top

See Also

Reference

WebTextEditorLabelCollection Class
ISNet.WebUI.WebTextEditor Namespace


Add Method

[image]
Intersoft WebTextEditor Documentation
Add Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorLabelCollection Class : Add Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Sub Add( _
   ByVal item As ISNet.WebUI.INamedObject2 _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorLabelCollection
Dim item As ISNet.WebUI.INamedObject2

instance.Add(item)
C#
[__DynamicallyInvokableAttribute()]
public void Add(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public procedure Add(
    item: ISNet.WebUI.INamedObject2
);
JScript
__DynamicallyInvokableAttribute()
public function Add(
   item : ISNet.WebUI.INamedObject2
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void Add(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void Add(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorLabelCollection Class
WebTextEditorLabelCollection Members


All Property

[image]
Intersoft WebTextEditor Documentation
All Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorLabelCollection Class : All Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public ReadOnly Property All As ISNet.WebUI.INamedObject2()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorLabelCollection
Dim value() As ISNet.WebUI.INamedObject2

value = instance.All
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public ISNet.WebUI.INamedObject2[] All {get;}
Delphi
public read-only property All: ISNet.WebUI.array of INamedObject2;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get All : ISNet.WebUI.INamedObject2[]
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property ISNet.WebUI.INamedObject2*[]* get_All();
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property ISNet.WebUI.array<INamedObject2^>^ All {
   ISNet.WebUI.array<INamedObject2^>^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorLabelCollection Class
WebTextEditorLabelCollection Members


Clear Method

[image]
Intersoft WebTextEditor Documentation
Clear Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorLabelCollection Class : Clear Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorLabelCollection

instance.Clear()
C#
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public void Clear()
Delphi
public procedure Clear();
JScript
__DynamicallyInvokableAttribute()
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function Clear();
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: void Clear();
C++/CLI
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
void Clear();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorLabelCollection Class
WebTextEditorLabelCollection Members


ClearItems Method

[image]
Intersoft WebTextEditor Documentation
ClearItems Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorLabelCollection Class : ClearItems Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ClearItems()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorLabelCollection

instance.ClearItems()
C#
protected virtual void ClearItems()
Delphi
protected procedure ClearItems(); virtual;
JScript
protected function ClearItems();
Managed Extensions for C++
protected: virtual void ClearItems();
C++/CLI
protected:
virtual void ClearItems();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorLabelCollection Class
WebTextEditorLabelCollection Members


Contains Method

[image]
Intersoft WebTextEditor Documentation
Contains Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorLabelCollection Class : Contains Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
<__DynamicallyInvokableAttribute()>
Public Function Contains( _
   ByVal item As ISNet.WebUI.INamedObject2 _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorLabelCollection
Dim item As ISNet.WebUI.INamedObject2
Dim value As System.Boolean

value = instance.Contains(item)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public System.bool Contains(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public function Contains(
    item: ISNet.WebUI.INamedObject2
): System.Boolean;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
__DynamicallyInvokableAttribute()
public function Contains(
   item : ISNet.WebUI.INamedObject2
) : System.boolean;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public: System.bool Contains(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public:
System.bool Contains(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorLabelCollection Class
WebTextEditorLabelCollection Members


CopyTo Method

[image]
Intersoft WebTextEditor Documentation
CopyTo Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorLabelCollection Class : CopyTo Method

array
index

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Sub CopyTo( _
   ByVal array() As ISNet.WebUI.INamedObject2, _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorLabelCollection
Dim array() As ISNet.WebUI.INamedObject2
Dim index As System.Integer

instance.CopyTo(array, index)
C#
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public void CopyTo(
   ISNet.WebUI.INamedObject2[] array,
   System.int index
)
Delphi
public procedure CopyTo(
    array: ISNet.WebUI.INamedObject2array of;
    index: System.Integer
);
JScript
__DynamicallyInvokableAttribute()
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function CopyTo(
   array : ISNet.WebUI.INamedObject2[],
   index : System.int
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: void CopyTo(
   ISNet.WebUI.INamedObject2*[]* array,
   System.int index
)
C++/CLI
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
void CopyTo(
   ISNet.WebUI.array<INamedObject2^>^ array,
   System.int index
)

Parameters

array
index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorLabelCollection Class
WebTextEditorLabelCollection Members


Count Property

[image]
Intersoft WebTextEditor Documentation
Count Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorLabelCollection Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public ReadOnly Property Count As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorLabelCollection
Dim value As System.Integer

value = instance.Count
C#
[__DynamicallyInvokableAttribute()]
public System.int Count {get;}
Delphi
public read-only property Count: System.Integer;
JScript
__DynamicallyInvokableAttribute()
public function get Count : System.int
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: __property System.int get_Count();
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
property System.int Count {
   System.int get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorLabelCollection Class
WebTextEditorLabelCollection Members


CreateArray Method

[image]
Intersoft WebTextEditor Documentation
CreateArray Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorLabelCollection Class : CreateArray Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function CreateArray() As ISNet.WebUI.INamedObject2()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorLabelCollection
Dim value() As ISNet.WebUI.INamedObject2

value = instance.CreateArray()
C#
protected ISNet.WebUI.INamedObject2[] CreateArray()
Delphi
protected function CreateArray(): ISNet.WebUI.array of INamedObject2;
JScript
protected function CreateArray() : ISNet.WebUI.INamedObject2[];
Managed Extensions for C++
protected: ISNet.WebUI.INamedObject2*[]* CreateArray();
C++/CLI
protected:
ISNet.WebUI.array<INamedObject2^>^ CreateArray();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorLabelCollection Class
WebTextEditorLabelCollection Members


CreateNewItem Method

[image]
Intersoft WebTextEditor Documentation
CreateNewItem Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorLabelCollection Class : CreateNewItem Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CreateNewItem() As WebTextEditorLabel
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorLabelCollection
Dim value As WebTextEditorLabel

value = instance.CreateNewItem()
C#
public WebTextEditorLabel CreateNewItem()
Delphi
public function CreateNewItem(): WebTextEditorLabel;
JScript
public function CreateNewItem() : WebTextEditorLabel;
Managed Extensions for C++
public: WebTextEditorLabel* CreateNewItem();
C++/CLI
public:
WebTextEditorLabel^ CreateNewItem();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorLabelCollection Class
WebTextEditorLabelCollection Members


GetEnumerator Method

[image]
Intersoft WebTextEditor Documentation
GetEnumerator Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorLabelCollection Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Function GetEnumerator() As System.Collections.Generic.IEnumerator(Of INamedObject2)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorLabelCollection
Dim value As System.Collections.Generic.IEnumerator(Of INamedObject2)

value = instance.GetEnumerator()
C#
[__DynamicallyInvokableAttribute()]
public System.Collections.Generic.IEnumerator<INamedObject2> GetEnumerator()
Delphi
public function GetEnumerator(): System.Collections.Generic.IEnumerator;
JScript
__DynamicallyInvokableAttribute()
public function GetEnumerator() : System.Collections.Generic.IEnumerator;
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: System.Collections.Generic.IEnumerator<INamedObject2*>* GetEnumerator();
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
System.Collections.Generic.IEnumerator<INamedObject2^>^ GetEnumerator();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorLabelCollection Class
WebTextEditorLabelCollection Members


GetObjectData Method

[image]
Intersoft WebTextEditor Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorLabelCollection Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorLabelCollection
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorLabelCollection Class
WebTextEditorLabelCollection Members


IndexOf Method

[image]
Intersoft WebTextEditor Documentation
IndexOf Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorLabelCollection Class : IndexOf Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
<__DynamicallyInvokableAttribute()>
Public Function IndexOf( _
   ByVal item As ISNet.WebUI.INamedObject2 _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorLabelCollection
Dim item As ISNet.WebUI.INamedObject2
Dim value As System.Integer

value = instance.IndexOf(item)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public System.int IndexOf(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public function IndexOf(
    item: ISNet.WebUI.INamedObject2
): System.Integer;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
__DynamicallyInvokableAttribute()
public function IndexOf(
   item : ISNet.WebUI.INamedObject2
) : System.int;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public: System.int IndexOf(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public:
System.int IndexOf(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorLabelCollection Class
WebTextEditorLabelCollection Members


Insert Method

[image]
Intersoft WebTextEditor Documentation
Insert Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorLabelCollection Class : Insert Method

index
item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal item As ISNet.WebUI.INamedObject2 _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorLabelCollection
Dim index As System.Integer
Dim item As ISNet.WebUI.INamedObject2

instance.Insert(index, item)
C#
[__DynamicallyInvokableAttribute()]
public void Insert(
   System.int index,
   ISNet.WebUI.INamedObject2 item
)
Delphi
public procedure Insert(
    index: System.Integer;
    item: ISNet.WebUI.INamedObject2
);
JScript
__DynamicallyInvokableAttribute()
public function Insert(
   index : System.int,
   item : ISNet.WebUI.INamedObject2
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void Insert(
   System.int index,
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void Insert(
   System.int index,
   ISNet.WebUI.INamedObject2^ item
)

Parameters

index
item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorLabelCollection Class
WebTextEditorLabelCollection Members


InsertItem Method

[image]
Intersoft WebTextEditor Documentation
InsertItem Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorLabelCollection Class : InsertItem Method

index
item

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub InsertItem( _
   ByVal index As System.Integer, _
   ByVal item As ISNet.WebUI.INamedObject2 _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorLabelCollection
Dim index As System.Integer
Dim item As ISNet.WebUI.INamedObject2

instance.InsertItem(index, item)
C#
protected virtual void InsertItem(
   System.int index,
   ISNet.WebUI.INamedObject2 item
)
Delphi
protected procedure InsertItem(
    index: System.Integer;
    item: ISNet.WebUI.INamedObject2
); virtual;
JScript
protected function InsertItem(
   index : System.int,
   item : ISNet.WebUI.INamedObject2
);
Managed Extensions for C++
protected: virtual void InsertItem(
   System.int index,
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
protected:
virtual void InsertItem(
   System.int index,
   ISNet.WebUI.INamedObject2^ item
)

Parameters

index
item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorLabelCollection Class
WebTextEditorLabelCollection Members


Item Property

[image]
Intersoft WebTextEditor Documentation
Item Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorLabelCollection Class : Item Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Default Property Item( _
   ByVal index As System.Integer _
) As ISNet.WebUI.INamedObject2
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorLabelCollection
Dim index As System.Integer
Dim value As ISNet.WebUI.INamedObject2

instance.Item(index) = value

value = instance.Item(index)
C#
[__DynamicallyInvokableAttribute()]
public ISNet.WebUI.INamedObject2 this[
   System.int index
]; {get; set;}
Delphi
public  this: : ISNet.WebUI.INamedObject2;[
    index: System.Integer
]; read-write
JScript
__DynamicallyInvokableAttribute()
public  this[
   index : System.int
] get,set : ISNet.WebUI.INamedObject2
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: __property ISNet.WebUI.INamedObject2* get_Item   System.int index
;
public: __property void set_Item   System.int index,
   ISNet.WebUI.INamedObject2* value
;
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
property ISNet.WebUI.INamedObject2^ default [int] {
   ISNet.WebUI.INamedObject2^ get(System.int index);
   void set (System.int index, ISNet.WebUI.INamedObject2^ value);
}

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorLabelCollection Class
WebTextEditorLabelCollection Members


Items Property

[image]
Intersoft WebTextEditor Documentation
Items Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorLabelCollection Class : Items Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Protected ReadOnly Property Items As System.Collections.Generic.IList(Of INamedObject2)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorLabelCollection
Dim value As System.Collections.Generic.IList(Of INamedObject2)

value = instance.Items
C#
[__DynamicallyInvokableAttribute()]
protected System.Collections.Generic.IList<INamedObject2> Items {get;}
Delphi
protected read-only property Items: System.Collections.Generic.IList;
JScript
__DynamicallyInvokableAttribute()
protected function get Items : System.Collections.Generic.IList
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
protected: __property System.Collections.Generic.IList<INamedObject2*>* get_Items();
C++/CLI
[__DynamicallyInvokableAttribute()]
protected:
property System.Collections.Generic.IList<INamedObject2^>^ Items {
   System.Collections.Generic.IList<INamedObject2^>^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorLabelCollection Class
WebTextEditorLabelCollection Members


Parent Property

[image]
Intersoft WebTextEditor Documentation
Parent Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorLabelCollection Class : Parent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorLabelCollection
Dim value As System.Object

value = instance.Parent
C#
public System.object Parent {get;}
Delphi
public read-only property Parent: System.TObject;
JScript
public function get Parent : System.Object
Managed Extensions for C++
public: __property System.Object* get_Parent();
C++/CLI
public:
property System.Object^ Parent {
   System.Object^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorLabelCollection Class
WebTextEditorLabelCollection Members


Remove Method

[image]
Intersoft WebTextEditor Documentation
Remove Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorLabelCollection Class : Remove Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Function Remove( _
   ByVal item As ISNet.WebUI.INamedObject2 _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorLabelCollection
Dim item As ISNet.WebUI.INamedObject2
Dim value As System.Boolean

value = instance.Remove(item)
C#
[__DynamicallyInvokableAttribute()]
public System.bool Remove(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public function Remove(
    item: ISNet.WebUI.INamedObject2
): System.Boolean;
JScript
__DynamicallyInvokableAttribute()
public function Remove(
   item : ISNet.WebUI.INamedObject2
) : System.boolean;
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: System.bool Remove(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
System.bool Remove(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorLabelCollection Class
WebTextEditorLabelCollection Members


RemoveAt Method

[image]
Intersoft WebTextEditor Documentation
RemoveAt Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorLabelCollection Class : RemoveAt Method

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorLabelCollection
Dim index As System.Integer

instance.RemoveAt(index)
C#
[__DynamicallyInvokableAttribute()]
public void RemoveAt(
   System.int index
)
Delphi
public procedure RemoveAt(
    index: System.Integer
);
JScript
__DynamicallyInvokableAttribute()
public function RemoveAt(
   index : System.int
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void RemoveAt(
   System.int index
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void RemoveAt(
   System.int index
)

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorLabelCollection Class
WebTextEditorLabelCollection Members


RemoveItem Method

[image]
Intersoft WebTextEditor Documentation
RemoveItem Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorLabelCollection Class : RemoveItem Method

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub RemoveItem( _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorLabelCollection
Dim index As System.Integer

instance.RemoveItem(index)
C#
protected virtual void RemoveItem(
   System.int index
)
Delphi
protected procedure RemoveItem(
    index: System.Integer
); virtual;
JScript
protected function RemoveItem(
   index : System.int
);
Managed Extensions for C++
protected: virtual void RemoveItem(
   System.int index
)
C++/CLI
protected:
virtual void RemoveItem(
   System.int index
)

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorLabelCollection Class
WebTextEditorLabelCollection Members


SerializerConstructor Method

[image]
Intersoft WebTextEditor Documentation
SerializerConstructor Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorLabelCollection Class : SerializerConstructor Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializerConstructor( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorLabelCollection
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializerConstructor(info, context)
C#
public void SerializerConstructor(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializerConstructor(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializerConstructor(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializerConstructor(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializerConstructor(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorLabelCollection Class
WebTextEditorLabelCollection Members


SetItem Method

[image]
Intersoft WebTextEditor Documentation
SetItem Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorLabelCollection Class : SetItem Method

index
item

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub SetItem( _
   ByVal index As System.Integer, _
   ByVal item As ISNet.WebUI.INamedObject2 _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorLabelCollection
Dim index As System.Integer
Dim item As ISNet.WebUI.INamedObject2

instance.SetItem(index, item)
C#
protected virtual void SetItem(
   System.int index,
   ISNet.WebUI.INamedObject2 item
)
Delphi
protected procedure SetItem(
    index: System.Integer;
    item: ISNet.WebUI.INamedObject2
); virtual;
JScript
protected function SetItem(
   index : System.int,
   item : ISNet.WebUI.INamedObject2
);
Managed Extensions for C++
protected: virtual void SetItem(
   System.int index,
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
protected:
virtual void SetItem(
   System.int index,
   ISNet.WebUI.INamedObject2^ item
)

Parameters

index
item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorLabelCollection Class
WebTextEditorLabelCollection Members


SetParent Method

[image]
Intersoft WebTextEditor Documentation
SetParent Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorLabelCollection Class : SetParent Method

parent

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SetParent( _
   ByVal parent As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorLabelCollection
Dim parent As System.Object

instance.SetParent(parent)
C#
public virtual void SetParent(
   System.object parent
)
Delphi
public procedure SetParent(
    parent: System.TObject
); virtual;
JScript
public function SetParent(
   parent : System.Object
);
Managed Extensions for C++
public: virtual void SetParent(
   System.Object* parent
)
C++/CLI
public:
virtual void SetParent(
   System.Object^ parent
)

Parameters

parent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorLabelCollection Class
WebTextEditorLabelCollection Members


Clone Method

[image]
Intersoft WebTextEditor Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorLabel Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorLabel
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorLabel Class
WebTextEditorLabel Members


Collection Property

[image]
Intersoft WebTextEditor Documentation
Collection Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorLabel Class : Collection Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
Public Property Collection As ISNet.WebUI.ISCollectionBase(Of INamedObject2)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorLabel
Dim value As ISNet.WebUI.ISCollectionBase(Of INamedObject2)

instance.Collection = value

value = instance.Collection
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public ISNet.WebUI.ISCollectionBase<INamedObject2> Collection {get; set;}
Delphi
public read-write property Collection: ISNet.WebUI.ISCollectionBase;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
public function get,set Collection : ISNet.WebUI.ISCollectionBase
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public: __property ISNet.WebUI.ISCollectionBase<INamedObject2*>* get_Collection();
public: __property void set_Collection(
   ISNet.WebUI.ISCollectionBase<INamedObject2*>* value
);
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public:
property ISNet.WebUI.ISCollectionBase<INamedObject2^>^ Collection {
   ISNet.WebUI.ISCollectionBase<INamedObject2^>^ get();
   void set (    ISNet.WebUI.ISCollectionBase<INamedObject2^>^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorLabel Class
WebTextEditorLabel Members


CopyFrom Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorLabel Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorLabel Class
WebTextEditorLabel Members


CopyFrom(Object) Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorLabel Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorLabel
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorLabel Class
WebTextEditorLabel Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorLabel Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorLabel
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorLabel Class
WebTextEditorLabel Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebTextEditor Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorLabel Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorLabel
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorLabel Class
WebTextEditorLabel Members


GetHashCode Method

[image]
Intersoft WebTextEditor Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorLabel Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorLabel
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorLabel Class
WebTextEditorLabel Members


GetPropertyString Method

[image]
Intersoft WebTextEditor Documentation
GetPropertyString Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorLabel Class : GetPropertyString Method

v

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetPropertyString( _
   ByVal v As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorLabel
Dim v As System.String
Dim value As System.String

value = instance.GetPropertyString(v)
C#
protected virtual System.string GetPropertyString(
   System.string v
)
Delphi
protected function GetPropertyString(
    v: System.String
): System.String; virtual;
JScript
protected function GetPropertyString(
   v : System.String
) : System.String;
Managed Extensions for C++
protected: virtual System.string* GetPropertyString(
   System.string* v
)
C++/CLI
protected:
virtual System.String^ GetPropertyString(
   System.String^ v
)

Parameters

v

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorLabel Class
WebTextEditorLabel Members


IsEmpty Method

[image]
Intersoft WebTextEditor Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorLabel Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorLabel
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorLabel Class
WebTextEditorLabel Members


IsInSerializationContext Method

[image]
Intersoft WebTextEditor Documentation
IsInSerializationContext Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorLabel Class : IsInSerializationContext Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function IsInSerializationContext() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorLabel
Dim value As System.Boolean

value = instance.IsInSerializationContext()
C#
protected virtual System.bool IsInSerializationContext()
Delphi
protected function IsInSerializationContext(): System.Boolean; virtual;
JScript
protected function IsInSerializationContext() : System.boolean;
Managed Extensions for C++
protected: virtual System.bool IsInSerializationContext();
C++/CLI
protected:
virtual System.bool IsInSerializationContext();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorLabel Class
WebTextEditorLabel Members


Name Property

[image]
Intersoft WebTextEditor Documentation
Name Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorLabel Class : Name Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BrowsableAttribute(False)>
Public Overridable Property Name As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorLabel
Dim value As System.String

instance.Name = value

value = instance.Name
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BrowsableAttribute(false)]
public virtual System.string Name {get; set;}
Delphi
public read-write property Name: System.String; virtual;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BrowsableAttribute()
public function get,set Name : System.String
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BrowsableAttribute(false)]
public: __property virtual System.string* get_Name();
public: __property virtual void set_Name(
   System.string* value
);
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BrowsableAttribute(false)]
public:
virtual property System.String^ Name {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorLabel Class
WebTextEditorLabel Members


OnItemAdd Method

[image]
Intersoft WebTextEditor Documentation
OnItemAdd Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorLabel Class : OnItemAdd Method

collection

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnItemAdd( _
   ByVal collection As ISNet.WebUI.ISCollectionBase(Of INamedObject2) _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorLabel
Dim collection As ISNet.WebUI.ISCollectionBase(Of INamedObject2)

instance.OnItemAdd(collection)
C#
protected virtual void OnItemAdd(
   ISNet.WebUI.ISCollectionBase<INamedObject2> collection
)
Delphi
protected procedure OnItemAdd(
    collection: ISNet.WebUI.ISCollectionBase
); virtual;
JScript
protected function OnItemAdd(
   collection : ISNet.WebUI.ISCollectionBase
);
Managed Extensions for C++
protected: virtual void OnItemAdd(
   ISNet.WebUI.ISCollectionBase<INamedObject2*>* collection
)
C++/CLI
protected:
virtual void OnItemAdd(
   ISNet.WebUI.ISCollectionBase<INamedObject2^>^ collection
)

Parameters

collection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorLabel Class
WebTextEditorLabel Members


OnItemRemove Method

[image]
Intersoft WebTextEditor Documentation
OnItemRemove Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorLabel Class : OnItemRemove Method

collection

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnItemRemove( _
   ByVal collection As ISNet.WebUI.ISCollectionBase(Of INamedObject2) _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorLabel
Dim collection As ISNet.WebUI.ISCollectionBase(Of INamedObject2)

instance.OnItemRemove(collection)
C#
protected virtual void OnItemRemove(
   ISNet.WebUI.ISCollectionBase<INamedObject2> collection
)
Delphi
protected procedure OnItemRemove(
    collection: ISNet.WebUI.ISCollectionBase
); virtual;
JScript
protected function OnItemRemove(
   collection : ISNet.WebUI.ISCollectionBase
);
Managed Extensions for C++
protected: virtual void OnItemRemove(
   ISNet.WebUI.ISCollectionBase<INamedObject2*>* collection
)
C++/CLI
protected:
virtual void OnItemRemove(
   ISNet.WebUI.ISCollectionBase<INamedObject2^>^ collection
)

Parameters

collection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorLabel Class
WebTextEditorLabel Members


Reset Method

[image]
Intersoft WebTextEditor Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorLabel Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorLabel

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorLabel Class
WebTextEditorLabel Members


SerializeObjectData Method

[image]
Intersoft WebTextEditor Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorLabel Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorLabel
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorLabel Class
WebTextEditorLabel Members


ToString Method

[image]
Intersoft WebTextEditor Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorLabel Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorLabel
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorLabel Class
WebTextEditorLabel Members


Clone Method

[image]
Intersoft WebTextEditor Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMailMergeObject Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMailMergeObject
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMailMergeObject Class
WebTextEditorMailMergeObject Members


CopyFrom Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMailMergeObject Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMailMergeObject Class
WebTextEditorMailMergeObject Members


CopyFrom(Object) Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMailMergeObject Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMailMergeObject
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMailMergeObject Class
WebTextEditorMailMergeObject Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMailMergeObject Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMailMergeObject
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMailMergeObject Class
WebTextEditorMailMergeObject Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebTextEditor Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMailMergeObject Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMailMergeObject
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMailMergeObject Class
WebTextEditorMailMergeObject Members


GetHashCode Method

[image]
Intersoft WebTextEditor Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMailMergeObject Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMailMergeObject
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMailMergeObject Class
WebTextEditorMailMergeObject Members


GetPropertyString Method

[image]
Intersoft WebTextEditor Documentation
GetPropertyString Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMailMergeObject Class : GetPropertyString Method

v

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetPropertyString( _
   ByVal v As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMailMergeObject
Dim v As System.String
Dim value As System.String

value = instance.GetPropertyString(v)
C#
protected virtual System.string GetPropertyString(
   System.string v
)
Delphi
protected function GetPropertyString(
    v: System.String
): System.String; virtual;
JScript
protected function GetPropertyString(
   v : System.String
) : System.String;
Managed Extensions for C++
protected: virtual System.string* GetPropertyString(
   System.string* v
)
C++/CLI
protected:
virtual System.String^ GetPropertyString(
   System.String^ v
)

Parameters

v

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMailMergeObject Class
WebTextEditorMailMergeObject Members


IsEmpty Method

[image]
Intersoft WebTextEditor Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMailMergeObject Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMailMergeObject
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMailMergeObject Class
WebTextEditorMailMergeObject Members


IsInSerializationContext Method

[image]
Intersoft WebTextEditor Documentation
IsInSerializationContext Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMailMergeObject Class : IsInSerializationContext Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function IsInSerializationContext() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMailMergeObject
Dim value As System.Boolean

value = instance.IsInSerializationContext()
C#
protected virtual System.bool IsInSerializationContext()
Delphi
protected function IsInSerializationContext(): System.Boolean; virtual;
JScript
protected function IsInSerializationContext() : System.boolean;
Managed Extensions for C++
protected: virtual System.bool IsInSerializationContext();
C++/CLI
protected:
virtual System.bool IsInSerializationContext();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMailMergeObject Class
WebTextEditorMailMergeObject Members


Reset Method

[image]
Intersoft WebTextEditor Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMailMergeObject Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMailMergeObject

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMailMergeObject Class
WebTextEditorMailMergeObject Members


SerializeObjectData Method

[image]
Intersoft WebTextEditor Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMailMergeObject Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMailMergeObject
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMailMergeObject Class
WebTextEditorMailMergeObject Members


ToString Method

[image]
Intersoft WebTextEditor Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMailMergeObject Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMailMergeObject
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMailMergeObject Class
WebTextEditorMailMergeObject Members


Clone Method

[image]
Intersoft WebTextEditor Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMailMergeSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMailMergeSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMailMergeSettings Class
WebTextEditorMailMergeSettings Members


CopyFrom Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMailMergeSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMailMergeSettings Class
WebTextEditorMailMergeSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMailMergeSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMailMergeSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMailMergeSettings Class
WebTextEditorMailMergeSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMailMergeSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMailMergeSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMailMergeSettings Class
WebTextEditorMailMergeSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebTextEditor Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMailMergeSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMailMergeSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMailMergeSettings Class
WebTextEditorMailMergeSettings Members


GetHashCode Method

[image]
Intersoft WebTextEditor Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMailMergeSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMailMergeSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMailMergeSettings Class
WebTextEditorMailMergeSettings Members


GetPropertyString Method

[image]
Intersoft WebTextEditor Documentation
GetPropertyString Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMailMergeSettings Class : GetPropertyString Method

v

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetPropertyString( _
   ByVal v As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMailMergeSettings
Dim v As System.String
Dim value As System.String

value = instance.GetPropertyString(v)
C#
protected virtual System.string GetPropertyString(
   System.string v
)
Delphi
protected function GetPropertyString(
    v: System.String
): System.String; virtual;
JScript
protected function GetPropertyString(
   v : System.String
) : System.String;
Managed Extensions for C++
protected: virtual System.string* GetPropertyString(
   System.string* v
)
C++/CLI
protected:
virtual System.String^ GetPropertyString(
   System.String^ v
)

Parameters

v

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMailMergeSettings Class
WebTextEditorMailMergeSettings Members


IsEmpty Method

[image]
Intersoft WebTextEditor Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMailMergeSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMailMergeSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMailMergeSettings Class
WebTextEditorMailMergeSettings Members


IsInSerializationContext Method

[image]
Intersoft WebTextEditor Documentation
IsInSerializationContext Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMailMergeSettings Class : IsInSerializationContext Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function IsInSerializationContext() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMailMergeSettings
Dim value As System.Boolean

value = instance.IsInSerializationContext()
C#
protected virtual System.bool IsInSerializationContext()
Delphi
protected function IsInSerializationContext(): System.Boolean; virtual;
JScript
protected function IsInSerializationContext() : System.boolean;
Managed Extensions for C++
protected: virtual System.bool IsInSerializationContext();
C++/CLI
protected:
virtual System.bool IsInSerializationContext();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMailMergeSettings Class
WebTextEditorMailMergeSettings Members


Reset Method

[image]
Intersoft WebTextEditor Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMailMergeSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMailMergeSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMailMergeSettings Class
WebTextEditorMailMergeSettings Members


SerializeObjectData Method

[image]
Intersoft WebTextEditor Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMailMergeSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMailMergeSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMailMergeSettings Class
WebTextEditorMailMergeSettings Members


ToString Method

[image]
Intersoft WebTextEditor Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMailMergeSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMailMergeSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMailMergeSettings Class
WebTextEditorMailMergeSettings Members


WebTextEditorMediaCollection Class Methods

[image]
Intersoft WebTextEditor Documentation
WebTextEditorMediaCollection Class Methods
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorMediaCollection Class

Glossary Item Box

For a list of all members of this type, see WebTextEditorMediaCollection members.

Public Methods

 | Name | Description
Public Method | Add | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Clear | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Contains | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CopyTo | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | CreateNewItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorMedia>)
Public Method | GetEnumerator | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | GetNamedItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorMedia>)
Public Method | GetObjectData | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Public Method | IndexOf | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Insert | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | Remove | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | RemoveAt | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Method | SerializerConstructor | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorMedia>)
Public Method | SetParent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

Protected Methods

 | Name | Description
Protected Method | ClearItems | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorMedia>)
Protected Method | CreateArray | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Protected Method | InsertItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorMedia>)
Protected Method | RemoveItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorMedia>)
Protected Method | SetItem | (Inherited from ISNet.WebUI.ISGenericCollectionBase<WebTextEditorMedia>)
Top

See Also

Reference

WebTextEditorMediaCollection Class
ISNet.WebUI.WebTextEditor Namespace


WebTextEditorMediaCollection Class Properties

[image]
Intersoft WebTextEditor Documentation
WebTextEditorMediaCollection Class Properties
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorMediaCollection Class

Glossary Item Box

For a list of all members of this type, see WebTextEditorMediaCollection members.

Public Properties

 | Name | Description
Public Property | All | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

Protected Properties

 | Name | Description
Protected Property | Items | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Top

See Also

Reference

WebTextEditorMediaCollection Class
ISNet.WebUI.WebTextEditor Namespace


Add Method

[image]
Intersoft WebTextEditor Documentation
Add Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMediaCollection Class : Add Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Sub Add( _
   ByVal item As ISNet.WebUI.INamedObject2 _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMediaCollection
Dim item As ISNet.WebUI.INamedObject2

instance.Add(item)
C#
[__DynamicallyInvokableAttribute()]
public void Add(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public procedure Add(
    item: ISNet.WebUI.INamedObject2
);
JScript
__DynamicallyInvokableAttribute()
public function Add(
   item : ISNet.WebUI.INamedObject2
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void Add(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void Add(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaCollection Class
WebTextEditorMediaCollection Members


All Property

[image]
Intersoft WebTextEditor Documentation
All Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMediaCollection Class : All Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public ReadOnly Property All As ISNet.WebUI.INamedObject2()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMediaCollection
Dim value() As ISNet.WebUI.INamedObject2

value = instance.All
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public ISNet.WebUI.INamedObject2[] All {get;}
Delphi
public read-only property All: ISNet.WebUI.array of INamedObject2;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get All : ISNet.WebUI.INamedObject2[]
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property ISNet.WebUI.INamedObject2*[]* get_All();
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property ISNet.WebUI.array<INamedObject2^>^ All {
   ISNet.WebUI.array<INamedObject2^>^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaCollection Class
WebTextEditorMediaCollection Members


Clear Method

[image]
Intersoft WebTextEditor Documentation
Clear Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMediaCollection Class : Clear Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMediaCollection

instance.Clear()
C#
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public void Clear()
Delphi
public procedure Clear();
JScript
__DynamicallyInvokableAttribute()
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function Clear();
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: void Clear();
C++/CLI
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
void Clear();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaCollection Class
WebTextEditorMediaCollection Members


ClearItems Method

[image]
Intersoft WebTextEditor Documentation
ClearItems Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMediaCollection Class : ClearItems Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ClearItems()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMediaCollection

instance.ClearItems()
C#
protected virtual void ClearItems()
Delphi
protected procedure ClearItems(); virtual;
JScript
protected function ClearItems();
Managed Extensions for C++
protected: virtual void ClearItems();
C++/CLI
protected:
virtual void ClearItems();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaCollection Class
WebTextEditorMediaCollection Members


Contains Method

[image]
Intersoft WebTextEditor Documentation
Contains Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMediaCollection Class : Contains Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
<__DynamicallyInvokableAttribute()>
Public Function Contains( _
   ByVal item As ISNet.WebUI.INamedObject2 _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMediaCollection
Dim item As ISNet.WebUI.INamedObject2
Dim value As System.Boolean

value = instance.Contains(item)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public System.bool Contains(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public function Contains(
    item: ISNet.WebUI.INamedObject2
): System.Boolean;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
__DynamicallyInvokableAttribute()
public function Contains(
   item : ISNet.WebUI.INamedObject2
) : System.boolean;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public: System.bool Contains(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public:
System.bool Contains(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaCollection Class
WebTextEditorMediaCollection Members


CopyTo Method

[image]
Intersoft WebTextEditor Documentation
CopyTo Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMediaCollection Class : CopyTo Method

array
index

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Sub CopyTo( _
   ByVal array() As ISNet.WebUI.INamedObject2, _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMediaCollection
Dim array() As ISNet.WebUI.INamedObject2
Dim index As System.Integer

instance.CopyTo(array, index)
C#
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public void CopyTo(
   ISNet.WebUI.INamedObject2[] array,
   System.int index
)
Delphi
public procedure CopyTo(
    array: ISNet.WebUI.INamedObject2array of;
    index: System.Integer
);
JScript
__DynamicallyInvokableAttribute()
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function CopyTo(
   array : ISNet.WebUI.INamedObject2[],
   index : System.int
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: void CopyTo(
   ISNet.WebUI.INamedObject2*[]* array,
   System.int index
)
C++/CLI
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
void CopyTo(
   ISNet.WebUI.array<INamedObject2^>^ array,
   System.int index
)

Parameters

array
index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaCollection Class
WebTextEditorMediaCollection Members


Count Property

[image]
Intersoft WebTextEditor Documentation
Count Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMediaCollection Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public ReadOnly Property Count As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMediaCollection
Dim value As System.Integer

value = instance.Count
C#
[__DynamicallyInvokableAttribute()]
public System.int Count {get;}
Delphi
public read-only property Count: System.Integer;
JScript
__DynamicallyInvokableAttribute()
public function get Count : System.int
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: __property System.int get_Count();
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
property System.int Count {
   System.int get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaCollection Class
WebTextEditorMediaCollection Members


CreateArray Method

[image]
Intersoft WebTextEditor Documentation
CreateArray Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMediaCollection Class : CreateArray Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function CreateArray() As ISNet.WebUI.INamedObject2()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMediaCollection
Dim value() As ISNet.WebUI.INamedObject2

value = instance.CreateArray()
C#
protected ISNet.WebUI.INamedObject2[] CreateArray()
Delphi
protected function CreateArray(): ISNet.WebUI.array of INamedObject2;
JScript
protected function CreateArray() : ISNet.WebUI.INamedObject2[];
Managed Extensions for C++
protected: ISNet.WebUI.INamedObject2*[]* CreateArray();
C++/CLI
protected:
ISNet.WebUI.array<INamedObject2^>^ CreateArray();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaCollection Class
WebTextEditorMediaCollection Members


CreateNewItem Method

[image]
Intersoft WebTextEditor Documentation
CreateNewItem Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMediaCollection Class : CreateNewItem Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CreateNewItem() As WebTextEditorMedia
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMediaCollection
Dim value As WebTextEditorMedia

value = instance.CreateNewItem()
C#
public WebTextEditorMedia CreateNewItem()
Delphi
public function CreateNewItem(): WebTextEditorMedia;
JScript
public function CreateNewItem() : WebTextEditorMedia;
Managed Extensions for C++
public: WebTextEditorMedia* CreateNewItem();
C++/CLI
public:
WebTextEditorMedia^ CreateNewItem();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaCollection Class
WebTextEditorMediaCollection Members


GetEnumerator Method

[image]
Intersoft WebTextEditor Documentation
GetEnumerator Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMediaCollection Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Function GetEnumerator() As System.Collections.Generic.IEnumerator(Of INamedObject2)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMediaCollection
Dim value As System.Collections.Generic.IEnumerator(Of INamedObject2)

value = instance.GetEnumerator()
C#
[__DynamicallyInvokableAttribute()]
public System.Collections.Generic.IEnumerator<INamedObject2> GetEnumerator()
Delphi
public function GetEnumerator(): System.Collections.Generic.IEnumerator;
JScript
__DynamicallyInvokableAttribute()
public function GetEnumerator() : System.Collections.Generic.IEnumerator;
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: System.Collections.Generic.IEnumerator<INamedObject2*>* GetEnumerator();
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
System.Collections.Generic.IEnumerator<INamedObject2^>^ GetEnumerator();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaCollection Class
WebTextEditorMediaCollection Members


GetNamedItem Method

[image]
Intersoft WebTextEditor Documentation
GetNamedItem Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMediaCollection Class : GetNamedItem Method

name

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetNamedItem( _
   ByVal name As System.String _
) As WebTextEditorMedia
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMediaCollection
Dim name As System.String
Dim value As WebTextEditorMedia

value = instance.GetNamedItem(name)
C#
public WebTextEditorMedia GetNamedItem(
   System.string name
)
Delphi
public function GetNamedItem(
    name: System.String
): WebTextEditorMedia;
JScript
public function GetNamedItem(
   name : System.String
) : WebTextEditorMedia;
Managed Extensions for C++
public: WebTextEditorMedia* GetNamedItem(
   System.string* name
)
C++/CLI
public:
WebTextEditorMedia^ GetNamedItem(
   System.String^ name
)

Parameters

name

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaCollection Class
WebTextEditorMediaCollection Members


GetObjectData Method

[image]
Intersoft WebTextEditor Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMediaCollection Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMediaCollection
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaCollection Class
WebTextEditorMediaCollection Members


IndexOf Method

[image]
Intersoft WebTextEditor Documentation
IndexOf Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMediaCollection Class : IndexOf Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
<__DynamicallyInvokableAttribute()>
Public Function IndexOf( _
   ByVal item As ISNet.WebUI.INamedObject2 _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMediaCollection
Dim item As ISNet.WebUI.INamedObject2
Dim value As System.Integer

value = instance.IndexOf(item)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public System.int IndexOf(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public function IndexOf(
    item: ISNet.WebUI.INamedObject2
): System.Integer;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
__DynamicallyInvokableAttribute()
public function IndexOf(
   item : ISNet.WebUI.INamedObject2
) : System.int;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public: System.int IndexOf(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public:
System.int IndexOf(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaCollection Class
WebTextEditorMediaCollection Members


Insert Method

[image]
Intersoft WebTextEditor Documentation
Insert Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMediaCollection Class : Insert Method

index
item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal item As ISNet.WebUI.INamedObject2 _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMediaCollection
Dim index As System.Integer
Dim item As ISNet.WebUI.INamedObject2

instance.Insert(index, item)
C#
[__DynamicallyInvokableAttribute()]
public void Insert(
   System.int index,
   ISNet.WebUI.INamedObject2 item
)
Delphi
public procedure Insert(
    index: System.Integer;
    item: ISNet.WebUI.INamedObject2
);
JScript
__DynamicallyInvokableAttribute()
public function Insert(
   index : System.int,
   item : ISNet.WebUI.INamedObject2
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void Insert(
   System.int index,
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void Insert(
   System.int index,
   ISNet.WebUI.INamedObject2^ item
)

Parameters

index
item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaCollection Class
WebTextEditorMediaCollection Members


InsertItem Method

[image]
Intersoft WebTextEditor Documentation
InsertItem Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMediaCollection Class : InsertItem Method

index
item

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub InsertItem( _
   ByVal index As System.Integer, _
   ByVal item As ISNet.WebUI.INamedObject2 _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMediaCollection
Dim index As System.Integer
Dim item As ISNet.WebUI.INamedObject2

instance.InsertItem(index, item)
C#
protected virtual void InsertItem(
   System.int index,
   ISNet.WebUI.INamedObject2 item
)
Delphi
protected procedure InsertItem(
    index: System.Integer;
    item: ISNet.WebUI.INamedObject2
); virtual;
JScript
protected function InsertItem(
   index : System.int,
   item : ISNet.WebUI.INamedObject2
);
Managed Extensions for C++
protected: virtual void InsertItem(
   System.int index,
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
protected:
virtual void InsertItem(
   System.int index,
   ISNet.WebUI.INamedObject2^ item
)

Parameters

index
item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaCollection Class
WebTextEditorMediaCollection Members


Item Property

[image]
Intersoft WebTextEditor Documentation
Item Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMediaCollection Class : Item Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Default Property Item( _
   ByVal index As System.Integer _
) As ISNet.WebUI.INamedObject2
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMediaCollection
Dim index As System.Integer
Dim value As ISNet.WebUI.INamedObject2

instance.Item(index) = value

value = instance.Item(index)
C#
[__DynamicallyInvokableAttribute()]
public ISNet.WebUI.INamedObject2 this[
   System.int index
]; {get; set;}
Delphi
public  this: : ISNet.WebUI.INamedObject2;[
    index: System.Integer
]; read-write
JScript
__DynamicallyInvokableAttribute()
public  this[
   index : System.int
] get,set : ISNet.WebUI.INamedObject2
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: __property ISNet.WebUI.INamedObject2* get_Item   System.int index
;
public: __property void set_Item   System.int index,
   ISNet.WebUI.INamedObject2* value
;
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
property ISNet.WebUI.INamedObject2^ default [int] {
   ISNet.WebUI.INamedObject2^ get(System.int index);
   void set (System.int index, ISNet.WebUI.INamedObject2^ value);
}

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaCollection Class
WebTextEditorMediaCollection Members


Items Property

[image]
Intersoft WebTextEditor Documentation
Items Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMediaCollection Class : Items Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Protected ReadOnly Property Items As System.Collections.Generic.IList(Of INamedObject2)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMediaCollection
Dim value As System.Collections.Generic.IList(Of INamedObject2)

value = instance.Items
C#
[__DynamicallyInvokableAttribute()]
protected System.Collections.Generic.IList<INamedObject2> Items {get;}
Delphi
protected read-only property Items: System.Collections.Generic.IList;
JScript
__DynamicallyInvokableAttribute()
protected function get Items : System.Collections.Generic.IList
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
protected: __property System.Collections.Generic.IList<INamedObject2*>* get_Items();
C++/CLI
[__DynamicallyInvokableAttribute()]
protected:
property System.Collections.Generic.IList<INamedObject2^>^ Items {
   System.Collections.Generic.IList<INamedObject2^>^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaCollection Class
WebTextEditorMediaCollection Members


Parent Property

[image]
Intersoft WebTextEditor Documentation
Parent Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMediaCollection Class : Parent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMediaCollection
Dim value As System.Object

value = instance.Parent
C#
public System.object Parent {get;}
Delphi
public read-only property Parent: System.TObject;
JScript
public function get Parent : System.Object
Managed Extensions for C++
public: __property System.Object* get_Parent();
C++/CLI
public:
property System.Object^ Parent {
   System.Object^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaCollection Class
WebTextEditorMediaCollection Members


Remove Method

[image]
Intersoft WebTextEditor Documentation
Remove Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMediaCollection Class : Remove Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Function Remove( _
   ByVal item As ISNet.WebUI.INamedObject2 _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMediaCollection
Dim item As ISNet.WebUI.INamedObject2
Dim value As System.Boolean

value = instance.Remove(item)
C#
[__DynamicallyInvokableAttribute()]
public System.bool Remove(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public function Remove(
    item: ISNet.WebUI.INamedObject2
): System.Boolean;
JScript
__DynamicallyInvokableAttribute()
public function Remove(
   item : ISNet.WebUI.INamedObject2
) : System.boolean;
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: System.bool Remove(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
System.bool Remove(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaCollection Class
WebTextEditorMediaCollection Members


RemoveAt Method

[image]
Intersoft WebTextEditor Documentation
RemoveAt Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMediaCollection Class : RemoveAt Method

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMediaCollection
Dim index As System.Integer

instance.RemoveAt(index)
C#
[__DynamicallyInvokableAttribute()]
public void RemoveAt(
   System.int index
)
Delphi
public procedure RemoveAt(
    index: System.Integer
);
JScript
__DynamicallyInvokableAttribute()
public function RemoveAt(
   index : System.int
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void RemoveAt(
   System.int index
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void RemoveAt(
   System.int index
)

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaCollection Class
WebTextEditorMediaCollection Members


RemoveItem Method

[image]
Intersoft WebTextEditor Documentation
RemoveItem Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMediaCollection Class : RemoveItem Method

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub RemoveItem( _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMediaCollection
Dim index As System.Integer

instance.RemoveItem(index)
C#
protected virtual void RemoveItem(
   System.int index
)
Delphi
protected procedure RemoveItem(
    index: System.Integer
); virtual;
JScript
protected function RemoveItem(
   index : System.int
);
Managed Extensions for C++
protected: virtual void RemoveItem(
   System.int index
)
C++/CLI
protected:
virtual void RemoveItem(
   System.int index
)

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaCollection Class
WebTextEditorMediaCollection Members


SerializerConstructor Method

[image]
Intersoft WebTextEditor Documentation
SerializerConstructor Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMediaCollection Class : SerializerConstructor Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializerConstructor( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMediaCollection
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializerConstructor(info, context)
C#
public void SerializerConstructor(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializerConstructor(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializerConstructor(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializerConstructor(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializerConstructor(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaCollection Class
WebTextEditorMediaCollection Members


SetItem Method

[image]
Intersoft WebTextEditor Documentation
SetItem Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMediaCollection Class : SetItem Method

index
item

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub SetItem( _
   ByVal index As System.Integer, _
   ByVal item As ISNet.WebUI.INamedObject2 _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMediaCollection
Dim index As System.Integer
Dim item As ISNet.WebUI.INamedObject2

instance.SetItem(index, item)
C#
protected virtual void SetItem(
   System.int index,
   ISNet.WebUI.INamedObject2 item
)
Delphi
protected procedure SetItem(
    index: System.Integer;
    item: ISNet.WebUI.INamedObject2
); virtual;
JScript
protected function SetItem(
   index : System.int,
   item : ISNet.WebUI.INamedObject2
);
Managed Extensions for C++
protected: virtual void SetItem(
   System.int index,
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
protected:
virtual void SetItem(
   System.int index,
   ISNet.WebUI.INamedObject2^ item
)

Parameters

index
item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaCollection Class
WebTextEditorMediaCollection Members


SetParent Method

[image]
Intersoft WebTextEditor Documentation
SetParent Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMediaCollection Class : SetParent Method

parent

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SetParent( _
   ByVal parent As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMediaCollection
Dim parent As System.Object

instance.SetParent(parent)
C#
public virtual void SetParent(
   System.object parent
)
Delphi
public procedure SetParent(
    parent: System.TObject
); virtual;
JScript
public function SetParent(
   parent : System.Object
);
Managed Extensions for C++
public: virtual void SetParent(
   System.Object* parent
)
C++/CLI
public:
virtual void SetParent(
   System.Object^ parent
)

Parameters

parent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaCollection Class
WebTextEditorMediaCollection Members


WebTextEditorMediaResourceGroupCollection Class Properties

[image]
Intersoft WebTextEditor Documentation
WebTextEditorMediaResourceGroupCollection Class Properties
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorMediaResourceGroupCollection Class

Glossary Item Box

For a list of all members of this type, see WebTextEditorMediaResourceGroupCollection members.

Public Properties

 | Name | Description
Public Property | All | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

Protected Properties

 | Name | Description
Protected Property | Items | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Top

See Also

Reference

WebTextEditorMediaResourceGroupCollection Class
ISNet.WebUI.WebTextEditor Namespace


Add Method

[image]
Intersoft WebTextEditor Documentation
Add Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMediaResourceGroupCollection Class : Add Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Sub Add( _
   ByVal item As ISNet.WebUI.INamedObject2 _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMediaResourceGroupCollection
Dim item As ISNet.WebUI.INamedObject2

instance.Add(item)
C#
[__DynamicallyInvokableAttribute()]
public void Add(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public procedure Add(
    item: ISNet.WebUI.INamedObject2
);
JScript
__DynamicallyInvokableAttribute()
public function Add(
   item : ISNet.WebUI.INamedObject2
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void Add(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void Add(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaResourceGroupCollection Class
WebTextEditorMediaResourceGroupCollection Members


All Property

[image]
Intersoft WebTextEditor Documentation
All Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMediaResourceGroupCollection Class : All Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public ReadOnly Property All As ISNet.WebUI.INamedObject2()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMediaResourceGroupCollection
Dim value() As ISNet.WebUI.INamedObject2

value = instance.All
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public ISNet.WebUI.INamedObject2[] All {get;}
Delphi
public read-only property All: ISNet.WebUI.array of INamedObject2;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get All : ISNet.WebUI.INamedObject2[]
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property ISNet.WebUI.INamedObject2*[]* get_All();
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property ISNet.WebUI.array<INamedObject2^>^ All {
   ISNet.WebUI.array<INamedObject2^>^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaResourceGroupCollection Class
WebTextEditorMediaResourceGroupCollection Members


Clear Method

[image]
Intersoft WebTextEditor Documentation
Clear Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMediaResourceGroupCollection Class : Clear Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMediaResourceGroupCollection

instance.Clear()
C#
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public void Clear()
Delphi
public procedure Clear();
JScript
__DynamicallyInvokableAttribute()
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function Clear();
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: void Clear();
C++/CLI
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
void Clear();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaResourceGroupCollection Class
WebTextEditorMediaResourceGroupCollection Members


ClearItems Method

[image]
Intersoft WebTextEditor Documentation
ClearItems Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMediaResourceGroupCollection Class : ClearItems Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ClearItems()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMediaResourceGroupCollection

instance.ClearItems()
C#
protected virtual void ClearItems()
Delphi
protected procedure ClearItems(); virtual;
JScript
protected function ClearItems();
Managed Extensions for C++
protected: virtual void ClearItems();
C++/CLI
protected:
virtual void ClearItems();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaResourceGroupCollection Class
WebTextEditorMediaResourceGroupCollection Members


Contains Method

[image]
Intersoft WebTextEditor Documentation
Contains Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMediaResourceGroupCollection Class : Contains Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
<__DynamicallyInvokableAttribute()>
Public Function Contains( _
   ByVal item As ISNet.WebUI.INamedObject2 _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMediaResourceGroupCollection
Dim item As ISNet.WebUI.INamedObject2
Dim value As System.Boolean

value = instance.Contains(item)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public System.bool Contains(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public function Contains(
    item: ISNet.WebUI.INamedObject2
): System.Boolean;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
__DynamicallyInvokableAttribute()
public function Contains(
   item : ISNet.WebUI.INamedObject2
) : System.boolean;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public: System.bool Contains(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public:
System.bool Contains(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaResourceGroupCollection Class
WebTextEditorMediaResourceGroupCollection Members


CopyTo Method

[image]
Intersoft WebTextEditor Documentation
CopyTo Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMediaResourceGroupCollection Class : CopyTo Method

array
index

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Sub CopyTo( _
   ByVal array() As ISNet.WebUI.INamedObject2, _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMediaResourceGroupCollection
Dim array() As ISNet.WebUI.INamedObject2
Dim index As System.Integer

instance.CopyTo(array, index)
C#
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public void CopyTo(
   ISNet.WebUI.INamedObject2[] array,
   System.int index
)
Delphi
public procedure CopyTo(
    array: ISNet.WebUI.INamedObject2array of;
    index: System.Integer
);
JScript
__DynamicallyInvokableAttribute()
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function CopyTo(
   array : ISNet.WebUI.INamedObject2[],
   index : System.int
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: void CopyTo(
   ISNet.WebUI.INamedObject2*[]* array,
   System.int index
)
C++/CLI
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
void CopyTo(
   ISNet.WebUI.array<INamedObject2^>^ array,
   System.int index
)

Parameters

array
index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaResourceGroupCollection Class
WebTextEditorMediaResourceGroupCollection Members


Count Property

[image]
Intersoft WebTextEditor Documentation
Count Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMediaResourceGroupCollection Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public ReadOnly Property Count As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMediaResourceGroupCollection
Dim value As System.Integer

value = instance.Count
C#
[__DynamicallyInvokableAttribute()]
public System.int Count {get;}
Delphi
public read-only property Count: System.Integer;
JScript
__DynamicallyInvokableAttribute()
public function get Count : System.int
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: __property System.int get_Count();
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
property System.int Count {
   System.int get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaResourceGroupCollection Class
WebTextEditorMediaResourceGroupCollection Members


CreateArray Method

[image]
Intersoft WebTextEditor Documentation
CreateArray Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMediaResourceGroupCollection Class : CreateArray Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function CreateArray() As ISNet.WebUI.INamedObject2()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMediaResourceGroupCollection
Dim value() As ISNet.WebUI.INamedObject2

value = instance.CreateArray()
C#
protected ISNet.WebUI.INamedObject2[] CreateArray()
Delphi
protected function CreateArray(): ISNet.WebUI.array of INamedObject2;
JScript
protected function CreateArray() : ISNet.WebUI.INamedObject2[];
Managed Extensions for C++
protected: ISNet.WebUI.INamedObject2*[]* CreateArray();
C++/CLI
protected:
ISNet.WebUI.array<INamedObject2^>^ CreateArray();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaResourceGroupCollection Class
WebTextEditorMediaResourceGroupCollection Members


CreateNewItem Method

[image]
Intersoft WebTextEditor Documentation
CreateNewItem Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMediaResourceGroupCollection Class : CreateNewItem Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CreateNewItem() As WebTextEditorMediaResourceGroup
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMediaResourceGroupCollection
Dim value As WebTextEditorMediaResourceGroup

value = instance.CreateNewItem()
C#
public WebTextEditorMediaResourceGroup CreateNewItem()
Delphi
public function CreateNewItem(): WebTextEditorMediaResourceGroup;
JScript
public function CreateNewItem() : WebTextEditorMediaResourceGroup;
Managed Extensions for C++
public: WebTextEditorMediaResourceGroup* CreateNewItem();
C++/CLI
public:
WebTextEditorMediaResourceGroup^ CreateNewItem();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaResourceGroupCollection Class
WebTextEditorMediaResourceGroupCollection Members


GetEnumerator Method

[image]
Intersoft WebTextEditor Documentation
GetEnumerator Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMediaResourceGroupCollection Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Function GetEnumerator() As System.Collections.Generic.IEnumerator(Of INamedObject2)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMediaResourceGroupCollection
Dim value As System.Collections.Generic.IEnumerator(Of INamedObject2)

value = instance.GetEnumerator()
C#
[__DynamicallyInvokableAttribute()]
public System.Collections.Generic.IEnumerator<INamedObject2> GetEnumerator()
Delphi
public function GetEnumerator(): System.Collections.Generic.IEnumerator;
JScript
__DynamicallyInvokableAttribute()
public function GetEnumerator() : System.Collections.Generic.IEnumerator;
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: System.Collections.Generic.IEnumerator<INamedObject2*>* GetEnumerator();
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
System.Collections.Generic.IEnumerator<INamedObject2^>^ GetEnumerator();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaResourceGroupCollection Class
WebTextEditorMediaResourceGroupCollection Members


GetObjectData Method

[image]
Intersoft WebTextEditor Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMediaResourceGroupCollection Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMediaResourceGroupCollection
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaResourceGroupCollection Class
WebTextEditorMediaResourceGroupCollection Members


IndexOf Method

[image]
Intersoft WebTextEditor Documentation
IndexOf Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMediaResourceGroupCollection Class : IndexOf Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
<__DynamicallyInvokableAttribute()>
Public Function IndexOf( _
   ByVal item As ISNet.WebUI.INamedObject2 _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMediaResourceGroupCollection
Dim item As ISNet.WebUI.INamedObject2
Dim value As System.Integer

value = instance.IndexOf(item)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public System.int IndexOf(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public function IndexOf(
    item: ISNet.WebUI.INamedObject2
): System.Integer;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
__DynamicallyInvokableAttribute()
public function IndexOf(
   item : ISNet.WebUI.INamedObject2
) : System.int;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public: System.int IndexOf(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public:
System.int IndexOf(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaResourceGroupCollection Class
WebTextEditorMediaResourceGroupCollection Members


Insert Method

[image]
Intersoft WebTextEditor Documentation
Insert Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMediaResourceGroupCollection Class : Insert Method

index
item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal item As ISNet.WebUI.INamedObject2 _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMediaResourceGroupCollection
Dim index As System.Integer
Dim item As ISNet.WebUI.INamedObject2

instance.Insert(index, item)
C#
[__DynamicallyInvokableAttribute()]
public void Insert(
   System.int index,
   ISNet.WebUI.INamedObject2 item
)
Delphi
public procedure Insert(
    index: System.Integer;
    item: ISNet.WebUI.INamedObject2
);
JScript
__DynamicallyInvokableAttribute()
public function Insert(
   index : System.int,
   item : ISNet.WebUI.INamedObject2
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void Insert(
   System.int index,
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void Insert(
   System.int index,
   ISNet.WebUI.INamedObject2^ item
)

Parameters

index
item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaResourceGroupCollection Class
WebTextEditorMediaResourceGroupCollection Members


InsertItem Method

[image]
Intersoft WebTextEditor Documentation
InsertItem Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMediaResourceGroupCollection Class : InsertItem Method

index
item

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub InsertItem( _
   ByVal index As System.Integer, _
   ByVal item As ISNet.WebUI.INamedObject2 _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMediaResourceGroupCollection
Dim index As System.Integer
Dim item As ISNet.WebUI.INamedObject2

instance.InsertItem(index, item)
C#
protected virtual void InsertItem(
   System.int index,
   ISNet.WebUI.INamedObject2 item
)
Delphi
protected procedure InsertItem(
    index: System.Integer;
    item: ISNet.WebUI.INamedObject2
); virtual;
JScript
protected function InsertItem(
   index : System.int,
   item : ISNet.WebUI.INamedObject2
);
Managed Extensions for C++
protected: virtual void InsertItem(
   System.int index,
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
protected:
virtual void InsertItem(
   System.int index,
   ISNet.WebUI.INamedObject2^ item
)

Parameters

index
item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaResourceGroupCollection Class
WebTextEditorMediaResourceGroupCollection Members


Item Property

[image]
Intersoft WebTextEditor Documentation
Item Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMediaResourceGroupCollection Class : Item Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Default Property Item( _
   ByVal index As System.Integer _
) As ISNet.WebUI.INamedObject2
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMediaResourceGroupCollection
Dim index As System.Integer
Dim value As ISNet.WebUI.INamedObject2

instance.Item(index) = value

value = instance.Item(index)
C#
[__DynamicallyInvokableAttribute()]
public ISNet.WebUI.INamedObject2 this[
   System.int index
]; {get; set;}
Delphi
public  this: : ISNet.WebUI.INamedObject2;[
    index: System.Integer
]; read-write
JScript
__DynamicallyInvokableAttribute()
public  this[
   index : System.int
] get,set : ISNet.WebUI.INamedObject2
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: __property ISNet.WebUI.INamedObject2* get_Item   System.int index
;
public: __property void set_Item   System.int index,
   ISNet.WebUI.INamedObject2* value
;
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
property ISNet.WebUI.INamedObject2^ default [int] {
   ISNet.WebUI.INamedObject2^ get(System.int index);
   void set (System.int index, ISNet.WebUI.INamedObject2^ value);
}

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaResourceGroupCollection Class
WebTextEditorMediaResourceGroupCollection Members


Items Property

[image]
Intersoft WebTextEditor Documentation
Items Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMediaResourceGroupCollection Class : Items Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Protected ReadOnly Property Items As System.Collections.Generic.IList(Of INamedObject2)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMediaResourceGroupCollection
Dim value As System.Collections.Generic.IList(Of INamedObject2)

value = instance.Items
C#
[__DynamicallyInvokableAttribute()]
protected System.Collections.Generic.IList<INamedObject2> Items {get;}
Delphi
protected read-only property Items: System.Collections.Generic.IList;
JScript
__DynamicallyInvokableAttribute()
protected function get Items : System.Collections.Generic.IList
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
protected: __property System.Collections.Generic.IList<INamedObject2*>* get_Items();
C++/CLI
[__DynamicallyInvokableAttribute()]
protected:
property System.Collections.Generic.IList<INamedObject2^>^ Items {
   System.Collections.Generic.IList<INamedObject2^>^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaResourceGroupCollection Class
WebTextEditorMediaResourceGroupCollection Members


Parent Property

[image]
Intersoft WebTextEditor Documentation
Parent Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMediaResourceGroupCollection Class : Parent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMediaResourceGroupCollection
Dim value As System.Object

value = instance.Parent
C#
public System.object Parent {get;}
Delphi
public read-only property Parent: System.TObject;
JScript
public function get Parent : System.Object
Managed Extensions for C++
public: __property System.Object* get_Parent();
C++/CLI
public:
property System.Object^ Parent {
   System.Object^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaResourceGroupCollection Class
WebTextEditorMediaResourceGroupCollection Members


Remove Method

[image]
Intersoft WebTextEditor Documentation
Remove Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMediaResourceGroupCollection Class : Remove Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Function Remove( _
   ByVal item As ISNet.WebUI.INamedObject2 _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMediaResourceGroupCollection
Dim item As ISNet.WebUI.INamedObject2
Dim value As System.Boolean

value = instance.Remove(item)
C#
[__DynamicallyInvokableAttribute()]
public System.bool Remove(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public function Remove(
    item: ISNet.WebUI.INamedObject2
): System.Boolean;
JScript
__DynamicallyInvokableAttribute()
public function Remove(
   item : ISNet.WebUI.INamedObject2
) : System.boolean;
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: System.bool Remove(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
System.bool Remove(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaResourceGroupCollection Class
WebTextEditorMediaResourceGroupCollection Members


RemoveAt Method

[image]
Intersoft WebTextEditor Documentation
RemoveAt Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMediaResourceGroupCollection Class : RemoveAt Method

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMediaResourceGroupCollection
Dim index As System.Integer

instance.RemoveAt(index)
C#
[__DynamicallyInvokableAttribute()]
public void RemoveAt(
   System.int index
)
Delphi
public procedure RemoveAt(
    index: System.Integer
);
JScript
__DynamicallyInvokableAttribute()
public function RemoveAt(
   index : System.int
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void RemoveAt(
   System.int index
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void RemoveAt(
   System.int index
)

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaResourceGroupCollection Class
WebTextEditorMediaResourceGroupCollection Members


RemoveItem Method

[image]
Intersoft WebTextEditor Documentation
RemoveItem Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMediaResourceGroupCollection Class : RemoveItem Method

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub RemoveItem( _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMediaResourceGroupCollection
Dim index As System.Integer

instance.RemoveItem(index)
C#
protected virtual void RemoveItem(
   System.int index
)
Delphi
protected procedure RemoveItem(
    index: System.Integer
); virtual;
JScript
protected function RemoveItem(
   index : System.int
);
Managed Extensions for C++
protected: virtual void RemoveItem(
   System.int index
)
C++/CLI
protected:
virtual void RemoveItem(
   System.int index
)

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaResourceGroupCollection Class
WebTextEditorMediaResourceGroupCollection Members


SerializerConstructor Method

[image]
Intersoft WebTextEditor Documentation
SerializerConstructor Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMediaResourceGroupCollection Class : SerializerConstructor Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializerConstructor( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMediaResourceGroupCollection
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializerConstructor(info, context)
C#
public void SerializerConstructor(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializerConstructor(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializerConstructor(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializerConstructor(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializerConstructor(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaResourceGroupCollection Class
WebTextEditorMediaResourceGroupCollection Members


SetItem Method

[image]
Intersoft WebTextEditor Documentation
SetItem Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMediaResourceGroupCollection Class : SetItem Method

index
item

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub SetItem( _
   ByVal index As System.Integer, _
   ByVal item As ISNet.WebUI.INamedObject2 _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMediaResourceGroupCollection
Dim index As System.Integer
Dim item As ISNet.WebUI.INamedObject2

instance.SetItem(index, item)
C#
protected virtual void SetItem(
   System.int index,
   ISNet.WebUI.INamedObject2 item
)
Delphi
protected procedure SetItem(
    index: System.Integer;
    item: ISNet.WebUI.INamedObject2
); virtual;
JScript
protected function SetItem(
   index : System.int,
   item : ISNet.WebUI.INamedObject2
);
Managed Extensions for C++
protected: virtual void SetItem(
   System.int index,
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
protected:
virtual void SetItem(
   System.int index,
   ISNet.WebUI.INamedObject2^ item
)

Parameters

index
item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaResourceGroupCollection Class
WebTextEditorMediaResourceGroupCollection Members


SetParent Method

[image]
Intersoft WebTextEditor Documentation
SetParent Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMediaResourceGroupCollection Class : SetParent Method

parent

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SetParent( _
   ByVal parent As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMediaResourceGroupCollection
Dim parent As System.Object

instance.SetParent(parent)
C#
public virtual void SetParent(
   System.object parent
)
Delphi
public procedure SetParent(
    parent: System.TObject
); virtual;
JScript
public function SetParent(
   parent : System.Object
);
Managed Extensions for C++
public: virtual void SetParent(
   System.Object* parent
)
C++/CLI
public:
virtual void SetParent(
   System.Object^ parent
)

Parameters

parent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaResourceGroupCollection Class
WebTextEditorMediaResourceGroupCollection Members


Clone Method

[image]
Intersoft WebTextEditor Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMediaResourceGroup Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMediaResourceGroup
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaResourceGroup Class
WebTextEditorMediaResourceGroup Members


Collection Property

[image]
Intersoft WebTextEditor Documentation
Collection Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMediaResourceGroup Class : Collection Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
Public Property Collection As ISNet.WebUI.ISCollectionBase(Of INamedObject2)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMediaResourceGroup
Dim value As ISNet.WebUI.ISCollectionBase(Of INamedObject2)

instance.Collection = value

value = instance.Collection
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public ISNet.WebUI.ISCollectionBase<INamedObject2> Collection {get; set;}
Delphi
public read-write property Collection: ISNet.WebUI.ISCollectionBase;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
public function get,set Collection : ISNet.WebUI.ISCollectionBase
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public: __property ISNet.WebUI.ISCollectionBase<INamedObject2*>* get_Collection();
public: __property void set_Collection(
   ISNet.WebUI.ISCollectionBase<INamedObject2*>* value
);
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public:
property ISNet.WebUI.ISCollectionBase<INamedObject2^>^ Collection {
   ISNet.WebUI.ISCollectionBase<INamedObject2^>^ get();
   void set (    ISNet.WebUI.ISCollectionBase<INamedObject2^>^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaResourceGroup Class
WebTextEditorMediaResourceGroup Members


CopyFrom Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMediaResourceGroup Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaResourceGroup Class
WebTextEditorMediaResourceGroup Members


CopyFrom(Object) Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMediaResourceGroup Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMediaResourceGroup
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaResourceGroup Class
WebTextEditorMediaResourceGroup Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMediaResourceGroup Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMediaResourceGroup
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaResourceGroup Class
WebTextEditorMediaResourceGroup Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebTextEditor Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMediaResourceGroup Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMediaResourceGroup
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaResourceGroup Class
WebTextEditorMediaResourceGroup Members


GetHashCode Method

[image]
Intersoft WebTextEditor Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMediaResourceGroup Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMediaResourceGroup
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaResourceGroup Class
WebTextEditorMediaResourceGroup Members


GetPropertyString Method

[image]
Intersoft WebTextEditor Documentation
GetPropertyString Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMediaResourceGroup Class : GetPropertyString Method

v

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetPropertyString( _
   ByVal v As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMediaResourceGroup
Dim v As System.String
Dim value As System.String

value = instance.GetPropertyString(v)
C#
protected virtual System.string GetPropertyString(
   System.string v
)
Delphi
protected function GetPropertyString(
    v: System.String
): System.String; virtual;
JScript
protected function GetPropertyString(
   v : System.String
) : System.String;
Managed Extensions for C++
protected: virtual System.string* GetPropertyString(
   System.string* v
)
C++/CLI
protected:
virtual System.String^ GetPropertyString(
   System.String^ v
)

Parameters

v

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaResourceGroup Class
WebTextEditorMediaResourceGroup Members


IsEmpty Method

[image]
Intersoft WebTextEditor Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMediaResourceGroup Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMediaResourceGroup
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaResourceGroup Class
WebTextEditorMediaResourceGroup Members


IsInSerializationContext Method

[image]
Intersoft WebTextEditor Documentation
IsInSerializationContext Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMediaResourceGroup Class : IsInSerializationContext Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function IsInSerializationContext() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMediaResourceGroup
Dim value As System.Boolean

value = instance.IsInSerializationContext()
C#
protected virtual System.bool IsInSerializationContext()
Delphi
protected function IsInSerializationContext(): System.Boolean; virtual;
JScript
protected function IsInSerializationContext() : System.boolean;
Managed Extensions for C++
protected: virtual System.bool IsInSerializationContext();
C++/CLI
protected:
virtual System.bool IsInSerializationContext();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaResourceGroup Class
WebTextEditorMediaResourceGroup Members


OnItemAdd Method

[image]
Intersoft WebTextEditor Documentation
OnItemAdd Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMediaResourceGroup Class : OnItemAdd Method

collection

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnItemAdd( _
   ByVal collection As ISNet.WebUI.ISCollectionBase(Of INamedObject2) _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMediaResourceGroup
Dim collection As ISNet.WebUI.ISCollectionBase(Of INamedObject2)

instance.OnItemAdd(collection)
C#
protected virtual void OnItemAdd(
   ISNet.WebUI.ISCollectionBase<INamedObject2> collection
)
Delphi
protected procedure OnItemAdd(
    collection: ISNet.WebUI.ISCollectionBase
); virtual;
JScript
protected function OnItemAdd(
   collection : ISNet.WebUI.ISCollectionBase
);
Managed Extensions for C++
protected: virtual void OnItemAdd(
   ISNet.WebUI.ISCollectionBase<INamedObject2*>* collection
)
C++/CLI
protected:
virtual void OnItemAdd(
   ISNet.WebUI.ISCollectionBase<INamedObject2^>^ collection
)

Parameters

collection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaResourceGroup Class
WebTextEditorMediaResourceGroup Members


OnItemRemove Method

[image]
Intersoft WebTextEditor Documentation
OnItemRemove Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMediaResourceGroup Class : OnItemRemove Method

collection

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnItemRemove( _
   ByVal collection As ISNet.WebUI.ISCollectionBase(Of INamedObject2) _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMediaResourceGroup
Dim collection As ISNet.WebUI.ISCollectionBase(Of INamedObject2)

instance.OnItemRemove(collection)
C#
protected virtual void OnItemRemove(
   ISNet.WebUI.ISCollectionBase<INamedObject2> collection
)
Delphi
protected procedure OnItemRemove(
    collection: ISNet.WebUI.ISCollectionBase
); virtual;
JScript
protected function OnItemRemove(
   collection : ISNet.WebUI.ISCollectionBase
);
Managed Extensions for C++
protected: virtual void OnItemRemove(
   ISNet.WebUI.ISCollectionBase<INamedObject2*>* collection
)
C++/CLI
protected:
virtual void OnItemRemove(
   ISNet.WebUI.ISCollectionBase<INamedObject2^>^ collection
)

Parameters

collection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaResourceGroup Class
WebTextEditorMediaResourceGroup Members


Reset Method

[image]
Intersoft WebTextEditor Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMediaResourceGroup Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMediaResourceGroup

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaResourceGroup Class
WebTextEditorMediaResourceGroup Members


SerializeObjectData Method

[image]
Intersoft WebTextEditor Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMediaResourceGroup Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMediaResourceGroup
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaResourceGroup Class
WebTextEditorMediaResourceGroup Members


ToString Method

[image]
Intersoft WebTextEditor Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMediaResourceGroup Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMediaResourceGroup
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMediaResourceGroup Class
WebTextEditorMediaResourceGroup Members


Clone Method

[image]
Intersoft WebTextEditor Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMedia Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMedia
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMedia Class
WebTextEditorMedia Members


Collection Property

[image]
Intersoft WebTextEditor Documentation
Collection Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMedia Class : Collection Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
Public Property Collection As ISNet.WebUI.ISCollectionBase(Of INamedObject2)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMedia
Dim value As ISNet.WebUI.ISCollectionBase(Of INamedObject2)

instance.Collection = value

value = instance.Collection
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public ISNet.WebUI.ISCollectionBase<INamedObject2> Collection {get; set;}
Delphi
public read-write property Collection: ISNet.WebUI.ISCollectionBase;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
public function get,set Collection : ISNet.WebUI.ISCollectionBase
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public: __property ISNet.WebUI.ISCollectionBase<INamedObject2*>* get_Collection();
public: __property void set_Collection(
   ISNet.WebUI.ISCollectionBase<INamedObject2*>* value
);
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public:
property ISNet.WebUI.ISCollectionBase<INamedObject2^>^ Collection {
   ISNet.WebUI.ISCollectionBase<INamedObject2^>^ get();
   void set (    ISNet.WebUI.ISCollectionBase<INamedObject2^>^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMedia Class
WebTextEditorMedia Members


CopyFrom Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMedia Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMedia Class
WebTextEditorMedia Members


CopyFrom(Object) Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMedia Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMedia
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMedia Class
WebTextEditorMedia Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMedia Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMedia
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMedia Class
WebTextEditorMedia Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebTextEditor Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMedia Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMedia
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMedia Class
WebTextEditorMedia Members


GetHashCode Method

[image]
Intersoft WebTextEditor Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMedia Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMedia
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMedia Class
WebTextEditorMedia Members


GetPropertyString Method

[image]
Intersoft WebTextEditor Documentation
GetPropertyString Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMedia Class : GetPropertyString Method

v

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetPropertyString( _
   ByVal v As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMedia
Dim v As System.String
Dim value As System.String

value = instance.GetPropertyString(v)
C#
protected virtual System.string GetPropertyString(
   System.string v
)
Delphi
protected function GetPropertyString(
    v: System.String
): System.String; virtual;
JScript
protected function GetPropertyString(
   v : System.String
) : System.String;
Managed Extensions for C++
protected: virtual System.string* GetPropertyString(
   System.string* v
)
C++/CLI
protected:
virtual System.String^ GetPropertyString(
   System.String^ v
)

Parameters

v

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMedia Class
WebTextEditorMedia Members


IsEmpty Method

[image]
Intersoft WebTextEditor Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMedia Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMedia
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMedia Class
WebTextEditorMedia Members


IsInSerializationContext Method

[image]
Intersoft WebTextEditor Documentation
IsInSerializationContext Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMedia Class : IsInSerializationContext Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function IsInSerializationContext() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMedia
Dim value As System.Boolean

value = instance.IsInSerializationContext()
C#
protected virtual System.bool IsInSerializationContext()
Delphi
protected function IsInSerializationContext(): System.Boolean; virtual;
JScript
protected function IsInSerializationContext() : System.boolean;
Managed Extensions for C++
protected: virtual System.bool IsInSerializationContext();
C++/CLI
protected:
virtual System.bool IsInSerializationContext();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMedia Class
WebTextEditorMedia Members


OnItemAdd Method

[image]
Intersoft WebTextEditor Documentation
OnItemAdd Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMedia Class : OnItemAdd Method

collection

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnItemAdd( _
   ByVal collection As ISNet.WebUI.ISCollectionBase(Of INamedObject2) _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMedia
Dim collection As ISNet.WebUI.ISCollectionBase(Of INamedObject2)

instance.OnItemAdd(collection)
C#
protected virtual void OnItemAdd(
   ISNet.WebUI.ISCollectionBase<INamedObject2> collection
)
Delphi
protected procedure OnItemAdd(
    collection: ISNet.WebUI.ISCollectionBase
); virtual;
JScript
protected function OnItemAdd(
   collection : ISNet.WebUI.ISCollectionBase
);
Managed Extensions for C++
protected: virtual void OnItemAdd(
   ISNet.WebUI.ISCollectionBase<INamedObject2*>* collection
)
C++/CLI
protected:
virtual void OnItemAdd(
   ISNet.WebUI.ISCollectionBase<INamedObject2^>^ collection
)

Parameters

collection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMedia Class
WebTextEditorMedia Members


OnItemRemove Method

[image]
Intersoft WebTextEditor Documentation
OnItemRemove Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMedia Class : OnItemRemove Method

collection

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnItemRemove( _
   ByVal collection As ISNet.WebUI.ISCollectionBase(Of INamedObject2) _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMedia
Dim collection As ISNet.WebUI.ISCollectionBase(Of INamedObject2)

instance.OnItemRemove(collection)
C#
protected virtual void OnItemRemove(
   ISNet.WebUI.ISCollectionBase<INamedObject2> collection
)
Delphi
protected procedure OnItemRemove(
    collection: ISNet.WebUI.ISCollectionBase
); virtual;
JScript
protected function OnItemRemove(
   collection : ISNet.WebUI.ISCollectionBase
);
Managed Extensions for C++
protected: virtual void OnItemRemove(
   ISNet.WebUI.ISCollectionBase<INamedObject2*>* collection
)
C++/CLI
protected:
virtual void OnItemRemove(
   ISNet.WebUI.ISCollectionBase<INamedObject2^>^ collection
)

Parameters

collection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMedia Class
WebTextEditorMedia Members


Reset Method

[image]
Intersoft WebTextEditor Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMedia Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMedia

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMedia Class
WebTextEditorMedia Members


SerializeObjectData Method

[image]
Intersoft WebTextEditor Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMedia Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMedia
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMedia Class
WebTextEditorMedia Members


ToString Method

[image]
Intersoft WebTextEditor Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorMedia Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorMedia
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorMedia Class
WebTextEditorMedia Members


WebTextEditorResourceCollection Class Properties

[image]
Intersoft WebTextEditor Documentation
WebTextEditorResourceCollection Class Properties
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorResourceCollection Class

Glossary Item Box

For a list of all members of this type, see WebTextEditorResourceCollection members.

Public Properties

 | Name | Description
Public Property | All | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

Protected Properties

 | Name | Description
Protected Property | Items | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Top

See Also

Reference

WebTextEditorResourceCollection Class
ISNet.WebUI.WebTextEditor Namespace


Add Method

[image]
Intersoft WebTextEditor Documentation
Add Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorResourceCollection Class : Add Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Sub Add( _
   ByVal item As ISNet.WebUI.INamedObject2 _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorResourceCollection
Dim item As ISNet.WebUI.INamedObject2

instance.Add(item)
C#
[__DynamicallyInvokableAttribute()]
public void Add(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public procedure Add(
    item: ISNet.WebUI.INamedObject2
);
JScript
__DynamicallyInvokableAttribute()
public function Add(
   item : ISNet.WebUI.INamedObject2
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void Add(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void Add(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorResourceCollection Class
WebTextEditorResourceCollection Members


All Property

[image]
Intersoft WebTextEditor Documentation
All Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorResourceCollection Class : All Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public ReadOnly Property All As ISNet.WebUI.INamedObject2()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorResourceCollection
Dim value() As ISNet.WebUI.INamedObject2

value = instance.All
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public ISNet.WebUI.INamedObject2[] All {get;}
Delphi
public read-only property All: ISNet.WebUI.array of INamedObject2;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get All : ISNet.WebUI.INamedObject2[]
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property ISNet.WebUI.INamedObject2*[]* get_All();
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property ISNet.WebUI.array<INamedObject2^>^ All {
   ISNet.WebUI.array<INamedObject2^>^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorResourceCollection Class
WebTextEditorResourceCollection Members


Clear Method

[image]
Intersoft WebTextEditor Documentation
Clear Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorResourceCollection Class : Clear Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorResourceCollection

instance.Clear()
C#
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public void Clear()
Delphi
public procedure Clear();
JScript
__DynamicallyInvokableAttribute()
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function Clear();
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: void Clear();
C++/CLI
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
void Clear();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorResourceCollection Class
WebTextEditorResourceCollection Members


ClearItems Method

[image]
Intersoft WebTextEditor Documentation
ClearItems Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorResourceCollection Class : ClearItems Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ClearItems()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorResourceCollection

instance.ClearItems()
C#
protected virtual void ClearItems()
Delphi
protected procedure ClearItems(); virtual;
JScript
protected function ClearItems();
Managed Extensions for C++
protected: virtual void ClearItems();
C++/CLI
protected:
virtual void ClearItems();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorResourceCollection Class
WebTextEditorResourceCollection Members


Contains Method

[image]
Intersoft WebTextEditor Documentation
Contains Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorResourceCollection Class : Contains Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
<__DynamicallyInvokableAttribute()>
Public Function Contains( _
   ByVal item As ISNet.WebUI.INamedObject2 _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorResourceCollection
Dim item As ISNet.WebUI.INamedObject2
Dim value As System.Boolean

value = instance.Contains(item)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public System.bool Contains(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public function Contains(
    item: ISNet.WebUI.INamedObject2
): System.Boolean;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
__DynamicallyInvokableAttribute()
public function Contains(
   item : ISNet.WebUI.INamedObject2
) : System.boolean;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public: System.bool Contains(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public:
System.bool Contains(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorResourceCollection Class
WebTextEditorResourceCollection Members


CopyTo Method

[image]
Intersoft WebTextEditor Documentation
CopyTo Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorResourceCollection Class : CopyTo Method

array
index

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Sub CopyTo( _
   ByVal array() As ISNet.WebUI.INamedObject2, _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorResourceCollection
Dim array() As ISNet.WebUI.INamedObject2
Dim index As System.Integer

instance.CopyTo(array, index)
C#
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public void CopyTo(
   ISNet.WebUI.INamedObject2[] array,
   System.int index
)
Delphi
public procedure CopyTo(
    array: ISNet.WebUI.INamedObject2array of;
    index: System.Integer
);
JScript
__DynamicallyInvokableAttribute()
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function CopyTo(
   array : ISNet.WebUI.INamedObject2[],
   index : System.int
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: void CopyTo(
   ISNet.WebUI.INamedObject2*[]* array,
   System.int index
)
C++/CLI
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
void CopyTo(
   ISNet.WebUI.array<INamedObject2^>^ array,
   System.int index
)

Parameters

array
index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorResourceCollection Class
WebTextEditorResourceCollection Members


Count Property

[image]
Intersoft WebTextEditor Documentation
Count Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorResourceCollection Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public ReadOnly Property Count As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorResourceCollection
Dim value As System.Integer

value = instance.Count
C#
[__DynamicallyInvokableAttribute()]
public System.int Count {get;}
Delphi
public read-only property Count: System.Integer;
JScript
__DynamicallyInvokableAttribute()
public function get Count : System.int
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: __property System.int get_Count();
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
property System.int Count {
   System.int get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorResourceCollection Class
WebTextEditorResourceCollection Members


CreateArray Method

[image]
Intersoft WebTextEditor Documentation
CreateArray Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorResourceCollection Class : CreateArray Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function CreateArray() As ISNet.WebUI.INamedObject2()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorResourceCollection
Dim value() As ISNet.WebUI.INamedObject2

value = instance.CreateArray()
C#
protected ISNet.WebUI.INamedObject2[] CreateArray()
Delphi
protected function CreateArray(): ISNet.WebUI.array of INamedObject2;
JScript
protected function CreateArray() : ISNet.WebUI.INamedObject2[];
Managed Extensions for C++
protected: ISNet.WebUI.INamedObject2*[]* CreateArray();
C++/CLI
protected:
ISNet.WebUI.array<INamedObject2^>^ CreateArray();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorResourceCollection Class
WebTextEditorResourceCollection Members


CreateNewItem Method

[image]
Intersoft WebTextEditor Documentation
CreateNewItem Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorResourceCollection Class : CreateNewItem Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CreateNewItem() As WebTextEditorResource
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorResourceCollection
Dim value As WebTextEditorResource

value = instance.CreateNewItem()
C#
public WebTextEditorResource CreateNewItem()
Delphi
public function CreateNewItem(): WebTextEditorResource;
JScript
public function CreateNewItem() : WebTextEditorResource;
Managed Extensions for C++
public: WebTextEditorResource* CreateNewItem();
C++/CLI
public:
WebTextEditorResource^ CreateNewItem();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorResourceCollection Class
WebTextEditorResourceCollection Members


GetEnumerator Method

[image]
Intersoft WebTextEditor Documentation
GetEnumerator Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorResourceCollection Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Function GetEnumerator() As System.Collections.Generic.IEnumerator(Of INamedObject2)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorResourceCollection
Dim value As System.Collections.Generic.IEnumerator(Of INamedObject2)

value = instance.GetEnumerator()
C#
[__DynamicallyInvokableAttribute()]
public System.Collections.Generic.IEnumerator<INamedObject2> GetEnumerator()
Delphi
public function GetEnumerator(): System.Collections.Generic.IEnumerator;
JScript
__DynamicallyInvokableAttribute()
public function GetEnumerator() : System.Collections.Generic.IEnumerator;
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: System.Collections.Generic.IEnumerator<INamedObject2*>* GetEnumerator();
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
System.Collections.Generic.IEnumerator<INamedObject2^>^ GetEnumerator();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorResourceCollection Class
WebTextEditorResourceCollection Members


GetObjectData Method

[image]
Intersoft WebTextEditor Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorResourceCollection Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorResourceCollection
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorResourceCollection Class
WebTextEditorResourceCollection Members


IndexOf Method

[image]
Intersoft WebTextEditor Documentation
IndexOf Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorResourceCollection Class : IndexOf Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
<__DynamicallyInvokableAttribute()>
Public Function IndexOf( _
   ByVal item As ISNet.WebUI.INamedObject2 _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorResourceCollection
Dim item As ISNet.WebUI.INamedObject2
Dim value As System.Integer

value = instance.IndexOf(item)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public System.int IndexOf(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public function IndexOf(
    item: ISNet.WebUI.INamedObject2
): System.Integer;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
__DynamicallyInvokableAttribute()
public function IndexOf(
   item : ISNet.WebUI.INamedObject2
) : System.int;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public: System.int IndexOf(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public:
System.int IndexOf(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorResourceCollection Class
WebTextEditorResourceCollection Members


Insert Method

[image]
Intersoft WebTextEditor Documentation
Insert Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorResourceCollection Class : Insert Method

index
item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal item As ISNet.WebUI.INamedObject2 _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorResourceCollection
Dim index As System.Integer
Dim item As ISNet.WebUI.INamedObject2

instance.Insert(index, item)
C#
[__DynamicallyInvokableAttribute()]
public void Insert(
   System.int index,
   ISNet.WebUI.INamedObject2 item
)
Delphi
public procedure Insert(
    index: System.Integer;
    item: ISNet.WebUI.INamedObject2
);
JScript
__DynamicallyInvokableAttribute()
public function Insert(
   index : System.int,
   item : ISNet.WebUI.INamedObject2
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void Insert(
   System.int index,
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void Insert(
   System.int index,
   ISNet.WebUI.INamedObject2^ item
)

Parameters

index
item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorResourceCollection Class
WebTextEditorResourceCollection Members


InsertItem Method

[image]
Intersoft WebTextEditor Documentation
InsertItem Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorResourceCollection Class : InsertItem Method

index
item

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub InsertItem( _
   ByVal index As System.Integer, _
   ByVal item As ISNet.WebUI.INamedObject2 _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorResourceCollection
Dim index As System.Integer
Dim item As ISNet.WebUI.INamedObject2

instance.InsertItem(index, item)
C#
protected virtual void InsertItem(
   System.int index,
   ISNet.WebUI.INamedObject2 item
)
Delphi
protected procedure InsertItem(
    index: System.Integer;
    item: ISNet.WebUI.INamedObject2
); virtual;
JScript
protected function InsertItem(
   index : System.int,
   item : ISNet.WebUI.INamedObject2
);
Managed Extensions for C++
protected: virtual void InsertItem(
   System.int index,
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
protected:
virtual void InsertItem(
   System.int index,
   ISNet.WebUI.INamedObject2^ item
)

Parameters

index
item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorResourceCollection Class
WebTextEditorResourceCollection Members


Item Property

[image]
Intersoft WebTextEditor Documentation
Item Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorResourceCollection Class : Item Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Default Property Item( _
   ByVal index As System.Integer _
) As ISNet.WebUI.INamedObject2
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorResourceCollection
Dim index As System.Integer
Dim value As ISNet.WebUI.INamedObject2

instance.Item(index) = value

value = instance.Item(index)
C#
[__DynamicallyInvokableAttribute()]
public ISNet.WebUI.INamedObject2 this[
   System.int index
]; {get; set;}
Delphi
public  this: : ISNet.WebUI.INamedObject2;[
    index: System.Integer
]; read-write
JScript
__DynamicallyInvokableAttribute()
public  this[
   index : System.int
] get,set : ISNet.WebUI.INamedObject2
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: __property ISNet.WebUI.INamedObject2* get_Item   System.int index
;
public: __property void set_Item   System.int index,
   ISNet.WebUI.INamedObject2* value
;
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
property ISNet.WebUI.INamedObject2^ default [int] {
   ISNet.WebUI.INamedObject2^ get(System.int index);
   void set (System.int index, ISNet.WebUI.INamedObject2^ value);
}

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorResourceCollection Class
WebTextEditorResourceCollection Members


Items Property

[image]
Intersoft WebTextEditor Documentation
Items Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorResourceCollection Class : Items Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Protected ReadOnly Property Items As System.Collections.Generic.IList(Of INamedObject2)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorResourceCollection
Dim value As System.Collections.Generic.IList(Of INamedObject2)

value = instance.Items
C#
[__DynamicallyInvokableAttribute()]
protected System.Collections.Generic.IList<INamedObject2> Items {get;}
Delphi
protected read-only property Items: System.Collections.Generic.IList;
JScript
__DynamicallyInvokableAttribute()
protected function get Items : System.Collections.Generic.IList
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
protected: __property System.Collections.Generic.IList<INamedObject2*>* get_Items();
C++/CLI
[__DynamicallyInvokableAttribute()]
protected:
property System.Collections.Generic.IList<INamedObject2^>^ Items {
   System.Collections.Generic.IList<INamedObject2^>^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorResourceCollection Class
WebTextEditorResourceCollection Members


Parent Property

[image]
Intersoft WebTextEditor Documentation
Parent Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorResourceCollection Class : Parent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorResourceCollection
Dim value As System.Object

value = instance.Parent
C#
public System.object Parent {get;}
Delphi
public read-only property Parent: System.TObject;
JScript
public function get Parent : System.Object
Managed Extensions for C++
public: __property System.Object* get_Parent();
C++/CLI
public:
property System.Object^ Parent {
   System.Object^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorResourceCollection Class
WebTextEditorResourceCollection Members


Remove Method

[image]
Intersoft WebTextEditor Documentation
Remove Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorResourceCollection Class : Remove Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Function Remove( _
   ByVal item As ISNet.WebUI.INamedObject2 _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorResourceCollection
Dim item As ISNet.WebUI.INamedObject2
Dim value As System.Boolean

value = instance.Remove(item)
C#
[__DynamicallyInvokableAttribute()]
public System.bool Remove(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public function Remove(
    item: ISNet.WebUI.INamedObject2
): System.Boolean;
JScript
__DynamicallyInvokableAttribute()
public function Remove(
   item : ISNet.WebUI.INamedObject2
) : System.boolean;
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: System.bool Remove(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
System.bool Remove(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorResourceCollection Class
WebTextEditorResourceCollection Members


RemoveAt Method

[image]
Intersoft WebTextEditor Documentation
RemoveAt Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorResourceCollection Class : RemoveAt Method

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorResourceCollection
Dim index As System.Integer

instance.RemoveAt(index)
C#
[__DynamicallyInvokableAttribute()]
public void RemoveAt(
   System.int index
)
Delphi
public procedure RemoveAt(
    index: System.Integer
);
JScript
__DynamicallyInvokableAttribute()
public function RemoveAt(
   index : System.int
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void RemoveAt(
   System.int index
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void RemoveAt(
   System.int index
)

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorResourceCollection Class
WebTextEditorResourceCollection Members


RemoveItem Method

[image]
Intersoft WebTextEditor Documentation
RemoveItem Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorResourceCollection Class : RemoveItem Method

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub RemoveItem( _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorResourceCollection
Dim index As System.Integer

instance.RemoveItem(index)
C#
protected virtual void RemoveItem(
   System.int index
)
Delphi
protected procedure RemoveItem(
    index: System.Integer
); virtual;
JScript
protected function RemoveItem(
   index : System.int
);
Managed Extensions for C++
protected: virtual void RemoveItem(
   System.int index
)
C++/CLI
protected:
virtual void RemoveItem(
   System.int index
)

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorResourceCollection Class
WebTextEditorResourceCollection Members


SerializerConstructor Method

[image]
Intersoft WebTextEditor Documentation
SerializerConstructor Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorResourceCollection Class : SerializerConstructor Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializerConstructor( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorResourceCollection
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializerConstructor(info, context)
C#
public void SerializerConstructor(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializerConstructor(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializerConstructor(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializerConstructor(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializerConstructor(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorResourceCollection Class
WebTextEditorResourceCollection Members


SetItem Method

[image]
Intersoft WebTextEditor Documentation
SetItem Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorResourceCollection Class : SetItem Method

index
item

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub SetItem( _
   ByVal index As System.Integer, _
   ByVal item As ISNet.WebUI.INamedObject2 _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorResourceCollection
Dim index As System.Integer
Dim item As ISNet.WebUI.INamedObject2

instance.SetItem(index, item)
C#
protected virtual void SetItem(
   System.int index,
   ISNet.WebUI.INamedObject2 item
)
Delphi
protected procedure SetItem(
    index: System.Integer;
    item: ISNet.WebUI.INamedObject2
); virtual;
JScript
protected function SetItem(
   index : System.int,
   item : ISNet.WebUI.INamedObject2
);
Managed Extensions for C++
protected: virtual void SetItem(
   System.int index,
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
protected:
virtual void SetItem(
   System.int index,
   ISNet.WebUI.INamedObject2^ item
)

Parameters

index
item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorResourceCollection Class
WebTextEditorResourceCollection Members


SetParent Method

[image]
Intersoft WebTextEditor Documentation
SetParent Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorResourceCollection Class : SetParent Method

parent

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SetParent( _
   ByVal parent As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorResourceCollection
Dim parent As System.Object

instance.SetParent(parent)
C#
public virtual void SetParent(
   System.object parent
)
Delphi
public procedure SetParent(
    parent: System.TObject
); virtual;
JScript
public function SetParent(
   parent : System.Object
);
Managed Extensions for C++
public: virtual void SetParent(
   System.Object* parent
)
C++/CLI
public:
virtual void SetParent(
   System.Object^ parent
)

Parameters

parent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorResourceCollection Class
WebTextEditorResourceCollection Members


Clone Method

[image]
Intersoft WebTextEditor Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorResource Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorResource
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorResource Class
WebTextEditorResource Members


Collection Property

[image]
Intersoft WebTextEditor Documentation
Collection Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorResource Class : Collection Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
Public Property Collection As ISNet.WebUI.ISCollectionBase(Of INamedObject2)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorResource
Dim value As ISNet.WebUI.ISCollectionBase(Of INamedObject2)

instance.Collection = value

value = instance.Collection
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public ISNet.WebUI.ISCollectionBase<INamedObject2> Collection {get; set;}
Delphi
public read-write property Collection: ISNet.WebUI.ISCollectionBase;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
public function get,set Collection : ISNet.WebUI.ISCollectionBase
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public: __property ISNet.WebUI.ISCollectionBase<INamedObject2*>* get_Collection();
public: __property void set_Collection(
   ISNet.WebUI.ISCollectionBase<INamedObject2*>* value
);
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public:
property ISNet.WebUI.ISCollectionBase<INamedObject2^>^ Collection {
   ISNet.WebUI.ISCollectionBase<INamedObject2^>^ get();
   void set (    ISNet.WebUI.ISCollectionBase<INamedObject2^>^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorResource Class
WebTextEditorResource Members


CopyFrom Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorResource Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorResource Class
WebTextEditorResource Members


CopyFrom(Object) Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorResource Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorResource
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorResource Class
WebTextEditorResource Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorResource Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorResource
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorResource Class
WebTextEditorResource Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebTextEditor Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorResource Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorResource
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorResource Class
WebTextEditorResource Members


GetHashCode Method

[image]
Intersoft WebTextEditor Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorResource Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorResource
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorResource Class
WebTextEditorResource Members


GetPropertyString Method

[image]
Intersoft WebTextEditor Documentation
GetPropertyString Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorResource Class : GetPropertyString Method

v

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetPropertyString( _
   ByVal v As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorResource
Dim v As System.String
Dim value As System.String

value = instance.GetPropertyString(v)
C#
protected virtual System.string GetPropertyString(
   System.string v
)
Delphi
protected function GetPropertyString(
    v: System.String
): System.String; virtual;
JScript
protected function GetPropertyString(
   v : System.String
) : System.String;
Managed Extensions for C++
protected: virtual System.string* GetPropertyString(
   System.string* v
)
C++/CLI
protected:
virtual System.String^ GetPropertyString(
   System.String^ v
)

Parameters

v

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorResource Class
WebTextEditorResource Members


IsEmpty Method

[image]
Intersoft WebTextEditor Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorResource Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorResource
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorResource Class
WebTextEditorResource Members


IsInSerializationContext Method

[image]
Intersoft WebTextEditor Documentation
IsInSerializationContext Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorResource Class : IsInSerializationContext Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function IsInSerializationContext() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorResource
Dim value As System.Boolean

value = instance.IsInSerializationContext()
C#
protected virtual System.bool IsInSerializationContext()
Delphi
protected function IsInSerializationContext(): System.Boolean; virtual;
JScript
protected function IsInSerializationContext() : System.boolean;
Managed Extensions for C++
protected: virtual System.bool IsInSerializationContext();
C++/CLI
protected:
virtual System.bool IsInSerializationContext();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorResource Class
WebTextEditorResource Members


OnItemAdd Method

[image]
Intersoft WebTextEditor Documentation
OnItemAdd Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorResource Class : OnItemAdd Method

collection

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnItemAdd( _
   ByVal collection As ISNet.WebUI.ISCollectionBase(Of INamedObject2) _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorResource
Dim collection As ISNet.WebUI.ISCollectionBase(Of INamedObject2)

instance.OnItemAdd(collection)
C#
protected virtual void OnItemAdd(
   ISNet.WebUI.ISCollectionBase<INamedObject2> collection
)
Delphi
protected procedure OnItemAdd(
    collection: ISNet.WebUI.ISCollectionBase
); virtual;
JScript
protected function OnItemAdd(
   collection : ISNet.WebUI.ISCollectionBase
);
Managed Extensions for C++
protected: virtual void OnItemAdd(
   ISNet.WebUI.ISCollectionBase<INamedObject2*>* collection
)
C++/CLI
protected:
virtual void OnItemAdd(
   ISNet.WebUI.ISCollectionBase<INamedObject2^>^ collection
)

Parameters

collection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorResource Class
WebTextEditorResource Members


OnItemRemove Method

[image]
Intersoft WebTextEditor Documentation
OnItemRemove Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorResource Class : OnItemRemove Method

collection

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnItemRemove( _
   ByVal collection As ISNet.WebUI.ISCollectionBase(Of INamedObject2) _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorResource
Dim collection As ISNet.WebUI.ISCollectionBase(Of INamedObject2)

instance.OnItemRemove(collection)
C#
protected virtual void OnItemRemove(
   ISNet.WebUI.ISCollectionBase<INamedObject2> collection
)
Delphi
protected procedure OnItemRemove(
    collection: ISNet.WebUI.ISCollectionBase
); virtual;
JScript
protected function OnItemRemove(
   collection : ISNet.WebUI.ISCollectionBase
);
Managed Extensions for C++
protected: virtual void OnItemRemove(
   ISNet.WebUI.ISCollectionBase<INamedObject2*>* collection
)
C++/CLI
protected:
virtual void OnItemRemove(
   ISNet.WebUI.ISCollectionBase<INamedObject2^>^ collection
)

Parameters

collection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorResource Class
WebTextEditorResource Members


Reset Method

[image]
Intersoft WebTextEditor Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorResource Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorResource

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorResource Class
WebTextEditorResource Members


SerializeObjectData Method

[image]
Intersoft WebTextEditor Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorResource Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorResource
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorResource Class
WebTextEditorResource Members


ToString Method

[image]
Intersoft WebTextEditor Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorResource Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorResource
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorResource Class
WebTextEditorResource Members


Clone Method

[image]
Intersoft WebTextEditor Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorSection Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorSection
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorSection Class
WebTextEditorSection Members


CopyFrom Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorSection Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorSection Class
WebTextEditorSection Members


CopyFrom(Object) Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorSection Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorSection
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorSection Class
WebTextEditorSection Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorSection Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorSection
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorSection Class
WebTextEditorSection Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebTextEditor Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorSection Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorSection
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorSection Class
WebTextEditorSection Members


GetHashCode Method

[image]
Intersoft WebTextEditor Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorSection Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorSection
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorSection Class
WebTextEditorSection Members


GetPropertyString Method

[image]
Intersoft WebTextEditor Documentation
GetPropertyString Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorSection Class : GetPropertyString Method

v

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetPropertyString( _
   ByVal v As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorSection
Dim v As System.String
Dim value As System.String

value = instance.GetPropertyString(v)
C#
protected virtual System.string GetPropertyString(
   System.string v
)
Delphi
protected function GetPropertyString(
    v: System.String
): System.String; virtual;
JScript
protected function GetPropertyString(
   v : System.String
) : System.String;
Managed Extensions for C++
protected: virtual System.string* GetPropertyString(
   System.string* v
)
C++/CLI
protected:
virtual System.String^ GetPropertyString(
   System.String^ v
)

Parameters

v

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorSection Class
WebTextEditorSection Members


IsEmpty Method

[image]
Intersoft WebTextEditor Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorSection Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorSection
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorSection Class
WebTextEditorSection Members


IsInSerializationContext Method

[image]
Intersoft WebTextEditor Documentation
IsInSerializationContext Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorSection Class : IsInSerializationContext Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function IsInSerializationContext() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorSection
Dim value As System.Boolean

value = instance.IsInSerializationContext()
C#
protected virtual System.bool IsInSerializationContext()
Delphi
protected function IsInSerializationContext(): System.Boolean; virtual;
JScript
protected function IsInSerializationContext() : System.boolean;
Managed Extensions for C++
protected: virtual System.bool IsInSerializationContext();
C++/CLI
protected:
virtual System.bool IsInSerializationContext();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorSection Class
WebTextEditorSection Members


Reset Method

[image]
Intersoft WebTextEditor Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorSection Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorSection

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorSection Class
WebTextEditorSection Members


SerializeObjectData Method

[image]
Intersoft WebTextEditor Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorSection Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorSection
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorSection Class
WebTextEditorSection Members


ToString Method

[image]
Intersoft WebTextEditor Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorSection Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorSection
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorSection Class
WebTextEditorSection Members


Clone Method

[image]
Intersoft WebTextEditor Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTaskPaneSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTaskPaneSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTaskPaneSettings Class
WebTextEditorTaskPaneSettings Members


CopyFrom Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTaskPaneSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTaskPaneSettings Class
WebTextEditorTaskPaneSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTaskPaneSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTaskPaneSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTaskPaneSettings Class
WebTextEditorTaskPaneSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTaskPaneSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTaskPaneSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTaskPaneSettings Class
WebTextEditorTaskPaneSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebTextEditor Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTaskPaneSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTaskPaneSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTaskPaneSettings Class
WebTextEditorTaskPaneSettings Members


GetHashCode Method

[image]
Intersoft WebTextEditor Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTaskPaneSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTaskPaneSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTaskPaneSettings Class
WebTextEditorTaskPaneSettings Members


GetPropertyString Method

[image]
Intersoft WebTextEditor Documentation
GetPropertyString Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTaskPaneSettings Class : GetPropertyString Method

v

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetPropertyString( _
   ByVal v As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTaskPaneSettings
Dim v As System.String
Dim value As System.String

value = instance.GetPropertyString(v)
C#
protected virtual System.string GetPropertyString(
   System.string v
)
Delphi
protected function GetPropertyString(
    v: System.String
): System.String; virtual;
JScript
protected function GetPropertyString(
   v : System.String
) : System.String;
Managed Extensions for C++
protected: virtual System.string* GetPropertyString(
   System.string* v
)
C++/CLI
protected:
virtual System.String^ GetPropertyString(
   System.String^ v
)

Parameters

v

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTaskPaneSettings Class
WebTextEditorTaskPaneSettings Members


IsEmpty Method

[image]
Intersoft WebTextEditor Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTaskPaneSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTaskPaneSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTaskPaneSettings Class
WebTextEditorTaskPaneSettings Members


IsInSerializationContext Method

[image]
Intersoft WebTextEditor Documentation
IsInSerializationContext Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTaskPaneSettings Class : IsInSerializationContext Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function IsInSerializationContext() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTaskPaneSettings
Dim value As System.Boolean

value = instance.IsInSerializationContext()
C#
protected virtual System.bool IsInSerializationContext()
Delphi
protected function IsInSerializationContext(): System.Boolean; virtual;
JScript
protected function IsInSerializationContext() : System.boolean;
Managed Extensions for C++
protected: virtual System.bool IsInSerializationContext();
C++/CLI
protected:
virtual System.bool IsInSerializationContext();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTaskPaneSettings Class
WebTextEditorTaskPaneSettings Members


Reset Method

[image]
Intersoft WebTextEditor Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTaskPaneSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTaskPaneSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTaskPaneSettings Class
WebTextEditorTaskPaneSettings Members


SerializeObjectData Method

[image]
Intersoft WebTextEditor Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTaskPaneSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTaskPaneSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTaskPaneSettings Class
WebTextEditorTaskPaneSettings Members


ToString Method

[image]
Intersoft WebTextEditor Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTaskPaneSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTaskPaneSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTaskPaneSettings Class
WebTextEditorTaskPaneSettings Members


Clone Method

[image]
Intersoft WebTextEditor Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


CopyFrom Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebTextEditor Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


GetHashCode Method

[image]
Intersoft WebTextEditor Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


GetPropertyString Method

[image]
Intersoft WebTextEditor Documentation
GetPropertyString Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : GetPropertyString Method

v

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetPropertyString( _
   ByVal v As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim v As System.String
Dim value As System.String

value = instance.GetPropertyString(v)
C#
protected virtual System.string GetPropertyString(
   System.string v
)
Delphi
protected function GetPropertyString(
    v: System.String
): System.String; virtual;
JScript
protected function GetPropertyString(
   v : System.String
) : System.String;
Managed Extensions for C++
protected: virtual System.string* GetPropertyString(
   System.string* v
)
C++/CLI
protected:
virtual System.String^ GetPropertyString(
   System.String^ v
)

Parameters

v

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


IsEmpty Method

[image]
Intersoft WebTextEditor Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


IsInSerializationContext Method

[image]
Intersoft WebTextEditor Documentation
IsInSerializationContext Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : IsInSerializationContext Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function IsInSerializationContext() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.Boolean

value = instance.IsInSerializationContext()
C#
protected virtual System.bool IsInSerializationContext()
Delphi
protected function IsInSerializationContext(): System.Boolean; virtual;
JScript
protected function IsInSerializationContext() : System.boolean;
Managed Extensions for C++
protected: virtual System.bool IsInSerializationContext();
C++/CLI
protected:
virtual System.bool IsInSerializationContext();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


Reset Method

[image]
Intersoft WebTextEditor Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


SerializeObjectData Method

[image]
Intersoft WebTextEditor Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


ToString Method

[image]
Intersoft WebTextEditor Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorTextSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorTextSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorTextSettings Class
WebTextEditorTextSettings Members


WebTextEditorToolBarCollection Class Properties

[image]
Intersoft WebTextEditor Documentation
WebTextEditorToolBarCollection Class Properties
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorToolBarCollection Class

Glossary Item Box

For a list of all members of this type, see WebTextEditorToolBarCollection members.

Public Properties

 | Name | Description
Public Property | All | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

Protected Properties

 | Name | Description
Protected Property | Items | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Top

See Also

Reference

WebTextEditorToolBarCollection Class
ISNet.WebUI.WebTextEditor Namespace


Add Method

[image]
Intersoft WebTextEditor Documentation
Add Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBarCollection Class : Add Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Sub Add( _
   ByVal item As ISNet.WebUI.INamedObject2 _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBarCollection
Dim item As ISNet.WebUI.INamedObject2

instance.Add(item)
C#
[__DynamicallyInvokableAttribute()]
public void Add(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public procedure Add(
    item: ISNet.WebUI.INamedObject2
);
JScript
__DynamicallyInvokableAttribute()
public function Add(
   item : ISNet.WebUI.INamedObject2
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void Add(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void Add(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBarCollection Class
WebTextEditorToolBarCollection Members


All Property

[image]
Intersoft WebTextEditor Documentation
All Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBarCollection Class : All Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public ReadOnly Property All As ISNet.WebUI.INamedObject2()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBarCollection
Dim value() As ISNet.WebUI.INamedObject2

value = instance.All
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public ISNet.WebUI.INamedObject2[] All {get;}
Delphi
public read-only property All: ISNet.WebUI.array of INamedObject2;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get All : ISNet.WebUI.INamedObject2[]
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property ISNet.WebUI.INamedObject2*[]* get_All();
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property ISNet.WebUI.array<INamedObject2^>^ All {
   ISNet.WebUI.array<INamedObject2^>^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBarCollection Class
WebTextEditorToolBarCollection Members


Clear Method

[image]
Intersoft WebTextEditor Documentation
Clear Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBarCollection Class : Clear Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBarCollection

instance.Clear()
C#
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public void Clear()
Delphi
public procedure Clear();
JScript
__DynamicallyInvokableAttribute()
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function Clear();
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: void Clear();
C++/CLI
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
void Clear();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBarCollection Class
WebTextEditorToolBarCollection Members


ClearItems Method

[image]
Intersoft WebTextEditor Documentation
ClearItems Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBarCollection Class : ClearItems Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ClearItems()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBarCollection

instance.ClearItems()
C#
protected virtual void ClearItems()
Delphi
protected procedure ClearItems(); virtual;
JScript
protected function ClearItems();
Managed Extensions for C++
protected: virtual void ClearItems();
C++/CLI
protected:
virtual void ClearItems();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBarCollection Class
WebTextEditorToolBarCollection Members


Contains Method

[image]
Intersoft WebTextEditor Documentation
Contains Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBarCollection Class : Contains Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
<__DynamicallyInvokableAttribute()>
Public Function Contains( _
   ByVal item As ISNet.WebUI.INamedObject2 _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBarCollection
Dim item As ISNet.WebUI.INamedObject2
Dim value As System.Boolean

value = instance.Contains(item)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public System.bool Contains(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public function Contains(
    item: ISNet.WebUI.INamedObject2
): System.Boolean;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
__DynamicallyInvokableAttribute()
public function Contains(
   item : ISNet.WebUI.INamedObject2
) : System.boolean;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public: System.bool Contains(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public:
System.bool Contains(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBarCollection Class
WebTextEditorToolBarCollection Members


CopyTo Method

[image]
Intersoft WebTextEditor Documentation
CopyTo Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBarCollection Class : CopyTo Method

array
index

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Sub CopyTo( _
   ByVal array() As ISNet.WebUI.INamedObject2, _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBarCollection
Dim array() As ISNet.WebUI.INamedObject2
Dim index As System.Integer

instance.CopyTo(array, index)
C#
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public void CopyTo(
   ISNet.WebUI.INamedObject2[] array,
   System.int index
)
Delphi
public procedure CopyTo(
    array: ISNet.WebUI.INamedObject2array of;
    index: System.Integer
);
JScript
__DynamicallyInvokableAttribute()
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function CopyTo(
   array : ISNet.WebUI.INamedObject2[],
   index : System.int
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: void CopyTo(
   ISNet.WebUI.INamedObject2*[]* array,
   System.int index
)
C++/CLI
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
void CopyTo(
   ISNet.WebUI.array<INamedObject2^>^ array,
   System.int index
)

Parameters

array
index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBarCollection Class
WebTextEditorToolBarCollection Members


Count Property

[image]
Intersoft WebTextEditor Documentation
Count Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBarCollection Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public ReadOnly Property Count As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBarCollection
Dim value As System.Integer

value = instance.Count
C#
[__DynamicallyInvokableAttribute()]
public System.int Count {get;}
Delphi
public read-only property Count: System.Integer;
JScript
__DynamicallyInvokableAttribute()
public function get Count : System.int
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: __property System.int get_Count();
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
property System.int Count {
   System.int get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBarCollection Class
WebTextEditorToolBarCollection Members


CreateArray Method

[image]
Intersoft WebTextEditor Documentation
CreateArray Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBarCollection Class : CreateArray Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function CreateArray() As ISNet.WebUI.INamedObject2()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBarCollection
Dim value() As ISNet.WebUI.INamedObject2

value = instance.CreateArray()
C#
protected ISNet.WebUI.INamedObject2[] CreateArray()
Delphi
protected function CreateArray(): ISNet.WebUI.array of INamedObject2;
JScript
protected function CreateArray() : ISNet.WebUI.INamedObject2[];
Managed Extensions for C++
protected: ISNet.WebUI.INamedObject2*[]* CreateArray();
C++/CLI
protected:
ISNet.WebUI.array<INamedObject2^>^ CreateArray();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBarCollection Class
WebTextEditorToolBarCollection Members


CreateNewItem Method

[image]
Intersoft WebTextEditor Documentation
CreateNewItem Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBarCollection Class : CreateNewItem Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CreateNewItem() As WebTextEditorToolBar
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBarCollection
Dim value As WebTextEditorToolBar

value = instance.CreateNewItem()
C#
public WebTextEditorToolBar CreateNewItem()
Delphi
public function CreateNewItem(): WebTextEditorToolBar;
JScript
public function CreateNewItem() : WebTextEditorToolBar;
Managed Extensions for C++
public: WebTextEditorToolBar* CreateNewItem();
C++/CLI
public:
WebTextEditorToolBar^ CreateNewItem();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBarCollection Class
WebTextEditorToolBarCollection Members


GetEnumerator Method

[image]
Intersoft WebTextEditor Documentation
GetEnumerator Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBarCollection Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Function GetEnumerator() As System.Collections.Generic.IEnumerator(Of INamedObject2)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBarCollection
Dim value As System.Collections.Generic.IEnumerator(Of INamedObject2)

value = instance.GetEnumerator()
C#
[__DynamicallyInvokableAttribute()]
public System.Collections.Generic.IEnumerator<INamedObject2> GetEnumerator()
Delphi
public function GetEnumerator(): System.Collections.Generic.IEnumerator;
JScript
__DynamicallyInvokableAttribute()
public function GetEnumerator() : System.Collections.Generic.IEnumerator;
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: System.Collections.Generic.IEnumerator<INamedObject2*>* GetEnumerator();
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
System.Collections.Generic.IEnumerator<INamedObject2^>^ GetEnumerator();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBarCollection Class
WebTextEditorToolBarCollection Members


GetObjectData Method

[image]
Intersoft WebTextEditor Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBarCollection Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBarCollection
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBarCollection Class
WebTextEditorToolBarCollection Members


IndexOf Method

[image]
Intersoft WebTextEditor Documentation
IndexOf Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBarCollection Class : IndexOf Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
<__DynamicallyInvokableAttribute()>
Public Function IndexOf( _
   ByVal item As ISNet.WebUI.INamedObject2 _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBarCollection
Dim item As ISNet.WebUI.INamedObject2
Dim value As System.Integer

value = instance.IndexOf(item)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public System.int IndexOf(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public function IndexOf(
    item: ISNet.WebUI.INamedObject2
): System.Integer;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
__DynamicallyInvokableAttribute()
public function IndexOf(
   item : ISNet.WebUI.INamedObject2
) : System.int;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public: System.int IndexOf(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public:
System.int IndexOf(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBarCollection Class
WebTextEditorToolBarCollection Members


Insert Method

[image]
Intersoft WebTextEditor Documentation
Insert Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBarCollection Class : Insert Method

index
item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal item As ISNet.WebUI.INamedObject2 _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBarCollection
Dim index As System.Integer
Dim item As ISNet.WebUI.INamedObject2

instance.Insert(index, item)
C#
[__DynamicallyInvokableAttribute()]
public void Insert(
   System.int index,
   ISNet.WebUI.INamedObject2 item
)
Delphi
public procedure Insert(
    index: System.Integer;
    item: ISNet.WebUI.INamedObject2
);
JScript
__DynamicallyInvokableAttribute()
public function Insert(
   index : System.int,
   item : ISNet.WebUI.INamedObject2
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void Insert(
   System.int index,
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void Insert(
   System.int index,
   ISNet.WebUI.INamedObject2^ item
)

Parameters

index
item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBarCollection Class
WebTextEditorToolBarCollection Members


InsertItem Method

[image]
Intersoft WebTextEditor Documentation
InsertItem Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBarCollection Class : InsertItem Method

index
item

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub InsertItem( _
   ByVal index As System.Integer, _
   ByVal item As ISNet.WebUI.INamedObject2 _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBarCollection
Dim index As System.Integer
Dim item As ISNet.WebUI.INamedObject2

instance.InsertItem(index, item)
C#
protected virtual void InsertItem(
   System.int index,
   ISNet.WebUI.INamedObject2 item
)
Delphi
protected procedure InsertItem(
    index: System.Integer;
    item: ISNet.WebUI.INamedObject2
); virtual;
JScript
protected function InsertItem(
   index : System.int,
   item : ISNet.WebUI.INamedObject2
);
Managed Extensions for C++
protected: virtual void InsertItem(
   System.int index,
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
protected:
virtual void InsertItem(
   System.int index,
   ISNet.WebUI.INamedObject2^ item
)

Parameters

index
item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBarCollection Class
WebTextEditorToolBarCollection Members


Item Property

[image]
Intersoft WebTextEditor Documentation
Item Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBarCollection Class : Item Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Default Property Item( _
   ByVal index As System.Integer _
) As ISNet.WebUI.INamedObject2
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBarCollection
Dim index As System.Integer
Dim value As ISNet.WebUI.INamedObject2

instance.Item(index) = value

value = instance.Item(index)
C#
[__DynamicallyInvokableAttribute()]
public ISNet.WebUI.INamedObject2 this[
   System.int index
]; {get; set;}
Delphi
public  this: : ISNet.WebUI.INamedObject2;[
    index: System.Integer
]; read-write
JScript
__DynamicallyInvokableAttribute()
public  this[
   index : System.int
] get,set : ISNet.WebUI.INamedObject2
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: __property ISNet.WebUI.INamedObject2* get_Item   System.int index
;
public: __property void set_Item   System.int index,
   ISNet.WebUI.INamedObject2* value
;
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
property ISNet.WebUI.INamedObject2^ default [int] {
   ISNet.WebUI.INamedObject2^ get(System.int index);
   void set (System.int index, ISNet.WebUI.INamedObject2^ value);
}

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBarCollection Class
WebTextEditorToolBarCollection Members


Items Property

[image]
Intersoft WebTextEditor Documentation
Items Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBarCollection Class : Items Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Protected ReadOnly Property Items As System.Collections.Generic.IList(Of INamedObject2)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBarCollection
Dim value As System.Collections.Generic.IList(Of INamedObject2)

value = instance.Items
C#
[__DynamicallyInvokableAttribute()]
protected System.Collections.Generic.IList<INamedObject2> Items {get;}
Delphi
protected read-only property Items: System.Collections.Generic.IList;
JScript
__DynamicallyInvokableAttribute()
protected function get Items : System.Collections.Generic.IList
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
protected: __property System.Collections.Generic.IList<INamedObject2*>* get_Items();
C++/CLI
[__DynamicallyInvokableAttribute()]
protected:
property System.Collections.Generic.IList<INamedObject2^>^ Items {
   System.Collections.Generic.IList<INamedObject2^>^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBarCollection Class
WebTextEditorToolBarCollection Members


Parent Property

[image]
Intersoft WebTextEditor Documentation
Parent Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBarCollection Class : Parent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBarCollection
Dim value As System.Object

value = instance.Parent
C#
public System.object Parent {get;}
Delphi
public read-only property Parent: System.TObject;
JScript
public function get Parent : System.Object
Managed Extensions for C++
public: __property System.Object* get_Parent();
C++/CLI
public:
property System.Object^ Parent {
   System.Object^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBarCollection Class
WebTextEditorToolBarCollection Members


Remove Method

[image]
Intersoft WebTextEditor Documentation
Remove Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBarCollection Class : Remove Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Function Remove( _
   ByVal item As ISNet.WebUI.INamedObject2 _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBarCollection
Dim item As ISNet.WebUI.INamedObject2
Dim value As System.Boolean

value = instance.Remove(item)
C#
[__DynamicallyInvokableAttribute()]
public System.bool Remove(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public function Remove(
    item: ISNet.WebUI.INamedObject2
): System.Boolean;
JScript
__DynamicallyInvokableAttribute()
public function Remove(
   item : ISNet.WebUI.INamedObject2
) : System.boolean;
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: System.bool Remove(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
System.bool Remove(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBarCollection Class
WebTextEditorToolBarCollection Members


RemoveAt Method

[image]
Intersoft WebTextEditor Documentation
RemoveAt Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBarCollection Class : RemoveAt Method

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBarCollection
Dim index As System.Integer

instance.RemoveAt(index)
C#
[__DynamicallyInvokableAttribute()]
public void RemoveAt(
   System.int index
)
Delphi
public procedure RemoveAt(
    index: System.Integer
);
JScript
__DynamicallyInvokableAttribute()
public function RemoveAt(
   index : System.int
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void RemoveAt(
   System.int index
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void RemoveAt(
   System.int index
)

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBarCollection Class
WebTextEditorToolBarCollection Members


RemoveItem Method

[image]
Intersoft WebTextEditor Documentation
RemoveItem Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBarCollection Class : RemoveItem Method

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub RemoveItem( _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBarCollection
Dim index As System.Integer

instance.RemoveItem(index)
C#
protected virtual void RemoveItem(
   System.int index
)
Delphi
protected procedure RemoveItem(
    index: System.Integer
); virtual;
JScript
protected function RemoveItem(
   index : System.int
);
Managed Extensions for C++
protected: virtual void RemoveItem(
   System.int index
)
C++/CLI
protected:
virtual void RemoveItem(
   System.int index
)

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBarCollection Class
WebTextEditorToolBarCollection Members


SerializerConstructor Method

[image]
Intersoft WebTextEditor Documentation
SerializerConstructor Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBarCollection Class : SerializerConstructor Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializerConstructor( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBarCollection
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializerConstructor(info, context)
C#
public void SerializerConstructor(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializerConstructor(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializerConstructor(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializerConstructor(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializerConstructor(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBarCollection Class
WebTextEditorToolBarCollection Members


SetItem Method

[image]
Intersoft WebTextEditor Documentation
SetItem Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBarCollection Class : SetItem Method

index
item

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub SetItem( _
   ByVal index As System.Integer, _
   ByVal item As ISNet.WebUI.INamedObject2 _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBarCollection
Dim index As System.Integer
Dim item As ISNet.WebUI.INamedObject2

instance.SetItem(index, item)
C#
protected virtual void SetItem(
   System.int index,
   ISNet.WebUI.INamedObject2 item
)
Delphi
protected procedure SetItem(
    index: System.Integer;
    item: ISNet.WebUI.INamedObject2
); virtual;
JScript
protected function SetItem(
   index : System.int,
   item : ISNet.WebUI.INamedObject2
);
Managed Extensions for C++
protected: virtual void SetItem(
   System.int index,
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
protected:
virtual void SetItem(
   System.int index,
   ISNet.WebUI.INamedObject2^ item
)

Parameters

index
item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBarCollection Class
WebTextEditorToolBarCollection Members


SetParent Method

[image]
Intersoft WebTextEditor Documentation
SetParent Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBarCollection Class : SetParent Method

parent

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SetParent( _
   ByVal parent As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBarCollection
Dim parent As System.Object

instance.SetParent(parent)
C#
public virtual void SetParent(
   System.object parent
)
Delphi
public procedure SetParent(
    parent: System.TObject
); virtual;
JScript
public function SetParent(
   parent : System.Object
);
Managed Extensions for C++
public: virtual void SetParent(
   System.Object* parent
)
C++/CLI
public:
virtual void SetParent(
   System.Object^ parent
)

Parameters

parent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBarCollection Class
WebTextEditorToolBarCollection Members


Clone Method

[image]
Intersoft WebTextEditor Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBarSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBarSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBarSettings Class
WebTextEditorToolBarSettings Members


CopyFrom Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBarSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBarSettings Class
WebTextEditorToolBarSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBarSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBarSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBarSettings Class
WebTextEditorToolBarSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBarSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBarSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBarSettings Class
WebTextEditorToolBarSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebTextEditor Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBarSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBarSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBarSettings Class
WebTextEditorToolBarSettings Members


GetHashCode Method

[image]
Intersoft WebTextEditor Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBarSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBarSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBarSettings Class
WebTextEditorToolBarSettings Members


GetPropertyString Method

[image]
Intersoft WebTextEditor Documentation
GetPropertyString Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBarSettings Class : GetPropertyString Method

v

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetPropertyString( _
   ByVal v As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBarSettings
Dim v As System.String
Dim value As System.String

value = instance.GetPropertyString(v)
C#
protected virtual System.string GetPropertyString(
   System.string v
)
Delphi
protected function GetPropertyString(
    v: System.String
): System.String; virtual;
JScript
protected function GetPropertyString(
   v : System.String
) : System.String;
Managed Extensions for C++
protected: virtual System.string* GetPropertyString(
   System.string* v
)
C++/CLI
protected:
virtual System.String^ GetPropertyString(
   System.String^ v
)

Parameters

v

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBarSettings Class
WebTextEditorToolBarSettings Members


IsEmpty Method

[image]
Intersoft WebTextEditor Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBarSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBarSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBarSettings Class
WebTextEditorToolBarSettings Members


IsInSerializationContext Method

[image]
Intersoft WebTextEditor Documentation
IsInSerializationContext Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBarSettings Class : IsInSerializationContext Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function IsInSerializationContext() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBarSettings
Dim value As System.Boolean

value = instance.IsInSerializationContext()
C#
protected virtual System.bool IsInSerializationContext()
Delphi
protected function IsInSerializationContext(): System.Boolean; virtual;
JScript
protected function IsInSerializationContext() : System.boolean;
Managed Extensions for C++
protected: virtual System.bool IsInSerializationContext();
C++/CLI
protected:
virtual System.bool IsInSerializationContext();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBarSettings Class
WebTextEditorToolBarSettings Members


Reset Method

[image]
Intersoft WebTextEditor Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBarSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBarSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBarSettings Class
WebTextEditorToolBarSettings Members


SerializeObjectData Method

[image]
Intersoft WebTextEditor Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBarSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBarSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBarSettings Class
WebTextEditorToolBarSettings Members


ToString Method

[image]
Intersoft WebTextEditor Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBarSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBarSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBarSettings Class
WebTextEditorToolBarSettings Members


Clone Method

[image]
Intersoft WebTextEditor Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBar Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBar
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBar Class
WebTextEditorToolBar Members


Collection Property

[image]
Intersoft WebTextEditor Documentation
Collection Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBar Class : Collection Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
Public Property Collection As ISNet.WebUI.ISCollectionBase(Of INamedObject2)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBar
Dim value As ISNet.WebUI.ISCollectionBase(Of INamedObject2)

instance.Collection = value

value = instance.Collection
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public ISNet.WebUI.ISCollectionBase<INamedObject2> Collection {get; set;}
Delphi
public read-write property Collection: ISNet.WebUI.ISCollectionBase;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
public function get,set Collection : ISNet.WebUI.ISCollectionBase
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public: __property ISNet.WebUI.ISCollectionBase<INamedObject2*>* get_Collection();
public: __property void set_Collection(
   ISNet.WebUI.ISCollectionBase<INamedObject2*>* value
);
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public:
property ISNet.WebUI.ISCollectionBase<INamedObject2^>^ Collection {
   ISNet.WebUI.ISCollectionBase<INamedObject2^>^ get();
   void set (    ISNet.WebUI.ISCollectionBase<INamedObject2^>^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBar Class
WebTextEditorToolBar Members


CopyFrom Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBar Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBar Class
WebTextEditorToolBar Members


CopyFrom(Object) Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBar Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBar
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBar Class
WebTextEditorToolBar Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBar Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBar
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBar Class
WebTextEditorToolBar Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebTextEditor Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBar Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBar
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBar Class
WebTextEditorToolBar Members


GetHashCode Method

[image]
Intersoft WebTextEditor Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBar Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBar
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBar Class
WebTextEditorToolBar Members


GetPropertyString Method

[image]
Intersoft WebTextEditor Documentation
GetPropertyString Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBar Class : GetPropertyString Method

v

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetPropertyString( _
   ByVal v As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBar
Dim v As System.String
Dim value As System.String

value = instance.GetPropertyString(v)
C#
protected virtual System.string GetPropertyString(
   System.string v
)
Delphi
protected function GetPropertyString(
    v: System.String
): System.String; virtual;
JScript
protected function GetPropertyString(
   v : System.String
) : System.String;
Managed Extensions for C++
protected: virtual System.string* GetPropertyString(
   System.string* v
)
C++/CLI
protected:
virtual System.String^ GetPropertyString(
   System.String^ v
)

Parameters

v

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBar Class
WebTextEditorToolBar Members


IsEmpty Method

[image]
Intersoft WebTextEditor Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBar Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBar
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBar Class
WebTextEditorToolBar Members


IsInSerializationContext Method

[image]
Intersoft WebTextEditor Documentation
IsInSerializationContext Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBar Class : IsInSerializationContext Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function IsInSerializationContext() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBar
Dim value As System.Boolean

value = instance.IsInSerializationContext()
C#
protected virtual System.bool IsInSerializationContext()
Delphi
protected function IsInSerializationContext(): System.Boolean; virtual;
JScript
protected function IsInSerializationContext() : System.boolean;
Managed Extensions for C++
protected: virtual System.bool IsInSerializationContext();
C++/CLI
protected:
virtual System.bool IsInSerializationContext();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBar Class
WebTextEditorToolBar Members


OnItemAdd Method

[image]
Intersoft WebTextEditor Documentation
OnItemAdd Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBar Class : OnItemAdd Method

collection

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnItemAdd( _
   ByVal collection As ISNet.WebUI.ISCollectionBase(Of INamedObject2) _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBar
Dim collection As ISNet.WebUI.ISCollectionBase(Of INamedObject2)

instance.OnItemAdd(collection)
C#
protected virtual void OnItemAdd(
   ISNet.WebUI.ISCollectionBase<INamedObject2> collection
)
Delphi
protected procedure OnItemAdd(
    collection: ISNet.WebUI.ISCollectionBase
); virtual;
JScript
protected function OnItemAdd(
   collection : ISNet.WebUI.ISCollectionBase
);
Managed Extensions for C++
protected: virtual void OnItemAdd(
   ISNet.WebUI.ISCollectionBase<INamedObject2*>* collection
)
C++/CLI
protected:
virtual void OnItemAdd(
   ISNet.WebUI.ISCollectionBase<INamedObject2^>^ collection
)

Parameters

collection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBar Class
WebTextEditorToolBar Members


OnItemRemove Method

[image]
Intersoft WebTextEditor Documentation
OnItemRemove Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBar Class : OnItemRemove Method

collection

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnItemRemove( _
   ByVal collection As ISNet.WebUI.ISCollectionBase(Of INamedObject2) _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBar
Dim collection As ISNet.WebUI.ISCollectionBase(Of INamedObject2)

instance.OnItemRemove(collection)
C#
protected virtual void OnItemRemove(
   ISNet.WebUI.ISCollectionBase<INamedObject2> collection
)
Delphi
protected procedure OnItemRemove(
    collection: ISNet.WebUI.ISCollectionBase
); virtual;
JScript
protected function OnItemRemove(
   collection : ISNet.WebUI.ISCollectionBase
);
Managed Extensions for C++
protected: virtual void OnItemRemove(
   ISNet.WebUI.ISCollectionBase<INamedObject2*>* collection
)
C++/CLI
protected:
virtual void OnItemRemove(
   ISNet.WebUI.ISCollectionBase<INamedObject2^>^ collection
)

Parameters

collection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBar Class
WebTextEditorToolBar Members


Reset Method

[image]
Intersoft WebTextEditor Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBar Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBar

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBar Class
WebTextEditorToolBar Members


SerializeObjectData Method

[image]
Intersoft WebTextEditor Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBar Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBar
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBar Class
WebTextEditorToolBar Members


ToString Method

[image]
Intersoft WebTextEditor Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolBar Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolBar
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolBar Class
WebTextEditorToolBar Members


WebTextEditorToolCommandCollection Class Properties

[image]
Intersoft WebTextEditor Documentation
WebTextEditorToolCommandCollection Class Properties
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorToolCommandCollection Class

Glossary Item Box

For a list of all members of this type, see WebTextEditorToolCommandCollection members.

Public Properties

 | Name | Description
Public Property | All | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

Protected Properties

 | Name | Description
Protected Property | Items | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Top

See Also

Reference

WebTextEditorToolCommandCollection Class
ISNet.WebUI.WebTextEditor Namespace


Add Method

[image]
Intersoft WebTextEditor Documentation
Add Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolCommandCollection Class : Add Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Sub Add( _
   ByVal item As ISNet.WebUI.INamedObject2 _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolCommandCollection
Dim item As ISNet.WebUI.INamedObject2

instance.Add(item)
C#
[__DynamicallyInvokableAttribute()]
public void Add(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public procedure Add(
    item: ISNet.WebUI.INamedObject2
);
JScript
__DynamicallyInvokableAttribute()
public function Add(
   item : ISNet.WebUI.INamedObject2
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void Add(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void Add(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolCommandCollection Class
WebTextEditorToolCommandCollection Members


All Property

[image]
Intersoft WebTextEditor Documentation
All Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolCommandCollection Class : All Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public ReadOnly Property All As ISNet.WebUI.INamedObject2()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolCommandCollection
Dim value() As ISNet.WebUI.INamedObject2

value = instance.All
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public ISNet.WebUI.INamedObject2[] All {get;}
Delphi
public read-only property All: ISNet.WebUI.array of INamedObject2;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get All : ISNet.WebUI.INamedObject2[]
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property ISNet.WebUI.INamedObject2*[]* get_All();
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property ISNet.WebUI.array<INamedObject2^>^ All {
   ISNet.WebUI.array<INamedObject2^>^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolCommandCollection Class
WebTextEditorToolCommandCollection Members


Clear Method

[image]
Intersoft WebTextEditor Documentation
Clear Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolCommandCollection Class : Clear Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolCommandCollection

instance.Clear()
C#
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public void Clear()
Delphi
public procedure Clear();
JScript
__DynamicallyInvokableAttribute()
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function Clear();
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: void Clear();
C++/CLI
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
void Clear();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolCommandCollection Class
WebTextEditorToolCommandCollection Members


ClearItems Method

[image]
Intersoft WebTextEditor Documentation
ClearItems Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolCommandCollection Class : ClearItems Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ClearItems()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolCommandCollection

instance.ClearItems()
C#
protected virtual void ClearItems()
Delphi
protected procedure ClearItems(); virtual;
JScript
protected function ClearItems();
Managed Extensions for C++
protected: virtual void ClearItems();
C++/CLI
protected:
virtual void ClearItems();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolCommandCollection Class
WebTextEditorToolCommandCollection Members


Contains Method

[image]
Intersoft WebTextEditor Documentation
Contains Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolCommandCollection Class : Contains Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
<__DynamicallyInvokableAttribute()>
Public Function Contains( _
   ByVal item As ISNet.WebUI.INamedObject2 _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolCommandCollection
Dim item As ISNet.WebUI.INamedObject2
Dim value As System.Boolean

value = instance.Contains(item)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public System.bool Contains(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public function Contains(
    item: ISNet.WebUI.INamedObject2
): System.Boolean;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
__DynamicallyInvokableAttribute()
public function Contains(
   item : ISNet.WebUI.INamedObject2
) : System.boolean;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public: System.bool Contains(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public:
System.bool Contains(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolCommandCollection Class
WebTextEditorToolCommandCollection Members


CopyTo Method

[image]
Intersoft WebTextEditor Documentation
CopyTo Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolCommandCollection Class : CopyTo Method

array
index

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Sub CopyTo( _
   ByVal array() As ISNet.WebUI.INamedObject2, _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolCommandCollection
Dim array() As ISNet.WebUI.INamedObject2
Dim index As System.Integer

instance.CopyTo(array, index)
C#
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public void CopyTo(
   ISNet.WebUI.INamedObject2[] array,
   System.int index
)
Delphi
public procedure CopyTo(
    array: ISNet.WebUI.INamedObject2array of;
    index: System.Integer
);
JScript
__DynamicallyInvokableAttribute()
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function CopyTo(
   array : ISNet.WebUI.INamedObject2[],
   index : System.int
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: void CopyTo(
   ISNet.WebUI.INamedObject2*[]* array,
   System.int index
)
C++/CLI
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
void CopyTo(
   ISNet.WebUI.array<INamedObject2^>^ array,
   System.int index
)

Parameters

array
index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolCommandCollection Class
WebTextEditorToolCommandCollection Members


Count Property

[image]
Intersoft WebTextEditor Documentation
Count Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolCommandCollection Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public ReadOnly Property Count As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolCommandCollection
Dim value As System.Integer

value = instance.Count
C#
[__DynamicallyInvokableAttribute()]
public System.int Count {get;}
Delphi
public read-only property Count: System.Integer;
JScript
__DynamicallyInvokableAttribute()
public function get Count : System.int
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: __property System.int get_Count();
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
property System.int Count {
   System.int get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolCommandCollection Class
WebTextEditorToolCommandCollection Members


CreateArray Method

[image]
Intersoft WebTextEditor Documentation
CreateArray Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolCommandCollection Class : CreateArray Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function CreateArray() As ISNet.WebUI.INamedObject2()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolCommandCollection
Dim value() As ISNet.WebUI.INamedObject2

value = instance.CreateArray()
C#
protected ISNet.WebUI.INamedObject2[] CreateArray()
Delphi
protected function CreateArray(): ISNet.WebUI.array of INamedObject2;
JScript
protected function CreateArray() : ISNet.WebUI.INamedObject2[];
Managed Extensions for C++
protected: ISNet.WebUI.INamedObject2*[]* CreateArray();
C++/CLI
protected:
ISNet.WebUI.array<INamedObject2^>^ CreateArray();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolCommandCollection Class
WebTextEditorToolCommandCollection Members


CreateNewItem Method

[image]
Intersoft WebTextEditor Documentation
CreateNewItem Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolCommandCollection Class : CreateNewItem Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CreateNewItem() As WebTextEditorToolCommand
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolCommandCollection
Dim value As WebTextEditorToolCommand

value = instance.CreateNewItem()
C#
public WebTextEditorToolCommand CreateNewItem()
Delphi
public function CreateNewItem(): WebTextEditorToolCommand;
JScript
public function CreateNewItem() : WebTextEditorToolCommand;
Managed Extensions for C++
public: WebTextEditorToolCommand* CreateNewItem();
C++/CLI
public:
WebTextEditorToolCommand^ CreateNewItem();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolCommandCollection Class
WebTextEditorToolCommandCollection Members


GetEnumerator Method

[image]
Intersoft WebTextEditor Documentation
GetEnumerator Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolCommandCollection Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Function GetEnumerator() As System.Collections.Generic.IEnumerator(Of INamedObject2)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolCommandCollection
Dim value As System.Collections.Generic.IEnumerator(Of INamedObject2)

value = instance.GetEnumerator()
C#
[__DynamicallyInvokableAttribute()]
public System.Collections.Generic.IEnumerator<INamedObject2> GetEnumerator()
Delphi
public function GetEnumerator(): System.Collections.Generic.IEnumerator;
JScript
__DynamicallyInvokableAttribute()
public function GetEnumerator() : System.Collections.Generic.IEnumerator;
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: System.Collections.Generic.IEnumerator<INamedObject2*>* GetEnumerator();
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
System.Collections.Generic.IEnumerator<INamedObject2^>^ GetEnumerator();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolCommandCollection Class
WebTextEditorToolCommandCollection Members


GetObjectData Method

[image]
Intersoft WebTextEditor Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolCommandCollection Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolCommandCollection
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolCommandCollection Class
WebTextEditorToolCommandCollection Members


IndexOf Method

[image]
Intersoft WebTextEditor Documentation
IndexOf Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolCommandCollection Class : IndexOf Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
<__DynamicallyInvokableAttribute()>
Public Function IndexOf( _
   ByVal item As ISNet.WebUI.INamedObject2 _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolCommandCollection
Dim item As ISNet.WebUI.INamedObject2
Dim value As System.Integer

value = instance.IndexOf(item)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public System.int IndexOf(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public function IndexOf(
    item: ISNet.WebUI.INamedObject2
): System.Integer;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
__DynamicallyInvokableAttribute()
public function IndexOf(
   item : ISNet.WebUI.INamedObject2
) : System.int;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public: System.int IndexOf(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public:
System.int IndexOf(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolCommandCollection Class
WebTextEditorToolCommandCollection Members


Insert Method

[image]
Intersoft WebTextEditor Documentation
Insert Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolCommandCollection Class : Insert Method

index
item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal item As ISNet.WebUI.INamedObject2 _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolCommandCollection
Dim index As System.Integer
Dim item As ISNet.WebUI.INamedObject2

instance.Insert(index, item)
C#
[__DynamicallyInvokableAttribute()]
public void Insert(
   System.int index,
   ISNet.WebUI.INamedObject2 item
)
Delphi
public procedure Insert(
    index: System.Integer;
    item: ISNet.WebUI.INamedObject2
);
JScript
__DynamicallyInvokableAttribute()
public function Insert(
   index : System.int,
   item : ISNet.WebUI.INamedObject2
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void Insert(
   System.int index,
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void Insert(
   System.int index,
   ISNet.WebUI.INamedObject2^ item
)

Parameters

index
item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolCommandCollection Class
WebTextEditorToolCommandCollection Members


InsertItem Method

[image]
Intersoft WebTextEditor Documentation
InsertItem Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolCommandCollection Class : InsertItem Method

index
item

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub InsertItem( _
   ByVal index As System.Integer, _
   ByVal item As ISNet.WebUI.INamedObject2 _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolCommandCollection
Dim index As System.Integer
Dim item As ISNet.WebUI.INamedObject2

instance.InsertItem(index, item)
C#
protected virtual void InsertItem(
   System.int index,
   ISNet.WebUI.INamedObject2 item
)
Delphi
protected procedure InsertItem(
    index: System.Integer;
    item: ISNet.WebUI.INamedObject2
); virtual;
JScript
protected function InsertItem(
   index : System.int,
   item : ISNet.WebUI.INamedObject2
);
Managed Extensions for C++
protected: virtual void InsertItem(
   System.int index,
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
protected:
virtual void InsertItem(
   System.int index,
   ISNet.WebUI.INamedObject2^ item
)

Parameters

index
item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolCommandCollection Class
WebTextEditorToolCommandCollection Members


Item Property

[image]
Intersoft WebTextEditor Documentation
Item Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolCommandCollection Class : Item Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Default Property Item( _
   ByVal index As System.Integer _
) As ISNet.WebUI.INamedObject2
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolCommandCollection
Dim index As System.Integer
Dim value As ISNet.WebUI.INamedObject2

instance.Item(index) = value

value = instance.Item(index)
C#
[__DynamicallyInvokableAttribute()]
public ISNet.WebUI.INamedObject2 this[
   System.int index
]; {get; set;}
Delphi
public  this: : ISNet.WebUI.INamedObject2;[
    index: System.Integer
]; read-write
JScript
__DynamicallyInvokableAttribute()
public  this[
   index : System.int
] get,set : ISNet.WebUI.INamedObject2
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: __property ISNet.WebUI.INamedObject2* get_Item   System.int index
;
public: __property void set_Item   System.int index,
   ISNet.WebUI.INamedObject2* value
;
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
property ISNet.WebUI.INamedObject2^ default [int] {
   ISNet.WebUI.INamedObject2^ get(System.int index);
   void set (System.int index, ISNet.WebUI.INamedObject2^ value);
}

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolCommandCollection Class
WebTextEditorToolCommandCollection Members


Items Property

[image]
Intersoft WebTextEditor Documentation
Items Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolCommandCollection Class : Items Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Protected ReadOnly Property Items As System.Collections.Generic.IList(Of INamedObject2)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolCommandCollection
Dim value As System.Collections.Generic.IList(Of INamedObject2)

value = instance.Items
C#
[__DynamicallyInvokableAttribute()]
protected System.Collections.Generic.IList<INamedObject2> Items {get;}
Delphi
protected read-only property Items: System.Collections.Generic.IList;
JScript
__DynamicallyInvokableAttribute()
protected function get Items : System.Collections.Generic.IList
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
protected: __property System.Collections.Generic.IList<INamedObject2*>* get_Items();
C++/CLI
[__DynamicallyInvokableAttribute()]
protected:
property System.Collections.Generic.IList<INamedObject2^>^ Items {
   System.Collections.Generic.IList<INamedObject2^>^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolCommandCollection Class
WebTextEditorToolCommandCollection Members


Parent Property

[image]
Intersoft WebTextEditor Documentation
Parent Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolCommandCollection Class : Parent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolCommandCollection
Dim value As System.Object

value = instance.Parent
C#
public System.object Parent {get;}
Delphi
public read-only property Parent: System.TObject;
JScript
public function get Parent : System.Object
Managed Extensions for C++
public: __property System.Object* get_Parent();
C++/CLI
public:
property System.Object^ Parent {
   System.Object^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolCommandCollection Class
WebTextEditorToolCommandCollection Members


Remove Method

[image]
Intersoft WebTextEditor Documentation
Remove Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolCommandCollection Class : Remove Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Function Remove( _
   ByVal item As ISNet.WebUI.INamedObject2 _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolCommandCollection
Dim item As ISNet.WebUI.INamedObject2
Dim value As System.Boolean

value = instance.Remove(item)
C#
[__DynamicallyInvokableAttribute()]
public System.bool Remove(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public function Remove(
    item: ISNet.WebUI.INamedObject2
): System.Boolean;
JScript
__DynamicallyInvokableAttribute()
public function Remove(
   item : ISNet.WebUI.INamedObject2
) : System.boolean;
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: System.bool Remove(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
System.bool Remove(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolCommandCollection Class
WebTextEditorToolCommandCollection Members


RemoveAt Method

[image]
Intersoft WebTextEditor Documentation
RemoveAt Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolCommandCollection Class : RemoveAt Method

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolCommandCollection
Dim index As System.Integer

instance.RemoveAt(index)
C#
[__DynamicallyInvokableAttribute()]
public void RemoveAt(
   System.int index
)
Delphi
public procedure RemoveAt(
    index: System.Integer
);
JScript
__DynamicallyInvokableAttribute()
public function RemoveAt(
   index : System.int
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void RemoveAt(
   System.int index
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void RemoveAt(
   System.int index
)

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolCommandCollection Class
WebTextEditorToolCommandCollection Members


RemoveItem Method

[image]
Intersoft WebTextEditor Documentation
RemoveItem Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolCommandCollection Class : RemoveItem Method

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub RemoveItem( _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolCommandCollection
Dim index As System.Integer

instance.RemoveItem(index)
C#
protected virtual void RemoveItem(
   System.int index
)
Delphi
protected procedure RemoveItem(
    index: System.Integer
); virtual;
JScript
protected function RemoveItem(
   index : System.int
);
Managed Extensions for C++
protected: virtual void RemoveItem(
   System.int index
)
C++/CLI
protected:
virtual void RemoveItem(
   System.int index
)

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolCommandCollection Class
WebTextEditorToolCommandCollection Members


SerializerConstructor Method

[image]
Intersoft WebTextEditor Documentation
SerializerConstructor Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolCommandCollection Class : SerializerConstructor Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializerConstructor( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolCommandCollection
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializerConstructor(info, context)
C#
public void SerializerConstructor(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializerConstructor(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializerConstructor(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializerConstructor(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializerConstructor(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolCommandCollection Class
WebTextEditorToolCommandCollection Members


SetItem Method

[image]
Intersoft WebTextEditor Documentation
SetItem Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolCommandCollection Class : SetItem Method

index
item

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub SetItem( _
   ByVal index As System.Integer, _
   ByVal item As ISNet.WebUI.INamedObject2 _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolCommandCollection
Dim index As System.Integer
Dim item As ISNet.WebUI.INamedObject2

instance.SetItem(index, item)
C#
protected virtual void SetItem(
   System.int index,
   ISNet.WebUI.INamedObject2 item
)
Delphi
protected procedure SetItem(
    index: System.Integer;
    item: ISNet.WebUI.INamedObject2
); virtual;
JScript
protected function SetItem(
   index : System.int,
   item : ISNet.WebUI.INamedObject2
);
Managed Extensions for C++
protected: virtual void SetItem(
   System.int index,
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
protected:
virtual void SetItem(
   System.int index,
   ISNet.WebUI.INamedObject2^ item
)

Parameters

index
item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolCommandCollection Class
WebTextEditorToolCommandCollection Members


SetParent Method

[image]
Intersoft WebTextEditor Documentation
SetParent Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolCommandCollection Class : SetParent Method

parent

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SetParent( _
   ByVal parent As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolCommandCollection
Dim parent As System.Object

instance.SetParent(parent)
C#
public virtual void SetParent(
   System.object parent
)
Delphi
public procedure SetParent(
    parent: System.TObject
); virtual;
JScript
public function SetParent(
   parent : System.Object
);
Managed Extensions for C++
public: virtual void SetParent(
   System.Object* parent
)
C++/CLI
public:
virtual void SetParent(
   System.Object^ parent
)

Parameters

parent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolCommandCollection Class
WebTextEditorToolCommandCollection Members


Clone Method

[image]
Intersoft WebTextEditor Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolCommand Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolCommand
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolCommand Class
WebTextEditorToolCommand Members


Collection Property

[image]
Intersoft WebTextEditor Documentation
Collection Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolCommand Class : Collection Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
Public Property Collection As ISNet.WebUI.ISCollectionBase(Of INamedObject2)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolCommand
Dim value As ISNet.WebUI.ISCollectionBase(Of INamedObject2)

instance.Collection = value

value = instance.Collection
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public ISNet.WebUI.ISCollectionBase<INamedObject2> Collection {get; set;}
Delphi
public read-write property Collection: ISNet.WebUI.ISCollectionBase;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
public function get,set Collection : ISNet.WebUI.ISCollectionBase
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public: __property ISNet.WebUI.ISCollectionBase<INamedObject2*>* get_Collection();
public: __property void set_Collection(
   ISNet.WebUI.ISCollectionBase<INamedObject2*>* value
);
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public:
property ISNet.WebUI.ISCollectionBase<INamedObject2^>^ Collection {
   ISNet.WebUI.ISCollectionBase<INamedObject2^>^ get();
   void set (    ISNet.WebUI.ISCollectionBase<INamedObject2^>^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolCommand Class
WebTextEditorToolCommand Members


CopyFrom Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolCommand Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolCommand Class
WebTextEditorToolCommand Members


CopyFrom(Object) Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolCommand Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolCommand
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolCommand Class
WebTextEditorToolCommand Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolCommand Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolCommand
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolCommand Class
WebTextEditorToolCommand Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebTextEditor Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolCommand Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolCommand
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolCommand Class
WebTextEditorToolCommand Members


GetHashCode Method

[image]
Intersoft WebTextEditor Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolCommand Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolCommand
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolCommand Class
WebTextEditorToolCommand Members


GetPropertyString Method

[image]
Intersoft WebTextEditor Documentation
GetPropertyString Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolCommand Class : GetPropertyString Method

v

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetPropertyString( _
   ByVal v As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolCommand
Dim v As System.String
Dim value As System.String

value = instance.GetPropertyString(v)
C#
protected virtual System.string GetPropertyString(
   System.string v
)
Delphi
protected function GetPropertyString(
    v: System.String
): System.String; virtual;
JScript
protected function GetPropertyString(
   v : System.String
) : System.String;
Managed Extensions for C++
protected: virtual System.string* GetPropertyString(
   System.string* v
)
C++/CLI
protected:
virtual System.String^ GetPropertyString(
   System.String^ v
)

Parameters

v

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolCommand Class
WebTextEditorToolCommand Members


IsEmpty Method

[image]
Intersoft WebTextEditor Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolCommand Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolCommand
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolCommand Class
WebTextEditorToolCommand Members


IsInSerializationContext Method

[image]
Intersoft WebTextEditor Documentation
IsInSerializationContext Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolCommand Class : IsInSerializationContext Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function IsInSerializationContext() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolCommand
Dim value As System.Boolean

value = instance.IsInSerializationContext()
C#
protected virtual System.bool IsInSerializationContext()
Delphi
protected function IsInSerializationContext(): System.Boolean; virtual;
JScript
protected function IsInSerializationContext() : System.boolean;
Managed Extensions for C++
protected: virtual System.bool IsInSerializationContext();
C++/CLI
protected:
virtual System.bool IsInSerializationContext();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolCommand Class
WebTextEditorToolCommand Members


OnItemAdd Method

[image]
Intersoft WebTextEditor Documentation
OnItemAdd Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolCommand Class : OnItemAdd Method

collection

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnItemAdd( _
   ByVal collection As ISNet.WebUI.ISCollectionBase(Of INamedObject2) _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolCommand
Dim collection As ISNet.WebUI.ISCollectionBase(Of INamedObject2)

instance.OnItemAdd(collection)
C#
protected virtual void OnItemAdd(
   ISNet.WebUI.ISCollectionBase<INamedObject2> collection
)
Delphi
protected procedure OnItemAdd(
    collection: ISNet.WebUI.ISCollectionBase
); virtual;
JScript
protected function OnItemAdd(
   collection : ISNet.WebUI.ISCollectionBase
);
Managed Extensions for C++
protected: virtual void OnItemAdd(
   ISNet.WebUI.ISCollectionBase<INamedObject2*>* collection
)
C++/CLI
protected:
virtual void OnItemAdd(
   ISNet.WebUI.ISCollectionBase<INamedObject2^>^ collection
)

Parameters

collection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolCommand Class
WebTextEditorToolCommand Members


OnItemRemove Method

[image]
Intersoft WebTextEditor Documentation
OnItemRemove Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolCommand Class : OnItemRemove Method

collection

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnItemRemove( _
   ByVal collection As ISNet.WebUI.ISCollectionBase(Of INamedObject2) _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolCommand
Dim collection As ISNet.WebUI.ISCollectionBase(Of INamedObject2)

instance.OnItemRemove(collection)
C#
protected virtual void OnItemRemove(
   ISNet.WebUI.ISCollectionBase<INamedObject2> collection
)
Delphi
protected procedure OnItemRemove(
    collection: ISNet.WebUI.ISCollectionBase
); virtual;
JScript
protected function OnItemRemove(
   collection : ISNet.WebUI.ISCollectionBase
);
Managed Extensions for C++
protected: virtual void OnItemRemove(
   ISNet.WebUI.ISCollectionBase<INamedObject2*>* collection
)
C++/CLI
protected:
virtual void OnItemRemove(
   ISNet.WebUI.ISCollectionBase<INamedObject2^>^ collection
)

Parameters

collection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolCommand Class
WebTextEditorToolCommand Members


Reset Method

[image]
Intersoft WebTextEditor Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolCommand Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolCommand

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolCommand Class
WebTextEditorToolCommand Members


SerializeObjectData Method

[image]
Intersoft WebTextEditor Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolCommand Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolCommand
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolCommand Class
WebTextEditorToolCommand Members


ToString Method

[image]
Intersoft WebTextEditor Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolCommand Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolCommand
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolCommand Class
WebTextEditorToolCommand Members


WebTextEditorToolItemCollection Class Properties

[image]
Intersoft WebTextEditor Documentation
WebTextEditorToolItemCollection Class Properties
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace : WebTextEditorToolItemCollection Class

Glossary Item Box

For a list of all members of this type, see WebTextEditorToolItemCollection members.

Public Properties

 | Name | Description
Public Property | All | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Public Property | Count | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Item | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Public Property | Parent | (Inherited from ISNet.WebUI.ISCollectionBase<INamedObject2>)
Top

Protected Properties

 | Name | Description
Protected Property | Items | (Inherited from System.Collections.ObjectModel.Collection<INamedObject2>)
Top

See Also

Reference

WebTextEditorToolItemCollection Class
ISNet.WebUI.WebTextEditor Namespace


Add Method

[image]
Intersoft WebTextEditor Documentation
Add Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolItemCollection Class : Add Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Sub Add( _
   ByVal item As ISNet.WebUI.INamedObject2 _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolItemCollection
Dim item As ISNet.WebUI.INamedObject2

instance.Add(item)
C#
[__DynamicallyInvokableAttribute()]
public void Add(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public procedure Add(
    item: ISNet.WebUI.INamedObject2
);
JScript
__DynamicallyInvokableAttribute()
public function Add(
   item : ISNet.WebUI.INamedObject2
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void Add(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void Add(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolItemCollection Class
WebTextEditorToolItemCollection Members


All Property

[image]
Intersoft WebTextEditor Documentation
All Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolItemCollection Class : All Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public ReadOnly Property All As ISNet.WebUI.INamedObject2()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolItemCollection
Dim value() As ISNet.WebUI.INamedObject2

value = instance.All
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public ISNet.WebUI.INamedObject2[] All {get;}
Delphi
public read-only property All: ISNet.WebUI.array of INamedObject2;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get All : ISNet.WebUI.INamedObject2[]
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property ISNet.WebUI.INamedObject2*[]* get_All();
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property ISNet.WebUI.array<INamedObject2^>^ All {
   ISNet.WebUI.array<INamedObject2^>^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolItemCollection Class
WebTextEditorToolItemCollection Members


Clear Method

[image]
Intersoft WebTextEditor Documentation
Clear Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolItemCollection Class : Clear Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Sub Clear()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolItemCollection

instance.Clear()
C#
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public void Clear()
Delphi
public procedure Clear();
JScript
__DynamicallyInvokableAttribute()
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function Clear();
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: void Clear();
C++/CLI
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
void Clear();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolItemCollection Class
WebTextEditorToolItemCollection Members


ClearItems Method

[image]
Intersoft WebTextEditor Documentation
ClearItems Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolItemCollection Class : ClearItems Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ClearItems()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolItemCollection

instance.ClearItems()
C#
protected virtual void ClearItems()
Delphi
protected procedure ClearItems(); virtual;
JScript
protected function ClearItems();
Managed Extensions for C++
protected: virtual void ClearItems();
C++/CLI
protected:
virtual void ClearItems();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolItemCollection Class
WebTextEditorToolItemCollection Members


Contains Method

[image]
Intersoft WebTextEditor Documentation
Contains Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolItemCollection Class : Contains Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
<__DynamicallyInvokableAttribute()>
Public Function Contains( _
   ByVal item As ISNet.WebUI.INamedObject2 _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolItemCollection
Dim item As ISNet.WebUI.INamedObject2
Dim value As System.Boolean

value = instance.Contains(item)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public System.bool Contains(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public function Contains(
    item: ISNet.WebUI.INamedObject2
): System.Boolean;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
__DynamicallyInvokableAttribute()
public function Contains(
   item : ISNet.WebUI.INamedObject2
) : System.boolean;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public: System.bool Contains(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public:
System.bool Contains(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolItemCollection Class
WebTextEditorToolItemCollection Members


CopyTo Method

[image]
Intersoft WebTextEditor Documentation
CopyTo Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolItemCollection Class : CopyTo Method

array
index

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Sub CopyTo( _
   ByVal array() As ISNet.WebUI.INamedObject2, _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolItemCollection
Dim array() As ISNet.WebUI.INamedObject2
Dim index As System.Integer

instance.CopyTo(array, index)
C#
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public void CopyTo(
   ISNet.WebUI.INamedObject2[] array,
   System.int index
)
Delphi
public procedure CopyTo(
    array: ISNet.WebUI.INamedObject2array of;
    index: System.Integer
);
JScript
__DynamicallyInvokableAttribute()
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function CopyTo(
   array : ISNet.WebUI.INamedObject2[],
   index : System.int
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: void CopyTo(
   ISNet.WebUI.INamedObject2*[]* array,
   System.int index
)
C++/CLI
[__DynamicallyInvokableAttribute()]
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
void CopyTo(
   ISNet.WebUI.array<INamedObject2^>^ array,
   System.int index
)

Parameters

array
index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolItemCollection Class
WebTextEditorToolItemCollection Members


Count Property

[image]
Intersoft WebTextEditor Documentation
Count Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolItemCollection Class : Count Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public ReadOnly Property Count As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolItemCollection
Dim value As System.Integer

value = instance.Count
C#
[__DynamicallyInvokableAttribute()]
public System.int Count {get;}
Delphi
public read-only property Count: System.Integer;
JScript
__DynamicallyInvokableAttribute()
public function get Count : System.int
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: __property System.int get_Count();
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
property System.int Count {
   System.int get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolItemCollection Class
WebTextEditorToolItemCollection Members


CreateArray Method

[image]
Intersoft WebTextEditor Documentation
CreateArray Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolItemCollection Class : CreateArray Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function CreateArray() As ISNet.WebUI.INamedObject2()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolItemCollection
Dim value() As ISNet.WebUI.INamedObject2

value = instance.CreateArray()
C#
protected ISNet.WebUI.INamedObject2[] CreateArray()
Delphi
protected function CreateArray(): ISNet.WebUI.array of INamedObject2;
JScript
protected function CreateArray() : ISNet.WebUI.INamedObject2[];
Managed Extensions for C++
protected: ISNet.WebUI.INamedObject2*[]* CreateArray();
C++/CLI
protected:
ISNet.WebUI.array<INamedObject2^>^ CreateArray();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolItemCollection Class
WebTextEditorToolItemCollection Members


CreateNewItem Method

[image]
Intersoft WebTextEditor Documentation
CreateNewItem Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolItemCollection Class : CreateNewItem Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CreateNewItem() As WebTextEditorToolItem
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolItemCollection
Dim value As WebTextEditorToolItem

value = instance.CreateNewItem()
C#
public WebTextEditorToolItem CreateNewItem()
Delphi
public function CreateNewItem(): WebTextEditorToolItem;
JScript
public function CreateNewItem() : WebTextEditorToolItem;
Managed Extensions for C++
public: WebTextEditorToolItem* CreateNewItem();
C++/CLI
public:
WebTextEditorToolItem^ CreateNewItem();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolItemCollection Class
WebTextEditorToolItemCollection Members


GetEnumerator Method

[image]
Intersoft WebTextEditor Documentation
GetEnumerator Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolItemCollection Class : GetEnumerator Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Function GetEnumerator() As System.Collections.Generic.IEnumerator(Of INamedObject2)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolItemCollection
Dim value As System.Collections.Generic.IEnumerator(Of INamedObject2)

value = instance.GetEnumerator()
C#
[__DynamicallyInvokableAttribute()]
public System.Collections.Generic.IEnumerator<INamedObject2> GetEnumerator()
Delphi
public function GetEnumerator(): System.Collections.Generic.IEnumerator;
JScript
__DynamicallyInvokableAttribute()
public function GetEnumerator() : System.Collections.Generic.IEnumerator;
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: System.Collections.Generic.IEnumerator<INamedObject2*>* GetEnumerator();
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
System.Collections.Generic.IEnumerator<INamedObject2^>^ GetEnumerator();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolItemCollection Class
WebTextEditorToolItemCollection Members


GetObjectData Method

[image]
Intersoft WebTextEditor Documentation
GetObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolItemCollection Class : GetObjectData Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub GetObjectData( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolItemCollection
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.GetObjectData(info, context)
C#
public void GetObjectData(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure GetObjectData(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function GetObjectData(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void GetObjectData(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void GetObjectData(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolItemCollection Class
WebTextEditorToolItemCollection Members


IndexOf Method

[image]
Intersoft WebTextEditor Documentation
IndexOf Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolItemCollection Class : IndexOf Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
<__DynamicallyInvokableAttribute()>
Public Function IndexOf( _
   ByVal item As ISNet.WebUI.INamedObject2 _
) As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolItemCollection
Dim item As ISNet.WebUI.INamedObject2
Dim value As System.Integer

value = instance.IndexOf(item)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public System.int IndexOf(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public function IndexOf(
    item: ISNet.WebUI.INamedObject2
): System.Integer;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
__DynamicallyInvokableAttribute()
public function IndexOf(
   item : ISNet.WebUI.INamedObject2
) : System.int;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public: System.int IndexOf(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
[__DynamicallyInvokableAttribute()]
public:
System.int IndexOf(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolItemCollection Class
WebTextEditorToolItemCollection Members


Insert Method

[image]
Intersoft WebTextEditor Documentation
Insert Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolItemCollection Class : Insert Method

index
item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Sub Insert( _
   ByVal index As System.Integer, _
   ByVal item As ISNet.WebUI.INamedObject2 _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolItemCollection
Dim index As System.Integer
Dim item As ISNet.WebUI.INamedObject2

instance.Insert(index, item)
C#
[__DynamicallyInvokableAttribute()]
public void Insert(
   System.int index,
   ISNet.WebUI.INamedObject2 item
)
Delphi
public procedure Insert(
    index: System.Integer;
    item: ISNet.WebUI.INamedObject2
);
JScript
__DynamicallyInvokableAttribute()
public function Insert(
   index : System.int,
   item : ISNet.WebUI.INamedObject2
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void Insert(
   System.int index,
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void Insert(
   System.int index,
   ISNet.WebUI.INamedObject2^ item
)

Parameters

index
item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolItemCollection Class
WebTextEditorToolItemCollection Members


InsertItem Method

[image]
Intersoft WebTextEditor Documentation
InsertItem Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolItemCollection Class : InsertItem Method

index
item

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub InsertItem( _
   ByVal index As System.Integer, _
   ByVal item As ISNet.WebUI.INamedObject2 _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolItemCollection
Dim index As System.Integer
Dim item As ISNet.WebUI.INamedObject2

instance.InsertItem(index, item)
C#
protected virtual void InsertItem(
   System.int index,
   ISNet.WebUI.INamedObject2 item
)
Delphi
protected procedure InsertItem(
    index: System.Integer;
    item: ISNet.WebUI.INamedObject2
); virtual;
JScript
protected function InsertItem(
   index : System.int,
   item : ISNet.WebUI.INamedObject2
);
Managed Extensions for C++
protected: virtual void InsertItem(
   System.int index,
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
protected:
virtual void InsertItem(
   System.int index,
   ISNet.WebUI.INamedObject2^ item
)

Parameters

index
item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolItemCollection Class
WebTextEditorToolItemCollection Members


Item Property

[image]
Intersoft WebTextEditor Documentation
Item Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolItemCollection Class : Item Property

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Default Property Item( _
   ByVal index As System.Integer _
) As ISNet.WebUI.INamedObject2
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolItemCollection
Dim index As System.Integer
Dim value As ISNet.WebUI.INamedObject2

instance.Item(index) = value

value = instance.Item(index)
C#
[__DynamicallyInvokableAttribute()]
public ISNet.WebUI.INamedObject2 this[
   System.int index
]; {get; set;}
Delphi
public  this: : ISNet.WebUI.INamedObject2;[
    index: System.Integer
]; read-write
JScript
__DynamicallyInvokableAttribute()
public  this[
   index : System.int
] get,set : ISNet.WebUI.INamedObject2
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: __property ISNet.WebUI.INamedObject2* get_Item   System.int index
;
public: __property void set_Item   System.int index,
   ISNet.WebUI.INamedObject2* value
;
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
property ISNet.WebUI.INamedObject2^ default [int] {
   ISNet.WebUI.INamedObject2^ get(System.int index);
   void set (System.int index, ISNet.WebUI.INamedObject2^ value);
}

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolItemCollection Class
WebTextEditorToolItemCollection Members


Items Property

[image]
Intersoft WebTextEditor Documentation
Items Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolItemCollection Class : Items Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Protected ReadOnly Property Items As System.Collections.Generic.IList(Of INamedObject2)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolItemCollection
Dim value As System.Collections.Generic.IList(Of INamedObject2)

value = instance.Items
C#
[__DynamicallyInvokableAttribute()]
protected System.Collections.Generic.IList<INamedObject2> Items {get;}
Delphi
protected read-only property Items: System.Collections.Generic.IList;
JScript
__DynamicallyInvokableAttribute()
protected function get Items : System.Collections.Generic.IList
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
protected: __property System.Collections.Generic.IList<INamedObject2*>* get_Items();
C++/CLI
[__DynamicallyInvokableAttribute()]
protected:
property System.Collections.Generic.IList<INamedObject2^>^ Items {
   System.Collections.Generic.IList<INamedObject2^>^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolItemCollection Class
WebTextEditorToolItemCollection Members


Parent Property

[image]
Intersoft WebTextEditor Documentation
Parent Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolItemCollection Class : Parent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public ReadOnly Property Parent As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolItemCollection
Dim value As System.Object

value = instance.Parent
C#
public System.object Parent {get;}
Delphi
public read-only property Parent: System.TObject;
JScript
public function get Parent : System.Object
Managed Extensions for C++
public: __property System.Object* get_Parent();
C++/CLI
public:
property System.Object^ Parent {
   System.Object^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolItemCollection Class
WebTextEditorToolItemCollection Members


Remove Method

[image]
Intersoft WebTextEditor Documentation
Remove Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolItemCollection Class : Remove Method

item

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Function Remove( _
   ByVal item As ISNet.WebUI.INamedObject2 _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolItemCollection
Dim item As ISNet.WebUI.INamedObject2
Dim value As System.Boolean

value = instance.Remove(item)
C#
[__DynamicallyInvokableAttribute()]
public System.bool Remove(
   ISNet.WebUI.INamedObject2 item
)
Delphi
public function Remove(
    item: ISNet.WebUI.INamedObject2
): System.Boolean;
JScript
__DynamicallyInvokableAttribute()
public function Remove(
   item : ISNet.WebUI.INamedObject2
) : System.boolean;
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: System.bool Remove(
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
System.bool Remove(
   ISNet.WebUI.INamedObject2^ item
)

Parameters

item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolItemCollection Class
WebTextEditorToolItemCollection Members


RemoveAt Method

[image]
Intersoft WebTextEditor Documentation
RemoveAt Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolItemCollection Class : RemoveAt Method

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
<__DynamicallyInvokableAttribute()>
Public Sub RemoveAt( _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolItemCollection
Dim index As System.Integer

instance.RemoveAt(index)
C#
[__DynamicallyInvokableAttribute()]
public void RemoveAt(
   System.int index
)
Delphi
public procedure RemoveAt(
    index: System.Integer
);
JScript
__DynamicallyInvokableAttribute()
public function RemoveAt(
   index : System.int
);
Managed Extensions for C++
[__DynamicallyInvokableAttribute()]
public: void RemoveAt(
   System.int index
)
C++/CLI
[__DynamicallyInvokableAttribute()]
public:
void RemoveAt(
   System.int index
)

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolItemCollection Class
WebTextEditorToolItemCollection Members


RemoveItem Method

[image]
Intersoft WebTextEditor Documentation
RemoveItem Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolItemCollection Class : RemoveItem Method

index

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub RemoveItem( _
   ByVal index As System.Integer _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolItemCollection
Dim index As System.Integer

instance.RemoveItem(index)
C#
protected virtual void RemoveItem(
   System.int index
)
Delphi
protected procedure RemoveItem(
    index: System.Integer
); virtual;
JScript
protected function RemoveItem(
   index : System.int
);
Managed Extensions for C++
protected: virtual void RemoveItem(
   System.int index
)
C++/CLI
protected:
virtual void RemoveItem(
   System.int index
)

Parameters

index

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolItemCollection Class
WebTextEditorToolItemCollection Members


SerializerConstructor Method

[image]
Intersoft WebTextEditor Documentation
SerializerConstructor Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolItemCollection Class : SerializerConstructor Method

info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializerConstructor( _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolItemCollection
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializerConstructor(info, context)
C#
public void SerializerConstructor(
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializerConstructor(
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializerConstructor(
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializerConstructor(
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializerConstructor(
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolItemCollection Class
WebTextEditorToolItemCollection Members


SetItem Method

[image]
Intersoft WebTextEditor Documentation
SetItem Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolItemCollection Class : SetItem Method

index
item

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub SetItem( _
   ByVal index As System.Integer, _
   ByVal item As ISNet.WebUI.INamedObject2 _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolItemCollection
Dim index As System.Integer
Dim item As ISNet.WebUI.INamedObject2

instance.SetItem(index, item)
C#
protected virtual void SetItem(
   System.int index,
   ISNet.WebUI.INamedObject2 item
)
Delphi
protected procedure SetItem(
    index: System.Integer;
    item: ISNet.WebUI.INamedObject2
); virtual;
JScript
protected function SetItem(
   index : System.int,
   item : ISNet.WebUI.INamedObject2
);
Managed Extensions for C++
protected: virtual void SetItem(
   System.int index,
   ISNet.WebUI.INamedObject2* item
)
C++/CLI
protected:
virtual void SetItem(
   System.int index,
   ISNet.WebUI.INamedObject2^ item
)

Parameters

index
item

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolItemCollection Class
WebTextEditorToolItemCollection Members


SetParent Method

[image]
Intersoft WebTextEditor Documentation
SetParent Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolItemCollection Class : SetParent Method

parent

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SetParent( _
   ByVal parent As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolItemCollection
Dim parent As System.Object

instance.SetParent(parent)
C#
public virtual void SetParent(
   System.object parent
)
Delphi
public procedure SetParent(
    parent: System.TObject
); virtual;
JScript
public function SetParent(
   parent : System.Object
);
Managed Extensions for C++
public: virtual void SetParent(
   System.Object* parent
)
C++/CLI
public:
virtual void SetParent(
   System.Object^ parent
)

Parameters

parent

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolItemCollection Class
WebTextEditorToolItemCollection Members


Clone Method

[image]
Intersoft WebTextEditor Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolItem Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolItem
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolItem Class
WebTextEditorToolItem Members


Collection Property

[image]
Intersoft WebTextEditor Documentation
Collection Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolItem Class : Collection Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
Public Property Collection As ISNet.WebUI.ISCollectionBase(Of INamedObject2)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolItem
Dim value As ISNet.WebUI.ISCollectionBase(Of INamedObject2)

instance.Collection = value

value = instance.Collection
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public ISNet.WebUI.ISCollectionBase<INamedObject2> Collection {get; set;}
Delphi
public read-write property Collection: ISNet.WebUI.ISCollectionBase;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
public function get,set Collection : ISNet.WebUI.ISCollectionBase
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public: __property ISNet.WebUI.ISCollectionBase<INamedObject2*>* get_Collection();
public: __property void set_Collection(
   ISNet.WebUI.ISCollectionBase<INamedObject2*>* value
);
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public:
property ISNet.WebUI.ISCollectionBase<INamedObject2^>^ Collection {
   ISNet.WebUI.ISCollectionBase<INamedObject2^>^ get();
   void set (    ISNet.WebUI.ISCollectionBase<INamedObject2^>^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolItem Class
WebTextEditorToolItem Members


CopyFrom Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolItem Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolItem Class
WebTextEditorToolItem Members


CopyFrom(Object) Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolItem Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolItem
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolItem Class
WebTextEditorToolItem Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolItem Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolItem
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolItem Class
WebTextEditorToolItem Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebTextEditor Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolItem Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolItem
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolItem Class
WebTextEditorToolItem Members


GetHashCode Method

[image]
Intersoft WebTextEditor Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolItem Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolItem
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolItem Class
WebTextEditorToolItem Members


GetPropertyString Method

[image]
Intersoft WebTextEditor Documentation
GetPropertyString Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolItem Class : GetPropertyString Method

v

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetPropertyString( _
   ByVal v As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolItem
Dim v As System.String
Dim value As System.String

value = instance.GetPropertyString(v)
C#
protected virtual System.string GetPropertyString(
   System.string v
)
Delphi
protected function GetPropertyString(
    v: System.String
): System.String; virtual;
JScript
protected function GetPropertyString(
   v : System.String
) : System.String;
Managed Extensions for C++
protected: virtual System.string* GetPropertyString(
   System.string* v
)
C++/CLI
protected:
virtual System.String^ GetPropertyString(
   System.String^ v
)

Parameters

v

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolItem Class
WebTextEditorToolItem Members


IsEmpty Method

[image]
Intersoft WebTextEditor Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolItem Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolItem
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolItem Class
WebTextEditorToolItem Members


IsInSerializationContext Method

[image]
Intersoft WebTextEditor Documentation
IsInSerializationContext Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolItem Class : IsInSerializationContext Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function IsInSerializationContext() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolItem
Dim value As System.Boolean

value = instance.IsInSerializationContext()
C#
protected virtual System.bool IsInSerializationContext()
Delphi
protected function IsInSerializationContext(): System.Boolean; virtual;
JScript
protected function IsInSerializationContext() : System.boolean;
Managed Extensions for C++
protected: virtual System.bool IsInSerializationContext();
C++/CLI
protected:
virtual System.bool IsInSerializationContext();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolItem Class
WebTextEditorToolItem Members


OnItemAdd Method

[image]
Intersoft WebTextEditor Documentation
OnItemAdd Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolItem Class : OnItemAdd Method

collection

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnItemAdd( _
   ByVal collection As ISNet.WebUI.ISCollectionBase(Of INamedObject2) _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolItem
Dim collection As ISNet.WebUI.ISCollectionBase(Of INamedObject2)

instance.OnItemAdd(collection)
C#
protected virtual void OnItemAdd(
   ISNet.WebUI.ISCollectionBase<INamedObject2> collection
)
Delphi
protected procedure OnItemAdd(
    collection: ISNet.WebUI.ISCollectionBase
); virtual;
JScript
protected function OnItemAdd(
   collection : ISNet.WebUI.ISCollectionBase
);
Managed Extensions for C++
protected: virtual void OnItemAdd(
   ISNet.WebUI.ISCollectionBase<INamedObject2*>* collection
)
C++/CLI
protected:
virtual void OnItemAdd(
   ISNet.WebUI.ISCollectionBase<INamedObject2^>^ collection
)

Parameters

collection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolItem Class
WebTextEditorToolItem Members


OnItemRemove Method

[image]
Intersoft WebTextEditor Documentation
OnItemRemove Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolItem Class : OnItemRemove Method

collection

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnItemRemove( _
   ByVal collection As ISNet.WebUI.ISCollectionBase(Of INamedObject2) _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolItem
Dim collection As ISNet.WebUI.ISCollectionBase(Of INamedObject2)

instance.OnItemRemove(collection)
C#
protected virtual void OnItemRemove(
   ISNet.WebUI.ISCollectionBase<INamedObject2> collection
)
Delphi
protected procedure OnItemRemove(
    collection: ISNet.WebUI.ISCollectionBase
); virtual;
JScript
protected function OnItemRemove(
   collection : ISNet.WebUI.ISCollectionBase
);
Managed Extensions for C++
protected: virtual void OnItemRemove(
   ISNet.WebUI.ISCollectionBase<INamedObject2*>* collection
)
C++/CLI
protected:
virtual void OnItemRemove(
   ISNet.WebUI.ISCollectionBase<INamedObject2^>^ collection
)

Parameters

collection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolItem Class
WebTextEditorToolItem Members


Reset Method

[image]
Intersoft WebTextEditor Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolItem Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolItem

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolItem Class
WebTextEditorToolItem Members


SerializeObjectData Method

[image]
Intersoft WebTextEditor Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolItem Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolItem
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolItem Class
WebTextEditorToolItem Members


ToString Method

[image]
Intersoft WebTextEditor Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorToolItem Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorToolItem
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorToolItem Class
WebTextEditorToolItem Members


Clone Method

[image]
Intersoft WebTextEditor Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorViewSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorViewSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorViewSettings Class
WebTextEditorViewSettings Members


CopyFrom Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorViewSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorViewSettings Class
WebTextEditorViewSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorViewSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorViewSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorViewSettings Class
WebTextEditorViewSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorViewSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorViewSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorViewSettings Class
WebTextEditorViewSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebTextEditor Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorViewSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorViewSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorViewSettings Class
WebTextEditorViewSettings Members


GetHashCode Method

[image]
Intersoft WebTextEditor Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorViewSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorViewSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorViewSettings Class
WebTextEditorViewSettings Members


GetPropertyString Method

[image]
Intersoft WebTextEditor Documentation
GetPropertyString Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorViewSettings Class : GetPropertyString Method

v

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetPropertyString( _
   ByVal v As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorViewSettings
Dim v As System.String
Dim value As System.String

value = instance.GetPropertyString(v)
C#
protected virtual System.string GetPropertyString(
   System.string v
)
Delphi
protected function GetPropertyString(
    v: System.String
): System.String; virtual;
JScript
protected function GetPropertyString(
   v : System.String
) : System.String;
Managed Extensions for C++
protected: virtual System.string* GetPropertyString(
   System.string* v
)
C++/CLI
protected:
virtual System.String^ GetPropertyString(
   System.String^ v
)

Parameters

v

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorViewSettings Class
WebTextEditorViewSettings Members


IsEmpty Method

[image]
Intersoft WebTextEditor Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorViewSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorViewSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorViewSettings Class
WebTextEditorViewSettings Members


IsInSerializationContext Method

[image]
Intersoft WebTextEditor Documentation
IsInSerializationContext Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorViewSettings Class : IsInSerializationContext Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function IsInSerializationContext() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorViewSettings
Dim value As System.Boolean

value = instance.IsInSerializationContext()
C#
protected virtual System.bool IsInSerializationContext()
Delphi
protected function IsInSerializationContext(): System.Boolean; virtual;
JScript
protected function IsInSerializationContext() : System.boolean;
Managed Extensions for C++
protected: virtual System.bool IsInSerializationContext();
C++/CLI
protected:
virtual System.bool IsInSerializationContext();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorViewSettings Class
WebTextEditorViewSettings Members


Reset Method

[image]
Intersoft WebTextEditor Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorViewSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorViewSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorViewSettings Class
WebTextEditorViewSettings Members


SerializeObjectData Method

[image]
Intersoft WebTextEditor Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorViewSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorViewSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorViewSettings Class
WebTextEditorViewSettings Members


ToString Method

[image]
Intersoft WebTextEditor Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorViewSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorViewSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorViewSettings Class
WebTextEditorViewSettings Members


Clone Method

[image]
Intersoft WebTextEditor Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorWatermarkSettings Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorWatermarkSettings
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorWatermarkSettings Class
WebTextEditorWatermarkSettings Members


CopyFrom Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorWatermarkSettings Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.WebUIBaseClass)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.WebUIBaseClass)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorWatermarkSettings Class
WebTextEditorWatermarkSettings Members


CopyFrom(Object) Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorWatermarkSettings Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorWatermarkSettings
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorWatermarkSettings Class
WebTextEditorWatermarkSettings Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorWatermarkSettings Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorWatermarkSettings
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorWatermarkSettings Class
WebTextEditorWatermarkSettings Members
Overload List


DeSerializeObjectData Method

[image]
Intersoft WebTextEditor Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorWatermarkSettings Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorWatermarkSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorWatermarkSettings Class
WebTextEditorWatermarkSettings Members


GetHashCode Method

[image]
Intersoft WebTextEditor Documentation
GetHashCode Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorWatermarkSettings Class : GetHashCode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function GetHashCode() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorWatermarkSettings
Dim value As System.Integer

value = instance.GetHashCode()
C#
public virtual System.int GetHashCode()
Delphi
public function GetHashCode(): System.Integer; virtual;
JScript
public function GetHashCode() : System.int;
Managed Extensions for C++
public: virtual System.int GetHashCode();
C++/CLI
public:
virtual System.int GetHashCode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorWatermarkSettings Class
WebTextEditorWatermarkSettings Members


GetPropertyString Method

[image]
Intersoft WebTextEditor Documentation
GetPropertyString Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorWatermarkSettings Class : GetPropertyString Method

v

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetPropertyString( _
   ByVal v As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorWatermarkSettings
Dim v As System.String
Dim value As System.String

value = instance.GetPropertyString(v)
C#
protected virtual System.string GetPropertyString(
   System.string v
)
Delphi
protected function GetPropertyString(
    v: System.String
): System.String; virtual;
JScript
protected function GetPropertyString(
   v : System.String
) : System.String;
Managed Extensions for C++
protected: virtual System.string* GetPropertyString(
   System.string* v
)
C++/CLI
protected:
virtual System.String^ GetPropertyString(
   System.String^ v
)

Parameters

v

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorWatermarkSettings Class
WebTextEditorWatermarkSettings Members


IsEmpty Method

[image]
Intersoft WebTextEditor Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorWatermarkSettings Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorWatermarkSettings
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorWatermarkSettings Class
WebTextEditorWatermarkSettings Members


IsInSerializationContext Method

[image]
Intersoft WebTextEditor Documentation
IsInSerializationContext Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorWatermarkSettings Class : IsInSerializationContext Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function IsInSerializationContext() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorWatermarkSettings
Dim value As System.Boolean

value = instance.IsInSerializationContext()
C#
protected virtual System.bool IsInSerializationContext()
Delphi
protected function IsInSerializationContext(): System.Boolean; virtual;
JScript
protected function IsInSerializationContext() : System.boolean;
Managed Extensions for C++
protected: virtual System.bool IsInSerializationContext();
C++/CLI
protected:
virtual System.bool IsInSerializationContext();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorWatermarkSettings Class
WebTextEditorWatermarkSettings Members


Reset Method

[image]
Intersoft WebTextEditor Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorWatermarkSettings Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorWatermarkSettings

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorWatermarkSettings Class
WebTextEditorWatermarkSettings Members


SerializeObjectData Method

[image]
Intersoft WebTextEditor Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorWatermarkSettings Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorWatermarkSettings
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorWatermarkSettings Class
WebTextEditorWatermarkSettings Members


ToString Method

[image]
Intersoft WebTextEditor Documentation
ToString Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditorWatermarkSettings Class : ToString Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ToString() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditorWatermarkSettings
Dim value As System.String

value = instance.ToString()
C#
public virtual System.string ToString()
Delphi
public function ToString(): System.String; virtual;
JScript
public function ToString() : System.String;
Managed Extensions for C++
public: virtual System.string* ToString();
C++/CLI
public:
virtual System.String^ ToString();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditorWatermarkSettings Class
WebTextEditorWatermarkSettings Members


AccessKey Property

[image]
Intersoft WebTextEditor Documentation
AccessKey Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : AccessKey Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overridable Property AccessKey As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.String

instance.AccessKey = value

value = instance.AccessKey
C#
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public virtual System.string AccessKey {get; set;}
Delphi
public read-write property AccessKey: System.String; virtual;
JScript
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set AccessKey : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property virtual System.string* get_AccessKey();
public: __property virtual void set_AccessKey(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
virtual property System.String^ AccessKey {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


Adapter Property

[image]
Intersoft WebTextEditor Documentation
Adapter Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : Adapter Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property Adapter As System.Web.UI.Adapters.ControlAdapter
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Web.UI.Adapters.ControlAdapter

value = instance.Adapter
C#
protected System.Web.UI.Adapters.ControlAdapter Adapter {get;}
Delphi
protected read-only property Adapter: System.Web.UI.Adapters.ControlAdapter;
JScript
protected function get Adapter : System.Web.UI.Adapters.ControlAdapter
Managed Extensions for C++
protected: __property System.Web.UI.Adapters.ControlAdapter* get_Adapter();
C++/CLI
protected:
property System.Web.UI.Adapters.ControlAdapter^ Adapter {
   System.Web.UI.Adapters.ControlAdapter^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


AddAttributesToRender Method

[image]
Intersoft WebTextEditor Documentation
AddAttributesToRender Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : AddAttributesToRender Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub AddAttributesToRender( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim writer As System.Web.UI.HtmlTextWriter

instance.AddAttributesToRender(writer)
C#
protected virtual void AddAttributesToRender(
   System.Web.UI.HtmlTextWriter writer
)
Delphi
protected procedure AddAttributesToRender(
    writer: System.Web.UI.HtmlTextWriter
); virtual;
JScript
protected function AddAttributesToRender(
   writer : System.Web.UI.HtmlTextWriter
);
Managed Extensions for C++
protected: virtual void AddAttributesToRender(
   System.Web.UI.HtmlTextWriter* writer
)
C++/CLI
protected:
virtual void AddAttributesToRender(
   System.Web.UI.HtmlTextWriter^ writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


AddParsedSubObject Method

[image]
Intersoft WebTextEditor Documentation
AddParsedSubObject Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : AddParsedSubObject Method

obj

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Protected Overridable Sub AddParsedSubObject( _
   ByVal obj As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim obj As System.Object

instance.AddParsedSubObject(obj)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
protected virtual void AddParsedSubObject(
   System.object obj
)
Delphi
protected procedure AddParsedSubObject(
    obj: System.TObject
); virtual;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
protected function AddParsedSubObject(
   obj : System.Object
);
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
protected: virtual void AddParsedSubObject(
   System.Object* obj
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
protected:
virtual void AddParsedSubObject(
   System.Object^ obj
)

Parameters

obj

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


ApplyControlTheme Method

[image]
Intersoft WebTextEditor Documentation
ApplyControlTheme Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : ApplyControlTheme Method

themeInfo

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function ApplyControlTheme( _
   ByVal themeInfo As ISNet.WebUI.ThemeInfo _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim themeInfo As ISNet.WebUI.ThemeInfo
Dim value As System.Boolean

value = instance.ApplyControlTheme(themeInfo)
C#
protected virtual System.bool ApplyControlTheme(
   ISNet.WebUI.ThemeInfo themeInfo
)
Delphi
protected function ApplyControlTheme(
    themeInfo: ISNet.WebUI.ThemeInfo
): System.Boolean; virtual;
JScript
protected function ApplyControlTheme(
   themeInfo : ISNet.WebUI.ThemeInfo
) : System.boolean;
Managed Extensions for C++
protected: virtual System.bool ApplyControlTheme(
   ISNet.WebUI.ThemeInfo* themeInfo
)
C++/CLI
protected:
virtual System.bool ApplyControlTheme(
   ISNet.WebUI.ThemeInfo^ themeInfo
)

Parameters

themeInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


ApplyStyle Method

[image]
Intersoft WebTextEditor Documentation
ApplyStyle Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : ApplyStyle Method

s

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ApplyStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim s As System.Web.UI.WebControls.Style

instance.ApplyStyle(s)
C#
public void ApplyStyle(
   System.Web.UI.WebControls.Style s
)
Delphi
public procedure ApplyStyle(
    s: System.Web.UI.WebControls.Style
);
JScript
public function ApplyStyle(
   s : System.Web.UI.WebControls.Style
);
Managed Extensions for C++
public: void ApplyStyle(
   System.Web.UI.WebControls.Style* s
)
C++/CLI
public:
void ApplyStyle(
   System.Web.UI.WebControls.Style^ s
)

Parameters

s

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


ApplyStyleSheetSkin Method

[image]
Intersoft WebTextEditor Documentation
ApplyStyleSheetSkin Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : ApplyStyleSheetSkin Method

page

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Overridable Sub ApplyStyleSheetSkin( _
   ByVal page As System.Web.UI.Page _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim page As System.Web.UI.Page

instance.ApplyStyleSheetSkin(page)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page page
)
Delphi
public procedure ApplyStyleSheetSkin(
    page: System.Web.UI.Page
); virtual;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function ApplyStyleSheetSkin(
   page : System.Web.UI.Page
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page* page
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
virtual void ApplyStyleSheetSkin(
   System.Web.UI.Page^ page
)

Parameters

page

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


AppRelativeTemplateSourceDirectory Property

[image]
Intersoft WebTextEditor Documentation
AppRelativeTemplateSourceDirectory Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : AppRelativeTemplateSourceDirectory Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<WebSysDescriptionAttribute("The virtual directory of the Page or UserControl that contains this control.")>
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property AppRelativeTemplateSourceDirectory As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.String

instance.AppRelativeTemplateSourceDirectory = value

value = instance.AppRelativeTemplateSourceDirectory
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[WebSysDescriptionAttribute("The virtual directory of the Page or UserControl that contains this control.")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public System.string AppRelativeTemplateSourceDirectory {get; set;}
Delphi
public read-write property AppRelativeTemplateSourceDirectory: System.String;
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
WebSysDescriptionAttribute("The virtual directory of the Page or UserControl that contains this control.")
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get,set AppRelativeTemplateSourceDirectory : System.String
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[WebSysDescriptionAttribute("The virtual directory of the Page or UserControl that contains this control.")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property System.string* get_AppRelativeTemplateSourceDirectory();
public: __property void set_AppRelativeTemplateSourceDirectory(
   System.string* value
);
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[WebSysDescriptionAttribute("The virtual directory of the Page or UserControl that contains this control.")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property System.String^ AppRelativeTemplateSourceDirectory {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


AspNetAjaxSettings Property

[image]
Intersoft WebTextEditor Documentation
AspNetAjaxSettings Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : AspNetAjaxSettings Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DefaultValueAttribute()>
Public ReadOnly Property AspNetAjaxSettings As ISNet.WebUI.AspNetAjaxSettings
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As ISNet.WebUI.AspNetAjaxSettings

value = instance.AspNetAjaxSettings
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
public ISNet.WebUI.AspNetAjaxSettings AspNetAjaxSettings {get;}
Delphi
public read-only property AspNetAjaxSettings: ISNet.WebUI.AspNetAjaxSettings;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DefaultValueAttribute()
public function get AspNetAjaxSettings : ISNet.WebUI.AspNetAjaxSettings
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
public: __property ISNet.WebUI.AspNetAjaxSettings* get_AspNetAjaxSettings();
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
public:
property ISNet.WebUI.AspNetAjaxSettings^ AspNetAjaxSettings {
   ISNet.WebUI.AspNetAjaxSettings^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


AssignXmlInputHiddenUniqueID Method

[image]
Intersoft WebTextEditor Documentation
AssignXmlInputHiddenUniqueID Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : AssignXmlInputHiddenUniqueID Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub AssignXmlInputHiddenUniqueID()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor

instance.AssignXmlInputHiddenUniqueID()
C#
protected virtual void AssignXmlInputHiddenUniqueID()
Delphi
protected procedure AssignXmlInputHiddenUniqueID(); virtual;
JScript
protected function AssignXmlInputHiddenUniqueID();
Managed Extensions for C++
protected: virtual void AssignXmlInputHiddenUniqueID();
C++/CLI
protected:
virtual void AssignXmlInputHiddenUniqueID();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


Attributes Property

[image]
Intersoft WebTextEditor Documentation
Attributes Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : Attributes Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Tag attributes of the control.")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
Public ReadOnly Property Attributes As System.Web.UI.AttributeCollection
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Web.UI.AttributeCollection

value = instance.Attributes
C#
[WebSysDescriptionAttribute("Tag attributes of the control.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public System.Web.UI.AttributeCollection Attributes {get;}
Delphi
public read-only property Attributes: System.Web.UI.AttributeCollection;
JScript
WebSysDescriptionAttribute("Tag attributes of the control.")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
public function get Attributes : System.Web.UI.AttributeCollection
Managed Extensions for C++
[WebSysDescriptionAttribute("Tag attributes of the control.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public: __property System.Web.UI.AttributeCollection* get_Attributes();
C++/CLI
[WebSysDescriptionAttribute("Tag attributes of the control.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public:
property System.Web.UI.AttributeCollection^ Attributes {
   System.Web.UI.AttributeCollection^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


BuildProfileTree Method

[image]
Intersoft WebTextEditor Documentation
BuildProfileTree Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : BuildProfileTree Method

parentId
calcViewState

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Sub BuildProfileTree( _
   ByVal parentId As System.String, _
   ByVal calcViewState As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim parentId As System.String
Dim calcViewState As System.Boolean

instance.BuildProfileTree(parentId, calcViewState)
C#
protected void BuildProfileTree(
   System.string parentId,
   System.bool calcViewState
)
Delphi
protected procedure BuildProfileTree(
    parentId: System.String;
    calcViewState: System.Boolean
);
JScript
protected function BuildProfileTree(
   parentId : System.String,
   calcViewState : System.boolean
);
Managed Extensions for C++
protected: void BuildProfileTree(
   System.string* parentId,
   System.bool calcViewState
)
C++/CLI
protected:
void BuildProfileTree(
   System.String^ parentId,
   System.bool calcViewState
)

Parameters

parentId
calcViewState

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


CanUseWebResources Method

[image]
Intersoft WebTextEditor Documentation
CanUseWebResources Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : CanUseWebResources Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function CanUseWebResources() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Boolean

value = instance.CanUseWebResources()
C#
public System.bool CanUseWebResources()
Delphi
public function CanUseWebResources(): System.Boolean;
JScript
public function CanUseWebResources() : System.boolean;
Managed Extensions for C++
public: System.bool CanUseWebResources();
C++/CLI
public:
System.bool CanUseWebResources();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


ChildControlsCreated Property

[image]
Intersoft WebTextEditor Documentation
ChildControlsCreated Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : ChildControlsCreated Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Property ChildControlsCreated As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Boolean

instance.ChildControlsCreated = value

value = instance.ChildControlsCreated
C#
protected System.bool ChildControlsCreated {get; set;}
Delphi
protected read-write property ChildControlsCreated: System.Boolean;
JScript
protected function get,set ChildControlsCreated : System.boolean
Managed Extensions for C++
protected: __property System.bool get_ChildControlsCreated();
protected: __property void set_ChildControlsCreated(
   System.bool value
);
C++/CLI
protected:
property System.bool ChildControlsCreated {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


ClearCachedClientID Method

[image]
Intersoft WebTextEditor Documentation
ClearCachedClientID Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : ClearCachedClientID Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Sub ClearCachedClientID()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor

instance.ClearCachedClientID()
C#
protected void ClearCachedClientID()
Delphi
protected procedure ClearCachedClientID();
JScript
protected function ClearCachedClientID();
Managed Extensions for C++
protected: void ClearCachedClientID();
C++/CLI
protected:
void ClearCachedClientID();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


ClearChildControlState Method

[image]
Intersoft WebTextEditor Documentation
ClearChildControlState Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : ClearChildControlState Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Sub ClearChildControlState()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor

instance.ClearChildControlState()
C#
protected void ClearChildControlState()
Delphi
protected procedure ClearChildControlState();
JScript
protected function ClearChildControlState();
Managed Extensions for C++
protected: void ClearChildControlState();
C++/CLI
protected:
void ClearChildControlState();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


ClearChildState Method

[image]
Intersoft WebTextEditor Documentation
ClearChildState Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : ClearChildState Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Sub ClearChildState()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor

instance.ClearChildState()
C#
protected void ClearChildState()
Delphi
protected procedure ClearChildState();
JScript
protected function ClearChildState();
Managed Extensions for C++
protected: void ClearChildState();
C++/CLI
protected:
void ClearChildState();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


ClearChildViewState Method

[image]
Intersoft WebTextEditor Documentation
ClearChildViewState Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : ClearChildViewState Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Sub ClearChildViewState()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor

instance.ClearChildViewState()
C#
protected void ClearChildViewState()
Delphi
protected procedure ClearChildViewState();
JScript
protected function ClearChildViewState();
Managed Extensions for C++
protected: void ClearChildViewState();
C++/CLI
protected:
void ClearChildViewState();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


ClearEffectiveClientIDMode Method

[image]
Intersoft WebTextEditor Documentation
ClearEffectiveClientIDMode Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : ClearEffectiveClientIDMode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Sub ClearEffectiveClientIDMode()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor

instance.ClearEffectiveClientIDMode()
C#
protected void ClearEffectiveClientIDMode()
Delphi
protected procedure ClearEffectiveClientIDMode();
JScript
protected function ClearEffectiveClientIDMode();
Managed Extensions for C++
protected: void ClearEffectiveClientIDMode();
C++/CLI
protected:
void ClearEffectiveClientIDMode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


ClientID Property

[image]
Intersoft WebTextEditor Documentation
ClientID Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : ClientID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<WebSysDescriptionAttribute("The ID of the control that is rendered for the client.")>
Public Overridable ReadOnly Property ClientID As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.String

value = instance.ClientID
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[WebSysDescriptionAttribute("The ID of the control that is rendered for the client.")]
public virtual System.string ClientID {get;}
Delphi
public read-only property ClientID: System.String; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
WebSysDescriptionAttribute("The ID of the control that is rendered for the client.")
public function get ClientID : System.String
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[WebSysDescriptionAttribute("The ID of the control that is rendered for the client.")]
public: __property virtual System.string* get_ClientID();
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[WebSysDescriptionAttribute("The ID of the control that is rendered for the client.")]
public:
virtual property System.String^ ClientID {
   System.String^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


ClientIDMode Property

[image]
Intersoft WebTextEditor Documentation
ClientIDMode Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : ClientIDMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.ThemeableAttribute(False)>
<WebCategoryAttribute("Behavior")>
<System.ComponentModel.DefaultValueAttribute()>
<WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")>
Public Overridable Property ClientIDMode As System.Web.UI.ClientIDMode
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Web.UI.ClientIDMode

instance.ClientIDMode = value

value = instance.ClientIDMode
C#
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")]
public virtual System.Web.UI.ClientIDMode ClientIDMode {get; set;}
Delphi
public read-write property ClientIDMode: System.Web.UI.ClientIDMode; virtual;
JScript
System.Web.UI.ThemeableAttribute()
WebCategoryAttribute("Behavior")
System.ComponentModel.DefaultValueAttribute()
WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")
public function get,set ClientIDMode : System.Web.UI.ClientIDMode
Managed Extensions for C++
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")]
public: __property virtual System.Web.UI.ClientIDMode get_ClientIDMode();
public: __property virtual void set_ClientIDMode(
   System.Web.UI.ClientIDMode value
);
C++/CLI
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Indicates how the ClientID should be generated for the control.")]
public:
virtual property System.Web.UI.ClientIDMode ClientIDMode {
   System.Web.UI.ClientIDMode get();
   void set (    System.Web.UI.ClientIDMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


ClientIDSeparator Property

[image]
Intersoft WebTextEditor Documentation
ClientIDSeparator Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : ClientIDSeparator Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property ClientIDSeparator As System.Char
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Char

value = instance.ClientIDSeparator
C#
protected System.char ClientIDSeparator {get;}
Delphi
protected read-only property ClientIDSeparator: System.Char;
JScript
protected function get ClientIDSeparator : System.char
Managed Extensions for C++
protected: __property System.char get_ClientIDSeparator();
C++/CLI
protected:
property System.char ClientIDSeparator {
   System.char get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


Clone Method

[image]
Intersoft WebTextEditor Documentation
Clone Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : Clone Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function Clone() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Object

value = instance.Clone()
C#
public virtual System.object Clone()
Delphi
public function Clone(): System.TObject; virtual;
JScript
public function Clone() : System.Object;
Managed Extensions for C++
public: virtual System.Object* Clone();
C++/CLI
public:
virtual System.Object^ Clone();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


ControlDataTransferFormat Property

[image]
Intersoft WebTextEditor Documentation
ControlDataTransferFormat Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : ControlDataTransferFormat Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines the format used to exchange the control's data across client and server.")>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Overridable Property ControlDataTransferFormat As ISNet.WebUI.DataTransferFormat
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As ISNet.WebUI.DataTransferFormat

instance.ControlDataTransferFormat = value

value = instance.ControlDataTransferFormat
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines the format used to exchange the control's data across client and server.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
public virtual ISNet.WebUI.DataTransferFormat ControlDataTransferFormat {get; set;}
Delphi
public read-write property ControlDataTransferFormat: ISNet.WebUI.DataTransferFormat; virtual;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines the format used to exchange the control's data across client and server.")
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set ControlDataTransferFormat : ISNet.WebUI.DataTransferFormat
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines the format used to exchange the control's data across client and server.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property virtual ISNet.WebUI.DataTransferFormat get_ControlDataTransferFormat();
public: __property virtual void set_ControlDataTransferFormat(
   ISNet.WebUI.DataTransferFormat value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that determines the format used to exchange the control's data across client and server.")]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
virtual property ISNet.WebUI.DataTransferFormat ControlDataTransferFormat {
   ISNet.WebUI.DataTransferFormat get();
   void set (    ISNet.WebUI.DataTransferFormat value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


ControlRequestHandler Method

[image]
Intersoft WebTextEditor Documentation
ControlRequestHandler Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : ControlRequestHandler Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Sub ControlRequestHandler()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor

instance.ControlRequestHandler()
C#
protected void ControlRequestHandler()
Delphi
protected procedure ControlRequestHandler();
JScript
protected function ControlRequestHandler();
Managed Extensions for C++
protected: void ControlRequestHandler();
C++/CLI
protected:
void ControlRequestHandler();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


Controls Property

[image]
Intersoft WebTextEditor Documentation
Controls Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : Controls Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("The collection of child controls owned by the control.")>
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Overridable ReadOnly Property Controls As System.Web.UI.ControlCollection
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Web.UI.ControlCollection

value = instance.Controls
C#
[WebSysDescriptionAttribute("The collection of child controls owned by the control.")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public virtual System.Web.UI.ControlCollection Controls {get;}
Delphi
public read-only property Controls: System.Web.UI.ControlCollection; virtual;
JScript
WebSysDescriptionAttribute("The collection of child controls owned by the control.")
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get Controls : System.Web.UI.ControlCollection
Managed Extensions for C++
[WebSysDescriptionAttribute("The collection of child controls owned by the control.")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property virtual System.Web.UI.ControlCollection* get_Controls();
C++/CLI
[WebSysDescriptionAttribute("The collection of child controls owned by the control.")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
virtual property System.Web.UI.ControlCollection^ Controls {
   System.Web.UI.ControlCollection^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


ControlStyle Property

[image]
Intersoft WebTextEditor Documentation
ControlStyle Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : ControlStyle Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("The style associated with the control.")>
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public ReadOnly Property ControlStyle As System.Web.UI.WebControls.Style
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Web.UI.WebControls.Style

value = instance.ControlStyle
C#
[WebSysDescriptionAttribute("The style associated with the control.")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public System.Web.UI.WebControls.Style ControlStyle {get;}
Delphi
public read-only property ControlStyle: System.Web.UI.WebControls.Style;
JScript
WebSysDescriptionAttribute("The style associated with the control.")
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get ControlStyle : System.Web.UI.WebControls.Style
Managed Extensions for C++
[WebSysDescriptionAttribute("The style associated with the control.")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property System.Web.UI.WebControls.Style* get_ControlStyle();
C++/CLI
[WebSysDescriptionAttribute("The style associated with the control.")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property System.Web.UI.WebControls.Style^ ControlStyle {
   System.Web.UI.WebControls.Style^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


ControlStyleCreated Property

[image]
Intersoft WebTextEditor Documentation
ControlStyleCreated Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : ControlStyleCreated Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
<WebSysDescriptionAttribute("Whether the style associated with the control has been created.")>
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public ReadOnly Property ControlStyleCreated As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Boolean

value = instance.ControlStyleCreated
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[WebSysDescriptionAttribute("Whether the style associated with the control has been created.")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public System.bool ControlStyleCreated {get;}
Delphi
public read-only property ControlStyleCreated: System.Boolean;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
WebSysDescriptionAttribute("Whether the style associated with the control has been created.")
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function get ControlStyleCreated : System.boolean
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[WebSysDescriptionAttribute("Whether the style associated with the control has been created.")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: __property System.bool get_ControlStyleCreated();
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[WebSysDescriptionAttribute("Whether the style associated with the control has been created.")]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
property System.bool ControlStyleCreated {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


CopyBaseAttributes Method

[image]
Intersoft WebTextEditor Documentation
CopyBaseAttributes Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : CopyBaseAttributes Method

controlSrc

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub CopyBaseAttributes( _
   ByVal controlSrc As System.Web.UI.WebControls.WebControl _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim controlSrc As System.Web.UI.WebControls.WebControl

instance.CopyBaseAttributes(controlSrc)
C#
public void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl controlSrc
)
Delphi
public procedure CopyBaseAttributes(
    controlSrc: System.Web.UI.WebControls.WebControl
);
JScript
public function CopyBaseAttributes(
   controlSrc : System.Web.UI.WebControls.WebControl
);
Managed Extensions for C++
public: void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl* controlSrc
)
C++/CLI
public:
void CopyBaseAttributes(
   System.Web.UI.WebControls.WebControl^ controlSrc
)

Parameters

controlSrc

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


CopyFrom Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : CopyFrom Method

Glossary Item Box

Overload List

Overload | Description
CopyFrom(Object) | (Inherited from ISNet.WebUI.ISNetControl)
CopyFrom(Object,Boolean) | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


CopyFrom(Object) Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom(Object) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class > CopyFrom Method : CopyFrom(Object) Method

objSource

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim objSource As System.Object

instance.CopyFrom(objSource)
C#
public virtual void CopyFrom(
   System.object objSource
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource
)

Parameters

objSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members
Overload List


CopyFrom(Object,Boolean) Method

[image]
Intersoft WebTextEditor Documentation
CopyFrom(Object,Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class > CopyFrom Method : CopyFrom(Object,Boolean) Method

objSource
cloneSourceValue

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Sub CopyFrom( _
   ByVal objSource As System.Object, _
   ByVal cloneSourceValue As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim objSource As System.Object
Dim cloneSourceValue As System.Boolean

instance.CopyFrom(objSource, cloneSourceValue)
C#
public virtual void CopyFrom(
   System.object objSource,
   System.bool cloneSourceValue
)
Delphi
public procedure CopyFrom(
    objSource: System.TObject;
    cloneSourceValue: System.Boolean
); virtual;
JScript
public function CopyFrom(
   objSource : System.Object,
   cloneSourceValue : System.boolean
);
Managed Extensions for C++
public: virtual void CopyFrom(
   System.Object* objSource,
   System.bool cloneSourceValue
)
C++/CLI
public:
virtual void CopyFrom(
   System.Object^ objSource,
   System.bool cloneSourceValue
)

Parameters

objSource
cloneSourceValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members
Overload List


CreateControlCollection Method

[image]
Intersoft WebTextEditor Documentation
CreateControlCollection Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : CreateControlCollection Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function CreateControlCollection() As System.Web.UI.ControlCollection
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Web.UI.ControlCollection

value = instance.CreateControlCollection()
C#
protected virtual System.Web.UI.ControlCollection CreateControlCollection()
Delphi
protected function CreateControlCollection(): System.Web.UI.ControlCollection; virtual;
JScript
protected function CreateControlCollection() : System.Web.UI.ControlCollection;
Managed Extensions for C++
protected: virtual System.Web.UI.ControlCollection* CreateControlCollection();
C++/CLI
protected:
virtual System.Web.UI.ControlCollection^ CreateControlCollection();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


CreateControlStyle Method

[image]
Intersoft WebTextEditor Documentation
CreateControlStyle Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : CreateControlStyle Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function CreateControlStyle() As System.Web.UI.WebControls.Style
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Web.UI.WebControls.Style

value = instance.CreateControlStyle()
C#
protected virtual System.Web.UI.WebControls.Style CreateControlStyle()
Delphi
protected function CreateControlStyle(): System.Web.UI.WebControls.Style; virtual;
JScript
protected function CreateControlStyle() : System.Web.UI.WebControls.Style;
Managed Extensions for C++
protected: virtual System.Web.UI.WebControls.Style* CreateControlStyle();
C++/CLI
protected:
virtual System.Web.UI.WebControls.Style^ CreateControlStyle();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


CreateThemeInfo Method

[image]
Intersoft WebTextEditor Documentation
CreateThemeInfo Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : CreateThemeInfo Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function CreateThemeInfo() As ISNet.WebUI.ThemeInfo
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As ISNet.WebUI.ThemeInfo

value = instance.CreateThemeInfo()
C#
protected virtual ISNet.WebUI.ThemeInfo CreateThemeInfo()
Delphi
protected function CreateThemeInfo(): ISNet.WebUI.ThemeInfo; virtual;
JScript
protected function CreateThemeInfo() : ISNet.WebUI.ThemeInfo;
Managed Extensions for C++
protected: virtual ISNet.WebUI.ThemeInfo* CreateThemeInfo();
C++/CLI
protected:
virtual ISNet.WebUI.ThemeInfo^ CreateThemeInfo();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


DataBind Method

[image]
Intersoft WebTextEditor Documentation
DataBind Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : DataBind Method

Glossary Item Box

Overload List

Overload | Description
DataBind() | (Inherited from System.Web.UI.Control)
DataBind(Boolean) | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


DataBind() Method

[image]
Intersoft WebTextEditor Documentation
DataBind() Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class > DataBind Method : DataBind() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Overridable Sub DataBind()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor

instance.DataBind()
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public virtual void DataBind()
Delphi
public procedure DataBind(); virtual;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function DataBind();
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: virtual void DataBind();
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
virtual void DataBind();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members
Overload List


DataBind(Boolean) Method

[image]
Intersoft WebTextEditor Documentation
DataBind(Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class > DataBind Method : DataBind(Boolean) Method

raiseOnDataBinding

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overloads Overridable Sub DataBind( _
   ByVal raiseOnDataBinding As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim raiseOnDataBinding As System.Boolean

instance.DataBind(raiseOnDataBinding)
C#
protected virtual void DataBind(
   System.bool raiseOnDataBinding
)
Delphi
protected procedure DataBind(
    raiseOnDataBinding: System.Boolean
); virtual;
JScript
protected function DataBind(
   raiseOnDataBinding : System.boolean
);
Managed Extensions for C++
protected: virtual void DataBind(
   System.bool raiseOnDataBinding
)
C++/CLI
protected:
virtual void DataBind(
   System.bool raiseOnDataBinding
)

Parameters

raiseOnDataBinding

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members
Overload List


DataBindChildren Method

[image]
Intersoft WebTextEditor Documentation
DataBindChildren Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : DataBindChildren Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub DataBindChildren()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor

instance.DataBindChildren()
C#
protected virtual void DataBindChildren()
Delphi
protected procedure DataBindChildren(); virtual;
JScript
protected function DataBindChildren();
Managed Extensions for C++
protected: virtual void DataBindChildren();
C++/CLI
protected:
virtual void DataBindChildren();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


DataBinding Event

[image]
Intersoft WebTextEditor Documentation
DataBinding Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : DataBinding Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the control's data binding expressions are to be evaluated.")>
<WebCategoryAttribute("Data")>
Public Event DataBinding As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim handler As System.EventHandler

AddHandler instance.DataBinding, handler
C#
[WebSysDescriptionAttribute("Fires when the control's data binding expressions are to be evaluated.")]
[WebCategoryAttribute("Data")]
public event System.EventHandler DataBinding
Delphi
public event DataBinding: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the control's data binding expressions are to be evaluated.")]
[WebCategoryAttribute("Data")]
public: __event System.EventHandler* DataBinding
C++/CLI
[WebSysDescriptionAttribute("Fires when the control's data binding expressions are to be evaluated.")]
[WebCategoryAttribute("Data")]
public:
event System.EventHandler^ DataBinding

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


DecodeRequest Method

[image]
Intersoft WebTextEditor Documentation
DecodeRequest Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : DecodeRequest Method

request

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function DecodeRequest( _
   ByVal request As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim request As System.String
Dim value As System.String

value = instance.DecodeRequest(request)
C#
protected System.string DecodeRequest(
   System.string request
)
Delphi
protected function DecodeRequest(
    request: System.String
): System.String;
JScript
protected function DecodeRequest(
   request : System.String
) : System.String;
Managed Extensions for C++
protected: System.string* DecodeRequest(
   System.string* request
)
C++/CLI
protected:
System.String^ DecodeRequest(
   System.String^ request
)

Parameters

request

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


DeSerializeObjectData Method

[image]
Intersoft WebTextEditor Documentation
DeSerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : DeSerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub DeSerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.DeSerializeObjectData(type, info, context)
C#
public void DeSerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure DeSerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function DeSerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void DeSerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void DeSerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


Dispose Method

[image]
Intersoft WebTextEditor Documentation
Dispose Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : Dispose Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Dispose()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor

instance.Dispose()
C#
public virtual void Dispose()
Delphi
public procedure Dispose(); virtual;
JScript
public function Dispose();
Managed Extensions for C++
public: virtual void Dispose();
C++/CLI
public:
virtual void Dispose();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


Disposed Event

[image]
Intersoft WebTextEditor Documentation
Disposed Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : Disposed Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the control has been disposed.")>
Public Event Disposed As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim handler As System.EventHandler

AddHandler instance.Disposed, handler
C#
[WebSysDescriptionAttribute("Fires when the control has been disposed.")]
public event System.EventHandler Disposed
Delphi
public event Disposed: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the control has been disposed.")]
public: __event System.EventHandler* Disposed
C++/CLI
[WebSysDescriptionAttribute("Fires when the control has been disposed.")]
public:
event System.EventHandler^ Disposed

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


Enabled Property

[image]
Intersoft WebTextEditor Documentation
Enabled Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : Enabled Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Overridable Property Enabled As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Boolean

instance.Enabled = value

value = instance.Enabled
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public virtual System.bool Enabled {get; set;}
Delphi
public read-write property Enabled: System.Boolean; virtual;
JScript
ISNet.Serialization.BinarySerializableAttribute()
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set Enabled : System.boolean
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property virtual System.bool get_Enabled();
public: __property virtual void set_Enabled(
   System.bool value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
virtual property System.bool Enabled {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


EnableManagedTheming Property

[image]
Intersoft WebTextEditor Documentation
EnableManagedTheming Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : EnableManagedTheming Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
Public Overridable Property EnableManagedTheming As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Boolean

instance.EnableManagedTheming = value

value = instance.EnableManagedTheming
C#
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public virtual System.bool EnableManagedTheming {get; set;}
Delphi
public read-write property EnableManagedTheming: System.Boolean; virtual;
JScript
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.NotifyParentPropertyAttribute()
public function get,set EnableManagedTheming : System.boolean
Managed Extensions for C++
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public: __property virtual System.bool get_EnableManagedTheming();
public: __property virtual void set_EnableManagedTheming(
   System.bool value
);
C++/CLI
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the theming for this control should be managed by Intersoft Theme Architecture. When set to false, this control will not apply the style defined in Theme Architecture.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
public:
virtual property System.bool EnableManagedTheming {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


EnableTheming Property

[image]
Intersoft WebTextEditor Documentation
EnableTheming Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : EnableTheming Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(True)>
Public Overridable Property EnableTheming As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Boolean

instance.EnableTheming = value

value = instance.EnableTheming
C#
[System.ComponentModel.BrowsableAttribute(true)]
public virtual System.bool EnableTheming {get; set;}
Delphi
public read-write property EnableTheming: System.Boolean; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
public function get,set EnableTheming : System.boolean
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(true)]
public: __property virtual System.bool get_EnableTheming();
public: __property virtual void set_EnableTheming(
   System.bool value
);
C++/CLI
[System.ComponentModel.BrowsableAttribute(true)]
public:
virtual property System.bool EnableTheming {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


EnableViewState Property

[image]
Intersoft WebTextEditor Documentation
EnableViewState Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : EnableViewState Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overridable Property EnableViewState As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Boolean

instance.EnableViewState = value

value = instance.EnableViewState
C#
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public virtual System.bool EnableViewState {get; set;}
Delphi
public read-write property EnableViewState: System.Boolean; virtual;
JScript
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set EnableViewState : System.boolean
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property virtual System.bool get_EnableViewState();
public: __property virtual void set_EnableViewState(
   System.bool value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
virtual property System.bool EnableViewState {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


EnableWebResources Property

[image]
Intersoft WebTextEditor Documentation
EnableWebResources Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : EnableWebResources Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). See help for more information and remarks.")>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Web Resources")>
Public Property EnableWebResources As ISNet.WebUI.WebResourceType
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As ISNet.WebUI.WebResourceType

instance.EnableWebResources = value

value = instance.EnableWebResources
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). See help for more information and remarks.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Web Resources")]
public ISNet.WebUI.WebResourceType EnableWebResources {get; set;}
Delphi
public read-write property EnableWebResources: ISNet.WebUI.WebResourceType;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). See help for more information and remarks.")
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Web Resources")
public function get,set EnableWebResources : ISNet.WebUI.WebResourceType
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). See help for more information and remarks.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Web Resources")]
public: __property ISNet.WebUI.WebResourceType get_EnableWebResources();
public: __property void set_EnableWebResources(
   ISNet.WebUI.WebResourceType value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Specifies the option for use with web resources feature. When enabled, the component will retrieve scripts and client resources from web resources instead of external script location (IIS virtual directory). See help for more information and remarks.")]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Web Resources")]
public:
property ISNet.WebUI.WebResourceType EnableWebResources {
   ISNet.WebUI.WebResourceType get();
   void set (    ISNet.WebUI.WebResourceType value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


EnsureChildControls Method

[image]
Intersoft WebTextEditor Documentation
EnsureChildControls Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : EnsureChildControls Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub EnsureChildControls()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor

instance.EnsureChildControls()
C#
protected virtual void EnsureChildControls()
Delphi
protected procedure EnsureChildControls(); virtual;
JScript
protected function EnsureChildControls();
Managed Extensions for C++
protected: virtual void EnsureChildControls();
C++/CLI
protected:
virtual void EnsureChildControls();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


EnsureID Method

[image]
Intersoft WebTextEditor Documentation
EnsureID Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : EnsureID Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Sub EnsureID()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor

instance.EnsureID()
C#
protected void EnsureID()
Delphi
protected procedure EnsureID();
JScript
protected function EnsureID();
Managed Extensions for C++
protected: void EnsureID();
C++/CLI
protected:
void EnsureID();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


Events Property

[image]
Intersoft WebTextEditor Documentation
Events Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : Events Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property Events As System.ComponentModel.EventHandlerList
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.ComponentModel.EventHandlerList

value = instance.Events
C#
protected System.ComponentModel.EventHandlerList Events {get;}
Delphi
protected read-only property Events: System.ComponentModel.EventHandlerList;
JScript
protected function get Events : System.ComponentModel.EventHandlerList
Managed Extensions for C++
protected: __property System.ComponentModel.EventHandlerList* get_Events();
C++/CLI
protected:
property System.ComponentModel.EventHandlerList^ Events {
   System.ComponentModel.EventHandlerList^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


FindControl Method

[image]
Intersoft WebTextEditor Documentation
FindControl Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : FindControl Method

Glossary Item Box

Overload List

Overload | Description
FindControl(String) | (Inherited from ISNet.WebUI.ISNetControl)
FindControl(String,Int32) | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


FindControl(String) Method

[image]
Intersoft WebTextEditor Documentation
FindControl(String) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class > FindControl Method : FindControl(String) Method

id

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Overridable Function FindControl( _
   ByVal id As System.String _
) As System.Web.UI.Control
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim id As System.String
Dim value As System.Web.UI.Control

value = instance.FindControl(id)
C#
public virtual System.Web.UI.Control FindControl(
   System.string id
)
Delphi
public function FindControl(
    id: System.String
): System.Web.UI.Control; virtual;
JScript
public function FindControl(
   id : System.String
) : System.Web.UI.Control;
Managed Extensions for C++
public: virtual System.Web.UI.Control* FindControl(
   System.string* id
)
C++/CLI
public:
virtual System.Web.UI.Control^ FindControl(
   System.String^ id
)

Parameters

id

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members
Overload List


FindControl(String,Int32) Method

[image]
Intersoft WebTextEditor Documentation
FindControl(String,Int32) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class > FindControl Method : FindControl(String,Int32) Method

id
pathOffset

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overloads Overridable Function FindControl( _
   ByVal id As System.String, _
   ByVal pathOffset As System.Integer _
) As System.Web.UI.Control
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim id As System.String
Dim pathOffset As System.Integer
Dim value As System.Web.UI.Control

value = instance.FindControl(id, pathOffset)
C#
protected virtual System.Web.UI.Control FindControl(
   System.string id,
   System.int pathOffset
)
Delphi
protected function FindControl(
    id: System.String;
    pathOffset: System.Integer
): System.Web.UI.Control; virtual;
JScript
protected function FindControl(
   id : System.String,
   pathOffset : System.int
) : System.Web.UI.Control;
Managed Extensions for C++
protected: virtual System.Web.UI.Control* FindControl(
   System.string* id,
   System.int pathOffset
)
C++/CLI
protected:
virtual System.Web.UI.Control^ FindControl(
   System.String^ id,
   System.int pathOffset
)

Parameters

id
pathOffset

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members
Overload List


Focus Method

[image]
Intersoft WebTextEditor Documentation
Focus Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : Focus Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Focus()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor

instance.Focus()
C#
public virtual void Focus()
Delphi
public procedure Focus(); virtual;
JScript
public function Focus();
Managed Extensions for C++
public: virtual void Focus();
C++/CLI
public:
virtual void Focus();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


ForceDisableXmlCompression Method

[image]
Intersoft WebTextEditor Documentation
ForceDisableXmlCompression Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : ForceDisableXmlCompression Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub ForceDisableXmlCompression()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor

instance.ForceDisableXmlCompression()
C#
public void ForceDisableXmlCompression()
Delphi
public procedure ForceDisableXmlCompression();
JScript
public function ForceDisableXmlCompression();
Managed Extensions for C++
public: void ForceDisableXmlCompression();
C++/CLI
public:
void ForceDisableXmlCompression();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


GetApplicationState Method

[image]
Intersoft WebTextEditor Documentation
GetApplicationState Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : GetApplicationState Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetApplicationState() As System.Web.HttpApplicationState
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Web.HttpApplicationState

value = instance.GetApplicationState()
C#
protected virtual System.Web.HttpApplicationState GetApplicationState()
Delphi
protected function GetApplicationState(): System.Web.HttpApplicationState; virtual;
JScript
protected function GetApplicationState() : System.Web.HttpApplicationState;
Managed Extensions for C++
protected: virtual System.Web.HttpApplicationState* GetApplicationState();
C++/CLI
protected:
virtual System.Web.HttpApplicationState^ GetApplicationState();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


GetCachedAppTheme Method

[image]
Intersoft WebTextEditor Documentation
GetCachedAppTheme Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : GetCachedAppTheme Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function GetCachedAppTheme() As ISNet.WebUI.ThemeInfo
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As ISNet.WebUI.ThemeInfo

value = instance.GetCachedAppTheme()
C#
protected ISNet.WebUI.ThemeInfo GetCachedAppTheme()
Delphi
protected function GetCachedAppTheme(): ISNet.WebUI.ThemeInfo;
JScript
protected function GetCachedAppTheme() : ISNet.WebUI.ThemeInfo;
Managed Extensions for C++
protected: ISNet.WebUI.ThemeInfo* GetCachedAppTheme();
C++/CLI
protected:
ISNet.WebUI.ThemeInfo^ GetCachedAppTheme();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


GetCurrentControlLifeCycle Method

[image]
Intersoft WebTextEditor Documentation
GetCurrentControlLifeCycle Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : GetCurrentControlLifeCycle Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetCurrentControlLifeCycle() As ISNet.WebUI.ControlLifeCycle
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As ISNet.WebUI.ControlLifeCycle

value = instance.GetCurrentControlLifeCycle()
C#
public ISNet.WebUI.ControlLifeCycle GetCurrentControlLifeCycle()
Delphi
public function GetCurrentControlLifeCycle(): ISNet.WebUI.ControlLifeCycle;
JScript
public function GetCurrentControlLifeCycle() : ISNet.WebUI.ControlLifeCycle;
Managed Extensions for C++
public: ISNet.WebUI.ControlLifeCycle GetCurrentControlLifeCycle();
C++/CLI
public:
ISNet.WebUI.ControlLifeCycle GetCurrentControlLifeCycle();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


GetCurrentTheme Method

[image]
Intersoft WebTextEditor Documentation
GetCurrentTheme Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : GetCurrentTheme Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetCurrentTheme() As ISNet.WebUI.ThemeInfo
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As ISNet.WebUI.ThemeInfo

value = instance.GetCurrentTheme()
C#
public ISNet.WebUI.ThemeInfo GetCurrentTheme()
Delphi
public function GetCurrentTheme(): ISNet.WebUI.ThemeInfo;
JScript
public function GetCurrentTheme() : ISNet.WebUI.ThemeInfo;
Managed Extensions for C++
public: ISNet.WebUI.ThemeInfo* GetCurrentTheme();
C++/CLI
public:
ISNet.WebUI.ThemeInfo^ GetCurrentTheme();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


GetDesignModeState Method

[image]
Intersoft WebTextEditor Documentation
GetDesignModeState Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : GetDesignModeState Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.NoFlags,
   Assertion=False,
   UnmanagedCode=False,
   SkipVerification=False,
   Execution=False,
   ControlThread=False,
   ControlEvidence=False,
   ControlPolicy=False,
   SerializationFormatter=False,
   ControlDomainPolicy=False,
   ControlPrincipal=False,
   ControlAppDomain=False,
   RemotingConfiguration=False,
   Infrastructure=False,
   BindingRedirects=False,
   Action=SecurityAction.Demand,
   Unrestricted=True)>
Protected Overridable Function GetDesignModeState() As System.Collections.IDictionary
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Collections.IDictionary

value = instance.GetDesignModeState()
C#
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.NoFlags,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=true)]
protected virtual System.Collections.IDictionary GetDesignModeState()
Delphi
protected function GetDesignModeState(): System.Collections.IDictionary; virtual;
JScript
System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.NoFlags,
   Assertion=,
   UnmanagedCode=,
   SkipVerification=,
   Execution=,
   ControlThread=,
   ControlEvidence=,
   ControlPolicy=,
   SerializationFormatter=,
   ControlDomainPolicy=,
   ControlPrincipal=,
   ControlAppDomain=,
   RemotingConfiguration=,
   Infrastructure=,
   BindingRedirects=,
   Action=SecurityAction.Demand,
   Unrestricted=)
protected function GetDesignModeState() : System.Collections.IDictionary;
Managed Extensions for C++
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.NoFlags,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=true)]
protected: virtual System.Collections.IDictionary* GetDesignModeState();
C++/CLI
[System.Security.Permissions.SecurityPermissionAttribute(Flags=SecurityPermissionFlag.NoFlags,
   Assertion=false,
   UnmanagedCode=false,
   SkipVerification=false,
   Execution=false,
   ControlThread=false,
   ControlEvidence=false,
   ControlPolicy=false,
   SerializationFormatter=false,
   ControlDomainPolicy=false,
   ControlPrincipal=false,
   ControlAppDomain=false,
   RemotingConfiguration=false,
   Infrastructure=false,
   BindingRedirects=false,
   Action=SecurityAction.Demand,
   Unrestricted=true)]
protected:
virtual System.Collections.IDictionary^ GetDesignModeState();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


GetFrameworkDataFolder Method

[image]
Intersoft WebTextEditor Documentation
GetFrameworkDataFolder Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : GetFrameworkDataFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkDataFolder() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.String

value = instance.GetFrameworkDataFolder()
C#
public System.string GetFrameworkDataFolder()
Delphi
public function GetFrameworkDataFolder(): System.String;
JScript
public function GetFrameworkDataFolder() : System.String;
Managed Extensions for C++
public: System.string* GetFrameworkDataFolder();
C++/CLI
public:
System.String^ GetFrameworkDataFolder();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


GetFrameworkFolder Method

[image]
Intersoft WebTextEditor Documentation
GetFrameworkFolder Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : GetFrameworkFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkFolder() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.String

value = instance.GetFrameworkFolder()
C#
public System.string GetFrameworkFolder()
Delphi
public function GetFrameworkFolder(): System.String;
JScript
public function GetFrameworkFolder() : System.String;
Managed Extensions for C++
public: System.string* GetFrameworkFolder();
C++/CLI
public:
System.String^ GetFrameworkFolder();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


GetFrameworkVersion Method

[image]
Intersoft WebTextEditor Documentation
GetFrameworkVersion Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : GetFrameworkVersion Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetFrameworkVersion() As System.Version
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Version

value = instance.GetFrameworkVersion()
C#
public System.Version GetFrameworkVersion()
Delphi
public function GetFrameworkVersion(): System.Version;
JScript
public function GetFrameworkVersion() : System.Version;
Managed Extensions for C++
public: System.Version* GetFrameworkVersion();
C++/CLI
public:
System.Version^ GetFrameworkVersion();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


GetIntersoftFolder Method

[image]
Intersoft WebTextEditor Documentation
GetIntersoftFolder Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : GetIntersoftFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetIntersoftFolder() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.String

value = instance.GetIntersoftFolder()
C#
public System.string GetIntersoftFolder()
Delphi
public function GetIntersoftFolder(): System.String;
JScript
public function GetIntersoftFolder() : System.String;
Managed Extensions for C++
public: System.string* GetIntersoftFolder();
C++/CLI
public:
System.String^ GetIntersoftFolder();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


GetLayoutFolder Method

[image]
Intersoft WebTextEditor Documentation
GetLayoutFolder Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : GetLayoutFolder Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetLayoutFolder() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.String

value = instance.GetLayoutFolder()
C#
public System.string GetLayoutFolder()
Delphi
public function GetLayoutFolder(): System.String;
JScript
public function GetLayoutFolder() : System.String;
Managed Extensions for C++
public: System.string* GetLayoutFolder();
C++/CLI
public:
System.String^ GetLayoutFolder();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


GetPostedXMLData Method

[image]
Intersoft WebTextEditor Documentation
GetPostedXMLData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : GetPostedXMLData Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetPostedXMLData() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.String

value = instance.GetPostedXMLData()
C#
public System.string GetPostedXMLData()
Delphi
public function GetPostedXMLData(): System.String;
JScript
public function GetPostedXMLData() : System.String;
Managed Extensions for C++
public: System.string* GetPostedXMLData();
C++/CLI
public:
System.String^ GetPostedXMLData();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


GetProductInfoKey Method

[image]
Intersoft WebTextEditor Documentation
GetProductInfoKey Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : GetProductInfoKey Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetProductInfoKey() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.String

value = instance.GetProductInfoKey()
C#
public System.string GetProductInfoKey()
Delphi
public function GetProductInfoKey(): System.String;
JScript
public function GetProductInfoKey() : System.String;
Managed Extensions for C++
public: System.string* GetProductInfoKey();
C++/CLI
public:
System.String^ GetProductInfoKey();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


GetProductSimpleName Method

[image]
Intersoft WebTextEditor Documentation
GetProductSimpleName Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : GetProductSimpleName Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetProductSimpleName() As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.String

value = instance.GetProductSimpleName()
C#
public System.string GetProductSimpleName()
Delphi
public function GetProductSimpleName(): System.String;
JScript
public function GetProductSimpleName() : System.String;
Managed Extensions for C++
public: System.string* GetProductSimpleName();
C++/CLI
public:
System.String^ GetProductSimpleName();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


GetPropertyString Method

[image]
Intersoft WebTextEditor Documentation
GetPropertyString Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : GetPropertyString Method

v

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetPropertyString( _
   ByVal v As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim v As System.String
Dim value As System.String

value = instance.GetPropertyString(v)
C#
protected virtual System.string GetPropertyString(
   System.string v
)
Delphi
protected function GetPropertyString(
    v: System.String
): System.String; virtual;
JScript
protected function GetPropertyString(
   v : System.String
) : System.String;
Managed Extensions for C++
protected: virtual System.string* GetPropertyString(
   System.string* v
)
C++/CLI
protected:
virtual System.String^ GetPropertyString(
   System.String^ v
)

Parameters

v

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


GetPropertyValue Method

[image]
Intersoft WebTextEditor Documentation
GetPropertyValue Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : GetPropertyValue Method

defValue
propValue
webConfigKey

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetPropertyValue( _
   ByVal defValue As System.String, _
   ByVal propValue As System.String, _
   ByVal webConfigKey As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim defValue As System.String
Dim propValue As System.String
Dim webConfigKey As System.String
Dim value As System.String

value = instance.GetPropertyValue(defValue, propValue, webConfigKey)
C#
public System.string GetPropertyValue(
   System.string defValue,
   System.string propValue,
   System.string webConfigKey
)
Delphi
public function GetPropertyValue(
    defValue: System.String;
    propValue: System.String;
    webConfigKey: System.String
): System.String;
JScript
public function GetPropertyValue(
   defValue : System.String,
   propValue : System.String,
   webConfigKey : System.String
) : System.String;
Managed Extensions for C++
public: System.string* GetPropertyValue(
   System.string* defValue,
   System.string* propValue,
   System.string* webConfigKey
)
C++/CLI
public:
System.String^ GetPropertyValue(
   System.String^ defValue,
   System.String^ propValue,
   System.String^ webConfigKey
)

Parameters

defValue
propValue
webConfigKey

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


GetResourceStream Method

[image]
Intersoft WebTextEditor Documentation
GetResourceStream Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : GetResourceStream Method

resourceUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetResourceStream( _
   ByVal resourceUrl As System.String _
) As System.IO.Stream
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim resourceUrl As System.String
Dim value As System.IO.Stream

value = instance.GetResourceStream(resourceUrl)
C#
public System.IO.Stream GetResourceStream(
   System.string resourceUrl
)
Delphi
public function GetResourceStream(
    resourceUrl: System.String
): System.IO.Stream;
JScript
public function GetResourceStream(
   resourceUrl : System.String
) : System.IO.Stream;
Managed Extensions for C++
public: System.IO.Stream* GetResourceStream(
   System.string* resourceUrl
)
C++/CLI
public:
System.IO.Stream^ GetResourceStream(
   System.String^ resourceUrl
)

Parameters

resourceUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


GetRouteUrl Method

[image]
Intersoft WebTextEditor Documentation
GetRouteUrl Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : GetRouteUrl Method

Glossary Item Box

Overload List

Overload | Description
GetRouteUrl(Object) | (Inherited from System.Web.UI.Control)
GetRouteUrl(String,Object) | (Inherited from System.Web.UI.Control)
GetRouteUrl(RouteValueDictionary) | (Inherited from System.Web.UI.Control)
GetRouteUrl(String,RouteValueDictionary) | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


GetRouteUrl(Object) Method

[image]
Intersoft WebTextEditor Documentation
GetRouteUrl(Object) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class > GetRouteUrl Method : GetRouteUrl(Object) Method

routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As System.Object _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim routeParameters As System.Object
Dim value As System.String

value = instance.GetRouteUrl(routeParameters)
C#
public System.string GetRouteUrl(
   System.object routeParameters
)
Delphi
public function GetRouteUrl(
    routeParameters: System.TObject
): System.String;
JScript
public function GetRouteUrl(
   routeParameters : System.Object
) : System.String;
Managed Extensions for C++
public: System.string* GetRouteUrl(
   System.Object* routeParameters
)
C++/CLI
public:
System.String^ GetRouteUrl(
   System.Object^ routeParameters
)

Parameters

routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members
Overload List


GetRouteUrl(RouteValueDictionary) Method

[image]
Intersoft WebTextEditor Documentation
GetRouteUrl(RouteValueDictionary) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class > GetRouteUrl Method : GetRouteUrl(RouteValueDictionary) Method

routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function GetRouteUrl( _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim routeParameters As System.Web.Routing.RouteValueDictionary
Dim value As System.String

value = instance.GetRouteUrl(routeParameters)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.string GetRouteUrl(
   System.Web.Routing.RouteValueDictionary routeParameters
)
Delphi
public function GetRouteUrl(
    routeParameters: System.Web.Routing.RouteValueDictionary
): System.String;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function GetRouteUrl(
   routeParameters : System.Web.Routing.RouteValueDictionary
) : System.String;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.string* GetRouteUrl(
   System.Web.Routing.RouteValueDictionary* routeParameters
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.String^ GetRouteUrl(
   System.Web.Routing.RouteValueDictionary^ routeParameters
)

Parameters

routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members
Overload List


GetRouteUrl(String,Object) Method

[image]
Intersoft WebTextEditor Documentation
GetRouteUrl(String,Object) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class > GetRouteUrl Method : GetRouteUrl(String,Object) Method

routeName
routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeName As System.String, _
   ByVal routeParameters As System.Object _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim routeName As System.String
Dim routeParameters As System.Object
Dim value As System.String

value = instance.GetRouteUrl(routeName, routeParameters)
C#
public System.string GetRouteUrl(
   System.string routeName,
   System.object routeParameters
)
Delphi
public function GetRouteUrl(
    routeName: System.String;
    routeParameters: System.TObject
): System.String;
JScript
public function GetRouteUrl(
   routeName : System.String,
   routeParameters : System.Object
) : System.String;
Managed Extensions for C++
public: System.string* GetRouteUrl(
   System.string* routeName,
   System.Object* routeParameters
)
C++/CLI
public:
System.String^ GetRouteUrl(
   System.String^ routeName,
   System.Object^ routeParameters
)

Parameters

routeName
routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members
Overload List


GetRouteUrl(String,RouteValueDictionary) Method

[image]
Intersoft WebTextEditor Documentation
GetRouteUrl(String,RouteValueDictionary) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class > GetRouteUrl Method : GetRouteUrl(String,RouteValueDictionary) Method

routeName
routeParameters

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Function GetRouteUrl( _
   ByVal routeName As System.String, _
   ByVal routeParameters As System.Web.Routing.RouteValueDictionary _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim routeName As System.String
Dim routeParameters As System.Web.Routing.RouteValueDictionary
Dim value As System.String

value = instance.GetRouteUrl(routeName, routeParameters)
C#
public System.string GetRouteUrl(
   System.string routeName,
   System.Web.Routing.RouteValueDictionary routeParameters
)
Delphi
public function GetRouteUrl(
    routeName: System.String;
    routeParameters: System.Web.Routing.RouteValueDictionary
): System.String;
JScript
public function GetRouteUrl(
   routeName : System.String,
   routeParameters : System.Web.Routing.RouteValueDictionary
) : System.String;
Managed Extensions for C++
public: System.string* GetRouteUrl(
   System.string* routeName,
   System.Web.Routing.RouteValueDictionary* routeParameters
)
C++/CLI
public:
System.String^ GetRouteUrl(
   System.String^ routeName,
   System.Web.Routing.RouteValueDictionary^ routeParameters
)

Parameters

routeName
routeParameters

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members
Overload List


GetSessionLevelTheme Method

[image]
Intersoft WebTextEditor Documentation
GetSessionLevelTheme Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : GetSessionLevelTheme Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function GetSessionLevelTheme() As ISNet.WebUI.ThemeInfo
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As ISNet.WebUI.ThemeInfo

value = instance.GetSessionLevelTheme()
C#
protected ISNet.WebUI.ThemeInfo GetSessionLevelTheme()
Delphi
protected function GetSessionLevelTheme(): ISNet.WebUI.ThemeInfo;
JScript
protected function GetSessionLevelTheme() : ISNet.WebUI.ThemeInfo;
Managed Extensions for C++
protected: ISNet.WebUI.ThemeInfo* GetSessionLevelTheme();
C++/CLI
protected:
ISNet.WebUI.ThemeInfo^ GetSessionLevelTheme();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


GetUniqueIDRelativeTo Method

[image]
Intersoft WebTextEditor Documentation
GetUniqueIDRelativeTo Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : GetUniqueIDRelativeTo Method

control

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function GetUniqueIDRelativeTo( _
   ByVal control As System.Web.UI.Control _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim control As System.Web.UI.Control
Dim value As System.String

value = instance.GetUniqueIDRelativeTo(control)
C#
public System.string GetUniqueIDRelativeTo(
   System.Web.UI.Control control
)
Delphi
public function GetUniqueIDRelativeTo(
    control: System.Web.UI.Control
): System.String;
JScript
public function GetUniqueIDRelativeTo(
   control : System.Web.UI.Control
) : System.String;
Managed Extensions for C++
public: System.string* GetUniqueIDRelativeTo(
   System.Web.UI.Control* control
)
C++/CLI
public:
System.String^ GetUniqueIDRelativeTo(
   System.Web.UI.Control^ control
)

Parameters

control

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


HasAttributes Property

[image]
Intersoft WebTextEditor Documentation
HasAttributes Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : HasAttributes Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public ReadOnly Property HasAttributes As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Boolean

value = instance.HasAttributes
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public System.bool HasAttributes {get;}
Delphi
public read-only property HasAttributes: System.Boolean;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get HasAttributes : System.boolean
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property System.bool get_HasAttributes();
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property System.bool HasAttributes {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


HasChildViewState Property

[image]
Intersoft WebTextEditor Documentation
HasChildViewState Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : HasChildViewState Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property HasChildViewState As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Boolean

value = instance.HasChildViewState
C#
protected System.bool HasChildViewState {get;}
Delphi
protected read-only property HasChildViewState: System.Boolean;
JScript
protected function get HasChildViewState : System.boolean
Managed Extensions for C++
protected: __property System.bool get_HasChildViewState();
C++/CLI
protected:
property System.bool HasChildViewState {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


HasControls Method

[image]
Intersoft WebTextEditor Documentation
HasControls Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : HasControls Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function HasControls() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Boolean

value = instance.HasControls()
C#
public virtual System.bool HasControls()
Delphi
public function HasControls(): System.Boolean; virtual;
JScript
public function HasControls() : System.boolean;
Managed Extensions for C++
public: virtual System.bool HasControls();
C++/CLI
public:
virtual System.bool HasControls();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


HasEvents Method

[image]
Intersoft WebTextEditor Documentation
HasEvents Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : HasEvents Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Protected Function HasEvents() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Boolean

value = instance.HasEvents()
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
protected System.bool HasEvents()
Delphi
protected function HasEvents(): System.Boolean;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
protected function HasEvents() : System.boolean;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
protected: System.bool HasEvents();
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
protected:
System.bool HasEvents();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


Height Property

[image]
Intersoft WebTextEditor Documentation
Height Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : Height Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Layout")>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<ISNet.Serialization.BinarySerializableAttribute()>
Public Overridable Property Height As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Web.UI.WebControls.Unit

instance.Height = value

value = instance.Height
C#
[System.ComponentModel.CategoryAttribute("Layout")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
public virtual System.Web.UI.WebControls.Unit Height {get; set;}
Delphi
public read-write property Height: System.Web.UI.WebControls.Unit; virtual;
JScript
System.ComponentModel.CategoryAttribute("Layout")
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
ISNet.Serialization.BinarySerializableAttribute()
public function get,set Height : System.Web.UI.WebControls.Unit
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Layout")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
public: __property virtual System.Web.UI.WebControls.Unit get_Height();
public: __property virtual void set_Height(
   System.Web.UI.WebControls.Unit value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Layout")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[ISNet.Serialization.BinarySerializableAttribute()]
public:
virtual property System.Web.UI.WebControls.Unit Height {
   System.Web.UI.WebControls.Unit get();
   void set (    System.Web.UI.WebControls.Unit value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


ID Property

[image]
Intersoft WebTextEditor Documentation
ID Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : ID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.FilterableAttribute(False)>
<System.Web.UI.ThemeableAttribute(False)>
<WebSysDescriptionAttribute("Programmatic name of the control.")>
<System.ComponentModel.ParenthesizePropertyNameAttribute(True)>
<System.ComponentModel.MergablePropertyAttribute(False)>
Public Overridable Property ID As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.String

instance.ID = value

value = instance.ID
C#
[System.Web.UI.FilterableAttribute(false)]
[System.Web.UI.ThemeableAttribute(false)]
[WebSysDescriptionAttribute("Programmatic name of the control.")]
[System.ComponentModel.ParenthesizePropertyNameAttribute(true)]
[System.ComponentModel.MergablePropertyAttribute(false)]
public virtual System.string ID {get; set;}
Delphi
public read-write property ID: System.String; virtual;
JScript
System.Web.UI.FilterableAttribute()
System.Web.UI.ThemeableAttribute()
WebSysDescriptionAttribute("Programmatic name of the control.")
System.ComponentModel.ParenthesizePropertyNameAttribute()
System.ComponentModel.MergablePropertyAttribute()
public function get,set ID : System.String
Managed Extensions for C++
[System.Web.UI.FilterableAttribute(false)]
[System.Web.UI.ThemeableAttribute(false)]
[WebSysDescriptionAttribute("Programmatic name of the control.")]
[System.ComponentModel.ParenthesizePropertyNameAttribute(true)]
[System.ComponentModel.MergablePropertyAttribute(false)]
public: __property virtual System.string* get_ID();
public: __property virtual void set_ID(
   System.string* value
);
C++/CLI
[System.Web.UI.FilterableAttribute(false)]
[System.Web.UI.ThemeableAttribute(false)]
[WebSysDescriptionAttribute("Programmatic name of the control.")]
[System.ComponentModel.ParenthesizePropertyNameAttribute(true)]
[System.ComponentModel.MergablePropertyAttribute(false)]
public:
virtual property System.String^ ID {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


IdSeparator Property

[image]
Intersoft WebTextEditor Documentation
IdSeparator Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : IdSeparator Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property IdSeparator As System.Char
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Char

value = instance.IdSeparator
C#
protected System.char IdSeparator {get;}
Delphi
protected read-only property IdSeparator: System.Char;
JScript
protected function get IdSeparator : System.char
Managed Extensions for C++
protected: __property System.char get_IdSeparator();
C++/CLI
protected:
property System.char IdSeparator {
   System.char get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


Init Event

[image]
Intersoft WebTextEditor Documentation
Init Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : Init Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the page has been initialized.")>
Public Event Init As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim handler As System.EventHandler

AddHandler instance.Init, handler
C#
[WebSysDescriptionAttribute("Fires when the page has been initialized.")]
public event System.EventHandler Init
Delphi
public event Init: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the page has been initialized.")]
public: __event System.EventHandler* Init
C++/CLI
[WebSysDescriptionAttribute("Fires when the page has been initialized.")]
public:
event System.EventHandler^ Init

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


InitializeLayoutBehaviors Method

[image]
Intersoft WebTextEditor Documentation
InitializeLayoutBehaviors Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : InitializeLayoutBehaviors Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub InitializeLayoutBehaviors()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor

instance.InitializeLayoutBehaviors()
C#
protected virtual void InitializeLayoutBehaviors()
Delphi
protected procedure InitializeLayoutBehaviors(); virtual;
JScript
protected function InitializeLayoutBehaviors();
Managed Extensions for C++
protected: virtual void InitializeLayoutBehaviors();
C++/CLI
protected:
virtual void InitializeLayoutBehaviors();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


InitializeManagedTheming Method

[image]
Intersoft WebTextEditor Documentation
InitializeManagedTheming Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : InitializeManagedTheming Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub InitializeManagedTheming()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor

instance.InitializeManagedTheming()
C#
protected virtual void InitializeManagedTheming()
Delphi
protected procedure InitializeManagedTheming(); virtual;
JScript
protected function InitializeManagedTheming();
Managed Extensions for C++
protected: virtual void InitializeManagedTheming();
C++/CLI
protected:
virtual void InitializeManagedTheming();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


IsApplicationAvailable Method

[image]
Intersoft WebTextEditor Documentation
IsApplicationAvailable Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : IsApplicationAvailable Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function IsApplicationAvailable() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Boolean

value = instance.IsApplicationAvailable()
C#
protected System.bool IsApplicationAvailable()
Delphi
protected function IsApplicationAvailable(): System.Boolean;
JScript
protected function IsApplicationAvailable() : System.boolean;
Managed Extensions for C++
protected: System.bool IsApplicationAvailable();
C++/CLI
protected:
System.bool IsApplicationAvailable();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


IsAppThemeEnabled Method

[image]
Intersoft WebTextEditor Documentation
IsAppThemeEnabled Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : IsAppThemeEnabled Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function IsAppThemeEnabled() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Boolean

value = instance.IsAppThemeEnabled()
C#
protected virtual System.bool IsAppThemeEnabled()
Delphi
protected function IsAppThemeEnabled(): System.Boolean; virtual;
JScript
protected function IsAppThemeEnabled() : System.boolean;
Managed Extensions for C++
protected: virtual System.bool IsAppThemeEnabled();
C++/CLI
protected:
virtual System.bool IsAppThemeEnabled();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


IsAtlasCallback Method

[image]
Intersoft WebTextEditor Documentation
IsAtlasCallback Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : IsAtlasCallback Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsAtlasCallback() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Boolean

value = instance.IsAtlasCallback()
C#
public System.bool IsAtlasCallback()
Delphi
public function IsAtlasCallback(): System.Boolean;
JScript
public function IsAtlasCallback() : System.boolean;
Managed Extensions for C++
public: System.bool IsAtlasCallback();
C++/CLI
public:
System.bool IsAtlasCallback();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


IsBetaRelease Method

[image]
Intersoft WebTextEditor Documentation
IsBetaRelease Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : IsBetaRelease Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsBetaRelease() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Boolean

value = instance.IsBetaRelease()
C#
public System.bool IsBetaRelease()
Delphi
public function IsBetaRelease(): System.Boolean;
JScript
public function IsBetaRelease() : System.boolean;
Managed Extensions for C++
public: System.bool IsBetaRelease();
C++/CLI
public:
System.bool IsBetaRelease();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


IsChromeBrowser Method

[image]
Intersoft WebTextEditor Documentation
IsChromeBrowser Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : IsChromeBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsChromeBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Boolean

value = instance.IsChromeBrowser()
C#
public System.bool IsChromeBrowser()
Delphi
public function IsChromeBrowser(): System.Boolean;
JScript
public function IsChromeBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsChromeBrowser();
C++/CLI
public:
System.bool IsChromeBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


IsControlThemed Property

[image]
Intersoft WebTextEditor Documentation
IsControlThemed Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : IsControlThemed Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public ReadOnly Property IsControlThemed As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Boolean

value = instance.IsControlThemed
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public System.bool IsControlThemed {get;}
Delphi
public read-only property IsControlThemed: System.Boolean;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get IsControlThemed : System.boolean
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property System.bool get_IsControlThemed();
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property System.bool IsControlThemed {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


IsDesign Property

[image]
Intersoft WebTextEditor Documentation
IsDesign Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : IsDesign Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Overridable ReadOnly Property IsDesign As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Boolean

value = instance.IsDesign
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public virtual System.bool IsDesign {get;}
Delphi
public read-only property IsDesign: System.Boolean; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get IsDesign : System.boolean
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property virtual System.bool get_IsDesign();
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
virtual property System.bool IsDesign {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


IsDynamicCreated Property

[image]
Intersoft WebTextEditor Documentation
IsDynamicCreated Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : IsDynamicCreated Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
Public Property IsDynamicCreated As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Boolean

instance.IsDynamicCreated = value

value = instance.IsDynamicCreated
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public System.bool IsDynamicCreated {get; set;}
Delphi
public read-write property IsDynamicCreated: System.Boolean;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
public function get,set IsDynamicCreated : System.boolean
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public: __property System.bool get_IsDynamicCreated();
public: __property void set_IsDynamicCreated(
   System.bool value
);
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public:
property System.bool IsDynamicCreated {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


IsEmpty Method

[image]
Intersoft WebTextEditor Documentation
IsEmpty Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : IsEmpty Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsEmpty() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Boolean

value = instance.IsEmpty()
C#
public virtual System.bool IsEmpty()
Delphi
public function IsEmpty(): System.Boolean; virtual;
JScript
public function IsEmpty() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsEmpty();
C++/CLI
public:
virtual System.bool IsEmpty();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


IsFlyPostBackControl Method

[image]
Intersoft WebTextEditor Documentation
IsFlyPostBackControl Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : IsFlyPostBackControl Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsFlyPostBackControl() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Boolean

value = instance.IsFlyPostBackControl()
C#
public virtual System.bool IsFlyPostBackControl()
Delphi
public function IsFlyPostBackControl(): System.Boolean; virtual;
JScript
public function IsFlyPostBackControl() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsFlyPostBackControl();
C++/CLI
public:
virtual System.bool IsFlyPostBackControl();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


IsFlyPostBackRequest Method

[image]
Intersoft WebTextEditor Documentation
IsFlyPostBackRequest Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : IsFlyPostBackRequest Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function IsFlyPostBackRequest() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Boolean

value = instance.IsFlyPostBackRequest()
C#
public virtual System.bool IsFlyPostBackRequest()
Delphi
public function IsFlyPostBackRequest(): System.Boolean; virtual;
JScript
public function IsFlyPostBackRequest() : System.boolean;
Managed Extensions for C++
public: virtual System.bool IsFlyPostBackRequest();
C++/CLI
public:
virtual System.bool IsFlyPostBackRequest();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


IsGeckoBasedBrowser Method

[image]
Intersoft WebTextEditor Documentation
IsGeckoBasedBrowser Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : IsGeckoBasedBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsGeckoBasedBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Boolean

value = instance.IsGeckoBasedBrowser()
C#
public System.bool IsGeckoBasedBrowser()
Delphi
public function IsGeckoBasedBrowser(): System.Boolean;
JScript
public function IsGeckoBasedBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsGeckoBasedBrowser();
C++/CLI
public:
System.bool IsGeckoBasedBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


IsGeckoVersion18 Method

[image]
Intersoft WebTextEditor Documentation
IsGeckoVersion18 Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : IsGeckoVersion18 Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsGeckoVersion18() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Boolean

value = instance.IsGeckoVersion18()
C#
public System.bool IsGeckoVersion18()
Delphi
public function IsGeckoVersion18(): System.Boolean;
JScript
public function IsGeckoVersion18() : System.boolean;
Managed Extensions for C++
public: System.bool IsGeckoVersion18();
C++/CLI
public:
System.bool IsGeckoVersion18();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


IsInDesignMode Method

[image]
Intersoft WebTextEditor Documentation
IsInDesignMode Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : IsInDesignMode Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInDesignMode() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Boolean

value = instance.IsInDesignMode()
C#
public System.bool IsInDesignMode()
Delphi
public function IsInDesignMode(): System.Boolean;
JScript
public function IsInDesignMode() : System.boolean;
Managed Extensions for C++
public: System.bool IsInDesignMode();
C++/CLI
public:
System.bool IsInDesignMode();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


IsInternalCreated Property

[image]
Intersoft WebTextEditor Documentation
IsInternalCreated Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : IsInternalCreated Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
Public Property IsInternalCreated As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Boolean

instance.IsInternalCreated = value

value = instance.IsInternalCreated
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public System.bool IsInternalCreated {get; set;}
Delphi
public read-write property IsInternalCreated: System.Boolean;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
public function get,set IsInternalCreated : System.boolean
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public: __property System.bool get_IsInternalCreated();
public: __property void set_IsInternalCreated(
   System.bool value
);
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public:
property System.bool IsInternalCreated {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


IsInternetExplorer8Browser Method

[image]
Intersoft WebTextEditor Documentation
IsInternetExplorer8Browser Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : IsInternetExplorer8Browser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInternetExplorer8Browser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Boolean

value = instance.IsInternetExplorer8Browser()
C#
public System.bool IsInternetExplorer8Browser()
Delphi
public function IsInternetExplorer8Browser(): System.Boolean;
JScript
public function IsInternetExplorer8Browser() : System.boolean;
Managed Extensions for C++
public: System.bool IsInternetExplorer8Browser();
C++/CLI
public:
System.bool IsInternetExplorer8Browser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


IsInternetExplorerBrowser Method

[image]
Intersoft WebTextEditor Documentation
IsInternetExplorerBrowser Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : IsInternetExplorerBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsInternetExplorerBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Boolean

value = instance.IsInternetExplorerBrowser()
C#
public System.bool IsInternetExplorerBrowser()
Delphi
public function IsInternetExplorerBrowser(): System.Boolean;
JScript
public function IsInternetExplorerBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsInternetExplorerBrowser();
C++/CLI
public:
System.bool IsInternetExplorerBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


IsLiteralContent Method

[image]
Intersoft WebTextEditor Documentation
IsLiteralContent Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : IsLiteralContent Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function IsLiteralContent() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Boolean

value = instance.IsLiteralContent()
C#
protected System.bool IsLiteralContent()
Delphi
protected function IsLiteralContent(): System.Boolean;
JScript
protected function IsLiteralContent() : System.boolean;
Managed Extensions for C++
protected: System.bool IsLiteralContent();
C++/CLI
protected:
System.bool IsLiteralContent();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


IsMvc Property

[image]
Intersoft WebTextEditor Documentation
IsMvc Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : IsMvc Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property IsMvc As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Boolean

value = instance.IsMvc
C#
protected System.bool IsMvc {get;}
Delphi
protected read-only property IsMvc: System.Boolean;
JScript
protected function get IsMvc : System.boolean
Managed Extensions for C++
protected: __property System.bool get_IsMvc();
C++/CLI
protected:
property System.bool IsMvc {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


IsOperaBrowser Method

[image]
Intersoft WebTextEditor Documentation
IsOperaBrowser Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : IsOperaBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsOperaBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Boolean

value = instance.IsOperaBrowser()
C#
public System.bool IsOperaBrowser()
Delphi
public function IsOperaBrowser(): System.Boolean;
JScript
public function IsOperaBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsOperaBrowser();
C++/CLI
public:
System.bool IsOperaBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


isPagePreRender Field

[image]
Intersoft WebTextEditor Documentation
isPagePreRender Field
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : isPagePreRender Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected isPagePreRender As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Boolean

value = instance.isPagePreRender

instance.isPagePreRender = value
C#
protected System.bool isPagePreRender
Delphi
protected field isPagePreRender: System.Boolean;
JScript
protected var isPagePreRender : System.boolean;
Managed Extensions for C++
protected: System.bool isPagePreRender
C++/CLI
protected:
System.bool isPagePreRender

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


IsSafariBrowser Method

[image]
Intersoft WebTextEditor Documentation
IsSafariBrowser Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : IsSafariBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsSafariBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Boolean

value = instance.IsSafariBrowser()
C#
public System.bool IsSafariBrowser()
Delphi
public function IsSafariBrowser(): System.Boolean;
JScript
public function IsSafariBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsSafariBrowser();
C++/CLI
public:
System.bool IsSafariBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


IsSessionAvailable Method

[image]
Intersoft WebTextEditor Documentation
IsSessionAvailable Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : IsSessionAvailable Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Function IsSessionAvailable() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Boolean

value = instance.IsSessionAvailable()
C#
protected System.bool IsSessionAvailable()
Delphi
protected function IsSessionAvailable(): System.Boolean;
JScript
protected function IsSessionAvailable() : System.boolean;
Managed Extensions for C++
protected: System.bool IsSessionAvailable();
C++/CLI
protected:
System.bool IsSessionAvailable();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


IsTrackingViewState Property

[image]
Intersoft WebTextEditor Documentation
IsTrackingViewState Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : IsTrackingViewState Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property IsTrackingViewState As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Boolean

value = instance.IsTrackingViewState
C#
protected System.bool IsTrackingViewState {get;}
Delphi
protected read-only property IsTrackingViewState: System.Boolean;
JScript
protected function get IsTrackingViewState : System.boolean
Managed Extensions for C++
protected: __property System.bool get_IsTrackingViewState();
C++/CLI
protected:
property System.bool IsTrackingViewState {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


IsUnloaded Property

[image]
Intersoft WebTextEditor Documentation
IsUnloaded Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : IsUnloaded Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property IsUnloaded As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Boolean

instance.IsUnloaded = value

value = instance.IsUnloaded
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public System.bool IsUnloaded {get; set;}
Delphi
public read-write property IsUnloaded: System.Boolean;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get,set IsUnloaded : System.boolean
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property System.bool get_IsUnloaded();
public: __property void set_IsUnloaded(
   System.bool value
);
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property System.bool IsUnloaded {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


IsW3CStandardBrowser Method

[image]
Intersoft WebTextEditor Documentation
IsW3CStandardBrowser Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : IsW3CStandardBrowser Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function IsW3CStandardBrowser() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Boolean

value = instance.IsW3CStandardBrowser()
C#
public System.bool IsW3CStandardBrowser()
Delphi
public function IsW3CStandardBrowser(): System.Boolean;
JScript
public function IsW3CStandardBrowser() : System.boolean;
Managed Extensions for C++
public: System.bool IsW3CStandardBrowser();
C++/CLI
public:
System.bool IsW3CStandardBrowser();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


Load Event

[image]
Intersoft WebTextEditor Documentation
Load Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : Load Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the page has been loaded.")>
Public Event Load As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim handler As System.EventHandler

AddHandler instance.Load, handler
C#
[WebSysDescriptionAttribute("Fires when the page has been loaded.")]
public event System.EventHandler Load
Delphi
public event Load: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the page has been loaded.")]
public: __event System.EventHandler* Load
C++/CLI
[WebSysDescriptionAttribute("Fires when the page has been loaded.")]
public:
event System.EventHandler^ Load

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


LoadControlState Method

[image]
Intersoft WebTextEditor Documentation
LoadControlState Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : LoadControlState Method

savedState

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub LoadControlState( _
   ByVal savedState As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim savedState As System.Object

instance.LoadControlState(savedState)
C#
protected virtual void LoadControlState(
   System.object savedState
)
Delphi
protected procedure LoadControlState(
    savedState: System.TObject
); virtual;
JScript
protected function LoadControlState(
   savedState : System.Object
);
Managed Extensions for C++
protected: virtual void LoadControlState(
   System.Object* savedState
)
C++/CLI
protected:
virtual void LoadControlState(
   System.Object^ savedState
)

Parameters

savedState

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


LoadLayout Method

[image]
Intersoft WebTextEditor Documentation
LoadLayout Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : LoadLayout Method

settings

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayout( _
   ByVal settings As ISNet.WebUI.LayoutInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim settings As ISNet.WebUI.LayoutInfo

instance.LoadLayout(settings)
C#
public virtual void LoadLayout(
   ISNet.WebUI.LayoutInfo settings
)
Delphi
public procedure LoadLayout(
    settings: ISNet.WebUI.LayoutInfo
); virtual;
JScript
public function LoadLayout(
   settings : ISNet.WebUI.LayoutInfo
);
Managed Extensions for C++
public: virtual void LoadLayout(
   ISNet.WebUI.LayoutInfo* settings
)
C++/CLI
public:
virtual void LoadLayout(
   ISNet.WebUI.LayoutInfo^ settings
)

Parameters

settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


LoadLayoutFromFile Method

[image]
Intersoft WebTextEditor Documentation
LoadLayoutFromFile Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : LoadLayoutFromFile Method

filePath

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromFile( _
   ByVal filePath As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim filePath As System.String

instance.LoadLayoutFromFile(filePath)
C#
public virtual void LoadLayoutFromFile(
   System.string filePath
)
Delphi
public procedure LoadLayoutFromFile(
    filePath: System.String
); virtual;
JScript
public function LoadLayoutFromFile(
   filePath : System.String
);
Managed Extensions for C++
public: virtual void LoadLayoutFromFile(
   System.string* filePath
)
C++/CLI
public:
virtual void LoadLayoutFromFile(
   System.String^ filePath
)

Parameters

filePath

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


LoadLayoutFromPredefinedName Method

[image]
Intersoft WebTextEditor Documentation
LoadLayoutFromPredefinedName Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : LoadLayoutFromPredefinedName Method

predefinedName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromPredefinedName( _
   ByVal predefinedName As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim predefinedName As System.String

instance.LoadLayoutFromPredefinedName(predefinedName)
C#
public virtual void LoadLayoutFromPredefinedName(
   System.string predefinedName
)
Delphi
public procedure LoadLayoutFromPredefinedName(
    predefinedName: System.String
); virtual;
JScript
public function LoadLayoutFromPredefinedName(
   predefinedName : System.String
);
Managed Extensions for C++
public: virtual void LoadLayoutFromPredefinedName(
   System.string* predefinedName
)
C++/CLI
public:
virtual void LoadLayoutFromPredefinedName(
   System.String^ predefinedName
)

Parameters

predefinedName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


LoadLayoutFromStream Method

[image]
Intersoft WebTextEditor Documentation
LoadLayoutFromStream Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : LoadLayoutFromStream Method

stream

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub LoadLayoutFromStream( _
   ByVal stream As System.IO.Stream _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim stream As System.IO.Stream

instance.LoadLayoutFromStream(stream)
C#
public virtual void LoadLayoutFromStream(
   System.IO.Stream stream
)
Delphi
public procedure LoadLayoutFromStream(
    stream: System.IO.Stream
); virtual;
JScript
public function LoadLayoutFromStream(
   stream : System.IO.Stream
);
Managed Extensions for C++
public: virtual void LoadLayoutFromStream(
   System.IO.Stream* stream
)
C++/CLI
public:
virtual void LoadLayoutFromStream(
   System.IO.Stream^ stream
)

Parameters

stream

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


LoadViewState Method

[image]
Intersoft WebTextEditor Documentation
LoadViewState Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : LoadViewState Method

savedState

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub LoadViewState( _
   ByVal savedState As System.Object _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim savedState As System.Object

instance.LoadViewState(savedState)
C#
protected virtual void LoadViewState(
   System.object savedState
)
Delphi
protected procedure LoadViewState(
    savedState: System.TObject
); virtual;
JScript
protected function LoadViewState(
   savedState : System.Object
);
Managed Extensions for C++
protected: virtual void LoadViewState(
   System.Object* savedState
)
C++/CLI
protected:
virtual void LoadViewState(
   System.Object^ savedState
)

Parameters

savedState

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


LoadViewStateByID Property

[image]
Intersoft WebTextEditor Documentation
LoadViewStateByID Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : LoadViewStateByID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected ReadOnly Property LoadViewStateByID As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Boolean

value = instance.LoadViewStateByID
C#
protected System.bool LoadViewStateByID {get;}
Delphi
protected read-only property LoadViewStateByID: System.Boolean;
JScript
protected function get LoadViewStateByID : System.boolean
Managed Extensions for C++
protected: __property System.bool get_LoadViewStateByID();
C++/CLI
protected:
property System.bool LoadViewStateByID {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


MaxJsonLength Property

[image]
Intersoft WebTextEditor Documentation
MaxJsonLength Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : MaxJsonLength Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the maximum length allowed for JSON Serializer.")>
<System.ComponentModel.DefaultValueAttribute()>
Protected Overridable Property MaxJsonLength As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Integer

instance.MaxJsonLength = value

value = instance.MaxJsonLength
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the maximum length allowed for JSON Serializer.")]
[System.ComponentModel.DefaultValueAttribute()]
protected virtual System.int MaxJsonLength {get; set;}
Delphi
protected read-write property MaxJsonLength: System.Integer; virtual;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the maximum length allowed for JSON Serializer.")
System.ComponentModel.DefaultValueAttribute()
protected function get,set MaxJsonLength : System.int
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the maximum length allowed for JSON Serializer.")]
[System.ComponentModel.DefaultValueAttribute()]
protected: __property virtual System.int get_MaxJsonLength();
protected: __property virtual void set_MaxJsonLength(
   System.int value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the maximum length allowed for JSON Serializer.")]
[System.ComponentModel.DefaultValueAttribute()]
protected:
virtual property System.int MaxJsonLength {
   System.int get();
   void set (    System.int value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


MergeStyle Method

[image]
Intersoft WebTextEditor Documentation
MergeStyle Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : MergeStyle Method

s

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub MergeStyle( _
   ByVal s As System.Web.UI.WebControls.Style _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim s As System.Web.UI.WebControls.Style

instance.MergeStyle(s)
C#
public void MergeStyle(
   System.Web.UI.WebControls.Style s
)
Delphi
public procedure MergeStyle(
    s: System.Web.UI.WebControls.Style
);
JScript
public function MergeStyle(
   s : System.Web.UI.WebControls.Style
);
Managed Extensions for C++
public: void MergeStyle(
   System.Web.UI.WebControls.Style* s
)
C++/CLI
public:
void MergeStyle(
   System.Web.UI.WebControls.Style^ s
)

Parameters

s

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


NamingContainer Property

[image]
Intersoft WebTextEditor Documentation
NamingContainer Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : NamingContainer Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BindableAttribute(Bindable=False, Direction=BindingDirection.OneWay)>
<WebSysDescriptionAttribute("The containing control or page within which ID is unique.")>
Public Overridable ReadOnly Property NamingContainer As System.Web.UI.Control
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Web.UI.Control

value = instance.NamingContainer
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BindableAttribute(Bindable=false, Direction=BindingDirection.OneWay)]
[WebSysDescriptionAttribute("The containing control or page within which ID is unique.")]
public virtual System.Web.UI.Control NamingContainer {get;}
Delphi
public read-only property NamingContainer: System.Web.UI.Control; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
WebSysDescriptionAttribute("The containing control or page within which ID is unique.")
public function get NamingContainer : System.Web.UI.Control
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BindableAttribute(Bindable=false, Direction=BindingDirection.OneWay)]
[WebSysDescriptionAttribute("The containing control or page within which ID is unique.")]
public: __property virtual System.Web.UI.Control* get_NamingContainer();
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BindableAttribute(Bindable=false, Direction=BindingDirection.OneWay)]
[WebSysDescriptionAttribute("The containing control or page within which ID is unique.")]
public:
virtual property System.Web.UI.Control^ NamingContainer {
   System.Web.UI.Control^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


OnBubbleEvent Method

[image]
Intersoft WebTextEditor Documentation
OnBubbleEvent Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : OnBubbleEvent Method

source
args

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function OnBubbleEvent( _
   ByVal source As System.Object, _
   ByVal args As System.EventArgs _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim source As System.Object
Dim args As System.EventArgs
Dim value As System.Boolean

value = instance.OnBubbleEvent(source, args)
C#
protected virtual System.bool OnBubbleEvent(
   System.object source,
   System.EventArgs args
)
Delphi
protected function OnBubbleEvent(
    source: System.TObject;
    args: System.EventArgs
): System.Boolean; virtual;
JScript
protected function OnBubbleEvent(
   source : System.Object,
   args : System.EventArgs
) : System.boolean;
Managed Extensions for C++
protected: virtual System.bool OnBubbleEvent(
   System.Object* source,
   System.EventArgs* args
)
C++/CLI
protected:
virtual System.bool OnBubbleEvent(
   System.Object^ source,
   System.EventArgs^ args
)

Parameters

source
args

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


OnDataBinding Method

[image]
Intersoft WebTextEditor Documentation
OnDataBinding Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : OnDataBinding Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnDataBinding( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim e As System.EventArgs

instance.OnDataBinding(e)
C#
protected virtual void OnDataBinding(
   System.EventArgs e
)
Delphi
protected procedure OnDataBinding(
    e: System.EventArgs
); virtual;
JScript
protected function OnDataBinding(
   e : System.EventArgs
);
Managed Extensions for C++
protected: virtual void OnDataBinding(
   System.EventArgs* e
)
C++/CLI
protected:
virtual void OnDataBinding(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


OnInfoChanged Method

[image]
Intersoft WebTextEditor Documentation
OnInfoChanged Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : OnInfoChanged Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub OnInfoChanged( _
   ByVal e As ISNet.WebUI.SynchronizeEventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim e As ISNet.WebUI.SynchronizeEventArgs

instance.OnInfoChanged(e)
C#
public void OnInfoChanged(
   ISNet.WebUI.SynchronizeEventArgs e
)
Delphi
public procedure OnInfoChanged(
    e: ISNet.WebUI.SynchronizeEventArgs
);
JScript
public function OnInfoChanged(
   e : ISNet.WebUI.SynchronizeEventArgs
);
Managed Extensions for C++
public: void OnInfoChanged(
   ISNet.WebUI.SynchronizeEventArgs* e
)
C++/CLI
public:
void OnInfoChanged(
   ISNet.WebUI.SynchronizeEventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


OnInit Method

[image]
Intersoft WebTextEditor Documentation
OnInit Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : OnInit Method

e

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub OnInit( _
   ByVal e As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim e As System.EventArgs

instance.OnInit(e)
C#
protected virtual void OnInit(
   System.EventArgs e
)
Delphi
protected procedure OnInit(
    e: System.EventArgs
); virtual;
JScript
protected function OnInit(
   e : System.EventArgs
);
Managed Extensions for C++
protected: virtual void OnInit(
   System.EventArgs* e
)
C++/CLI
protected:
virtual void OnInit(
   System.EventArgs^ e
)

Parameters

e

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


OnPreInitialize Method

[image]
Intersoft WebTextEditor Documentation
OnPreInitialize Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : OnPreInitialize Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub OnPreInitialize()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor

instance.OnPreInitialize()
C#
public virtual void OnPreInitialize()
Delphi
public procedure OnPreInitialize(); virtual;
JScript
public function OnPreInitialize();
Managed Extensions for C++
public: virtual void OnPreInitialize();
C++/CLI
public:
virtual void OnPreInitialize();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


Page Property

[image]
Intersoft WebTextEditor Documentation
Page Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : Page Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Property Page As System.Web.UI.Page
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Web.UI.Page

instance.Page = value

value = instance.Page
C#
public virtual System.Web.UI.Page Page {get; set;}
Delphi
public read-write property Page: System.Web.UI.Page; virtual;
JScript
public function get,set Page : System.Web.UI.Page
Managed Extensions for C++
public: __property virtual System.Web.UI.Page* get_Page();
public: __property virtual void set_Page(
   System.Web.UI.Page* value
);
C++/CLI
public:
virtual property System.Web.UI.Page^ Page {
   System.Web.UI.Page^ get();
   void set (    System.Web.UI.Page^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


Parent Property

[image]
Intersoft WebTextEditor Documentation
Parent Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : Parent Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<WebSysDescriptionAttribute("The control containing this control.")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BindableAttribute(Bindable=False, Direction=BindingDirection.OneWay)>
Public Overridable ReadOnly Property Parent As System.Web.UI.Control
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Web.UI.Control

value = instance.Parent
C#
[System.ComponentModel.BrowsableAttribute(false)]
[WebSysDescriptionAttribute("The control containing this control.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BindableAttribute(Bindable=false, Direction=BindingDirection.OneWay)]
public virtual System.Web.UI.Control Parent {get;}
Delphi
public read-only property Parent: System.Web.UI.Control; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
WebSysDescriptionAttribute("The control containing this control.")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get Parent : System.Web.UI.Control
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[WebSysDescriptionAttribute("The control containing this control.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BindableAttribute(Bindable=false, Direction=BindingDirection.OneWay)]
public: __property virtual System.Web.UI.Control* get_Parent();
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[WebSysDescriptionAttribute("The control containing this control.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BindableAttribute(Bindable=false, Direction=BindingDirection.OneWay)]
public:
virtual property System.Web.UI.Control^ Parent {
   System.Web.UI.Control^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


ParentStyleId Property

[image]
Intersoft WebTextEditor Documentation
ParentStyleId Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : ParentStyleId Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
Public ReadOnly Property ParentStyleId As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.String

value = instance.ParentStyleId
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public System.string ParentStyleId {get;}
Delphi
public read-only property ParentStyleId: System.String;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
public function get ParentStyleId : System.String
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public: __property System.string* get_ParentStyleId();
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public:
property System.String^ ParentStyleId {
   System.String^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


PreInitialize Event

[image]
Intersoft WebTextEditor Documentation
PreInitialize Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : PreInitialize Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Event PreInitialize As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim handler As System.EventHandler

AddHandler instance.PreInitialize, handler
C#
public event System.EventHandler PreInitialize
Delphi
public event PreInitialize: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
public: __event System.EventHandler* PreInitialize
C++/CLI
public:
event System.EventHandler^ PreInitialize

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


PreRender Event

[image]
Intersoft WebTextEditor Documentation
PreRender Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : PreRender Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires before the page is rendered.")>
Public Event PreRender As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim handler As System.EventHandler

AddHandler instance.PreRender, handler
C#
[WebSysDescriptionAttribute("Fires before the page is rendered.")]
public event System.EventHandler PreRender
Delphi
public event PreRender: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires before the page is rendered.")]
public: __event System.EventHandler* PreRender
C++/CLI
[WebSysDescriptionAttribute("Fires before the page is rendered.")]
public:
event System.EventHandler^ PreRender

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


RaiseBubbleEvent Method

[image]
Intersoft WebTextEditor Documentation
RaiseBubbleEvent Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : RaiseBubbleEvent Method

source
args

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Sub RaiseBubbleEvent( _
   ByVal source As System.Object, _
   ByVal args As System.EventArgs _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim source As System.Object
Dim args As System.EventArgs

instance.RaiseBubbleEvent(source, args)
C#
protected void RaiseBubbleEvent(
   System.object source,
   System.EventArgs args
)
Delphi
protected procedure RaiseBubbleEvent(
    source: System.TObject;
    args: System.EventArgs
);
JScript
protected function RaiseBubbleEvent(
   source : System.Object,
   args : System.EventArgs
);
Managed Extensions for C++
protected: void RaiseBubbleEvent(
   System.Object* source,
   System.EventArgs* args
)
C++/CLI
protected:
void RaiseBubbleEvent(
   System.Object^ source,
   System.EventArgs^ args
)

Parameters

source
args

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


RaisePostDataChangedEvent Method

[image]
Intersoft WebTextEditor Documentation
RaisePostDataChangedEvent Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : RaisePostDataChangedEvent Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RaisePostDataChangedEvent()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor

instance.RaisePostDataChangedEvent()
C#
public virtual void RaisePostDataChangedEvent()
Delphi
public procedure RaisePostDataChangedEvent(); virtual;
JScript
public function RaisePostDataChangedEvent();
Managed Extensions for C++
public: virtual void RaisePostDataChangedEvent();
C++/CLI
public:
virtual void RaisePostDataChangedEvent();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


ReadWebConfigValue Method

[image]
Intersoft WebTextEditor Documentation
ReadWebConfigValue Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : ReadWebConfigValue Method

key

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ReadWebConfigValue( _
   ByVal key As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim key As System.String
Dim value As System.String

value = instance.ReadWebConfigValue(key)
C#
public System.string ReadWebConfigValue(
   System.string key
)
Delphi
public function ReadWebConfigValue(
    key: System.String
): System.String;
JScript
public function ReadWebConfigValue(
   key : System.String
) : System.String;
Managed Extensions for C++
public: System.string* ReadWebConfigValue(
   System.string* key
)
C++/CLI
public:
System.String^ ReadWebConfigValue(
   System.String^ key
)

Parameters

key

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


RegisterBoxSizing Method

[image]
Intersoft WebTextEditor Documentation
RegisterBoxSizing Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : RegisterBoxSizing Method

Glossary Item Box

Overload List

Overload | Description
RegisterBoxSizing() | (Inherited from ISNet.WebUI.ISNetControl)
RegisterBoxSizing(Boolean) | (Inherited from ISNet.WebUI.ISNetControl)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


RegisterBoxSizing() Method

[image]
Intersoft WebTextEditor Documentation
RegisterBoxSizing() Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class > RegisterBoxSizing Method : RegisterBoxSizing() Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub RegisterBoxSizing()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor

instance.RegisterBoxSizing()
C#
public void RegisterBoxSizing()
Delphi
public procedure RegisterBoxSizing();
JScript
public function RegisterBoxSizing();
Managed Extensions for C++
public: void RegisterBoxSizing();
C++/CLI
public:
void RegisterBoxSizing();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members
Overload List


RegisterBoxSizing(Boolean) Method

[image]
Intersoft WebTextEditor Documentation
RegisterBoxSizing(Boolean) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class > RegisterBoxSizing Method : RegisterBoxSizing(Boolean) Method

forceAll

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overloads Sub RegisterBoxSizing( _
   ByVal forceAll As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim forceAll As System.Boolean

instance.RegisterBoxSizing(forceAll)
C#
public void RegisterBoxSizing(
   System.bool forceAll
)
Delphi
public procedure RegisterBoxSizing(
    forceAll: System.Boolean
);
JScript
public function RegisterBoxSizing(
   forceAll : System.boolean
);
Managed Extensions for C++
public: void RegisterBoxSizing(
   System.bool forceAll
)
C++/CLI
public:
void RegisterBoxSizing(
   System.bool forceAll
)

Parameters

forceAll

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members
Overload List


RegisterGlobalStyle Method

[image]
Intersoft WebTextEditor Documentation
RegisterGlobalStyle Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : RegisterGlobalStyle Method

style

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterGlobalStyle( _
   ByVal style As ISNet.WebUI.WebStyle _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim style As ISNet.WebUI.WebStyle

instance.RegisterGlobalStyle(style)
C#
public void RegisterGlobalStyle(
   ISNet.WebUI.WebStyle style
)
Delphi
public procedure RegisterGlobalStyle(
    style: ISNet.WebUI.WebStyle
);
JScript
public function RegisterGlobalStyle(
   style : ISNet.WebUI.WebStyle
);
Managed Extensions for C++
public: void RegisterGlobalStyle(
   ISNet.WebUI.WebStyle* style
)
C++/CLI
public:
void RegisterGlobalStyle(
   ISNet.WebUI.WebStyle^ style
)

Parameters

style

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


RegisterLink Method

[image]
Intersoft WebTextEditor Documentation
RegisterLink Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : RegisterLink Method

name
url

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterLink( _
   ByVal name As System.String, _
   ByVal url As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim name As System.String
Dim url As System.String

instance.RegisterLink(name, url)
C#
public void RegisterLink(
   System.string name,
   System.string url
)
Delphi
public procedure RegisterLink(
    name: System.String;
    url: System.String
);
JScript
public function RegisterLink(
   name : System.String,
   url : System.String
);
Managed Extensions for C++
public: void RegisterLink(
   System.string* name,
   System.string* url
)
C++/CLI
public:
void RegisterLink(
   System.String^ name,
   System.String^ url
)

Parameters

name
url

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


RegisterOptimizedCssClasses Method

[image]
Intersoft WebTextEditor Documentation
RegisterOptimizedCssClasses Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : RegisterOptimizedCssClasses Method

runtimeStyleOnly

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterOptimizedCssClasses( _
   ByVal runtimeStyleOnly As System.Boolean _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim runtimeStyleOnly As System.Boolean

instance.RegisterOptimizedCssClasses(runtimeStyleOnly)
C#
public void RegisterOptimizedCssClasses(
   System.bool runtimeStyleOnly
)
Delphi
public procedure RegisterOptimizedCssClasses(
    runtimeStyleOnly: System.Boolean
);
JScript
public function RegisterOptimizedCssClasses(
   runtimeStyleOnly : System.boolean
);
Managed Extensions for C++
public: void RegisterOptimizedCssClasses(
   System.bool runtimeStyleOnly
)
C++/CLI
public:
void RegisterOptimizedCssClasses(
   System.bool runtimeStyleOnly
)

Parameters

runtimeStyleOnly

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


RegisterPreloadImage Method

[image]
Intersoft WebTextEditor Documentation
RegisterPreloadImage Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : RegisterPreloadImage Method

image

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub RegisterPreloadImage( _
   ByVal image As System.String _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim image As System.String

instance.RegisterPreloadImage(image)
C#
public void RegisterPreloadImage(
   System.string image
)
Delphi
public procedure RegisterPreloadImage(
    image: System.String
);
JScript
public function RegisterPreloadImage(
   image : System.String
);
Managed Extensions for C++
public: void RegisterPreloadImage(
   System.string* image
)
C++/CLI
public:
void RegisterPreloadImage(
   System.String^ image
)

Parameters

image

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


RegisterSharePointHandler Method

[image]
Intersoft WebTextEditor Documentation
RegisterSharePointHandler Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : RegisterSharePointHandler Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RegisterSharePointHandler()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor

instance.RegisterSharePointHandler()
C#
public virtual void RegisterSharePointHandler()
Delphi
public procedure RegisterSharePointHandler(); virtual;
JScript
public function RegisterSharePointHandler();
Managed Extensions for C++
public: virtual void RegisterSharePointHandler();
C++/CLI
public:
virtual void RegisterSharePointHandler();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


RenderBeginTag Method

[image]
Intersoft WebTextEditor Documentation
RenderBeginTag Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : RenderBeginTag Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub RenderBeginTag( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderBeginTag(writer)
C#
public virtual void RenderBeginTag(
   System.Web.UI.HtmlTextWriter writer
)
Delphi
public procedure RenderBeginTag(
    writer: System.Web.UI.HtmlTextWriter
); virtual;
JScript
public function RenderBeginTag(
   writer : System.Web.UI.HtmlTextWriter
);
Managed Extensions for C++
public: virtual void RenderBeginTag(
   System.Web.UI.HtmlTextWriter* writer
)
C++/CLI
public:
virtual void RenderBeginTag(
   System.Web.UI.HtmlTextWriter^ writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


RenderContents Method

[image]
Intersoft WebTextEditor Documentation
RenderContents Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : RenderContents Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub RenderContents( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderContents(writer)
C#
protected virtual void RenderContents(
   System.Web.UI.HtmlTextWriter writer
)
Delphi
protected procedure RenderContents(
    writer: System.Web.UI.HtmlTextWriter
); virtual;
JScript
protected function RenderContents(
   writer : System.Web.UI.HtmlTextWriter
);
Managed Extensions for C++
protected: virtual void RenderContents(
   System.Web.UI.HtmlTextWriter* writer
)
C++/CLI
protected:
virtual void RenderContents(
   System.Web.UI.HtmlTextWriter^ writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


RenderControl Method

[image]
Intersoft WebTextEditor Documentation
RenderControl Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : RenderControl Method

Glossary Item Box

Overload List

Overload | Description
RenderControl(HtmlTextWriter) | (Inherited from System.Web.UI.Control)
RenderControl(HtmlTextWriter,ControlAdapter) | (Inherited from System.Web.UI.Control)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


RenderControl(HtmlTextWriter) Method

[image]
Intersoft WebTextEditor Documentation
RenderControl(HtmlTextWriter) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class > RenderControl Method : RenderControl(HtmlTextWriter) Method

writer

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")>
Public Overloads Overridable Sub RenderControl( _
   ByVal writer As System.Web.UI.HtmlTextWriter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim writer As System.Web.UI.HtmlTextWriter

instance.RenderControl(writer)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public virtual void RenderControl(
   System.Web.UI.HtmlTextWriter writer
)
Delphi
public procedure RenderControl(
    writer: System.Web.UI.HtmlTextWriter
); virtual;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")
public function RenderControl(
   writer : System.Web.UI.HtmlTextWriter
);
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public: virtual void RenderControl(
   System.Web.UI.HtmlTextWriter* writer
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline across NGen image boundaries")]
public:
virtual void RenderControl(
   System.Web.UI.HtmlTextWriter^ writer
)

Parameters

writer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members
Overload List


RenderControl(HtmlTextWriter,ControlAdapter) Method

[image]
Intersoft WebTextEditor Documentation
RenderControl(HtmlTextWriter,ControlAdapter) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class > RenderControl Method : RenderControl(HtmlTextWriter,ControlAdapter) Method

writer
adapter

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overloads Sub RenderControl( _
   ByVal writer As System.Web.UI.HtmlTextWriter, _
   ByVal adapter As System.Web.UI.Adapters.ControlAdapter _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim writer As System.Web.UI.HtmlTextWriter
Dim adapter As System.Web.UI.Adapters.ControlAdapter

instance.RenderControl(writer, adapter)
C#
protected void RenderControl(
   System.Web.UI.HtmlTextWriter writer,
   System.Web.UI.Adapters.ControlAdapter adapter
)
Delphi
protected procedure RenderControl(
    writer: System.Web.UI.HtmlTextWriter;
    adapter: System.Web.UI.Adapters.ControlAdapter
);
JScript
protected function RenderControl(
   writer : System.Web.UI.HtmlTextWriter,
   adapter : System.Web.UI.Adapters.ControlAdapter
);
Managed Extensions for C++
protected: void RenderControl(
   System.Web.UI.HtmlTextWriter* writer,
   System.Web.UI.Adapters.ControlAdapter* adapter
)
C++/CLI
protected:
void RenderControl(
   System.Web.UI.HtmlTextWriter^ writer,
   System.Web.UI.Adapters.ControlAdapter^ adapter
)

Parameters

writer
adapter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members
Overload List


renderDHTML Field

[image]
Intersoft WebTextEditor Documentation
renderDHTML Field
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : renderDHTML Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected renderDHTML As ISNet.WebUI.RenderDHTML
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As ISNet.WebUI.RenderDHTML

value = instance.renderDHTML

instance.renderDHTML = value
C#
protected ISNet.WebUI.RenderDHTML renderDHTML
Delphi
protected field renderDHTML: ISNet.WebUI.RenderDHTML;
JScript
protected var renderDHTML : ISNet.WebUI.RenderDHTML;
Managed Extensions for C++
protected: ISNet.WebUI.RenderDHTML* renderDHTML
C++/CLI
protected:
ISNet.WebUI.RenderDHTML^ renderDHTML

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


RenderingCompatibility Property

[image]
Intersoft WebTextEditor Documentation
RenderingCompatibility Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : RenderingCompatibility Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.BindableAttribute(Bindable=False, Direction=BindingDirection.OneWay)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Overridable Property RenderingCompatibility As System.Version
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Version

instance.RenderingCompatibility = value

value = instance.RenderingCompatibility
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.BindableAttribute(Bindable=false, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public virtual System.Version RenderingCompatibility {get; set;}
Delphi
public read-write property RenderingCompatibility: System.Version; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get,set RenderingCompatibility : System.Version
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.BindableAttribute(Bindable=false, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property virtual System.Version* get_RenderingCompatibility();
public: __property virtual void set_RenderingCompatibility(
   System.Version* value
);
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.BindableAttribute(Bindable=false, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
virtual property System.Version^ RenderingCompatibility {
   System.Version^ get();
   void set (    System.Version^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


RenderingMode Property

[image]
Intersoft WebTextEditor Documentation
RenderingMode Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : RenderingMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets a value that specifies the HTML rendering behavior applied in this control.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Overridable Property RenderingMode As ISNet.WebUI.RenderMode
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As ISNet.WebUI.RenderMode

instance.RenderingMode = value

value = instance.RenderingMode
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that specifies the HTML rendering behavior applied in this control.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public virtual ISNet.WebUI.RenderMode RenderingMode {get; set;}
Delphi
public read-write property RenderingMode: ISNet.WebUI.RenderMode; virtual;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets a value that specifies the HTML rendering behavior applied in this control.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set RenderingMode : ISNet.WebUI.RenderMode
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that specifies the HTML rendering behavior applied in this control.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property virtual ISNet.WebUI.RenderMode get_RenderingMode();
public: __property virtual void set_RenderingMode(
   ISNet.WebUI.RenderMode value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets a value that specifies the HTML rendering behavior applied in this control.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
virtual property ISNet.WebUI.RenderMode RenderingMode {
   ISNet.WebUI.RenderMode get();
   void set (    ISNet.WebUI.RenderMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


renderNS Field

[image]
Intersoft WebTextEditor Documentation
renderNS Field
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : renderNS Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected renderNS As ISNet.WebUI.RenderNS
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As ISNet.WebUI.RenderNS

value = instance.renderNS

instance.renderNS = value
C#
protected ISNet.WebUI.RenderNS renderNS
Delphi
protected field renderNS: ISNet.WebUI.RenderNS;
JScript
protected var renderNS : ISNet.WebUI.RenderNS;
Managed Extensions for C++
protected: ISNet.WebUI.RenderNS* renderNS
C++/CLI
protected:
ISNet.WebUI.RenderNS^ renderNS

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


RequiresUIRefresh Property

[image]
Intersoft WebTextEditor Documentation
RequiresUIRefresh Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : RequiresUIRefresh Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property RequiresUIRefresh As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Boolean

instance.RequiresUIRefresh = value

value = instance.RequiresUIRefresh
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public System.bool RequiresUIRefresh {get; set;}
Delphi
public read-write property RequiresUIRefresh: System.Boolean;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get,set RequiresUIRefresh : System.boolean
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property System.bool get_RequiresUIRefresh();
public: __property void set_RequiresUIRefresh(
   System.bool value
);
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property System.bool RequiresUIRefresh {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


Reset Method

[image]
Intersoft WebTextEditor Documentation
Reset Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : Reset Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub Reset()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor

instance.Reset()
C#
public virtual void Reset()
Delphi
public procedure Reset(); virtual;
JScript
public function Reset();
Managed Extensions for C++
public: virtual void Reset();
C++/CLI
public:
virtual void Reset();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


ResetFilteredStyle Method

[image]
Intersoft WebTextEditor Documentation
ResetFilteredStyle Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : ResetFilteredStyle Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub ResetFilteredStyle()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor

instance.ResetFilteredStyle()
C#
protected virtual void ResetFilteredStyle()
Delphi
protected procedure ResetFilteredStyle(); virtual;
JScript
protected function ResetFilteredStyle();
Managed Extensions for C++
protected: virtual void ResetFilteredStyle();
C++/CLI
protected:
virtual void ResetFilteredStyle();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


ResolveAdapter Method

[image]
Intersoft WebTextEditor Documentation
ResolveAdapter Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : ResolveAdapter Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function ResolveAdapter() As System.Web.UI.Adapters.ControlAdapter
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Web.UI.Adapters.ControlAdapter

value = instance.ResolveAdapter()
C#
protected virtual System.Web.UI.Adapters.ControlAdapter ResolveAdapter()
Delphi
protected function ResolveAdapter(): System.Web.UI.Adapters.ControlAdapter; virtual;
JScript
protected function ResolveAdapter() : System.Web.UI.Adapters.ControlAdapter;
Managed Extensions for C++
protected: virtual System.Web.UI.Adapters.ControlAdapter* ResolveAdapter();
C++/CLI
protected:
virtual System.Web.UI.Adapters.ControlAdapter^ ResolveAdapter();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


ResolveClientUrl Method

[image]
Intersoft WebTextEditor Documentation
ResolveClientUrl Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : ResolveClientUrl Method

relativeUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveClientUrl( _
   ByVal relativeUrl As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim relativeUrl As System.String
Dim value As System.String

value = instance.ResolveClientUrl(relativeUrl)
C#
public System.string ResolveClientUrl(
   System.string relativeUrl
)
Delphi
public function ResolveClientUrl(
    relativeUrl: System.String
): System.String;
JScript
public function ResolveClientUrl(
   relativeUrl : System.String
) : System.String;
Managed Extensions for C++
public: System.string* ResolveClientUrl(
   System.string* relativeUrl
)
C++/CLI
public:
System.String^ ResolveClientUrl(
   System.String^ relativeUrl
)

Parameters

relativeUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


ResolveImagePath Method

[image]
Intersoft WebTextEditor Documentation
ResolveImagePath Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : ResolveImagePath Method

folder
image

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveImagePath( _
   ByVal folder As System.String, _
   ByVal image As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim folder As System.String
Dim image As System.String
Dim value As System.String

value = instance.ResolveImagePath(folder, image)
C#
public System.string ResolveImagePath(
   System.string folder,
   System.string image
)
Delphi
public function ResolveImagePath(
    folder: System.String;
    image: System.String
): System.String;
JScript
public function ResolveImagePath(
   folder : System.String,
   image : System.String
) : System.String;
Managed Extensions for C++
public: System.string* ResolveImagePath(
   System.string* folder,
   System.string* image
)
C++/CLI
public:
System.String^ ResolveImagePath(
   System.String^ folder,
   System.String^ image
)

Parameters

folder
image

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


ResolveRelativeURL Method

[image]
Intersoft WebTextEditor Documentation
ResolveRelativeURL Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : ResolveRelativeURL Method

url

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ResolveRelativeURL( _
   ByVal url As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim url As System.String
Dim value As System.String

value = instance.ResolveRelativeURL(url)
C#
public virtual System.string ResolveRelativeURL(
   System.string url
)
Delphi
public function ResolveRelativeURL(
    url: System.String
): System.String; virtual;
JScript
public function ResolveRelativeURL(
   url : System.String
) : System.String;
Managed Extensions for C++
public: virtual System.string* ResolveRelativeURL(
   System.string* url
)
C++/CLI
public:
virtual System.String^ ResolveRelativeURL(
   System.String^ url
)

Parameters

url

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


ResolveResourceUrl Method

[image]
Intersoft WebTextEditor Documentation
ResolveResourceUrl Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : ResolveResourceUrl Method

kind
defaultFolder
currentFolder
resourceName

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveResourceUrl( _
   ByVal kind As ISNet.WebUI.ResourceKind, _
   ByVal defaultFolder As System.String, _
   ByVal currentFolder As System.String, _
   ByVal resourceName As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim kind As ISNet.WebUI.ResourceKind
Dim defaultFolder As System.String
Dim currentFolder As System.String
Dim resourceName As System.String
Dim value As System.String

value = instance.ResolveResourceUrl(kind, defaultFolder, currentFolder, resourceName)
C#
public System.string ResolveResourceUrl(
   ISNet.WebUI.ResourceKind kind,
   System.string defaultFolder,
   System.string currentFolder,
   System.string resourceName
)
Delphi
public function ResolveResourceUrl(
    kind: ISNet.WebUI.ResourceKind;
    defaultFolder: System.String;
    currentFolder: System.String;
    resourceName: System.String
): System.String;
JScript
public function ResolveResourceUrl(
   kind : ISNet.WebUI.ResourceKind,
   defaultFolder : System.String,
   currentFolder : System.String,
   resourceName : System.String
) : System.String;
Managed Extensions for C++
public: System.string* ResolveResourceUrl(
   ISNet.WebUI.ResourceKind kind,
   System.string* defaultFolder,
   System.string* currentFolder,
   System.string* resourceName
)
C++/CLI
public:
System.String^ ResolveResourceUrl(
   ISNet.WebUI.ResourceKind kind,
   System.String^ defaultFolder,
   System.String^ currentFolder,
   System.String^ resourceName
)

Parameters

kind
defaultFolder
currentFolder
resourceName

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


ResolveUrl Method

[image]
Intersoft WebTextEditor Documentation
ResolveUrl Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : ResolveUrl Method

relativeUrl

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Function ResolveUrl( _
   ByVal relativeUrl As System.String _
) As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim relativeUrl As System.String
Dim value As System.String

value = instance.ResolveUrl(relativeUrl)
C#
public System.string ResolveUrl(
   System.string relativeUrl
)
Delphi
public function ResolveUrl(
    relativeUrl: System.String
): System.String;
JScript
public function ResolveUrl(
   relativeUrl : System.String
) : System.String;
Managed Extensions for C++
public: System.string* ResolveUrl(
   System.string* relativeUrl
)
C++/CLI
public:
System.String^ ResolveUrl(
   System.String^ relativeUrl
)

Parameters

relativeUrl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


RuntimeLicenseKey Property

[image]
Intersoft WebTextEditor Documentation
RuntimeLicenseKey Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : RuntimeLicenseKey Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.PersistLayoutAttribute(False)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("The runtime license key for xcopy deployment. Registered customers please obtain the key through Intersoft Developer Network.")>
Public Overridable Property RuntimeLicenseKey As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.String

instance.RuntimeLicenseKey = value

value = instance.RuntimeLicenseKey
C#
[ISNet.PersistLayoutAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The runtime license key for xcopy deployment. Registered customers please obtain the key through Intersoft Developer Network.")]
public virtual System.string RuntimeLicenseKey {get; set;}
Delphi
public read-write property RuntimeLicenseKey: System.String; virtual;
JScript
ISNet.PersistLayoutAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("The runtime license key for xcopy deployment. Registered customers please obtain the key through Intersoft Developer Network.")
public function get,set RuntimeLicenseKey : System.String
Managed Extensions for C++
[ISNet.PersistLayoutAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The runtime license key for xcopy deployment. Registered customers please obtain the key through Intersoft Developer Network.")]
public: __property virtual System.string* get_RuntimeLicenseKey();
public: __property virtual void set_RuntimeLicenseKey(
   System.string* value
);
C++/CLI
[ISNet.PersistLayoutAttribute(false)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("The runtime license key for xcopy deployment. Registered customers please obtain the key through Intersoft Developer Network.")]
public:
virtual property System.String^ RuntimeLicenseKey {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


SaveControlState Method

[image]
Intersoft WebTextEditor Documentation
SaveControlState Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : SaveControlState Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function SaveControlState() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Object

value = instance.SaveControlState()
C#
protected virtual System.object SaveControlState()
Delphi
protected function SaveControlState(): System.TObject; virtual;
JScript
protected function SaveControlState() : System.Object;
Managed Extensions for C++
protected: virtual System.Object* SaveControlState();
C++/CLI
protected:
virtual System.Object^ SaveControlState();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


SaveLayout Method

[image]
Intersoft WebTextEditor Documentation
SaveLayout Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : SaveLayout Method

settings

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayout( _
   ByVal settings As ISNet.WebUI.LayoutInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim settings As ISNet.WebUI.LayoutInfo

instance.SaveLayout(settings)
C#
public virtual void SaveLayout(
   ISNet.WebUI.LayoutInfo settings
)
Delphi
public procedure SaveLayout(
    settings: ISNet.WebUI.LayoutInfo
); virtual;
JScript
public function SaveLayout(
   settings : ISNet.WebUI.LayoutInfo
);
Managed Extensions for C++
public: virtual void SaveLayout(
   ISNet.WebUI.LayoutInfo* settings
)
C++/CLI
public:
virtual void SaveLayout(
   ISNet.WebUI.LayoutInfo^ settings
)

Parameters

settings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


SaveLayoutToFile Method

[image]
Intersoft WebTextEditor Documentation
SaveLayoutToFile Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : SaveLayoutToFile Method

filePath
saveOptions

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayoutToFile( _
   ByVal filePath As System.String, _
   ByVal saveOptions As ISNet.WebUI.SaveLayoutOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim filePath As System.String
Dim saveOptions As ISNet.WebUI.SaveLayoutOptions

instance.SaveLayoutToFile(filePath, saveOptions)
C#
public virtual void SaveLayoutToFile(
   System.string filePath,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)
Delphi
public procedure SaveLayoutToFile(
    filePath: System.String;
    saveOptions: ISNet.WebUI.SaveLayoutOptions
); virtual;
JScript
public function SaveLayoutToFile(
   filePath : System.String,
   saveOptions : ISNet.WebUI.SaveLayoutOptions
);
Managed Extensions for C++
public: virtual void SaveLayoutToFile(
   System.string* filePath,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)
C++/CLI
public:
virtual void SaveLayoutToFile(
   System.String^ filePath,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)

Parameters

filePath
saveOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


SaveLayoutToStream Method

[image]
Intersoft WebTextEditor Documentation
SaveLayoutToStream Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : SaveLayoutToStream Method

stream
saveOptions

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Sub SaveLayoutToStream( _
   ByVal stream As System.IO.Stream, _
   ByVal saveOptions As ISNet.WebUI.SaveLayoutOptions _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim stream As System.IO.Stream
Dim saveOptions As ISNet.WebUI.SaveLayoutOptions

instance.SaveLayoutToStream(stream, saveOptions)
C#
public virtual void SaveLayoutToStream(
   System.IO.Stream stream,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)
Delphi
public procedure SaveLayoutToStream(
    stream: System.IO.Stream;
    saveOptions: ISNet.WebUI.SaveLayoutOptions
); virtual;
JScript
public function SaveLayoutToStream(
   stream : System.IO.Stream,
   saveOptions : ISNet.WebUI.SaveLayoutOptions
);
Managed Extensions for C++
public: virtual void SaveLayoutToStream(
   System.IO.Stream* stream,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)
C++/CLI
public:
virtual void SaveLayoutToStream(
   System.IO.Stream^ stream,
   ISNet.WebUI.SaveLayoutOptions saveOptions
)

Parameters

stream
saveOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


SaveViewState Method

[image]
Intersoft WebTextEditor Documentation
SaveViewState Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : SaveViewState Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function SaveViewState() As System.Object
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Object

value = instance.SaveViewState()
C#
protected virtual System.object SaveViewState()
Delphi
protected function SaveViewState(): System.TObject; virtual;
JScript
protected function SaveViewState() : System.Object;
Managed Extensions for C++
protected: virtual System.Object* SaveViewState();
C++/CLI
protected:
virtual System.Object^ SaveViewState();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


SaveViewStateOnFlyPostback Property

[image]
Intersoft WebTextEditor Documentation
SaveViewStateOnFlyPostback Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : SaveViewStateOnFlyPostback Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property SaveViewStateOnFlyPostback As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Boolean

instance.SaveViewStateOnFlyPostback = value

value = instance.SaveViewStateOnFlyPostback
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public System.bool SaveViewStateOnFlyPostback {get; set;}
Delphi
public read-write property SaveViewStateOnFlyPostback: System.Boolean;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get,set SaveViewStateOnFlyPostback : System.boolean
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property System.bool get_SaveViewStateOnFlyPostback();
public: __property void set_SaveViewStateOnFlyPostback(
   System.bool value
);
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property System.bool SaveViewStateOnFlyPostback {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


SerializedJSFiles Property

[image]
Intersoft WebTextEditor Documentation
SerializedJSFiles Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : SerializedJSFiles Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public ReadOnly Property SerializedJSFiles As System.Collections.ArrayList
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Collections.ArrayList

value = instance.SerializedJSFiles
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public System.Collections.ArrayList SerializedJSFiles {get;}
Delphi
public read-only property SerializedJSFiles: System.Collections.ArrayList;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get SerializedJSFiles : System.Collections.ArrayList
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property System.Collections.ArrayList* get_SerializedJSFiles();
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
property System.Collections.ArrayList^ SerializedJSFiles {
   System.Collections.ArrayList^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


SerializedStyles Property

[image]
Intersoft WebTextEditor Documentation
SerializedStyles Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : SerializedStyles Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
Public ReadOnly Property SerializedStyles As System.Collections.Generic.Dictionary(Of String,Object)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Collections.Generic.Dictionary(Of String,Object)

value = instance.SerializedStyles
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public System.Collections.Generic.Dictionary<string,object> SerializedStyles {get;}
Delphi
public read-only property SerializedStyles: System.Collections.Generic.Dictionary;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
public function get SerializedStyles : System.Collections.Generic.Dictionary
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public: __property System.Collections.Generic.Dictionary<string*,Object*>* get_SerializedStyles();
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
public:
property System.Collections.Generic.Dictionary<String^,Object^>^ SerializedStyles {
   System.Collections.Generic.Dictionary<String^,Object^>^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


SerializeObjectData Method

[image]
Intersoft WebTextEditor Documentation
SerializeObjectData Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : SerializeObjectData Method

type
info
context

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SerializeObjectData( _
   ByVal type As System.Type, _
   ByVal info As System.Runtime.Serialization.SerializationInfo, _
   ByVal context As System.Runtime.Serialization.StreamingContext _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim type As System.Type
Dim info As System.Runtime.Serialization.SerializationInfo
Dim context As System.Runtime.Serialization.StreamingContext

instance.SerializeObjectData(type, info, context)
C#
public void SerializeObjectData(
   System.Type type,
   System.Runtime.Serialization.SerializationInfo info,
   System.Runtime.Serialization.StreamingContext context
)
Delphi
public procedure SerializeObjectData(
    type: System.Type;
    info: System.Runtime.Serialization.SerializationInfo;
    context: System.Runtime.Serialization.StreamingContext
);
JScript
public function SerializeObjectData(
   type : System.Type,
   info : System.Runtime.Serialization.SerializationInfo,
   context : System.Runtime.Serialization.StreamingContext
);
Managed Extensions for C++
public: void SerializeObjectData(
   System.Type* type,
   System.Runtime.Serialization.SerializationInfo* info,
   System.Runtime.Serialization.StreamingContext context
)
C++/CLI
public:
void SerializeObjectData(
   System.Type^ type,
   System.Runtime.Serialization.SerializationInfo^ info,
   System.Runtime.Serialization.StreamingContext context
)

Parameters

type
info
context

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


SetDesignModeState Method

[image]
Intersoft WebTextEditor Documentation
SetDesignModeState Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : SetDesignModeState Method

data

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub SetDesignModeState( _
   ByVal data As System.Collections.IDictionary _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim data As System.Collections.IDictionary

instance.SetDesignModeState(data)
C#
protected virtual void SetDesignModeState(
   System.Collections.IDictionary data
)
Delphi
protected procedure SetDesignModeState(
    data: System.Collections.IDictionary
); virtual;
JScript
protected function SetDesignModeState(
   data : System.Collections.IDictionary
);
Managed Extensions for C++
protected: virtual void SetDesignModeState(
   System.Collections.IDictionary* data
)
C++/CLI
protected:
virtual void SetDesignModeState(
   System.Collections.IDictionary^ data
)

Parameters

data

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


SetRenderMethodDelegate Method

[image]
Intersoft WebTextEditor Documentation
SetRenderMethodDelegate Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : SetRenderMethodDelegate Method

renderMethod

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Sub SetRenderMethodDelegate( _
   ByVal renderMethod As System.Web.UI.RenderMethod _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim renderMethod As System.Web.UI.RenderMethod

instance.SetRenderMethodDelegate(renderMethod)
C#
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod renderMethod
)
Delphi
public procedure SetRenderMethodDelegate(
    renderMethod: System.Web.UI.RenderMethod
);
JScript
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
public function SetRenderMethodDelegate(
   renderMethod : System.Web.UI.RenderMethod
);
Managed Extensions for C++
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public: void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod* renderMethod
)
C++/CLI
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public:
void SetRenderMethodDelegate(
   System.Web.UI.RenderMethod^ renderMethod
)

Parameters

renderMethod

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


SetSessionTheme Method

[image]
Intersoft WebTextEditor Documentation
SetSessionTheme Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : SetSessionTheme Method

themeInfo

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Sub SetSessionTheme( _
   ByVal themeInfo As ISNet.WebUI.ThemeInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim themeInfo As ISNet.WebUI.ThemeInfo

instance.SetSessionTheme(themeInfo)
C#
public void SetSessionTheme(
   ISNet.WebUI.ThemeInfo themeInfo
)
Delphi
public procedure SetSessionTheme(
    themeInfo: ISNet.WebUI.ThemeInfo
);
JScript
public function SetSessionTheme(
   themeInfo : ISNet.WebUI.ThemeInfo
);
Managed Extensions for C++
public: void SetSessionTheme(
   ISNet.WebUI.ThemeInfo* themeInfo
)
C++/CLI
public:
void SetSessionTheme(
   ISNet.WebUI.ThemeInfo^ themeInfo
)

Parameters

themeInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


SetTheme Method

[image]
Intersoft WebTextEditor Documentation
SetTheme Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : SetTheme Method

themeInfo

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub SetTheme( _
   ByVal themeInfo As ISNet.WebUI.ThemeInfo _
)
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim themeInfo As ISNet.WebUI.ThemeInfo

instance.SetTheme(themeInfo)
C#
protected virtual void SetTheme(
   ISNet.WebUI.ThemeInfo themeInfo
)
Delphi
protected procedure SetTheme(
    themeInfo: ISNet.WebUI.ThemeInfo
); virtual;
JScript
protected function SetTheme(
   themeInfo : ISNet.WebUI.ThemeInfo
);
Managed Extensions for C++
protected: virtual void SetTheme(
   ISNet.WebUI.ThemeInfo* themeInfo
)
C++/CLI
protected:
virtual void SetTheme(
   ISNet.WebUI.ThemeInfo^ themeInfo
)

Parameters

themeInfo

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


ShouldReturnJson Method

[image]
Intersoft WebTextEditor Documentation
ShouldReturnJson Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : ShouldReturnJson Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Public Overridable Function ShouldReturnJson() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Boolean

value = instance.ShouldReturnJson()
C#
public virtual System.bool ShouldReturnJson()
Delphi
public function ShouldReturnJson(): System.Boolean; virtual;
JScript
public function ShouldReturnJson() : System.boolean;
Managed Extensions for C++
public: virtual System.bool ShouldReturnJson();
C++/CLI
public:
virtual System.bool ShouldReturnJson();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


ShowAboutBox Method

[image]
Intersoft WebTextEditor Documentation
ShowAboutBox Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : ShowAboutBox Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Sub ShowAboutBox()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor

instance.ShowAboutBox()
C#
protected void ShowAboutBox()
Delphi
protected procedure ShowAboutBox();
JScript
protected function ShowAboutBox();
Managed Extensions for C++
protected: void ShowAboutBox();
C++/CLI
protected:
void ShowAboutBox();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


Site Property

[image]
Intersoft WebTextEditor Documentation
Site Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : Site Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<WebSysDescriptionAttribute("Site of the control.")>
<System.ComponentModel.BrowsableAttribute(False)>
Public Property Site As System.ComponentModel.ISite
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.ComponentModel.ISite

instance.Site = value

value = instance.Site
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[WebSysDescriptionAttribute("Site of the control.")]
[System.ComponentModel.BrowsableAttribute(false)]
public System.ComponentModel.ISite Site {get; set;}
Delphi
public read-write property Site: System.ComponentModel.ISite;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)
WebSysDescriptionAttribute("Site of the control.")
System.ComponentModel.BrowsableAttribute()
public function get,set Site : System.ComponentModel.ISite
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[WebSysDescriptionAttribute("Site of the control.")]
[System.ComponentModel.BrowsableAttribute(false)]
public: __property System.ComponentModel.ISite* get_Site();
public: __property void set_Site(
   System.ComponentModel.ISite* value
);
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[WebSysDescriptionAttribute("Site of the control.")]
[System.ComponentModel.BrowsableAttribute(false)]
public:
property System.ComponentModel.ISite^ Site {
   System.ComponentModel.ISite^ get();
   void set (    System.ComponentModel.ISite^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


SkinID Property

[image]
Intersoft WebTextEditor Documentation
SkinID Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : SkinID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(True)>
Public Overridable Property SkinID As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.String

instance.SkinID = value

value = instance.SkinID
C#
[System.ComponentModel.BrowsableAttribute(true)]
public virtual System.string SkinID {get; set;}
Delphi
public read-write property SkinID: System.String; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
public function get,set SkinID : System.String
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(true)]
public: __property virtual System.string* get_SkinID();
public: __property virtual void set_SkinID(
   System.string* value
);
C++/CLI
[System.ComponentModel.BrowsableAttribute(true)]
public:
virtual property System.String^ SkinID {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


Style Property

[image]
Intersoft WebTextEditor Documentation
Style Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : Style Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
<WebSysDescriptionAttribute("Low-level access to control styles.")>
Public ReadOnly Property Style As System.Web.UI.CssStyleCollection
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Web.UI.CssStyleCollection

value = instance.Style
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[WebSysDescriptionAttribute("Low-level access to control styles.")]
public System.Web.UI.CssStyleCollection Style {get;}
Delphi
public read-only property Style: System.Web.UI.CssStyleCollection;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
WebSysDescriptionAttribute("Low-level access to control styles.")
public function get Style : System.Web.UI.CssStyleCollection
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[WebSysDescriptionAttribute("Low-level access to control styles.")]
public: __property System.Web.UI.CssStyleCollection* get_Style();
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[WebSysDescriptionAttribute("Low-level access to control styles.")]
public:
property System.Web.UI.CssStyleCollection^ Style {
   System.Web.UI.CssStyleCollection^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


SupportsDisabledAttribute Property

[image]
Intersoft WebTextEditor Documentation
SupportsDisabledAttribute Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : SupportsDisabledAttribute Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
Public Overridable ReadOnly Property SupportsDisabledAttribute As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Boolean

value = instance.SupportsDisabledAttribute
C#
[System.ComponentModel.BrowsableAttribute(false)]
public virtual System.bool SupportsDisabledAttribute {get;}
Delphi
public read-only property SupportsDisabledAttribute: System.Boolean; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
public function get SupportsDisabledAttribute : System.boolean
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
public: __property virtual System.bool get_SupportsDisabledAttribute();
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
public:
virtual property System.bool SupportsDisabledAttribute {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


SupportXMLCultureInfo Property

[image]
Intersoft WebTextEditor Documentation
SupportXMLCultureInfo Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : SupportXMLCultureInfo Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Overridable ReadOnly Property SupportXMLCultureInfo As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Boolean

value = instance.SupportXMLCultureInfo
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public virtual System.bool SupportXMLCultureInfo {get;}
Delphi
public read-only property SupportXMLCultureInfo: System.Boolean; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get SupportXMLCultureInfo : System.boolean
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property virtual System.bool get_SupportXMLCultureInfo();
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
virtual property System.bool SupportXMLCultureInfo {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


TabIndex Property

[image]
Intersoft WebTextEditor Documentation
TabIndex Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : TabIndex Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Overridable Property TabIndex As System.Short
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Short

instance.TabIndex = value

value = instance.TabIndex
C#
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public virtual System.short TabIndex {get; set;}
Delphi
public read-write property TabIndex: System.Int16; virtual;
JScript
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set TabIndex : System.short
Managed Extensions for C++
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property virtual System.short get_TabIndex();
public: __property virtual void set_TabIndex(
   System.short value
);
C++/CLI
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
virtual property System.short TabIndex {
   System.short get();
   void set (    System.short value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


TagKey Property

[image]
Intersoft WebTextEditor Documentation
TagKey Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : TagKey Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
Protected Overridable ReadOnly Property TagKey As System.Web.UI.HtmlTextWriterTag
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Web.UI.HtmlTextWriterTag

value = instance.TagKey
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
protected virtual System.Web.UI.HtmlTextWriterTag TagKey {get;}
Delphi
protected read-only property TagKey: System.Web.UI.HtmlTextWriterTag; virtual;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
protected function get TagKey : System.Web.UI.HtmlTextWriterTag
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
protected: __property virtual System.Web.UI.HtmlTextWriterTag get_TagKey();
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
protected:
virtual property System.Web.UI.HtmlTextWriterTag TagKey {
   System.Web.UI.HtmlTextWriterTag get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


TagName Property

[image]
Intersoft WebTextEditor Documentation
TagName Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : TagName Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Protected Overridable ReadOnly Property TagName As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.String

value = instance.TagName
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
protected virtual System.string TagName {get;}
Delphi
protected read-only property TagName: System.String; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
protected function get TagName : System.String
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
protected: __property virtual System.string* get_TagName();
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
protected:
virtual property System.String^ TagName {
   System.String^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


TemplateControl Property

[image]
Intersoft WebTextEditor Documentation
TemplateControl Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : TemplateControl Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
<WebSysDescriptionAttribute("The TemplateControl that hosts this control.")>
<System.ComponentModel.BindableAttribute(Bindable=False, Direction=BindingDirection.OneWay)>
Public Property TemplateControl As System.Web.UI.TemplateControl
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Web.UI.TemplateControl

instance.TemplateControl = value

value = instance.TemplateControl
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[WebSysDescriptionAttribute("The TemplateControl that hosts this control.")]
[System.ComponentModel.BindableAttribute(Bindable=false, Direction=BindingDirection.OneWay)]
public System.Web.UI.TemplateControl TemplateControl {get; set;}
Delphi
public read-write property TemplateControl: System.Web.UI.TemplateControl;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
WebSysDescriptionAttribute("The TemplateControl that hosts this control.")
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set TemplateControl : System.Web.UI.TemplateControl
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[WebSysDescriptionAttribute("The TemplateControl that hosts this control.")]
[System.ComponentModel.BindableAttribute(Bindable=false, Direction=BindingDirection.OneWay)]
public: __property System.Web.UI.TemplateControl* get_TemplateControl();
public: __property void set_TemplateControl(
   System.Web.UI.TemplateControl* value
);
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
[WebSysDescriptionAttribute("The TemplateControl that hosts this control.")]
[System.ComponentModel.BindableAttribute(Bindable=false, Direction=BindingDirection.OneWay)]
public:
property System.Web.UI.TemplateControl^ TemplateControl {
   System.Web.UI.TemplateControl^ get();
   void set (    System.Web.UI.TemplateControl^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


TemplateSourceDirectory Property

[image]
Intersoft WebTextEditor Documentation
TemplateSourceDirectory Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : TemplateSourceDirectory Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<WebSysDescriptionAttribute("The virtual directory of the Page or UserControl that contains this control.")>
Public Overridable ReadOnly Property TemplateSourceDirectory As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.String

value = instance.TemplateSourceDirectory
C#
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[WebSysDescriptionAttribute("The virtual directory of the Page or UserControl that contains this control.")]
public virtual System.string TemplateSourceDirectory {get;}
Delphi
public read-only property TemplateSourceDirectory: System.String; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
WebSysDescriptionAttribute("The virtual directory of the Page or UserControl that contains this control.")
public function get TemplateSourceDirectory : System.String
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[WebSysDescriptionAttribute("The virtual directory of the Page or UserControl that contains this control.")]
public: __property virtual System.string* get_TemplateSourceDirectory();
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[WebSysDescriptionAttribute("The virtual directory of the Page or UserControl that contains this control.")]
public:
virtual property System.String^ TemplateSourceDirectory {
   System.String^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


ToolTip Property

[image]
Intersoft WebTextEditor Documentation
ToolTip Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : ToolTip Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Behavior")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overridable Property ToolTip As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.String

instance.ToolTip = value

value = instance.ToolTip
C#
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public virtual System.string ToolTip {get; set;}
Delphi
public read-write property ToolTip: System.String; virtual;
JScript
System.ComponentModel.CategoryAttribute("Behavior")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set ToolTip : System.String
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property virtual System.string* get_ToolTip();
public: __property virtual void set_ToolTip(
   System.string* value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Behavior")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
virtual property System.String^ ToolTip {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


TrackViewState Method

[image]
Intersoft WebTextEditor Documentation
TrackViewState Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : TrackViewState Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Sub TrackViewState()
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor

instance.TrackViewState()
C#
protected virtual void TrackViewState()
Delphi
protected procedure TrackViewState(); virtual;
JScript
protected function TrackViewState();
Managed Extensions for C++
protected: virtual void TrackViewState();
C++/CLI
protected:
virtual void TrackViewState();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


UniqueID Property

[image]
Intersoft WebTextEditor Documentation
UniqueID Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : UniqueID Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BrowsableAttribute(False)>
<WebSysDescriptionAttribute("The unique ID of the control within the page.")>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Overridable ReadOnly Property UniqueID As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.String

value = instance.UniqueID
C#
[System.ComponentModel.BrowsableAttribute(false)]
[WebSysDescriptionAttribute("The unique ID of the control within the page.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public virtual System.string UniqueID {get;}
Delphi
public read-only property UniqueID: System.String; virtual;
JScript
System.ComponentModel.BrowsableAttribute()
WebSysDescriptionAttribute("The unique ID of the control within the page.")
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
public function get UniqueID : System.String
Managed Extensions for C++
[System.ComponentModel.BrowsableAttribute(false)]
[WebSysDescriptionAttribute("The unique ID of the control within the page.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public: __property virtual System.string* get_UniqueID();
C++/CLI
[System.ComponentModel.BrowsableAttribute(false)]
[WebSysDescriptionAttribute("The unique ID of the control within the page.")]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public:
virtual property System.String^ UniqueID {
   System.String^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


Unload Event

[image]
Intersoft WebTextEditor Documentation
Unload Event
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : Unload Event

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Fires when the page is unloaded.")>
Public Event Unload As System.EventHandler
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim handler As System.EventHandler

AddHandler instance.Unload, handler
C#
[WebSysDescriptionAttribute("Fires when the page is unloaded.")]
public event System.EventHandler Unload
Delphi
public event Unload: System.EventHandler;
JScript
In JScript, you can handle the events defined by another class, but you cannot define your own.
Managed Extensions for C++
[WebSysDescriptionAttribute("Fires when the page is unloaded.")]
public: __event System.EventHandler* Unload
C++/CLI
[WebSysDescriptionAttribute("Fires when the page is unloaded.")]
public:
event System.EventHandler^ Unload

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


UseDeepCloneForViewStateStorage Method

[image]
Intersoft WebTextEditor Documentation
UseDeepCloneForViewStateStorage Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : UseDeepCloneForViewStateStorage Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function UseDeepCloneForViewStateStorage() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Boolean

value = instance.UseDeepCloneForViewStateStorage()
C#
protected virtual System.bool UseDeepCloneForViewStateStorage()
Delphi
protected function UseDeepCloneForViewStateStorage(): System.Boolean; virtual;
JScript
protected function UseDeepCloneForViewStateStorage() : System.boolean;
Managed Extensions for C++
protected: virtual System.bool UseDeepCloneForViewStateStorage();
C++/CLI
protected:
virtual System.bool UseDeepCloneForViewStateStorage();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


UseMemoryStreamStateType Method

[image]
Intersoft WebTextEditor Documentation
UseMemoryStreamStateType Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : UseMemoryStreamStateType Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function UseMemoryStreamStateType() As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Boolean

value = instance.UseMemoryStreamStateType()
C#
protected virtual System.bool UseMemoryStreamStateType()
Delphi
protected function UseMemoryStreamStateType(): System.Boolean; virtual;
JScript
protected function UseMemoryStreamStateType() : System.boolean;
Managed Extensions for C++
protected: virtual System.bool UseMemoryStreamStateType();
C++/CLI
protected:
virtual System.bool UseMemoryStreamStateType();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


ValidateRequestMode Property

[image]
Intersoft WebTextEditor Documentation
ValidateRequestMode Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : ValidateRequestMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebCategoryAttribute("Behavior")>
<System.ComponentModel.DefaultValueAttribute()>
<WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")>
Public Overridable Property ValidateRequestMode As System.Web.UI.ValidateRequestMode
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Web.UI.ValidateRequestMode

instance.ValidateRequestMode = value

value = instance.ValidateRequestMode
C#
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")]
public virtual System.Web.UI.ValidateRequestMode ValidateRequestMode {get; set;}
Delphi
public read-write property ValidateRequestMode: System.Web.UI.ValidateRequestMode; virtual;
JScript
WebCategoryAttribute("Behavior")
System.ComponentModel.DefaultValueAttribute()
WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")
public function get,set ValidateRequestMode : System.Web.UI.ValidateRequestMode
Managed Extensions for C++
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")]
public: __property virtual System.Web.UI.ValidateRequestMode get_ValidateRequestMode();
public: __property virtual void set_ValidateRequestMode(
   System.Web.UI.ValidateRequestMode value
);
C++/CLI
[WebCategoryAttribute("Behavior")]
[System.ComponentModel.DefaultValueAttribute()]
[WebSysDescriptionAttribute("Determines whether the control validates client input or not. Defaults to inherit from parent.")]
public:
virtual property System.Web.UI.ValidateRequestMode ValidateRequestMode {
   System.Web.UI.ValidateRequestMode get();
   void set (    System.Web.UI.ValidateRequestMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


ViewState Property

[image]
Intersoft WebTextEditor Documentation
ViewState Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : ViewState Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<WebSysDescriptionAttribute("Current viewstate of the control.")>
<System.ComponentModel.BrowsableAttribute(False)>
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Protected Overridable ReadOnly Property ViewState As System.Web.UI.StateBag
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Web.UI.StateBag

value = instance.ViewState
C#
[WebSysDescriptionAttribute("Current viewstate of the control.")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
protected virtual System.Web.UI.StateBag ViewState {get;}
Delphi
protected read-only property ViewState: System.Web.UI.StateBag; virtual;
JScript
WebSysDescriptionAttribute("Current viewstate of the control.")
System.ComponentModel.BrowsableAttribute()
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
protected function get ViewState : System.Web.UI.StateBag
Managed Extensions for C++
[WebSysDescriptionAttribute("Current viewstate of the control.")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
protected: __property virtual System.Web.UI.StateBag* get_ViewState();
C++/CLI
[WebSysDescriptionAttribute("Current viewstate of the control.")]
[System.ComponentModel.BrowsableAttribute(false)]
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
protected:
virtual property System.Web.UI.StateBag^ ViewState {
   System.Web.UI.StateBag^ get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


ViewStateIgnoresCase Property

[image]
Intersoft WebTextEditor Documentation
ViewStateIgnoresCase Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : ViewStateIgnoresCase Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<System.ComponentModel.BrowsableAttribute(False)>
Protected Overridable ReadOnly Property ViewStateIgnoresCase As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Boolean

value = instance.ViewStateIgnoresCase
C#
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
protected virtual System.bool ViewStateIgnoresCase {get;}
Delphi
protected read-only property ViewStateIgnoresCase: System.Boolean; virtual;
JScript
System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)
System.ComponentModel.BrowsableAttribute()
protected function get ViewStateIgnoresCase : System.boolean
Managed Extensions for C++
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
protected: __property virtual System.bool get_ViewStateIgnoresCase();
C++/CLI
[System.ComponentModel.DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[System.ComponentModel.BrowsableAttribute(false)]
protected:
virtual property System.bool ViewStateIgnoresCase {
   System.bool get();
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


ViewStateItems Property

[image]
Intersoft WebTextEditor Documentation
ViewStateItems Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : ViewStateItems Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.CategoryAttribute("View State Settings")>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the items to be stored in view state storage.")>
Public Overridable Property ViewStateItems As ISNet.WebUI.ViewStateItem
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As ISNet.WebUI.ViewStateItem

instance.ViewStateItems = value

value = instance.ViewStateItems
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the items to be stored in view state storage.")]
public virtual ISNet.WebUI.ViewStateItem ViewStateItems {get; set;}
Delphi
public read-write property ViewStateItems: ISNet.WebUI.ViewStateItem; virtual;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.CategoryAttribute("View State Settings")
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DescriptionAttribute("Gets or sets the items to be stored in view state storage.")
public function get,set ViewStateItems : ISNet.WebUI.ViewStateItem
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the items to be stored in view state storage.")]
public: __property virtual ISNet.WebUI.ViewStateItem get_ViewStateItems();
public: __property virtual void set_ViewStateItems(
   ISNet.WebUI.ViewStateItem value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the items to be stored in view state storage.")]
public:
virtual property ISNet.WebUI.ViewStateItem ViewStateItems {
   ISNet.WebUI.ViewStateItem get();
   void set (    ISNet.WebUI.ViewStateItem value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


viewStateLoaded Field

[image]
Intersoft WebTextEditor Documentation
viewStateLoaded Field
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : viewStateLoaded Field

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected viewStateLoaded As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Boolean

value = instance.viewStateLoaded

instance.viewStateLoaded = value
C#
protected System.bool viewStateLoaded
Delphi
protected field viewStateLoaded: System.Boolean;
JScript
protected var viewStateLoaded : System.boolean;
Managed Extensions for C++
protected: System.bool viewStateLoaded
C++/CLI
protected:
System.bool viewStateLoaded

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


ViewStateMode Property

[image]
Intersoft WebTextEditor Documentation
ViewStateMode Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : ViewStateMode Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Web.UI.ThemeableAttribute(False)>
<WebCategoryAttribute("Behavior")>
<WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")>
<System.ComponentModel.DefaultValueAttribute()>
Public Overridable Property ViewStateMode As System.Web.UI.ViewStateMode
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Web.UI.ViewStateMode

instance.ViewStateMode = value

value = instance.ViewStateMode
C#
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")]
[System.ComponentModel.DefaultValueAttribute()]
public virtual System.Web.UI.ViewStateMode ViewStateMode {get; set;}
Delphi
public read-write property ViewStateMode: System.Web.UI.ViewStateMode; virtual;
JScript
System.Web.UI.ThemeableAttribute()
WebCategoryAttribute("Behavior")
WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")
System.ComponentModel.DefaultValueAttribute()
public function get,set ViewStateMode : System.Web.UI.ViewStateMode
Managed Extensions for C++
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")]
[System.ComponentModel.DefaultValueAttribute()]
public: __property virtual System.Web.UI.ViewStateMode get_ViewStateMode();
public: __property virtual void set_ViewStateMode(
   System.Web.UI.ViewStateMode value
);
C++/CLI
[System.Web.UI.ThemeableAttribute(false)]
[WebCategoryAttribute("Behavior")]
[WebSysDescriptionAttribute("Determines whether the control has viewstate enabled or not, defaults to inherit from parent.")]
[System.ComponentModel.DefaultValueAttribute()]
public:
virtual property System.Web.UI.ViewStateMode ViewStateMode {
   System.Web.UI.ViewStateMode get();
   void set (    System.Web.UI.ViewStateMode value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


ViewStateServerConnection Property

[image]
Intersoft WebTextEditor Documentation
ViewStateServerConnection Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : ViewStateServerConnection Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.DescriptionAttribute("Gets or sets the server connection string for file server-based viewstate storage.")>
<System.ComponentModel.CategoryAttribute("View State Settings")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overridable Property ViewStateServerConnection As System.String
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.String

instance.ViewStateServerConnection = value

value = instance.ViewStateServerConnection
C#
[System.ComponentModel.DescriptionAttribute("Gets or sets the server connection string for file server-based viewstate storage.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public virtual System.string ViewStateServerConnection {get; set;}
Delphi
public read-write property ViewStateServerConnection: System.String; virtual;
JScript
System.ComponentModel.DescriptionAttribute("Gets or sets the server connection string for file server-based viewstate storage.")
System.ComponentModel.CategoryAttribute("View State Settings")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set ViewStateServerConnection : System.String
Managed Extensions for C++
[System.ComponentModel.DescriptionAttribute("Gets or sets the server connection string for file server-based viewstate storage.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property virtual System.string* get_ViewStateServerConnection();
public: __property virtual void set_ViewStateServerConnection(
   System.string* value
);
C++/CLI
[System.ComponentModel.DescriptionAttribute("Gets or sets the server connection string for file server-based viewstate storage.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
virtual property System.String^ ViewStateServerConnection {
   System.String^ get();
   void set (    System.String^ value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


ViewStateStorage Property

[image]
Intersoft WebTextEditor Documentation
ViewStateStorage Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : ViewStateStorage Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.NotifyParentPropertyAttribute(True)>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.DescriptionAttribute("Gets or sets the location to store the viewstate of this control.")>
<System.ComponentModel.CategoryAttribute("View State Settings")>
Public Overridable Property ViewStateStorage As ISNet.WebUI.StateCacheStorage
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As ISNet.WebUI.StateCacheStorage

instance.ViewStateStorage = value

value = instance.ViewStateStorage
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the location to store the viewstate of this control.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
public virtual ISNet.WebUI.StateCacheStorage ViewStateStorage {get; set;}
Delphi
public read-write property ViewStateStorage: ISNet.WebUI.StateCacheStorage; virtual;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.NotifyParentPropertyAttribute()
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.DescriptionAttribute("Gets or sets the location to store the viewstate of this control.")
System.ComponentModel.CategoryAttribute("View State Settings")
public function get,set ViewStateStorage : ISNet.WebUI.StateCacheStorage
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the location to store the viewstate of this control.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
public: __property virtual ISNet.WebUI.StateCacheStorage get_ViewStateStorage();
public: __property virtual void set_ViewStateStorage(
   ISNet.WebUI.StateCacheStorage value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.NotifyParentPropertyAttribute(true)]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.DescriptionAttribute("Gets or sets the location to store the viewstate of this control.")]
[System.ComponentModel.CategoryAttribute("View State Settings")]
public:
virtual property ISNet.WebUI.StateCacheStorage ViewStateStorage {
   ISNet.WebUI.StateCacheStorage get();
   void set (    ISNet.WebUI.StateCacheStorage value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


Visible Property

[image]
Intersoft WebTextEditor Documentation
Visible Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : Visible Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
<System.ComponentModel.CategoryAttribute("Behavior")>
Public Overridable Property Visible As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Boolean

instance.Visible = value

value = instance.Visible
C#
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public virtual System.bool Visible {get; set;}
Delphi
public read-write property Visible: System.Boolean; virtual;
JScript
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
System.ComponentModel.CategoryAttribute("Behavior")
public function get,set Visible : System.boolean
Managed Extensions for C++
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public: __property virtual System.bool get_Visible();
public: __property virtual void set_Visible(
   System.bool value
);
C++/CLI
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
[System.ComponentModel.CategoryAttribute("Behavior")]
public:
virtual property System.bool Visible {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


Width Property

[image]
Intersoft WebTextEditor Documentation
Width Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : Width Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.ComponentModel.CategoryAttribute("Layout")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overridable Property Width As System.Web.UI.WebControls.Unit
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Web.UI.WebControls.Unit

instance.Width = value

value = instance.Width
C#
[System.ComponentModel.CategoryAttribute("Layout")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public virtual System.Web.UI.WebControls.Unit Width {get; set;}
Delphi
public read-write property Width: System.Web.UI.WebControls.Unit; virtual;
JScript
System.ComponentModel.CategoryAttribute("Layout")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set Width : System.Web.UI.WebControls.Unit
Managed Extensions for C++
[System.ComponentModel.CategoryAttribute("Layout")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property virtual System.Web.UI.WebControls.Unit get_Width();
public: __property virtual void set_Width(
   System.Web.UI.WebControls.Unit value
);
C++/CLI
[System.ComponentModel.CategoryAttribute("Layout")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
virtual property System.Web.UI.WebControls.Unit Width {
   System.Web.UI.WebControls.Unit get();
   void set (    System.Web.UI.WebControls.Unit value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


XmlCompressionEnabled Property

[image]
Intersoft WebTextEditor Documentation
XmlCompressionEnabled Property
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebTextEditor Class : XmlCompressionEnabled Property

Glossary Item Box

Syntax

Visual Basic (Declaration)
<ISNet.Serialization.XmlSerializableAttribute()>
<System.ComponentModel.DefaultValueAttribute()>
<System.ComponentModel.DescriptionAttribute("Specifies whether the Xml used for clientside state storage should be compressed.")>
<ISNet.Serialization.BinarySerializableAttribute()>
<System.ComponentModel.CategoryAttribute("Behavior")>
<System.ComponentModel.BindableAttribute(Bindable=True, Direction=BindingDirection.OneWay)>
Public Overridable Property XmlCompressionEnabled As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebTextEditor
Dim value As System.Boolean

instance.XmlCompressionEnabled = value

value = instance.XmlCompressionEnabled
C#
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the Xml used for clientside state storage should be compressed.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public virtual System.bool XmlCompressionEnabled {get; set;}
Delphi
public read-write property XmlCompressionEnabled: System.Boolean; virtual;
JScript
ISNet.Serialization.XmlSerializableAttribute()
System.ComponentModel.DefaultValueAttribute()
System.ComponentModel.DescriptionAttribute("Specifies whether the Xml used for clientside state storage should be compressed.")
ISNet.Serialization.BinarySerializableAttribute()
System.ComponentModel.CategoryAttribute("Behavior")
System.ComponentModel.BindableAttribute(Bindable=, Direction=BindingDirection.OneWay)
public function get,set XmlCompressionEnabled : System.boolean
Managed Extensions for C++
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the Xml used for clientside state storage should be compressed.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public: __property virtual System.bool get_XmlCompressionEnabled();
public: __property virtual void set_XmlCompressionEnabled(
   System.bool value
);
C++/CLI
[ISNet.Serialization.XmlSerializableAttribute()]
[System.ComponentModel.DefaultValueAttribute()]
[System.ComponentModel.DescriptionAttribute("Specifies whether the Xml used for clientside state storage should be compressed.")]
[ISNet.Serialization.BinarySerializableAttribute()]
[System.ComponentModel.CategoryAttribute("Behavior")]
[System.ComponentModel.BindableAttribute(Bindable=true, Direction=BindingDirection.OneWay)]
public:
virtual property System.bool XmlCompressionEnabled {
   System.bool get();
   void set (    System.bool value);
}

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebTextEditor Class
WebTextEditor Members


EditComponent(ITypeDescriptorContext,Object) Method

[image]
Intersoft WebTextEditor Documentation
EditComponent(ITypeDescriptorContext,Object) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebUIComponentEditor Class > EditComponent Method : EditComponent(ITypeDescriptorContext,Object) Method

context
component

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Overridable Function EditComponent( _
   ByVal context As System.ComponentModel.ITypeDescriptorContext, _
   ByVal component As System.Object _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebUIComponentEditor
Dim context As System.ComponentModel.ITypeDescriptorContext
Dim component As System.Object
Dim value As System.Boolean

value = instance.EditComponent(context, component)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public virtual System.bool EditComponent(
   System.ComponentModel.ITypeDescriptorContext context,
   System.object component
)
Delphi
public function EditComponent(
    context: System.ComponentModel.ITypeDescriptorContext;
    component: System.TObject
): System.Boolean; virtual;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function EditComponent(
   context : System.ComponentModel.ITypeDescriptorContext,
   component : System.Object
) : System.boolean;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: virtual System.bool EditComponent(
   System.ComponentModel.ITypeDescriptorContext* context,
   System.Object* component
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
virtual System.bool EditComponent(
   System.ComponentModel.ITypeDescriptorContext^ context,
   System.Object^ component
)

Parameters

context
component

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebUIComponentEditor Class
WebUIComponentEditor Members
Overload List


EditComponent(Object) Method

[image]
Intersoft WebTextEditor Documentation
EditComponent(Object) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebUIComponentEditor Class > EditComponent Method : EditComponent(Object) Method

component

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function EditComponent( _
   ByVal component As System.Object _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebUIComponentEditor
Dim component As System.Object
Dim value As System.Boolean

value = instance.EditComponent(component)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.bool EditComponent(
   System.object component
)
Delphi
public function EditComponent(
    component: System.TObject
): System.Boolean;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function EditComponent(
   component : System.Object
) : System.boolean;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.bool EditComponent(
   System.Object* component
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.bool EditComponent(
   System.Object^ component
)

Parameters

component

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebUIComponentEditor Class
WebUIComponentEditor Members
Overload List


EditComponent(Object,IWin32Window) Method

[image]
Intersoft WebTextEditor Documentation
EditComponent(Object,IWin32Window) Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebUIComponentEditor Class > EditComponent Method : EditComponent(Object,IWin32Window) Method

component
owner

Glossary Item Box

Syntax

Visual Basic (Declaration)
<System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")>
Public Overloads Function EditComponent( _
   ByVal component As System.Object, _
   ByVal owner As System.Windows.Forms.IWin32Window _
) As System.Boolean
Visual Basic (Usage) Copy Code
Dim instance As WebUIComponentEditor
Dim component As System.Object
Dim owner As System.Windows.Forms.IWin32Window
Dim value As System.Boolean

value = instance.EditComponent(component, owner)
C#
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public System.bool EditComponent(
   System.object component,
   System.Windows.Forms.IWin32Window owner
)
Delphi
public function EditComponent(
    component: System.TObject;
    owner: System.Windows.Forms.IWin32Window
): System.Boolean;
JScript
System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")
public function EditComponent(
   component : System.Object,
   owner : System.Windows.Forms.IWin32Window
) : System.boolean;
Managed Extensions for C++
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public: System.bool EditComponent(
   System.Object* component,
   System.Windows.Forms.IWin32Window* owner
)
C++/CLI
[System.Runtime.TargetedPatchingOptOutAttribute("Performance critical to inline this type of method across NGen image boundaries")]
public:
System.bool EditComponent(
   System.Object^ component,
   System.Windows.Forms.IWin32Window^ owner
)

Parameters

component
owner

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebUIComponentEditor Class
WebUIComponentEditor Members
Overload List


GetComponentEditorPages Method

[image]
Intersoft WebTextEditor Documentation
GetComponentEditorPages Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebUIComponentEditor Class : GetComponentEditorPages Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetComponentEditorPages() As System.Type()
Visual Basic (Usage) Copy Code
Dim instance As WebUIComponentEditor
Dim value() As System.Type

value = instance.GetComponentEditorPages()
C#
protected virtual System.Type[] GetComponentEditorPages()
Delphi
protected function GetComponentEditorPages(): System.array of Type; virtual;
JScript
protected function GetComponentEditorPages() : System.Type[];
Managed Extensions for C++
protected: virtual System.Type*[]* GetComponentEditorPages();
C++/CLI
protected:
virtual System.array<Type^>^ GetComponentEditorPages();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebUIComponentEditor Class
WebUIComponentEditor Members


GetInitialComponentEditorPageIndex Method

[image]
Intersoft WebTextEditor Documentation
GetInitialComponentEditorPageIndex Method
See Also Send Feedback
ISNet.WebUI.WebTextEditor Namespace > WebUIComponentEditor Class : GetInitialComponentEditorPageIndex Method

Glossary Item Box

Syntax

Visual Basic (Declaration)
Protected Overridable Function GetInitialComponentEditorPageIndex() As System.Integer
Visual Basic (Usage) Copy Code
Dim instance As WebUIComponentEditor
Dim value As System.Integer

value = instance.GetInitialComponentEditorPageIndex()
C#
protected virtual System.int GetInitialComponentEditorPageIndex()
Delphi
protected function GetInitialComponentEditorPageIndex(): System.Integer; virtual;
JScript
protected function GetInitialComponentEditorPageIndex() : System.int;
Managed Extensions for C++
protected: virtual System.int GetInitialComponentEditorPageIndex();
C++/CLI
protected:
virtual System.int GetInitialComponentEditorPageIndex();

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

WebUIComponentEditor Class
WebUIComponentEditor Members


ISNet.WebUI.WebTextEditor Namespace Inheritance Hierarchy

ISNet.WebUI.WebTextEditor Namespace Inheritance Hierarchy
See Also Send Feedback

Glossary Item Box

Inheritance Hierarchy

System.Object
ISNet.WebUI.DataSourceInfo
ISNet.WebUI.WebTextEditor.WebTextEditorDataSourceInfo
ISNet.WebUI.WebTextEditor.Presets
ISNet.WebUI.WebTextEditor.WebFileUploaderFileProcessor
ISNet.WebUI.WebTextEditor.WebFileUploaderHttpHandler
ISNet.WebUI.WebTextEditor.WebFileUploaderHttpModule
ISNet.WebUI.WebTextEditor.WebTextEditor.PostBackAction
ISNet.WebUI.WebUIBaseClass
ISNet.WebUI.ClientEvents
ISNet.WebUI.WebTextEditor.WebFileUploaderClientSideEvents
ISNet.WebUI.NamedObjectBase2
ISNet.WebUI.WebTextEditor.WebSpellCheckerDictionaryData
ISNet.WebUI.WebTextEditor.WebSpellCheckerTextSuggestion
ISNet.WebUI.WebTextEditor.WebTextEditorLabel
ISNet.WebUI.WebTextEditor.WebTextEditorMedia
ISNet.WebUI.WebTextEditor.WebTextEditorMediaResourceGroup
ISNet.WebUI.WebTextEditor.WebTextEditorResource
ISNet.WebUI.WebTextEditor.WebTextEditorToolBar
ISNet.WebUI.WebTextEditor.WebTextEditorToolCommand
ISNet.WebUI.WebTextEditor.WebTextEditorToolItem
ISNet.WebUI.Settings
ISNet.WebUI.WebTextEditor.WebFileUploaderImageSettings
ISNet.WebUI.WebTextEditor.WebFileUploaderStyleSettings
ISNet.WebUI.WebTextEditor.WebFileUploaderTextSettings
ISNet.WebUI.WebTextEditor.WebFileUploaderFileInfo
ISNet.WebUI.WebTextEditor.WebFileUploaderInfo
ISNet.WebUI.WebTextEditor.WebFileUploaderProgressInformation
ISNet.WebUI.WebTextEditor.WebSpellCheckerClientSideEvents
ISNet.WebUI.WebTextEditor.WebSpellCheckerImagesSettings
ISNet.WebUI.WebTextEditor.WebSpellCheckerTextSettings
ISNet.WebUI.WebTextEditor.WebTextEditorClientSideEvents
ISNet.WebUI.WebTextEditor.WebTextEditorCssFile
ISNet.WebUI.WebTextEditor.WebTextEditorEditorSettings
ISNet.WebUI.WebTextEditor.WebTextEditorFileUploaderSettings
ISNet.WebUI.WebTextEditor.WebTextEditorImagesSettings
ISNet.WebUI.WebTextEditor.WebTextEditorMailMergeObject
ISNet.WebUI.WebTextEditor.WebTextEditorMailMergeSettings
ISNet.WebUI.WebTextEditor.WebTextEditorSection
ISNet.WebUI.WebTextEditor.WebTextEditorTaskPaneSettings
ISNet.WebUI.WebTextEditor.WebTextEditorTextSettings
ISNet.WebUI.WebTextEditor.WebTextEditorToolBarSettings
ISNet.WebUI.WebTextEditor.WebTextEditorViewSettings
ISNet.WebUI.WebTextEditor.WebTextEditorWatermarkSettings
System.Collections.Generic.List<T>
ISNet.WebUI.WebTextEditor.SerializableList<T>
System.Collections.ObjectModel.Collection<T>
ISNet.WebUI.ISCollectionBase<T>
ISNet.WebUI.ISGenericCollectionBase<T>
ISNet.WebUI.WebTextEditor.WebSpellCheckerDictionaryDataCollection
ISNet.WebUI.WebTextEditor.WebSpellCheckerTextSuggestionCollection
ISNet.WebUI.WebTextEditor.WebTextEditorLabelCollection
ISNet.WebUI.WebTextEditor.WebTextEditorMediaCollection
ISNet.WebUI.WebTextEditor.WebTextEditorMediaResourceGroupCollection
ISNet.WebUI.WebTextEditor.WebTextEditorResourceCollection
ISNet.WebUI.WebTextEditor.WebTextEditorToolBarCollection
ISNet.WebUI.WebTextEditor.WebTextEditorToolCommandCollection
ISNet.WebUI.WebTextEditor.WebTextEditorToolItemCollection
System.ComponentModel.ComponentEditor
System.Windows.Forms.Design.WindowsFormsComponentEditor
ISNet.WebUI.WebTextEditor.WebUIComponentEditor
System.EventArgs
ISNet.WebUI.WebTextEditor.WebFileUploaderFileEventArgs
ISNet.WebUI.WebTextEditor.WebTextEditorBeforeSendMailArgs
ISNet.WebUI.WebTextEditor.WebTextEditorMailMergeArgs
ISNet.WebUI.WebTextEditor.WebTextEditorMailMergeCompletedArgs
ISNet.WebUI.WebTextEditor.WebTextEditorSaveArgs
ISNet.WebUI.WebTextEditor.WebTextEditorSendMailArgs
ISNet.WebUI.WebTextEditor.WebTextEditorSendMailCompletedArgs
ISNet.WebUI.WebTextEditor.WebTextEditorToolBarArgs
System.MarshalByRefObject
System.ComponentModel.Component
System.Windows.Forms.Control
System.Windows.Forms.ScrollableControl
System.Windows.Forms.ContainerControl
System.Windows.Forms.Form
ISNet.WebUI.WebTextEditor.ImageListForm
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
ISNet.WebUI.ISNetControl
ISNet.WebUI.WebTextEditor.WebFileUploader
ISNet.WebUI.WebTextEditor.WebSpellChecker
ISNet.WebUI.WebTextEditor.WebTextEditor

See Also

Reference

ISNet.WebUI.WebTextEditor Assembly


a
about
after
against
all
along
also
although
am
among
an
and
are
as
at
be
became
because
been
being
between
but
by
can
caution
come
could
details
did
do
does
doing
done
during
each
early
far
finally
for
found
from
had
has
have
he
her
here
his
how
however
I
if
in
include
including
information
into
is
it
its
late
later
made
many
may
me
med
might
more
most
near
no
non
none
nor
not
note
of
off
on
only
or
other
over
saw
see
seen
several
she
since
so
some
such
than
that
the
their
them
then
there
these
they
this
those
through
tip
to
too
under
until
up
us
use
very
warning
was
we
were
when
where
which
while
who
with
you